Welcome

Actipro Universal Windows Controls Reference
Welcome
What are Actipro Universal Windows Controls?

Actipro's Universal Windows controls are a set of professional user interface controls and components for Microsoft's Universal Windows Platform, used to make .NET-based Windows Store applications. The controls support development of all Windows 10 apps.

Actipro Software has been making top-notch Windows Forms controls since .NET was first introduced, and was the very first control vendor to release a commercial WPF control. Today Actipro Software is a leader in the WPF and Silverlight control markets, with numerous product offerings in each. Wherever possible, codebases are shared among Actipro's XAML-based UI platforms, thereby allowing for a high degree of code compatibility between our products on various platforms.

Available Products

These products are currently available for the Universal Windows platform, with more on the way:

Product Name Description Sample UI
Actipro Bar Codes

Actipro Bar Codes is a bar code generation product natively written for Universal Windows.

All the most common bar code symbologies are supported. There are many configurable display options and each bar code is rendered using vector-based drawing so that it scales crisp and clean to any zoom level and on any sort of media.

Actipro Charts

Actipro Charts is a set of charts that are designed to provide rich visualization for complex, quantitative data.

Chart types include area, bar, line, pie, donut, and scatter, as well as stacked area and stacked bar. Visualization features include legends, axis ticks and labels, data point labels, grid lines and stripes, as well as customization, styling, and templating support.

Actipro Docking & MDI

Actipro Docking & MDI is a complete solution for easily adding a docking tool window and/or multiple document interface to your applications.

Docking & MDI has been implemented with flexibility in mind. While it supports all the types of standard layouts you find in most docking window products, it also supports some extended functionality such as: floating document windows, nested dock sites (a self-contained set of docking windows within another docking window), side-by-side dock sites (two or more self-contained sets of docking windows next to each other), tool window inner fill (no workspace area), tabbed and standard MDI styles, custom workspace content, total control over docking window capabilities and appearance, animated transitions, and much more.

Actipro Editors

Actipro Editors provide a number of user input controls for common .NET data types such as dates, times, numbers, colors, enumerations, sizes, and many more.

Each of the controls features unique designs that have been specifically crafted to support input by keyboard, mouse, and touch. The control appearances align with other native controls, allowing them to be dropped right into an app and be instantly approachable by end users.

Actipro Grids

Actipro Grids is a product that includes our PropertyGrid and custom tree structure (TreeListBox and TreeListView) controls.

PropertyGrid allows for all the properties of one or more objects to be displayed, optionally using categories. Pre-defined editors for modifying properties are auto-generated based on property type, and custom property/category editors can be easily created, allowing for total customization of the property editing experience.

PropertyGrid can also optionally harness our advanced data editing controls found in our Editors product (sold separately) when appropriate. Many editing features are driven using standard .NET attributes like BrowsableAttribute, DisplayAttribute, etc. Support for sorting, filtering, collections, read-only display, nested properties, and deep customization are all included.

TreeListBox is a single-column tree control similar to the Visual Studio Solution Explorer tree control. TreeListView is a multi-column variant of TreeListBox that renders similar to a standard ListView but has additional features.

Actipro Micro Charts

Actipro Micro Charts is a set of charts that visualize quantitative data and are designed to render clearly in compact spaces.

Many chart types are supported, from basic line and bar charts to stacked area charts. The chart control includes numerous useful features such as multiple series, stacking, hot tracking, customizable palettes, and data aggregation. Common usage scenarios for micro charts are within dashboards, reports, and grids.

Actipro SyntaxEditor

SyntaxEditor is a powerful text editing control that is packed with features for efficient code editing, including syntax highlighting, line numbers, block selection, IntelliPrompt UI, code outlining, parsing, zooming, and much more. It has many of the same code editing features found in the Visual Studio code editor.

SyntaxEditor is built on top of our next-generation extensible text/parsing framework. While over free 20 sample languages are available to get you started (such as C#, VB, XML, and more), custom language definitions can be developed and distributed with your applications as well. SyntaxEditor is designed for use in IDE (integrated development environment) applications, however there are many other applications out there than can take advantage of such a control.

These free add-ons are included with SyntaxEditor:

  • LL(*) Parser Framework - Easily build advanced parsers using EBNF-like notation

These optional premium add-ons for advanced syntax language implementations are shipped and demoed with the Universal Windows controls, but are sold separately:

  • .NET Languages Add-on - Advanced C# and Visual Basic
  • Python Language Add-on - Advanced Python
  • Web Languages Add-on - Advanced XML, JavaScript, and JSON

Note Note
At the current time, the Windows Phone app version of SyntaxEditor only supports code viewing. On the other hand, the Windows app version support full-featured editing.

Actipro Views

Actipro Views includes a TaskBoard control that makes it easy to add interactive task scheduling and prioritization to your apps.

Actipro Shared Library

The Actipro Silverlight Shared Library is a common control library referenced by all of our Universal Windows controls.

It contains a number of very useful controls and components that can be used in your projects, such as radial sliders, panels, value converters, and more.

Universal Windows Studio Licensing

A license of Actipro Universal Windows Studio suite enables you to use all of Actipro's Universal Windows control products (excludes premium SyntaxEditor add-ons), along with any new control products or features that are implemented in the future during your license subscription period.

Commitment to XAML-Based Frameworks

Actipro firmly believes that XAML-based frameworks such as Universal Windows and WPF are the best way to develop Microsoft-oriented applications, and is committed to expanding its XAML-based framework product offerings going forward.

What is the Sample Browser?

The Sample Browser is the main sample project that ships with the Universal Windows Controls.

It is an application with full source code that is designed to provide information, demos, and QuickStarts for all of the Universal Windows control products. This source code is invaluable for learning how to use the various Universal Windows control products.

The Sample Browser project can be opened with Visual Studio or Expression Blend.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Why Choose Actipro Products?

Actipro Universal Windows Controls Reference
Why Choose Actipro Products?
Experience

Actipro Software has been developing Windows Forms components since .NET was first released, and has been working on commercial WPF control development since WPF was first introduced in 2006. Actipro began development of Silverlight controls in 2009 and WinRT XAML controls in 2012, followed by Universal Windows controls in 2015.

Our object models are very refined and easy to work with.

Documentation, Samples, and Designer Support

We realize that creating a good product is only half the battle in product development. The other half is providing thorough product documentation, samples, and having rich design-time functionality to aid in development efficiency.

We've spent a lot of time creating extensive documentation along with numerous product demos and QuickStarts so that you can get up and running with our products in minutes.

All our products also have designer interaction support when used in Visual Studio or Expression Blend.

Attention to Detail

Unlike most software vendors who slap together products just to get them out the door making money, we prefer to distinguish ourselves by taking a different approach to software development.

At Actipro, we pay attention to the minute details. We add that extra polish to our products that really makes the difference to developers and end users alike.

Quality, Not Quantity

Sure, other competitor companies may offer a couple more controls than we do, but rest assured that our products are well thought out and have enormous feature sets that you won't find anywhere else.

Interesting Fact Interesting Fact
We run our control product source code through Visual Studio's Code Analyzer and resolve all warnings it generates. This ensures that our code is well-designed and meets all appropriate .NET standards.

Customer Satisfaction

Every day we strive to please our customers. Are you used to waiting a week for a response from other vendors? Not at Actipro. We always try to reply to customers within one business day, and are frequently told we provide top-notch support to our customers.

Interesting Fact Interesting Fact
Organizations across the globe from over 80 countries own Actipro products

Save Time and Money

Simply stated, we've put hundreds of hours into the design and development of our products so that you don't have to. Why spend weeks developing in-house custom user interface controls when ours are already mature and can be purchased for the cost of several hours of development time?

You Speak, We Listen

We love to hear your feedback and often drive our products' designs based on the needs of our customers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Recent Documentation Updates

Actipro Universal Windows Controls Reference
Recent Documentation Updates

The product documentation has frequent updates so this topic is the best place to get caught up on recent major new documentation updates.

If you are looking for a list of recently-added major new features to our Universal Windows control products, please see the Sample Browser's 'Release History' page instead.

This topic contains these sections:

  • Updates for v17.1.0310
  • Updates for v16.1.0306
  • Updates for v16.1.0305
  • Updates for v16.1.0304
  • Updates for v16.1.0303
  • Updates for v15.1.0164
  • Updates for v15.1.0163
  • Updates for v15.1.0162
  • Updates for v15.1.0161
  • Updates for v15.1.0160
  • Updates for v14.2.0152
  • Updates for v14.2.0151
  • Updates for v14.2.0150
  • Updates for v14.1.0142
  • Updates for v14.1.0140
  • Updates for v13.2.0131
  • Updates for v13.2.0130
  • Updates for v13.1.0122
  • Updates for v13.1.0120
  • Updates for v12.2.0100

Updates for v17.1.0310

  • Editors: Added multiple topics with information on new controls: BrushEditBox, BrushPicker, Calculator, GradientStopSlider, Int16EditBox, Int16Picker, Int64EditBox, Int64Picker, MaskedTextBox, SingleEditBox, SinglePicker, Rating, TimeSpanEditBox, and TimeSpanPicker.
  • Editors: Updated the MonthCalendar topic with information on many new features.
  • Grids: Added Grids product documentation for the new property grid control and tree controls.

Updates for v16.1.0306

  • Docking: Updated the Docking Window Capabilities topic with information on a new event for limiting the dock guides that are displayed when docking windows are dragged over a new drop target.
  • Editors: Added the Calculator topic with information on the new calculator control.
  • Editors: Added multiple Edit Boxes topics with information on the new edit box controls.
  • Editors: Added multiple Pickers topics with information on the new picker controls.
  • Editors: Updated the Edit Box Basics topic with information on the new spin wrapping feature.
  • Editors: Updated the DoubleEditBox topic with information on the new properties that allow NaN and infinity values to be entered.
  • Grids (work-in-progress): Added the Filtering topic with information on the new data filtering features.

Updates for v16.1.0305

  • Docking: Updated the Floating Dock Hosts topic with information on a new property for preventing tool windows from being dragged to floating dock hosts that contain a workspace.
  • Grids (work-in-progress): Added the Grids topics, which cover the new TreeListBox and TreeListView controls that are in development and ready for alpha testing.
  • SyntaxEditor: Updated the Text Changes and Operations topic with information on the new feature that allows a programmatically-created text change to be merged into the previous text change on the undo stack.
  • SyntaxEditor: Updated the JSON Text Formatter topic with information on the new JSON text formatter service that beautifies the text data.

Updates for v16.1.0304

  • Shared Library: Added the Progress Spinners topic with information on the new RingSpinner control.

Updates for v16.1.0303

  • Docking: Added the Docking & MDI set of topics for the new product.
  • SyntaxEditor: Updated the SyntaxEditor Image Source Providers topic with information on the new image sets that are included with SyntaxEditor and how to choose between them.

Updates for v15.1.0164

  • SyntaxEditor: Updated the SyntaxEditor Line Commenters topic with information on new features that allow for enhanced comment locating when uncommenting.

Updates for v15.1.0163

  • SyntaxEditor: Updated the Python Language Add-on's Automated IntelliPrompt topic with information on a new option to show the entire docstring instead of just the summary line.

Updates for v15.1.0162

  • Editors: Updated the Edit Box Basics topic with information on input scope hints.

Updates for v15.1.0161

  • Editors: Updated the various edit box and picker topics with information on the new small and large change properties.
  • Shared Library: Updated the Value Converters topic with information on the new CornerRadiusConverter value converter.

Updates for v15.1.0160

  • Bar Codes: Added the Bar Codes section with information on the new bar code control.
  • Editors: Updated the Edit Box Basics topic with information on the new non-editable mode.
  • SyntaxEditor: Added the Resolver topic with information on new Python resolver features.
  • SyntaxEditor: Updated the EditorSearchView topic with information on the new Find All button option.
  • SyntaxEditor: Updated the Selection and Block Selection topic with information on the new property that can disable touch-based selection grippers.
  • Views: Added the TaskBoard topic with information on the new task board control.
  • Shared Library: Updated the Shapes topic with information on the new shapes and properties.

Updates for v14.2.0152

  • SyntaxEditor: Updated the Tags and Classification Types topic with information on the new read-only region tag features.
  • SyntaxEditor: Updated the Default Key Bindings topic with information on the newly added commands for moving selected lines.
  • Shared Library: Updated the Shapes topic with information on the new shapes.

Updates for v14.2.0151

  • Micro Charts: Added the Trend Indicator topic with information on the new control.
  • SyntaxEditor: Updated the Delimiter Auto-Completion with information on quote completion.
  • Shared Library: Added the Shapes topic with information on the new shapes.

Updates for v14.2.0150

  • All: All controls ported to support both Windows 8.1 and Windows Phone 8.1 via separate extension SDKs.
  • Editors: Added the Editors set of topics for the new product.
  • Micro Charts: Added the Segment topic with information on the new segment chart control.
  • SyntaxEditor: Added the Python Language Add-on set of topics for the new add-on.
  • Shared Library: Added the TransitioningContentPresenter topic with information on the new content transition control.
  • Shared Library: Updated the Value Converters topic with information on the new parallax and boolean not converters.

Updates for v14.1.0142

  • Charts: Updated the Axes topic with information on the new tick auto-calculation features.
  • SyntaxEditor: Updated the Navigable Symbol Provider topic with information on how to sort and return symbols via the newer object model.
  • SyntaxEditor: Updated the XML Language IntelliPrompt topic in the Web Languages Add-on documentation with information on the new navigable symbol provider service.
  • SyntaxEditor: Updated the Indent Providers topic with information on how to use the new close delimiter indent level feature.
  • Shared Library: Added the HorizontalListBox topic with information on the new control.
  • Shared Library: Added the UniformGrid topic with information on the new control.
  • Shared Library: Updated the Value Converters topic with information on the new thickness converter.

Updates for v14.1.0140

  • SyntaxEditor: Updated the Indicators topic with information on the new bookmark enabled/disabled state features.
  • SyntaxEditor: Added the Lipsum Generator topic with information on the new 'Lorem Ipsum' placeholder text generator utility class.
  • SyntaxEditor: Updated the View Lines topic with information on how to enable editor resizing based on view line text content.
  • SyntaxEditor: Added the JSON Language topic with information on the new JSON language.
  • SyntaxEditor: Added the IntelliPrompt topic with information on the new JavaScript completion provider features.
  • SyntaxEditor: Updated the Indent Providers topic with information on the new square brace indentation features in the DelimiterIndentProvider class.
  • Shared Library: Added the AppBarHint topics with information on the new control.

Updates for v13.2.0131

  • Charts: Updated the Data Point Labels topic with information on the new label positioning options.
  • SyntaxEditor: Added the Incremental Search topic with information on the new incremental search features.
  • SyntaxEditor: Added the Custom Cursors topic that discusses how to register custom mouse cursors that can be used when over margins and when in incremental search mode.
  • SyntaxEditor: Added the Search Result Highlighting topic with information on the new search result highlighting features.

Updates for v13.2.0130

  • Charts: Added topics on the new PieChart control and its features.
  • Charts: Updated the Axes topic with information on the new percentage axis feature.
  • Charts: Updated the Data Point Labels topic with information on the new SeriesBase.LabelFunc property.
  • SyntaxEditor: First product release.
  • Shared Library: Added the RadialSlider and RingSlice topics with information on the new controls.

Updates for v13.1.0122

  • Charts: Updated the Axes topic with information on the new grouped axis feature.

Updates for v13.1.0120

  • Charts: Added documentation topics for the new Charts product.

Updates for v12.2.0100

  • All: First product release.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Bar Codes Reference
Overview

Actipro Bar Codes is a bar code generation product natively written for Universal Windows. Use bar codes in your organization to more efficiently input data.

Two BarCode control instances, each with a different symbology

This product is useful for adding bar codes to any Universal Windows application or report. Bar codes can be included anywhere in your visual tree or saved to a bitmap.

Actipro Bar Codes takes all the work out of the bar code generation process, by allowing you to simply say what value to encode. It will automatically calculate any appropriate checksums and will generate the bar code for you. The output is completely customizable with many options, everything from setting the bar height to display of the encoded value below the bar lines.

The most common symbologies are all supported, including EAN-13, EAN-8, UPC-A, UPC-E, Code 39 (and full ASCII variant), Code 93 (and full ASCII variant), Code 128, Codabar, and Interleaved 2 of 5. In addition, the 2D QR Code symbology is supported.

What About Bar Code Fonts?

Out of the box, the only way to generate bar codes in Universal Windows was to use bar code fonts (a.k.a. fontware). However bar code fonts have a lot of limitations. When you compare them to Actipro Bar Codes, you'll find that Actipro Bar Codes provides the best solution for bar code generation in Universal Windows.

Please see our Why Not Bar Code Fonts? topic for more information.

Features

Symbology Implementations

  • 2D symbology implementations:
    1. QR Code
      • With automatic detection of best version, encoding, and mask based on value
  • Linear symbology implementations:
    1. Codabar
      • Optional display of start/stop characters
    2. Code 128
      • Auto-generation and insertion of a checksum
    3. Code 39
      • Optional display of start/stop characters
      • Optional auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    4. Code 39 Extended (full ASCII)
      • Optional display of start/stop characters
      • Optional auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    5. Code 93
      • Optional display of start/stop characters
      • Auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    6. Code 93 Extended (full ASCII)
      • Optional display of start/stop characters
      • Auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    7. EAN-8
      • Auto-generation and insertion of a checksum
    8. EAN-13
      • Auto-generation and insertion of a checksum
    9. Interleaved 2 of 5
      • Optional auto-generation and insertion of a checksum
      • Alter the width ratio of narrow to wide bars.
    10. UPC-A
      • Auto-generation and insertion of a checksum
    11. UPC-E

BarCode Control Features

  • Implemeted as a Control that can be used in any context.
  • Add borders around the bar code and adjust their corner radius.
  • Add a caption above the bar code.
  • Easily switch between symbologies.
  • Provides a lot of features that you can't get using bar code fonts (a.k.a. fontware).
    • See our Why Not Bar Code Fonts? document for more information.

Symbology Features

  • Set the fore and background colors of the bar code output.
  • Set the bar height of linear bar codes.
  • Set the cell size of 2D codes.
  • Set the minimum bar height/width ratio so that long bar codes are tall enough to be read properly.
  • Specify the thickness of the quiet zone surrounding the bar code.
  • Use multiple value display styles for linear bar codes including:
    • None - The value is not displayed.
    • Centered - The value is centered horizontally.
    • LeftAligned - The value is left-aligned.
    • RightAligned - The value is right-aligned.
    • CharactersAlignedWithBars - The characters in the value are centered under the bars that represent each character.
    • QuietZoneExtension - The first and last characters are drawn in the lead/tail quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as UPC-A.
    • QuietZoneExtensionLeft - The first character is drawn in the lead quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as EIN-13.
  • Scale to any size using a built-in zoom level property.
  • Specify how far (if at all) the displayed value "intrudes" into the bar lines (used in bar codes like UPC-A).
  • Validate bar code values programmatically.

Additional Symbology Implemetations

Do you require implementation of another symbology not listed? Just write us, our bar code framework was designed from the ground up to be extensible so that nearly any symbology can be added without too much work.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Why Not Bar Code Fonts?

Bar Codes Reference
Why Not Bar Code Fonts?
Top 10 Reasons To Use Actipro Bar Codes Instead of a Bar Code Font

  1. Bar code fonts (a.k.a. fontware) usually require licensing - While you may be able to scour the web to find a royalty-free implementation of a bar code font for a simple bar code symbology such as Code 39, most font creators charge licensing fees even in excess of $100 for the use of a single bar code font. Beware because even some free bar code fonts don't permit distribution with an application. With Actipro Bar Codes, you get a large number of bar code symbology implementations at a low price and royalty-free distribution.
  2. Bar code fonts require special distribution of font file(s) - Any font files must be embedded as a resource in your application and special syntax must be used to access the font.
  3. Actipro Bar Codes can render the character value under the bar code lines, bar code fonts can't - Bar code fonts are incapable of rendering the represented value below the bar code. Actipro Bar Codes can do this and even provides a number of display style options for the displayed value, including the ability to have the value's characters intrude into the bars such as in UPC-A.
  4. Actipro Bar Codes can alter the height of the bar code lines, bar code fonts can't - Bar code fonts only support a fixed height of lines, whereas Actipro Bar Codes allows you via a property setting to exactly specify a desired line height.
  5. Actipro Bar Codes auto-computes checksums, bar code fonts can't - A font can't do math. A major benefit of using Actipro Bar Codes is that each symbology automatically computes any appropriate checksum values for you so there is no math that needs to be done manually by you.
  6. Actipro Bar Codes supports bar width ratios, bar code fonts don't - In some symbologies such as Code 39, you are permitted to have dark lines be anywhere from two to three times as wide as narrow lines. Actipro Bar Codes provides an option for controlling this. Bar code fonts are always fixed bar widths.
  7. Actipro Bar Codes is written in Universal Windows, for Universal Windows developers - Actipro Bar Codes is written in 100% C# and is designed for use with any Universal Windows application. All Actipro Bar Codes drawing is done in vectors, so it cleanly scales to any size and always looks crisp on your printouts.
  8. Actipro Bar Codes supports borders and a caption - Actipro Bar Codes can support the rendering of a border around the bar code (with total control over the roundness of the corners), along with an optional caption that is rendered above the bar code. You can't do this with bar code fonts.
  9. Actipro Bar Codes supports WPF scaling and rotation - Bar codes produced by Actipro Bar Codes can be resized or rotated however you like via the use of render transforms and the zoom level property. You could even use a Viewbox to have the bar code auto scale to fit a certain area.
  10. Actipro Bar Codes can render to a bitmap - In several lines of code, render any bar code onto a bitmap.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Bar Codes Reference
Getting Started

We've engineered the bar codes to be extremely easy to use.

This topic contains these sections:

  • Add Extension SDK Reference
  • Add the BarCode Control
  • Assign a Symbology
  • Further Study

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Add the BarCode Control

Then find the parent element that will contain the bar code. This could be a UserControl or any other type of control.

Next, add a BarCode control to the desired parent element. In this sample we will add the BarCode to a UserControl:

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:barcodes="using:ActiproSoftware.UI.Xaml.Controls.BarCodes"
    >
    <barcodes:BarCode>
    </barcodes:BarCode>
</UserControl>

Assign a Symbology

Now we need to set the type of symbology that we wish to use. In this sample we will use Code 39 Extended, which is one of the most common types of bar codes and supports all lower ASCII characters.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:barcodes="using:ActiproSoftware.UI.Xaml.Controls.BarCodes"
    >
    <barcodes:BarCode>
        <barcodes:Code39ExtendedSymbology Value="123456" BarHeight="25" />
    </barcodes:BarCode>
</UserControl>

Note that we have also set a couple options like the BarCodeSymbology.Value of the symbology (the value that is encoded) and the height of the bars (via LinearBarCodeSymbology.BarHeight).

That's all we need to do! You can optionally configure many other settings for the bar code and/or its symbology. See the other topics in this documentation to see which features are available.

Further Study

It's very easy to use Bar Code and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of Bar Code.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BarCode Basics

Bar Codes Reference
BarCode Basics

The BarCode control itself has several options like borders and a caption that can be used to wrap its symbology presentation.

This topic contains these sections:

  • Border Around the Bar Code
  • Caption Above the Bar Code
  • Setting a Symbology
  • Setting the Value to Encode
  • Rotating or Scaling the Bar Code
  • Changing Symbology Options

Border Around the Bar Code

The BarCode inherits Control and therefore has several border-related properties such as BorderBrush and BorderThickness. Set those properties to add a border around the bar code.

We also have added a CornerRadius property that can be used to round off one or more of the corners. It accepts a standard CornerRadius.

Caption Above the Bar Code

Normally the bar code's value is displayed below the bar code. You can also display content above the bar code.

For instance, perhaps you wish to show some text indicating what the bar code is for.

The Caption property can be set to add a caption. The property accepts any object so you can use text or another UIElement and it will be centered above the bar code, but within the bar code's outer border, if any.

Setting a Symbology

Each bar code symbology is implemented in a separate .NET type. For instance, Code 39 is implemented by the Code39Symbology class.

Set the symbology that you would like to use for your bar code to the BarCode.Symbology property.

See the Symbologies topic for a list of the available symbologies.

Setting the Value to Encode

You set the value to encode directly on the BarCodeSymbology class instance that you assign to the BarCode. This is done via the Value property.

Rotating or Scaling the Bar Code

Since BarCode is a Control, you can apply RotateTransform and ScaleTransform objects to its RenderTransform properties. The BarCodeSymbology.ZoomLevel property can also be set to the scale (e.g. 2.0) at which you'd like the bar code to render.

Changing Symbology Options

Each symbology has its own options. Although many share some common options such as BarHeight or ValueDisplayStyle, others like Code39Symbology have extended options such as AreStartStopCharactersVisible and IsChecksumEnabled.

See the documentation for each symbology to learn what options are available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Bar Codes Symbologies
Overview

Actipro Bar Codes includes a number of built-in common symbology implementations.

Name Description
QR Code

QR Code is a 2D symbology, originally used in automotive manufacturing, that is now used worldwide for a wide variety of purposes.

It is readable by most mobile devices with cameras and can be used to display text to a user, add a vCard contact to the user's device, open a URL, or compose a text message or e-mail.

EAN-13

EAN-13 is a linear symbology, based on the original 12-digit Universal Product Code (UPC) system developed in North America.

EAN-8

EAN-8 is a linear symbology, used on smaller retail packages where EAN-13 bar codes don't fit.

UPC-A

UPC-A is a linear symbology, widely used in the United States and Canada for tracking trade items in stores.

UPC-E

UPC-E is a linear symbology, used on smaller retail packages where UPC-A bar codes don't fit.

Code 39

Code 39 is a linear symbology, and is one of the first alphanumeric bar codes.

Code 39 Extended

Code 39 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 39.

Code 93

Code 93 is a linear symbology, designed in 1982 by Intermec to provide a higher density and data security enhancement to Code 39.

Code 93 Extended

Code 93 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 93.

Code 128

Code 128 is a high-density barcode symbology, used extensively worldwide in shipping and packaging industries.

Codabar

Codabar is a linear symbology, developed in 1972 by Pitney Bowes, Inc.

Interleaved 2 of 5

Interleaved 2 of 5 is a linear symbology, that provides higher density than the Industrial 2 of 5 symbology that it is based on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


QR Code

Bar Codes Symbologies
QR Code

QR Code is a 2D symbology, originally used in automotive manufacturing, that is now used worldwide for a wide variety of purposes.

It is readable by most mobile devices with cameras and can be used to display text to a user, add a vCard contact to the user's device, open a URL, or compose a text message or e-mail.

A sample of this symbology

This symbology can encode up to 7,089 numeric characters, 4,296 alpha numeric characters, or 2,953 bytes. Encoding modes are automatically switched when it is most efficient to do so. This symbology implementation also auto-calculates the QR Code symbol version and inserts error correction codewords.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML
  • Trademark

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | QrCodeSymbology
Base Class | Grid2DBarCodeSymbology
Encodable Characters | Number characters, alphanumeric characters, and bytes.
Supports Error Correction | Yes. The implementation will auto-calculate and insert error correction data.
Fixed Length Requirements | No. The maximum length of the value varies depending on the type of data being encoded, the symbol version selected, and the error correction level selected.

Important Members

This symbology has these important members:

Member | Description
AllowLowercase Property | Gets or sets a value indicating whether lowercase characters are allowed. The QR code specification does not allow lowercase characters when using the alphanumeric encoding mode. Therefore, when allowing lowercase characters the binary encoding mode must be used.
Background Property | Gets or sets the Brush to use for rendering the background.
CellSize Property | Gets or sets the size in pixels of each cell.
DisplayName Property | Gets the display name of the symbology.
EncodingMode Property | Gets the mode in which the value will be encoded. The default value is null, which indicates the encoding mode will be auto-selected based on the specified value.
ErrorCorrectionLevel Property | Gets the level of error correction that will be added to the encoded data. The higher the error correction level is, the lower the quantity of data that can be encoded is.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MaskIndex Property | Gets or sets the QR mask applied to the code. The default value is null, which indicates the mask will be auto-selected based on the specified value.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
QuietZoneThickness Property | Gets the thickness of the margin on each side of the rendered symbol.
Version Property | Gets the symbol version that should be rendered. The default value is null, which indicates the version will be auto-selected based on the specified value.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:QrCodeSymbology Value="0123456789" />
</barcodes:BarCode>

Trademark

QR Code is registered trademark of DENSO WAVE INCORPORATED. The trademark only applies to the word "QR Code", and not for any QR Code pattern (image).

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EAN-13

Bar Codes Symbologies
EAN-13

EAN-13 is a linear symbology, based on the original 12-digit Universal Product Code (UPC) system developed in North America.

EAN-13 bar codes are used worldwide for marking retail goods.

A sample of this symbology

The 13 character value is divided into four parts: system code, manufacturer code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Ean13Symbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 12 characters with a 13th character, the check digit, automatically calculated and added by the symbology.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Ean13Symbology Value="003600029145" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EAN-8

Bar Codes Symbologies
EAN-8

EAN-8 is a linear symbology, used on smaller retail packages where EAN-13 bar codes don't fit.

A sample of this symbology

The 8 character value is divided into three parts: system code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Ean8Symbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 7 characters with a 8th character, the check digit, automatically calculated and added by the symbology.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Ean8Symbology Value="5512345" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UPC-A

Bar Codes Symbologies
UPC-A

UPC-A is a linear symbology, widely used in the United States and Canada for tracking trade items in stores.

This symbology is also known as Universal Product Code version A.

A sample of this symbology

The 13 character value is divided into four parts: system code, manufacturer code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | UpcASymbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 11 characters with a 12th character, the check digit, automatically calculated and added by the symbology.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:UpcASymbology Value="03600029145" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UPC-E

Bar Codes Symbologies
UPC-E

UPC-E is a linear symbology, used on smaller retail packages where UPC-A bar codes don't fit.

This symbology is also known as Universal Product Code version E.

A sample of this symbology

The 8 character value is divided into three parts: system code, product code, and check digit.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | UpcESymbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number characters.
Supports Checksum | No. This symbology uses a check digit, but it is not currently calculated automatically.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | The value must be 8 characters, including the developer-calculated check digit.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:UpcESymbology Value="04252614" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 39

Bar Codes Symbologies
Code 39

Code 39 is a linear symbology, and is one of the first alphanumeric bar codes.

Each character encoded is made up of 5 bars and 4 spaces for a total of 9 elements. 3 out of the 9 element are always wide. Although it is not as dense of a symbology such as Code 128, it is one of the most widely supported symbologies by devices.

A sample of this symbology

An extended implementation of Code 39 is available in Code 39 Extended. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 39 concepts.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code39Symbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number, uppercase letter, and -$% ./+ characters.
Supports Checksum | Yes. While this symbology is self-checking, the implementation can optionally auto-calculate and insert a check character. This is referred to as Code 39 mod 43.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
IsChecksumEnabled Property | Gets or sets whether the optional checksum should be added.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Code39Symbology Value="ABC-123" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 39 Extended

Bar Codes Symbologies
Code 39 Extended

Code 39 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 39.

This symbology is also known as Code 39 Full ASCII.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code39ExtendedSymbology
Base Class | Code39Symbology
Encodable Characters | All lower 128 ASCII characters.
Supports Checksum | Yes. While this symbology is self-checking, the implementation can optionally auto-calculate and insert a check character. This is referred to as Code 39 mod 43.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
IsChecksumEnabled Property | Gets or sets whether the optional checksum should be added.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Code39ExtendedSymbology Value="abc-123" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 93

Bar Codes Symbologies
Code 93

Code 93 is a linear symbology, designed in 1982 by Intermec to provide a higher density and data security enhancement to Code 39.

Each Code 93 character is divided into nine modules and always has three bars and three spaces. This symbology is primarily used by the Canadian postal office.

A sample of this symbology

An extended implementation of Code 93 is available in Code 93 Extended. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 93 concepts.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code93Symbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number, uppercase letter, and -$% ./+ characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts two check characters.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Code93Symbology Value="ABC-123" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 93 Extended

Bar Codes Symbologies
Code 93 Extended

Code 93 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 93.

This symbology is also known as Code 93 Full ASCII.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code93ExtendedSymbology
Base Class | Code93Symbology
Encodable Characters | All lower 128 ASCII characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts two check characters.
Has Special Start/Stop Characters | Yes. Must start and stop with * characters, but these are automatically appended for you.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Code93ExtendedSymbology Value="abc-123" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code 128

Bar Codes Symbologies
Code 128

Code 128 is a high-density barcode symbology, used extensively worldwide in shipping and packaging industries.

It is especially efficient when encoding sequential numbers since they are merged into a single output character width.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Code128Symbology
Base Class | LinearBarCodeSymbology
Encodable Characters | All lower 128 ASCII characters.
Supports Checksum | Yes. This symbology implementation auto-calculates and inserts a check character.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Code128Symbology Value="ABC-123" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Codabar

Bar Codes Symbologies
Codabar

Codabar is a linear symbology, developed in 1972 by Pitney Bowes, Inc.

It is most commonly used by libraries, blood banks, and on FedEx airbills.

A sample of this symbology

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | CodabarSymbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number and -$:/.+ characters, along with 4 start/stop characters.
Supports Checksum | No. This symbology is self-checking, so no checksum or check digit is required.
Has Special Start/Stop Characters | Yes. Each encoded value must start and stop with A, B, C, or D.
Fixed Length Requirements | No. The symbology value may be any number of characters.

Important Members

This symbology has these important members:

Member | Description
AreStartStopCharactersVisible Property | Gets or sets whether the start/stop characters are visible in the displayed value.
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:CodabarSymbology Value="A12345678A" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Interleaved 2 of 5

Bar Codes Symbologies
Interleaved 2 of 5

Interleaved 2 of 5 is a linear symbology, that provides higher density than the Industrial 2 of 5 symbology that it is based on.

It is most commonly used by the distribution and warehouse industry.

A sample of this symbology

This symbology can encode numeric digits, and requires that an even number of digits (including the optional check digit) are encoded. This symbology implementation will automatically add a 0 at the start of the encoded value to ensure that an even number of digits are encoded.

This topic contains these sections:

  • Symbology Characteristics
  • Important Members
  • Sample XAML

Symbology Characteristics

The following table gives an overview of the characteristics of the symbology.

Item | Details
Implementation Class | Interleaved2of5Symbology
Base Class | LinearBarCodeSymbology
Encodable Characters | Number characters.
Supports Checksum | Yes. The implementation can optionally auto-calculate and insert a check digit.
Has Special Start/Stop Characters | No.
Fixed Length Requirements | No. The symbology value may be any number of characters. A 0 is added at the start of the encoded value if the supplied value is an odd number of characters.

Important Members

This symbology has these important members:

Member | Description
Background Property | Gets or sets the Brush to use for rendering the background.
BarHeight Property | Gets or sets the desired height of the bars.
BarWidthRatio Property | Gets or sets the width ratio of wide lines to narrow lines.
DisplayName Property | Gets the display name of the symbology.
DisplayValue Property | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Foreground Property | Gets or sets the Brush to use for rendering the foreground.
IsChecksumEnabled Property | Gets or sets whether the optional checksum should be added.
MeasureDesiredSize Method | Measures the desired size of the symbology, based on the specified available size.
MinBarHeightWidthRatio Property | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
QuietZoneThickness Property | Gets or sets the Thickness of the quiet zone.
Render Method | Renders the symbology to the specified DrawingContext.
ValidateValue Method | Validates that the symbology can parse the specified value.
Value Property | Gets or sets the value to encode in the bar code.
ValueDisplayStyle Property | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
ValueIntrusionOffset Property | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
ZoomLevel Property | Gets or sets the zoom level of the rendered bar code. The default value is 1.0. It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.

Sample XAML

This sample XAML code shows how to create a BarCode using this symbology.

XAML
Copy
​<barcodes:BarCode>
    <barcodes:Interleaved2of5Symbology Value="0123456789" />
</barcodes:BarCode>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Bar Codes Advanced Features
Overview

Bar Codes supports some advanced features where are summarized below.

Export to Bitmap

Bar codes can easily be exported to a bitmap, which can then be displayed in the native Image control or saved to a file.

See the Export to Bitmap topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Export to Bitmap

Bar Codes Advanced Features
Export to Bitmap

Bar codes can easily be exported to a bitmap, which can then be displayed in the native Image control or saved to a file.

It's easy to generate a RenderTargetBitmap from a symbology that is loaded in UI, simply by calling its RenderAsync method. When you have an image representation of a bar code, you can set the Image.Source property to display it there.

Sample Code

This sample code creates a RenderTargetBitmap from a Code 39 extended bar code symbology that is loaded in the UI.

C#
VB
Copy
​RenderTargetBitmap bitmap = new RenderTargetBitmap();
await bitmap.RenderAsync(symbology);
​Dim bitmap As RenderTargetBitmap = New RenderTargetBitmap()
Await bitmap.RenderAsync(symbology)

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Bar Codes Reference
Designer Interaction

Bar Code has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create your bar codes and assign a symbology.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • BarCode Context Menu
  • Task Pane Introduction
  • BarCode Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

BarCode Context Menu

A context menu for the BarCode control is provided. You can right click on the control in the designer to display the context menu.

A BarCode context menu in the Visual Studio designer

Use the context menu options to select the current symbology in the designer for editing in the property grid or in XAML, and also to change to a different symbology from the sub-menu of symbology options.

Task Pane Introduction

Whenever you select a BarCode control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

BarCode Task Pane

The BarCode task pane provides quick access for selecting the current symbology (allows editing of the symbology in the property grid or in the XAML source) or changing to a different symbology. Click on a symbology link in the task pane to switch to that symbology.

The task pane for the BarCode control in the Visual Studio designer

You also can type in the caption or the bar code value. The bar code updates dynamically as you type.

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Charts Reference
Overview

Actipro Charts are meant to help visualize quantitative data. They are the full-featured counterpart to Micro Charts, and include rich visual elements such as legends, axes, labels, and more. Use charts to convey rich data and trends in your custom apps, dashboards, and reports.

Sample sales illustrated using three line series on an XYChart

Sample sales illustrated using PieChart

Actipro Charts makes it easy to generate charts based on any custom data source. It will automatically calculate the best scales to fit the data into the control, or you can customize the scales as needed. It includes support for aggregation of large data sets to improve performance and readability, highlighting ranges or key data points, and much more.

Several types of charts are supported, which include Area, Bar, Line, Pie, Donut, and Scatter. Stacked and 100% stacked variations of area and bar charts are available as well.

Features

Chart Types

  • Area
    • Includes support for spline curves and stepped lines.
    • Optionally display a line along the series.
    • Optionally display markers to highlight data points.
    • Show markers for first, last, high, low, and negative data points.
  • Bar
    • Quickly customize the spacing between the bars and groups of bars to fit your needs.
    • Stack bars side-by-side, on top of each other, or by percentage (100%).
    • Customize the range that a bar represents.
    • Advanced customization of bars using styles.
  • Line
    • Includes support for spline curves and stepped lines.
    • Optionally display markers to highlight data points.
    • Show markers for for first, last, high, low, and negative data points.
  • Pie / Donut
    • Nest multiple series or support hierarchical data.
    • Several label display options.
    • 'Other' slice for aggregating small pie slices.
  • Scatter
    • Show markers for first, last, high, low, and negative data points.

Data Source Features

  • Supports displaying any numeric and date/time values from custom data sources.
  • Supports displaying and grouping complex data based on equality or custom logic.
  • Data can be automatically aggregated to reduce the number of data points rendered.
  • Automatically group data together under single bars in a bar chart, based on a numeric or date range.

Appearance Features

  • Combine any number of different series into a single chart.
  • Supports stacking multiple series, both normally and using 100% scale.
  • Customizable baseline value, which dictates which values are considered 'negative', and optional display of baseline.
  • Customizable minimum and maximum values of each axis for fixed scales.
  • Add horizontal or vertical ranges, which are used to highlight specific data ranges.
  • Easily customize the various brushes used to render charts via palettes and palette selectors.
  • Set the visibility of any series to dictate whether or not it is rendered on the chart.
  • Over 10 built-in palettes.
  • Show axis ticks, labels, and title; with customizable appearance.
  • Stack multiple axis and assign each axis to a specific series or share with multiple series.
  • Show customizable labels and markers on data points; labels move to avoid overlapping each other.
  • Display grid lines and stripes behind chart for easy viewing; with customizable appearance.
  • Customize bars in bar charts to fit the look and style you want.
  • Show and position a customizable legend.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Charts Reference
Getting Started

Getting started with Charts is simple. Follow the steps below to build your first chart.

This topic contains these sections:

  • Add Extension SDK Reference
  • Add the XYChart Control
  • Add a Series
  • Further Study

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Add the XYChart Control

Then find the parent element that will contain the chart. This could be a UserControl or any other type of UIElement.

Next, add a XYChart control to the desired parent element. In this sample we will add the XYChart to a UserControl:

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:charts="http://schemas.actiprosoftware.com/winfx/xaml/charts">
    <charts:XYChart Width="300" Height="200"/>
</UserControl>

Add a Series

Now we need to add a series, which renders a single set of data points on the chart. In this sample we will add a AreaSeries series, but the other types are added in a similar manner.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:charts="http://schemas.actiprosoftware.com/winfx/xaml/charts">
    <charts:XYChart Width="300" Height="200">
        <charts:AreaSeries ItemsSource="{Binding}" />
    </charts:XYChart>
</UserControl>

Note that this sample assumes that the chart's DataContext is a list of numeric (i.e. Double, Decimal, etc) or DateTime objects. With this configuration, the chart's X values will represent the index value in the list and the chart's Y values will represent the list's actual value at the related list index.

If our list contained custom objects and we wanted to pull the X and Y values from properties on that object, then we would have to specify the property path on the series.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:charts="http://schemas.actiprosoftware.com/winfx/xaml/charts">
    <charts:XYChart Width="300" Height="200">
        <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyNumericProperty" />
    </charts:XYChart>
</UserControl>

This sample assumes the objects in the list each contain a property named MyDateProperty and MyNumericProperty, which are then used for the associated axis.

Note Note
If a list contains custom data objects but the index of each entry should be used as the X-values, leave out the XPath attribute and just specify the YPath to the data object's property that contains the value to display.

Additional series can be added and they will all be rendered on the same chart using the same X and Y scales.

Further Study

To familiarize yourself with all of the features in Charts, take a look at the feature documentation and also look at the numerous QuickStarts located in the sample project.

If you require further assistance after looking through those, please visit our Charts support forum.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Chart Basics

Charts Reference
Chart Basics

This topic discusses some of the basic concepts for using Charts.

This topic contains these sections:

  • Primary vs. Secondary Axis
  • Adding a Series
  • Specifying Items

Primary vs. Secondary Axis

The XYChart control supports two axes, X and Y. The X axis runs horizontally along the control, and the Y axis runs vertically. All series default to rendering horizontally, which means that Y is the primary axis and X is the secondary axis.

Certain series types, such as Bar, support vertical orientations as well as the default horizontal orientation. With vertically oriented series, X is the primary axis and Y is the secondary axis.

See the Chart Types topic for additional information.

Horizontal Bar Chart

Vertical Bar Chart

Adding a Series

Each series is represented by an individual .NET type. For instance, a Line series is implemented by the LineSeries class.

Add any series you would like to display to the XYChart.Series collection. The chart will automatically scale the X and Y axes to fit the data of each series properly, however you can also specify axes and control how they are displayed. See Axes for more details.

See the Chart Types topic for a list of the available chart types.

Specifying Items

Each series is bound to it's own data source, which is indicated by the ItemsSource property. The XPath and YPath will determine the property path used for values on the X and Y axes.

When XPath and YPath are not specified, then the respective X and Y values will instead be the items in the ItemsSource collection.

When X or Y axes values resolve to a quantifiable or numeric data type, such as Double, Decimal, Int32 or DateTime, then the respective axis should match the data type. If axes are not specified, they wil be set automatically.

When X or Y axes values resolve to a complex object or reference type, such as String or a user-provided type, then the respective axis should be XYGroupedAxis. By default, these type of values will be grouped based on object equality. Grouping can be determined based on custom criteria by specifying XYGroupedAxis.GroupingFunc.

See the Specifying Items topic for additional information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Chart Types
Overview

Actipro Charts includes a number of built-in chart types.

Name | Description
Area | An area chart is a derivative of a line chart. The area between the line and axis is filled in. Markers and lines can optionally be displayed.
Bar | A bar chart displays rectangular bars with lengths proportional to the values they represent.
Line | A line chart render quantitative data as a series of points connected by line segments. Lines can be straight, curved, or stepped. Markers can optionally be displayed.
Pie / Donut | A pie chart can display data points as pie slices, or in the case of a donut chart, cocentric rings.
Scatter | Scatter charts render data points where each point is represented by a marker.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Area

Chart Types
Area

An area chart is a derivative of a line chart where the area between the line and axis is filled in.

This topic contains these sections:

  • Baseline Value
  • Line Kind
  • Line
  • Markers

Baseline Value

The area series will pivot it's polygon based on the chart's baseline value, as specified by the Baseline property on XYDateTimeAxis, XYDoubleAxis, or XYDecimalAxis The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following examples, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Line Kind

The area series supports three kinds of lines specified by the LineKind, which also determines how the area is rendered. By default, the Normal kind of line is used which simply draws a line to connect the data points when determining the area's polygon.

An area series using a normal line kind

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An area series using a spline line kind

The Step line kind creates a polygon that only uses horizontal and vertical lines to connect the data points, producing a step look.

An area series using a step line kind

Line

The area series can render an actual line along the top of the area to distinguish it better. By default the line is not rendered, but it can be shown by setting LineVisibility to a value other than None. The area series has the same configuration properties available as the line series, with regards to line rendering.

An area series with LineVisibility set to All.

See the Line topic for more information on the options available.

Markers

The area series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The area series has the same configuration properties available as the scatter series, with regards to marker rendering.

An area series with MarkerVisibility set to All.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bar

Chart Types
Bar

A bar chart displays rectangular bars with lengths proportional to the values they represent.

This topic contains these sections:

  • Baseline Value
  • Orientation
  • Bar Spacing

Baseline Value

The bar series will pivot it's bars based on the chart's baseline value, as specified by the Baseline property on XYDateTimeAxis, XYDoubleAxis, or XYDecimalAxis.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum. Since our baseline is 0 (the default), the bars are not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the bars will appear to "grow" down instead of up.

Orientation

The bar chart can be oriented horizontally (the default) or vertically by setting the Orientation property. When switching orientation, the values of the XPath and YPath properties may need to be swapped.

Bar Spacing

The BarSpacing property can be used to configure the space between the bars. The default value is 1px, which indicates there should be a 1 pixel space between the bars.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line

Chart Types
Line

A line chart renders quantitative data as a series of points connected by line segments, which can be straight, curved, or stepped.

This topic contains these sections:

  • Baseline Value
  • Line Kind
  • Markers

Baseline Value

The chart's baseline value, as specified by the Baseline property on XYDateTimeAxis, XYDoubleAxis, or XYDecimalAxis.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative". Visually nothing will change unless the baseline is shown, using XYChart.IsAxisBaselineVisible.

Line Kind

The line series supports three kinds of lines specified by the LineKind. By default, the Normal kind of line is used which simply draws a line to connect the data points.

An line series using a normal line kind

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An line series using a spline line kind

The Step line kind creates a line that only uses horizontal and vertical lines to connect the data points, producing a step look.

An line series using a step line kind

Markers

The line series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The line series has the same configuration properties available as the scatter series, with regards to marker rendering.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pie / Donut

Chart Types
Pie / Donut

A pie / donut chart displays pie slices with sizes proportional to the values they represent.

This topic contains these sections:

  • Donut Chart
  • Customization

Donut Chart

Donut charts act just like pie charts, except for an adjustable donut hole in the center of the chart. Refer to Donut Chart for more information.

Customization

Pie / donut charts support several customization options, such as labels, legends, multiple series and more. Refer to Pie Chart Features for details on how to use these features.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scatter

Chart Types
Scatter

Scatter charts render data points where each point is represented by a marker.

This topic contains these sections:

  • Marker Shape Kinds

Marker Shape Kinds

Markers support several built in shape kinds, which include:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
RoundedRectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple and Stacked Series

Chart Types
Multiple and Stacked Series

The chart control supports multiple series which can be optionally stacked on top of the previous series.

This topic contains these sections:

  • Multiple Series
  • No Stacking
  • Normal Stacking
  • Percentage Stacking

Multiple Series

Any number of series can be added to the chart, which will simply render one on top of each (in z-order) Simply add the series to the XYChart.Series collection that you would like to be rendered.

In this example, we display a bar and line series in the same chart:

XAML
Copy
​<charts:XYChart Width="200" Height="100" >
    <charts:BarSeries ItemsSource="4;11;3;1;8;9;14" />
    <charts:LineSeries ItemsSource="7;3;5;1;1;3;10" />
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis Minimum="0"/>
    </charts:XYChart.YAxes>
</charts:XYChart>

This results in the following chart:

The chart will automatically align the multiple series along the secondary axis (X in this example). So, if the series have data with disparate values, then it will automatically adjust to fit the data.

In this example, we add additional data points to the line series:

XAML
Copy
​<charts:XYChart Width="200" Height="100">
    <charts:BarSeries ItemsSource="4;11;3;1;8;9;14" />
    <charts:LineSeries ItemsSource="7;3;5;1;1;3;10;5;2;8;1;14" />
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis Minimum="0"/>
    </charts:XYChart.YAxes>
</charts:XYChart>

This results in the following chart, which has extended the line series beyond the bar series since it has more data points:

No Stacking

When not stacked, series will render on top of each other. For BarSeries, bars will render next to each other. This can be done by setting StackKind on the series to None.

XAML
Copy
​<charts:XYChart Width="200" Height="150" >
    <charts:AreaSeries ItemsSource="{Binding Data1}" StackKind="None" />
    <charts:AreaSeries ItemsSource="{Binding Data2}" StackKind="None" />
</charts:XYChart>

Normal Stacking

Two or more series can be stacked one on top of the other to convey cumlative values to the end user.

By setting StackKind on the series to Normal, the values of each series will be added to the previous stacked series.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<charts:XYChart Width="200" Height="150" >
    <charts:AreaSeries ItemsSource="{Binding Data1}" StackKind="Normal" />
    <charts:AreaSeries ItemsSource="{Binding Data2}" StackKind="Normal" />
</charts:XYChart>

Percentage Stacking

Two or more area series can be stacked one on top of the other to convey proportional values to the end user. In this mode, the series render to fill the chart height. At any given location, the height of each rendered series indicates its value percentage relative to the total.

By setting StackKind on the series to Percentage, the values of each series will be added to the previous stacked series and a percentage of the total value will be used.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<charts:XYChart Width="200" Height="150" >
    <charts:AreaSeries ItemsSource="{Binding Data1}" StackKind="Percentage" />
    <charts:AreaSeries ItemsSource="{Binding Data2}" StackKind="Percentage" />
</charts:XYChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

XY Chart Features
Overview

The XYChart control contains several features that can be used to customize the appearance and data.

Axes

Axes control the range of values that are visible in a chart, and also can display ticks, labels, titles, and other elements.

See the Axes topic for more information.

Bar Chart Custom Styles

Bar Charts can be customized to have a unique look that fits your needs.

See the Bar Chart Custom Styles topic for more information.

Baseline

A baseline value can be used to alter the look of area, bar, and win/loss series, and can be optionally displayed on the chart.

See the Baseline topic for more information.

Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

See the Data Aggregation topic for more information.

Data Point Labels

Data point labels allow you to show the values of a given data point.

See the Data Point Labels topic for more information.

Grid Lines and Stripes

Grid lines and stripes appear behind the chart data and allow the user to easily compare data against axis values.

See the Grid Lines and Stripes topic for more information.

Legend

A legend can provide context for what each series in a chart represents. Legends are fully stylable and can be customized to match the look and feel of your application.

See the Legend topic for more information.

Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

See the Palettes topic for more information.

Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

See the Ranges topic for more information.

Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

See the Series Visibility topic for more information.

Specifying Items

The chart control can be bound to any custom data source and supports several data types.

See the Specifying Items topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Axes

XY Chart Features
Axes

Axes control the range of values that are visible on a chart. Visually, they provide a quick reference to lookup the value of data points on a chart.

This topic contains these sections:

  • Getting Started
  • Minimum and Maximum
  • Grouped Axis
  • Percentage Axis
  • Ticks
  • Labels
  • Titles
  • Position
  • Stacking / Sharing Axis

Getting Started

If you do not specify axes on your chart, then default values will be used. If your axis is a numeric or quantifiable type, then the Minimum and Maximum values will be automatically set to the lowest and highest values in your data set. To specify axes and axis properties on your chart, you must choose the correct axis for your data.

Note the example below, where the X axis data contains DateTime values and the Y axis data contains Double values.

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

For this case, you would add a XYDateTimeAxis to XYChart.XAxes, and a XYDoubleAxis to XYChart.YAxes, like in the following example.

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:XYChart.XAxes>
        <XYDateTimeAxis&quot;/>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <XYDoubleAxis/>
    </charts:XYChart.YAxes>
    <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

Once the axis is specified, you can set properties on it, like the example below:

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:XYChart.XAxes>
        <XYDateTimeAxis Minimum="1/1/1990" Maximum="1/1/2000"/>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <XYDoubleAxis Minimum="100" Maximum"100000"/>
    </charts:XYChart.YAxes>
    <charts:AreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

Minimum and Maximum

The Minimum and Maximum properties on XYDateTimeAxis, XYDoubleAxis, and XYDecimalAxis control the range of values that are displayed on the chart. Any values outside of the Minimum / Maximum range will not be displayed on the chart (unless they fall in the space around the chart created by XYChart.PaddingPercentage).

When Minimum and Maximum are not specified, or when the axes are not defined in markup, Minimum will be automatically set to the lowest value in the data set, and Maximum will be set to the highest.

Grouped Axis

When your X or Y axis values are a String or other complex data type, then XYGroupedAxis will be used.

Note the example below, where the X axis data contains String values and the Y axis data contains Double values.

XAML
Copy
​<charts:XYChart Width="300" Height="200">
    <charts:BarSeries ItemsSource="{Binding}" XPath="MyStringProperty" YPath="MyDoubleProperty" />
</charts:XYChart>

In the example above, and by default, values on the secondary axis (in this case, the X axis) will be grouped based on object equality. So any strings that are equal to each other will be grouped under the same bar. In the cases where mutliple objects are grouped, the values on the primary axis (in this case, the Y axis) will be summed up, if they are a numeric data type. If the primary axis values are not set, or are a non-numeric data type, they will be ignored and replaced with the number of items in each group.

Grouping

By default, items will be grouped by object equality. To change how groups are determined, you can specify XYGroupedAxis.GroupingFunc. This is a Func<object,object,bool> that takes two objects to compare and returns a bool. Return True if they should be grouped together, elsewise, return False.

This example shows a custom grouping function that groups by the first letter in each string.
C#
VB
Copy
​GroupByFirstLetter = (a, b) => {
    char firstLetterForA = ((string)a).ToLower()[0];
    char firstLetterForB = ((string)b).ToLower()[0];
    return firstLetterForA.Equals(firstLetterForB);
};
​Dim groupByFirstLetter = Function(a, b) CStr(a).Chars(0).Equals(CStr(b).Chars(0))

Labeling Groups

By default, groups will be labelled using the ToString() result on the first object in each group. To change how groups are labelled, you can specify XYGroupedAxis.LabelFunc. This is a Func<object,string> that takes the first object in a group and returns a string to be used as the group label.

This example shows a custom labeling function that labels using first letter in each string.
C#
VB
Copy
​Func<object,string> labelWithFirstLetter = a => ((string) a).Substring(0, 1);
​Dim labelWithFirstLetter = Function(a) CStr(a).Substring(0, 1)

Sorting Groups

By default, groups will not be sorted. To change how groups are sorted, you can specify XYGroupedAxis.SortingFunc. This is a Func<object,object,int> that takes the first object from two groups and returns an int describing how they compare to each other.

  • If the function returns a negative value, then the first instance is sorted before the second.
  • If the function returns zero, then the instances are considered equal and sorted next to each other.
  • If the function returns a positive value, then the first instance is sorted after the second.

This example shows a custom sorting function that sorts using first letter in each string.
C#
VB
Copy
​Func<object,object,int> sortAlphabetically = (a, b) => {
    char firstLetterForA = ((string)a).ToLower()[0];
    char firstLetterForB = ((string)b).ToLower()[0];
    return firstLetterForA - firstLetterForB;
};
​Dim sortAlphabetically = Function(a, b) AscW(CStr(a).ToLower().Chars(0)) - AscW(CStr(b).ToLower().Chars(0))
Percentage Axis

When your series has XYSeriesBase.StackKind set to XYSeriesStackKind.Percentage, then XYPercentageAxis will be used and data will be stacked by percentage on the secondary axis.

"Stacked by percentage" means that instead of a value being placed on a cartesian axis, it is instead stacked on top of values from other series. The position and size of the value is relative to the sum of all values in that slot.

So, if there are two values in a slot, 5.0 and 5.0, they will both occupy 50% of the available size since they are both half of the sum (5.0 + 5.0 = 10.0). If there are two values in a slot, 2.0 and 8.0, they will occupy 20% and 80% of the available size.

Note that XYPercentageAxis can only be used on numeric data. DateTime and complex types cannot be placed on the axis.

Labeling

By default, major ticks on XYPercentageAxis will be labeled using the percentage formatting of the environment's current culture.

For simple custom formatting, you can specify XYAxisBase.LabelFormat. The parameter "{0}" will be the percentage of the tick, represented by a value between 0.0 and 1.0. You can reference this MSDN article for numeric format strings.

This example will format the percent with two decimal places (note the use of the additional {} to escape the use of curly brackets in XAML). So, a percentage value of 0.2543 would be displayed as 25.43 % in the en-US culture.
XAML
Copy
​<XYPercentageAxis LabelFormat=0:P2}/&gt;

For more advanced labeling scenarios, you can specify XYPercentageAxis.LabelFunc. Setting this will override whatever is specified for XYAxisBase.LabelFormat. LabelFunc is a Func<double,string> that takes an object (the percentage of the current tick) and returns a string to be used as the label for the tick.

This example shows a custom labeling function that spells out the word "Percent".
C#
VB
Copy
​Func<double,string> labelFunc = percent => (percent*100).ToString() + " Percent";
​Dim labelFunc = Function(percent) (percent*100).ToString() + " Percent"
Ticks

Axis ticks create a "guide" that help to communicate the value of any given point in your chart. Major ticks generally are more prominent and have labels associated with them, while minor ticks are less prominent and do not have labels.

Tick Visibility

Major and minor ticks can be shown or hidden using XYAxisBase.AreMajorTicksVisible and XYAxisBase.AreMinorTicksVisible, respectively.

This example shows a chart with minor and major ticks visible on Y axis.
XAML
Copy
​<XYDoubleAxis AreMajorTicksVisible="True" AreMinorTicksVisible="True" ... TickMajorInterval="5" TickMinorInterval="2.5"/>

Intervals

Tick intervals control how frequently major and minor ticks occur on the axis.

For XYDoubleAxis and XYDecimalAxis, TickMajorInterval and TickMinorInterval are used. When tick intervals are not specified, they will automatically be calculated based on the chart data.

This example shows a chart with major tick interval set to 10, and minor tick interval set to 5. Compare with the examples above and note how the ticks are further spread out.
XAML
Copy
​<XYDoubleAxis TickMajorInterval="10" TickMinorInterval="5" ... />

For XYPercentageAxis, tick intervals work slightly differently. You can control how far major and minor ticks are spaced apart by setting XYPercentageAxis.TickMajorInterval and XYPercentageAxis.TickMinorInterval. Both of these properties take a Double value between 0.0 and 1.0. This represents how far apart the ticks are spaced, by percentage. For example, if the interval is set to 0.25, a tick will be placed every 25%. So there will be ticks at 0%, 25%, 50%, 75%, and 100%.

For XYDateTimeAxis, tick intervals can be set via the TickMajorInterval and TickMinorInterval properties. However the TickMajorIntervalUnit and TickMinorIntervalUnit properties must also be set to a TimeUnit that describes the unit specified by the tick intervals (days, hours, etc.). A major tick interval will automatically be calculated if none is set.

Labels

Label Visibility

Labels can be displayed on the major ticks using XYAxisBase.AreLabelsVisible.

This example shows a chart with labels and ticks visible on Y axis.
XAML
Copy
​<XYDoubleAxis AreLabelsVisible="True" ... TickMajorInterval="5" TickMinorInterval="2.5"/>

Label Visibility

Titles

An axis can be titled using XYAxisBase.Title.

This example shows a chart with a title set on the Y axis.
XAML
Copy
​<XYDoubleAxis Title="Sales" ... />

An axis title can be styled using XYAxisBase.TitleStyle.

This example shows a chart with a title style set on the Y axis.
XAML
Copy
​<charts:XYDoubleAxis Title="Sales" ...>
    <charts:XYDoubleAxis.TitleStyle>
        <Style TargetType="ContentControl">
            <Setter Property="FontSize" Value="18"/>
            <Setter Property="Foreground" Value="#004dee"/>
        </Style>
    </charts:XYDoubleAxis.TitleStyle>
</charts:XYDoubleAxis>

Position

Axes can be placed on the near edge or far edge of the chart using the XYAxisBase.Position property.

This example shows a chart with both axes on the far edge of the chart.
XAML
Copy
​<charts:XYChart ...>
    <charts:LineSeries .../>
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis Position="FarEdge" .../>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis Position="FarEdge" .../>
    </charts:XYChart.YAxes>
</charts:XYChart>

Stacking / Sharing Axis

A chart can contain multiple Y axes and multiple X axes. You can specify which series is bound to which axis by using XYSeriesBase.XAxis and XYSeriesBase.YAxis.

This example shows a chart with two series, each bound to a different Y axis with a unique range of values.
XAML
Copy
​<charts:XYChart Width="300" Height="150" >
    <charts:BarSeries ItemsSource="4;11;3;1;8;9;14" YAxis="{Binding ElementName=yAxis1}" />
    <charts:LineSeries ItemsSource="700;300;500;100;100;300;900" YAxis="{Binding ElementName=yAxis2}"/>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis x:Name="yAxis1" Minimum="0" Maximum="15" IsTickMajorVisible="True" TickMajorInterval="2" AreLabelsVisible="True" Title="Sales (Line)"/>
        <charts:XYDoubleAxis x:Name="yAxis2" Position="FarEdge" Minimum="0" Maximum="1000" AreMajorTicksVisible="True" TickMajorInterval="200"  AreLabelsVisible="True" Title="Revenue (Bar)"/>
    </charts:XYChart.YAxes>
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis AreMajorTicksVisible="False" AreMinorTicksVisible="False" AreLabelsVisible="False"/>
    </charts:XYChart.XAxes>
</charts:XYChart>
Note that each series is bound by ElementName to an axis in the XYChart.YAxes collection.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bar Chart Custom Styles

XY Chart Features
Bar Chart Custom Styles

Bar Charts can be customized to have a unique look that fits your needs.

This topic contains these sections:

  • Brushes & Styling
  • Custom Template

Brushes & Styling

Bar Series can have custom styles applied to the bars using BarSeriesBase.BarStyle.

This example shows a chart the bars styled uniquely.
XAML
Copy
​<charts:BarSeries ItemsSource="11;2;3;14;20;6">
    <charts:BarSeries.BarStyle>
        <Style TargetType="Border">
            <Setter Property="Background" Value="#55ee00ee"/>
            <Setter Property="BorderBrush" Value="#ee880088"/>
            <Setter Property="CornerRadius" Value="3"/>
            <Setter Property="BorderThickness" Value="1"/>
            <Setter Property="Effect">
                <Setter.Value>
                    <DropShadowEffect Opacity="0.4"/>
                </Setter.Value>
            </Setter>
        </Style>
    </charts:BarSeries.BarStyle>
</charts:BarSeries>

Custom Template

For a more dramatic change, you can retemplate the bar content completely by using BarSeriesBase.BarTemplate.

This example shows a chart the bars retemplated uniquely.
XAML
Copy
​<charts:XYChart Width="200" Height="150" Margin="20" HorizontalAlignment="Left">
    <charts:BarSeries ItemsSource="11;2;3;14;20;6">
        <charts:BarSeries.BarStyle>
            <Style TargetType="Border">
                <Setter Property="Background" Value="Transparent"/>
                <Setter Property="BorderBrush" Value="Transparent"/>
            </Style>
        </charts:BarSeries.BarStyle>
        <charts:BarSeries.BarTemplate>
            <DataTemplate>
                <Viewbox shared:ClipToBoundsBehavior.ClipToBounds="True" StretchDirection="DownOnly"
                                Stretch="UniformToFill" Margin="0" VerticalAlignment="Bottom" >
                    <StackPanel Width="20" Orientation="Vertical">
                        <StackPanel.Resources>
                            <Style x:Key="EllipseStyle" TargetType="Ellipse">
                                <Setter Property="Width" Value="20"/>
                                <Setter Property="Height" Value="20"/>
                                <Setter Property="Fill" Value="#8bbcde"/>
                            </Style>
                        </StackPanel.Resources>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                        <Ellipse Style="{StaticResource EllipseStyle}"/>
                    </StackPanel>
                </Viewbox>
            </DataTemplate>
        </charts:BarSeries.BarTemplate>
    </charts:BarSeries>
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis BarSpacing="10" IsTickMajorVisible="False" IsTickMinorVisible="False" AreLabelsVisible="False"/>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis AreMajorTicksVisible="True" AreMinorTicksVisible="True" AreLabelsVisible="False" TickMajorInterval="5" TickMinorInterval="2.5" Minimum="0"/>
    </charts:XYChart.YAxes>
</charts:XYChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Baseline

XY Chart Features
Baseline

Baseline is the point on an axis that separates positive and negative values. A baseline value can be used to alter the look of area and bar series, and can be optionally displayed on the chart.

This topic contains these sections:

  • Baseline Value
  • Baseline Visibility and Style

Baseline Value

The baseline value determines what the chart considers "positive" and "negative" values. Any value greater than or equal to the baseline value is considered positive, and any value less than the baseline value is considered negative.

The baseline value can be customized using the Baseline property on XYDoubleAxis, XYDecimalAxis, and XYDateTimeAxis. Baseline defaults to 0 for numeric values and DateTime.MinValue for date/time.

In addition, area and bar series will pivot their polygons around the baseline value, which alters their appearance.

In the following examples, the data rendered by the area chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Baseline Visibility and Style

An actual line can be rendered at the specified baseline value to highlight its location in the chart. The visibility of the line is configured using the IsAxisBaselineVisible property, which is false by default.

For example, the following line series uses the same fixed values from above (10, 20, 10, 20, 10, 20, 10) and a baseline value of 15. In this particular example, since the line is rendered with a single color, it is not possible to visually determine what is considered above or below the baseline.

If we set IsAxisBaselineVisible to True, then we can easily determine this information.

The style of the line can be customized using the AxisBaselineStyle property. The associated Style should target the Shape type, which includes properties such as Stroke and StrokeThickness.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Aggregation

XY Chart Features
Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

This topic contains these sections:

  • Aggregation Factor
  • Aggregation Kinds

Aggregation Factor

In order to increase performance, the chart control will automatically determine the optimal number of data points to display based on the size of the control. This is determined using the AggregationFactor property, which defaults to 0.2.

For example, if the chart control is 100 pixels wide and uses an aggregation factor of 0.1, then the optimal number of data points would be 10. If the data source contained 1000 items, then the chart would create 10 groups, each with 100 items in it. Then some sort of aggregation function would be performed on each group to generate a single data point for display.

A line series with markers visible with no aggregation, 10% aggregation, and 50% aggregation

Aggregation is enabled by default and can be disabled by setting IsAggregationEnabled to false.

Aggregation Kinds

There are various aggregation functions that can be performed on the items in a group. The supported aggregation kinds are specified using the PrimaryAggregationKind and SecondaryAggregationKind.

The PrimaryAggregationKind is typically used for the Y values, but for vertically-oriented series this will be used by the X values. Similarly the SecondaryAggregationKind is used for X values, but will be used by Y values for vertically-oriented series.

The following table lists the supported aggregation kinds:

Aggregation Kind | Description
Average | Averages all the values in the group and uses that as the aggregated value.
First | Uses the first value in the group as the aggregated value.
Last | Uses the last value in the group as the aggregated value.
Maximum | Uses the maximum value in the group as the aggregated value.
Minimum | Uses the minimum value in the group as the aggregated value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Point Labels

XY Chart Features
Data Point Labels

Data point labels allow you to show the values of a given data point.

This topic contains these sections:

  • Visibility
  • Style
  • Formatting
  • Advanced Customization
  • Angle
  • Layout
  • Collision Avoidance

Visibility

Visibility of data point labels can be controlled using SeriesBase.LabelVisibility. LabelVisibility defaults to Hidden, in which no labels are visible.

This is an example of setting LabelVisibility to Visible, in which all labels are visible.
XAML
Copy
​<charts:BarSeries LabelVisibility="Visible" .../>

This is an example of setting LabelVisibility to PointerAxis, in which labels are visible on all data points near the mouse pointer on the secondary axis.
XAML
Copy
​<charts:BarSeries LabelVisibility="PointerAxis" .../>

This is an example of setting LabelVisibility to PointerProximity, in which labels are visible on all data points near the mouse pointer.
XAML
Copy
​<charts:BarSeries LabelVisibility="PointerProximity" .../>

Style

The sytle of the data point labels can be changed using SeriesBase.LabelStyle. The style TargetType must be DataPointLabel.

This is an example of a custom data point label style. Note how the default label color is available by binding to DataPointLabel.SeriesDefaultBrush.
XAML
Copy
​<charts:BarSeries ItemsSource="11;2;3;14;20" LabelVisibility="Visible">
    <charts:BarSeries.LabelStyle>
        s<Style TargetType="charts:DataPointLabel">
            <Setter Property="Background" Value="White"/>
            <Setter Property="BorderBrush" Value="{Binding SeriesDefaultBrush}"/>
            <Setter Property="BorderThickness" Value="2"/>
            <Setter Property="Foreground" Value="{Binding SeriesDefaultBrush}"/>
            <Setter Property="FontWeight" Value="Bold"/>
            <Setter Property="Effect">
                <Setter.Value>
                    <DropShadowEffect Opacity="0.1"/>
                </Setter.Value>
            </Setter>
        </Style>
    </charts:BarSeries.LabelStyle>
</charts:BarSeries>

Formatting

The formatting of the data point labels can be changed using SeriesBase.LabelFormat. Label format provides four parameters:

  • {0} is the value on the primary axis.
  • {1} is the value on the secondary axis.
  • {2} is the value on the X axis.
  • {3} is the value on the Y axis.

This is an example of a custom data point label format. The label format is "X:{2} Y:{3}". Note the extra pair of curly-braces used to escape the format string in XAML.
XAML
Copy
​<charts:BarSeries LabelFormat="{}X:{2} Y:{3}" .../>

Advanced Customization

There may be situations where SeriesBase.LabelFormat is not sufficient for your needs. In those cases, you can use SeriesBase.LabelFunc to create custom labels using a custom function. LabelFunc is a Func<object,object,object,object,object,string>. It has the following parameters: primary axis value, secondary axis value, X axis value, Y axis value, and original value. The string that is returned is used for the data point label.

This is an example of a custom data point label func.
XAML
Copy
​<charts:BarSeries LabelFunc="{Binding CustomLabelFunc}" .../>
It is bound to a Func<object,object,object,object,object,string> property on the DataContext, which has a function pointer with a matching signature assigned to it.
C#
VB
Copy
​private readonly Func<object, object, object, object, object, string> customLabelFunc = GetCustomLabel;

public Func<object, object, object, object, object, string> CustomLabelFunc {
    get { return customLabelFunc; }
}

public static string GetCustomLabel(object primaryValue, object secondaryValue, object xValue, object yValue, object originalValue) {
    return string.Format("X: {0}{1}Y: {2}", xValue, Environment.NewLine, yValue);
}
​Private ReadOnly _customLabelFunc As New Func(Of Object, Object, Object, Object, Object, String)(AddressOf GetCustomLabel)

Public ReadOnly Property CustomLabelFunc() As Func(Of Object, Object, Object, Object, Object, String)
    Get
        Return _customLabelFunc
    End Get
End Property

Public Shared Function GetCustomLabel(ByVal primaryValue As Object, ByVal secondaryValue As Object, ByVal xValue As Object, ByVal yValue As Object, ByVal originalValue As Object) As String
    Return String.Format("X: {0}{1}Y: {2}", xValue, Environment.NewLine, yValue)
End Function

Angle

The angle of data point labels can be changed using SeriesBase.LabelAngle.

This is an example of a custom data point label angle at 45 degrees.
XAML
Copy
​<charts:BarSeries LabelAngle="45" .../>

Layout

Each series uses the best method for determining label position by default, but this can be customized when needed. You can set LabelPositioningMode on BarSeries, LineSeries, AreaSeries, or ScatterSeries to determine how labels are positioned. The two possible values are LabelPositioningMode.FromBaseline, which positions labels away from the baseline, and LabelPositioningMode.FromAverage, which positions labels away from the average value of the primary axis.

Collision Avoidance

By default, data point labels have collision detection enabled and will attempt to not overlap each other by stacking away from the baseline.

If you want to disable this behavior, you can use XYChart.LabelCollisionMode and set it to None.

This is an example of the label collision detection being disabled.
XAML
Copy
​<charts:XYChart LabelCollisionMode="None" .../>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Grid Lines and Stripes

XY Chart Features
Grid Lines and Stripes

Grid lines and stripes appear behind the chart data and allow the user to easily compare data against axis values.

This topic contains these sections:

  • Line Visibility
  • Stripe Visibility
  • Line Customization
  • Stripe Customization

Line Visibility

Visibility of the grid lines is controlled using XYChart.GridLineMajorVisibility and XYChart.GridLineMinorVisibility. These properties can be set to None, All, X, or Y.

This is an example of setting GridLineMajorVisibility to Y, in which grid lines are shown for each major tick on the Y axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="Y" .../>

This is an example of setting GridLineMajorVisibility to X, in which grid lines are shown for each major tick on the X axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="X" .../>

This is an example of setting GridLineMajorVisibility to All, in which grid lines are shown for each major tick on the X and Y axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="All" .../>

Stripe Visibility

Visibility of the grid stripes is controlled using XYChart.GridStripeVisibility. This property can be set to None, X, or Y.

This is an example of setting GridLineMajorVisibility to Y, in which grid stripes are shown alternating between each major tick on the Y axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="Y" .../>

This is an example of setting GridLineMajorVisibility to X, in which grid stripes are shown alternating between each major tick on the X axis.
XAML
Copy
​<charts:XYChart GridLineVisibility="X" .../>

Line Customization

The color of major and minor grid lines can be controlled using XYChart.GridLineMajorBrush and XYChart.GridLineMinorBrush, respectively.

This is an example of setting GridLineMajorBrush and GridLineMinorBrush to custom colors.
XAML
Copy
​<charts:XYChart .... GridLineMajorBrush="#338833" GridLineMinorBrush="#33bb33">

Stripe Customization

The color of grid stripes and alternating grid stripes can be controlled using XYChart.GridStripeBrush and XYChart.GridStripeAlternatingBrush.

This is an example of setting GridStripeBrush and GridStripeAlternatingBrush to custom colors.
XAML
Copy
​<charts:XYChart .... GridStripeBrush="#55338833" GridStripeAlternatingBrush="#2233bb33">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Legend

XY Chart Features
Legend

A chart legend is a reference that shows a description of each data set and the color it is represented by.

This topic contains these sections:

  • Visibility
  • Position
  • Legend Customization
  • Legend Item Customization

Visibility

The visibility of the legend can be controlled using XYChart.IsLegendVisible.

This is an example of setting IsLegendVisible to true.
XAML
Copy
​<charts:XYChart IsLegendVisible="true" .../>

Position

The position of the legend can be controlled using XYChart.LegendHorizontalPosition and XYChart.LegendVerticalPosition. Legend positions have two modifiers, Inside and Outside (for example, LeftInside and TopOutside. Inside means the legend will be positioned relative to the chart drawing area, and Outside means the legend will be positioned relative to the entire chart control. So CenterInside will be in the center of the chart drawing area, wheras CenterOutside will be in the center of the entire chart control.

This is an example of setting LegendHorizontalPosition to RightOutside and LegendVerticalPosition to TopOutside. Note how when placed outside the chart drawing area, the chart will resize to make room for the legend.
XAML
Copy
​<charts:XYChart LegendHorizontalPosition="RightOutside" LegendVerticalPosition="TopOutside" .../>

This is an example of setting LegendHorizontalPosition to LeftInside and LegendVerticalPosition to BottomInside.
XAML
Copy
​<charts:XYChart LegendHorizontalPosition="LeftInside" LegendVerticalPosition="BottomInside" .../>

Legend Customization

The legend can be styled using XYChart.LegendStyle. The style you provide should have a TargetType of ItemsControl.

This is an example of providing a custom LegendStyle.
XAML
Copy
​<charts:XYChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="BorderBrush" Value="LightGray"/>
        <Setter Property="BorderThickness" Value="3"/>
        <Setter Property="Background">
            <Setter.Value>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#222222" Offset="0.0"/>
                    <GradientStop Color="#444444" Offset="0.2"/>
                    <GradientStop Color="#444444" Offset="0.8"/>
                    <GradientStop Color="#222222" Offset="1.0"/>
                </LinearGradientBrush>
            </Setter.Value>
        </Setter>
        <Setter Property="Padding" Value="10"/>
        <Setter Property="Effect">
            <Setter.Value>
                <DropShadowEffect Opacity="0.5"/>
            </Setter.Value>
        </Setter>
        <Setter Property="FontFamily" Value="Trebuchet MS"/>
        <Setter Property="FontWeight" Value="Normal"/>
        <Setter Property="FontStyle" Value="Italic"/>
        <Setter Property="FontSize" Value="14"/>
        <Setter Property="Foreground" Value="White"/>
    </Style>
</charts:XYChart.LegendStyle>

Legend Item Customization

Each individual legend item can be retemplated by setting ItemTemplate in XYChart.LegendStyle. The data source for the template is LegendKey, allowing you to bind to properties from the template such as LegendKey.Label and LegendKey.LegendMarkerStyle.

This is an example of providing a custom LegendStyle to retemplate the legend items.
XAML
Copy
​<charts:XYChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="ItemTemplate">
            <Setter.Value>
                <DataTemplate>
                    <Border Background="#dddddd" Padding="5" Margin="5">
                        <StackPanel Orientation="Horizontal">
                            <charts:ChartMarker Margin="0,0,5,0" Style="{Binding LegendMarkerStyle}" BorderBrush="#333333"/>
                            <TextBlock Text="{Binding Label}" Foreground="#111111" FontFamily="Arial"/>
                        </StackPanel>
                    </Border>
                </DataTemplate>
            </Setter.Value>
        </Setter>
    </Style>
</charts:XYChart.LegendStyle>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Palettes

XY Chart Features
Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

This topic contains these sections:

  • Introduction
  • Built-In Palettes
  • Palette Color Selection
  • Palette Shade Generation
  • Custom Palette Colors
  • Customizing Highlight Effect Brushes

Introduction

When any series is being rendered within a chart, it uses the chart's XYChart.SeriesStyleSelector to determine which styles to apply to the various shapes displayed. These shapes include the basic shapes representing lines, areas, bars, markers, etc.

The SeriesPaletteStyleSelector class inherits SeriesStyleSelector and provides many settings that can be used to completely customize how a chart renders its series.

An important thing to note is that the SeriesPaletteStyleSelector builds shape styles based on colors defined in a Palette that has been assigned to its PaletteStyleSelectorBase`1.Palette property. The palette contains multiple colors so that when more than one series is used in a chart, each series will cycle to use a different palette color.

Built-In Palettes

Numerous built-in palettes are included with the product, each named via a value within the PaletteKind enumeration.

A built-in palette can be assigned to a chart like this (in this case the Roman palette):

XAML
Copy
​<charts:XYChart Width="100" Height="18">
    <charts:XYChart.SeriesStyleSelector>
        <charts:SeriesPaletteStyleSelector>
            <charts:Palette Kind="Roman" />
        </charts:SeriesPaletteStyleSelector>
    </charts:XYChart.SeriesStyleSelector>
    ...
</charts:XYChart>

For simple cases where no other customization is needed on the SeriesPaletteStyleSelector, the palette kind can simply be set as an attribute value as well, where the text specified matches one of the PaletteKind values:

XAML
Copy
​<charts:XYChart Width="100" Height="18" SeriesStyleSelector="Roman">
    ...
</charts:XYChart>

Palette Color Selection

Each palette has two mode options for how colors will be assigned to series in a chart. The mode is set by specifying a ColorSelectionHint value on the Palette.ColorSelectionHint property.

Mode | Description
Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.

The default is to use UniformDistribution mode on the built-in palettes, and Sequential mode on custom palettes.

Palette Shade Generation

Each palette has a list of base colors used directly as the core color for each series in a chart. Most palettes define six colors. But what happens when there are more than six series in a chart?

If shade generation is enabled on a palette, via its Palette.IsShadeGenerationEnabled property, additional darker and lighter shades of the base colors will be generated and used for the other series. By default, this feature is enabled.

If this feature is disabled, the color assignments will recycle and the seventh series will simply use the first base color again, and so on.

Custom Palette Colors

It's very easy to create custom palettes. Simply create a Palette and assign the custom colors to its BaseColors collection.

This sample shows the creation of a palette that contains two custom colors:

XAML
Copy
​<charts:XYChart Width="100" Height="18">
    <charts:XYChart.SeriesStyleSelector>
        <charts:SeriesPaletteStyleSelector>
            <charts:Palette>
                <Color>#46bff7</Color>
                <Color>#06226b</Color>
            </charts:Palette>
        </charts:SeriesPaletteStyleSelector>
    </charts:XYChart.SeriesStyleSelector>
    ...
</charts:XYChart>

Note Note
When multiple series are used in a chart, make sure that your palette has enough base color entries to match or exceed your series count. Or ensure that the shade generation feature (described above) is active.

Customizing Highlight Effect Brushes

As described in the introduction above, there are many ways certain data points (and related markers, bars, etc.) can be highlighted. The SeriesPaletteStyleSelector class has an enormous number of property-based options for customizing highlight effects:

  • Area
  • Bar
  • Legend
  • Line
  • Marker

Each of these options generally has three properties on SeriesPaletteStyleSelector, such as these for normal areas:

  • AreaBrushCustom
  • AreaBrushKind
  • AreaTintColor

Custom Brush

A custom Brush, if specified via properties like AreaBrushCustom, will cause the related shape (in this case, a normal area) to directly use that brush for rendering.

Brush Kind

A brush kind can be specified via properties like AreaBrushKind. This kind is of type SeriesBrushKind and has many values that can "modify" the palette color assigned to the series:

  • Default - Use the exact palette color.
  • Light - Use a slightly lighter version of the palette color.
  • Dark - Use a slightly darker version of the palette color.
  • SemiTransparent - Use gradient, from a semi-transparent version of the palette color to transparent.
  • SemiTransparentGradient - Use a gradient, from a semi-transparent version of the palette color to an almost completely transparent version of the palette color.
  • DarkToLightGradient - Use a gradient, from the Dark to Light color.
  • LightToDarkGradient - Use a gradient, from the Light to Dark color.
  • CylinderGradient - Use a gradient, creating a cylindrical appearance.

By using a brush kind setting instead of specifying an exact custom brush, the brush used for each series will be relative to the palette color assigned to that series.

Tint Color

A tint color can be set via properties like AreaTintColor. If specified, the tint will be applied to the resulting brush from the brush kind setting. The tint color is not used if a custom brush is directly set.

The default usage of tint colors is for high areas/markers to tint towards green, and low areas/markers to tint towards red.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ranges

XY Chart Features
Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

A line chart with a green and red range for positive and negative values, respectively

This topic contains these sections:

  • Orientation
  • Minimum and Maximum Values

Orientation

By default, ranges will be aligned horizontally, which means they highlight value ranges along the Y-axis. A vertical range can be created by setting the Orientation property to Vertical. Vertical ranges highlight value ranges along the X-axis.

A line chart with a yellow range between the X values 2 and 5

In this example, the line series is set to a collection of doubles. Therefore, the X values will range from 0 to 7 (since there are 8 entries) and the actual values shown will be used along the Y axis:

XAML
Copy
​<charts:XYChart IsLegendVisible="True" ...>
    <charts:LineSeries ItemsSource="11;2;3;14;20" />
    <charts:LineSeries ItemsSource="3;8;1;15;10" />
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis ...>
            <charts:XYDoubleAxis.Ranges>
                <charts:XYRange Background="#66FFFF00" Minimum="1" Maximum="2" Orientation="Vertical"/>
            </charts:XYDoubleAxis.Ranges>
        </charts:XYDoubleAxis>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis .../>
    </charts:XYChart.YAxes>
</charts:XYChart>

Minimum and Maximum Values

The values of a range are specified using the Maximum and Minimum properties.

If either of these properties is unset (or set to null), then it's value will be auto-calculated based on the data points from all series. The Maximum will run to the highest value and likewise the Minimum will run to the lowest value.

For example, we can produce two ranges that run up (green) and down (red) from 0 using the following code:

XAML
Copy
​<charts:XYChart ...>
    <charts:LineSeries ItemsSource="11;2;3;14;20" />
    <charts:LineSeries ItemsSource="3;8;1;15;10" />
    <charts:XYChart.XAxes>
        <charts:XYDoubleAxis .../>
    </charts:XYChart.XAxes>
    <charts:XYChart.YAxes>
        <charts:XYDoubleAxis ...>
            <charts:XYDoubleAxis.Ranges>
                <charts:XYRange Minimum="10">
                    <charts:XYRange.Background>
                        <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                            <GradientStop Color="Transparent" Offset="0" />
                            <GradientStop Color="#2200FF00" Offset="0.95" />
                            <GradientStop Color="#3300FF00" Offset="1" />
                        </LinearGradientBrush>
                    </charts:XYRange.Background>
                </charts:XYRange>
                <charts:XYRange Maximum="10">
                    <charts:XYRange.Background>
                        <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                            <GradientStop Color="#33FF0000" Offset="0" />
                            <GradientStop Color="#22FF0000" Offset="0.05" />
                            <GradientStop Color="Transparent" Offset="1" />
                        </LinearGradientBrush>
                    </charts:XYRange.Background>
                </charts:XYRange>
            </charts:XYDoubleAxis.Ranges>
        </charts:XYDoubleAxis>
    </charts:XYChart.YAxes>
</charts:XYChart>

This produces the following chart:

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Series Visibility

XY Chart Features
Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

Usage

The visibility of a series can be changed in order to create the ability to show/hide the series on the chart. With this feature several series can be contained within a chart then their visibilities can be manipulated to better compare just a couple at a time. The visibility of a series can be customized with the SeriesBase.Visibility property, which defaults to Visible.

In this example, the visibility property of the line series is bound to the IsChecked property of the checkbox so that the series is shown when checked and not shown when unchecked:

XAML
Copy
​<charts:XYChart ...>
    <charts:BarSeries Description="New York" ... />
    <charts:LineSeries Description="Los Angeles" Visibility="{Binding IsChecked, ElementName=seriesVisibleCheckBox, Converter={StaticResource BooleanToVisibilityConverter}}" .../>
</charts:XYChart>
...
<CheckBox x:Name="seriesVisibleCheckBox" Content="Los Angeles series visible" IsChecked="True"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Specifying Items

XY Chart Features
Specifying Items

The chart control can be bound to any custom data source and supports several data types.

This topic contains these sections:

  • Supported Quantifiable Axis Types
  • Other Axis Types
  • Setting ItemsSource

Supported Quantifiable Axis Types

The chart control supports a fixed set of quantifiable data types along each axis.

The supported data types include:

  • Byte
  • DateTime
  • Decimal
  • Double
  • Int16
  • Int32
  • Int64
  • Float
  • SByte
  • UInt16
  • UInt32
  • UInt64

When the X or Y axis values are of these data types, then the values can be mapped on an axis according to their relative position within the axis Minimum and Maximum values.

Other Axis Types

For all other types of data, including complex objects and String, they will be mapped using XYGroupedAxis.

When using XYGroupedAxis, items will be grouped based on object equality by default. Items can be grouped using custom logic by specifying XYGroupedAxis.GroupingFunc.

Setting ItemsSource

Each series in a chart control can be bound to a separate data source, or to different properties on the same data source. The ItemsSource property on each series can be set to any collection of objects, including custom objects, as long as the collection implements IEnumerable.

In this case, the XPath and/or YPath properties must be set to the name of a property on the objects in the collection.

Note Note
You can traverse complex hierarchies to get to the value you need by using a property path that is delimited by a period ("."). For example you can set XPath or YPath to something like "MyProperty.MyOtherProperty.MyDoubleValue", similar to how binding paths work in XAML.

For example, consider the following custom object:

C#
VB
Copy
​public class SalesData {

    private decimal amount;
    private DateTime date;

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // OBJECT
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Initializes a new instance of the <c>SalesData</c> class.
    /// </summary>
    /// <param name="date">The date for which the amount is specified.</param>
    /// <param name="amount">The sales amount.</param>
    public SalesData(DateTime date, decimal amount) {
        this.date = date;
        this.amount = amount;
    }

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Gets the sales amount.
    /// </summary>
    /// <value>The sales amount.</value>
    public decimal Amount {
        get {
            return amount;
        }
    }

    /// <summary>
    /// Gets the date for which the amount is specified.
    /// </summary>
    /// <value>The date for which the amount is specified.</value>
    public DateTime Date {
        get {
            return date;
        }
    }

}
​Public Class SalesData

    Private amount_Renamed As Decimal
    Private date_Renamed As DateTime

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' OBJECT
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Initializes a new instance of the <c>SalesData</c> class.
    ''' </summary>
    ''' <param name="date">The date for which the amount is specified.</param>
    ''' <param name="amount">The sales amount.</param>
    Public Sub New(ByVal [date] As DateTime, ByVal amount As Decimal)
        Me.date_Renamed = [date]
        Me.amount_Renamed = amount
    End Sub

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Gets the sales amount.
    ''' </summary>
    ''' <value>The sales amount.</value>
    Public ReadOnly Property Amount() As Decimal
        Get
            Return amount_Renamed
        End Get
    End Property

    ''' <summary>
    ''' Gets the date for which the amount is specified.
    ''' </summary>
    ''' <value>The date for which the amount is specified.</value>
    Public ReadOnly Property [Date]() As DateTime
        Get
            Return date_Renamed
        End Get
    End Property

End Class

We can specify that the Y values should be pulled from the Amount property by setting YPath to "Amount". If we want to use the index in the collection as our X values, then we do not need to set XPath.

If instead we want the X values to be pulled from the Date property, then we would need to set XPath to "Date".

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Pie Chart Features
Overview

Pie charts have several features that allow you to customize their function and appearance to meet your needs.

Customizing Appearance

Several properties allow you to change the colors used for the pie slices, along with other elements in pie charts.

See the Customizing Appearance topic for more information.

Donut Chart

Donut charts act just like pie charts, except for an adjustable donut hole in the center of the chart.

See the Donut Chart topic for more information.

Legend

A legend can provide context for what each pie slice represents. Legends are fully stylable to match the look and feel of your application.

See the Legend topic for more information.

Multiple Series

Pie charts and donut charts can contain multiple series, displayed as cocentric rings. They also support heirarchical data, displaying a child ring outside or inside the parent.

See the Multiple Series topic for more information.

'Other' Slice

Small slices can be aggregated into an 'Other' slice. This can be based on a numeric threshold or a percentage.

See the 'Other' Slice topic for more information.

Pie Slice Labels

Labels can be displayed on each pie slice and fully customized.

See the Pie Slice Labels topic for more information.

Specifying Items

Pie / donut charts can be bound to any custom data source as long as it contains a numeric value to determine pie slice percentages from.

See the Specifying Items topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customizing Appearance

Pie Chart Features
Customizing Appearance

Several properties allow you to change the colors used for the pie slices, along with other elements in pie charts.

This topic contains these sections:

  • Built-In Palettes
  • Custom Palettes
  • Chart Border
  • Chart Background

Built-In Palettes

Style selectors determine what style will be applied to each pie slice. To change the style selector, set PieSeries.SliceStyleSelector to an instance of PieSlicePaletteStyleSelector, or a custom implementation of IPieSliceStyleSelector.

PieSlicePaletteStyleSelector contains several built-in palettes to make styling your pie chart or donut chart easier. The full list can be found in the PaletteKind enumeration.

A built-in palette can be assigned to a pie / donut chart like this (in this case the Roman palette):

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries>
        <charts:PieSeries.SliceStyleSelector>
            <charts:PieSlicePaletteStyleSelector>
                <charts:Palette Kind="Roman"/>
            </charts:PieSlicePaletteStyleSelector>
        </charts:PieSeries.SliceStyleSelector>
    </charts:PieSeries>
</charts:PieChart>

Custom Palettes

Custom palettes can be assigned by specifying your own colors on an instance of Palette.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries>
        <charts:PieSeries.SliceStyleSelector>
            <charts:PieSlicePaletteStyleSelector>
                <charts:Palette>
                    <Color>#FFFF00</Color>
                    <Color>#00FFFF</Color>
                    <Color>#FF00FF</Color>
                    <Color>#00FF00</Color>
                    <Color>#FF0000</Color>
                    <Color>#0000FF</Color>
                </charts:Palette>
            </charts:PieSlicePaletteStyleSelector>
        </charts:PieSeries.SliceStyleSelector>
    </charts:PieSeries>
</charts:PieChart>

Chart Border

The color and thickness of a pie / donut chart border can be changed using the PieChart.BorderBrush and PieChart.BorderThickness properties, respectively.

XAML
Copy
​<charts:PieChart BorderBrush="DarkSlateGray" BorderThickness="3"/>

Chart Background

The color of a pie / donut chart background can be changed using the PieChart.Background property.

XAML
Copy
​<charts:PieChart Background="DimGray"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Donut Chart

Pie Chart Features
Donut Chart

Donut charts act just like pie charts, except for an adjustable donut hole in the center of the chart. DonutChart is a subclass of PieChart, so all pie chart documentation also applies to donut chart.

This topic contains these sections:

  • Specifying Hole Radius

Specifying Hole Radius

The hole radius of a donut chart can be specified by changing DonutChart.HoleRadiusPercentage. HoleRadiusPercentage determines what percentage of the DonutChart is consumed by the donut hole, from 0.0 (0%) to 1.0 (100%).

A donut chart with a donut hole radius at 80%:

XAML
Copy
​<charts:DonutChart HoleRadiusPercentage="0.8"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Legend

Pie Chart Features
Legend

A legend can provide context for what each pie slice represents. Legends are fully stylable to match the look and feel of your application.

This topic contains these sections:

  • Getting Started
  • Legend Position
  • Styling Legend
  • Legend Item Customization

Getting Started

The legend will display the title of each pie slice in the pie chart, along with the color of each pie slice as a key in the legend. To display a legend on a pie / donut chart, set PieChart.IsLegendVisible to true.

XAML
Copy
​<charts:PieChart IsLegendVisible="true"/>

Legend Position

The position of the legend can be controlled using PieChart.LegendHorizontalPosition and PieChart.LegendVerticalPosition. Legend positions have two modifiers, Inside and Outside (for example, LeftInside and TopOutside.

Inside means the legend will be positioned within the pie chart drawing area and may overlap labels and other elements. Outside means the legend will be positioned outside of the pie chart drawing area and space will be made so that it does not overlap the pie chart or labels.

This is a legend displayed at TopInside and RightInside. Note how it overlaps other elements on the pie chart.

XAML
Copy
​<charts:PieChart LegendVerticalPosition="TopInside" LegendHorizontalPosition="RightInside"/>

This is a legend displayed at TopInside and RightOutside. Note how room is made to place the legend on the right, outside the chart.

XAML
Copy
​<charts:PieChart LegendVerticalPosition="TopInside" LegendHorizontalPosition="RightOutside"/>

Legend position can also be fine-tuned using PieChart.LegendMargin. LegendMargin is a Thickness that determines how the legend is placed after PieChart.LegendHorizontalPosition and PieChart.LegendVerticalPosition are applied.

This is a legend displayed at TopInside and RightInside, with a LegendMargin of 0,40,0,0. Note how the legend is placed 40 pixels lower than it normally would be without the margin.

XAML
Copy
​<charts:PieChart LegendVerticalPosition="TopInside"
                        LegendHorizontalPosition="RightInside" LegendMargin="0,40,0,0"/>

Styling Legend

The legend can be styled using PieChart.LegendStyle. The style you provide should have a TargetType of ItemsControl.

This is an example of providing a custom LegendStyle.
XAML
Copy
​<charts:PieChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="BorderBrush" Value="LightGray"/>
        <Setter Property="BorderThickness" Value="3"/>
        <Setter Property="Background">
            <Setter.Value>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#222222" Offset="0.0"/>
                    <GradientStop Color="#444444" Offset="0.2"/>
                    <GradientStop Color="#444444" Offset="0.8"/>
                    <GradientStop Color="#222222" Offset="1.0"/>
                </LinearGradientBrush>
            </Setter.Value>
        </Setter>
        <Setter Property="Padding" Value="10"/>
        <Setter Property="Effect">
            <Setter.Value>
                <DropShadowEffect Opacity="0.5"/>
            </Setter.Value>
        </Setter>
        <Setter Property="FontFamily" Value="Trebuchet MS"/>
        <Setter Property="FontWeight" Value="Normal"/>
        <Setter Property="FontStyle" Value="Italic"/>
        <Setter Property="FontSize" Value="14"/>
        <Setter Property="Foreground" Value="White"/>
    </Style>
</charts:PieChart.LegendStyle>

Legend Item Customization

Each individual legend item can be retemplated by setting ItemTemplate in PieChart.LegendStyle. The data source for the template is LegendKey, allowing you to bind to properties from the template such as LegendKey.Label and LegendKey.LegendMarkerStyle.

This is an example of providing a custom LegendStyle to retemplate the legend items.
XAML
Copy
​<charts:PieChart.LegendStyle>
    <Style TargetType="ItemsControl">
        <Setter Property="ItemTemplate">
            <Setter.Value>
                <DataTemplate>
                    <Border Padding="5,0">
                        <StackPanel Orientation="Horizontal">
                            <charts:ChartMarker Margin="0,0,5,0" Style="{Binding LegendMarkerStyle}" BorderBrush="#333333" ShapeKind="Star5Points" Width="15" Height="15" />
                            <TextBlock Text="{Binding Label}" Foreground="#111111" FontFamily="Arial" FontSize="16"/>
                        </StackPanel>
                    </Border>
                </DataTemplate>
            </Setter.Value>
        </Setter>
    </Style>
</charts:PieChart.LegendStyle>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple Series

Pie Chart Features
Multiple Series

Pie charts and donut charts can contain multiple series, displayed as cocentric rings. They also support hierarchical data, displaying a child ring outside or inside the parent.

This topic contains these sections:

  • Stacked Pie Series
  • Child (Hierarchical) Pie Series

Stacked Pie Series

To display multiple pie series, simply specify them as PieChart.Content the same way you would specify a single pie series:

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="[...]"/>
    <charts:PieSeries ItemsSource="[...]"/>
</charts:PieChart>

The size of pie series can be adjusted using the PieSeries.Length property. This is a number that is relative to the other pie series on the chart. If there are two pie series with a length of 1.0, both pie series will display at 50%. In the example below, one pie series has a length of 1.0 and the other 3.0. Because of this, one will display at 25% and the other at 75%.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries Length="1" ItemsSource="[...]"/>
    <charts:PieSeries Length="3" ItemsSource="[...]"/>
</charts:PieChart>

Child (Hierarchical) Pie Series

Data can be displayed hierarchically, so that inside or outside of each pie slice there are child slices. To display children, you must set PieSeries.ChildrenPath. ChildrenPath is a property path to an item on your data source that contains an IEnumerable of child items. At a minimum, children must have values, so PieSeries.ChildSliceValuePath must be set as well, and resolve to a numeric value.

There are numerous properties on PieSeries that have a matching counterpart for child slices: ChildLabelBrush, ChildLabelPosition, ChildLabelStyle, ChildSliceLabelFormat, ChildSliceLabelFunc, ChildSliceTitlePath, and ChildSliceValuePath are all properties that have a matching counterpart for parent pie slices. Consult the relevant sections at Pie Chart Features to understand how these properties work.

Example

As an example, let's say we have an IEnumerable of Person for our PieSeries.ItemsSource.

C#
VB
Copy
​public class Person {
    public string Name { get; set; }
    public double Income { get; set; }
    public IEnumerable<Person> Employees { get; set; }
}
​Public Class Person
    Public Property Name() As String
    Public Property Income() As Double
    Public Property Employees() As IEnumerable(Of Person)
End Class
Our IEnumerable of Person is called People, and we set it as our data source:
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" SliceValuePath="Income" SliceTitlePath="Name"/>
</charts:PieChart>
Note how the Person class has a Employees property, which is also an IEnumerable of Person. Let's use that as our child data source for each pie slice. We also need to set the ChildSliceValuePath and the ChildSliceTitlePath.
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" ChildrenPath="Employees"
                      SliceValuePath="Income" SliceTitlePath="Name"
                      ChildSliceValuePath="Income" ChildSliceTitlePath="Name"
                      Length="5" ChildrenLength="1" [...]/>
</charts:PieChart>
Now we can see each child as a slice under the parent:

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


'Other' Slice

Pie Chart Features
'Other' Slice

Small slices can be aggregated into an 'Other' slice. This can be based on a numeric threshold or a percentage.

This topic contains these sections:

  • Specifying Threshold

Specifying Threshold

To aggregate smaller slices into an 'Other' slice, you can set PieSeries.OtherThreshold. If PieSeries.IsOtherThresholdPercent is set to true, then OtherThreshold will represent a percentage between 0.0 (0%) and 1.0 (100%). If set to false, then OtherThreshold will represent a numeric value. All values below this threshold will get aggregated into an 'Other' slice.

In this example, all values below 6% are aggregated into an 'Other' slice.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries IsOtherThresholdPercent="true" OtherThreshold="0.6"/>
</charts:PieChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Pie Slice Labels

Pie Chart Features
Pie Slice Labels

Labels can be displayed on each pie slice and fully customized.

This topic contains these sections:

  • Customizing Labels
  • Label Position
  • Label Inside Fit Mode
  • Label Appearance

Customizing Labels

Label Format

Pie slice labels by default display percentage only. They can be customized using PieSeries.SliceLabelFormat and PieSeries.ChildSliceLabelFormat. This is a format string with three parameters:

  • {0} - The percentage of the pie slice, between 0.0 (0%) and 1.0 (100%).
  • {1} - The original value of the pie slice.
  • {2} - The title of the pie slice.

In this example, the pie slice label is configured to show all three parameters, with the first parameter displayed in percent formatting. Note a couple things of interest: the :P0 used to format the first parameter as a percent, the opening angle brackets used to escape future angle brackets in the string, and the &#x0a; used to add new lines in XAML.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries SliceLabelFormat="{}{2}
{1} ({0:P0})" AreLabelsVisible="True"/>
</charts:PieChart>

Label Func

In some cases, PieSeries.SliceLabelFormat may be too limited. Some labels may require additional customization that can not be done using standard .NET format strings. In this case, you may provide a custom function that will allow you to fully customize pie slice labels with PieSeries.SliceLabelFunc and PieSeries.ChildSliceLabelFunc. The function must match the signature string MethodName(double, object, string). The label function takes in percentage, original value, and title as parameters, and returns the desired label.

In this example, SliceLabelFunc is bound to a function in the code behind.

C#
Copy
​public MainControl() {
    CustomLabelFunc = GetLabel;
    DataContext = this;
    InitializeComponent();
}

public Func<double, object, string, string> CustomLabelFunc { get; set; }

public static string GetLabel(double percent, object originalValue, string title) {
    string format = "{0}";
    if (percent < 0.1)
        format = "{0} - LOW";

    return string.Format(format, title.ToUpper());
}
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries SliceLabelFunc="{Binding CustomLabelFunc}"/>
</charts:PieChart>

Label Position

By default, labels are displayed on the inside of each pie slice. They can also be displayed on the outside of the chart by setting PieSeries.LabelPosition to PieSliceLabelPosition.Sides. This will place the labels in one of two columns on either side of the pie chart.

Pie slice labels positioned on the insides of the pie slices.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelPosition="Inside"/>
</charts:PieChart>

Pie slice labels positioned on the sides of the pie chart.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelPosition="Sides"/>
</charts:PieChart>

Label Inside Fit Mode

When labels are positioned inside pie slices, they will automatically be hidden if they overlap the pie slice. To disable this, you can set PieSeries.LabelInsideFitMode to PieSliceLabelInsideFitMode.None. This will display all labels regardless of whether or not they fit inside the pie slice.

Labels hidden when they do not fit inside pie slices.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelInsideFitMode="Hide"/>
</charts:PieChart>

Labels always shown, even if they do not fit inside pie slices.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelInsideFitMode="None"/>
</charts:PieChart>

Label Appearance

Label Color

To set the same label color for the entire pie chart, you can simply set PieChart.Foreground. To set different label colors for different pie series, set PieSeries.LabelBrush and PieSeries.ChildLabelBrush.

This example shows a different color set on parent and child pie slice labels.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries LabelPosition="Inside" ChildLabelPosition="Sides"
                      ChildrenPosition="Outside"
                      AreLabelsVisible="True" AreChildLabelsVisible="True"
                      LabelBrush="White" ChildLabelBrush="Black"
                      [...]/>
</charts:PieChart>

Label Style

For more advanced customization, you can set PieSeries.LabelStyle and PieSeries.ChildLabelStyle. The style must have a TargetType of TextBlock.

This example shows a custom style applied to pie slice labels.

XAML
Copy
​<charts:PieChart>
    <charts:PieSeries>
        <charts:PieSeries.LabelStyle>
            <Style TargetType="TextBlock">
                <Setter Property="FontSize" Value="20"/>
                <Setter Property="FontStyle" Value="Italic"/>
            </Style>
        </charts:PieSeries.LabelStyle>
    </charts:PieSeries>
</charts:PieChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Specifying Items

Pie Chart Features
Specifying Items

Pie / donut charts can be bound to any custom data source.

This topic contains these sections:

  • Getting Started
  • Setting Value Path
  • Setting Title Path

Getting Started

To set a data source, set the PieSeries.ItemsSource property. This is an IEnumerable of whatever your items are. Each item will represent a pie slice.

Setting Value Path

The value path is a property path that points to a numeric property on the items in your ItemsSource that will be used to determine how large the pie slice is in relation to the other pie slices. You must set SliceValuePath to use pie chart correctly.

As an example, let's say we have an IEnumerable of Person for our PieSeries.ItemsSource.

C#
VB
Copy
​public class Person {
    public string Name { get; set; }
    public double Income { get; set; }
}
​Public Class Person
    Public Property Name() As String
    Public Property Income() As Double
End Class
Our IEnumerable of Person is called People, and we set it as our data source:
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" SliceValuePath="Income" AreLabelsVisible="True"/>
</charts:PieChart>

Note Note
The value path must point to a property with a numeric type (double, int, decimal, etc) or an exception will be thrown.
Note Note
Negative values will be treated as zero (0).
Setting Title Path

The value path is a property path that points to a property on the items in your ItemsSource that will be used to determine what the title of the pie slice is. The title is, by default, displayed on the pie chart legend, but also can optionally be displayed on the pie chart label.

Using the previous example of Person:

C#
VB
Copy
​public class Person {
    public string Name { get; set; }
    public double Income { get; set; }
}
​Public Class Person
    Public Property Name() As String
    Public Property Income() As Double
End Class
We can set our title as the person's name and use a custom label format to display it:
XAML
Copy
​<charts:PieChart>
    <charts:PieSeries ItemsSource="{Binding People}" SliceValuePath="Income" SliceTitlePath="Name" SliceLabelFormat="{}{2} - {0:P0}" AreLabelsVisible="True"/>
</charts:PieChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Charts Reference
Designer Interaction

Charts has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create your charts and series.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • XYChart Context Menu
  • Task Pane Introduction
  • XYChart Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

XYChart Context Menu

A context menu for the XYChart control is provided. You can right click on the control in the designer to display the context menu.

A XYChart context menu in the Visual Studio designer

Use the context menu options to add new series or remove all the series in a chart.

Task Pane Introduction

Whenever you select a XYChart control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

XYChart Task Pane

Use the task pane options to add, remove, or arrange series, configure tha axes, set the baseline, and enable hot tracking.

The XYChart task pane provides quick access for adding, removing, or arranging series. It can also be used to configure the axes, baseline, hot tracking, and style selector.

The task pane for the XYChart control in the Visual Studio designer

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Docking & MDI Reference
Overview

Actipro Docking & MDI is a complete solution for easily adding a docking tool window and/or multiple document interface to your applications.

Docking windows and tabbed MDI provided by this product

Docking & MDI has been implemented with flexibility in mind. It has more options than nearly any other competitive product out there, including enhanced MVVM support. While it supports all the types of standard layouts you find in most docking window products, it also supports some extended functionality such as: floating document areas, nested dock sites (a self-contained set of docking windows within another docking window), side-by-side dock sites (two or more self-contained sets of docking windows next to each other), linked dock sites (two or more self-contained sets of docking windows whose windows can be moved to either site), tool window inner fill (no workspace area), tabbed and standard MDI styles, custom workspace content, total control over docking window capabilities and appearance, fluid animations, and much more.

Features

MVVM Features

  • Bind to separate document and tool view-model collections.
  • Bind to VM properties to open, close, activate, and change the state of docking windows.
  • Fully customizable styles and data templates for both document and tool windows.
  • Can be optionally used in conjunction with non-MVVM defined document and tool windows.

Docking Window Features

  • Document windows that remain in MDI but can be floated.
  • Tool windows that can be docked, auto-hidden, floated, or moved into MDI.
  • Auto-hidden tool windows show as tabs along the outer edge of a dock host and show a popup when clicked.
  • Create nested hierarchies of tool windows within a dock site or in a separate floating windows.
  • Resize any control via the use of built-in splitters.
  • Rich object model for opening, closing, and repositioning docking windows anywhere in a layout.
  • Tons of global options for controlling everything from whether windows can drag to whether tool windows have options buttons.
  • Window-specific instance overrides for nearly all global options.
  • Multiple ways to designate preferences for initial dock location when a docking window is opened.
  • Ability to customize all context and drop-down menus.
  • Multiple Ctrl+Tab switcher types, including one with a Visual Studio-like interface.
  • Dock guides that make selecting document and tool window drop target locations easier.
  • Drag to reorder windows within a tab group.
  • Dragging floating windows can snap next to other floating windows using magnetism features. Also works for documents in standard MDI mode.
  • Numerous centralized docking window-related events.

Appearance Features

  • Subtle fluid animations that occur throughout use of the product.
  • Ability to create hosted floating windows that can fade out with inactivity.
  • Create tool windows that don't have a title bar and/or cannot be moved.
  • An implementation of a control that mimics a standard Window but can be used in any control context.
  • Specify custom contextual content (status indicators, buttons, etc.) within tabs or title bars.
  • Tint specific docking window tabs.
  • Built-in tab flashing capabilities to grab attention.

Workspace and MDI Features

  • Ability to host any sort of custom content in a workspace area.
  • Tabbed MDI support that is capable of multi-directional hierarchies of documents.
  • Tabbed MDI options like tab images and tab placement on any side.
  • Document tabs can be rendered as pinned, normal, or preview tabs.
  • Optional new tab button in the tab well.
  • Built-in read-only document glyph display.
  • Standard MDI that supports a windowed approach to managing documents.
  • Cascade, tile horizontally, and tile vertically documents.

Layout, Globalization, and Accessibility Features

  • Full support for nested and side-by-side dock sites.
  • Dock sites can be linked, which allows windows to be dragged from one dock site to another.
  • Tool window inner-fill mode supported.
  • Complete tool window layout save/load capabilities, for persisting end user customizations.
  • Layout logic does its best to adhere to optional specified desired, minimum, and maximum container sizes.
  • Size-to-content support for floating windows and standard MDI documents when displayed.
  • Use any pointer such as mouse, touch, or pen to interact with docking windows.
  • AdvancedTabControl control included that extends the standard TabControl with powerful capabilities.
  • Right-to-left support is fully integrated for languages such as Hebrew or Arabic.
  • All text properties use localization attributes, and string resources may be customized.
  • Follows the standard accessibility model for UI automation.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Docking & MDI Reference
Getting Started

Getting up and running with Docking & MDI controls is extremely easy.

This topic's information will assume you are using Visual Studio to write your XAML code for control that will contain docking windows and/or MDI.

This topic contains these sections:

  • Add Extension SDK Reference
  • Getting Started with Docking & MDI
  • Further Study

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Getting Started with Docking & MDI

This 'xmlns' declaration in your root XAML control allows access to the various controls in this product:

XAML
Copy
​xmlns:docking="using:ActiproSoftware.UI.Xaml.Controls.Docking"

This code shows the base XAML that you can use to create a simple docking window layout with several windows:

XAML
Copy
​<docking:DockSite>
    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost>
                <docking:TabbedMdiContainer>
                    <docking:DocumentWindow Title="Document1.txt" Description="Text document" FileName="Document1.rtf">
                        <TextBox BorderThickness="0" TextWrapping="Wrap" Text="This is a document window." />
                    </docking:DocumentWindow>
                </docking:TabbedMdiContainer>
            </docking:TabbedMdiHost>
        </docking:Workspace>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 1" />
            <docking:ToolWindow Title="Tool Window 2" />
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>

This code shows the base XAML that you can use to create a simple docking window layout that leverages MVVM support:

XAML
Copy
​<docking:DockSite DocumentItemsSource="{Binding DocumentItems}" DocumentItemContainerStyle="..."
            ToolItemsSource="{Binding ToolItems}" ToolItemContainerStyle="...">
    <docking:Workspace>
        <docking:TabbedMdiHost />
    </docking:Workspace>
</docking:DockSite>
Several ways of opening the windows are shown in the MVVM examples found in our Sample Browser.

Further Study

There are fair number of controls and concepts to understand when working with this product. We encourage you to at a minimum, read through the Term Definitions and Control Hierarchy topics since they cover some essential things to know.

Also, please run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of the controls.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Term Definitions

Docking & MDI Reference
Term Definitions

There are some key terms and concepts to understand when working with this product. This topic defines all of the docking-related terms.

This topic contains these sections:

  • General Terms
  • Lifecycle Terms
  • State Terms
  • Container Terms

General Terms

Term | Description
Docking Window | A docking window (represented by the DockingWindow class) is a general term that could mean either a tool window or a document window, since both of those inherit the base docking window functionality.
Dock Site | A dock site (represented by the DockSite class) is the root control that contains a tool window hierarchy and/or MDI, and provides management functionality for all contained docking-related controls.
Document | A document is a docking window (either a document window or tool window) that is within the MDI area.
Document Window

A document window (represented by the DocumentWindow class) is a docking window that is restricted to only be used within a MDI area.

By default it is destroyed after it is closed, however this behavior can be changed.

Floating | Floating is where you have a floating dock host that contains one or more tool windows or a secondary MDI area, and is able to be moved anywhere above the dock site's control hierarchy.
MDI

MDI stands for Multiple Document Interface, meaning the method with which documents can be visually interacted by the end user.

The two built-in types of MDI are Tabbed MDI and Standard MDI.

MVVM

MVVM stands for Model View ViewModel and is a design pattern used to build applications where the logic is separated from the user interface, testability is increased, as well as other benefits.

Nested Dock Sites

Nested dock sites is when you have one DockSite that is contained within a docking window that belongs to a parent DockSite.

In this scenario, the docking windows may only be moved within their respective owner dock sites.

Standard MDI | Standard MDI (implemented via the StandardMdiHost class and its children) is the windowed variation of MDI, where each document is represented by a window that can be moved around within the workspace. Windows can be cascaded or tiled.
Tabbed MDI | Tabbed MDI (implemented via the TabbedMdiHost class and its children) is where the full size of the workspace is filled with one or more tabbed containers, with each tab representing a document. Windows can be cascaded or tiled.
Tool Window

A tool window (represented by the ToolWindow class) is a docking window that can be used in a number of states, including within the MDI area.

Tool windows usually continue to exist after being closed and can be reactivated later.

Tool Window Inner-Fill | Tool window inner-fill occurs when there is no Workspace within a DockSite, and the dock site hierarchy consists only of tool windows that fill its content area.
Workspace

A workspace (represented by the Workspace class) is the area around which tool windows may be docked.

If the workspace's content is a TabbedMdiHost, then tabbed MDI is in use. If the workspace's content is a StandardMdiHost, then standard MDI is in use. The workspace's content can be set to anything else when MDI is not needed and custom content should be displayed.

By not including a workspace within a DockSite hierarchy, tool window inner-fill mode is activated.

Lifecycle Terms

Term | Description
Activate | Ensure that a docking window is open, its contents are visible, and optionally allows focus to be set. If the activated window is represented by a tab, it will become the selected tab in the parent container.
Close | Remove a docking window from the dock site hierarchy so that it is no longer accessible.
Closed | When a docking window is not currently accessible in the dock site hierarchy.
Open | Ensure that a docking window is accessible in the dock site hierarchy, although its contents may not necessarily be visible such as when it is represented by an unselected tab.
Opened | When a docking window is currently accessible in the dock site hierarchy, although its related tab may or may not currently be selected. In the latter case, clicking the tab ensures the window's contents are visible.
Selected | When a docking window is opened and represented by a tab that is currently selected.

State Terms

Term | Description
Auto-Hide | When a tool window's tab appears along the outer edge of a dock host. Clicking the tab makes the tool window's content slide into view. Tool windows that are auto-hidden within a floating dock host are still considered to be in an auto-hide state. This state only applies tool windows.
Docked | When a tool window is docked somewhere within a dock host hierarchy, but not in MDI. Tool windows that are docked within a floating dock host are still considered to be in a docked state. This state only applies tool windows.
Document | When a docking window is within the MDI area. Docking windows that are in the MDI area of a floating dock host are still considered to be in a document state. This state applies to both tool and document windows.

Container Terms

Term | Description
Dock Host | A dock host (represented by the DockHost class) is the actual root hierarchy container. A primary dock host is implicitly created within a dock site, while other dock hosts are created behind-the-scenes whenever docking windows are floated. Dock hosts should never be explicitly created by you.
Split Container | A split container (represented by the SplitContainer class) is used to hold one or more other docking containers and provide splitter-based resizing capabilities between them. Split containers can be oriented horizontally or vertically.
Standard MDI Host | A standard MDI host (represented by the StandardMdiHost class) is the root container for standard MDI implementation, that is placed as the direct child of a workspace.
Tabbed MDI Container | A tabbed MDI container (represented by the TabbedMdiContainer class) is the direct parent of one or more docking windows that are in tabbed MDI.
Tabbed MDI Host | A tabbed MDI host (represented by the TabbedMdiHost class) is the root container for tabbed MDI implementation, that is placed as the direct child of a workspace.
Tool Window Container

A tool window container (represented by the ToolWindowContainer class) is the direct parent of one or more tool windows that are docked or auto-hidden.

This container provides a title area displaying the selected tool window's title. When more than one tool windows are included, it also contains tabs for selecting the other tool windows.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Control Hierarchy

Docking & MDI Reference
Control Hierarchy

Since a number of controls are involved in creating a docking window and MDI hierarchy, this topic delves into what can be contained by what in your XAML.

Note Note
When creating a layout programmatically (not in XAML), refer to some of the other topics in this documentation.

This topic contains these sections:

  • DockSite Hierarchy
  • Tabbed MDI Hierarchy
  • Standard MDI Hierarchy

DockSite Hierarchy

The DockSite is always the root control in a docking window and/or MDI hierarchy. It implicitly creates a primary DockHost within its template. The DockSite has a single child control that becomes the child control of the primary DockHost in the template.

A DockSite hierarchy diagram

Child Content

The DockSite.Child can be one of the following:

  • SplitContainer
  • ToolWindowContainer
  • Workspace

Each SplitContainer has an Orientation property that indicates whether the splits are horizontal or vertical. SplitContainer objects can be nested to create complex hierarchies. SplitContainer children can be one of the following:

  • SplitContainer
  • ToolWindowContainer
  • Workspace

ToolWindowContainer controls contain one or more ToolWindow controls and provide a title bar and tabs for selecting between tool windows.

Workspace defines the area around which tool window can be docked. If no Workspace is included within the hierarchy, tool window inner-fill mode is activated. A Workspace control has a single child. If the Workspace .Content is a TabbedMdiHost, tabbed MDI is activated. If the Workspace .Content is a StandardMdiHost, standard MDI is activated.

This example shows two attached tool windows docked on the right side of a workspace with empty tabbed MDI:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost />
        </docking:Workspace>

        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 1" />
            <docking:ToolWindow Title="Tool Window 2" />
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>

Auto-Hide Configuration

To add tool windows into an auto-hide state, use the four auto-hide properties:

  • DockSite.AutoHideLeftContainers
  • DockSite.AutoHideTopContainers
  • DockSite.AutoHideRightContainers
  • DockSite.AutoHideBottomContainers
Each of those accepts one or more ToolWindowContainer controls, each of which can contain one or more ToolWindow controls.

This example shows two tool windows docked vertically on the right side of a workspace with empty tabbed MDI, and an auto-hidden tool window on the left:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:DockSite.AutoHideLeftContainers>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 3" />
        </docking:ToolWindowContainer>
    </docking:DockSite.AutoHideLeftContainers>

    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost />
        </docking:Workspace>

        <docking:SplitContainer Orientation="Vertical">
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 1" />
            </docking:ToolWindowContainer>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 2" />
            </docking:ToolWindowContainer>
        </docking:SplitContainer>
    </docking:SplitContainer>
</docking:DockSite>

Tabbed MDI Hierarchy

When the Workspace .Content is a TabbedMdiHost, tabbed MDI mode is activated. Tabbed MDI is where the full size of the workspace is filled with one or more tabbed containers, with each tab representing a document. Windows can be cascaded or tiled.

A tabbed MDI hierarchy diagram

The TabbedMdiHost control has a single child, which can be one of the following:

  • SplitContainer
  • TabbedMdiContainer

Each SplitContainer has an Orientation property that indicates whether the splits are horizontal or vertical. SplitContainer objects can be nested to create complex hierarchies. SplitContainer children can be one of the following:

  • SplitContainer
  • TabbedMdiContainer

TabbedMdiContainer controls contain one or more ToolWindow and/or DocumentWindow controls and provide tabs for selecting between the documents.

This example shows a single document open in tabbed MDI:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:Workspace>
        <docking:TabbedMdiHost>
            <docking:TabbedMdiContainer>
                <docking:DocumentWindow Title="Document1.txt" Description="Text document" FileName="Document1.rtf">
                    <TextBox BorderThickness="0" TextWrapping="Wrap" Text="This is a document window." />
                </docking:DocumentWindow>
            </docking:TabbedMdiContainer>
        </docking:TabbedMdiHost>
    </docking:Workspace>
</docking:DockSite>

Standard MDI Hierarchy

When the Workspace .Content is a StandardMdiHost, standard MDI mode is activated. Standard MDI is the windowed variation of MDI, where each document is represented by a window that can be moved around within the workspace. Windows can be cascaded or tiled.

A standard MDI hierarchy diagram

The StandardMdiHost control contains one or more ToolWindow and/or DocumentWindow controls. It renders each document as a window.

This example shows a single document open in standard MDI:

XAML
Copy
​xmlns:docking="http://schemas.actiprosoftware.com/winfx/xaml/docking"
...

<docking:DockSite>
    <docking:Workspace>
        <docking:StandardMdiHost>
            <docking:DocumentWindow Title="Document1.txt" Description="Text document" FileName="Document1.rtf">
                <TextBox BorderThickness="0" TextWrapping="Wrap" Text="This is a document window." />
            </docking:DocumentWindow>
        </docking:StandardMdiHost>
    </docking:Workspace>
</docking:DockSite>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Docking & MDI Docking Window Features
Overview

There are an enormous feature set in Actipro Docking & MDI related to docking windows.

Docking Window States

There are three states in which docking windows can be: auto-hide, docked, and document. Docking windows can be in these states even when they are in a floating dock host.

See the Docking Window States topic for more information.

Lifecycle and Docking Management

The lifecycle of a docking window includes its creation, specifying initial size and/or size restrictions, providing a default open location, opening, moving to various states, docking to various locations, closing, and destruction. This topic covers how to perform all of those operations.

See the Lifecycle and Docking Management topic for more information.

Docking Window Capabilities

One of the best features of Actipro Docking & MDI is the number of options that are available to you as a developer. Many options control the behaviors and capabilities of the docking windows and can be set at a global level as well as at a docking window instance level.

See the Docking Window Capabilities topic for more information.

Docking Window Events

There are a number of events to which you can attach to know when various actions occur to docking windows.

See the Docking Window Events topic for more information.

Docked Tool Windows

Tool windows in docked state appear docked in containers around an optional workspace within their dock host. When two or more tool windows are in the same container, tabs allow for selecting which one is visible.

See the Docked Tool Windows topic for more information.

Auto-Hidden Tool Windows

Tool windows in auto-hide state show tabs along a tray area on the side of their dock host. When a tab is clicked, the related tool window's content is displayed in an animated popup.

See the Auto-Hidden Tool Windows topic for more information.

Floating Dock Hosts

Docking windows can be dragged to float, meaning appear in a floating dock host that can move independently above the dock site's primary dock host.

See the Floating Dock Hosts topic for more information.

Contextual Content

Contextual content, such as buttons or status indicators, can be displayed throughout the docking window UI within tabs and title bars.

See the Contextual Content topic for more information.

Fixed Tool Windows

By turning off various options on a specific tool window, you can completely prevent it from being moved and can keep it "fixed" within a tool window layout, while still allowing other tool windows to be docked around it.

See the Fixed Tool Windows topic for more information.

Menu Customization

All context menus displayed by this product can be customized or replaced entirely before they are shown to the end user.

See the Menu Customization topic for more information.

Switchers

Switchers are used during Ctrl+Tab, etc. key presses to easily navigate between open documents and tool windows.

See the Switchers topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docking Window States

Docking & MDI Docking Window Features
Docking Window States

There are three states in which docking windows can be: auto-hide, docked, and document. Docking windows can be in these states even when they are in a floating dock host. These states are represented by the DockingWindowState enumeration.

Document windows can only be in the Document state, while tool windows are more flexible and can be in any of the three states.

Note Note
See the Floating Dock Hosts topic for an explanation of why there is no specific floating state.

This topic contains these sections:

  • The AutoHide State
  • The Docked State
  • The Document State
  • State Changes

The AutoHide State

A tool window is in auto-hide state when its tab appears along one of four outer edges of a dock host. Clicking the tab makes the tool window's content slide into view using a quick animation. The content remains visible while it has focus. When the focus leaves the content area or when the tab is clicked again, the tool window slides back out of view, while its tab remains visible.

The Solution Explorer tool window in AutoHide state with its popup displayed

The AutoHide state is only available to tool windows. Auto-hide is always supported in the primary dock host, and is only supported in floating dock hosts that have a workspace visible.

The Docked State

A tool window is considered Docked when it is within a dock host hierarchy but not in auto-hide and not in MDI (the document area).

The Solution Explorer tool window in Docked state

The Docked state is only available to tool windows. Tool windows that are dragged to float are considered in a Docked state in their containing floating dock host.

The Document State

A docking window is in Document state when it is within the MDI area. It could be a tab in tabbed MDI or a window in standard MDI.

The Solution Explorer tool window in Document state (tabbed MDI)

The Solution Explorer tool window in Document state (standard MDI)

The Document state is available to both tool and document windows. Documents that are dragged to float will create a MDI host in their containing floating dock host.

State Changes

The DockingWindow.State property can be set to alter where the docking window is located. Note that setting the state will not automatically open the docking window if it currently closed. It is designed this way so that the state can be set and other properties configured prior to the open occuring, which can be done by setting the IsOpen property to true, setting the IsActive property to true, calling the Open method, or calling the Activate method.

The DockSite.WindowsStateChanged event can be used to detect changes to the DockingWindow.State property of the various registered windows. This event may fire once for a group of docking windows that change state together, with the event arguments containing the list of affected docking windows.

Alternatively, the DockingWindow.OnStateChanged virtual method can be overridden by custom window classes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lifecycle and Docking Management

Docking & MDI Docking Window Features
Lifecycle and Docking Management

The lifecycle of a docking window includes its creation, specifying initial size and/or size restrictions, providing a default open location, opening, moving to various states, docking to various locations, closing, and destruction. This topic covers how to perform all of those operations.

This topic contains these sections:

  • Tool Windows vs. Document Windows
  • Creation and Destruction
  • Preventing Document Windows from Auto-Destroying on Close
  • Opening and Closing
  • Activating and Focusing
  • Default Initial Size
  • Minimum and Maximum Size
  • Default Locations
  • Programmatically Changing States and Docking
  • Determining the Location of a Tool Window in Relation to the Workspace
  • Programmatically Starting a Drag
  • Splitter Drag Kinds

Tool Windows vs. Document Windows

Tool and document windows are the two varieties of docking windows that exist in the Docking/MDI product. While they both share many capabilities, they have several functional differences and you should choose to use the appropriate kind based on your UI needs.

Tool windows are capable of being docked outside of MDI, auto-hidden to the side of a dock host, or used in the MDI area. They have no out-of-the-box restrictions on where they can go. Tool windows are typically used for scenarios where the docking window needs to support all those state locations, or needs to frequently be closed and reopened. They remain registered with the dock site after they are closed, and thus can be readily reopened into the layout in their previous locations.

Document windows on the other hand can only be used within the MDI area. Since document windows are intended to have a limited lifetime, they are destroyed (unregistered from the dock site) by default when they are closed. See a section below for information on altering this behavior. Document windows are typically used for scenarios where the docking window is no longer needed after it is closed.

Creation and Destruction

When a DockingWindow has been associated with a DockSite, it is considered created. Note that at this time it may not yet be opened (accessible in the user interface).

After a docking window ceases to be managed by a DockSite, it is considered destroyed.

While being tracked by a DockSite, tool windows will be contained in its ToolWindows collection and document windows will be contained in its DocumentWindows collection.

Creating Tool Window

Use this code to create a tool window. Always use a constructor that accepts a DockSite parameter since this associates the tool window with that DockSite.

C#
VB
Copy
​TextBox tb = new TextBox();
tb.BorderThickness = new Thickness(0);
ToolWindow window = new ToolWindow(dockSite, "MyToolWindow1", "My First Tool Window",
    new BitmapImage(new Uri("/Resources/Images/Properties16.png", UriKind.Relative)), tb);
​Dim tb As TextBox = New TextBox()
tb.BorderThickness = new Thickness(0)
Dim window As ToolWindow = New ToolWindow(dockSite, "MyToolWindow1", "My First Tool Window", _
    New BitmapImage(New Uri("/Resources/Images/Properties16.png", UriKind.Relative)), tb)

When using the constructor in the example above, the first parameter is the DockSite that will manage the window.

The second is the value to be assigned to the Name property.

Note Note
A unique Name or SerializationId must be assigned to each tool window if layout serialization will be used in your application. The Name property must be a valid C#/VB identifier (underscore, letter, and number characters only), while the SerializationId is more flexible and can consist of any characters.

The third and fourth parameters are the title text and ImageSource respectively that will be displayed in the UI for the tool window.

The final parameter is the content that will be placed in the tool window.

Creating Document Windows

Use this code to create a document window. Always use a constructor that accepts a DockSite parameter since this associates the document window with that DockSite.

C#
VB
Copy
​TextBox tb = new TextBox();
tb.BorderThickness = new Thickness(0);
DocumentWindow window = new DocumentWindow(dockSite, "MyDocumentWindow1", "My First Document Window",
    new BitmapImage(new Uri("/Resources/Images/TextDocument16.png", UriKind.Relative)), tb);
​Dim tb As TextBox = New TextBox()
tb.BorderThickness = new Thickness(0)
Dim window As DocumentWindow = New DocumentWindow(dockSite, "MyDocumentWindow1", "My First Document Window", _
    New BitmapImage(New Uri("/Resources/Images/TextDocument16.png", UriKind.Relative)), tb)

The same notes above regarding constructor parameters apply to document windows as well with one exception. Since document windows are not normally serialized with a layout, the Name parameter is not important to pass and may be null.

Destroying Docking Windows

Both tool and document windows may be destroyed by calling the DockingWindow.Destroy method.

This closes them out of the UI (if currently open) and removes them from their managing DockSite.

Note Note
By default, document windows auto-destroy themselves when closed. See the following section for more information.

Preventing Document Windows from Auto-Destroying on Close

By default, document windows are only alive while open and will destroy themselves after being closed. This is the default because normally once a document is closed, it is no longer needed unless the the end user specifically chooses to open it again, which may or may not ever occur.

You can alter this behavior by changing the DockSite.AreDocumentWindowsDestroyedOnClose property to false. When false, document windows will continue to be associated with the DockSite and will remain within its DocumentWindows collection, allowing them to be retrived for later reopening.

Opening and Closing

When open, a docking window is accessible in the user interface. When closed, it is not.

Note Note
It is very important to NOT set the DockingWindow.Visibility property yourself. The docking framework itself will manage user interface visibility based on whether a docking window is currently open or not.

Opening Docking Windows

Docking windows aren't added to the user interface until specifically opened. A call to the DockingWindow.Open method will restore the docking window to its previous state and location, if known. If the docking window doesn't have a prior location breadcrumb available, it will restore to a default location based on its property settings.

Setting the IsOpen property to true is the same as calling the parameterless Open method. This property can be bound to in MVVM scenarios.

Closing Docking Windows

Docking windows can be removed from the user interface by a call to their DockingWindow.Close method.

Setting the IsOpen property to false is the same as calling the Close method. This property can be bound to in MVVM scenarios.

When closed, tool windows remain in the DockSite.ToolWindows collection until destroyed. However when document windows are closed, by default they will be destroyed as well unless the DockSite.AreDocumentWindowsDestroyedOnClose property is set to false.

Activating and Focusing

Activating is a superset of the Open functionality. When the DockingWindow.Activate method is called, if the docking window is currently closed, it will be opened. Additionally if it is open but in a tabbed scenario where it is not the selected tab, its tab will be selected.

The Activate method also has an overload for whether to set focus to the docking window's content.

Setting the IsActive property to true is the same as calling the parameterless Activate method. This property can be bound to in MVVM scenarios.

The LastActiveDateTime property is updated every time the docking window is activated, either programmatically or by focus moving within it. Sorting docking windows by this property value allows you to determine the sequence in which the docking windows were last active.

The DockSite.ActiveWindow tracks the currently active window. This property changes whenever a different docking window gains focus, and the the DockSite.WindowActivated event fires in response.

Default Initial Size

Docking windows default to a desired initial size of 200,200. Sometimes you may wish to set a different default initial size for docking windows. This can be done by using the DockingWindow.ContainerDockedSize property.

This example shows the property being set that will request that the ToolWindow have an initial size of 300, 150:

XAML
Copy
​... <docking:ToolWindow Title="Wide" ContainerDockedSize="300,150"> ...

Important Note Important Note
Since the docking elements need to dynamically change their size based on their location and available space, the Width, Height, MinWidth, MinHeight, MaxWidth, and MaxHeight properties should NEVER be used.

Minimum and Maximum Size

Docking windows default to a minimum size of 30,30 and a maximum size of positive infinity. Sometimes you may wish to designate some restrictions on size, such as a tool window's container should always try to be a minimum of 180 high. This can be done by using the DockingWindow.ContainerMinSize and ContainerMaxSize properties.

This example shows how to request a minimum container height of 180:

XAML
Copy
​... <docking:ToolWindow Title="Min Height" ContainerMinSize="30,180"> ...

By setting the minimum size to the same thing as the maximum height, you can achieve a fixed size. This example shows how to request a fixed container height of 180:

XAML
Copy
​... <docking:ToolWindow Title="Fixed Height" ContainerMinSize="30,180" ContainerMaxSize="10000,180"> ...

Important Note Important Note
Since the docking elements need to dynamically change their size based on their location and available space, the Width, Height, MinWidth, MinHeight, MaxWidth, and MaxHeight properties should NEVER be used.

Default Locations

When a docking window is opened via calling its DockingWindow.Open method or by setting the IsOpen property to true, it will first attempt to restore to a previous location where a related breadcrumb was left. If no breadcrumb is found, it will restore to a default location instead.

This is how a default location is determined:

  • First, if a WindowGroupName value is specified, the docking window will try to find another open docking window that has the same window group name.
  • Second, the DockingWindow.DefaultLocationRequested event fires with the DockingWindowDefaultLocationEventArgs.Target property initialized to the docking window found in the same window group, if any.
  • Third, the DockSite.WindowDefaultLocationRequested event fires with the same event arguments.
  • Both of these events allow you to programmatically customize where the default location for the window will be. You can indicate a dock target and optional side around which it should dock. Passing null as the side will trigger an attach.
  • If a dock target isn't set by an event handler, the docking window will fall back to opening in a default side specified by the ToolWindow.DefaultDockSide property. If an existing root level container is found at that side, the docking window will attach to that container.

Programmatically Changing States and Docking

It's very easy to move document and tool windows to anywhere in the layout programmatically.

State Change and Docking Members

The DockingWindow class has a number of methods that make it easy to programmatically move a docking window to another state.

Member Description
Float Method

Moves the tool or document window into a floating dock host.

One overload of this method restores the docking window back to its default floating bounds, and others let you optionally specify location and size.

Note Note
If you wish for the docking window to auto-size itself to its content when floated, update the DockingWindow.SizeToContentModes property to contain the SizeToContentModes.Floating flag.

This method will keep the docking window in its current State, but it will be contained within a new floating dock host.

MoveToMdi Method

Moves the tool or document window into the MDI area. Note that tabbed MDI or standard MDI modes should be active before calling this method.

One overload of this method restores the docking window back to its default document location and the other lets you specify the target dock host.

This method changes the docking window into a Document state.

The ToolWindow class defines additional methods that can be used to move a tool window to any state at either a default or target location.

Member | Description
Attach Method | Attaches the tool window to the specified dock target, which could be another open docking window, tabbed MDI container, or tool window container. This method changes the tool window into the state defined by the dock target.
AutoHide Method | Auto-hides the tool window to the outer-edge of the current dock host. One overload of this method goes to a default dock side, and the other lets you specify the target dock side. This method changes the tool window into an AutoHide state.
Dock Method | Docks the tool window within the dock host hierarchy. One overload of this method restores the tool window back to its default dock location and the other lets you specify a target and side against which to dock. This method changes the tool window into a Docked state.

The DocumentWindow class defines additional methods that can be used to move a document window to a target location.

Member | Description
Attach Method | Attaches the document window to the specified dock target, which could be another tabbed document window or tabbed MDI container.
Dock Method | Docks the document window to the side of a specified target, which could be another tabbed document window or tabbed MDI container.

Example: Docking to the Top of a Target

In this example we will dock the solutionExplorerToolWindow to the top of the propertiesToolWindow.

C#
VB
Copy
​solutionExplorerToolWindow.Dock(propertiesToolWindow, Side.Top);
​solutionExplorerToolWindow.Dock(propertiesToolWindow, Side.Top)

Example: Creating a Tabbed Group

In this example we will create a tabbed group of tool windows by "attaching" the solutionExplorerToolWindow to the propertiesToolWindow.

C#
VB
Copy
​solutionExplorerToolWindow.Attach(propertiesToolWindow);
​solutionExplorerToolWindow.Attach(propertiesToolWindow)

Example: Floating to a Location

In this example we will float the solutionExplorerToolWindow to a particular location.

C#
VB
Copy
​solutionExplorerToolWindow.Float(new Point(100, 100));
​solutionExplorerToolWindow.Float(New Point(100, 100))

Example: Floating and sizing to fit content

In this example we will float the solutionExplorerToolWindow to its previous location and have it size-to-content.

C#
VB
Copy
​solutionExplorerToolWindow.SizeToContentModes = SizeToContentModes.Floating;
solutionExplorerToolWindow.Float();
​solutionExplorerToolWindow.SizeToContentModes = SizeToContentModes.Floating
solutionExplorerToolWindow.Float()

Determining the Location of a Tool Window in Relation to the Workspace

The ToolWindow class has a GetCurrentSide method that returns a Side specifying where the tool window currently is in relation to the workspace, if one is in use.

If the tool window is open in a Document state, null is returned. If the tool window is open in an AutoHide state, a Side indicating the auto-hide dock side is returned. If the tool window is open in a Docked state and a workspace is in use in the dock site (no tool window inner-fill), a Side indicating the location of the tool window relative to the workspace is returned. If the tool window is open in a Docked state and the containing dock host does not has a workspace (tool window inner-fill is active), a Side indicating the location of the tool window's midpoint relative to the dock host's bounds is returned. Otherwise, if the tool window is closed, null is returned.

Programmatically Starting a Drag

It is possible to programmatically start a drag operation on DocumentWindow, ToolWindow, or ToolWindowContainer, by calling the associated DragMove method.

The only requirements are that the DocumentWindow/ToolWindow be registered with a DockSite and that the left mouse button be pressed when the method is called. This means that the method can even be called on windows that are not currently selected, in the auto-hide state, or in a standard MDI host. Also note that a InputPointerButtonEventArgs must be passed so that the related pointer can be captured.

In this example we trigger a programmatic drag on a tool window in the window variable from within an event handler for its primary pointer button being down:

C#
VB
Copy
​window.DragMove(new InputPointerButtonEventArgs(e, InputPointerButtonKind.Primary));
​window.DragMove(New InputPointerButtonEventArgs(e, InputPointerButtonKind.Primary))

Splitter Drag Kinds

Live splitting is enabled by default, meaning that when a splitter is dragged, the surrounding containers will immediately resize. This feature can be turned off by setting the DockSite.IsLiveSplittingEnabled property to false. When false, highlights are dragged instead and the containers only resize when the splitter is dropped.

While the live splitting feature is desirable for most scenarios, if your docking window content has very complex element trees that don't measure/arrange fast, turning off live splitting will improve performance when the end user uses splitters.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docking Window Capabilities

Docking & MDI Docking Window Features
Docking Window Capabilities

One of the best features of Actipro Docking & MDI is the number of options that are available to you as a developer. Many options control the behaviors and capabilities of the docking windows and can be set at a global level as well as at a docking window instance level.

This topic contains these sections:

  • Global Default Options
  • Docking Window Instance Options
  • How to Allow Tabs to Be Reordered, But Not Dragged Elsewhere
  • Limiting the Allowed Dock Guides While Dragging
  • Magnetism
  • Images on Tabs Option
  • Single Tab Layout Behavior
  • Tinting Tabs
  • Flashing Tabs
  • ToolWindowContainer Title Font

Global Default Options

A number of global default options appear on the DockSite. By default, docking windows will use these options unless their instance settings overrides them.

Member | Description
DockSite.AreDocumentWindowsDestroyedOnClose Property | Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed. The default value is true.
DockSite.AreNewTabsInsertedBeforeExistingTabs Property | Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container. The default value is true.
TabbedMdiHost.CanDocumentsAttach Property | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping. The default value is true.
TabbedMdiHost.CanDocumentsCloseOnMiddleClick Property | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button. The default value is true.
TabbedMdiHost.CanDocumentTabsDrag Property | Gets or sets the global setting for whether document tabs may be dragged to another location. The default value is true.
DockSite.CanDocumentWindowsClose Property | Gets or sets the global setting for whether document windows can be closed. The default value is true.
DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspaces Property | Gets or sets the global setting for whether tool windows may be dragged to floating dock hosts that contain a workspace. The default value is true. When false, tool windows can still be dragged and docked against floating dock hosts that only contain tool windows.
DockSite.CanDocumentWindowsDragToLinkedDockSites Property | Gets or sets the global setting for whether document windows may be dragged to a linked dock site. The default value is true.
DockSite.CanDocumentWindowsFloat Property | Gets or sets the global setting for whether document windows may be contained in a floating window. The default value is false.
DockSite.CanToolWindowsAttach Property | Gets or sets the global setting for whether the end user can edit document window titles in-place when a document window tab is double-clicked. The default value is true.
DockSite.CanToolWindowsAutoHide Property | Gets or sets the global setting for whether tool windows may be placed in auto-hide mode. The default value is true.
DockSite.CanToolWindowsBecomeDocuments Property | Gets or sets the global setting for whether tool windows may be placed in a document state. The default value is true.
DockSite.CanToolWindowsClose Property | Gets or sets the global setting for whether tool windows can be closed. The default value is true.
DockSite.CanToolWindowsCloseOnMiddleClick Property | Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button. The default value is true.
DockSite.CanToolWindowsDock Property | Gets or sets the global setting for whether tool windows can be docked. The default value is true.
DockSite.CanToolWindowTabsDrag Property | Gets or sets the global setting for whether tool window tabs may be dragged to another location. The default value is true.
DockSite.CanToolWindowsDragToLinkedDockSites Property | Gets or sets the global setting for whether tool windows may be dragged to a linked dock site. The default value is true.
DockSite.CanToolWindowsFloat Property | Gets or sets the global setting for whether tool windows may be floated into separate top-level containers. The default value is true.
DockSite.ClosePerContainer Property | Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping. The default value is false.
DockSite.ContainersHaveNewTabButtons Property | Gets or sets whether containers have new tab buttons. The default value is false.
DockSite.HasTabCloseButtons Property | Gets or sets whether close buttons should appear on document tabs. The default value is true.
TabbedMdiHost.TabOverflowBehavior Property | Gets or sets the global setting for the overflow behavior of the document tabs. The default value is TabOverflowBehavior.Menu.
DockSite.IsDockGuideAnimationEnabled Property | Gets or sets whether dock guide animation is enabled. The default value is true.
DockSite.IsFloatingWindowSnapToScreenEnabled Property | Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged. The default value is true.
DockSite.IsLiveSplittingEnabled Property | Gets or sets whether live splitting of docking windows is enabled. The default value is true.
DockSite.IsTabLayoutAnimationEnabled Property | Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed. The default value is true.
TabbedMdiHost.TabStripPlacement Property | Gets or sets a Side indicating the side upon which the tabs are located. The default value is Top.
DockSite.ToolWindowsHaveCloseButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar close buttons. The default value is true.
DockSite.ToolWindowsHaveOptionsButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar options buttons. The default value is true.
DockSite.ToolWindowsHaveTitleBarIcons Property | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window. The default value is false.
DockSite.ToolWindowsHaveTitleBars Property | Gets or sets the global setting for whether tool windows display a title bar when not in MDI. The default value is true.
DockSite.ToolWindowsHaveToggleAutoHideButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons. The default value is true.
DockSite.ToolWindowsSingleTabLayoutBehavior Property | Gets or sets the global setting for the behavior used when a single tool window is in a container. The default value is SingleTabLayoutBehavior.Hide.
DockSite.ToolWindowsTabOverflowBehavior Property | Gets or sets the global setting for the overflow behavior of the tool window tabs. The default value is TabOverflowBehavior.Shrink.
DockSite.ToolWindowsTabStripPlacement Property | Gets or sets the global setting for the overflow behavior of the tool window tabs. The default value is Bottom.
DockSite.UseDragFloatPreviews Property | Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows. The default value is false.

Docking Window Instance Options

All of the global default options listed above will apply to docking windows by default. Related docking window instance options are all nullable booleans with default values of null, indicating that they will inherit the global defaults.

Member | Description
DockingWindow.CanAttach Property | Gets or sets whether the window may be attached to another window, creating a tabbed grouping.
ToolWindow.CanAutoHide Property | Gets or sets whether the tool window may be placed in auto-hide mode.
ToolWindow.CanBecomeDocument Property | Gets or sets whether the tool window may be placed in a document state.
DockingWindow.CanClose Property | Gets or sets whether the window may be closed.
DockingWindow.CanDock Property | Gets or sets whether the tool window may be docked.
DockingWindow.CanDragTab Property | Gets or sets whether the window's tab may be dragged to another location.
DockingWindow.CanDragToLinkedDockSites Property | Gets or sets whether the window may be dragged to a linked dock site.
DockingWindow.CanFloat Property | Gets or sets whether the window may be floated into a separate top-level container.
DockingWindow.CanSerialize Property | Gets or sets whether the window's layout information may be serialized.
DockingWindow.CanStandardMdiMaximize Property | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.
DockingWindow.CanStandardMdiMinimize Property | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.
ToolWindow.HasOptionsButton Property | Gets or sets whether the window has an options menu available.
ToolWindow.HasTitleBar Property | Gets or sets whether the window displays a title bar when docked.

How to Allow Tabs to Be Reordered, But Not Dragged Elsewhere

In some situations you may wish to keep docking windows in their current container but still want to allow them to be reordered.

To accomplish this, turn all the appropriate options off such as can dock and can raft, etc. but leave can drag on. This will allow the user to reorder tabs by dragging them within their container but will prevent the docking window from moving outside of the container.

Limiting the Allowed Dock Guides While Dragging

The DockSite.WindowsDragOver event is raised while dragging docking windows over a new drop target. This event is passed an instance of DockingWindowsDragOverEventArgs, which indicates the DockHost being dragged, the docking windows inside that DockHost, and the IDockTarget control that the pointer is currently over.

The DockingWindowsDragOverEventArgs.SupportedDockGuideKinds property lists the dock guide kinds (a DockGuideKinds flags enumeration value) that are supported with this particular combination and will be shown by default.

If you wish to prevent certain supported dock guides from being displayed, change the DockingWindowsDragOverEventArgs.AllowedDockGuideKinds property value. It defaults to the SupportedDockGuideKinds property value.

For instance, if you'd only like docking windows to be able to dock left, right, or center (attach), you could set the AllowedDockGuideKinds property to OuterLeft | InnerLeft | Center | InnerRight | OuterRight. Any values that you set to this property that aren't "supported" at the time will be ignored.

You can use complex logic to tailor the allowed dock guides based on your application design and its current state.

Magnetism

Magnetism allows floating windows to be "snapped" together when moving or resizing. This makes it easier for the end-user to line up the windows into rows or columns.

Magnetism can be configured using DockSite.MagnetismSnapDistance and DockSite.MagnetismGapDistance. The snap distance indicates the distance at which magnetism begins to snap windows being dragged. The gap distance indicates the distance between windows that are snapped together via magnetism. Magnetism can be disabled by setting the snap distance to 0.

Images on Tabs Option

The DockingWindow.ImageSource image can appear on docking window tabs when tab images are enabled.

You can force the image to display on the tool window tabs by setting the DockSite.ToolWindowsHaveTabImages property to true, or on tabbed MDI tabs by setting the TabbedMdiHost.HasTabImages property to true.

Single Tab Layout Behavior

By default, when a ToolWindowContainer only has a single ToolWindow, then the tabs are hidden. This mimics the behavior seen in Visual Studio, but can be customized. The tab for the single window can be hidden or shown.

The behavior can be customized using the DockSite.ToolWindowsSingleTabLayoutBehavior property, whose default value is Hide.

A ToolWindowContainer with a single window using Hide and Show behaviors

Tinting Tabs

Tabs can be tinted towards a color by setting the DockingWindow.TabTintColor property. The tab will have the same general visual appearance but the colors will be skewed towards the tint color.

Several tinted tabs

Flashing Tabs

Tabs can enter a flashing mode by setting the DockingWindow.TabFlashMode property to either Blink or Smooth. The Blink mode will cause the tab to appear as flashing for a bit, then instantly restore it to normal for a bit, then appear as flashing for a bit, and so on until the mode is changed back to None. The Smooth mode will do a smooth transition between the flashing appearance and normal appearance.

The DockingWindow.TabFlashColor property specifies the color used to tint the tab for its flash effect.

Flashing is best used to grab the end user's attention, and let them know that a tab should be clicked. Watch the DockSite.WindowActivated event to see when the docking window is activated. At that point, set the TabFlashMode property back to None to disable flashing.

ToolWindowContainer Title Font

The ToolWindowContainer control has several properties that can be set to alter its title font appearance:

  • TitleFontFamily
  • TitleFontSize
  • TitleFontWeight

Properties like these should never be set directly on specific instances of container controls since containers are created and destroyed dynamically at run-time with layout changes. Instead, if you wish to change these properties, use an implicit Style that targets ToolWindowContainer in your application's Resources:

XAML
Copy
​<Style TargetType="docking:ToolWindowContainer">
    <Setter Property="TitleFontFamily" Value="Verdana" />
    <Setter Property="TitleFontSize" Value="14" />
    <Setter Property="TitleFontWeight" Value="Bold" />
</Style>

That implicit Style will update all instances of the container within your application.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docking Window Events

Docking & MDI Docking Window Features
Docking Window Events

There are a number of events to which you can attach to know when various actions occur to docking windows.

This topic contains these sections:

  • DockSite Events
  • Displaying a StatusBar Message During Drags
  • Customizing Menus

DockSite Events

The DockSite that owns the docking window receiving an action has these events:

Member | Description
FloatingWindowOpening Event | Occurs when a floating window is opening, allowing for customization before it is displayed.
MdiKindChanged Event | Occurs when the DockSite.MdiKind property is changed.
MenuOpening Event | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
NewWindowRequested Event | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
PrimaryDocumentChanged Event | Occurs when the DockSite.PrimaryDocument property has changed.
WindowActivated Event | Occurs after a DockingWindow has been activated.
WindowAutoHidePopupClosed Event | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
WindowAutoHidePopupOpened Event | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
WindowDeactivated Event | Occurs after a DockingWindow has been deactivated.
WindowDefaultLocationRequested Event | Occurs when a DockingWindow's default location is requested.
WindowRegistered Event | Occurs after a DockingWindow has been registered.
WindowsAutoHiding Event | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
WindowsClosed Event | Occurs after one or more DockingWindow controls have been closed.
WindowsClosing Event | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
WindowsDragged Event | Occurs after one or more DockingWindow controls are dragged by the end user.
WindowsDragging Event | Occurs before one or more DockingWindow controls are dragged by the end user.
WindowsDragOver Event | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
WindowsOpened Event | Occurs after one or more DockingWindow controls have been opened.
WindowsOpening Event | Occurs before one or more DockingWindow controls is opened.
WindowsStateChanged Event | Occurs after one or more DockingWindow controls' states have changed.
WindowUnregistered Event | Occurs after a DockingWindow has been unregistered.

Most of the event arguments pass references to the related DockingWindow controls.

Displaying a StatusBar Message During Drags

It is a common practice to display a status bar message during tool window drags to indicate to the end user that they can move over the dock guides to docks a tool window.

To accomplish this, handle the WindowsDragging and display a message like this in your status bar:

Use the guide diamond to choose a docking location. To prevent docking, hold down CTRL.

Handle the WindowsDragged event and restore the status bar message back to something like Ready.

Customizing Menus

The MenuOpening event fires before any menu is displayed for a window or button, allowing you to customize it or replace it with your own.

See the Menu Customization topic for details on handling this event.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Docked Tool Windows

Docking & MDI Docking Window Features
Docked Tool Windows

Tool windows in docked state appear docked in containers around an optional workspace within their dock host. When two or more tool windows are in the same container, tabs allow for selecting which one is visible.

When a tool window is docked, it appears within a ToolWindowContainer.

The Solution Explorer tool window docked

This topic contains these sections:

  • Allowing Docking
  • Programmatically Docking a Tool Window
  • Appearance Options
  • Title vs. Tab Text
  • Tab Tool Tip
  • Tab Images
  • Tab and Title Bar Contextual Content
  • Tab Strip Placement
  • Tab Overflow Behavior
  • Single Tab Behavior
  • Keyboard Shortcuts

Allowing Docking

Only tool windows can be docked. A global DockSite.CanToolWindowsDock property (defaults to true) determines the default value for whether they have that capability, but it can be overridden at an instance-level by setting the DockingWindow.CanDock property.

The DockingWindow.CanAttach property can be set to false to prevent a tool window from attaching (becoming tabbed with) another tool window in the same container.

Programmatically Docking a Tool Window

A tool window can be programmatically docked by calling the ToolWindow.Dock method. An overload of the method allows you to specify the IDockTarget and Side against which to dock around the target.

The IDockTarget can be a DockSite, DockHost, Workspace, or another docking window.

Appearance Options

These options control the appearance of tool window containers:

Member | Description
DockSite.ToolWindowsHaveCloseButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar close buttons.
DockSite.ToolWindowsHaveOptionsButtons Property | Gets or sets whether ToolWindowContainer controls can have title bar options buttons.
DockSite.ToolWindowsHaveTitleBarIcons Property | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.
DockSite.ToolWindowsHaveTitleBars Property | Gets or sets the global setting for whether tool windows display a title bar when not in MDI.

The ToolWindowContainer control also defines TitleFontFamily and TitleFontSize properties that can adjust the look of a title in a tool window container. These properties can only be altered with an implicit Style that targets ToolWindowContainer that is in your application's Resources.

Title vs. Tab Text

The DockingWindow.Title property is normally set to determine the title text that is rendered in tabs as well as in title bars and on the standard switcher. In some cases, it might be desirable to have longer text for the Title, such as "Properties - Document1.txt", while having shorting text that renders on tabs, such as "Properties". This allows your title to provide more extensive contextual information.

By setting the TabText property to a non-null value, its value will be used to render the tab text instead of the Title value. In that scenario, the Title value will still be used in title bars and on the standard switcher when the window is selected.

Tab Tool Tip

The DockingWindow.TabToolTip property is automatically bound to the Title property for tool windows. Override the TabToolTip property to set alternate tool tip content.

Tab Images

By default the DockingWindow.ImageSource image will not appear on tool window tabs.

You can force the image to display on the tabs by setting the DockSite.ToolWindowsHaveTabImages property to true.

Tab and Title Bar Contextual Content

Tool window tabs and tool window container title bars can display any context-related content to the right of the title. This content is set via the ToolWindow.ToolWindowContainerTabContextContentTemplate and ToolWindow.ToolWindowContainerTitleBarContextContentTemplate properties respectively.

See the Contextual Content topic for some more information.

Tab Strip Placement

By default the tool window tabs will appear below their content, but can be changed to appear on any side of the content.

You can alter the location of the tool window tabs by changing the value of the DockSite.ToolWindowsTabStripPlacement property.

Tab Overflow Behavior

There are numerous options from the TabOverflowBehavior enumeration for selecting what happens when the tabs overflow the available tab strip space.

By default, the tabs shrink to fit within the available tab strip space. This can be changed via the DockSite.ToolWindowsTabOverflowBehavior property.

Single Tab Behavior

Use the DockSite.ToolWindowsSingleTabLayoutBehavior property to adjust whether tool window containers that have a single tool window should show a tab or not. By default, tabs only show when there are two or more tool windows in a container.

Keyboard Shortcuts

The Alt+- keyboard shortcut shows the options menu for the currently selected tool window in the container.

Other keyboard shortcuts allow you to jump directly to a tab. Ctrl+1 will activate the first tab, with Ctrl+2 activating the second tab, and so on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Auto-Hidden Tool Windows

Docking & MDI Docking Window Features
Auto-Hidden Tool Windows

Tool windows in auto-hide state show tabs along a tray area on the side of their dock host. When a tab is clicked, the related tool window's content is displayed in an animated popup.

The Solution Explorer tool window in AutoHide state with its popup displayed

This topic contains these sections:

  • Allowing Auto-Hide
  • Programmatically Auto-Hiding a Tool Window
  • Behavior and Animation Options
  • Appearance Options
  • Iterating Auto-Hidden Tool Windows
  • Determining If an Auto-Hide Popup Is Displayed
  • Dynamically Altering the Auto-Hide Side
  • Auto-Hide Popup Events

Allowing Auto-Hide

Only tool windows can be auto-hidden. A global DockSite.CanToolWindowsAutoHide property (defaults to true) determines the default value for whether they have that capability, but it can be overridden at an instance-level by setting the ToolWindow.CanAutoHide property.

Programmatically Auto-Hiding a Tool Window

A tool window can be programmatically auto-hidden by calling the ToolWindow.AutoHide method. An overload of the method allows you to specify the Side against which to auto-hide.

Behavior and Animation Options

These options control auto-hide functionality behavior and ensuing animation:

Member | Description
DockSite.AutoHidePerContainer Property | Gets or sets whether auto-hide state toggles affect all the windows in the parent container. The default value is true.
DockSite.AutoHidePopupCloseAnimationDuration Property | Gets or sets the time in milliseconds of the animation that is applied to an auto-hide popup close. The default value is 150ms.
DockSite.AutoHidePopupOpenAnimationDuration Property | Gets or sets the time in milliseconds of the animation that is applied to an auto-hide popup open. The default value is 150ms.

Appearance Options

These options control the appearance of auto-hide tabs:

Member | Description
ToolWindow.AutoHideTabContextContentTemplate Property | Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
DockSite.AutoHideTabItemTemplate Property | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
DockSite.AutoHideTabItemTemplateSelector Property | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.

Iterating Auto-Hidden Tool Windows

These DockSite properties are the four collections of ToolWindowContainer controls, one collection for each side of the dock site.

  • DockSite.AutoHideLeftContainers
  • DockSite.AutoHideTopContainers
  • DockSite.AutoHideRightContainers
  • DockSite.AutoHideBottomContainers
Each of those accepts one or more ToolWindowContainer controls, each of which can contain one or more ToolWindow controls.

The properties above are simple wrappers for similar properties on the DockHost returned by the DockSite.PrimaryDockHost property. You can iterate through those collections to see which tool windows are on each side of the primary dock host.

You can also examine each floating DockHost, if there are any, by iterating the DockSite.FloatingDockHosts collection and examining the DockHost.AutoHideLeftContainers, etc. properties on them.

Determining If an Auto-Hide Popup Is Displayed

The DockHost.IsAutoHidePopupOpen property returns true when there is an auto-hide popup displayed.

The DockHost.AutoHidePopupToolWindow property returns the ToolWindow that is currently open in that popup. The ToolWindow.IsAutoHidePopupOpen property of that tool window will return true while it is open in the popup.

Dynamically Altering the Auto-Hide Side

The WindowsAutoHiding event fires whenever one or more tool windows are auto-hidden, allowing for the side upon which they are being auto-hidden to be customized. This is useful in scenarios like when you wish to restrict auto-hiding to only the left/right or top/bottom of a dock host.

The event is passed arguments of type DockingWindowsAutoHidingEventArgs, which has a Side property. An event handler can examine the list of windows being auto-hidden and can choose to change the side to another side.

Auto-Hide Popup Events

The WindowAutoHidePopupOpened and WindowAutoHidePopupClosed events on DockSite fire whenever the auto-hide popup is opened or closed. The event arguments specify which tool window was opened or closed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Floating Dock Hosts

Docking & MDI Docking Window Features
Floating Dock Hosts

Docking windows can be dragged to float, meaning appear in a floating dock host that can move independently above the dock site's primary dock host.

This topic contains these sections:

  • Floating Dock Host Overview
  • Allowing Floating Windows
  • Programmatically Floating a Docking Window
  • Preventing Tool Windows from Docking Against Floating Dock Hosts Containing Workspaces
  • Determining if a Docking Window is on a Floating Dock Host
  • Floating Window Icon and Title
  • Using Drag Float Previews
  • Snap to Screen Threshold
  • Size-to-Content
  • Limiting Floating Window Initial Sizes
  • Hosted Floating Window Inactivity Animations
  • Hosted Floating Window Container

Floating Dock Host Overview

Any time a docking window is floated, a floating DockHost is created to contain it. If a document window is floated, the dock host will contain its own workspace and MDI host in which the floated document window will appear. If a tool window is floated, the dock host will contain a single tool window container.

For floating dock hosts with a workspace, other documents can be added to the floating dock host's MDI host and other tool windows can be docked around the workspace, or even auto-hidden. For floating dock hosts that do not have a workspace and only have tool window containers, other tool windows can be attached or docked next to the tool window containers.

Allowing Floating Windows

Both tool and document windows can be floated, but only tool windows have floating enabled by default.

A global DockSite.CanToolWindowsFloat property (defaults to true) determines the default value for whether tool windows have that capability, and a global DockSite.CanDocumentWindowsFloat property (defaults to false) determines the default value for whether document windows have that capability. The properties can be overridden at an instance-level by setting the DockingWindow.CanFloat property.

Programmatically Floating a Docking Window

A docking window can be programmatically floated by calling the DockingWindow.Float method. Overloads of the method are available that allow you to specify the location or size of the floating dock host.

Preventing Tool Windows from Docking Against Floating Dock Hosts Containing Workspaces

In some scenarios, you might only wish to allow tool windows to be dragged and docked against floating dock hosts that only contain tool windows, and don't have a workspace. To enable this feature, set the DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspaces property to false.

Determining if a Docking Window is on a Floating Dock Host

When the DockingWindow.IsOpen property returns true, the docking window is open in the layout and is nested within a DockHost. The dock host can be retrieved via the DockingWindow.DockHost property. If the dock host is in the DockSite.FloatingDockHosts collection, then it is a floating dock host, and thus the docking window is "floating".

This code shows how to do this check:

C#
VB
Copy
​var isOnFloatingDockHost = (window.IsOpen) && (window.DockSite.FloatingDockHosts.Contains(window.DockHost));
​Dim isOnFloatingDockHost = (window.IsOpen) AndAlso (window.DockSite.FloatingDockHosts.Contains(window.DockHost))

Note that the DockingWindowState enumeration doesn't have a Floating item. This is due to the fact that Docking/MDI's advanced floating dock host features allow tool windows to be in a docked, auto-hide, or in document state when they are in a floating dock host.

For instance, if a tool window is floated, it will show up in a single ToolWindowContainer inside of a floating dock host and its state will be Docked. If a document window is floated, it will show up in a MDI area inside of a floating dock host and its state will be Document. A tool window could then be dragged and docked next to that MDI area. Once that is done, it could be auto-hidden, and its state would be AutoHide. These examples show how various docking window states can exist within a floating dock host.

Floating Window Icon and Title

A floating dock host can have its icon and title set via the DockSite.FloatingWindowIcon and FloatingWindowTitle properties respectively. It's generally a good practice to use an application icon as the icon and the application title as the title.

Using Drag Float Previews

By default, dragging a docking window will instantly float it, giving it more of a live feel. The DockSite.UseDragFloatPreviews property, which defaults to false, can be set to true to prevent this behavior and only show a float preview highlight while dragging.

This property should be set to true when docking window content contains a large number of elements that may not measure/arrange quickly. When this property is true, fewer layout cycles occur since a float preview is used to show where the floating window will be created instead of instantly moving the dragged windows into a floating window.

Snap to Screen Threshold

When the DockSite.IsFloatingWindowSnapToScreenEnabled property is true, which is the default, floating windows are snapped onto the closest screen when displayed via a method other than being dragged. This feature ensures that floating windows are fully visible on-screen when being programmatically displayed, such as when a layout is loaded.

The minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen can be set by the DockSite.FloatingWindowSnapToScreenThreshold property. If a floating window is completely beyond the screen edge, it will be fully snapped back onto the screen. If a floating window is only partially beyond the screen edge, but the visible portion is less than this property's value, it will be snapped partially back onto the screen.

Size-to-Content

If you wish for a docking window to auto-size itself to its content when floated, update its DockingWindow.SizeToContentModes property to contain the SizeToContentModes.Floating flag.

Limiting Floating Window Initial Sizes

The DockSite.FloatingWindowOpening event fires whenever a floating window is opening, allowing for customization before it is displayed. It is passed arguments of type FloatingWindowOpeningEventArgs that indicate the child control of the floating dock host that will be created, along with the default size of the floating window.

The FloatingWindowOpeningEventArgs.Size property can be altered in the event handler to limit the size of the floating window. This feature is useful since sometimes when a MDI area fills most of the screen, dragged-to-float documents would fully obscure what is behind them.

This code shows an event handler implementation that ensures that floating windows are never longer than 600 on their long side, and 300 on their short side.

C#
VB
Copy
​private void OnDockSiteFloatingWindowOpening(object sender, FloatingWindowOpeningEventArgs e) {
    // Make sure the long side is no longer than 600, and the short side is no longer than 300
    if (e.Size.Width > e.Size.Height)
        e.Size = new Size(Math.Min(600.0, e.Size.Width), Math.Min(300.0, e.Size.Height));
    else
        e.Size = new Size(Math.Min(300.0, e.Size.Width), Math.Min(600.0, e.Size.Height));
}
​Private Sub OnDockSiteFloatingWindowOpening(ByVal sender As Object, ByVal e As FloatingWindowOpeningEventArgs)
    ' Make sure the long side is no longer than 600, and the short side is no longer than 300
    If e.Size.Width > e.Size.Height Then
        e.Size = New Size(Math.Min(600.0, e.Size.Width), Math.Min(300.0, e.Size.Height))
    Else
        e.Size = New Size(Math.Min(300.0, e.Size.Width), Math.Min(600.0, e.Size.Height))
    End If
End Sub

Hosted Floating Window Inactivity Animations

A great feature implemented by hosted floating windows that cannot be implemented in normal floating windows is inactivity animation.

Basically after the pointer has not moved over a hosted floating window for a while and it doesn't have focus, it will begin to slowly fade out to partial transparency. You have total control over whether this feature is enabled and how long it takes to fade, etc.

These DockSite properties control the inactivity behavior:

Member | Description
InactiveFloatingWindowFadeDelay Property | Gets or sets the duration of inactivity that must take place for a floating window before it starts to fade out. The default value is 20 seconds.
InactiveFloatingWindowFadeDuration Property | Gets or sets the duration over which an inactive floating window will fade. The default value is 20 seconds.
InactiveFloatingWindowFadeOpacity Property | Gets or sets the target opacity to which inactive floating windows to fade. The default value is 0.25 (25% opacity).
IsInactiveFloatingWindowFadeEnabled Property | Gets or sets whether floating windows will fade out following inactivity. The default value is true.

Hosted Floating Window Container

To ensure that a portion of the hosted floating windows are always visible to the end user, their bounds are coerced such that part of the title bar is always visible. The DockSite.HostedFloatingWindowContainer property can be set to any visual ancestor of the DockSite, and hosted floating window bounds will be constrained to the bounds of the specified container. If a container is not specified, the DockSite will be used as the container.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Contextual Content

Docking & MDI Docking Window Features
Contextual Content

Contextual content, such as buttons or status indicators, can be displayed throughout the docking window UI within tabs and title bars.

A status indicator showing in both the tool window tab and title bar

This topic contains these sections:

  • Contextual Content Locations
  • Tool Window Container Title Bar Alignment
  • Status Indicator Example

Contextual Content Locations

There are five locations that support contextual content. Each of the properties below can be assigned a DataTemplate that specifies the contextual content to use for the related location.

The data context of the DataTemplate will be the DataContext of the docking window, unless the DataContext is a UIElement. In that case, no data context is passed since it could otherwise lead to logical tree issues.

Member | Description
ToolWindow.AutoHideTabContextContentTemplate Property | The tab of an auto-hidden tool window.
DockingWindow.StandardMdiTitleBarContextContentTemplate Property | The title bar of a standard MDI document.
ToolWindow.ToolWindowContainerTabContextContentTemplate Property | The tab of a docked tool window.
ToolWindow.ToolWindowContainerTitleBarContextContentTemplate Property | The title bar of a docked tool window.

Tool Window Container Title Bar Alignment

The DockSite.ToolWindowsTitleBarContextContentAlignment property can be set to a ContextContentAlignment that indicates if the context content is aligned to the near (left) side of the title, or to the far (right) side. The far side is just left of any title bar buttons, and is the default alignment.

Status Indicator Example

Let's see how to reproduce the Status tool window in the screenshot above.

This DataTemplate contains an ellipse whose fill color is bound to the value of the docking window's DataContext. A special value converter is used to convert the value to a Brush. See the related QuickStart in the Sample Browser for the full source code.

XAML
Copy
​<DataTemplate x:Key="StatusIconDataTemplate">
    <Ellipse Margin="2" Width="12" Height="12" StrokeThickness="1" Stroke="#ffffff" HorizontalAlignment="Center" VerticalAlignment="Center"
    Fill="{Binding Converter={StaticResource StatusLightConditionalConverter}}" />
</DataTemplate>

This XAML within a dock site shows how a tool widnow could be defined to use the DataTemplate above in all possible locations. Note how its DataContext is initialized to a boolean value.

XAML
Copy
​<docking:ToolWindow x:Name="statusToolWindow" Title="Status"
    AutoHideTabContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    StandardMdiTitleBarContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    TabbedMdiTabContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    ToolWindowContainerTabContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    ToolWindowContainerTitleBarContextContentTemplate="{StaticResource StatusIconDataTemplate}"
    >
    <docking:ToolWindow.DataContext>
        <system:Boolean>False</system:Boolean>
    </docking:ToolWindow.DataContext>
    ...
</docking:ToolWindow>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Fixed Tool Windows

Docking & MDI Docking Window Features
Fixed Tool Windows

By turning off various options on a specific tool window, you can completely prevent it from being moved and can keep it "fixed" within a tool window layout, while still allowing other tool windows to be docked around it.

A fixed tool window without a title bar surrounded by the workspace and some other tool windows

A fixed tool window like the one in the screenshot can be created by setting:

  • ToolWindow.CanAttach = false
  • ToolWindow.CanDragTab = false
  • ToolWindow.HasTitleBar = false

Those settings prevent other tool windows from attaching (creating tabbed groups) to the tool window, being dragged anywhere, and having a title bar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Menu Customization

Docking & MDI Docking Window Features
Menu Customization

All menus displayed by this product can be customized or replaced entirely before they are shown to the end user.

This topic contains these sections:

  • The MenuOpening Event
  • Customizing Individual Menu Items
  • Using a Different Context Menu

The MenuOpening Event

The customization of menus is handled via the DockSite.MenuOpening event. This event fires whenever a menu is displayed for a docking window, when an options button is pressed for a docking window, etc.

The event arguments that are passed are type DockingMenuEventArgs, which indicates the DockingWindow for which the event was fired. The DockingMenuEventArgs.Kind property supplies a DockingMenuKind value that can be used to determine the type of menu being constructed.

The event arguments passes a pre-configured MenuFlyout in its Menu property.

Customizing Individual Menu Items

As mentioned above, the event argument's Menu property includes all the menu items, already initialized.

You can customize the items in that menu, and add or remove new ones as needed.

Using a Different Context Menu

To use a completely different menu, simply set the new menu to the event argument's Menu property. The alternate menu you specify will be displayed instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Switchers

Docking & MDI Docking Window Features
Switchers

Switchers are used during Ctrl+Tab, etc. key presses to easily navigate between open documents and tool windows.

The standard switcher

These two built-in switcher options are included with Actipro Docking & MDI:

  • Simple
  • Standard

This topic contains these sections:

  • Activation Key Gestures
  • Configuration
  • The Simple Switcher
  • The Standard Switcher

Activation Key Gestures

If a switcher is available, these key gestures will activate it:

Key | Description
Ctrl+Tab | Select the next document.
Alt+F7 | Select the next tool window.
Ctrl+Shift+Tab | Select the previous document.
Shift+Alt+F7 | Select the previous tool window.

Configuration

By default the DockSite is assigned a StandardSwitcher to its Switcher property.

You can clear the Switcher property to not use switchers, or can set that property to another SwitcherBase-inherited class instance to use another switcher. StandardSwitcher and SimpleSwitcher are implementations of SwitcherBase.

This sample XAML code shows how to use a simple switcher for a dock site.

XAML
Copy
​<docking:DockSite>
    <docking:DockSite.Switcher>
        <docking:SimpleSwitcher />
    </docking:DockSite.Switcher>
</docking:DockSite>

The Simple Switcher

The simple switcher does not display a user interface. Instead, pressing the switcher key gestures will toggle through the various documents and tool windows.

The Standard Switcher

The standard switcher is more advanced and displays a user interface shown in the screenshot above. It shows multiple columns of open tool windows and documents. You also can use the arrow keys to navigate through the windows while the switcher is open.

There are many properties that allow you to completely customize the appearance of the switcher. Everything from the appearance of items to the number of document columns can be set.

In scenarios where you don't use tool windows at all, set the AreToolWindowsVisible property to false. Likewise, if you don't use MDI, set the AreDocumentsVisible property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Docking & MDI Workspace and MDI Features
Overview

Actipro Docking & MDI supports an optional workspace area, which can contain custom content or multiple types of MDI (multiple document interface).

Workspace

The workspace is the central area of a dock site hierarchy, around which tool windows are docked. It can contain optional MDI hosts or can host any other sort of content.

See the Workspace topic for more information.

Tabbed MDI

Tabbed MDI is the default type of MDI found in most modern applications and is fully supported by Actipro Docking & MDI.

See the Tabbed MDI topic for more information.

Standard MDI

A standard (windowed) MDI option is implemented by Actipro Docking & MDI via a WindowControl control that mimics the functionality of a native window with resizable borders, minimize/maximize/close buttons, etc.

See the Standard MDI topic for more information.

Working with Documents

All documents can be easily managed via DockSite properties and methods, regardless of whether tabbed or standard MDI is in use. This allows your document-related code to remain the same regardless of the style of MDI in use.

See the Working with Documents topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Workspace

Docking & MDI Workspace and MDI Features
Workspace

The workspace is the central area of a dock site hierarchy, around which tool windows are docked. It can contain optional MDI hosts or can host any other sort of content.

A workspace with custom content (the Actipro logo)

This topic contains these sections:

  • Control and Hierarchy
  • Workspace with Custom Content
  • Workspace with Tabbed MDI
  • Workspace with Standard MDI
  • MDI Only (No Tool Window Hierarchy)
  • Switching MDI Modes at Run-Time
  • Determining the Location of a Tool Window in Relation to the Workspace

Control and Hierarchy

A workspace is implemented by the Workspace control. Only one Workspace can be included within a dock host hierarchy at a time.

If no workspace is within a dock host hierarchy, tool window inner-fill mode is activated.

See the Control Hierarchy topic for help on which controls can be parents to a workspace.

Workspace with Custom Content

As mentioned above, any sort of content can be placed as the child of a workspace. Just set the custom content to the Content property of the Workspace.

The screenshot above shows a workspace with custom content loaded.

When placing custom content in a workspace, a TabbedMdiHost or StandardMdiHost can optionally be the content. If neither host is defined as the workspace content, then no MDI features will be available.

Workspace with Tabbed MDI

If you want to have tabbed MDI features in your docking layout, you must place a TabbedMdiHost control directly as the Content of the Workspace.

The DockSite.MdiKind property returns Tabbed when a tabbed MDI host is present. Additionally, DockSite.PrimaryDockHost.MdiHost returns the MDI host registered with the primary dock host (the one implicitly defined within the dock site).

Tabbed MDI will not function correctly if the TabbedMdiHost is placed elsewhere.

Workspace with Standard MDI

If you want to have standard MDI features in your docking layout, you must place a StandardMdiHost control directly as the Content of the Workspace.

The DockSite.MdiKind property returns Standard when a standard MDI host is present. Additionally, DockSite.PrimaryDockHost.MdiHost returns the MDI host registered with the primary dock host (the one implicitly defined within the dock site).

Standard MDI will not function correctly if the StandardMdiHost is placed elsewhere.

MDI Only (No Tool Window Hierarchy)

In some scenarios you may wish to have MDI functionality but no tool windows surrounding the MDI area.

To achieve this, place the Workspace directly as a child of the DockSite. And use either a TabbedMdiHost or a StandardMdiHost as a child of the workspace, depending on which type of MDI you wish to have.

Switching MDI Modes at Run-Time

You can easily switch between MDI modes at run-time by setting the DockSite.MdiKind property. When switching modes, all open documents should remain open.

Determining the Location of a Tool Window in Relation to the Workspace

The ToolWindow.GetCurrentSide method can be used to determine where an open tool window is in relation to the workspace.

See the Lifecycle and Docking Management topic for some more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tabbed MDI

Docking & MDI Workspace and MDI Features
Tabbed MDI

Tabbed MDI is the default type of MDI found in most modern applications and is fully supported by Actipro Docking & MDI.

Tabbed MDI without any tool windows active

With tabbed MDI, the Workspace area is filled with one or more tab controls (implemented by TabbedMdiContainer) where each tab provides access to its related docking window.

This topic contains these sections:

  • Implementation and Hierarchy
  • Tab Layout Kinds (Pinned, Normal, Preview)
  • Behavior Options
  • Tab Close Buttons
  • Tab Pin Buttons
  • Title vs. Tab Text
  • Tab Tool Tip
  • Tab Images
  • Tab Contextual Content
  • Tab Strip Placement
  • Tab Overflow Behavior
  • Tab Insertion Order
  • New Tab Buttons
  • Content for Empty MDI Hosts
  • Listing All Documents in the MDI Host
  • Cascading Documents
  • Tiling Documents
  • Switching to Tabbed MDI at Run-Time
  • Floating Documents
  • Tab Control Custom Styling
  • Keyboard Shortcuts

Implementation and Hierarchy

At design-time, the MDI area can be instantiated via XAML code. The Control Hierarchy topic has a diagram showing the controls that are needed to implement this type of MDI from XAML. But essentially, to have tabbed MDI features available in your docking layout, you must place a TabbedMdiHost control directly as the Content of the Workspace within the dock site.

At run-time, you can use the common document framework (shared with standard MDI) to manage the documents in the MDI area. The Working with Documents topic describes how to interact with this common document framework to open and close documents along with performing other common tasks. But before doing so, please ensure that a TabbedMdiHost control is the direct Content of the Workspace within the dock site.

Tab Layout Kinds (Pinned, Normal, Preview)

There are three kinds of tabs available: pinned, normal, and preview.

The three kinds of tabs

Normal tabs are the default kind of tab and render normally.

Pinned tabs are tabs that have been pinned by the end user and align to the leftmost end of the tab strip. They also render like normal tabs other than having an unpin button visible.

Preview tabs render on the far right side of the tab strip, generally in a slightly faded-out appearance. They have a keep open button visible that when clicked, will make the tab a normal tab. It is advisable to only have a single preview tab in the UI at any given time.

Switching Kinds

The DockingWindow.TabbedMdiLayoutKind property specifies which kind of tab to use for the docking window when in tabbed MDI.

The end user can use context menus and tab buttons when appropriate to alter the tab layout kind. You can toggle it manually by setting the above property.

Behavior Options

Tabbed MDI has numerous behavior capability options that are available. Several of these are global settings (like TabbedMdiHost.CanDocumentsAttach) and can be overridden by related window-instance settings on the DockingWindow class.

Member | Description
TabbedMdiHost.CanDocumentsAttach Property | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping. The default value is true.
TabbedMdiHost.CanDocumentsCloseOnMiddleClick Property | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button. The default value is true.
TabbedMdiHost.CanDocumentTabsDrag Property | Gets or sets the global setting for whether document tabs may be dragged to another location. The default value is true.

Tab Close Buttons

By default, a close button appears directly on the tabs. This feature can be disabled by setting the TabbedMdiHost.HasTabCloseButtons property to false.

Tab Pin Buttons

By default, no pin button appears directly on 'normal' tabs. This feature can be enabled by setting the TabbedMdiHost.HasTabPinButtons property to true. That option will force a pin button to show on 'normal' tabs when the pointer is over the tab.

Title vs. Tab Text

The DockingWindow.Title property is normally set to determine the title text that is rendered in tabs as well as in title bars and on the standard switcher. In some cases, it might be desirable to have longer text for the Title, such as "Properties - Document1.txt", while having shorting text that renders on tabs, such as "Properties". This allows your title to provide more extensive contextual information.

By setting the TabText property to a non-null value, its value will be used to render the tab text instead of the Title value. In that scenario, the Title value will still be used in title bars and on the standard switcher when the window is selected.

Tab Tool Tip

The DockingWindow.TabToolTip property is automatically bound to the Title property for tool windows and to the FileName property for document windows. Override the TabToolTip property to set alternate tool tip content.

Tab Images

By default the DockingWindow.ImageSource image will not appear on document tabs.

You can force the image to display on the tabs by setting the TabbedMdiHost.HasTabImages property to true.

Tab Contextual Content

Tabbed MDI tabs can display any context-related content to the right of the tab title. This content is set via the DockingWindow.TabbedMdiTabContextContentTemplate property.

See the Contextual Content topic for some more information.

Tab Strip Placement

By default the document tabs will appear above their content, but can be changed to appear on any side of the content.

You can alter the location of the document tabs by changing the value of the TabbedMdiHost.TabStripPlacement property.

Tab Overflow Behavior

There are numerous options from the TabOverflowBehavior enumeration for selecting what happens when the tabs overflow the available tab strip space.

By default, a menu button is displayed that lists all open documents for a container when clicked. This can be changed via the TabbedMdiHost.TabOverflowBehavior property.

Tab Insertion Order

The DockSite.AreNewTabsInsertedBeforeExistingTabs property determines whether new tabs are inserted at the start of a tabbed MDI container. It defaults to true and may be set to false to add new tabs at the end of the container instead.

New Tab Buttons

The TabbedMdiHost.ContainersHaveNewTabButtons property can be set to true to display a new tab button. When this button is clicked, the DockSite.NewWindowRequested event fires. A handler of this event should activate a new document.

This feature is useful for browser-like applications and works best when the TabOverflowBehavior is set to Shrink or ShrinkWithMenu.

Content for Empty MDI Hosts

The TabbedMdiHost.EmptyContentTemplate property can be set to a DataTemplate that should be displayed in the MDI host whenever there are no documents open. If additional data needs to be passed into the data template, set it to the EmptyContent property.

This is a great place to place a company or application logo, or give end users instructions on what to do next to open a document.

Listing All Documents in the MDI Host

The TabbedMdiHost.GetDocuments method returns a list of all documents that are within the MDI host.

Cascading Documents

Call the TabbedMdiHost.Cascade method to automatically cascade the documents into a single TabbedMdiContainer.

Alternatively, the DockSite.CascadeDocuments method provides access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

Tiling Documents

The tiling of documents makes more efficient use of space and will position each document so that it is visible within the workspace.

Call the TabbedMdiHost.TileHorizontally method to tile documents horizontally. Likewise, the TabbedMdiHost.TileVertically method will tile documents vertically.

Alternatively, two methods on DockSite, TileDocumentsHorizontally and TileDocumentsVertically, provide access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

Switching to Tabbed MDI at Run-Time

You can easily switch to tabbed MDI mode at run-time by setting the DockSite.MdiKind property to Tabbed, as long as a Workspace is defined in the dock site.

Floating Documents

While disabled by default, document windows can be floated, similar to tool windows.

Tabbed MDI with a floating document

To float a document window, click on the associated tab and drag it away from the tabbed MDI host. A floating dock host is created with its own tabbed MDI host that contains the dragged document. The document can be redocked at any time.

To enable this feature and allow document windows to be floated, set the DockSite.CanDocumentWindowsFloat property to true.

Tab Control Custom Styling

The TabbedMdiHost.TabControlStyle property can be set to a custom Style for the AdvancedTabControl that is used within the templates of TabbedMdiContainer controls in the host.

Keyboard Shortcuts

The Alt+- keyboard shortcut shows the context menu for the currently selected document in the active tabbed MDI container.

The Ctrl+Alt+DownArrow keyboard shortcut shows the document list menu for the active tabbed MDI container.

Other keyboard shortcuts allow you to jump directly to a tab. Ctrl+1 will activate the first tab in a normal state, with Ctrl+2 activating the second normal tab, and so on. Ctrl+Alt+1 will activate the first tab in a pinned state, with Ctrl+Alt+2 activating the second pinned tab, and so on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Standard MDI

Docking & MDI Workspace and MDI Features
Standard MDI

A standard (windowed) MDI option is implemented by Actipro Docking & MDI via a WindowControl control that mimics the functionality of a native window with resizable borders, minimize/maximize/close buttons, etc.

A context menu is displayed whenever clicking the window icon or right-clicking the title bar.

Standard MDI without any tool windows active

Standard MDI is the first style of MDI found in Windows and still remains popular in certain applications. Each document is represented as its own window and can be moved, resized, minimized, maximized, restored, and closed.

This topic contains these sections:

  • Implementation and Hierarchy
  • Allowing Windows to Maximize/Minimize
  • Window State
  • Restored Window Bounds
  • Making Windows Maximized
  • Hiding Frames when Maximized
  • Size-to-Content
  • Magnetism
  • Title Bar Contextual Content
  • Listing All Documents in the MDI Host
  • Cascading Documents
  • Tiling Documents
  • Arranging Minimized Windows
  • Scrolling
  • Switching to Standard MDI at Run-Time

Implementation and Hierarchy

At design-time, the MDI area can be instantiated via XAML code. The Control Hierarchy topic has a diagram showing the controls that are needed to implement this type of MDI from XAML. But essentially, to have standard MDI features available in your docking layout, you must place a StandardMdiHost control directly as the Content of the Workspace within the dock site.

At run-time, you can use the common document framework (shared with tabbed MDI) to manage the documents in the MDI area. The Working with Documents topic describes how to interact with this common document framework to open and close documents along with performing other common tasks. But before doing so, please ensure that a StandardMdiHost control is the direct Content of the Workspace within the dock site.

Allowing Windows to Maximize/Minimize

The maximize and minimize buttons on windows within the standard MDI area can be selectively shown or hidden using the StandardMdiHost.CanWindowsMaximize and StandardMdiHost.CanWindowsMinimize properties, respectively.

Individual windows can have its maximize and minimize buttons selectively shown or hidden using the DockingWindow.CanStandardMdiMaximize and DockingWindow.CanStandardMdiMinimize properties, respectively.

In addition to hiding the maximize button, the StandardMdiHost.CanWindowsMaximize and DockingWindow.CanStandardMdiMaximize properties will disable the ability to double click the titlebar of a window to maximize it. Windows that do not display their maximize or minimize buttons can still be programmatically maximized/minimized.

Window State

The state, such as normal/minimized/maximized, of the MDI child windows can be retrieved or set using the DockingWindow.StandardMdiWindowState property.

Restored Window Bounds

The restored window bounds and be retrieved or set using the DockingWindow.StandardMdiBounds property.

Making Windows Maximized

The StandardMdiHost.AreWindowsMaximized property gets or sets whether the windows within the standard MDI area are currently maximized.

If you wish for your windows to be opened as maximized by default, set it to true.

Hiding Frames when Maximized

The StandardMdiHost.AreMaximizedWindowFramesVisible can be set to false to hide the title bar and frame of the child MDI windows when they are maximized. This gives more room to the MDI window and is typical for a standard MDI layout.

When hiding the frame, the title and minimize/restore/close buttons are typically presented by an assocated Ribbon, toolbar, or menu of the containing window/control. The Sample Browser includes a 'Standard MDI-Only' sample that show how this can be accomplished.

When using external buttons to manage the windows, these StandardMdiHost commands are available for use with the buttons: MinimizePrimaryWindowCommand, RestorePrimaryWindowCommand, MaximizePrimaryWindowCommand, and ClosePrimaryWindowCommand.

Size-to-Content

If you wish for a docking window to auto-size itself to its content when opened in standard MDI, update its DockingWindow.SizeToContentModes property to contain the SizeToContentModes.StandardMdi flag.

Magnetism

Magnetism allows windows within the standard MDI area to be "snapped" together when moving or resizing. This makes it easier for the end-user to line up the windows into rows or columns.

Magnetism can be configured using DockSite.MagnetismSnapDistance and DockSite.MagnetismGapDistance. The snap distance indicates the distance at which magnetism begins to snap windows being dragged. The gap distance indicates the distance between windows that are snapped together via magnetism. Magnetism can be disabled by setting the snap distance to 0.

Title Bar Contextual Content

Standard MDI window title bars can display any context-related content to the right of the tab title. This content is set via the DockingWindow.StandardMdiTitleBarContextContentTemplate property.

See the Contextual Content topic for some more information.

Listing All Documents in the MDI Host

The StandardMdiHost.GetDocuments method returns a list of all documents that are within the MDI host.

Cascading Documents

Call the StandardMdiHost.Cascade method to automatically cascade the documents as displayed in the screenshot above.

Alternatively, the DockSite.CascadeDocuments method provides access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

By default, the documents will automatically be cascaded on the initial load of the standard MDI host. This behavior can be disabled by setting the StandardMdiHost.IsAutoCascadeEnabled property to false.

Tiling Documents

The tiling of documents makes more efficient use of space and will position each document so that it is visible within the workspace. The visible documents fill the entire workspace area.

Call the StandardMdiHost.TileHorizontally method to tile documents horizontally. Likewise, the StandardMdiHost.TileVertically method will tile documents vertically.

Alternatively, two methods on DockSite, TileDocumentsHorizontally and TileDocumentsVertically, provide access to the same functionality but for all MDI hosts, including those on primary and floating dock hosts.

Arranging Minimized Windows

Call the StandardMdiHost.ArrangeMinimizedWindows method to automatically arrange the minimized windows at the bottom of the MDI host.

Scrolling

By setting the StandardMdiHost.IsScrollingEnabled property to true, scrolling support can be enabled in the standard MDI host. This allows MDI child windows to be dragged out of view, while still allowing the end-user to easily bring it back into view.

This setting is set to false by default.

Switching to Standard MDI at Run-Time

You can easily switch to standard MDI mode at run-time by setting the DockSite.MdiKind property to Standard, as long as a Workspace is defined in the dock site.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Working with Documents

Docking & MDI Workspace and MDI Features
Working with Documents

All documents can be easily managed via DockSite properties and methods, regardless of whether tabbed or standard MDI is in use. This allows your document-related code to remain the same regardless of the style of MDI in use.

This topic contains these sections:

  • Creating a New Document
  • Additional Document Window Properties
  • Opening a Document
  • Activating a Document
  • Enumerating Open Documents
  • Primary Document
  • Working with Open Documents
  • Closing a Document
  • Contextual Content
  • Read-Only Documents

Creating a New Document

A document is just a term referring to a docking window (either a tool or document window) that is in the MDI area.

See the Lifecycle and Docking Management topic for details on how to create a new docking window via code.

Additional Document Window Properties

Document windows have a couple additional properties that aid in their user interface presentation.

The DocumentWindow.FileName property should be set to the full file or URL path of the document content, if appropriate. If this doesn't apply, leave the value null.

The DocumentWindow.Description property should be set to a description of the document type, such as: Text document This value gets displayed on a standard switcher.

Opening a Document

Opening a document will make it visible in the UI, but it won't necessarily be selected or have focus. To ensure a document is opened, selected, and focused, it must be activated instead.

A call to the DockingWindow.Open method will open the document. Alternatively, the IsOpen property can be set to true.

DocumentWindow controls will always open in the MDI area. ToolWindow controls on the other hand will only open in the MDI area if their State is Document before the open occurs.

Activating a Document

Activating a document will open it, select it, and focus its content as well. There is no need to open a document before activating it, because activating includes the open behavior.

A call to the DockingWindow.Activate method will activate the document. An overload of this method allows you to ensure the document is selected but not focused. Alternatively, the IsActive property can be set to true.

As described above, to ensure that a ToolWindow opens in the MDI area, make sure its State property is set to Document before activating it.

Enumerating Open Documents

Use the DockSite.Documents collection to enumerate through the open documents.

Sort the collection by DockingWindow.LastActiveDateTime to order them by which the documents were last activated.

The DockSite.HasDocuments property indicates whether there are currently any open documents.

Primary Document

The DockSite.PrimaryDocument property gets the document that currently is the primary document in the dock site. The primary document is the same as DockSite.ActiveWindow if the active window is a document. When the DockSite.ActiveWindow is not a document, then the primary document is the open document that was last activated.

The DockSite.PrimaryDocumentChanged event fires whenever the primary document changes.

Working with Open Documents

There are numerous DockSite methods that can be used to manipulate open documents.

Member | Description
ActivateNextDocument Method | Activates the next document.
ActivatePreviousDocument Method | Activates the previous document.
ActivatePrimaryDocument Method | Activates the primary (currently selected) document DockingWindow, if there is one.
CascadeDocuments Method | Cascades all open documents, if using tabbed or standard MDI.
CloseAllDocuments Method | Closes all open documents.
ClosePrimaryDocument Method | Closes the primary (currently selected) document DockingWindow if there is one.
TileDocumentsHorizontally Method | Tiles all open documents horizontally, if using tabbed or standard MDI.
TileDocumentsVertically Method | Tiles all open documents vertically, if using tabbed or standard MDI.

Closing a Document

A document can be closed by calling its DockingWindow.Close method.

Note Note
For document windows this will also destroy the window by default unless the DockSite.AreDocumentWindowsDestroyedOnClose property is set to false.

Contextual Content

Tabbed MDI tabs and standard MDI window title bars can display custom contextual content such as buttons or status indicators.

See the Contextual Content topic for some more information.

Read-Only Documents

Document windows have a special feature for automatically supporting the representation of read-only states. When a document window should be marked as read-only in the user interface, set DocumentWindow.IsReadOnly property to true. This will display a small lock context icon next to the document title.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Docking & MDI Layout, Globalization, and Accessibility Features
Overview

Actipro Docking & MDI has an enormous feature set related to layouts, globalization and accessibility.

Layout Serialization

The full tool window layout can be saved to XML and restored later, allowing end users to retain their customized layout information across multiple application executions.

See the Layout Serialization topic for more information.

Nested Dock Sites

Dock sites can be nested, where a child DockSite is placed within a document window or tool window of an ancestor DockSite.

See the Nested Dock Sites topic for more information.

Side-by-Side Dock Sites

Dock sites are completely self-contained, meaning that you can have two DockSite in the same Window and tool windows belonging to one can't be moved into other, and vice versa.

See the Side-by-Side Dock Sites topic for more information.

Tool Window Inner-Fill

Actipro Docking & MDI supports tool window inner-fill mode, in which all tool windows fill the entire content area of the ancestor DockSite.

See the Tool Window Inner-Fill topic for more information.

Programmatic Layout

This topic covers several methods for programmatically arranging and resizing the docking windows.

See the Programmatic Layout topic for more information.

Localization

All strings that are displayed in the user interface can be customized and localized.

See the Localization topic for more information.

UI Automation

This product follows the WPF accessibility model for UI automation.

See the UI Automation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Layout Serialization

Docking & MDI Layout, Globalization, and Accessibility Features
Layout Serialization

The full window layout can be saved to XML and restored later, allowing end users to retain their customized layout information across multiple application executions.

Window layout data stores the location, size, state, and other related information for all document and tool windows currently being managed by the dock site.

This topic contains these sections:

  • Requirements for Docking Windows to Serialize Properly
  • Saving Layout Data
  • Loading Layout Data
  • Window Deserialization Behaviors
  • Optimal Memory Utilization when Using Layout Serializers
  • Disabling Floating Window Snap-to-Screen

Requirements for Docking Windows to Serialize Properly

When serializing a layout, each ToolWindow and DocumentWindow must have either its SerializationId or Name property set to a unique value. These properties are used to restore the layout later by matching the docking windows in the layout with already-registered docking windows in the dock site, meaning tool windows in the DockSite.ToolWindows collection and document windows in the DockSite.DocumentWindows collection.

The Name property is only used for matching if the SerializationId property is not specified. Thus, SerializationId has a higher priority than Name in terms of which property is used to match layout data with registered docking window instances.

The SerializationId property is the preferred property to use for matching layout data with docking windows for two reasons. First, it can accept any text characters as its value, whereas the Name property must be a valid C#/VB identifier (underscore, letter, and number characters only). Second, it can be bound to in ways where the Name property might sometimes be restricted from supporting a binding.

Important Note Important Note
Please make sure every docking window has either a unique SerializationId or Name set as described above, or else layout deserialization will not work properly.

Docking windows can be individually prevented from serializing within a layout by setting their DockingWindow.CanSerialize property to false. This property defaults to true, meaning that all applicable docking windows will normally participate in the serialized layout.

Saving Layout Data

Dock site layout data can be persisted in XML format and loaded at a later time. Probably the two most common ways to store layouts are in files and in a database.

This sample code shows how to save a DockSite layout to an XML string:

C#
VB
Copy
​string layout = new DockSiteLayoutSerializer().SaveToString(dockSite);
​Dim layout As String = New DockSiteLayoutSerializer().SaveToString(dockSite)

Saving the Entire Layout (Including Document Windows and MDI)

By default, only layout information of tool windows is serialized. The full layout, including document windows and the MDI layout, can be saved by setting the DockSiteLayoutSerializer.SerializationBehavior to DockSiteSerializationBehavior.All.

Loading Layout Data

When loaded, dock site layout data restores the location, size, and state of all document and/or tool windows. Layouts that include the full layout information (as described above), will restore document windows, tool windows, and the MDI layout.

The layout data loading code matches the SerializationId (or Name) of windows that were stored in the layout data to the SerializationId (or Name) of windows currently registered with the DockSite.

This sample code shows how to load a DockSite layout from the XML string:

C#
VB
Copy
​new DockSiteLayoutSerializer().LoadFromString(layout, dockSite);
​New DockSiteLayoutSerializer().LoadFromString(layout, dockSite)

Window Deserialization Behaviors

When loading a previously saved layout, any document or tool windows that are missing will not have their layout restored. So if a tool window with the name "TW1" has size and position information in the layout string, but is not currently registered with the DockSite, then it's layout information is ignored.

There are two other behaviors supported, which allow the layout information to be retained and then applied to the associated window. These behaviors can be configured using the DocumentWindowDeserializationBehavior and/or ToolWindowDeserializationBehavior properties on DockSiteLayoutSerializer.

Lazy Loading

The window layout information will be applied to the DocumentWindow and/or ToolWindow later, when they are registered with the DockSite. When loading the layout data, the information for any missing document or tool windows is saved in the DockSite and applied if and when the window is ever created.

This allows the layout information to be properly restored, without have to immediately create the associated document or tool windows.

When using this feature, the DocumentWindow and/or ToolWindow must specify a unique SerializationId or Name so that its associated layout data can be found. In addition, when creating a DocumentWindow and/or ToolWindow its SerializationId or Name must be specified before it is registered with the DockSite. If this is not done, then the layout data will not be restored.

This sample code will not properly load the layout data, because the ToolWindow is registered before it SerializationId property is set:

C#
VB
Copy
​// INCORRECT
ToolWindow tw = new ToolWindow(this.dockSite) {
    SerializationId = "MyToolWindow",
};
​' INCORRECT
Dim tw As ToolWindow = New ToolWindow(Me.dockSite) {
    .SerializationId = "MyToolWindow"
}

This sample code will properly load the layout data, because the ToolWindow has its SerializationId property is set before it is registered:

C#
VB
Copy
​// CORRECT
ToolWindow tw = new ToolWindow() {
    SerializationId = "MyToolWindow",
};
this.dockSite.ToolWindows.Add(tw);
​' CORRECT
Dim tw As ToolWindow = New ToolWindow() {
    .SerializationId = "MyToolWindow"
}
Me.dockSite.ToolWindows.Add(tw)

This sample code will also properly load the layout data, because the ToolWindow has its SerializationId property value passed to the constructor:

C#
VB
Copy
​// CORRECT
ToolWindow tw = new ToolWindow(this.dockSite, "MyToolWindow", "Title", null, "Content");
​' CORRECT
Dim tw As ToolWindow = New ToolWindow(Me.dockSite, "MyToolWindow", "Title", Nothing, "Content")

Normally when a layout is serialized, the dock site's unused lazy load data for docking windows that have not yet been registered will be discarded in the serialized layout. This prevents the data from accumulating over time if you have a scenario where you dynamically create different docking windows with limited lifetime. In some cases, you may wish for this unused lazy load data to persist in the serialized layout. To enable this feature, set the DockSiteLayoutSerializer.CanSerializeUnusedLazyLoadData property to true.

Auto Creation

Alternatively, the missing document or tool windows can be automatically created and registered with the DockSite. During this process, certain information must be manually configured, such as the title, image, and content.

The DockSiteLayoutSerializer.DockingWindowDeserializing is fired before any document and/or tool window is deserialized. The event arguments are of type DockingWindowDeserializingEventArgs, which include the XML node from the layout data and the associated DockingWindow. When using auto-creation, the docking window is a new instance created during the deserialization process. The properties on this window can then be explicitly set, as needed. The event handler attached to DockingWindowDeserializing simply needs to check the name of the XML node to know the window for which the event was fired.

If the DockSite.WindowsOpening event is used instead, check to see if any of the windows specified in the event args have been initialized yet. If not, then set appropriate properties like title, image, and content on the uninitialized windows.

Optimal Memory Utilization when Using Layout Serializers

The layout serializer uses an XmlSerializer as the core .NET object that reads/writes XML data. One issue that has been discovered in the Microsoft .NET framework is that XmlSerializer is capable of creating memory leaks. The leak occurs whenever a new instance of XmlSerializer is created.

To combat this leak we've implemented some caching code on our end, but also highly recommend that instead of creating a new layout serializer any time you do a layout serialization, you instead keep a reference to a single app-wide instance of the layout serializer and use that for each layout serialization.

Disabling Floating Window Snap-to-Screen

By default, when a floating window is created and displayed for reasons other than a drag operation, such as when a layout containing floating windows is loaded, the floating windows will attempt to snap back onto their closest screen. This ensures that they are fully visible to the user and prevents scenarios where the user might have moved a floating window to a location where it is no longer visible on a screen due to screen resolution changes, etc.

This feature can be disabled by setting the DockSite.IsFloatingWindowSnapToScreenEnabled property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Nested Dock Sites

Docking & MDI Layout, Globalization, and Accessibility Features
Nested Dock Sites

Dock sites are completely self-contained and can be nested, where a child DockSite is placed within a document window or tool window of an ancestor DockSite.

Nested dock sites where there are tool windows in inner-fill mode within a document window of another dock site

Many other competitive docking products don't support this feature.

This topic contains these sections:

  • Configuration and Features
  • A XAML Example

Configuration and Features

The creation of a nested dock site scenario is very easy. Just create a root DockSite then add a couple document windows. Within the first document window, place another inner DockSite control and add docking windows to it. Note that you could have chosen to place the child dock site in a tool window instead.

Now, when you drag tool windows around from the dock sites, notice how they remain self-contained within their own ancestor DockSite.

A XAML Example
This sample XAML code shows how to create a nested scenario.
XAML
Copy
​<!-- Outer DockSite -->
<docking:DockSite>
    <docking:SplitContainer>
        <docking:Workspace>
            <docking:TabbedMdiHost>
                <docking:TabbedMdiContainer>

                    <docking:DocumentWindow Title="Document1">
                        <!-- Inner DockSite 1 -->
                        <docking:DockSite>
                            <docking:ToolWindowContainer>
                                <docking:ToolWindow Title="Inner DockSite 1-1">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                                <docking:ToolWindow Title="Inner DockSite 1-2">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                            </docking:ToolWindowContainer>
                        </docking:DockSite>
                    </docking:DocumentWindow>

                    <docking:DocumentWindow Title="Document2">
                        <!-- Inner DockSite 2 -->
                        <docking:DockSite>
                            <docking:ToolWindowContainer>
                                <docking:ToolWindow Title="Inner DockSite 2-1">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                                <docking:ToolWindow Title="Inner DockSite 2-2">
                                    <TextBox BorderThickness="0" />
                                </docking:ToolWindow>
                            </docking:ToolWindowContainer>
                        </docking:DockSite>
                    </docking:DocumentWindow>

                </docking:TabbedMdiContainer>
            </docking:TabbedMdiHost>
        </docking:Workspace>

        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Outer DockSite 1">
                <TextBox BorderThickness="0" />
            </docking:ToolWindow>
            <docking:ToolWindow Title="Outer DockSite 2">
                <TextBox BorderThickness="0" />
            </docking:ToolWindow>
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Side-by-Side Dock Sites

Docking & MDI Layout, Globalization, and Accessibility Features
Side-by-Side Dock Sites

Dock sites are completely self-contained, meaning that you can have two DockSite in the same Window and tool windows belonging to one can't be moved into other, and vice versa.

Two separate dock sites on the same Window

Many other competitive docking products don't support this feature.

This topic contains these sections:

  • Configuration and Features
  • A XAML Example

Configuration and Features

When placing two separate DockSite controls within a root container, they will automatically be independent of each other.

Tool windows will not be able to be dragged from one dock site into the other, unless you link the dock sites.

A XAML Example
This sample XAML code shows how to create a side-by-side scenario.
XAML
Copy
​<Grid>
    <Grid.RowDefinitions>
        <RowDefinition Height="Auto" />
        <RowDefinition Height="*" />
    </Grid.RowDefinitions>
    <Grid.ColumnDefinitions>
        <ColumnDefinition Width="*" />
        <ColumnDefinition Width="7" />
        <ColumnDefinition Width="*" />
    </Grid.ColumnDefinitions>

    <Border Padding="3">
        <TextBlock Text="DockSite #1" />
    </Border>

    <!-- DockSite #1 -->
    <docking:DockSite Grid.Row="1">
        <docking:DockSite.AutoHideLeftContainers>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 1-3" />
                <docking:ToolWindow Title="DockSite 1-4" />
            </docking:ToolWindowContainer>
        </docking:DockSite.AutoHideLeftContainers>

        <docking:SplitContainer>
            <docking:Workspace/>

            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 1-1" />
                <docking:ToolWindow Title="DockSite 1-2" />
            </docking:ToolWindowContainer>
        </docking:SplitContainer>
    </docking:DockSite>

    <Border Grid.Column="2" Padding="3">
        <TextBlock Text="DockSite #2" />
    </Border>

    <!-- DockSite #2 -->
    <docking:DockSite Grid.Row="1" Grid.Column="2">
        <docking:DockSite.AutoHideRightContainers>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 2-3" />
                <docking:ToolWindow Title="DockSite 2-4" />
            </docking:ToolWindowContainer>
        </docking:DockSite.AutoHideRightContainers>

        <docking:SplitContainer>
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="DockSite 2-1" />
                <docking:ToolWindow Title="DockSite 2-2" />
            </docking:ToolWindowContainer>

            <docking:Workspace/>
        </docking:SplitContainer>
    </docking:DockSite>

</Grid>
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Linked Dock Sites

Docking & MDI Layout, Globalization, and Accessibility Features
Linked Dock Sites

Dock sites are completely self-contained but they can be linked, which allows the document and tool windows from one dock site to be dragged/moved to the other dock site.

This topic contains these sections:

  • Linking/Unlinking Dock Sites
  • Programmatically Moving Windows
  • Preventing Windows from Dragging

Linking/Unlinking Dock Sites

A DockSite can be linked with one or more other DockSites using the DockSite.LinkDockSite method. This method only needs to be called on one of the dock sites, as both dock sites will be linked to each other.

Two dock sites can be unlinked using the DockSite.UnlinkDockSite method. Like with the LinkDockSite method, this method only needs to be called on one of the two linked dock sites.

The list of currently linked dock sites can be obtained using the DockSite.LinkedDockSites property.

Note Note
Dock sites hold weak references to their linked dock sites. This allows dock sites to be implicitly unlinked by allowing a dock site to fall out of scope and garbage collected.

Programmatically Moving Windows

The DockingWindow.MoveToLinkedDockSite method can be used to move a specific document or tool window to a linked dock site. After the method has been called, you can use any programmatic methods to open, dock, move to MDI, etc. the docking window within its new dock site.

Preventing Windows from Dragging

As soon as the dock sites are linked, the documents and/or tool windows can be moved between them, both programmatically and interactively. The DockSite.CanDocumentWindowsDragToLinkedDockSites can be set to false to prevent DocumentWindows from being interactively dragged between linked dock sites. To prevent ToolWindows from being interactively dragged to a linked dock site, the DockSite.CanToolWindowsDragToLinkedDockSites can be set to false. Alternatively, the DockingWindow.CanDragToLinkedDockSites property can be used to prevent windows from being dragged to linked dock sites on a window by window basis.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tool Window Inner-Fill

Docking & MDI Layout, Globalization, and Accessibility Features
Tool Window Inner-Fill

Actipro Docking & MDI supports tool window inner-fill mode, in which all tool windows fill the entire content area of the ancestor DockSite.

Tool windows in inner-fill mode, where there is no MDI area

Many other competitive docking products don't support this feature.

Configuration and Features

Tool window inner-fill mode is achieved by omitting a Workspace from within the DockSite.

By leaving out the workspace, the dock site will automatically switch to tool window inner-fill mode. This is similar to the layout mode that is active for floating tool windows.

When in tool window inner-fill mode, no MDI is available and tool windows fill the entire content area of the dock site. Thus all layout sizing is done based on ratios of the initial ToolWindow.ContainerDockedSize values. For instance if two tool windows are docked next to each other, and the first has a ContainerDockedSize width of 100, while the second has a ContainerDockedSize width of 200, the second one will fill the area at twice the width of the first. If the dock site is 600 wide, the first tool window would be 200 wide, while the second would be 400 wide in that example.

A XAML Example
This sample XAML code shows how to create a tool window inner-fill scenario.
XAML
Copy
​<docking:DockSite x:Name="dockSite">
    <docking:DockSite.AutoHideLeftContainers>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 8" />
            <docking:ToolWindow Title="Tool Window 9" />
        </docking:ToolWindowContainer>
    </docking:DockSite.AutoHideLeftContainers>
    <docking:DockSite.AutoHideBottomContainers>
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 10" />
            <docking:ToolWindow Title="Tool Window 11" />
        </docking:ToolWindowContainer>
    </docking:DockSite.AutoHideBottomContainers>

    <docking:SplitContainer>
        <docking:SplitContainer Orientation="Vertical">
            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 1" />
                <docking:ToolWindow Title="Tool Window 2" />
            </docking:ToolWindowContainer>

            <docking:ToolWindowContainer>
                <docking:ToolWindow Title="Tool Window 3" />
                <docking:ToolWindow Title="Tool Window 4" />
                <docking:ToolWindow Title="Tool Window 5" />
            </docking:ToolWindowContainer>
        </docking:SplitContainer>

        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="Tool Window 6" />
            <docking:ToolWindow Title="Tool Window 7" />
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Programmatic Layout

Docking & MDI Layout, Globalization, and Accessibility Features
Programmatic Layout

This topic covers several methods for programmatically arranging and resizing the docking windows.

This topic contains these sections:

  • Resizing Split Container Slots
  • Arranging Tabbed MDI Windows
  • Arranging Standard MDI Windows
  • Setting Docking Window Initial Sizes
  • Setting Docking Window Default Locations

Resizing Split Container Slots

The SplitContainer control is used to arrange the various docking elements vertically or horizontally, while also allowing dynamic resizing. The child elements of the SplitContainer are arranged into slots, which allows the elements to be sized proportionally as the SplitContainer is sized.

The SplitContainer.ResizeSlots method can be used to resize the associated slots, and therefore the underlying docking elements. The ResizeSlots method accepts zero or more ratios, represented by a double array. The ratios are used to calculate new sizes for the associated slots.

For example, this code shows a SplitContainer with two child elements, therefore the SplitContainer has two slots:

XAML
Copy
​...
<docking:SplitContainer Orientation="Horizontal">
    <docking:TabbedMdiContainer>
        <docking:DocumentWindow Title="Upper-1">
            <TextBox TextWrapping="Wrap" Text="A document window in the upper-left corner of the tabbed MDI area." />
        </docking:DocumentWindow>
    </docking:TabbedMdiContainer>
    <docking:TabbedMdiContainer>
        <docking:DocumentWindow Title="Upper-2">
            <TextBox TextWrapping="Wrap" Text="A document window in the upper-right corner of the tabbed MDI area." />
        </docking:DocumentWindow>
    </docking:TabbedMdiContainer>
</docking:SplitContainer>
...

This code can be used to evenly distribute the available space between the two elemnents in the above example:

C#
VB
Copy
​splitContainer.ResizeSlots();
​splitContainer.ResizeSlots()

This code can be used to give the first element twice as much space as the second element:

C#
VB
Copy
​splitContainer.ResizeSlots(2, 1);
​splitContainer.ResizeSlots(2, 1)

The only restriction on the ratios passed is that they be greater than 0. If there are more ratios than there are slots, then the extra ratios will be ignored. If there are more slots than there are ratios, then the last ratio will be repeated for the remaining slots. As a result, passing a single ratio is equivalent to not passing any ratios, since all the slots will share the same ratio.

There is no way to indicate that one slot should use star ('*') sizing. Instead, take into account the current size of the split container and adjust the ratios passed to the ResizeSlots method to get child controls into their desired sizes.

The above code shows how to call the ResizeSlots method, but does not illustrate how the reference to the SplitContainer was obtained.

Note Note
You should never used XAML name references to obtain a specific SplitContainer, as these elements are created and destroyed dynamically as changes are made to the docking layout.

The VisualTreeHelper and VisualTreeHelperExtended can be used to locate the various SplitContainer elements currently used. VisualTreeHelperExtended offers several helper methods for walking up and down the visual tree.

Arranging Tabbed MDI Windows

See the Tabbed MDI topic for more information on arranging tabbed MDI windows.

Arranging Standard MDI Windows

See the Standard MDI topic for more information on arranging standard MDI windows.

Setting Docking Window Initial Sizes

See the Lifecycle and Docking Management topic for more information on setting a different default initial size for docking windows.

Setting Docking Window Default Locations

See the Lifecycle and Docking Management topic for more information on setting a different default location for docking windows.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

Docking & MDI Layout, Globalization, and Accessibility Features
Localization

All strings that are displayed in the user interface can be customized and localized.

This topic contains these sections:

  • Customizing String Resources

Customizing String Resources

All strings that are displayed in the user interface are available from static methods on the ActiproSoftware.Products.Docking.SR class. Use that class to customize string resources as well.

Note Note
String resource customization is described in great detail in the general Customizing String Resources topic. Please see that topic for in-depth information related to localization of string resources.

An enumation named SRName includes a list of all the string resource names.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

Docking & MDI Layout, Globalization, and Accessibility Features
UI Automation

Actipro Docking & MDI follows the accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

Docking & MDI implements automation peers for the following classes:

  • The DockSite class, which is the manager of all docking functionality.
  • The DockHost class, which is the top-level container for all docking hierarchies.
  • The SplitContainer class, which contains two or more other containers in a docking hierarchy.
  • The DockingWindowContainerBase class, which is the base class of TabbedMdiContainer and ToolWindowContainer. This automation peer provides access to the child DockingWindow elements.
  • The StandardMdiHost class. This automation peer provides access to the child DockingWindow elements.
  • The DockingWindow class, which is the base class of DocumentWindow and ToolWindow.
  • The WindowControl class. This automation peer provides access to the child elements and programmatic access to move, resize, or close the window.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


MVVM Features

Docking & MDI Reference
MVVM Features

The Docking & MDI product has been designed to support the popular MVVM pattern. The DockSite control's item container generation features and infrastructure are similar to a standard ItemsControl, but geared towards the generation of docking windows.

Tip Tip
Many of the concepts below are implemented in the MVVM-related samples in the Sample Browser, so be sure to examine those samples.

This topic contains these sections:

  • Specifying Document and Tool Items
  • Styling the Document and Tool Windows
  • Layout Serialization Support
  • Opening and Positioning the Docking Windows
  • Item Containers
  • Item Container Unregistration Triggering Items Source Update
  • Troubleshooting

Specifying Document and Tool Items

The DockSite includes several properties and methods that mimic the design of the native ItemsControl. Using these properties and methods, the DockSite can be bound to a collection of view-models for documents and/or tool windows.

Document Windows

Document windows can be defined by binding the DockSite.DocumentItemsSource property to a collection of items, such as view-models. The items will be wrapped in an instance of DocumentWindow, which is the container used to present the item.

A Style can be applied to the generated DocumentWindow instances by using the DockSite.DocumentItemContainerStyle or DocumentItemContainerStyleSelector properties.

The DataTemplate used by the DocumentWindow instances to present the associated item can be specified using the DockSite.DocumentItemTemplate or DocumentItemTemplateSelector properties.

Tool Windows

Tool windows can be defined by binding the DockSite.ToolItemsSource property to a collection of items, such as view-models. The items will be wrapped in an instance of ToolWindow, which is the container used to present the item.

A Style can be applied to the generated ToolWindow instances by using the DockSite.ToolItemContainerStyle or ToolItemContainerStyleSelector properties.

The DataTemplate used by the ToolWindow instances to present the associated item can be specified using the DockSite.ToolItemTemplate or ToolItemTemplateSelector properties.

Container Customization

The DockSite includes several virtual methods that can be overridden to customize the containers created based on the bound items. These methods mimic the native ItemsControl and includes ClearContainerForItemOverride, GetContainerForItemOverride, IsItemItsOwnContainerOverride, and PrepareContainerForItemOverride. Each of these methods works like it's ItemsControl counterpart, with one exception. Each method includes an additional parameter that specifies whether the container is for a document or tool item.

The PrepareContainerForItemOverride method override could be used to bind your view model's properties to the containing docking window's related properties. The ClearContainerForItemOverride method override would clear those bindings. You don't need to override these methods if you are setting up your bindings in a Style instead that gets used by DocumentItemContainerStyle, ToolItemContainerStyle, etc.

Content and Template

As with a standard ItemsControl bound to a collection of view model items, each item will be assigned to the Content property of the generated container docking window.

These view model items require that a content template be specified to properly render their data. As mentioned above, the DocumentItemTemplate, DocumentItemTemplateSelector, ToolItemTemplate, and ToolItemTemplateSelector properties can be used to designate the DataTemplate to use for each item.

Styling the Document and Tool Windows

Custom styles can easily be applied to the DocumentWindow and/or ToolWindow containers created for the bound items. The DocumentItemContainerStyle, DocumentItemContainerStyleSelector, ToolItemContainerStyle, or ToolItemContainerStyleSelector properties can be used to apply a custom Style.

Layout Serialization Support

If you plan on serializing your layout between application execution sessions, you must assign your docking windows a unique Name or SerializationId. It is recommended that you use the SerializationId property since unlike the Name property, it can be bound easier and allows any character to be used in the value.

Opening and Positioning the Docking Windows

The DocumentWindow and/or ToolWindow containers created for the bound items will initially be closed and must be opened to appear in the visible layout.

Numerous bindable properties are available on DockingWindow for determining the state and position of docking windows, along with whether they are open and active. For instance, the State property can be set to designate which state the window should open in. This property must remain Document for any DocumentWindow. To open a docking window and add it to the layout, set its IsOpen property to true. To open a docking window (if it isn't already open) and ensure it's selected and focused, set its IsActive property to true. This can be done instead of setting IsOpen. Finally, to make sure an already-open docking window's tab is selected, set its IsSelected property to true.

When a docking window is opened via its IsOpen or IsActive properties, it will open in a default location. There are numerous properties and events available that allow you to customize this default location prior to opening the docking window. Some examples are ToolWindow.DefaultDockSide, DockingWindow.WindowGroupName, DockSite.WindowDefaultLocationRequested, etc.

If you prefer to open, activate, dock, etc. a docking window in code-behind instead, this can be easily accomplished by adding a handler for the DockSite.WindowRegistered event. This event is fired once per DocumentWindow and/or ToolWindow when it is initially registered with the DockSite.

The following code shows an example of a WindowRegistered handler:

C#
VB
Copy
​dockSite.WindowRegistered += this.OnDockSiteWindowRegistered;

// ...

/// <summary>
/// Handles the <c>WindowRegistered</c> event of the <c>DockSite</c> control.
/// </summary>
/// <param name="sender">The source of the event.</param>
/// <param name="e">The <see cref="DockingWindowEventArgs"/> instance containing the event data.</param>
private void OnDockSiteWindowRegistered(object sender, DockingWindowEventArgs e) {
    DockSite dockSite = sender as DockSite;
    if (dockSite == null)
        return;

    // Ensure the DockingWindow exists and is generated for an item
    DockingWindow dockingWindow = e.Window;
    if (dockingWindow == null || !dockingWindow.IsContainerForItem)
        return;

    // Open the DockingWindow, if it's not already open
    if (!dockingWindow.IsOpen) {
        // ** Open window in desired location here
    }
}
​AddHandler dockSite.WindowRegistered, AddressOf OnDockSiteWindowRegistered

' ...

''' <summary>
''' Handles the <c>WindowRegistered</c> event of the <c>DockSite</c> control.
''' </summary>
''' <param name="sender">The source of the event.</param>
''' <param name="e">The <see cref="DockingWindowEventArgs"/> instance containing the event data.</param>
Private Sub OnDockSiteWindowRegistered(ByVal sender As Object, ByVal e As DockingWindowEventArgs)
    Dim dockSite As DockSite = TryCast(sender, DockSite)
    If dockSite Is Nothing Then
        Return
    End If

    ' Ensure the DockingWindow exists and is generated for an item
    Dim dockingWindow As DockingWindow = e.Window
    If dockingWindow Is Nothing OrElse (Not dockingWindow.IsContainerForItem) Then
        Return
    End If

    ' Open the DockingWindow, if it's not already open
    If Not dockingWindow.IsOpen Then
        ' ** Open window in desired location here
    End If
End Sub

Item Containers

The DockingWindow.IsContainerForItem property returns true when a docking window is a generated container for an item in the DockSite.DocumentItemsSource or DockSite.ToolItemsSource collections.

The ContainerFromItem method can be used to retrieve the DocumentWindow or ToolWindow associated with a given item. If the type of the item is known, then the ContainerFromDocumentItem or ContainerFromToolItem methods can be used instead.

Item Container Unregistration Triggering Items Source Update

The DockSite.CanUpdateItemsSourceOnUnregister property indicates whether to watch the WindowUnregistered event for an item container DockingWindow to be unregistered. If that property is true, the dock site will try to automatically remove the related item from the appropriate DockSite.DocumentItemsSource or DockSite.ToolItemsSource collection.

The functionality will only succeed if the items source is an IList that is not read-only or fixed size.

In scenarios where the above conditions are not met, it is up to you to watch the WindowUnregistered event and remove the related item from its items source.

Troubleshooting

See the Troubleshooting topic for more information, with some specific details on configuring data contexts properly.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AdvancedTabControl

Docking & MDI Reference
AdvancedTabControl

Docking & MDI includes a very full-featured tab control named AdvancedTabControl that is extremely customizable and can be used independently of docking windows in your apps.

The type of item for the AdvancedTabControl is AdvancedTabItem. Make sure to use that type or a derived class whenever specifying tab items.

This topic contains these sections:

  • Selection
  • Tab Layout Kinds
  • Tab Images
  • Tab Overflow Behavior
  • Tab Strip Placement
  • Tab Content Orientation
  • Tab Control Appearance
  • Tab Appearance
  • New Tab Button
  • Embedded Buttons
  • Tab Closing
  • Tab Dragging to Reorder
  • Layout Animation
  • Menus
  • Keyboard Shortcuts

Selection

Just like with standard ItemsControl and Selector controls, the SelectedItem property specifies the item that is currently selected in the tab control. Note that in MVVM scenarios, this will return the item that is selected and not the AdvancedTabItem.

Tab Layout Kinds

Tabs can be displayed in three layout kinds within the tab control: pinned, normal, and preview. Each tab's layout kind is set via the AdvancedTabItem.LayoutKind property, which defaults to Normal.

Normal tabs appear normally and left-aligned within the tab strip. If the AdvancedTabControl.CanTabsPin is true they will show a pin button that allows them to change to the Pinned layout kind when clicked.

Pinned tabs always appear to the left of all normal tabs. They always show an unpin button that when clicked, will return them to Normal layout kind.

Preview tabs show up right-aligned in the tab strip. They are meant to show temporary contextual information. As long as the AdvancedTabControl.CanTabsPromote property remains its default true value, preview tabs will have a button on them that when clicked, will change the tab to a Normal layout kind.

Tab Images

Tabs can show images on them if the AdvancedTabControl.HasTabImages property is set to true and the AdvancedTabItem.ImageSource property is set to a valid ImageSource.

Tab Overflow Behavior

There are numerous options from the TabOverflowBehavior enumeration for selecting what happens when the tabs overflow the available tab strip space.

By default, the tabs shrink to fit within the available tab strip space. This can be changed via the AdvancedTabControl.TabOverflowBehavior property.

Tab Strip Placement

The tab strip can be located on any side (left, top, right, bottom) of the tab control. Use the TabStripPlacement property to adjust the side as needed.

Tab Content Orientation

Tabs will normally always display their content in a horizontal orientation, even when the tab strip placement is on the left or right.

Tab content can be rotated to a vertical orientation by setting the AdvancedTabControl.IsTabContentHorizontal property to false.

Tab Control Appearance

The tab control has several properties that adjust its own appearance.

Tab Strip Visibility

The tab strip can be hidden by setting the AdvancedTabControl.IsTabStripVisible property to false.

Highlight

The tab strip can display an optional highlight border around its outside. The border thickness is set by the AdvancedTabControl.HighlightThickness property and the brushes used to render the highlight are specified via the HighlightBrushInactive and HighlightBrushActive properties. Which one is used depends on if the tab control is marked active.

Flagging as Active

The AdvancedTabControl.IsActive property flags the tab control as whether it is currently active or not. This flag is generally set to true when the focus moves within the tab control. The active setting affects which brushes are used for highlight effects and tab rendering.

Tab Appearance

Numerous properties allow you to completely customize the appearance of tabs in the tab control.

Background, Border, and Foreground

There are numerous variations of properties like AdvancedTabControl.TabBackground, such as TabBackgroundPointerOver, etc. that determine the background brush used to render tabs in various layout kinds and states.

Likewise, similar sets of layout kind and state properties are available for TabBorderBrush and TabForeground.

Corner Radius

The AdvancedTabControl.TabCornerRadius property sets the corner radius of tab borders, relative to a top-facing tab.

Padding

The AdvancedTabControl.TabPadding property sets the tab padding, relative to a top-facing tab.

Spacing

The AdvancedTabControl.TabSpacing property, which defaults to 0, determines the amount of space between each tab. Set it to a negative value to have tabs overlap each other.

Minimum and Maximum Extents

The AdvancedTabControl.MinTabExtent and MaxTabExtent properties set the minimum and maximum extent (length) that a tab can be. Set these properties to the same value to create fixed size tabs.

Highlighting Inactive Tabs On Pointer Over

The AdvancedTabControl.CanTabsHighlightOnPointerOverWhenInactive property sets whether tabs can highlight when the pointer is over inactive ones. The default value is false.

New Tab Button

A new tab button can be displayed by setting the AdvancedTabControl.HasNewTabButton property to true. The new tab button appears just to the right of the normal tabs. It is recommended that one of the shrink-related overflow behaviors is used when a new tab button is present.

The style of the button can be set with the NewTabButtonStyle property.

When the button is clicked, the NewTabRequested event fires. Handlers of that event should add a new tab to the control in response.

Embedded Buttons

The tab control and its tabs can embed several buttons. Tab control embedded buttons generally display in response to the tab overflow behavior setting. Several tab embedded buttons depend on the tab's layout kind and other options like AdvancedTabControl.HasTabCloseButtons.

Some tab embedded buttons are only visible when the tab is selected or in a pointer over state. The AdvancedTabControl.AreTabEmbeddedButtonsAlwaysVisible property sets whether tab embedded buttons are always visible, even when the tab is unselected.

The AdvancedTabControl.EmbeddedButtonStyle property allows you to customize the Style of tab control embedded buttons, while the TabEmbeddedButtonStyle property allows you to customize the Style of tab embedded buttons,

The AdvancedTabControl.MenuButtonContentTemplate, OverflowMenuButtonContentTemplate, ScrollBackwardButtonContentTemplate, and ScrollForwardButtonContentTemplate properties allow you to customize the DataTemplate of the related tab control embedded buttons.

Tab Closing

Tabs can close when their embedded close button is clicked or also on middle-click if the AdvancedTabControl.CanTabsCloseOnMiddleClick property is set to true. These features also require that the AdvancedTabItem.CanClose property is true.

When a tab is about to close, it raises the AdvancedTabControl.TabClosing event. If the Cancel flag is set to true in the event arguments, the close will not occur. This event is a good place to prompt the end user about unsaved changes, etc.

Tab Dragging to Reorder

While tabs do support dragging to reorder themselves, the feature is not enabled by default. To enable this behavior, set the AdvancedTabControl.CanTabsDrag property to true.

Layout Animation

By default, animation effects are applied during layout, such as when tabs are added or removed from the tab control. To disable these animation effects, set the AdvancedTabControl.IsLayoutAnimationEnabled property to false.

Menus

The AdvancedTabControl.MenuOpening event fires before a context or drop-down menu is opening. Its event arguments specify the related AdvancedTabItem, if any, along with the default menu that will be displayed. You can fully customize or change the menu to suit your needs.

Keyboard Shortcuts

When the AdvancedTabControl.IsTabKeyboardSwitchingEnabled property is true (the default), the Ctrl+Tab shortcut will switch to the next tab and the Ctrl+Shift+Tab shortcut will switch to the previous tab.

When the AdvancedTabControl.IsTabKeyboardAccessEnabled property is true (the default), keyboard access to directly select a tab is enabled. Ctrl+1 will activate the first tab in a normal state, with Ctrl+2 activating the second normal tab, and so on. Ctrl+Alt+1 will activate the first tab in a pinned state, with Ctrl+Alt+2 activating the second pinned tab, and so on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


WindowControl

Docking & MDI Reference
WindowControl

During the implementation of standard MDI and hosted floating windows for this product, we ran into the need for a Window-like class that was skinnable and behaved like a regular Control. Thus we developed WindowControl, a control that looks and acts like a Window and can mimic both normal and tool window styles.

A WindowControl on top of a Canvas

WindowControl is a Control that implements most of same members as the standard WPF Window class.

This topic contains these sections:

  • What Can I Do with WindowControl?
  • Working with the WindowControl
  • Managing the Title Bar

What Can I Do with WindowControl?

Unlike a normal Window, WindowControl can be put in any control hierarchy. It also supports complete templating and can be animated.

Want to have a window that flies and rotates into view? No problem!

While we use WindowControl in two general areas in this product, we wanted to make it available to you as well in case you find your own uses for it.

Working with the WindowControl

WindowControl inherits ContentControl so set its

As mentioned above we implemented many of the same members found in a WPF Window within WindowControl. You can set properties such as WindowState or ResizeMode. Browse through the members list on the WindowControl control to see what is available to you.

There are also a number of extra properties, methods, and events that aren't on Window, such as the ToggleWindowState method, the TitleBarMenuOpening event, etc.

Title bar drags and border resize operations will cause the control's Left, Top, Width, and Height properties to be altered. To support drag operations visually, place the WindowControl in a Canvas and bind the Canvas.Left attached property to the WindowControl.Left property, and Canvas.Top attached property to the WindowControl.Top property.

Managing the Title Bar

The title bar can be hidden entirely by setting HasTitleBar to false. Alternatively, the buttons, icon, and text displayed by the title bar can be customized as described below.

Buttons

A number of properties can be used to alter the state or visibility of the title bar buttons. By default, the current window state governs which of the minimize, restore, and maximize buttons are visible.

The CanClose property indicates if the close button is enabled.

Sometimes it is useful to be able to always force one or more of the buttons to be hidden. One use case is where you don't wish to allow minimization of the window and never want the minimize button visible. The HasMinimizeButton, HasRestoreButton, HasMaximizeButton, and HasCloseButton properties can be set to false to specify that their related button should never be visible.

Icon

An icon can be displayed by setting WindowControl.Icon to a valid ImageSource. By default, the icon is displayed when an valid image is specified. You can alter this behavior by explicitly setting WindowControl.HasIcon. Therefore, you can force the WindowControl to display the specified image by setting HasIcon to true.

Note Note
The icon is restricted to be 16 pixels wide by 16 pixels high.

Context Content

Additional context content can be added to the right of the title bar text by using the WindowControl.ContextContent, WindowControl.ContextContentTemplate, and WindowControl.ContextContentTemplateSelector properties.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

Docking & MDI Reference
Troubleshooting

This topic contains troubleshooting data specific to the Docking & MDI product.

Note Note
For some more troubleshooting information that relates both to this product as well as other WPF Studio products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • Document/Tool Window Content Sizing Is Incorrect
  • Programmatic Layout Updates Don't Work Until Loaded
  • Document/ToolWindow DataContext Cleared On Layout Changes

Document/Tool Window Content Sizing Is Incorrect

A common mistake is to set the Width, Height, MinWidth, MinHeight, MaxWidth, or MaxHeight properties of a docking window (ToolWindow or DocumentWindow) instance. Since the docking elements need to dynamically change their size based on their location, these properties should never be set by you.

Instead, you can set the DockingWindow.ContainerDockedSize, ContainerMinSize, ContainerMaxSize, and ToolWindow.ContainerAutoHideSize properties as appropriate for your needs.

See the Lifecycle and Docking Management topic for details on using these properties.

Programmatic Layout Updates Don't Work Until Loaded

Sometimes docking windows are programmatically added to a layout (via opening, docking, layout loading, etc.) within the contructor of a root element like a Window or UserControl after its InitializeComponent method executes. In situations like this, the code to add the docking windows to the layout needs to be performed at or after the time that root element's Loaded event fires.

When the root element has loaded, that means that all the templates of the control hierarchy within the dock site have been properly loaded and applied as well. The dock site and its features are then ready for programmatic interaction.

Document/ToolWindow DataContext Cleared On Layout Changes

In many common app design scenarios, you set a data context on a root container in your element hierarchy. Naturally you expect it to inherit down the tree of elements and into the ToolWindow and DocumentWindow.DataContext properties.

While that may work on initial load, the problem is that as soon as the layout changes, such as when an end user drags a tool window to float, the DataContext will clear. This is because the tool window has now moved to a new root container, and the data context is no longer inheriting down.

Note Note
This issue is not present when using our MVVM Features since in that case, the DataContext of each docking window becomes the item you bound in the DockSite.ToolItemsSource or DocumentItemsSource properties.

If the content of your docking windows will rely on a data context that normally would be inherited down, you should explicitly bind your docking window's DataContext property to the dock site's DataContext like this:

XAML
Copy
​<docking:DockSite x:Name="dockSite">
    <docking:SplitContainer>
        <docking:Workspace />
        <docking:ToolWindowContainer>
            <docking:ToolWindow Title="DataContext Test" DataContext="{Binding ElementName=dockSite, Path=DataContext}">
                <TextBlock Text="{Binding}" />
            </docking:ToolWindow>
        </docking:ToolWindowContainer>
    </docking:SplitContainer>
</docking:DockSite>

By doing that, you ensure that the docking window data contexts will still match the dock site's data context, even when any layout changes occur, such as floating windows.

The same concept applies if you have a Workspace that has direct content (no MDI) and that content relies on an inherited data context. Changing the docking window layout around the workspace will briefly cause the workspace to be removed from and added back into the layout. Both are actions that temporarily change the inherited data context. By using a binding as above on the workspace's data context, that can be prevented.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Editors Reference
Overview

Actipro Editors provide a number of edit controls for common .NET data types such as dates, times, numbers, brushes, colors, enumerations, sizes, and many more. Other miscellaneous controls include a regex-based masked textbox, calculator, month calendar, star rating, gradient stop slider, and various color component pickers.

Each of the controls features unique designs that have been specifically crafted to support input by keyboard, mouse, and touch. The control appearances align with other native controls, allowing them to be dropped right into an app and be instantly approachable by end users.

Features

Edit Boxes

  • Common Features
    • Ability to type values directly in, or use mouse/touch to show advanced picker drop-downs.
    • Typed-in values are validated when committed.
    • Use up/down arrow and PgUp/PgDn keys to cycle through known values in a current part.
    • Use left/right arrow keys to move between parts in multi-part edit boxes.
    • Optional null value support.
    • Optional clear and popup buttons.
    • Optional read-only mode.
    • Optional non-editable mode, changing behavior to be similar to a ComboBox.
    • Placeholder text and header support.
    • Drop-down picker customization options.
    • Renders just like a standard ComboBox.
    • Alternate appearance that automatically kicks in for Windows Phone usage.
  • .NET Types Supported
    • Brush - Shows brush swatch and optionally allows alpha component and gradients.
    • Color - Shows color swatch and optionally allows alpha component.
    • CornerRadius - Display format, min/max values, and small/large change values supported.
    • Date - Display format, and min/max values supported. Can optionally retain time component.
    • DateTime - Display format, and min/max values supported.
    • Double - Display format, min/max values, and small/large change values supported.
    • Enum - Supports flags and non-flags enums. Optional custom sorting and use of display attributes.
    • Guid - New GUID generation button.
    • Int16 - Display format, min/max values, and small/large change values supported.
    • Int32 - Display format, min/max values, and small/large change values supported.
    • Int64 - Display format, min/max values, and small/large change values supported.
    • Point - Display format, min/max values, and small/large change values supported.
    • Rect - Display format, min/max values, and small/large change values supported.
    • Size - Display format, min/max values, and small/large change values supported.
    • Thickness - Display format, min/max values, and small/large change values supported.
    • Time - Display format, and min/max values supported.
    • TimeSpan - Display format, min/max values, and small/large change values supported.

Pickers

  • Common Features
    • Designed for keyboard, mouse, and touch support and generally used in drop-downs.
    • Has many of the same options found in the related edit box.
  • .NET Types Supported
    • Brush - Combines a ColorPicker with GradientStopSlider for brush entry.
    • Color - Combines a HsbColorPicker with multiple Int32EditBox controls for ARGB component entry.
    • CornerRadius - Uses tabbed radial sliders.
    • Date - Users a MonthCalendar.
    • DateTime - Combines a MonthCalendar and TimePicker.
    • Double - Uses a radial slider or calculator.
    • Enum - Uses an EnumListBox.
    • Int16 - Uses a radial slider or calculator.
    • Int32 - Uses a radial slider or calculator.
    • Int64 - Uses a radial slider or calculator.
    • Point - Uses tabbed radial sliders.
    • Rect - Uses tabbed radial sliders.
    • Single - Uses a radial slider or calculator.
    • Size - Uses tabbed radial sliders.
    • Thickness - Uses tabbed radial sliders.
    • Time - Uses radial sliders to input hour and minute values, similar to an analog clock.
    • TimeSpan - Uses tabbed radial sliders.

Other Controls

  • Calculator - Provides a familiar calculator interface to interactively calculate numeric values.
  • CountryComboBox - Includes a complete country list as defined by the ISO.
  • CurrencyComboBox - Includes a complete currency list as defined by the ISO.
  • EnumListBox - Presents the values of an enumeration in a list box. Supports flags and non-flags enums.
  • GradientStopSlider - Modify the stops within a gradient brush.
  • HsbColorPicker - Selects a HSB (hue, saturation, brightness) color via a RadialHuePicker and SaturationBrightnessPicker.
  • MaskedTextBox - A text box that restricts input based on a specified regular expression mask. Support for input prompts and literal completion is included.
  • MonthCalendar - Month, year, decade, and century views with animated changes. Appearance customization supported.
  • RadialHuePicker - Uses a radial slider to select a color hue.
  • Rating - Renders glyphs that can be used present an average rating or collect a user rating.
  • SaturationBrightnessPicker - Uses a 2D slider to select saturation/brightness values in a square.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Editors Reference
Getting Started

Getting started with Editors is simple. Follow the steps below to build your first chart.

This topic contains these sections:

  • Add Extension SDK Reference
  • Add Any Editor Control
  • Further Study

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Add Any Editor Control

Then find the parent element that will contain the editor. This could be a UserControl or any other type of UIElement.

Next, add an editor control to the desired parent element. In this sample we will add the Int32EditBox to a UserControl:

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:editors="using:ActiproSoftware.UI.Xaml.Controls.Editors">
    <editors:Int32EditBox />
</UserControl>

Next configure the control's options, set up a binding to the Value property, and you are all done.

There are over 30 editor controls contained in this product. Be sure to check them all out.

Further Study

To familiarize yourself with all of the features in Editors, take a look at the feature documentation and also look at the numerous QuickStarts located in the sample project.

If you require further assistance after looking through those, please visit our Editors support forum.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Edit Boxes
Overview

Actipro Editors includes a number of edit boxes, which are controls that allow for the editing/selection of common data type values. They are designed to visually fit right in with the standard Windows controls.

This topic contains these sections:

  • Edit Box Basics
  • Edit Box Controls

Edit Box Basics

All of the edit box controls listed below share a base class that provides common core functionality.

See the Edit Box Basics topic for more information.

Edit Box Controls

This table shows the edit box controls that are included in the product:

Name | Description
BrushEditBox | Allows for the input of a Brush value.
ColorEditBox | Allows for the input of a Color value.
CornerRadiusEditBox | Allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value.
DateEditBox | Allows for the input of a DateTime value's date component.
DateTimeEditBox | Allows for the input of a DateTime value.
DoubleEditBox | Allows for the input of a Double (floating-point number) value.
EnumEditBox | Allows for the input of an Enum (flags and non-flags enumeration) value.
GuidEditBox | Allows for the input of a Guid (unique ID) value.
Int16EditBox | Allows for the input of an Int16 (16-bit integer) value.
Int32EditBox | Allows for the input of an Int32 (32-bit integer) value.
Int64EditBox | Allows for the input of an Int64 (64-bit integer) value.
PointEditBox | Allows for the input of a Point (X, Y) value.
RectEditBox | Allows for the input of a Rect (X, Y, width, height) value.
SingleEditBox | Allows for the input of a Single (floating-point number) value.
SizeEditBox | Allows for the input of a Size (width, height) value.
ThicknessEditBox | Allows for the input of a Thickness (left, top, right, bottom) value.
TimeEditBox | Allows for the input of a DateTime value's time component.
TimeSpanEditBox | Allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Edit Box Basics

Edit Boxes
Edit Box Basics

All of the edit box controls share a PartEditBoxBase`1 base class that provides common core functionality.

This topic contains these sections:

  • Designed for Keyboard, Mouse, and Touch Input
  • Values
  • Null Values
  • Value Validation
  • Incrementing/Cycling Values
  • Moving Between Parts
  • Input Scope Hints
  • Read-Only Mode
  • Non-Editable Mode
  • Clear Button
  • Popups and Picker Customization
  • Placeholder Text
  • Header
  • Appearances That Match Native Controls

Designed for Keyboard, Mouse, and Touch Input

Unlike many other third party editor controls, the Actipro Editors have been specifically designed to work great for whichever form of input (keyboard, mouse, or touch) is utilized by the end user.

Each editor's main appearance is similar to a standard TextBox, where the value can be typed in via a keyboard for maximum efficiency. Certain keyboard keys and the mouse wheel can often be used to increment/cycle values. See the related section below for more information.

Most editors also contain a default popup picker that is geared for mouse and touch-based input. The popup can easily be invoked by tapping the edit box's drop-down button, if it is optionally displayed.

Values

The Value property gets/sets the value that is being edited by the edit box. When using an edit box in your UI, you generally want to bind this property to your view model via two-way binding.

As the user types in a value, the temporary value derived from the text being typed is available in the IntermediateValue property. This intermediate value gets 'committed' (or set to the Value property) when Enter is pressed, or the control loses focus. There also is a Commit method that will programmatically commit the intermediate value. In the event that a typed value isn't desired, the user can press Esc to revert back to the last committed value.

When the Value property is changed, the ValueChanged event is raised.

Null Values

The IsNullAllowed property determines if a null value is permitted. It can be set to false to designate that a non-null value is required.

Many of the Value properties are implemented as nullable types. For instance, the Int32EditBox.Value property is of type Nullable<Int32>. When IsNullAllowed is false, an integer will always be returned in the Value property and the control will make its default value show 0 instead of blank text.

Value Validation

Value validation occurs when the user types in a value and attempts to commit it. In this scenario, the protected TryConvertFromString method is called and the edit box attempts to convert the typed text into a value. Then that value is checked via a call to the IsValidValue method. If no conversion is possible or if the value fails validation, the value is not committed.

Custom conversion and validation logic can be implemented by overriding the TryConvertFromString and its related ConvertToString method.

Incrementing/Cycling Values

Up/down arrow keys, PgUp/PgDn keys, and the mouse wheel can all be used to increment and decrement the value in many edit boxes.

The up/down arrow keys and mouse wheel will cycle values by a small amount (in the case of numbers) and PgUp/PgDn keys will cycle values by a larger amount.

The SpinWrapping property property determines the wrapping behavior used when spinning past a minimum or maximum value in the active part. See the documentation on the SpinWrapping enumeration for more information on the available options.

Moving Between Parts

Some edit boxes have multiple component parts. An example is the TimeEditBox, which generally has hour, minute, and AM/PM parts.

For these types of edit boxes, the IsArrowKeyPartNavigationEnabled property determines if the left/right arrow keys move between parts. When true, pressing one of those arrow keys will move to the previous/next part and select its text. This makes it easy to quickly jump to a certain component of the value being edited and then either type over that component value or increment/cycle it.

Input Scope Hints

The InputScopeNameValue property accepts a value of type InputScopeNameValue, which provides a hint of how non-read-only edit boxes should display their soft keyboards. Edit boxes with number, date, and time values will default to a Number setting, while all others will use the Default setting.

Read-Only Mode

When the IsReadOnly property is true, the text in the edit box remains selectable but is read-only and can't be changed. Some edit boxes may still show a popup but the picker on the popup will remain read-only as well.

Non-Editable Mode

When the IsEditable property is false, the edit box converts its appearance and behavior to that of a standard ComboBox as long as the edit box indicates it has a popup. Tapping anywhere on the edit box will open an available popup, if there is one. The popup can be used to alter the value.

Up/down arrow keys, PgUp/PgDn keys, and the mouse wheel can be used to increment and decrement the value in non-editable edit boxes that have a single part.

When in non-editable mode, the standard clipboard keyboard shortcuts (Ctrl+C, Ctrl+X, and Ctrl+V) are available to get/set the text value of the edit box. Cut and paste will not modify the value if the control is in read-only mode.

Clear Button

A clear button (with X icon) normally appears when the control has focus (in Windows apps) or all the time (in Windows Phone apps). The button can be tapped to clear or reset the value in the edit box, which is done via a call to the protected ResetValue method.

The clear button can be hidden by setting the HasClearButton property to false.

Popups and Picker Customization

Most edit boxes have popups that can optionally be displayed, which contain pickers that are geared for mouse/touch data input. If a popup is available, a drop-down button will be displayed in the right side of the edit box. This drop-down button can be hidden by setting the HasPopup property to false.

Each edit box with a popup has a default picker control associated with it. For instance, the Int32EditBox control has a related separate Int32Picker control that is used in its popup. The edit box and pickers are named with the same prefix so that it's easy to know how they are paired up.

A custom picker style can be easily assigned to an edit box to give the picker a unique custom user interface. In the screenshot above, we've made a new Style for Int32Picker that uses a linear slider and assigned that style to the Int32EditBox.PopupPickerStyle property.

Placeholder Text

Edit boxes support placeholder text that is rendered when there is no value in the control. This text can be designated via the PlaceholderText property.

Header

Header content that optionally appears above the control can also be used to label what data the control is collecting. This header content is set via the Header and HeaderTemplate properties.

Appearances That Match Native Controls

The edit boxes have been carefully crafted to match the standard UI of related native controls found in Windows.

Above we see how a ColorEditBox fits right in with any standard Windows app TextBox or ComboBox.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BrushEditBox

Edit Boxes
BrushEditBox

The BrushEditBox control allows for the input of a Brush value. It uses the BrushPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Alpha Transparency
  • Gradient Support
  • Swatch Display
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Alpha Transparency

The BrushEditBox.IsAlphaEnabled property can be set to false to prevent alpha transparency from being supported.

When false, the edit box will only allow selection of RGB colors instead of ARGB colors.

Gradient Support

The BrushEditBox.IsGradientAllowed property can be set to false to prevent gradient brushes from being supported.

When false, the edit box will only allow selection of solid color brushes.

Swatch Display

The BrushEditBox.HasSwatch property defaults to true, meaning that a small swatch will display the Brush value. Set the property to false to hide the swatch.

The SwatchMargin property sets the margin thickness around the swatch.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:BrushEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ColorEditBox

Edit Boxes
ColorEditBox

The ColorEditBox control allows for the input of a Color value. It uses the ColorPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Alpha Transparency
  • Swatch Display
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Alpha Transparency

The ColorEditBox.IsAlphaEnabled property can be set to false to prevent alpha transparency from being supported.

When false, the edit box will only allow selection of an RGB color instead of an ARGB color.

Swatch Display

The ColorEditBox.HasSwatch property defaults to true, meaning that a small swatch will display the Brush value. Set the property to false to hide the swatch.

The SwatchMargin property sets the margin thickness around the swatch.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • A (optional)
  • R
  • G
  • B

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current color component by a single unit. Large value changes alter the current color component by 16 units.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ColorEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CornerRadiusEditBox

Edit Boxes
CornerRadiusEditBox

The CornerRadiusEditBox control allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value. It uses the CornerRadiusPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Top-left
  • Top-right
  • Bottom-right
  • Bottom-left

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:CornerRadiusEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DateEditBox

Edit Boxes
DateEditBox

The DateEditBox control allows for the input of a DateTime value's date component. It uses the DatePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Time Retention
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Time Retention

When using separate DateEditBox and TimeEditBox controls that bind to the same DateTime object, it's sometimes helpful to have the DateEditBox retain the time portion as selections are made, instead of reverting the time to midnight. The CanRetainTime property can be set to true to enable time retention.

Note that a DateTimeEditBox can be used in place of separate DateEditBox and TimeEditBox controls if dates and times require input.

Formats

Standard date formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • d
  • D
  • m
  • y
  • MM/dd/yyyy
  • MM/dd/yy
  • yyyy-MM-dd
  • d MMMM yyyy
  • d MMM yyyy
  • dd.MM.yyyy
  • d.M.yyyy

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Year
  • Month
  • Day
  • Hour
  • Minute
  • Second
  • AM/PM

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DateEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DateTimeEditBox

Edit Boxes
DateTimeEditBox

The DateTimeEditBox control allows for the input of a DateTime value. It uses the DateTimePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Formats

Standard date/time formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • g
  • G
  • f
  • F
  • MM/dd/yyyy hh:mm tt
  • MM/dd/yy h:mm:ss tt
  • yyyy-MM-dd HH:mm:ss
  • d MMMM yyyy HH:mm
  • d MMM yyyy HH:mm
  • dd.MM.yyyy HH:mm
  • d.M.yyyy HH:mm

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Year
  • Month
  • Day

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DateTimeEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DoubleEditBox

Edit Boxes
DoubleEditBox

The DoubleEditBox control allows for the input of a Double (floating-point number) value. It uses the DoublePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Allowing NaN or Infinity Values
  • Built-in Picker Kinds
  • Sample XAML
  • Sample XAML for Currency Input

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C (currency)
  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G
  • N
  • Nx, where x is the number of decimal places (e.g. N1)
  • P (percentage)

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the DoubleEditBox.PickerKind property, which is of type DoubleEditBoxPickerKind.

The default value in UWP is Default.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DoubleEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Sample XAML for Currency Input

This control is great for currency input, which can be implemented with this XAML:

XAML
Copy
​<editors:DoubleEditBox Format="C" Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EnumEditBox

Edit Boxes
EnumEditBox

The EnumEditBox control allows for the input of an Enum (flags and non-flags enumeration) value. It uses the EnumPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Enumeration Value and Type
  • Using Display Attributes
  • Custom Sorting
  • Hiding Enumeration Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes. Non-editable by default.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Simple wrap.

Enumeration Value and Type

The Value property provides a quick and easy way to setup to the list box. The EnumType property is used to to build the items presented by the EnumEditBox. The items are constructed by reflecting the enumeration type, with full support for the FlagsAttribute.

When the Value property is bound/set to a non-null enumeration value, then the enumeration type will be automatically set (if it has not been explicitly set). Therefore, the EnumType only needs to be set when Value is bound to a nullable enumeration type.

Using Display Attributes

Sometimes it is helpful to display an alternate text version of an enumeration value, especially when the values are made of multiple concatenated words. For instance, an enumeration value named "FooBar" might appear nicer as "Foo Bar".

This scenario is fully supported by EnumEditBox. A System.ComponentModel.DataAnnotations.DisplayAttribute can be applied to a value to give it an alternate textual description. Then as long as the UseDisplayAttributes property is set to true, that alternate text will be used.

If the DisplayAttribute.ResourceType property is left blank, it will use the direct value specified by the Name property. Otherwise, it will look in the specified resource Type for a localized resource value within the property indicated by Name.

In this example, the DisplayAttribute will look for a property named MyFirstValue in the string resources type MyResources and use that property's value:

C#
VB
Copy
​public enum SampleEnum {

    [Display(ResourceType = typeof(MyResources), Name = "MyFirstValue")]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <Display(ResourceType := GetType(MyResources), Name := "MyFirstValue")>
    MyFirstValue = 1

    ...
End Enum

Custom Sorting

By default, values are listed in the order they are defined. The exception is that in flags enums, group values get placed together.

Sorting can be altered by implementing a custom IComparer<Enum> class and assigning it to the EnumSortComparer property. The EnumValueNameSortComparer.Instance static property provides access to a pre-built comparer for listing enumeration values alphabetically by name.

Hiding Enumeration Values

By default, all values are listed in the control's popup and when cycling through values using arrow keys. If you wish to hide a specific value from the end user, use EditorBrowsableAttribute on the value with EditorBrowsableState.Never.

In this example, the EditorBrowsableAttribute hides the MyFirstValue value from the user interface:

C#
VB
Copy
​public enum SampleEnum {

    [EditorBrowsable(EditorBrowsableState.Never)]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <EditorBrowsable(EditorBrowsableState.Never)>
    MyFirstValue = 1

    ...
End Enum

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented as long as a single value is specified. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:EnumEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


GuidEditBox

Edit Boxes
GuidEditBox

The GuidEditBox control allows for the input of a Guid (unique ID) value.

This topic contains these sections:

  • Common Capabilities
  • Generating a New GUID
  • Formats
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | No.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Generating a New GUID

The plus button in the edit box can be used to generate a new GUID value.

Formats

Standard GUID formats are supported via the Format property and affect the textual value display. These formats are allowed:

  • N - 32 digits (uppercase)
  • n - 32 digits (lowercase)
  • D - 32 digits separated by hyphens (uppercase)
  • d - 32 digits separated by hyphens (lowercase)
  • B - 32 digits separated by hyphens, enclosed in braces (uppercase)
  • b - 32 digits separated by hyphens, enclosed in braces (lowercase)
  • P - 32 digits separated by hyphens, enclosed in parentheses (uppercase)
  • p - 32 digits separated by hyphens, enclosed in parentheses (lowercase)

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:GuidEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int16EditBox

Edit Boxes
Int16EditBox

The Int16EditBox control allows for the input of an Int16 (16-bit integer) value. It uses the Int16Picker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the Int16EditBox.PickerKind property, which is of type Int16EditBoxPickerKind.

The default value in UWP is Default.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int16EditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int32EditBox

Edit Boxes
Int32EditBox

The Int32EditBox control allows for the input of an Int32 (32-bit integer) value. It uses the Int32Picker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the Int32EditBox.PickerKind property, which is of type Int32EditBoxPickerKind.

The default value in UWP is Default.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int32EditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int64EditBox

Edit Boxes
Int64EditBox

The Int64EditBox control allows for the input of an Int64 (64-bit integer) value. It uses the Int64Picker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Built-in Picker Kinds
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C0 (currency without decimals)
  • D
  • Dx, where x is the number of zero-padded digits (e.g. D3)
  • G
  • N0
  • X (uppercase hexadecimal)
  • x (lowercase hexadecimal)

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the Int64EditBox.PickerKind property, which is of type Int64EditBoxPickerKind.

The default value in UWP is Default.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int64EditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PointEditBox

Edit Boxes
PointEditBox

The PointEditBox control allows for the input of a Point (X, Y) value. It uses the PointPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • X
  • Y

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:PointEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RectEditBox

Edit Boxes
RectEditBox

The RectEditBox control allows for the input of a Rect (X, Y, width, height) value. It uses the RectPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • X
  • Y
  • Width
  • Height

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:RectEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SingleEditBox

Edit Boxes
SingleEditBox

The SingleEditBox control allows for the input of a Single (floating-point number) value. It uses the SinglePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Allowing NaN or Infinity Values
  • Sample XAML
  • Built-in Picker Kinds
  • Sample XAML for Currency Input

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | No.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • C (currency)
  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G
  • N
  • Nx, where x is the number of decimal places (e.g. N1)
  • P (percentage)

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has a single part.

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Allowing NaN or Infinity Values

Text entry of NaN (not-a-number) and infinity values into the edit box is not allowed by default.

Set the IsNaNAllowed property to true to allow a NaN value to be entered by typing the letter 'n'.

Set the IsNegativeInfinityAllowed property to true to allow a negative infinity value to be entered by typing a negative sign and then the letter 'i'.

Set the IsPositiveInfinityAllowed property to true to allow a positive infinity value to be entered by typing the letter 'i'.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SingleEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Built-in Picker Kinds

This edit box has multiple built-in picker kinds that can be set via the SingleEditBox.PickerKind property, which is of type SingleEditBoxPickerKind.

The default value in UWP is Default.

The Default picker kind renders using a radial slider, while the Calculator picker kind utilizes the Calculator control.

Sample XAML for Currency Input

This control is great for currency input, which can be implemented with this XAML:

XAML
Copy
​<editors:SingleEditBox Format="C" Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SizeEditBox

Edit Boxes
SizeEditBox

The SizeEditBox control allows for the input of a Size (width, height) value. It uses the SizePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Width
  • Height

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SizeEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ThicknessEditBox

Edit Boxes
ThicknessEditBox

The ThicknessEditBox control allows for the input of a Thickness (left, top, right, bottom) value. It uses the ThicknessPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Number Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | No wrap.

Number Formats

Standard numeric formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • F
  • Fx, where x is the number of decimal places (e.g. F1)
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Left
  • Top
  • Right
  • Bottom

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by 5, which is the default for the LargeChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ThicknessEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimeEditBox

Edit Boxes
TimeEditBox

The TimeEditBox control allows for the input of a DateTime value's time component. It uses the TimePicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Formats

Standard time formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • t
  • T
  • hh:mm tt
  • h:mm:ss tt
  • HH:mm:ss
  • HH:mm

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Hour
  • Minute
  • Second
  • AM/PM

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimeEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimeSpanEditBox

Edit Boxes
TimeSpanEditBox

The TimeSpanEditBox control allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value. It uses the TimeSpanPicker control in its popup.

This topic contains these sections:

  • Common Capabilities
  • Formats
  • Minimum and Maximum Values
  • Parts and Incrementing/Decrementing
  • Sample XAML

Common Capabilities

Each of the features listed in the table below describe functionality that is common to most edit boxes. Please see the Edit Box Basics topic for details on each of these options and how to set them.

Feature | Description
Has a clear button | Yes, and can be hidden.
Has a popup | Yes, and can be hidden or its picker appearance customized.
Null value allowed | Yes, and can be prevented.
Read-only mode supported | Yes.
Non-editable mode supported | Yes.
Has multiple parts | Yes, and supports optional arrow key navigation.
Placeholder text supported | Yes, and overlays the control.
Header content supported | Yes, and appears above the control.
Default spin behavior | Wrap.

Formats

Standard time formats are supported via the Format property and affect the textual value display. These formats are recommended:

  • c
  • g
  • G

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Parts and Incrementing/Decrementing

This edit box has multiple parts:

  • Days
  • Hours
  • Minutes
  • Seconds
  • Milliseconds

When the caret is over a part, the part value may be incremented or decremented. Please see the Edit Box Basics topic for information on how to do this.

Small value changes alter the current number component by 1, which is the default for the SmallChange property. Large value changes alter the current number component by other amounts, based on the LargeChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimeSpanEditBox Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Pickers
Overview

Actipro Editors includes a number of pickers that are generally intended to be used within popups. In many cases, the pickers are designed to work with a related edit box of a similar name.

This topic contains these sections:

  • Picker Controls

Picker Controls

This table shows the picker controls that are included in the product:

Name | Description
BrushPicker | Allows for the input of a Brush value.
ColorPicker | Allows for the input of a Color value.
CornerRadiusPicker | Allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value.
DatePicker | Allows for the input of a DateTime value's date component.
DateTimePicker | Allows for the input of a DateTime value.
DoublePicker | Allows for the input of a Double (floating-point number) value.
EnumPicker | Allows for the input of an Enum (flags and non-flags enumeration) value.
HsbColorPicker | Allows for the input of a Color value.
Int16Picker | Allows for the input of an Int16 (16-bit integer) value.
Int32Picker | Allows for the input of an Int32 (32-bit integer) value.
Int64Picker | Allows for the input of an Int64 (64-bit integer) value.
PointPicker | Allows for the input of a Point (X, Y) value.
RadialHuePicker | Allows for the input of a color's hue component.
RectPicker | Allows for the input of a Rect (X, Y, width, height) value.
SaturationBrightnessPicker | Allows for the input of a color's saturation and brightness components.
SinglePicker | Allows for the input of a Single (floating-point number) value.
SizePicker | Allows for the input of a Size (width, height) value.
ThicknessPicker | Allows for the input of a Thickness (left, top, right, bottom) value.
TimePicker | Allows for the input of a DateTime value's time component.
TimeSpanPicker | Allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


BrushPicker

Pickers
BrushPicker

The BrushPicker control makes it easy for end users to select a Brush via touch or a mouse. It is generally intended for display within a popup, such as for the BrushEditBox control.

It combines a horizontal list for picking the brush kind, along with ColorPicker and GradientStopSlider controls for modifying the brush value.

Alpha transparency and gradients are also optionally supported.

This topic contains these sections:

  • Alpha Transparency
  • Gradient Support
  • Null Support
  • Sample XAML

Alpha Transparency

The BrushPicker.IsAlphaEnabled property governs whether alpha transparency is supported.

When false, the edit box will only allow selection of RGB colors instead of ARGB colors.

Gradient Support

The BrushPicker.IsGradientAllowed property can be set to false to prevent gradient brushes from being supported.

When false, the picker will hide all brush kind options related to gradients.

Null Support

The BrushPicker.IsNullAllowed property can be set to false to always require that a valid Brush value is present, and that null is not supported.

When false, the picker will hide the null brush kind option.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:BrushPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ColorPicker

Pickers
ColorPicker

The ColorPicker control makes it easy for end users to select a color via touch or a mouse. It is generally intended for display within a popup, such as for the ColorEditBox control.

It combines a HsbColorPicker with edit boxes for ARGB (alpha, red, green blue) values. This allows the end user to select the color either via HSB (hue, saturation, brightness) or RGB values.

Alpha transparency selection is also optionally supported.

This topic contains these sections:

  • Alpha Transparency
  • Embedded ColorEditBox
  • Sample XAML

Alpha Transparency

The ColorPicker.IsAlphaEnabled property governs whether alpha transparency is supported.

When false, the edit box will only allow selection of an RGB color instead of an ARGB color.

Embedded ColorEditBox

The ColorPicker.HasColorEditBox property, which defaults to true, defines whether a ColorEditBox is embedded within the picker.

The edit box is used to display and allow editing of the hex color value.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ColorPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CornerRadiusPicker

Pickers
CornerRadiusPicker

The CornerRadiusPicker control allows for the input of a CornerRadius (top-left, top-right, bottom-right, bottom-left) value. It is generally intended for display within a popup, such as for the CornerRadiusEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the TopLeft, TopRight, BottomRight or BottomLeft component of the CornerRadius. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:CornerRadiusPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DatePicker

Pickers
DatePicker

The DatePicker control allows for the input of a DateTime value's date component. It uses a month calendar with animated view changes and its design is similar to the layout of a standard calendar, making it instantly approachable by end users.

Use the previous/next buttons in the calendar's header to navigate to a nearby month, or tap the current view's title to 'zoom out' to year, decade, or century views.

The DatePicker directly embeds a MonthCalendar control to provide the functionality mentioned above. See the MonthCalendar topic for more information on that control's capabilities.

This topic contains these sections:

  • Time Retention
  • Minimum and Maximum Values
  • Sample XAML

Time Retention

When using separate DatePicker and TimePicker controls that bind to the same DateTime object, it's sometimes helpful to have the DatePicker retain the time portion as selections are made, instead of reverting the time to midnight. The CanRetainTime property can be set to true to enable time retention.

Note that a DateTimePicker can be used in place of separate DatePicker and TimePicker controls if dates and times require input.

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DatePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DateTimePicker

Pickers
DateTimePicker

The DateTimePicker control allows for the input of a DateTime value using a month calendar with animated view changes for date selection, and two radial sliders for time selection. Its design is similar to the layout of a standard calendar and clock, making it instantly approachable by end users.

Use the previous/next buttons in the calendar's header to navigate to a nearby month, or tap the current view's title to 'zoom out' to year, decade, or century views.

The time portion's inner radial slider sets the hours value. It can be rotated up to two full cycles, where each cycle represents a 12 hour period. The outer radial slider sets the minutes value, and can be rotated freely.

The toggle at the top determines whether the DateTimePicker is currently modifying the date or time component of the DateTime. The date component is edited with a DatePicker and the time component is edited with a TimePicker.

This topic contains these sections:

  • Minimum and Maximum Values
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DateTimePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


DoublePicker

Pickers
DoublePicker

The DoublePicker control allows for the input of a Double (floating-point number) value. It is generally intended for display within a popup, such as for the DoubleEditBox control, and is also used within many other pickers.

The control allows for selection of a Double value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:DoublePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EnumPicker

Pickers
EnumPicker

The EnumPicker control allows for the input of an Enum value using a standard list presentation. It supports both flags and non-flags enumerations, altering the user interface as appropriate.

The EnumPicker directly embeds an EnumListBox control to provide the functionality mentioned above.

This topic contains these sections:

  • Enumeration Value and Type
  • Using Display Attributes
  • Custom Sorting
  • Hiding Enumeration Values
  • Sample XAML

Enumeration Value and Type

The Value property provides a quick and easy way to setup to the list box. The EnumType property is used to to build the items presented by the EnumPicker. The items are constructed by reflecting the enumeration type, with full support for the FlagsAttribute.

When the Value property is bound/set to a non-null enumeration value, then the enumeration type will be automatically set (if it has not been explicitly set). Therefore, the EnumType only needs to be set when Value is bound to a nullable enumeration type.

Using Display Attributes

Sometimes it is helpful to display an alternate text version of an enumeration value, especially when the values are made of multiple concatenated words. For instance, an enumeration value named "FooBar" might appear nicer as "Foo Bar".

This scenario is fully supported by EnumPicker. A System.ComponentModel.DataAnnotations.DisplayAttribute can be applied to a value to give it an alternate textual description. Then as long as the UseDisplayAttributes property is set to true, that alternate text will be used.

If the DisplayAttribute.ResourceType property is left blank, it will use the direct value specified by the Name property. Otherwise, it will look in the specified resource Type for a localized resource value within the property indicated by Name.

In this example, the DisplayAttribute will look for a property named MyFirstValue in the string resources type MyResources and use that property's value:

C#
VB
Copy
​public enum SampleEnum {

    [Display(ResourceType = typeof(MyResources), Name = "MyFirstValue")]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <Display(ResourceType := GetType(MyResources), Name := "MyFirstValue")>
    MyFirstValue = 1

    ...
End Enum

Custom Sorting

By default, values are listed in the order they are defined. The exception is that in flags enums, group values get placed together.

Sorting can be altered by implementing a custom IComparer<Enum> class and assigning it to the EnumSortComparer property. The EnumValueNameSortComparer.Instance static property provides access to a pre-built comparer for listing enumeration values alphabetically by name.

Hiding Enumeration Values

By default, all values are listed in the control. If you wish to hide a specific value from the end user, use EditorBrowsableAttribute on the value with EditorBrowsableState.Never.

In this example, the EditorBrowsableAttribute hides the MyFirstValue value from the user interface:

C#
VB
Copy
​public enum SampleEnum {

    [EditorBrowsable(EditorBrowsableState.Never)]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <EditorBrowsable(EditorBrowsableState.Never)>
    MyFirstValue = 1

    ...
End Enum

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:EnumPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


HsbColorPicker

Pickers
HsbColorPicker

The HsbColorPicker control combines several primitives (RadialHuePicker and SaturationBrightnessPicker) together to create a control that allows for easy selection of a HSB (hue, saturation, brightness) color.

The outer ring of the control is a radial slider for selecting the hue. The inner square allows for selection of the saturation (x-axis) and brightness (y-axis).

This topic contains these sections:

  • Sample XAML

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:HsbColorPicker Color="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int16Picker

Pickers
Int16Picker

The Int16EditBox control allows for the input of an Int16 (16-bit integer) value. It is generally intended for display within a popup, such as for the Int16EditBox control.

The control allows for selection of an Int16 value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int16Picker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int32Picker

Pickers
Int32Picker

The Int32EditBox control allows for the input of an Int32 (32-bit integer) value. It is generally intended for display within a popup, such as for the Int32EditBox control.

The control allows for selection of an Int32 value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int32Picker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Int64Picker

Pickers
Int64Picker

The Int64EditBox control allows for the input of an Int64 (64-bit integer) value. It is generally intended for display within a popup, such as for the Int64EditBox control.

The control allows for selection of an Int64 value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:Int64Picker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PointPicker

Pickers
PointPicker

The PointPicker control allows for the input of a Point (X, Y) value. It is generally intended for display within a popup, such as for the PointEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the X or Y component of the Point. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:PointPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RadialHuePicker

Pickers
RadialHuePicker

The RadialHuePicker control renders a circular gradient of the color spectrum and uses a radial slider to select a color hue.

This topic contains these sections:

  • Sample XAML

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:RadialHuePicker Hue="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RectPicker

Pickers
RectPicker

The RectPicker control allows for the input of a Rect (X, Y, width, height) value. It is generally intended for display within a popup, such as for the RectEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the X, Y, Width or Height component of the Rect. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:RectPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SaturationBrightnessPicker

Pickers
SaturationBrightnessPicker

The SaturationBrightnessPicker control allows for the input of color saturation and brightness values.

The control displays a two-dimensional gradient of color values for a given hue, where the vertical gradient represents brightness and the horizontal gradient represents saturation.

A gripper can be dragged to change the selected color.

This topic contains these sections:

  • Setting the Hue
  • Sample XAML

Setting the Hue

This picker shows the saturation and brightness cross-section for a particular hue. Therefore it is important to set the Hue property appropriately. 0 is red, 120 is green, and 240 is blue. The hue may be set to any value between 0 and 360.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SaturationBrightnessPicker Hue="120" Saturation="{Binding Path=YourSVMProperty, Mode=TwoWay}"
    Brightness="{Binding Path=YourBVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SinglePicker

Pickers
SinglePicker

The SinglePicker control allows for the input of a Single (floating-point number) value. It is generally intended for display within a popup, such as for the SingleEditBox control, and is also used within many other pickers.

The control allows for selection of a Single value via the use of a radial slider and increment/decrement button combination. The radial slider facilitates large changes to the value, while the increment/decrement buttons enable fine tuning.

The picker adjusts its radial slider functionality according to the range of specified minimum and maximum values. Large ranges permit multiple slider rotation cycles and show an overall progress indicator towards the largest value. Smaller ranges only allow for a single rotation cycle.

Negative values have a distinct appearance from positive values.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SinglePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


SizePicker

Pickers
SizePicker

The SizePicker control allows for the input of a Size (width, height) value. It is generally intended for display within a popup, such as for the SizeEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the Width or Height component of the Size. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:SizePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ThicknessPicker

Pickers
ThicknessPicker

The ThicknessPicker control allows for the input of a Thickness (left, top, right, bottom) value. It is generally intended for display within a popup, such as for the ThicknessEditBox control.

The toggle at the top determines whether the embedded DoublePicker is currently modifying the Left, Top, Right or Bottom component of the Thickness. See the DoublePicker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:ThicknessPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimePicker

Pickers
TimePicker

The TimePicker control allows for the input of a DateTime value's time component. Its design uses two radial sliders and is similar to the layout of a standard analog clock, making it instantly approachable by end users.

The inner radial slider sets the hours value. It can be rotated up to two full cycles, where each cycle represents a 12 hour period. The second cycle (for PM times) applies a subtle highlight effect on the track. The outer radial slider sets the minutes value, and can be rotated freely.

This topic contains these sections:

  • Minimum and Maximum Values
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimePicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TimeSpanPicker

Pickers
TimeSpanPicker

The TimeSpanPicker control allows for the input of a TimeSpan (days, hours, minutes, seconds, milliseconds) value. It is generally intended for display within a popup, such as for the TimeSpanEditBox control.

The toggle at the top determines whether the embedded Int32Picker is currently modifying the Days, Hours, Minutes, Seconds or Milliseconds component of the TimeSpan. See the Int32Picker for a description of how its UI functions.

This topic contains these sections:

  • Minimum and Maximum Values
  • Incrementing/Decrementing
  • Sample XAML

Minimum and Maximum Values

Minimum and maximum values may be assigned via the Maximum and Minimum properties.

No values can be committed that lay outside of the inclusive range created by those properties.

Incrementing/Decrementing

Value changes alter the current number component by 1, which is the default for the SmallChange property.

Sample XAML

This control can be placed within any other XAML container control, such as a Page or Panel with this sort of XAML:

XAML
Copy
​<editors:TimeSpanPicker Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Other Controls
Overview

Actipro Editors includes a number of additional helpful controls beyond edit boxes and pickers.

This topic contains these sections:

  • Additional Controls

Additional Controls

This table shows the additional controls that are included in the product:

Name | Description
Calculator | Provides a familiar calculator interface to interactively calculate numeric values.
CountryComboBox | Allows for the selection of an ISO country.
CurrencyComboBox | Allows for the selection of an ISO currency.
EnumListBox | Presents the values of an enumeration in a list box. The control supports both flags and non-flags enums.
GradientStopSlider | Allows for adding, changing, and removing the various gradient stops within a GradientBrush, such as a LinearGradientBrush.
MaskedTextBox | Used to restrict user input based on a specified regular expression mask. Support for input prompts and literal completion is included.
MonthCalendar | Allows for selection of a date from a calendar with animated view changes.
Rating | Renders glyphs that can be used present an average rating or collect a user rating.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Calculator

Other Controls
Calculator

The Calculator control provides a familiar calculator interface to interactively calculate numeric values.

This topic contains these sections:

  • Overview
  • Customization

Overview

The calculator can be operated by tapping its various buttons or by focusing it and typing on the keyboard.

The Calculator.Value property gets or sets the current numeric calculator value, and supports data binding. It is a Double value.

The DisplayText property gets the current text that is rendered in the display area of the calculator.

Customization

Calculator offers several properties that can be used to customize the look of the control.

General

There properties can be used to customize the overall look of the Calculator, as described below.

Property | Description
DisplayFontSize | The display font size.
HasDisplay | Whether the calculator output is displayed.
HasMemoryButtons | Whether the memory buttons are displayed.

Styles

The various buttons presented by the Calculator can be customized using a Style.

Property | Description
DigitButtonStyle | Specifies the Style to use for digit buttons.
MemoryButtonStyle | Specifies the Style to use for memory buttons.
OperationButtonStyle | Specifies the Style to use for operation buttons.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CountryComboBox

Other Controls
CountryComboBox

The CountryComboBox can be used to select a Country from a list of countries in the world. The country code can then be used with LINQ and CountryCurrencyMapping to query the Currency that is used in that Country.

This topic contains these sections:

  • Overview
  • List of Countries
  • Selection
  • Country/Currency Mapping

Overview

The CountryComboBox extends the native ComboBox and displays a list of countries as defined by the ISO. A country is represented by an instance of Country, and the list of countries is defined by the Country.Countries collection

List of Countries

The list of countries can be customized by updating the Country.Countries collection. Items can be added or removed as needed directly from this list. In addition, a custom list can be assigned to the ItemsSource property.

This example code shows how the default full list of countries can be filtered down to several European countries via LINQ:

C#
VB
Copy
​var countries = new string[] { "PT", "ES", "GB", "FR", "DE" };
countryComboBox.ItemSource = from c in Country.Countries where countries.Contains(c.Code) select c;
​Dim countries = New String() {"PT", "ES", "GB", "FR", "DE"}
countryComboBox.ItemSource = From c In Country.Countries
    Where countries.Contains(c.Code)
    Select c

Selection

The selected Country is accessible through the SelectedItem property. In addition, the unique ISO code associated with the country can be accessed through the SelectedValue property.

Country/Currency Mapping

The CountryCurrencyMapping class contains Mappings between Country.Countries and Currency.Currencies. This is useful for seeing which countries use which currencies, and which currencies are used by which countries.

It is possible to use LINQ with CountryCurrencyMapping.Mappings, Country.Countries and Currency.Currencies. This shows the currencies for the United States.

C#
VB
Copy
​var results =
    from mapping in CountryCurrencyMapping.Mappings
    join currency in Currency.Currencies on mapping.CurrencyCode equals currency.Code
    where mapping.CountryCode == "US"
    select currency;
​Dim results =
    From mapping In CountryCurrencyMapping.Mappings
    Join currency In Currency.Currencies On mapping.CurrencyCode Equals currency.Code
    Where mapping.CountryCode = "US"
    Select currency

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


CurrencyComboBox

Other Controls
CurrencyComboBox

The CurrencyComboBox can be used to select a Currency from a list of currencies in the world. The currency code can then be used with LINQ and CountryCurrencyMapping to query the Country or countries that use that Currency.

This topic contains these sections:

  • Overview
  • List of Currencies
  • Selection
  • Country/Currency Mapping

Overview

The CurrencyComboBox extends the native ComboBox and displays a list of currencies as defined by the ISO. A currency is represented by an instance of Currency, and the list of currencies is defined by the Currency.Currencies collection.

List of Currencies

The list of currencies can be customized by updating the Currency.Currencies collection. Items can be added or removed as needed directly from this list. In addition, a custom list can be assigned to the ItemsSource property.

Selection

The selected Currency is accessible through the SelectedItem property. In addition, the unique ISO code associated with the currency can be accessed through the SelectedValue property.

Country/Currency Mapping

See the CountryComboBox topic for more information on the CountryCurrencyMapping class.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EnumListBox

Other Controls
EnumListBox

The EnumListBox control automatically presents the values of an enumeration with a more intuitive interface.

This topic contains these sections:

  • Enumeration Value and Type
  • Using Display Attributes
  • Custom Sorting
  • Hiding Enumeration Values

Enumeration Value and Type

The EnumValue property provides a quick and easy way to setup to the list box. The EnumType property is used to to build the items presented by the EnumListBox. The items are constructed by reflecting the enumeration type, with full support for the FlagsAttribute.

When the EnumValue property is bound/set to a non-null enumeration value, then the enumeration type will be automatically set (if it has not been explicitly set). Therefore, the EnumType only needs to be set when EnumValue is bound to a nullable enumeration type.

By default, the items are presented in a standard single selection list box style. When the enumeration type is marked with the FlagsAttribute, then the items are presented using a CheckBox control and the list box allows multiple selection. In addition, flag enumerations are separate into three sections. The first section contains values that are equal to zero. The second section contains union values, or values that have more than one bit set. The third section contains the remaing values, which have one and only one bit set.

EnumListBox bound to a flags enum

Using Display Attributes

Sometimes it is helpful to display an alternate text version of an enumeration value, especially when the values are made of multiple concatenated words. For instance, an enumeration value named "FooBar" might appear nicer as "Foo Bar".

This scenario is fully supported by EnumListBox. A System.ComponentModel.DataAnnotations.DisplayAttribute can be applied to a value to give it an alternate textual description. Then as long as the UseDisplayAttributes property is set to true, that alternate text will be used.

If the DisplayAttribute.ResourceType property is left blank, it will use the direct value specified by the Name property. Otherwise, it will look in the specified resource Type for a localized resource value within the property indicated by Name.

In this example, the DisplayAttribute will look for a property named MyFirstValue in the string resources type MyResources and use that property's value:

C#
VB
Copy
​public enum SampleEnum {

    [Display(ResourceType = typeof(MyResources), Name = "MyFirstValue")]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <Display(ResourceType := GetType(MyResources), Name := "MyFirstValue")>
    MyFirstValue = 1

    ...
End Enum

Custom Sorting

By default, values are listed in the order they are defined. The exception is that in flags enums, group values get placed together.

Sorting can be altered by implementing a custom IComparer<Enum> class and assigning it to the EnumSortComparer property. The EnumValueNameSortComparer.Instance static property provides access to a pre-built comparer for listing enumeration values alphabetically by name.

Hiding Enumeration Values

By default, all values are listed in the control. If you wish to hide a specific value from the end user, use EditorBrowsableAttribute on the value with EditorBrowsableState.Never.

In this example, the EditorBrowsableAttribute hides the MyFirstValue value from the user interface:

C#
VB
Copy
​public enum SampleEnum {

    [EditorBrowsable(EditorBrowsableState.Never)]
    MyFirstValue = 1

    ...
}
​Public Enum SampleEnum

    <EditorBrowsable(EditorBrowsableState.Never)>
    MyFirstValue = 1

    ...
End Enum

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


GradientStopSlider

Other Controls
GradientStopSlider

The GradientStopSlider control allows for adding, changing, and removing the various gradient stops within a GradientBrush, such as a LinearGradientBrush.

This topic contains these sections:

  • Usage
  • Stop Add/Remove Capabilities
  • Track Height
  • Commands for External Buttons

Usage

The slider will display a thumb for each GradientStop in the gradient brush. Each stop consists of an offset and Color pair.

Thumbs can be dragged to adjust their offsets and the color for the selected thumb can be changed. When dragging a thumb far above or below the slider, it will turn semi-transparent meaning that it will be removed if it is released at that location. Double click an empty area of the slider track to insert a new thumb.

The GradientStopSlider.ActiveBrush is the property that you apply a two-way binding to whichever Brush-based property that you wish to adjust using the slider.

You also need to add a two-way binding to the SelectedColor property that binds to an external control for altering the color of the selected stop. Any one of the coloring picking controls in this product can be used for this purpose.

Stop Add/Remove Capabilities

The CanAddStops and CanRemoveStops properties can be used to restrict whether stops can be added to or removed from the gradient brush. They are both true by default.

Track Height

The TrackHeight property sets the height of the track, which is the area in which the actual gradient brush is rendered.

Commands for External Buttons

There are several properties that return ICommand and can be utilized by external buttons or menu items:

  • AddStopCommand
  • RemoveSelectedStopCommand
  • ReverseStopsCommand

Simply bind the Command property of an external button or menu item to the appropriate slider property to have them interact with the control.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


MaskedTextBox

Other Controls
MaskedTextBox

The MaskedTextBox control can be used to restrict user input based on a specified regular expression mask. Support for input prompts and literal completion is included.

Since the MaskedTextBox control inherits the native TextBox control, it fully supports features such as UI automation, IME input, etc.

When typing text data, the control will attempt to move the caret past any literal (fixed) characters it encounters in the mask.

The "12" were typed by the user and the remaining text with bullets/dashes is a prompt

This topic contains these sections:

  • Mask and Text
  • Prompts
  • Case Sensitivity and Case-Correction
  • Regular Expression Mask Syntax
  • Wildcard Mask Syntax

Mask and Text

The Mask property can be used to define the desired mask pattern that must be input. It defaults to using a regular expression pattern. Any characters or input that violate this mask will be discarded. This ensures that only data in the proper format is entered.

The MaskKind property indicates whether the Mask is a regular expression (the default) or wildcard pattern. See the reference below for more details on each mask kind, as they have different pattern syntax.

The Text property can be used to retrieve any text entered by the end user, along with any prompt text that is currently displayed.

Prompts

Prompts can be appended to the end of the text in scenarios where further text input is required to properly match a mask. The prompts do their best to indicate literal characters as themselves. Any time there is a choice in character, a prompt character specified by the PromptChar is inserted.

By default the prompts will only be appended when the control has focus. The PromptVisibility property can be changed to Always to always show prompts, even when the control doesn't has focus. The Never option prevents prompts from ever showing.

Case Sensitivity and Case-Correction

The control attempts to match the mask in a case-insensitive way by default, meaning that both 'A' and 'a' will match an "a" pattern. If you wish to force your mask to be case sensitive, set the IsCaseSensitive property to true.

If you wish to allow case-insensitivity and also coerce characters to match the pattern, set the IsCaseAutoCorrected property to true. When this property is set, the IsCaseSensitive property is ignored. Say the mask pattern is "(Male|Female)". This means only one of the two strings can be typed. If the user types a 'm' into the control, it will convert the typed character to 'M'. The control also will automatically insert the rest of the text, making it read "Male" since the "ale" characters are considered literals at those character offsets. Note that this last feature occurs regardless of case options.

Regular Expression Mask Syntax

The MaskedTextBox uses a custom regular expression engine implementation with full support for Unicode categories. The engine includes support for most common regular expression constructs, as described below, when the MaskKind property is Regex.

Literals

Literal characters can be included in the regular expression, but special characters must be escaped using the backslash character (\).

Whitespace such as spaces are treated as a literal.

Groups

Any number of regular expression elements can grouped together by enclosing them in parenthesis. Alternations, which are described below, are a special type of group which are also enclosed in parenthesis. Groups can be repeated using one of the support quantifiers after the closing paraenthesis.

For example, the regular expression "ABC*" requires A and B, then allows for zero or more of C. The regular expression "(ABC)*", which groups "ABC" into a single element, allows for zero or more of "ABC" together.

In terms of literal completion, only the A character would ever be entered by the end-user for the "(ABC)*" regular expresssion. When the user types an A, then the BC are required and are therefore automatically inserted by the control. If an additional A is typed, then again the BC would be auto completed, resulting in "ABCABC" as the text.

Alternations

Alternation allows for two or more alternate branches to be taken and is defined by using the vertical bar in parenthesis. For example, the "(AB|CD)" regular expression can match the string "AB" or the string "CD". The alternate branches can be any other supported regular expression element, including other groups or alternations. This allows for very complex scenarioes to be defined and used as a mask.

When showing prompt indicators for uncompleted sections of the maks, the control will choose the shortest branch of an alternation that would result in completion of the mask.

Quantifiers

Quantifiers can be used to specify the number of times a regular expression element should be repeated. There are several methods for defining quantifiers, which are:

Quantifier | Description
? | Indicates that the regular expression element is optional. For example, the regular expression "AB?C" will match the string "ABC" or "AC".
* | Indicates that the regular expression element is can be repeated zero or more times, with no upper limit. For example, the regular expression "AB*C" will match the string "ABC" or "AC", as well as "ABBBBBBBC".
+ | Indicates that the regular expression element must occur once, but can be repeat any number of times. For example, the regular expression "AB+C" will match the string "ABC" or "ABBBBBBBC", but will not match "AC".
{N} | Indicates that the regular expression element must occur exactly N times, where N is a postive integer value. For example, the regular expression "AB{2}C" will only match the string "ABBC".
{N,} | Indicates that the regular expression element must occur exactly N times, where N is a postive integer value, but can be repeated any number of times. For example, the regular expression "AB{2,}C" will match the string "ABBC" or "ABBBBBBC".
{N,M} | Indicates that the regular expression element must occur exactly N times, where N is a postive integer value, but can be repeated M times, where M is a positive integer value greater than N. For example, the regular expression "AB{2,3}C" will match the string "ABBC" or "ABBBC", but not "ABBBBC".

Character Classes

Character classes can be used to define one or more characters, using ranges or by explicitly defining individual characters.

Custom character classes are enclosed in square brackets. Ranges can be defined using a start character, followed by a dash (-), followed by an end character. For example, the character class "[0-9]", includes all digits. Additional ranges can be appended to specify non-contiguous ranges. For example, the character class "[0-357-9]", includes all digits except 4 and 6. The caret (^) can be used to negate the character class. For example, the character class "[^0-9]" includes all characters except the digits.

The following table summarizes character matching syntax for custom and built-in character classes.

Character Class | Description
. | Matches any character except \n. When within a character class, the . will be treated as a period character.
[aeiou] | Matches any single character included in the specified set of characters.
[^aeiou] | Matches any single character not in the specified set of characters.
[0-9a-fA-F] | Use of a hyphen (–) allows specification of contiguous character ranges.
\p{name} | Matches any character in the Unicode general category specified by name (for example, Ll, Nd, Z).
\P{name} | Matches any character not in Unicode general category specified in name.
\w | Matches any word character, which includes letters, digits, and underscores.
\W | Matches any non-word character.
\s | Matches any whitespace character.
\S | Matches any non-whitespace character.
\d | Matches any decimal digit.
\D | Matches any non-digit.
[.\w\s] | Escaped built-in character classes such as \w and \s may be used in a character class. This example matches any period, word or whitespace character.

Supported Unicode General Categories

Unicode defines the general categories and descriptions listed in the following table. These categories can be used with the \p and \P character classes described above.

Category | Description
Lu | Letter, Uppercase
Ll | Letter, Lowercase
Lt | Letter, Titlecase
Lm | Letter, Modifier
Lo | Letter, Other
Mn | Mark, Nonspacing
Mc | Mark, Spacing Combining
Me | Mark, Enclosing
Nd | Number, Decimal Digit
Nl | Number, Letter
No | Number, Other
Pc | Punctuation, Connector
Pd | Punctuation, Dash
Ps | Punctuation, Open
Pe | Punctuation, Close
Pi | Punctuation, Initial quote
Pf | Punctuation, Final quote
Po | Punctuation, Other
Sm | Symbol, Math
Sc | Symbol, Currency
Sk | Symbol, Modifier
So | Symbol, Other
Zs | Separator, Space
Zl | Separator, Line
Zp | Separator, Paragraph
Cc | Other, Control
Cf | Other, Format
Cs | Other, Surrogate
Co | Other, Private Use
Cn | Other, Not Assigned

Additional special categories are supported that represent a set of Unicode character categories, as shown in the following table:

Category | Description
C | (All control characters) Cc, Cf, Cs, Co, and Cn.
L | (All letters) Lu, Ll, Lt, Lm, and Lo.
M | (All diacritic marks) Mm, Mc, and Me.
N | (All numbers) Nd, Nl, and No.
P | (All punctuation) Pc, Pd, Ps, Pe, Pi, Pf and Po.
S | (All symbols) Sm, Sc, Sk, and So.
Z | (All separators) Zs, Zl, and Zp.

Wildcard Mask Syntax

Wildcard based patterns are supported when the MaskKind property is Wildcard. In this mode, the wildcard pattern is converted to an equivalent regular expression pattern behind the scenes.

Wildcard pattern providers search for text by using "wildcard" pattern matching. The following wildcard patterns are recognized:

Construct | Description
* | Specifies zero or more of any character, except the line feed character.
? | Specifies any single character, except the line feed character.
# | Specifies any single digit.
[aeiou] | Matches any one character in the set.
[!aeiou] | Matches any one character not in the set.

Any other character in the pattern matches the character. An example wildcard pattern is "#####-####".

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


MonthCalendar

Other Controls
MonthCalendar

The MonthCalendar control presents a calendar using several view levels. It includes smooth animations when navigating and is highly customizable.

This topic contains these sections:

  • Navigation
  • Selection
  • Disabled Dates
  • Customization

Navigation

The current view presented by the MonthCalendar is controlled by the ActiveDate and ActiveViewMode properties. There are various methods of navigating through the control, which are described below.

Zooming In and Out

The MonthCalendar control supports four view modes: Month, Year, Decade, and Century. The various view modes make it easier to navigate from one date to another, by allowing to user to zoom out and then drill back in to a specific date.

The MonthCalendar control showing the year, decade, and century views, repsectively.

The end-user can zoom out by clicking the title bar text (e.g. "August 2014" for the month view). When an individual item is clicked, that item is zoomed in. So clicking on "August" in the year view, will zoom in to the month view for August.

Tip Tip
To zoom out using the keyboard, press the '-' key while holding down the Control key. Similarly, pressing the '+' key while hold down the Control key will zoom in.

By default, the user can zoom out all the way out to the century view. This can be restricted by setting the MaxViewMode property.

Scrolling

Using the arrows in the title bar, the current view can be scrolled left or right. For the month view, scrolling left will move to the previous month and scrolling right will move to the next month. The other views move to their respective previous and next views (e.g. year, decade, century).

Tip Tip
To scroll left using the keyboard, press the PageDown key. Similarly, pressing the PageUp key will scroll right.

Keyboard/Item Navigation

When the MonthCalendar has focus, the arrow keys can be used to navigate through the current view. When moving onto an overflow item, which is an item that actually belongs to the next or previous view, then the next/previous view will be scrolled into view.

Today Button

A "today" command is available via the MonthCalendar.SelectTodayCommand property that can be bound to any button. When the button is tapped, the item that contains DateTime.Today will be selected and scrolled into view.

View Reset

The view presented by the MonthCalendar can be reset to the Month view when it loses focus, by setting the ViewResetMode property. This feature is useful when the calendar is being hosted in a Popup.

Selection

The MonthCalendar can be used to select one or more dates. The currently selected dates are available in the SelectedDates collection. Additionally, the first selected date can be retrieved using the SelectedDate property. The SelectedDate property supports two-way binding.

Note Note
Disabled dates, as described below, are automatically excluded from selection.

The SelectionChanged event fires whenever the SelectedDate or SelectedDates properties change.

The number of selected dates can be restricted using the MaxSelectionCount property. When set to -1 (the default value), no limit is imposed.

The calendar supports several selection modes, each with a unique behavior. The selection mode is configured using the SelectionMode property.

Note Note
The selection mode only limits how the end-user can select dates. The selection mode restrictions are not enforce when adding dates to SelectedDates programmatically.

Mode | Description
Single | Specifies that only a single date can be selected.
Multiple | Specifies that multiple dates can be selected, but must be done so explicitly (e.g. each item must be selected individually). When clicking on an item it's selection state is toggled.
Extended | Specifies that multiple dates can be selected, by using the Control (to toggle a selected day) and Shift (to select a range) keys.
Range | Specifies that multiple dates can be selected, by using the Shift (to select a range) key. Works like the Extended mode, but the selected dates must be in a continguous range (not including disabled dates).

The day of week header items and week number items can be used for selection, when the SelectionMode allows multiple dates to be selected. This feature can be disabled by setting IsDayOfWeekSelectionEnabled and/or IsWeekNumberSelectionEnabled properties to false.

A "clear" button can be included by setting IsClearButtonVisible to true. This button clears the current selection, which is useful when multiple date selection is enabled.

Disabled Dates

The Minimum and Maximum properties can be used to restrict the date range over which the user can navigate and select a date. Any dates falling outside of that range will appear disabled and won't be selectable.

Within the minimum and maximum range, other dates can be disabled as well. All instances of dates that fall over certain days of week can be disabled by setting the DisabledDaysOfWeek property, which accepts one or more values from the flags enumeration DaysOfWeek. This is useful for scenarios like where you might not wish to allow weekend days to be selected.

Note Note
When DisabledDaysOfWeek is set to DaysOfWeek.All then the user will not be able to navigate away from the currently active date.

Finally, for any dates that would normally be enabled within the Minimum and Maximum range, and aren't disabled by the DisabledDaysOfWeek property, a special IsDateDisabledFunc property can optionally supply a function that is passed a DateTime and returns true if the specified date should be disabled. This function is called for each day cell that is rendered.

This example code shows how to set the IsDateDisabledFunc property with a function that disables the first Tuesday of each month.

C#
VB
Copy
​disabledDaysCalendar.IsDateDisabledFunc = d => (d.DayOfWeek == DayOfWeek.Tuesday) && (d.Day >= 8) && (d.Day <= 14);
​disabledDaysCalendar.IsDateDisabledFunc = Function(d) (d.DayOfWeek = DayOfWeek.Tuesday) AndAlso (d.Day >= 8) AndAlso (d.Day <= 14)

Customization

MonthCalendar offers several properties that can be used to customize the look of the control.

General

There properties can be used to customize the overall look of the MonthCalendar, as described below.

Property | Description
CalendarWeekRule | By default the calender week rule, which determines how weeks are numbered, is retrieved from the current culture, but this property can be used to override the value.
DayOfWeekFormatPattern | Specifies the format used to display the values in the day of week header.
FirstDayOfWeek | By default the first day of the week is retrieved from the current culture, but this property can be used to override the value.
IsTodayButtonVisible | Indicates whether the today button is visible.
IsTodayHighlighted | Indicates whether today is highlighted with an outline.
IsWeekNumberColumnVisible | Indicates whether the week number column is visible.

Styles

The various items presented by the MonthCalendar can be customized using a DataTemplate or Style.

Property | Description
ClearButtonStyle | Specifies the Style to use for the Clear button within the calendar.
DayItemTemplate | Specifies the DataTemplate to use for day items within the calendar.
DayNameItemContainerStyle | Specifies the Style to use for day name items within the calendar.
DayNameItemTemplate | Specifies the DataTemplate to use for day name items within the calendar.
DecadeItemTemplate | Specifies the DataTemplate to use for decade items within the calendar.
MonthItemTemplate | Specifies the DataTemplate to use for month items within the calendar.
NavigationButtonStyle | Specifies the Style to use for navigation buttons within the calendar.
TitleButtonStyle | Specifies the Style to use for the title button within the calendar.
TodayButtonStyle | Specifies the Style to use for the Today button within the calendar.
WeekNumberItemContainerStyle | Specifies the Style to use for week number items within the calendar.
WeekNumberItemTemplate | Specifies the DataTemplate to use for week number items within the calendar.
YearItemTemplate | Specifies the DataTemplate to use for year items within the calendar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Rating

Other Controls
Rating

The Rating control inherits from ItemsControl and renders glyphs that can be used present an average rating or collect a user rating.

This topic contains these sections:

  • Average Value and Value
  • Populating the Rating
  • Glyphs and DataTemplates
  • Item Content
  • Orientation

Average Value and Value

The Rating control has two different value properties, AverageValue and Value.

The AverageValue property is displayed when the Value property is null. Generally, this would be the average value of all the known ratings for the associated item. The user cannot modify this value through use of the control, and it must be set programmatically.

Rating showing an average value of 3.5

The Value property is displayed when non-null and effectively hides the AverageValue. This value indicates the user's selection and can be updated using a pointer or the keyboard.

Populating the Rating

The Rating control is an ItemsControl, and as such, you can populate the Items collection directly with RatingItem instances, with each item representing a new "star" or rating value.

To simplify the use of the Rating control, the ItemCount property can be used to automatically populate the Items collection with 0 or more instances of RatingItem.

This XAML shows how five items can be created and the control's value bound to a view model property:

XAML
Copy
​<editors:Rating ItemCount="5" Value="{Binding Path=YourVMProperty, Mode=TwoWay}" />

Glyphs and DataTemplates

The RatingItem class is used to present each "star" or rating glyph. By default, a star glyph is shown, but this can easily be customized. Using the following properties, one or more DataTemplates can be specified to be used by the various states of a RatingItem:

  • NormalGlyphTemplate - Used when the item is in the normal (unselected) state.
  • ActiveGlyphTemplate - Used when the end user's pointer actively over this item or one after it.
  • AverageGlyphTemplate - Used when the item is involved in rendering an average value for the overall rating.
  • SelectedGlyphTemplate - Used when the item is involved in the end user's value selection.

These properties can be set using a Style that targets the RatingItem class with a setter for each of the glyph templates. Set the style to the rating's ItemContainerStyle property.

Custom glyph templates for each item

Alternatively, if the Rating control is manually populated (i.e. one or more RatingItem instances are manually added to the Items collection), the RatingItem properties can be set directly. This approach is needed to achieve advanced display scenarios like in the screenshot above.

Item Content

The RatingItem class inherits ContentControl and thus has several properties like Content, ContentTemplate, etc. Any content-related properties that are set will render the content below each item when in a horizontal orientation, or next to each item when in a vertical orientation.

In the screenshot above, the first item has "Poor" content, the second has "Fair" content, and the third has "Good" content.

Orientation

The Rating control can be oriented horizontally (the default) or vertically by setting the Orientation property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Editors Interoperability
Overview

The various edit boxes can be easily integrated and used within other controls.

  • The PropertyGrid topic contains information on integrating with the Actipro PropertyGrid control.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


PropertyGrid

Editors Interoperability
PropertyGrid

The controls provided in the Editors product can be easily integrated into the PropertyGrid control, through the use of custom property editors. In order to keep both products segregated, an Interop assembly is provided that ties the two products together.

PropertyGrid with BrushEditBox integrated

This topic contains these sections:

  • Property Editors
  • Adding to PropertyGrid

Property Editors

The PropertyGrid uses "property editors" to tie a properties to controls, by property name and/or property type. For example, you can tell the PropertyGrid that all properties of the type DateTime should use MyControlA and all properties of the type String should use MyControlB. This gives you a lot of control over what control is used for the various properties. In reality, the "control" is actually a DataTemplate since it will most likely be used multiple times.

Property editors are defined via an instance of the PropertyEditor class. Derivations of this class can provide default values, such as a known DataTemplate or property Type. In addition, derivations are required in order to decorate properties with EditorAttribute. EditorAttribute only allows the editor Type to be specified, therefore that Type needs to provide a default DataTemplate (via a derivation of PropertyEditor).

Note Note
Property editors can actually provide a DataTemplate for the value cell and the name cell, but typically the name cell does not need to be altered.

See the Property Editors topic under Actipro PropertyGrid for more information.

The Interop assembly provides a set of classes that derive from PropertyEditor and provide default values for the DataTemplate used for the value cell and the property Type. These classes include:

Class | Description
BrushPropertyEditor | Represents an property editor that uses a BrushEditBox for editing Brush property values.
ColorPropertyEditor | Represents an property editor that uses a ColorEditBox for editing Color property values.
CornerRadiusPropertyEditor | Represents an property editor that uses a CornerRadiusEditBox for editing CornerRadius property values.
DatePropertyEditor | Represents an property editor that uses a DateEditBox for editing DateTime (date-only) property values.
DateTimePropertyEditor | Represents an property editor that uses a DateTimeEditBox for editing DateTime property values.
DoublePropertyEditor | Represents an property editor that uses a DoubleEditBox for editing Double property values.
EnumPropertyEditor | Represents an property editor that uses a EnumEditBox for editing Enum property values.
GuidPropertyEditor | Represents an property editor that uses a GuidEditBox for editing Guid property values.
Int16PropertyEditor | Represents an property editor that uses a Int16EditBox for editing Int16 property values.
Int32PropertyEditor | Represents an property editor that uses a Int32EditBox for editing Int32 property values.
Int64PropertyEditor | Represents an property editor that uses a Int64EditBox for editing Int64 property values.
MaskedStringPropertyEditor | Represents an property editor that uses a MaskedTextBox for editing property values.
NullableColorPropertyEditor | Represents an property editor that uses a ColorEditBox for editing Color? property values.
NullableCornerRadiusPropertyEditor | Represents an property editor that uses a CornerRadiusEditBox for editing CornerRadius? property values.
NullableDatePropertyEditor | Represents an property editor that uses a DateEditBox for editing DateTime? (date-only) property values.
NullableDateTimePropertyEditor | Represents an property editor that uses a DateTimeEditBox for editing DateTime? property values.
NullableDoublePropertyEditor | Represents an property editor that uses a DoubleEditBox for editing Double? property values.
NullableGuidPropertyEditor | Represents an property editor that uses a GuidEditBox for editing Guid? property values.
NullableInt16PropertyEditor | Represents an property editor that uses a Int16EditBox for editing Int16? property values.
NullableInt32PropertyEditor | Represents an property editor that uses a Int32EditBox for editing Int32? property values.
NullableInt64PropertyEditor | Represents an property editor that uses a Int64EditBox for editing Int64? property values.
NullablePointPropertyEditor | Represents an property editor that uses a PointEditBox for editing Point? property values.
NullableRectPropertyEditor | Represents an property editor that uses a RectEditBox for editing Rect? property values.
NullableSinglePropertyEditor | Represents an property editor that uses a SingleEditBox for editing Single? property values.
NullableSizePropertyEditor | Represents an property editor that uses a SizeEditBox for editing Size? property values.
NullableThicknessPropertyEditor | Represents an property editor that uses a ThicknessEditBox for editing Thickness? property values.
NullableTimePropertyEditor | Represents an property editor that uses a TimeEditBox for editing DateTime? (time-only) property values.
NullableTimeSpanPropertyEditor | Represents an property editor that uses a TimeSpanEditBox for editing TimeSpan? property values.
PointPropertyEditor | Represents an property editor that uses a PointEditBox for editing Point property values.
RectPropertyEditor | Represents an property editor that uses a RectEditBox for editing Rect property values.
SinglePropertyEditor | Represents an property editor that uses a SingleEditBox for editing Single property values.
SizePropertyEditor | Represents an property editor that uses a SizeEditBox for editing Size property values.
ThicknessPropertyEditor | Represents an property editor that uses a ThicknessEditBox for editing Thickness property values.
TimePropertyEditor | Represents an property editor that uses a TimeEditBox for editing DateTime (time-only) property values.
TimeSpanPropertyEditor | Represents an property editor that uses a TimeSpanEditBox for editing TimeSpan property values.

Each property editor exposes some of the more common settings available on their associated control. For example, the MaskedStringPropertyEditor has a Mask property that allows you to set the associated Mask on the underlying MaskedTextBox. Remember that the controls are defined using a DataTemplate, so normally it is not easy to access the settings on the controls. Using the settings available on the property editor, the underlying controls can be quickly configured.

Adding to PropertyGrid

The property editors provided can be added to a PropertyGrid using several methods, which are described below.

All Default Property Editors

All default Editors integration property editors can be easily injected into a single PropertyGrid instance by setting the attached BuiltinPropertyEditors.IsEnabled property to true.

Note Note
Setting this attached property simply appends our Editors integration property editors to the PropertyGrid.PropertyEditors collection. You can add your own customized property editors to that collection through XAML too, and your custom property editors will be appended after our default Editors integration property editors. This gives your custom property editors higher priority for selection over ours.

This can be done on the specific instance or via an implicit Style that targets all PropertyGrid instances in the app.

This code shows how add the default Editors integration property editor definitions to a single PropertyGrid:

XAML
Copy
​<grids:PropertyGrid ... gridseditors:BuiltinPropertyEditors.IsEnabled="True">
    ...
</grids:PropertyGrid>

If you wish to apply the property editors provided to all property grid instances in the application, the attached BuiltinPropertyEditors.IsEnabled property can be set to true on a PropertyGridPropertyEditorsModifier object that you define in Application.Resources. Please see the Property Editors topic under Actipro PropertyGrid for more information on defining property editors in XAML using PropertyGridPropertyEditorsModifier.

Note Note
There are several property editors that cannot be installed via the built-in editors property described above and must be manually added to a PropertyGrid.PropertyEditors collection:
  • DatePropertyEditor - Targets DateTime and normally the DateTimePropertyEditor handles that.
  • MaskedStringPropertyEditor - Targets String and requires that a Mask is set.
  • NullableDatePropertyEditor - Targets DateTime? and normally the NullableDateTimePropertyEditor handles that.
  • NullableTimePropertyEditor - Targets DateTime? and normally the NullableDateTimePropertyEditor handles that.
  • TimePropertyEditor - Targets DateTime and normally the DateTimePropertyEditor handles that.

Specific Property Editors via PropertyGrid.PropertyEditors

Property editors can also be manually defined on a single instance of the PropertyGrid control by updating the PropertyEditors collection.

Several property editors (described above) require this since they can't be automatically set up by the built-in editors property. Note that you can apply the built-in editor and manually-defined editors on the same property grid.

This code shows how manually add several property editor definitions to a single PropertyGrid:

XAML
Copy
​<grids:PropertyGrid ... >
    <grids:PropertyGrid.PropertyEditors>
        <gridseditors:DatePropertyEditor PropertyName="DateLongValue" Format="D" />
        <gridseditors:MaskedStringPropertyEditor PropertyName="MaskedString" Mask="\w+([.]\w+)*@\w+([.]\w+)+" />
        <gridseditors:EnumPropertyEditor UseDisplayAttributes="True" />
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

Using EditorAttribute

A property editor can also be associated right on the data objects displayed by PropertyGrid using the EditorAttribute.

This code shows how associated a ColorEditBox property editor with a property:

C#
VB
Copy
​[Editor(typeof(ColorPropertyEditor), typeof(PropertyEditor))]
public Color MyColor {
    ...
}
​<Editor(GetType(ColorPropertyEditor), GetType(PropertyEditor))> _
Public Property MyColor() As Color
    ...
End Property

Since EditorAttribute only allows a Type to be specified, if you need to alter any default property values, create a class that inherits the desired property editor Type and set the property values in the class' constructor.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Grids Reference
Overview

Actipro Grids is a product that includes our PropertyGrid and custom tree structure (TreeListBox and TreeListView) controls.

PropertyGrid allows for all the properties of one or more objects to be displayed, optionally using categories. Pre-defined editors for modifying properties are auto-generated based on property type, and custom property/category editors can be easily created, allowing for total customization of the property editing experience.

TreeListBox is a single-column tree control similar to the Visual Studio Solution Explorer tree control. TreeListView is a multi-column variant of TreeListBox that renders similar to a standard ListView but has additional features.

Features

PropertyGrid Control

  • Displays a grid of all accessible properties for one or more objects, with full UI virtualization support.
  • Based on TreeListView, thereby inheriting all of it and TreeListBox's UI customization features.
  • Numerous built-in property editors are provided, and custom property editors can be created to customize the look and/or feel of a given property.
  • Property editors can be tied to a property by name, Type, or both, which allows for all properties of a specified Type to use the same editor.
  • A model-based data factory architecture allows for complete low-level customization of the property item presented.
  • Explicitly-defined property models can be used in place of, or in addition to, any property models dynamically-generated by a factory.
  • Support for DisplayAttribute, EditableAttribute, and several other ComponentModel attributes.
  • Properties can be automatically categorized via usage of DisplayAttribute, and nested categories can be created with a special syntax.
  • Built-in and custom filters can be used to exclude items from being displayed.
  • Properties can be automatically sorted and custom sort comparers can be defined.
  • Options for determining whether categories and properties are expanded by default.
  • Advanced expansion and inline editing (including adding/removing items where appropriate) support for collections, lists and dictionaries.
  • Ability to merge multiple objects, which means only properties common to all objects are presented.
  • Support for custom category editors, which can be used to provide more complex interfaces for presenting/modifying specified properties.
  • Support for expandable properties and lazy loading, which allows for cyclic references and faster load times.
  • Includes fully customizable and resizable summary area, which shows details about the selected property item.
  • Columns can be resized or customized as needed to provide a different appearance, and new columns can even be added.
  • Read-only state can be used to prevent changes to items through the UI.
  • Customizable built-in context menu.
  • Events for property value changes and collection children add/removes.

TreeListBox Control

  • Fully customize the appearance of each node.
  • UI virtualization, allowing for hundreds of thousands of nodes to be loaded into a tree very quickly.
  • No scrollbar jumpiness as seen in other virtualized tree controls when scrolling vertically.
  • Use your own custom data models as the source for the tree, with no dependencies on UI or our interfaces. An adapter class is used (and can be fully customized to fit your model) to communicate between the UI and the model for things like expansion state, getting children, etc.
  • The adapter can be coded with bindings in XAML (convenient, yet can be slow in very large trees) or via method overrides (slightly more work but lightning fast).
  • Optionally show the root item in the control.
  • Fine-grained control over expandability and children query triggers.
  • Optional async loading with busy indicator display.
  • Events for expansion.
  • Events for selection.
  • Single or multi-selection, with Ctrl and Shift-based selection options.
  • Filter selection such as only allowing sibling nodes to be multi-selected, or nodes of the same depth.
  • All common tree hotkeys supported including special ones for expanding and collapsing entire branches.
  • Select or ensure nodes are visible by path.
  • Double-click and Return key default action handling.
  • Optional checkboxes within the data templates.
  • Intelligent text searching so when you start typing while the control has focus, it will auto-focus the item that matches the typed text.
  • Inline editing via F2 and single-click on a selected item.
  • Per-item context menus that can be constructed dynamically via an event.
  • Drag items to external controls, drop data from external controls, or drag/drop items within the control itself.
  • Dragged items can highlight above, on, and below drop areas for each item.
  • Single and multiple item dragging is supported.
  • Optional data virtualization optimization when using virtualized collections.
  • Indentation of top-level and other nodes can be set independently.
  • Customizable item filtering that supports string, boolean, or predicate-based logic.
  • Filtered items can automatically have their ancestors expanded.

TreeListView Control

  • All features found in TreeListBox.
  • Templates, template selectors, or text property bindings used to specify custom content for each cell.
  • Column width can be a specific pixel value, auto (size to header, cells, or both), or star-sized.
  • Optional minimum and maximum widths for column auto/star-sizing modes.
  • Columns can optionally be resized, reordered, and have visibility toggled by the end user.
  • Frozen columns that don't scroll horizontally.
  • Set which column renders the indentation and expander buttons.
  • Column headers have a built-in context menu, and the headers themselves can be hidden.
  • Size columns to fit contents.
  • Optional grid line display.
  • Numerous events for column resizing, reordering, visibility changes, and header menu requests.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

PropertyGrid Features
Overview

PropertyGrid allows for all the properties of one or more objects to be displayed, optionally using categories. Pre-defined editors for modifying properties are auto-generated based on property type, and custom property/category editors can be easily created, allowing for total customization of the property editing experience.

The PropertyGrid control showing properties for a UI control

The PropertyGrid control's items can be populated simply by binding to a target data object (or data objects), by adding pre-defined property models to a properties collection, or by making a custom data factory.

Several property editors are included, which leverage existing native controls for value display and editing. Custom property or category editors can be used as well, to provide a highly-tailored presentation for your needs.

This topic contains these sections:

  • Features

Features

PropertyGrid Control

  • Displays a grid of all accessible properties for one or more objects, with full UI virtualization support.
  • Based on TreeListView, thereby inheriting all of it and TreeListBox's UI customization features.
  • Numerous built-in property editors are provided, and custom property editors can be created to customize the look and/or feel of a given property.
  • Property editors can be tied to a property by name, Type, or both, which allows for all properties of a specified Type to use the same editor.
  • A model-based data factory architecture allows for complete low-level customization of the property item presented.
  • Explicitly-defined property models can be used in place of, or in addition to, any property models dynamically-generated by a factory.
  • Support for DisplayAttribute, EditableAttribute, and several other ComponentModel attributes.
  • Properties can be automatically categorized via usage of DisplayAttribute, and nested categories can be created with a special syntax.
  • Built-in and custom filters can be used to exclude items from being displayed.
  • Properties can be automatically sorted and custom sort comparers can be defined.
  • Options for determining whether categories and properties are expanded by default.
  • Advanced expansion and inline editing (including adding/removing items where appropriate) support for collections, lists and dictionaries.
  • Ability to merge multiple objects, which means only properties common to all objects are presented.
  • Support for custom category editors, which can be used to provide more complex interfaces for presenting/modifying specified properties.
  • Support for expandable properties and lazy loading, which allows for cyclic references and faster load times.
  • Includes fully customizable and resizable summary area, which shows details about the selected property item.
  • Columns can be resized or customized as needed to provide a different appearance, and new columns can even be added.
  • Read-only state can be used to prevent changes to items through the UI.
  • Customizable built-in context menu.
  • Events for property value changes and collection children add/removes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

PropertyGrid Features
Getting Started

It's very easy to get up and running with the PropertyGrid control. In fact, setting a single property is often enough to start.

PropertyGrid is extremely customizable and allows you to alter everything from sorting, to filtering, to even the properties that are allowed to display. Be sure to read through this and other documentation topics to learn all about the advanced capabilities property grid supports.

The various Actipro Editors edit box and MaskedTextBox controls can be quickly integrated with a property grid too. These editors help provide enhanced editing features for certain .NET data types. See the Editors/PropertyGrid Interoperability topic for more information.

This topic contains these sections:

  • Displaying Properties of a Data Object
  • Read-Only Display

Displaying Properties of a Data Object

This code shows the base XAML that creates a simple PropertyGrid used to modify the properties of a .NET object, which is the most common usage scenario:

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding YourVMProperty}" />

The PropertyGrid.DataObject property allows for a single data object's properties to be displayed in the control. If multiple data objects need their common properties displayed, bind to the DataObjects property instead.

Note Note
There are other ways to populate property items, such as explictly defining them, all of which are described in the Data Models and Factories topic.

Read-Only Display

While most property grid usage scenarios involve wanting end users to be able to alter property values, the property grid is also great for displaying property values in a read-only fashion.

The PropertyGrid control in read-only mode

Set the PropertyGrid.IsReadOnly property to true to prevent any values from being changed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Models and Factories

PropertyGrid Features
Data Models and Factories

There are several ways to populate the PropertyGrid control with items (categories, properties, etc.). This topic covers the various alternatives, along with descriptions of the data models used behind the scenes and how data factories supply the data models.

The resulting data models are passed to property editors and other UI-related layers to create the user interface.

This topic contains these sections:

  • Setting the DataObject or DataObjects Properties
  • Explicitly Defining Properties
  • Data Models
  • Property Data Models
  • Category Data Models
  • Category Editor Data Models
  • Data Factories
  • Custom Data Factories

Setting the DataObject or DataObjects Properties

The property grid can easily present the properties of any .NET object or objects by setting the DataObject or DataObjects properties, respectively. When one of these two properties is set, the current data factory examines the data object(s) and generates a property data model for each of the accessible properties. Data factories are described in detail in a later section of this topic and can be highly customized, which is one of the best parts of the property grid's design.

On the Universal Windows platform, reflection is used by the default data factory to enumerate and examine properties.

If categorization is enabled, category data models are also created by the data factory. When category editors are supported, category editor data models can also be generated.

The entire hierarchy of data models (properties, categories, category editors, etc.) is then passed back to the property grid control and is bound to the control as the data source for display. The PropertyGrid control inherits TreeListView, which inherits TreeListBox. Thus the property grid harnesses and expands upon the fast data population and display framework provided by those base classes. And as such, most of the topics in the Tree Control Features area of the documentation can also apply to property grid.

Mutually-Exclusive

The DataObject and DataObjects properties are mutually exclusive and are automatically synchronized by the property grid. Therefore, if DataObject is set then DataObjects is automatically set to an object array containing only one item, the data object. Conversely, if DataObjects is set then DataObject is automatically set to the first item in the object array, if any. This functionality mirrors the Windows Forms PropertyGrid control.

Setting DataObject Example

This code shows the base XAML that creates a simple PropertyGrid used to modify the properties of a single .NET object, which is the most common usage scenario:

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding YourVMProperty}" />

Setting DataObjects Example

This code shows the base XAML that creates a simple PropertyGrid used to modify the properties of multiple .NET objects:

XAML
Copy
​<grids:PropertyGrid DataObjects="{Binding YourVMProperty}" />

When the DataObjects property is used and includes more than one .NET object, the data factory only generates property data models for "common properties". Common properties are properties that have the same name and Type and are present on all the data objects. These common properties are merged into a single property data model and presented as a single item in the property grid control. This allows any number of .NET objects to be presented or modified all at once.

See the Multiple Objects topic for more information.

Explicitly Defining Properties

PropertyGrid has a Properties collection property that accepts one or more IPropertyModel items. The PropertyModel class is generally used in this collection since it lets you set all the IPropertyModel properties yourself.

Any property models in this collection will be appended to any property models that the data factory generates for DataObject/DataObjects. Then all of the properties will be categorized (if appropriate) together and the property grid control will render the user interface for the data models. Explicitly-defined property can be used without bound data objects too.

This code shows the base XAML that you can use to create a simple property grid with two statically-defined properties via the PropertyGrid.Properties collection:

XAML
Copy
​<grids:PropertyGrid>
    <grids:PropertyModel x:Name="property1" ValueType="system:String" DisplayName="Text" Value="A string value" Description="Description for the property." />
    <grids:PropertyModel x:Name="property2" ValueType="system:Boolean" DisplayName="Boolean" Value="True" Description="Description for the property." />
</grids:PropertyGrid>

The property models can be named per the XAML above and their values checked in code. Alternatively, bindings to Value and some other properties are supported since PropertyModel does inherit DependencyObject.

Data Models

The PropertyData namespace defines a number of interfaces and classes related to data models generated by the data factory of property grid. There are data models for properties, categories, and category editors. All data models implement the core IDataModel interface and are hierarchy objects, meaning each one can have one or more child data models. This allows for nested categories and properties.

The abstract DataModelBase class implements IDataModel and INotifyPropertyChanged. It is the base class for the more concrete data model implementations.

The core IDataModel interface defines properties related to hierarchy (Parent, Children, and IsRoot), properties related to appearance (DisplayName, Description, IsExpanded, IsSelected, and IsModified), and properties related to sorting (SortComparer, SortImportance, and SortOrder). There also is a Tag property that can hold custom data related to the data model.

The display name is what shows in the property grid's name column. The description is what shows in the property grid's summary area (if displayed) when the related property is selected.

Property Data Models

The IPropertyModel interface inherits IDataModel and is designed to represent a property in a property grid. This interface has a large number of properties related to property display and editing, all of which can be bound to within a property editor.

The abstract PropertyModelBase class implements many of the core features of IPropertyModel. Then another abstract CachedPropertyModelBase class inherits PropertyModelBase and provides caching of results for various properties for optimal performance. PropertyDescriptorPropertyModel inherits that base class and uses property descriptors to retrieve values for many of the IPropertyModel properties.

Another PropertyModel class inherits PropertyModelBase and can be used in scenarios where you want to explicitly configure all of the various properties on the property model instead of using results from something like a property descriptor.

The following sections talk about the various properties declared in IPropertyModel.

Target

The Target property returns the object that owns the property. For instance, if a Foo class instance was set to PropertyGrid.DataObject, and a property model was generated for a Bar property on the Foo class, that property model's Target would return the Foo instance.

The TargetType property returns the Type of the Target instance. In the example above, it would return a Type representing the Foo class.

Value and Type

The Value property gets or sets the actual property value.

Some UI controls like TextBox require that a string representation be used. A ValueAsString property, also a get/set, converts the Value to/from a string that can be bound to. The conversions are done in protected virtual ConvertToString and ConvertFromString methods. These methods can be overridden and customized if additional logic is required for the conversion.

The ValueType property returns the Type of the Value property.

The Values property returns a list of property values in scenarios where there will be more than one if the property model represents a merged property.

Read-Only

The IsHostReadOnly property returns whether the entire host property grid is flagged as read-only via PropertyGrid.IsReadOnly. The IsValueReadOnly property returns whether the property itself is flagged as read-only, such as by not having a setter, or by having a ReadOnlyAttribute applied.

If either of those two values is true, then the IsReadOnly property will return true. This is the property that UI controls in value editing templates will bind to for a read-only state.

That property can also return true if the property model is for a nested property and the parent property model is flagged with IsImmutable.

Standard Values

Standard values can be specified for a property, which are effectively a list of known values from which the end user can choose for the property. The HasStandardValues property returns if the property has any standard values.

If the IsLimitedToStandardValues property returns true, the end user can only choose from standard values when entering a value. Otherwise, freeform entry is allowed and the standard values are presented solely as options.

The StandardValues property returns the actual collection of standard values. As an example, this collection could be bound to a CombBox.ItemsSource. For cases where these must be converted to strings, use the StandardValuesAsStrings property instead.

The CycleToNextStandardValue method can be manually called to change the Value to the next standard value.

Name Property Editors and Templates

The actual DataTemplate to use for showing the property display name in a property grid is determined by the NameTemplate, NameTemplateSelector, NameTemplateKey properties, and finally related properties on a property editor, in that order.

If a property editor is used to select the DataTemplate, it will be available in the NamePropertyEditor property.

The DataTemplate-selecting process is described in detail in the Property Editors topic.

Value Property Editors and Templates

The actual DataTemplate to use editing the property value in a property grid is determined by the ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind properties, and finally related properties on a property editor, in that order.

If a property editor is used to select the DataTemplate, it will be available in the ValuePropertyEditor property.

The DataTemplate-selecting process is described in detail in the Property Editors topic.

Resetting

The CanResetValue property determines if the value can be reset to a default value.

If so, a virtual ResetValue method is called. A related ResetValueCommand property can be used with UI controls like menu items to invoke that method.

Merging

When the IsMergeable property returns true, the property can be merged with other similarly named/typed properties. This situation can happen if multiple objects are set to the PropertyGrid.DataObjects property.

Collections

For property models that represent collections, the CanAddChild property returns whether the collection allows child items to be added. This process occurs when the IPropertyModel.AddChild method is called, or the AddChildCommand is used with a UI control to invoke the method.

For property models that represent an item within a collection, the CanRemove property returns whether the collection allows the child item to be removed. This process occurs when the IPropertyModel.Remove method is called, or the RemoveCommand is used with a UI control to invoke the method.

Category Data Models

The ICategoryModel interface inherits IDataModel and is designed to represent a category in a property grid. The interface is implemented by the CategoryModel class.

Category data models are created by the data factory when the PropertyGrid.IsCategorized property is set to true. In this scenario, the IPropertyModel.Category property is examined for each property model and properties with the same category are grouped together as child models of a category model.

Categories and how they work are described in detail in the Categorization and Sorting topic.

Category Editor Data Models

The ICategoryEditorModel interface inherits IDataModel and is designed to represent a category editor in a property grid. The interface is implemented by the CategoryEditorModel class.

Category editors and how they work are described in detail in the Category Editors topic.

Data Factories

Each property grid has a data factory assigned to the PropertyGrid.DataFactory property. A data factory is a class that implements IDataFactory. It is responsible for handling requests for generating data models via its IDataFactory.GetDataModels method. Property grid may request data models whenever a top-level control property changes (e.g. PropertyGrid.IsCategorized, etc.), when expanding nested items, or when a change is detected to certain property models.

DataFactoryBase is the abstract base class that implements IDataFactory and provides all the base logic needed to build a data factory. It handles most of the mundane details of how a data factory should work so that inherited classes can focus more on actual property model creation instead of merging, categorization, sorting, etc.

On the Universal Windows platform, an instance of the TypeReflectionFactory class is the default data factory applied to PropertyGrid.DataFactory. This class inherits DataFactoryBase and uses reflection to return data models.

How DataFactoryBase Works

Whenever a request for data models (generally for PropertyGrid.DataObjects) is made to the data factory, the GetDataModels method is called. This method is passed an IDataFactoryRequest object that contains various parameters describing what is requested. The request object also contains many options that directly come from PropertyGrid control options.

The DataFactoryBase.GetDataModels method first calls into the abstract GetPropertyModels method to get the IPropertyModel objects found for each property of each of the requested data objects to examine. These property models are stored in a data model collection. If multiple data objects are being examined and a merged property needs to be created, the CreateMergedPropertyModel method will be called.

The TypeReflectionFactory.GetPropertyModels method implementation uses reflection to locate properties on the data objects. For collection properties, the CreateCollectionPropertyModel method is called to create an IPropertyModel. Otherwise, the CreatePropertyModel method is called to create an IPropertyModel.

Next, if the request is made for a root data object, any additional explicitly-defined properties (via PropertyGrid.Properties) will be appended to the data model collection.

If categorization is enabled (via PropertyGrid.IsCategorized), then the CategorizeDataModels method is called. In that method, each of the properties in the data model collection is examined to see which category the property falls into. If no category is specified, a default Misc category is used. The final display name of this Misc category can be set with the PropertyGrid.MiscCategoryName property. ICategoryModel objects are created as appropriate to contain each of the properties in the related category. The CreateCategoryModel method is called to create the ICategoryModel object. In scenarios where category editors should be applied, the CreateCategoryEditorModel method is called to create the ICategoryEditorModel object. These category and category editor models are placed in a new top-level data model collection and they are what is returned by the GetDataModels method. If categorization is not enabled, the original uncategorized property models are what would be returned by the GetDataModels method instead.

Finally, before the results are returned, the data model collection is sorted via a call to the SortDataModels method. By default, the data models are sorted in order of sort importance (a DataModelSortImportance value), sort order (an integer), numeric display name index (if applicable and using format like [0])), and finally display name.

Note Note
All of the DataFactoryBase methods described above are virtual and can be overridden in derived classes to customize or replace default functionality.

Custom Data Factories

Custom data factories can be written to tailor what is displayed by the property grid. Custom factories can populate the property grid using entries in a collection, xml document, or application settings. It is not limited to strictly properties.

A custom factory needs to implement IDataFactory and must be assigned to the PropertyGrid.DataFactory property for it to be used.

While it's generally easiest to inherit TypeReflectionFactory for your custom factory and to simply override its methods as appropriate, you could inherit the lower-level DataFactoryBase, or even implement IDataFactory completely yourself.

The following sections summarize all of the virtual methods you can override in various data factory implementations that originally described above in the "How DataFactoryBase Works" portion of the documentation.

GetDataModels Method

The IDataFactory.GetDataModels method (implemented by DataFactoryBase.GetDataModels) is the main entry and exit point of a data factory. Thus you can override it to alter request data, reimplement all core logic, or alter the default final data model results for the request.

GetPropertyModels Method

The abstract DataFactoryBase.GetPropertyModels method is implemented by inheriting classes. It is passed a single data object and the IDataFactoryRequest object and expects that a collection of IPropertyModel objects is returned, where each property model represents an accessible property on the data object. Override this method to customize which properties are accessible for the specified data object.

Note Note
This is the most commonly overridden method for a custom data factory.

CreatePropertyModel Method

The TypeReflectionFactory.CreatePropertyModel method is called by DataFactoryBase.GetPropertyModels to create an IPropertyModel for a normal property. The default return type is PropertyDescriptorPropertyModel.

CreateCollectionPropertyModel Method

The TypeReflectionFactory.CreateCollectionPropertyModel method is called by DataFactoryBase.GetPropertyModels to create an IPropertyModel for a collection property. The default return type is CollectionPropertyDescriptorPropertyModel.

CreateMergedPropertyModel Method

The DataFactoryBase.CreateMergedPropertyModel method is called by DataFactoryBase.GetDataModels to create an IPropertyModel representing merged properties. The default return type is MergedPropertyModel.

CategorizeDataModels Method

The DataFactoryBase.CategorizeDataModels method is called by DataFactoryBase.GetDataModels to create top-level ICategoryModel objects when categorization is enabled.

CreateCategoryModel Method

The DataFactoryBase.CreateCategoryModel method is called by DataFactoryBase.CategorizeDataModels to create an ICategoryModel object for a certain category. The default return type is CategoryModel.

CreateCategoryEditorModel Method

The DataFactoryBase.CreateCategoryEditorModel method is called by DataFactoryBase.CategorizeDataModels to create an ICategoryEditorModel object for a certain category editor. The default return type is CategoryEditorModel.

SortDataModels Method

The DataFactoryBase.SortDataModels method is called by DataFactoryBase.GetDataModels to sort the data models before they are returned. While other features described in the Categorization and Sorting topic can be used to sort data models, override this method to implement a lower-level sort mechanism.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Supported Property Attributes

PropertyGrid Features
Supported Property Attributes

The data models and factories are designed to support all the common property attributes found in namespaces like System.ComponentModel and System.ComponentModel.DataAnnotations. These property attributes can help control everything from display name to description to visibility and much more.

This topic contains these sections:

  • System.ComponentModel Attributes
  • System.ComponentModel.DataAnnotations Attributes
  • Browsable Properties

System.ComponentModel Attributes

The System.ComponentModel attributes in the table below are supported. The more commonly-used attributes include usage examples.

Attribute Description
DefaultValueAttribute

Specifies the default value for a property.

The default value can be used when determine if a property has been modified, or when resetting a property. The value specified by this attribute takes precedence over the "Reset"/"ShouldSerialize" methods, if any.

This code shows an example of applying DefaultValueAttribute to set the property's default value:

C#
VB
Copy
​public class Foo {
    [DefaultValue(5)]
    public int Bar { get; set; }
}
​Public Class Foo
    <DefaultValue(5)>
    Public Property Bar() As Integer
End Class

See MSDN (external) for more information on this attribute.

EditorAttribute

Specifies the editor to use to change a property.

In the context of property grid, this attribute can be used to specify the property editor used for selecting a name cell or value editor cell DataTemplate. This property editor would override any other default property editor that normally would have been used.

This code shows an example of applying EditorAttribute to set the property's editor to use a DatePropertyEditor instead of a default DateTimePropertyEditor when Editors interop is being used:

C#
VB
Copy
​public class Foo {
    [Editor(typeof(DatePropertyEditor), typeof(PropertyEditor))]
    public DateTime Bar { get; set; }
}
​Public Class Foo
    <Editor(GetType(DatePropertyEditor), GetType(PropertyEditor))>
    Public Property Bar() As DateTime
End Class

See the Property Editors for more information on how to use this attribute.

Note Note
EditorAttribute doesn't exist natively in the Universal Windows platform, but a special implementation of it is included in the Compatibility namespace.

See MSDN (external) for more information on this attribute.

System.ComponentModel.DataAnnotations Attributes

The System.ComponentModel.DataAnnotations attributes in the table below are supported. The more commonly-used attributes include usage examples.

Attribute Description
DisplayAttribute

Provides a general-purpose attribute that lets you specify sort order and localizable strings for category, display name, description.

This code shows an example of applying DisplayAttribute to set sort order (via Order), category (via GroupName), display name (via ShortName), and description (via Description) for a property:

C#
VB
Copy
​public class Foo {
    [Display(Order = 4, GroupName = "Common", ShortName = "Bar Property", Description = "A description about Bar.")]
    public int Bar { get; set; }
}
​Public Class Foo
    <Display(Order = 4, GroupName = "Common", ShortName = "Bar Property", Description = "A description about Bar.")>
    Public Property Bar() As int
End Class

See MSDN (external) for more information on this attribute.

EditableAttribute

Indicates whether a property is editable.

When not specified, the property is editable by default if there is a set accessor available. However if this attribute is supplied with its AllowEdit property set to false, the property will be displayed as read-only.

This code shows an example of applying EditableAttribute to force the property to be read-only when in a property grid:

C#
VB
Copy
​public class Foo {
    [Editable(false)]
    public int Bar { get; set; }
}
​Public Class Foo
    <Editable(False)>
    Public Property Bar() As int
End Class

See MSDN (external) for more information on this attribute.

Browsable Properties

The properties returned by the built-in factories can be filtered based on a set of "browsable attributes". These attributes, which are defined in the BrowsableAttributes property, must be explicitly defined on a property or must be the default value for the given attribute Type. In addition, any settings stored by the attribute must be equal, such as the BrowsableAttribute.Browsable.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Property Editors

PropertyGrid Features
Property Editors

Property editors are configured to tell the property grid how to choose a user interface for displaying/editing each property. For instance, boolean properties show a check box in the value cell by default. But a custom property editor could be used to change this to a toggle switch control instead.

Property editors have the ability to match properties based on object type, property name, and property type. When a match is made, the property editor gives the user interface (via DataTemplate objects) for the property. Both the name and value cells can have a custom DataTemplate applied.

A number of built-in property editors are included with property grid, and these can be extended with any number of custom property editors. The Actipro Editors can even be easily integrated with property grid through the use of property editors, providing advanced editing features for common .NET types like numbers, dates, enums, colors, etc.

This topic contains these sections:

  • Name/Value Cells
  • Mapping UI to Properties
  • Property Editor Selection Process
  • Built-in DataTemplates and Property Editors
  • Integrating with Actipro Editors
  • Creating DataTemplates
  • Specifying a Property Editor in XAML
  • Specifying a Property Editor at the Property Level
  • Starting Property Value Editing
  • Committing Property Value Changes
  • Canceling Property Value Changes
  • Property Dialogs (ExtendedStringPropertyEditor)

Name/Value Cells

DataTemplate objects can be used to customize the display of the name and/or value cells for one or more properties. Typically, only the value cell is customized, but this is not a requirement. Cell customization is accomplished by assigning a DataTemplate to a property-related cell through property models or the use of PropertyEditor objects.

Property editors can be defined in several locations, which are discussed in detail below.

Mapping UI to Properties

Whenever the PropertyGrid control goes to generate a name or value cell for a property, it uses its NameTemplateSelector and ValueTemplateSelector objects respectively. The NameTemplateSelector property is pre-assigned with a PropertyGridNameTemplateSelector instance that has logic for matching property editors to a property and selecting a DataTemplate to use in the name cell. Likewise the ValueTemplateSelector property is pre-assigned with a PropertyGridValueTemplateSelector instance that has logic for matching property editors to a property and selecting a DataTemplate to use in the value cell.

Both template selectors use the following general prioritization for selecting a DataTemplate for an IPropertyModel. The steps are followed in order until a valid DataTemplate is found.

  1. IPropertyModel.NameTemplate / ValueTemplate
  2. IPropertyModel.NameTemplateSelector / ValueTemplateSelector
  3. IPropertyModel.NameTemplateKey / ValueTemplateKey - Attempts to locate a DataTemplate resource with the supplied x:Key.
  4. IPropertyModel.ValueTemplateKind (value cells only) - If a kind other than DefaultValueTemplateKind.None, uses a specified built-in template.
  5. Find the best PropertyEditor to use for subsequent logic. If a IPropertyModel.NamePropertyEditor / ValuePropertyEditor is specified, which can be done using EditorAttribute as described below, use it. Otherwise, use property editor matching logic described below to try and locate a property editor.
  6. PropertyEditor.NameTemplate / ValueTemplate
  7. PropertyEditor.NameTemplateSelector / ValueTemplateSelector
  8. PropertyEditor.NameTemplateKey / ValueTemplateKey - Attempts to locate a DataTemplate resource with the supplied x:Key.
  9. PropertyEditor.ValueTemplateKind (value cells only) - If a kind other than DefaultValueTemplateKind.None, uses a specified built-in template.

If none of the above steps supply a DataTemplate for a name cell, the fallback PropertyGrid.DefaultStringNameTemplate object will be used.

If none of the above steps supply a DataTemplate for a value cell, one of the following templates will be selected as fallback:

  • For property models with HasStandardValues and string-based IsLimitedToStandardValues, the PropertyGrid.DefaultLimitedStringValueTemplate object will be used.
  • For property models with HasStandardValues and non-string-based IsLimitedToStandardValues, the PropertyGrid.DefaultLimitedObjectValueTemplate object will be used.
  • For property models with HasStandardValues that aren't limited, the PropertyGrid.DefaultSuggestedStringValueTemplate object will be used.
  • Otherwise the PropertyGrid.DefaultStringValueTemplate object will be used.

Property Editor Selection Process

As mentioned in the template selection process flow above, there are scenarios where an attempt is made to locate the property editor that best matches a property. The IPropertyModel.NamePropertyEditor and The ValuePropertyEditor properties are first examined to see if a property editor is already available. If not, the property editors defined in the PropertyGrid.PropertyEditors and PropertyGrid.DefaultPropertyEditors collections are the ones that are examined next.

The PropertyGrid.PropertyEditors collection contains property editors that should only be used by that particular property grid control instance. The PropertyGrid.DefaultPropertyEditors collection on the other hand is a global collection that is shared by all property grid controls and has a number of pre-defined property editors built-in. This collection is where property editors should be defined that apply to all property grid controls in an application. Any number of custom property editors can be added to either collection.

Each PropertyEditor object has several properties that are used to determine the best match: ObjectType, PropertyName, and PropertyType. Property names must match exactly, while types offer a few more comparison options. In addition to exact matches, types can match if one of their base classes is specified in the property editor, or if it (or one of its base classes) implements a specified interface.

This table defines the precedence of property editor defintions, with the highest priority at the top ('-' indicates the given property is null or undefined):

Source | Object Type | Property Name | Property Type
PropertyEditor defined directly on the property via EditorAttribute
Instance PropertyEditors | Exact Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Exact Match
Instance PropertyEditors | Exact Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Sub-class Match
Instance PropertyEditors | Exact Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Interface Match
Instance PropertyEditors | Exact Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Exact Match | Exact Match | Generic Interface Match
Instance PropertyEditors | Sub-class Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Exact Match
Instance PropertyEditors | Sub-class Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Sub-class Match
Instance PropertyEditors | Sub-class Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Interface Match
Instance PropertyEditors | Sub-class Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Sub-class Match | Exact Match | Generic Interface Match
Instance PropertyEditors | Interface Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Exact Match
Instance PropertyEditors | Interface Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Sub-class Match
Instance PropertyEditors | Interface Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Interface Match
Instance PropertyEditors | Interface Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Interface Match | Exact Match | Generic Interface Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Exact Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Exact Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Sub-class Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Sub-class Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Interface Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Interface Match
Instance PropertyEditors | Generic Interface Match | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | Generic Interface Match | Exact Match | Generic Interface Match
Instance PropertyEditors | - | Exact Match | Exact Match
Global DefaultPropertyEditors | - | Exact Match | Exact Match
Instance PropertyEditors | - | Exact Match | Sub-class Match
Global DefaultPropertyEditors | - | Exact Match | Sub-class Match
Instance PropertyEditors | - | Exact Match | Interface Match
Global DefaultPropertyEditors | - | Exact Match | Interface Match
Instance PropertyEditors | - | Exact Match | Generic Interface Match
Global DefaultPropertyEditors | - | Exact Match | Generic Interface Match
Instance PropertyEditors | - | Exact Match | -
Global DefaultPropertyEditors | - | Exact Match | -
Instance PropertyEditors | - | - | Exact Match
Global DefaultPropertyEditors | - | - | Exact Match
Instance PropertyEditors | - | - | Sub-class Match
Global DefaultPropertyEditors | - | - | Sub-class Match
Instance PropertyEditors | - | - | Interface Match
Global DefaultPropertyEditors | - | - | Interface Match
Instance PropertyEditors | - | - | Generic Interface Match
Global DefaultPropertyEditors | - | - | Generic Interface Match
Instance PropertyEditors | - | - | -
Global DefaultPropertyEditors | - | - | -

Note Note
The search through the PropertyEditors and PropertyGrid.DefaultPropertyEditors collections will take the best match per the table above. If two or more matches are made with the same precedence level, the last one in the collection is chosen. This ensures that any user-defined property editors have a higher priority than built-in ones.

Built-in DataTemplates and Property Editors

The property grid comes with several built-in DataTemplate objects based on native controls and property editors that reference them. Each of the built-in DataTemplate objects is a property on PropertyGrid, such as DefaultStringValueTemplate. This way, it's easy to alter the built-in DataTemplate objects as needed.

The following table lists the built-in DataTemplate object for use in name cells:

Property | Description
DefaultStringNameTemplate | A DataTemplate with a read-only TextBlock that can be used for name column cells. This is used by default for all name cells.

The following table lists the built-in DataTemplate objects and property editors for use in value cells:

Property | Description
DefaultBooleanValueTemplate | A DataTemplate for editing a Boolean value with a two-state CheckBox. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.Boolean is used. The BooleanPropertyEditor class also selects this template.
DefaultBrushValueTemplate | A DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.Brush is used. The BrushPropertyEditor class also selects this template.
DefaultColorValueTemplate | A DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.Color is used. The ColorPropertyEditor class also selects this template.
DefaultExtendedStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.ExtendedString is used. The ExtendedStringPropertyEditor class also selects this template.
DefaultFontFamilyValueTemplate | A DataTemplate for editing a FontFamily value with a ComboBox that contains system font families. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontFamily is used. The FontFamilyPropertyEditor class also selects this template.
DefaultFontStretchValueTemplate | A DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontStretch is used. The FontStretchPropertyEditor class also selects this template.
DefaultFontStyleValueTemplate | A DataTemplate for editing a FontStyle value with a ComboBox that contains font style options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontStyle is used. The FontStylePropertyEditor class also selects this template.
DefaultFontWeightValueTemplate | A DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.FontWeight is used. The FontWeightPropertyEditor class also selects this template.
DefaultLimitedObjectValueTemplate | A DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.LimitedObject is used. The LimitedObjectPropertyEditor class also selects this template.
DefaultLimitedStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.LimitedString is used. The LimitedStringPropertyEditor class also selects this template.
DefaultNullableBooleanValueTemplate | A DataTemplate for editing a nullable Boolean with a three-state CheckBox. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.NullableBoolean is used. The NullableBooleanPropertyEditor class also selects this template.
DefaultStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.String is used. The StringPropertyEditor class also selects this template.
DefaultSuggestedStringValueTemplate | A DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options. The PropertyGridValueTemplateSelector selects this template when DefaultValueTemplateKind.SuggestedString is used. The SuggestedStringPropertyEditor class also selects this template.

Integrating with Actipro Editors

The powerful edit box controls in the Actipro Editors product (sold separately from Grids) can be easily integrated with the property grid for handling advanced editing of numeric types, enumerations, and more. Often this functionality is enabled by adding one line of code.

See the Actipro Editors / PropertyGrid Interoperability topic for details.

Creating DataTemplates

The data context passed to each DataTemplate is the IPropertyModel for which the DataTemplate was selected. This means that any UI controls in the value cell template should generally two-way bind to properties like Value or ValueAsString if the UI control requires a string value. Properties like IsReadOnly can also be used to ensure that the UI control is read-only when appropriate.

This code shows the default DataTemplate used in PropertyGrid.DefaultStringValueTemplate (EmbeddedTextBoxStyle is a special style we have that removes the border, etc.):

XAML
Copy
​<DataTemplate>
    <TextBox Text="{Binding ValueAsString, Mode=TwoWay}" IsReadOnly="{Binding IsReadOnly, Mode=OneWay}" Style="{StaticResource EmbeddedTextBoxStyle}" />
</DataTemplate>

When ValueAsString is used, the Value is converted to a string representation with the virtual PropertyModelBase.ConvertToString method. Likewise, the string value can be converted back to an appropriate object with the virtual ConvertFromString method. The logic of these methods can be overridden in custom property model classes.

This code shows the default DataTemplate used in PropertyGrid.DefaultLimitedObjectValueTemplate:

XAML
Copy
​<shared:BooleanNotConverter x:Key="BooleanNotConverter" />
<DataTemplate>
    <ComboBox BorderThickness="0" Padding="{ThemeResource TextControlThemePadding}" HorizontalAlignment="Stretch"
                ItemsSource="{Binding StandardValues, Mode=OneWay}" IsEnabled="{Binding IsReadOnly, Mode=OneWay, Converter={StaticResource BooleanNotConverter}}"
                SelectedItem="{Binding Value, Mode=TwoWay}"
                />
</DataTemplate>

If a PropertyEditor is used to select the DataTemplate, it will be available in the IPropertyModel.NamePropertyEditor or ValuePropertyEditor properties. Sometimes custom property editors may have additional option properties set on them. As an example, the DataTemplate could bind to a Format property on a custom value property editor with this sort of binding syntax: {Binding ValuePropertyEditor.Format}. Since the IPropertyModel itself is the binding context, the property editor and its options can be accessed in this way.

Specifying a Property Editor in XAML

It's very easy to define custom property editors in XAML, both at instance and global levels.

This example shows how a custom property editor can be applied to a property named "Foo" via the PropertyGrid.PropertyEditors property, but only on the single property grid instance upon which the property editor is defined.

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding}">
    <grids:PropertyGrid.PropertyEditors>
        <gridsPropertyEditors:PropertyEditor PropertyName="Foo">
            <gridsPropertyEditors:PropertyEditor.ValueTemplate>
                <DataTemplate>
                    <!-- NOTE: Put your UI here -->
                </DataTemplate>
            </gridsPropertyEditors:PropertyEditor.ValueTemplate>
        </gridsPropertyEditors:PropertyEditor>
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

This example shows how a custom property editor can be applied to a property named "Foo" via a PropertyGridPropertyEditorsModifier, which is a mechanism used to alter the global PropertyGrid.DefaultPropertyEditors collection (applies to all property grid instances in the application). The PropertyGridPropertyEditorsModifier.Clear property can be set to true to force the built-in default property editors collection to first clear. Then any property editors added to the modifier are added to the collection.

XAML
Copy
​<gridsPropertyEditors:PropertyGridPropertyEditorsModifier x:Key="PropertyGridPropertyEditorsModifierKey">
    <gridsPropertyEditors:PropertyEditor PropertyName="Foo">
        <gridsPropertyEditors:PropertyEditor.ValueTemplate>
            <DataTemplate>
                <!-- NOTE: Put your UI here -->
            </DataTemplate>
        </gridsPropertyEditors:PropertyEditor.ValueTemplate>
    </gridsPropertyEditors:PropertyEditor>
</gridsPropertyEditors:PropertyGridPropertyEditorsModifier>

Note Note
The PropertyGridPropertyEditorsModifier needs to be placed in your app's Application.Resources using the x:Key specified above, or it will not be applied properly.

Specifying a Property Editor at the Property Level

As described above, the IPropertyModel.NamePropertyEditor or ValuePropertyEditor properties can provide a specific PropertyEditor to use for a property model. These properties or even the DataTemplate-related selection properties on IPropertyModel can be set in a data factory or in the case of the PropertyModel, set directly in XAML.

EditorAttribute can be used to designate a PropertyEditor-based type as the property editor for a property.

Note Note
EditorAttribute doesn't exist natively in the Universal Windows platform, but a special implementation of it is included in the Compatibility namespace.

For instance, if integrating with Actipro Editors and a date-only property editor should be used on a DateTime-based property, you can apply a DatePropertyEditor to the the property like this:

C#
VB
Copy
​[Editor(typeof(DatePropertyEditor), typeof(PropertyEditor))]
public DateTime MyProperty {
    ...
}
​<Editor(GetType(DatePropertyEditor), GetType(PropertyEditor))> _
Public Property MyProperty() As DateTime
    ...
End Property

Since EditorAttribute only allows a Type to be specified, if you wish to have any non-default options set on a property editor or if you are building a custom property editor, you need to make a class that directly or indirectly inherits PropertyEditor and updates/sets those options in its constructor. Then reference that derived type in the EditorAttribute.

Starting Property Value Editing

PropertyGridItem is the "container" UI control for each row in a PropertyGrid. When a PropertyGridItem has keyboard focus, any text input can be forwarded to the first focusable control. The first focusable control is typically located in the associated value cell. This makes it easier to start to input data for a given property.

This behavior is controlled by the static PropertyGrid.StartPropertyValueEditHandlers dictionary. This dictionary maps a Type to a PropertyGridItemActionHandler delegate. Using the type of the first focusable control, the property grid will search for an associated delegate to execute. The search will start with the concrete type, then search up the base class types until a delegate is found or until no more base types are available.

Once a delegate is found, it will be executed. The delegate is responsible for moving the focus and/or passing the text input. The dictionary is initialized with several entries to support TextBox, ToggleButton, and UIElement.

Committing Property Value Changes

The property grid will move focus to the current PropertyGridItem when it receives a key down event for the Enter key. This generally has the effect of committing any changes made in a TextBox, editable ComboBox, or similar control. For other control types, such as CheckBox, the value is immediately committed back.

Canceling Property Value Changes

When the property grid receives a key down event for the Escape key, it will attempt to find an appropriate action to perform. The action would generally cancel any pending changes and move the focus back to the current PropertyGridItem.

This behavior is control by the static PropertyGrid.CancelPropertyValueEditHandlers dictionary. This dictionary maps a Type to a PropertyGridItemActionHandler delegate. Using the type of the focused control, the property grid will search for an associated delegate to execute. The search will start with the concrete type, then search up the base class types until a delegate is found or until no more base types are available.

Once a delegate is found, it will be executed. The delegate is responsible for moving the focus and/or cancelling any changes. The dictionary is initialized with a two entries to support TextBox and ComboBox.

Property Dialogs (ExtendedStringPropertyEditor)

The ExtendedStringPropertyEditor class activates a value DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button. A common use of this UI is to allow the end user to show a dialog or popup that allows extended input by clicking the ellipses button.

The button's Command property is bound to the ExtendedStringPropertyEditor.ButtonCommand property, which must be set in your code to an ICommand that shows appropriate UI such as a dialog in response. The related IPropertyModel is passed as a parameter to the command.

This sample code uses the ExtendedStringPropertyEditor for a property named Path:

XAML
Copy
​<grids:PropertyGrid x:Name="propGrid" DataObject="{Binding}">
    <grids:PropertyGrid.PropertyEditors>
        <gridsPropertyEditors:ExtendedStringPropertyEditor x:Name="dialogEditor" PropertyName="Path" />
    </grids:PropertyGrid.PropertyEditors>
</grids:PropertyGrid>

This sample code wires up the command to the property editor:

C#
VB
Copy
​private void InitializeDialogEditorButtonCommand() {
    dialogEditor.ButtonCommand = new DelegateCommand<object>(p => {
        var propertyModel = p as IPropertyModel;
        if (propertyModel != null) {
            // NOTE: Show a dialog or popup here and update propertyModel.Value after
        }
    });
}
​Private Sub InitializeDialogEditorButtonCommand()
    dialogEditor.ButtonCommand = New DelegateCommand(Of Object)(Sub(p)
        Dim propertyModel = TryCast(p, IPropertyModel)
        If propertyModel IsNot Nothing Then
            ' NOTE: Show a dialog or popup here and update propertyModel.Value after
        End If
    End Sub)
End Sub

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Category Editors

PropertyGrid Features
Category Editors

Category editors provide a way to consume several properties within a category and provide a custom user interface for them.

A property grid showing a category editor

This topic contains these sections:

  • Defining a Category Editor
  • Example Category Editor

Defining a Category Editor

The CategoryEditor class represents a category editor. Add each CategoryEditor instance that should be active to the PropertyGrid.CategoryEditors collection.

Category editors consist of three main aspects:

  • Standard display properties like Category (the category that the category editor should fall under), DisplayName, and Description.
  • A Properties collection of CategoryEditorProperty objects that are the properties to be consumed.
  • Editor DataTemplate selection properties like EditorTemplate and EditorTemplateKey. The DataTemplate provides the user interface for the collection editor.

The Category property indicates which category the editor should be under.

Note Note
If the category associated with a CategoryEditor is not used, then the category editor will not be used.

Properties to be consumed by a category editor are defined in the Properties collection. Each CategoryEditorProperty object specifies the criteria used to match properties to be consumed, such as ObjectType, PropertyName, and/or PropertyType. When a property is consumed, it is not displayed in the property grid and the category editor is responsible for presenting it.

The data factory creates an ICategoryEditorModel whenever a category editor needs to be displayed. This model has a Children collection property that provides access to each of the consumed IPropertyModel objects. The collection is enumerable and can be indexed by property name as well. The DataTemplate used by a category editor can access any of the aggregated property models and their values through that collection, such as for binding to UI controls. Although there is no requirement that a category editor allow a property to be modified.

Example Category Editor

This code shows how category editor is used to consume all properties in a "Colors" category that have a return type of Color:

XAML
Copy
​<grids:PropertyGrid DataObject="{Binding}">
    <grids:PropertyGrid.CategoryEditors>

        <gridsPropertyEditors:CategoryEditor Category="Colors" DisplayName="Colors" Description="Edit multiple Color properties using a single category editor.">
            <gridsPropertyEditors:CategoryEditor.Properties>
                <propEditors:CategoryEditorProperty PropertyType="Color" />
            </gridsPropertyEditors:CategoryEditor.Properties>
            <gridsPropertyEditors:CategoryEditor.EditorTemplate>
                <DataTemplate>
                    <StackPanel>
                        <ListBox x:Name="propertyListBox" BorderThickness="0" ItemsSource="{Binding Children}" HorizontalContentAlignment="Stretch" IsTabStop="False"
                                 SelectedItem="{Binding Children[BackgroundColor]}">
                            <ListBox.ItemTemplate>
                                <DataTemplate>
                                    <Grid Margin="0,-2">
                                        <Grid.ColumnDefinitions>
                                            <ColumnDefinition Width="150" />
                                            <ColumnDefinition Width="Auto" />
                                            <ColumnDefinition Width="80" />
                                        </Grid.ColumnDefinitions>

                                        <TextBlock Text="{Binding Name}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />

                                        <Grid Grid.Column="1" Margin="5,3,3,3" Height="14" Width="14" Background="#ffffff" VerticalAlignment="Center">
                                            <Path Margin="1" Fill="#cccccc" Data="M4,0 L8,0 L8,4 L4,4 Z  M0,4 L4,4 L4,8 L0,8 Z  M8,4 L12,4 L12,8 L8,8 Z  M4,8 L8,8 L8,12 L4,12 Z" />

                                            <Border BorderThickness="1" BorderBrush="#808080">
                                                <Border.Background>
                                                    <SolidColorBrush Color="{Binding Value}" />
                                                </Border.Background>
                                            </Border>
                                        </Grid>

                                        <TextBlock Grid.Column="2" Text="{Binding ValueAsString}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />
                                    </Grid>
                                </DataTemplate>
                            </ListBox.ItemTemplate>
                        </ListBox>

                        <editors:ColorPicker Margin="6,3" Value="{Binding ElementName=propertyListBox, Path=SelectedItem.Value, Mode=TwoWay}">
                            <editors:ColorPicker.Template>
                                <ControlTemplate TargetType="editors:ColorPicker">
                                    <editors:HsbColorPicker A="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=A, Mode=OneWay}"
                                                            Hue="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=Hue, Mode=TwoWay}"
                                                            Saturation="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=Saturation, Mode=TwoWay}"
                                                            Brightness="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=Brightness, Mode=TwoWay}"
                                                            />
                                </ControlTemplate>
                            </editors:ColorPicker.Template>
                        </editors:ColorPicker>
                    </StackPanel>
                </DataTemplate>
            </gridsPropertyEditors:CategoryEditor.EditorTemplate>
        </gridsPropertyEditors:CategoryEditor>

    </grids:PropertyGrid.CategoryEditors>
</grids:PropertyGrid>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Categorization and Sorting

PropertyGrid Features
Categorization and Sorting

Properties displayed in the property grid can be categorized into groups and sorted.

This topic contains these sections:

  • Categorization
  • Sorting

Categorization

Overview

The properties presented by the property grid can be grouped together into categories, which is controlled by the IsCategorized property.

In reality, the data factory performs the categorization of the properties based on that option. When enabled, the built-in data factory examines all data object properties for CategoryAttribute (or DisplayAttribute with a GroupName). These values get stored in the IPropertyModel.Category property for the property models that are generated. Then the data factory groups all the property models with the same category together as children of a new ICategoryModel.

Expansion

By default, all categories are automatically expanded. This default can be changed via information detailed in the Expandability topic.

Nested Categories

Properties can also be categorized into nested categories. For example, if a property specifies a category of "One\Two", then by default the property will be in a top-level category titled "One\Two". By setting PropertyGrid.AreNestedCategoriesSupported to true, the PropertyGrid will interpret the category name as a path to the desired category. In the previous example, a top-level category titled "One" will be created, with a nested category titled "Two" (which will contain the property).

If two properties specify the same root category name, then the nested categories & properties will be combined. Continuing the example from above, if another property specifies a category of "One" then it will be contained in the category titled "One" along with the nested category "Two".

Any number of nested categories can be specified, at any level. A category titled "One\Two\Three" would create three categories, with each of the latter two being nested.

The PropertyGrid.MiscCategoryName property also supports the nested category syntax. For example, if set to "One\Two" then any miscellaneous properties will be placed in the category titled "Two", which is nested in the top-level category "One".

Sorting

The items presented by the property grid can be sorted using any custom logic. By default, the items will be sorted by this data in ascending order:

  • IDataModel.SortImportance
  • IDataModel.SortOrder
  • Numeric IDataModel.DisplayName index (i.e. [0], [1], etc.) if applicable
  • IDataModel.DisplayName

Note Note
The DataModelSortImportance enumeration defines several levels of sorting, which allows categories to be sorted before category editors and properties, and category editors before properties. Statically-defined properties (via PropertyGrid.Properties) can easily change their sort importance by setting the IDataModel.SortImportance property.

The default sort comparer is what implements the above logic and can be completely customized. It is specified via the PropertyGrid.SortComparer property. This is initialized by default with an instance of DataModelSortComparer, which is a class implementing IComparer<IDataModel>. The class has boolean properties to optionally disable any of the sorting mechanisms described above and the logic to sort each one is implemented in a separate virtual method that can be overridden with custom logic.

Set the PropertyGrid.SortComparer property to null to prevent default sorting.

The data factory is what locates and applies sorting based on a sort comparer that was found. This occurs in the virtual DataFactoryBase.SortDataModels method.

Every IDataModel that is generated by the data factory has a SortComparer property. If that property is left null, then the property grid default sort comparer is used for child models of the data model. If a sort comparer is specified for a particular data model (such as a category), then that model's direct children will be sorted using the sort comparer.

While any custom sort comparer must inherit DataModelSortComparer, any of its virtual Compare* methods may be overridden with custom logic tailored to your needs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Collections

PropertyGrid Features
Collections

The property grid supports inline collection display and even editing in some cases.

This topic contains these sections:

  • Collection Property Display Mode
  • Collection TypeConverter
  • Related Events

Collection Property Display Mode

By default, collections are simply displayed without expansion or inline editing support. The PropertyGrid.CollectionPropertyDisplayMode property can be used to override this behavior.

A property grid showing several collections using Default

If PropertyGrid.CollectionPropertyDisplayMode is set to Expandable, the type converter for supported collection types will be overridden to allow expansion. In addition, the item count of the collection is used when converting a collection to a string (as seen in the following image).

A property grid showing several collections using Expandable

EditableInline works exactly like Expandable, but adds inline editing buttons for collections that support them.

A property grid showing several collections using EditableInline

Collection TypeConverter

When CollectionDisplayMode property is set to Default (which is the default value), collections with continue to use their default type converters. If this property is changed to Expandable or EditableInline, then the default collection type converters will be overridden/replaced.

When using Expandable or EditableInline, the built-in data factory will check for properties that implement ICollection, IList, IDictionary, and their generic variations. When a collection property is encountered, it is represented using CollectionPropertyDescriptorPropertyModel instead of PropertyDescriptorPropertyModel.

The CollectionPropertyDescriptorPropertyModel will call its virtual CreateExpandableCollectionConverter method and will use the type converter that is returned. By default, an instance of ExpandableCollectionConverter is returned.

ExpandableCollectionConverter supports expanding any object that implements ICollection, IList, IDictionary, and their generic variations. If more control is required over the generation of the sub-items, a derivation of ExpandableCollectionConverter can be created to customize the behavior/look.

Related Events

There are several PropertyGrid events that are raised before and after a child is added or removed, which are: ChildPropertyAdding, ChildPropertyAdded, ChildPropertyRemoving, and ChildPropertyRemoved.

The PropertyModelChildChangeEventArgs event arguments class used for the ChildPropertyAdding and ChildPropertyAdded events includes references to the parent IPropertyModel (the collection property), the child IPropertyModel (the item if known), and the child value being added. The ChildPropertyAdding event fires before the item is added to the collection and the event args' Cancel property can be set to true to prevent the add. Changing the ChildValue in this event handler will also change the item being added.

The PropertyModelChildChangeEventArgs event arguments class used for the ChildPropertyRemoving and ChildPropertyRemoved events includes references to the parent IPropertyModel (the collection property), the child IPropertyModel (the item if known), and the child value being removed. The ChildPropertyRemoving event fires before the item is removed from the collection and the event args' Cancel property can be set to true to prevent the remove.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Filtering

PropertyGrid Features
Filtering

The property grid includes advanced filtering support, which can be used to narrow down the items that are displayed. Built-in filters can be applied to several properties and can be combined into groups. Filter groups can perform a logical AND or OR operation on the child filters, and several levels of groups can be used for total control. String filters offer several comparison options including regular expressions.

This topic contains these sections:

  • Filter Infrastructure
  • Built-in PropertyModelStringFilter
  • Built-in PropertyModelBooleanFilter
  • Group Filters
  • Predicate or Custom Filters

Filter Infrastructure

The Tree Controls Filtering topic describes the core filtering mechanism used by property grid. Please review that topic first since PropertyGrid indirectly inherits TreeListBox and harnesses the same core filtering mechanism for its own filtering.

Property grid comes with a couple built-in filters that are designed to filter common properties on property models. These are described in the following sections.

Note Note
To activate filtering functionality, set the IsFilterActive property to true. It is false by default. For optimal performance, keep it false unless you have a DataFilter set and you are actively want to filter displayed properties.

Built-in PropertyModelStringFilter

The PropertyModelStringFilter class is an IDataFilter implementation for IPropertyModel string properties. It inherits StringFilterBase and all of the information in the Tree Controls Filtering topic related to "String Filters" applies. There are numerous comparison operators available, and even regular expressions are supported.

The PropertyModelStringFilter class introduces a Source property that accepts a PropertyModelStringFilterSource value and defaults to DisplayName.

That enumeration has these values:

Value | Description
Category | The IPropertyModel.Category property should be used as the source.
Description | The IDataModel.Description property should be used as the source.
DisplayName | The IDataModel.DisplayName property should be used as the source.
Name | The IDataModel.Name property should be used as the source.
ValueType | The IPropertyModel.ValueType property should be used as the source.

This code shows how to only show properties that contain "is" in their display names:

XAML
Copy
​<grids:PropertyGrid ... IsFilterActive="True">
    <grids:PropertyGrid.DataFilter>
        <grids:PropertyModelStringFilter x:Name="stringFilter" Source="DisplayName" Operation="Contains" Value="is" />
    </grids:PropertyGrid.DataFilter>
</grids:PropertyGrid>

Built-in PropertyModelBooleanFilter

The PropertyModelBooleanFilter class is an IDataFilter implementation for IPropertyModel boolean properties. It inherits BooleanFilterBase and all of the information in the Tree Controls Filtering topic related to "Boolean Filters" applies. There are numerous comparison operators available.

The PropertyModelBooleanFilter class introduces a Source property that accepts a PropertyModelBooleanFilterSource value and defaults to IsReadOnly.

That enumeration has these values:

Value | Description
CanResetValue | The IPropertyModel.CanResetValue property should be used as the source.
HasStandardValues | The IPropertyModel.HasStandardValues property should be used as the source.
IsLimitedToStandardValues | The IPropertyModel.IsLimitedToStandardValues property should be used as the source.
IsMergeable | The IPropertyModel.IsMergeable property should be used as the source.
IsModified | The IDataModel.IsModified property should be used as the source.
IsReadOnly | The IPropertyModel.IsReadOnly property should be used as the source.

This code shows how to apply a filter that excludes read-only properties:

XAML
Copy
​<grids:PropertyGrid ... IsFilterActive="True">
    <grids:PropertyGrid.DataFilter>
        <grids:PropertyModelBooleanFilter x:Name="booleanFilter" Source="IsReadOnly" Operation="Equals" Value="False" />
    </grids:PropertyGrid.DataFilter>
</grids:PropertyGrid>

Group Filters

Multiple filters like PropertyModelStringFilter and PropertyModelBooleanFilter can be combined in a group with logical AND or OR operators to return a filter result.

See the Tree Controls Filtering topic for details on using group filters.

This code shows how to only show properties that contain "is" in their display names and aren't read-only:

XAML
Copy
​<grids:PropertyGrid ... IsFilterActive="True">
    <grids:PropertyGrid.DataFilter>
        <shared:DataFilterGroup x:Name="filterGroup">
            <grids:PropertyModelStringFilter x:Name="stringFilter" Source="DisplayName" Operation="Contains" Value="is" />
            <grids:PropertyModelBooleanFilter x:Name="booleanFilter" Source="IsReadOnly" Operation="Equals" Value="False" />
        </shared:DataFilterGroup>
    </grids:PropertyGrid.DataFilter>
</grids:PropertyGrid>

Predicate or Custom Filters

Predicates or completely custom filters can be created as well. See the Tree Controls Filtering topic for details on using predicate or custom filters.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Expandability

PropertyGrid Features
Expandability

Certain complex properties are capable of being expandable in the property grid. Categories will auto-expand by default, while expandable properties will not auto-expand by default. This behavior can be changed in several ways.

This topic contains these sections:

  • Determining Property Expandability
  • Category Auto-Expansion
  • Property Auto-Expansion
  • Selectively Expanding Categories or Properties

Determining Property Expandability

The PropertyExpandability option helps guide if and when a property is deemed expandable. The PropertyExpandability enumeration returned by that property has these values:

Value | Description
Default | Indicates that properties will be expandable if the associated type converter allows sub-properties to be retrieved.
None | Indicates that properties will never be expandable.
ForceSimple | Indicates that properties will be forced to be expandable if a custom type converter has not been specified.
ForceAlways | Indicates that properties will be forced to be expandable even if a custom type converter has been specified. If a custom type converter has been specified, then it will only be overridden if it does not allow the property to be expandable.

Most properties aren't expandable, however they can be expandable if their current value has sub-properties of its own. In that case, the expandability option above governs if a property is expandable.

For the Default case, assigning a TypeConverter that is or inherits ExpandableTypeConverter onto the object type will allow it to be expandable based on the expandability setting.

This code shows how to mark a class as expandable via ExpandableTypeConverter:

C#
VB
Copy
​[TypeConverter(typeof(ExpandableObjectConverter))]
public class Foo {
    ...
}
​<TypeConverter(GetType(ExpandableObjectConverter))>
Public Class Foo
   Private ...
End Class

Category Auto-Expansion

Categories auto-expand by default, revealing the properties within them. The AreCategoriesAutoExpanded property can be set to false to not auto-expand categories.

Property Auto-Expansion

Expandable properties don't auto-expand by default. The ArePropertiesAutoExpanded property can be set to true to auto-expand all expandable properties.

Selectively Expanding Categories or Properties

Data factories generate the data models (categories, properties, etc.) that the property grid consumes when building its user interface. The IDataModel.IsExpanded property determines if a data model is expanded. It defaults to false, but as mentioned above, the AreCategoriesAutoExpanded and ArePropertiesAutoExpanded properties can alter the defaults for categories and properties respectively.

There may be certain scenarios where you wish to only expand certain categories or properties. In these cases, set AreCategoriesAutoExpanded or and ArePropertiesAutoExpanded (whichever is appropriate) to false and then make a custom data factory.

In the Universal Windows platform, the custom data factory should inherit TypeReflectionFactory. Override the CreatePropertyModel or CreateCollectionPropertyModel methods as appropriate and call their base methods. If the IPropertyModel result is for a property that should be expanded, set its IsExpanded property to true.

Note that you could alternatively add this logic in a more generalized GetDataModels method override. In that case, call the base method and iterate through the IPropertyModel results. Look for properties that should be expanded and set their IsExpanded properties to true.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple Objects

PropertyGrid Features
Multiple Objects

The property grid fully supports editing properties on multiple objects at the same time. When in a multiple object scenario, only the mergeable properties of the same name and Type will be displayed in the property grid.

This topic contains these sections:

  • Setting Multiple Objects
  • Factory Support
  • Displaying Values
  • Updating Values

Setting Multiple Objects

The DataObjects property can be set or bound to any collection that implements IEnumerable.

Note Note
When the DataObjects property is updated, then the DataObject property is automatically set to the first item in the list, or to null if there are no items.

This code shows how to the DataObjects property can be bound to the selected items of a ListBox:

XAML
Copy
​<grids:PropertyGrid DataObjects="{Binding SelectedItems, ElementName=listBox}" />

Factory Support

The built-in data factory has special support for merging the properties of more than one data object. The properties of all the data objects are retrieved, and all the common properties are located. Common properties are those that have same name and Type and that exist on all the data objects. A MergedPropertyModel is created for each merged property, which effectively wraps the related IPropertyModel for each of the data object's properties that were merged together into one.

When information about a merged property is requested, the MergedPropertyModel uses information from the wrapped property models to determine the best possible "merged information". For example, if one wrapped property accessor is read-only, then the merged property is considered read-only.

Tip Tip
The MergablePropertyAttribute can be used on a property to prevent it from being merged. Also, only one property from all the data objects needs to be marked as not mergable.

Displaying Values

Because only a single value can be displayed in the property for single property, the values of multiple properties must be compared. If all the values are equal, then that single value is used. In all other instances, null is used. The get method for the MergedPropertyModel.Value property performs this comparison.

It is possible to get the unique values of all the selected objects using the The get method for the MergedPropertyModel.Values property. A custom property editor could then be developed that presented each unique value, if so desired.

Updating Values

When updating multiple objects, the specified value is set on each object in turn. If any errors occur in the process of updating, then the remaining objects are not updated.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Columns

PropertyGrid Features
Columns

The property grid contains two resizable columns by default (a name and a value column), and also supports custom columns.

A custom column that shows a red dot for modified properties

This topic contains these sections:

  • Resizing Support
  • Default Columns and Widths
  • Adding a Custom Column

Resizing Support

By default, the columns in the property grid are resizable within their defined bounds. The CanColumnsResize property can be set to false to prevent resizing.

Default Columns and Widths

The two columns that are generated by default are the name and value columns. The name column's cells show the display names of categories and properties, while the value column's cells provide for the display/editing of property values.

The two columns have certain width settings and restrictions configured by default. These are intended to handle most common scenarios so that the end user never needs to resize the columns.

The name column and value column are set to use star (*) sizing, similar to as in a Grid where each one is equal width. However with the goals of keeping the name column cells readable and maximizing editing space in the value column cells, there are certain minimum and maximum width restrictions on each column.

The name column has a minimum width of 100 and a maximum width of NameColumnMaxWidth, which defaults to 180. This means that the name column will always stay within the range of 100 to 180 pixels wide. This is a good range to keep display name text visible.

The value column has a minimum width of 60 and no maximum width.

If you wish to allow the end user to make the name column larger, you can increase the value of the NameColumnMaxWidth property. You also can examine the Columns collection yourself to locate the appropriate column and manually tweak any of the width values to suit your needs.

Adding a Custom Column

It's very easy to add a custom column. Simply initialize a new TreeListViewColumn object and add it to the Columns collection.

This code shows how to add a custom column that renders a red dot for any modified properties:

C#
VB
Copy
​var column = new TreeListViewColumn();
column.CellBorderThickness = new Thickness(0, 0, 1, 0);
column.CellPadding = new Thickness(3, 0, 3, 0);
column.CellTemplate = this.FindResource("IsModifiedTemplate") as DataTemplate;
column.MinWidth = 16;
column.Width = GridLength.Auto;
propGrid.Columns.Insert(1, column);
​Dim column = New TreeListViewColumn()
column.CellBorderThickness = New Thickness(0, 0, 1, 0)
column.CellPadding = New Thickness(3, 0, 3, 0)
column.CellTemplate = TryCast(Me.FindResource("IsModifiedTemplate"), DataTemplate)
column.MinWidth = 16
column.Width = GridLength.Auto
propGrid.Columns.Insert(1, column)
This code shows the DataTemplate referenced above:
XAML
Copy
​<BooleanToVisibilityConverter x:Key="BooleanToVisibilityConverter" />

<DataTemplate x:Key="IsModifiedTemplate">
    <Ellipse Width="12" Height="12" StrokeThickness="1" Stroke="#ffffff" Fill="#d40404" HorizontalAlignment="Center" VerticalAlignment="Center"
                Visibility="{Binding IsModified, Mode=OneWay, Converter={StaticResource BooleanToVisibilityConverter}}" ToolTip="Modified" />
</DataTemplate>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Summary Area

PropertyGrid Features
Summary Area

The summary area is optionally displayed at the bottom of the property grid and displays information about the currently-selected property grid item, which could be a category or property.

A property grid with the summary area visible

This topic contains these sections:

  • Visibility
  • Height and Resizing
  • Customizing the DataTemplate

Visibility

The visibility of the summary area can be controlled using the IsSummaryVisible property. By default, the summary area is visible.

The end user has the ability to toggle the visibility via a "Description" context menu item. This ability can be disabled by setting the IsSummaryToggleAllowed property to false.

Height and Resizing

When the summary area is visible, it can be resized by the end-user with the mouse. This allows the end-user to show more or less of the summary area as desired. Additionally, the height of the summary area can be set programmatically using the SummaryHeight property.

By setting the IsSummaryResizable property to false, the summary will not be resizable by the end-user.

The summary area includes an "auto-size" feature, in which the summary area is dynamically sized to fit it's content. When CanSummaryAutoSize is set to true, the end-user can double click the summary area splitter to enter the auto-size mode. If the end-user resizes the summary area, then the new explict size is used and it is no longer in the auto-size mode. The summary area can be set to auto-size programmatically by setting the SummaryHeight property to Double.NaN (or "Auto" if defining in XAML).

Customizing the DataTemplate

The default DataTemplate used by the summary area includes the display name and description of the currently selected, similar to how the Windows Forms PropertyGrid control displayed information. The template also include support for scrolling content that is too large to be displayed.

A custom DataTemplate can be used by setting the SummaryTemplate or SummaryTemplateSelector properties.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Property Events

PropertyGrid Features
Property Events

The property grid has several property events that get raised in various scenarios.

Note Note
Since PropertyGrid indirectly inherits TreeListBox, all of the events described for that control such as those related to selection, expansion, etc. apply to property grid as well.

This topic contains these sections:

  • Property Change Events
  • Collection Change Events

Property Change Events

The OnPropertyValueChanging and PropertyValueChanged events are raised before and after, respectively, a property's value is updated through the property grid. The event arguments for both events include the PropertyModelValueChangeEventArgs.PropertyModel being changed and the new Value.

To cancel an update to the property value, handle the OnPropertyValueChanging event and set e.Cancel to true. This will prevent the new value from being assigned and will not raise the PropertyValueChanged event.

Collection Change Events

When a property model represents a collection property, there are several events relating to the adding and removing of child items.

See the Collections topic for a description of each of these events and when they occur.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context Menu Customization

PropertyGrid Features
Context Menu Customization

Property grid item (category, property, etc.) context menus displayed by this product can be customized or replaced entirely before they are shown to the end user.

This topic contains these sections:

  • Default Category Menu
  • Default Property Menu
  • Customizing the Menu or Items

Default Category Menu

A default context menu can be pre-configured if the PropertyGrid.IsDefaultItemContextMenuEnabled property is set to true.

The default context menu for a category has a menu item for toggling the display of the summary area, if that feature is enabled via PropertyGrid.IsSummaryToggleAllowed.

Default Property Menu

A default context menu can be pre-configured if the PropertyGrid.IsDefaultItemContextMenuEnabled property is set to true.

The default context menu for a property has a menu item for resetting the value to its default, if the control determines the property has been modified.

The context menu also has a menu item for toggling the display of the summary area, if that feature is enabled via PropertyGrid.IsSummaryToggleAllowed.

Customizing the Menu or Items

The customization of context menus is handled via the PropertyGrid.ItemMenuRequested event. This event fires whenever a context menu is displayed for an item in the property grid.

The event arguments passed are of type TreeListBoxItemMenuEventArgs, which indicates the IDataModel for which the event was fired in its Item property. This IDataModel could be an ICategoryModel, IPropertyModel, or ICategoryEditorModel.

Any pre-configured default menu is passed in the TreeListBoxItemMenuEventArgs.Menu property. Its menu items can be changed or removed, or new menu items added.

The default menu is built with all native controls such as MenuFlyout and MenuFlyoutItem. This means that custom styles targeting those types can be applied.

If you wish to completely replace the default menu and supply a custom one, set the TreeListBoxItemMenuEventArgs.Menu property to a menu of your own.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Virtualization

PropertyGrid Features
Virtualization

The property grid control uses both UI virtualization and lazy loading techniques to achieve maximum performance.

This topic contains these sections:

  • UI Virtualization
  • Lazy Loading

UI Virtualization

UI virtualization means that if many property grid items (categories, properties, etc.) are loaded in the property grid, containers are only generated for items that are visible or are close to being visible. Without UI virtualization enabled, containers would be generated for all items in the control, regardless of whether they are (or are close to being) visible, and that can severely affect UI performance. Especially since a property grid can contain a large number of items based on the data object(s) being examined.

Since property grid uses a selector to switch styles/templates for items (between properties, categories, etc.), "Standard" virtualization mode is used by default instead of "Recycling".

For more information on UI virtualization and the related features inherited via TreeListBox, please see the tree control Virtualization topic.

Lazy Loading

The property grid is designed to lazy load items. When property items are generated for a root data object, the list of root properties is first retrieved by a call to the data factory. Then additional calls are made to the data factory for each of the property value objects. This is done to see if any of them have child properties, so that property grid knows if the root property should be marked as expandable.

No deeper calls to the data factory are made until one of those root properties is expanded, at which point each of the child properties of the expanded property's value object are examined in the same way to see if any of them are expandable.

This process ensures that if a large hierarchy of expandable objects is used with property grid, it's doing the minimum number of calls to the data factory to keep the property grid UI up-to-date.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Tree Control Features
Overview

The TreeListBox control is a single-column tree control with many advanced features, similar to the Visual Studio Solution Explorer tree control. The TreeListView control is a multi-column variant of TreeListBox that renders similar to a standard ListView but has additional features.

Note Note
Since the TreeListView control inherits TreeListBox, all of the documentation related to TreeListBox also applies to TreeListView.

This topic contains these sections:

  • Features
  • Getting Started
  • Columns (TreeListView)
  • Expandability
  • Selection
  • Default Actions
  • Item Paths
  • Item CheckBoxes
  • Item Context Menus
  • Inline Editing
  • Drag and Drop
  • Text Searching
  • Filtering
  • Virtualization
  • Keyboard Shortcuts

Features

TreeListBox Control

  • Fully customize the appearance of each node.
  • UI virtualization, allowing for hundreds of thousands of nodes to be loaded into a tree very quickly.
  • No scrollbar jumpiness as seen in other virtualized tree controls when scrolling vertically.
  • Use your own custom data models as the source for the tree, with no dependencies on UI or our interfaces. An adapter class is used (and can be fully customized to fit your model) to communicate between the UI and the model for things like expansion state, getting children, etc.
  • The adapter can be coded with bindings in XAML (convenient, yet can be slow in very large trees) or via method overrides (slightly more work but lightning fast).
  • Optionally show the root item in the control.
  • Fine-grained control over expandability and children query triggers.
  • Optional async loading with busy indicator display.
  • Events for expansion.
  • Events for selection.
  • Single or multi-selection, with Ctrl and Shift-based selection options.
  • Filter selection such as only allowing sibling nodes to be multi-selected, or nodes of the same depth.
  • All common tree hotkeys supported including special ones for expanding and collapsing entire branches.
  • Select or ensure nodes are visible by path.
  • Double-click and Return key default action handling.
  • Optional checkboxes within the data templates.
  • Intelligent text searching so when you start typing while the control has focus, it will auto-focus the item that matches the typed text.
  • Inline editing via F2 and single-click on a selected item.
  • Per-item context menus that can be constructed dynamically via an event.
  • Drag items to external controls, drop data from external controls, or drag/drop items within the control itself.
  • Dragged items can highlight above, on, and below drop areas for each item.
  • Single and multiple item dragging is supported.
  • Optional data virtualization optimization when using virtualized collections.
  • Indentation of top-level and other nodes can be set independently.
  • Customizable item filtering that supports string, boolean, or predicate-based logic.
  • Filtered items can automatically have their ancestors expanded.

TreeListView Control

  • All features found in TreeListBox.
  • Templates, template selectors, or text property bindings used to specify custom content for each cell.
  • Column width can be a specific pixel value, auto (size to header, cells, or both), or star-sized.
  • Optional minimum and maximum widths for column auto/star-sizing modes.
  • Columns can optionally be resized, reordered, and have visibility toggled by the end user.
  • Frozen columns that don't scroll horizontally.
  • Set which column renders the indentation and expander buttons.
  • Column headers have a built-in context menu, and the headers themselves can be hidden.
  • Size columns to fit contents.
  • Optional grid line display.
  • Numerous events for column resizing, reordering, visibility changes, and header menu requests.

Getting Started

This topic covers everything you need to get started, including high-level information about how item adapters work, how to bind to data, and how to provide customized UI for your items.

See the Getting Started topic for more information.

Columns (TreeListView)

The TreeListView control supports one or more columns of cells that can be displayed within each item (row). Columns can be resized, reordered, hidden, frozen, and much more.

See the Columns (TreeListView) topic for more information.

Expandability

Everything from when children are queried to expander display is configurable, and events allow for expand/collapse operations to be canceled. Child items can be loaded asynchronously while a progress spinner shows that activity is occurring.

See the Expandability topic for more information.

Selection

Both single and multi-selection modes are supported. Various properties and events allow for the selection of certain items to be blocked.

See the Selection topic for more information.

Default Actions

A default action occurs when an item is double-tapped or Enter is pressed. This action can be fully customized to execute custom logic.

See the Default Actions topic for more information.

Item Paths

Sometimes it's handy to be able to supply a string path to obtain or work with an item. Each item can provide its own path. A full path can be constructed by appending a path separator delimiter and the item's path to its parent's full path.

See the Item Paths topic for more information.

Item CheckBoxes

CheckBox controls can be inserted into item templates to make items checkable, and default actions can be implemented to toggle checked states for double-taps and Enter key presses.

See the Item CheckBoxes topic for more information.

Item Context Menus

Context menus can be generated dynamically upon request by items.

See the Item Context Menus topic for more information.

Inline Editing

Items support inline editing, which means that a special UI mode can be entered where their text or other properties are in an editable state.

See the Inline Editing topic for more information.

Drag and Drop

This control supports the standard system drag and drop functionality and even has built-in features for displaying an optional drop indicator over items when dragging over the control. Full control over the drag and drop capabilities and drop result is available.

See the Drag and Drop topic for more information.

Text Searching

Text searching allows the end user to start typing text and for a visible (all ancestor items expanded, but not necessarily scrolled into view) item that starts with the typed text to be focused and scrolled into view.

See the Text Searching topic for more information.

Filtering

Filtering allows a tree to be narrowed down to only display items that match filter criteria. A powerful data filtering mechanism is provided that uses string, boolean, and predicate-based logic to filter items. The underlaying data model is not altered in any way, only the view is.

See the Filtering topic for more information.

Virtualization

The tree controls are lightning-fast because they have UI virtualization on by default. Data virtualization is an additional option for scenarios where virtualized child collections are in use.

See the Virtualization topic for more information.

Keyboard Shortcuts

Many keyboard shortcuts are supported that provide access to expand/collapse, focus/selection, default actions and editing mode.

See the Keyboard Shortcuts topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Tree Control Features
Getting Started

This topic covers everything you need to get started, including high-level information about how item adapters work, how to bind to data, and how to provide customized UI for your TreeListBox and TreeListView items.

After reading through this topic, see other topics to learn more about expansion, selection, and other advanced features offered by the tree controls.

This topic contains these sections:

  • Item Adapters
  • Recommended Item and Adapter Samples
  • Binding to Data
  • Item Templates
  • Per-Item Appearance Customization
  • Root Item Visibility
  • Ensuring An Item Is Visible
  • Item Indentation

Item Adapters

The TreeListBox and TreeListView controls are geared for MVVM usage, knowing that items can be any custom type and there could be many thousands of items. We specifically designed things so that your items would never have to implement an interface from our library, as many competitors require. After all, data libraries requiring dependencies on UI libraries are frowned up. In order to support a powerful API, keep performance very fast, and avoid any virtualization quirks that some competitors have, the tree controls use an adapter design.

An item adapter is a class (that is or is based on TreeListBoxItemAdapter) that can communicate between the control and items, and is set to the TreeListBox.ItemAdapter property. It has methods that TreeListBox and TreeListView call into to retrieve data and set various states, and is essential to activating many control features.

At a minimum, an item adapter must tell the control how to retrieve the child items of a particular item. See the next section for an example of accomplishing that. But an item adapter can do so much more, such as getting/setting expansion, selection, editing, etc. states. An item adapter can also do things like return search text, item paths, manage drag and drop, and more.

Recommended Item and Adapter Samples

The "Common" folder in the Grids portion of samples contains full source sample implementations of tree node models (e.g. the TreeNodeModel class) that can be used as a starting point for your own items. There also is a DefaultTreeListBoxItemAdapter class that implements method overrides for all adapter methods and provides optimal performance (no binding usage) when working with items of type TreeNodeModel. Using those classes, you can load hundreds of thousands of items nearly instantly.

Binding to Data

Every tree has a root and that root item should be set to the TreeListBox.RootItem property. The root item is always expanded and can optionally be displayed in the tree (see below), but by default, it is not visible. Whenever the control needs to query for child items, it will do so through the item adapter by a call to the TreeListBoxItemAdapter.GetChildren method.

A Binding can be set in XAML to the TreeListBoxItemAdapter.ChildrenBinding property to tell how an item should retrieve child items. The GetChildren method will use that binding if it is supplied, and will otherwise return null Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetChildren method instead with custom logic to retrieve the appropriate value.

The TreeListBoxItemAdapter.ChildrenPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the ChildrenBinding property, for performance reasons, it is just used temporarily to get the value in the adapter method's default implementation. The binding doesn't persist, and that's why the ChildrenPath property is required for property change notifications. This is only needed if the children collection property itself will ever change. The control will natively monitor any observable collection returned from GetChildren for changes to its items.

Here's an example specifying a children binding right in XAML. Note that this is not a recommended approach if you have very large trees or see any performance issues. In those scenarios, it's better to override the GetChildren method directly.

XAML
Copy
​<grids:TreeListBox>
    <grids:TreeListBox.ItemAdapter>
        <grids:TreeListBoxItemAdapter ChildrenBinding="{Binding Children}" ChildrenPath="Children" />
    </grids:TreeListBox.ItemAdapter>
</grids:TreeListBox>

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override IEnumerable GetChildren(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.Children : null);
}
​Public Overrides Function GetChildren(ByVal item As Object) As IEnumerable
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.Children, Nothing))
End Function

Item Templates

Since items can be any custom type, it is essential that you supply an item template containing UI for your items.

For the single-column TreeListBox control, this can be done by setting a DataTemplate to the TreeListBox.ItemTemplate property. The DataTemplate can contain any elements and those elements can be bound to properties on your item. All of this UI will appear indented based on item depth level and with an expander to the left of it.

Here's an example of a common DataTemplate that includes a Image and a TextBlock. This example assumes that you are using an item type that has ImageSource and Name properties.

XAML
Copy
​<grids:TreeListBox>
    <grids:TreeListBox.ItemTemplate>
        <DataTemplate>
            <StackPanel Orientation="Horizontal">
                <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
                <TextBlock Text="{Binding Name}" VerticalAlignment="Center" />
            </StackPanel>
        </DataTemplate>
    </grids:TreeListBox.ItemTemplate>
</grids:TreeListBox>

For the multi-column TreeListView control, the TreeListView.ItemTemplate property is not used. Instead, a DataTemplate can be set for each defined column via the TreeListViewColumn.CellTemplate property .

Here's an example of how to specify the same item template as above, but for a TreeListView column:

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name">
            <DataTemplate>
                <StackPanel Orientation="Horizontal">
                    <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
                    <TextBlock Text="{Binding Name}" VerticalAlignment="Center" />
                </StackPanel>
            </DataTemplate>
        </grids:TreeListViewColumn>
    </grids:TreeListView.Columns>
</grids:TreeListView>

If you need your appearance to vary per item, see the next section.

Per-Item Appearance Customization

For the single-column TreeListBox control, the ItemTemplateSelector property may be set to a custom DataTemplateSelector instance that picks a DataTemplate to use based on the supplied item. Use of template selectors can be important when different items require a different appearance. For instance, one DataTemplate might just show an image and text, while another may show text and a micro chart. Several examples of template selectors are found in the product QuickStarts.

For the multi-column TreeListView control, the TreeListViewColumn.CellTemplateSelector property can be set for each column, instead of the TreeListView.ItemTemplateSelector property.

You also can set the ItemContainerStyleSelector property to a custom StyleSelector instance that picks a TreeListBoxItem class or TreeListViewItem Style to use based on the supplied item. Normally only template selectors are ever required when doing per-item appearance customization, but the higher-level style selection option is there as well.

Root Item Visibility

The TreeListBox.IsRootItemVisible property (defaulting to false) determines if the RootItem is visible in the control. When true, it will be the sole top-level item. When false, its child items will be the top-level items.

Ensuring An Item Is Visible

The TreeListBox.BringItemIntoView and BringItemIntoViewByFullPath methods can be used to ensure that an item is visible and scrolled into view.

Both methods will expand any collapsed ancestor items so that the target item is visible. The BringItemIntoView method can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node. For that case, it is recommended to use the BringItemIntoViewByFullPath method that searches by full path instead, since that can be much faster. See the Item Paths topic for more information on working with paths.

Item Indentation

There are two properties that determine the indentation of items for each depth level. Expanders are generally rendered within the indentation space.

The primary property is TreeListBox.IndentIncrement, and that is the step indentation increment amount between depth levels.

The TreeListBox.TopLevelIndent is used for the top-level items only, to determine how far in they indent. Set this property to zero when top-level items aren't expandable (see the Expandability topic for more informatation). That ensures that the top-level items don't have empty whitespace on the left when they never show expanders.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Columns (TreeListView)

Tree Control Features
Columns (TreeListView)

The TreeListView control supports one or more columns of cells that can be displayed within each item (row). Columns can be resized, reordered, hidden, frozen, and much more.

Columns are created by adding TreeListViewColumn instances to the TreeListView.Columns collection. Properties set on the column instance affect all cells within that column.

This topic contains these sections:

  • Header and Cell Appearance
  • Widths
  • Resizing
  • Reordering
  • Visibility
  • Frozen Columns
  • Specifying the Expansion Column
  • Column Header Context Menus
  • Size-to-Fit
  • Grid Lines
  • Column Index

Header and Cell Appearance

Header Appearance

For a basic text column header, simply set the TreeListViewColumn.Header property to a text value.

If you need to display additional content such as images, you can set the HeaderTemplate property to a custom DataTemplate. The HeaderTemplateSelector property can be used if you have a DataTemplateSelector instance for multiple columns that is responsible for supplying a DataTemplate for each column based on the column's Header content.

The TreeListViewColumnHeader control that is used to render the chrome of a column header can have an additional style applied via the HeaderContainerStyle property. This allows you to customize the appearance of the header chrome.

The HeaderHorizontalAlignment property lets you set the horizontal alignment of content within the header cell. This is useful in cases such as numeric columns where you may wish to right-align text.

The HeaderCellPadding property controls the amount of padding between the header cell's border and its content.

The HeaderCellBorderThickness property sets the thickness of the border around the header cell.

Cell Appearance

Each column has TreeListViewColumn.CellTemplate and CellTemplateSelector properties that can be set to generate templated content for each cell within that column. See the Getting Started topic for some examples of setting the cell template properties.

The CellHorizontalAlignment property lets you set the horizontal alignment of content within the item cells. This is useful in cases such as numeric columns where you may wish to right-align text.

The CellPadding property controls the amount of padding between each item cell's border and its content.

The CellBorderThickness property sets the thickness of the border around each item cell.

Widths

A column's width is specified via the TreeListViewColumn.Width property. This property accepts a GridLength value and effectively works the same as a Grid panel's column width specification where a value can be a specific pixel length, Auto, or can be a star (*) sized length.

In the case of auto and star-sized columns, the MinWidth and MaxWidth values are also examined. These properties set minimum and maximum values for any calculated widths.

The current pixel width of the column is returned by the ActualWidth property.

Pixel Width

Pixel width columns will always render at the specified width value.

Here's an example of specifying a pixel width for a column:

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name" Width="150" />
        <grids:TreeListViewColumn Header="Description" Width="250" />
    </grids:TreeListView.Columns>
</grids:TreeListView>

Auto Width

Auto width columns will auto-size to their content. The AutoWidthMode property governs whether the auto-size includes header-only, items-only, or both (the default). It can be set to another TreeListViewColumnAutoWidthMode value to alter this behavior. It is common to set minimum and/or maximum width values on these sorts of columns.

Here's an example of specifying an auto width (which is also the default) for a column, ensuring it is at least 50px, and indicating that only item cells should be used for auto-width calculation:

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name" Width="Auto" MinWidth="50" AutoWidthMode="ItemsOnly" />
        <grids:TreeListViewColumn Header="Description" Width="250" />
    </grids:TreeListView.Columns>
</grids:TreeListView>

Star Width

Star-sized columns fill the remaining available space. It is generally a good idea to set minimum and/or maximum width values on these sorts of columns.

Here's an example of specifying star-sized widths for columns (the second column will be twice as wide as the first):

XAML
Copy
​<grids:TreeListView>
    <grids:TreeListView.Columns>
        <grids:TreeListViewColumn Header="Name" Width="*" MinWidth="50" />
        <grids:TreeListViewColumn Header="Description" Width="2*" MinWidth="50" />
    </grids:TreeListView.Columns>
</grids:TreeListView>

Resizing

The TreeListView.CanColumnsResize property (defaults to true) is a global property that indicates whether columns can resize by default. This value can be overridden on an instance basis by setting the TreeListViewColumn.CanResize property to a non-null value.

When a column is allowed to resize, the end user can click and drag a gripper on the right side of the column's header to resize it. Note that this feature is only available for star-sized columns when there is another visible star-sized column after it in the same control.

The SizeToFitCommand property returns a command that can be wired up to menu items to size the column to fit its visible contents.

The TreeListView.ColumnsResized event is raised after the end user resizes columns.

Reordering

The TreeListView.CanColumnsReorder property (defaults to false) is a global property that indicates whether columns can be reordered by default. This value can be overridden on an instance basis by setting the TreeListViewColumn.CanReorder property to a non-null value.

When a column is allowed to be reordered, the end user can click and drag the column header to a new location. Drop indicators will show where the drop will occur.

The TreeListView.ColumnReordered event is raised after the end user reorders a column.

Visibility

A column's visibility can be controlled via the TreeListViewColumn.IsVisible property. The TreeListView.ColumnIsVisibleChanged event is raised after a column's visibility changes.

The TreeListView.CanColumnsToggleVisibility property (defaults to false) is a global property that indicates whether columns can toggle their visibility by default. This value can be overridden on an instance basis by setting the TreeListViewColumn.CanToggleVisibility property to a non-null value.

When a column is allowed to have its visibility toggled, the end user can right-click the column header to show a context menu (see a section below for more on column header context menus) and the default context menu provides an option for toggling visibility.

The ToggleVisibilityCommand property returns a command that can be wired up to menu items to toggle the visibility of the column.

Frozen Columns

Frozen columns are one or more columns that appear fixed to the left side of the TreeListView control and are outside of the scrollable portion of the control.

Set the TreeListView.FrozenColumnCount to a value larger than 0 to indicate the number of columns to freeze. Make sure the columns you intend to freeze are the first columns in the Columns collection. The count doesn't examine the current visibility state of the columns, only their index in the collection.

Specifying the Expansion Column

Set the TreeListView.ExpansionColumnIndex property to the index of the column that should contain the expander buttons and be indented based on nesting level. This property defaults to 0, meaning use the first column.

The index doesn't examine the current visibility state of the columns, so it is possible to hide the expansion column. It's good practice to set the CanToggleVisibility to false on the expansion column index if you are enabling column visibility toggling in general.

Column Header Context Menus

When the TreeListView.IsDefaultColumnHeaderContextMenuEnabled property is set to true (the default), a default context menu will be generated when a column header is right-clicked. The default context menus has size-to-fit options and column visibility options, all based on if the related features are enabled.

If you are using column header templates instead of setting the TreeListViewColumn.Header properties to string values, be sure to set the Title property to a string that describes the column title. This string will be used in the default column header context menu and/or other UI.

The TreeListView.ColumnHeaderMenuRequested event is raised immediately before the menu is displayed. This allows you to customize the menu as needed with custom logic, or prevent it from showing at all.

Size-to-Fit

The TreeListViewColumn.SizeToFit method can be called to size a column to its visible contents based on the AutoWidthMode setting.

A companion SizeToFitCommand property is available, returning a command that can be used in menu items to call the SizeToFit method.

Grid Lines

While column headers have grid lines by default due to the TreeListViewColumn.HeaderCellBorderThickness property being 0,0,1,1, item cells don't have grid lines by default.

Set the TreeListViewColumn.CellBorderThickness property to 0,0,1,1 to enable grid lines around the item cells too.

Column Index

The index of the column within its owner control can be retrieved via the TreeListViewColumn.Index property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Expandability

Tree Control Features
Expandability

Everything from when children are queried to expander display is configurable, and events allow for expand/collapse operations to be canceled. Child items can be loaded asynchronously while a progress spinner shows that activity is occurring.

This topic contains these sections:

  • Syncing Item Expansion State
  • Expand and Collapse Events
  • Querying Children on Expansion
  • Expander Display
  • Optimizing Leaf Node Items
  • Async Loading of Children

Syncing Item Expansion State

The control can two-way communicate with items regarding their expansion state. This is accomplished by calls to the TreeListBoxItemAdapter.GetIsExpanded and TreeListBoxItemAdapter.SetIsExpanded methods (via TreeListBox.ItemAdapter).

A two-way Binding can be set in XAML to the TreeListBoxItemAdapter.IsExpandedBinding property to tell how an item should retrieve the selection state. The GetIsExpanded method will use that binding if it is supplied, and will otherwise return false. The SetIsExpanded method will also use that binding if it is supplied. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsExpanded and SetIsExpanded methods instead with custom logic to retrieve/set the appropriate values.

Note Note
The GetIsExpanded method is generally called much more than other item adapter methods and as such, its performance if using bindings per above can cause UI sluggishness. That being said, for any small to medium size trees, using bindings is generally fine.

The TreeListBoxItemAdapter.IsExpandedPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsExpandedBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsExpandedPath property is required for property change notifications.

This example code shows how to override the methods for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsExpanded(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsExpanded : false);
}

public override void SetIsExpanded(object item, bool value) {
    var model = item as TreeNodeModel;
    if (model != null)
        model.IsExpanded = value;
}
​Public Overrides Function GetIsExpanded(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsExpanded, False))
End Function

Public Overrides Sub SetIsExpanded(ByVal item As Object, ByVal value As Boolean)
    Dim model = TryCast(item, TreeNodeModel)
    If model IsNot Nothing Then
        model.IsExpanded = value
    End If
End Sub

Expand and Collapse Events

There are several events on TreeListBox that are raised when items are expanding and collapsing. All of them are passed an event arguments object of type TreeListBoxItemExpansionEventArgs, which specifies the related Item and its UI Container.

In addition, the event arguments indicate the kind of expand/collapse (Single, Branch, or All) via the Kind property and also the root item where the event occurred via the SourceItem property. This source item is the same as the Item when affecting a single item, specifies the branch root item when affecting a branch of items, and is null when affecting all items. Branch and all expand/collapse scenarios occur when pressing *, Ctrl+*, /, and Ctrl+/. See the Keyboard Shortcuts topic for more information.

The ItemExpanding event is raised immediately before an item is expanded. Set its Cancel property to true to prevent the expand. The ItemExpanded event is raised after the expand.

The ItemCollapsing event is raised immediately before an item is collapsed. Set its Cancel property to true to prevent the collapse. The ItemCollapsed event is raised after the collapse.

Querying Children on Expansion

The TreeListBoxItemAdapter.ChildrenQueryModeDefault property (via TreeListBox.ItemAdapter) returns a TreeItemChildrenQueryMode value that determines when children are queried. The default value is OnDisplay, meaning that any time an item first becomes visible, a query will be made for its child items. If no child items are found, the item's expander will be hidden.

If the property is changed to OnExpansion instead, a query will only be made for the child items when it is first expanded. Again, if no child items are found, the item's expander will be hidden.

Expander Display

The TreeListBoxItemAdapter.GetExpandability method (via TreeListBox.ItemAdapter) returns a TreeItemExpandability value that indicates if a given item can be expandable, assuming it has child items. The default logic for this method will return Never if the specified item is top-level and the TreeListBoxItemAdapter.TopLevelExpandabilityDefault property value is Never. Otherwise, the TreeListBoxItemAdapter.ExpandabilityDefault property value is returned.

A TreeListBoxItemAdapter.GetExpandability method result of Never will never show an expander and double-clicking items won't toggle their expansion state. This is useful when you wish to display a full tree without letting the user toggle expansion. A result of Auto means the children querying logic described above will determine if the expander is visible.

If an item doesn't initially have any children, thereby preventing the expander from displaying, and at a later time children are added while the item is collapsed, the TreeListBox.InvalidateChildren method can be called to clear the cached state.

Note Note
If you wish to always have top-level items expanded, ensure the top-level items are expanded and set TreeListBoxItemAdapter.TopLevelExpandabilityDefault to Never. It is also generally advised to set TreeListBox.TopLevelIndent to 0 in this case so there is no whitespace to the left of the top-level items.

Optimizing Leaf Node Items

Sometimes certain items might be of a type that they are always leaves in the tree and can never have child items. This is very applicable when using the TreeItemChildrenQueryMode.OnExpansion query mode. In these cases, you can override the TreeListBoxItemAdapter.CanHaveChildren method (via TreeListBox.ItemAdapter) to return false. It returns true by default, and should never return false if the item can have child items, but doesn't at the current time. Optimizations are in place to not call TreeListBoxItemAdapter.GetChildren when this method returns true for an item.

This example code shows how to override the method to return true if the item is of type LeafTreeNodeModel.

C#
VB
Copy
​public virtual bool CanHaveChildren(object item) {
    return (item is LeafTreeNodeModel);
}
​Public Overridable Function CanHaveChildren(ByVal item As Object) As Boolean
    Return (TypeOf item Is LeafTreeNodeModel)
End Function

Async Loading of Children

Sometimes child item queries can be lengthy operations and it's not desirable to lock up the UI while they occur. Scenarios where this is applicable are file system, web, or database queries. TreeListBox fully supports async loading of child items. While an item is flagged as loading, it will keep its expander visible.

When setting the TreeListBoxItemAdapter.ChildrenQueryModeDefault property to TreeItemChildrenQueryMode.OnExpansion, you can add a TreeListBox.ItemExpanding event handler. In that event handler, inform the control that the item is doing async loading and start an async Task with your loading code. The task's logic should execute your potentially lengthy loading code and end with a Dispatcher.BeginInvoke that creates the new child items, adds them to the parent item's children collection, and finally informs the control that the item is done async loading.

The loading state is provided to the control by calls to the TreeListBoxItemAdapter.GetIsLoading method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.IsLoadingBinding property to tell how an item should retrieve the loading state. The GetIsLoading method will use that binding if it is supplied, and will otherwise return false. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsLoading method instead with custom logic to retrieve the appropriate value.

The TreeListBoxItemAdapter.IsLoadingPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsLoadingBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsLoadingPath property is required for property change notifications.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsLoading(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsLoading : false);
}
​Public Overrides Function GetIsLoading(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsLoading, False))
End Function

Note Note
It is a good idea to swap out the image for the item that is performing async loading and to replace it with a small progress spinner until the loading is complete.

A full sample of how everything described above works is in the Folder Browser demo.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Selection

Tree Control Features
Selection

Both single and multi-selection modes are supported. Various properties and events allow for the selection of certain items to be blocked.

This topic contains these sections:

  • Single or Multiple Selection
  • Returning Selectability
  • Multiple Selection Filtering
  • Syncing Item Selection State
  • Selection Events

Single or Multiple Selection

The TreeListBox.SelectionMode property indicates the kind of selection supported by the control. The default is Single.

Mode | Description
Single | The user can select only one item at a time.
Multiple | The user can select multiple items without holding down a modifier key.
Extended | The user can select multiple consecutive items while holding down the Shift key or can toggle selection on items while holding the Ctrl key. This is a more common selection mode for multi-select over the Multiple option.

The TreeListBox.SelectedItem property gets and sets the primary selected item, while the SelectedItems property contains the collection of currently-selected items.

Returning Selectability

The control calls the TreeListBoxItemAdapter.GetIsSelectable method (via TreeListBox.ItemAdapter) to return whether an item is capable of being selected. This method returns true by default, but can return false for items that aren't currently capable of being selected, such as for temporary placeholder items.

A Binding can be set in XAML to the TreeListBoxItemAdapter.IsSelectableBinding property to tell how an item should retrieve the path segment. The GetIsSelectable method will use that binding if it is supplied, and will otherwise return null. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsSelectable method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsSelectable(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsSelectable : true);
}
​Public Overrides Function GetIsSelectable(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsSelectable, True))
End Function

Multiple Selection Filtering

The TreeListBox.MultiSelectionKind property (of type TreeMultiSelectionKind) can be used when multi-selection is enabled. It can apply restrictions to items being added to an existing selection. The default is Any, meaning any items can be added to the selection. This table lists the other options:

Mode | Description
Any | Any node can be selected.
SameType | Any node that is the same type can be selected.
SameDepth | Any node at the same depth can be selected.
Siblings | Any node that shares the same parent can be selected.

The TreeListBox.ItemSelecting event is also raised prior to any selection being made. The event is passed arguments of type TreeListBoxItemEventArgs, which specifies the related Item and its UI Container. If you wish to prevent a certain item from being selected, set the event args' Cancel property to true.

Syncing Item Selection State

The control needs to two-way communicate with items regarding their selection state. This is accomplished by calls to the TreeListBoxItemAdapter.GetIsSelected and TreeListBoxItemAdapter.SetIsSelected methods (via TreeListBox.ItemAdapter).

A two-way Binding can be set in XAML to the TreeListBoxItemAdapter.IsSelectedBinding property to tell how an item should retrieve the selection state. The GetIsSelected method will use that binding if it is supplied, and will otherwise return false. The SetIsSelected method will also use that binding if it is supplied. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsSelected and SetIsSelected methods instead with custom logic to retrieve/set the appropriate values.

The TreeListBoxItemAdapter.IsSelectedPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsSelectedBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsSelectedPath property is required for property change notifications.

This example code shows how to override the methods for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsSelected(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsSelected : false);
}

public override void SetIsSelected(object item, bool value) {
    var model = item as TreeNodeModel;
    if (model != null)
        model.IsSelected = value;
}
​Public Overrides Function GetIsSelected(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsSelected, False))
End Function

Public Overrides Sub SetIsSelected(ByVal item As Object, ByVal value As Boolean)
    Dim model = TryCast(item, TreeNodeModel)
    If model IsNot Nothing Then
        model.IsSelected = value
    End If
End Sub

Selection Events

The TreeListBox.SelectionChanged event is raised whenever the selection (such the values stored in the SelectedItem and SelectedItems properties) has changed.

The TreeListBox.ItemSelecting event is raised before an item is about to be selected. The Cancel property on the event arguments can be set to true to prevent the item from being selected.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Default Actions

Tree Control Features
Default Actions

A default action occurs when an item is double-tapped or Enter is pressed. This action can be fully customized to execute custom logic.

This topic contains these sections:

  • Built-In Default Actions
  • Customizing Default Actions

Built-In Default Actions

The only built-in default action is for expandable items to toggle their expansion state. You can cancel this default action by handling the TreeListBox.ItemDefaultActionExecuting event and setting the event args' Cancel property to true.

Customizing Default Actions

In addition to blocking a default action from occurring as above, the TreeListBox.ItemDefaultActionExecuting event can be used for notifications of when to execute a custom action. For instance, when including check boxes on items, you might want to toggle the checked state of the item. Take whatever custom action you wish to take in response to that event. The event is passed arguments of type TreeListBoxItemEventArgs, which specifies the related Item and its UI Container.

If the ItemDefaultActionExecuting event doesn't cancel the default action, then the control will look to see if a TreeListBoxItem.DefaultActionCommand exists. If so, it will try to execute that command.

The TreeListBoxItem.DefaultActionCommand can be set in a TreeListBox.PrepareContainerForItemOverride override.

Otherwise, the built-in default action will execute, if appropriate.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Paths

Tree Control Features
Item Paths

Sometimes it's handy to be able to supply a string path to obtain or work with an item. Each item can provide its own path. A full path can be constructed by appending a path separator delimiter and the item's path to its parent's full path.

This topic contains these sections:

  • Providing an Item Path
  • Setting the Path Separator
  • Getting an Item From a Full Path
  • Getting an Item's Full Path
  • Other Operations by Full Path

Providing an Item Path

An item's path segment is provided to the control by calls to the TreeListBoxItemAdapter.GetPath method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.PathBinding property to tell how an item should retrieve the path segment. The GetPath method will use that binding if it is supplied, and will otherwise return null. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetPath method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override string GetPath(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.Name: null);
}
​Public Overrides Function GetPath(ByVal item As Object) As String
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.Name, Nothing))
End Function

Setting the Path Separator

The TreeListBox.PathSeparator property is what defines the delimiter text that separates each item's path segment to build a full path. Its default value is \.

Getting an Item From a Full Path

If you know the full path of an item and wish to obtain the item itself, you can call the TreeListBox.GetItemByFullPath method, passing in the full path as an argument.

Getting an Item's Full Path

If you have an item reference and wish to obtain its full path, you can call the TreeListBox.GetFullPath method, passing in the item as an argument.

Other Operations by Full Path

This methods can be executed by supplying a full path.

Member | Description
TreeListBox.BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view.
TreeListBox.FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed.
TreeListBox.SelectItemByFullPath | Sets the TreeListBox.SelectedItem to the node with the specified full path.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item CheckBoxes

Tree Control Features
Item CheckBoxes

CheckBox controls can be inserted into item templates to make items checkable, and default actions can be implemented to toggle checked states for double-taps and Enter key presses.

This topic contains these sections:

  • Displaying CheckBoxes
  • Using Default Actions to Toggle Checked State

Displaying CheckBoxes

CheckBox controls aren't built into the control itself but rather are part of the DataTemplate you supply for the items.

Here's an example of a DataTemplate that includes a CheckBox. This example assumes that you are using an item type that has IsThreeState, IsChecked, and Name properties. The IsChecked property has a two-way binding so that it can update the item's property as the end user toggles the CheckBox.

XAML
Copy
​<DataTemplate>
    <StackPanel Orientation="Horizontal">
        <CheckBox Margin="0,0,4,0" VerticalAlignment="Center"
                  Visibility="{Binding IsCheckable, Converter={StaticResource BooleanToVisibilityConverter}}"
                  IsThreeState="{Binding IsThreeState}" IsChecked="{Binding IsChecked, Mode=TwoWay}"
                  />

        <TextBlock Text="{Binding Name}" TextTrimming="CharacterEllipsis" VerticalAlignment="Center" />
    </StackPanel>
</DataTemplate>

Using Default Actions to Toggle Checked State

Default actions are executed when an item is double-tapped or Enter is pressed. When using CheckBox controls in item templates, it's generally good practice to handle item default actions and toggle the item's IsChecked property appropriately.

This example code shows how to handle a default action (via the TreeListBox.ItemDefaultActionExecuting event) and toggle the checked state on a CheckableTreeNodeModel item type that has IsCheckable, IsThreeState, and IsChecked properties.

C#
VB
Copy
​private void OnTreeListBoxItemDefaultActionExecuting(object sender, TreeListBoxItemEventArgs e) {
    var model = e.Item as CheckableTreeNodeModel;
    if ((model != null) && (model.IsCheckable)) {
        e.Cancel = true;

        // Toggle the checked state
        switch (model.IsChecked) {
            case true:
                model.IsChecked = (model.IsThreeState ? (bool?)null : false);
                return;
            case null:
                model.IsChecked = false;
                return;
            default:
                model.IsChecked = true;
                return;
        }
    }
}
​Private Sub OnTreeListBoxItemDefaultActionExecuting(ByVal sender As Object, ByVal e As TreeListBoxItemEventArgs)
    Dim model = TryCast(e.Item, CheckableTreeNodeModel)
    If (model IsNot Nothing) AndAlso (model.IsCheckable) Then
        e.Cancel = True

        ' Toggle the checked state
        Select Case model.IsChecked
            Case True
                model.IsChecked = (model.IsThreeState ? (If(Boolean, )Nothing, False))
                Return
            Case Nothing
                model.IsChecked = False
                Return
            Case Else
                model.IsChecked = True
                Return
        End Select
    End If
End Sub

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Item Context Menus

Tree Control Features
Item Context Menus

Context menus can be generated dynamically upon request by items.

This topic contains these sections:

  • Dynamically Creating Context Menus

Dynamically Creating Context Menus

The TreeListBox.ItemMenuRequested event is raised whenever a context menu is required for an item. The event is passed arguments of type TreeListBoxItemMenuEventArgs, which specifies the related Item and its UI Container.

No context menu is automatically created by default. It is up to you to set the TreeListBoxItemMenuEventArgs.Menu property to a menu you generate. Responding to the event allows you to dynamically build a menu based on the context of the item.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Inline Editing

Tree Control Features
Inline Editing

Items support inline editing, which means that a special UI mode can be entered where their text or other properties are in an editable state.

This topic contains these sections:

  • Starting Editing
  • Using an Editable Item Template
  • Providing Whether an Item Is Editable
  • Syncing Item Editing State

Starting Editing

If an item is editable (see below for how to provide this), pressing F2 while it is focused, or single tapping on an EditableContentControl in the item's template will trigger edit mode. This is often kept in sync with an item's IsEditing property.

Note Note
When edit mode is active, no arrow key-based item navigation will be enabled. Therefore it is important to only mark items as editable (see below) that have a control in the item template that will respond to IsEditing property changes (from F2 pressed or the item is single tapped) and that also exits the edit mode when appropriate (i.e. focus loss). The default implementation of EditableContentControl does all this for you if you two-way bind its IsEditing property. If you wish to manage the IsEditing state on your own, do not mark the item as editable.

Using an Editable Item Template

When an item's text should be editable, use a EditableContentControl in its item template instead of a TextBlock to display the text. The text will display like a normal TextBlock by default, but will switch to a TextBox for editing when in edit mode.

Here's an example of a DataTemplate that includes a Image and EditableContentControl. This example assumes that you are using an item type that has ImageSource, Name, and IsEditing properties. The IsEditing property has a two-way binding so that it can update the item's property as the end user exits edit mode.

XAML
Copy
​<DataTemplate>
    <StackPanel Orientation="Horizontal">
        <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
        <shared:EditableContentControl Margin="2,0,0,0" Content="{Binding Name, Mode=TwoWay}" IsEditing="{Binding IsEditing, Mode=TwoWay}" />
    </StackPanel>
</DataTemplate>

By specifying a ContentTemplate on the content control, you can surround the bound text content with other text. For instance, if Name has value "Foo", instead of just showing "Foo" in the item template, you could display the text as "Solution 'Foo'". Here's an example:

XAML
Copy
​<DataTemplate>
    <StackPanel Orientation="Horizontal">
        <Image Width="16" Height="16" Source="{Binding ImageSource}" Stretch="None" VerticalAlignment="Center" />
        <shared:EditableContentControl Margin="2,0,0,0" Content="{Binding Name, Mode=TwoWay}" IsEditing="{Binding IsEditing, Mode=TwoWay}">
            <shared:EditableContentControl.ContentTemplate>
                <DataTemplate>
                    <StackPanel Orientation="Horizontal">
                        <TextBlock Text="Solution '" VerticalAlignment="Center" />
                        <TextBlock Text="{Binding}" VerticalAlignment="Center" />
                        <TextBlock Text="'" VerticalAlignment="Center" />
                    </StackPanel>
                </DataTemplate>
            </shared:EditableContentControl.ContentTemplate>
        </shared:EditableContentControl>
    </StackPanel>
</DataTemplate>

When an item with the above item template is edited, the surrounding "Solution'" and "'" text disappears and the TextBox occupies the entire space, editing the Name value.

Providing Whether an Item Is Editable

An item will only enter edit mode if the adapter returns that it is editable. The editable state is provided to the control by calls to the TreeListBoxItemAdapter.GetIsEditable method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.IsEditableBinding property to tell how an item should retrieve the editable state. The GetIsEditable method will use that binding if it is supplied, and will otherwise return the TreeListBoxItemAdapter.IsEditableDefault property value. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsEditable method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsEditing(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsEditing : false);
}
​Public Overrides Function GetIsEditing(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsEditing, False))
End Function

Syncing Item Editing State

The control needs to two-way communicate with items regarding their editing state. This is accomplished by calls to the TreeListBoxItemAdapter.GetIsEditing and TreeListBoxItemAdapter.SetIsEditing methods (via TreeListBox.ItemAdapter).

A two-way Binding can be set in XAML to the TreeListBoxItemAdapter.IsEditingBinding property to tell how an item should retrieve the editable state. The GetIsEditing method will use that binding if it is supplied, and will otherwise return false. The SetIsEditing method will also use that binding if it is supplied. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetIsEditable and SetIsEditing methods instead with custom logic to retrieve/set the appropriate values.

The TreeListBoxItemAdapter.IsEditingPath property specifies the property name to watch for in case your item implements INotifyPropertyChanged. When a change to that property is detected, the updated value will be requested by the control. Note that even though a binding can be used via the IsEditingBinding property, for performance reasons, it is just used temporarily to get/set the value in the adapter methods' default implementations. The binding doesn't persist, and that's why the IsEditingPath property is required for property change notifications.

This example code shows how to override the methods for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override bool GetIsEditing(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.IsEditing : false);
}

public override void SetIsEditing(object item, bool value) {
    var model = item as TreeNodeModel;
    if (model != null)
        model.IsEditing = value;
}
​Public Overrides Function GetIsEditing(ByVal item As Object) As Boolean
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.IsEditing, False))
End Function

Public Overrides Sub SetIsEditing(ByVal item As Object, ByVal value As Boolean)
    Dim model = TryCast(item, TreeNodeModel)
    If model IsNot Nothing Then
        model.IsEditing = value
    End If
End Sub

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Drag and Drop

Tree Control Features
Drag and Drop

This control supports the standard system drag and drop functionality and even has built-in features for displaying an optional drop indicator over items when dragging over the control. Full control over the drag and drop capabilities and drop result is available.

This topic contains these sections:

  • Dragging Support
  • Multiple Item Dragging and Filtering
  • Initializing a DataObject
  • Dropping Support
  • Handling OnDragOver and OnDrop Notifications

Dragging Support

Dragging is not enabled by default and must be activated by setting the TreeListBox.CanDragItems property to true.

When dragging is enabled and dragging over collapsed items, they will expand after a delay. Similarly, dragging around the very top and bottom of the control will scroll the control.

Multiple Item Dragging and Filtering

The TreeListBox.MultiDragKind property (of type TreeMultiDragKind) can be used when multiple item drag is enabled. It can apply restrictions so that certain items cannot be dragged together. The default is None, meaning only single item selection drags are permitted. This table lists the other options:

Mode | Description
None | Drags are not allowed when multiple items are selected. Only single item selection drags are permitted.
Any | Any node can be dragged.
SameType | Any node that is the same type can be dragged.
SameDepth | Any node at the same depth can be dragged.
Siblings | Any node that shares the same parent can be dragged.

Initializing a DataObject

When items are about to be dragged, the TreeListBoxItemAdapter.InitializeDataObject method (via TreeListBox.ItemAdapter) is called to initialize the drag data.

By default, the InitializeDataObject method does nothing and needs an override implementation for drag support.

The TreeListBox.ItemDataFormat format can be used to store custom data referencing each item being dragged. We recommend storing a string object in that format where each line in the string is a full path to the item. See the Item Paths topic for more information on paths. Each full path should be able to uniquely identify the item.

Other formats can be added to the drag data. For instance, if one item is being dragged, it's common to set a text value that contains the primary text displayed for the item. This text value could then be dropped onto other external controls like TextBox controls.

Note Note
A full sample of drag and drop functionality is included in the product QuickStarts. It contains fairly extensive logic and should be referred to for better understanding of how drag and drop works.

Dropping Support

Dropping is not enabled by default. Set the TreeListBox.AllowDrop property to true to allow dropping. When dropping is allowed, various notification methods will be called on the item adapter as described below. Dropped items can be sourced from the same control or from external controls as well.

Handling OnDragOver and OnDrop Notifications

The TreeListBoxItemAdapter.OnDragOverAsync method (via TreeListBox.ItemAdapter) notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.

The default implementation of this method flags that dropping is not allowed and returns TreeItemDropArea.None, meaning no visual feedback should be given. Override this method if you wish to support dropping and add logic to properly handle the dragged data.

The target item (which can be null if over the whitespace area below the last item in the control) and a TreeItemDropArea based on hit testing over the target item are passed in as arguments. If dropping is to be supported and a drop indicator should be displayed, the TreeItemDropArea returned can be the same value, or coerced to another value. The resulting value will affect the displayed drop indicator. Possible values are None (no indicator), Before (small bar at the top of the target item), On (a highlight under the item), or After (small bar at the bottom of the target item). Some implementations of drag/drop may wish to keep the drop indicators simple by only returning None or On (coercing Before and After to On).

The DragEventArgs.AcceptedOperation property should also be set appropriately.

Finally if a drop does occur, the TreeListBoxItemAdapter.OnDropAsync method (via TreeListBox.ItemAdapter) is called and requests that appropriate updates are made to the supplied DragEventArgs.

The default implementation of this method flags that no drop occurred and takes no further action. Override this method if you wish to support dropping and add logic to properly handle the dragged data.

Here again, the target item (which can be null if over the whitespace area below the last item in the control) and a TreeItemDropArea based on hit testing over the target item are passed in as arguments. An override of this method takes appropriate action to update tree items. This could involve moving items, copying items, inserting new items, etc.

Note Note
A full sample of drag and drop functionality is included in the product QuickStarts. It contains fairly extensive logic and should be referred to for better understanding of how drag and drop works.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Searching

Tree Control Features
Text Searching

Text searching allows the end user to start typing text and for a visible (all ancestor items expanded, but not necessarily scrolled into view) item that starts with the typed text to be focused and scrolled into view.

This topic contains these sections:

  • Runtime Functionality
  • Providing Search Text

Runtime Functionality

When text searching is supported, any unhandled text input that bubbles up to item's container will be used for text searching purposes. As a character is typed, the character is added to a prefix string that is stored internally. Then the active item, the one with focus, is examined and its search text is retrieved (see a section below on how to provide search text). A case-insensitive check is made to see if the retrieved item search text starts with the currently typed prefix. If the item search text does start with the prefix, the item is focused and searching quits. Otherwise, the next visible item is examined with the same process. Item examination continues and wraps to the top of the control as needed to find a match.

As more characters are typed, they are appended to the prefix string. That is unless there was a pause in between typing. In that case, the character starts a new prefix string.

A great feature built into text searching is that if you continue pressing the last character that was typed and no matches that were made using the old prefix with the new character appended, it will reuse the old prefix and look for another match without the newly-typed character. Picture a scenario where there are three items (Foo 1, Foo 2, and Foo 3). Typing 'f' focuses the first item. Typing 'o' keeps focus on the first item. Typing 'o' again keeps focus on the first item since everything matches thus far. Typing 'o' another time doesn't match "fooo" with any items in the control, so a second search is made with the previous prefix ("foo") and Foo 2 is focused. Similarly, typing 'o' another time would focus Foo 3.

Providing Search Text

Text search only works if the control knows what search text applies to each visible item. Search text is provided to the control by calls to the TreeListBoxItemAdapter.GetSearchText method (via TreeListBox.ItemAdapter).

A Binding can be set in XAML to the TreeListBoxItemAdapter.SearchTextBinding property to tell how an item should retrieve search text. The GetSearchText method will use that binding if it is supplied, and will otherwise return null. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override the GetSearchText method instead with custom logic to retrieve the appropriate value.

This example code shows how to override the method for a custom item type TreeNodeModel. This is not only the most performant way of providing a result, but also supports returning different results for different item types or based on item state.

C#
VB
Copy
​public override string GetSearchText(object item) {
    var model = item as TreeNodeModel;
    return (model != null ? model.Name: null);
}
​Public Overrides Function GetSearchText(ByVal item As Object) As String
    Dim model = TryCast(item, TreeNodeModel)
    Return (If(model IsNot Nothing, model.Name, Nothing))
End Function

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Filtering

Tree Control Features
Filtering

Filtering allows a tree to be narrowed down to only display items that match filter criteria. A powerful data filtering mechanism is provided that uses string, boolean, and predicate-based logic to filter items. The underlaying data model is not altered in any way, only the view is.

This topic contains these sections:

  • Using Filters
  • Predicate Filters
  • String Filters
  • Boolean Filters
  • Filter Groups
  • Custom Filters
  • Auto-Expanding to Filtered Items

Using Filters

To activate filtering functionality, set the TreeListBox.IsFilterActive property to true. It is false by default.

When filtering is active, the control will iterate over every item in the tree and will call the TreeListBoxItemAdapter.Filter method for each item. That method should return a DataFilterResult:

  • Included - The item passed all filter conditions and is included in the filter. Tree descendants will also be examined by the filter.
  • IncludedByDescendants - The item did not pass all filter conditions and will only be included in the filter if one or more of its tree descendants are included. Tree descendants will also be examined by the filter.
  • Excluded - The item did not pass all filter conditions and will not be included in the filter. None of its tree descendants will be examined by the filter.

Note Note
When a filter includes an item, that item will be visible in the tree. When a filter excludes an item, that item will not be visible in the tree.

The Filter method is virtual and at a low level can be overridden to use custom filter logic.

However, this generally is not necessary since there is a higher level filtering mechanism that is provided via the TreeListBox.DataFilter property. By default, the TreeListBoxItemAdapter.Filter method will get the IDataFilter instance (if set) in the DataFilter property and will call its IDataFilter.Filter method to get the filter result. If no IDataFilter is available, the method will fall back to returning DataFilterResult.Included.

The main benefit of this approach is that there are several built-in IDataFilter implementations that can be plugged into the DataFilter property. Custom implementations can be made as well. This keeps the filtering mechanism very modular.

Another benefit of using IDataFilter objects for filtering is that each has an IsEnabled property that can be set to false to prevent that filter from being applied. This is especially useful when building complex filter groups, as described below. You still want to make sure the TreeListBox.IsFilterActive property is set back to false when no filtering is needed, since that will improve performance.

Tip Tip
It is most efficient to set and configure the DataFilter property prior to setting the TreeListBox.IsFilterActive property to true.

Predicate Filters

The PredicateFilter class, a built-in implementation of IDataFilter, uses a custom Predicate<object> to return filter results.

Simply set the Predicate property to the predicate to use. If the predicate returns true, DataFilterResult.Included will be returned by the filter. Otherwise, DataFilterResult.IncludedByDescendants will be returned.

This example code shows how to set a predicate filter that assumes each item is a TreeNodeModel (your custom model type) and checks to see if the Name starts with "Foo".

C#
VB
Copy
​treeListBox.DataFilter = new PredicateFilter(i => ((TreeNodeModel)i).Name.StartsWith("Foo"));
​treeListBox.DataFilter = New PredicateFilter(Function(i) (CType(i, TreeNodeModel)).Name.StartsWith("Foo"))

String Filters

The abstract StringFilterBase class, a built-in implementation of IDataFilter, can be used to easily construct a filter that is based on a string value comparison. Regular expressions are even supported. It has several properties that factor into the comparison.

Target Value

The Value property needs to be set to the operand value used by the filter. The is the target value against which the comparison will be made.

Operation

The Operation property is set to a StringFilterOperation value that determines the kind of comparison operation to perform. The default value is Contains, but all of these operations are available: Contains, NotContains, StartsWith, NotStartsWith, EndsWith, NotEndsWith, Equals, NotEquals, RegexMatch, and NotRegexMatch.

Culture and Case Sensitivity

The StringComparison property is set to a StringComparison value that determines how to compare the strings in terms of culture and case sensitivity. The default value is CurrentCultureIgnoreCase, but can be set to other options if you would prefer ordinal or case sensitive comparisons.

Regular Expressions

When Operation is set to RegexMatch or NotRegexMatch, regular expression matching will be used. The regular expression should be specified in the Value property. If a StringComparison option is used that ignores case, then the regular expression matching will be told to ignore case as well.

If any other RegexOptions (matching options) need to be set, they can be assigned to the RegexOptions property.

Implementing a String Filter

This example code shows how to create a TreeNodeModelStringFilter class that knows how to examine a TreeNodeModel (your custom model type) and check its Name property.

C#
VB
Copy
​public class TreeNodeModelStringFilter : StringFilterBase {
    public override bool Filter(object item) {
        return (this.FilterByString(((TreeNodeModel)item).Name) ? DataFilterResult.Included : DataFilterResult.IncludedByDescendants);
    }
}
​Public Class TreeNodeModelStringFilter
    Inherits StringFilterBase
    Public Overrides Function Filter(ByVal item As Object) As Boolean
        Return (If(Me.FilterByString((CType(item, TreeNodeModel)).Name), DataFilterResult.Included, DataFilterResult.IncludedByDescendants))
    End Function
End Class

Once the string filter has been created, it can be implemented in XAML like this to filter all models whose Name starts with Foo:

XAML
Copy
​<grids:TreeListBox ...>
    <grids:TreeListBox.DataFilter>
        <local:TreeNodeModelStringFilter x:Name="stringFilter" Operation="StartsWith" Value="Foo" />
    </grids:TreeListBox.DataFilter>
    ...
</grids:TreeListBox>

The filter's value or other properties can be dynamically updated to refresh the filter results. For instance, with string filters it is common for a TextBox in the user interface to update a string filter's value as text is typed.

Boolean Filters

The abstract BooleanFilterBase class, a built-in implementation of IDataFilter, can be used to easily construct a filter that is based on a boolean value comparison. It has several properties that factor into the comparison.

Target Value

The Value property needs to be set to the operand value used by the filter. The is the target value against which the comparison will be made.

Operation

The Operation property is set to a BooleanFilterOperation value that determines the kind of comparison operation to perform. The default value is Equals, but all of these operations are available: Equals, NotEquals, And, Or and Xor.

Implementing a Boolean Filter

This example code shows how to create a TreeNodeModelBooleanFilter class that knows how to examine a TreeNodeModel (your custom model type) and check its IsActive property.

C#
VB
Copy
​public class TreeNodeModelBooleanFilter : BooleanFilterBase {
    public override bool Filter(object item) {
        return (this.FilterByBoolean(((TreeNodeModel)item).IsActive) ? DataFilterResult.Included : DataFilterResult.IncludedByDescendants);
    }
}
​Public Class TreeNodeModelBooleanFilter
    Inherits BooleanFilterBase
    Public Overrides Function Filter(ByVal item As Object) As Boolean
        Return (If(Me.FilterByBoolean((CType(item, TreeNodeModel)).IsActive), DataFilterResult.Included, DataFilterResult.IncludedByDescendants))
    End Function
End Class

Once the boolean filter has been created, it can be implemented in XAML like this to filter all models whose IsActive property is true:

XAML
Copy
​<grids:TreeListBox ...>
    <grids:TreeListBox.DataFilter>
        <local:TreeNodeModelBooleanFilter x:Name="booleanFilter" Operation="Equals" Value="True" />
    </grids:TreeListBox.DataFilter>
    ...
</grids:TreeListBox>

The filter's value or other properties can be dynamically updated to refresh the filter results. For instance, with boolean filters it is common for a CheckBox in the user interface to update a boolean filter's value as its checked state changes.

Filter Groups

The DataFilterGroup class, a built-in implementation of IDataFilter, can be used to perform a logical AND or OR operation on any number of child filters.

Note Note
A filter group can contain other filters or filter groups. Combine that with the ability for filters to be individually enabled or disabled (via IDataFilter.IsEnabled) and complex filter tree logic can be easily implemented.

Child Filters

The Children property is the collection of child filters to use.

Operation

The Operation property is set to a DataFilterGroupOperation value that determines the kind of comparison operation to perform. The default value is And (all child filters must pass), but Or (any child filter must pass) can be chosen as well.

Implementing a Filter Group

This example code shows how to use the filters described above in a filter group, where both must pass for an item to be included:

XAML
Copy
​<grids:TreeListBox ...>
    <grids:TreeListBox.DataFilter>
        <shared:DataFilterGroup>
            <local:TreeNodeModelStringFilter x:Name="stringFilter" Operation="StartsWith" Value="Foo" />
            <local:TreeNodeModelBooleanFilter x:Name="booleanFilter" Operation="Equals" Value="True" />
        </shared:DataFilterGroup>
    </grids:TreeListBox.DataFilter>
    ...
</grids:TreeListBox>

Custom Filters

While the built-in classes described above will suit most needs, custom IDataFilter implementations can be written as well. The easiest way to do this is to make a class that inherits DataFilterBase, as that class already implements most of the details of the IDataFilter interface. Your only task then is to implement the Filter method with custom logic.

Your custom filter can then be set to the TreeListBox.DataFilter property or can be used in a DataFilterGroup.

It is also possible to inherit the other base classes like StringFilterBase or BooleanFilterBase and augment them.

Auto-Expanding to Filtered Items

The TreeListBox.AutoExpandItemsOnFilter property can be set to true to ensure that when filtering occurs and an item is included in the filter, all of its ancestor items will be expanded automatically. The propertly's default value is false, meaning don't enable this behavior.

This feature is useful when you want to ensure that filtered items are always fully visible immediately and can't be hidden by collapsed ancestor items.

When this feature is enabled, as soon as filtering is deactivated, the expansion state of the items is restored to what it was before filtering activated.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Virtualization

Tree Control Features
Virtualization

The tree controls are lightning-fast because they have UI virtualization on by default. Data virtualization is an additional option for scenarios where virtualized child collections are in use.

This topic contains these sections:

  • UI Virtualization
  • Data Virtualization

UI Virtualization

UI virtualization means that if many items are loaded in the control, containers are only generated for items that are visible or are close to being visible. Without UI virtualization enabled, containers would be generated for all items in the control, regardless of whether they are (or are close to being) visible, and that can severely affect UI performance.

The tree controls have "Recycling" UI virtualization active by default, and nothing needs to be done to configure it. As the control is scrolled, containers for items that are scrolled out of view may be recycled and reused for other items that are being scrolled into view. This recycling helps performance because it prevents UI elements from being created new for every container that is needed.

Recycling Virtualization Mode Issues Recycling Virtualization Mode Issues

If you see issues with bound data showing up on incorrect containers or styles not being applied properly, especially while scrolling, please see the Troubleshooting topic. That topic has a section that describes this scenario in more detail and talks about how to change the virtualization mode back to "Standard", which should solve the issue. "Standard" virtualization is a little slower than "Recycling" virtualization, but is still fast.

The problems described above mostly tend to happen in scenarios where you are switching styles/templates for tree control items on the fly with a selector, based on data. Most tree control usage scenarios don't use selectors, and thus shouldn't run into the problem.

Data Virtualization

Normally, when the control goes to query for an item's children, it will do a for-each through all the items that are indicated as the children's IEnumerable. In some special scenarios where a virtualizing list is used as the children collection, and that virtualizing list should only do paged lookups of data based on what is needed for display, then data virtualization can be enabled by setting the TreeListBox.IsDataVirtualizationEnabled property to true. Otherwise, just leave the property its default of false.

When data virtualization is enabled and an item's children are being queried, the control will first see if the children's IEnumerable is an IList. If so, it will enter data virtualization mode and will populate a list of ITreeItemVirtualPlaceholder objects, one for each child in the source list. This process does not actually access any items in the source list. It only checks the Count of the source list. ITreeItemVirtualPlaceholder is a simple interface to represent a slot in a virtualized list, and just has an Index property.

The TreeListBoxItemAdapter.CreateVirtualPlaceholder method (via TreeListBox.ItemAdapter) is called during the process of creating ITreeItemVirtualPlaceholder objects. The method is passed the parent item and the index of the child that needs a virtual placeholder. Normally this method doesn't need to be overridden since it will return a default placeholder, but you can customize it to return a custom placeholder if you wish.

When a container is generated for an item that is a virtual placeholder, the control will access the parent item's children list and retrieve the child at the index specified by ITreeItemVirtualPlaceholder.Index via its indexer. This is the point at which a paged lookup in the virtualized list can occur, so that a page of items around the specified item can be loaded if needed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Keyboard Shortcuts

Tree Control Features
Keyboard Shortcuts

Many keyboard shortcuts are supported that provide access to expand/collapse, focus/selection, default actions and editing mode.

This topic contains these sections:

  • Expand and Collapse Shortcuts
  • Focus and Selection Keyboard Shortcuts
  • Other Keyboard Shortcuts

Expand and Collapse Shortcuts

Key | Description
Add | Expands the active item.
Divide | Collapses the active item and all of its descendants.
Ctrl+Divide | Collapses all items.
Left | Contracts the active item (if it is expanded with children) or focuses the parent item.
Multiply | Expands the active item and all of its descendants.
Ctrl+Multiply | Expands all items.
Right | Expands the active item (if it is collapsed) or focuses the first child item.
Subtract | Collapses the active item.

Focus and Selection Keyboard Shortcuts

Key | Description
Ctrl+A | Selects all items when in a multi-selection mode.
Down | Focuses the next visible item.
Ctrl+Down | Focuses the next visible item, without selecting it.
End | Focuses the last visible item.
Ctrl+End | Focuses the last visible item, without selecting it.
Home | Focuses the first visible item.
Ctrl+Home | Focuses the first visible item, without selecting it.
PgDn | Focuses the next appropriate item from a page down request.
Ctrl+PgDn | Focuses the next appropriate item from a page down request, without selecting it.
PgUp | Focuses the next appropriate item from a page up request.
Ctrl+PgUp | Focuses the next appropriate item from a page up request, without selecting it.
Space | Selects the active item.
Ctrl+Space | Toggles selection on the active item.
Shift+Space | Extends the selection to the active item when in extended selection mode.
Up | Focuses the previous visible item.
Ctrl+Up | Focuses the previous visible item, without selecting it.

Other Keyboard Shortcuts

Key | Description
Enter | Performs the default action for the active item.
F2 | Starts editing the active item, if it supports editing.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

Grids Reference
Troubleshooting

This topic contains troubleshooting data specific to the Grids product.

Note Note
For some more troubleshooting information that relates both to this product as well as other products, please see the more general TroubleShooting topic.

This topic contains these sections:

  • TreeListBox/TreeListView Data Not Binding Correctly

TreeListBox/TreeListView Data Not Binding Correctly

In some usage scenarios (particularly if data is late-bound) the core ItemsControl recycling logic might not be able to properly identify when data items change for a container. This often happens if DataTemplate bindings don't give enough data to indicate a difference between bound data items. Symptoms of this scenario are visible when you see items rendering with incorrect bound data, especially when scrolling, since in that case the item containers aren't rebinding to data or reapplying styles/templates properly while recycling.

When you see odd symptoms like this happening, simply set the VirtualizingPanel.VirtualizationMode="Standard" attached attribute on the root TreeListBox (or derived) control. "Standard" virtualization isn't quite as fast as "Recycling" virtualization but it should solve the problem because it doesn't reuse containers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Micro Charts Reference
Overview

Actipro Micro Charts are a special form of chart that are meant to be used in small spaces, to help visualize quantitative data. Use micro charts to quickly convey data and trends in your custom dashboards, reports, and grids.

Sample sales illustrated using two bar series

Actipro Micro Charts makes it easy to generate charts based on any custom data source. It will automatically calculate the best scales to fit the data into the control, or you can customize the scales as needed. It includes support for aggregation of large data sets to improve performance and readability, highlighting ranges or key data points, and much more.

Several types of charts are supported, which include Area, Bar, Line, Scatter, Win/Loss, and Heat Map. Stacked and 100% stacked variations of area and bar charts are available as well.

Features

Chart Types

  • Area
    • Includes support for spline curves and stepped lines.
    • Highlight values below the baseline using custom styles.
    • Optionally display a line along the series.
    • Optionally display markers to highlight data points.
    • Easily apply alternate marker styles for first, last, high, low, and negative data points.
  • Bar
    • Quickly customize the spacing between the bars to fit your needs.
    • Easily apply alternate bar styles for high, low, and negative data points.
  • Line
    • Includes support for spline curves and stepped lines.
    • Highlight values below the baseline using custom styles.
    • Optionally display markers to highlight data points.
    • Easily apply alternate marker styles for first, last, high, low, and negative data points.
  • Scatter
    • Easily apply alternate marker styles for first, last, high, low, and negative data points.
  • Win/Loss
    • Quickly customize the spacing between the bars to fit your needs.
    • Easily apply alternate bar styles for high, low, and negative data points.
  • Bullet Graph
    • Compare a data value to a target or goal and a future projection.
    • Put data into the context of several qualitative ranges.
  • Box Plot
    • Display the distribution of a set of values.
    • Identify the outliers and extreme values of a data set.
  • Candlestick
    • Visualize price movements over time.
    • Track the status of stocks, currency values, or securities.
  • Heat Map
    • Use color and/or size changing markers to represent data.
  • Segment
    • Visualizes an integer value in relation to a total number.
    • Use on dashboards, infographics, or as progress indicators.
    • Customizable color, size, shape, and layout.
  • Trend Indicator
    • Uses three states to reflect whether a numeric value is higher, the same as, or lower than an origin value.

Data Source Features

  • Supports displaying any numeric and date/time values from custom data sources.
  • Data can be automatically aggregated to reduce the number of data points rendered.

Appearance Features

  • Combine any number of different series into a single chart.
  • Supports stacking multiple series, both normally and using 100% scale.
  • Customizable baseline value, which dictates which values are considered 'negative', and optional display of baseline.
  • Customizable minimum and maximum values of each axis for fixed scales.
  • Add horizontal or vertical ranges, which are used to highlight specific data ranges.
  • Support for a hot-tracking tool tip, which allows the end user to hover over the chart and read the associated value.
  • Easily customize the various brushes used to render charts via palettes and palette selectors.
  • Set the visibility of any series to dictate whether or not it is rendered on the chart.
  • Over 10 built-in palettes.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Micro Charts Reference
Getting Started

It's easy to get started using Micro Charts. Simply follow the steps below to build your first chart.

This topic contains these sections:

  • Add Extension SDK Reference
  • Add the MicroXYChart Control
  • Add a Series
  • Further Study

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Add the MicroXYChart Control

Then find the parent element that will contain the micro chart. This could be a UserControl or any other type of UIElement.

Next, add a MicroXYChart control to the desired parent element. In this sample we will add the MicroXYChart to a UserControl:

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:microcharts="using:ActiproSoftware.UI.Xaml.Controls.MicroCharts"
    >
    <microcharts:MicroXYChart Width="100" Height="18">
    </microcharts:MicroXYChart>
</UserControl>

Add a Series

Now we need to add a series, which renders a single set of data points on the chart. In this sample we will add a MicroAreaSeries series, but the other types are added in a similar manner.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:microcharts="using:ActiproSoftware.UI.Xaml.Controls.MicroCharts"
    >
    <microcharts:MicroXYChart Width="100" Height="18">
        <microcharts:MicroAreaSeries ItemsSource="{Binding}" />
    </microcharts:MicroXYChart>
</UserControl>

Note that this sample assumes that the chart's DataContext is a list of numeric (i.e. Double, Decimal, etc) or DateTime objects. With this configuration, the chart's X values will represent the index value in the list and the chart's Y values will represent the list's actual value at the related list index.

If our list contained custom objects and we wanted to pull the X and Y values from properties on that object, then we would have to specify the property path on the series.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:microcharts="using:ActiproSoftware.UI.Xaml.Controls.MicroCharts"
    >
    <microcharts:MicroXYChart Width="100" Height="18">
        <microcharts:MicroAreaSeries ItemsSource="{Binding}" XPath="MyDateProperty" YPath="MyNumericProperty" />
    </microcharts:MicroXYChart>
</UserControl>

This sample assumes the objects in the list each contain a property named MyDateProperty and MyNumericProperty, which are then used for the associated axis.

Note Note
If a list contains custom data objects but the index of each entry should be used as the X-values, leave out the XPath attribute and just specify the YPath to the data object's property that contains the value to display.

Additional series can be added and they will all be rendered on the same chart using the same X and Y scales.

Further Study

It's very easy to use Micro Charts and there are probably a lot of great features that you aren't aware of.

Run through the feature documentation and also look at the numerous QuickStarts located in the sample project. The documentation is very thorough and the sample project demonstrates almost every feature of Micro Charts.

If you require further assistance after looking through those, please visit our support forum for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Micro Chart Basics

Micro Charts Reference
Micro Chart Basics

This topic discusses some of the basic concepts to know about using micro charts.

This topic contains these sections:

  • Primary vs. Secondary Axis
  • Adding a Series
  • Specifying Items

Primary vs. Secondary Axis

The MicroXYChart control supports two axes, X and Y. The X axis runs horizontally along the control, and the Y axis runs vertically. All series default to rendering horizontally, which means that Y is the primary axis and X is the secondary axis.

Certain series types, such as Bar and Win/Loss, support vertical orientations as well as the default horizontal orientation. With vertically oriented series, X is the primary axis and Y is the secondary axis.

See the Chart Types topic for additional information.

Adding a Series

Each series type is implemented in a separate .NET type. For instance, a Line series is implemented by the MicroLineSeries class.

Add any series you would like to display to the MicroXYChart.Series collection. The chart will automatically scale the X and Y axes to fit the data of each series properly.

See the Chart Types topic for a list of the available chart types.

Specifying Items

Each series is bound to it's own data source, which is indicated by the ItemsSource property. The data source can be a collection of numeric values (i.e. Double, Decimal, Int32, etc), DateTime values, or custom objects.

When the data source is a collection of numeric or DateTime values, then the series' XPath and YPath properties should not be set. The series will automatically use the value from the collection as the data point's primary value (which is typically the Y value) and the index in the data source as the secondary value.

When the data source is a collection of custom objects, then the series' XPath and YPath need to be set appropriately. The index in the data source can be used as the secondary value (which is typically the X value), in which case the associated path property can be left blank. The path primary value must be specified and must indicate the name of a numeric or date/time property on the custom object.

See the Specifying Items topic for additional information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Micro Chart Types
Overview

Actipro Micro Charts includes a number of built-in chart types.

Name | Description
Area | An area chart is a derivative of a line chart. The area between the line and axis is filled in. Markers and lines can optionally be displayed.
Bar | A bar chart displays rectangular bars with lengths proportional to the values they represent.
Line | A line chart render quantitative data as a series of points connected by line segments. Lines can be straight, curved, or stepped. Markers can optionally be displayed.
Scatter | Scatter charts render data points where each point is represented by a marker.
Win/Loss | A win/loss chart is a special kind of bar chart where any positive value renders as a full-height upward bar, any negative value renders as a full-height downward bar, and zero values render as a line in the middle.
Box Plot | A box plot is a chart that displays a list of data in a five number summary shown by the ends of the whiskers, ends of the box, and the median bar.
Bullet Graph | A bullet graph is a special kind of bar chart used to display a single value in a context of one or more related values.
Candlestick | Candlestick charts are used to visualize price movements over time, such as changing stock or currency values.
Heat Map | A heat map is a grid where each cell renders color and/or size differences to reflect data values. The MicroHeatMapPresenter control is the marker used in each heat map cell, and automatically handles the color and/or size rendering for its particular data value representation.
Segment | A segment chart provides a visual representation of an integer value in relation to a total number. Each segment in the chart is rendered as highlighted or unhighlighted. For instance, if the value is 3 of 10, there will be 10 total segments displayed, with the first 3 rendering as highlighted. This sort of chart is great for use on dashboards, and also as an indicator of steps or progress achieved.
Trend Indicator | The trend indicator is a three state control that is intended to reflect whether a numeric value is higher, the same as, or lower than an origin value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Area

Micro Chart Types
Area

An area chart is a derivative of a line chart where the area between the line and axis is filled in.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Line Kind
  • Line
  • Markers

Baseline Value

The area series will pivot it's polygon based on the chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property. The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following examples, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Style Kinds

The negative areas can be rendered using a distinct style and brush to highlight them. This is done using the AreaStyleKinds property, which is used to specify which style kinds should be used. If we explicitly set this to Negative, then we can see the bottom area is rendered using a contrasting brush.

The normal style can be customized using the AreaStyle property, and negative style can be customized using the AreaNegativeStyle property. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Line Kind

The area series supports three kinds of lines specified by the LineKind, which also determines how the area is rendered. By default, the Normal kind of line is used which simply draws a line to connect the data points when determining the area's polygon.

An area series using a normal line kind, zoomed 400%

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An area series using a spline line kind, zoomed 400%

The Step line kind creates a polygon that only uses horizontal and vertical lines to connect the data points, producing a step look.

An area series using a step line kind, zoomed 400%

Line

The area series can render an actual line along the top of the area to distinguish it better. By default the line is not rendered, but it can be shown by setting LineVisibility to a value other than None. The area series has the same configuration properties available as the line series, with regards to line rendering.

See the Line topic for more information on the options available.

Markers

The area series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The area series has the same configuration properties available as the scatter series, with regards to marker rendering.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bar

Micro Chart Types
Bar

A bar chart displays rectangular bars with lengths proportional to the values they represent.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Orientation
  • Bar Spacing

Baseline Value

The bar series will pivot it's bars based on the chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property. The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum. Since our baseline is 0 (the default), the bars are not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the bars will appear to "grow" down instead of up.

Style Kinds

The bar series can render various bars differently, which is specified using the BarStyleKinds property. Supported options include High, Low, Negative, or any combination of those values.

If we include the High and Low flags, then the bars associated with the data points with the highest and lowest value will render using a distinct style/brush.

If we include the Negative flags, then the bar associated with the data points whose value is less than 15 will render using a distinct style/brush.

The normal style can be customized using the BarStyle property, and negative style can be customized using the BarNegativeStyle property. Similarly, the high and low bars can be styled using the BarHighStyle and BarLowStyle, respectively. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Orientation

The bar chart can be oriented horizontally (the default) or vertically by setting the Orientation property. When switching orientation, the values of the XPath and YPath properties may need to be swapped.

Bar Spacing

The BarSpacing property can be used to configure the space between the bars. The default value is 1px, which indicates there should be a 1 pixel space between the bars.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line

Micro Chart Types
Line

A line chart renders quantitative data as a series of points connected by line segments, which can be straight, curved, or stepped.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Line Kind
  • Markers

Baseline Value

The chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property, only determines which portion of the line is considered "negative" when using various style kinds. The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative". Visually nothing will change until the Negative flag is included in the LineStyleKinds property.

Style Kinds

The negative lines can be rendered using a distinct style and brush to highlight them. This is done using the LineStyleKinds property, which is used to specify which style kinds should be used. If we explicitly set this to Negative, then we can see the bottom line is rendered using a contrasting brush.

The normal style can be customized using the LineStyle property, and negative style can be customized using the LineNegativeStyle property. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Line Kind

The line series supports three kinds of lines specified by the LineKind. By default, the Normal kind of line is used which simply draws a line to connect the data points.

An line series using a normal line kind, zoomed 400%

The Spline line kind builds a canonical spline that runs through the data points, producing a smooth line.

An line series using a spline line kind, zoomed 400%

The Step line kind creates a line that only uses horizontal and vertical lines to connect the data points, producing a step look.

An line series using a step line kind, zoomed 400%

Markers

The line series can render a markers at each data point to highlight the actual location. By default the markers is not rendered, but they can be shown by setting MarkerVisibility to a value other than None. The line series has the same configuration properties available as the scatter series, with regards to marker rendering.

See the Scatter topic for more information on the options available.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scatter

Micro Chart Types
Scatter

Scatter charts render data points where each point is represented by a marker.

This topic contains these sections:

  • Baseline and Style Kinds
  • Marker Shape Kinds

Baseline and Style Kinds

The scatter series can render various markers differently, which is specified using the MarkerStyleKinds property. Supported options include First, Last, High, Low, Negative, or any combination of those values.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum.

If we include the First and Last flags, then the first and last markers will render slightly different from the other markers.

If we include the High and Low flags, then the markers associated with the data points with the highest and lowest value will render using a distinct style/brush.

The chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property, can be used to indicate which markers are considered "negative". If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative". The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue. If we include the Negative flags, then the markers associated with the data points whose value is less than 15 will render using a distinct style/brush.

The normal style can be customized using the MarkerStyle property, and negative style can be customized using the MarkerNegativeStyle property. Similarly, the first, last, high, and low markers can be styled using the MarkerFirstStyle, MarkerLastStyle, MarkerHighStyle, and MarkerLowStyle, respectively. The associated Style should target the MicroChartMarker type, which includes properties such as Fill, Stroke, StrokeThickness, and ShapeKind.

Marker Shape Kinds

Markers support several built in shape kinds, which include:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Win/Loss

Micro Chart Types
Win/Loss

A win/loss chart is a special kind of bar chart where any positive value renders as a full-height upward bar, any negative value renders as a full-height downward bar, and zero values render as a line in the middle.

This topic contains these sections:

  • Baseline Value
  • Style Kinds
  • Orientation
  • Bar Spacing

Baseline Value

The win/loss series uses the chart's baseline value, as specified by the MicroXYChart.AxisBaselineValue property, to determine which values are positive (i.e. above the baseline) and negative (i.e. below the baseline). The default baseline for numeric values is 0, and for date/time values it is DateTime.MinValue.

In the following example, the data rendered by the chart uses the index postion along the X-axis and the fixed values 10, 25, 10, 20, 5, 20, 10 for the Y-axis. The first image shows the series using 5 as the minimum value along the Y-axis, and 25 for the maximum. Since our baseline is 0 (the default) all the values are considered positive.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the bars will appear to "grow" down instead of up.

Style Kinds

The win/loss series can render various bars differently, which is specified using the BarStyleKinds property. Supported options include High, Low, Negative, or any combination of those values.

If we include the High and Low flags, then the bars associated with the data points with the highest and lowest value will render using a distinct style/brush.

If we include the Negative flags, then the bar associated with the data points whose value is less than 15 will render using a distinct style/brush.

The normal style can be customized using the BarStyle property, and negative style can be customized using the BarNegativeStyle property. Similarly, the high and low bars can be styled using the BarHighStyle and BarLowStyle, respectively. The associated Style should target the Shape type, which includes properties such as Fill, Stroke, and StrokeThickness.

Orientation

The win/loss chart can be oriented horizontally (the default) or vertically by setting the Orientation property. When switching orientation, the values of the XPath and YPath properties may need to be swapped.

Bar Spacing

The BarSpacing property can be used to configure the space between the bars. The default value is 1px, which indicates there should be a 1 pixel space between the bars.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Multiple and Stacked Series

Micro Chart Types
Multiple and Stacked Series

The chart control supports multiple series which can be optionally stacked on top of the previous series.

This topic contains these sections:

  • Multiple Series
  • Normal Stacking
  • Percentage Stacking

Multiple Series

Any number of series can be added to the chart, which will simply render one on top of each (in z-order) Simply add the series to the MicroXYChart.Series collection that you would like to be rendered.

In this example, we display a bar and line series in the same chart:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" YAxisMinimum="0">
    <microcharts:MicroBarSeries ItemsSource="4;11;3;1;8;9;14" />
    <microcharts:MicroLineSeries ItemsSource="7;3;5;1;1;3;10" />
</microcharts:MicroXYChart>

This results in the following chart:

The chart will automatically align the multiple series along the secondary axis (X in this example). So, if the series have data with disparate values, then it will automatically adjust to fit the data.

In this example, we add additional data points to the line series:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" YAxisMinimum="0">
    <microcharts:MicroBarSeries ItemsSource="4;11;3;1;8;9;14" />
    <microcharts:MicroLineSeries ItemsSource="7;3;5;1;1;3;10;5;2;8;1;14" />
</microcharts:MicroXYChart>

This results in the following chart, which has extended the line series beyond the bar series since it has more data points:

Normal Stacking

Two or more series can be stacked one on top of the other to convey cumlative values to the end user.

By setting StackKind on the series to Normal, the values of each series will be added to the previous stacked series.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" >
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data1}" StackKind="Normal" />
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data2}" StackKind="Normal" />
</microcharts:MicroXYChart>

Percentage Stacking

Two or more area series can be stacked one on top of the other to convey proportional values to the end user. In this mode, the series render to fill the chart height. At any given location, the height of each rendered series indicates its value percentage relative to the total.

By setting StackKind on the series to Percentage, the values of each series will be added to the previous stacked series and a percentage of the total value will be used.

In this sample the second series will be stacked on top of the first series.

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" >
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data1}" StackKind="Percentage" />
    <microcharts:MicroAreaSeries ItemsSource="{Binding Data2}" StackKind="Percentage" />
</microcharts:MicroXYChart>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Box Plot

Micro Chart Types
Box Plot

A box plot is a chart that displays a set of data through five major values: the lower whisker value, the lower quartile value, the median, the upper quartile, and the upper whisker value. The median is the value found directly in the center of the data when it is sorted, meaning half of the data lies above it, and half lies below it. The median is displayed as a perpendicular line to the chart. The lower quartile is the median of the lower half of data, resulting in a quarter of the data being less than it, and three-quarters being greater. The upper quartile is the median of the higher half of data, resulting in three-quarters of the data being less than it, and a quarter being greater. The upper and lower quartiles define the edges of a box drawn on the chart, resulting in the middle half of the data being contained within the box. The difference between the upper and lower quartiles is known as the Interquartile Range (IQR). The product of the IQR and the IQR multiplier (normally a value of 1.5) is then subtracted from the lower quartile value to get the lower whisker value and added to the upper quartile value to get the upper whisker value. The whiskers are displayed as "T" bars that extend from the edges of the box to their respective values.

The spacing between the different parts of the box plot help indicate the degree of spread in the data. Box Plots are particularly useful for displaying distributions of a group in a compact way. This is good for creating charts that compare a group of data such as the performance of salespeople, heights of a group of people, temperatures along a latitude, and more.

This topic contains these sections:

  • Data Display
  • Graph Minimum and Maximum
  • Orientation
  • Appearance Customization
  • Tool Tips

Data Display

The MicroBoxPlot control accepts a collection of data in its Values property, and then from that data it calculates the median value, which can optionally be displayed, the upper and lower quartile values (the 75th and 25th percentiles respectively), the upper and lower whisker values, and the minimum and maximum values. Outliers, values that fall outside the range between the whisker values, can be optionally displayed. If outliers are not displayed they will not affect the minimum and maximum values. The mean, or average, value can also be displayed optionally. Below is an example of a MicroBoxPlot with all parts displayed and labeled.

Note that the box's ends are defined by the upper and lower quartile values. The width of the box, equal to the difference between the upper and lower quartiles, is known as the Interquartile Range (IQR). The IQR is used to calculate the whisker values. The whiskers extend to the furthest data point from the edges of the box within a distance equal to the IQR multiplied by the IqrMultiplier, which defaults to 1.5. Not that if the IqrMultiplier is set to a number less than or equal to zero no whiskers will be displayed. An example of populating the collection of values is shown below.

XAML
Copy
​<microcharts:MicroBoxPlot Values="1; 2; 3; 4; 5; 6" />

Graph Minimum and Maximum

The minimum and maximum of the chart are auto-calculated if they are not given a value. The minimum and maximum are set to the smallest and largest displayed values respectively. The minimum and maximum can also be set to specific values, note that any data values outside of the set range will be clipped and not displayed.

Setting the minimum and maximum chart values can be useful for putting group of box plots into the same context. This allows all the charts to display the same range and makes it easy to compare several data sets. The box plots could then be placed in a vertical column to produce a comprehensive report.

Orientation

The MicroBoxPlot.Orientation property is Horizontal by default, but can be set to Vertical as well. Setting the chart's orientation to vertical effectively rotates the control 90 degrees counter-clockwise, so the minimum value is on the bottom and the maximum is at the top of the control.

Appearance Customization

Every part of the MicroBoxPlot has a style that can be customized to change its color, size, and visual features. Below is a list of the different parts with what member can be accessed to change their style. Note that the target type of the styles should be Shape.

Part Name | Member Name
Box | MicroBoxPlot.BoxStyle
Mean Bar | MicroBoxPlot.MeanStyle
Median bar | MicroBoxPlot.MedianStyle
Outliers | MicroBoxPlot.OutlierStyle
Whiskers | MicroBoxPlot.WhiskerStyle

Styles can be used to set the brushes on the Fill and/or Stroke properties of the parts to change their color, and the StrokeThickness property can be set on the whiskers, mean, and median bars to alter their size. In addition, there is a WhiskerAscent property that controls the size of the whiskers' end lines. The ascent property takes a Unit value that is generally a pixel or percentage type. Note that setting the WhiskerAscent to zero will result in no end lines being rendered.

Since the outliers are MicroChartMarkers their ShapeKind value can be set to any of the following shapes:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
RoundedRectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

XAML
Copy
​<microcharts:MicroBoxPlot Values="1; 2; 3; 4; 5; 6">
    <microcharts:MicroBoxPlot.Style>
        <Style TargetType="microcharts:MicroBoxPlot" BasedOn="{StaticResource MicroBoxPlotStyleBase}">
            <Setter Property="BoxStyle">
                <Setter.Value>
                    <Style TargetType="Shape">
                        <Setter Property="Fill" Value="#3b8525" />
                    </Style>
                </Setter.Value>
            </Setter>
            <Setter Property="MedianStyle">
                <Setter.Value>
                    <Style TargetType="Shape">
                        <Setter Property="Stroke" Value="#ffffff" />
                        <Setter Property="StrokeThickness" Value="3" />
                    </Style>
                </Setter.Value>
            </Setter>
            <Setter Property="WhiskerStyle">
                <Setter.Value>
                    <Style TargetType="Shape">
                        <Setter Property="Stroke" Value="#3b8525" />
                        <Setter Property="StrokeThickness" Value="3" />
                    </Style>
                </Setter.Value>
            </Setter>
        </Style>
    </microcharts:MicroBoxPlot.Style>
</microcharts:MicroBoxPlot>

The above example shows how to set values for the different parts' styles and customize the size values.

Tool Tips

MicroBoxPlots support tooltips that can be custom formatted and can display the values of the quartiles, whiskers and mean, as well as the minimum and maximum.

Format Parameter | Description
{0} | The minimum value.
{1} | The lower whisker value.
{2} | The lower quartile value (Q1).
{3} | The median value (Q2).
{4} | The upper quartile value (Q3).
{5} | The upper whisker value.
{6} | The maximum value.
{7} | The mean value.
{8} | The number of values.

This example displays the upper and lower quartile values as well as the mean value of the data. Note how numeric formatting is used on the values.

XAML
Copy
​<microcharts:MicroBoxPlot ... LegendStringFormat="Lower Quartile: {2:F1}, Upper Quartile: {4:F1}, Average: {7:F1}">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Bullet Graph

Micro Chart Types
Bullet Graph

Bullet graphs are used to simultaneously display and evaluate data. They show a single data value with contextual information to give the value further meaning. The actual value is represented by a featured measure bar, which is juxtaposed with a comparative value displayed as a bar perpendicular to it. The featured and comparative values are then placed in the context of specific ranges such as poor, average, and excellent.

Bullet graphs were originally designed to replace meters and gauges in a more compact way while still being informative. Bullet graphs are excellent to use as gauges or meters; however, they can also be used to display many other types of data very effectively. They are most suited to display a value that has other related values to be compared to, such as last year's mark, a goal or target, or a projected future value. Examples could include annual income or expenses data, sales data, and performance ratings data.

This topic contains these sections:

  • Measure Display
  • Graphing Minimum and Maximum
  • Orientation
  • Appearance Customization
  • Tooltips

Measure Display

The MicroBulletGraph is capable of displaying a featured value, a comparative value, a projected value, and any number of ranges. The only required value is the featured value, all others default to NaN, in which case they will not be displayed. If all parts are present the order they are rendered from top to bottom is: featured, comparative, projected, then the ranges in order from the smallest value to the largest value.

By default the featured and projected bars take up a third of the control and extend from zero to a length proportional to their respective values. The comparative bar is displayed perpendicular to the featured bar, with a default width of two and fills two thirds of the control. Ranges fill the entire control and extend to a length proportional to their value, any ranges that aren't given a value will fill to the end of the control. The MicroBulletGraph.QualitativeRanges member is used to set and access the collection of MicroQualitativeRanges displayed by the chart. An example of populating the collection is shown below.

XAML
Copy
​<bulletGraph:MicroBulletGraph Maximum="800" FeaturedMeasureValue="450" FeaturedMeasureBrush="Black">
    <bulletGraph:MicroBulletGraph.QualitativeRanges>
        <bulletGraph:MicroQualitativeRange Value="200" Background="DarkSlateGray"/>
        <bulletGraph:MicroQualitativeRange Value="350" Background="DimGray" />
        <bulletGraph:MicroQualitativeRange Value="500" Background="Gray" />
        <bulletGraph:MicroQualitativeRange Value="650" Background="DarkGray" />
        <bulletGraph:MicroQualitativeRange Background="LightGray" />
    </bulletGraph:MicroBulletGraph.QualitativeRanges>
</bulletGraph:MicroBulletGraph>

Graphing Minimum and Maximum

The Minimum and Maximum of the graph are auto-calculated if they are not given a value. The minimum is set to zero, or the smallest part value less than zero if one exists. The maximum is set to the largest part value. The minimum and maximum can also be set, in which case the displayed values will be coerced into the range so all specified values will be displayed.

Ellipses Display

If the Minimum is set to a value greater than zero, the featured value, and projected value if there is one, will be displayed as an ellipse centered on the value. The image below shows an example with the minimum set to one.

Negative Values

Negative values are supported by the MicroBulletGraph control. If the featured and/or projected bar is given a negative value they will start at zero and extend in the opposite direction to a length proportional to their value.

Orientation

The MicroBulletGraph.Orientation property is Horizontal by default, but can be set to Vertical as well. Setting the chart's orientation to vertical effectively rotates the control 90 degrees counter-clockwise, so the minimum value is on the bottom and the maximum is at the top of the control.

Appearance Customization

Brushes

Every part of the graph has a brush that can be customized to display any color or gradient desired. To specify the brush used on a range set its background property. Below is a list of the different parts and what member can be accessed to change their brush.

Part Name | Member Name
Featured bar/ellipse | MicroBulletGraph.FeaturedMeasureBrush
Projected bar/ellipse | MicroBulletGraph.ProjectedMeasureBrush
Comparative bar | MicroBulletGraph.ComparativeMeasureBrush
Range(s) | MicroQualitativeRange .Background

Sizes

The size of the featured, projected, and comparative bars can be customized using the FeaturedMeasureAscent, ComparativeMeasureAscent, and ComparativeMeasureExtent properties. The ascent properties are Unit values that specify the amount of the control that the part should fill (height for horizontal orientation and width for vertical). The FeaturedMeasureAscent property changes both the featured and projected bars and is commonly set as a percentage, but can also be a pixel value. The ComparativeMeasureExtent property represents the thickness, generally in pixels, of the comparative bar (width for horizontal orientation and height for vertical).

XAML
Copy
​<microcharts:MicroBulletGraph FeaturedMeasureValue="72" FeaturedMeasureBrush="White"
            ProjectedMeasureValue="80" ProjectedMeasureBrush="LightGray" ComparativeMeasureValue="60"
            Maximum="100" ComparativeMeasureBrush="White" FeaturedMeasureAscent="30%"
            ComparativeMeasureAscent="60%" ComparativeMeasureExtent="5">
    <microcharts:MicroBulletGraph.QualitativeRanges>
        <microcharts:MicroQualitativeRange Value="33" Background="#505f74" />
        <microcharts:MicroQualitativeRange Value="66" Background="#758498" />
        <microcharts:MicroQualitativeRange Background="#a9b2be" />
    </microcharts:MicroBulletGraph.QualitativeRanges>
</microcharts:MicroBulletGraph>

The above example shows how to set values for the different part brushes and customize the size values.

Tooltips

MicroBulletGraphs support tooltips that can be custom formatted and can display the values of the bars as well as of the ranges and the minimum and maximum.

Format Parameter | Description
{0} | The featured measure value.
{1} | The projected measure value.
{2} | The comparative measure value.
{3} | The minimum value.
{4} | The maximum value.
{5} | The value of the first qualitative range.
{6} | The value of the second qualitative range.
{7} | The value of the third qualitative range.
{8} | The value of the fourth qualitative range.
{9} | The value of the fifth qualitative range.

This example displays the featured value as well as the ranges from the minimum to the end of the third range. Note how numeric formatting is used on the featured value.

XAML
Copy
​<microcharts:MicroBulletGraph ... LegendStringFormat="Rating:{0:F2} (Poor:{3}-{5} Satisfactory:{5}-{6} Excellent:{6}-{7})">

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Candlestick

Micro Chart Types
Candlestick

Candlestick charts are designed to visualize a change in value over an interval of time, and as such are excellent at showing price movements in stocks, currency values, or securities such as bonds. While a single candlestick can display the changes over one time interval, several can be placed side by side to show a trend over a longer time period, or to provide comparisons.

A candlestick chart displays an opening, closing, highest, and lowest price value for a time interval. The chart consists of a box with two lines, known as wicks, that extend out of either end of it. The wicks extend to the highest and lowest values reached during the interval. The edges of the box are defined by the opening and closing values. If the closing value is less than the opening value then the box is shaded and filled in with the color selected to display loss. If the closing value is greater than the opening value than the box remains unshaded, or is optionally filled in with an alternate color selected to display gain.

The MicroCandlestickChart control accepts values for the opening, closing, high, and low values. The control will determine if there is a gain or loss based on the opening and closing values and display the parts using the appropriate style. Note that if the high value is equal to either the opening or closing values, the upper wick will not be displayed; similarly the lower wick will not be displayed if the low value is equal to either the opening or closing values. An example of giving the parts values is shown below.

XAML
Copy
​<microcharts:MicroCandlestickChart HighValue="60" LowValue="5" OpenValue="15" CloseValue="33" />

This topic contains these sections:

  • Graph Minimum and Maximum
  • Orientation
  • Appearance Customization
  • Tool Tips

Graph Minimum and Maximum

The minimum and maximum of the chart are auto-calculated if they are not given a value. The minimum and maximum are set to the smallest and largest displayed values respectively. The minimum and maximum can also be set to specific values, note that any data values outside of the set range will be clipped and not displayed.

Setting the minimum and maximum chart values can be useful for putting group of candlestick charts into the same context. This allows all the charts to display the same range and makes it easy to compare several data sets. The charts could then be rendered vertically and placed in a row to produce a comprehensive report.

Orientation

The MicroCandlestickChart.Orientation property is Horizontal by default, but can be set to Vertical as well. Setting the chart's orientation to vertical effectively rotates the control 90 degrees counter-clockwise, so the minimum value is on the bottom and the maximum is at the top of the control.

Appearance Customization

The MicroCandlestickChart control has a GainStyle and LossStyle property that can be customized to alter the appearance of the chart. Note that both styles should be set for a Shape. The control uses the gain style if the closing value is greater than the opening value and the loss style if the closing value is less than the opening value. The selected style is applied wicks and the box of the control, the stroke defining the color of the wicks and box outline and the fill defining the color inside the box. If GainStyle is not given a value then LossStyle will be used with the fill being set to Transparent instead. By default the stroke and fill of the loss style are black and the gain style is not given a value.

XAML
Copy
​<microcharts:MicroCandlestickChart ... >
      <microcharts:MicroCandlestickChart.LossStyle>
             <Style TargetType="Shape">
                    <Setter Property="Stroke" Value="#5778B6" />
                    <Setter Property="Fill" Value="#5778B6" />
                    <Setter Property="StrokeThickness" Value="3" />
             </Style>
      </microcharts:MicroCandlestickChart.LossStyle>
</microcharts:MicroCandlestickChart>

The above example shows how to set a style for the chart and the appearance of a gain and loss situation.

Tool Tips

MicroCandlestickCharts support tooltips that can be custom formatted and can display the low, high, open, and close values.

Format Parameter | Description
{0} | The low value.
{1} | The high value.
{2} | The open value.
{3} | The close value.

This example displays the upper and lower quartile values as well as the mean value of the data. Note how numeric formatting is used on the values.

XAML
Copy
​<microcharts:MicroCandlestickChart ... LegendStringFormat"Low: {0:C2}; High: {1:C2}; Open: {2:C2}; Close: {3:C2}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Heat Map

Micro Chart Types
Heat Map

A heat map is a grid where each cell renders color and/or size differences to reflect data values. The MicroHeatMapPresenter control is the marker used in each heat map cell, and automatically handles the color and/or size rendering for its particular data value representation.

This topic contains these sections:

  • What is a Heat Map?
  • Reusing Styles
  • Color Changing Ability
  • Sizing Ability
  • Marker Shape Kinds
  • Tooltips

What is a Heat Map?

Heat maps are charts made up of individual markers that use changing color and/or size to represent one or two pieces of data. Each marker has one or two values that are part of the set(s) of data represented by the chart. For each value the marker gets its size or color based on the position of that value within the range defined by the minimum and maximum values in the set.

In the example above the markers are changing color and size to represent their two values. The smaller the values represented by color are shown with lighter markers, and the smaller the values represented by size are shown with smaller markers. The two values are independent of one another, meaning a large marker can be very light and a small marker can be very dark.

The MicroHeatMapPresenter control provides this dynamic functionality for a single marker. Multiple instances can be used to create a heat map. In the example, each single circle is one MicroHeatMapPresenter control, with its own color and size values.

Reusing Styles

Generally a group of MicroHeatMapPresenter controls will all use the same values for their GradientStops property, minimum and maximum values, LegendStringFormat (for tooltips) property, IsSizingEnabled property, and Height and Width properties. Instead of setting these properties for each individual control it is much more practical to set a style that the controls can inherit from. The style can be set in the Resources property of the container for the elements, such as a Grid or Border.

XAML
Copy
​<Border>
      <Border.Resources>
             <Style TargetType="microcharts:MicroHeatMapPresenter">
                    <Setter Property="GradientStops">
                           <Setter.Value>
                                         <GradientStopCollection>
                                                <GradientStop Color="WhiteSmoke" Offset="0" />
                                                <GradientStop Color="DarkGreen" Offset="1" />
                                         </GradientStopCollection>
                           </Setter.Value>
                    </Setter>

                    <Setter Property="MarkerStyle">
                           <Setter.Value>
                                  <Style TargetType="microcharts:MicroChartMarker">
                                        <Setter Property="ShapeKind" Value="Ellipse" />
                                 </Style>
                           </Setter.Value>
                    </Setter>

                    <Setter Property="Height" Value="20" />
                    <Setter Property="Width" Value="20" />
                    <Setter Property="ColorMaximum" Value="100" />
                    <Setter Property="SizeMaximum" Value="10000" />
                    <Setter Property="Margin" Value="3" />
                    <Setter Property="IsSizingEnabled" Value="True" />

             <Setter Property="LegendStringFormat" Value="Revenue per item:       {0:C2}  Items sold: {3:N0}" />
             </Style>
      </Border.Resources>

      <StackPanel>
             <microcharts:MicroHeatMapPresenter ColorValue="15" SizeValue="1250" />
             <microcharts:MicroHeatMapPresenter ColorValue="21" SizeValue="2590" />
      </StackPanel>
</Border>

The sample code above sets the style used in the example from the "What is a Heat Map?" section. Note that the ColorMaximum and SizeMaximum properties are hard-coded in. Generally these values will come from data and not be set in the style, unless the range is known regardless of the data. This style is applied to each MicroHeatMapPresenter within the Border. This can be repeated for several different containers on a page to create multiple charts, or the style can be put into the App.Resources to apply to all MicroHeatMapPresenter controls in the application.

Color Changing Ability

The MicroHeatMapPresenter.GradientStops property can be set to a GradientStopsCollection from which it will select a color based on its ColorValue. The control will select its color based on the GradientStop(s) with the offset value(s) closest to the percentage of the ColorValue from the ColorMinimum to the ColorMaximum. If the percentage lies within two offsets the control will find and use the color at the proper point between the two colors. If the GradientStops property is not defined then the control will display black.

Below is an example of initializing the color variables so the control will find its place in the range between the min and max and render at a color selected from the gradient specified.

XAML
Copy
​<microcharts:MicroHeatMapPresenter ColorValue="21" ColorMinimum="10" ColorMaximum="70">
      <microcharts:MicroHeatMapPresenter.GradientStops>
             <GradientStopCollection>
                    <GradientStop Color="#90bc0b" Offset="0.0" />
                    <GradientStop Color="#c3d92e" Offset="0.2" />
                    <GradientStop Color="#e0cc2e" Offset="0.4" />
                    <GradientStop Color="#d79c36" Offset="0.6" />
                    <GradientStop Color="#e07b3d" Offset="0.8" />
                    <GradientStop Color="#da4d38" Offset="1.0" />
             </GradientStopCollection>
      </microcharts:MicroHeatMapPresenter.GradientStops>
</microcharts:MicroHeatMapPresenter>

Sizing Ability

By default the MicroHeatMapPresenter will size to fit its container. The control can be set to change size to reflect data by setting the IsSizingEnabled property to true. The marker will then render at a percentage of its normal size equal to the percentage of its SizeValue from the SizeMinimum to the SizeMaximum. If the SizeValue is equal to the maximum it will render at the full defined size, and if it is equal to the minimum it will not render visibly.

Below is an example of a MicroHeatMapPresenter with its IsSizingEnabled property set to true. Note that the GradientStops property is not set, so the control will render black for a sizing-only effect.

XAML
Copy
​<microcharts:MicroHeatMapPresenter SizeValue="1250" SizeMinimum="100" SizeMaximum="10000" Width=20” Height=20” IsSizingEnabled="True"/>

Marker Shape Kinds

The marker of the control supports several built in shape kinds, which include:

Kind | Example
Diamond |
Ellipse |
Hexagon |
Pentagon |
Octagon |
Rectangle |
Star4Points |
Star5Points |
Star6Points |
Star8Points |
Triangle |

Tooltips

MicroHeatMapPresenters support tooltips that can be custom formatted and can display the color and size value as well as the color and size minimums and maximums.

Format Parameter | Description
{0} | The value represented by color.
{1} | The minimum color value.
{2} | The maximum color value.
{3} | The value represented by size.
{4} | The minimum size value.
{5} | The maximum size value.

This example displays the ColorValue as well as the ColorMinimum and the ColorMaximum to show the range. Note how numeric formatting is used on the ColorValue.

XAML
Copy
​<microcharts:MicroHeatMapPresenter ... LegendStringFormat="Temperature: {0:F2}°C  (Range: {1}-{2}°C)" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Segment

Micro Chart Types
Segment

A segment chart provides a visual representation of an integer value in relation to a total number. Each segment in the chart is rendered as highlighted or unhighlighted. For instance, if the value is 3 of 10, there will be 10 total segments displayed, with the first 3 rendering as highlighted.

This sort of chart is great for use on dashboards, and also as an indicator of steps or progress achieved.

The style for the segments can be customized, allowing for any sort of shape, size, or color combination. The Panel used to render the chart can also be set, enabling wrapping and other layout scenarios.

This topic contains these sections:

  • Basic Usage
  • Appearance Customization
  • Increment and Decrement Commands

Basic Usage

It's easy to use the MicroSegmentChart control. Simply set its Total property to the total number of segments that should be displayed. Then bind the Value property to a value indicating the number of segments that should be highlighted. This value should be less than or equal to the total segment count.

XAML
Copy
​<microcharts:MicroSegmentChart Total="5" Value="{Binding CurrentValue}" />

Appearance Customization

The MicroSegmentChart control can easily be customized to render segments in many interesting ways.

Size and Shape

This code shows how to make red 13x13 squares with a 1px margin:

XAML
Copy
​<microcharts:MicroSegmentChart Value="7" Total="10">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="HighlightedBackground" Value="#e73232" />
            <Setter Property="Margin" Value="1" />
            <Setter Property="MinHeight" Value="13" />
            <Setter Property="MinWidth" Value="13" />
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
</microcharts:MicroSegmentChart>

This code shows how to customize the chart template to create the purple circles seen above:

XAML
Copy
​<microcharts:MicroSegmentChart Value="5" Total="15" HorizontalAlignment="Left">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="Background" Value="#d0d0d0" />
            <Setter Property="HighlightedBackground" Value="#9e5aac" />
            <Setter Property="MinHeight" Value="15" />
            <Setter Property="MinWidth" Value="15" />
            <Setter Property="Template">
                <Setter.Value>
                    <ControlTemplate TargetType="microcharts:MicroSegmentChartItem">

                        <Ellipse x:Name="background" Fill="{TemplateBinding Background}">
                            <VisualStateManager.VisualStateGroups>
                                <VisualStateGroup x:Name="HighlightStates">
                                    <VisualState x:Name="Unhighlighted" />
                                    <VisualState x:Name="Highlighted">
                                        <Storyboard>
                                            <ObjectAnimationUsingKeyFrames Storyboard.TargetName="background" Storyboard.TargetProperty="Fill">
                                                <DiscreteObjectKeyFrame KeyTime="0" Value="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=HighlightedBackground}" />
                                            </ObjectAnimationUsingKeyFrames>
                                        </Storyboard>
                                    </VisualState>
                                </VisualStateGroup>
                            </VisualStateManager.VisualStateGroups>
                        </Ellipse>

                    </ControlTemplate>
                </Setter.Value>
            </Setter>
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
</microcharts:MicroSegmentChart>

Segment Number Display

Each segment is passed its number as the data context. This allows the segment number to be rendered in the segment via custom templates.

XAML
Copy
​<microcharts:MicroSegmentChart Value="6" Total="10" HorizontalAlignment="Left">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="Background" Value="#d0d0d0" />
            <Setter Property="Foreground" Value="#000000" />
            <Setter Property="HighlightedBackground" Value="#0073cd" />
            <Setter Property="MinHeight" Value="25" />
            <Setter Property="MinWidth" Value="25" />
            <Setter Property="Template">
                <Setter.Value>
                    <ControlTemplate TargetType="microcharts:MicroSegmentChartItem">

                        <Border x:Name="background" Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}"
                                BorderThickness="{TemplateBinding BorderThickness}" Padding="{TemplateBinding Padding}">
                            <TextBlock x:Name="text" Text="{Binding}" Foreground="{TemplateBinding Foreground}" HorizontalAlignment="Center" VerticalAlignment="Center" />

                            <VisualStateManager.VisualStateGroups>
                                <VisualStateGroup x:Name="HighlightStates">
                                    <VisualState x:Name="Unhighlighted" />
                                    <VisualState x:Name="Highlighted">
                                        <Storyboard>
                                            <ObjectAnimationUsingKeyFrames Storyboard.TargetName="background" Storyboard.TargetProperty="Background">
                                                <DiscreteObjectKeyFrame KeyTime="0" Value="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=HighlightedBackground}" />
                                            </ObjectAnimationUsingKeyFrames>
                                            <ObjectAnimationUsingKeyFrames Storyboard.TargetName="text" Storyboard.TargetProperty="Foreground">
                                                <DiscreteObjectKeyFrame KeyTime="0" Value="#ffffff" />
                                            </ObjectAnimationUsingKeyFrames>
                                        </Storyboard>
                                    </VisualState>
                                </VisualStateGroup>
                            </VisualStateManager.VisualStateGroups>
                        </Border>

                    </ControlTemplate>
                </Setter.Value>
            </Setter>
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
</microcharts:MicroSegmentChart>

Alternate Panels

By setting a custom ItemsPanel property value, different backing Panel controls can be used. In the screenshot above, we display 100 segments in a large square with this code:

XAML
Copy
​<microcharts:MicroSegmentChart Value="57" Total="100" HorizontalAlignment="Left">
    <microcharts:MicroSegmentChart.ItemContainerStyle>
        <Style TargetType="microcharts:MicroSegmentChartItem">
            <Setter Property="HighlightedBackground" Value="#26b106" />
            <Setter Property="Margin" Value="1" />
            <Setter Property="MinHeight" Value="8" />
            <Setter Property="MinWidth" Value="8" />
        </Style>
    </microcharts:MicroSegmentChart.ItemContainerStyle>
    <microcharts:MicroSegmentChart.ItemsPanel>
        <ItemsPanelTemplate>
            <toolkit:WrapPanel MaxWidth="100" />
        </ItemsPanelTemplate>
    </microcharts:MicroSegmentChart.ItemsPanel>
</microcharts:MicroSegmentChart>

Increment and Decrement Commands

The MicroSegmentChart control has two ICommand properties that can be bound to any button to allow incrementing or decrementing of the Value property.

XAML
Copy
​<RepeatButton Margin="0,0,5,0" MinWidth="20" MinHeight="20" Content="-" Command="{Binding ElementName=commandedSegmentChart, Path=DecreaseCommand}" />
<microcharts:MicroSegmentChart x:Name="commandedSegmentChart" Value="3" Total="10" />
<RepeatButton Margin="5,0,0,0" MinWidth="20" MinHeight="20" Content="+" Command="{Binding ElementName=commandedSegmentChart, Path=IncreaseCommand}" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Trend Indicator

Micro Chart Types
Trend Indicator

The trend indicator is a three state control that is intended to reflect whether a numeric value is higher, the same as, or lower than an origin value.

This sort of element is commonly used in stock value display where the origin value is bound to the previous day's stock price, and the value is bound to the current price. The trend indicator then renders an upward green triangle if there was positive movement, a gray line if no change, or a red triangle if there was negative movement.

If the values are updating live, the indicator changes use a pleasing animation that rotates and fades in the new indicator. The template for each state's indicator can be customized as well.

This topic contains these sections:

  • Basic Usage
  • Appearance Customization

Basic Usage

Simply bind the control's OriginValue property to the original value (or previous value) and the Value property to the current value. The control will animate and display one of three indicator templates.

XAML
Copy
​<microcharts:MicroTrendIndicator OriginValue="{Binding OriginValue}" Value="{Binding CurrentValue}" />

Appearance Customization

The MicroTrendIndicator control can display custom indicator templates for each of its three states.

This code alters the indicator templates to all use circles:

XAML
Copy
​<microcharts:MicroTrendIndicator OriginValue="7" Value="10">
    <microcharts:MicroTrendIndicator.HigherTemplate>
        <DataTemplate>
            <Ellipse Fill="#42cb0c" />
        </DataTemplate>
    </microcharts:MicroTrendIndicator.HigherTemplate>
    <microcharts:MicroTrendIndicator.NeutralTemplate>
        <DataTemplate>
            <Ellipse Fill="#808080" />
        </DataTemplate>
    </microcharts:MicroTrendIndicator.NeutralTemplate>
    <microcharts:MicroTrendIndicator.LowerTemplate>
        <DataTemplate>
            <Ellipse Fill="#cb0c0c" />
        </DataTemplate>
    </microcharts:MicroTrendIndicator.LowerTemplate>
</microcharts:MicroTrendIndicator>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Micro Charts Data Sources
Overview

It's easy to use any simple or complex objects as data sources for charts, and data aggregation is fully supported.

Specifying Items

The chart control can be bound to any custom data source and supports several data types.

See the Specifying Items topic for more information.

Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

See the Data Aggregation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Specifying Items

Micro Charts Data Sources
Specifying Items

The chart control can be bound to any custom data source and supports several data types.

This topic contains these sections:

  • Supported Axis Types
  • Setting ItemsSource

Supported Axis Types

The chart control supports a fixed set of data types along each axis.

The supported data types include:

  • Byte
  • DateTime
  • Decimal
  • Double
  • Int16
  • Int32
  • Int64
  • Float
  • SByte
  • UInt16
  • UInt32
  • UInt64

An exception will be thrown if an unsupported data type is specified.

Setting ItemsSource

Each series in a chart control can be bound to a separate data source, or to different properties on the same data source. The ItemsSource property on each series can be set to any collection of objects, including custom objects, as long as the collection implements IEnumerable.

There are two types of collections that can be used, simple (such as as list of Double) and complex (such as a list of custom objects).

Simple Collections

A collection of supported axis data types (shown above) can be used as-is without specifying a path to a source property. The index in the collection will be used as the secondary value (which is typically the X value) and the actual value in the collection will be used as the primary value (which is typically the Y value).

In this example, the line series is set to a collection of doubles, defined inline in XAML. Therefore, the X values will range from 0 to 11 (since there are 12 entries) and the actual values shown will be used along the Y axis:

XAML
Copy
​<microcharts:MicroLineSeries ItemsSource="7;3;5;1;1;3;10;5;2;8;1;14" />
Assuming the Counts binding below in the ItemsSource referenced an IEnumerable of the same numeric data values as above, this code would produce identical output:
XAML
Copy
​<microcharts:MicroLineSeries ItemsSource="{Binding Counts}" />

Complex Collections

Collections of custom complex objects can also be used. In this case, the XPath and/or YPath properties must be set to the name of a property on the objects in the collection.

For example, consider the following custom object:

C#
VB
Copy
​public class SalesData {

    private decimal amount;
    private DateTime date;

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // OBJECT
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Initializes a new instance of the <c>SalesData</c> class.
    /// </summary>
    /// <param name="date">The date for which the amount is specified.</param>
    /// <param name="amount">The sales amount.</param>
    public SalesData(DateTime date, decimal amount) {
        this.date = date;
        this.amount = amount;
    }

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Gets the sales amount.
    /// </summary>
    /// <value>The sales amount.</value>
    public decimal Amount {
        get {
            return amount;
        }
    }

    /// <summary>
    /// Gets the date for which the amount is specified.
    /// </summary>
    /// <value>The date for which the amount is specified.</value>
    public DateTime Date {
        get {
            return date;
        }
    }

}
​Public Class SalesData

    Private amount_Renamed As Decimal
    Private date_Renamed As DateTime

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' OBJECT
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Initializes a new instance of the <c>SalesData</c> class.
    ''' </summary>
    ''' <param name="date">The date for which the amount is specified.</param>
    ''' <param name="amount">The sales amount.</param>
    Public Sub New(ByVal [date] As DateTime, ByVal amount As Decimal)
        Me.date_Renamed = [date]
        Me.amount_Renamed = amount
    End Sub

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Gets the sales amount.
    ''' </summary>
    ''' <value>The sales amount.</value>
    Public ReadOnly Property Amount() As Decimal
        Get
            Return amount_Renamed
        End Get
    End Property

    ''' <summary>
    ''' Gets the date for which the amount is specified.
    ''' </summary>
    ''' <value>The date for which the amount is specified.</value>
    Public ReadOnly Property [Date]() As DateTime
        Get
            Return date_Renamed
        End Get
    End Property

End Class

We can specify that the Y values should be pulled from the Amount property by setting YPath to "Amount". If we want to use the index in the collection as our X values, then we do not need to set XPath.

If instead we want the X values to be pulled from the Date property, then we would need to set XPath to "Date".

Note Note
You can traverse complex hierarchies to get to the value you need by using a property path that is delimited by a period ("."). For example you can set XPath or YPath to something like "MyProperty.MyOtherProperty.MyDoubleValue", similar to how binding paths work in XAML.
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Aggregation

Micro Charts Data Sources
Data Aggregation

The chart control supports aggregating its data to reduce the number of data points displayed.

This topic contains these sections:

  • Aggregation Factor
  • Aggregation Kinds

Aggregation Factor

In order to increase performance, the chart control will automatically determine the optimal number of data points to display based on the size of the control. This is determined using the AggregationFactor property, which defaults to 0.2.

For example, if the chart control is 100 pixels wide and uses an aggregation factor of 0.1, then the optimal number of data points would be 10. If the data source contained 1000 items, then the chart would create 10 groups, each with 100 items in it. Then some sort of aggregation function would be performed on each group to generate a single data point for display.

A line series with markers visible with no aggregation, 10% aggregation, and 50% aggregation

Aggregation is enabled by default and can be disabled by setting IsAggregationEnabled to false.

Aggregation Kinds

There are various aggregation functions that can be performed on the items in a group. The supported aggregation kinds are specified using the PrimaryAggregationKind and SecondaryAggregationKind.

The PrimaryAggregationKind is typically used for the Y values, but for vertically-oriented series this will be used by the X values. Similarly the SecondaryAggregationKind is used for X values, but will be used by Y values for vertically-oriented series.

The following table lists the supported aggregation kinds:

Aggregation Kind | Description
Average | Averages all the values in the group and uses that as the aggregated value.
First | Uses the first value in the group as the aggregated value.
Last | Uses the last value in the group as the aggregated value.
Maximum | Uses the maximum value in the group as the aggregated value.
Minimum | Uses the minimum value in the group as the aggregated value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Micro Charts Appearance Features
Overview

The chart control contains several other features that can be used to customize the appearance.

Baseline

A baseline value can be used to alter the look of area, bar, and win/loss series, and can be optionally displayed on the chart.

See the Baseline topic for more information.

Hot Tracking

Hot tracking displays a customizable tooltip which contains the values of the data point closest to the end-user's mouse cursor.

See the Hot Tracking topic for more information.

Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

See the Palettes topic for more information.

Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

See the Ranges topic for more information.

Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

See the Series Visibility topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Baseline

Micro Charts Appearance Features
Baseline

A baseline value can be used to alter the look of area, bar, and win/loss series, and can be optionally displayed on the chart.

This topic contains these sections:

  • Baseline Value
  • Baseline Visibility and Style

Baseline Value

The baseline value determines what the chart considers "positive" and "negative" values. Any value greater than or equal to the baseline value is considered positive, and any value less than the baseline value is considered negative.

The baseline value can be customized using the MicroXYChart.AxisBaselineValue property, which defaults to 0 for numeric values and DateTime.MinValue for date/time.

This positive/negative distinction can affect which style is used for various elements in the chart. For example, when enabled the MarkerNegativeStyle style will be used for any markers below the baseline value, while values above it will use the MarkerStyle style.

In addition, area, bar, and win/loss series will pivot their polygons around the baseline value, which alters their appearance.

In the following examples, the data rendered by the area chart uses the index postion along the X-axis and the fixed values 10, 20, 10, 20, 10, 20, 10 for the Y-axis. The first image shows the series using 10 as the minimum value along the Y-axis, and 20 for the maximum. Since our baseline is 0 (the default), the polygon is not pivoted.

If we explicitly set our baseline value to 15, then any values below the baseline will be considered "negative" and the polyon will appear to pivot around the baseline.

Finally, if we enable the use of negative styles then the portions of the polygon below the baseline use a distinct style.

Baseline Visibility and Style

An actual line can be rendered at the specified baseline value to highlight its location in the chart. The visibility of the line is configured using the IsAxisBaselineVisible property, which is false by default.

For example, the following line series uses the same fixed values from above (10, 20, 10, 20, 10, 20, 10) and a baseline value of 15. In this particular example, since the line is rendered with a single color, it is not possible to visually determine what is considered above or below the baseline.

If we set IsAxisBaselineVisible to True, then we can easily determine this information.

The style of the line can be customized using the AxisBaselineStyle property. The associated Style should target the Shape type, which includes properties such as Stroke and StrokeThickness.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Hot Tracking

Micro Charts Appearance Features
Hot Tracking

Hot tracking displays a customizable tooltip which contains the values of the data point closest to the end-user's mouse cursor.

This topic contains these sections:

  • Enabling Hot-Tracking
  • Legend String Format
  • Legend Marker Style
  • Legend Item Template

Enabling Hot-Tracking

Hot-tracking can be enabled by setting the MicroXYChart.IsHotTrackingEnabled property to true. It is set to false by default.

Once enabled, as the end user's mouse moves over the chart, values nearest the mouse will display in a tooltip. The tooltip's contents can be completely customized via the various series-oriented legend settings discussed below.

Legend String Format

The legend's string format is the easiest way to customize what is displayed in a tooltip for a series. The series-specific string format is set via the MicroXYSeriesBase.LegendStringFormat property. By default the value of the primary axis is displayed.

Format Parameter | Description
{0} | The value of the primary axis, generally the Y value.
{1} | The value of the secondary axis, generally the X value.
{2} | The X value.
{3} | The Y value.
{4} | Reserved for future use.
{5} | The series description, as indicated in the MicroXYSeriesBase.Description property.

This example shows the display of both X and Y values. Note how numeric formatting is used on the Y value.

XAML
Copy
​<microcharts:MicroLineSeries ... LegendStringFormat="{}X: {2}, Y: {3:F2}" />

This example shows two series in the same chart, and each indicates its own description and value.

XAML
Copy
​<microcharts:MicroLineSeries ... Description="{Binding DataSet[0].Name}" LegendStringFormat="{}{5}: {0:C0}" />
<microcharts:MicroLineSeries ... Description="{Binding DataSet[1].Name}" LegendStringFormat="{}{5}: {0:C0}" />

Legend Marker Style

The legend markers, used to render a series' base color in front of its string formatted display value within the tooltip, use a square shape by default. This shape renders using the style assigned to the MicroXYSeriesBase.LegendMarkerStyle property.

By setting that property to another Style that targets the MicroChartMarker type, the shape used in the tooltip can be customized. Properties such as Fill, Stroke, StrokeThickness, and ShapeKind can be set.

See the Scatter chart type topic for more information on available shape kinds.

Legend Item Template

The default legend item template renders the legend marker to the left of the string formatted display value. This can be customized if a different layout is preferred, by setting the MicroXYSeriesBase.LegendItemTemplate property with an alternate DataTemplate.

This example shows the default DataTemplate used:

XAML
Copy
​<DataTemplate>
    <Grid>
        <Grid.ColumnDefinitions>
            <ColumnDefinition Width="Auto" />
            <ColumnDefinition Width="*" />
        </Grid.ColumnDefinitions>
        <microcharts:MicroChartMarker Width="8" Height="8" Style="{Binding MarkerStyle}" VerticalAlignment="Center" />
        <TextBlock Grid.Column="1" Margin="3,0,0,0" Text="{Binding Text}" />
    </Grid>
</DataTemplate>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Palettes

Micro Charts Appearance Features
Palettes

There are an enormous number of configuration options related to palettes. The various brushes used by the chart can be easily customized using a palette of colors or the styles can be completely overridden.

This topic contains these sections:

  • Introduction
  • Built-In Palettes
  • Palette Color Selection
  • Palette Shade Generation
  • Custom Palette Colors
  • Customizing Highlight Effect Brushes

Introduction

When any series is being rendered within a chart, it uses the chart's MicroChartBase.SeriesStyleSelector to determine which styles to apply to the various shapes displayed. These shapes include the basic shapes representing lines, areas, bars, markers, etc.

For instance, by default a line series that shows all markers will render the markers in the same color. An option can be set to apply highlight effects (different brushes) to certain markers such as the first/last, high/low, or negative ones. Similar options are available where appropriate for lines, areas, and bars. These highlight effects are achieved by the series style selector telling the chart which style to use. Normal markers get their style from a MicroSeriesStyleSelector.SelectMarkerStyle call. If the series has indicated it wants negative value markers to be rendered differently, the negative value markers get their style from a MicroSeriesStyleSelector.SelectMarkerNegativeStyle call, and so on for other highlight effects.

The MicroSeriesPaletteStyleSelector class inherits MicroSeriesStyleSelector and provides many settings that can be used to completely customize how a chart renders its series.

An important thing to note is that the MicroSeriesPaletteStyleSelector builds shape styles based on colors defined in a MicroPalette that has been assigned to its Palette property. The palette contains multiple colors so that when more than one series is used in a chart, each series will cycle to use a different palette color.

Built-In Palettes

Numerous built-in palettes are included with the product, each named via a value within the MicroPaletteKind enumeration.

A built-in palette can be assigned to a chart like this (in this case the Roman palette):

XAML
Copy
​xmlns:microcharts="using:ActiproSoftware.UI.Xaml.Controls.MicroCharts"
xmlns:microchartsPalettes="using:ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes"
...
<microcharts:MicroXYChart Width="100" Height="18">
    <microcharts:MicroXYChart.SeriesStyleSelector>
        <microchartsPalettes:MicroSeriesPaletteStyleSelector>
            <microchartsPalettes:MicroPalette Kind="Roman" />
        </microchartsPalettes:MicroSeriesPaletteStyleSelector>
    </microcharts:MicroXYChart.SeriesStyleSelector>
    ...
</microcharts:MicroXYChart>

For simple cases where no other customization is needed on the MicroSeriesPaletteStyleSelector, the palette kind can simply be set as an attribute value as well, where the text specified matches one of the MicroPaletteKind values:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" SeriesStyleSelector="Roman">
    ...
</microcharts:MicroXYChart>

Palette Color Selection

Each palette has two mode options for how colors will be assigned to series in a chart. The mode is set by specifying a MicroColorSelectionHint value on the MicroPalette.ColorSelectionHint property.

Mode | Description
Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.

The default is to use UniformDistribution mode on the built-in palettes, and Sequential mode on custom palettes.

Palette Shade Generation

Each palette has a list of base colors used directly as the core color for each series in a chart. Most palettes define six colors. But what happens when there are more than six series in a chart?

If shade generation is enabled on a palette, via its MicroPalette.IsShadeGenerationEnabled property, additional darker and lighter shades of the base colors will be generated and used for the other series. By default, this feature is enabled.

If this feature is disabled, the color assignments will recycle and the seventh series will simply use the first base color again, and so on.

Custom Palette Colors

It's very easy to create custom palettes. Simply create a MicroPalette and assign the custom colors to its BaseColors collection.

This sample shows the creation of a palette that contains two custom colors:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18">
    <microcharts:MicroXYChart.SeriesStyleSelector>
        <microchartsPalettes:MicroSeriesPaletteStyleSelector>
            <microchartsPalettes:MicroPalette>
                <Color>#46bff7</Color>
                <Color>#06226b</Color>
            </microchartsPalettes:MicroPalette>
        </microchartsPalettes:MicroSeriesPaletteStyleSelector>
    </microcharts:MicroXYChart.SeriesStyleSelector>
    ...
</microcharts:MicroXYChart>

Note Note
When multiple series are used in a chart, make sure that your palette has enough base color entries to match or exceed your series count. Or ensure that the shade generation feature (described above) is active.

Customizing Highlight Effect Brushes

As described in the introduction above, there are many ways certain data points (and related markers, bars, etc.) can be highlighted. The MicroSeriesPaletteStyleSelector class has an enormous number of property-based options for customizing highlight effects:

  • Area (also used for bars) - Normal, high, low, negative
  • Line - Normal, negative
  • Marker - Normal, first, last, high, low, negative

Each of these options generally has three properties on MicroSeriesPaletteStyleSelector, such as these for normal areas:

  • AreaBrushCustom
  • AreaBrushKind
  • AreaTintColor

Custom Brush

A custom Brush, if specified via properties like AreaBrushCustom, will cause the related shape (in this case, a normal area) to directly use that brush for rendering.

Brush Kind

A brush kind can be specified via properties like AreaBrushKind. This kind is of type MicroSeriesBrushKind and has many values that can "modify" the palette color assigned to the series:

  • Default - Use the exact palette color.
  • Light - Use a slightly lighter version of the palette color.
  • Dark - Use a slightly darker version of the palette color.
  • SemiTransparent - Use a semi-transparent version of the palette color.
  • DarkToLightGradient - Use a gradient, from the Dark to Light color.
  • LightToDarkGradient - Use a gradient, from the Light to Dark color.
  • Complement - Use a complement of the Default color.
  • ComplementLight - Use a complement of the Light color.
  • ComplementDark - Use a complement of the Dark color.
  • ComplementSemiTransparent - Use a semi-transparent version of the Default color.
  • ComplementDarkToLightGradient - Use a gradient, from the ComplementDark to ComplementLight color.
  • ComplementLightToDarkGradient - Use a gradient, from the ComplementLight to ComplementDark color.

By using a brush kind setting instead of specifying an exact custom brush, the brush used for each series will be relative to the palette color assigned to that series.

Tint Color

A tint color can be set via properties like AreaTintColor. If specified, the tint will be applied to the resulting brush from the brush kind setting. The tint color is not used if a custom brush is directly set.

The default usage of tint colors is for high areas/markers to tint towards green, and low areas/markers to tint towards red.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Ranges

Micro Charts Appearance Features
Ranges

Specific value ranges of the chart can be highlighted to convey additional information to the end-user.

A line chart with a green and red range for positive and negative values, respectively

This topic contains these sections:

  • Orientation
  • Minimum and Maximum Values

Orientation

By default, ranges will be aligned horizontally, which means they highlight value ranges along the Y-axis. A vertical range can be created by setting the Orientation property to Vertical. Vertical ranges highlight value ranges along the X-axis.

A line chart with a yellow range between the X values 2 and 5

In this example, the line series is set to a collection of doubles. Therefore, the X values will range from 0 to 7 (since there are 8 entries) and the actual values shown will be used along the Y axis:

XAML
Copy
​<microcharts:MicroXYChart Width="130" Height="40">
    <microcharts:MicroLineSeries ItemsSource="4;-5;3;6;9;-9;1;5" MarkerVisibility="All" MarkerStyleKinds="All" />
    <microcharts:MicroXYChart.Ranges>
        <microcharts:MicroXYRange Background="#88FFFF00" Minimum="2" Maximum="5" Orientation="Vertical"/>
    </microcharts:MicroXYChart.Ranges>
</microcharts:MicroXYChart>

Minimum and Maximum Values

The values of a range are specified using the Maximum and Minimum properties.

If either of these properties is unset (or set to null), then it's value will be auto-calculated based on the data points from all series. The Maximum will run to the highest value and likewise the Minimum will run to the lowest value.

For example, we can produce two ranges that run up (green) and down (red) from 0 using the following code:

XAML
Copy
​<microcharts:MicroXYChart Width="130" Height="40">
    <microcharts:MicroLineSeries ItemsSource="4;-5;3;6;9;-9;1;5" MarkerVisibility="All" MarkerStyleKinds="All" />
    <microcharts:MicroXYChart.Ranges>
        <microcharts:MicroXYRange Minimum="0">
            <microcharts:MicroXYRange.Background>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="Transparent" Offset="0" />
                    <GradientStop Color="#2200FF00" Offset="1" />
                </LinearGradientBrush>
            </microcharts:MicroXYRange.Background>
        </microcharts:MicroXYRange>
        <microcharts:MicroXYRange Maximum="0">
            <microcharts:MicroXYRange.Background>
                <LinearGradientBrush StartPoint="0,0" EndPoint="0,1">
                    <GradientStop Color="#22FF0000" Offset="0" />
                    <GradientStop Color="Transparent" Offset="1" />
                </LinearGradientBrush>
            </microcharts:MicroXYRange.Background>
        </microcharts:MicroXYRange>
    </microcharts:MicroXYChart.Ranges>
</microcharts:MicroXYChart>

This produces the following chart:

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Series Visibility

Micro Charts Appearance Features
Series Visibility

The visibility of any series can be set to dictate whether or not it is rendered on the chart.

Usage

The visibility of a series can be changed in order to create the ability to show/hide the series on the chart. With this feature several series can be contained within a chart then their visibilities can be manipulated to better compare just a couple at a time. The visibility of a series can be customized with the MicroSeriesBase.Visibility property, which defaults to Visible.

In this example, the visibility property of the line series is bound to the IsChecked property of the checkbox so that the series is shown when checked and not shown when unchecked:

XAML
Copy
​<microcharts:MicroXYChart Width="100" Height="18" IsHotTrackingEnabled="True">
    <microcharts:MicroBarSeries Description="New York" ItemsSource="581415; 591966; 492003; 460123; 523962; 622962; 649196; 789123; 800124; 750126; 741612; 720556" LegendStringFormat="{}{5}: {0:C0}"/>
    <microcharts:MicroLineSeries Description="Los Angeles" ItemsSource="318624; 358185; 381725; 310128; 251929; 370125; 380120; 354501; 263105; 492031; 423123; 380125" LegendStringFormat="{}{5}: {0:C0}"
        Visibility="{Binding IsChecked, ElementName=chkVisible, Converter={StaticResource BooleanToVisibilityConverter}}"/>
</microcharts:MicroXYChart>
...
<CheckBox x:Name="chkVisible" Content="Los Angeles series visible" IsChecked="True"/>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Reference
Overview

SyntaxEditor is a powerful text editing control that is packed with features for efficient code editing, including syntax highlighting, code outlining, parsing, line numbers, block selection, IntelliPrompt UI, zooming, adornments, and much more. It has many of the same code editing features found in the Visual Studio code editor.

The SyntaxEditor control editing a Javascript file with outlining enabled

SyntaxEditor is built on top of our next-generation extensible text/parsing framework. While over 20 sample languages are available to get you started (such as C#, VB, XML, and more), custom language definitions can be developed and distributed with your applications as well. SyntaxEditor is designed for use in IDE (integrated development environment) applications, however there are many other applications out there than can take advantage of such a control.

Note Note
At the current time, the Windows Phone app version of SyntaxEditor only supports code viewing. On the other hand, the Windows app version support full-featured editing.

Features

Editing Features

  • Unlimited undo/redo with ability to batch replace operations.
  • Block indent/outdent.
  • Automated line modification tracking.
  • Block (rectangular) selection and ability to prevent certain selection methods.
  • Edit multiple lines at the same time with block selection.
  • Line selection in the selection margin.
  • Clipboard operations natively supported (cut, copy, paste), with support for any DataObject.
  • Complete extended Unicode character support.
  • Over 100 edit actions including everything found in Visual Studio such as caret movement, selection, indenting, tabification, transposition, and more.
  • Block, none, and customizable smart auto-indent modes when pressing Enter.
  • Current line and delimiter (bracket) highlighting.
  • Delimiter (bracket) auto-completion.
  • Auto-case correct.
  • Code block selection (expansion/contraction).

Appearance Features

  • Syntax highlighting of code based on classification mechanism, with ability to override lexer-based classifications.
  • Word wrap.
  • Whitespace display.
  • Optional line number, selection, outlining, and word wrap glyph margins.
  • Indicators (bookmarks, breakpoints, current statement, etc.).
  • Ability to create custom margins and place them anywhere in the editor view.
  • Ability to inject any custom adornment elements into the text area surface, or even in-line between characters.
  • Fully compatible with XAML styles/templates.
  • Multiple font support.
  • Four-way or two-way split views.
  • Scrollbar visibility options.
  • Customizable scrollbar tray areas that allow for embedding of custom controls next to scrollbars.
  • Animated zoom in and out, with mouse wheel support.
  • Squiggle lines for marking errors and spelling mistakes.
  • Complete support for both automatic and manual code outlining (folding), with customizable outlining node options.
  • Collapse (hide) regions of text independently of the outlining feature.
  • Indentation guides.
  • Single-line editing mode.

Text/Parsing Framework Features

  • Complete separation of the document model from the user interface.
  • Documents keep track of text via thread-safe versioned snapshots.
  • Snapshots are immutable and can be examined without fear of them changing.
  • Text offsets can be translated between snapshots.
  • Text changes support batching of replace operations.
  • Powerful snapshot text scanning classes that allow scanning by character, text, token, etc.
  • Load and save files, track modified flag.
  • Language definitions that can wrap all editor and parsing functionality for a specific language.
  • Ability to create custom language definitions using the feature-rich Language Designer application.
  • Free sample language definitions for common languages like Assembly, Batch files, C, C#, C++, CSS, HTML, INI files, Java, JavaScript, Lua, Markdown, MSIL, Pascal, Perl, PHP, PowerShell, Python, RTF, Ruby, SQL, VB.NET, VBScript, and XML.
  • Lexing of text into tokens, via a "dynamic" regex pattern-based lexer, "programmatic" hand-coded lexers, or other custom options.
  • Multi-threaded parsing capabilities.
  • Code fragment editing with full IntelliPrompt, such as editing a method body, when using advanced languages.
  • Categorization of text ranges into classifications (used to drive features like syntax highlighting).
  • Tagging mechanism that allows for marking of text ranges with custom data.
  • Line commenting with line and range options.
  • Text formatting capabilities.
  • Export to HTML and RTF.

IntelliPrompt Features

  • Session-based IntelliPrompt object model.
  • Completion lists that improve editing productivity and support complete word functionality.
  • Completion lists support filters (tabs/buttons), multiple matching algorithm options, ability to create custom matching algorithms, matched text highlights, description tips, and much more.
  • Quick info tips that can show detailed information about what is under the mouse, with automated mouse hover tracking.
  • Parameter info tips that can show multiple signature overloads and track the current parameter.
  • Code snippets that allow pre-defined text fragments to be inserted into the editor, and declared fields edited.
  • Lazy load images and content used in IntelliPrompt popups.
  • Optional mini-HTML markup supported for popup content.
  • NavigableSymbolSelector control that provides functionality similar to the VS type/member drop-downs.

Printing Features

  • WYSIWYG printing with print-specific format settings.
  • Optional document title, line number, word wrap glyph, and page number margins.
  • Ability to create custom margins and place them anywhere in a printed page.

Searching (Find/Replace) Features

  • All standard options available including match case, match whole word, search up, search in selection, etc.
  • Search pattern options include normal, regular expression, wildcard, acronum, and shorthand.
  • Regular expression searches support captures/substitutions.
  • Custom search patterns can be created.
  • Incremental search mode that automatically searches the entire document as characters are typed.
  • In-line search result highlights.
  • EditorSearchView control that provides an implementation of a Visual Studio-like search dialog with animations.

Other Features

  • Designed to perform well with very large documents.
  • Support for read-only documents and specific text ranges within documents.
  • Macro recording and playback.
  • Text statistics that calculate statistics such as line, word, character counts as well as readability scores.
  • Custom input processing handlers that can intercept and handle key and mouse events.
  • Abstracted and extensible object model design.

Free Add-ons

  • Actipro's advanced LL(*) Parser Framework can be used to build custom grammar-based parsers written in C#/VB using EBNF-like notation, customizable AST construction, advanced error handling/reporting, easy code injection, a complete debugger UI, and much more.

Optional Premium Add-ons

  • .NET Languages Add-on that provides automated IntelliPrompt, code outlining, parsing, AST construction, syntax error reporting, and more for C# and Visual Basic documents.
  • Python Language Add-on that provides automated IntelliPrompt, code outlining, parsing, AST construction, syntax error reporting, and more for Python documents.
  • Web Languages Add-on that provides automated IntelliPrompt, code outlining, validation, formatting, and more for XML documents.
  • Web Languages Add-on also provides automated IntelliPrompt, code outlining, parsing, syntax error reporting, formatting, and more for JavaScript documents.
  • Web Languages Add-on also provides code outlining, parsing, syntax error reporting, formatting, and more for JSON documents.

Premium add-ons are sold separately from SyntaxEditor and its containing bundles.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

SyntaxEditor Reference
Getting Started

Although SyntaxEditor is a massive product, it is pretty simple to get up and running fast. Use the tips in this topic to get started.

This topic contains these sections:

  • Understanding Abstraction (Interfaces and Implementation)
  • Read the Documentation Topics
  • Examine the Sample QuickStarts
  • Learn Terms
  • Use the 'How To' Topic
  • Add Extension SDK Reference
  • Copy Code from the Sample Project
  • Premium Language Add-ons

Understanding Abstraction (Interfaces and Implementation)

The entire product has been abstracted out into an interface-based object model. This provides for a more open object model that can easily be extended in a number of places.

Most main namespaces in the product contain interfaces, enumerations, structs, and static classes. Classes, both constructable and abstract, that implement the interfaces can be found in Implementation child namespaces of the namespaces that define the related interfaces.

This information is vital to know when examining the class library or reading through these documentation topics.

Read the Documentation Topics

This documentation file contains a lot of information about working with SyntaxEditor and the text/parsing framework. Whenever you have specific questions about a feature, please read through its documentation topic to search for answers.

The documentation is organized such that the text/parsing framework is described first. This framework is the core of the product and the user interface is built around it. Thus the user interface is described after the text/parsing framework. A language creation guide is included to help walk you through the process of creating your own syntax languages.

Note Note
If you have read through the documentation topics and samples and have found that some information is not clear enough, please e-mail us. We want to continue to improve the documentation and samples over time to thoroughly cover all functionality found in this enormous product, and we certainly appreciate your feedback.

Examine the Sample QuickStarts

The sample project contains a lot of full source samples called QuickStarts that focus on specific feature areas. When learning about a certain feature, it's best to examine the documentation on the feature and also look at any related QuickStarts in the sample project.

The QuickStarts contain a wealth of information on almost every product feature area, so be sure to look at them while working with the documentation.

A 'Getting Started' series of QuickStarts is included in the sample project that shows how to build a robust syntax language from start to finish. It is an extremely valuable sample when starting to build your own syntax languages.

Learn Terms

The Term Definitions topic provides an extensive list of terms used in this product. If you ever wonder what a term means, check that list.

Use the 'How To' Topic

The How To... topic provides a great jump off point for where to find information on performing the most common tasks with SyntaxEditor. It's a great resource.

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Copy Code from the Sample Project

We encourage you to copy and use any code from our sample project, including sample language definitions. It will really help you implement features in a matter of minutes instead of hours.

Note Note
Please note that some images in the sample project are copyrighted by Microsoft and we include them in our sample project for control demonstration purposes only!

Premium Language Add-ons

If you are going to use one of our premium language add-ons (sold separately), it is vital to follow all the steps in their Getting Started topics to ensure they operate correctly:

  • C# syntax language in the .NET Languages Add-on
  • Visual Basic syntax language in the .NET Languages Add-on
  • XML syntax language in the Web Languages Add-on
  • JavaScript syntax language in the Web Languages Add-on

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Term Definitions

SyntaxEditor Reference
Term Definitions

SyntaxEditor is no small product. It has an enormous object model and feature set. While it's easy to get started using it, it also allows for developers to do some very advanced things.

In this topic, we provide the complete list of categorized terms found in this product. If you ever wonder what a term means, use this topic to find the definition.

This topic contains these sections:

  • Text (General) Terms
  • Text (Exporters) Terms
  • Text (Lexing) Terms
  • Text (Parsing) Terms
  • Text (Regular Expressions) Terms
  • Text (Searching) Terms
  • Text (Tagging) Terms
  • Text (Undo) Terms

Text (General) Terms

Term | Description
Case Sensitivity | Indicates how letter matching is performed when parsing, and is represented by the CaseSensitivity enumeration.
Classification Type | A classification type (represented by the IClassificationType interface) is a categorization that can be applied to a range of text via an IClassificationTag tagger.
Classification Type Registry | A classification type registry (represented by the IClassificationTypeRegistry interface) provides a registry of IClassificationType instances.
Code Document | A code document (represented by the ICodeDocument interface) is a text document that also has a syntax language associated with it, providing additional functionality.
Example Text Provider | An example text provider (represented by the IExampleTextProvider interface) is an object that can stores a small code snippet showing many of the constructs for a specific language.
Line Commenter | A line commenter (represented by the ILineCommenter interface) is an object that has logic to comment out and uncomment lines of code using comment delimiters for a specific language.
Line Terminator | Indicates the character or characters used to end a line, and is represented by the LineTerminator enumeration.
Normalized Text Snapshot Range Collection | A normalized text snapshot range collection (represented by the NormalizedTextSnapshotRangeCollection class) is a collection that ensures all contained ranges are for the same snapshot and are guaranteed to be sorted and non-overlapping.
Offset | An offset is a zero-based integer index that refers to the location of a character within text.
Syntax Language | A syntax language (represented by the ISyntaxLanguage interface) is an object that provides access to services and functionality related to the parsing of a code language, such as C#, VB, HTML, etc.
Text Buffer Reader | A text buffer reader (represented by the ITextBufferReader interface) allows you to do very low-level fast scanning over some sort of text source, such as a string or text snapshot.
Text Change | A text change (represented by the ITextChange interface) is a single transaction that modifies a document and creates a new text snapshot. It consists of one or more operations.
Text Change Operation | A text change operation (represented by the ITextChangeOperation interface) is a single atomic replace operation that is performed within a text change. It may replace text, delete text, or insert text.
Text Change Options | Text change options (represented by the ITextChangeOptions interface) provide configurable options to a text change.
Text Change Type | A text change type (represented by the ITextChangeType interface) represents the type of text change, such as Typing, Paste, etc. Custom types can be created.
Text Document

A text document (represented by the ITextDocument interface) represents a textual document.

It always keeps a reference to its current text snapshot. Use the current snapshot to examine the contents of the document.

Text Offset Tracking Mode | Text offset tracking modes (represented by the TextOffsetTrackingMode enumeration) indicate how an offset should be translated from one text snapshot to another.
Text Position | A text position (represented by the TextPosition structure) provides line and character information about a point in text.
Text Position Range | A text position range (represented by the TextPositionRange structure) represents a range of text positions, with a start and end value.
Text Range | A text range (represented by the TextRange structure) represents a range of offsets, with a start and end value.
Text Range Tracking Mode | Text range tracking modes (represented by the TextRangeTrackingModes enumeration) indicate how a text range should be translated from one text snapshot to another.
Text Snapshot

A text snapshot (represented by the ITextSnapshot interface) is an immutable copy of a document at a certain time. It can be scanned and parsed without the possibility of change via user edits.

All reading of a document is done on a snapshot of the document. The ITextDocument.CurrentSnapshot property always provides the most recent snapshot.

Text Snapshot Line | A text snapshot line (represented by the ITextSnapshotLine interface) represents a text line within a snapshot.
Text Snapshot Offset | A text snapshot offset (represented by the TextSnapshotOffset structure) points to a specific offset within a snapshot. It can be easily translated to other snapshots.
Text Snapshot Range | A text snapshot range (represented by the TextSnapshotRange structure) points to a specific text range within a snapshot. It can be easily translated to other snapshots.
Text Snapshot Reader | A text snapshot reader (represented by the ITextSnapshotReader interface) is used to scan through a specific snapshot and has many useful methods for navigating by token, word, etc.
Text Snapshot Reader Options | Text snapshot reader options (represented by the ITextSnapshotReaderOptions interface) provides configurable options to a text snapshot reader.
Text Statistics | Text statistics (represented by the ITextStatistics interface) examine text and provide numerous statistics on the text such as number of lines, characters, etc.
Text Version | A text version (represented by the ITextVersion interface) is a numeric version that tracks the sequence of changes made to a document. Each snapshot is related to a certain version.
Text Version Range | A text version range (represented by the ITextVersionRange interface) is an object that internally stores a text range for a certain text version. This version range can be translated to any other version or snapshot to get the related text range in that context.
Word-Break Finder | A word-break finder (represented by the IWordBreakFinder interface) is used to locate word breaks for a particular syntax language.

Text (Exporters) Terms

Term | Description
Text Exporter | A text exporter (represented by the ITextExporter interface) is an object that can export text to other output formats, such as HTML or RTF.

Text (Lexing) Terms

Lexer | A lexer (represented by the ILexer interface) scans text and tokenizes it, meaning that a series of tokens are assigned to text ranges that identifies in detail what the text represents.
Lexical Target | A lexical target (represented by the ILexerTarget interface) is an object that is passed to a lexer and is updated by the lexer during its execution to provide lexing results.
Lexical Scope | A lexical scope (represented by the ILexicalScope interface) defines how a parent lexical state can transition to another child lexical state and back.
Lexical State | A lexical state (represented by the ILexicalState interface) is a context in which certain text can be parsed into a set of tokens.
Lexical State ID Provider | A lexical state ID provider (represented by the ILexicalStateIdProvider interface) is a class that is useful for providing all the lexical state IDs for a language.
Lexical State Transition | A lexical state transition (represented by the ILexicalStateTransition interface) specifies a transition that can occur from one lexical state to another, typically in a separate language (i.e. HTML to CSS).
Mergable Lexer | A mergable lexer (represented by the IMergableLexer interface) is a lexer that supports transitioning into other languages that have mergable lexers.
Mergable Lexical Result | A mergable lexer result (represented by the MergableLexerResult class) provides information for the next token that has been read by a mergable lexer.
Mergable Token | A mergable token (represented by the IMergableToken interface) is a token that is created by a mergable lexer.
Mergable Token Lexer Data | Mergable token lexical parse data (represented by the IMergableTokenLexerData interface) is part of a mergable lexical parse result and gets assigned to mergable tokens.
Token | A token (represented by the IToken interface) is a span of text that has some sort of lexical parse data associated with it.
Token ID Provider | A token ID provider (represented by the ITokenIdProvider interface) is a class that is useful for providing all the token IDs for a language.
Token Set | A token set (represented by the ITokenSet interface) is a group of tokens that are returned by an token tagger.

Text (Parsing) Terms

Term | Description
Ambient Parse Request Dispatcher Provider | An ambient parse request dispatcher provider (represented by the AmbientParseRequestDispatcherProvider class) specifies an object that provides the default IParseRequestDispatcher to use, which allows for multi-threaded parsing.
Parse Data | Parse data (represented by the IParseData interface) specifies the data that is returned by an IParser to a document when parsing is completed.
Parse Error | A parse error (represented by the IParseError interface) specifies an error that was encountered when performing parsing.
Parse Error Level | A parse error level (represented by the ParseErrorLevel enumeration) specifies the severity of a parse error.
Parse Error Provider | A parse error provider (represented by the IParseErrorProvider interface) specifies an object that can return parse errors for a parsing operation. This interface is typically implemented by parse data objects.
Parser | A parser (represented by the IParser interface) specifies an object that can perform syntax and/or semantic parsing.
Parse Request | A parse request (represented by the IParseRequest interface) specifies an object that designates a request for a parsing operation, and can be queued by a parse request dispatcher
Parse Request Dispatcher | A parse request dispatcher (represented by the IParseRequestDispatcher interface) specifies an object that is capable of queuing up parse requests and performing them on worker threads.
Parse Error State | A parse error state (represented by the ParseRequestState enumeration) specifies the current state of a parse request, such as whether it is queued, executing, etc.
Parse Target | A parse target (represented by the IParseTarget interface) specifies an object that is notified with parse data results when a parsing operation completes.

Text (Regular Expressions) Terms

Term | Description
Character Class | A character class (represented by the CharClass class) specifies a set of character ranges.
Character Interval | A character interval (represented by the CharInterval structure) specifies a range of characters.

Text (Searching) Terms

Term | Description
Search Capture | A search capture (represented by the ISearchCapture interface) denotes a single regular expression capture made during a find operation.
Search Options | Search options (represented by the ISearchOptions interface) contains the settings used during find/replace operations, such as the text to find, whether to match case, etc.
Search Pattern Provider | A search pattern provider (represented by the ISearchPatternProvider interface) is an object that converts find/replace pattern syntax to a format that is compatible with the search engine. Built-it search pattern providers include normal, regular expression, wildcard, etc.
Search Result | A search result (represented by the ISearchResult interface) is a single result from a search operation that is included within a result set.
Search Result Set | A search result set (represented by the ISearchResultSet interface) is an object that provides the results of a search operation.
Search Operation Type | Indicates a type of search operation, such as find next or replace all, and is represented by the SearchOperationType enumeration.

Text (Tagging) Terms

Term | Description
Classification Tag | A classification tag (represented by the IClassificationTag interface) is a tag that specifies an IClassificationType, and when used in an editor, tells the editor how to syntax highlight text based on related highlighting styles.
Tag | A tag (represented by the ITag interface) is an object that can store data and be applied over a range of text via a tagger.
Tag Aggregator | A tag aggregator (represented by the ITagAggregator`1 interface) collects tags of a certain type from all the available taggers.
Tag Snapshot Range | A tag snapshot range (represented by the TagSnapshotRange`1 structure) specifies a text snapshot range and an ITag that is applied over the range.
Tag Version Range | A tag version range (represented by the TagVersionRange`1 structure) specifies a text version range and an ITag that is applied over the range.
Tagger | A tagger (represented by the ITagger`1 interface) provides tag snapshot ranges that are within specified snapshot ranges.
Tagger Provider | A tagger provider (represented by the ICodeDocumentTaggerProvider and ITextViewTaggerProvider interfaces) is a language service that can create taggers for documents/views that use the language.
Token Tag | A token tag (represented by the ITokenTag interface) is a tag that specifies an IToken.
Token Tagger | A token tagger (represented by the TokenTagger interface) is a special tagger that provides incremental lexing capabilities to an ILexer.

Text (Undo) Terms

Term | Description
Save Point Change Type | Indicates the save point change type (none, unsaved changes, or saved changes) for a line within the current snapshot of a document, and is represented by the SavePointChangeType enumeration.
Undoable Text Change | An undoable text change (represented by the IUndoableTextChange interface) is used to track information for an ITextChange that has been placed into the undo history.
Undoable Text Change Stack | An undoable text change stack (represented by the IUndoableTextChangeStack interface) is a stack that stores IUndoableTextChange entries for either the undo or redo stacks.
Undo History | An undo history (represented by the IUndoHistory interface) provides access to all the undo/redo functionality for an ITextDocument.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


How To...

SyntaxEditor Reference
How To...

Since the documentation for SyntaxEditor is quite large, this topic provides a quick jump off point for the most common tasks of working with the product.

This topic contains these sections:

  • Text Features
  • Parsing Features
  • IntelliPrompt Features

Text Features

How to get text from a document?

Immutable snapshots are what store the text for a document. Each ITextDocument points to its current text content via the CurrentSnapshot property.

The Documents, Snapshots, and Versions topic talks about some basic methods for getting the full text or substrings from a snapshot.

The Scanning Text Using a Reader topic talks about more advanced scanning of a snapshot's text, characters, tokens, and more.

How to make changes to a document?

Text changes can be made using a couple different methods, both described in the Text Changes and Operations topic. Batch changes that are flagged as a single undoable unit are fully supported.

How to load a document from or save a document to a file/Stream?

The text content of an ITextDocument can easily be saved to a file or Stream via methods described in the Loading and Saving Files topic.

How to convert between offsets and text positions?

The Offsets, Ranges, and Positions topic describes all the types of character indices used by the text framework and how to convert between them.

Why are offsets that I externally found not syncing up with document offsets?

Normal multi-line strings in Windows use both carriage return and newline characters as line terminators. When ITextDocument objects load text, they convert all line terminators to newline characters only. This helps with parsing performance.

The Line Terminators topic talks about why this is done and how to get document text back out using any common line terminator.

How to programmatically find and replace text?

The Low-Level Search Operations topic describes how to programmatically find/replace text using the lowest-level search object model.

How to perform an undo or redo?

The Undo History topic describes how to perform an undo or redo operation.

How to obtain statistics for snapshot text or a string?

The Text Statstics topic shows how to easy obtain a wealth of statistics about snapshot text or text within a String.

How to export a snapshot's text to HTML or RTF?

The Exporting to HTML / RTF topic describes how to export a snapshot's text to HTML or RTF format.

Parsing Features

How to comment or uncomment text in a document?

The Line Commenting topic demonstrates how to comment or uncomment text.

IntelliPrompt Features

How to display a completion list in response to the end user typing a '.', '<', etc.?

The Completion List topic contains several samples on how to display a completion list in response to user typing.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Assemblies and Add-on Licensing

SyntaxEditor Reference
Assemblies and Add-on Licensing

SyntaxEditor is a bit unique in relation to our other Universal Windows control products in that it requires several assemblies depending on which features and add-ons you use.

This topic contains these sections:

  • What is an Add-on?
  • Add-on Packaging
  • Assemblies and Cost

What is an Add-on?

An add-on is simply a term used to describe some sort of functionality that can optionally be added onto the main product.

Add-ons may include very advanced syntax language implementations that have features such as automated IntelliPrompt, etc. These sorts of add-ons are generally sold separately from SyntaxEditor or its containing bundles.

Add-on Packaging

Add-ons can come in one or more assemblies. Often add-ons for a syntax language implementation involve two assemblies. One contains the core text/parsing (non-UI) implementation for language and the other provides UI-related functionality such as working with IntelliPrompt.

The reason add-on assemblies are split up in this way is that we have designed this SyntaxEditor framework to be multi-platform capable. This means that the core text/parsing assembly could be used in WPF, Windows Forms, ASP.NET, etc. Then each platform would have their own UI-related assembly that interacted with the user interface.

Assemblies and Cost

This list of assemblies indicates all of the assemblies related to SyntaxEditor, if they are required or optional, the related add-on (if any), and if they are included for free or sold separately from SyntaxEditor and its containing bundles.

Assembly | Required | Add-on | Cost | Description
ActiproSoftware.Shared.Universal.dll | Yes | - | Included | Core framework for all Actipro Universal Windows controls
ActiproSoftware.Text.Universal.dll | Yes | - | Included | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Universal.dll | Yes | - | Included | Framework for building top-down text parsers that parse input left-to-right and construct a leftmost derivation.
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | - | Included | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.DotNet.Universal.dll | No | .NET Languages | Sold Separately | Core text/parsing for .NET languages
ActiproSoftware.SyntaxEditor.Addons.DotNet.Universal.dll | No | .NET Languages | Sold Separately | SyntaxEditor for Universal Windows advanced C# and VB syntax language implementations
ActiproSoftware.Text.Addons.JavaScript.Universal.dll | No | Web Languages | Sold Separately | Core text/parsing for the JavaScript and JSON languages
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Universal.dll | No | Web Languages | Sold Separately | SyntaxEditor for WPF advanced JavaScript and JSON syntax language implementations
ActiproSoftware.Text.Addons.Python.Universal.dll | No | Python Language | Sold Separately | Core text/parsing for the Python language
ActiproSoftware.SyntaxEditor.Addons.Python.Universal.dll | No | Python Language | Sold Separately | SyntaxEditor for WPF advanced Python syntax language implementation
ActiproSoftware.Text.Addons.Xml.Universal.dll | No | Web Languages | Sold Separately | Core text/parsing for the XML language
ActiproSoftware.SyntaxEditor.Addons.Xml.Universal.dll | No | Web Languages | Sold Separately | SyntaxEditor for Universal Windows advanced XML syntax language implementation

Although the add-ons that are marked as sold separately are included with the Universal Windows controls sample for demo purposes, licenses for them must be purchased separately if you would like to use them. However, the pricing on the add-ons is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Text/Parsing Framework
Overview

The text and parsing framework included with this product provide for complete separation from the user interface and can be reused across mutiple platforms.

This topic contains these sections:

  • Core Text Features
  • Syntax Languages
  • Lexing
  • Tagging
  • Parsing
  • Advanced Text Features

Core Text Features

The core text features presented in this portion of the documentation are essential knowledge for working with nearly every other portion of the product.

See the Core Text Features topic for more information.

Syntax Languages

Syntax languages are objects that provide access to services and functionality related to the parsing of a code language, such as C#, VB, HTML, etc.

See the Syntax Languages topic for more information.

Lexing

Lexing is the process of scanning text and breaking it up into meaningful tokens that can be examined by a higher-level parser.

See the Lexing topic for more information.

Tagging

Tagging is a generic mechanism that allows any sort of data to be associated with a text range. This tagged data can then be retrieved on-demand by tag aggregators. Tagging is the core mechanism behind features such as tokenization, classification (which in turn drives syntax highlighting when used in an editor), and more.

See the Tagging topic for more information.

Parsing

Parsing is the process of performing syntax and/or semantic analysis on a text, and outputting some sort of parse data, generally an AST. The parsing framework supports automated calling of parsers via worker threads following text changes. Any custom or third-party parser can be called.

See the Parsing topic for more information.

Advanced Text Features

The text framework contains numerous advanced features that build upon the core text features, everything from a search object model to the exporting of HTML and RTF.

See the Advanced Text Features topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Text/Parsing Framework - Core Text Features
Overview

The core text features presented in this portion of the documentation are essential knowledge for working with nearly every other portion of the product.

This topic contains these sections:

  • Documents, Snapshots, and Versions
  • Offsets, Ranges, and Positions
  • Line Terminators
  • Snapshot Translation
  • Text Changes and Operations
  • Scanning Text Using a Reader
  • Loading and Saving Files

Documents, Snapshots, and Versions

Documents, snapshots, and versions are used to store text data. Documents allow for text updates, while a snapshot provides an immutable view of text within a document for a certain version that can be read.

See the Documents, Snapshots, and Versions topic for more information.

Offsets, Ranges, and Positions

There are several ways to reference the location of characters within a string or snapshot, each with their own benefits.

See the Offsets, Ranges, and Positions topic for more information.

Line Terminators

While the text framework can load text using any sort of standard line terminator character sequence, the framework internally tracks all line terminators as a single line feed character. Text can easily be exported back out with any line terminator.

See the Line Terminators topic for more information.

Snapshot Translation

Offsets and offset ranges can be translated from one snapshot to another using a feature called snapshot translation. Snapshots are immutable views of a document and are able to determine the changes made between any two snapshots for the same document. This allows for the locating of a certain offset or range of text in the current snapshot based on some offset/range created using an older snapshot, even with mutiple document changes being made in between the two snapshots.

See the Snapshot Translation topic for more information.

Text Changes and Operations

A large portion of the text framework is focused on the ability to make changes to document text. Multiple individual replace transactions, called text change operations, can be batched up into a single text change and performed together as a single modification.

See the Text Changes and Operations topic for more information.

Scanning Text Using a Reader

The text framework has very robust features built-in for scanning through snapshot text via the use of readers.

See the Scanning Text Using a Reader topic for more information.

Loading and Saving Files

It's very easy to load document text from a file, stream, or string. Likewise, document text can be saved back out to a file, stream, or string.

See the Loading and Saving Files topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Documents, Snapshots, and Versions

Text/Parsing Framework - Core Text Features
Documents, Snapshots, and Versions

Documents, snapshots, and versions are used to store text data. Documents allow for text updates, while a snapshot provides an immutable view of text within a document for a certain version that can be read.

This topic contains these sections:

  • Looking at a Document's Current Text Data
  • Object Relationships
  • Memory Usage and Performance
  • Reading Text, Use Snapshots
  • Writing Text, Use Document
  • Multiple Snapshots and Snapshot Translation

Looking at a Document's Current Text Data

The ITextDocument interface has a CurrentSnapshot property that returns the "current" ITextSnapshot for the document.

Think of ITextSnapshot objects like .NET strings. They are immutable, meaning their contents cannot be changed, and they can be used across threads. Therefore you are able to examine and parse a snapshot without fear of its contents changing from some other operations in a separate thread.

There are multiple ways to examine text in a snapshot, some of the most common are described below.

Object Relationships

ITextDocument objects only store a reference to the "current" ITextSnapshot, meaning the snapshot the specifies the text contents of the document at this point in time.

Each snapshot is related to a single version. Therefore, each ITextSnapshot has a Version property that returns a reference to its ITextVersion. The ITextVersion has a version number.

A sequence of text changes made, showing how new snapshots and versions are created

As changes are made to a document, new snapshots and related versions are created. For instance a blank document would have a current snapshot with version 0. If the text "Actipro" was appended to the document, it would now have a current snapshot with version 1. If the first three characters were removed, the document would now have a current snapshot with version 2. And so on.

Essentially, the version increments with any change and provides the data needed for snapshot translation. Each snapshot references a single version and the snapshot contains a complete immutable copy of the text that is related to the version.

Memory Usage and Performance

After reading above that every change creates a completely new immutable copy of the document text in a snapshot, it would be conceivable to think that memory usage would be enormous and performance would suffer, especially for large documents.

Actually this is not the case at all. Snapshots are designed to share data as much as possible that is not different between consecutive snapshots. Besides that, once a snapshot is no longer referenced by your code, it and its contents drop out of memory. Therefore there really isn't much of a memory impact by adding the great features provided by snapshots.

It's also important to mention that snapshots and their creation are designed to be very fast. There is no performance decrease by using them.

Reading Text, Use Snapshots

Whenever you need to read or examine the contents of a document, get the ITextDocument.CurrentSnapshot and use the snapshot's various properties and methods.

These members on ITextSnapshot are related to reading text:

Member | Description
GetReader Method | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
GetSubstring Method | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
GetText Method | Returns the entire text of the snapshot using the specified LineTerminator for line ends.
GetWordText Method | Gets the text of the word at the specified offset.
Length Property | Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.
Lines Property | Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.
Text Property | Gets the entire text of the snapshot using LineTerminator.CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.

Writing Text, Use Document

Whenever making text changes to a document, thereby creating a new snapshot, use methods on the ITextDocument interface.

The Text Changes and Operations topic talks about making text changes in details. See that topic for information on modifying a document.

Multiple Snapshots and Snapshot Translation

As displayed by the diagram above, multiple snapshots can be active for a document at any given time. Sometimes it's useful to store an offset range of text that was parsed from a particular snapshot and at some later arbitrary time, see where the same range is in the "current" snapshot for a document.

This can easily be done and is really a neat feature provided by the snapshot/version design. See the Snapshot Translation topic for more information on doing this.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Offsets, Ranges, and Positions

Text/Parsing Framework - Core Text Features
Offsets, Ranges, and Positions

There are several ways to reference the location of characters within a string or snapshot, each with their own benefits.

This topic contains these sections:

  • Offsets
  • Text Ranges
  • Text Positions
  • Text Position Ranges
  • Converting Between Offsets and Text Positions
  • Snapshot Offsets
  • Snapshot Ranges
  • Normalized Snapshot Range Collection
  • Version Ranges

Offsets

Offsets are zero-based integer numbers indicating a character index from the beginning of a string or snapshot.

The first character in a document is at index 0. The offset past the last character in a snapshot can be retrieved via the ITextSnapshot.Length property.

Text Ranges

It is often necessary to work with an ordered pair of offsets. For instance when getting a substring of text in a snapshot, you need to pass the offset range to obtain.

The TextRange structure represents an ordered pair of two offsets. It has many methods for comparing the range with other offsets and ranges.

To create a text range that spans 2 characters starting at offset 3, you'd create a text range with start offset 3 and end offset 5. Note that the end offset is the offset after the last character encapsulated by the range.

C#
VB
Copy
​TextRange range = new TextRange(3, 5);
​Dim range As TextRange = New TextRange(3, 5)

This code creates a TextRange with the same offset values but creates it using start offset and length combinations instead.

C#
VB
Copy
​TextRange range = TextRange.FromSpan(3, 2);
​Dim range As TextRange = TextRange.FromSpan(3, 2)

Text Positions

TextPosition structures are similar to offsets in that they indicate a certain character within a string or snapshot. However they work in terms of a line index and a character index within that line.

The Line and Character values of text positions are zero-based so a text position representing line index 1 and character 7 references the eighth character on the second line in the text.

This code creates a TextPosition with line index 1 and character 7:

C#
VB
Copy
​TextPosition position = new TextPosition(1, 7);
​Dim position As TextPosition = New TextPosition(1, 7)

Text Position Ranges

Similar to how TextRange provides a range of offsets, the TextPositionRange structure provides a range of TextPosition objects.

This code creates a TextPositionRange from position (1,7) to (2,3):

C#
VB
Copy
​TextPositionRange positionRange = new TextPositionRange(1, 7, 2, 3);
​Dim positionRange As TextPositionRange = New TextPositionRange(1, 7, 2, 3)

Converting Between Offsets and Text Positions

Sometimes it's useful to convert between offsets and text positions. Likewise, conversion between text ranges and text positions is possible.

These members in the ITextSnapshot inteface allow for conversion:

Member | Description
OffsetToPosition Method | Returns the TextPosition that represents the specified offset within the text lines.
PositionRangeToTextRange Method | Returns the TextRange that represents the specified TextPositionRange within the snapshot.
PositionToOffset Method | Returns the offset for the specified TextPosition within the text lines.
TextRangeToPositionRange Method | Returns the TextPositionRange that represents the specified TextRange within the snapshot.

Snapshot Offsets

The TextSnapshotOffset structure is a bit more advanced than a simple offset or TextPosition. It stores a reference to a particular location within an ITextSnapshot and provides access to the offset or TextPosition of that location.

The root ITextSnapshot and the ITextSnapshotLine that contains the snapshot offset are accessible from the snapshot offset.

This code creates a TextSnapshotOffset at offset 5 within the document's current ITextSnapshot:

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = new TextSnapshotOffset(document.CurrentSnapshot, 5);
​Dim snapshotOffset As TextSnapshotOffset = New TextSnapshotOffset(document.CurrentSnapshot, 5)

Snapshot offsets can be translated to another snaphot. Details on this are available in the Snapshot Translation topic.

Snapshot Ranges

The TextSnapshotRange structure is similar to a TextSnapshotOffset in that it references a specific ITextSnapshot. The different is that it tracks two normalized locations within the snapshot.

Accordingly, it can do additional things like return the text contained within the range, give the offset/text positions of the start/end, etc.

To create a snapshot range that spans 2 characters starting at offset 3, you'd create a snapshot range with start offset 3 and end offset 5. Note that the end offset is the offset after the last character encapsulated by the range.

C#
VB
Copy
​TextSnapshotRange snapshotRange = new TextSnapshotRange(document.CurrentSnapshot, 3, 5);
​Dim snapshotRange As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 3, 5)

This code creates a TextSnapshotRange with the same offset values but creates it using start offset and length combinations instead.

C#
VB
Copy
​TextSnapshotRange snapshotRange = TextSnapshotRange.FromSpan(document.CurrentSnapshot, 3, 2);
​Dim snapshotRange As TextSnapshotRange = TextSnapshotRange.FromSpan(document.CurrentSnapshot, 3, 2)

Snapshot ranges can be translated to another snaphot. Details on this are available in the Snapshot Translation topic.

Normalized Snapshot Range Collection

The NormalizedTextSnapshotRangeCollection class provides a collection implementation that normalizes all of its contained TextSnapshotRange objects.

This means that snapshot ranges in the collection are guaranteed to:

  • All be based on the same ITextSnapshot.
  • Be in sequential order by start offset.
  • Not overlap (overlapping snapshot ranges are merged when the collection is built).

Version Ranges

As described in the Documents, Snapshots, and Versions topic, text versions are placeholders that provide the core functionality needed to link snapshots together and support features like Snapshot Translation.

The ITextVersionRange interface designates an object that can refer to a text range within an ITextVersion. By itself, the ITextVersionRange object is not very useful since it doesn't provide direct access to the text range data. It also holds no references to any text snapshots, which makes it very lightweight.

The nice thing about version ranges though is that they are a lightweight reference to a text range that can be easily translated to any snapshot range or other text range in a specific text version. This makes them ideal for use in scenarios where you wish to store a version-oriented range for a long period of time, without needing to retain the related snapshot in memory.

Version ranges can be created with the various ITextVersion.CreateRange methods.

C#
VB
Copy
​ITextVersionRange versionRange = document.CurrentSnapshot.Version.CreateRange(1, 3);
​Dim versionRange As ITextVersionRange = document.CurrentSnapshot.Version.CreateRange(1, 3)

Version ranges can be translated to any snapshot for the same document:

C#
VB
Copy
​TextSnapshotRange snapshotRange = versionRange.Translate(document.CurrentSnapshot);
​Dim snapshotRange As TextSnapshotRange = versionRange.Translate(document.CurrentSnapshot)

Version ranges also can be translated to a text range for particular lightweight ITextVersion that is also from the same document.

C#
VB
Copy
​TextRange range = versionRange.Translate(document.CurrentSnapshot.Version);
​Dim range As TextRange = versionRange.Translate(document.CurrentSnapshot.Version)

Another way a version range can be created is from a TextSnapshotRange:

C#
VB
Copy
​ITextVersionRange versionRange = snapshotRange.ToVersionRange(TextRangeTrackingModes.Default);
​Dim versionRange As ITextVersionRange = snapshotRange.ToVersionRange(TextRangeTrackingModes.Default)

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Terminators

Text/Parsing Framework - Core Text Features
Line Terminators

While the text framework can load text using any sort of standard line terminator character sequence, the framework internally tracks all line terminators as a single line feed character. Text can easily be exported back out with any line terminator.

This topic contains these sections:

  • Standard Line Terminators
  • Why Does the Framework Only Track Line Feeds?
  • Impact on Offsets
  • The ITextSnapshot.Text and GetSubstring Members
  • Getting Text and Substrings with a Specific Line Terminator

Standard Line Terminators

The standard line terminators are:

  • Carriage return followed immediately by a newline (CR/LF)
  • Carriage return only (CR)
  • Newline only (LF)

Standard line terminators can be specified by the LineTerminator enumeration.

Why Does the Framework Only Track Line Feeds?

As mentioned above, it is important to know that when text added to an ITextDocument, it is converted so that the internal buffer stores the text using a single line feed character for denoting line terminators, regardless of what sort of line terminator was originally used.

The main reason for doing this is for performance when parsing. If we didn't store line terminators this way, any parsing code would require more complicated and time consuming procedures to be looking for carriage return characters, line feed characters, or potentially both at each line terminator. Using a single LF character makes it easy for parsing to perform quickly and efficiently since we know which specific single character denotes the end of a line.

Note Note
Since text is tracked internally using only line feeds, see the following sections for information on how to retrieve text back out of the text framework with specific line terminators.

Impact on Offsets

An offset is the zero-based index of a character within text. Sometimes you may have scanned some text that has CR/LF endings and saved a character range. Then you passed the text into a document and tried to get the substring of the range. What you'd find is that the returned text is not what you expected.

A simple diagram will illustrate why. Say your text string was:

Code Snippet
Copy
int a;
int b;

In a string with a CR/LF line terminator, the b character would be located at offset 12 like in the diagram below.

The top character sequence showing original text, the bottom showing how it is stored in documents

The bottom part of the diagram shows how an ITextDocument would convert the text to LF line terminators. You can see how offset 12 now points to the semi-colon character instead.

To work around this issue, use the text framework to determine your offsets once it's in a document.

Note Note
If you will be doing any external parsing, use the GetText method (described below) to retrieve the text with LF-only format so the offsets remain in sync.

The ITextSnapshot.Text and GetSubstring Members

The ITextSnapshot.Text property and GetSubstring method both return text back out with CR/LF format.

Since those properties are generally accessed when getting text and using it in other places within your application, they return the Windows default line terminator, which is CR/LF.

Getting Text and Substrings with a Specific Line Terminator

Since the two members above return text using CR/LF, sometimes you need to get the text with LF-only or CR-only. To do this, you can use the GetText method and the GetSubstring method overload that accepts a LineTerminator parameter.

Both of those methods allow you to obtain the text with any line terminator that you specify.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Snapshot Translation

Text/Parsing Framework - Core Text Features
Snapshot Translation

Offsets and offset ranges can be translated from one snapshot to another using a feature called snapshot translation. Snapshots are immutable views of a document and are able to determine the changes made between any two snapshots for the same document. This allows for the locating of a certain offset or range of text in the current snapshot based on some offset/range created using an older snapshot, even with mutiple document changes being made in between the two snapshots.

Note Note
See the Documents, Snapshots, and Versions topic for a basic overview on snapshots and how different snapshots relate to each other wihin a document.

This topic contains these sections:

  • Scenario 1: Threaded Parsing
  • Scenario 2: Text Range Results
  • Storing Results in Preparation for a Translation
  • Offset Translation
  • Text Range Translation

Scenario 1: Threaded Parsing

Say you start some time-consuming parsing on the most current snapshot, which we'll call snapshot 1. While the parsing is executing in a separate thread on snapshot 1, more text changes in the document are made, bringing us to what we'll call snapshot 2. Then assume snapshot 1's parsing completes and returns an AST of the document.

All the offsets for the AST are based on the text found in snapshot 1. Since snapshot 2 is the the most current snapshot, the offsets for the AST are most likely incorrect by some delta amount since they were not based on snapshot 2.

The text framework can translate offsets from one snapshot to another, taking any text changes into account. So if we were editing a document in an editor and wanted to jump directly to a class name whose offset we know from the AST based on snapshot 1, we can translate the offset from snapshot 1 to the current snapshot (snapshot 2), and move the editor's caret right to the translated offset.

Scenario 2: Text Range Results

Another common scenario where snapshot translation is useful is when working with some sort of parsing result set.

Say you do a "find all" operation on a snapshot and list the replace locations in a ListBox. By tracking a TextSnapshotRange for each result, you could move directly to the found text on double-clicks by translating the clicked range to the current snapshot, even after multiple edits have been made following the find all operation.

Storing Results in Preparation for a Translation

The TextSnapshotOffset and TextSnapshotRange structures can both be used to translate offsets/ranges.

TextSnapshotOffset stores an offset and references a particular ITextSnapshot. Likewise, TextSnapshotRange stores a text range and references a particular ITextSnapshot.

Both have TranslateTo methods that are used to translate the offset/range to a new ITextSnapshot.

When persisting results related to a parse operation, such as in the two scenarios above, there are a couple recommended options. The first options is to directly use TextSnapshotOffset and TextSnapshotRange instances to store the data. Alternatively, if you have some sort of result set, have the root result set store the ITextSnapshot from which the results were found and use integer offsets or TextRange structures to store the individual results. With this approach, you can use the ITextSnapshot and offset/range to create TextSnapshotOffset and TextSnapshotRange instances as needed.

Offset Translation

The TextSnapshotOffset structure provides functionality for translating an offset from one snapshot to another. By calling the TranslateTo method, a new TextSnapshotOffset can be retrieved, indicating the offset value within the target ITextSnapshot.

The TranslateTo method accepts two parameters: the target ITextSnapshot, and a TextOffsetTrackingMode value.

The tracking mode indicates how the offset tends to move when text changes are made next to or surrounding it, between the original snapshot and the target snapshot. See the TextOffsetTrackingMode enumeration documentation for details on available values.

This code shows how to translate an offset to a new snapshot after changes are made to the document:

C#
VB
Copy
​TextSnapshotOffset offset = new TextSnapshotOffset(document.CurrentSnapshot, 10);
// Document changes made here, meaning new snapshots are created
TextSnapshotOffset translatedOffset = offset.TranslateTo(document.CurrentSnapshot, TextOffsetTrackingMode.Negative);
​Dim offset As TextSnapshotOffset = New TextSnapshotOffset(document.CurrentSnapshot, 10)
' Document changes made here, meaning new snapshots are created
Dim translatedOffset As TextSnapshotOffset = offset.TranslateTo(document.CurrentSnapshot, TextOffsetTrackingMode.Negative)

A TextSnapshotOffset can be marked as "deleted" via its IsDeleted property. The Deleted static property provides access to an instance of the structure that has been marked "deleted". This variation of the offset may be useful when you wish to flag that some edit operation removed the range that contained the offset.

Text Range Translation

The TextSnapshotRange structure provides functionality for translating an offset range (or TextRange) from one snapshot to another. By calling the TranslateTo method, a new TextSnapshotRange can be retrieved, indicating the offset range within the target ITextSnapshot.

The TranslateTo method accepts two parameters: the target ITextSnapshot, and a TextRangeTrackingModes value.

The tracking modes indicates how the range tends to update when text changes are made next to or surrounding it, between the original snapshot and the target snapshot. See the TextRangeTrackingModes enumeration documentation for details on available values.

This code shows how to translate a text range to a new snapshot after changes are made to the document:

C#
VB
Copy
​TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 10, 15);
// Document changes made here, meaning new snapshots are created
TextSnapshotRange translatedRange = range.TranslateTo(document.CurrentSnapshot, TextRangeTrackingModes.Default);
​Dim offset As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 10, 15)
' Document changes made here, meaning new snapshots are created
Dim translatedRange As TextSnapshotRange = range.TranslateTo(document.CurrentSnapshot, TextRangeTrackingModes.Default)

When translating a TextSnapshotRange, it is possible that the resulting range no longer exists. For example, this coudl happen if the user deleted the line that contained the range. In these cases, then IsDeleted property may be set to true, depending on which tracking mode options were used.

Note Note
The TextSnapshotRange.IsDeleted static property provides access to an instance of the structure that has been marked "deleted".

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Scanning Text Using a Reader

Text/Parsing Framework - Core Text Features
Scanning Text Using a Reader

The text framework has very robust features built-in for scanning through snapshot text via the use of readers.

This topic contains these sections:

  • ITextBufferReader vs. ITextSnapshotReader
  • Getting an ITextSnapshotReader for a Snapshot
  • Getting an ITextBufferReader for a Snapshot
  • Notes on Performance
  • ITextSnapshotReader Options
  • Getting an ITextBufferReader for a String
  • Getting a System.IO.TextReader for an ITextBufferReader

ITextBufferReader vs. ITextSnapshotReader

There are two types of readers included with the text framework: ITextBufferReader and ITextSnapshotReader.

ITextBufferReader

ITextBufferReader provides a very fast, low-level interface for scanning through text. It reads character-by-character, but does allow for jumping to a specific offset.

The current character's value, offset, and TextPosition can be retrieved at any time. This interface also has some help methods like ReadThrough, that advance the reader until it encounters and passes a particular character.

Please see the ITextBufferReader members list in the class library to see what scanning features are available for use.

ITextSnapshotReader

ITextSnapshotReader is a higher-level interface for scanning through text, and is made specifically for reading an ITextSnapshot instance. It internally uses a ITextBufferReader but wraps the core buffer reader with a ton of extended functionality.

A snapshot reader can return the current character, offset, TextPosition, current IToken, current token text, current ITextSnapshotLine, and more.

It has a large number of helper methods for navigating through text, such as ReadToken, GoToNextTokenWithId, etc.

Please see the ITextSnapshotReader members list in the class library to see what scanning features are available for use.

Getting an ITextSnapshotReader for a Snapshot

To get an ITextSnapshotReader for an ITextSnapshot, call the ITextSnapshot.GetReader method.

There are two overloads for this method. Each accept a parameter indicating to where in the snapshot the reader should be initialized. The first overload accepts an offset and the second accepts a TextPosition.

This code retrieves an ITextSnapshotReader for the current text in a document, starting at offset 0:

C#
VB
Copy
​ITextSnapshotReader reader = document.CurrentSnapshot.GetReader(0);
​Dim reader As ITextSnapshotReader = document.CurrentSnapshot.GetReader(0)

Getting an ITextBufferReader for a Snapshot

As mentioned above, the ITextSnapshotReader implementations use a core ITextBufferReader instance. So once you have an ITextSnapshotReader instance via the code in the previous section, simply use its BufferReader property to return the wrapped ITextBufferReader.

This code retrieves an ITextBufferReader from the reader defined above:

C#
VB
Copy
​ITextBufferReader bufferReader = reader.BufferReader;
​Dim bufferReader As ITextBufferReader = reader.BufferReader

Notes on Performance

If you only need to do core character scanning for a snapshot, use an ITextBufferReader. It is the most low-level reader available and therefore has the fastest performance.

You also can do basic text/character scanning with an ITextSnapshotReader. This will incur a negligible performance loss since all of those members essentially just call members on the core ITextBufferReader.

Performance, while still fast, will be lessened a little when using the various members on ITextSnapshotReader that deal with tokens and token scanning. Any of these methods do additional work to ensure that tokens are in sync with the reader. However overall they should still perform fast, as this is a common usage for readers.

The ITextSnapshotReader.Options property allows you to customize some optimizations used for token scanning to aid in performance. Since tokens are virtualized in the text/parsing framework, tweaking these options to best fit your scenario can make a difference in scanning performance. The following section describes the options.

ITextSnapshotReader Options

The ITextSnapshotReader interface has an Options property that allows you to modify the options for the reader instance. The options are of type ITextSnapshotReaderOptions and must be changed prior to using any members on the reader, if you are changing the options.

The options are mainly used to configure optimizations for token scanning, since tokens are virtualized in the text/parsing framework. If you will not be doing token scanning with yoru reader, you do not need to change the options. Even if you are doing token scanning, you can optionally leave the default options if you wish.

The options basically deal with how large of a block of tokens to load up, both initially and afterward, when scanning through text. They also let you indicate whether you primarily plan on scanning forward, backward, or both.

Please see the ITextSnapshotReaderOptions members list in the class library to see what options available for use.

Getting an ITextBufferReader for a String

The StringTextBufferReader class is an implementation of ITextBufferReader that operates on a string.

This code creates a StringTextBufferReader for a string:

C#
VB
Copy
​StringTextBufferReader bufferReader = new StringTextBufferReader("Text to read");
​Dim bufferReader As StringTextBufferReader = New StringTextBufferReader("Text to read")

Getting a System.IO.TextReader for an ITextBufferReader

The ITextBufferReader.AsTextReader method can be used to create a System.IO.TextReader instance.

System.IO.TextReader objects are defined in the core .NET framework and are useful for passing to various external components that are based on text readers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Changes and Operations

Text/Parsing Framework - Core Text Features
Text Changes and Operations

A large portion of the text framework is focused on the ability to make changes to document text. Multiple individual replace transactions, called text change operations, can be batched up into a single text change and performed together as a single undoable modification.

This topic contains these sections:

  • Text Changes vs. Text Change Operations
  • Text Change Types
  • Single vs. Multiple Operation Text Changes
  • Single-Operation Text Changes
  • Multiple-Operation Text Changes
  • Text Change Options
  • Offset Deltas
  • Auto Character Casing

Text Changes vs. Text Change Operations

Text changes, represented by the ITextChange interface, consist of one or more text change operations. Each text change is considered a single undoable modification.

A text change operation, represented by the ITextChangeOperation interface, is a single replace transaction. The operation can insert text, delete text, or do both.

A text change and its operations are not performed until the text change is applied.

Text Change Types

Each text change is described by an ITextChangeType instance that is assigned to the ITextChange when it is created. Text change types can be anything, but some common examples are Typing, Paste, Auto-Complete, etc.

Note Note
The TextChangeTypes static class provides quick access to the most common text change types.

If you are creating a text change for which no TextChangeTypes member property describes, you can build your own custom text change type by making a class that implements ITextChangeType.

Single vs. Multiple Operation Text Changes

The text framework supports both single- and multiple-operation text changes. It is up to you to decide which to use, but the key thing to remember is that each text change is considered a single undoable modification in the undo history.

If you were just going to append some text to the end of the document, you'd use a single-operation text change. If you were writing some code to insert a comment delimiter at the start of multiple lines, you'd use a multiple-operation text change instead.

Single-Operation Text Changes

The ITextDocument interface provides a number of helper methods that quickly create and instantly apply single-operation text changes:

Member | Description
AppendText Method | Appends text to the end of the current snapshot's text. There are two overloads of this method. One overload accepts an ITextChangeOptions parameter.
DeleteText Method | Performs a delete text change in the current snapshot. There are four overloads of this method. Various overloads accept offset/length parameters vs. a TextRange parameter. Two overloads accept an ITextChangeOptions parameter.
InsertText Method | Performs an insert text change in the current snapshot at the specified offset. There are two overloads of this method. One overload accepts an ITextChangeOptions parameter.
ReplaceText Method | Performs a replace text change in the current snapshot at the specified offset. There are four overloads of this method. Various overloads accept offset/length parameters vs. a TextRange parameter. Two overloads accept an ITextChangeOptions parameter.
SetText Method | Replaces all the text in the current snapshot. There are three overloads of this method. The simplest overload that only accepts a String parameter replaces all the text in the current snapshot and also clears the undo history. One overload accepts an ITextChangeOptions parameter.

When using the methods above, you do not interact directly with an ITextChange since it is created and applied behind the scenes for you.

Multiple-Operation Text Changes

Use the following techniques whenever you are going to perform a number of replaces that should be considered a single undoable modification.

Creating an ITextChange

First, create an ITextChange object by calling the ITextDocument.CreateTextChange.

This code creates an ITextChange:

C#
VB
Copy
​TextChangeOptions options = new TextChangeOptions();
options.OffsetDelta = TextChangeOffsetDelta.SequentialOnly;
ITextChange change = document.CreateTextChange(TextChangeTypes.CommentLines, options);
​Dim options As TextChangeOptions = New TextChangeOptions();
options.OffsetDelta = TextChangeOffsetDelta.SequentialOnly
Dim change As ITextChange = document.CreateTextChange(TextChangeTypes.CommentLines, options)

The ITextChangeType parameter describes the text change that will be performed.

In this sample we also used the overload of CreateTextChange that accepts an ITextChangeOptions parameter. One of the settings in the options was set to apply a "sequential-only" offset delta. This is described in detail in the "Text Change Options" section below.

Creating a Reader

Most often, when performing multiple operations in a text change, you need to scan an ITextSnapshot. To do this, create an ITextSnapshotReader as described in the Scanning Text Using a Reader topic.

But be sure to use the ITextSnapshot for which the ITextChange is based. This ensures that the offsets will be properly in sync.

This code retrieves an ITextSnapshotReader for the ITextChange's snapshot, starting at offset 0:

C#
VB
Copy
​ITextSnapshotReader reader = change.Snapshot.GetReader(0);
​Dim reader As ITextSnapshotReader = change.Snapshot.GetReader(0)

Scanning Using a Reader and Adding Operations

Often the next code that you'd implement is to scan through the snapshot using the ITextSnapshotReader that was created.

This code uses the reader to scan through code and insert a C-like comment at the start of each line:

C#
VB
Copy
​while (!reader.IsAtSnapshotEnd) {
    change.InsertText(reader.Offset, "//");
    reader.ReadCharacterThrough('\n');
}
​While Not reader.IsAtSnapshotEnd
    change.InsertText(reader.Offset, "//")
    reader.ReadCharacterThrough(ControlChars.Lf);
End While

Applying the Text Change

Finally when you have completely constructed the text change, call its Apply method to perform the text change on the document.

This code applies the text change.

C#
VB
Copy
​change.Apply();
​change.Apply()

Text Change Options

All methods that either quickly perform a single-operation text change or create an ITextChange have an overload that accepts an optional ITextChangeOptions object. This object allows you to specify some additional settings that are used when the text change is applied.

Custom Data

The CustomData property allows you to pass some custom data object with the text change. This custom data object will be persisted in the undo history. Therefore when examining the undo history or undoing back to this change, you can retrieve the custom data object via the IUndoableTextChange.CustomData property.

Check Read-Only

By default, programmatically-created text changes will not check for read-only regions when applying the text change. You can change this behavior to force the text change to cancel if it attempts to alter a read-only region by setting the CheckReadOnly property to true.

Offset Delta

The OffsetDelta property can be used to auto-apply an offset delta when performing multiple operations in a text change. This feature is described in the following section.

Retain Selection

By default, when a text change is applied, any attached editor will move its caret to the end of the last operation in the text change. This behavior can be disabled by setting then RetainSelection property to true.

Source

Sometimes it's useful to know the source object that created the text change. This most often is some sort of editor view and can be passed in the Source property.

Can Merge Into Previous Change

When the CanMergeIntoPreviousChange property is true, the text change will try and merge into a previous text change on the undo stack. This is useful when you want to apply a programmatically-created text change that shouldn't have its own undo history entry. Enabling this feature means that if an undo occurs after this text change is applied, the undo will include all of the operations in the merged text change along with those of the text change they were merged into, all acting as a single atomic text change.

The ITextChange.IsMerged property returns if a text change is the result of two or more text changes being merged.

Offset Deltas

Text changes have a great optional feature called offset deltas that make things much easier when performing multiple operations in a single text change. To explain the benefit, let's examine a simple scenario.

Assume that you scan a snapshot and determine that you would like to insert the text // at offsets 0 and 10. Therefore you create an ITextChange. The first insert operation would be made at offset 0 and would insert 2 characters. Now we have a problem since if we make the second insert operation at offset 10, it would be off by 2 characters from what we originally wanted. By default, operations added to a text change are made at absolute offsets, so that means at the offsets that will exist after the previous operations that have occurred for the text change.

There are two ways around this. The first and harder way is to keep some sort of delta variable yourself to determine that any operations you perform need to be offset by the delta. Then after each operation, update the delta to account for the deletion and insertion lengths of the operation. For the scenario example above, you'd have to tell the second insert operation to occur at offset 12, not 10, to achieve the correct results.

Obviously that is tedious so the text framework provides a really handy feature to do the delta calculations for you. The only caveat is that you must be performing the operations in forward sequence, meaning no operation can start at an offset that is earlier than the start offsets of any previously-added operation.

In the multi-operation example above, we activate this feature by passing options to the text change that set ITextChangeOptions.OffsetDelta to TextChangeOffsetDelta.SequentialOnly. When this option is set, all offsets you pass for operations can be based on the original offsets in the snapshot you scan. This means that in our scenario example above, you can tell the second insert operation to occur at offset 10.

Auto Character Casing

The ITextDocument.AutoCharacterCasing property enables control over the casing of text that is entered into the document via text changes. It supports these CharacterCasing values:

Value | Description
Normal | The case of characters is left unchanged, which is the default.
Upper | Converts all characters to uppercase.
Lower | Converts all characters to lowercase.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Loading and Saving Files

Text/Parsing Framework - Core Text Features
Loading and Saving Files

It's very easy to load document text from a file, stream, or string. Likewise, document text can be saved back out to a file, stream, or string.

This topic contains these sections:

  • Loading Text Directly from a File/Stream
  • Loading Text from a String
  • Saving Text to a File
  • Updating the IsModified Property
  • Getting Text into a String
  • Exporting to HTML / RTF
  • Storing the File Name of a Document

Loading Text Directly from a File/Stream

Document text may be loaded from files using one of the overloads of the ITextDocument.LoadFile method.

Use of a LoadFile method will reset the IsModified property to false and will clear the undo history. Use of the LoadFile method overloads that accept an IStorageFile parameter will auto-update the FileName property with the file path.

Load from File System Using UTF-8 Encoding

The first overload of LoadFile simply accepts an IStorageFile parameter. It loads files using standard UTF-8 encoding.

This code loads text from a file using UTF-8 encoding:

C#
VB
Copy
​await document.LoadFileAsync(storageFile);
​await document.LoadFileAsync(storageFile)

Load from File System Using a Specified Encoding

The second overload of LoadFile accepts an IStorageFile parameter as well as an Encoding parameter. It loads files using the Encoding that you specify. This allows for easy loading of non-UTF-8 encoded files.

This code loads text from a file using ASCII encoding:

C#
VB
Copy
​await document.LoadFileAsync(storageFile, Encoding.ASCII);
​await document.LoadFileAsync(storageFile, Encoding.ASCII)

Load from Stream Using a Specified Encoding

The third overload accepts a Stream parameter as well as an Encoding parameter. It loads from the stream using the Encoding that you specify. This allows for easy loading of non-UTF-8 encoded files.

This code loads text from a Stream using UTF-8 encoding:

C#
VB
Copy
​document.LoadFile(stream, Encoding.UTF8);
​document.LoadFile(stream, Encoding.UTF8)

Loading Text from a String

Sometimes a document's text is fetched using an external process, such as from a database. In this case, the text to place in the document is available as a string variable.

The ITextDocument.SetText method can be used to completely replace the document text with a string.

There are several overloads of the SetText available. The overload that only accepts a String parameter will will reset the IsModified property to false and will clear the undo history. The other overloads will not do this.

This code replaces the text content of a document from a string, marks the IsModified property to false, and clears the undo history:

C#
VB
Copy
​string text = "int a;";
document.SetText(text);
​Dim text As String = "int a;"
document.SetText(text)

This code replaces the text content of a document from a string, without updating the IsModified property or the undo history:

C#
VB
Copy
​string text = "int a;";
document.SetText(TextChangeTypes.Typing, text);
​Dim text As String = "int a;"
document.SetText(TextChangeTypes.Typing, text)

Saving Text to a File

Document text may be saved to files using one of the overloads of the ITextDocument.SaveFile method.

Save to File Using UTI-8 Encoding

The first overload simply accepts an IStorageFile parameter and a LineTerminator parameter. It saves files using standard UTF-8 encoding.

This code saves document text to a file using UTF-8 encoding:

C#
VB
Copy
​await document.SaveFileAsync(storageFile, LineTerminator.CarriageReturnNewline);
​Await document.SaveFileAsync(storageFile, LineTerminator.CarriageReturnNewline)

Save to File Using a Specified Encoding

The second overload accepts an IStorageFile parameter, a LineTerminator parameter, as well as an Encoding parameter. It saves files using the Encoding that you specify. This allows for easy saving of non-UTF-8 encoded files.

This code saves document text to a file using ASCII encoding:

C#
VB
Copy
​await document.SaveFileAsync(storageFile, Encoding.ASCII, LineTerminator.CarriageReturnNewline);
​Await document.SaveFileAsync(storageFile, Encoding.ASCII, LineTerminator.CarriageReturnNewline)

Save to Stream Using a Specified Encoding

The third overload accepts a Stream parameter, a LineTerminator parameter, as well as an Encoding parameter. It saves to the stream using the Encoding that you specify. This allows for easy saving of non-UTF-8 encoded files.

This code saves document text to a Stream using UTF-8 encoding:

C#
VB
Copy
​document.SaveFile(stream, Encoding.UTF8, LineTerminator.CarriageReturnNewline);
​document.SaveFile(stream, Encoding.UTF8, LineTerminator.CarriageReturnNewline)

Updating the IsModified Property

After saving a document, it is a good idea to mark it as no longer modified. Save points are tracked in the undo history so that you are notified when the document reaches the save point.

This code sets a save point by telling a document that it is no longer modified:

C#
VB
Copy
​document.IsModified = false;
​document.IsModified = False

When the ITextDocument.IsModified property is set to false all unsaved changes in undo history's change tracking will be switched to saved changes.

Calling any of the SaveFile overloads with a path parameter will automatically set the ITextDocument.IsModified property to false if the specified path is the same as the document's FileName property value.

Getting Text into a String

Sometimes a document's text needs to be saved using an external process, such as to a database. In this case, the text to save needs to be retrieve into a string variable.

The current snapshot of a document (see the Documents, Snapshots, and Versions topic for more information) is available via the ITextDocument.CurrentSnapshot property. The ITextSnapshot.GetText method can be used to retrieve a snapshot's text content with a specified LineTerminator. The Text property returns the snapshot's text using standard Windows carriage return / newline line terminators.

This code fetches the current document text into a string:

C#
VB
Copy
​string text = document.CurrentSnapshot.Text;
​Dim text As String = document.CurrentSnapshot.Text

Exporting to HTML / RTF

The text framework supports exporting document text to HTML and RTF formats.

See the Exporting to HTML / RTF topic for more information on this feature.

Storing the File Name of a Document

The ITextDocument.FileName property can be used to store the file name (full path) of the file that has been loaded into the document. The LoadFile method overloads that read a file automatically set this property.

When the FileName property value is changed, the FileNameChanged event fires.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Syntax Languages

Text/Parsing Framework
Syntax Languages

Syntax languages are objects that can be assigned to any ICodeDocument that provide advanced functionality for working with the text content of the document. This functionality can be simple such as determining where word breaks are, to more complex such as tokenization (lexing) of text, or parsing the text into an abstract syntax tree.

This topic contains these sections:

  • The ISyntaxLanguage Interface (Service Locator Architecture)
  • Creating, Loading, and Using a Language
  • Notification of Document Language Changes
  • Reusing Language Instances

The ISyntaxLanguage Interface (Service Locator Architecture)

The ISyntaxLanguage interface, implemented by any syntax language is designed to be completely open and extensible. The main requirement it has is that a string-based language key is provided that identifies the language. The other requirement is that it supports the service locator design pattern.

The service locator design pattern is somewhat like a dictionary object. Any object can be assigned as a "service" to the language using a Type-based key. There are a number of built-in feature service types that the text/parsing framework and products like SyntaxEditor look for, such as ILexer, ILineCommenter, IWordBreakFinder, etc. Then there are provider services that create/return various objects on-demand, and event sink services that allow you to be notified when various document and UI events occur that can be intercepted and handled by the language.

Note Note
A complete list of the built-in service types, along with a more in-depth look at how the service locator architecture works, is given in the Service Locator Architecture topic.

A Real Service Type Example

Each one of these services provide some functionality that can be requested at any time. As a real example, say we have created an ITextSnapshotReader (see the Scanning Text Using a Reader topic for details), and want to jump to the start of a word. The implementation of the GoToCurrentWordStart method checks with the language currently assigned to the document to see if an IWordBreakFinder service has been registered. If so, it uses that object to find the start of the word. Otherwise it falls back to a default word break finder.

Thus via the use fo the service locator architecture, we can register (or customize) built-in functionality for a particular language.

A Custom Service Type Example

Any custom service types can be registered too. Say you made a service that returns an object which has a method indicating if a passed filename is supported by the language. If our language was Java and the passed filename had a .java extension, we'd return true. You could register similar functionality on all the languages you use and publish this service as a type called IFilenameSupported. Then in your application where you maintained a list of available languages, when a file was opened you could enumerate your list of languages, get the IFilenameSupported service, pass the filename to its method, and see if true was returned. When you encounter a true return value, you know that language supports the file.

Creating, Loading, and Using a Language

The Language Creation Guide has topics that cover how to create, load, and use syntax languages. It also goes into detail about the service locator architecture, event sinks, the available built-in service types, and more.

In addition, we provide a Language Designer application that makes it easy to get started building a custom syntax language. That tool lets you configure information about your language and then it generates language-related code that can be used in your applications. With the application's help, you can be up and running in a few minutes.

Notification of Document Language Changes

The ICodeDocument.LanguageChanged event fires whenever the document's Language property changes. Its event arguments pass the old and newly-assigned languages.

Reusing Language Instances

It is encouraged to reuse ISyntaxLanguage instances among multiple documents that are of the same language. For instance, if your application has multiple instances of a SyntaxEditor control and your IDE edits XML documents, load your XML syntax language one time and apply the same instance to each document. This saves on memory and reduces load time.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Text/Parsing Framework - Lexing
Overview

Lexing is the process of scanning text and breaking it up into meaningful tokens that can be examined by a higher-level parser.

This topic contains these sections:

  • Basic Concepts
  • Tokens
  • Dynamic Lexers
  • Programmatic Lexers

Basic Concepts

There are various types of lexers and ways to go in terms of implementing them. This topic walks through how a lexer works and the benefits/drawbacks of various implementations.

See the Basic Concepts topic for more information.

Tokens

A token is a span of text within a snapshot that has some sort of lexical parse data associated with it. Tokens are used throughout the product, in various types of parsing, classification, and text scanning.

See the Tokens topic for more information.

Dynamic Lexers

Dynamic lexers are mergable lexers and use our custom pattern-based regular expression engine to match and tokenize text. It is recommended that developers new to the text/parsing framework as well as developers who do not require much advanced parsing use dynamic lexers since they make it simple to get up and running quickly.

See the Dynamic Lexers topic for more information.

Programmatic Lexers

The fastest lexers are handwritten classes (called "programmatic") that are hard-coded to parse a specific language's code.

See the Programmatic Lexers topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Basic Concepts

Text/Parsing Framework - Lexing
Basic Concepts

There are various types of lexers and ways to go in terms of implementing them. This topic walks through how a lexer works and the benefits/drawbacks of various implementations.

This topic contains these sections:

  • What Does a Lexer Do?
  • Key Components of a Lexer
  • Registering with a Syntax Language
  • Mergable vs. Non-Mergable Lexers
  • Changing Mergable Lexers
  • Dynamic, Programmatic, and Other Lexers

What Does a Lexer Do?

A lexer scans text and tokenizes it, meaning that a series of tokens are assigned to text ranges that identifies in detail what the text represents.

The concept is best illustrated with a diagram:

In this diagram, we have two lines of C# code. Each line is tokenized using a C# lexer. Note how a token spans one to many characters. For instance, the text using is contained by a single token that indicates it is a using keyword.

Key Components of a Lexer

Lexer

The root interface for a lexer in the parsing framework is ILexer. This interface is very simple. It has a String-based Key property that identifies the lexer, a Parse method that performs a parsing operation, and an optional TokenIdProvider property, which returns an ITokenIdProvider instance.

Token ID Provider

An ITokenIdProvider is simply a utility class related to the lexer that has integer constants indicating the token ID values used by the lexer. It has a GetKey method that returns the String-based Key for a particular ID and has properties that return the minimum and maximum ID values associated with the provider.

Lexical States

A lexical state, represented by the ILexicalState interface, is a context in which certain text can be parsed into a set of tokens.

For instance, all lexers must have a default lexical state, but then languages such as C# may have another lexical state for XML documentation comments. As you know, XML documentation comment tags are not valid in normal code. The code must have a /// delimiter on a line (thereby entering the XML documentation comment lexical state) and then tags are valid. While in this state, keywords such as void are not recognized and all text other than tags is treated as comment text. The lexical state ends at the line terminator and flips back to its parent default lexical state where again, keywords like void are recognized.

Lexical Scopes

A lexical scope, represented by the ILexicalScope interface, defines how a parent lexical state can transition to another child lexical state and back.

Again using the C# XML documentation comment example, the start scope for the XML documentation comment lexical state recognizes the text /// as its start scope and when found, transitions to the lexical state. Once in the lexical state, it looks for a line terminator, which is the end lexical scope for the lexical state. When that is found, it exits the lexical state and pops back to the parent default state.

Registering with a Syntax Language

An ILexer can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ILexer>(myLexer);
​language.RegisterService(Of ILexer)(myLexer)

Once the lexer is registered with a language, it can be used by other objects such as token taggers or other higher-level syntax or semantic parsers.

Mergable vs. Non-Mergable Lexers

Some languages can perform transitions to other languages, such as in the case of HTML where it can transition to CSS, Javascript, etc. These transitions are made when one lexer determines it should transition to another language's lexer. This feature is only supported by mergable lexers. Although language transitions are a great feature, non-mergable lexers will offer slightly better performance.

Making a Lexer Mergable

Any ILexer that implements IMergableLexer is a mergable lexer and thus supports language transition features.

The IMergableLexer interface can be easily implemented by creating a lexer that inherits MergableLexerBase. With this abstract base class, the only member that is required to be implemented is GetNextToken. That method is passed an ITextBufferReader and the current ILexicalState, and returns a MergableLexerResult object.

The MergableLexerResult class has two properties. The MatchType property is an enumeration indicating whether there was a match, and if so, if the match was exact or loose (such as a case insensitive match). The LexerData property is an IMergableTokenLexerData instance. It provides data about what was parsed. Programmatic lexers can use the built-in LexicalStateTokenData and LexicalScopeTokenData classes as property values.

If no match is made, return the static MergableLexerResult.NoMatch property value.

Tokens

Mergable lexers must generate tokens that implement IMergableToken. Non-mergable lexers, on the other hand, may generate simpler tokens that only implement IToken.

Performance Considerations

A common question is, should I make my language's lexer mergable or not? The two things to weigh are whether your language needs to support transitions to other languages, or would you like maximum parsing speed and minimal memory usage.

Mergable lexers require more overhead, both in the actual parsing operation and in how data ends up being tracked in tokens. This translates into slightly slower overall lexing and some increased memory usage.

Non-mergable lexers, since they don't support language transitions, only need to process the information needed to support the core IToken interface. Therefore they can run faster and use less overall memory.

Changing Mergable Lexers

Mergable lexers sometimes cache data about themselves. Therefore if they are ever to be altered after their initial creation, they need to be notified that something within them has changed.

As an example, this scenario can occur if you load two independent languages and then wish to merge them together, such as HTML with CSS. In this scenario you'd load two ISyntaxLanguage instances, one for HTML and one for CSS. Then you'd create a lexical state that contains a scope transition to CSS. See the Language Transitions QuickStart for a related full sample.

Before you change the HTML language's lexer to add the transitioning state, you need to wrap the change with a using statement executed on the result of the IMergableLexer.CreateChangeBatch method.

This code shows how to wrap changes:

C#
VB
Copy
​using (IDisposable batch = parentLexer.CreateChangeBatch()) {
    // Update lexical states, patterns, etc. on parent lexer here
}
​Using batch As IDisposable = parentLexer.CreateChangeBatch()
    ' Update lexical states, patterns, etc. on parent lexer here
End Using

Another scenario you may need to do this in is if you are dynamically adding/removing lexical patterns to a lexical state after it has already been used.

Dynamic, Programmatic, and Other Lexers

High-Level Comparison

Dynamic lexers use regular expression patterns to tokenize text. The DynamicLexer class inherits MergableLexerBase, meaning that all dynamic lexers are mergable and capable of transitioning to other languages. Dynamic lexers are generic and can support the parsing of nearly any language.

Programmatic lexers are written by hand and optimized to parse a specific language's code. This almost always results in faster parsing performance than dynamic lexers can achieve. Programmatic lexers can optionally be made mergable by implementing IMergableLexer or inheriting MergableLexerBase.

Which to Choose?

When building a new syntax language and making a new lexer, you must choose whether to create a dynamic or programmatic lexer.

It's often best to start out making a dynamic lexer. The reason is that these can be created extremely fast and will get you up and running quicker, especially when using the Language Designer to create your language and lexer.

If at a later time you decide to squeeze some more performance out of your lexer, then create a programmatic lexer instead. Programmatic lexers take more time to write and are really for more advanced developers.

Since any class that implements ILexer can be used by an ISyntaxLanguage, it is important to note that even if you start initially with a dynamic lexer, you can easily swap in a programmatic lexer for your language at a later time.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tokens

Text/Parsing Framework - Lexing
Tokens

A token is a span of text within a snapshot that has some sort of lexical parse data associated with it. Tokens are used throughout the product, in various types of parsing, classification, and text scanning.

This topic contains these sections:

  • Token Basic Properties
  • Mergable Tokens
  • Token Classes

Token Basic Properties

All tokens are represented by classes implementing the IToken interface. This interface defines properties that fall into two categories: identification and location.

Identification properties provide the most basic data for identifying what a token represents. The Id and Key properties are used for this purpose. The Id property is an integer number and the Key is a String value. Either or both can be used to provide identification of the token, although the ID is preferred since integer comparisons are faster than String comparisons.

Location properties give information about the size and location of the token within its text source. The StartOffset and EndOffset properties specify the start/end offsets of the token. The end offset is the offset after the last character contained by the token. The Length property gives the number of characters in the token. The StartPosition and EndPosition properties specify the start/end TextPosition objects that relate to the offsets. The TextRange and PositionRange properties provide the related ranges.

Note Note
See the Offsets, Ranges, and Positions topic for more information on offsets and text positions.

Mergable Tokens

Mergable tokens are represented by classes implementing the IMergableToken interface, which inherits the IToken interface. Mergable tokens are the type of token that is created when using a mergable lexer, meaning a lexer from one language that can merge its results with another language's mergable lexer. This is commonly seen in languages like HTML where multiple child languages like CSS, JavaScript, etc. can be used.

Mergable tokens provide more information about how the token was created, such as its owner ILexicalState, owner ILexicalScope (if appropriate), and the root IMergableLexer

Another key feature provided by the IMergableToken interface is the IClassificationType associated with the token, available via the IMergableToken.ClassificationType property. A classification type is a logical category such as Identifier, Comment, or Whitespace.

Token Classes

If you wish to create a bare bones class that implements IToken for your language, and your language's lexer is not mergable, you can inherit the TokenBase class. It is abstract and only requires that you implement its Id property and optionally the Key property.

For languages that use mergable lexers, you can use the non-abstract MergableToken class for your tokens. Typically you don't even need to worry about this though since the MergableLexerBase class, which most IMergableLexer implementations inherit, automatically creates MergableToken instances for you.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Dynamic Lexers

Text/Parsing Framework - Lexing
Dynamic Lexers

Dynamic lexers are mergable lexers and use our custom pattern-based regular expression engine to match and tokenize text. It is recommended that developers new to the text/parsing framework as well as developers who do not require much advanced parsing use dynamic lexers since they make it simple to get up and running quickly.

This topic contains these sections:

  • How do they work?
  • Free Samples
  • Lexical States
  • Lexical Scopes
  • Lexical Pattern Groups
  • Lexical Macros
  • Lexical State Transitions (Language Transitions)
  • Lexing Sequence
  • Importance of Pattern Order
  • Optimization
  • Importing SyntaxEditor 4.0 for WinForms Dynamic Language XML Definitions

How do they work?

Dynamic lexers, represented by the DynamicLexer class, harness a specialized pattern-based engine to tokenize document text. This means that no handwritten lexing code needs to be written for dynamic lexers, such as you would write for a programmatic lexer. Instead, you provide the patterns that the lexer engine will use to match the text against. The patterns can be straight text (called explicit) or regular expressions (called regex). They also support case senstivity settings.

The lexer's patterns can be defined either by using a language definition file or by constructing the lexer programmatically via its object model. If a language definition file is used, the Loading a Language Definition topic explains how to load it at runtime.

Note Note
The Language Designer tool has extensive features for building a dynamic lexer. A new dynamic lexer wizard asks you several questions about your language and builds an initial dynamic lexer for you, which you can then modify as needed. Use that wizard to get started fast.

There are a number of pieces that make up a dynamic lexer, all described in greater detail below:

  • Lexical states
  • Lexical scopes
  • Lexical pattern groups
  • Lexical macros
  • Lexical state transitions

Free Samples

There are a number of free open source syntax language samples that use dynamic lexers. These free samples are included in the sample project and cover everything from C# to Perl.

Lexical States

Dynamic lexical states, represented by the DynamicLexicalState class, provide states into which different patterns may be grouped. The lexer only recognizes patterns that are valid within the current lexical state.

For instance, all lexers must have a default lexical state, but then languages such as C# may have another lexical state for XML documentation comments. As you know, XML documentation comment tags are not valid in normal code. The code must have a /// delimiter on a line (thereby entering the XML documentation comment lexical state) and then tags are valid. While in this state, keywords such as void are not recognized and all text other than tags is treated as comment text. The lexical state ends at the line terminator and flips back to its parent default lexical state where again, keywords like void are recognized.

Dynamic lexical states have several default properties that can inherit down to lexical pattern groups inside the state. Defaults are available for case sensitivity, classification type, and token ID/key.

Each dynamic lexical state has a collection of child lexical states and lexical scopes. The child lexical states collection specifies the lexical states that can be entered from the lexical state. When the dynamic lexer engine runs, it looks at each child lexical state to see if any of their lexical scope start lexical pattern groups match at the current offset in the text. If so, that child lexical state is entered. When the child lexical state's end lexical pattern group is recognized at a later point, the parent lexical state is re-entered.

Dynamic lexical states also have a lexical pattern groups collection, which provide the list of patterns that can be recognized while in the lexical state.

Lexical Scopes

Dynamic lexical states are represented by the DynamicLexicalScope class. As mentioned above, lexical scopes control when a child lexical state is entered and exited. Dynamic lexical scopes have a start lexical pattern group and end lexical pattern group property that provide the patterns recognized for entry and exit.

Lexical Pattern Groups

A lexical pattern group, represented by the DynamicLexicalPatternGroup class, is a group of patterns that share common attributes. For instance, in a dynamic lexer there is often one explcit lexical pattern group in the default lexical state that contains a list of keywords, where each pattern is the keyword text.

Lexical pattern groups can be an explicit or regex pattern type. When using the explicit pattern type, the pattern is matched exactly as specified, including whitespace. When using the regex pattern type, the pattern is matched using our regular expression engine. See the Regular Expression Guide for the regex pattern syntax.

Lexical pattern groups have options for case sensitivity, classification type, and token ID/key assigned.

In addition, a look-behind and look-ahead pattern can be set. These patterns are always specified in the regex pattern type and apply to all patterns in the lexical pattern group. When the dynamic lexer engine attempts to match a pattern, it also checks the look-behind pattern and look-ahead pattern to see if they match. They are treated as zero-width assertions, however if either fail, then no patterns in the lexical pattern group can match.

A common look-ahead pattern used for things like keywords is {NonWord}|\z. That look-ahead pattern ensures that patterns in the pattern group will match if the text following the match starts with a non-word character or is at the end of the document. Thus if matching the keyword int, the document text int foo; will match the int at the start while the document text integer foo; will not match.

Lexical Macros

Lexical macros are optional and provide a nice way to define reusable patterns for a dynamic lexer. Custom patterns can be defined as macros, but you can also redefine built-in macros for your lexer.

For instance, in the CSS language the Word macro is redefined as [a-zA-Z_0-9\-], which includes the hyphen character since that is a valid word character in CSS. Likewise, the NonWord is redefined as [^a-zA-Z_0-9\-].

Lexical macros can be referenced by key within { and } characters in any regex pattern. For instance this pattern specifies a C# identifier: (_ | {Alpha})({Word})*

The Dynamic Lexical Macros topic talks in more detail about the built-in macros that are available and how to use them in regex patterns.

Lexical State Transitions (Language Transitions)

There are two types of lexical state transitions to different languages that are supported.

Direct Lexical State Transitions

Sometimes it is necessary for a single pattern match to transition into another language. An instance of that is an ASP directive within an HTML document. In that case the <% directive changes the language to VBScript. Likewise, the %> directive exits back to HTML.

This type of transition is called a direct lexical state transition. You essentially create a dummy lexical state in the root HTML language. You give it a lexical start and end scope, which are the ASP directive patterns.

You then set the dummy lexical state's DynamicLexicalState.Transition property to an LexicalStateTransition object that indicates the language and lexical state to transition into. When the dummy state's start scope is recognized by the lexer, it transitions to the child language you indicated.

Scope Lexical State Transitions

A more complicated scenario is where a lexical state end scope is recognized and at that point, a lexical state transition needs to be made to another language. This occurs in HTML where a <style> tag is recognized, and a transition needs to be made to CSS.

This can be accomplished via a scope lexical state transition. You define a lexical state transition for a lexical scope (in the DynamicLexicalScope.Transition property) and you give the transition a child lexical scope with end pattern that it should look for to exit the child lexical state.

At run-time when the end scope pattern of the lexical state is recognized, the language transition is made. Later on when the transition's child lexical scope end pattern is recognized, the child language is exited and the parent lexical state of the original lexical state is entered.

Lexing Sequence

The lexer coordinator used by mergable lexers matches patterns in sequential order within four sequential groups:

  • Parent scopes (outside of the current lexer) to see if one ends the current state.
  • Child state start scopes to see if one starts a child state.
  • Pattern groups within the current state.
  • Parent scopes (inside of the current language) to see if one ends the current state.

In some scenarios you may wish to not check any ancestor scope to see if it ends the current state. For these scenarios, you can set the ILexicalScope.IsAncestorEndScopeCheckEnabled property to false. This prevents the lexer coordinator from looking at any scope above the current one when checking to see if they end the state.

Importance of Pattern Order

It is extremely important to optimize your dynamic lexer design. By making certain design decisions you can affect the run-time scanning speed of the dynamic lexer. Use the techniques described below to get the most efficiency out of a dynamic lexer.

Most Frequently Matched Patterns Should Be Defined First

Dynamic lexers use our custom NFA regular expression engine to parse text and find a pattern that matches the text. It does this by looping through all of the patterns in the lexer in the order in which they are defined. If a pattern is found to match the current text, the code breaks out of the loop and creates a mergable token containing the pattern's lexical parse information.

The key here is that the looping is done in the order in which the patterns groups are defined. Therefore, lexical parsing will be much faster if you place the most frequently-matched pattern groups first.

For instance, in C#, tokens like { and ( occur much more often than the keyword volatile. The patterns for the { and ( tokens should be defined at the beginning of a lexical state and the pattern for the infrequently-matched keyword volatile should be near the end of a lexical state.

Similar to how frequently-matched pattern groups should be placed first within a lexical state, frequently-matched patterns should be placed first within their parent pattern group. This will help when there are a number of keywords that start with the same character. SyntaxEditor has optimizations to help speed up which patterns to match however every bit of good language design helps speed up lexical parsing.

Be Careful of Pattern Order

When defining patterns, remember that the first match is accepted. Say you have two number pattern groups, one that looks for a series of digits followed by a period and more digits, marked as a real number and another patter than looks for a series of digits that ends with a non-digit, marked as an integer. If the integer pattern is defined first, when the lexical parser encounters a number it will start using the integer pattern. Say the number has a period afterwards and a number and should be defined as a real, the lexical parser would get to the period, see it as a non-digit and assign it as an integer. The real number pattern would never even be reached. Therefore in situations like this, it's important to place the more complicated patterns first. If the real number pattern had been defined first, then the parser would have tokenized the text appropriately.

The Language Designer has several helpful features for sorting explicit pattern group patterns appropriately to avoid this scenario when conflicting patterns are in the same lexical pattern group.

Optimization

For best memory and performance optimization, try and develop patterns that use as long of matches as possible. For instance, in comments, try and consume all comment text in a line in one token. This will perform better than if there is one token for each letter or word.

When using a lexer in SyntaxEditor, it is also beneficial to try and keep tokens on one line. For instance, in a multi-line comment, you should have a state with the text for each line in its own token, with a comment line terminator token for the line terminator. That sort of design helps with the performance of incremental classification, versus possible scenarios where a single token is potentially a thousand lines long.

Importing SyntaxEditor 4.0 for WinForms Dynamic Language XML Definitions

If you are a customer of our SyntaxEditor 4.0 for WinForms product and have created dynamic language XML definitions there, they can easily be converted over to the new language definition format used in this product. Use the Language Designer to import the XML definition and automatically create a language project that can export a language definition file. The Language Designer's Getting Started topic talks about this feature.

The language definition format used by this product is very similar in structure to the SyntaxEditor 4.0 dynamic language XML definition format, but the new format is more extensible and works for all languages, not just those that use a dynamic lexer.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Programmatic Lexers

Text/Parsing Framework - Lexing
Programmatic Lexers

The fastest lexers are handwritten classes (called "programmatic") that are hard-coded to parse a specific language's code.

This topic contains these sections:

  • Mergable vs. Non-Mergable
  • Implementing a Mergable Programmatic Lexer
  • Implementing a Non-Mergable Programmatic Lexer

Mergable vs. Non-Mergable

Programmatic lexers can be mergable or non-mergable. Mergable lexers allow a language to be merged with other languages at run-time via language transitions. An example of a language that uses merging is HTML since it can transition to CSS, VBScript, etc.

Mergable lexers provide this functionality by implementing the IMergableLexer interface. While this merging functionality is useful for certain scenarios, it does add a bit of overhead and thus results in some performance loss. This performance loss may not be very significant in many situations, but still if you wish to make your lexer as fast as possible and it doesn't need to merge with other language, you should make your lexer non-mergable.

A non-mergable lexer has the best performance among the various lexer types, although it requires a little more work to get started.

Implementing a Mergable Programmatic Lexer

A mergable programmatic lexer is made by creating a class that implements the IMergableLexer interface, although inheriting the MergableLexerBase class is the easiest way to accomplish this. When inheriting MergableLexerBase, the only method we are required to implement is the GetNextToken method.

That method is passed an ITextBufferReader and an ILexicalState that indicates the current lexical state. The reader is already initialized to the current offset that should be scanned to look for tokens. See the Scanning Text Using a Reader topic for some more details on the low-level ITextBufferReader class.

The GetNextToken method asks us to return a MergableLexerResult object. So after we scan a range of text using the reader and identify a token, we need to return an appropriate MergableLexerResult instance.

This code shows how to return a result for some text that was successfully identified as a token:

C#
VB
Copy
​return new MergableLexerResult(MatchType.ExactMatch, new LexicalStateTokenData(lexicalState, tokenId));
​Return New MergableLexerResult(MatchType.ExactMatch, New LexicalStateTokenData(lexicalState, tokenId))

In that example we indicate there was an exact case-sensitive match and also indicates the ILexicalState that match was made in (in case we moved to a new lexical state), along with the ID of the token. The token ID is user defined and varies for each language. For instance a CSS property name token may have ID value 10. A token is created for you behind-the-scenes based on the result value that spans from the reader's original offset through to the reader's current offset.

If there was no successful match, we want to move the reader back to the offset it started at and return MergableLexerResult.NoMatch instead.

There is an example of a mergable programmatic lexer in the sample project for the Simple language.

Implementing a Non-Mergable Programmatic Lexer

A non-mergable programmatic lexer is made by creating a class that implements the core ILexer interface. The main member of this interface is the Parse method.

This method passes a TextSnapshotRange indicating the ITextSnapshot and the range to parse, along with an ILexerTarget. A TextRange is returned that specifies the snapshot range that was modified.

Preparing to Lex

The first step in a Parse implementation is to adjust the range to lex. The TextSnapshotRange passed in tells us the minimum range to lex but often times we'll want to actually start our lexing at the start of the line that contains the range's start offset, or even somewhere on the line before that. Thus you can use the ITextSnapshot instance from the TextSnapshotRange.Snapshot property to find the line start and move the lexing start offset back appropriately.

Once we have determined the lexing start offset, call the ILexerTarget.OnPreParse method, passing in the lexing start offset by reference. This tells the lexer target where we would like to begin lexing at. It will return an ILexerContext object and will further update the lexing start offset to indicate where the offset at which that context is valid, and thus from where we should actually start our lexing.

The ILexerContext instance includes a stack of lexical states and scopes at the specified lexing start offset, thus allowing us to resume incremental parsing. This helps performance since we don't need to start lexing from the beginning of the document.

Lexing

The next step is to actually do some lexing. For this we will need to do some core text scanning by using an ITextBufferReader.

This code retrieves an ITextBufferReader that is initialized at the lexing start offset:

C#
VB
Copy
​ITextBufferReader reader = snapshotRange.Snapshot.GetReader(lexingStartOffset).BufferReader;
​Dim reader As ITextBufferReader = snapshotRange.Snapshot.GetReader(lexingStartOffset).BufferReader

At this point we want to start a loop while the reader.IsAtEnd property returns false, meaning keep going until the end of the snapshot. Inside the loop we scan characters using the reader and tokenize the text.

When some sort of pattern is recognized, we are ready to tell the lexer target. We call the ILexerTarget.OnTokenParsed method by passing it the next IToken that was lexed (which can be any class that inherits TokenBase) and an ILexicalScopeStateNode that can be persisted and returned to us in future ILexerContext instances if we wish to resume incremental lexing at this point.

The OnTokenParsed returns a boolean value indicating if lexing should continue. If that return value is false and we have passed the desired range to parse, we can safely quit our loop and complete lexing. Otherwise we continue the loop.

Completing Lexing

If we exited the loop because the end of the snapshot was reached, we should return a token indicating a document end. The TokenIdProviderBase.DocumentEnd value is the token ID to use for this token type.

Next we need to let the parse target know that parsing is complete so we call ILexerTarget.OnPostParse and tell it the offset of the reader we ended on.

Finally we return a TextRange indicating the actual offset range that was modified.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Text/Parsing Framework - Tagging
Overview

Tagging is a generic mechanism that allows any sort of data to be associated with a text range. This tagged data can then be retrieved on-demand by tag aggregators. Tagging is the core mechanism behind features such as tokenization, classification (which in turn drives syntax highlighting when used in an editor), and more.

This topic contains these sections:

  • Tags and Classification Types
  • Taggers and Tagger Providers
  • Tag Aggregators

Tags and Classification Types

Tags are objects that store data and can be applied to a text range. Classification types are used throughout the product to categorize objects. Both are key pieces towards understanding tagging.

See the Tags and Classification Types topic for more information.

Taggers and Tagger Providers

Taggers are objects that can return tagged snapshot ranges for any requested snapshot range. They are generally created by tagger providers, which are language service. Tagger results are then consumed by tag aggregators.

See the Taggers and Tagger Providers topic for more information.

Tag Aggregators

Tag aggregators are objects that can monitor all the available taggers for a specific tag type and can return a unioned set of tagged snapshot ranges for a requested snapshot range. They are used for consuming the results of taggers.

See the Tag Aggregators topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tags and Classification Types

Text/Parsing Framework - Tagging
Tags and Classification Types

Tags are objects that store data and can be applied to a text range. Classification types are used throughout the product to categorize objects. Both are key pieces towards understanding tagging.

This topic contains these sections:

  • What are Tags?
  • Classification Types
  • Tokens vs. Classifications
  • Providing Tagged Ranges

What are Tags?

Tags are any object inheriting ITag that can contain some data and can be applied to and tracked with a range of text in a document.

There are several built-in tag types are are used to drive various functionality pieces in the product. This table lists the built-in tag interface types that are supported, along with optional implementation classes that can be used.

Type Description
IClassificationTag

A tag that refers to an IClassificationType and can be used to classify a range of text (see below), which when used in an editor can also drive syntax highlighting.

The ClassificationTag class implements this tag interface.

IReadOnlyRegionTag

A tag that can mark a range of text as read-only (uneditable) by the end user. This is similar to setting the ITextDocument.IsReadOnly property to true, except that the read-only state only applies to the tagged text ranges.

The ReadOnlyRegionTag class implements this tag interface and also includes an IClassificationType reference, which defaults to ClassificationTypes.ReadOnlyRegion. If that classification type is registered with a style in the ambient highlighting style registry, it is possible for the read-only regions to render in an alternate appearance, such as with a gray background.

ISquiggleTag

A tag that may be available when the text/parsing framework is used in conjunction with an editor. In that case, the tag can mark a range of text as needing a squiggle underline. This is generally used to flag syntax errors, etc. The tag includes an IClassificationType reference so that the type of squiggle can be classified.

The SquiggleTag class implements this tag interface.

ITokenTag

A tag that refers to an IToken and can be used to mark a range of text with the token. Use of these tags allow snapshot readers to scan through a document by token.

Token tags are typically handled completely internally by the text/parsing framework via the use of token taggers.

Classification Types

The IClassificationType interface provides information about classification types. A classification type is a high-level categorization, such as Identifier or Comment, that can be applied to text ranges via tags.

Each IClassificationType defines a string-based Key that identifies it, along with a more descriptive Description that may be used in user interfaces.

Note Note
Several of the most common classification types are available via static properties on the ClassificationTypes class.

The reuse of IClassificationType instances is highly recommended.

Tokens vs. Classifications

Tokens and classification tags are often related, especially in the case of token taggers. Let us examine an example.

In a C# document, consider a token that has been created via lexing for the keyword foreach. Syntax languages (advanced ones at least) generally assign different token ID values for each individual keyword. So the token ID for keyword foreach could be 50 for instance. This value is likely defined in some enumeration or static class of integer constants for the C# language. By doing this, when we later scan the tokens in the document, we know that this particular token is a foreach token without having to look at its text.

Now assume that a classification tag has been applied over the same text range via a token tagger. This classification would apply a Keyword classification type over that text range.

The difference is that where a token can be very specific as to what it represents, a classification tag over the same range is usually much more general. When the text/parsing framework is used within an editor control such as SyntaxEditor, classification tags are what drive syntax highlighting. In that scenario, each classification type is associated with a highlighting style. Therefore when ranges of text are classified with a classification type, SyntaxEditor maps the classification type to its related highlighting style and renders the text in the range using that style.

Even though token taggers most often provide both ITokenTag and IClassificationTag instances, additional IClassificationTag taggers can be layered on top of a token tagger to override and reclassify text. When used in an editor, this allows for more customized syntax highlighting to be added that merges with the default syntax highlighting.

Providing Tagged Ranges

Taggers are objects that can return an enumerable of tagged snapshot ranges that overlap a requested set of snapshot ranges. They are described in detail in the Taggers topic, along with details on special token taggers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Taggers and Tagger Providers

Text/Parsing Framework - Tagging
Taggers and Tagger Providers

Taggers are objects that can return tagged snapshot ranges for any requested snapshot range. They are generally created by tagger providers, which are language service. Tagger results are then consumed by tag aggregators.

This topic contains these sections:

  • The ITagger Interface
  • Token Taggers
  • Collection Taggers
  • Parse Error Taggers
  • Tagger Base Classes
  • Sample: ITagger<ISquiggleTag> Implementation
  • Tagger Providers
  • Registering with a Syntax Language

The ITagger Interface

Taggers must implement the ITagger`1 interface. The type parameter indicates the ITag-based type that is provided by the tagger. For instance, a tagger that returns IClassificationTag would be an ITagger<IClassificationTag>.

Returning Tagged Snapshot Ranges

The main focus of this interface is its GetTags method. That method is called when some other object, such as a tag aggregator, needs to know the tagged snapshot ranges provided by the tagger for one or more snapshot ranges. The return value of the method is an IEnumerable<TagSnapshotRange<T>>. This allows the C# yield keyword to be used when implementing a GetTags method.

Lifecycle

Since taggers generally attach to various events on a document or other objects, they have the notion of a lifecycle. The lifecycle starts when the tagger is created and ends when the tagger is closed.

The ITagger`1.Close method can be used to close a tagger. When a tagger is closed, its Closed event fires.

Notification of Tag Changes

Sometimes the data that a tagger monitors is updated in such a way that its tag results are affected. The tagger's TagsChanged event can be raised to notify any watchers, such as tag aggregators, that the tag data that can be retrieved has been updated.

The event arguments should indicate the snapshot range that was updated. If the entire document was updated, pass a snapshot range that starts at offset 0 and goes through the snapshot length.

Ordering Taggers

Most of the time, the order of taggers isn't important. However when working in an editor and layering IClassificationTag taggers, order is important since that governs how the highlighting style data related to one classification type is merged into the highlighting style data from another classification type.

Taggers must implement the IOrderable interface, which allows them to be ordered as desired.

Token Taggers

Token taggers are a special built-in implementation of taggers that return both ITokenTag and IClassificationTag objects. The tokens used are generated by the language's lexer. These tokens are returned in token tags, and are also used to generate related classification tags as appropriate.

Since in an editor, the syntax highlighting is based off of classifications, token taggers provide the mechanism by which a lexer indirectly provides the base syntax highlighting layer for code. Because token tags also report tokens for a given range, they are used to enable the functionality of scanning a snapshot by tokens.

Note Note
Only one token tagger should ever be associated with a document at any given time. Therefore only one tagger provider service should ever be registered on a language.

The TokenTagger Class

The TokenTagger class wraps all this functionality up into a handy package. For languages that have a mergable lexer, the TokenTagger class is all you need, and can be used by your language by adding a TokenTaggerProvider`1 service to your language with the type parameter of TokenTagger.

Note Note
If your language is loaded from a language definition file, a token tagger provider service will be automatically registered with your language. If your language is created in code-behind and all the code was generated by the Language Designer tool, it will make a custom token tagger provider class that can be used.

The standard TokenTagger works for languages with mergable lexers since the tokens created by those lexers already include references to the classification type that should be used for each individual token.

For languages with non-mergable lexers, tokens are smaller and more simplistic. They do not know the related classification type to use. Therefore for languages that use these types of lexers, you must create a class that inherits the TokenTagger class and overrides the ClassifyToken method. This method is passed a token and you return the IClassificationType, if any, to use for that token. The code in the base TokenTagger class takes care of the rest.

The TokenTagger class has a built-in mechanism to support incremental lexing from any point in a document, which is why it is considered a special case tagger type. It completely virtualizes the caching of token data for a document, and allows token data to be generated incrementally on-demand when requested. Whereas most parsing frameworks store all tokens for a document in memory (which can be really bad for large documents), this class instead uses a minimal amount of memory by only caching data at certain intervals and regenerates token data as needed. The net result is that a miniscule amount of memory is used to persist token data for incremental parsing vs. what most other products use, and performance is still good.

Sample: Adding a Token Tagger Provider Service

Assume that we are making an ECMAScript language and have an EcmaScriptTokenTagger class inherits TokenTagger and has a ClassifyToken override. This is how a provider for it could be installed:

C#
VB
Copy
​language.RegisterService(new TokenTaggerProvider<EcmaScriptTokenTagger>());
​language.RegisterService(New TokenTaggerProvider(Of EcmaScriptTokenTagger)())

Note Note
The example above only works for token taggers. For all other taggers, see the documentation on tagger providers below.

Collection Taggers

The ICollectionTagger`1 interface (and related CollectionTagger`1 implementation class) is a ITagger`1 that is ideal for situations where there is a set of tagged ranges that should be maintained like a collection. If you would rather virtualize your tagger results, you should make a tagger that inherits one of the tagger base classes instead.

Collection Items

The collection tagger stores tagged version ranges (TagVersionRange`1) items. This class represents an ITag and its associated ITextVersionRange in a document. The version range can be translated to any snapshot.

A TagVersionRange`1 can be created by passing it a lightweight ITextVersionRange (see the Offsets, Ranges, and Positions topic for details on how to create a version range), along with a tag.

Modifying the Collection

The tagger works just like a collection, where tagged version ranges (TagVersionRange`1 objects) can be added to it with the Add method. Similar Remove and Clear methods are also available.

Two additional overloads for the Add method allows for adding a TagVersionRange`1 indirectly by specifying a TextSnapshotRange and ITag, or an ITextSnapshotLine and ITag. In the latter case, the tagged region will track with a single line. Both of these overloads set the created TagVersionRange`1 to be deleted when it becomes zero-length. If more find-grained control over tracking modes (how the range adjusts due to text changes) is required, use the lower-level Add method that takes a TagVersionRange`1 directly.

An additional overload of the Remove method allows for indirectly removing a TagVersionRange`1 by finding the instance that has a specified ITag.

Two Toggle method overloads toggle whether a tagged range appears over a certain text range. Just like the additional Add method overloads, one accepts a TextSnapshotRange and ITag, and the other an ITextSnapshotLine and ITag. If any tags (within the same tagger) are located in the covered range, they will be removed. If there are no tags within that range, the result is the same as calling the related Add method.

Batch Updates

The tagger will fire off a TagsChanged event any time the collection is modified. When adding multiple tagged ranges, this is not efficient. Therefore, batches are supported. A batch can be created by calling the CreateBatch method. This returns an IDisposable object. When the object gets disposed, the batch is ended and the TagsChanged event is raised. Therefore this disposible object is ideal for use within a C# using block.

This code shows how to wrap tagger modification code in a batch update:
C#
VB
Copy
​using (IDisposable batch = tagger.CreateBatch()) {
    // Make batch updates here
}
​Using batch As IDisposable = tagger.CreateBatch()
    ' Make batch updates here
End Using

Finding Tags

The indexer of the ICollectionTagger`1 type allows you to specify an ITag and the related TagVersionRange`1 item is returned, if one is found.

ICollectionTagger`1 also supports more complex search operations via its FindNext method overloads. The FindNext method will find the next TagVersionRange`1 from the starting point that matches the options that are specified. This method is very useful in scenarios such as trying to find the next bookmark tagged range from the current caret offset in an editor.

One overload is line-based and accepts a start ITextSnapshotLine argument. The other is offset-based and accepts a start TextSnapshotOffset argument. Both overloads also take an optional ITagSearchOptions`1 argument.

The options have properties for setting whether the search should search upwards instead of downward (the default), if the search can wrap if it reaches the start/end of the document with no match, and a filter predicate that can allow for a lambda to decide whether a potential match is valid.

Parse Error Taggers

A ParseErrorTagger class may be available, which is a tagger for ISquiggleTag. When this tagger is provided to a document, it will watch for updates to the document's ParseData property. It will see if the parse data implements the IParseErrorProvider interface. If it does, this tagger will automatically provide related squiggle tags for all parse errors, and when in an editor, will automatically render squiggles under the appropriate text ranges.

This tagger can be attached to a document via a document-oriented tagger provider, described below.

Tagger Base Classes

There are several classes that can be used as base classes for tagger implementations.

Type Description
TaggerBase`1

This is an abstract base class for a tagger that implements nearly all of the ITagger`1 inteface. The only method that you need to implement in an inheriting class is the GetTags method.

In most scenarios, this is the ideal base class to use when writing a tagger.

The TaggerBase`1 constructor takes a string key that identifies the tagger, an optional collection of IOrderable objects (if ordering the tagger), and the ICodeDocument that the tagger is for. There also is an optional flag indicating whether or not the tagger is for a language. In most cases this should be true since it will automatically disconnect the tagger if the document's language is changed.

TokenTagger

This class is used for the special token tagger functionality that is described above. For languages with mergable lexers, an instance of this class can be installed as-is. However for languages with non-mergable lexers, you can make class that inherits TokenTagger and overrides its ClassifyToken method, which returns the IClassificationType to use for an IToken.

Sample: ITagger<ISquiggleTag> Implementation

In this sample we have implemented a tagger that uses the .NET regular expression engine to search for a text pattern. When a match is found, it is tagged with an ISquiggleTag. Assuming this is being used with an editor, a squiggle line will appear under the related text.

C#
VB
Copy
​/// <summary>
/// Provides <see cref="ISquiggleTag"/> objects over text ranges that contain the specified regex pattern text.
/// </summary>
public class CustomSquiggleTagger : TaggerBase<ISquiggleTag> {

    /// <summary>
    /// Initializes a new instance of the <c>CustomSquiggleTagger</c> class.
    /// </summary>
    /// <param name="document">The document to which this manager is attached.</param>
    public CustomSquiggleTagger(ICodeDocument document) :
        base("ActiproPatternBasedSquiggle", null, document, true) {}

    /// <summary>
    /// Returns the tag ranges that intersect with the specified normalized snapshot ranges.
    /// </summary>
    /// <param name="snapshotRanges">The collection of normalized snapshot ranges.</param>
    /// <param name="parameter">An optional parameter that provides contextual information about the tag request.</param>
    /// <returns>The tag ranges that intersect with the specified normalized snapshot ranges.</returns>
    public override IEnumerable<TagSnapshotRange<ISquiggleTag>> GetTags(
        NormalizedTextSnapshotRangeCollection snapshotRanges, object parameter) {

        if (snapshotRanges != null) {
            // Loop through the snapshot ranges
            foreach (TextSnapshotRange snapshotRange in snapshotRanges) {
                // Get the text of the snapshot range
                string text = snapshotRange.Text;

                // Look for a regex pattern match
                MatchCollection matches = Regex.Matches(text, @"\bActipro\b", RegexOptions.IgnoreCase);
                if (matches.Count > 0) {
                    // Loop through the matches
                    foreach (Match match in matches) {
                        // Create a tag
                        SquiggleTag tag = new SquiggleTag();

                        // Yield the tag
                        yield return new TagSnapshotRange<ISquiggleTag>(
                            TextSnapshotRange.FromSpan(snapshotRange.Snapshot,
                                snapshotRange.StartOffset + match.Index, match.Length), tag);
                    }
                }
            }
        }
    }
}
​''' <summary>
''' Provides <see cref="ISquiggleTag"/> objects over text ranges that contain the specified regex pattern text.
''' </summary>
Public Class CustomSquiggleTagger
    Inherits TaggerBase(Of ISquiggleTag)

    ''' <summary>
    ''' Initializes a new instance of the <c>CustomSquiggleTagger</c> class.
    ''' </summary>
    ''' <param name="document">The document to which this manager is attached.</param>
    Public Sub New(ByVal document As ICodeDocument)
        MyBase.New("ActiproPatternBasedSquiggle", Nothing, document, True)
    End Sub

    ''' <summary>
    ''' Returns the tag ranges that intersect with the specified normalized snapshot ranges.
    ''' </summary>
    ''' <param name="snapshotRanges">The collection of normalized snapshot ranges.</param>
    ''' <param name="parameter">An optional parameter that provides contextual information about the tag request.</param>
    ''' <returns>The tag ranges that intersect with the specified normalized snapshot ranges.</returns>
    Public Overrides Function GetTags(ByVal snapshotRanges As NormalizedTextSnapshotRangeCollection, _
        ByVal parameter As Object) As IEnumerable(Of TagSnapshotRange(Of ISquiggleTag))

        Dim results As List(Of TagSnapshotRange(Of ISquiggleTag)) = New List(Of TagSnapshotRange(Of ISquiggleTag))
        If snapshotRanges IsNot Nothing Then
            ' Loop through the snapshot ranges
            For Each snapshotRange As TextSnapshotRange In snapshotRanges
                ' Get the text of the snapshot range
                Dim text As String = snapshotRange.Text

                ' Look for a regex pattern match
                Dim matches As MatchCollection = Regex.Matches(text, "\bActipro\b", RegexOptions.IgnoreCase)
                If matches.Count > 0 Then
                    ' Loop through the matches
                    For Each match As Match In matches
                        ' Create a tag
                        Dim tag As New SquiggleTag()

                        ' Yield the tag
                        results.Add(New TagSnapshotRange(Of ISquiggleTag)(TextSnapshotRange.FromSpan( _
                            snapshotRange.Snapshot, snapshotRange.StartOffset + match.Index, match.Length), tag))
                    Next match
                End If
            Next snapshotRange
        End If
        Return results
    End Function
End Class

Tagger Providers

Tagger providers are objects that can create/retrieve taggers for a particular document or view. Taggers can be created for either a document or a view and their providers are called on-demand when a related tagger is needed.

The general rule is that if a tagger is going to provide tags for that document that should show up in any view that uses the document, a document-oriented tagger provider should be used. Most taggers fall into this category. An example of this would be a tagger that provides syntax error tags. Document-oriented tagger providers are represented by the ICodeDocumentTaggerProvider interface.

For other cases where a tagger should be for a specific view, a view-oriented tagger provider should be used. An example of this would be a tagger that relies on the current selection in a view. View-oriented tagger providers are represented by the ITextViewTaggerProvider interface.

Both tagger provider interfaces have two members: a TagTypes property that returns an enumerable of the Type of tags that are returned by provided taggers, and a GetTagger method that returns a tagger instance to use for the specified document/view.

Built-In Implementation Classes

These types are built-in classes that can be registered as services on syntax languages and used to provide taggers.

Type Description
CodeDocumentTaggerProvider`1

Creates a tagger is associated with an ICodeDocument and any view that uses it.

A constructor overload accepts a "singleton" object key that can be used to persist any created tagger into the ICodeDocument.Properties dictionary using the key. In this case, if the document's language changes, the tagger is automatically closed and removed from the properties dictionary. The tagger associated with the document can be retrieved via the properties dictionary while it is active.

If no "singleton" object is is passed to the tagger provider, a new tagger class instance will be created each time a tag aggregator requests one.

TextViewTaggerProvider`1

Creates a tagger is associated with a specific text view. This type is only available when an editor is used.

A constructor overload accepts a "singleton" object key that can be used to persist any created tagger into the ITextView.Properties dictionary using the key. In this case, if the view's document or the document's language changes, the tagger is automatically closed and removed from the properties dictionary. The tagger associated with the view can be retrieved via the properties dictionary while it is active.

If no "singleton" object is is passed to the tagger provider, a new tagger class instance will be created each time a tag aggregator requests one.

TokenTaggerProvider`1

Creates a token tagger (see above for more info) that is associated with an ICodeDocument and any views that use it.

Only one token tagger provider should ever be registered as a service on the same language at a time.

Registering with a Syntax Language

As described above, CodeDocumentTaggerProvider`1, TextViewTaggerProvider`1, and TokenTaggerProvider`1 objects can be used as language services to provide taggers to any tag aggregator that request them.

This code shows how to register a document-oriented tagger provider language service that provides ParseErrorTagger objects for documents that use the language. Note that we are also passing a "singleton" key so that the tagger that is created for any document using the language is persisted in the document's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
​language.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tag Aggregators

Text/Parsing Framework - Tagging
Tag Aggregators

Tag aggregators are objects that can monitor all the available taggers for a specific tag type and can return a unioned set of tagged snapshot ranges for a requested snapshot range. They are used for consuming the results of taggers.

This topic contains these sections:

  • When to Use Tag Aggregators?
  • Document- or View-Oriented Tag Aggregators
  • Collecting Tags
  • Notification of Tag Changes

When to Use Tag Aggregators?

Tag aggregators are used when you need to collect all the available tagged ranges for a certain snapshot range. Most often, tag aggregators are used in conjunction with adornment layers managers in editors. In this scenario, a tagger is used to mark ranges of text with a custom tag, basically indicating the ranges that need some sort of adornment. Then an adornment layer manager creates a tag aggregator for this custom tag. When the adornment layer manager builds adornments for a certain editor view line, it uses the tag aggregator to get the custom tags that fall in that line's text range and makes appropriate adornments based on the data passed in the custom tag.

To sum up, think of tags as data. Taggers are the data providers. Tag aggregators are the data consumers.

Document- or View-Oriented Tag Aggregators

As discussed in the Taggers and Tagger Providers topic, tagger providers can be oriented to create taggers either for an ICodeDocument or for an ITextView. Similarly, tag aggregators can be document- or view-oriented.

Document-oriented tag aggregators are created by calling the ICodeDocument.CreateTagAggregator method. The type of tag to collect is indicated as a type parameter to that method. The tag aggregator collects all the appropriate tags from any taggers associated with the document.

View-oriented tag aggregators are created by calling the ITextView.CreateTagAggregator method. The type of tag to collect is indicated as a type parameter to that method. The tag aggregator collects all the appropriate tags from any taggers associated with the view's document or with that specific view.

Collecting Tags

The ITagAggregator`1 inteface defines two overloads of a GetTags method. Both methods allow you to request the tags that fall into one or more snapshot ranges.

When either of these methods are called, the tag aggregator examines all of the appropriate taggers that provide the tag type associated with the tag aggregator.

Notification of Tag Changes

Whenever one of the taggers being monitored by a tag aggregator raises an event that notifies its tags have changed, the tag aggregator bubbles the event up as well via the TagsChanged event. Thus any listeners to this event can refresh themselves by requesting the updated tags in the affected range.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Text/Parsing Framework - Parsing
Overview

Parsing is the process of performing syntax and/or semantic analysis on a text, and outputting some sort of parse data, generally an AST. The parsing framework supports automated calling of parsers via worker threads following text changes. Any custom or third-party parser can be called.

This topic contains these sections:

  • Parse Requests and Dispatchers
  • Parsers
  • AST Nodes
  • Code Fragments
  • The Actipro LL(*) Parser Framework

Parse Requests and Dispatchers

Parse requests are created to request that syntax/semantic analysis be performed on some text. ICodeDocument is capable of automatically making parse requests when its text changes, so long as its ISyntaxLanguage has an IParser service registered.

A parse request dispatcher is notified of incoming parse requests and queues them. It uses one or more worker threads to execute the requested parsing operations in prioritized order, thereby preventing any blocking of the main UI thread.

See the Parse Requests and Dispatchers topic for more information.

Parsers

Parsers are objects that take in a parser request and output some sort of parse data. They are generally called via worker threads to prevent the blocking of the main UI thread.

The parse data returned by a parser is a result of performing syntax and/or semantic analysis on some text indicated by a parse request. Parsers can optionally be implemented to call into other parsing frameworks and return their results.

See the Parsers topic for more information.

AST Nodes

An abstract syntax tree (AST) is a structural tree representation of source code, without the specific details of the language, such as punctuation. An AST is comprised of AST Nodes, each which represent a particular construct in the concrete syntax.

See the AST Nodes topic for more information.

Code Fragments

Documents support code fragment editing, whereby the editable document text is a code fragment that is to be surrounded by header and footer text for the purposes of parsing. This is useful in situations where a language with parsing capabilties is used by a document but the end user should only be able to edit the contents of a specific method, expression, etc.

See the Code Fragments topic for more information.

The Actipro LL(*) Parser Framework

Actipro offers a very robust parser framework that makes it simple to build parsers using EBNF-like notation in C# and VB. It is free to use, has AST construction, error handling, callbacks, and a lot of other features that make it integrate nicely with our core text/parsing framework.

See the LL(*) Parser Framework section for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parse Requests and Dispatchers

Text/Parsing Framework - Parsing
Parse Requests and Dispatchers

Parse requests are created to request that syntax/semantic analysis be performed on some text. CodeDocument is capable of automatically making parse requests when its text changes, so long as its ISyntaxLanguage has an IParser service registered.

A parse request dispatcher is notified of incoming parse requests and queues them. It uses one or more worker threads to execute the requested parsing operations in prioritized order, thereby preventing any blocking of the main UI thread.

This topic contains these sections:

  • Initializing an Ambient Parse Request Dispatcher for an Application
  • CodeDocument Makes Automatic Parse Requests
  • Manually Triggering CodeDocument Parse Requests
  • Creating a Parse Request Manually
  • Other Parse Request Features
  • Other Parse Request Dispatcher Features

Initializing an Ambient Parse Request Dispatcher for an Application

An IParseRequestDispatcher is an object that is capable of receiving parse requests (IParseRequest instances). Upon receipt of a request, it will generally queue the request, possibly disposing of similar previous requests that are still on the queue.

One or more worker threads are then used to perform parsing operations, one by one, based on the data in the requests. More than one worker thread is advantageous when there are potentially many parsing requests queued, while editing of a code document (via a SyntaxEditor control for instance) is taking place. This allows the requests made by the code document to continue to get handled fast, intermixed with the other queued requests.

Important Note Important Note
By default, no ambient IParseRequestDispatcher is installed meaning parsing from code documents (explained in next section) will be done in the main UI thread. Configure an ambient parse request dispatcher (see below) to ensure parsing operations are offloaded into worker threads.

TaskBasedParseRequestDispatcher

TaskBasedParseRequestDispatcher is the default implementation of an IParseRequestDispatcher that ships with the parsing framework. It is capable of handling parse requests on one or more worker threads.

Configuring the Ambient Parse Request Dispatcher

As described below, code documents are capable of making automatic parse requests. They need to know which IParseRequestDispatcher to use though. If they can't find one, then they execute the parsing operation in the main UI thread, which can block UI if the parsing operation takes time.

The AmbientParseRequestDispatcherProvider class is used to indicate which IParseRequestDispatcher should be used by default. Code documents look at the AmbientParseRequestDispatcherProvider, and any manual parse requests should too.

This code is executed at application startup and creates a TaskBasedParseRequestDispatcher for use as the ambient parse request dispatcher.

C#
VB
Copy
​AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
​AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()

Once the code above is executed, worker threads will now be used to execute parsing operations.

At application shutdown, this code can be used to remove the ambient parse request dispatcher, kill its worker threads, and empty its parse queue.

C#
VB
Copy
​IParseRequestDispatcher dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
AmbientParseRequestDispatcherProvider.Dispatcher = null;
dispatcher.Dispose();
​Dim dispatcher As IParseRequestDispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
dispatcher.Dispose()

CodeDocument Makes Automatic Parse Requests

Code documents (CodeDocument instances) have special features built into them such that when a text change occurs, they look at the ISyntaxLanguage that is attached to the document, if any. If the language has an IParser registered as a service, an IParseRequest is automatically generated and sent to the IParseRequestDispatcher specified by the AmbientParseRequestDispatcherProvider to be queued for processing.

Note Note
As indicated above, if no ambient parse request dispatcher is configured, parsing operations will be performed in the main UI thread, possibly blocking it if the parsing operations take time to complete.

All of the parse request generation occurs automatically, as long as a parser is found on the language. The results of the parse operation are returned asynchronously to the ICodeDocument.ParseData property, at which time the document's ParseDataChanged event fires.

Note that ICodeDocument implements IParseTarget, so any code document is capable of receiving parsing operation results. That is how CodeDocument knows when to update its ParseData property.

Manually Triggering CodeDocument Parse Requests

Sometimes there are situations where a configuration option that the parser uses has changed but the text of an ICodeDocument has not been modified. Thus the parse data for the document may no longer be valid.

The ICodeDocument.QueueParseRequest method can be called in this scenario to manually queue up a parse request for the document. Once the parse request is processed, the document's ParseData property will be updated. As discussed above, like all parsing operations, this process may be asynchronous.

Creating a Parse Request Manually

Parse requests can be created manually for any bit of text. No document is necessary. Say that you are loading a C# project and would like to load compilation unit data for each one of the files in the project. In that case you could queue up parsing requests for each of the files. It is best to use a low priority so that the queued requests don't interfere with normal editor/code document parsing.

The ParseRequest class implements IParseRequest. Its constructor takes several parameters:

  • A string source key that identifies the source
  • An ITextBufferReader that is used by the parser to scan text
  • The ISyntaxLanguage (preferred) or IParser that should be used to perform the parsing operation
  • The IParseTarget that is notified once the parsing is completed

The source key is generally a filename but really can be anything you like that uniquely identifies the text content being parsed.

The ITextBufferReader can be any object that supports text reading per the interface members. The interface is described in the Scanning Text Using a Reader topic.

The ISyntaxLanguage is a language that has an IParser. If no ISyntaxLanguage is available, then an IParser instance can be passed in its place, but it is better to pass the language instance. The IParser is any object that has a Parse that accepts an IParseRequest and returns an IParseData result.

The IParseTarget is an object that has a unique ID identifying it, along with a method that is called after a request has been processed and completed.

This code shows how to create a manual request without a language available and queue it:

C#
VB
Copy
​// Create the request
string sourceKey = @"c:\myfilename.txt";
ITextBufferReader reader = new StringTextBufferReader("Text to parse");
IParser parser = new MyTextParser();  // Some class implementing IParser
IParseTarget parseTarget = this;  // Assuming class that executes this code implements IParseTarget
IParseRequest request = new ParseRequest(sourceKey, reader, parser, parseTarget);
request.Priority = ParseRequest.LowPriority;

// Queue the request
if (AmbientParseRequestDispatcherProvider.Dispatcher != null)
    AmbientParseRequestDispatcherProvider.Dispatcher.QueueRequest(request);
​' Create the request
Dim sourceKey As String = "c:\myfilename.txt"
Dim reader As ITextBufferReader = New StringTextBufferReader("Text to parse")
Dim parser As IParser = New MyTextParser() ' Some class implementing IParser
Dim parseTarget As IParseTarget = Me ' Assuming class that executes this code implements IParseTarget
Dim request As IParseRequest = New ParseRequest(sourceKey, reader, parser, parseTarget)
request.Priority = ParseRequest.LowPriority

' Queue the request
If AmbientParseRequestDispatcherProvider.Dispatcher IsNot Nothing Then
    AmbientParseRequestDispatcherProvider.Dispatcher.QueueRequest(request)
End If

Other Parse Request Features

The IParseRequest has some additional useful features.

Creation and Identification

The CreatedDateTime property indicates when the request was created.

The ParseHashKey property returns a hash key that can be used to identify the request, and is used in many IParseRequestDispatcher members.

Queueing - Priority and Optimization

The Priority property allows the priority of the request to be set. Manual parse requests should generally use the priority specified by ParseRequest.LowPriority. Code document requests use MediumPriority. IParseRequestDispatcher implementations generally use the priority setting to determine how to queue requests.

The RepeatedRequestPause property lets you indicate the number of milliseconds to pause if there are repeated attempts for the same request. This scenario can happen if an editor is working on a code document and a lot of typing is occurring. By introducing a small pause, performance is optimized. The default value is 250.

Originating Text Snapshot

The Snapshot property returns a ITextSnapshot that indicates the snapshot from which the request was made, if available. Note that while this property is automatically populated when CodeDocument creates the request, manually-created parse requests may choose not to specify a snapshot.

State

The State property returns a ParseRequestState value that indicates the current state of the request, such as whether it is queued, or being parsed, etc.

Custom Data

The Tag property allows for custom data to be passed along with the request, all the way through to the IParseTarget.

Other Parse Request Dispatcher Features

Generally it is not necessary to call any additional methods on IParseRequestDispatcher since the entire queue and dispatch processing is mostly automated for your convenience. However there are a number of useful members on the dispatcher that can tell you what it is currently doing, etc.

Many of the methods on the dispatcher deal with parse hash keys, which can be retrieved from the IParseRequest.ParseHashKey property.

Queue Updating

The QueueRequest method is used to tell the dispatcher that a new IParseRequest needs to be queued for processing. See the manual parse request example above for a sample of code calling this method.

The RemovePendingRequests method accepts a parse hash key and removes any queued instances of requests with that hash key, if there are any.

Dispatcher Examination

The IsBusy property indicates if there are any requests that need to be completed. PendingRequestCount returns the number of pending requests remaining.

GetPendingRequests returns an array of the pending requests remaining. HasPendingRequest returns whether there are any pending requests with a specific parse hash key.

Blocking Until a Request Has Been Processed

The WaitForParse method can be used to block the calling thread until a pending request with the specified hash key is completed, or a certain timespan is elapsed. The standard timespan used is 250ms.

This method is generally used before building contextual data for IntelliPrompt display since ideally you want the IntelliPrompt UI to have the most up-to-date data in it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsers

Text/Parsing Framework - Parsing
Parsers

Parsers are objects that take in a parser request and output some sort of parse data. They are generally called via worker threads to prevent the blocking of the main UI thread.

The parse data returned by a parser is a result of performing syntax and/or semantic analysis on some text indicated by a parse request. Parsers can optionally be implemented to call into other parsing frameworks and return their results.

This topic contains these sections:

  • What Does a Parser Do?
  • The IParser Interface
  • The Abstract ParserBase Class
  • Registering with a Syntax Language
  • The IParseData Interface
  • Document Parse Data
  • Quickly Parsing a Text String

What Does a Parser Do?

A parser is an object that can perform syntax and/or semantic analysis on text.

Processing Diagram

The concept is best illustrated with the following diagram, which shows the sequence of events that occur when a text change occurs in a code document. Near the end of the cycle, parsing kicks in and returns the parse data result back to the document.

Note that generally an IParseRequestDispatcher is used to queue parse requests and execute them on worker threads, meaning that parsing most often occurs asynchronously.

Syntax and Semantic Analysis

Syntax analysis is the process of iterating the tokens returned by a lexer, and converting that input into some structured representation. Put quite simply, it is the process of determining the structure of the code. The output from this sort of analysis is generally some sort of parse or syntax tree.

Semantic analysis is more concerned with examining the code to determine its meaning, rather than its syntax, although the output from syntax analysis is often used as input to the semantic analysis phase. Semantic checks may include type-checking, scope rules, or any other requirements described by a language specification.

The output of most parsers is some sort of abstract syntax tree (AST) with the root node being called a compilation unit. It may include symbol table data and/or a list of the syntax/semantic errors that were located during the parsing operation, if there were any. Any data can be returned, as long as it implements the IParseData interface.

Although the syntax and semantic analysis methodology described above is the formal definition of what generally takes place in parsing, parsing really can be any sort of processing that performed as a result of text scanning.

The IParser Interface

The IParser interface is very simple and only has a single Parse method defined. The Parse method takes in an IParseRequest and returns an IParseData object.

Note Note
See the Parse Requests and Dispatchers topic for more information on parse requests.

What does a parser actually do? Well it's entirely up to you. Generally, it calls some sort of external parser to examine the text in the request and return some sort of result.

However the parser could be implemented to simply execute your own custom code instead. Maybe you don't need to run a complicated parser that builds an AST and you simply want to build a list of variables defined and where they are defined. Anything is possible by scanning the text.

The only requirement for whatever the parser does is that it return its results in the form of an IParseData object. This object then gets placed in the calling ICodeDocument's ParseData property.

The Abstract ParserBase Class

An abstract base class called ParserBase that implements IParser is included with the parsing framework.

A parser can be implemented like this:

C#
VB
Copy
​public class MyParser : ParserBase {

    public MyParser() : base("MyParser") {}

    public override IParseData Parse(IParseRequest request) {
        IParseData parseData = null;

        // Perform some sort of parsing here and place the result in parseData

        return parseData;
    }

}
​Public Class MyParser
    Inherits ParserBase

    Public Sub New()
        MyBase.New("MyParser")
    End Sub

    Public Overrides Function Parse(ByVal request As IParseRequest) As IParseData
        Dim parseData As IParseData = Nothing

        ' Perform some sort of parsing here and place the result in parseData

        Return parseData
    End Function

End Class

Once you have a parser class defined, you should register it with your language.

Registering with a Syntax Language

An IParser can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<IParser>(new MyParser());
​language.RegisterService(Of IParser)(New MyParser())

Once the parser is registered with a language, it will be called automatically if any code documents that use the language are modified. See the Parse Requests and Dispatchers topic for more information.

When no IParser is registered with a language that is being used by a code document, then no parsing will occur when changes are made to that document.

The IParseData Interface

The IParseData interface defines the base requirements for an object that is returned as the result of a parsing opertion.

There are not currently any default implementations of this interface so you must ensure that any object that is returned by an IParser implements the interface.

Document Parse Data

The ICodeDocument.ParseData property is used to store the last parse result received for the document by an IParser.

When an IParser completes a parse operation, the IParseData that is returned is placed in the calling ICodeDocument's ParseData property. This generally happens asynchronously if a Parse Request Dispatcher is used.

At that time, the ICodeDocument.ParseDataChanged event fires, allowing you to update the user interface or take other action as appropriate.

Quickly Parsing a Text String

In some cases, it is desirable to load an ISyntaxLanguage and use its parser to parse a text string. There is an extension method called SyntaxLanguageParsingExtensions.Parse that is available when the Parsing namespace is referenced. This makes it simple to obtain the IParseData result of a parsing operation executed on the specified text.

The parsing operation executes within the calling thread, meaning the thread will block until the resulting parse data is obtained.

This sample code shows how to parse a string containing a C# code snippet, by using the CSharpSyntaxLanguage found in the .NET Languages Add-on:

C#
VB
Copy
​ISyntaxLanguage language = new CSharpSyntaxLanguage();
IParseData parseData = language.Parse("class Foo {}");
​Dim language As ISyntaxLanguage = New CSharpSyntaxLanguage()
Dim parseData As IParseData = language.Parse("class Foo {}")

The resulting IParseData object can be cast to the appropriate type that can provide AST and parse error results.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AST Nodes

Text/Parsing Framework - Parsing
AST Nodes

An abstract syntax tree (AST) is a structural tree representation of source code, without the specific details of the language, such as punctuation. An AST is comprised of AST Nodes, each which represent a particular construct in the concrete syntax.

This topic contains these sections:

  • An Example
  • Introduction to IAstNode
  • The DefaultAstNode Class
  • Type-Specific AST Nodes
  • The AstNodeBase Class

An Example

Here is an example of an AST for two simple expressions. Notice how the constructs of the original expressions are communicated through the AST, but language-specific syntactical details (such as operator precedence and punctuation) are excluded. The AST is correct for both expressions.

Sample Expression 1
Copy
1 + 4 / 7
Sample Expression 2
Copy
1 + (4 / 7)
Sample AST
Copy
"+" [
    1
    "/" [
        4
        7
    ]
]

Introduction to IAstNode

The IAstNode interface provides the base requirements for an AST node. It provides a standardized way for your syntax language's services to communicate or consume the syntactical structure of the document. Any custom or third-party AST node classes can be made to implement the interface.

IParser implementations generally create some sort of AST (a tree of IAstNode objects) for the document being parsed and provide the resulting AST as a property on the IParseData that is returned. The parse data as a whole is stored in the ICodeDocument.ParseData property, which it is available to other language services.

For instance, a code outliner could consume the IAstNode tree by searching for function declaration nodes and making the text range collapsible.

IAstNode Members

Member | Description
Children Property | Gets the list containing the child AST nodes of this AST node.
Contains Method | Returns whether the AST node contains the specified offset.
EndOffset Property | Gets or sets the end offset of the AST node, if known.
FindChildNode Method | Searches through the child nodes for a node that contains the specified offset.
FindDescendantNode Method | Recursively searches through the descendant nodes for a node that contains the specified offset.
HasChildren Property | Gets whether the AST node contains any child AST nodes.
Length Property | Gets the character length of this AST node, if known.
StartOffset Property | Gets or sets the start offset of the AST node, if known.
ToTreeString Method | Outputs the contents of the AST node in tree form.

The DefaultAstNode Class

The DefaultAstNode class provides a completely generic implementation of the IAstNode interface, where each node has a string Value and can contain any other node in its Children collection.

This class is good to use when first prototyping out a grammar, or in scenarios where type-specific AST nodes are not required. It is the default AST node type used by the LL(*) Parser Framework's tree constructors that don't designate a specific AST node type.

Type-Specific AST Nodes

Sometimes it is beneficial to have specific types of AST nodes, where a distinct .NET class is created for each type of AST node. Take this snippet of C# for example, a simple class declaration:

Code Snippet
Copy
class Foo {}

With the default AST nodes discussed above, a resulting AST would be something like:

Code Snippet
Copy
ClassDeclaration[
    Name[
        "Foo"
    ]
]

It's easy to imagine how large the AST grows as you get into much more complex code since additional AST nodes are typically used to describe the context of their contained nodes, such as with the Name node above.

In contrast, assume we build a class called ClassDeclaration like this:

C#
VB
Copy
​public class ClassDeclaration : AstNodeBase {
    public string Name { get; set; }
    ...
}
​Public Class ClassDeclaration
    Inherits AstNodeBase

    Public Property Name() As String
    ...

End Class

The ClassDeclaration class is a type-specific AST node, where instead of wrapping our Foo value node with another Name node, we simply set a string property called Name to the value Foo. The snippet that originally required three AST nodes to represent, now just uses one AST node with a property set. Thus the overall complexity of the AST is reduced.

Another major benefit of using type-specific AST nodes is that since they are .NET classes, you can fully extend them with partial classes, etc. This makes it easy to add helper methods/properties or to override the default ToString result.

The only downside of using type-specific AST nodes is that they can take more time to develop, since you need to define a class for each type of AST node your language grammar can generate. Luckily, we've made this almost a non-issue since the Language Designer tool has full type-specific AST node code generation features. All you have to do is indicate a few settings for each AST node type and its properties, and the code will be generated for you.

The AstNodeBase Class

The abstract AstNodeBase class is available to use as a base class for any type-specific AST nodes. It fully implements the IAstNode interface.

The only requirement of inheritors is that they override its GetChildrenEnumerator method to return an enumerator for any IAstNode objects that are children of the node. This allows the node's IAstNode.Children property enumerate child nodes.

For instance, a ClassDeclaration class might define a Members property where each member is represented by another AST node. In this scenario, the GetChildrenEnumerator method should be overridden to return those AST nodes.

If your type-specific AST nodes are generated by the Language Designer tool, all this work is done for you.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Fragments

Text/Parsing Framework - Parsing
Code Fragments

Documents support code fragment editing, whereby the editable document text is a code fragment that is to be surrounded by header and footer text for the purposes of parsing. This is useful in situations where a language with parsing capabilties is used by a document but the end user should only be able to edit the contents of a specific method, expression, etc.

This topic contains these sections:

  • How It Works
  • An Example
  • Languages With Significant Line Terminators

How It Works

To set the optional header and footer text for a document, use the ITextDocument.SetHeaderAndFooterText method.

When this method is called, a new ITextSnapshot is created for the document with updated HeaderText and FooterText properties.

Whenever the document's text is changed, a new parse request is made if the document's language has a parser service. One component of this parse request is an ITextBufferReader that is used by the parser to read through the snapshot's text and parse it. A method called ITextSnapshot.GetMergedBufferReader is used to obtain an ITextBufferReader for this purpose. If header/footer text are specified for the snapshot, they are included as part of that buffer reader. The end result is that the parser thinks that the header/footer text, which surround the snapshot's text, are part of the snapshot's text, even though they really are not. All of this happens automatically behind the scenes.

Note Note
If header text is used, the reader will start at a negative offset. This is done so that the real snapshot text still aligns to offset 0, and all AST nodes, syntax errors, etc. that are created by the parser will properly align with the offsets of the snapshot text.

An Example

Say that you wanted an editor to only edit a method body but you still want full IntelliPrompt features while editing. This is an example of code fragment editing.

First you define the header and footer of the code fragment. The header contains the namespace, class, and member declarations. The footer contains the closing braces and any other members that should be accessible while editing the code fragment. The header and footer are set via the ITextDocument.SetHeaderAndFooterText method.

This is an example of C# code fragment editing, where a class named Foo contains a method Bar, and the document's text will be editing the contents of that method.

C#
VB
Copy
​document.SetHeaderAndFooterText("class Foo { object Bar() {", "}}");
​document.SetHeaderAndFooterText("class Foo { object Bar() {", "}}")

If the document's current snapshot has return null; in its text, the buffer reader sent to the parser for parsing will contain:

Code Snippet
Copy
class Foo { object Bar() {return null;}}

The AST built for the document will fully contain the Foo class and Bar method, and any syntax errors will be reported correctly. This allows advanced languages with resolvers and automated IntelliPrompt features to have their functionality work correctly, even in code fragment editing scenarios.

Languages With Significant Line Terminators

Some languages such as Visual Basic treat line terminators as significant tokens in their parser grammars. Namely, in VB, line terminators end statements.

Thus in languages like this, it's very important to ensure there is a line terminator at the end of any header text specified, and probably also at the start of any footer text specified. Since the header, snapshot, and footer text are simply appended together, this ensures that no syntax errors will be generated from missing line terminators.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Text/Parsing Framework - Advanced Text Features
Overview

The text framework contains numerous advanced features that build upon the core text features, everything from a search object model to the exporting of HTML and RTF.

This topic contains these sections:

  • Low-Level Search Operations
  • Undo History
  • Text Statistics
  • Exporting to HTML / RTF
  • Line Commenting
  • Text Formatting
  • Structure Matching
  • Lipsum Generator
  • Document Properties

Low-Level Search Operations

The text framework contains an object model for performing low-level search operations. This low-level object model is usually called by higher-level search object models that are more view-based.

See the Low-Level Search Operations topic for more information.

Undo History

The text framework's undo history tracks undoable text changes, allows for examination and manipulation of the undo/redo stacks, and provides access to the change types (unsaved/saved) for snapshot lines.

See the Undo History topic for more information.

Text Statistics

Text statistics are a powerful feature that provide statistics about text in a document. By default, there are numerous text statistics available, even including things like readability scores. Syntax languages can also choose to customize the statistics by supplying additional ones such as commented-line counts, etc.

See the Text Statistics topic for more information.

Exporting to HTML / RTF

Text from a snapshot can easily be exported to a String or file in various HTML and RTF (rich text) formats.

See the Exporting to HTML / RTF topic for more information.

Line Commenting

The text framework includes an extensible interface for commenting and uncommenting regions of text. Both line-based and range comment styles are supported.

See the Line Commenting topic for more information.

Text Formatting

The text framework includes an interface for formatting regions of text, where whitespace and other symbols such as braces are adjusted to make code more readable.

See the Text Formatting topic for more information.

Structure Matching

The text framework includes support for locating matching structural text delimiters, such as brackets.

See the Structure Matching topic for more information.

Lipsum Generator

A special utility class is included supports the generation of 'lorem ipsum' placeholder text. Placeholder text is useful for developers and designers when prototyping out web pages and screens. It is designed to contain unreadable gibberish sentences, which are ideal for layout.

See the Lipsum Generator topic for more information.

Document Properties

The ICodeDocument.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the document.

See the Document Properties topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Low-Level Search Operations

Text/Parsing Framework - Advanced Text Features
Low-Level Search Operations

The text framework contains an object model for performing low-level search operations. This low-level object model is usually called by higher-level search object models that are more view-based.

This topic contains these sections:

  • Finding Text
  • Replacing Text
  • Search Results
  • Search Options
  • Built-In Search Pattern Providers
  • Creating a Custom Search Pattern Provider

Finding Text

Since text snapshots provide immutable views on a text document, the ITextSnapshot interface contains several methods for finding text:

Member | Description
FindAll Method | Performs a find all operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.
FindNext Method | Performs a find next operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.

Both methods return an ISearchResultSet object that contains information about the search results. In the case of an find all operation, more than one result may be present within the result set.

Replacing Text

Since text change operations typically originate from a document, the ITextDocument interface contains several methods for replacing text:

Member | Description
ReplaceAll Method | Performs a replace all operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.
ReplaceNext Method | Performs a replace next operation. There are two overloads of this method. One overload accepts a TextRange indicating the range of offsets to search.

Both methods return an ISearchResultSet object that contains information about the search results. In the case of an replace all operation, more than one result may be present within the result set.

Search Results

ISearchResultSet instances are what are returned by all the search methods. The result set provides a deep copy of the ISearchOptions used by the search operation, a SearchOperationType indicating the type of operation (find next, find all, etc.), whether the searching wrapped at the end of the search range, and the collection of ISearchResult objects that specify individual results.

The ToString method of the ISearchResultSet provides a text representation of the search criteria and individual results, and can be useful for display in results windows.

Each ISearchResult object indicates the TextSnapshotRange at which the result was found, and in the case of replace operations, the TextSnapshotRange of the replaced text. If no replace occurred, that TextSnapshotRange will be marked as deleted.

ISearchResult also contains a collection of captures. Since the search engine is based on regular expressions, this collection specifies the captures that were made. Each ISearchCapture has a key that identifies the capture, the text that was captured, and its offset range.

Search Options

The ISearchOptions interface contains all the settings needed to perform a search operation. These options include the text to find/replace, whether to match case, match whole word, search up, and the type of seatch pattern provider to use (normal, regular expressions, etc.). The maximum number of results can also be set, which is useful in find all scenarios.

Each core search method described above accepts an ISearchOptions instance. Any custom implementations of ISearchOptions should implement an Equals method override.

Built-In Search Pattern Providers

A search pattern format is a syntax for entering how to find and replace text within a document. Since the search engine is regular expression-based, the ISearchPatternProvider interface provides two methods, one for getting a regex pattern for supplied find text, and one for getting a regex pattern for supplied replace text.

The text framework ships with five built-in pattern providers:

  • Normal is a plain text find and replace format.
  • Regular Expression uses regular expressions to match find text, and uses regular expression replace pattern syntax to allow for replacements at different matched capture points in the find pattern.
  • Wildcard uses simple wildcard search patterns to match text.
  • Acronym matches a character at the start of a word, then every capital letter or character following an underscore.
  • Shorthand allows any non-whitespace character to be between the search pattern characters.

Note Note
The SearchPatternProviders static class provides access to each of these ISearchPatternProvider instances.

Normal Pattern Provider

This pattern provider searchs for the find text exactly as specified and replaces using the exact replace text.

Regular Expression Pattern Provider

Regular expression find/replace operations search for text by using .NET regular expression syntax pattern matching. It is important to note that pattern whitespace is ignored. Whitespace can be matched by using the \s character class.

The regular expression pattern provider has a feature that the others don't have. In its replace patterns, substitutions can be specified. Replace patterns recognize normal text characters, regular expression escape characters (\n meaning line feed, etc.), and substitution specifications ($1, etc.).

Substitutions place text from captures into the replace text. This is best illustrated by an example. Say the text to search in is using System;, the find text is using \s+ (\w[\w\.]+);, and the replace text is Namespace: $1;. This operation is looking for any C# using statement and is outputting the namespace. So the result in this scenario is Namespace: System;.

See the Regular Expression Language Elements topic for more information on the regular expression syntax.

Wildcard Pattern Provider

Wildcard pattern providers search for text by using "wildcard" pattern matching. The following wildcard patterns are recognized:

Construct | Description
* | Specifies zero or more of any character, except the line feed character.
? | Specifies any single character, except the line feed character.
# | Specifies any single digit.
[aeiou] | Matches any one character in the set.
[!aeiou] | Matches any one character not in the set.

Any other character in the pattern matches the character. An example wildcard pattern is using *;. This pattern will match any C# using statement.

Acronym Pattern Provider

Acronym searching matches a character at the start of a word, then every capital letter or character following an underscore. Space characters have special meaning to match any whitespace character.

An example acronym pattern fr would match the text FindR in the word FindReplace.

Shorthand Pattern Provider

Shorthand searching is even more open in scope than acronyms. It allows any non-whitespace character to be between the search pattern characters. Space characters have special meaning to match any whitespace character.

An example shorthand pattern fr would match the text for in the word therefore.

Creating a Custom Search Pattern Provider

Although the text framework comes packaged with the pattern providers described above, it's easy to create your own custom search pattern providers as well.

The ISearchPatternProvider interface has several members. One is a string Key that identifies it. Another is a more verbose Description that can be displayed in user interfaces. Then there are two methods that must be implemented.

The GetFindPattern method returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses the provider. Likewise, the GetReplacePattern method returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses the provider.

As mentioned above, the core search engine uses our built-in regular expression engine to perform searching. Therefore search patterns used by the search engine must be provided in regular expression syntax. That is essentially what an ISearchPatternProvider does, converts a custom pattern syntax to regular expression syntax.

Finally, the RequiresCaseSensitivity property returns whether the find patterns used require case sensitivity. If this is false, the default, the ISearchOptions.MatchCase value is used instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Undo History

Text/Parsing Framework - Undo History
Undo History

The text framework's undo history tracks undoable text changes, allows for examination and manipulation of the undo/redo stacks, and provides access to the change types (unsaved/saved) for snapshot lines.

This topic contains these sections:

  • Undo History
  • Clearing the Undo/Redo Stacks
  • Enumerating Undo/Redo Stack Entries
  • Performing an Undo or Redo
  • Getting the Change Type for a Line

Undo History

The ITextDocument.UndoHistory property is used to access the IUndoHistory, which provides the undo/redo features for a document.

The undo history contains two stacks, the UndoStack and RedoStack. As text changes are performed on a document, undo entries are added to the undo stack. When an undo operation is performed, the top item on the undo stack is moved to the redo stack and the document text is updated appropriately. If a redo operation is performed, the top item on the redo stack is moved back to the undo stack and the document text is updated appropriately.

Clearing the Undo/Redo Stacks

The undo/redo stacks can be cleared by calling the IUndoHistory.Clear method. The parameterless overload of this method keeps all change tracking in place, while another overload allows for specifying whether to reset change tracking.

The undo/redo stacks are automatically cleared when the ITextDocument.SetText method overload is called that only accepts a String parameter. This is done since when calling that method, it is assumed that you are completely replacing and resetting the text content of the document.

Enumerating Undo/Redo Stack Entries

The CanUndo and CanRedo properties indicate whether there are any entries currently on the undo/redo stacks.

For enumerating the stack entries, use the UndoStack and RedoStack properties to retrieve the proper stack. These both return an IUndoableTextChangeStack instance.

Each stack has a Count property and the stack is capable of enumerating IUndoableTextChange entries. A specific stack entry can be retrieved using the GetTextChange method. The capacity for a stack can be changed via the Capacity property. The default capacity is 100 entries but can be made as large or small as you wish.

The IUndoableTextChange interface contains a lot of information found on the ITextChange interface that created it. A Description property returns a description of the entry that can be displayed in user interfaces.

Performing an Undo or Redo

An undo operation can be performed like this:

C#
VB
Copy
​document.UndoHistory.Undo();
​document.UndoHistory.Undo()

An redo operation can be performed like this:

C#
VB
Copy
​document.UndoHistory.Redo();
​document.UndoHistory.Redo()

Other overloads for the Undo and Redo methods allow you to undo/redo multiple entries.

Getting the Change Type for a Line

The undo history tracks the change types for lines in the document, meaning whether lines have been modified at all, modified since the last save, or never modified. The change type is represented by the SavePointChangeType enumeration and can be either None, UnsavedChanges, or SavedChanges.

As changes occur in a document, the appropriate ranges are marked as unsaved changes. When the ITextDocument.IsModified property changes to false, the unsaved changes are modified to be saved changes. From that point on, any new changes that occur are marked unsaved again. When the undo history gets cleared (see above), all change tracking is cleared, since it is assumed that the document has been reset.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Statistics

Text/Parsing Framework - Advanced Text Features
Text Statistics

Text statistics are a powerful feature that provide statistics about text in a document. By default, there are numerous text statistics available, even including things like readability scores. Syntax languages can also choose to customize the statistics by supplying additional ones such as commented-line counts, etc.

This topic contains these sections:

  • Built-In Statistics
  • Getting Statistics for a Snapshot
  • Getting Statistics for a String
  • Registering a Custom Statistics Factory for a Syntax Language

Built-In Statistics

The ITextStatistics interface calculates and returns statistics. It includes many built-in statistics such as:

  • Line count
  • Whitespace line count
  • Sentence count
  • Word count
  • Syllable count
  • Character count
  • Whitespace character count
  • Letter count
  • Consonant count
  • Vowel count
  • Average words / sentence
  • Average syllables / word
  • Average letters / word
  • Flesch reading ease score
  • Flesch-Kincaid grade level

See the ITextStatistics class library documentation for a list of the statistic properties on the interface.

Getting Statistics for a Snapshot

The ITextSnapshot.GetTextStatistics method can be called to retrieve the ITextStatistics for the snapshot. If an ISyntaxLanguage is attached to the snapshot's document, it will be used to generate the statistics. This is where custom language-specific statistics can be retrieved if they have been created.

This code shows how to get the statistics for the current snapshot of a document:

C#
VB
Copy
​ITextStatistics stats = document.CurrentSnapshot.GetTextStatistics();
​Dim stats As ITextStatistics = document.CurrentSnapshot.GetTextStatistics()

Getting Statistics for a String

Text statistics can also be generated for a String variable by creating an instance of the TextStatistics class.

This code shows how to generate the built-in statistics for a String variable named text:

C#
VB
Copy
​ITextStatistics stats = new TextStatistics(text);
​Dim stats As ITextStatistics = New TextStatistics(text)

Registering a Custom Statistics Factory for a Syntax Language

In some syntax languages, some of those statistics may not be useful or you may wish to add other statistics, such as comment coverage. Adding new statistics is easy.

First, make a class that inherits TextStatistics.

Second, in your TextStatistics class, calculate your additional statistics in the constructor.

Third, override the GetRawStatistics method so that the additional statistics are added to the returned list. You can optionally remove built-in statistics here too. The returned list has items of type ITextStatistic. The TextStatistics.CreateStatistic static method can be used to create items to add to the list.

Fourth, make a class that implements ITextStatisticsFactory by building a CreateStatistics method. This method should return an instance of the TextStatistics-based class you created in the previous steps.

Finally, we you need to associate the ITextStatisticsFactory with your language so that the custom text statistics can be used. An ITextStatisticsFactory can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ITextStatisticsFactory>(myTextStatisticsFactory);
​language.RegisterService(Of ITextStatisticsFactory)(myTextStatisticsFactory)

Your custom statistics should be ready for use after that.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Exporting to HTML / RTF

Text/Parsing Framework - Advanced Text Features
Exporting to HTML / RTF

Text from a snapshot can easily be exported to a String or file in various HTML and RTF (rich text) formats.

The ITextExporter interface provides a unified model that supports exporting to any custom output format, although the text framework only includes built-in implementations for HTML and RTF.

This topic contains these sections:

  • Built-in HTML Exporters
  • Built-in RTF Exporter
  • Using a Custom IHighlightingStyleRegistry
  • Exporting to a String
  • Exporting Selected Text in a SyntaxEditor View
  • Exporting a Snapshot Text Range

Built-in HTML Exporters

The text framework has four formats for exporting HTML, all available as methods on the TextExporterFactory class:

Member Description
CreateHtmlClassBased Method

Returns the IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.

CSS class references will be used for highlighting. This type adds a STYLE tag block to the exported HTML where CSS classes are defined. The text in the code block references these CSS classes, therefore allowing color settings to easily be altered for each highlighting style (i.e. keywords, comments, etc.). Root HTML, BODY and other tags will be added to the output.

CreateHtmlClipboard Method

Returns the IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.

The output of this exporter is the same as CreateHtmlInlineFragment, except that some additional information is added to make the exported text compatible with the Windows clipboard HTML data format.

CreateHtmlInline Method

Returns the IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.

Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will be added to the output.

CreateHtmlInlineFragment Method

Returns the IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.

Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will not be added to the output.

The appropriate exporter should be used based on your HTML output needs.

Built-in RTF Exporter

The TextExporterFactory class also has a static CreateRtf method for creating a RTF exporter.

Using a Custom IHighlightingStyleRegistry

The constructor of the TextExporterFactory class optionally takes an IHighlightingStyleRegistry argument. If specified, that registry will be used for converting classification types to styles. Otherwise, the AmbientHighlightingStyleRegistry will be used.

Exporting to a String

Exporting to a string is done via the ITextSnapshot.Export method.

This code shows how to export the contents of an ITextSnapshot to a string in RTF format:

C#
VB
Copy
​string text = document.CurrentSnapshot.Export(new TextExporterFactory().CreateRtf());
​Dim text As String = document.CurrentSnapshot.Export(New TextExporterFactory().CreateRtf())

Exporting Selected Text in a SyntaxEditor View

Exporting to the selected text in a SyntaxEditor view to a string is done via the IEditorView.ExportSelectedText method.

This code shows how to export the selected text in the active view to a string in RTF format:

C#
VB
Copy
​string text = editor.ActiveView.ExportSelectedText(new TextExporterFactory().CreateRtf());
​Dim text As String = editor.ActiveView.ExportSelectedText(New TextExporterFactory().CreateRtf())

Exporting a Snapshot Text Range

The ITextExporter.Export method allows for the exporting of any custom snapshot text range.

This code shows how to export a snapshot text range to a string in RTF format:

C#
VB
Copy
​string text = new TextExporterFactory().CreateRtf().Export(snapshot, new TextRange[] { textRange });
​Dim text As String = New TextExporterFactory().CreateRtf().Export(snapshot, New TextRange() { textRange })

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Commenting

Text/Parsing Framework - Advanced Text Features
Line Commenting

The text framework includes an extensible interface for commenting and uncommenting regions of text. Both line-based and range comment styles are supported.

Commenting is performed by inserting language-specific comment delimiters. Uncommenting is performed by removing the language-specific comment delimiters.

This topic contains these sections:

  • Registering a Line Commenter with a Syntax Language
  • Commenting a Range of Text
  • Uncommenting a Range of Text
  • Creating a Line-Based Line Commenter
  • Creating a Range Line Commenter

Registering a Line Commenter with a Syntax Language

Line commenters implement the ILineCommenter interface. This interface defines two methods.

The Comment method has parameters that indicate the TextSnapshotRange to examine and the ITextChangeOptions to use when inserting comment delimiters. The Uncomment method has the same parameters, although it removes comment delimiters instead.

An ILineCommenter can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ILineCommenter>(myLineCommenter);
​language.RegisterService(Of ILineCommenter)(myLineCommenter)

Registering line commenters with a language is optional, but recommended.

Commenting a Range of Text

This code uses an ICodeDocument's current language's line commenter to comment out a range of text from offset 0-10:

C#
VB
Copy
​if (document.Language.LineCommenter != null) {
    TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 0, 10);
    ITextChangeOptions options = new TextChangeOptions();
    document.Language.LineCommenter.Comment(range, options);
}
​If Not (document.Language.LineCommenter Is Nothing) Then
    Dim range As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 0, 10)
    Dim options As ITextChangeOptions = New TextChangeOptions()
    document.Language.LineCommenter.Comment(range, options)
End If

Uncommenting a Range of Text

This code uses an ICodeDocument's current language's line commenter to uncomment a range of text from offset 0-10:

C#
VB
Copy
​if (document.Language.LineCommenter != null) {
    TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 0, 10);
    ITextChangeOptions options = new TextChangeOptions();
    document.Language.LineCommenter.Uncomment(range, options);
}
​If Not (document.Language.LineCommenter Is Nothing) Then
    Dim range As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 0, 10)
    Dim options As ITextChangeOptions = New TextChangeOptions()
    document.Language.LineCommenter.Uncomment(range, options)
End If

Creating a Line-Based Line Commenter

Line-based line commenters are used in languages like C# where // should be used to comment out lines of text. To accomplish this, create a LineBasedLineCommenter object.

LineBasedLineCommenter already has the comment and uncomment code implemented. However it defines a StartDelimiter property that must be set to the start comment delimiter for your language.

LineBasedLineCommenter has a CanCommentEmptyLines property that determines whether to comment a line that is only whitespace. The default is true.

For C#, this would be set to the string //. For VB, this would be set to the string '.

Creating a Range Line Commenter

Range line commenters are used in languages like XML where <!-- --> should be used to comment out lines of text. To accomplish this, create a RangeLineCommenter object.

RangeLineCommenter already has the comment and uncomment code implemented. However it defines a StartDelimiter and EndDelimiter properties that must be set to the start and end comment delimiters for your language.

For XML, the start delimiter would be set to the string <!-- and the end delimiter would be set to the string -->.

Comment Token ID

If your range comment consists of a single token and you wish to enhance the comment locating logic when performing an uncomment, set the RangeLineCommenter.CommentTokenId property to the comment token's ID. As long as the selection is fully within a token with that ID, it will be found.

Advanced Logic

If your range comment consists of multiple tokens or requires more advanced logic to properly locate it, you can override the virtual RangeLineCommenter.FindCommentTextRange method. It passes in the TextSnapshotRange to examine. You can create a snapshot reader to examine text and tokens over that range. Then return a TextRange indicating the range of the comment. If no comment was found, return null instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatting

Text/Parsing Framework - Advanced Text Features
Text Formatting

The text framework includes an interface for formatting regions of text. Text that has been formatted can be more readable because whitespace and symbols such as braces are uniformly placed.

This topic contains these sections:

  • Formatting Logic
  • Registering a Text Formatter with a Syntax Language
  • Formatting a Range of Text

Formatting Logic

Text formatters implement the ITextFormatter interface. This interface defines one method, the Format method, which has one parameter that indicates the TextSnapshotRange to examine and update.

The TextSnapshotOffset.Snapshot property gives access to its ITextSnapshot. Likewise, the ITextSnapshot.Document provides access to its owner ITextDocument. The ITextDocument.TabSize property tells how many spaces are in a tab, in case that information is useful while formatting.

If the ITextDocument is an ICodeDocument, the ICodeDocument.ParseData property may also contain AST or other language-specific information that can be useful when formatting.

When formatting, it is likely that multiple changes will be made. These updates can be batched up into a single undoable text change. For information on text changes, see the Text Changes and Operations topic.

Formatters are free to implement any custom logic to perform the formatting. However, there are most likely going to be similarities in the technique that most formatters use. Here are some common steps that a formatter might follow in the process of formatting a document:

  1. Find the next token that allows whitespace between itself and the following non-whitespace token.
  2. Replace all whitespace between these two tokens with the new whitespace, which can either be no whitespace at all, or a combination of any number of linebreaks, tabs and spaces.
  3. Repeat from step 1 until the entire range is formatted.

Registering a Text Formatter with a Syntax Language

An ITextFormatter can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ITextFormatter>(myTextFormatter);
​language.RegisterService(Of ITextFormatter)(myTextFormatter)

Registering a text formatter with a language is optional, but recommended.

Formatting a Range of Text

This code uses an ICodeDocument's current language's text formatter to format a range of text from offset 0-10:

C#
VB
Copy
​ITextFormatter textFormatter = document.Language.GetService<ITextFormatter>();
if (textFormatter != null) {
    TextSnapshotRange range = new TextSnapshotRange(document.CurrentSnapshot, 0, 10);
    textFormatter.Format(range);
}
​Dim textFormatter As ITextFormatter = document.Language.GetService(Of ITextFormatter)();
If Not (textFormatter Is Nothing) Then
    Dim range As TextSnapshotRange = New TextSnapshotRange(document.CurrentSnapshot, 0, 10)
    textFormatter.Format(range)
End If

This code uses an ICodeDocument's current language's text formatter to format the entire document:

C#
VB
Copy
​ITextFormatter textFormatter = document.Language.GetService<ITextFormatter>();
if (textFormatter != null)
    textFormatter.Format(document.CurrentSnapshot.SnapshotRange);
​Dim textFormatter As ITextFormatter = document.Language.GetService(Of ITextFormatter)();
If Not (textFormatter Is Nothing) Then
    textFormatter.Format(document.CurrentSnapshot.SnapshotRange)
End If

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Structure Matching

Text/Parsing Framework - Advanced Text Features
Structure Matching

The text framework includes support for locating matching structural text delimiters, such as brackets.

Once the language service is implemented for structure matching, SyntaxEditor features such as move to matching bracket and select to matching bracket are automatically supported. Structure matching is also a requirement for the delimiter highlighting feature.

This topic contains these sections:

  • Matching Logic
  • Registering a Structure Matcher with a Syntax Language
  • Default Structure Matcher Implementation

Matching Logic

Structure matchers implement the IStructureMatcher interface, which defines a single method. The Match method accepts the TextSnapshotOffset to examine and an IStructureMatchOptions object that provides match options. The goal of this method is to look around the offset and built a set of results that indicate if there are structural text delimiters (generally parentheses and braces) around it. For instance if the caret is next to a parenthesis, then the method would return results indicating the range of the parenthesis and also the range of its matching parenthesis, if found.

The TextSnapshotOffset.Snapshot property gives access to its ITextSnapshot. From the ITextSnapshot, an ITextSnapshotReader can be obtained.

A structure matcher generally does text scanning, token scanning, or even AST examination to build its results. The ITextSnapshotReader allows for easy text and token scanning of a snapshot. If an AST is needed for examination and the ITextDocument is an ICodeDocument, the ICodeDocument.ParseData property may also contain AST or other language-specific information that can be useful when performing matching logic.

Options

The IStructureMatchOptions interface defines a IsNavigationRequest property that can be set to true when the request is being made for navigation purposes, such as SyntaxEditor's move to matching bracket feature. When this property is true, the match logic should be a bit more liberal and allow any possible bracket surrounding or next to the source offset to be a valid result.

When this property is false, the request is more likely for a feature such as delimiter highlighting. And in that case, the logic for finding a match next to the source offset should be a bit more strict.

Results

The Match method returns an IStructureMatchResultSet object that contains a collection of IStructureMatchResult objects. Each IStructureMatchResult indicates its TextSnapshotRange and also an optional TextSnapshotOffset if the match is something that can be navigated to when SyntaxEditor's move to matching bracket feature is utilized.

If a structural delimiter is next to the source offset, a result for that delimiter should be included in the result set, and its IsSource property needs to be set to true. Any other "matching" structural delimiters should also be included in the collection.

For example, if parenthesis structure matching is supported, the match logic would first use an ITextSnapshotReader to see if a parenthesis is next to the source offset. If there is one, a result (with IsSource indication) is added to the result set for that parenthesis. Then the reader is used to scan forward or backward as appropriate to look for a matching parenthesis. If one is found, a second result is added to the result set.

Structure matching also supports multiple results. Say that the structure matching should support #if...#else...#endif blocks. If the source offset is within the #else then the result set would include three results (one for each directive text range) and only the one for #else would have its IsSource property set to true.

Each result also has a MatchEdges property that should be set to a StructureMatchEdges value indicating which edges (none, start, end, or both) of the result's range can cause the structure matcher to match the result again. This information is used for optimizations by the delimiter highlighting feature.

Registering a Structure Matcher with a Syntax Language

An IStructureMatcher can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<IStructureMatcher>(myStructureMatcher);
​language.RegisterService(Of IStructureMatcher)(myStructureMatcher)

Registering structure matchers with a language is optional, but recommended.

Default Structure Matcher Implementation

A built-in StructureMatcher class is included that implements IStructureMatcher and makes it easy for a language to support matching of these bracket pairs:

  • Angle braces (disabled by default)
  • Curly braces
  • Parenthesis
  • Square braces

The various supported brace match options can be turned on or off with properties such as StructureMatcher.CanMatchSquareBraces.

By default, this matcher will just perform basic text scanning to match brackets. However this can cause issues when scanning for a pair of parentheses and there is a parenthesis character within a contained string. Thus the matcher also provides optional token IDs that can be set for each character. When a potential text match is found and a related token ID is specified, it will double-check that the token at the offset has that token ID. This eliminates the problem. Properties such as StructureMatcher.OpenParenthesisTokenId are available for indicating the token IDs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lipsum Generator

Text/Parsing Framework - Advanced Text Features
Lipsum Generator

A special utility class is included supports the generation of 'lorem ipsum' placeholder text. Placeholder text is useful for developers and designers when prototyping out web pages and screens. It is designed to contain unreadable gibberish sentences, which are ideal for layout.

This topic contains these sections:

  • Generating Placeholder Text

Generating Placeholder Text

A toolbar button or menu item (i.e. a "Insert Lorem Ipsum" item) clicked by the user in your app's UI might trigger the generation of placeholder text.

This code snippet shows how to use the LipsumGenerator class to generate the placeholder text:

C#
VB
Copy
​var text = new LipsumGenerator().GenerateParagraph(true, 30);
​Dim text = New LipsumGenerator().GenerateParagraph(True, 30)

The result of that call might yield:

Lorem ipsum dolor sit amet, consectetur adipisicing elit. Necessitatibus distinctio voluptates facilis nesciunt magnam, tempore similique voluptate cupiditate. Et fugit assumenda necessitatibus eum suscipit maiores ullam. Cum enim consequuntur adipisci.

The GenerateParagraph method generates a single paragraph of placeholder text. It has two parameters. The first is a boolean indicating whether the generated text should begin with the standard starting words "Lorem ipsum dolor sit amet, consectetur adipisicing elit." The second parameter is an integer indicating the total number of words that should be generated in the paragraph. The generated sentences in the paragraph will be of random length and will have commas sporatically inserted.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Document Properties

Text/Parsing Framework - Advanced Text Features
Document Properties

The ICodeDocument.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the document.

The property returns an PropertyDictionary object, which supports any object type as a key or value.

This topic contains these sections:

  • Storing Data
  • Retrieving Data

Storing Data

In this code snippet we store an object referenced by the variable someObject into the properties dictionary under the string key MyPropertyKey:

C#
VB
Copy
​document.Properties["MyPropertyKey"] = someObject;
​document.Properties.Item("MyPropertyKey") = someObject

Retrieving Data

In this code snippet we retrieve an object stored under the string key MyPropertyKey:

C#
VB
Copy
​object someObject;
if (document.Properties.TryGetValue("MyPropertyKey", out someObject)) {
    ...
}
​Dim someObject As Object
If document.Properties.TryGetValue("MyPropertyKey", someObject) Then
    ...
End If

Alternatively the indexer could be used, however it will throw an exception if there is no object stored with the specified key, whereas TryGetValue will not.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

User Interface Features
Overview

The SyntaxEditor user interface implements many of the features you'd expect to see in a powerful code editor.

This topic contains these sections:

  • Editor View Features
  • Input/Output Features
  • Printing Features
  • Searching (Find/Replace) Features
  • IntelliPrompt Features
  • Theme and Highlighting Style Features
  • Adornment Features
  • Outlining and Collapsing Features
  • Globalization and Accessibility Features

Editor View Features

Editor views are where end users primarily interact with documents and are customizable in a number of ways.

See the Editor View Features topic for more information.

Input/Output Features

In addition to the input/output features found in the text framework such as file load/save, exporting to HTML/RTF, etc., SyntaxEditor has a lot of other i/o features built-in.

See the Input/Output topic for more information.

Printing Features

SyntaxEditor's print features include easy dialog access, many print options, and customizable margins.

See the Printing Features topic for more information.

Searching (Find/Replace) Features

SyntaxEditor's view search model interacts with the view's selection and provides extensive find/replace functionality. A standalone EditorSearchView control can be used to instantly recreate a Visual Studio-like search experience for end users.

See the Searching (Find/Replace) Features topic for more information.

IntelliPrompt Features

SyntaxEditor includes some extremely powerful IntelliPrompt features that help enhance end user productivity.

See the IntelliPrompt topic for more information.

Theme and Highlighting Style Features

Highlighting styles govern how SyntaxEditor text is rendered and can be used to create entire themes for various languages.

See the Theme and Highlighting Style Features topic for more information.

Adornment Features

SyntaxEditor has a fully-extensible adornment layer framework that allows for any sort of custom content to be inserted within a view's text area. This can include everything from alternating row highlights, to animated text decorations, or anything else you can imagine.

All the built-in text area rendering is done using adornment layers, such as the text itself, selection, caret, and more.

See the Adornment Features topic for more information.

Outlining and Collapsing Features

SyntaxEditor fully supports automatic (language-driven) and manual (user-driven) code outlining/folding features similar to those found in Visual Studio.

Various text regions can even be collapsed (hidden) independent of the outlining features.

See the Outlining and Collapsing topic for more information.

Globalization and Accessibility Features

SyntaxEditor has full support for editing Unicode text, is completely localizable, and implements UI automation.

See the Globalization and Accessibility Features topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Editor View Features
Overview

Editor views are where end users primarily interact with documents and are customizable in a number of ways.

Tip Tip
If you want your SyntaxEditor instances to look just like Visual Studio's code editor, use the Consolas font with a FontSize of 13.

This topic contains these sections:

  • Caret
  • Selection and Block Selection
  • Locations, Offsets, and Positions
  • View Lines
  • Editor View Margins
  • Whitespace
  • Word Wrap
  • Zooming
  • Current Line Highlighting
  • Delimiter Highlighting
  • Code Block Selection
  • Indicators
  • Indentation Guides
  • ScrollBar Visibility, Trays, and Buttons
  • Hit Testing
  • View Lifecycle
  • Delayed UI Updates
  • View Properties
  • Single-Line Mode
  • Custom Cursors

Caret

The SyntaxEditor caret is the bar that blinks within an editor view and marks the location where typing will insert text. It also is linked to the end position of the selection.

See the Caret topic for more information.

Selection and Block Selection

SyntaxEditor has a powerful text selection model that supports both continuous stream (snaking) as well as block selection within editor views.

See the Selection and Block Selection topic for more information.

Locations, Offsets, and Positions

There are several ways to reference the location of characters within an IEditorView, each with their own benefits.

See the Locations, Offsets, and Positions topic for more information.

View Lines

Each view consists of one or more view lines, which are the lines of text that are visible in the view. View lines don't always match up with snapshot lines when features like word wrap or code outlining are active.

See the View Lines topic for more information.

Editor View Margins

While the SyntaxEditor editor views have numerous built-in margins (line number, outlining, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to editor views in any location.

See the Editor View Margins topic for more information.

Whitespace

SyntaxEditor can optionally display whitespace characters, change tab size, do tab to space conversion, and more.

See the Whitespace topic for more information.

Word Wrap

Word wrapping is a powerful feature that allows users to view all text for a line by wrapping text that normally would have been outside the view horizontally to one or more view lines in the editor.

See the Word Wrap topic for more information.

Zooming

SyntaxEditor supports animated zooming in and out of views, which is a great feature to use when giving overhead presentations. Only the scrollable area content of each view is zoomed, not the scrollbars.

See the Zooming topic for more information.

Current Line Highlighting

SyntaxEditor supports highlighting of the current editor view line, meaning the view line that currently contains the caret.

See the Current Line Highlighting topic for more information.

Delimiter Highlighting

SyntaxEditor supports highlighting of the delimiter pairs that are currently next to the caret, also known as bracket highlighting.

While delimiter pairs such as {...}, and (...) are most commonly highlighted, delimiter highlighting also supports the highlighting of more than two delimiters at a time, such as when there are #if...#else...#endif blocks.

See the Delimiter Highlighting topic for more information.

Code Block Selection

SyntaxEditor supports code block selection expansion and contraction, meaning that the view's selection can be expanded to include containing code blocks and contracted all the way back down to the caret as appropriate.

For instance, in C# the first time you expand the selection, it may select the containing identifier. By expanding it again, it may select the containing expression, then the containing statement, then the containing method. And so on up the compilation unit.

By contracting the selection, it goes back and selects the previously selected block. Contracting can occur recursively to go back to the original selection.

See the Code Block Selection topic for more information.

Indicators

Indicators are special "tagged" regions of text that display a glyph in the indicator margin also generally highlight the text range with special styles. Quick info can be displayed when hovering over the glyph, and custom mouse handling can be implemented to support functionality like toggling indicators when clicking in the indicator margin.

SyntaxEditor includes several built-in indicators: bookmarks, breakpoints, and current statement markers. Any sort of custom indicator can easily be created as well.

See the Indicators topic for more information.

Indentation Guides

Indentation guides are subtle vertical lines that render at each tab stop on lines prior to the first non-whitespace character. Whitespace-only lines render indentation guides based on the tab stop level of surrounding text.

See the Indentation Guides topic for more information.

ScrollBar Visibility, Trays, and Buttons

Scrollbars can optionally be hidden in the views. Each editor view in SyntaxEditor also has four scrollbar tray areas, where custom controls can be inserted via data templates.

See the ScrollBar Visibility, Trays, and Buttons topic for more information.

Hit Testing

SyntaxEditor makes it easy to hit test any Point in the editor and return detailed information about what is at that location.

See the Hit Testing topic for more information.

View Lifecycle

SyntaxEditor views can be opened and closed via various end user actions. This topic discussed how to be notified when views are opened and closed.

See the View Lifecycle topic for more information.

Delayed UI Updates

SyntaxEditor includes a special event that is raised shortly after any text, caret, or selection changes occur within the editor. This event can be handled to update external UI controls based on updated editor context.

See the Delayed UI Updates topic for more information.

View Properties

The ITextView.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the view.

The property returns an PropertyDictionary object, which supports any object type as a key or value.

See the View Properties topic for more information.

Single-Line Mode

SyntaxEditor is a multi-line editor by default, but also supports a single-line edit mode where it looks like a single-line native TextBox.

In this mode, nearly all of SyntaxEditor's features remain available, such as syntax highlighting, syntax error squiggle lines, and automated IntelliPrompt.

See the Single-Line Mode topic for more information.

Custom Cursors

WinRT doesn't allow custom mouse cursors to be included natively via .NET, however they can be included via C++ .res files. Several custom cursors have been created for use with SyntaxEditor but must be properly registered at app startup.

See the Custom Cursors topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Caret

SyntaxEditor Editor View Features
Caret

The SyntaxEditor caret is the bar that blinks within an editor view and marks the location where typing will insert text. It also is linked to the end position of the selection.

This topic contains these sections:

  • Accessing the Caret
  • Determining and Moving the Caret Location
  • Changing the Blink Interval
  • Changing the Insert and Overwrite Mode Width/Style
  • Temporarily Suspending Blinking
  • Caret Move Event
  • Scroll to Caret

Accessing the Caret

The caret and its functionality described below is available via the ICaret interface, which can be retrieved from the SyntaxEditor.Caret property.

Determining and Moving the Caret Location

The caret has several properties for determining its location. A couple of the properties can be set to move the caret.

Member | Description
CharacterColumn Property | Gets the character column of the caret within the active view.
DisplayCharacterColumn Property | Gets the character column of the caret within the the active view. and adds one to the value for display purposes within a status bar.
DisplayPosition Property | Gets the TextPosition of the caret within the active view, and adds one to the line and character values for display purposes within a status bar.
Offset Property | Gets or sets the offset of the caret within the active view.
Position Property | Gets or sets the TextPosition of the caret within the active view.

This code moves the caret to the start of the third line (the Position property is zero-based):

C#
VB
Copy
​editor.Caret.Position = new TextPosition(2, 0);
​editor.Caret.Position = New TextPosition(2, 0)

Use the display-related properties when showing data within a status bar, since it coerces the related value to be one-based instead of zero-based.

Changing the Blink Interval

The blink interval of the caret is set by default to 500ms.

Use the ICaret.BlinkInterval to change the blink interval to be faster or slower. The value indicates the millisecond delay between blinks.

This code changes the blink interface to one second:

C#
VB
Copy
​editor.Caret.BlinkInterval = 1000;
​editor.Caret.BlinkInterval = 1000

Changing the Insert and Overwrite Mode Width/Style

The caret can be in one of two modes: insert and overwrite. Insert mode is the traditional mode where typed text is inserted directly at the caret's offset. Overwrite mode will insert text at the caret's offset but will first remove any existing character on the line that is already at that offset.

The InsertWidth and OverwriteWidth properties can be used to tweak the width of the caret in each respective mode.

The InsertStyle and OverwriteStyle properties accept a CaretStyle value. This value determines the shape/alignment of the caret and can be VerticalLine, HorizontalUnderline, or Block.

Temporarily Suspending Blinking

The SuspendBlinking method can be used to temporarily suspend blinking of the caret. It accepts a boolean parameter indicating whether to display the caret while suspended or not. Generally, false is passed to this method.

When the caret should resume blinking, call the ResumeBlinking method.

Caret Move Event

The SyntaxEditor.ViewSelectionChanged event is raised whenever the caret moves, since the caret is always in sync with the end of the selection.

See the Selection topic for more information on this event.

Scroll to Caret

The IEditorView.ScrollToCaretOnSelectionChange property, normally true, will auto-scroll to the caret when the selection is changed. Temporarily setting this property to false will prevent that behavior. This property only affects a single editor view.

The SyntaxEditor.ScrollToCaretOnSelectAll property that determines whether to scroll to the caret when a select all operation is performed. It defaults to true.

The IEditorViewScroller interface defines a ScrollToCaret method that can be called manually to scroll to the caret.

This code scrolls the active view to the caret:

C#
VB
Copy
​editor.ActiveView.Scroller.ScrollToCaret();
​editor.ActiveView.Scroller.ScrollToCaret()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Selection and Block Selection

SyntaxEditor Editor View Features
Selection and Block Selection

SyntaxEditor has a powerful text selection model that supports both continuous stream (snaking) as well as block selection within editor views.

This topic contains these sections:

  • Accessing the Selection
  • Continuous Stream vs. Block Selection
  • Getting Information About the Current Selection
  • Creating Continuous Stream Selections at Run-time
  • Creating Block Selections at Run-time
  • Creating a Selection Programmatically
  • Getting or Replacing the Selected Text
  • Determining If Any of the Selected Text is Read-Only
  • Disabling Certain Selection Modes
  • Selection Change Event
  • Capturing and Restoring the Selection State
  • Selection Collapsing
  • Editing Multiple Lines at the Same Time
  • Selection Grippers for Touch

Accessing the Selection

Each IEditorView has its own selection model since the selection is unique to each view. The selection and its functionality described below is available via the IEditorViewSelection interface, which can be retrieved from the IEditorView.Selection property.

The currently active view within a SyntaxEditor is available from the SyntaxEditor.ActiveView property.

Continuous Stream vs. Block Selection

Continuous stream is considered the "normal", snaking type of selection. It has a start and end position and encompasses all text in between the positions.

Block selection, sometimes called column or rectangular selection, allows a rectangular portion of text to be selected instead of the whole line. The selection includes all of the characters captured within the rectangle defined by the start (anchor) position and the end position in the selection.

Continuous stream (left) vs. block (right) selection

Getting Information About the Current Selection

There are a number of properties on the IEditorViewSelection interface that allow you to see exactly what is selected in the selection's owner IEditorView.

Member | Description
EndOffset Property | Gets or sets the end offset of the selection.
EndPosition Property | Gets or sets the TextPosition that represents the end of the selection range.
FirstOffset Property | Gets the first offset in the selection.
FirstPosition Property | Gets the first TextPosition in the selection.
GetCharacterIndexRanges Method | Returns an array of character index Range objects for characters contained on each view line in the selection.
GetTextRanges Method | Returns an array of TextRange objects that specify the ranges of text that is selected.
IsNormalized Property | Gets whether the selection is normalized (StartPosition occurs at or before the EndPosition).
IsZeroLength Property | Gets whether the selection has a zero length.
LastOffset Property | Gets the last offset in the selection.
LastPosition Property | Gets the last TextPosition in the selection.
Length Property | Gets the absolute offset length of the selection.
Mode Property | Gets a SelectionModes that indicates the selection mode currently in use.
PositionRange Property | Gets or sets the TextPositionRange that describes the start and end TextPosition of the selection.
StartOffset Property | Gets or sets the start offset of the selection.
StartPosition Property | Gets or sets the TextPosition that represents the start of the selection range.
TextRange Property | Gets or sets the TextRange that specifies the offset range of the selection.

Creating Continuous Stream Selections at Run-time

Continuous stream selections can be made via the mouse or the keyboard.

To make a continuous stream selection with the mouse, left click in the text area and drag to create the selection. Hold Ctrl when click+dragging to select by word instead of character.

To make a continuous stream selection with the keyboard, hold the Shift key, and press any arrow key. Other keys such as Home, End, PageUp, and PageDn also create selections while holding Shift. Holding Ctrl+Shift when using the arrows keys will select by word instead of character.

Creating Block Selections at Run-time

Block selections can be made via the mouse or the keyboard.

To make a block selection with the mouse, hold the Alt key, left click in the text area and drag to create the selection. Hold Ctrl+Alt+Shift when click+dragging to select by word instead of character.

To make a block selection with the keyboard, hold the Shift+Alt keys, and press any arrow key. Holding Ctrl+Alt+Shift when using the arrows keys will select by word instead of character.

Creating a Selection Programmatically

The selection can be set programmatically using a number of the properties and methods on IEditorViewSelection, such as StartOffset.

The SelectRange method has several overloads that allow for easy selection creation with options. For instance you can create a selection via an offset/length, a TextRange, a TextPosition pair, or a TextPositionRange. Each overload also has corresponding overloads that accept a SelectionModes parameter. When you use this parameter, you can indicate whether the selection should be a continuous stream or block selection.

When using setter properties or SelectRange method overloads that don't accept a SelectionModes property, the current selection mode (indicated by the Mode property) will be used.

This code selects the text range 0-20 (20 characters) using the current Mode:

C#
VB
Copy
​editor.ActiveView.Selection.SelectRange(new TextRange(0, 20));
​editor.ActiveView.Selection.SelectRange(New TextRange(0, 20))

This code selects the text range 10-20 (10 characters) using continuous stream mode:

C#
VB
Copy
​editor.ActiveView.Selection.SelectRange(10, 10, SelectionModes.ContinuousStream));
​editor.ActiveView.Selection.SelectRange(10, 10, SelectionModes.ContinuousStream))

This code selects the text position (line, char) range (1,0)-(2,10) using block mode:

C#
VB
Copy
​editor.ActiveView.Selection.SelectRange(new TextPositionRange(1, 0, 2, 10), SelectionModes.Block);
​editor.ActiveView.Selection.SelectRange(New TextPositionRange(1, 0, 2, 10), SelectionModes.Block)

The IEditorViewSelection interface provides a lot of additional methods for performing relative selection operations such as MoveDown, SelectPageDown, SelectBlockRight, etc. Check the IEditorViewSelection class library member list to see the numerous methods that are available.

Getting or Replacing the Selected Text

The IEditorView.SelectedText property gets and sets the currently selected text and pays proper attention to block selections if applicable. The setter calls the ReplaceSelectedText method.

This code puts the currently selected text in a string:

C#
VB
Copy
​string text = editor.ActiveView.SelectedText;
​Dim text As String = editor.ActiveView.SelectedText

For setting text, the ReplaceSelectedText method can be called to replace the currently selected text with alternate text. The DeleteSelectedText method can be called to delete the currently selected text.

This code deletes currently selected text:

C#
VB
Copy
​editor.ActiveView.DeleteSelectedText(TextChangeTypes.Delete);
​editor.ActiveView.DeleteSelectedText(TextChangeTypes.Delete)

This code replaces currently selected text:

C#
VB
Copy
​editor.ActiveView.ReplaceSelectedText(TextChangeTypes.Typing, "Inserted Text");
​editor.ActiveView.ReplaceSelectedText(TextChangeTypes.Typing, "Inserted Text")

Both these methods have overloads that accept an IEditorViewTextChangeOptions object, which inherits ITextChangeOptions. The base options in ITextChangeOptions are described in the Text Changes and Operations topic. The IEditorViewTextChangeOptions interface defines several additional properties.

The IsBlock option indicates if the text change should be considered a block text change. The SelectInsertedText option determines if the inserted text should be selected. The VirtualCharacterFill option determines if when the caret is at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.

Determining If Any of the Selected Text is Read-Only

The IEditorViewSelection.IsReadOnly property returns whether any of the text in the selection is currently flagged as read-only.

Disabling Certain Selection Modes

The SyntaxEditor.SelectionModesAllowed property is a flags enumeration that indicates the types of selection modes that are permitted.

By altering the SelectionModes value set to this property, you can determine whether continuous stream and block selections are allowed. The default is to allow both.

Selection Change Event

The SyntaxEditor.ViewSelectionChanged event fires whenever the selection's anchor or length have changed. This makes the event an ideal place to update the current caret column and position in a status bar.

The event passes an EditorViewSelectionEventArgs that has a number of useful properties on it. It tells you the IEditorView that contains the selection (be sure to only update UI when the view's IsActive property is true). The CaretDisplayCharacterColumn and CaretDisplayPosition properties are the values that should be displayed in a status bar.

Capturing and Restoring the Selection State

Sometimes it's handy to be able to capture and later restore a selection. This feature is used in actions like indent lines where the text in the selection is modified and when complete, the selection still appears to contain the same relative range of text, even though new characters were inserted within the selected text range.

The IEditorViewSelection.CaptureState method can be called to return an IEditorViewSelectionState object. This object persists information about the current selection state. If you make changes and then call the IEditorViewSelectionState.Restore method, the selection will attempt to restore itself as best it can to the text that was originally selected.

This functionality makes use of the snapshot translation feature, found in the text framework.

Selection Collapsing

The Esc key can be pressed to collapse a selection, meaning make the selection go to zero-length.

By default, the selection will collapse to the caret. This behavior can be changed so that the selection collapses to the selection anchor instead. The SyntaxEditor.SelectionCollapsesToAnchor property can be set to true to activate this behavior.

Some end users like the ability to auto-collapse the selection when a copy operation occurs. Set the SyntaxEditor.SelectionCollapsesOnCopy property to true to enable this behavior.

Editing Multiple Lines at the Same Time

While a block selection is active, multiple lines can be edited at the same time. Typing will enter the character on each line. Pasting single-line text will paste the text on each line. Likewise, operations like Del and Backspace will work on each line.

This is useful for cases such as when you wish to quickly insert numerous <div> tags within HTML.

Selection Grippers for Touch

When the end user touches a view, a small selection gripper will appear below the start and end of the selection. The gripper can be dragged to resize the selection, or tapped to show a context menu.

The SyntaxEditor.AreSelectionGrippersEnabled property can be set to false to disable display of the selection grippers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Locations, Offsets, and Positions

SyntaxEditor Editor View Features
Locations, Offsets, and Positions

There are several ways to reference the location of characters within an IEditorView, each with their own benefits.

Note Note
Before reading this topic, first read the Offsets, Ranges, and Positions topic since that provides a lot of information about core text-related structures that apply to the information in this topic too.

This topic contains these sections:

  • Offsets and Positions
  • The First Visible Position in a View
  • Locations
  • Converting Between Locations and Offsets/Positions
  • Hit Testing

Offsets and Positions

As mentioned in the Offsets, Ranges, and Positions topic, offsets are zero-based integer numbers indicating a character index from the beginning of a string or snapshot and text positions are similar but specify a line index and a character index within that line instead.

Offsets and positions are used within IEditorView objects to provide layout information to the view lines. However it is important to note that while a TextPosition 4,0 is the fifth line in a view's CurrentSnapshot, it may not be the fifth view line in the view, even when the view is scrolled all the way to the top. Things that can cause this scenario are word wrap, collapsed outlining nodes, etc. So in the same scenario, assume word wrap is on and the second line wrapped once. This would mean that TextPosition 4,0 would appear as the sixth line.

The First Visible Position in a View

The IEditorView.FirstVisiblePosition property gets and sets the first visible TextPosition in the view, or the character that appears at the upper left of the view when the view is scrolled all the way to the left. On a related note, the FirstVisibleX property indicates how many layout units (normally pixels) the view is scrolled to the right, if at all.

The character value of FirstVisiblePosition is normally 0 however can be another larger value when word wrap, etc. is active. For instance if the second line of the view wraps once, and the wrapped portion is the top visible view line, the FirstVisiblePosition may return something like 1, 50, meaning the 51st character within the second line is the first visible character at the upper left of the view.

Locations

When related to a view, locations are the term used to describe the x,y layout position such as mouse coordinates, etc. They are specified using the Windows Point structure.

Converting Between Locations and Offsets/Positions

Locations can be translated to a TextPosition by using the IEditorView.LocationToPosition method. This method accepts a Point in text area-relative coordinates. The TransformToTextArea method can transform a view-relative coordinate to the text area. A LocationToPositionAlgorithm enumeration value is also passed, indicating how the logic used to convert the x,y coordinate to a TextPosition.

The GetCharacterBounds method can return the Rect coordinates that contain the character at a particular offset or TextPosition.

Hit Testing

SyntaxEditor features a very powerful hit testing mechanism where you indicate a Point relative to the SyntaxEditor control and it returns very detailed information about what is at the location. Information includes related character offsets, positions, etc. as well.

See the Hit Testing topic for information on how to perform hit testing.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Lines

SyntaxEditor Editor View Features
View Lines

Each view consists of one or more view lines, which are the lines of text that are visible in the view. View lines don't always match up with snapshot lines when features like word wrap and code outlining are active.

This topic contains these sections:

  • View Lines vs. Snapshot Lines
  • Getting a View Line for an Offset
  • Getting a View Line for a Text Position
  • Getting a View Line for a Location
  • Getting a Relative View Line
  • Getting or Setting the First Visible View Line
  • Scrolling
  • Auto-Sizing the View to View Line Contents

View Lines vs. Snapshot Lines

View lines are the rendered display lines within a view, and are represented by the IEditorViewLine interface. Snapshot lines are the actual physical lines within a snapshot, and are represented by the ITextSnapshotLine interface.

The view lines most often do line up exactly with the lines in the IEditorView.CurrentSnapshot, however this may not be the case when features such as word wrap or code outlining are active.

To better illustrate the difference, let us examine a snippet of code that is being edited in view. This is the full text as it appears within the document's snapshot (line numbers are included for reference):

Code Snippet
Copy
0: // Sample code
1: int myIntValue = 123;
2: string myStringValue = "This is a long bit of text that will be word wrapped.";
3: // End of code

You can see there are four lines in the snapshot. Now assume that the editor has word wrap enabled. And assume that the second last line is wrapped like so:

Code Snippet
Copy
0: // Sample code
1: int myIntValue = 123;
2: string myStringValue = "This is a long bit of text
3: that will be word wrapped.";
4: // End of code

Even though there are four snapshot lines, there are five view lines needed to display the text due to the word wrap.

View lines are completely virtualized meaning they are generated on demand and are not persisted in memory. This is a key feature since it means much less memory usage and processing required when working with large documents.

Getting a View Line for an Offset

There is an IEditorView.GetViewLine method overload that accepts an offset parameter. This method allows you to retrieve the view line that contains the specified offset.

This code gets the IEditorViewLine that contains offset 10:

C#
VB
Copy
​editor.ActiveView.GetViewLine(10);
​editor.ActiveView.GetViewLine(10))

Getting a View Line for a Text Position

There is an IEditorView.GetViewLine method overload that accepts a TextPosition parameter. This method allows you to retrieve the view line that contains the specified text position.

This code gets the IEditorViewLine that contains the start of the fourth line:

C#
VB
Copy
​editor.ActiveView.GetViewLine(new TextPosition(3, 0));
​editor.ActiveView.GetViewLine(New TextPosition(3, 0)))

Getting a View Line for a Location

There is an IEditorView.GetViewLine method overload that accepts two parameters: a y-coordinate and a LocationToPositionAlgorithm to use. This method allows you to retrieve the view line under a specific mouse coordinate for example.

Getting a Relative View Line

If you already have an IEditorViewLine instance and would like to find a view line that is above or below it by a certain number of lines, there is a IEditorView.GetViewLine overload that accepts the source IEditorViewLine instance and the number of lines to traverse, which can be negative.

If you are just iterating view lines, the IEditorViewLine has NextLine and previous PreviousLine properties that return the next and previous view lines respectively.

Getting or Setting the First Visible View Line

The IEditorView.FirstVisiblePosition property gets and sets the first visible TextPosition in the view,

See the Locations, Offsets, and Positions topic for some details on using that property.

Scrolling

The IEditorView.Scroller property provides access to an IEditorViewScroller for the view. This interface has a lot of methods such as ScrollDown, ScrollToDocumentEnd, ScrollIntoView, ScrollToCaret, etc. that can be used to scroll the view.

See the IEditorViewScroller class library member list documentation for the list of methods that are available.

Auto-Sizing the View to View Line Contents

Sometimes it is desirable for the editor to resize itself based on the current text content. This feature is useful in scenarios such as where an editor is in a StackPanel and its height needs to grow as text is entered by the user.

The SyntaxEditor.IsViewLineMeasureEnabled property, which defaults to false, can be set to true to force each view line to be measured during measure phases, thus allowing the containing editor to resize based on the the current text content.

Note Note
Enabling this feature will affect performance and is only recommended for scenarios where small documents are expected to be edited. If you expect the editor to always be docked to fill an available space, leave this feature disabled.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Editor View Margins

SyntaxEditor Editor View Features
Editor View Margins

While the SyntaxEditor editor views have numerous built-in margins (line number, outlining, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to editor views in any location.

Editor view margins all implement the IEditorViewMargin interface.

This topic contains these sections:

  • Margin Locations
  • Built-In Margin Summary
  • Indicator Margin
  • Line Number Margin
  • Selection Margin
  • Outlining Margin
  • Word Wrap Glyph Margin
  • Margin Factories
  • Custom Margins

Margin Locations

Editor view margins surround the text area and fall into two categories: scrollable or fixed.

Scrollable margins appear inside of the scrollbars and scroll with the text area as it is scrolled. Fixed margins appear outside of the scrollbars and do not scroll when the text area is scrolled.

Custom margins that show the eight available margin placement locations

All in all there are eight available margin placement locations. The screenshot above shows where each placement is located.

The IEditorViewMargin.Placement property has an EditorViewMarginPlacement enumeration value that indicates one of those eight placement locations.

Since each IEditorViewMargin has a string-based Key, and the interface also implements IOrderable, it has an Orderings property that returns an enumerable of Ordering objects. Each ordering indicates the a string Key of another margin and whether this margin comes before or after that one. When multiple margins are combined into a placement location, they are ordered based on the Orderings property values, where "after" means farther away from the text area.

For instance, the selection margin says it is not after anything, meaning it is placed closes to the text area. The line number margin says it is after the selection margin, and so on.

Built-In Margin Summary

These editor view margins are built-in to the product:

  • Indicator margin
  • Line number margin
  • Selection margin
  • Outlining margin
  • Word wrap glyph margin

All of the built-in margins are scrollable margins, meaning they scroll with the text area.

Indicator Margin

The indicator margin, implemented by the EditorIndicatorMargin class, is used to display glyphs for indicators. It appears in the scrollable left placement.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.IsIndicatorMarginVisible property is true.

Style

The SyntaxEditor.IndicatorMarginBackground property can be set to any Brush value to alter the display of the margin.

Line Number Margin

The line number margin, implemented by the EditorLineNumberMargin class, is used to display snapshot line numbers. It appears in the scrollable left placement.

Word wrapped lines do not display any line numbers.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.IsLineNumberMarginVisible property is true.

Style

The SyntaxEditor.LineNumberMarginBackground and LineNumberMarginForeground properties can be set to any Brush value to alter the display of the margin.

In addition, the LineNumberMarginFontFamily and LineNumberMarginFontSize properties can provide an alternate font for display of the line numbers.

Custom Cursor

A reverse arrow mouse cursor will be used when the mouse is over the margin, as long as the cursor has been registered according to the instructions in the Custom Cursors topic.

Selection Margin

The selection margin, implemented by the EditorSelectionMargin class, is used to display line modification marks and to provide an easy way to make line-based selections. It appears in the scrollable left placement.

Visibility

This margin is visible by default, and can be made invisible when the SyntaxEditor.IsSelectionMarginVisible property is false.

Style

The SyntaxEditor.SelectionMarginBackground property can be set to any Brush value to alter the display of the margin.

Custom Cursor

A reverse arrow mouse cursor will be used when the mouse is over the margin, as long as the cursor has been registered according to the instructions in the Custom Cursors topic.

Outlining Margin

The outlining margin, implemented by the EditorOutliningMargin class, is used to display the code outlining (folding) node tree, also enables the end user to easily expand and collapse nodes. It appears in the scrollable left placement.

Visibility

This margin is visible by default, and can be made invisible when the SyntaxEditor.IsOutliningMarginVisible property is false.

Style

The SyntaxEditor.OutliningMarginBackground property can be set to any Brush value to alter the display of the margin.

Word Wrap Glyph Margin

The word wrap glyph margin, implemented by the EditorWordWrapGlyphMargin class, is used to display glyphs at the end of lines that are too long to fit in the view and must be wrapped. It appears in the scrollable right placement.

Visibility

This margin is not visible by default, and can be made visible when the SyntaxEditor.AreWordWrapGlyphsVisible property is true. The editor must also be in word wrap mode for this margin to be visible.

Style

The SyntaxEditor.WordWrapGlyphMarginBackground and WordWrapGlyphMarginForeground properties can be set to any Brush value to alter the display of the margin.

Margin Factories

Margin factories are used to tell SyntaxEditor which margins to display in an editor view. Margin factories are implementations of the IEditorViewMarginFactory interface.

The DefaultEditorViewMarginFactory class is an implementation of a factory that creates all of the built-in margins. While all the built-in margins are added if this factory is used, they still change their visibility based on the related SyntaxEditor margin visibility properties such as IsLineNumberMarginVisible.

The SyntaxEditor.ViewMarginFactories property is a collection of IEditorViewMarginFactory objects. By default it is auto-populated with the DefaultEditorViewMarginFactory, meaning all built-in margins are available. Add additional margin factories to the collection if you wish to add custom margins. A QuickStart is available in the samples that shows how to do this.

Custom Margins

Custom margins are pretty easy to create. These are the basic steps involved:

  • First, make a margin Control that implements IEditorViewMargin.
  • Second, make a custom IEditorViewMarginFactory that creates an instance of your margin class.
  • Third, add your custom margin factory to the SyntaxEditor.ViewMarginFactories collection.

At this point your margin should now be getting added to the view. Scrollable margins need to update when the text area is changed, so be sure to attach to the view's TextAreaLayout event and update the margin properly when that event fires.

For details on implementing a custom margin including several complete examples, please see the related QuickStarts in the samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Whitespace

SyntaxEditor Editor View Features
Whitespace

SyntaxEditor can optionally display whitespace characters, change tab size, do tab to space conversion, and more.

This topic contains these sections:

  • Visible Whitespace
  • Tab Size
  • Tabs to Spaces Conversion While Typing
  • Backspacing to the Previous Tab Stop
  • Tabification and Tab to Space Conversion
  • Whitespace Trim Modes

Visible Whitespace

SyntaxEditor can optionally display whitespace characters when the SyntaxEditor.IsWhitespaceVisible property is set to true.

Tabs and spaces visible in the editor

Visible Whitespace Color

The SyntaxEditor.VisibleWhitespaceForeground property gets/sets the color used to render visible whitespace.

Tab Size

The term tab size refers to the number of spaces that a tab character appears to represent. SyntaxEditor allows you to configure the tab size. The default tab size is 4, meaning tabs render in the space of four space characters.

A tab size of eight spaces, instead of four, which is the default

The tab size can be altered by setting the ITextDocument.TabSize property. When this property is changed, the related TabSizeChanged event fires.

Tabs to Spaces Conversion While Typing

Tabs that are typed can be automatically converted to space characters if the ITextDocument.AutoConvertTabsToSpaces property is set to true.

Backspacing to the Previous Tab Stop

When ITextDocument.AutoConvertTabsToSpaces is true, pressing the Backspace key before the first non-whitespace character of a line will backspace to the previous tab stop by default. Set the SyntaxEditor.CanBackspaceOverSpacesToTabStop property is set to false to alter this behavior to only allow backspacing a single space at a time.

Tabification and Tab to Space Conversion

The IEditorViewTextChangeActions interface, available via the IEditorView.TextChangeActions property, provides several methods for doing tab/space conversions within the currently selected text.

The TabifySelectedLines and UntabifySelectedLines methods convert leading line whitespace from spaces to tabs and back in the current view selection.

The ConvertSpacesToTabs and ConvertTabsToSpaces methods convert all whitespace from spaces to tabs and back in the current view selection.

Whitespace Trim Modes

SyntaxEditor supports automatic trimming of whitespace under certain scenarios. The WhitespaceTrimModes enumeration is a flags enumeration that specifies the types of whitespace trim modes that are available, such as trimming trailing whitespace on paste and trailing whitespace on text replacements.

Set the IEditorDocument.WhitespaceTrimModes property to control the automatic whitespace trim behavior.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Word Wrap

SyntaxEditor Editor View Features
Word Wrap

Word wrapping is a powerful feature that allows users to view all text for a line by wrapping text that normally would have been outside the view horizontally to one or more view lines in the editor.

This topic contains these sections:

  • Word Wrap Modes
  • Word Wrap Glyph Margin

Word Wrap Modes

The SyntaxEditor.WordWrapMode property can be set to WordWrapMode.Word to activate word wrap functionality. By default it is set to WordWrapMode.None, meaning no word wrap.

Word wrap active in the editor, with the glyphs on the right indicating wrapped lines

This code activates word wrap:

C#
VB
Copy
​editor.WordWrapMode = WordWrapMode.Word;
​editor.WordWrapMode = WordWrapMode.Word

Word Wrap Glyph Margin

Word wrap glyphs can be displayed on the right side of view lines in a special margin that indicate soft line breaks (wrapped lines).

The SyntaxEditor.AreWordWrapGlyphsVisible property can be set to true to activate this functionality.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Zooming

SyntaxEditor Editor View Features
Zooming

SyntaxEditor supports animated zooming in and out of views, which is a great feature to use when giving overhead presentations. Only the scrollable area content of each view is zoomed, not the scrollbars.

This topic contains these sections:

  • Mouse Wheel Zoom
  • Zoom Level
  • Min/Max Zoom Levels
  • Zoom Animation

Mouse Wheel Zoom

If the SyntaxEditor.IsMouseWheelZoomEnabled property is set to true, mouse wheel zoom is enabled.

Mouse wheel zoom is activated at run-time by holding the Ctrl key and turning the mouse wheel up to zoom in (make text larger) and down to zoom out. When zooming is performed via the mouse wheel, a small zoom level indicator appears over the editor.

The SyntaxEditor.ZoomLevelIncrement property determines the percentage amount by which to zoom with the mouse wheel. It defaults to 0.25, which means a 25% increment on each mouse wheel notch scroll.

Zoom Level

The SyntaxEditor.ZoomLevel property gets and sets the current zoom level of the control.

This code sets the zoom level to 300%:

C#
VB
Copy
​editor.ZoomLevel = 3.0;
​editor.ZoomLevel = 3.0

Tip Tip
You can bind the ZoomLevel property to a Slider control that is in the status bar to provide end users an additional way to zoom.

Min/Max Zoom Levels

The SyntaxEditor.MinZoomLevel and MaxZoomLevel properties denote the range of zoom levels over which zooming can occur.

By setting these properties you can prevent end users from zooming in too far, etc.

Zoom Animation

Zoom animation occurs by default, meaning that zoom level changes smoothly animate, providing a subtle grow/shrink effect.

The animation duration can be set via the SyntaxEditor.ZoomAnimationDuration property. Set it to 0ms to turn off animation.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Current Line Highlighting

SyntaxEditor Editor View Features
Current Line Highlighting

SyntaxEditor supports highlighting of the current editor view line, meaning the view line that currently contains the caret.

This topic contains these sections:

  • Activating Current Line Highlighting
  • Changing the Highlight Brush

Activating Current Line Highlighting

The SyntaxEditor.IsCurrentLineHighlightingEnabled property can be set to true to activate current line highlighting. It is off by default.

Changing the Highlight Brush

The brush used to render the highlight can be adjusted by the end user since it is exposed via a special classification type's style in the highlighting style registry.

See the "Special Classification Types" section in the Highlighting Style Registries topic for more information on how to modify the style.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delimiter Highlighting

SyntaxEditor Editor View Features
Delimiter Highlighting

SyntaxEditor supports highlighting of the delimiter pairs that are currently next to the caret, also known as bracket highlighting.

While delimiter pairs such as {...}, and (...) are most commonly highlighted, delimiter highlighting also supports the highlighting of more than two delimiters at a time, such as when there are #if...#else...#endif blocks.

This topic contains these sections:

  • Activating Delimiter Highlighting
  • Required Language Services
  • Performance Optimizations
  • Changing the Highlight Brush

Activating Delimiter Highlighting

The SyntaxEditor.IsDelimiterHighlightingEnabled property can be set to true to allow SyntaxEditor to render delimiter highlighting, as long as the current syntax language supports the feature. Delimiter highlighting is enabled on SyntaxEditor by default.

Required Language Services

The current syntax language must have two services registered so that delimiter highlighting can render: a structure matcher and a delimiter highlight tagger.

Structure Matcher

A structure matcher service contains the core logic for examining a document snapshot to see if any delimiters are next to a given offset. The delimiter highlighting feature calls this structure matcher and passes it the caret's offset. The matcher's results are passed back and if there are valid delimiter results next to the caret, they can be highlighted.

See the Structure Matching topic for detail on how structure matchers work and how to register one with the language.

Delimiter Highlight Tagger

A special DelimiterHighlightTagger class has been implemented that watches for text/selection changes within SyntaxEditor and calls the language's structure matcher to look for delimiter pairs as appropriate. When matcher results are found, the ranges are tagged and highlights are rendered by an internal adornment manager.

Without the tagger being registered on the language, no highlights will show for delimiters.

This code shows how to register the tagger with the language:

C#
VB
Copy
​language.RegisterService(new TextViewTaggerProvider<DelimiterHighlightTagger>(typeof(DelimiterHighlightTagger)));
​language.RegisterService(New TextViewTaggerProvider(Of DelimiterHighlightTagger)(GetType(DelimiterHighlightTagger)))

Performance Optimizations

The delimiter highlight mechanism can take time to execute when editing larger documents. This can directly have a negative performance impact on caret movement and typing speed. Thus this feature has been designed to do nearly all the work in worker threads, and utilizes the multi-threaded parser capabilities described in the Parse Requests and Dispatchers topic.

It is very important that an ambient parse request dispatcher is configured per the instructions in that topic, otherwise the delimiter highlighting feature, when enabled, will run in the UI thread and negatively affect performance.

Changing the Highlight Brush

The brush used to render the highlight can be adjusted by the end user since it is exposed via a special classification type's style in the highlighting style registry.

See the "Special Classification Types" section in the Highlighting Style Registries topic for more information on how to modify the style.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Block Selection

SyntaxEditor Editor View Features
Code Block Selection

SyntaxEditor supports code block selection expansion and contraction, meaning that the view's selection can be expanded to include containing code blocks and contracted all the way back down to the caret as appropriate.

For instance, in C# the first time you expand the selection, it may select the containing identifier. By expanding it again, it may select the containing expression, then the containing statement, then the containing method. And so on up the compilation unit.

By contracting the selection, it goes back and selects the previously selected block. Contracting can occur recursively to go back to the original selection.

This topic contains these sections:

  • Activating Code Block Selection
  • Finder Logic
  • Registering a Code Block Finder with a Syntax Language
  • LLParseDataCodeBlockFinder Implementation
  • Programmatic Execution

Activating Code Block Selection

Code block selection is enabled on SyntaxEditor by default, and can be executed via the default Ctrl+Num+ (expand) and Ctrl+Num- (contract) key bindings.

However note that code block selection only functions if the required language service (ICodeBlockFinder interface) is registered.

Finder Logic

The ICodeBlockFinder interface has a single FindContaining method on it that accepts a TextSnapshotRange (which is the current selection range in an editor) and returns a TextSnapshotRange, which should be the text range of the containing code block. The code block could be determined by examining an AST or doing simple text/token scanning.

Registering a Code Block Finder with a Syntax Language

An ICodeBlockFinder can be associated with an ISyntaxLanguage by registering it with the language:

C#
VB
Copy
​language.RegisterService<ICodeBlockFinder>(myCodeBlockFinder);
​language.RegisterService(Of ICodeBlockFinder)(myCodeBlockFinder)

Registering a code block finder with a language is optional, but recommended.

LLParseDataCodeBlockFinder Implementation

The built-in LLParseDataCodeBlockFinder class, which is part of the LL(*) Parser Framework, implements ICodeBlockFinder and can be used as a code block finder service on any language that uses a grammar-based parser from our framework.

It is designed to examine the resulting AST (abstract syntax tree) that was constructed from the parser and walk up the tree as calls are made to the code block finder.

The class has a special Filter property that can optionally be assigned to a predicate delegate. The delegate is passed an IAstNode that the finder is currently examining and considering returning. If the AST node should be used, return true, otherwise return false and the finder will examine the node's parent instead. This mechanism allows for certain AST nodes to be skipped over.

Programmatic Execution

The IEditorViewSelection interface defines two methods (CodeBlockExpand and CodeBlockContract) that can be used to programmatically invoke code block selection functionality.

Again, these methods only function if an ICodeBlockFinder service is registered on the current language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indicators

SyntaxEditor Editor View Features
Indicators

Indicators are special "tagged" regions of text that display a glyph in the indicator margin also generally highlight the text range with special styles. Quick info can be displayed when hovering over the glyph, and custom mouse handling can be implemented to support functionality like toggling indicators when clicking in the indicator margin.

SyntaxEditor includes several built-in indicators: bookmarks, breakpoints, and current statement markers. Any sort of custom indicator can easily be created as well.

This topic contains these sections:

  • Basic Concepts
  • Line-Based vs. Text Range-Based Indicators
  • Bookmark Indicators
  • Breakpoint Indicators
  • Current Statement Indicators
  • Custom Indicators
  • IntelliPrompt Quick Info for Glyphs
  • Handling Mouse Events in the Indicator Margin

Basic Concepts

Indicators use the same tagging mechanism that is harnessed by many other SyntaxEditor features. A certain text range is marked with a custom tag, in this case a tag that implements IIndicatorTag. As text changes occur, the tagged range is automatically adjusted appropriately.

Glyphs

The indicator margin is where glyphs from indicators are displayed. Glyphs can be any sort of FrameworkElement, and render on the first view line that contains the related indicator. The IIndicatorTag.CreateGlyph method is responsible for creating the glyph FrameworkElement.

Important Note Important Note
The indicator margin is hidden by default and should be made visible via the SyntaxEditor.IsIndicatorMarginVisible property when indicators are used. Otherwise, no glyphs will render in the editor.

It is recommended that glyphs be restricted to 16x16 size. See the custom indicators example for a sample of creating a glyph.

Classifications

While the IIndicatorTag interface just handles rendering of the glyphs, more often than not, indicators also intend to style the contained text range differently. You see this sort of thing with breakpoints, where they highlight the background of the text red. This is accomplished by having the tag instance also implement IClassificationTag.

See the Tags and Classification Types topic for more information on how classification tags can be used to override default syntax highlighting.

Taggers and Indicator Managers

Any ITagger`1 can provide indicators, but indicators are most generally used with ICollectionTagger`1 objects. That sort of tagger works like a collection and allows you to add/remove, etc. indicator tags from it.

Say you wish to support bookmark indicators in your editor. You would add a bookmark indicator tag for each bookmark instance to the ICollectionTagger`1. If the end user toggles off a bookmark, the related tag should be removed from the tagger.

SyntaxEditor provides a helpful indicator manager (IIndicatorManager interface, accessible via the IEditorDocument.IndicatorManager property) that wraps up much of the functionality of creating/accessing a tagger behind the scenes. The manager has a number of generic methods that can be used to interact with indicators at a very high level. When a method on the indicator manager is accessed, it will go see if a related tagger is found on the document. For methods like Add and Toggle, where it is your intention to add an indicator, the manager will install an appropriate ICollectionTagger`1 on the document if one is not already present. This is helpful because it means that a tagger provider language service doesn't need to be set up on your languages for each kind of indicator you wish to use.

IIndicatorManager also provides access to some sub-managers (e.g. via the Breakpoints property) which are even friendlier ways to work directly with the related indicator type.

See below for examples of working with the indicator manager.

Line-Based vs. Text Range-Based Indicators

There are two general kinds of indicators: line-based and text range-based.

A line-based indicator is one that is applied to a single text snapshot line. An example of this kind is a bookmark. As text changes occur in and around the line, the indicator uses special logic and adjusts its tagged range to remain on and fully encompass a single line.

A text range-based indicator is one that is applied to a text snapshot range (start and end offset pair). An example of this kind is a breakpoint. As text changes occur in and around the range, the indicator adjusts its tagged range accordingly. The tagged range can cover a small portion of a line or even span multiple lines.

Bookmark Indicators

Bookmarks are line-based indicators that render a small bookmark glyph in the indicator margin to mark an area of interest for the end user. An app generally supports navigation between the bookmarks so the end user can jump the caret between them.

Bookmarks can be easily managed via the IBookmarkIndicatorManager interface, which is accessible via the IIndicatorManager.Bookmarks property.

This code shows how to toggle a bookmark on the current line that contains the caret:

C#
VB
Copy
​editor.Document.IndicatorManager.Bookmarks.Toggle(editor.ActiveView.Selection.EndSnapshotOffset.Line);
​editor.Document.IndicatorManager.Bookmarks.Toggle(editor.ActiveView.Selection.EndSnapshotOffset.Line)

Bookmark indicators also support an enabled state via their BookmarkIndicatorTag.IsEnabled property. Bookmarks are enabled by default. When disabled, their glyph and styled text range render differently. This is generally a visual reminder to the end user that the bookmark will not be hit when finding the next bookmark.

This code shows how to toggle the enabled state for a bookmark on the current line:

C#
VB
Copy
​var tagRange = editor.Document.IndicatorManager.Bookmarks.GetInstances(editor.ActiveView.Selection.EndSnapshotOffset.Line).FirstOrDefault();
if (tagRange != null)
    editor.Document.IndicatorManager.Bookmarks.ToggleEnabledState(tagRange.Tag)
​Dim tagRange = editor.Document.IndicatorManager.Bookmarks.GetInstances(editor.ActiveView.Selection.EndSnapshotOffset.Line).FirstOrDefault()
If tagRange IsNot Nothing Then
    editor.Document.IndicatorManager.Bookmarks.ToggleEnabledState(tagRange.Tag)

This code shows how to find and move the caret to the next instance of an enabled bookmark:

C#
VB
Copy
​// Create search options
var options = new TagSearchOptions<BookmarkIndicatorTag>();
options.CanWrap = true;
options.SearchUp = false;
options.Filter = (tr => tr.Tag.IsEnabled);

// Find the next indicator
var tagRange = editor.Document.IndicatorManager.Bookmarks.FindNext(editor.ActiveView.Selection.EndSnapshotOffset.Line, options);
if (tagRange != null) {
    // Move the caret
    editor.Caret.Offset = tagRange.VersionRange.Translate(editor.ActiveView.CurrentSnapshot).StartOffset;
}
​' Create search options
Dim options = New TagSearchOptions(Of BookmarkIndicatorTag)()
options.CanWrap = True
options.SearchUp = False
options.Filter = (tr => tr.Tag.IsEnabled);

' Find the next indicator
Dim tagRange = editor.Document.IndicatorManager.Bookmarks.FindNext(editor.ActiveView.Selection.EndSnapshotOffset.Line, options)
If tagRange IsNot Nothing Then
    ' Move the caret
    editor.Caret.Offset = tagRange.VersionRange.Translate(editor.ActiveView.CurrentSnapshot).StartOffset
End If

Breakpoint Indicators

Breakpoints are text range-based indicators that render a red circle glyph in the indicator margin and also highlight the contained text range with a red background. Breakpoint indicators can be used to visually represent a code execution breakpoint when working with an external debugger.

Breakpoints can be easily managed via the IBreakpointIndicatorManager interface, which is accessible via the IIndicatorManager.Breakpoints property.

This code shows how to toggle a breakpoint over a TextSnapshotRange (which generally is the text range of a statement):

C#
VB
Copy
​document.IndicatorManager.Breakpoints.Toggle(snapshotRange);
​document.IndicatorManager.Breakpoints.Toggle(snapshotRange)

This code shows how to clear all breakpoints from a document:

C#
VB
Copy
​document.IndicatorManager.Breakpoints.Clear();
​document.IndicatorManager.Breakpoints.Clear()

Breakpoint indicators also support an enabled state via their BreakpointIndicatorTag.IsEnabled property. Breakpoints are enabled by default. When disabled, their glyph and styled text range render differently. This is generally a visual reminder to the end user that the breakpoint will not be hit when code execution occurs.

This code shows how to toggle the enabled state for a breakpoint on the current line:

C#
VB
Copy
​var tagRange = editor.Document.IndicatorManager.Breakpoints.GetInstances(new TextSnapshotRange(editor.ActiveView.Selection.EndSnapshotOffset)).FirstOrDefault();
if (tagRange != null)
    editor.Document.IndicatorManager.Breakpoints.ToggleEnabledState(tagRange.Tag)
​Dim tagRange = editor.Document.IndicatorManager.Breakpoints.GetInstances(New TextSnapshotRange(editor.ActiveView.Selection.EndSnapshotOffset)).FirstOrDefault()
If tagRange IsNot Nothing Then
    editor.Document.IndicatorManager.Breakpoints.ToggleEnabledState(tagRange.Tag)

Current Statement Indicators

Current statement indicators are text range-based indicators that render a yellow arrow glyph in the indicator margin and also highlight the contained text range with a yellow background. Current statement indicators can be used to visually represent the current code execution point in a debugging session.

Current statement indicators can be easily managed via the ICurrentStatementIndicatorManager interface, which is accessible via the IIndicatorManager.CurrentStatement property. Note that this particular indicator manager is geared towards managing at most a single indicator instance at a time for a document. The reason is that there can only be a single current location in any debugging session.

This code shows how to set the current statement indicator over a TextSnapshotRange (which generally is the text range of a statement):

C#
VB
Copy
​document.IndicatorManager.CurrentStatement.SetInstance(snapshotRange);
​document.IndicatorManager.CurrentStatement.SetInstance(snapshotRange)

This code shows how to clear the current statement indicator from a document:

C#
VB
Copy
​document.IndicatorManager.CurrentStatement.Clear();
​document.IndicatorManager.CurrentStatement.Clear()

Custom Indicators

Custom indicators can easily be created and used with SyntaxEditor. To support a custom indicator, a custom indicator tag class and a custom indicator tagger class must be created.

Note Note
One of the samples included with the product shows a complete implementation of a custom tag and tagger. That is an excellent sample to examine when building a custom indicator.

Indicator Tag

Two base classes are included that make it easier to support custom indicator creation. The first is IndicatorTagBase and is an abstract base class that implements IIndicatorTag. Use this base class when the indicator will only show a glyph and not do any text range styling, such as in the case of bookmarks.

The second base class is IndicatorClassificationTagBase. This abstract base class inherits the first and also implements IClassificationTag, allowing it to style text ranges. See the Tags and Classification Types topic for more information on how classification tags can be used to override default syntax highlighting.

The IIndicatorTag.CreateGlyph method must be overridden to return a FrameworkElement that is the glyph for the indicator. It will be called any time the indicator is scrolled into view, and the resulting glyph will appear in the indicator margin.

Indicator Tagger

Similar to the two tag base classes above, two tagger base classes are provided: IndicatorTaggerBase`1 (to be used with IndicatorTagBase tags) and IndicatorClassificationTaggerBase`1 (to be used with IndicatorClassificationTagBase tags). The type parameter is the type of tag being returned by the tagger.

In either case, both taggers implement ICollectionTagger`1 and can be interacted with similar to a collection. See the Taggers and Tagger Providers topic for details on collection taggers.

One important thing to note about the tagger is that your inheriting class must include a public constructor that takes a single ICodeDocument parameter. The constructor should call the base constructor and pass any orderings that are appropriate to it so that indicators from certain taggers can appear above indicator from other taggers.

This code shows an example of a custom tagger that orders itself above the token tagger, meaning if its tags support IClassificationTag then it can override syntax highlighting:

C#
VB
Copy
​public CustomIndicatorTagger(ICodeDocument document) :
    base("CustomIndicator", new Ordering[] {
        new Ordering(TaggerKeys.Token, OrderPlacement.Before)
    }, document, true) {}
​Public Sub New(ByVal document As ICodeDocument)
    MyBase.New("CustomIndicator", New Ordering() {New Ordering(TaggerKeys.Token, OrderPlacement.Before)}, document, True)
End Sub

Indicator Manager

As mentioned above, the IIndicatorManager interface has a number of helpful method for working with indicators, even custom ones. For custom indicators, the generic methods directly on IIndicatorManager should be used. Each of these methods takes two generic type arguments: the type of tagger and the type of tag.

This code shows how to create a custom tag, set its quick info content provider, and add it to a certain TextSnapshotRange:

C#
VB
Copy
​// Create an indicator tag
var tag = new CustomIndicatorTag();
tag.ContentProvider = new PlainTextContentProvider("Custom indicator created at " + DateTime.Now.ToLongTimeString());

// Add the indicator tag (use a generic method provided on the indicator manager for custom indicators)
editor.Document.IndicatorManager.Add<CustomIndicatorTagger, CustomIndicatorTag>(snapshotRange, tag);
​' Create an indicator tag
Dim tag = New CustomIndicatorTag()
tag.ContentProvider = New PlainTextContentProvider("Custom indicator created at " & DateTime.Now.ToLongTimeString())

' Add the indicator tag (use a generic method provided on the indicator manager for custom indicators)
editor.Document.IndicatorManager.Add(Of CustomIndicatorTagger, CustomIndicatorTag)(snapshotRange, tag)

IntelliPrompt Quick Info for Glyphs

IntelliPrompt quick info can be added for the glyphs in the indicator margin. This means that when the mouse hovers over the glyph, a tooltip will display.

The quick info comes from the IContentProvider that is set in the IIndicatorTag.ContentProvider property. The content provider can return simple text, complex markup, etc. as described in the Content Providers topic.

Note Note
There is one requirement for this functionality to work. A special IndicatorQuickInfoProvider language service must be registered on the language. This quick info provider has built-in functionality to watch for the mouse being over indicator glyphs and use their related content provider for the quick info tip content.

This code shows how to register an IndicatorQuickInfoProvider language service on a language:

C#
VB
Copy
​language.RegisterService(new IndicatorQuickInfoProvider());
​language.RegisterService(New IndicatorQuickInfoProvider())

Handling Mouse Events in the Indicator Margin

Mouse events in the indicator margin can be handled via an IEditorViewMouseInputEventSink language service.

For instance, if your app supports a debugging experience, you may wish to allow clicks in the indicator margin to toggle whether a breakpoint is defined on the statement at that line. A full example of implementing this kind of behavior is given in the debugging-related indicators sample.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indentation Guides

SyntaxEditor Editor View Features
Indentation Guides

Indentation guides are subtle vertical lines that render at each tab stop on lines prior to the first non-whitespace character. Whitespace-only lines render indentation guides based on the tab stop level of surrounding text.

This topic contains these sections:

  • Activating Indentation Guides
  • Changing the Indentation Guide Brush

Activating Indentation Guides

The SyntaxEditor.AreIndentationGuidesVisible property can be set to true to activate indentation guides. Guides are not visible by default.

Changing the Indentation Guide Brush

The brush used to render the indentation guides can be adjusted by the end user since it is exposed via a special classification type's style in the highlighting style registry.

See the "Special Classification Types" section in the Highlighting Style Registries topic for more information on how to modify the style.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


ScrollBar Visibility, Trays, and Buttons

SyntaxEditor Editor View Features
ScrollBar Visibility, Trays, and Buttons

Scrollbars can optionally be hidden in the views. Each editor view in SyntaxEditor also has four scrollbar tray areas, where custom controls can be inserted via data templates.

This topic contains these sections:

  • ScrollBar Visibility
  • ScrollBar Tray Locations
  • Data Templates

ScrollBar Visibility

The SyntaxEditor.HorizontalScrollBarVisibility and VerticalScrollBarVisibility can be set to Hidden to hide the scrollbars. The default value is Visible.

Note that there is no "auto" mode at this time. Auto maps to Visible, and Disabled maps to Hidden.

ScrollBar Tray Locations

Each editor view has four distinct scrollbar tray areas. The locations include:

  • Left of the horizontal scrollbar
  • Right of the horizontal scrollbar
  • Above of the vertical scrollbar
  • Below of the vertical scrollbar

An editor view showing controls added in each of the four scrollbar trays

Data Templates

The tray areas are populated based on data templates that are set via these SyntaxEditor properties:

Member | Description
ScrollBarTrayBottomTemplate Property | Gets or sets the DataTemplate containing controls that are displayed under the vertical ScrollBar in an IEditorView.
ScrollBarTrayLeftTemplate Property | Gets or sets the DataTemplate containing controls that are displayed left of the horizontal ScrollBar in an IEditorView.
ScrollBarTrayRightTemplate Property | Gets or sets the DataTemplate containing controls that are displayed right of the horizontal ScrollBar in an IEditorView.
ScrollBarTrayTopTemplate Property | Gets or sets the DataTemplate containing controls that are displayed above the vertical ScrollBar in an IEditorView.

The easiest way to define a data template is in XAML. This code shows how to define the mail ToggleButton seen in the screenshot above:

XAML
Copy
​<editor:SyntaxEditor>
    <editor:SyntaxEditor.ScrollBarTrayBottomTemplate>
        <DataTemplate>
            <ToggleButton ToolTip="ToggleButton in the bottom tray">
                <Image Width="16" Height="16" Stretch="None"
                    Source="/Resources/Images/Mail16.png" />
            </ToggleButton>
        </DataTemplate>
    </editor:SyntaxEditor.ScrollBarTrayBottomTemplate>
</editor:SyntaxEditor>

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Hit Testing

SyntaxEditor Editor View Features
Hit Testing

SyntaxEditor makes it easy to hit test any Point in the editor and return detailed information about what is at that location.

This topic contains these sections:

  • Performing a Hit Test
  • Hit Test Results
  • Determining if the Hit Test is Over a Character
  • Scanning Text Around the Hit Test Result

Performing a Hit Test

A hit test can be performed by first obtaining a Point relative to the SyntaxEditor's coordinates and then calling the SyntaxEditor.HitTest method.

This code gets the current location of the mouse and performs a hit test against it:

C#
VB
Copy
​IHitTestResult result = editor.HitTest(Mouse.GetPosition(editor));
​Dim result As IHitTestResult = editor.HitTest(Mouse.GetPosition(editor))

Hit Test Results

The HitTest method returns an object of type IHitTestResult. This object provides information about exactly what is at the location being hit tested.

SyntaxEditor and Location

The SyntaxEditor and Location properties return the SyntaxEditor instance and location that were hit-tested.

Result Type

The Type property returns a HitTestResultType enumeration value. This value gives a high-level categorization of the result.

View and Margin

The View property returns an IEditorView if the location was over a view.

If the location was over a margin in the view, the ViewMargin property returns the IEditorViewMargin.

Offset and Position

The Offset and Position properties return the offset and TextPosition of the character at the location. If the location is not over a character, the nearest character is returned. If the location is not over a view, then the offset is -1.

See information below for how to determine if the offset/position are for an actual character or for a close character.

View Line and Text Area Location

The ViewLine property returns the IEditorViewLine that contains the Position.

The TextAreaLocation returns the location, but in text area-relative coordinates.

Snapshot and Reader

The Snapshot property returns the ITextSnapshot that was current when the hit test took place. The GetReader method can be used to obtain an ITextSnapshotReader that is initialized to the hit test offset.

Intra-Text Spacer

The IntraTextSpacerTag property returns the TagSnapshotRange`1 of the IIntraTextSpacerTag that contains the hit test offset, if any. This property is only filled in when the hit test type is ViewTextAreaOverIntraTextSpacer.

VisualElement

The VisualElement property returns the FrameworkElement, if any, that is related to the hit test result.

Determining if the Hit Test is Over a Character

The Type property is useful for determining if the location is over a character in the text area. When its value is ViewTextAreaOverCharacter, the location is directly over a character within an editor view. When its value is ViewTextAreaOverLine, the location is not over a character within an editor view, but it is in the whitespace past the end of a view line. When its value is ViewTextArea, the location is not over any editor view lines, but it is in the text area.

Thus the Offset and Position properties return the exact character the location is over when Type is ViewTextAreaOverCharacter. Otherwise, the offset/position of the closest character is returned.

Scanning Text Around the Hit Test Result

The ITextSnapshotReader returned by the GetReader method can be used to scan text and tokens near the hit test result.

See the Scanning Text Using a Reader topic for more information on scanning text.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Lifecycle

SyntaxEditor Editor View Features
View Lifecycle

SyntaxEditor views can be opened and closed via various end user actions. This topic discussed how to be notified when views are opened and closed.

This topic contains these sections:

  • Editor View Lifecycle
  • Printer View Lifecycle
  • SyntaxEditor Events
  • Language Event Sinks

Editor View Lifecycle

Editor views, represented by the IEditorView interface, are the interactive views that end users type in. There always is one active editor view in a SyntaxEditor instance, retrieved with the SyntaxEditor.ActiveView property.

Printer View Lifecycle

Printer views, represented by the IPrinterView interface, are quickly opened and immediately closed when building printable pages.

See the Printing Features topic for more information on printing editor contents.

SyntaxEditor Events

Whenever a view is opened, the SyntaxEditor.ViewOpened event is raised.

Likewise, a corresponding SyntaxEditor.ViewClosed is raised when a view is closed.

Language Event Sinks

Objects implementing the ITextViewLifecycleEventSink interface can be registered as a service on a syntax language. This allows the objects to be notified whenever a view that uses the language is attached or detached.

See the Event Sink Services topic for more information on how to register and implement event sinks.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delayed UI Updates

SyntaxEditor Editor View Features
Delayed UI Updates

SyntaxEditor includes a special event that is raised shortly after any text, caret, or selection changes occur within the editor. This event can be handled to update external UI controls based on updated editor context.

This topic contains these sections:

  • The UserInterfaceUpdate Event
  • Repeated Actions

The UserInterfaceUpdate Event

The SyntaxEditor.UserInterfaceUpdate event is raised following a brief delay after certain actions occur in the editor.

The event is set to raise 1 second after any of these actions occur:

  • Document text changed.
  • Document ParseData property changed.
  • Caret moves.
  • Selection changes.

Repeated Actions

The UserInterfaceUpdate event will not raise until the delay period has elapsed following any action listed above.

For instance, if the end user types a word and then stops, the timer to raise this event starts. However then assume that the end user holds down the down arrow to scroll through the document, before the delay period has elapsed. This action resets the event timer, and the process restarts again. Once the delay period has been reached without any further actions taking place, the event is raised.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


View Properties

SyntaxEditor Editor View Features
View Properties

The ITextView.Properties property provides a dictionary-like object that can store any sort of custom data that should be associated with the view.

The property returns an PropertyDictionary object, which supports any object type as a key or value.

This topic contains these sections:

  • Storing Data
  • Retriving Data

Storing Data

In this code snippet we store an object referenced by the variable someObject into the properties dictionary under the string key MyPropertyKey:

C#
VB
Copy
​editor.ActiveView.Properties["MyPropertyKey"] = someObject;
​editor.ActiveView.Properties.Item("MyPropertyKey") = someObject

Retriving Data

In this code snippet we retrieve an object stored under the string key MyPropertyKey:

C#
VB
Copy
​object someObject;
if (editor.ActiveView.Properties.TryGetValue("MyPropertyKey", out someObject)) {
    ...
}
​Dim someObject As Object
If editor.ActiveView.Properties.TryGetValue("MyPropertyKey", someObject) Then
    ...
End If

Alternatively the indexer could be used, however it will throw an exception if there is no object stored with the specified key, whereas TryGetValue will not.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Single-Line Mode

SyntaxEditor Editor View Features
Single-Line Mode

SyntaxEditor is a multi-line editor by default, but also supports a single-line edit mode where it looks like a single-line native TextBox.

In this mode, nearly all of SyntaxEditor's features remain available, such as syntax highlighting, syntax error squiggle lines, and automated IntelliPrompt.

This topic contains these sections:

  • Activating Single-Line Mode

Activating Single-Line Mode

The SyntaxEditor.IsMultiLine property can be set to false to activate single-line mode.

When that property is set to false, these properties are also automatically adjusted:

  • AcceptsTab is set to false.
  • IsOutliningMarginVisible is set to false.
  • IsSelectionMarginVisible is set to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Input/Output Features
Overview

In addition to the input/output features found in the text framework such as file load/save, exporting to HTML/RTF, etc., SyntaxEditor has a lot of other i/o features built-in.

This topic contains these sections:

  • Document Swapping
  • Clipboard Operations
  • Edit Actions
  • Default Key Bindings
  • Macro Recording and Playback
  • Data Binding
  • Indent Providers (Auto-Indent)
  • Delimiter Auto-Completion

Document Swapping

Documents can be attached to zero or more SyntaxEditor controls at any given time, and alternate IEditorDocument instances can be swapped into a SyntaxEditor.

See the Document Swapping topic for more information.

Clipboard Operations

SyntaxEditor makes use the Windows clipboard as a temporary repository for data for cut/copy/paste operations.

See the Clipboard Operations topic for more information.

Edit Actions

Edit actions are classes that implement IEditAction and contain code to perform different simple tasks related to a SyntaxEditor. They are often paired with WPF commands so that commands call can-execute and executed handlers on the edit actions to perform all the work.

See the Edit Actions topic for more information.

Default Key Bindings

Many keyboard shortcuts are automatically bound to allow keyboard access to most of the built-in edit actions.

See the Default Key Bindings topic for more information.

Macro Recording and Playback

SyntaxEditor has full macro recording and playback capabilities. It can record any edit action that is executed and can play back the set of edit actions at a later time. During macro recording mode, mouse input to the editor is ignored.

See the Macro Recording and Playback topic for more information.

Data Binding

SyntaxEditor has the capability of allowing two-way binding of its text to any other data source. This feature is disabled by default for performance reasons, but can be enabled via a property setting.

See the Data Binding topic for more information.

Indent Providers (Auto-Indent)

Indent providers are classes that implement IIndentProvider and contain code to perform automatic indentation when the Enter key is pressed.

See the Indent Providers (Auto-Indent) topic for more information.

Delimiter Auto-Completion

Delimiter auto-completion occurs when the end user types a start delimiter and a related end delimiter is auto-inserted after the caret. This improves code editing productivity since it means less overall typing is required to output the same code.

See the Delimiter Auto-Completion topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Document Swapping

SyntaxEditor Input/Output Features
Document Swapping

Documents can be attached to zero or more SyntaxEditor controls at any given time, and alternate IEditorDocument instances can be swapped into a SyntaxEditor.

This topic contains these sections:

  • UI and Text Separation
  • Swapping Document Instances

UI and Text Separation

The SyntaxEditor product has been specifically designed such that the text/parsing framework functions completely independently from the user interface layer.

The SyntaxEditor control is the root object of the product's user interface layer. It contains multiple editor views in which text can be edited.

The IEditorDocument interface provides the requirements for a document that can be edited within a SyntaxEditor control. Editor documents are the root of the text/parsing framework hierarchy and specify an ISyntaxLanguage that is used to parse the code in the document.

Swapping Document Instances

The SyntaxEditor control is always editing a single IEditorDocument instance at a time. The Document property gets and sets which IEditorDocument is currently being edited.

A second IEditorDocument could be opened and swapped in place of the SyntaxEditor's current document, by setting the Document property to the new document instance. When this occurs, the SyntaxEditor control detaches from the old document, attaches to the new document, and updates its views to display the text in the new document.

So effectively you could have an application that has a single SyntaxEditor control instance, but a lot of IEditorDocument instances that are loaded in memory. When the end user wishes to edit a particular document, you would swap that document into the editor. This saves on overall memory since mutiple editor control instances are not required.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Clipboard Operations

SyntaxEditor Input/Output Features
Clipboard Operations

SyntaxEditor makes use the Windows clipboard as a temporary repository for data for cut/copy/paste operations.

This topic contains these sections:

  • Cutting and Copying Text
  • Cutting and Copying with HTML and RTF Export
  • Pasting Text
  • Customizing Text to be Cut, Copied, or Dragged
  • Tracking Clipboard Change Events
  • Customizing Text to be Pasted or Dropped

Cutting and Copying Text

The IEditorView.CutLineToClipboard and CopyToClipboard methods may be used to cut and copy text to the clipboard respectively. The text that is placed on the clipboard is the currently selected text designated by the IEditorView.Selection.

If the selection length is zero, or in other words, no text is selected, a feature of SyntaxEditor is to place the entire line of text on the clipboard of which the caret is currently on. You can control whether blank lines will overwrite the clipboard by using the CanCutCopyBlankLineWhenNoSelection property.

There are CutAndAppendToClipboard and CopyAndAppendToClipboard methods on IEditorView as well, that append to the clipboard instead of replacing the contents of the clipboard.

This code demonstrates how to copy the currently selected text to the clipboard:

C#
VB
Copy
​editor.ActiveView.CopyToClipboard();
​editor.ActiveView.CopyToClipboard()

Cutting and Copying with HTML and RTF Export

The text that is copied can also be copied to the clipboard with HTML and RTF exported highlighting. Then, if you paste the text in an application such as Word, the text will appear highlighted.

The SyntaxEditor.CanCutCopyDragWithHtml property controls whether HTML exporting is performed whenever cutting or copying to the clipboard.

The SyntaxEditor.CanCutCopyDragWithRtf property controls whether RTF exporting is performed whenever cutting or copying to the clipboard.

Pasting Text

The IEditorView.PasteFromClipboard method allows text on the clipboard to be pasted into the document, thereby replacing any text that is currently selected within the view from which the method is called.

If text was copied from a SyntaxEditor when the selection length was zero (see above) the entire line of text that was copied will be inserted above the line in which the caret is currently located. In this situation, the caret is not moved.

This code demonstrates how to paste text from the clipboard:

C#
VB
Copy
​editor.ActiveView.PasteFromClipboard();
​editor.ActiveView.PasteFromClipboard()

Customizing Text to be Cut, Copied, or Dragged

Sometimes it is useful to be able to customize the text, or objects, to be cut, copied, or dragged. The SyntaxEditor.CutCopyDrag event that fires before text is cut or copied to the clipboard, and also before a drag occurs.

In its event arguments, it passes the IDataStore that is to be copied as well as the type of operation that will be performed. When the event fires, the IDataStore has already been initialized with a StandardDataFormats.Text entry based on the current selection in the editor. The IDataStore can be modified to customize what is sent to the clipboard or dragged.

Tracking Clipboard Change Events

Since the SyntaxEditor.CutCopyDrag event fires any time text is cut or copied from the control, it can also be used to maintain an external clipboard-setting history in your application. This is useful for maintaining a clipboard ring for your application.

Customizing Text to be Pasted or Dropped

Just like the SyntaxEditor.CutCopyDrag event, an event is provided to allow for customization of text that is to be pasted or dropped onto the editor. The PasteDragDrop event fires in several situations:

  • Paste operations
  • Paste completion
  • CanPaste checks
  • Drag enter
  • Drag/drop

This event passes the IDataStore that is to be pasted/dropped and the source of the event. The IDataStore is similar to IDataObject (see note above) and provides access to any clipboard data (such as non-text formats) that was used to trigger the event.

The PasteDragDropEventArgs.Text property can be set to the text to be inserted. It also can be set to null to insert nothing.

Note Note
For CanPaste checks and drag enter scenarios, the event arg's Text property can be set to any non-null value to indicate that the object can be pasted or dropped.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Edit Actions

SyntaxEditor Input/Output Features
Edit Actions

Edit actions are classes that implement IEditAction and contain code to perform different simple tasks related to a SyntaxEditor. They are often paired with commands so that commands call can-execute and executed handlers on the edit actions to perform all the work.

This topic contains these sections:

  • Edit Actions and Commands
  • Executing Edit Actions
  • Creating a Custom Edit Action

Edit Actions and Commands

SyntaxEditor includes over 100 unique edit actions and related commands, covering everything such as movements, selection types, clipboard operations, and more.

The built-in edit actions are all located in the EditActions namespace.

All commands related to the built-in edit actions are available via static properties on the EditorCommands class.

Executing Edit Actions

To execute an edit action, use the IEditorView.ExecuteEditAction method. Simply pass it an instance of the IEditAction to execute.

This code shows how to execute an IndentAction on the active view:

C#
VB
Copy
​editor.ActiveView.ExecuteEditAction(new IndentAction());
​editor.ActiveView.ExecuteEditAction(New IndentAction())

Most of the edit action classes defined by SyntaxEditor also have helper methods which make running the edit actions easier. or instance, the IEditorViewSelection interface has a method SelectAll, which runs the SelectAllAction. Another example is the IEditorView interface has a method CopyToClipboard, which runs the CopyToClipboardAction.

Creating a Custom Edit Action

Custom edit action classes may be defined. The only requirement is that they implement IEditAction. When defining an edit action, it's easiest to inherit EditActionBase.

This code shows how to define an edit action that surrounds the selected text with custom tags.

C#
VB
Copy
​/// <summary>
/// Provides a custom <see cref="IEditAction"/> implementation that inserts a
/// <c>custom</c> tag surrounding the selected text.
/// </summary>
public class CustomAction : ActiproSoftware.Windows.Controls.SyntaxEditor.Implementation.EditActionBase {

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Executes the edit action in the specified <see cref="IEditorView"/>.
    /// </summary>
    /// <param name="view">The <see cref="IEditorView"/> in which to execute the edit action.</param>
    public override void Execute(IEditorView view) {
        view.InsertSurroundingText("<custom>", "</custom>");
    }

}
​''' <summary>
''' Provides a custom <see cref="IEditAction"/> implementation that inserts a
''' <c>custom</c> tag surrounding the selected text.
''' </summary>
Public Class CustomAction
    Inherits ActiproSoftware.Windows.Controls.SyntaxEditor.Implementation.EditActionBase

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Executes the edit action in the specified <see cref="IEditorView"/>.
    ''' </summary>
    ''' <param name="view">The <see cref="IEditorView"/> in which to execute the edit action.</param>
    Public Overrides Sub Execute(ByVal view As IEditorView)
        view.InsertSurroundingText("<custom>", "</custom>")
    End Sub

End Class

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Default Key Bindings

SyntaxEditor Input/Output Features
Default Key Bindings

Many keyboard shortcuts are automatically bound to allow keyboard access to most of the built-in edit actions.

The following tables describe the default key bindings that are in place when the SyntaxEditor control is created. These can be modified by using the SyntaxEditor.InputBindings collection.

This topic contains these sections:

  • Clipboard/Undo Edit Actions
  • Deletion Edit Actions
  • Insertion Edit Actions
  • IntelliPrompt Edit Actions
  • Misecellaneous Edit Actions
  • Movement Edit Actions
  • Scroll Edit Actions
  • Selection Edit Actions

Clipboard/Undo Edit Actions

Key | Edit Action
Ctrl + C | CopyToClipboardAction
Ctrl + Ins | CopyToClipboardAction
Ctrl + X | CutToClipboardAction
Shift + Del | CutToClipboardAction
Ctrl + L | CutLineToClipboardAction
Ctrl + V | PasteFromClipboardAction
Shift + Ins | PasteFromClipboardAction
Ctrl + Y | RedoAction
Ctrl + Shift + Z | RedoAction
Ctrl + Z | UndoAction

Deletion Edit Actions

Key | Edit Action
Backspace | BackspaceAction
Shift + Backspace | BackspaceAction
Ctrl + Backspace | BackspaceToPreviousWordAction
Del | DeleteAction
Ctrl + Shift + L | DeleteLineAction
Ctrl + Del | DeleteToNextWordAction

Insertion Edit Actions

Key | Edit Action
Enter | InsertLineBreakAction
Shift + Enter | InsertLineBreakAction
Ctrl + Enter | OpenLineAboveAction
Ctrl + Shift + Enter | OpenLineBelowAction

IntelliPrompt Edit Actions

Key | Edit Action
Ctrl + Space | RequestIntelliPromptAutoCompleteAction
Ctrl + Shift + Space | RequestIntelliPromptParameterInfoSessionAction

Misecellaneous Edit Actions

Key | Edit Action
Ctrl + I | IncrementalSearchAction
Tab | InsertTabStopOrIndentAction
Ctrl + U | MakeLowercaseAction
Ctrl + Shift + U | MakeUppercaseAction
Shift + Tab | RemoveTabStopOrOutdentAction
Ctrl + Shift + I | ReverseIncrementalSearchAction
Insert | ToggleOverwriteModeAction
Ctrl + T | TransposeCharactersAction
Ctrl + Shift + T | TransposeWordsAction
Shift + Alt + T | TransposeLinesAction
Alt + Up | MoveSelectedLinesUpAction
Alt + Down | MoveSelectedLinesDownAction

Movement Edit Actions

Key | Edit Action
Down | MoveDownAction
Up | MoveUpAction
Left | MoveLeftAction
Right | MoveRightAction
Ctrl + Left | MoveToPreviousWordAction
Ctrl + Right | MoveToNextWordAction
Home | MoveToLineStartAction
End | MoveToLineEndAction
Ctrl + Home | MoveToDocumentStartAction
Ctrl + End | MoveToDocumentEndAction
Page Up | MovePageUpAction
Page Down | MovePageDownAction
Ctrl + Page Up | MoveToVisibleTopAction
Ctrl + Page Down | MoveToVisibleBottomAction
Ctrl + ] | MoveToMatchingBracketAction

Scroll Edit Actions

Key | Edit Action
Ctrl + Down | ScrollDownAction
Ctrl + Up | ScrollUpAction

Selection Edit Actions

Key | Edit Action
Ctrl + Num- | CodeBlockSelectionContractAction
Ctrl + Num+ | CodeBlockSelectionExpandAction
Escape | CollapseSelectionAction
Shift + Down | SelectDownAction
Shift + Up | SelectUpAction
Shift + Left | SelectLeftAction
Shift + Right | SelectRightAction
Ctrl + Shift + Left | SelectToPreviousWordAction
Ctrl + Shift + Right | SelectBlockToNextWordAction
Shift + Home | SelectToLineStartAction
Shift + End | SelectToLineEndAction
Ctrl + Shift + Home | SelectToDocumentStartAction
Ctrl + Shift + End | SelectToDocumentEndAction
Shift + Page Up | SelectPageUpAction
Shift + Page Down | SelectPageDownAction
Ctrl + Shift + Page Up | SelectToVisibleTopAction
Ctrl + Shift + Page Down | SelectToVisibleBottomAction
Ctrl + A | SelectAllAction
Ctrl + Shift + W | SelectWordAction
Ctrl + Shift + ] | SelectToMatchingBracketAction
Shift + Alt + Down | SelectBlockDownAction
Shift + Alt + Up | SelectBlockUpAction
Shift + Alt + Left | SelectBlockLeftAction
Shift + Alt + Right | SelectBlockRightAction
Ctrl + Shift + Alt + Left | SelectBlockToPreviousWordAction
Ctrl + Shift + Alt + Right | SelectBlockToNextWordAction

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Macro Recording and Playback

SyntaxEditor Input/Output Features
Macro Recording and Playback

SyntaxEditor has full macro recording and playback capabilities. It can record any edit action that is executed and can play back the set of edit actions at a later time. During macro recording mode, mouse input to the editor is ignored.

This topic contains these sections:

  • Controlling Macro Recording
  • MacroAction
  • Adding Macro Edit Action Key Bindings
  • Macro Commands
  • Serializing and Deserializing Macros to XML

Controlling Macro Recording

All macro recording functionality is accessible via the SyntaxEditor.MacroRecording property. The IMacroRecording interface has a number of important members:

Member | Description
Cancel Method | Cancels recording a macro. When macro recording is cancelled, the old value of the LastMacroAction property is not overwritten.
CurrentMacroAction Property | Gets the MacroAction that is currently being recorded. This method returns null (Nothing in VB) if no macro recording is currently taking place.
LastMacroAction Property | Gets the last MacroAction that was recorded. After macro recording is stopped, this property contains what was recorded.
Pause Method | Pauses recording a macro. Use the Resume method to resume recording.
Resume Method | Resumes recording a macro from a paused state. This method should be called after a Pause to resume recording.
Record Method | Starts recording a new macro. Use the Stop method to end recording and save the macro that was recorded.
State Property | Gets a MacroRecordingState indicating the current state of macro recording.
Stop Method | Stops recording a macro. The MacroAction that is recorded is stored in the LastMacroAction property. If no commands were recorded during this recording session, the old value of the LastMacroAction property will not be overwritten.

All of the methods above raise the SyntaxEditor.MacroRecordingStateChanged event.

MacroAction

Once a macro has been recorded, it is stored in a MacroAction object. The MacroAction class is an IEditAction itself. However it, and the other macro-related edit actions override the CanRecordInMacro property to prevent them from being recorded in other macros.

To play back a MacroAction, execute code like this:

C#
VB
Copy
​editor.ActiveView.ExecuteEditAction(macroAction);
​editor.ActiveView.ExecuteEditAction(macroAction)

The MacroAction class is an enumerable class of child IEditAction objects.

Adding Macro Edit Action Key Bindings

SyntaxEditor ships with several edit actions that can be added as key bindings to the SyntaxEditor.InputBindings collection:

Command | Description
CancelMacroRecordingAction | Cancels recording a macro.
PauseResumeMacroRecordingAction | Pauses or resumes recording a macro, depending on the current state of macro recording.
RunMacroAction | Runs the macro that was last recorded.
ToggleMacroRecordingAction | Starts or stops recording a macro, depending on the current state of macro recording.

By default, these edit actions are not added to the default key bindings.

Macro Commands

The EditorCommands class has a number of static properties containing commands that are handled by SyntaxEditor.

These commands are related to macros and can be used by toolbar buttons, etc. to control macro recording:

  • CancelMacroRecording
  • PauseResumeMacroRecording
  • RunMacro
  • ToggleMacroRecording

The commands use the related edit actions described in the previous section.

Serializing and Deserializing Macros to XML

SyntaxEditor can serialize a macro to XML by using the MacroAction.WriteToXml method. To deserialize a macro later, create an instance of the MacroAction and call its ReadFromXml method. All the child edit actions of the macro should load into the macro so that it is ready to be run.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Data Binding

SyntaxEditor Input/Output Features
Data Binding

SyntaxEditor has the capability of allowing two-way binding of its text to any other data source. This feature is disabled by default for performance reasons, but can be enabled via a property setting.

This topic contains these sections:

  • Why is Data Binding Disabled by Default?
  • Configuring Data Binding on Text

Why is Data Binding Disabled by Default?

Data binding to the SyntaxEditor.Text property is disabled by default for several reasons.

First, supporting the Text dependency property means that two full copies of the document text are stored in memory instead of one, which can increase memory a lot for large documents.

Second, the full text must be set to the dependency property after each text change, meaning performance could suffer depending on the size of the document.

Therefore, databinding is disabled by default.

Configuring Data Binding on Text

To enable data binding on the Text property, simply set the IsTextDataBindingEnabled property to true.

When that property is true, the text dependency property is updated when changes are made to the document, and thus binding to other objects can be achieved.

This code demonstrates how to bind the SyntaxEditor's text to another WPF TextBox:

XAML
Copy
​<editor:SyntaxEditor AreLineModificationMarksVisible="False"
                     IsTextDataBindingEnabled="True"
                     Text="{Binding ElementName=boundTextBox, Path=Text, Mode=TwoWay}" />

Since data binding replaces the complete text of the document with each change in the data source, it is best to set the AreLineModificationMarksVisible property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Providers (Auto-Indent)

SyntaxEditor Input/Output Features
Indent Providers (Auto-Indent)

Indent providers are classes that implement IIndentProvider and contain code to perform automatic indentation when the Enter key is pressed.

This topic contains these sections:

  • Indent Mode
  • Default Auto-Indent Behavior
  • Smart Indent Logic
  • Registering with a Language
  • Curly Brace Auto-Indent
  • Square Brace Auto-Indent
  • Close Delimiter Indentation Level

Indent Mode

SyntaxEditor has been designed such that customized auto-indent behavior can be implemented to suit the language being edited.

If a class that implements IIndentProvider is registered with a syntax language as an IIndentProvider service, the indent provider's Mode property will be queried by SyntaxEditor to determine the type of indentation it should be performing when Enter is pressed.

There are three mode options:

Mode | Description
None | When selected, no automatic indenting occurs when the end user presses Enter to move to a new line of text, and the cursor is placed at the first column of the next line.
Block | When selected and the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.
Smart | When selected and the end user presses Enter, the new line of text is automatically indented based on what the current language's IIndentProvider service determines the context to be.

Default Auto-Indent Behavior

If do not you have an indent provider registered with your syntax language, a default "Block" mode will be used. When the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.

Smart Indent Logic

When an IIndentProvider is registered with the language and the Smart indent mode is set, the GetIndentAmount method will be invoked whenever the Enter key is pressed.

The method is passed a TextSnapshotOffset and the default "block" indent amount. The result of this method should always be the number of columns (spaces) to indent the line, as opposed to tabs. Upon return from the method, SyntaxEditor will automatically indent the first non-whitespace character on the line to the desired column.

The TextSnapshotOffset.Snapshot property gives access to its ITextSnapshot. Likewise, the ITextSnapshot.Document provides access to its owner ITextDocument. The ITextDocument.TabSize property tells how many spaces are in a tab, in case that information is useful while determining the amount to indent.

If the ITextDocument is an ICodeDocument, the ICodeDocument.ParseData property may also contain AST or other language-specific information that can be useful when determining the indent amount.

Indent providers are free to use any custom logic in the GetIndentAmount implementation to perform the indentation. They typically will create an ITextSnapshotReader (see the Scanning Text Using a Reader topic), will scan backwards from the indicated offset and will determine how the passed-in "block" indent amount value should be altered, if at all.

For instance, in C#, if while scanning backwards the first non-whitespace character encountered is a {, then the the indent amount returned should be the "block" indent amount plus an additional tab stop (usually calculated by adding the ITextDocument.TabSize value).

Registering with a Language

This code demonstrates registering an XmlIndentProvider service with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlIndentProvider indentProvider = new XmlIndentProvider();
language.RegisterService<IIndentProvider>(indentProvider);
​Dim indentProvider As XmlIndentProvider = New XmlIndentProvider()
language.RegisterService(Of IIndentProvider)(indentProvider)

Curly Brace Auto-Indent

Some languages like C# and JavaScript use curly braces as delimiters for code blocks. When the end user presses Enter while the caret is immediately between a curly brace pair, it is handy for the caret to be moved to the next line, indented, and for the close curly brace to be moved to the line following the caret. This aids in typing efficiency.

This example, where the | character denotes the caret, demonstrates the before and after what is described above:

Code Snippet
Copy
function Foo() {|}
Code Snippet
Copy
function Foo() {
    |
}

A pre-built DelimiterIndentProvider class is included that implements IIndentProvider. While it doesn't actually do anything other than block indent, it does have the code necessary to support curly brace auto-indent, as long as its CanAutoIndentCurlyBraces property is set to true (the default).

Note Note
This class is ideal for use as a base class for your own indent providers, as long as your language should have curly brace auto-indent features.

By default, DelimiterIndentProvider will just perform basic text scanning when determining if delimiters are valid for auto-indent. However this can cause issues when examining an open curly brace and the character is within a string or comment, meaning it's not really a code-oriented brace. Thus the indent provider also provides optional token IDs that can be set for each character. When a potential open/close delimiter pair is found and related token IDs are specified, it will double-check that the tokens have those token IDs. This eliminates the problem. Properties such as DelimiterIndentProvider.OpenCurlyBraceTokenId and DelimiterIndentProvider.CloseCurlyBraceTokenId are available for indicating the token IDs.

In some lexers such as dynamic lexers, token ID's might not be known and string-based token keys might only be set. In these cases, it's easy to handle. Instead of specifying values to the various token ID properties on DelimiterIndentProvider, override its IsValidStartDelimiter and IsValidEndDelimiter methods. An example of this concept is given in the Delimiter Auto-Completion topic.

Square Brace Auto-Indent

The pre-built DelimiterIndentProvider class described above also fully supports square brace auto-indent. This feature can be activated by setting the CanAutoIndentSquareBraces property is set to true.

As with curly braces, DelimiterIndentProvider will just perform basic text scanning when determining if delimiters are valid for auto-indent. However this can cause issues when examining an open curly brace and the character is within a string or comment, meaning it's not really a code-oriented brace. Thus the indent provider also provides optional token IDs that can be set for each character. When a potential open/close delimiter pair is found and related token IDs are specified, it will double-check that the tokens have those token IDs. This eliminates the problem. Properties such as DelimiterIndentProvider.OpenSquareBraceTokenId and DelimiterIndentProvider.CloseSquareBraceTokenId are available for indicating the token IDs.

In some lexers such as dynamic lexers, token ID's might not be known and string-based token keys might only be set. In these cases, it's easy to handle. Instead of specifying values to the various token ID properties on DelimiterIndentProvider, override its IsValidStartDelimiter and IsValidEndDelimiter methods. An example of this concept is given in the Delimiter Auto-Completion topic.

Close Delimiter Indentation Level

When using the DelimiterIndentProvider class described above, the close delimiter will normally flow to the same indent level as the line upon which Enter was pressed, such as:

Code Snippet
Copy
function Foo() {|}
Code Snippet
Copy
function Foo() {
    |
}

If the DelimiterIndentProvider.CloseDelimiterIndentLevel property is set to 1, the close delimiter indent an additional level:

Code Snippet
Copy
function Foo() {|}
Code Snippet
Copy
function Foo() {
    |
    }

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delimiter Auto-Completion

SyntaxEditor Input/Output Features
Delimiter Auto-Completion

Delimiter auto-completion occurs when the end user types a start delimiter and a related end delimiter is auto-inserted after the caret. This improves code editing productivity since it means less overall typing is required to output the same code.

This topic contains these sections:

  • Activating Delimiter Auto-Completion
  • Auto-Completion Logic
  • Registering a Delimiter Auto-Completer with a Syntax Language
  • Working with Dynamic Lexers and String Token Keys

Activating Delimiter Auto-Completion

The SyntaxEditor.IsDelimiterAutoCompleteEnabled property can be set to true to allow SyntaxEditor to perform delimiter auto-completion, as long as the current syntax language supports the feature. Delimiter auto-completion is enabled on SyntaxEditor by default.

Auto-Completion Logic

Delimiter auto-completers are language services that implement the IDelimiterAutoCompleter interface. A built-in DelimiterAutoCompleter class is included that fully implements IDelimiterAutoCompleter and makes it easy for a language to support auto-completion of these delimiter pairs:

  • Angle braces (disabled by default)
  • Curly braces
  • Double quotes
  • Parenthesis
  • Single quotes (disabled by default)
  • Square braces

The various supported brace match options can be turned on or off with properties such as DelimiterAutoCompleter.CanCompleteSquareBraces.

By default, this auto-completer will just perform basic text scanning when determining if delimiters are valid for auto-completion. However this can cause issues when examining an open parenthesis and the character is within a string or comment, meaning it's not really a code-oriented parenthesis. Thus the auto-completer also provides optional token IDs that can be set for each character. When a potential open delimiter is found and a related token ID is specified, it will double-check that the token at the offset has that token ID. This eliminates the problem. Properties such as DelimiterAutoCompleter.OpenParenthesisTokenId are available for indicating the token IDs.

Registering a Delimiter Auto-Completer with a Syntax Language

An IDelimiterAutoCompleter can be associated with an ISyntaxLanguage by registering it with the language. This example shows how to use a DelimiterAutoCompleter that only has curly brace and parenthesis support:

C#
VB
Copy
​language.RegisterService<IDelimiterAutoCompleter>(new DelimiterAutoCompleter() {
    CanCompleteDoubleQuotes = false,
    CanCompleteSquareBraces = false,
    OpenCurlyBraceTokenId = SimpleTokenId.OpenCurlyBrace,
    OpenParenthesisTokenId = SimpleTokenId.OpenParenthesis,
});
​language.RegisterService(Of IDelimiterAutoCompleter)(New DelimiterAutoCompleter() With { _
    .CanCompleteDoubleQuotes = False, _
    .CanCompleteSquareBraces = False, _
    .OpenCurlyBraceTokenId = SimpleTokenId.OpenCurlyBrace, _
    .OpenParenthesisTokenId = SimpleTokenId.OpenParenthesis _
})

Note how token IDs are specified to ensure start delimiters are properly recognized.

Working with Dynamic Lexers and String Token Keys

In some lexers such as dynamic lexers, token ID's might not be known and string-based token keys might only be set. In these cases, it's easy to handle. Instead of specifying values to the various token ID properties on DelimiterAutoCompleter, override its IsValidStartDelimiter method.

This example shows how to make a customized delimiter auto-completer that adds parenthesis-only auto-completion to the free SQL language:

C#
VB
Copy
​public class SqlDelimiterAutoCompleter : DelimiterAutoCompleter {

    public SqlDelimiterAutoCompleter() {
        this.CanCompleteDoubleQuotes = false;
        this.CanCompleteCurlyBraces = false;
        this.CanCompleteSquareBraces = false;
    }

    protected override bool IsValidStartDelimiter(IToken token, char startDelimiter) {
        switch (startDelimiter) {
            case '(':
                return (token != null) && (token.Key == "OpenParenthesis");
            default:
                return false;
        }
    }

}
​Public Class SqlDelimiterAutoCompleter
    Inherits DelimiterAutoCompleter

    Public Sub New()
        Me.CanCompleteDoubleQuotes = False
        Me.CanCompleteCurlyBraces = False
        Me.CanCompleteSquareBraces = False
    End Sub

    Protected Overrides Function IsValidStartDelimiter(ByVal token As IToken, ByVal startDelimiter As Char) As Boolean
        Select Case startDelimiter
            Case "("c
                Return (token IsNot Nothing) AndAlso (token.Key = "OpenParenthesis")
            Case Else
                Return False
        End Select
    End Function

End Class

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Printing Features
Overview

SyntaxEditor's print features include easy dialog access, many print options, and customizable margins.

This topic contains these sections:

  • Print Dialogs
  • Print Options
  • Printer View Margins

Print Dialogs

SyntaxEditor provides easy access to built-in print dialogs.

See the Print Dialogs topic for more information.

Print Options

There are a large number of options available that affect how printouts render.

See the Print Options topic for more information.

Printer View Margins

While the SyntaxEditor printer views have numerous built-in margins (document title, page number, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to printer views in any location.

See the Printer View Margins topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Print Dialogs

SyntaxEditor Printing Features
Print Dialogs

SyntaxEditor provides easy access to built-in print dialogs.

This topic contains these sections:

  • The Print Flyout

The Print Flyout

SyntaxEditor fully supports the Windows Print flyout:

The Print flyout

This code shows an AttachToPrintManager method that should be called when a page with SyntaxEditor on it is active:

C#
VB
Copy
​/// <summary>
/// Attaches to the print manager.
/// </summary>
private void AttachToPrintManager() {
    printManager = PrintManager.GetForCurrentView();
    if (printManager != null)
        printManager.PrintTaskRequested += OnPrintManagerPrintTaskRequested;
}

/// <summary>
/// Detaches from the print manager.
/// </summary>
private void DetachFromPrintManager() {
    if (printManager != null) {
        printManager.PrintTaskRequested -= OnPrintManagerPrintTaskRequested;
        printManager = null;
    }
}
​''' <summary>
''' Attaches to the print manager.
''' </summary>
Private Sub AttachToPrintManager()
    printManager = printManager.GetForCurrentView()
    If printManager IsNot Nothing Then
        AddHandler printManager.PrintTaskRequested, AddressOf OnPrintManagerPrintTaskRequested
    End If
End Sub

''' <summary>
''' Detaches from the print manager.
''' </summary>
Private Sub DetachFromPrintManager()
    If printManager IsNot Nothing Then
        RemoveHandler printManager.PrintTaskRequested, AddressOf OnPrintManagerPrintTaskRequested
        printManager = Nothing
    End If
End Sub

This code handles print task requests and renders a PrintDocument from SyntaxEditor:

C#
VB
Copy
​/// <summary>
/// Occurs when the <see cref="PrintManager"/> requests a print task.
/// </summary>
/// <param name="sender">The sender of the event.</param>
/// <param name="e">The <c>PrintTaskRequestedEventArgs</c> that contains data related to this event.</param>
private void OnPrintManagerPrintTaskRequested(PrintManager sender, PrintTaskRequestedEventArgs e) {
    PrintTask printTask = null;
    printTask = e.Request.CreatePrintTask("SyntaxEditor Printout", async sourceRequestedArgs => {
        var deferral = sourceRequestedArgs.GetDeferral();

        if (editor != null) {
            await editor.Dispatcher.RunAsync(CoreDispatcherPriority.Normal, () => {
                if (editor.PrintSettings != null) {
                    // Update the document title for the printout
                    editor.PrintSettings.DocumentTitle = editor.Document.FileName;

                    // Create a print document
                    printDocument = editor.PrintSettings.CreatePrintDocument(editor);
                    if ((printDocument != null) && (printDocument.DocumentSource != null)) {
                        // Set the source
                        sourceRequestedArgs.SetSource(printDocument.DocumentSource);
                    }
                }
            });
        }

        deferral.Complete();
    });
}
​''' <summary>
''' Occurs when the <see cref="PrintManager"/> requests a print task.
''' </summary>
''' <param name="sender">The sender of the event.</param>
''' <param name="e">The <c>PrintTaskRequestedEventArgs</c> that contains data related to this event.</param>
Private Sub OnPrintManagerPrintTaskRequested(ByVal sender As PrintManager, ByVal e As PrintTaskRequestedEventArgs)
    Dim printTask As PrintTask = Nothing
    printTask = e.Request.CreatePrintTask("SyntaxEditor Printout", Async Sub(sourceRequestedArgs)
        Dim deferral = sourceRequestedArgs.GetDeferral()
        If editor IsNot Nothing Then
            Await editor.Dispatcher.RunAsync(CoreDispatcherPriority.Normal, Sub()
                If editor.PrintSettings IsNot Nothing Then
                    editor.PrintSettings.DocumentTitle = editor.Document.FileName
                    printDocument = editor.PrintSettings.CreatePrintDocument(editor)
                    If (printDocument IsNot Nothing) AndAlso (printDocument.DocumentSource IsNot Nothing) Then
                        sourceRequestedArgs.SetSource(printDocument.DocumentSource)
                    End If
                End If
            End Sub)
        End If
        deferral.Complete()
    End Sub)
End Sub

Then finally, this code shows the flyout:

C#
VB
Copy
​await PrintManager.ShowPrintUIAsync();
​Await printManager.ShowPrintUIAsync()

The printed content is based on the configuration of the SyntaxEditor.PrintSettings object.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Print Options

SyntaxEditor Printing Features
Print Options

There are a large number of options available that affect how printouts render.

This topic contains these sections:

  • Accessing Print Settings
  • The Document Title
  • Turning Off Syntax Highlighting
  • Using a Custom Highlighting Style Registry
  • Displaying Whitespace

Accessing Print Settings

The IPrintSettings interface contains all the options that relate to printing. The print settings are accessed via the SyntaxEditor.PrintSettings property.

The Document Title

The document title can optionally be displayed at the top of each page in a printer view. It is visible when the IPrintSettings.DocumentTitle property is non-null and the IsDocumentTitleMarginVisible property is true, which is the default.

This code sets the document title that is displayed at the top of each page:

C#
VB
Copy
​editor.PrintSettings.DocumentTitle = "My Document";
​editor.PrintSettings.DocumentTitle = "My Document"

Turning Off Syntax Highlighting

Syntax highlighting is on by default for printer views. To turn it off and make text black and white, set the IPrintSettings.IsSyntaxHighlightingEnabled property is set to false.

Using a Custom Highlighting Style Registry

When syntax highlighting is on for printer views, it will use the IHighlightingStyleRegistry that is currently active in the editor. However when the editor is using a dark theme, this is not a desirable registry to use for printouts.

A IPrintSettings.HighlightingStyleRegistry property can be set to a custom IHighlightingStyleRegistry instance that will be used for printer output only, and is ideally set up with darker foreground colors and no backgrounds.

See the Highlighting Style Registries topic for more information on highlighting style registries.

Displaying Whitespace

Tabs and spaces can be visually displayed when the IPrintSettings.IsWhitespaceVisible property is set to true. The default is to not show whitespace.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Printer View Margins

SyntaxEditor Printing Features
Printer View Margins

While the SyntaxEditor printer views have numerous built-in margins (document title, page number, etc.), SyntaxEditor offers an extensibility point where custom margins can be created and added to printer views in any location.

Printer view margins all implement the IPrinterViewMargin interface.

This topic contains these sections:

  • Margin Locations
  • Built-In Margin Summary
  • Document Title Margin
  • Line Number Margin
  • Word Wrap Glyph Margin
  • Page Number Margin
  • Margin Factories
  • Custom Margins

Margin Locations

Printer view margins surround the text area and can be displayed in one of four placement locations (left, top, right, bottom).

The IPrinterViewMargin.Placement property has an PrinterViewMarginPlacement enumeration value that indicates one of those four placement locations.

Since each IPrinterViewMargin has a string-based Key, and the interface also implements IOrderable, it has an Orderings property that returns an enumerable of Ordering objects. Each ordering indicates the a string Key of another margin and whether this margin comes before or after that one. When multiple margins are combined into a placement location, they are ordered based on the Orderings property values, where "after" means farther away from the text area.

Built-In Margin Summary

These printer view margins are built-in to the product:

  • Document title margin
  • Line number margin
  • Word wrap glyph margin
  • Page number margin

Document Title Margin

The document title margin, implemented by the PrinterDocumentTitleMargin class, is used to display the title of the document, which is specified in the IPrintSettings.DocumentTitle property. It appears in the top placement.

Visibility

This margin is visible by default (if a document title is specified), and can be made invisible when the IPrintSettings.IsDocumentTitleMarginVisible property is false.

Line Number Margin

The line number margin, implemented by the PrinterLineNumberMargin class, is used to display snapshot line numbers. It appears in the left placement.

Word wrapped lines do not display any line numbers.

Visibility

This margin is not visible by default, and can be made visible when the IPrintSettings.IsLineNumberMarginVisible property is true.

Word Wrap Glyph Margin

The word wrap glyph margin, implemented by the PrinterWordWrapGlyphMargin class, is used to display glyphs at the end of lines that are too long to fit in the view and must be wrapped. It appears in the right placement.

Visibility

This margin is visible by default, and can be made invisible when the IPrintSettings.IsWordWrapGlyphMarginVisible property is false.

Page Number Margin

The page number margin, implemented by the PrinterPageNumberMargin class, is used to display the current page number on each page. It appears in the bottom placement.

Visibility

This margin is visible by default, and can be made invisible when the IPrintSettings.IsPageNumberMarginVisible property is false.

Margin Factories

Margin factories are used to tell SyntaxEditor which margins to display in a printer view. Margin factories are implementations of the IPrinterViewMarginFactory interface.

The DefaultPrinterViewMarginFactory class is an implementation of a factory that creates all of the built-in margins. While all the built-in margins are added if this factory is used, they still change their visibility based on the related IPrintSettings margin visibility properties such as IsDocumentTitleMarginVisible.

The IPrintSettings.ViewMarginFactories property is a collection of IPrinterViewMarginFactory objects. By default it is auto-populated with the DefaultPrinterViewMarginFactory, meaning all built-in margins are available. Add additional margin factories to the collection if you wish to add custom margins. A QuickStart is available in the samples that shows how to do this.

Custom Margins

Custom margins are pretty easy to create. These are the basic steps involved:

  • First, make a margin Control that implements IPrinterViewMargin.
  • Second, make a custom IPrinterViewMarginFactory that creates an instance of your margin class.
  • Third, add your custom margin factory to the IPrintSettings.ViewMarginFactories collection.

At this point your margin should now be getting added to the view.

For details on implementing a custom margin including several complete examples, please see the related QuickStarts in the samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Searching (Find/Replace) Features
Overview

SyntaxEditor's view search model interacts with the view's selection and provides extensive find/replace functionality. A standalone EditorSearchView control can be used to instantly recreate a Visual Studio-like search experience for end users.

This topic contains these sections:

  • Programmatically Searching
  • Incremental Search
  • Search Result Highlighting
  • EditorSearchView Control

Programmatically Searching

SyntaxEditor includes a powerful view search model that is layered on top of the low-level search model found in the text framework.

See the Programmatically Searching topic for more information.

Incremental Search

SyntaxEditor supports incremental search, which is a feature that allows for fast text searching via the keyboard, and without the use of any search dialogs or panes.

See the Incremental Search topic for more information.

Search Result Highlighting

When performing searches, many modern editors actively display matching results as the user types the find text. SyntaxEditor supports the live highlighting of search results.

See the Search Result Highlighting topic for more information.

EditorSearchView Control

The EditorSearchView control is a standalone control that can be used within an application tool window to provide an user interface with Visual Studio-like search capabilities for a SyntaxEditor.

See the EditorSearchView Control topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Programmatically Searching

SyntaxEditor Searching (Find/Replace) Features
Programmatically Searching

SyntaxEditor includes a powerful view search model that is layered on top of the low-level search model found in the text framework.

This topic contains these sections:

  • Understanding the View Search Model vs. the Low-Level Search Model
  • Accessing the View Search Model
  • Editor Search Options
  • Search Result Sets
  • Performing a Find Next Operation
  • Performing a Replace Next Operation
  • Performing a Replace All Operation

Understanding the View Search Model vs. the Low-Level Search Model

Before diving into this topic any further, it is essential that you understand the information presented in the Low-Level Searching Operations topic. That topic describes the core search object model and its capabilities. Most of the same types described in that topic are used in the "view" search model.

The "view" search model layers itself on top of the core model and provides some extended functionality. Most of the extended functionality deals with manipulating the search operations based on the view's selection and updated the selection when appropriate.

In general, the rule of thumb is: if you are going to search a document that is open within a SyntaxEditor control, use the "view" search model. If you are going to search a document that is not open in a SyntaxEditor control, use the low-level search model.

Accessing the View Search Model

The "view" search model is accessed via the IEditorView.Searcher property. This property returns an IEditorViewSearcher instance, which has find/replace functionality built-in.

Since the view search model is accessed for a particular view, it interacts with the owner view's selection.

Editor Search Options

The IEditorSearchOptions interface specifies the options type that must be passed into the view search model methods. It inherits the low-level ISearchOptions interface, which is described in the Low-Level Searching Operations topic.

This view search model options interface adds a Scope property, which is an enumeration value of type EditorSearchScope. It specifies whether the search is performed within the entire document or in the current selection only.

The EditorSearchOptions is an implementation of the IEditorSearchOptions interface and can be used in your code.

Search Result Sets

Each search method returns an ISearchResultSet object, which is described in detail in the Low-Level Searching Operations topic.

Performing a Find Next Operation

A find next operation can be performed like this:

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions();
options.FindText = "findtext";
options.PatternProvider = SearchPatternProviders.Normal;
ISearchResultSet resultSet = editor.ActiveView.Searcher.FindNext(options);
​Dim options As EditorSearchOptions = New EditorSearchOptions()
options.FindText = "findtext"
options.PatternProvider = SearchPatternProviders.Normal
Dim resultSet As ISearchResultSet = editor.ActiveView.Searcher.FindNext(options)

Performing a Replace Next Operation

A replace next operation can be performed like this:

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions();
options.FindText = "findtext";
options.ReplaceText = "replacetext";
options.PatternProvider = SearchPatternProviders.Normal;
ISearchResultSet resultSet = editor.ActiveView.Searcher.ReplaceNext(options);
​Dim options As EditorSearchOptions = New EditorSearchOptions()
options.FindText = "findtext"
options.ReplaceText = "replacetext"
options.PatternProvider = SearchPatternProviders.Normal
Dim resultSet As ISearchResultSet = editor.ActiveView.Searcher.ReplaceNext(options)

Performing a Replace All Operation

A replace all operation can be performed like this:

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions();
options.FindText = "findtext";
options.ReplaceText = "replacetext";
options.PatternProvider = SearchPatternProviders.Normal;
ISearchResultSet resultSet = editor.ActiveView.Searcher.ReplaceAll(options);
​Dim options As EditorSearchOptions = New EditorSearchOptions()
options.FindText = "findtext"
options.ReplaceText = "replacetext"
options.PatternProvider = SearchPatternProviders.Normal
Dim resultSet As ISearchResultSet = editor.ActiveView.Searcher.ReplaceAll(options)

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Incremental Search

SyntaxEditor Searching (Find/Replace) Features
Incremental Search

SyntaxEditor supports incremental search, which is a feature that allows for fast text searching via the keyboard, and without the use of any search dialogs or panes.

This topic contains these sections:

  • Run-Time Usage
  • UI Updates While Searching
  • Trimming Unmatched Find Text

Run-Time Usage

Incremental searches are performed from the current caret offset in the editor. To start incremental search mode, press Ctrl+I and start typing some characters. The characters will be accumulated into a find text string and used to search the document for the next instance of the find text, which will be selected.

All find text matches will be automatically highlighted as long as the Search Result Highlighting feature is enabled.

Press Ctrl+I to move to the next match. Press Ctrl+Shift+I to move to the previous match.

Continue typing characters to append to the find text. Backspace can be used to remove characters from the find text. Esc can be used to deactivate incremental search mode.

UI Updates While Searching

The application UI should provide some sort of status indicator when incremental search events occur.

The SyntaxEditor.ViewSearch event fires whenever any editor view search occurs, including when incremental searches take place. In this scenario, the result set's ISearchResultSet.OperationType property will be FindNextIncremental. UI such as a statusbar can be updated in an event handler to indicate that incremental search is active and what the find text is.

The SyntaxEditor.ViewIsIncrementalSearchActiveChanged event fires whenever incremental search mode is activated or deactivated. It's a great place to clear out any UI that indicates incremental search is active. The IEditorView.IsIncrementalSearchActive property is used to know if incremental search mode is active.

This code shows how a statusbar panel could be updated in response to the events mentioned above:

C#
VB
Copy
​private void OnSyntaxEditorViewIsIncrementalSearchActiveChanged(object sender, TextViewEventArgs e) {
    IEditorView editorView = e.View as IEditorView;
    if ((editorView != null) && (!editorView.IsIncrementalSearchActive)) {
        // Incremental search is now deactivated
        messagePanel.Content = "Ready";
    }
}

private void OnSyntaxEditorViewSearch(object sender, EditorViewSearchEventArgs e) {
    // If an incremental search was performed...
    if (e.ResultSet.OperationType == SearchOperationType.FindNextIncremental) {
        // Show a statusbar message
        bool hasFindText = !String.IsNullOrEmpty(e.ResultSet.Options.FindText);
        bool notFound = (hasFindText) && (e.ResultSet.Results.Count == 0);
        string notFoundMessage = (notFound ? " (not found)" : String.Empty);
        messagePanel.Content = "Incremental Search: " + e.ResultSet.Options.FindText + notFoundMessage;
    }
}
​Private Sub OnSyntaxEditorViewIsIncrementalSearchActiveChanged(ByVal sender As Object, ByVal e As TextViewEventArgs)
    Dim editorView As IEditorView = TryCast(e.View, IEditorView)
    If (editorView IsNot Nothing) AndAlso ((Not editorView.IsIncrementalSearchActive)) Then
        ' Incremental search is now deactivated
        messagePanel.Content = "Ready"
    End If
End Sub

Private Sub OnSyntaxEditorViewSearch(ByVal sender As Object, ByVal e As EditorViewSearchEventArgs)
    ' If an incremental search was performed...
    If e.ResultSet.OperationType = SearchOperationType.FindNextIncremental Then
        ' Show a statusbar message
        Dim hasFindText As Boolean = Not String.IsNullOrEmpty(e.ResultSet.Options.FindText)
        Dim notFound As Boolean = (hasFindText) AndAlso (e.ResultSet.Results.Count = 0)
        Dim notFoundMessage As String = (If(notFound, " (not found)", String.Empty))
        messagePanel.Content = "Incremental Search: " & e.ResultSet.Options.FindText & notFoundMessage
    End If
End Sub

Note Note
Incremental search also automatically sets a custom mouse cursor while it is active, as long as the cursor has been registered according to the instructions in the Custom Cursors topic.

Trimming Unmatched Find Text

The SyntaxEditor.CanIncrementalSearchTrimUnmatchedFindText, which defaults to true, determines whether characters typed by the end user while incremental search is active will be appended to the find text in scenarios where the previous find text didn't match anything.

For instance, say incremental search mode is active and the end user types "int". This finds a match. Then the user types "e" but no match is found. At this point, if CanIncrementalSearchTrimUnmatchedFindText is true and another character like "g" is typed, it will be ignored and not appended to the find text. If the property is false instead, the "g" would be appended to the find text.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Search Result Highlighting

SyntaxEditor Searching (Find/Replace) Features
Search Result Highlighting

When performing searches, many modern editors actively display matching results as the user types the find text. SyntaxEditor supports the live highlighting of search results.

There are two common usage scenarios for search result highlighting: incremental searches and search panes.

This topic contains these sections:

  • Incremental Search Highlights
  • Search Pane Highlights
  • Requirements

Incremental Search Highlights

The Incremental Search features built into SyntaxEditor allow for an end user to quickly search for a string that they type. When the SyntaxEditor.IsIncrementalSearchResultHighlightingEnabled property is set to true (the default), highlights will appear throughout the document showing all matches for the find text.

This allows the end user to immediately visualize where all matches occur instead of having to navigate through the incremental search matches one-by-one.

Search Pane Highlights

If your app has a search pane, it may wish to highlight search results live as the user types in the search pane's "find what" textbox, and prior to the user pressing the "Find" button.

This can be achieved by setting an ISearchOptions instance to the IEditorView.HighlightedResultSearchOptions property. Every time that property is set, a worker task kicks off that does a find all operation in the document and then when complete, updates the search result highlights.

The property must be updated every time the user types a character in the "find what" textbox. That tells the view to search again. Set the property to a null value when the search pane closes, so that all highlights will be removed.

This code shows how highlights could be displayed over any text in the document with the words "highlight this text":

C#
VB
Copy
​EditorSearchOptions options = new EditorSearchOptions;
options.FindText = "highlight this text";
editor.ActiveView.HighlightedResultSearchOptions = options;
​Dim options As EditorSearchOptions = New EditorSearchOptions
options.FindText = "highlight this text"
editor.ActiveView.HighlightedResultSearchOptions = options

Note Note
Make sure that the ISearchOptions object passed in implements an Equals method override that examines each property in the options, since this is used for internal comparisons. The predefined EditorSearchOptions class does so.

Requirements
This code is required to be called once per application instance since it registers the classification types and related styles for the highlights. If it is not called, then the highlights might not display.
C#
VB
Copy
​new DisplayItemClassificationTypeProvider().RegisterAll();
​CType(New DisplayItemClassificationTypeProvider(), DisplayItemClassificationTypeProvider).RegisterAll()
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EditorSearchView Control

SyntaxEditor Searching (Find/Replace) Features
EditorSearchView Control

The EditorSearchView control is a standalone control that can be used within an application tool window to provide an user interface with Visual Studio-like search capabilities for a SyntaxEditor.

This topic contains these sections:

  • The EditorSearchView User Interface
  • Syncing Options
  • Attaching to a SyntaxEditor Instance
  • Handling Results

The EditorSearchView User Interface

The EditorSearchView control is designed to mimic the find/replace dialog found in Visual Studio. Since it is a regular WPF control, it can be included in any container.

The EditorSearchView control in Quick Replace mode

Search Modes

The control offers two search modes: Quick Find and Quick Replace. There is a built-in toolbar at the top of the control that allows the end user to toggle between modes.

Programmatically, the mode can be set via the Mode property, which take an EditorSearchMode enumeration value of Find or Replace.

The ModeChanged event fires when the Mode property is changed. This allows you to alter a parent tool window title, for example, when the mode changes.

ToolBar Visibility

The modes toolbar is displayed by default. However the IsModeToolBarVisible property can be set to false to hide it.

This is useful if you only wish to allow the end user to perform find opertions and not replace operations.

Find All Button Visibility

The Find All button is not displayed by default. The IsFindAllButtonVisible property can be set to true to show it.

This button should only be made visible if the find results will be displayed to the user from within a SyntaxEditor.ViewSearch event handler. A common way to do this is to display the results within a Find Results tool window.

Search Pattern Providers

The search type drop-down in the options panel allows the end user to select which search pattern provider to use. It is populated via a ISearchPatternProviderFactory, which is a factory interface that can create a collection of ISearchPatternProvider objects.

Any factory instance can be set to the SearchPatternProviderFactory property to change which pattern providers are available. By default, the DefaultSearchPatternProviderFactory is used.

If you create your own search pattern provider and would like to make it available for use within the EditorSearchView control, a custom ISearchPatternProviderFactory would be needed.

Focusing the Find-What TextBox

The FocusFindWhatTextBox method can be called to "select all" in the find-what TextBox and focus it.

Syncing Options

The EditorSearchView.SearchOptions property accepts an IEditorSearchOptions instance. These options are what are used to populate the user interface of the control.

When the end user alters the "find what" text for instance, the control auto-updates the attached options. The options can be used with any search operation.

Note Note
The EditorSearchOptions class provides an implementation of the IEditorSearchOptions interface.

Attaching to a SyntaxEditor Instance

The EditorSearchView control must be attached to a SyntaxEditor control so that it knows which control to search.

This is done by setting a SyntaxEditor control instance to the EditorSearchView.SyntaxEditor property.

Handling Results

The SyntaxEditor.ViewSearch event fires whenever a search is made using EditorSearchView. The event arguments pass along the search options and the result set. That information can then be presented to the user in a Find Results tool window for example.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor IntelliPrompt Features
Overview

SyntaxEditor includes some extremely powerful IntelliPrompt features that help enhance end user productivity. These features range from popup lists with text completion to popup tips that provide more information about what the end user it editing.

This topic contains these sections:

  • Sessions
  • Quick Info
  • Completion List
  • Parameter Info
  • Code Snippets
  • Content Providers
  • Image Source Providers
  • Navigable Symbol Selector

Sessions

An IntelliPrompt session is essentially a controller for a certain type of IntelliPrompt UI. Each type of IntelliPrompt UI (completion list, quick info, etc.) has a related session. The IntelliPrompt UI and functionality can be made activate by "opening" the related session.

See the Sessions topic for more information.

Quick Info

IntelliPrompt quick info displays helpful popup hints about what is under the mouse or next to the caret. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

See the Quick Info topic for more information.

Completion List

The IntelliPrompt completion list allows you create popups for displaying a list of options used to complete what the end user is typing. This is most used when editing programming languages. Features include ctrl+space support, description tips, multiple matching algorithms, matched text highlights, filters, and more.

See the Completion List topic for more information.

Parameter Info

IntelliPrompt parameter info displays helpful popup hints about an invocation that is being typed, and its parameters. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

See the Parameter Info topic for more information.

Code Snippets

IntelliPrompt code snippets provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

See the Code Snippets topic for more information.

Content Providers

Content providers are classes that provide content on demand to IntelliPrompt sessions that display popups. An example of their usage is providing content for quick info and completion item description tip popups.

See the Content Providers topic for more information.

Image Source Providers

Image source providers are classes that provide ImageSource objects on demand to IntelliPrompt sessions. An example of their usage is providing image sources for completion list items.

See the Image Source Providers topic for more information.

Navigable Symbol Selector

The NavigableSymbolSelector control displays two side-by-side drop-downs similar to the type/member drop-downs above the code editor in Visual Studio. One drop-down shows all available root symbols (generally types), and the other shows all available member symbols within the currently selected root symbol.

As the caret in a bound SyntaxEditor instance is moved, the selections in the NavigableSymbolSelector update to indicate the enclosing symbols (types/members). The end user can also select a different symbol from the drop-downs to navigate directly to the related symbol declaration.

See the Navigable Symbol Selector topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Sessions

SyntaxEditor IntelliPrompt Features
Sessions

An IntelliPrompt session is essentially a controller for a certain type of IntelliPrompt UI. Each type of IntelliPrompt UI (completion list, quick info, etc.) has a related session. The IntelliPrompt UI and functionality can be made activate by "opening" the related session.

This topic contains these sections:

  • Built-In Sessions
  • Provider Language Services for Built-In Sessions
  • Session Types
  • Opening and Closing Sessions
  • Session Information
  • Managing Sessions at Run-Time
  • Requesting Built-In IntelliPrompt Session Types

Built-In Sessions

IntelliPrompt functionality is active only while related sessions are open. For instance, a completion list is displayed only while its session is open.

SyntaxEditor includes several built-in IntelliPrompt sessions, however you can create your own as well.

These sessions are currently included:

  • Completion list
  • Quick info
  • Parameter info
  • Code snippets (selection / template)

Provider Language Services for Built-In Sessions

There are several provider interfaces that can be registered as language services. These providers make it very easy to respond to certain editor events and respond with the appropriate IntelliPrompt sessions.

These providers are currently included:

  • Completion provider
  • Quick info provider
  • Parameter info provider
  • Code snippet provider

Session Types

Each IntelliPrompt session must be associated with a specific session type. A session type is represented by the IIntelliPromptSessionType interface.

This interface requires that each type specify a unique string-based Key that identifies it. It also has an AreMultipleSessionsAllowed property that returns whether more than one session of that type are permitted at a time. If that property is false and a second session of the same types is added to the manager (see below), the first session will be removed.

The IntelliPromptSessionType class implements IIntelliPromptSessionType and can be used if you need to create your own session type.

Note Note
The IntelliPromptSessionTypes class has a number of static properties that return the most common IIntelliPromptSessionType instances such as session types for Quick Info, Completion List, etc.

Opening and Closing Sessions

When a session is "open", it is active within the user interface. The IIntelliPromptSession.IsOpen property indicates if a session is currently open.

A session can be opened by calling the Open method. This method accepts two parameters: the IEditorView in which the session should be opened and the TextRange in the view that is affected by the session. The text range is most often the selection range or the text range of the word surrounding the caret.

When a session opens, its Opened event fires.

Note Note
Some session implementations may add additional Open method overloads that should be used for that session implementation instead of the basic Open method.

A session can be closed by calling the Close method. This method accepts a Boolean parameter that indicates whether the session was cancelled or not.

When a session opens, its Closed event fires. The event arguments of this event specify whether the session was cancelled.

Session Information

Each IIntelliPromptSession contains these members that provide some useful information about the session:

Member | Description
SessionType Property | Gets the IIntelliPromptSessionType that identifies the type of session.
SnapshotRange Property | Gets the TextSnapshotRange containing the original TextRange in the ITextSnapshot that triggered the session. This member should only be used while the session is open.
View Property | Gets the IEditorView in which the session is opened. This member should only be used while the session is open.

Managing Sessions at Run-Time

The SyntaxEditor class has a IntelliPrompt property that is of type IIntelliPromptManager and provides access to all of the open sessions within the SyntaxEditor.

The Sessions collection lists all the open sessions and can be enumerated.

The CloseAllSessions method closes all open sessions, while the CloseSessions member only closes sessions of a particular IIntelliPromptSessionType.

Requesting Built-In IntelliPrompt Session Types

Sometimes you may wish to programmatically request that a certain type of IntelliPrompt session be opened, but you want the current set of IntelliPrompt providers (generally designated from language services) to decide if an IntelliPrompt session should open and what should be in it. An example scenario is if your language checks to see when the . key is pressed via an event sink service. When that event occurs, it raises a request to see if an IntelliPrompt completion session should open.

The IEditorView.IntelliPrompt object has methods for requesting built-in session types:

Member | Description
RequestAutoComplete Method | Performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
RequestCompletionSession Method | Displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
RequestInsertSnippetSession Method | Displays IntelliPrompt 'expansion' code snippet selection at the current offset.
RequestParameterInfoSession Method | Displays IntelliPrompt parameter info based on the current context.
RequestQuickInfoSession Method | Displays IntelliPrompt quick info based on the current context.
RequestSurroundWithSession Method | Displays IntelliPrompt 'surrounds with' code snippet selection at the current offset.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Quick Info

SyntaxEditor IntelliPrompt Features
Quick Info

IntelliPrompt quick info displays helpful popup hints about what is under the mouse or next to the caret. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

This topic contains these sections:

  • Creating and Opening a Session
  • Using Rich Formatting for Content
  • Maximum Width
  • Control Key Down Opacity
  • Automatic Quick Info for a Language (Initiated by Mouse Hovers, etc.)
  • Programmatically Requesting Quick Info
  • Built-In Quick Info Providers

Creating and Opening a Session

Creating and opening a quick info session is very easy. There are only a few simple steps to follow.

Creating a Session

The first step is to create a QuickInfoSession:

C#
VB
Copy
​QuickInfoSession session = new QuickInfoSession();
​Dim session As QuickInfoSession = New QuickInfoSession()

Setting the Content to Display

Next, the content that will be displayed must be specified. Since a ContentProvider is used behind the scenes, this could be any object. However it is recommended that you use a WPF UIElement or the output from one of the Content Providers.

This code uses the output from a PlainTextContentProvider as the content to display since it provides a word wrapping TextBlock containing a string:

C#
VB
Copy
​session.Content = new PlainTextContentProvider("Text here").GetContent();
​session.Content = New PlainTextContentProvider("Text here").GetContent()

Open the Session

The final step is to open the session:

C#
VB
Copy
​session.Open(editor.ActiveView, new TextRange(editor.Caret.Offset));
​session.Open(editor.ActiveView, New TextRange(editor.Caret.Offset))

The IQuickInfoSession interface defines an Open method overload that can display the popup against a particular target and location.

For most cases, once the session is opened, the built-in functionality handles all the rest for you, such as when to dismiss the popup.

Using Rich Formatting for Content

As mentioned above, the built-in content providers are a great way to easily populate quick info content. The HtmlContentProvider in particular is nice since it uses a mini-HTML markup to style the text content.

It is highly recommended to make use of the HtmlContentProvider and all of its features that are described in detail in the Content Providers topic.

Maximum Width

The IQuickInfoSession.MaxWidth property can be set to specify a maximum width for the popup.

Control Key Down Opacity

The quick info popup animates to be semi-transparent when the Ctrl key is held down, thereby allowing the end user to see the text behind it. The IQuickInfoSession.ControlKeyDownOpacity property specifies the opacity when the popup is semi-transparent.

Set this property to 1.0 to prevent the list from being semi-transparent.

Automatic Quick Info for a Language (Initiated by Mouse Hovers, etc.)

Syntax languages are fully capable of listening for mouse hovers and opening a quick info session in response to hovers over various tokens, or even any other part of the editor.

The IntelliPrompt Quick Info Provider topic describes a special language service that can be implemented to respond to mouse hovers and show a quick info popup.

Programmatically Requesting Quick Info

Sometimes it is desirable to programmatically request that quick info be displayed if the editor caret is in a location at which the language is capable of displaying quick info.

The IEditorView.IntelliPrompt.RequestQuickInfoSession method can be called to request quick info display, if the current language allows it.

Built-In Quick Info Providers

There are built in Quick Info providers for collapsed node text (used with outlining) and squiggle tags.

When using the code outlining features, sometimes the end user will collapse outlining nodes. By default, nothing happens when the mouse is hovered over a collapsed outlining node adornment (normally a box with "..." in it). The built-in IQuickInfoProvider implementation called CollapsedRegionQuickInfoProvider watches for mouse hovers over collapsed regions and will automatically show a quick info tip with the contained content on mouse hovers.

When using the parsing framework and the ParseErrorTagger (or other custom tagger that uses SquiggleTag tags), there will be squiggle adornments in the document window. By default, nothing happens when the mouse is hovered over these adornments. However, there is a built-in IQuickInfoProvider implementation called SquiggleTagQuickInfoProvider that watches for mouse hovers over squiggle adorned regions and will automatically show a quick info tip with the parse error description on mouse hovers.

For additional information on these built-in Quick Info providers, visit the IntelliPrompt Quick Info Provider topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Completion List

SyntaxEditor IntelliPrompt Features
Completion List

The IntelliPrompt completion list allows you create popups for displaying a list of options used to complete what the end user is typing. This is most used when editing programming languages. Features include ctrl+space support, description tips, multiple matching algorithms, matched text highlights, filters, and more.

As the end user types in the editor, the selected item in the completion list is updated to reflect the item that most closely matches what has been typed. The end user can press Tab or Enter to insert the complete text associated with the item. This immensely helps increase the productivity of end users while typing.

This topic contains these sections:

  • Run-Time Functionality
  • Creating and Opening a Session
  • Opening a Session in Response to a Typed Character ('.', '<', etc.)
  • Having a Language Open a Session in Response to a Typed Character or Ctrl+Space
  • Completion List Items (Images, Text, etc.)
  • Sorting Items
  • Text Insertion
  • Commit and Cancel
  • Auto-Commit Without Showing a Popup (Complete Word)
  • Description Tips
  • Getting the Selection
  • Allowed and Commit Characters
  • Built-In Matching Algorithms
  • Custom Matching Algorithms
  • Case Sensitivity
  • Match Target Text
  • Requiring an Exact Match
  • Filters
  • Filtering via Buttons/Tabs
  • Filtering Unmatched Items (Auto-Shrink)
  • Custom Actions for an Item Selection (Opening a Dialog, etc.)
  • Control Key Down Opacity

Run-Time Functionality

The completion list bases itself on a text range that is passed in when it is opened. While open a list of items is displayed. Arrow keys and the mouse can be used to scroll through the list. As the end user types, the selected item in the list is changed to best fit the typed text based on various matching algorithms.

Optional filters can be toggled by the end user via buttons and tabs to narrow down the list of displayed items.

The pressing and holding of the Ctrl key animates the list to be semi-transparent so that the end user can see the text under the list.

When the Tab key is pressed, the completion list is closed and the selected item's text is auto-inserted into the document. The Esc key can be used to cancel the completion list and close it without inserting any text.

Creating and Opening a Session

Creating and opening a completion list session is very easy. There are only a few simple steps to follow.

Creating a Session

The first step is to create a CompletionSession:

C#
VB
Copy
​CompletionSession session = new CompletionSession();
​Dim session As CompletionSession = New CompletionSession()

Configure Options

Next, configure any options that should be set on the session such as whether to allow complete word functionality, set up filters, etc.:

C#
VB
Copy
​session.CanCommitWithoutPopup = true;  // Allow complete word
​session.CanCommitWithoutPopup = True  ' Allow complete word

Add Items

The next step is to populate the list with all the items that should be included. Items (described in more detail below) must implement ICompletionItem. The CompletionItem class implements this interface and makes it easy to add items.

This code adds a single item for a Boolean native type:

C#
VB
Copy
​session.Items.Add(new CompletionItem("bool",
    new CommonImageSourceProvider(CommonImage.StructurePublic),
    new CustomContentProvider(typeof(bool))));
​session.Items.Add(New CompletionItem("Boolean", _
    New CommonImageSourceProvider(CommonImage.StructurePublic), _
    New CustomContentProvider(GetType(Boolean))))

Open the Session

The final step is to open the session:

C#
VB
Copy
​session.Open(editor.ActiveView);
​session.Open(editor.ActiveView)

The ICompletionSession interface defines an Open method overload that just takes the IEditorView in which to display. This overload automatically determines the text range with which to initialize the completion list for you. Therefore if the caret is at the end of a partial word when the completion list is opened, the partial word's text will be used to initialize the selection in the completion list.

For most cases, once the session is opened, the built-in functionality handles all the rest for you, including auto-complete of selected items when appropriate.

Opening a Session in Response to a Typed Character ('.', '<', etc.)

Completion lists are often opened in response to a typed character by the end user. For instance, in C# or VB, pressing the . (dot) character generally opens a completion list for the object represented by the text before the dot. In HTML a < character displays a completion list for available tags. Some languages also automatically show a completion list when a letter is typed that starts a new word.

Watching Typed Characters

The SyntaxEditor.DocumentTextChanged event is the best place to watch for specific characters being typed. Its event args, EditorSnapshotChangedEventArgs, has a special helper property called TypedText that is normally a null value but is filled in only when the text change is TextChangeTypes.Typing, and there is a single insert operation in the change.

If your app allows two or more SyntaxEditor controls to operate on the same document, then all of the samples below should be wrapped with a check to ensure that the view in which the text change occurred is the same editor's view in which the completion session will be requested:

C#
VB
Copy
​if (e.TextChange.Source == editor.ActiveView) {
    ...
}
​If (e.TextChange.Source Is editor.ActiveView) Then
    ...
End If

Sample: Showing an HTML Tag List

In this scenario, assume we have an HTML language loaded and wish to show a completion list in response to < characters being typed. Here is sample code for a DocumentTextChanged event handler to do this:

C#
VB
Copy
​switch (e.TypedText) {
    case "<":
        // Open completion list session for HTML tags here
        break;
}
​Select Case e.TypedText
    Case "<"
        ' Open completion list session for HTML tags here
End Select

Sample: Showing a C# Object Member List

In this scenario, assume we have a C# language loaded and wish to show a completion list in response to . characters being typed after the keyword this. Here is sample code for a DocumentTextChanged event handler to do this:

C#
VB
Copy
​switch (e.TypedText) {
    case ".": {
        // Use a snapshot reader to iterate backwards through the active view's current text
        ITextSnapshotReader reader = editor.ActiveView.GetReader();
        reader.ReadCharacterReverseThrough('.');
        IToken token = reader.ReadTokenReverse();

        // In production code, a token ID comparison would be better than this string comparison
        if ((token != null) && (reader.TokenText == "this")) {
            // A dot was typed after a "this" keyword so open the completion list session here
        }
        break;
    }
}
​Select Case e.TypedText
    Case "."
        ' Use a snapshot reader to iterate backwards through the active view's current text
        Dim reader As ITextSnapshotReader = editor.ActiveView.GetReader()
        reader.ReadCharacterReverseThrough("."c)
        Dim token As IToken = reader.ReadTokenReverse()

        ' In production code, a token ID comparison would be better than this string comparison
        If ((token IsNot Nothing) AndAlso (reader.TokenText = "this")) Then
            ' A dot was typed after a "this" keyword so open the completion list session here
        End If
End Select

Note that in this sample, we used an ITextSnapshotReader to scan backwards past the dot and to the token before it. We then did a text compare with the token to see if its text was this. If your language has token IDs available, it's better to do a token ID comparison here instead of a string comparison. Also while scanning back, you may wish to skip over whitespace tokens. If all that criteria was met, the completion list session was opened.

Sample: Showing a Completion List Automatically When a New Word Is Started

In this scenario, we wish to show a completion list whenever a letter is typed by the end user that is starting a new word. This prevents the end user from having to do a Ctrl+Space to initiate a completion session.

Here is sample code for a DocumentTextChanged event handler to do this:

C#
VB
Copy
​// If the text that was typed is a letter character that is starting a word...
if (e.IsTypedWordStart) {
    // If no completion session is currently open, show a completion list
    if (!editor.IntelliPrompt.Sessions.Contains(IntelliPromptSessionTypes.Completion)) {
        // Open the completion list session here
    }
}
​' If the text that was typed is a letter character that is starting a word...
If e.IsTypedWordStart Then
    ' If no completion session is currently open, show a completion list
    If Not editor.IntelliPrompt.Sessions.Contains(IntelliPromptSessionTypes.Completion) Then
        ' Open the completion list session here
    End If
End If

Having a Language Open a Session in Response to a Typed Character or Ctrl+Space

Syntax languages are fully capable of listening to typed characters like above and opening a completion list session in response. To do this, they can use the event sinks mechanism that allows them to be notified of text changes.

The IntelliPrompt Completion Provider topic describes a special language service that can be implemented to respond to Ctrl+Space and show a completion list.

When a completion provider service is registered for a language, the IEditorView.IntelliPrompt.RequestAutoComplete and RequestCompletionSession methods can be called to request auto-complete or completion list display respectively. In that case if the completion provider determines that completion can occur at the current editor caret position, IntelliPrompt action will be taken.

As an example, if a syntax language has an event sink registered that watches for the . key to be typed, it may wish to request that a completion session be opened if appropriate. In that case the event sink handler should call RequestCompletionSession and if a completion provider is available to handle the request, a completion list will display.

Completion List Items (Images, Text, etc.)

All completion list items implement the ICompletionItem interface, which is realized by the CompletionItem class.

The interface has several members on it:

Member | Description
AutoCompletePostText Property | Gets or sets the text that is inserted into the document after the caret when auto-complete is executed.
AutoCompletePreText Property | Gets or sets the text that is inserted into the document before the caret when auto-complete is executed.
DescriptionProvider Property

Gets an IContentProvider that can provide content for a popup displaying a verbose description of the item.

Note Note
See the Content Providers topic for details on the IContentProvider interface and the available built-in implementations.

ImageSourceProvider Property

Gets an IImageSourceProvider that can provide an ImageSource for display within a list.

Note Note
See the Image Source Providers topic for details on the IImageSourceProvider interface and the available built-in implementations.

Tag Property | Gets or sets the object that contains user-defined data about the object.
Text Property | Gets the text for the item that is displayed within a list.

Sorting Items

The items in the completion session should always be sorted so that proper selection matching occurs at run-time as the end user types. You can choose to pre-sort the items yourself before you add them to the Items collection.

Alternatively, you can call the SortItems method right before opening the session to ensure they are properly sorted. This allows you to add items in any order while building the list. A SortItems overload allows a custom comparer to be specified in the event that custom sort logic is required.

Text Insertion

Normally the text displayed in the completion list for an item is the same text that is inserted. That is what happens by default.

However SyntaxEditor has the ability to insert alternate text both before and after the caret. Several variations are shown in the following sections.

Displayed text inserted before the caret

When using the CompletionItem constructor that just takes the text (no auto-complete pre or post text), the text you pass in is displayed in the list and is also what is inserted on auto-complete. So in essence, that constructor fills in AutoCompletePreText with the text value as well.

Alternate text inserted before the caret

Many times the displayed Text is not what should be inserted.

A br tag before and after it is inserted from the completion list

In the screenshot above, a br should be displayed but <br/> should be inserted before the caret. To accomplish this, Text is set to br, AutoCompletePreText is set to <br/>, and AutoCompletePostText is set to a null reference.

Alternate text inserted to surround the caret

Sometimes auto-completes need to surround the caret with text.

An HTML comment before and after it is inserted from the completion list

In the screenshot above, a !-- should be displayed but <!-- --> should surround the caret on auto-complete. To accomplish this, Text is set to !--, AutoCompletePreText is set to <!--, and AutoCompletePostText is set to -->.

Commit and Cancel

When the completion list is committed, auto-complete is performed on whichever item is selected. If the completion list is cancelled, auto-complete is not performed and no text is changed in the document.

The completion list can be programmatically committed by calling the Commit method. Likewise, it can be cancelled by calling the Cancel method.

If committed, two events fire: Committing, then Committed. The first event allows you to set the Cancel property of the event args to cancel auto-complete.

The Tab key commits the selected item at run-time and is consumed. The Enter key commits and is normally consumed as well unless the IsEnterKeyHandledOnCommit property is set to false.

Auto-Commit Without Showing a Popup (Complete Word)

There generally are two modes in which to display a completion list. Ctrl+Space keypresses typically activate a "complete word" mode where if the text range with which the list was initialized is capable of fully selecting an item in the list, the list item is auto-completed and the list is never displayed. If no exact match is made, the list displays and operates like normal. The default mode is to have the list display regardless of whether it can initially match an item.

To enable "complete word" functionality, set the ICompletionSession.CanCommitWithoutPopup property to true.

Description Tips

Description tips, which are essentially quick info tips, are displayed when an item is selected within the completion list. They are optional but can provide some extensive information about the selected item to the end user.

Description tip content is specified on each item via the ICompletionItem.DescriptionProvider property. Since this is a property, the info is pulled-on demand, thereby using less memory in most cases.

Note Note
See the Content Providers topic for details on the IContentProvider interface and the available built-in implementations.

The ICompletionSession.DescriptionTipMaxWidth property can be set to specify a maximum width for the description tip.

The ICompletionSession.DescriptionTipShowDelay accepts a TimeSpan value that indicates the delay length between when a completion item is selected and when its related description tip is displayed. The default value is 400ms.

Getting the Selection

The ICompletionSession.Selection property indicates the current selection of the list. Its value is of type CompletionSelection, which indicates the ICompletionItem that is selected and its selection state (full or partial). If there is no selection then that property returns a null reference.

When the selection changes, the SelectionChanged event fires.

Allowed and Commit Characters

By default, only letters, digits, and underscores are allowed characters. If you type any other character while a completion list is open, it will either auto-complete or cancel depending on whether you have a full selection in the list and if the character is a commit character.

Since sometimes other characters such as ! need to be allowed characters, the completion list session provides the ICompletionSession.AllowedCharacters collection. By adding characters to this collection, they will be allowed to be typed without the session being cancelled.

All letter and digit characters are automatically allowed by the completion popup and therefore do not need to added to this collection.

The ICompletionSession.CommitCharacters property defaults to contain all characters. This means that if a typed character is not an allowed character, it will auto-complete the session if there is a full selection in the list. If you wish to limit the characters that can auto-complete the session, set a new character collection to this property with the appropriate characters.

Built-In Matching Algorithms

Matching algorithms are what are used to select an item in the completion list as you type in the editor. SyntaxEditor includes numerous built-in matching algorithms, each used in a priority order.

Default Matching Algorithm

Normal completion lists match with an algorithm in which the typed characters are compared against the start of each item. This default algorithm has the highest priority when attempting to match items.

If no match is made, the next active algorithm is used.

Acronym Matching Algorithm

Next in priority is an optional algorithm in which the first and every uppercase letter is examined for a match. For words that contain underscores, the first and every character following an underscore are examined for a match instead.

This algorithm is only active if the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.UseAcronyms flag specified.

If no match is made, the next active algorithm is used.

Shorthand Matching Algorithm

Next in priority is another optional algorithm in which the supplied text provides a wildcard sort of pattern. A match is made if all the characters appear somewhere in the item text. Shorthand provides the most flexibility since it allows substring matches anywhere in the items.

This algorithm is only active if the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.UseShorthand flag specified.

If no match is made, the next active algorithm is used.

Fallback Partial Matching Algorithm

Finally if no match as been made yet, a partial match can be made at the item that starts with text closest to the typed text.

Custom Matching Algorithms

SyntaxEditor includes the built-in matching algorithms described above. However it's very easy to add custom matching algorithms as well. Matching algorithms as implementations of the ICompletionItemMatcher interface.

The RegexCompletionItemMatcherBase class is the best class to inherit when making a custom matching algorithm. When you inherit that class, all you need to do is override the GetRegex method to return a standard .NET Regex (from the System.Text.RegularExpressions namespace) and override the Key property to return a string-based key that identifies the matcher. The Regex is used to both identify matches and can even perform matched text highlights (see previous section).

A Regex Sample

In this sample implementation of the GetRegex method we'll return a Regex that matches text that appears after any . or _ character:

C#
VB
Copy
​return new Regex(String.Format("[\\._]({0})", Regex.Escape(text)),
    RegexOptions.IgnoreCase | RegexOptions.Singleline);
​Return New Regex(String.Format("[\._]({0})", Regex.Escape(text)), _
    RegexOptions.IgnoreCase | RegexOptions.Singleline)

Note Note
The actual matched text portion(s) in the regular expression pattern should always be surrounded by parenthesis. In the example above, {0} is surrounded by parenthesis. This allows the matched text highlights to work automatically based on your regular expression pattern.

Adding the Custom Item Matcher to the Session

All the item matchers for a session are listed in the ICompletionSession.ItemMatchers collection. By default this collection contains all the built-in matchers although some (like Acroynm) may not be active if its match option is not specified (see above).

To enable a custom item matcher to be used in a session, it must be added to the ItemMatchers collection too. Item matchers are executed in order until one succeeds. The default "starts-with" item matcher should nearly always be used first so it's best to insert your custom item matcher at index 1.

This code installs a CustomCompletionItemMatcher after the "starts-with" matcher:

C#
VB
Copy
​session.ItemMatchers.Insert(1, new CustomCompletionItemMatcher());
​session.ItemMatchers.Insert(1, new CustomCompletionItemMatcher())

Case Sensitivity

By default, matching is done such that matches that actually match the case of the typed text are returned first. If none are found, an insensitive match is returned instead.

This default can be disabled so that insensitive matches are always used by ensuring the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.IsCaseInsensitive flag specified.

Match Target Text

Completion list items each have display text and text that is actually inserted into the document. By default the text that will be inserted into the document is matched against. However you can change it to match against the display text if you prefer.

Note Note
In most cases, the display text and text to insert actually are the same thing.

Matching can be made to target the display text by ensuring the ICompletionSession.MatchOptions flags property has the CompletionMatchOptions.TargetsDisplayText flag specified.

Requiring an Exact Match

Normally completion list items are fully selected as long as the matched item's text starts with the typed text. However there are scenarios where you may wish for matching to be less aggressive, and to only make full selections if the typed text exactly matches the item's text.

In these scenarios, the ICompletionSession.MatchOptions flags property should have the CompletionMatchOptions.RequiresExact flag specified.

Filters

Completion list filtering is a feature that allows the presented items in the list to be filtered down. This is most useful when you potentially have hundreds of items in a completion list and want the ability for the end user to narrow down the items that are displayed.

SyntaxEditor for WPF contains a feature-rich model for supporting filtering, and even makes it easy to add custom buttons and tabs to support filter toggling by the end user.

Filters are designed with the expectation such that each language developer using the extensible filter object model can make customized filters for each language and in some cases, context within a language. For instance, a completion list for namespaces should have different filters than a type member completion list.

Completion filters are implementations of the ICompletionFilter interface. This interface has a string-based Key that identifies the filter, a boolean IsActive property that indicates if the filter is currently active, and a Filter method that does the actual filtering work.

The CompletionFilter class is a nice implementation of the ICompletionFilter that provides extended functionality for automatically supporting buttons and tabs as described in the next section.

When using the CompletionFilter class, its constructor takes the string-based key that identifies it, and a CompletionFilterPredicate. This predicate is simply a delegate that returns whether the specified item should be excluded from the available completion items. The delegate is passed the ICompletionSession and the ICompletionItem to examine. It returns true if the item should be excluded from the available completion items; otherwise, false.

A filter is added to a completion session via the ICompletionSession.Filters property. This property is a collection of the available filters, not all of which may be active. If a filter is inactive (even if it is in the collection), it will not be used.

Filtering via Buttons/Tabs

The CompletionFilter class, when used for filtering, provides some extensive functionality to adding buttons and tabs to the completion list user interface.

The CompletionFilter.DisplayMode is the property that governs how the filter is displayed in UI. It is an enumeration of type CompletionFilterDisplayMode, which has None, ToggleButton, Tab, and AllTab options. When the value is None, the default, no user interface is created for the filter.

Buttons and Button Groups

One option for filter UI is the creation of a toggle button. If the toggle button is checked, the filter is not applied (because filters exclude items). When the toggle button is unchecked by the end user, the filter becomes active and is applied.

A completion list where several filter buttons have been auto-generated for the UI

In the screenshots above, the left completion list shows the default unfiltered view. In the right completion list, the inherited filter has been activated, thereby excluding all inherited members from the list.

A filter can be displayed in the UI as a toggle butten when its DisplayMode is set to ToggleButton.

In this display mode, the Content property gets or sets the content to display in the generated user interface control for the filter, which is generally an Image or String.

The ToolTip property sets the content to display in a tooltip for the button.

Groups of buttons can be displayed by placing filters that should be grouped visually in sequence and having their GroupName property value match. In the screenshots above, the first three filters have the same group name and the last filter has a different group name. Thus a separator line is drawn between them.

Tabs

Tabs are another sort of UI that can be generated for filters. With tabs, the related filter is applied only when the tab is selected. There is a special “All” tab that can be added that deactivates any filters that are applied by tabs.

A completion list that shows two filter tabs

A filter can be displayed in the UI as a tab when its DisplayMode is set to Tab or AllTab. When set to Tab, the filter is only applied when it is selected. AllTab is special because it will unapply any other Tab filters. Only one AllTab filter can be added at a time.

The Content property gets or sets the content to display in the generated user interface control for the filter, which is generally a String.

Combining buttons and tabs

Button and tab filters can be used at the same time. There is no problem with implementing things this way.

Filtering Unmatched Items (Auto-Shrink)

There is a handy option that can automatically filter out and hide items from the completion list that don't match the text that has been typed by the end user. This feature is seen when editing Visual Basic files in Visual Studio and using completion lists there. It is a helpful feature since it allows the end user to focus on items that match the text they've typed and it continuously updates the visible items in the completion list as text is modified.

Filtering unmatched items is disabled by default, meaning all unmatched items remain visible. To enable this feature, set the ICompletionSession.CanFilterUnmatchedItems property is set to true.

Custom Actions for an Item Selection (Opening a Dialog, etc.)

Sometimes it is useful to have "special" completion list items that when selected, don't auto-complete and insert text, but rather perform some other custom action. An example is opening a dialog in response to selecting an item.

The way to accomplish this is to first place some sort of way to identify the special item in its ICompletionItem.Tag property.

Then attach to the ICompletionSession.Committing event. In that handler examine the selected item, if any, and look to see if it is a special item. If it is, set e.Cancel to true. This will prevent auto-complete from occurring. Finally, show your dialog.

Control Key Down Opacity

The completion list animates to be semi-transparent when the Ctrl key is held down, thereby allowing the end user to see the text behind it. The ICompletionSession.ControlKeyDownOpacity property specifies the opacity when the list is semi-transparent.

Set this property to 1.0 to prevent the list from being semi-transparent.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parameter Info

SyntaxEditor IntelliPrompt Features
Parameter Info

IntelliPrompt parameter info displays helpful popup hints about an invocation that is being typed, and its parameters. Tip content can include any WPF control and it's easy to generate richly-formatted content using an HTML-like syntax.

This topic contains these sections:

  • Creating and Opening a Session
  • Managing Parameter Info Sessions
  • Using Rich Formatting for Content
  • Bolding the Current Parameter
  • Maximum Width
  • Arrow Key Selection
  • Programmatically Requesting Parameter Info

Creating and Opening a Session

Creating and opening a parameter info session is very easy. There are only a few simple steps to follow.

Creating a Session

The first step is to create a ParameterInfoSession:

C#
VB
Copy
​ParameterInfoSession session = new ParameterInfoSession();
​Dim session As ParameterInfoSession = New ParameterInfoSession()

Setting the Content to Display

Next, the content that will be displayed must be specified. Parameter info can display one or more overloads of an invocation. When multiple overloads are specified, built-in UI is added to show up and down arrows for switching the selected overload.

Each item in the parameter info is an ISignatureItem instance, that are implemented by the SignatureItem class. This interface consists of a Content Providers and an optional data object.

This code adds a couple method overloads using a PlainTextContentProvider for the displayed content of each item:

C#
VB
Copy
​session.Items.Add(new SignatureItem(new PlainTextContentProvider("void Foo()"));
session.Items.Add(new SignatureItem(new PlainTextContentProvider("void Foo(int a)"));
​session.Items.Add(new SignatureItem(New PlainTextContentProvider("void Foo()"))
session.Items.Add(new SignatureItem(New PlainTextContentProvider("void Foo(int a)"))

Open the Session

The final step is to open the session:

C#
VB
Copy
​session.Open(editor.ActiveView, new TextRange(editor.Caret.Offset));
​session.Open(editor.ActiveView, New TextRange(editor.Caret.Offset))

The above code is simplistic and will display a parameter info session however there is more code required for managing a session and knowing when to switch to a new session (in cases where the caret moves into a nested invocation), supporting the bolding of the current parameter, etc. These concepts are described further below.

Managing Parameter Info Sessions

While it's easy to create and display a parameter info session, there is some more advanced work needed to actually manage the session so that you know when it should be altered (such as bolding a new parameter) or closed. The management of the session is performed by its calling parameter info provider.

See the Parameter Info Provider topic for details on how to manage a parameter info session.

Using Rich Formatting for Content

As mentioned above, the built-in content providers are a great way to easily populate quick info content. The HtmlContentProvider in particular is nice since it uses a mini-HTML markup to style the text content.

It is highly recommended to make use of the HtmlContentProvider and all of its features that are described in detail in the Content Providers topic.

Bolding the Current Parameter

When implementing a content provider for an ISignatureItem, an IParameterizedContentProvider interface can be implemented on the IContentProvider to add support for the designation of the current parameter.

The IParameterizedContentProvider interface defines a ParameterIndex property that is a nullable integer, indicating the current parameter index, if known. The content provider implementation can examine that property and provide some method of focusing the end user's attention on it, such as bolding the parameter name if a HtmlContentProvider is used behind the scenes.

The parameter index can be set by code described in the Managing Parameter Info Sessions topic above.

Maximum Width

The IParameterInfoSession.MaxWidth property can be set to specify a maximum width for the popup.

Arrow Key Selection

When two or more signatures are displayed in a parameter info tip, arrow buttons appear in the tip's UI that allow for toggling between which one is selected. The IParameterInfoSession.IsArrowKeySelectionEnabled property determines whether the up and down arrow keys also can toggle between the selected signature.

Programmatically Requesting Parameter Info

Sometimes it is desirable to programmatically request that parameter info be displayed if the editor caret is in a location at which the language is capable of displaying parameter info.

The IEditorView.IntelliPrompt.RequestParameterInfoSession method can be called to request quick info display, if the current language allows it.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Snippets

SyntaxEditor IntelliPrompt Features
Code Snippets

IntelliPrompt code snippets provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

Multiple fields can be declared with the same ID. In this scenario, only one of the fields with that ID in a template session will be editable. When that field's value is changed by the end user, the dependent fields (the other non-editable fields with the same ID) will have their value updated as well. This improves end user typing efficiency.

The XML code snippet file format used is the same as Visual Studio's. This allows for any Visual Studio compatible code snippet to be used in SyntaxEditor.

This topic contains these sections:

  • Opening Selection Sessions
  • Opening Template Sessions
  • Template Sessions at Run-Time
  • Template Session Event Sink
  • Code Snippets
  • Code Snippet Serialization
  • Code Snippet Folders and Metadata
  • Code Snippet Providers
  • Customizing Code Snippet Providers
  • Code Snippets in Completion Lists

Opening Selection Sessions

Functionality is included that displays a helpful popup where the end user can type the title of an accessible code snippet to activate it. A completion list that shows the code snippets and child folders at the current folder level is also displayed below the popup and fully supports partial matches and Tab-based selection. The code snippets used to populate the selection session come from the ICodeSnippetProvider language service.

When a folder is selected in the completion list, the scope of the selection popup changes to that folder and the user can access the code snippets and child folders within it. Pressing Backspace or clicking the parent folder's link, backs up to the parent folder level.

Programmatic Session Creation

A code snippet selection session can be opened via two different method calls. Both require that a ICodeSnippetProvider language service is registered on the language. One displays the code snippets that are designated as 'expansion' types and the other displays those designated as 'surrounds with' types:

C#
VB
Copy
​editor.ActiveView.IntelliPrompt.RequestInsertSnippetSession();  // Show 'expansion' code snippets
// editor.ActiveView.IntelliPrompt.RequestSurroundWithSession();  // Show 'surrounds with' code snippets
​editor.ActiveView.IntelliPrompt.RequestInsertSnippetSession()  ' Show 'expansion' code snippets
' editor.ActiveView.IntelliPrompt.RequestSurroundWithSession()  ' Show 'surrounds with' code snippets

Both of these helper methods wrap a call to the ICodeSnippetProvider.RequestSelectionSession method.

Opening Template Sessions

Code snippets are generally inserted into SyntaxEditor and activated into a template session by one of these methods:

  • Selection made via a selection session.
  • End user types a code snippet's registered shortcut (defined in the source XML file) into SyntaxEditor and presses the Tab key.
  • Programmatic template session creation.

Pressing Tab After a Code Snippet Shortcut

Each code snippet has a shortcut that can be typed into the editor. When the Tab key is pressed after the shortcut, an ICodeSnippetProvider language service will look at the word before the caret to see if it matches any registered code snippets. If a match is found, the shortcut text is removed from the document, and a code snippet template session is opened.

This mechanism depends on a ICodeSnippetProvider service being registered on the current language. Please see the sections below for more information on code snippet providers.

Programmatic Session Creation

Assuming that an ICodeSnippet has been loaded into the snippet variable via some means, a session can be programmatically opened like this:

C#
VB
Copy
​CodeSnippetTemplateSession session = new CodeSnippetTemplateSession();
session.CodeSnippet = snippet;
session.Open(editor.ActiveView);
​Dim session As New CodeSnippetTemplateSession()
session.CodeSnippet = snippet
session.Open(editor.ActiveView)

Template Sessions at Run-Time

When a template session is opened, the code snippet's text is inserted into the document. Some code snippets indicate a location within their text where the current view's selected text should be inserted. In this scenario, the selected text prior to the session being opened is appropriately indented and injected within the code snippet text.

If one or more fields were declared in the code snippet, then fields will display in the editor. Fields are highlighted replacement regions that represent the regions of text that need to be edited to complete the code snippet. While the caret is in a field, the Tab key can be used to navigate to the next field. Likewise, Shift+Tab navigates to the previous field.

Editable fields are drawn with a background behind them. Sometimes a field refers to a declaration that is used in multiple places within the code snippet. In that case, only the first field is designated as editable. When its value changes, the other fields that are dependent upon it automatically update. The dependent fields are drawn with a dotted line around them.

Once all the fields have been updated, pressing Enter while in a field completes the code snippet and closes the session. At this point, if the code snippet designated a target offset for the caret to end up at, the caret will move to that offset.

Template Session Event Sink

Any object that implements the ICodeSnippetTemplateSessionEventSink interface can be registered on a language to handle events related to code snippet template sessions.

These methods on the event sink receive the event notifications:

Member | Description
NotifyDeclarationActivated Method | Notifies when a new declaration in the session's code snippet is activated.
NotifyDeclarationDeactivated Method | Notifies when a declaration in the session's code snippet is deactivated.
NotifyDeclarationTextChanged Method | Notifies when the text value of the active declaration in the session's code snippet is changed.
NotifySessionClosed Method | Notifies when a session is closed.
NotifySessionOpened Method | Notifies when a session is opened.

See the Event Sinks topic for more information on event sinks in general.

Code Snippets

Code snippets are represented by the ICodeSnippet interface.

Here are the important members of the CodeSnippet class, which implements ICodeSnippet:

Member | Description
Author Property | Gets or sets the name of the code snippet author.
CodeDelimiter Property | Gets or sets the character used to describe literals and objects in the code.
CodeKind Property | Gets or sets a CodeSnippetKind indicating the kind of code contained by the snippet.
CodeLanguage Property | Gets or sets the language in which the snippet's code is written.
CodeText Property | Gets or sets the code that is inserted when the code snippet is activated.
Declarations Property | Gets the collection of declarations.
Description Property | Gets or sets descriptive information about the code snippet contents.
HelpUrl Property | Gets or sets a URL that provides more information about the code snippet.
ImportedNamespaces Property | Gets the collection of imported namespaces.
Keywords Property | Gets the collection of keywords that describe the code snippet.
References Property | Gets the collection of assembly references.
Shortcut Property | Gets or sets the shortcut text used to insert the code snippet.
SnippetTypes Property | Gets the types of actions that can be performed by the code snippet.
Tag Property | Gets or sets the object that contains user-defined data about the object.
Title Property | Gets or sets the code snippet title.

Code Snippet Serialization

ICodeSnippet objects can be saved to and loaded from an XML format via the use of a CodeSnippetSerializer. In fact, it's the same XML format that Visual Studio uses to store code snippet data. That means that any code snippets created for Visual Studio can be used directly within SyntaxEditor as well.

Please see the Visual Studio documentation for more information on the XML schema for code snippet files.

Loading a Code Snippet

Code snippets can be loaded from a Stream via the CodeSnippetSerializer.LoadFromStream method.

The return value is an enumerable of ICodeSnippet objects, since each code snippet file can contain more than one code snippet per Microsoft's specifications.

Saving a Code Snippet

Code snippets can be saved to a Stream via the CodeSnippetSerializer.SaveToStream method.

A parameter array of ICodeSnippet objects is used as a parameter, since each code snippet file can contain more than one code snippet per Microsoft's specifications.

Code Snippet Folders and Metadata

The ICodeSnippetFolder interface, implemented by the CodeSnippetFolder class, represents a folder that can reference code snippets. Each folder has a Name property that is usually the value of the real file system folder it represents.

A folder has a Items collection, where each item is an object of type ICodeSnippetMetadata. The ICodeSnippetMetadata interface specifies a subset of the properties found on the ICodeSnippet interface, and is used to store minimal descriptive information about a particular code snippet, such as its title, shortcut, and description. The metadata also has a GetCodeSnippet method that can be called to dynamically load the referenced full code snippet.

Nested folders can be created as well. Each folder has a Folders collection that lists the child folders of the current folder.

A helper FindItemByShortcut method is included that recursively searches an ICodeSnippetFolder hierarchy for a contained code snippet that has a particular shortcut.

Code Snippet Providers

The ICodeSnippetProvider interface, and related CodeSnippetProvider implementation class, is very important since it is the service that should be registered on a language to make code snippet functionality available. It is used to store available code snippet metadata, watch keypresses, and manage the adornments for fields in any template sessions.

Its RootFolder property needs to be set to an ICodeSnippetFolder instance that has loaded code snippet metadata into itself or one of its nested folders. Its IsCaseSensitive property can also be set to false for case-insensitive languages.

This code registers a provider on a language using the folder from the previous section's sample:

C#
VB
Copy
​language.RegisterService(new CodeSnippetProvider() { RootFolder = folder });
​language.RegisterService(New CodeSnippetProvider() With {.RootFolder = folder})
This code is also required to be called once per application instance since it registers the classification types and related styles for any fields that will be visible during a template session. If it is not called, then field backgrounds and borders might not display.
C#
VB
Copy
​new DisplayItemClassificationTypeProvider().RegisterAll();
​CType(New DisplayItemClassificationTypeProvider(), DisplayItemClassificationTypeProvider).RegisterAll()

Once the provider has been registered on a language, it will watch for Tab key presses. If a shortcut for a known code snippet appears before the caret, then that code snippet will be activated into a new template session.

Customizing Code Snippet Providers

Some languages may wish to only allow shortcuts to trigger code snippet template sessions when in certain portions of code. For instance, a language generally doesn't want a code snippet shortcut to trigger when the shortcut is in a comment or a string literal.

This can be achieved by creating a class that inherits CodeSnippetProvider. Then override the GetPossibleShortcutSnapshotRange method and in that code, first call the base method. If a snapshot range is returned that is not zero-length, get a snapshot reader and see what sort of token is at the snapshot range. If it is a comment or literal, return TextSnapshotRange.Deleted. Otherwise, return the result from the base method call.

Code Snippets in Completion Lists

Languages that wish to include code snippet support may wish to list code snippet metadata items in the Ctrl+Space completion lists. The .NET Languages Add-on languages include this feature.

When a code snippet is selected in the completion list, its shortcut is inserted into the editor. Then if the user presses the Tab key next, and assuming a code snippet provider is registered on the language (see above), the related code snippet is inserted.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Content Providers

SyntaxEditor IntelliPrompt Features
Content Providers

Content providers are classes that provide content on demand to IntelliPrompt sessions that display popups. An example of their usage is providing content for quick info and completion item description tip popups.

This topic contains these sections:

  • The IContentProvider Interface
  • The DirectContentProvider Class
  • The PlainTextContentProvider Class
  • The HtmlContentProvider Class
  • Custom Content Providers

The IContentProvider Interface

All content providers implement the IContentProvider interface. There are several built-in provider implementations described below.

The DirectContentProvider Class

The DirectContentProvider is the simplest way to provide content. Its constructor takes an object instance and that is what is returned by the provider.

The downside to using this provider is that the content must be loaded prior to creation of the provider. If a large number of providers are needed (such as for a completion list), then it is better to use another provider or build a custom one.

This code creates a DirectContentProvider using the TextBlock control that is already loaded in a textBlock variable:

C#
VB
Copy
​DirectContentProvider provider = new DirectContentProvider(textBlock);
​Dim provider As DirectContentProvider = New DirectContentProvider(textBlock)

The PlainTextContentProvider Class

The PlainTextContentProvider is very similar to the DirectContentProvider except that it takes a String value instead of an object.

Behind the scenes a TextBlock with word wrap capabilities is created that renders the String value and the TextBlock is returned as the content.

The HtmlContentProvider Class

The HtmlContentProvider is a really nice way to spruce up IntelliPrompt popups because it supports a mini-HTML markup format, allowing multiple fonts, colors, etc. to be used.

As with PlainTextContentProvider, a word wrap capable TextBlock is created behind the scenes but here, the String passed into the provider is parsed for markup instead of being treated as plain text.

Markup Tags

The markup text is specified using lowercase HTML-like formatting tags. All tags must be well-formed must be in XML-compliant syntax.

These tags are supported:

Tag | Description
b | Renders the enclosed text in a bold face.
br | Adds a line break.
em | Renders the enclosed text using emphasis. The default style renders in italics.
i | Renders the enclosed text in an italic style.
img | Renders an image. The src specifies the image and the the align tag controls alignment. See the special notes for this tag below.
span | Changes the formatting of the enclosed text. This tag should be used with the style attribute to specify formatting such as color, font, etc.
strong | Renders the enclosed text using a strong face. The default style renders in bold face.
u | Renders the enclosed text with an underline.

The style Attribute

The style attribute can be applied to any tag listed above. It accepts a subset of CSS (cascading style sheets) properites as input.

The supported properties are:

Property | Description
background-color | The background color of the text. This value can be specified using HTML format (e.g. #RRGGBB) or by referencing standard web colors by name (e.g. Red).
color | The foreground color of the text. This value can be specified using HTML format (e.g. #RRGGBB) or by referencing standard web colors by name (e.g. Red).
font-family | The font family of the text. This can be any valid font family name (e.g. Tahoma), even in quotes (e.g. "Courier New"). It can also be one of the generic family names (Monospace, Serif, or Sans-Serif).
font-size | The font size of the text. This is currently always specified in points (e.g. 10pt).
font-weight | The font weight, or boldness, of the text. These values map to a normal font: normal, lighter, 100, 200, 300, 400, 500. These values map to a bold font: bold, bolder, 600, 700, 800, 900.
font-style | The font style of the text. The values italic and oblique map to an italic font. The value normal map to a normal font.
text-decoration | The decoration for the text. The value none uses no decoration. The value underline draws a line under the text. The value line-through draws a line through the middle of the text (strike-through).

Adding Horizontal Whitespace

You can use the &nbsp; character to add a non-breaking space to the text. Use multiple &nbsp; characters in a row to create a horizontal spacer.

Working With the 'img' (Image) Tag

Since there is no way to pass binary image data in the XML markup itself, the HtmlContentProvider.GetImage method is called when an img tag is encountered. The src attribute value is passed in and the method returns an Image. This method must be overridden in a custom class that inherits HtmlContentProvider, otherwise a null reference is always returned.

The align attribute accepts values of baseline and absbottom. The default is baseline.

Syntax Example

This is an example of markup text that can be used with HtmlContentProvider:

XML
Copy
​<span style="font-size: 16pt; font-weight: bold;">Actipro SyntaxEditor</span>
<br/><i>The ultimate syntax-highlighting code editor control.</i>

Escaping Markup Text

HtmlContentProvider provides an XML escape method for ensuring that "plain text" can be used in it without having to worry about possible malformed XML errors. Situations where this is useful are generally those where the text comes from an external data source that could have & or other XML control characters in the text.

The HtmlContentProvider.Escape static method will escape all XML control characters such as <, >, &, etc. and will also convert line feed characters to <br /> tags.

This is an example of escaping the markup text that without an escape, would have raised a bad XML exception:

C#
VB
Copy
​string text = "Line 1 &" + Environment.NewLine + "Line 2";
text = HtmlContentProvider.Escape(text);
​Dim text As String = "Line 1 &" & Environment.NewLine & "Line 2"
text = HtmlContentProvider.Escape(text)

Custom Content Providers

It's easy to write your own custom content provider if none of the implementations above work for your scenario. Simply create a class that implements IContentProvider.

The GetContent method that must be implemented as part of that interface returns an object. You could have it be pulled from a storage mechanism or could dynamically generate it.

Since the method is called on-demand, the content doesn't need to be loaded up front. When creating a custom provider, the provider generally stores some object that contains data that should be described by the generated content. Then in the GetContent method, the data object is examined in order to generate the appropriate content.

It is common to use the HtmlContentProvider to aid in dynamically generating content in custom content providers. In this example of a GetContent implementation, there is a Type field in the custom content provider class called targetType. A HtmlContentProvider is used to help provide nicely-formatted markup content describing the type.

C#
VB
Copy
​string htmlSnippet = String.Format("Type: <b>{0}</b>",
    HtmlContentProvider.Escape(targetType.FullName));
return new HtmlContentProvider(htmlSnippet).GetContent();
​Dim htmlSnippet As String = String.Format("Type: <b>{0}</b>", _
    HtmlContentProvider.Escape(targetType.FullName))
return New HtmlContentProvider(htmlSnippet).GetContent()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Image Source Providers

SyntaxEditor IntelliPrompt Features
Image Source Providers

Image source providers are classes that provide ImageSource objects on demand to IntelliPrompt sessions. An example of their usage is providing image sources for completion list items.

This topic contains these sections:

  • The IImageSourceProvider Interface
  • The DirectImageSourceProvider Class
  • The CommonImageSourceProvider Class
  • Custom Image Source Providers

The IImageSourceProvider Interface

All image source providers implement the IImageSourceProvider interface. There are a couple built-in provider implementations described below.

The DirectImageSourceProvider Class

The DirectImageSourceProvider is the simplest way to provide image sources. Its constructor takes an ImageSource instance and that is what is returned by the provider.

The downside to using this provider is that the image source must be loaded prior to creation of the provider. If a large number of providers are needed (such as for a completion list), then it is better to use another provider or build a custom one.

This code creates a DirectImageSourceProvider using the ImageSource that is already loaded in a source variable:

C#
VB
Copy
​DirectImageSourceProvider provider = new DirectImageSourceProvider(source);
​Dim provider As DirectImageSourceProvider = New DirectImageSourceProvider(source)

The CommonImageSourceProvider Class

The CommonImageSourceProvider is a handy image source provider that comes pre-packaged with some of the most common 16x16 icons used in features like completion lists.

Its constructor takes a single parameter of type CommonImage, which is an enumeration that specifies one of many built-in images. This image source provider works on-demand and only pulls the image from assembly resources as needed.

This code creates a CommonImageSourceProvider that returns a 16x16 public method icon:

C#
VB
Copy
​CommonImageSourceProvider provider = new CommonImageSourceProvider(CommonImage.MethodPublic);
​Dim provider As CommonImageSourceProvider = New CommonImageSourceProvider(CommonImage.MethodPublic)

Image Set Selection

There are several image sets that are included with SyntaxEditor:

  • Classic - Best for non-Metro themes.
  • MetroLight (default) - Best for most Metro themes.
  • MetroDark - Best for the MetroDark theme.

To change the image set that is currently in effect, set the CommonImageSourceProvider.DefaultImageSet property to a CommonImageSet value. Note that some UI, such as for the NavigableSymbolSelector, may need to be reloaded following a change to this property.

Custom Image Source Providers

It's easy to write your own custom image source provider if none of the implementations above work for your scenario. Simply create a class that implements IImageSourceProvider.

The GetImageSource method that must be implemented as part of that interface returns an ImageSource object. You could have it be pulled from a resource, database, or any other storage mechanism.

Since the method is called on-demand, the image source doesn't need to be loaded up front.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Navigable Symbol Selector

SyntaxEditor IntelliPrompt Features
Navigable Symbol Selector

The NavigableSymbolSelector control displays two side-by-side drop-downs similar to the type/member drop-downs above the code editor in Visual Studio. One drop-down shows all available root symbols (generally types), and the other shows all available member symbols within the currently selected root symbol.

As the caret in a bound SyntaxEditor instance is moved, the selections in the NavigableSymbolSelector update to indicate the enclosing symbols (types/members). The end user can also select a different symbol from the drop-downs to navigate directly to the related symbol declaration.

This topic contains these sections:

  • Attaching to a SyntaxEditor Instance
  • Populating the NavigableSymbolSelector
  • Symbol Selection Logic
  • Rool Symbol-Only Display
  • Member Symbol-Only Display

Attaching to a SyntaxEditor Instance

NavigableSymbolSelector controls must be bound to a single SyntaxEditor control instance. The selector will watch for various events on the bound editor and will respond accordingly.

For instance, when the caret moves, the selector will find the appropriate symbols to select in its drop-downs based on which ones most closely enclose or are near the caret. Likewise, when the end user picks another symbol from one of the drop-downs, the bound editor's caret will move to its declaration.

NavigableSymbolSelector controls generally appear directly above the bound SyntaxEditor control like in this example within a Grid:

XAML
Copy
​<Grid>
    <Grid.RowDefinitions>
        <RowDefinition Height="Auto" />
        <RowDefinition Height="*" />
    </Grid.RowDefinitions>
    <editor:NavigableSymbolSelector SyntaxEditor="{Binding ElementName=editor}" />
    <editor:SyntaxEditor x:Name="editor" Grid.Row="1" />
</Grid>

Populating the NavigableSymbolSelector

While it's extremely simple to get a NavigableSymbolSelector working in an app per binding it to an editor (as above), the current syntax language needs to support telling the selector what symbols are available in the document.

The Navigable Symbol Provider topic describes the special language service that must be implemented so that a selector knows how to populate its drop-downs with symbols.

Symbol Selection Logic

As mentioned above, the selector watches editor events and updates the symbols that are selected in the drop-downs according to the current editor caret location. If the caret is within a symbol, the closest enclosing symbol is selected in the drop-down. If the caret is not within a symbol, but there is one after the caret, it is selected in the drop-down. Or if there are no symbols after the caret, the previous symbol is selected.

The selector has an additional feature where the selected symbol grays out when the symbol doesn't enclose the caret. This provides a nice visual indicator for when the caret is actually within or just near the selected symbol.

Rool Symbol-Only Display

Some languages may not support members and may only need to have a single drop-down to display root symbols, instead of an additional drop-down to display member symbols.

For these scenarios, set the NavigableSymbolSelector.AreMemberSymbolsSupported property to false.

Member Symbol-Only Display

Some languages may wish to only show members and have a single drop-down to display member symbols, instead of an additional drop-down to display root symbols.

For these scenarios, set the NavigableSymbolSelector.AreRootSymbolsSupported property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Theme and Highlighting Style Features
Overview

Highlighting styles govern how SyntaxEditor text is rendered and can be used to create entire themes for various languages.

This topic contains these sections:

  • Highlighting Styles
  • Highlighting Style Registries

Highlighting Styles

Highlighting styles store information about how text should be rendered within a SyntaxEditor, including fore/background, font styles, and more.

See the Highlighting Styles topic for more information.

Highlighting Style Registries

Highlighting style registries provide a mapping from classification types to highlighting styles. They tell SyntaxEditor how the various ranges of classified text should appear within the text area.

See the Highlighting Style Registries topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Highlighting Styles

SyntaxEditor Theme and Highlighting Style Features
Highlighting Styles

Highlighting styles store information about how text should be rendered within a SyntaxEditor, including fore/background, font styles, and more.

Styles have the capability of altering these formatting options:

  • Foreground
  • Background
  • Border
  • Bold
  • Italic
  • Font family
  • Font size

This topic contains these sections:

  • Basic Concepts
  • Relationship Between Classifications and Styles
  • Formatting Options
  • Editable Properties

Basic Concepts

Interface and Implementation

Highlighting styles are instances of the IHighlightingStyle interface. The HighlightingStyle class implements this interface and provides for the easiest way to create highlighting styles.

This code creates a simple highlighting style with a foreground color of maroon:

C#
VB
Copy
​IHighlightingStyle style = new HighlightingStyle(Brushes.Maroon);
​Dim style As IHighlightingStyle = New HighlightingStyle(Brushes.Maroon)

Default Values and Inheritance

All the properties in HighlightingStyle are initially set to "default" values. These default values are set up to not change formatting in any way.

In the code example above however, we have assigned a Maroon foreground Brush to the style. This means that the style defined above will only change the foreground of text that it is applied against. It will not alter the bold weight, font size, etc.

There are scenarios in SyntaxEditor where two or more styles may be merged together to create resolved formatting options. For instance, if the special DisplayItemClassificationTypeProvider.PlainText classification type is used (see the Highlighting Style Registries topic for more information), then the style associated with that classification type is the default style for the text area. Classifications made by an ITagger<IClassificationTag> may apply their own styles to specific ranges of text. SyntaxEditor resolves the two styles together to get resolved formatting options for the text in the editor.

During the resolution process, any non-default property settings on the higher-priority style will be applied and will override any property settings on the lower-priority style. If the higher-priority style doesn't set a property value but the lower-priority style does, the lower-priority style's value will be used, thereby establishing inheritance.

Relationship Between Classifications and Styles

Taggers are objects that provide data (in the form of tags) over ranges of text. One such tag is the IClassificationTag, which is a tag that indicates an IClassificationType. Thus these tags can provide logical classifications of text ranges. All this functionality is built into the text/parsing framework.

Highlighting styles on the other hand purely deal with the user interface and how text is formatted.

There is a strong relationship that ties together classificationa and highlighting styles, and that tie is made via highlighting style registries. These registries provide a mapping from classification types to highlighting styles.

As a SyntaxEditor prepares to draw text, it examines the logical classifications that have been on the text. Then it uses highlighting style registries to determine which highlighting styles apply. After that, it resolves styles (see above) and returns a list of resolved styles to the code that renders the text.

Formatting Options

Highlighting styles have a lot of options for changing the formatting of text.

Foreground and Background

The Foreground and Background properties are used to designate Brush objects that should be used to render the foreground and background of text.

It is recommended to generally use SolidColorBrush instances that have no transparency.

A null reference value is considered the "default" value and will not alter formatting.

Background Spans Virtual Whitespace

The BackgroundSpansVirtualSpace property specifies whether the background should span virtual space when the styled range includes a line terminator. When set to true, the background will be rendered to the right edge of the view, thereby covering virtual space.

It is a nullable Boolean type, where a null reference value is considered the "default" value and will not alter formatting.

Bold and Italic

The Bold and Italic properties are used to designate whether the text should be bold and/or italic.

It is a nullable Boolean type, where a null reference value is considered the "default" value and will not alter formatting.

Border

Optional borders can be applied to text via highlighting styles. The BorderStyle property can be used to indicate the style (solid, dotted, etc.) to use for the border.

The BorderBrush property specifies the brush to use for rendering the border. If it is not specified, then the foreground is used.

Borders render with square corners by default but the BorderCornerStyle property can be set to change to rounded corners instead.

Font Family

The FontFamilyName property can be used to specify the font family name in which to render text.

A null reference value is considered the "default" value and will not alter formatting.

Font Size

The FontSize property can be used to specify the font size (in points) in which to render text.

A value of 0.0 is considered the "default" value and will not alter formatting.

Editable Properties

SyntaxEditor highlighting styles are designed to be editable by the end user via an options dialog. Therefore, styles include several options for designating which of the most common properties may be edited by the end user.

The IsForegroundEditable, IsBackgroundEditable, IsBoldEditable, IsBorderEditable, and IsItalicEditable properties all indicate which of the related properties are editable. By default, all properties except for the border one are editable.

There are a number of cases however where certain properties don't make sense to be editable. As an example, the style for the special DisplayItemClassificationTypeProvider.CollapsibleRegion shouldn't allow bold or italic to be editable. That style only needs its foreground and background to be editable.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Highlighting Style Registries

SyntaxEditor Theme and Highlighting Style Features
Highlighting Style Registries

Highlighting style registries provide a mapping from classification types to highlighting styles. They tell SyntaxEditor how the various ranges of classified text should appear within the text area.

This topic contains these sections:

  • Basic Concepts
  • The Ambient Registry
  • Registering and Unregistering Entries
  • Enumerating Classification Types and Highlighting Styles
  • Classification Type Sort Order
  • Special Classification Types (Plain Text, Line Numbers, Indicator Margin, etc.)
  • Highlighting Styles Options Dialog
  • Defining and Using an Alternate Default Registry
  • Classification Tags Providing an Alternate Registry

Basic Concepts

A classification type (which could represent an identifier, comment, etc.) is a logical category that can be assigned to ranges of text via a tagger for the IClassificationTag type. Classifications are made within the text/parsing framework and therefore are not tied to the user interface.

A highlighting style registry takes these classification types and maps them to highlighting styles. Highlighting styles define formatting options that should be applied to text. Therefore via the use of highlighting style registries allows the editor to determine how classified text should be rendered.

Highlighting style registries are implementations of the IHighlightingStyleRegistry interface. The HighlightingStyleRegistry class implements this interface.

The Ambient Registry

The ambient registry is a static registry that is always available and is generally what is used by the editor. It is available via the AmbientHighlightingStyleRegistry class.

This code shows how to get an instance of the ambient registry:

C#
VB
Copy
​IHighlightingStyleRegistry registry = AmbientHighlightingStyleRegistry.Instance;
​Dim registry As IHighlightingStyleRegistry = AmbientHighlightingStyleRegistry.Instance

Registering and Unregistering Entries

A registry entry consists of an IClassificationType and IHighlightingStyle pair.

Registrations can be made by calling the IHighlightingStyleRegistry.Register method. Registrations can be removed by calling the IHighlightingStyleRegistry.Unregister method.

This code registers a highlighting style in the style variable for the common Comment classification type in the ambient registry:

C#
VB
Copy
​AmbientHighlightingStyleRegistry.Instance.Register(ClassificationTypes.Comment, style);
​AmbientHighlightingStyleRegistry.Instance.Register(ClassificationTypes.Comment, style)

An overload for the Register method indicates whether any existing entry for the IClassificationType should be overwritten. The overload in the sample code above will not override an existing entry if one is found.

Enumerating Classification Types and Highlighting Styles

The IHighlightingStyleRegistry.ClassificationTypes property returns the collection of IClassificationType objects that are currently registered.

The IHighlightingStyleRegistry.HighlightingStyles property returns the collection of IHighlightingStyle objects that are currently registered.

Classification Type Sort Order

The IHighlightingStyleRegistry.ClassificationTypes collection is sorted in a special order. This allows you to be able to bind the collection to a list in an application options dialog.

The base sorting is performed on the IClassificationType.Description property. If a IClassificationType implements IOrderable, it is sorted before any IClassificationType that doesn't implement IOrderable. The IOrderable implementation can be used to indicate the keys of other IClassificationType after which the classification type should be sorted.

Special Classification Types (Plain Text, Line Numbers, Indicator Margin, etc.)

There are several classification types that have special meaning for SyntaxEditor, all of which are available as properties on the DisplayItemClassificationTypeProvider class. These classification types are special cased to allow for end user customization of things such as the default text format, line number margin, indicator margin, visible whitespace, etc.

The classification types on DisplayItemClassificationTypeProvider are not used unless they are registered.

Registration into the ambient highlighting style registry can be performed with this code:

C#
VB
Copy
​new DisplayItemClassificationTypeProvider().RegisterAll();
​New DisplayItemClassificationTypeProvider().RegisterAll()

These are the special IClassificationType properties on DisplayItemClassificationTypeProvider:

Member | Description
BreakpointDisabled Property | Gets the IClassificationType to use for a disabled breakpoint. Only the border is editable in the default IHighlightingStyle that is registered for this classification type.
BreakpointEnabled Property | Gets the IClassificationType to use for an enabled breakpoint. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
CodeSnippetDependentField Property | Gets the IClassificationType to use for a code snippet dependent field. Only the border is editable in the default IHighlightingStyle that is registered for this classification type.
CodeSnippetField Property | Gets the IClassificationType to use for a code snippet field. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
CollapsedText Property | Gets the IClassificationType to use for collapsed text. Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
CollapsibleRegion Property | Gets the IClassificationType to use for collapsible regions. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
CurrentLine Property | Gets the IClassificationType to use for the current line highlight. Only the background and border are editable in the default IHighlightingStyle that is registered for this classification type.
CurrentStatement Property | Gets the IClassificationType to use for a current statement. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
DelimiterMatching Property | Gets the IClassificationType to use for the delimiter matching highlight. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
FindMatchHighlight Property | Gets the IClassificationType to use for a find match highlight. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
IndentationGuides Property | Gets the IClassificationType to use for indentation guides. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
IndicatorMargin Property | Gets the IClassificationType to use for the indicator margin. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
LineNumbers Property | Gets the IClassificationType to use for the line number margin. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
OutliningMarginSquare Property | Gets the IClassificationType to use for outlining margin squares. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
OutliningMarginVerticalRule Property | Gets the IClassificationType to use for outlining margin vertical rules. Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
PlainText Property | Gets the IClassificationType to use for default text in the text area. Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
RevertedChangesMark Property | Gets the IClassificationType to use for reverted changes marks. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
SavedChangesMark Property | Gets the IClassificationType to use for saved changes marks. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
UnsavedChangesMark Property | Gets the IClassificationType to use for unsaved changes marks. Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
VisibleWhitespace Property | Gets the IClassificationType to use for visible whitespace. Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.

Highlighting Styles Options Dialog

Please see the samples for a QuickStart on how to create a highlighting styles options dialog that allows the end user to customize all aspects of the editor's display.

Defining and Using an Alternate Default Registry

In most cases, the AmbientHighlightingStyleRegistry is the only registry you need to use. However in some scenarios, you may wish to support more than one highlighting style registry, for instance one for text editors and one for console windows. Each registry can have different style settings for its known classification types. In these scenarios, you can use the ambient registry for text editors and can create a custom HighlightingStyleRegistry to use for console windows. In fact, any number of custom registries can be created as needed.

The SyntaxEditor.HighlightingStyleRegistry property is used to indicate which IHighlightingStyleRegistry to use when mapping classification types to highlighting styles. If the property is left unassigned, then the AmbientHighlightingStyleRegistry is used.

Back to the example scenario, for any SyntaxEditor that will be used as a console window, you would assign the custom IHighlightingStyleRegistry for console windows to that editor instance.

This code creates a custom registry and assigns it to a console window SyntaxEditor:

C#
VB
Copy
​SyntaxEditor console = new SyntaxEditor();
IHighlightingStyleRegistry consoleWindowRegistry = new HighlightingStyleRegistry();
consoleWindowRegistry.Description = "Console Window";
console.DefaultHighlightingStyleRegistry = consoleWindowRegistry;
​Dim console As New SyntaxEditor()
Dim consoleWindowRegistry As IHighlightingStyleRegistry = New HighlightingStyleRegistry()
consoleWindowRegistry.Description = "Console Window"
console.DefaultHighlightingStyleRegistry = consoleWindowRegistry

You must populate the entries into the custom registry.

Note that the SyntaxLanguageDefinitionSerializer class has a HighlightingStyleRegistry property where the registry it should use can be specified. A TextExporterFactory (used when exporting text) constructor overload also accepts a custom IHighlightingStyleRegistry. In all cases, if no custom registry is specified, the AmbientHighlightingStyleRegistry is used.

Another alternate registry can be designated for use in printer output only. See the Print Options topic for more information.

Classification Tags Providing an Alternate Registry

Although most of the time, the classification types used by classification taggers are registered into the IHighlightingStyleRegistry instance used by the editor, there are cases where you may wish to not add certain classification types into that registry.

One possible scenario is if you wish to have some classification types that should not be included in the list of classification types that are configuarable by the end user. Another is if your classification tagger just keeps its types private.

In these scenarios, it's possible to have an IClassificationTag specify an alternate IHighlightingStyleRegistry to use. This is done by having the IClassificationTag implement the IHighlightingStyleRegistryProvider interface. The classification tag returns the custom registry via the HighlightingStyleRegistry property. Classification taggers can use the StyleRegistryClassificationTag class for this purpose. When the normal highlighting style registry is fine for use, use the smaller ClassificationTag class instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Adornment Features
Overview

SyntaxEditor has a fully-extensible adornment layer framework that allows for any sort of custom content to be inserted within a view's text area. This can include everything from alternating row highlights, to animated text decorations, or anything else you can imagine.

All the built-in text area rendering is done using adornment layers, such as the text itself, selection, caret, and more.

This topic contains these sections:

  • Adornment Layers
  • Syntax Highlighting
  • Squiggle Lines
  • Intra-Text Adornments

Adornment Layers

Adornment layers are panels that are stacked within a view's text area. Each layer can be ordered to appear before or after other specified layers. Layers can contain any sort of adornment element.

See the Adornment Layers topic for more information.

Syntax Highlighting

The document text rendered within a view is drawn using two adornment layers, one for the text itself and normal decorations (underlines, etc.), and one for any text backgrounds. Classification taggers can be applied to a document (via language services) to override the default syntax highlighting provided by a language's lexer. This adds support for features like changing the foreground color of certain words, marking search result ranges in a different background color, etc.

See the Syntax Highlighting topic for more information.

Squiggle Lines

There is a built-in adornment layer that can render squiggle lines. Squiggle lines are generally displayed under parse errors or spelling mistakes.

A built-in tagger can also be installed to watch for errors in the parse data returned by a parser, and automatically render squiggle lines based on those ranges.

See the Squiggle Lines topic for more information.

Intra-Text Adornments

SyntaxEditor supports the ability to insert intra-text spacers, or space between text characters, and have adornments render within the space that was created.

This feature can be used to insert any sort of UI element in-line with the text of a view, and is different than normal adornments in that normal adornments don't alter text positioning. This feature allows for inserting in-line images, in-line buttons that can be used to take action on nearby document text, etc.

See the Intra-Text Adornments topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Adornment Layers

SyntaxEditor Adornment Features
Adornment Layers

Adornment layers are panels that are stacked within a view's text area. Each layer can be ordered to appear before or after other specified layers. Layers can contain any sort of adornment element.

This topic contains these sections:

  • Adornment Layers and Definitions
  • Built-In Adornment Layers
  • Working With the Adornments on a Layer
  • Tagging Interaction
  • Adornment Managers
  • Adornment Manager Providers
  • Registering with a Syntax Language

Adornment Layers and Definitions

Adornment layers, represented by the IAdornmentLayer interface, are panels that can contain adornment elements. Typically related adornment elements are grouped into a single adornment layer. For instance, a squiggle lines are in one adornment layer, however selection is rendered in a separate layer.

Adornment Layer Definitions

An adornment layer is retrieved by using an adornment layer definition. This definition, represented by the AdornmentLayerDefinition class, holds the string-based key used to identify the layer, along with information about how the layer should be ordered relative to other layers.

Ordering

Each AdornmentLayerDefinition can be passed an optional set of Ordering objects. Each Ordering object allows you to indicate a string-based target layer key along with whether this layer should appear before or after the target layer.

Therefore, you could easily indicate that a custom layer should appear before the text foreground layer, etc.

Important Note About Duplicate Keys Important Note About Duplicate Keys
Always be sure to use unique keys for each of your adornment layers, unique even from the built-in adornment layer names. If layers don't have unique keys, the item with a duplicate key may not sort correctly.

This code shows how to create an adornment layer definition that renders adornments in front of the text foreground layer:

C#
VB
Copy
​AdornmentLayerDefinition def = new AdornmentLayerDefinition("CustomLayer",
    new Ordering(AdornmentLayerDefinitions.TextForeground, OrderPlacement.Before));
​Dim def As AdornmentLayerDefinition = New AdornmentLayerDefinition("CustomLayer", _
    New Ordering(AdornmentLayerDefinitions.TextForeground, OrderPlacement.Before))

Using a Definition to Retrieve a Layer

The ITextView implementations manage the available adornment layers. This means that you can have custom adornment layers in both editor views and printer views, or even just one of those types.

The ITextView.GetAdornmentLayer method can be called to return an adornment layer. It is passed an AdornmentLayerDefinition instance (see previous sub-section) and uses that to see if an adornment layer with the specified key has already been created. If not, it creates a layer with the key and uses the ordering information to reorder the layers.

This code gets an adornment layer using the definition created above:

C#
VB
Copy
​IAdornmentLayer layer = view.GetAdornmentLayer(def);
​Dim layer As IAdornmentLayer = view.GetAdornmentLayer(def)

Adornment Layer Opacity

The IAdornmentLayer.Opacity property allows you to alter the opacity for adornments displayed within a certain layer.

Built-In Adornment Layers

SyntaxEditor includes a number of built-in adornment layers. Each of these built-in adornment layers has their definitions available via static properties on the AdornmentLayerDefinitions class.

Custom adornments should not be added to the built-in adornment layers. Instead, add your own adornment layer and put custom adornments in there. You can use the AdornmentLayerDefinitions class to help with the keys used when ordering your adornment layer.

The stack of built-in adornments layers

This table shows the built-in adornment layers, listed in order by which the layers are stacked (top to bottom):

Adornment Layer | Description
Caret | Renders the blinking caret.
Text Foreground | Renders the syntax-highlighted document text and built-in decorations such as underlines.
Squiggle | Renders any squiggle lines.
Collapsed Region | Renders any collapsed region indicators.
Selection | Renders the selection.
Highlight | Renders any background highlights, such as when mouse hovering over expanded outlining nodes in the outlining margin.
Guides | Renders any background guide lines, such as indentation guides.
Text Background | Renders the syntax highlighting background for any text highlighting styles that have a background set.

Working With the Adornments on a Layer

Adding Adornments

Adornments, represented by the IAdornment interface, are created by calling the IAdornmentLayer.AddAdornment method. There are two overloads for this method. One takes information for more general adornments and the other has a couple extra parameters that allow the adornment to be tied with a TextSnapshotRange, which is useful for adornments like text decorations.

Both methods have four common parameters:

  • visualElement - The actual UIElement used to visually render the adornment. It is commonly a shape but could be any element type.
  • location - The initial location of the adornment, in text area-relative coordinates. Methods like ITextView.TransformToTextArea can be used to transform coordinates from view-relative to text area-relative.
  • tag - An object that contains user-defined data about the adornment. The tag can optionally later be used to find specific adornments that have been created.
  • removedCallback - The callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.

If the adornment should be tracked with text, it will automatically be removed when the related text range is scrolled out of the view. These parameters apply to this AddAdornment overload:

  • snapshotRange - The TextSnapshotRange that indicates the range of the adornment.
  • trackingModes - A TextRangeTrackingModes indicating the tracking modes to use.

Finding Existing Adornments

The IAdornmentLayer.Adornments property is a read-only collection of all the adornments in the layer.

A number of methods are also available that make it easy to find certain adornments. The FindAdornment method returns the adornment with the specified visual element. The overloaded FindAdornments methods return the adornments that match criteria, including:

  • Intersection with a certain snapshot range
  • An object that is stored in the adornment's Tag property
  • A predicate that allows for custom matching

Removing Adornments

The IAdornmentLayer.RemoveAdornment method removes a specific IAdornment instance from the layer.

The RemoveAdornments method removes an enumerable list of IAdornment instances from the layer. The enumerable is generally constructed using the results of the various "find" methods described above.

All adornments in a layer can be removed by a call to the RemoveAllAdornments method.

Tagging Interaction

The text/parsing framework's tagging mechanism is usually integrated with adornments, especially in scenarios where the adornments are based on document text. In these scenarios, taggers are responsible for logically marking the ranges of text that require adornments, most often with some sort of custom ITag class. Then an adornment manager (see below) monitors tags of that type and adds/removes adornments as appropriate.

Tagging can also be used to drive some of the built in adornment layers such as customized syntax highlighting and squiggle lines.

Adornment Managers

Adornment managers are objects that manage the adornments placed on a certain adornment layer. When the adornments are based on document text, the tagging mechanism is leveraged.

There are two base classes that can be used for adornment managers: AdornmentManagerBase`1 and DecorationAdornmentManagerBase`2.

The AdornmentManagerBase<T> Class

The AdornmentManagerBase`1 class is the lowest-level class that should be used for adornment managers. It automatically retrieves an appropriate adornment layer, auto-closes when the attached view is closed, and supports an "active" state concept.

The type parameter for the class indicates the type of view to support. To support editor views only, use IEditorView. To support printer views only, use IPrinterView. To support both types of views, use ITextView.

The constructor accepts up to three parameters:

  • view - The view to which the manager will be attached.
  • layerDefinition - The AdornmentLayerDefinition that indicates the definition for the adornment layer to use. The layer is available via the AdornmentLayer property.
  • isForLanguage - Optional. When true, indicates that the manager is something installed by a syntax language and that if the view's document or its language are changed, the managers should auto-close itself. Otherwise the manager will not close unless the view is closed or it is closed explicitly via the Close method.

The View property provides access to the view that contains the adornment layer. The AdornmentLayer property specifies the IAdornmentLayer that is used by this manager.

The Close method can be called to detach the manager from the view. Whenever the manager is closed, the OnClosed method is called. Inherited classes can override this method to clean up any event handlers created in the constructor.

The IsActive property is optionally used but provides a handy way to indicate whether the manager's adornments should be displayed or not. When its value changes, the OnIsActiveChanged method is called. Inherited classes can override this method to add/update/remove adornments as appropriate.

Adornment managers typically link up to various document and view events in their constructor and detach from the events when the manager is closed. While open, when the events occur, adornments are added to and removed from the managed adornment layer. A common event that is attached to is the ITextView.TextAreaLayout event. This event's arguments pass the list of view lines that are added/updated/removed/translated in the layout, if any. Thus you can adjust your adornments appropriately using the add/remove methods of the IAdornmentLayer. IAdornment instances also have Location properties that can be set to move them. If you wish to move an adornment by a certain delta amount, it can use the Translate event instead.

The DecorationAdornmentManagerBase<T,U> Class

The DecorationAdornmentManagerBase`2 class inherits AdornmentManagerBase`1 and provides extensive additional functionality for managing adornments that are related to tagged text ranges. Specifically, this base class creates a tag aggregator for the tag type indicated as the second type parameter to the class.

The base class is notified whenever tags are changed or when the text area layout occurs. It automatically determines when to add and remove tags based on what is currently visible in the editor.

Whenever a new adornment needs to be created for a tagged range, the abstract AddAdornment method is called. This method has these parameters:

  • viewLine - The ITextViewLine upon which the adornment will be placed.
  • tagRange - A TagSnapshotRange`1 indicating the tag and snapshot range for which an adornment is needed on this line. Note that the tag range could extend outside of the view line's range if the tag covers more than one view line.
  • bounds - The text bounds in which to render the adornment.

Inheritors of this class should override the AddAdornment method and in there, have it create a visual element (such as a shape) that will be rendered, then call the IAdornmentLayer.AddAdornment method to add the element into the adornment layer and create an IAdornment.

This base class makes it very easy to add adornments to text ranges via the use of a tagger.

Adornment Manager Providers

Adornment manager providers, represented by the IAdornmentManagerProvider interface, are objects that can create/retrieve adornment managers for a particular view. Adornment manager providers are called on-demand when a view is created or the view's document/language are changed.

The IAdornmentManagerProvider interface has a GetAdornmentManager method that returns an adornment manager instance to use for the specified view.

The AdornmentManagerProvider`1 class is an implementation of the IAdornmentManagerProvider interface that makes it easy to return instances of the adornment manager type indicated as a type parameter.

A constructor overload accepts a "singleton" object key that can be used to persist any created adornment manager into the ITextView.Properties dictionary using the key. In this case, if the view's document or the document's language changes, the adornment manager is automatically closed and removed from the properties dictionary. The adornment manager associated with the view can be retrieved via the properties dictionary while it is open.

If no "singleton" object is is passed to the adornment manager provider, a new adornment manager class instance will be created each time the provider used.

Registering with a Syntax Language

As described above, AdornmentManagerProvider`1 objects can be used as language services to provide adornment managers to any text views that request them.

This code shows how to register an adornment manager provider language service that returns AlternatingRowsAdornmentManager objects (defined in a QuickStart to provide alternating row highlights). for views that use the language. Note that we are also passing a "singleton" key so that the adornment manager that is created for any view using the language is persisted in the views's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new AdornmentManagerProvider<AlternatingRowsAdornmentManager>(typeof(AlternatingRowsAdornmentManager)));
​language.RegisterService(New AdornmentManagerProvider(Of AlternatingRowsAdornmentManager)(GetType(AlternatingRowsAdornmentManager)))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Syntax Highlighting

SyntaxEditor Adornment Features
Syntax Highlighting

The document text rendered within a view is drawn using two adornment layers, one for the text itself and normal decorations (underlines, etc.), and one for any text backgrounds. Classification taggers can be applied to a document (via language services) to override the default syntax highlighting provided by a language's lexer. This adds support for features like changing the foreground color of certain words, marking search result ranges in a different background color, etc.

This topic contains these sections:

  • Text Rendering Layers
  • Lexer-Based Syntax Highlighting
  • Overriding Syntax Highlighting

Text Rendering Layers

Syntax highlighting is divided into two adornment layers, a foreground and a background. A reference to the text foreground can be obtained via the AdornmentLayerDefinitions.TextForeground property and a reference to the text background can be obtained via the AdornmentLayerDefinitions.TextBackground property.

The background is separated out so that the selection layer can overlay the text background when the selection extends to text ranges that have a background set.

Note Note
The two text rendering layers cannot be returned via the ITextView.GetAdornmentLayer method. If you wish to add custom adornments around text, you should make your own adornment layer and order it relative to the built-in adornment layers.

Lexer-Based Syntax Highlighting

Syntax languages almost always have a lexer in place that is able to tokenize text. A token tagger can then be used to provide classification tag ranges for the lexer's tokens, where the classification tags indicate a logical IClassificationType for the contained text. The text rendering layers watch the classification tags that are provided by the token tagger.

Each IClassificationType can be paired with a highlighting style, via a highlighting style registry. Once there is a mapping between classification types and highlighting styles, the text rendering layers know how each classified range should be rendered.

Thus with the pieces above in place, lexer-based syntax highlighting is achieved.

Overriding Syntax Highlighting

Sometimes it is desirable to override default lexer-based highlighting. Instances of this could be where certain text ranges should be rendered in a specific foreground, such as when highlighting type names in C# code. Or perhaps changing the background color of certain ranges to indicate breakpoints or find results.

As mentioned above, the text rendering layers already use a tag aggregator to watch for updates to IClassificationTag ranges. When update occur, the text is repainted. Classification taggers (implementations of ITagger<IClassificationTag>) can be ordered. It is very important that classification taggers are set to be ordered before the TaggerKeys.Token tagger, which is the key for the lexer-based syntax highlighting. Otherwise the syntax highlighting derived from the classification tag ranges will appear under the lexer-based syntax highlighting, where it likely would not be seen.

Several QuickStarts show how to implement taggers that alter syntax highlighting.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Squiggle Lines

SyntaxEditor Adornment Features
Squiggle Lines

There is a built-in adornment layer that can render squiggle lines. Squiggle lines are generally displayed under parse errors or spelling mistakes.

A built-in tagger can also be installed to watch for errors in the parse data returned by a parser, and automatically render squiggle lines based on those ranges.

This topic contains these sections:

  • Squiggle Lines Adornment Layer
  • Automated Squiggle Lines for Parse Errors

Squiggle Lines Adornment Layer

The built-in squiggle lines adornment layer uses a tag aggregator for the ISquiggleTag type. When a tagger is applied to a document via a tagger provider language service, the ISquiggleTag ranges that it returns are rendered as squiggle lines in text views.

Squiggle lines showing a syntax error

The ISquiggleTag interface has a ClassificationType property that allows an IClassificationType to be set. When left null, the squiggle line will be rendered in red. If the classification type has a highlighting style mapped to it via the ambient highlighting style registry, the foreground of the style will be used to render the squiggle line.

Automated Squiggle Lines for Parse Errors

If you are using a parser your language, it will return resulting parse data to the ICodeDocument.ParseData property. If the parse data object implements the IParseErrorProvider interface then parse errors can be retrieved from it.

There is a built-in tagger called ParseErrorTagger that can be attached to a document via a document-oriented tagger provider service. See the Tagger Provider topic for details on making tagger provider services.

When this parse error tagger is attached to a document, it will monitor the document's parse data for changes. If the parse data is updated, it will automatically get the list of parse errors from it (assuming the parse data implements IParseErrorProvider) and will return ISquiggleTag tags for each one. This automatically drives the squiggle line display when used in an editor.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Intra-Text Adornments

SyntaxEditor Adornment Features
Intra-Text Adornments

SyntaxEditor supports the ability to insert intra-text spacers, or space between text characters, and have adornments render within the space that was created.

This feature can be used to insert any sort of UI element in-line with the text of a view, and is different than normal adornments in that normal adornments don't alter text positioning. This feature allows for inserting in-line images, in-line buttons that can be used to take action on nearby document text, etc.

A popup button adornment added into an intra-text spacer

There are two things that must be done to create intra-text adornments.

  • First, an intra-text spacer must be created, which tells the text formatting engine to reserve extra space between two characters.
  • Second, adornments must be added within the space that was created so that they are visible to the end user.

This topic contains these sections:

  • Tagging Intra-Text Spacers
  • Getting Data About Intra-Text Spacers
  • Creating an Intra-Text Adornment Manager

Tagging Intra-Text Spacers

Intra-text spacers can be created via the tagging mechanism that is used throughout the product. The IIntraTextSpacerTag is a dedicated tag type that the SyntaxEditor text formatting engine aggregates. As it formats lines, it watches for tags of this type that intersect the line's offset range, and when found knows to insert an appropriate amount of space at the tag's start offset location.

The IIntraTextSpacerTag has these members:

Member | Description
Baseline | Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline. This property can return the height of the spacer to sit the spacer on top of the text baseline.
Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Size | Gets the size of the spacer. This must be a fixed size.

Therefore to reserve space within text characters, all you need to do is create a tagger for the IIntraTextSpacerTag type and return appropriate tag ranges when requested. You can create a custom class that implements IIntraTextSpacerTag and use that in your tagger results. The tagger can in installed by your language via a tagger provider service.

At this point if your tagger is in use by your language, you should see extra whitespace at any tagged offsets, with the width and height designated by your tag.

Getting Data About Intra-Text Spacers

There are several members that can be useful for working with intra-text spacers, although they are generally only used internally:

Member | Description
GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer. The object passed as an argument is the value of the desired tag's Key property.
GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer. Spacer characters are embedded in between other real text characters. While spacer characters do take up a character index, they do not have a corresponding real character in a document.
GetIntraTextSpacerTags | Returns a collection of intra-text spacer tag ranges on the line that are of the specified type.

Creating an Intra-Text Adornment Manager

Now that intra-text spacers have been created, it's time to fill their space with adornments. SyntaxEditor includes a handy base class called IntraTextAdornmentManagerBase`2 that makes it very easy to fill your pre-defined intra-text spacers with adornments.

Note Note
It is important to understand the core concepts for adornments and adornment layers described in the Adornment Layers topic, since many of them apply here.

To make an intra-text adornment manager, create a new class that inherits IntraTextAdornmentManagerBase`2. The first type parameter you pass the base class is the type of view to support, such as IEditorView. The second type parameter you pass the base class is the type of tag to aggregate. For instance if your intra-text spacer tagger returns an IconTag, which for this discussion we will assume that IconTag implements IIntraTextSpacerTag, you would pass the IconTag type to the base class.

Next, have the intra-text adornment manager class constructor pass the target view instance and AdornmentLayerDefinition to use to the base class constructor.

Then override the base class' AddAdornment method. That method passes the view line being examined, the tag and its range for which to create an adornment, and the bounds in which a related intra-text spacer has been placed. Your implementation of the method should create the appropriate adornment, whether it be an image or other shape/control. Then add it to the adornment layer via the layer's AddAdornment method, being sure to pass the IIntraTextSpacerTag.Key value in the "tag" argument to that method. The adornment layer can be retrieved using the AdornmentLayer property on the base class.

Finally register an adornment manager provider (described in the Adornment Layers topic) as a language service. Your views should now be rendering adornments in your intra-text spacers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Outlining and Collapsing Features
Overview

SyntaxEditor fully supports automatic (language-driven) and manual (user-driven) code outlining/folding features similar to those found in Visual Studio.

Various text regions can even be collapsed (hidden) independent of the outlining features.

This topic contains these sections:

  • Code Outlining (Folding)
  • Outlining Nodes and Definitions
  • Outlining Sources and Outliners
  • Collapsing Regions without Outlining

Code Outlining (Folding)

Code outlining, also commonly referred to as code folding, is a mechanism by which a hierarchy of outlining nodes is maintained and visually rendered in an outlining margin. Nodes can be expanded and collapsed by the end user.

Automatic outlining mode is used when a syntax language defines an outlining source that tells the outlining manager how to incrementally update nodes as text is changed. Manual outlining mode is used when the end user wishes to define where outlining nodes occur.

A number of built-in commands provide easy access to all the outlining functionality found in products like Visual Studio.

See the Code Outlining (Folding) topic for more information.

Outlining Nodes and Definitions

Outlining nodes are part of a nested hierarchy of text ranges, stored within an outlining manager for a document. They can each be assigned various characteristics via outlining node definitions, such as what they render when collapsed, if they are collapsed automatically when a document is loaded, etc.

See the Outlining Nodes and Definitions topic for more information.

Outlining Sources and Outliners

Outlining sources are objects that an outlining manager can call upon to direct language-specific automatic outlining updates when document text changes. Several helpful base classes are included to make the creation of a syntax language's outlining source a simple task.

An outliner is a language service that returns a language-specific outlining source for a particular ITextSnapshot. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

See the Outlining Sources and Outliners topic for more information.

Collapsing Regions without Outlining

The code outlining feature decribed in earlier topics supports the collapsing of outlining nodes, where contained text becomes hidden. SyntaxEditor's low-level collapsed region management feature is harnessed to achieve this functionality. This same collapsed regions mechanism can be used independently of code outlining too.

Various text regions can be collapsed (hidden) independent of the outlining features. And in these cases you can even optionally replace the collapsed region with an adornment.

See the Collapsing Regions without Outlining topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Outlining (Folding)

SyntaxEditor Outlining and Collapsing Features
Code Outlining (Folding)

Code outlining, also commonly referred to as code folding, is a mechanism by which a hierarchy of outlining nodes is maintained and visually rendered in an outlining margin. Nodes can be expanded and collapsed by the end user.

Automatic outlining mode is used when a syntax language defines an outlining source that tells the outlining manager how to incrementally update nodes as text is changed. Manual outlining mode is used when the end user wishes to define where outlining nodes occur.

A number of built-in commands provide easy access to all the outlining functionality found in products like Visual Studio.

This topic contains these sections:

  • Run-Time Features
  • Outlining Mode (Automatic, Manual, etc.)
  • Outlining Manager
  • Outlining Edit Actions and Commands
  • Collapsed Node Quick Info Tips

Run-Time Features

SyntaxEditor's run-time code outlining features match those found in popular code editors.

A SyntaxEditor control with Javascript code being outlined

A margin on the left of the text area visually renders the outlining structure for text within the view. Small "+" (meaning collapsed) and "-" (meaning expanded) boxes show where outlining nodes start. Clicking these boxes allows the related outlining node(s) to toggle their collapsed state. When a node is expanded, a vertical line extending from the node's start box shows view lines that are included in the node's range. A small horizontal line appears on the view line where the node ends.

Hovering the mouse over a vertical line in the margin will cause a highlight to appear that shows the lines contained by the related outlining node. The vertical line can be double-clicked to collapse the node.

Once collapsed, the node's text content is hidden and a small adornment appears in its place. By default this adornment renders "..." text, however that can be customized via the node's definition. Hovering the mouse over the collapsed node adornment will provide a quick info tip displaying the node's contents, if the proper service is registered (see below). Single-clicking the collapsed node adornment will select the node's text range. Double-clicking the collapsed node adornment will expand the node.

Outlining Mode (Automatic, Manual, etc.)

There are two primary ways to supply outlining node data, which are referred to as automatic outlining and manual outlining.

Automatic outlining is language-specific and uses an outlining source to tell the outlining manager how to update the nodes. Manual outlining is where the end user, not the language, dictates the which nodes are present.

The IEditorDocument.OutliningMode property dictates which outlining modes are permitted:

  • Default - Automatic or manual are permitted and the end user may switch between them at any time.
  • Automatic - Only automatic is permitted.
  • Manual - Only manual is permitted.
  • None - No outlining is permitted.

The currently "active" mode is always available in the IOutliningManager.ActiveMode property. This property will never return a value of OutliningMode.Default, since it always is a resolved result.

Outlining Manager

An outlining manager, represented by the IOutliningManager interface, maintains the outlining node hierarchy for a particular document. It can be retrieved via the IEditorDocument.OutliningManager property.

The outlining manager tracks outlining data based on its ActiveMode property. When automatic outlining mode is active, the manager coordinates with an outlining source provided by the current language to determine how to update the outlining node hierarchy when text changes occur. These sorts of updates are generally syntax-driven based on the code in the editor. When manual outlining mode is active, the end user typically indicates which outlining nodes are present by making a text selections and choosing to create outlining nodes from them.

Getting Started with Automatic Outlining

The current syntax language must be capable of providing IOutliningSource objects that can be used by the outlining manager, if automatic outlining is to be supported.

See the Outlining Sources and Providers topic for details on how to add automatic outlining support to a syntax language.

Getting Started with Manual Outlining

Manual nodes can be created programmatic via the IOutliningManager.AddManualNode method and can be removed via the RemoveManualNode or RemoveAllManualNodes methods.

However in most cases the functionality provided by the HideSelectionAction (and related EditorCommands.HideSelection command) should be exposed directly to the end user via a menu/button. This functionality allows the end user to create manual nodes based on the current selection.

Other commands, all of which are described below, are also used when performing manual outlining.

Outlining Edit Actions and Commands

These edit actions and related commands deal with code outlining.

Action, Command | Description
CollapseToDefinitionsAction, EditorCommands.CollapseToDefinitions | Collapses all outlining nodes that have an IOutliningNodeDefinition.IsImplementation value of true.
HideSelectionAction, EditorCommands.HideSelection | Collapses the current selection.
StartAutomaticOutliningAction, EditorCommands.StartAutomaticOutlining | Starts automatic outlining.
StopHidingCurrentAction, EditorCommands.StopHidingCurrent | Stops hiding the outlining node that currently contains the caret, if any.
StopOutliningAction, EditorCommands.StopOutlining | Stops outlining.
ToggleAllOutliningExpansionAction, EditorCommands.ToggleAllOutliningExpansion | Toggles the collapsed state of all outlining nodes.
ToggleOutliningExpansionAction, EditorCommands.ToggleOutliningExpansion | Toggles the collapsed state of the outlining node that contains the caret, if any.

The commands can be easily wired up to any button or menu item.

Collapsed Node Quick Info Tips

By default no quick info tips will appear when hovering the mouse over a collapsed node adornment. However a CollapsedRegionQuickInfoProvider instance can be registered as a language service to automatically build quick info for collapsed node adornments.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Outlining Nodes and Definitions

SyntaxEditor Outlining and Collapsing Features
Outlining Nodes and Definitions

Outlining nodes are part of a nested hierarchy of text ranges, stored within an outlining manager for a document. They can each be assigned various characteristics via outlining node definitions, such as what they render when collapsed, if they are collapsed automatically when a document is loaded, etc.

This topic contains these sections:

  • Outlining Nodes
  • Outlining Node Definitions
  • Advanced Collapsed Content

Outlining Nodes

The IOutliningManager for a document stores a complete hierarchy of outlining nodes. Nodes are created either by a language (when in automatic mode) or by the end user (when in manual mode). Each node is created using an outlining node definition, which provides some characteristics for the node. Node definitions are described in detail below.

Outlining nodes are represented by the IOutliningNode interface. This interface gives access to various node data properties and also lets you traverse to other nodes.

Root Node

The root node, which is never visible and always contains the entire document, can be retrieved via the IOutliningManager.RootNode property. The IsRoot property of any node returns whether it is the root node or not.

Node Definition

The Definition property returns the IOutliningNodeDefinition used to create the node. See below for more information on node definitions.

Collapsed State

The IsCollapsed property returns whether the node is collapsed. It can be toggled to expand or collapse the node.

Snapshot Range and Open/Closed Nodes

The SnapshotRange property returns the TextSnapshotRange that is covered by the node.

If a node is "closed", it has a definite end at the end offset specified in the snapshot range. If a node is "open", it does not have an end and inherits the end offset of the nearest "closed" ancestor node. The IsOpen property indicates if a node is open.

Traversing Nodes

The Count property indicates how many child nodes are in the node, and the Item (indexer) property provides access to the child nodes. The ParentNode property provides access to the parent node.

The FindNodeRecursive method does a recursive search to find the lowest level node that contains the specified offset. This should generally only be called from the root node.

Note Note
The IOutliningNode instances are just wrappers around the core data structure used to track outlining node data. Therefore doing a reference equality check on two nodes that should be the same will always return false, since a new IOutliningNode instance is created each time you traverse to a new node.

Outlining Node Definitions

Outlining node definitions, represented by the IOutliningNodeDefinition interface, are used to define the characteristics of an outlining node. Node definitions are used by outlining sources when in automatic outlining mode, and can optionally be passed to the IOutliningManager.AddManualNode when adding a manual node.

Tip Tip
You can create static instances of your outlining node definitions and reuse them when creating outlining nodes. For example you may wish to support curly brace and multi-line comment outlining nodes in your language. In this scenario, just define two static outlining node definitions (one for curly braces and one for multi-line comments), and use the appropriate one as you create outlining nodes.

OutliningNodeDefinition Class

The OutliningNodeDefinition class implements the IOutliningNodeDefinition interface and is generally used wherever an IOutliningNodeDefinition is needed.

Collapsed Content

The IOutliningNodeDefinition.GetCollapsedContent method allows you to return some content to render when an outlining node is collapsed. Right now, only text strings can be returned by that method. If a null value is returned, the text "..." will be rendered in collapsed nodes. Comment nodes may wish to return a default of "/**/" instead.

The OutliningNodeDefinition class defines an additional DefaultCollapsedContent property that can be set to the content to return in the GetCollapsedContent method. This makes it so that for most cases, inheriting OutliningNodeDefinition is not necessary.

Is Default Collapsed

Sometimes certain node types should be collapsed by default when a document is loaded. #region nodes are good examples of this sort of node.

The IsDefaultCollapsed property should return true if nodes created using the definition should be collapsed by default.

Is Implementation

There is a common edit action called "Collapse to Definitions" that can be executed by the end user. In this scenario, the outlining tree is searched for any nodes with definitions that return true from their IsImplementation property. These nodes are then collapsed.

Is Collapsible

Sometimes you may wish to define nodes that do not allow the end user to alter their state from the UI. In these scenarios, a definition's IsCollapsible property should return false.

Advanced Collapsed Content

As mentioned above, collapsed content can be set on a node definition so that collapsed nodes can render something other than the default "..." when collapsed. Once you get automatic outlining working for your language, you may wish to have certain node types some alternate content that dynamically changes based on the content of the node. For instance, a collapsed #region node may wish to show the text label that follows the #region preprocessor keyword.

This can be achieved by creating a class that inherits OutliningNodeDefinition. Use this new node definition wherever you wish to have this advanced collapse content. In the new node definition class, override the GetCollapsedContent method. The method is passed an IOutliningNode instance. This instance is a node that was created using the definition.

The IOutliningNode.SnapshotRange property returns the TextSnapshotRange covered by the node. Snapshot ranges provide access to the complete text snapshot, via their Snapshot property. Then from that, an ITextSnapshotReader can be obtained so that scanning through text and tokens can be performed.

Thus by using the properties on the TextSnapshotRange and/or by using an ITextSnapshotReader, you can gather text/token data and display customized content for any nodes that use this definition.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Outlining Sources and Outliners

SyntaxEditor Outlining and Collapsing Features
Outlining Sources and Outliners

Outlining sources are objects that an outlining manager can call upon to direct language-specific automatic outlining updates when document text changes. Several helpful base classes are included to make the creation of a syntax language's outlining source a simple task.

An outliner is a language service that returns a language-specific outlining source for a particular ITextSnapshot. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

This topic contains these sections:

  • Outlining Source Basics
  • Outliners
  • Registering with a Syntax Language
  • Token-Based Outlining Sources
  • Range-Based Outlining Sources
  • Performance Optimizations

Outlining Source Basics

Outlining sources are represented by the IOutliningSource interface. This interface defines a single GetNodeAction method that is called by the IOutliningManager.

When a text change occurs and the outlining node hierarchy needs to be incrementally updated, the manager iterates through the existing nodes and compares them to the actions indicated by an IOutliningSource at the same offset. For each offset that is examined, the manager calls the GetNodeAction method and passes it by reference the offset to examine. It expects the outlining source to return the OutliningNodeAction to take (None, Start, or End) at that offset. None means that no outlining node should start or end at this offset. Start means that an outlining node should start at this offset. And likewise, End means that an outlining node should end at this offset. If the action is Start or End, then an IOutliningNodeDefinition needs to be returned via an out parameter. The node definition helps the manager to create new nodes and match ends to existing nodes. Also for an optimization, the offset passed can be moved ahead to indicate the next meaningful offset for the outlining source. When used properly this can result in a lot less calls to GetNodeAction while still returning the same accurate data.

SyntaxEditor comes with two built-in base classes that make it easier to construct an outlining source. One typically executes in the main thread, uses simple token pairs to determine how to create outlining nodes, and is very quick to set up. The other generally executes in a worker thread by a parser and is better suited for potential large documents, but requires a bit more code to get working. Both are described in detail below.

Outliners

Outliners, represented by the IOutliner interface, are objects that can create/retrieve an IOutliningSource for use by an outlining manager when it needs to update its outlining node hierarchy. The presence of an outliner service on a language tells the outlining manager that the language supports automatic outlining.

The IOutliner interface has two members. The first member is the UpdateTrigger property, that returns an AutomaticOutliningUpdateTrigger enumeration value indicating what event should trigger an automatic outlining update. If the outlining source is to be used in the main thread, such as with the token-based outlining source, then a TextChanged update trigger should be returned. This tells the outlining manager to update outlining data whenever a text change occurs. If the outlining source is to be generated by a parser, such as with a range-based outlining source, then a ParseDataChanged update trigger should be used. This tells the outlining manager to update outlining data whenever the ICodeDocument.ParseData property is changed.

The second member defined by IOutliner is the GetOutliningSource method, which returns an IOutliningSource to use for a given ITextSnapshot.

If you will be using an outlining source that derives from TokenOutliningSourceBase, you can use the built-in TokenOutliner`1 class to create your outlining source as needed. The TokenOutliner`1 class implements IOutliner and is able to create instances of the outlining source type indicated as a type parameter, assuming the outlining source type accepts a single ITextSnapshot constructor parameter.

Registering with a Syntax Language

As described above, IOutliner objects can be used as language services to provide outlining sources to any outlining manager that requests them.

This code shows how to register an outliner language service, assuming JavascriptOutliner implements IOutliner.

C#
VB
Copy
​language.RegisterService<IOutliner>(new JavascriptOutliner());
​language.RegisterService(Of IOutliner)(New JavascriptOutliner())

Token-Based Outlining Sources

A token-based outlining source executes in the main UI thread immediately after any text change occurs. It examines tokens from the language's lexer and returns whether a token indicates a start or end of an outlining node, or neither. For instance, a token for an open curly brace would generally indicate an outlining node start. A token for a close curly brace would generally indicate an outlining node end.

Benefits and Drawbacks

The benefits of this sort of outlining source are that it's extremely fast to get up and running with, and the outlining UI is always up-to-date with the document.

The drawbacks are that there is limited customization for when nodes are created, and since it's updating in the main thread, it has the potential to slow down typing speed when used on a very large document. For small to medium size documents, it should perform well though.

Implementation

A token-based outlining source can be created by inheriting the abstract TokenOutliningSourceBase class. The inherited class you create simply needs to override its GetNodeActionForToken method. That method is passed an IToken and expects an OutliningNodeAction returned. If the action is Start or End, then an appropriate IOutliningNodeDefinition must be returned via the "out" parameter. The outlining manager uses this information to determine how to sync up its outlining node hierarchy with your outlining source.

This code shows a sample token-based outlining source for the Javascript language:

C#
VB
Copy
​public class JavascriptOutliningSource : TokenOutliningSourceBase {

    private static OutliningNodeDefinition curlyBraceDefinition;
    private static OutliningNodeDefinition multiLineCommentDefinition;

    static JavascriptOutliningSource() {
        curlyBraceDefinition = new OutliningNodeDefinition("CurlyBrace");
        curlyBraceDefinition.IsImplementation = true;

        multiLineCommentDefinition = new OutliningNodeDefinition("MultiLineComment");
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/";
        multiLineCommentDefinition.IsImplementation = true;
    }

    public JavascriptOutliningSource(ITextSnapshot snapshot) : base(snapshot) {}

    protected override OutliningNodeAction GetNodeActionForToken(IToken token,
        out IOutliningNodeDefinition definition) {

        switch (token.Key) {
            case "MultiLineCommentStartDelimiter":
                definition = multiLineCommentDefinition;
                return OutliningNodeAction.Start;
            case "MultiLineCommentEndDelimiter":
                definition = multiLineCommentDefinition;
                return OutliningNodeAction.End;
            case "OpenCurlyBrace":
                definition = curlyBraceDefinition;
                return OutliningNodeAction.Start;
            case "CloseCurlyBrace":
                definition = curlyBraceDefinition;
                return OutliningNodeAction.End;
            default:
                definition = null;
                return OutliningNodeAction.None;
        }
    }
}
​Public Class JavascriptOutliningSource
    Inherits TokenOutliningSourceBase

    Private Shared curlyBraceDefinition As OutliningNodeDefinition
    Private Shared multiLineCommentDefinition As OutliningNodeDefinition

    Shared Sub New()
        curlyBraceDefinition = New OutliningNodeDefinition("CurlyBrace")
        curlyBraceDefinition.IsImplementation = True

        multiLineCommentDefinition = New OutliningNodeDefinition("MultiLineComment")
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/"
        multiLineCommentDefinition.IsImplementation = True
    End Sub

    Public Sub New(ByVal snapshot As ITextSnapshot)
        MyBase.New(snapshot)
    End Sub

    Protected Overrides Function GetNodeActionForToken(ByVal token As IToken, _
        <System.Runtime.InteropServices.Out()> ByRef definition As IOutliningNodeDefinition) _
        As OutliningNodeAction

        Select Case token.Key
            Case "MultiLineCommentStartDelimiter"
                definition = multiLineCommentDefinition
                Return OutliningNodeAction.Start
            Case "MultiLineCommentEndDelimiter"
                definition = multiLineCommentDefinition
                Return OutliningNodeAction.End
            Case "OpenCurlyBrace"
                definition = curlyBraceDefinition
                Return OutliningNodeAction.Start
            Case "CloseCurlyBrace"
                definition = curlyBraceDefinition
                Return OutliningNodeAction.End
            Case Else
                definition = Nothing
                Return OutliningNodeAction.None
        End Select
    End Function
End Class

The outlining source could be used by a language by registering a TokenOutliner`1 service:

C#
VB
Copy
​language.RegisterService<IOutliner>(
    new TokenOutliner<JavascriptOutliningSource>());
​language.RegisterService(Of IOutliner)( _
    New TokenOutliner(Of JavascriptOutliningSource)())

Range-Based Outlining Sources

A range-based outlining source is generated by an IParser in a worker thread. The parser scans and provides outlining data for the entire document in the form of text ranges and corresponding outlining node definitions. This could be done via simple token scanning or by examining an AST (abstract syntax tree) that is constructed by the parser immediately beforehand. Since a majority of the work is done in a separate thread, there is almost no impact to the UI thread.

Benefits and Drawbacks

The benefits of this sort of outlining source are that it doesn't slow down the main UI thread (even for relatively large documents) when typing, and allows for complete customization of what text ranges become outlining nodes. For example, you can choose to only make outlining nodes for top-level curly braces, instead of curly braces at all levels.

The drawbacks are that it is slightly more complex than the simpler token-based outlining source mechanism, and there can be a brief delay between when typing and when outlining node UI pops into the margin, due to the multi-threading.

Note Note
Since this sort of outlining source is executed within a parser, be sure to read up on parsers and configuring a dispatcher. Failing to set up a parse request dispatcher properly will prevent worker threads from being used.

Using Abstract Syntax Trees

Advanced syntax language developers will want to build an IParser to construct an AST of their document, and use that AST data to create the appropriate outlining node ranges for their outlining source. Say your syntax language is for C# and assume you have a parser that makes an AST of the document. Your AST knows which text ranges are namespaces, which are classes, etc. Therefore that sort of AST node data can be used to construct related outlining node data.

Implementation

A range-based outlining source can be created by inheriting the abstract RangeOutliningSourceBase class. The inherited class you create should configure the outlining node ranges in its constructor. The constructor can be passed an ITextSnapshot and/or AST data if available.

Regardless of which method will be used to determine where outlining node ranges are, the concept remains the same. Some sort of iteration/recursion should take place and when an outlining node range is found, it can be configured by calling the AddNode method. This method takes a TextRange (relative to the ITextSnapshot passed in) and the IOutliningNodeDefinition to use for that range.

Sometimes certain nodes may not have an end. This could happen in VB if a Namespace ... End Namespace block contains a Class declaration however no End Class has yet been typed. In this case the outlining node for the Class is considered "open". It can be added by calling the AddOpenNode method. That method accepts a start offset instead of a TextRange.

Here is some sample code showing how a range-based Javascript outlining source could be made that only creates outlining nodes for multi-line comments and top-level curly braces. This sample does token scanning in the ITextSnapshot. However if you already have built an AST of the document, that would be more preferable for use.

C#
VB
Copy
​public class JavascriptOutliningSource : RangeOutliningSourceBase {

    private static OutliningNodeDefinition curlyBraceDefinition;
    private static OutliningNodeDefinition multiLineCommentDefinition;

    static JavascriptOutliningSource() {
        curlyBraceDefinition = new OutliningNodeDefinition("CurlyBrace");
        curlyBraceDefinition.IsImplementation = true;

        multiLineCommentDefinition = new OutliningNodeDefinition("MultiLineComment");
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/";
        multiLineCommentDefinition.IsImplementation = true;
    }

    public JavascriptOutliningSource(ITextSnapshot snapshot) : base(snapshot) {
        int curlyBraceStartOffset = -1;
        int curlyBraceLevel = 0;
        int commentStartOffset = -1;
        IToken token;

        // Get a text snapshot reader so that we can read tokens
        ITextSnapshotReader reader = snapshot.GetReader(0);

        // Read through the entire snapshot
        while (!reader.IsAtSnapshotEnd) {
            // Get the next token
            token = reader.ReadToken();
            if (token != null) {
                switch (token.Key) {
                    case "MultiLineCommentStartDelimiter":
                        // A multi-line comment is starting... save its start offset
                        if (commentStartOffset == -1)
                            commentStartOffset = token.StartOffset;
                        break;
                    case "MultiLineCommentEndDelimiter":
                        // A multi-line comment is ending... add its range to the outlining source
                        if (commentStartOffset != -1) {
                            this.AddNode(new TextRange(commentStartOffset, token.EndOffset), multiLineCommentDefinition);
                            commentStartOffset = -1;
                        }
                        break;
                    case "OpenCurlyBrace":
                        // An open curly brace... save its start offset if it's a top-level brace
                        if (curlyBraceLevel++ == 0) {
                            if (curlyBraceStartOffset == -1)
                                curlyBraceStartOffset = token.StartOffset;
                        }
                        break;
                    case "CloseCurlyBrace":
                        // A close curly brace... add its range to the outlining source if it's a top-level brace
                        if (curlyBraceLevel > 0) {
                            curlyBraceLevel--;
                            if (curlyBraceLevel == 0) {
                                this.AddNode(new TextRange(curlyBraceStartOffset, token.EndOffset), curlyBraceDefinition);
                                curlyBraceStartOffset = -1;
                            }
                        }
                        break;
                }
            }
            else
                break;
        }

        // If there are any "open" nodes (never found a matching end), add them too
        if (commentStartOffset != -1)
            this.AddOpenNode(commentStartOffset, multiLineCommentDefinition);
        if (curlyBraceStartOffset != -1)
            this.AddOpenNode(curlyBraceStartOffset, curlyBraceDefinition);
    }
}
​Public Class JavascriptOutliningSource
    Inherits RangeOutliningSourceBase

    Private Shared curlyBraceDefinition As OutliningNodeDefinition
    Private Shared multiLineCommentDefinition As OutliningNodeDefinition

    Shared Sub New()
        curlyBraceDefinition = New OutliningNodeDefinition("CurlyBrace")
        curlyBraceDefinition.IsImplementation = True

        multiLineCommentDefinition = New OutliningNodeDefinition("MultiLineComment")
        multiLineCommentDefinition.DefaultCollapsedContent = "/**/"
        multiLineCommentDefinition.IsImplementation = True
    End Sub

    Public Sub New(ByVal snapshot As ITextSnapshot)
        MyBase.New(snapshot)
        Dim curlyBraceStartOffset As Integer = -1
        Dim curlyBraceLevel As Integer = 0
        Dim commentStartOffset As Integer = -1
        Dim token As IToken

        ' Get a text snapshot reader so that we can read tokens
        Dim reader As ITextSnapshotReader = snapshot.GetReader(0)

        ' Read through the entire snapshot
        Do While Not reader.IsAtSnapshotEnd
            ' Get the next token
            token = reader.ReadToken()
            If token IsNot Nothing Then
                Select Case token.Key
                    Case "MultiLineCommentStartDelimiter"
                        ' A multi-line comment is starting... save its start offset
                        If commentStartOffset = -1 Then
                            commentStartOffset = token.StartOffset
                        End If
                    Case "MultiLineCommentEndDelimiter"
                        ' A multi-line comment is ending... add its range to the outlining source
                        If commentStartOffset <> -1 Then
                            Me.AddNode(New TextRange(commentStartOffset, token.EndOffset), multiLineCommentDefinition)
                            commentStartOffset = -1
                        End If
                    Case "OpenCurlyBrace"
                        ' An open curly brace... save its start offset if it's a top-level brace
                        curlyBraceLevel += 1
                        If curlyBraceLevel = 1 Then
                            If curlyBraceStartOffset = -1 Then
                                curlyBraceStartOffset = token.StartOffset
                            End If
                        End If
                    Case "CloseCurlyBrace"
                        ' A close curly brace... add its range to the outlining source if it's a top-level brace
                        If curlyBraceLevel > 0 Then
                            curlyBraceLevel -= 1
                            If curlyBraceLevel = 0 Then
                                Me.AddNode(New TextRange(curlyBraceStartOffset, token.EndOffset), curlyBraceDefinition)
                                curlyBraceStartOffset = -1
                            End If
                        End If
                End Select
            Else
                Exit Do
            End If
        Loop

        ' If there are any "open" nodes (never found a matching end), add them too
        If commentStartOffset <> -1 Then
            Me.AddOpenNode(commentStartOffset, multiLineCommentDefinition)
        End If
        If curlyBraceStartOffset <> -1 Then
            Me.AddOpenNode(curlyBraceStartOffset, curlyBraceDefinition)
        End If
    End Sub
End Class

This code shows a sample outliner for the outlining source above. Note that since much of the outlining work is occuring in a worker thread, the editor control may already be on a new text snapshot by the time the parsing completes. Therefore we do a quick call to TranslateTo to ensure the data in the outlining source that will be used by the outlining manager are up-to-date with the current snapshot in the editor.

C#
VB
Copy
​public class JavascriptOutliner : IOutliner {

    public IOutliningSource GetOutliningSource(ITextSnapshot snapshot) {
        ICodeDocument document = snapshot.Document as ICodeDocument;
        if (document != null) {
            // Get the outlining source, which should be passed back by the IParser in the parse data
            JavacriptParseData parseData = document.ParseData as JavacriptParseData;
            if ((parseData != null) && (parseData.OutliningSource != null)) {
                // Translate the data to the desired snapshot,
                //   which could be slightly newer than the parsed source
                parseData.OutliningSource.TranslateTo(snapshot);
                return parseData.OutliningSource;
            }
        }
        return null;
    }

    public AutomaticOutliningUpdateTrigger UpdateTrigger {
        get {
            return AutomaticOutliningUpdateTrigger.ParseDataChanged;
        }
    }
}
​Public Class JavascriptOutliner
    Implements IOutliner

    Public Function GetOutliningSource(ByVal snapshot As ITextSnapshot) As IOutliningSource
        Dim document As ICodeDocument = TryCast(snapshot.Document, ICodeDocument)
        If document IsNot Nothing Then
            ' Get the outlining source, which should be passed back by the IParser in the parse data
            Dim parseData As JavacriptParseData = TryCast(document.ParseData, JavacriptParseData)
            If (parseData IsNot Nothing) AndAlso (parseData.OutliningSource IsNot Nothing) Then
                ' Translate the data to the desired snapshot,
                '   which could be slightly newer than the parsed source
                parseData.OutliningSource.TranslateTo(snapshot)
                Return parseData.OutliningSource
            End If
        End If
        Return Nothing
    End Function

    Public ReadOnly Property UpdateTrigger() As AutomaticOutliningUpdateTrigger
        Get
            Return AutomaticOutliningUpdateTrigger.ParseDataChanged
        End Get
    End Property
End Class

The outlining source could be used by a language by registering a custom outliner service:

C#
VB
Copy
​language.RegisterService<IOutliner>(
    new JavascriptOutliner());
​language.RegisterService(Of IOutliner)( _
    New JavascriptOutliner())

Performance Optimizations

Remeber that token-based outlining sources are generally used in the main UI thread and thus can block the UI temporarily if editing a large document and a large incremental outlining update is being made. In cases where this becomes noticable, a range-based outlining source should be used instead. Range-based outlining sources are generally built in a worker thread by a parser, and only cause a minimal UI thread hit when merging the data into the outlining hierarchy.

Code outlining has a lot of dependence on a language's lexer. Therefore a faster lexer can make a huge difference in outlining performance when compared to a slower lexer. Keep this in mind when looking for ways to speed up outlining performance. For instance, if you started off using a dynamic lexer for your language, you should note that while dynamic lexers are great ways to get started, they are the slowest of the lexer types. You can probably achieve a 2-300% code outlining speed increase by switching your language to a programmatic lexer instead.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Collapsing Regions without Outlining

SyntaxEditor Outlining and Collapsing Features
Collapsing Regions without Outlining

The code outlining feature decribed in earlier topics supports the collapsing of outlining nodes, where contained text becomes hidden. SyntaxEditor's low-level collapsed region management feature is harnessed to achieve this functionality. This same collapsed regions mechanism can be used independently of code outlining too.

Various text regions can be collapsed (hidden) independent of the outlining features. And in these cases you can even optionally replace the collapsed region with an adornment.

This topic contains these sections:

  • Collapsed Region Manager
  • Tagging Collapsed Regions
  • Rendering Intra-Text Adornments in Place of Collapsed Regions

Collapsed Region Manager

The ICollapsedRegionManager is the object that tracks all the collapsed regions for a particular view. A view's collapsed region manager is accessible via the ITextView.CollapsedRegionManager property.

When the view's text formatting engine builds up layout data for a view line, it consults the collapsed region manager to see if there are any collapsed regions that it needs to be aware of. When one is found, it ignores the contained text and moves onto the remaining text that should be rendered on the view line.

The ICollapsedRegionManager has two main functions:

  • Raise an event when the collapsed regions change
  • Allow consumers to return collapsed regions that contain an offset or interset a text range

RegionsChanged Event

The manager watches all document text changes and also changes published by ICollapsedRegionTag taggers. When any of those changes occur, the manager updates its collapsed regions accordingly. If any regions are added or removed, the RegionsChanged event is raised, passing along the TextSnapshotRange that was changed.

Returning Intersecting Collapsed Regions

The ICollapsedRegionManager.GetCollapsedRange returns the TextSnapshotRange, if any, that contains the specified offset.

The GetCollapsedRanges method returns a NormalizedTextSnapshotRangeCollection of collapsed snapshot ranges that intersect the specified range, if any.

Tagging Collapsed Regions

The ICollapsedRegionTag is a dedicated tag type that the ICollapsedRegionManager watches for and uses to determine which regions are collapsed. SyntaxEditor's text formatting engine then consults the collapsed region manager and uses its data to determine when text should be rendered as collapsed (hidden).

Therefore to collapse a region of text without using code outlining, all you need to do is create a tagger for the ICollapsedRegionTag type and return appropriate tag ranges when requested. You can create a custom class that implements ICollapsedRegionTag and use that in your tagger results. The tagger can in installed by your language via a tagger provider service.

At this point if your tagger is in use by your language, you should notice hidden text wherever your tagger designates.

Rendering Intra-Text Adornments in Place of Collapsed Regions

Collapsed regions by default will not render anything in their place. However there is an option to render an adornment in place of the collapsed region. The code outlining feature uses this option to render the "..." sort of adornments wherever an outlining node is collapsed.

Since the adornments that are inserted in place of collapsed regions should be inserted in between the surrounding text characters, intra-text adornments are used.

Note Note
See the Intra-Text Adornments topic for details on how to create intra-text adornments.

What you do is have an IIntraTextSpacerTag tagger return the same tag ranges as the ICollapsedRegionTag ranges that need adornments. The text formatter will look for intra-text spacers that match the same range as collapsed ranges and will render space in those locations. Then an intra-text adornment manager can place an adornment in that space.

To sum up, an ICollapsedRegionTag is returned by a tagger over a certain range. An IIntraTextSpacerTag is also returned by a tagger over the same range. An intra-text adornment manager places an adornment in the space that has been reserved.

Tip Tip
For this mechanism, you can have a single tagger return both the ICollapsedRegionTag and IIntraTextSpacerTag ranges. Just create the tagger for ICollapsedRegionTag and explicitly implement the interface of ITagger`1 for IIntraTextSpacerTag.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

SyntaxEditor Globalization and Accessibility
Overview

SyntaxEditor has full support for editing Unicode text, is completely localizable, and implements UI automation.

This topic contains these sections:

  • Localization
  • UI Automation

Localization

All of the strings that are displayed in the user interface can be customized and localized.

See the Localization topic for more information.

UI Automation

SyntaxEditor follows the Microsoft accessibility model for UI automation.

See the UI Automation topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Localization

SyntaxEditor Globalization and Accessibility
Localization

All of the strings that are displayed in the user interface can be customized and localized.

This topic contains these sections:

  • Customizing String Resources

Customizing String Resources

All strings that are displayed in the user interface are available from static methods on the ActiproSoftware.Products.SyntaxEditor.SR and ActiproSoftware.Products.Text.SR classes. The optional add-on products have their own related SR classes too.

Note Note
String resource customization is described in great detail in the general Customizing String Resources topic. Please see that topic for in-depth information related to localization of string resources.

An enumation named SRName includes a list of all the string resource names. A XAML markup extension named SRExtension is available for use within XAML templates to access string resources.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UI Automation

SyntaxEditor Globalization and Accessibility
UI Automation

SyntaxEditor follows the Microsoft accessibility model for UI automation.

What is UI Automation?

Microsoft UI Automation is the new accessibility framework for Microsoft Windows. It addresses the needs of assistive technology products and automated test frameworks by providing programmatic access to information about the user interface (UI).

SyntaxEditor implements automation peers for the following classes:

  • The SyntaxEditor class, which provides access to the current document text, and various other abilities.
  • The EditorView class, which provides simple scrolling abilities.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Language Creation Guide
Overview

This guide walks through the steps needed to build and use your own syntax languages with SyntaxEditor. Syntax languages are a key part of the SyntaxEditor control product because they are part of the flow that enables syntax highlighting and other features in SyntaxEditor.

To better illustrate, lets examine the flow that occurs when text is typed into a SyntaxEditor to see how a language is involved in determining how the typed text gets rendered.

A diagram that illustrates the general flow of logic from input through to display

A SyntaxEditor control is a code editor that accept input. When typing occurs, it creates a text change and applies it on the attached IEditorDocument. This creates a new immutable snapshot. The snapshot text is analyzed by a lexer and tokens are generated. These tokens are "tagged" by a token tagger and back in the UI layer, the classifications are translated to related highlighting styles via a highlighting style registry. These highlighting styles are then used to tell SyntaxEditor how to render text.

This topic contains these sections:

  • Step-by-Step Walkthrough
  • Creating an ISyntaxLanguage
  • Loading a Language Definition (.langdef File)
  • Service Locator Architecture
  • Feature Services
  • Provider Services
  • Event Sink Services
  • Using a Language

Step-by-Step Walkthrough

Don't know where to get started building a custom syntax language? This walkthrough is the perfect place to go because it gives the steps that should be followed, along with links to many other helpful topics in this documentation.

See the Step-by-Step Walkthrough topic for more information.

Creating an ISyntaxLanguage

The first step in building a language is the creation of a class that implements ISyntaxLanguage.

See the Creating an ISyntaxLanguage topic for more information.

Loading a Language Definition (.langdef File)

The Language Designer application can be used to optionally create files with .langdef file extensions, which are language definitions. These language definition files can be distributed with your application, often in file form or as an embedded resource. They contain information about a language and can be loaded at run-time to automatically create and initialize a language.

See the Loading a Language Definition (.langdef File) topic for details on how to load one of these files at run-time.

Service Locator Architecture

Syntax languages are architected using the Service Locator design pattern, which keeps the ISyntaxLanguage interface small while still allowing for powerful extensibility of features.

Language features such as lexing, token tagger providers, line commenters, etc. can be registered as services on each language instance. Certain service types are well known and extension methods provide easy access to the built-in feature services. Any sort of custom service can be registered with a language and retrieved later as well.

See the Service Locator Architecture topic for more information.

Feature Services

Syntax languages have a wide array of optional features that can be implemented to enhance their capabilities when used with SyntaxEditor.

See the Feature Services topic for more information.

Provider Services

Syntax languages can register multiple instances of service objects implementing provider interfaces. These provider interfaces can help drive features like tagging, adornments, and IntelliPrompt.

See the Provider Services topic for more information.

Event Sink Services

Event sinks are interfaces that allow a language to be notified of events that occur to a SyntaxEditor or IEditorDocument. This could be anything from input events to text change events. The language can choose to process these events and optionally block editor views from receiving them.

See the Event Sinks topic for more information.

Using a Language

Once your syntax language has been configured properly, it's ready for use.

See the Using a Language topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Step-by-Step Walkthrough

Language Creation Guide
Step-by-Step Walkthrough

Don't know where to get started building a custom syntax language? This walkthrough is the perfect place to go because it gives the steps that should be followed, along with links to many other helpful topics in this documentation.

This walkthough gives you a sequence of concepts to understand when working with syntax languages. Each section in the walkthough provides a brief overview along with links to other documentation topics that give detailed information about the related subject.

This topic contains these sections:

  • Understanding Language Concepts
  • Gathering Language Specifications
  • Using the Language Designer Tool
  • Loading and Using a Language at Run-time
  • Adding Support for Services / Event Sinks
  • Functionality to Language Service Mapping Table
  • Moving Forward

Understanding Language Concepts

A syntax language is an object implementing ISyntaxLanguage that can be assigned to an ICodeDocument to provide language-specific functionality for the document. This functionality can be anything from word-break finding to lexing/parsing, all available via registered services. Multiple syntax languages can be created so that different documents can each receive different functionality.

For instance, the C# language uses different word-break and tokenizing rules than the CSS language does. By having different syntax languages defined for C# and CSS, different functionality can be applied to a document based on the language it currently is using.

  • The Syntax Languages topic talks at a high-level about syntax languages and what they do.
  • The Service Locator Architecture topic talks in-depth about the service locator architecture utilized by syntax languages and how it provides an open and extensible framework for plugging in language features. It also describes the available built-in service types. We will get more into implementing services later in this topic.
  • The Feature Services, Provider Services, and Event Sink Services topics give details on the various built-in service types that are available, but more on that below.

Gathering Language Specifications

Once you understand the basic concepts of what syntax languages do, it's time to think about implementing a custom syntax language for the language(s) you wish to support in your application. Syntax languages are best used in conjunction with SyntaxEditor controls since they provide a full-featured editing experience much like what is found in Visual Studio.

A number of free syntax language samples are included in the sample project. Be sure to check those out since we may have already created a syntax language for the language you wish to support. If one is available, feel free to copy and use it in your application. You can extend or modify it using the concepts we describe below.

If no existing syntax language is available for your target language, you can create one yourself. You will need to go on the Internet and find a language specification for your language. Language specifications generally describe the lexical and semantic structure of a language. They are very important because they tell us the language's keywords, the syntax of comments, etc.

Once you have examined your language's specifications, it's time to use the Language Designer tool.

Using the Language Designer Tool

The Language Designer application was built with the goal of making it easy to get started building a language. You essentially input information about your language and it generates code for you that can be included in your project to use your syntax language.

  • Run through the entire Language Designer documentation section since it discusses the functionality of the application, what pieces of a language can be defined in a language project, how to output code, etc.

Our recommendations for using the application are to follow these steps:

  • Run the application and create a new language project.
  • Set the General Properties for the language.
  • Create a Lexer for the language. A dynamic lexer is the fastest way to get started if you are new to the product.
  • Define the classification types that will be used.
  • Build the language project.
  • Fix any errors that are found.
  • Use the Live Test feature (if the lexer type you use is supported) and test that your lexer is operating correctly.
  • Use the Code Generation feature to output code for the language.

Loading and Using a Language at Run-time

At this point, we assume we have some code for our syntax language. It could have been code generated by the Language Designer application (described above). Or we could have followed the steps in the Creating an ISyntaxLanguage topic to do it by hand.

We are ready to load the language. If we have created a dedicated code-based syntax language class, we create an instance of it. If instead we used the Language Designer to output a language definition (.langdef) file, the Loading a Language Definition topic talks about how to load it.

In either case we now have a variable reference to an ISyntaxLanguage instance. The Using a Language topic talks about how to assign the syntax language to a document to enable its features to be used by the document and related view controls, such as a SyntaxEditor.

We now can run our application and use the language.

Adding Support for Services / Event Sinks

As mentioned in the Service Locator Architecture topic, there are quite a number of other features that can be added to languages via services.

The Feature Services topic lists the various services that implement features for a syntax language. Features can include things like lexers, parsers, line commenters, etc.

Provider Services are services that provide some sort of data upon request. Any language service that implements one of the provider interfaces is automatically called as needed. These services drive features like tagging, adornments, and IntelliPrompt.

Event Sink Services are a category of service types that can be registered with a language and are used to listen to events that take place in a document or an editor control that uses the document. For instance, you can listen to document text change events, key/mouse input events, view selection change events, etc. In each of these events you have the option to handle them within the language. As an example, this provides the ideal place for a syntax language such as HTML to watch for the < character being typed in a SyntaxEditor so that it can show a completion list containing the available HTML tags.

By using the service locator design pattern, syntax languages are very open and extensible. You can further customize a pre-built syntax language by adding your own service implementations.

Functionality to Language Service Mapping Table

There is an enormous amount of functionality available to be implemented via language services, and with this flexibility can understandably come some confusion. This table maps the services that are typically used in a language to implement the specified functionality.

Functionality Notes
Lexer-based syntax highlighting

This functionality is the ability for a lexer to tokenize text and use that information to drive syntax highlighting within a SyntaxEditor.

Requires an ILexer feature service and a token tagger provider service. The token tagger (created for each document by the provider service) tags ranges of text as tokens with a certain IClassificationType.

The classification types that are tagged by the token tagger must be mapped to highlighting styles in a highlighting style registry. Generally the AmbientHighlightingStyleRegistry is used for the mappings.

To sum up, the lexer tokenizes text, the token tagger flags ranges of text with tokens/classification types, and the highlighting style registry tells SyntaxEditor how to convert tagged ranges to syntax highlighted markup.

When loading a syntax language from a language definition (.langdef) file, everything described above is configured for you.

Customized syntax highlighting

While lexers generally provide the core syntax highlighting (via the functionality described above), sometimes you may wish to override the syntax highlighting for certain text ranges, add underlines, change background colors, etc.

To accomplish this a tagger provider service must be used that creates a tagger for IClassificationTag objects. The IClassificationTag interface specifies a IClassificationType. The tagger needs to be set up to be ordered before the TaggerKeys.Token tagger, accomplished via the IOrderable interface, so that its classification types merge into and can override the lexer's existing classifications.

Similar to above, the classification types that are tagged by the tagger must be mapped to highlighting styles in a highlighting style registry. Generally the AmbientHighlightingStyleRegistry is used for the mappings.

The result is that syntax highlighting can be overridden. Multiple layers of customized syntax highlighting can be achieved using this same mechanism.

Parsing (syntax and/or semantic analysis)

Syntax and semantic analysis generally include the parsing of tokens to ensure that code is syntactically correct and valid. Parsing kicks off following text changes. Some form of parse data (which can include an AST, error list, etc.) is returned to the document when the parsing completes. The parsing options can be automatically offloaded into a worker thread so that the complex parsing doesn't cause any locking of the main UI thread.

The first step in setting up parsing is to ensure an ambient parse request dispatcher is installed right at your application's startup. This is vital because it is what allows the parsing to occur in a separate worker thread. If no ambient parse request dispatcher is installed, parsing will occur in the main UI thread. This could cause the editor user interface to slow down, depending on how much work the parser does. Therefore, make sure it is installed to prevent any slowdowns.

Next, register an IParser feature service. Now the parser will be called in a worker thread whenever text changes occur to a document that uses the language.

Actipro offers a very robust LL(*) Parser Framework that makes it simple to build IParser-based parsers using EBNF-like notation in C# and VB. It is free to use, has AST construction, error handling, callbacks, and a lot of other features that make it integrate nicely with our core text/parsing framework.

Alternatively, since a parser just has to implement the IParser interface, any sort of custom parsing can be performed with our generic parsing mechanism.

Automatic outlining support

Automatic outlining is where the document text is scanned and an outlining node hierarchy is constructed based on its contents. The outlining node tree is rendered visually in the editor's outlining margin and end users can expand/collapse nodes. As further text changes occur, the outlining node tree is incrementally updated.

The IOutliningManager is the object that maintains the outlining node hierarhcy. When a language has an IOutliner service registered, the outlining manager knows that the language is capable of performing automatic outlining. The outlining manager uses the outliner service to retrieve an IOutliningSource whenever it needs to update. The outlining source is capable of examining an offset and returning whether an outlining node should start or end there, or neither. There are several base classes included with SyntaxEditor that make it easy to create an outlining source.

An Outliner service is required for automatic outlining support. The Outlining and Collapsing Features series of topics talk about how create outlining sources and define nodes.

Quick info tips for mouse hovers over collapsed regions

The built-in CollapsedRegionQuickInfoProvider service can be registered on a language to allow quick info tips to be automatically displayed when the end user hovers over a collapsed outlining node adornment, such as the "..." blocks.

Line commenting

Line commenting is the ability for SyntaxEditor to comment and uncomment lines with language-specific text. For instance, C# syntax languages can be set up to use // single line comments for line commenting. Or they could be set up to use /* ... */ multi-line comments instead.

This feature requires that an ILineCommenter service be registered with the language.

Text statistics

Text statistics can be quickly constructed for any language. The statistics can include everything from word counts to readability scores. Custom statistics can be be built for each language.

This feature requires that an ITextStatisticsFactory service be registered with the language.

Word break finding

While many syntax languages use the same patterns for determining line breaks, there are some syntax languages that require further customization. For instance, the CSS syntax language needs hyphen (-) characters to be considered word characters.

Custom word break finding functionality can be configured for a language by registering an IWordBreakFinder service with the language.

Automated IntelliPrompt completion (auto-complete and popup list)

IntelliPrompt Completion is an extremely helpful way for end users to maximize their productivity when writing code. Completion sessions support auto-complete via keys like Ctrl+Space and will show a completion list popup when no single auto-completion can be determined.

The IntelliPrompt Completion topic walks through the very extensive list of features available with completion sessions.

Syntax languages have several ways they can be set up to provide automated IntelliPrompt completion.

One or more ICompletionProvider services may be registered on the language. These provider services can be ordered. When a completion provider service is on the language, any Ctrl+Space keys typed by the end user will call the first completion provider to see if it can open a completion session. If it can't, the next provider is checked, and so on. When opening a session, the completion providers determine if auto-complete is allowed, what features are enabled (filtering, auto-shrink, text matching algorithms, etc). The completion provider must also populate the items in the completion session prior to opening it. Completion providers often use a mix of looking at any available document ParseData and token scanning to detemine which sort of items should be in the session, based on the current editor view caret location.

Completion sessions can also be requested when the end user begins to type a new word. This involves having the language register an IEditorDocumentTextChangeEventSink service and in the text changed event notification, check a helper property on the event args that indicates if a new word is being typed. If so, request a completion session. A full sample of this is included in the "Opening a Session in Response to a Typed Character" section of the Completion List topic.

Automated IntelliPrompt quick info

IntelliPrompt Quick Info is the ability to render helpful tooltips related to end user mouse hovers, or related to what is under the caret. The content of a quick info tip can be plain text, formatted text (using an HTML-like markup), or any UIElement.

The IntelliPrompt Quick Info topic walks through the list of features available with quick info sessions.

One or more IQuickInfoProvider services may be registered on the language. These provider services can be ordered. When a quick info provider service is on the language, any mouse hovers by the end user will call the first quick info provider to see if it can open a quick info session. If it can't, the next provider is checked, and so on. The quick info provider populates content in the quick info session prior to it opening. Similar to completion providers, quick info providers often use a mix of looking at any available document ParseData and token scanning to detemine the content that should be presented in the session.

Navigable symbol (type/member) selector support

A Navigable Symbol Selector control is included that can be bound to a SyntaxEditor and supports listing accessible symbols (such as types and members) within a document. The selections within the control update as the editor caret is moved. When a symbol is selected from a dropdown, the caret navigates directly to the related symbol declaration.

The control requires that a feature service is implemented on the language that returns accessible symbols. The IntelliPrompt Navigable Symbol Provider topic walks through how to create such a service.

Code snippet support

IntelliPrompt Code Snippets allow small snippets of code to be inserted into a document. Selection sessions display all available code snippets and allow the end user to easily pick one to activate. Template sessions occur when a code snippet is activated and alllow the end user to tab between pre-defined fields within the code snippet to customize the text that is inserted.

Code snippet features require that an IntelliPrompt code snippet provider is registered on the language, with one or more code snippets loaded into it.

Creating a custom tagger for a document

A custom tagger can be installed into a document by using a tagger provider language service. Once the tagger is installed into the document, tag aggregators for the tag type returned by the tagger will be collected from the tagger and combined with results from other similar taggers.

Custom taggers are often used to drive features like customized syntax highlighting, squiggle line display, adornments, etc.

Automatically render squiggle lines for parse errors with quick info tips

If you are using an IParser feature service on your language, it will return resulting parse data to the ICodeDocument.ParseData property. If the parse data object implements the IParseErrorProvider interface then parse errors can be retrieved from it.

There is a built-in tagger called ParseErrorTagger that can be attached to a document via a document-oriented tagger provider service. See the Tagger Provider topic for details on making tagger provider services.

When this parse error tagger is attached to a document, it will monitor the document's parse data for changes. If the parse data is updated, it will automatically get the list of parse errors from it (assuming the parse data implements IParseErrorProvider) and will return ISquiggleTag tags for each one. This automatically drives the squiggle line display when used in an editor.

The SquiggleTagQuickInfoProvider is an IQuickInfoProvider that presents a Quick Info popup with the contents of ISquiggleTag.ContentProvider. When registered with a language along with a ParseErrorTagger, it will provide the description of a parsing error when you hover the mouse over a text range that is tagged by an ISquiggleTag.

Add custom adornments to a view's text area

An example of adornments that are not related directly to document text content are alternating row highlights. To implement this sort of feature, a custom adornment manager is created that inherits AdornmentManagerBase`1. The manager attaches to the view's TextAreaLayout event and updates its Rectangle higlight adornments based on the document line numbers of the view lines that need adornments.

An adornment manager provider service is required to create adornment manager instances for each view that should use them.

Add custom decoration adornments to specific text ranges

An example of adornments that are related directly to text spans are borders around certain text ranges that indicate find operation results. For scenarios like this, a custom adornment manager is created that inherits DecorationAdornmentManagerBase`2. The base class handles the determination of when to add/update/remove adornments. When a new adornment needs to be added, the AddAdornment method is called. This method is overridden in your inheriting class and the code you implement calls IAdornmentLayer.AddAdornment to add an adornment to the layer.

An adornment manager provider service is required to create adornment manager instances for each view that should use them.

Add custom adornments in between text characters

Any sort of content can be inserted in-line with text, right between text characters. This feature is known as intra-text adornments. The content could be images, controls, or any other UI element.

See the Intra-Text Adornments topic for details on how to use this feature.

Hide text regions (without outlining)

Sometimes you may wish to hide a region of text within a SyntaxEditor view but still keep it in the document. This sort of feature can be attained by "tagging" the desired ranges to hide with ICollapsedRegionTag instances. This feature can be used independently from code outlining. In fact the code outlining feature does use this behind the scenes for collapsed nodes. If you tag the same collapsed regions with an IIntraTextSpacerTag, you can insert an adornment in place of the collapsed region.

See the Collapsing Regions without Outlining topic for details on how to use this feature.

Event notifications

There are a large number of events to which languages can be attached, everything from document text changes to end user input. Events are logically grouped into various event sink services.

Any service registered on a language that implements one of the event sink interfaces is automatically notified whenever a related event occurs.

Auto-indentation

Auto-indent is the ability for SyntaxEditor to automatically indent a new line when the Enter key is pressed. The default behavior is to indent a new line to the same level as the preceeding line.

To override the default behavior, an IIndentProvider service must be registered with the language.

Text formatting

Text formatting is the ability for SyntaxEditor to format the text in a specified range where whitespace and other symbols such as braces are adjusted to make code more readable.

See the Text Formatter topic for more information.

Structure matching (move to matching bracket, etc.)

Structure matching is the ability for SyntaxEditor to find a bracket or other text delimiter that is related to the delimiter that is next to the caret.

See the Structure Matcher topic for more information.

Delimiter highlighting (bracket highlighting)

Delimiter highlighting renders highlights behind delimiter pairs that are currently next to the caret, also known as bracket highlighting.

While the delimiter highlighting feature requires the use of a structure matcher (see above), it also requires that another language service is registered that can tag delimiter highlight ranges.

See the Delimiter Highlighting topic for more information.

Code block selection

Code block selection adjusts the view's selection by expanding it to include containing code blocks and contracting all the way back down to the caret as appropriate.

See the Code Block Selection topic for more information.

Auto-correct, and case correction

An auto-corrector can perform additional edits after text changes, such as auto-case correcting language keywords.

See the Auto-Corrector topic for more information.

Delimiter auto-completion

Delimiter auto-completion is where the user types a start delimiter and a related end delimiter is auto-inserted after the caret.

See the Delimiter Auto-Completer topic for more information.

Moving Forward

This walkthrough should point you in the right direction towards building a custom language. If at any time you find some of the documentation confusing, please contact us and let us know so that we may improve it in the future.

As next steps, look around at the other documentation for the product and examine the sample projects. We provide numerous language samples that you can freely copy and modify.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Creating an ISyntaxLanguage

Language Creation Guide
Creating an ISyntaxLanguage

The first step in building a language is the creation of a class that implements ISyntaxLanguage.

There are three main options for doing this, each of which are described below.

This topic contains these sections:

  • Option 1: Building a SyntaxLanguage Externally
  • Option 2: Creating a Custom Class that Inherits SyntaxLanguage
  • Option 3: Loading a Language Definition (.langdef File)

Option 1: Building a SyntaxLanguage Externally

For languages that only require a couple simple property settings, you may wish to construct the language on the fly. The SyntaxLanguage class implements the ISyntaxLanguage and can be used to accomplish this.

This code creates a language that uses a line commenter which can comment and uncomment lines with the text //.

C#
VB
Copy
​SyntaxLanguage language = new SyntaxLanguage("Dynamic");
// NOTE: Register lexer, parser, or other language services here
language.RegisterLineCommenter(new LineBasedLineCommenter() { StartDelimiter = "//" });
​Dim language As SyntaxLanguage = New SyntaxLanguage("Dynamic")
' NOTE: Register lexer, parser, or other language services here
language.RegisterLineCommenter(New LineBasedLineCommenter() With {.StartDelimiter = "//"})

Note Note
The SyntaxLanguageExtensions.RegisterLineCommenter method in the code snippet above is a helper extension method that get added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Since this language only has a couple options set, there is nothing wrong with defining it this way and using it. Generally, it is better design to use option 2 (below) for more complex languages.

Option 2: Creating a Custom Class that Inherits SyntaxLanguage

Many times language implementations are more complex that the sample illustrated in the previous option. It could be a case of additional configuration/processing needed or you may simply want to have your language completely encapsulated with a dedicated class.

Note Note
The Language Designer tool allows you to quickly configure information about your language. It can generate a lot of the C#/VB code needed to have a dedicated syntax language class and related features. Use of that application is the fastest way to get started making a syntax language.

In any event, if those scenarios apply to you, making a custom language class that inherits SyntaxLanguage is what you'd want to do. SyntaxLanguage implements ISyntaxLanguage and is a perfect base class for any custom language implementation.

This code defines a custom language class that inherits SyntaxLanguage:

C#
VB
Copy
​public class MyCustomSyntaxLanguage : SyntaxLanguage {
    public MyCustomSyntaxLanguage() : base("My Custom Language") {}
}
​Public Class MyCustomSyntaxLanguage
    Inherits SyntaxLanguage
    Public Sub New()
        MyBase.New("My Custom Language")
    End Sub
End Class

The next step would be to add code into your constructor that registers all the language services you wish for you language to provide (lexer, token tagger, line commenter, etc.).

C#
VB
Copy
​public class MyCustomSyntaxLanguage : SyntaxLanguage {
    public MyCustomSyntaxLanguage() : base("My Custom Language") {
        this.RegisterLexer(new MyCustomLexer());
        this.RegisterService(new TokenTaggerProvider<MyCustomTokenTagger>());
        this.RegisterLineCommenter(new LineBasedLineCommenter() { StartDelimiter = "//" });
    }
}
​Public Class MyCustomSyntaxLanguage
    Inherits SyntaxLanguage
    Public Sub New()
        MyBase.New("My Custom Language")

        Me.RegisterLexer(New MyCustomLexer())
        Me.RegisterService(New TokenTaggerProvider(Of MyCustomTokenTagger)())
        Me.RegisterLineCommenter(New LineBasedLineCommenter() With {.StartDelimiter = "//"})
    End Sub
End Class

Note Note
The SyntaxLanguageExtensions.RegisterLexer and SyntaxLanguageExtensions.RegisterLineCommenter methods in the code snippet above are helper extension methods that get added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

After that is complete, the language can be completely instantiated in one line of code:

C#
VB
Copy
​MyCustomSyntaxLanguage language = new MyCustomSyntaxLanguage();
​Dim language As MyCustomSyntaxLanguage = New MyCustomSyntaxLanguage()

Option 3: Loading a Language Definition (.langdef File)

The Language Designer application can be used to optionally create files with .langdef file extensions, which are language definitions. These language definition files can be distributed with your application, often in file form or as an embedded resource. They contain information about a language and can be loaded at run-time to automatically create and initialize a language.

Language definitions can be used to either:

  • Create a new ISyntaxLanguage from scratch that is initialized with data from the language definition, which is focus of this Option 3.
  • Initialize an existing ISyntaxLanguage, which means it can be used in both Option 1 and 2 scenarios listed above to supply the lexer, etc. instead of manually registering code-based ones

See the Loading a Language Definition (.langdef File) topic for details on how to load one of these files at run-time.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Loading a Language Definition (.langdef File)

Language Creation Guide
Loading a Language Definition (.langdef File)

The Language Designer application can be used to optionally create files with .langdef file extensions, which are language definitions. These language definition files can be distributed with your application, often in file form or as an embedded resource. They contain information about a language and can be loaded at run-time to automatically create and initialize a language.

Read the Language Designer's Getting Started topic for more information on language definitions and when to use them.

Language definition files may be loaded directly from a file, or from a Stream.

This topic contains these sections:

  • Option 1: Loading from a File
  • Option 2: Loading from a Stream
  • Initializing an Existing ISyntaxLanguage Instead

Option 1: Loading from a File

The benefit of distributing the language definition as a file with your application is that end users can modify the language definition if necessary.

This code creates a syntax language object based on a ECMAScript.langdef file:

C#
VB
Copy
​SyntaxLanguageDefinitionSerializer serializer = new SyntaxLanguageDefinitionSerializer();
string path = @"C:\ECMAScript.langdef";
ISyntaxLanguage language = serializer.LoadFromFile(path);
​Dim serializer As SyntaxLanguageDefinitionSerializer = New SyntaxLanguageDefinitionSerializer()
Dim path As String = "C:\ECMAScript.langdef"
Dim language As ISyntaxLanguage = serializer.LoadFromFile(path)

Now that an ISyntaxLanguage object has been created based on the language definition, it can be used.

Option 2: Loading from a Stream

A language definition can also be distributed in any other form, such as an embedded resource, or in a database. Once you have a Stream pointing to the language definition data, it can be loaded.

This code creates a syntax language object based on a Stream in the variable stream:

C#
VB
Copy
​SyntaxLanguageDefinitionSerializer serializer = new SyntaxLanguageDefinitionSerializer();
ISyntaxLanguage language = serializer.LoadFromStream(stream);
​Dim serializer As SyntaxLanguageDefinitionSerializer = New SyntaxLanguageDefinitionSerializer()
Dim language As ISyntaxLanguage = serializer.LoadFromStream(stream)

Now that an ISyntaxLanguage object has been created based on the language definition, it can be used.

Initializing an Existing ISyntaxLanguage Instead

The two loading methods described above load a language definition file and use it to create a new ISyntaxLanguage. However there could be scenarios where you already have an ISyntaxLanguage created but wish to initialize it with language definition data. An example of this is that maybe you wish to ship .langdef files with your app so that end users can customize them. However you have several additional language services (such as a parser) that need to get used on this language as well. In this scenario, you'd want the best of both worlds: to load the lexer, token tagger, and classification types from the .langdef and register your additional services for use as well.

This code snippet shows how a custom language class can be created that both initializes itself based on a .langdef file and also adds additional services.

C#
VB
Copy
​public class EcmaScriptSyntaxLanguage : SyntaxLanguage {
    public EcmaScriptSyntaxLanguage() : base("ECMAScript") {
        // Use a SyntaxLanguageDefinitionSerializer to load a lexer, token tagger, etc. from a .langdef file
        new SyntaxLanguageDefinitionSerializer().InitializeFromFile("C:\ECMAScript.langdef");

        // Register additional services
        this.RegisterParser(new EcmaScriptParser());
        this.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
    }
}
​Public Class EcmaScriptSyntaxLanguage
    Inherits SyntaxLanguage
    Public Sub New()
        MyBase.New("ECMAScript")
        ' Use a SyntaxLanguageDefinitionSerializer to load a lexer, token tagger, etc. from a .langdef file
        CType(New SyntaxLanguageDefinitionSerializer(), SyntaxLanguageDefinitionSerializer).InitializeFromFile("C:\ECMAScript.langdef")

        ' Register additional services
        Me.RegisterParser(New EcmaScriptParser())
        Me.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))
    End Sub
End Class

The language can then be instantiated like this:

C#
VB
Copy
​EcmaScriptSyntaxLanguage language = new EcmaScriptSyntaxLanguage();
​Dim language As EcmaScriptSyntaxLanguage = New EcmaScriptSyntaxLanguage()

The SyntaxLanguageDefinitionSerializer class has:

  • An InitializeFromStream method for initializing an existing syntax language from a Stream, and

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Service Locator Architecture

Language Creation Guide
Service Locator Architecture

Syntax languages are architected using the Service Locator design pattern, which keeps the ISyntaxLanguage interface small while still allowing for powerful extensibility of features.

Language features such as lexing, token tagger providers, line commenters, etc. can be registered as services on each language instance. Certain service types are well known and extension methods provide easy access to the built-in feature services. Any sort of custom service can be registered with a language and retrieved later as well.

This topic contains these sections:

  • What is the Service Locator Design Pattern?
  • Built-In Service Types
  • Helper Extension Methods, and Requirements for Usage
  • Service Add/Remove Events
  • Sample: Registering a Lexer
  • Sample: Retrieving a Lexer
  • Sample: Registering a Completion Provider
  • Sample: Retrieving a Completion Provider

What is the Service Locator Design Pattern?

Our implementation of the Service Locator designer pattern contains four types of methods, two types for registering and unregistering services with a language, and two types for retrieving registered services from a language.

The ISyntaxLanguage.RegisterService and UnregisterService methods are used to register and unregister services with a language. Once a service has been registered with a language, it can be retrieved via the GetService method. That method requires you to pass the service type you are trying to retrieve (see built-in service types table below). To get a collection of all service types that have been registered with a language, use the GetAllServiceTypes method.

The methods described above are generic and allow for any sort of service to be registered with a language. Helper extension methods are available that wrap these generic calls and make it easy to work with the built-in feature service types. Examples of both the extension method calls and generic service method calls are included later in this topic.

Note Note
If no type parameter is passed to the RegisterService method, then the service being registered will be registered under its own Type as the key.

Built-In Service Types

While you can customize a syntax language with any custom services you like, there are a number of built-in service types are that recognized, and they come in three varieties.

Feature Service Types

Many service types require that a service providing a certain function are registered using a specific Type key. These service types are referred to as "feature services", and only one instance of these service types can be registered on a language.

For instance, in order for our code to locate the lexer for the language, we require that the service implementing ILexer is registered with the service Type key ILexer. If the service is registered under any other key, then our code can't locate it.

This table lists the built-in single-instance service types that can be used when adding features to an ISyntaxLanguage. The Service Type column indicates the service Type key that must be used when registering them. Only one of these services may be registered per language instance.

Service Type | Description
IAutoCorrector | Designates the auto-corrector that can perform additional edits after text changes, such as auto-case correcting language keywords.
IDelimiterAutoCompleter | Designates the delimiter auto-completer that can insert end delimiters when a start delimiter is typed by the end user.
IExampleTextProvider | Designates the example text provider that returns a code snippet which can be displayed in an application to show sample code syntax.
IIndentProvider | Designates the indent provider that performs automatic indentation of text when the Enter key is pressed.
ILexer | Designates the lexer that tokenizes text for the language.
ILineCommenter | Designates the line commenter that is capable of commenting and uncommenting lines or a range of text.
INavigableSymbolProvider | Designates the navigable symbol provider that lists the accessible symbols within a document.
IOutliner | Designates the outliner that allows a language to provide automatic outlining (code folding) for a document.
IParser | Designates the parser that performs syntax and/or semantic analysis on code and often returns parse data such as an abstract syntax tree (AST), list of syntax errors, symbol table, etc.
IStructureMatcher | Designates the structure matcher that can locate matching structural text delimiters, such as brackets.
ITextFormatter | Designates the text formatter that adjusts whitespace and other symbols such as braces on a specified text range to make code more readable.
ITextStatisticsFactory | Designates the text statistics factory that is capable of creating customized ITextStatistics objects for a language.
IWordBreakFinder | Designates the word break finder that locates word starts and ends for the language.

Provider Service Types

The next variety of service types is related to being able to provide data for a language. Unlike "feature" services, more than one "provider" service can be registered on a language.

It doesn't matter which service Type key a service is registered under. Therefore if any registered service implements one of these interfaces, it will be used. But be careful to not register more than one service with the same Type key, or else the existing service that with Type key will be removed.

This table lists the built-in multiple-instance service types that can be used when adding providers to an ISyntaxLanguage. The Service Type column indicates the interface that must be implemented by the service for it to be used, however as mentioned above, the service can be registered using any Type key.

Service Type | Description
ICodeSnippetProvider | Designates the code snippet provider that can open display available code snippets for selection and activate a code snippet template session within an editor view.
ICompletionProvider | Designates the completion provider that can open an IntelliPrompt completion session within an editor view, generally initiated by a Ctrl+Space.
IParameterInfoProvider | Designates the parameter info provider that can open an IntelliPrompt parameter info session within an editor view.
IQuickInfoProvider | Designates the quick info provider that can open an IntelliPrompt quick info session within an editor view, generally initiated by mouse hovering.

Event Sink Service Types

The final variety of service types is called "event sinks" and these service types receive various event notifications and process them. Events could be anything from editor view input events to document text change events.

Event sink service types are registered similarly to the rules described in the Provider Service Types section above, where multiple event sinks that have the same interfaces can be registered on a language. To sum up, if any object registered as a service implements one or more of the event sink interfaces, it will be notified when related events occur.

Note Note
See the Event Sinks topic for a list of the built-in event sink service types and what each can do.

Helper Extension Methods, and Requirements for Usage

The SyntaxLanguageExtensions static class contains numerous extension methods that are available on any ISyntaxLanguage instance when the ActiproSoftware.Text namespace is imported. These extension methods wrap the generic service locator methods and implement Register, Unregister, and Get methods for each of the built-in "feature" service types described above.

While it is not necessary to use them since you can just use the core generic service locator methods, they keep your code cleaner and give you some prompting via the Visual Studio member list for which service types are available.

Service Add/Remove Events

The ISyntaxLanguage interface defines two events that provide notifications of when services are added to or removed from a language.

The ServiceAdded event fires whenever a service is added to the language. Likewise the ServiceRemoved event fires whenever a service is removed from the language.

Sample: Registering a Lexer

This section shows some examples of registering a lexer feature service with a language, both via an extension method and generically.

This code registers a lexer in the myLexer variable with a language using a helper extension method:

C#
VB
Copy
​language.RegisterLexer(myLexer);
​language.RegisterLexer(myLexer)

This code registers a lexer in the myLexer variable with a language generically:

C#
VB
Copy
​language.RegisterService<ILexer>(myLexer);
​language.RegisterService(Of ILexer)(myLexer)

Sample: Retrieving a Lexer

This section shows some examples of retrieving a registered lexer service from a language, both via an extension method and generically.

This code retrieves a lexer from a language using a helper extension method:

C#
VB
Copy
​ILexer lexer = language.GetLexer();
​Dim lexer As ILexer = language.GetLexer()

This code retrieves a lexer from a language generically:

C#
VB
Copy
​ILexer lexer = language.GetService<ILexer>();
​Dim lexer As ILexer = language.GetService(Of ILexer)()

Sample: Registering a Completion Provider

This section shows how to register an object as a service that implements ICompletionProvider. Note that since languages can have mutiple objects registered that implement this interface, we will register the service using the object's type.

This code registers an object of type CustomCompletionProvider in the myCompletionProvider variable with a language, using its type:

C#
VB
Copy
​language.RegisterService<CustomCompletionProvider>(myCompletionProvider);
​language.RegisterService(Of CustomCompletionProvider)(myCompletionProvider)

This code does the same thing but the Type key is automatically pulled via reflection, based on the Type of the object referenced by myCompletionProvider. Note that this shortcut cannot be used with "feature" services because those must be registered using the specific interface types described in the table above.

C#
VB
Copy
​language.RegisterService(myCompletionProvider);
​language.RegisterService(myCompletionProvider)

Sample: Retrieving a Completion Provider

This section shows how to retrieve the CustomCompletionProvider class instance that was registered in the previous sample.

C#
VB
Copy
​CustomCompletionProvider provider = language.GetService<CustomCompletionProvider>();
​Dim provider As CustomCompletionProvider = language.GetService(Of CustomCompletionProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Language Creation Guide - Feature Services
Overview

Syntax languages have a wide array of optional features that can be implemented to enhance their capabilities when used with SyntaxEditor.

This topic contains these sections:

  • Lexer
  • Parser
  • Outliner
  • Line Commenter
  • Example Text
  • Text Statistics
  • Word Break Finder
  • Indent Provider (Auto-Indent)
  • Text Formatter
  • IntelliPrompt Navigable Symbol Provider
  • Structure Matcher
  • Code Block Finder
  • Auto-Corrector
  • Delimiter Auto-Completer

Lexer

A lexer is the lowest-level key piece of a syntax language. It examines a stream of text and parses it into tokens that give text ranges meaning. Tokens are then used to support many other language features such as classification.

See the Lexer topic for more information.

Parser

A parser is something that performs syntax and/or semantic analysis on code and often returns parse data such as an abstract syntax tree (AST), list of syntax errors, symbol table, etc. Syntax languages can have parsers registered with them that get called automatically via worker threads when text changes in code documents occur.

See the Parser topic for more information.

Outliner

An outliner returns a language-specific outlining source for a particular ITextSnapshot when requested by an outlining manager. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

See the Outliner topic for more information.

Line Commenter

Syntax languages support line commenters, which provide built-in functionality for commenting and uncommenting text based on language-specific delimiters.

See the Line Commenter topic for more information.

Example Text

Syntax languages have to ability to expose a small code snippet showing many of the constructs in the language.

See the Example Text topic for more information.

Text Statistics

While the text/parsing framework includes an implementation of text statistics that provides the most common statistics for text, sometimes it's useful to create custom statistics classes that are tailored to a particular language and can return additional statistics such as comment coverage.

See the Text Statistics topic for more information.

Word Break Finder

While most languages use the same criteria for locating word breaks, some languages like may wish to include a @ character as the start of a word.

See the Word Break Finder topic for more information.

Indent Provider (Auto-Indent)

Syntax languages support indent providers, which provide functionality for auto-indentation of the code when the Enter key is pressed.

See the Indent Provider (Auto-Indent) topic for more information.

Text Formatter

Syntax languages support text formatters, which provide functionality for formatting the layout of whitespace and symbols such as braces to make code more readable.

See the Text Formatter topic for more information.

IntelliPrompt Navigable Symbol Provider

Languages can choose to support an IntelliPrompt navigable symbol provider that lists the accessible symbols within an editor's document. Once a language implements this provider service, the Navigable Symbol Selector control can be paired with a SyntaxEditor to provide VS type/member dropdown-like functionality.

See the IntelliPrompt Navigable Symbol Provider topic for more information.

Structure Matcher

Syntax languages support structure matchers, which provide functionality for locating matching structural text delimiters, such as brackets.

See the Structure Matcher topic for more information.

Code Block Finder

A code block finder finds the snapshot range of a logical code block that contains a specified snapshot range. This service is used to drive the Code Block Selection feature.

See the Code Block Finder topic for more information.

Auto-Corrector

An auto-corrector is a language service that typically occurs after text changes and can fix up things like character casing.

A pre-built class is available that can help add automatic case correction to a language.

See the Auto-Corrector topic for more information.

Delimiter Auto-Completer

A delimiter auto-completer is a language service that can insert an end delimiter when its related start delimiter is typed.

A pre-built class is available that performs nearly all the work of this feature.

See the Delimiter Auto-Completer topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lexer

Language Creation Guide - Feature Services
Lexer

A lexer is the lowest-level key piece of a syntax language. It examines a stream of text and parses it into tokens that give text ranges meaning. Tokens are then used to support many other language features such as classification.

This topic contains these sections:

  • Creating a Lexer for a Language
  • Registering a Lexer with a Language

Creating a Lexer for a Language

The first step when creating a syntax language is to create its lexer.

Please see the text/parsing framework's Lexing series of topics for details on the various types of lexers and the benefits/drawbacks of each.

Once a lexer has been written, it needs to be associated with the language.

Registering a Lexer with a Language

Associating a lexer with a language is done by registering the lexer instance as an ILexer service on the language.

This code, called from a syntax language constructor, assigns a programmatic lexer named MyLexer to the language:

C#
VB
Copy
​public MySyntaxLanguage() {
    this.RegisterLexer(new MyLexer());
}
​Public Sub New()
    Me.RegisterLexer(New MyLexer())
End Sub

Note Note
The SyntaxLanguageExtensions.RegisterLexer method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parser

Language Creation Guide - Feature Services
Parser

A parser is something that performs syntax and/or semantic analysis on code and often returns parse data such as an abstract syntax tree (AST), list of syntax errors, symbol table, etc. Syntax languages can have parsers registered with them that get called automatically via worker threads when text changes in code documents occur.

This topic contains these sections:

  • Creating a Parser for a Language
  • Registering a Parser with a Language

Creating a Parser for a Language

Please see the text/parsing framework's Parsing series of topics for details on how to create a parser.

Once a parser has been written, it needs to be associated with the language.

Registering a Parser with a Language

Associating a parser with a language is done by registering the parser instance as an IParser service on the language.

This code, called from a syntax language constructor, assigns a parser named MyParser to the language:

C#
VB
Copy
​public MySyntaxLanguage() {
    this.RegisterParser(new MyParser());
}
​Public Sub New()
    Me.RegisterParser(New MyParser())
End Sub

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Outliner

Language Creation Guide - Feature Services
Outliner

An outliner returns a language-specific outlining source for a particular ITextSnapshot when requested by an outlining manager. Having an outliner service registered on a language is what tells SyntaxEditor that the language supports automatic outlining.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Outliners are classes implementing IOutliner that provide outlining manager with IOutliningSource objects upon request. Each outliner designated whether the automatic outlining should be performed in the main UI thread when any text change occurs, or if it should be performed in response to a parse data update.

See the Outlining Sources and Outliners topic for details on how to create and work with outlining sources and outliners.

When an outliner is associated with a syntax language, SyntaxEditor knows that the language supports automatic outlining.

Registering with a Language

Any object that implements IOutliner can be associated with a syntax language by registering it as an IOutliner service on the language.

This code creates an outliner for a TokenOutliningSourceBase-based outlining source named JavascriptOutliningSource, and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​TokenOutliner<JavascriptOutliningSource> source = new TokenOutliner<JavascriptOutliningSource>();
language.RegisterOutliner(source);
​Dim source As TokenOutliner(Of JavascriptOutliningSource) = New TokenOutliner(Of JavascriptOutliningSource)()
language.RegisterOutliner(source)

Note Note
The SyntaxLanguageExtensions.RegisterOutliner method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Line Commenter

Language Creation Guide - Feature Services
Line Commenter

Syntax languages support line commenters, which provide built-in functionality for commenting and uncommenting text based on language-specific delimiters.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Line commenters are classes implementing ILineCommenter that can comment or comment a range of text. The text/parsing framework includes two implementations of line commenters: one that comments out a specific line (like C#'s //) and one that comments out a specific range of text (like XML's <!-- -->).

See the Line Commenting topic for details on how to create and work with line commenter classes.

When a line commenter is associated with a syntax language, SyntaxEditor can take advantage of it to implement its comment and uncomment lines feature.

Registering with a Language

Any object that implements ILineCommenter can be associated with a syntax language by registering it as an ILineCommenter service on the language.

This code creates a line commenter for C# style comments and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​LineBasedLineCommenter commenter = new LineBasedLineCommenter();
commenter.StartDelimiter = "//";
language.RegisterLineCommenter(commenter);
​Dim commenter As LineBasedLineCommenter = New LineBasedLineCommenter()
commenter.StartDelimiter = "//"
language.RegisterLineCommenter(commenter)

Note Note
The SyntaxLanguageExtensions.RegisterLineCommenter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Example Text

Language Creation Guide - Feature Services
Example Text

Syntax languages have to ability to expose a small code snippet showing many of the constructs in the language.

This can be used in options dialogs to show the current classifications / syntax highlighting settings affect a particular language. In this case, it is best to use code the shows all the various classifications and related highlighting styles.

Basic Concepts

The IExampleTextProvider interface is a simple interface that describes an ExampleText property. The property simply returns a code snippet that can be used by a language for example text purposes.

The ExampleTextProvider class implements the IExampleTextProvider interface and provides an easy way to associate example text with your languages.

Registering with a Language

Any object that implements IExampleTextProvider can be associated with a syntax language by registering it as an IExampleTextProvider service on the language.

This code creates XML example text and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterExampleTextProvider(new ExampleTextProvider("<xml></xml>"));
​language.RegisterExampleTextProvider(New ExampleTextProvider("<xml></xml>"))

Note Note
The SyntaxLanguageExtensions.RegisterExampleTextProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Statistics

Language Creation Guide - Feature Services
Text Statistics

While the text/parsing framework includes an implementation of text statistics that provides the most common statistics for text, sometimes it's useful to create custom statistics classes that are tailored to a particular language and can return additional statistics such as comment coverage.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Text statistics are classes that implement ITextStatistics and return numerous statistics about text such as character/line counts, whitespace percentage, etc. The TextStatistics class provides the default implementation of that interface.

See the text/parsing framework's Text Statistics topic for details on how to create and work with text statistics classes.

Registering with a Language

Any object that implements ITextStatisticsFactory can be associated with a syntax language by registering it as an ITextStatisticsFactory service on the language.

Normally a custom factory that creates custom statistics does not need to be implemented. The exception would be if you created a custom ITextStatistics class for your language and would like to use that instead of the default statistics.

This code registers a make-believe custom text statistics factory named CustomTextStatisticsFactory (that creates a make-believe CustomTextStatistics class) with a syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextStatisticsFactory(new CustomTextStatisticsFactory());
​language.RegisterTextStatisticsFactory(New CustomTextStatisticsFactory())

Note Note
The SyntaxLanguageExtensions.RegisterTextStatisticsFactory method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Word Break Finder

Language Creation Guide - Feature Services
Word Break Finder

While most languages use the same criteria for locating word breaks, some languages like may wish to include a @ character as the start of a word.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Word break finders are classes that implement IWordBreakFinder and navigate text to locate word breaks. The text/parsing framework includes a DefaultWordBreakFinder class that implements IWordBreakFinder using the most common word break finding logic that suits most languages fine.

When making a custom word break finder, the members of IWordBreakFinder must be implemented. The FindCurrentWordStart, FindCurrentWordEnd, FindPreviousWordStart, and FindNextWordStart methods each accept a TextSnapshotOffset that indicates the ITextSnapshot and offset within that snapshot at which to begin scanning. Those methods all return an integer indicating the offset within the same snapshot at which the appropriate word break was found.

Registering with a Language

Any object that implements IWordBreakFinder can be associated with a syntax language by registering it as an IWordBreakFinder service on the language.

The SyntaxLanguage class automatically registers a DefaultWordBreakFinder with itself when it is created, so normally word break finders never need to be set on a language unless a custom one is made.

This code creates a custom word break finder (defined in a make-believe CustomWordBreakFinder class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterWordBreakFinder(new CustomWordBreakFinder());
​language.RegisterWordBreakFinder(New CustomWordBreakFinder())

Note Note
The SyntaxLanguageExtensions.RegisterWordBreakFinder method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider (Auto-Indent)

Language Creation Guide - Feature Services
Indent Provider (Auto-Indent)

Syntax languages support indent providers, which provide functionality for auto-indentation of the code when the Enter key is pressed.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Indent providers are classes that implement IIndentProvider that can automatically indent text when the Enter key is pressed.

See the Indent Providers topic for details on how to create and work with indent provider classes.

When an indent provider is associated with a syntax language, SyntaxEditor can take advantage of it to implement its auto-indentation feature.

Registering with a Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

This code creates an XML indent provider and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlIndentProvider indentProvider = new XmlIndentProvider();
language.RegisterIndentProvider(indentProvider);
​Dim indentProvider As XmlIndentProvider = New XmlIndentProvider()
language.RegisterIndentProvider(indentProvider)

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

Language Creation Guide - Feature Services
Text Formatter

Syntax languages support text formatters, which provide functionality for formatting the layout of whitespace and symbols such as braces to make code more readable.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Text formatters are classes implementing ITextFormatter that can format a specified range of text. Formatting involves adjusting the layout of whitespace and symbols such as braces to make code more readable.

See the Text Formatting topic for details on how to create and work with text formatter classes.

Registering with a Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

This code creates an XML text formatter and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​XmlFormatter textFormatter = new XmlFormatter();
language.RegisterTextFormatter(textFormatter);
​Dim textFormatter As XmlFormatter = New XmlFormatter()
language.RegisterTextFormatter(textFormatter)

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Navigable Symbol Provider

Language Creation Guide - Feature Services
IntelliPrompt Navigable Symbol Provider

Languages can choose to support an IntelliPrompt navigable symbol provider that lists the accessible symbols within an editor's document. Once a language implements this provider service, the Navigable Symbol Selector control can be paired with a SyntaxEditor to provide VS type/member dropdown-like functionality.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Navigable Symbols

Navigable symbols are any object that implements the INavigableSymbol interface. The NavigableSymbol class is a default implementation. Symbols represents a type or member within a document's text. They each provide these bits of information:

Member | Description
ContentProvider Property | Gets a Content Provider that creates the content to render for the symbol within UI.
NavigationSnapshotOffset Property | Gets the TextSnapshotOffset within the symbol's source file to navigate when the symbol is selected.
SnapshotRange Property | Gets a TextSnapshotRange indicating the offset range of the symbol within its source file.

So for instance in a C# language, a symbol that represented a class declaration would have a content provider that listed the name of the class, a navigation snapshot offset that was the offset of the class name within the document, and a snapshot range that covered everything from the type's XML comments through to its closing curly brace.

Navigable Request Contexts

When an INavigableSymbolProvider is called to obtain accessible symbols, it is passed an INavigableRequestContext object. This object provides additional information about what is requesting the symbols.

The NavigableRequestContexts.NavigableSymbolSelector is currently the only pre-defined request context, and indicates that a Navigable Symbol Selector control is making the request.

Navigable Symbol Provider

The INavigableSymbolProvider interface is the language service used to return accessible symbols to callers. It has a single GetSymbols method that takes in:

  • An INavigableRequestContext indicating the source of the request.
  • An ITextSnapshot that is the snapshot to examine.
  • An optional parent INavigableSymbol to examine.

If the parent symbol is a null value, it means the request is for all root symbols within the document. If a parent symbol is specified, then the request is for the members of that root symbol.

The ITextSnapshot provides access to its container ICodeDocument, and via that, the document's parse data, which usually contains information such as an AST. That is assuming that the language has a parser that constructs an AST.

The GetSymbols method implementation should use information such as the AST to create INavigableSymbol objects based on the parameters passed in, and then return those symbols. By doing so, controls such as Navigable Symbol Selector can consume this information and provide an advanced editing experience for end users.

This code shows a sample GetSymbols implementation. It assumes that whatever type you use for parse data (in this case our ILLParseData type) has an AST available. Then it calls a AddTypeSymbolsFromAst or AddMemberSymbolsFromAst method (both would need implementation based on your language) and passes along the relevant information needed to build the symbol list.

C#
VB
Copy
​public IEnumerable<INavigableSymbol> GetSymbols(INavigableRequestContext context, ITextSnapshot snapshot, INavigableSymbol parentSymbol) {
    if (context == NavigableRequestContexts.NavigableSymbolSelector) {
        var document = snapshot.Document as ICodeDocument;
        if (document != null) {
            // If there is AST data...
            var parseData = document.ParseData as ILLParseData;
            if ((parseData != null) && (parseData.Ast != null)) {
                // Recurse into the AST
                var symbols = new List<INavigableSymbol>();
                if (parentSymbol != null)
                    this.AddMemberSymbolsFromAst(symbols, parseData.Snapshot ?? snapshot, parseData.Ast, parentSymbol);
                else
                    this.AddTypeSymbolsFromAst(symbols, parseData.Snapshot ?? snapshot, parseData.Ast);

                // Sort (navigationSymbolComparer is a cached NavigableSymbolContentProviderComparer instance)
                symbols.Sort(navigationSymbolComparer);

                return new NavigableSymbolSet(symbols);
            }
        }
    }

    // No results
    return new NavigableSymbolSet(null);
}
​Public Function GetSymbols(ByVal context As INavigableRequestContext, ByVal snapshot As ITextSnapshot, ByVal parentSymbol As INavigableSymbol) As IEnumerable(Of INavigableSymbol)
    If context Is NavigableRequestContexts.NavigableSymbolSelector Then
        Dim document = TryCast(snapshot.Document, ICodeDocument)
        If document IsNot Nothing Then
            ' If there is AST data...
            Dim parseData = TryCast(document.ParseData, ILLParseData)
            If (parseData IsNot Nothing) AndAlso (parseData.Ast IsNot Nothing) Then
                ' Recurse into the AST
                Dim symbols = New List(Of INavigableSymbol)()
                If parentSymbol IsNot Nothing Then
                    Me.AddMemberSymbolsFromAst(symbols, If(parseData.Snapshot, snapshot), parseData.Ast, parentSymbol)
                Else
                    Me.AddTypeSymbolsFromAst(symbols, If(parseData.Snapshot, snapshot), parseData.Ast)
                End If

                ' Sort (navigationSymbolComparer is a cached NavigableSymbolContentProviderComparer instance)
                symbols.Sort(navigationSymbolComparer)

                Return New NavigableSymbolSet(symbols)
            End If
        End If
    End If

    ' No results
    Return New NavigableSymbolSet(Nothing)
End Function

Registering with a Language

Any object that implements INavigableSymbolProvider can be associated with a syntax language by registering it as an INavigableSymbolProvider service on the language.

This code creates a custom navigable symbol provider and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​INavigableSymbolProvider provider = new CustomNavigableSymbolProvider();
language.RegisterNavigableSymbolProvider(provider);
​Dim provider As INavigableSymbolProvider = New CustomNavigableSymbolProvider()
language.RegisterNavigableSymbolProvider(provider)

Note Note
The SyntaxLanguageExtensions.RegisterNavigableSymbolProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Structure Matcher

Language Creation Guide - Feature Services
Structure Matcher

Syntax languages support structure matchers, which provide functionality for locating matching structural text delimiters, such as brackets.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Structure matchers are classes implementing IStructureMatcher that can scan through text and tokens to find a pair or set of related text delimiters, most often brackets. Once the language service is implemented for structure matching, SyntaxEditor features such as move to matching bracket and select to matching bracket are automatically supported.

See the Structure Matching topic for details on how to create and work with structure matcher classes.

Registering with a Language

Any object that implements IStructureMatcher can be associated with a syntax language by registering it as an IStructureMatcher service on the language.

This code creates a StructureMatcher object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​StructureMatcher matcher = new StructureMatcher();
language.RegisterStructureMatcher(matcher);
​Dim matcher As StructureMatcher = New StructureMatcher()
language.RegisterStructureMatcher(matcher)

Note Note
The SyntaxLanguageExtensions.RegisterStructureMatcher method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Block Finder

Language Creation Guide - Feature Services
Code Block Finder

A code block finder finds the snapshot range of a logical code block that contains a specified snapshot range. This service is used to drive the Code Block Selection feature.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Code block finders are classes implementing ICodeBlockFinder that can scan through text, tokens, or AST data to locate the snapshot range of a code block that contains the specified snapshot range. Once the code block finder language service is implemented, SyntaxEditor's Code Block Selection feature can be used.

Registering with a Language

Any object that implements ICodeBlockFinder can be associated with a syntax language by registering it as an ICodeBlockFinder service on the language.

This code creates a LLParseDataCodeBlockFinder object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​LLParseDataCodeBlockFinder finder = new LLParseDataCodeBlockFinder();
language.RegisterCodeBlockFinder(matcher);
​Dim finder As LLParseDataCodeBlockFinder = New LLParseDataCodeBlockFinder()
language.RegisterCodeBlockFinder(finder)

Note Note
The SyntaxLanguageExtensions.RegisterCodeBlockFinder method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Auto-Corrector

Language Creation Guide - Feature Services
Auto-Corrector

An auto-corrector is a language service that typically occurs after text changes and can fix up things like character casing.

A pre-built class is available that can help add automatic case correction to a language.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language
  • Disabling Auto-Correct

Basic Concepts

Auto-correctors are classes implementing IAutoCorrector with an AutoCorrect method that performs some modification of text over the specified range.

AutoCorrectorBase Class

An abstract AutoCorrectorBase class is available that implements IAutoCorrector, providing a great starting point for an auto-corrector. This class watches for document text changes and caret moves. If a document text change spans multiple lines, auto-correct is immediately called for the affected lines. If a document text change occurs on a single line, a flag is set. When the caret moves to a new line, auto-correct is called for the previously modified line.

All the an inheritor class needs to implement is an override for the AutoCorrect method to perform the actual auto-correct logic.

AutoCaseCorrector Class

The AutoCaseCorrector class inherits AutoCorrectorBase and implements auto-correct behavior to cycle over the tokens in the specified range.

The GetCaseCorrectText method is passed the current ITextSnapshot and the IToken to examine. It returns a string value if there is some auto-correction of text that should be made. It can return null to indicate no auto-correct change is necessary.

The method is virtual and its default implementation looks to see if the token is an IMergableToken. If so, it checks to see if the token didn't match its source lexical pattern in a case sensitive way. In that scenario, it returns the IMergableToken.AutoCaseCorrectText value.

Thus the AutoCaseCorrector can be registered on any language that uses a dynamic lexer and it will work out of the box to provide case correction functionality. Note that the lexer must have some lexical patterns' case sensitivities marked as auto-correct.

For more advanced programmatic lexers, as long as they are mergable, this class can still provide a good base for an auto-case corrector. Simply override the GetCaseCorrectText method and implement logic to determine if the token was a case sensitive match. If it wasn't, return the auto-case corrected text to use.

Registering with a Language

Any object that implements IAutoCorrector can be associated with a syntax language by registering it as an IAutoCorrector service on the language.

This code creates an AutoCaseCorrector object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​AutoCaseCorrector corrector = new AutoCaseCorrector();
language.RegisterAutoCorrector(corrector);
​Dim corrector As AutoCaseCorrector = New AutoCaseCorrector()
language.RegisterAutoCorrector(corrector)

Note Note
The SyntaxLanguageExtensions.RegisterAutoCorrector method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling Auto-Correct

Auto-correct can be disabled within a SyntaxEditor instance by setting the SyntaxEditor.IsAutoCorrectEnabled property to false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Delimiter Auto-Completer

Language Creation Guide - Feature Services
Delimiter Auto-Completer

A delimiter auto-completer can insert an end delimiter when its related start delimiter is typed. This service is used to drive the Delimiter Auto-Completion feature.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language

Basic Concepts

Delimiter auto-completers are classes implementing IDelimiterAutoCompleter that can auto-complete an end delimiter when a start delimiter is typed by the end user. See the Delimiter Auto-Completion topic for details on this feature and how the built-in DelimiterAutoCompleter works.

Registering with a Language

Any object that implements IDelimiterAutoCompleter can be associated with a syntax language by registering it as an IDelimiterAutoCompleter service on the language.

This code creates a DelimiterAutoCompleter object and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​DelimiterAutoCompleter completer = new DelimiterAutoCompleter();
language.RegisterDelimiterAutoCompleter(completer);
​Dim completer As DelimiterAutoCompleter = New DelimiterAutoCompleter()
language.RegisterDelimiterAutoCompleter(completer)

Note Note
The SyntaxLanguageExtensions.RegisterDelimiterAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Language Creation Guide - Provider Services
Overview

Syntax languages can register multiple instances of service objects implementing provider interfaces. These provider interfaces can help drive features like tagging, adornments, and IntelliPrompt.

This topic contains these sections:

  • Tagger Provider
  • Adornment Manager Provider
  • IntelliPrompt Completion Provider
  • IntelliPrompt Quick Info Provider
  • IntelliPrompt Parameter Info Provider
  • IntelliPrompt Code Snippet Provider

Tagger Provider

Tagger provider services allow taggers to be created for a document or view. Each language should provide a token tagger for documents using the language. Token taggers read tokens from the language's lexer and marks them with a logical categorization such as Identifier, Keyword, Comment, or anything else. These classifications can then be translated to highlighting styles, thereby achieving syntax highlighting in SyntaxEditor.

See the Tagger Provider topic for more information.

Adornment Manager Provider

Adornment manager provider services allow adornment layers to be created for a view.

See the Adornment Manager Provider topic for more information.

IntelliPrompt Completion Provider

Languages can choose to support IntelliPrompt completion lists and respond to Ctrl+Space.

See the IntelliPrompt Completion Provider topic for more information.

IntelliPrompt Quick Info Provider

Languages can choose to support IntelliPrompt quick info popups that are automatically displayed when the mouse moves over text and/or other parts of the editor, such as margins.

See the IntelliPrompt Quick Info Provider topic for more information.

IntelliPrompt Parameter Info Provider

Languages can choose to support IntelliPrompt parameter info popups that are automatically displayed when the end user types an invocation, and can provide additional information about the current parameter.

See the IntelliPrompt Parameter Info Provider topic for more information.

IntelliPrompt Code Snippet Provider

Languages can choose to support IntelliPrompt code snippets that provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

See the IntelliPrompt Code Snippet Provider topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tagger Provider

Language Creation Guide - Provider Services
Tagger Provider

Tagger provider services allow taggers to be created for a document or view. Each language should provide a token tagger for documents using the language. Token taggers read tokens from the language's lexer and marks them with a logical categorization such as Identifier, Keyword, Comment, or anything else. These classifications can then be translated to highlighting styles, thereby achieving syntax highlighting in SyntaxEditor.

This topic contains these sections:

  • What are Taggers?
  • Token Taggers and Syntax Highlighting
  • Registering with a Syntax Language

What are Taggers?

Taggers are objects that can apply data (in the form of tags) over various text ranges. This data could be anything from classifications, to squiggle tags, and more. Since each tagger can only be associated with a single document or view, tagger provider services are used to create taggers for documents/views upon request.

See the Taggers and Tagger Providers topic for details on how taggers and providers work.

Taggers are used for many features of SyntaxEditor including being involved in:

  • Classification
  • Syntax highlighting
  • Snapshot reading by token
  • Squiggle lines
  • Adornment layer managers

Token Taggers and Syntax Highlighting

As mentioned above, token taggers are special classes that are used to provide classification and token tags. When working with an editor like SyntaxEditor, the token tagger reads tags from the language's lexer and can return associated classifications, that are mapped to highlighting styles and used to achieve syntax highlighting.

Therefore if you need syntax highlighting, your language must have a lexer service, a token tagger provider service, and must have set up classification types to have mapped to highlighting styles in the ambient highlighting style registry.

Registering with a Syntax Language

As described in the Taggers and Tagger Providers topic, CodeDocumentTaggerProvider`1, TextViewTaggerProvider`1, and TokenTaggerProvider`1 objects can be used as language services to provide taggers to any tag aggregator that request them.

This code shows how to register a document-oriented tagger provider language service that provides ParseErrorTagger objects for documents that use the language. Note that we are also passing a "singleton" key so that the tagger that is created for any document using the language is persisted in the document's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
​language.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))

This code shows how to register a document-oriented token tagger provider language service. Token taggers automatically persist themselves in the document's Properties dictionary while they are active. Only one token tagger provider service should ever be registered on a language instance at a time.

C#
VB
Copy
​language.RegisterService(new TokenTaggerProvider<TokenTagger>());
​language.RegisterService(New TokenTaggerProvider(Of TokenTagger)())

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Adornment Manager Provider

Language Creation Guide - Provider Services
Adornment Manager Provider

Adornment manager provider services allow adornment layers to be created for a view.

This topic contains these sections:

  • What are Adornment Managers?
  • Registering with a Syntax Language

What are Adornment Managers?

Adornment managers are objects that create an adornment layer and add/update/remove adornment objects within the layer. Layers can be ordered around any other layer (text foreground, selection, etc.) and adornments can consist of any element. This allows for any sort of custom content to be rendered within the text area. Since each adornment manager can only be associated with a single view, adornment manager provider services are used to create adornment managers for views upon request.

See the Adornment Layers topic for details on how adornments, adornment layers, and providers work.

Adornment managers are used for rendering many built-in features of SyntaxEditor such as:

  • Caret
  • Selection
  • Squiggle lines

Registering with a Syntax Language

As described in the Adornment Layers topic, AdornmentManagerProvider`1 objects can be used as language services to provide adornment managers to any text view that requests them.

This code shows how to register an adornment manager provider language service that returns AlternatingRowsAdornmentManager objects (defined in a QuickStart to provide alternating row highlights). for views that use the language. Note that we are also passing a "singleton" key so that the adornment manager that is created for any view using the language is persisted in the views's Properties dictionary while it is active.

C#
VB
Copy
​language.RegisterService(new AdornmentManagerProvider<AlternatingRowsAdornmentManager>(typeof(AlternatingRowsAdornmentManager)));
​language.RegisterService(New AdornmentManagerProvider(Of AlternatingRowsAdornmentManager)(GetType(AlternatingRowsAdornmentManager)))

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Completion Provider

Language Creation Guide - Provider Services
IntelliPrompt Completion Provider

Languages can choose to support IntelliPrompt completion lists and respond to Ctrl+Space.

This topic contains these sections:

  • Basic Concepts
  • The CompletionProviderBase Base Class
  • Registering with a Language
  • Ordering Providers

Basic Concepts

The ICompletionProvider interface defines a single method: RequestSession. This method has a parameter that indicates the IEditorView in which to open the session and a boolean parameter that indicates whether to auto-complete if a single match is found.

SyntaxEditor is wired up to automatically call this method if a completion provider is registered as a service on the current language when Ctrl+Space is typed by the end user.

RequestSession can also be called directly in your code if you wish to generically initiate a completion session, assuming the language supports it.

Implementors of the method should use code to examine the context of the caret in the view. This may involve token scanning and/or AST examination if available. Based on the context (in a method declaration, in a type declaration, in a documentation comment, etc.), a completion session should be opened if appropriate.

The CompletionProviderBase Base Class

The easiest way to implement an ICompletionProvider for a language is to inherit the CompletionProviderBase class. Then just override its abstract RequestSession method.

Registering with a Language

Any object that implements ICompletionProvider can be associated with a syntax language by registering it as an ICompletionProvider service on the language.

This code registers a completion provider in the completionProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(completionProvider);
​language.RegisterService(completionProvider)

It is a common practice for a language itself to implement the ICompletionProvider interface and register itself as a completion provider service.

Ordering Providers

The ICompletionProvider interface inherits the IOrderable interface. When multiple language services are registered that implement ICompletionProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Quick Info Provider

Language Creation Guide - Provider Services
IntelliPrompt Quick Info Provider

Languages can choose to support IntelliPrompt quick info popups that are automatically displayed when the mouse moves over text and/or other parts of the editor, such as margins.

This topic contains these sections:

  • Basic Concepts
  • The QuickInfoProviderBase Base Class
  • Registering with a Language
  • Ordering Providers
  • Showing Quick Info Based on a Button Click
  • Built-In Quick Info Provider for Collapsed Outlining Nodes
  • Built-In Quick Info Provider for Squiggle Tags

Basic Concepts

Context Retrieval

The IQuickInfoProvider defines two GetContext method overloads, both of quick are expected to return a context object given a certain parameter. One overload accepts an IHitTestResult (from a mouse event) and the other overload accepts a zero-based text offset.

A context object can be anything, but it should be some custom type that gives enough information to provide to the RequestSession method later and have that method be able to create a quick info session based on the context. It also must implement value equality via an Equals method override.

Implementors of these methods should use code to examine the context of the hit test result or offset in the view. This may involve token scanning and/or AST examination if available. The context data (in a method declaration, in a type declaration, in a documentation comment, etc.) should be wrapped within the context object retuned by the GetContext methods.

How Contexts Are Used

Context objects should always be stored in the IQuickInfoSession.Context property. As mouse movements occur, a quick info provider repeatedly calls the GetContext method with related mouse hit test results. If the context of an open quick info session matches (value equality) the GetContext return value, the provider knows that no new quick info session needs to be displayed. If GetContext returns a null value, then any existing open quick info session should be closed. If GetContext returns a context that doesn't match the existing session's context, or there is no existing open session, the RequestSession method is called, passing along the new context to use.

Note Note
All context objects must implement an Equals method override so that value equality functions properly.

Requesting a Session

The final method in the IQuickInfoProvider interface is RequestSession. This method is automatically called whenever a new context object has been retrieved that should be used to create and open a new quick info session.

Implementations of this method should create a new quick info session, store the passed context in its Context property, build its content based on the data in the context object, and open the quick info session (show it).

The QuickInfoProviderBase Base Class

The IQuickInfoProvider interface implements IEditorViewMouseInputEventSink and thus is able to process mouse input from within a SyntaxEditor. There is some complicated code needed to do this processing, which is wrapped up in the handy abstract QuickInfoProviderBase class.

The easiest way to implement an IQuickInfoProvider for a language is to inherit the QuickInfoProviderBase class. Then just override its abstract members.

By default its virtual GetContext overload that takes an IHitTestResult is designed to see if the hit is over a character in the text area and if so, call the other abstract GetContext overload that accepts an offset. This is done since most of the time, a quick info provider will be used for showing quick info popups related to text content. To support quick info popups for other parts of the editor, override the GetContext overload that takes an IHitTestResult.

A QuickInfoProviderBase-based provider will automatically close a quick info session it created when appropriate. However to do this, it needs to know which Type of context objects can be returned by its GetContext methods. The ContextTypes property must be implemented to provide this information. For instance, if a quick info provider can return a context object of type KeywordQuickInfoContext from GetContext, then the ContextTypes should return the KeywordQuickInfoContext type.

Registering with a Language

Any object that implements IQuickInfoProvider can be associated with a syntax language by registering it as an IQuickInfoProvider service on the language.

This code registers a quick info provider in the quickInfoProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(quickInfoProvider);
​language.RegisterService(quickInfoProvider)

Ordering Providers

The IQuickInfoProvider interface inherits the IOrderable interface. When multiple language services are registered that implement IQuickInfoProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Showing Quick Info Based on a Button Click

Many applications provide some sort of Display Quick Info button in their application toolbar. When displaying quick info popups in this mode, mouse move/hover input should be ignored until the next quick info session is requested.

This code handles a button click event and shows how to properly focus the editor, get the current IQuickInfoProvider, create a context based on the offset of the caret, and request a quick info session:

C#
VB
Copy
​private void OnShowQuickInfoButtonClick(object sender, RoutedEventArgs e) {
    // Focus the editor
    editor.Focus();

    // Get the IQuickInfoProvider that is registered with the language
    IQuickInfoProvider provider = editor.Document.Language.GetService<IQuickInfoProvider>();
    if (provider != null) {
        // Create a context
        object context = provider.GetContext(editor.ActiveView, editor.Caret.Offset);

        if (context != null) {
            // Request that a session is created based on the context, and disable mouse tracking since
            //   this request is initiated from a button click
            provider.RequestSession(editor.ActiveView, context, false);
        }
    }
}
​Private Sub OnShowQuickInfoButtonClick(ByVal sender As Object, ByVal e As RoutedEventArgs)
    ' Focus the editor
    editor.Focus()

    ' Get the IQuickInfoProvider that is registered with the language
    Dim provider As IQuickInfoProvider = editor.Document.Language.GetService(Of IQuickInfoProvider)()
    If provider IsNot Nothing Then
        ' Create a context
        Dim context As Object = provider.GetContext(editor.ActiveView, editor.Caret.Offset)

        If context IsNot Nothing Then
            ' Request that a session is created based on the context, and disable mouse tracking since
            '   this request is initiated from a button click
            provider.RequestSession(editor.ActiveView, context, False)
        End If
    End If
End Sub

Built-In Quick Info Provider for Collapsed Outlining Nodes

When using the code outlining features, sometimes the end user will collapse outlining nodes. By default, nothing happens when the mouse is hovered over a collapsed outlining node adornment (normally a box with "..." in it). However there is a built-in IQuickInfoProvider implementation called CollapsedRegionQuickInfoProvider that watches for mouse hovers over collapsed regions and will automatically show a quick info tip with the contained content on mouse hovers.

To enable this feature simply register a CollapsedRegionQuickInfoProvider instance as a service on your language. Note that if you register other IQuickInfoProvider services, make sure they are not handling scenarios that would normally be picked up by the CollapsedRegionQuickInfoProvider. You could order them after the CollapsedRegionQuickInfoProvider (see Ordering Providers section above) to ensure they occur after it is already checked.

This code registers the built-in CollapsedRegionQuickInfoProvider service with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(new CollapsedRegionQuickInfoProvider());
​language.RegisterService(New CollapsedRegionQuickInfoProvider())

If you wish to customize the content of the popup from its default, create a class that inherits CollapsedRegionQuickInfoProvider and override its GetContent method. That method is passed a TextSnapshotRange and returns the content to display for that range. Then register an instance of this custom class as the service instead.

Built-In Quick Info Provider for Squiggle Tags

When using the parsing framework and the ParseErrorTagger (or other custom tagger that uses SquiggleTag tags), there will be squiggle adornments in the document window. By default, nothing happens when the mouse is hovered over these adornments. However, there is a built-in IQuickInfoProvider implementation called SquiggleTagQuickInfoProvider that watches for mouse hovers over squiggle adorned regions and will automatically show a quick info tip with the parse error description on mouse hovers.

To enable this feature, simple register a SquiggleTagQuickInfoProvider instance as a service on your language. Note that if you register other IQuickInfoProvider services, make sure they are not handling scenarios that would normally be picked up by the SquiggleTagQuickInfoProvider. You could order them after the SquiggleTagQuickInfoProvider (see Ordering Providers section above) to ensure they occur after it is already checked.

This code registers the built-in SquiggleTagQuickInfoProvider service with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(new SquiggleTagQuickInfoProvider());
​language.RegisterService(New SquiggleTagQuickInfoProvider())

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Parameter Info Provider

Language Creation Guide - Provider Services
IntelliPrompt Parameter Info Provider

Languages can choose to support IntelliPrompt parameter info popups that are automatically displayed when the end user types an invocation, and can provide additional information about the current parameter.

This topic contains these sections:

  • Basic Concepts
  • The ParameterInfoProviderBase Base Class
  • Registering with a Language
  • Ordering Providers

Basic Concepts

The concepts described below are overviews of how to implement a parameter info provider. Please pair this information with the QuickStarts in the Sample Browser for IntelliPrompt Parameter Info and the Getting Started series sample that implements parameter info to see fully-implemented examples.

Requesting a Session

The IParameterInfoProvider interface defines a single method: RequestSession. This method has a parameter that indicates the IEditorView in which to open the session.

RequestSession can be called directly in your code if you wish to generically initiate a parameter info session, assuming the language supports it. A common usage of this is to have the provider implement the IEditorDocumentTextChangeEventSink interface and watch for typing events where the user enters ( or , characters.

Implementors of the RequestSession method should use code to examine the context of the caret in the view. This may involve token scanning and/or AST examination if available, and the resulting context should indicate if the caret is in an invocation of some sort, such as a method call. If it is, the argument index and argument list's start offset should also be specified in the context data, as this information is important for the tracking of parameter info sessions.

Assuming that the context indicates that the caret is within an invocation, the provider should gather information about the invoked member (including overloads when appropriate), create a parameter info session, and add those as signature items to the session being created, as described in the IntelliPrompt parameter info topic. Finally, the session should be opened with the argument list start offset used as the text range.

Watching the Caret

The next task a parameter info provider needs to do is watch the caret to determine if it moves to another argument index, nested invocation, or outside of a valid invocation range altogether. This can be achieved by having the parameter info provider implement the IEditorViewSelectionChangeEventSink interface.

In the selection change notification, if there is a parameter info session already open, a new context object should be retrieved (similar to the context retrieval when requesting a session) for the caret's location. If the argument list's start offset has changed, the open session should be closed and a request for a new session should be made in the event the caret has moved into a nested invocation.

Bolding the Current Parameter

If the content providers used in the session's signature items implement the IParameterizedContentProvider interface, the current parameter index can be specified to them. This allows them to alter the content that they display so that the current parameter has attention drawn to it, such as by a boldface font.

In this scenario, a method should be added to the parameter info provider that can examine a context and enumerate through a session's signature items to update the IParameterizedContentProvider.ParameterIndex property of each item's content provider, based on which argument index the context indicates that the caret is currently in. If the session is already open and any updates are made to the current argument index, the IParameterInfoSession.Refresh method should be called to force an update to the displayed content.

The method to update the current parameters should be called in two places. First is immediately before the a session is first opened, in RequestSession. Second is in the selection change handler, if it is detected that the caret is still within the same argument list. This can be determined by if the context's argument list start offset matches the currently-open session's snapshot range start offset.

The ParameterInfoProviderBase Base Class

The easiest way to implement an IParameterInfoProvider for a language is to inherit the ParameterInfoProviderBase class. Then just override its abstract RequestSession method.

Registering with a Language

Any object that implements IParameterInfoProvider can be associated with a syntax language by registering it as an IParameterInfoProvider service on the language.

This code registers a parameter info provider in the parameterInfoProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(parameterInfoProvider);
​language.RegisterService(parameterInfoProvider)

Ordering Providers

The IParameterInfoProvider interface inherits the IOrderable interface. When multiple language services are registered that implement IParameterInfoProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


IntelliPrompt Code Snippet Provider

Language Creation Guide - Provider Services
IntelliPrompt Code Snippet Provider

Languages can choose to support IntelliPrompt code snippets that provide a way to insert pre-defined fragments of text into the editor. Each code snippet can declare multiple fields of text, and when a code snippet template session is activated in SyntaxEditor, the text is inserted and the end user can tab between the fields to edit their values.

This topic contains these sections:

  • Basic Concepts
  • Registering with a Language
  • Ordering Providers

Basic Concepts

Code snippet providers, represented by the ICodeSnippetProvider interface and implemented by the CodeSnippetProvider class, serve several purposes when registered as a service on a language:

  • They let other code know that code snippets are supported for the language.
  • They make the available code snippets accessible.
  • They allow for selection sessions to be opened.
  • They watch for Tab to be pressed after a code snippet shortcut, and open a template session in response.
  • They allow for the various template session adornments to be displayed.

A CodeSnippetProvider class instance can be used directly as the service.

Loading a Root Folder

The ICodeSnippetProvider.RootFolder property needs to be set to an ICodeSnippetFolder instance that has loaded code snippet metadata into itself or one of its nested folders. This is required for certain functionality to be enabled.

The IntelliPrompt code snippets topic discusses ways to populate a folder, including the ability to recursively load from a file system folder.

Setting Case Sensitivity

The ICodeSnippetProvider.IsCaseSensitive property can be set to false for languages that don't require that code snippet shortcuts be matched with exact case.

Registering with a Language

Any object that implements ICodeSnippetProvider can be associated with a syntax language by registering it as an ICodeSnippetProvider service on the language.

This code registers a code snippet provider in the codeSnippetProvider variable with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterService(codeSnippetProvider);
​language.RegisterService(codeSnippetProvider)

Ordering Providers

The ICodeSnippetProvider interface inherits the IOrderable interface. When multiple language services are registered that implement ICodeSnippetProvider, they can be ordered. The highest priority provider will be used first. If it indicates that a session was opened, no other providers will be used. If it indicates that a session was not opened, the next provider is checked, and so on. This allows for layering of multiple providers.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Event Sink Services

Language Creation Guide
Event Sink Services

Event sinks are interfaces that allow a language to be notified of events that occur to a SyntaxEditor or IEditorDocument. This could be anything from input events to text change events. The language can choose to process these events and optionally block editor views from receiving them.

Event sinks use the service locator architecture and thus are managed as services. This design has several benefits:

  • Event notifications can be prioritized (IntelliPrompt sessions receive events before languages, etc.)
  • Custom event sink handlers can be externally swapped in without inheriting a language class
  • There are no extra ties between a SyntaxEditor, IEditorDocument, or ISyntaxLanguage meaning less chance for memory leaks
  • Languages continue to use basic .NET 2.0-based techniques for event handling, keeping their code platform independent

Note Note
The Service Locator Architecture topic contains a lot of information that is necessary to understand when working with event sinks.

This topic contains these sections:

  • Built-In Event Sink Service Types
  • Sample: Implementing an Event Sink for Listening to Text Changes

Built-In Event Sink Service Types

This table lists the built-in event sink service types that can be used with ISyntaxLanguage. Note that multiple objects implementing these interfaces can be registered as language services, as long as they are registered using separate Type keys.

Service Type | Description
ICodeDocumentLifecycleEventSink | An object that can be notified of when an ICodeDocument becomes associated and disassociated with a language, via events such as a language change.
ICodeDocumentPropertyChangeEventSink | An object that can be notified of when attached ICodeDocument properties, such as ParseData or FileName, are changed.
ICodeSnippetTemplateSessionEventSink | An object that can be notified of various events occur related to a code snippet template session. See the Code Snippets documentation for more information.
IEditorDocumentTextChangeEventSink | An object that can be notified of IEditorDocument text change events, both before and after a text change occurs.
IEditorViewKeyInputEventSink | An object that can be notified of IEditorView keyboard input events, both key down and up. These input events can be intercepted before the editor view ever receives them.
IEditorViewMouseInputEventSink | An object that can be notified of IEditorView mouse input events, including all standard mouse events. These input events can be intercepted before the editor view ever receives them.
IEditorViewSelectionChangeEventSink | An object that can be notified of IEditorView selection change events.
IEditorViewTextInputEventSink | An object that can be notified of IEditorView text input events. These input events can be intercepted before the editor view ever receives them.
ITextViewLifecycleEventSink | An object that can be notified of when an ITextView becomes associated and disassociated with a language, via events such as view open/close, document change, or language change.

Sample: Implementing an Event Sink for Listening to Text Changes

For this sample, assume that you are implementing an HTML language and wish to watch for < being typed so that you know when to show a completion list of HTML tags. To do this, we'll work with the IEditorDocumentTextChangeEventSink, which notifies after text changes occur. We examine typed text to look for < characters.

Registering the Event Sink

As mentioned above, event sinks use the service locator architecture. In this sample, we'll have our language class itself implement the IEditorDocumentTextChangeEventSink interface and in the language's constructor, we'll register itself as a service for that service type.

This code registers the language itself as an IEditorDocumentTextChangeEventSink service:

C#
VB
Copy
​public class HtmlSyntaxLanguage : SyntaxLanguage, IEditorDocumentTextChangeEventSink }
    public HtmlSyntaxLanguage() : base("HTML") {
        // Other initialization here
        this.RegisterService<IEditorDocumentTextChangeEventSink>(this);
    }
}
​Public Class HtmlSyntaxLanguage
    Inherits SyntaxLanguage
    Implements IEditorDocumentTextChangeEventSink

    Public Sub New()
        MyBase.New("HTML")
        ' Other initialization here
        Me.RegisterService(Of IEditorDocumentTextChangeEventSink)(Me);
    End Sub
End Class

Note Note
See the Service Locator Architecture topic for details on registering and retrieving various service object instances.

Implementing the IEditorDocumentTextChangeEventSink Interface

Next we implement the interface on the language. Again, we could have implemented this interface on any other object and registered that instead but for simplicity, we have chosen to implement it on the language itself.

This code shows the two methods on the interface, added into the language class:

C#
VB
Copy
​void IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanged(SyntaxEditor editor, EditorSnapshotChangedEventArgs e) {
    // The e.TypedText is not null only when a Typing change occurs with a single operation that inserts text,
    //   so we can check that to display the completion list when "<" is typed
    if (e.TypedText == "<") {
        // Show completion list containing tags here
    }
}

void IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanging(SyntaxEditor editor, EditorSnapshotChangingEventArgs e) {
    // Nothing needs to be done here
}
​Private Sub NotifyDocumentTextChanged(ByVal editor As SyntaxEditor, ByVal e As EditorSnapshotChangedEventArgs) _
    Implements IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanged

    ' The e.TypedText is not null only when a Typing change occurs with a single operation that inserts text,
    '   so we can check that to display the completion list when "<" is typed
    If e.TypedText = "<" Then
        ' Show completion list containing tags here
    End If
End Sub

Private Sub NotifyDocumentTextChanging(ByVal editor As SyntaxEditor, ByVal e As EditorSnapshotChangedEventArgs) _
    Implements IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanging
    ' Nothing needs to be done here
End Sub

Note that in the text changed handler, we look to see if text that was typed was the < character. If that scenario occurred, we'd call code to display a completion list.

Of course we may also wish to add code to ensure we didn't type within a comment, etc. This logic could be added by getting an ITextSnapshotReader and examining the token that was typed.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Using a Language

Language Creation Guide
Using a Language

Once your syntax language has been configured properly, it's ready for use.

This topic contains these sections:

  • Using with an ICodeDocument or SyntaxEditor
  • Packaging Options

Using with an ICodeDocument or SyntaxEditor

Using with an ICodeDocument

The ICodeDocument interface designates the requirements for a document that can by parsed by a syntax language. It defines a Language property that accepts any ISyntaxLanguage instance. Therefore, to have a document use a syntax language, simply assign it to that property.

This code creates a new IEditorDocument (which inherits ICodeDocument) and assigns an ISyntaxLanguage that is already defined in the language variable:

C#
VB
Copy
​IEditorDocument document = new EditorDocument();
document.Language = language;
​Dim document As IEditorDocument = New EditorDocument()
document.Language = language

The ICodeDocument.LanguageChanged event fires whenever the document's Language property changes. Its event arguments pass the old and newly-assigned languages.

Using with a SyntaxEditor

Since IEditorDocument is the property type for the SyntaxEditor.Document property, assigning an ISyntaxLanguage to be used for a SyntaxEditor control is done the same way.

In that scenario, the SyntaxEditor's document is assigned the language like this:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

The SyntaxEditor.DocumentLanguageChanged event wraps the ICodeDocument.LanguageChanged event and is an easy way to be notified whenever a new language is assigned to the document currently being edited in a SyntaxEditor.

Packaging Options

There are a few options for packaging the custom languages you've created with your application. It is completely up to you as to how you package things, since any of these options work fine.

Included in Application Assembly

The easiest way is to include a custom language and its related classes right in your main application assembly.

Included in Library Assembly

For languages that tend to be more complex and use a lot of optional features, it's probably better design to separate them out into a single library assembly. This allows you to maintain your language in a project that is independent of your UI project.

Included in Library Assemblies with Text/UI Separation

This option is similar to the previous one where the language is in its own assembly, however in this option the language and its classes are split into two assemblies: one for text/parsing and one for UI. This option is how we deploy our optional language add-ons. It is generally only used in scenarios where you plan on using the same text/parsing code across multiple platforms (WPF, WinForms, etc.).

The first assembly contains only the core text and parsing related classes. This keeps it truly platform independent since there are no references to any UI platforms (WPF, WinForms, etc.) in the code.

The second assembly is platform dependent and includes code specifically for working with SyntaxEditor for WPF, etc. Language functionality that interacts with IntelliPrompt would be included here.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Language Designer Tool
Overview

The Language Designer tool is an application that has many helpful features for quickly developing language definitions. It is an option when installing the Universal Windows controls.

This application uses several of the WPF Studio control products, such as Ribbon, Docking & MDI, Editors, Navigation, PropertyGrid, and SyntaxEditor, and is a nice showcase of what you can do with our products.

Its main goal is to provide you with a user interface for creating a language project, which is essentially a profile about a syntax language. Various language features such as a lexer and classification types can be configured and in some cases tested right within the application. Then code generation can be performed to output code files that allow for a related syntax language to be used in your own applications with the SyntaxEditor control.

Compatibility Note Compatibility Note
Since the Language Designer is written in WPF and thus runs on the core .NET Framework, it is unable to load Universal Windows assemblies for debugging in the LL Parser Debugger. This is described in more detail in the LL Parser Debugger topic.

This topic contains these sections:

  • Getting Started
  • Lexer Configuration Pane
  • AST Nodes Configuration Pane
  • Other Configuration Panes
  • Building a Project
  • Live Test
  • Code Generation
  • LL Parser Debugger

Getting Started

This topic covers essential information about using the application, such as how to start it, what is a language project, how to open/save language projects, use the ribbon user interface and Properties tool window, and get started defining the general properties for a language.

See the Getting Started topic for more information.

Lexer Configuration Pane

The lexer for a language is very important since it is a building block for supporting many language features such as tokenization, syntax highlighting, and more.

See the Lexer Configuration Pane topic for more information.

AST Nodes Configuration Pane

The AST Nodes configuration pane is used to design the type-specific AST node classes that can be code generated by the Language Designer, and used with the LL(*) Parser Framework.

See the AST Nodes Configuration Pane topic for more information.

Other Configuration Panes

The Language Designer has several other configuration panes that are described in this topic.

See the Other Configuration Panes topic for more information.

Building a Project

Once you have configured your language project and are ready to start testing it or generating code, it's time to build the project. Building a project examines the project and reports whether there are any errors, warnings, or messages that you should be aware of.

See the Building a Project topic for more information.

Live Test

The Language Designer Live Test pane allows you to try various aspects of your language out before performing any code generation.

See the Live Test topic for more information.

Code Generation

The Language Designer's main purpose is to generate code that allows you to load custom syntax languages at run-time in your applications.

See the Code Generation topic for more information.

LL Parser Debugger

The Language Designer LL Parser Debugger pane allows you to load an assembly which contains a non-abstract ILLParser implementation class and debug the grammar.

See the LL Parser Debugger topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Language Designer Tool
Getting Started

This topic covers essential information about using the application, such as how to start it, what is a language project, how to open/save language projects, use the ribbon user interface and Properties tool window, and get started defining the general properties for a language.

This topic contains these sections:

  • Running the Application
  • Language Projects vs. Language Definitions
  • Language Project File Operations
  • Importing a SyntaxEditor 4.0 for WinForms Dynamic Language XML Definition
  • The Ribbon User Interface
  • The Properties Tool Window
  • General Properties Configuration Pane

Running the Application

Go to your Windows' Programs menu group for the Universal Windows controls and click the Run SyntaxEditor Language Designer menu item. This will run the application. If the application previously had a language project open, it will be reopened. Otherwise a Start Actions task pane will be visible with several options for creating a new language project or opening an existing one.

Note Note
If you do not see the menu item to run the application, ensure that you kept the option to install it checked during the Universal Windows controls setup process.

Language Projects vs. Language Definitions

It is important to understand the difference between language project files (.langproj) and language definition files (.langdef). Language project files are what can be loaded and edited by the Language Designer application. The language project stores a lot of information about your language such as lexer configuration, classification types, etc. Based on the information about your language stored in a language project, you are able to generate language-related code that can be included in your application's project. Language projects themselves are not intended to be distributed with your application, only the code generated by them is.

Language definitions on the other hand are one output option when performing code generation, the other option being the generation of pure C#/VB language-related code. Language definitions are essentially a subset of the data stored in the language project and are can be distributed with an application and loaded at run-time to instantly configure a language. Again, language definitions are just one option for working with a language at run-time with your code. They are nice because they are portable and can easily be shared or tweaked. More information on language definitions and the difference between them and pure C#/VB code generation is given in the Code Generation topic.

Language Project File Operations

The Language Designer supports all the basic file operations for working with language projects. These file operations are always available on the ribbon's application menu, and also on the Start Actions task pane when no project is currently open.

The New action (Ctrl+N) creates a new language project and opens the General Properties configuration pane. The Open action (Ctrl+O) opens an existing language project that you have already created. The Save action (Ctrl+S) saves the currently-open language project. The Save As action saves the currently-open language project, but as a different file. The Close action closes the currently-open language project.

A list of recently-opened projects is also available. Click on a recently-opened project to reopen it.

Whenever an action is taken that will close a currently-open language project, you will be prompted as to whether you wish to save the project or not before continuing.

Importing a SyntaxEditor 4.0 for WinForms Dynamic Language XML Definition

To help aid in the transition of some of our WinForms customers to newer platforms, we have added a feature that allows you to import a SyntaxEditor 4.0 for WinForms dynamic language XML definition. Most of the data in the definition will be converted over and imported into a new language project.

To access this feature, choose the Import SE4 Definition action.

The Ribbon User Interface

The ribbon user interface in the Language Designer provides access to all of the application's features.

The Language Designer's ribbon user interface

The Actions group contains numerous actions that can be used whenever lists are presented in a configuration pane. Certain actions enable/disable based on the selection within the list.

The Project Windows group contains actions that when clicked will open up the various configuration panes used to store data about your language.

The Code Generation group has actions that are related to building your project (error checking), performing code generation, and doing a live test.

The Properties Tool Window

The Properties tool window is used throughout the application. It will auto-populate when focus enters many of the configuration panes. In the scenario where configuration panes contain a list, it will often show the properties of the selected list item. Most lists support multi-selection, and in this case you can see/change the properties of more than one object at a time.

General Properties Configuration Pane

The General Properties configuration pane can be opened by clicking General Properties on the ribbon. This configuration pane allows you to set some high-level properties for your language. All language projects should set this data first.

The language key is the name of the language that will be used in type names, etc. So it must conform to identifier naming requirements for C# and VB. This means that say we were making a language project for C#, we would set the language key to be CSharp.

The language description is only used in comments so if we were developing a C# language, here is where we would put C#.

The creator indicates the name of the company that created the language project. The copyright is a place to put a copyright line for the language project data. Both of these items, if included, are output during the code generation phase and help protect your intellectual property.

The example text is where you can paste in a code snippet for the language that is used in the Language Designer application when performing a Live Test. It can also be loaded nad used at run-time if desired for previewing how a language is syntax highlighted.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lexer Configuration Pane

Language Designer Tool
Lexer Configuration Pane

The lexer for a language is very important since it is a building block for supporting many language features such as tokenization, syntax highlighting, and more.

The Lexer configuration pane can be opened by clicking Lexer on the ribbon. This configuration pane allows you to define the lexer used by the language.

This topic contains these sections:

  • Choosing a Lexer Type
  • The New Dynamic Lexer Wizard
  • Modifying a Dynamic Lexer
  • Modifying a Programmatic Lexer

Choosing a Lexer Type

Although any sort of lexer is supported by SyntaxEditor via the ILexer interface, the Language Designer directly supports these types of lexers:

  • None - No lexer is used with the language.
  • Dynamic - A dynamic lexer is used with the language. This lexer type is mergable and is the fastest way to get going. It uses regular expression patterns to define how text is tokenized.
  • Programmatic (mergable) - A mergable programmatic lexer is used with the language. This lexer type is mergable and uses a handwritten code-based lexer to tokenize text. It is faster than a dynamic lexer.
  • Programmatic (non-mergable) - A non-mergable programmatic lexer is used with the language. This lexer type is not mergable and uses a handwritten code-based lexer to tokenize text. It provides the fastest performance.
  • 'M' Language Definitions - Not supported in Universal Windows.

The Language Designer allowing a lexer type to be chosen

To select a new lexer type, choose the lexer type in the radio button list and click the Change Lexer Type button below the list. In some cases the lexer type will change instantly and in other cases, you may be presented with a wizard.

The New Dynamic Lexer Wizard

The New Dynamic Lexer Wizard appears when you choose to use a dynamic lexer. The first page provides you with two options. The first option allows you to continue using the wizard, which will subsequently ask you a number of questions about the lexical structure of your language and then will automatically configure a number of states and pattern groups to get you started. The second option allows you to quit the wizard and start with a blank dynamic lexer.

The New Dynamic Lexer Wizard asking whether to help you create the basics for a code oriented language.

The first option is best for code-oriented languages like C#, Java, VB, etc. It asks you series of questions about your language's lexical structure such as the keywords, operators, comment, number, and string syntax, etc.

The New Dynamic Lexer Wizard asks for you to define whether line terminators are significant in your langauge. The Python language would be an example of a language where line terminators are significant. It also asks for you to select one of 3 options that define the characters that are allowed in an identifier.

The New Dynamic Lexer Wizard allowing for configuration of line terminators and identifiers.

After configuring line terminators and identifiers, you will be prompted to define the language's keywords and whether they are case-sensitive. Note that if you are creating this Dynamic language for use with the LL(*) Parser Framework, keywords will each need to be defined as separate tokens. This is discussed in the Lexer Preparation topic.

The New Dynamic Lexer Wizard allowing for configuration of language keywords.

After configuring keywords, you will be prompted to configure the language's operators and delimiters. Many languages share a similar set of operators. You have the option to initialize the list with the most common operators, then edit it to your liking.

The New Dynamic Lexer Wizard allowing for configuration of operators and delimiters.

Many languages support defining string literals in more than one way. For this reason, the wizard will prompt you for a primary and an alternate string syntax. If you only need to define one type of string, leave the first radio button group selection on "None" when you are presented with the alternate syntax configuration. If your langauge does not support strings at all, use the "None" selection on the primary and alternate syntax pages.

The New Dynamic Lexer Wizard allowing for configuration of strings.

The next wizard screen will allow you to configure number tokens for your language. You can allow for exponent notation and hexadecimal notation, both of which are supported in many, but not all, languages.

The New Dynamic Lexer Wizard allowing for configuration of numbers.

The last wizard screen allows you to configure comments in your language. You can configure it to support single line comments, multiline comments, neither, or both. You can also customize the comment delimiters.

The New Dynamic Lexer Wizard allowing for configuration of comments.

Upon wizard completion, a dynamic lexer is created for you that is prepopulated with states and patterns. For many languages, this wizard can help to get you up and running in minutes.

Modifying a Dynamic Lexer

Once a dynamic lexer has been created, it can be modified via the Lexer configuration pane. The treeview on the left of the application has nodes for accessing the lexical macro list, lexical state list, and for each state, the scopes, child states, and pattern groups. Click on a treeview node to view its related pane.

Dynamic Lexical Macros

Lexical macros are optional regular expression patterns that can be defined for reuse elsewhere within the lexer. For instance, if you have a pattern snippet that appears in many patterns, define it here and reuse it in other regular expression patterns via {LexicalMacroKey} syntax.

To add macros, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new macros. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new macro is created for each key that you enter.

Once added, use the Properties tool window to update the pattern for each macro. Macros can be removed, cleared, and reordered via the ribbon.

Dynamic Lexical States

Lexical states specify the patterns that can be recognized to tokenize text when the state is active.

To add states, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new states. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new state is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each state. States can be removed, cleared, and reordered via the ribbon.

A state description can be set, which is a more verbose name for the state. Also an ID value can be assigned to the state, which is ideal for best performance when scanning through text at run-time. A number of default properties that apply to the pattern groups in the state (such as case sensitivity) are available to be set.

Dynamic Lexical Scopes

Lexical scopes contain a start and end pattern group and determine how a state is entered and exited via a parent state that references it.

To add a scope, click the Add button in the ribbon. A new scope is created.

Once added, use the Properties tool window to update the properties for the scope. Scopes can be removed and cleared via the ribbon.

Each scope should have a start and end pattern group defined. See the Dynamic Lexical Pattern Groups sub-section below for more information on defining pattern groups.

Dynamic Child Lexical States

Child lexical states provide the list of states that can be transitioned into from a state. When a child state's start scope pattern group is recognized, a transition into that state will be made.

To add a child state reference, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new child states. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A child state reference is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each child state reference. Child state references can be removed, cleared, and reordered via the ribbon.

Dynamic Lexical Pattern Groups

Pattern groups define one or more patterns that are used to tokenize text. Patterns can be explicit or can use regular expressions.

To add a pattern group, click the Add button in the ribbon. A new pattern group is created.

Once added, use the Properties tool window to update the properties for each pattern group. Pattern groups can be removed, cleared, and reordered via the ribbon.

Pattern groups can be assigned a pattern type (explicit or regular expression), various case sensitivity settings, a token ID (for optimal performance when scanning tokenized text), and a token key (which must conform to standard identifier syntax). A classification type key indicates the key of the classification type to use for tokens created using this pattern group.

Pattern groups have a collection of patterns. Patterns can be entered by clicking the ellipses button in the property grid or by right-clicking on the pattern group in the list. Enter one pattern per line on the dialog that appears. A pattern group look-behind and look-ahead pattern can also be defined. These patterns, if specified, must evaluation to true for any of the patterns in the group to match successfully.

Modifying a Programmatic Lexer

This type of lexer is handwritten via code but a couple helpful classes can be generated to help.

Lexical States

Lexical states specify a mdoe in which patterns can be recognized to tokenize text when the state is active. Since lexers often have multiple lexical states, it is useful to have a lexical state ID class that provides constants for all the possible lexical state IDs used by the lexer. This lexical state ID class can be code generated by the Language Designer.

To add states, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new states. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new state is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each state. States can be removed, cleared, and reordered via the ribbon.

A state description can be set, which is a more verbose name for the state. Also an ID value can be assigned to the state, but it is recommended to leave it empty so that it can be auto-generated.

Tip Tip
If you plan on eventually merging the lexer with another lexer it is a good idea to ensure that the lexical state IDs for the two lexers don't overlap. By setting a base ID value on the first lexical state and leaving the rest of the IDs empty, the code generator will auto-generate the remaining IDs to 1-up after the base ID. Thus you could specify ID 1000 on the first lexical state. The code generator will make the next lexical state with an empty ID value have an ID of 1001, and so on.

Token Declarations

The output of lexers is tokenized text. Each token needs to have an ID value to identify it. It is useful to have a token ID class that provides constants for all the possible token IDs used by the lexer. This token ID class can be code generated by the Language Designer.

To add token declarations, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new token declarations. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new token declaration is created for each key that you enter.

Once added, use the Properties tool window to update the properties for each token declaration. States can be removed, cleared, and reordered via the ribbon.

A token declaration description can be set, which is a more verbose name for the token declaration. Also an ID value can be assigned to the token declaration, but it is recommended to leave it empty so that it can be auto-generated.

Tip Tip
If you plan on eventually merging the lexer with another lexer it is a good idea to ensure that the token declaration IDs for the two lexers don't overlap. By setting a base ID value on the first token declaration and leaving the rest of the IDs empty, the code generator will auto-generate the remaining IDs to 1-up after the base ID. Thus you could specify ID 1000 on the first token declaration. The code generator will make the next token declaration with an empty ID value have an ID of 1001, and so on.

A classification type key can be set on the token declaration, indicating the classification type with which the token should be associated. When one is specified, a method is generated on the token ID class that returns whether a specified token ID uses the classification type.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


AST Nodes Configuration Pane

Language Designer Tool
AST Nodes Configuration Pane

The AST Nodes configuration pane is used to design the type-specific AST node classes that can be code generated by the Language Designer, and used with the LL(*) Parser Framework.

Type-specific AST nodes, described in more detail in the general AST nodes topic, are distinct classes designed to represent each type of AST node that a language grammar can create. The features described in this topic make it easy to configure type-specific AST nodes for a language grammar, and fully code generate those node classes.

This topic contains these sections:

  • Pane Layout
  • AST Node Configuration
  • AST Node Property Configuration
  • Code Generation

Pane Layout

The AST Nodes configuration pane contains two lists, one above the other. The upper list displays the AST node classes defined for the language, which can be code generated. The lower list displays the properties that will be code generated for the selected AST node in the upper list.

The Properties tool window is heavily used with this pane, since it allows for the changing of configuration settings for the nodes and their properties. Whichever list was focused last is the one that the Properties tool window considers active.

Note that multiple items can be selected in either list and the Properties window allows you to change common values among all the selected instances. This is useful when changing the base type of multiple AST nodes, etc.

AST Node Configuration

AST node configuration is done by modifying items in the upper list.

Adding AST Nodes

To add AST nodes, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new AST nodes. Enter one key per line, where each key conforms to standard identifier syntax since they will be used as the class name in code generation. A new AST node is created for each key that you enter.

Updating AST Nodes

Select one or more AST nodes in the upper list and use the Properties tool window to modify their properties. You can double-click an AST node in the list to open the Properties tool window.

A description is a text description of the node, used in code generation comments.

The inherits property indicates the base class for the AST node. If left blank, the default AST node base class will be used. A drop-down is provided, allowing for quick selection of any AST node already defined for the language.

Removing AST Nodes

AST nodes can be removed by either selecting the items in the upper list and clicking the ribbon's Remove button (after focusing the list), or by clicking the ribbon's Clear button, which will remove all of them.

AST Node Property Configuration

AST node property configuration is done by modifying items in the lower list. The lower list displays the properties to code generate for the selected AST node in the upper list.

Adding Properties

To add properties, first select the target AST node in the upper list, then click the lower list to focus it, and click the Add button in the ribbon. A dialog will appear asking you for the keys of the new properties. Enter one key per line, where each key conforms to standard identifier syntax since they will be used as the property name in code generation. A new property is created for each key that you enter.

Updating Properties

Select one or more properties in the lower list and use the Properties tool window to modify their properties. You can double-click a property in the list to open the Properties tool window.

A description is a text description of the property, used in code generation comments.

The property type property indicates the kind of property to generate, which is one of these options:

  • Simple – Gets or sets a simple CLR type object. Supported types are strings, ints, bools, enums, and flags enums.
  • SimpleList – Gets an IList<T> containing a collection of strings, ints, bools, or enums.
  • AstNode – Gets or sets an AST node object.
  • AstNodeList – Gets an IList<T> containing a collection of AST nodes.

The property types that relate to child AST nodes are separated out since code generation will add special code to generated AST node classes to allow those to be enumerated through as child nodes.

The type property specifies the Type returned by the property, which can be an AST node type name, a string, etc.

Removing Properties

Properties can be removed by either selecting the items in the lower list and clicking the ribbon's Remove button (after focusing the list), or by clicking the ribbon's Clear button, which will remove all of them.

Code Generation

Any AST nodes defined in this pane will show in the list of files that can be code generated.

The generated classes for AST nodes fully implement IAstNode and can be used with the LL(*) Parser Framework's tree construction mechanism.

The classes are output with a partial modifier so that they can be extended as needed with other partial classes in the same project.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Other Configuration Panes

Language Designer Tool
Other Configuration Panes

The Language Designer has several other configuration panes that are described in this topic.

This topic contains these sections:

  • General Properties
  • Classification Types

General Properties

The General Properties configuration pane is where several high-level language properties are defined.

Please see the Getting Started topic for details, as this configuration pane is described in that topic.

Classification Types

The Classification Types configuration pane can be opened by clicking Classification Types on the ribbon. This configuration pane allows you to set which classification types are used by the language.

Classifications provide the foundation for syntax highlighting. Ranges in text are classified with various logical classification types. These classification types are mapped to highlighting styles, which SyntaxEditor uses to determine how to highlight code. The end user is able to customize the styles for each classification type too.

The Language Designer showing classification types being edited

Classification types are used in conjunction with a lexer. Be sure to define a Lexer as well since classifications are assigned to the various tokens generated by the lexer.

Common classification types are:

  • Comment
  • Delimiter
  • Identifier
  • Keyword
  • Number
  • Operator
  • String

Adding Classification Types

To add classification types, click the Add button in the ribbon. A dialog will appear asking you for the keys of the new classification types. Enter one key per line, where each key conforms to standard identifier syntax since they will be used in code generation. A new classification type is created for each key that you enter.

Updating Classification Types

Select one or more classification types in the list and use the Properties tool window to modify their properties. You can double-click a classification type in the list to open the Properties tool window.

A description is a verbose way of describing the classification type that is displayed in user interfaces (such as options dialogs). If no description is provided, the key is used instead. In most scenarios, keys will look fine in UI. However consider something like a C# XmlDocumentationTag. In this case, we'd want to assign a description of XML Doc Tag, since that will look better in UI.

The default style indicates the default highlighting style that should be used for syntax highlighting any text in SyntaxEditor that is classified with the classification type. Null values for the style attributes will inherit whatever the default editor text style is. These style attributes can be edited:

  • Foreground
  • Bold
  • Italic

Previewing Classification Types

A box below the list shows a preview of the classification type and its default style.

Removing Classification Types

Classification types can be removed by either selecting the items in the list and clicking the ribbon's Remove button, or by clicking the ribbon's Clear button, which will remove all of them.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Building a Project

Language Designer Tool
Building a Project

Once you have configured your language project and are ready to start testing it or generating code, it's time to build the project. Building a project examines the project and reports whether there are any errors, warnings, or messages that you should be aware of.

Project builds can be initiated from the ribbon, or by pressing the shortcut Ctrl+Shift+B.

This topic contains these sections:

  • Error List and Status Bar
  • Fixing Errors
  • Notes Related to Live Test
  • Notes Related to Code Generation

Error List and Status Bar

The Error List tool window indicates the errors, warnings, and messages from the last build. Each item in the list shows a general category, which relates to a configuration pane, along with a description.

In addition, the status bar will show a project build result summary and at what time the last build succeeded or failed.

Fixing Errors

In the event that there are errors or warnings that appear, you can double-click the item in the Error List and the related configuration pane should open. In most cases, the appropriate item will be selected or focused as well.

This makes it easy for you to quickly jump to the problem location and get the issue resolved.

Notes Related to Live Test

Project builds are what trigger updates to the language used in the Live Test pane. If there are any build errors, no update to the live test language are made.

Notes Related to Code Generation

Project builds are what update the list of code files that can be generated in the Code Generation Configuration pane. No code previewing or generation can occur if there are build errors.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Live Test

Language Designer Tool
Live Test

The Language Designer Live Test pane allows you to try various aspects of your language out before performing any code generation.

Click the Live Test button in the ribbon to open the Live Test pane.

This topic contains these sections:

  • Features and Limitations
  • Status Bar Information
  • Updating the Live Test

Features and Limitations

The Live Test can show syntax highlighting for a language that has a dynamic lexer and classification types defined. It does not yet work with other lexer types. There are a number of enhancements planned for this pane in the future.

Status Bar Information

Assuming a supported lexer type is available (see above), as the caret moves through text, the status bar indicates the current lexical state and token keys. An asterisk (*) appears next to the token key if the caret is at the start of a token.

The right side of the status bar indicates the current line, column, and character positions of the caret.

Updating the Live Test

You can build the language project to update the language used in the Live Test pane. Changes made to the other configuration panes will not be picked up in Live Test until a project build occurs.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Code Generation

Language Designer Tool
Code Generation

The Language Designer's main purpose is to generate code that allows you to load custom syntax languages at run-time in your applications.

This topic contains these sections:

  • Configuration
  • Language Definition vs. Code File Output
  • Selecting the Output Language
  • Previewing Generated File
  • Saving Generated Files
  • Usage of Generated Files

Configuration

Click the Configuration button in the Code Generation ribbon group to open the code generation configuration pane.

On this pane, two fields must be entered. Output namespace indicates the namespace in which any generated C#/VB code is placed. Output folder path indicates the folder in which code files are written when generated. It can be any valid path on your hard drive.

Language Definition vs. Code File Output

A checkbox provides an option for generating a language definition instead of C#/VB code files.

Language definitions are intended to be portable XML files that can be distributed with an application and loaded on the fly to configure a language. Use these if you plan on allowing end users to modify language definitions, or if you simply don't wish to deal with dedicated C#/VB code files.

The other option is to generate dedicated C#/VB code files for the language. In this scenario, you create a language at run-time simply by creating a new instance of the generated language class.

Selecting the Output Language

Code file output can occur in C# or VB, and is generated using CodeDOM. Use the Options tab in the ribbon to switch between the various output language options.

Previewing Generated File

If there are no project build errors, you can preview any of the generated code files by double clicking on the item in the code files list. This opens a new document tab with a complete preview of the code that will be generated. Selecting one or more code files and pressing the Preview Selected button also works.

Saving Generated Files

If there are no project build errors, you can select one or more files and press the Generated Selected or Generate All buttons to save files to the hard drive in the output folder path. Please note that generated files will overwrite any existing files with the same name.

Usage of Generated Files

If you are generating a language definition (.langdef) file, you can either include the file in a folder under your application's main folder or can include the file as an embedded resource in your application project. Then at run-time, create a SyntaxLanguageDefinitionSerializer object, and use its LoadFromStream method to create a SyntaxLanguage-based class that is initialized with all the information in the language definition.

If you are generating code files instead, copy all the generated C#/VB code files to your application project and include them as compilable code. To begin using a language, just create an instance of the syntax language class that was generated. The constructor for the language class has all the information in it to configure itself. All generated classes are marked as partial classes so you can further extend them in other files without worrying about your code customizations being wiped out when code is generated again.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


LL Parser Debugger

Language Designer Tool
LL Parser Debugger

The LL Parser Debugger allows you to load an assembly which contains a non-abstract ILLParser implementation class and debug the grammar.

Opening the LL Parser Debugger pane shows a new contextual tab group on the ribbon.

This topic contains these sections:

  • Important Silverlight Assembly Notes
  • Debugger Layout
  • Opening a Parser
  • Debugging
  • Hotkeys

Important Silverlight Assembly Notes

Before digging into the debugger UI, there are some important things to know about its ability to load various assemblies. Since the Language Designer is written in WPF and runs on the core .NET framework, it is unable to load Silverlight assemblies for debugging in the LL Parser Debugger.

Silverlight Assemblies

When you wish to debug a Silverlight-based language parser written using the LL(*) Parser Framework, you must clone the classes to a native .NET class library (non-Silverlight-based) and compile a .dll of them. Then load that assembly instead of the Silverlight-based one. This way you can debug the grammar as you are no longer trying to load Silverlight assemblies into a native .NET framework application. The Silverlight version's LL(*) Parser Framework is object model compatible with the WPF version of SyntaxEditor, thus making this possible.

Debugger Layout

The debugger comes with a number of panels that contain useful information about your grammar. Some of them are only used when stepping through the process of parsing the example text.

The LL Parser Debugger

EBNF Rules Pane

The main part of the debugger window is taken up by the EBNF representation of your grammar. Each production that you defined in your grammar class should show up in this window, expressed in standard EBNF notation.

If you find that you are having trouble with one of your productions, this window is a good place to look to see if the production is being interpreted as you expected.

Input Tab

At the bottom of the debugger pane, there is an Input tab. This tab is populated with the example code from the Language Project that Language Designer currently has loaded.

The text entered in this tab is used as input for the parser for debugging.

You can edit the text in this input if you want to test something specific, but changes to the contents of this box are not preserved for future debugging sessions.

Parse Errors Tab

The Parse Errors tab will report any parsing errors encountered while debugging.

If an error is reported while debugging, either the example input text is incorrectly formed, or the grammar is not correct.

Terminals Tab

The Terminals tab reports all the terminals that are defined in the Grammar.

Non-Terminal Stack Tab

The Non-Terminal Stack tab reports the stack from the parser, as you are single-stepping through a parse operation.

Matches Tab

The Matches tool reports the matched results from each production as you are stepping through a parse operation. This can be very helpful in debugging a grammar as you can see the immediate results from a specific production as it completes.

Conditions Tab

The Conditions tool lists all the possible next tokens that are valid for the current production. This information is used to determine whether the parser can attempt a match within a production by comparing the list with the look-ahead token.

Opening a Parser

Clicking the Open Parser button launches a file browser dialog. Navigate to and select an assembly that contains a non-abstract ILLParser implementation. Note that the parser implementation class must have a parameterless constructor.

If there are two or more non-abstract ILLParser implementations in the same assembly, the LL Parser Debugger will prompt and ask which parser it should load.

There are a number of grammar-related exceptions that can occur when loading an assembly for debugging. The exception message should be helpful in solving the issue that is causing the exception, and the issue(s) must be resolved before the debugger can load the exception and debug the grammar.

Once the parser is loaded, you should see the main area of the debugger populate with EBNF rules that represent your grammar. This will be described in further detail below.

Debugging

The LL Parser Debugger controls.

If you would like to see the complete results of parsing the example text without stepping through, you can simply click the Start button. The Parse Errors tab will populate with any generated error messages. The Matches tool will populate with the AST result of the parsing operation.

If there is an issue in the complete parse tree that you would like to debug, it can be very informative to step through the grammar. You can begin this by pressing the Step Into button instead of the Start button. Each time you click Step Into, you will drill deeper into the production rules, following the parser's path. If you want to skip over a production rule that you are not interested in, you can click Step Over. Or, if you would like to leave a production rule that you no longer need additional information about, you can click Step Out, and the debugger will continue from the next element of the parent production.

If you know the exact production you would like to debug, you can place a breakpoint on that production by clicking within the production and clickin the Toggle Breakpoint button. You can then press Start and the debugger will run until it hits that breakpoint.

You can stop the debugger at any time by clicking the Stop button.

If you would like to see the next Term that the debugger will evaluate, click the Show Next Term button. The next term is usually in view already by default, but if you scrolled the view away from that location, the Show Next Term button provides a convenient way to relocate the debugger's position in the grammar.

Hotkeys

The LL Parser Debugger supports the same main debugging hotkeys as Visual Studio.

Hotkey Combination | Action
F5 | Start Debugging
Shift+F5 | Stop Debugging
F11 | Step Into
F10 | Step Over
Shift+F11 | Step Out
F9 | Toggle Breakpoint

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Free Languages

SyntaxEditor Reference
Free Languages

SyntaxEditor includes over 20 free syntax language implementations that can be used in your applications, everything from C# and VB, to HTML, CSS, Java, and more.

This topic contains these sections:

  • Plain Text Language
  • Open Source Languages with a Dynamic Lexer
  • Creating a New Language

Plain Text Language

The plain text language is included as a syntax language to use when no other language is applicable. Since the ICodeDocument.Language property cannot be set to a null value, the plain text language is the ideal language to use when a document doesn't need a language implementation assigned.

The plain text language can be retrieved via the SyntaxLanguage.PlainText property.

Open Source Languages with a Dynamic Lexer

There are a number of open source languages included that use a dynamic lexer.

The languages each have a language project that can be opened and edited using the Language Designer tool. That tool allows you to modify information about a language in a language project, and generate code for the language based the project. Language project files are located in this folder relative to the Sample Browser project's root:

\ProductSamples\SyntaxEditorSamples\Languages\Projects

Note Note
The language projects all specify a code generation output path that is valid on our development machines. The Language Designer will warn you with an error when building the language projects if the path does not exist on your machine. In that case, simply change to the code generation output path to another location that is valid for your machine.

Each of the languages that have language projects in the folder above have had a language definition file code-generated by the Language Designer tool. The language definition files can be distributed with your applications and loaded at run-time. Language definition files are located in this folder relative to the Sample Browser project's root:

\ProductSamples\SyntaxEditorSamples\Languages\Definitions

This is the list of languages included:

Language Name | Project Filename | Definition Filename
Assembly | Assembly.langproj | Assembly.langdef
Batch File | BatchFile.langproj | BatchFile.langdef
C | C.langproj | C.langdef
C# | CSharp.langproj | CSharp.langdef
C++ | Cpp.langproj | Cpp.langdef
CSS | Css.langproj | Css.langdef
HTML | Html.langproj | Html.langdef
INI File | IniFile.langproj | IniFile.langdef
Java | Java.langproj | Java.langdef
JavaScript | JavaScript.langproj | JavaScript.langdef
Lua | Lua.langproj | Lua.langdef
Markdown | Markdown.langproj | Markdown.langdef
MSIL | Msil.langproj | Msil.langdef
Pascal | Pascal.langproj | Pascal.langdef
Perl | Perl.langproj | Perl.langdef
PHP | Php.langproj | Php.langdef
PowerShell | PowerShell.langproj | PowerShell.langdef
Python | Python.langproj | Python.langdef
RTF | Rtf.langproj | Rtf.langdef
Ruby | Ruby.langproj | Ruby.langdef
SQL | Sql.langproj | Sql.langdef
VB | VB.langproj | VB.langdef
VBScript | VBScript.langproj | VBScript.langdef
XAML | Xaml.langproj | Xaml.langdef
XML | Xml.langproj | Xml.langdef

Creating a New Language

Don't see a language listed above that fits your needs? No problem!

One option if one of the languages above is close to your language syntactically, is to copy the related language project file, and open your copied language project in the Language Designer tool to change its lexer configuration and other features appropriately.

Another option is to use the Language Designer tool to create a new language project from scratch. It has a bunch of helpful features to get you up and running quickly with a custom syntax language implementation.

Be sure to read through the Language Creation Guide for details on what a syntax language is and what features are available to be added to a language. That is essential information for building your own syntax language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


The 'Simple' Language (used in samples)

SyntaxEditor Reference
The 'Simple' Language (used in samples)

The 'Simple' language is a very basic sort of language that we created to help demonstrate how to implement language-related features with SyntaxEditor and the text/parsing framework. It is used in several samples.

The Simple language supports statements, expressions, and function/variable declarations.

This topic contains these sections:

  • Code Sample
  • Lexical Structure
  • Semantic Structure (in EBNF)

Code Sample

This snippet shows some sample Simple language code:

Simple
Copy
/*
    The Simple language demonstrates a C-like
    language that only knows several keywords and
    operators.  All variables are integer numbers.
*/

function Add(x, y) {
    return x + y;
}

function Increment(x) {
    return (x + 1);
}

function IncrementAndMultiply(x, y) {
    // This function calls another function
    var result;
    result = Increment(x);
    return result * y;
}

Lexical Structure

The Simple language is case sensitive, similar to C.

Identifiers must start with a letter or underscore, and can only contain letters, digits, and underscore characters.

Only integer numbers are supported.

Keywords include:

  • function - Declares a function
  • return - Returns a value
  • var - Declares a variable

Operators include:

  • = - Assignment
  • == - Equality
  • != - Inequality
  • + - Addition
  • - - Subtraction
  • * - Multiplication
  • / - Division

Delimiters include:

  • { - Scope start
  • } - Scope end
  • ( - Group start
  • ) - Group end
  • , - Comma
  • ; - Statement end

Comments include:

  • // Single-line comment
  • /* Range comment */

Semantic Structure (in EBNF)

This EBNF describes the semantic structure of the Simple language:

Code Snippet
Copy
CompilationUnit:
    FunctionDeclarationList?

FunctionDeclarationList:
    FunctionDeclaration
    FunctionDeclarationList FunctionDeclaration

FunctionDeclaration:
    "function" "identifier" "(" FunctionParameterList? ")" Block

FunctionParameterList:
    "identifier"
    FunctionParameterList "," "identifier"

StatementList:
    Statement
    StatementList Statement

Statement:
    Block
    EmptyStatement
    VariableDeclarationStatement
    AssignmentStatement
    ReturnStatement

Block:
    "{" StatementList? "}"

EmptyStatement:
    ";"

VariableDeclarationStatement:
    "var" "identifier" ";"

AssignmentStatement:
    "identifier" "=" Expression ";"

ReturnStatement:
    "return" Expression ";"

Expression:
    EqualityExpression

EqualityExpression:
    AdditiveExpression
    AdditiveExpression "==" EqualityExpression
    AdditiveExpression "!=" EqualityExpression

AdditiveExpression:
    MultiplicativeExpression
    MultiplicativeExpression "+" AdditiveExpression
    MultiplicativeExpression "-" AdditiveExpression

MultiplicativeExpression:
    PrimaryExpression
    PrimaryExpression "*" MultiplicativeExpression
    PrimaryExpression "/" MultiplicativeExpression

PrimaryExpression:
    NumberExpression
    SimpleName
    FunctionAccessExpression
    ParenthesizedExpression

NumberExpression:
    "number"

SimpleName:
    "identifier"

FunctionAccessExpression:
    "identifier" "(" FunctionArgumentList? ")"

FunctionArgumentList:
    FunctionArgument
    FunctionArgumentList "," FunctionArgument

FunctionArgument:
    Expression

ParenthesizedExpression:
    "(" Expression ")"

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Regular Expression Guide
Overview

The text/parsing framework includes a custom traditional backtracking Nondeterministic Finite Automation (NFA) regular expression engine. Other products that use a similar engine are the .NET framework, Perl, Python, Emacs, and Tcl. This regular expression engine is used by features such as the search object model, allowing for regular expression searching.

The regular expression engine also is the core for performing lexing and tokenization with a dynamic lexer. The engine is very robust and is capable of parsing even the most complicated of languages.

This topic contains these sections:

  • Language Elements
  • Dynamic Lexical Macros
  • Invalid Regular Expressions

Language Elements

The text/parsing framework contains a regular expression engine that accepts an extensive set of regular expression elements, enabling you to efficiently search for text patterns. This topic details the set of characters, operators, and constructs that you can use to define regular expressions.

See the Language Elements topic for more information.

Dynamic Lexical Macros

The built-in regular expression engine, when used with dynamic lexers, allows for the definition of macros that represent regular expression elements. These macros are valid for use in any regular expression within a dynamic lexer and promote reusability of common patterns.

See the Dynamic Lexical Macros topic for more information.

Invalid Regular Expressions

If you enter an invalid regular expression pattern that the regular expression engine cannot parse, an InvalidRegexPatternException is raised with a message describing the problem.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Language Elements

Regular Expression Guide
Language Elements

The text/parsing framework contains a regular expression engine that accepts an extensive set of regular expression elements, enabling you to efficiently search for text patterns. This topic details the set of characters, operators, and constructs that you can use to define regular expressions.

Whitespace characters are ignored in all regular expression patterns. Use the \s character class to indicate whitespace matching.

This topic contains these sections:

  • Character Escapes
  • Character Classes
  • Supported Unicode General Categories
  • Quantifiers
  • Atomic Zero-Width Assertions
  • Grouping Constructs
  • Substitutions
  • Other Constructs

Character Escapes

Most of the important regular expression language operators are unescaped single characters. The escape character \ (a single backslash) signals to the regular expression parser that the character following the backslash is not an operator. For example, the parser treats an asterisk (*) as a repeating quantifier and a backslash followed by an asterisk (\*) as the Unicode character \u002A.

Escaped Character | Description
(Ordinary characters) | Characters other than . $ ^ { [ ( | ) * + ? \ match themselves.
\a | Matches a bell (alarm) \u0007.
\t | Matches a tab \u0009.
\r | Matches a carriage return \u000D.
\v | Matches a vertical tab \u000B.
\f | Matches a form feed \u000C.
\n | Matches a new line \u000A.
\e | Matches an escape \u001B.
\040 | Matches an ASCII character as octal (exactly three digits). The character \040 represents a space.
\x20 | Matches an ASCII character using hexadecimal representation (exactly two digits).
\u0020 | Matches a Unicode character using hexadecimal representation (exactly four digits).
\ | When followed by a character that is not recognized as an escaped character, matches that character. For example, \* is the same as \x2A.

Character Classes

The following table summarizes character matching syntax.

Character Class | Description
. | Matches any character except \n. When within a character class, the . will be treated as a period character.
[aeiou] | Matches any single character included in the specified set of characters.
[^aeiou] | Matches any single character not in the specified set of characters.
[0-9a-fA-F] | Use of a hyphen (–) allows specification of contiguous character ranges.
\p{name} | Matches any character in the Unicode general category specified by name (for example, Ll, Nd, Z).
\P{name} | Matches any character not in Unicode general category specified in name.
\w | Matches any word character, which includes letters, digits, and underscores.
\W | Matches any non-word character.
\s | Matches any whitespace character.
\S | Matches any non-whitespace character.
\d | Matches any decimal digit.
\D | Matches any non-digit.
[.\w\s] | Escaped built-in character classes such as \w and \s may be used in a character class. This example matches any period, word or whitespace character.

Supported Unicode General Categories

Unicode defines the general categories and descriptions listed in the following table. These categories can be used with the \p and \P character classes described above.

Category | Description
Lu | Letter, Uppercase
Ll | Letter, Lowercase
Lt | Letter, Titlecase
Lm | Letter, Modifier
Lo | Letter, Other
Mn | Mark, Nonspacing
Mc | Mark, Spacing Combining
Me | Mark, Enclosing
Nd | Number, Decimal Digit
Nl | Number, Letter
No | Number, Other
Pc | Punctuation, Connector
Pd | Punctuation, Dash
Ps | Punctuation, Open
Pe | Punctuation, Close
Pi | Punctuation, Initial quote
Pf | Punctuation, Final quote
Po | Punctuation, Other
Sm | Symbol, Math
Sc | Symbol, Currency
Sk | Symbol, Modifier
So | Symbol, Other
Zs | Separator, Space
Zl | Separator, Line
Zp | Separator, Paragraph
Cc | Other, Control
Cf | Other, Format
Cs | Other, Surrogate
Co | Other, Private Use
Cn | Other, Not Assigned

Additional special categories are supported that represent a set of Unicode character categories, as shown in the following table:

Category | Description
C | (All control characters) Cc, Cf, Cs, Co, and Cn.
L | (All letters) Lu, Ll, Lt, Lm, and Lo.
M | (All diacritic marks) Mm, Mc, and Me.
N | (All numbers) Nd, Nl, and No.
P | (All punctuation) Pc, Pd, Ps, Pe, Pi, Pf and Po.
S | (All symbols) Sm, Sc, Sk, and So.
Z | (All separators) Zs, Zl, and Zp.

Quantifiers

Quantifiers add optional quantity data to a regular expression. A quantifier expression applies to the character, group, or character class that immediately precedes it.

The following table describes the metacharacters that affect matching quantity.

Quantifier | Description
* | Specifies zero or more matches; for example, \w* or (abc)*. Same as {0,}.
+ | Specifies one or more matches; for example, \w+ or (abc)+. Same as {1,}.
? | Specifies zero or one matches; for example, \w? or (abc)?. Same as {0,1}.
{n} | Specifies exactly n matches; for example, (pizza){2}.
{n,} | Specifies at least n matches; for example, (abc){2,}.
{n,m} | Specifies at least n, but no more than m, matches.

Atomic Zero-Width Assertions

The metacharacters described in the following table do not cause the engine to advance through the string or consume characters. They simply cause a match to succeed or fail depending on the current position in the string. For instance, ^ specifies that the current position is at the beginning of a line or string. Thus, the regular expression ^#region returns only those occurrences of the character string #region that occur at the beginning of a line.

Assertion | Description
^ | Specifies that the match must occur at the beginning of the document or the beginning of the line.
$ | Specifies that the match must occur at the end of the string, before \n at the end of the string, or at the end of the line.
\A | Specifies that the match must occur at the beginning of the document.
\z | Specifies that the match must occur at the end of the document.
\b | Specifies that the match must occur on a boundary between \w (alphanumeric) and \W (nonalphanumeric) characters.
\B | Specifies that the match must not occur on a \b boundary.

Grouping Constructs

Grouping constructs allow you to capture groups of subexpressions and to increase the efficiency of regular expressions with noncapturing lookahead and lookbehind modifiers.

( ) | Captures the matched substring if used in a find/replace operation. In lexing, provides non-captured grouping. Find/replace captures using ( ) are numbered automatically based on the order of the opening parenthesis, starting from one. The first capture, capture element number zero, is the text matched by the whole regular expression pattern.
(?= ) | Zero-width positive lookahead assertion. Continues match only if the subexpression matches at this position on the right. For example, _(?=\w) matches an underscore followed by a word character, without matching the word character.
(?! ) | Zero-width negative lookahead assertion. Continues match only if the subexpression does not match at this position on the right. For example, \b(?!un)\w+\b matches words that do not begin with un.
(?<= ) | Zero-width positive lookbehind assertion. Continues match only if the subexpression matches at this position on the left. For example, (?<=19)99 matches instances of 99 that follow 19.
(?<! ) | Zero-width negative lookbehind assertion. Continues match only if the subexpression does not match at this position on the left.

Substitutions

Substitutions are allowed only within find/replace replacement patterns.

Character escapes and substitutions are the only special constructs recognized in a replacement pattern. For example, the replacement pattern a*$1b inserts the string a* followed by the substring matched by the first capturing group, if any, followed by the string b. The * character is not recognized as a metacharacter within a replacement pattern. Similarly, $ patterns are not recognized within regular expression matching patterns. Within regular expressions, $ designates the end of the string.

The following table shows how to define named and numbered replacement patterns.

Construct | Description
$1 | Substitutes the last substring matched by group number 1 (decimal). The second group is number 2 ($2), and so on.
$0 | Substitutes a copy of the entire match itself.
$& | Substitutes a copy of the entire match itself.
$$ | Substitutes a single $ literal.

Other Constructs

The following table lists other regular expression constructs.

Construct | Description
" " | Encapsulates a fixed string of characters.
{ } | Provides a call to a lexical macro. The use of a WordMacro (which is similar to \w) would appear as {WordMacro}.
(?# ) | Inline comment inserted within a regular expression. The comment terminates at the first closing parenthesis character.
| | Provides an alternation construct that matches any one of the terms separated by the | (vertical bar) character. For example, cat|dog|tiger. The leftmost successful match wins.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Dynamic Lexical Macros

Regular Expression Guide
Dynamic Lexical Macros

The built-in regular expression engine, when used with dynamic lexers, allows for the definition of macros that represent regular expression elements. These macros are valid for use in any regular expression within a dynamic lexer and promotes reusability of common patterns.

This topic contains these sections:

  • Usage
  • Built-In Macros

Usage

Using defined macros is easy. To reference a macro, simply type its name within curly braces ({ ... }).

This regular expression uses a macro that represents the character class [0-9] to build a decimal number regular expression.

{Digit}+ (\. {Digit}+)?

This regular expression builds a C# identifier using two macros.

(_ | {Alpha})({Word})*

Built-In Macros

The regular expression engine recognizes a number of built-in macros. If a dynamic lexer defines a lexical macro of the same key as a built-in lexical macro, the user's definition will override the system definition.

The following table summarizes all of the built-in macros:

Name | Description
All | Contains all Unicode characters. This is the same as: [\u0000-\uFFFF].
Alpha | Contains all Unicode alphabetic digits. This is the same as \p{L} (all letters).
Digit | Contains all Unicode decimal digits. This is the same as \d and \p{Nd}.
HexDigit | Contains all Unicode hexidecimal digits. This is the same as [0-9a-fA-F].
LineTerminator | Contains all Unicode line terminators. This is the same as [\n\r\p{Zl}\p{Zp}].
LineTerminatorWhitespace | Contains all Unicode line terminators and whitespace characters. This is the same as \s or [\f\n\r\t\v\x85\p{Z}].
NonAlpha | Contains the inverse of Alpha.
NonDigit | Contains the inverse of Digit.
None | Contains no characters.
NonHexDigit | Contains the inverse of HexDigit.
NonLineTerminator | Contains the inverse of LineTerminator.
NonLineTerminatorWhitespace | Contains the inverse of LineTerminatorWhitespace.
NonWhitespace | Contains the inverse of Whitespace.
NonWord | Contains the inverse of Word.
Whitespace | Contains all Unicode whitespace characters. This is the same as [\f\t\v\x85\p{Zs}].
Word | Contains all Unicode word characters. This is the same as \w and [\p{L}\p{Nd}\p{Pc}] (all letters, decimal digits, and connectors like underscore).

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

LL(*) Parser Framework
Overview

The LL(*) Parser Framework is Actipro's own framework for constructing robust text parsers that work standalone or with code editor controls like SyntaxEditor. The framework features grammars that are written in C#/VB using EBNF-like notation, customizable AST construction, advanced error handling/reporting, easy code injection, a complete debugger UI, and much more.

A parsing framework is the key to enhancing a SyntaxEditor editing experience because it gives us meaningful information about what is contained in the document. This not only can be used to provide contextual information to the end user (what method is the caret in), but is used to help drive features like automated IntelliPrompt completion lists, parameter info, and quick info.

This topic contains these sections:

  • Parser Type
  • Feature Summary
  • Getting Started
  • Lexer Preparation
  • Parser Infrastructure
  • Symbols and EBNF Terms
  • Walkthrough: Symbols and EBNF Terms
  • Tree Constructors
  • Walkthrough: Tree Constructors
  • Callbacks and Error Handling
  • Walkthrough: Callbacks and Error Handling
  • Custom Data

Parser Type

The parser in our framework is LL(*), meaning it is a top-down parser that can run on a subset of context-free grammars. It parses input from left to right, traces leftmost derivation, and by default uses one symbol of look-ahead. This normally would mean LL(1), however can-match callbacks allow infinite symbol look-ahead, thus making it LL(*).

LL parsers do not support left recursion however grammars can generally be refactored to eliminate left recursion and turn it into right recursion instead. Ambiguity can be resolved using can-match callbacks. Examples of handling both scenarios are given in this framework's documentation.

Feature Summary

There are many types of parsers, each with their pros and cons. Actipro's LL(*) Parser Framework was carefully designed to be easy-to-use, provide an enormous feature set, and address the most common shortcomings encountered with other third-party parsers.

The frameworks features include:

  • A top-down LL parser that supports infinite symbol look-ahead.
  • Grammars built directly in C#/VB code using EBNF-like syntax, made possible via operator overloading, implicit type conversion, and delegates.
  • No code generation, everything is interpreted.
  • Pre-existing grammars can be programmatically altered before they are compiled and used.
  • Can-match callbacks can provide code-based determination of whether a non-terminal can match with the parser's current state.
  • Custom code callbacks can be injected anywhere in the grammar before/after an EBNF term is parsed, or on success/error.
  • Automated parse error reporting and recovery options, with the ability to customize.
  • All productions support customized AST (abstract syntax tree) construction rules using numerous built-in tree constructor options, and ability to create custom tree constructors.
  • Generated AST nodes are automatically assigned the proper text offsets.
  • Re-use ILexer implementations that have already been made for a language.
  • Filter out tokens that are meaningless to the parser (comments, etc.).
  • Designed to integrate easily with SyntaxEditor.
  • Complete debugger UI in the Language Designer tool that allows you to step through a parser to see exactly how it is matching and building results.

Getting Started

There are five steps involved in using the LL(*) Parser Framework to create a parser for a language.

See the Getting Started topic for more information.

Lexer Preparation

The core parser in the LL(*) Parser Framework depends on an ILexer to provide tokens for consumption. This topic discusses how to properly prepare a lexer for use with a parser.

See the Lexer Preparation topic for more information.

Parser Infrastructure

There are several classes that will need to be created and connected in order to use the LL(*) Parser Framework. This topic makes the process easy by guiding you through each step that is required.

See the Parser Infrastructure topic for more information.

Symbols and EBNF Terms

A grammar is a set of symbols, both terminals or non-terminals, along with production rules that determine how to parse text for a formal language, where there is a single starting symbol from which parsing should begin.

See the Symbols and EBNF Terms topic for more information.

Walkthrough: Symbols and EBNF Terms

In this walkthrough, we are going to write a grammar for a language called Simple. The Simple language is basically a small subset of a Javascript-like language. When we're done, we'll load it up into a SyntaxEditor and we'll look at the AST results that are generated for us based on some input code.

See the Walkthrough: Symbols and EBNF Terms topic for more information.

Tree Constructors

Non-terminal productions will by default produce a very verbose AST that generally contains much more information than is useful for later consumption. The LL(*) Parser Framework has an extremely powerful tree construction mechanism with numerous built-in helper methods to do common tree construction tasks. You also have the ability to create completely custom tree construction nodes via C#/VB code if you like.

See the Tree Constructors topic for more information.

Walkthrough: Tree Constructors

In this walkthrough, we are going to revisit the Simple language and will enhance our grammar productions with tree constructors so that we make the resulting AST very concise.

See the Walkthrough: Tree Constructors topic for more information.

Callbacks and Error Handling

The next step in building a grammar is to make sure that it properly handles errors. After all, since this grammar framework is intended to be used with SyntaxEditor, we have to assume that most of the time the document’s code passed to our grammar parser will be in an invalid state. The user is continuously typing and modifying it.

In this topic, we will look at the various callbacks that are available to you, probably the most important of which are the error handling callbacks. We'll also dig into error handling options.

See the Callbacks and Error Handling topic for more information.

Walkthrough: Callbacks and Error Handling

In this topic we’ll examine the importance of adding error handling. We’ll enhance our Simple language grammar to properly recover from nearly any invalid syntax in a document so that it can continue parsing the rest of the document.

See the Walkthrough: Callbacks and Error Handling topic for more information.

Custom Data

The IParserState object passed to each callback in the parser framework has a property on it where custom data can be tracked and updated throughout each parsing operation.

Anything can be placed in this custom data store. It could be used to help perform semantic validation, construct name tables, and more.

See the Custom Data topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

LL(*) Parser Framework
Getting Started

There are five steps involved in using the LL(*) Parser Framework to create a parser for a language.

Check out the sections in this topic for more information on each of these steps.

  • Assembly Requirements
  • Step 1: Constructing a Lexer
  • Step 2: Creating the Core Classes
  • Step 3: Set Up Symbols and Non-Terminal Productions
  • Step 4: Add Customized Tree Constructors
  • Step 5: Add Error Handling and Advanced Error Reporting

Assembly Requirements

The following list indicates the assemblies that are used with the LL(*) Parser Framework.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | No * | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | No * | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control

* Not required however is used to integrate parsers made with the framework with a SyntaxEditor control.

Step 1: Constructing a Lexer

The core parser in the LL(*) Parser Framework depends on an ILexer to provide tokens for consumption.

The easiest and recommended way to fulfill this need is to use the Language Designer to create a new language. Once you have a language designed, you can generate source files which you can then include in your project. One of the generated source files will contain a class that implements the ILexer interface.

The new language's lexer can more often than not be reused for the syntax highlighting engine. Or if you have already created a lexer for your language, you can probably reuse it here.

In some cases, a lexer used to drive syntax highlighting may have different tokenization requirements than the lexer used to feed tokens to the parser framework. In this scenario, a second lexer with different logic can be created for use with the parser framework.

For more information on constructing a lexer for the parsing framework, view the Lexer Preparation topic.

Step 2: Creating the Core Classes

There are a few classes which you will need to create in order to use the LL(*) Parser Framework.

The most important one, the Grammar class, contains the core of the whole setup. Its constructor will set up the productions that tell the LL(*) Parser Framework how to interpret the syntax of your language.

An ILLParser-based class (you should generally inherit from LLParserBase) is registered as a service to the SyntaxLanguage that is associated with the SyntaxEditor.

An ITokenReader-based class is necessary to provide tokens to the parsing framework. For some languages with mergable lexers, it is sufficient to use the existing MergableTokenReader class. However in non-mergable lexer scenarios or scenarios where you wish to filter the tokens being supplied to the parser, you may need to subclass TokenReaderBase or MergableTokenReader for more control.

For more information on creating the core classes, view the Parser Infrastructure topic.

Step 3: Set Up Symbols and Non-Terminal Productions

Your grammar class will need to define the rules for how the core parser will interpret input. This is done by defining all the symbols that are in your language and defining a number of productions which reference the symbols.

There are two types of symbols: terminals and non-terminals. Terminals are the lowest-level fixed-input lexical element used in a grammar production rule. In the case of Actipros text framework, terminals equate to tokens that are read in from a lexer. Non-terminals each have a production rule that is comprised of some combination of terminal and non-terminal symbol references.

For more information on setting up the symbols and non-terminal productions, view the Symbols and EBNF Terms topic.

Step 4: Add Customized Tree Constructors

The default tree constructors will output nearly everything that is parsed. You will probably want to customize the tree construction to generate a cleaner tree.

There are a number of built-in tree construction nodes that should handle nearly all your tree construction needs. These nodes are created by method calls on the Grammar class. If you require special tree construction logic, there are provisions available.

For more information on adding customized tree constructors, view the Tree Constructors topic.

Step 5: Add Error Handling and Advanced Error Reporting

When building a grammar, it is important to cleanly handle errors and report helpful messages to the user. This framework is intended to be used with SyntaxEditor, so we have to assume that the code passed to our parser will often be in an invalid state. This is because the user is continuously typing and modifying it.

Error handling can be performed automatically, or manually via the use of error callbacks. There are a number of built-in error callbacks that can be utilized, and you can also create custom error callbacks.

It is possible to assign an ErrorAlias to any Terminal and NonTerminal instance, which gives you greater control over what automated messages are reported and when.

For more information on adding error handling and advanced error reporting, view the Callbacks and Error Handling topic.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Lexer Preparation

LL(*) Parser Framework
Lexer Preparation

The core parser in the LL(*) Parser Framework depends on an ILexer to provide tokens for consumption. This topic discusses how to properly prepare a lexer for use with a parser.

The easiest and recommended way to fulfill this need is to use the Language Designer to create a new language. Once you have a language designed, you can generate source files which you can then include in your project. One of the generated source files will contain a class that implements the ILexer interface.

As mentioned above, any ILexer-based object will work with the LL(*) parser. Thus you don't have to use the Language Designer to create your lexer. All the techniques described in the Lexing portion of the documentation apply.

This topic contains these sections:

  • Designing A Parser-Friendly Dynamic Language
  • Generate Source Files
  • Advanced Languages

Designing A Parser-Friendly Dynamic Language

A lexer that is to be used with the parser framework has to take into account some special considerations. This section assumes you are already familiar with the Language Designer tool and understand the basic terminology.

Keywords for your language should each be defined with a separate token ID and key. This is because your parser will need to know which keyword was used in a particular location, not just that it is a keyword that was used.

It is best to avoid token rules that capture compound constructs. If you leave that sort of thing to the parser to handle, you will get more useful error messages and handling. Make tokens for the lowest possible level of constructs, such as individual symbols and punctuation, identifiers, numbers, etc.

It can be good practice to make a comment state and a string state for languages that have comments and strings. This allows for better handling of unterminated strings and comments and makes it easy to generate tokens for text that is within a string or comment.

Generate Source Files

You may be used to loading a language definition file (.langdef) into your application to provide a SyntaxLanguage for use with your SyntaxEditor, but the parsing framework's needs are more granular. For this reason, you need to generate source files for the language instead of the .langdef file. This will ensure that ILexer, ITokenIdProvider, and other classes are built that can be used by the parser.

See the Parser Infrastucture topic for more information on how to set up your SyntaxLanguage.

Advanced Languages

In some cases, a lexer used to drive syntax highlighting may have different tokenization requirements than the lexer used to feed tokens to the parser framework. In this scenario, a second lexer with different logic can be created for use with the parser framework.

The lexer used to drive syntax highlighting should always be registered on your syntax language as a lexer service, while the lexer used to provide tokens to the parser framework can optionally be different.

See the Parser Infrastructure topic for more information on how to set a different lexer up for the parser.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parser Infrastructure

LL(*) Parser Framework
Parser Infrastructure

There are several classes that will need to be created and connected in order to use the LL(*) Parser Framework. This topic makes the process easy by guiding you through each step that is required.

By the end of this topic, you should have a system built that can compile without errors. However, there are additional things you will need to do in the next topic and beyond before your parser will operate properly, such as adding grammar productions.

This topic contains these sections:

  • Grammar Class
  • ITokenReader Interface
  • ILLParser Interface
  • ILLParseData Interface
  • ISyntaxLanguage Interface

Grammar Class

The Grammar class contains the meat of the whole setup. To quickly sum up, a grammar is a set of parsing rules defined via EBNF for how to derive structure from text. It is used to tell the ILLParser how to parse text.

The grammar class constructor will do four tasks:

  1. Create terminals
  2. Create non-terminals
  3. Configure non-terminal productions
  4. Configure non-terminal can-match callbacks
We will explain these further in the Symbols and EBNF Terms and Walkthrough: Adding Symbols and Productions topics.

For now, all you need to do is create the class and the empty constructor. Here is an example of the Grammar derived class we've created for our Simple language:

C#
VB
Copy
​/// <summary>
/// Represents a <see cref="Grammar" /> for the <c>Simple</c> language.
/// </summary>
public class SimpleGrammar : Grammar {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleGrammar</c> class.
    /// </summary>
    public SimpleGrammar() : base("Simple") {

        // More code will be added here in the next several topics

    }
}
​''' <summary>
''' Represents a <see cref="Grammar" /> for the <c>Simple</c> language.
''' </summary>
Public Class SimpleGrammar
    Inherits Grammar

    ''' <summary>
    ''' Initializes a new instance of the <c>SimpleGrammar</c> class.
    ''' </summary>
    Public Sub New()
        MyBase.New("Simple")

        ' More code will be added here in the next several topics

    End Sub
End Class

ITokenReader Interface

An ITokenReader provides tokens to the parsing framework. A token reader is an intermediate class that is created for each parse request and sits between the ILexer that will be used to tokenize text for the parser, and the parser itself. This means that it can also be used to filter out certain tokens that the parser won't care about.

For instance, many parsers don't care about comments so those tokens can be skipped over by the token reader as it passes tokens up to the parser. Many parsers find that whitespace is insignificant as well. Thus whitespace can also generally be skipped over. There may be other token types that are desirable to be skipped by the token reader as it iterates and passes tokens to the parser.

If you are using a mergable lexer to supply tokens to the parser, it may be sufficient to use the built-in MergableTokenReader class since it fully implements ITokenReader. The MergableTokenReader class will by default provide every token from a mergable lexer to the parser. If you have a mergable lexer but would like to filter out certain token types, such as whitespace in a whitespace insensitive language, you can subclass MergableTokenReader as shown in sample below.

If you are using a non-mergable lexer then you should inherit TokenReaderBase instead and implement its abstract GetNextToken method, which simply returns the next token that will be consumed by the parser.

If you inherit from MergableTokenReader, your token reader class will need two things. First, you will need a public constructor which takes an ITextBufferReader and an IMergableLexer as arguments. Pass these along to the base constructor. Second, you will need to override the GetNextToken member.

Here is an example token reader, based on MergableTokenReader, which discards all whitespace tokens. The concepts here show how to filter tokens regardless of whether you inherit MergableTokenReader or TokenReaderBase. The SimpleParsingTokenId class contains token ID constants and was generated by the Language Designer tool using our Simple language project. You should have an equivalent class that was generated for your language. This also makes the assumption that you have a Whitespace token defined in the language that was used to generate the SimpleParsingTokenId class.

C#
VB
Copy
​/// <summary>
/// Represents an object that can provide tokens to a <see cref="ILLParser"/> in a forward-only direction for the <c>Simple</c> language.
/// </summary>
public class SimpleTokenReader : MergableTokenReader {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleTokenReader</c> class.
    /// </summary>
    /// <param name="reader">The <see cref="ITextBufferReader"/> to use for consuming text.</param>
    /// <param name="rootLexer">The root <see cref="IMergableLexer"/>.</param>
    public SimpleTokenReader(ITextBufferReader reader, IMergableLexer rootLexer) : base(reader, rootLexer) {}

    /// <summary>
    /// Returns the next <see cref="IToken"/> that will be consumed by the token reader.
    /// </summary>
    /// <returns>The next <see cref="IToken"/> that will be consumed by the token reader.</returns>
    protected override IToken GetNextToken() {
        // Call the base method
        IToken token = base.GetNextToken();

        // Loop to skip over tokens that are insignificant to the parser
        while (!this.IsAtEnd) {
            switch (token.Id) {
                case SimpleParsingTokenId.Whitespace:
                    // Skip
                    token = base.GetNextToken();
                    break;
                default:
                    return token;
            }
        }

        return token;
    }
}
​/// <summary>
/// Represents an object that can provide tokens to a <see cref="ILLParser"/> in a forward-only direction for the <c>Simple</c> language.
/// </summary>
public class SimpleTokenReader : MergableTokenReader {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleTokenReader</c> class.
    /// </summary>
    /// <param name="reader">The <see cref="ITextBufferReader"/> to use for consuming text.</param>
    /// <param name="rootLexer">The root <see cref="IMergableLexer"/>.</param>
    public SimpleTokenReader(ITextBufferReader reader, IMergableLexer rootLexer) : base(reader, rootLexer) {}

    /// <summary>
    /// Returns the next <see cref="IToken"/> that will be consumed by the token reader.
    /// </summary>
    /// <returns>The next <see cref="IToken"/> that will be consumed by the token reader.</returns>
    protected override IToken GetNextToken() {
        // Call the base method
        IToken token = base.GetNextToken();

        // Loop to skip over tokens that are insignificant to the parser
        while (!this.IsAtEnd) {
            switch (token.Id) {
                case SimpleParsingTokenId.Whitespace:
                    // Skip
                    token = base.GetNextToken();
                    break;
                default:
                    return token;
            }
        }

        return token;
    }
}

ILLParser Interface

You must create a parser class to register as a service with your language. This class will implement the ILLParser interface. Generally, you will want to inherit from LLParserBase class, which takes care of implementing most of the interface.

Your parser class must have a minimum of two things:

  1. It should declare a public constructor which passes a new instance of your grammar class to the base constructor.
  2. You must override the CreateTokenReader method, because it is declared abstract.

The CreateTokenReader override returns a new ITokenReader instance to provide tokens to the parsing framework. This method is called each time parsing is started, so it is important to make a new instance of the token reader to be used with each call.

In this example code, we will create and return a MergableTokenReader instance, but you could just as easily return a new instance of your own ITokenReader implementation. The SimpleLexer and SimpleClassificationTypeProvider classes were generated by the Language Designer tool using our Simple language project. You should have equivalent classes that were generated for your language.

C#
VB
Copy
​/// <summary>
/// Represents a parser for the <c>Simple</c> language.
/// </summary>
public class SimpleParser : LLParserBase {

    /// <summary>
    /// Initializes a new instance of the <c>SimpleParser</c> class.
    /// </summary>
    public SimpleParser() : base(new SimpleGrammar()) {}

    /// <summary>
    /// Creates an <see cref="ITokenReader"/> that is used by the parser to read through tokens.
    /// </summary>
    /// <param name="reader">The <see cref="ITextBufferReader"/> that provides access to the text buffer.</param>
    /// <returns>An <see cref="ITokenReader"/> that is used by the parser to read through tokens.</returns>
    public override ITokenReader CreateTokenReader(ITextBufferReader reader) {
        return new MergableTokenReader(reader, new SimpleLexer(new SimpleClassificationTypeProvider()));
    }
}
​''' <summary>
''' Represents a parser for the <c>Simple</c> language.
''' </summary>
Public Class SimpleParser
    Inherits LLParserBase

    ''' <summary>
    ''' Initializes a new instance of the <c>SimpleParser</c> class.
    ''' </summary>
    Public Sub New()
        MyBase.New(New SimpleGrammar())
    End Sub

    ''' <summary>
    ''' Creates an <see cref="ITokenReader"/> that is used by the parser to read through tokens.
    ''' </summary>
    ''' <param name="reader">The <see cref="ITextBufferReader"/> that provides access to the text buffer.</param>
    ''' <returns>An <see cref="ITokenReader"/> that is used by the parser to read through tokens.</returns>
    Public Overrides Function CreateTokenReader(ByVal reader As ITextBufferReader) As ITokenReader
        Return New MergableTokenReader(reader, New SimpleLexer(New SimpleClassificationTypeProvider()))
    End Function
End Class

ILLParseData Interface

By default, a parser will generate an LLParseData object. This object implements the ILLParseData interface, which returns data containing the IAstNode that was parsed, IParseError objects that were reported, and the ITextSnapshot that was used, if known. ILLParseData implements IParseErrorProvider, meaning that it can easily be wired up to show squiggle lines where parse errors occur.

It is possible that you will want to retain additional information from the parsing process than what is provisioned with this type. For instance, an XML language may wish to store a boolean flag indicating whether the document is well-formed. If this is the case, you can create a new parse data class that inherits from LLParseData. You can then add any additional properties you wish to be available.

If you do create a new parse data type, you will need to override the CreateParseData member. This override should look something like the following code. The SimpleParseData type represents the custom parse data type that you would create for your language.

C#
VB
Copy
​/// <summary>
/// Creates an <see cref="IParseData"/> for the specified <see cref="IParserState"/>.
/// </summary>
/// <param name="request">The <see cref="IParseRequest"/> that contains data about the requested parsing operation.</param>
/// <param name="state">The <see cref="IParserState"/> to examine.</param>
/// <returns>The <see cref="IParseData"/> that was created.</returns>
protected virtual IParseData CreateParseData(IParseRequest request, IParserState state) {
    SimpleParseData parseData = new SimpleParseData();
    this.InitializeParseData(parseData, state);

    // Add custom parse data to the parseData object

    return parseData;
}
​''' <summary>
''' Creates an <see cref="IParseData"/> for the specified <see cref="IParserState"/>.
''' </summary>
''' <param name="request">The <see cref="IParseRequest"/> that contains data about the requested parsing operation.</param>
''' <param name="state">The <see cref="IParserState"/> to examine.</param>
''' <returns>The <see cref="IParseData"/> that was created.</returns>
Protected Overridable Function CreateParseData(ByVal request As IParseRequest, ByVal state As IParserState) As IParseData
    Dim parseData As New SimpleParseData()
    Me.InitializeParseData(parseData, state)

    ' Add custom parse data to the parseData object

    Return parseData
End Function

ISyntaxLanguage Interface

Finally, you will need to register your parser class as a service with an ISyntaxLanguage for the parsing system to operate. You may also want to associate the ISyntaxLanguage with a SyntaxEditor instance.

If you used the Language Designer tool to generate source files for your language, you should have a source file which contains a syntax language class that inherits from SyntaxLanguage. You will have to register additional services than what is included in the generated class constructor. While you could simply add the additional registrations to the generated constructor, odds are you will need to regenerate those files at a later time. Rather than risk losing your changes to this class constructor if you overwrite it with the Language Designer's source code generator, we recommend creating a new class which inherits from the generated class. You can perform your additional registrations in the constructor of your derived class, and if you have to regenerate the base class, no changes are lost.

In addition to registering your parser class as a service, you might also want to register a ParseErrorTagger. This will cause parsing errors to be automatically marked with red squiggly underlines once everything is set up correctly.

Your new syntax language class should look something like the following code. The SimpleSyntaxLanguage class was generated by the Language Designer tool using our Simple language project. You should have an equivalent class that was generated for your language. The SimpleParser type is equivalent to the custom parser class that you would create for your language.

C#
VB
Copy
​/// <summary>
/// Represents a <c>Simple</c> syntax language definition.
/// </summary>
public class ExtendedSimpleSyntaxLanguage : SimpleSyntaxLanguage {

    /// <summary>
    /// Initializes a new instance of the <see cref="ExtendedSimpleSyntaxLanguage"/> class.
    /// </summary>
    public ExtendedSimpleSyntaxLanguage() {
        // Register a parser with the language
        this.RegisterService<IParser>(new SimpleParser());

        // Register a ParseErrorTagger so errors get squiggles
        this.RegisterService(new CodeDocumentTaggerProvider<ParseErrorTagger>(typeof(ParseErrorTagger)));
    }
}
​''' <summary>
''' Represents a <c>Simple</c> syntax language definition.
''' </summary>
Public Class ExtendedSimpleSyntaxLanguage
    Inherits SimpleSyntaxLanguage

    ''' <summary>
    ''' Initializes a new instance of the <see cref="ExtendedSimpleSyntaxLanguage"/> class.
    ''' </summary>
    Public Sub New()
        ' Register a parser with the language
        Me.RegisterService(Of IParser)(New SimpleParser())

        ' Register a ParseErrorTagger so errors get squiggles
        Me.RegisterService(New CodeDocumentTaggerProvider(Of ParseErrorTagger)(GetType(ParseErrorTagger)))
    End Sub
End Class

As mentioned in the Lexer Preparation topic, there are some rare cases where you might want a separate lexer defined for your syntax highlighting and for your parsing. This scenario can occur if the tokenization required to support your parser is different than the tokenization of text needed to support syntax highlighting.

In this scenario, set up your syntax language like normal. However when creating your ITokenReader in your ILLParser class, make sure it is using a new instance of your alternate lexer that should be generating tokens for the parser. The alternate ILexer you use for parsing can be created using a second language project in the Language Designer or you can create it using other techniques described in the lexing portion of the Text/Parsing Framework documentation.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Symbols and EBNF Terms

LL(*) Parser Framework
Symbols and EBNF Terms

A grammar is a set of symbols, both terminals or non-terminals, along with production rules that determine how to parse text for a formal language, where there is a single starting symbol from which parsing should begin.

Terminals are the lowest-level fixed-input lexical element used in a grammar production rule. In the case of the LL(*) Parser Framework, terminals equate to tokens that are read in from a lexer.

Non-terminals each have a production rule that is comprised of some combination of EBNF-like terminal and non-terminal symbol references.

This topic contains these sections:

  • What is EBNF?
  • EBNF Terms
  • Steps to Initialize a Grammar
  • Step 1: Create Terminals
  • Step 2: Create Non-Terminals
  • Step 3: Configure Non-Terminal Productions
  • Step 4: Configure Non-Terminal Can-Match Callbacks
  • Document End Terminal
  • Next Steps

What is EBNF?

Extended Backus–Naur Form (EBNF) is a meta-syntax notation used for expressing context-free grammars. Nearly all programming languages have some form of EBNF grammar specification available for reference on the Internet, so that compilers and other products know how to read the code and interpret it.

EBNF supports concatenation, alternation (options), quantifiers (optional, zero-or-more, one-or-more, etc.), and symbol (terminal and non-terminal) references.

Sample EBNF

Take this EBNF for a Simple language FunctionDeclaration non-terminal:

Code Snippet
Copy
FunctionDeclaration:
        "function" "identifier" "(" FunctionParameterList? ")" Block

That is saying the non-terminal’s name is FunctionDeclaration and a function declaration is built by a concatenation of a function terminal, followed by an identifier terminal, followed by an open parenthesis terminal, followed by an optional FunctionParameterList non-terminal, followed by a close parenthesis terminal, and ending with a Block non-terminal.

EBNF Terms

In the LL(*) Parser Framework, we have the concept of EBNF terms, all of which inherit an EbnfTerm base class. There are multiple classes use to represent various types of EBNF terms, each of which can be used within a production rule for a non-terminal:

  • EbnfProduction
  • EbnfTerminal
  • EbnfNonTerminal
  • EbnfQuantifier
  • EbnfConcatenation
  • EbnfAlternation

EbnfProduction

An EbnfProduction represents a production rule. Each NonTerminal has exactly one EbnfProduction associated with it that defines the EBNF for that non-terminal.

EbnfProduction objects have one child EbnfTerm that provides the EBNF pattern to match for the production rule. Productions can also optionally be assigned custom tree constructors, but we’ll get into that more in the Tree Constructors topic.

EbnfTerminal

An EbnfTerminal represents the usage of a pre-defined Terminal instance within a production rule.

For instance, a Terminal for an Identifier is likely to be used many places in a grammar. The Terminal for an Identifier is defined once at the top of the grammar declaration and each usage of it within a production is made via separate EbnfTerminal instances that reference the Terminal.

EbnfNonTerminal

An EbnfNonTerminal is the same as an EbnfTerminal except that instead of referencing a Terminal, it is referencing a NonTerminal.

EbnfQuantifier

An EbnfQuantifier wraps a child EbnfTerm and allows you to specify the minimum and maximum number of matches that can be made of the child term.

There are pre-defined helpers for standard Kleene operators such as optional (?), zero-or-more (*), and one-or-more (+).

EbnfConcatenation

An EbnfConcatenation is a sequence of other EbnfTerm objects that are matched at the same scope level when performing tree construction.

EbnfAlternation

An EbnfAlternation is a way for one of multiple supplied EbnfTerm options to match. In standard EBNF notation, alternations are typically represented with a vertical bar (|).

Steps to Initialize a Grammar

Now that we’ve covered the basics, let’s dig in and see how it works. We’ll write some grammar creation code that builds the FunctionDeclaration non-terminal example above.

A grammar is generally initialized in its constructor with four steps:

  1. Create terminals
  2. Create non-terminals
  3. Configure non-terminal productions
  4. Configure non-terminal can-match callbacks

Step 1: Create Terminals

The first step is where we simply declare Terminal variables, one for each token that will be supplied to us by a lexer and used in our non-terminal productions.

For the above example EBNF, we have four terminals, so let's declare them:

C#
VB
Copy
​var @closeParenthesis = new Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis")
    { ErrorAlias = "')'" };
var @function = new Terminal(SimpleTokenId.Function, "Function")
    { ErrorAlias = "'function'" };
var @identifier = new Terminal(SimpleTokenId.Identifier, "Identifier");
var @openParenthesis = new Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis")
    { ErrorAlias = "'('" };
​Dim closeParenthesis = New Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis") With {.ErrorAlias = "')'"}
Dim [function] = New Terminal(SimpleTokenId.Function, "Function") With {.ErrorAlias = "'function'"}
Dim identifier = New Terminal(SimpleTokenId.Identifier, "Identifier")
Dim openParenthesis = New Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis") With {.ErrorAlias = "'('"}

You’ll notice that each variable has a @ in front of it in the C# snippet. In C#, the @ character is simply an escape character in case the identifier is a keyword. In our case, we’re going to use it just so later in our non-terminal productions, we can easily tell which variables are terminals and which are non-terminals. Similar notation could be done in VB if desired using the square brace escape for identifiers as seen in the function variable declaration.

The Terminal constructor takes a token ID and the string key that identifies the terminal. Note that the SimpleTokenId class contains const token ID values and was generated for us by the Language Designer application. Token IDs are how the grammar parser matches terminals with tokens that are being read. The tokens come from the ITokenReader that was created by the ILLParser in use. See the Parser Infrastructure topic for more information on those types.

Some of the Terminal objects are also assigned an ErrorAlias. When parsing, if a terminal is expected, but the current token doesn’t match, a parse error will be reported that will use the error alias if it is specified. If not specified, it will fall back to using the terminal’s key.

Now that our four terminals are defined, let’s create our non-terminals.

Step 2: Create Non-Terminals

We now declare NonTerminal variables, one for each non-terminal in our grammar.

For this introduction we will just declare one non-terminal variable even though a real grammar would have a lot more and we are even referencing other non-terminals for FunctionParameterList and Block in our production below.

C#
VB
Copy
​var functionDeclaraion = new NonTerminal("FunctionDeclaration");
​Dim functionDeclaraion = New NonTerminal("FunctionDeclaration")

Step 3: Configure Non-Terminal Productions

Finally we come to the meat of the grammar. All terminals and non-terminal variables have been declared and we’re ready to get into some EBNF-like notation for our non-terminal production rules that consists of various EbnfTerm instances.

This is where the real magic of our grammar framework happens. The object model has a lot of operator overloads, methods, indexers, and implicit casts so that you can define production rules with a minimal amount of C#/VB code.

Let’s define our example non-terminal production rule now:

C#
VB
Copy
​functionDeclaration.Production = @function + @identifier + @openParenthesis +
    functionParameterList.Optional() + @closeParenthesis + block;
​functionDeclaration.Production = [function] + identifier + openParenthesis + _
    functionParameterList.Optional() + closeParenthesis + block

In C#, it is our convention to have @ characters at the start of our terminal variables so they stand out differently than non-terminal variables. The + operator means concatenation. Even though we are referencing Terminal and NonTerminal-based variables here, operator overloading is actually converting each Terminal reference to an EbnfTerminal and each NonTerminal reference to an EbnfNonTerminal behind the scenes. Finally note the Optional method call which wraps the EbnfNonTerminal for FunctionParameterList with an EbnfQuantifier that has a minimum of 0 and a maximum of 1.

Step 4: Configure Non-Terminal Can-Match Callbacks

Some grammars have more than one non-terminal that start with the same terminal and since our grammar is LL-based that defaults to one token of look-ahead, it is not allowed to have two or more non-terminals starting with the same terminal in an alternation together. If that was allowed, then the parser would never have the possibility of matching anything but the first non-terminal in the alternation that started with that terminal. This is called ambiguity and the grammar automatically detects it for you and warns you about it when it is found.

You can easily resolve ambiguity by setting a can-match callback on non-terminals that require it. In that case, your custom callback code is executed to determine if a non-terminal can match rather than the normal "first set" way (one token of look-ahead) that is ambiguous. Since the custom callback has access to all the remaining tokens in the text being parsed, it has infinite look-ahead. Thus the grammar as a whole can be considered LL(*).

This is a confusing concept but the Walkthrough: Symbols and EBNF Terms topic shows an example of why and when to do this.

Document End Terminal

Some languages like Visual Basic use line terminators to mark the end of statements. Problems could arise if at the end of a document there was a line containing a statement, and was immediately followed by the document end without a required line terminator in place. Since line terminators are significant to completing the statement, but there was a document end in place of the line terminator, a parse error would be reported.

To handle this scenario, the framework supports matching against document end. The document end terminal must use the standard document end token ID specified in the static DocumentEnd property.

Once a document end terminal has been defined, it can be used in a production like this, which correctly handles the scenario mentioned above:

C#
VB
Copy
​statement.Production = statementBody + (@lineTerminator | @documentEnd);
​statement.Production = statementBody + (@lineTerminator | @documentEnd)

Important Notes

When matching against the document end terminal, it is very important to realize that the parser is already at the document end, so no text is consumed when the match is made. This is unlike normal terminal matches in which case the matched text is consumed.

Thus if the document end terminal is referenced in a scenario where it can be repeatedly matched (such as in a quantifier) without any other required terminal matches in between, the parser could enter an infinite loop scenario.

This example code shows what NOT to do. Note the OneOrMore quantifier that could enter infinite looping at document end:

C#
VB
Copy
​statement.Production = statementBody + (@lineTerminator | @documentEnd).OneOrMore();
​statement.Production = statementBody + (@lineTerminator | @documentEnd).OneOrMore()

In languages like VB where there could be empty statements (effectively just a line terminator), make sure you only have the empty statement production reference the line terminator terminal, and not the document end terminal.

Next Steps

Wasn’t that easy? Of course a real grammar would have a lot more terminals, non-terminals, and production rules but you just follow the same process for them too.

There is one more thing to mention. Let’s assume we have the following input to the parser for this grammar:

Code Snippet
Copy
function Add() {}

The default tree constructors will build a full AST for you without you needing to do anything. Of course it includes much more information than is practical, which is why we’ll show in Tree Constructors topic how to optimize tree construction. Anyhow, here is a text representation of the AST node output for that function using the default tree constructor:

Code Snippet
Copy
FunctionDeclaration[
    "function"
    "Add"
    "("
    []
    ")"
    Block[
        "{"
        []
        "}"
    ]
]

Each AST node in the output automatically stores the proper start/end offsets for you too making it possible to query which node contains an offset later on.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Walkthrough: Symbols and EBNF Terms

LL(*) Parsing Framework
Walkthrough: Symbols and EBNF Terms

In this walkthrough, we are going to write a grammar for a language called Simple. The Simple language is basically a small subset of a Javascript-like language. When we're done, we'll load it up into a SyntaxEditor and we'll look at the AST results that are generated for us based on some input code.

This topic contains these sections:

  • Finding the Language Specification and EBNF
  • Grammar Initialization Overview
  • Step 1: Create Terminals
  • Step 2: Create Non-Terminals
  • Step 3: Configure Non-Terminal Productions
  • Step 3a: Elimination of Left Recursion
  • Step 3b: Elimination of Ambiguity
  • Step 4: Configure Non-Terminal Can-Match Callbacks
  • Default Tree Constructor Output

Finding the Language Specification and EBNF

The first thing to do when building a grammar for a language is to locate the language specification for the language. Nearly all programming languages have some sort of formal EBNF specification that tell parsers and compilers how to interpret their code.

This walkthrough series will use the Simple language. The complete EBNF for the Simple language is given in the Simple Language topic.

Grammar Initialization Overview

In the Parser Infrastructure topic, we discussed the creation of a Grammar-derived class. We also discussed that the class constructor will do four tasks:

  1. Create terminals
  2. Create non-teminals
  3. Configure non-terminal productions
  4. Configure non-terminal can-match productions

In the Symbols and EBNF Terms topic, we explained these steps and showed some quick examples. Now let's implement them for the entire language.

Step 1: Create Terminals

In the Simple language's EBNF specification, the terminals are quoted. We’ll now insert Terminal variable declarations for each of the terminals in our language into the constructor for our SimpleGrammar class.

C#
VB
Copy
​var @addition = new Terminal(SimpleTokenId.Addition, "Addition")
    { ErrorAlias = "'+'" };
var @assignment = new Terminal(SimpleTokenId.Assignment, "Assignment")
    { ErrorAlias = "'='" };
var @closeCurlyBrace = new Terminal(SimpleTokenId.CloseCurlyBrace, "CloseCurlyBrace")
    { ErrorAlias = "'}'" };
var @closeParenthesis = new Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis")
    { ErrorAlias = "')'" };
var @comma = new Terminal(SimpleTokenId.Comma, "Comma")
    { ErrorAlias = "','" };
var @division = new Terminal(SimpleTokenId.Division, "Division")
    { ErrorAlias = "'/'" };
var @equality = new Terminal(SimpleTokenId.Equality, "Equality")
    { ErrorAlias = "'=='" };
var @function = new Terminal(SimpleTokenId.Function, "Function")
    { ErrorAlias = "'function'" };
var @identifier = new Terminal(SimpleTokenId.Identifier, "Identifier");
var @inequality = new Terminal(SimpleTokenId.Inequality, "Inequality")
    { ErrorAlias = "'!='" };
var @multiplication = new Terminal(SimpleTokenId.Multiplication, "Multiplication")
    { ErrorAlias = "'*'" };
var @number = new Terminal(SimpleTokenId.Number, "Number");
var @openCurlyBrace = new Terminal(SimpleTokenId.OpenCurlyBrace, "OpenCurlyBrace")
    { ErrorAlias = "'{'" };
var @openParenthesis = new Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis")
    { ErrorAlias = "'('" };
var @return = new Terminal(SimpleTokenId.Return, "Return")
    { ErrorAlias = "'return'" };
var @semiColon = new Terminal(SimpleTokenId.SemiColon, "SemiColon")
    { ErrorAlias = "';'" };
var @subtraction = new Terminal(SimpleTokenId.Subtraction, "Subtraction")
    { ErrorAlias = "'-'" };
var @var = new Terminal(SimpleTokenId.Var, "Var")
    { ErrorAlias = "'var'" };
​Dim addition = New Terminal(SimpleTokenId.Addition, "Addition") With {.ErrorAlias = "'+'"}
Dim assignment = New Terminal(SimpleTokenId.Assignment, "Assignment") With {.ErrorAlias = "'='"}
Dim closeCurlyBrace = New Terminal(SimpleTokenId.CloseCurlyBrace, "CloseCurlyBrace") With {.ErrorAlias = "'}'"}
Dim closeParenthesis = New Terminal(SimpleTokenId.CloseParenthesis, "CloseParenthesis") With {.ErrorAlias = "')'"}
Dim comma = New Terminal(SimpleTokenId.Comma, "Comma") With {.ErrorAlias = "','"}
Dim division = New Terminal(SimpleTokenId.Division, "Division") With {.ErrorAlias = "'/'"}
Dim equality = New Terminal(SimpleTokenId.Equality, "Equality") With {.ErrorAlias = "'=='"}
Dim [function] = New Terminal(SimpleTokenId.Function, "Function") With {.ErrorAlias = "'function'"}
Dim identifier = New Terminal(SimpleTokenId.Identifier, "Identifier")
Dim inequality = New Terminal(SimpleTokenId.Inequality, "Inequality") With {.ErrorAlias = "'!='"}
Dim multiplication = New Terminal(SimpleTokenId.Multiplication, "Multiplication") With {.ErrorAlias = "'*'"}
Dim number = New Terminal(SimpleTokenId.Number, "Number")
Dim openCurlyBrace = New Terminal(SimpleTokenId.OpenCurlyBrace, "OpenCurlyBrace") With {.ErrorAlias = "'{'"}
Dim openParenthesis = New Terminal(SimpleTokenId.OpenParenthesis, "OpenParenthesis") With {.ErrorAlias = "'('"}
Dim [return] = New Terminal(SimpleTokenId.Return, "Return") With {.ErrorAlias = "'return'"}
Dim semiColon = New Terminal(SimpleTokenId.SemiColon, "SemiColon") With {.ErrorAlias = "';'"}
Dim subtraction = New Terminal(SimpleTokenId.Subtraction, "Subtraction") With {.ErrorAlias = "'-'"}
Dim var = New Terminal(SimpleTokenId.Var, "Var") With {.ErrorAlias = "'var'"}

As mentioned in the Symbols and EBNF Terms topic, it is helpful to prefix terminal variables with a @ character so they can be distinguished from non-terminals in the productions.

The SimpleTokenId class was generated by the Language Designer application and provides constant fields for each token ID produced by the Simple language’s lexer. The second parameter to the Terminal constructor is the terminal key, which is used to identify it.

When errors occur, the key is used in the error message unless an error alias is used. If an error alias is provided, it is used instead. For instance telling the user == expected is a much nicer error message than Equality expected.

Step 2: Create Non-Terminals

Now we’ll declare NonTerminal variables for each non-terminal in the grammar.

C#
VB
Copy
​this.Root = new NonTerminal("CompilationUnit");
var functionDeclaration = new NonTerminal("FunctionDeclaration");
var functionParameterList = new NonTerminal("FunctionParameterList");
var statement = new NonTerminal("Statement");
var block = new NonTerminal("Block");
var emptyStatement = new NonTerminal("EmptyStatement");
var variableDeclarationStatement = new NonTerminal("VariableDeclarationStatement");
var assignmentStatement = new NonTerminal("AssignmentStatement");
var returnStatement = new NonTerminal("ReturnStatement");
var expression = new NonTerminal("Expression");
var equalityExpression = new NonTerminal("EqualityExpression");
var additiveExpression = new NonTerminal("AdditiveExpression");
var multiplicativeExpression = new NonTerminal("MultiplicativeExpression");
var primaryExpression = new NonTerminal("PrimaryExpression");
var numberExpression = new NonTerminal("NumberExpression");
var simpleName = new NonTerminal("SimpleName");
var functionAccessExpression = new NonTerminal("FunctionAccessExpression");
var functionArgumentList = new NonTerminal("FunctionArgumentList");
var parenthesizedExpression = new NonTerminal("ParenthesizedExpression");
​Me.Root = New NonTerminal("CompilationUnit")
Dim functionDeclaration = New NonTerminal("FunctionDeclaration")
Dim functionParameterList = New NonTerminal("FunctionParameterList")
Dim statement = New NonTerminal("Statement")
Dim block = New NonTerminal("Block")
Dim emptyStatement = New NonTerminal("EmptyStatement")
Dim variableDeclarationStatement = New NonTerminal("VariableDeclarationStatement")
Dim assignmentStatement = New NonTerminal("AssignmentStatement")
Dim returnStatement = New NonTerminal("ReturnStatement")
Dim expression = New NonTerminal("Expression")
Dim equalityExpression = New NonTerminal("EqualityExpression")
Dim additiveExpression = New NonTerminal("AdditiveExpression")
Dim multiplicativeExpression = New NonTerminal("MultiplicativeExpression")
Dim primaryExpression = New NonTerminal("PrimaryExpression")
Dim numberExpression = New NonTerminal("NumberExpression")
Dim simpleName = New NonTerminal("SimpleName")
Dim functionAccessExpression = New NonTerminal("FunctionAccessExpression")
Dim functionArgumentList = New NonTerminal("FunctionArgumentList")
Dim parenthesizedExpression = New NonTerminal("ParenthesizedExpression")

Note how the grammar’s Root property is set to the root non-terminal.

Step 3: Configure Non-Terminal Productions

Next is the more interesting part. We’ll configure the production rules for each non-terminal. As explained in the Symbols and EBNF Terms topic, the LL(*) Parser Framework makes heavy use of operator overloads, methods, indexers, and implicit casts so that production rules can be created with minimal C#/VB code.

Here are the productions:

C#
VB
Copy
​this.Root.Production = functionDeclaration.ZeroOrMore();

functionDeclaration.Production = @function + @identifier + @openParenthesis +
    functionParameterList.Optional() + @closeParenthesis + block;

functionParameterList.Production = @identifier + (@comma + @identifier).ZeroOrMore();

statement.Production = block
    | emptyStatement
    | variableDeclarationStatement
    | assignmentStatement
    | returnStatement;

block.Production = @openCurlyBrace + statement.ZeroOrMore() + @closeCurlyBrace;

emptyStatement.Production = semiColon.ToTerm().ToProduction();

variableDeclarationStatement.Production = @var + @identifier + @semiColon;

assignmentStatement.Production = @identifier + @assignment + expression + @semiColon;

returnStatement.Production = @return + expression + @semiColon;

expression.Production = equalityExpression.ToTerm().ToProduction();

equalityExpression.Production = additiveExpression +
    ((@equality | @inequality) + equalityExpression).Optional();

additiveExpression.Production = multiplicativeExpression +
    ((@addition | @subtraction) + additiveExpression).Optional();

multiplicativeExpression.Production = primaryExpression +
    ((@multiplication | @division) + multiplicativeExpression).Optional();

primaryExpression.Production = numberExpression
    | simpleName
    | functionAccessExpression
    | parenthesizedExpression;

numberExpression.Production = @number.ToTerm().ToProduction();

simpleName.Production = @identifier.ToTerm().ToProduction();

functionAccessExpression.Production = @identifier + @openParenthesis +
    functionArgumentList.Optional() + @closeParenthesis;

functionArgumentList.Production = expression + (@comma + expression).ZeroOrMore();

parenthesizedExpression.Production = @openParenthesis + expression + @closeParenthesis;
​Me.Root.Production = functionDeclaration.ZeroOrMore()

functionDeclaration.Production = [function] + identifier + openParenthesis + functionParameterList.Optional() + closeParenthesis + block

functionParameterList.Production = identifier + (comma + identifier).ZeroOrMore()

statement.Production = block Or emptyStatement Or variableDeclarationStatement Or assignmentStatement Or returnStatement

block.Production = openCurlyBrace + statement.ZeroOrMore() + closeCurlyBrace

emptyStatement.Production = semiColon.ToTerm().ToProduction()

variableDeclarationStatement.Production = var + identifier + semiColon

assignmentStatement.Production = identifier + assignment + expression + semiColon

returnStatement.Production = [return] + expression + semiColon

expression.Production = equalityExpression.ToTerm().ToProduction()

equalityExpression.Production = additiveExpression + ((equality Or inequality) + equalityExpression).Optional()

additiveExpression.Production = multiplicativeExpression + ((addition Or subtraction) + additiveExpression).Optional()

multiplicativeExpression.Production = primaryExpression + ((multiplication Or division) + multiplicativeExpression).Optional()

primaryExpression.Production = numberExpression Or simpleName Or functionAccessExpression Or parenthesizedExpression

numberExpression.Production = number.ToTerm().ToProduction()

simpleName.Production = identifier.ToTerm().ToProduction()

functionAccessExpression.Production = identifier + openParenthesis + functionArgumentList.Optional() + closeParenthesis

functionArgumentList.Production = expression + (comma + expression).ZeroOrMore()

parenthesizedExpression.Production = openParenthesis + expression + closeParenthesis

Not so hard, is it? Let’s review some details about what we just did during our translation from the EBNF language specification to these production rules.

Step 3a: Elimination of Left Recursion

The FunctionParameterList, EqualityExpression, AdditiveExpression, MultiplicativeExpression, and FunctionArgumentList all have left recursion in the EBNF specification. Since our grammar is LL-based, that is not permitted.

It’s easy to rearrange our rules to handle this though. First look at how we changed FunctionParameterList. Its EBNF specification says:

Code Snippet
Copy
FunctionParameterList:
    "identifier"
    FunctionParameterList "," identifier

We wrote that in our grammar as:

C#
VB
Copy
​functionParameterList.Production = @identifier + (@comma + @identifier).ZeroOrMore();
​functionParameterList.Production = identifier + (comma + identifier).ZeroOrMore()

Next, let's look at EqualityExpression:

Code Snippet
Copy
EqualityExpression:
    AdditiveExpression
    AdditiveExpression "==" EqualityExpression
    AdditiveExpression "!=" EqualityExpression

We wrote that in our grammar as:

C#
VB
Copy
​equalityExpression.Production = additiveExpression +
    ((@equality | @inequality) + equalityExpression).Optional();
​equalityExpression.Production = additiveExpression + _
    ((equality Or inequality) + equalityExpression).Optional()

The remaining left recursion instances were handled in a similar fashion.

Step 3b: Elimination of Ambiguity

Now let’s try running our grammar within SyntaxEditor. When we do so, we get an exception:

Multiple productions within a NonTerminal 'PrimaryExpression' alternation start with the terminal 'Identifier' either directly or indirectly. The second production that contains a reference to the terminal is: FunctionAccessDeclaration

PrimaryExpression’s EBNF specification says:

Code Snippet
Copy
PrimaryExpression:
    NumberExpression
    SimpleName
    FunctionAccessExpression
    ParenthesizedExpression

The productions of both SimpleName and FunctionAccessExpression start with an Identifier terminal. That means they are ambiguous and the grammar framework detected it for us.

This is where we need to add a can-match callback for one of the non-terminals. In this scenario SimpleName only matches an Identifier while FunctionAccessExpression matches an Identifier followed by an OpenParenthesis. Therefore we’ll put our can-match callback on the FunctionAccessExpression.

First though, let’s move the FunctionAccessExpression in the alternation before the SimpleName. This ensures that its can-match callback will occur before the ambiguity.

C#
VB
Copy
​primaryExpression.Production = numberExpression
    | functionAccessExpression  // This was moved up
    | simpleName
    | parenthesizedExpression;
​primaryExpression.Production = numberExpression _
    Or functionAccessExpression  ' This was moved up _
    Or simpleName _
    Or parenthesizedExpression

Step 4: Configure Non-Terminal Can-Match Callbacks

Let’s make the can-match callback for the FunctionAccessExpression to resolve ambiguity between it and SimpleName:

C#
VB
Copy
​/// <summary>
/// Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>
/// <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
/// otherwise, <c>false</c>.
/// </returns>
private bool CanMatchFunctionAccessExpression(IParserState state) {
    return (state.TokenReader.LookAheadToken.Id == SimpleTokenId.Identifier) &&
        (state.TokenReader.GetLookAheadToken(2).Id == SimpleTokenId.OpenParenthesis);
}
​''' <summary>
''' Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>
''' <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
''' otherwise, <c>false</c>.
''' </returns>
Private Function CanMatchFunctionAccessExpression(ByVal state As IParserState) As Boolean
    Return (state.TokenReader.LookAheadToken.Id = SimpleTokenId.Identifier) AndAlso (state.TokenReader.GetLookAheadToken(2).Id = SimpleTokenId.OpenParenthesis)
End Function

Can-match callbacks are passed an IParserState object. The state gives access to everything from the look-ahead tokens to AST match data and even custom data. The callback returns true if the non-terminal can match with the current state.

In our situation we want to indicate FunctionAccessExpression can match if the next two tokens are Identifier and OpenParenthesis. The above code returns whether that condition is met.

We then wire up the can-match callback to the non-terminal like this:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = CanMatchFunctionAccessExpression;
​functionAccessExpression.CanMatchCallback = AddressOf CanMatchFunctionAccessExpression

Now we're done with the grammar for this topic's sample.

Default Tree Constructor Output

The LL(*) Parser Framework will automatically generate an AST for you, just based on what we’ve written so far. It will contain AST nodes for each terminal, non-terminal, and quantifier.

Let’s first see what output we get as-is. The input we’ll type in our SyntaxEditor is:

Code Snippet
Copy
function IncrementAndMultiply(x, y) {
    var result;
    result = Increment(x);
    return result * y;
}

Here is the text representation of the AST that was generated:

Code Snippet
Copy
CompilationUnit[
    [
        FunctionDeclaration[
            "function"
            "IncrementAndMultiply"
            "("
            FunctionParameterList[
                "x"
                [
                    ","
                    "y"
                ]
            ]
            ")"
            Block[
                "{"
                [
                    Statement[
                        VariableDeclarationStatement[
                            "var"
                            "result"
                            ";"
                        ]
                    ]
                    Statement[
                        AssignmentStatement[
                            "result"
                            "="
                            Expression[
                                EqualityExpression[
                                    AdditiveExpression[
                                        MultiplicativeExpression[
                                            PrimaryExpression[
                                                FunctionAccessExpression[
                                                    "Increment"
                                                    "("
                                                    FunctionArgumentList[
                                                        Expression[
                                                            EqualityExpression[
                                                                AdditiveExpression[
                                                                    MultiplicativeExpression[
                                                                        PrimaryExpression[
                                                                            SimpleName[
                                                                                "x"
                                                                            ]
                                                                        ]
                                                                        []
                                                                    ]
                                                                    []
                                                                ]
                                                                []
                                                            ]
                                                        ]
                                                        []
                                                    ]
                                                    ")"
                                                ]
                                            ]
                                            []
                                        ]
                                        []
                                    ]
                                    []
                                ]
                            ]
                            ";"
                        ]
                    ]
                    Statement[
                        ReturnStatement[
                            "return"
                            Expression[
                                EqualityExpression[
                                    AdditiveExpression[
                                        MultiplicativeExpression[
                                            PrimaryExpression[
                                                SimpleName[
                                                    "result"
                                                ]
                                            ]
                                            [
                                                "*"
                                            ]
                                            MultiplicativeExpression[
                                                PrimaryExpression[
                                                    SimpleName[
                                                        "y"
                                                    ]
                                                ]
                                                []
                                            ]
                                        ]
                                        []
                                    ]
                                    []
                                ]
                            ]
                            ";"
                        ]
                    ]
                ]
                "}"
            ]
        ]
    ]
]

Obviously this is much more data than is useful and in the Tree Constructors topic we’ll show features for creating a concise AST that only contains the useful data and in a meaningful structure.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Tree Constructors

LL(*) Parser Framework
Tree Constructors

Non-terminal productions will by default produce a very verbose AST that generally contains much more information than is useful for later consumption. The LL(*) Parser Framework has an extremely powerful tree construction mechanism with numerous built-in helper methods to do common tree construction tasks. You also have the ability to create completely custom tree construction nodes via C#/VB code if you like.

In the previous walkthrough topic, we stepped through how to create a grammar for the Simple language (which is similar to a Javascript subset). We showed how easy it was to write the grammar using EBNF-like notation but completely from within your native C#/VB code. We also showed how the grammar automatically generates an AST of the parsed document for you.

This topic will show how to completely customize the AST output so that it focuses only on the information we care about.

This topic contains these sections:

  • Default Tree Construction
  • Scopes and Labels
  • Customizing Tree Constructors
  • Tree Construction Type Summary and Comparison
  • Core Built-in Tree Construction Nodes
  • Type-Specific Built-in Tree Construction Nodes
  • Creating Custom Tree Construction Nodes
  • Left Associativity

Default Tree Construction

The default tree constructors will output nearly everything that is parsed. Each AST node that is generated automatically contains the offset range of the text that created it.

AST nodes generated by the default tree constructors implement IAstNode and are of type DefaultAstNode.

Productions

Any EBNF production will create a scope and will output a new hierarchy level node in an AST. The AST node that is created can have zero to many children, depending on what was matched within the production.

If the production is the root production for a non-terminal, then the AST node that is output for the production will have a value that is the non-terminal’s key. Note that productions can be used within other productions. In that case, the nested productions generate an AST node that has children but no value.

Terminals

Terminals, which match tokens, will output an AST node with no children that has a value of the text that was read.

Quantifiers

“Optional” quantifiers will output the tree construction results for the quantifier’s child term if the term matched successfully. Otherwise an empty structural AST node will be output.

For any other quantifier (“zero-or-more”, “one-or-more”, etc.), a new scope is created within the quantifier. The quantifier will output a new hierarchy level node in the AST. The AST node that is created can have zero to many children, depending on what was matched in the quantifier.

Scopes and Labels

A couple places in the previous section mentioned where scopes are created. Namely, scopes occur in productions and in quantifiers (ones other than "optional" quantifiers).

Any EBNF term, other than EbnfConcatenation, can be assigned a label. A label is a way for a tree constructor to identify something that was matched in its scope. Labels are only useful when creating custom tree constructors.

Terminals and non-terminals, represented by the Terminal and NonTerminal classes can be auto-converted to their EBNF term equivalents (EbnfTerminal and EbnfNonTerminal) by calling their indexer and passing the label as a string parameter.

So say we have a terminal within a production for an identifier and we want to apply a name label to it. We can do so like this:

C#
VB
Copy
​@identifier["name"]
​identifier("name")

For any object that is EbnfTerm-based, there is a SetLabel method you can call instead like:

C#
VB
Copy
​statement.ZeroOrMore().SetLabel("stmt")
​statement.ZeroOrMore().SetLabel("stmt")

In that example, statement is a NonTerminal, its ZeroOrMore method call converted it to an EbnfNonTerminal and wrapped it with an EbnfQuantifier. Finally we set the label stmt on the quantifier via the SetLabel method.

Note Note
Labels cannot be set on EbnfConcatenation objects, but can be set on any other EbnfTerm-based object.

Customizing Tree Constructors

Adding tree constructors to a production is easy. So far we’ve only seen how to indicate the EBNF pattern expression for a production. A tree constructor can be added to this by using the > operator followed by an ITreeConstructionNode instance like this:

C#
VB
Copy
​expression.Production = equalityExpression["exp"] > AstFrom("exp");
​expression.Production = equalityExpression["exp"] > AstFrom("exp")

In the above sample code, a production was created for an Expression non-terminal, which simply calls into an EqualityExpression non-terminal. It applies a label to that non-terminal’s results so that the tree constructor can work with them. The AstFrom tree constructor simply looks for a match with the specified label and returns its value.

Thus the result of a match with this production is the result of the EqualityExpression non-terminal. If we didn’t include the tree constructor portion of the above production, the result would be an Expression AST node whose child was the result of the EqualityExpression non-terminal.

Tree Construction Type Summary and Comparison

There are numerous built-in tree construction node types that should handle nearly all your tree construction needs. In extreme cases where the built-in functionality isn't enough, it is possible to create your own custom tree construction nodes.

Note Note
Sections below discuss DefaultAstNode and type-specific AST nodes. For more information on the difference between these types of AST nodes, see the AST Nodes topic. The Language Designer also has features that allow you to code generate classes for type-specific AST nodes.

Type Summary

There are several types of tree construction:

Type Description
Default (built-in)

Automatically used when no tree constructors are specified in a production and output nearly everything that is parsed using DefaultAstNode instances.

The default tree constructors are good to use when first writing a grammar's EBNF productions since they give you immediate feedback on what is parsed without having to take time to write tree constructors. However they are certainly not idea for production use since they include much more information than what is desired or needed.

Core (built-in)

Manually added to the tree constructor portion of productions via the use of the various non-generic AstXX methods found on the Grammar class.

AST nodes created using these methods are DefaultAstNode instances. These nodes are fine to use in production since they should be optimized to contain only meaningful data based on how how you specified the tree constructor portion of the productions.

Type-Specific (built-in)

Manually added to the tree constructor portion of productions via the use of the various generic AstXX methods found on the Grammar class.

AST nodes created using these methods are of the type passed into the method as a generic argument, and can have various properties on the type set. Since the AST nodes used are dedicated .NET partial classes, they can easily be extended with helper methods. These nodes are the most ideal for production, since they have a more efficient AST structure. As an example, for simple cases where the AST needs to store a string value, a string property on the AST node can be set, as opposed to how DefaultAstNode would need to create an AST node to store the value and likely wrap it with another contextual AST node.

The downside of type-specific nodes is that they require a bit more work since many new classes need to be created, one for each AST node type. That being said, the Language Designer has features that can code generate the classes for you based on some quick configuration settings.

Custom

Manually added to the tree construction portion of productions via the instantiation of the custom class used to implement the tree construction node.

Custom nodes are used in scenarios where there is custom processing needed to properly handle matches made in a production, that the built-in tree construction nodes can't handle.

Comparison

To best illustrate the differences between the various built-in node types, let's make a production for a C# if-statement. Its EBNF is stated as:

Code Snippet
Copy
if-statement:
"if" "(" boolean-expression ")" embedded-statement
"if" "(" boolean-expression ")" embedded-statement "else" embedded-statement

For these samples, we'll use the same input code:

Code Snippet
Copy
if (isTrue) return 1 else return 0;

This comparison is just an introduction to the various built-in node types. Details on how to work with each is included in other sections below.

First is the default tree constructors, where no tree constructor is specified in a production:

C#
VB
Copy
​ifStatement.Production = @keywordIf + @openParenthesis + booleanExpression +
    @closeParenthesis + embeddedStatement + (@keywordElse + embeddedStatement).Optional();
​ifStatement.Production = keywordIf + openParenthesis + booleanExpression + _
    closeParenthesis + embeddedStatement + (keywordElse + embeddedStatement).Optional()

The output from the default tree constructors would be similar to this, which includes nodes for everything, even the punctuation:

Code Snippet
Copy
IfStatement[
    "If",
    "(",
    SimpleName[
        "isTrue"
    ],
    ")"
    ReturnStatement[
        LiteralExpression[
            "1"
        ]
    ],
    "Else",
    ReturnStatement[
        LiteralExpression[
            "0"
        ]
    ]
]

Now let's use the core tree construction nodes:

C#
VB
Copy
​ifStatement.Production = @keywordIf + @openParenthesis +
    booleanExpression["conditionexp"].OnErrorContinue() +
    @closeParenthesis.OnErrorContinue() + embeddedStatement["truestmt"].OnErrorContinue() +
    (@keywordElse + embeddedStatement["falsestmt"].OnErrorContinue()).Optional()
    > Ast("IfStatement",
        Ast("ConditionExpression", AstFrom("conditionexp")),
        Ast("TrueStatement", AstFrom("truestmt")),
        Ast("FalseStatement", AstFrom("falsestmt")));
​ifStatement.Production = keywordIf + openParenthesis + _
    booleanExpression("conditionexp").OnErrorContinue() + _
    closeParenthesis.OnErrorContinue() + embeddedStatement("truestmt").OnErrorContinue() + _
    (keywordElse + embeddedStatement("falsestmt").OnErrorContinue()).Optional() _
    > Ast("IfStatement", _
        Ast("ConditionExpression", AstFrom("conditionexp")), _
        Ast("TrueStatement", AstFrom("truestmt")), _
        Ast("FalseStatement", AstFrom("falsestmt")))

The output from the core tree constructors would be similar to this, which is much more concise than the default tree constructors:

Code Snippet
Copy
IfStatement[
    ConditionExpression [
        SimpleName[
            "isTrue"
        ]
    ],
    TrueStatement[
        ReturnStatement[
            LiteralExpression[
                "1"
            ]
        ]
    ],
    FalseExpression[
        ReturnStatement[
            LiteralExpression[
                "0"
            ]
        ]
    ]
]

For the final comparison, we'll use type-specific tree constructors:

C#
VB
Copy
​ifStatement.Production = @keywordIf + @openParenthesis +
    booleanExpression["conditionexp"].OnErrorContinue() +
    @closeParenthesis.OnErrorContinue() +
    embeddedStatement["truestmt"].OnErrorContinue() +
    (@keywordElse + embeddedStatement["falsestmt"].OnErrorContinue()).Optional()
    > Ast<IfStatement>()
        .SetProperty(s => s.ConditionExpression, AstFrom("conditionexp"))
        .SetProperty(s => s.TrueStatement, AstFrom("truestmt"))
        .SetProperty(s => s.FalseStatement, AstFrom("falsestmt"));
​ifStatement.Production = keywordIf + openParenthesis + _
    booleanExpression("conditionexp").OnErrorContinue() + _
    closeParenthesis.OnErrorContinue() + _
    embeddedStatement("truestmt").OnErrorContinue() + _
    (keywordElse + embeddedStatement("falsestmt").OnErrorContinue()).Optional() _
    > Ast(Of IfStatement)() _
        .SetProperty(Function(s) s.ConditionExpression, AstFrom("conditionexp")) _
        .SetProperty(Function(s) s.TrueStatement, AstFrom("truestmt")) _
        .SetProperty(Function(s) s.FalseStatement, AstFrom("falsestmt"))

The output from this is an instance of the IfStatement class, along with various other classes that represent each type of AST node.

Code Snippet
Copy
new IfStatement {
    ConditionExpression = new SimpleName {
        Text = "isTrue"
    },
    TrueStatement = new ReturnStatement {
        Expression = new LiteralExpression() {
            Value = 1
        }
    },
    FalseStatement = new ReturnStatement {
        Expression = new LiteralExpression() {
            Value = 0
        }
    }
}

From this comparison, it's easy to see how either the core or type-specific tree construction types are good for production use. The type-specific tree construction type takes a bit more work simply because classes need to be created for each AST node type, but in the end you get a nicer and more flexible AST model.

Core Built-in Tree Construction Nodes

There are a number of core built-in tree construction nodes that should handle nearly all your tree construction needs. These nodes are created by method calls on the Grammar class.

Ast(string value, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the Ast method will create a DefaultAstNode with the specified value and optional child nodes.

This tree construction node is the most basic building block used in tree construction, as it allows you to wrap other AST nodes with an AST node that has a specific value, generally the name of the containing non-terminal.

This example creates an AST node with value ReturnStatement that has a child node resulting from an EBNF term match whose label is exp:

C#
VB
Copy
​returnStatement.Production = @return + expression["exp"] + @semiColon
    > Ast("ReturnStatement", AstFrom("exp"));
​returnStatement.Production = [return] + expression("exp") + semiColon _
    > Ast("ReturnStatement", AstFrom("exp"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
return 1;

The first parameter passed to Ast method, ReturnStatement, becomes the value of the root AST node returned by the tree constructor. The result of the Expression match, in this case 1, is returned directly as a child of the ReturnStatement node via the AstFrom method. Note that the Return and SemiColon terminals are discarded since they are not important for our AST.

AstValueOf(ITreeConstructionNode valueOfNode, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstValueOf method works the same way as Ast except that the root node created will have the value of the valueOfNode tree construction node result’s value.

This tree construction node is used when your resulting AST node's value is based on some match's value, instead of a fixed value such as what is provided to the Ast method.

This example for an XML attribute name and value shows how a parent AST node can be created whose value is the attribute name and the child AST node will be the attribute value:

C#
VB
Copy
​xmlAttribute.Production = @startTagAttrName["attrName"] + @startTagAttrValStart + @startTagAttrValText["attrValue"] + @startTagAttrValEnd
    > AstValueOf(AstFrom("attrName"), AstFrom("attrValue"))
​xmlAttribute.Production = startTagAttrName("attrName") + startTagAttrValStart + startTagAttrValText("attrValue") + startTagAttrValEnd _
    > AstValueOf(AstFrom("attrName"), AstFrom("attrValue"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
Language="English"

Note how the the root AST node's value is the value of a match, in this case Language.

AstFrom(string label)

The ITreeConstructionNode generated by the AstFrom method will create an AST node from an EBNF term match with the specified label.

This tree construction node is useful when merging resulting AST nodes within another container AST node, such as one generated by a call to the Ast method. See the Ast method example above for a sample showing one typical use of the AstFrom method.

Another common use of this tree construction node is to "promote" a child match node up without wrapping it by another node. This example shows how a generalized Statement production can match a certain kind of statement (a Block) and have the BlockStatement result bubble up without it being wrapped by a Statement node. For a real language, normally there would be other similar statement types in an alternation with the Block term.

C#
VB
Copy
​statement.Production = block["stmt"]
    > AstFrom("stmt")
​statement.Production = block("stmt") _
    > AstFrom("stmt")

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
{ ... }

Note how the results of the Block term are directly returned without being wrapped by another AST node.

AstChildFrom(string label)

The ITreeConstructionNode generated by the AstChildFrom method will create an AST node from the first child of an EBNF term match with the specified label.

This tree construction node is similar to AstFrom however instead of returning the resulting AST node of the specified match, it is returning the first child AST node within that resulting AST node, thus skipping a level.

Note Note
An overload of this method allows for specification of a particular child node index. The default child index is 0, meaning the first child.

This example for a binary operator expression shows how the operator used will be the value of the root node created, but only if the leftexp and rightexp returned matches. If only one match occurred (no operator was used), then that match will be directly passed up. The operator portion of this production is actually a nested child production, thus its result is wrapped by an AST node with no value by default. The use of AstChildFrom allows us to retrieve the matched operator value, while discarding the wrapper AST node.

C#
VB
Copy
​additiveExp.Production = multiplicativeExp["leftexp"] + ((@addition | @subtraction).SetLabel("op") + additiveExp["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));
​additiveExp.Production = multiplicativeExp("leftexp") + ((addition Or subtraction).SetLabel("op") + additiveExp("rightexp")).Optional() _
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
1 + 2

This production uses the powerful AstValueOfConditional method, which contains conditional logic. The value of the operator nested production becomes the value of the root AST node and the values of the left and right expressions become the values of child AST nodes.

In an alternate scenario if the input was just 1 then AstValueOfConditional would just promote the left expression AST node with value 1 up without wrapping it by an operator AST node.

AstChildrenFrom(string label)

The ITreeConstructionNode generated by the AstChildrenFrom method will create an AST node from the children of an EBNF term match with the specified label.

Since the result of this particular tree construction node is a list, it can never be used as the root return value of a production.

This example creates an AST node with value CompilationUnit that contains the children of an EBNF term match whose label is decl:

C#
VB
Copy
​compilationUnit.Production = functionDeclaration.ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​compilationUnit.Production = functionDeclaration.ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
function Foo() {}
function Bar() {}

The root AST node returned has value CompilationUnit, and has child AST nodes that represent the AST node results of the FunctionDeclaration non-terminal calls.

An overload of AstChildrenFrom accepts a nesting level parameter, which allows for retrieval of nodes two or more levels deep. A value of 0 passed to this overload means take the direct children, same as the functionality described above. A value of 1 passed as the nesting level means return grandchildren nodes instead. This functionality is helpful in scenarios where the desired list of results are wrapped by another AST node.

AstConditionalFrom(string value, string label)

The ITreeConstructionNode generated by the AstConditionalFrom method will create a DefaultAstNode with the specified value whose child nodes come from the children of the specified labeled EBNF term match, but only if at least one child node is available. If no child nodes are available, nothing is created.

This tree construction node is very handy when there are things such as optional parameter or argument lists in a grammar and you don’t want to clutter up the resulting AST when a particular member doesn’t have parameters or arguments.

This example creates a FunctionAccessExpression AST node whose first child comes from an EBNF term match with label name. The next child will be an Arguments node but only if there was at least one child within an EBNF term match with label args.

C#
VB
Copy
​functionAccessExp.Production = @identifier["name"] + @openParenthesis + functionArgumentList["args"].Optional() + @closeParenthesis
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"));
​functionAccessExp.Production = identifier("name") + openParenthesis + functionArgumentList("args").Optional() + closeParenthesis _
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
Foo(1, 2)

The root FunctionAccessExpression AST node's first child node has the value of the name match, in this case Foo. Since there was more than one argument passed, AstConditionalFrom injects a second child node called Arguments, whose children are the argument AST nodes.

Alternatively if the input was Foo(), the Arguments node and its children would not have been in the result.

AstConditional(string value, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstConditional method will create a DefaultAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.

This behavior is very similar to the logic for the AstConditionalFrom method, except that the arguments to AstConditional can be individual tree constructors or the special AstChildrenFrom tree constructor that can return zero to many results.

This example creates an AST node with value Parameters that has child nodes from the union of the children of EBNF term matches params1 and params2:

C#
VB
Copy
​functionParameters.Production = AstConditional("Parameters", AstChildrenFrom("params1"), AstChildrenFrom("params2"))
​AstConditional("Parameters", AstChildrenFrom("params1"), AstChildrenFrom("params2"))

Note that if only one result came from the union of params1 and params2 children, that single result would be returned and would not be wrapped by a Parameters node.

AstValueOfConditional(ITreeConstructionNode valueOfNode, params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstValueOfConditional method works the same way as AstConditional except that the root node created when there is more than one child available will have the value of the valueOfNode tree construction node result’s value.

A sample usage for this tree construction node is included in the AstChildFrom sample above.

AstCount(params ITreeConstructionNode[] childNodes)

The ITreeConstructionNode generated by the AstCount method will create an AST node whose value is the count of IAstNode objects generated by contained nodes.

This tree construction node is useful in scenarios where you need a count of matched objects.

This example counts the number of dimensions in an array rank specifier. Note that since it counts commas, an additional result is included to make the result one-based instead of zero-based:

C#
VB
Copy
​rankSpecifier.Production = @openSquareBrace + @comma.ZeroOrMore().SetLabel("dims") + @closeSquareBrace.OnErrorContinue()
    > AstCount(Ast("FirstDim"), AstChildrenFrom("dims"));
​rankSpecifier.Production = openSquareBrace + comma.ZeroOrMore().SetLabel("dims") + closeSquareBrace.OnErrorContinue() _
    > AstCount(Ast("FirstDim"), AstChildrenFrom("dims"))

When parsing the following input, the result is shown in the diagram below:

Code Snippet
Copy
[,,]

The resulting AST node has a value of 3, which is 1 (from the hardcoded node) added to 2 (the number of commas).

Type-Specific Built-in Tree Construction Nodes

Type-specific tree construction nodes can be used when you have type-specific AST nodes, which can easily be code generated by the Language Designer.

There are several type-specific built-in tree construction nodes which are similar to their non-generic core counterparts. These nodes are created by generic method calls on the Grammar class.

Each of the type-specific tree construction nodes implement the ITypedTreeConstructionNode`1 interface, which has methods on it that allow for altering of properties on the type. These properties are described in more detail below.

Type-Specific Tree Construction Nodes

The following generic methods are available on the Grammar class to create type-specific tree construction nodes. In each case, the generic type argument passed to the method indicates the Type of AST node to create. Since they work similarly to their core non-generic counterparts, please see the documentation above for more details on how and when to use them.

Method | Description
Ast<T>() | This node works similarly to the core non-generic Ast method in that it creates a new instance of an AST node. However instead of a DefaultAstNode being created with a certain value, the AST node instance created is of the type passed as a generic type argument, and properties can be set on it.
AstFrom<T>(string label) | This node works exactly the same as the core non-generic AstFrom method in that it returns the node that was matched using the specified label. The only difference is that the node instance is cast to the type passed as a generic type argument and properties can be set on the instance.
AstConditional<T>(params ITreeConstructionNode[] childNodes) | This node works similarly to the core non-generic AstConditional method in that it creates a new AST node instance only if two or more child AST nodes are passed in. The type created in this instance is the type passed as a generic type argument, and properties can be set on the created isntance. If instead only one child AST node is passed in, it is directly returned and no new AST node is created or properties assigned.
AstLeftAssociativity<T, U>(ITreeConstructionNode childNode, ...) | This node provides special advanced functionality to update the AST tree such that left associativity is supported when appropriate. See the section below on Left Associativity for more information on what it means.

Modifying AST Node Properties

All of the three tree constructor generic methods described above return an ITypedTreeConstructionNode`1 instance, which has several methods on it for describing how to update properties on the related type-specific AST node.

Note that all of these methods use one or more lambda expressions that indicate the property to update. This enables type checking and validation by the C#/VB compiler.

SetProperty

The SetProperty method is the most-used mechanism to update properties. It calls a setter for the specified property to set it to a new value. Depending on the property’s return type, different logic is used for how to obtain its value. Strings, integers, booleans, enums, flags enums, and AST node properties are supported.

Multiple instances of these values can be passed to the method for a single property too, which is especially useful for things like type modifiers. Generally there are zero or more type modifiers allowed on a type. So we end up with a list of them. But say our type-specific AST node for type declarations has a Modifiers property where the Modifiers enum value is a flags enum. In this case SetProperty will automatically OR all the flags found together and set the resulting value to the property.

Similar logic is available for strings (which get concatenated), ints (which get added together), and bools (which get OR’ed together). Generally though, only a single AST node result is passed to SetProperty for examination.

This sample shows the use of SetProperty. Note that even though a type-specific AST node is being created, we can still use core tree construction node to obtain property values.

C#
VB
Copy
​constantDeclarator.Production = simpleNameWithoutTypeArguments["name"] +
    @operatorAssignment.OnErrorContinue() + constantExpression["exp"].OnErrorContinue()
    > Ast<VariableDeclarator>()
        .SetProperty(d => d.Name, AstFrom("name"))
        .SetProperty(d => d.Initializer, AstFrom("exp"))
        .SetProperty(d => d.Kind, VariableDeclaratorKind.Constant);
​constantDeclarator.Production = simpleNameWithoutTypeArguments("name") + _
    operatorAssignment.OnErrorContinue() + constantExpression("exp").OnErrorContinue() _
    > Ast(Of VariableDeclarator)() _
        .SetProperty(Function(d) d.Name, AstFrom("name")) _
        .SetProperty(Function(d) d.Initializer, AstFrom("exp")) _
        .SetProperty(Function(d) d.Kind, VariableDeclaratorKind.Constant)

Another overload of SetProperty allows a literal value to be assigned as the value like the above production where a constant declarator should always have its Kind property set to a specific enumeration value.

AppendToProperty

The AppendToProperty method works the same as SetProperty. The only difference is that instead of wiping out any previous property value, the previous value is included in the OR/concatenation/addition logic described above for SetProperty when multiple AST node values are passed.

This sample shows the use of AppendToProperty.

C#
VB
Copy
​typeDeclaration.Production = attributeSection.OnErrorContinue().ZeroOrMore().SetLabel("attrs") +
    modifier.OnErrorContinue().ZeroOrMore().SetLabel("modifiers") + typeDeclarationCore["decl"]
    > AstFrom<IDecoratedMember>("decl")
        .AddToCollectionProperty(d => d.AttributeSections, AstChildrenFrom("attrs"))
        .AppendToProperty(d => d.Modifiers, AstChildrenFrom("modifiers"));
​typeDeclaration.Production = attributeSection.OnErrorContinue().ZeroOrMore().SetLabel("attrs") + _
    modifier.OnErrorContinue().ZeroOrMore().SetLabel("modifiers") + typeDeclarationCore("decl") _
    > AstFrom(Of IDecoratedMember)("decl") _
        .AddToCollectionProperty(Function(d) d.AttributeSections, AstChildrenFrom("attrs")) _
        .AppendToProperty(Function(d) d.Modifiers, AstChildrenFrom("modifiers"))

The above production shows usage of AppendToProperty and how it will not wipe out any existing modifiers values that came in from the declaration AST node returned in label decl. Instead it will take the existing property value and OR in any matched modifiers. The result is set as the new Modifiers property value.

AddToCollectionProperty

The AddToCollectionProperty method appends one or more AST node result values to a collection property. In the production above, any attribute section AST nodes that are matched are added to the the AttributeSections list property.

SetCollectionItemProperties

The SetCollectionItemProperties method works just like SetProperty except that instead of setting the property value on the target AST node, it sets the properties of all items in a collection property on the target AST node.

This sample shows the use of SetCollectionItemProperties.

C#
VB
Copy
​constantDeclaration.Production = @keywordConst + type["type"] + constantDeclarator["decl"].OnErrorContinue() +
    (@comma + constantDeclarator["decl"] > AstFrom("decl")).OnErrorContinue().ZeroOrMore().SetLabel("moredecls") + @semiColon.OnErrorContinue()
    > Ast<FieldDeclaration>()
        .AddToCollectionProperty(d => d.Declarators, AstFrom("decl"), AstChildrenFrom("moredecls"))
        .SetCollectionItemProperties(d => d.Declarators, v => v.Type, AstFrom("type"));
​constantDeclaration.Production = keywordConst + type("type") + constantDeclarator("decl").OnErrorContinue() + _
    (comma + constantDeclarator("decl") > AstFrom("decl")).OnErrorContinue().ZeroOrMore().SetLabel("moredecls") + semiColon.OnErrorContinue() _
    > Ast(Of FieldDeclaration)() _
        .AddToCollectionProperty(Function(d) d.Declarators, AstFrom("decl"), AstChildrenFrom("moredecls")) _
        .SetCollectionItemProperties(Function(d) d.Declarators, Function(v) v.Type, AstFrom("type"))

Take the above production as an example. First a FieldDeclaration AST node is created and any declarators that were matched are added to its Declarators property. Then since in C# the type is defined before the declarators, we need a way to push the type down to each VariableDeclarator instance in the Declarators collection. This is where SetCollectionItemProperties comes in to save the day.

Creating Custom Tree Construction Nodes

The built-in tree construction nodes should handle nearly all the tree construction scenarios you have. But what if there is something that requires some additional programmatic logic? No problem, you can simply create a class that implements ITreeConstructionNode and inject it anywhere just like you do with the results of the above methods.

The abstract TreeConstructionNodeBase class implements ITreeConstructionNode and is provided to be used as base class for any custom tree construction nodes that do not have any child tree construction nodes. The abstract ParentTreeConstructionNodeBase class, which inherits TreeConstructionNodeBase, is provided to be used as a base class for any custom tree construction nodes that do have other child tree construction nodes.

To better illustrate how this works, let's consider a scenario with the C# language grammar we encountered when working on the .NET Languages Add-on. When building a C# type name, it is possible to have a namespace alias at the start. global:: is a special one, meaning start at the root empty namespace. Normally we capture the alias before the double colons in an Alias property of our QualifiedName class. However if the alias global was used, we wanted to clear that and mark a special flag instead. To do this, we made a custom tree constructor like this:

C#
VB
Copy
​/// <summary>
/// Implements a tree constructor for the <c>QualifiedName</c> non-terminal.
/// </summary>
/// <remarks>
/// Converts a "global::" from an alias to an <c>IsGlobal</c> flag.
/// </remarks>
private class QualifiedNameTreeConstructionNode : ParentTreeConstructionNodeBase {

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // OBJECT
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Initializes a new instance of the <c>QualifiedNameTreeConstructionNode</c> class.
    /// </summary>
    /// <param name="childNode">The child node containing the declaration.</param>
    public QualifiedNameTreeConstructionNode(ITreeConstructionNode childNode) : base(childNode) {}

    /////////////////////////////////////////////////////////////////////////////////////////////////////
    // PUBLIC PROCEDURES
    /////////////////////////////////////////////////////////////////////////////////////////////////////

    /// <summary>
    /// Returns the <see cref="IAstNode"/> that is created for this tree construction node.
    /// </summary>
    /// <param name="matches">The collection of matched <see cref="IAstNode"/> objects within the current <see cref="IAstNodeBuilder"/> scope.</param>
    /// <returns>The <see cref="IAstNode"/> that is created for this tree construction node.</returns>
    public override IAstNode CreateNode(IAstNodeMatchCollection matches) {
        var childNode = this.Children.FirstOrDefault();
        if (childNode != null) {
            var qualifiedNameAstNode = childNode.CreateNode(matches) as QualifiedName;
            if (qualifiedNameAstNode != null) {
                if (qualifiedNameAstNode.Alias == "global") {
                    // Switch access type
                    qualifiedNameAstNode.IsGlobal = true;
                    qualifiedNameAstNode.Alias = null;
                }

                return qualifiedNameAstNode;
            }
        }

        return null;
    }

}
​''' <summary>
''' Implements a tree constructor for the <c>QualifiedName</c> non-terminal.
''' </summary>
''' <remarks>
''' Converts a "global::" from an alias to an <c>IsGlobal</c> flag.
''' </remarks>
Private Class QualifiedNameTreeConstructionNode
    Inherits ParentTreeConstructionNodeBase

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' OBJECT
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Initializes a new instance of the <c>QualifiedNameTreeConstructionNode</c> class.
    ''' </summary>
    ''' <param name="childNode">The child node containing the declaration.</param>
    Public Sub New(ByVal childNode As ITreeConstructionNode)
        MyBase.New(childNode)
    End Sub

    '///////////////////////////////////////////////////////////////////////////////////////////////////
    ' PUBLIC PROCEDURES
    '///////////////////////////////////////////////////////////////////////////////////////////////////

    ''' <summary>
    ''' Returns the <see cref="IAstNode"/> that is created for this tree construction node.
    ''' </summary>
    ''' <param name="matches">The collection of matched <see cref="IAstNode"/> objects within the current <see cref="IAstNodeBuilder"/> scope.</param>
    ''' <returns>The <see cref="IAstNode"/> that is created for this tree construction node.</returns>
    Public Overrides Function CreateNode(ByVal matches As IAstNodeMatchCollection) As IAstNode
        Dim childNode = Me.Children.FirstOrDefault()
        If childNode IsNot Nothing Then
            Dim qualifiedNameAstNode = TryCast(childNode.CreateNode(matches), QualifiedName)
            If qualifiedNameAstNode IsNot Nothing Then
                If qualifiedNameAstNode.Alias = "global" Then
                    ' Switch access type
                    qualifiedNameAstNode.IsGlobal = True
                    qualifiedNameAstNode.Alias = Nothing
                End If

                Return qualifiedNameAstNode
            End If
        End If

        Return Nothing
    End Function

End Class

This code shows how it can be used from within a grammar:

C#
VB
Copy
​qualifiedAliasMember.Production = identifierOrContextualKeyword["lefti"] + @namespaceAliasQualifier + simpleName["righti"].OnErrorContinue()
    > new QualifiedNameTreeConstructionNode(
        Ast<QualifiedName>()
            .SetProperty(qn => qn.Alias, AstFrom("lefti"))
            .AddToCollectionProperty(qn => qn.Identifiers, AstFrom("righti"))
        );
​qualifiedAliasMember.Production = identifierOrContextualKeyword("lefti") + namespaceAliasQualifier + simpleName("righti").OnErrorContinue() _
    > New QualifiedNameTreeConstructionNode( _
        Ast(Of QualifiedName)() _
            .SetProperty(Function(qn) qn.Alias, AstFrom("lefti")) _
            .AddToCollectionProperty(Function(qn) qn.Identifiers, AstFrom("righti")) _
        )

Left Associativity

Most languages have left associativity within them, in the form of binary operators. This is best explained in an example with a diagram. Assume we have normal math expressions such as subtraction in a language, and in the code we write 8 - 5 - 2.

The left side shows how an AST is constructed for that expression with left associativity. The right side shows how an AST is constructed for that expression with right associativity (how the LL(*) parser works). When reading through AST nodes later, you can see how a different result can be obtained from one way or the other.

Note that the correct result can be reached if the AST consumer recognizes this kind of AST scenario where binary operator nodes recurse off to the right and in those cases treats all the nodes as being at the same level, and interprets the leaf nodes in sequence, left-to-right. Most languages also feature some form of parenthesized expression node, which also can be used to identify points where the code really did want right associativity.

Since the Actipro grammar is LL(*) based and doesn't allow left recursion, left associativity is not normally an option in tree constructors. There are three solutions available to make a left associative result.

1: Don't Use Binary Operators

Instead of having a binary operator expression node that only takes two children, use an operator expression node that supports any number of child expressions. Then populate it with child expression nodes at the same level that use operators of a similar precedence level. This way when your AST consumer reaches the operator node, it just reads through all the children left-to-right.

2: Use a Custom Tree Constructor to Alter the AST Results

For grammars using default generic tree constructors, a custom tree construction node can be written per information in the section above to watch for this scenario and alter the AST results approprately.

3: Use the AstLeftAssociativity Method

For grammars using default type-specific tree constructors, there is a built-in Grammar.AstLeftAssociativity method that does all the heavy lifting of altering the AST tree for you. Say a language has a BinaryOperatorExpression AST node type which inherits an Expression node type. The BinaryOperatorExpression has LeftExpression, RightExpression, and Operator properties, where the operator property uses an OperatorKind enumeration.

This code shows how it can be used from within a grammar:

C#
VB
Copy
​additiveExpression.Production = multiplicativeExpression["leftexp"] + (
        (
            @operatorAddition > Ast(OperatorKind.Addition.ToString())
            | @operatorSubtraction > Ast(OperatorKind.Subtraction.ToString())
        ).SetLabel("op") + additiveExpression["rightexp"]).Optional()
    > AstLeftAssociativity<Expression, BinaryOperatorExpression>(
        AstConditional<BinaryOperatorExpression>(AstFrom("leftexp"), AstFrom("rightexp"))
            .SetProperty(e => e.Operator, AstFrom("op"))
            .SetProperty(e => e.LeftExpression, AstFrom("leftexp"))
            .SetProperty(e => e.RightExpression, AstFrom("rightexp")),
        n => n.LeftExpression,
        n => n.RightExpression,
        (n1, n2) => BinaryOperatorKindCheck(n1, n2, OperatorKind.Addition, OperatorKind.Subtraction));
​additiveExpression.Production = multiplicativeExpression("leftexp") + ( _
        ( _
            operatorAddition > Ast(OperatorKind.Addition.ToString()) _
            Or operatorSubtraction > Ast(OperatorKind.Subtraction.ToString()) _
        ).SetLabel("op") + additiveExpression("rightexp")).Optional() _
    > AstLeftAssociativity(Of Expression, BinaryOperatorExpression)( _
        AstConditional(Of BinaryOperatorExpression)(AstFrom("leftexp"), AstFrom("rightexp")) _
            .SetProperty(Function(e) e.Operator, AstFrom("op")) _
            .SetProperty(Function(e) e.LeftExpression, AstFrom("leftexp")) _
            .SetProperty(Function(e) e.RightExpression, AstFrom("rightexp")), _
        Function(n) n.LeftExpression, _
        Function(n) n.RightExpression, _
        Function(n1, n2) BinaryOperatorKindCheck(n1, n2, OperatorKind.Addition, OperatorKind.Subtraction))

There are two generic type arguments to the method. The first is the more generic type that we know is being bubbled up. The second is the derived type that can optionally be created by the production, in this case BinaryOperatorExpression

For method arguments, the first is the other tree constructor whose AST node result will be examined. The second and third arguments specify how to access the left and right side properties on a BinaryOperatorExpression. The final parameter is an optional condition predicate that returns true if the associativity should be changed.

The BinaryOperatorKindCheck method used in the predicate is a simple method that looks at the Operator property of each node and ensures that it is one of the supplied values. This ensures that operator precedence is properly maintained, since other higher-precedence operators like division should not be affected by the AstLeftAssociativity tree constructor for this particular additive expression production.

C#
VB
Copy
​private bool BinaryOperatorKindCheck(BinaryOperatorExpression expr1, BinaryOperatorExpression expr2, params OperatorKind[] operators) {
    if ((expr1 != null) && (expr2 != null) && (operators != null)) {
        // Ensure the expressions both contain one of the desired operators (to ensure proper operator precedence)
        return ((operators.Contains(expr1.Operator)) && (operators.Contains(expr2.Operator)));
    }
    return false;
}
​Private Function BinaryOperatorKindCheck(ByVal expr1 As BinaryOperatorExpression, ByVal expr2 As BinaryOperatorExpression, ParamArray ByVal operators() As OperatorKind) As Boolean
    If (expr1 IsNot Nothing) AndAlso (expr2 IsNot Nothing) AndAlso (operators IsNot Nothing) Then
        ' Ensure the expressions both contain one of the desired operators (to ensure proper operator precedence)
        Return ((operators.Contains(expr1.Operator)) AndAlso (operators.Contains(expr2.Operator)))
    End If
    Return False
End Function

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Walkthrough: Tree Constructors

LL(*) Parser Framework
Walkthrough: Tree Constructors

In the Tree Constructors topic, we gave an introduction to the powerful tree construction mechanism that is built into the LL(*) Parser Framework and talked about each of the built-in tree construction nodes that are available.

In this walkthrough, we are going to revisit the Simple language and will enhance our grammar productions with core tree constructors so that we make the resulting AST very concise.

This topic contains these sections:

  • Simple Language Grammar Review
  • Grammar Tree Constructor Enhancements
  • Elimination of Empty Value Nodes
  • Elimination of Unimportant Terminal Nodes
  • Elimination of Expression Nodes That Don’t Apply
  • More Conditional Output

Simple Language Grammar Review

The grammar productions we set up in the Walkthrough: Symbols and EBNF Terms topic all use the default tree constructors, so the AST output when parsing documents is extremely verbose.

When we look at the output, we see lots of empty nodes that contain other nodes, nodes for tokens such as ( that we don't care about, and lots of extra nodes for various expressions (like AdditiveExpression) that don't really apply here, but which are inserted due to how expressions are defined.

Let's fix all these problems right now by modifying out grammar productions to add tree constructors.

Grammar Tree Constructor Enhancements

Here is the modified set of grammar productions we’ll use. Note the tree constructors that are now present in nearly all of the productions as compared to our original grammar productions listed above.

C#
VB
Copy
​// Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
//   which is zero or more FunctionDeclarations
this.Root.Production = functionDeclaration.ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));

// Outputs a 'FunctionDeclaration' node with children:
//   1) The function declaration name value
//   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
//      if there are no parameters
//   3) The Block statement result
functionDeclaration.Production = @function + @identifier["name"] + @openParenthesis + functionParameterList["params"].Optional() + @closeParenthesis + block["block"]
    > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"));

// Outputs a 'FunctionParameterList' node whose children are parameter name values...
//   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = @identifier["param"] + (@comma + @identifier["param"] > AstFrom("param")).ZeroOrMore().SetLabel("moreparams")
    > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"));

// Outputs the result that came from the appropriate statement type that was matched...
//   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block["stmt"] > AstFrom("stmt")
    | emptyStatement > null
    | variableDeclarationStatement["stmt"] > AstFrom("stmt")
    | assignmentStatement["stmt"] > AstFrom("stmt")
    | returnStatement["stmt"] > AstFrom("stmt");

// Outputs a 'Block' node whose children are the contained statements
block.Production = @openCurlyBrace + statement.ZeroOrMore().SetLabel("stmt") + @closeCurlyBrace
    > Ast("Block", AstChildrenFrom("stmt"));

// Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > null;

// Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon
    > Ast("VariableDeclarationStatement", AstFrom("name"));

// Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = @identifier["varname"] + @assignment + expression["exp"] + @semiColon
    > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"));

// Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = @return + expression["exp"] + @semiColon
    > Ast("ReturnStatement", AstFrom("exp"));

// Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression["exp"] > AstFrom("exp");

// Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
//   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression["leftexp"] + ((@equality | @inequality).SetLabel("op") + equalityExpression["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
//   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression["leftexp"] + ((@addition | @subtraction).SetLabel("op") + additiveExpression["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
//   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression["leftexp"] + ((@multiplication | @division).SetLabel("op") + multiplicativeExpression["rightexp"]).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the result that came from the appropriate expression type that was matched...
//   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression["exp"] > AstFrom("exp")
    | functionAccessExpression["exp"] > AstFrom("exp")
    | simpleName["exp"] > AstFrom("exp")
    | parenthesizedExpression["exp"] > AstFrom("exp");

// Outputs the numeric value
numberExpression.Production = @number.ToTerm().ToProduction();

// Outputs the name value
simpleName.Production = @identifier.ToTerm().ToProduction();

// Outputs a 'FunctionAccessExpression' node with children:
//   1) The function name
//   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
//      if there are no arguments
functionAccessExpression.Production = @identifier["name"] + @openParenthesis + functionArgumentList["args"].Optional() + @closeParenthesis
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"));

// Outputs a 'FunctionArgumentList' node whose children are argument expressions...
//   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression["exp"] + (@comma + expression["exp"] > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps")
    > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"));

// Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = @openParenthesis + expression["exp"] + @closeParenthesis
    > Ast("ParenthesizedExpression", AstFrom("exp"));
​' Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
'   which is zero or more FunctionDeclarations
Me.Root.Production = functionDeclaration.ZeroOrMore().SetLabel("decl") > Ast("CompilationUnit", AstChildrenFrom("decl"))

' Outputs a 'FunctionDeclaration' node with children:
'   1) The function declaration name value
'   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
'      if there are no parameters
'   3) The Block statement result
functionDeclaration.Production = [function] + identifier("name") + openParenthesis + functionParameterList("params").Optional() + closeParenthesis + block("block") > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"))

' Outputs a 'FunctionParameterList' node whose children are parameter name values...
'   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = identifier("param") + (comma + identifier("param") > AstFrom("param")).ZeroOrMore().SetLabel("moreparams") > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"))

' Outputs the result that came from the appropriate statement type that was matched...
'   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block("stmt") > AstFrom("stmt") Or emptyStatement > Nothing Or variableDeclarationStatement("stmt") > AstFrom("stmt") Or assignmentStatement("stmt") > AstFrom("stmt") Or returnStatement("stmt") > AstFrom("stmt")

' Outputs a 'Block' node whose children are the contained statements
block.Production = openCurlyBrace + statement.ZeroOrMore().SetLabel("stmt") + closeCurlyBrace > Ast("Block", AstChildrenFrom("stmt"))

' Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > Nothing

' Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = var + identifier("name") + semiColon > Ast("VariableDeclarationStatement", AstFrom("name"))

' Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = identifier("varname") + assignment + expression("exp") + semiColon > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"))

' Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = [return] + expression("exp") + semiColon > Ast("ReturnStatement", AstFrom("exp"))

' Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression("exp") > AstFrom("exp")

' Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
'   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression("leftexp") + ((equality Or inequality).SetLabel("op") + equalityExpression("rightexp")).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
'   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression("leftexp") + ((addition Or subtraction).SetLabel("op") + additiveExpression("rightexp")).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
'   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression("leftexp") + ((multiplication Or division).SetLabel("op") + multiplicativeExpression("rightexp")).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the result that came from the appropriate expression type that was matched...
'   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression("exp") > AstFrom("exp") Or functionAccessExpression("exp") > AstFrom("exp") Or simpleName("exp") > AstFrom("exp") Or parenthesizedExpression("exp") > AstFrom("exp")

' Outputs the numeric value
numberExpression.Production = number.ToTerm().ToProduction()

' Outputs the name value
simpleName.Production = identifier.ToTerm().ToProduction()

' Outputs a 'FunctionAccessExpression' node with children:
'   1) The function name
'   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
'      if there are no arguments
functionAccessExpression.Production = identifier("name") + openParenthesis + functionArgumentList("args").Optional() + closeParenthesis > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"))

' Outputs a 'FunctionArgumentList' node whose children are argument expressions...
'   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression("exp") + (comma + expression("exp") > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps") > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"))

' Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = openParenthesis + expression("exp") + closeParenthesis > Ast("ParenthesizedExpression", AstFrom("exp"))

You can see we’re now making use of labels and all the various Ast* methods described in the Tree Constructors topic. Let’s use the same input as we did at the end of the Walkthrough: Symbols and EBNF Terms topic and see how our AST now looks:

Code Snippet
Copy
CompilationUnit[
    FunctionDeclaration[
        "IncrementAndMultiply"
        Parameters[
            "x"
            "y"
        ]
        Block[
            VariableDeclarationStatement[
                "result"
            ]
            AssignmentStatement[
                "result"
                FunctionAccessExpression[
                    "Increment"
                    Arguments[
                        SimpleName[
                            "x"
                        ]
                    ]
                ]
            ]
            ReturnStatement[
                *[
                    SimpleName[
                        "result"
                    ]
                    SimpleName[
                        "y"
                    ]
                ]
            ]
        ]
    ]
]

Now that’s a big improvement. We only have nodes for information that is important to us. And as mentioned in the past, each AST node that is generated automatically adds which start/end offsets it occurs over, which is invaluable information for consuming the AST later on.

Elimination of Empty Value Nodes

You’ll note that we completely eliminated all empty value nodes that are generated by quantifiers. An example is where in the root non-terminal’s production, we create a CompilationUnit whose child nodes come directly from the child nodes of the ZeroOrMore quantifier.

Elimination of Unimportant Terminal Nodes

We no longer have any AST nodes that relate to unimportant terminals such as ( or {. We now only have AST nodes for terminals that are meaningful to the code structure.

Elimination of Expression Nodes That Don’t Apply

Due to how expressions must be defined to properly set up operator precedence, the default tree constructors would create a lot of nodes such as AdditiveExpression that didn’t apply for this input. With our modifications, we’ve completely eliminated those extra expressions. You’ll note our return statement at the end generates an AST node whose value is * (the operator used) and whose two children are the left and right child expressions to be multiplied. This functionality is achieved via the tree construction node provided by the AstValueOfConditional method.

More Conditional Output

Although the above input doesn’t show it, say IncrementAndMultiply didn’t have any parameters. Via use of the tree construction node created by AstConditionalFrom, the Parameters node would have been left out of the AST output in that case.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Callbacks and Error Handling

LL(*) Parser Framework
Callbacks and Error Handling

The next step in building a grammar is to make sure that it properly handles errors. After all, since this grammar framework is intended to be used with SyntaxEditor, our code editor control, we have to assume that most of the time the document’s code passed to our grammar parser will be in an invalid state. The user is continuously typing and modifying it.

In this topic, we will look at the various callbacks that are available to you, probably the most important of which are the error handling callbacks. We'll also dig into error handling options.

This topic contains these sections:

  • What is a Callback?
  • EbnfTerm Callbacks
  • Important Notes on Callback Assignments
  • Built-in Error Callbacks
  • Advanced Error Handling
  • Error Precedence
  • Non-Terminal Can-Match Callbacks
  • Terminal Can-Match Callbacks
  • Proper Design of Iterative Productions
  • Best Practices for Error Handling

What is a Callback?

As we’ve seen previously, our entire grammar is built directly in C# or VB code. We do not do code generation like a lot of other parser generators do. A benefit of this is that you can interact directly with objects in the grammar.

One way to interact with objects is to assign callbacks to them. All EbnfTerm-based objects support four callbacks:

  • Initialize
  • Success
  • Error
  • Complete

And as shown in other topics, NonTerminal objects can be assigned a can-match callback.

Callbacks are simply delegates that get called when certain events occur. You can point them to methods you declare or can inject lambda expressions as well.

Let’s look at each of the five callbacks.

EbnfTerm Callbacks

Initialize and Complete callbacks

The Initialize callback is called right before an EbnfTerm is about to be parsed. The Complete callback is called right after an EbnfTerm has been parsed. Thus they are always paired.

It is important to note that Complete is called regardless of whether the term’s parsing succeeded or failed.

Success and Error callbacks

The Success callback is called right after an EbnfTerm is parsed successfully. Alternatively, if the EbnfTerm was not parsed successfully, the Error callback is called. Thus each term that is attempted to be parsed will either have its Success or Error callbacks fired.

The Success and Error callbacks occur immediately before the Complete callback does.

Summary of EbnfTerm Callbacks

A term that is successfully parsed will offer this sequence of callbacks:

  • Initialize
  • (parsing attempt here)
  • Success
  • Complete

A term that is not successfully parsed will offer this sequence of callbacks:

  • Initialize
  • (parsing attempt here)
  • Error
  • Complete

Definitions

The Initialize, Success, and Complete callbacks have this definition:

C#
VB
Copy
​public delegate void ParserCallback(IParserState state);
​Public Delegate Sub ParserCallback(ByVal state As IParserState)

It is passed an IParserState that gives you access to look-ahead tokens, custom data, and the matches that have been made at the current scope level. You can update custom data, or even modify the matches collection if you wish in any of these callbacks.

Custom data can be anything you wish. Perhaps as you traverse through certain non-terminals, you want to maintain a stack of which ones you’ve visited. Your custom data could contain such a stack. In the Initialize callback for the non-terminals you wish to track, you could push an item on the stack. In the Complete callback for the non-terminals you wish to track, you could pop an item off the stack.

The Error callback has this definition:

C#
VB
Copy
​public delegate IParserErrorResult ParserErrorCallback(IParserState state);
​Public Delegate Function ParserErrorCallback(ByVal state As IParserState) As IParserErrorResult

The Error callback also gets an IParserState passed to it. However it differs from the others in that it expects an IParserErrorResult object returned. Since the Error callback is called when an error occurs, this result tells the parser how to proceed. There are options for preventing any errors from being reported and options for whether to continue on as if no error occurred.

The standard set of options are provided in the ParserErrorResults object via static properties:

  • Default – Potentially report errors and return a match failure.
  • Continue – Potentially report errors but continue on.
  • Ignore – Never report errors and continue on.
  • NoReport – Never report errors and return a match failure.

Sample callback

Callbacks can be assigned with the OnInitialize, OnSuccess, OnError, and OnComplete methods.

This root production shows how an Error callback can be assigned by calling the OnError method and passing it the delegate to use. In this case the method that will be called is AdvanceToDefaultState.

C#
VB
Copy
​this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​Me.Root.Production = functionDeclaration.OnError(AddressOf AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

What happens is that if an error occurs while parsing FunctionDeclaration, the AdvanceToDefaultState method is called, which does this:

C#
VB
Copy
​/// <summary>
/// Advances the token reader to the next 'function' token from where parsing
/// can resume.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
private IParserErrorResult AdvanceToDefaultState(IParserState state) {
    state.TokenReader.AdvanceTo(SimpleTokenId.Function);
    return ParserErrorResults.Continue;
}
​''' <summary>
''' Advances the token reader to the next 'function' token from where parsing
''' can resume.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
Private Function AdvanceToDefaultState(ByVal state As IParserState) As IParserErrorResult
    state.TokenReader.AdvanceTo(SimpleTokenId.Function)
    Return ParserErrorResults.Continue
End Function

You can see how it tells the token reader to advance to the next Function token. We have skipped over any potentially “bad” tokens and have gone right to the next token that we know will successfully start a FunctionDeclaration.

The callback returns ParserErrorResults.Continue, which means potentially report an error, but continue on instead of breaking out of the ZeroOrMore quantifier that contains the FunctionDeclaration non-terminal.

Important Notes on Callback Assignments

Both the Symbol (terminals and non-terminals) and the various EbnfTerm-based classes have methods to be able to assign the callbacks above, along with the built-in error callbacks described below in this topic.

If the callback assign method is called on a Symbol-based class then a related EbnfTerm-based class (either EbnfTerminal or EbnfNonTerminal) is created, assigned the callback, and is returned by the method. It is important to note that the callback is not assigned on the Symbol instance itself, only on the EbnfTerm class that is returned by the method.

On the other hand, if the callback assign method is called on an EbnfTerm-based class, the callback is directly assigned to it and the EbnfTerm same instance is returned.

Say that you want to assign a Complete callback onto a CompilationUnit non-terminal so you can examine the AST that was created by the parse and report any additional parse errors as needed. You may be tempted to do this:

C#
VB
Copy
​compilationUnit.Production = [your EBNF production here];
compilationUnit.OnComplete(CompilationUnitComplete);
​compilationUnit.Production = [your EBNF production here]
compilationUnit.OnComplete(AddressOf CompilationUnitComplete)

Per above, the various OnXX calls on a symbol like NonTerminal will create an EbnfNonTerminal instance and will assign the callback to that. Since we're not capturing the return value of the OnComplete call here within a production, the EBNF term is discarded and the callback is never used.

One way to do what was intended is to do this instead:

C#
VB
Copy
​compilationUnit.Production = [your EBNF production here];
compilationUnit.Production.CompleteCallback = CompilationUnitComplete;
​compilationUnit.Production = [your EBNF production here]
compilationUnit.Production.CompleteCallback = AddressOf CompilationUnitComplete

This code assigns the callback to the EbnfProduction for the CompilationUnit non-terminal, and will thus always get called properly.

Another way to accomplish the same thing is inline like this:

C#
VB
Copy
​compilationUnit.Production = ([your EBNF production here]).OnComplete(CompilationUnitComplete);
​compilationUnit.Production = ([your EBNF production here]).OnComplete(AddressOf CompilationUnitComplete)

Built-in Error Callbacks

There are also some built-in Error callbacks that you can assign. They don’t do anything other than return the various related ParserErrorResults values:

  • OnErrorContinue – Returns ParserErrorResults.Continue.
  • OnErrorIgnore – Returns ParserErrorResults.Ignore.
  • OnErrorNoReport – Returns ParserErrorResults.NoReport.

This example shows the use of OnErrorContinue, where we will report an error if the semi-colon isn’t matched, but we’ll continue on with parsing as if it was there:

C#
VB
Copy
​variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon.OnErrorContinue()
    > Ast("VariableDeclarationStatement", AstFrom("name"));
​variableDeclarationStatement.Production = var + identifier("name") + semiColon.OnErrorContinue() _
    > Ast("VariableDeclarationStatement", AstFrom("name"))

Advanced Error Handling

Sometimes errors will occur where a non-terminal is referenced however that non-terminal is capable of starting with multiple different terminals. In that case, the parser doesn’t report an error by default since it doesn’t know what it should say. Here’s a perfect example:

C#
VB
Copy
​returnStatement.Production = @return + expression["exp"].OnErrorContinue() + @semiColon.OnErrorContinue()
    > Ast("ReturnStatement", AstFrom("exp"));
​returnStatement.Production = [return] + expression("exp").OnErrorContinue() + semiColon.OnErrorContinue() _
    > Ast("ReturnStatement", AstFrom("exp"))

Say the input for this production was return return. Obviously that is invalid as the second return keyword doesn’t fit into an expression. Expression can start with numerous terminals so an error occurs but no parse error is reported into the parse errors collection since the parser doesn’t know what to tell the UI.

We have two options for handling this scenario.

Option 1 - Use an Error Alias

When a NonTerminal is assigned an ErrorAlias, it will report an error by default if it fails to match. You only want to set error aliases on higher-level non-terminals such as Expression or Statement non-terminals. You can do so like this:

C#
VB
Copy
​var expression = new NonTerminal("Expression") { ErrorAlias = "Expression" };
​Dim expression = New NonTerminal("Expression") With {.ErrorAlias = "Expression"}

That will tell the parser to automatically report an Expression expected parse error if Expression fails to match. This is the easiest way to handle this scenario.

Option 2 - Custom Error Callback

The second option that can be used if we need to customize the error message more is to use an error callback:

C#
VB
Copy
​returnStatement.Production = @return + expression["exp"].OnError(ExpressionExpected) + @semiColon.OnErrorContinue()
    > Ast("ReturnStatement", AstFrom("exp"));
​returnStatement.Production = [return] + expression("exp").OnError(AddressOf ExpressionExpected) + semiColon.OnErrorContinue() _
    > Ast("ReturnStatement", AstFrom("exp"))

The error callback can be implemented like this:

C#
VB
Copy
​/// <summary>
/// Occurs when an expression is expected but not found.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
private IParserErrorResult ExpressionExpected(IParserState state) {
    // Report a custom error, and return a value telling the parser to not report
    // errors and continue on
    state.ReportError(ParseErrorLevel.Error, "Expression should have been here.");
    return ParserErrorResults.Ignore;
}
​''' <summary>
''' Occurs when an expression is expected but not found.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>An <see cref="IParserErrorResult"/> value indicating a result.</returns>
Private Function ExpressionExpected(ByVal state As IParserState) As IParserErrorResult
    ' Report a custom error, and return a value telling the parser to not report
    ' errors and continue on
    state.ReportError(ParseErrorLevel.Error, "Expression should have been here.")
    Return ParserErrorResults.Ignore
End Function

Note that here we report an error Expression should have been here instead of the Expression expected message that comes from option #1. We also return ParserErrorResults.Ignore to ensure that no other error message is reported, and tell the parser to continue on.

Note Note
The IParserState interface defines multiple methods that can be used to report parse errors within callbacks.

Error Precedence

We've now seen how both terminals and non-terminals are capable of reporting parse errors that can be displayed in the user interface. In some scenarios, multiple errors may be reported for a given text offset. Allowing this can really confuse the end user. The grammar framework has built in functionality such that it will only report the first parse error for a given offset, since that is the most important one.

The parse error collection returned in the parse data result back to the document will also be sorted by each error’s location in the document.

Non-Terminal Can-Match Callbacks

Can-match callbacks can optionally be assigned to any NonTerminal. Since our grammar is LL-based, each NonTerminal maintains a set of terminals that it knows are able to start it. This is called the "first set". For instance a Simple language FunctionDeclaration production always starts with a Function terminal. Thus the FunctionDeclaration’s first set consists of a single Function terminal.

Sometimes you may have an alternation EBNF term with two or more non-terminal references that have intersecting first sets. We see this in the Simple language where both the SimpleName and FunctionAccessExpression non-terminal productions start with Identifier terminals, and the PrimaryExpression non-terminal production is an alternation that contains both of them. This situation is called ambiguity and the grammar will warn you when it detects the scenario so that you can fix it.

When a can-match callback is specified, it effectively overrides the "first set" of the non-terminal. Thus in the Simple language where the ambiguity occurred, the ambiguity is resolved by applying a can-match callback to one of the ambiguous non-terminals.

Note Note
The NonTerminal.CanMatch method can be used to determine if a specified IParserState's look-ahead token can start to match the NonTerminal. The method examines the non-terminal's "first set" as well as its can-match callbacks to determine the result.

Definition

A can-match callback has this definition:

C#
VB
Copy
​public delegate bool ParserCanMatchCallback(IParserState state);
​Public Delegate Function ParserCanMatchCallback(ByVal state As IParserState) As Boolean

It is passed an IParserState and the result is a boolean value indicating whether the non-terminal can match with the current state. Logic in the callback is generally implemented such that it examines look-ahead tokens to see what the next several tokens are. Since you are able to look ahead all the way to the end of the document if you wish, that is the reason our grammar is LL(*). The * means infinite look-ahead.

Sample callback

The Simple language grammar’s FunctionAccessExpression has a can-match callback. This code can be used to assign the callback:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = CanMatchFunctionAccessExpression;
​functionAccessExpression.CanMatchCallback = AddressOf CanMatchFunctionAccessExpression

And here is the callback implementation:

C#
VB
Copy
​/// <summary>
/// Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information
/// about the parser's current state.</param>
/// <returns>
/// <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
/// otherwise, <c>false</c>.
/// </returns>
private bool CanMatchFunctionAccessExpression(IParserState state) {
    return (state.TokenReader.LookAheadToken.Id == SimpleTokenId.Identifier) &&
        (state.TokenReader.GetLookAheadToken(2).Id == SimpleTokenId.OpenParenthesis);
}
​''' <summary>
''' Returns whether the <c>FunctionAccessExpression</c> non-terminal can match.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information
''' about the parser's current state.</param>
''' <returns>
''' <c>true</c> if the <see cref="NonTerminal"/> can match with the current state;
''' otherwise, <c>false</c>.
''' </returns>
Private Function CanMatchFunctionAccessExpression(ByVal state As IParserState) As Boolean
    Return (state.TokenReader.LookAheadToken.Id = SimpleTokenId.Identifier) AndAlso (state.TokenReader.GetLookAheadToken(2).Id = SimpleTokenId.OpenParenthesis)
End Function

Smaller callback implementations can be entered directly in a single statement via lambdas like this:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = (state =>
    (state.TokenReader.LookAheadToken.Id == SimpleTokenId.Identifier) &&
    (state.TokenReader.GetLookAheadToken(2).Id == SimpleTokenId.OpenParenthesis) );
​functionAccessExpression.CanMatchCallback = (Function(state) _
    (state.TokenReader.LookAheadToken.Id = SimpleTokenId.Identifier) AndAlso _
    (state.TokenReader.GetLookAheadToken(2).Id = SimpleTokenId.OpenParenthesis))

Token Reader AreNext Helper Method

A lot of times, can-match callbacks just involve checking for a specific sequence of two or more tokens such as in the example above. The ITokenReader.AreNext helper method is available for these scenarios. It accepts two or more token IDs and the returns if that exact sequence of tokens is next.

The previous example could therefore be simplified to:

C#
VB
Copy
​functionAccessExpression.CanMatchCallback = (state =>
    state.TokenReader.AreNext(SimpleTokenId.Identifier, SimpleTokenId.OpenParenthesis));
​functionAccessExpression.CanMatchCallback = (Function(state) _
    state.TokenReader.AreNext(SimpleTokenId.Identifier, SimpleTokenId.OpenParenthesis))

Token Reader Push/Pop Methods

Sometimes a can-match callback may require multiple token look-ahead, where special conditions are checked along the way. Special ITokenReader.Push and related Pop methods are available for this scenario.

Normally reading ahead through tokens in a can-match callback would consume the token, preventing it from later being parsed. By calling Push, the state of the token reader is saved. You then can advance through as many tokens as you wish and then Pop the old state back into place.

Here is an example of their usage for a C# language grammar that checks to see if a local variable declaration can start:

C#
VB
Copy
​private bool CanMatchLocalVariableDeclaration(IParserState state) {
    state.TokenReader.Push();
    try {
        if (state.TokenReader.LookAheadToken.Id == CSharpTokenId.Var) {
            // Advance past 'var'
            state.TokenReader.Advance();
        }
        else if (!this.IsType(state))
            return false;

        // Ensure that an identifier or contextual keyword can match at this point
        return identifierOrContextualKeyword.CanMatch(state);
    }
    finally {
        state.TokenReader.Pop();
    }
}
​Private Function CanMatchLocalVariableDeclaration(ByVal state As IParserState) As Boolean
    state.TokenReader.Push()
    Try
        If state.TokenReader.LookAheadToken.Id = CSharpTokenId.Var Then
            ' Advance past 'var'
            state.TokenReader.Advance()
        ElseIf Not Me.IsType(state) Then
            Return False
        End If

        ' Ensure that an identifier or contextual keyword can match at this point
        Return identifierOrContextualKeyword.CanMatch(state)
    Finally
        state.TokenReader.Pop()
    End Try
End Function

Note we are able to freely advance through tokens and do other calls (like to the IsType method) that also advance through more tokens to tell us if the conditions to start this non-terminal are met.

CanAlwaysMatch Callback

There is a built-in method called Grammar.CanAlwaysMatch which is a can-match callback that always returns true. This callback is useful as described in the next section.

Terminal Can-Match Callbacks

Although a lesser-used feature, terminals can also support can-match callbacks, similar to non-terminals. Normally when no can-match callback is specified on a terminal, the terminal's first set is considered the token ID value associated with it.

An example use for this feature is say that you have some contextual keywords, meaning identifiers that turn into keywords but only in certain parser contexts. The lexer in use may always mark them as identifiers but in certain grammar productions you want to look for these identifiers that have a certain value. In this case you would define a terminal that had a can-match callback to first make sure the look-ahead token is an identifier. If so, it would check its text value to see if it matches the contextual keyword text. That is one way to handle contextual keywords like var or from in C#.

Proper Design of Iterative Productions

Very often a root compilation unit has some other set of non-terminals that repeat within it. In this case we set up a non-terminal EBNF term with an error handler and place it in a ZeroOrMore quantifier like this:

C#
VB
Copy
​this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​Me.Root.Production = functionDeclaration.OnError(AddressOf AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

What happens here is that if an error occurs in FunctionDeclaration it will advance to the next function token (per above) and will continue on with the next FunctionDeclaration match.

But what happens if at the start of the document we have an invalid token instead, such as an Identifier? FunctionDeclaration doesn’t start with an Identifier terminal. It only starts with a Function terminal. Thus the entire ZeroOrMore quantifier will never be entered and your CompilationUnit AST node output will be empty, even if there are a lot of valid function declarations after that initial Identifier.

We can easily handle this scenario by using the Grammar.CanAlwaysMatch callback on FunctionDeclaration:

C#
VB
Copy
​// Make sure FunctionDeclaration will always be examined,
// even if the next token is not 'function'
functionDeclaration.CanMatchCallback = CanAlwaysMatch;
​' Make sure FunctionDeclaration will always be examined,
' even if the next token is not 'function'
functionDeclaration.CanMatchCallback = AddressOf CanAlwaysMatch

Thus we have forced the "first set" of FunctionDeclaration to be overridden and even tokens like Identifier will cause us to enter FunctionDeclaration. In that scenario, Identifier won’t match with the Function terminal and an error will be reported that indicates 'function' expected. This scenario is now properly handled.

Advanced Implementations

What about languages such as C# where you could have a using statement, namespace, or type declaration at the root compilation unit level? We’ll apply the same concepts.

Make a new non-terminal called CompilationUnitContent that has an alternation between those other non-terminals. Make the root production call CompilationUnitContent in the same way FunctionDeclaration was called above, with an error handler. Then likewise, we set the CanAlwaysMatch callback on the CompilationUnitContent non-terminal.

The AdvanceToDefaultState method that we use needs to be designed to advance to the next Using, Namespace, etc. token. This is easy as the AdvanceTo method we provide on ITokenReader can accept any number of token ID values.

Finally we can use one of the two options listed in the Advanced Error Handling section above to report a helpful parse error to the end user.

Best Practices for Error Handling

This section discusses some best practices to use when implementing error handling in a grammar.

Looping

When looping on a child non-terminal, it is advisable to have an error handler on the inside of the ZeroOrMore/OneOrMore so that if an error occurs inside the loop, it can continue on when appropriate.

This sample shows a production that includes an error handler within the quantifier loop. The custom CompilationUnitError error handler has code in it that advances the token reader to the next token that can start a CompilationUnitContent non-terminal.

C#
VB
Copy
​compilationUnit.Production = compilationUnitContent.OnError(CompilationUnitError).ZeroOrMore();
​compilationUnit.Production = compilationUnitContent.OnError(AddressOf CompilationUnitError).ZeroOrMore()

Consuming Minimum Important Terms

Don't add error handling that always continues on until a minimum number of EBNF terms have been matched to justify an AST result.

In this case, we need a namespace name before it makes sense to build an AST result.

C#
VB
Copy
​namespaceDeclaration.Production = @keywordNamespace + qualifiedIdentifier["name"] + namespaceBody["body"].OnErrorContinue() + @semiColon.Optional();
​namespaceDeclaration.Production = keywordNamespace + qualifiedIdentifier("name") + namespaceBody("body").OnErrorContinue() + semiColon.Optional()

Don't Add Error Handlers to Everything

Don't put error handlers on all EBNF terms, thus forcing the parser to continue through all productions. Sometimes it's better to let a bad production fail due to a syntax error and bubble up to a container that has a generalized handler.

No Error Handling on Optional Terminals

Never add error handling on an optional terminal since there is no way it can error.

In this sample, the semiColon terminal doesn't have an error handler on it since it is optional.

C#
VB
Copy
​namespaceDeclaration.Production = @keywordNamespace + qualifiedIdentifier["name"] + namespaceBody["body"].OnErrorContinue() + @semiColon.Optional();
​namespaceDeclaration.Production = keywordNamespace + qualifiedIdentifier("name") + namespaceBody("body").OnErrorContinue() + semiColon.Optional()

No Error Handling on First Terminal in a Production

Don't put error handlers on a first single terminal in a production.

In this sample, the keywordNamespace terminal doesn't have an error handler on it since in order for this non-terminal to be called, a namespace keyword must have been present.

C#
VB
Copy
​namespaceDeclaration.Production = @keywordNamespace + qualifiedIdentifier["name"] + namespaceBody["body"].OnErrorContinue() + @semiColon.Optional();
​namespaceDeclaration.Production = keywordNamespace + qualifiedIdentifier("name") + namespaceBody("body").OnErrorContinue() + semiColon.Optional()

Add Error Handling to Insignificant Terminals at a Production End

Required terminals that end non-terminal productions like ), } or ; should always have an OnErrorContinue on them since they are insignificant to the meaning of what is in the document. A parse error will still be reported for them if they are not present in the code.

In this sample, the semiColon terminal has an error handler on it.

C#
VB
Copy
​usingNamespaceDirective.Production = @keywordUsing + namespaceName["name"] + @semiColon.OnErrorContinue();
​usingNamespaceDirective.Production = keywordUsing + namespaceName("name") + semiColon.OnErrorContinue()

Watch For .OnErrorContinue().OneOrMore() Infinite Loop Possibilities

Be careful of .OnErrorContinue().OneOrMore() scenarios. Since at least one match is required, if it doesn't perform any token consumption (due to a syntax error), then an infinite loop can occur due to the error handler. Any OneOrMore calls with inner error handlers need to have the error handlers ensure that at least one token is consumed to void the possibility of infinite loops.

Watch For Can-Match Callback Infinite Loop Possibilities

Similar to the previous tip, when setting a can-match that forces a non-terminal to match (such as is described in the Proper Design of Iterative Productions section above), callers of that non-terminal need to have a custom error handler that will force at least one token to be consumed, or else an infinite loop can occur if there is a syntax error.

Break Out Alternation Options to Separate Non-Terminals

For improved error reporting, break out alternations to their own non-terminal productions and give each new non-terminal an ErrorAlias as appropriate.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Walkthrough: Callbacks and Error Handling

LL(*) Parser Framework
Walkthrough: Callbacks and Error Handling

In the Callbacks and Error Handling topic, we saw how the grammar framework supports callbacks nearly everywhere in the EBNF terms. You are able to inject custom code before and after any term is matched. One of the most important injection points is the Error callback since that allows you to tell the parser how to handle errors.

In this topic we’ll examine the importance of adding error handling. We’ll enhance our Simple language grammar to properly recover from nearly any invalid syntax in a document so that it can continue parsing the rest of the document.

This topic contains these sections:

  • Why Add Error Handling?
  • Enhancing the Simple Language Grammar with Error Handling
  • Final Grammar Productions for the Simple Language
  • Error Handling in Action
  • Conclusion

Why Add Error Handling?

An error occurs when one or more terminals is expected by the parser (per the grammar) but a different token is found at the current location in the document.

By default when this scenario occurs, the parser will report a parse error if a single terminal is expected. If there is more than one terminal that could be next, and if the containing non-terminal has an error alias set, it will report a parse error instead. This behavior is described in the Callbacks and Error Handling topic.

Following any possible error reporting, the parser will immediately exit the current non-terminal and will continue up the non-terminal stack, exiting each one as it goes until the root non-terminal is reached and exited itself.

Thus the result is that if any invalid syntax is found in a document, parsing stops at that point and no AST will be built. That’s definitely not good since we expect code being parsed from our SyntaxEditor control editing to be invalid most of the time. End users are continuously typing in it.

As shown in the Callbacks and Error Handling topic, the grammar framework has a lot ways to recover from errors, and they are easy to add.

Enhancing the Simple Language Grammar with Error Handling

Adding an Error Alias to Some Non-Terminals

The first step in adding error handling is to identify which non-terminals should get error aliases (described in the Callbacks and Error Handling topic). When a non-terminal has an error alias and an error occurs within it, it will report a parse error.

In the Simple language grammar, we’ll add an error alias to the Statement and PrimaryExpression non-terminals like this:

C#
VB
Copy
​var statement = new NonTerminal("Statement") { ErrorAlias = "Statement" };
var primaryExpression = new NonTerminal("PrimaryExpression") { ErrorAlias = "Expression" };
​Dim statement = New NonTerminal("Statement") With {.ErrorAlias = "Statement"}
Dim primaryExpression = New NonTerminal("PrimaryExpression") With {.ErrorAlias = "Expression"}

Now say we are parsing and an Expression is expected next but our look-ahead token is Var. The Terminal for Var doesn’t start any expressions, so this is an error. Thus an Expression expected error will be reported since we assigned an error alias to the PrimaryExpression non-terminal, which is indirectly required by the Expression non-terminal.

Adding Iterative Error Handling in the Root Production

As described in the Callbacks and Error Handling topic, when you have a scenario where some child non-terminal is being repeated, which often is the case in the root non-terminal, we want to force the child non-terminal being repeated to get parsed. We do this, even if the look-ahead token doesn’t match the child non-terminal’s "first set."

Otherwise if some token was first in the document that didn’t match with the "first set" of the child non-terminal, the parsing would exit immediately, which is not good.

We can force a non-terminal to ignore its "first set" and always be matched by setting its can-match callback to the built in CanAlwaysMatch method on Grammar:

C#
VB
Copy
​// NOTE: Next line added so that FunctionDeclaration will always be examined,
//   even if the next token is not 'function'... This ensures that a non-function
//   token at the start of the document will not prevent the rest of the document
//   from being parsed
functionDeclaration.CanMatchCallback = CanAlwaysMatch;
​' NOTE: Next line added so that FunctionDeclaration will always be examined,
'   even if the next token is not 'function'... This ensures that a non-function
'   token at the start of the document will not prevent the rest of the document
'   from being parsed
functionDeclaration.CanMatchCallback = AddressOf CanAlwaysMatch

The next step is to add an error callback to the FunctionDeclaration EBNF non-terminal:

C#
VB
Copy
​// Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
//   which is zero or more FunctionDeclarations...
// If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
//   that is defined below... it advances to the next 'Function' token and flags to continue parsing
this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));
​' Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
'   which is zero or more FunctionDeclarations...
' If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
'   that is defined below... it advances to the next 'Function' token and flags to continue parsing
Me.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") _
    > Ast("CompilationUnit", AstChildrenFrom("decl"))

The AdvanceToDefaultState method is called when an unhandled error occurs in FunctionDeclaration. It advances to the next Function token, which is what properly starts a FunctionDeclaration, thus skipping over any other tokens that would cause more parse errors. It then tells the parser to continue on.

C#
VB
Copy
​/// <summary>
/// Advances the token reader to the next 'function' token from where
/// parsing can resume.
/// </summary>
/// <param name="state">An <c>IParserState</c> that provides information
/// about the parser's current state.</param>
/// <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
private IParserErrorResult AdvanceToDefaultState(IParserState state) {
    state.TokenReader.AdvanceTo(SimpleTokenId.Function);
    return ParserErrorResults.Continue;
}
​''' <summary>
''' Advances the token reader to the next 'function' token from where
''' parsing can resume.
''' </summary>
''' <param name="state">An <c>IParserState</c> that provides information
''' about the parser's current state.</param>
''' <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
Private Function AdvanceToDefaultState(ByVal state As IParserState) As IParserErrorResult
    state.TokenReader.AdvanceTo(SimpleTokenId.Function)
    Return ParserErrorResults.Continue
End Function

Let’s walk through what happens now. Say there is an invalid look-ahead token while parsing in the middle of a FunctionDeclaration. An error will occur and possibly be reported. The error will bubble up to the root non-terminal, where the error callback will execute AdvanceToDefaultState. That moves to the next Function token and then tells the parser to continue on. Thus the ZeroOrMore quantifier in the root non-terminal will not be exited and the FunctionDeclaration non-terminal will be entered again.

This design is very important because it allows us recover from invalid syntax and to continue on parsing a document.

Adding Iterative Error Handling for Statements

In block statements, we'll want to force the next token to be parsed as a statement as long as we aren't at the document end or if the token isn't a '}' character. This ensures that any tokens that don't start a statement will be flagged as an error and skipped over. To accomplish this, we add a new BlockChildStatement non-terminal and set a can-match callback:

C#
VB
Copy
​var blockChildStatement = new NonTerminal("BlockChildStatement");
blockChildStatement.CanMatchCallback = CanMatchBlockChildStatement;

// Forces a child statement to try to match via the CanMatch callback, unless the next token is a '}'
blockChildStatement.Production = statement["stmt"] > AstFrom("stmt");
​Dim blockChildStatement = New NonTerminal("BlockChildStatement")
blockChildStatement.CanMatchCallback = AddressOf CanMatchBlockChildStatement

' Forces a child statement to try to match via the CanMatch callback, unless the next token Is a '}'
blockChildStatement.Production = statement("stmt") > AstFrom("stmt")

C#
VB
Copy
​/// <summary>
/// Returns whether the <c>BlockChildStatement</c> non-terminal can match.
/// </summary>
/// <param name="state">A <see cref="IParserState"/> that provides information about the parser's current state.</param>
/// <returns>
/// <c>true</c> if the <see cref="NonTerminal"/> can match with the current state; otherwise, <c>false</c>.
/// </returns>
private bool CanMatchBlockChildStatement(IParserState state) {
    // Match as long as we aren't at the document end or at a curly brace
    return (!state.TokenReader.IsAtEnd) && (state.TokenReader.LookAheadToken.Id != SimpleTokenId.CloseCurlyBrace);
}
​''' <summary>
''' Returns whether the <c>BlockChildStatement</c> non-terminal can match.
''' </summary>
''' <param name="state">A <see cref="IParserState"/> that provides information about the parser's current state.</param>
''' <returns>
''' <c>true</c> if the <see cref="NonTerminal"/> can match with the current state; otherwise, <c>false</c>.
''' </returns>
Private Function CanMatchBlockChildStatement(ByVal state As IParserState) As Boolean
    ' Match as long as we aren't at the document end or at a curly brace
    Return (Not state.TokenReader.IsAtEnd) AndAlso (state.TokenReader.LookAheadToken.Id <> SimpleTokenId.CloseCurlyBrace)
End Function

The Block production changes its Statement non-terminal reference to be the new BlockChildStatement non-terminal instead. Finally, we need to inject a custom error handler so that when a child statement fails to match, the token reader is advanced to the next token that can start a statement or is the block close ('}'). The Block production is updated to call a custom AdvanceToStatementOrBlockEnd callback if an error occurs while parsing a child statement.

C#
VB
Copy
​// Outputs a 'Block' node whose children are the contained statements
block.Production = @openCurlyBrace + blockChildStatement.OnError(AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + @closeCurlyBrace.OnErrorContinue()
    > Ast("Block", AstChildrenFrom("stmt"));
​' Outputs a 'Block' node whose children are the contained statements
block.Production = openCurlyBrace + blockChildStatement.OnError(AddressOf AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + closeCurlyBrace.OnErrorContinue() _
    > Ast("Block", AstChildrenFrom("stmt"))

AdvanceToStatementOrBlockEnd is set up to advance through tokens until the next one is reached that can either close the block or start a new statement. Note that part of this code requires the direct use of the Statement non-terminal, so the statement variable in the constructor has been changed to a class field instead.

C#
VB
Copy
​/// <summary>
/// Advances the token reader to the next statement or block end from where parsing can resume.
/// </summary>
/// <param name="state">An <c>IParserState</c> that provides information
/// about the parser's current state.</param>
/// <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
private IParserErrorResult AdvanceToStatementOrBlockEnd(IParserState state) {
    while (!state.TokenReader.IsAtEnd) {
        // Quit when a statement or block end is reached
        if (
            (state.TokenReader.LookAheadToken.Id == SimpleTokenId.CloseCurlyBrace) ||
            (statement.CanMatch(state))
            )
            return ParserErrorResults.Continue;

        // Advance a token
        state.TokenReader.Advance();
    }

    return ParserErrorResults.Continue;
}
​''' <summary>
''' Advances the token reader to the next statement or block end from where parsing can resume.
''' </summary>
''' <param name="state">An <c>IParserState</c> that provides information
''' about the parser's current state.</param>
''' <returns>An <c>IParserErrorResult</c> value indicating a result.</returns>
Private Function AdvanceToStatementOrBlockEnd(ByVal state As IParserState) As IParserErrorResult
    Do While Not state.TokenReader.IsAtEnd
        ' Quit when a statement or block end is reached
        If (state.TokenReader.LookAheadToken.Id = SimpleTokenId.CloseCurlyBrace) OrElse (statement.CanMatch(state)) Then
            Return ParserErrorResults.Continue
        End If

        ' Advance a token
        state.TokenReader.Advance()
    Loop

    Return ParserErrorResults.Continue
End Function

Adding More Inline Error Handling to Productions

The last step we’ll do to add error handling to the Simple language grammar is to insert OnErrorContinue handlers in various places throughout the productions.

It’s good to insert them on Terminal objects that are generally insignificant we don’t want things like a missing semi-colon to prevent an entire function declaration from being parsed. Here’s an example:

C#
VB
Copy
​// Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon.OnErrorContinue()
    > Ast("VariableDeclarationStatement", AstFrom("name"));
​' Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = var + identifier("name") + semiColon.OnErrorContinue() _
    > Ast("VariableDeclarationStatement", AstFrom("name"))

It’s up to you to determine when you think a parser should just continue on (by specifying OnErrorContinue) and when it should bubble up to the calling non-terminal. The grammar framework gives you complete flexibility in how you wish to process things.

Final Grammar Productions for the Simple Language

Here is our finalized set of grammar productions for the Simple language. It completely parses Simple code, builds a concise AST, and properly recovers from syntax errors.

C#
VB
Copy
​// Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
//   which is zero or more FunctionDeclarations...
// If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
//   that is defined below... it advances to the next 'Function' token and flags to continue parsing
this.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl")
    > Ast("CompilationUnit", AstChildrenFrom("decl"));

// Outputs a 'FunctionDeclaration' node with children:
//   1) The function declaration name value
//   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
//      if there are no parameters
//   3) The Block statement result
functionDeclaration.Production = @function + @identifier["name"] + @openParenthesis.OnErrorContinue() + functionParameterList["params"].Optional() + @closeParenthesis.OnErrorContinue() + block["block"].OnErrorContinue()
    > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"));

// Outputs a 'FunctionParameterList' node whose children are parameter name values...
//   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = @identifier["param"] + (@comma + @identifier["param"].OnErrorContinue() > AstFrom("param")).ZeroOrMore().SetLabel("moreparams")
    > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"));

// Outputs the result that came from the appropriate statement type that was matched...
//   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block["stmt"] > AstFrom("stmt")
    | emptyStatement > null
    | variableDeclarationStatement["stmt"] > AstFrom("stmt")
    | assignmentStatement["stmt"] > AstFrom("stmt")
    | returnStatement["stmt"] > AstFrom("stmt");

// Outputs a 'Block' node whose children are the contained statements
block.Production = @openCurlyBrace + blockChildStatement.OnError(AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + @closeCurlyBrace.OnErrorContinue()
    > Ast("Block", AstChildrenFrom("stmt"));

// Forces a child statement to try to match via the CanMatch callback, unless the next token is a '}'
blockChildStatement.Production = statement["stmt"] > AstFrom("stmt");

// Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > null;

// Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = @var + @identifier["name"] + @semiColon.OnErrorContinue()
    > Ast("VariableDeclarationStatement", AstFrom("name"));

// Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = @identifier["varname"] + @assignment + expression["exp"].OnErrorContinue() + @semiColon.OnErrorContinue()
    > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"));

// Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = @return + expression["exp"].OnErrorContinue() + @semiColon.OnErrorContinue()
    > Ast("ReturnStatement", AstFrom("exp"));

// Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression["exp"] > AstFrom("exp");

// Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
//   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression["leftexp"] + ((@equality | @inequality).SetLabel("op") + equalityExpression["rightexp"].OnErrorContinue()).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
//   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression["leftexp"] + ((@addition | @subtraction).SetLabel("op") + additiveExpression["rightexp"].OnErrorContinue()).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
//   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression["leftexp"] + ((@multiplication | @division).SetLabel("op") + multiplicativeExpression["rightexp"].OnErrorContinue()).Optional()
    > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"));

// Outputs the result that came from the appropriate expression type that was matched...
//   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression["exp"] > AstFrom("exp")
    | functionAccessExpression["exp"] > AstFrom("exp")
    | simpleName["exp"] > AstFrom("exp")
    | parenthesizedExpression["exp"] > AstFrom("exp");

// Outputs the numeric value
numberExpression.Production = @number.ToTerm().ToProduction();

// Outputs the name value
simpleName.Production = @identifier.ToTerm().ToProduction();

// Outputs a 'FunctionAccessExpression' node with children:
//   1) The function name
//   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
//      if there are no arguments
functionAccessExpression.Production = @identifier["name"] + @openParenthesis + functionArgumentList["args"].Optional() + @closeParenthesis.OnErrorContinue()
    > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"));

// Outputs a 'FunctionArgumentList' node whose children are argument expressions...
//   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression["exp"] + (@comma + expression["exp"].OnErrorContinue() > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps")
    > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"));

// Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = @openParenthesis + expression["exp"] + @closeParenthesis.OnErrorContinue()
    > Ast("ParenthesizedExpression", AstFrom("exp"));
​' Outputs a root 'CompilationUnit' node that contains the children of the ZeroOrMore quantifier,
'   which is zero or more FunctionDeclarations...
' If an error occurs in a FunctionDeclaration we will call the AdvanceToDefaultState method,
'   that is defined below... it advances to the next 'Function' token and flags to continue parsing
Me.Root.Production = functionDeclaration.OnError(AdvanceToDefaultState).ZeroOrMore().SetLabel("decl") > Ast("CompilationUnit", AstChildrenFrom("decl"))

' Outputs a 'FunctionDeclaration' node with children:
'   1) The function declaration name value
'   2) A 'Parameters' node that contains each parameter name; or nothing gets inserted
'      if there are no parameters
'   3) The Block statement result
functionDeclaration.Production = [function] + identifier("name") + openParenthesis.OnErrorContinue() + functionParameterList("params").Optional() + closeParenthesis.OnErrorContinue() + block("block").OnErrorContinue() > Ast("FunctionDeclaration", AstFrom("name"), AstConditionalFrom("Parameters", "params"), AstFrom("block"))

' Outputs a 'FunctionParameterList' node whose children are parameter name values...
'   Is an excellent sample of how to build node for a delimited list
functionParameterList.Production = identifier("param") + (comma + identifier("param").OnErrorContinue() > AstFrom("param")).ZeroOrMore().SetLabel("moreparams") > Ast("FunctionParameterList", AstFrom("param"), AstChildrenFrom("moreparams"))

' Outputs the result that came from the appropriate statement type that was matched...
'   We don't want to wrap the results with a 'Statement' node so we use AstFrom
statement.Production = block("stmt") > AstFrom("stmt") Or emptyStatement > Nothing Or variableDeclarationStatement("stmt") > AstFrom("stmt") Or assignmentStatement("stmt") > AstFrom("stmt") Or returnStatement("stmt") > AstFrom("stmt")

' Outputs a 'Block' node whose children are the contained statements
block.Production = openCurlyBrace + blockChildStatement.OnError(AddressOf AdvanceToStatementOrBlockEnd).ZeroOrMore().SetLabel("stmt") + closeCurlyBrace.OnErrorContinue() > Ast("Block", AstChildrenFrom("stmt"))

' Forces a child statement to try to match via the CanMatch callback, unless the next token Is a '}'
blockChildStatement.Production = statement("stmt") > AstFrom("stmt")

' Don't output anything since we don't care about empty statements
emptyStatement.Production = semiColon > Nothing

' Outputs a 'VariableDeclarationStatement' node whose child is the variable name
variableDeclarationStatement.Production = var + identifier("name") + semiColon.OnErrorContinue() > Ast("VariableDeclarationStatement", AstFrom("name"))

' Outputs a 'AssignmentStatement' node whose children are the variable name and the assigned expression
assignmentStatement.Production = identifier("varname") + assignment + expression("exp").OnErrorContinue() + semiColon.OnErrorContinue() > Ast("AssignmentStatement", AstFrom("varname"), AstFrom("exp"))

' Outputs a 'ReturnStatement' node whose child is the expression to return
returnStatement.Production = [return] + expression("exp").OnErrorContinue() + semiColon.OnErrorContinue() > Ast("ReturnStatement", AstFrom("exp"))

' Outputs the resulting node from the EqualityExpression
expression.Production = equalityExpression("exp") > AstFrom("exp")

' Outputs the resulting node from the AdditiveExpression; or if an equality operator is found,
'   outputs a '==' or '!=' node whose children are the left and right child expressions of the operator
equalityExpression.Production = additiveExpression("leftexp") + ((equality Or inequality).SetLabel("op") + equalityExpression("rightexp").OnErrorContinue()).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the MultiplicativeExpression; or if an additive operator is found,
'   outputs a '+' or '-' node whose children are the left and right child expressions of the operator
additiveExpression.Production = multiplicativeExpression("leftexp") + ((addition Or subtraction).SetLabel("op") + additiveExpression("rightexp").OnErrorContinue()).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the resulting node from the PrimaryExpression; or if an multiplicative operator is found,
'   outputs a '*' or '/' node whose children are the left and right child expressions of the operator
multiplicativeExpression.Production = primaryExpression("leftexp") + ((multiplication Or division).SetLabel("op") + multiplicativeExpression("rightexp").OnErrorContinue()).Optional() > AstValueOfConditional(AstChildFrom("op"), AstFrom("leftexp"), AstFrom("rightexp"))

' Outputs the result that came from the appropriate expression type that was matched...
'   We don't want to wrap the results with a 'Expression' node so we use AstFrom
primaryExpression.Production = numberExpression("exp") > AstFrom("exp") Or functionAccessExpression("exp") > AstFrom("exp") Or simpleName("exp") > AstFrom("exp") Or parenthesizedExpression("exp") > AstFrom("exp")

' Outputs the numeric value
numberExpression.Production = number.ToTerm().ToProduction()

' Outputs the name value
simpleName.Production = identifier.ToTerm().ToProduction()

' Outputs a 'FunctionAccessExpression' node with children:
'   1) The function name
'   2) An 'Arguments' node that contains each argument name; or nothing gets inserted
'      if there are no arguments
functionAccessExpression.Production = identifier("name") + openParenthesis + functionArgumentList("args").Optional() + closeParenthesis.OnErrorContinue() > Ast("FunctionAccessExpression", AstFrom("name"), AstConditionalFrom("Arguments", "args"))

' Outputs a 'FunctionArgumentList' node whose children are argument expressions...
'   Is an excellent sample of how to build node for a delimited list
functionArgumentList.Production = expression("exp") + (comma + expression("exp").OnErrorContinue() > AstFrom("exp")).ZeroOrMore().SetLabel("moreexps") > Ast("FunctionArgumentList", AstFrom("exp"), AstChildrenFrom("moreexps"))

' Outputs a 'ParenthesizedExpression' node whose child is the contained expression
parenthesizedExpression.Production = openParenthesis + expression("exp") + closeParenthesis.OnErrorContinue() > Ast("ParenthesizedExpression", AstFrom("exp"))

Error Handling in Action

Now let’s see our error handling in action. We’ll use this input code:

Code Snippet
Copy
function Add(x, y {
    return x + y;
}

Note that there is a ) missing in the function declaration and a ')' expected error is reported. But we still get this complete AST, as if there were no syntax error:

Code Snippet
Copy
CompilationUnit[
    FunctionDeclaration[
        "Add"
        Parameters[
            "x"
            "y"
        ]
        Block[
            ReturnStatement[
                +[
                    SimpleName[
                        "x"
                    ]
                    SimpleName[
                        "y"
                    ]
                ]
            ]
        ]
    ]
]

Let’s create some more complex syntax errors now:

Code Snippet
Copy
invalid
function Add(x,) {
    return x +
}

Here we have three syntax errors:

  1. 'function' expected that highlights the invalid word
  2. Identifier expected that highlights the )
  3. ';' expected that highlights the }

Even with three syntax errors, we still get an AST:

Code Snippet
Copy
CompilationUnit[
    Error[]
    FunctionDeclaration[
        "Add"
        Parameters[
            "x"
        ]
        Block[
            ReturnStatement[
                SimpleName[
                    "x"
                ]
            ]
        ]
    ]
]

You’ll note that an Error node was inserted as the first child of the CompilationUnit node. An Error node is inserted when a non-terminal fails to match but is told by error callbacks to continue on as is the case with the error handling we added.

Conclusion

In this topic, we've seen how to enhance a grammar to properly support robust error handling. Really, this is about the last thing you generally need to do when designing a grammar.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Custom Data

LL(*) Parser Framework
Custom Data

The IParserState object passed to each callback in the parser framework has a property on it where custom data can be tracked and updated throughout each parsing operation.

Anything can be placed in this custom data store. It could be used to help perform semantic validation, construct name tables, and more.

This topic contains these sections:

  • Usage Scenarios
  • Bad Ways to Track Custom Data
  • Initializing Custom Data
  • Updating the Custom Data While Parsing
  • Performing Semantic Validation with Custom Data
  • Returning and Consuming the Custom Data

Usage Scenarios

Although there are many things that can be tracked in custom data, here are a couple examples.

XML Element Hierarchy Validation

In the advanced XML syntax language in the Web Languages Add-on we maintain a stack of elements in this custom data. Any time we enter a new element, we push it on the stack. When we exit an element we pop it off. If the end tag name doesn't match the start tag name, we can intelligently report errors.

Name Tables

Many parser implementations may wish to construct a name table. The table could be stored in the custom data and then updated as a new type or variable name is encountered.

Bad Ways to Track Custom Data

One way you may be tempted to track custom data during a parse is to put a member variable on your grammar class. You would initialize it at some point and updated it in your callbacks.

The problem is that if more than one document is using the language, the grammar is potentially operating on multiple documents at the same time. This of course means that each parser working on the documents could be modifying the member variable while the other is working with the variable, thus leading to invalid data and possible exceptions.

The use of member variables is not recommended and for this reason, we recommend the use of techniques described below to store and update custom data instead.

Initializing Custom Data

The IParserState.CustomData property is the right place to store custom data for a parsing operation since it and its containing IParserState are specific to each parse request. The IParserState object for a parsing operation is created interally by the LL(*) Parser Framework and then is passed to each callback in your grammar. This begs the question, how can the custom data be initialized at the parsing operation start?

We recommend initializing the custom data in an initialize callback of the root production since that is the very first part of your grammar to be entered.

This example show how to add initialize and complete callbacks to the root production. Note that ellipses (...) indicate where the normal production terms and tree constructors would go.

C#
VB
Copy
​this.Root.Production = (...).OnInitialize(CompilationUnitInitialize).OnComplete(CompilationUnitComplete);
​Me.Root.Production = (...).OnInitialize(AddressOf CompilationUnitInitialize).OnComplete(AddressOf CompilationUnitComplete)

A CompilationUnitInitialize implementation could look like this, where MyParserContext is a class with various properties to help track custom data for this particular parsing operation:

C#
VB
Copy
​private void CompilationUnitInitialize(IParserState state) {
    // Initialize the state's custom data with a parser context
    state.CustomData = new MyParserContext();
}
​Private Sub CompilationUnitInitialize(ByVal state As IParserState)
    ' Initialize the state's custom data with a parser context
    state.CustomData = New MyParserContext()
End Sub

Updating the Custom Data While Parsing

Any callback has access to the IParserState.CustomData property, and therefore can access the object created during initialization.

Properties on the object can be updated as needed. If the custom data is tracking a name table, any variable declarations should add an entry into the name table.

A stack property can be added to the custom data object so that you can track scopes entered/exited as code is parsed. That way you can know what sort of scope you are in when each callback is called. A stack item would be pushed onto the stack by you from a callback whenever a scope is entered, and then popped when the scope is existed.

These are just a couple ideas. Really the custom data can be used to track anything while the parsing operation is active.

Performing Semantic Validation with Custom Data

We've seen how to initialize the custom data for a parsing operation. The corresponding complete callback for the root production is an ideal place to examine the custom data to see if any further syntax or semantic errors should be reported.

For instance, in XML you may wish to report if not all tags were closed properly, assuming the custom data had data in it to indicate this scenario.

A CompilationUnitComplete implementation could look like this:

C#
VB
Copy
​private void CompilationUnitComplete(IParserState state) {
    MyParserContext context = state.CustomData as MyParserContext;
    if (context != null) {
        // Report any semantic errors here with state.ReportError() based on data in the parser context
    }
}
​Private Sub CompilationUnitComplete(ByVal state As IParserState)
    Dim context As MyParserContext = TryCast(state.CustomData, MyParserContext)
    If context IsNot Nothing Then
        ' Report any semantic errors here with state.ReportError() based on data in the parser context
    End If
End Sub

Returning and Consuming the Custom Data

Since the LL(*) Parser Framework is being used, the IParser for the language should inherit LLParserBase. This base class has a virtual CreateParseData method that creates the IParseData returned by the parser.

By creating a language-specific IParseData object, you can get data from your CustomData object, store it in the IParseData, and it will be returned to the document. Thus it is available to consume by other language services such as IntelliPrompt since it is part of the parse data.

This code sample shows a possible implementation of a CreateParseData override that moves data from the MyParserContext object to the MyParseData object that is returned to the document:

C#
VB
Copy
​protected override IParseData CreateParseData(IParseRequest request, IParserState state) {
    if (request == null)
        throw new ArgumentNullException("request");
    if (state == null)
        throw new ArgumentNullException("state");

    MyParseData parseData = new MyParseData();

    // Initialize
    this.InitializeParseData(parseData, state);

    // Pass on parser context data
    MyParserContext context = state.CustomData as MyParserContext;
    if (context != null)
        parseData.SomeData = context.SomeData;

    return parseData;
}
​Protected Overrides Function CreateParseData(ByVal request As IParseRequest, ByVal state As IParserState) As IParseData
    If request Is Nothing Then
        Throw New ArgumentNullException("request")
    End If
    If state Is Nothing Then
        Throw New ArgumentNullException("state")
    End If

    Dim parseData As New MyParseData()

    ' Initialize
    Me.InitializeParseData(parseData, state)

    ' Pass on parser context data
    Dim context As MyParserContext = TryCast(state.CustomData, MyParserContext)
    If context IsNot Nothing Then
        parseData.SomeData = context.SomeData
    End If

    Return parseData
End Function

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

.NET Languages Add-on
Overview

The .NET Languages Add-on is an optional premium extra for SyntaxEditor customers that includes advanced implementations of C# and Visual Basic syntax languages.

The add-on has been built from the ground up by Actipro to take advantage of best practices for syntax language design. While it is already packed with innovative features, the design is completely extensible and can be enhanced or modified as much as you like.

Note Note
Be sure to read through each language's "Getting Started" topics and follow each step in them exactly to ensure that the add-on's features will operate properly. While it only takes several lines of code to get up and running, those lines are very important and may prevent the add-on from working correctly if they are not present.

Although the add-on is distributed and demoed with the Universal Windows controls, it is sold separately.

This topic contains these sections:

  • Assemblies
  • Reflection Data
  • Assembly Documentation
  • Resolver
  • C# Language
  • Visual Basic Language
  • Troubleshooting

Assemblies

Assemblies are objects implementing IAssembly that can track reflection data from binary .NET assemblies or source code files. This reflection data is then used by other add-on features such as the resolver and automated IntelliPrompt. It is critical to configure assemblies correctly to use the advanced features offered by this add-on.

See the Assemblies topic for more information.

Reflection Data

A large object model is included in the add-on for managing reflection data for both .NET assemblies as well as source code files. All of this data, which consists of everything from namespaces down to member parameters, is stored in a common set of interfaces so that it may easily be queried and used by features like the resolver, thus helping to populate automated IntelliPrompt.

See the Reflection Data topic for more information.

Assembly Documentation

Each IAssembly is able to provide documentation for the types and members that it contains. This documentation generally originates from XML documentation comments.

See the Assembly Documentation topic for more information.

Resolver

The resolver is an object that examines an expression and its containing contextual information. It uses language-specific rules to investigate what is returned by the expression, such as a namespace, type, member, variable, etc. This information is often passed to automated IntelliPrompt for display.

See the Resolver topic for more information.

C# Language

The advanced C# syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

See the C# Language topics for more information.

Visual Basic Language

The advanced Visual Basic syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

See the Visual Basic Language topics for more information.

Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

See the Troubleshooting topics for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Assemblies

.NET Languages Add-on
Assemblies

Assemblies are objects implementing IAssembly that can track reflection data from binary .NET assemblies or source code files. This reflection data is then used by other add-on features such as the resolver and automated IntelliPrompt. It is critical to configure assemblies correctly to use the advanced features offered by this add-on.

An ambient assembly repository can be installed to manage reuse of binary assemblies in scenarios where multiple project assemblies are active, and can also cache assembly data to improve future load performance.

This topic contains these sections:

  • What is an Assembly?
  • Project Assemblies
  • Registering with a Syntax Language
  • Managing Assembly References
  • Assembly Reference Cleanup
  • Performance Impact of Adding References
  • Source Files
  • Binary Assemblies
  • Assembly Repositories
  • The FileBasedAssemblyRepository Class
  • Ambient Assembly Repository
  • Loading Pre-Defined Binary Assembly Cache Data

What is an Assembly?

There are two main types of assemblies: project assemblies and binary assemblies.

Project assemblies are similar in concept to a Visual Studio project in that they can track reflection data for source code files and can maintain a list of other IAssembly references related to the project. These references can be to other project assemblies (similar to Visual Studio when a solution hosts multiple projects that are dependent upon each other) or can be to binary assemblies.

Binary assemblies store reflection data for pre-compiled binary .dll files such as mscorlib.dll.

Since IAssembly and the rest of the types used for reflection in this add-on are all implemented as interfaces, it is possible to create other custom assembly types when there are special need scenarios.

All assemblies have a name, provide a flat list of namespaces defined within type, and provide access to a namespace hierarchy that is rooted at the global namespace. Each namespace can contain other nested namespaces or types, types can contain members, and so on. This design is described in more detail in the Reflection topic.

Project Assemblies

Project assemblies, classes that implement IProjectAssembly, can track source code files and references to other assemblies. They also can return an IResolver class that is used to resolve expressions to a namespace, type, member, etc.

Different project assembly types are available for each language, since there are some language-specific rules that need to be followed by the resolver. For instance, a C# resolver should ignore standard modules, while a VB resolver should handle standard modules and use case insensitive name matching.

The built-in project assembly types are:

  • CSharpProjectAssembly - for C# languages
  • VBProjectAssembly - for Visual Basic languages

This diagram shows the general structure of a project assembly:

In the diagram, there are three source files loaded: Foo1.cs, Foo2.cs, and Bar.cs. The first two files contain a partial class named Foo, so the two class declarations are merged together in the reflection data tracked by the project assembly. The last file contains a Bar class along with a nested type named Nested. The diagram also shows that there are references made to other assemblies such as mscorlib.dll, System.dll, etc. All of this data is tracked live and can be updated on-the-fly as code changes or references need to be added/removed.

When the resolver executes, it uses all of the above information along with language-specific rules to try and find the best match for a type, member, etc., even if that match is in a referenced assembly.

Registering with a Syntax Language

Any object that implements IProjectAssembly, such as the built-in CSharpProjectAssembly and VBProjectAssembly classes, can be associated with a syntax language by registering it as an IProjectAssembly service on the language.

Note Note
Due to language-specific rules that project assemblies use, only register CSharpProjectAssembly instances on a CSharpSyntaxLanguage, and VBProjectAssembly instances on a VBSyntaxLanguage.

Appropriate default IProjectAssembly instances are pre-registered on the built-in C#/VB syntax languages but need to be configured with source files and/or assembly references to be useful. Alternatively, you can create and configure a new project assembly instance and then register it on the language.

This code creates a new C# project assembly and registers it with the CSharpSyntaxLanguage that is already declared in the language variable:

C#
VB
Copy
​CSharpProjectAssembly project = new CSharpProjectAssembly("Sample");
language.RegisterProjectAssembly(project);
​Dim project As New CSharpProjectAssembly("Sample")
language.RegisterProjectAssembly(project)
Then as the page is loaded, assembly references are added asynchronously (see following sections for more information on why),
C#
VB
Copy
​private async void OnLoaded(object sender, RoutedEventArgs e) {
    await project.AssemblyReferences.AddMsCorLibAsync();
    await project.AssemblyReferences.AddAsync("System");
}
​Private Async Sub OnLoaded(ByVal sender As Object, ByVal e As RoutedEventArgs)
    Await project.AssemblyReferences.AddMsCorLibAsync()
    Await project.AssemblyReferences.AddAsync("System")
End Sub

Note Note
The DotNetSyntaxLanguageExtensions.RegisterProjectAssembly method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.DotNet namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Managing Assembly References

For the resolver and automated IntelliPrompt features to work properly, the appropriate assembly references must be added to the project assembly. At a minimum, a reference to mscorlib.dll should always be added since that is where native types like Int32, String, etc. are defined. The resolver only knows about the assemblies that are referenced by the project, so if a reference is made to a type Foo but there is no source file or referenced assembly that defines Foo, the resolution of that reference will fail.

Always think about project assemblies in terms of being equivalient to Visual Studio projects. If an assembly reference would be needed to support a type or member in code, then a reference to the assembly should be made in the project assembly.

There are numerous methods and overloads for adding a reference to a project assembly. These methods are located on the IProjectAssembly.AssemblyReferences collection, which also allows enumeration and removal of references.

These methods can add references to a project assembly:

Member | Description
Add(IAssembly) Method | Adds a new reference for the specified IAssembly, which can be an already-loaded project or binary assembly.
AddAsync(Assembly) Method | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
AddAsync(Assembly, IAssemblyName) Method | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
AddAsync(string) Method | Adds a new reference to an IBinaryAssembly for the specified assembly name. While using the simple assembly name may work in some simple cases (such as System), it is highly recommended to pass the fully-qualified assembly name to this method (such as System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089) since the probing code will have a better chance of successfully finding it.
AddMsCorLibAsync() Method | Adds a new reference to an IBinaryAssembly for mscorlib. This should always be added.

This code shows how to add assembly references to an IProjectAssembly in the project variable using a variety of methods:

C#
VB
Copy
​// Add mscorlib (should always add at a minimum)
await project.AssemblyReferences.AddMsCorLibAsync();

// Add 'System.dll' via a direct Assembly
await project.AssemblyReferences.AddAsync(typeof(System.Uri).Assembly);

// Add 'System.Core.dll' via its full name
await project.AssemblyReferences.AddAsync("System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089");

// Add another IProjectAssembly that was previously loaded elsewhere
project.AssemblyReferences.Add(anotherProject);
​' Add mscorlib (should always add at a minimum)
Await project.AssemblyReferences.AddMsCorLibAsync()

' Add 'System.dll' via a direct Assembly
Await project.AssemblyReferences.AddAsync(GetType(System.Uri).Assembly)

' Add 'System.Core.dll' via its full name
Await project.AssemblyReferences.AddAsync("System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")

' Add another IProjectAssembly that was previously loaded elsewhere
project.AssemblyReferences.Add(anotherProject)

Assembly Reference Cleanup

When an IProjectAssembly is no longer needed in your application, it is a good idea to its AssemblyReferences collection. When an assembly repository is used (described later in this topic), it will often track the reference count of an assembly. While that reference count remains above zero, it will track data for the assembly. When the reference count returns to zero, it will close up any open cache files or other resources that it may have open for the assembly.

Thus it is very important to clear the assembly references collection on a project assembly prior to the project assembly going out of scope, so that memory and resources for its referenced assemblies can be reclaimed when appropriate.

Performance Impact of Adding References

When a new IBinaryAssembly needs to be created using reflection on a System.Reflection.Assembly (regardless of if the Assembly is passed directly or via a full name or file path), there is processing that must take place to gather the data needed to construct the resulting IBinaryAssembly. This processing uses .NET reflection and thus can take some time to complete. For instance, if 20 new assembly references are being added to a project assembly, it might take several seconds to load.

This is the reason why in the sample code earlier in this topic, we used a System.ComponentModel.BackgroundWorker to execute the loading code. That allows the code to execute asynchronously, thus preventing the UI from slowing down or being blocked. .NET 4.0 and later includes other features such as tasks that can be used in a similar fashion instead.

Note that there are features built in to cache the IBinaryAssembly data constructed from an Assembly. These features are part of the "Assembly Repositories" object model described later in this topic, and can help speed up assembly loading by ten times or more when properly used.

Source Files

Source files, represented by the ISourceFile interface, have a string-based key and a collection of ITypeDefinition objects that are defined in the file.

Source file objects can be added to and removed from the IProjectAssembly.SourceFiles collection. This is similar in concept to the adding/removing of code files to a Visual Studio project. When a source file is included in a project, its types, members, etc. can be used by the resolver.

Automatic Source File Creation by Documents

As long as the following conditions are met, documents will automatically update a project assembly whenever the document is altered (such as when typing is performed in a SyntaxEditor):

  1. The document must have a ITextDocument.FileName property value set. The value of this property is used as the ISourceFile.Key. No source file can be created without it as a key.
  2. The document is using a .NET syntax language (CSharpSyntaxLanguage or VBSyntaxLanguage).
  3. The .NET syntax language in use must have an IProjectAssembly service registered. The ISourceFile created for the document will be added to this project assembly.

Behind the scenes, the .NET syntax languages watch any attached document for ICodeDocument.ParseData changes. When they detect a change, they translate the document's AST to ITypeDefinition instances, and an ISourceFile instance is created to contain the type definitions with the document's FileName as its key. The ISourceFile is added to the project assembly and replaces any prior source files with the same key.

Programmatically Adding Source Files

There are several ways to programmatically append source files to a project assembly, all available from the IProjectAssembly.SourceFiles collection. One way is to add an ISourceFile instance directly with the Add method. Here are the other ways:

Member Description
Add Method

Adds an ISourceFile for the specified AST CompilationUnit to the collection.

This method allows the source file key to be specified, and it translates the compilation unit's contents to a set of ITypeDefinition objects.

QueueCode Method

Queues parsing for the specified source code using an indicated language, and adds an ISourceFile for the result.

The parsing operation will occur in a worker thread and will not block the calling thread as long as an ambient parse request dispatcher is set up.

QueueFileAsync Method

Queues parsing for the specified file using an indicated language, and adds an ISourceFile for the result.

The parsing operation will occur in a worker thread and will not block the calling thread as long as an ambient parse request dispatcher is set up.

This code shows how to queue up parsing to create source files for a project assembly defined in project:

C#
VB
Copy
​project.SourceFiles.QueueCode(cSharpSyntaxLanguage, "MyFile1.cs", "class Foo { public void Bar() {} }");
await project.SourceFiles.QueueFileAsync(cSharpSyntaxLanguage, @"C:\MyFile2.cs");
​project.SourceFiles.QueueCode(cSharpSyntaxLanguage, "MyFile1.cs", "class Foo { public void Bar() {} }")
Await project.SourceFiles.QueueFileAsync(cSharpSyntaxLanguage, "C:\MyFile2.cs")

Again, make sure an ambient parse request dispatcher is set up so parsing occurs in a worker thread.

Programmatic Source File Creation

The SourceFile class implements ISourceFile and can be used to programmatically add a set of ITypeDefinition objects to a project assembly.

Binary Assemblies

Binary assemblies, represented by the IBinaryAssembly interface, store reflection data for pre-compiled binary .dll files such as mscorlib.dll. They can be created for any System.Reflection.Assembly instance, one in memory or one on disk.

Similar to project assemblies, binary assemblies also have their own references to other assemblies. However in binary assemblies, the references are more informational.

IBinaryAssembly instances can be created for an Assembly using any of the methods described in the 'Managing Assembly References' section earlier in this topic. Similar loading methods are available on IAssemblyRepository that can be used to load an IBinaryAssembly without adding it as a reference to a project. The assembly reference add methods internally call these various IAssemblyRepository load methods.

Assembly Repositories

Assembly repositories provide a way to store loaded binary assemblies and possibly cache their data so that it can be retrieved much faster in the future. They are represented by the IAssemblyRepository interface and the FileBasedAssemblyRepository class provides the implementation used by most applications.

Assembly repositories have several LoadAsync methods for loading an IBinaryAssembly from a reflection Assembly. If the assembly repository implementation supports caching, the loaded assembly data is cached from these load method calls. The various methods for adding references to project assemblies mentioned in previous sections call these load methods.

Pruning the Cache

The assembly repository's cache may write to files or some other mechanism depending on the implementation. Regardless it is important to call the IAssemblyRepository.PruneCacheAsync method to prune invalid data from the cache upon application shutdown.

Note Note
Since assemblies can change over time (when a .dll is recompiled or deleted), it is important to make sure the cache removes data that is no longer valid via a call to IAssemblyRepository.PruneCacheAsync when the application is shut down.

Reference Tracking

The default implementation of IProjectAssembly will call the IAssemblyRepository.Add method when a binary assembly is added as a reference. The assembly repository keeps a pointer to the binary assembly and tracks a reference count for it. Likewise, the IAssemblyRepository.Remove method is called when a binary assembly is removed as a project assembly reference. If the reference count for the binary assembly reaches zero, the assembly repository will discard its pointer to the assembly.

The FileBasedAssemblyRepository Class

The FileBasedAssemblyRepository is the main IAssemblyRepository implementation provided with the add-on. It supports caching of assembly data out to files in a folder, as long as the application's security allows for write access to the folder specified in its cache path. This often requires full/elevated trust by the application. These cache files can be reloaded in the next application session, dramatically reducing binary assembly load times.

Use of this repository type as the ambient assembly repository is recommended since its caching mechanism can load its cached assembly data for an assembly about ten times faster than creating a new IBinaryAssembly via the use of .NET reflection.

If no cache path is set on the repository then it will not attempt to save or load any assembly data cache files. However it still will perform reference tracking, which significantly helps performance when multiple project assemblies are used.

This table illustrates the preferred catch path settings for FileBasedAssemblyRepository based on the type of application and its trust level.

Ambient Assembly Repository

There are often scenarios where multiple project assemblies are used at the same time. This is similar to scenarios in Visual Studio when a solution has multiple projects open. Each one of these projects probably references some of the same binary assemblies, like mscorlib.

By using an ambient assembly repository, the loaded binary assembly instances are reused among the various project assemblies, thus saving on memory. As mentioned in the previous section, assembly repositories also are capable of caching data, thus sometimes improving loading speeds by ten times or more.

Important Note Important Note
By default, no ambient IAssemblyRepository is installed meaning that more than one project assembly will use unncessary extra memory when referencing various binary assemblies, since those instances will not be shared among the project assemblies. Also, no caching will occur for binary assemblies if there is no ambient assembly repository, thus affecting application performance when adding references to project assemblies.

This code is executed at application startup and creates a FileBasedAssemblyRepository for use as the ambient assembly repository. Note that it uses an application-specific data folder path that you should update as appropriate for your application.

C#
VB
Copy
​string appDataPath = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Assembly Repository");
AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(appDataPath);
​Dim appDataPath As String = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Assembly Repository")
AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(appDataPath)

At application shutdown, this code can be used to prune cache data that is no longer valid.

C#
VB
Copy
​var repository = AmbientAssemblyRepositoryProvider.Repository;
if (repository != null)
    await repository.PruneCacheAsync();
​Dim repository = AmbientAssemblyRepositoryProvider.Repository
If repository IsNot Nothing Then
    Await repository.PruneCacheAsync()
End If

Loading Pre-Defined Binary Assembly Cache Data

Many of the add reference methods described above in the "Managing Assembly References" section will load the assemblies for the current platform version. Say that your application is a Silverlight application and you call the IProjectAssemblyReferenceCollection.AddMsCorLibAsync method. In this case, the Silverlight MsCorLib assembly will be added.

But what if you are developing a Silverlight application that is for a .NET 2.0 WinForms development IDE? First, Silverlight's MsCorLib has slightly different API than .NET 2.0's MsCorLib does. Second, you can't load .NET 2.0 assemblies into Silverlight applications for reflection. Luckily the .NET Languages Add-on has a mechanism to support this scenario.

When using the FileBasedAssemblyRepository as the ambient assembly repository, as described in previous sections, you can set a cache path. After loading the appropriate assembly once, you can go to this cache folder and find the related cache file for the assembly.

The following code is a snippet you can paste in a new Visual Studio WPF application project (we'll assume it's called 'WpfApplication1'). In the application project, add references to the .NET Languages Add-on and SyntaxEditor assemblies. The WPF version of these Actipro assemblies can be found in the Language Designer tool's folder, since it uses them. Then paste this code in your application startup section:

C#
VB
Copy
​var appPath = Directory.GetCurrentDirectory();
var cachePath = Path.Combine(appPath, "Cache");
AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(cachePath);
var project = new CSharpProjectAssembly("Loader");

// Customize these based on which .NET assemblies you wish to load
project.AssemblyReferences.AddMsCorLib();
project.AssemblyReferences.AddFrom(Path.Combine(appPath, "WpfApplication1.exe"));
​Dim appPath = Directory.GetCurrentDirectory()
Dim cachePath = Path.Combine(appPath, "Cache")
AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(cachePath)
Dim project = New CSharpProjectAssembly("Loader")

' Customize these based on which .NET assemblies you wish to load
project.AssemblyReferences.AddMsCorLib()
project.AssemblyReferences.AddFrom(Path.Combine(appPath, "WpfApplication1.exe"))

After running the application, in the 'bin/Debug' folder there should now be a 'Cache' folder. That folder will contain files named something like 'mscorlib-v2.0-d7ffa534.Reflection.dat'. Each '...Reflection.dat' file is the reflection data file for an assembly.

If you copy a '...Reflection.dat' file to your application and make it accessible as a Stream (perhaps by making it an Embedded Resource), it can be loaded to create an IBinaryAssembly instance, even if it was created on a completely different platform (WPF vs. Silverlight, etc.).

This code creates a BinaryAssemblySerializer and loads an IBinaryAssembly from a Stream located in the resourceStreamName resource path.

C#
VB
Copy
​var serializer = new BinaryAssemblySerializer();
using (var stream = Assembly.GetExecutingAssembly().GetManifestResourceStream(resourceStreamName)) {
    var assembly = serializer.LoadFromStream(null, stream);
    if (assembly != null)
        project.AssemblyReferences.Add(assembly);
}
​Dim serializer = New BinaryAssemblySerializer()
Using stream = System.Reflection.Assembly.GetExecutingAssembly().GetManifestResourceStream(resourceStreamName)
    Dim [assembly] = serializer.LoadFromStream(Nothing, stream)
    If [assembly] IsNot Nothing Then
        project.AssemblyReferences.Add([assembly])
    End If
End Using

Note Note
Assembly cache files all contain version numbers. While these version numbers generally remain constant, they are incremented when there are additions/changes made to the serialized data so that it can be properly loaded. Trying to load a cache file with an older version into a newer BinaryAssemblySerializer will result in no IBinaryAssembly being created. The Language Designer's .NET Languages Add-on assemblies should always be in sync with this version in regards to codebases. So for Silverlight and WinRT XAML controls, it is best to use the Language Designer's WPF assemblies to generate the reflection data files.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Reflection Data

.NET Languages Add-on
Reflection Data

A large object model is included in the add-on for managing reflection data for both .NET assemblies as well as source code files. All of this data, which consists of everything from namespaces down to member parameters, is stored in a common set of interfaces so that it may easily be queried and used by features like the resolver, thus helping to populate automated IntelliPrompt.

This topic contains these sections:

  • Assemblies
  • Namespaces
  • Types
  • Members
  • Parameters
  • LINQ Queryable

Assemblies

Similar to real .NET assemblies, assemblies in this add-on, represented by the IAssembly interface, store information about contained types and members. Assemblies can be created for real pre-compiled .NET assemblies, or can be like Visual Studio projects where they are containers of source code files with references to other assemblies. Assemblies provide access to type/member information via namespaces.

Note Note
See the Assemblies topic for detailed information on the types of assemblies and how to load them.

Assembly Names

While each IAssembly has a Name property that returns its simple name, there also is a GetAssemblyName method that returns an IAssemblyName object. This object stores the simple name as well as some other information such as version. It supports comparison using the Equals method.

Namespaces Property

The IAssembly.Namespaces collection provides a flat list of the namespaces defined in the assembly. Each item in the collection is a INamespaceDefinition. The key of the collection used for the indexer is the full name of the namespace.

This code accesses the INamespaceDefinition for System.Linq within the IAssembly in the assembly variable:

C#
VB
Copy
​var namespaceDef = assembly.Namespaces["System.Linq", true];
​Dim namespaceDef = assembly.Namespaces("System.Linq", True)

GlobalNamespace Property

The IAssembly.GlobalNamespace property provides hierarchical access to the tree of namespaces defined in the assembly. The INamespaceDefinition returned by GlobalNamespace is always the global namespace whose name is an empty string.

This code accesses the global (root) INamespaceDefinition within the IAssembly in the assembly variable:

C#
VB
Copy
​var namespaceDef = assembly.GlobalNamespace;
​Dim namespaceDef = assembly.GlobalNamespace

Namespaces

Namespaces defined within an assembly are represented by the INamespaceDefinition interface. As described above, the main entry point to these objects is via IAssembly.Namespaces or IAssembly.GlobalNamespace.

Each namespace definition within an assembly has a unique full name (e.g. System.Collections.Generic) and contains all the types that are defined within it. The INamespaceDefinition.FullName property returns the namespace's full name, and its Name property returns the simple name (last identifier of the full name).

Nested Namespaces

Namespaces often contain other nested namespaces. For instance the global namespace whose name is an empty string often contains a nested namespace named System. These nested namespaces are available from the INamespaceDefinition.Children collection, which is indexed using the simple names of each nested namespace.

This code accesses the INamespaceDefinition for System within the IAssembly in the assembly variable:

C#
VB
Copy
​var namespaceDef = assembly.GlobalNamespace.Children["System", true];
​Dim namespaceDef = assembly.GlobalNamespace.Children("System", True)

Types

Namespaces contain zero or more ITypeDefinition object that specify the types defined within the namespace.

This code accesses the ITypeDefinition for System.Int32 within the IAssembly in the assembly variable:

C#
VB
Copy
​var typeDef = assembly.Namespaces["System", true].Types["Int32", true];
​Dim typeDef = assembly.Namespaces("System", True).Types("Int32", True)

Other Collections

Namespace definitions provide access to a couple other helper collections.

First is the INamespaceDefinition.ExtensionMethods property. This property is a collection of ITypeMemberDefinition objects where each member definition is for an extension method defined on a type which is contained by the namespace.

Second is the INamespaceDefinition.StandardModules property. This property is a collection of ITypeDefinition objects where each type definition is a standard module (only used by VB). The collection of standard modules is effectively a subset of the Types collection.

Types

There are three main categories of types used in the reflection data.

An ITypeReference is simply a pointer to another type. The referenced type may be defined in the same assembly or within another. A resolver can examine its qualified name and the general context in which it is located, and uses that information to try and convert the type reference to a type definition.

An ITypeDefinition is the definition of a type within an assembly. The ITypeDefinition interface inherits ITypeReference. Type definitions can potentially define nested types and members.

A type definition contains all sorts of information about a type, such as its access (public, private, etc.), its kind (class, structure, etc.), its namespace, and whether it is abstract, sealed, etc. It has a NestedTypes collection that lists all of the nested type definitions within the type. Its TypeParameters and TypeArguments collections indicate the generic parameters and any related generic arguments (if a generic type has been constructed). The Members collection contains the list of members within the type.

This code accesses the ITypeMemberDefinition overloads for ToString within the ITypeDefinition in the typeDef variable:

C#
VB
Copy
​var memberDefs = typeDef.Members["ToString", true];
​Dim memberDefs = typeDef.Members("ToString", True)

An ITypeParameter represents a generic parameter for a generic type definition or a generic method. The ITypeParameter interface inherits ITypeDefinition. Type parameters include several properties that describe their constraints and variance (covariant/contravariant) modifiers. The list of type constraints is indicated via the BaseTypes collection.

Members

Type members, represented by the ITypeMemberDefinition interface, can be a method, property, field, operator, etc. A type member stores information such as its access (public, private, etc.), kind (method, property, etc.), return type (if any), parameters (if any), type parameters (for generic methods), and other flag properties indicating whether it is abstract, static, etc.

This code accesses the first IParameterDefinition within the ITypeMemberDefinition in the memberDef variable:

C#
VB
Copy
​var firstParamDef = memberDef.Parameters[0];
​Dim firstParamDef = memberDef.Parameters(0)

Parameters

Parameter definitions, represented by the IParameterDefinition interface, store information about parameters in members, such as their name, type, whether they are optional, by-reference, are a parameter array, etc.

LINQ Queryable

Reflection data is fully LINQ queryable. For instance, this query looks in the IProjectAssembly for an ITypeDefinition named Foo:

C#
VB
Copy
​var fooType = (from ns in project.Namespaces
    let types = ns.Types["Foo", true]
    where types != null
    select types).FirstOrDefault();
​Dim fooType = ( _
    From ns In project.Namespaces _
    Let types = ns.Types("Foo", False) _
    Where types IsNot Nothing _
    Select types).FirstOrDefault()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Assembly Documentation

.NET Languages Add-on
Assembly Documentation

Each IAssembly is able to provide documentation for the types and members that it contains. This documentation generally originates from XML documentation comments.

This topic contains these sections:

  • Assembly Documentation
  • Project Assembly Documentation
  • Binary Assembly Documentation
  • Manually Loading Binary Assembly Documentation
  • Custom Assembly Documentation

Assembly Documentation

The IAssembly.Documentation property provides access to the assembly's documentation. It returns an object of type IAssemblyDocumentation that has GetDocumentationAsync method overloads, capable of returning an IDocumentationProvider for a specific type or member.

The IDocumentationProvider makes it easy to get the documentation summary, type parameter info, or parameter info for the target type/member. This data is generally used in IntelliPrompt display.

Project Assembly Documentation

Project assemblies, or types implementing IProjectAssembly, automatically create a special IAssemblyDocumentation instance that provides the documentation for types/members defined in the project's source files. This class is wired up by default onto the IProjectAssembly.Documentation property.

Binary Assembly Documentation

Binary assemblies, or types implementing IBinaryAssembly, cannot automatically attempt to probe and look for .xml documentation files due to security sandboxing in Universal Windows. That being said, if .xml documentation files are accessible in certain folder paths, they can be manually loaded per the information in the following section.

Manually Loading Binary Assembly Documentation

For scenarios where the automatic probing for .xml documentation comment files was unsuccessful (generally because of security restrictions or the files simply not being in a known location), but you know where the .xml file is located, it is possible to manually create a FileAssemblyDocumentation instance and pass the file path in its constructor. Then set that instance to the IBinaryAssembly.Documentation property.

As long as security permits access to the path, the documentation will be loaded properly as needed.

Custom Assembly Documentation

Custom IAssemblyDocumentation implementations can also be built if you would prefer to access type/member documentation in another fashion (web service, etc.).

For instance, a class inheriting StreamAssemblyDocumentationBase could be made to access .xml documentation files stored as a manifest resource in the application's .exe. In this case, simply override the GetStreamAsync method to return a Stream to the .xml file, and the base class will do the rest.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Resolver

.NET Languages Add-on
Resolver

The resolver is an object that examines an expression and its containing contextual information. It uses language-specific rules to investigate what is returned by the expression, such as a namespace, type, member, variable, etc. This information is often passed to automated IntelliPrompt for display.

This topic contains these sections:

  • Obtaining a Resolver
  • Creating a Request
  • Performing a Resolve Operation
  • A Resolve Sample
  • Enumerating Members for an Offset

Obtaining a Resolver

The resolver for a language, represented by the IResolver interface, can be obtained from the IProjectAssembly.Resolver property. As described in the Assemblies topic, an IProjectAssembly is registered as a service on the .NET syntax languages in this add-on.

Creating a Request

The first step in using the resolver is to create an IResolverRequest. An implementation of this interface is in the ResolverRequest This class can accept an AST Expression or a qualified name as parameters into its constructor. The argument passed in will be what is resolved by the resolver.

The request's IResolverRequest.Context property can be set to an IDotNetContext object to provide contextual information about the request. This is very useful information for the resolver. Say that a simple name foo is trying to be resolved. If the context of the request occurs within a method, the resolver will first look for variables named foo within the method, then parameters, etc. Context objects can be retrieved via the information in the C# Context and Visual Basic Context topics.

Performing a Resolve Operation

The resolver has a Resolve method that accepts an IResolverRequest parameter and returns an IResolverResultSet.

The result set consists of zero or more IResolverResult objects. There can be more than one result in the set if there is ambiguity of the resolution result, such as when there are multiple overloads of a method that can match the expression to resolve. In this scenario, the results are sorted by which match best. So the first result is always the best match.

Each IResolverResult includes a string Name property and a Type property that returns the resulting ITypeDefinition of the result if one is available (not applicable for namespaces). For instance, if the result is for a type, this property returns the type. If the result is for a member, this property returns the member's return type.

The kinds of resolver results include:

  • INamespaceResolverResult - Specifies the full name of a namespace that was matched and includes the INamespaceDeclaration objects from the various loaded assemblies that match that full name.
  • ITypeResolverResult - Specifies the ITypeDefinition that was matched.
  • ITypeMemberResolverResult - Specifies the ITypeMemberDefinition that was matched.
  • IParameterResolverResult - Specifies the IParameterDefinition that was matched.
  • IVariableResolverResult - Specifies the IVariableDefinition that was matched.

A Resolve Sample

This code gets the current caret offset in a SyntaxEditor that is using a CSharpSyntaxLanguage, creates a context for it, builds a new resolver request, and calls the resolver to get a result set for what is under the caret:

C#
VB
Copy
​// Create a context
var snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
var context = new CSharpContextFactory().CreateContext(snapshotOffset);

if (context.ProjectAssembly != null) {
    // Create a request
    var request = new ResolverRequest(context.TargetExpression);
    request.Context = context;

    // Resolve
    var resolver = context.ProjectAssembly.Resolver;
    var resultSet = resolver.Resolve(request);
}
​' Create a context
Dim snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context = New CSharpContextFactory().CreateContext(snapshotOffset)

If context.ProjectAssembly IsNot Nothing Then
    ' Create a request
    Dim request = New ResolverRequest(context.TargetExpression)
    request.Context = context

    ' Resolve
    Dim resolver = context.ProjectAssembly.Resolver
    Dim resultSet = resolver.Resolve(request)
End If

This code does the same thing as above but uses a IDotNetContext.Resolve helper method to perform a bulk of the work:

C#
VB
Copy
​var snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
var context = new CSharpContextFactory().CreateContext(snapshotOffset);
var resultSet = context.Resolve();
​Dim snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context = New CSharpContextFactory().CreateContext(snapshotOffset)
Dim resultSet = context.Resolve()

Enumerating Members for an Offset

The resolver is normally used to tell what is at an offset but it also can enumerate accessible namespaces, types, etc. for a given offset. To do this, simply create the context whose kind is DotNetContextKind.SelfAndSiblings.

This code shows how to obtain a result set that includes all of the accessible namespaces, types, etc. for the current caret offset in a SyntaxEditor that is using a CSharpSyntaxLanguage:

C#
VB
Copy
​var snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
var context = new CSharpContextFactory().CreateContext(snapshotOffset, DotNetContextKind.SelfAndSiblings);
var resultSet = context.Resolve();
​Dim snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context = New CSharpContextFactory().CreateContext(snapshotOffset, DotNetContextKind.SelfAndSiblings)
Dim resultSet = context.Resolve()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

.NET Languages Add-on - C# Language
Overview

The advanced C# syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Text Formatter
  • Context
  • Automated IntelliPrompt
  • Documentation Comment Auto-Completer

Features

The C# language is packed with features, including:

  • Automated IntelliPrompt completion list, parameter info, and quick info.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Over 130 distinct AST node classes.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Stub documentation comment auto-generation.
  • Code snippet support.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Code fragment editing with full IntelliPrompt, such as editing a method body.
  • Optionally change the parser to parse expressions, statements, etc. instead of compilation units.
  • Project assemblies that manage a project's code files and external references to other assemblies.
  • Assembly repository that stores and caches reflection information for binary .NET assemblies.
  • Support for navigable symbol selector (type/member drop-downs).

Licensing

Even though the .NET Languages Add-on is distributed and demoed with the Universal Windows controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the C# language from the .NET Languages Add-on, implemented by the CSharpSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The C# language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

See the Text Formatter topic for more information.

Context

The C# language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

See the Context topic for more information.

Automated IntelliPrompt

The C# language has built-in automated IntelliPrompt completion list, parameter info, quick info, and code snippet features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when /// is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

See the Documentation Comment Auto-Completer topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

.NET Languages Add-on - C# Language
Getting Started

This topic covers how to get started using the C# language from the .NET Languages Add-on, implemented by the CSharpSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the Ambient Assembly Repository
  • Configure the CSharpSyntaxLanguage and CSharpProjectAssembly
  • Use the CSharpSyntaxLanguage
  • Documents Should Have an Appropriate FileName
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the Ambient Assembly Repository

An ambient assembly repository should always be set up to ensure that the application reuses binary assembly reflection data whenever appropriate and that binary assembly references added to a project assembly are cached for future loading performance gains.

The ambient assembly repository should be set up in your application startup code as described in the Assemblies topic. The FileBasedAssemblyRepository class is the default implementation of an assembly repository, which supports the writing of binary assembly data to a cache folder specified in its constructor, as long as the application has read/write permissions to that folder (the app's data folder is advised).

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    string appDataPath = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Assembly Repository");
    AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(appDataPath);
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    Dim appDataPath As String = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Assembly Repository")
    AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(appDataPath)
    ...
End Sub

Likewise on application exit, the assembly repository's cache should be pruned, also as described in the Assemblies topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var repository = AmbientAssemblyRepositoryProvider.Repository;
    if (repository != null)
        repository.PruneCache();
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim repository = AmbientAssemblyRepositoryProvider.Repository
    If repository IsNot Nothing Then
        repository.PruneCache()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient assembly repository provider may result in unnecessary increased memory usages and slowdown when loading assembly references.

Configure the CSharpSyntaxLanguage and CSharpProjectAssembly

The next step is to create an instance of the CSharpSyntaxLanguage class and configure its project assembly.

This code creates a CSharpSyntaxLanguage, gets its default project assembly, and uses a background worker (for asynchronous execution) to add some assembly references, and queue up a source file to be included:

C#
VB
Copy
​var language = new CSharpSyntaxLanguage();
var project = language.GetService<IProjectAssembly>();
var assemblyLoader = new BackgroundWorker();
assemblyLoader.DoWork += (sender, e) => {
    project.AssemblyReferences.AddMsCorLib();  // MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System");
    project.AssemblyReferences.AddFrom(@"C:\MyAssembly.dll");
    project.SourceFiles.QueueFile(language, @"C:\MyFile.cs");
};
assemblyLoader.RunWorkerAsync();
​Dim language As New CSharpSyntaxLanguage()
Dim project As IProjectAssembly = language.GetService(Of IProjectAssembly)()
Dim assemblyLoader As New BackgroundWorker()
AddHandler assemblyLoader.DoWork, Sub(sender, e)
    project.AssemblyReferences.AddMsCorLib()  ' MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System")
    project.AssemblyReferences.AddFrom("C:\MyAssembly.dll")
    project.SourceFiles.QueueFile(language, "C:\MyFile.cs")
End Sub
assemblyLoader.RunWorkerAsync()

Note Note
The Assemblies topic contains detailed information on the multiple ways (some not shown above) to add assembly references and source files to a project assembly.

Note that the IProjectAssembly.AssemblyReferences collection should be cleared when the project assembly will no longer be used. This cleans up any memory or resources in use by the assembly repository for loaded assemblies.

C#
VB
Copy
​project.AssemblyReferences.Clear();
​project.AssemblyReferences.Clear()

Use the CSharpSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing C# code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your CSharpSyntaxLanguage instance among all the documents in your application that are editing C# code. This saves on overall memory usage and reduces load times.

Documents Should Have an Appropriate FileName

It is a good practice to set the FileName on any document using the language to an appropriate value that uniquely identifies the document's contents. The filename is used as a key to register the types defined in the document with the language's IProjectAssembly.

If the filename is left empty, the add-on will fall back to using the document's unique ID (a GUID value) to identify its contents in the project assembly.

This code sets the filename for a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.FileName = @"C:\Code.cs";
​editor.Document.FileName = "C:\Code.cs"

Assembly Requirements

The following list indicates the assemblies that are used with the C# syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.DotNet.Universal.dll | Yes | Actipro | .NET Languages Add-on | Core text/parsing for the C# language
ActiproSoftware.SyntaxEditor.Addons.DotNet.Universal.dll | Yes | Actipro | .NET Languages Add-on | SyntaxEditor for Universal Windows advanced C# syntax language implementation

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

.NET Languages Add-on - C# Language
Parsing and Parse Data

The C# language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String
  • Grammar Options

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

The CSharpParser class also has a special helper static method named ParseExpression that takes a string containing a C# expression and returns the IDotNetParseData parse results.

Grammar Options

The C# grammar (CSharpGrammar class) constructor can be passed an ICSharpGrammarOptions object that indicates options for the grammar's creation. The CSharpGrammarOptions class implements this interface.

Root Non-Terminal

The default options indicate that compilation unit should be the root non-terminal for the grammar. However this can be altered via the ICSharpGrammarOptions.RootNonTerminal property. The DotNetGrammarRootNonTerminal enumeration has a number of options for a root non-terminal, everything from expressions to statements.

Use this code to alter the root non-terminal for the grammar so that it tries to parse a single expression instead of a compilation unit:

C#
VB
Copy
​CSharpSyntaxLanguage language = new CSharpSyntaxLanguage();

CSharpGrammarOptions grammarOptions = new CSharpGrammarOptions();
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression;

CSharpGrammar grammar = new CSharpGrammar(grammarOptions);
language.RegisterParser(new CSharpParser(grammar));
​Dim language As New CSharpSyntaxLanguage()

Dim grammarOptions As New CSharpGrammarOptions()
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression

Dim grammar As New CSharpGrammar(grammarOptions)
language.RegisterParser(New CSharpParser(grammar))

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

.NET Languages Add-on - C# Language
Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The CSharpIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a { will cause the next line to be indented by one tab stop. Pressing ENTER while still typing a statement will also attempt to indent the next line by one tab stop.

Typed Characters

When certain characters such as {, }, or : are typed, the line will be examined to see if it should be indented/outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The CSharpSyntaxLanguage class automatically registers a CSharpIndentProvider with itself when it is created, so normally indent providers never need to be set on a C# language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomCSharpIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomCSharpIndentProvider());
​language.RegisterIndentProvider(New CustomCSharpIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on CSharpSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

.NET Languages Add-on - C# Language
Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The CSharpTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Opening Curly Braces on New Line

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The CSharpSyntaxLanguage class automatically registers a CSharpTextFormatter with itself when it is created, so normally text formatters never need to be set on a Visual Basic language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomCSharpTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomCSharpTextFormatter());
​language.RegisterTextFormatter(New CustomCSharpTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on CSharpSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Opening Curly Braces on New Line

The CSharpTextFormatter.IsOpeningBraceOnNewLine property can be used to determine whether opening curly braces appear on a new line.

It defaults to false, but can be changed to true to cause opening curly braces to move to the next line.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

.NET Languages Add-on - C# Language
Context

The C# language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • .NET Context

Obtaining Context Information

Context information can be retrieved via the use of the CSharpContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IDotNetContext for that offset.

This code retrieves an IDotNetContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IDotNetContext context = new CSharpContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IDotNetContext = New CSharpContextFactory().CreateContext(snapshotOffset)

A context kind (via the DotNetContextKind enumeration) can also be passed to a CreateContext method overload. The default value is Self but you can also pass SelfAndSiblings to indicate that alternate logic should be used when building the context. When SelfAndSiblings is passed, the context factory will return a context object that focuses on the "parent" of the offset. This allows resolver operations that use the context to enumerate a list of accessible members.

.NET Context

IDotNetContext objects provide .NET language-related context information for a specific snapshot offset, such as the containing AST node, target expression, and more.

These IDotNetContext members are important:

Member | Description
ContainingAstNode Property | Gets the IAstNode that contains the TextSnapshotOffset.
ContainingAstTypeDeclaration Property | Gets the AST TypeDeclaration that contains the TextSnapshotOffset, if any.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
ProjectAssembly Property | Gets the IProjectAssembly with which this context is associated.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetExpression Property | Gets the target AST Expression for the context, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

.NET Languages Add-on - C# Language
Automated IntelliPrompt

The C# language has built-in automated IntelliPrompt completion list, parameter info, quick info, code snippet, and navigable symbol selector features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Parameter Info
  • Quick Info
  • Code Snippets
  • Navigable Symbol Selector
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a . character after an identifier.

There are two types of completion list scenarios when typing in code blocks. First is when listing members of something. This can occur when typing a . character after an identifier. The second type is when showing all accessible members based on the current context. This can occur when starting to type a new sequence of identifiers.

When typing a < character in documentation comments, a list of appropriate documentation comment tags is displayed.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire identifier/keyword that was matched.

The completion list features are implemented by the CSharpCompletionProvider class.

Disabling Auto-Show On Typed Word Start

The CSharpCompletionProvider class has a CanShowOnTypedWordStart property that defaults to true. When true, the completion provider will attempt to automatically show a completion list as the user starts to type a new word, but only in certain contexts. Set the property to false to disable this behavior.

Parameter Info

IntelliPrompt parameter info is the ability to display helpful tooltips when typing an invocation that presents all of the signature overloads, along with information on the current parameter being typed.

Parameter info is displayed for method, indexer, and constructor invocations.

IntelliPrompt quick info features are implemented by the CSharpParameterInfoProvider language service.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers and some language keywords in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for namespaces, types, members, parameters, and variables. Appropriate documentation comments are displayed when available.

IntelliPrompt quick info features are implemented by the CSharpQuickInfoProvider language service.

Code Snippets

IntelliPrompt code snippets provide the ability to insert pre-defined text fragments and for the end user to edit fields declared within the text. When a code snippet provider with code snippets is registered as a service on the language, the automated completion list will list code snippets at appropriate times. Typing a code snippet's shortcut, which is also inserted by selecting a code snippet from the completion list, and pressing Tab will activate a code snippet template session.

The ICodeSnippetProvider service that is registered needs to have a root ICodeSnippetFolder set on it, with at least code snippet within it or its child folders. A folder can be created programmatically.

This code creates a CSharpSyntaxLanguage and registers a CSharpCodeSnippetProvider service on it, which is a code snippet provider that is optimized for this language. The provider has a root ICodeSnippetFolder assigned that contains all the snippets recursively found within the file system path specified by the path variable. Note that CSharp is passed as a language name parameter when loading the folder. This ensures that only code snippets designed for the C# language will be loaded.

C#
VB
Copy
​var language = new CSharpSyntaxLanguage();

ICodeSnippetFolder snippetFolder = CodeSnippetFolder.LoadFrom(path, "CSharp");
language.RegisterService(new CSharpCodeSnippetProvider() { RootFolder = snippetFolder });
​Dim language = New CSharpSyntaxLanguage()

Dim snippetFolder As ICodeSnippetFolder = CodeSnippetFolder.LoadFrom(path, "CSharp")
language.RegisterService(New CSharpCodeSnippetProvider() With {.RootFolder = snippetFolder})

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the types and members that currently enclose or are nearest the caret, and allows the end user to select other types/members within the same document via a dropdown, and to navigate to those members upon selection.

This control populates its symbol lists by the CSharpNavigableSymbolProvider language service.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the CSharpSyntaxLanguage that is created:

C#
VB
Copy
​var language = new CSharpSyntaxLanguage();

// Disable completion lists
language.UnregisterService<CSharpCompletionProvider>();

// Disable parameter info
language.UnregisterService<CSharpParameterInfoProvider>();

// Disable quick info
language.UnregisterService<CSharpQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New CSharpSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of CSharpCompletionProvider)()

' Disable parameter info
language.UnregisterService(Of CSharpParameterInfoProvider)()

' Disable quick info
language.UnregisterService(Of CSharpQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Documentation Comment Auto-Completer

.NET Languages Add-on - C# Language
Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when /// is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

The IDocumentationCommentAutoCompleter interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The CSharpDocumentationCommentAutoCompleter class is the default implementation of the IDocumentationCommentAutoCompleter interface.

This topic contains these sections:

  • Capabilities
  • Registering with a Syntax Language
  • Disabling the Functionality

Capabilities

Auto-generation of stub documentation comments is made when /// is typed by the end user as long as the CSharpDocumentationCommentAutoCompleter.IsStubGenerationEnabled property is set to true. Depending on which type or member follows, the generated comments will contain summary, typeparam, param, and returns tags as appropriate.

When a > character is typed by the end user to end a documentation comment start tag, the appropriate end tag will be inserted as long as the CSharpDocumentationCommentAutoCompleter.IsEndTagCompletionEnabled property is set to true.

When the end user presses Enter while in a documentation comment, /// is added to the next line as long as the CSharpDocumentationCommentAutoCompleter.IsNewLineGenerationEnabled property is set to true.

Registering with a Syntax Language

Any object that implements IDocumentationCommentAutoCompleter can be associated with a syntax language by registering it as an IDocumentationCommentAutoCompleter service on the language.

The CSharpSyntaxLanguage class automatically registers a CSharpDocumentationCommentAutoCompleter with itself when it is created, so normally documentation comment auto-completers never need to be set on an C# language unless a custom one is made.

This code creates a custom documentation comment auto-completer (defined in a make-believe CustomDocumentationCommentAutoCompleter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterDocumentationCommentAutoCompleter(new CustomDocumentationCommentAutoCompleter());
​language.RegisterDocumentationCommentAutoCompleter(New CustomDocumentationCommentAutoCompleter())

Note Note
The DotNetSyntaxLanguageExtensions.RegisterDocumentationCommentAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.DotNet namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on CSharpSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

.NET Languages Add-on - Visual Basic Language
Overview

The advanced Visual Basic syntax language implementation in the SyntaxEditor .NET Languages Add-on includes everything from automated IntelliPrompt and code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Text Formatter
  • Context
  • Automated IntelliPrompt
  • Documentation Comment Auto-Completer

Features

The Visual Basic language is packed with features, including:

  • Automated IntelliPrompt completion list, parameter info, and quick info.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Over 130 distinct AST node classes.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Stub documentation comment auto-generation.
  • Code snippet support.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Code fragment editing with full IntelliPrompt, such as editing a method body.
  • Optionally change the parser to parse expressions, statements, etc. instead of compilation units.
  • Project assemblies that manage a project's code files and external references to other assemblies.
  • Assembly repository that stores and caches reflection information for binary .NET assemblies.
  • Support for navigable symbol selector (type/member drop-downs).

Licensing

Even though the .NET Languages Add-on is distributed and demoed with the Universal Windows controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the Visual Basic language from the .NET Languages Add-on, implemented by the VBSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The Visual Basic language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

See the Text Formatter topic for more information.

Context

The Visual Basic language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

See the Context topic for more information.

Automated IntelliPrompt

The Visual Basic language has built-in automated IntelliPrompt completion list, parameter info, quick info, and code snippet features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when ''' is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

See the Documentation Comment Auto-Completer topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

.NET Languages Add-on - Visual Basic Language
Getting Started

This topic covers how to get started using the Visual Basic language from the .NET Languages Add-on, implemented by the VBSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the Ambient Assembly Repository
  • Configure the VBSyntaxLanguage and VBProjectAssembly
  • Use the VBSyntaxLanguage
  • Documents Should Have an Appropriate FileName
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the Ambient Assembly Repository

An ambient assembly repository should always be set up to ensure that the application reuses binary assembly reflection data whenever appropriate and that binary assembly references added to a project assembly are cached for future loading performance gains.

The ambient assembly repository should be set up in your application startup code as described in the Assemblies topic. The FileBasedAssemblyRepository class is the default implementation of an assembly repository, which supports the writing of binary assembly data to a cache folder specified in its constructor, as long as the application has read/write permissions to that folder (the app's data folder is advised).

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    string appDataPath = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Assembly Repository");
    AmbientAssemblyRepositoryProvider.Repository = new FileBasedAssemblyRepository(appDataPath);
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    Dim appDataPath As String = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Assembly Repository")
    AmbientAssemblyRepositoryProvider.Repository = New FileBasedAssemblyRepository(appDataPath)
    ...
End Sub

Likewise on application exit, the assembly repository's cache should be pruned, also as described in the Assemblies topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var repository = AmbientAssemblyRepositoryProvider.Repository;
    if (repository != null)
        repository.PruneCache();
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim repository = AmbientAssemblyRepositoryProvider.Repository
    If repository IsNot Nothing Then
        repository.PruneCache()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient assembly repository provider may result in unnecessary increased memory usages and slowdown when loading assembly references.

Configure the VBSyntaxLanguage and VBProjectAssembly

The next step is to create an instance of the VBSyntaxLanguage class and configure its project assembly.

This code creates a VBSyntaxLanguage, gets its default project assembly, and uses a background worker (for asynchronous execution) to add some assembly references, and queue up a source file to be included:

C#
VB
Copy
​var language = new VBSyntaxLanguage();
var project = language.GetService<IProjectAssembly>();
var assemblyLoader = new BackgroundWorker();
assemblyLoader.DoWork += (sender, e) => {
    project.AssemblyReferences.AddMsCorLib();  // MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System");
    project.AssemblyReferences.AddFrom(@"C:\MyAssembly.dll");
    project.SourceFiles.QueueFile(language, @"C:\MyFile.vb");
};
assemblyLoader.RunWorkerAsync();
​Dim language As New VBSyntaxLanguage()
Dim project As IProjectAssembly = language.GetService(Of IProjectAssembly)()
Dim assemblyLoader As New BackgroundWorker()
AddHandler assemblyLoader.DoWork, Sub(sender, e)
    project.AssemblyReferences.AddMsCorLib()  ' MsCorLib should always be added at a minimum
    project.AssemblyReferences.Add("System")
    project.AssemblyReferences.AddFrom("C:\MyAssembly.dll")
    project.SourceFiles.QueueFile(language, "C:\MyFile.vb")
End Sub
assemblyLoader.RunWorkerAsync()

Note Note
The Assemblies topic contains detailed information on the multiple ways (some not shown above) to add assembly references and source files to a project assembly.

Note that the IProjectAssembly.AssemblyReferences collection should be cleared when the project assembly will no longer be used. This cleans up any memory or resources in use by the assembly repository for loaded assemblies.

C#
VB
Copy
​project.AssemblyReferences.Clear();
​project.AssemblyReferences.Clear()

Use the VBSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing Visual Basic code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your VBSyntaxLanguage instance among all the documents in your application that are editing Visual Basic code. This saves on overall memory usage and reduces load times.

Documents Should Have an Appropriate FileName

It is a good practice to set the FileName on any document using the language to an appropriate value that uniquely identifies the document's contents. The filename is used as a key to register the types defined in the document with the language's IProjectAssembly.

If the filename is left empty, the add-on will fall back to using the document's unique ID (a GUID value) to identify its contents in the project assembly.

This code sets the filename for a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.FileName = @"C:\Code.cs";
​editor.Document.FileName = "C:\Code.cs"

Assembly Requirements

The following list indicates the assemblies that are used with the Visual Basic syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for SyntaxEditor
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.DotNet.Universal.dll | Yes | Actipro | .NET Languages Add-on | Core text/parsing for the Visual Basic language
ActiproSoftware.SyntaxEditor.Addons.DotNet.Universal.dll | Yes | Actipro | .NET Languages Add-on | SyntaxEditor for Universal Windows advanced Visual Basic syntax language implementation

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

.NET Languages Add-on - Visual Basic Language
Parsing and Parse Data

The Visual Basic language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String
  • Grammar Options

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

The VBParser class also has a special helper static method named ParseExpression that takes a string containing a Visual Basic expression and returns the IDotNetParseData parse results.

Grammar Options

The Visual Basic grammar (VBGrammar class) constructor can be passed an IVBGrammarOptions object that indicates options for the grammar's creation. The VBGrammarOptions class implements this interface.

Root Non-Terminal

The default options indicate that compilation unit should be the root non-terminal for the grammar. However this can be altered via the IVBGrammarOptions.RootNonTerminal property. The DotNetGrammarRootNonTerminal enumeration has a number of options for a root non-terminal, everything from expressions to statements.

Use this code to alter the root non-terminal for the grammar so that it tries to parse a single expression instead of a compilation unit:

C#
VB
Copy
​VBSyntaxLanguage language = new VBSyntaxLanguage();

VBGrammarOptions grammarOptions = new VBGrammarOptions();
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression;

VBGrammar grammar = new VBGrammar(grammarOptions);
language.RegisterParser(new VBParser(grammar));
​Dim language As New VBSyntaxLanguage()

Dim grammarOptions As New VBGrammarOptions()
grammarOptions.RootNonTerminal = DotNetGrammarRootNonTerminal.Expression

Dim grammar As New VBGrammar(grammarOptions)
language.RegisterParser(New VBParser(grammar))

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

.NET Languages Add-on - Visual Basic Language
Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The VBIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a Sub signature will cause the next line to be indented by one tab stop.

Typed Characters

When a space is typed after certain keywords such as End, Next, etc., the line will be examined to see if it should be outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The VBSyntaxLanguage class automatically registers a VBIndentProvider with itself when it is created, so normally indent providers never need to be set on a Visual Basic language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomVBIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomVBIndentProvider());
​language.RegisterIndentProvider(New CustomVBIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on VBSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

.NET Languages Add-on - Visual Basic Language
Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The VBTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The VBSyntaxLanguage class automatically registers a VBTextFormatter with itself when it is created, so normally text formatters never need to be set on a VB language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomVBTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomVBTextFormatter());
​language.RegisterTextFormatter(New CustomVBTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on VBSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

.NET Languages Add-on - Visual Basic Language
Context

The Visual Basic language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • .NET Context

Obtaining Context Information

Context information can be retrieved via the use of the VBContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IDotNetContext for that offset.

This code retrieves an IDotNetContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IDotNetContext context = new VBContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IDotNetContext = New VBContextFactory().CreateContext(snapshotOffset)

A context kind (via the DotNetContextKind enumeration) can also be passed to a CreateContext method overload. The default value is Self but you can also pass SelfAndSiblings to indicate that alternate logic should be used when building the context. When SelfAndSiblings is passed, the context factory will return a context object that focuses on the "parent" of the offset. This allows resolver operations that use the context to enumerate a list of accessible members.

.NET Context

IDotNetContext objects provide .NET language-related context information for a specific snapshot offset, such as the containing AST node, target expression, and more.

These IDotNetContext members are important:

Member | Description
ContainingAstNode Property | Gets the IAstNode that contains the TextSnapshotOffset.
ContainingAstTypeDeclaration Property | Gets the AST TypeDeclaration that contains the TextSnapshotOffset, if any.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
ProjectAssembly Property | Gets the IProjectAssembly with which this context is associated.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetExpression Property | Gets the target AST Expression for the context, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

.NET Languages Add-on - Visual Basic Language
Automated IntelliPrompt

The Visual Basic language has built-in automated IntelliPrompt completion list, parameter info, quick info, code snippet, and navigable symbol selector features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Parameter Info
  • Quick Info
  • Code Snippets
  • Navigable Symbol Selector
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a . character after an identifier.

There are two types of completion list scenarios when typing in code blocks. First is when listing members of something. This can occur when typing a . character after an identifier. The second type is when showing all accessible members based on the current context. This can occur when starting to type a new sequence of identifiers.

When typing a < character in documentation comments, a list of appropriate documentation comment tags is displayed.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire identifier/keyword that was matched.

The completion list features are implemented by the VBCompletionProvider class.

Disabling Auto-Show On Typed Word Start

The VBCompletionProvider class has a CanShowOnTypedWordStart property that defaults to true. When true, the completion provider will attempt to automatically show a completion list as the user starts to type a new word, but only in certain contexts. Set the property to false to disable this behavior.

Parameter Info

IntelliPrompt parameter info is the ability to display helpful tooltips when typing an invocation that presents all of the signature overloads, along with information on the current parameter being typed.

Parameter info is displayed for method, indexer, and constructor invocations.

IntelliPrompt quick info features are implemented by the VBParameterInfoProvider language service.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers and some language keywords in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for namespaces, types, members, parameters, and variables. Appropriate documentation comments are displayed when available.

IntelliPrompt quick info features are implemented by the VBQuickInfoProvider language service.

Code Snippets

IntelliPrompt code snippets provide the ability to insert pre-defined text fragments and for the end user to edit fields declared within the text. When a code snippet provider with code snippets is registered as a service on the language, the automated completion list will list code snippets at appropriate times. Typing a code snippet's shortcut, which is also inserted by selecting a code snippet from the completion list, and pressing Tab will activate a code snippet template session.

The ICodeSnippetProvider service that is registered needs to have a root ICodeSnippetFolder set on it, with at least code snippet within it or its child folders. A folder can be created programmatically.

This code creates a VBSyntaxLanguage and registers a VBCodeSnippetProvider service on it, which is a code snippet provider that is optimized for this language. The provider has a root ICodeSnippetFolder assigned that contains all the snippets recursively found within the file system path specified by the path variable. Note that VB is passed as a language name parameter when loading the folder. This ensures that only code snippets designed for the Visual Basic language will be loaded.

C#
VB
Copy
​var language = new VBSyntaxLanguage();

ICodeSnippetFolder snippetFolder = CodeSnippetFolder.LoadFrom(path, "VB");
language.RegisterService(new VBCodeSnippetProvider() { RootFolder = snippetFolder });
​Dim language = New VBSyntaxLanguage()

Dim snippetFolder As ICodeSnippetFolder = CodeSnippetFolder.LoadFrom(path, "VB")
language.RegisterService(New VBCodeSnippetProvider() With {.RootFolder = snippetFolder})

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the types and members that currently enclose or are nearest the caret, and allows the end user to select other types/members within the same document via a dropdown, and to navigate to those members upon selection.

This control populates its symbol lists by the VBNavigableSymbolProvider language service.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the VBSyntaxLanguage that is created:

C#
VB
Copy
​var language = new VBSyntaxLanguage();

// Disable completion lists
language.UnregisterService<VBCompletionProvider>();

// Disable parameter info
language.UnregisterService<VBParameterInfoProvider>();

// Disable quick info
language.UnregisterService<VBQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New VBSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of VBCompletionProvider)()

' Disable parameter info
language.UnregisterService(Of VBParameterInfoProvider)()

' Disable quick info
language.UnregisterService(Of VBQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Documentation Comment Auto-Completer

.NET Languages Add-on - Visual Basic Language
Documentation Comment Auto-Completer

A documentation comment auto-completer is an object that can attempt to auto-generate stub documentation comments for a type or member when ''' is typed by the end user, can auto-complete end tags, and can insert continuation delimiters when pressing Enter in a documentation comment.

The IDocumentationCommentAutoCompleter interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The VBDocumentationCommentAutoCompleter class is the default implementation of the IDocumentationCommentAutoCompleter interface.

This topic contains these sections:

  • Capabilities
  • Registering with a Syntax Language
  • Disabling the Functionality

Capabilities

Auto-generation of stub documentation comments is made when ''' is typed by the end user as long as the VBDocumentationCommentAutoCompleter.IsStubGenerationEnabled property is set to true. Depending on which type or member follows, the generated comments will contain summary, typeparam, param, and returns tags as appropriate.

When a > character is typed by the end user to end a documentation comment start tag, the appropriate end tag will be inserted as long as the VBDocumentationCommentAutoCompleter.IsEndTagCompletionEnabled property is set to true.

When the end user presses Enter while in a documentation comment, ''' is added to the next line as long as the VBDocumentationCommentAutoCompleter.IsNewLineGenerationEnabled property is set to true.

Registering with a Syntax Language

Any object that implements IDocumentationCommentAutoCompleter can be associated with a syntax language by registering it as an IDocumentationCommentAutoCompleter service on the language.

The VBSyntaxLanguage class automatically registers a VBDocumentationCommentAutoCompleter with itself when it is created, so normally documentation comment auto-completers never need to be set on an Visual Basic language unless a custom one is made.

This code creates a custom documentation comment auto-completer (defined in a make-believe CustomDocumentationCommentAutoCompleter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterDocumentationCommentAutoCompleter(new CustomDocumentationCommentAutoCompleter());
​language.RegisterDocumentationCommentAutoCompleter(New CustomDocumentationCommentAutoCompleter())

Note Note
The DotNetSyntaxLanguageExtensions.RegisterDocumentationCommentAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.DotNet namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on VBSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

.NET Languages Add-on
Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

This topic contains these sections:

  • How Do I Get Started With C# / Visual Basic Languages?
  • Typing Is Slow
  • Loading of Binary Assembly References Blocks the UI Thread
  • No IntelliPrompt For System Types

How Do I Get Started With C# / Visual Basic Languages?

The C# Getting Started topic walks through all the requirements for using the C# language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

The Visual Basic Getting Started topic walks through all the requirements for using the Visual Basic language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

Typing Is Slow

If you notice a lag when typing, it is likely due to an ambient parse request dispatcher not being set up. Each time text changes occur, such as while typing, a parse request is fired off for the parser to parse the document. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up an ambient parse request dispatcher for your application.

When no ambient parse request dispatcher has been configured for your application, the parsing will occur in the main UI thread, thus severely affecting typing performance, especially in larger documents.

See the C# Getting Started or Visual Basic Getting Started topics for more information on how to set up an ambient parse request dispatcher for your application.

Loading of Binary Assembly References Blocks the UI Thread

When .NET assemblies are added to a project assembly as references, we use reflection to iterate over all the namespaces, types, members, etc. in the assembly to build up our own reflection data model for the assembly. Using .NET reflection does take time so referencing assemblies will block the UI if it is done in the main UI thread.

A project assembly's references should be loaded using a BackgroundWorker or another similar asynchronous mechanism. That way, it will not block the UI while loading.

The add-on also supports caching of binary assembly data, so that the second and later times that the same assembly is loaded (even in future application sessions), it will load ten or more times faster than its initial load. This feature is implemented via an ambient assembly repository, which helps reduce overall memory and improves performance.

See the C# Getting Started or Visual Basic Getting Started topics for more information on how to load project assembly references in a worker thread and configure an ambient assembly repository for caching.

No IntelliPrompt For System Types

If automated IntelliPrompt features like quick info are not working for system types or for the language's native keywords, make sure that the project assembly in use has the proper assembly references to allow those types to be resolved. For instance, at a minimum the MsCorLib assembly should always be added as a reference.

See the C# Getting Started or Visual Basic Getting Started topics for more information on how load project assembly references.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Python Language Add-on
Overview

The Python Language Add-on is an optional premium extra for SyntaxEditor customers that includes an advanced implementation of the Python syntax language.

The add-on has been built from the ground up by Actipro to take advantage of best practices for syntax language design. While it is already packed with innovative features, the design is completely extensible and can be enhanced or modified as much as you like.

Note Note
Be sure to read through the language's "Getting Started" topic and follow each step in it exactly to ensure that the add-on's features will operate properly. While it only takes several lines of code to get up and running, those lines are very important and may prevent the add-on from working correctly if they are not present.

Although the add-on is distributed and demoed with the Universal Windows controls, it is sold separately.

This topic contains these sections:

  • Python Language
  • Troubleshooting

Python Language

The advanced Python syntax language implementation in the SyntaxEditor Python Language Add-on includes everything from code outlining to syntax error reporting.

See the Python Language topics for more information.

Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

See the Troubleshooting topics for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Python Language Add-on - Python Language
Overview

The advanced Python syntax language implementation in the SyntaxEditor Python Language Add-on includes everything from code outlining to syntax error reporting.

Note Note
The syntax language supports both the Python v3.x and Python v2.x syntax, toggleable via a flag when creating the syntax language.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Context
  • Resolver
  • Automated IntelliPrompt

Features

The Python language is packed with features, including:

  • Automated IntelliPrompt completion list, parameter info, and quick info.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Line commenting.
  • Smart indent.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Project that manage a project's code files and references to external libraries, such as the Python standard library.
  • Package repository that stores and caches reflection information for Python packages.
  • Support for navigable symbol selector (contextual drop-down).

Licensing

Even though the Python Languages Add-on is distributed and demoed with the Universal Windows controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the Python language from the Python Language Add-on, implemented by the PythonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The Python language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Context

The Python language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

See the Context topic for more information.

Resolver

Each Python IProject has an IResolver that can examine a Python context and AST expression and return the results associated with that expression. The resolver is used by the automated IntelliPrompt features to determine what to show in the UI for various scenarios.

See the Resolver topic for more information.

Automated IntelliPrompt

The Python language has built-in automated IntelliPrompt completion list, parameter info, and quick info features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Python Language Add-on - Python Language
Getting Started

This topic covers how to get started using the Python language from the Python Language Add-on, implemented by the PythonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the Ambient Package Repository
  • Create the PythonSyntaxLanguage
  • Configure the Python Project
  • Use the PythonSyntaxLanguage
  • Documents Should Have an Appropriate FileName and Tab Settings
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the Ambient Package Repository

An ambient package repository should always be set up to ensure that the application is able to use and cache package data from all packages within the Python project's search paths. A Python project (see below) normally adds search paths for the root of your project's .py files, along with external libraries such as the Python standard library's Lib folder. When a search path is added to a project, it will search the cache path to see if the cached data there is up-to-date with the related source package. If not, cache data is added to the package repository via a worker thread.

The ambient package repository should be set up in your application startup code. The FileBasedPackageRepository class is the default implementation of a package repository, which supports the writing of binary package data to a cache folder specified in its constructor, as long as the application has read/write permissions to that folder (the app's data folder is advised).

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    string appDataPath = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Package Repository");
    AmbientPackageRepositoryProvider.Repository = new FileBasedPackageRepository(appDataPath);
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    Dim appDataPath As String = Path.Combine(ApplicationData.Current.LocalFolder.Path, "Package Repository")
    AmbientPackageRepositoryProvider.Repository = New FileBasedPackageRepository(appDataPath)
    ...
End Sub

Note Note
Failure to set up an ambient package repository provider will result in IntelliPrompt features not working for module internals.

Create the PythonSyntaxLanguage

The next step is to create an instance of the PythonSyntaxLanguage class and configure its project.

Note Note
Since Python v3.x has breaking syntax changes from v2.x, you can pass a PythonVersion parameter into the language constructor to designate which version should be supported.

This code creates a PythonSyntaxLanguage for editing Python v3.x code:

C#
VB
Copy
​var language = new PythonSyntaxLanguage(PythonVersion.Version3);
​Dim language As New PythonSyntaxLanguage(PythonVersion.Version3)

Alternatively, this code creates a PythonSyntaxLanguage for editing Python v2.x code:

C#
VB
Copy
​var language = new PythonSyntaxLanguage(PythonVersion.Version2);
​Dim language As New PythonSyntaxLanguage(PythonVersion.Version2)

Configure the Python Project

Each language has a IProject registered as a service on it that provides information such as which modules are actively being edited in a SyntaxEditor, the collection of paths to search for external packages, and the Python version.

If you wish to support automated IntelliPrompt for external modules, it is important to add search paths to the project. This tells the resolver where to look for .py files. Note that the resolver will recursively search through child folders of specified paths as long as the folder names are valid Python identifiers.

It is common practice to specify these paths:

  • The root path of your Python project code
  • The path to the Python standard library Lib folder
  • The path to the Python standard library's Lib\site-packages folder
  • The path to any other folders that contain external libraries that are used by code in your project

This code gets the language's default project, and adds several search paths to where external packages can be located and used for IntelliPrompt:

C#
VB
Copy
​var project = language.GetService<IProject>();
project.SearchPaths.Add(@"C:\Python\Projects\MyProject");
project.SearchPaths.Add(@"C:\Python\Platform34\Lib");
project.SearchPaths.Add(@"C:\Python\Platform34\Lib\site-packages");
​Dim project As IProject = language.GetService(Of IProject)()
project.SearchPaths.Add("C:\Python\Projects\MyProject")
project.SearchPaths.Add("C:\Python\Platform34\Lib")
project.SearchPaths.Add("C:\Python\Platform34\Lib\site-packages")

Note Note
Due to the security sandbox restrictions of the file system in Windows apps, take care to ensure that the search paths you add are fully accessible to the app. The app's data folder is advised.

Use the PythonSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing Python code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your PythonSyntaxLanguage instance among all the documents in your application that are editing Python code. This saves on overall memory usage and reduces load times.

Documents Should Have an Appropriate FileName and Tab Settings

It is a good practice to set the FileName on any document using the language to an appropriate value that uniquely identifies the document's contents. The filename is used as a key to register the module defined in the document with the language's IProject.

Note Note
If the filename is left empty, relative paths can't be used in from...import statements and some other IntelliPrompt feature might not work properly.

Python also generally prefers that spaces are used in place of tabs for indentation. Set the ITextDocument.AutoConvertTabsToSpaces property to true to force the use of spaces.

This code sets the filename and tab options for a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.FileName = @"C:\mymodule.py";
editor.Document.TabSize = 4";
editor.Document.AutoConvertTabsToSpaces = true
​editor.Document.FileName = "C:\mymodule.py
editor.Document.TabSize = 4
editor.Document.AutoConvertTabsToSpaces = True"

Assembly Requirements

The following list indicates the assemblies that are used with the Python syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for Universal Windows
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.Python.Universal.dll | Yes | Actipro | Python Language Add-on | Core text/parsing for the Python languages
ActiproSoftware.SyntaxEditor.Addons.Python.Universal.dll | Yes | Actipro | Python Language Add-on | SyntaxEditor for Universal Windows advanced Python syntax language implementations

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

Python Language Add-on - Python Language
Parsing and Parse Data

The Python language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

Python Language Add-on - Python Language
Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The PythonIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope.

For instance, pressing ENTER after a : will cause the next line to be indented by one tab stop. Pressing ENTER after a statement such as a return statement will outdent by one tab stop.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The PythonSyntaxLanguage class automatically registers a PythonIndentProvider with itself when it is created, so normally indent providers never need to be set on a Python language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomPythonIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomPythonIndentProvider());
​language.RegisterIndentProvider(New CustomPythonIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on PythonSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

Python Language Add-on - Python Language
Context

The Python language can return detailed context information about any offset in a document. The context includes data such as containing AST node, target expression, and more. This sort of information is essential in passing to the resolver to determine what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • .NET Context

Obtaining Context Information

Context information can be retrieved via the use of the PythonContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IPythonContext for that offset.

This code retrieves an IPythonContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IPythonContext context = new PythonContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IPythonContext = New PythonContextFactory().CreateContext(snapshotOffset)

A context kind (via the PythonContextKind enumeration) can also be passed to a CreateContext method overload. The default value is Self but you can also pass SelfAndSiblings to indicate that alternate logic should be used when building the context. When SelfAndSiblings is passed, the context factory will return a context object that focuses on the "parent" of the offset. This allows resolver operations that use the context to enumerate a list of accessible members.

.NET Context

IPythonContext objects provide .NET language-related context information for a specific snapshot offset, such as the containing AST node, target expression, and more.

These IPythonContext members are important:

Member | Description
ContainingAstNode Property | Gets the IAstNode that contains the TextSnapshotOffset.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
Project Property | Gets the IProject with which this context is associated.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetExpression Property | Gets the target AST Expression for the context, if known.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Resolver

Python Language Add-on - Python Language
Resolver

Each Python IProject has an IResolver that can examine a Python context and AST expression and return the results associated with that expression. The resolver is used by the automated IntelliPrompt features to determine what to show in the UI for various scenarios.

An IResolver instance is automatically created by the Python Project when it is instantiated.

While it's not normally necessary to directly use the resolver (since it internally helps drive the built-in automated IntelliPrompt features), there are several ways to externally adjust how it functions. These are described below.

This topic contains these sections:

  • Unknown Return Type Reference Callback
  • Maximum Import Recursion Level

Unknown Return Type Reference Callback

Since the Python add-on doesn't have a full interpreter to run, sometimes the return types of functions will be unknown to it. When the resolver is unable to determine the type that is returned by a function, variable, etc., it will call the IResolver.UnknownReturnTypeReferenceCallback if one has been specified.

This code shows how a callback can be created to return types for functions, variables, etc. in scenarios where the resolver couldn't determine the type.

C#
VB
Copy
​...
project.Resolver.UnknownReturnTypeReferenceCallback = MyUnknownReturnTypeReferenceCallback;
...
private static ITypeReference MyUnknownReturnTypeReferenceCallback(IReflectionDefinition refDef) {
    var funcDef = refDef as IFunctionDefinition;
    if (funcDef != null) {
        if (funcDef.DeclaringModule != null) {
            // Examine the name of the declaring module
            switch (funcDef.DeclaringModule.Name) {
                case "somemodule":
                    if (funcDef.DeclaringType != null) {
                        // Examine the name of the declaring type
                        switch (funcDef.DeclaringType.Name) {
                            case "SomeClass":
                                // Examine the name of the method
                                switch (funcDef.Name) {
                                    case "somemethod":
                                        // Return a 'SomeOtherClass' type defined in a 'someotherclass.py' module
                                        return new TypeReference(Path.Combine(pathToTheReturnTypeModule, "someotherclass.py"), "SomeOtherClass");
                                }
                                break;
                    }
                    else {
                        // Examine the name of the function (not a method since there is no DeclaringType)
                        switch (funcDef.Name) {
                            case "somefunction":
                                // Return the built-in 'int' type
                                return new TypeReference(null, "int");
                        }
                    }
                    break;
            }
        }
    }

    return null;
}
​...
project.Resolver.UnknownReturnTypeReferenceCallback = AddressOf(MyUnknownReturnTypeReferenceCallback)
...
Private Shared Function MyUnknownReturnTypeReferenceCallback(ByVal refDef As IReflectionDefinition) As ITypeReference
    Dim funcDef = TryCast(refDef, IFunctionDefinition)
    If funcDef IsNot Nothing Then
        If funcDef.DeclaringModule IsNot Nothing Then
            ' Examine the name of the declaring module
            Select Case funcDef.DeclaringModule.Name
                Case "somemodule"
                    If funcDef.DeclaringType IsNot Nothing Then
                        ' Examine the name of the declaring type
                        Select Case funcDef.DeclaringType.Name
                            Case "SomeClass"
                                ' Examine the name of the method
                                Select Case funcDef.Name
                                    Case "somemethod"
                                        ' Return a 'SomeOtherClass' type defined in a 'someotherclass.py' module
                                        Return New TypeReference(Path.Combine(pathToTheReturnTypeModule, "someotherclass.py"), "SomeOtherClass")
                                End Select
                        End Select
                    Else
                        ' Examine the name of the function (not a method since there is no DeclaringType)
                        Select Case funcDef.Name
                            Case "somefunction"
                                ' Return the built-in 'int' type
                                Return New TypeReference(Nothing, "int")
                        End Select
                    End If
            End Select
        End If
    End If

    Return Nothing
End Function

Maximum Import Recursion Level

Some very large external Python packages involve lots of import recursions, where certain modules import other modules/packages, which in turn import other modules/packages down the line. While the Python resolver has a lot of optimizations and caching mechanisms to make examination of those imports as quick as possible, packages with many hundreds of interconnected modules might experience a brief slowdown as the resolver processes. This may manifest itself as a brief pause while bringing up an IntelliPrompt completion list, etc.

There is an option via the IResolver.MaximumImportRecursionLevel property that can be changed to limit how many import recursions deep the resolver can go. The default value is 10. If the root module has an import statement, as the resolver navigates down to the imported module/package, that is the first recursion. If that imported module/package has another import that would affect the resolver results, navigating into this other import would be the second recursion. By making the MaximumImportRecursionLevel a smaller value, it prevents the resolver from going too deeply into import recursions (thus possibly improving resolution speed), but also may cause only a subset of the real resolver results to be returned.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

Python Language Add-on - Python Language
Automated IntelliPrompt

The Python language has built-in automated IntelliPrompt completion list, parameter info, quick info, and navigable symbol selector features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Parameter Info
  • Quick Info
  • Navigable Symbol Selector
  • Showing Full Docstrings
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. In many cases, the completion list is triggered by key events such as pressing Ctrl+Space or typing a . character after an identifier.

There are two types of completion list scenarios when typing in code blocks. First is when listing members of something. This can occur when typing a . character after an identifier. The second type is when showing all accessible members based on the current context. This can occur when starting to type a new sequence of identifiers.

In cases where a completion list is triggered via Ctrl+Space, if there is a single match for the text that has been typed, it will not show the list but will auto-complete the match. This saves the user from having to type the entire identifier/keyword that was matched.

The completion list features are implemented by the PythonCompletionProvider class.

Parameter Info

IntelliPrompt parameter info is the ability to display helpful tooltips when typing an invocation that presents all of the signature overloads, along with information on the current parameter being typed.

Parameter info is displayed for function and method invocations.

IntelliPrompt quick info features are implemented by the PythonParameterInfoProvider language service.

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers and some language keywords in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for packages, modules, types, functions/methods, parameters, and variables. Appropriate docstring comments are displayed when available.

IntelliPrompt quick info features are implemented by the PythonQuickInfoProvider language service.

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the types and attributes that currently enclose or are nearest the caret, and allows the end user to select other types/attributes within the same document via a dropdown.

The NavigableSymbolSelector.AreMemberSymbolsSupported property should be set to false when working with Python since only one drop-down is used.

This control populates its symbol lists by the PythonNavigableSymbolProvider language service.

Showing Full Docstrings

By default, any docstrings that show in IntelliPrompt popups will only be the summary line. The summary line is the text up through the first whitespace line within docstring. This behavior can be altered for various IntelliPrompt providers so that the entire docstring is displayed instead.

This code tells each IntelliPrompt provider to display the entire docstring:

C#
VB
Copy
​language.RegisterService(new PythonCompletionProvider() { DocstringDisplayMode = PythonDocstringDisplayMode.All });
language.RegisterService(new PythonParameterInfoProvider() { DocstringDisplayMode = PythonDocstringDisplayMode.All });
language.RegisterService(new PythonQuickInfoProvider() { DocstringDisplayMode = PythonDocstringDisplayMode.All });
​language.RegisterService(New PythonCompletionProvider() With {.DocstringDisplayMode = PythonDocstringDisplayMode.All})
language.RegisterService(New PythonParameterInfoProvider() With {.DocstringDisplayMode = PythonDocstringDisplayMode.All})
language.RegisterService(New PythonQuickInfoProvider() With {.DocstringDisplayMode = PythonDocstringDisplayMode.All})

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the PythonSyntaxLanguage that is created:

C#
VB
Copy
​var language = new PythonSyntaxLanguage();

// Disable completion lists
language.UnregisterService<PythonCompletionProvider>();

// Disable parameter info
language.UnregisterService<PythonParameterInfoProvider>();

// Disable quick info
language.UnregisterService<PythonQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New PythonSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of PythonCompletionProvider)()

' Disable parameter info
language.UnregisterService(Of PythonParameterInfoProvider)()

' Disable quick info
language.UnregisterService(Of PythonQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

Python Language Add-on
Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

This topic contains these sections:

  • How Do I Get Started With Python Language?
  • Typing Is Slow

How Do I Get Started With Python Language?

The Getting Started topic walks through all the requirements for using the Python language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

Typing Is Slow

If you notice a lag when typing, it is likely due to an ambient parse request dispatcher not being set up. Each time text changes occur, such as while typing, a parse request is fired off for the parser to parse the document. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up an ambient parse request dispatcher for your application.

When no ambient parse request dispatcher has been configured for your application, the parsing will occur in the main UI thread, thus severely affecting typing performance, especially in larger documents.

See the Getting Started topic for more information on how to set up an ambient parse request dispatcher for your application.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Web Languages Add-on
Overview

The Web Languages Add-on is an optional premium extra for SyntaxEditor customers that includes an advanced implementation of the XML, JavaScript, and JSON syntax languages.

The add-on has been built from the ground up by Actipro to take advantage of best practices for syntax language design. While it is already packed with innovative features, the design is completely extensible and can be enhanced or modified as much as you like.

Note Note
Be sure to read through the language's "Getting Started" topic and follow each step in it exactly to ensure that the add-on's features will operate properly. While it only takes several lines of code to get up and running, those lines are very important and may prevent the add-on from working correctly if they are not present.

Although the add-on is distributed and demoed with the Universal Windows controls, it is sold separately.

This topic contains these sections:

  • XML Language
  • JavaScript Language
  • JSON Language
  • Troubleshooting

XML Language

The advanced XML syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from automated IntelliPrompt and code outlining to validation, and provides a best-of-breed XML editing experience for end users.

See the XML Language topics for more information.

JavaScript Language

The advanced JavaScript syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

See the JavaScript Language topics for more information.

JSON Language

The advanced JSON syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

See the JSON Language topics for more information.

Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

See the Troubleshooting topics for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Web Languages Add-on - XML Language
Overview

The advanced XML syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from automated IntelliPrompt and code outlining to validation, and provides a best-of-breed XML editing experience for end users.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • End Tag Auto-Completer
  • Indent Provider
  • Text Formatter
  • Context
  • Automated IntelliPrompt

Features

The XML language is packed with features, including:

  • Automated IntelliPrompt quick info for elements and attributes.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Automatic code outlining based on XML element structure.
  • Reporting and automatic squiggle display of errors for invalid XML syntax.
  • Mouse hover quick info for syntax errors.
  • Easily obtain full XML contextual information for any offset.
  • End tag auto-complete.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Support for navigable symbol selector (element/attribute drop-downs).

Licensing

Even though the Web Languages Add-on is distributed and demoed with the Universal Windows controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the XML language from the Web Languages Add-on, implemented by the XmlSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The XML language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The IXmlParseData results returned by this parser are consumed by multiple other features of the language, such as automated IntelliPrompt, code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

End Tag Auto-Completer

An end-tag auto-completer is an object that can be called to attempt to insert an end tag such as when > is typed by the end user.

See the End Tag Auto-Completer topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in XML text formatter can adjust whitespace between elements and attributes to make code more readable.

See the Text Formatter topic for more information.

Context

The XML language can return detailed context information about any offset in a document. The context includes data such as declared namespaces, containing element hierarchy, current element/attribute, and more. This sort of information is essential in determining what to display in automated IntelliPrompt.

See the Context topic for more information.

Automated IntelliPrompt

The XML language has built-in automated IntelliPrompt quick info features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Web Languages Add-on - XML Language
Getting Started

This topic covers how to get started using the XML language from the Web Languages Add-on, implemented by the XmlSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the XmlSyntaxLanguage
  • Use the XmlSyntaxLanguage
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the XmlSyntaxLanguage

The next step is to create an instance of the XmlSyntaxLanguage class.

This code creates a XmlSyntaxLanguage:

C#
VB
Copy
​XmlSyntaxLanguage language = new XmlSyntaxLanguage();
​Dim language As New XmlSyntaxLanguage()

Use the XmlSyntaxLanguage

The final step is to use the language on the ICodeDocument instances that will be editing XML.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Assembly Requirements

The following list indicates the assemblies that are used with the XML syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for Universal Windows
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.Xml.Universal.dll | Yes | Actipro | Web Languages Add-on | Core text/parsing for the XML language
ActiproSoftware.SyntaxEditor.Addons.Xml.Universal.dll | Yes | Actipro | Web Languages Add-on | SyntaxEditor for Universal Windows advanced XML syntax language implementation

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

Web Languages Add-on - XML Language
Parsing and Parse Data

The XML language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The IXmlParseData results returned by this parser are consumed by multiple other features of the language, such as automated IntelliPrompt, code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Well-Formed Flag
  • Retrieving Parse Data
  • Parsing a Text String

AST Construction

A complete AST of parsed documents is generated by the parser, with structured element nodes and lists of the attributes on each element. It is passed back in the IXmlParseData.Ast property.

This information is used when building the context for an offset.

Parse Errors

Parse errors are reported from the parser. They are passed back in the IXmlParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Well-Formed Flag

The IXmlParseData.IsWellFormed property indicates whether the XML is well-formed.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the IXmlParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


End Tag Auto-Completer

Web Languages Add-on - XML Language
End Tag Auto-Completer

An end-tag auto-completer is an object that can be called to attempt to insert an end tag such as when > is typed by the end user.

The IXmlEndTagAutoCompleter interface provides the base requirements for this functionality. It is installed into a language as a "feature" language service.

The XmlEndTagAutoCompleter class is the default implementation of the IXmlEndTagAutoCompleter interface.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality

Registering with a Syntax Language

Any object that implements IXmlEndTagAutoCompleter can be associated with a syntax language by registering it as an IXmlEndTagAutoCompleter service on the language.

The XmlSyntaxLanguage class automatically registers a XmlEndTagAutoCompleter with itself when it is created, so normally end tag auto-completers never need to be set on an XML language unless a custom one is made.

This code creates a custom end tag auto-completer (defined in a make-believe CustomXmlEndTagAutoCompleter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterXmlEndTagAutoCompleter(new CustomXmlEndTagAutoCompleter());
​language.RegisterXmlEndTagAutoCompleter(New CustomXmlEndTagAutoCompleter())

Note Note
The XmlSyntaxLanguageExtensions.RegisterXmlEndTagAutoCompleter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text.Languages.Xml namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

Web Languages Add-on - XML Language
Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The XmlIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will normally use block indent (same indent level as the previous line) except when it detects that ENTER is pressed on a line that ends with a start tag. In this case, the caret is indented another level on the next line.

Block Element Handling

Also consider this scenario, where the caret is at |:

XML
Copy
​<tag>|</tag>

If the end user presses ENTER, the indent provider will make this the result:

XML
Copy
​<tag>
    |
</tag>

Note how the end tag is moved to the line below the caret and is properly indented to the same indent level of the start tag. However the caret is indented on the line in the middle of the tags.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The XmlSyntaxLanguage class automatically registers a XmlIndentProvider with itself when it is created, so normally indent providers never need to be set on an XML language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomXmlIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomXmlIndentProvider());
​language.RegisterIndentProvider(New CustomXmlIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

Web Languages Add-on - XML Language
Text Formatter

The built-in XML text formatter can adjust whitespace between elements and attributes to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The XmlTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Attribute Spacing Mode
  • Element Spacing Mode
  • Tag Wrap Length

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The XmlSyntaxLanguage class automatically registers a XmlTextFormatter with itself when it is created, so normally text formatters never need to be set on a XML language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomXmlTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomXmlTextFormatter());
​language.RegisterTextFormatter(New CustomXmlTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on XmlSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Attribute Spacing Mode

The XmlTextFormatter has an AttributeSpacingMode property that can be set to alter the behavior of the formatter when dealing with whitespace around attributes within an element. None of the modes affect the TagWrapLength feature (described below). The XmlAttributeSpacingMode enumeration defines these three mode options:

Mode | Formatter Behavior
Preserve | The formatter will not make changes to the whitespace around attributes. This is the default mode.
NormalizeWhitespace | The formatter will adjust any whitespace around attributes to be exactly one space.
SeparateLines | The formatter will adjust any whitespace such that each attribute is on a separate line.

Element Spacing Mode

The XmlTextFormatter has an ElementSpacingMode property that can be set to alter the behavior of the formatter when dealing with whitespace in element content. The XmlElementSpacingMode enumeration defines these three mode options:

Mode | Formatter Behavior
Preserve | The formatter will not make changes to the whitespace in element content. This is the default mode.
NormalizeEmptyLines | The formatter will adjust any whitespace around element content so that there is no more than a single empty line between the content and the containing element.
RemoveEmptyLines | The formatter will remove extra whitespace around element content. The actual result depends on the type of content, which can be text-only, one or more elements, or mixed content.

Tag Wrap Length

The XmlTextFormatter has a TagWrapLength property that can be set to cause the formatter to wrap an attribute to the next line when the element length on a particular line exceeds the specified length. This feature will operate regardless of the AttributeSpacingMode.

Setting the value to 0 (zero) will disable the feature, which is the default value. When enabling this wrap feature, a common setting is 120.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Context

Web Languages Add-on - XML Language
Context

The XML language can return detailed context information about any offset in a document. The context includes data such as declared namespaces, containing element hierarchy, current element/attribute, and more. This sort of information is essential in determining what to display in automated IntelliPrompt.

This topic contains these sections:

  • Obtaining Context Information
  • XML Context
  • Element Context
  • Attribute Context

Obtaining Context Information

Context information can be retrieved via the use of the XmlContextFactory class. Its CreateContext method accepts a TextSnapshotOffset and returns the IXmlContext for that offset.

This code retrieves an IXmlContext for the caret's offset (the end selection offset in the active view):

C#
VB
Copy
​TextSnapshotOffset snapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset;
IXmlContext context = new XmlContextFactory().CreateContext(snapshotOffset);
​Dim snapshotOffset As TextSnapshotOffset = syntaxEditor.ActiveView.Selection.EndSnapshotOffset
Dim context As IXmlContext = New XmlContextFactory().CreateContext(snapshotOffset)

XML Context

IXmlContext objects provide XML-related context information for a specific snapshot offset, such as the element hierarchy that contains the offset, the available namespace declarations, current element/attribute, and more.

These IXmlContext members are important:

Member | Description
ElementHierarchy Property | Gets a read-only list of IXmlElementContext objects that describes the element hierarchy. The element hierarchy is the list of parent elements that contain the current offset.
InitializationSnapshotRange Property | Gets the TextSnapshotRange with which the context was initialized.
NamespaceDeclarations Property | Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context. The dictionary keys are namespaces and the values are namespace prefixes.
SchemaResolver Property | Gets the IXmlSchemaResolver to use.
SnapshotOffset Property | Gets the TextSnapshotOffset for which this context was created.
TargetAttribute Property | Gets the IXmlAttributeContext that contains context information related to the target attribute. This property is only populated if the context is related to an attribute.
TargetElement Property | Gets the IXmlElementContext that contains context information related to the target element. This property is only populated if the context is related to an element or attribute.
Type Property | Gets an XmlContextType that specifies the type of context.

Element Context

IXmlContext objects can return contextual data about XML elements via their ElementHierarchy and TargetElement properties. Both of these properties return objects of type IXmlElementContext that have element contextual information.

Element contexts contain their namespace/name information, included attributes, and various snapshot ranges.

These IXmlElementContext members are important:

Member | Description
Attributes Property | Gets the dictionary of attributes for this element. The dictionary keys are the attribute qualified names and the values are IXmlAttributeContext objects.
EndTagSnapshotRange Property | Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
Name Property | Gets the name of the element.
Namespace Property | Gets the namespace that defines the element.
NamespacePrefix Property | Gets the prefix of the namespace that defines the element.
QualifiedName Property | Gets the XmlQualifiedName that contains the element's qualified name.
StartTagNameSnapshotRange Property | Gets the TextSnapshotRange that specifies the range of the start tag name.

Attribute Context

IXmlAttributeContext objects specify contextual information about XML attributes. Instances are returned by the IXmlContext.TargetAttribute and IXmlElementContext.Attributes properties.

Attribute contexts contain their namespace/name information, owner element, and name snapshot range.

These IXmlAttributeContext members are important:

Member | Description
Element Property | Gets the IXmlElementContext upon which this attribute is located.
Name Property | Gets the name of the attribute.
NameSnapshotRange Property | Gets the TextSnapshotRange that specifies the range of the attribute name.
Namespace Property | Gets the namespace that defines the attribute.
NamespacePrefix Property | Gets the prefix of the namespace that defines the attribute.
QualifiedName Property | Gets the XmlQualifiedName that contains the attribute's qualified name.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

.NET Languages Add-on - XML Language
Automated IntelliPrompt

The XML language has built-in automated IntelliPrompt quick info features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Quick Info
  • Navigable Symbol Selector
  • Disabling Automated IntelliPrompt

Quick Info

IntelliPrompt quick info is the ability to display helpful tooltips when hovering over various identifiers in the code editor. When hovering over an identifier, the resolver attempts to determine what the identifier means, and the resulting information is presented in a quick info tip.

Detailed information is shown for elements and attributes.

IntelliPrompt quick info features are implemented by the XmlQuickInfoProvider language service.

Navigable Symbol Selector

The Navigable Symbol Selector is a control that generally sits above and is bound to a SyntaxEditor. It shows the elements and attributes that currently enclose or are nearest the caret, and allows the end user to select other elements/attributes within the same document via a dropdown, and to navigate to those members upon selection.

This control populates its symbol lists by the XmlNavigableSymbolProvider language service.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the XmlSyntaxLanguage that is created:

C#
VB
Copy
​var language = new XmlSyntaxLanguage();

// Disable quick info
language.UnregisterService<XmlQuickInfoProvider>();

// Disable navigable symbol provider
language.UnregisterService<INavigableSymbolProvider>();
​Dim language = New XmlSyntaxLanguage()

' Disable quick info
language.UnregisterService(Of XmlQuickInfoProvider)()

' Disable navigable symbol provider
language.UnregisterService(Of INavigableSymbolProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Web Languages Add-on - JavaScript Language
Overview

The advanced JavaScript syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider
  • Text Formatter
  • Automated IntelliPrompt

Features

The JavaScript language is packed with features, including:

  • Automated IntelliPrompt completion list.
  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Over 45 distinct AST node classes.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Line commenting.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.
  • Code fragment editing with full IntelliPrompt, such as editing a function body.
  • Optionally change the parser to parse expressions, statements, etc. instead of compilation units.

Licensing

Even though the Web Languages Add-on is distributed and demoed with the Universal Windows controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the JavaScript language from the Web Languages Add-on, implemented by the JavaScriptSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and automated IntelliPrompt.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The JavaScript language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

See the Text Formatter topic for more information.

Automated IntelliPrompt

The JavaScript language has built-in automated IntelliPrompt completion list features that greatly enhance the end user's editing experience.

See the Automated IntelliPrompt topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Web Languages Add-on - JavaScript Language
Getting Started

This topic covers how to get started using the JavaScript language from the Web Languages Add-on, implemented by the JavaScriptSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and code outlining.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the JavaScriptSyntaxLanguage
  • Use the JavaScriptSyntaxLanguage
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the JavaScriptSyntaxLanguage

The next step is to create an instance of the JavaScriptSyntaxLanguage class.

This code creates a JavaScriptSyntaxLanguage:

C#
VB
Copy
​var language = new JavaScriptSyntaxLanguage();
​Dim language As New JavaScriptSyntaxLanguage()

Use the JavaScriptSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing JavaScript code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your JavaScriptSyntaxLanguage instance among all the documents in your application that are editing JavaScript code. This saves on overall memory usage and reduces load times.

Assembly Requirements

The following list indicates the assemblies that are used with the JavaScript syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for Universal Windows
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.JavaScript.Universal.dll | Yes | Actipro | Web Languages Add-on | Core text/parsing for the JavaScript and JSON languages
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Universal.dll | Yes | Actipro | Web Languages Add-on | SyntaxEditor for Universal Windows advanced JavaScript and JSON syntax language implementations

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

Web Languages Add-on - JavaScript Language
Parsing and Parse Data

The JavaScript language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String
  • Grammar Options

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Grammar Options

The JavaScript grammar (JavaScriptGrammar class) constructor can be passed an IJavaScriptGrammarOptions object that indicates options for the grammar's creation. The JavaScriptGrammarOptions class implements this interface.

Root Non-Terminal

The default options indicate that compilation unit should be the root non-terminal for the grammar. However this can be altered via the IJavaScriptGrammarOptions.RootNonTerminal property. The JavaScriptGrammarRootNonTerminal enumeration has a number of options for a root non-terminal, everything from expressions to statements.

Use this code to alter the root non-terminal for the grammar so that it tries to parse a single expression instead of a compilation unit:

C#
VB
Copy
​JavaScriptSyntaxLanguage language = new JavaScriptSyntaxLanguage();

JavaScriptGrammarOptions grammarOptions = new JavaScriptGrammarOptions();
grammarOptions.RootNonTerminal = JavaScriptGrammarRootNonTerminal.Expression;

JavaScriptGrammar grammar = new JavaScriptGrammar(grammarOptions);
language.RegisterParser(new JavaScriptParser(grammar));
​Dim language As New JavaScriptSyntaxLanguage()

Dim grammarOptions As New JavaScriptGrammarOptions()
grammarOptions.RootNonTerminal = JavaScriptGrammarRootNonTerminal.Expression

Dim grammar As New JavaScriptGrammar(grammarOptions)
language.RegisterParser(New JavaScriptParser(grammar))

Note Note
The SyntaxLanguageExtensions.RegisterParser method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

Web Languages Add-on - JavaScript Language
Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The JavaScriptIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a { will cause the next line to be indented by one tab stop. Pressing ENTER while still typing a statement will also attempt to indent the next line by one tab stop.

Typed Characters

When certain characters such as {, }, or : are typed, the line will be examined to see if it should be indented/outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The JavaScriptSyntaxLanguage class automatically registers a JavaScriptIndentProvider with itself when it is created, so normally indent providers never need to be set on a JavaScript language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomJavaScriptIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomJavaScriptIndentProvider());
​language.RegisterIndentProvider(New CustomJavaScriptIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JavaScriptSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

Web Languages Add-on - JavaScript Language
Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The JavaScriptTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Opening Curly Braces on New Line

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The JavaScriptSyntaxLanguage class automatically registers a JavaScriptTextFormatter with itself when it is created, so normally text formatters never need to be set on a JavaScript language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomJavaScriptTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomJavaScriptTextFormatter());
​language.RegisterTextFormatter(New CustomJavaScriptTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JavaScriptSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Opening Curly Braces on New Line

The JavaScriptTextFormatter.IsOpeningBraceOnNewLine property can be used to determine whether opening curly braces appear on a new line.

It defaults to false, but can be changed to true to cause opening curly braces to move to the next line.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Automated IntelliPrompt

Web Languages Add-on - JavaScript Language
Automated IntelliPrompt

The JavaScript language has built-in automated IntelliPrompt completion list features that greatly enhance the end user's editing experience.

This topic contains these sections:

  • Completion List
  • Disabling Automated IntelliPrompt

Completion List

IntelliPrompt completion lists are used to present end users with a list of accessible members from the code editor's current caret location. The completion list is triggered by key events such as pressing Ctrl+Space.

The JavaScript completion list is relatively simplistic in its implementation. It will present a list of JavaScript keywords, along with identifiers that have been defined in the document. Note that the identifiers listed do not account for their scope within the document. As the end user types, the list is filtered down to only show matched items. Both acronym and shorthand item matchers are enabled.

The completion list features are implemented by the JavaScriptCompletionProvider class.

Disabling Automated IntelliPrompt

Automated IntelliPrompt features can be easily turned off for a language by unregistering the appropriate services that are installed by default.

This code disables IntelliPrompt features on the JavaScriptSyntaxLanguage that is created:

C#
VB
Copy
​var language = new JavaScriptSyntaxLanguage();

// Disable completion lists
language.UnregisterService<JavaScriptCompletionProvider>();
​Dim language = New JavaScriptSyntaxLanguage()

' Disable completion lists
language.UnregisterService(Of JavaScriptCompletionProvider)()

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Web Languages Add-on - JSON Language
Overview

The advanced JSON syntax language implementation in the SyntaxEditor Web Languages Add-on includes everything from code outlining to syntax error reporting.

This topic contains these sections:

  • Features
  • Licensing
  • Getting Started
  • Parsing and Parse Data
  • Indent Provider

Features

The JSON language is packed with features, including:

  • Syntax highlighting.
  • Abstract syntax tree (AST) generation.
  • Automatic code outlining based on AST structure.
  • Reporting and automatic squiggle display of errors for invalid syntax.
  • Mouse hover quick info for syntax errors.
  • Smart indent.
  • Text formatting.
  • Code block selection.
  • Delimiter (bracket) highlighting and auto-completion.

Licensing

Even though the Web Languages Add-on is distributed and demoed with the Universal Windows controls, it is optional and is sold separately from SyntaxEditor and any containing bundles. The pricing on the add-on is very cheap and licenses are all Enterprise licenses, meaning they cover your entire organization.

See the Assemblies and Add-on Licensing topic for more information.

Getting Started

This topic covers how to get started using the JSON language from the Web Languages Add-on, implemented by the JsonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

See the Getting Started topic for more information.

Parsing and Parse Data

The JSON language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

See the Parsing and Parse Data topic for more information.

Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

See the Indent Provider topic for more information.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Web Languages Add-on - JSON Language
Getting Started

This topic covers how to get started using the JSON language from the Web Languages Add-on, implemented by the JsonSyntaxLanguage class, and lists its requirements for supporting advanced features like parsing and code outlining.

It is very important to follow the steps in this topic to configure the language correctly so that its advanced features operate as expected.

This topic contains these sections:

  • Configure the Ambient Parse Request Dispatcher
  • Configure the JsonSyntaxLanguage
  • Use the JsonSyntaxLanguage
  • Assembly Requirements

Configure the Ambient Parse Request Dispatcher

The language's parser does a lot of processing when text changes occur. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up a parse request dispatcher for your application.

The ambient parse request dispatcher should be set up in your application startup code as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnStartup(StartupEventArgs e) {
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = new TaskBasedParseRequestDispatcher();
    ...
}
​Protected Overrides Sub OnStartup(ByVal e As StartupEventArgs)
    ...
    AmbientParseRequestDispatcherProvider.Dispatcher = New TaskBasedParseRequestDispatcher()
    ...
End Sub

Likewise it should be shut down on application exit, also as described in the Parse Requests and Dispatchers topic.

C#
VB
Copy
​protected override void OnExit(ExitEventArgs e) {
    ...
    var dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher;
    if (dispatcher != null) {
        AmbientParseRequestDispatcherProvider.Dispatcher = null;
        dispatcher.Dispose();
    }
    ...
}
​Protected Overrides Sub OnExit(ByVal e As ExitEventArgs)
    ...
    Dim dispatcher = AmbientParseRequestDispatcherProvider.Dispatcher
    If dispatcher IsNot Nothing Then
        AmbientParseRequestDispatcherProvider.Dispatcher = Nothing
        dispatcher.Dispose()
    End If
    ...
End Sub

Note Note
Failure to set up an ambient parse request dispatcher when using the language will result in unnecessary UI slowdown since parse operations will be performed in the UI thread instead of in a worker thread.

Configure the JsonSyntaxLanguage

The next step is to create an instance of the JsonSyntaxLanguage class.

This code creates a JsonSyntaxLanguage:

C#
VB
Copy
​var language = new JsonSyntaxLanguage();
​Dim language As New JsonSyntaxLanguage()

Use the JsonSyntaxLanguage

Next, use the language on the ICodeDocument instances that will be editing JSON code.

This code applies the language to a document in a SyntaxEditor, whose instance is in the editor variable:

C#
VB
Copy
​editor.Document.Language = language;
​editor.Document.Language = language

Note Note
We recommend reusing your JsonSyntaxLanguage instance among all the documents in your application that are editing JSON code. This saves on overall memory usage and reduces load times.

Assembly Requirements

The following list indicates the assemblies that are used with the JSON syntax language implementation in this add-on.

Assembly | Required | Author | Licensed With | Description
ActiproSoftware.Text.Universal.dll | Yes | Actipro | SyntaxEditor | Core text/parsing framework for Universal Windows
ActiproSoftware.Text.LLParser.Universal.dll | Yes | Actipro | SyntaxEditor | LL parser framework implementation
ActiproSoftware.Shared.Universal.dll | Yes | Actipro | SyntaxEditor | Core framework for all Actipro Universal Windows controls
ActiproSoftware.SyntaxEditor.Universal.dll | Yes | Actipro | SyntaxEditor | SyntaxEditor for Universal Windows control
ActiproSoftware.Text.Addons.JavaScript.Universal.dll | Yes | Actipro | Web Languages Add-on | Core text/parsing for the JavaScript and JSON languages
ActiproSoftware.SyntaxEditor.Addons.JavaScript.Universal.dll | Yes | Actipro | Web Languages Add-on | SyntaxEditor for Universal Windows advanced JavaScript and JSON syntax language implementations

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Parsing and Parse Data

Web Languages Add-on - JSON Language
Parsing and Parse Data

The JSON language uses an advanced parser that has been constructed using the Actipro LL(*) Parser Framework, and provides functionality for building ASTs, reporting parse errors, and more.

The ILLParseData results returned by this parser are consumed by multiple other features of the language, such as code outlining, parse error display, etc.

This topic contains these sections:

  • AST Construction
  • Parse Errors
  • Retrieving Parse Data
  • Parsing a Text String

AST Construction

A complete AST of parsed documents is generated by the parser, comprised of the various type-specific AST nodes created for this language. It is passed back in the ILLParseData.Ast property.

The AST node classes are all defined in the Implementation namespace, while related enumerations and intefaces are defined in the Ast namespace.

Parse Errors

Parse errors are reported from the parser. They are passed back in the ILLParseData.Errors property.

The parser reports errors as it performs syntax and semantic analysis of document text.

When the language is used in a SyntaxEditor control, the parse errors will have squiggle lines under them and mouse hovering over the squiggle lines will show IntelliPrompt quick info tips with error descriptions.

Parse errors can also be consumed by applications that wish to show the parse errors in a tool window.

Retrieving Parse Data

As long as an ambient parse request dispatcher has been set up, all parsing and validation is performed in a worker thread. The processing occurs after any text changes are made to documents using the language. Since the work occurs in a worker thread, the results are returned asynchronously and may not be in perfect sync with the document text. Although since the parse data includes the ITextSnapshot instance that was parsed, if known, you can easily translate offsets from the parse data snapshot to the current snapshot in a SyntaxEditor view or document.

Once a parsing operation completes, the ILLParseData results are placed into the ParseData property of the document that was parsed and its ParseDataChanged event fires. The latest parse data results can be obtained at any time from that property.

See the Parsers topic for more detailed information on the parsing workflow and parse data.

Parsing a Text String

See the Parsers for details on how to easily parse a text string using a language's parser, such as this one.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Indent Provider

Web Languages Add-on - JSON Language
Indent Provider

An indent provider enables support for smart indent features when pressing ENTER.

The Indent Providers topic talks about indent providers in general and how to register them as a "feature" language service.

The JsonIndentProvider class is the default implementation of an IIndentProvider service for this language.

This topic contains these sections:

  • Feature Summary
  • Registering with a Syntax Language
  • Disabling the Functionality

Feature Summary

Smart Indent

The built-in indent provider will attempt to properly indent lines inside the current block scope. For instance, pressing ENTER after a { will cause the next line to be indented by one tab stop.

Typed Characters

When certain characters such as {, }, [ or ] are typed, the line will be examined to see if it should be indented/outdented.

Registering with a Syntax Language

Any object that implements IIndentProvider can be associated with a syntax language by registering it as an IIndentProvider service on the language.

The JsonSyntaxLanguage class automatically registers a JsonIndentProvider with itself when it is created, so normally indent providers never need to be set on a JSON language unless a custom one is made.

This code creates a custom indent provider (defined in a make-believe CustomJsonIndentProvider class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterIndentProvider(new CustomJsonIndentProvider());
​language.RegisterIndentProvider(New CustomJsonIndentProvider())

Note Note
The SyntaxLanguageExtensions.RegisterIndentProvider method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JsonSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Text Formatter

Web Languages Add-on - JSON Language
Text Formatter

The built-in text formatter can adjust whitespace between code elements to make code more readable.

The Text Formatting topic talks about text formatters in general and how to register them as a "feature" language service.

The JsonTextFormatter class is the default implementation of an ITextFormatter service for this language.

This topic contains these sections:

  • Registering with a Syntax Language
  • Disabling the Functionality
  • Opening Braces on New Line

Registering with a Syntax Language

Any object that implements ITextFormatter can be associated with a syntax language by registering it as an ITextFormatter service on the language.

The JsonSyntaxLanguage class automatically registers a JsonTextFormatter with itself when it is created, so normally text formatters never need to be set on a JSON language unless a custom one is made.

This code creates a custom text formatter (defined in a make-believe CustomJsonTextFormatter class) and registers it with the syntax language that is already declared in the language variable:

C#
VB
Copy
​language.RegisterTextFormatter(new CustomJsonTextFormatter());
​language.RegisterTextFormatter(New CustomJsonTextFormatter())

Note Note
The SyntaxLanguageExtensions.RegisterTextFormatter method in the code snippet above is a helper extension method that gets added to ISyntaxLanguage objects when the ActiproSoftware.Text namespace is imported. See the Service Locator Architecture topic for details on registering and retrieving various service object instances, both via extension methods and generically, as there are some additional requirements for using the extension methods.

Disabling the Functionality

Since this feature is installed as a "feature" service on the language and is installed on JsonSyntaxLanguage by default, it can be disabled by uninstalling the service from the language.

Opening Braces on New Line

The JsonTextFormatter.IsOpeningBraceOnNewLine property can be used to determine whether opening braces appear on a new line after a colon.

It defaults to false, but can be changed to true to cause opening braces to move to the next line after a colon.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

Web Languages Add-on
Troubleshooting

This topic provides answers to common questions and problems related to the add-on.

This topic contains these sections:

  • How Do I Get Started With XML Language?
  • Typing Is Slow

How Do I Get Started With XML Language?

The Getting Started topic walks through all the requirements for using the XML language. Be sure to follow all the steps in that topic so that the syntax language operates correctly.

Typing Is Slow

If you notice a lag when typing, it is likely due to an ambient parse request dispatcher not being set up. Each time text changes occur, such as while typing, a parse request is fired off for the parser to parse the document. To ensure that these parsing operations are offloaded into a worker thread that won't affect the UI performance, you must set up an ambient parse request dispatcher for your application.

When no ambient parse request dispatcher has been configured for your application, the parsing will occur in the main UI thread, thus severely affecting typing performance, especially in larger documents.

See the Getting Started topic for more information on how to set up an ambient parse request dispatcher for your application.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

SyntaxEditor Reference
Designer Interaction

SyntaxEditor has designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to setup the SyntaxEditor.

Note Note
Visual Studio and Expression Blend support a rich design experience, and support all the features described below.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Task Pane Introduction
  • SyntaxEditor Task Pane
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Task Pane Introduction

Whenever you select a SyntaxEditor control in the designer, a task pane adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

SyntaxEditor Task Pane

The SyntaxEditor task pane allows you to quickly configure many of the most common options, which are orgnaized into three categories.

Tip Tip
Several items include a blue information icon, which uses a tool-tip to provide more information about the associated item.

General

The general settings affect the behavior or feel of the control. Several options are available in the expandable sections at the bottom.

The General tab of the task pane for the SyntaxEditor

View

The general settings affect the view or look of the control. Several options are available in the expandable sections at the bottom.

The View tab of the task pane for the SyntaxEditor

Document

The general settings affect the document, or underlying data, of the control. Several options are available in the expandable sections at the bottom.

Note Note
When using the "Create new document" link, you must manually add xml:space="preserve" to the EditorDocument element, if setting the initial text/content. Addtionally, the text should be wrapped with a CDATA element to further preserve the whitespace.

The Document tab of the task pane for the SyntaxEditor

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Views Reference
Overview

The Views library includes a TaskBoard control that makes it easy to add interactive task scheduling and prioritization to your apps. A task board consists of zero to many columns, each of which can contain zero to many cards. Columns and cards can be dragged around and reordered, all using pleasing sway animations.

The TaskBoard control in a task planning usage scenario

Features

TaskBoard Control

  • Designed for use in MVVM environments, with easy data binding.
  • Numerous properties for altering the styles/templates of columns and cards.
  • Display board footer content after the last column.
  • Display header/footer content surrounding the cards in a column.
  • Optional column and card dragging with pleasing sway animations.
  • Cancelable events when the dragging of a column/card starts and dropping completes.
  • Card tap notification events.
  • Touch-friendly interactions.
  • Hit test for columns and cards.

This product is written in 100% pure C#, and includes detailed documentation and samples.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Getting Started

Views Reference
Getting Started

Getting started with Views is simple. Follow the steps below to build your first task board.

This topic contains these sections:

  • Add Extension SDK Reference
  • Create a TaskBoard
  • Further Study

Add Extension SDK Reference

In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" and add the "Actipro Universal Windows Controls" SDK to your project. This process is described in further detail in the References and Deployment topic.

Create a TaskBoard

Then find the parent element that will contain the control. This could be a UserControl or any other type of UIElement.

Next, add a TaskBoard control to the desired parent element.

XAML
Copy
​<UserControl
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:views="using:ActiproSoftware.UI.Xaml.Controls.Views">
    <views:TaskBoard ItemsSource="{Binding Lists}" ColumnItemsSourcePath="Tasks">
        <views:TaskBoard.ItemContainerStyle>
            <Style TargetType="views:TaskColumn">
                <Setter Property="Width" Value="260" />
            </Style>
        </views:TaskBoard.ItemContainerStyle>
        <views:TaskBoard.ItemTemplate>
            <DataTemplate>
                <TextBlock Margin="10,5" Text="{Binding Name}" FontWeight="Bold" />
            </DataTemplate>
        </views:TaskBoard.ItemTemplate>
        <views:TaskBoard.CardTemplate>
            <DataTemplate>
                <TextBlock Text="{Binding Name}" />
            </DataTemplate>
        </views:TaskBoard.CardTemplate>
    </views:TaskBoard>
</UserControl>

The above XAML assumes you have a DataContext in place that has a Lists collection where each item has a Name property, and each list has a Tasks collection where each task also has a Name property.

Finally, configure the control's style and template properties further to give the control the appearance you're after. Interactive controls like buttons can even be added within the various column and card templates. See the TaskBoard topic for more in-depth detail.

Further Study

To familiarize yourself with all of the features in Views, take a look at the feature documentation and also look at the numerous QuickStarts located in the sample project.

If you require further assistance after looking through those, please visit our Views support forum.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Views Reference - Controls
Overview

This topic contains these sections:

  • TaskBoard

TaskBoard

The TaskBoard control makes it easy to add interactive task scheduling and prioritization to your apps. A task board consists of zero to many columns, each of which can contain zero to many cards. Columns and cards can be dragged around and reordered, all using pleasing sway animations.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TaskBoard

Views Reference - Controls
TaskBoard

The TaskBoard control makes it easy to add interactive task scheduling and prioritization to your apps. A task board consists of zero to many columns, each of which can contain zero to many cards. Columns and cards can be dragged around and reordered, all using pleasing sway animations.

This topic contains these sections:

  • Data Binding
  • Customizing the Appearance
  • Animated Drag Reordering
  • Card Tap Notifications
  • Hit Testing
  • Sample Usage

Data Binding

The task board has been designed specifically to work with MVVM environments. The root TaskBoard control is an ItemsControl, and thus its ItemsSource property should be bound to a collection property, which will be used to generate the board's columns.

The TaskColumn control is also an ItemsControl, and its ItemsSource should be bound to a collection property on the data item used for each column. This collection property will be used to generate the column's cards. Since the column is nested within the board as a second-level control, the property to bind to for card data can be set via the TaskBoard.ColumnItemsSourcePath property. This is a string value that indicates the property name on the data item.

Customizing the Appearance

As described above, the task board is meant to be data-driven. It provides a number of Style, DataTemplate, etc. properties that allow for complete customization of how the board renders and what UI is available. Any interactive controls, such as buttons, can be placed within a DataTemplate to support advanced functionality like popups within the cards. By using a DataTemplateSelector, different appearances can be supplied for cards depending on the data item.

Each task board renders its columns in a horizontal layout, followed by an optional board footer. A task planning app might put an "Add a list" button in the board footer template. Each column renders a header at the top, typically displaying a bold title. The vertical list of cards within the column renders under the header. This is followed by an optional column footer. A task planning app mgiht put an "Add a task" button in the column footer template.

These properties on TaskBoard allow for appearance customization:

Member | Description
CardContainerStyle Property | The Style to use for card containers.
CardContainerStyleSelector Property | The StyleSelector to use for card containers.
CardCornerRadius Property | The card corner radius. The default value is 3.0.
CardSpacing Property | The spacing between cards. The default value is 7.0.
CardTemplate Property | The DataTemplate to use for cards.
CardTemplateSelector Property | The DataTemplateSelector to use for cards.
ColumnCornerRadius Property | The column corner radius. The default value is 3.0.
ColumnPadding Property | The column padding. The default value is 7.0.
ColumnSpacing Property | The spacing between columns. The default value is 10.0.
FooterTemplate Property | The DataTemplate to use for a footer.
ItemFooterTemplate Property | The DataTemplate to use for column footers.
ItemFooterTemplateSelector Property | The DataTemplateSelector to use for column footers.
ItemHeaderTemplate Property | The DataTemplate to use for column headers.
ItemHeaderTemplateSelector Property | The DataTemplateSelector to use for column headers.

Animated Drag Reordering

The task board uses smooth sway animations to help convey that a column or card is dragging. The maximum degrees that a column or card can rotate is based on the TaskBoard.ColumnDragRotationAngle and CardDragRotationAngle properties respectively. Both default to 3.0 but can be altered as needed. Set them to 0.0 to prevent swaying.

Column and card dragging to reorder is enabled by default as long as the source data item collections implement IList. Set the TaskBoard.CanColumnsDrag and CanCardsDrag properties to false to prevent dragging of columns/cards altogether.

Note that when using touch to drag a column or card, you must first hold your finger down on the column/card for at least a quarter second before moving it. Otherwise, if you touch down and immediately drag, the control will think you are trying to scroll the control.

When dragging is enabled, an event is raised whenever a drag is initiated. Columns raise the TaskBoard.ColumnDragging event and cards raise the CardDragging event. Both of these events support blocking the drag by setting the event arguments' e.Cancel property to true. Logic for setting it can be done on an individual data item basis via these events.

When a drag is completed, columns raise the TaskBoard.ColumnDropped event and cards raise the CardDropped event. The event includes arguments that tell the old and new locations of the droped column/card. The drop can also be canceled by setting e.Cancel to true on the event arguments.

Card Tap Notifications

When a card is tapped, the TaskBoard.CardTapped event is raised.

Hit Testing

Sometimes it's handy to be able to hit test for a card or column that is at a certain location. Perhaps the app is watching for certain hotkeys to be pressed and needs to know which card is under the mouse. This is a scenario where hit testing is needed.

The TaskBoard.HitTestForColumn method takes a TaskBoard-relative location and returns the TaskColumn under that location, if any.

The TaskColumn.HitTestForCard method takes a TaskColumn-relative location and returns the TaskCard under that location, if any.

By using both those methods, it's possible to determine which card is at a certain point location.

Sample Usage

This basic XAML shows how to create the basic appearance for the Task Planning demo, whose complete source is in the sample project.

XAML
Copy
​<views:TaskBoard x:Name="taskBoard" ItemsSource="{Binding Lists}" ColumnItemsSourcePath="Tasks"
                    Padding="15" ColumnSpacing="15" ColumnPadding="10" FontSize="14">
    <views:TaskBoard.ItemContainerStyle>
        <Style TargetType="views:TaskColumn">
            <Setter Property="Background" Value="#80ffffff" />
            <Setter Property="BorderThickness" Value="0" />
            <Setter Property="Foreground" Value="#202020" />
            <Setter Property="Width" Value="260" />
        </Style>
    </views:TaskBoard.ItemContainerStyle>
    <views:TaskBoard.ItemHeaderTemplate>
        <DataTemplate>
            <sample:ColumnHeaderControl />
        </DataTemplate>
    </views:TaskBoard.ItemHeaderTemplate>
    <views:TaskBoard.CardContainerStyle>
        <Style TargetType="views:TaskCard">
            <Setter Property="Background" Value="#ffffff" />
            <Setter Property="BorderThickness" Value="0" />
            <Setter Property="Foreground" Value="#404040" />
        </Style>
    </views:TaskBoard.CardContainerStyle>
    <views:TaskBoard.CardTemplate>
        <DataTemplate>
            <sample:CardContentControl />
        </DataTemplate>
    </views:TaskBoard.CardTemplate>
    <views:TaskBoard.ItemFooterTemplate>
        <DataTemplate>
            <sample:AddTaskControl />
        </DataTemplate>
    </views:TaskBoard.ItemFooterTemplate>
    <views:TaskBoard.FooterTemplate>
        <DataTemplate>
            <sample:AddListControl Width="260" VerticalAlignment="Top" />
        </DataTemplate>
    </views:TaskBoard.FooterTemplate>
</views:TaskBoard>

Some of the data templates above reference other UserControl objects that are defined in the full sample source.

In this example, the root DataContext is a TaskBoardModel instance, which has a Lists collection property used to define the columns. The TaskListModel class has a Tasks collection property (referenced by the ColumnItemsSourcePath property in the XAML) used to define the cards in each column.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Shared Library Reference
Overview

The Actipro Shared library contains a number of useful controls and components that can be reused in your applications.

ActiproSoftware.UI.Xaml.Controls Namespace (Miscellaneous Controls)

This namespace contains various user interface controls that may be used in your applications.

See the Controls topic for information on the controls.

ActiproSoftware.UI.Xaml.Media Namespace (UIColor, VisualTreeHelperExtended)

This namespace has a UIColor structure that has a lot of helper methods for working with colors and a VisualTreeHelperExtended class that adds some useful methods that aren't in the core VisualTreeHelper class.

See the Media topic for information on these helper classes.

ActiproSoftware.UI.Xaml.Shapes Namespace (Shapes)

This namespace contains various primitive shapes that may be used in your UI.

See the Shapes topic for information on the shapes.

Value Converters

The Shared Library comes packed with numerous useful value converters that can be used with XAML bindings.

See the Value Converters topic for information on the value converters.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Shared Library Reference - Controls
Overview

The Controls namespace contains various user interface controls that may be used in your applications.

AppBarHint

The AppBarHint control makes it easy to inject an ellipses (three dot) area at the bottom of an app page that can be tapped by the end user to display the page's app bars.

EditableContentControl

The EditableContentControl control is a standard ContentControl, which also features an alternate editing mode that can be toggled to display a TextBox for editing a string.

HorizontalListBox

The HorizontalListBox control is a restyled native ListBox that arranges its items in a uniform width horizontally, and without a ScrollBar.

RadialSlider

The RadialSlider control is a circular slider that allows for quick selection of a degree value, which can easily be converted to some form of scalar value.

RingSlice

The RingSlice control renders a portion (or the entire circle) of a ring shape. Its start/end angles, radius, thickness, and other stroke properties can be set.

TransitioningContentPresenter

The TransitioningContentPresenter control supports fast and fluid animated transitions between two objects. These content transitions can be anything from a simple fade to a push. The content transition classes are extensible and provide the foundation for transitions in some of our other controls.

UniformGrid

The UniformGrid control arranges content in a grid where all the cells in the grid have the same size.

The panel can auto-calculate the number of rows and columns that are necessary, or the rows/columns can optionally be specified.

WrapPanel

The WrapPanel control positions child elements in sequential order, breaking content to the next line at the edge of the containing box.

Progress Spinners

Progress Spinners are used when some form of processing is occurring to tell the end user that something is happening.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


EditableContentControl

Shared Library Reference - Controls
EditableContentControl

The EditableContentControl control is a standard ContentControl, which also features an alternate editing mode that can be toggled to display a TextBox for editing a string.

When entering edit mode, the Content property value is copied to the EditableContent property, and the UI switches to a TextBox for editing the editable content. Note that an alternate template could be provided for the control to support an editor other than a TextBox.

While in editing mode, pressing Enter or moving focus out of the control will commit the value. This has the effect of copying the EditableContent property value back over to Content. If Esc is pressed while editing, the value is not committed.

The EditableContentControl class has these important members:

Member | Description
EditableContent Property | Gets or sets the content being edited. This property is for internal use only.
IsEditing Property | Gets or sets whether the content is currently being edited. This property toggles the UI of the control between display and edit modes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


HorizontalListBox

Shared Library Reference - Controls
HorizontalListBox

The HorizontalListBox control is a restyled native ListBox that arranges its items in a uniform width horizontally, and without a ScrollBar.

A HorizontalListBox providing selection between two options.

Since the control inherits ListBox, all features found on the native ListBox can also be used, such as single or multiple selection modes.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RadialSlider

Shared Library Reference - Controls
RadialSlider

The RadialSlider control is a circular slider that allows for quick selection of a degree value, which can easily be converted to some form of scalar value.

Radial sliders function just like normal linear sliders however instead of moving the slider thumb in a straight line, the thumb can move in a circular fashion around the slider's center point. This sort of UI allows for additional precision when compared to linear sliders, especially with touch interaction.

Radial sliders are often paired with RingSlice controls, which are designed to render the main UI for radial slider tracks and values.

A RadialSlider that uses RingSlice controls for rendering of the track and value.

RadialSlider supports minimum/maximum ranges, infinite wrapping mode, customizable thumb styles, and more. While the control is ideal for touch-based input, it also fully accepts mouse and keyboard input. Combine two RadialSlider controls on top of each other to enable range-based selection.

This topic contains these sections:

  • Values
  • Input and Value Snapping
  • Conversion to Scalar Values
  • Range Constraints and Wrapping
  • Radius
  • Customizing the Thumb
  • Combining Multiple Sliders

Values

Values in the RadialSlider are expressed in terms of degrees, where 0 is upward and the degree values increase as they go clockwise, meaning 90 degrees is to the right.

There are two value properties exposed by this control. The first is the Value property, which inherits from RangeBase. This property contains the final 'snapped' degree value as the radial slider is interacted with by the end user. The second is IntermediateValue, which is the exact degree value as the radial slider is interacted with by the end user. They generally will be the same value however they can be different in cases where the user is dragging the slider's thumb off of a snap point (see below).

Input and Value Snapping

The slider is designed to accept all forms of input (touch, mouse, and keyboard). The SmallChange and LargeChange properties (inherited from RangeBase) specify degree values and dictate the interaction behavior with the slider.

A RadialSlider that has snapping enabled and makes use of multiple RingSlice controls to render the snap points.

Dragging

When dragging the slider's thumb via touch or mouse, the Value property will snap to the closest SmallChange interval, while the IntermediateValue will be directly under the drag location. When the thumb is released, it will animate IntermediateValue over to the Value property.

Mouse Wheel

When turning the mouse wheel, the slider's value will increment/decrement by the LargeChange value.

Keyboard

These keys are supported for keyboard input:

  • Up - Increment by SmallChange.
  • Down - Decrement by SmallChange.
  • PageUp - Increment by LargeChange.
  • PageDown - Decrement by LargeChange.
  • Home - Change directly to Minimum.
  • End - Change directly to Maximum.

Conversion to Scalar Values

While the slider's value are always represented in degrees, they can easily be converted to any scalar value via the use of a value converter.

In this example, a slider is set to snap at 30 degree increments and a TextBlock in the middle of it is bound to the value. But instead of displaying a degree value, the value converter divides the degree value by the degree increment (30) and displays the result, which is a value in the range of 0 to 11.

XAML
Copy
​<controls:RadialSlider x:Name="snappingSlider2" Radius="100" Value="120" LargeChange="30" SmallChange="30" />
<TextBlock FontSize="28" HorizontalAlignment="Center" VerticalAlignment="Center"
    Text="{Binding ElementName=snappingSlider2, Path=Value, Converter={StaticResource DegreeToScalarConverter}, ConverterParameter=30.0}" />

While the converter above is a simple example, the degree value could be converted to a percentage or even a text label instead.

Range Constraints and Wrapping

The Minimum and Maximum properties (inherited from RangeBase) can be used to designate a degree range that can contain the Value. For instance, to achieve a semi-circle range that bows upward, you would specify a Minimum of 270 (leftward) and a Maximum of 450 (rightward). The slider values will not be allowed to pass outside of that range.

The default Minimum is 0 and Maximum is 360. These settings enable a special mode where the slider's value can wrap infinitely.

A RadialSlider that is constrained to a semi-circle.

Other ranges can allow for creative input scenarios too. A Minimum of -360 and a Maximum of 360 allow for a full circle rotation negative or positive. A Minimum of 0 and a Maximum of 1080 allow for three full circle rotations positive.

Radius

The RadialSlider.Radius property indicates the radius of the invisible track over which the thumb will rotate. A radius of 40 means the circle will be 80x80 in size.

Customizing the Thumb

The thumb, represented by the CircularThumb primitive control, is the only visible portion of the slider. It is what the end user interacts with and drags to change the slider's value.

These members on RadialSlider are related to altering the appearance of the thumb:

Member | Description
ThumbArrowAngle Property | Gets or sets the thumb's arrow angle. The default value is 180, meaning it will face down when up at 0 degrees in the slider.
ThumbBackground Property | Gets or sets the background Brush to render when the thumb is in a normal state.
ThumbPressedBackground Property | Gets or sets the background Brush to render when the thumb is pressed.
ThumbStyle Property | Gets or sets the Style to use for the thumb. Use this property if a custom thumb Style is desired.

Combining Multiple Sliders

Two RadialSlider controls that overlay each other.

Multiple sliders can be overlayed on top of each other. The sliders themselves are transparent and only their thumbs allow for interaction. This means that two sliders would render two separate thumbs, each of which can be interacted with separately, and can therefore be used to specify a range of values by the end user.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


RingSlice

Shared Library Reference - Controls
RingSlice

The RingSlice control renders a portion (or the entire circle) of a ring shape. Its start/end angles, radius, thickness, and other stroke properties can be set.

Several RingSlice controls combined to create an appealing radial graph.

Ring slice controls can be combined in many interesting ways within UI, including being used to represent the 'track' or value of a RadialSlider, used to create segmented progress indicators, etc.

This topic contains these sections:

  • Angles, Radius, and Thickness
  • Other Stroke Properties
  • Entire Circle

Angles, Radius, and Thickness

The control renders a ring slice between two angles, specified in degrees, where 0 is upward and the degree values increase as they go clockwise, meaning 90 degrees is to the right. To render a quarter circle ring from the top to the right, use a StartAngle of 0 and an EndAngle of 90.

Several RingSlice controls used to render a four-step circular progress indicator.

The control also has two properties that control its radius and thickness. The Radius property specifies the outer radius of the ring. The StrokeThickness property specifies the thickness of the ring, extending inward from the outer radius.

Tip Tip
Use an StrokeThickness value that is the same as the Radius to render a pie slice.

Other Stroke Properties

RingSlice also supports all of the standard stroke properties found on a shape control. This includes setting start/end/dash caps to achieve circular, triangle, etc. line ends, or setting properties to renders dashed lines.

Entire Circle

When the StartAngle and EndAngle are the same value, the ring slice will by default render a full circular ring. the IsRenderedWhenFullCircle property can be set to false to disable this behavior. When set to false and the angles are the same, nothing will be rendered.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


TransitioningContentPresenter

Shared Library Reference - Controls
TransitioningContentPresenter

The TransitioningContentPresenter control supports fast and fluid animated transitions between two objects. These content transitions can be anything from a simple fade to a push. The content transition classes are extensible and provide the foundation for transitions in some of our other controls.

This topic contains these sections:

  • Using the TransitioningContentPresenter Control
  • Built-In Transitions

Using the TransitioningContentPresenter Control

The TransitioningContentPresenter control coordinates transitions between two contents, a "from" content and a "to" content. The contents may be any object type and can optionally use a DataTemplate to build the user interface for the objects.

Only one content can be displayed in the presenter, although as a new content is selected, it is transitioned in based on the transition that is currently assigned to the presenter.

This XAML code shows how to assign a specific IContentTransition to the presenter via the TransitioningContentPresenter.Transition property:

XAML
Copy
​<controls:TransitioningContentPresenter x:Name="presenter">
    <controls:TransitionPresenter.Transition>
        <controlsContentTransitions:FadeContentTransition />
    </controls:TransitionPresenter.Transition>
</controls:TransitionPresenter>

That code assigned a FadeContentTransition to the presenter.

The currently visible content in the transition presenter is set via the TransitioningContentPresenter.Content property. When a new object is set to that property, the transition presenter performs a transition from the "from" content (existing property value) to the "to" content (new property value). You can use the ContentTemplate property to set a DataTemplate for the "to" content. Of course you can bind all these properties in XAML too.

You can specify a default ContentTransitionDirection for transitions that support directions. This is done via the TransitioningContentPresenter.DefaultDirection property.

You can also specify a default Duration for transitions that support defaultable durations. This is done via the TransitioningContentPresenter.DefaultDuration property.

Built-In Transitions

The Shared Library includes a number of built-in transitions. Many of the built-in transitions support multiple directions and have an in/out mode concept. This table shows the built-in transitions:

Type | Description
FadedZoomContentTransition | A crossfade transition between two elements that zooms the new content in as well. The transition supports BeginTime, Duration, and Mode properties. It also has configurable ZoomInPercentage and ZoomOutPercentage properties that indicate the percentage by which zoomed in and out content is scaled. The default is 0.2. The values must be between 0 and 0.5.
FadeContentTransition | A crossfade transition between two elements. The transition supports BeginTime, Duration, and Mode properties.
SlideContentTransition | A slide transition between two elements that moves one element over the other, or alternatively pushes the other. The transition supports BeginTime, Direction, Duration, and Mode properties. It also has a IsFromContentPushed property that indicates whether the "from" content is pushed offscreen or if the "to" content simply slides over it. The default is false.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


UniformGrid

Shared Library Reference - Controls
UniformGrid

The UniformGrid control arranges content in a grid where all the cells in the grid have the same size.

The panel can auto-calculate the number of rows and columns that are necessary, or the rows/columns can optionally be specified.

This topic contains these sections:

  • Panel Support
  • Rows and Columns
  • Leading Blank Cells

Panel Support

Since the UniformGrid control inherits Panel, it is able to be used in any location that a custom panel can be set. For instance, it can be used within the ItemsPanelTemplate of an ItemsControl.

Rows and Columns

The UniformGrid control automatically calculates the number of rows and columns necessary to arrange all visible children. The Rows and Columns properties may also be optionally specified if a certain value is required of one or the other.

Leading Blank Cells

The UniformGrid.FirstColumn property optionally sets the number of leading blank cells in the first row of the grid. Be sure to also set the Columns property when specifying this value.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


WrapPanel

Shared Library Reference - Controls
WrapPanel

The WrapPanel control positions child elements in sequential order, breaking content to the next line at the edge of the containing box.

This topic contains these sections:

  • Panel Support
  • Orientation

Panel Support

Since the WrapPanel control inherits Panel, it is able to be used in any location that a custom panel can be set. For instance, it can be used within the ItemsPanelTemplate of an ItemsControl.

Orientation

The WrapPanel control can be oriented horizontally (the default) or vertically by setting the Orientation property.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Progress Spinners

Shared Library Reference - Controls
Progress Spinners

Progress spinners are used when some form of processing is occurring to tell the end user that something is happening.

A large RingSpinner control.

This topic contains these sections:

  • RingSpinner Overview

RingSpinner Overview

The RingSpinner control renders an animated ring where the two ring segment ends chase each other around the circle.

A couple RingSpinner controls.

The IsSpinning property must be set to true to activate animated spinning.

The outer radius of the ring will be auto-calculated based on the Width and Height of the control. They always should be set. For instance if Width and Height are 16 and there is no Padding set, the ring's radius will be 8.

The BorderBrush and BorderThickness properties specify the brush and thickness of the ring, extending inward from the outer radius.

Tip Tip
Use a BorderThickness value that is the same as the Radius to render a pie. The LineCap property (defaults to Round) should be set to Flat when rendering as a pie.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Media

Shared Library Reference
Media

The Media namespace has a UIColor structure that has a lot of helper methods for working with colors and a VisualTreeHelperExtended class that adds some useful methods that aren't in the core VisualTreeHelper class.

This topic contains these sections:

  • UIColor Structure
  • VisualTreeHelperExtended Class

UIColor Structure

The UIColor structure provides an enhanced representation of a Color object that supports the RGB, HSB, and HLS color models, conversion between models, and numerous other color helper methods. Static methods on the structure are used to create an instance of it.

These instance members are found in the structure:

Member | Description
A Property | Gets or sets the alpha component value of this UIColor structure.
B Property | Gets or sets the RGB blue component value of this UIColor structure.
ExceedsW3CBrightnessThreshold Property | Gets whether the color exceeds the W3C threshold for brightness.
G Property | Gets or sets the RGB green component value of this UIColor structure.
HlsHue Property | Gets or sets the HLS hue component value of this UIColor structure.
HlsLightness Property | Gets or sets the HLS lightness component value of this UIColor structure.
HlsSaturation Property | Gets or sets the HLS saturation component value of this UIColor structure.
HsbBrightness Property | Gets or sets the HSB brightness component value of this UIColor structure.
HsbHue Property | Gets or sets the HSB hue component value of this UIColor structure.
HsbSaturation Property | Gets or sets the HSB saturation component value of this UIColor structure.
IsGrayscale Property | Gets whether the color is grayscale.
R Property | Gets or sets the RGB red component value of this UIColor structure.
Tint Method | Tints this color towards the specified tint Color.
ToColor Method | Gets the Color value of this UIColor structure.
ToWebColor Method | Converts the color to a web color string (e.g. #FF0000 for Red).
W3CBrightness Property | Gets the brightness of the color, based on the W3C formula for calculating brightness.

These static members are found in the structure, many of which are used to create a UIColor:

Member | Description
FromAhls Method | Creates a UIColor structure from an alpha value and the specified HLS color values (hue, lightness, and saturation).
FromAhsb Method | Creates a UIColor structure from an alpha value and the specified HSB color values (hue, saturation, and brightness).
FromArgb Method | Creates a UIColor structure from an alpha value and the specified RGB color values (red, green, and blue).
FromColor Method | Creates a UIColor structure from the specified Color.
FromColorComplement Method | Creates a UIColor structure from the complement of the specified Color.
FromHls Method | Creates a UIColor structure from the specified HLS color values (hue, lightness, and saturation).
FromHsb Method | Creates a UIColor structure from the specified HSB color values (hue, saturation, and brightness).
FromMix Method | Creates a UIColor structure that is the specified percentage between the value of two Color objects.
FromName Method | Creates a UIColor structure from the specified name of a pre-defined color.
FromRgb Method | Creates a UIColor structure from the specified RGB color values (red, green, and blue).
FromWebColor Method | Creates a UIColor structure from the specified web color. This method can process HTML color specifications (e.g. #FF00FF) and known color names.
GetStandardCustomColors Method | Returns a Color array containing all of the standard custom values.
GetTintedColor Method | Returns the custom tinted color for the specified base color.
GetWebColors Method | Returns an array containing all of the web color values.

VisualTreeHelperExtended Class

The VisualTreeHelperExtended class has several static methods that are useful for performing common tasks with nodes in a visual tree. This class provides some advanced functionality that is not found in the VisualTreeHelper class.

These static members are found in the class:

Member | Description
GetAncestor Method | Returns a DependencyObject value that represents an ancestor of the visual object that is of the specified Type.
IsVisual Method | Returns whether the specified DependencyObject is a UIElement.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Shapes

Shared Library Reference
Shapes

The Shapes namespace contains shapes that can be used in XAML.

It can be imported with this XML namespace import:

XAML
Copy
​xmlns:shapes="using:ActiproSoftware.UI.Xaml.Shapes"

Available Shapes

Type Description
SemiEllipse

A half ellipse shape.

These properties are important:

  • ApexSide - The side upon which the semi-ellipse apex appears.
  • IsClosed - Whether the side opposite the apex is closed.

XAML
Copy
​<shapes:SemiEllipse Width="40" Height="20" ApexSide="Top" Fill="Red" />
Triangle

A triangle shape.

These properties are important:

  • ApexSide - The side upon which the triangle apex appears.
  • IsClosed - Whether the side opposite the apex is closed.

XAML
Copy
​<shapes:Triangle Width="20" Height="20" ApexSide="Top" Fill="Red" />
Wave

A wave shape.

These properties are important:

  • ApexCount - The number of apexes in the wave.
  • ApexSide - The side upon which the wave apex appears.
  • IsInverted - Whether the 'inside' of the shape occurs on the same side as the apex.

XAML
Copy
​<shapes:Wave Width="200" Height="10" ApexSide="Top" ApexCount="10" Stroke="Red" StrokeThickness="1" />
ZigZag

A zig-zag shape.

These properties are important:

  • ApexCount - The number of apexes in the zig-zag.
  • ApexSide - The side upon which the zig-zag apex appears.
  • IsInverted - Whether the 'inside' of the shape occurs on the same side as the apex.

XAML
Copy
​<shapes:ZigZag Width="200" Height="10" ApexSide="Top" ApexCount="10" Stroke="Red" StrokeThickness="1" />

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Value Converters

Shared Library Reference
Value Converters

The Data namespace contains numerous value converters that can be used in XAML for working with data.

It can be imported with this XML namespace import:

XAML
Copy
​xmlns:data="using:ActiproSoftware.UI.Xaml.Data"

Available Value Converters

Type | Description
BooleanNotConverter | Represents a value converter that performs a NOT (!) operation on a specified Boolean value.
BooleanToVisibilityConverter Represents a value converter that converts Boolean values to and from Visibility enumeration values.
XAML
Copy
​<TextBlock Visibility="{Binding ElementName=visibilityCheckBox, Path=IsChecked, Converter={StaticResource BooleanToVisibilityConverter}}" ... />
ConditionalConverter Represents a value converter that provides if-else functionality for Binding objects.

This converter expects the following source value to be specified:

  • Condition - A boolean value indicating whether the true or false value should be returned.

This sample code shows how to use the converter in a Binding in XAML:

XAML
Copy
​<shared:ConditionalConverter x:Key="ConditionalConverter" TrueValue="The Value is true" FalseValue="The Value is false" />
...
<TextBlock Text="{Binding Path=BooleanProperty, Converter={StaticResource ConditionalConverter}}" />
CornerRadiusConverter Represents a value converter that converts between a CornerRadius and a number.

By default, the CornerRadius returned will have all four corners set to the specified number. An optional parameter of type Corners can be specified, which can be used to customize the corners that are set.

XAML
Copy
​<!-- Set all four corners -->
... Value="{Binding Path=Number, Converter={StaticResource CornerRadiusConverter}}" ...

<!-- Only set the top left and right corners -->
... Value="{Binding Path=Number, Converter={StaticResource CornerRadiusConverter}, ConverterParameter='TopLeft,TopRight'}" ...
DurationToMillisecondConverter | Represents a value converter that converts between a Duration and a number of milliseconds.
GridLengthConverter | Represents a value converter that converts between a double and a GridLength.
IsEnumFlagSetConverter Represents a value converter that returns whether the specified enumeration value has the flag, specified by the converter's parameter, set.
XAML
Copy
​<CheckBox IsChecked="{Binding Path=EnumValue, Mode=TwoWay, Converter={StaticResource IsEnumFlagSetConverter}, ConverterParameter=Yes}" />
ParallaxConverter Represents a value converter that can be used to create a parallax background scrolling effect.

Use the converter in a binding on a background element's RenderTransform's TranslateTransform.X or Y property, and bind to a related ScrollViewer.HorizontalOffset or VerticalOffset property.

PercentageConverter | Represents a value converter that converts between a number and a percentage. The percentage is simply the number multiplied by 100.
StringFormatConverter Represents a multi-value converter that provides String.Format functionality for Binding objects.

Pass the format string in the converter's parameter. Since { characters are normally interpreted as markup extension starts, you can escape them by placing {} before the format string:

XAML
Copy
​<TextBlock Text="{Binding Path=Value, Converter={StaticResource StringFormatConverter}, ConverterParameter='Formatted number: {0:C2}'}"/>
ThicknessConverter Represents a value converter that converts between a Thickness and a number.

By default, the Thickness returned will have all four sides (Thickness.Left, Thickness.Top, Thickness.Right, and Thickness.Bottom) set to the specified number. An optional parameter of type Sides can be specified, which can be used to customize the sides that are set.

XAML
Copy
​<!-- Set all four sides -->
... Value="{Binding Path=Number, Converter={StaticResource ThicknessConverter}}" ...

<!-- Only set the Left and Right sides -->
... Value="{Binding Path=Number, Converter={StaticResource ThicknessConverter}, ConverterParameter='Left,Right'}" ...

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Customizing String Resources

Actipro Universal Windows Controls Reference
Customizing String Resources

This topic contains these sections:

  • What is a String Resource?
  • Localization
  • Getting/Setting Custom Strings with the SR Class
  • The SRName Enumeration

What is a String Resource?

A string resource is a text string that generally can be displayed in the user interface of our products.

For instance, the ITextChangeType.Description text for all the change type instances defined in TextChangeTypes comes from string resources.

All products that have displayable strings have string resources defined for those items. You can view all the string resources in our products with the String Resource Browser.

Localization

The default string resources in our products are defined in US English.

Our products have a nice framework that offers you the ability to alter any string resource to use custom text. This feature can be used in two main cases: simple changing of various strings to other strings that you prefer instead, and for localization.

In the first case, maybe you are building a US English-based application but wish to change one or two of the items to alternate text.

In the second case, you may wish to provide localization on the strings for any language based on the current culture that is running your application. Here you would want to customize the full set of string resources for each product that has string resources.

Getting/Setting Custom Strings with the SR Class

Products that have string resources have a class named SR (string resource) in their ActiproSoftware.Products.[ProductName] namespace. For instance, the SyntaxEditor product has the ActiproSoftware.Products.SyntaxEditor.SR class.

The SR class contains static methods allowing you to customize any string resources and return the resolved value of a string resource between its default value and any customizations you may have made. Even if you haven't made any customizations, the SR class is ideal for returning the default string resource values via a call to its GetString method.

Important Note Important Note
Any string resource customizations must be performed at application startup such as in Application.OnStartup, before any UI or controls have been referenced. This must be done since some string resources are used by static class initializers. Therefore your customizations may not be picked up if not set immediately upon application startup before UI classes are referenced.

These are the important members on any SR class implementation:

Member | Description
ClearCustomStrings Method | Removes all custom strings.
ContainsCustomString Method | Returns whether a custom string is defined for the specified string resource.
GetCustomString Method | Returns the custom string that is stored for the specified string resource, if any.
GetString Method | Returns the resolved value of the specified string resource. There is an overload that takes an optional argument list. This overload returns the resolved value of the specified string resource, by calling String.Format using the supplied arguments.
RemoveCustomString Method | Removes any custom string that is defined for the specified string resource
SetCustomString Method | Sets a custom string value for the specified string resource.

This code shows how to set a custom string for the SyntaxEditor's plain text classification type description:

C#
VB
Copy
​SR.SetCustomString(SRName.UIClassificationTypePlainText.ToString(), "Custom Text");
​SR.SetCustomString(SRName.UIClassificationTypePlainText.ToString(), "Custom Text")

This code shows how to retrieve the resolved value of a string resource (including any customizations):

C#
VB
Copy
​string text = SR.GetString(SRName.UIClassificationTypePlainText);
​Dim text As String = SR.GetString(SRName.UIClassificationTypePlainText)

Note Note
Use the String Resource Browser in the Sample Browser to browse all available string resources and easily generate string resource customization code.

The SRName Enumeration

To make discovery and verification of string resource names even easier, each product that has string resources will also have an enumeration named SRName defined in the same namespace as SR.

The SRName enumeration has one value for each string resource name in the product. You can call ToString on a value to convert it to a string when working with various methods on SR.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Licensing

Actipro Universal Windows Controls Reference
Licensing

This topic talks about the various product licensing options available, and walks through how to apply licensing when both evaluating and after a purchase.

This topic contains these sections:

  • License Types
  • Free Subscriptions and Free New Products
  • No Runtime, Server, Distribution Royalties
  • Purchasing Licenses
  • Steps to Install and Apply Licenses
  • ActiproLicenseManager.RegisterLicense Sample Code
  • Troubleshooting
  • Licensing Questions?

License Types

Evaluation License

Under the Evaluation License, you may only use the product for evaluation purposes for a period of 30 days, after which you must either remove all files associated with the product or purchase a Single Developer License for each individual developer on a project that uses the product. Evaluation extensions are available upon request.

Important Note Important Note
Our Universal Windows product evaluations are hassle-free, meaning there are no license keys required for evaluation and no annoying nag screens. The products will no longer be able to be used after a certain date following your evaluation period without the purchase of developer licenses or an evaluation extension.

Evaluation versions of the products may include some background watermarks or other means of displaying they are not licensed versions, all of which are removed once licenses are purchased.

Single Developer License

Single Developer Licenses must be purchased for each individual developer on a project using a product and may NOT be transferred between developers. This license grants each developer the right to use the purchased products in production applications and to include any files marked as redistributable with their applications.

Site License

Site licenses may be purchased, automatically giving all developers at a physical location a Single Developer License.

Enterprise License

Enterprise licenses may be purchased, automatically giving all developers in your entire organization and at all sites a Single Developer License.

Blueprint License (Source Code)

Blueprint licenses enable access to product source code. The term of Blueprint licenses must be kept in sync with product subscriptions. Please read the EULA to see the Blueprint license terms and conditions.

Free Subscriptions and Free New Products

All of the non-evaluation licenses described above for our Universal Windows control products include one full year of free upgrades to any new versions that are released within that timeframe.

In addition, customers with active Universal Windows Studio subscriptions will receive any new products added to the suite for free while the subscription is active.

No Runtime, Server, Distribution Royalties

Actipro Software control products have NO runtime, server, or distribution royalties if you own the proper amount of developer licenses for your development team (see above).

Purchasing Licenses

Licenses may be purchased directly from the Actipro web site. After a purchase has been made and the purchase has been processed, you will be e-mailed information on how to log into your Actipro account on our web site. Use the login information contained within the e-mail to log into the site.

Once you are within your account on our web site, download the latest release and e-mail yourself your license key. Then be sure to follow the instructions in the following sections to properly license the product for use in your applications.

Steps to Install and Apply Licenses

The following steps indicate how to install and license Actipro products for both fresh install and upgrade situations.

  1. First, obtain the licensing information (Licensee and License Key) to use.
    1. If you have purchased licenses for the product, e-mail yourself the licensing information for the product from your Actipro account's page for your organization.
    2. If you are evaluating, the Actipro products should already be pre-configured for evaluation and may show watermarks. No further action is needed by you to register an evaluation license.
  2. If you don't already have the latest product build installed...
    1. Download the latest build of the product from your Actipro account's page for your organization.
    2. Uninstall any old version of the product that is on your machine.
    3. Install the latest build on your machine. For build servers, the documentation and samples install options may be turned off.
  3. When adding products to your application the first time...
    1. Add a reference to the "Actipro Universal Windows Controls" extension SDK, as described in the References and Deployment topic.
    2. In your application's startup code, make an ActiproLicenseManager.RegisterLicense call using the licensing information obtained in step 1, if applicable. An example is shown in the following section.
  4. When making a license purchase after an earlier evaluation, or when upgrading products to new versions in an application that used old versions...
    1. Ensure the reference to the "Actipro Universal Windows Controls" extension SDK is correctly pointing to the new version you installed. Update the references as needed.
    2. In your application's startup code, make sure the ActiproLicenseManager.RegisterLicense call contains updated Licensee and License Key values. An example is shown in the following section.
  5. In Visual Studio, execute Clean Solution and then Rebuild Solution.

After following these steps, licensing will be properly applied to your application.

ActiproLicenseManager.RegisterLicense Sample Code

If you have purchased licenses for Actipro Universal Windows control products, a call to ActiproLicenseManager.RegisterLicense must be made in your application startup code before any UI has been created.

This method accepts two parameters, a Licensee and License Key. You must call RegisterLicense with the exact values indicated in your license e-mail.

This code shows how to register a license in your application's Startup event handler:

C#
VB
Copy
​string licensee = "YourLicenseeHere";
string licenseKey = "YourLicenseKeyHere";
ActiproSoftware.Products.ActiproLicenseManager.RegisterLicense(licensee, licenseKey);
​Dim licensee As String = "YourLicenseeHere"
Dim licenseKey As String = "YourLicenseKeyHere"
ActiproSoftware.Products.ActiproLicenseManager.RegisterLicense(licensee, licenseKey)

Troubleshooting

If you run into licensing issues, please first walk through the steps above in detail to make sure you didn't miss anything.

I've purchased licenses and followed the steps above but still get 'evaluation' watermarks or license exceptions.
Make sure you have a ActiproLicenseManager.RegisterLicense call in your application startup code before any UI code is referenced, and ensure that it uses the exact Licensee and License Key that is specified in the license e-mail.
I'm evaluating the product and am getting licensing exceptions.
Evaluation licenses do have a date upon which they cease to work any more. If you downloaded the evaluation a long time ago, you may be running into an expired evaluation key scenario. Please make sure you update to the latest build from our web site, or contact us for assistance.

Licensing Questions?

If you have any further questions regarding purchasing or licensing, please contact us. We're happy to help.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


References and Deployment

Actipro Universal Windows Controls Reference
References and Deployment

This topic discusses how to add a reference to an extension SDK so that the Universal Windows controls can be used in your own apps, and how to deploy the extension SDK with your apps.

This topic contains these sections:

  • Referencing the Extension SDK
  • Deployment Overview
  • Redistributable Files
  • Other Deployment Notes

Referencing the Extension SDK

The control products can be used in your own applications by adding a reference to the "Actipro Universal Windows Controls" extension SDK.

To get started, open a Windows or Windows Phone app project in Visual Studio. In the Visual Studio "Add References" dialog, expand out "Windows/Extensions" (in the left treeview) and add the "Actipro Universal Windows Controls" SDK to your project.

Deployment Overview

After the "Actipro Universal Windows Controls" SDK has been added as a reference to your project, the Actipro .dlls and other resource files will automatically be copied to your application's output folder and will be uploaded when you go to publish your app.

Your license information also needs to be registered via code in your application startup. For more information on how your register your license information, please read the Licensing topic.

Redistributable Files

When you own a license for an Actipro Universal Windows bundle or product, you are licensed to redistribute all files that are part of the "Actipro Universal Windows Controls" SDK with your application. That being said, you are only licensed to use the functionality of various products based on which bundles/products you have licensed. This chart shows the products that may be used based on the bundles/products for which you own licenses:

Product | Bundles/Products Licensed
 | Universal Windows Studio | Bar Codes | Charts | Docking/MDI | Editors | Grids | Micro Charts | SyntaxEditor | Views
Bar Codes | Yes | Yes | - | - | - | - | - | - | -
Charts | Yes | - | Yes | - | - | - | - | - | -
Docking/MDI | Yes | - | - | Yes | - | - | - | - | -
Editors | Yes | - | - | - | Yes | - | - | - | -
Grids | Yes | - | - | - | - | Yes | - | - | -
MicroCharts | Yes | - | - | - | - | - | Yes | - | -
SyntaxEditor | Yes | - | - | - | - | - | - | Yes | -
SyntaxEditor .NET Languages Add-on | No * | - | - | - | - | - | - | No * | -
SyntaxEditor Python Language Add-on | No * | - | - | - | - | - | - | No * | -
SyntaxEditor Web Languages Add-on | No * | - | - | - | - | - | - | No * | -
Views | Yes | - | - | - | - | - | - | - | Yes
Shared Library | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes

* Add-ons marked with an asterisk are sold separately from SyntaxEditor and its containing bundles. See the documentation for more details on licensing these add-ons.

Other Deployment Notes

No Run-time Royalties

There are no run-time royalties or other distribution charges for our control products. We only require that you have the proper of licenses for each developer on your project.

See the Licensing topic for more information on licensing requirements.

Do Not Use Our Product Installers on End User Machines

You do NOT need to use our product installers to place our controls on end user machines, nor are you permitted to distribute your license key directly to end users.

Instead, register your license information in your application startup as described in the Licensing topic. That way it will be embedded in the application and not directly distributed to end users.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Sample Code and QuickStarts

Actipro Universal Windows Controls Reference
Sample Code and QuickStarts

Actipro's Universal Windows controls include many demos and QuickStarts in the sample project.

We pride ourselves in providing more full-source samples than our competition, allowing you to learn our products easier and avoid having to rewrite common logic and design patterns.

This topic contains these sections:

  • What is a Demo?
  • What is a QuickStart?
  • Reusing Sample Source Code

What is a Demo?

A demo is a large sample that shows the combination of many product features together to create a finished product.

Demos are intended to show some ideas of what you can do with our products when you use them in your own applications.

What is a QuickStart?

A QuickStart is a small sample that is focused on a particular feature area or how to perform a certain task.

QuickStarts are the place to go to quickly learn how to get a specific feature working without having to navigate around unrelated code needed to support other features.

Reusing Sample Source Code

The full source for all samples is located in the sample project and you are free to reuse the sample source code as you wish.

We encourage you to copy what you need to help you get started with using the product in your own applications.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Overview

Actipro Universal Windows Controls Utilities
Overview

The Universal Windows Controls Sample Browser includes utilities that we developed to help aid our customers in working with our products.

These utilities are available in the Shared Library section of the Sample Browser.

This topic contains these sections:

  • The String Resource Browser

The String Resource Browser

The String Resource Browser can be used to view all the string resources that are used in Actipro's control products. It even helps you generate C# and VB code that lets you customize or localize the string resources.

See the String Resource Browser topic for information on this utility.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


String Resource Browser

Actipro Universal Windows Controls Utilities
String Resource Browser

The String Resource Browser allows you to view all the string resources that are defined for the various Actipro products. It generates code in C# and VB to customize or localize any of the string resources in our products.

It is available in the Shared Library section of the Sample Browser.

The String Resource Browser looking at SyntaxEditor's string resources

This topic contains these sections:

  • Using the String Resource Browser
  • Customizing String Resources

Using the String Resource Browser

Simply select the desired product in the Product drop-down to view the string resources for a product.

The list of resources shows the resource name and its default value.

Customizing String Resources

You may wish to change the default text to your own text, and in many other cases, you may simply wish to create localized versions of our default text.

The String Resource Browser can create C# and VB statements that override our default text for a specific string resource. To do this, select the target string resource in the list, enter some customized text, and click either C#'s Copy button or VB's Copy button depending on which language your code needs to be in.

The copied value looks like this:

C#
VB
Copy
​ActiproSoftware.Products.SyntaxEditor.SR.SetCustomString(ActiproSoftware.Products.SyntaxEditor.SRName.UIClassificationTypeVisibleWhitespace.ToString(), "Customized Text");
​ActiproSoftware.Products.SyntaxEditor.SR.SetCustomString(ActiproSoftware.Products.SyntaxEditor.SRName.UIClassificationTypeVisibleWhitespace.ToString(), "Customized Text")

Note Note
You should paste this code in your application startup so that it is run before any user interface has been loaded.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Designer Interaction

Actipro Universal Windows Controls Reference
Designer Interaction

Actipro's Universal Windows controls have have designer support for Visual Studio and Expression Blend. This enhanced functionality makes it much easier to quickly create and configure the various controls.

This topic contains these sections:

  • Property Categorization / Descriptions
  • Task Panes
  • Context Menus
  • Toolbox Icons

Property Categorization / Descriptions

All public properties on classes used in this product are categorized for use in the Visual Studio Properties window.

Task Panes

Some Actipro controls have task panes that can be displayed in the designer surface by clicking a toggle button adornment.

Toggle Button Adornments

Whenever you select an Actipro control in the designer that supports task pane display, a task pane toggle button adorner appears in the upper right area of the control.

The task pane adorner in the Visual Studio designer

When you click this adorner, a task pane for the control appears, giving you access to many configuration features.

Task Pane Popups

Task panes can provide access to configuring the most common options for a control.

The task pane for the MicroXYChart control in the Visual Studio designer

Context Menus

Some Actipro controls support design surface context menus. You can right-click on the control in the designer to display the context menu.

A MicroXYChart context menu in the Visual Studio designer

Use the context menu options to configure some common options for a control.

Toolbox Icons

This product's installer automatically adds appropriate control icons into the Visual Studio toolbox under a toolbox group for the product.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Troubleshooting

Actipro Universal Windows Controls Reference
Troubleshooting

This topic provides several tips on common questions or issues that you may encounter when using the Universal Windows Controls.

This topic contains these sections:

  • Enabling Developer Mode in Windows Settings
  • Actipro Controls in the VS Designer Appear Blank
  • The Sample Browser Isn't Optimized for Phone Usage
  • SyntaxEditor in Windows Phone Doesn't Allow Editing
  • Sample Browser Deployment Error on Phone

Enabling Developer Mode in Windows Settings

When developing Universal apps, you must enable developer mode in the Windows Settings. In the Windows 10 Settings app, go to "Updates & security", click the "For developers" tab on the left, and ensure "Developer mode" is selected on the right. Once you do that, you will be able to run the Sample Browser application or any other custom Universal app on your computer from Visual Studio.

Actipro Controls in the VS Designer Appear Blank

Visual Studio only shows third-party controls (like the Actipro controls) in the designer when the platform architecture for your project is set to 32-bit. If it is currently set to 64-bit or ARM, no Actipro controls will display. Thus when working with the VS designer, it is best to be in 32-bit platform architecture mode.

The Sample Browser Isn't Optimized for Phone Usage

While it is possible to open the Sample Browser app on a Windows Phone, most of the samples have not been optimized to work properly on a phone and may not render correctly. That being said, the Actipro UI controls themselves should work fine on a phone.

SyntaxEditor in Windows Phone Doesn't Allow Editing

Since Windows Phone doesn't allow custom controls to display the soft keyboard, SyntaxEditor should only be used in read-only mode on mobile devices. However in Windows apps or when using continuum on mobile devices, SyntaxEditor can be used for full editing.

Sample Browser Deployment Error on Phone

If you see an error like this when deploying the "Actipro Universal Windows Controls" Sample Browser app to a device, uninstall the already-installed "Actipro Universal Windows Controls" Sample Browser app, and then redeploy. Deployment will succeed once the old copy of the app is off of the device.

DEP0001 : Unexpected Error: Install failed. Please contact your software vendor. (Exception from HRESULT: 0x80073CF9) SampleBrowser-CSharp

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Support

Actipro Universal Windows Controls Reference
Support

This topic contains these sections:

  • Licensing Support
  • General Product Support

Licensing Support

If you are experiencing a problem with the licensing of a purchased product, please read the Licensing topic. It has valuable information on licensing and how to resolve any issues you may encounter.

If after reading the Licensing topic and following its directions you still cannot resolve the licensing issue, please contact us at support@actiprosoftware.com.

General Product Support

If you need to obtain support on one of our products, you have two options:

  1. Post a message in the Actipro Software support forums.
  2. E-mail support@actiprosoftware.com for assistance.

We highly recommend the first support option since it will enable other users to participate in the discussion.

Licensed customers of our products will receive the highest priority of support.

Please visit the Actipro Software web site to sign up for our .NET newsletter or to see our other .NET products.

Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com.


Class Library

Actipro Universal Windows Controls Documentation
Class Library
Namespaces
Namespace | Description
ActiproSoftware.Text | Contains types related to text.
ActiproSoftware.Text.Analysis | Contains types related to code structural analysis.
ActiproSoftware.Text.Analysis.Implementation | Contains the implementation types related to code structural analysis.
ActiproSoftware.Text.Exporters | Contains types related to the export of text to other markup formats..
ActiproSoftware.Text.Implementation | Contains implementation types related to text.
ActiproSoftware.Text.Languages.CSharp | Contains the classes related to implementing a C# syntax language.
ActiproSoftware.Text.Languages.CSharp.Implementation | Contains the core classes related to implementing a C# syntax language.
ActiproSoftware.Text.Languages.DotNet | Contains the classes related to implementing a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Ast | Contains the types related to ASTs for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation | Contains the implementation types related to ASTs for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Implementation | Contains the core classes related to implementing a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Reflection | Contains the types related to reflection for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation | Contains the implementation types related to reflection for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Resolution | Contains the types related to resolution for a .NET syntax language.
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation | Contains the implementation types related to resolution for a .NET syntax language.
ActiproSoftware.Text.Languages.JavaScript | Contains the classes related to implementing a JavaScript syntax language.
ActiproSoftware.Text.Languages.JavaScript.Ast | Contains the types related to ASTs for a JavaScript syntax language.
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation | Contains the implementation types related to ASTs for a JavaScript syntax language.
ActiproSoftware.Text.Languages.JavaScript.Implementation | Contains the core classes related to implementing a JavaScript syntax language.
ActiproSoftware.Text.Languages.Python | Contains the classes related to implementing a Python syntax language.
ActiproSoftware.Text.Languages.Python.Ast | Contains the types related to ASTs for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Ast.Implementation | Contains the implementation types related to ASTs for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Implementation | Contains the core classes related to implementing a Python syntax language.
ActiproSoftware.Text.Languages.Python.Reflection | Contains the types related to reflection for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Reflection.Implementation | Contains the implementation types related to reflection for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Resolution | Contains the types related to resolution for a Python syntax language.
ActiproSoftware.Text.Languages.Python.Resolution.Implementation | Contains the implementation types related to resolution for a Python syntax language.
ActiproSoftware.Text.Languages.VB | Contains the classes related to implementing a VB syntax language.
ActiproSoftware.Text.Languages.VB.Implementation | Contains the core classes related to implementing a VB syntax language.
ActiproSoftware.Text.Languages.Xml | Contains the classes related to implementing an XML syntax language.
ActiproSoftware.Text.Languages.Xml.Ast.Implementation | Contains the implementation types related to ASTs for a XML syntax language.
ActiproSoftware.Text.Languages.Xml.Implementation | Contains the core classes related to implementing an XML syntax language.
ActiproSoftware.Text.Lexing | Contains types related to lexing.
ActiproSoftware.Text.Lexing.Implementation | Contains implementation types related to lexing.
ActiproSoftware.Text.Parsing | Contains types related to parsing.
ActiproSoftware.Text.Parsing.Implementation | Contains implementation types related to parsing.
ActiproSoftware.Text.Parsing.LLParser | Contains types related to the creation of an LL parser.
ActiproSoftware.Text.Parsing.LLParser.Debugging | Contains types related to the debugging of an LL parser.
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation | Contains implementation types related to the debugging of an LL parser.
ActiproSoftware.Text.Parsing.LLParser.Implementation | Contains implementation types related to the creation of an LL parser.
ActiproSoftware.Text.RegularExpressions | Contains types related to working with regular expressions.
ActiproSoftware.Text.Searching | Contains types related to searching within text documents.
ActiproSoftware.Text.Searching.Implementation | Contains implementation types related to searching within text documents.
ActiproSoftware.Text.Tagging | Contains types related to tagging text ranges with custom data.
ActiproSoftware.Text.Tagging.Implementation | Contains implementation types related to tagging text ranges with custom data.
ActiproSoftware.Text.Undo | Contains types related to managing the undo/redo stacks of text documents.
ActiproSoftware.Text.Utility | Contains utility classes.
ActiproSoftware.Themes |
ActiproSoftware.UI.Xaml | Contains some core classes used throughout various products.
ActiproSoftware.UI.Xaml.Controls | Contains some core controls and related classes.
ActiproSoftware.UI.Xaml.Controls.Automation.Peers |
ActiproSoftware.UI.Xaml.Controls.BarCodes | Contains classes that support implementing bar code controls.
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.UI.Xaml.Controls.Charts | Contains classes that support implementing chart controls.
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes | Contains types related to chart palettes.
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives | Contains the primitive classes used for charts.
ActiproSoftware.UI.Xaml.Controls.ContentTransitions | Supports animated transitions of content.
ActiproSoftware.UI.Xaml.Controls.Docking | Contains classes that support implementing docking windows & MDI.
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives | Contains primitive classes used for Docking & MDI controls.
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization | Contains classes that are used to serialize layout data for the DockSite control.
ActiproSoftware.UI.Xaml.Controls.Editors | Contains classes that support implementing editor controls.
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers |
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors | Contains property editor classes that support integration of Editors with PropertyGrid.
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives | Contains property editor primitive classes that support integration of Editors with PropertyGrid.
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives | Contains the primitive classes used for editors.
ActiproSoftware.UI.Xaml.Controls.Grids | Contains classes that support implementing tree and grid controls.
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives | Contains the primitive classes used for Grids product controls.
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData | Contains the classes used for PropertyGrid model data.
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors | Contains the classes used for PropertyGrid property editors.
ActiproSoftware.UI.Xaml.Controls.MicroCharts | Contains classes that support implementing micro chart controls.
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes | Contains types related to micro chart palettes.
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives | Contains the primitive classes used for micro charts.
ActiproSoftware.UI.Xaml.Controls.Primitives | Contains some primitive classes used for the Shared Library controls.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor | Contains types related to the SyntaxEditor product.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments | Contains types related to adornments.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation | Contains implementation types related to adornments.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers | Contains automation peer classes that support UI automation for the product.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditActions | Contains IEditAction implementation types.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting | Contains types related to highlighting.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Highlighting.Implementation | Contains implementation types related to highlighting.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Implementation | Contains implementation types related to SyntaxEditor.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Indicators | Contains types related to working with indicators.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt | Contains IntelliPrompt-related types for the SyntaxEditor product.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.Implementation | Contains implementation types related to SyntaxEditor IntelliPrompt.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Margins | Contains margin-related types for the SyntaxEditor product.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Margins.Implementation | Contains implementation types related to SyntaxEditor margins.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining | Contains code outlining-related types for the SyntaxEditor product.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining.Implementation | Contains implementation types related to SyntaxEditor code outlining.
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Primitives | Contains primitive types for the SyntaxEditor product.
ActiproSoftware.UI.Xaml.Controls.Views | Contains classes that support implementing view controls.
ActiproSoftware.UI.Xaml.Controls.Views.Primitives | Contains the primitive classes used for views.
ActiproSoftware.UI.Xaml.Data | Provides classes for working with data.
ActiproSoftware.UI.Xaml.Data.Filtering | Provides classes for filtering data.
ActiproSoftware.UI.Xaml.Extensions | Contains extension methods for common types.
ActiproSoftware.UI.Xaml.Input | Contains classes related to user input.
ActiproSoftware.UI.Xaml.Media | Contains several helper classes for working with colors and visual trees.
ActiproSoftware.UI.Xaml.Serialization | Contains types related to serialization.
ActiproSoftware.UI.Xaml.Shapes | Contains primitive shapes that can be used in UI.
ActiproSoftware.UI.Xaml.StateTriggers |
Visit http://www.actiprosoftware.com for more information on our products.

Copyright (c) 2011-2017 Actipro Software LLC. All rights reserved.

Send comments on this topic to support@actiprosoftware.com


ActiproSoftware.Text Namespace

ActiproSoftware.Text Namespace
Contains types related to text.
Classes
 | Class | Description
Public class | CaseSensitivity | Represents the type of case sensitivity to apply.
Public class | CharacterCasing | Specifies the target case of text characters.
Public class | ClassificationTypes | Provides access to the built-in IClassificationType instances.
Public class | LineTerminator | Specifies a type of line terminator.
Public class | NormalizedTextSnapshotRangeCollection | Represents a read-only normalized text snapshot range collection.
Public class | SyntaxLanguageChangedEventArgs | Event arguments for the ICodeDocument.LanguageChanged event.
Public class | SyntaxLanguageExtensions | Contains extension methods that make it easier to work with ISyntaxLanguage objects.
Public class | TextChangeOffsetDelta | Specifies how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public class | TextChangeTypes | Provides access to the built-in ITextChangeType instances, that indicate the type of ITextChange made.
Public class | TextOffsetTrackingMode | Specifies how a text offset is updated by text change operations that occur around it.
Public class | TextPosition | Represents an ordered pair of zero-based line and character index values that defines a position within the lines of an ITextSnapshot.
Public class | TextPositionRange | Represents a range of two TextPosition values within the lines of an ITextSnapshot.
Public class | TextRange | Represents a zero-based range of two offset values within a text document.
Public class | TextRangeTrackingModes | Specifies how a text range is updated by text change operations that occur at its edges.
Public class | TextScanDirection | Specifies a direction in which text will be scanned.
Public class | TextSnapshotChangedEventArgs | Event arguments for the ITextDocument.TextChanged event.
Public class | TextSnapshotChangingEventArgs | Event arguments for the ITextDocument.TextChanging event.
Public class | TextSnapshotOffset | Represents a zero-based offset value within a certain ITextSnapshot.
Public class | TextSnapshotRange | Represents a zero-based range of two normalized offset values within a certain ITextSnapshot.
Public class | TextSnapshotRangeEventArgs | Event arguments used when a change notification is needed for a TextSnapshotRange.
Public class | TextSnapshotReaderOptions | Represents options that are applied to an ITextSnapshotReader.
Public class | WhitespaceTrimModes | Specifies the modes by which whitespace is trimmed.
Interfaces
 | Interface | Description
Public interface | IClassificationType | Provides the base requirements for an object that represents a classification type.
Public interface | IClassificationTypeRegistry | Provides the base requirements for an object that provides a registry of IClassificationType data.
Public interface | ICodeDocument | Provides the base requirements for a text document with some advanced features that relate to syntax highlighting and code parsing.
Public interface | ICodeDocumentLifecycleEventSink | Provides the base requirements for an object that can be notified of when an ICodeDocument becomes associated and disassociated with a language, via events such as a language change.
Public interface | ICodeDocumentPropertyChangeEventSink | Provides the base requirements for an object that can be notified of when an ICodeDocument's properties, such as ParseData or FileName, are changed.
Public interface | IEditorDocument | Provides the base requirements for a code document that has advanced functionality when edited in a code editor.
Public interface | IExampleTextProvider | Provides the base requirements for an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.
Public interface | IIdProvider | Provides the base requirements for a class that provides ID's.
Public interface | IIndexedTextRangeProviderCollection | Provides the base requirements for a collection of ITextRangeProvider objects.
Public interface | ILineCommenter | Provides the base requirements for an object that can comment and uncomment lines for a particular language.
Public interface | ISyntaxLanguage | Provides the base requirements for a syntax language that provides parsing and other functionality for a text document via registered services.
Public interface | ITextBufferReader | Provides the base requirements for an object that reads characters from a fixed text buffer.
Public interface | ITextChange | Provides the base requirements for a text change, which contains one or more ITextChangeOperation objects.
Public interface | ITextChangeOperation | Provides the base requirements for a single replace operations within a text change.
Public interface | ITextChangeOptions | Provides the base requirements for options that are applied to an ITextChange.
Public interface | ITextChangeRangedOperation | Provides the base requirements for a single replace operations within a text change, but without storing the actual text inserted/deleted.
Public interface | ITextChangeType | Provides the base requirements for an object that indicates the type of change made by an ITextChange.
Public interface | ITextDocument | Provides the base requirements for a text document that provides access to the ITextSnapshot (via CurrentSnapshot) that contains the current text of the document, and allows for text modification.
Public interface | ITextFormatter | Provides the base requirements of a language formatter that can adjust the whitespace layout of text for better readability.
Public interface | ITextPositionRangeProvider | Provides the base requirements for an object that has range of two TextPosition values within a text document.
Public interface | ITextRangeProvider | Provides the base requirements for an object that has range of two offset values within a text document.
Public interface | ITextSnapshot | Provides the base requirements for an immutable snapshot of an ITextDocument for a certain ITextVersion of that document.
Public interface | ITextSnapshotLine | Provides the base requirements for a line in an ITextSnapshot.
Public interface | ITextSnapshotLineCollection | Encapsulates a collection of ITextSnapshotLine objects.
Public interface | ITextSnapshotReader | Provides the base requirements for an object that reads through characters and tokens from an ITextSnapshot.
Public interface | ITextSnapshotReaderOptions | Provides the base requirements for options that are applied to an ITextSnapshotReader.
Public interface | ITextStatistic | Provides the base requirements for a text statistic that is returned by an ITextStatistics.
Public interface | ITextStatistics | Provides the base requirements for a class that contains numerous statistics such as line, word, character counts, and readability scores for text.
Public interface | ITextStatisticsFactory | Provides the base requirements for a factory capable of creating ITextStatistics objects.
Public interface | ITextVersion | Provides the base requirements for a version of an ITextDocument.
Public interface | ITextVersionRange | Provides the base requirements for a zero-based range of two normalized offset values within a text document that can be translated from one version of the document to another.
Public interface | IWordBreakFinder | Provides the base requirements for an object that finds word breaks within an ITextSnapshot.


CaseSensitivity Class

CaseSensitivity Class
Represents the type of case sensitivity to apply.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextCaseSensitivity

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CaseSensitivity : Enum
Public NotInheritable Class CaseSensitivity
    Inherits Enum

The CaseSensitivity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AutoCorrect | Treated the same as Insensitive however the text is converted to the exact pattern if not already equal to it. This is useful for languages like VB.NET where keywords should be forced to be certain combinations of mixed case letters.
 | Insensitive | Case insensitive - upper and lower case of a letter is matched.
 | Sensitive | Case sensitive - exact letter case is matched.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


CaseSensitivity Methods

CaseSensitivity Methods

The CaseSensitivity type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CaseSensitivity Class
ActiproSoftware.Text Namespace


CaseSensitivity Fields

CaseSensitivity Fields

The CaseSensitivity type exposes the following members.

Fields
 | Name | Description
 | AutoCorrect | Treated the same as Insensitive however the text is converted to the exact pattern if not already equal to it. This is useful for languages like VB.NET where keywords should be forced to be certain combinations of mixed case letters.
 | Insensitive | Case insensitive - upper and lower case of a letter is matched.
 | Sensitive | Case sensitive - exact letter case is matched.
Public field | value__ |
Top
See Also

Reference

CaseSensitivity Class
ActiproSoftware.Text Namespace


CaseSensitivity.AutoCorrect Field

CaseSensitivityAutoCorrect Field
Treated the same as Insensitive however the text is converted to the exact pattern if not already equal to it. This is useful for languages like VB.NET where keywords should be forced to be certain combinations of mixed case letters.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CaseSensitivity AutoCorrect = 2
Public Const AutoCorrect As CaseSensitivity = 2

Field Value

Type: CaseSensitivity
See Also

Reference

CaseSensitivity Class
ActiproSoftware.Text Namespace


CaseSensitivity.Insensitive Field

CaseSensitivityInsensitive Field
Case insensitive - upper and lower case of a letter is matched.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CaseSensitivity Insensitive = 1
Public Const Insensitive As CaseSensitivity = 1

Field Value

Type: CaseSensitivity
See Also

Reference

CaseSensitivity Class
ActiproSoftware.Text Namespace


CaseSensitivity.Sensitive Field

CaseSensitivitySensitive Field
Case sensitive - exact letter case is matched.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CaseSensitivity Sensitive = 0
Public Const Sensitive As CaseSensitivity = 0

Field Value

Type: CaseSensitivity
See Also

Reference

CaseSensitivity Class
ActiproSoftware.Text Namespace


CaseSensitivity.value__ Field

CaseSensitivityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.CaseSensitivity.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CaseSensitivity Class
ActiproSoftware.Text Namespace


CharacterCasing Class

CharacterCasing Class
Specifies the target case of text characters.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextCharacterCasing

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CharacterCasing : Enum
Public NotInheritable Class CharacterCasing
    Inherits Enum

The CharacterCasing type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Lower | Converts all characters to lowercase.
 | Normal | The case of characters is left unchanged.
 | Upper | Converts all characters to uppercase.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


CharacterCasing Methods

CharacterCasing Methods

The CharacterCasing type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CharacterCasing Class
ActiproSoftware.Text Namespace


CharacterCasing Fields

CharacterCasing Fields

The CharacterCasing type exposes the following members.

Fields
 | Name | Description
 | Lower | Converts all characters to lowercase.
 | Normal | The case of characters is left unchanged.
 | Upper | Converts all characters to uppercase.
Public field | value__ |
Top
See Also

Reference

CharacterCasing Class
ActiproSoftware.Text Namespace


CharacterCasing.Lower Field

CharacterCasingLower Field
Converts all characters to lowercase.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CharacterCasing Lower = 2
Public Const Lower As CharacterCasing = 2

Field Value

Type: CharacterCasing
See Also

Reference

CharacterCasing Class
ActiproSoftware.Text Namespace


CharacterCasing.Normal Field

CharacterCasingNormal Field
The case of characters is left unchanged.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CharacterCasing Normal = 0
Public Const Normal As CharacterCasing = 0

Field Value

Type: CharacterCasing
See Also

Reference

CharacterCasing Class
ActiproSoftware.Text Namespace


CharacterCasing.Upper Field

CharacterCasingUpper Field
Converts all characters to uppercase.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CharacterCasing Upper = 1
Public Const Upper As CharacterCasing = 1

Field Value

Type: CharacterCasing
See Also

Reference

CharacterCasing Class
ActiproSoftware.Text Namespace


CharacterCasing.value__ Field

CharacterCasingvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.CharacterCasing.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CharacterCasing Class
ActiproSoftware.Text Namespace


ClassificationTypes Class

ClassificationTypes Class
Provides access to the built-in IClassificationType instances.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextClassificationTypes

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class ClassificationTypes
Public NotInheritable Class ClassificationTypes

The ClassificationTypes type exposes the following members.

Properties
Name | Description
Comment | Gets the IClassificationType for a general comment.
CompilerError | Gets the IClassificationType for a compiler error.
Identifier | Gets the IClassificationType for a general identifier.
Keyword | Gets the IClassificationType for a general keyword.
Number | Gets the IClassificationType for a general number.
OtherError | Gets the IClassificationType for an other error.
PreprocessorKeyword | Gets the IClassificationType for a general preprocessor keyword.
ReadOnlyRegion | Gets the IClassificationType for a read-only region.
String | Gets the IClassificationType for a general string.
SyntaxError | Gets the IClassificationType for a syntax error.
Warning | Gets the IClassificationType for a warning.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ClassificationTypes Properties

ClassificationTypes Properties

The ClassificationTypes type exposes the following members.

Properties
Name | Description
Comment | Gets the IClassificationType for a general comment.
CompilerError | Gets the IClassificationType for a compiler error.
Identifier | Gets the IClassificationType for a general identifier.
Keyword | Gets the IClassificationType for a general keyword.
Number | Gets the IClassificationType for a general number.
OtherError | Gets the IClassificationType for an other error.
PreprocessorKeyword | Gets the IClassificationType for a general preprocessor keyword.
ReadOnlyRegion | Gets the IClassificationType for a read-only region.
String | Gets the IClassificationType for a general string.
SyntaxError | Gets the IClassificationType for a syntax error.
Warning | Gets the IClassificationType for a warning.
Top
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Comment Property

ClassificationTypesComment Property
Gets the IClassificationType for a general comment.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType Comment { get; }
Public Shared ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general comment.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.CompilerError Property

ClassificationTypesCompilerError Property
Gets the IClassificationType for a compiler error.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType CompilerError { get; }
Public Shared ReadOnly Property CompilerError As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a compiler error.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Identifier Property

ClassificationTypesIdentifier Property
Gets the IClassificationType for a general identifier.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType Identifier { get; }
Public Shared ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general identifier.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Keyword Property

ClassificationTypesKeyword Property
Gets the IClassificationType for a general keyword.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType Keyword { get; }
Public Shared ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general keyword.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Number Property

ClassificationTypesNumber Property
Gets the IClassificationType for a general number.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType Number { get; }
Public Shared ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general number.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.OtherError Property

ClassificationTypesOtherError Property
Gets the IClassificationType for an other error.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType OtherError { get; }
Public Shared ReadOnly Property OtherError As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for an other error.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.PreprocessorKeyword Property

ClassificationTypesPreprocessorKeyword Property
Gets the IClassificationType for a general preprocessor keyword.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType PreprocessorKeyword { get; }
Public Shared ReadOnly Property PreprocessorKeyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general preprocessor keyword.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.ReadOnlyRegion Property

ClassificationTypesReadOnlyRegion Property
Gets the IClassificationType for a read-only region.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType ReadOnlyRegion { get; }
Public Shared ReadOnly Property ReadOnlyRegion As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a read-only region.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.String Property

ClassificationTypesString Property
Gets the IClassificationType for a general string.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType String { get; }
Public Shared ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a general string.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.SyntaxError Property

ClassificationTypesSyntaxError Property
Gets the IClassificationType for a syntax error.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType SyntaxError { get; }
Public Shared ReadOnly Property SyntaxError As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a syntax error.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


ClassificationTypes.Warning Property

ClassificationTypesWarning Property
Gets the IClassificationType for a warning.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IClassificationType Warning { get; }
Public Shared ReadOnly Property Warning As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType for a warning.
See Also

Reference

ClassificationTypes Class
ActiproSoftware.Text Namespace


IClassificationType Interface

IClassificationType Interface
Provides the base requirements for an object that represents a classification type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IClassificationType : IKeyedObject
Public Interface IClassificationType
    Inherits IKeyedObject

The IClassificationType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationClassificationType


IClassificationType Properties

IClassificationType Properties

The IClassificationType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

IClassificationType Interface
ActiproSoftware.Text Namespace


IClassificationType.Description Property

IClassificationTypeDescription Property
Gets the description of the classification type, which is displayed in the user interface.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the classification type, which is displayed in the user interface.
See Also

Reference

IClassificationType Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry Interface

IClassificationTypeRegistry Interface
Provides the base requirements for an object that provides a registry of IClassificationType data.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IClassificationTypeRegistry : IEnumerable<IClassificationType>,
    IEnumerable
Public Interface IClassificationTypeRegistry
    Inherits IEnumerable(Of IClassificationType), IEnumerable

The IClassificationTypeRegistry type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entries in the registry.
Public property | Item | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface.
Top
Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable IClassificationType .)
Top
See Also

Reference

ActiproSoftware.Text Namespace


IClassificationTypeRegistry Properties

IClassificationTypeRegistry Properties

The IClassificationTypeRegistry type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entries in the registry.
Public property | Item | Gets the IClassificationType with the specified key. [C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface.
Top
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry.Count Property

IClassificationTypeRegistryCount Property
Gets the number of entries in the registry.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of entries in the registry.
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry.Item Property

IClassificationTypeRegistryItem Property
Gets the IClassificationType with the specified key.

[C#] In C#, this property is the indexer for the IClassificationTypeRegistry interface.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType this[
    string key
] { get; }
ReadOnly Property Item (
    key As String
) As IClassificationType
    Get

Parameters

key
Type: SystemString
The key of the IClassificationType to return.

Property Value

Type: IClassificationType
The IClassificationType with the specified key.
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


IClassificationTypeRegistry Methods

IClassificationTypeRegistry Methods

The IClassificationTypeRegistry type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable IClassificationType .)
Top
See Also

Reference

IClassificationTypeRegistry Interface
ActiproSoftware.Text Namespace


ICodeDocument Interface

ICodeDocument Interface
Provides the base requirements for a text document with some advanced features that relate to syntax highlighting and code parsing.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeDocument : IParseTarget,
    ITextDocument
Public Interface ICodeDocument
    Inherits IParseTarget, ITextDocument

The ICodeDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationCodeDocument


ICodeDocument Properties

ICodeDocument Properties

The ICodeDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Top
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.Language Property

ICodeDocumentLanguage Property
Gets or sets the ISyntaxLanguage that is currently loaded.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISyntaxLanguage Language { get; set; }
Property Language As ISyntaxLanguage
    Get
    Set

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that is currently loaded.
Remarks
The default value is a plain text language.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.LanguageData Property

ICodeDocumentLanguageData Property
Gets or sets an object that specifies document-specific data for the Language that is loaded.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object LanguageData { get; set; }
Property LanguageData As Object
    Get
    Set

Property Value

Type: Object
An object that specifies document-specific data for the Language that is loaded.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.ParseData Property

ICodeDocumentParseData Property
Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseData ParseData { get; set; }
Property ParseData As IParseData
    Get
    Set

Property Value

Type: IParseData
The syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.Properties Property

ICodeDocumentProperties Property
Gets the dictionary containing custom properties for this object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PropertyDictionary Properties { get; }
ReadOnly Property Properties As PropertyDictionary
    Get

Property Value

Type: PropertyDictionary
The dictionary containing custom properties for this object.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument Methods

ICodeDocument Methods

The ICodeDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.AddLanguageChangedEventHandler Method

ICodeDocumentAddLanguageChangedEventHandler Method
Adds an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AddLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub AddLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.CreateTagAggregator(T) Method

ICodeDocumentCreateTagAggregatorT Method
Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITagAggregator<T> CreateTagAggregator<T>()
where T : ITag

Function CreateTagAggregator(Of T As ITag) As ITagAggregator(Of T)

Type Parameters

T
The type of ITag associated with this aggregator.

Return Value

Type: ITagAggregator T
The ITagAggregatorT that was created.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.GetServices(TService) Method

ICodeDocumentGetServicesTService Method
Returns a list of available services of the specified type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<TService> GetServices<TService>()
where TService : class

Function GetServices(Of TService As Class) As IList(Of TService)

Type Parameters

TService
The type of service.

Return Value

Type: IList TService
The list of available services of the specified type.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.QueueParseRequest Method

ICodeDocumentQueueParseRequest Method
Queues up a parse request for the document with the ambient dispatcher.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void QueueParseRequest()
Sub QueueParseRequest
Remarks
If AmbientParseRequestDispatcherProvider does not provide a dispatcher, the parsing operation is completed immediately in the calling thread.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.RemoveLanguageChangedEventHandler Method

ICodeDocumentRemoveLanguageChangedEventHandler Method
Removes an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RemoveLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub RemoveLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument Events

ICodeDocument Events

The ICodeDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.LanguageChanged Event

ICodeDocumentLanguageChanged Event
Occurs after the value of the Language property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<SyntaxLanguageChangedEventArgs> LanguageChanged
Event LanguageChanged As EventHandler(Of SyntaxLanguageChangedEventArgs)

Value

Type: SystemEventHandler SyntaxLanguageChangedEventArgs
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocument.ParseDataChanged Event

ICodeDocumentParseDataChanged Event
Occurs after the value of the ParseData property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<ParseDataPropertyChangedEventArgs> ParseDataChanged
Event ParseDataChanged As EventHandler(Of ParseDataPropertyChangedEventArgs)

Value

Type: SystemEventHandler ParseDataPropertyChangedEventArgs
See Also

Reference

ICodeDocument Interface
ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink Interface

ICodeDocumentLifecycleEventSink Interface
Provides the base requirements for an object that can be notified of when an ICodeDocument becomes associated and disassociated with a language, via events such as a language change.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeDocumentLifecycleEventSink
Public Interface ICodeDocumentLifecycleEventSink

The ICodeDocumentLifecycleEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDocumentAttached | Occurs when the specified ICodeDocument is attached to a language.
Public method | NotifyDocumentDetached | Occurs when the specified ICodeDocument is detached from a language.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink Methods

ICodeDocumentLifecycleEventSink Methods

The ICodeDocumentLifecycleEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDocumentAttached | Occurs when the specified ICodeDocument is attached to a language.
Public method | NotifyDocumentDetached | Occurs when the specified ICodeDocument is detached from a language.
Top
See Also

Reference

ICodeDocumentLifecycleEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink.NotifyDocumentAttached Method

ICodeDocumentLifecycleEventSinkNotifyDocumentAttached Method
Occurs when the specified ICodeDocument is attached to a language.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDocumentAttached(
    ICodeDocument document
)
Sub NotifyDocumentAttached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

ICodeDocumentLifecycleEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentLifecycleEventSink.NotifyDocumentDetached Method

ICodeDocumentLifecycleEventSinkNotifyDocumentDetached Method
Occurs when the specified ICodeDocument is detached from a language.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDocumentDetached(
    ICodeDocument document
)
Sub NotifyDocumentDetached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is detached.
See Also

Reference

ICodeDocumentLifecycleEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink Interface

ICodeDocumentPropertyChangeEventSink Interface
Provides the base requirements for an object that can be notified of when an ICodeDocument's properties, such as ParseData or FileName, are changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeDocumentPropertyChangeEventSink
Public Interface ICodeDocumentPropertyChangeEventSink

The ICodeDocumentPropertyChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyFileNameChanged | Occurs after the value of the FileName property has changed.
Public method | NotifyParseDataChanged | Occurs after the value of the ParseData property has changed.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink Methods

ICodeDocumentPropertyChangeEventSink Methods

The ICodeDocumentPropertyChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyFileNameChanged | Occurs after the value of the FileName property has changed.
Public method | NotifyParseDataChanged | Occurs after the value of the ParseData property has changed.
Top
See Also

Reference

ICodeDocumentPropertyChangeEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink.NotifyFileNameChanged Method

ICodeDocumentPropertyChangeEventSinkNotifyFileNameChanged Method
Occurs after the value of the FileName property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyFileNameChanged(
    ICodeDocument document,
    StringPropertyChangedEventArgs e
)
Sub NotifyFileNameChanged (
    document As ICodeDocument,
    e As StringPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose FileName property is changed.
e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
The StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

ICodeDocumentPropertyChangeEventSink Interface
ActiproSoftware.Text Namespace


ICodeDocumentPropertyChangeEventSink.NotifyParseDataChanged Method

ICodeDocumentPropertyChangeEventSinkNotifyParseDataChanged Method
Occurs after the value of the ParseData property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyParseDataChanged(
    ICodeDocument document,
    ParseDataPropertyChangedEventArgs e
)
Sub NotifyParseDataChanged (
    document As ICodeDocument,
    e As ParseDataPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose ParseData property is changed.
e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
The ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

ICodeDocumentPropertyChangeEventSink Interface
ActiproSoftware.Text Namespace


IEditorDocument Interface

IEditorDocument Interface
Provides the base requirements for a code document that has advanced functionality when edited in a code editor.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorDocument : ICodeDocument,
    IParseTarget, ITextDocument
Public Interface IEditorDocument
    Inherits ICodeDocument, IParseTarget, ITextDocument

The IEditorDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from ICodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from ICodeDocument.)
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from ICodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ICodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from ICodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from ICodeDocument.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from ICodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from ICodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from ICodeDocument.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


IEditorDocument Properties

IEditorDocument Properties

The IEditorDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from ITextDocument.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from ITextDocument.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from ITextDocument.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from ITextDocument.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from ITextDocument.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from ITextDocument.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from ICodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from ICodeDocument.)
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from ICodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ICodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from ITextDocument.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from ITextDocument.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from IParseTarget.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.IndicatorManager Property

IEditorDocumentIndicatorManager Property
Gets the IIndicatorManager that manages indicators for the document.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IIndicatorManager IndicatorManager { get; }
ReadOnly Property IndicatorManager As IIndicatorManager
    Get

Property Value

Type: IIndicatorManager
The IIndicatorManager that manages indicators for the document.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.OutliningManager Property

IEditorDocumentOutliningManager Property
Gets the IOutliningManager that manages outlining nodes for the document.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IOutliningManager OutliningManager { get; }
ReadOnly Property OutliningManager As IOutliningManager
    Get

Property Value

Type: IOutliningManager
The IOutliningManager that manages outlining nodes for the document.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.OutliningMode Property

IEditorDocumentOutliningMode Property
Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
OutliningMode OutliningMode { get; set; }
Property OutliningMode As OutliningMode
    Get
    Set

Property Value

Type: OutliningMode
The OutliningMode for the document that determines what type of code outlining (folding) is supported. The default value is OutliningMode.Default.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument.WhitespaceTrimModes Property

IEditorDocumentWhitespaceTrimModes Property
Gets or sets the modes in which whitespace should be automatically trimmed.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
WhitespaceTrimModes WhitespaceTrimModes { get; set; }
Property WhitespaceTrimModes As WhitespaceTrimModes
    Get
    Set

Property Value

Type: WhitespaceTrimModes
A WhitespaceTrimModes indicating the modes in which whitespace should be automatically trimmed. The default value is None.
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument Methods

IEditorDocument Methods

The IEditorDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from ITextDocument.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from ICodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from ICodeDocument.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from ITextDocument.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from ITextDocument.)
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result. (Inherited from IParseTarget.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from ICodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from ICodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from ITextDocument.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from ITextDocument.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from ITextDocument.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from ITextDocument.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from ITextDocument.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from ITextDocument.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from ITextDocument.)
Top
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IEditorDocument Events

IEditorDocument Events

The IEditorDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from ITextDocument.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from ITextDocument.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from ITextDocument.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from ICodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from ICodeDocument.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from ITextDocument.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from ITextDocument.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from ITextDocument.)
Top
See Also

Reference

IEditorDocument Interface
ActiproSoftware.Text Namespace


IExampleTextProvider Interface

IExampleTextProvider Interface
Provides the base requirements for an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IExampleTextProvider
Public Interface IExampleTextProvider

The IExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationExampleTextProvider


IExampleTextProvider Properties

IExampleTextProvider Properties

The IExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

IExampleTextProvider Interface
ActiproSoftware.Text Namespace


IExampleTextProvider.ExampleText Property

IExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ExampleText { get; }
ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text.
See Also

Reference

IExampleTextProvider Interface
ActiproSoftware.Text Namespace


IIdProvider Interface

IIdProvider Interface
Provides the base requirements for a class that provides ID's.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIdProvider
Public Interface IIdProvider

The IIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

ActiproSoftware.Text Namespace


IIdProvider Properties

IIdProvider Properties

The IIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.MaxId Property

IIdProviderMaxId Property
Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int MaxId { get; }
ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.MinId Property

IIdProviderMinId Property
Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int MinId { get; }
ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider Methods

IIdProvider Methods

The IIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetKey | Returns the string-based key for the specified ID.
Top
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.ContainsId Method

IIdProviderContainsId Method
Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ContainsId(
    int id
)
Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.GetDescription Method

IIdProviderGetDescription Method
Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetDescription(
    int id
)
Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIdProvider.GetKey Method

IIdProviderGetKey Method
Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetKey(
    int id
)
Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.
See Also

Reference

IIdProvider Interface
ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection Interface

IIndexedTextRangeProviderCollection Interface
Provides the base requirements for a collection of ITextRangeProvider objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIndexedTextRangeProviderCollection
Public Interface IIndexedTextRangeProviderCollection

The IIndexedTextRangeProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetCount | Returns the number of ITextRangeProvider objects in the collection.
Public method | GetItem | Returns the ITextRangeProvider at the specified index.
Top
See Also

Reference

ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection Methods

IIndexedTextRangeProviderCollection Methods

The IIndexedTextRangeProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetCount | Returns the number of ITextRangeProvider objects in the collection.
Public method | GetItem | Returns the ITextRangeProvider at the specified index.
Top
See Also

Reference

IIndexedTextRangeProviderCollection Interface
ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection.GetCount Method

IIndexedTextRangeProviderCollectionGetCount Method
Returns the number of ITextRangeProvider objects in the collection.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetCount()
Function GetCount As Integer

Return Value

Type: Int32
The number of ITextRangeProvider objects in the collection.
See Also

Reference

IIndexedTextRangeProviderCollection Interface
ActiproSoftware.Text Namespace


IIndexedTextRangeProviderCollection.GetItem Method

IIndexedTextRangeProviderCollectionGetItem Method
Returns the ITextRangeProvider at the specified index.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextRangeProvider GetItem(
    int index
)
Function GetItem (
    index As Integer
) As ITextRangeProvider

Parameters

index
Type: SystemInt32
The index of the ITextRangeProvider to return.

Return Value

Type: ITextRangeProvider
The ITextRangeProvider at the specified index.
See Also

Reference

IIndexedTextRangeProviderCollection Interface
ActiproSoftware.Text Namespace


ILineCommenter Interface

ILineCommenter Interface
Provides the base requirements for an object that can comment and uncomment lines for a particular language.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILineCommenter
Public Interface ILineCommenter

The ILineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange.
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationLineBasedLineCommenter
ActiproSoftware.Text.ImplementationRangeLineCommenter


ILineCommenter Methods

ILineCommenter Methods

The ILineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange.
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange.
Top
See Also

Reference

ILineCommenter Interface
ActiproSoftware.Text Namespace


ILineCommenter.Comment Method

ILineCommenterComment Method
Comments out the lines of code in the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Comment(
    TextSnapshotRange snapshotRange,
    ITextChangeOptions options
)
Sub Comment (
    snapshotRange As TextSnapshotRange,
    options As ITextChangeOptions
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.
See Also

Reference

ILineCommenter Interface
ActiproSoftware.Text Namespace


ILineCommenter.Uncomment Method

ILineCommenterUncomment Method
Uncomments the lines of code in the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Uncomment(
    TextSnapshotRange snapshotRange,
    ITextChangeOptions options
)
Sub Uncomment (
    snapshotRange As TextSnapshotRange,
    options As ITextChangeOptions
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to uncomment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.
See Also

Reference

ILineCommenter Interface
ActiproSoftware.Text Namespace


ISyntaxLanguage Interface

ISyntaxLanguage Interface
Provides the base requirements for a syntax language that provides parsing and other functionality for a text document via registered services.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISyntaxLanguage : IKeyedObject,
    IServiceLocator
Public Interface ISyntaxLanguage
    Inherits IKeyedObject, IServiceLocator

The ISyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationSyntaxLanguage


ISyntaxLanguage Properties

ISyntaxLanguage Properties

The ISyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ISyntaxLanguage Interface
ActiproSoftware.Text Namespace


ISyntaxLanguage Methods

ISyntaxLanguage Methods

The ISyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from IServiceLocator.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from IServiceLocator.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from IServiceLocator.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

ISyntaxLanguage Interface
ActiproSoftware.Text Namespace


ISyntaxLanguage Events

ISyntaxLanguage Events

The ISyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from IServiceLocator.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from IServiceLocator.)
Top
See Also

Reference

ISyntaxLanguage Interface
ActiproSoftware.Text Namespace


ITextBufferReader Interface

ITextBufferReader Interface
Provides the base requirements for an object that reads characters from a fixed text buffer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextBufferReader
Public Interface ITextBufferReader

The ITextBufferReader type exposes the following members.

Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationStringTextBufferReader


ITextBufferReader Properties

ITextBufferReader Properties

The ITextBufferReader type exposes the following members.

Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.HasStackEntries Property

ITextBufferReaderHasStackEntries Property
Gets whether there are entries on the stack.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasStackEntries { get; }
ReadOnly Property HasStackEntries As Boolean
    Get

Property Value

Type: Boolean
true if there are entries on the stack; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsAtEnd Property

ITextBufferReaderIsAtEnd Property
Gets whether the current Offset is at the end of the text buffer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtEnd { get; }
ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of the text buffer; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsAtStart Property

ITextBufferReaderIsAtStart Property
Gets whether the current Offset is at the start of the text buffer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtStart { get; }
ReadOnly Property IsAtStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the text buffer; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsWhitespaceOnlyAfterOnLine Property

ITextBufferReaderIsWhitespaceOnlyAfterOnLine Property
Gets whether only whitespace characters appear at and after the Offset on the current line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWhitespaceOnlyAfterOnLine { get; }
ReadOnly Property IsWhitespaceOnlyAfterOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear at and after the Offset on the current line; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.IsWhitespaceOnlyBeforeOnLine Property

ITextBufferReaderIsWhitespaceOnlyBeforeOnLine Property
Gets whether only whitespace characters appear before the Offset on the current line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWhitespaceOnlyBeforeOnLine { get; }
ReadOnly Property IsWhitespaceOnlyBeforeOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear before the Offset on the current line; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Length Property

ITextBufferReaderLength Property
Gets the number of characters in the text buffer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the text buffer.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Offset Property

ITextBufferReaderOffset Property
Gets or sets the current reader offset in the text buffer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Offset { get; set; }
Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The current reader offset in the text buffer.
Remarks
For performance reasons there is no bounds check on the setter.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.OffsetDelta Property

ITextBufferReaderOffsetDelta Property
Gets the amount by which to alter the offset values that are parsed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int OffsetDelta { get; }
ReadOnly Property OffsetDelta As Integer
    Get

Property Value

Type: Int32
The amount by which to alter the offset values that are parsed.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Position Property

ITextBufferReaderPosition Property
Gets the current reader TextPosition in the text buffer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition Position { get; }
ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The current reader TextPosition in the text buffer.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.PositionDelta Property

ITextBufferReaderPositionDelta Property
Gets the amount by which to alter the Position values that are parsed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition PositionDelta { get; }
ReadOnly Property PositionDelta As TextPosition
    Get

Property Value

Type: TextPosition
The amount by which to alter the Position values that are parsed.
Remarks
The Character portion only affects character offset of the line after the Line count.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader Methods

ITextBufferReader Methods

The ITextBufferReader type exposes the following members.

Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.AsTextReader Method

ITextBufferReaderAsTextReader Method
Returns a TextReader wrapper for this reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextReader AsTextReader()
Function AsTextReader As TextReader

Return Value

Type: TextReader
A TextReader wrapper for this reader.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.GetSubstring Method

ITextBufferReaderGetSubstring Method
Returns a substring from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetSubstring(
    int offset,
    int length
)
Function GetSubstring (
    offset As Integer,
    length As Integer
) As String

Parameters

offset
Type: SystemInt32
The offset at which to retrieve the text.
length
Type: SystemInt32
The number of characters to return.

Return Value

Type: String
The substring from the text buffer using Newline for line ends.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Peek Method

ITextBufferReaderPeek Method
Overload List
 | Name | Description
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Peek Method

ITextBufferReaderPeek Method
Peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char Peek()
Function Peek As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
Peek Overload
ActiproSoftware.Text Namespace


ITextBufferReader.Peek Method (Int32)

ITextBufferReaderPeek Method (Int32)
Peeks at a certain character from the text buffer after the current Offset without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char Peek(
    int count
)
Function Peek (
    count As Integer
) As Char

Parameters

count
Type: SystemInt32
The number of characters away from the current Offset at which to peek.

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
Peek Overload
ActiproSoftware.Text Namespace


ITextBufferReader.PeekReverse Method

ITextBufferReaderPeekReverse Method
Reverse peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char PeekReverse()
Function PeekReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Pop Method

ITextBufferReaderPop Method
Pops the top offset from the stack and moves the Offset to that offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Pop()
Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.PopAll Method

ITextBufferReaderPopAll Method
Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool PopAll()
Function PopAll As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Push Method

ITextBufferReaderPush Method
Pushes the Offset onto the stack for later restoration.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Push()
Sub Push
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.Read Method

ITextBufferReaderRead Method
Reads a single character from the text buffer and seeks forward one offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char Read()
Function Read As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverse Method

ITextBufferReaderReadReverse Method
Reverse reads a single character from the text buffer and seeks backward one offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char ReadReverse()
Function ReadReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverseThrough Method

ITextBufferReaderReadReverseThrough Method
Overload List
 | Name | Description
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverseThrough Method (Char)

ITextBufferReaderReadReverseThrough Method (Char)
Reverse reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadReverseThrough(
    char ch
)
Function ReadReverseThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the start of the text buffer was reached.
See Also

Reference

ITextBufferReader Interface
ReadReverseThrough Overload
ActiproSoftware.Text Namespace


ITextBufferReader.ReadReverseThrough Method (Char, Int32)

ITextBufferReaderReadReverseThrough Method (Char, Int32)
Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadReverseThrough(
    char ch,
    int minOffset
)
Function ReadReverseThrough (
    ch As Char,
    minOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
minOffset
Type: SystemInt32
The minimum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextBufferReader Interface
ReadReverseThrough Overload
ActiproSoftware.Text Namespace


ITextBufferReader.ReadThrough Method

ITextBufferReaderReadThrough Method
Overload List
 | Name | Description
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextBufferReader Interface
ActiproSoftware.Text Namespace


ITextBufferReader.ReadThrough Method (Char)

ITextBufferReaderReadThrough Method (Char)
Reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadThrough(
    char ch
)
Function ReadThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the end of the text buffer was reached.
See Also

Reference

ITextBufferReader Interface
ReadThrough Overload
ActiproSoftware.Text Namespace


ITextBufferReader.ReadThrough Method (Char, Int32)

ITextBufferReaderReadThrough Method (Char, Int32)
Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadThrough(
    char ch,
    int maxOffset
)
Function ReadThrough (
    ch As Char,
    maxOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
maxOffset
Type: SystemInt32
The maximum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextBufferReader Interface
ReadThrough Overload
ActiproSoftware.Text Namespace


ITextChange Interface

ITextChange Interface
Provides the base requirements for a text change, which contains one or more ITextChangeOperation objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextChange
Public Interface ITextChange

The ITextChange type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets whether to prevent the text change from occurring if any text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | IsRedo | Gets whether the text change is for a redo.
Public property | IsUndo | Gets whether the text change is for an undo.
Public property | LastTextReplacementOperationIndex | Gets the index of the last operation within the text change in which the entire document text was replaced, if any.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | SelectionPositionRange | Gets or sets the TextPositionRange that specifies the range of text that was selected before the text change occurred.
Public property | Snapshot | Gets the ITextSnapshot against which all operations in this text change should be based.
Public property | Source | Gets the optional source of the text change, which is most often an editor view if specified.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
Methods
 | Name | Description
Public method | AppendText | Adds an ITextChangeOperation that appends text to the end of the Snapshot.
Public method | Apply | Applies the text change and all of its Operations in sequential order.
Public method | DeleteText(TextRange) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | DeleteText(Int32, Int32) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | InsertText | Adds an ITextChangeOperation that inserts text in the Snapshot.
Public method | ReplaceText(TextRange, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | ReplaceText(Int32, Int32, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | SetText(String) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.
Public method | SetText(String, Boolean) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextChange Properties

ITextChange Properties

The ITextChange type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets whether to prevent the text change from occurring if any text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | IsRedo | Gets whether the text change is for a redo.
Public property | IsUndo | Gets whether the text change is for an undo.
Public property | LastTextReplacementOperationIndex | Gets the index of the last operation within the text change in which the entire document text was replaced, if any.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | SelectionPositionRange | Gets or sets the TextPositionRange that specifies the range of text that was selected before the text change occurred.
Public property | Snapshot | Gets the ITextSnapshot against which all operations in this text change should be based.
Public property | Source | Gets the optional source of the text change, which is most often an editor view if specified.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.CanMergeIntoPreviousChange Property

ITextChangeCanMergeIntoPreviousChange Property
Gets whether this text change can merge into the previous text change in the undo stack.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanMergeIntoPreviousChange { get; }
ReadOnly Property CanMergeIntoPreviousChange As Boolean
    Get

Property Value

Type: Boolean
true if this text change can merge into the previous text change in the undo stack; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.CheckReadOnly Property

ITextChangeCheckReadOnly Property
Gets whether to prevent the text change from occurring if any text range to modify is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CheckReadOnly { get; }
ReadOnly Property CheckReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the read-only state should be checked; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.CustomData Property

ITextChangeCustomData Property
Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set

Property Value

Type: Object
The custom data.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.IsMerged Property

ITextChangeIsMerged Property
Gets whether this text change is the result of a merge of two or more text changes.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsMerged { get; }
ReadOnly Property IsMerged As Boolean
    Get

Property Value

Type: Boolean
true if this text change is the result of a merge of two or more text changes; otherwise, false.
Remarks
A merge can occur when a text change is created with CanMergeIntoPreviousChange.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.IsRedo Property

ITextChangeIsRedo Property
Gets whether the text change is for a redo.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsRedo { get; }
ReadOnly Property IsRedo As Boolean
    Get

Property Value

Type: Boolean
true if the text change is for a redo; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.IsUndo Property

ITextChangeIsUndo Property
Gets whether the text change is for an undo.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsUndo { get; }
ReadOnly Property IsUndo As Boolean
    Get

Property Value

Type: Boolean
true if the text change is for an undo; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.LastTextReplacementOperationIndex Property

ITextChangeLastTextReplacementOperationIndex Property
Gets the index of the last operation within the text change in which the entire document text was replaced, if any.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LastTextReplacementOperationIndex { get; }
ReadOnly Property LastTextReplacementOperationIndex As Integer
    Get

Property Value

Type: Int32
The index of the last text replacement operation within the text change; otherwise, -1 if there are no such operations.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Operations Property

ITextChangeOperations Property
Gets the read-only list of ITextChangeOperation objects that make up this text change.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ITextChangeOperation> Operations { get; }
ReadOnly Property Operations As IList(Of ITextChangeOperation)
    Get

Property Value

Type: IList ITextChangeOperation
The read-only list of ITextChangeOperation objects that make up this text change.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.RetainSelection Property

ITextChangeRetainSelection Property
Gets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RetainSelection { get; }
ReadOnly Property RetainSelection As Boolean
    Get

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.SelectionPositionRange Property

ITextChangeSelectionPositionRange Property
Gets or sets the TextPositionRange that specifies the range of text that was selected before the text change occurred.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange SelectionPositionRange { get; set; }
Property SelectionPositionRange As TextPositionRange
    Get
    Set

Property Value

Type: TextPositionRange
The TextPositionRange that specifies the range of text that was selected before the text change occurred.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Snapshot Property

ITextChangeSnapshot Property
Gets the ITextSnapshot against which all operations in this text change should be based.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot against which all operations in this text change should be based.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Source Property

ITextChangeSource Property
Gets the optional source of the text change, which is most often an editor view if specified.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Source { get; }
ReadOnly Property Source As Object
    Get

Property Value

Type: Object
The optional source of the text change, which is most often an editor view if specified.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.Type Property

ITextChangeType Property
Gets an ITextChangeType indicating the type of change that was made.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextChangeType Type { get; }
ReadOnly Property Type As ITextChangeType
    Get

Property Value

Type: ITextChangeType
An ITextChangeType indicating the type of change that was made.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange Methods

ITextChange Methods

The ITextChange type exposes the following members.

Methods
 | Name | Description
Public method | AppendText | Adds an ITextChangeOperation that appends text to the end of the Snapshot.
Public method | Apply | Applies the text change and all of its Operations in sequential order.
Public method | DeleteText(TextRange) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | DeleteText(Int32, Int32) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | InsertText | Adds an ITextChangeOperation that inserts text in the Snapshot.
Public method | ReplaceText(TextRange, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | ReplaceText(Int32, Int32, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | SetText(String) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.
Public method | SetText(String, Boolean) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.AppendText Method

ITextChangeAppendText Method
Adds an ITextChangeOperation that appends text to the end of the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AppendText(
    string text
)
Sub AppendText (
    text As String
)

Parameters

text
Type: SystemString
The text to append to the end of the Snapshot.
Remarks
This method is simply a wrapper for a call to InsertText(Int32, String).
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)
ITextChangeSetText(String)


ITextChange.Apply Method

ITextChangeApply Method
Applies the text change and all of its Operations in sequential order.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Apply()
Function Apply As Boolean

Return Value

Type: Boolean
true if all the operations were applied successfully; otherwise, false.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.DeleteText Method

ITextChangeDeleteText Method
Overload List
 | Name | Description
Public method | DeleteText(TextRange) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Public method | DeleteText(Int32, Int32) | Adds an ITextChangeOperation that deletes text in the Snapshot.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.DeleteText Method (TextRange)

ITextChangeDeleteText Method (TextRange)
Adds an ITextChangeOperation that deletes text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteText(
    TextRange textRange
)
Sub DeleteText (
    textRange As TextRange
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
See Also

Reference

ITextChange Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(TextRange, String)
ITextChangeSetText(String)


ITextChange.DeleteText Method (Int32, Int32)

ITextChangeDeleteText Method (Int32, Int32)
Adds an ITextChangeOperation that deletes text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteText(
    int offset,
    int deleteLength
)
Sub DeleteText (
    offset As Integer,
    deleteLength As Integer
)

Parameters

offset
Type: SystemInt32
The starting offset at which to delete.
deleteLength
Type: SystemInt32
The number of characters to delete.
See Also

Reference

ITextChange Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)
ITextChangeSetText(String)


ITextChange.InsertText Method

ITextChangeInsertText Method
Adds an ITextChangeOperation that inserts text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void InsertText(
    int offset,
    string text
)
Sub InsertText (
    offset As Integer,
    text As String
)

Parameters

offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeReplaceText(Int32, Int32, String)
ITextChangeSetText(String)


ITextChange.ReplaceText Method

ITextChangeReplaceText Method
Overload List
 | Name | Description
Public method | ReplaceText(TextRange, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Public method | ReplaceText(Int32, Int32, String) | Adds an ITextChangeOperation that replaces text in the Snapshot.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.ReplaceText Method (TextRange, String)

ITextChangeReplaceText Method (TextRange, String)
Adds an ITextChangeOperation that replaces text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ReplaceText(
    TextRange textRange,
    string insertText
)
Sub ReplaceText (
    textRange As TextRange,
    insertText As String
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
insertText
Type: SystemString
The text to insert.
See Also

Reference

ITextChange Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(TextRange)
ITextChangeInsertText(Int32, String)
ITextChangeSetText(String)


ITextChange.ReplaceText Method (Int32, Int32, String)

ITextChangeReplaceText Method (Int32, Int32, String)
Adds an ITextChangeOperation that replaces text in the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ReplaceText(
    int offset,
    int deleteLength,
    string insertText
)
Sub ReplaceText (
    offset As Integer,
    deleteLength As Integer,
    insertText As String
)

Parameters

offset
Type: SystemInt32
The offset at which to insert.
deleteLength
Type: SystemInt32
The number of characters to delete before inserting the text.
insertText
Type: SystemString
The text to insert.
See Also

Reference

ITextChange Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeSetText(String)


ITextChange.SetText Method

ITextChangeSetText Method
Overload List
 | Name | Description
Public method | SetText(String) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.
Public method | SetText(String, Boolean) | Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.
Top
See Also

Reference

ITextChange Interface
ActiproSoftware.Text Namespace


ITextChange.SetText Method (String)

ITextChangeSetText Method (String)
Adds an ITextChangeOperation that replaces all the text in the Snapshot and marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SetText(
    string text
)
Sub SetText (
    text As String
)

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the document.
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.
See Also

Reference

ITextChange Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)


ITextChange.SetText Method (String, Boolean)

ITextChangeSetText Method (String, Boolean)
Adds an ITextChangeOperation that replaces all the text in the Snapshot and optionally marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SetText(
    string text,
    bool isProgrammatic
)
Sub SetText (
    text As String,
    isProgrammatic As Boolean
)

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the document.
isProgrammatic
Type: SystemBoolean
Whether the operation is considered a programmatic replacement.
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.
See Also

Reference

ITextChange Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextChangeAppendText(String)
ITextChangeDeleteText(Int32, Int32)
ITextChangeInsertText(Int32, String)
ITextChangeReplaceText(Int32, Int32, String)


ITextChangeOperation Interface

ITextChangeOperation Interface
Provides the base requirements for a single replace operations within a text change.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextChangeOperation : ITextChangeRangedOperation
Public Interface ITextChangeOperation
    Inherits ITextChangeRangedOperation

The ITextChangeOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletedText | Gets the text that was deleted by the operation.
Public property | DeletionEndOffset | Gets the offset at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionLength | Gets the number of characters that were deleted. (Inherited from ITextChangeRangedOperation.)
Public property | HasDeletion | Gets whether the operation deleted any text. (Inherited from ITextChangeRangedOperation.)
Public property | HasInsertion | Gets whether the operation inserted any text. (Inherited from ITextChangeRangedOperation.)
Public property | InsertedText | Gets the text that was inserted by the operation.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionLength | Gets the number of characters that were inserted. (Inherited from ITextChangeRangedOperation.)
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation. (Inherited from ITextChangeRangedOperation.)
Public property | IsProgrammaticTextReplacement | Gets whether the operation completely replaces the document's text, and is only caused by using the SetText(String) method.
Public property | IsTextReplacement | Gets whether the operation completely replaces the document's text.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDelta | Gets the net change in document lines after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesInserted | Gets the number of lines inserted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | StartOffset | Gets the offset at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Public property | StartPosition | Gets the TextPosition at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Top
Remarks
All text change operations are represented in terms of a replace operation. The StartOffset and StartPosition properties both indicate where the operations occurred. For delete operations, the InsertionLength is 0. For insert operations that have no selection of text to be replaced, the DeletionLength is 0.
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeOperation Properties

ITextChangeOperation Properties

The ITextChangeOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletedText | Gets the text that was deleted by the operation.
Public property | DeletionEndOffset | Gets the offset at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended. (Inherited from ITextChangeRangedOperation.)
Public property | DeletionLength | Gets the number of characters that were deleted. (Inherited from ITextChangeRangedOperation.)
Public property | HasDeletion | Gets whether the operation deleted any text. (Inherited from ITextChangeRangedOperation.)
Public property | HasInsertion | Gets whether the operation inserted any text. (Inherited from ITextChangeRangedOperation.)
Public property | InsertedText | Gets the text that was inserted by the operation.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended. (Inherited from ITextChangeRangedOperation.)
Public property | InsertionLength | Gets the number of characters that were inserted. (Inherited from ITextChangeRangedOperation.)
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation. (Inherited from ITextChangeRangedOperation.)
Public property | IsProgrammaticTextReplacement | Gets whether the operation completely replaces the document's text, and is only caused by using the SetText(String) method.
Public property | IsTextReplacement | Gets whether the operation completely replaces the document's text.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesDelta | Gets the net change in document lines after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | LinesInserted | Gets the number of lines inserted after performing the operation. (Inherited from ITextChangeRangedOperation.)
Public property | StartOffset | Gets the offset at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Public property | StartPosition | Gets the TextPosition at which the operation occurred. (Inherited from ITextChangeRangedOperation.)
Top
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.DeletedText Property

ITextChangeOperationDeletedText Property
Gets the text that was deleted by the operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DeletedText { get; }
ReadOnly Property DeletedText As String
    Get

Property Value

Type: String
The text that was deleted by the operation.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.InsertedText Property

ITextChangeOperationInsertedText Property
Gets the text that was inserted by the operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string InsertedText { get; }
ReadOnly Property InsertedText As String
    Get

Property Value

Type: String
The text that was inserted by the operation.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.IsProgrammaticTextReplacement Property

ITextChangeOperationIsProgrammaticTextReplacement Property
Gets whether the operation completely replaces the document's text, and is only caused by using the SetText(String) method.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsProgrammaticTextReplacement { get; }
ReadOnly Property IsProgrammaticTextReplacement As Boolean
    Get

Property Value

Type: Boolean
true if the operation completely replaces the document's text, and is only caused by using the SetText(String) method; otherwise, false.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOperation.IsTextReplacement Property

ITextChangeOperationIsTextReplacement Property
Gets whether the operation completely replaces the document's text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsTextReplacement { get; }
ReadOnly Property IsTextReplacement As Boolean
    Get

Property Value

Type: Boolean
true if the operation completely replaces the document's text; otherwise, false.
See Also

Reference

ITextChangeOperation Interface
ActiproSoftware.Text Namespace


ITextChangeOptions Interface

ITextChangeOptions Interface
Provides the base requirements for options that are applied to an ITextChange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextChangeOptions
Public Interface ITextChangeOptions

The ITextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeOptions Properties

ITextChangeOptions Properties

The ITextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.CanMergeIntoPreviousChange Property

ITextChangeOptionsCanMergeIntoPreviousChange Property
Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanMergeIntoPreviousChange { get; set; }
Property CanMergeIntoPreviousChange As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this text change can merge into the previous text change in the undo stack; otherwise, false.
Remarks
When true, if an undo occurs after this text change, this text change's operations along with those of the previous text change would occur as a single undoable text change.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.CheckReadOnly Property

ITextChangeOptionsCheckReadOnly Property
Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CheckReadOnly { get; set; }
Property CheckReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the read-only state should be checked; otherwise, false.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.CustomData Property

ITextChangeOptionsCustomData Property
Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set

Property Value

Type: Object
The custom data.
Remarks
This custom data is only persisted for the root text change of a set of operations.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.OffsetDelta Property

ITextChangeOptionsOffsetDelta Property
Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextChangeOffsetDelta OffsetDelta { get; set; }
Property OffsetDelta As TextChangeOffsetDelta
    Get
    Set

Property Value

Type: TextChangeOffsetDelta
A TextChangeOffsetDelta value indicating how to apply offset deltas, if at all.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.RetainSelection Property

ITextChangeOptionsRetainSelection Property
Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RetainSelection { get; set; }
Property RetainSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeOptions.Source Property

ITextChangeOptionsSource Property
Gets or sets the optional source of the text change, which is most often an editor view if specified.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Source { get; set; }
Property Source As Object
    Get
    Set

Property Value

Type: Object
The optional source of the text change, which is most often an editor view if specified.
See Also

Reference

ITextChangeOptions Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation Interface

ITextChangeRangedOperation Interface
Provides the base requirements for a single replace operations within a text change, but without storing the actual text inserted/deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextChangeRangedOperation
Public Interface ITextChangeRangedOperation

The ITextChangeRangedOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletionEndOffset | Gets the offset at which the deletion ended.
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended.
Public property | DeletionLength | Gets the number of characters that were deleted.
Public property | HasDeletion | Gets whether the operation deleted any text.
Public property | HasInsertion | Gets whether the operation inserted any text.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended.
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended.
Public property | InsertionLength | Gets the number of characters that were inserted.
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation.
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation.
Public property | LinesDelta | Gets the net change in document lines after performing the operation.
Public property | LinesInserted | Gets the number of lines inserted after performing the operation.
Public property | StartOffset | Gets the offset at which the operation occurred.
Public property | StartPosition | Gets the TextPosition at which the operation occurred.
Top
Remarks
All text change operations are represented in terms of a replace operation. The StartOffset and StartPosition properties both indicate where the operations occurred. For delete operations, the InsertionLength is 0. For insert operations that have no selection of text to be replaced, the DeletionLength is 0.
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeRangedOperation Properties

ITextChangeRangedOperation Properties

The ITextChangeRangedOperation type exposes the following members.

Properties
 | Name | Description
Public property | DeletionEndOffset | Gets the offset at which the deletion ended.
Public property | DeletionEndPosition | Gets the TextPosition at which the deletion ended.
Public property | DeletionLength | Gets the number of characters that were deleted.
Public property | HasDeletion | Gets whether the operation deleted any text.
Public property | HasInsertion | Gets whether the operation inserted any text.
Public property | InsertionEndOffset | Gets the offset at which the insertion ended.
Public property | InsertionEndPosition | Gets the TextPosition at which the insertion ended.
Public property | InsertionLength | Gets the number of characters that were inserted.
Public property | IsIgnoredForTranslation | Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation.
Public property | LengthDelta | Gets the net change in length to the document after performing the operation.
Public property | LinesDeleted | Gets the number of document lines deleted after performing the operation.
Public property | LinesDelta | Gets the net change in document lines after performing the operation.
Public property | LinesInserted | Gets the number of lines inserted after performing the operation.
Public property | StartOffset | Gets the offset at which the operation occurred.
Public property | StartPosition | Gets the TextPosition at which the operation occurred.
Top
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.DeletionEndOffset Property

ITextChangeRangedOperationDeletionEndOffset Property
Gets the offset at which the deletion ended.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DeletionEndOffset { get; }
ReadOnly Property DeletionEndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the deletion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.DeletionEndPosition Property

ITextChangeRangedOperationDeletionEndPosition Property
Gets the TextPosition at which the deletion ended.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition DeletionEndPosition { get; }
ReadOnly Property DeletionEndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the deletion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.DeletionLength Property

ITextChangeRangedOperationDeletionLength Property
Gets the number of characters that were deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DeletionLength { get; }
ReadOnly Property DeletionLength As Integer
    Get

Property Value

Type: Int32
The number of characters that were deleted.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.HasDeletion Property

ITextChangeRangedOperationHasDeletion Property
Gets whether the operation deleted any text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasDeletion { get; }
ReadOnly Property HasDeletion As Boolean
    Get

Property Value

Type: Boolean
true if any text was deleted; otherwise, false.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.HasInsertion Property

ITextChangeRangedOperationHasInsertion Property
Gets whether the operation inserted any text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasInsertion { get; }
ReadOnly Property HasInsertion As Boolean
    Get

Property Value

Type: Boolean
true if any text was inserted; otherwise, false.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.InsertionEndOffset Property

ITextChangeRangedOperationInsertionEndOffset Property
Gets the offset at which the insertion ended.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int InsertionEndOffset { get; }
ReadOnly Property InsertionEndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the insertion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.InsertionEndPosition Property

ITextChangeRangedOperationInsertionEndPosition Property
Gets the TextPosition at which the insertion ended.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition InsertionEndPosition { get; }
ReadOnly Property InsertionEndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the insertion ended.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.InsertionLength Property

ITextChangeRangedOperationInsertionLength Property
Gets the number of characters that were inserted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int InsertionLength { get; }
ReadOnly Property InsertionLength As Integer
    Get

Property Value

Type: Int32
The number of characters that were inserted.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.IsIgnoredForTranslation Property

ITextChangeRangedOperationIsIgnoredForTranslation Property
Gets whether the operation is a simple replace such as a character casing update that should be ignored for translation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsIgnoredForTranslation { get; }
ReadOnly Property IsIgnoredForTranslation As Boolean
    Get

Property Value

Type: Boolean
true if the operation is a simple replace such as a character casing update that should be ignored for translation; otherwise, false.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LengthDelta Property

ITextChangeRangedOperationLengthDelta Property
Gets the net change in length to the document after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LengthDelta { get; }
ReadOnly Property LengthDelta As Integer
    Get

Property Value

Type: Int32
The net change in length to the document after performing the operation.
Remarks
This value is the InsertionLength minus the DeletionLength.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LinesDeleted Property

ITextChangeRangedOperationLinesDeleted Property
Gets the number of document lines deleted after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LinesDeleted { get; }
ReadOnly Property LinesDeleted As Integer
    Get

Property Value

Type: Int32
The number of document lines deleted after performing the operation.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LinesDelta Property

ITextChangeRangedOperationLinesDelta Property
Gets the net change in document lines after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LinesDelta { get; }
ReadOnly Property LinesDelta As Integer
    Get

Property Value

Type: Int32
The net change in document lines after performing the operation.
Remarks
This value is the LinesInserted value minus the LinesDeleted value.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.LinesInserted Property

ITextChangeRangedOperationLinesInserted Property
Gets the number of lines inserted after performing the operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LinesInserted { get; }
ReadOnly Property LinesInserted As Integer
    Get

Property Value

Type: Int32
The number of lines inserted after performing the operation.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.StartOffset Property

ITextChangeRangedOperationStartOffset Property
Gets the offset at which the operation occurred.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the operation occurred.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeRangedOperation.StartPosition Property

ITextChangeRangedOperationStartPosition Property
Gets the TextPosition at which the operation occurred.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition StartPosition { get; }
ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the operation occurred.
See Also

Reference

ITextChangeRangedOperation Interface
ActiproSoftware.Text Namespace


ITextChangeType Interface

ITextChangeType Interface
Provides the base requirements for an object that indicates the type of change made by an ITextChange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextChangeType : IKeyedObject
Public Interface ITextChangeType
    Inherits IKeyedObject

The ITextChangeType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the change type, which is displayed in the user interface in undo lists.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextChangeType Properties

ITextChangeType Properties

The ITextChangeType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the change type, which is displayed in the user interface in undo lists.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ITextChangeType Interface
ActiproSoftware.Text Namespace


ITextChangeType.Description Property

ITextChangeTypeDescription Property
Gets the description of the change type, which is displayed in the user interface in undo lists.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the change type, which is displayed in the user interface in undo lists.
See Also

Reference

ITextChangeType Interface
ActiproSoftware.Text Namespace


ITextDocument Interface

ITextDocument Interface
Provides the base requirements for a text document that provides access to the ITextSnapshot (via CurrentSnapshot) that contains the current text of the document, and allows for text modification.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextDocument
Public Interface ITextDocument

The ITextDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile | Loads document text from a Stream using the specified encoding.
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding.
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile | Saves document text to a Stream using the specified encoding.
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile.
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextDocument Properties

ITextDocument Properties

The ITextDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AutoCharacterCasing Property

ITextDocumentAutoCharacterCasing Property
Gets or sets how to modify the case of text that is inserted into the document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CharacterCasing AutoCharacterCasing { get; set; }
Property AutoCharacterCasing As CharacterCasing
    Get
    Set

Property Value

Type: CharacterCasing
A CharacterCasing indicating the desired case of inserted text.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AutoConvertTabsToSpaces Property

ITextDocumentAutoConvertTabsToSpaces Property
Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AutoConvertTabsToSpaces { get; set; }
Property AutoConvertTabsToSpaces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs should be converted to spaces when the Tab key is pressed or indenting occurs; otherwise, false. The default value is false.
Remarks
The number of spaces inserted is indicated by the TabSize property.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.CurrentSnapshot Property

ITextDocumentCurrentSnapshot Property
Gets the ITextSnapshot that contains the current text of the document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot CurrentSnapshot { get; }
ReadOnly Property CurrentSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the current text of the document.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.FileName Property

ITextDocumentFileName Property
Gets or sets the name of the file currently loaded in the document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set

Property Value

Type: String
The name of the file currently loaded in the document.
Remarks
This property is automatically set whenever a [!:LoadFile(string)] overload is called that accepts a file path.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsModified Property

ITextDocumentIsModified Property
Gets or sets whether the document has been modified.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsModified { get; set; }
Property IsModified As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document has been modified; otherwise, false.
Remarks
This flag is reset to false when the ActiproSoftware.Text property is set, or when a [!:SaveFile(string,LineTerminator)] overload is used that accepts a path matching the current FileName property value.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsReadOnly Property

ITextDocumentIsReadOnly Property
Gets or sets whether the entire document is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; set; }
Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the entire document is flagged as read-only; otherwise, false. The default value is false.
Remarks
When read-only, the document's contents should not be editable.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TabSize Property

ITextDocumentTabSize Property
Gets or sets the distance in spaces between tab stops.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int TabSize { get; set; }
Property TabSize As Integer
    Get
    Set

Property Value

Type: Int32
The distance in spaces between tab stops. The default value is 4 spaces.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.UndoHistory Property

ITextDocumentUndoHistory Property
Gets an IUndoHistory that provides access to undo and redo functionality for the document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IUndoHistory UndoHistory { get; }
ReadOnly Property UndoHistory As IUndoHistory
    Get

Property Value

Type: IUndoHistory
An IUndoHistory that provides access to undo and redo functionality for the document.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument Methods

ITextDocument Methods

The ITextDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile | Loads document text from a Stream using the specified encoding.
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding.
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile | Saves document text to a Stream using the specified encoding.
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile.
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AddTextChangedEventHandler Method

ITextDocumentAddTextChangedEventHandler Method
Adds an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AddTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub AddTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AddTextChangingEventHandler Method

ITextDocumentAddTextChangingEventHandler Method
Adds an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AddTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Sub AddTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AppendText Method

ITextDocumentAppendText Method
Overload List
 | Name | Description
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.AppendText Method (ITextChangeType, String)

ITextDocumentAppendText Method (ITextChangeType, String)
Appends text to the end of the CurrentSnapshot text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AppendText(
    ITextChangeType type,
    string text
)
Function AppendText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
AppendText Overload
ActiproSoftware.Text Namespace
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.AppendText Method (ITextChangeType, String, ITextChangeOptions)

ITextDocumentAppendText Method (ITextChangeType, String, ITextChangeOptions)
Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AppendText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Function AppendText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
AppendText Overload
ActiproSoftware.Text Namespace
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.CreateTextChange Method

ITextDocumentCreateTextChange Method
Overload List
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.CreateTextChange Method (ITextChangeType)

ITextDocumentCreateTextChange Method (ITextChangeType)
Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type
)
Function CreateTextChange (
    type As ITextChangeType
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextDocument Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextDocument.CreateTextChange Method (ITextChangeType, ITextChangeOptions)

ITextDocumentCreateTextChange Method (ITextChangeType, ITextChangeOptions)
Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type,
    ITextChangeOptions options
)
Function CreateTextChange (
    type As ITextChangeType,
    options As ITextChangeOptions
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextDocument Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextDocument.DeleteText Method

ITextDocumentDeleteText Method
Overload List
 | Name | Description
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.DeleteText Method (ITextChangeType, TextRange)

ITextDocumentDeleteText Method (ITextChangeType, TextRange)
Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    TextRange textRange
)
Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, TextRange, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.DeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)

ITextDocumentDeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)
Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    TextRange textRange,
    ITextChangeOptions options
)
Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.DeleteText Method (ITextChangeType, Int32, Int32)

ITextDocumentDeleteText Method (ITextChangeType, Int32, Int32)
Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    int offset,
    int length
)
Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.DeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)

ITextDocumentDeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)
Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool DeleteText(
    ITextChangeType type,
    int offset,
    int length,
    ITextChangeOptions options
)
Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
DeleteText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.InsertText Method

ITextDocumentInsertText Method
Overload List
 | Name | Description
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.InsertText Method (ITextChangeType, Int32, String)

ITextDocumentInsertText Method (ITextChangeType, Int32, String)
Performs an insert text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool InsertText(
    ITextChangeType type,
    int offset,
    string text
)
Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
InsertText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)


ITextDocument.InsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)

ITextDocumentInsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)
Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool InsertText(
    ITextChangeType type,
    int offset,
    string text,
    ITextChangeOptions options
)
Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
InsertText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.IsTextRangeReadOnly Method

ITextDocumentIsTextRangeReadOnly Method
Returns whether any character in the specified TextRange is flagged as read-only.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsTextRangeReadOnly(
    TextRange textRange
)
Function IsTextRangeReadOnly (
    textRange As TextRange
) As Boolean

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if any character in the specified TextRange is flagged as read-only; otherwise, false.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.LoadFile Method

ITextDocumentLoadFile Method
Loads document text from a Stream using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
LineTerminator LoadFile(
    Stream stream,
    Encoding encoding
)
Function LoadFile (
    stream As Stream,
    encoding As Encoding
) As LineTerminator

Parameters

stream
Type: System.IOStream
The Stream from which to load.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.LoadFileAsync Method

ITextDocumentLoadFileAsync Method
Overload List
 | Name | Description
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding.
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.LoadFileAsync Method (IStorageFile)

ITextDocumentLoadFileAsync Method (IStorageFile)
Loads document text from an IStorageFile, using the file's character encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<LineTerminator> LoadFileAsync(
    IStorageFile file
)
Function LoadFileAsync (
    file As IStorageFile
) As Task(Of LineTerminator)

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to examine.

Return Value

Type: Task LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
Remarks
This method updates the value of the FileName property.
See Also

Reference

ITextDocument Interface
LoadFileAsync Overload
ActiproSoftware.Text Namespace


ITextDocument.LoadFileAsync Method (IStorageFile, Encoding)

ITextDocumentLoadFileAsync Method (IStorageFile, Encoding)
Loads document text from an IStorageFile, using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<LineTerminator> LoadFileAsync(
    IStorageFile file,
    Encoding encoding
)
Function LoadFileAsync (
    file As IStorageFile,
    encoding As Encoding
) As Task(Of LineTerminator)

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to examine.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: Task LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
Remarks
This method updates the value of the FileName property.
See Also

Reference

ITextDocument Interface
LoadFileAsync Overload
ActiproSoftware.Text Namespace


ITextDocument.LoadFileAsync Method (IStorageFile, UnicodeEncoding)

ITextDocumentLoadFileAsync Method (IStorageFile, UnicodeEncoding)
Loads document text from an IStorageFile, using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<LineTerminator> LoadFileAsync(
    IStorageFile file,
    UnicodeEncoding encoding
)
Function LoadFileAsync (
    file As IStorageFile,
    encoding As UnicodeEncoding
) As Task(Of LineTerminator)

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to examine.
encoding
Type: Windows.Storage.StreamsUnicodeEncoding
The UnicodeEncoding to use when loading the file.

Return Value

Type: Task LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.
Remarks
This method updates the value of the FileName property.
See Also

Reference

ITextDocument Interface
LoadFileAsync Overload
ActiproSoftware.Text Namespace


ITextDocument.RemoveTextChangedEventHandler Method

ITextDocumentRemoveTextChangedEventHandler Method
Removes an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RemoveTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Sub RemoveTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.RemoveTextChangingEventHandler Method

ITextDocumentRemoveTextChangingEventHandler Method
Removes an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RemoveTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Sub RemoveTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceAll Method

ITextDocumentReplaceAll Method
Overload List
 | Name | Description
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceAll Method (ISearchOptions)

ITextDocumentReplaceAll Method (ISearchOptions)
Performs a replace all operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceAll(
    ISearchOptions options
)
Function ReplaceAll (
    options As ISearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceAll Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceAll Method (ISearchOptions, TextRange[])

ITextDocumentReplaceAll Method (ISearchOptions, TextRange)
Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceAll(
    ISearchOptions options,
    params TextRange[] searchTextRanges
)
Function ReplaceAll (
    options As ISearchOptions,
    ParamArray searchTextRanges As TextRange()
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRanges
Type: ActiproSoftware.TextTextRange
The TextRange array of offsets to search. If everything should be searched, specify the range 0 to the length of the document's current snapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceAll Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceNext Method

ITextDocumentReplaceNext Method
Overload List
 | Name | Description
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceNext Method (ISearchOptions, Int32, Boolean)

ITextDocumentReplaceNext Method (ISearchOptions, Int32, Boolean)
Performs a replace next operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap
)
Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceNext Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)

ITextDocumentReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)
Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextDocument Interface
ReplaceNext Overload
ActiproSoftware.Text Namespace


ITextDocument.ReplaceText Method

ITextDocumentReplaceText Method
Overload List
 | Name | Description
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.ReplaceText Method (ITextChangeType, TextRange, String)

ITextDocumentReplaceText Method (ITextChangeType, TextRange, String)
Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text
)
Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, TextRange)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.ReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)

ITextDocumentReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)
Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text,
    ITextChangeOptions options
)
Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, TextRange, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.ReplaceText Method (ITextChangeType, Int32, Int32, String)

ITextDocumentReplaceText Method (ITextChangeType, Int32, Int32, String)
Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text
)
Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentSetText(ITextChangeType, String)


ITextDocument.ReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)

ITextDocumentReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)
Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text,
    ITextChangeOptions options
)
Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
ReplaceText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.SaveFile Method

ITextDocumentSaveFile Method
Saves document text to a Stream using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SaveFile(
    Stream stream,
    Encoding encoding,
    LineTerminator lineTerminator
)
Sub SaveFile (
    stream As Stream,
    encoding As Encoding,
    lineTerminator As LineTerminator
)

Parameters

stream
Type: System.IOStream
The Stream to write to.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SaveFileAsync Method

ITextDocumentSaveFileAsync Method
Overload List
 | Name | Description
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile.
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SaveFileAsync Method (IStorageFile, LineTerminator)

ITextDocumentSaveFileAsync Method (IStorageFile, LineTerminator)
Saves document text to an IStorageFile.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task SaveFileAsync(
    IStorageFile file,
    LineTerminator lineTerminator
)
Function SaveFileAsync (
    file As IStorageFile,
    lineTerminator As LineTerminator
) As Task

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to update.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.ITextDocument.SaveFileAsync(Windows.Storage.IStorageFile,ActiproSoftware.Text.LineTerminator)"]

Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

ITextDocument Interface
SaveFileAsync Overload
ActiproSoftware.Text Namespace


ITextDocument.SaveFileAsync Method (IStorageFile, Encoding, LineTerminator)

ITextDocumentSaveFileAsync Method (IStorageFile, Encoding, LineTerminator)
Saves document text to an IStorageFile using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task SaveFileAsync(
    IStorageFile file,
    Encoding encoding,
    LineTerminator lineTerminator
)
Function SaveFileAsync (
    file As IStorageFile,
    encoding As Encoding,
    lineTerminator As LineTerminator
) As Task

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to update.
encoding
Type: System.TextEncoding
The Encoding to use when saving the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.ITextDocument.SaveFileAsync(Windows.Storage.IStorageFile,System.Text.Encoding,ActiproSoftware.Text.LineTerminator)"]

Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

ITextDocument Interface
SaveFileAsync Overload
ActiproSoftware.Text Namespace


ITextDocument.SaveFileAsync Method (IStorageFile, UnicodeEncoding, LineTerminator)

ITextDocumentSaveFileAsync Method (IStorageFile, UnicodeEncoding, LineTerminator)
Saves document text to an IStorageFile using the specified encoding.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task SaveFileAsync(
    IStorageFile file,
    UnicodeEncoding encoding,
    LineTerminator lineTerminator
)
Function SaveFileAsync (
    file As IStorageFile,
    encoding As UnicodeEncoding,
    lineTerminator As LineTerminator
) As Task

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to update.
encoding
Type: Windows.Storage.StreamsUnicodeEncoding
The UnicodeEncoding to use when saving the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.ITextDocument.SaveFileAsync(Windows.Storage.IStorageFile,Windows.Storage.Streams.UnicodeEncoding,ActiproSoftware.Text.LineTerminator)"]

Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

ITextDocument Interface
SaveFileAsync Overload
ActiproSoftware.Text Namespace


ITextDocument.SetHeaderAndFooterText Method

ITextDocumentSetHeaderAndFooterText Method
Sets the HeaderText and FooterText, and creates a new snapshot with the results.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SetHeaderAndFooterText(
    string headerText,
    string footerText
)
Function SetHeaderAndFooterText (
    headerText As String,
    footerText As String
) As Boolean

Parameters

headerText
Type: SystemString
The new header text value.
footerText
Type: SystemString
The new footer text value.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SetText Method

ITextDocumentSetText Method
Overload List
 | Name | Description
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.SetText Method (String)

ITextDocumentSetText Method (String)
Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SetText(
    string text
)
Function SetText (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.

This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.

See Also

Reference

ITextDocument Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextDocumentSetText(ITextChangeType, String)
ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)


ITextDocument.SetText Method (ITextChangeType, String)

ITextDocumentSetText Method (ITextChangeType, String)
Replaces all the text in the CurrentSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SetText(
    ITextChangeType type,
    string text
)
Function SetText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
ITextDocumentInsertText(ITextChangeType, Int32, String)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)


ITextDocument.SetText Method (ITextChangeType, String, ITextChangeOptions)

ITextDocumentSetText Method (ITextChangeType, String, ITextChangeOptions)
Replaces all the text in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SetText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Function SetText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

ITextDocument Interface
SetText Overload
ActiproSoftware.Text Namespace
ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)


ITextDocument Events

ITextDocument Events

The ITextDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.FileNameChanged Event

ITextDocumentFileNameChanged Event
Occurs after the value of the FileName property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<StringPropertyChangedEventArgs> FileNameChanged
Event FileNameChanged As EventHandler(Of StringPropertyChangedEventArgs)

Value

Type: SystemEventHandler StringPropertyChangedEventArgs
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsModifiedChanged Event

ITextDocumentIsModifiedChanged Event
Occurs after the value of the IsModified property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler IsModifiedChanged
Event IsModifiedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.IsReadOnlyChanged Event

ITextDocumentIsReadOnlyChanged Event
Occurs after the value of the IsReadOnly property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler IsReadOnlyChanged
Event IsReadOnlyChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TabSizeChanged Event

ITextDocumentTabSizeChanged Event
Occurs after the value of the TabSize property has changed.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler TabSizeChanged
Event TabSizeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TextChanged Event

ITextDocumentTextChanged Event
Occurs after a text change occurs to this document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<TextSnapshotChangedEventArgs> TextChanged
Event TextChanged As EventHandler(Of TextSnapshotChangedEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangedEventArgs
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextDocument.TextChanging Event

ITextDocumentTextChanging Event
Occurs before a text change occurs to this document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<TextSnapshotChangingEventArgs> TextChanging
Event TextChanging As EventHandler(Of TextSnapshotChangingEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangingEventArgs
See Also

Reference

ITextDocument Interface
ActiproSoftware.Text Namespace


ITextFormatter Interface

ITextFormatter Interface
Provides the base requirements of a language formatter that can adjust the whitespace layout of text for better readability.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextFormatter
Public Interface ITextFormatter

The ITextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies formatting to the specified TextSnapshotRange
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace


ITextFormatter Methods

ITextFormatter Methods

The ITextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Format | Applies formatting to the specified TextSnapshotRange
Top
See Also

Reference

ITextFormatter Interface
ActiproSoftware.Text Namespace


ITextFormatter.Format Method

ITextFormatterFormat Method
Applies formatting to the specified TextSnapshotRange

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Format(
    TextSnapshotRange snapshotRange
)
Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange that is requested to be formatted.
Remarks
The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

ITextFormatter Interface
ActiproSoftware.Text Namespace


ITextPositionRangeProvider Interface

ITextPositionRangeProvider Interface
Provides the base requirements for an object that has range of two TextPosition values within a text document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextPositionRangeProvider
Public Interface ITextPositionRangeProvider

The ITextPositionRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | PositionRange | Gets or sets a TextPositionRange that specifies the text position range of the object.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextPositionRangeProvider Properties

ITextPositionRangeProvider Properties

The ITextPositionRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | PositionRange | Gets or sets a TextPositionRange that specifies the text position range of the object.
Top
See Also

Reference

ITextPositionRangeProvider Interface
ActiproSoftware.Text Namespace


ITextPositionRangeProvider.PositionRange Property

ITextPositionRangeProviderPositionRange Property
Gets or sets a TextPositionRange that specifies the text position range of the object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; set; }
Property PositionRange As TextPositionRange
    Get
    Set

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the object.
Remarks
Note that not all objects implement a setter for this property and in the cases of those who don't, an exception may be thrown.
See Also

Reference

ITextPositionRangeProvider Interface
ActiproSoftware.Text Namespace


ITextRangeProvider Interface

ITextRangeProvider Interface
Provides the base requirements for an object that has range of two offset values within a text document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextRangeProvider
Public Interface ITextRangeProvider

The ITextRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextRangeProvider Properties

ITextRangeProvider Properties

The ITextRangeProvider type exposes the following members.

Properties
 | Name | Description
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object.
Top
See Also

Reference

ITextRangeProvider Interface
ActiproSoftware.Text Namespace


ITextRangeProvider.TextRange Property

ITextRangeProviderTextRange Property
Gets or sets a TextRange that specifies the text range of the object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRange { get; set; }
Property TextRange As TextRange
    Get
    Set

Property Value

Type: TextRange
A TextRange that specifies the text range of the object.
Remarks
Note that not all objects implement a setter for this property and in the cases of those who don't, an exception may be thrown.
See Also

Reference

ITextRangeProvider Interface
ActiproSoftware.Text Namespace


ITextSnapshot Interface

ITextSnapshot Interface
Provides the base requirements for an immutable snapshot of an ITextDocument for a certain ITextVersion of that document.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextSnapshot : ITextRangeProvider
Public Interface ITextSnapshot
    Inherits ITextRangeProvider

The ITextSnapshot type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this snapshot applies.
Public property | FooterText | Gets the footer text to append to the end of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | HasContent | Gets whether there is content in the snapshot.
Public property | HeaderText | Gets the header text to append to the start of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | Item | Gets a character in the snapshot.
Public property | Length | Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.
Public property | Lines | Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the entire text snapshot.
Public property | Text | Gets the entire text of the snapshot using CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Version | Gets the ITextVersion that specifies the text version represented by the snapshot.
Top
Methods
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | Export | Exports the contents of the snapshot to another text format, such as HTML or RTF.
Public method | FindAll(ISearchOptions) | Performs a find all operation.
Public method | FindAll(ISearchOptions, TextRange) | Performs a find all operation over a specific range of the snapshot.
Public method | FindNext(ISearchOptions, Int32, Boolean) | Performs a find next operation.
Public method | FindNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a find next operation over a specific range of the snapshot.
Public method | GetMergedBufferReader | Returns an ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.
Public method | GetReader(Int32) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetReader(TextPosition) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetSubstring(TextRange) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(Int32, Int32) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(TextRange, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetSubstring(Int32, Int32, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetText | Returns the entire text of the snapshot using the specified LineTerminator for line ends.
Public method | GetTextStatistics | Returns an ITextStatistics for the snapshot's text, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.
Public method | GetWordText | Gets the text of the word at the specified offset.
Public method | GetWordTextRange | Gets a TextRange of offsets that contain the word at the specified offset.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | PositionRangeToTextRange | Returns the TextRange that represents the specified TextPositionRange within the snapshot.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the text lines.
Public method | TextRangeToPositionRange | Returns the TextPositionRange that represents the specified TextRange within the snapshot.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextSnapshot Properties

ITextSnapshot Properties

The ITextSnapshot type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this snapshot applies.
Public property | FooterText | Gets the footer text to append to the end of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | HasContent | Gets whether there is content in the snapshot.
Public property | HeaderText | Gets the header text to append to the start of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.
Public property | Item | Gets a character in the snapshot.
Public property | Length | Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.
Public property | Lines | Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the entire text snapshot.
Public property | Text | Gets the entire text of the snapshot using CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Version | Gets the ITextVersion that specifies the text version represented by the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Document Property

ITextSnapshotDocument Property
Gets the ITextDocument for which this snapshot applies.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextDocument Document { get; }
ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument for which this snapshot applies.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FooterText Property

ITextSnapshotFooterText Property
Gets the footer text to append to the end of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FooterText { get; }
ReadOnly Property FooterText As String
    Get

Property Value

Type: String
The footer text to append to the end of the snapshot's Text.
Remarks
The use of this property, along with HeaderText, allows for editing 'fragments' of code. The header and footer sections provide the outer code that surrounds the 'fragment' being edited in the snapshot's Text property.

An example is when editing a method body in a language like C#. The HeaderText would contain the namespace, class, and member declaration starts. The FooterText would contain the namespace, class, and member declaration ends. The document would edit the 'fragment' of statements within the header and footer, and all of them would be combined for parsing purposes.

See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace
ITextSnapshotGetMergedBufferReader
ITextSnapshotHeaderText
ITextSnapshotText


ITextSnapshot.HasContent Property

ITextSnapshotHasContent Property
Gets whether there is content in the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasContent { get; }
ReadOnly Property HasContent As Boolean
    Get

Property Value

Type: Boolean
true if there is content in the snapshot; otherwise, false.
Remarks
This property simply checks whether the snapshot has a length greater than 0.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.HeaderText Property

ITextSnapshotHeaderText Property
Gets the header text to append to the start of the snapshot's Text when scanning through the GetMergedBufferReader result, typically used when parsing the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string HeaderText { get; }
ReadOnly Property HeaderText As String
    Get

Property Value

Type: String
The header text to append to the start of the snapshot's Text.
Remarks
The use of this property, along with FooterText, allows for editing 'fragments' of code. The header and footer sections provide the outer code that surrounds the 'fragment' being edited in the snapshot's Text property.

An example is when editing a method body in a language like C#. The HeaderText would contain the namespace, class, and member declaration starts. The FooterText would contain the namespace, class, and member declaration ends. The document would edit the 'fragment' of statements within the header and footer, and all of them would be combined for parsing purposes.

See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace
ITextSnapshotGetMergedBufferReader
ITextSnapshotHeaderText
ITextSnapshotText


ITextSnapshot.Item Property

ITextSnapshotItem Property
Gets a character in the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char this[
    int index
] { get; }
ReadOnly Property Item (
    index As Integer
) As Char
    Get

Parameters

index
Type: SystemInt32
The index of the character to return.

Property Value

Type: Char
A character in the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Length Property

ITextSnapshotLength Property
Gets the number of characters in the snapshot, excluding any carriage-returns but including newlines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the snapshot, excluding any carriage-returns but including newlines.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Lines Property

ITextSnapshotLines Property
Gets the collection of ITextSnapshotLine objects, each of which represents a line in the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotLineCollection Lines { get; }
ReadOnly Property Lines As ITextSnapshotLineCollection
    Get

Property Value

Type: ITextSnapshotLineCollection
A ITextSnapshotLineCollection containing the lines in the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.SnapshotRange Property

ITextSnapshotSnapshotRange Property
Gets a TextSnapshotRange that contains the entire text snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the entire text snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Text Property

ITextSnapshotText Property
Gets the entire text of the snapshot using CarriageReturnNewline for line ends, which is not intended to be used for parsing for classification reasons.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The entire text of the snapshot using CarriageReturnNewline for line ends.
Remarks
This property should not be used as input for language parsers or taggers since internally for performance reasons, text is stored with newlines-only as line terminators. Instead, call GetText(LineTerminator) with the Newline parameter when needing the text for parsing or tagging reasons.

The GetText(LineTerminator) method can be used to obtain text using any of the LineTerminator options.

See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.Version Property

ITextSnapshotVersion Property
Gets the ITextVersion that specifies the text version represented by the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersion Version { get; }
ReadOnly Property Version As ITextVersion
    Get

Property Value

Type: ITextVersion
The ITextVersion that specifies the text version represented by the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot Methods

ITextSnapshot Methods

The ITextSnapshot type exposes the following members.

Methods
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | Export | Exports the contents of the snapshot to another text format, such as HTML or RTF.
Public method | FindAll(ISearchOptions) | Performs a find all operation.
Public method | FindAll(ISearchOptions, TextRange) | Performs a find all operation over a specific range of the snapshot.
Public method | FindNext(ISearchOptions, Int32, Boolean) | Performs a find next operation.
Public method | FindNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a find next operation over a specific range of the snapshot.
Public method | GetMergedBufferReader | Returns an ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.
Public method | GetReader(Int32) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetReader(TextPosition) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetSubstring(TextRange) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(Int32, Int32) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(TextRange, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetSubstring(Int32, Int32, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetText | Returns the entire text of the snapshot using the specified LineTerminator for line ends.
Public method | GetTextStatistics | Returns an ITextStatistics for the snapshot's text, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.
Public method | GetWordText | Gets the text of the word at the specified offset.
Public method | GetWordTextRange | Gets a TextRange of offsets that contain the word at the specified offset.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | PositionRangeToTextRange | Returns the TextRange that represents the specified TextPositionRange within the snapshot.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the text lines.
Public method | TextRangeToPositionRange | Returns the TextPositionRange that represents the specified TextRange within the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.CreateTextChange Method

ITextSnapshotCreateTextChange Method
Overload List
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.CreateTextChange Method (ITextChangeType)

ITextSnapshotCreateTextChange Method (ITextChangeType)
Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type
)
Function CreateTextChange (
    type As ITextChangeType
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextSnapshot Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextSnapshot.CreateTextChange Method (ITextChangeType, ITextChangeOptions)

ITextSnapshotCreateTextChange Method (ITextChangeType, ITextChangeOptions)
Creates an ITextChange based on this snapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextChange CreateTextChange(
    ITextChangeType type,
    ITextChangeOptions options
)
Function CreateTextChange (
    type As ITextChangeType,
    options As ITextChangeOptions
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: ITextChange
The ITextChange that was created.
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

ITextSnapshot Interface
CreateTextChange Overload
ActiproSoftware.Text Namespace


ITextSnapshot.Export Method

ITextSnapshotExport Method
Exports the contents of the snapshot to another text format, such as HTML or RTF.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Export(
    ITextExporter exporter
)
Function Export (
    exporter As ITextExporter
) As String

Parameters

exporter
Type: ActiproSoftware.Text.ExportersITextExporter
The ITextExporter to use for the export operation.

Return Value

Type: String
The exported text.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FindAll Method

ITextSnapshotFindAll Method
Overload List
 | Name | Description
Public method | FindAll(ISearchOptions) | Performs a find all operation.
Public method | FindAll(ISearchOptions, TextRange) | Performs a find all operation over a specific range of the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FindAll Method (ISearchOptions)

ITextSnapshotFindAll Method (ISearchOptions)
Performs a find all operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindAll(
    ISearchOptions options
)
Function FindAll (
    options As ISearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindAll Overload
ActiproSoftware.Text Namespace


ITextSnapshot.FindAll Method (ISearchOptions, TextRange)

ITextSnapshotFindAll Method (ISearchOptions, TextRange)
Performs a find all operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindAll(
    ISearchOptions options,
    TextRange searchTextRange
)
Function FindAll (
    options As ISearchOptions,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the snapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindAll Overload
ActiproSoftware.Text Namespace


ITextSnapshot.FindNext Method

ITextSnapshotFindNext Method
Overload List
 | Name | Description
Public method | FindNext(ISearchOptions, Int32, Boolean) | Performs a find next operation.
Public method | FindNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a find next operation over a specific range of the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.FindNext Method (ISearchOptions, Int32, Boolean)

ITextSnapshotFindNext Method (ISearchOptions, Int32, Boolean)
Performs a find next operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap
)
Function FindNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindNext Overload
ActiproSoftware.Text Namespace


ITextSnapshot.FindNext Method (ISearchOptions, Int32, Boolean, TextRange)

ITextSnapshotFindNext Method (ISearchOptions, Int32, Boolean, TextRange)
Performs a find next operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Function FindNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

ITextSnapshot Interface
FindNext Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetMergedBufferReader Method

ITextSnapshotGetMergedBufferReader Method
Returns an ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextBufferReader GetMergedBufferReader()
Function GetMergedBufferReader As ITextBufferReader

Return Value

Type: ITextBufferReader
An ITextBufferReader that allows scanning over a union of the HeaderText, Text, and FooterText.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace
ITextSnapshotFooterText
ITextSnapshotHeaderText
ITextSnapshotText


ITextSnapshot.GetReader Method

ITextSnapshotGetReader Method
Overload List
 | Name | Description
Public method | GetReader(Int32) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Public method | GetReader(TextPosition) | Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetReader Method (Int32)

ITextSnapshotGetReader Method (Int32)
Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotReader GetReader(
    int offset
)
Function GetReader (
    offset As Integer
) As ITextSnapshotReader

Parameters

offset
Type: SystemInt32
The offset at which to initalize the reader.

Return Value

Type: ITextSnapshotReader
An ITextBufferReader that can be used to navigate through the text and token contents of the snapshot.
See Also

Reference

ITextSnapshot Interface
GetReader Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetReader Method (TextPosition)

ITextSnapshotGetReader Method (TextPosition)
Returns an ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotReader GetReader(
    TextPosition position
)
Function GetReader (
    position As TextPosition
) As ITextSnapshotReader

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition at which to initalize the reader.

Return Value

Type: ITextSnapshotReader
An ITextSnapshotReader that can be used to navigate through the text and token contents of the snapshot.
See Also

Reference

ITextSnapshot Interface
GetReader Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method

ITextSnapshotGetSubstring Method
Overload List
 | Name | Description
Public method | GetSubstring(TextRange) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(Int32, Int32) | Returns a substring from the snapshot text using CarriageReturnNewline for line ends.
Public method | GetSubstring(TextRange, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Public method | GetSubstring(Int32, Int32, LineTerminator) | Returns a substring from the snapshot text using the specified LineTerminator for line ends.
Top
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (TextRange)

ITextSnapshotGetSubstring Method (TextRange)
Returns a substring from the snapshot text using CarriageReturnNewline for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetSubstring(
    TextRange textRange
)
Function GetSubstring (
    textRange As TextRange
) As String

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text to retrieve.

Return Value

Type: String
The substring from the snapshot text using CarriageReturnNewline for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (Int32, Int32)

ITextSnapshotGetSubstring Method (Int32, Int32)
Returns a substring from the snapshot text using CarriageReturnNewline for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetSubstring(
    int offset,
    int length
)
Function GetSubstring (
    offset As Integer,
    length As Integer
) As String

Parameters

offset
Type: SystemInt32
The offset at which to retrieve the text.
length
Type: SystemInt32
The number of characters to return.

Return Value

Type: String
The substring from the snapshot text using CarriageReturnNewline for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (TextRange, LineTerminator)

ITextSnapshotGetSubstring Method (TextRange, LineTerminator)
Returns a substring from the snapshot text using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetSubstring(
    TextRange textRange,
    LineTerminator lineTerminator
)
Function GetSubstring (
    textRange As TextRange,
    lineTerminator As LineTerminator
) As String

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text to retrieve.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The substring from the snapshot text using the specified LineTerminator for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetSubstring Method (Int32, Int32, LineTerminator)

ITextSnapshotGetSubstring Method (Int32, Int32, LineTerminator)
Returns a substring from the snapshot text using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetSubstring(
    int offset,
    int length,
    LineTerminator lineTerminator
)
Function GetSubstring (
    offset As Integer,
    length As Integer,
    lineTerminator As LineTerminator
) As String

Parameters

offset
Type: SystemInt32
The offset at which to retrieve the text.
length
Type: SystemInt32
The number of characters to return.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The substring from the snapshot text using the specified LineTerminator for line ends.
See Also

Reference

ITextSnapshot Interface
GetSubstring Overload
ActiproSoftware.Text Namespace


ITextSnapshot.GetText Method

ITextSnapshotGetText Method
Returns the entire text of the snapshot using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetText(
    LineTerminator lineTerminator
)
Function GetText (
    lineTerminator As LineTerminator
) As String

Parameters

lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The entire text of the snapshot using the specified LineTerminator for line ends.
Remarks
To retrieve the text in the format expected by a language parser or tagger, pass Newline as the lineTerminator parameter.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetTextStatistics Method

ITextSnapshotGetTextStatistics Method
Returns an ITextStatistics for the snapshot's text, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextStatistics GetTextStatistics()
Function GetTextStatistics As ITextStatistics

Return Value

Type: ITextStatistics
An ITextStatistics for the snapshot's text.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetWordText Method

ITextSnapshotGetWordText Method
Gets the text of the word at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetWordText(
    int offset
)
Function GetWordText (
    offset As Integer
) As String

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: String
The text of the word at the specified offset.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.GetWordTextRange Method

ITextSnapshotGetWordTextRange Method
Gets a TextRange of offsets that contain the word at the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange GetWordTextRange(
    int offset
)
Function GetWordTextRange (
    offset As Integer
) As TextRange

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: TextRange
A TextRange containing a range of offsets that contain the word at the specified offset.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.OffsetToPosition Method

ITextSnapshotOffsetToPosition Method
Returns the TextPosition that represents the specified offset within the text lines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition OffsetToPosition(
    int offset
)
Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the snapshot.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the text lines.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.PositionRangeToTextRange Method

ITextSnapshotPositionRangeToTextRange Method
Returns the TextRange that represents the specified TextPositionRange within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange PositionRangeToTextRange(
    TextPositionRange positionRange
)
Function PositionRangeToTextRange (
    positionRange As TextPositionRange
) As TextRange

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange within the snapshot.

Return Value

Type: TextRange
The TextRange that represents the specified TextPositionRange within the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.PositionToOffset Method

ITextSnapshotPositionToOffset Method
Returns the offset for the specified TextPosition within the text lines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PositionToOffset(
    TextPosition position
)
Function PositionToOffset (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition of a character within the text lines.

Return Value

Type: Int32
The offset for the specified TextPosition within the text lines.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshot.TextRangeToPositionRange Method

ITextSnapshotTextRangeToPositionRange Method
Returns the TextPositionRange that represents the specified TextRange within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange TextRangeToPositionRange(
    TextRange textRange
)
Function TextRangeToPositionRange (
    textRange As TextRange
) As TextPositionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange within the snapshot.

Return Value

Type: TextPositionRange
The TextPositionRange that represents the specified TextRange within the snapshot.
See Also

Reference

ITextSnapshot Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine Interface

ITextSnapshotLine Interface
Provides the base requirements for a line in an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextSnapshotLine : ITextRangeProvider
Public Interface ITextSnapshotLine
    Inherits ITextRangeProvider

The ITextSnapshotLine type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset at which the line ends, excluding the line terminator.
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.
Public property | FirstNonWhitespaceCharacterOffset | Gets the offset of the first non-whitespace character in the line.
Public property | IndentAmount | Gets or sets the indent amount, in columns, of the line.
Public property | Index | Gets the index of the line within the ITextSnapshot.
Public property | Length | Gets the length of the line, excluding the line terminator.
Public property | Snapshot | Gets the ITextSnapshot that contains the line.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the text of the line, excluding the line terminator.
Public property | StartOffset | Gets the offset at which the line starts.
Public property | Text | Gets the text of the line, excluding the line terminator.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the line contains the specified offset.
Public method | GetIndentAmountBefore | Returns indent amount, in columns, of the line before the specified offset.
Public method | IsLineEnd | Returns whether the specified offset ends the line.
Public method | IsLineStart | Returns whether the specified offset starts the line.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextSnapshotLine Properties

ITextSnapshotLine Properties

The ITextSnapshotLine type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset at which the line ends, excluding the line terminator.
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.
Public property | FirstNonWhitespaceCharacterOffset | Gets the offset of the first non-whitespace character in the line.
Public property | IndentAmount | Gets or sets the indent amount, in columns, of the line.
Public property | Index | Gets the index of the line within the ITextSnapshot.
Public property | Length | Gets the length of the line, excluding the line terminator.
Public property | Snapshot | Gets the ITextSnapshot that contains the line.
Public property | SnapshotRange | Gets a TextSnapshotRange that contains the text of the line, excluding the line terminator.
Public property | StartOffset | Gets the offset at which the line starts.
Public property | Text | Gets the text of the line, excluding the line terminator.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
Top
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.EndOffset Property

ITextSnapshotLineEndOffset Property
Gets the offset at which the line ends, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the line ends, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.EndOffsetIncludingLineTerminator Property

ITextSnapshotLineEndOffsetIncludingLineTerminator Property
Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffsetIncludingLineTerminator { get; }
ReadOnly Property EndOffsetIncludingLineTerminator As Integer
    Get

Property Value

Type: Int32
The offset at which the line ends, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.FirstNonWhitespaceCharacterOffset Property

ITextSnapshotLineFirstNonWhitespaceCharacterOffset Property
Gets the offset of the first non-whitespace character in the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FirstNonWhitespaceCharacterOffset { get; }
ReadOnly Property FirstNonWhitespaceCharacterOffset As Integer
    Get

Property Value

Type: Int32
The offset of the first non-whitespace character in the line.
Remarks
If no non-whitespace character is found, the value of EndOffset is returned.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IndentAmount Property

ITextSnapshotLineIndentAmount Property
Gets or sets the indent amount, in columns, of the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndentAmount { get; set; }
Property IndentAmount As Integer
    Get
    Set

Property Value

Type: Int32
The indent amount, in columns, of the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Index Property

ITextSnapshotLineIndex Property
Gets the index of the line within the ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the line within the ITextSnapshot.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Length Property

ITextSnapshotLineLength Property
Gets the length of the line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of the line, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Snapshot Property

ITextSnapshotLineSnapshot Property
Gets the ITextSnapshot that contains the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.SnapshotRange Property

ITextSnapshotLineSnapshotRange Property
Gets a TextSnapshotRange that contains the text of the line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the text of the line, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.StartOffset Property

ITextSnapshotLineStartOffset Property
Gets the offset at which the line starts.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the line starts.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Text Property

ITextSnapshotLineText Property
Gets the text of the line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text of the line, excluding the line terminator.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.TextRangeIncludingLineTerminator Property

ITextSnapshotLineTextRangeIncludingLineTerminator Property
Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRangeIncludingLineTerminator { get; }
ReadOnly Property TextRangeIncludingLineTerminator As TextRange
    Get

Property Value

Type: TextRange
The TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine Methods

ITextSnapshotLine Methods

The ITextSnapshotLine type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the line contains the specified offset.
Public method | GetIndentAmountBefore | Returns indent amount, in columns, of the line before the specified offset.
Public method | IsLineEnd | Returns whether the specified offset ends the line.
Public method | IsLineStart | Returns whether the specified offset starts the line.
Top
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.Contains Method

ITextSnapshotLineContains Method
Returns whether the line contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the line contains the offset; otherwise, false.
Remarks
This method returns false if the offset falls on the line terminator of the line.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.GetIndentAmountBefore Method

ITextSnapshotLineGetIndentAmountBefore Method
Returns indent amount, in columns, of the line before the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetIndentAmountBefore(
    int offset
)
Function GetIndentAmountBefore (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:ActiproSoftware.Text.ITextSnapshotLine.GetIndentAmountBefore(System.Int32)"]

Field Value

Type: Int32
The indent amount, in columns, of the line before the specified offset.

Return Value

Type: Int32

[Missing <returns> documentation for "M:ActiproSoftware.Text.ITextSnapshotLine.GetIndentAmountBefore(System.Int32)"]

See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IsLineEnd Method

ITextSnapshotLineIsLineEnd Method
Returns whether the specified offset ends the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLineEnd(
    int offset
)
Function IsLineEnd (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the offset ends the line; otherwise, false.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLine.IsLineStart Method

ITextSnapshotLineIsLineStart Method
Returns whether the specified offset starts the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLineStart(
    int offset
)
Function IsLineStart (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the offset starts the line; otherwise, false.
See Also

Reference

ITextSnapshotLine Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection Interface

ITextSnapshotLineCollection Interface
Encapsulates a collection of ITextSnapshotLine objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextSnapshotLineCollection : ICollection,
    IEnumerable
Public Interface ITextSnapshotLineCollection
    Inherits ICollection, IEnumerable

The ITextSnapshotLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection.)
Public property | IsSynchronized | (Inherited from ICollection.)
Public property | Item | Gets the ITextSnapshotLine at the specified index. [C#] In C#, this property is the indexer for the ITextSnapshotLineCollection class.
Public property | SyncRoot | (Inherited from ICollection.)
Top
Methods
 | Name | Description
Public method | CopyTo | (Inherited from ICollection.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | GetLineTextRange | Returns the TextRange of the specified line, excluding the line terminator.
Public method | IndexOf | Finds the index of the ITextSnapshotLine that contains the specified offset.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.TextITextSnapshotLine


ITextSnapshotLineCollection Properties

ITextSnapshotLineCollection Properties

The ITextSnapshotLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection.)
Public property | IsSynchronized | (Inherited from ICollection.)
Public property | Item | Gets the ITextSnapshotLine at the specified index. [C#] In C#, this property is the indexer for the ITextSnapshotLineCollection class.
Public property | SyncRoot | (Inherited from ICollection.)
Top
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection.Item Property

ITextSnapshotLineCollectionItem Property
Gets the ITextSnapshotLine at the specified index.

[C#] In C#, this property is the indexer for the ITextSnapshotLineCollection class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotLine this[
    int index
] { get; }
ReadOnly Property Item (
    index As Integer
) As ITextSnapshotLine
    Get

Parameters

index
Type: SystemInt32
The index of the ITextSnapshotLine to return.

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine at the specified index.
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection Methods

ITextSnapshotLineCollection Methods

The ITextSnapshotLineCollection type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | (Inherited from ICollection.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | GetLineTextRange | Returns the TextRange of the specified line, excluding the line terminator.
Public method | IndexOf | Finds the index of the ITextSnapshotLine that contains the specified offset.
Top
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection.GetLineTextRange Method

ITextSnapshotLineCollectionGetLineTextRange Method
Returns the TextRange of the specified line, excluding the line terminator.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange GetLineTextRange(
    int index
)
Function GetLineTextRange (
    index As Integer
) As TextRange

Parameters

index
Type: SystemInt32
The index of the line to examine.

Return Value

Type: TextRange
The TextRange of the specified line, excluding the line terminator.
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotLineCollection.IndexOf Method

ITextSnapshotLineCollectionIndexOf Method
Finds the index of the ITextSnapshotLine that contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndexOf(
    int offset
)
Function IndexOf (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset to look for.

Return Value

Type: Int32
The index of the ITextSnapshotLine that contains the specified offset.
See Also

Reference

ITextSnapshotLineCollection Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader Interface

ITextSnapshotReader Interface
Provides the base requirements for an object that reads through characters and tokens from an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextSnapshotReader
Public Interface ITextSnapshotReader

The ITextSnapshotReader type exposes the following members.

Properties
 | Name | Description
Public property | BufferReader | Gets the ITextBufferReader that is wrapped by this reader and can be used for performing fast low-level text scanning on the snapshot.
Public property | Character | Gets the character at the Offset.
Public property | IsAtSnapshotEnd | Gets whether the current Offset is at the end of the snapshot.
Public property | IsAtSnapshotLineEnd | Gets whether the current Offset is at the end of an ITextSnapshotLine.
Public property | IsAtSnapshotLineStart | Gets whether the current Offset is at the start of an ITextSnapshotLine.
Public property | IsAtSnapshotStart | Gets whether the current Offset is at the start of the snapshot.
Public property | IsAtTokenStart | Gets whether the current Offset is at the start of the Token.
Public property | IsCharacterLineTerminator | Gets whether the Character is a newline character.
Public property | IsCharacterWhitespace | Gets whether the Character is categorized as a whitespace character.
Public property | Language | Gets the ISyntaxLanguage that contains the current offset within the snapshot.
Public property | Length | Gets the length of the snapshot.
Public property | Offset | Gets or sets the current offset within the snapshot.
Public property | Options | Gets the ITextSnapshotReaderOptions that contains optimization options for the reader.
Public property | Position | Gets the current TextPosition within the snapshot.
Public property | Snapshot | Gets the core ITextSnapshot that is examined by this reader.
Public property | SnapshotLine | Gets the ITextSnapshotLine that contains the Offset.
Public property | Token | Gets the IToken that contains the offset indicated by Offset.
Public property | TokenText | Gets the snapshot text contained by the Token.
Top
Methods
 | Name | Description
Public method | GoToCurrentSnapshotLineEnd | Moves the Offset to the end of the snapshot line that contains the Offset.
Public method | GoToCurrentSnapshotLineStart | Moves the Offset to the start of the snapshot line that contains the Offset.
Public method | GoToCurrentTokenStart | Moves the Offset to the start of the IToken that contains the Offset.
Public method | GoToCurrentWordEnd | Moves to the current word's end offset.
Public method | GoToCurrentWordStart | Moves to the current word's start offset.
Public method | GoToNextMatchingTokenById | Moves the Offset to the next matching token where there can be nested token pairs.
Public method | GoToNextSnapshotLineStart | Moves the Offset to the start of the snapshot line after the snapshot line that contains the Offset.
Public method | GoToNextToken | Moves to the next token's start offset.
Public method | GoToNextToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToNextToken(PredicateIToken) | Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches the specified ID.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches any of the specified IDs.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches the specified key.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches any of the specified keys.
Public method | GoToNextWordStart | Moves to the next word's start offset.
Public method | GoToPreviousMatchingTokenById | Moves the Offset to the previous matching token where there can be nested token pairs.
Public method | GoToPreviousSnapshotLineEnd | Moves the Offset to the end of the snapshot line before the snapshot line that contains the Offset.
Public method | GoToPreviousToken | Moves to the previous token's start offset.
Public method | GoToPreviousToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToPreviousToken(PredicateIToken) | Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches the specified ID.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches any of the specified IDs.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches the specified key.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches any of the specified keys.
Public method | GoToPreviousWordStart | Moves to the previous word's start character.
Public method | GoToSnapshotEnd | Moves the Offset to the end of the Snapshot.
Public method | GoToSnapshotStart | Moves the Offset to the start of the Snapshot.
Public method | PeekCharacter | Peeks at a single character without seeking past it.
Public method | PeekCharacterReverse | Reverse peeks at a single character without seeking past it.
Public method | PeekText | Peeks at a string without seeking past it.
Public method | PeekTextReverse | Reverse peeks at a string without seeking past it.
Public method | PeekToken | Peeks at a single IToken from the snapshot without seeking past it.
Public method | PeekTokenReverse | Reverse peeks at a single IToken from the snapshot without seeking past it.
Public method | ReadCharacter | Reads a single character and seeks forward one offset.
Public method | ReadCharacterReverse | Reverse reads a single character and seeks backward one offset.
Public method | ReadCharacterReverseThrough(Char) | Reverse reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterReverseThrough(Char, Int32) | Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadCharacterThrough(Char) | Reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterThrough(Char, Int32) | Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadText | Reads a string and seeks forward to the end of it.
Public method | ReadTextReverse | Reverse reads a string and seeks backward to the start of it.
Public method | ReadToken | Reads a single IToken from the snapshot and seeks forward one IToken.
Public method | ReadTokenReverse | Reverse reads a single IToken from the snapshot and seeks backward one IToken.
Public method | SeekCharacter | Moves the Offset by the specified amount.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextSnapshotReader Properties

ITextSnapshotReader Properties

The ITextSnapshotReader type exposes the following members.

Properties
 | Name | Description
Public property | BufferReader | Gets the ITextBufferReader that is wrapped by this reader and can be used for performing fast low-level text scanning on the snapshot.
Public property | Character | Gets the character at the Offset.
Public property | IsAtSnapshotEnd | Gets whether the current Offset is at the end of the snapshot.
Public property | IsAtSnapshotLineEnd | Gets whether the current Offset is at the end of an ITextSnapshotLine.
Public property | IsAtSnapshotLineStart | Gets whether the current Offset is at the start of an ITextSnapshotLine.
Public property | IsAtSnapshotStart | Gets whether the current Offset is at the start of the snapshot.
Public property | IsAtTokenStart | Gets whether the current Offset is at the start of the Token.
Public property | IsCharacterLineTerminator | Gets whether the Character is a newline character.
Public property | IsCharacterWhitespace | Gets whether the Character is categorized as a whitespace character.
Public property | Language | Gets the ISyntaxLanguage that contains the current offset within the snapshot.
Public property | Length | Gets the length of the snapshot.
Public property | Offset | Gets or sets the current offset within the snapshot.
Public property | Options | Gets the ITextSnapshotReaderOptions that contains optimization options for the reader.
Public property | Position | Gets the current TextPosition within the snapshot.
Public property | Snapshot | Gets the core ITextSnapshot that is examined by this reader.
Public property | SnapshotLine | Gets the ITextSnapshotLine that contains the Offset.
Public property | Token | Gets the IToken that contains the offset indicated by Offset.
Public property | TokenText | Gets the snapshot text contained by the Token.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.BufferReader Property

ITextSnapshotReaderBufferReader Property
Gets the ITextBufferReader that is wrapped by this reader and can be used for performing fast low-level text scanning on the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextBufferReader BufferReader { get; }
ReadOnly Property BufferReader As ITextBufferReader
    Get

Property Value

Type: ITextBufferReader
The ITextBufferReader that can be used for performing fast low-level text scanning on the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Character Property

ITextSnapshotReaderCharacter Property
Gets the character at the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char Character { get; }
ReadOnly Property Character As Char
    Get

Property Value

Type: Char
The character at the Offset.
Remarks
This value is the same as the return value of the PeekCharacter method.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotEnd Property

ITextSnapshotReaderIsAtSnapshotEnd Property
Gets whether the current Offset is at the end of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtSnapshotEnd { get; }
ReadOnly Property IsAtSnapshotEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of the snapshot; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotLineEnd Property

ITextSnapshotReaderIsAtSnapshotLineEnd Property
Gets whether the current Offset is at the end of an ITextSnapshotLine.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtSnapshotLineEnd { get; }
ReadOnly Property IsAtSnapshotLineEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of an ITextSnapshotLine; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotLineStart Property

ITextSnapshotReaderIsAtSnapshotLineStart Property
Gets whether the current Offset is at the start of an ITextSnapshotLine.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtSnapshotLineStart { get; }
ReadOnly Property IsAtSnapshotLineStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of an ITextSnapshotLine; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtSnapshotStart Property

ITextSnapshotReaderIsAtSnapshotStart Property
Gets whether the current Offset is at the start of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtSnapshotStart { get; }
ReadOnly Property IsAtSnapshotStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the snapshot; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsAtTokenStart Property

ITextSnapshotReaderIsAtTokenStart Property
Gets whether the current Offset is at the start of the Token.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtTokenStart { get; }
ReadOnly Property IsAtTokenStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the Token; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsCharacterLineTerminator Property

ITextSnapshotReaderIsCharacterLineTerminator Property
Gets whether the Character is a newline character.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsCharacterLineTerminator { get; }
ReadOnly Property IsCharacterLineTerminator As Boolean
    Get

Property Value

Type: Boolean
true if the Character is a newline character; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.IsCharacterWhitespace Property

ITextSnapshotReaderIsCharacterWhitespace Property
Gets whether the Character is categorized as a whitespace character.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsCharacterWhitespace { get; }
ReadOnly Property IsCharacterWhitespace As Boolean
    Get

Property Value

Type: Boolean
true if the Character is categorized as a whitespace character; otherwise, false.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Language Property

ITextSnapshotReaderLanguage Property
Gets the ISyntaxLanguage that contains the current offset within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISyntaxLanguage Language { get; }
ReadOnly Property Language As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that contains the current offset within the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Length Property

ITextSnapshotReaderLength Property
Gets the length of the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Offset Property

ITextSnapshotReaderOffset Property
Gets or sets the current offset within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Offset { get; set; }
Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The current offset within the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Options Property

ITextSnapshotReaderOptions Property
Gets the ITextSnapshotReaderOptions that contains optimization options for the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotReaderOptions Options { get; }
ReadOnly Property Options As ITextSnapshotReaderOptions
    Get

Property Value

Type: ITextSnapshotReaderOptions
The ITextSnapshotReaderOptions that contains optimization options for the reader.
Remarks
Configure the options before accessing any members on this reader instance.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Position Property

ITextSnapshotReaderPosition Property
Gets the current TextPosition within the snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition Position { get; }
ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The current TextPosition within the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Snapshot Property

ITextSnapshotReaderSnapshot Property
Gets the core ITextSnapshot that is examined by this reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The core ITextSnapshot that is examined by this reader.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.SnapshotLine Property

ITextSnapshotReaderSnapshotLine Property
Gets the ITextSnapshotLine that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotLine SnapshotLine { get; }
ReadOnly Property SnapshotLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the Offset.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.Token Property

ITextSnapshotReaderToken Property
Gets the IToken that contains the offset indicated by Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken Token { get; }
ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The IToken that contains the offset indicated by Offset.
Remarks
This value is the same as the return value of the PeekToken method.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.TokenText Property

ITextSnapshotReaderTokenText Property
Gets the snapshot text contained by the Token.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string TokenText { get; }
ReadOnly Property TokenText As String
    Get

Property Value

Type: String
The snapshot text contained by the Token.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader Methods

ITextSnapshotReader Methods

The ITextSnapshotReader type exposes the following members.

Methods
 | Name | Description
Public method | GoToCurrentSnapshotLineEnd | Moves the Offset to the end of the snapshot line that contains the Offset.
Public method | GoToCurrentSnapshotLineStart | Moves the Offset to the start of the snapshot line that contains the Offset.
Public method | GoToCurrentTokenStart | Moves the Offset to the start of the IToken that contains the Offset.
Public method | GoToCurrentWordEnd | Moves to the current word's end offset.
Public method | GoToCurrentWordStart | Moves to the current word's start offset.
Public method | GoToNextMatchingTokenById | Moves the Offset to the next matching token where there can be nested token pairs.
Public method | GoToNextSnapshotLineStart | Moves the Offset to the start of the snapshot line after the snapshot line that contains the Offset.
Public method | GoToNextToken | Moves to the next token's start offset.
Public method | GoToNextToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToNextToken(PredicateIToken) | Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches the specified ID.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches any of the specified IDs.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches the specified key.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches any of the specified keys.
Public method | GoToNextWordStart | Moves to the next word's start offset.
Public method | GoToPreviousMatchingTokenById | Moves the Offset to the previous matching token where there can be nested token pairs.
Public method | GoToPreviousSnapshotLineEnd | Moves the Offset to the end of the snapshot line before the snapshot line that contains the Offset.
Public method | GoToPreviousToken | Moves to the previous token's start offset.
Public method | GoToPreviousToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToPreviousToken(PredicateIToken) | Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches the specified ID.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches any of the specified IDs.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches the specified key.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches any of the specified keys.
Public method | GoToPreviousWordStart | Moves to the previous word's start character.
Public method | GoToSnapshotEnd | Moves the Offset to the end of the Snapshot.
Public method | GoToSnapshotStart | Moves the Offset to the start of the Snapshot.
Public method | PeekCharacter | Peeks at a single character without seeking past it.
Public method | PeekCharacterReverse | Reverse peeks at a single character without seeking past it.
Public method | PeekText | Peeks at a string without seeking past it.
Public method | PeekTextReverse | Reverse peeks at a string without seeking past it.
Public method | PeekToken | Peeks at a single IToken from the snapshot without seeking past it.
Public method | PeekTokenReverse | Reverse peeks at a single IToken from the snapshot without seeking past it.
Public method | ReadCharacter | Reads a single character and seeks forward one offset.
Public method | ReadCharacterReverse | Reverse reads a single character and seeks backward one offset.
Public method | ReadCharacterReverseThrough(Char) | Reverse reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterReverseThrough(Char, Int32) | Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadCharacterThrough(Char) | Reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterThrough(Char, Int32) | Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Public method | ReadText | Reads a string and seeks forward to the end of it.
Public method | ReadTextReverse | Reverse reads a string and seeks backward to the start of it.
Public method | ReadToken | Reads a single IToken from the snapshot and seeks forward one IToken.
Public method | ReadTokenReverse | Reverse reads a single IToken from the snapshot and seeks backward one IToken.
Public method | SeekCharacter | Moves the Offset by the specified amount.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentSnapshotLineEnd Method

ITextSnapshotReaderGoToCurrentSnapshotLineEnd Method
Moves the Offset to the end of the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToCurrentSnapshotLineEnd()
Sub GoToCurrentSnapshotLineEnd
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentSnapshotLineStart Method

ITextSnapshotReaderGoToCurrentSnapshotLineStart Method
Moves the Offset to the start of the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToCurrentSnapshotLineStart()
Sub GoToCurrentSnapshotLineStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentTokenStart Method

ITextSnapshotReaderGoToCurrentTokenStart Method
Moves the Offset to the start of the IToken that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToCurrentTokenStart()
Sub GoToCurrentTokenStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentWordEnd Method

ITextSnapshotReaderGoToCurrentWordEnd Method
Moves to the current word's end offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToCurrentWordEnd()
Function GoToCurrentWordEnd As Boolean

Return Value

Type: Boolean
true if the word end is found; otherwise, false.
Remarks
If a proper word end is not found, the reader's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToCurrentWordStart Method

ITextSnapshotReaderGoToCurrentWordStart Method
Moves to the current word's start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToCurrentWordStart()
Function GoToCurrentWordStart As Boolean

Return Value

Type: Boolean
true if the word start is found; otherwise, false.
Remarks
If a proper word start is not found, the reader's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextMatchingTokenById Method

ITextSnapshotReaderGoToNextMatchingTokenById Method
Moves the Offset to the next matching token where there can be nested token pairs.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextMatchingTokenById(
    int startTokenId,
    int endTokenId
)
Function GoToNextMatchingTokenById (
    startTokenId As Integer,
    endTokenId As Integer
) As Boolean

Parameters

startTokenId
Type: SystemInt32
The ID of the start IToken.
endTokenId
Type: SystemInt32
The ID of the related end IToken for which to search.

Return Value

Type: Boolean
true if the next matching token is found; otherwise, false.
Remarks
This method is useful for bracket matching.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextSnapshotLineStart Method

ITextSnapshotReaderGoToNextSnapshotLineStart Method
Moves the Offset to the start of the snapshot line after the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToNextSnapshotLineStart()
Sub GoToNextSnapshotLineStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method

ITextSnapshotReaderGoToNextToken Method
Overload List
 | Name | Description
Public method | GoToNextToken | Moves to the next token's start offset.
Public method | GoToNextToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToNextToken(PredicateIToken) | Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method

ITextSnapshotReaderGoToNextToken Method
Moves to the next token's start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextToken()
Function GoToNextToken As Boolean

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method (Int32)

ITextSnapshotReaderGoToNextToken Method (Int32)
Moves backward the specified number of tokens.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextToken(
    int count
)
Function GoToNextToken (
    count As Integer
) As Boolean

Parameters

count
Type: SystemInt32
The number of tokens to move.

Return Value

Type: Boolean
true if a token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextToken Method (Predicate(IToken))

ITextSnapshotReaderGoToNextToken Method (PredicateIToken)
Continues forward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextToken(
    Predicate<IToken> predicate
)
Function GoToNextToken (
    predicate As Predicate(Of IToken)
) As Boolean

Parameters

predicate
Type: SystemPredicate IToken
The predicate to use. Return true to stop scanning; otherwise, false to continue scanning.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithId Method

ITextSnapshotReaderGoToNextTokenWithId Method
Overload List
 | Name | Description
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches the specified ID.
Public method | GoToNextTokenWithId(Int32) | Moves to the next token's start offset whose token ID matches any of the specified IDs.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithId Method (Int32)

ITextSnapshotReaderGoToNextTokenWithId Method (Int32)
Moves to the next token's start offset whose token ID matches the specified ID.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithId(
    int id
)
Function GoToNextTokenWithId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithId Method (Int32[])

ITextSnapshotReaderGoToNextTokenWithId Method (Int32)
Moves to the next token's start offset whose token ID matches any of the specified IDs.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithId(
    params int[] ids
)
Function GoToNextTokenWithId (
    ParamArray ids As Integer()
) As Boolean

Parameters

ids
Type: SystemInt32
An array of token IDs to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithKey Method

ITextSnapshotReaderGoToNextTokenWithKey Method
Overload List
 | Name | Description
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches the specified key.
Public method | GoToNextTokenWithKey(String) | Moves to the next token's start offset whose token key matches any of the specified keys.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithKey Method (String)

ITextSnapshotReaderGoToNextTokenWithKey Method (String)
Moves to the next token's start offset whose token key matches the specified key.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithKey(
    string key
)
Function GoToNextTokenWithKey (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The token key to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextTokenWithKey Method (String[])

ITextSnapshotReaderGoToNextTokenWithKey Method (String)
Moves to the next token's start offset whose token key matches any of the specified keys.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextTokenWithKey(
    params string[] keys
)
Function GoToNextTokenWithKey (
    ParamArray keys As String()
) As Boolean

Parameters

keys
Type: SystemString
An array of token keys to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToNextTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToNextWordStart Method

ITextSnapshotReaderGoToNextWordStart Method
Moves to the next word's start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextWordStart()
Function GoToNextWordStart As Boolean

Return Value

Type: Boolean
true if the word start is found; otherwise, false.
Remarks
If a proper word start is not found, the reader's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousMatchingTokenById Method

ITextSnapshotReaderGoToPreviousMatchingTokenById Method
Moves the Offset to the previous matching token where there can be nested token pairs.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousMatchingTokenById(
    int endTokenId,
    int startTokenId
)
Function GoToPreviousMatchingTokenById (
    endTokenId As Integer,
    startTokenId As Integer
) As Boolean

Parameters

endTokenId
Type: SystemInt32
The ID of the end IToken.
startTokenId
Type: SystemInt32
The ID of the related start IToken for which to search.

Return Value

Type: Boolean
true if the previous matching token is found; otherwise, false.
Remarks
This method is useful for bracket matching.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousSnapshotLineEnd Method

ITextSnapshotReaderGoToPreviousSnapshotLineEnd Method
Moves the Offset to the end of the snapshot line before the snapshot line that contains the Offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToPreviousSnapshotLineEnd()
Sub GoToPreviousSnapshotLineEnd
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method

ITextSnapshotReaderGoToPreviousToken Method
Overload List
 | Name | Description
Public method | GoToPreviousToken | Moves to the previous token's start offset.
Public method | GoToPreviousToken(Int32) | Moves backward the specified number of tokens.
Public method | GoToPreviousToken(PredicateIToken) | Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method

ITextSnapshotReaderGoToPreviousToken Method
Moves to the previous token's start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousToken()
Function GoToPreviousToken As Boolean

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method (Int32)

ITextSnapshotReaderGoToPreviousToken Method (Int32)
Moves backward the specified number of tokens.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousToken(
    int count
)
Function GoToPreviousToken (
    count As Integer
) As Boolean

Parameters

count
Type: SystemInt32
The number of tokens to move.

Return Value

Type: Boolean
true if a token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousToken Method (Predicate(IToken))

ITextSnapshotReaderGoToPreviousToken Method (PredicateIToken)
Continues backward token scanning until the specified predicate returns true, at which time the reader points to the token's start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousToken(
    Predicate<IToken> predicate
)
Function GoToPreviousToken (
    predicate As Predicate(Of IToken)
) As Boolean

Parameters

predicate
Type: SystemPredicate IToken
The predicate to use. Return true to stop scanning; otherwise, false to continue scanning.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the end of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousToken Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithId Method

ITextSnapshotReaderGoToPreviousTokenWithId Method
Overload List
 | Name | Description
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches the specified ID.
Public method | GoToPreviousTokenWithId(Int32) | Moves to the previous token's start offset whose token ID matches any of the specified IDs.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithId Method (Int32)

ITextSnapshotReaderGoToPreviousTokenWithId Method (Int32)
Moves to the previous token's start offset whose token ID matches the specified ID.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithId(
    int id
)
Function GoToPreviousTokenWithId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithId Method (Int32[])

ITextSnapshotReaderGoToPreviousTokenWithId Method (Int32)
Moves to the previous token's start offset whose token ID matches any of the specified IDs.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithId(
    params int[] ids
)
Function GoToPreviousTokenWithId (
    ParamArray ids As Integer()
) As Boolean

Parameters

ids
Type: SystemInt32
An array of token IDs to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithId Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithKey Method

ITextSnapshotReaderGoToPreviousTokenWithKey Method
Overload List
 | Name | Description
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches the specified key.
Public method | GoToPreviousTokenWithKey(String) | Moves to the previous token's start offset whose token key matches any of the specified keys.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithKey Method (String)

ITextSnapshotReaderGoToPreviousTokenWithKey Method (String)
Moves to the previous token's start offset whose token key matches the specified key.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithKey(
    string key
)
Function GoToPreviousTokenWithKey (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The token key to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousTokenWithKey Method (String[])

ITextSnapshotReaderGoToPreviousTokenWithKey Method (String)
Moves to the previous token's start offset whose token key matches any of the specified keys.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousTokenWithKey(
    params string[] keys
)
Function GoToPreviousTokenWithKey (
    ParamArray keys As String()
) As Boolean

Parameters

keys
Type: SystemString
An array of token keys to look for.

Return Value

Type: Boolean
true if the token is found; otherwise, false.
Remarks
If a token is not found, the stream's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
GoToPreviousTokenWithKey Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToPreviousWordStart Method

ITextSnapshotReaderGoToPreviousWordStart Method
Moves to the previous word's start character.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousWordStart()
Function GoToPreviousWordStart As Boolean

Return Value

Type: Boolean
true if the word start is found; otherwise, false.
Remarks
If a proper word start is not found, the reader's Offset will be the beginning of the snapshot.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToSnapshotEnd Method

ITextSnapshotReaderGoToSnapshotEnd Method
Moves the Offset to the end of the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToSnapshotEnd()
Sub GoToSnapshotEnd
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.GoToSnapshotStart Method

ITextSnapshotReaderGoToSnapshotStart Method
Moves the Offset to the start of the Snapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void GoToSnapshotStart()
Sub GoToSnapshotStart
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekCharacter Method

ITextSnapshotReaderPeekCharacter Method
Peeks at a single character without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char PeekCharacter()
Function PeekCharacter As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekCharacterReverse Method

ITextSnapshotReaderPeekCharacterReverse Method
Reverse peeks at a single character without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char PeekCharacterReverse()
Function PeekCharacterReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekText Method

ITextSnapshotReaderPeekText Method
Peeks at a string without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string PeekText(
    int maxCharCount
)
Function PeekText (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the end of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekTextReverse Method

ITextSnapshotReaderPeekTextReverse Method
Reverse peeks at a string without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string PeekTextReverse(
    int maxCharCount
)
Function PeekTextReverse (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the start of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekToken Method

ITextSnapshotReaderPeekToken Method
Peeks at a single IToken from the snapshot without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken PeekToken()
Function PeekToken As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.PeekTokenReverse Method

ITextSnapshotReaderPeekTokenReverse Method
Reverse peeks at a single IToken from the snapshot without seeking past it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken PeekTokenReverse()
Function PeekTokenReverse As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacter Method

ITextSnapshotReaderReadCharacter Method
Reads a single character and seeks forward one offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char ReadCharacter()
Function ReadCharacter As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverse Method

ITextSnapshotReaderReadCharacterReverse Method
Reverse reads a single character and seeks backward one offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
char ReadCharacterReverse()
Function ReadCharacterReverse As Char

Return Value

Type: Char
The character that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverseThrough Method

ITextSnapshotReaderReadCharacterReverseThrough Method
Overload List
 | Name | Description
Public method | ReadCharacterReverseThrough(Char) | Reverse reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterReverseThrough(Char, Int32) | Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverseThrough Method (Char)

ITextSnapshotReaderReadCharacterReverseThrough Method (Char)
Reverse reads characters from the snapshot until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadCharacterReverseThrough(
    char ch
)
Function ReadCharacterReverseThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the start of the snapshot was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterReverseThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterReverseThrough Method (Char, Int32)

ITextSnapshotReaderReadCharacterReverseThrough Method (Char, Int32)
Reverse reads characters from the snapshot until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadCharacterReverseThrough(
    char ch,
    int minOffset
)
Function ReadCharacterReverseThrough (
    ch As Char,
    minOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
minOffset
Type: SystemInt32
The minimum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterReverseThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterThrough Method

ITextSnapshotReaderReadCharacterThrough Method
Overload List
 | Name | Description
Public method | ReadCharacterThrough(Char) | Reads characters from the snapshot until the specified character is read through.
Public method | ReadCharacterThrough(Char, Int32) | Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterThrough Method (Char)

ITextSnapshotReaderReadCharacterThrough Method (Char)
Reads characters from the snapshot until the specified character is read through.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadCharacterThrough(
    char ch
)
Function ReadCharacterThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the end of the snapshot was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadCharacterThrough Method (Char, Int32)

ITextSnapshotReaderReadCharacterThrough Method (Char, Int32)
Reads characters from the snapshot until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReadCharacterThrough(
    char ch,
    int maxOffset
)
Function ReadCharacterThrough (
    ch As Char,
    maxOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
maxOffset
Type: SystemInt32
The maximum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.
See Also

Reference

ITextSnapshotReader Interface
ReadCharacterThrough Overload
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadText Method

ITextSnapshotReaderReadText Method
Reads a string and seeks forward to the end of it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ReadText(
    int maxCharCount
)
Function ReadText (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the end of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadTextReverse Method

ITextSnapshotReaderReadTextReverse Method
Reverse reads a string and seeks backward to the start of it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ReadTextReverse(
    int maxCharCount
)
Function ReadTextReverse (
    maxCharCount As Integer
) As String

Parameters

maxCharCount
Type: SystemInt32
The maximum number of characters to read, if the start of the snapshot is not reached beforehand.

Return Value

Type: String
The string that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadToken Method

ITextSnapshotReaderReadToken Method
Reads a single IToken from the snapshot and seeks forward one IToken.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken ReadToken()
Function ReadToken As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.ReadTokenReverse Method

ITextSnapshotReaderReadTokenReverse Method
Reverse reads a single IToken from the snapshot and seeks backward one IToken.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken ReadTokenReverse()
Function ReadTokenReverse As IToken

Return Value

Type: IToken
The IToken that was read.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReader.SeekCharacter Method

ITextSnapshotReaderSeekCharacter Method
Moves the Offset by the specified amount.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SeekCharacter(
    int delta
)
Sub SeekCharacter (
    delta As Integer
)

Parameters

delta
Type: SystemInt32
The amount of characters to move. This value may be negative.
See Also

Reference

ITextSnapshotReader Interface
ActiproSoftware.Text Namespace


ITextSnapshotReaderOptions Interface

ITextSnapshotReaderOptions Interface
Provides the base requirements for options that are applied to an ITextSnapshotReader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextSnapshotReaderOptions
Public Interface ITextSnapshotReaderOptions

The ITextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.TextTextSnapshotReaderOptions


ITextSnapshotReaderOptions Properties

ITextSnapshotReaderOptions Properties

The ITextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace


ITextSnapshotReaderOptions.DefaultTokenLoadBufferLength Property

ITextSnapshotReaderOptionsDefaultTokenLoadBufferLength Property
Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DefaultTokenLoadBufferLength { get; set; }
Property DefaultTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 700.
Remarks
This property governs each load of tokens following the first load.
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace
ITextSnapshotReaderOptionsInitialTokenLoadBufferLength


ITextSnapshotReaderOptions.InitialTokenLoadBufferLength Property

ITextSnapshotReaderOptionsInitialTokenLoadBufferLength Property
Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int InitialTokenLoadBufferLength { get; set; }
Property InitialTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 100.
Remarks
This property only governs the first load of tokens.
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace
ITextSnapshotReaderOptionsDefaultTokenLoadBufferLength


ITextSnapshotReaderOptions.PrimaryScanDirection Property

ITextSnapshotReaderOptionsPrimaryScanDirection Property
Gets or sets the primary direction in which text scanning will take place with the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextScanDirection> PrimaryScanDirection { get; set; }
Property PrimaryScanDirection As Nullable(Of TextScanDirection)
    Get
    Set

Property Value

Type: Nullable TextScanDirection
The primary direction in which text scanning will take place with the reader. The default value is .
Remarks
A value of means indeterminate. This property is simply used for optimization of the initial token load and in no way restricts which way you are permitted to scan with the reader.
See Also

Reference

ITextSnapshotReaderOptions Interface
ActiproSoftware.Text Namespace


ITextStatistic Interface

ITextStatistic Interface
Provides the base requirements for a text statistic that is returned by an ITextStatistics.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextStatistic : IKeyedObject
Public Interface ITextStatistic
    Inherits IKeyedObject

The ITextStatistic type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the statistic, generally displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | StringValue | Gets the string value of the statistic.
Public property | Value | Gets the value of the statistic.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextStatistic Properties

ITextStatistic Properties

The ITextStatistic type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the statistic, generally displayed in the user interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | StringValue | Gets the string value of the statistic.
Public property | Value | Gets the value of the statistic.
Top
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistic.Description Property

ITextStatisticDescription Property
Gets the description of the statistic, generally displayed in the user interface.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the statistic, generally displayed in the user interface.
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistic.StringValue Property

ITextStatisticStringValue Property
Gets the string value of the statistic.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string StringValue { get; }
ReadOnly Property StringValue As String
    Get

Property Value

Type: String
The string value of the statistic.
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistic.Value Property

ITextStatisticValue Property
Gets the value of the statistic.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Value { get; }
ReadOnly Property Value As Object
    Get

Property Value

Type: Object
The value of the statistic.
See Also

Reference

ITextStatistic Interface
ActiproSoftware.Text Namespace


ITextStatistics Interface

ITextStatistics Interface
Provides the base requirements for a class that contains numerous statistics such as line, word, character counts, and readability scores for text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextStatistics
Public Interface ITextStatistics

The ITextStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
Methods
 | Name | Description
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Top
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationTextStatistics


ITextStatistics Properties

ITextStatistics Properties

The ITextStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.AverageLettersPerWord Property

ITextStatisticsAverageLettersPerWord Property
Gets the average number of letters per word.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double AverageLettersPerWord { get; }
ReadOnly Property AverageLettersPerWord As Double
    Get

Property Value

Type: Double
The average number of letters per word.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.AverageSyllablesPerWord Property

ITextStatisticsAverageSyllablesPerWord Property
Gets the average number of syllables per word.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double AverageSyllablesPerWord { get; }
ReadOnly Property AverageSyllablesPerWord As Double
    Get

Property Value

Type: Double
The average number of syllables per word.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.AverageWordsPerSentence Property

ITextStatisticsAverageWordsPerSentence Property
Gets the average number of words per sentence.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double AverageWordsPerSentence { get; }
ReadOnly Property AverageWordsPerSentence As Double
    Get

Property Value

Type: Double
The average number of words per sentence.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Characters Property

ITextStatisticsCharacters Property
Gets the number of characters in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Characters { get; }
ReadOnly Property Characters As Integer
    Get

Property Value

Type: Int32
The number of characters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Consonants Property

ITextStatisticsConsonants Property
Gets the number of consonants in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Consonants { get; }
ReadOnly Property Consonants As Integer
    Get

Property Value

Type: Int32
The number of consonants in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.FleschKincaidGradeLevel Property

ITextStatisticsFleschKincaidGradeLevel Property
Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double FleschKincaidGradeLevel { get; }
ReadOnly Property FleschKincaidGradeLevel As Double
    Get

Property Value

Type: Double
Remarks
A grade level of 7.1 indicates that an individual with about 7 years of education could understand the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.FleschReadingEaseScore Property

ITextStatisticsFleschReadingEaseScore Property
Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double FleschReadingEaseScore { get; }
ReadOnly Property FleschReadingEaseScore As Double
    Get

Property Value

Type: Double
Remarks
Scores of 90-100 are considered easily understandable by an average 5th grader. Scores of 60-70 are considered easily understandable by 8th and 9th grade students. Scores of 0-30 are best understood by college graduates.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Letters Property

ITextStatisticsLetters Property
Gets the number of letters in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Letters { get; }
ReadOnly Property Letters As Integer
    Get

Property Value

Type: Int32
The number of letters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Lines Property

ITextStatisticsLines Property
Gets the number of lines in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Lines { get; }
ReadOnly Property Lines As Integer
    Get

Property Value

Type: Int32
The number of lines in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.NonWhitespaceCharacters Property

ITextStatisticsNonWhitespaceCharacters Property
Gets the number of non-whitespace characters in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int NonWhitespaceCharacters { get; }
ReadOnly Property NonWhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace characters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.NonWhitespaceLines Property

ITextStatisticsNonWhitespaceLines Property
Gets the number of non-whitespace lines in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int NonWhitespaceLines { get; }
ReadOnly Property NonWhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace lines in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Sentences Property

ITextStatisticsSentences Property
Gets the number of sentences in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Sentences { get; }
ReadOnly Property Sentences As Integer
    Get

Property Value

Type: Int32
The number of sentences in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Syllables Property

ITextStatisticsSyllables Property
Gets the number of syllables in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Syllables { get; }
ReadOnly Property Syllables As Integer
    Get

Property Value

Type: Int32
The number of syllables in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Vowels Property

ITextStatisticsVowels Property
Gets the number of vowels in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Vowels { get; }
ReadOnly Property Vowels As Integer
    Get

Property Value

Type: Int32
The number of vowels in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.WhitespaceCharacters Property

ITextStatisticsWhitespaceCharacters Property
Gets the number of whitespace characters in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int WhitespaceCharacters { get; }
ReadOnly Property WhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of whitespace characters in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.WhitespaceLines Property

ITextStatisticsWhitespaceLines Property
Gets the number of whitespace lines in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int WhitespaceLines { get; }
ReadOnly Property WhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of whitespace lines in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.Words Property

ITextStatisticsWords Property
Gets the number of words in the text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Words { get; }
ReadOnly Property Words As Integer
    Get

Property Value

Type: Int32
The number of words in the text.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics Methods

ITextStatistics Methods

The ITextStatistics type exposes the following members.

Methods
 | Name | Description
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Top
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatistics.GetRawStatistics Method

ITextStatisticsGetRawStatistics Method
Returns the list of ITextStatistic objects that contain the statistic results.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ITextStatistic> GetRawStatistics()
Function GetRawStatistics As IList(Of ITextStatistic)

Return Value

Type: IList ITextStatistic
The list of ITextStatistic objects that contain the statistic results.
See Also

Reference

ITextStatistics Interface
ActiproSoftware.Text Namespace


ITextStatisticsFactory Interface

ITextStatisticsFactory Interface
Provides the base requirements for a factory capable of creating ITextStatistics objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextStatisticsFactory
Public Interface ITextStatisticsFactory

The ITextStatisticsFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateStatistics | Creates an ITextStatistics for the specified text.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace


ITextStatisticsFactory Methods

ITextStatisticsFactory Methods

The ITextStatisticsFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateStatistics | Creates an ITextStatistics for the specified text.
Top
See Also

Reference

ITextStatisticsFactory Interface
ActiproSoftware.Text Namespace


ITextStatisticsFactory.CreateStatistics Method

ITextStatisticsFactoryCreateStatistics Method
Creates an ITextStatistics for the specified text.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextStatistics CreateStatistics(
    string text
)
Function CreateStatistics (
    text As String
) As ITextStatistics

Parameters

text
Type: SystemString
The text to examine.

Return Value

Type: ITextStatistics
The ITextStatistics that was created.
See Also

Reference

ITextStatisticsFactory Interface
ActiproSoftware.Text Namespace


ITextVersion Interface

ITextVersion Interface
Provides the base requirements for a version of an ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextVersion
Public Interface ITextVersion

The ITextVersion type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this version applies.
Public property | Length | Gets the number of characters in the version, excluding any carriage-returns but including newlines.
Public property | Next | Gets the next ITextVersion that occurs after this one.
Public property | Number | Gets the integer version number associated with this instance.
Public property | Operations | Gets the read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.
Top
Methods
 | Name | Description
Public method | CreateRange(TextRange) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, FuncTextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextVersion Properties

ITextVersion Properties

The ITextVersion type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this version applies.
Public property | Length | Gets the number of characters in the version, excluding any carriage-returns but including newlines.
Public property | Next | Gets the next ITextVersion that occurs after this one.
Public property | Number | Gets the integer version number associated with this instance.
Public property | Operations | Gets the read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.
Top
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Document Property

ITextVersionDocument Property
Gets the ITextDocument for which this version applies.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextDocument Document { get; }
ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument for which this version applies.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Length Property

ITextVersionLength Property
Gets the number of characters in the version, excluding any carriage-returns but including newlines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the version, excluding any carriage-returns but including newlines.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Next Property

ITextVersionNext Property
Gets the next ITextVersion that occurs after this one.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersion Next { get; }
ReadOnly Property Next As ITextVersion
    Get

Property Value

Type: ITextVersion
The next ITextVersion that occurs after this one.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Number Property

ITextVersionNumber Property
Gets the integer version number associated with this instance.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Number { get; }
ReadOnly Property Number As Integer
    Get

Property Value

Type: Int32
The integer version number associated with this instance.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.Operations Property

ITextVersionOperations Property
Gets the read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ITextChangeRangedOperation> Operations { get; }
ReadOnly Property Operations As IList(Of ITextChangeRangedOperation)
    Get

Property Value

Type: IList ITextChangeRangedOperation
The read-only list of ITextChangeRangedOperation objects that can be applied to this text version to generate the next version.
Remarks
This property returns for the most current version of a document.
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion Methods

ITextVersion Methods
Methods
 | Name | Description
Public method | CreateRange(TextRange) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, FuncTextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Top
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method

ITextVersionCreateRange Method
Overload List
 | Name | Description
Public method | CreateRange(TextRange) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(TextRange, FuncTextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Public method | CreateRange(Int32, Int32, TextRangeTrackingModes) | Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
Top
See Also

Reference

ITextVersion Interface
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (TextRange)

ITextVersionCreateRange Method (TextRange)
Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    TextRange textRange
)
Function CreateRange (
    textRange As TextRange
) As ITextVersionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text within this version.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (Int32, Int32)

ITextVersionCreateRange Method (Int32, Int32)
Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    int startOffset,
    int length
)
Function CreateRange (
    startOffset As Integer,
    length As Integer
) As ITextVersionRange

Parameters

startOffset
Type: SystemInt32
The start offset in the range.
length
Type: SystemInt32
The length of the range.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (TextRange, TextRangeTrackingModes)

ITextVersionCreateRange Method (TextRange, TextRangeTrackingModes)
Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    TextRange textRange,
    TextRangeTrackingModes trackingModes
)
Function CreateRange (
    textRange As TextRange,
    trackingModes As TextRangeTrackingModes
) As ITextVersionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text within this version.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (TextRange, Func(TextRangeTrackingModes))

ITextVersionCreateRange Method (TextRange, FuncTextRangeTrackingModes)
Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    TextRange textRange,
    Func<TextRangeTrackingModes> trackingModesFunc
)
Function CreateRange (
    textRange As TextRange,
    trackingModesFunc As Func(Of TextRangeTrackingModes)
) As ITextVersionRange

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange indicating the range of text within this version.
trackingModesFunc
Type: SystemFunc TextRangeTrackingModes
A function that dynamically returns a TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersion.CreateRange Method (Int32, Int32, TextRangeTrackingModes)

ITextVersionCreateRange Method (Int32, Int32, TextRangeTrackingModes)
Creates an ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextVersionRange CreateRange(
    int startOffset,
    int length,
    TextRangeTrackingModes trackingModes
)
Function CreateRange (
    startOffset As Integer,
    length As Integer,
    trackingModes As TextRangeTrackingModes
) As ITextVersionRange

Parameters

startOffset
Type: SystemInt32
The start offset in the range.
length
Type: SystemInt32
The length of the range.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
An ITextVersionRange that stores data about a text range in this version and can be used to translate to other versions.
See Also

Reference

ITextVersion Interface
CreateRange Overload
ActiproSoftware.Text Namespace


ITextVersionRange Interface

ITextVersionRange Interface
Provides the base requirements for a zero-based range of two normalized offset values within a text document that can be translated from one version of the document to another.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextVersionRange
Public Interface ITextVersionRange

The ITextVersionRange type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this text range applies.
Public property | TrackingModes | Gets a TextRangeTrackingModes indicating the tracking modes to use.
Top
Methods
 | Name | Description
Public method | Translate(ITextSnapshot) | Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
Public method | Translate(ITextVersion) | Gets a TextRange that indicates the text range within the specified target ITextVersion.
Top
See Also

Reference

ActiproSoftware.Text Namespace


ITextVersionRange Properties

ITextVersionRange Properties

The ITextVersionRange type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument for which this text range applies.
Public property | TrackingModes | Gets a TextRangeTrackingModes indicating the tracking modes to use.
Top
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.Document Property

ITextVersionRangeDocument Property
Gets the ITextDocument for which this text range applies.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextDocument Document { get; }
ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument for which this text range applies.
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.TrackingModes Property

ITextVersionRangeTrackingModes Property
Gets a TextRangeTrackingModes indicating the tracking modes to use.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRangeTrackingModes TrackingModes { get; }
ReadOnly Property TrackingModes As TextRangeTrackingModes
    Get

Property Value

Type: TextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange Methods

ITextVersionRange Methods
Methods
 | Name | Description
Public method | Translate(ITextSnapshot) | Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
Public method | Translate(ITextVersion) | Gets a TextRange that indicates the text range within the specified target ITextVersion.
Top
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.Translate Method

ITextVersionRangeTranslate Method
Overload List
 | Name | Description
Public method | Translate(ITextSnapshot) | Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
Public method | Translate(ITextVersion) | Gets a TextRange that indicates the text range within the specified target ITextVersion.
Top
See Also

Reference

ITextVersionRange Interface
ActiproSoftware.Text Namespace


ITextVersionRange.Translate Method (ITextSnapshot)

ITextVersionRangeTranslate Method (ITextSnapshot)
Gets a TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange Translate(
    ITextSnapshot toSnapshot
)
Function Translate (
    toSnapshot As ITextSnapshot
) As TextSnapshotRange

Parameters

toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The target ITextSnapshot.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange that indicates the text range within the specified target ITextSnapshot.
See Also

Reference

ITextVersionRange Interface
Translate Overload
ActiproSoftware.Text Namespace


ITextVersionRange.Translate Method (ITextVersion)

ITextVersionRangeTranslate Method (ITextVersion)
Gets a TextRange that indicates the text range within the specified target ITextVersion.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange Translate(
    ITextVersion toVersion
)
Function Translate (
    toVersion As ITextVersion
) As TextRange

Parameters

toVersion
Type: ActiproSoftware.TextITextVersion
The target ITextVersion.

Return Value

Type: TextRange
A TextRange that indicates the text range within the specified target ITextVersion.
See Also

Reference

ITextVersionRange Interface
Translate Overload
ActiproSoftware.Text Namespace


IWordBreakFinder Interface

IWordBreakFinder Interface
Provides the base requirements for an object that finds word breaks within an ITextSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IWordBreakFinder
Public Interface IWordBreakFinder

The IWordBreakFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text Namespace
ActiproSoftware.Text.ImplementationDefaultWordBreakFinder


IWordBreakFinder Methods

IWordBreakFinder Methods

The IWordBreakFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Top
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindCurrentWordEnd Method

IWordBreakFinderFindCurrentWordEnd Method
Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindCurrentWordEnd(
    TextSnapshotOffset snapshotOffset
)
Function FindCurrentWordEnd (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindCurrentWordStart Method

IWordBreakFinderFindCurrentWordStart Method
Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindCurrentWordStart(
    TextSnapshotOffset snapshotOffset
)
Function FindCurrentWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindNextWordStart Method

IWordBreakFinderFindNextWordStart Method
Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindNextWordStart(
    TextSnapshotOffset snapshotOffset
)
Function FindNextWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs after the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


IWordBreakFinder.FindPreviousWordStart Method

IWordBreakFinderFindPreviousWordStart Method
Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindPreviousWordStart(
    TextSnapshotOffset snapshotOffset
)
Function FindPreviousWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs before the specified start offset.
See Also

Reference

IWordBreakFinder Interface
ActiproSoftware.Text Namespace


LineTerminator Class

LineTerminator Class
Specifies a type of line terminator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextLineTerminator

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LineTerminator : Enum
Public NotInheritable Class LineTerminator
    Inherits Enum

The LineTerminator type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CarriageReturn | A single carriage return character (ASCII value 13). This format is typically used on Macintosh machines.
 | CarriageReturnNewline | A carriage return character (ASCII value 13) followed by a newline character (ASCII value 10). This format is typically used on Windows machines.
 | Newline | A single newline character (ASCII value 10). This format is typically used on UNIX machines.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


LineTerminator Methods

LineTerminator Methods

The LineTerminator type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LineTerminator Class
ActiproSoftware.Text Namespace


LineTerminator Fields

LineTerminator Fields

The LineTerminator type exposes the following members.

Fields
 | Name | Description
 | CarriageReturn | A single carriage return character (ASCII value 13). This format is typically used on Macintosh machines.
 | CarriageReturnNewline | A carriage return character (ASCII value 13) followed by a newline character (ASCII value 10). This format is typically used on Windows machines.
 | Newline | A single newline character (ASCII value 10). This format is typically used on UNIX machines.
Public field | value__ |
Top
See Also

Reference

LineTerminator Class
ActiproSoftware.Text Namespace


LineTerminator.CarriageReturn Field

LineTerminatorCarriageReturn Field
A single carriage return character (ASCII value 13). This format is typically used on Macintosh machines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineTerminator CarriageReturn = 1
Public Const CarriageReturn As LineTerminator = 1

Field Value

Type: LineTerminator
See Also

Reference

LineTerminator Class
ActiproSoftware.Text Namespace


LineTerminator.CarriageReturnNewline Field

LineTerminatorCarriageReturnNewline Field
A carriage return character (ASCII value 13) followed by a newline character (ASCII value 10). This format is typically used on Windows machines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineTerminator CarriageReturnNewline = 2
Public Const CarriageReturnNewline As LineTerminator = 2

Field Value

Type: LineTerminator
See Also

Reference

LineTerminator Class
ActiproSoftware.Text Namespace


LineTerminator.Newline Field

LineTerminatorNewline Field
A single newline character (ASCII value 10). This format is typically used on UNIX machines.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineTerminator Newline = 0
Public Const Newline As LineTerminator = 0

Field Value

Type: LineTerminator
See Also

Reference

LineTerminator Class
ActiproSoftware.Text Namespace


LineTerminator.value__ Field

LineTerminatorvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.LineTerminator.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LineTerminator Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Class

NormalizedTextSnapshotRangeCollection Class
Represents a read-only normalized text snapshot range collection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextNormalizedTextSnapshotRangeCollection

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NormalizedTextSnapshotRangeCollection : IList<TextSnapshotRange>,
    ICollection<TextSnapshotRange>, IEnumerable<TextSnapshotRange>, IEnumerable
Public Class NormalizedTextSnapshotRangeCollection
    Implements IList(Of TextSnapshotRange), ICollection(Of TextSnapshotRange),
    IEnumerable(Of TextSnapshotRange), IEnumerable

The NormalizedTextSnapshotRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | NormalizedTextSnapshotRangeCollection | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(TextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange, Boolean) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets or sets the item at the specified index. [C#] In C#, this property is the indexer for the NormalizedTextSnapshotRangeCollection class.
Top
Methods
 | Name | Description
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetInverse | Gets a NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the specified item in the collection.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor

NormalizedTextSnapshotRangeCollection Constructor
Overload List
 | Name | Description
Public method | NormalizedTextSnapshotRangeCollection | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(TextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Public method | NormalizedTextSnapshotRangeCollection(IEnumerableTextSnapshotRange, Boolean) | Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.
Top
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor

NormalizedTextSnapshotRangeCollection Constructor
Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection()
Public Sub New
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor (TextSnapshotRange[])

NormalizedTextSnapshotRangeCollection Constructor (TextSnapshotRange)
Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection(
    params TextSnapshotRange[] snapshotRanges
)
Public Sub New (
    ParamArray snapshotRanges As TextSnapshotRange()
)

Parameters

snapshotRanges
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange objects to add to the collection.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor (IEnumerable(TextSnapshotRange))

NormalizedTextSnapshotRangeCollection Constructor (IEnumerableTextSnapshotRange)
Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection(
    IEnumerable<TextSnapshotRange> snapshotRanges
)
Public Sub New (
    snapshotRanges As IEnumerable(Of TextSnapshotRange)
)

Parameters

snapshotRanges
Type: System.Collections.GenericIEnumerable TextSnapshotRange
The TextSnapshotRange objects to add to the collection.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Constructor (IEnumerable(TextSnapshotRange), Boolean)

NormalizedTextSnapshotRangeCollection Constructor (IEnumerableTextSnapshotRange, Boolean)
Initializes a new instance of the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection(
    IEnumerable<TextSnapshotRange> snapshotRanges,
    bool mergeSequentialRanges
)
Public Sub New (
    snapshotRanges As IEnumerable(Of TextSnapshotRange),
    mergeSequentialRanges As Boolean
)

Parameters

snapshotRanges
Type: System.Collections.GenericIEnumerable TextSnapshotRange
The TextSnapshotRange objects to add to the collection.
mergeSequentialRanges
Type: SystemBoolean
Whether to merge sequential ranges.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
NormalizedTextSnapshotRangeCollection Overload
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Properties

NormalizedTextSnapshotRangeCollection Properties

The NormalizedTextSnapshotRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets or sets the item at the specified index. [C#] In C#, this property is the indexer for the NormalizedTextSnapshotRangeCollection class.
Top
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.Count Property

NormalizedTextSnapshotRangeCollectionCount Property
Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.

Implements

ICollectionTCount
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.Item Property

NormalizedTextSnapshotRangeCollectionItem Property
Gets or sets the item at the specified index.

[C#] In C#, this property is the indexer for the NormalizedTextSnapshotRangeCollection class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange this[
    int index
] { get; set; }
Public Property Item (
    index As Integer
) As TextSnapshotRange
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to return.

Property Value

Type: TextSnapshotRange
The item at the specified index.

Implements

IListTItemInt32
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection Methods

NormalizedTextSnapshotRangeCollection Methods

The NormalizedTextSnapshotRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetInverse | Gets a NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the specified item in the collection.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.Contains Method

NormalizedTextSnapshotRangeCollectionContains Method
Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextSnapshotRange item
)
Public Function Contains (
    item As TextSnapshotRange
) As Boolean

Parameters

item
Type: ActiproSoftware.TextTextSnapshotRange
The object to locate in the collection.

Return Value

Type: Boolean
true if the item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.CopyTo Method

NormalizedTextSnapshotRangeCollectionCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    TextSnapshotRange[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As TextSnapshotRange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.TextTextSnapshotRange
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.GetEnumerator Method

NormalizedTextSnapshotRangeCollectionGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<TextSnapshotRange> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TextSnapshotRange)

Return Value

Type: IEnumerator TextSnapshotRange
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.GetInverse Method

NormalizedTextSnapshotRangeCollectionGetInverse Method
Gets a NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NormalizedTextSnapshotRangeCollection GetInverse(
    TextSnapshotRange targetSnapshotRange
)
Public Function GetInverse (
    targetSnapshotRange As TextSnapshotRange
) As NormalizedTextSnapshotRangeCollection

Parameters

targetSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to return ranges.

Return Value

Type: NormalizedTextSnapshotRangeCollection
A NormalizedTextSnapshotRangeCollection that contains the inverse ranges contained in this instance.
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


NormalizedTextSnapshotRangeCollection.IndexOf Method

NormalizedTextSnapshotRangeCollectionIndexOf Method
Returns the index of the specified item in the collection.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    TextSnapshotRange item
)
Public Function IndexOf (
    item As TextSnapshotRange
) As Integer

Parameters

item
Type: ActiproSoftware.TextTextSnapshotRange
The item to look for.

Return Value

Type: Int32
If found, the index where the item is in the collection; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

NormalizedTextSnapshotRangeCollection Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Class

SyntaxLanguageChangedEventArgs Class
Event arguments for the ICodeDocument.LanguageChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextSyntaxLanguageChangedEventArgs

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SyntaxLanguageChangedEventArgs : EventArgs
Public Class SyntaxLanguageChangedEventArgs
    Inherits EventArgs

The SyntaxLanguageChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxLanguageChangedEventArgs | Initializes a new instance of the SyntaxLanguageChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewLanguage | Gets the ISyntaxLanguage is in use after the change.
Public property | OldLanguage | Gets the ISyntaxLanguage that was in use before the change.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Constructor

SyntaxLanguageChangedEventArgs Constructor
Initializes a new instance of the SyntaxLanguageChangedEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SyntaxLanguageChangedEventArgs(
    ISyntaxLanguage oldLanguage,
    ISyntaxLanguage newLanguage
)
Public Sub New (
    oldLanguage As ISyntaxLanguage,
    newLanguage As ISyntaxLanguage
)

Parameters

oldLanguage
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage that was in use before the change.
newLanguage
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage that is in use after the change.
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Properties

SyntaxLanguageChangedEventArgs Properties

The SyntaxLanguageChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewLanguage | Gets the ISyntaxLanguage is in use after the change.
Public property | OldLanguage | Gets the ISyntaxLanguage that was in use before the change.
Top
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs.NewLanguage Property

SyntaxLanguageChangedEventArgsNewLanguage Property
Gets the ISyntaxLanguage is in use after the change.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISyntaxLanguage NewLanguage { get; }
Public ReadOnly Property NewLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage is in use after the change.
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs.OldLanguage Property

SyntaxLanguageChangedEventArgsOldLanguage Property
Gets the ISyntaxLanguage that was in use before the change.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISyntaxLanguage OldLanguage { get; }
Public ReadOnly Property OldLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that was in use before the change.
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageChangedEventArgs Methods

SyntaxLanguageChangedEventArgs Methods

The SyntaxLanguageChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SyntaxLanguageChangedEventArgs Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions Class

SyntaxLanguageExtensions Class
Contains extension methods that make it easier to work with ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class SyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class SyntaxLanguageExtensions

The SyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction.
GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range.
GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language.
GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed.
GetLexer | Returns the ILexer that can be used for lexing of the language.
GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language.
GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language.
GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
GetParser | Returns the IParser that can be used for parsing of the language.
GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language.
GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language.
GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language.
RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction.
RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range.
RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language.
RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed.
RegisterLexer | Registers the ILexer that can be used for lexing of the language.
RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language.
RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language.
RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
RegisterParser | Registers the IParser that can be used for parsing of the language.
RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language.
RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language.
RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language.
UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction.
UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range.
UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language.
UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed.
UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language.
UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language.
UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language.
UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
UnregisterParser | Unregisters the IParser that can be used for parsing of the language.
UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language.
UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language.
UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language.
Top
See Also

Reference

ActiproSoftware.Text Namespace


SyntaxLanguageExtensions Methods

SyntaxLanguageExtensions Methods

The SyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction.
GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range.
GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language.
GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed.
GetLexer | Returns the ILexer that can be used for lexing of the language.
GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language.
GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language.
GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
GetParser | Returns the IParser that can be used for parsing of the language.
GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language.
GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language.
GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language.
RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction.
RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range.
RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language.
RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed.
RegisterLexer | Registers the ILexer that can be used for lexing of the language.
RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language.
RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language.
RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
RegisterParser | Registers the IParser that can be used for parsing of the language.
RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language.
RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language.
RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language.
UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction.
UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range.
UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.
UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language.
UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed.
UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language.
UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language.
UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language.
UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.
UnregisterParser | Unregisters the IParser that can be used for parsing of the language.
UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.
UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language.
UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language.
UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language.
Top
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetAutoCorrector Method

SyntaxLanguageExtensionsGetAutoCorrector Method
Returns the IAutoCorrector that can perform auto-correction.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IAutoCorrector GetAutoCorrector(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetAutoCorrector (
    language As ISyntaxLanguage
) As IAutoCorrector

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IAutoCorrector
The IAutoCorrector instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetCodeBlockFinder Method

SyntaxLanguageExtensionsGetCodeBlockFinder Method
Returns the ICodeBlockFinder that can find the containing code block for a text range.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ICodeBlockFinder GetCodeBlockFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetCodeBlockFinder (
    language As ISyntaxLanguage
) As ICodeBlockFinder

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ICodeBlockFinder
The ICodeBlockFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetDelimiterAutoCompleter Method

SyntaxLanguageExtensionsGetDelimiterAutoCompleter Method
Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDelimiterAutoCompleter GetDelimiterAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetDelimiterAutoCompleter (
    language As ISyntaxLanguage
) As IDelimiterAutoCompleter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IDelimiterAutoCompleter
The IDelimiterAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetExampleTextProvider Method

SyntaxLanguageExtensionsGetExampleTextProvider Method
Returns the IExampleTextProvider that can generate example text for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IExampleTextProvider GetExampleTextProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetExampleTextProvider (
    language As ISyntaxLanguage
) As IExampleTextProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IExampleTextProvider
The IExampleTextProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetIndentProvider Method

SyntaxLanguageExtensionsGetIndentProvider Method
Returns the IIndentProvider that can indent text for the language when the Enter key pressed.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IIndentProvider GetIndentProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetIndentProvider (
    language As ISyntaxLanguage
) As IIndentProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IIndentProvider
The IIndentProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetLexer Method

SyntaxLanguageExtensionsGetLexer Method
Returns the ILexer that can be used for lexing of the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ILexer GetLexer(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetLexer (
    language As ISyntaxLanguage
) As ILexer

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ILexer
The ILexer instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetLineCommenter Method

SyntaxLanguageExtensionsGetLineCommenter Method
Returns the ILineCommenter that can comment and uncomment lines for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ILineCommenter GetLineCommenter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetLineCommenter (
    language As ISyntaxLanguage
) As ILineCommenter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ILineCommenter
The ILineCommenter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetNavigableSymbolProvider Method

SyntaxLanguageExtensionsGetNavigableSymbolProvider Method
Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static INavigableSymbolProvider GetNavigableSymbolProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetNavigableSymbolProvider (
    language As ISyntaxLanguage
) As INavigableSymbolProvider

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: INavigableSymbolProvider
The INavigableSymbolProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetOutliner Method

SyntaxLanguageExtensionsGetOutliner Method
Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IOutliner GetOutliner(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetOutliner (
    language As ISyntaxLanguage
) As IOutliner

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IOutliner
The IOutliner instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetParser Method

SyntaxLanguageExtensionsGetParser Method
Returns the IParser that can be used for parsing of the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParser GetParser(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetParser (
    language As ISyntaxLanguage
) As IParser

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IParser
The IParser instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetStructureMatcher Method

SyntaxLanguageExtensionsGetStructureMatcher Method
Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IStructureMatcher GetStructureMatcher(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetStructureMatcher (
    language As ISyntaxLanguage
) As IStructureMatcher

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IStructureMatcher
The IStructureMatcher instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetTextFormatter Method

SyntaxLanguageExtensionsGetTextFormatter Method
Returns the ITextFormatter that can improve the readability of code for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextFormatter GetTextFormatter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetTextFormatter (
    language As ISyntaxLanguage
) As ITextFormatter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ITextFormatter
The ITextFormatter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetTextStatisticsFactory Method

SyntaxLanguageExtensionsGetTextStatisticsFactory Method
Returns the ITextStatisticsFactory that can generate customized text statistics for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextStatisticsFactory GetTextStatisticsFactory(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetTextStatisticsFactory (
    language As ISyntaxLanguage
) As ITextStatisticsFactory

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: ITextStatisticsFactory
The ITextStatisticsFactory instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.GetWordBreakFinder Method

SyntaxLanguageExtensionsGetWordBreakFinder Method
Returns the IWordBreakFinder that is capable of locating word breaks for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IWordBreakFinder GetWordBreakFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetWordBreakFinder (
    language As ISyntaxLanguage
) As IWordBreakFinder

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IWordBreakFinder
The IWordBreakFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterAutoCorrector Method

SyntaxLanguageExtensionsRegisterAutoCorrector Method
Registers the IAutoCorrector that can perform auto-correction.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterAutoCorrector(
    this ISyntaxLanguage language,
    IAutoCorrector value
)
<ExtensionAttribute>
Public Shared Sub RegisterAutoCorrector (
    language As ISyntaxLanguage,
    value As IAutoCorrector
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisIAutoCorrector
The IAutoCorrector instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterCodeBlockFinder Method

SyntaxLanguageExtensionsRegisterCodeBlockFinder Method
Registers the ICodeBlockFinder that can find the containing code block for a text range.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterCodeBlockFinder(
    this ISyntaxLanguage language,
    ICodeBlockFinder value
)
<ExtensionAttribute>
Public Shared Sub RegisterCodeBlockFinder (
    language As ISyntaxLanguage,
    value As ICodeBlockFinder
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisICodeBlockFinder
The ICodeBlockFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterDelimiterAutoCompleter Method

SyntaxLanguageExtensionsRegisterDelimiterAutoCompleter Method
Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterDelimiterAutoCompleter(
    this ISyntaxLanguage language,
    IDelimiterAutoCompleter value
)
<ExtensionAttribute>
Public Shared Sub RegisterDelimiterAutoCompleter (
    language As ISyntaxLanguage,
    value As IDelimiterAutoCompleter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisIDelimiterAutoCompleter
The IDelimiterAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterExampleTextProvider Method

SyntaxLanguageExtensionsRegisterExampleTextProvider Method
Registers the IExampleTextProvider that can generate example text for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterExampleTextProvider(
    this ISyntaxLanguage language,
    IExampleTextProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterExampleTextProvider (
    language As ISyntaxLanguage,
    value As IExampleTextProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextIExampleTextProvider
The IExampleTextProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterIndentProvider Method

SyntaxLanguageExtensionsRegisterIndentProvider Method
Registers the IIndentProvider that can indent text for the language when the Enter key pressed.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterIndentProvider(
    this ISyntaxLanguage language,
    IIndentProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterIndentProvider (
    language As ISyntaxLanguage,
    value As IIndentProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIIndentProvider
The IIndentProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterLexer Method

SyntaxLanguageExtensionsRegisterLexer Method
Registers the ILexer that can be used for lexing of the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterLexer(
    this ISyntaxLanguage language,
    ILexer value
)
<ExtensionAttribute>
Public Shared Sub RegisterLexer (
    language As ISyntaxLanguage,
    value As ILexer
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.LexingILexer
The ILexer instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterLineCommenter Method

SyntaxLanguageExtensionsRegisterLineCommenter Method
Registers the ILineCommenter that can comment and uncomment lines for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterLineCommenter(
    this ISyntaxLanguage language,
    ILineCommenter value
)
<ExtensionAttribute>
Public Shared Sub RegisterLineCommenter (
    language As ISyntaxLanguage,
    value As ILineCommenter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextILineCommenter
The ILineCommenter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterNavigableSymbolProvider Method

SyntaxLanguageExtensionsRegisterNavigableSymbolProvider Method
Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterNavigableSymbolProvider(
    this ISyntaxLanguage language,
    INavigableSymbolProvider value
)
<ExtensionAttribute>
Public Shared Sub RegisterNavigableSymbolProvider (
    language As ISyntaxLanguage,
    value As INavigableSymbolProvider
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableSymbolProvider
The INavigableSymbolProvider instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterOutliner Method

SyntaxLanguageExtensionsRegisterOutliner Method
Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterOutliner(
    this ISyntaxLanguage language,
    IOutliner value
)
<ExtensionAttribute>
Public Shared Sub RegisterOutliner (
    language As ISyntaxLanguage,
    value As IOutliner
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.OutliningIOutliner
The IOutliner instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterParser Method

SyntaxLanguageExtensionsRegisterParser Method
Registers the IParser that can be used for parsing of the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterParser(
    this ISyntaxLanguage language,
    IParser value
)
<ExtensionAttribute>
Public Shared Sub RegisterParser (
    language As ISyntaxLanguage,
    value As IParser
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.ParsingIParser
The IParser instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterStructureMatcher Method

SyntaxLanguageExtensionsRegisterStructureMatcher Method
Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterStructureMatcher(
    this ISyntaxLanguage language,
    IStructureMatcher value
)
<ExtensionAttribute>
Public Shared Sub RegisterStructureMatcher (
    language As ISyntaxLanguage,
    value As IStructureMatcher
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.AnalysisIStructureMatcher
The IStructureMatcher instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterTextFormatter Method

SyntaxLanguageExtensionsRegisterTextFormatter Method
Registers the ITextFormatter that can improve the readability of code for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterTextFormatter(
    this ISyntaxLanguage language,
    ITextFormatter value
)
<ExtensionAttribute>
Public Shared Sub RegisterTextFormatter (
    language As ISyntaxLanguage,
    value As ITextFormatter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextITextFormatter
The ITextFormatter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterTextStatisticsFactory Method

SyntaxLanguageExtensionsRegisterTextStatisticsFactory Method
Registers the ITextStatisticsFactory that can generate customized text statistics for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterTextStatisticsFactory(
    this ISyntaxLanguage language,
    ITextStatisticsFactory value
)
<ExtensionAttribute>
Public Shared Sub RegisterTextStatisticsFactory (
    language As ISyntaxLanguage,
    value As ITextStatisticsFactory
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextITextStatisticsFactory
The ITextStatisticsFactory instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.RegisterWordBreakFinder Method

SyntaxLanguageExtensionsRegisterWordBreakFinder Method
Registers the IWordBreakFinder that is capable of locating word breaks for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterWordBreakFinder(
    this ISyntaxLanguage language,
    IWordBreakFinder value
)
<ExtensionAttribute>
Public Shared Sub RegisterWordBreakFinder (
    language As ISyntaxLanguage,
    value As IWordBreakFinder
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.TextIWordBreakFinder
The IWordBreakFinder instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterAutoCorrector Method

SyntaxLanguageExtensionsUnregisterAutoCorrector Method
Unregisters the IAutoCorrector that can perform auto-correction.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterAutoCorrector(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterAutoCorrector (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterCodeBlockFinder Method

SyntaxLanguageExtensionsUnregisterCodeBlockFinder Method
Unregisters the ICodeBlockFinder that can find the containing code block for a text range.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterCodeBlockFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterCodeBlockFinder (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterDelimiterAutoCompleter Method

SyntaxLanguageExtensionsUnregisterDelimiterAutoCompleter Method
Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterDelimiterAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterDelimiterAutoCompleter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterExampleTextProvider Method

SyntaxLanguageExtensionsUnregisterExampleTextProvider Method
Unregisters the IExampleTextProvider that can generate example text for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterExampleTextProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterExampleTextProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterIndentProvider Method

SyntaxLanguageExtensionsUnregisterIndentProvider Method
Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterIndentProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterIndentProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterLexer Method

SyntaxLanguageExtensionsUnregisterLexer Method
Unregisters the ILexer that can be used for lexing of the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterLexer(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterLexer (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterLineCommenter Method

SyntaxLanguageExtensionsUnregisterLineCommenter Method
Unregisters the ILineCommenter that can comment and uncomment lines for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterLineCommenter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterLineCommenter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterNavigableSymbolProvider Method

SyntaxLanguageExtensionsUnregisterNavigableSymbolProvider Method
Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterNavigableSymbolProvider(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterNavigableSymbolProvider (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterOutliner Method

SyntaxLanguageExtensionsUnregisterOutliner Method
Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterOutliner(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterOutliner (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterParser Method

SyntaxLanguageExtensionsUnregisterParser Method
Unregisters the IParser that can be used for parsing of the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterParser(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterParser (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterStructureMatcher Method

SyntaxLanguageExtensionsUnregisterStructureMatcher Method
Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterStructureMatcher(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterStructureMatcher (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterTextFormatter Method

SyntaxLanguageExtensionsUnregisterTextFormatter Method
Unregisters the ITextFormatter that can improve the readability of code for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterTextFormatter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterTextFormatter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterTextStatisticsFactory Method

SyntaxLanguageExtensionsUnregisterTextStatisticsFactory Method
Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterTextStatisticsFactory(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterTextStatisticsFactory (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


SyntaxLanguageExtensions.UnregisterWordBreakFinder Method

SyntaxLanguageExtensionsUnregisterWordBreakFinder Method
Unregisters the IWordBreakFinder that is capable of locating word breaks for the language.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterWordBreakFinder(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterWordBreakFinder (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SyntaxLanguageExtensions Class
ActiproSoftware.Text Namespace


TextChangeOffsetDelta Class

TextChangeOffsetDelta Class
Specifies how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextTextChangeOffsetDelta

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextChangeOffsetDelta : Enum
Public NotInheritable Class TextChangeOffsetDelta
    Inherits Enum

The TextChangeOffsetDelta type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | No offset delta is applied to operations.
 | SequentialOnly | An offset delta is tracked based on the net length change of previously-added operations. This offset delta is applied to the start offset of any newly-added operation. It is important to note that this option cannot be used if any newly-added operation will be made before a previously-added operation. This option is extremely handy when sequentially adding operations based on the original snapshot's offsets since it automatically applies the offset delta to ensure that operations are updating the correct text range.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextChangeOffsetDelta Methods

TextChangeOffsetDelta Methods

The TextChangeOffsetDelta type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TextChangeOffsetDelta Class
ActiproSoftware.Text Namespace


TextChangeOffsetDelta Fields

TextChangeOffsetDelta Fields

The TextChangeOffsetDelta type exposes the following members.

Fields
 | Name | Description
 | None | No offset delta is applied to operations.
 | SequentialOnly | An offset delta is tracked based on the net length change of previously-added operations. This offset delta is applied to the start offset of any newly-added operation. It is important to note that this option cannot be used if any newly-added operation will be made before a previously-added operation. This option is extremely handy when sequentially adding operations based on the original snapshot's offsets since it automatically applies the offset delta to ensure that operations are updating the correct text range.
Public field | value__ |
Top
See Also

Reference

TextChangeOffsetDelta Class
ActiproSoftware.Text Namespace


TextChangeOffsetDelta.None Field

TextChangeOffsetDeltaNone Field
No offset delta is applied to operations.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextChangeOffsetDelta None = 0
Public Const None As TextChangeOffsetDelta = 0

Field Value

Type: TextChangeOffsetDelta
See Also

Reference

TextChangeOffsetDelta Class
ActiproSoftware.Text Namespace


TextChangeOffsetDelta.SequentialOnly Field

TextChangeOffsetDeltaSequentialOnly Field
An offset delta is tracked based on the net length change of previously-added operations. This offset delta is applied to the start offset of any newly-added operation.

It is important to note that this option cannot be used if any newly-added operation will be made before a previously-added operation.

This option is extremely handy when sequentially adding operations based on the original snapshot's offsets since it automatically applies the offset delta to ensure that operations are updating the correct text range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextChangeOffsetDelta SequentialOnly = 1
Public Const SequentialOnly As TextChangeOffsetDelta = 1

Field Value

Type: TextChangeOffsetDelta
See Also

Reference

TextChangeOffsetDelta Class
ActiproSoftware.Text Namespace


TextChangeOffsetDelta.value__ Field

TextChangeOffsetDeltavalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.TextChangeOffsetDelta.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TextChangeOffsetDelta Class
ActiproSoftware.Text Namespace


TextChangeTypes Class

TextChangeTypes Class
Provides access to the built-in ITextChangeType instances, that indicate the type of ITextChange made.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextTextChangeTypes

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class TextChangeTypes
Public NotInheritable Class TextChangeTypes

The TextChangeTypes type exposes the following members.

Properties
Name | Description
AutoComplete | Gets the ITextChangeType for an IntelliPrompt auto-complete action.
AutoCorrect | Gets the ITextChangeType for an auto-correct action.
AutoFormat | Gets the ITextChangeType for an auto-format action.
AutoIndent | Gets the ITextChangeType for an auto-indent action.
AutoReplace | Gets the ITextChangeType for an auto-replace action.
Backspace | Gets the ITextChangeType for the press of the Backspace key.
ChangeCase | Gets the ITextChangeType for a character casing change action.
CommentLines | Gets the ITextChangeType for a comment lines action.
ConvertSpacesToTabs | Gets the ITextChangeType for a convert spaces to tabs action.
ConvertTabsToSpaces | Gets the ITextChangeType for a convert tabs to spaces action.
Custom | Gets the ITextChangeType for a custom change type.
Cut | Gets the ITextChangeType for a cut to the clipboard action.
Delete | Gets the ITextChangeType for a deletion action.
DragAndDrop | Gets the ITextChangeType for a drag and drop action.
DuplicateLine | Gets the ITextChangeType for a duplicate line action.
Enter | Gets the ITextChangeType for the press of the Enter key.
HeaderAndFooterChange | Gets the ITextChangeType for the change of a snapshot's header and footer.
Indent | Gets the ITextChangeType for an indent action.
InsertCodeSnippetTemplate | Gets the ITextChangeType for a code snippet template insertion action.
InsertFile | Gets the ITextChangeType for an insert file action.
MoveSelectedLinesDown | Gets the ITextChangeType for a move selected lines down action.
MoveSelectedLinesUp | Gets the ITextChangeType for a move selected lines up action.
OpenLine | Gets the ITextChangeType for an open line action.
Outdent | Gets the ITextChangeType for an outdent action.
Paste | Gets the ITextChangeType for a paste from the clipboard action.
Replace | Gets the ITextChangeType for a replace action.
ReplaceAll | Gets the ITextChangeType for a replace all action.
SpellingChange | Gets the ITextChangeType for a spelling change action.
TextReplacement | Gets the ITextChangeType for a text replacement action.
ToggleCase | Gets the ITextChangeType for a toggle case action.
TransposeCharacters | Gets the ITextChangeType for a transpose characters action.
TransposeLines | Gets the ITextChangeType for a transpose lines action.
TransposeWords | Gets the ITextChangeType for a transpose words action.
TrimTrailingWhitespace | Gets the ITextChangeType for a trim trailing whitespace action.
Typing | Gets the ITextChangeType for a typing action.
UncommentLines | Gets the ITextChangeType for an uncomment lines action.
UpdateCodeSnippetTemplateFields | Gets the ITextChangeType for a code snippet template update fields action.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextChangeTypes Properties

TextChangeTypes Properties

The TextChangeTypes type exposes the following members.

Properties
Name | Description
AutoComplete | Gets the ITextChangeType for an IntelliPrompt auto-complete action.
AutoCorrect | Gets the ITextChangeType for an auto-correct action.
AutoFormat | Gets the ITextChangeType for an auto-format action.
AutoIndent | Gets the ITextChangeType for an auto-indent action.
AutoReplace | Gets the ITextChangeType for an auto-replace action.
Backspace | Gets the ITextChangeType for the press of the Backspace key.
ChangeCase | Gets the ITextChangeType for a character casing change action.
CommentLines | Gets the ITextChangeType for a comment lines action.
ConvertSpacesToTabs | Gets the ITextChangeType for a convert spaces to tabs action.
ConvertTabsToSpaces | Gets the ITextChangeType for a convert tabs to spaces action.
Custom | Gets the ITextChangeType for a custom change type.
Cut | Gets the ITextChangeType for a cut to the clipboard action.
Delete | Gets the ITextChangeType for a deletion action.
DragAndDrop | Gets the ITextChangeType for a drag and drop action.
DuplicateLine | Gets the ITextChangeType for a duplicate line action.
Enter | Gets the ITextChangeType for the press of the Enter key.
HeaderAndFooterChange | Gets the ITextChangeType for the change of a snapshot's header and footer.
Indent | Gets the ITextChangeType for an indent action.
InsertCodeSnippetTemplate | Gets the ITextChangeType for a code snippet template insertion action.
InsertFile | Gets the ITextChangeType for an insert file action.
MoveSelectedLinesDown | Gets the ITextChangeType for a move selected lines down action.
MoveSelectedLinesUp | Gets the ITextChangeType for a move selected lines up action.
OpenLine | Gets the ITextChangeType for an open line action.
Outdent | Gets the ITextChangeType for an outdent action.
Paste | Gets the ITextChangeType for a paste from the clipboard action.
Replace | Gets the ITextChangeType for a replace action.
ReplaceAll | Gets the ITextChangeType for a replace all action.
SpellingChange | Gets the ITextChangeType for a spelling change action.
TextReplacement | Gets the ITextChangeType for a text replacement action.
ToggleCase | Gets the ITextChangeType for a toggle case action.
TransposeCharacters | Gets the ITextChangeType for a transpose characters action.
TransposeLines | Gets the ITextChangeType for a transpose lines action.
TransposeWords | Gets the ITextChangeType for a transpose words action.
TrimTrailingWhitespace | Gets the ITextChangeType for a trim trailing whitespace action.
Typing | Gets the ITextChangeType for a typing action.
UncommentLines | Gets the ITextChangeType for an uncomment lines action.
UpdateCodeSnippetTemplateFields | Gets the ITextChangeType for a code snippet template update fields action.
Top
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoComplete Property

TextChangeTypesAutoComplete Property
Gets the ITextChangeType for an IntelliPrompt auto-complete action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoComplete { get; }
Public Shared ReadOnly Property AutoComplete As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an IntelliPrompt auto-complete action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoCorrect Property

TextChangeTypesAutoCorrect Property
Gets the ITextChangeType for an auto-correct action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoCorrect { get; }
Public Shared ReadOnly Property AutoCorrect As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-correct action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoFormat Property

TextChangeTypesAutoFormat Property
Gets the ITextChangeType for an auto-format action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoFormat { get; }
Public Shared ReadOnly Property AutoFormat As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-format action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoIndent Property

TextChangeTypesAutoIndent Property
Gets the ITextChangeType for an auto-indent action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoIndent { get; }
Public Shared ReadOnly Property AutoIndent As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-indent action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.AutoReplace Property

TextChangeTypesAutoReplace Property
Gets the ITextChangeType for an auto-replace action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType AutoReplace { get; }
Public Shared ReadOnly Property AutoReplace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an auto-replace action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Backspace Property

TextChangeTypesBackspace Property
Gets the ITextChangeType for the press of the Backspace key.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Backspace { get; }
Public Shared ReadOnly Property Backspace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for the press of the Backspace key.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ChangeCase Property

TextChangeTypesChangeCase Property
Gets the ITextChangeType for a character casing change action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType ChangeCase { get; }
Public Shared ReadOnly Property ChangeCase As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a character casing change action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.CommentLines Property

TextChangeTypesCommentLines Property
Gets the ITextChangeType for a comment lines action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType CommentLines { get; }
Public Shared ReadOnly Property CommentLines As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a comment lines action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ConvertSpacesToTabs Property

TextChangeTypesConvertSpacesToTabs Property
Gets the ITextChangeType for a convert spaces to tabs action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType ConvertSpacesToTabs { get; }
Public Shared ReadOnly Property ConvertSpacesToTabs As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a convert spaces to tabs action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ConvertTabsToSpaces Property

TextChangeTypesConvertTabsToSpaces Property
Gets the ITextChangeType for a convert tabs to spaces action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType ConvertTabsToSpaces { get; }
Public Shared ReadOnly Property ConvertTabsToSpaces As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a convert tabs to spaces action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Custom Property

TextChangeTypesCustom Property
Gets the ITextChangeType for a custom change type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Custom { get; }
Public Shared ReadOnly Property Custom As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a custom change type.
Remarks
Instead of using this ITextChangeType, it really is best to create your own custom ITextChangeType with the proper name.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Cut Property

TextChangeTypesCut Property
Gets the ITextChangeType for a cut to the clipboard action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Cut { get; }
Public Shared ReadOnly Property Cut As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a cut to the clipboard action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Delete Property

TextChangeTypesDelete Property
Gets the ITextChangeType for a deletion action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Delete { get; }
Public Shared ReadOnly Property Delete As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a deletion action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.DragAndDrop Property

TextChangeTypesDragAndDrop Property
Gets the ITextChangeType for a drag and drop action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType DragAndDrop { get; }
Public Shared ReadOnly Property DragAndDrop As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a drag and drop action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.DuplicateLine Property

TextChangeTypesDuplicateLine Property
Gets the ITextChangeType for a duplicate line action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType DuplicateLine { get; }
Public Shared ReadOnly Property DuplicateLine As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a duplicate line action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Enter Property

TextChangeTypesEnter Property
Gets the ITextChangeType for the press of the Enter key.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Enter { get; }
Public Shared ReadOnly Property Enter As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for the press of the Enter key.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.HeaderAndFooterChange Property

TextChangeTypesHeaderAndFooterChange Property
Gets the ITextChangeType for the change of a snapshot's header and footer.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType HeaderAndFooterChange { get; }
Public Shared ReadOnly Property HeaderAndFooterChange As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for the change of a snapshot's header and footer.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Indent Property

TextChangeTypesIndent Property
Gets the ITextChangeType for an indent action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Indent { get; }
Public Shared ReadOnly Property Indent As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an indent action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.InsertCodeSnippetTemplate Property

TextChangeTypesInsertCodeSnippetTemplate Property
Gets the ITextChangeType for a code snippet template insertion action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType InsertCodeSnippetTemplate { get; }
Public Shared ReadOnly Property InsertCodeSnippetTemplate As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a code snippet template insertion action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.InsertFile Property

TextChangeTypesInsertFile Property
Gets the ITextChangeType for an insert file action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType InsertFile { get; }
Public Shared ReadOnly Property InsertFile As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an insert file action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.MoveSelectedLinesDown Property

TextChangeTypesMoveSelectedLinesDown Property
Gets the ITextChangeType for a move selected lines down action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType MoveSelectedLinesDown { get; }
Public Shared ReadOnly Property MoveSelectedLinesDown As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a move selected lines down action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.MoveSelectedLinesUp Property

TextChangeTypesMoveSelectedLinesUp Property
Gets the ITextChangeType for a move selected lines up action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType MoveSelectedLinesUp { get; }
Public Shared ReadOnly Property MoveSelectedLinesUp As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a move selected lines up action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.OpenLine Property

TextChangeTypesOpenLine Property
Gets the ITextChangeType for an open line action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType OpenLine { get; }
Public Shared ReadOnly Property OpenLine As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an open line action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Outdent Property

TextChangeTypesOutdent Property
Gets the ITextChangeType for an outdent action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Outdent { get; }
Public Shared ReadOnly Property Outdent As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an outdent action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Paste Property

TextChangeTypesPaste Property
Gets the ITextChangeType for a paste from the clipboard action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Paste { get; }
Public Shared ReadOnly Property Paste As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a paste from the clipboard action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Replace Property

TextChangeTypesReplace Property
Gets the ITextChangeType for a replace action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Replace { get; }
Public Shared ReadOnly Property Replace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a replace action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ReplaceAll Property

TextChangeTypesReplaceAll Property
Gets the ITextChangeType for a replace all action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType ReplaceAll { get; }
Public Shared ReadOnly Property ReplaceAll As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a replace all action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.SpellingChange Property

TextChangeTypesSpellingChange Property
Gets the ITextChangeType for a spelling change action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType SpellingChange { get; }
Public Shared ReadOnly Property SpellingChange As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a spelling change action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TextReplacement Property

TextChangeTypesTextReplacement Property
Gets the ITextChangeType for a text replacement action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType TextReplacement { get; }
Public Shared ReadOnly Property TextReplacement As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a text replacement action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.ToggleCase Property

TextChangeTypesToggleCase Property
Gets the ITextChangeType for a toggle case action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType ToggleCase { get; }
Public Shared ReadOnly Property ToggleCase As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a toggle case action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TransposeCharacters Property

TextChangeTypesTransposeCharacters Property
Gets the ITextChangeType for a transpose characters action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType TransposeCharacters { get; }
Public Shared ReadOnly Property TransposeCharacters As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a transpose characters action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TransposeLines Property

TextChangeTypesTransposeLines Property
Gets the ITextChangeType for a transpose lines action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType TransposeLines { get; }
Public Shared ReadOnly Property TransposeLines As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a transpose lines action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TransposeWords Property

TextChangeTypesTransposeWords Property
Gets the ITextChangeType for a transpose words action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType TransposeWords { get; }
Public Shared ReadOnly Property TransposeWords As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a transpose words action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.TrimTrailingWhitespace Property

TextChangeTypesTrimTrailingWhitespace Property
Gets the ITextChangeType for a trim trailing whitespace action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType TrimTrailingWhitespace { get; }
Public Shared ReadOnly Property TrimTrailingWhitespace As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a trim trailing whitespace action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.Typing Property

TextChangeTypesTyping Property
Gets the ITextChangeType for a typing action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType Typing { get; }
Public Shared ReadOnly Property Typing As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a typing action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.UncommentLines Property

TextChangeTypesUncommentLines Property
Gets the ITextChangeType for an uncomment lines action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType UncommentLines { get; }
Public Shared ReadOnly Property UncommentLines As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for an uncomment lines action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextChangeTypes.UpdateCodeSnippetTemplateFields Property

TextChangeTypesUpdateCodeSnippetTemplateFields Property
Gets the ITextChangeType for a code snippet template update fields action.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextChangeType UpdateCodeSnippetTemplateFields { get; }
Public Shared ReadOnly Property UpdateCodeSnippetTemplateFields As ITextChangeType
    Get

Property Value

Type: ITextChangeType
The ITextChangeType for a code snippet template update fields action.
See Also

Reference

TextChangeTypes Class
ActiproSoftware.Text Namespace


TextOffsetTrackingMode Class

TextOffsetTrackingMode Class
Specifies how a text offset is updated by text change operations that occur around it.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextTextOffsetTrackingMode

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextOffsetTrackingMode : Enum
Public NotInheritable Class TextOffsetTrackingMode
    Inherits Enum

The TextOffsetTrackingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Negative | The text offset tends to move in a negative (towards document start) direction when text change operations occur next to it. If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4. If the text offset is 3, and a single character is inserted at offset 3, the text offset remains 3. If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 2, which is the start of the text change operation.
 | Positive | The text offset tends to move in a positive (towards document end) direction when text change operations occur next to it. If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4. If the text offset is 3, and a single character is inserted at offset 3, the text offset slides forward a character and becomes 4. If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 5, which is the end of the text change operation's insertion.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextOffsetTrackingMode Methods

TextOffsetTrackingMode Methods

The TextOffsetTrackingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TextOffsetTrackingMode Class
ActiproSoftware.Text Namespace


TextOffsetTrackingMode Fields

TextOffsetTrackingMode Fields

The TextOffsetTrackingMode type exposes the following members.

Fields
 | Name | Description
 | Negative | The text offset tends to move in a negative (towards document start) direction when text change operations occur next to it. If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4. If the text offset is 3, and a single character is inserted at offset 3, the text offset remains 3. If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 2, which is the start of the text change operation.
 | Positive | The text offset tends to move in a positive (towards document end) direction when text change operations occur next to it. If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4. If the text offset is 3, and a single character is inserted at offset 3, the text offset slides forward a character and becomes 4. If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 5, which is the end of the text change operation's insertion.
Public field | value__ |
Top
See Also

Reference

TextOffsetTrackingMode Class
ActiproSoftware.Text Namespace


TextOffsetTrackingMode.Negative Field

TextOffsetTrackingModeNegative Field
The text offset tends to move in a negative (towards document start) direction when text change operations occur next to it.

If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4.

If the text offset is 3, and a single character is inserted at offset 3, the text offset remains 3.

If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 2, which is the start of the text change operation.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextOffsetTrackingMode Negative = 0
Public Const Negative As TextOffsetTrackingMode = 0

Field Value

Type: TextOffsetTrackingMode
See Also

Reference

TextOffsetTrackingMode Class
ActiproSoftware.Text Namespace


TextOffsetTrackingMode.Positive Field

TextOffsetTrackingModePositive Field
The text offset tends to move in a positive (towards document end) direction when text change operations occur next to it.

If the text offset is 3, and a single character is inserted at offset 2, the text offset slides forward a character and becomes 4.

If the text offset is 3, and a single character is inserted at offset 3, the text offset slides forward a character and becomes 4.

If the text offset is 3, and the text range {2,4} is replaced with text Foo, the text offset moves to 5, which is the end of the text change operation's insertion.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextOffsetTrackingMode Positive = 1
Public Const Positive As TextOffsetTrackingMode = 1

Field Value

Type: TextOffsetTrackingMode
See Also

Reference

TextOffsetTrackingMode Class
ActiproSoftware.Text Namespace


TextOffsetTrackingMode.value__ Field

TextOffsetTrackingModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.TextOffsetTrackingMode.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TextOffsetTrackingMode Class
ActiproSoftware.Text Namespace


TextPosition Class

TextPosition Class
Represents an ordered pair of zero-based line and character index values that defines a position within the lines of an ITextSnapshot.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.TextTextPosition

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextPosition : ValueType,
    IComparable
Public NotInheritable Class TextPosition
    Inherits ValueType
    Implements IComparable

The TextPosition type exposes the following members.

Constructors
 | Name | Description
Public method | TextPosition | Initializes a new instance of the TextPosition class with the specified line and character values.
Top
Properties
 | Name | Description
Public property | Character | Gets the zero-based character of this TextPosition.
Public property | DisplayCharacter | Gets the one-based character of this TextPosition, which is better for display than use of the Character property.
Public property | DisplayLine | Gets the one-based line of this TextPosition, which is better for display than use of the Line property.
Public property | IsEmpty | Returns whether the TextPosition is empty.
Public property | Line | Gets the zero-based line of this TextPosition.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of this TextPosition object.
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextPosition) | Compares the current instance with another TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | First | Returns the TextPosition that comes first.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
 | Last | Returns the TextPosition that comes last.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
Fields
Name | Description
Empty | Returns an empty TextPosition.
MaxCharacter | Gets the maximum character value for a position.
MaxLine | Gets the maximum line value for a position.
Zero | Returns a TextPosition with line and character values of 0.
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextPosition Constructor

TextPosition Constructor
Initializes a new instance of the TextPosition class with the specified line and character values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition(
    int line,
    int character
)
Public Sub New (
    line As Integer,
    character As Integer
)

Parameters

line
Type: SystemInt32
The line of the position.
character
Type: SystemInt32
The character of the position.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition Properties

TextPosition Properties

The TextPosition type exposes the following members.

Properties
 | Name | Description
Public property | Character | Gets the zero-based character of this TextPosition.
Public property | DisplayCharacter | Gets the one-based character of this TextPosition, which is better for display than use of the Character property.
Public property | DisplayLine | Gets the one-based line of this TextPosition, which is better for display than use of the Line property.
Public property | IsEmpty | Returns whether the TextPosition is empty.
Public property | Line | Gets the zero-based line of this TextPosition.
Top
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Character Property

TextPositionCharacter Property
Gets the zero-based character of this TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Character { get; }
Public ReadOnly Property Character As Integer
    Get

Property Value

Type: Int32
The zero-based character of this TextPosition.
Remarks
This property is zero-based. When displaying the value in UI, use the DisplayCharacter property instead, which adds 1 to this value to make it one-based.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.DisplayCharacter Property

TextPositionDisplayCharacter Property
Gets the one-based character of this TextPosition, which is better for display than use of the Character property.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int DisplayCharacter { get; }
Public ReadOnly Property DisplayCharacter As Integer
    Get

Property Value

Type: Int32
The one-based character of this TextPosition, which is better for display than use of the Character property.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.DisplayLine Property

TextPositionDisplayLine Property
Gets the one-based line of this TextPosition, which is better for display than use of the Line property.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int DisplayLine { get; }
Public ReadOnly Property DisplayLine As Integer
    Get

Property Value

Type: Int32
The one-based line of this TextPosition, which is better for display than use of the Line property.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.IsEmpty Property

TextPositionIsEmpty Property
Returns whether the TextPosition is empty.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the TextPosition is empty; otherwise, false.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Line Property

TextPositionLine Property
Gets the zero-based line of this TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Line { get; }
Public ReadOnly Property Line As Integer
    Get

Property Value

Type: Int32
The zero-based line of this TextPosition.
Remarks
This property is zero-based. When displaying the value in UI, use the DisplayCharacter property instead, which adds 1 to this value to make it one-based.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition Methods

TextPosition Methods

The TextPosition type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of this TextPosition object.
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextPosition) | Compares the current instance with another TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | First | Returns the TextPosition that comes first.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
 | Last | Returns the TextPosition that comes last.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Clone Method

TextPositionClone Method
Creates a copy of this TextPosition object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
The TextPosition object that this method creates.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.CompareTo Method

TextPositionCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextPosition) | Compares the current instance with another TextPosition.
Top
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.CompareTo Method (Object)

TextPositionCompareTo Method (Object)
Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
An object to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.

Implements

IComparableCompareTo(Object)
See Also

Reference

TextPosition Class
CompareTo Overload
ActiproSoftware.Text Namespace


TextPosition.CompareTo Method (TextPosition)

TextPositionCompareTo Method (TextPosition)
Compares the current instance with another TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextPosition position
)
Public Function CompareTo (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
A TextPosition to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextPosition Class
CompareTo Overload
ActiproSoftware.Text Namespace


TextPosition.Equals Method

TextPositionEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.First Method

TextPositionFirst Method
Returns the TextPosition that comes first.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextPosition First(
    TextPosition position1,
    TextPosition position2
)
Public Shared Function First (
    position1 As TextPosition,
    position2 As TextPosition
) As TextPosition

Parameters

position1
Type: ActiproSoftware.TextTextPosition
The first TextPosition to compare.
position2
Type: ActiproSoftware.TextTextPosition
The second TextPosition to compare.

Return Value

Type: TextPosition
The TextPosition that comes first.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.GetHashCode Method

TextPositionGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Last Method

TextPositionLast Method
Returns the TextPosition that comes last.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextPosition Last(
    TextPosition position1,
    TextPosition position2
)
Public Shared Function Last (
    position1 As TextPosition,
    position2 As TextPosition
) As TextPosition

Parameters

position1
Type: ActiproSoftware.TextTextPosition
The first TextPosition to compare.
position2
Type: ActiproSoftware.TextTextPosition
The second TextPosition to compare.

Return Value

Type: TextPosition
The TextPosition that comes last.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.ToString Method

TextPositionToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition Operators

TextPosition Operators

The TextPosition type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Equality Operator

TextPositionEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextPosition left,
    TextPosition right
)
Public Shared Operator = (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_Equality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.GreaterThan Operator

TextPositionGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextPosition left,
    TextPosition right
)
Public Shared Operator > (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.GreaterThanOrEqual Operator

TextPositionGreaterThanOrEqual Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator >=(
    TextPosition left,
    TextPosition right
)
Public Shared Operator >= (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_GreaterThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Inequality Operator

TextPositionInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextPosition left,
    TextPosition right
)
Public Shared Operator <> (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_Inequality(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.LessThan Operator

TextPositionLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextPosition left,
    TextPosition right
)
Public Shared Operator < (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThan(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.LessThanOrEqual Operator

TextPositionLessThanOrEqual Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator <=(
    TextPosition left,
    TextPosition right
)
Public Shared Operator <= (
    left As TextPosition,
    right As TextPosition
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPosition

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

right
Type: ActiproSoftware.TextTextPosition

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPosition.op_LessThanOrEqual(ActiproSoftware.Text.TextPosition,ActiproSoftware.Text.TextPosition)"]

See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition Fields

TextPosition Fields

The TextPosition type exposes the following members.

Fields
Name | Description
Empty | Returns an empty TextPosition.
MaxCharacter | Gets the maximum character value for a position.
MaxLine | Gets the maximum line value for a position.
Zero | Returns a TextPosition with line and character values of 0.
Top
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Empty Field

TextPositionEmpty Field
Returns an empty TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly TextPosition Empty
Public Shared ReadOnly Empty As TextPosition

Field Value

Type: TextPosition
A TextPosition that is empty.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.MaxCharacter Field

TextPositionMaxCharacter Field
Gets the maximum character value for a position.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MaxCharacter = 2147483647
Public Const MaxCharacter As Integer = 2147483647

Field Value

Type: Int32
The maximum character value for a position.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.MaxLine Field

TextPositionMaxLine Field
Gets the maximum line value for a position.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MaxLine = 2147483647
Public Const MaxLine As Integer = 2147483647

Field Value

Type: Int32
The maximum line value for a position.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPosition.Zero Field

TextPositionZero Field
Returns a TextPosition with line and character values of 0.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly TextPosition Zero
Public Shared ReadOnly Zero As TextPosition

Field Value

Type: TextPosition
A TextPosition with line and character values of 0.
See Also

Reference

TextPosition Class
ActiproSoftware.Text Namespace


TextPositionRange Class

TextPositionRange Class
Represents a range of two TextPosition values within the lines of an ITextSnapshot.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.TextTextPositionRange

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextPositionRange : ValueType
Public NotInheritable Class TextPositionRange
    Inherits ValueType

The TextPositionRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextPositionRange(TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition value for both start and end.
Public method | TextPositionRange(TextPosition, TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Public method | TextPositionRange(Int32, Int32, Int32, Int32) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Top
Properties
 | Name | Description
 | Empty | Returns an empty TextPositionRange.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | FirstPosition | Gets the first TextPosition in the range.
Public property | IsEmpty | Returns whether the TextPositionRange is empty.
Public property | IsNormalized | Gets whether the range is normalized (StartPosition occurs at or before the EndPosition).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastPosition | Gets the last TextPosition in the range.
Public property | Lines | Gets the number of lines encompassed by the TextPositionRange.
Public property | NormalizedTextPositionRange | Gets a normalized version of this TextPositionRange without actually modifying this instance.
Public property | StartPosition | Gets the start TextPosition in the range.
Top
Methods
 | Name | Description
Public method | BordersOn(TextPosition) | Returns whether the TextPositionRange borders on the specified TextPosition.
Public method | BordersOn(TextPositionRange) | Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.
Public method | Clone | Creates a copy of this TextPositionRange object.
Public method | Contains(TextPosition) | Returns whether the TextPositionRange contains the specified TextPosition.
Public method | Contains(TextPositionRange) | Returns whether the TextPositionRange contains the specified TextPositionRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith(TextPosition) | Returns whether the TextPositionRange intersects with the specified TextPosition.
Public method | IntersectsWith(TextPositionRange) | Returns whether the TextPositionRange intersects with the specified TextPositionRange.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Normalize | Normalizes the range and ensures that the StartPosition occurs at or before the EndPosition TextPosition.
Public method | OverlapsWith | Returns whether the TextPositionRange overlaps with, or crosses, the specified TextPositionRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
 | Union | Returns the normalized union of two TextPositionRange objects.
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextPositionRange Constructor

TextPositionRange Constructor
Overload List
 | Name | Description
Public method | TextPositionRange(TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition value for both start and end.
Public method | TextPositionRange(TextPosition, TextPosition) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Public method | TextPositionRange(Int32, Int32, Int32, Int32) | Initializes a new instance of the TextPositionRange class with the specified TextPosition values.
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange Constructor (TextPosition)

TextPositionRange Constructor (TextPosition)
Initializes a new instance of the TextPositionRange class with the specified TextPosition value for both start and end.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange(
    TextPosition position
)
Public Sub New (
    position As TextPosition
)

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to use as the start and end of the range.
See Also

Reference

TextPositionRange Class
TextPositionRange Overload
ActiproSoftware.Text Namespace


TextPositionRange Constructor (TextPosition, TextPosition)

TextPositionRange Constructor (TextPosition, TextPosition)
Initializes a new instance of the TextPositionRange class with the specified TextPosition values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange(
    TextPosition startPosition,
    TextPosition endPosition
)
Public Sub New (
    startPosition As TextPosition,
    endPosition As TextPosition
)

Parameters

startPosition
Type: ActiproSoftware.TextTextPosition
The start TextPosition in the range.
endPosition
Type: ActiproSoftware.TextTextPosition
The end TextPositionin the range.
See Also

Reference

TextPositionRange Class
TextPositionRange Overload
ActiproSoftware.Text Namespace


TextPositionRange Constructor (Int32, Int32, Int32, Int32)

TextPositionRange Constructor (Int32, Int32, Int32, Int32)
Initializes a new instance of the TextPositionRange class with the specified TextPosition values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange(
    int startLine,
    int startCharacter,
    int endLine,
    int endCharacter
)
Public Sub New (
    startLine As Integer,
    startCharacter As Integer,
    endLine As Integer,
    endCharacter As Integer
)

Parameters

startLine
Type: SystemInt32
The line of the start TextPositionin the range.
startCharacter
Type: SystemInt32
The character of the start TextPositionin the range.
endLine
Type: SystemInt32
The line of the end TextPositionin the range.
endCharacter
Type: SystemInt32
The character of the end TextPositionin the range.
See Also

Reference

TextPositionRange Class
TextPositionRange Overload
ActiproSoftware.Text Namespace


TextPositionRange Properties

TextPositionRange Properties

The TextPositionRange type exposes the following members.

Properties
 | Name | Description
 | Empty | Returns an empty TextPositionRange.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | FirstPosition | Gets the first TextPosition in the range.
Public property | IsEmpty | Returns whether the TextPositionRange is empty.
Public property | IsNormalized | Gets whether the range is normalized (StartPosition occurs at or before the EndPosition).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastPosition | Gets the last TextPosition in the range.
Public property | Lines | Gets the number of lines encompassed by the TextPositionRange.
Public property | NormalizedTextPositionRange | Gets a normalized version of this TextPositionRange without actually modifying this instance.
Public property | StartPosition | Gets the start TextPosition in the range.
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Empty Property

TextPositionRangeEmpty Property
Returns an empty TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextPositionRange Empty { get; }
Public Shared ReadOnly Property Empty As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that is empty.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.EndPosition Property

TextPositionRangeEndPosition Property
Gets the end TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition EndPosition { get; }
Public ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The end TextPosition in the range.
Remarks
The end TextPosition may occur before the start TextPosition if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first TextPosition in the range, use the FirstPosition property. To get the normalized last TextPosition in the range, use the LastPosition property.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.FirstPosition Property

TextPositionRangeFirstPosition Property
Gets the first TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition FirstPosition { get; }
Public ReadOnly Property FirstPosition As TextPosition
    Get

Property Value

Type: TextPosition
The first TextPosition in the range.
Remarks
This property returns either the StartPosition or EndPosition property, whichever comes first.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.IsEmpty Property

TextPositionRangeIsEmpty Property
Returns whether the TextPositionRange is empty.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the TextPositionRange is empty; otherwise, false.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.IsNormalized Property

TextPositionRangeIsNormalized Property
Gets whether the range is normalized (StartPosition occurs at or before the EndPosition).

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNormalized { get; }
Public ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the range is normalized; otherwise, false.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.IsZeroLength Property

TextPositionRangeIsZeroLength Property
Gets whether the range has a zero length.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsZeroLength { get; }
Public ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the range has a zero length; otherwise, false.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.LastPosition Property

TextPositionRangeLastPosition Property
Gets the last TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition LastPosition { get; }
Public ReadOnly Property LastPosition As TextPosition
    Get

Property Value

Type: TextPosition
The last TextPosition in the range.
Remarks
This property returns either the StartPosition or EndPosition property, whichever comes last.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Lines Property

TextPositionRangeLines Property
Gets the number of lines encompassed by the TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Lines { get; }
Public ReadOnly Property Lines As Integer
    Get

Property Value

Type: Int32
The number of lines encompassed by the TextPositionRange.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.NormalizedTextPositionRange Property

TextPositionRangeNormalizedTextPositionRange Property
Gets a normalized version of this TextPositionRange without actually modifying this instance.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange NormalizedTextPositionRange { get; }
Public ReadOnly Property NormalizedTextPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A normalized version of this TextPositionRange without actually modifying this instance.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.StartPosition Property

TextPositionRangeStartPosition Property
Gets the start TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition StartPosition { get; }
Public ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The start TextPosition in the range.
Remarks
The start TextPosition may occur after the end TextPosition if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first TextPosition in the range, use the FirstPosition property. To get the normalized last TextPosition in the range, use the LastPosition property.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange Methods

TextPositionRange Methods

The TextPositionRange type exposes the following members.

Methods
 | Name | Description
Public method | BordersOn(TextPosition) | Returns whether the TextPositionRange borders on the specified TextPosition.
Public method | BordersOn(TextPositionRange) | Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.
Public method | Clone | Creates a copy of this TextPositionRange object.
Public method | Contains(TextPosition) | Returns whether the TextPositionRange contains the specified TextPosition.
Public method | Contains(TextPositionRange) | Returns whether the TextPositionRange contains the specified TextPositionRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith(TextPosition) | Returns whether the TextPositionRange intersects with the specified TextPosition.
Public method | IntersectsWith(TextPositionRange) | Returns whether the TextPositionRange intersects with the specified TextPositionRange.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Normalize | Normalizes the range and ensures that the StartPosition occurs at or before the EndPosition TextPosition.
Public method | OverlapsWith | Returns whether the TextPositionRange overlaps with, or crosses, the specified TextPositionRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
 | Union | Returns the normalized union of two TextPositionRange objects.
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.BordersOn Method

TextPositionRangeBordersOn Method
Overload List
 | Name | Description
Public method | BordersOn(TextPosition) | Returns whether the TextPositionRange borders on the specified TextPosition.
Public method | BordersOn(TextPositionRange) | Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.BordersOn Method (TextPosition)

TextPositionRangeBordersOn Method (TextPosition)
Returns whether the TextPositionRange borders on the specified TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextPosition position
)
Public Function BordersOn (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the TextPositionRange borders on the specified TextPosition; otherwise, false.
Remarks
This method checks to see if the specified TextPosition is either the StartPosition or EndPosition.
See Also

Reference

TextPositionRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextPositionRange.BordersOn Method (TextPositionRange)

TextPositionRangeBordersOn Method (TextPositionRange)
Returns whether the TextPositionRange borders on, but does not overlap the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextPositionRange range
)
Public Function BordersOn (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange borders on, but does not overlap the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextPositionRange.Clone Method

TextPositionRangeClone Method
Creates a copy of this TextPositionRange object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
The TextPositionRange object that this method creates.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Contains Method

TextPositionRangeContains Method
Overload List
 | Name | Description
Public method | Contains(TextPosition) | Returns whether the TextPositionRange contains the specified TextPosition.
Public method | Contains(TextPositionRange) | Returns whether the TextPositionRange contains the specified TextPositionRange.
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Contains Method (TextPosition)

TextPositionRangeContains Method (TextPosition)
Returns whether the TextPositionRange contains the specified TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextPosition position
)
Public Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the TextPositionRange contains the specified TextPosition; otherwise, false.
Remarks
This method returns false if the TextPosition falls on the LastPosition TextPosition since this method indicates if the TextPosition is encompassed by the TextPositionRange.
See Also

Reference

TextPositionRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextPositionRange.Contains Method (TextPositionRange)

TextPositionRangeContains Method (TextPositionRange)
Returns whether the TextPositionRange contains the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextPositionRange range
)
Public Function Contains (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange contains the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextPositionRange.Equals Method

TextPositionRangeEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.GetHashCode Method

TextPositionRangeGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.IntersectsWith Method

TextPositionRangeIntersectsWith Method
Overload List
 | Name | Description
Public method | IntersectsWith(TextPosition) | Returns whether the TextPositionRange intersects with the specified TextPosition.
Public method | IntersectsWith(TextPositionRange) | Returns whether the TextPositionRange intersects with the specified TextPositionRange.
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.IntersectsWith Method (TextPosition)

TextPositionRangeIntersectsWith Method (TextPosition)
Returns whether the TextPositionRange intersects with the specified TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextPosition position
)
Public Function IntersectsWith (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the TextPositionRange intersects with the specified TextPosition; otherwise, false.
See Also

Reference

TextPositionRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextPositionRange.IntersectsWith Method (TextPositionRange)

TextPositionRangeIntersectsWith Method (TextPositionRange)
Returns whether the TextPositionRange intersects with the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextPositionRange range
)
Public Function IntersectsWith (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange intersects with the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextPositionRange.Normalize Method

TextPositionRangeNormalize Method
Normalizes the range and ensures that the StartPosition occurs at or before the EndPosition TextPosition.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.OverlapsWith Method

TextPositionRangeOverlapsWith Method
Returns whether the TextPositionRange overlaps with, or crosses, the specified TextPositionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextPositionRange range
)
Public Function OverlapsWith (
    range As TextPositionRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.

Return Value

Type: Boolean
true if the TextPositionRange overlaps with, or crosses, the specified TextPositionRange; otherwise, false.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.ToString Method

TextPositionRangeToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Union Method

TextPositionRangeUnion Method
Returns the normalized union of two TextPositionRange objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextPositionRange Union(
    TextPositionRange range1,
    TextPositionRange range2
)
Public Shared Function Union (
    range1 As TextPositionRange,
    range2 As TextPositionRange
) As TextPositionRange

Parameters

range1
Type: ActiproSoftware.TextTextPositionRange
The first TextPositionRange to examine.
range2
Type: ActiproSoftware.TextTextPositionRange
The second TextPositionRange to examine.

Return Value

Type: TextPositionRange
The normalized union of two TextPositionRange objects.
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange Operators

TextPositionRange Operators

The TextPositionRange type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Equality Operator

TextPositionRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextPositionRange left,
    TextPositionRange right
)
Public Shared Operator = (
    left As TextPositionRange,
    right As TextPositionRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

right
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Equality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextPositionRange.Inequality Operator

TextPositionRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextPositionRange left,
    TextPositionRange right
)
Public Shared Operator <> (
    left As TextPositionRange,
    right As TextPositionRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

right
Type: ActiproSoftware.TextTextPositionRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextPositionRange.op_Inequality(ActiproSoftware.Text.TextPositionRange,ActiproSoftware.Text.TextPositionRange)"]

See Also

Reference

TextPositionRange Class
ActiproSoftware.Text Namespace


TextRange Class

TextRange Class
Represents a zero-based range of two offset values within a text document.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.TextTextRange

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextRange : ValueType,
    IComparable, ITextRangeProvider
Public NotInheritable Class TextRange
    Inherits ValueType
    Implements IComparable, ITextRangeProvider

The TextRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextRange(Int32) | Initializes a new instance of the TextRange class using the specified offset for both the start and end values.
Public method | TextRange(Int32, Int32) | Initializes a new instance of the TextRange class with the specified offset values.
Top
Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextRange.
 | Deleted | Gets a TextRange that is flagged as deleted.
Public property | EndOffset | Gets the end offset in the range.
Public property | FirstOffset | Gets the first offset in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsNormalized | Gets whether the range is normalized (StartOffset occurs at or before the EndOffset).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastOffset | Gets the last offset in the range.
Public property | Length | Gets the number of characters encompassed by the TextRange.
Public property | NormalizedTextRange | Gets a normalized version of this TextRange without actually modifying this instance.
Public property | StartOffset | Gets the start offset in the range.
Top
Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextRange borders on, but does not overlap the specified TextRange.
Public method | Clone | Creates a copy of this TextRange object.
Public method | CompareTo | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextRange contains the specified TextRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromSpan | Returns a TextRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
 | Intersect | Returns the intersection of two TextRange objects.
Public method | IntersectsWith(Int32) | Returns whether the TextRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextRange intersects with the specified TextRange.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Normalize | Normalizes the range and ensures that the StartOffset occurs at or before the EndOffset offset.
Public method | OverlapsWith | Returns whether the TextRange overlaps with, or crosses, the specified TextRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Translate(ITextSnapshot, ITextSnapshot, TextRangeTrackingModes) | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Public method | Translate(ITextVersion, ITextVersion, TextRangeTrackingModes) | Translates this text range from one ITextVersion to another in the same ITextDocument.
 | Union | Returns the normalized union of two TextRange objects.
Top
Operators
Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextRange Constructor

TextRange Constructor
Overload List
 | Name | Description
Public method | TextRange(Int32) | Initializes a new instance of the TextRange class using the specified offset for both the start and end values.
Public method | TextRange(Int32, Int32) | Initializes a new instance of the TextRange class with the specified offset values.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange Constructor (Int32)

TextRange Constructor (Int32)
Initializes a new instance of the TextRange class using the specified offset for both the start and end values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange(
    int offset
)
Public Sub New (
    offset As Integer
)

Parameters

offset
Type: SystemInt32
The start and end offset in the range.
See Also

Reference

TextRange Class
TextRange Overload
ActiproSoftware.Text Namespace


TextRange Constructor (Int32, Int32)

TextRange Constructor (Int32, Int32)
Initializes a new instance of the TextRange class with the specified offset values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange(
    int startOffset,
    int endOffset
)
Public Sub New (
    startOffset As Integer,
    endOffset As Integer
)

Parameters

startOffset
Type: SystemInt32
The start offset in the range.
endOffset
Type: SystemInt32
The end offset in the range.
See Also

Reference

TextRange Class
TextRange Overload
ActiproSoftware.Text Namespace


TextRange Properties

TextRange Properties

The TextRange type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextRange.
 | Deleted | Gets a TextRange that is flagged as deleted.
Public property | EndOffset | Gets the end offset in the range.
Public property | FirstOffset | Gets the first offset in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsNormalized | Gets whether the range is normalized (StartOffset occurs at or before the EndOffset).
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | LastOffset | Gets the last offset in the range.
Public property | Length | Gets the number of characters encompassed by the TextRange.
Public property | NormalizedTextRange | Gets a normalized version of this TextRange without actually modifying this instance.
Public property | StartOffset | Gets the start offset in the range.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.AbsoluteLength Property

TextRangeAbsoluteLength Property
Gets the absolute number of characters encompassed by the TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int AbsoluteLength { get; }
Public ReadOnly Property AbsoluteLength As Integer
    Get

Property Value

Type: Int32
The absolute number of characters encompassed by the TextRange.
Remarks
This value will always return a positive length, even if the range is not normalized.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Deleted Property

TextRangeDeleted Property
Gets a TextRange that is flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextRange Deleted { get; }
Public Shared ReadOnly Property Deleted As TextRange
    Get

Property Value

Type: TextRange
A TextRange that is flagged as deleted.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.EndOffset Property

TextRangeEndOffset Property
Gets the end offset in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int EndOffset { get; }
Public ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The end offset in the range.
Remarks
The end offset may occur before the start offset if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first offset in the range, use the FirstOffset property. To get the normalized last offset in the range, use the LastOffset property.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.FirstOffset Property

TextRangeFirstOffset Property
Gets the first offset in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FirstOffset { get; }
Public ReadOnly Property FirstOffset As Integer
    Get

Property Value

Type: Int32
The first offset in the range.
Remarks
This property returns either the StartOffset or EndOffset property, whichever comes first.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.IsDeleted Property

TextRangeIsDeleted Property
Gets whether the range has been flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get

Property Value

Type: Boolean
true if the range has been flagged as deleted; otherwise, false.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.IsNormalized Property

TextRangeIsNormalized Property
Gets whether the range is normalized (StartOffset occurs at or before the EndOffset).

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNormalized { get; }
Public ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the range is normalized; otherwise, false.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.IsZeroLength Property

TextRangeIsZeroLength Property
Gets whether the range has a zero length.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsZeroLength { get; }
Public ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the range has a zero length; otherwise, false.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.LastOffset Property

TextRangeLastOffset Property
Gets the last offset in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int LastOffset { get; }
Public ReadOnly Property LastOffset As Integer
    Get

Property Value

Type: Int32
The last offset in the range.
Remarks
This property returns either the StartOffset or EndOffset property, whichever comes last.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Length Property

TextRangeLength Property
Gets the number of characters encompassed by the TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters encompassed by the TextRange.
Remarks
This value will return a negative length if the range is not normalized.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.NormalizedTextRange Property

TextRangeNormalizedTextRange Property
Gets a normalized version of this TextRange without actually modifying this instance.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange NormalizedTextRange { get; }
Public ReadOnly Property NormalizedTextRange As TextRange
    Get

Property Value

Type: TextRange
A normalized version of this TextRange without actually modifying this instance.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.StartOffset Property

TextRangeStartOffset Property
Gets the start offset in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int StartOffset { get; }
Public ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The start offset in the range.
Remarks
The start offset may occur after the end offset if the range is not normalized. The IsNormalized property indicates if the range is normalized. To get the normalized first offset in the range, use the FirstOffset property. To get the normalized last offset in the range, use the LastOffset property.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange Methods

TextRange Methods

The TextRange type exposes the following members.

Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextRange borders on, but does not overlap the specified TextRange.
Public method | Clone | Creates a copy of this TextRange object.
Public method | CompareTo | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextRange contains the specified TextRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromSpan | Returns a TextRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
 | Intersect | Returns the intersection of two TextRange objects.
Public method | IntersectsWith(Int32) | Returns whether the TextRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextRange intersects with the specified TextRange.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Normalize | Normalizes the range and ensures that the StartOffset occurs at or before the EndOffset offset.
Public method | OverlapsWith | Returns whether the TextRange overlaps with, or crosses, the specified TextRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Translate(ITextSnapshot, ITextSnapshot, TextRangeTrackingModes) | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Public method | Translate(ITextVersion, ITextVersion, TextRangeTrackingModes) | Translates this text range from one ITextVersion to another in the same ITextDocument.
 | Union | Returns the normalized union of two TextRange objects.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.BordersOn Method

TextRangeBordersOn Method
Overload List
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextRange borders on, but does not overlap the specified TextRange.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.BordersOn Method (Int32)

TextRangeBordersOn Method (Int32)
Returns whether the TextRange borders on the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    int offset
)
Public Function BordersOn (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextRange borders on the specified offset; otherwise, false.
Remarks
This method checks to see if the specified offset is either the StartOffset or EndOffset.
See Also

Reference

TextRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextRange.BordersOn Method (TextRange)

TextRangeBordersOn Method (TextRange)
Returns whether the TextRange borders on, but does not overlap the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextRange range
)
Public Function BordersOn (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange borders on, but does not overlap the specified TextRange; otherwise, false.
See Also

Reference

TextRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextRange.Clone Method

TextRangeClone Method
Creates a copy of this TextRange object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
The TextRange object that this method creates.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.CompareTo Method

TextRangeCompareTo Method
Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextRange textRange
)
Public Function CompareTo (
    textRange As TextRange
) As Integer

Parameters

textRange
Type: ActiproSoftware.TextTextRange
A TextRange to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Contains Method

TextRangeContains Method
Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the TextRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextRange contains the specified TextRange.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Contains Method (Int32)

TextRangeContains Method (Int32)
Returns whether the TextRange contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextRange contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the LastOffset offset since this method indicates if the offset is encompassed by the TextRange.
See Also

Reference

TextRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextRange.Contains Method (TextRange)

TextRangeContains Method (TextRange)
Returns whether the TextRange contains the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextRange range
)
Public Function Contains (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange contains the specified TextRange; otherwise, false.
See Also

Reference

TextRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextRange.Equals Method

TextRangeEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.FromSpan Method

TextRangeFromSpan Method
Returns a TextRange that covers the specified offset and length.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextRange FromSpan(
    int offset,
    int length
)
Public Shared Function FromSpan (
    offset As Integer,
    length As Integer
) As TextRange

Parameters

offset
Type: SystemInt32
The start offset.
length
Type: SystemInt32
The length of the range.

Return Value

Type: TextRange
The TextRange that was created.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.GetHashCode Method

TextRangeGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Intersect Method

TextRangeIntersect Method
Returns the intersection of two TextRange objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextRange Intersect(
    TextRange range1,
    TextRange range2
)
Public Shared Function Intersect (
    range1 As TextRange,
    range2 As TextRange
) As TextRange

Parameters

range1
Type: ActiproSoftware.TextTextRange
The first TextRange to examine.
range2
Type: ActiproSoftware.TextTextRange
The second TextRange to examine.

Return Value

Type: TextRange
The intersection of two TextRange objects.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method

TextRangeIntersectsWith Method
Overload List
 | Name | Description
Public method | IntersectsWith(Int32) | Returns whether the TextRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextRange intersects with the specified TextRange.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method (Int32)

TextRangeIntersectsWith Method (Int32)
Returns whether the TextRange intersects with the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    int offset
)
Public Function IntersectsWith (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextRange intersects with the specified offset; otherwise, false.
Remarks
This method returns whether the specified offset borders on or lies within the TextRange.
See Also

Reference

TextRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextRange.IntersectsWith Method (TextRange)

TextRangeIntersectsWith Method (TextRange)
Returns whether the TextRange intersects with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextRange range
)
Public Function IntersectsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange intersects with the specified TextRange; otherwise, false.
Remarks
This method returns whether the specified TextRange borders on or overlaps the TextRange.
See Also

Reference

TextRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextRange.Normalize Method

TextRangeNormalize Method
Normalizes the range and ensures that the StartOffset occurs at or before the EndOffset offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.OverlapsWith Method

TextRangeOverlapsWith Method
Returns whether the TextRange overlaps with, or crosses, the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextRange range
)
Public Function OverlapsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextRange overlaps with, or crosses, the specified TextRange; otherwise, false.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.ToString Method

TextRangeToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Translate Method

TextRangeTranslate Method
Overload List
 | Name | Description
Public method | Translate(ITextSnapshot, ITextSnapshot, TextRangeTrackingModes) | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Public method | Translate(ITextVersion, ITextVersion, TextRangeTrackingModes) | Translates this text range from one ITextVersion to another in the same ITextDocument.
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Translate Method (ITextSnapshot, ITextSnapshot, TextRangeTrackingModes)

TextRangeTranslate Method (ITextSnapshot, ITextSnapshot, TextRangeTrackingModes)
Translates this text range from one ITextSnapshot to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange Translate(
    ITextSnapshot fromSnapshot,
    ITextSnapshot toSnapshot,
    TextRangeTrackingModes trackingModes
)
Public Function Translate (
    fromSnapshot As ITextSnapshot,
    toSnapshot As ITextSnapshot,
    trackingModes As TextRangeTrackingModes
) As TextRange

Parameters

fromSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to which to text range belongs.
toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is the target of the translation.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: TextRange
The translated TextRange.
See Also

Reference

TextRange Class
Translate Overload
ActiproSoftware.Text Namespace


TextRange.Translate Method (ITextVersion, ITextVersion, TextRangeTrackingModes)

TextRangeTranslate Method (ITextVersion, ITextVersion, TextRangeTrackingModes)
Translates this text range from one ITextVersion to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange Translate(
    ITextVersion fromVersion,
    ITextVersion toVersion,
    TextRangeTrackingModes trackingModes
)
Public Function Translate (
    fromVersion As ITextVersion,
    toVersion As ITextVersion,
    trackingModes As TextRangeTrackingModes
) As TextRange

Parameters

fromVersion
Type: ActiproSoftware.TextITextVersion
The ITextVersion to which to text range belongs.
toVersion
Type: ActiproSoftware.TextITextVersion
The ITextVersion that is the target of the translation.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: TextRange
The translated TextRange.
See Also

Reference

TextRange Class
Translate Overload
ActiproSoftware.Text Namespace


TextRange.Union Method

TextRangeUnion Method
Returns the normalized union of two TextRange objects.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextRange Union(
    TextRange range1,
    TextRange range2
)
Public Shared Function Union (
    range1 As TextRange,
    range2 As TextRange
) As TextRange

Parameters

range1
Type: ActiproSoftware.TextTextRange
The first TextRange to examine.
range2
Type: ActiproSoftware.TextTextRange
The second TextRange to examine.

Return Value

Type: TextRange
The normalized union of two TextRange objects.
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange Operators

TextRange Operators

The TextRange type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
Inequality |
LessThan |
Top
See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Equality Operator

TextRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextRange left,
    TextRange right
)
Public Shared Operator = (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_Equality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.GreaterThan Operator

TextRangeGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextRange left,
    TextRange right
)
Public Shared Operator > (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_GreaterThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.Inequality Operator

TextRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextRange left,
    TextRange right
)
Public Shared Operator <> (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_Inequality(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRange.LessThan Operator

TextRangeLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextRange left,
    TextRange right
)
Public Shared Operator < (
    left As TextRange,
    right As TextRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

right
Type: ActiproSoftware.TextTextRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextRange.op_LessThan(ActiproSoftware.Text.TextRange,ActiproSoftware.Text.TextRange)"]

See Also

Reference

TextRange Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes Class

TextRangeTrackingModes Class
Specifies how a text range is updated by text change operations that occur at its edges.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextTextRangeTrackingModes

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class TextRangeTrackingModes : Enum
<FlagsAttribute>
Public NotInheritable Class TextRangeTrackingModes
    Inherits Enum

The TextRangeTrackingModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The text range doesn't get deleted by deletion operations that cross it, instead is slides to the deletion start. The text range doesn't expand when insertion operations occur at its edges. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.
 | DeleteMask | The mask value for all delete-related values.
 | DeleteWhenSurrounded | Alters deletion behavior such that the text range is deleted if a deletion operation occurs that completely surrounds it. A deletion operation that collapses the text range to zero-length will not delete it.
 | DeleteWhenZeroLength | Alters deletion behavior such that the text range is deleted if a deletion operation occurs that surrounds it or collapses it to zero-length. This value includes the DeleteWhenSurrounded value.
 | ExpandBothEdges | Alters expansion behavior such that the text range expands when insertion operations occur at either of its edges. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}. This value is the combination of the ExpandFirstEdge and ExpandLastEdge values.
 | ExpandFirstEdge | Alters expansion behavior such that the text range expands when insertion operations occur at its leading (first) edge. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.
 | ExpandLastEdge | Alters expansion behavior such that the text range expands when insertion operations occur at its trailing (last) edge. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}.
 | ExpandMask | The mask value for all expansion-related values.
 | LineBased | The text range follows the text on the line to which it is attached. This option is useful for line-based tracking, such as for bookmarks. Inserting a line terminator in the line will move the text range to the next line, unless the line terminator is inserted at the very end of the line.
Public field | value__ |
Top
Remarks
Combine various flags to achieve different tracking behavior.
See Also

Reference

ActiproSoftware.Text Namespace


TextRangeTrackingModes Methods

TextRangeTrackingModes Methods

The TextRangeTrackingModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes Fields

TextRangeTrackingModes Fields

The TextRangeTrackingModes type exposes the following members.

Fields
 | Name | Description
 | Default | The text range doesn't get deleted by deletion operations that cross it, instead is slides to the deletion start. The text range doesn't expand when insertion operations occur at its edges. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.
 | DeleteMask | The mask value for all delete-related values.
 | DeleteWhenSurrounded | Alters deletion behavior such that the text range is deleted if a deletion operation occurs that completely surrounds it. A deletion operation that collapses the text range to zero-length will not delete it.
 | DeleteWhenZeroLength | Alters deletion behavior such that the text range is deleted if a deletion operation occurs that surrounds it or collapses it to zero-length. This value includes the DeleteWhenSurrounded value.
 | ExpandBothEdges | Alters expansion behavior such that the text range expands when insertion operations occur at either of its edges. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}. This value is the combination of the ExpandFirstEdge and ExpandLastEdge values.
 | ExpandFirstEdge | Alters expansion behavior such that the text range expands when insertion operations occur at its leading (first) edge. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.
 | ExpandLastEdge | Alters expansion behavior such that the text range expands when insertion operations occur at its trailing (last) edge. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}. If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}.
 | ExpandMask | The mask value for all expansion-related values.
 | LineBased | The text range follows the text on the line to which it is attached. This option is useful for line-based tracking, such as for bookmarks. Inserting a line terminator in the line will move the text range to the next line, unless the line terminator is inserted at the very end of the line.
Public field | value__ |
Top
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.Default Field

TextRangeTrackingModesDefault Field
The text range doesn't get deleted by deletion operations that cross it, instead is slides to the deletion start. The text range doesn't expand when insertion operations occur at its edges.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes Default = 0
Public Const Default As TextRangeTrackingModes = 0

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.DeleteMask Field

TextRangeTrackingModesDeleteMask Field
The mask value for all delete-related values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes DeleteMask = 12
Public Const DeleteMask As TextRangeTrackingModes = 12

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.DeleteWhenSurrounded Field

TextRangeTrackingModesDeleteWhenSurrounded Field
Alters deletion behavior such that the text range is deleted if a deletion operation occurs that completely surrounds it. A deletion operation that collapses the text range to zero-length will not delete it.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes DeleteWhenSurrounded = 4
Public Const DeleteWhenSurrounded As TextRangeTrackingModes = 4

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.DeleteWhenZeroLength Field

TextRangeTrackingModesDeleteWhenZeroLength Field
Alters deletion behavior such that the text range is deleted if a deletion operation occurs that surrounds it or collapses it to zero-length.

This value includes the DeleteWhenSurrounded value.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes DeleteWhenZeroLength = 12
Public Const DeleteWhenZeroLength As TextRangeTrackingModes = 12

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.ExpandBothEdges Field

TextRangeTrackingModesExpandBothEdges Field
Alters expansion behavior such that the text range expands when insertion operations occur at either of its edges.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}.

This value is the combination of the ExpandFirstEdge and ExpandLastEdge values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes ExpandBothEdges = 3
Public Const ExpandBothEdges As TextRangeTrackingModes = 3

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.ExpandFirstEdge Field

TextRangeTrackingModesExpandFirstEdge Field
Alters expansion behavior such that the text range expands when insertion operations occur at its leading (first) edge.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range expands to become {2,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range remains {2,4}.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes ExpandFirstEdge = 1
Public Const ExpandFirstEdge As TextRangeTrackingModes = 1

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.ExpandLastEdge Field

TextRangeTrackingModesExpandLastEdge Field
Alters expansion behavior such that the text range expands when insertion operations occur at its trailing (last) edge.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 2, the text range slides forward a character and becomes {3,5}.

If the text range is {2,4}, meaning the characters at offsets 2 and 3 are included in the range, and a single character is inserted at offset 4, the text range expands to become {2,5}.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes ExpandLastEdge = 2
Public Const ExpandLastEdge As TextRangeTrackingModes = 2

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.ExpandMask Field

TextRangeTrackingModesExpandMask Field
The mask value for all expansion-related values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes ExpandMask = 3
Public Const ExpandMask As TextRangeTrackingModes = 3

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.LineBased Field

TextRangeTrackingModesLineBased Field
The text range follows the text on the line to which it is attached. This option is useful for line-based tracking, such as for bookmarks.

Inserting a line terminator in the line will move the text range to the next line, unless the line terminator is inserted at the very end of the line.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextRangeTrackingModes LineBased = 16
Public Const LineBased As TextRangeTrackingModes = 16

Field Value

Type: TextRangeTrackingModes
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextRangeTrackingModes.value__ Field

TextRangeTrackingModesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.TextRangeTrackingModes.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TextRangeTrackingModes Class
ActiproSoftware.Text Namespace


TextScanDirection Class

TextScanDirection Class
Specifies a direction in which text will be scanned.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextTextScanDirection

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextScanDirection : Enum
Public NotInheritable Class TextScanDirection
    Inherits Enum

The TextScanDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Backward | Backward-oriented text scanning.
 | Forward | Forward-oriented text scanning.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextScanDirection Methods

TextScanDirection Methods

The TextScanDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TextScanDirection Class
ActiproSoftware.Text Namespace


TextScanDirection Fields

TextScanDirection Fields

The TextScanDirection type exposes the following members.

Fields
 | Name | Description
 | Backward | Backward-oriented text scanning.
 | Forward | Forward-oriented text scanning.
Public field | value__ |
Top
See Also

Reference

TextScanDirection Class
ActiproSoftware.Text Namespace


TextScanDirection.Backward Field

TextScanDirectionBackward Field
Backward-oriented text scanning.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextScanDirection Backward = 1
Public Const Backward As TextScanDirection = 1

Field Value

Type: TextScanDirection
See Also

Reference

TextScanDirection Class
ActiproSoftware.Text Namespace


TextScanDirection.Forward Field

TextScanDirectionForward Field
Forward-oriented text scanning.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextScanDirection Forward = 0
Public Const Forward As TextScanDirection = 0

Field Value

Type: TextScanDirection
See Also

Reference

TextScanDirection Class
ActiproSoftware.Text Namespace


TextScanDirection.value__ Field

TextScanDirectionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.TextScanDirection.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TextScanDirection Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Class

TextSnapshotChangedEventArgs Class
Event arguments for the ITextDocument.TextChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextTextSnapshotChangedEventArgs

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextSnapshotChangedEventArgs : EventArgs
Public Class TextSnapshotChangedEventArgs
    Inherits EventArgs

The TextSnapshotChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotChangedEventArgs | Initializes a new instance of the TextSnapshotChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | ChangedSnapshotRange | Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Constructor

TextSnapshotChangedEventArgs Constructor
Initializes a new instance of the TextSnapshotChangedEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotChangedEventArgs(
    ITextSnapshot oldSnapshot,
    ITextSnapshot newSnapshot,
    ITextChange textChange
)
Public Sub New (
    oldSnapshot As ITextSnapshot,
    newSnapshot As ITextSnapshot,
    textChange As ITextChange
)

Parameters

oldSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
newSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that is made.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Properties

TextSnapshotChangedEventArgs Properties

The TextSnapshotChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangedSnapshotRange | Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.ChangedSnapshotRange Property

TextSnapshotChangedEventArgsChangedSnapshotRange Property
Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange ChangedSnapshotRange { get; }
Public ReadOnly Property ChangedSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.NewSnapshot Property

TextSnapshotChangedEventArgsNewSnapshot Property
Gets the ITextSnapshot that is in effect after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot NewSnapshot { get; }
Public ReadOnly Property NewSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
Remarks
This property value may be before the text change actually occurs.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.OldSnapshot Property

TextSnapshotChangedEventArgsOldSnapshot Property
Gets the ITextSnapshot that is in effect before the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot OldSnapshot { get; }
Public ReadOnly Property OldSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs.TextChange Property

TextSnapshotChangedEventArgsTextChange Property
Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextChange TextChange { get; }
Public ReadOnly Property TextChange As ITextChange
    Get

Property Value

Type: ITextChange
The ITextChange that is made to the document.
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangedEventArgs Methods

TextSnapshotChangedEventArgs Methods

The TextSnapshotChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextSnapshotChangedEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Class

TextSnapshotChangingEventArgs Class
Event arguments for the ITextDocument.TextChanging event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
ActiproSoftware.TextTextSnapshotChangingEventArgs

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextSnapshotChangingEventArgs : CancelEventArgs
Public Class TextSnapshotChangingEventArgs
    Inherits CancelEventArgs

The TextSnapshotChangingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotChangingEventArgs | Initializes a new instance of the TextSnapshotChangingEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | (Inherited from CancelEventArgs.)
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Constructor

TextSnapshotChangingEventArgs Constructor
Initializes a new instance of the TextSnapshotChangingEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotChangingEventArgs(
    ITextSnapshot oldSnapshot,
    ITextSnapshot newSnapshot,
    ITextChange textChange
)
Public Sub New (
    oldSnapshot As ITextSnapshot,
    newSnapshot As ITextSnapshot,
    textChange As ITextChange
)

Parameters

oldSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
newSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that is made.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Properties

TextSnapshotChangingEventArgs Properties

The TextSnapshotChangingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | (Inherited from CancelEventArgs.)
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Top
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs.NewSnapshot Property

TextSnapshotChangingEventArgsNewSnapshot Property
Gets the ITextSnapshot that is in effect after the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot NewSnapshot { get; }
Public ReadOnly Property NewSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
Remarks
This property value may be before the text change actually occurs.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs.OldSnapshot Property

TextSnapshotChangingEventArgsOldSnapshot Property
Gets the ITextSnapshot that is in effect before the text change is applied.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot OldSnapshot { get; }
Public ReadOnly Property OldSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs.TextChange Property

TextSnapshotChangingEventArgsTextChange Property
Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextChange TextChange { get; }
Public ReadOnly Property TextChange As ITextChange
    Get

Property Value

Type: ITextChange
The ITextChange that is made to the document.
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotChangingEventArgs Methods

TextSnapshotChangingEventArgs Methods

The TextSnapshotChangingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextSnapshotChangingEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotOffset Class

TextSnapshotOffset Class
Represents a zero-based offset value within a certain ITextSnapshot.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.TextTextSnapshotOffset

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextSnapshotOffset : ValueType,
    ITextRangeProvider
Public NotInheritable Class TextSnapshotOffset
    Inherits ValueType
    Implements ITextRangeProvider

The TextSnapshotOffset type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotOffset | Initializes a new instance of the TextSnapshotOffset class with the specified offset.
Top
Properties
 | Name | Description
Public property | Column | Gets the zero-based column value, which accounts for the document's tab size.
 | Deleted | Gets a TextSnapshotOffset that has no Snapshot and is flagged as deleted.
Public property | IsDeleted | Gets whether the offset has been flagged as deleted.
Public property | Line | Gets the ITextSnapshotLine that contains the offset.
Public property | Offset | Gets the zero-based offset value.
Public property | Position | Gets the TextPosition for the offset.
Public property | Snapshot | Gets the ITextSnapshot that contains the offset.
Top
Methods
 | Name | Description
Public method | CompareTo(Int32) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotOffset) | Compares the current instance with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | TranslateTo | Translates this offset from one ITextSnapshot to another in the same ITextDocument.
Top
Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotOffset to Int32) |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotOffset Constructor

TextSnapshotOffset Constructor
Initializes a new instance of the TextSnapshotOffset class with the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotOffset(
    ITextSnapshot snapshot,
    int offset
)
Public Sub New (
    snapshot As ITextSnapshot,
    offset As Integer
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the offset.
offset
Type: SystemInt32
The zero-based offset.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset Properties

TextSnapshotOffset Properties

The TextSnapshotOffset type exposes the following members.

Properties
 | Name | Description
Public property | Column | Gets the zero-based column value, which accounts for the document's tab size.
 | Deleted | Gets a TextSnapshotOffset that has no Snapshot and is flagged as deleted.
Public property | IsDeleted | Gets whether the offset has been flagged as deleted.
Public property | Line | Gets the ITextSnapshotLine that contains the offset.
Public property | Offset | Gets the zero-based offset value.
Public property | Position | Gets the TextPosition for the offset.
Public property | Snapshot | Gets the ITextSnapshot that contains the offset.
Top
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Column Property

TextSnapshotOffsetColumn Property
Gets the zero-based column value, which accounts for the document's tab size.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Column { get; }
Public ReadOnly Property Column As Integer
    Get

Property Value

Type: Int32
The zero-based column value, which accounts for the document's tab size.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Deleted Property

TextSnapshotOffsetDeleted Property
Gets a TextSnapshotOffset that has no Snapshot and is flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextSnapshotOffset Deleted { get; }
Public Shared ReadOnly Property Deleted As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
A TextSnapshotOffset that has no Snapshot and is flagged as deleted.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.IsDeleted Property

TextSnapshotOffsetIsDeleted Property
Gets whether the offset has been flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get

Property Value

Type: Boolean
true if the offset has been flagged as deleted; otherwise, false.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Line Property

TextSnapshotOffsetLine Property
Gets the ITextSnapshotLine that contains the offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshotLine Line { get; }
Public ReadOnly Property Line As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the offset.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Offset Property

TextSnapshotOffsetOffset Property
Gets the zero-based offset value.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The zero-based offset value.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Position Property

TextSnapshotOffsetPosition Property
Gets the TextPosition for the offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition Position { get; }
Public ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition for the offset.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Snapshot Property

TextSnapshotOffsetSnapshot Property
Gets the ITextSnapshot that contains the offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; }
Public ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the offset.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset Methods

TextSnapshotOffset Methods

The TextSnapshotOffset type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Int32) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotOffset) | Compares the current instance with another object of the same type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | TranslateTo | Translates this offset from one ITextSnapshot to another in the same ITextDocument.
Top
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.CompareTo Method

TextSnapshotOffsetCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Int32) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotOffset) | Compares the current instance with another object of the same type.
Top
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.CompareTo Method (Int32)

TextSnapshotOffsetCompareTo Method (Int32)
Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    int value
)
Public Function CompareTo (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
An offset to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotOffset Class
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotOffset.CompareTo Method (TextSnapshotOffset)

TextSnapshotOffsetCompareTo Method (TextSnapshotOffset)
Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextSnapshotOffset snapshotOffset
)
Public Function CompareTo (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
A TextSnapshotOffset to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotOffset Class
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotOffset.Equals Method

TextSnapshotOffsetEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.GetHashCode Method

TextSnapshotOffsetGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.ToString Method

TextSnapshotOffsetToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.TranslateTo Method

TextSnapshotOffsetTranslateTo Method
Translates this offset from one ITextSnapshot to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotOffset TranslateTo(
    ITextSnapshot toSnapshot,
    TextOffsetTrackingMode trackingMode
)
Public Function TranslateTo (
    toSnapshot As ITextSnapshot,
    trackingMode As TextOffsetTrackingMode
) As TextSnapshotOffset

Parameters

toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is the target of the translation.
trackingMode
Type: ActiproSoftware.TextTextOffsetTrackingMode
A TextOffsetTrackingMode indicating the tracking mode to use.

Return Value

Type: TextSnapshotOffset
The translated TextSnapshotOffset.
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset Operators and Type Conversions

TextSnapshotOffset Operators and Type Conversions

The TextSnapshotOffset type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotOffset to Int32) |
Inequality |
LessThan |
Top
See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Equality Operator

TextSnapshotOffsetEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator = (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Equality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.GreaterThan Operator

TextSnapshotOffsetGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator > (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_GreaterThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset Implicit Conversion (TextSnapshotOffset to Int32)

TextSnapshotOffset Conversion (TextSnapshotOffset to Int32)

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Implicit(ActiproSoftware.Text.TextSnapshotOffset)~System.Int32"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator int (
    TextSnapshotOffset snapshotOffset
)
Public Shared Widening Operator CType (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="snapshotOffset"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Implicit(ActiproSoftware.Text.TextSnapshotOffset)~System.Int32"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Implicit(ActiproSoftware.Text.TextSnapshotOffset)~System.Int32"]

See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.Inequality Operator

TextSnapshotOffsetInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator <> (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_Inequality(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotOffset.LessThan Operator

TextSnapshotOffsetLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextSnapshotOffset left,
    TextSnapshotOffset right
)
Public Shared Operator < (
    left As TextSnapshotOffset,
    right As TextSnapshotOffset
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

right
Type: ActiproSoftware.TextTextSnapshotOffset

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotOffset.op_LessThan(ActiproSoftware.Text.TextSnapshotOffset,ActiproSoftware.Text.TextSnapshotOffset)"]

See Also

Reference

TextSnapshotOffset Class
ActiproSoftware.Text Namespace


TextSnapshotRange Class

TextSnapshotRange Class
Represents a zero-based range of two normalized offset values within a certain ITextSnapshot.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.TextTextSnapshotRange

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextSnapshotRange : ValueType,
    ITextPositionRangeProvider, ITextRangeProvider
Public NotInheritable Class TextSnapshotRange
    Inherits ValueType
    Implements ITextPositionRangeProvider, ITextRangeProvider

The TextSnapshotRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotRange(TextSnapshotOffset) | Initializes a new instance of the TextSnapshotRange class using the specified TextSnapshotOffset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, TextRange) | Initializes a new instance of the TextSnapshotRange class with the specified TextRange.
Public method | TextSnapshotRange(ITextSnapshot, Int32) | Initializes a new instance of the TextSnapshotRange class using the specified offset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, Int32, Int32) | Initializes a new instance of the TextSnapshotRange class with the specified offset values.
Top
Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextSnapshotRange.
 | Deleted | Gets a TextSnapshotRange that has no Snapshot and is flagged as deleted.
Public property | EndLine | Gets the ITextSnapshotLine that contains the end offset in the text range.
Public property | EndOffset | Gets the end offset in the range.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | Length | Gets the number of characters encompassed by the TextSnapshotRange.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the object.
Public property | Snapshot | Gets the ITextSnapshot that contains the text range.
Public property | StartLine | Gets the ITextSnapshotLine that contains the start offset in the text range.
Public property | StartOffset | Gets the start offset in the range.
Public property | StartPosition | Gets the start TextPosition in the range.
Public property | Text | Gets the snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.
Public property | TextRange | Gets a TextRange that specifies the text range of the object.
Top
Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextSnapshotRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.
Public method | BordersOn(TextSnapshotRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.
Public method | CompareTo(TextRange) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotRange) | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextSnapshotRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextSnapshotRange contains the specified TextRange.
Public method | Contains(TextSnapshotRange) | Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromSpan | Returns a TextSnapshotRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetText | Returns the snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith(Int32) | Returns whether the TextSnapshotRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextSnapshotRange intersects with the specified TextRange.
Public method | IntersectsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OverlapsWith(TextRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.
Public method | OverlapsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | ToVersionRange(TextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | ToVersionRange(FuncTextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | TranslateTo | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Top
Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotRange to TextRange) |
Inequality |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotRange Constructor

TextSnapshotRange Constructor
Overload List
 | Name | Description
Public method | TextSnapshotRange(TextSnapshotOffset) | Initializes a new instance of the TextSnapshotRange class using the specified TextSnapshotOffset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, TextRange) | Initializes a new instance of the TextSnapshotRange class with the specified TextRange.
Public method | TextSnapshotRange(ITextSnapshot, Int32) | Initializes a new instance of the TextSnapshotRange class using the specified offset for both the start and end values.
Public method | TextSnapshotRange(ITextSnapshot, Int32, Int32) | Initializes a new instance of the TextSnapshotRange class with the specified offset values.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (TextSnapshotOffset)

TextSnapshotRange Constructor (TextSnapshotOffset)
Initializes a new instance of the TextSnapshotRange class using the specified TextSnapshotOffset for both the start and end values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    TextSnapshotOffset snapshotOffset
)
Public Sub New (
    snapshotOffset As TextSnapshotOffset
)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The start and end offset in the range.
See Also

Reference

TextSnapshotRange Class
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (ITextSnapshot, TextRange)

TextSnapshotRange Constructor (ITextSnapshot, TextRange)
Initializes a new instance of the TextSnapshotRange class with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    ITextSnapshot snapshot,
    TextRange textRange
)
Public Sub New (
    snapshot As ITextSnapshot,
    textRange As TextRange
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of the range.
See Also

Reference

TextSnapshotRange Class
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (ITextSnapshot, Int32)

TextSnapshotRange Constructor (ITextSnapshot, Int32)
Initializes a new instance of the TextSnapshotRange class using the specified offset for both the start and end values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    ITextSnapshot snapshot,
    int offset
)
Public Sub New (
    snapshot As ITextSnapshot,
    offset As Integer
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
offset
Type: SystemInt32
The start and end offset in the range.
See Also

Reference

TextSnapshotRange Class
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Constructor (ITextSnapshot, Int32, Int32)

TextSnapshotRange Constructor (ITextSnapshot, Int32, Int32)
Initializes a new instance of the TextSnapshotRange class with the specified offset values.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange(
    ITextSnapshot snapshot,
    int startOffset,
    int endOffset
)
Public Sub New (
    snapshot As ITextSnapshot,
    startOffset As Integer,
    endOffset As Integer
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
startOffset
Type: SystemInt32
The start offset in the range.
endOffset
Type: SystemInt32
The end offset in the range.
See Also

Reference

TextSnapshotRange Class
TextSnapshotRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange Properties

TextSnapshotRange Properties

The TextSnapshotRange type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteLength | Gets the absolute number of characters encompassed by the TextSnapshotRange.
 | Deleted | Gets a TextSnapshotRange that has no Snapshot and is flagged as deleted.
Public property | EndLine | Gets the ITextSnapshotLine that contains the end offset in the text range.
Public property | EndOffset | Gets the end offset in the range.
Public property | EndPosition | Gets the end TextPosition in the range.
Public property | IsDeleted | Gets whether the range has been flagged as deleted.
Public property | IsZeroLength | Gets whether the range has a zero length.
Public property | Length | Gets the number of characters encompassed by the TextSnapshotRange.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the object.
Public property | Snapshot | Gets the ITextSnapshot that contains the text range.
Public property | StartLine | Gets the ITextSnapshotLine that contains the start offset in the text range.
Public property | StartOffset | Gets the start offset in the range.
Public property | StartPosition | Gets the start TextPosition in the range.
Public property | Text | Gets the snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.
Public property | TextRange | Gets a TextRange that specifies the text range of the object.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.AbsoluteLength Property

TextSnapshotRangeAbsoluteLength Property
Gets the absolute number of characters encompassed by the TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int AbsoluteLength { get; }
Public ReadOnly Property AbsoluteLength As Integer
    Get

Property Value

Type: Int32
The absolute number of characters encompassed by the TextSnapshotRange.
Remarks
This value will always return a positive length, even if the range is not normalized.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Deleted Property

TextSnapshotRangeDeleted Property
Gets a TextSnapshotRange that has no Snapshot and is flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextSnapshotRange Deleted { get; }
Public Shared ReadOnly Property Deleted As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that has no Snapshot and is flagged as deleted.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.EndLine Property

TextSnapshotRangeEndLine Property
Gets the ITextSnapshotLine that contains the end offset in the text range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshotLine EndLine { get; }
Public ReadOnly Property EndLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the end offset in the text range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.EndOffset Property

TextSnapshotRangeEndOffset Property
Gets the end offset in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int EndOffset { get; }
Public ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The end offset in the range.
Remarks
Since snapshot ranges are normalized, this property returns the last offset in the range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.EndPosition Property

TextSnapshotRangeEndPosition Property
Gets the end TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition EndPosition { get; }
Public ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The end TextPosition in the range.
Remarks
Since snapshot ranges are normalized, this property returns the last TextPosition in the range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.IsDeleted Property

TextSnapshotRangeIsDeleted Property
Gets whether the range has been flagged as deleted.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDeleted { get; }
Public ReadOnly Property IsDeleted As Boolean
    Get

Property Value

Type: Boolean
true if the range has been flagged as deleted; otherwise, false.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.IsZeroLength Property

TextSnapshotRangeIsZeroLength Property
Gets whether the range has a zero length.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsZeroLength { get; }
Public ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the range has a zero length; otherwise, false.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Length Property

TextSnapshotRangeLength Property
Gets the number of characters encompassed by the TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters encompassed by the TextSnapshotRange.
Remarks
This value will return a negative length if the range is not normalized.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.PositionRange Property

TextSnapshotRangePositionRange Property
Gets a TextPositionRange that specifies the text position range of the object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; }
Public ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the object.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Snapshot Property

TextSnapshotRangeSnapshot Property
Gets the ITextSnapshot that contains the text range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; }
Public ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the text range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.StartLine Property

TextSnapshotRangeStartLine Property
Gets the ITextSnapshotLine that contains the start offset in the text range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshotLine StartLine { get; }
Public ReadOnly Property StartLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The ITextSnapshotLine that contains the start offset in the text range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.StartOffset Property

TextSnapshotRangeStartOffset Property
Gets the start offset in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int StartOffset { get; }
Public ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The start offset in the range.
Remarks
Since snapshot ranges are normalized, this property returns the first offset in the range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.StartPosition Property

TextSnapshotRangeStartPosition Property
Gets the start TextPosition in the range.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition StartPosition { get; }
Public ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The start TextPosition in the range.
Remarks
Since snapshot ranges are normalized, this property returns the first TextPosition in the range.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Text Property

TextSnapshotRangeText Property
Gets the snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The snapshot text substring encompassed by this range, using CarriageReturnNewline for line ends.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.TextRange Property

TextSnapshotRangeTextRange Property
Gets a TextRange that specifies the text range of the object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; }
Public ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
A TextRange that specifies the text range of the object.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange Methods

TextSnapshotRange Methods

The TextSnapshotRange type exposes the following members.

Methods
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextSnapshotRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.
Public method | BordersOn(TextSnapshotRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.
Public method | CompareTo(TextRange) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotRange) | Compares the current instance with another object of the same type.
Public method | Contains(Int32) | Returns whether the TextSnapshotRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextSnapshotRange contains the specified TextRange.
Public method | Contains(TextSnapshotRange) | Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
 | FromSpan | Returns a TextSnapshotRange that covers the specified offset and length.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetText | Returns the snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith(Int32) | Returns whether the TextSnapshotRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextSnapshotRange intersects with the specified TextRange.
Public method | IntersectsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OverlapsWith(TextRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.
Public method | OverlapsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | ToVersionRange(TextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | ToVersionRange(FuncTextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | TranslateTo | Translates this text range from one ITextSnapshot to another in the same ITextDocument.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method

TextSnapshotRangeBordersOn Method
Overload List
 | Name | Description
Public method | BordersOn(Int32) | Returns whether the TextSnapshotRange borders on the specified offset.
Public method | BordersOn(TextRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.
Public method | BordersOn(TextSnapshotRange) | Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method (Int32)

TextSnapshotRangeBordersOn Method (Int32)
Returns whether the TextSnapshotRange borders on the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    int offset
)
Public Function BordersOn (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange borders on the specified offset; otherwise, false.
Remarks
This method checks to see if the specified offset is either the StartOffset or EndOffset.
See Also

Reference

TextSnapshotRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method (TextRange)

TextSnapshotRangeBordersOn Method (TextRange)
Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextRange range
)
Public Function BordersOn (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange borders on, but does not overlap the specified TextRange; otherwise, false.
See Also

Reference

TextSnapshotRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.BordersOn Method (TextSnapshotRange)

TextSnapshotRangeBordersOn Method (TextSnapshotRange)
Returns whether the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BordersOn(
    TextSnapshotRange range
)
Public Function BordersOn (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange borders on, but does not overlap the specified TextSnapshotRange; otherwise, false.
See Also

Reference

TextSnapshotRange Class
BordersOn Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.CompareTo Method

TextSnapshotRangeCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(TextRange) | Compares the current instance with another object of the same type.
Public method | CompareTo(TextSnapshotRange) | Compares the current instance with another object of the same type.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.CompareTo Method (TextRange)

TextSnapshotRangeCompareTo Method (TextRange)
Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextRange range
)
Public Function CompareTo (
    range As TextRange
) As Integer

Parameters

range
Type: ActiproSoftware.TextTextRange
A TextRange to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotRange Class
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.CompareTo Method (TextSnapshotRange)

TextSnapshotRangeCompareTo Method (TextSnapshotRange)
Compares the current instance with another object of the same type.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    TextSnapshotRange range
)
Public Function CompareTo (
    range As TextSnapshotRange
) As Integer

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange to compare with this instance.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the comparands.
See Also

Reference

TextSnapshotRange Class
CompareTo Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method

TextSnapshotRangeContains Method
Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the TextSnapshotRange contains the specified offset.
Public method | Contains(TextRange) | Returns whether the TextSnapshotRange contains the specified TextRange.
Public method | Contains(TextSnapshotRange) | Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method (Int32)

TextSnapshotRangeContains Method (Int32)
Returns whether the TextSnapshotRange contains the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method (TextRange)

TextSnapshotRangeContains Method (TextRange)
Returns whether the TextSnapshotRange contains the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextRange range
)
Public Function Contains (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange contains the specified TextRange; otherwise, false.
See Also

Reference

TextSnapshotRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Contains Method (TextSnapshotRange)

TextSnapshotRangeContains Method (TextSnapshotRange)
Returns whether the TextSnapshotRange contains the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextSnapshotRange range
)
Public Function Contains (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange contains the specified TextSnapshotRange; otherwise, false.
See Also

Reference

TextSnapshotRange Class
Contains Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.Equals Method

TextSnapshotRangeEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.FromSpan Method

TextSnapshotRangeFromSpan Method
Returns a TextSnapshotRange that covers the specified offset and length.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextSnapshotRange FromSpan(
    ITextSnapshot snapshot,
    int offset,
    int length
)
Public Shared Function FromSpan (
    snapshot As ITextSnapshot,
    offset As Integer,
    length As Integer
) As TextSnapshotRange

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that contains the text range.
offset
Type: SystemInt32
The start offset.
length
Type: SystemInt32
The length of the range.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange that was created.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.GetHashCode Method

TextSnapshotRangeGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.GetText Method

TextSnapshotRangeGetText Method
Returns the snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetText(
    LineTerminator lineTerminator
)
Public Function GetText (
    lineTerminator As LineTerminator
) As String

Parameters

lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the type of line terminators to use.

Return Value

Type: String
The snapshot text substring encompassed by this range, using the specified LineTerminator for line ends.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method

TextSnapshotRangeIntersectsWith Method
Overload List
 | Name | Description
Public method | IntersectsWith(Int32) | Returns whether the TextSnapshotRange intersects with the specified offset.
Public method | IntersectsWith(TextRange) | Returns whether the TextSnapshotRange intersects with the specified TextRange.
Public method | IntersectsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (Int32)

TextSnapshotRangeIntersectsWith Method (Int32)
Returns whether the TextSnapshotRange intersects with the specified offset.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    int offset
)
Public Function IntersectsWith (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified offset; otherwise, false.
Remarks
This method returns whether the specified offset borders on or lies within the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (TextRange)

TextSnapshotRangeIntersectsWith Method (TextRange)
Returns whether the TextSnapshotRange intersects with the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextRange range
)
Public Function IntersectsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified TextRange; otherwise, false.
Remarks
This method returns whether the specified TextRange borders on or overlaps the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.IntersectsWith Method (TextSnapshotRange)

TextSnapshotRangeIntersectsWith Method (TextSnapshotRange)
Returns whether the TextSnapshotRange intersects with the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    TextSnapshotRange range
)
Public Function IntersectsWith (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange intersects with the specified TextSnapshotRange; otherwise, false.
Remarks
This method returns whether the specified TextSnapshotRange borders on or overlaps the TextSnapshotRange.
See Also

Reference

TextSnapshotRange Class
IntersectsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.OverlapsWith Method

TextSnapshotRangeOverlapsWith Method
Overload List
 | Name | Description
Public method | OverlapsWith(TextRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.
Public method | OverlapsWith(TextSnapshotRange) | Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.OverlapsWith Method (TextRange)

TextSnapshotRangeOverlapsWith Method (TextRange)
Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextRange range
)
Public Function OverlapsWith (
    range As TextRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange overlaps with, or crosses, the specified TextRange; otherwise, false.
See Also

Reference

TextSnapshotRange Class
OverlapsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.OverlapsWith Method (TextSnapshotRange)

TextSnapshotRangeOverlapsWith Method (TextSnapshotRange)
Returns whether the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    TextSnapshotRange range
)
Public Function OverlapsWith (
    range As TextSnapshotRange
) As Boolean

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Boolean
true if the TextSnapshotRange overlaps with, or crosses, the specified TextSnapshotRange; otherwise, false.
See Also

Reference

TextSnapshotRange Class
OverlapsWith Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.ToString Method

TextSnapshotRangeToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.ToVersionRange Method

TextSnapshotRangeToVersionRange Method
Overload List
 | Name | Description
Public method | ToVersionRange(TextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Public method | ToVersionRange(FuncTextRangeTrackingModes) | Converts this text range into an ITextVersionRange.
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.ToVersionRange Method (TextRangeTrackingModes)

TextSnapshotRangeToVersionRange Method (TextRangeTrackingModes)
Converts this text range into an ITextVersionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextVersionRange ToVersionRange(
    TextRangeTrackingModes trackingModes
)
Public Function ToVersionRange (
    trackingModes As TextRangeTrackingModes
) As ITextVersionRange

Parameters

trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
The ITextVersionRange that was created.
See Also

Reference

TextSnapshotRange Class
ToVersionRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.ToVersionRange Method (Func(TextRangeTrackingModes))

TextSnapshotRangeToVersionRange Method (FuncTextRangeTrackingModes)
Converts this text range into an ITextVersionRange.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextVersionRange ToVersionRange(
    Func<TextRangeTrackingModes> trackingModesFunc
)
Public Function ToVersionRange (
    trackingModesFunc As Func(Of TextRangeTrackingModes)
) As ITextVersionRange

Parameters

trackingModesFunc
Type: SystemFunc TextRangeTrackingModes
A function that dynamically returns a TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: ITextVersionRange
The ITextVersionRange that was created.
See Also

Reference

TextSnapshotRange Class
ToVersionRange Overload
ActiproSoftware.Text Namespace


TextSnapshotRange.TranslateTo Method

TextSnapshotRangeTranslateTo Method
Translates this text range from one ITextSnapshot to another in the same ITextDocument.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange TranslateTo(
    ITextSnapshot toSnapshot,
    TextRangeTrackingModes trackingModes
)
Public Function TranslateTo (
    toSnapshot As ITextSnapshot,
    trackingModes As TextRangeTrackingModes
) As TextSnapshotRange

Parameters

toSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is the target of the translation.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.

Return Value

Type: TextSnapshotRange
The translated TextSnapshotRange.
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange Operators and Type Conversions

TextSnapshotRange Operators and Type Conversions

The TextSnapshotRange type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
(TextSnapshotRange to TextRange) |
Inequality |
LessThan |
Top
See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Equality Operator

TextSnapshotRangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator = (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Equality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.GreaterThan Operator

TextSnapshotRangeGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator >(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator > (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_GreaterThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange Implicit Conversion (TextSnapshotRange to TextRange)

TextSnapshotRange Conversion (TextSnapshotRange to TextRange)

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Implicit(ActiproSoftware.Text.TextSnapshotRange)~ActiproSoftware.Text.TextRange"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator TextRange (
    TextSnapshotRange range
)
Public Shared Widening Operator CType (
    range As TextSnapshotRange
) As TextRange

Parameters

range
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="range"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Implicit(ActiproSoftware.Text.TextSnapshotRange)~ActiproSoftware.Text.TextRange"]

Return Value

Type: TextRange

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Implicit(ActiproSoftware.Text.TextSnapshotRange)~ActiproSoftware.Text.TextRange"]

See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.Inequality Operator

TextSnapshotRangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator <> (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_Inequality(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRange.LessThan Operator

TextSnapshotRangeLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator <(
    TextSnapshotRange left,
    TextSnapshotRange right
)
Public Shared Operator < (
    left As TextSnapshotRange,
    right As TextSnapshotRange
) As Boolean

Parameters

left
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

right
Type: ActiproSoftware.TextTextSnapshotRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.TextSnapshotRange.op_LessThan(ActiproSoftware.Text.TextSnapshotRange,ActiproSoftware.Text.TextSnapshotRange)"]

See Also

Reference

TextSnapshotRange Class
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Class

TextSnapshotRangeEventArgs Class
Event arguments used when a change notification is needed for a TextSnapshotRange.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextTextSnapshotRangeEventArgs
ActiproSoftware.Text.TaggingTagsChangedEventArgs

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextSnapshotRangeEventArgs : EventArgs
Public Class TextSnapshotRangeEventArgs
    Inherits EventArgs

The TextSnapshotRangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextSnapshotRangeEventArgs | Initializes a new instance of the TextSnapshotRangeEventArgs class.
Top
Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Constructor

TextSnapshotRangeEventArgs Constructor
Initializes a new instance of the TextSnapshotRangeEventArgs class.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRangeEventArgs(
    TextSnapshotRange snapshotRange
)
Public Sub New (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange of the change.
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Properties

TextSnapshotRangeEventArgs Properties

The TextSnapshotRangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change.
Top
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs.SnapshotRange Property

TextSnapshotRangeEventArgsSnapshotRange Property
Gets the TextSnapshotRange of the change.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange SnapshotRange { get; }
Public ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange of the change.
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotRangeEventArgs Methods

TextSnapshotRangeEventArgs Methods

The TextSnapshotRangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextSnapshotRangeEventArgs Class
ActiproSoftware.Text Namespace


TextSnapshotReaderOptions Class

TextSnapshotReaderOptions Class
Represents options that are applied to an ITextSnapshotReader.
Inheritance Hierarchy
SystemObject
ActiproSoftware.TextTextSnapshotReaderOptions

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextSnapshotReaderOptions : ITextSnapshotReaderOptions
Public Class TextSnapshotReaderOptions
    Implements ITextSnapshotReaderOptions

The TextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text Namespace


TextSnapshotReaderOptions Properties

TextSnapshotReaderOptions Properties

The TextSnapshotReaderOptions type exposes the following members.

Properties
 | Name | Description
Public property | DefaultTokenLoadBufferLength | Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | InitialTokenLoadBufferLength | Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.
Public property | PrimaryScanDirection | Gets or sets the primary direction in which text scanning will take place with the reader.
Top
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace


TextSnapshotReaderOptions.DefaultTokenLoadBufferLength Property

TextSnapshotReaderOptionsDefaultTokenLoadBufferLength Property
Gets or sets the default number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int DefaultTokenLoadBufferLength { get; set; }
Public Property DefaultTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 700.

Implements

ITextSnapshotReaderOptionsDefaultTokenLoadBufferLength
Remarks
This property governs each load of tokens following the first load.
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace
TextSnapshotReaderOptionsInitialTokenLoadBufferLength


TextSnapshotReaderOptions.InitialTokenLoadBufferLength Property

TextSnapshotReaderOptionsInitialTokenLoadBufferLength Property
Gets or sets the initial number of characters for which to load tokens when retrieving tokens for consumption by the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int InitialTokenLoadBufferLength { get; set; }
Public Property InitialTokenLoadBufferLength As Integer
    Get
    Set

Property Value

Type: Int32
The number of characters for which to load tokens. The default value is 100.

Implements

ITextSnapshotReaderOptionsInitialTokenLoadBufferLength
Remarks
This property only governs the first load of tokens.
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace
TextSnapshotReaderOptionsDefaultTokenLoadBufferLength


TextSnapshotReaderOptions.PrimaryScanDirection Property

TextSnapshotReaderOptionsPrimaryScanDirection Property
Gets or sets the primary direction in which text scanning will take place with the reader.

Namespace: ActiproSoftware.Text
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<TextScanDirection> PrimaryScanDirection { get; set; }
Public Property PrimaryScanDirection As Nullable(Of TextScanDirection)
    Get
    Set

Property Value

Type: Nullable TextScanDirection
The primary direction in which text scanning will take place with the reader. The default value is .

Implements

ITextSnapshotReaderOptionsPrimaryScanDirection
Remarks
A value of means indeterminate. This property is simply used for optimization of the initial token load and in no way restricts which way you are permitted to scan with the reader.
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace


TextSnapshotReaderOptions Methods

TextSnapshotReaderOptions Methods

The TextSnapshotReaderOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextSnapshotReaderOptions Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes Class

WhitespaceTrimModes Class
Specifies the modes by which whitespace is trimmed.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.TextWhitespaceTrimModes

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class WhitespaceTrimModes : Enum
<FlagsAttribute>
Public NotInheritable Class WhitespaceTrimModes
    Inherits Enum

The WhitespaceTrimModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | Whitespace is not auto-trimmed.
 | TrailingOnPaste | Trailing whitespace is trimmed on text pasted into the document.
 | TrailingOnTextReplacement | Trailing whitespace is trimmed when the entire contents of the document are replaced, such as via a document open.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text Namespace


WhitespaceTrimModes Methods

WhitespaceTrimModes Methods

The WhitespaceTrimModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

WhitespaceTrimModes Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes Fields

WhitespaceTrimModes Fields

The WhitespaceTrimModes type exposes the following members.

Fields
 | Name | Description
 | None | Whitespace is not auto-trimmed.
 | TrailingOnPaste | Trailing whitespace is trimmed on text pasted into the document.
 | TrailingOnTextReplacement | Trailing whitespace is trimmed when the entire contents of the document are replaced, such as via a document open.
Public field | value__ |
Top
See Also

Reference

WhitespaceTrimModes Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes.None Field

WhitespaceTrimModesNone Field
Whitespace is not auto-trimmed.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WhitespaceTrimModes None = 0
Public Const None As WhitespaceTrimModes = 0

Field Value

Type: WhitespaceTrimModes
See Also

Reference

WhitespaceTrimModes Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes.TrailingOnPaste Field

WhitespaceTrimModesTrailingOnPaste Field
Trailing whitespace is trimmed on text pasted into the document.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WhitespaceTrimModes TrailingOnPaste = 1
Public Const TrailingOnPaste As WhitespaceTrimModes = 1

Field Value

Type: WhitespaceTrimModes
See Also

Reference

WhitespaceTrimModes Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes.TrailingOnTextReplacement Field

WhitespaceTrimModesTrailingOnTextReplacement Field
Trailing whitespace is trimmed when the entire contents of the document are replaced, such as via a document open.

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WhitespaceTrimModes TrailingOnTextReplacement = 2
Public Const TrailingOnTextReplacement As WhitespaceTrimModes = 2

Field Value

Type: WhitespaceTrimModes
See Also

Reference

WhitespaceTrimModes Class
ActiproSoftware.Text Namespace


WhitespaceTrimModes.value__ Field

WhitespaceTrimModesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.WhitespaceTrimModes.value__"]

Namespace: ActiproSoftware.Text
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

WhitespaceTrimModes Class
ActiproSoftware.Text Namespace


ActiproSoftware.Text.Analysis Namespace

ActiproSoftware.Text.Analysis Namespace
Contains types related to code structural analysis.
Classes
 | Class | Description
Public class | StructureMatchEdges | Specifies which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Interfaces
 | Interface | Description
Public interface | IAutoCorrector | Provides the base requirements for a class that can perform auto-correction.
Public interface | ICodeBlockFinder | Provides the base requirements for a class that can find containing code blocks, generally used for code block selection expansion in an editor.
Public interface | IDelimiterAutoCompleter | Provides the base requirements for a class that can perform delimiter auto-completion.
Public interface | IStructureMatcher | Provides the base requirements for a class that can locate matching structural text ranges for an offset, such as finding matching brackets.
Public interface | IStructureMatchOptions | Provides the base requirements for a class that stores options for a structure match operation.
Public interface | IStructureMatchResult | Provides the base requirements for a class that stores a single result of a structure match operation.
Public interface | IStructureMatchResultCollection | Provides the base requirements for a collection of IStructureMatchResult objects.
Public interface | IStructureMatchResultSet | Provides the base requirements for a class that stores the results of a structure match operation.


IAutoCorrector Interface

IAutoCorrector Interface
Provides the base requirements for a class that can perform auto-correction.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAutoCorrector
Public Interface IAutoCorrector

The IAutoCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IAutoCorrector Methods

IAutoCorrector Methods

The IAutoCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Top
See Also

Reference

IAutoCorrector Interface
ActiproSoftware.Text.Analysis Namespace


IAutoCorrector.AutoCorrect Method

IAutoCorrectorAutoCorrect Method
Auto-corrects over the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AutoCorrect(
    TextSnapshotRange snapshotRange
)
Sub AutoCorrect (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.
See Also

Reference

IAutoCorrector Interface
ActiproSoftware.Text.Analysis Namespace


ICodeBlockFinder Interface

ICodeBlockFinder Interface
Provides the base requirements for a class that can find containing code blocks, generally used for code block selection expansion in an editor.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeBlockFinder
Public Interface ICodeBlockFinder

The ICodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


ICodeBlockFinder Methods

ICodeBlockFinder Methods

The ICodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Top
See Also

Reference

ICodeBlockFinder Interface
ActiproSoftware.Text.Analysis Namespace


ICodeBlockFinder.FindContaining Method

ICodeBlockFinderFindContaining Method
Returns the TextSnapshotRange of the containing code block.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange FindContaining(
    TextSnapshotRange snapshotRange
)
Function FindContaining (
    snapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the containing code block.
See Also

Reference

ICodeBlockFinder Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter Interface

IDelimiterAutoCompleter Interface
Provides the base requirements for a class that can perform delimiter auto-completion.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDelimiterAutoCompleter
Public Interface IDelimiterAutoCompleter

The IDelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter Properties

IDelimiterAutoCompleter Properties

The IDelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Top
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteAngleBraces Property

IDelimiterAutoCompleterCanCompleteAngleBraces Property
Gets or sets whether angle braces can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanCompleteAngleBraces { get; set; }
Property CanCompleteAngleBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if angle braces can be completed; otherwise, false. The default value is false.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteCurlyBraces Property

IDelimiterAutoCompleterCanCompleteCurlyBraces Property
Gets or sets whether curly braces can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanCompleteCurlyBraces { get; set; }
Property CanCompleteCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be completed; otherwise, false. The default value is true.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteParentheses Property

IDelimiterAutoCompleterCanCompleteParentheses Property
Gets or sets whether parentheses can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanCompleteParentheses { get; set; }
Property CanCompleteParentheses As Boolean
    Get
    Set

Property Value

Type: Boolean
true if parentheses can be completed; otherwise, false. The default value is true.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IDelimiterAutoCompleter.CanCompleteSquareBraces Property

IDelimiterAutoCompleterCanCompleteSquareBraces Property
Gets or sets whether square braces can be completed.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanCompleteSquareBraces { get; set; }
Property CanCompleteSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be completed; otherwise, false. The default value is true.
See Also

Reference

IDelimiterAutoCompleter Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatcher Interface

IStructureMatcher Interface
Provides the base requirements for a class that can locate matching structural text ranges for an offset, such as finding matching brackets.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IStructureMatcher
Public Interface IStructureMatcher

The IStructureMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatcher Methods

IStructureMatcher Methods

The IStructureMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Top
See Also

Reference

IStructureMatcher Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatcher.Match Method

IStructureMatcherMatch Method
Attempts to locate structural text, such as bracket pairs, at the specified offset.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IStructureMatchResultSet Match(
    TextSnapshotOffset snapshotOffset,
    IStructureMatchOptions options
)
Function Match (
    snapshotOffset As TextSnapshotOffset,
    options As IStructureMatchOptions
) As IStructureMatchResultSet

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.
options
Type: ActiproSoftware.Text.AnalysisIStructureMatchOptions
The IStructureMatchOptions to use.

Return Value

Type: IStructureMatchResultSet
An IStructureMatchResultSet that contains the results that were found, if any.
Remarks
When the result set is empty, no structural delimiter was next to the specified offset. When the result set contains a single result, a structural delimiter such as a bracket was found next to the specified offset, but no matching structural delimiter was found. The result set may contain multiple entries in cases such as when a language wishes to flag #if...#else...#endif blocks as a structure.
See Also

Reference

IStructureMatcher Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchOptions Interface

IStructureMatchOptions Interface
Provides the base requirements for a class that stores options for a structure match operation.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IStructureMatchOptions
Public Interface IStructureMatchOptions

The IStructureMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchOptions Properties

IStructureMatchOptions Properties

The IStructureMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

IStructureMatchOptions Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchOptions.IsNavigationRequest Property

IStructureMatchOptionsIsNavigationRequest Property
Gets or sets whether the structure match is being performed for a navigation request.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsNavigationRequest { get; set; }
Property IsNavigationRequest As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the structure match is being performed for a navigation request; otherwise, false.
Remarks
When the operating is being performed for a navigation request, the match algorithm may want to be more liberal with its match algorithm.
See Also

Reference

IStructureMatchOptions Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult Interface

IStructureMatchResult Interface
Provides the base requirements for a class that stores a single result of a structure match operation.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IStructureMatchResult : ITextRangeProvider
Public Interface IStructureMatchResult
    Inherits ITextRangeProvider

The IStructureMatchResult type exposes the following members.

Properties
 | Name | Description
Public property | IsSource | Gets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets a TextSnapshotRange indicating the offset range of the match.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult Properties

IStructureMatchResult Properties

The IStructureMatchResult type exposes the following members.

Properties
 | Name | Description
Public property | IsSource | Gets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets a TextSnapshotRange indicating the offset range of the match.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.IsSource Property

IStructureMatchResultIsSource Property
Gets whether this result is the match that occurred from the source offset.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsSource { get; }
ReadOnly Property IsSource As Boolean
    Get

Property Value

Type: Boolean
true if the result is the match that occurred from the source offset; otherwise, false.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.MatchEdges Property

IStructureMatchResultMatchEdges Property
Gets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
StructureMatchEdges MatchEdges { get; }
ReadOnly Property MatchEdges As StructureMatchEdges
    Get

Property Value

Type: StructureMatchEdges
A StructureMatchEdges that specifies the valid edges.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.NavigationSnapshotOffset Property

IStructureMatchResultNavigationSnapshotOffset Property
Gets the TextSnapshotOffset to navigate for the match, if one is available.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> NavigationSnapshotOffset { get; }
ReadOnly Property NavigationSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset to navigate for the match, if one is available.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResult.SnapshotRange Property

IStructureMatchResultSnapshotRange Property
Gets a TextSnapshotRange indicating the offset range of the match.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange indicating the offset range of the match.
See Also

Reference

IStructureMatchResult Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultCollection Interface

IStructureMatchResultCollection Interface
Provides the base requirements for a collection of IStructureMatchResult objects.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IStructureMatchResultCollection : IList<IStructureMatchResult>,
    ICollection<IStructureMatchResult>, IEnumerable<IStructureMatchResult>, IEnumerable
Public Interface IStructureMatchResultCollection
    Inherits IList(Of IStructureMatchResult), ICollection(Of IStructureMatchResult),
    IEnumerable(Of IStructureMatchResult), IEnumerable

The IStructureMatchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IStructureMatchResult .)
Public property | IsReadOnly | (Inherited from ICollection IStructureMatchResult .)
Public property | Item | (Inherited from IList IStructureMatchResult .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IStructureMatchResult .)
Public method | Clear | (Inherited from ICollection IStructureMatchResult .)
Public method | Contains | (Inherited from ICollection IStructureMatchResult .)
Public method | CopyTo | (Inherited from ICollection IStructureMatchResult .)
Public method | GetEnumerator | (Inherited from IEnumerable IStructureMatchResult .)
Public method | IndexOf | (Inherited from IList IStructureMatchResult .)
Public method | Insert | (Inherited from IList IStructureMatchResult .)
Public method | Remove | (Inherited from ICollection IStructureMatchResult .)
Public method | RemoveAt | (Inherited from IList IStructureMatchResult .)
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultCollection Properties

IStructureMatchResultCollection Properties

The IStructureMatchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IStructureMatchResult .)
Public property | IsReadOnly | (Inherited from ICollection IStructureMatchResult .)
Public property | Item | (Inherited from IList IStructureMatchResult .)
Top
See Also

Reference

IStructureMatchResultCollection Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultCollection Methods

IStructureMatchResultCollection Methods

The IStructureMatchResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IStructureMatchResult .)
Public method | Clear | (Inherited from ICollection IStructureMatchResult .)
Public method | Contains | (Inherited from ICollection IStructureMatchResult .)
Public method | CopyTo | (Inherited from ICollection IStructureMatchResult .)
Public method | GetEnumerator | (Inherited from IEnumerable IStructureMatchResult .)
Public method | IndexOf | (Inherited from IList IStructureMatchResult .)
Public method | Insert | (Inherited from IList IStructureMatchResult .)
Public method | Remove | (Inherited from ICollection IStructureMatchResult .)
Public method | RemoveAt | (Inherited from IList IStructureMatchResult .)
Top
See Also

Reference

IStructureMatchResultCollection Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultSet Interface

IStructureMatchResultSet Interface
Provides the base requirements for a class that stores the results of a structure match operation.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IStructureMatchResultSet
Public Interface IStructureMatchResultSet

The IStructureMatchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultSet Properties

IStructureMatchResultSet Properties

The IStructureMatchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

IStructureMatchResultSet Interface
ActiproSoftware.Text.Analysis Namespace


IStructureMatchResultSet.Results Property

IStructureMatchResultSetResults Property
Gets the collection of IStructureMatchResult objects.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IStructureMatchResultCollection Results { get; }
ReadOnly Property Results As IStructureMatchResultCollection
    Get

Property Value

Type: IStructureMatchResultCollection
The collection of IStructureMatchResult objects.
See Also

Reference

IStructureMatchResultSet Interface
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges Class

StructureMatchEdges Class
Specifies which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.AnalysisStructureMatchEdges

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class StructureMatchEdges : Enum
<FlagsAttribute>
Public NotInheritable Class StructureMatchEdges
    Inherits Enum

The StructureMatchEdges type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Both | Both the match result range's start and end offsets can cause the matcher to match the result again.
 | End | Only the end offset of the match result's range can cause the matcher to match the result again.
 | None | Only the inside of the match result range can cause the matcher to match the result again; no outer edges will match.
 | Start | Only the start offset of the match result's range can cause the matcher to match the result again.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges Methods

StructureMatchEdges Methods

The StructureMatchEdges type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges Fields

StructureMatchEdges Fields

The StructureMatchEdges type exposes the following members.

Fields
 | Name | Description
 | Both | Both the match result range's start and end offsets can cause the matcher to match the result again.
 | End | Only the end offset of the match result's range can cause the matcher to match the result again.
 | None | Only the inside of the match result range can cause the matcher to match the result again; no outer edges will match.
 | Start | Only the start offset of the match result's range can cause the matcher to match the result again.
Public field | value__ |
Top
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges.Both Field

StructureMatchEdgesBoth Field
Both the match result range's start and end offsets can cause the matcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const StructureMatchEdges Both = 3
Public Const Both As StructureMatchEdges = 3

Field Value

Type: StructureMatchEdges
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges.End Field

StructureMatchEdgesEnd Field
Only the end offset of the match result's range can cause the matcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const StructureMatchEdges End = 2
Public Const End As StructureMatchEdges = 2

Field Value

Type: StructureMatchEdges
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges.None Field

StructureMatchEdgesNone Field
Only the inside of the match result range can cause the matcher to match the result again; no outer edges will match.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const StructureMatchEdges None = 0
Public Const None As StructureMatchEdges = 0

Field Value

Type: StructureMatchEdges
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges.Start Field

StructureMatchEdgesStart Field
Only the start offset of the match result's range can cause the matcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const StructureMatchEdges Start = 1
Public Const Start As StructureMatchEdges = 1

Field Value

Type: StructureMatchEdges
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


StructureMatchEdges.value__ Field

StructureMatchEdgesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Analysis.StructureMatchEdges.value__"]

Namespace: ActiproSoftware.Text.Analysis
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

StructureMatchEdges Class
ActiproSoftware.Text.Analysis Namespace


ActiproSoftware.Text.Analysis.Implementation Namespace

ActiproSoftware.Text.Analysis.Implementation Namespace
Contains the implementation types related to code structural analysis.
Classes
 | Class | Description
Public class | AutoCaseCorrector | Provides a default implementation of an IAutoCorrector that examines tokens for case-insensitive matches and auto-corrects them to proper case.
Public class | AutoCorrectorBase | Provides an abstract base class for an IAutoCorrector whose AutoCorrect(TextSnapshotRange) method is called at appropriate times following text changes or caret moves.
Public class | DelimiterAutoCompleter | Provides a default implementation for an IDelimiterAutoCompleter that can perform delimiter auto-completion.
Public class | LLParseDataCodeBlockFinder | Represents a default implementation of an ICodeBlockFinder that is capable of returning containing code blocks based on AST parse data from an ILLParser.
Public class | StructureMatcher | Represents a default implementation of an IStructureMatcher that is capable of matching common bracket delimiters.
Public class | StructureMatchOptions | Represents options for a structure match operation.
Public class | StructureMatchResult | Stores a single result of a structure match operation.
Public class | StructureMatchResultCollection | Represents a collection of an IStructureMatchResult objects.
Public class | StructureMatchResultSet | Stores the results of a structure match operation.


AutoCaseCorrector Class

AutoCaseCorrector Class
Provides a default implementation of an IAutoCorrector that examines tokens for case-insensitive matches and auto-corrects them to proper case.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationAutoCorrectorBase
ActiproSoftware.Text.Analysis.ImplementationAutoCaseCorrector
ActiproSoftware.Text.Languages.VB.ImplementationVBAutoCaseCorrector

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AutoCaseCorrector : AutoCorrectorBase
Public Class AutoCaseCorrector
    Inherits AutoCorrectorBase

The AutoCaseCorrector type exposes the following members.

Constructors
 | Name | Description
Public method | AutoCaseCorrector | Initializes a new instance of the AutoCaseCorrector class
Top
Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Overrides AutoCorrectorBaseAutoCorrect(TextSnapshotRange).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IAutoCorrector interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector Constructor

AutoCaseCorrector Constructor
Initializes a new instance of the AutoCaseCorrector class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutoCaseCorrector()
Public Sub New
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector Methods

AutoCaseCorrector Methods

The AutoCaseCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Overrides AutoCorrectorBaseAutoCorrect(TextSnapshotRange).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector.AutoCorrect Method

AutoCaseCorrectorAutoCorrect Method
Auto-corrects over the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void AutoCorrect(
    TextSnapshotRange snapshotRange
)
Public Overrides Sub AutoCorrect (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Implements

IAutoCorrectorAutoCorrect(TextSnapshotRange)
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCaseCorrector.GetCaseCorrectText Method

AutoCaseCorrectorGetCaseCorrectText Method
Returns the case-corrected text for the specified IToken.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string GetCaseCorrectText(
    ITextSnapshot snapshot,
    IToken token
)
Protected Overridable Function GetCaseCorrectText (
    snapshot As ITextSnapshot,
    token As IToken
) As String

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The source ITextSnapshot.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The case-corrected text for the specified IToken. Returns if no case-correction is required.
See Also

Reference

AutoCaseCorrector Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase Class

AutoCorrectorBase Class
Provides an abstract base class for an IAutoCorrector whose AutoCorrect(TextSnapshotRange) method is called at appropriate times following text changes or caret moves.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationAutoCorrectorBase
ActiproSoftware.Text.Analysis.ImplementationAutoCaseCorrector

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class AutoCorrectorBase : IAutoCorrector,
    IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink
Public MustInherit Class AutoCorrectorBase
    Implements IAutoCorrector, IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink

The AutoCorrectorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AutoCorrectorBase | Initializes a new instance of the AutoCorrectorBase class
Top
Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IAutoCorrector interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase Constructor

AutoCorrectorBase Constructor
Initializes a new instance of the AutoCorrectorBase class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AutoCorrectorBase()
Protected Sub New
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase Methods

AutoCorrectorBase Methods

The AutoCorrectorBase type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.AutoCorrect Method

AutoCorrectorBaseAutoCorrect Method
Auto-corrects over the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void AutoCorrect(
    TextSnapshotRange snapshotRange
)
Public MustOverride Sub AutoCorrect (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Implements

IAutoCorrectorAutoCorrect(TextSnapshotRange)
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.OnDocumentTextChanged Method

AutoCorrectorBaseOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.OnDocumentTextChanging Method

AutoCorrectorBaseOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


AutoCorrectorBase.OnViewSelectionChanged Method

AutoCorrectorBaseOnViewSelectionChanged Method
Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

AutoCorrectorBase Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Class

DelimiterAutoCompleter Class
Provides a default implementation for an IDelimiterAutoCompleter that can perform delimiter auto-completion.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationDelimiterAutoCompleter

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DelimiterAutoCompleter : IDelimiterAutoCompleter,
    IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink, IEditorViewTextInputEventSink
Public Class DelimiterAutoCompleter
    Implements IDelimiterAutoCompleter, IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink, IEditorViewTextInputEventSink

The DelimiterAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | DelimiterAutoCompleter | Initializes a new instance of the DelimiterAutoCompleter class.
Top
Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion.
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset.
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView.
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDelimiterAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Constructor

DelimiterAutoCompleter Constructor
Initializes a new instance of the DelimiterAutoCompleter class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DelimiterAutoCompleter()
Public Sub New
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Properties

DelimiterAutoCompleter Properties

The DelimiterAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | CanCompleteAngleBraces | Gets or sets whether angle braces can be completed.
Public property | CanCompleteCurlyBraces | Gets or sets whether curly braces can be completed.
Public property | CanCompleteDoubleQuotes | Gets or sets whether double quotes can be completed.
Public property | CanCompleteParentheses | Gets or sets whether parentheses can be completed.
Public property | CanCompleteSingleQuotes | Gets or sets whether single quotes can be completed.
Public property | CanCompleteSquareBraces | Gets or sets whether square braces can be completed.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion.
Public property | OpenDoubleQuoteTokenId | Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.
Public property | OpenSingleQuoteTokenId | Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion.
Top
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteAngleBraces Property

DelimiterAutoCompleterCanCompleteAngleBraces Property
Gets or sets whether angle braces can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompleteAngleBraces { get; set; }
Public Property CanCompleteAngleBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if angle braces can be completed; otherwise, false. The default value is false.

Implements

IDelimiterAutoCompleterCanCompleteAngleBraces
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteCurlyBraces Property

DelimiterAutoCompleterCanCompleteCurlyBraces Property
Gets or sets whether curly braces can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompleteCurlyBraces { get; set; }
Public Property CanCompleteCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be completed; otherwise, false. The default value is true.

Implements

IDelimiterAutoCompleterCanCompleteCurlyBraces
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteDoubleQuotes Property

DelimiterAutoCompleterCanCompleteDoubleQuotes Property
Gets or sets whether double quotes can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompleteDoubleQuotes { get; set; }
Public Property CanCompleteDoubleQuotes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if double quotes can be completed; otherwise, false. The default value is true.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteParentheses Property

DelimiterAutoCompleterCanCompleteParentheses Property
Gets or sets whether parentheses can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompleteParentheses { get; set; }
Public Property CanCompleteParentheses As Boolean
    Get
    Set

Property Value

Type: Boolean
true if parentheses can be completed; otherwise, false. The default value is true.

Implements

IDelimiterAutoCompleterCanCompleteParentheses
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteSingleQuotes Property

DelimiterAutoCompleterCanCompleteSingleQuotes Property
Gets or sets whether single quotes can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompleteSingleQuotes { get; set; }
Public Property CanCompleteSingleQuotes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if single quotes can be completed; otherwise, false. The default value is false.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.CanCompleteSquareBraces Property

DelimiterAutoCompleterCanCompleteSquareBraces Property
Gets or sets whether square braces can be completed.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompleteSquareBraces { get; set; }
Public Property CanCompleteSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be completed; otherwise, false. The default value is true.

Implements

IDelimiterAutoCompleterCanCompleteSquareBraces
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenAngleBraceTokenId Property

DelimiterAutoCompleterOpenAngleBraceTokenId Property
Gets the optional token ID value used to ensure that an open angle brace character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenAngleBraceTokenId { get; set; }
Public Property OpenAngleBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open angle brace character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for angle braces.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenCurlyBraceTokenId Property

DelimiterAutoCompleterOpenCurlyBraceTokenId Property
Gets the optional token ID value used to ensure that an open curly brace character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenCurlyBraceTokenId { get; set; }
Public Property OpenCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open curly brace character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenDoubleQuoteTokenId Property

DelimiterAutoCompleterOpenDoubleQuoteTokenId Property
Gets the optional token ID value used to ensure that an open double quote character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenDoubleQuoteTokenId { get; set; }
Public Property OpenDoubleQuoteTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open double quote character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for double quotes.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenParenthesisTokenId Property

DelimiterAutoCompleterOpenParenthesisTokenId Property
Gets the optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenParenthesisTokenId { get; set; }
Public Property OpenParenthesisTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open parenthesis character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for parentheses.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenSingleQuoteTokenId Property

DelimiterAutoCompleterOpenSingleQuoteTokenId Property
Gets the optional token ID value used to ensure that an open single quote character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSingleQuoteTokenId { get; set; }
Public Property OpenSingleQuoteTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open single quote character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for single quotes.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OpenSquareBraceTokenId Property

DelimiterAutoCompleterOpenSquareBraceTokenId Property
Gets the optional token ID value used to ensure that an open square brace character is valid for auto-completion.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSquareBraceTokenId { get; set; }
Public Property OpenSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open square brace character is valid for auto-completion.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter Methods

DelimiterAutoCompleter Methods

The DelimiterAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidForEndDelimiterAutoComplete | Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset.
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Protected method | OnViewTextInput | Occurs before text is input to the specified IEditorView.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.IsValidForEndDelimiterAutoComplete Method

DelimiterAutoCompleterIsValidForEndDelimiterAutoComplete Method
Returns whether an end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsValidForEndDelimiterAutoComplete(
    TextSnapshotOffset snapshotOffset,
    char endDelimiter
)
Protected Overridable Function IsValidForEndDelimiterAutoComplete (
    snapshotOffset As TextSnapshotOffset,
    endDelimiter As Char
) As Boolean

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset at which to possibly auto-insert the delimiter.
endDelimiter
Type: SystemChar
The end delimiter.

Return Value

Type: Boolean
true if the end delimiter is valid to be auto-inserted at the specified TextSnapshotOffset; otherwise, false.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.IsValidStartDelimiter Method

DelimiterAutoCompleterIsValidStartDelimiter Method
Returns whether an IToken represents the specified start delimiter.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsValidStartDelimiter(
    IToken token,
    char startDelimiter
)
Protected Overridable Function IsValidStartDelimiter (
    token As IToken,
    startDelimiter As Char
) As Boolean

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.
startDelimiter
Type: SystemChar
The start delimiter.

Return Value

Type: Boolean
true if the IToken represents the specified start delimiter; otherwise, false.
Remarks
The default implementation of this method compares the token ID to the IDs specified in the OpenAngleBraceTokenId, OpenCurlyBraceTokenId, OpenParenthesisTokenId, and OpenSquareBraceTokenId properties. This method is called by the default implementation of the IsValidForEndDelimiterAutoComplete(TextSnapshotOffset, Char) method.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnDocumentTextChanged Method

DelimiterAutoCompleterOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnDocumentTextChanging Method

DelimiterAutoCompleterOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnViewSelectionChanged Method

DelimiterAutoCompleterOnViewSelectionChanged Method
Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


DelimiterAutoCompleter.OnViewTextInput Method

DelimiterAutoCompleterOnViewTextInput Method
Occurs before text is input to the specified IEditorView.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewTextInput(
    IEditorView view,
    TextCompositionEventArgs e
)
Protected Overridable Sub OnViewTextInput (
    view As IEditorView,
    e As TextCompositionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextCompositionEventArgs
The TextCompositionEventArgs that contains the event data.
See Also

Reference

DelimiterAutoCompleter Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Class

LLParseDataCodeBlockFinder Class
Represents a default implementation of an ICodeBlockFinder that is capable of returning containing code blocks based on AST parse data from an ILLParser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptCodeBlockFinder
ActiproSoftware.Text.Languages.Python.ImplementationPythonCodeBlockFinder
ActiproSoftware.Text.Languages.Xml.ImplementationXmlCodeBlockFinder

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LLParseDataCodeBlockFinder : ICodeBlockFinder
Public Class LLParseDataCodeBlockFinder
    Implements ICodeBlockFinder

The LLParseDataCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | LLParseDataCodeBlockFinder | Initializes a new instance of the LLParseDataCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ICodeBlockFinder interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Constructor

LLParseDataCodeBlockFinder Constructor
Initializes a new instance of the LLParseDataCodeBlockFinder class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LLParseDataCodeBlockFinder()
Public Sub New
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Properties

LLParseDataCodeBlockFinder Properties

The LLParseDataCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid.
Top
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.Filter Property

LLParseDataCodeBlockFinderFilter Property
Gets or sets the optional callback used to determine if a potential IAstNode result is valid.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Predicate<IAstNode> Filter { get; set; }
Public Property Filter As Predicate(Of IAstNode)
    Get
    Set

Property Value

Type: Predicate IAstNode
The optional callback used to determine if a potential IAstNode result is valid.
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder Methods

LLParseDataCodeBlockFinder Methods

The LLParseDataCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.FindContaining Method

LLParseDataCodeBlockFinderFindContaining Method
Returns the TextSnapshotRange of the containing code block.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TextSnapshotRange FindContaining(
    TextSnapshotRange snapshotRange
)
Public Overridable Function FindContaining (
    snapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the containing code block.

Implements

ICodeBlockFinderFindContaining(TextSnapshotRange)
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.GetSnapshotRange Method

LLParseDataCodeBlockFinderGetSnapshotRange Method
Returns a TextSnapshotRange for the specified IAstNode.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotRange GetSnapshotRange(
    TextSnapshotRange searchSnapshotRange,
    IAstNode astNode,
    TextSnapshotRange astNodeSnapshotRange
)
Protected Overridable Function GetSnapshotRange (
    searchSnapshotRange As TextSnapshotRange,
    astNode As IAstNode,
    astNodeSnapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

searchSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode that was found to contain the search snapshot range.
astNodeSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The full snapshot range of the IAstNode.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange for the specified IAstNode.
Remarks
The default implementation of this method returns the astNodeSnapshotRange value. This method can optionally be used to adjust the snapshot range for an AST node as necessary.
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


LLParseDataCodeBlockFinder.TranslateToParseDataSnapshot Method

LLParseDataCodeBlockFinderTranslateToParseDataSnapshot Method
Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    ILLParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As ILLParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParserILLParseData
The ILLParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

LLParseDataCodeBlockFinder Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Class

StructureMatcher Class
Represents a default implementation of an IStructureMatcher that is capable of matching common bracket delimiters.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatcher

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureMatcher : IStructureMatcher
Public Class StructureMatcher
    Implements IStructureMatcher

The StructureMatcher type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatcher | Initializes a new instance of the StructureMatcher class.
Top
Properties
 | Name | Description
Public property | CanMatchAngleBraces | Gets or sets whether angle braces can be matched.
Public property | CanMatchCurlyBraces | Gets or sets whether curly braces can be matched.
Public property | CanMatchParentheses | Gets or sets whether parentheses can be matched.
Public property | CanMatchSquareBraces | Gets or sets whether square braces can be matched.
Public property | CloseAngleBraceTokenId | Gets the optional token ID value used to ensure that a close angle brace character is valid for structure matching.
Public property | CloseCurlyBraceTokenId | Gets the optional token ID value used to ensure that a close curly brace character is valid for structure matching.
Public property | CloseParenthesisTokenId | Gets the optional token ID value used to ensure that a close parenthesis character is valid for structure matching.
Public property | CloseSquareBraceTokenId | Gets the optional token ID value used to ensure that a close square brace character is valid for structure matching.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for structure matching.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for structure matching.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for structure matching.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for structure matching.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IStructureMatcher interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Constructor

StructureMatcher Constructor
Initializes a new instance of the StructureMatcher class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureMatcher()
Public Sub New
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Properties

StructureMatcher Properties

The StructureMatcher type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchAngleBraces | Gets or sets whether angle braces can be matched.
Public property | CanMatchCurlyBraces | Gets or sets whether curly braces can be matched.
Public property | CanMatchParentheses | Gets or sets whether parentheses can be matched.
Public property | CanMatchSquareBraces | Gets or sets whether square braces can be matched.
Public property | CloseAngleBraceTokenId | Gets the optional token ID value used to ensure that a close angle brace character is valid for structure matching.
Public property | CloseCurlyBraceTokenId | Gets the optional token ID value used to ensure that a close curly brace character is valid for structure matching.
Public property | CloseParenthesisTokenId | Gets the optional token ID value used to ensure that a close parenthesis character is valid for structure matching.
Public property | CloseSquareBraceTokenId | Gets the optional token ID value used to ensure that a close square brace character is valid for structure matching.
Public property | OpenAngleBraceTokenId | Gets the optional token ID value used to ensure that an open angle brace character is valid for structure matching.
Public property | OpenCurlyBraceTokenId | Gets the optional token ID value used to ensure that an open curly brace character is valid for structure matching.
Public property | OpenParenthesisTokenId | Gets the optional token ID value used to ensure that an open parenthesis character is valid for structure matching.
Public property | OpenSquareBraceTokenId | Gets the optional token ID value used to ensure that an open square brace character is valid for structure matching.
Top
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchAngleBraces Property

StructureMatcherCanMatchAngleBraces Property
Gets or sets whether angle braces can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMatchAngleBraces { get; set; }
Public Property CanMatchAngleBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if angle braces can be matched; otherwise, false. The default value is false.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchCurlyBraces Property

StructureMatcherCanMatchCurlyBraces Property
Gets or sets whether curly braces can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMatchCurlyBraces { get; set; }
Public Property CanMatchCurlyBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if curly braces can be matched; otherwise, false. The default value is true.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchParentheses Property

StructureMatcherCanMatchParentheses Property
Gets or sets whether parentheses can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMatchParentheses { get; set; }
Public Property CanMatchParentheses As Boolean
    Get
    Set

Property Value

Type: Boolean
true if parentheses can be matched; otherwise, false. The default value is true.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CanMatchSquareBraces Property

StructureMatcherCanMatchSquareBraces Property
Gets or sets whether square braces can be matched.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMatchSquareBraces { get; set; }
Public Property CanMatchSquareBraces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if square braces can be matched; otherwise, false. The default value is true.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseAngleBraceTokenId Property

StructureMatcherCloseAngleBraceTokenId Property
Gets the optional token ID value used to ensure that a close angle brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CloseAngleBraceTokenId { get; set; }
Public Property CloseAngleBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close angle brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for angle braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseCurlyBraceTokenId Property

StructureMatcherCloseCurlyBraceTokenId Property
Gets the optional token ID value used to ensure that a close curly brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CloseCurlyBraceTokenId { get; set; }
Public Property CloseCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close curly brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseParenthesisTokenId Property

StructureMatcherCloseParenthesisTokenId Property
Gets the optional token ID value used to ensure that a close parenthesis character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CloseParenthesisTokenId { get; set; }
Public Property CloseParenthesisTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close parenthesis character is valid for structure matching.
Remarks
Leave the value if token validation is not required for parentheses.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.CloseSquareBraceTokenId Property

StructureMatcherCloseSquareBraceTokenId Property
Gets the optional token ID value used to ensure that a close square brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CloseSquareBraceTokenId { get; set; }
Public Property CloseSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that a close square brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenAngleBraceTokenId Property

StructureMatcherOpenAngleBraceTokenId Property
Gets the optional token ID value used to ensure that an open angle brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenAngleBraceTokenId { get; set; }
Public Property OpenAngleBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open angle brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for angle braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenCurlyBraceTokenId Property

StructureMatcherOpenCurlyBraceTokenId Property
Gets the optional token ID value used to ensure that an open curly brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenCurlyBraceTokenId { get; set; }
Public Property OpenCurlyBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open curly brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for curly braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenParenthesisTokenId Property

StructureMatcherOpenParenthesisTokenId Property
Gets the optional token ID value used to ensure that an open parenthesis character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenParenthesisTokenId { get; set; }
Public Property OpenParenthesisTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open parenthesis character is valid for structure matching.
Remarks
Leave the value if token validation is not required for parentheses.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.OpenSquareBraceTokenId Property

StructureMatcherOpenSquareBraceTokenId Property
Gets the optional token ID value used to ensure that an open square brace character is valid for structure matching.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> OpenSquareBraceTokenId { get; set; }
Public Property OpenSquareBraceTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The optional token ID value used to ensure that an open square brace character is valid for structure matching.
Remarks
Leave the value if token validation is not required for square braces.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher Methods

StructureMatcher Methods

The StructureMatcher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Match | Attempts to locate structural text, such as bracket pairs, at the specified offset.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatcher.Match Method

StructureMatcherMatch Method
Attempts to locate structural text, such as bracket pairs, at the specified offset.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IStructureMatchResultSet Match(
    TextSnapshotOffset snapshotOffset,
    IStructureMatchOptions options
)
Public Overridable Function Match (
    snapshotOffset As TextSnapshotOffset,
    options As IStructureMatchOptions
) As IStructureMatchResultSet

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.
options
Type: ActiproSoftware.Text.AnalysisIStructureMatchOptions
The IStructureMatchOptions to use.

Return Value

Type: IStructureMatchResultSet
An IStructureMatchResultSet that contains the results that were found, if any.

Implements

IStructureMatcherMatch(TextSnapshotOffset, IStructureMatchOptions)
Remarks
When the result set is empty, no structural delimiter was next to the specified offset. When the result set contains a single result, a structural delimiter such as a bracket was found next to the specified offset, but no matching structural delimiter was found. The result set may contain multiple entries in cases such as when a language wishes to flag #if...#else...#endif blocks as a structure.
See Also

Reference

StructureMatcher Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Class

StructureMatchOptions Class
Represents options for a structure match operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatchOptions

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureMatchOptions : IStructureMatchOptions
Public Class StructureMatchOptions
    Implements IStructureMatchOptions

The StructureMatchOptions type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchOptions | Initializes a new instance of the StructureMatchOptions class
Top
Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Constructor

StructureMatchOptions Constructor
Initializes a new instance of the StructureMatchOptions class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureMatchOptions()
Public Sub New
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Properties

StructureMatchOptions Properties

The StructureMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsNavigationRequest | Gets or sets whether the structure match is being performed for a navigation request.
Top
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions.IsNavigationRequest Property

StructureMatchOptionsIsNavigationRequest Property
Gets or sets whether the structure match is being performed for a navigation request.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNavigationRequest { get; set; }
Public Property IsNavigationRequest As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the structure match is being performed for a navigation request; otherwise, false.

Implements

IStructureMatchOptionsIsNavigationRequest
Remarks
When the operating is being performed for a navigation request, the match algorithm may want to be more liberal with its match algorithm.
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchOptions Methods

StructureMatchOptions Methods

The StructureMatchOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StructureMatchOptions Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Class

StructureMatchResult Class
Stores a single result of a structure match operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResult

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureMatchResult : IStructureMatchResult,
    ITextRangeProvider
Public Class StructureMatchResult
    Implements IStructureMatchResult, ITextRangeProvider

The StructureMatchResult type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchResult | Initializes a new instance of the StructureMatchResult class.
Top
Properties
 | Name | Description
Public property | IsSource | Gets or sets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets or sets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets or sets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets or sets a TextSnapshotRange indicating the offset range of the match.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Constructor

StructureMatchResult Constructor
Initializes a new instance of the StructureMatchResult class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureMatchResult(
    TextSnapshotRange snapshotRange
)
Public Sub New (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range of the match.
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Properties

StructureMatchResult Properties

The StructureMatchResult type exposes the following members.

Properties
 | Name | Description
Public property | IsSource | Gets or sets whether this result is the match that occurred from the source offset.
Public property | MatchEdges | Gets or sets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.
Public property | NavigationSnapshotOffset | Gets or sets the TextSnapshotOffset to navigate for the match, if one is available.
Public property | SnapshotRange | Gets or sets a TextSnapshotRange indicating the offset range of the match.
Top
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.IsSource Property

StructureMatchResultIsSource Property
Gets or sets whether this result is the match that occurred from the source offset.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSource { get; set; }
Public Property IsSource As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the result is the match that occurred from the source offset; otherwise, false.

Implements

IStructureMatchResultIsSource
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.MatchEdges Property

StructureMatchResultMatchEdges Property
Gets or sets which edges of a IStructureMatchResult's range can cause the IStructureMatcher to match the result again.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureMatchEdges MatchEdges { get; set; }
Public Property MatchEdges As StructureMatchEdges
    Get
    Set

Property Value

Type: StructureMatchEdges
A StructureMatchEdges that specifies the valid edges.

Implements

IStructureMatchResultMatchEdges
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.NavigationSnapshotOffset Property

StructureMatchResultNavigationSnapshotOffset Property
Gets or sets the TextSnapshotOffset to navigate for the match, if one is available.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<TextSnapshotOffset> NavigationSnapshotOffset { get; set; }
Public Property NavigationSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get
    Set

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset to navigate for the match, if one is available.

Implements

IStructureMatchResultNavigationSnapshotOffset
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult.SnapshotRange Property

StructureMatchResultSnapshotRange Property
Gets or sets a TextSnapshotRange indicating the offset range of the match.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange SnapshotRange { get; set; }
Public Property SnapshotRange As TextSnapshotRange
    Get
    Set

Property Value

Type: TextSnapshotRange
A TextSnapshotRange indicating the offset range of the match.

Implements

IStructureMatchResultSnapshotRange
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResult Methods

StructureMatchResult Methods

The StructureMatchResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StructureMatchResult Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Class

StructureMatchResultCollection Class
Represents a collection of an IStructureMatchResult objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IStructureMatchResult
ActiproSoftware.Text.UtilitySimpleObservableCollection IStructureMatchResult
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResultCollection

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureMatchResultCollection : SimpleObservableCollection<IStructureMatchResult>,
    IStructureMatchResultCollection, IList<IStructureMatchResult>, ICollection<IStructureMatchResult>,
    IEnumerable<IStructureMatchResult>, IEnumerable
Public Class StructureMatchResultCollection
    Inherits SimpleObservableCollection(Of IStructureMatchResult)
    Implements IStructureMatchResultCollection, IList(Of IStructureMatchResult),
    ICollection(Of IStructureMatchResult), IEnumerable(Of IStructureMatchResult), IEnumerable

The StructureMatchResultCollection type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchResultCollection | Initializes a new instance of the StructureMatchResultCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection IStructureMatchResult .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Overrides SimpleObservableCollectionTIsReadOnly.)
Public property | Item | (Inherited from Collection IStructureMatchResult .)
Protected property | Items | (Inherited from Collection IStructureMatchResult .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection IStructureMatchResult .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection IStructureMatchResult .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | (Inherited from Collection IStructureMatchResult .)
Public method | CopyTo | (Inherited from Collection IStructureMatchResult .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection IStructureMatchResult .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection IStructureMatchResult .)
Public method | Insert | (Inherited from Collection IStructureMatchResult .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | (Inherited from Collection IStructureMatchResult .)
Public method | RemoveAt | (Inherited from Collection IStructureMatchResult .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Constructor

StructureMatchResultCollection Constructor
Initializes a new instance of the StructureMatchResultCollection class

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureMatchResultCollection()
Public Sub New
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Properties

StructureMatchResultCollection Properties

The StructureMatchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection IStructureMatchResult .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Overrides SimpleObservableCollectionTIsReadOnly.)
Public property | Item | (Inherited from Collection IStructureMatchResult .)
Protected property | Items | (Inherited from Collection IStructureMatchResult .)
Top
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection.IsReadOnly Property

StructureMatchResultCollectionIsReadOnly Property
Gets whether the collection is allowed to be modified.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is allowed to be modified; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Methods

StructureMatchResultCollection Methods

The StructureMatchResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection IStructureMatchResult .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection IStructureMatchResult .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | (Inherited from Collection IStructureMatchResult .)
Public method | CopyTo | (Inherited from Collection IStructureMatchResult .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection IStructureMatchResult .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection IStructureMatchResult .)
Public method | Insert | (Inherited from Collection IStructureMatchResult .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | (Inherited from Collection IStructureMatchResult .)
Public method | RemoveAt | (Inherited from Collection IStructureMatchResult .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultCollection Events

StructureMatchResultCollection Events

The StructureMatchResultCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

StructureMatchResultCollection Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Class

StructureMatchResultSet Class
Stores the results of a structure match operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResultSet

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureMatchResultSet : IStructureMatchResultSet
Public Class StructureMatchResultSet
    Implements IStructureMatchResultSet

The StructureMatchResultSet type exposes the following members.

Constructors
 | Name | Description
Public method | StructureMatchResultSet | Initializes a new instance of the StructureMatchResultSet class.
Top
Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Constructor

StructureMatchResultSet Constructor
Initializes a new instance of the StructureMatchResultSet class.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureMatchResultSet(
    IStructureMatchResultCollection results
)
Public Sub New (
    results As IStructureMatchResultCollection
)

Parameters

results
Type: ActiproSoftware.Text.AnalysisIStructureMatchResultCollection
The collection of IStructureMatchResult objects.
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Properties

StructureMatchResultSet Properties

The StructureMatchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of IStructureMatchResult objects.
Top
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet.Results Property

StructureMatchResultSetResults Property
Gets the collection of IStructureMatchResult objects.

Namespace: ActiproSoftware.Text.Analysis.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IStructureMatchResultCollection Results { get; }
Public ReadOnly Property Results As IStructureMatchResultCollection
    Get

Property Value

Type: IStructureMatchResultCollection
The collection of IStructureMatchResult objects.

Implements

IStructureMatchResultSetResults
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


StructureMatchResultSet Methods

StructureMatchResultSet Methods

The StructureMatchResultSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StructureMatchResultSet Class
ActiproSoftware.Text.Analysis.Implementation Namespace


ActiproSoftware.Text.Exporters Namespace

ActiproSoftware.Text.Exporters Namespace
Contains types related to the export of text to other markup formats..
Classes
 | Class | Description
Public class | TextExporterFactory | Provides access to the built-in ITextExporter instances, that export text to other formats such as HTML or RTF markup.
Interfaces
 | Interface | Description
Public interface | IHtmlTextExporter | Provides the base requirements for a class that can export text to HTML markup.
Public interface | IRtfTextExporter | Provides the base requirements for a class that can export text to RTF markup.
Public interface | ITextExporter | Provides the base requirements for a class that can export text to some other format, such as HTML or RTF markup.


IHtmlTextExporter Interface

IHtmlTextExporter Interface
Provides the base requirements for a class that can export text to HTML markup.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IHtmlTextExporter : ITextExporter
Public Interface IHtmlTextExporter
    Inherits ITextExporter

The IHtmlTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Public property | Title | Gets or sets the title for the exported HTML.
Top
Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


IHtmlTextExporter Properties

IHtmlTextExporter Properties

The IHtmlTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Public property | Title | Gets or sets the title for the exported HTML.
Top
See Also

Reference

IHtmlTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IHtmlTextExporter.Title Property

IHtmlTextExporterTitle Property
Gets or sets the title for the exported HTML.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Title { get; set; }
Property Title As String
    Get
    Set

Property Value

Type: String
The title for the exported HTML.
See Also

Reference

IHtmlTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IHtmlTextExporter Methods

IHtmlTextExporter Methods

The IHtmlTextExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

IHtmlTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter Interface

IRtfTextExporter Interface
Provides the base requirements for a class that can export text to RTF markup.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IRtfTextExporter : ITextExporter
Public Interface IRtfTextExporter
    Inherits ITextExporter

The IRtfTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | FontFamily | Gets or sets the font family name to use for the RTF.
Public property | FontSizeInPoints | Gets or sets the font size in points to use for the RTF.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Top
Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter Properties

IRtfTextExporter Properties

The IRtfTextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates. (Inherited from ITextExporter.)
Public property | FontFamily | Gets or sets the font family name to use for the RTF.
Public property | FontSizeInPoints | Gets or sets the font size in points to use for the RTF.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use. (Inherited from ITextExporter.)
Top
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter.FontFamily Property

IRtfTextExporterFontFamily Property
Gets or sets the font family name to use for the RTF.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FontFamily { get; set; }
Property FontFamily As String
    Get
    Set

Property Value

Type: String
The font family name to use for the RTF.
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter.FontSizeInPoints Property

IRtfTextExporterFontSizeInPoints Property
Gets or sets the font size in points to use for the RTF.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double FontSizeInPoints { get; set; }
Property FontSizeInPoints As Double
    Get
    Set

Property Value

Type: Double
The font size in points to use for the RTF.
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


IRtfTextExporter Methods

IRtfTextExporter Methods

The IRtfTextExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format. (Inherited from ITextExporter.)
Top
See Also

Reference

IRtfTextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter Interface

ITextExporter Interface
Provides the base requirements for a class that can export text to some other format, such as HTML or RTF markup.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextExporter
Public Interface ITextExporter

The ITextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use.
Top
Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format.
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


ITextExporter Properties

ITextExporter Properties

The ITextExporter type exposes the following members.

Properties
 | Name | Description
Public property | DataFormat | Gets a string that describes the data format this exporter creates.
Public property | LineTerminator | Gets or sets the LineTerminator specifying the type of line terminators to use.
Top
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter.DataFormat Property

ITextExporterDataFormat Property
Gets a string that describes the data format this exporter creates.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DataFormat { get; }
ReadOnly Property DataFormat As String
    Get

Property Value

Type: String
A string that describes the data format this exporter creates.
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter.LineTerminator Property

ITextExporterLineTerminator Property
Gets or sets the LineTerminator specifying the type of line terminators to use.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
LineTerminator LineTerminator { get; set; }
Property LineTerminator As LineTerminator
    Get
    Set

Property Value

Type: LineTerminator
The LineTerminator specifying the type of line terminators to use.
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter Methods

ITextExporter Methods

The ITextExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Exports the specified ITextSnapshot ranges to another text format.
Top
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


ITextExporter.Export Method

ITextExporterExport Method
Exports the specified ITextSnapshot ranges to another text format.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Export(
    ITextSnapshot snapshot,
    ICollection<TextRange> textRanges
)
Function Export (
    snapshot As ITextSnapshot,
    textRanges As ICollection(Of TextRange)
) As String

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which to export.
textRanges
Type: System.Collections.GenericICollection TextRange
The collection of text ranges in the snapshot for which to export.

Return Value

Type: String
The string that was created to represent the text ranges.
See Also

Reference

ITextExporter Interface
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Class

TextExporterFactory Class
Provides access to the built-in ITextExporter instances, that export text to other formats such as HTML or RTF markup.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ExportersTextExporterFactory

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextExporterFactory
Public Class TextExporterFactory

The TextExporterFactory type exposes the following members.

Constructors
 | Name | Description
Public method | TextExporterFactory | Initializes a new instance of the TextExporterFactory class.
Public method | TextExporterFactory(IHighlightingStyleRegistry) | Initializes a new instance of the TextExporterFactory class.
Top
Methods
 | Name | Description
Public method | CreateHtmlClassBased | Returns an IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.
Public method | CreateHtmlClipboard | Returns an IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.
Public method | CreateHtmlInline | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.
Public method | CreateHtmlInlineFragment | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.
Public method | CreateRtf | Returns an IRtfTextExporter that can export text to RTF.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Constructor

TextExporterFactory Constructor
Overload List
 | Name | Description
Public method | TextExporterFactory | Initializes a new instance of the TextExporterFactory class.
Public method | TextExporterFactory(IHighlightingStyleRegistry) | Initializes a new instance of the TextExporterFactory class.
Top
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Constructor

TextExporterFactory Constructor
Initializes a new instance of the TextExporterFactory class.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextExporterFactory()
Public Sub New
See Also

Reference

TextExporterFactory Class
TextExporterFactory Overload
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Constructor (IHighlightingStyleRegistry)

TextExporterFactory Constructor (IHighlightingStyleRegistry)
Initializes a new instance of the TextExporterFactory class.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextExporterFactory(
    IHighlightingStyleRegistry registry
)
Public Sub New (
    registry As IHighlightingStyleRegistry
)

Parameters

registry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The custom IHighlightingStyleRegistry that should be used.
See Also

Reference

TextExporterFactory Class
TextExporterFactory Overload
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory Methods

TextExporterFactory Methods

The TextExporterFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateHtmlClassBased | Returns an IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.
Public method | CreateHtmlClipboard | Returns an IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.
Public method | CreateHtmlInline | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.
Public method | CreateHtmlInlineFragment | Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.
Public method | CreateRtf | Returns an IRtfTextExporter that can export text to RTF.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlClassBased Method

TextExporterFactoryCreateHtmlClassBased Method
Returns an IHtmlTextExporter that can export text to HTML, using CSS classes for syntax highlighting.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlClassBased()
Public Function CreateHtmlClassBased As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
CSS class references will be used for highlighting. This type adds a STYLE tag block to the exported HTML where CSS classes are defined. The text in the code block references these CSS classes, therefore allowing color settings to easily be altered for each highlighting style (i.e. keywords, comments, etc.). Root HTML, BODY and other tags will be added to the output.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlClipboard Method

TextExporterFactoryCreateHtmlClipboard Method
Returns an IHtmlTextExporter that can export text to HTML, in a format that is compatible with the Windows clipboard HTML data format.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlClipboard()
Public Function CreateHtmlClipboard As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
The output of this exporter is the same as CreateHtmlInlineFragment, except that some additional information is added to make the exported text compatible with the Windows clipboard HTML data format.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlInline Method

TextExporterFactoryCreateHtmlInline Method
Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlInline()
Public Function CreateHtmlInline As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will be added to the output.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateHtmlInlineFragment Method

TextExporterFactoryCreateHtmlInlineFragment Method
Returns an IHtmlTextExporter that can export text to HTML, using inline CSS for syntax highlighting and no root HTML or BODY tags.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHtmlTextExporter CreateHtmlInlineFragment()
Public Function CreateHtmlInlineFragment As IHtmlTextExporter

Return Value

Type: IHtmlTextExporter
An IHtmlTextExporter that can export text to HTML.
Remarks
Inline CSS styles will be used for highlighting. This type allows for the code block to be directly copied out of the exported document and pasted into another. Root HTML, BODY and other tags will not be added to the output.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


TextExporterFactory.CreateRtf Method

TextExporterFactoryCreateRtf Method
Returns an IRtfTextExporter that can export text to RTF.

Namespace: ActiproSoftware.Text.Exporters
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IRtfTextExporter CreateRtf()
Public Function CreateRtf As IRtfTextExporter

Return Value

Type: IRtfTextExporter
An IRtfTextExporter that can export text to RTF.
See Also

Reference

TextExporterFactory Class
ActiproSoftware.Text.Exporters Namespace


ActiproSoftware.Text.Implementation Namespace

ActiproSoftware.Text.Implementation Namespace
Contains implementation types related to text.
Classes
 | Class | Description
Public class | ClassificationType | Represents the default implementation of a class that represents a classification type.
Public class | CodeDocument | Represents a text document with some advanced features that relate to syntax highlighting and code parsing.
Public class | DefaultWordBreakFinder | Provides the default implementation of an object that finds word breaks within an ITextSnapshot.
Public class | EditorDocument | Represents a text document that can be used in an editor.
Public class | ExampleTextProvider | Implements an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.
Public class | LineBasedLineCommenter | Represents an object that can comment and uncomment lines on a per-line basis.
Public class | RangeLineCommenter | Represents an object that can comment and uncomment lines over a particular range.
Public class | StringTextBufferReader | Represents an ITextBufferReader implementation for a String.
Public class | SyntaxLanguage | Implements a syntax-highlighting language definition that can be used to parse an ICodeDocument and provide additional functionality via registered services.
Public class | SyntaxLanguageDefinitionSerializer | Provides a class that can deserialize a SyntaxLanguage from XML.
Public class | TextChangeOptions | Represents options that are applied to an ITextChange.
Public class | TextDocumentBase | Represents a text document.
Public class | TextStatistics | Provides numerous statistics such as line, word, character counts, and readability scores for text.


ClassificationType Class

ClassificationType Class
Represents the default implementation of a class that represents a classification type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationClassificationType

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ClassificationType : IClassificationType,
    IKeyedObject
Public Class ClassificationType
    Implements IClassificationType, IKeyedObject

The ClassificationType type exposes the following members.

Constructors
 | Name | Description
Public method | ClassificationType(String) | Initializes a new instance of the ClassificationType class.
Public method | ClassificationType(String, String) | Initializes a new instance of the ClassificationType class.
Top
Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string key that uniquely identifies the classification type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


ClassificationType Constructor

ClassificationType Constructor
Overload List
 | Name | Description
Public method | ClassificationType(String) | Initializes a new instance of the ClassificationType class.
Public method | ClassificationType(String, String) | Initializes a new instance of the ClassificationType class.
Top
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType Constructor (String)

ClassificationType Constructor (String)
Initializes a new instance of the ClassificationType class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassificationType(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string key that uniquely identifies the classification type.
See Also

Reference

ClassificationType Class
ClassificationType Overload
ActiproSoftware.Text.Implementation Namespace


ClassificationType Constructor (String, String)

ClassificationType Constructor (String, String)
Initializes a new instance of the ClassificationType class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassificationType(
    string key,
    string description
)
Public Sub New (
    key As String,
    description As String
)

Parameters

key
Type: SystemString
The string key that uniquely identifies the classification type.
description
Type: SystemString
The description of the classification type.
See Also

Reference

ClassificationType Class
ClassificationType Overload
ActiproSoftware.Text.Implementation Namespace


ClassificationType Properties

ClassificationType Properties

The ClassificationType type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the classification type, which is displayed in the user interface.
Public property | Key | Gets the string key that uniquely identifies the classification type.
Top
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.Description Property

ClassificationTypeDescription Property
Gets the description of the classification type, which is displayed in the user interface.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the classification type, which is displayed in the user interface.

Implements

IClassificationTypeDescription
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.Key Property

ClassificationTypeKey Property
Gets the string key that uniquely identifies the classification type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string key that uniquely identifies the classification type.

Implements

IKeyedObjectKey
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType Methods

ClassificationType Methods

The ClassificationType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.Equals Method

ClassificationTypeEquals Method
Determines whether the specified Object is equal to this instance.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.GetHashCode Method

ClassificationTypeGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


ClassificationType.ToString Method

ClassificationTypeToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ClassificationType Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Class

CodeDocument Class
Represents a text document with some advanced features that relate to syntax highlighting and code parsing.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextDocumentBase
ActiproSoftware.Text.ImplementationCodeDocument
ActiproSoftware.Text.ImplementationEditorDocument

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CodeDocument : TextDocumentBase,
    ICodeDocument, IParseTarget, ITextDocument
Public Class CodeDocument
    Inherits TextDocumentBase
    Implements ICodeDocument, IParseTarget, ITextDocument

The CodeDocument type exposes the following members.

Constructors
 | Name | Description
Public method | CodeDocument | Initializes a new instance of the CodeDocument class.
Top
Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest.
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Overrides TextDocumentBaseGetReadOnlyRegions(TextRange).)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Inherited from TextDocumentBase.)
Public method | GetType | (Inherited from Object.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result.
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Overrides TextDocumentBaseOnFileNameChanged(StringPropertyChangedEventArgs).)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event.
Protected method | OnParseDataChanged | Raises the ParseDataChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides TextDocumentBaseOnTextChanged(TextSnapshotChangedEventArgs).)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


CodeDocument Constructor

CodeDocument Constructor
Initializes a new instance of the CodeDocument class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CodeDocument()
Public Sub New
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Properties

CodeDocument Properties

The CodeDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded.
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.Language Property

CodeDocumentLanguage Property
Gets or sets the ISyntaxLanguage that is currently loaded.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISyntaxLanguage Language { get; set; }
Public Property Language As ISyntaxLanguage
    Get
    Set

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that is currently loaded.

Implements

ICodeDocumentLanguage
Remarks
The default value is a plain text language.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.LanguageData Property

CodeDocumentLanguageData Property
Gets or sets an object that specifies document-specific data for the Language that is loaded.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object LanguageData { get; set; }
Public Property LanguageData As Object
    Get
    Set

Property Value

Type: Object
An object that specifies document-specific data for the Language that is loaded.

Implements

ICodeDocumentLanguageData
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.ParseData Property

CodeDocumentParseData Property
Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseData ParseData { get; set; }
Public Property ParseData As IParseData
    Get
    Set

Property Value

Type: IParseData
The syntax/semantic parse data that has been assigned to this document as a result of a parsing operation.

Implements

ICodeDocumentParseData
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.Properties Property

CodeDocumentProperties Property
Gets the dictionary containing custom properties for this object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyDictionary Properties { get; }
Public ReadOnly Property Properties As PropertyDictionary
    Get

Property Value

Type: PropertyDictionary
The dictionary containing custom properties for this object.

Implements

ICodeDocumentProperties
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Methods

CodeDocument Methods

The CodeDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level.
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest.
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Overrides TextDocumentBaseGetReadOnlyRegions(TextRange).)
Public method | GetServicesTService | Returns a list of available services of the specified type.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Inherited from TextDocumentBase.)
Public method | GetType | (Inherited from Object.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result.
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Overrides TextDocumentBaseOnFileNameChanged(StringPropertyChangedEventArgs).)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event.
Protected method | OnParseDataChanged | Raises the ParseDataChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Overrides TextDocumentBaseOnTextChanged(TextSnapshotChangedEventArgs).)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher.
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.AddLanguageChangedEventHandler Method

CodeDocumentAddLanguageChangedEventHandler Method
Adds an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub AddLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ICodeDocumentAddLanguageChangedEventHandler(EventHandlerSyntaxLanguageChangedEventArgs, EventHandlerPriority)
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.CreateParseRequest Method

CodeDocumentCreateParseRequest Method
Creates an IParseRequest that will be used by calls to QueueParseRequest.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IParseRequest CreateParseRequest()
Protected Overridable Function CreateParseRequest As IParseRequest

Return Value

Type: IParseRequest
The IParseRequest that was created.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.CreateTagAggregator(T) Method

CodeDocumentCreateTagAggregatorT Method
Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagAggregator<T> CreateTagAggregator<T>()
where T : ITag

Public Function CreateTagAggregator(Of T As ITag) As ITagAggregator(Of T)

Type Parameters

T
The type of ITag associated with this aggregator.

Return Value

Type: ITagAggregator T
The ITagAggregatorT that was created.

Implements

ICodeDocumentCreateTagAggregatorT
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.GetReadOnlyRegions Method

CodeDocumentGetReadOnlyRegions Method
Returns the collection of read-only region tag snapshot ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable<TagSnapshotRange<IReadOnlyRegionTag>> GetReadOnlyRegions(
    TextRange textRange
)
Protected Overrides Function GetReadOnlyRegions (
    textRange As TextRange
) As IEnumerable(Of TagSnapshotRange(Of IReadOnlyRegionTag))

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The text range relative to the current snapshot for which to locate read-only regions.

Return Value

Type: IEnumerable TagSnapshotRange IReadOnlyRegionTag
The collection of read-only region tag snapshot ranges.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.GetServices(TService) Method

CodeDocumentGetServicesTService Method
Returns a list of available services of the specified type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TService> GetServices<TService>()
where TService : class

Public Function GetServices(Of TService As Class) As IList(Of TService)

Type Parameters

TService
The type of service.

Return Value

Type: IList TService
The list of available services of the specified type.

Implements

ICodeDocumentGetServicesTService
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.NotifyParseComplete Method

CodeDocumentNotifyParseComplete Method
Called when a parsing operation has completed for this document, and passes the original request along with the result.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void NotifyParseComplete(
    IParseRequest request,
    IParseData result
)
Protected Overridable Sub NotifyParseComplete (
    request As IParseRequest,
    result As IParseData
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
An IParseRequest that contains information about the parsing operation that was requested.
result
Type: ActiproSoftware.Text.ParsingIParseData
An IParseData that is the result of the parsing operation.
Remarks
The default implementation of this method assigns result to the ParseData property.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnFileNameChanged Method

CodeDocumentOnFileNameChanged Method
Raises the FileNameChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnFileNameChanged(
    StringPropertyChangedEventArgs e
)
Protected Overrides Sub OnFileNameChanged (
    e As StringPropertyChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
An StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnLanguageChanged Method

CodeDocumentOnLanguageChanged Method
Raises the LanguageChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnLanguageChanged(
    SyntaxLanguageChangedEventArgs e
)
Protected Overridable Sub OnLanguageChanged (
    e As SyntaxLanguageChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.TextSyntaxLanguageChangedEventArgs
An SyntaxLanguageChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnParseDataChanged Method

CodeDocumentOnParseDataChanged Method
Raises the ParseDataChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnParseDataChanged(
    ParseDataPropertyChangedEventArgs e
)
Protected Overridable Sub OnParseDataChanged (
    e As ParseDataPropertyChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
An ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.OnTextChanged Method

CodeDocumentOnTextChanged Method
Raises the TextChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnTextChanged(
    TextSnapshotChangedEventArgs e
)
Protected Overrides Sub OnTextChanged (
    e As TextSnapshotChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.TextTextSnapshotChangedEventArgs
A TextSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.QueueParseRequest Method

CodeDocumentQueueParseRequest Method
Queues up a parse request for the document with the ambient dispatcher.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void QueueParseRequest()
Public Sub QueueParseRequest

Implements

ICodeDocumentQueueParseRequest
Remarks
If AmbientParseRequestDispatcherProvider does not provide a dispatcher, the parsing operation is completed immediately in the calling thread.
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.RemoveLanguageChangedEventHandler Method

CodeDocumentRemoveLanguageChangedEventHandler Method
Removes an event handler for the LanguageChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveLanguageChangedEventHandler(
    EventHandler<SyntaxLanguageChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub RemoveLanguageChangedEventHandler (
    handler As EventHandler(Of SyntaxLanguageChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler SyntaxLanguageChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ICodeDocumentRemoveLanguageChangedEventHandler(EventHandlerSyntaxLanguageChangedEventArgs, EventHandlerPriority)
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument Events

CodeDocument Events

The CodeDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed.
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed.
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.LanguageChanged Event

CodeDocumentLanguageChanged Event
Occurs after the value of the Language property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<SyntaxLanguageChangedEventArgs> LanguageChanged
Public Event LanguageChanged As EventHandler(Of SyntaxLanguageChangedEventArgs)

Value

Type: SystemEventHandler SyntaxLanguageChangedEventArgs

Implements

ICodeDocumentLanguageChanged
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


CodeDocument.ParseDataChanged Event

CodeDocumentParseDataChanged Event
Occurs after the value of the ParseData property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<ParseDataPropertyChangedEventArgs> ParseDataChanged
Public Event ParseDataChanged As EventHandler(Of ParseDataPropertyChangedEventArgs)

Value

Type: SystemEventHandler ParseDataPropertyChangedEventArgs

Implements

ICodeDocumentParseDataChanged
See Also

Reference

CodeDocument Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Class

DefaultWordBreakFinder Class
Provides the default implementation of an object that finds word breaks within an ITextSnapshot.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationDefaultWordBreakFinder

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DefaultWordBreakFinder : IWordBreakFinder
Public Class DefaultWordBreakFinder
    Implements IWordBreakFinder

The DefaultWordBreakFinder type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultWordBreakFinder | Initializes a new instance of the DefaultWordBreakFinder class.
Top
Properties
 | Name | Description
 | DefaultWordContainsAdditionalCharacters | Gets the default CharClass for the WordContainsAdditionalCharacters property.
 | DefaultWordStandaloneCharacters | Gets the default CharClass for the WordStandaloneCharacters property.
Public property | WordContainsAdditionalCharacters | Gets or sets the set of additional characters that can constitute the inside of a word, other than letters and digits.
Public property | WordStandaloneCharacters | Gets or sets the set of characters that are intended to be single character words.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IWordBreakFinder interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Constructor

DefaultWordBreakFinder Constructor
Initializes a new instance of the DefaultWordBreakFinder class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DefaultWordBreakFinder()
Public Sub New
Remarks
The default constructor initializes all fields to their default values.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Properties

DefaultWordBreakFinder Properties

The DefaultWordBreakFinder type exposes the following members.

Properties
 | Name | Description
 | DefaultWordContainsAdditionalCharacters | Gets the default CharClass for the WordContainsAdditionalCharacters property.
 | DefaultWordStandaloneCharacters | Gets the default CharClass for the WordStandaloneCharacters property.
Public property | WordContainsAdditionalCharacters | Gets or sets the set of additional characters that can constitute the inside of a word, other than letters and digits.
Public property | WordStandaloneCharacters | Gets or sets the set of characters that are intended to be single character words.
Top
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.DefaultWordContainsAdditionalCharacters Property

DefaultWordBreakFinderDefaultWordContainsAdditionalCharacters Property
Gets the default CharClass for the WordContainsAdditionalCharacters property.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass DefaultWordContainsAdditionalCharacters { get; }
Public Shared ReadOnly Property DefaultWordContainsAdditionalCharacters As CharClass
    Get

Property Value

Type: CharClass
The default CharClass for the WordContainsAdditionalCharacters property.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.DefaultWordStandaloneCharacters Property

DefaultWordBreakFinderDefaultWordStandaloneCharacters Property
Gets the default CharClass for the WordStandaloneCharacters property.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass DefaultWordStandaloneCharacters { get; }
Public Shared ReadOnly Property DefaultWordStandaloneCharacters As CharClass
    Get

Property Value

Type: CharClass
The default CharClass for the WordStandaloneCharacters property.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.WordContainsAdditionalCharacters Property

DefaultWordBreakFinderWordContainsAdditionalCharacters Property
Gets or sets the set of additional characters that can constitute the inside of a word, other than letters and digits.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass WordContainsAdditionalCharacters { get; set; }
Public Property WordContainsAdditionalCharacters As CharClass
    Get
    Set

Property Value

Type: CharClass
The set of additional characters that can constitute the inside of a word, other than letters and digits.
Remarks
The default value is the _ character.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.WordStandaloneCharacters Property

DefaultWordBreakFinderWordStandaloneCharacters Property
Gets or sets the set of characters that are intended to be single character words.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass WordStandaloneCharacters { get; set; }
Public Property WordStandaloneCharacters As CharClass
    Get
    Set

Property Value

Type: CharClass
The set of characters that are intended to be single character words.
Remarks
The default value is the set of .,()<>[]{}?!\/:;'" characters.
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder Methods

DefaultWordBreakFinder Methods

The DefaultWordBreakFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindCurrentWordEnd | Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.
Public method | FindCurrentWordStart | Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.
Public method | FindNextWordStart | Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.
Public method | FindPreviousWordStart | Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindCurrentWordEnd Method

DefaultWordBreakFinderFindCurrentWordEnd Method
Returns the ITextSnapshot offset of the word end character that occurs at or after the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FindCurrentWordEnd(
    TextSnapshotOffset snapshotOffset
)
Public Function FindCurrentWordEnd (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word end character that occurs at or after the specified start offset.

Implements

IWordBreakFinderFindCurrentWordEnd(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindCurrentWordStart Method

DefaultWordBreakFinderFindCurrentWordStart Method
Returns the ITextSnapshot offset of the word start character that occurs at or before the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FindCurrentWordStart(
    TextSnapshotOffset snapshotOffset
)
Public Function FindCurrentWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs at or before the specified start offset.

Implements

IWordBreakFinderFindCurrentWordStart(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindNextWordStart Method

DefaultWordBreakFinderFindNextWordStart Method
Returns the ITextSnapshot offset of the word start character that occurs after the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FindNextWordStart(
    TextSnapshotOffset snapshotOffset
)
Public Function FindNextWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs after the specified start offset.

Implements

IWordBreakFinderFindNextWordStart(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


DefaultWordBreakFinder.FindPreviousWordStart Method

DefaultWordBreakFinderFindPreviousWordStart Method
Returns the ITextSnapshot offset of the word start character that occurs before the specified start offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FindPreviousWordStart(
    TextSnapshotOffset snapshotOffset
)
Public Function FindPreviousWordStart (
    snapshotOffset As TextSnapshotOffset
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start parsing.

Return Value

Type: Int32
The ITextSnapshot offset of the word start character that occurs before the specified start offset.

Implements

IWordBreakFinderFindPreviousWordStart(TextSnapshotOffset)
See Also

Reference

DefaultWordBreakFinder Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Class

EditorDocument Class
Represents a text document that can be used in an editor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextDocumentBase
ActiproSoftware.Text.ImplementationCodeDocument
ActiproSoftware.Text.ImplementationEditorDocument

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorDocument : CodeDocument,
    IEditorDocument, ICodeDocument, IParseTarget, ITextDocument
Public Class EditorDocument
    Inherits CodeDocument
    Implements IEditorDocument, ICodeDocument, IParseTarget, ITextDocument

The EditorDocument type exposes the following members.

Constructors
 | Name | Description
Public method | EditorDocument | Initializes a new instance of the EditorDocument class.
Top
Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from CodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from CodeDocument.)
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from CodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from CodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | Text | Gets or sets the text in the document.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest. (Inherited from CodeDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from CodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Inherited from CodeDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from CodeDocument.)
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Overrides TextDocumentBaseGetTextReplacementInsertText(ITextChangeOperation).)
Public method | GetType | (Inherited from Object.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result. (Inherited from CodeDocument.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Inherited from CodeDocument.)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event. (Inherited from CodeDocument.)
Protected method | OnParseDataChanged | Raises the ParseDataChanged event. (Inherited from CodeDocument.)
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from CodeDocument.)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from CodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from CodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from CodeDocument.)
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


EditorDocument Constructor

EditorDocument Constructor
Initializes a new instance of the EditorDocument class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorDocument()
Public Sub New
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Properties

EditorDocument Properties

The EditorDocument type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document. (Inherited from TextDocumentBase.)
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs. (Inherited from TextDocumentBase.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document. (Inherited from TextDocumentBase.)
Public property | FileName | Gets or sets the name of the file currently loaded in the document. (Inherited from TextDocumentBase.)
Public property | IndicatorManager | Gets the IIndicatorManager that manages indicators for the document.
Public property | IsModified | Gets or sets whether the document has been modified. (Inherited from TextDocumentBase.)
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only. (Inherited from TextDocumentBase.)
Public property | Language | Gets or sets the ISyntaxLanguage that is currently loaded. (Inherited from CodeDocument.)
Public property | LanguageData | Gets or sets an object that specifies document-specific data for the Language that is loaded. (Inherited from CodeDocument.)
Public property | OutliningManager | Gets the IOutliningManager that manages outlining nodes for the document.
Public property | OutliningMode | Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.
Public property | ParseData | Gets or sets the syntax/semantic parse data that has been assigned to this document as a result of a parsing operation. (Inherited from CodeDocument.)
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from CodeDocument.)
Public property | TabSize | Gets or sets the distance in spaces between tab stops. (Inherited from TextDocumentBase.)
Public property | Text | Gets or sets the text in the document.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document. (Inherited from TextDocumentBase.)
Public property | WhitespaceTrimModes | Gets or sets the modes in which whitespace should be automatically trimmed.
Top
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.IndicatorManager Property

EditorDocumentIndicatorManager Property
Gets the IIndicatorManager that manages indicators for the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IIndicatorManager IndicatorManager { get; }
Public ReadOnly Property IndicatorManager As IIndicatorManager
    Get

Property Value

Type: IIndicatorManager
The IIndicatorManager that manages indicators for the document.

Implements

IEditorDocumentIndicatorManager
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.OutliningManager Property

EditorDocumentOutliningManager Property
Gets the IOutliningManager that manages outlining nodes for the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningManager OutliningManager { get; }
Public ReadOnly Property OutliningManager As IOutliningManager
    Get

Property Value

Type: IOutliningManager
The IOutliningManager that manages outlining nodes for the document. The default value is OutliningMode.Default.

Implements

IEditorDocumentOutliningManager
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.OutliningMode Property

EditorDocumentOutliningMode Property
Gets or sets the OutliningMode for the document that determines what type of code outlining (folding) is supported.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OutliningMode OutliningMode { get; set; }
Public Property OutliningMode As OutliningMode
    Get
    Set

Property Value

Type: OutliningMode
The OutliningMode for the document that determines what type of code outlining (folding) is supported.

Implements

IEditorDocumentOutliningMode
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.Text Property

EditorDocumentText Property
Gets or sets the text in the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text in the document.
Remarks
This property is only intended to be used when deserializing text content from XAML.
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.WhitespaceTrimModes Property

EditorDocumentWhitespaceTrimModes Property
Gets or sets the modes in which whitespace should be automatically trimmed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WhitespaceTrimModes WhitespaceTrimModes { get; set; }
Public Property WhitespaceTrimModes As WhitespaceTrimModes
    Get
    Set

Property Value

Type: WhitespaceTrimModes
A WhitespaceTrimModes indicating the modes in which whitespace should be automatically trimmed. The default value is None.

Implements

IEditorDocumentWhitespaceTrimModes
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Methods

EditorDocument Methods

The EditorDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddLanguageChangedEventHandler | Adds an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text. (Inherited from TextDocumentBase.)
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options. (Inherited from TextDocumentBase.)
Protected method | CreateParseRequest | Creates an IParseRequest that will be used by calls to QueueParseRequest. (Inherited from CodeDocument.)
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this document. (Inherited from CodeDocument.)
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges. (Inherited from CodeDocument.)
Public method | GetServicesTService | Returns a list of available services of the specified type. (Inherited from CodeDocument.)
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation. (Overrides TextDocumentBaseGetTextReplacementInsertText(ITextChangeOperation).)
Public method | GetType | (Inherited from Object.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only. (Inherited from TextDocumentBase.)
Public method | LoadFile | Loads document text from a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding. (Inherited from TextDocumentBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyParseComplete | Called when a parsing operation has completed for this document, and passes the original request along with the result. (Inherited from CodeDocument.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed. (Inherited from TextDocumentBase.)
Protected method | OnFileNameChanged | Raises the FileNameChanged event. (Inherited from CodeDocument.)
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event. (Inherited from TextDocumentBase.)
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event. (Inherited from TextDocumentBase.)
Protected method | OnLanguageChanged | Raises the LanguageChanged event. (Inherited from CodeDocument.)
Protected method | OnParseDataChanged | Raises the ParseDataChanged event. (Inherited from CodeDocument.)
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event. (Inherited from TextDocumentBase.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from CodeDocument.)
Protected method | OnTextChanging | Raises the TextChanging event. (Inherited from TextDocumentBase.)
Public method | QueueParseRequest | Queues up a parse request for the document with the ambient dispatcher. (Inherited from CodeDocument.)
Public method | RemoveLanguageChangedEventHandler | Removes an event handler for the LanguageChanged event using the specified priority level. (Inherited from CodeDocument.)
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset. (Inherited from TextDocumentBase.)
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | SaveFile | Saves document text to a Stream using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding. (Inherited from TextDocumentBase.)
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results. (Inherited from TextDocumentBase.)
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot. (Inherited from TextDocumentBase.)
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options. (Inherited from TextDocumentBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument.GetTextReplacementInsertText Method

EditorDocumentGetTextReplacementInsertText Method
Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetTextReplacementInsertText(
    ITextChangeOperation operation
)
Protected Overrides Function GetTextReplacementInsertText (
    operation As ITextChangeOperation
) As String

Parameters

operation
Type: ActiproSoftware.TextITextChangeOperation
The ITextChangeOperation containing default text to insert.

Return Value

Type: String
The text to insert.
Remarks
This method can be overridden to scrub the text to insert, such as remove trailing whitespace, etc.
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


EditorDocument Events

EditorDocument Events

The EditorDocument type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed. (Inherited from TextDocumentBase.)
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed. (Inherited from TextDocumentBase.)
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed. (Inherited from TextDocumentBase.)
Public event | LanguageChanged | Occurs after the value of the Language property has changed. (Inherited from CodeDocument.)
Public event | ParseDataChanged | Occurs after the value of the ParseData property has changed. (Inherited from CodeDocument.)
Public event | PropertyChanged | Occurs when a property value is changed. (Inherited from TextDocumentBase.)
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed. (Inherited from TextDocumentBase.)
Public event | TextChanged | Occurs after a text change occurs to this document. (Inherited from TextDocumentBase.)
Public event | TextChanging | Occurs before a text change occurs to this document. (Inherited from TextDocumentBase.)
Top
See Also

Reference

EditorDocument Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Class

ExampleTextProvider Class
Implements an object that returns example text, which can be displayed in an application to show how a language's code snippet is syntax-highlighted.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationExampleTextProvider

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExampleTextProvider : IExampleTextProvider
Public Class ExampleTextProvider
    Implements IExampleTextProvider

The ExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ExampleTextProvider | Initializes a new instance of the ExampleTextProvider class.
Top
Properties
 | Name | Description
Public property | ExampleText | Gets or sets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IExampleTextProvider interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Constructor

ExampleTextProvider Constructor
Initializes a new instance of the ExampleTextProvider class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExampleTextProvider(
    string exampleText
)
Public Sub New (
    exampleText As String
)

Parameters

exampleText
Type: SystemString
The example text, a code snippet of the related language.
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Properties

ExampleTextProvider Properties

The ExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets or sets the example text, a code snippet of the related language.
Top
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider.ExampleText Property

ExampleTextProviderExampleText Property
Gets or sets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; set; }
Public Property ExampleText As String
    Get
    Set

Property Value

Type: String
The example text.

Implements

IExampleTextProviderExampleText
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


ExampleTextProvider Methods

ExampleTextProvider Methods

The ExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExampleTextProvider Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Class

LineBasedLineCommenter Class
Represents an object that can comment and uncomment lines on a per-line basis.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationLineBasedLineCommenter

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LineBasedLineCommenter : ILineCommenter
Public Class LineBasedLineCommenter
    Implements ILineCommenter

The LineBasedLineCommenter type exposes the following members.

Constructors
 | Name | Description
Public method | LineBasedLineCommenter | Initializes a new instance of the LineBasedLineCommenter class
Top
Properties
 | Name | Description
Public property | CanCommentEmptyLines | Gets or sets a value indicating whether to comment empty lines, when the target range includes more than one line.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange.
Top
Remarks
The StartDelimiter is required.

The start delimiter is added/removed from each line in the range.

Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILineCommenter interface type, its features can be used by the language.

See Also

Reference

ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Constructor

LineBasedLineCommenter Constructor
Initializes a new instance of the LineBasedLineCommenter class

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LineBasedLineCommenter()
Public Sub New
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Properties

LineBasedLineCommenter Properties

The LineBasedLineCommenter type exposes the following members.

Properties
 | Name | Description
Public property | CanCommentEmptyLines | Gets or sets a value indicating whether to comment empty lines, when the target range includes more than one line.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.CanCommentEmptyLines Property

LineBasedLineCommenterCanCommentEmptyLines Property
Gets or sets a value indicating whether to comment empty lines, when the target range includes more than one line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCommentEmptyLines { get; set; }
Public Property CanCommentEmptyLines As Boolean
    Get
    Set

Property Value

Type: Boolean
true if empty lines are to be commented, when the target range includes more than one line; otherwise, false.
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.StartDelimiter Property

LineBasedLineCommenterStartDelimiter Property
Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StartDelimiter { get; set; }
Public Property StartDelimiter As String
    Get
    Set

Property Value

Type: String
The start delimiter text that is added or removed during comment/uncomment operations.
Remarks
In C#, the start delimiter would be //.
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter Methods

LineBasedLineCommenter Methods

The LineBasedLineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange.
Top
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.Comment Method

LineBasedLineCommenterComment Method
Comments out the lines of code in the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Comment(
    TextSnapshotRange snapshotRange,
    ITextChangeOptions options
)
Public Overridable Sub Comment (
    snapshotRange As TextSnapshotRange,
    options As ITextChangeOptions
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterComment(TextSnapshotRange, ITextChangeOptions)
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


LineBasedLineCommenter.Uncomment Method

LineBasedLineCommenterUncomment Method
Uncomments the lines of code in the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Uncomment(
    TextSnapshotRange snapshotRange,
    ITextChangeOptions options
)
Public Overridable Sub Uncomment (
    snapshotRange As TextSnapshotRange,
    options As ITextChangeOptions
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to uncomment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterUncomment(TextSnapshotRange, ITextChangeOptions)
See Also

Reference

LineBasedLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Class

RangeLineCommenter Class
Represents an object that can comment and uncomment lines over a particular range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationRangeLineCommenter
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLineCommenter

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RangeLineCommenter : ILineCommenter
Public Class RangeLineCommenter
    Implements ILineCommenter

The RangeLineCommenter type exposes the following members.

Constructors
 | Name | Description
Public method | RangeLineCommenter | Initializes a new instance of the RangeLineCommenter class
Top
Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID.
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange.
Top
Remarks
The StartDelimiter and EndDelimiter properties are both required.

The start delimiter is added/removed from the start of the range. The end delimiter is added/removed from the end of the range.

Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILineCommenter interface type, its features can be used by the language.

See Also

Reference

ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Constructor

RangeLineCommenter Constructor
Initializes a new instance of the RangeLineCommenter class

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeLineCommenter()
Public Sub New
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Properties

RangeLineCommenter Properties

The RangeLineCommenter type exposes the following members.

Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID.
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations.
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.
Top
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.CommentTokenId Property

RangeLineCommenterCommentTokenId Property
Gets or sets the comment token ID.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> CommentTokenId { get; set; }
Public Property CommentTokenId As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The comment token ID.
Remarks
If a token ID is specified for the comment, it can be used to help locate a surrounding comment when uncommenting.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.EndDelimiter Property

RangeLineCommenterEndDelimiter Property
Gets or sets the end delimiter text that is added or removed during comment/uncomment operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string EndDelimiter { get; set; }
Public Property EndDelimiter As String
    Get
    Set

Property Value

Type: String
The end delimiter text that is added or removed during comment/uncomment operations.
Remarks
For instance, in XML the end delimiter would be -->.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.StartDelimiter Property

RangeLineCommenterStartDelimiter Property
Gets or sets the start delimiter text that is added or removed during comment/uncomment operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StartDelimiter { get; set; }
Public Property StartDelimiter As String
    Get
    Set

Property Value

Type: String
The start delimiter text that is added or removed during comment/uncomment operations.
Remarks
For instance, in XML the start delimiter would be <!--.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter Methods

RangeLineCommenter Methods

The RangeLineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange.
Top
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.Comment Method

RangeLineCommenterComment Method
Comments out the lines of code in the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Comment(
    TextSnapshotRange snapshotRange,
    ITextChangeOptions options
)
Public Overridable Sub Comment (
    snapshotRange As TextSnapshotRange,
    options As ITextChangeOptions
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to comment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterComment(TextSnapshotRange, ITextChangeOptions)
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.FindCommentTextRange Method

RangeLineCommenterFindCommentTextRange Method
Returns the full text range of the comment that surrounds the specified snapshot range, if any.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Nullable<TextRange> FindCommentTextRange(
    TextSnapshotRange snapshotRange
)
Protected Overridable Function FindCommentTextRange (
    snapshotRange As TextSnapshotRange
) As Nullable(Of TextRange)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Nullable TextRange
The full text range of the comment that surrounds the specified snapshot range, if any.
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


RangeLineCommenter.Uncomment Method

RangeLineCommenterUncomment Method
Uncomments the lines of code in the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Uncomment(
    TextSnapshotRange snapshotRange,
    ITextChangeOptions options
)
Public Overridable Sub Uncomment (
    snapshotRange As TextSnapshotRange,
    options As ITextChangeOptions
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which to uncomment lines.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Implements

ILineCommenterUncomment(TextSnapshotRange, ITextChangeOptions)
See Also

Reference

RangeLineCommenter Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Class

StringTextBufferReader Class
Represents an ITextBufferReader implementation for a String.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationStringTextBufferReader

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StringTextBufferReader : ITextBufferReader
Public Class StringTextBufferReader
    Implements ITextBufferReader

The StringTextBufferReader type exposes the following members.

Constructors
 | Name | Description
Public method | StringTextBufferReader(String) | Initializes a new instance of the StringTextBufferReader class.
Public method | StringTextBufferReader(String, TextPosition, Int32) | Initializes a new instance of the StringTextBufferReader class.
Top
Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Constructor

StringTextBufferReader Constructor
Overload List
 | Name | Description
Public method | StringTextBufferReader(String) | Initializes a new instance of the StringTextBufferReader class.
Public method | StringTextBufferReader(String, TextPosition, Int32) | Initializes a new instance of the StringTextBufferReader class.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Constructor (String)

StringTextBufferReader Constructor (String)
Initializes a new instance of the StringTextBufferReader class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StringTextBufferReader(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text to store in the text buffer.
See Also

Reference

StringTextBufferReader Class
StringTextBufferReader Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Constructor (String, TextPosition, Int32)

StringTextBufferReader Constructor (String, TextPosition, Int32)
Initializes a new instance of the StringTextBufferReader class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StringTextBufferReader(
    string text,
    TextPosition position,
    int offset
)
Public Sub New (
    text As String,
    position As TextPosition,
    offset As Integer
)

Parameters

text
Type: SystemString
The text to store in the text buffer.
position
Type: ActiproSoftware.TextTextPosition
The initial TextPosition of the reader.
offset
Type: SystemInt32
The initial offset of the reader.
See Also

Reference

StringTextBufferReader Class
StringTextBufferReader Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Properties

StringTextBufferReader Properties

The StringTextBufferReader type exposes the following members.

Properties
 | Name | Description
Public property | HasStackEntries | Gets whether there are entries on the stack.
Public property | IsAtEnd | Gets whether the current Offset is at the end of the text buffer.
Public property | IsAtStart | Gets whether the current Offset is at the start of the text buffer.
Public property | IsWhitespaceOnlyAfterOnLine | Gets whether only whitespace characters appear at and after the Offset on the current line.
Public property | IsWhitespaceOnlyBeforeOnLine | Gets whether only whitespace characters appear before the Offset on the current line.
Public property | Length | Gets the number of characters in the text buffer.
Public property | Offset | Gets or sets the current reader offset in the text buffer.
Public property | OffsetDelta | Gets the amount by which to alter the offset values that are parsed.
Public property | Position | Gets the current reader TextPosition in the text buffer.
Public property | PositionDelta | Gets the amount by which to alter the Position values that are parsed.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.HasStackEntries Property

StringTextBufferReaderHasStackEntries Property
Gets whether there are entries on the stack.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStackEntries { get; }
Public ReadOnly Property HasStackEntries As Boolean
    Get

Property Value

Type: Boolean
true if there are entries on the stack; otherwise, false.

Implements

ITextBufferReaderHasStackEntries
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsAtEnd Property

StringTextBufferReaderIsAtEnd Property
Gets whether the current Offset is at the end of the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAtEnd { get; }
Public ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the end of the text buffer; otherwise, false.

Implements

ITextBufferReaderIsAtEnd
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsAtStart Property

StringTextBufferReaderIsAtStart Property
Gets whether the current Offset is at the start of the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAtStart { get; }
Public ReadOnly Property IsAtStart As Boolean
    Get

Property Value

Type: Boolean
true if the current Offset is at the start of the text buffer; otherwise, false.

Implements

ITextBufferReaderIsAtStart
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsWhitespaceOnlyAfterOnLine Property

StringTextBufferReaderIsWhitespaceOnlyAfterOnLine Property
Gets whether only whitespace characters appear at and after the Offset on the current line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWhitespaceOnlyAfterOnLine { get; }
Public ReadOnly Property IsWhitespaceOnlyAfterOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear at and after the Offset on the current line; otherwise, false.

Implements

ITextBufferReaderIsWhitespaceOnlyAfterOnLine
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.IsWhitespaceOnlyBeforeOnLine Property

StringTextBufferReaderIsWhitespaceOnlyBeforeOnLine Property
Gets whether only whitespace characters appear before the Offset on the current line.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWhitespaceOnlyBeforeOnLine { get; }
Public ReadOnly Property IsWhitespaceOnlyBeforeOnLine As Boolean
    Get

Property Value

Type: Boolean
true if only whitespace characters appear before the Offset on the current line; otherwise, false.

Implements

ITextBufferReaderIsWhitespaceOnlyBeforeOnLine
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Length Property

StringTextBufferReaderLength Property
Gets the number of characters in the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The number of characters in the text buffer.

Implements

ITextBufferReaderLength
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Offset Property

StringTextBufferReaderOffset Property
Gets or sets the current reader offset in the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The current reader offset in the text buffer.

Implements

ITextBufferReaderOffset
Remarks
For performance reasons there is no bounds check on the setter.
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.OffsetDelta Property

StringTextBufferReaderOffsetDelta Property
Gets the amount by which to alter the offset values that are parsed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int OffsetDelta { get; }
Public ReadOnly Property OffsetDelta As Integer
    Get

Property Value

Type: Int32
The amount by which to alter the offset values that are parsed.

Implements

ITextBufferReaderOffsetDelta
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Position Property

StringTextBufferReaderPosition Property
Gets the current reader TextPosition in the text buffer.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition Position { get; }
Public ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The current reader TextPosition in the text buffer.

Implements

ITextBufferReaderPosition
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.PositionDelta Property

StringTextBufferReaderPositionDelta Property
Gets the amount by which to alter the Position values that are parsed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition PositionDelta { get; }
Public ReadOnly Property PositionDelta As TextPosition
    Get

Property Value

Type: TextPosition
The amount by which to alter the Position values that are parsed.

Implements

ITextBufferReaderPositionDelta
Remarks
The Character portion only affects character offset of the line after the Line count.
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader Methods

StringTextBufferReader Methods

The StringTextBufferReader type exposes the following members.

Methods
 | Name | Description
Public method | AsTextReader | Returns a TextReader wrapper for this reader.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSubstring | Returns a substring from the text buffer using Newline for line ends.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Public method | PeekReverse | Reverse peeks at a single character from the text buffer without seeking past it.
Public method | Pop | Pops the top offset from the stack and moves the Offset to that offset.
Public method | PopAll | Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.
Public method | Push | Pushes the Offset onto the stack for later restoration.
Public method | Read | Reads a single character from the text buffer and seeks forward one offset.
Public method | ReadReverse | Reverse reads a single character from the text buffer and seeks backward one offset.
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.AsTextReader Method

StringTextBufferReaderAsTextReader Method
Returns a TextReader wrapper for this reader.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextReader AsTextReader()
Public Function AsTextReader As TextReader

Return Value

Type: TextReader
A TextReader wrapper for this reader.

Implements

ITextBufferReaderAsTextReader
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.GetSubstring Method

StringTextBufferReaderGetSubstring Method
Returns a substring from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetSubstring(
    int startOffset,
    int substringLength
)
Public Function GetSubstring (
    startOffset As Integer,
    substringLength As Integer
) As String

Parameters

startOffset
Type: SystemInt32
The offset at which to retrieve the text.
substringLength
Type: SystemInt32
The number of characters to return.

Return Value

Type: String
The substring from the text buffer using Newline for line ends.

Implements

ITextBufferReaderGetSubstring(Int32, Int32)
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Peek Method

StringTextBufferReaderPeek Method
Overload List
 | Name | Description
Public method | Peek | Peeks at a single character from the text buffer without seeking past it.
Public method | Peek(Int32) | Peeks at a certain character from the text buffer after the current Offset without seeking past it.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Peek Method

StringTextBufferReaderPeek Method
Peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char Peek()
Public Function Peek As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderPeek
See Also

Reference

StringTextBufferReader Class
Peek Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Peek Method (Int32)

StringTextBufferReaderPeek Method (Int32)
Peeks at a certain character from the text buffer after the current Offset without seeking past it.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char Peek(
    int count
)
Public Function Peek (
    count As Integer
) As Char

Parameters

count
Type: SystemInt32
The number of characters away from the current Offset at which to peek.

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderPeek(Int32)
See Also

Reference

StringTextBufferReader Class
Peek Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.PeekReverse Method

StringTextBufferReaderPeekReverse Method
Reverse peeks at a single character from the text buffer without seeking past it.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char PeekReverse()
Public Function PeekReverse As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderPeekReverse
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Pop Method

StringTextBufferReaderPop Method
Pops the top offset from the stack and moves the Offset to that offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Pop()
Public Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITextBufferReaderPop
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.PopAll Method

StringTextBufferReaderPopAll Method
Pops the all offsets from the stack and moves the Offset to the offset that was on the bottom of the stack.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool PopAll()
Public Function PopAll As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITextBufferReaderPopAll
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Push Method

StringTextBufferReaderPush Method
Pushes the Offset onto the stack for later restoration.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Push()
Public Sub Push

Implements

ITextBufferReaderPush
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.Read Method

StringTextBufferReaderRead Method
Reads a single character from the text buffer and seeks forward one offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char Read()
Public Function Read As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderRead
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverse Method

StringTextBufferReaderReadReverse Method
Reverse reads a single character from the text buffer and seeks backward one offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char ReadReverse()
Public Function ReadReverse As Char

Return Value

Type: Char
The character that was read.

Implements

ITextBufferReaderReadReverse
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverseThrough Method

StringTextBufferReaderReadReverseThrough Method
Overload List
 | Name | Description
Public method | ReadReverseThrough(Char) | Reverse reads characters from the text buffer until the specified character is read through.
Public method | ReadReverseThrough(Char, Int32) | Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverseThrough Method (Char)

StringTextBufferReaderReadReverseThrough Method (Char)
Reverse reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReadReverseThrough(
    char ch
)
Public Function ReadReverseThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the start of the text buffer was reached.

Implements

ITextBufferReaderReadReverseThrough(Char)
See Also

Reference

StringTextBufferReader Class
ReadReverseThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadReverseThrough Method (Char, Int32)

StringTextBufferReaderReadReverseThrough Method (Char, Int32)
Reverse reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReadReverseThrough(
    char ch,
    int minOffset
)
Public Function ReadReverseThrough (
    ch As Char,
    minOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
minOffset
Type: SystemInt32
The minimum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.

Implements

ITextBufferReaderReadReverseThrough(Char, Int32)
See Also

Reference

StringTextBufferReader Class
ReadReverseThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadThrough Method

StringTextBufferReaderReadThrough Method
Overload List
 | Name | Description
Public method | ReadThrough(Char) | Reads characters from the text buffer until the specified character is read through.
Public method | ReadThrough(Char, Int32) | Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.
Top
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadThrough Method (Char)

StringTextBufferReaderReadThrough Method (Char)
Reads characters from the text buffer until the specified character is read through.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReadThrough(
    char ch
)
Public Function ReadThrough (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the end of the text buffer was reached.

Implements

ITextBufferReaderReadThrough(Char)
See Also

Reference

StringTextBufferReader Class
ReadThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ReadThrough Method (Char, Int32)

StringTextBufferReaderReadThrough Method (Char, Int32)
Reads characters from the text buffer until the specified character is read through, or the specified offset is reached.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReadThrough(
    char ch,
    int maxOffset
)
Public Function ReadThrough (
    ch As Char,
    maxOffset As Integer
) As Boolean

Parameters

ch
Type: SystemChar
The desired character.
maxOffset
Type: SystemInt32
The maximum offset to check.

Return Value

Type: Boolean
true if the desired character was read; otherwise, false if the specified offset was reached.

Implements

ITextBufferReaderReadThrough(Char, Int32)
See Also

Reference

StringTextBufferReader Class
ReadThrough Overload
ActiproSoftware.Text.Implementation Namespace


StringTextBufferReader.ToString Method

StringTextBufferReaderToString Method
Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

StringTextBufferReader Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Class

SyntaxLanguage Class
Implements a syntax-highlighting language definition that can be used to parse an ICodeDocument and provide additional functionality via registered services.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSyntaxLanguage
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonSyntaxLanguage
ActiproSoftware.Text.Languages.Python.ImplementationPythonSyntaxLanguage
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSyntaxLanguage

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SyntaxLanguage : ISyntaxLanguage,
    IKeyedObject, IServiceLocator
Public Class SyntaxLanguage
    Implements ISyntaxLanguage, IKeyedObject, IServiceLocator

The SyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxLanguage | Initializes a new instance of the SyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language.
 | PlainText | Gets a SyntaxLanguage that implements a default plain text parser.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnServiceAdded | Raises the ServiceAdded event.
Protected method | OnServiceRemoved | Raises the ServiceRemoved event.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Constructor

SyntaxLanguage Constructor
Initializes a new instance of the SyntaxLanguage class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SyntaxLanguage(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the language.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Properties

SyntaxLanguage Properties

The SyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language.
 | PlainText | Gets a SyntaxLanguage that implements a default plain text parser.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.Key Property

SyntaxLanguageKey Property
Gets a string that identifies the language.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; protected set; }
Public Property Key As String
    Get
    Protected Set

Property Value

Type: String
A string that identifies the language.

Implements

IKeyedObjectKey
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.PlainText Property

SyntaxLanguagePlainText Property
Gets a SyntaxLanguage that implements a default plain text parser.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static SyntaxLanguage PlainText { get; }
Public Shared ReadOnly Property PlainText As SyntaxLanguage
    Get

Property Value

Type: SyntaxLanguage
A SyntaxLanguage that implements a default plain text parser.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Methods

SyntaxLanguage Methods

The SyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnServiceAdded | Raises the ServiceAdded event.
Protected method | OnServiceRemoved | Raises the ServiceRemoved event.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetAutoCorrector | Returns the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetCodeBlockFinder | Returns the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDelimiterAutoCompleter | Returns the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetExampleTextProvider | Returns the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetIndentProvider | Returns the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLexer | Returns the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetLineCommenter | Returns the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetNavigableSymbolProvider | Returns the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetOutliner | Returns the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetParser | Returns the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetProject | Returns the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | GetProjectAssembly | Returns the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | GetStructureMatcher | Returns the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextFormatter | Returns the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetTextStatisticsFactory | Returns the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetWordBreakFinder | Returns the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | GetXmlValidator | Returns the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | Parse | Parses text using the specified language's IParser service and returns the IParseData result. (Defined by SyntaxLanguageParsingExtensions.)
Public Extension Method | RegisterAutoCorrector | Registers the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterCodeBlockFinder | Registers the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDelimiterAutoCompleter | Registers the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterExampleTextProvider | Registers the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterIndentProvider | Registers the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLexer | Registers the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterLineCommenter | Registers the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterNavigableSymbolProvider | Registers the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterOutliner | Registers the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterParser | Registers the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterProject | Registers the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | RegisterStructureMatcher | Registers the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextFormatter | Registers the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterTextStatisticsFactory | Registers the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterWordBreakFinder | Registers the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | RegisterXmlValidator | Registers the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterAutoCorrector | Unregisters the IAutoCorrector that can perform auto-correction. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterCodeBlockFinder | Unregisters the ICodeBlockFinder that can find the containing code block for a text range. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDelimiterAutoCompleter | Unregisters the IDelimiterAutoCompleter that can auto-complete delimiters, such as brace pairs. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterExampleTextProvider | Unregisters the IExampleTextProvider that can generate example text for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterIndentProvider | Unregisters the IIndentProvider that can indent text for the language when the Enter key pressed. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLexer | Unregisters the ILexer that can be used for lexing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterLineCommenter | Unregisters the ILineCommenter that can comment and uncomment lines for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterNavigableSymbolProvider | Unregisters the INavigableSymbolProvider that can be used to return navigable symbols for a language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterOutliner | Unregisters the IOutliner that can be used to generate an IOutliningSource for a language, which is used to drive automatic code outlining (folding) features. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterParser | Unregisters the IParser that can be used for parsing of the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterProject | Unregisters the IProject that can validate XML. (Defined by PythonSyntaxLanguageExtensions.)
Public Extension Method | UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML. (Defined by DotNetSyntaxLanguageExtensions.)
Public Extension Method | UnregisterStructureMatcher | Unregisters the IStructureMatcher that can locate matching structural text ranges for an offset, such as finding matching brackets. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextFormatter | Unregisters the ITextFormatter that can improve the readability of code for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterTextStatisticsFactory | Unregisters the ITextStatisticsFactory that can generate customized text statistics for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterWordBreakFinder | Unregisters the IWordBreakFinder that is capable of locating word breaks for the language. (Defined by SyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data. (Defined by XmlSyntaxLanguageExtensions.)
Public Extension Method | UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML. (Defined by XmlSyntaxLanguageExtensions.)
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetAllServiceTypes Method

SyntaxLanguageGetAllServiceTypes Method
Returns a collection of all the service types that have been registered.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<Object> GetAllServiceTypes()
Public Function GetAllServiceTypes As IEnumerable(Of Object)

Return Value

Type: IEnumerable Object
A collection of all the service types that have been registered.

Implements

IServiceLocatorGetAllServiceTypes
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetService Method

SyntaxLanguageGetService Method
Overload List
 | Name | Description
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetService(T) Method

SyntaxLanguageGetServiceT Method
Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T GetService<T>()

Public Function GetService(Of T) As T

Type Parameters

T
The type of service to return.

Return Value

Type: T
The service that has been registered with the specified type.

Implements

IServiceLocatorGetServiceT
See Also

Reference

SyntaxLanguage Class
GetService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.GetService Method (Object)

SyntaxLanguageGetService Method (Object)
Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object GetService(
    Object serviceType
)
Public Function GetService (
    serviceType As Object
) As Object

Parameters

serviceType
Type: SystemObject
The type of service to return.

Return Value

Type: Object
The service that has been registered with the specified type.

Implements

IServiceLocatorGetService(Object)
See Also

Reference

SyntaxLanguage Class
GetService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.OnServiceAdded Method

SyntaxLanguageOnServiceAdded Method
Raises the ServiceAdded event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnServiceAdded(
    CollectionChangeEventArgs<Object> e
)
Protected Overridable Sub OnServiceAdded (
    e As CollectionChangeEventArgs(Of Object)
)

Parameters

e
Type: ActiproSoftware.Text.UtilityCollectionChangeEventArgs Object
A CollectionChangeEventArgs{object} that contains the event data.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.OnServiceRemoved Method

SyntaxLanguageOnServiceRemoved Method
Raises the ServiceRemoved event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnServiceRemoved(
    CollectionChangeEventArgs<Object> e
)
Protected Overridable Sub OnServiceRemoved (
    e As CollectionChangeEventArgs(Of Object)
)

Parameters

e
Type: ActiproSoftware.Text.UtilityCollectionChangeEventArgs Object
A CollectionChangeEventArgs{object} that contains the event data.
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.RegisterService Method

SyntaxLanguageRegisterService Method
Overload List
 | Name | Description
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.RegisterService(T) Method (T)

SyntaxLanguageRegisterServiceT Method (T)
Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RegisterService<T>(
    T service
)

Public Sub RegisterService(Of T) (
    service As T
)

Parameters

service
Type: T
The service object instance.

Type Parameters

T
The type of service.

Implements

IServiceLocatorRegisterServiceT(T)
See Also

Reference

SyntaxLanguage Class
RegisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.RegisterService Method (Object, Object)

SyntaxLanguageRegisterService Method (Object, Object)
Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RegisterService(
    Object serviceType,
    Object service
)
Public Sub RegisterService (
    serviceType As Object,
    service As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.
service
Type: SystemObject
The service object instance.

Implements

IServiceLocatorRegisterService(Object, Object)
See Also

Reference

SyntaxLanguage Class
RegisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.UnregisterService Method

SyntaxLanguageUnregisterService Method
Overload List
 | Name | Description
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.UnregisterService(T) Method

SyntaxLanguageUnregisterServiceT Method
Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void UnregisterService<T>()

Public Sub UnregisterService(Of T)

Type Parameters

T
The type of service.

Implements

IServiceLocatorUnregisterServiceT
See Also

Reference

SyntaxLanguage Class
UnregisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.UnregisterService Method (Object)

SyntaxLanguageUnregisterService Method (Object)
Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void UnregisterService(
    Object serviceType
)
Public Sub UnregisterService (
    serviceType As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.

Implements

IServiceLocatorUnregisterService(Object)
See Also

Reference

SyntaxLanguage Class
UnregisterService Overload
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage Events

SyntaxLanguage Events

The SyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.ServiceAdded Event

SyntaxLanguageServiceAdded Event
Occurs after a service is added to the object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<Object>> ServiceAdded
Public Event ServiceAdded As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object

Implements

IServiceLocatorServiceAdded
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguage.ServiceRemoved Event

SyntaxLanguageServiceRemoved Event
Occurs after a service is removed from the object.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<Object>> ServiceRemoved
Public Event ServiceRemoved As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object

Implements

IServiceLocatorServiceRemoved
See Also

Reference

SyntaxLanguage Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Class

SyntaxLanguageDefinitionSerializer Class
Provides a class that can deserialize a SyntaxLanguage from XML.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguageDefinitionSerializer

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SyntaxLanguageDefinitionSerializer
Public Class SyntaxLanguageDefinitionSerializer

The SyntaxLanguageDefinitionSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxLanguageDefinitionSerializer | Initializes a new instance of the SyntaxLanguageDefinitionSerializer class
Top
Properties
 | Name | Description
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry that should be used.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeFromStream | Initializes an existing ISyntaxLanguage from a language definition Stream.
Public method | LoadFromStream | Loads an ISyntaxLanguage from a language definition Stream.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Constructor

SyntaxLanguageDefinitionSerializer Constructor
Initializes a new instance of the SyntaxLanguageDefinitionSerializer class

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SyntaxLanguageDefinitionSerializer()
Public Sub New
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Properties

SyntaxLanguageDefinitionSerializer Properties

The SyntaxLanguageDefinitionSerializer type exposes the following members.

Properties
 | Name | Description
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry that should be used.
Top
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.HighlightingStyleRegistry Property

SyntaxLanguageDefinitionSerializerHighlightingStyleRegistry Property
Gets or sets the custom IHighlightingStyleRegistry that should be used.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Public Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The custom IHighlightingStyleRegistry that should be used.
Remarks
If this property is , the AmbientHighlightingStyleRegistry will be used.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer Methods

SyntaxLanguageDefinitionSerializer Methods

The SyntaxLanguageDefinitionSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeFromStream | Initializes an existing ISyntaxLanguage from a language definition Stream.
Public method | LoadFromStream | Loads an ISyntaxLanguage from a language definition Stream.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.InitializeFromStream Method

SyntaxLanguageDefinitionSerializerInitializeFromStream Method
Initializes an existing ISyntaxLanguage from a language definition Stream.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void InitializeFromStream(
    ISyntaxLanguage language,
    Stream stream
)
Public Sub InitializeFromStream (
    language As ISyntaxLanguage,
    stream As Stream
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The existing ISyntaxLanguage to initialize.
stream
Type: System.IOStream
The Stream from which to load.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


SyntaxLanguageDefinitionSerializer.LoadFromStream Method

SyntaxLanguageDefinitionSerializerLoadFromStream Method
Loads an ISyntaxLanguage from a language definition Stream.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISyntaxLanguage LoadFromStream(
    Stream stream
)
Public Function LoadFromStream (
    stream As Stream
) As ISyntaxLanguage

Parameters

stream
Type: System.IOStream
The Stream from which to load.

Return Value

Type: ISyntaxLanguage
The ISyntaxLanguage that was loaded.
See Also

Reference

SyntaxLanguageDefinitionSerializer Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Class

TextChangeOptions Class
Represents options that are applied to an ITextChange.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextChangeOptions
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditorViewTextChangeOptions

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextChangeOptions : ITextChangeOptions
Public Class TextChangeOptions
    Implements ITextChangeOptions

The TextChangeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TextChangeOptions | Initializes a new instance of the TextChangeOptions class.
Top
Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Constructor

TextChangeOptions Constructor
Initializes a new instance of the TextChangeOptions class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextChangeOptions()
Public Sub New
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Properties

TextChangeOptions Properties

The TextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack.
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified.
Top
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.CanMergeIntoPreviousChange Property

TextChangeOptionsCanMergeIntoPreviousChange Property
Gets or sets whether this text change can merge into the previous text change in the undo stack.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMergeIntoPreviousChange { get; set; }
Public Property CanMergeIntoPreviousChange As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this text change can merge into the previous text change in the undo stack; otherwise, false.

Implements

ITextChangeOptionsCanMergeIntoPreviousChange
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.CheckReadOnly Property

TextChangeOptionsCheckReadOnly Property
Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CheckReadOnly { get; set; }
Public Property CheckReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the read-only state should be checked; otherwise, false.

Implements

ITextChangeOptionsCheckReadOnly
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.CustomData Property

TextChangeOptionsCustomData Property
Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object CustomData { get; set; }
Public Property CustomData As Object
    Get
    Set

Property Value

Type: Object
The custom data.

Implements

ITextChangeOptionsCustomData
Remarks
This custom data is only persisted for the root text change of a set of operations.
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.OffsetDelta Property

TextChangeOptionsOffsetDelta Property
Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextChangeOffsetDelta OffsetDelta { get; set; }
Public Property OffsetDelta As TextChangeOffsetDelta
    Get
    Set

Property Value

Type: TextChangeOffsetDelta
A TextChangeOffsetDelta value indicating how to apply offset deltas, if at all.

Implements

ITextChangeOptionsOffsetDelta
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.RetainSelection Property

TextChangeOptionsRetainSelection Property
Gets or sets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool RetainSelection { get; set; }
Public Property RetainSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.

Implements

ITextChangeOptionsRetainSelection
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions.Source Property

TextChangeOptionsSource Property
Gets or sets the optional source of the text change, which is most often an editor view if specified.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Source { get; set; }
Public Property Source As Object
    Get
    Set

Property Value

Type: Object
The optional source of the text change, which is most often an editor view if specified.

Implements

ITextChangeOptionsSource
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextChangeOptions Methods

TextChangeOptions Methods

The TextChangeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextChangeOptions Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Class

TextDocumentBase Class
Represents a text document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextDocumentBase
ActiproSoftware.Text.ImplementationCodeDocument

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TextDocumentBase : ITextDocument,
    INotifyPropertyChanged
Public MustInherit Class TextDocumentBase
    Implements ITextDocument, INotifyPropertyChanged

The TextDocumentBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TextDocumentBase | Initializes a new instance of the TextDocumentBase class.
Top
Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.
Public method | GetType | (Inherited from Object.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile | Loads document text from a Stream using the specified encoding.
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding.
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Protected method | OnFileNameChanged | Raises the FileNameChanged event.
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event.
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event.
Protected method | OnTextChanged | Raises the TextChanged event.
Protected method | OnTextChanging | Raises the TextChanging event.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile | Saves document text to a Stream using the specified encoding.
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile.
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | PropertyChanged | Occurs when a property value is changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Constructor

TextDocumentBase Constructor
Initializes a new instance of the TextDocumentBase class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TextDocumentBase()
Protected Sub New
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Properties

TextDocumentBase Properties

The TextDocumentBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoCharacterCasing | Gets or sets how to modify the case of text that is inserted into the document.
Public property | AutoConvertTabsToSpaces | Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.
Public property | CurrentSnapshot | Gets the ITextSnapshot that contains the current text of the document.
Public property | FileName | Gets or sets the name of the file currently loaded in the document.
Public property | IsModified | Gets or sets whether the document has been modified.
Public property | IsReadOnly | Gets or sets whether the entire document is flagged as read-only.
Public property | TabSize | Gets or sets the distance in spaces between tab stops.
Public property | UndoHistory | Gets an IUndoHistory that provides access to undo and redo functionality for the document.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AutoCharacterCasing Property

TextDocumentBaseAutoCharacterCasing Property
Gets or sets how to modify the case of text that is inserted into the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharacterCasing AutoCharacterCasing { get; set; }
Public Property AutoCharacterCasing As CharacterCasing
    Get
    Set

Property Value

Type: CharacterCasing
A CharacterCasing indicating the desired case of inserted text.

Implements

ITextDocumentAutoCharacterCasing
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AutoConvertTabsToSpaces Property

TextDocumentBaseAutoConvertTabsToSpaces Property
Gets or sets whether to convert tabs to spaces when the Tab key is pressed or indenting occurs.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AutoConvertTabsToSpaces { get; set; }
Public Property AutoConvertTabsToSpaces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs should be converted to spaces when the Tab key is pressed or indenting occurs; otherwise, false. The default value is false.

Implements

ITextDocumentAutoConvertTabsToSpaces
Remarks
The number of spaces inserted is indicated by the TabSize property.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.CurrentSnapshot Property

TextDocumentBaseCurrentSnapshot Property
Gets the ITextSnapshot that contains the current text of the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot CurrentSnapshot { get; }
Public ReadOnly Property CurrentSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that contains the current text of the document.

Implements

ITextDocumentCurrentSnapshot
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.FileName Property

TextDocumentBaseFileName Property
Gets or sets the name of the file currently loaded in the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The name of the file currently loaded in the document.

Implements

ITextDocumentFileName
Remarks
This property is automatically set whenever a [!:LoadFile(string)] overload is called that accepts a file path.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsModified Property

TextDocumentBaseIsModified Property
Gets or sets whether the document has been modified.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document has been modified; otherwise, false.

Implements

ITextDocumentIsModified
Remarks
This flag is reset to false when the ActiproSoftware.Text property is set, or when a [!:SaveFile(string,LineTerminator)] overload is used that accepts a path matching the current FileName property value.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsReadOnly Property

TextDocumentBaseIsReadOnly Property
Gets or sets whether the entire document is flagged as read-only.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the entire document is flagged as read-only; otherwise, false. The default value is false.

Implements

ITextDocumentIsReadOnly
Remarks
When read-only, the document's contents should not be editable.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TabSize Property

TextDocumentBaseTabSize Property
Gets or sets the distance in spaces between tab stops.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TabSize { get; set; }
Public Property TabSize As Integer
    Get
    Set

Property Value

Type: Int32
The distance in spaces between tab stops. The default value is 4 spaces.

Implements

ITextDocumentTabSize
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.UndoHistory Property

TextDocumentBaseUndoHistory Property
Gets an IUndoHistory that provides access to undo and redo functionality for the document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IUndoHistory UndoHistory { get; }
Public ReadOnly Property UndoHistory As IUndoHistory
    Get

Property Value

Type: IUndoHistory
An IUndoHistory that provides access to undo and redo functionality for the document.

Implements

ITextDocumentUndoHistory
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase Methods

TextDocumentBase Methods

The TextDocumentBase type exposes the following members.

Methods
 | Name | Description
Public method | AddTextChangedEventHandler | Adds an event handler for the TextChanged event using the specified priority level.
Public method | AddTextChangingEventHandler | Adds an event handler for the TextChanging event using the specified priority level.
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetReadOnlyRegions | Returns the collection of read-only region tag snapshot ranges.
Protected method | GetTextReplacementInsertText | Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.
Public method | GetType | (Inherited from Object.)
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | IsTextRangeReadOnly | Returns whether any character in the specified TextRange is flagged as read-only.
Public method | LoadFile | Loads document text from a Stream using the specified encoding.
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding.
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property's value has changed.
Protected method | OnFileNameChanged | Raises the FileNameChanged event.
Protected method | OnIsModifiedChanged | Raises the IsModifiedChanged event.
Protected method | OnIsReadOnlyChanged | Raises the IsReadOnlyChanged event.
Protected method | OnTabSizeChanged | Raises the TabSizeChanged event.
Protected method | OnTextChanged | Raises the TextChanged event.
Protected method | OnTextChanging | Raises the TextChanging event.
Public method | RemoveTextChangedEventHandler | Removes an event handler for the TextChanged event using the specified priority level.
Public method | RemoveTextChangingEventHandler | Removes an event handler for the TextChanging event using the specified priority level.
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | SaveFile | Saves document text to a Stream using the specified encoding.
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile.
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SetHeaderAndFooterText | Sets the HeaderText and FooterText, and creates a new snapshot with the results.
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AddTextChangedEventHandler Method

TextDocumentBaseAddTextChangedEventHandler Method
Adds an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub AddTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentAddTextChangedEventHandler(EventHandlerTextSnapshotChangedEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AddTextChangingEventHandler Method

TextDocumentBaseAddTextChangingEventHandler Method
Adds an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub AddTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentAddTextChangingEventHandler(EventHandlerTextSnapshotChangingEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AppendText Method

TextDocumentBaseAppendText Method
Overload List
 | Name | Description
Public method | AppendText(ITextChangeType, String) | Appends text to the end of the CurrentSnapshot text.
Public method | AppendText(ITextChangeType, String, ITextChangeOptions) | Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.AppendText Method (ITextChangeType, String)

TextDocumentBaseAppendText Method (ITextChangeType, String)
Appends text to the end of the CurrentSnapshot text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AppendText(
    ITextChangeType type,
    string text
)
Public Function AppendText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentAppendText(ITextChangeType, String)
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
AppendText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.AppendText Method (ITextChangeType, String, ITextChangeOptions)

TextDocumentBaseAppendText Method (ITextChangeType, String, ITextChangeOptions)
Appends text to the end of the CurrentSnapshot text and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AppendText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Public Function AppendText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to append to the current contents of the snapshot.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentAppendText(ITextChangeType, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds an append operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
AppendText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.CreateTextChange Method

TextDocumentBaseCreateTextChange Method
Overload List
 | Name | Description
Public method | CreateTextChange(ITextChangeType) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Public method | CreateTextChange(ITextChangeType, ITextChangeOptions) | Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.CreateTextChange Method (ITextChangeType)

TextDocumentBaseCreateTextChange Method (ITextChangeType)
Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextChange CreateTextChange(
    ITextChangeType type
)
Public Function CreateTextChange (
    type As ITextChangeType
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: ITextChange
The ITextChange that was created.

Implements

ITextDocumentCreateTextChange(ITextChangeType)
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

TextDocumentBase Class
CreateTextChange Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.CreateTextChange Method (ITextChangeType, ITextChangeOptions)

TextDocumentBaseCreateTextChange Method (ITextChangeType, ITextChangeOptions)
Creates an ITextChange based on the CurrentSnapshot, whereby any following calls to methods such as ITextChange.ReplaceText(Int32, Int32, String) are grouped into the text change as operations and sequentially executed upon a ITextChange.Apply call.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextChange CreateTextChange(
    ITextChangeType type,
    ITextChangeOptions options
)
Public Function CreateTextChange (
    type As ITextChangeType,
    options As ITextChangeOptions
) As ITextChange

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: ITextChange
The ITextChange that was created.

Implements

ITextDocumentCreateTextChange(ITextChangeType, ITextChangeOptions)
Remarks
The ITextChange.Apply method must be called to apply the queued operations to the document.
See Also

Reference

TextDocumentBase Class
CreateTextChange Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.DeleteText Method

TextDocumentBaseDeleteText Method
Overload List
 | Name | Description
Public method | DeleteText(ITextChangeType, TextRange) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, TextRange, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Public method | DeleteText(ITextChangeType, Int32, Int32) | Performs a delete text change in the CurrentSnapshot.
Public method | DeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions) | Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.DeleteText Method (ITextChangeType, TextRange)

TextDocumentBaseDeleteText Method (ITextChangeType, TextRange)
Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    TextRange textRange
)
Public Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, TextRange)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, TextRange, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.DeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)

TextDocumentBaseDeleteText Method (ITextChangeType, TextRange, ITextChangeOptions)
Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    TextRange textRange,
    ITextChangeOptions options
)
Public Function DeleteText (
    type As ITextChangeType,
    textRange As TextRange,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, TextRange, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.DeleteText Method (ITextChangeType, Int32, Int32)

TextDocumentBaseDeleteText Method (ITextChangeType, Int32, Int32)
Performs a delete text change in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    int offset,
    int length
)
Public Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, Int32, Int32)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.DeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)

TextDocumentBaseDeleteText Method (ITextChangeType, Int32, Int32, ITextChangeOptions)
Performs a delete text change in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool DeleteText(
    ITextChangeType type,
    int offset,
    int length,
    ITextChangeOptions options
)
Public Function DeleteText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The starting offset at which to delete.
length
Type: SystemInt32
The number of characters to delete.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a delete operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
DeleteText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.GetReadOnlyRegions Method

TextDocumentBaseGetReadOnlyRegions Method
Returns the collection of read-only region tag snapshot ranges.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IEnumerable<TagSnapshotRange<IReadOnlyRegionTag>> GetReadOnlyRegions(
    TextRange textRange
)
Protected Overridable Function GetReadOnlyRegions (
    textRange As TextRange
) As IEnumerable(Of TagSnapshotRange(Of IReadOnlyRegionTag))

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The text range relative to the current snapshot for which to locate read-only regions.

Return Value

Type: IEnumerable TagSnapshotRange IReadOnlyRegionTag
The collection of read-only region tag snapshot ranges.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.GetTextReplacementInsertText Method

TextDocumentBaseGetTextReplacementInsertText Method
Returns the scrubbed text that should be inserted for an entire text replacement ITextChangeOperation.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string GetTextReplacementInsertText(
    ITextChangeOperation operation
)
Protected Overridable Function GetTextReplacementInsertText (
    operation As ITextChangeOperation
) As String

Parameters

operation
Type: ActiproSoftware.TextITextChangeOperation
The ITextChangeOperation contanining default text to insert.

Return Value

Type: String
The text to insert.
Remarks
This method can be overridden to scrub the text to insert, such as remove trailing whitespace, etc. By default it returns a , meaning to use the unscrubbed InsertedText value.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.InsertText Method

TextDocumentBaseInsertText Method
Overload List
 | Name | Description
Public method | InsertText(ITextChangeType, Int32, String) | Performs an insert text change in the CurrentSnapshot at the specified offset.
Public method | InsertText(ITextChangeType, Int32, String, ITextChangeOptions) | Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.InsertText Method (ITextChangeType, Int32, String)

TextDocumentBaseInsertText Method (ITextChangeType, Int32, String)
Performs an insert text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool InsertText(
    ITextChangeType type,
    int offset,
    string text
)
Public Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentInsertText(ITextChangeType, Int32, String)
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
InsertText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.InsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)

TextDocumentBaseInsertText Method (ITextChangeType, Int32, String, ITextChangeOptions)
Performs an insert text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool InsertText(
    ITextChangeType type,
    int offset,
    string text,
    ITextChangeOptions options
)
Public Function InsertText (
    type As ITextChangeType,
    offset As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds an insert operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
InsertText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.IsTextRangeReadOnly Method

TextDocumentBaseIsTextRangeReadOnly Method
Returns whether any character in the specified TextRange is flagged as read-only.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTextRangeReadOnly(
    TextRange textRange
)
Public Function IsTextRangeReadOnly (
    textRange As TextRange
) As Boolean

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange to examine.

Return Value

Type: Boolean
true if any character in the specified TextRange is flagged as read-only; otherwise, false.

Implements

ITextDocumentIsTextRangeReadOnly(TextRange)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFile Method

TextDocumentBaseLoadFile Method
Loads document text from a Stream using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LineTerminator LoadFile(
    Stream stream,
    Encoding encoding
)
Public Function LoadFile (
    stream As Stream,
    encoding As Encoding
) As LineTerminator

Parameters

stream
Type: System.IOStream
The Stream from which to load.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFile(Stream, Encoding)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFileAsync Method

TextDocumentBaseLoadFileAsync Method
Overload List
 | Name | Description
Public method | LoadFileAsync(IStorageFile) | Loads document text from an IStorageFile, using the file's character encoding.
Public method | LoadFileAsync(IStorageFile, Encoding) | Loads document text from an IStorageFile, using the specified encoding.
Public method | LoadFileAsync(IStorageFile, UnicodeEncoding) | Loads document text from an IStorageFile, using the specified encoding.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFileAsync Method (IStorageFile)

TextDocumentBaseLoadFileAsync Method (IStorageFile)
Loads document text from an IStorageFile, using the file's character encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<LineTerminator> LoadFileAsync(
    IStorageFile file
)
Public Function LoadFileAsync (
    file As IStorageFile
) As Task(Of LineTerminator)

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to examine.

Return Value

Type: Task LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFileAsync(IStorageFile)
Remarks
This method updates the value of the FileName property.
See Also

Reference

TextDocumentBase Class
LoadFileAsync Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFileAsync Method (IStorageFile, Encoding)

TextDocumentBaseLoadFileAsync Method (IStorageFile, Encoding)
Loads document text from an IStorageFile, using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<LineTerminator> LoadFileAsync(
    IStorageFile file,
    Encoding encoding
)
Public Function LoadFileAsync (
    file As IStorageFile,
    encoding As Encoding
) As Task(Of LineTerminator)

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to examine.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.

Return Value

Type: Task LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFileAsync(IStorageFile, Encoding)
Remarks
This method updates the value of the FileName property.
See Also

Reference

TextDocumentBase Class
LoadFileAsync Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.LoadFileAsync Method (IStorageFile, UnicodeEncoding)

TextDocumentBaseLoadFileAsync Method (IStorageFile, UnicodeEncoding)
Loads document text from an IStorageFile, using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<LineTerminator> LoadFileAsync(
    IStorageFile file,
    UnicodeEncoding encoding
)
Public Function LoadFileAsync (
    file As IStorageFile,
    encoding As UnicodeEncoding
) As Task(Of LineTerminator)

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to examine.
encoding
Type: Windows.Storage.StreamsUnicodeEncoding
The UnicodeEncoding to use when loading the file.

Return Value

Type: Task LineTerminator
A LineTerminator indicating the line terminator of the file that was loaded.

Implements

ITextDocumentLoadFileAsync(IStorageFile, UnicodeEncoding)
Remarks
This method updates the value of the FileName property.
See Also

Reference

TextDocumentBase Class
LoadFileAsync Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.NotifyPropertyChanged Method

TextDocumentBaseNotifyPropertyChanged Method
Notifies that a property's value has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string name
)
Protected Sub NotifyPropertyChanged (
    name As String
)

Parameters

name
Type: SystemString
The name of the property.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnFileNameChanged Method

TextDocumentBaseOnFileNameChanged Method
Raises the FileNameChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnFileNameChanged(
    StringPropertyChangedEventArgs e
)
Protected Overridable Sub OnFileNameChanged (
    e As StringPropertyChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
An StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnIsModifiedChanged Method

TextDocumentBaseOnIsModifiedChanged Method
Raises the IsModifiedChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIsModifiedChanged(
    EventArgs e
)
Protected Overridable Sub OnIsModifiedChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnIsReadOnlyChanged Method

TextDocumentBaseOnIsReadOnlyChanged Method
Raises the IsReadOnlyChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIsReadOnlyChanged(
    EventArgs e
)
Protected Overridable Sub OnIsReadOnlyChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnTabSizeChanged Method

TextDocumentBaseOnTabSizeChanged Method
Raises the TabSizeChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTabSizeChanged(
    EventArgs e
)
Protected Overridable Sub OnTabSizeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnTextChanged Method

TextDocumentBaseOnTextChanged Method
Raises the TextChanged event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTextChanged(
    TextSnapshotChangedEventArgs e
)
Protected Overridable Sub OnTextChanged (
    e As TextSnapshotChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.TextTextSnapshotChangedEventArgs
A TextSnapshotChangedEventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.OnTextChanging Method

TextDocumentBaseOnTextChanging Method
Raises the TextChanging event.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTextChanging(
    TextSnapshotChangingEventArgs e
)
Protected Overridable Sub OnTextChanging (
    e As TextSnapshotChangingEventArgs
)

Parameters

e
Type: ActiproSoftware.TextTextSnapshotChangingEventArgs
A TextSnapshotChangingEventArgs that contains the event data.
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.RemoveTextChangedEventHandler Method

TextDocumentBaseRemoveTextChangedEventHandler Method
Removes an event handler for the TextChanged event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveTextChangedEventHandler(
    EventHandler<TextSnapshotChangedEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub RemoveTextChangedEventHandler (
    handler As EventHandler(Of TextSnapshotChangedEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangedEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentRemoveTextChangedEventHandler(EventHandlerTextSnapshotChangedEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.RemoveTextChangingEventHandler Method

TextDocumentBaseRemoveTextChangingEventHandler Method
Removes an event handler for the TextChanging event using the specified priority level.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveTextChangingEventHandler(
    EventHandler<TextSnapshotChangingEventArgs> handler,
    EventHandlerPriority priority
)
Public Sub RemoveTextChangingEventHandler (
    handler As EventHandler(Of TextSnapshotChangingEventArgs),
    priority As EventHandlerPriority
)

Parameters

handler
Type: SystemEventHandler TextSnapshotChangingEventArgs
The delegate handler.
priority
Type: ActiproSoftware.Text.UtilityEventHandlerPriority
A EventHandlerPriority specifying the priority level.

Implements

ITextDocumentRemoveTextChangingEventHandler(EventHandlerTextSnapshotChangingEventArgs, EventHandlerPriority)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceAll Method

TextDocumentBaseReplaceAll Method
Overload List
 | Name | Description
Public method | ReplaceAll(ISearchOptions) | Performs a replace all operation in the CurrentSnapshot.
Public method | ReplaceAll(ISearchOptions, TextRange) | Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceAll Method (ISearchOptions)

TextDocumentBaseReplaceAll Method (ISearchOptions)
Performs a replace all operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceAll(
    ISearchOptions options
)
Public Function ReplaceAll (
    options As ISearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceAll(ISearchOptions)
See Also

Reference

TextDocumentBase Class
ReplaceAll Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceAll Method (ISearchOptions, TextRange[])

TextDocumentBaseReplaceAll Method (ISearchOptions, TextRange)
Performs a replace all operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceAll(
    ISearchOptions options,
    params TextRange[] searchTextRanges
)
Public Function ReplaceAll (
    options As ISearchOptions,
    ParamArray searchTextRanges As TextRange()
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRanges
Type: ActiproSoftware.TextTextRange
The TextRange array of offsets to search. If everything should be searched, specify the range 0 to the length of the document's current snapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceAll(ISearchOptions, TextRange)
See Also

Reference

TextDocumentBase Class
ReplaceAll Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceNext Method

TextDocumentBaseReplaceNext Method
Overload List
 | Name | Description
Public method | ReplaceNext(ISearchOptions, Int32, Boolean) | Performs a replace next operation in the CurrentSnapshot.
Public method | ReplaceNext(ISearchOptions, Int32, Boolean, TextRange) | Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceNext Method (ISearchOptions, Int32, Boolean)

TextDocumentBaseReplaceNext Method (ISearchOptions, Int32, Boolean)
Performs a replace next operation in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap
)
Public Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceNext(ISearchOptions, Int32, Boolean)
See Also

Reference

TextDocumentBase Class
ReplaceNext Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)

TextDocumentBaseReplaceNext Method (ISearchOptions, Int32, Boolean, TextRange)
Performs a replace next operation in the CurrentSnapshot over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchResultSet ReplaceNext(
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Public Function ReplaceNext (
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.

Implements

ITextDocumentReplaceNext(ISearchOptions, Int32, Boolean, TextRange)
See Also

Reference

TextDocumentBase Class
ReplaceNext Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceText Method

TextDocumentBaseReplaceText Method
Overload List
 | Name | Description
Public method | ReplaceText(ITextChangeType, TextRange, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String) | Performs a replace text change in the CurrentSnapshot at the specified offset.
Public method | ReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions) | Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.ReplaceText Method (ITextChangeType, TextRange, String)

TextDocumentBaseReplaceText Method (ITextChangeType, TextRange, String)
Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text
)
Public Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, TextRange, String)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, TextRange)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.ReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)

TextDocumentBaseReplaceText Method (ITextChangeType, TextRange, String, ITextChangeOptions)
Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    TextRange textRange,
    string text,
    ITextChangeOptions options
)
Public Function ReplaceText (
    type As ITextChangeType,
    textRange As TextRange,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
textRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to delete.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, TextRange, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, TextRange, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.ReplaceText Method (ITextChangeType, Int32, Int32, String)

TextDocumentBaseReplaceText Method (ITextChangeType, Int32, Int32, String)
Performs a replace text change in the CurrentSnapshot at the specified offset.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text
)
Public Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseSetText(ITextChangeType, String)


TextDocumentBase.ReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)

TextDocumentBaseReplaceText Method (ITextChangeType, Int32, Int32, String, ITextChangeOptions)
Performs a replace text change in the CurrentSnapshot at the specified offset and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ReplaceText(
    ITextChangeType type,
    int offset,
    int length,
    string text,
    ITextChangeOptions options
)
Public Function ReplaceText (
    type As ITextChangeType,
    offset As Integer,
    length As Integer,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
offset
Type: SystemInt32
The offset at which to insert.
length
Type: SystemInt32
The number of characters to delete before inserting the text.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a replace operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
ReplaceText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.SaveFile Method

TextDocumentBaseSaveFile Method
Saves document text to a Stream using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SaveFile(
    Stream stream,
    Encoding encoding,
    LineTerminator lineTerminator
)
Public Sub SaveFile (
    stream As Stream,
    encoding As Encoding,
    lineTerminator As LineTerminator
)

Parameters

stream
Type: System.IOStream
The Stream to write to.
encoding
Type: System.TextEncoding
The Encoding to use when loading the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Implements

ITextDocumentSaveFile(Stream, Encoding, LineTerminator)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFileAsync Method

TextDocumentBaseSaveFileAsync Method
Overload List
 | Name | Description
Public method | SaveFileAsync(IStorageFile, LineTerminator) | Saves document text to an IStorageFile.
Public method | SaveFileAsync(IStorageFile, Encoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Public method | SaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator) | Saves document text to an IStorageFile using the specified encoding.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFileAsync Method (IStorageFile, LineTerminator)

TextDocumentBaseSaveFileAsync Method (IStorageFile, LineTerminator)
Saves document text to an IStorageFile.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task SaveFileAsync(
    IStorageFile file,
    LineTerminator lineTerminator
)
Public Function SaveFileAsync (
    file As IStorageFile,
    lineTerminator As LineTerminator
) As Task

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to update.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Implementation.TextDocumentBase.SaveFileAsync(Windows.Storage.IStorageFile,ActiproSoftware.Text.LineTerminator)"]

Implements

ITextDocumentSaveFileAsync(IStorageFile, LineTerminator)
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

TextDocumentBase Class
SaveFileAsync Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFileAsync Method (IStorageFile, Encoding, LineTerminator)

TextDocumentBaseSaveFileAsync Method (IStorageFile, Encoding, LineTerminator)
Saves document text to an IStorageFile using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task SaveFileAsync(
    IStorageFile file,
    Encoding encoding,
    LineTerminator lineTerminator
)
Public Function SaveFileAsync (
    file As IStorageFile,
    encoding As Encoding,
    lineTerminator As LineTerminator
) As Task

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to update.
encoding
Type: System.TextEncoding
The Encoding to use when saving the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Implementation.TextDocumentBase.SaveFileAsync(Windows.Storage.IStorageFile,System.Text.Encoding,ActiproSoftware.Text.LineTerminator)"]

Implements

ITextDocumentSaveFileAsync(IStorageFile, Encoding, LineTerminator)
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

TextDocumentBase Class
SaveFileAsync Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SaveFileAsync Method (IStorageFile, UnicodeEncoding, LineTerminator)

TextDocumentBaseSaveFileAsync Method (IStorageFile, UnicodeEncoding, LineTerminator)
Saves document text to an IStorageFile using the specified encoding.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task SaveFileAsync(
    IStorageFile file,
    UnicodeEncoding encoding,
    LineTerminator lineTerminator
)
Public Function SaveFileAsync (
    file As IStorageFile,
    encoding As UnicodeEncoding,
    lineTerminator As LineTerminator
) As Task

Parameters

file
Type: Windows.StorageIStorageFile
The IStorageFile to update.
encoding
Type: Windows.Storage.StreamsUnicodeEncoding
The UnicodeEncoding to use when saving the file.
lineTerminator
Type: ActiproSoftware.TextLineTerminator
A LineTerminator specifying the output format.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Implementation.TextDocumentBase.SaveFileAsync(Windows.Storage.IStorageFile,Windows.Storage.Streams.UnicodeEncoding,ActiproSoftware.Text.LineTerminator)"]

Implements

ITextDocumentSaveFileAsync(IStorageFile, UnicodeEncoding, LineTerminator)
Remarks
The IsModified property is set to false if the specified file path is the same as the FileName property's current value.
See Also

Reference

TextDocumentBase Class
SaveFileAsync Overload
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SetHeaderAndFooterText Method

TextDocumentBaseSetHeaderAndFooterText Method
Sets the HeaderText and FooterText, and creates a new snapshot with the results.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SetHeaderAndFooterText(
    string headerText,
    string footerText
)
Public Function SetHeaderAndFooterText (
    headerText As String,
    footerText As String
) As Boolean

Parameters

headerText
Type: SystemString
The new header text value.
footerText
Type: SystemString
The new footer text value.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetHeaderAndFooterText(String, String)
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SetText Method

TextDocumentBaseSetText Method
Overload List
 | Name | Description
Public method | SetText(String) | Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.
Public method | SetText(ITextChangeType, String) | Replaces all the text in the CurrentSnapshot.
Public method | SetText(ITextChangeType, String, ITextChangeOptions) | Replaces all the text in the CurrentSnapshot and allows for the specification of other options.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.SetText Method (String)

TextDocumentBaseSetText Method (String)
Replaces all the text in the CurrentSnapshot and marks the operation as a programmatic replacement.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SetText(
    string text
)
Public Function SetText (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetText(String)
Remarks
A programmatic text replacement means that the undo history will be cleared, and any attached editors will reset the caret to offset 0.

This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.

See Also

Reference

TextDocumentBase Class
SetText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseSetText(ITextChangeType, String)
TextDocumentBaseSetText(ITextChangeType, String, ITextChangeOptions)


TextDocumentBase.SetText Method (ITextChangeType, String)

TextDocumentBaseSetText Method (ITextChangeType, String)
Replaces all the text in the CurrentSnapshot.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SetText(
    ITextChangeType type,
    string text
)
Public Function SetText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetText(ITextChangeType, String)
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
SetText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32)
TextDocumentBaseInsertText(ITextChangeType, Int32, String)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String)


TextDocumentBase.SetText Method (ITextChangeType, String, ITextChangeOptions)

TextDocumentBaseSetText Method (ITextChangeType, String, ITextChangeOptions)
Replaces all the text in the CurrentSnapshot and allows for the specification of other options.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SetText(
    ITextChangeType type,
    string text,
    ITextChangeOptions options
)
Public Function SetText (
    type As ITextChangeType,
    text As String,
    options As ITextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert. Pass an empty string to "clear" the snapshot text.
options
Type: ActiproSoftware.TextITextChangeOptions
The ITextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.

Implements

ITextDocumentSetText(ITextChangeType, String, ITextChangeOptions)
Remarks
This method creates an ITextChange for the current snapshot, adds a set text operation, and immediately applies it. If you will be executing multiple text change operations in a row, for improved performance it is recommended that you call the CreateTextChange(ITextChangeType, ITextChangeOptions) method instead, add operations to the returned ITextChange, and then apply the text change.
See Also

Reference

TextDocumentBase Class
SetText Overload
ActiproSoftware.Text.Implementation Namespace
TextDocumentBaseAppendText(ITextChangeType, String, ITextChangeOptions)
TextDocumentBaseDeleteText(ITextChangeType, Int32, Int32, ITextChangeOptions)
TextDocumentBaseInsertText(ITextChangeType, Int32, String, ITextChangeOptions)
TextDocumentBaseReplaceText(ITextChangeType, Int32, Int32, String, ITextChangeOptions)


TextDocumentBase Events

TextDocumentBase Events

The TextDocumentBase type exposes the following members.

Events
 | Name | Description
Public event | FileNameChanged | Occurs after the value of the FileName property has changed.
Public event | IsModifiedChanged | Occurs after the value of the IsModified property has changed.
Public event | IsReadOnlyChanged | Occurs after the value of the IsReadOnly property has changed.
Public event | PropertyChanged | Occurs when a property value is changed.
Public event | TabSizeChanged | Occurs after the value of the TabSize property has changed.
Public event | TextChanged | Occurs after a text change occurs to this document.
Public event | TextChanging | Occurs before a text change occurs to this document.
Top
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.FileNameChanged Event

TextDocumentBaseFileNameChanged Event
Occurs after the value of the FileName property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<StringPropertyChangedEventArgs> FileNameChanged
Public Event FileNameChanged As EventHandler(Of StringPropertyChangedEventArgs)

Value

Type: SystemEventHandler StringPropertyChangedEventArgs

Implements

ITextDocumentFileNameChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsModifiedChanged Event

TextDocumentBaseIsModifiedChanged Event
Occurs after the value of the IsModified property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler IsModifiedChanged
Public Event IsModifiedChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ITextDocumentIsModifiedChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.IsReadOnlyChanged Event

TextDocumentBaseIsReadOnlyChanged Event
Occurs after the value of the IsReadOnly property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler IsReadOnlyChanged
Public Event IsReadOnlyChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ITextDocumentIsReadOnlyChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.PropertyChanged Event

TextDocumentBasePropertyChanged Event
Occurs when a property value is changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TabSizeChanged Event

TextDocumentBaseTabSizeChanged Event
Occurs after the value of the TabSize property has changed.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler TabSizeChanged
Public Event TabSizeChanged As EventHandler

Value

Type: SystemEventHandler

Implements

ITextDocumentTabSizeChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TextChanged Event

TextDocumentBaseTextChanged Event
Occurs after a text change occurs to this document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TextSnapshotChangedEventArgs> TextChanged
Public Event TextChanged As EventHandler(Of TextSnapshotChangedEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangedEventArgs

Implements

ITextDocumentTextChanged
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextDocumentBase.TextChanging Event

TextDocumentBaseTextChanging Event
Occurs before a text change occurs to this document.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TextSnapshotChangingEventArgs> TextChanging
Public Event TextChanging As EventHandler(Of TextSnapshotChangingEventArgs)

Value

Type: SystemEventHandler TextSnapshotChangingEventArgs

Implements

ITextDocumentTextChanging
See Also

Reference

TextDocumentBase Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics Class

TextStatistics Class
Provides numerous statistics such as line, word, character counts, and readability scores for text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationTextStatistics

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextStatistics : ITextStatistics
Public Class TextStatistics
    Implements ITextStatistics

The TextStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | TextStatistics | Initializes a new instance of the TextStatistics class.
Top
Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
Methods
 | Name | Description
 | CreateStatistic | Creates an ITextStatistic with the specified key and value.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Implementation Namespace


TextStatistics Constructor

TextStatistics Constructor
Initializes a new instance of the TextStatistics class.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextStatistics(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text to examine and create statistics data.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics Properties

TextStatistics Properties

The TextStatistics type exposes the following members.

Properties
 | Name | Description
Public property | AverageLettersPerWord | Gets the average number of letters per word.
Public property | AverageSyllablesPerWord | Gets the average number of syllables per word.
Public property | AverageWordsPerSentence | Gets the average number of words per sentence.
Public property | Characters | Gets the number of characters in the text.
Public property | Consonants | Gets the number of consonants in the text.
Public property | FleschKincaidGradeLevel | Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.
Public property | FleschReadingEaseScore | Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.
Public property | Letters | Gets the number of letters in the text.
Public property | Lines | Gets the number of lines in the text.
Public property | NonWhitespaceCharacters | Gets the number of non-whitespace characters in the text.
Public property | NonWhitespaceLines | Gets the number of non-whitespace lines in the text.
Public property | Sentences | Gets the number of sentences in the text.
Public property | Syllables | Gets the number of syllables in the text.
Public property | Vowels | Gets the number of vowels in the text.
Public property | WhitespaceCharacters | Gets the number of whitespace characters in the text.
Public property | WhitespaceLines | Gets the number of whitespace lines in the text.
Public property | Words | Gets the number of words in the text.
Top
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.AverageLettersPerWord Property

TextStatisticsAverageLettersPerWord Property
Gets the average number of letters per word.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AverageLettersPerWord { get; }
Public ReadOnly Property AverageLettersPerWord As Double
    Get

Property Value

Type: Double
The average number of letters per word.

Implements

ITextStatisticsAverageLettersPerWord
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.AverageSyllablesPerWord Property

TextStatisticsAverageSyllablesPerWord Property
Gets the average number of syllables per word.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AverageSyllablesPerWord { get; }
Public ReadOnly Property AverageSyllablesPerWord As Double
    Get

Property Value

Type: Double
The average number of syllables per word.

Implements

ITextStatisticsAverageSyllablesPerWord
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.AverageWordsPerSentence Property

TextStatisticsAverageWordsPerSentence Property
Gets the average number of words per sentence.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AverageWordsPerSentence { get; }
Public ReadOnly Property AverageWordsPerSentence As Double
    Get

Property Value

Type: Double
The average number of words per sentence.

Implements

ITextStatisticsAverageWordsPerSentence
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Characters Property

TextStatisticsCharacters Property
Gets the number of characters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Characters { get; }
Public ReadOnly Property Characters As Integer
    Get

Property Value

Type: Int32
The number of characters in the text.

Implements

ITextStatisticsCharacters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Consonants Property

TextStatisticsConsonants Property
Gets the number of consonants in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Consonants { get; }
Public ReadOnly Property Consonants As Integer
    Get

Property Value

Type: Int32
The number of consonants in the text.

Implements

ITextStatisticsConsonants
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.FleschKincaidGradeLevel Property

TextStatisticsFleschKincaidGradeLevel Property
Gets the Flesch-Kincaid grade level, which indicates the number of years of education required to understand the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double FleschKincaidGradeLevel { get; }
Public ReadOnly Property FleschKincaidGradeLevel As Double
    Get

Property Value

Type: Double

Implements

ITextStatisticsFleschKincaidGradeLevel
Remarks
A grade level of 7.1 indicates that an individual with about 7 years of education could understand the text.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.FleschReadingEaseScore Property

TextStatisticsFleschReadingEaseScore Property
Gets the Flesch reading ease score in the range of 0 to 100, which indicates how readable the text is.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double FleschReadingEaseScore { get; }
Public ReadOnly Property FleschReadingEaseScore As Double
    Get

Property Value

Type: Double

Implements

ITextStatisticsFleschReadingEaseScore
Remarks
Scores of 90-100 are considered easily understandable by an average 5th grader. Scores of 60-70 are considered easily understandable by 8th and 9th grade students. Scores of 0-30 are best understood by college graduates.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Letters Property

TextStatisticsLetters Property
Gets the number of letters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Letters { get; }
Public ReadOnly Property Letters As Integer
    Get

Property Value

Type: Int32
The number of letters in the text.

Implements

ITextStatisticsLetters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Lines Property

TextStatisticsLines Property
Gets the number of lines in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Lines { get; }
Public ReadOnly Property Lines As Integer
    Get

Property Value

Type: Int32
The number of lines in the text.

Implements

ITextStatisticsLines
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.NonWhitespaceCharacters Property

TextStatisticsNonWhitespaceCharacters Property
Gets the number of non-whitespace characters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int NonWhitespaceCharacters { get; }
Public ReadOnly Property NonWhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace characters in the text.

Implements

ITextStatisticsNonWhitespaceCharacters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.NonWhitespaceLines Property

TextStatisticsNonWhitespaceLines Property
Gets the number of non-whitespace lines in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int NonWhitespaceLines { get; }
Public ReadOnly Property NonWhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of non-whitespace lines in the text.

Implements

ITextStatisticsNonWhitespaceLines
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Sentences Property

TextStatisticsSentences Property
Gets the number of sentences in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Sentences { get; }
Public ReadOnly Property Sentences As Integer
    Get

Property Value

Type: Int32
The number of sentences in the text.

Implements

ITextStatisticsSentences
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Syllables Property

TextStatisticsSyllables Property
Gets the number of syllables in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Syllables { get; }
Public ReadOnly Property Syllables As Integer
    Get

Property Value

Type: Int32
The number of syllables in the text.

Implements

ITextStatisticsSyllables
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Vowels Property

TextStatisticsVowels Property
Gets the number of vowels in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Vowels { get; }
Public ReadOnly Property Vowels As Integer
    Get

Property Value

Type: Int32
The number of vowels in the text.

Implements

ITextStatisticsVowels
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.WhitespaceCharacters Property

TextStatisticsWhitespaceCharacters Property
Gets the number of whitespace characters in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int WhitespaceCharacters { get; }
Public ReadOnly Property WhitespaceCharacters As Integer
    Get

Property Value

Type: Int32
The number of whitespace characters in the text.

Implements

ITextStatisticsWhitespaceCharacters
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.WhitespaceLines Property

TextStatisticsWhitespaceLines Property
Gets the number of whitespace lines in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int WhitespaceLines { get; }
Public ReadOnly Property WhitespaceLines As Integer
    Get

Property Value

Type: Int32
The number of whitespace lines in the text.

Implements

ITextStatisticsWhitespaceLines
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.Words Property

TextStatisticsWords Property
Gets the number of words in the text.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Words { get; }
Public ReadOnly Property Words As Integer
    Get

Property Value

Type: Int32
The number of words in the text.

Implements

ITextStatisticsWords
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics Methods

TextStatistics Methods

The TextStatistics type exposes the following members.

Methods
 | Name | Description
 | CreateStatistic | Creates an ITextStatistic with the specified key and value.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRawStatistics | Returns the list of ITextStatistic objects that contain the statistic results.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.CreateStatistic Method

TextStatisticsCreateStatistic Method
Creates an ITextStatistic with the specified key and value.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITextStatistic CreateStatistic(
    string key,
    string description,
    Object value
)
Public Shared Function CreateStatistic (
    key As String,
    description As String,
    value As Object
) As ITextStatistic

Parameters

key
Type: SystemString
The key of the statistic.
description
Type: SystemString
The description of the statistic, generally displayed in the user interface.
value
Type: SystemObject
The value of the statistic.

Return Value

Type: ITextStatistic
The ITextStatistic that was created.
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


TextStatistics.GetRawStatistics Method

TextStatisticsGetRawStatistics Method
Returns the list of ITextStatistic objects that contain the statistic results.

Namespace: ActiproSoftware.Text.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IList<ITextStatistic> GetRawStatistics()
Public Overridable Function GetRawStatistics As IList(Of ITextStatistic)

Return Value

Type: IList ITextStatistic
The list of ITextStatistic objects that contain the statistic results.

Implements

ITextStatisticsGetRawStatistics
See Also

Reference

TextStatistics Class
ActiproSoftware.Text.Implementation Namespace


ActiproSoftware.Text.Languages.CSharp Namespace

ActiproSoftware.Text.Languages.CSharp Namespace
Contains the classes related to implementing a C# syntax language.
Classes
 | Class | Description
Public class | CSharpContextLocations | Contains common context locations for a C# language.
Interfaces
 | Interface | Description
Public interface | ICSharpGrammarOptions | Contains options for a C# grammar.


CSharpContextLocations Class

CSharpContextLocations Class
Contains common context locations for a C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharpCSharpContextLocations

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class CSharpContextLocations
Public NotInheritable Class CSharpContextLocations

The CSharpContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
LocalVariableType | Gets the IDotNetContextLocation that represents a local variable type name specification.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
ReturnType | Gets the IDotNetContextLocation that represents a return type name specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespace | Gets the IDotNetContextLocation that represents a namespace specification within a using directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations Properties

CSharpContextLocations Properties

The CSharpContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
LocalVariableType | Gets the IDotNetContextLocation that represents a local variable type name specification.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
ReturnType | Gets the IDotNetContextLocation that represents a return type name specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespace | Gets the IDotNetContextLocation that represents a namespace specification within a using directive.
Top
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.Attribute Property

CSharpContextLocationsAttribute Property
Gets the IDotNetContextLocation that represents an attribute specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Attribute { get; }
Public Shared ReadOnly Property Attribute As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.Comment Property

CSharpContextLocationsComment Property
Gets the IDotNetContextLocation that represents a comment specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Comment { get; }
Public Shared ReadOnly Property Comment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.DocumentationComment Property

CSharpContextLocationsDocumentationComment Property
Gets the IDotNetContextLocation that represents a documentation comment specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation DocumentationComment { get; }
Public Shared ReadOnly Property DocumentationComment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ExpressionStart Property

CSharpContextLocationsExpressionStart Property
Gets the IDotNetContextLocation that represents an expression start specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ExpressionStart { get; }
Public Shared ReadOnly Property ExpressionStart As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ImplicitLocalVariableType Property

CSharpContextLocationsImplicitLocalVariableType Property
Gets the IDotNetContextLocation that represents an implicit local variable type.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ImplicitLocalVariableType { get; }
Public Shared ReadOnly Property ImplicitLocalVariableType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.LiteralCharacter Property

CSharpContextLocationsLiteralCharacter Property
Gets the IDotNetContextLocation that represents a literal character specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralCharacter { get; }
Public Shared ReadOnly Property LiteralCharacter As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.LiteralString Property

CSharpContextLocationsLiteralString Property
Gets the IDotNetContextLocation that represents a literal string specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralString { get; }
Public Shared ReadOnly Property LiteralString As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.LocalVariableType Property

CSharpContextLocationsLocalVariableType Property
Gets the IDotNetContextLocation that represents a local variable type name specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LocalVariableType { get; }
Public Shared ReadOnly Property LocalVariableType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ObjectCreationExpressionType Property

CSharpContextLocationsObjectCreationExpressionType Property
Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ObjectCreationExpressionType { get; }
Public Shared ReadOnly Property ObjectCreationExpressionType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.PreprocessorDirective Property

CSharpContextLocationsPreprocessorDirective Property
Gets the IDotNetContextLocation that represents a preprocessor directive specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation PreprocessorDirective { get; }
Public Shared ReadOnly Property PreprocessorDirective As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.ReturnType Property

CSharpContextLocationsReturnType Property
Gets the IDotNetContextLocation that represents a return type name specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ReturnType { get; }
Public Shared ReadOnly Property ReturnType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.Type Property

CSharpContextLocationsType Property
Gets the IDotNetContextLocation that represents a type name specification.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Type { get; }
Public Shared ReadOnly Property Type As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.UsingDirectiveAliasedNamespaceOrType Property

CSharpContextLocationsUsingDirectiveAliasedNamespaceOrType Property
Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveAliasedNamespaceOrType { get; }
Public Shared ReadOnly Property UsingDirectiveAliasedNamespaceOrType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


CSharpContextLocations.UsingDirectiveNamespace Property

CSharpContextLocationsUsingDirectiveNamespace Property
Gets the IDotNetContextLocation that represents a namespace specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveNamespace { get; }
Public Shared ReadOnly Property UsingDirectiveNamespace As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

CSharpContextLocations Class
ActiproSoftware.Text.Languages.CSharp Namespace


ICSharpGrammarOptions Interface

ICSharpGrammarOptions Interface
Contains options for a C# grammar.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICSharpGrammarOptions
Public Interface ICSharpGrammarOptions

The ICSharpGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp Namespace


ICSharpGrammarOptions Properties

ICSharpGrammarOptions Properties

The ICSharpGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ICSharpGrammarOptions Interface
ActiproSoftware.Text.Languages.CSharp Namespace


ICSharpGrammarOptions.RootNonTerminal Property

ICSharpGrammarOptionsRootNonTerminal Property
Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.CSharp
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DotNetGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As DotNetGrammarRootNonTerminal
    Get

Property Value

Type: DotNetGrammarRootNonTerminal
A DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

ICSharpGrammarOptions Interface
ActiproSoftware.Text.Languages.CSharp Namespace


ActiproSoftware.Text.Languages.CSharp.Implementation Namespace

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace
Contains the core classes related to implementing a C# syntax language.
Classes
 | Class | Description
Public class | CSharpCodeBlockFinder | Provides a C# language code block finder service.
Public class | CSharpCodeSnippetProvider | Provides a C# language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Public class | CSharpCompletionProvider | Provides IntelliPrompt completion data for the C# language.
Public class | CSharpContextFactory | Creates C# language IDotNetContext objects for a TextSnapshotOffset.
Public class | CSharpDocumentationCommentAutoCompleter | Provides a class that can auto-complete C# language documentation comments when appropriate.
Public class | CSharpExampleTextProvider | Represents a example text provider for the C# language.
Public class | CSharpGrammar | Represents a Grammar for the C# language.
Public class | CSharpGrammarOptions | Contains options for a C# grammar.
Public class | CSharpIndentProvider | Provides a C# language indent provider service.
Public class | CSharpLexer | Represents a C# lexer (lexical analyzer) implementation.
Public class | CSharpLexicalStateId | Contains the lexical state IDs for the C# language.
Public class | CSharpNavigableSymbolProvider | Represents a navigable symbol provider for the C# language.
Public class | CSharpOutliner | Provides a C# language outliner service.
Public class | CSharpOutliningSource | Represents a C# language range-based outlining source.
Public class | CSharpParameterInfoProvider | Provides IntelliPrompt parameter info data for the C# language.
Public class | CSharpParser | Represents a parser for the C# language.
Public class | CSharpProjectAssembly | Represents a C# project (source code-based) assembly.
Public class | CSharpQuickInfoProvider | Provides IntelliPrompt quick info data for the C# language.
Public class | CSharpSyntaxLanguage | Represents a C# syntax language definition.
Public class | CSharpTextFormatter | Provides a C# language text formatter service.
Public class | CSharpTokenId | Contains the token IDs for the C# language.
Public class | CSharpTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the C# language.
Public class | CSharpTokenTagger | Represents an ITaggerT for the C# language.
Public class | CSharpTokenTaggerProvider | Represents a provider of CSharpTokenTagger objects for documents that use the CSharpTokenTagger language.
Public class | CSharpTokenTaggerProviderTaggerFactory | Implements a factory that can creates CSharpTokenTagger objects for a document.


CSharpCodeBlockFinder Class

CSharpCodeBlockFinder Class
Provides a C# language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpCodeBlockFinder : DotNetCodeBlockFinderBase
Public Class CSharpCodeBlockFinder
    Inherits DotNetCodeBlockFinderBase

The CSharpCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpCodeBlockFinder | Initializes a new instance of the CSharpCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeBlockFinder Constructor

CSharpCodeBlockFinder Constructor
Initializes a new instance of the CSharpCodeBlockFinder class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpCodeBlockFinder()
Public Sub New
See Also

Reference

CSharpCodeBlockFinder Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeBlockFinder Properties

CSharpCodeBlockFinder Properties

The CSharpCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

CSharpCodeBlockFinder Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeBlockFinder Methods

CSharpCodeBlockFinder Methods

The CSharpCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

CSharpCodeBlockFinder Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Class

CSharpCodeSnippetProvider Class
Provides a C# language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCodeSnippetProvider
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCodeSnippetProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpCodeSnippetProvider : CodeSnippetProvider
Public Class CSharpCodeSnippetProvider
    Inherits CodeSnippetProvider

The CSharpCodeSnippetProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpCodeSnippetProvider | Initializes a new instance of the CSharpCodeSnippetProvider class.
Top
Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Constructor

CSharpCodeSnippetProvider Constructor
Initializes a new instance of the CSharpCodeSnippetProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpCodeSnippetProvider()
Public Sub New
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Properties

CSharpCodeSnippetProvider Properties

The CSharpCodeSnippetProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider Methods

CSharpCodeSnippetProvider Methods

The CSharpCodeSnippetProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCodeSnippetProvider.GetPossibleShortcutSnapshotRange Method

CSharpCodeSnippetProviderGetPossibleShortcutSnapshotRange Method
Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override TextSnapshotRange GetPossibleShortcutSnapshotRange(
    TextSnapshotOffset snapshotOffset
)
Protected Overrides Function GetPossibleShortcutSnapshotRange (
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotRange

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the possible shortcut; or TextSnapshotRange.Deleted if there is no possible shortcut.
Remarks
Language implementations may wish to inherit this class and override this method to ensure the shortcut is not within a comment or other literal.
See Also

Reference

CSharpCodeSnippetProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Class

CSharpCompletionProvider Class
Provides IntelliPrompt completion data for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCompletionProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCompletionProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpCompletionProvider : DotNetCompletionProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class CSharpCompletionProvider
    Inherits DotNetCompletionProviderBase
    Implements IEditorDocumentTextChangeEventSink

The CSharpCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpCompletionProvider | Initializes a new instance of the CSharpCompletionProvider class.
Top
Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Constructor

CSharpCompletionProvider Constructor
Initializes a new instance of the CSharpCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpCompletionProvider()
Public Sub New
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Properties

CSharpCompletionProvider Properties

The CSharpCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider Methods

CSharpCompletionProvider Methods

The CSharpCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.CreateContext Method

CSharpCompletionProviderCreateContext Method
Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.OnDocumentTextChanged Method

CSharpCompletionProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.OnDocumentTextChanging Method

CSharpCompletionProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.RequestSession Method

CSharpCompletionProviderRequestSession Method
Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpCompletionProvider.ShouldShowForTypedWordStart Method

CSharpCompletionProviderShouldShowForTypedWordStart Method
Returns whether the specified IEditorView supports automatic completion list display at its current caret location.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ShouldShowForTypedWordStart(
    IEditorView view
)
Public Overrides Function ShouldShowForTypedWordStart (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if automatic completion list display is supported; otherwise, false.
See Also

Reference

CSharpCompletionProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory Class

CSharpContextFactory Class
Creates C# language IDotNetContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetContextFactoryBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpContextFactory

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpContextFactory : DotNetContextFactoryBase
Public Class CSharpContextFactory
    Inherits DotNetContextFactoryBase

The CSharpContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpContextFactory | Initializes a new instance of the CSharpContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory Constructor

CSharpContextFactory Constructor
Initializes a new instance of the CSharpContextFactory class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpContextFactory()
Public Sub New
See Also

Reference

CSharpContextFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory Methods

CSharpContextFactory Methods

The CSharpContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

CSharpContextFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory.CreateContext Method

CSharpContextFactoryCreateContext Method
Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Top
See Also

Reference

CSharpContextFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpContextFactory.CreateContext Method (TextSnapshotOffset, DotNetContextKind)

CSharpContextFactoryCreateContext Method (TextSnapshotOffset, DotNetContextKind)
Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    DotNetContextKind kind
)
Public Overrides Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As DotNetContextKind
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.DotNetDotNetContextKind
A DotNetContextKind indicating the kind of context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

CSharpContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Class

CSharpDocumentationCommentAutoCompleter Class
Provides a class that can auto-complete C# language documentation comments when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDocumentationCommentAutoCompleterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDocumentationCommentAutoCompleter

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpDocumentationCommentAutoCompleter : DocumentationCommentAutoCompleterBase,
    IEditorDocumentTextChangeEventSink
Public Class CSharpDocumentationCommentAutoCompleter
    Inherits DocumentationCommentAutoCompleterBase
    Implements IEditorDocumentTextChangeEventSink

The CSharpDocumentationCommentAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpDocumentationCommentAutoCompleter | Initializes a new instance of the CSharpDocumentationCommentAutoCompleter class
Top
Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDocumentationCommentAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Constructor

CSharpDocumentationCommentAutoCompleter Constructor
Initializes a new instance of the CSharpDocumentationCommentAutoCompleter class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpDocumentationCommentAutoCompleter()
Public Sub New
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Properties

CSharpDocumentationCommentAutoCompleter Properties

The CSharpDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter Methods

CSharpDocumentationCommentAutoCompleter Methods

The CSharpDocumentationCommentAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter.OnDocumentTextChanged Method

CSharpDocumentationCommentAutoCompleterOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpDocumentationCommentAutoCompleter.OnDocumentTextChanging Method

CSharpDocumentationCommentAutoCompleterOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Class

CSharpExampleTextProvider Class
Represents a example text provider for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpExampleTextProvider : IExampleTextProvider
Public Class CSharpExampleTextProvider
    Implements IExampleTextProvider

The CSharpExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpExampleTextProvider | Initializes a new instance of the CSharpExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Constructor

CSharpExampleTextProvider Constructor
Initializes a new instance of the CSharpExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpExampleTextProvider()
Public Sub New
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Properties

CSharpExampleTextProvider Properties

The CSharpExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider.ExampleText Property

CSharpExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpExampleTextProvider Methods

CSharpExampleTextProvider Methods

The CSharpExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpExampleTextProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Class

CSharpGrammar Class
Represents a Grammar for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammar

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpGrammar : DotNetGrammarBase
Public Class CSharpGrammar
    Inherits DotNetGrammarBase

The CSharpGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpGrammar | Initializes a new instance of the CSharpGrammar class using default options.
Public method | CSharpGrammar(ICSharpGrammarOptions) | Initializes a new instance of the CSharpGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Constructor

CSharpGrammar Constructor
Overload List
 | Name | Description
Public method | CSharpGrammar | Initializes a new instance of the CSharpGrammar class using default options.
Public method | CSharpGrammar(ICSharpGrammarOptions) | Initializes a new instance of the CSharpGrammar class.
Top
See Also

Reference

CSharpGrammar Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Constructor

CSharpGrammar Constructor
Initializes a new instance of the CSharpGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpGrammar()
Public Sub New
See Also

Reference

CSharpGrammar Class
CSharpGrammar Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Constructor (ICSharpGrammarOptions)

CSharpGrammar Constructor (ICSharpGrammarOptions)
Initializes a new instance of the CSharpGrammar class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpGrammar(
    ICSharpGrammarOptions options
)
Public Sub New (
    options As ICSharpGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.CSharpICSharpGrammarOptions
An ICSharpGrammarOptions that contains options for the grammar.
See Also

Reference

CSharpGrammar Class
CSharpGrammar Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Properties

CSharpGrammar Properties

The CSharpGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

CSharpGrammar Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammar Methods

CSharpGrammar Methods

The CSharpGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

CSharpGrammar Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Class

CSharpGrammarOptions Class
Contains options for a C# grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarOptionsBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammarOptions

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpGrammarOptions : DotNetGrammarOptionsBase,
    ICSharpGrammarOptions
Public Class CSharpGrammarOptions
    Inherits DotNetGrammarOptionsBase
    Implements ICSharpGrammarOptions

The CSharpGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpGrammarOptions | Initializes a new instance of the CSharpGrammarOptions class
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Constructor

CSharpGrammarOptions Constructor
Initializes a new instance of the CSharpGrammarOptions class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpGrammarOptions()
Public Sub New
See Also

Reference

CSharpGrammarOptions Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Properties

CSharpGrammarOptions Properties

The CSharpGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
See Also

Reference

CSharpGrammarOptions Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpGrammarOptions Methods

CSharpGrammarOptions Methods

The CSharpGrammarOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpGrammarOptions Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Class

CSharpIndentProvider Class
Provides a C# language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpIndentProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpIndentProvider : DelimiterIndentProvider
Public Class CSharpIndentProvider
    Inherits DelimiterIndentProvider

The CSharpIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpIndentProvider | Initializes a new instance of the CSharpIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Constructor

CSharpIndentProvider Constructor
Initializes a new instance of the CSharpIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpIndentProvider()
Public Sub New
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Properties

CSharpIndentProvider Properties

The CSharpIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.Mode Property

CSharpIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider Methods

CSharpIndentProvider Methods

The CSharpIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.GetIndentAmount Method

CSharpIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.OnDocumentTextChanged Method

CSharpIndentProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overrides Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpIndentProvider.OnDocumentTextChanging Method

CSharpIndentProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overrides Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpIndentProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Class

CSharpLexer Class
Represents a C# lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexer

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpLexer : MergableLexerBase
Public Class CSharpLexer
    Inherits MergableLexerBase

The CSharpLexer type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpLexer | Initializes a new instance of the CSharpLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Constructor

CSharpLexer Constructor
Initializes a new instance of the CSharpLexer class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpLexer()
Public Sub New
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Properties

CSharpLexer Properties

The CSharpLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer.LexicalStates Property

CSharpLexerLexicalStates Property
Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Methods

CSharpLexer Methods

The CSharpLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer.GetAllLexicalStateTransitions Method

CSharpLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer.GetNextToken Method

CSharpLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexer Events

CSharpLexer Events

The CSharpLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

CSharpLexer Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Class

CSharpLexicalStateId Class
Contains the lexical state IDs for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexicalStateId

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpLexicalStateId : LexicalStateIdProviderBase
Public Class CSharpLexicalStateId
    Inherits LexicalStateIdProviderBase

The CSharpLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpLexicalStateId | Initializes a new instance of the CSharpLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Constructor

CSharpLexicalStateId Constructor
Initializes a new instance of the CSharpLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpLexicalStateId()
Public Sub New
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Properties

CSharpLexicalStateId Properties

The CSharpLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.MaxId Property

CSharpLexicalStateIdMaxId Property
Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.MinId Property

CSharpLexicalStateIdMinId Property
Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Methods

CSharpLexicalStateId Methods

The CSharpLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.ContainsId Method

CSharpLexicalStateIdContainsId Method
Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.GetDescription Method

CSharpLexicalStateIdGetDescription Method
Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.GetKey Method

CSharpLexicalStateIdGetKey Method
Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId Fields

CSharpLexicalStateId Fields

The CSharpLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
Top
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.Default Field

CSharpLexicalStateIdDefault Field
Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Default = 10000
Public Const Default As Integer = 10000

Field Value

Type: Int32
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.DocumentationComment Field

CSharpLexicalStateIdDocumentationComment Field
Gets the DocumentationComment lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationComment = 10001
Public Const DocumentationComment As Integer = 10001

Field Value

Type: Int32
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpLexicalStateId.PreprocessorDirective Field

CSharpLexicalStateIdPreprocessorDirective Field
Gets the PreprocessorDirective lexical state ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirective = 10002
Public Const PreprocessorDirective As Integer = 10002

Field Value

Type: Int32
See Also

Reference

CSharpLexicalStateId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider Class

CSharpNavigableSymbolProvider Class
Represents a navigable symbol provider for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetNavigableSymbolProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpNavigableSymbolProvider : DotNetNavigableSymbolProviderBase
Public Class CSharpNavigableSymbolProvider
    Inherits DotNetNavigableSymbolProviderBase

The CSharpNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpNavigableSymbolProvider | Initializes a new instance of the CSharpNavigableSymbolProvider class
Top
Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider Constructor

CSharpNavigableSymbolProvider Constructor
Initializes a new instance of the CSharpNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpNavigableSymbolProvider()
Public Sub New
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider Methods

CSharpNavigableSymbolProvider Methods

The CSharpNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider.CreateTypeMemberSymbol Method

CSharpNavigableSymbolProviderCreateTypeMemberSymbol Method
Creates an INavigableSymbol for a TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeMemberSymbol(
    TypeMemberDeclaration memberDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeMemberSymbol (
    memberDecl As TypeMemberDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

memberDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
The TypeMemberDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpNavigableSymbolProvider.CreateTypeSymbol Method

CSharpNavigableSymbolProviderCreateTypeSymbol Method
Creates an INavigableSymbol for a TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeSymbol(
    TypeDeclaration typeDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeSymbol (
    typeDecl As TypeDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

typeDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
The TypeDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

CSharpNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Class

CSharpOutliner Class
Provides a C# language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpOutliner

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpOutliner : IOutliner
Public Class CSharpOutliner
    Implements IOutliner

The CSharpOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpOutliner | Initializes a new instance of the CSharpOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Constructor

CSharpOutliner Constructor
Initializes a new instance of the CSharpOutliner class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpOutliner()
Public Sub New
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Properties

CSharpOutliner Properties

The CSharpOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner.UpdateTrigger Property

CSharpOutlinerUpdateTrigger Property
Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner Methods

CSharpOutliner Methods

The CSharpOutliner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliner.GetOutliningSource Method

CSharpOutlinerGetOutliningSource Method
Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

CSharpOutliner Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource Class

CSharpOutliningSource Class
Represents a C# language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpOutliningSource

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpOutliningSource : RangeOutliningSourceBase
Public Class CSharpOutliningSource
    Inherits RangeOutliningSourceBase

The CSharpOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpOutliningSource | Initializes a new instance of the CSharpOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource Constructor

CSharpOutliningSource Constructor
Initializes a new instance of the CSharpOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource Methods

CSharpOutliningSource Methods

The CSharpOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesFromParseData Method

CSharpOutliningSourceAddNodesFromParseData Method
Overload List
 | Name | Description
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesFromParseData Method (IDotNetParseData)

CSharpOutliningSourceAddNodesFromParseData Method (IDotNetParseData)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IDotNetParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IDotNetParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
See Also

Reference

CSharpOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)

CSharpOutliningSourceAddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IDotNetParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IDotNetParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

CSharpOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpOutliningSource.AddNodesRecursive Method

CSharpOutliningSourceAddNodesRecursive Method
Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

CSharpOutliningSource Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Class

CSharpParameterInfoProvider Class
Provides IntelliPrompt parameter info data for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParameterInfoProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpParameterInfoProvider : DotNetParameterInfoProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class CSharpParameterInfoProvider
    Inherits DotNetParameterInfoProviderBase
    Implements IEditorDocumentTextChangeEventSink

The CSharpParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpParameterInfoProvider | Initializes a new instance of the CSharpParameterInfoProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Constructor

CSharpParameterInfoProvider Constructor
Initializes a new instance of the CSharpParameterInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpParameterInfoProvider()
Public Sub New
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Properties

CSharpParameterInfoProvider Properties

The CSharpParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider Methods

CSharpParameterInfoProvider Methods

The CSharpParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.CreateContext Method

CSharpParameterInfoProviderCreateContext Method
Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.OnDocumentTextChanged Method

CSharpParameterInfoProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.OnDocumentTextChanging Method

CSharpParameterInfoProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParameterInfoProvider.RequestSession Method

CSharpParameterInfoProviderRequestSession Method
Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view
)
Public Overrides Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

IParameterInfoProviderRequestSession(IEditorView)
See Also

Reference

CSharpParameterInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Class

CSharpParser Class
Represents a parser for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParser

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpParser : DotNetParserBase
Public Class CSharpParser
    Inherits DotNetParserBase

The CSharpParser type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpParser | Initializes a new instance of the CSharpParser class.
Public method | CSharpParser(Grammar) | Initializes a new instance of the CSharpParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Constructor

CSharpParser Constructor
Overload List
 | Name | Description
Public method | CSharpParser | Initializes a new instance of the CSharpParser class.
Public method | CSharpParser(Grammar) | Initializes a new instance of the CSharpParser class.
Top
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Constructor

CSharpParser Constructor
Initializes a new instance of the CSharpParser class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpParser()
Public Sub New
See Also

Reference

CSharpParser Class
CSharpParser Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Constructor (Grammar)

CSharpParser Constructor (Grammar)
Initializes a new instance of the CSharpParser class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

CSharpParser Class
CSharpParser Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Properties

CSharpParser Properties

The CSharpParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser Methods

CSharpParser Methods

The CSharpParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.CreateTokenReader Method

CSharpParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.InitializeParseData Method

CSharpParserInitializeParseData Method
Initializes a LLParseData using the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParseData(
    LLParseData parseData,
    IParserState state
)
Protected Overrides Sub InitializeParseData (
    parseData As LLParseData,
    state As IParserState
)

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
The LLParseData to initialize.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
Remarks
This method is called by default from the CreateParseData(IParseRequest, IParserState) method.
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.InitializeParserState Method

CSharpParserInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpParser.ParseExpression Method

CSharpParserParseExpression Method
Parses the specified expression text.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetParseData ParseExpression(
    string text
)
Public Shared Function ParseExpression (
    text As String
) As IDotNetParseData

Parameters

text
Type: SystemString
The expression text to parse.

Return Value

Type: IDotNetParseData
The IDotNetParseData that contains the parse results.
See Also

Reference

CSharpParser Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Class

CSharpProjectAssembly Class
Represents a C# project (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationProjectAssembly
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpProjectAssembly

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpProjectAssembly : ProjectAssembly
Public Class CSharpProjectAssembly
    Inherits ProjectAssembly

The CSharpProjectAssembly type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpProjectAssembly(String) | Initializes a new instance of the CSharpProjectAssembly class.
Public method | CSharpProjectAssembly(IAssemblyName) | Initializes a new instance of the CSharpProjectAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Constructor

CSharpProjectAssembly Constructor
Overload List
 | Name | Description
Public method | CSharpProjectAssembly(String) | Initializes a new instance of the CSharpProjectAssembly class.
Public method | CSharpProjectAssembly(IAssemblyName) | Initializes a new instance of the CSharpProjectAssembly class.
Top
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Constructor (String)

CSharpProjectAssembly Constructor (String)
Initializes a new instance of the CSharpProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpProjectAssembly(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

CSharpProjectAssembly Class
CSharpProjectAssembly Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Constructor (IAssemblyName)

CSharpProjectAssembly Constructor (IAssemblyName)
Initializes a new instance of the CSharpProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpProjectAssembly(
    IAssemblyName assemblyName
)
Public Sub New (
    assemblyName As IAssemblyName
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

CSharpProjectAssembly Class
CSharpProjectAssembly Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Properties

CSharpProjectAssembly Properties

The CSharpProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly.IsLanguageCaseSensitive Property

CSharpProjectAssemblyIsLanguageCaseSensitive Property
Gets whether the language associated with this project assembly is case-sensitive.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsLanguageCaseSensitive { get; }
Protected Overrides ReadOnly Property IsLanguageCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the language associated with this project assembly is case-sensitive; otherwise, false.
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly.Resolver Property

CSharpProjectAssemblyResolver Property
Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IResolver Resolver { get; }
Public Overrides ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.

Implements

IProjectAssemblyResolver
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpProjectAssembly Methods

CSharpProjectAssembly Methods

The CSharpProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

CSharpProjectAssembly Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Class

CSharpQuickInfoProvider Class
Provides IntelliPrompt quick info data for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpQuickInfoProvider : QuickInfoProviderBase
Public Class CSharpQuickInfoProvider
    Inherits QuickInfoProviderBase

The CSharpQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpQuickInfoProvider | Initializes a new instance of the CSharpQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Constructor

CSharpQuickInfoProvider Constructor
Initializes a new instance of the CSharpQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpQuickInfoProvider()
Public Sub New
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Properties

CSharpQuickInfoProvider Properties

The CSharpQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.ContextTypes Property

CSharpQuickInfoProviderContextTypes Property
Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider Methods

CSharpQuickInfoProvider Methods

The CSharpQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.GetContext Method

CSharpQuickInfoProviderGetContext Method
Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.GetContext Method (IEditorView, Int32)

CSharpQuickInfoProviderGetContext Method (IEditorView, Int32)
Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

CSharpQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.OnSessionOpening Method

CSharpQuickInfoProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.RequestSession Method

CSharpQuickInfoProviderRequestSession Method
Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

CSharpQuickInfoProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpQuickInfoProvider.RequestSession Method (IEditorView, Object)

CSharpQuickInfoProviderRequestSession Method (IEditorView, Object)
Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

CSharpQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Class

CSharpSyntaxLanguage Class
Represents a C# syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpSyntaxLanguage : DotNetSyntaxLanguageBase,
    ITextViewLifecycleEventSink
Public Class CSharpSyntaxLanguage
    Inherits DotNetSyntaxLanguageBase
    Implements ITextViewLifecycleEventSink

The CSharpSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpSyntaxLanguage | Initializes a new instance of the CSharpSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Constructor

CSharpSyntaxLanguage Constructor
Initializes a new instance of the CSharpSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpSyntaxLanguage()
Public Sub New
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Properties

CSharpSyntaxLanguage Properties

The CSharpSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Methods

CSharpSyntaxLanguage Methods

The CSharpSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpSyntaxLanguage Events

CSharpSyntaxLanguage Events

The CSharpSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

CSharpSyntaxLanguage Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Class

CSharpTextFormatter Class
Provides a C# language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetTextFormatterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTextFormatter

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpTextFormatter : DotNetTextFormatterBase
Public Class CSharpTextFormatter
    Inherits DotNetTextFormatterBase

The CSharpTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTextFormatter | Initializes a new instance of the CSharpTextFormatter class
Top
Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range. (Overrides DotNetTextFormatterBaseFormat(TextSnapshotRange).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Constructor

CSharpTextFormatter Constructor
Initializes a new instance of the CSharpTextFormatter class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpTextFormatter()
Public Sub New
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Properties

CSharpTextFormatter Properties

The CSharpTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter.IsOpeningBraceOnNewLine Property

CSharpTextFormatterIsOpeningBraceOnNewLine Property
Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOpeningBraceOnNewLine { get; set; }
Public Property IsOpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter Methods

CSharpTextFormatter Methods

The CSharpTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range. (Overrides DotNetTextFormatterBaseFormat(TextSnapshotRange).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTextFormatter.Format Method

CSharpTextFormatterFormat Method
Formats the specified snapshot range.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Format(
    TextSnapshotRange snapshotRange
)
Public Overrides Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The snapshot range.

Implements

ITextFormatterFormat(TextSnapshotRange)
See Also

Reference

CSharpTextFormatter Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Class

CSharpTokenId Class
Contains the token IDs for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenId

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpTokenId : TokenIdProviderBase
Public Class CSharpTokenId
    Inherits TokenIdProviderBase

The CSharpTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenId | Initializes a new instance of the CSharpTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsCSharpVerbatimStringClassificationType | Returns whether the specified ID value is part of the CSharpVerbatimString.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAdd | Gets the ContextualKeywordAdd token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGet | Gets the ContextualKeywordGet token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordLet | Gets the ContextualKeywordLet token ID.
ContextualKeywordOn | Gets the ContextualKeywordOn token ID.
ContextualKeywordOrderBy | Gets the ContextualKeywordOrderBy token ID.
ContextualKeywordPartial | Gets the ContextualKeywordPartial token ID.
ContextualKeywordRemove | Gets the ContextualKeywordRemove token ID.
ContextualKeywordSelect | Gets the ContextualKeywordSelect token ID.
ContextualKeywordSet | Gets the ContextualKeywordSet token ID.
ContextualKeywordVar | Gets the ContextualKeywordVar token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordAbstract | Gets the KeywordAbstract token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBase | Gets the KeywordBase token ID.
KeywordBool | Gets the KeywordBool token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordChecked | Gets the KeywordChecked token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordDynamic | Gets the KeywordDynamic token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExplicit | Gets the KeywordExplicit token ID.
KeywordExtern | Gets the KeywordExtern token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFixed | Gets the KeywordFixed token ID.
KeywordFloat | Gets the KeywordFloat token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordForEach | Gets the KeywordForEach token ID.
KeywordGoto | Gets the KeywordGoto token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplicit | Gets the KeywordImplicit token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInt | Gets the KeywordInt token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordInternal | Gets the KeywordInternal token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLock | Gets the KeywordLock token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOut | Gets the KeywordOut token ID.
KeywordOverride | Gets the KeywordOverride token ID.
KeywordParams | Gets the KeywordParams token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordRef | Gets the KeywordRef token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSealed | Gets the KeywordSealed token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSizeOf | Gets the KeywordSizeOf token ID.
KeywordStackAlloc | Gets the KeywordStackAlloc token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStruct | Gets the KeywordStruct token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInt | Gets the KeywordUInt token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUnchecked | Gets the KeywordUnchecked token ID.
KeywordUnsafe | Gets the KeywordUnsafe token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVirtual | Gets the KeywordVirtual token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordVolatile | Gets the KeywordVolatile token ID.
KeywordWhile | Gets the KeywordWhile token ID.
Lambda | Gets the Lambda token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralString | Gets the LiteralString token ID.
LiteralVerbatimString | Gets the LiteralVerbatimString token ID.
NamespaceAliasQualifier | Gets the NamespaceAliasQualifier token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorNullCoalescing | Gets the OperatorNullCoalescing token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPointerDereference | Gets the OperatorPointerDereference token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordDefine | Gets the PreprocessorDirectiveKeywordDefine token ID.
PreprocessorDirectiveKeywordElIf | Gets the PreprocessorDirectiveKeywordElIf token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordError | Gets the PreprocessorDirectiveKeywordError token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordLine | Gets the PreprocessorDirectiveKeywordLine token ID.
PreprocessorDirectiveKeywordPragma | Gets the PreprocessorDirectiveKeywordPragma token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveKeywordUndef | Gets the PreprocessorDirectiveKeywordUndef token ID.
PreprocessorDirectiveKeywordWarning | Gets the PreprocessorDirectiveKeywordWarning token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Constructor

CSharpTokenId Constructor
Initializes a new instance of the CSharpTokenId class

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpTokenId()
Public Sub New
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Properties

CSharpTokenId Properties

The CSharpTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.MaxId Property

CSharpTokenIdMaxId Property
Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.MinId Property

CSharpTokenIdMinId Property
Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Methods

CSharpTokenId Methods

The CSharpTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsCSharpVerbatimStringClassificationType | Returns whether the specified ID value is part of the CSharpVerbatimString.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContainsId Method

CSharpTokenIdContainsId Method
Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.GetDescription Method

CSharpTokenIdGetDescription Method
Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.GetKey Method

CSharpTokenIdGetKey Method
Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsCommentClassificationType Method

CSharpTokenIdIsCommentClassificationType Method
Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsCSharpVerbatimStringClassificationType Method

CSharpTokenIdIsCSharpVerbatimStringClassificationType Method
Returns whether the specified ID value is part of the CSharpVerbatimString.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsCSharpVerbatimStringClassificationType(
    int id
)
Public Shared Function IsCSharpVerbatimStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsIdentifierClassificationType Method

CSharpTokenIdIsIdentifierClassificationType Method
Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsKeywordClassificationType Method

CSharpTokenIdIsKeywordClassificationType Method
Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsNumberClassificationType Method

CSharpTokenIdIsNumberClassificationType Method
Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsOperatorClassificationType Method

CSharpTokenIdIsOperatorClassificationType Method
Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsPreprocessorKeywordClassificationType Method

CSharpTokenIdIsPreprocessorKeywordClassificationType Method
Returns whether the specified ID value is part of the PreprocessorKeyword.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsPreprocessorKeywordClassificationType(
    int id
)
Public Shared Function IsPreprocessorKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsStringClassificationType Method

CSharpTokenIdIsStringClassificationType Method
Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsXmlDocumentationCommentClassificationType Method

CSharpTokenIdIsXmlDocumentationCommentClassificationType Method
Returns whether the specified ID value is part of the XmlDocumentationComment.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationCommentClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.IsXmlDocumentationTagClassificationType Method

CSharpTokenIdIsXmlDocumentationTagClassificationType Method
Returns whether the specified ID value is part of the XmlDocumentationTag.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationTagClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationTagClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId Fields

CSharpTokenId Fields

The CSharpTokenId type exposes the following members.

Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAdd | Gets the ContextualKeywordAdd token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGet | Gets the ContextualKeywordGet token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordLet | Gets the ContextualKeywordLet token ID.
ContextualKeywordOn | Gets the ContextualKeywordOn token ID.
ContextualKeywordOrderBy | Gets the ContextualKeywordOrderBy token ID.
ContextualKeywordPartial | Gets the ContextualKeywordPartial token ID.
ContextualKeywordRemove | Gets the ContextualKeywordRemove token ID.
ContextualKeywordSelect | Gets the ContextualKeywordSelect token ID.
ContextualKeywordSet | Gets the ContextualKeywordSet token ID.
ContextualKeywordVar | Gets the ContextualKeywordVar token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordAbstract | Gets the KeywordAbstract token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBase | Gets the KeywordBase token ID.
KeywordBool | Gets the KeywordBool token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordChecked | Gets the KeywordChecked token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordDynamic | Gets the KeywordDynamic token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExplicit | Gets the KeywordExplicit token ID.
KeywordExtern | Gets the KeywordExtern token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFixed | Gets the KeywordFixed token ID.
KeywordFloat | Gets the KeywordFloat token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordForEach | Gets the KeywordForEach token ID.
KeywordGoto | Gets the KeywordGoto token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplicit | Gets the KeywordImplicit token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInt | Gets the KeywordInt token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordInternal | Gets the KeywordInternal token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLock | Gets the KeywordLock token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOut | Gets the KeywordOut token ID.
KeywordOverride | Gets the KeywordOverride token ID.
KeywordParams | Gets the KeywordParams token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordRef | Gets the KeywordRef token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSealed | Gets the KeywordSealed token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSizeOf | Gets the KeywordSizeOf token ID.
KeywordStackAlloc | Gets the KeywordStackAlloc token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStruct | Gets the KeywordStruct token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInt | Gets the KeywordUInt token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUnchecked | Gets the KeywordUnchecked token ID.
KeywordUnsafe | Gets the KeywordUnsafe token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVirtual | Gets the KeywordVirtual token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordVolatile | Gets the KeywordVolatile token ID.
KeywordWhile | Gets the KeywordWhile token ID.
Lambda | Gets the Lambda token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralString | Gets the LiteralString token ID.
LiteralVerbatimString | Gets the LiteralVerbatimString token ID.
NamespaceAliasQualifier | Gets the NamespaceAliasQualifier token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorNullCoalescing | Gets the OperatorNullCoalescing token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPointerDereference | Gets the OperatorPointerDereference token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordDefine | Gets the PreprocessorDirectiveKeywordDefine token ID.
PreprocessorDirectiveKeywordElIf | Gets the PreprocessorDirectiveKeywordElIf token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordError | Gets the PreprocessorDirectiveKeywordError token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordLine | Gets the PreprocessorDirectiveKeywordLine token ID.
PreprocessorDirectiveKeywordPragma | Gets the PreprocessorDirectiveKeywordPragma token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveKeywordUndef | Gets the PreprocessorDirectiveKeywordUndef token ID.
PreprocessorDirectiveKeywordWarning | Gets the PreprocessorDirectiveKeywordWarning token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CloseCurlyBrace Field

CSharpTokenIdCloseCurlyBrace Field
Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 10003
Public Const CloseCurlyBrace As Integer = 10003

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CloseParenthesis Field

CSharpTokenIdCloseParenthesis Field
Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 10007
Public Const CloseParenthesis As Integer = 10007

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CloseSquareBrace Field

CSharpTokenIdCloseSquareBrace Field
Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 10005
Public Const CloseSquareBrace As Integer = 10005

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Colon Field

CSharpTokenIdColon Field
Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Colon = 10010
Public Const Colon As Integer = 10010

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Comma Field

CSharpTokenIdComma Field
Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Comma = 10009
Public Const Comma As Integer = 10009

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CommentMultiLine Field

CSharpTokenIdCommentMultiLine Field
Gets the CommentMultiLine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentMultiLine = 10016
Public Const CommentMultiLine As Integer = 10016

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.CommentSingleLine Field

CSharpTokenIdCommentSingleLine Field
Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 10015
Public Const CommentSingleLine As Integer = 10015

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAdd Field

CSharpTokenIdContextualKeywordAdd Field
Gets the ContextualKeywordAdd token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAdd = 10106
Public Const ContextualKeywordAdd As Integer = 10106

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAscending Field

CSharpTokenIdContextualKeywordAscending Field
Gets the ContextualKeywordAscending token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAscending = 10105
Public Const ContextualKeywordAscending As Integer = 10105

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAsync Field

CSharpTokenIdContextualKeywordAsync Field
Gets the ContextualKeywordAsync token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAsync = 10107
Public Const ContextualKeywordAsync As Integer = 10107

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordAwait Field

CSharpTokenIdContextualKeywordAwait Field
Gets the ContextualKeywordAwait token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAwait = 10108
Public Const ContextualKeywordAwait As Integer = 10108

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordBy Field

CSharpTokenIdContextualKeywordBy Field
Gets the ContextualKeywordBy token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordBy = 10109
Public Const ContextualKeywordBy As Integer = 10109

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordDescending Field

CSharpTokenIdContextualKeywordDescending Field
Gets the ContextualKeywordDescending token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordDescending = 10110
Public Const ContextualKeywordDescending As Integer = 10110

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordEquals Field

CSharpTokenIdContextualKeywordEquals Field
Gets the ContextualKeywordEquals token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordEquals = 10111
Public Const ContextualKeywordEquals As Integer = 10111

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordFrom Field

CSharpTokenIdContextualKeywordFrom Field
Gets the ContextualKeywordFrom token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordFrom = 10112
Public Const ContextualKeywordFrom As Integer = 10112

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordGet Field

CSharpTokenIdContextualKeywordGet Field
Gets the ContextualKeywordGet token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordGet = 10113
Public Const ContextualKeywordGet As Integer = 10113

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordGroup Field

CSharpTokenIdContextualKeywordGroup Field
Gets the ContextualKeywordGroup token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordGroup = 10114
Public Const ContextualKeywordGroup As Integer = 10114

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordInto Field

CSharpTokenIdContextualKeywordInto Field
Gets the ContextualKeywordInto token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordInto = 10115
Public Const ContextualKeywordInto As Integer = 10115

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordJoin Field

CSharpTokenIdContextualKeywordJoin Field
Gets the ContextualKeywordJoin token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordJoin = 10116
Public Const ContextualKeywordJoin As Integer = 10116

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordLet Field

CSharpTokenIdContextualKeywordLet Field
Gets the ContextualKeywordLet token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordLet = 10117
Public Const ContextualKeywordLet As Integer = 10117

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordOn Field

CSharpTokenIdContextualKeywordOn Field
Gets the ContextualKeywordOn token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOn = 10118
Public Const ContextualKeywordOn As Integer = 10118

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordOrderBy Field

CSharpTokenIdContextualKeywordOrderBy Field
Gets the ContextualKeywordOrderBy token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOrderBy = 10119
Public Const ContextualKeywordOrderBy As Integer = 10119

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordPartial Field

CSharpTokenIdContextualKeywordPartial Field
Gets the ContextualKeywordPartial token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordPartial = 10120
Public Const ContextualKeywordPartial As Integer = 10120

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordRemove Field

CSharpTokenIdContextualKeywordRemove Field
Gets the ContextualKeywordRemove token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordRemove = 10121
Public Const ContextualKeywordRemove As Integer = 10121

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordSelect Field

CSharpTokenIdContextualKeywordSelect Field
Gets the ContextualKeywordSelect token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordSelect = 10122
Public Const ContextualKeywordSelect As Integer = 10122

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordSet Field

CSharpTokenIdContextualKeywordSet Field
Gets the ContextualKeywordSet token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordSet = 10123
Public Const ContextualKeywordSet As Integer = 10123

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordVar Field

CSharpTokenIdContextualKeywordVar Field
Gets the ContextualKeywordVar token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordVar = 10125
Public Const ContextualKeywordVar As Integer = 10125

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordWhere Field

CSharpTokenIdContextualKeywordWhere Field
Gets the ContextualKeywordWhere token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordWhere = 10124
Public Const ContextualKeywordWhere As Integer = 10124

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.ContextualKeywordYield Field

CSharpTokenIdContextualKeywordYield Field
Gets the ContextualKeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordYield = 10126
Public Const ContextualKeywordYield As Integer = 10126

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.DocumentationCommentDelimiter Field

CSharpTokenIdDocumentationCommentDelimiter Field
Gets the DocumentationCommentDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationCommentDelimiter = 10017
Public Const DocumentationCommentDelimiter As Integer = 10017

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.DocumentationCommentTag Field

CSharpTokenIdDocumentationCommentTag Field
Gets the DocumentationCommentTag token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationCommentTag = 10018
Public Const DocumentationCommentTag As Integer = 10018

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.DocumentationCommentText Field

CSharpTokenIdDocumentationCommentText Field
Gets the DocumentationCommentText token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationCommentText = 10019
Public Const DocumentationCommentText As Integer = 10019

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Dot Field

CSharpTokenIdDot Field
Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Dot = 10008
Public Const Dot As Integer = 10008

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Identifier Field

CSharpTokenIdIdentifier Field
Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Identifier = 10026
Public Const Identifier As Integer = 10026

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordAbstract Field

CSharpTokenIdKeywordAbstract Field
Gets the KeywordAbstract token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAbstract = 10027
Public Const KeywordAbstract As Integer = 10027

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordAs Field

CSharpTokenIdKeywordAs Field
Gets the KeywordAs token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAs = 10028
Public Const KeywordAs As Integer = 10028

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordBase Field

CSharpTokenIdKeywordBase Field
Gets the KeywordBase token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordBase = 10029
Public Const KeywordBase As Integer = 10029

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordBool Field

CSharpTokenIdKeywordBool Field
Gets the KeywordBool token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordBool = 10030
Public Const KeywordBool As Integer = 10030

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordBreak Field

CSharpTokenIdKeywordBreak Field
Gets the KeywordBreak token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordBreak = 10031
Public Const KeywordBreak As Integer = 10031

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordByte Field

CSharpTokenIdKeywordByte Field
Gets the KeywordByte token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordByte = 10032
Public Const KeywordByte As Integer = 10032

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordCase Field

CSharpTokenIdKeywordCase Field
Gets the KeywordCase token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCase = 10033
Public Const KeywordCase As Integer = 10033

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordCatch Field

CSharpTokenIdKeywordCatch Field
Gets the KeywordCatch token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCatch = 10034
Public Const KeywordCatch As Integer = 10034

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordChar Field

CSharpTokenIdKeywordChar Field
Gets the KeywordChar token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordChar = 10035
Public Const KeywordChar As Integer = 10035

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordChecked Field

CSharpTokenIdKeywordChecked Field
Gets the KeywordChecked token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordChecked = 10036
Public Const KeywordChecked As Integer = 10036

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordClass Field

CSharpTokenIdKeywordClass Field
Gets the KeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordClass = 10037
Public Const KeywordClass As Integer = 10037

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordConst Field

CSharpTokenIdKeywordConst Field
Gets the KeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordConst = 10038
Public Const KeywordConst As Integer = 10038

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordContinue Field

CSharpTokenIdKeywordContinue Field
Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 10039
Public Const KeywordContinue As Integer = 10039

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDecimal Field

CSharpTokenIdKeywordDecimal Field
Gets the KeywordDecimal token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDecimal = 10040
Public Const KeywordDecimal As Integer = 10040

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDefault Field

CSharpTokenIdKeywordDefault Field
Gets the KeywordDefault token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDefault = 10041
Public Const KeywordDefault As Integer = 10041

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDelegate Field

CSharpTokenIdKeywordDelegate Field
Gets the KeywordDelegate token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDelegate = 10042
Public Const KeywordDelegate As Integer = 10042

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDo Field

CSharpTokenIdKeywordDo Field
Gets the KeywordDo token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDo = 10043
Public Const KeywordDo As Integer = 10043

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDouble Field

CSharpTokenIdKeywordDouble Field
Gets the KeywordDouble token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDouble = 10044
Public Const KeywordDouble As Integer = 10044

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordDynamic Field

CSharpTokenIdKeywordDynamic Field
Gets the KeywordDynamic token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDynamic = 10045
Public Const KeywordDynamic As Integer = 10045

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordElse Field

CSharpTokenIdKeywordElse Field
Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordElse = 10046
Public Const KeywordElse As Integer = 10046

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordEnum Field

CSharpTokenIdKeywordEnum Field
Gets the KeywordEnum token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEnum = 10047
Public Const KeywordEnum As Integer = 10047

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordEvent Field

CSharpTokenIdKeywordEvent Field
Gets the KeywordEvent token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEvent = 10048
Public Const KeywordEvent As Integer = 10048

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordExplicit Field

CSharpTokenIdKeywordExplicit Field
Gets the KeywordExplicit token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordExplicit = 10049
Public Const KeywordExplicit As Integer = 10049

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordExtern Field

CSharpTokenIdKeywordExtern Field
Gets the KeywordExtern token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordExtern = 10050
Public Const KeywordExtern As Integer = 10050

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFalse Field

CSharpTokenIdKeywordFalse Field
Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 10051
Public Const KeywordFalse As Integer = 10051

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFinally Field

CSharpTokenIdKeywordFinally Field
Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 10052
Public Const KeywordFinally As Integer = 10052

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFixed Field

CSharpTokenIdKeywordFixed Field
Gets the KeywordFixed token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFixed = 10053
Public Const KeywordFixed As Integer = 10053

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFloat Field

CSharpTokenIdKeywordFloat Field
Gets the KeywordFloat token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFloat = 10054
Public Const KeywordFloat As Integer = 10054

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordFor Field

CSharpTokenIdKeywordFor Field
Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFor = 10055
Public Const KeywordFor As Integer = 10055

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordForEach Field

CSharpTokenIdKeywordForEach Field
Gets the KeywordForEach token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordForEach = 10056
Public Const KeywordForEach As Integer = 10056

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordGoto Field

CSharpTokenIdKeywordGoto Field
Gets the KeywordGoto token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGoto = 10057
Public Const KeywordGoto As Integer = 10057

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordIf Field

CSharpTokenIdKeywordIf Field
Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIf = 10058
Public Const KeywordIf As Integer = 10058

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordImplicit Field

CSharpTokenIdKeywordImplicit Field
Gets the KeywordImplicit token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordImplicit = 10059
Public Const KeywordImplicit As Integer = 10059

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordIn Field

CSharpTokenIdKeywordIn Field
Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIn = 10060
Public Const KeywordIn As Integer = 10060

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordInt Field

CSharpTokenIdKeywordInt Field
Gets the KeywordInt token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInt = 10061
Public Const KeywordInt As Integer = 10061

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordInterface Field

CSharpTokenIdKeywordInterface Field
Gets the KeywordInterface token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInterface = 10062
Public Const KeywordInterface As Integer = 10062

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordInternal Field

CSharpTokenIdKeywordInternal Field
Gets the KeywordInternal token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInternal = 10063
Public Const KeywordInternal As Integer = 10063

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordIs Field

CSharpTokenIdKeywordIs Field
Gets the KeywordIs token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIs = 10064
Public Const KeywordIs As Integer = 10064

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordLock Field

CSharpTokenIdKeywordLock Field
Gets the KeywordLock token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLock = 10065
Public Const KeywordLock As Integer = 10065

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordLong Field

CSharpTokenIdKeywordLong Field
Gets the KeywordLong token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLong = 10066
Public Const KeywordLong As Integer = 10066

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordNamespace Field

CSharpTokenIdKeywordNamespace Field
Gets the KeywordNamespace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNamespace = 10067
Public Const KeywordNamespace As Integer = 10067

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordNew Field

CSharpTokenIdKeywordNew Field
Gets the KeywordNew token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNew = 10068
Public Const KeywordNew As Integer = 10068

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordNull Field

CSharpTokenIdKeywordNull Field
Gets the KeywordNull token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNull = 10069
Public Const KeywordNull As Integer = 10069

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordObject Field

CSharpTokenIdKeywordObject Field
Gets the KeywordObject token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordObject = 10070
Public Const KeywordObject As Integer = 10070

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordOperator Field

CSharpTokenIdKeywordOperator Field
Gets the KeywordOperator token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOperator = 10071
Public Const KeywordOperator As Integer = 10071

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordOut Field

CSharpTokenIdKeywordOut Field
Gets the KeywordOut token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOut = 10072
Public Const KeywordOut As Integer = 10072

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordOverride Field

CSharpTokenIdKeywordOverride Field
Gets the KeywordOverride token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOverride = 10073
Public Const KeywordOverride As Integer = 10073

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordParams Field

CSharpTokenIdKeywordParams Field
Gets the KeywordParams token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordParams = 10074
Public Const KeywordParams As Integer = 10074

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordPrivate Field

CSharpTokenIdKeywordPrivate Field
Gets the KeywordPrivate token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPrivate = 10075
Public Const KeywordPrivate As Integer = 10075

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordProtected Field

CSharpTokenIdKeywordProtected Field
Gets the KeywordProtected token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordProtected = 10076
Public Const KeywordProtected As Integer = 10076

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordPublic Field

CSharpTokenIdKeywordPublic Field
Gets the KeywordPublic token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPublic = 10077
Public Const KeywordPublic As Integer = 10077

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordReadOnly Field

CSharpTokenIdKeywordReadOnly Field
Gets the KeywordReadOnly token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReadOnly = 10078
Public Const KeywordReadOnly As Integer = 10078

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordRef Field

CSharpTokenIdKeywordRef Field
Gets the KeywordRef token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordRef = 10079
Public Const KeywordRef As Integer = 10079

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordReturn Field

CSharpTokenIdKeywordReturn Field
Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 10080
Public Const KeywordReturn As Integer = 10080

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSByte Field

CSharpTokenIdKeywordSByte Field
Gets the KeywordSByte token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSByte = 10081
Public Const KeywordSByte As Integer = 10081

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSealed Field

CSharpTokenIdKeywordSealed Field
Gets the KeywordSealed token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSealed = 10082
Public Const KeywordSealed As Integer = 10082

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordShort Field

CSharpTokenIdKeywordShort Field
Gets the KeywordShort token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordShort = 10083
Public Const KeywordShort As Integer = 10083

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSizeOf Field

CSharpTokenIdKeywordSizeOf Field
Gets the KeywordSizeOf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSizeOf = 10084
Public Const KeywordSizeOf As Integer = 10084

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordStackAlloc Field

CSharpTokenIdKeywordStackAlloc Field
Gets the KeywordStackAlloc token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStackAlloc = 10085
Public Const KeywordStackAlloc As Integer = 10085

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordStatic Field

CSharpTokenIdKeywordStatic Field
Gets the KeywordStatic token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStatic = 10086
Public Const KeywordStatic As Integer = 10086

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordString Field

CSharpTokenIdKeywordString Field
Gets the KeywordString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordString = 10087
Public Const KeywordString As Integer = 10087

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordStruct Field

CSharpTokenIdKeywordStruct Field
Gets the KeywordStruct token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStruct = 10088
Public Const KeywordStruct As Integer = 10088

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordSwitch Field

CSharpTokenIdKeywordSwitch Field
Gets the KeywordSwitch token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSwitch = 10089
Public Const KeywordSwitch As Integer = 10089

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordThis Field

CSharpTokenIdKeywordThis Field
Gets the KeywordThis token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordThis = 10090
Public Const KeywordThis As Integer = 10090

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordThrow Field

CSharpTokenIdKeywordThrow Field
Gets the KeywordThrow token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordThrow = 10091
Public Const KeywordThrow As Integer = 10091

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordTrue Field

CSharpTokenIdKeywordTrue Field
Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 10092
Public Const KeywordTrue As Integer = 10092

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordTry Field

CSharpTokenIdKeywordTry Field
Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTry = 10093
Public Const KeywordTry As Integer = 10093

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordTypeOf Field

CSharpTokenIdKeywordTypeOf Field
Gets the KeywordTypeOf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTypeOf = 10094
Public Const KeywordTypeOf As Integer = 10094

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUInt Field

CSharpTokenIdKeywordUInt Field
Gets the KeywordUInt token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUInt = 10095
Public Const KeywordUInt As Integer = 10095

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordULong Field

CSharpTokenIdKeywordULong Field
Gets the KeywordULong token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordULong = 10096
Public Const KeywordULong As Integer = 10096

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUnchecked Field

CSharpTokenIdKeywordUnchecked Field
Gets the KeywordUnchecked token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUnchecked = 10097
Public Const KeywordUnchecked As Integer = 10097

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUnsafe Field

CSharpTokenIdKeywordUnsafe Field
Gets the KeywordUnsafe token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUnsafe = 10098
Public Const KeywordUnsafe As Integer = 10098

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUShort Field

CSharpTokenIdKeywordUShort Field
Gets the KeywordUShort token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUShort = 10099
Public Const KeywordUShort As Integer = 10099

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordUsing Field

CSharpTokenIdKeywordUsing Field
Gets the KeywordUsing token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUsing = 10100
Public Const KeywordUsing As Integer = 10100

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordVirtual Field

CSharpTokenIdKeywordVirtual Field
Gets the KeywordVirtual token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordVirtual = 10101
Public Const KeywordVirtual As Integer = 10101

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordVoid Field

CSharpTokenIdKeywordVoid Field
Gets the KeywordVoid token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordVoid = 10102
Public Const KeywordVoid As Integer = 10102

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordVolatile Field

CSharpTokenIdKeywordVolatile Field
Gets the KeywordVolatile token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordVolatile = 10103
Public Const KeywordVolatile As Integer = 10103

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.KeywordWhile Field

CSharpTokenIdKeywordWhile Field
Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 10104
Public Const KeywordWhile As Integer = 10104

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Lambda Field

CSharpTokenIdLambda Field
Gets the Lambda token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Lambda = 10014
Public Const Lambda As Integer = 10014

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LineTerminator Field

CSharpTokenIdLineTerminator Field
Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineTerminator = 10001
Public Const LineTerminator As Integer = 10001

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralCharacter Field

CSharpTokenIdLiteralCharacter Field
Gets the LiteralCharacter token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralCharacter = 10023
Public Const LiteralCharacter As Integer = 10023

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralDecimalInteger Field

CSharpTokenIdLiteralDecimalInteger Field
Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 10020
Public Const LiteralDecimalInteger As Integer = 10020

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralHexadecimalInteger Field

CSharpTokenIdLiteralHexadecimalInteger Field
Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 10021
Public Const LiteralHexadecimalInteger As Integer = 10021

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralReal Field

CSharpTokenIdLiteralReal Field
Gets the LiteralReal token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralReal = 10022
Public Const LiteralReal As Integer = 10022

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralString Field

CSharpTokenIdLiteralString Field
Gets the LiteralString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralString = 10024
Public Const LiteralString As Integer = 10024

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.LiteralVerbatimString Field

CSharpTokenIdLiteralVerbatimString Field
Gets the LiteralVerbatimString token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralVerbatimString = 10025
Public Const LiteralVerbatimString As Integer = 10025

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.NamespaceAliasQualifier Field

CSharpTokenIdNamespaceAliasQualifier Field
Gets the NamespaceAliasQualifier token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int NamespaceAliasQualifier = 10013
Public Const NamespaceAliasQualifier As Integer = 10013

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OpenCurlyBrace Field

CSharpTokenIdOpenCurlyBrace Field
Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 10002
Public Const OpenCurlyBrace As Integer = 10002

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OpenParenthesis Field

CSharpTokenIdOpenParenthesis Field
Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 10006
Public Const OpenParenthesis As Integer = 10006

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OpenSquareBrace Field

CSharpTokenIdOpenSquareBrace Field
Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 10004
Public Const OpenSquareBrace As Integer = 10004

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorAddition Field

CSharpTokenIdOperatorAddition Field
Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 10127
Public Const OperatorAddition As Integer = 10127

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorAdditionAssignment Field

CSharpTokenIdOperatorAdditionAssignment Field
Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 10149
Public Const OperatorAdditionAssignment As Integer = 10149

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorAssignment Field

CSharpTokenIdOperatorAssignment Field
Gets the OperatorAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAssignment = 10137
Public Const OperatorAssignment As Integer = 10137

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseAnd Field

CSharpTokenIdOperatorBitwiseAnd Field
Gets the OperatorBitwiseAnd token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAnd = 10132
Public Const OperatorBitwiseAnd As Integer = 10132

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseAndAssignment Field

CSharpTokenIdOperatorBitwiseAndAssignment Field
Gets the OperatorBitwiseAndAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAndAssignment = 10154
Public Const OperatorBitwiseAndAssignment As Integer = 10154

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseOr Field

CSharpTokenIdOperatorBitwiseOr Field
Gets the OperatorBitwiseOr token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOr = 10133
Public Const OperatorBitwiseOr As Integer = 10133

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorBitwiseOrAssignment Field

CSharpTokenIdOperatorBitwiseOrAssignment Field
Gets the OperatorBitwiseOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOrAssignment = 10155
Public Const OperatorBitwiseOrAssignment As Integer = 10155

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorConditionalAnd Field

CSharpTokenIdOperatorConditionalAnd Field
Gets the OperatorConditionalAnd token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorConditionalAnd = 10142
Public Const OperatorConditionalAnd As Integer = 10142

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorConditionalOr Field

CSharpTokenIdOperatorConditionalOr Field
Gets the OperatorConditionalOr token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorConditionalOr = 10143
Public Const OperatorConditionalOr As Integer = 10143

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorDecrement Field

CSharpTokenIdOperatorDecrement Field
Gets the OperatorDecrement token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDecrement = 10141
Public Const OperatorDecrement As Integer = 10141

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorDivision Field

CSharpTokenIdOperatorDivision Field
Gets the OperatorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDivision = 10130
Public Const OperatorDivision As Integer = 10130

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorDivisionAssignment Field

CSharpTokenIdOperatorDivisionAssignment Field
Gets the OperatorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDivisionAssignment = 10152
Public Const OperatorDivisionAssignment As Integer = 10152

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorEquality Field

CSharpTokenIdOperatorEquality Field
Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 10145
Public Const OperatorEquality As Integer = 10145

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorExclusiveOr Field

CSharpTokenIdOperatorExclusiveOr Field
Gets the OperatorExclusiveOr token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOr = 10134
Public Const OperatorExclusiveOr As Integer = 10134

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorExclusiveOrAssignment Field

CSharpTokenIdOperatorExclusiveOrAssignment Field
Gets the OperatorExclusiveOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOrAssignment = 10156
Public Const OperatorExclusiveOrAssignment As Integer = 10156

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorGreaterThan Field

CSharpTokenIdOperatorGreaterThan Field
Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 10139
Public Const OperatorGreaterThan As Integer = 10139

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorGreaterThanOrEqual Field

CSharpTokenIdOperatorGreaterThanOrEqual Field
Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 10148
Public Const OperatorGreaterThanOrEqual As Integer = 10148

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorIncrement Field

CSharpTokenIdOperatorIncrement Field
Gets the OperatorIncrement token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorIncrement = 10140
Public Const OperatorIncrement As Integer = 10140

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorInequality Field

CSharpTokenIdOperatorInequality Field
Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 10146
Public Const OperatorInequality As Integer = 10146

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLeftShift Field

CSharpTokenIdOperatorLeftShift Field
Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 10144
Public Const OperatorLeftShift As Integer = 10144

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLeftShiftAssignment Field

CSharpTokenIdOperatorLeftShiftAssignment Field
Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 10157
Public Const OperatorLeftShiftAssignment As Integer = 10157

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLessThan Field

CSharpTokenIdOperatorLessThan Field
Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 10138
Public Const OperatorLessThan As Integer = 10138

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorLessThanOrEqual Field

CSharpTokenIdOperatorLessThanOrEqual Field
Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 10147
Public Const OperatorLessThanOrEqual As Integer = 10147

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorModulus Field

CSharpTokenIdOperatorModulus Field
Gets the OperatorModulus token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorModulus = 10131
Public Const OperatorModulus As Integer = 10131

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorModulusAssignment Field

CSharpTokenIdOperatorModulusAssignment Field
Gets the OperatorModulusAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorModulusAssignment = 10153
Public Const OperatorModulusAssignment As Integer = 10153

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorMultiplication Field

CSharpTokenIdOperatorMultiplication Field
Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 10129
Public Const OperatorMultiplication As Integer = 10129

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorMultiplicationAssignment Field

CSharpTokenIdOperatorMultiplicationAssignment Field
Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 10151
Public Const OperatorMultiplicationAssignment As Integer = 10151

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorNegation Field

CSharpTokenIdOperatorNegation Field
Gets the OperatorNegation token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorNegation = 10135
Public Const OperatorNegation As Integer = 10135

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorNullCoalescing Field

CSharpTokenIdOperatorNullCoalescing Field
Gets the OperatorNullCoalescing token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorNullCoalescing = 10159
Public Const OperatorNullCoalescing As Integer = 10159

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorOnesComplement Field

CSharpTokenIdOperatorOnesComplement Field
Gets the OperatorOnesComplement token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorOnesComplement = 10136
Public Const OperatorOnesComplement As Integer = 10136

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorPointerDereference Field

CSharpTokenIdOperatorPointerDereference Field
Gets the OperatorPointerDereference token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorPointerDereference = 10158
Public Const OperatorPointerDereference As Integer = 10158

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorSubtraction Field

CSharpTokenIdOperatorSubtraction Field
Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 10128
Public Const OperatorSubtraction As Integer = 10128

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.OperatorSubtractionAssignment Field

CSharpTokenIdOperatorSubtractionAssignment Field
Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 10150
Public Const OperatorSubtractionAssignment As Integer = 10150

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordDefine Field

CSharpTokenIdPreprocessorDirectiveKeywordDefine Field
Gets the PreprocessorDirectiveKeywordDefine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordDefine = 10164
Public Const PreprocessorDirectiveKeywordDefine As Integer = 10164

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordElIf Field

CSharpTokenIdPreprocessorDirectiveKeywordElIf Field
Gets the PreprocessorDirectiveKeywordElIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElIf = 10162
Public Const PreprocessorDirectiveKeywordElIf As Integer = 10162

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordElse Field

CSharpTokenIdPreprocessorDirectiveKeywordElse Field
Gets the PreprocessorDirectiveKeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElse = 10161
Public Const PreprocessorDirectiveKeywordElse As Integer = 10161

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordEndIf Field

CSharpTokenIdPreprocessorDirectiveKeywordEndIf Field
Gets the PreprocessorDirectiveKeywordEndIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndIf = 10163
Public Const PreprocessorDirectiveKeywordEndIf As Integer = 10163

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordEndRegion Field

CSharpTokenIdPreprocessorDirectiveKeywordEndRegion Field
Gets the PreprocessorDirectiveKeywordEndRegion token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndRegion = 10170
Public Const PreprocessorDirectiveKeywordEndRegion As Integer = 10170

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordError Field

CSharpTokenIdPreprocessorDirectiveKeywordError Field
Gets the PreprocessorDirectiveKeywordError token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordError = 10167
Public Const PreprocessorDirectiveKeywordError As Integer = 10167

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordIf Field

CSharpTokenIdPreprocessorDirectiveKeywordIf Field
Gets the PreprocessorDirectiveKeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordIf = 10160
Public Const PreprocessorDirectiveKeywordIf As Integer = 10160

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordLine Field

CSharpTokenIdPreprocessorDirectiveKeywordLine Field
Gets the PreprocessorDirectiveKeywordLine token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordLine = 10168
Public Const PreprocessorDirectiveKeywordLine As Integer = 10168

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordPragma Field

CSharpTokenIdPreprocessorDirectiveKeywordPragma Field
Gets the PreprocessorDirectiveKeywordPragma token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordPragma = 10171
Public Const PreprocessorDirectiveKeywordPragma As Integer = 10171

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordRegion Field

CSharpTokenIdPreprocessorDirectiveKeywordRegion Field
Gets the PreprocessorDirectiveKeywordRegion token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordRegion = 10169
Public Const PreprocessorDirectiveKeywordRegion As Integer = 10169

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordUndef Field

CSharpTokenIdPreprocessorDirectiveKeywordUndef Field
Gets the PreprocessorDirectiveKeywordUndef token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordUndef = 10165
Public Const PreprocessorDirectiveKeywordUndef As Integer = 10165

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveKeywordWarning Field

CSharpTokenIdPreprocessorDirectiveKeywordWarning Field
Gets the PreprocessorDirectiveKeywordWarning token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordWarning = 10166
Public Const PreprocessorDirectiveKeywordWarning As Integer = 10166

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.PreprocessorDirectiveText Field

CSharpTokenIdPreprocessorDirectiveText Field
Gets the PreprocessorDirectiveText token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveText = 10172
Public Const PreprocessorDirectiveText As Integer = 10172

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.QuestionMark Field

CSharpTokenIdQuestionMark Field
Gets the QuestionMark token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int QuestionMark = 10012
Public Const QuestionMark As Integer = 10012

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.SemiColon Field

CSharpTokenIdSemiColon Field
Gets the SemiColon token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SemiColon = 10011
Public Const SemiColon As Integer = 10011

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenId.Whitespace Field

CSharpTokenIdWhitespace Field
Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Whitespace = 10000
Public Const Whitespace As Integer = 10000

Field Value

Type: Int32
See Also

Reference

CSharpTokenId Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Class

CSharpTokenReader Class
Represents an object that can provide tokens to a ILLParser in a forward-only direction for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenReader

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpTokenReader : MergableTokenReader
Public Class CSharpTokenReader
    Inherits MergableTokenReader

The CSharpTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenReader | Initializes a new instance of the CSharpTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Constructor

CSharpTokenReader Constructor
Initializes a new instance of the CSharpTokenReader class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Properties

CSharpTokenReader Properties

The CSharpTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader Methods

CSharpTokenReader Methods

The CSharpTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenReader.GetNextToken Method

CSharpTokenReaderGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

CSharpTokenReader Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Class

CSharpTokenTagger Class
Represents an ITaggerT for the C# language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTagger

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpTokenTagger : TokenTagger
Public Class CSharpTokenTagger
    Inherits TokenTagger

The CSharpTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenTagger | Initializes a new instance of the CSharpTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Constructor

CSharpTokenTagger Constructor
Initializes a new instance of the CSharpTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpTokenTagger(
    ICodeDocument document,
    IDotNetClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IDotNetClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Properties

CSharpTokenTagger Properties

The CSharpTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Methods

CSharpTokenTagger Methods

The CSharpTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger.ClassifyToken Method

CSharpTokenTaggerClassifyToken Method
Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTagger Events

CSharpTokenTagger Events

The CSharpTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CSharpTokenTagger Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Class

CSharpTokenTaggerProvider Class
Represents a provider of CSharpTokenTagger objects for documents that use the CSharpTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase CSharpTokenTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CSharpTokenTaggerProvider : TaggerProviderBase<CSharpTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class CSharpTokenTaggerProvider
    Inherits TaggerProviderBase(Of CSharpTokenTagger)
    Implements ICodeDocumentTaggerProvider

The CSharpTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpTokenTaggerProvider | Initializes a new instance of the CSharpTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Constructor

CSharpTokenTaggerProvider Constructor
Initializes a new instance of the CSharpTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpTokenTaggerProvider(
    IDotNetClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IDotNetClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types.
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Properties

CSharpTokenTaggerProvider Properties

The CSharpTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider Methods

CSharpTokenTaggerProvider Methods

The CSharpTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider.GetTagger(T) Method

CSharpTokenTaggerProviderGetTaggerT Method
Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

CSharpTokenTaggerProvider Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider.TaggerFactory Class

CSharpTokenTaggerProviderTaggerFactory Class
Implements a factory that can creates CSharpTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The CSharpTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an CSharpTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


TaggerFactory Methods

TaggerFactory Methods

The CSharpTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an CSharpTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CSharpTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


CSharpTokenTaggerProvider.TaggerFactory.CreateTagger Method

CSharpTokenTaggerProviderTaggerFactoryCreateTagger Method
Creates an CSharpTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.CSharp.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CSharpTokenTagger CreateTagger()
Public Function CreateTagger As CSharpTokenTagger

Return Value

Type: CSharpTokenTagger
An CSharpTokenTagger for the ICodeDocument.
See Also

Reference

CSharpTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.CSharp.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet Namespace

ActiproSoftware.Text.Languages.DotNet Namespace
Contains the classes related to implementing a .NET syntax language.
Classes
 | Class | Description
Public class | DotNetContextKind | Specifies the kind of context.
Public class | DotNetGrammarRootNonTerminal | Specifies the root non-terminal to use for a .NET grammar.
Public class | DotNetSyntaxLanguageExtensions | Contains extension methods that make it easier to work with .NET ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IDocumentationCommentAutoCompleter | Provides the base requirements for a class that can auto-complete .NET language documentation comments when appropriate.
Public interface | IDotNetClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for a .NET language.
Public interface | IDotNetContext | Provides the base requirements for information about a .NET language context of a certain offset within an ITextSnapshot.
Public interface | IDotNetContextLocation | Provides the base requirements for an IDotNetContext location, that determines what sort of resolver results are permitted.
Public interface | IDotNetParseData | Provides the base requirements of an object that stores the results of a .NET language parsing operation.


DotNetContextKind Class

DotNetContextKind Class
Specifies the kind of context.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNetDotNetContextKind

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DotNetContextKind : Enum
Public NotInheritable Class DotNetContextKind
    Inherits Enum

The DotNetContextKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ContainingInvocation | The context and its resolve operations work on the invocation that contains the offset, if any.
 | Self | The context and its resolve operations work on the existing member referenced at the offset.
 | SelfAndSiblings | The context and its resolve operations work on the existing member and its siblings referenced at the offset.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


DotNetContextKind Methods

DotNetContextKind Methods

The DotNetContextKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DotNetContextKind Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetContextKind Fields

DotNetContextKind Fields

The DotNetContextKind type exposes the following members.

Fields
 | Name | Description
 | ContainingInvocation | The context and its resolve operations work on the invocation that contains the offset, if any.
 | Self | The context and its resolve operations work on the existing member referenced at the offset.
 | SelfAndSiblings | The context and its resolve operations work on the existing member and its siblings referenced at the offset.
Public field | value__ |
Top
See Also

Reference

DotNetContextKind Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetContextKind.ContainingInvocation Field

DotNetContextKindContainingInvocation Field
The context and its resolve operations work on the invocation that contains the offset, if any.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetContextKind ContainingInvocation = 2
Public Const ContainingInvocation As DotNetContextKind = 2

Field Value

Type: DotNetContextKind
See Also

Reference

DotNetContextKind Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetContextKind.Self Field

DotNetContextKindSelf Field
The context and its resolve operations work on the existing member referenced at the offset.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetContextKind Self = 0
Public Const Self As DotNetContextKind = 0

Field Value

Type: DotNetContextKind
See Also

Reference

DotNetContextKind Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetContextKind.SelfAndSiblings Field

DotNetContextKindSelfAndSiblings Field
The context and its resolve operations work on the existing member and its siblings referenced at the offset.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetContextKind SelfAndSiblings = 1
Public Const SelfAndSiblings As DotNetContextKind = 1

Field Value

Type: DotNetContextKind
See Also

Reference

DotNetContextKind Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetContextKind.value__ Field

DotNetContextKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.DotNetContextKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DotNetContextKind Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal Class

DotNetGrammarRootNonTerminal Class
Specifies the root non-terminal to use for a .NET grammar.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNetDotNetGrammarRootNonTerminal

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DotNetGrammarRootNonTerminal : Enum
Public NotInheritable Class DotNetGrammarRootNonTerminal
    Inherits Enum

The DotNetGrammarRootNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CompilationUnit | Compilation unit (the default).
 | Expression | Expression.
 | QueryExpression | Query expression.
 | Statement | Statement.
 | StatementList | Statement list.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal Methods

DotNetGrammarRootNonTerminal Methods

The DotNetGrammarRootNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal Fields

DotNetGrammarRootNonTerminal Fields

The DotNetGrammarRootNonTerminal type exposes the following members.

Fields
 | Name | Description
 | CompilationUnit | Compilation unit (the default).
 | Expression | Expression.
 | QueryExpression | Query expression.
 | Statement | Statement.
 | StatementList | Statement list.
Public field | value__ |
Top
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal.CompilationUnit Field

DotNetGrammarRootNonTerminalCompilationUnit Field
Compilation unit (the default).

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetGrammarRootNonTerminal CompilationUnit = 0
Public Const CompilationUnit As DotNetGrammarRootNonTerminal = 0

Field Value

Type: DotNetGrammarRootNonTerminal
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal.Expression Field

DotNetGrammarRootNonTerminalExpression Field
Expression.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetGrammarRootNonTerminal Expression = 3
Public Const Expression As DotNetGrammarRootNonTerminal = 3

Field Value

Type: DotNetGrammarRootNonTerminal
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal.QueryExpression Field

DotNetGrammarRootNonTerminalQueryExpression Field
Query expression.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetGrammarRootNonTerminal QueryExpression = 4
Public Const QueryExpression As DotNetGrammarRootNonTerminal = 4

Field Value

Type: DotNetGrammarRootNonTerminal
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal.Statement Field

DotNetGrammarRootNonTerminalStatement Field
Statement.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetGrammarRootNonTerminal Statement = 2
Public Const Statement As DotNetGrammarRootNonTerminal = 2

Field Value

Type: DotNetGrammarRootNonTerminal
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal.StatementList Field

DotNetGrammarRootNonTerminalStatementList Field
Statement list.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DotNetGrammarRootNonTerminal StatementList = 1
Public Const StatementList As DotNetGrammarRootNonTerminal = 1

Field Value

Type: DotNetGrammarRootNonTerminal
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetGrammarRootNonTerminal.value__ Field

DotNetGrammarRootNonTerminalvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.DotNetGrammarRootNonTerminal.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DotNetGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions Class

DotNetSyntaxLanguageExtensions Class
Contains extension methods that make it easier to work with .NET ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNetDotNetSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class DotNetSyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class DotNetSyntaxLanguageExtensions

The DotNetSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML.
GetProjectAssembly | Returns the IProjectAssembly that can validate XML.
RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML.
RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML.
UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML.
UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions Methods

DotNetSyntaxLanguageExtensions Methods

The DotNetSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetDocumentationCommentAutoCompleter | Returns the IDocumentationCommentAutoCompleter that can validate XML.
GetProjectAssembly | Returns the IProjectAssembly that can validate XML.
RegisterDocumentationCommentAutoCompleter | Registers the IDocumentationCommentAutoCompleter that can validate XML.
RegisterProjectAssembly | Registers the IProjectAssembly that can validate XML.
UnregisterDocumentationCommentAutoCompleter | Unregisters the IDocumentationCommentAutoCompleter that can validate XML.
UnregisterProjectAssembly | Unregisters the IProjectAssembly that can validate XML.
Top
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.GetDocumentationCommentAutoCompleter Method

DotNetSyntaxLanguageExtensionsGetDocumentationCommentAutoCompleter Method
Returns the IDocumentationCommentAutoCompleter that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDocumentationCommentAutoCompleter GetDocumentationCommentAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetDocumentationCommentAutoCompleter (
    language As ISyntaxLanguage
) As IDocumentationCommentAutoCompleter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IDocumentationCommentAutoCompleter
The IDocumentationCommentAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.GetProjectAssembly Method

DotNetSyntaxLanguageExtensionsGetProjectAssembly Method
Returns the IProjectAssembly that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IProjectAssembly GetProjectAssembly(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetProjectAssembly (
    language As ISyntaxLanguage
) As IProjectAssembly

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IProjectAssembly
The IProjectAssembly instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.RegisterDocumentationCommentAutoCompleter Method

DotNetSyntaxLanguageExtensionsRegisterDocumentationCommentAutoCompleter Method
Registers the IDocumentationCommentAutoCompleter that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterDocumentationCommentAutoCompleter(
    this ISyntaxLanguage language,
    IDocumentationCommentAutoCompleter value
)
<ExtensionAttribute>
Public Shared Sub RegisterDocumentationCommentAutoCompleter (
    language As ISyntaxLanguage,
    value As IDocumentationCommentAutoCompleter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.DotNetIDocumentationCommentAutoCompleter
The IDocumentationCommentAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.RegisterProjectAssembly Method

DotNetSyntaxLanguageExtensionsRegisterProjectAssembly Method
Registers the IProjectAssembly that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterProjectAssembly(
    this ISyntaxLanguage language,
    IProjectAssembly value
)
<ExtensionAttribute>
Public Shared Sub RegisterProjectAssembly (
    language As ISyntaxLanguage,
    value As IProjectAssembly
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIProjectAssembly
The IProjectAssembly instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.UnregisterDocumentationCommentAutoCompleter Method

DotNetSyntaxLanguageExtensionsUnregisterDocumentationCommentAutoCompleter Method
Unregisters the IDocumentationCommentAutoCompleter that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterDocumentationCommentAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterDocumentationCommentAutoCompleter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


DotNetSyntaxLanguageExtensions.UnregisterProjectAssembly Method

DotNetSyntaxLanguageExtensionsUnregisterProjectAssembly Method
Unregisters the IProjectAssembly that can validate XML.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterProjectAssembly(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterProjectAssembly (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DotNetSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter Interface

IDocumentationCommentAutoCompleter Interface
Provides the base requirements for a class that can auto-complete .NET language documentation comments when appropriate.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDocumentationCommentAutoCompleter
Public Interface IDocumentationCommentAutoCompleter

The IDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDocumentationCommentAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDocumentationCommentAutoCompleter
ActiproSoftware.Text.Languages.VB.ImplementationVBDocumentationCommentAutoCompleter


IDocumentationCommentAutoCompleter Properties

IDocumentationCommentAutoCompleter Properties

The IDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter.IsEndTagCompletionEnabled Property

IDocumentationCommentAutoCompleterIsEndTagCompletionEnabled Property
Gets whether documentation comment end tag completion is enabled.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsEndTagCompletionEnabled { get; }
ReadOnly Property IsEndTagCompletionEnabled As Boolean
    Get

Property Value

Type: Boolean
true if documentation comment end tag completion is enabled; otherwise, false.
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter.IsNewLineGenerationEnabled Property

IDocumentationCommentAutoCompleterIsNewLineGenerationEnabled Property
Gets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsNewLineGenerationEnabled { get; }
ReadOnly Property IsNewLineGenerationEnabled As Boolean
    Get

Property Value

Type: Boolean
true if documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment; otherwise, false.
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDocumentationCommentAutoCompleter.IsStubGenerationEnabled Property

IDocumentationCommentAutoCompleterIsStubGenerationEnabled Property
Gets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsStubGenerationEnabled { get; }
ReadOnly Property IsStubGenerationEnabled As Boolean
    Get

Property Value

Type: Boolean
true if stub documentation comment auto-generation is enabled when starting to type new documentation comments; otherwise, false.
See Also

Reference

IDocumentationCommentAutoCompleter Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider Interface

IDotNetClassificationTypeProvider Interface
Provides the base requirements of an object that provides IClassificationType objects for a .NET language.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDotNetClassificationTypeProvider
Public Interface IDotNetClassificationTypeProvider

The IDotNetClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.540.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider Properties

IDotNetClassificationTypeProvider Properties

The IDotNetClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Comment Property

IDotNetClassificationTypeProviderComment Property
Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Comment { get; }
ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.CSharpVerbatimString Property

IDotNetClassificationTypeProviderCSharpVerbatimString Property
Gets the CSharpVerbatimString classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType CSharpVerbatimString { get; }
ReadOnly Property CSharpVerbatimString As IClassificationType
    Get

Property Value

Type: IClassificationType
The CSharpVerbatimString classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Identifier Property

IDotNetClassificationTypeProviderIdentifier Property
Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Identifier { get; }
ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Keyword Property

IDotNetClassificationTypeProviderKeyword Property
Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Keyword { get; }
ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Number Property

IDotNetClassificationTypeProviderNumber Property
Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Number { get; }
ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.Operator Property

IDotNetClassificationTypeProviderOperator Property
Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Operator { get; }
ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.PreprocessorKeyword Property

IDotNetClassificationTypeProviderPreprocessorKeyword Property
Gets the PreprocessorKeyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType PreprocessorKeyword { get; }
ReadOnly Property PreprocessorKeyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The PreprocessorKeyword classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.String Property

IDotNetClassificationTypeProviderString Property
Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType String { get; }
ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.VBXmlLiteral Property

IDotNetClassificationTypeProviderVBXmlLiteral Property
Gets the VBXmlLiteral classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType VBXmlLiteral { get; }
ReadOnly Property VBXmlLiteral As IClassificationType
    Get

Property Value

Type: IClassificationType
The VBXmlLiteral classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.XmlDocumentationComment Property

IDotNetClassificationTypeProviderXmlDocumentationComment Property
Gets the XmlDocumentationComment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlDocumentationComment { get; }
ReadOnly Property XmlDocumentationComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationComment classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetClassificationTypeProvider.XmlDocumentationTag Property

IDotNetClassificationTypeProviderXmlDocumentationTag Property
Gets the XmlDocumentationTag classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlDocumentationTag { get; }
ReadOnly Property XmlDocumentationTag As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationTag classification type.
See Also

Reference

IDotNetClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext Interface

IDotNetContext Interface
Provides the base requirements for information about a .NET language context of a certain offset within an ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDotNetContext
Public Interface IDotNetContext

The IDotNetContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | ContainingAstTypeDeclaration | Gets the AST TypeDeclaration that contains the SnapshotOffset, if any.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the DotNetContextKind indicating the kind of context.
Public property | Location | Gets an optional IDotNetContextLocation that provides more location information about the context.
Public property | ProjectAssembly | Gets the IProjectAssembly with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Top
Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the ProjectAssembly to return an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext Properties

IDotNetContext Properties

The IDotNetContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | ContainingAstTypeDeclaration | Gets the AST TypeDeclaration that contains the SnapshotOffset, if any.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the DotNetContextKind indicating the kind of context.
Public property | Location | Gets an optional IDotNetContextLocation that provides more location information about the context.
Public property | ProjectAssembly | Gets the IProjectAssembly with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Top
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ArgumentIndex Property

IDotNetContextArgumentIndex Property
Gets the index of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> ArgumentIndex { get; }
ReadOnly Property ArgumentIndex As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The index of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ArgumentListSnapshotOffset Property

IDotNetContextArgumentListSnapshotOffset Property
Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentListSnapshotOffset { get; }
ReadOnly Property ArgumentListSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ArgumentSnapshotOffset Property

IDotNetContextArgumentSnapshotOffset Property
Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentSnapshotOffset { get; }
ReadOnly Property ArgumentSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ContainingAstNode Property

IDotNetContextContainingAstNode Property
Gets the IAstNode that contains the SnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode ContainingAstNode { get; }
ReadOnly Property ContainingAstNode As IAstNode
    Get

Property Value

Type: IAstNode
The IAstNode that contains the SnapshotOffset.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ContainingAstTypeDeclaration Property

IDotNetContextContainingAstTypeDeclaration Property
Gets the AST TypeDeclaration that contains the SnapshotOffset, if any.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TypeDeclaration ContainingAstTypeDeclaration { get; }
ReadOnly Property ContainingAstTypeDeclaration As TypeDeclaration
    Get

Property Value

Type: TypeDeclaration
The AST TypeDeclaration that contains the SnapshotOffset, if any.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.InitializationSnapshotRange Property

IDotNetContextInitializationSnapshotRange Property
Gets the TextSnapshotRange with which the context was initialized.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> InitializationSnapshotRange { get; }
ReadOnly Property InitializationSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The TextSnapshotRange with which the context was initialized.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.Kind Property

IDotNetContextKind Property
Gets the DotNetContextKind indicating the kind of context.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DotNetContextKind Kind { get; }
ReadOnly Property Kind As DotNetContextKind
    Get

Property Value

Type: DotNetContextKind
The DotNetContextKind indicating the kind of context.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.Location Property

IDotNetContextLocation Property
Gets an optional IDotNetContextLocation that provides more location information about the context.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDotNetContextLocation Location { get; }
ReadOnly Property Location As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
An optional IDotNetContextLocation that provides more location information about the context.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.ProjectAssembly Property

IDotNetContextProjectAssembly Property
Gets the IProjectAssembly with which this context is associated.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProjectAssembly ProjectAssembly { get; }
ReadOnly Property ProjectAssembly As IProjectAssembly
    Get

Property Value

Type: IProjectAssembly
The IProjectAssembly with which this context is associated.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.SnapshotOffset Property

IDotNetContextSnapshotOffset Property
Gets the TextSnapshotOffset for which this context was created.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotOffset SnapshotOffset { get; }
ReadOnly Property SnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset for which this context was created.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.TargetExpression Property

IDotNetContextTargetExpression Property
Gets the target AST Expression for the context, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Expression TargetExpression { get; }
ReadOnly Property TargetExpression As Expression
    Get

Property Value

Type: Expression
The target AST Expression for the context, if known.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.TargetSnapshotOffset Property

IDotNetContextTargetSnapshotOffset Property
Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> TargetSnapshotOffset { get; }
ReadOnly Property TargetSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset, if known, against which to use as context for the resolver.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext Methods

IDotNetContext Methods

The IDotNetContext type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the ProjectAssembly to return an IResolverResultSet.
Top
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContext.Resolve Method

IDotNetContextResolve Method
Uses the IResolver on the ProjectAssembly to return an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve()
Function Resolve As IResolverResultSet

Return Value

Type: IResolverResultSet
The IResolverResultSet that was returned by the resolver.
See Also

Reference

IDotNetContext Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContextLocation Interface

IDotNetContextLocation Interface
Provides the base requirements for an IDotNetContext location, that determines what sort of resolver results are permitted.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDotNetContextLocation
Public Interface IDotNetContextLocation

The IDotNetContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContextLocation Methods

IDotNetContextLocation Methods

The IDotNetContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

IDotNetContextLocation Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetContextLocation.IsAllowed Method

IDotNetContextLocationIsAllowed Method
Returns whether the specified IResolverResult is allowed within the context location.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAllowed(
    IResolverResult result
)
Function IsAllowed (
    result As IResolverResult
) As Boolean

Parameters

result
Type: ActiproSoftware.Text.Languages.DotNet.ResolutionIResolverResult
The IResolverResult to examine.

Return Value

Type: Boolean
true if the specified IResolverResult is allowed within the context location; otherwise, false.
See Also

Reference

IDotNetContextLocation Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetParseData Interface

IDotNetParseData Interface
Provides the base requirements of an object that stores the results of a .NET language parsing operation.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDotNetParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IDotNetParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IDotNetParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet Namespace
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParseData


IDotNetParseData Properties

IDotNetParseData Properties

The IDotNetParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IDotNetParseData Interface
ActiproSoftware.Text.Languages.DotNet Namespace


IDotNetParseData.PreprocessorDirectives Property

IDotNetParseDataPreprocessorDirectives Property
Gets the collection of preprocessor directives.

Namespace: ActiproSoftware.Text.Languages.DotNet
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<PreprocessorDirective> PreprocessorDirectives { get; }
ReadOnly Property PreprocessorDirectives As IList(Of PreprocessorDirective)
    Get

Property Value

Type: IList PreprocessorDirective
The collection of preprocessor directives.
See Also

Reference

IDotNetParseData Interface
ActiproSoftware.Text.Languages.DotNet Namespace


ActiproSoftware.Text.Languages.DotNet.Ast Namespace

ActiproSoftware.Text.Languages.DotNet.Ast Namespace
Contains the types related to ASTs for a .NET syntax language.
Classes
 | Class | Description
Public class | AccessorKind | Specifies the kind of accessor.
Public class | AttributeTargetKind | Specifies the kind of attribute target.
Public class | ConstructorInitializerKind | Specifies the type of constructor initializer.
Public class | ContinueKind | Specifies the type of block to continue within an ContinueStatement.
Public class | ExitKind | Specifies the type of block to exit within an ExitStatement.
Public class | LiteralExpressionKind | Specifies the type of literal expression.
Public class | MemberAccessKind | Specifies the kind of a member access.
Public class | Modifiers | Specifies the modifiers for a type or member.
Public class | OperatorKind | Specifies the kind of an operator.
Public class | OrderingDirection | Specifies a sort order for an query expression ordering.
Public class | ParameterModifiers | Specifies the modifiers for a parameter.
Public class | TypeDeclarationKind | Specifies the kind of TypeDeclaration.
Public class | TypeMemberDeclarationKind | Specifies the kind of TypeMemberDeclaration.
Public class | VariableDeclaratorKind | Specifies the kind of VariableDeclarator.
Public class | VarianceAnnotation | Specifies the variance annotation for a type parameter.
Interfaces
 | Interface | Description
Public interface | IDecoratedMember | Provides the base requirements for a type or type member that has attributes and modifiers.
Public interface | INamedTypeMember | Provides the base requirements for a type member that has a name.


AccessorKind Class

AccessorKind Class
Specifies the kind of accessor.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstAccessorKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class AccessorKind : Enum
Public NotInheritable Class AccessorKind
    Inherits Enum

The AccessorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Add | An add handler event accessor.
 | Get | A get property accessor.
 | Raise | A raise event accessor.
 | Remove | A remove handler event accessor.
 | Set | A set property accessor.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind Methods

AccessorKind Methods

The AccessorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind Fields

AccessorKind Fields

The AccessorKind type exposes the following members.

Fields
 | Name | Description
 | Add | An add handler event accessor.
 | Get | A get property accessor.
 | Raise | A raise event accessor.
 | Remove | A remove handler event accessor.
 | Set | A set property accessor.
Public field | value__ |
Top
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind.Add Field

AccessorKindAdd Field
An add handler event accessor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AccessorKind Add = 2
Public Const Add As AccessorKind = 2

Field Value

Type: AccessorKind
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind.Get Field

AccessorKindGet Field
A get property accessor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AccessorKind Get = 0
Public Const Get As AccessorKind = 0

Field Value

Type: AccessorKind
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind.Raise Field

AccessorKindRaise Field
A raise event accessor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AccessorKind Raise = 4
Public Const Raise As AccessorKind = 4

Field Value

Type: AccessorKind
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind.Remove Field

AccessorKindRemove Field
A remove handler event accessor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AccessorKind Remove = 3
Public Const Remove As AccessorKind = 3

Field Value

Type: AccessorKind
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind.Set Field

AccessorKindSet Field
A set property accessor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AccessorKind Set = 1
Public Const Set As AccessorKind = 1

Field Value

Type: AccessorKind
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AccessorKind.value__ Field

AccessorKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.AccessorKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

AccessorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind Class

AttributeTargetKind Class
Specifies the kind of attribute target.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstAttributeTargetKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class AttributeTargetKind : Enum
Public NotInheritable Class AttributeTargetKind
    Inherits Enum

The AttributeTargetKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Assembly | An assembly.
 | Default | No specific attribute target.
 | Event | An event.
 | Field | A field.
 | Method | A method.
 | Module | A module.
 | Parameter | A parameter.
 | Property | A property.
 | Return | A return value.
 | Type | A type.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind Methods

AttributeTargetKind Methods

The AttributeTargetKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind Fields

AttributeTargetKind Fields

The AttributeTargetKind type exposes the following members.

Fields
 | Name | Description
 | Assembly | An assembly.
 | Default | No specific attribute target.
 | Event | An event.
 | Field | A field.
 | Method | A method.
 | Module | A module.
 | Parameter | A parameter.
 | Property | A property.
 | Return | A return value.
 | Type | A type.
Public field | value__ |
Top
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Assembly Field

AttributeTargetKindAssembly Field
An assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Assembly = 1
Public Const Assembly As AttributeTargetKind = 1

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Default Field

AttributeTargetKindDefault Field
No specific attribute target.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Default = 0
Public Const Default As AttributeTargetKind = 0

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Event Field

AttributeTargetKindEvent Field
An event.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Event = 4
Public Const Event As AttributeTargetKind = 4

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Field Field

AttributeTargetKindField Field
A field.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Field = 3
Public Const Field As AttributeTargetKind = 3

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Method Field

AttributeTargetKindMethod Field
A method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Method = 5
Public Const Method As AttributeTargetKind = 5

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Module Field

AttributeTargetKindModule Field
A module.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Module = 2
Public Const Module As AttributeTargetKind = 2

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Parameter Field

AttributeTargetKindParameter Field
A parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Parameter = 6
Public Const Parameter As AttributeTargetKind = 6

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Property Field

AttributeTargetKindProperty Field
A property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Property = 7
Public Const Property As AttributeTargetKind = 7

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Return Field

AttributeTargetKindReturn Field
A return value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Return = 8
Public Const Return As AttributeTargetKind = 8

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.Type Field

AttributeTargetKindType Field
A type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AttributeTargetKind Type = 9
Public Const Type As AttributeTargetKind = 9

Field Value

Type: AttributeTargetKind
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


AttributeTargetKind.value__ Field

AttributeTargetKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.AttributeTargetKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

AttributeTargetKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind Class

ConstructorInitializerKind Class
Specifies the type of constructor initializer.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstConstructorInitializerKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ConstructorInitializerKind : Enum
Public NotInheritable Class ConstructorInitializerKind
    Inherits Enum

The ConstructorInitializerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Base | Base reference.
 | None | No constructor initializer.
 | This | This reference.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind Methods

ConstructorInitializerKind Methods

The ConstructorInitializerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ConstructorInitializerKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind Fields

ConstructorInitializerKind Fields

The ConstructorInitializerKind type exposes the following members.

Fields
 | Name | Description
 | Base | Base reference.
 | None | No constructor initializer.
 | This | This reference.
Public field | value__ |
Top
See Also

Reference

ConstructorInitializerKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind.Base Field

ConstructorInitializerKindBase Field
Base reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ConstructorInitializerKind Base = 2
Public Const Base As ConstructorInitializerKind = 2

Field Value

Type: ConstructorInitializerKind
See Also

Reference

ConstructorInitializerKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind.None Field

ConstructorInitializerKindNone Field
No constructor initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ConstructorInitializerKind None = 0
Public Const None As ConstructorInitializerKind = 0

Field Value

Type: ConstructorInitializerKind
See Also

Reference

ConstructorInitializerKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind.This Field

ConstructorInitializerKindThis Field
This reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ConstructorInitializerKind This = 1
Public Const This As ConstructorInitializerKind = 1

Field Value

Type: ConstructorInitializerKind
See Also

Reference

ConstructorInitializerKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ConstructorInitializerKind.value__ Field

ConstructorInitializerKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.ConstructorInitializerKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ConstructorInitializerKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind Class

ContinueKind Class
Specifies the type of block to continue within an ContinueStatement.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstContinueKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ContinueKind : Enum
Public NotInheritable Class ContinueKind
    Inherits Enum

The ContinueKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The direct containing block.
 | Do | Do loop.
 | For | For loop.
Public field | value__ |
 | While | While loop.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind Methods

ContinueKind Methods

The ContinueKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind Fields

ContinueKind Fields

The ContinueKind type exposes the following members.

Fields
 | Name | Description
 | Default | The direct containing block.
 | Do | Do loop.
 | For | For loop.
Public field | value__ |
 | While | While loop.
Top
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind.Default Field

ContinueKindDefault Field
The direct containing block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContinueKind Default = 0
Public Const Default As ContinueKind = 0

Field Value

Type: ContinueKind
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind.Do Field

ContinueKindDo Field
Do loop.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContinueKind Do = 1
Public Const Do As ContinueKind = 1

Field Value

Type: ContinueKind
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind.For Field

ContinueKindFor Field
For loop.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContinueKind For = 2
Public Const For As ContinueKind = 2

Field Value

Type: ContinueKind
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind.value__ Field

ContinueKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.ContinueKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ContinueKind.While Field

ContinueKindWhile Field
While loop.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContinueKind While = 3
Public Const While As ContinueKind = 3

Field Value

Type: ContinueKind
See Also

Reference

ContinueKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind Class

ExitKind Class
Specifies the type of block to exit within an ExitStatement.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstExitKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ExitKind : Enum
Public NotInheritable Class ExitKind
    Inherits Enum

The ExitKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | The direct containing block.
 | Do | Do loop.
 | For | For loop.
 | Switch | Switch (Select in VB) statement.
 | Try | Try statement.
 | TypeMember | Method or property.
Public field | value__ |
 | While | While loop.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind Methods

ExitKind Methods

The ExitKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind Fields

ExitKind Fields

The ExitKind type exposes the following members.

Fields
 | Name | Description
 | Default | The direct containing block.
 | Do | Do loop.
 | For | For loop.
 | Switch | Switch (Select in VB) statement.
 | Try | Try statement.
 | TypeMember | Method or property.
Public field | value__ |
 | While | While loop.
Top
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.Default Field

ExitKindDefault Field
The direct containing block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind Default = 0
Public Const Default As ExitKind = 0

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.Do Field

ExitKindDo Field
Do loop.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind Do = 1
Public Const Do As ExitKind = 1

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.For Field

ExitKindFor Field
For loop.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind For = 2
Public Const For As ExitKind = 2

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.Switch Field

ExitKindSwitch Field
Switch (Select in VB) statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind Switch = 4
Public Const Switch As ExitKind = 4

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.Try Field

ExitKindTry Field
Try statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind Try = 5
Public Const Try As ExitKind = 5

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.TypeMember Field

ExitKindTypeMember Field
Method or property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind TypeMember = 6
Public Const TypeMember As ExitKind = 6

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.value__ Field

ExitKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.ExitKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ExitKind.While Field

ExitKindWhile Field
While loop.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ExitKind While = 3
Public Const While As ExitKind = 3

Field Value

Type: ExitKind
See Also

Reference

ExitKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember Interface

IDecoratedMember Interface
Provides the base requirements for a type or type member that has attributes and modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDecoratedMember : IAstNode
Public Interface IDecoratedMember
    Inherits IAstNode

The IDecoratedMember type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember Properties

IDecoratedMember Properties

The IDecoratedMember type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember.AttributeSections Property

IDecoratedMemberAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<AttributeSection> AttributeSections { get; }
ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember.Modifiers Property

IDecoratedMemberModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Modifiers Modifiers { get; set; }
Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


IDecoratedMember Methods

IDecoratedMember Methods

The IDecoratedMember type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

IDecoratedMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember Interface

INamedTypeMember Interface
Provides the base requirements for a type member that has a name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INamedTypeMember : IAstNode
Public Interface INamedTypeMember
    Inherits IAstNode

The INamedTypeMember type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Name | Gets or sets the member name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember Properties

INamedTypeMember Properties

The INamedTypeMember type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from IAstNode.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from IAstNode.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from IAstNode.)
Public property | Id | Gets an integer value that identifies the type of AST node, if known. (Inherited from IAstNode.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from IAstNode.)
Public property | Name | Gets or sets the member name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from IAstNode.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from IAstNode.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from IAstNode.)
Top
See Also

Reference

INamedTypeMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember.Name Property

INamedTypeMemberName Property
Gets or sets the member name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SimpleName Name { get; set; }
Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The member name.
See Also

Reference

INamedTypeMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


INamedTypeMember Methods

INamedTypeMember Methods

The INamedTypeMember type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from IAstNode.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from IAstNode.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from IAstNode.)
Top
See Also

Reference

INamedTypeMember Interface
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind Class

LiteralExpressionKind Class
Specifies the type of literal expression.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstLiteralExpressionKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LiteralExpressionKind : Enum
Public NotInheritable Class LiteralExpressionKind
    Inherits Enum

The LiteralExpressionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Boolean | A boolean.
 | Character | A character.
 | DateTime | A date/time.
 | DecimalInteger | A decimal integer.
 | HexadecimalInteger | A hexadecimal integer.
 | None | No kind indicated.
 | Null | A null value.
 | OctalInteger | An octal integer.
 | Real | A real number.
 | String | A string of characters.
Public field | value__ |
 | VerbatimString | A verbatim string.
 | Xml | A XML fragment.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind Methods

LiteralExpressionKind Methods

The LiteralExpressionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind Fields

LiteralExpressionKind Fields

The LiteralExpressionKind type exposes the following members.

Fields
 | Name | Description
 | Boolean | A boolean.
 | Character | A character.
 | DateTime | A date/time.
 | DecimalInteger | A decimal integer.
 | HexadecimalInteger | A hexadecimal integer.
 | None | No kind indicated.
 | Null | A null value.
 | OctalInteger | An octal integer.
 | Real | A real number.
 | String | A string of characters.
Public field | value__ |
 | VerbatimString | A verbatim string.
 | Xml | A XML fragment.
Top
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.Boolean Field

LiteralExpressionKindBoolean Field
A boolean.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Boolean = 2
Public Const Boolean As LiteralExpressionKind = 2

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.Character Field

LiteralExpressionKindCharacter Field
A character.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Character = 7
Public Const Character As LiteralExpressionKind = 7

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.DateTime Field

LiteralExpressionKindDateTime Field
A date/time.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DateTime = 10
Public Const DateTime As LiteralExpressionKind = 10

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.DecimalInteger Field

LiteralExpressionKindDecimalInteger Field
A decimal integer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DecimalInteger = 3
Public Const DecimalInteger As LiteralExpressionKind = 3

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.HexadecimalInteger Field

LiteralExpressionKindHexadecimalInteger Field
A hexadecimal integer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind HexadecimalInteger = 4
Public Const HexadecimalInteger As LiteralExpressionKind = 4

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.None Field

LiteralExpressionKindNone Field
No kind indicated.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind None = 0
Public Const None As LiteralExpressionKind = 0

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.Null Field

LiteralExpressionKindNull Field
A null value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Null = 1
Public Const Null As LiteralExpressionKind = 1

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.OctalInteger Field

LiteralExpressionKindOctalInteger Field
An octal integer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind OctalInteger = 5
Public Const OctalInteger As LiteralExpressionKind = 5

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.Real Field

LiteralExpressionKindReal Field
A real number.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Real = 6
Public Const Real As LiteralExpressionKind = 6

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.String Field

LiteralExpressionKindString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind String = 8
Public Const String As LiteralExpressionKind = 8

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.value__ Field

LiteralExpressionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.LiteralExpressionKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.VerbatimString Field

LiteralExpressionKindVerbatimString Field
A verbatim string.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind VerbatimString = 9
Public Const VerbatimString As LiteralExpressionKind = 9

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


LiteralExpressionKind.Xml Field

LiteralExpressionKindXml Field
A XML fragment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Xml = 11
Public Const Xml As LiteralExpressionKind = 11

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind Class

MemberAccessKind Class
Specifies the kind of a member access.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstMemberAccessKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MemberAccessKind : Enum
Public NotInheritable Class MemberAccessKind
    Inherits Enum

The MemberAccessKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BaseType | The member is on the current instance's base type, and overridden/shadowed members in derived classes are ignored. In C#: base; In VB: MyBase
 | Default | The standard type of access. When used on VB's XML elements, this also indicates element access.
 | Dictionary | Dictionary. In VB: element!param
 | Global | Accesses the root global namespace. In VB: Global
 | PointerDereference | Pointer dereference (C# only).
 | ThisType | The member is on the current instance's type, and overridden/shadowed members in derived classes are ignored. In VB: MyClass
Public field | value__ |
 | XmlAttribute | XML attribute access. In VB: element.@attributename
 | XmlDescendant | XML descendant access. In VB: element...<childelement>
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind Methods

MemberAccessKind Methods

The MemberAccessKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind Fields

MemberAccessKind Fields

The MemberAccessKind type exposes the following members.

Fields
 | Name | Description
 | BaseType | The member is on the current instance's base type, and overridden/shadowed members in derived classes are ignored. In C#: base; In VB: MyBase
 | Default | The standard type of access. When used on VB's XML elements, this also indicates element access.
 | Dictionary | Dictionary. In VB: element!param
 | Global | Accesses the root global namespace. In VB: Global
 | PointerDereference | Pointer dereference (C# only).
 | ThisType | The member is on the current instance's type, and overridden/shadowed members in derived classes are ignored. In VB: MyClass
Public field | value__ |
 | XmlAttribute | XML attribute access. In VB: element.@attributename
 | XmlDescendant | XML descendant access. In VB: element...<childelement>
Top
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.BaseType Field

MemberAccessKindBaseType Field
The member is on the current instance's base type, and overridden/shadowed members in derived classes are ignored. In C#: base; In VB: MyBase

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind BaseType = 2
Public Const BaseType As MemberAccessKind = 2

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.Default Field

MemberAccessKindDefault Field
The standard type of access. When used on VB's XML elements, this also indicates element access.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind Default = 0
Public Const Default As MemberAccessKind = 0

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.Dictionary Field

MemberAccessKindDictionary Field
Dictionary. In VB: element!param

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind Dictionary = 5
Public Const Dictionary As MemberAccessKind = 5

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.Global Field

MemberAccessKindGlobal Field
Accesses the root global namespace. In VB: Global

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind Global = 3
Public Const Global As MemberAccessKind = 3

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.PointerDereference Field

MemberAccessKindPointerDereference Field
Pointer dereference (C# only).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind PointerDereference = 4
Public Const PointerDereference As MemberAccessKind = 4

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.ThisType Field

MemberAccessKindThisType Field
The member is on the current instance's type, and overridden/shadowed members in derived classes are ignored. In VB: MyClass

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind ThisType = 1
Public Const ThisType As MemberAccessKind = 1

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.value__ Field

MemberAccessKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.MemberAccessKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.XmlAttribute Field

MemberAccessKindXmlAttribute Field
XML attribute access. In VB: element.@attributename

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind XmlAttribute = 6
Public Const XmlAttribute As MemberAccessKind = 6

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


MemberAccessKind.XmlDescendant Field

MemberAccessKindXmlDescendant Field
XML descendant access. In VB: element...<childelement>

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MemberAccessKind XmlDescendant = 7
Public Const XmlDescendant As MemberAccessKind = 7

Field Value

Type: MemberAccessKind
See Also

Reference

MemberAccessKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers Class

Modifiers Class
Specifies the modifiers for a type or member.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstModifiers

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class Modifiers : Enum
<FlagsAttribute>
Public NotInheritable Class Modifiers
    Inherits Enum

The Modifiers type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Abstract | Defines a class or member that must be inherited. Represents MustOverride and MustInherit in Visual Basic.
 | AccessMask | The bitmask for access modifiers.
 | Assembly | Internal (also known as Internal or Friend) access. Code within the assembly that declares an assembly element can access it.
 | Async | Specifies that the target procedure is asynchronously executed.
 | Default | Identifies a property as the default property of its class, structure, or interface. Used in Visual Basic only.
 | External | Defines a method that is implemented externally.
 | Family | Protected access. Code within the class that declares a family (also known as Protected) element, or a class derived from it, can access the element.
 | FamilyOrAssembly | Family or assembly access. This is a union of Family and Assembly access. Code within the same class or the same assembly as the element, or within any class derived from the element's class, can access it.
 | Final | Defines a class or member that cannot be overridden (also known as Sealed). Represents NotInheritable and NotOverridable in Visual Basic.
 | Iterator | Specifies that a property or procedure that contains an iterator. Used in Visual Basic only.
 | Narrowing | Indicates that a conversion operator (CType) converts a class or structure to a type that might not be able to hold some of the possible values of the original class or structure. Used in Visual Basic only.
 | New | Hides a defined member in a base class. Represents Shadows in Visual Basic.
 | None | No modifier.
 | Overloads | Specifies that a property or procedure redeclares one or more existing properties or procedures with the same name. Used in Visual Basic only.
 | Override | Defines a member that overrides a base abstract or virtual implementation. Represents Overrides in Visual Basic.
 | Partial | Defines the type as a partial type which is defined in multiple parts.
 | Private | Private access. Code within the type that declares a private element, including code within contained types, can access the element.
 | Public | Public access. Any code that can see a public element can access it.
 | ReadOnly | Defines a read-only member.
 | Static | Defines a static member. Represents Shared in Visual Basic.
 | Unsafe | Defines an unsafe context. Used in C# only.
Public field | value__ |
 | Virtual | Defines a member that can be overridden. Represents Overridable in Visual Basic.
 | Volatile | Defines a field that can be modified by multiple concurrently executing threads. Used in C# only.
 | Widening | Indicates that a conversion operator (CType) converts a class or structure to a type that can hold all possible values of the original class or structure. Used in Visual Basic only.
 | WithEvents | Specifies that one or more declared member variables refer to an instance of a class that can raise events. Used in Visual Basic only.
 | WriteOnly | Specifies that a property can be written but not read. Used in Visual Basic only.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers Methods

Modifiers Methods

The Modifiers type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers Fields

Modifiers Fields

The Modifiers type exposes the following members.

Fields
 | Name | Description
 | Abstract | Defines a class or member that must be inherited. Represents MustOverride and MustInherit in Visual Basic.
 | AccessMask | The bitmask for access modifiers.
 | Assembly | Internal (also known as Internal or Friend) access. Code within the assembly that declares an assembly element can access it.
 | Async | Specifies that the target procedure is asynchronously executed.
 | Default | Identifies a property as the default property of its class, structure, or interface. Used in Visual Basic only.
 | External | Defines a method that is implemented externally.
 | Family | Protected access. Code within the class that declares a family (also known as Protected) element, or a class derived from it, can access the element.
 | FamilyOrAssembly | Family or assembly access. This is a union of Family and Assembly access. Code within the same class or the same assembly as the element, or within any class derived from the element's class, can access it.
 | Final | Defines a class or member that cannot be overridden (also known as Sealed). Represents NotInheritable and NotOverridable in Visual Basic.
 | Iterator | Specifies that a property or procedure that contains an iterator. Used in Visual Basic only.
 | Narrowing | Indicates that a conversion operator (CType) converts a class or structure to a type that might not be able to hold some of the possible values of the original class or structure. Used in Visual Basic only.
 | New | Hides a defined member in a base class. Represents Shadows in Visual Basic.
 | None | No modifier.
 | Overloads | Specifies that a property or procedure redeclares one or more existing properties or procedures with the same name. Used in Visual Basic only.
 | Override | Defines a member that overrides a base abstract or virtual implementation. Represents Overrides in Visual Basic.
 | Partial | Defines the type as a partial type which is defined in multiple parts.
 | Private | Private access. Code within the type that declares a private element, including code within contained types, can access the element.
 | Public | Public access. Any code that can see a public element can access it.
 | ReadOnly | Defines a read-only member.
 | Static | Defines a static member. Represents Shared in Visual Basic.
 | Unsafe | Defines an unsafe context. Used in C# only.
Public field | value__ |
 | Virtual | Defines a member that can be overridden. Represents Overridable in Visual Basic.
 | Volatile | Defines a field that can be modified by multiple concurrently executing threads. Used in C# only.
 | Widening | Indicates that a conversion operator (CType) converts a class or structure to a type that can hold all possible values of the original class or structure. Used in Visual Basic only.
 | WithEvents | Specifies that one or more declared member variables refer to an instance of a class that can raise events. Used in Visual Basic only.
 | WriteOnly | Specifies that a property can be written but not read. Used in Visual Basic only.
Top
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Abstract Field

ModifiersAbstract Field
Defines a class or member that must be inherited. Represents MustOverride and MustInherit in Visual Basic.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Abstract = 256
Public Const Abstract As Modifiers = 256

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.AccessMask Field

ModifiersAccessMask Field
The bitmask for access modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers AccessMask = 15
Public Const AccessMask As Modifiers = 15

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Assembly Field

ModifiersAssembly Field
Internal (also known as Internal or Friend) access. Code within the assembly that declares an assembly element can access it.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Assembly = 2
Public Const Assembly As Modifiers = 2

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Async Field

ModifiersAsync Field
Specifies that the target procedure is asynchronously executed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Async = 512
Public Const Async As Modifiers = 512

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Default Field

ModifiersDefault Field
Identifies a property as the default property of its class, structure, or interface. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Default = 1024
Public Const Default As Modifiers = 1024

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.External Field

ModifiersExternal Field
Defines a method that is implemented externally.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers External = 2048
Public Const External As Modifiers = 2048

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Family Field

ModifiersFamily Field
Protected access. Code within the class that declares a family (also known as Protected) element, or a class derived from it, can access the element.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Family = 4
Public Const Family As Modifiers = 4

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.FamilyOrAssembly Field

ModifiersFamilyOrAssembly Field
Family or assembly access. This is a union of Family and Assembly access. Code within the same class or the same assembly as the element, or within any class derived from the element's class, can access it.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers FamilyOrAssembly = 6
Public Const FamilyOrAssembly As Modifiers = 6

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Final Field

ModifiersFinal Field
Defines a class or member that cannot be overridden (also known as Sealed). Represents NotInheritable and NotOverridable in Visual Basic.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Final = 4096
Public Const Final As Modifiers = 4096

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Iterator Field

ModifiersIterator Field
Specifies that a property or procedure that contains an iterator. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Iterator = 8192
Public Const Iterator As Modifiers = 8192

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Narrowing Field

ModifiersNarrowing Field
Indicates that a conversion operator (CType) converts a class or structure to a type that might not be able to hold some of the possible values of the original class or structure. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Narrowing = 16384
Public Const Narrowing As Modifiers = 16384

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.New Field

ModifiersNew Field
Hides a defined member in a base class. Represents Shadows in Visual Basic.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers New = 32768
Public Const New As Modifiers = 32768

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.None Field

ModifiersNone Field
No modifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers None = 0
Public Const None As Modifiers = 0

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Overloads Field

ModifiersOverloads Field
Specifies that a property or procedure redeclares one or more existing properties or procedures with the same name. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Overloads = 131072
Public Const Overloads As Modifiers = 131072

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Override Field

ModifiersOverride Field
Defines a member that overrides a base abstract or virtual implementation. Represents Overrides in Visual Basic.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Override = 262144
Public Const Override As Modifiers = 262144

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Partial Field

ModifiersPartial Field
Defines the type as a partial type which is defined in multiple parts.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Partial = 65536
Public Const Partial As Modifiers = 65536

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Private Field

ModifiersPrivate Field
Private access. Code within the type that declares a private element, including code within contained types, can access the element.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Private = 1
Public Const Private As Modifiers = 1

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Public Field

ModifiersPublic Field
Public access. Any code that can see a public element can access it.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Public = 8
Public Const Public As Modifiers = 8

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.ReadOnly Field

ModifiersReadOnly Field
Defines a read-only member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers ReadOnly = 524288
Public Const ReadOnly As Modifiers = 524288

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Static Field

ModifiersStatic Field
Defines a static member. Represents Shared in Visual Basic.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Static = 1048576
Public Const Static As Modifiers = 1048576

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Unsafe Field

ModifiersUnsafe Field
Defines an unsafe context. Used in C# only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Unsafe = 2097152
Public Const Unsafe As Modifiers = 2097152

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.value__ Field

Modifiersvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.Modifiers.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Virtual Field

ModifiersVirtual Field
Defines a member that can be overridden. Represents Overridable in Visual Basic.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Virtual = 4194304
Public Const Virtual As Modifiers = 4194304

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Volatile Field

ModifiersVolatile Field
Defines a field that can be modified by multiple concurrently executing threads. Used in C# only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Volatile = 8388608
Public Const Volatile As Modifiers = 8388608

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.Widening Field

ModifiersWidening Field
Indicates that a conversion operator (CType) converts a class or structure to a type that can hold all possible values of the original class or structure. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers Widening = 16777216
Public Const Widening As Modifiers = 16777216

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.WithEvents Field

ModifiersWithEvents Field
Specifies that one or more declared member variables refer to an instance of a class that can raise events. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers WithEvents = 33554432
Public Const WithEvents As Modifiers = 33554432

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


Modifiers.WriteOnly Field

ModifiersWriteOnly Field
Specifies that a property can be written but not read. Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Modifiers WriteOnly = 67108864
Public Const WriteOnly As Modifiers = 67108864

Field Value

Type: Modifiers
See Also

Reference

Modifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind Class

OperatorKind Class
Specifies the kind of an operator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstOperatorKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class OperatorKind : Enum
Public NotInheritable Class OperatorKind
    Inherits Enum

The OperatorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Addition | An addition operator.
 | AddressOf | An address-of operator.
 | BitwiseAnd | A bitwise AND operator.
 | BitwiseOr | A bitwise OR operator.
 | ConditionalAnd | A conditional AND binary operator.
 | ConditionalOr | A conditional OR binary operator.
 | Division | A division operator.
 | ExclusiveOr | A bitwise XOR operator.
 | ExplicitCast | An explicit cast operator.
 | Exponentiation | An exponentiation operator. Used in Visual Basic only (^).
 | GreaterThan | A greater than operator.
 | GreaterThanOrEqual | A greater than or equal operator.
 | ImplicitCast | An implicit cast operator.
 | IntegerDivision | An integer division operator. Used in Visual Basic only (\).
 | IsFalse | A false operator.
 | IsTrue | A true operator.
 | LeftShift | A left shift operator.
 | LessThan | A less than operator.
 | LessThanOrEqual | A less than or equal operator.
 | Modulus | A modulus operator.
 | Multiplication | A multiplication operator.
 | Negation | A negation operator.
 | None | No valid operator kind.
 | NullCoalescing | A null coalescing operator.
 | OnesComplement | A bitwise complement operator.
 | PointerIndirection | A pointer indirection operator.
 | PostDecrement | An post-decrement operator.
 | PostIncrement | An post-increment operator.
 | PreDecrement | An pre-decrement operator.
 | PreIncrement | An pre-increment operator.
 | ReferenceEquality | A reference equality operator. Used in Visual Basic only (Is).
 | ReferenceInequality | A reference inequality operator. Used in Visual Basic only (IsNot).
 | RightShift | A right shift operator.
 | StringConcatenation | A concatenation operator (&). Used in Visual Basic only.
 | Subtraction | A subtraction operator.
Public field | value__ |
 | ValueEquality | A value equality operator.
 | ValueInequality | A value inequality operator.
 | WildcardPatternMatch | A string wildcard pattern match operator. Used in Visual Basic only (Like).
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind Methods

OperatorKind Methods

The OperatorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind Fields

OperatorKind Fields

The OperatorKind type exposes the following members.

Fields
 | Name | Description
 | Addition | An addition operator.
 | AddressOf | An address-of operator.
 | BitwiseAnd | A bitwise AND operator.
 | BitwiseOr | A bitwise OR operator.
 | ConditionalAnd | A conditional AND binary operator.
 | ConditionalOr | A conditional OR binary operator.
 | Division | A division operator.
 | ExclusiveOr | A bitwise XOR operator.
 | ExplicitCast | An explicit cast operator.
 | Exponentiation | An exponentiation operator. Used in Visual Basic only (^).
 | GreaterThan | A greater than operator.
 | GreaterThanOrEqual | A greater than or equal operator.
 | ImplicitCast | An implicit cast operator.
 | IntegerDivision | An integer division operator. Used in Visual Basic only (\).
 | IsFalse | A false operator.
 | IsTrue | A true operator.
 | LeftShift | A left shift operator.
 | LessThan | A less than operator.
 | LessThanOrEqual | A less than or equal operator.
 | Modulus | A modulus operator.
 | Multiplication | A multiplication operator.
 | Negation | A negation operator.
 | None | No valid operator kind.
 | NullCoalescing | A null coalescing operator.
 | OnesComplement | A bitwise complement operator.
 | PointerIndirection | A pointer indirection operator.
 | PostDecrement | An post-decrement operator.
 | PostIncrement | An post-increment operator.
 | PreDecrement | An pre-decrement operator.
 | PreIncrement | An pre-increment operator.
 | ReferenceEquality | A reference equality operator. Used in Visual Basic only (Is).
 | ReferenceInequality | A reference inequality operator. Used in Visual Basic only (IsNot).
 | RightShift | A right shift operator.
 | StringConcatenation | A concatenation operator (&). Used in Visual Basic only.
 | Subtraction | A subtraction operator.
Public field | value__ |
 | ValueEquality | A value equality operator.
 | ValueInequality | A value inequality operator.
 | WildcardPatternMatch | A string wildcard pattern match operator. Used in Visual Basic only (Like).
Top
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Addition Field

OperatorKindAddition Field
An addition operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Addition = 1
Public Const Addition As OperatorKind = 1

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.AddressOf Field

OperatorKindAddressOf Field
An address-of operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind AddressOf = 30
Public Const AddressOf As OperatorKind = 30

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.BitwiseAnd Field

OperatorKindBitwiseAnd Field
A bitwise AND operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind BitwiseAnd = 6
Public Const BitwiseAnd As OperatorKind = 6

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.BitwiseOr Field

OperatorKindBitwiseOr Field
A bitwise OR operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind BitwiseOr = 7
Public Const BitwiseOr As OperatorKind = 7

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ConditionalAnd Field

OperatorKindConditionalAnd Field
A conditional AND binary operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ConditionalAnd = 28
Public Const ConditionalAnd As OperatorKind = 28

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ConditionalOr Field

OperatorKindConditionalOr Field
A conditional OR binary operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ConditionalOr = 27
Public Const ConditionalOr As OperatorKind = 27

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Division Field

OperatorKindDivision Field
A division operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Division = 4
Public Const Division As OperatorKind = 4

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ExclusiveOr Field

OperatorKindExclusiveOr Field
A bitwise XOR operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ExclusiveOr = 8
Public Const ExclusiveOr As OperatorKind = 8

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ExplicitCast Field

OperatorKindExplicitCast Field
An explicit cast operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ExplicitCast = 26
Public Const ExplicitCast As OperatorKind = 26

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Exponentiation Field

OperatorKindExponentiation Field
An exponentiation operator. Used in Visual Basic only (^).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Exponentiation = 37
Public Const Exponentiation As OperatorKind = 37

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.GreaterThan Field

OperatorKindGreaterThan Field
A greater than operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind GreaterThan = 12
Public Const GreaterThan As OperatorKind = 12

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.GreaterThanOrEqual Field

OperatorKindGreaterThanOrEqual Field
A greater than or equal operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind GreaterThanOrEqual = 22
Public Const GreaterThanOrEqual As OperatorKind = 22

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ImplicitCast Field

OperatorKindImplicitCast Field
An implicit cast operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ImplicitCast = 25
Public Const ImplicitCast As OperatorKind = 25

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.IntegerDivision Field

OperatorKindIntegerDivision Field
An integer division operator. Used in Visual Basic only (\).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind IntegerDivision = 36
Public Const IntegerDivision As OperatorKind = 36

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.IsFalse Field

OperatorKindIsFalse Field
A false operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind IsFalse = 24
Public Const IsFalse As OperatorKind = 24

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.IsTrue Field

OperatorKindIsTrue Field
A true operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind IsTrue = 23
Public Const IsTrue As OperatorKind = 23

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.LeftShift Field

OperatorKindLeftShift Field
A left shift operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LeftShift = 17
Public Const LeftShift As OperatorKind = 17

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.LessThan Field

OperatorKindLessThan Field
A less than operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LessThan = 11
Public Const LessThan As OperatorKind = 11

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.LessThanOrEqual Field

OperatorKindLessThanOrEqual Field
A less than or equal operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LessThanOrEqual = 21
Public Const LessThanOrEqual As OperatorKind = 21

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Modulus Field

OperatorKindModulus Field
A modulus operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Modulus = 5
Public Const Modulus As OperatorKind = 5

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Multiplication Field

OperatorKindMultiplication Field
A multiplication operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Multiplication = 3
Public Const Multiplication As OperatorKind = 3

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Negation Field

OperatorKindNegation Field
A negation operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Negation = 9
Public Const Negation As OperatorKind = 9

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.None Field

OperatorKindNone Field
No valid operator kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind None = 0
Public Const None As OperatorKind = 0

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.NullCoalescing Field

OperatorKindNullCoalescing Field
A null coalescing operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind NullCoalescing = 31
Public Const NullCoalescing As OperatorKind = 31

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.OnesComplement Field

OperatorKindOnesComplement Field
A bitwise complement operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind OnesComplement = 10
Public Const OnesComplement As OperatorKind = 10

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.PointerIndirection Field

OperatorKindPointerIndirection Field
A pointer indirection operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PointerIndirection = 29
Public Const PointerIndirection As OperatorKind = 29

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.PostDecrement Field

OperatorKindPostDecrement Field
An post-decrement operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PostDecrement = 16
Public Const PostDecrement As OperatorKind = 16

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.PostIncrement Field

OperatorKindPostIncrement Field
An post-increment operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PostIncrement = 15
Public Const PostIncrement As OperatorKind = 15

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.PreDecrement Field

OperatorKindPreDecrement Field
An pre-decrement operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PreDecrement = 14
Public Const PreDecrement As OperatorKind = 14

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.PreIncrement Field

OperatorKindPreIncrement Field
An pre-increment operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PreIncrement = 13
Public Const PreIncrement As OperatorKind = 13

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ReferenceEquality Field

OperatorKindReferenceEquality Field
A reference equality operator. Used in Visual Basic only (Is).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ReferenceEquality = 32
Public Const ReferenceEquality As OperatorKind = 32

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ReferenceInequality Field

OperatorKindReferenceInequality Field
A reference inequality operator. Used in Visual Basic only (IsNot).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ReferenceInequality = 33
Public Const ReferenceInequality As OperatorKind = 33

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.RightShift Field

OperatorKindRightShift Field
A right shift operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind RightShift = 18
Public Const RightShift As OperatorKind = 18

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.StringConcatenation Field

OperatorKindStringConcatenation Field
A concatenation operator (&). Used in Visual Basic only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind StringConcatenation = 35
Public Const StringConcatenation As OperatorKind = 35

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.Subtraction Field

OperatorKindSubtraction Field
A subtraction operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Subtraction = 2
Public Const Subtraction As OperatorKind = 2

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.value__ Field

OperatorKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.OperatorKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ValueEquality Field

OperatorKindValueEquality Field
A value equality operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ValueEquality = 19
Public Const ValueEquality As OperatorKind = 19

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.ValueInequality Field

OperatorKindValueInequality Field
A value inequality operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ValueInequality = 20
Public Const ValueInequality As OperatorKind = 20

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OperatorKind.WildcardPatternMatch Field

OperatorKindWildcardPatternMatch Field
A string wildcard pattern match operator. Used in Visual Basic only (Like).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind WildcardPatternMatch = 34
Public Const WildcardPatternMatch As OperatorKind = 34

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection Class

OrderingDirection Class
Specifies a sort order for an query expression ordering.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstOrderingDirection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class OrderingDirection : Enum
Public NotInheritable Class OrderingDirection
    Inherits Enum

The OrderingDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Ascending | Ascending order.
 | Descending | Descending order.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection Methods

OrderingDirection Methods

The OrderingDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

OrderingDirection Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection Fields

OrderingDirection Fields

The OrderingDirection type exposes the following members.

Fields
 | Name | Description
 | Ascending | Ascending order.
 | Descending | Descending order.
Public field | value__ |
Top
See Also

Reference

OrderingDirection Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection.Ascending Field

OrderingDirectionAscending Field
Ascending order.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OrderingDirection Ascending = 0
Public Const Ascending As OrderingDirection = 0

Field Value

Type: OrderingDirection
See Also

Reference

OrderingDirection Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection.Descending Field

OrderingDirectionDescending Field
Descending order.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OrderingDirection Descending = 1
Public Const Descending As OrderingDirection = 1

Field Value

Type: OrderingDirection
See Also

Reference

OrderingDirection Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


OrderingDirection.value__ Field

OrderingDirectionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.OrderingDirection.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

OrderingDirection Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers Class

ParameterModifiers Class
Specifies the modifiers for a parameter.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstParameterModifiers

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class ParameterModifiers : Enum
<FlagsAttribute>
Public NotInheritable Class ParameterModifiers
    Inherits Enum

The ParameterModifiers type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ByReference | A pass-by-reference parameter.
 | Extension | An extension method target parameter.
 | None | No modifier.
 | Optional | The parameter is optional.
 | Output | An output parameter.
 | ParameterArray | The parameter is a parameter array.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers Methods

ParameterModifiers Methods

The ParameterModifiers type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers Fields

ParameterModifiers Fields

The ParameterModifiers type exposes the following members.

Fields
 | Name | Description
 | ByReference | A pass-by-reference parameter.
 | Extension | An extension method target parameter.
 | None | No modifier.
 | Optional | The parameter is optional.
 | Output | An output parameter.
 | ParameterArray | The parameter is a parameter array.
Public field | value__ |
Top
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.ByReference Field

ParameterModifiersByReference Field
A pass-by-reference parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterModifiers ByReference = 1
Public Const ByReference As ParameterModifiers = 1

Field Value

Type: ParameterModifiers
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.Extension Field

ParameterModifiersExtension Field
An extension method target parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterModifiers Extension = 16
Public Const Extension As ParameterModifiers = 16

Field Value

Type: ParameterModifiers
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.None Field

ParameterModifiersNone Field
No modifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterModifiers None = 0
Public Const None As ParameterModifiers = 0

Field Value

Type: ParameterModifiers
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.Optional Field

ParameterModifiersOptional Field
The parameter is optional.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterModifiers Optional = 8
Public Const Optional As ParameterModifiers = 8

Field Value

Type: ParameterModifiers
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.Output Field

ParameterModifiersOutput Field
An output parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterModifiers Output = 2
Public Const Output As ParameterModifiers = 2

Field Value

Type: ParameterModifiers
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.ParameterArray Field

ParameterModifiersParameterArray Field
The parameter is a parameter array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterModifiers ParameterArray = 4
Public Const ParameterArray As ParameterModifiers = 4

Field Value

Type: ParameterModifiers
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ParameterModifiers.value__ Field

ParameterModifiersvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.ParameterModifiers.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ParameterModifiers Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind Class

TypeDeclarationKind Class
Specifies the kind of TypeDeclaration.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstTypeDeclarationKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TypeDeclarationKind : Enum
Public NotInheritable Class TypeDeclarationKind
    Inherits Enum

The TypeDeclarationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Class | A class.
 | Delegate | A delegate.
 | Enumeration | An enumeration.
 | Interface | An interface.
 | Structure | A structure.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind Methods

TypeDeclarationKind Methods

The TypeDeclarationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind Fields

TypeDeclarationKind Fields

The TypeDeclarationKind type exposes the following members.

Fields
 | Name | Description
 | Class | A class.
 | Delegate | A delegate.
 | Enumeration | An enumeration.
 | Interface | An interface.
 | Structure | A structure.
Public field | value__ |
Top
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind.Class Field

TypeDeclarationKindClass Field
A class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDeclarationKind Class = 0
Public Const Class As TypeDeclarationKind = 0

Field Value

Type: TypeDeclarationKind
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind.Delegate Field

TypeDeclarationKindDelegate Field
A delegate.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDeclarationKind Delegate = 1
Public Const Delegate As TypeDeclarationKind = 1

Field Value

Type: TypeDeclarationKind
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind.Enumeration Field

TypeDeclarationKindEnumeration Field
An enumeration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDeclarationKind Enumeration = 2
Public Const Enumeration As TypeDeclarationKind = 2

Field Value

Type: TypeDeclarationKind
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind.Interface Field

TypeDeclarationKindInterface Field
An interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDeclarationKind Interface = 3
Public Const Interface As TypeDeclarationKind = 3

Field Value

Type: TypeDeclarationKind
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind.Structure Field

TypeDeclarationKindStructure Field
A structure.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDeclarationKind Structure = 4
Public Const Structure As TypeDeclarationKind = 4

Field Value

Type: TypeDeclarationKind
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeDeclarationKind.value__ Field

TypeDeclarationKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.TypeDeclarationKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TypeDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind Class

TypeMemberDeclarationKind Class
Specifies the kind of TypeMemberDeclaration.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstTypeMemberDeclarationKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TypeMemberDeclarationKind : Enum
Public NotInheritable Class TypeMemberDeclarationKind
    Inherits Enum

The TypeMemberDeclarationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Constructor | A constructor.
 | EnumerationMember | An enumeration member.
 | Event | An event.
 | Field | A field.
 | FixedSizeBuffer | A fixed-size buffer.
 | InterfaceEvent | An interface event.
 | InterfaceMethod | An interface method.
 | InterfaceProperty | An interface property.
 | Method | A method.
 | Operator | An operator.
 | Property | A property.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind Methods

TypeMemberDeclarationKind Methods

The TypeMemberDeclarationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind Fields

TypeMemberDeclarationKind Fields

The TypeMemberDeclarationKind type exposes the following members.

Fields
 | Name | Description
 | Constructor | A constructor.
 | EnumerationMember | An enumeration member.
 | Event | An event.
 | Field | A field.
 | FixedSizeBuffer | A fixed-size buffer.
 | InterfaceEvent | An interface event.
 | InterfaceMethod | An interface method.
 | InterfaceProperty | An interface property.
 | Method | A method.
 | Operator | An operator.
 | Property | A property.
Public field | value__ |
Top
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.Constructor Field

TypeMemberDeclarationKindConstructor Field
A constructor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind Constructor = 0
Public Const Constructor As TypeMemberDeclarationKind = 0

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.EnumerationMember Field

TypeMemberDeclarationKindEnumerationMember Field
An enumeration member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind EnumerationMember = 1
Public Const EnumerationMember As TypeMemberDeclarationKind = 1

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.Event Field

TypeMemberDeclarationKindEvent Field
An event.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind Event = 2
Public Const Event As TypeMemberDeclarationKind = 2

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.Field Field

TypeMemberDeclarationKindField Field
A field.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind Field = 3
Public Const Field As TypeMemberDeclarationKind = 3

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.FixedSizeBuffer Field

TypeMemberDeclarationKindFixedSizeBuffer Field
A fixed-size buffer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind FixedSizeBuffer = 4
Public Const FixedSizeBuffer As TypeMemberDeclarationKind = 4

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.InterfaceEvent Field

TypeMemberDeclarationKindInterfaceEvent Field
An interface event.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind InterfaceEvent = 5
Public Const InterfaceEvent As TypeMemberDeclarationKind = 5

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.InterfaceMethod Field

TypeMemberDeclarationKindInterfaceMethod Field
An interface method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind InterfaceMethod = 6
Public Const InterfaceMethod As TypeMemberDeclarationKind = 6

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.InterfaceProperty Field

TypeMemberDeclarationKindInterfaceProperty Field
An interface property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind InterfaceProperty = 7
Public Const InterfaceProperty As TypeMemberDeclarationKind = 7

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.Method Field

TypeMemberDeclarationKindMethod Field
A method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind Method = 8
Public Const Method As TypeMemberDeclarationKind = 8

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.Operator Field

TypeMemberDeclarationKindOperator Field
An operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind Operator = 9
Public Const Operator As TypeMemberDeclarationKind = 9

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.Property Field

TypeMemberDeclarationKindProperty Field
A property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDeclarationKind Property = 10
Public Const Property As TypeMemberDeclarationKind = 10

Field Value

Type: TypeMemberDeclarationKind
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


TypeMemberDeclarationKind.value__ Field

TypeMemberDeclarationKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.TypeMemberDeclarationKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TypeMemberDeclarationKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind Class

VariableDeclaratorKind Class
Specifies the kind of VariableDeclarator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstVariableDeclaratorKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class VariableDeclaratorKind : Enum
Public NotInheritable Class VariableDeclaratorKind
    Inherits Enum

The VariableDeclaratorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Constant | A constant variable.
 | Default | A normal variable.
 | Static | A static variable that retains its value between containing member invocations (VB only).
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind Methods

VariableDeclaratorKind Methods

The VariableDeclaratorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

VariableDeclaratorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind Fields

VariableDeclaratorKind Fields

The VariableDeclaratorKind type exposes the following members.

Fields
 | Name | Description
 | Constant | A constant variable.
 | Default | A normal variable.
 | Static | A static variable that retains its value between containing member invocations (VB only).
Public field | value__ |
Top
See Also

Reference

VariableDeclaratorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind.Constant Field

VariableDeclaratorKindConstant Field
A constant variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const VariableDeclaratorKind Constant = 1
Public Const Constant As VariableDeclaratorKind = 1

Field Value

Type: VariableDeclaratorKind
See Also

Reference

VariableDeclaratorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind.Default Field

VariableDeclaratorKindDefault Field
A normal variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const VariableDeclaratorKind Default = 0
Public Const Default As VariableDeclaratorKind = 0

Field Value

Type: VariableDeclaratorKind
See Also

Reference

VariableDeclaratorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind.Static Field

VariableDeclaratorKindStatic Field
A static variable that retains its value between containing member invocations (VB only).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const VariableDeclaratorKind Static = 2
Public Const Static As VariableDeclaratorKind = 2

Field Value

Type: VariableDeclaratorKind
See Also

Reference

VariableDeclaratorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VariableDeclaratorKind.value__ Field

VariableDeclaratorKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.VariableDeclaratorKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

VariableDeclaratorKind Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation Class

VarianceAnnotation Class
Specifies the variance annotation for a type parameter.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.AstVarianceAnnotation

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class VarianceAnnotation : Enum
Public NotInheritable Class VarianceAnnotation
    Inherits Enum

The VarianceAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Contravariant | The matching type can be less derived than what is defined (marked in C# via in and VB via In).
 | Covariant | The matching type can be more derived than what is defined (marked in C# via out and VB via Out).
 | Invariant | No variance annotation, the default value.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation Methods

VarianceAnnotation Methods

The VarianceAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

VarianceAnnotation Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation Fields

VarianceAnnotation Fields

The VarianceAnnotation type exposes the following members.

Fields
 | Name | Description
 | Contravariant | The matching type can be less derived than what is defined (marked in C# via in and VB via In).
 | Covariant | The matching type can be more derived than what is defined (marked in C# via out and VB via Out).
 | Invariant | No variance annotation, the default value.
Public field | value__ |
Top
See Also

Reference

VarianceAnnotation Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation.Contravariant Field

VarianceAnnotationContravariant Field
The matching type can be less derived than what is defined (marked in C# via in and VB via In).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const VarianceAnnotation Contravariant = 2
Public Const Contravariant As VarianceAnnotation = 2

Field Value

Type: VarianceAnnotation
See Also

Reference

VarianceAnnotation Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation.Covariant Field

VarianceAnnotationCovariant Field
The matching type can be more derived than what is defined (marked in C# via out and VB via Out).

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const VarianceAnnotation Covariant = 1
Public Const Covariant As VarianceAnnotation = 1

Field Value

Type: VarianceAnnotation
See Also

Reference

VarianceAnnotation Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation.Invariant Field

VarianceAnnotationInvariant Field
No variance annotation, the default value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const VarianceAnnotation Invariant = 0
Public Const Invariant As VarianceAnnotation = 0

Field Value

Type: VarianceAnnotation
See Also

Reference

VarianceAnnotation Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


VarianceAnnotation.value__ Field

VarianceAnnotationvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Ast.VarianceAnnotation.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

VarianceAnnotation Class
ActiproSoftware.Text.Languages.DotNet.Ast Namespace


ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Contains the implementation types related to ASTs for a .NET syntax language.
Classes
 | Class | Description
Public class | AccessorBody | Represents an accessor body.
Public class | AccessorDeclaration | Represents an accessor declaration.
Public class | AddressOfExpression | Represents an address of expression (VB only).
Public class | AggregateQueryOperator | Represents an aggregate query operator (VB only).
Public class | AnonymousMethodExpression | Represents an anonymous method expression.
Public class | Argument | Represents an argument.
Public class | ArrayEraseStatement | Represents an array erase statement.
Public class | ArrayReallocateClause | Represents an array reallocate clause.
Public class | ArrayReallocateStatement | Represents an array reallocate statement.
Public class | AssignmentExpression | Represents an assignment expression.
Public class | Attribute | Represents an attribute.
Public class | AttributeArgument | Represents an attribute argument.
Public class | AttributeSection | Represents an attribute section.
Public class | AwaitExpression | Represents an await expression.
Public class | BinaryOperatorExpression | Represents a binary operator expression.
Public class | BlockStatement | Represents a block statement.
Public class | BreakStatement | Represents a break statement.
Public class | CastExpression | Represents a cast expression.
Public class | CatchClause | Represents a catch clause.
Public class | CheckedExpression | Represents a checked expression.
Public class | CheckedStatement | Represents a checked statement.
Public class | ClassBody | Represents a class body.
Public class | ClassDeclaration | Represents a class declaration.
Public class | CompilationUnit | Represents a compilation unit.
Public class | CompilationUnitOption | Represents a compilation unit option.
Public class | ConditionalExpression | Represents a conditional expression.
Public class | ConstructorBody | Represents a constructor body.
Public class | ConstructorDeclaration | Represents a constructor declaration.
Public class | ContinueStatement | Represents a continue statement.
Public class | DefaultValueExpression | Represents a default value expression.
Public class | DelegateDeclaration | Represents a delegate declaration.
Public class | DistinctQueryOperator | Represents a distinct query operator (VB only).
Public class | DocumentationComment | Represents a documentation comment.
Public class | DoStatement | Represents a do statement.
Public class | DotNetAstNodeId | Contains the AST node IDs for the .NET language.
Public class | ElseIfSection | Represents an else if section (VB only).
Public class | EndStatement | Represents an end statement.
Public class | EnumerationBody | Represents an enumeration body.
Public class | EnumerationDeclaration | Represents an enumeration declaration.
Public class | EnumerationMemberDeclaration | Represents an enumeration member declaration.
Public class | EventBody | Represents an event body.
Public class | EventDeclaration | Represents an event declaration.
Public class | ExitStatement | Represents an exit statement.
Public class | Expression | Represents an expression.
Public class | ExpressionStatement | Represents an expression statement.
Public class | ExternalAliasDirective | Represents an external alias directive.
Public class | ExternalAliasDirectiveSection | Represents an external alias directive section.
Public class | FieldDeclaration | Represents a field declaration.
Public class | FixedSizeBufferDeclaration | Represents a fixed size buffer declaration.
Public class | FixedSizeBufferDeclarator | Represents a fixed size buffer declarator.
Public class | FixedStatement | Represents a fixed statement.
Public class | ForEachStatement | Represents a for each statement.
Public class | ForStatement | Represents a for statement.
Public class | FromQueryOperator | Represents a from query operator.
Public class | GoToStatement | Represents a go to statement.
Public class | GroupQueryOperator | Represents a group query operator.
Public class | IfStatement | Represents an if statement.
Public class | InitializerExpression | Represents an initializer expression.
Public class | InstanceExpression | Represents an instance expression.
Public class | InterfaceAccessorDeclaration | Represents an interface accessor declaration.
Public class | InterfaceBody | Represents an interface body.
Public class | InterfaceDeclaration | Represents an interface declaration.
Public class | InterfaceEventDeclaration | Represents an interface event declaration.
Public class | InterfaceMemberDeclaration | Represents an interface member declaration.
Public class | InterfaceMethodDeclaration | Represents an interface method declaration.
Public class | InterfacePropertyDeclaration | Represents an interface property declaration.
Public class | InvocationExpression | Represents an invocation expression.
Public class | IsTypeOfExpression | Represents an is type of expression.
Public class | JoinQueryOperator | Represents a join query operator.
Public class | LabeledStatement | Represents a labeled statement.
Public class | LambdaExpression | Represents a lambda expression.
Public class | LetQueryOperator | Represents a let query operator.
Public class | LiteralExpression | Represents a literal expression.
Public class | LocalVariableDeclaration | Represents a local variable declaration.
Public class | LockStatement | Represents a lock statement.
Public class | MemberAccess | Represents a member access.
Public class | MethodBody | Represents a method body.
Public class | MethodDeclaration | Represents a method declaration.
Public class | NamespaceBody | Represents a namespace body.
Public class | NamespaceDeclaration | Represents a namespace declaration.
Public class | ObjectCreationExpression | Represents an object creation expression.
Public class | OperatorBody | Represents an operator body.
Public class | OperatorDeclaration | Represents an operator declaration.
Public class | OrderByQueryOperator | Represents an order by query operator.
Public class | Ordering | Represents an ordering.
Public class | ParameterDeclaration | Represents a parameter declaration.
Public class | ParenthesizedExpression | Represents a parenthesized expression.
Public class | PreprocessorDirective | Represents a preprocessor directive.
Public class | PropertyBody | Represents a property body.
Public class | PropertyDeclaration | Represents a property declaration.
Public class | QualifiedName | Represents a qualified name.
Public class | QueryExpression | Represents a query expression.
Public class | QueryOperator | Represents a query operator.
Public class | RangeVariableDeclaration | Represents a range variable declaration.
Public class | RangeVariableDeclarator | Represents a range variable declarator.
Public class | RegionPreprocessorDirective | Represents a region preprocessor directive.
Public class | ReturnStatement | Represents a return statement.
Public class | ReturnTypeDeclaration | Represents a return type declaration.
Public class | ReturnTypeExpression | Represents a return type expression (used by resolver).
Public class | SelectQueryOperator | Represents a select query operator.
Public class | SimpleName | Represents a simple name.
Public class | SizeOfExpression | Represents a size of expression.
Public class | SkipQueryOperator | Represents a skip query operator (VB only).
Public class | SkipWhileQueryOperator | Represents a skip while query operator (VB only).
Public class | StackAllocationInitializer | Represents a stack allocation initializer.
Public class | Statement | Represents a statement.
Public class | StopStatement | Represents a stop statement.
Public class | StructureBody | Represents a structure body.
Public class | StructureDeclaration | Represents a structure declaration.
Public class | SwitchSection | Represents a switch section.
Public class | SwitchStatement | Represents a switch statement.
Public class | TakeQueryOperator | Represents a take query operator (VB only).
Public class | TakeWhileQueryOperator | Represents a take while query operator (VB only).
Public class | ThrowStatement | Represents a throw statement.
Public class | TryCastExpression | Represents a try cast expression.
Public class | TryStatement | Represents a try statement.
Public class | TypeDeclaration | Represents a type declaration.
Public class | TypeMemberDeclaration | Represents a type member declaration.
Public class | TypeOfExpression | Represents a type of expression.
Public class | TypeParameter | Represents a type parameter.
Public class | UnaryOperatorExpression | Represents an unary operator expression.
Public class | UncheckedExpression | Represents an unchecked expression.
Public class | UncheckedStatement | Represents an unchecked statement.
Public class | UnsafeStatement | Represents an unsafe statement.
Public class | UnstructuredErrorHandlerStatement | Represents an unstructured error handler statement.
Public class | UnstructuredErrorResumeStatement | Represents an unstructured error resume statement.
Public class | UnstructuredErrorThrowStatement | Represents an unstructured error throw statement.
Public class | UsingDirective | Represents an using directive.
Public class | UsingDirectiveSection | Represents an using directive section.
Public class | UsingStatement | Represents an using statement.
Public class | VariableDeclarationExpression | Represents a variable declaration expression.
Public class | VariableDeclarator | Represents a variable declarator.
Public class | WhereQueryOperator | Represents a where query operator.
Public class | WhileStatement | Represents a while statement.
Public class | WithStatement | Represents a with statement (VB only).
Public class | WithTargetExpression | Represents a with target expression (VB only).
Public class | XmlNamespaceExpression | Represents a xml namespace expression (VB only).
Public class | YieldStatement | Represents a yield statement.


AccessorBody Class

AccessorBody Class
Represents an accessor body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AccessorBody : AstNodeBase
Public Class AccessorBody
    Inherits AstNodeBase

The AccessorBody type exposes the following members.

Constructors
 | Name | Description
Public method | AccessorBody | Initializes a new instance of the AccessorBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody Constructor

AccessorBody Constructor
Initializes a new instance of the AccessorBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AccessorBody()
Public Sub New
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody Properties

AccessorBody Properties

The AccessorBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.HasStatements Property

AccessorBodyHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.Id Property

AccessorBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.Statements Property

AccessorBodyStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody Methods

AccessorBody Methods

The AccessorBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorBody.GetChildrenEnumerator Method

AccessorBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AccessorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Class

AccessorDeclaration Class
Represents an accessor declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AccessorDeclaration : AstNodeBase
Public Class AccessorDeclaration
    Inherits AstNodeBase

The AccessorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | AccessorDeclaration | Initializes a new instance of the AccessorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Constructor

AccessorDeclaration Constructor
Initializes a new instance of the AccessorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AccessorDeclaration()
Public Sub New
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Properties

AccessorDeclaration Properties

The AccessorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.AttributeSections Property

AccessorDeclarationAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Body Property

AccessorDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AccessorBody Body { get; set; }
Public Property Body As AccessorBody
    Get
    Set

Property Value

Type: AccessorBody
The body.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.HasAttributeSections Property

AccessorDeclarationHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.HasParameters Property

AccessorDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Id Property

AccessorDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Kind Property

AccessorDeclarationKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AccessorKind Kind { get; set; }
Public Property Kind As AccessorKind
    Get
    Set

Property Value

Type: AccessorKind
The kind.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Modifiers Property

AccessorDeclarationModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.Parameters Property

AccessorDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration Methods

AccessorDeclaration Methods

The AccessorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AccessorDeclaration.GetChildrenEnumerator Method

AccessorDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Class

AddressOfExpression Class
Represents an address of expression (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAddressOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AddressOfExpression : Expression
Public Class AddressOfExpression
    Inherits Expression

The AddressOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AddressOfExpression | Initializes a new instance of the AddressOfExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Constructor

AddressOfExpression Constructor
Initializes a new instance of the AddressOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AddressOfExpression()
Public Sub New
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Properties

AddressOfExpression Properties

The AddressOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression.ChildExpression Property

AddressOfExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression.Id Property

AddressOfExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression Methods

AddressOfExpression Methods

The AddressOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AddressOfExpression.GetChildrenEnumerator Method

AddressOfExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AddressOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Class

AggregateQueryOperator Class
Represents an aggregate query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAggregateQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AggregateQueryOperator : QueryOperator
Public Class AggregateQueryOperator
    Inherits QueryOperator

The AggregateQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | AggregateQueryOperator | Initializes a new instance of the AggregateQueryOperator class
Top
Properties
 | Name | Description
Public property | ChildQueryOperators | Gets the child query operators.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildQueryOperators | Returns whether the ChildQueryOperators collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Constructor

AggregateQueryOperator Constructor
Initializes a new instance of the AggregateQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AggregateQueryOperator()
Public Sub New
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Properties

AggregateQueryOperator Properties

The AggregateQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | ChildQueryOperators | Gets the child query operators.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildQueryOperators | Returns whether the ChildQueryOperators collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.ChildQueryOperators Property

AggregateQueryOperatorChildQueryOperators Property
Gets the child query operators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QueryOperator> ChildQueryOperators { get; }
Public ReadOnly Property ChildQueryOperators As IList(Of QueryOperator)
    Get

Property Value

Type: IList QueryOperator
The child query operators.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.Declarator Property

AggregateQueryOperatorDeclarator Property
Gets or sets the declarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclarator Declarator { get; set; }
Public Property Declarator As RangeVariableDeclarator
    Get
    Set

Property Value

Type: RangeVariableDeclarator
The declarator.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.HasChildQueryOperators Property

AggregateQueryOperatorHasChildQueryOperators Property
Returns whether the ChildQueryOperators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildQueryOperators { get; }
Public ReadOnly Property HasChildQueryOperators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.Id Property

AggregateQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.Projection Property

AggregateQueryOperatorProjection Property
Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator Methods

AggregateQueryOperator Methods

The AggregateQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AggregateQueryOperator.GetChildrenEnumerator Method

AggregateQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AggregateQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Class

AnonymousMethodExpression Class
Represents an anonymous method expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAnonymousMethodExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AnonymousMethodExpression : Expression
Public Class AnonymousMethodExpression
    Inherits Expression

The AnonymousMethodExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AnonymousMethodExpression | Initializes a new instance of the AnonymousMethodExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Constructor

AnonymousMethodExpression Constructor
Initializes a new instance of the AnonymousMethodExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AnonymousMethodExpression()
Public Sub New
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Properties

AnonymousMethodExpression Properties

The AnonymousMethodExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.HasParameters Property

AnonymousMethodExpressionHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.HasStatements Property

AnonymousMethodExpressionHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Id Property

AnonymousMethodExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Modifiers Property

AnonymousMethodExpressionModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Parameters Property

AnonymousMethodExpressionParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.Statements Property

AnonymousMethodExpressionStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression Methods

AnonymousMethodExpression Methods

The AnonymousMethodExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AnonymousMethodExpression.GetChildrenEnumerator Method

AnonymousMethodExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AnonymousMethodExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Class

Argument Class
Represents an argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArgument

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Argument : AstNodeBase
Public Class Argument
    Inherits AstNodeBase

The Argument type exposes the following members.

Constructors
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class.
Public method | Argument(Expression) | Initializes a new instance of the Argument class.
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Constructor

Argument Constructor
Overload List
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class.
Public method | Argument(Expression) | Initializes a new instance of the Argument class.
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Constructor

Argument Constructor
Initializes a new instance of the Argument class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Argument()
Public Sub New
See Also

Reference

Argument Class
Argument Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Constructor (Expression)

Argument Constructor (Expression)
Initializes a new instance of the Argument class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Argument(
    Expression expression
)
Public Sub New (
    expression As Expression
)

Parameters

expression
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
The expression.
See Also

Reference

Argument Class
Argument Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Properties

Argument Properties

The Argument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Expression Property

ArgumentExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Id Property

ArgumentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Modifiers Property

ArgumentModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParameterModifiers Modifiers { get; set; }
Public Property Modifiers As ParameterModifiers
    Get
    Set

Property Value

Type: ParameterModifiers
The modifiers.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.Name Property

ArgumentName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument Methods

Argument Methods

The Argument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Argument.GetChildrenEnumerator Method

ArgumentGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Class

ArrayEraseStatement Class
Represents an array erase statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayEraseStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ArrayEraseStatement : Statement
Public Class ArrayEraseStatement
    Inherits Statement

The ArrayEraseStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayEraseStatement | Initializes a new instance of the ArrayEraseStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableNames | Returns whether the VariableNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableNames | Gets the variable names.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Constructor

ArrayEraseStatement Constructor
Initializes a new instance of the ArrayEraseStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ArrayEraseStatement()
Public Sub New
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Properties

ArrayEraseStatement Properties

The ArrayEraseStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableNames | Returns whether the VariableNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableNames | Gets the variable names.
Top
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.HasVariableNames Property

ArrayEraseStatementHasVariableNames Property
Returns whether the VariableNames collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasVariableNames { get; }
Public ReadOnly Property HasVariableNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.Id Property

ArrayEraseStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.VariableNames Property

ArrayEraseStatementVariableNames Property
Gets the variable names.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> VariableNames { get; }
Public ReadOnly Property VariableNames As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The variable names.
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement Methods

ArrayEraseStatement Methods

The ArrayEraseStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayEraseStatement.GetChildrenEnumerator Method

ArrayEraseStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayEraseStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Class

ArrayReallocateClause Class
Represents an array reallocate clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateClause

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ArrayReallocateClause : AstNodeBase
Public Class ArrayReallocateClause
    Inherits AstNodeBase

The ArrayReallocateClause type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayReallocateClause | Initializes a new instance of the ArrayReallocateClause class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableName | Gets or sets the variable name.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Constructor

ArrayReallocateClause Constructor
Initializes a new instance of the ArrayReallocateClause class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ArrayReallocateClause()
Public Sub New
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Properties

ArrayReallocateClause Properties

The ArrayReallocateClause type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableName | Gets or sets the variable name.
Top
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.Arguments Property

ArrayReallocateClauseArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The arguments.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.ArrayRankSpecifiers Property

ArrayReallocateClauseArrayRankSpecifiers Property
Gets the array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<int> ArrayRankSpecifiers { get; }
Public ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The array rank specifiers.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.HasArguments Property

ArrayReallocateClauseHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.HasArrayRankSpecifiers Property

ArrayReallocateClauseHasArrayRankSpecifiers Property
Returns whether the ArrayRankSpecifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArrayRankSpecifiers { get; }
Public ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.Id Property

ArrayReallocateClauseId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.VariableName Property

ArrayReallocateClauseVariableName Property
Gets or sets the variable name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression VariableName { get; set; }
Public Property VariableName As Expression
    Get
    Set

Property Value

Type: Expression
The variable name.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause Methods

ArrayReallocateClause Methods

The ArrayReallocateClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateClause.GetChildrenEnumerator Method

ArrayReallocateClauseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayReallocateClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Class

ArrayReallocateStatement Class
Represents an array reallocate statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ArrayReallocateStatement : Statement
Public Class ArrayReallocateStatement
    Inherits Statement

The ArrayReallocateStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayReallocateStatement | Initializes a new instance of the ArrayReallocateStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clauses | Gets the clauses.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasClauses | Returns whether the Clauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PreserveData | Gets or sets the preserve data.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Constructor

ArrayReallocateStatement Constructor
Initializes a new instance of the ArrayReallocateStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ArrayReallocateStatement()
Public Sub New
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Properties

ArrayReallocateStatement Properties

The ArrayReallocateStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clauses | Gets the clauses.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasClauses | Returns whether the Clauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PreserveData | Gets or sets the preserve data.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.Clauses Property

ArrayReallocateStatementClauses Property
Gets the clauses.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ArrayReallocateClause> Clauses { get; }
Public ReadOnly Property Clauses As IList(Of ArrayReallocateClause)
    Get

Property Value

Type: IList ArrayReallocateClause
The clauses.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.HasClauses Property

ArrayReallocateStatementHasClauses Property
Returns whether the Clauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasClauses { get; }
Public ReadOnly Property HasClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.Id Property

ArrayReallocateStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.PreserveData Property

ArrayReallocateStatementPreserveData Property
Gets or sets the preserve data.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool PreserveData { get; set; }
Public Property PreserveData As Boolean
    Get
    Set

Property Value

Type: Boolean
The preserve data.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement Methods

ArrayReallocateStatement Methods

The ArrayReallocateStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ArrayReallocateStatement.GetChildrenEnumerator Method

ArrayReallocateStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayReallocateStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Class

AssignmentExpression Class
Represents an assignment expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAssignmentExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AssignmentExpression : Expression
Public Class AssignmentExpression
    Inherits Expression

The AssignmentExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AssignmentExpression | Initializes a new instance of the AssignmentExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Constructor

AssignmentExpression Constructor
Initializes a new instance of the AssignmentExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssignmentExpression()
Public Sub New
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Properties

AssignmentExpression Properties

The AssignmentExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.Id Property

AssignmentExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.LeftExpression Property

AssignmentExpressionLeftExpression Property
Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.Operator Property

AssignmentExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.RightExpression Property

AssignmentExpressionRightExpression Property
Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression Methods

AssignmentExpression Methods

The AssignmentExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AssignmentExpression.GetChildrenEnumerator Method

AssignmentExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Class

Attribute Class
Represents an attribute.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttribute

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Attribute : AstNodeBase
Public Class Attribute
    Inherits AstNodeBase

The Attribute type exposes the following members.

Constructors
 | Name | Description
Public method | Attribute | Initializes a new instance of the Attribute class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Target | Gets or sets the target.
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Constructor

Attribute Constructor
Initializes a new instance of the Attribute class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Attribute()
Public Sub New
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Properties

Attribute Properties

The Attribute type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Target | Gets or sets the target.
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Arguments Property

AttributeArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeArgument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of AttributeArgument)
    Get

Property Value

Type: IList AttributeArgument
The arguments.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.HasArguments Property

AttributeHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Id Property

AttributeId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Target Property

AttributeTarget Property
Gets or sets the target.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AttributeTargetKind Target { get; set; }
Public Property Target As AttributeTargetKind
    Get
    Set

Property Value

Type: AttributeTargetKind
The target.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.Type Property

AttributeType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute Methods

Attribute Methods

The Attribute type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Attribute.GetChildrenEnumerator Method

AttributeGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Attribute Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Class

AttributeArgument Class
Represents an attribute argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeArgument

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AttributeArgument : AstNodeBase
Public Class AttributeArgument
    Inherits AstNodeBase

The AttributeArgument type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeArgument | Initializes a new instance of the AttributeArgument class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Constructor

AttributeArgument Constructor
Initializes a new instance of the AttributeArgument class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AttributeArgument()
Public Sub New
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Properties

AttributeArgument Properties

The AttributeArgument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.Expression Property

AttributeArgumentExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.Id Property

AttributeArgumentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.Name Property

AttributeArgumentName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument Methods

AttributeArgument Methods

The AttributeArgument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeArgument.GetChildrenEnumerator Method

AttributeArgumentGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AttributeArgument Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Class

AttributeSection Class
Represents an attribute section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AttributeSection : AstNodeBase
Public Class AttributeSection
    Inherits AstNodeBase

The AttributeSection type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeSection | Initializes a new instance of the AttributeSection class
Top
Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Constructor

AttributeSection Constructor
Initializes a new instance of the AttributeSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AttributeSection()
Public Sub New
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Properties

AttributeSection Properties

The AttributeSection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.Attributes Property

AttributeSectionAttributes Property
Gets the attributes.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Attribute> Attributes { get; }
Public ReadOnly Property Attributes As IList(Of Attribute)
    Get

Property Value

Type: IList Attribute
The attributes.
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.HasAttributes Property

AttributeSectionHasAttributes Property
Returns whether the Attributes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributes { get; }
Public ReadOnly Property HasAttributes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.Id Property

AttributeSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection Methods

AttributeSection Methods

The AttributeSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AttributeSection.GetChildrenEnumerator Method

AttributeSectionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AttributeSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Class

AwaitExpression Class
Represents an await expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAwaitExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AwaitExpression : Expression
Public Class AwaitExpression
    Inherits Expression

The AwaitExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AwaitExpression | Initializes a new instance of the AwaitExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Constructor

AwaitExpression Constructor
Initializes a new instance of the AwaitExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AwaitExpression()
Public Sub New
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Properties

AwaitExpression Properties

The AwaitExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression.ChildExpression Property

AwaitExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression.Id Property

AwaitExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression Methods

AwaitExpression Methods

The AwaitExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


AwaitExpression.GetChildrenEnumerator Method

AwaitExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AwaitExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Class

BinaryOperatorExpression Class
Represents a binary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBinaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BinaryOperatorExpression : Expression
Public Class BinaryOperatorExpression
    Inherits Expression

The BinaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryOperatorExpression | Initializes a new instance of the BinaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Constructor

BinaryOperatorExpression Constructor
Initializes a new instance of the BinaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BinaryOperatorExpression()
Public Sub New
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Properties

BinaryOperatorExpression Properties

The BinaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.Id Property

BinaryOperatorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.LeftExpression Property

BinaryOperatorExpressionLeftExpression Property
Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.Operator Property

BinaryOperatorExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.RightExpression Property

BinaryOperatorExpressionRightExpression Property
Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression Methods

BinaryOperatorExpression Methods

The BinaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BinaryOperatorExpression.GetChildrenEnumerator Method

BinaryOperatorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Class

BlockStatement Class
Represents a block statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBlockStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BlockStatement : Statement
Public Class BlockStatement
    Inherits Statement

The BlockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockStatement | Initializes a new instance of the BlockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Constructor

BlockStatement Constructor
Initializes a new instance of the BlockStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement()
Public Sub New
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Properties

BlockStatement Properties

The BlockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.ChildStatements Property

BlockStatementChildStatements Property
Gets the child statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> ChildStatements { get; }
Public ReadOnly Property ChildStatements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The child statements.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.HasChildStatements Property

BlockStatementHasChildStatements Property
Returns whether the ChildStatements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildStatements { get; }
Public ReadOnly Property HasChildStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.Id Property

BlockStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement Methods

BlockStatement Methods

The BlockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BlockStatement.GetChildrenEnumerator Method

BlockStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Class

BreakStatement Class
Represents a break statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBreakStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BreakStatement : Statement
Public Class BreakStatement
    Inherits Statement

The BreakStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BreakStatement | Initializes a new instance of the BreakStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Constructor

BreakStatement Constructor
Initializes a new instance of the BreakStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BreakStatement()
Public Sub New
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Properties

BreakStatement Properties

The BreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement.Id Property

BreakStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


BreakStatement Methods

BreakStatement Methods

The BreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Class

CastExpression Class
Represents a cast expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCastExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CastExpression : Expression
Public Class CastExpression
    Inherits Expression

The CastExpression type exposes the following members.

Constructors
 | Name | Description
Public method | CastExpression | Initializes a new instance of the CastExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Constructor

CastExpression Constructor
Initializes a new instance of the CastExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CastExpression()
Public Sub New
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Properties

CastExpression Properties

The CastExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.ChildExpression Property

CastExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.Id Property

CastExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.Type Property

CastExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression Methods

CastExpression Methods

The CastExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CastExpression.GetChildrenEnumerator Method

CastExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Class

CatchClause Class
Represents a catch clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCatchClause

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CatchClause : AstNodeBase
Public Class CatchClause
    Inherits AstNodeBase

The CatchClause type exposes the following members.

Constructors
 | Name | Description
Public method | CatchClause | Initializes a new instance of the CatchClause class
Top
Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarator | Gets or sets the variable declarator.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Constructor

CatchClause Constructor
Initializes a new instance of the CatchClause class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CatchClause()
Public Sub New
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Properties

CatchClause Properties

The CatchClause type exposes the following members.

Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarator | Gets or sets the variable declarator.
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.CatchBlock Property

CatchClauseCatchBlock Property
Gets or sets the catch block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement CatchBlock { get; set; }
Public Property CatchBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The catch block.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.ConditionExpression Property

CatchClauseConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.Id Property

CatchClauseId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.VariableDeclarator Property

CatchClauseVariableDeclarator Property
Gets or sets the variable declarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclarator VariableDeclarator { get; set; }
Public Property VariableDeclarator As VariableDeclarator
    Get
    Set

Property Value

Type: VariableDeclarator
The variable declarator.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause Methods

CatchClause Methods

The CatchClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CatchClause.GetChildrenEnumerator Method

CatchClauseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Class

CheckedExpression Class
Represents a checked expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CheckedExpression : Expression
Public Class CheckedExpression
    Inherits Expression

The CheckedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | CheckedExpression | Initializes a new instance of the CheckedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Constructor

CheckedExpression Constructor
Initializes a new instance of the CheckedExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CheckedExpression()
Public Sub New
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Properties

CheckedExpression Properties

The CheckedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression.ChildExpression Property

CheckedExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression.Id Property

CheckedExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression Methods

CheckedExpression Methods

The CheckedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedExpression.GetChildrenEnumerator Method

CheckedExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Class

CheckedStatement Class
Represents a checked statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CheckedStatement : Statement
Public Class CheckedStatement
    Inherits Statement

The CheckedStatement type exposes the following members.

Constructors
 | Name | Description
Public method | CheckedStatement | Initializes a new instance of the CheckedStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Constructor

CheckedStatement Constructor
Initializes a new instance of the CheckedStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CheckedStatement()
Public Sub New
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Properties

CheckedStatement Properties

The CheckedStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement.ChildStatement Property

CheckedStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement.Id Property

CheckedStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement Methods

CheckedStatement Methods

The CheckedStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CheckedStatement.GetChildrenEnumerator Method

CheckedStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Class

ClassBody Class
Represents a class body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ClassBody : AstNodeBase
Public Class ClassBody
    Inherits AstNodeBase

The ClassBody type exposes the following members.

Constructors
 | Name | Description
Public method | ClassBody | Initializes a new instance of the ClassBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Constructor

ClassBody Constructor
Initializes a new instance of the ClassBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassBody()
Public Sub New
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Properties

ClassBody Properties

The ClassBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.HasMembers Property

ClassBodyHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.Id Property

ClassBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.Members Property

ClassBodyMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody Methods

ClassBody Methods

The ClassBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassBody.GetChildrenEnumerator Method

ClassBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ClassBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Class

ClassDeclaration Class
Represents a class declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ClassDeclaration : TypeDeclaration
Public Class ClassDeclaration
    Inherits TypeDeclaration

The ClassDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ClassDeclaration | Initializes a new instance of the ClassDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | IsStandardModule | Gets whether this class is a standard module.
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Constructor

ClassDeclaration Constructor
Initializes a new instance of the ClassDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassDeclaration()
Public Sub New
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Properties

ClassDeclaration Properties

The ClassDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | IsStandardModule | Gets whether this class is a standard module.
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.BaseTypes Property

ClassDeclarationBaseTypes Property
Gets the base types.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> BaseTypes { get; }
Public ReadOnly Property BaseTypes As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The base types.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.Body Property

ClassDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassBody Body { get; set; }
Public Property Body As ClassBody
    Get
    Set

Property Value

Type: ClassBody
The body.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.HasBaseTypes Property

ClassDeclarationHasBaseTypes Property
Returns whether the BaseTypes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.HasTypeParameters Property

ClassDeclarationHasTypeParameters Property
Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.Id Property

ClassDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.IsStandardModule Property

ClassDeclarationIsStandardModule Property
Gets whether this class is a standard module.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsStandardModule { get; }
Public ReadOnly Property IsStandardModule As Boolean
    Get

Property Value

Type: Boolean
true if this class is a standard module; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.Kind Property

ClassDeclarationKind Property
Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.TypeParameters Property

ClassDeclarationTypeParameters Property
Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration Methods

ClassDeclaration Methods

The ClassDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ClassDeclaration.GetChildrenEnumerator Method

ClassDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Class

CompilationUnit Class
Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Constructor

CompilationUnit Constructor
Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Properties

CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.HasMembers Property

CompilationUnitHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.Members Property

CompilationUnitMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit Methods

CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Class

CompilationUnitOption Class
Represents a compilation unit option.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnitOption

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CompilationUnitOption : AstNodeBase
Public Class CompilationUnitOption
    Inherits AstNodeBase

The CompilationUnitOption type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnitOption | Initializes a new instance of the CompilationUnitOption class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Constructor

CompilationUnitOption Constructor
Initializes a new instance of the CompilationUnitOption class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompilationUnitOption()
Public Sub New
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Properties

CompilationUnitOption Properties

The CompilationUnitOption type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption.Id Property

CompilationUnitOptionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption.Name Property

CompilationUnitOptionName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption.Value Property

CompilationUnitOptionValue Property
Gets or sets the value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value.
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


CompilationUnitOption Methods

CompilationUnitOption Methods

The CompilationUnitOption type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnitOption Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Class

ConditionalExpression Class
Represents a conditional expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConditionalExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConditionalExpression : Expression
Public Class ConditionalExpression
    Inherits Expression

The ConditionalExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalExpression | Initializes a new instance of the ConditionalExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Constructor

ConditionalExpression Constructor
Initializes a new instance of the ConditionalExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConditionalExpression()
Public Sub New
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Properties

ConditionalExpression Properties

The ConditionalExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.ConditionExpression Property

ConditionalExpressionConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.FalseExpression Property

ConditionalExpressionFalseExpression Property
Gets or sets the false expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression FalseExpression { get; set; }
Public Property FalseExpression As Expression
    Get
    Set

Property Value

Type: Expression
The false expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.Id Property

ConditionalExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.TrueExpression Property

ConditionalExpressionTrueExpression Property
Gets or sets the true expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TrueExpression { get; set; }
Public Property TrueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The true expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression Methods

ConditionalExpression Methods

The ConditionalExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConditionalExpression.GetChildrenEnumerator Method

ConditionalExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Class

ConstructorBody Class
Represents a constructor body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConstructorBody : AstNodeBase
Public Class ConstructorBody
    Inherits AstNodeBase

The ConstructorBody type exposes the following members.

Constructors
 | Name | Description
Public method | ConstructorBody | Initializes a new instance of the ConstructorBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Constructor

ConstructorBody Constructor
Initializes a new instance of the ConstructorBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConstructorBody()
Public Sub New
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Properties

ConstructorBody Properties

The ConstructorBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.HasStatements Property

ConstructorBodyHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.Id Property

ConstructorBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.Statements Property

ConstructorBodyStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody Methods

ConstructorBody Methods

The ConstructorBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorBody.GetChildrenEnumerator Method

ConstructorBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConstructorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Class

ConstructorDeclaration Class
Represents a constructor declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConstructorDeclaration : TypeMemberDeclaration
Public Class ConstructorDeclaration
    Inherits TypeMemberDeclaration

The ConstructorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ConstructorDeclaration | Initializes a new instance of the ConstructorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerArguments | Returns whether the InitializerArguments collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | InitializerArguments | Gets the initializer arguments.
Public property | InitializerKind | Gets or sets the initializer kind.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Constructor

ConstructorDeclaration Constructor
Initializes a new instance of the ConstructorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConstructorDeclaration()
Public Sub New
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Properties

ConstructorDeclaration Properties

The ConstructorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerArguments | Returns whether the InitializerArguments collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | InitializerArguments | Gets the initializer arguments.
Public property | InitializerKind | Gets or sets the initializer kind.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Body Property

ConstructorDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConstructorBody Body { get; set; }
Public Property Body As ConstructorBody
    Get
    Set

Property Value

Type: ConstructorBody
The body.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.HasInitializerArguments Property

ConstructorDeclarationHasInitializerArguments Property
Returns whether the InitializerArguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasInitializerArguments { get; }
Public ReadOnly Property HasInitializerArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.HasParameters Property

ConstructorDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Id Property

ConstructorDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.InitializerArguments Property

ConstructorDeclarationInitializerArguments Property
Gets the initializer arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> InitializerArguments { get; }
Public ReadOnly Property InitializerArguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The initializer arguments.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.InitializerKind Property

ConstructorDeclarationInitializerKind Property
Gets or sets the initializer kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConstructorInitializerKind InitializerKind { get; set; }
Public Property InitializerKind As ConstructorInitializerKind
    Get
    Set

Property Value

Type: ConstructorInitializerKind
The initializer kind.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Kind Property

ConstructorDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Name Property

ConstructorDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.Parameters Property

ConstructorDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration Methods

ConstructorDeclaration Methods

The ConstructorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ConstructorDeclaration.GetChildrenEnumerator Method

ConstructorDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConstructorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Class

ContinueStatement Class
Represents a continue statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationContinueStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ContinueStatement : Statement
Public Class ContinueStatement
    Inherits Statement

The ContinueStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueStatement | Initializes a new instance of the ContinueStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Constructor

ContinueStatement Constructor
Initializes a new instance of the ContinueStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContinueStatement()
Public Sub New
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Properties

ContinueStatement Properties

The ContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement.Id Property

ContinueStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement.Kind Property

ContinueStatementKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContinueKind Kind { get; set; }
Public Property Kind As ContinueKind
    Get
    Set

Property Value

Type: ContinueKind
The kind.
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ContinueStatement Methods

ContinueStatement Methods

The ContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Class

DefaultValueExpression Class
Represents a default value expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDefaultValueExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DefaultValueExpression : Expression
Public Class DefaultValueExpression
    Inherits Expression

The DefaultValueExpression type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValueExpression | Initializes a new instance of the DefaultValueExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Constructor

DefaultValueExpression Constructor
Initializes a new instance of the DefaultValueExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DefaultValueExpression()
Public Sub New
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Properties

DefaultValueExpression Properties

The DefaultValueExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression.Id Property

DefaultValueExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression.Type Property

DefaultValueExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression Methods

DefaultValueExpression Methods

The DefaultValueExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DefaultValueExpression.GetChildrenEnumerator Method

DefaultValueExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DefaultValueExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Class

DelegateDeclaration Class
Represents a delegate declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDelegateDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DelegateDeclaration : TypeDeclaration
Public Class DelegateDeclaration
    Inherits TypeDeclaration

The DelegateDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | DelegateDeclaration | Initializes a new instance of the DelegateDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Constructor

DelegateDeclaration Constructor
Initializes a new instance of the DelegateDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DelegateDeclaration()
Public Sub New
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Properties

DelegateDeclaration Properties

The DelegateDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.HasParameters Property

DelegateDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.HasTypeParameters Property

DelegateDeclarationHasTypeParameters Property
Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.Id Property

DelegateDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.Kind Property

DelegateDeclarationKind Property
Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.Parameters Property

DelegateDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.ReturnType Property

DelegateDeclarationReturnType Property
Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.TypeParameters Property

DelegateDeclarationTypeParameters Property
Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration Methods

DelegateDeclaration Methods

The DelegateDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DelegateDeclaration.GetChildrenEnumerator Method

DelegateDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DelegateDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Class

DistinctQueryOperator Class
Represents a distinct query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDistinctQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DistinctQueryOperator : QueryOperator
Public Class DistinctQueryOperator
    Inherits QueryOperator

The DistinctQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | DistinctQueryOperator | Initializes a new instance of the DistinctQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Constructor

DistinctQueryOperator Constructor
Initializes a new instance of the DistinctQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DistinctQueryOperator()
Public Sub New
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Properties

DistinctQueryOperator Properties

The DistinctQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator.Id Property

DistinctQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DistinctQueryOperator Methods

DistinctQueryOperator Methods

The DistinctQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DistinctQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Class

DocumentationComment Class
Represents a documentation comment.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDocumentationComment

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DocumentationComment : AstNodeBase
Public Class DocumentationComment
    Inherits AstNodeBase

The DocumentationComment type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentationComment | Initializes a new instance of the DocumentationComment class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the comment text.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Constructor

DocumentationComment Constructor
Initializes a new instance of the DocumentationComment class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentationComment()
Public Sub New
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Properties

DocumentationComment Properties

The DocumentationComment type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the comment text.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment.Id Property

DocumentationCommentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment.Text Property

DocumentationCommentText Property
Gets or sets the comment text.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The comment text.
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DocumentationComment Methods

DocumentationComment Methods

The DocumentationComment type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DocumentationComment Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Class

DoStatement Class
Represents a do statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDoStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DoStatement : Statement
Public Class DoStatement
    Inherits Statement

The DoStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DoStatement | Initializes a new instance of the DoStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Constructor

DoStatement Constructor
Initializes a new instance of the DoStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoStatement()
Public Sub New
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Properties

DoStatement Properties

The DoStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.ChildStatement Property

DoStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.ConditionExpression Property

DoStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.Id Property

DoStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement Methods

DoStatement Methods

The DoStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DoStatement.GetChildrenEnumerator Method

DoStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Class

DotNetAstNodeId Class
Contains the AST node IDs for the .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDotNetAstNodeId

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DotNetAstNodeId : AstNodeIdProviderBase
Public Class DotNetAstNodeId
    Inherits AstNodeIdProviderBase

The DotNetAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetAstNodeId | Initializes a new instance of the DotNetAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
AccessorBody | Gets the AccessorBody AST node ID.
AccessorDeclaration | Gets the AccessorDeclaration AST node ID.
AddressOfExpression | Gets the AddressOfExpression AST node ID.
AggregateQueryOperator | Gets the AggregateQueryOperator AST node ID.
AnonymousMethodExpression | Gets the AnonymousMethodExpression AST node ID.
Argument | Gets the Argument AST node ID.
ArrayEraseStatement | Gets the ArrayEraseStatement AST node ID.
ArrayReallocateClause | Gets the ArrayReallocateClause AST node ID.
ArrayReallocateStatement | Gets the ArrayReallocateStatement AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
Attribute | Gets the Attribute AST node ID.
AttributeArgument | Gets the AttributeArgument AST node ID.
AttributeSection | Gets the AttributeSection AST node ID.
AwaitExpression | Gets the AwaitExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CastExpression | Gets the CastExpression AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CheckedExpression | Gets the CheckedExpression AST node ID.
CheckedStatement | Gets the CheckedStatement AST node ID.
ClassBody | Gets the ClassBody AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
CompilationUnitOption | Gets the CompilationUnitOption AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ConstructorBody | Gets the ConstructorBody AST node ID.
ConstructorDeclaration | Gets the ConstructorDeclaration AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DefaultValueExpression | Gets the DefaultValueExpression AST node ID.
DelegateDeclaration | Gets the DelegateDeclaration AST node ID.
DistinctQueryOperator | Gets the DistinctQueryOperator AST node ID.
DocumentationComment | Gets the DocumentationComment AST node ID.
DoStatement | Gets the DoStatement AST node ID.
ElseIfSection | Gets the ElseIfSection AST node ID.
EndStatement | Gets the EndStatement AST node ID.
EnumerationBody | Gets the EnumerationBody AST node ID.
EnumerationDeclaration | Gets the EnumerationDeclaration AST node ID.
EnumerationMemberDeclaration | Gets the EnumerationMemberDeclaration AST node ID.
EventBody | Gets the EventBody AST node ID.
EventDeclaration | Gets the EventDeclaration AST node ID.
ExitStatement | Gets the ExitStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ExternalAliasDirective | Gets the ExternalAliasDirective AST node ID.
ExternalAliasDirectiveSection | Gets the ExternalAliasDirectiveSection AST node ID.
FieldDeclaration | Gets the FieldDeclaration AST node ID.
FixedSizeBufferDeclaration | Gets the FixedSizeBufferDeclaration AST node ID.
FixedSizeBufferDeclarator | Gets the FixedSizeBufferDeclarator AST node ID.
FixedStatement | Gets the FixedStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromQueryOperator | Gets the FromQueryOperator AST node ID.
GoToStatement | Gets the GoToStatement AST node ID.
GroupQueryOperator | Gets the GroupQueryOperator AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InitializerExpression | Gets the InitializerExpression AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InterfaceAccessorDeclaration | Gets the InterfaceAccessorDeclaration AST node ID.
InterfaceBody | Gets the InterfaceBody AST node ID.
InterfaceDeclaration | Gets the InterfaceDeclaration AST node ID.
InterfaceEventDeclaration | Gets the InterfaceEventDeclaration AST node ID.
InterfaceMemberDeclaration | Gets the InterfaceMemberDeclaration AST node ID.
InterfaceMethodDeclaration | Gets the InterfaceMethodDeclaration AST node ID.
InterfacePropertyDeclaration | Gets the InterfacePropertyDeclaration AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
IsTypeOfExpression | Gets the IsTypeOfExpression AST node ID.
JoinQueryOperator | Gets the JoinQueryOperator AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
LetQueryOperator | Gets the LetQueryOperator AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
LocalVariableDeclaration | Gets the LocalVariableDeclaration AST node ID.
LockStatement | Gets the LockStatement AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
MethodBody | Gets the MethodBody AST node ID.
MethodDeclaration | Gets the MethodDeclaration AST node ID.
NamespaceBody | Gets the NamespaceBody AST node ID.
NamespaceDeclaration | Gets the NamespaceDeclaration AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
OperatorBody | Gets the OperatorBody AST node ID.
OperatorDeclaration | Gets the OperatorDeclaration AST node ID.
OrderByQueryOperator | Gets the OrderByQueryOperator AST node ID.
Ordering | Gets the Ordering AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PreprocessorDirective | Gets the PreprocessorDirective AST node ID.
PropertyBody | Gets the PropertyBody AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
QualifiedName | Gets the QualifiedName AST node ID.
QueryExpression | Gets the QueryExpression AST node ID.
QueryOperator | Gets the QueryOperator AST node ID.
RangeVariableDeclaration | Gets the RangeVariableDeclaration AST node ID.
RangeVariableDeclarator | Gets the RangeVariableDeclarator AST node ID.
RegionPreprocessorDirective | Gets the RegionPreprocessorDirective AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
ReturnTypeDeclaration | Gets the ReturnTypeDeclaration AST node ID.
ReturnTypeExpression | Gets the ReturnTypeExpression AST node ID.
SelectQueryOperator | Gets the SelectQueryOperator AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SizeOfExpression | Gets the SizeOfExpression AST node ID.
SkipQueryOperator | Gets the SkipQueryOperator AST node ID.
SkipWhileQueryOperator | Gets the SkipWhileQueryOperator AST node ID.
StackAllocationInitializer | Gets the StackAllocationInitializer AST node ID.
Statement | Gets the Statement AST node ID.
StopStatement | Gets the StopStatement AST node ID.
StructureBody | Gets the StructureBody AST node ID.
StructureDeclaration | Gets the StructureDeclaration AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
TakeQueryOperator | Gets the TakeQueryOperator AST node ID.
TakeWhileQueryOperator | Gets the TakeWhileQueryOperator AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryCastExpression | Gets the TryCastExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TypeDeclaration | Gets the TypeDeclaration AST node ID.
TypeMemberDeclaration | Gets the TypeMemberDeclaration AST node ID.
TypeOfExpression | Gets the TypeOfExpression AST node ID.
TypeParameter | Gets the TypeParameter AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
UncheckedExpression | Gets the UncheckedExpression AST node ID.
UncheckedStatement | Gets the UncheckedStatement AST node ID.
UnsafeStatement | Gets the UnsafeStatement AST node ID.
UnstructuredErrorHandlerStatement | Gets the UnstructuredErrorHandlerStatement AST node ID.
UnstructuredErrorResumeStatement | Gets the UnstructuredErrorResumeStatement AST node ID.
UnstructuredErrorThrowStatement | Gets the UnstructuredErrorThrowStatement AST node ID.
UsingDirective | Gets the UsingDirective AST node ID.
UsingDirectiveSection | Gets the UsingDirectiveSection AST node ID.
UsingStatement | Gets the UsingStatement AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableDeclarator | Gets the VariableDeclarator AST node ID.
WhereQueryOperator | Gets the WhereQueryOperator AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
WithTargetExpression | Gets the WithTargetExpression AST node ID.
XmlNamespaceExpression | Gets the XmlNamespaceExpression AST node ID.
YieldStatement | Gets the YieldStatement AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Constructor

DotNetAstNodeId Constructor
Initializes a new instance of the DotNetAstNodeId class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DotNetAstNodeId()
Public Sub New
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Properties

DotNetAstNodeId Properties

The DotNetAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MaxId Property

DotNetAstNodeIdMaxId Property
Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MinId Property

DotNetAstNodeIdMinId Property
Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Methods

DotNetAstNodeId Methods

The DotNetAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ContainsId Method

DotNetAstNodeIdContainsId Method
Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GetDescription Method

DotNetAstNodeIdGetDescription Method
Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GetKey Method

DotNetAstNodeIdGetKey Method
Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId Fields

DotNetAstNodeId Fields

The DotNetAstNodeId type exposes the following members.

Fields
Name | Description
AccessorBody | Gets the AccessorBody AST node ID.
AccessorDeclaration | Gets the AccessorDeclaration AST node ID.
AddressOfExpression | Gets the AddressOfExpression AST node ID.
AggregateQueryOperator | Gets the AggregateQueryOperator AST node ID.
AnonymousMethodExpression | Gets the AnonymousMethodExpression AST node ID.
Argument | Gets the Argument AST node ID.
ArrayEraseStatement | Gets the ArrayEraseStatement AST node ID.
ArrayReallocateClause | Gets the ArrayReallocateClause AST node ID.
ArrayReallocateStatement | Gets the ArrayReallocateStatement AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
Attribute | Gets the Attribute AST node ID.
AttributeArgument | Gets the AttributeArgument AST node ID.
AttributeSection | Gets the AttributeSection AST node ID.
AwaitExpression | Gets the AwaitExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CastExpression | Gets the CastExpression AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CheckedExpression | Gets the CheckedExpression AST node ID.
CheckedStatement | Gets the CheckedStatement AST node ID.
ClassBody | Gets the ClassBody AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
CompilationUnitOption | Gets the CompilationUnitOption AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ConstructorBody | Gets the ConstructorBody AST node ID.
ConstructorDeclaration | Gets the ConstructorDeclaration AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DefaultValueExpression | Gets the DefaultValueExpression AST node ID.
DelegateDeclaration | Gets the DelegateDeclaration AST node ID.
DistinctQueryOperator | Gets the DistinctQueryOperator AST node ID.
DocumentationComment | Gets the DocumentationComment AST node ID.
DoStatement | Gets the DoStatement AST node ID.
ElseIfSection | Gets the ElseIfSection AST node ID.
EndStatement | Gets the EndStatement AST node ID.
EnumerationBody | Gets the EnumerationBody AST node ID.
EnumerationDeclaration | Gets the EnumerationDeclaration AST node ID.
EnumerationMemberDeclaration | Gets the EnumerationMemberDeclaration AST node ID.
EventBody | Gets the EventBody AST node ID.
EventDeclaration | Gets the EventDeclaration AST node ID.
ExitStatement | Gets the ExitStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ExternalAliasDirective | Gets the ExternalAliasDirective AST node ID.
ExternalAliasDirectiveSection | Gets the ExternalAliasDirectiveSection AST node ID.
FieldDeclaration | Gets the FieldDeclaration AST node ID.
FixedSizeBufferDeclaration | Gets the FixedSizeBufferDeclaration AST node ID.
FixedSizeBufferDeclarator | Gets the FixedSizeBufferDeclarator AST node ID.
FixedStatement | Gets the FixedStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromQueryOperator | Gets the FromQueryOperator AST node ID.
GoToStatement | Gets the GoToStatement AST node ID.
GroupQueryOperator | Gets the GroupQueryOperator AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InitializerExpression | Gets the InitializerExpression AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InterfaceAccessorDeclaration | Gets the InterfaceAccessorDeclaration AST node ID.
InterfaceBody | Gets the InterfaceBody AST node ID.
InterfaceDeclaration | Gets the InterfaceDeclaration AST node ID.
InterfaceEventDeclaration | Gets the InterfaceEventDeclaration AST node ID.
InterfaceMemberDeclaration | Gets the InterfaceMemberDeclaration AST node ID.
InterfaceMethodDeclaration | Gets the InterfaceMethodDeclaration AST node ID.
InterfacePropertyDeclaration | Gets the InterfacePropertyDeclaration AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
IsTypeOfExpression | Gets the IsTypeOfExpression AST node ID.
JoinQueryOperator | Gets the JoinQueryOperator AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
LetQueryOperator | Gets the LetQueryOperator AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
LocalVariableDeclaration | Gets the LocalVariableDeclaration AST node ID.
LockStatement | Gets the LockStatement AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
MethodBody | Gets the MethodBody AST node ID.
MethodDeclaration | Gets the MethodDeclaration AST node ID.
NamespaceBody | Gets the NamespaceBody AST node ID.
NamespaceDeclaration | Gets the NamespaceDeclaration AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
OperatorBody | Gets the OperatorBody AST node ID.
OperatorDeclaration | Gets the OperatorDeclaration AST node ID.
OrderByQueryOperator | Gets the OrderByQueryOperator AST node ID.
Ordering | Gets the Ordering AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PreprocessorDirective | Gets the PreprocessorDirective AST node ID.
PropertyBody | Gets the PropertyBody AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
QualifiedName | Gets the QualifiedName AST node ID.
QueryExpression | Gets the QueryExpression AST node ID.
QueryOperator | Gets the QueryOperator AST node ID.
RangeVariableDeclaration | Gets the RangeVariableDeclaration AST node ID.
RangeVariableDeclarator | Gets the RangeVariableDeclarator AST node ID.
RegionPreprocessorDirective | Gets the RegionPreprocessorDirective AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
ReturnTypeDeclaration | Gets the ReturnTypeDeclaration AST node ID.
ReturnTypeExpression | Gets the ReturnTypeExpression AST node ID.
SelectQueryOperator | Gets the SelectQueryOperator AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SizeOfExpression | Gets the SizeOfExpression AST node ID.
SkipQueryOperator | Gets the SkipQueryOperator AST node ID.
SkipWhileQueryOperator | Gets the SkipWhileQueryOperator AST node ID.
StackAllocationInitializer | Gets the StackAllocationInitializer AST node ID.
Statement | Gets the Statement AST node ID.
StopStatement | Gets the StopStatement AST node ID.
StructureBody | Gets the StructureBody AST node ID.
StructureDeclaration | Gets the StructureDeclaration AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
TakeQueryOperator | Gets the TakeQueryOperator AST node ID.
TakeWhileQueryOperator | Gets the TakeWhileQueryOperator AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryCastExpression | Gets the TryCastExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TypeDeclaration | Gets the TypeDeclaration AST node ID.
TypeMemberDeclaration | Gets the TypeMemberDeclaration AST node ID.
TypeOfExpression | Gets the TypeOfExpression AST node ID.
TypeParameter | Gets the TypeParameter AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
UncheckedExpression | Gets the UncheckedExpression AST node ID.
UncheckedStatement | Gets the UncheckedStatement AST node ID.
UnsafeStatement | Gets the UnsafeStatement AST node ID.
UnstructuredErrorHandlerStatement | Gets the UnstructuredErrorHandlerStatement AST node ID.
UnstructuredErrorResumeStatement | Gets the UnstructuredErrorResumeStatement AST node ID.
UnstructuredErrorThrowStatement | Gets the UnstructuredErrorThrowStatement AST node ID.
UsingDirective | Gets the UsingDirective AST node ID.
UsingDirectiveSection | Gets the UsingDirectiveSection AST node ID.
UsingStatement | Gets the UsingStatement AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableDeclarator | Gets the VariableDeclarator AST node ID.
WhereQueryOperator | Gets the WhereQueryOperator AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
WithTargetExpression | Gets the WithTargetExpression AST node ID.
XmlNamespaceExpression | Gets the XmlNamespaceExpression AST node ID.
YieldStatement | Gets the YieldStatement AST node ID.
Top
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AccessorBody Field

DotNetAstNodeIdAccessorBody Field
Gets the AccessorBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AccessorBody = 10000
Public Const AccessorBody As Integer = 10000

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AccessorDeclaration Field

DotNetAstNodeIdAccessorDeclaration Field
Gets the AccessorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AccessorDeclaration = 10001
Public Const AccessorDeclaration As Integer = 10001

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AddressOfExpression Field

DotNetAstNodeIdAddressOfExpression Field
Gets the AddressOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AddressOfExpression = 10002
Public Const AddressOfExpression As Integer = 10002

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AggregateQueryOperator Field

DotNetAstNodeIdAggregateQueryOperator Field
Gets the AggregateQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AggregateQueryOperator = 10003
Public Const AggregateQueryOperator As Integer = 10003

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AnonymousMethodExpression Field

DotNetAstNodeIdAnonymousMethodExpression Field
Gets the AnonymousMethodExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AnonymousMethodExpression = 10004
Public Const AnonymousMethodExpression As Integer = 10004

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Argument Field

DotNetAstNodeIdArgument Field
Gets the Argument AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Argument = 10005
Public Const Argument As Integer = 10005

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ArrayEraseStatement Field

DotNetAstNodeIdArrayEraseStatement Field
Gets the ArrayEraseStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ArrayEraseStatement = 10006
Public Const ArrayEraseStatement As Integer = 10006

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ArrayReallocateClause Field

DotNetAstNodeIdArrayReallocateClause Field
Gets the ArrayReallocateClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ArrayReallocateClause = 10007
Public Const ArrayReallocateClause As Integer = 10007

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ArrayReallocateStatement Field

DotNetAstNodeIdArrayReallocateStatement Field
Gets the ArrayReallocateStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ArrayReallocateStatement = 10008
Public Const ArrayReallocateStatement As Integer = 10008

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AssignmentExpression Field

DotNetAstNodeIdAssignmentExpression Field
Gets the AssignmentExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AssignmentExpression = 10009
Public Const AssignmentExpression As Integer = 10009

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Attribute Field

DotNetAstNodeIdAttribute Field
Gets the Attribute AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Attribute = 10010
Public Const Attribute As Integer = 10010

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AttributeArgument Field

DotNetAstNodeIdAttributeArgument Field
Gets the AttributeArgument AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AttributeArgument = 10011
Public Const AttributeArgument As Integer = 10011

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AttributeSection Field

DotNetAstNodeIdAttributeSection Field
Gets the AttributeSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AttributeSection = 10012
Public Const AttributeSection As Integer = 10012

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.AwaitExpression Field

DotNetAstNodeIdAwaitExpression Field
Gets the AwaitExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AwaitExpression = 10013
Public Const AwaitExpression As Integer = 10013

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.BinaryOperatorExpression Field

DotNetAstNodeIdBinaryOperatorExpression Field
Gets the BinaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BinaryOperatorExpression = 10014
Public Const BinaryOperatorExpression As Integer = 10014

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.BlockStatement Field

DotNetAstNodeIdBlockStatement Field
Gets the BlockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BlockStatement = 10015
Public Const BlockStatement As Integer = 10015

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.BreakStatement Field

DotNetAstNodeIdBreakStatement Field
Gets the BreakStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BreakStatement = 10016
Public Const BreakStatement As Integer = 10016

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CastExpression Field

DotNetAstNodeIdCastExpression Field
Gets the CastExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CastExpression = 10017
Public Const CastExpression As Integer = 10017

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CatchClause Field

DotNetAstNodeIdCatchClause Field
Gets the CatchClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CatchClause = 10018
Public Const CatchClause As Integer = 10018

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CheckedExpression Field

DotNetAstNodeIdCheckedExpression Field
Gets the CheckedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CheckedExpression = 10019
Public Const CheckedExpression As Integer = 10019

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CheckedStatement Field

DotNetAstNodeIdCheckedStatement Field
Gets the CheckedStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CheckedStatement = 10020
Public Const CheckedStatement As Integer = 10020

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ClassBody Field

DotNetAstNodeIdClassBody Field
Gets the ClassBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ClassBody = 10021
Public Const ClassBody As Integer = 10021

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ClassDeclaration Field

DotNetAstNodeIdClassDeclaration Field
Gets the ClassDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ClassDeclaration = 10022
Public Const ClassDeclaration As Integer = 10022

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CompilationUnit Field

DotNetAstNodeIdCompilationUnit Field
Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 10023
Public Const CompilationUnit As Integer = 10023

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.CompilationUnitOption Field

DotNetAstNodeIdCompilationUnitOption Field
Gets the CompilationUnitOption AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CompilationUnitOption = 10024
Public Const CompilationUnitOption As Integer = 10024

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ConditionalExpression Field

DotNetAstNodeIdConditionalExpression Field
Gets the ConditionalExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ConditionalExpression = 10025
Public Const ConditionalExpression As Integer = 10025

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ConstructorBody Field

DotNetAstNodeIdConstructorBody Field
Gets the ConstructorBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ConstructorBody = 10026
Public Const ConstructorBody As Integer = 10026

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ConstructorDeclaration Field

DotNetAstNodeIdConstructorDeclaration Field
Gets the ConstructorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ConstructorDeclaration = 10027
Public Const ConstructorDeclaration As Integer = 10027

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ContinueStatement Field

DotNetAstNodeIdContinueStatement Field
Gets the ContinueStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContinueStatement = 10028
Public Const ContinueStatement As Integer = 10028

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DefaultValueExpression Field

DotNetAstNodeIdDefaultValueExpression Field
Gets the DefaultValueExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DefaultValueExpression = 10029
Public Const DefaultValueExpression As Integer = 10029

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DelegateDeclaration Field

DotNetAstNodeIdDelegateDeclaration Field
Gets the DelegateDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DelegateDeclaration = 10030
Public Const DelegateDeclaration As Integer = 10030

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DistinctQueryOperator Field

DotNetAstNodeIdDistinctQueryOperator Field
Gets the DistinctQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DistinctQueryOperator = 10031
Public Const DistinctQueryOperator As Integer = 10031

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DocumentationComment Field

DotNetAstNodeIdDocumentationComment Field
Gets the DocumentationComment AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationComment = 10032
Public Const DocumentationComment As Integer = 10032

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.DoStatement Field

DotNetAstNodeIdDoStatement Field
Gets the DoStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DoStatement = 10033
Public Const DoStatement As Integer = 10033

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ElseIfSection Field

DotNetAstNodeIdElseIfSection Field
Gets the ElseIfSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ElseIfSection = 10034
Public Const ElseIfSection As Integer = 10034

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EndStatement Field

DotNetAstNodeIdEndStatement Field
Gets the EndStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EndStatement = 10035
Public Const EndStatement As Integer = 10035

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EnumerationBody Field

DotNetAstNodeIdEnumerationBody Field
Gets the EnumerationBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EnumerationBody = 10036
Public Const EnumerationBody As Integer = 10036

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EnumerationDeclaration Field

DotNetAstNodeIdEnumerationDeclaration Field
Gets the EnumerationDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EnumerationDeclaration = 10037
Public Const EnumerationDeclaration As Integer = 10037

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EnumerationMemberDeclaration Field

DotNetAstNodeIdEnumerationMemberDeclaration Field
Gets the EnumerationMemberDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EnumerationMemberDeclaration = 10038
Public Const EnumerationMemberDeclaration As Integer = 10038

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EventBody Field

DotNetAstNodeIdEventBody Field
Gets the EventBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EventBody = 10039
Public Const EventBody As Integer = 10039

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.EventDeclaration Field

DotNetAstNodeIdEventDeclaration Field
Gets the EventDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EventDeclaration = 10040
Public Const EventDeclaration As Integer = 10040

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExitStatement Field

DotNetAstNodeIdExitStatement Field
Gets the ExitStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExitStatement = 10041
Public Const ExitStatement As Integer = 10041

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Expression Field

DotNetAstNodeIdExpression Field
Gets the Expression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Expression = 10042
Public Const Expression As Integer = 10042

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExpressionStatement Field

DotNetAstNodeIdExpressionStatement Field
Gets the ExpressionStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExpressionStatement = 10043
Public Const ExpressionStatement As Integer = 10043

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExternalAliasDirective Field

DotNetAstNodeIdExternalAliasDirective Field
Gets the ExternalAliasDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExternalAliasDirective = 10044
Public Const ExternalAliasDirective As Integer = 10044

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ExternalAliasDirectiveSection Field

DotNetAstNodeIdExternalAliasDirectiveSection Field
Gets the ExternalAliasDirectiveSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExternalAliasDirectiveSection = 10045
Public Const ExternalAliasDirectiveSection As Integer = 10045

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FieldDeclaration Field

DotNetAstNodeIdFieldDeclaration Field
Gets the FieldDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FieldDeclaration = 10046
Public Const FieldDeclaration As Integer = 10046

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FixedSizeBufferDeclaration Field

DotNetAstNodeIdFixedSizeBufferDeclaration Field
Gets the FixedSizeBufferDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FixedSizeBufferDeclaration = 10047
Public Const FixedSizeBufferDeclaration As Integer = 10047

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FixedSizeBufferDeclarator Field

DotNetAstNodeIdFixedSizeBufferDeclarator Field
Gets the FixedSizeBufferDeclarator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FixedSizeBufferDeclarator = 10048
Public Const FixedSizeBufferDeclarator As Integer = 10048

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FixedStatement Field

DotNetAstNodeIdFixedStatement Field
Gets the FixedStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FixedStatement = 10049
Public Const FixedStatement As Integer = 10049

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ForEachStatement Field

DotNetAstNodeIdForEachStatement Field
Gets the ForEachStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ForEachStatement = 10050
Public Const ForEachStatement As Integer = 10050

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ForStatement Field

DotNetAstNodeIdForStatement Field
Gets the ForStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ForStatement = 10051
Public Const ForStatement As Integer = 10051

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.FromQueryOperator Field

DotNetAstNodeIdFromQueryOperator Field
Gets the FromQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FromQueryOperator = 10052
Public Const FromQueryOperator As Integer = 10052

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GoToStatement Field

DotNetAstNodeIdGoToStatement Field
Gets the GoToStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int GoToStatement = 10053
Public Const GoToStatement As Integer = 10053

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.GroupQueryOperator Field

DotNetAstNodeIdGroupQueryOperator Field
Gets the GroupQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int GroupQueryOperator = 10054
Public Const GroupQueryOperator As Integer = 10054

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.IfStatement Field

DotNetAstNodeIdIfStatement Field
Gets the IfStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int IfStatement = 10055
Public Const IfStatement As Integer = 10055

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InitializerExpression Field

DotNetAstNodeIdInitializerExpression Field
Gets the InitializerExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InitializerExpression = 10056
Public Const InitializerExpression As Integer = 10056

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InstanceExpression Field

DotNetAstNodeIdInstanceExpression Field
Gets the InstanceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InstanceExpression = 10057
Public Const InstanceExpression As Integer = 10057

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceAccessorDeclaration Field

DotNetAstNodeIdInterfaceAccessorDeclaration Field
Gets the InterfaceAccessorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfaceAccessorDeclaration = 10058
Public Const InterfaceAccessorDeclaration As Integer = 10058

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceBody Field

DotNetAstNodeIdInterfaceBody Field
Gets the InterfaceBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfaceBody = 10059
Public Const InterfaceBody As Integer = 10059

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceDeclaration Field

DotNetAstNodeIdInterfaceDeclaration Field
Gets the InterfaceDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfaceDeclaration = 10060
Public Const InterfaceDeclaration As Integer = 10060

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceEventDeclaration Field

DotNetAstNodeIdInterfaceEventDeclaration Field
Gets the InterfaceEventDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfaceEventDeclaration = 10061
Public Const InterfaceEventDeclaration As Integer = 10061

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceMemberDeclaration Field

DotNetAstNodeIdInterfaceMemberDeclaration Field
Gets the InterfaceMemberDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfaceMemberDeclaration = 10062
Public Const InterfaceMemberDeclaration As Integer = 10062

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfaceMethodDeclaration Field

DotNetAstNodeIdInterfaceMethodDeclaration Field
Gets the InterfaceMethodDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfaceMethodDeclaration = 10063
Public Const InterfaceMethodDeclaration As Integer = 10063

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InterfacePropertyDeclaration Field

DotNetAstNodeIdInterfacePropertyDeclaration Field
Gets the InterfacePropertyDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InterfacePropertyDeclaration = 10064
Public Const InterfacePropertyDeclaration As Integer = 10064

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.InvocationExpression Field

DotNetAstNodeIdInvocationExpression Field
Gets the InvocationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InvocationExpression = 10065
Public Const InvocationExpression As Integer = 10065

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.IsTypeOfExpression Field

DotNetAstNodeIdIsTypeOfExpression Field
Gets the IsTypeOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int IsTypeOfExpression = 10066
Public Const IsTypeOfExpression As Integer = 10066

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.JoinQueryOperator Field

DotNetAstNodeIdJoinQueryOperator Field
Gets the JoinQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int JoinQueryOperator = 10067
Public Const JoinQueryOperator As Integer = 10067

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LabeledStatement Field

DotNetAstNodeIdLabeledStatement Field
Gets the LabeledStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LabeledStatement = 10068
Public Const LabeledStatement As Integer = 10068

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LambdaExpression Field

DotNetAstNodeIdLambdaExpression Field
Gets the LambdaExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LambdaExpression = 10069
Public Const LambdaExpression As Integer = 10069

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LetQueryOperator Field

DotNetAstNodeIdLetQueryOperator Field
Gets the LetQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LetQueryOperator = 10070
Public Const LetQueryOperator As Integer = 10070

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LiteralExpression Field

DotNetAstNodeIdLiteralExpression Field
Gets the LiteralExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralExpression = 10071
Public Const LiteralExpression As Integer = 10071

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LocalVariableDeclaration Field

DotNetAstNodeIdLocalVariableDeclaration Field
Gets the LocalVariableDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LocalVariableDeclaration = 10072
Public Const LocalVariableDeclaration As Integer = 10072

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.LockStatement Field

DotNetAstNodeIdLockStatement Field
Gets the LockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LockStatement = 10073
Public Const LockStatement As Integer = 10073

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MemberAccess Field

DotNetAstNodeIdMemberAccess Field
Gets the MemberAccess AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MemberAccess = 10074
Public Const MemberAccess As Integer = 10074

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MethodBody Field

DotNetAstNodeIdMethodBody Field
Gets the MethodBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MethodBody = 10075
Public Const MethodBody As Integer = 10075

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.MethodDeclaration Field

DotNetAstNodeIdMethodDeclaration Field
Gets the MethodDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MethodDeclaration = 10076
Public Const MethodDeclaration As Integer = 10076

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.NamespaceBody Field

DotNetAstNodeIdNamespaceBody Field
Gets the NamespaceBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int NamespaceBody = 10077
Public Const NamespaceBody As Integer = 10077

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.NamespaceDeclaration Field

DotNetAstNodeIdNamespaceDeclaration Field
Gets the NamespaceDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int NamespaceDeclaration = 10078
Public Const NamespaceDeclaration As Integer = 10078

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ObjectCreationExpression Field

DotNetAstNodeIdObjectCreationExpression Field
Gets the ObjectCreationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ObjectCreationExpression = 10079
Public Const ObjectCreationExpression As Integer = 10079

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.OperatorBody Field

DotNetAstNodeIdOperatorBody Field
Gets the OperatorBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBody = 10080
Public Const OperatorBody As Integer = 10080

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.OperatorDeclaration Field

DotNetAstNodeIdOperatorDeclaration Field
Gets the OperatorDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDeclaration = 10081
Public Const OperatorDeclaration As Integer = 10081

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.OrderByQueryOperator Field

DotNetAstNodeIdOrderByQueryOperator Field
Gets the OrderByQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OrderByQueryOperator = 10082
Public Const OrderByQueryOperator As Integer = 10082

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Ordering Field

DotNetAstNodeIdOrdering Field
Gets the Ordering AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Ordering = 10083
Public Const Ordering As Integer = 10083

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ParameterDeclaration Field

DotNetAstNodeIdParameterDeclaration Field
Gets the ParameterDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ParameterDeclaration = 10084
Public Const ParameterDeclaration As Integer = 10084

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ParenthesizedExpression Field

DotNetAstNodeIdParenthesizedExpression Field
Gets the ParenthesizedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ParenthesizedExpression = 10085
Public Const ParenthesizedExpression As Integer = 10085

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.PreprocessorDirective Field

DotNetAstNodeIdPreprocessorDirective Field
Gets the PreprocessorDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirective = 10086
Public Const PreprocessorDirective As Integer = 10086

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.PropertyBody Field

DotNetAstNodeIdPropertyBody Field
Gets the PropertyBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PropertyBody = 10087
Public Const PropertyBody As Integer = 10087

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.PropertyDeclaration Field

DotNetAstNodeIdPropertyDeclaration Field
Gets the PropertyDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PropertyDeclaration = 10088
Public Const PropertyDeclaration As Integer = 10088

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.QualifiedName Field

DotNetAstNodeIdQualifiedName Field
Gets the QualifiedName AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int QualifiedName = 10089
Public Const QualifiedName As Integer = 10089

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.QueryExpression Field

DotNetAstNodeIdQueryExpression Field
Gets the QueryExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int QueryExpression = 10090
Public Const QueryExpression As Integer = 10090

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.QueryOperator Field

DotNetAstNodeIdQueryOperator Field
Gets the QueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int QueryOperator = 10091
Public Const QueryOperator As Integer = 10091

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.RangeVariableDeclaration Field

DotNetAstNodeIdRangeVariableDeclaration Field
Gets the RangeVariableDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int RangeVariableDeclaration = 10092
Public Const RangeVariableDeclaration As Integer = 10092

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.RangeVariableDeclarator Field

DotNetAstNodeIdRangeVariableDeclarator Field
Gets the RangeVariableDeclarator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int RangeVariableDeclarator = 10093
Public Const RangeVariableDeclarator As Integer = 10093

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.RegionPreprocessorDirective Field

DotNetAstNodeIdRegionPreprocessorDirective Field
Gets the RegionPreprocessorDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int RegionPreprocessorDirective = 10094
Public Const RegionPreprocessorDirective As Integer = 10094

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ReturnStatement Field

DotNetAstNodeIdReturnStatement Field
Gets the ReturnStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReturnStatement = 10095
Public Const ReturnStatement As Integer = 10095

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ReturnTypeDeclaration Field

DotNetAstNodeIdReturnTypeDeclaration Field
Gets the ReturnTypeDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReturnTypeDeclaration = 10096
Public Const ReturnTypeDeclaration As Integer = 10096

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ReturnTypeExpression Field

DotNetAstNodeIdReturnTypeExpression Field
Gets the ReturnTypeExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReturnTypeExpression = 10097
Public Const ReturnTypeExpression As Integer = 10097

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SelectQueryOperator Field

DotNetAstNodeIdSelectQueryOperator Field
Gets the SelectQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SelectQueryOperator = 10098
Public Const SelectQueryOperator As Integer = 10098

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SimpleName Field

DotNetAstNodeIdSimpleName Field
Gets the SimpleName AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SimpleName = 10099
Public Const SimpleName As Integer = 10099

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SizeOfExpression Field

DotNetAstNodeIdSizeOfExpression Field
Gets the SizeOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SizeOfExpression = 10100
Public Const SizeOfExpression As Integer = 10100

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SkipQueryOperator Field

DotNetAstNodeIdSkipQueryOperator Field
Gets the SkipQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SkipQueryOperator = 10101
Public Const SkipQueryOperator As Integer = 10101

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SkipWhileQueryOperator Field

DotNetAstNodeIdSkipWhileQueryOperator Field
Gets the SkipWhileQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SkipWhileQueryOperator = 10102
Public Const SkipWhileQueryOperator As Integer = 10102

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StackAllocationInitializer Field

DotNetAstNodeIdStackAllocationInitializer Field
Gets the StackAllocationInitializer AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StackAllocationInitializer = 10103
Public Const StackAllocationInitializer As Integer = 10103

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.Statement Field

DotNetAstNodeIdStatement Field
Gets the Statement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Statement = 10104
Public Const Statement As Integer = 10104

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StopStatement Field

DotNetAstNodeIdStopStatement Field
Gets the StopStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StopStatement = 10105
Public Const StopStatement As Integer = 10105

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StructureBody Field

DotNetAstNodeIdStructureBody Field
Gets the StructureBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StructureBody = 10106
Public Const StructureBody As Integer = 10106

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.StructureDeclaration Field

DotNetAstNodeIdStructureDeclaration Field
Gets the StructureDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StructureDeclaration = 10107
Public Const StructureDeclaration As Integer = 10107

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SwitchSection Field

DotNetAstNodeIdSwitchSection Field
Gets the SwitchSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SwitchSection = 10108
Public Const SwitchSection As Integer = 10108

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.SwitchStatement Field

DotNetAstNodeIdSwitchStatement Field
Gets the SwitchStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SwitchStatement = 10109
Public Const SwitchStatement As Integer = 10109

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TakeQueryOperator Field

DotNetAstNodeIdTakeQueryOperator Field
Gets the TakeQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TakeQueryOperator = 10110
Public Const TakeQueryOperator As Integer = 10110

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TakeWhileQueryOperator Field

DotNetAstNodeIdTakeWhileQueryOperator Field
Gets the TakeWhileQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TakeWhileQueryOperator = 10111
Public Const TakeWhileQueryOperator As Integer = 10111

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.ThrowStatement Field

DotNetAstNodeIdThrowStatement Field
Gets the ThrowStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ThrowStatement = 10112
Public Const ThrowStatement As Integer = 10112

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TryCastExpression Field

DotNetAstNodeIdTryCastExpression Field
Gets the TryCastExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TryCastExpression = 10113
Public Const TryCastExpression As Integer = 10113

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TryStatement Field

DotNetAstNodeIdTryStatement Field
Gets the TryStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TryStatement = 10114
Public Const TryStatement As Integer = 10114

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeDeclaration Field

DotNetAstNodeIdTypeDeclaration Field
Gets the TypeDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TypeDeclaration = 10115
Public Const TypeDeclaration As Integer = 10115

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeMemberDeclaration Field

DotNetAstNodeIdTypeMemberDeclaration Field
Gets the TypeMemberDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TypeMemberDeclaration = 10116
Public Const TypeMemberDeclaration As Integer = 10116

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeOfExpression Field

DotNetAstNodeIdTypeOfExpression Field
Gets the TypeOfExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TypeOfExpression = 10117
Public Const TypeOfExpression As Integer = 10117

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.TypeParameter Field

DotNetAstNodeIdTypeParameter Field
Gets the TypeParameter AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TypeParameter = 10118
Public Const TypeParameter As Integer = 10118

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnaryOperatorExpression Field

DotNetAstNodeIdUnaryOperatorExpression Field
Gets the UnaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnaryOperatorExpression = 10119
Public Const UnaryOperatorExpression As Integer = 10119

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UncheckedExpression Field

DotNetAstNodeIdUncheckedExpression Field
Gets the UncheckedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UncheckedExpression = 10120
Public Const UncheckedExpression As Integer = 10120

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UncheckedStatement Field

DotNetAstNodeIdUncheckedStatement Field
Gets the UncheckedStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UncheckedStatement = 10121
Public Const UncheckedStatement As Integer = 10121

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnsafeStatement Field

DotNetAstNodeIdUnsafeStatement Field
Gets the UnsafeStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnsafeStatement = 10122
Public Const UnsafeStatement As Integer = 10122

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnstructuredErrorHandlerStatement Field

DotNetAstNodeIdUnstructuredErrorHandlerStatement Field
Gets the UnstructuredErrorHandlerStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnstructuredErrorHandlerStatement = 10123
Public Const UnstructuredErrorHandlerStatement As Integer = 10123

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnstructuredErrorResumeStatement Field

DotNetAstNodeIdUnstructuredErrorResumeStatement Field
Gets the UnstructuredErrorResumeStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnstructuredErrorResumeStatement = 10124
Public Const UnstructuredErrorResumeStatement As Integer = 10124

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UnstructuredErrorThrowStatement Field

DotNetAstNodeIdUnstructuredErrorThrowStatement Field
Gets the UnstructuredErrorThrowStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnstructuredErrorThrowStatement = 10125
Public Const UnstructuredErrorThrowStatement As Integer = 10125

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UsingDirective Field

DotNetAstNodeIdUsingDirective Field
Gets the UsingDirective AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UsingDirective = 10126
Public Const UsingDirective As Integer = 10126

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UsingDirectiveSection Field

DotNetAstNodeIdUsingDirectiveSection Field
Gets the UsingDirectiveSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UsingDirectiveSection = 10127
Public Const UsingDirectiveSection As Integer = 10127

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.UsingStatement Field

DotNetAstNodeIdUsingStatement Field
Gets the UsingStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UsingStatement = 10128
Public Const UsingStatement As Integer = 10128

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.VariableDeclarationExpression Field

DotNetAstNodeIdVariableDeclarationExpression Field
Gets the VariableDeclarationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int VariableDeclarationExpression = 10129
Public Const VariableDeclarationExpression As Integer = 10129

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.VariableDeclarator Field

DotNetAstNodeIdVariableDeclarator Field
Gets the VariableDeclarator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int VariableDeclarator = 10130
Public Const VariableDeclarator As Integer = 10130

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WhereQueryOperator Field

DotNetAstNodeIdWhereQueryOperator Field
Gets the WhereQueryOperator AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WhereQueryOperator = 10131
Public Const WhereQueryOperator As Integer = 10131

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WhileStatement Field

DotNetAstNodeIdWhileStatement Field
Gets the WhileStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WhileStatement = 10132
Public Const WhileStatement As Integer = 10132

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WithStatement Field

DotNetAstNodeIdWithStatement Field
Gets the WithStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WithStatement = 10133
Public Const WithStatement As Integer = 10133

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.WithTargetExpression Field

DotNetAstNodeIdWithTargetExpression Field
Gets the WithTargetExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WithTargetExpression = 10134
Public Const WithTargetExpression As Integer = 10134

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.XmlNamespaceExpression Field

DotNetAstNodeIdXmlNamespaceExpression Field
Gets the XmlNamespaceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int XmlNamespaceExpression = 10135
Public Const XmlNamespaceExpression As Integer = 10135

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


DotNetAstNodeId.YieldStatement Field

DotNetAstNodeIdYieldStatement Field
Gets the YieldStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int YieldStatement = 10136
Public Const YieldStatement As Integer = 10136

Field Value

Type: Int32
See Also

Reference

DotNetAstNodeId Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Class

ElseIfSection Class
Represents an else if section (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationElseIfSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ElseIfSection : AstNodeBase
Public Class ElseIfSection
    Inherits AstNodeBase

The ElseIfSection type exposes the following members.

Constructors
 | Name | Description
Public method | ElseIfSection | Initializes a new instance of the ElseIfSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Constructor

ElseIfSection Constructor
Initializes a new instance of the ElseIfSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ElseIfSection()
Public Sub New
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Properties

ElseIfSection Properties

The ElseIfSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.ConditionExpression Property

ElseIfSectionConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.Id Property

ElseIfSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.Statement Property

ElseIfSectionStatement Property
Gets or sets the statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement Statement { get; set; }
Public Property Statement As Statement
    Get
    Set

Property Value

Type: Statement
The statement.
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection Methods

ElseIfSection Methods

The ElseIfSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ElseIfSection.GetChildrenEnumerator Method

ElseIfSectionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ElseIfSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Class

EndStatement Class
Represents an end statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEndStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EndStatement : Statement
Public Class EndStatement
    Inherits Statement

The EndStatement type exposes the following members.

Constructors
 | Name | Description
Public method | EndStatement | Initializes a new instance of the EndStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Constructor

EndStatement Constructor
Initializes a new instance of the EndStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EndStatement()
Public Sub New
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Properties

EndStatement Properties

The EndStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement.Id Property

EndStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EndStatement Methods

EndStatement Methods

The EndStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Class

EnumerationBody Class
Represents an enumeration body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumerationBody : AstNodeBase
Public Class EnumerationBody
    Inherits AstNodeBase

The EnumerationBody type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerationBody | Initializes a new instance of the EnumerationBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Constructor

EnumerationBody Constructor
Initializes a new instance of the EnumerationBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumerationBody()
Public Sub New
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Properties

EnumerationBody Properties

The EnumerationBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.HasMembers Property

EnumerationBodyHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.Id Property

EnumerationBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.Members Property

EnumerationBodyMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<EnumerationMemberDeclaration> Members { get; }
Public ReadOnly Property Members As IList(Of EnumerationMemberDeclaration)
    Get

Property Value

Type: IList EnumerationMemberDeclaration
The members.
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody Methods

EnumerationBody Methods

The EnumerationBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationBody.GetChildrenEnumerator Method

EnumerationBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EnumerationBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Class

EnumerationDeclaration Class
Represents an enumeration declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumerationDeclaration : TypeDeclaration
Public Class EnumerationDeclaration
    Inherits TypeDeclaration

The EnumerationDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerationDeclaration | Initializes a new instance of the EnumerationDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseType | Gets or sets the base type.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Constructor

EnumerationDeclaration Constructor
Initializes a new instance of the EnumerationDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumerationDeclaration()
Public Sub New
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Properties

EnumerationDeclaration Properties

The EnumerationDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseType | Gets or sets the base type.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.BaseType Property

EnumerationDeclarationBaseType Property
Gets or sets the base type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName BaseType { get; set; }
Public Property BaseType As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The base type.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.Body Property

EnumerationDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumerationBody Body { get; set; }
Public Property Body As EnumerationBody
    Get
    Set

Property Value

Type: EnumerationBody
The body.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.Id Property

EnumerationDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.Kind Property

EnumerationDeclarationKind Property
Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration Methods

EnumerationDeclaration Methods

The EnumerationDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationDeclaration.GetChildrenEnumerator Method

EnumerationDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EnumerationDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Class

EnumerationMemberDeclaration Class
Represents an enumeration member declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationMemberDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumerationMemberDeclaration : TypeMemberDeclaration,
    INamedTypeMember, IAstNode
Public Class EnumerationMemberDeclaration
    Inherits TypeMemberDeclaration
    Implements INamedTypeMember, IAstNode

The EnumerationMemberDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | EnumerationMemberDeclaration | Initializes a new instance of the EnumerationMemberDeclaration class.
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Constructor

EnumerationMemberDeclaration Constructor
Initializes a new instance of the EnumerationMemberDeclaration class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumerationMemberDeclaration()
Public Sub New
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Properties

EnumerationMemberDeclaration Properties

The EnumerationMemberDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Id Property

EnumerationMemberDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Initializer Property

EnumerationMemberDeclarationInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Kind Property

EnumerationMemberDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.Name Property

EnumerationMemberDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration Methods

EnumerationMemberDeclaration Methods

The EnumerationMemberDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EnumerationMemberDeclaration.GetChildrenEnumerator Method

EnumerationMemberDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EnumerationMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Class

EventBody Class
Represents an event body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EventBody : AstNodeBase
Public Class EventBody
    Inherits AstNodeBase

The EventBody type exposes the following members.

Constructors
 | Name | Description
Public method | EventBody | Initializes a new instance of the EventBody class
Top
Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Constructor

EventBody Constructor
Initializes a new instance of the EventBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EventBody()
Public Sub New
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Properties

EventBody Properties

The EventBody type exposes the following members.

Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.Accessors Property

EventBodyAccessors Property
Gets the accessors.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AccessorDeclaration> Accessors { get; }
Public ReadOnly Property Accessors As IList(Of AccessorDeclaration)
    Get

Property Value

Type: IList AccessorDeclaration
The accessors.
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.HasAccessors Property

EventBodyHasAccessors Property
Returns whether the Accessors collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAccessors { get; }
Public ReadOnly Property HasAccessors As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.Id Property

EventBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody Methods

EventBody Methods

The EventBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventBody.GetChildrenEnumerator Method

EventBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EventBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Class

EventDeclaration Class
Represents an event declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EventDeclaration : TypeMemberDeclaration
Public Class EventDeclaration
    Inherits TypeMemberDeclaration

The EventDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | EventDeclaration | Initializes a new instance of the EventDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Constructor

EventDeclaration Constructor
Initializes a new instance of the EventDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EventDeclaration()
Public Sub New
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Properties

EventDeclaration Properties

The EventDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Body Property

EventDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EventBody Body { get; set; }
Public Property Body As EventBody
    Get
    Set

Property Value

Type: EventBody
The body.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Declarators Property

EventDeclarationDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.DelegateDeclaration Property

EventDeclarationDelegateDeclaration Property
Gets or sets the delegate declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DelegateDeclaration DelegateDeclaration { get; set; }
Public Property DelegateDeclaration As DelegateDeclaration
    Get
    Set

Property Value

Type: DelegateDeclaration
The delegate declaration.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.DelegateType Property

EventDeclarationDelegateType Property
Gets or sets the delegate type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName DelegateType { get; set; }
Public Property DelegateType As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The delegate type.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.HasDeclarators Property

EventDeclarationHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.HasImplements Property

EventDeclarationHasImplements Property
Returns whether the Implements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasImplements { get; }
Public ReadOnly Property HasImplements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Id Property

EventDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Implements Property

EventDeclarationImplements Property
Gets the implements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Implements { get; }
Public ReadOnly Property Implements As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The implements.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.Kind Property

EventDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration Methods

EventDeclaration Methods

The EventDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


EventDeclaration.GetChildrenEnumerator Method

EventDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

EventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Class

ExitStatement Class
Represents an exit statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExitStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExitStatement : Statement
Public Class ExitStatement
    Inherits Statement

The ExitStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExitStatement | Initializes a new instance of the ExitStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Constructor

ExitStatement Constructor
Initializes a new instance of the ExitStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExitStatement()
Public Sub New
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Properties

ExitStatement Properties

The ExitStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement.Id Property

ExitStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement.Kind Property

ExitStatementKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExitKind Kind { get; set; }
Public Property Kind As ExitKind
    Get
    Set

Property Value

Type: ExitKind
The kind.
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExitStatement Methods

ExitStatement Methods

The ExitStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExitStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression Class

Expression Class
Represents an expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Expression : AstNodeBase
Public Class Expression
    Inherits AstNodeBase

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
 | FromQualifiedName(IQualifiedName) | Creates an AST Expression from an IQualifiedName.
 | FromQualifiedName(QualifiedName) | Creates an AST Expression from an AST QualifiedName.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAddressOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAnonymousMethodExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAssignmentExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAwaitExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBinaryOperatorExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCastExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConditionalExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDefaultValueExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInitializerExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInstanceExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInvocationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIsTypeOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLambdaExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLiteralExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMemberAccess
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationObjectCreationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParenthesizedExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSizeOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStackAllocationInitializer
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryCastExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeOfExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnaryOperatorExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithTargetExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationXmlNamespaceExpression


Expression Constructor

Expression Constructor
Initializes a new instance of the Expression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression()
Public Sub New
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression Properties

Expression Properties

The Expression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.Id Property

ExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression Methods

Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
 | FromQualifiedName(IQualifiedName) | Creates an AST Expression from an IQualifiedName.
 | FromQualifiedName(QualifiedName) | Creates an AST Expression from an AST QualifiedName.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.FromQualifiedName Method

ExpressionFromQualifiedName Method
Overload List
Name | Description
FromQualifiedName(IQualifiedName) | Creates an AST Expression from an IQualifiedName.
FromQualifiedName(QualifiedName) | Creates an AST Expression from an AST QualifiedName.
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.FromQualifiedName Method (IQualifiedName)

ExpressionFromQualifiedName Method (IQualifiedName)
Creates an AST Expression from an IQualifiedName.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Expression FromQualifiedName(
    IQualifiedName qualifiedName
)
Public Shared Function FromQualifiedName (
    qualifiedName As IQualifiedName
) As Expression

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIQualifiedName
The IQualifiedName to examine.

Return Value

Type: Expression
The AST Expression that was created.
See Also

Reference

Expression Class
FromQualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Expression.FromQualifiedName Method (QualifiedName)

ExpressionFromQualifiedName Method (QualifiedName)
Creates an AST Expression from an AST QualifiedName.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Expression FromQualifiedName(
    QualifiedName qualifiedName
)
Public Shared Function FromQualifiedName (
    qualifiedName As QualifiedName
) As Expression

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The AST QualifiedName to examine.

Return Value

Type: Expression
The AST Expression that was created.
See Also

Reference

Expression Class
FromQualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Class

ExpressionStatement Class
Represents an expression statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpressionStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExpressionStatement : Statement
Public Class ExpressionStatement
    Inherits Statement

The ExpressionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionStatement | Initializes a new instance of the ExpressionStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Constructor

ExpressionStatement Constructor
Initializes a new instance of the ExpressionStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExpressionStatement()
Public Sub New
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Properties

ExpressionStatement Properties

The ExpressionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement.Expression Property

ExpressionStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement.Id Property

ExpressionStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement Methods

ExpressionStatement Methods

The ExpressionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExpressionStatement.GetChildrenEnumerator Method

ExpressionStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Class

ExternalAliasDirective Class
Represents an external alias directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExternalAliasDirective : AstNodeBase
Public Class ExternalAliasDirective
    Inherits AstNodeBase

The ExternalAliasDirective type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalAliasDirective | Initializes a new instance of the ExternalAliasDirective class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Constructor

ExternalAliasDirective Constructor
Initializes a new instance of the ExternalAliasDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExternalAliasDirective()
Public Sub New
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Properties

ExternalAliasDirective Properties

The ExternalAliasDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective.Alias Property

ExternalAliasDirectiveAlias Property
Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective.Id Property

ExternalAliasDirectiveId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirective Methods

ExternalAliasDirective Methods

The ExternalAliasDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Class

ExternalAliasDirectiveSection Class
Represents an external alias directive section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirectiveSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExternalAliasDirectiveSection : AstNodeBase
Public Class ExternalAliasDirectiveSection
    Inherits AstNodeBase

The ExternalAliasDirectiveSection type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalAliasDirectiveSection | Initializes a new instance of the ExternalAliasDirectiveSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Constructor

ExternalAliasDirectiveSection Constructor
Initializes a new instance of the ExternalAliasDirectiveSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExternalAliasDirectiveSection()
Public Sub New
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Properties

ExternalAliasDirectiveSection Properties

The ExternalAliasDirectiveSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.Directives Property

ExternalAliasDirectiveSectionDirectives Property
Gets the directives.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ExternalAliasDirective> Directives { get; }
Public ReadOnly Property Directives As IList(Of ExternalAliasDirective)
    Get

Property Value

Type: IList ExternalAliasDirective
The directives.
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.HasDirectives Property

ExternalAliasDirectiveSectionHasDirectives Property
Returns whether the Directives collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDirectives { get; }
Public ReadOnly Property HasDirectives As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.Id Property

ExternalAliasDirectiveSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection Methods

ExternalAliasDirectiveSection Methods

The ExternalAliasDirectiveSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ExternalAliasDirectiveSection.GetChildrenEnumerator Method

ExternalAliasDirectiveSectionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExternalAliasDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Class

FieldDeclaration Class
Represents a field declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFieldDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FieldDeclaration : TypeMemberDeclaration
Public Class FieldDeclaration
    Inherits TypeMemberDeclaration

The FieldDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FieldDeclaration | Initializes a new instance of the FieldDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Constructor

FieldDeclaration Constructor
Initializes a new instance of the FieldDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FieldDeclaration()
Public Sub New
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Properties

FieldDeclaration Properties

The FieldDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.Declarators Property

FieldDeclarationDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.HasDeclarators Property

FieldDeclarationHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.Id Property

FieldDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.Kind Property

FieldDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration Methods

FieldDeclaration Methods

The FieldDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FieldDeclaration.GetChildrenEnumerator Method

FieldDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FieldDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Class

FixedSizeBufferDeclaration Class
Represents a fixed size buffer declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FixedSizeBufferDeclaration : TypeMemberDeclaration
Public Class FixedSizeBufferDeclaration
    Inherits TypeMemberDeclaration

The FixedSizeBufferDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FixedSizeBufferDeclaration | Initializes a new instance of the FixedSizeBufferDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Constructor

FixedSizeBufferDeclaration Constructor
Initializes a new instance of the FixedSizeBufferDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FixedSizeBufferDeclaration()
Public Sub New
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Properties

FixedSizeBufferDeclaration Properties

The FixedSizeBufferDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.Declarators Property

FixedSizeBufferDeclarationDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<FixedSizeBufferDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of FixedSizeBufferDeclarator)
    Get

Property Value

Type: IList FixedSizeBufferDeclarator
The declarators.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.HasDeclarators Property

FixedSizeBufferDeclarationHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.Id Property

FixedSizeBufferDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.Kind Property

FixedSizeBufferDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration Methods

FixedSizeBufferDeclaration Methods

The FixedSizeBufferDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclaration.GetChildrenEnumerator Method

FixedSizeBufferDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FixedSizeBufferDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Class

FixedSizeBufferDeclarator Class
Represents a fixed size buffer declarator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclarator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FixedSizeBufferDeclarator : AstNodeBase
Public Class FixedSizeBufferDeclarator
    Inherits AstNodeBase

The FixedSizeBufferDeclarator type exposes the following members.

Constructors
 | Name | Description
Public method | FixedSizeBufferDeclarator | Initializes a new instance of the FixedSizeBufferDeclarator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Constructor

FixedSizeBufferDeclarator Constructor
Initializes a new instance of the FixedSizeBufferDeclarator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FixedSizeBufferDeclarator()
Public Sub New
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Properties

FixedSizeBufferDeclarator Properties

The FixedSizeBufferDeclarator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.Id Property

FixedSizeBufferDeclaratorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.Name Property

FixedSizeBufferDeclaratorName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.SizeExpression Property

FixedSizeBufferDeclaratorSizeExpression Property
Gets or sets the size expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression SizeExpression { get; set; }
Public Property SizeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The size expression.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.Type Property

FixedSizeBufferDeclaratorType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator Methods

FixedSizeBufferDeclarator Methods

The FixedSizeBufferDeclarator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedSizeBufferDeclarator.GetChildrenEnumerator Method

FixedSizeBufferDeclaratorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FixedSizeBufferDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Class

FixedStatement Class
Represents a fixed statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FixedStatement : Statement
Public Class FixedStatement
    Inherits Statement

The FixedStatement type exposes the following members.

Constructors
 | Name | Description
Public method | FixedStatement | Initializes a new instance of the FixedStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableDeclarators | Returns whether the VariableDeclarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarators | Gets the variable declarators.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Constructor

FixedStatement Constructor
Initializes a new instance of the FixedStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FixedStatement()
Public Sub New
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Properties

FixedStatement Properties

The FixedStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasVariableDeclarators | Returns whether the VariableDeclarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclarators | Gets the variable declarators.
Top
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.ChildStatement Property

FixedStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.HasVariableDeclarators Property

FixedStatementHasVariableDeclarators Property
Returns whether the VariableDeclarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasVariableDeclarators { get; }
Public ReadOnly Property HasVariableDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.Id Property

FixedStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.VariableDeclarators Property

FixedStatementVariableDeclarators Property
Gets the variable declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> VariableDeclarators { get; }
Public ReadOnly Property VariableDeclarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The variable declarators.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement Methods

FixedStatement Methods

The FixedStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FixedStatement.GetChildrenEnumerator Method

FixedStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FixedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Class

ForEachStatement Class
Represents a for each statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForEachStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ForEachStatement : Statement
Public Class ForEachStatement
    Inherits Statement

The ForEachStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForEachStatement | Initializes a new instance of the ForEachStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Constructor

ForEachStatement Constructor
Initializes a new instance of the ForEachStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ForEachStatement()
Public Sub New
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Properties

ForEachStatement Properties

The ForEachStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.ChildStatement Property

ForEachStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.ElementExpression Property

ForEachStatementElementExpression Property
Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.EnumerableExpression Property

ForEachStatementEnumerableExpression Property
Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.Id Property

ForEachStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement Methods

ForEachStatement Methods

The ForEachStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForEachStatement.GetChildrenEnumerator Method

ForEachStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Class

ForStatement Class
Represents a for statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ForStatement : Statement
Public Class ForStatement
    Inherits Statement

The ForStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForStatement | Initializes a new instance of the ForStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerExpressions | Returns whether the InitializerExpressions collection property contains at least one item.
Public property | HasIteratorExpressions | Returns whether the IteratorExpressions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpressions | Gets the initializer expressions.
Public property | IteratorExpressions | Gets the iterator expressions.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Constructor

ForStatement Constructor
Initializes a new instance of the ForStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ForStatement()
Public Sub New
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Properties

ForStatement Properties

The ForStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializerExpressions | Returns whether the InitializerExpressions collection property contains at least one item.
Public property | HasIteratorExpressions | Returns whether the IteratorExpressions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpressions | Gets the initializer expressions.
Public property | IteratorExpressions | Gets the iterator expressions.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.ChildStatement Property

ForStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.ConditionExpression Property

ForStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.HasInitializerExpressions Property

ForStatementHasInitializerExpressions Property
Returns whether the InitializerExpressions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasInitializerExpressions { get; }
Public ReadOnly Property HasInitializerExpressions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.HasIteratorExpressions Property

ForStatementHasIteratorExpressions Property
Returns whether the IteratorExpressions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasIteratorExpressions { get; }
Public ReadOnly Property HasIteratorExpressions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.Id Property

ForStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.InitializerExpressions Property

ForStatementInitializerExpressions Property
Gets the initializer expressions.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> InitializerExpressions { get; }
Public ReadOnly Property InitializerExpressions As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The initializer expressions.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.IteratorExpressions Property

ForStatementIteratorExpressions Property
Gets the iterator expressions.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> IteratorExpressions { get; }
Public ReadOnly Property IteratorExpressions As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The iterator expressions.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement Methods

ForStatement Methods

The ForStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ForStatement.GetChildrenEnumerator Method

ForStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Class

FromQueryOperator Class
Represents a from query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFromQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FromQueryOperator : QueryOperator
Public Class FromQueryOperator
    Inherits QueryOperator

The FromQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | FromQueryOperator | Initializes a new instance of the FromQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Constructor

FromQueryOperator Constructor
Initializes a new instance of the FromQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FromQueryOperator()
Public Sub New
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Properties

FromQueryOperator Properties

The FromQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.Declarators Property

FromQueryOperatorDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<RangeVariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of RangeVariableDeclarator)
    Get

Property Value

Type: IList RangeVariableDeclarator
The declarators.
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.HasDeclarators Property

FromQueryOperatorHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.Id Property

FromQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator Methods

FromQueryOperator Methods

The FromQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


FromQueryOperator.GetChildrenEnumerator Method

FromQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FromQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Class

GoToStatement Class
Represents a go to statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGoToStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GoToStatement : Statement
Public Class GoToStatement
    Inherits Statement

The GoToStatement type exposes the following members.

Constructors
 | Name | Description
Public method | GoToStatement | Initializes a new instance of the GoToStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Constructor

GoToStatement Constructor
Initializes a new instance of the GoToStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GoToStatement()
Public Sub New
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Properties

GoToStatement Properties

The GoToStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement.Id Property

GoToStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement.Label Property

GoToStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement Methods

GoToStatement Methods

The GoToStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GoToStatement.GetChildrenEnumerator Method

GoToStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GoToStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Class

GroupQueryOperator Class
Represents a group query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGroupQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GroupQueryOperator : QueryOperator
Public Class GroupQueryOperator
    Inherits QueryOperator

The GroupQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | GroupQueryOperator | Initializes a new instance of the GroupQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Key | Gets or sets the key.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Constructor

GroupQueryOperator Constructor
Initializes a new instance of the GroupQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GroupQueryOperator()
Public Sub New
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Properties

GroupQueryOperator Properties

The GroupQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Key | Gets or sets the key.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Id Property

GroupQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Key Property

GroupQueryOperatorKey Property
Gets or sets the key.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Key { get; set; }
Public Property Key As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The key.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Projection Property

GroupQueryOperatorProjection Property
Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.Source Property

GroupQueryOperatorSource Property
Gets or sets the source.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Source { get; set; }
Public Property Source As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The source.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator Methods

GroupQueryOperator Methods

The GroupQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


GroupQueryOperator.GetChildrenEnumerator Method

GroupQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GroupQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Class

IfStatement Class
Represents an if statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIfStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IfStatement : Statement
Public Class IfStatement
    Inherits Statement

The IfStatement type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatement | Initializes a new instance of the IfStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseIfSections | Gets the else if sections.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasElseIfSections | Returns whether the ElseIfSections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Constructor

IfStatement Constructor
Initializes a new instance of the IfStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IfStatement()
Public Sub New
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Properties

IfStatement Properties

The IfStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseIfSections | Gets the else if sections.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasElseIfSections | Returns whether the ElseIfSections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.ConditionExpression Property

IfStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.ElseIfSections Property

IfStatementElseIfSections Property
Gets the else if sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ElseIfSection> ElseIfSections { get; }
Public ReadOnly Property ElseIfSections As IList(Of ElseIfSection)
    Get

Property Value

Type: IList ElseIfSection
The else if sections.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.FalseStatement Property

IfStatementFalseStatement Property
Gets or sets the false statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement FalseStatement { get; set; }
Public Property FalseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The false statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.HasElseIfSections Property

IfStatementHasElseIfSections Property
Returns whether the ElseIfSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasElseIfSections { get; }
Public ReadOnly Property HasElseIfSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.Id Property

IfStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.TrueStatement Property

IfStatementTrueStatement Property
Gets or sets the true statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement TrueStatement { get; set; }
Public Property TrueStatement As Statement
    Get
    Set

Property Value

Type: Statement
The true statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement Methods

IfStatement Methods

The IfStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IfStatement.GetChildrenEnumerator Method

IfStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Class

InitializerExpression Class
Represents an initializer expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInitializerExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InitializerExpression : Expression
Public Class InitializerExpression
    Inherits Expression

The InitializerExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InitializerExpression | Initializes a new instance of the InitializerExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Constructor

InitializerExpression Constructor
Initializes a new instance of the InitializerExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InitializerExpression()
Public Sub New
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Properties

InitializerExpression Properties

The InitializerExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.HasInitializers Property

InitializerExpressionHasInitializers Property
Returns whether the Initializers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasInitializers { get; }
Public ReadOnly Property HasInitializers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.Id Property

InitializerExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.Initializers Property

InitializerExpressionInitializers Property
Gets the initializers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Initializers { get; }
Public ReadOnly Property Initializers As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The initializers.
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression Methods

InitializerExpression Methods

The InitializerExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InitializerExpression.GetChildrenEnumerator Method

InitializerExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InitializerExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Class

InstanceExpression Class
Represents an instance expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInstanceExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InstanceExpression : Expression
Public Class InstanceExpression
    Inherits Expression

The InstanceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InstanceExpression | Initializes a new instance of the InstanceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Constructor

InstanceExpression Constructor
Initializes a new instance of the InstanceExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InstanceExpression()
Public Sub New
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Properties

InstanceExpression Properties

The InstanceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression.Id Property

InstanceExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InstanceExpression Methods

InstanceExpression Methods

The InstanceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Class

InterfaceAccessorDeclaration Class
Represents an interface accessor declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceAccessorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InterfaceAccessorDeclaration : AstNodeBase
Public Class InterfaceAccessorDeclaration
    Inherits AstNodeBase

The InterfaceAccessorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceAccessorDeclaration | Initializes a new instance of the InterfaceAccessorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Constructor

InterfaceAccessorDeclaration Constructor
Initializes a new instance of the InterfaceAccessorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfaceAccessorDeclaration()
Public Sub New
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Properties

InterfaceAccessorDeclaration Properties

The InterfaceAccessorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.AttributeSections Property

InterfaceAccessorDeclarationAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.HasAttributeSections Property

InterfaceAccessorDeclarationHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.Id Property

InterfaceAccessorDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.Kind Property

InterfaceAccessorDeclarationKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AccessorKind Kind { get; set; }
Public Property Kind As AccessorKind
    Get
    Set

Property Value

Type: AccessorKind
The kind.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration Methods

InterfaceAccessorDeclaration Methods

The InterfaceAccessorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceAccessorDeclaration.GetChildrenEnumerator Method

InterfaceAccessorDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceAccessorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Class

InterfaceBody Class
Represents an interface body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InterfaceBody : AstNodeBase
Public Class InterfaceBody
    Inherits AstNodeBase

The InterfaceBody type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceBody | Initializes a new instance of the InterfaceBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Constructor

InterfaceBody Constructor
Initializes a new instance of the InterfaceBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfaceBody()
Public Sub New
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Properties

InterfaceBody Properties

The InterfaceBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.HasMembers Property

InterfaceBodyHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.Id Property

InterfaceBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.Members Property

InterfaceBodyMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody Methods

InterfaceBody Methods

The InterfaceBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceBody.GetChildrenEnumerator Method

InterfaceBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Class

InterfaceDeclaration Class
Represents an interface declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InterfaceDeclaration : TypeDeclaration
Public Class InterfaceDeclaration
    Inherits TypeDeclaration

The InterfaceDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceDeclaration | Initializes a new instance of the InterfaceDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Constructor

InterfaceDeclaration Constructor
Initializes a new instance of the InterfaceDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfaceDeclaration()
Public Sub New
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Properties

InterfaceDeclaration Properties

The InterfaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.BaseTypes Property

InterfaceDeclarationBaseTypes Property
Gets the base types.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> BaseTypes { get; }
Public ReadOnly Property BaseTypes As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The base types.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.Body Property

InterfaceDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfaceBody Body { get; set; }
Public Property Body As InterfaceBody
    Get
    Set

Property Value

Type: InterfaceBody
The body.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.HasBaseTypes Property

InterfaceDeclarationHasBaseTypes Property
Returns whether the BaseTypes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.HasTypeParameters Property

InterfaceDeclarationHasTypeParameters Property
Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.Id Property

InterfaceDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.Kind Property

InterfaceDeclarationKind Property
Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.TypeParameters Property

InterfaceDeclarationTypeParameters Property
Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration Methods

InterfaceDeclaration Methods

The InterfaceDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceDeclaration.GetChildrenEnumerator Method

InterfaceDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Class

InterfaceEventDeclaration Class
Represents an interface event declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceEventDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InterfaceEventDeclaration : InterfaceMemberDeclaration,
    INamedTypeMember, IAstNode
Public Class InterfaceEventDeclaration
    Inherits InterfaceMemberDeclaration
    Implements INamedTypeMember, IAstNode

The InterfaceEventDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceEventDeclaration | Initializes a new instance of the InterfaceEventDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Constructor

InterfaceEventDeclaration Constructor
Initializes a new instance of the InterfaceEventDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfaceEventDeclaration()
Public Sub New
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Properties

InterfaceEventDeclaration Properties

The InterfaceEventDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DelegateDeclaration | Gets or sets the delegate declaration.
Public property | DelegateType | Gets or sets the delegate type.
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.DelegateDeclaration Property

InterfaceEventDeclarationDelegateDeclaration Property
Gets or sets the delegate declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DelegateDeclaration DelegateDeclaration { get; set; }
Public Property DelegateDeclaration As DelegateDeclaration
    Get
    Set

Property Value

Type: DelegateDeclaration
The delegate declaration.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.DelegateType Property

InterfaceEventDeclarationDelegateType Property
Gets or sets the delegate type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName DelegateType { get; set; }
Public Property DelegateType As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The delegate type.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.Id Property

InterfaceEventDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.Kind Property

InterfaceEventDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.Name Property

InterfaceEventDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration Methods

InterfaceEventDeclaration Methods

The InterfaceEventDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceEventDeclaration.GetChildrenEnumerator Method

InterfaceEventDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceEventDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Class

InterfaceMemberDeclaration Class
Represents an interface member declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceEventDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMethodDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfacePropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class InterfaceMemberDeclaration : TypeMemberDeclaration
Public MustInherit Class InterfaceMemberDeclaration
    Inherits TypeMemberDeclaration

The InterfaceMemberDeclaration type exposes the following members.

Constructors
 | Name | Description
Protected method | InterfaceMemberDeclaration | Initializes a new instance of the InterfaceMemberDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Inherited from TypeMemberDeclaration.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from TypeMemberDeclaration.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Constructor

InterfaceMemberDeclaration Constructor
Initializes a new instance of the InterfaceMemberDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected InterfaceMemberDeclaration()
Protected Sub New
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Properties

InterfaceMemberDeclaration Properties

The InterfaceMemberDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Inherited from TypeMemberDeclaration.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration.Id Property

InterfaceMemberDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMemberDeclaration Methods

InterfaceMemberDeclaration Methods

The InterfaceMemberDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from TypeMemberDeclaration.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Class

InterfaceMethodDeclaration Class
Represents an interface method declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMethodDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InterfaceMethodDeclaration : InterfaceMemberDeclaration,
    INamedTypeMember, IAstNode
Public Class InterfaceMethodDeclaration
    Inherits InterfaceMemberDeclaration
    Implements INamedTypeMember, IAstNode

The InterfaceMethodDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceMethodDeclaration | Initializes a new instance of the InterfaceMethodDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Constructor

InterfaceMethodDeclaration Constructor
Initializes a new instance of the InterfaceMethodDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfaceMethodDeclaration()
Public Sub New
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Properties

InterfaceMethodDeclaration Properties

The InterfaceMethodDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.HasParameters Property

InterfaceMethodDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.HasTypeParameters Property

InterfaceMethodDeclarationHasTypeParameters Property
Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Id Property

InterfaceMethodDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Kind Property

InterfaceMethodDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Name Property

InterfaceMethodDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.Parameters Property

InterfaceMethodDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.ReturnType Property

InterfaceMethodDeclarationReturnType Property
Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.TypeParameters Property

InterfaceMethodDeclarationTypeParameters Property
Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration Methods

InterfaceMethodDeclaration Methods

The InterfaceMethodDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfaceMethodDeclaration.GetChildrenEnumerator Method

InterfaceMethodDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfaceMethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Class

InterfacePropertyDeclaration Class
Represents an interface property declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfacePropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InterfacePropertyDeclaration : InterfaceMemberDeclaration,
    INamedTypeMember, IAstNode
Public Class InterfacePropertyDeclaration
    Inherits InterfaceMemberDeclaration
    Implements INamedTypeMember, IAstNode

The InterfacePropertyDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | InterfacePropertyDeclaration | Initializes a new instance of the InterfacePropertyDeclaration class
Top
Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Constructor

InterfacePropertyDeclaration Constructor
Initializes a new instance of the InterfacePropertyDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InterfacePropertyDeclaration()
Public Sub New
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Properties

InterfacePropertyDeclaration Properties

The InterfacePropertyDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides InterfaceMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Accessors Property

InterfacePropertyDeclarationAccessors Property
Gets the accessors.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<InterfaceAccessorDeclaration> Accessors { get; }
Public ReadOnly Property Accessors As IList(Of InterfaceAccessorDeclaration)
    Get

Property Value

Type: IList InterfaceAccessorDeclaration
The accessors.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.HasAccessors Property

InterfacePropertyDeclarationHasAccessors Property
Returns whether the Accessors collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAccessors { get; }
Public ReadOnly Property HasAccessors As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.HasParameters Property

InterfacePropertyDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Id Property

InterfacePropertyDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Kind Property

InterfacePropertyDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Name Property

InterfacePropertyDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Parameters Property

InterfacePropertyDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.Type Property

InterfacePropertyDeclarationType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration Type { get; set; }
Public Property Type As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The type.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration Methods

InterfacePropertyDeclaration Methods

The InterfacePropertyDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InterfacePropertyDeclaration.GetChildrenEnumerator Method

InterfacePropertyDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InterfacePropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Class

InvocationExpression Class
Represents an invocation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInvocationExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvocationExpression : Expression
Public Class InvocationExpression
    Inherits Expression

The InvocationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InvocationExpression | Initializes a new instance of the InvocationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Constructor

InvocationExpression Constructor
Initializes a new instance of the InvocationExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvocationExpression()
Public Sub New
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Properties

InvocationExpression Properties

The InvocationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.Arguments Property

InvocationExpressionArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.HasArguments Property

InvocationExpressionHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.Id Property

InvocationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.TargetExpression Property

InvocationExpressionTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression Methods

InvocationExpression Methods

The InvocationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


InvocationExpression.GetChildrenEnumerator Method

InvocationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Class

IsTypeOfExpression Class
Represents an is type of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIsTypeOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IsTypeOfExpression : Expression
Public Class IsTypeOfExpression
    Inherits Expression

The IsTypeOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | IsTypeOfExpression | Initializes a new instance of the IsTypeOfExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Constructor

IsTypeOfExpression Constructor
Initializes a new instance of the IsTypeOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IsTypeOfExpression()
Public Sub New
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Properties

IsTypeOfExpression Properties

The IsTypeOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.ChildExpression Property

IsTypeOfExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.Id Property

IsTypeOfExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.Type Property

IsTypeOfExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression Methods

IsTypeOfExpression Methods

The IsTypeOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


IsTypeOfExpression.GetChildrenEnumerator Method

IsTypeOfExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IsTypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Class

JoinQueryOperator Class
Represents a join query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationJoinQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JoinQueryOperator : QueryOperator
Public Class JoinQueryOperator
    Inherits QueryOperator

The JoinQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | JoinQueryOperator | Initializes a new instance of the JoinQueryOperator class
Top
Properties
 | Name | Description
Public property | ChildJoin | Gets or sets the child join.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | LeftKeyExpression | Gets or sets the left key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | RightKeyExpression | Gets or sets the right key expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Constructor

JoinQueryOperator Constructor
Initializes a new instance of the JoinQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JoinQueryOperator()
Public Sub New
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Properties

JoinQueryOperator Properties

The JoinQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | ChildJoin | Gets or sets the child join.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarator | Gets or sets the declarator.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | LeftKeyExpression | Gets or sets the left key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | RightKeyExpression | Gets or sets the right key expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.ChildJoin Property

JoinQueryOperatorChildJoin Property
Gets or sets the child join.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JoinQueryOperator ChildJoin { get; set; }
Public Property ChildJoin As JoinQueryOperator
    Get
    Set

Property Value

Type: JoinQueryOperator
The child join.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.Declarator Property

JoinQueryOperatorDeclarator Property
Gets or sets the declarator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclarator Declarator { get; set; }
Public Property Declarator As RangeVariableDeclarator
    Get
    Set

Property Value

Type: RangeVariableDeclarator
The declarator.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.Id Property

JoinQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.LeftKeyExpression Property

JoinQueryOperatorLeftKeyExpression Property
Gets or sets the left key expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftKeyExpression { get; set; }
Public Property LeftKeyExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left key expression.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.Projection Property

JoinQueryOperatorProjection Property
Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.RightKeyExpression Property

JoinQueryOperatorRightKeyExpression Property
Gets or sets the right key expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightKeyExpression { get; set; }
Public Property RightKeyExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right key expression.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator Methods

JoinQueryOperator Methods

The JoinQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


JoinQueryOperator.GetChildrenEnumerator Method

JoinQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

JoinQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Class

LabeledStatement Class
Represents a labeled statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLabeledStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LabeledStatement : Statement
Public Class LabeledStatement
    Inherits Statement

The LabeledStatement type exposes the following members.

Constructors
 | Name | Description
Public method | LabeledStatement | Initializes a new instance of the LabeledStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Constructor

LabeledStatement Constructor
Initializes a new instance of the LabeledStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabeledStatement()
Public Sub New
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Properties

LabeledStatement Properties

The LabeledStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.ChildStatement Property

LabeledStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.Id Property

LabeledStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.Label Property

LabeledStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement Methods

LabeledStatement Methods

The LabeledStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LabeledStatement.GetChildrenEnumerator Method

LabeledStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Class

LambdaExpression Class
Represents a lambda expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLambdaExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LambdaExpression : Expression
Public Class LambdaExpression
    Inherits Expression

The LambdaExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LambdaExpression | Initializes a new instance of the LambdaExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Constructor

LambdaExpression Constructor
Initializes a new instance of the LambdaExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LambdaExpression()
Public Sub New
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Properties

LambdaExpression Properties

The LambdaExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.HasParameters Property

LambdaExpressionHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.HasStatements Property

LambdaExpressionHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Id Property

LambdaExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Modifiers Property

LambdaExpressionModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Parameters Property

LambdaExpressionParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.Statements Property

LambdaExpressionStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression Methods

LambdaExpression Methods

The LambdaExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LambdaExpression.GetChildrenEnumerator Method

LambdaExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Class

LetQueryOperator Class
Represents a let query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLetQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LetQueryOperator : QueryOperator
Public Class LetQueryOperator
    Inherits QueryOperator

The LetQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | LetQueryOperator | Initializes a new instance of the LetQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Constructor

LetQueryOperator Constructor
Initializes a new instance of the LetQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LetQueryOperator()
Public Sub New
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Properties

LetQueryOperator Properties

The LetQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator.Id Property

LetQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator.Projection Property

LetQueryOperatorProjection Property
Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator Methods

LetQueryOperator Methods

The LetQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LetQueryOperator.GetChildrenEnumerator Method

LetQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LetQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Class

LiteralExpression Class
Represents a literal expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLiteralExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LiteralExpression : Expression
Public Class LiteralExpression
    Inherits Expression

The LiteralExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LiteralExpression | Initializes a new instance of the LiteralExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Constructor

LiteralExpression Constructor
Initializes a new instance of the LiteralExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LiteralExpression()
Public Sub New
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Properties

LiteralExpression Properties

The LiteralExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression.Id Property

LiteralExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression.Kind Property

LiteralExpressionKind Property
Gets or sets the kind of literal.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LiteralExpressionKind Kind { get; set; }
Public Property Kind As LiteralExpressionKind
    Get
    Set

Property Value

Type: LiteralExpressionKind
The kind of literal.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression.StringValue Property

LiteralExpressionStringValue Property
Gets or sets the string value.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StringValue { get; set; }
Public Property StringValue As String
    Get
    Set

Property Value

Type: String
The string value.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LiteralExpression Methods

LiteralExpression Methods

The LiteralExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Class

LocalVariableDeclaration Class
Represents a local variable declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLocalVariableDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LocalVariableDeclaration : Statement
Public Class LocalVariableDeclaration
    Inherits Statement

The LocalVariableDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | LocalVariableDeclaration | Initializes a new instance of the LocalVariableDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Constructor

LocalVariableDeclaration Constructor
Initializes a new instance of the LocalVariableDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LocalVariableDeclaration()
Public Sub New
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Properties

LocalVariableDeclaration Properties

The LocalVariableDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.Declarators Property

LocalVariableDeclarationDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.HasDeclarators Property

LocalVariableDeclarationHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.Id Property

LocalVariableDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration Methods

LocalVariableDeclaration Methods

The LocalVariableDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LocalVariableDeclaration.GetChildrenEnumerator Method

LocalVariableDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LocalVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Class

LockStatement Class
Represents a lock statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLockStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LockStatement : Statement
Public Class LockStatement
    Inherits Statement

The LockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | LockStatement | Initializes a new instance of the LockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Constructor

LockStatement Constructor
Initializes a new instance of the LockStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LockStatement()
Public Sub New
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Properties

LockStatement Properties

The LockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.ChildStatement Property

LockStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.Expression Property

LockStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.Id Property

LockStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement Methods

LockStatement Methods

The LockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


LockStatement.GetChildrenEnumerator Method

LockStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LockStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Class

MemberAccess Class
Represents a member access.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMemberAccess

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MemberAccess : Expression
Public Class MemberAccess
    Inherits Expression

The MemberAccess type exposes the following members.

Constructors
 | Name | Description
Public method | MemberAccess | Initializes a new instance of the MemberAccess class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Constructor

MemberAccess Constructor
Initializes a new instance of the MemberAccess class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MemberAccess()
Public Sub New
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Properties

MemberAccess Properties

The MemberAccess type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Alias Property

MemberAccessAlias Property
Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Id Property

MemberAccessId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Kind Property

MemberAccessKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MemberAccessKind Kind { get; set; }
Public Property Kind As MemberAccessKind
    Get
    Set

Property Value

Type: MemberAccessKind
The kind.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.Name Property

MemberAccessName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.TargetExpression Property

MemberAccessTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess Methods

MemberAccess Methods

The MemberAccess type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MemberAccess.GetChildrenEnumerator Method

MemberAccessGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Class

MethodBody Class
Represents a method body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MethodBody : AstNodeBase
Public Class MethodBody
    Inherits AstNodeBase

The MethodBody type exposes the following members.

Constructors
 | Name | Description
Public method | MethodBody | Initializes a new instance of the MethodBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Constructor

MethodBody Constructor
Initializes a new instance of the MethodBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MethodBody()
Public Sub New
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Properties

MethodBody Properties

The MethodBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.HasStatements Property

MethodBodyHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.Id Property

MethodBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.Statements Property

MethodBodyStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody Methods

MethodBody Methods

The MethodBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodBody.GetChildrenEnumerator Method

MethodBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MethodBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Class

MethodDeclaration Class
Represents a method declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MethodDeclaration : TypeMemberDeclaration,
    INamedTypeMember, IAstNode
Public Class MethodDeclaration
    Inherits TypeMemberDeclaration
    Implements INamedTypeMember, IAstNode

The MethodDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | MethodDeclaration | Initializes a new instance of the MethodDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Handles | Gets the handles.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasHandles | Returns whether the Handles collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Constructor

MethodDeclaration Constructor
Initializes a new instance of the MethodDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MethodDeclaration()
Public Sub New
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Properties

MethodDeclaration Properties

The MethodDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Handles | Gets the handles.
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasHandles | Returns whether the Handles collection property contains at least one item.
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Body Property

MethodDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MethodBody Body { get; set; }
Public Property Body As MethodBody
    Get
    Set

Property Value

Type: MethodBody
The body.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Handles Property

MethodDeclarationHandles Property
Gets the handles.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Handles { get; }
Public ReadOnly Property Handles As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The handles.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasHandles Property

MethodDeclarationHasHandles Property
Returns whether the Handles collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasHandles { get; }
Public ReadOnly Property HasHandles As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasImplements Property

MethodDeclarationHasImplements Property
Returns whether the Implements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasImplements { get; }
Public ReadOnly Property HasImplements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasParameters Property

MethodDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.HasTypeParameters Property

MethodDeclarationHasTypeParameters Property
Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Id Property

MethodDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Implements Property

MethodDeclarationImplements Property
Gets the implements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Implements { get; }
Public ReadOnly Property Implements As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The implements.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Kind Property

MethodDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Name Property

MethodDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.Parameters Property

MethodDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.ReturnType Property

MethodDeclarationReturnType Property
Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.TypeParameters Property

MethodDeclarationTypeParameters Property
Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration Methods

MethodDeclaration Methods

The MethodDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


MethodDeclaration.GetChildrenEnumerator Method

MethodDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MethodDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Class

NamespaceBody Class
Represents a namespace body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NamespaceBody : AstNodeBase
Public Class NamespaceBody
    Inherits AstNodeBase

The NamespaceBody type exposes the following members.

Constructors
 | Name | Description
Public method | NamespaceBody | Initializes a new instance of the NamespaceBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Constructor

NamespaceBody Constructor
Initializes a new instance of the NamespaceBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NamespaceBody()
Public Sub New
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Properties

NamespaceBody Properties

The NamespaceBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.HasMembers Property

NamespaceBodyHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.Id Property

NamespaceBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.Members Property

NamespaceBodyMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody Methods

NamespaceBody Methods

The NamespaceBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceBody.GetChildrenEnumerator Method

NamespaceBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NamespaceBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Class

NamespaceDeclaration Class
Represents a namespace declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NamespaceDeclaration : AstNodeBase
Public Class NamespaceDeclaration
    Inherits AstNodeBase

The NamespaceDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | NamespaceDeclaration | Initializes a new instance of the NamespaceDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Constructor

NamespaceDeclaration Constructor
Initializes a new instance of the NamespaceDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NamespaceDeclaration()
Public Sub New
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Properties

NamespaceDeclaration Properties

The NamespaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.Body Property

NamespaceDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NamespaceBody Body { get; set; }
Public Property Body As NamespaceBody
    Get
    Set

Property Value

Type: NamespaceBody
The body.
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.Id Property

NamespaceDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.Name Property

NamespaceDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Name { get; set; }
Public Property Name As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The name.
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration Methods

NamespaceDeclaration Methods

The NamespaceDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


NamespaceDeclaration.GetChildrenEnumerator Method

NamespaceDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NamespaceDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Class

ObjectCreationExpression Class
Represents an object creation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationObjectCreationExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ObjectCreationExpression : Expression
Public Class ObjectCreationExpression
    Inherits Expression

The ObjectCreationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectCreationExpression | Initializes a new instance of the ObjectCreationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Constructor

ObjectCreationExpression Constructor
Initializes a new instance of the ObjectCreationExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObjectCreationExpression()
Public Sub New
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Properties

ObjectCreationExpression Properties

The ObjectCreationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Arguments Property

ObjectCreationExpressionArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.HasArguments Property

ObjectCreationExpressionHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Id Property

ObjectCreationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Initializer Property

ObjectCreationExpressionInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InitializerExpression Initializer { get; set; }
Public Property Initializer As InitializerExpression
    Get
    Set

Property Value

Type: InitializerExpression
The initializer.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.Type Property

ObjectCreationExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression Methods

ObjectCreationExpression Methods

The ObjectCreationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ObjectCreationExpression.GetChildrenEnumerator Method

ObjectCreationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Class

OperatorBody Class
Represents an operator body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OperatorBody : AstNodeBase
Public Class OperatorBody
    Inherits AstNodeBase

The OperatorBody type exposes the following members.

Constructors
 | Name | Description
Public method | OperatorBody | Initializes a new instance of the OperatorBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Constructor

OperatorBody Constructor
Initializes a new instance of the OperatorBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorBody()
Public Sub New
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Properties

OperatorBody Properties

The OperatorBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.HasStatements Property

OperatorBodyHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.Id Property

OperatorBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.Statements Property

OperatorBodyStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody Methods

OperatorBody Methods

The OperatorBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorBody.GetChildrenEnumerator Method

OperatorBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

OperatorBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Class

OperatorDeclaration Class
Represents an operator declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OperatorDeclaration : TypeMemberDeclaration
Public Class OperatorDeclaration
    Inherits TypeMemberDeclaration

The OperatorDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | OperatorDeclaration | Initializes a new instance of the OperatorDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Operator | Gets or sets the operator.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Constructor

OperatorDeclaration Constructor
Initializes a new instance of the OperatorDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorDeclaration()
Public Sub New
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Properties

OperatorDeclaration Properties

The OperatorDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Operator | Gets or sets the operator.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnType | Gets or sets the return type.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Body Property

OperatorDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorBody Body { get; set; }
Public Property Body As OperatorBody
    Get
    Set

Property Value

Type: OperatorBody
The body.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.HasParameters Property

OperatorDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Id Property

OperatorDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Kind Property

OperatorDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Operator Property

OperatorDeclarationOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.Parameters Property

OperatorDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.ReturnType Property

OperatorDeclarationReturnType Property
Gets or sets the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration ReturnType { get; set; }
Public Property ReturnType As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The return type.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration Methods

OperatorDeclaration Methods

The OperatorDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OperatorDeclaration.GetChildrenEnumerator Method

OperatorDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

OperatorDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Class

OrderByQueryOperator Class
Represents an order by query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrderByQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OrderByQueryOperator : QueryOperator
Public Class OrderByQueryOperator
    Inherits QueryOperator

The OrderByQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | OrderByQueryOperator | Initializes a new instance of the OrderByQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasOrderings | Returns whether the Orderings collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Orderings | Gets the orderings.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Constructor

OrderByQueryOperator Constructor
Initializes a new instance of the OrderByQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OrderByQueryOperator()
Public Sub New
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Properties

OrderByQueryOperator Properties

The OrderByQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasOrderings | Returns whether the Orderings collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Orderings | Gets the orderings.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.HasOrderings Property

OrderByQueryOperatorHasOrderings Property
Returns whether the Orderings collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasOrderings { get; }
Public ReadOnly Property HasOrderings As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.Id Property

OrderByQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.Orderings Property

OrderByQueryOperatorOrderings Property
Gets the orderings.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Ordering> Orderings { get; }
Public ReadOnly Property Orderings As IList(Of Ordering)
    Get

Property Value

Type: IList Ordering
The orderings.
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator Methods

OrderByQueryOperator Methods

The OrderByQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


OrderByQueryOperator.GetChildrenEnumerator Method

OrderByQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

OrderByQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Class

Ordering Class
Represents an ordering.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrdering

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Ordering : AstNodeBase
Public Class Ordering
    Inherits AstNodeBase

The Ordering type exposes the following members.

Constructors
 | Name | Description
Public method | Ordering | Initializes a new instance of the Ordering class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Direction | Gets or sets the direction.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Constructor

Ordering Constructor
Initializes a new instance of the Ordering class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Ordering()
Public Sub New
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Properties

Ordering Properties

The Ordering type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Direction | Gets or sets the direction.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.Direction Property

OrderingDirection Property
Gets or sets the direction.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OrderingDirection Direction { get; set; }
Public Property Direction As OrderingDirection
    Get
    Set

Property Value

Type: OrderingDirection
The direction.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.Expression Property

OrderingExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.Id Property

OrderingId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering Methods

Ordering Methods

The Ordering type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Ordering.GetChildrenEnumerator Method

OrderingGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Class

ParameterDeclaration Class
Represents a parameter declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParameterDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParameterDeclaration : AstNodeBase
Public Class ParameterDeclaration
    Inherits AstNodeBase

The ParameterDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterDeclaration | Initializes a new instance of the ParameterDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Constructor

ParameterDeclaration Constructor
Initializes a new instance of the ParameterDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParameterDeclaration()
Public Sub New
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Properties

ParameterDeclaration Properties

The ParameterDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.AttributeSections Property

ParameterDeclarationAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.HasAttributeSections Property

ParameterDeclarationHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Id Property

ParameterDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Initializer Property

ParameterDeclarationInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Modifiers Property

ParameterDeclarationModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParameterModifiers Modifiers { get; set; }
Public Property Modifiers As ParameterModifiers
    Get
    Set

Property Value

Type: ParameterModifiers
The modifiers.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Name Property

ParameterDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.Type Property

ParameterDeclarationType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration Methods

ParameterDeclaration Methods

The ParameterDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParameterDeclaration.GetChildrenEnumerator Method

ParameterDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Class

ParenthesizedExpression Class
Represents a parenthesized expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParenthesizedExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParenthesizedExpression : Expression
Public Class ParenthesizedExpression
    Inherits Expression

The ParenthesizedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ParenthesizedExpression | Initializes a new instance of the ParenthesizedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Constructor

ParenthesizedExpression Constructor
Initializes a new instance of the ParenthesizedExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParenthesizedExpression()
Public Sub New
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Properties

ParenthesizedExpression Properties

The ParenthesizedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression.ChildExpression Property

ParenthesizedExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression.Id Property

ParenthesizedExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression Methods

ParenthesizedExpression Methods

The ParenthesizedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ParenthesizedExpression.GetChildrenEnumerator Method

ParenthesizedExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Class

PreprocessorDirective Class
Represents a preprocessor directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPreprocessorDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRegionPreprocessorDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PreprocessorDirective : AstNodeBase
Public Class PreprocessorDirective
    Inherits AstNodeBase

The PreprocessorDirective type exposes the following members.

Constructors
 | Name | Description
Public method | PreprocessorDirective | Initializes a new instance of the PreprocessorDirective class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Constructor

PreprocessorDirective Constructor
Initializes a new instance of the PreprocessorDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PreprocessorDirective()
Public Sub New
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Properties

PreprocessorDirective Properties

The PreprocessorDirective type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective.Id Property

PreprocessorDirectiveId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PreprocessorDirective Methods

PreprocessorDirective Methods

The PreprocessorDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Class

PropertyBody Class
Represents a property body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyBody : AstNodeBase
Public Class PropertyBody
    Inherits AstNodeBase

The PropertyBody type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyBody | Initializes a new instance of the PropertyBody class
Top
Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Constructor

PropertyBody Constructor
Initializes a new instance of the PropertyBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyBody()
Public Sub New
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Properties

PropertyBody Properties

The PropertyBody type exposes the following members.

Properties
 | Name | Description
Public property | Accessors | Gets the accessors.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAccessors | Returns whether the Accessors collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.Accessors Property

PropertyBodyAccessors Property
Gets the accessors.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AccessorDeclaration> Accessors { get; }
Public ReadOnly Property Accessors As IList(Of AccessorDeclaration)
    Get

Property Value

Type: IList AccessorDeclaration
The accessors.
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.HasAccessors Property

PropertyBodyHasAccessors Property
Returns whether the Accessors collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAccessors { get; }
Public ReadOnly Property HasAccessors As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.Id Property

PropertyBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody Methods

PropertyBody Methods

The PropertyBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyBody.GetChildrenEnumerator Method

PropertyBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PropertyBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Class

PropertyDeclaration Class
Represents a property declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyDeclaration : TypeMemberDeclaration,
    INamedTypeMember, IAstNode
Public Class PropertyDeclaration
    Inherits TypeMemberDeclaration
    Implements INamedTypeMember, IAstNode

The PropertyDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDeclaration | Initializes a new instance of the PropertyDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Constructor

PropertyDeclaration Constructor
Initializes a new instance of the PropertyDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyDeclaration()
Public Sub New
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Properties

PropertyDeclaration Properties

The PropertyDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeMemberDeclaration.)
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeMemberDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeMemberDeclaration.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasImplements | Returns whether the Implements collection property contains at least one item.
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeMemberDeclarationId.)
Public property | Implements | Gets the implements.
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member. (Overrides TypeMemberDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeMemberDeclaration.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Body Property

PropertyDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyBody Body { get; set; }
Public Property Body As PropertyBody
    Get
    Set

Property Value

Type: PropertyBody
The body.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.HasImplements Property

PropertyDeclarationHasImplements Property
Returns whether the Implements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasImplements { get; }
Public ReadOnly Property HasImplements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.HasParameters Property

PropertyDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Id Property

PropertyDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
IAstNodeId
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Implements Property

PropertyDeclarationImplements Property
Gets the implements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> Implements { get; }
Public ReadOnly Property Implements As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The implements.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Initializer Property

PropertyDeclarationInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Kind Property

PropertyDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeMemberDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Name Property

PropertyDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.

Implements

INamedTypeMemberName
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Parameters Property

PropertyDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.Type Property

PropertyDeclarationType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration Type { get; set; }
Public Property Type As ReturnTypeDeclaration
    Get
    Set

Property Value

Type: ReturnTypeDeclaration
The type.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration Methods

PropertyDeclaration Methods

The PropertyDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeMemberDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


PropertyDeclaration.GetChildrenEnumerator Method

PropertyDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Class

QualifiedName Class
Represents a qualified name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class QualifiedName : AstNodeBase,
    IQualifiedName
Public Class QualifiedName
    Inherits AstNodeBase
    Implements IQualifiedName

The QualifiedName type exposes the following members.

Constructors
 | Name | Description
Public method | QualifiedName | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, SimpleName) | Initializes a new instance of the QualifiedName class.
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Identifiers | Gets the identifiers.
Public property | IsGlobal | Gets or sets the is global.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PointerLevel | Gets or sets the pointer level.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Constructor

QualifiedName Constructor
Overload List
 | Name | Description
Public method | QualifiedName | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, SimpleName) | Initializes a new instance of the QualifiedName class.
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Constructor

QualifiedName Constructor
Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName()
Public Sub New
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Constructor (String, Boolean, SimpleName[])

QualifiedName Constructor (String, Boolean, SimpleName)
Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName(
    string alias,
    bool isGlobal,
    params SimpleName[] identifiers
)
Public Sub New (
    alias As String,
    isGlobal As Boolean,
    ParamArray identifiers As SimpleName()
)

Parameters

alias
Type: SystemString
The optional alias that indicates the root of the qualified name.
isGlobal
Type: SystemBoolean
Whether the qualified name is rooted at the default global namespace.
identifiers
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName
The collection of identifiers for the qualified name.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Properties

QualifiedName Properties

The QualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArrayRankSpecifiers | Returns whether the ArrayRankSpecifiers collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Identifiers | Gets the identifiers.
Public property | IsGlobal | Gets or sets the is global.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | PointerLevel | Gets or sets the pointer level.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Alias Property

QualifiedNameAlias Property
Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.

Implements

IQualifiedNameAlias
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.ArrayRankSpecifiers Property

QualifiedNameArrayRankSpecifiers Property
Gets the array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<int> ArrayRankSpecifiers { get; }
Public ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The array rank specifiers.

Implements

IQualifiedNameArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.HasArrayRankSpecifiers Property

QualifiedNameHasArrayRankSpecifiers Property
Returns whether the ArrayRankSpecifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArrayRankSpecifiers { get; }
Public ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.

Implements

IQualifiedNameHasArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.HasIdentifiers Property

QualifiedNameHasIdentifiers Property
Returns whether the Identifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasIdentifiers { get; }
Public ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.

Implements

IQualifiedNameHasIdentifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Id Property

QualifiedNameId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Identifiers Property

QualifiedNameIdentifiers Property
Gets the identifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SimpleName> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of SimpleName)
    Get

Property Value

Type: IList SimpleName
The identifiers.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.IsGlobal Property

QualifiedNameIsGlobal Property
Gets or sets the is global.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGlobal { get; set; }
Public Property IsGlobal As Boolean
    Get
    Set

Property Value

Type: Boolean
The is global.

Implements

IQualifiedNameIsGlobal
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.PointerLevel Property

QualifiedNamePointerLevel Property
Gets or sets the pointer level.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int PointerLevel { get; set; }
Public Property PointerLevel As Integer
    Get
    Set

Property Value

Type: Int32
The pointer level.

Implements

IQualifiedNamePointerLevel
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Value Property

QualifiedNameValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName Methods

QualifiedName Methods

The QualifiedName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Clone Method

QualifiedNameClone Method
Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Clone()
Public Function Clone As QualifiedName

Return Value

Type: QualifiedName
The object that was created.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.Equals Method

QualifiedNameEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.GetChildrenEnumerator Method

QualifiedNameGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.GetHashCode Method

QualifiedNameGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QualifiedName.ToString Method

QualifiedNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Class

QueryExpression Class
Represents a query expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class QueryExpression : Expression
Public Class QueryExpression
    Inherits Expression

The QueryExpression type exposes the following members.

Constructors
 | Name | Description
Public method | QueryExpression | Initializes a new instance of the QueryExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasQueryOperators | Returns whether the QueryOperators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | QueryOperators | Gets the query operators.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Constructor

QueryExpression Constructor
Initializes a new instance of the QueryExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QueryExpression()
Public Sub New
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Properties

QueryExpression Properties

The QueryExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasQueryOperators | Returns whether the QueryOperators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | QueryOperators | Gets the query operators.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.HasQueryOperators Property

QueryExpressionHasQueryOperators Property
Returns whether the QueryOperators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasQueryOperators { get; }
Public ReadOnly Property HasQueryOperators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.Id Property

QueryExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.QueryOperators Property

QueryExpressionQueryOperators Property
Gets the query operators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QueryOperator> QueryOperators { get; }
Public ReadOnly Property QueryOperators As IList(Of QueryOperator)
    Get

Property Value

Type: IList QueryOperator
The query operators.
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression Methods

QueryExpression Methods

The QueryExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryExpression.GetChildrenEnumerator Method

QueryExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

QueryExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator Class

QueryOperator Class
Represents a query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class QueryOperator : AstNodeBase
Public Class QueryOperator
    Inherits AstNodeBase

The QueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | QueryOperator | Initializes a new instance of the QueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAggregateQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDistinctQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFromQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGroupQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationJoinQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLetQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrderByQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSelectQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipWhileQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeWhileQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhereQueryOperator


QueryOperator Constructor

QueryOperator Constructor
Initializes a new instance of the QueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QueryOperator()
Public Sub New
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator Properties

QueryOperator Properties

The QueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator.Id Property

QueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


QueryOperator Methods

QueryOperator Methods

The QueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

QueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Class

RangeVariableDeclaration Class
Represents a range variable declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RangeVariableDeclaration : AstNodeBase
Public Class RangeVariableDeclaration
    Inherits AstNodeBase

The RangeVariableDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | RangeVariableDeclaration | Initializes a new instance of the RangeVariableDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Constructor

RangeVariableDeclaration Constructor
Initializes a new instance of the RangeVariableDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration()
Public Sub New
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Properties

RangeVariableDeclaration Properties

The RangeVariableDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.Declarators Property

RangeVariableDeclarationDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<RangeVariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of RangeVariableDeclarator)
    Get

Property Value

Type: IList RangeVariableDeclarator
The declarators.
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.HasDeclarators Property

RangeVariableDeclarationHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.Id Property

RangeVariableDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration Methods

RangeVariableDeclaration Methods

The RangeVariableDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclaration.GetChildrenEnumerator Method

RangeVariableDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

RangeVariableDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Class

RangeVariableDeclarator Class
Represents a range variable declarator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclarator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RangeVariableDeclarator : AstNodeBase
Public Class RangeVariableDeclarator
    Inherits AstNodeBase

The RangeVariableDeclarator type exposes the following members.

Constructors
 | Name | Description
Public method | RangeVariableDeclarator | Initializes a new instance of the RangeVariableDeclarator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Constructor

RangeVariableDeclarator Constructor
Initializes a new instance of the RangeVariableDeclarator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclarator()
Public Sub New
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Properties

RangeVariableDeclarator Properties

The RangeVariableDeclarator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Source | Gets or sets the source.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Id Property

RangeVariableDeclaratorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Name Property

RangeVariableDeclaratorName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Source Property

RangeVariableDeclaratorSource Property
Gets or sets the source.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Source { get; set; }
Public Property Source As Expression
    Get
    Set

Property Value

Type: Expression
The source.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.Type Property

RangeVariableDeclaratorType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator Methods

RangeVariableDeclarator Methods

The RangeVariableDeclarator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RangeVariableDeclarator.GetChildrenEnumerator Method

RangeVariableDeclaratorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

RangeVariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Class

RegionPreprocessorDirective Class
Represents a region preprocessor directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPreprocessorDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRegionPreprocessorDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RegionPreprocessorDirective : PreprocessorDirective
Public Class RegionPreprocessorDirective
    Inherits PreprocessorDirective

The RegionPreprocessorDirective type exposes the following members.

Constructors
 | Name | Description
Public method | RegionPreprocessorDirective | Initializes a new instance of the RegionPreprocessorDirective class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides PreprocessorDirectiveId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Constructor

RegionPreprocessorDirective Constructor
Initializes a new instance of the RegionPreprocessorDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RegionPreprocessorDirective()
Public Sub New
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Properties

RegionPreprocessorDirective Properties

The RegionPreprocessorDirective type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides PreprocessorDirectiveId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective.Id Property

RegionPreprocessorDirectiveId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


RegionPreprocessorDirective Methods

RegionPreprocessorDirective Methods

The RegionPreprocessorDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RegionPreprocessorDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Class

ReturnStatement Class
Represents a return statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReturnStatement : Statement
Public Class ReturnStatement
    Inherits Statement

The ReturnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnStatement | Initializes a new instance of the ReturnStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Constructor

ReturnStatement Constructor
Initializes a new instance of the ReturnStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnStatement()
Public Sub New
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Properties

ReturnStatement Properties

The ReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement.Expression Property

ReturnStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement.Id Property

ReturnStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement Methods

ReturnStatement Methods

The ReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnStatement.GetChildrenEnumerator Method

ReturnStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Class

ReturnTypeDeclaration Class
Represents a return type declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReturnTypeDeclaration : AstNodeBase
Public Class ReturnTypeDeclaration
    Inherits AstNodeBase

The ReturnTypeDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnTypeDeclaration | Initializes a new instance of the ReturnTypeDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Constructor

ReturnTypeDeclaration Constructor
Initializes a new instance of the ReturnTypeDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeDeclaration()
Public Sub New
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Properties

ReturnTypeDeclaration Properties

The ReturnTypeDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.AttributeSections Property

ReturnTypeDeclarationAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.HasAttributeSections Property

ReturnTypeDeclarationHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.Id Property

ReturnTypeDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.Type Property

ReturnTypeDeclarationType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration Methods

ReturnTypeDeclaration Methods

The ReturnTypeDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeDeclaration.GetChildrenEnumerator Method

ReturnTypeDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnTypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Class

ReturnTypeExpression Class
Represents a return type expression (used by resolver).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReturnTypeExpression : Expression
Public Class ReturnTypeExpression
    Inherits Expression

The ReturnTypeExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnTypeExpression | Initializes a new instance of the ReturnTypeExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Constructor

ReturnTypeExpression Constructor
Initializes a new instance of the ReturnTypeExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnTypeExpression()
Public Sub New
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Properties

ReturnTypeExpression Properties

The ReturnTypeExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression.ChildExpression Property

ReturnTypeExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression.Id Property

ReturnTypeExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression Methods

ReturnTypeExpression Methods

The ReturnTypeExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ReturnTypeExpression.GetChildrenEnumerator Method

ReturnTypeExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnTypeExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Class

SelectQueryOperator Class
Represents a select query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSelectQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SelectQueryOperator : QueryOperator
Public Class SelectQueryOperator
    Inherits QueryOperator

The SelectQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | SelectQueryOperator | Initializes a new instance of the SelectQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Constructor

SelectQueryOperator Constructor
Initializes a new instance of the SelectQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectQueryOperator()
Public Sub New
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Properties

SelectQueryOperator Properties

The SelectQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Projection | Gets or sets the projection.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator.Id Property

SelectQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator.Projection Property

SelectQueryOperatorProjection Property
Gets or sets the projection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeVariableDeclaration Projection { get; set; }
Public Property Projection As RangeVariableDeclaration
    Get
    Set

Property Value

Type: RangeVariableDeclaration
The projection.
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator Methods

SelectQueryOperator Methods

The SelectQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SelectQueryOperator.GetChildrenEnumerator Method

SelectQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SelectQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Class

SimpleName Class
Represents a simple name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleName : Expression, ISimpleName
Public Class SimpleName
    Inherits Expression
    Implements ISimpleName

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, QualifiedName) | Initializes a new instance of the SimpleName class.
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeArguments | Returns whether the TypeArguments collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | TypeArguments | Gets the generic type arguments.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Constructor

SimpleName Constructor
Overload List
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, QualifiedName) | Initializes a new instance of the SimpleName class.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Constructor

SimpleName Constructor
Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName()
Public Sub New
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Constructor (String, QualifiedName[])

SimpleName Constructor (String, QualifiedName)
Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName(
    string text,
    params QualifiedName[] typeArguments
)
Public Sub New (
    text As String,
    ParamArray typeArguments As QualifiedName()
)

Parameters

text
Type: SystemString
The text value of the identifier.
typeArguments
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The collection of optional generic type arguments for the identifier.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Properties

SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeArguments | Returns whether the TypeArguments collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | TypeArguments | Gets the generic type arguments.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.HasTypeArguments Property

SimpleNameHasTypeArguments Property
Returns whether the TypeArguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeArguments { get; }
Public ReadOnly Property HasTypeArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.

Implements

ISimpleNameHasTypeArguments
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Id Property

SimpleNameId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property
Gets or sets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text value of the identifier.

Implements

ISimpleNameText
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.TypeArguments Property

SimpleNameTypeArguments Property
Gets the generic type arguments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> TypeArguments { get; }
Public ReadOnly Property TypeArguments As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The generic type arguments.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Value Property

SimpleNameValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName Methods

SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Clone Method

SimpleNameClone Method
Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Clone()
Public Function Clone As SimpleName

Return Value

Type: SimpleName
The object that was created.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.Equals Method

SimpleNameEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.GetChildrenEnumerator Method

SimpleNameGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.GetHashCode Method

SimpleNameGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SimpleName.ToString Method

SimpleNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Class

SizeOfExpression Class
Represents a size of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSizeOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SizeOfExpression : Expression
Public Class SizeOfExpression
    Inherits Expression

The SizeOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SizeOfExpression | Initializes a new instance of the SizeOfExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Constructor

SizeOfExpression Constructor
Initializes a new instance of the SizeOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SizeOfExpression()
Public Sub New
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Properties

SizeOfExpression Properties

The SizeOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression.Id Property

SizeOfExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression.Type Property

SizeOfExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression Methods

SizeOfExpression Methods

The SizeOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SizeOfExpression.GetChildrenEnumerator Method

SizeOfExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SizeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Class

SkipQueryOperator Class
Represents a skip query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SkipQueryOperator : QueryOperator
Public Class SkipQueryOperator
    Inherits QueryOperator

The SkipQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | SkipQueryOperator | Initializes a new instance of the SkipQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Constructor

SkipQueryOperator Constructor
Initializes a new instance of the SkipQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SkipQueryOperator()
Public Sub New
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Properties

SkipQueryOperator Properties

The SkipQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator.CountExpression Property

SkipQueryOperatorCountExpression Property
Gets or sets the count expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression CountExpression { get; set; }
Public Property CountExpression As Expression
    Get
    Set

Property Value

Type: Expression
The count expression.
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator.Id Property

SkipQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator Methods

SkipQueryOperator Methods

The SkipQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipQueryOperator.GetChildrenEnumerator Method

SkipQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SkipQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Class

SkipWhileQueryOperator Class
Represents a skip while query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSkipWhileQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SkipWhileQueryOperator : QueryOperator
Public Class SkipWhileQueryOperator
    Inherits QueryOperator

The SkipWhileQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | SkipWhileQueryOperator | Initializes a new instance of the SkipWhileQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Constructor

SkipWhileQueryOperator Constructor
Initializes a new instance of the SkipWhileQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SkipWhileQueryOperator()
Public Sub New
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Properties

SkipWhileQueryOperator Properties

The SkipWhileQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator.ConditionExpression Property

SkipWhileQueryOperatorConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator.Id Property

SkipWhileQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator Methods

SkipWhileQueryOperator Methods

The SkipWhileQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SkipWhileQueryOperator.GetChildrenEnumerator Method

SkipWhileQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SkipWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Class

StackAllocationInitializer Class
Represents a stack allocation initializer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStackAllocationInitializer

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StackAllocationInitializer : Expression
Public Class StackAllocationInitializer
    Inherits Expression

The StackAllocationInitializer type exposes the following members.

Constructors
 | Name | Description
Public method | StackAllocationInitializer | Initializes a new instance of the StackAllocationInitializer class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Constructor

StackAllocationInitializer Constructor
Initializes a new instance of the StackAllocationInitializer class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StackAllocationInitializer()
Public Sub New
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Properties

StackAllocationInitializer Properties

The StackAllocationInitializer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SizeExpression | Gets or sets the size expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.Id Property

StackAllocationInitializerId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.SizeExpression Property

StackAllocationInitializerSizeExpression Property
Gets or sets the size expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression SizeExpression { get; set; }
Public Property SizeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The size expression.
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.Type Property

StackAllocationInitializerType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer Methods

StackAllocationInitializer Methods

The StackAllocationInitializer type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StackAllocationInitializer.GetChildrenEnumerator Method

StackAllocationInitializerGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StackAllocationInitializer Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement Class

Statement Class
Represents a statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Statement : AstNodeBase
Public Class Statement
    Inherits AstNodeBase

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayEraseStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBlockStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationBreakStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCheckedStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationContinueStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDoStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEndStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExitStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpressionStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForEachStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationForStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationGoToStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationIfStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLabeledStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLocalVariableDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationLockStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStopStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationThrowStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnsafeStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorHandlerStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorResumeStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorThrowStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhileStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationYieldStatement


Statement Constructor

Statement Constructor
Initializes a new instance of the Statement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement()
Public Sub New
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement Properties

Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement.Id Property

StatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


Statement Methods

Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Class

StopStatement Class
Represents a stop statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStopStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StopStatement : Statement
Public Class StopStatement
    Inherits Statement

The StopStatement type exposes the following members.

Constructors
 | Name | Description
Public method | StopStatement | Initializes a new instance of the StopStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Constructor

StopStatement Constructor
Initializes a new instance of the StopStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StopStatement()
Public Sub New
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Properties

StopStatement Properties

The StopStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement.Id Property

StopStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StopStatement Methods

StopStatement Methods

The StopStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StopStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Class

StructureBody Class
Represents a structure body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureBody

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureBody : AstNodeBase
Public Class StructureBody
    Inherits AstNodeBase

The StructureBody type exposes the following members.

Constructors
 | Name | Description
Public method | StructureBody | Initializes a new instance of the StructureBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Constructor

StructureBody Constructor
Initializes a new instance of the StructureBody class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureBody()
Public Sub New
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Properties

StructureBody Properties

The StructureBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.HasMembers Property

StructureBodyHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.Id Property

StructureBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.Members Property

StructureBodyMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Members { get; }
Public ReadOnly Property Members As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The members.
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody Methods

StructureBody Methods

The StructureBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureBody.GetChildrenEnumerator Method

StructureBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StructureBody Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Class

StructureDeclaration Class
Represents a structure declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StructureDeclaration : TypeDeclaration
Public Class StructureDeclaration
    Inherits TypeDeclaration

The StructureDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | StructureDeclaration | Initializes a new instance of the StructureDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Constructor

StructureDeclaration Constructor
Initializes a new instance of the StructureDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureDeclaration()
Public Sub New
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Properties

StructureDeclaration Properties

The StructureDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections. (Inherited from TypeDeclaration.)
Public property | BaseTypes | Gets the base types.
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment. (Inherited from TypeDeclaration.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item. (Inherited from TypeDeclaration.)
Public property | HasBaseTypes | Returns whether the BaseTypes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasTypeParameters | Returns whether the TypeParameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides TypeDeclarationId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type. (Overrides TypeDeclarationKind.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers. (Inherited from TypeDeclaration.)
Public property | Name | Gets or sets the name. (Inherited from TypeDeclaration.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeParameters | Gets the type parameters.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.BaseTypes Property

StructureDeclarationBaseTypes Property
Gets the base types.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> BaseTypes { get; }
Public ReadOnly Property BaseTypes As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The base types.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.Body Property

StructureDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StructureBody Body { get; set; }
Public Property Body As StructureBody
    Get
    Set

Property Value

Type: StructureBody
The body.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.HasBaseTypes Property

StructureDeclarationHasBaseTypes Property
Returns whether the BaseTypes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasBaseTypes { get; }
Public ReadOnly Property HasBaseTypes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.HasTypeParameters Property

StructureDeclarationHasTypeParameters Property
Returns whether the TypeParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeParameters { get; }
Public ReadOnly Property HasTypeParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.Id Property

StructureDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.Kind Property

StructureDeclarationKind Property
Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed TypeDeclarationKind Kind { get; }
Public Overrides NotOverridable ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.TypeParameters Property

StructureDeclarationTypeParameters Property
Gets the type parameters.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TypeParameter> TypeParameters { get; }
Public ReadOnly Property TypeParameters As IList(Of TypeParameter)
    Get

Property Value

Type: IList TypeParameter
The type parameters.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration Methods

StructureDeclaration Methods

The StructureDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides TypeDeclarationGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


StructureDeclaration.GetChildrenEnumerator Method

StructureDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StructureDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Class

SwitchSection Class
Represents a switch section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SwitchSection : AstNodeBase
Public Class SwitchSection
    Inherits AstNodeBase

The SwitchSection type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchSection | Initializes a new instance of the SwitchSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Constructor

SwitchSection Constructor
Initializes a new instance of the SwitchSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SwitchSection()
Public Sub New
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Properties

SwitchSection Properties

The SwitchSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.HasLabels Property

SwitchSectionHasLabels Property
Returns whether the Labels collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasLabels { get; }
Public ReadOnly Property HasLabels As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.HasStatements Property

SwitchSectionHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.Id Property

SwitchSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.Labels Property

SwitchSectionLabels Property
Gets the labels.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Labels { get; }
Public ReadOnly Property Labels As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The labels.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.Statements Property

SwitchSectionStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection Methods

SwitchSection Methods

The SwitchSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchSection.GetChildrenEnumerator Method

SwitchSectionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Class

SwitchStatement Class
Represents a switch statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SwitchStatement : Statement
Public Class SwitchStatement
    Inherits Statement

The SwitchStatement type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchStatement | Initializes a new instance of the SwitchStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Constructor

SwitchStatement Constructor
Initializes a new instance of the SwitchStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SwitchStatement()
Public Sub New
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Properties

SwitchStatement Properties

The SwitchStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.Expression Property

SwitchStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.HasSections Property

SwitchStatementHasSections Property
Returns whether the Sections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSections { get; }
Public ReadOnly Property HasSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.Id Property

SwitchStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.Sections Property

SwitchStatementSections Property
Gets the sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SwitchSection> Sections { get; }
Public ReadOnly Property Sections As IList(Of SwitchSection)
    Get

Property Value

Type: IList SwitchSection
The sections.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement Methods

SwitchStatement Methods

The SwitchStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


SwitchStatement.GetChildrenEnumerator Method

SwitchStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Class

TakeQueryOperator Class
Represents a take query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TakeQueryOperator : QueryOperator
Public Class TakeQueryOperator
    Inherits QueryOperator

The TakeQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | TakeQueryOperator | Initializes a new instance of the TakeQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Constructor

TakeQueryOperator Constructor
Initializes a new instance of the TakeQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TakeQueryOperator()
Public Sub New
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Properties

TakeQueryOperator Properties

The TakeQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CountExpression | Gets or sets the count expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator.CountExpression Property

TakeQueryOperatorCountExpression Property
Gets or sets the count expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression CountExpression { get; set; }
Public Property CountExpression As Expression
    Get
    Set

Property Value

Type: Expression
The count expression.
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator.Id Property

TakeQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator Methods

TakeQueryOperator Methods

The TakeQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeQueryOperator.GetChildrenEnumerator Method

TakeQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TakeQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Class

TakeWhileQueryOperator Class
Represents a take while query operator (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTakeWhileQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TakeWhileQueryOperator : QueryOperator
Public Class TakeWhileQueryOperator
    Inherits QueryOperator

The TakeWhileQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | TakeWhileQueryOperator | Initializes a new instance of the TakeWhileQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Constructor

TakeWhileQueryOperator Constructor
Initializes a new instance of the TakeWhileQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TakeWhileQueryOperator()
Public Sub New
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Properties

TakeWhileQueryOperator Properties

The TakeWhileQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator.ConditionExpression Property

TakeWhileQueryOperatorConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator.Id Property

TakeWhileQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator Methods

TakeWhileQueryOperator Methods

The TakeWhileQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TakeWhileQueryOperator.GetChildrenEnumerator Method

TakeWhileQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TakeWhileQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Class

ThrowStatement Class
Represents a throw statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationThrowStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ThrowStatement : Statement
Public Class ThrowStatement
    Inherits Statement

The ThrowStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ThrowStatement | Initializes a new instance of the ThrowStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Constructor

ThrowStatement Constructor
Initializes a new instance of the ThrowStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ThrowStatement()
Public Sub New
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Properties

ThrowStatement Properties

The ThrowStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement.Expression Property

ThrowStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement.Id Property

ThrowStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement Methods

ThrowStatement Methods

The ThrowStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ThrowStatement.GetChildrenEnumerator Method

ThrowStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Class

TryCastExpression Class
Represents a try cast expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryCastExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TryCastExpression : Expression
Public Class TryCastExpression
    Inherits Expression

The TryCastExpression type exposes the following members.

Constructors
 | Name | Description
Public method | TryCastExpression | Initializes a new instance of the TryCastExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Constructor

TryCastExpression Constructor
Initializes a new instance of the TryCastExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TryCastExpression()
Public Sub New
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Properties

TryCastExpression Properties

The TryCastExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.ChildExpression Property

TryCastExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.Id Property

TryCastExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.Type Property

TryCastExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression Methods

TryCastExpression Methods

The TryCastExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryCastExpression.GetChildrenEnumerator Method

TryCastExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryCastExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Class

TryStatement Class
Represents a try statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTryStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TryStatement : Statement
Public Class TryStatement
    Inherits Statement

The TryStatement type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatement | Initializes a new instance of the TryStatement class
Top
Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Constructor

TryStatement Constructor
Initializes a new instance of the TryStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TryStatement()
Public Sub New
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Properties

TryStatement Properties

The TryStatement type exposes the following members.

Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.CatchClauses Property

TryStatementCatchClauses Property
Gets the catch clauses.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<CatchClause> CatchClauses { get; }
Public ReadOnly Property CatchClauses As IList(Of CatchClause)
    Get

Property Value

Type: IList CatchClause
The catch clauses.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.FinallyBlock Property

TryStatementFinallyBlock Property
Gets or sets the finally block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement FinallyBlock { get; set; }
Public Property FinallyBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The finally block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.HasCatchClauses Property

TryStatementHasCatchClauses Property
Returns whether the CatchClauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCatchClauses { get; }
Public ReadOnly Property HasCatchClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.Id Property

TryStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.TryBlock Property

TryStatementTryBlock Property
Gets or sets the try block.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement TryBlock { get; set; }
Public Property TryBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The try block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement Methods

TryStatement Methods

The TryStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TryStatement.GetChildrenEnumerator Method

TryStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Class

TypeDeclaration Class
Represents a type declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDelegateDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureDeclaration

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TypeDeclaration : AstNodeBase,
    IDecoratedMember, IAstNode
Public MustInherit Class TypeDeclaration
    Inherits AstNodeBase
    Implements IDecoratedMember, IAstNode

The TypeDeclaration type exposes the following members.

Constructors
 | Name | Description
Protected method | TypeDeclaration | Initializes a new instance of the TypeDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Constructor

TypeDeclaration Constructor
Initializes a new instance of the TypeDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TypeDeclaration()
Protected Sub New
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Properties

TypeDeclaration Properties

The TypeDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeDeclarationKind indicating the kind of type.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.AttributeSections Property

TypeDeclarationAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.

Implements

IDecoratedMemberAttributeSections
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.DocumentationComment Property

TypeDeclarationDocumentationComment Property
Gets or sets the documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentationComment DocumentationComment { get; set; }
Public Property DocumentationComment As DocumentationComment
    Get
    Set

Property Value

Type: DocumentationComment
The documentation comment.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.HasAttributeSections Property

TypeDeclarationHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Id Property

TypeDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Kind Property

TypeDeclarationKind Property
Gets a TypeDeclarationKind indicating the kind of type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract TypeDeclarationKind Kind { get; }
Public MustOverride ReadOnly Property Kind As TypeDeclarationKind
    Get

Property Value

Type: TypeDeclarationKind
A TypeDeclarationKind indicating the kind of type.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Modifiers Property

TypeDeclarationModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.

Implements

IDecoratedMemberModifiers
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.Name Property

TypeDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration Methods

TypeDeclaration Methods

The TypeDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeDeclaration.GetChildrenEnumerator Method

TypeDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration Class

TypeMemberDeclaration Class
Represents a type member declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
More...

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TypeMemberDeclaration : AstNodeBase,
    IDecoratedMember, IAstNode
Public MustInherit Class TypeMemberDeclaration
    Inherits AstNodeBase
    Implements IDecoratedMember, IAstNode

The TypeMemberDeclaration type exposes the following members.

Constructors
 | Name | Description
Protected method | TypeMemberDeclaration | Initializes a new instance of the TypeMemberDeclaration class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFieldDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyDeclaration


TypeMemberDeclaration Constructor

TypeMemberDeclaration Constructor
Initializes a new instance of the TypeMemberDeclaration class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TypeMemberDeclaration()
Protected Sub New
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration Properties

TypeMemberDeclaration Properties

The TypeMemberDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DocumentationComment | Gets or sets the documentation comment.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets a TypeMemberDeclarationKind indicating the kind of type member.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Modifiers | Gets or sets the modifiers.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.AttributeSections Property

TypeMemberDeclarationAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.

Implements

IDecoratedMemberAttributeSections
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.DocumentationComment Property

TypeMemberDeclarationDocumentationComment Property
Gets or sets the documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentationComment DocumentationComment { get; set; }
Public Property DocumentationComment As DocumentationComment
    Get
    Set

Property Value

Type: DocumentationComment
The documentation comment.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.HasAttributeSections Property

TypeMemberDeclarationHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.Id Property

TypeMemberDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
IAstNodeId
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.Kind Property

TypeMemberDeclarationKind Property
Gets a TypeMemberDeclarationKind indicating the kind of type member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract TypeMemberDeclarationKind Kind { get; }
Public MustOverride ReadOnly Property Kind As TypeMemberDeclarationKind
    Get

Property Value

Type: TypeMemberDeclarationKind
A TypeMemberDeclarationKind indicating the kind of type member.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.Modifiers Property

TypeMemberDeclarationModifiers Property
Gets or sets the modifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Modifiers Modifiers { get; set; }
Public Property Modifiers As Modifiers
    Get
    Set

Property Value

Type: Modifiers
The modifiers.

Implements

IDecoratedMemberModifiers
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration Methods

TypeMemberDeclaration Methods

The TypeMemberDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeMemberDeclaration.GetChildrenEnumerator Method

TypeMemberDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeMemberDeclaration Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Class

TypeOfExpression Class
Represents a type of expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeOfExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TypeOfExpression : Expression
Public Class TypeOfExpression
    Inherits Expression

The TypeOfExpression type exposes the following members.

Constructors
 | Name | Description
Public method | TypeOfExpression | Initializes a new instance of the TypeOfExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Constructor

TypeOfExpression Constructor
Initializes a new instance of the TypeOfExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypeOfExpression()
Public Sub New
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Properties

TypeOfExpression Properties

The TypeOfExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression.Id Property

TypeOfExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression.Type Property

TypeOfExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression Methods

TypeOfExpression Methods

The TypeOfExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeOfExpression.GetChildrenEnumerator Method

TypeOfExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeOfExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Class

TypeParameter Class
Represents a type parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeParameter

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TypeParameter : AstNodeBase
Public Class TypeParameter
    Inherits AstNodeBase

The TypeParameter type exposes the following members.

Constructors
 | Name | Description
Public method | TypeParameter | Initializes a new instance of the TypeParameter class
Top
Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDefaultConstructorConstraint | Gets or sets the has default constructor constraint.
Public property | HasNotNullableValueTypeConstraint | Gets or sets the has not-nullable value type constraint.
Public property | HasReferenceTypeConstraint | Gets or sets the has reference type constraint.
Public property | HasTypeConstraints | Returns whether the TypeConstraints collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeConstraints | Gets the type constraints.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VarianceAnnotation | Gets or sets the variance annotation.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Constructor

TypeParameter Constructor
Initializes a new instance of the TypeParameter class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypeParameter()
Public Sub New
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Properties

TypeParameter Properties

The TypeParameter type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSections | Gets the attribute sections.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasAttributeSections | Returns whether the AttributeSections collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDefaultConstructorConstraint | Gets or sets the has default constructor constraint.
Public property | HasNotNullableValueTypeConstraint | Gets or sets the has not-nullable value type constraint.
Public property | HasReferenceTypeConstraint | Gets or sets the has reference type constraint.
Public property | HasTypeConstraints | Returns whether the TypeConstraints collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TypeConstraints | Gets the type constraints.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VarianceAnnotation | Gets or sets the variance annotation.
Top
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.AttributeSections Property

TypeParameterAttributeSections Property
Gets the attribute sections.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<AttributeSection> AttributeSections { get; }
Public ReadOnly Property AttributeSections As IList(Of AttributeSection)
    Get

Property Value

Type: IList AttributeSection
The attribute sections.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasAttributeSections Property

TypeParameterHasAttributeSections Property
Returns whether the AttributeSections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributeSections { get; }
Public ReadOnly Property HasAttributeSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasDefaultConstructorConstraint Property

TypeParameterHasDefaultConstructorConstraint Property
Gets or sets the has default constructor constraint.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDefaultConstructorConstraint { get; set; }
Public Property HasDefaultConstructorConstraint As Boolean
    Get
    Set

Property Value

Type: Boolean
The has default constructor constraint.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasNotNullableValueTypeConstraint Property

TypeParameterHasNotNullableValueTypeConstraint Property
Gets or sets the has not-nullable value type constraint.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNotNullableValueTypeConstraint { get; set; }
Public Property HasNotNullableValueTypeConstraint As Boolean
    Get
    Set

Property Value

Type: Boolean
The has not-nullable value type constraint.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasReferenceTypeConstraint Property

TypeParameterHasReferenceTypeConstraint Property
Gets or sets the has reference type constraint.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasReferenceTypeConstraint { get; set; }
Public Property HasReferenceTypeConstraint As Boolean
    Get
    Set

Property Value

Type: Boolean
The has reference type constraint.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.HasTypeConstraints Property

TypeParameterHasTypeConstraints Property
Returns whether the TypeConstraints collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeConstraints { get; }
Public ReadOnly Property HasTypeConstraints As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.Id Property

TypeParameterId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.Name Property

TypeParameterName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.TypeConstraints Property

TypeParameterTypeConstraints Property
Gets the type constraints.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<QualifiedName> TypeConstraints { get; }
Public ReadOnly Property TypeConstraints As IList(Of QualifiedName)
    Get

Property Value

Type: IList QualifiedName
The type constraints.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.VarianceAnnotation Property

TypeParameterVarianceAnnotation Property
Gets or sets the variance annotation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VarianceAnnotation VarianceAnnotation { get; set; }
Public Property VarianceAnnotation As VarianceAnnotation
    Get
    Set

Property Value

Type: VarianceAnnotation
The variance annotation.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter Methods

TypeParameter Methods

The TypeParameter type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


TypeParameter.GetChildrenEnumerator Method

TypeParameterGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TypeParameter Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Class

UnaryOperatorExpression Class
Represents an unary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnaryOperatorExpression : Expression
Public Class UnaryOperatorExpression
    Inherits Expression

The UnaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UnaryOperatorExpression | Initializes a new instance of the UnaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Constructor

UnaryOperatorExpression Constructor
Initializes a new instance of the UnaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnaryOperatorExpression()
Public Sub New
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Properties

UnaryOperatorExpression Properties

The UnaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.ChildExpression Property

UnaryOperatorExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.Id Property

UnaryOperatorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.Operator Property

UnaryOperatorExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression Methods

UnaryOperatorExpression Methods

The UnaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnaryOperatorExpression.GetChildrenEnumerator Method

UnaryOperatorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Class

UncheckedExpression Class
Represents an unchecked expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UncheckedExpression : Expression
Public Class UncheckedExpression
    Inherits Expression

The UncheckedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UncheckedExpression | Initializes a new instance of the UncheckedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Constructor

UncheckedExpression Constructor
Initializes a new instance of the UncheckedExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UncheckedExpression()
Public Sub New
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Properties

UncheckedExpression Properties

The UncheckedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression.ChildExpression Property

UncheckedExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression.Id Property

UncheckedExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression Methods

UncheckedExpression Methods

The UncheckedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedExpression.GetChildrenEnumerator Method

UncheckedExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UncheckedExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Class

UncheckedStatement Class
Represents an unchecked statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUncheckedStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UncheckedStatement : Statement
Public Class UncheckedStatement
    Inherits Statement

The UncheckedStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UncheckedStatement | Initializes a new instance of the UncheckedStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Constructor

UncheckedStatement Constructor
Initializes a new instance of the UncheckedStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UncheckedStatement()
Public Sub New
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Properties

UncheckedStatement Properties

The UncheckedStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement.ChildStatement Property

UncheckedStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement.Id Property

UncheckedStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement Methods

UncheckedStatement Methods

The UncheckedStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UncheckedStatement.GetChildrenEnumerator Method

UncheckedStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UncheckedStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Class

UnsafeStatement Class
Represents an unsafe statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnsafeStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnsafeStatement : Statement
Public Class UnsafeStatement
    Inherits Statement

The UnsafeStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnsafeStatement | Initializes a new instance of the UnsafeStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Constructor

UnsafeStatement Constructor
Initializes a new instance of the UnsafeStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnsafeStatement()
Public Sub New
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Properties

UnsafeStatement Properties

The UnsafeStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement.ChildStatement Property

UnsafeStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement.Id Property

UnsafeStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement Methods

UnsafeStatement Methods

The UnsafeStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnsafeStatement.GetChildrenEnumerator Method

UnsafeStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnsafeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Class

UnstructuredErrorHandlerStatement Class
Represents an unstructured error handler statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorHandlerStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnstructuredErrorHandlerStatement : Statement
Public Class UnstructuredErrorHandlerStatement
    Inherits Statement

The UnstructuredErrorHandlerStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnstructuredErrorHandlerStatement | Initializes a new instance of the UnstructuredErrorHandlerStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Constructor

UnstructuredErrorHandlerStatement Constructor
Initializes a new instance of the UnstructuredErrorHandlerStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnstructuredErrorHandlerStatement()
Public Sub New
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Properties

UnstructuredErrorHandlerStatement Properties

The UnstructuredErrorHandlerStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement.Id Property

UnstructuredErrorHandlerStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement.Label Property

UnstructuredErrorHandlerStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement Methods

UnstructuredErrorHandlerStatement Methods

The UnstructuredErrorHandlerStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorHandlerStatement.GetChildrenEnumerator Method

UnstructuredErrorHandlerStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnstructuredErrorHandlerStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Class

UnstructuredErrorResumeStatement Class
Represents an unstructured error resume statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorResumeStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnstructuredErrorResumeStatement : Statement
Public Class UnstructuredErrorResumeStatement
    Inherits Statement

The UnstructuredErrorResumeStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnstructuredErrorResumeStatement | Initializes a new instance of the UnstructuredErrorResumeStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Constructor

UnstructuredErrorResumeStatement Constructor
Initializes a new instance of the UnstructuredErrorResumeStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnstructuredErrorResumeStatement()
Public Sub New
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Properties

UnstructuredErrorResumeStatement Properties

The UnstructuredErrorResumeStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement.Id Property

UnstructuredErrorResumeStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement.Label Property

UnstructuredErrorResumeStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Label { get; set; }
Public Property Label As Expression
    Get
    Set

Property Value

Type: Expression
The label.
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement Methods

UnstructuredErrorResumeStatement Methods

The UnstructuredErrorResumeStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorResumeStatement.GetChildrenEnumerator Method

UnstructuredErrorResumeStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnstructuredErrorResumeStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Class

UnstructuredErrorThrowStatement Class
Represents an unstructured error throw statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUnstructuredErrorThrowStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnstructuredErrorThrowStatement : Statement
Public Class UnstructuredErrorThrowStatement
    Inherits Statement

The UnstructuredErrorThrowStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UnstructuredErrorThrowStatement | Initializes a new instance of the UnstructuredErrorThrowStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Constructor

UnstructuredErrorThrowStatement Constructor
Initializes a new instance of the UnstructuredErrorThrowStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnstructuredErrorThrowStatement()
Public Sub New
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Properties

UnstructuredErrorThrowStatement Properties

The UnstructuredErrorThrowStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement.Expression Property

UnstructuredErrorThrowStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement.Id Property

UnstructuredErrorThrowStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement Methods

UnstructuredErrorThrowStatement Methods

The UnstructuredErrorThrowStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UnstructuredErrorThrowStatement.GetChildrenEnumerator Method

UnstructuredErrorThrowStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnstructuredErrorThrowStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Class

UsingDirective Class
Represents an using directive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirective

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UsingDirective : AstNodeBase
Public Class UsingDirective
    Inherits AstNodeBase

The UsingDirective type exposes the following members.

Constructors
 | Name | Description
Public method | UsingDirective | Initializes a new instance of the UsingDirective class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the type or namespace name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | XmlNamespace | Gets or sets the xml namespace.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Constructor

UsingDirective Constructor
Initializes a new instance of the UsingDirective class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UsingDirective()
Public Sub New
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Properties

UsingDirective Properties

The UsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the type or namespace name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | XmlNamespace | Gets or sets the xml namespace.
Top
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Alias Property

UsingDirectiveAlias Property
Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Id Property

UsingDirectiveId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.Name Property

UsingDirectiveName Property
Gets or sets the type or namespace name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Name { get; set; }
Public Property Name As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type or namespace name.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.XmlNamespace Property

UsingDirectiveXmlNamespace Property
Gets or sets the xml namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string XmlNamespace { get; set; }
Public Property XmlNamespace As String
    Get
    Set

Property Value

Type: String
The xml namespace.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective Methods

UsingDirective Methods

The UsingDirective type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirective.GetChildrenEnumerator Method

UsingDirectiveGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UsingDirective Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Class

UsingDirectiveSection Class
Represents an using directive section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirectiveSection

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UsingDirectiveSection : AstNodeBase
Public Class UsingDirectiveSection
    Inherits AstNodeBase

The UsingDirectiveSection type exposes the following members.

Constructors
 | Name | Description
Public method | UsingDirectiveSection | Initializes a new instance of the UsingDirectiveSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Constructor

UsingDirectiveSection Constructor
Initializes a new instance of the UsingDirectiveSection class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UsingDirectiveSection()
Public Sub New
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Properties

UsingDirectiveSection Properties

The UsingDirectiveSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Directives | Gets the directives.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDirectives | Returns whether the Directives collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.Directives Property

UsingDirectiveSectionDirectives Property
Gets the directives.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<UsingDirective> Directives { get; }
Public ReadOnly Property Directives As IList(Of UsingDirective)
    Get

Property Value

Type: IList UsingDirective
The directives.
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.HasDirectives Property

UsingDirectiveSectionHasDirectives Property
Returns whether the Directives collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDirectives { get; }
Public ReadOnly Property HasDirectives As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.Id Property

UsingDirectiveSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection Methods

UsingDirectiveSection Methods

The UsingDirectiveSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingDirectiveSection.GetChildrenEnumerator Method

UsingDirectiveSectionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UsingDirectiveSection Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Class

UsingStatement Class
Represents an using statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UsingStatement : Statement
Public Class UsingStatement
    Inherits Statement

The UsingStatement type exposes the following members.

Constructors
 | Name | Description
Public method | UsingStatement | Initializes a new instance of the UsingStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResourceAcquisition | Gets or sets the resource acquisition.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Constructor

UsingStatement Constructor
Initializes a new instance of the UsingStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UsingStatement()
Public Sub New
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Properties

UsingStatement Properties

The UsingStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResourceAcquisition | Gets or sets the resource acquisition.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.ChildStatement Property

UsingStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.Id Property

UsingStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.ResourceAcquisition Property

UsingStatementResourceAcquisition Property
Gets or sets the resource acquisition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ResourceAcquisition { get; set; }
Public Property ResourceAcquisition As Expression
    Get
    Set

Property Value

Type: Expression
The resource acquisition.
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement Methods

UsingStatement Methods

The UsingStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


UsingStatement.GetChildrenEnumerator Method

UsingStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UsingStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Class

VariableDeclarationExpression Class
Represents a variable declaration expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarationExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VariableDeclarationExpression : Expression
Public Class VariableDeclarationExpression
    Inherits Expression

The VariableDeclarationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclarationExpression | Initializes a new instance of the VariableDeclarationExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Constructor

VariableDeclarationExpression Constructor
Initializes a new instance of the VariableDeclarationExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclarationExpression()
Public Sub New
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Properties

VariableDeclarationExpression Properties

The VariableDeclarationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarators | Gets the declarators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarators | Returns whether the Declarators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.Declarators Property

VariableDeclarationExpressionDeclarators Property
Gets the declarators.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclarator> Declarators { get; }
Public ReadOnly Property Declarators As IList(Of VariableDeclarator)
    Get

Property Value

Type: IList VariableDeclarator
The declarators.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.HasDeclarators Property

VariableDeclarationExpressionHasDeclarators Property
Returns whether the Declarators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarators { get; }
Public ReadOnly Property HasDeclarators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.Id Property

VariableDeclarationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression Methods

VariableDeclarationExpression Methods

The VariableDeclarationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarationExpression.GetChildrenEnumerator Method

VariableDeclarationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Class

VariableDeclarator Class
Represents a variable declarator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VariableDeclarator : AstNodeBase
Public Class VariableDeclarator
    Inherits AstNodeBase

The VariableDeclarator type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclarator | Initializes a new instance of the VariableDeclarator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Constructor

VariableDeclarator Constructor
Initializes a new instance of the VariableDeclarator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclarator()
Public Sub New
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Properties

VariableDeclarator Properties

The VariableDeclarator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Id Property

VariableDeclaratorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Initializer Property

VariableDeclaratorInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Kind Property

VariableDeclaratorKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclaratorKind Kind { get; set; }
Public Property Kind As VariableDeclaratorKind
    Get
    Set

Property Value

Type: VariableDeclaratorKind
The kind.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Name Property

VariableDeclaratorName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.Type Property

VariableDeclaratorType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName Type { get; set; }
Public Property Type As QualifiedName
    Get
    Set

Property Value

Type: QualifiedName
The type.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator Methods

VariableDeclarator Methods

The VariableDeclarator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


VariableDeclarator.GetChildrenEnumerator Method

VariableDeclaratorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclarator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Class

WhereQueryOperator Class
Represents a where query operator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhereQueryOperator

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WhereQueryOperator : QueryOperator
Public Class WhereQueryOperator
    Inherits QueryOperator

The WhereQueryOperator type exposes the following members.

Constructors
 | Name | Description
Public method | WhereQueryOperator | Initializes a new instance of the WhereQueryOperator class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression..
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Constructor

WhereQueryOperator Constructor
Initializes a new instance of the WhereQueryOperator class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WhereQueryOperator()
Public Sub New
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Properties

WhereQueryOperator Properties

The WhereQueryOperator type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression..
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides QueryOperatorId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator.ConditionExpression Property

WhereQueryOperatorConditionExpression Property
Gets or sets the condition expression..

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression..
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator.Id Property

WhereQueryOperatorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator Methods

WhereQueryOperator Methods

The WhereQueryOperator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhereQueryOperator.GetChildrenEnumerator Method

WhereQueryOperatorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhereQueryOperator Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Class

WhileStatement Class
Represents a while statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWhileStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WhileStatement : Statement
Public Class WhileStatement
    Inherits Statement

The WhileStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WhileStatement | Initializes a new instance of the WhileStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Constructor

WhileStatement Constructor
Initializes a new instance of the WhileStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WhileStatement()
Public Sub New
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Properties

WhileStatement Properties

The WhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.ChildStatement Property

WhileStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.ConditionExpression Property

WhileStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.Id Property

WhileStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement Methods

WhileStatement Methods

The WhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WhileStatement.GetChildrenEnumerator Method

WhileStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Class

WithStatement Class
Represents a with statement (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WithStatement : Statement
Public Class WithStatement
    Inherits Statement

The WithStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WithStatement | Initializes a new instance of the WithStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Constructor

WithStatement Constructor
Initializes a new instance of the WithStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WithStatement()
Public Sub New
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Properties

WithStatement Properties

The WithStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.ChildStatement Property

WithStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.Expression Property

WithStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.Id Property

WithStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement Methods

WithStatement Methods

The WithStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithStatement.GetChildrenEnumerator Method

WithStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Class

WithTargetExpression Class
Represents a with target expression (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationWithTargetExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WithTargetExpression : Expression
Public Class WithTargetExpression
    Inherits Expression

The WithTargetExpression type exposes the following members.

Constructors
 | Name | Description
Public method | WithTargetExpression | Initializes a new instance of the WithTargetExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Constructor

WithTargetExpression Constructor
Initializes a new instance of the WithTargetExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WithTargetExpression()
Public Sub New
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Properties

WithTargetExpression Properties

The WithTargetExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression.Id Property

WithTargetExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


WithTargetExpression Methods

WithTargetExpression Methods

The WithTargetExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithTargetExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Class

XmlNamespaceExpression Class
Represents a xml namespace expression (VB only).
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationXmlNamespaceExpression

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlNamespaceExpression : Expression
Public Class XmlNamespaceExpression
    Inherits Expression

The XmlNamespaceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | XmlNamespaceExpression | Initializes a new instance of the XmlNamespaceExpression class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Constructor

XmlNamespaceExpression Constructor
Initializes a new instance of the XmlNamespaceExpression class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlNamespaceExpression()
Public Sub New
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Properties

XmlNamespaceExpression Properties

The XmlNamespaceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression.Alias Property

XmlNamespaceExpressionAlias Property
Gets or sets the alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression.Id Property

XmlNamespaceExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


XmlNamespaceExpression Methods

XmlNamespaceExpression Methods

The XmlNamespaceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

XmlNamespaceExpression Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Class

YieldStatement Class
Represents a yield statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationYieldStatement

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class YieldStatement : Statement
Public Class YieldStatement
    Inherits Statement

The YieldStatement type exposes the following members.

Constructors
 | Name | Description
Public method | YieldStatement | Initializes a new instance of the YieldStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v12.2.572.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Constructor

YieldStatement Constructor
Initializes a new instance of the YieldStatement class

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public YieldStatement()
Public Sub New
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Properties

YieldStatement Properties

The YieldStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement.Expression Property

YieldStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement.Id Property

YieldStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement Methods

YieldStatement Methods

The YieldStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


YieldStatement.GetChildrenEnumerator Method

YieldStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.DotNet.Ast.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

YieldStatement Class
ActiproSoftware.Text.Languages.DotNet.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet.Implementation Namespace

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace
Contains the core classes related to implementing a .NET syntax language.
Classes
 | Class | Description
Public class | DocumentationCommentAutoCompleterBase | Provides an abstract base class for performing auto-complete of .NET language documentation comments when appropriate.
Public class | DotNetClassificationTypeProvider | Represents a provider of IClassificationType objects for a .NET language.
Public class | DotNetCodeBlockFinderBase | Provides an abstract base class for a .NET language code block finder service.
Public class | DotNetCompletionProviderBase | Provides an abstract base class for providing IntelliPrompt completion data for .NET languages.
Public class | DotNetContextFactoryBase | Provides an abstract base class that can create IDotNetContext objects for a TextSnapshotOffset.
Public class | DotNetGrammarBase | Provides an abstract base class for .NET grammars.
Public class | DotNetGrammarOptionsBase | Provides an abstract base class that contains options for a .NET grammar.
Public class | DotNetNavigableSymbolProviderBase | Provides a base class for the navigable symbol provider of a .NET language.
Public class | DotNetParameterInfoProviderBase | Provides an abstract base class for providing IntelliPrompt parameter info popups for .NET languages.
Public class | DotNetParseData | Stores the results of a .NET language parsing operation.
Public class | DotNetParserBase | Provides the abstract base class of a .NET language parser.
Public class | DotNetSyntaxLanguageBase | Provides an abstract base class for a .NET syntax language definition.
Public class | DotNetTextFormatterBase | Provides an abstract base class for text formatting a .NET language.


DocumentationCommentAutoCompleterBase Class

DocumentationCommentAutoCompleterBase Class
Provides an abstract base class for performing auto-complete of .NET language documentation comments when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDocumentationCommentAutoCompleterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpDocumentationCommentAutoCompleter
ActiproSoftware.Text.Languages.VB.ImplementationVBDocumentationCommentAutoCompleter

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DocumentationCommentAutoCompleterBase : IDocumentationCommentAutoCompleter
Public MustInherit Class DocumentationCommentAutoCompleterBase
    Implements IDocumentationCommentAutoCompleter

The DocumentationCommentAutoCompleterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DocumentationCommentAutoCompleterBase | Initializes a new instance of the DocumentationCommentAutoCompleterBase class
Top
Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase Constructor

DocumentationCommentAutoCompleterBase Constructor
Initializes a new instance of the DocumentationCommentAutoCompleterBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DocumentationCommentAutoCompleterBase()
Protected Sub New
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase Properties

DocumentationCommentAutoCompleterBase Properties

The DocumentationCommentAutoCompleterBase type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled.
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.
Top
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.IsEndTagCompletionEnabled Property

DocumentationCommentAutoCompleterBaseIsEndTagCompletionEnabled Property
Gets or sets whether documentation comment end tag completion is enabled.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEndTagCompletionEnabled { get; set; }
Public Property IsEndTagCompletionEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documentation comment end tag completion is enabled; otherwise, false.

Implements

IDocumentationCommentAutoCompleterIsEndTagCompletionEnabled
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.IsNewLineGenerationEnabled Property

DocumentationCommentAutoCompleterBaseIsNewLineGenerationEnabled Property
Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNewLineGenerationEnabled { get; set; }
Public Property IsNewLineGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment; otherwise, false.

Implements

IDocumentationCommentAutoCompleterIsNewLineGenerationEnabled
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.IsStubGenerationEnabled Property

DocumentationCommentAutoCompleterBaseIsStubGenerationEnabled Property
Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsStubGenerationEnabled { get; set; }
Public Property IsStubGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stub documentation comment auto-generation is enabled when starting to type new documentation comments; otherwise, false.

Implements

IDocumentationCommentAutoCompleterIsStubGenerationEnabled
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase Methods

DocumentationCommentAutoCompleterBase Methods

The DocumentationCommentAutoCompleterBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.InsertStubDocumentationComment Method

DocumentationCommentAutoCompleterBaseInsertStubDocumentationComment Method
Attempts to insert a stub documentation comment at the caret's location.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void InsertStubDocumentationComment(
    IEditorView view,
    TextSnapshotOffset targetSnapshotOffset,
    string delimiter
)
Protected Overridable Sub InsertStubDocumentationComment (
    view As IEditorView,
    targetSnapshotOffset As TextSnapshotOffset,
    delimiter As String
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.
targetSnapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
A TextSnapshotOffset indicating the offset at which the target type/member is located.
delimiter
Type: SystemString
The documentation comment delimiter.
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DocumentationCommentAutoCompleterBase.TranslateToParseDataSnapshot Method

DocumentationCommentAutoCompleterBaseTranslateToParseDataSnapshot Method
Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    IDotNetParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As IDotNetParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

DocumentationCommentAutoCompleterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Class

DotNetClassificationTypeProvider Class
Represents a provider of IClassificationType objects for a .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DotNetClassificationTypeProvider : IDotNetClassificationTypeProvider
Public Class DotNetClassificationTypeProvider
    Implements IDotNetClassificationTypeProvider

The DotNetClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetClassificationTypeProvider | Initializes a new instance of the DotNetClassificationTypeProvider class.
Public method | DotNetClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the DotNetClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.540.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Constructor

DotNetClassificationTypeProvider Constructor
Overload List
 | Name | Description
Public method | DotNetClassificationTypeProvider | Initializes a new instance of the DotNetClassificationTypeProvider class.
Public method | DotNetClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the DotNetClassificationTypeProvider class.
Top
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Constructor

DotNetClassificationTypeProvider Constructor
Initializes a new instance of the DotNetClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DotNetClassificationTypeProvider()
Public Sub New
See Also

Reference

DotNetClassificationTypeProvider Class
DotNetClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

DotNetClassificationTypeProvider Constructor (IHighlightingStyleRegistry)
Initializes a new instance of the DotNetClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DotNetClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

DotNetClassificationTypeProvider Class
DotNetClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Properties

DotNetClassificationTypeProvider Properties

The DotNetClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | CSharpVerbatimString | Gets the CSharpVerbatimString classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PreprocessorKeyword | Gets the PreprocessorKeyword classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Public property | VBXmlLiteral | Gets the VBXmlLiteral classification type.
Public property | XmlDocumentationComment | Gets the XmlDocumentationComment classification type.
Public property | XmlDocumentationTag | Gets the XmlDocumentationTag classification type.
Top
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Comment Property

DotNetClassificationTypeProviderComment Property
Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Comment { get; }
Public ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.

Implements

IDotNetClassificationTypeProviderComment
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.CSharpVerbatimString Property

DotNetClassificationTypeProviderCSharpVerbatimString Property
Gets the CSharpVerbatimString classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CSharpVerbatimString { get; }
Public ReadOnly Property CSharpVerbatimString As IClassificationType
    Get

Property Value

Type: IClassificationType
The CSharpVerbatimString classification type.

Implements

IDotNetClassificationTypeProviderCSharpVerbatimString
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Identifier Property

DotNetClassificationTypeProviderIdentifier Property
Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Identifier { get; }
Public ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.

Implements

IDotNetClassificationTypeProviderIdentifier
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Keyword Property

DotNetClassificationTypeProviderKeyword Property
Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Keyword { get; }
Public ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.

Implements

IDotNetClassificationTypeProviderKeyword
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Number Property

DotNetClassificationTypeProviderNumber Property
Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Number { get; }
Public ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.

Implements

IDotNetClassificationTypeProviderNumber
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Operator Property

DotNetClassificationTypeProviderOperator Property
Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Operator { get; }
Public ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.

Implements

IDotNetClassificationTypeProviderOperator
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.PreprocessorKeyword Property

DotNetClassificationTypeProviderPreprocessorKeyword Property
Gets the PreprocessorKeyword classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType PreprocessorKeyword { get; }
Public ReadOnly Property PreprocessorKeyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The PreprocessorKeyword classification type.

Implements

IDotNetClassificationTypeProviderPreprocessorKeyword
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.Registry Property

DotNetClassificationTypeProviderRegistry Property
Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.String Property

DotNetClassificationTypeProviderString Property
Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType String { get; }
Public ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.

Implements

IDotNetClassificationTypeProviderString
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.VBXmlLiteral Property

DotNetClassificationTypeProviderVBXmlLiteral Property
Gets the VBXmlLiteral classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType VBXmlLiteral { get; }
Public ReadOnly Property VBXmlLiteral As IClassificationType
    Get

Property Value

Type: IClassificationType
The VBXmlLiteral classification type.

Implements

IDotNetClassificationTypeProviderVBXmlLiteral
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.XmlDocumentationComment Property

DotNetClassificationTypeProviderXmlDocumentationComment Property
Gets the XmlDocumentationComment classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlDocumentationComment { get; }
Public ReadOnly Property XmlDocumentationComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationComment classification type.

Implements

IDotNetClassificationTypeProviderXmlDocumentationComment
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.XmlDocumentationTag Property

DotNetClassificationTypeProviderXmlDocumentationTag Property
Gets the XmlDocumentationTag classification type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlDocumentationTag { get; }
Public ReadOnly Property XmlDocumentationTag As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDocumentationTag classification type.

Implements

IDotNetClassificationTypeProviderXmlDocumentationTag
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider Methods

DotNetClassificationTypeProvider Methods

The DotNetClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetClassificationTypeProvider.RegisterAll Method

DotNetClassificationTypeProviderRegisterAll Method
Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

DotNetClassificationTypeProvider Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Class

DotNetCodeBlockFinderBase Class
Provides an abstract base class for a .NET language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCodeBlockFinder
ActiproSoftware.Text.Languages.VB.ImplementationVBCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetCodeBlockFinderBase : LLParseDataCodeBlockFinder
Public MustInherit Class DotNetCodeBlockFinderBase
    Inherits LLParseDataCodeBlockFinder

The DotNetCodeBlockFinderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetCodeBlockFinderBase | Initializes a new instance of the DotNetCodeBlockFinderBase class.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Constructor

DotNetCodeBlockFinderBase Constructor
Initializes a new instance of the DotNetCodeBlockFinderBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetCodeBlockFinderBase()
Protected Sub New
See Also

Reference

DotNetCodeBlockFinderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Properties

DotNetCodeBlockFinderBase Properties

The DotNetCodeBlockFinderBase type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

DotNetCodeBlockFinderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCodeBlockFinderBase Methods

DotNetCodeBlockFinderBase Methods

The DotNetCodeBlockFinderBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

DotNetCodeBlockFinderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Class

DotNetCompletionProviderBase Class
Provides an abstract base class for providing IntelliPrompt completion data for .NET languages.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCompletionProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpCompletionProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBCompletionProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetCompletionProviderBase : CompletionProviderBase
Public MustInherit Class DotNetCompletionProviderBase
    Inherits CompletionProviderBase

The DotNetCompletionProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetCompletionProviderBase | Initializes a new instance of the DotNetCompletionProviderBase class.
Top
Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Inherited from CompletionProviderBase.)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Constructor

DotNetCompletionProviderBase Constructor
Initializes a new instance of the DotNetCompletionProviderBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetCompletionProviderBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string-based key that identifies the provider.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Properties

DotNetCompletionProviderBase Properties

The DotNetCompletionProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.CanShowOnTypedWordStart Property

DotNetCompletionProviderBaseCanShowOnTypedWordStart Property
Gets or sets whether a completion list can auto-show when typing a new word.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanShowOnTypedWordStart { get; set; }
Public Property CanShowOnTypedWordStart As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a completion list can auto-show when typing a new word; otherwise, false.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase Methods

DotNetCompletionProviderBase Methods

The DotNetCompletionProviderBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Inherited from CompletionProviderBase.)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.CreateContext Method

DotNetCompletionProviderBaseCreateContext Method
Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IDotNetContext CreateContext(
    IEditorView view
)
Protected MustOverride Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.OnSessionOpening Method

DotNetCompletionProviderBaseOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetCompletionProviderBase.ShouldShowForTypedWordStart Method

DotNetCompletionProviderBaseShouldShowForTypedWordStart Method
Returns whether the specified IEditorView supports automatic completion list display at its current caret location.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract bool ShouldShowForTypedWordStart(
    IEditorView view
)
Public MustOverride Function ShouldShowForTypedWordStart (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if automatic completion list display is supported; otherwise, false.
See Also

Reference

DotNetCompletionProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase Class

DotNetContextFactoryBase Class
Provides an abstract base class that can create IDotNetContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetContextFactoryBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpContextFactory
ActiproSoftware.Text.Languages.VB.ImplementationVBContextFactory

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetContextFactoryBase
Public MustInherit Class DotNetContextFactoryBase

The DotNetContextFactoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetContextFactoryBase | Initializes a new instance of the DotNetContextFactoryBase class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase Constructor

DotNetContextFactoryBase Constructor
Initializes a new instance of the DotNetContextFactoryBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetContextFactoryBase()
Protected Sub New
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase Methods

DotNetContextFactoryBase Methods

The DotNetContextFactoryBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.CreateContext Method

DotNetContextFactoryBaseCreateContext Method
Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset.
Top
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.CreateContext Method (TextSnapshotOffset)

DotNetContextFactoryBaseCreateContext Method (TextSnapshotOffset)
Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

DotNetContextFactoryBase Class
CreateContext Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.CreateContext Method (TextSnapshotOffset, DotNetContextKind)

DotNetContextFactoryBaseCreateContext Method (TextSnapshotOffset, DotNetContextKind)
Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    DotNetContextKind kind
)
Public MustOverride Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As DotNetContextKind
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.DotNetDotNetContextKind
A DotNetContextKind indicating the kind of context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

DotNetContextFactoryBase Class
CreateContext Overload
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.GetContainingAstNode Method

DotNetContextFactoryBaseGetContainingAstNode Method
Returns the IAstNode that contains the specified offset.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IAstNode GetContainingAstNode(
    IDotNetParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Function GetContainingAstNode (
    parseData As IDotNetParseData,
    snapshotOffset As TextSnapshotOffset
) As IAstNode

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: IAstNode
The IAstNode that contains the specified offset.
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.IsQualifiedName Method

DotNetContextFactoryBaseIsQualifiedName Method
Returns whether the specified Expression can equate to a qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected bool IsQualifiedName(
    Expression expression
)
Protected Function IsQualifiedName (
    expression As Expression
) As Boolean

Parameters

expression
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
The Expression to examine.

Return Value

Type: Boolean
true if the specified Expression can equate to a qualified name; otherwise, false.
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetContextFactoryBase.TranslateToParseDataSnapshot Method

DotNetContextFactoryBaseTranslateToParseDataSnapshot Method
Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    IDotNetParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As IDotNetParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

DotNetContextFactoryBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Class

DotNetGrammarBase Class
Provides an abstract base class for .NET grammars.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammar
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammar

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetGrammarBase : Grammar
Public MustInherit Class DotNetGrammarBase
    Inherits Grammar

The DotNetGrammarBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetGrammarBase | Initializes a new instance of the DotNetGrammarBase class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Constructor

DotNetGrammarBase Constructor
Initializes a new instance of the DotNetGrammarBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetGrammarBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the grammar, generally the related language name.
See Also

Reference

DotNetGrammarBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Properties

DotNetGrammarBase Properties

The DotNetGrammarBase type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

DotNetGrammarBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarBase Methods

DotNetGrammarBase Methods

The DotNetGrammarBase type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

DotNetGrammarBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Class

DotNetGrammarOptionsBase Class
Provides an abstract base class that contains options for a .NET grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarOptionsBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpGrammarOptions
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammarOptions

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetGrammarOptionsBase
Public MustInherit Class DotNetGrammarOptionsBase

The DotNetGrammarOptionsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetGrammarOptionsBase | Initializes a new instance of the DotNetGrammarOptionsBase class.
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Constructor

DotNetGrammarOptionsBase Constructor
Initializes a new instance of the DotNetGrammarOptionsBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetGrammarOptionsBase()
Protected Sub New
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Properties

DotNetGrammarOptionsBase Properties

The DotNetGrammarOptionsBase type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase.RootNonTerminal Property

DotNetGrammarOptionsBaseRootNonTerminal Property
Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DotNetGrammarRootNonTerminal RootNonTerminal { get; set; }
Public Property RootNonTerminal As DotNetGrammarRootNonTerminal
    Get
    Set

Property Value

Type: DotNetGrammarRootNonTerminal
A DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetGrammarOptionsBase Methods

DotNetGrammarOptionsBase Methods

The DotNetGrammarOptionsBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetGrammarOptionsBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase Class

DotNetNavigableSymbolProviderBase Class
Provides a base class for the navigable symbol provider of a .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetNavigableSymbolProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpNavigableSymbolProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetNavigableSymbolProviderBase : INavigableSymbolProvider
Public MustInherit Class DotNetNavigableSymbolProviderBase
    Implements INavigableSymbolProvider

The DotNetNavigableSymbolProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetNavigableSymbolProviderBase | Initializes a new instance of the DotNetNavigableSymbolProviderBase class
Top
Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration.
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase Constructor

DotNetNavigableSymbolProviderBase Constructor
Initializes a new instance of the DotNetNavigableSymbolProviderBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetNavigableSymbolProviderBase()
Protected Sub New
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase Methods

DotNetNavigableSymbolProviderBase Methods

The DotNetNavigableSymbolProviderBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration.
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase.CreateTypeMemberSymbol Method

DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol Method
Creates an INavigableSymbol for a TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract INavigableSymbol CreateTypeMemberSymbol(
    TypeMemberDeclaration memberDecl,
    ITextSnapshot snapshot
)
Protected MustOverride Function CreateTypeMemberSymbol (
    memberDecl As TypeMemberDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

memberDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
The TypeMemberDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase.CreateTypeSymbol Method

DotNetNavigableSymbolProviderBaseCreateTypeSymbol Method
Creates an INavigableSymbol for a TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract INavigableSymbol CreateTypeSymbol(
    TypeDeclaration typeDecl,
    ITextSnapshot snapshot
)
Protected MustOverride Function CreateTypeSymbol (
    typeDecl As TypeDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

typeDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
The TypeDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetNavigableSymbolProviderBase.GetSymbols Method

DotNetNavigableSymbolProviderBaseGetSymbols Method
Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Public Overridable Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.

Implements

INavigableSymbolProviderGetSymbols(INavigableRequestContext, TextSnapshotOffset, INavigableSymbol)
See Also

Reference

DotNetNavigableSymbolProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Class

DotNetParameterInfoProviderBase Class
Provides an abstract base class for providing IntelliPrompt parameter info popups for .NET languages.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParameterInfoProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParameterInfoProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetParameterInfoProviderBase : ParameterInfoProviderBase,
    IEditorViewSelectionChangeEventSink
Public MustInherit Class DotNetParameterInfoProviderBase
    Inherits ParameterInfoProviderBase
    Implements IEditorViewSelectionChangeEventSink

The DotNetParameterInfoProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetParameterInfoProviderBase | Initializes a new instance of the DotNetParameterInfoProviderBase class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Inherited from ParameterInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Constructor

DotNetParameterInfoProviderBase Constructor
Initializes a new instance of the DotNetParameterInfoProviderBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetParameterInfoProviderBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string-based key that identifies the provider.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Properties

DotNetParameterInfoProviderBase Properties

The DotNetParameterInfoProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase Methods

DotNetParameterInfoProviderBase Methods

The DotNetParameterInfoProviderBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Inherited from ParameterInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext.
Top
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.CreateContext Method

DotNetParameterInfoProviderBaseCreateContext Method
Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IDotNetContext CreateContext(
    IEditorView view
)
Protected MustOverride Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.OnSessionOpening Method

DotNetParameterInfoProviderBaseOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IParameterInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IParameterInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.OnViewSelectionChanged Method

DotNetParameterInfoProviderBaseOnViewSelectionChanged Method
Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParameterInfoProviderBase.UpdateCurrentParameter Method

DotNetParameterInfoProviderBaseUpdateCurrentParameter Method
Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool UpdateCurrentParameter(
    IParameterInfoSession session,
    IDotNetContext context
)
Protected Overridable Function UpdateCurrentParameter (
    session As IParameterInfoSession,
    context As IDotNetContext
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession to update.
context
Type: ActiproSoftware.Text.Languages.DotNetIDotNetContext
The IDotNetContext to examine.

Return Value

Type: Boolean
true if an update was made; otherwise, false.
See Also

Reference

DotNetParameterInfoProviderBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Class

DotNetParseData Class
Stores the results of a .NET language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParseData

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DotNetParseData : LLParseData,
    IDotNetParseData, ILLParseData, IParseData, IParseErrorProvider
Public Class DotNetParseData
    Inherits LLParseData
    Implements IDotNetParseData, ILLParseData, IParseData, IParseErrorProvider

The DotNetParseData type exposes the following members.

Constructors
 | Name | Description
Public method | DotNetParseData | Initializes a new instance of the DotNetParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Constructor

DotNetParseData Constructor
Initializes a new instance of the DotNetParseData class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DotNetParseData()
Public Sub New
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Properties

DotNetParseData Properties

The DotNetParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | PreprocessorDirectives | Gets the collection of preprocessor directives.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData.PreprocessorDirectives Property

DotNetParseDataPreprocessorDirectives Property
Gets the collection of preprocessor directives.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<PreprocessorDirective> PreprocessorDirectives { get; }
Public ReadOnly Property PreprocessorDirectives As IList(Of PreprocessorDirective)
    Get

Property Value

Type: IList PreprocessorDirective
The collection of preprocessor directives.

Implements

IDotNetParseDataPreprocessorDirectives
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParseData Methods

DotNetParseData Methods

The DotNetParseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetParseData Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Class

DotNetParserBase Class
Provides the abstract base class of a .NET language parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpParser
ActiproSoftware.Text.Languages.VB.ImplementationVBParser

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetParserBase : LLParserBase
Public MustInherit Class DotNetParserBase
    Inherits LLParserBase

The DotNetParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetParserBase | Initializes a new instance of the DotNetParserBase class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from LLParserBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Constructor

DotNetParserBase Constructor
Initializes a new instance of the DotNetParserBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetParserBase(
    Grammar grammar
)
Protected Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Properties

DotNetParserBase Properties

The DotNetParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase Methods

DotNetParserBase Methods

The DotNetParserBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from LLParserBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetParserBase.CreateParseData Method

DotNetParserBaseCreateParseData Method
Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

DotNetParserBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Class

DotNetSyntaxLanguageBase Class
Provides an abstract base class for a .NET syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpSyntaxLanguage
ActiproSoftware.Text.Languages.VB.ImplementationVBSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetSyntaxLanguageBase : SyntaxLanguage,
    ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink
Public MustInherit Class DotNetSyntaxLanguageBase
    Inherits SyntaxLanguage
    Implements ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink

The DotNetSyntaxLanguageBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetSyntaxLanguageBase | Initializes a new instance of the DotNetSyntaxLanguageBase class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Constructor

DotNetSyntaxLanguageBase Constructor
Initializes a new instance of the DotNetSyntaxLanguageBase class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetSyntaxLanguageBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
The language key.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Properties

DotNetSyntaxLanguageBase Properties

The DotNetSyntaxLanguageBase type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Methods

DotNetSyntaxLanguageBase Methods

The DotNetSyntaxLanguageBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentAttached Method

DotNetSyntaxLanguageBaseOnDocumentAttached Method
Occurs when the specified ICodeDocument is attached to the language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentAttached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentAttached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentDetached Method

DotNetSyntaxLanguageBaseOnDocumentDetached Method
Occurs when the specified ICodeDocument is detached from the language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentDetached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentDetached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentFileNameChanged Method

DotNetSyntaxLanguageBaseOnDocumentFileNameChanged Method
Occurs after the FileName property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentFileNameChanged(
    ICodeDocument document,
    StringPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentFileNameChanged (
    document As ICodeDocument,
    e As StringPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose FileName property is changed.
e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
The StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase.OnDocumentParseDataChanged Method

DotNetSyntaxLanguageBaseOnDocumentParseDataChanged Method
Occurs after the ParseData property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentParseDataChanged(
    ICodeDocument document,
    ParseDataPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentParseDataChanged (
    document As ICodeDocument,
    e As ParseDataPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose ParseData property is changed.
e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
The ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetSyntaxLanguageBase Events

DotNetSyntaxLanguageBase Events

The DotNetSyntaxLanguageBase type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

DotNetSyntaxLanguageBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase Class

DotNetTextFormatterBase Class
Provides an abstract base class for text formatting a .NET language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetTextFormatterBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTextFormatter
ActiproSoftware.Text.Languages.VB.ImplementationVBTextFormatter

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DotNetTextFormatterBase : ITextFormatter
Public MustInherit Class DotNetTextFormatterBase
    Implements ITextFormatter

The DotNetTextFormatterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DotNetTextFormatterBase | Initializes a new instance of the DotNetTextFormatterBase class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase Constructor

DotNetTextFormatterBase Constructor
Initializes a new instance of the DotNetTextFormatterBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DotNetTextFormatterBase()
Protected Sub New
See Also

Reference

DotNetTextFormatterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase Methods

DotNetTextFormatterBase Methods

The DotNetTextFormatterBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DotNetTextFormatterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


DotNetTextFormatterBase.Format Method

DotNetTextFormatterBaseFormat Method
Formats the specified snapshot range.

Namespace: ActiproSoftware.Text.Languages.DotNet.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Format(
    TextSnapshotRange snapshotRange
)
Public MustOverride Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The snapshot range.

Implements

ITextFormatterFormat(TextSnapshotRange)
See Also

Reference

DotNetTextFormatterBase Class
ActiproSoftware.Text.Languages.DotNet.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet.Reflection Namespace

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace
Contains the types related to reflection for a .NET syntax language.
Classes
 | Class | Description
Public class | AmbientAssemblyRepositoryProvider | Implements a class that can be used to provide a static IAssemblyRepository that is used for managing and caching assemblies by default.
Public class | TypeAccess | Specifies the type of access visibility for an ITypeDefinition.
Public class | TypeDefinitionKind | Specifies the kind of ITypeDefinition.
Public class | TypeMemberAccess | Specifies the type of access visibility for an ITypeMemberDefinition.
Public class | TypeMemberDefinitionKind | Specifies the kind of ITypeMemberDefinition.
Interfaces
 | Interface | Description
Public interface | IAliasedUsingDirective | Provides the base requirements of an using directive with an alias.
Public interface | IAssembly | Provides the base requirements of an assembly.
Public interface | IAssemblyDocumentation | Provides the base requirements of an object that can access documentation for the types and members defined in an assembly.
Public interface | IAssemblyName | Provides the base requirements of an assembly name.
Public interface | IAssemblyReference | Provides the base requirements of an assembly reference.
Public interface | IAssemblyRepository | Provides the base requirements for a class that manages IAssembly instances and caching of data as appropriate.
Public interface | IBinaryAssembly | Provides the base requirements of a binary assembly.
Public interface | IBinaryAssemblyMetadata | Provides the base requirements for storing metadata of an IBinaryAssembly, generally used with serialization.
Public interface | IBinaryAssemblyReference | Provides the base requirements of an assembly reference within an IBinaryAssembly.
Public interface | IBinaryAssemblyReferenceCollection | Provides the base requirements for a collection of IBinaryAssemblyReference objects.
Public interface | IDocumentationProvider | Provides the base requirements of an object that can return documentation for a .NET type or member definition.
Public interface | IExternalAliasDirective | Provides the base requirements of an external alias directive.
Public interface | INamespaceDeclaration | Provides the base requirements of a namespace declaration that encloses types declared in a source file.
Public interface | INamespaceDefinition | Provides the base requirements of a namespace that can contain types and other nested namespaces.
Public interface | INamespaceDefinitionCollection | Provides the base requirements for a collection of INamespaceDefinition objects.
Public interface | IParameterDefinition | Provides the base requirements of a parameter definition.
Public interface | IParameterDefinitionCollection | Provides the base requirements for a collection of IParameterDefinition objects.
Public interface | IProjectAssembly | Provides the base requirements of a project (source code-based) assembly.
Public interface | IProjectAssemblyReference | Provides the base requirements of an assembly reference within an IProjectAssembly.
Public interface | IProjectAssemblyReferenceCollection | Provides the base requirements for a collection of IProjectAssemblyReference objects.
Public interface | IQualifiedName | Provides the base requirements of a qualified name.
Public interface | IReflectionDefinition | Provides the base requirements of a reflection definition.
Public interface | ISimpleName | Provides the base requirements of a simple name with optional type arguments, which is a component of an IQualifiedName.
Public interface | ISourceFile | Provides the base requirements of a source code file that can be loaded by an IProjectAssembly.
Public interface | ISourceFileCollection | Provides the base requirements for a collection of ISourceFile objects.
Public interface | ITypeDefinition | Provides the base requirements of a type definition.
Public interface | ITypeDefinitionCollection | Provides the base requirements for a collection of ITypeDefinition objects.
Public interface | ITypeMemberDefinition | Provides the base requirements of a type member (method, property, etc.) definition.
Public interface | ITypeMemberDefinitionCollection | Provides the base requirements for a collection of ITypeMemberDefinition objects.
Public interface | ITypeMemberReference | Provides the base requirements of a type member (method, property, etc.) reference.
Public interface | ITypeParameter | Provides the base requirements of a generic type parameter.
Public interface | ITypeParameterCollection | Provides the base requirements for a collection of ITypeParameter objects.
Public interface | ITypeReference | Provides the base requirements of a type reference.
Public interface | ITypeReferenceCollection | Provides the base requirements for a collection of ITypeReference objects.
Public interface | IUsingDirective | Provides the base requirements of an using directive.
Public interface | IVariableDefinition | Provides the base requirements of a variable definition.


AmbientAssemblyRepositoryProvider Class

AmbientAssemblyRepositoryProvider Class
Implements a class that can be used to provide a static IAssemblyRepository that is used for managing and caching assemblies by default.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ReflectionAmbientAssemblyRepositoryProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class AmbientAssemblyRepositoryProvider
Public NotInheritable Class AmbientAssemblyRepositoryProvider

The AmbientAssemblyRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IAssemblyRepository to use.
Top
Remarks
Set the Repository property to an IAssemblyRepository instance to register the default assembly respository.
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


AmbientAssemblyRepositoryProvider Properties

AmbientAssemblyRepositoryProvider Properties

The AmbientAssemblyRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IAssemblyRepository to use.
Top
See Also

Reference

AmbientAssemblyRepositoryProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


AmbientAssemblyRepositoryProvider.Repository Property

AmbientAssemblyRepositoryProviderRepository Property
Gets or sets the default IAssemblyRepository to use.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IAssemblyRepository Repository { get; set; }
Public Shared Property Repository As IAssemblyRepository
    Get
    Set

Property Value

Type: IAssemblyRepository
The default IAssemblyRepository to use.
See Also

Reference

AmbientAssemblyRepositoryProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAliasedUsingDirective Interface

IAliasedUsingDirective Interface
Provides the base requirements of an using directive with an alias.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAliasedUsingDirective : IUsingDirective
Public Interface IAliasedUsingDirective
    Inherits IUsingDirective

The IAliasedUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Public property | Name | Gets the qualified name of the namespace imported by the using directive. (Inherited from IUsingDirective.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAliasedUsingDirective Properties

IAliasedUsingDirective Properties

The IAliasedUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Public property | Name | Gets the qualified name of the namespace imported by the using directive. (Inherited from IUsingDirective.)
Top
See Also

Reference

IAliasedUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAliasedUsingDirective.Alias Property

IAliasedUsingDirectiveAlias Property
Gets the alias that is defined by the directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The alias that is defined by the directive.
See Also

Reference

IAliasedUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly Interface

IAssembly Interface
Provides the base requirements of an assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAssembly
Public Interface IAssembly

The IAssembly type exposes the following members.

Properties
 | Name | Description
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly Properties

IAssembly Properties

The IAssembly type exposes the following members.

Properties
 | Name | Description
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Top
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.Documentation Property

IAssemblyDocumentation Property
Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAssemblyDocumentation Documentation { get; set; }
Property Documentation As IAssemblyDocumentation
    Get
    Set

Property Value

Type: IAssemblyDocumentation
The IAssemblyDocumentation that provides access to this assembly's type and member documentation.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.GlobalNamespace Property

IAssemblyGlobalNamespace Property
Gets the entry point into the INamespaceDefinition tree defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDefinition GlobalNamespace { get; }
ReadOnly Property GlobalNamespace As INamespaceDefinition
    Get

Property Value

Type: INamespaceDefinition
The entry point into the INamespaceDefinition tree defined in this assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.Name Property

IAssemblyName Property
Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.Namespaces Property

IAssemblyNamespaces Property
Gets the collection of INamespaceDefinition objects defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDefinitionCollection Namespaces { get; }
ReadOnly Property Namespaces As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of INamespaceDefinition objects defined in this assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly Methods

IAssembly Methods

The IAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.GetAssemblyName Method

IAssemblyGetAssemblyName Method
Returns an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAssemblyName GetAssemblyName()
Function GetAssemblyName As IAssemblyName

Field Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.

Return Value

Type: IAssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.IAssembly.GetAssemblyName"]

See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssembly.ToTreeString Method

IAssemblyToTreeString Method
Outputs the contents of the assembly in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ToTreeString()
Function ToTreeString As String

Return Value

Type: String
A string that indicates the contents of the assembly.
See Also

Reference

IAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation Interface

IAssemblyDocumentation Interface
Provides the base requirements of an object that can access documentation for the types and members defined in an assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAssemblyDocumentation
Public Interface IAssemblyDocumentation
Methods
 | Name | Description
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation Methods

IAssemblyDocumentation Methods
Methods
 | Name | Description
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

IAssemblyDocumentation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation.GetDocumentationAsync Method

IAssemblyDocumentationGetDocumentationAsync Method
Overload List
 | Name | Description
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

IAssemblyDocumentation Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation.GetDocumentationAsync Method (ITypeDefinition)

IAssemblyDocumentationGetDocumentationAsync Method (ITypeDefinition)
Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IDocumentationProvider> GetDocumentationAsync(
    ITypeDefinition typeDef
)
Function GetDocumentationAsync (
    typeDef As ITypeDefinition
) As Task(Of IDocumentationProvider)

Parameters

typeDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The ITypeDefinition for which to search.

Return Value

Type: Task IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
See Also

Reference

IAssemblyDocumentation Interface
GetDocumentationAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyDocumentation.GetDocumentationAsync Method (ITypeMemberDefinition)

IAssemblyDocumentationGetDocumentationAsync Method (ITypeMemberDefinition)
Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IDocumentationProvider> GetDocumentationAsync(
    ITypeMemberDefinition typeMemberDef
)
Function GetDocumentationAsync (
    typeMemberDef As ITypeMemberDefinition
) As Task(Of IDocumentationProvider)

Parameters

typeMemberDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeMemberDefinition
The ITypeMemberDefinition for which to search.

Return Value

Type: Task IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
See Also

Reference

IAssemblyDocumentation Interface
GetDocumentationAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName Interface

IAssemblyName Interface
Provides the base requirements of an assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAssemblyName
Public Interface IAssemblyName

The IAssemblyName type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName Properties

IAssemblyName Properties

The IAssemblyName type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName.FullName Property

IAssemblyNameFullName Property
Gets the full name of the assembly, also known as the display name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the assembly, also known as the display name.
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName.Name Property

IAssemblyNameName Property
Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyName.Version Property

IAssemblyNameVersion Property
Gets the major, minor, build, and revision numbers of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Version Version { get; }
ReadOnly Property Version As Version
    Get

Property Value

Type: Version
the major, minor, build, and revision numbers of the assembly.
See Also

Reference

IAssemblyName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyReference Interface

IAssemblyReference Interface
Provides the base requirements of an assembly reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAssemblyReference
Public Interface IAssemblyReference

The IAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyReference Properties

IAssemblyReference Properties

The IAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information.
Top
See Also

Reference

IAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyReference.AssemblyName Property

IAssemblyReferenceAssemblyName Property
Gets an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAssemblyName AssemblyName { get; }
ReadOnly Property AssemblyName As IAssemblyName
    Get

Property Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

IAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository Interface

IAssemblyRepository Interface
Provides the base requirements for a class that manages IAssembly instances and caching of data as appropriate.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAssemblyRepository
Public Interface IAssemblyRepository

The IAssemblyRepository type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Public method | PruneCacheAsync | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository Methods

IAssemblyRepository Methods

The IAssemblyRepository type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Public method | PruneCacheAsync | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Top
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Add Method

IAssemblyRepositoryAdd Method
Adds a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Add(
    IBinaryAssembly assembly
)
Sub Add (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is referenced.
Remarks
The specified assembly will be tracked while there are remaining references to it. While tracked, the various [!:Load(string)] methods will return the already-loaded instance when appropriate.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.LoadAsync Method

IAssemblyRepositoryLoadAsync Method
Overload List
 | Name | Description
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Top
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.LoadAsync Method (Assembly)

IAssemblyRepositoryLoadAsync Method (Assembly)
Creates a new IBinaryAssembly instance from the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IBinaryAssembly> LoadAsync(
    Assembly assembly
)
Function LoadAsync (
    assembly As Assembly
) As Task(Of IBinaryAssembly)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.

Return Value

Type: Task IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
LoadAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.LoadAsync Method (String)

IAssemblyRepositoryLoadAsync Method (String)
Creates a new IBinaryAssembly instance from the specified Assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IBinaryAssembly> LoadAsync(
    string fullName
)
Function LoadAsync (
    fullName As String
) As Task(Of IBinaryAssembly)

Parameters

fullName
Type: SystemString
The Assembly full name for which to load.

Return Value

Type: Task IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
LoadAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.LoadAsync Method (Assembly, IAssemblyName)

IAssemblyRepositoryLoadAsync Method (Assembly, IAssemblyName)
Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IBinaryAssembly> LoadAsync(
    Assembly assembly,
    IAssemblyName assemblyName
)
Function LoadAsync (
    assembly As Assembly,
    assemblyName As IAssemblyName
) As Task(Of IBinaryAssembly)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The alternate AssemblyName to use.

Return Value

Type: Task IBinaryAssembly
The IBinaryAssembly that was created.
See Also

Reference

IAssemblyRepository Interface
LoadAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.PruneCacheAsync Method

IAssemblyRepositoryPruneCacheAsync Method
Deletes any cache data that is no longer valid.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task PruneCacheAsync()
Function PruneCacheAsync As Task

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyRepository.PruneCacheAsync"]

Remarks
Call this method upon the shutdown of your application to ensure out-of-date cache data isn't retained.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IAssemblyRepository.Remove Method

IAssemblyRepositoryRemove Method
Removes a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Remove(
    IBinaryAssembly assembly
)
Sub Remove (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is no longer referenced.
Remarks
When no references remain for the assembly, it will no longer be tracked.
See Also

Reference

IAssemblyRepository Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly Interface

IBinaryAssembly Interface
Provides the base requirements of a binary assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBinaryAssembly : IAssembly,
    IBinaryAssemblyMetadata
Public Interface IBinaryAssembly
    Inherits IAssembly, IBinaryAssemblyMetadata

The IBinaryAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | HasLoadErrors | Gets whether load errors were encountered when using reflection on the related .NET assembly.
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Location | Gets the location of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Size | Gets the size of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly Properties

IBinaryAssembly Properties

The IBinaryAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | HasLoadErrors | Gets whether load errors were encountered when using reflection on the related .NET assembly.
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Location | Gets the location of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Size | Gets the size of the assembly, if known. (Inherited from IBinaryAssemblyMetadata.)
Top
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly.AssemblyReferences Property

IBinaryAssemblyAssemblyReferences Property
Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IBinaryAssemblyReferenceCollection AssemblyReferences { get; }
ReadOnly Property AssemblyReferences As IBinaryAssemblyReferenceCollection
    Get

Property Value

Type: IBinaryAssemblyReferenceCollection
The collection of assembly references for this assembly.
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly.HasLoadErrors Property

IBinaryAssemblyHasLoadErrors Property
Gets whether load errors were encountered when using reflection on the related .NET assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasLoadErrors { get; }
ReadOnly Property HasLoadErrors As Boolean
    Get

Property Value

Type: Boolean
true if load errors were encountered; otherwise, false.
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssembly Methods

IBinaryAssembly Methods

The IBinaryAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

IBinaryAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata Interface

IBinaryAssemblyMetadata Interface
Provides the base requirements for storing metadata of an IBinaryAssembly, generally used with serialization.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBinaryAssemblyMetadata
Public Interface IBinaryAssemblyMetadata

The IBinaryAssemblyMetadata type exposes the following members.

Properties
 | Name | Description
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known.
Public property | Location | Gets the location of the assembly, if known.
Public property | Size | Gets the size of the assembly, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata Properties

IBinaryAssemblyMetadata Properties

The IBinaryAssemblyMetadata type exposes the following members.

Properties
 | Name | Description
Public property | LastModifiedDateTime | Gets the DateTime at which the assembly was last modified, if known.
Public property | Location | Gets the location of the assembly, if known.
Public property | Size | Gets the size of the assembly, if known.
Top
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata.LastModifiedDateTime Property

IBinaryAssemblyMetadataLastModifiedDateTime Property
Gets the DateTime at which the assembly was last modified, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<DateTime> LastModifiedDateTime { get; }
ReadOnly Property LastModifiedDateTime As Nullable(Of DateTime)
    Get

Property Value

Type: Nullable DateTime
The DateTime at which the assembly was last modified, if known.
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata.Location Property

IBinaryAssemblyMetadataLocation Property
Gets the location of the assembly, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Location { get; }
ReadOnly Property Location As String
    Get

Property Value

Type: String
The location of the assembly, if known.
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyMetadata.Size Property

IBinaryAssemblyMetadataSize Property
Gets the size of the assembly, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<long> Size { get; }
ReadOnly Property Size As Nullable(Of Long)
    Get

Property Value

Type: Nullable Int64
The size of the assembly, if known.
See Also

Reference

IBinaryAssemblyMetadata Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReference Interface

IBinaryAssemblyReference Interface
Provides the base requirements of an assembly reference within an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBinaryAssemblyReference : IAssemblyReference
Public Interface IBinaryAssemblyReference
    Inherits IAssemblyReference

The IBinaryAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReference Properties

IBinaryAssemblyReference Properties

The IBinaryAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

IBinaryAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Interface

IBinaryAssemblyReferenceCollection Interface
Provides the base requirements for a collection of IBinaryAssemblyReference objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBinaryAssemblyReferenceCollection : IObservableCollection<IBinaryAssemblyReference>,
    IList<IBinaryAssemblyReference>, ICollection<IBinaryAssemblyReference>, IEnumerable<IBinaryAssemblyReference>,
    IEnumerable
Public Interface IBinaryAssemblyReferenceCollection
    Inherits IObservableCollection(Of IBinaryAssemblyReference), IList(Of IBinaryAssemblyReference),
    ICollection(Of IBinaryAssemblyReference), IEnumerable(Of IBinaryAssemblyReference), IEnumerable

The IBinaryAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IBinaryAssemblyReference .)
Public property | IsReadOnly | (Inherited from ICollection IBinaryAssemblyReference .)
Public property | ItemInt32 | (Inherited from IList IBinaryAssemblyReference .)
Public property | ItemString | Gets the IBinaryAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Clear | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Contains | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | CopyTo | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | GetEnumerator | (Inherited from IEnumerable IBinaryAssemblyReference .)
Public method | IndexOf | (Inherited from IList IBinaryAssemblyReference .)
Public method | Insert | (Inherited from IList IBinaryAssemblyReference .)
Public method | Remove | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | RemoveAt | (Inherited from IList IBinaryAssemblyReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Properties

IBinaryAssemblyReferenceCollection Properties

The IBinaryAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IBinaryAssemblyReference .)
Public property | IsReadOnly | (Inherited from ICollection IBinaryAssemblyReference .)
Public property | ItemInt32 | (Inherited from IList IBinaryAssemblyReference .)
Public property | ItemString | Gets the IBinaryAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection.Item Property

IBinaryAssemblyReferenceCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IBinaryAssemblyReference .)
Public property | ItemString | Gets the IBinaryAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection.Item Property (String)

IBinaryAssemblyReferenceCollectionItem Property (String)
Gets the IBinaryAssemblyReference for the assembly with the specified full name.

[C#] In C#, this property is the indexer for the IBinaryAssemblyReferenceCollection class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IBinaryAssemblyReference this[
    string fullName
] { get; }
ReadOnly Property Item (
    fullName As String
) As IBinaryAssemblyReference
    Get

Parameters

fullName
Type: SystemString
The full name of the IBinaryAssemblyReference to return.

Property Value

Type: IBinaryAssemblyReference
The IBinaryAssemblyReference for the assembly with the specified full name.
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Methods

IBinaryAssemblyReferenceCollection Methods

The IBinaryAssemblyReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Clear | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | Contains | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | CopyTo | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | GetEnumerator | (Inherited from IEnumerable IBinaryAssemblyReference .)
Public method | IndexOf | (Inherited from IList IBinaryAssemblyReference .)
Public method | Insert | (Inherited from IList IBinaryAssemblyReference .)
Public method | Remove | (Inherited from ICollection IBinaryAssemblyReference .)
Public method | RemoveAt | (Inherited from IList IBinaryAssemblyReference .)
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IBinaryAssemblyReferenceCollection Events

IBinaryAssemblyReferenceCollection Events

The IBinaryAssemblyReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IBinaryAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider Interface

IDocumentationProvider Interface
Provides the base requirements of an object that can return documentation for a .NET type or member definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDocumentationProvider
Public Interface IDocumentationProvider

The IDocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider Methods

IDocumentationProvider Methods

The IDocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Top
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider.GetParameter Method

IDocumentationProviderGetParameter Method
Returns the documentation for the parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetParameter(
    string name
)
Function GetParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the parameter with the specified name.
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider.GetSummary Method

IDocumentationProviderGetSummary Method
Returns the summary documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetSummary()
Function GetSummary As String

Return Value

Type: String
The summary documentation.
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IDocumentationProvider.GetTypeParameter Method

IDocumentationProviderGetTypeParameter Method
Returns the documentation for the type parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetTypeParameter(
    string name
)
Function GetTypeParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the type parameter with the specified name.
See Also

Reference

IDocumentationProvider Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IExternalAliasDirective Interface

IExternalAliasDirective Interface
Provides the base requirements of an external alias directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IExternalAliasDirective
Public Interface IExternalAliasDirective

The IExternalAliasDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IExternalAliasDirective Properties

IExternalAliasDirective Properties

The IExternalAliasDirective type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias that is defined by the directive.
Top
See Also

Reference

IExternalAliasDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IExternalAliasDirective.Alias Property

IExternalAliasDirectiveAlias Property
Gets the alias that is defined by the directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The alias that is defined by the directive.
See Also

Reference

IExternalAliasDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration Interface

INamespaceDeclaration Interface
Provides the base requirements of a namespace declaration that encloses types declared in a source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INamespaceDeclaration
Public Interface INamespaceDeclaration

The INamespaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AliasedUsingDirectives | Gets the collection of aliased using directives within the namespace declaration.
Public property | ExternalAliasDirectives | Gets the collection of external alias directives within the namespace declaration.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the name of the namespace.
Public property | Parent | Gets the INamespaceDeclaration that contains this namespace declaration.
Public property | UsingDirectives | Gets the collection of using directives within the namespace declaration.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration Properties

INamespaceDeclaration Properties

The INamespaceDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | AliasedUsingDirectives | Gets the collection of aliased using directives within the namespace declaration.
Public property | ExternalAliasDirectives | Gets the collection of external alias directives within the namespace declaration.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the name of the namespace.
Public property | Parent | Gets the INamespaceDeclaration that contains this namespace declaration.
Public property | UsingDirectives | Gets the collection of using directives within the namespace declaration.
Top
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.AliasedUsingDirectives Property

INamespaceDeclarationAliasedUsingDirectives Property
Gets the collection of aliased using directives within the namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IAliasedUsingDirective> AliasedUsingDirectives { get; }
ReadOnly Property AliasedUsingDirectives As IList(Of IAliasedUsingDirective)
    Get

Property Value

Type: IList IAliasedUsingDirective
The collection of aliased using directives within the namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.ExternalAliasDirectives Property

INamespaceDeclarationExternalAliasDirectives Property
Gets the collection of external alias directives within the namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IExternalAliasDirective> ExternalAliasDirectives { get; }
ReadOnly Property ExternalAliasDirectives As IList(Of IExternalAliasDirective)
    Get

Property Value

Type: IList IExternalAliasDirective
The collection of external alias directives within the namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.FullName Property

INamespaceDeclarationFullName Property
Gets the full name of the namespace, which includes the names of ancestor namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the namespace, which includes the names of ancestor namespaces.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.Name Property

INamespaceDeclarationName Property
Gets the name of the namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the namespace.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.Parent Property

INamespaceDeclarationParent Property
Gets the INamespaceDeclaration that contains this namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDeclaration Parent { get; }
ReadOnly Property Parent As INamespaceDeclaration
    Get

Property Value

Type: INamespaceDeclaration
The INamespaceDeclaration that contains this namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDeclaration.UsingDirectives Property

INamespaceDeclarationUsingDirectives Property
Gets the collection of using directives within the namespace declaration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IUsingDirective> UsingDirectives { get; }
ReadOnly Property UsingDirectives As IList(Of IUsingDirective)
    Get

Property Value

Type: IList IUsingDirective
The collection of using directives within the namespace declaration.
See Also

Reference

INamespaceDeclaration Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition Interface

INamespaceDefinition Interface
Provides the base requirements of a namespace that can contain types and other nested namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INamespaceDefinition : IReflectionDefinition
Public Interface INamespaceDefinition
    Inherits IReflectionDefinition

The INamespaceDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child INamespaceDefinition objects within this namespace.
Public property | ExtensionMethods | Gets the collection of extension methods that are contained in the namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | StandardModules | Gets the collection of standard modules that are contained in the namespace.
Public property | Types | Gets the collection of ITypeDefinition objects within this namespace.
Top
Methods
 | Name | Description
Public method | ToTreeString | Outputs the contents of the namespace in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition Properties

INamespaceDefinition Properties

The INamespaceDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child INamespaceDefinition objects within this namespace.
Public property | ExtensionMethods | Gets the collection of extension methods that are contained in the namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | StandardModules | Gets the collection of standard modules that are contained in the namespace.
Public property | Types | Gets the collection of ITypeDefinition objects within this namespace.
Top
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.Children Property

INamespaceDefinitionChildren Property
Gets the collection of child INamespaceDefinition objects within this namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDefinitionCollection Children { get; }
ReadOnly Property Children As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of child INamespaceDefinition objects within this namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.ExtensionMethods Property

INamespaceDefinitionExtensionMethods Property
Gets the collection of extension methods that are contained in the namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeMemberDefinitionCollection ExtensionMethods { get; }
ReadOnly Property ExtensionMethods As ITypeMemberDefinitionCollection
    Get

Property Value

Type: ITypeMemberDefinitionCollection
The collection of extension methods that are contained in the namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.FullName Property

INamespaceDefinitionFullName Property
Gets the full name of the namespace, which includes the names of ancestor namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the namespace, which includes the names of ancestor namespaces.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.StandardModules Property

INamespaceDefinitionStandardModules Property
Gets the collection of standard modules that are contained in the namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection StandardModules { get; }
ReadOnly Property StandardModules As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of standard modules that are contained in the namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.Types Property

INamespaceDefinitionTypes Property
Gets the collection of ITypeDefinition objects within this namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection Types { get; }
ReadOnly Property Types As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of ITypeDefinition objects within this namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition Methods

INamespaceDefinition Methods

The INamespaceDefinition type exposes the following members.

Methods
 | Name | Description
Public method | ToTreeString | Outputs the contents of the namespace in tree form.
Top
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinition.ToTreeString Method

INamespaceDefinitionToTreeString Method
Outputs the contents of the namespace in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ToTreeString(
    int indentLevel
)
Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the namespace.
See Also

Reference

INamespaceDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Interface

INamespaceDefinitionCollection Interface
Provides the base requirements for a collection of INamespaceDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INamespaceDefinitionCollection : IObservableCollection<INamespaceDefinition>,
    IList<INamespaceDefinition>, ICollection<INamespaceDefinition>, IEnumerable<INamespaceDefinition>,
    IEnumerable
Public Interface INamespaceDefinitionCollection
    Inherits IObservableCollection(Of INamespaceDefinition), IList(Of INamespaceDefinition),
    ICollection(Of INamespaceDefinition), IEnumerable(Of INamespaceDefinition), IEnumerable

The INamespaceDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection INamespaceDefinition .)
Public property | IsReadOnly | (Inherited from ICollection INamespaceDefinition .)
Public property | ItemInt32 | (Inherited from IList INamespaceDefinition .)
Public property | ItemString, Boolean | Gets the INamespaceDefinition with the specified name. [C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection INamespaceDefinition .)
Public method | Clear | (Inherited from ICollection INamespaceDefinition .)
Public method | Contains | (Inherited from ICollection INamespaceDefinition .)
Public method | CopyTo | (Inherited from ICollection INamespaceDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable INamespaceDefinition .)
Public method | IndexOf | (Inherited from IList INamespaceDefinition .)
Public method | Insert | (Inherited from IList INamespaceDefinition .)
Public method | Remove | (Inherited from ICollection INamespaceDefinition .)
Public method | RemoveAt | (Inherited from IList INamespaceDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Properties

INamespaceDefinitionCollection Properties

The INamespaceDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection INamespaceDefinition .)
Public property | IsReadOnly | (Inherited from ICollection INamespaceDefinition .)
Public property | ItemInt32 | (Inherited from IList INamespaceDefinition .)
Public property | ItemString, Boolean | Gets the INamespaceDefinition with the specified name. [C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection.Item Property

INamespaceDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList INamespaceDefinition .)
Public property | ItemString, Boolean | Gets the INamespaceDefinition with the specified name. [C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection.Item Property (String, Boolean)

INamespaceDefinitionCollectionItem Property (String, Boolean)
Gets the INamespaceDefinition with the specified name.

[C#] In C#, this property is the indexer for the INamespaceDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDefinition this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Property Item (
    name As String,
    caseSensitive As Boolean
) As INamespaceDefinition
    Get

Parameters

name
Type: SystemString
The name of the INamespaceDefinition to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: INamespaceDefinition
The INamespaceDefinition with the specified name.
See Also

Reference

INamespaceDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Methods

INamespaceDefinitionCollection Methods

The INamespaceDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection INamespaceDefinition .)
Public method | Clear | (Inherited from ICollection INamespaceDefinition .)
Public method | Contains | (Inherited from ICollection INamespaceDefinition .)
Public method | CopyTo | (Inherited from ICollection INamespaceDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable INamespaceDefinition .)
Public method | IndexOf | (Inherited from IList INamespaceDefinition .)
Public method | Insert | (Inherited from IList INamespaceDefinition .)
Public method | Remove | (Inherited from ICollection INamespaceDefinition .)
Public method | RemoveAt | (Inherited from IList INamespaceDefinition .)
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


INamespaceDefinitionCollection Events

INamespaceDefinitionCollection Events

The INamespaceDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

INamespaceDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition Interface

IParameterDefinition Interface
Provides the base requirements of a parameter definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterDefinition : IReflectionDefinition
Public Interface IParameterDefinition
    Inherits IReflectionDefinition

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current parameter.
Public property | IsByReference | Gets whether this is a pass by-reference parameter.
Public property | IsExtension | Gets whether this is the first parameter to an extension method.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsOutput | Gets whether this is an output parameter.
Public property | IsParameterArray | Gets whether this is a parameter array.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the parameter type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition Properties

IParameterDefinition Properties

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current parameter.
Public property | IsByReference | Gets whether this is a pass by-reference parameter.
Public property | IsExtension | Gets whether this is the first parameter to an extension method.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsOutput | Gets whether this is an output parameter.
Public property | IsParameterArray | Gets whether this is a parameter array.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the parameter type.
Top
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.DeclaringMember Property

IParameterDefinitionDeclaringMember Property
Gets the type member that declares the current parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeMemberDefinition DeclaringMember { get; }
ReadOnly Property DeclaringMember As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
An ITypeMemberDefinition object representing the type member that declares the current parameter.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsByReference Property

IParameterDefinitionIsByReference Property
Gets whether this is a pass by-reference parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsByReference { get; }
ReadOnly Property IsByReference As Boolean
    Get

Property Value

Type: Boolean
true if this is a pass by-reference parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsExtension Property

IParameterDefinitionIsExtension Property
Gets whether this is the first parameter to an extension method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsExtension { get; }
ReadOnly Property IsExtension As Boolean
    Get

Property Value

Type: Boolean
true if this is the first parameter to an extension method; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsOptional Property

IParameterDefinitionIsOptional Property
Gets whether this is an optional parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsOptional { get; }
ReadOnly Property IsOptional As Boolean
    Get

Property Value

Type: Boolean
true if this is an optional parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsOutput Property

IParameterDefinitionIsOutput Property
Gets whether this is an output parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsOutput { get; }
ReadOnly Property IsOutput As Boolean
    Get

Property Value

Type: Boolean
true if this is an output parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.IsParameterArray Property

IParameterDefinitionIsParameterArray Property
Gets whether this is a parameter array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsParameterArray { get; }
ReadOnly Property IsParameterArray As Boolean
    Get

Property Value

Type: Boolean
true if this is a parameter array; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinition.Type Property

IParameterDefinitionType Property
Gets an ITypeReference for the parameter type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReference Type { get; }
ReadOnly Property Type As ITypeReference
    Get

Property Value

Type: ITypeReference
An ITypeReference for the parameter type.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Interface

IParameterDefinitionCollection Interface
Provides the base requirements for a collection of IParameterDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterDefinitionCollection : IObservableCollection<IParameterDefinition>,
    IList<IParameterDefinition>, ICollection<IParameterDefinition>, IEnumerable<IParameterDefinition>,
    IEnumerable
Public Interface IParameterDefinitionCollection
    Inherits IObservableCollection(Of IParameterDefinition), IList(Of IParameterDefinition),
    ICollection(Of IParameterDefinition), IEnumerable(Of IParameterDefinition), IEnumerable

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | (Inherited from IList IParameterDefinition .)
Public property | ItemString, Boolean | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IParameterDefinition .)
Public method | Clear | (Inherited from ICollection IParameterDefinition .)
Public method | Contains | (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IParameterDefinition .)
Public method | IndexOf | (Inherited from IList IParameterDefinition .)
Public method | Insert | (Inherited from IList IParameterDefinition .)
Public method | Remove | (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | (Inherited from IList IParameterDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Properties

IParameterDefinitionCollection Properties

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | (Inherited from IList IParameterDefinition .)
Public property | ItemString, Boolean | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection.Item Property

IParameterDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IParameterDefinition .)
Public property | ItemString, Boolean | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection.Item Property (String, Boolean)

IParameterDefinitionCollectionItem Property (String, Boolean)
Gets the IParameterDefinition with the specified name.

[C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParameterDefinition this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Property Item (
    name As String,
    caseSensitive As Boolean
) As IParameterDefinition
    Get

Parameters

name
Type: SystemString
The name of the IParameterDefinition to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: IParameterDefinition
The IParameterDefinition with the specified name.
See Also

Reference

IParameterDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Methods

IParameterDefinitionCollection Methods

The IParameterDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IParameterDefinition .)
Public method | Clear | (Inherited from ICollection IParameterDefinition .)
Public method | Contains | (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IParameterDefinition .)
Public method | IndexOf | (Inherited from IList IParameterDefinition .)
Public method | Insert | (Inherited from IList IParameterDefinition .)
Public method | Remove | (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | (Inherited from IList IParameterDefinition .)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IParameterDefinitionCollection Events

IParameterDefinitionCollection Events

The IParameterDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly Interface

IProjectAssembly Interface
Provides the base requirements of a project (source code-based) assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IProjectAssembly : IAssembly
Public Interface IProjectAssembly
    Inherits IAssembly

The IProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly Properties

IProjectAssembly Properties

The IProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from IAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from IAssembly.)
Public property | Name | Gets the simple name of the assembly. (Inherited from IAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from IAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly.AssemblyReferences Property

IProjectAssemblyAssemblyReferences Property
Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProjectAssemblyReferenceCollection AssemblyReferences { get; }
ReadOnly Property AssemblyReferences As IProjectAssemblyReferenceCollection
    Get

Property Value

Type: IProjectAssemblyReferenceCollection
The collection of assembly references for this assembly.
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly.Resolver Property

IProjectAssemblyResolver Property
Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolver Resolver { get; }
ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly.SourceFiles Property

IProjectAssemblySourceFiles Property
Gets the collection of source files in this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISourceFileCollection SourceFiles { get; }
ReadOnly Property SourceFiles As ISourceFileCollection
    Get

Property Value

Type: ISourceFileCollection
The collection of source files in this project assembly.
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssembly Methods

IProjectAssembly Methods

The IProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from IAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from IAssembly.)
Top
See Also

Reference

IProjectAssembly Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReference Interface

IProjectAssemblyReference Interface
Provides the base requirements of an assembly reference within an IProjectAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IProjectAssemblyReference : IAssemblyReference
Public Interface IProjectAssemblyReference
    Inherits IAssemblyReference

The IProjectAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the IAssembly that is referenced.
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReference Properties

IProjectAssemblyReference Properties

The IProjectAssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the IAssembly that is referenced.
Public property | AssemblyName | Gets an IAssemblyName that contains assembly name information. (Inherited from IAssemblyReference.)
Top
See Also

Reference

IProjectAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReference.Assembly Property

IProjectAssemblyReferenceAssembly Property
Gets the IAssembly that is referenced.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAssembly Assembly { get; }
ReadOnly Property Assembly As IAssembly
    Get

Property Value

Type: IAssembly
The IAssembly that is referenced.
See Also

Reference

IProjectAssemblyReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Interface

IProjectAssemblyReferenceCollection Interface
Provides the base requirements for a collection of IProjectAssemblyReference objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IProjectAssemblyReferenceCollection : IObservableCollection<IProjectAssemblyReference>,
    IList<IProjectAssemblyReference>, ICollection<IProjectAssemblyReference>, IEnumerable<IProjectAssemblyReference>,
    IEnumerable
Public Interface IProjectAssemblyReferenceCollection
    Inherits IObservableCollection(Of IProjectAssemblyReference), IList(Of IProjectAssemblyReference),
    ICollection(Of IProjectAssemblyReference), IEnumerable(Of IProjectAssemblyReference), IEnumerable

The IProjectAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IProjectAssemblyReference .)
Public property | IsReadOnly | (Inherited from ICollection IProjectAssemblyReference .)
Public property | ItemInt32 | (Inherited from IList IProjectAssemblyReference .)
Public property | ItemString | Gets the IProjectAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Public property | ItemIAssemblyName | Gets the IProjectAssemblyReference for the assembly with the specified name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Top
Methods
 | Name | Description
Public method | Add(IAssembly) | Adds a new reference for the specified IAssembly.
Public method | Add(T) | (Inherited from ICollection IProjectAssemblyReference .)
Public method | AddAsync(Assembly) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Public method | AddAsync(String) | Adds a new reference to an IBinaryAssembly for the specified assembly name.
Public method | AddAsync(Assembly, IAssemblyName) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Public method | AddMsCorLibAsync | Adds a new reference to an IBinaryAssembly for mscorlib.
Public method | Clear | (Inherited from ICollection IProjectAssemblyReference .)
Public method | Contains | (Inherited from ICollection IProjectAssemblyReference .)
Public method | CopyTo | (Inherited from ICollection IProjectAssemblyReference .)
Public method | GetEnumerator | (Inherited from IEnumerable IProjectAssemblyReference .)
Public method | IndexOf | (Inherited from IList IProjectAssemblyReference .)
Public method | Insert | (Inherited from IList IProjectAssemblyReference .)
Public method | Remove | (Inherited from ICollection IProjectAssemblyReference .)
Public method | RemoveAt | (Inherited from IList IProjectAssemblyReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Properties

IProjectAssemblyReferenceCollection Properties

The IProjectAssemblyReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IProjectAssemblyReference .)
Public property | IsReadOnly | (Inherited from ICollection IProjectAssemblyReference .)
Public property | ItemInt32 | (Inherited from IList IProjectAssemblyReference .)
Public property | ItemString | Gets the IProjectAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Public property | ItemIAssemblyName | Gets the IProjectAssemblyReference for the assembly with the specified name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Item Property

IProjectAssemblyReferenceCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IProjectAssemblyReference .)
Public property | ItemString | Gets the IProjectAssemblyReference for the assembly with the specified full name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Public property | ItemIAssemblyName | Gets the IProjectAssemblyReference for the assembly with the specified name. [C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Item Property (String)

IProjectAssemblyReferenceCollectionItem Property (String)
Gets the IProjectAssemblyReference for the assembly with the specified full name.

[C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProjectAssemblyReference this[
    string fullName
] { get; }
ReadOnly Property Item (
    fullName As String
) As IProjectAssemblyReference
    Get

Parameters

fullName
Type: SystemString
The full name of the IProjectAssemblyReference to return.

Property Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference for the assembly with the specified full name.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Item Property (IAssemblyName)

IProjectAssemblyReferenceCollectionItem Property (IAssemblyName)
Gets the IProjectAssemblyReference for the assembly with the specified name.

[C#] In C#, this property is the indexer for the IProjectAssemblyReferenceCollection class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProjectAssemblyReference this[
    IAssemblyName assemblyName
] { get; }
ReadOnly Property Item (
    assemblyName As IAssemblyName
) As IProjectAssemblyReference
    Get

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName of the assembly to return.

Property Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference for the assembly with the specified name.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Methods

IProjectAssemblyReferenceCollection Methods

The IProjectAssemblyReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(IAssembly) | Adds a new reference for the specified IAssembly.
Public method | Add(T) | (Inherited from ICollection IProjectAssemblyReference .)
Public method | AddAsync(Assembly) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Public method | AddAsync(String) | Adds a new reference to an IBinaryAssembly for the specified assembly name.
Public method | AddAsync(Assembly, IAssemblyName) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Public method | AddMsCorLibAsync | Adds a new reference to an IBinaryAssembly for mscorlib.
Public method | Clear | (Inherited from ICollection IProjectAssemblyReference .)
Public method | Contains | (Inherited from ICollection IProjectAssemblyReference .)
Public method | CopyTo | (Inherited from ICollection IProjectAssemblyReference .)
Public method | GetEnumerator | (Inherited from IEnumerable IProjectAssemblyReference .)
Public method | IndexOf | (Inherited from IList IProjectAssemblyReference .)
Public method | Insert | (Inherited from IList IProjectAssemblyReference .)
Public method | Remove | (Inherited from ICollection IProjectAssemblyReference .)
Public method | RemoveAt | (Inherited from IList IProjectAssemblyReference .)
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method

IProjectAssemblyReferenceCollectionAdd Method
Overload List
 | Name | Description
Public method | Add(IAssembly) | Adds a new reference for the specified IAssembly.
Public method | Add(T) | (Inherited from ICollection IProjectAssemblyReference .)
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.Add Method (IAssembly)

IProjectAssemblyReferenceCollectionAdd Method (IAssembly)
Adds a new reference for the specified IAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProjectAssemblyReference Add(
    IAssembly assembly
)
Function Add (
    assembly As IAssembly
) As IProjectAssemblyReference

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssembly
The IAssembly to reference.

Return Value

Type: IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddAsync Method

IProjectAssemblyReferenceCollectionAddAsync Method
Overload List
 | Name | Description
Public method | AddAsync(Assembly) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.
Public method | AddAsync(String) | Adds a new reference to an IBinaryAssembly for the specified assembly name.
Public method | AddAsync(Assembly, IAssemblyName) | Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddAsync Method (Assembly)

IProjectAssemblyReferenceCollectionAddAsync Method (Assembly)
Adds a new reference to an IBinaryAssembly for the specified reflection Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IProjectAssemblyReference> AddAsync(
    Assembly assembly
)
Function AddAsync (
    assembly As Assembly
) As Task(Of IProjectAssemblyReference)

Parameters

assembly
Type: System.ReflectionAssembly
The reflection Assembly to reference.

Return Value

Type: Task IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
AddAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddAsync Method (String)

IProjectAssemblyReferenceCollectionAddAsync Method (String)
Adds a new reference to an IBinaryAssembly for the specified assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IProjectAssemblyReference> AddAsync(
    string fullName
)
Function AddAsync (
    fullName As String
) As Task(Of IProjectAssemblyReference)

Parameters

fullName
Type: SystemString
The full name of the assembly to reference.

Return Value

Type: Task IProjectAssemblyReference
The IProjectAssemblyReference that was created.
Remarks
While using the simple assembly name may work in some simple cases (such as System), it is highly recommended to pass the fully-qualified assembly name to this method (such as System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089) since the probing code will have a better chance of successfully finding it.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
AddAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddAsync Method (Assembly, IAssemblyName)

IProjectAssemblyReferenceCollectionAddAsync Method (Assembly, IAssemblyName)
Adds a new reference to an IBinaryAssembly for the specified reflection Assembly, but stores it with an alternate IAssemblyName, which is useful for dynamically generated assemblies.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IProjectAssemblyReference> AddAsync(
    Assembly assembly,
    IAssemblyName assemblyName
)
Function AddAsync (
    assembly As Assembly,
    assemblyName As IAssemblyName
) As Task(Of IProjectAssemblyReference)

Parameters

assembly
Type: System.ReflectionAssembly
The reflection Assembly to reference.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The alternate IAssemblyName to use.

Return Value

Type: Task IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
AddAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection.AddMsCorLibAsync Method

IProjectAssemblyReferenceCollectionAddMsCorLibAsync Method
Adds a new reference to an IBinaryAssembly for mscorlib.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IProjectAssemblyReference> AddMsCorLibAsync()
Function AddMsCorLibAsync As Task(Of IProjectAssemblyReference)

Return Value

Type: Task IProjectAssemblyReference
The IProjectAssemblyReference that was created.
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IProjectAssemblyReferenceCollection Events

IProjectAssemblyReferenceCollection Events

The IProjectAssemblyReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IProjectAssemblyReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName Interface

IQualifiedName Interface
Provides the base requirements of a qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IQualifiedName
Public Interface IQualifiedName

The IQualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the collection of array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName Properties

IQualifiedName Properties

The IQualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the collection of array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.Alias Property

IQualifiedNameAlias Property
Gets the optional alias that indicates the root of the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The optional alias that indicates the root of the qualified name.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.ArrayRankSpecifiers Property

IQualifiedNameArrayRankSpecifiers Property
Gets the collection of array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<int> ArrayRankSpecifiers { get; }
ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The collection of array rank specifiers.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.HasArrayRankSpecifiers Property

IQualifiedNameHasArrayRankSpecifiers Property
Gets whether the qualified name has at least one array rank specifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasArrayRankSpecifiers { get; }
ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one array rank specifier; otherwise, false.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.HasIdentifiers Property

IQualifiedNameHasIdentifiers Property
Gets whether the qualified name has at least one identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasIdentifiers { get; }
ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one identifier; otherwise, false.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.Identifiers Property

IQualifiedNameIdentifiers Property
Gets the collection of identifiers for the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ISimpleName> Identifiers { get; }
ReadOnly Property Identifiers As IList(Of ISimpleName)
    Get

Property Value

Type: IList ISimpleName
The collection of identifiers for the qualified name.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.IsGlobal Property

IQualifiedNameIsGlobal Property
Gets whether the qualified name is rooted at the default global namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsGlobal { get; }
ReadOnly Property IsGlobal As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name is rooted at the default global namespace; otherwise, false.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.PointerLevel Property

IQualifiedNamePointerLevel Property
Gets the pointer level.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PointerLevel { get; }
ReadOnly Property PointerLevel As Integer
    Get

Property Value

Type: Int32
The pointer level.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName Methods

IQualifiedName Methods

The IQualifiedName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IQualifiedName.Clone Method

IQualifiedNameClone Method
Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IQualifiedName Clone()
Function Clone As IQualifiedName

Return Value

Type: IQualifiedName
The object that was created.
See Also

Reference

IQualifiedName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IReflectionDefinition Interface

IReflectionDefinition Interface
Provides the base requirements of a reflection definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IReflectionDefinition
Public Interface IReflectionDefinition

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IReflectionDefinition Properties

IReflectionDefinition Properties

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IReflectionDefinition.Name Property

IReflectionDefinitionName Property
Gets the definition's name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The definition's name.
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName Interface

ISimpleName Interface
Provides the base requirements of a simple name with optional type arguments, which is a component of an IQualifiedName.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISimpleName
Public Interface ISimpleName

The ISimpleName type exposes the following members.

Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName Properties

ISimpleName Properties

The ISimpleName type exposes the following members.

Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.HasTypeArguments Property

ISimpleNameHasTypeArguments Property
Gets whether the identifier has at least one type argument.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasTypeArguments { get; }
ReadOnly Property HasTypeArguments As Boolean
    Get

Property Value

Type: Boolean
true if the identifier has at least one type argument; otherwise, false.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.Text Property

ISimpleNameText Property
Gets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text value of the identifier.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.TypeArguments Property

ISimpleNameTypeArguments Property
Gets the collection of optional generic type arguments for the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IQualifiedName> TypeArguments { get; }
ReadOnly Property TypeArguments As IList(Of IQualifiedName)
    Get

Property Value

Type: IList IQualifiedName
The collection of optional generic type arguments for the identifier.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName Methods

ISimpleName Methods

The ISimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Top
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISimpleName.Clone Method

ISimpleNameClone Method
Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISimpleName Clone()
Function Clone As ISimpleName

Return Value

Type: ISimpleName
The object that was created.
See Also

Reference

ISimpleName Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFile Interface

ISourceFile Interface
Provides the base requirements of a source code file that can be loaded by an IProjectAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISourceFile : IKeyedObject
Public Interface ISourceFile
    Inherits IKeyedObject

The ISourceFile type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFile Properties

ISourceFile Properties

The ISourceFile type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
See Also

Reference

ISourceFile Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFile.TypeDefinitions Property

ISourceFileTypeDefinitions Property
Gets the collection of ITypeDefinition objects contained in the source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection TypeDefinitions { get; }
ReadOnly Property TypeDefinitions As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of ITypeDefinition objects contained in the source file.
See Also

Reference

ISourceFile Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Interface

ISourceFileCollection Interface
Provides the base requirements for a collection of ISourceFile objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISourceFileCollection : IKeyedObservableCollection<ISourceFile>,
    IObservableCollection<ISourceFile>, IList<ISourceFile>, ICollection<ISourceFile>,
    IEnumerable<ISourceFile>, IEnumerable
Public Interface ISourceFileCollection
    Inherits IKeyedObservableCollection(Of ISourceFile), IObservableCollection(Of ISourceFile),
    IList(Of ISourceFile), ICollection(Of ISourceFile), IEnumerable(Of ISourceFile),
    IEnumerable

The ISourceFileCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISourceFile .)
Public property | IsReadOnly | (Inherited from ICollection ISourceFile .)
Public property | ItemInt32 | (Inherited from IList ISourceFile .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add(T) | (Inherited from ICollection ISourceFile .)
Public method | Add(String, CompilationUnit) | Adds an ISourceFile for the specified CompilationUnit to the collection.
Public method | Clear | (Inherited from ICollection ISourceFile .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ISourceFile .)
Public method | CopyTo | (Inherited from ICollection ISourceFile .)
Public method | GetEnumerator | (Inherited from IEnumerable ISourceFile .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ISourceFile .)
Public method | Insert | (Inherited from IList ISourceFile .)
Public method | QueueCode | Queues parsing for the specified source code, and adds an ISourceFile for the result.
Public method | QueueFileAsync | Queues parsing for the specified file, and adds an ISourceFile for the result.
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ISourceFile .)
Public method | RemoveAt | (Inherited from IList ISourceFile .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Properties

ISourceFileCollection Properties

The ISourceFileCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISourceFile .)
Public property | IsReadOnly | (Inherited from ICollection ISourceFile .)
Public property | ItemInt32 | (Inherited from IList ISourceFile .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Methods

ISourceFileCollection Methods

The ISourceFileCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | (Inherited from ICollection ISourceFile .)
Public method | Add(String, CompilationUnit) | Adds an ISourceFile for the specified CompilationUnit to the collection.
Public method | Clear | (Inherited from ICollection ISourceFile .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ISourceFile .)
Public method | CopyTo | (Inherited from ICollection ISourceFile .)
Public method | GetEnumerator | (Inherited from IEnumerable ISourceFile .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ISourceFile .)
Public method | Insert | (Inherited from IList ISourceFile .)
Public method | QueueCode | Queues parsing for the specified source code, and adds an ISourceFile for the result.
Public method | QueueFileAsync | Queues parsing for the specified file, and adds an ISourceFile for the result.
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ISourceFile .)
Public method | RemoveAt | (Inherited from IList ISourceFile .)
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.Add Method

ISourceFileCollectionAdd Method
Overload List
 | Name | Description
Public method | Add(T) | (Inherited from ICollection ISourceFile .)
Public method | Add(String, CompilationUnit) | Adds an ISourceFile for the specified CompilationUnit to the collection.
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.Add Method (String, CompilationUnit)

ISourceFileCollectionAdd Method (String, CompilationUnit)
Adds an ISourceFile for the specified CompilationUnit to the collection.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISourceFile Add(
    string sourceFileKey,
    CompilationUnit compilationUnit
)
Function Add (
    sourceFileKey As String,
    compilationUnit As CompilationUnit
) As ISourceFile

Parameters

sourceFileKey
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
compilationUnit
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnit
The CompilationUnit to examine.

Return Value

Type: ISourceFile
The ISourceFile that was added.
See Also

Reference

ISourceFileCollection Interface
Add Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.QueueCode Method

ISourceFileCollectionQueueCode Method
Queues parsing for the specified source code, and adds an ISourceFile for the result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void QueueCode(
    ISyntaxLanguage language,
    string sourceFileKey,
    string text
)
Sub QueueCode (
    language As ISyntaxLanguage,
    sourceFileKey As String,
    text As String
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage containing an IParser service that will be used to parse the source code.
sourceFileKey
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
text
Type: SystemString
A string containing the source code to parse.
Remarks
The parsing operation will occur in a worker thread and will not block the calling thread as long as an Dispatcher has been configured.
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection.QueueFileAsync Method

ISourceFileCollectionQueueFileAsync Method
Queues parsing for the specified file, and adds an ISourceFile for the result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task QueueFileAsync(
    ISyntaxLanguage language,
    string path
)
Function QueueFileAsync (
    language As ISyntaxLanguage,
    path As String
) As Task

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage containing an IParser service that will be used to parse the file.
path
Type: SystemString
The absolute path of the file to load.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.ISourceFileCollection.QueueFileAsync(ActiproSoftware.Text.ISyntaxLanguage,System.String)"]

Remarks
The parsing operation will occur in a worker thread and will not block the calling thread as long as an Dispatcher has been configured.
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ISourceFileCollection Events

ISourceFileCollection Events

The ISourceFileCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ISourceFileCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition Interface

ITypeDefinition Interface
Provides the base requirements of a type definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeDefinition : IReflectionDefinition,
    ITypeReference
Public Interface ITypeDefinition
    Inherits IReflectionDefinition, ITypeReference

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility.
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array.
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested.
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code.
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type.
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAnonymous | Gets whether the current type is an anonymous type.
Public property | IsArray | Gets whether the current type is an array.
Public property | IsByReference | Gets whether the current type is passed by reference.
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods.
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed.
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor.
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type.
Public property | IsObsolete | Gets whether the current type is decorated as obsolete.
Public property | IsPointer | Gets whether the current type is a pointer.
Public property | IsSealed | Gets whether the current type is declared sealed.
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition.
Public property | Members | Gets the collection of members that are defined within the current type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type.
Public property | NamespaceDeclaration | Gets the INamespaceDeclaration that declared the current type, if the type came from a parsed source file.
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition Properties

ITypeDefinition Properties

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility.
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array.
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested.
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code.
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type.
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAnonymous | Gets whether the current type is an anonymous type.
Public property | IsArray | Gets whether the current type is an array.
Public property | IsByReference | Gets whether the current type is passed by reference.
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods.
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed.
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor.
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type.
Public property | IsObsolete | Gets whether the current type is decorated as obsolete.
Public property | IsPointer | Gets whether the current type is a pointer.
Public property | IsSealed | Gets whether the current type is declared sealed.
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition.
Public property | Members | Gets the collection of members that are defined within the current type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type.
Public property | NamespaceDeclaration | Gets the INamespaceDeclaration that declared the current type, if the type came from a parsed source file.
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition.
Top
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Access Property

ITypeDefinitionAccess Property
Gets a TypeAccess indicating the current type's access visibility.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TypeAccess Access { get; }
ReadOnly Property Access As TypeAccess
    Get

Property Value

Type: TypeAccess
A TypeAccess indicating the current type's access visibility.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.ArrayRank Property

ITypeDefinitionArrayRank Property
Gets the number of dimensions in the current type, if the type is an array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int ArrayRank { get; }
ReadOnly Property ArrayRank As Integer
    Get

Property Value

Type: Int32
The number of dimensions in the current type, if the type is an array.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.BaseTypes Property

ITypeDefinitionBaseTypes Property
Gets the collection of base types inherited/implemented by the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReferenceCollection BaseTypes { get; }
ReadOnly Property BaseTypes As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of base types inherited/implemented by the current type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.DeclaringType Property

ITypeDefinitionDeclaringType Property
Gets the type that declares the current type, if it is nested.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
An ITypeDefinition object representing the enclosing type, if the current type is a nested type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.DocumentationComment Property

ITypeDefinitionDocumentationComment Property
Gets the optional documentation comment, if the current type is defined in source code.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DocumentationComment { get; }
ReadOnly Property DocumentationComment As String
    Get

Property Value

Type: String
The optional documentation comment, if the current type is defined in source code.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.ElementType Property

ITypeDefinitionElementType Property
Gets the type of the object encompassed or referred to by the current array, pointer or reference type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition ElementType { get; }
ReadOnly Property ElementType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The type of the object encompassed or referred to by the current array, pointer, or reference type, or if the current type is not an array or a pointer, or is not passed by reference, or represents a generic type or a type parameter in the definition of a generic type or generic method.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.FullName Property

ITypeDefinitionFullName Property
Gets the fully qualified name of the type, including the namespace of the type but not the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The fully qualified name of the type, including the namespace of the type but not the assembly.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsAbstract Property

ITypeDefinitionIsAbstract Property
Gets whether the current type is abstract and must be overridden.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAbstract { get; }
ReadOnly Property IsAbstract As Boolean
    Get

Property Value

Type: Boolean
true if the current type is abstract and must be overridden; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsAdvanced Property

ITypeDefinitionIsAdvanced Property
Gets whether the current type is decorated such that it should only be visible to advanced users within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAdvanced { get; }
ReadOnly Property IsAdvanced As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated such that it should only be visible to advanced users within an editor; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsAnonymous Property

ITypeDefinitionIsAnonymous Property
Gets whether the current type is an anonymous type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAnonymous { get; }
ReadOnly Property IsAnonymous As Boolean
    Get

Property Value

Type: Boolean
true if the current type is an anonymous type; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsArray Property

ITypeDefinitionIsArray Property
Gets whether the current type is an array.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsArray { get; }
ReadOnly Property IsArray As Boolean
    Get

Property Value

Type: Boolean
true if the current type is an array; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsByReference Property

ITypeDefinitionIsByReference Property
Gets whether the current type is passed by reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsByReference { get; }
ReadOnly Property IsByReference As Boolean
    Get

Property Value

Type: Boolean
true if the current type is passed by reference; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsExtension Property

ITypeDefinitionIsExtension Property
Gets whether the current type is decorated as a static class that can contain extension methods.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsExtension { get; }
ReadOnly Property IsExtension As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated as a static class that can contain extension methods; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsGenericTypeDefinition Property

ITypeDefinitionIsGenericTypeDefinition Property
Gets whether the current type is a generic type definition, from which other generic types can be constructed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsGenericTypeDefinition { get; }
ReadOnly Property IsGenericTypeDefinition As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a generic type definition, from which other generic types can be constructed; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsHidden Property

ITypeDefinitionIsHidden Property
Gets whether the current type is decorated such that it should never be visible within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsHidden { get; }
ReadOnly Property IsHidden As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated such that it should never be visible within an editor; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsNested Property

ITypeDefinitionIsNested Property
Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsNested { get; }
ReadOnly Property IsNested As Boolean
    Get

Property Value

Type: Boolean
true if the Type is nested inside another type; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsObsolete Property

ITypeDefinitionIsObsolete Property
Gets whether the current type is decorated as obsolete.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsObsolete { get; }
ReadOnly Property IsObsolete As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated as obsolete; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsPointer Property

ITypeDefinitionIsPointer Property
Gets whether the current type is a pointer.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPointer { get; }
ReadOnly Property IsPointer As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a pointer; otherwise, False.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsSealed Property

ITypeDefinitionIsSealed Property
Gets whether the current type is declared sealed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsSealed { get; }
ReadOnly Property IsSealed As Boolean
    Get

Property Value

Type: Boolean
true if the current type is declared sealed; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.IsStandardModule Property

ITypeDefinitionIsStandardModule Property
Gets whether the current type is decorated as a standard module class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsStandardModule { get; }
ReadOnly Property IsStandardModule As Boolean
    Get

Property Value

Type: Boolean
true if the current type is decorated as a standard module class; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Kind Property

ITypeDefinitionKind Property
Gets a TypeDefinitionKind that indicates the kind of type definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TypeDefinitionKind Kind { get; }
ReadOnly Property Kind As TypeDefinitionKind
    Get

Property Value

Type: TypeDefinitionKind
A TypeDefinitionKind that indicates the kind of type definition.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Members Property

ITypeDefinitionMembers Property
Gets the collection of members that are defined within the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeMemberDefinitionCollection Members { get; }
ReadOnly Property Members As ITypeMemberDefinitionCollection
    Get

Property Value

Type: ITypeMemberDefinitionCollection
The collection of members that are defined within the current type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.Namespace Property

ITypeDefinitionNamespace Property
Gets the namespace of the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Namespace { get; }
ReadOnly Property Namespace As String
    Get

Property Value

Type: String
The namespace of the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.NamespaceDeclaration Property

ITypeDefinitionNamespaceDeclaration Property
Gets the INamespaceDeclaration that declared the current type, if the type came from a parsed source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDeclaration NamespaceDeclaration { get; }
ReadOnly Property NamespaceDeclaration As INamespaceDeclaration
    Get

Property Value

Type: INamespaceDeclaration
The INamespaceDeclaration that declared the current type, if the type came from a parsed source file.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.NestedTypes Property

ITypeDefinitionNestedTypes Property
Gets the collection of nested types that are defined within the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection NestedTypes { get; }
ReadOnly Property NestedTypes As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of nested types that are defined within the current type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinition.TypeParameters Property

ITypeDefinitionTypeParameters Property
Gets the collection of generic type parameters, when the current type is a generic type definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeParameterCollection TypeParameters { get; }
ReadOnly Property TypeParameters As ITypeParameterCollection
    Get

Property Value

Type: ITypeParameterCollection
The collection of generic type parameters, when the current type is a generic type definition.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Interface

ITypeDefinitionCollection Interface
Provides the base requirements for a collection of ITypeDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeDefinitionCollection : IObservableCollection<ITypeDefinition>,
    IList<ITypeDefinition>, ICollection<ITypeDefinition>, IEnumerable<ITypeDefinition>,
    IEnumerable
Public Interface ITypeDefinitionCollection
    Inherits IObservableCollection(Of ITypeDefinition), IList(Of ITypeDefinition),
    ICollection(Of ITypeDefinition), IEnumerable(Of ITypeDefinition), IEnumerable

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | (Inherited from IList ITypeDefinition .)
Public property | ItemString, Boolean | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeDefinition .)
Public method | Clear | (Inherited from ICollection ITypeDefinition .)
Public method | Contains | (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeDefinition .)
Public method | IndexOf | (Inherited from IList ITypeDefinition .)
Public method | Insert | (Inherited from IList ITypeDefinition .)
Public method | Remove | (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | (Inherited from IList ITypeDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Properties

ITypeDefinitionCollection Properties

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | (Inherited from IList ITypeDefinition .)
Public property | ItemString, Boolean | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection.Item Property

ITypeDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList ITypeDefinition .)
Public property | ItemString, Boolean | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection.Item Property (String, Boolean)

ITypeDefinitionCollectionItem Property (String, Boolean)
Gets the ITypeDefinition with the specified name.

[C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Property Item (
    name As String,
    caseSensitive As Boolean
) As ITypeDefinition
    Get

Parameters

name
Type: SystemString
The name of the ITypeDefinition to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: ITypeDefinition
The ITypeDefinition with the specified name.
See Also

Reference

ITypeDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Methods

ITypeDefinitionCollection Methods

The ITypeDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeDefinition .)
Public method | Clear | (Inherited from ICollection ITypeDefinition .)
Public method | Contains | (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeDefinition .)
Public method | IndexOf | (Inherited from IList ITypeDefinition .)
Public method | Insert | (Inherited from IList ITypeDefinition .)
Public method | Remove | (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | (Inherited from IList ITypeDefinition .)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeDefinitionCollection Events

ITypeDefinitionCollection Events

The ITypeDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition Interface

ITypeMemberDefinition Interface
Provides the base requirements of a type member (method, property, etc.) definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeMemberDefinition : ITypeMemberReference,
    IReflectionDefinition
Public Interface ITypeMemberDefinition
    Inherits ITypeMemberReference, IReflectionDefinition

The ITypeMemberDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeMemberAccess indicating the current member's access visibility.
Public property | DeclaringType | Gets the type that declares the current member.
Public property | DocumentationComment | Gets the optional documentation comment, if the current member is defined in source code.
Public property | ExtensionType | Gets the type that is implicitly used as a first argument, when an extension method is invoked.
Public property | IsAbstract | Gets whether the current member is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current member is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAsync | Gets whether the current member is designated as having an asynchronous result.
Public property | IsDefault | Gets whether the current member is the default member for the declaring type.
Public property | IsExtension | Gets whether the current member is decorated as an extension method.
Public property | IsFinal | Gets whether the current member is declared final.
Public property | IsGenericMethod | Gets whether the current member is a generic method. (Inherited from ITypeMemberReference.)
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed. (Inherited from ITypeMemberReference.)
Public property | IsHidden | Gets whether the current member is decorated such that it should never be visible within an editor.
Public property | IsImplicitDefaultConstructor | Gets whether the current member is an implicit default constructor.
Public property | IsLiteral | Gets whether the current member's value is written at compile time and cannot be changed.
Public property | IsObsolete | Gets whether the current member is decorated as obsolete.
Public property | IsReadOnly | Gets whether the current member is read-only.
Public property | IsStatic | Gets whether the current member is declared static.
Public property | IsVirtual | Gets whether the current member is virtual and can be overridden.
Public property | IsWriteOnly | Gets whether the current member is write-only.
Public property | Kind | Gets a TypeMemberDefinitionKind that indicates the kind of type member definition.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current member.
Public property | ReturnType | Gets the type that is returned by the current member.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method. (Inherited from ITypeMemberReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current member is a generic method definition.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition Properties

ITypeMemberDefinition Properties

The ITypeMemberDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeMemberAccess indicating the current member's access visibility.
Public property | DeclaringType | Gets the type that declares the current member.
Public property | DocumentationComment | Gets the optional documentation comment, if the current member is defined in source code.
Public property | ExtensionType | Gets the type that is implicitly used as a first argument, when an extension method is invoked.
Public property | IsAbstract | Gets whether the current member is abstract and must be overridden.
Public property | IsAdvanced | Gets whether the current member is decorated such that it should only be visible to advanced users within an editor.
Public property | IsAsync | Gets whether the current member is designated as having an asynchronous result.
Public property | IsDefault | Gets whether the current member is the default member for the declaring type.
Public property | IsExtension | Gets whether the current member is decorated as an extension method.
Public property | IsFinal | Gets whether the current member is declared final.
Public property | IsGenericMethod | Gets whether the current member is a generic method. (Inherited from ITypeMemberReference.)
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed. (Inherited from ITypeMemberReference.)
Public property | IsHidden | Gets whether the current member is decorated such that it should never be visible within an editor.
Public property | IsImplicitDefaultConstructor | Gets whether the current member is an implicit default constructor.
Public property | IsLiteral | Gets whether the current member's value is written at compile time and cannot be changed.
Public property | IsObsolete | Gets whether the current member is decorated as obsolete.
Public property | IsReadOnly | Gets whether the current member is read-only.
Public property | IsStatic | Gets whether the current member is declared static.
Public property | IsVirtual | Gets whether the current member is virtual and can be overridden.
Public property | IsWriteOnly | Gets whether the current member is write-only.
Public property | Kind | Gets a TypeMemberDefinitionKind that indicates the kind of type member definition.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current member.
Public property | ReturnType | Gets the type that is returned by the current member.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method. (Inherited from ITypeMemberReference.)
Public property | TypeParameters | Gets the collection of generic type parameters, when the current member is a generic method definition.
Top
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.Access Property

ITypeMemberDefinitionAccess Property
Gets a TypeMemberAccess indicating the current member's access visibility.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TypeMemberAccess Access { get; }
ReadOnly Property Access As TypeMemberAccess
    Get

Property Value

Type: TypeMemberAccess
A TypeMemberAccess indicating the current member's access visibility.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.DeclaringType Property

ITypeMemberDefinitionDeclaringType Property
Gets the type that declares the current member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
An ITypeDefinition object representing the enclosing type.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.DocumentationComment Property

ITypeMemberDefinitionDocumentationComment Property
Gets the optional documentation comment, if the current member is defined in source code.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DocumentationComment { get; }
ReadOnly Property DocumentationComment As String
    Get

Property Value

Type: String
The optional documentation comment, if the current member is defined in source code.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.ExtensionType Property

ITypeMemberDefinitionExtensionType Property
Gets the type that is implicitly used as a first argument, when an extension method is invoked.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition ExtensionType { get; }
ReadOnly Property ExtensionType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The type that is implicitly used as a first argument, when an extension method is invoked.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsAbstract Property

ITypeMemberDefinitionIsAbstract Property
Gets whether the current member is abstract and must be overridden.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAbstract { get; }
ReadOnly Property IsAbstract As Boolean
    Get

Property Value

Type: Boolean
true if the current member is abstract and must be overridden; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsAdvanced Property

ITypeMemberDefinitionIsAdvanced Property
Gets whether the current member is decorated such that it should only be visible to advanced users within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAdvanced { get; }
ReadOnly Property IsAdvanced As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated such that it should only be visible to advanced users within an editor; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsAsync Property

ITypeMemberDefinitionIsAsync Property
Gets whether the current member is designated as having an asynchronous result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAsync { get; }
ReadOnly Property IsAsync As Boolean
    Get

Property Value

Type: Boolean
true if the current member is designated as having an asynchronous result; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsDefault Property

ITypeMemberDefinitionIsDefault Property
Gets whether the current member is the default member for the declaring type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsDefault { get; }
ReadOnly Property IsDefault As Boolean
    Get

Property Value

Type: Boolean
true if the current member is the default member for the declaring type; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsExtension Property

ITypeMemberDefinitionIsExtension Property
Gets whether the current member is decorated as an extension method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsExtension { get; }
ReadOnly Property IsExtension As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated as an extension method; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsFinal Property

ITypeMemberDefinitionIsFinal Property
Gets whether the current member is declared final.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsFinal { get; }
ReadOnly Property IsFinal As Boolean
    Get

Property Value

Type: Boolean
true if the current member is declared final; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsHidden Property

ITypeMemberDefinitionIsHidden Property
Gets whether the current member is decorated such that it should never be visible within an editor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsHidden { get; }
ReadOnly Property IsHidden As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated such that it should never be visible within an editor; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsImplicitDefaultConstructor Property

ITypeMemberDefinitionIsImplicitDefaultConstructor Property
Gets whether the current member is an implicit default constructor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsImplicitDefaultConstructor { get; }
ReadOnly Property IsImplicitDefaultConstructor As Boolean
    Get

Property Value

Type: Boolean
true if the current member is an implicit default constructor; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsLiteral Property

ITypeMemberDefinitionIsLiteral Property
Gets whether the current member's value is written at compile time and cannot be changed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLiteral { get; }
ReadOnly Property IsLiteral As Boolean
    Get

Property Value

Type: Boolean
true if the current member's value is written at compile time and cannot be changed; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsObsolete Property

ITypeMemberDefinitionIsObsolete Property
Gets whether the current member is decorated as obsolete.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsObsolete { get; }
ReadOnly Property IsObsolete As Boolean
    Get

Property Value

Type: Boolean
true if the current member is decorated as obsolete; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsReadOnly Property

ITypeMemberDefinitionIsReadOnly Property
Gets whether the current member is read-only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the current member is read-only; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsStatic Property

ITypeMemberDefinitionIsStatic Property
Gets whether the current member is declared static.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get

Property Value

Type: Boolean
true if the current member is declared static; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsVirtual Property

ITypeMemberDefinitionIsVirtual Property
Gets whether the current member is virtual and can be overridden.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVirtual { get; }
ReadOnly Property IsVirtual As Boolean
    Get

Property Value

Type: Boolean
true if the current member is virtual and can be overridden; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.IsWriteOnly Property

ITypeMemberDefinitionIsWriteOnly Property
Gets whether the current member is write-only.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWriteOnly { get; }
ReadOnly Property IsWriteOnly As Boolean
    Get

Property Value

Type: Boolean
true if the current member is write-only; otherwise, false.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.Kind Property

ITypeMemberDefinitionKind Property
Gets a TypeMemberDefinitionKind that indicates the kind of type member definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TypeMemberDefinitionKind Kind { get; }
ReadOnly Property Kind As TypeMemberDefinitionKind
    Get

Property Value

Type: TypeMemberDefinitionKind
A TypeMemberDefinitionKind that indicates the kind of type member definition.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.Parameters Property

ITypeMemberDefinitionParameters Property
Gets the collection of parameters to the current member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParameterDefinitionCollection Parameters { get; }
ReadOnly Property Parameters As IParameterDefinitionCollection
    Get

Property Value

Type: IParameterDefinitionCollection
The collection of parameters to the current member.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.ReturnType Property

ITypeMemberDefinitionReturnType Property
Gets the type that is returned by the current member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReference ReturnType { get; }
ReadOnly Property ReturnType As ITypeReference
    Get

Property Value

Type: ITypeReference
The type that is returned by the current member.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinition.TypeParameters Property

ITypeMemberDefinitionTypeParameters Property
Gets the collection of generic type parameters, when the current member is a generic method definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeParameterCollection TypeParameters { get; }
ReadOnly Property TypeParameters As ITypeParameterCollection
    Get

Property Value

Type: ITypeParameterCollection
The collection of generic type parameters, when the current member is a generic method definition.
See Also

Reference

ITypeMemberDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Interface

ITypeMemberDefinitionCollection Interface
Provides the base requirements for a collection of ITypeMemberDefinition objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeMemberDefinitionCollection : IObservableCollection<ITypeMemberDefinition>,
    IList<ITypeMemberDefinition>, ICollection<ITypeMemberDefinition>, IEnumerable<ITypeMemberDefinition>,
    IEnumerable
Public Interface ITypeMemberDefinitionCollection
    Inherits IObservableCollection(Of ITypeMemberDefinition), IList(Of ITypeMemberDefinition),
    ICollection(Of ITypeMemberDefinition), IEnumerable(Of ITypeMemberDefinition), IEnumerable

The ITypeMemberDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeMemberDefinition .)
Public property | IsReadOnly | (Inherited from ICollection ITypeMemberDefinition .)
Public property | ItemInt32 | (Inherited from IList ITypeMemberDefinition .)
Public property | ItemString, Boolean | Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name. [C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeMemberDefinition .)
Public method | Clear | (Inherited from ICollection ITypeMemberDefinition .)
Public method | Contains | (Inherited from ICollection ITypeMemberDefinition .)
Public method | CopyTo | (Inherited from ICollection ITypeMemberDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeMemberDefinition .)
Public method | IndexOf | (Inherited from IList ITypeMemberDefinition .)
Public method | Insert | (Inherited from IList ITypeMemberDefinition .)
Public method | Remove | (Inherited from ICollection ITypeMemberDefinition .)
Public method | RemoveAt | (Inherited from IList ITypeMemberDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Properties

ITypeMemberDefinitionCollection Properties

The ITypeMemberDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeMemberDefinition .)
Public property | IsReadOnly | (Inherited from ICollection ITypeMemberDefinition .)
Public property | ItemInt32 | (Inherited from IList ITypeMemberDefinition .)
Public property | ItemString, Boolean | Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name. [C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection.Item Property

ITypeMemberDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList ITypeMemberDefinition .)
Public property | ItemString, Boolean | Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name. [C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection.Item Property (String, Boolean)

ITypeMemberDefinitionCollectionItem Property (String, Boolean)
Gets the collection of ITypeMemberDefinition objects with the specified name, since there may potentially be member overloads with the same name.

[C#] In C#, this property is the indexer for the ITypeMemberDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<ITypeMemberDefinition> this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Property Item (
    name As String,
    caseSensitive As Boolean
) As IEnumerable(Of ITypeMemberDefinition)
    Get

Parameters

name
Type: SystemString
The name of the ITypeMemberDefinition objects to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: IEnumerable ITypeMemberDefinition
The collection of ITypeMemberDefinition objects with the specified name.
See Also

Reference

ITypeMemberDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Methods

ITypeMemberDefinitionCollection Methods

The ITypeMemberDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeMemberDefinition .)
Public method | Clear | (Inherited from ICollection ITypeMemberDefinition .)
Public method | Contains | (Inherited from ICollection ITypeMemberDefinition .)
Public method | CopyTo | (Inherited from ICollection ITypeMemberDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeMemberDefinition .)
Public method | IndexOf | (Inherited from IList ITypeMemberDefinition .)
Public method | Insert | (Inherited from IList ITypeMemberDefinition .)
Public method | Remove | (Inherited from ICollection ITypeMemberDefinition .)
Public method | RemoveAt | (Inherited from IList ITypeMemberDefinition .)
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberDefinitionCollection Events

ITypeMemberDefinitionCollection Events

The ITypeMemberDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeMemberDefinitionCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference Interface

ITypeMemberReference Interface
Provides the base requirements of a type member (method, property, etc.) reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeMemberReference : IReflectionDefinition
Public Interface ITypeMemberReference
    Inherits IReflectionDefinition

The ITypeMemberReference type exposes the following members.

Properties
 | Name | Description
Public property | IsGenericMethod | Gets whether the current member is a generic method.
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference Properties

ITypeMemberReference Properties

The ITypeMemberReference type exposes the following members.

Properties
 | Name | Description
Public property | IsGenericMethod | Gets whether the current member is a generic method.
Public property | IsGenericMethodDefinition | Gets whether the current member is a generic method definition, from which other generic methods can be constructed.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current member is a constructed generic method.
Top
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference.IsGenericMethod Property

ITypeMemberReferenceIsGenericMethod Property
Gets whether the current member is a generic method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsGenericMethod { get; }
ReadOnly Property IsGenericMethod As Boolean
    Get

Property Value

Type: Boolean
true if the current member is a generic method; otherwise, false.
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference.IsGenericMethodDefinition Property

ITypeMemberReferenceIsGenericMethodDefinition Property
Gets whether the current member is a generic method definition, from which other generic methods can be constructed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsGenericMethodDefinition { get; }
ReadOnly Property IsGenericMethodDefinition As Boolean
    Get

Property Value

Type: Boolean
true if the current member is a generic method definition, from which other generic methods can be constructed; otherwise, false.
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeMemberReference.TypeArguments Property

ITypeMemberReferenceTypeArguments Property
Gets the collection of generic type arguments, when the current member is a constructed generic method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReferenceCollection TypeArguments { get; }
ReadOnly Property TypeArguments As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of generic type arguments, when the current member is a constructed generic method.
See Also

Reference

ITypeMemberReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter Interface

ITypeParameter Interface
Provides the base requirements of a generic type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeParameter : ITypeDefinition,
    IReflectionDefinition, ITypeReference
Public Interface ITypeParameter
    Inherits ITypeDefinition, IReflectionDefinition, ITypeReference

The ITypeParameter type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility. (Inherited from ITypeDefinition.)
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array. (Inherited from ITypeDefinition.)
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type. (Inherited from ITypeDefinition.)
Public property | DeclaringMember | Gets the type member that declares the current type parameter.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested. (Inherited from ITypeDefinition.)
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code. (Inherited from ITypeDefinition.)
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type. (Inherited from ITypeDefinition.)
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly. (Inherited from ITypeDefinition.)
Public property | HasDefaultConstructorConstraint | Gets whether a public parameterless constructor constraint is present.
Public property | HasNotNullableValueTypeConstraint | Gets whether a non-nullable value type constraint is present.
Public property | HasReferenceTypeConstraint | Gets whether a reference type constraint is present.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden. (Inherited from ITypeDefinition.)
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor. (Inherited from ITypeDefinition.)
Public property | IsAnonymous | Gets whether the current type is an anonymous type. (Inherited from ITypeDefinition.)
Public property | IsArray | Gets whether the current type is an array. (Inherited from ITypeDefinition.)
Public property | IsByReference | Gets whether the current type is passed by reference. (Inherited from ITypeDefinition.)
Public property | IsContravariant | Gets whether the type can be less derived than what is defined (in).
Public property | IsCovariant | Gets whether the type can be more derived than what is defined (out).
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods. (Inherited from ITypeDefinition.)
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed. (Inherited from ITypeDefinition.)
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor. (Inherited from ITypeDefinition.)
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type. (Inherited from ITypeDefinition.)
Public property | IsObsolete | Gets whether the current type is decorated as obsolete. (Inherited from ITypeDefinition.)
Public property | IsPointer | Gets whether the current type is a pointer. (Inherited from ITypeDefinition.)
Public property | IsSealed | Gets whether the current type is declared sealed. (Inherited from ITypeDefinition.)
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class. (Inherited from ITypeDefinition.)
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition. (Inherited from ITypeDefinition.)
Public property | Members | Gets the collection of members that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type. (Inherited from ITypeDefinition.)
Public property | NamespaceDeclaration | Gets the INamespaceDeclaration that declared the current type, if the type came from a parsed source file. (Inherited from ITypeDefinition.)
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameterPosition | Gets the zero-based index of the generic type parameter.
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition. (Inherited from ITypeDefinition.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter Properties

ITypeParameter Properties

The ITypeParameter type exposes the following members.

Properties
 | Name | Description
Public property | Access | Gets a TypeAccess indicating the current type's access visibility. (Inherited from ITypeDefinition.)
Public property | ArrayRank | Gets the number of dimensions in the current type, if the type is an array. (Inherited from ITypeDefinition.)
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known. (Inherited from ITypeReference.)
Public property | BaseTypes | Gets the collection of base types inherited/implemented by the current type. (Inherited from ITypeDefinition.)
Public property | DeclaringMember | Gets the type member that declares the current type parameter.
Public property | DeclaringType | Gets the type that declares the current type, if it is nested. (Inherited from ITypeDefinition.)
Public property | DocumentationComment | Gets the optional documentation comment, if the current type is defined in source code. (Inherited from ITypeDefinition.)
Public property | ElementType | Gets the type of the object encompassed or referred to by the current array, pointer or reference type. (Inherited from ITypeDefinition.)
Public property | FullName | Gets the fully qualified name of the type, including the namespace of the type but not the assembly. (Inherited from ITypeDefinition.)
Public property | HasDefaultConstructorConstraint | Gets whether a public parameterless constructor constraint is present.
Public property | HasNotNullableValueTypeConstraint | Gets whether a non-nullable value type constraint is present.
Public property | HasReferenceTypeConstraint | Gets whether a reference type constraint is present.
Public property | IsAbstract | Gets whether the current type is abstract and must be overridden. (Inherited from ITypeDefinition.)
Public property | IsAdvanced | Gets whether the current type is decorated such that it should only be visible to advanced users within an editor. (Inherited from ITypeDefinition.)
Public property | IsAnonymous | Gets whether the current type is an anonymous type. (Inherited from ITypeDefinition.)
Public property | IsArray | Gets whether the current type is an array. (Inherited from ITypeDefinition.)
Public property | IsByReference | Gets whether the current type is passed by reference. (Inherited from ITypeDefinition.)
Public property | IsContravariant | Gets whether the type can be less derived than what is defined (in).
Public property | IsCovariant | Gets whether the type can be more derived than what is defined (out).
Public property | IsExtension | Gets whether the current type is decorated as a static class that can contain extension methods. (Inherited from ITypeDefinition.)
Public property | IsGenericType | Gets whether the current type is a generic type. (Inherited from ITypeReference.)
Public property | IsGenericTypeDefinition | Gets whether the current type is a generic type definition, from which other generic types can be constructed. (Inherited from ITypeDefinition.)
Public property | IsHidden | Gets whether the current type is decorated such that it should never be visible within an editor. (Inherited from ITypeDefinition.)
Public property | IsNested | Gets a value indicating whether the current type object represents a type whose definition is nested inside the definition of another type. (Inherited from ITypeDefinition.)
Public property | IsObsolete | Gets whether the current type is decorated as obsolete. (Inherited from ITypeDefinition.)
Public property | IsPointer | Gets whether the current type is a pointer. (Inherited from ITypeDefinition.)
Public property | IsSealed | Gets whether the current type is declared sealed. (Inherited from ITypeDefinition.)
Public property | IsStandardModule | Gets whether the current type is decorated as a standard module class. (Inherited from ITypeDefinition.)
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed. (Inherited from ITypeReference.)
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter. (Inherited from ITypeReference.)
Public property | Kind | Gets a TypeDefinitionKind that indicates the kind of type definition. (Inherited from ITypeDefinition.)
Public property | Members | Gets the collection of members that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Namespace | Gets the namespace of the type. (Inherited from ITypeDefinition.)
Public property | NamespaceDeclaration | Gets the INamespaceDeclaration that declared the current type, if the type came from a parsed source file. (Inherited from ITypeDefinition.)
Public property | NestedTypes | Gets the collection of nested types that are defined within the current type. (Inherited from ITypeDefinition.)
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type. (Inherited from ITypeReference.)
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type. (Inherited from ITypeReference.)
Public property | TypeParameterPosition | Gets the zero-based index of the generic type parameter.
Public property | TypeParameters | Gets the collection of generic type parameters, when the current type is a generic type definition. (Inherited from ITypeDefinition.)
Top
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.DeclaringMember Property

ITypeParameterDeclaringMember Property
Gets the type member that declares the current type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeMemberDefinition DeclaringMember { get; }
ReadOnly Property DeclaringMember As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
An ITypeMemberDefinition object representing the type member that declares the current type parameter.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.HasDefaultConstructorConstraint Property

ITypeParameterHasDefaultConstructorConstraint Property
Gets whether a public parameterless constructor constraint is present.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasDefaultConstructorConstraint { get; }
ReadOnly Property HasDefaultConstructorConstraint As Boolean
    Get

Property Value

Type: Boolean
true if a public parameterless constructor constraint is present; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.HasNotNullableValueTypeConstraint Property

ITypeParameterHasNotNullableValueTypeConstraint Property
Gets whether a non-nullable value type constraint is present.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasNotNullableValueTypeConstraint { get; }
ReadOnly Property HasNotNullableValueTypeConstraint As Boolean
    Get

Property Value

Type: Boolean
true if a non-nullable value type constraint is present; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.HasReferenceTypeConstraint Property

ITypeParameterHasReferenceTypeConstraint Property
Gets whether a reference type constraint is present.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasReferenceTypeConstraint { get; }
ReadOnly Property HasReferenceTypeConstraint As Boolean
    Get

Property Value

Type: Boolean
true if a reference type constraint is present; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.IsContravariant Property

ITypeParameterIsContravariant Property
Gets whether the type can be less derived than what is defined (in).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsContravariant { get; }
ReadOnly Property IsContravariant As Boolean
    Get

Property Value

Type: Boolean
true if the type can be less derived than what is defined; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.IsCovariant Property

ITypeParameterIsCovariant Property
Gets whether the type can be more derived than what is defined (out).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsCovariant { get; }
ReadOnly Property IsCovariant As Boolean
    Get

Property Value

Type: Boolean
true if the type can be more derived than what is defined; otherwise, false.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameter.TypeParameterPosition Property

ITypeParameterTypeParameterPosition Property
Gets the zero-based index of the generic type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int TypeParameterPosition { get; }
ReadOnly Property TypeParameterPosition As Integer
    Get

Property Value

Type: Int32
The zero-based index of the generic type parameter.
See Also

Reference

ITypeParameter Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Interface

ITypeParameterCollection Interface
Provides the base requirements for a collection of ITypeParameter objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeParameterCollection : IObservableCollection<ITypeParameter>,
    IList<ITypeParameter>, ICollection<ITypeParameter>, IEnumerable<ITypeParameter>,
    IEnumerable
Public Interface ITypeParameterCollection
    Inherits IObservableCollection(Of ITypeParameter), IList(Of ITypeParameter),
    ICollection(Of ITypeParameter), IEnumerable(Of ITypeParameter), IEnumerable

The ITypeParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeParameter .)
Public property | IsReadOnly | (Inherited from ICollection ITypeParameter .)
Public property | ItemInt32 | (Inherited from IList ITypeParameter .)
Public property | ItemString, Boolean | Gets the ITypeParameter with the specified name. [C#] In C#, this property is the indexer for the ITypeParameterCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeParameter .)
Public method | Clear | (Inherited from ICollection ITypeParameter .)
Public method | Contains | (Inherited from ICollection ITypeParameter .)
Public method | CopyTo | (Inherited from ICollection ITypeParameter .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeParameter .)
Public method | IndexOf | (Inherited from IList ITypeParameter .)
Public method | Insert | (Inherited from IList ITypeParameter .)
Public method | Remove | (Inherited from ICollection ITypeParameter .)
Public method | RemoveAt | (Inherited from IList ITypeParameter .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Properties

ITypeParameterCollection Properties

The ITypeParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeParameter .)
Public property | IsReadOnly | (Inherited from ICollection ITypeParameter .)
Public property | ItemInt32 | (Inherited from IList ITypeParameter .)
Public property | ItemString, Boolean | Gets the ITypeParameter with the specified name. [C#] In C#, this property is the indexer for the ITypeParameterCollection interface.
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection.Item Property

ITypeParameterCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList ITypeParameter .)
Public property | ItemString, Boolean | Gets the ITypeParameter with the specified name. [C#] In C#, this property is the indexer for the ITypeParameterCollection interface.
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection.Item Property (String, Boolean)

ITypeParameterCollectionItem Property (String, Boolean)
Gets the ITypeParameter with the specified name.

[C#] In C#, this property is the indexer for the ITypeParameterCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeParameter this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Property Item (
    name As String,
    caseSensitive As Boolean
) As ITypeParameter
    Get

Parameters

name
Type: SystemString
The name of the ITypeParameter to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: ITypeParameter
The ITypeParameter with the specified name.
See Also

Reference

ITypeParameterCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Methods

ITypeParameterCollection Methods

The ITypeParameterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeParameter .)
Public method | Clear | (Inherited from ICollection ITypeParameter .)
Public method | Contains | (Inherited from ICollection ITypeParameter .)
Public method | CopyTo | (Inherited from ICollection ITypeParameter .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeParameter .)
Public method | IndexOf | (Inherited from IList ITypeParameter .)
Public method | Insert | (Inherited from IList ITypeParameter .)
Public method | Remove | (Inherited from ICollection ITypeParameter .)
Public method | RemoveAt | (Inherited from IList ITypeParameter .)
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeParameterCollection Events

ITypeParameterCollection Events

The ITypeParameterCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeParameterCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference Interface

ITypeReference Interface
Provides the base requirements of a type reference.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeReference
Public Interface ITypeReference

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known.
Public property | IsGenericType | Gets whether the current type is a generic type.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed.
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference Properties

ITypeReference Properties

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName | Gets the IAssemblyName of the assembly in which this type is defined, if known.
Public property | IsGenericType | Gets whether the current type is a generic type.
Public property | IsTypeDefinition | Gets whether the current type is a type definition, from which other types can be constructed.
Public property | IsTypeParameter | Gets whether the current type is a generic type parameter.
Public property | QualifiedName | Gets the IQualifiedName that indicates the qualified name of the current type.
Public property | TypeArguments | Gets the collection of generic type arguments, when the current type is a constructed generic type.
Top
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.AssemblyName Property

ITypeReferenceAssemblyName Property
Gets the IAssemblyName of the assembly in which this type is defined, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAssemblyName AssemblyName { get; }
ReadOnly Property AssemblyName As IAssemblyName
    Get

Property Value

Type: IAssemblyName
The IAssemblyName of the assembly in which this type is defined, if known.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.IsGenericType Property

ITypeReferenceIsGenericType Property
Gets whether the current type is a generic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsGenericType { get; }
ReadOnly Property IsGenericType As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a generic type; otherwise, false.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.IsTypeDefinition Property

ITypeReferenceIsTypeDefinition Property
Gets whether the current type is a type definition, from which other types can be constructed.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsTypeDefinition { get; }
ReadOnly Property IsTypeDefinition As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a type definition, from which other types can be constructed; otherwise, false.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.IsTypeParameter Property

ITypeReferenceIsTypeParameter Property
Gets whether the current type is a generic type parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsTypeParameter { get; }
ReadOnly Property IsTypeParameter As Boolean
    Get

Property Value

Type: Boolean
true if the current type is a generic type parameter; otherwise, False.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.QualifiedName Property

ITypeReferenceQualifiedName Property
Gets the IQualifiedName that indicates the qualified name of the current type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IQualifiedName QualifiedName { get; }
ReadOnly Property QualifiedName As IQualifiedName
    Get

Property Value

Type: IQualifiedName
The IQualifiedName that indicates the qualified name of the current type.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReference.TypeArguments Property

ITypeReferenceTypeArguments Property
Gets the collection of generic type arguments, when the current type is a constructed generic type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReferenceCollection TypeArguments { get; }
ReadOnly Property TypeArguments As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of generic type arguments, when the current type is a constructed generic type.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Interface

ITypeReferenceCollection Interface
Provides the base requirements for a collection of ITypeReference objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeReferenceCollection : IObservableCollection<ITypeReference>,
    IList<ITypeReference>, ICollection<ITypeReference>, IEnumerable<ITypeReference>,
    IEnumerable
Public Interface ITypeReferenceCollection
    Inherits IObservableCollection(Of ITypeReference), IList(Of ITypeReference),
    ICollection(Of ITypeReference), IEnumerable(Of ITypeReference), IEnumerable

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | (Inherited from IList ITypeReference .)
Public property | ItemString, Boolean | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeReference .)
Public method | Clear | (Inherited from ICollection ITypeReference .)
Public method | Contains | (Inherited from ICollection ITypeReference .)
Public method | CopyTo | (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeReference .)
Public method | IndexOf | (Inherited from IList ITypeReference .)
Public method | Insert | (Inherited from IList ITypeReference .)
Public method | Remove | (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | (Inherited from IList ITypeReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Properties

ITypeReferenceCollection Properties

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | (Inherited from IList ITypeReference .)
Public property | ItemString, Boolean | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection.Item Property

ITypeReferenceCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList ITypeReference .)
Public property | ItemString, Boolean | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection.Item Property (String, Boolean)

ITypeReferenceCollectionItem Property (String, Boolean)
Gets the ITypeReference with the specified name.

[C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReference this[
    string name,
    bool caseSensitive
] { get; }
ReadOnly Property Item (
    name As String,
    caseSensitive As Boolean
) As ITypeReference
    Get

Parameters

name
Type: SystemString
The name of the ITypeReference to return.
caseSensitive
Type: SystemBoolean
Whether to perform a case-sensitive name search.

Property Value

Type: ITypeReference
The ITypeReference with the specified name.
See Also

Reference

ITypeReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Methods

ITypeReferenceCollection Methods

The ITypeReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeReference .)
Public method | Clear | (Inherited from ICollection ITypeReference .)
Public method | Contains | (Inherited from ICollection ITypeReference .)
Public method | CopyTo | (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeReference .)
Public method | IndexOf | (Inherited from IList ITypeReference .)
Public method | Insert | (Inherited from IList ITypeReference .)
Public method | Remove | (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | (Inherited from IList ITypeReference .)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ITypeReferenceCollection Events

ITypeReferenceCollection Events

The ITypeReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective Interface

IUsingDirective Interface
Provides the base requirements of an using directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IUsingDirective
Public Interface IUsingDirective

The IUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the qualified name of the namespace imported by the using directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective Properties

IUsingDirective Properties

The IUsingDirective type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the qualified name of the namespace imported by the using directive.
Top
See Also

Reference

IUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IUsingDirective.Name Property

IUsingDirectiveName Property
Gets the qualified name of the namespace imported by the using directive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IQualifiedName Name { get; }
ReadOnly Property Name As IQualifiedName
    Get

Property Value

Type: IQualifiedName
The qualified name of the namespace imported by the using directive.
See Also

Reference

IUsingDirective Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition Interface

IVariableDefinition Interface
Provides the base requirements of a variable definition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IVariableDefinition : IReflectionDefinition
Public Interface IVariableDefinition
    Inherits IReflectionDefinition

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current variable.
Public property | IsRangeVariable | Gets whether the variable is a LINQ range variable.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the variable type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition Properties

IVariableDefinition Properties

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringMember | Gets the type member that declares the current variable.
Public property | IsRangeVariable | Gets whether the variable is a LINQ range variable.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets an ITypeReference for the variable type.
Top
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.DeclaringMember Property

IVariableDefinitionDeclaringMember Property
Gets the type member that declares the current variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeMemberDefinition DeclaringMember { get; }
ReadOnly Property DeclaringMember As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
An ITypeMemberDefinition object representing the type member that declares the current variable.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.IsRangeVariable Property

IVariableDefinitionIsRangeVariable Property
Gets whether the variable is a LINQ range variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsRangeVariable { get; }
ReadOnly Property IsRangeVariable As Boolean
    Get

Property Value

Type: Boolean
true if the variable is a LINQ range variable; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


IVariableDefinition.Type Property

IVariableDefinitionType Property
Gets an ITypeReference for the variable type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReference Type { get; }
ReadOnly Property Type As ITypeReference
    Get

Property Value

Type: ITypeReference
An ITypeReference for the variable type.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess Class

TypeAccess Class
Specifies the type of access visibility for an ITypeDefinition.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.ReflectionTypeAccess

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class TypeAccess : Enum
<FlagsAttribute>
Public NotInheritable Class TypeAccess
    Inherits Enum

The TypeAccess type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Assembly | Visible only within its own assembly (internal).
 | Family | Visible only within its own declaring type family (protected).
 | FamilyOrAssembly | Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).
 | Private | Visible only within its declaring type.
 | Public | Visible to all.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess Methods

TypeAccess Methods

The TypeAccess type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess Fields

TypeAccess Fields

The TypeAccess type exposes the following members.

Fields
 | Name | Description
 | Assembly | Visible only within its own assembly (internal).
 | Family | Visible only within its own declaring type family (protected).
 | FamilyOrAssembly | Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).
 | Private | Visible only within its declaring type.
 | Public | Visible to all.
Public field | value__ |
Top
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess.Assembly Field

TypeAccessAssembly Field
Visible only within its own assembly (internal).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeAccess Assembly = 2
Public Const Assembly As TypeAccess = 2

Field Value

Type: TypeAccess
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess.Family Field

TypeAccessFamily Field
Visible only within its own declaring type family (protected).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeAccess Family = 4
Public Const Family As TypeAccess = 4

Field Value

Type: TypeAccess
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess.FamilyOrAssembly Field

TypeAccessFamilyOrAssembly Field
Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeAccess FamilyOrAssembly = 8
Public Const FamilyOrAssembly As TypeAccess = 8

Field Value

Type: TypeAccess
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess.Private Field

TypeAccessPrivate Field
Visible only within its declaring type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeAccess Private = 1
Public Const Private As TypeAccess = 1

Field Value

Type: TypeAccess
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess.Public Field

TypeAccessPublic Field
Visible to all.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeAccess Public = 16
Public Const Public As TypeAccess = 16

Field Value

Type: TypeAccess
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeAccess.value__ Field

TypeAccessvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Reflection.TypeAccess.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TypeAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind Class

TypeDefinitionKind Class
Specifies the kind of ITypeDefinition.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.ReflectionTypeDefinitionKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TypeDefinitionKind : Enum
Public NotInheritable Class TypeDefinitionKind
    Inherits Enum

The TypeDefinitionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Class | A class.
 | Delegate | A delegate.
 | Enumeration | An enumeration.
 | Interface | An interface.
 | Structure | A structure.
 | Unknown | An unknown kind.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind Methods

TypeDefinitionKind Methods

The TypeDefinitionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind Fields

TypeDefinitionKind Fields

The TypeDefinitionKind type exposes the following members.

Fields
 | Name | Description
 | Class | A class.
 | Delegate | A delegate.
 | Enumeration | An enumeration.
 | Interface | An interface.
 | Structure | A structure.
 | Unknown | An unknown kind.
Public field | value__ |
Top
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.Class Field

TypeDefinitionKindClass Field
A class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDefinitionKind Class = 1
Public Const Class As TypeDefinitionKind = 1

Field Value

Type: TypeDefinitionKind
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.Delegate Field

TypeDefinitionKindDelegate Field
A delegate.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDefinitionKind Delegate = 2
Public Const Delegate As TypeDefinitionKind = 2

Field Value

Type: TypeDefinitionKind
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.Enumeration Field

TypeDefinitionKindEnumeration Field
An enumeration.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDefinitionKind Enumeration = 3
Public Const Enumeration As TypeDefinitionKind = 3

Field Value

Type: TypeDefinitionKind
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.Interface Field

TypeDefinitionKindInterface Field
An interface.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDefinitionKind Interface = 4
Public Const Interface As TypeDefinitionKind = 4

Field Value

Type: TypeDefinitionKind
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.Structure Field

TypeDefinitionKindStructure Field
A structure.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDefinitionKind Structure = 5
Public Const Structure As TypeDefinitionKind = 5

Field Value

Type: TypeDefinitionKind
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.Unknown Field

TypeDefinitionKindUnknown Field
An unknown kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeDefinitionKind Unknown = 0
Public Const Unknown As TypeDefinitionKind = 0

Field Value

Type: TypeDefinitionKind
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeDefinitionKind.value__ Field

TypeDefinitionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Reflection.TypeDefinitionKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TypeDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess Class

TypeMemberAccess Class
Specifies the type of access visibility for an ITypeMemberDefinition.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.ReflectionTypeMemberAccess

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class TypeMemberAccess : Enum
<FlagsAttribute>
Public NotInheritable Class TypeMemberAccess
    Inherits Enum

The TypeMemberAccess type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Assembly | Visible only within its own assembly (internal).
 | Family | Visible only within its own declaring type family (protected).
 | FamilyOrAssembly | Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).
 | Private | Visible only within its declaring type.
 | Public | Visible to all.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess Methods

TypeMemberAccess Methods

The TypeMemberAccess type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess Fields

TypeMemberAccess Fields

The TypeMemberAccess type exposes the following members.

Fields
 | Name | Description
 | Assembly | Visible only within its own assembly (internal).
 | Family | Visible only within its own declaring type family (protected).
 | FamilyOrAssembly | Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).
 | Private | Visible only within its declaring type.
 | Public | Visible to all.
Public field | value__ |
Top
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess.Assembly Field

TypeMemberAccessAssembly Field
Visible only within its own assembly (internal).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberAccess Assembly = 2
Public Const Assembly As TypeMemberAccess = 2

Field Value

Type: TypeMemberAccess
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess.Family Field

TypeMemberAccessFamily Field
Visible only within its own declaring type family (protected).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberAccess Family = 4
Public Const Family As TypeMemberAccess = 4

Field Value

Type: TypeMemberAccess
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess.FamilyOrAssembly Field

TypeMemberAccessFamilyOrAssembly Field
Visible only to types that belong to either its own declaring type family or to its own assembly (protected internal).

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberAccess FamilyOrAssembly = 8
Public Const FamilyOrAssembly As TypeMemberAccess = 8

Field Value

Type: TypeMemberAccess
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess.Private Field

TypeMemberAccessPrivate Field
Visible only within its declaring type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberAccess Private = 1
Public Const Private As TypeMemberAccess = 1

Field Value

Type: TypeMemberAccess
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess.Public Field

TypeMemberAccessPublic Field
Visible to all.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberAccess Public = 16
Public Const Public As TypeMemberAccess = 16

Field Value

Type: TypeMemberAccess
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberAccess.value__ Field

TypeMemberAccessvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Reflection.TypeMemberAccess.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TypeMemberAccess Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind Class

TypeMemberDefinitionKind Class
Specifies the kind of ITypeMemberDefinition.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.ReflectionTypeMemberDefinitionKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TypeMemberDefinitionKind : Enum
Public NotInheritable Class TypeMemberDefinitionKind
    Inherits Enum

The TypeMemberDefinitionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Constructor | A constructor.
 | Event | An event.
 | Field | A field.
 | Method | A method.
 | Operator | An operator.
 | Property | A property.
 | Unknown | An unknown kind.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind Methods

TypeMemberDefinitionKind Methods

The TypeMemberDefinitionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind Fields

TypeMemberDefinitionKind Fields

The TypeMemberDefinitionKind type exposes the following members.

Fields
 | Name | Description
 | Constructor | A constructor.
 | Event | An event.
 | Field | A field.
 | Method | A method.
 | Operator | An operator.
 | Property | A property.
 | Unknown | An unknown kind.
Public field | value__ |
Top
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Constructor Field

TypeMemberDefinitionKindConstructor Field
A constructor.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Constructor = 1
Public Const Constructor As TypeMemberDefinitionKind = 1

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Event Field

TypeMemberDefinitionKindEvent Field
An event.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Event = 2
Public Const Event As TypeMemberDefinitionKind = 2

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Field Field

TypeMemberDefinitionKindField Field
A field.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Field = 3
Public Const Field As TypeMemberDefinitionKind = 3

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Method Field

TypeMemberDefinitionKindMethod Field
A method.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Method = 4
Public Const Method As TypeMemberDefinitionKind = 4

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Operator Field

TypeMemberDefinitionKindOperator Field
An operator.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Operator = 5
Public Const Operator As TypeMemberDefinitionKind = 5

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Property Field

TypeMemberDefinitionKindProperty Field
A property.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Property = 6
Public Const Property As TypeMemberDefinitionKind = 6

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.Unknown Field

TypeMemberDefinitionKindUnknown Field
An unknown kind.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TypeMemberDefinitionKind Unknown = 0
Public Const Unknown As TypeMemberDefinitionKind = 0

Field Value

Type: TypeMemberDefinitionKind
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


TypeMemberDefinitionKind.value__ Field

TypeMemberDefinitionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Reflection.TypeMemberDefinitionKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TypeMemberDefinitionKind Class
ActiproSoftware.Text.Languages.DotNet.Reflection Namespace


ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace
Contains the implementation types related to reflection for a .NET syntax language.
Classes
 | Class | Description
Public class | AssemblyName | Stores an IAssembly name.
Public class | AssemblyRepositoryBase | Provides the abstract base class for an IAssemblyRepository implementation.
Public class | BinaryAssemblySerializer | Serializes and deserializes IBinaryAssembly objects.
Public class | DocumentationProvider | Returns documentation for a .NET type or member definition.
Public class | FileAssemblyDocumentation | Provides an assembly documentation source from a file on the hard drive.
Public class | FileBasedAssemblyRepository | Represents an IAssemblyRepository that can cache data in the file system.
Public class | ProjectAssembly | Represents a project (source code-based) assembly.
Public class | QualifiedName | Represents a qualified name.
Public class | SimpleName | Represents a simple name with optional type arguments, which is a component of an IQualifiedName.
Public class | SourceFile | Represents a source code file that can be loaded by an IProjectAssembly.
Public class | StreamAssemblyDocumentationBase | Provides an abstract base class for a Stream-based assembly documentation source.


AssemblyName Class

AssemblyName Class
Stores an IAssembly name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationAssemblyName

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AssemblyName : IAssemblyName
Public Class AssemblyName
    Implements IAssemblyName

The AssemblyName type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyName(AssemblyName) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String, Version) | Initializes a new instance of the AssemblyName class.
Top
Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ParseFullName | Creates a new instance of the AssemblyName class based on the specified assembly full name.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor

AssemblyName Constructor
Overload List
 | Name | Description
Public method | AssemblyName(AssemblyName) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String) | Initializes a new instance of the AssemblyName class.
Public method | AssemblyName(String, Version) | Initializes a new instance of the AssemblyName class.
Top
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor (AssemblyName)

AssemblyName Constructor (AssemblyName)
Initializes a new instance of the AssemblyName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssemblyName(
    AssemblyName assemblyName
)
Public Sub New (
    assemblyName As AssemblyName
)

Parameters

assemblyName
Type: System.ReflectionAssemblyName
The system reflection AssemblyName to examine.
See Also

Reference

AssemblyName Class
AssemblyName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor (String)

AssemblyName Constructor (String)
Initializes a new instance of the AssemblyName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssemblyName(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

AssemblyName Class
AssemblyName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Constructor (String, Version)

AssemblyName Constructor (String, Version)
Initializes a new instance of the AssemblyName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssemblyName(
    string name,
    Version version
)
Public Sub New (
    name As String,
    version As Version
)

Parameters

name
Type: SystemString
The simple name of the assembly.
version
Type: SystemVersion
The major, minor, build, and revision numbers of the assembly.
See Also

Reference

AssemblyName Class
AssemblyName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Properties

AssemblyName Properties

The AssemblyName type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets the full name of the assembly, also known as the display name.
Public property | Name | Gets the simple name of the assembly.
Public property | Version | Gets the major, minor, build, and revision numbers of the assembly.
Top
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.FullName Property

AssemblyNameFullName Property
Gets the full name of the assembly, also known as the display name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the assembly, also known as the display name.

Implements

IAssemblyNameFullName
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.Name Property

AssemblyNameName Property
Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.

Implements

IAssemblyNameName
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.Version Property

AssemblyNameVersion Property
Gets the major, minor, build, and revision numbers of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get

Property Value

Type: Version
The major, minor, build, and revision numbers of the assembly.

Implements

IAssemblyNameVersion
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName Methods

AssemblyName Methods

The AssemblyName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | ParseFullName | Creates a new instance of the AssemblyName class based on the specified assembly full name.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.Equals Method

AssemblyNameEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.GetHashCode Method

AssemblyNameGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.ParseFullName Method

AssemblyNameParseFullName Method
Creates a new instance of the AssemblyName class based on the specified assembly full name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AssemblyName ParseFullName(
    string fullName
)
Public Shared Function ParseFullName (
    fullName As String
) As AssemblyName

Parameters

fullName
Type: SystemString
The assembly full name to examine.

Return Value

Type: AssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyName.ParseFullName(System.String)"]

See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyName.ToString Method

AssemblyNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

AssemblyName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Class

AssemblyRepositoryBase Class
Provides the abstract base class for an IAssemblyRepository implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationAssemblyRepositoryBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileBasedAssemblyRepository

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class AssemblyRepositoryBase : IAssemblyRepository
Public MustInherit Class AssemblyRepositoryBase
    Implements IAssemblyRepository

The AssemblyRepositoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AssemblyRepositoryBase | Initializes a new instance of the AssemblyRepositoryBase class
Top
Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetOrCreateAsync | Gets an existing or creates a new IBinaryAssembly for the specified Assembly.
Public method | GetType | (Inherited from Object.)
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PruneCacheAsync | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Constructor

AssemblyRepositoryBase Constructor
Initializes a new instance of the AssemblyRepositoryBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AssemblyRepositoryBase()
Protected Sub New
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase Methods

AssemblyRepositoryBase Methods

The AssemblyRepositoryBase type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly.
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetOrCreateAsync | Gets an existing or creates a new IBinaryAssembly for the specified Assembly.
Public method | GetType | (Inherited from Object.)
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PruneCacheAsync | Deletes any cache data that is no longer valid.
Public method | Remove | Removes a reference to an IBinaryAssembly.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Add Method

AssemblyRepositoryBaseAdd Method
Adds a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Add(
    IBinaryAssembly assembly
)
Public MustOverride Sub Add (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is referenced.

Implements

IAssemblyRepositoryAdd(IBinaryAssembly)
Remarks
The specified assembly will be tracked while there are remaining references to it. While tracked, the various [!:Load(string)] methods will return the already-loaded instance when appropriate.
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Create Method

AssemblyRepositoryBaseCreate Method
Creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IBinaryAssembly Create(
    Assembly assembly,
    IAssemblyName assemblyName,
    IBinaryAssemblyMetadata metadata
)
Protected Overridable Function Create (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    metadata As IBinaryAssemblyMetadata
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata.

Return Value

Type: IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyRepositoryBase.Create(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,ActiproSoftware.Text.Languages.DotNet.Reflection.IBinaryAssemblyMetadata)"]

See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.GetOrCreateAsync Method

AssemblyRepositoryBaseGetOrCreateAsync Method
Gets an existing or creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Task<IBinaryAssembly> GetOrCreateAsync(
    Assembly assembly,
    IAssemblyName assemblyName,
    string location
)
Protected MustOverride Function GetOrCreateAsync (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    location As String
) As Task(Of IBinaryAssembly)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
location
Type: SystemString
The assembly location, if known.

Return Value

Type: Task IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyRepositoryBase.GetOrCreateAsync(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,System.String)"]

See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.LoadAsync Method

AssemblyRepositoryBaseLoadAsync Method
Overload List
 | Name | Description
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly.
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name.
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.
Top
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.LoadAsync Method (Assembly)

AssemblyRepositoryBaseLoadAsync Method (Assembly)
Creates a new IBinaryAssembly instance from the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<IBinaryAssembly> LoadAsync(
    Assembly assembly
)
Public Function LoadAsync (
    assembly As Assembly
) As Task(Of IBinaryAssembly)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.

Return Value

Type: Task IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoadAsync(Assembly)
See Also

Reference

AssemblyRepositoryBase Class
LoadAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.LoadAsync Method (String)

AssemblyRepositoryBaseLoadAsync Method (String)
Creates a new IBinaryAssembly instance from the specified Assembly name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<IBinaryAssembly> LoadAsync(
    string fullName
)
Public Function LoadAsync (
    fullName As String
) As Task(Of IBinaryAssembly)

Parameters

fullName
Type: SystemString
The Assembly full name for which to load.

Return Value

Type: Task IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoadAsync(String)
See Also

Reference

AssemblyRepositoryBase Class
LoadAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.LoadAsync Method (Assembly, IAssemblyName)

AssemblyRepositoryBaseLoadAsync Method (Assembly, IAssemblyName)
Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<IBinaryAssembly> LoadAsync(
    Assembly assembly,
    IAssemblyName assemblyName
)
Public Function LoadAsync (
    assembly As Assembly,
    assemblyName As IAssemblyName
) As Task(Of IBinaryAssembly)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The alternate AssemblyName to use.

Return Value

Type: Task IBinaryAssembly
The IBinaryAssembly that was created.

Implements

IAssemblyRepositoryLoadAsync(Assembly, IAssemblyName)
See Also

Reference

AssemblyRepositoryBase Class
LoadAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.PruneCacheAsync Method

AssemblyRepositoryBasePruneCacheAsync Method
Deletes any cache data that is no longer valid.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract Task PruneCacheAsync()
Public MustOverride Function PruneCacheAsync As Task

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.AssemblyRepositoryBase.PruneCacheAsync"]

Implements

IAssemblyRepositoryPruneCacheAsync
Remarks
Call this method upon the shutdown of your application to ensure out-of-date cache data isn't retained.
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


AssemblyRepositoryBase.Remove Method

AssemblyRepositoryBaseRemove Method
Removes a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Remove(
    IBinaryAssembly assembly
)
Public MustOverride Sub Remove (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is no longer referenced.

Implements

IAssemblyRepositoryRemove(IBinaryAssembly)
Remarks
When no references remain for the assembly, it will no longer be tracked.
See Also

Reference

AssemblyRepositoryBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer Class

BinaryAssemblySerializer Class
Serializes and deserializes IBinaryAssembly objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationBinaryAssemblySerializer

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BinaryAssemblySerializer
Public Class BinaryAssemblySerializer

The BinaryAssemblySerializer type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryAssemblySerializer | Initializes a new instance of the BinaryAssemblySerializer class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LoadFromStream | Loads an IBinaryAssembly from a cache Stream.
Public method | LoadMetadataFromStream | Loads an IBinaryAssemblyMetadata from a cache Stream.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SaveToStream | Saves an IBinaryAssembly to a cache Stream.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer Constructor

BinaryAssemblySerializer Constructor
Initializes a new instance of the BinaryAssemblySerializer class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BinaryAssemblySerializer()
Public Sub New
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer Methods

BinaryAssemblySerializer Methods

The BinaryAssemblySerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LoadFromStream | Loads an IBinaryAssembly from a cache Stream.
Public method | LoadMetadataFromStream | Loads an IBinaryAssemblyMetadata from a cache Stream.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SaveToStream | Saves an IBinaryAssembly to a cache Stream.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer.LoadFromStream Method

BinaryAssemblySerializerLoadFromStream Method
Loads an IBinaryAssembly from a cache Stream.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IBinaryAssembly LoadFromStream(
    IBinaryAssemblyMetadata metadata,
    Stream stream
)
Public Function LoadFromStream (
    metadata As IBinaryAssemblyMetadata,
    stream As Stream
) As IBinaryAssembly

Parameters

metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata, if known, to compare to the stream's data for validation.
stream
Type: System.IOStream
The Stream from which to load.

Return Value

Type: IBinaryAssembly
The IBinaryAssembly that was loaded.
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer.LoadMetadataFromStream Method

BinaryAssemblySerializerLoadMetadataFromStream Method
Loads an IBinaryAssemblyMetadata from a cache Stream.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IBinaryAssemblyMetadata LoadMetadataFromStream(
    Stream stream
)
Public Function LoadMetadataFromStream (
    stream As Stream
) As IBinaryAssemblyMetadata

Parameters

stream
Type: System.IOStream
The Stream from which to load.

Return Value

Type: IBinaryAssemblyMetadata
The IBinaryAssemblyMetadata that was loaded.
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


BinaryAssemblySerializer.SaveToStream Method

BinaryAssemblySerializerSaveToStream Method
Saves an IBinaryAssembly to a cache Stream.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SaveToStream(
    IBinaryAssembly assembly,
    Stream stream
)
Public Sub SaveToStream (
    assembly As IBinaryAssembly,
    stream As Stream
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly to serialize.
stream
Type: System.IOStream
The Stream into which serialization should occur.
See Also

Reference

BinaryAssemblySerializer Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider Class

DocumentationProvider Class
Returns documentation for a .NET type or member definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationDocumentationProvider

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DocumentationProvider : IDocumentationProvider
Public Class DocumentationProvider
    Implements IDocumentationProvider

The DocumentationProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentationProvider | Initializes a new instance of the DocumentationProvider class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetDocumentationKey(ITypeDefinition) | Returns the documentation key for the specified ITypeDefinition.
 | GetDocumentationKey(ITypeMemberDefinition, Boolean) | Returns the documentation key for the specified ITypeMemberDefinition.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetType | (Inherited from Object.)
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider Constructor

DocumentationProvider Constructor
Initializes a new instance of the DocumentationProvider class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentationProvider(
    string documentation
)
Public Sub New (
    documentation As String
)

Parameters

documentation
Type: SystemString
The XML documentation.
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider Methods

DocumentationProvider Methods

The DocumentationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetDocumentationKey(ITypeDefinition) | Returns the documentation key for the specified ITypeDefinition.
 | GetDocumentationKey(ITypeMemberDefinition, Boolean) | Returns the documentation key for the specified ITypeMemberDefinition.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetParameter | Returns the documentation for the parameter with the specified name.
Public method | GetSummary | Returns the summary documentation.
Public method | GetType | (Inherited from Object.)
Public method | GetTypeParameter | Returns the documentation for the type parameter with the specified name.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetDocumentationKey Method

DocumentationProviderGetDocumentationKey Method
Overload List
Name | Description
GetDocumentationKey(ITypeDefinition) | Returns the documentation key for the specified ITypeDefinition.
GetDocumentationKey(ITypeMemberDefinition, Boolean) | Returns the documentation key for the specified ITypeMemberDefinition.
Top
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetDocumentationKey Method (ITypeDefinition)

DocumentationProviderGetDocumentationKey Method (ITypeDefinition)
Returns the documentation key for the specified ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string GetDocumentationKey(
    ITypeDefinition typeDef
)
Public Shared Function GetDocumentationKey (
    typeDef As ITypeDefinition
) As String

Parameters

typeDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The ITypeDefinition to examine.

Return Value

Type: String
The documentation key for the specified ITypeDefinition.
See Also

Reference

DocumentationProvider Class
GetDocumentationKey Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetDocumentationKey Method (ITypeMemberDefinition, Boolean)

DocumentationProviderGetDocumentationKey Method (ITypeMemberDefinition, Boolean)
Returns the documentation key for the specified ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string GetDocumentationKey(
    ITypeMemberDefinition typeMemberDef,
    bool includeDeclaringType
)
Public Shared Function GetDocumentationKey (
    typeMemberDef As ITypeMemberDefinition,
    includeDeclaringType As Boolean
) As String

Parameters

typeMemberDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeMemberDefinition
The ITypeMemberDefinition to examine.
includeDeclaringType
Type: SystemBoolean
Whether to include the declaring type.

Return Value

Type: String
The documentation key for the specified ITypeMemberDefinition.
See Also

Reference

DocumentationProvider Class
GetDocumentationKey Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetParameter Method

DocumentationProviderGetParameter Method
Returns the documentation for the parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetParameter(
    string name
)
Public Function GetParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the parameter with the specified name.

Implements

IDocumentationProviderGetParameter(String)
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetSummary Method

DocumentationProviderGetSummary Method
Returns the summary documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetSummary()
Public Function GetSummary As String

Return Value

Type: String
The summary documentation.

Implements

IDocumentationProviderGetSummary
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


DocumentationProvider.GetTypeParameter Method

DocumentationProviderGetTypeParameter Method
Returns the documentation for the type parameter with the specified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetTypeParameter(
    string name
)
Public Function GetTypeParameter (
    name As String
) As String

Parameters

name
Type: SystemString
The parameter name.

Return Value

Type: String
The documentation for the type parameter with the specified name.

Implements

IDocumentationProviderGetTypeParameter(String)
See Also

Reference

DocumentationProvider Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation Class

FileAssemblyDocumentation Class
Provides an assembly documentation source from a file on the hard drive.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationStreamAssemblyDocumentationBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileAssemblyDocumentation

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FileAssemblyDocumentation : StreamAssemblyDocumentationBase
Public Class FileAssemblyDocumentation
    Inherits StreamAssemblyDocumentationBase

The FileAssemblyDocumentation type exposes the following members.

Constructors
 | Name | Description
Public method | FileAssemblyDocumentation | Initializes a new instance of the FileAssemblyDocumentation class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetStreamAsync | Returns the Stream to use for reading documentation. (Overrides StreamAssemblyDocumentationBaseGetStreamAsync.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request. (Inherited from StreamAssemblyDocumentationBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation Constructor

FileAssemblyDocumentation Constructor
Initializes a new instance of the FileAssemblyDocumentation class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FileAssemblyDocumentation(
    string path
)
Public Sub New (
    path As String
)

Parameters

path
Type: SystemString
The path to the file on the local hard drive.
See Also

Reference

FileAssemblyDocumentation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation Methods

FileAssemblyDocumentation Methods

The FileAssemblyDocumentation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition. (Inherited from StreamAssemblyDocumentationBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetStreamAsync | Returns the Stream to use for reading documentation. (Overrides StreamAssemblyDocumentationBaseGetStreamAsync.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request. (Inherited from StreamAssemblyDocumentationBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FileAssemblyDocumentation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileAssemblyDocumentation.GetStreamAsync Method

FileAssemblyDocumentationGetStreamAsync Method
Returns the Stream to use for reading documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Task<Stream> GetStreamAsync()
Protected Overrides Function GetStreamAsync As Task(Of Stream)

Return Value

Type: Task Stream
The Stream to use for reading documentation.
Remarks
The Stream must support seeking.
See Also

Reference

FileAssemblyDocumentation Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Class

FileBasedAssemblyRepository Class
Represents an IAssemblyRepository that can cache data in the file system.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationAssemblyRepositoryBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileBasedAssemblyRepository

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FileBasedAssemblyRepository : AssemblyRepositoryBase
Public Class FileBasedAssemblyRepository
    Inherits AssemblyRepositoryBase

The FileBasedAssemblyRepository type exposes the following members.

Constructors
 | Name | Description
Public method | FileBasedAssemblyRepository | Initializes a new instance of the FileBasedAssemblyRepository class.
Top
Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Top
Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseAdd(IBinaryAssembly).)
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseCreate(Assembly, IAssemblyName, IBinaryAssemblyMetadata).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetOrCreateAsync | Gets an existing or creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseGetOrCreateAsync(Assembly, IAssemblyName, String).)
Public method | GetType | (Inherited from Object.)
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly. (Inherited from AssemblyRepositoryBase.)
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name. (Inherited from AssemblyRepositoryBase.)
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies. (Inherited from AssemblyRepositoryBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PruneCacheAsync | Deletes any cache-related files in the CachePath that are no longer valid. (Overrides AssemblyRepositoryBasePruneCacheAsync.)
Public method | Remove | Removes a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseRemove(IBinaryAssembly).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Constructor

FileBasedAssemblyRepository Constructor
Initializes a new instance of the FileBasedAssemblyRepository class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FileBasedAssemblyRepository(
    string cachePath
)
Public Sub New (
    cachePath As String
)

Parameters

cachePath
Type: SystemString
The path to use for assembly and documentation cache files.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Properties

FileBasedAssemblyRepository Properties

The FileBasedAssemblyRepository type exposes the following members.

Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Top
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.CachePath Property

FileBasedAssemblyRepositoryCachePath Property
Gets or sets the path to use for assembly and documentation cache files.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string CachePath { get; set; }
Public Property CachePath As String
    Get
    Set

Property Value

Type: String
The path to use for assembly and documentation cache files.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository Methods

FileBasedAssemblyRepository Methods

The FileBasedAssemblyRepository type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseAdd(IBinaryAssembly).)
Protected method | Create | Creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseCreate(Assembly, IAssemblyName, IBinaryAssemblyMetadata).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetOrCreateAsync | Gets an existing or creates a new IBinaryAssembly for the specified Assembly. (Overrides AssemblyRepositoryBaseGetOrCreateAsync(Assembly, IAssemblyName, String).)
Public method | GetType | (Inherited from Object.)
Public method | LoadAsync(Assembly) | Creates a new IBinaryAssembly instance from the specified Assembly. (Inherited from AssemblyRepositoryBase.)
Public method | LoadAsync(String) | Creates a new IBinaryAssembly instance from the specified Assembly name. (Inherited from AssemblyRepositoryBase.)
Public method | LoadAsync(Assembly, IAssemblyName) | Creates a new IBinaryAssembly instance from the specified Assembly, but stores it with an alternate AssemblyName, which is useful for dynamically generated assemblies. (Inherited from AssemblyRepositoryBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | PruneCacheAsync | Deletes any cache-related files in the CachePath that are no longer valid. (Overrides AssemblyRepositoryBasePruneCacheAsync.)
Public method | Remove | Removes a reference to an IBinaryAssembly. (Overrides AssemblyRepositoryBaseRemove(IBinaryAssembly).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.Add Method

FileBasedAssemblyRepositoryAdd Method
Adds a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Add(
    IBinaryAssembly assembly
)
Public Overrides Sub Add (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is referenced.

Implements

IAssemblyRepositoryAdd(IBinaryAssembly)
Remarks
The specified assembly will be tracked while there are remaining references to it. While tracked, the various [!:AssemblyRepositoryBase.Load(string)] methods will return the already-loaded instance when appropriate.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.Create Method

FileBasedAssemblyRepositoryCreate Method
Creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IBinaryAssembly Create(
    Assembly assembly,
    IAssemblyName assemblyName,
    IBinaryAssemblyMetadata metadata
)
Protected Overrides Function Create (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    metadata As IBinaryAssemblyMetadata
) As IBinaryAssembly

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
metadata
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssemblyMetadata
The assembly metadata.

Return Value

Type: IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.FileBasedAssemblyRepository.Create(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,ActiproSoftware.Text.Languages.DotNet.Reflection.IBinaryAssemblyMetadata)"]

See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.GetOrCreateAsync Method

FileBasedAssemblyRepositoryGetOrCreateAsync Method
Gets an existing or creates a new IBinaryAssembly for the specified Assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Task<IBinaryAssembly> GetOrCreateAsync(
    Assembly assembly,
    IAssemblyName assemblyName,
    string location
)
Protected Overrides Function GetOrCreateAsync (
    assembly As Assembly,
    assemblyName As IAssemblyName,
    location As String
) As Task(Of IBinaryAssembly)

Parameters

assembly
Type: System.ReflectionAssembly
The Assembly to examine.
assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
The IAssemblyName to use.
location
Type: SystemString
The assembly location, if known.

Return Value

Type: Task IBinaryAssembly

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.FileBasedAssemblyRepository.GetOrCreateAsync(System.Reflection.Assembly,ActiproSoftware.Text.Languages.DotNet.Reflection.IAssemblyName,System.String)"]

See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.PruneCacheAsync Method

FileBasedAssemblyRepositoryPruneCacheAsync Method
Deletes any cache-related files in the CachePath that are no longer valid.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Task PruneCacheAsync()
Public Overrides Function PruneCacheAsync As Task

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.FileBasedAssemblyRepository.PruneCacheAsync"]

Implements

IAssemblyRepositoryPruneCacheAsync
Remarks
Call this method upon the shutdown of your application to ensure out-of-date cache files aren't retained.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


FileBasedAssemblyRepository.Remove Method

FileBasedAssemblyRepositoryRemove Method
Removes a reference to an IBinaryAssembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Remove(
    IBinaryAssembly assembly
)
Public Overrides Sub Remove (
    assembly As IBinaryAssembly
)

Parameters

assembly
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIBinaryAssembly
The IBinaryAssembly that is no longer referenced.

Implements

IAssemblyRepositoryRemove(IBinaryAssembly)
Remarks
When no references remain for the assembly, it will no longer be tracked.
See Also

Reference

FileBasedAssemblyRepository Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Class

ProjectAssembly Class
Represents a project (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationProjectAssembly
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpProjectAssembly
ActiproSoftware.Text.Languages.VB.ImplementationVBProjectAssembly

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class ProjectAssembly : IProjectAssembly,
    IAssembly
Public MustInherit Class ProjectAssembly
    Implements IProjectAssembly, IAssembly

The ProjectAssembly type exposes the following members.

Constructors
 | Name | Description
Protected method | ProjectAssembly(String) | Initializes a new instance of the ProjectAssembly class.
Protected method | ProjectAssembly(IAssemblyName) | Initializes a new instance of the ProjectAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Constructor

ProjectAssembly Constructor
Overload List
 | Name | Description
Protected method | ProjectAssembly(String) | Initializes a new instance of the ProjectAssembly class.
Protected method | ProjectAssembly(IAssemblyName) | Initializes a new instance of the ProjectAssembly class.
Top
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Constructor (String)

ProjectAssembly Constructor (String)
Initializes a new instance of the ProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ProjectAssembly(
    string name
)
Protected Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

ProjectAssembly Class
ProjectAssembly Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Constructor (IAssemblyName)

ProjectAssembly Constructor (IAssemblyName)
Initializes a new instance of the ProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ProjectAssembly(
    IAssemblyName assemblyName
)
Protected Sub New (
    assemblyName As IAssemblyName
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

ProjectAssembly Class
ProjectAssembly Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Properties

ProjectAssembly Properties

The ProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly.
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly.
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive.
Public property | Name | Gets the simple name of the assembly.
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly.
Public property | Resolver | Gets the IResolver to use for this project assembly.
Public property | SourceFiles | Gets the collection of source files in this project assembly.
Top
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.AssemblyReferences Property

ProjectAssemblyAssemblyReferences Property
Gets the collection of assembly references for this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IProjectAssemblyReferenceCollection AssemblyReferences { get; }
Public ReadOnly Property AssemblyReferences As IProjectAssemblyReferenceCollection
    Get

Property Value

Type: IProjectAssemblyReferenceCollection
The collection of assembly references for this assembly.

Implements

IProjectAssemblyAssemblyReferences
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Documentation Property

ProjectAssemblyDocumentation Property
Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAssemblyDocumentation Documentation { get; set; }
Public Property Documentation As IAssemblyDocumentation
    Get
    Set

Property Value

Type: IAssemblyDocumentation
The IAssemblyDocumentation that provides access to this assembly's type and member documentation.

Implements

IAssemblyDocumentation
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.GlobalNamespace Property

ProjectAssemblyGlobalNamespace Property
Gets the entry point into the INamespaceDefinition tree defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public INamespaceDefinition GlobalNamespace { get; }
Public ReadOnly Property GlobalNamespace As INamespaceDefinition
    Get

Property Value

Type: INamespaceDefinition
The entry point into the INamespaceDefinition tree defined in this assembly.

Implements

IAssemblyGlobalNamespace
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.IsLanguageCaseSensitive Property

ProjectAssemblyIsLanguageCaseSensitive Property
Gets whether the language associated with this project assembly is case-sensitive.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsLanguageCaseSensitive { get; }
Protected MustOverride ReadOnly Property IsLanguageCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the language associated with this project assembly is case-sensitive; otherwise, false.
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Name Property

ProjectAssemblyName Property
Gets the simple name of the assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The simple name of the assembly.

Implements

IAssemblyName
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Namespaces Property

ProjectAssemblyNamespaces Property
Gets the collection of INamespaceDefinition objects defined in this assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public INamespaceDefinitionCollection Namespaces { get; }
Public ReadOnly Property Namespaces As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of INamespaceDefinition objects defined in this assembly.

Implements

IAssemblyNamespaces
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.Resolver Property

ProjectAssemblyResolver Property
Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IResolver Resolver { get; }
Public MustOverride ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.

Implements

IProjectAssemblyResolver
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.SourceFiles Property

ProjectAssemblySourceFiles Property
Gets the collection of source files in this project assembly.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISourceFileCollection SourceFiles { get; }
Public ReadOnly Property SourceFiles As ISourceFileCollection
    Get

Property Value

Type: ISourceFileCollection
The collection of source files in this project assembly.

Implements

IProjectAssemblySourceFiles
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly Methods

ProjectAssembly Methods

The ProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form.
Top
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.GetAssemblyName Method

ProjectAssemblyGetAssemblyName Method
Returns an IAssemblyName that contains assembly name information.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAssemblyName GetAssemblyName()
Public Function GetAssemblyName As IAssemblyName

Field Value

Type: IAssemblyName
An IAssemblyName that contains assembly name information.

Return Value

Type: IAssemblyName

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation.ProjectAssembly.GetAssemblyName"]

Implements

IAssemblyGetAssemblyName
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.ToString Method

ProjectAssemblyToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ProjectAssembly.ToTreeString Method

ProjectAssemblyToTreeString Method
Outputs the contents of the assembly in tree form.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToTreeString()
Public Function ToTreeString As String

Return Value

Type: String
A string that indicates the contents of the assembly.

Implements

IAssemblyToTreeString
See Also

Reference

ProjectAssembly Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Class

QualifiedName Class
Represents a qualified name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationQualifiedName

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class QualifiedName : IQualifiedName
Public Class QualifiedName
    Implements IQualifiedName

The QualifiedName type exposes the following members.

Constructors
 | Name | Description
Public method | QualifiedName(QualifiedName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, ISimpleName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, Int32, Int32, ISimpleName) | Initializes a new instance of the QualifiedName class.
Top
Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor

QualifiedName Constructor
Overload List
 | Name | Description
Public method | QualifiedName(QualifiedName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, ISimpleName) | Initializes a new instance of the QualifiedName class.
Public method | QualifiedName(String, Boolean, Int32, Int32, ISimpleName) | Initializes a new instance of the QualifiedName class.
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor (QualifiedName)

QualifiedName Constructor (QualifiedName)
Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName(
    QualifiedName qualifiedName
)
Public Sub New (
    qualifiedName As QualifiedName
)

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The AST qualified name to examine.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor (String, Boolean, ISimpleName[])

QualifiedName Constructor (String, Boolean, ISimpleName)
Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName(
    string alias,
    bool isGlobal,
    params ISimpleName[] identifiers
)
Public Sub New (
    alias As String,
    isGlobal As Boolean,
    ParamArray identifiers As ISimpleName()
)

Parameters

alias
Type: SystemString
The optional alias that indicates the root of the qualified name.
isGlobal
Type: SystemBoolean
Whether the qualified name is rooted at the default global namespace.
identifiers
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionISimpleName
The collection of identifiers for the qualified name.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Constructor (String, Boolean, Int32[], Int32, ISimpleName[])

QualifiedName Constructor (String, Boolean, Int32, Int32, ISimpleName)
Initializes a new instance of the QualifiedName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QualifiedName(
    string alias,
    bool isGlobal,
    int[] arrayRankSpecifiers,
    int pointerLevel,
    params ISimpleName[] identifiers
)
Public Sub New (
    alias As String,
    isGlobal As Boolean,
    arrayRankSpecifiers As Integer(),
    pointerLevel As Integer,
    ParamArray identifiers As ISimpleName()
)

Parameters

alias
Type: SystemString
The optional alias that indicates the root of the qualified name.
isGlobal
Type: SystemBoolean
Whether the qualified name is rooted at the default global namespace.
arrayRankSpecifiers
Type: SystemInt32
The array rank specifiers.
pointerLevel
Type: SystemInt32
The pointer level.
identifiers
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionISimpleName
The collection of identifiers for the qualified name.
See Also

Reference

QualifiedName Class
QualifiedName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Properties

QualifiedName Properties

The QualifiedName type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the optional alias that indicates the root of the qualified name.
Public property | ArrayRankSpecifiers | Gets the array rank specifiers.
Public property | HasArrayRankSpecifiers | Gets whether the qualified name has at least one array rank specifier.
Public property | HasIdentifiers | Gets whether the qualified name has at least one identifier.
Public property | Identifiers | Gets the collection of identifiers for the qualified name.
Public property | IsGlobal | Gets whether the qualified name is rooted at the default global namespace.
Public property | PointerLevel | Gets the pointer level.
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Alias Property

QualifiedNameAlias Property
Gets the optional alias that indicates the root of the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alias { get; }
Public ReadOnly Property Alias As String
    Get

Property Value

Type: String
The optional alias that indicates the root of the qualified name.

Implements

IQualifiedNameAlias
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.ArrayRankSpecifiers Property

QualifiedNameArrayRankSpecifiers Property
Gets the array rank specifiers.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<int> ArrayRankSpecifiers { get; }
Public ReadOnly Property ArrayRankSpecifiers As IList(Of Integer)
    Get

Property Value

Type: IList Int32
The array rank specifiers.

Implements

IQualifiedNameArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.HasArrayRankSpecifiers Property

QualifiedNameHasArrayRankSpecifiers Property
Gets whether the qualified name has at least one array rank specifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArrayRankSpecifiers { get; }
Public ReadOnly Property HasArrayRankSpecifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one array rank specifier; otherwise, false.

Implements

IQualifiedNameHasArrayRankSpecifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.HasIdentifiers Property

QualifiedNameHasIdentifiers Property
Gets whether the qualified name has at least one identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasIdentifiers { get; }
Public ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name has at least one identifier; otherwise, false.

Implements

IQualifiedNameHasIdentifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Identifiers Property

QualifiedNameIdentifiers Property
Gets the collection of identifiers for the qualified name.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ISimpleName> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of ISimpleName)
    Get

Property Value

Type: IList ISimpleName
The collection of identifiers for the qualified name.

Implements

IQualifiedNameIdentifiers
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.IsGlobal Property

QualifiedNameIsGlobal Property
Gets whether the qualified name is rooted at the default global namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGlobal { get; }
Public ReadOnly Property IsGlobal As Boolean
    Get

Property Value

Type: Boolean
true if the qualified name is rooted at the default global namespace; otherwise, false.

Implements

IQualifiedNameIsGlobal
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.PointerLevel Property

QualifiedNamePointerLevel Property
Gets the pointer level.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int PointerLevel { get; }
Public ReadOnly Property PointerLevel As Integer
    Get

Property Value

Type: Int32
The pointer level.

Implements

IQualifiedNamePointerLevel
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName Methods

QualifiedName Methods

The QualifiedName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Clone Method

QualifiedNameClone Method
Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IQualifiedName Clone()
Public Function Clone As IQualifiedName

Return Value

Type: IQualifiedName
The object that was created.

Implements

IQualifiedNameClone
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.Equals Method

QualifiedNameEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.GetHashCode Method

QualifiedNameGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


QualifiedName.ToString Method

QualifiedNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

QualifiedName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Class

SimpleName Class
Represents a simple name with optional type arguments, which is a component of an IQualifiedName.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleName : ISimpleName
Public Class SimpleName
    Implements ISimpleName

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName(SimpleName) | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, IQualifiedName) | Initializes a new instance of the SimpleName class.
Top
Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Constructor

SimpleName Constructor
Overload List
 | Name | Description
Public method | SimpleName(SimpleName) | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String, IQualifiedName) | Initializes a new instance of the SimpleName class.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Constructor (SimpleName)

SimpleName Constructor (SimpleName)
Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName(
    SimpleName simpleName
)
Public Sub New (
    simpleName As SimpleName
)

Parameters

simpleName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSimpleName
The AST simple name to examine.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Constructor (String, IQualifiedName[])

SimpleName Constructor (String, IQualifiedName)
Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName(
    string text,
    params IQualifiedName[] typeArguments
)
Public Sub New (
    text As String,
    ParamArray typeArguments As IQualifiedName()
)

Parameters

text
Type: SystemString
The text value of the identifier.
typeArguments
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIQualifiedName
The collection of optional generic type arguments for the identifier.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Properties

SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | HasTypeArguments | Gets whether the identifier has at least one type argument.
Public property | Text | Gets the text value of the identifier.
Public property | TypeArguments | Gets the collection of optional generic type arguments for the identifier.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.HasTypeArguments Property

SimpleNameHasTypeArguments Property
Gets whether the identifier has at least one type argument.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTypeArguments { get; }
Public ReadOnly Property HasTypeArguments As Boolean
    Get

Property Value

Type: Boolean
true if the identifier has at least one type argument; otherwise, false.

Implements

ISimpleNameHasTypeArguments
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property
Gets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The text value of the identifier.

Implements

ISimpleNameText
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.TypeArguments Property

SimpleNameTypeArguments Property
Gets the collection of optional generic type arguments for the identifier.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IQualifiedName> TypeArguments { get; }
Public ReadOnly Property TypeArguments As IList(Of IQualifiedName)
    Get

Property Value

Type: IList IQualifiedName
The collection of optional generic type arguments for the identifier.

Implements

ISimpleNameTypeArguments
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName Methods

SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a deep clone of the object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.Clone Method

SimpleNameClone Method
Returns a deep clone of the object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISimpleName Clone()
Public Function Clone As ISimpleName

Return Value

Type: ISimpleName
The object that was created.

Implements

ISimpleNameClone
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.Equals Method

SimpleNameEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.GetHashCode Method

SimpleNameGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SimpleName.ToString Method

SimpleNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Class

SourceFile Class
Represents a source code file that can be loaded by an IProjectAssembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationSourceFile

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SourceFile : ISourceFile, IKeyedObject
Public Class SourceFile
    Implements ISourceFile, IKeyedObject

The SourceFile type exposes the following members.

Constructors
 | Name | Description
Public method | SourceFile(String, ITypeDefinition) | Initializes a new instance of the SourceFile class.
Public method | SourceFile(String, IEnumerableITypeDefinition) | Initializes a new instance of the SourceFile class.
Top
Properties
 | Name | Description
Public property | Key | Gets the unique key that identifies the source file, which is generally a full file path or GUID.
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Constructor

SourceFile Constructor
Overload List
 | Name | Description
Public method | SourceFile(String, ITypeDefinition) | Initializes a new instance of the SourceFile class.
Public method | SourceFile(String, IEnumerableITypeDefinition) | Initializes a new instance of the SourceFile class.
Top
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Constructor (String, ITypeDefinition[])

SourceFile Constructor (String, ITypeDefinition)
Initializes a new instance of the SourceFile class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SourceFile(
    string key,
    params ITypeDefinition[] typeDefs
)
Public Sub New (
    key As String,
    ParamArray typeDefs As ITypeDefinition()
)

Parameters

key
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
typeDefs
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The collection of ITypeDefinition objects contained in the source file.
See Also

Reference

SourceFile Class
SourceFile Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Constructor (String, IEnumerable(ITypeDefinition))

SourceFile Constructor (String, IEnumerableITypeDefinition)
Initializes a new instance of the SourceFile class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SourceFile(
    string key,
    IEnumerable<ITypeDefinition> typeDefs
)
Public Sub New (
    key As String,
    typeDefs As IEnumerable(Of ITypeDefinition)
)

Parameters

key
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
typeDefs
Type: System.Collections.GenericIEnumerable ITypeDefinition
The collection of ITypeDefinition objects contained in the source file.
See Also

Reference

SourceFile Class
SourceFile Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Properties

SourceFile Properties

The SourceFile type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the unique key that identifies the source file, which is generally a full file path or GUID.
Public property | TypeDefinitions | Gets the collection of ITypeDefinition objects contained in the source file.
Top
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile.Key Property

SourceFileKey Property
Gets the unique key that identifies the source file, which is generally a full file path or GUID.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The unique key that identifies the source file, which is generally a full file path or GUID.

Implements

IKeyedObjectKey
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile.TypeDefinitions Property

SourceFileTypeDefinitions Property
Gets the collection of ITypeDefinition objects contained in the source file.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITypeDefinitionCollection TypeDefinitions { get; }
Public ReadOnly Property TypeDefinitions As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of ITypeDefinition objects contained in the source file.

Implements

ISourceFileTypeDefinitions
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile Methods

SourceFile Methods

The SourceFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


SourceFile.ToString Method

SourceFileToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SourceFile Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase Class

StreamAssemblyDocumentationBase Class
Provides an abstract base class for a Stream-based assembly documentation source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationStreamAssemblyDocumentationBase
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationFileAssemblyDocumentation

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class StreamAssemblyDocumentationBase : IAssemblyDocumentation
Public MustInherit Class StreamAssemblyDocumentationBase
    Implements IAssemblyDocumentation

The StreamAssemblyDocumentationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | StreamAssemblyDocumentationBase | Initializes a new instance of the StreamAssemblyDocumentationBase class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetStreamAsync | Returns the Stream to use for reading documentation.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase Constructor

StreamAssemblyDocumentationBase Constructor
Initializes a new instance of the StreamAssemblyDocumentationBase class

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected StreamAssemblyDocumentationBase()
Protected Sub New
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase Methods

StreamAssemblyDocumentationBase Methods

The StreamAssemblyDocumentationBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetStreamAsync | Returns the Stream to use for reading documentation.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Refresh | Clears all index and cache data, allowing the documentation to refresh itself on the next request.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetDocumentationAsync Method

StreamAssemblyDocumentationBaseGetDocumentationAsync Method
Overload List
 | Name | Description
Public method | GetDocumentationAsync(ITypeDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.
Public method | GetDocumentationAsync(ITypeMemberDefinition) | Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.
Top
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetDocumentationAsync Method (ITypeDefinition)

StreamAssemblyDocumentationBaseGetDocumentationAsync Method (ITypeDefinition)
Returns the IDocumentationProvider, if any, that is available for the specified ITypeDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<IDocumentationProvider> GetDocumentationAsync(
    ITypeDefinition typeDef
)
Public Function GetDocumentationAsync (
    typeDef As ITypeDefinition
) As Task(Of IDocumentationProvider)

Parameters

typeDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeDefinition
The ITypeDefinition for which to search.

Return Value

Type: Task IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeDefinition.

Implements

IAssemblyDocumentationGetDocumentationAsync(ITypeDefinition)
See Also

Reference

StreamAssemblyDocumentationBase Class
GetDocumentationAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetDocumentationAsync Method (ITypeMemberDefinition)

StreamAssemblyDocumentationBaseGetDocumentationAsync Method (ITypeMemberDefinition)
Returns the IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<IDocumentationProvider> GetDocumentationAsync(
    ITypeMemberDefinition typeMemberDef
)
Public Function GetDocumentationAsync (
    typeMemberDef As ITypeMemberDefinition
) As Task(Of IDocumentationProvider)

Parameters

typeMemberDef
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionITypeMemberDefinition
The ITypeMemberDefinition for which to search.

Return Value

Type: Task IDocumentationProvider
The IDocumentationProvider, if any, that is available for the specified ITypeMemberDefinition.

Implements

IAssemblyDocumentationGetDocumentationAsync(ITypeMemberDefinition)
See Also

Reference

StreamAssemblyDocumentationBase Class
GetDocumentationAsync Overload
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.GetStreamAsync Method

StreamAssemblyDocumentationBaseGetStreamAsync Method
Returns the Stream to use for reading documentation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Task<Stream> GetStreamAsync()
Protected MustOverride Function GetStreamAsync As Task(Of Stream)

Return Value

Type: Task Stream
The Stream to use for reading documentation.
Remarks
The Stream must support seeking.
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


StreamAssemblyDocumentationBase.Refresh Method

StreamAssemblyDocumentationBaseRefresh Method
Clears all index and cache data, allowing the documentation to refresh itself on the next request.

Namespace: ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

StreamAssemblyDocumentationBase Class
ActiproSoftware.Text.Languages.DotNet.Reflection.Implementation Namespace


ActiproSoftware.Text.Languages.DotNet.Resolution Namespace

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace
Contains the types related to resolution for a .NET syntax language.
Classes
 | Class | Description
Public class | ResolverResultKind | Specifies the kind of resolver result.
Interfaces
 | Interface | Description
Public interface | INamespaceResolverResult | Provides the base requirements of a namespace result from an IResolver resolution operation.
Public interface | IParameterResolverResult | Provides the base requirements of a parameter result from an IResolver resolution operation.
Public interface | IResolver | Provides the base requirements of a .NET language resolver.
Public interface | IResolverRequest | Provides the base requirements of a request for a .NET language resolve operation.
Public interface | IResolverResult | Provides the base requirements of a single result from an IResolver resolution operation.
Public interface | IResolverResultCollection | Provides the base requirements for a collection of IResolverResult objects.
Public interface | IResolverResultSet | Provides the base requirements of a result set from an IResolver resolution operation.
Public interface | ITypeMemberResolverResult | Provides the base requirements of a type member result from an IResolver resolution operation.
Public interface | ITypeResolverResult | Provides the base requirements of a type result from an IResolver resolution operation.
Public interface | IVariableResolverResult | Provides the base requirements of a local variable result from an IResolver resolution operation.


INamespaceResolverResult Interface

INamespaceResolverResult Interface
Provides the base requirements of a namespace result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface INamespaceResolverResult : IResolverResult
Public Interface INamespaceResolverResult
    Inherits IResolverResult

The INamespaceResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Definitions | Get the collection of accessible INamespaceDefinition objects for this namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


INamespaceResolverResult Properties

INamespaceResolverResult Properties

The INamespaceResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Definitions | Get the collection of accessible INamespaceDefinition objects for this namespace.
Public property | FullName | Gets the full name of the namespace, which includes the names of ancestor namespaces.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

INamespaceResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


INamespaceResolverResult.Definitions Property

INamespaceResolverResultDefinitions Property
Get the collection of accessible INamespaceDefinition objects for this namespace.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
INamespaceDefinitionCollection Definitions { get; }
ReadOnly Property Definitions As INamespaceDefinitionCollection
    Get

Property Value

Type: INamespaceDefinitionCollection
The collection of accessible INamespaceDefinition objects for this namespace.
See Also

Reference

INamespaceResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


INamespaceResolverResult.FullName Property

INamespaceResolverResultFullName Property
Gets the full name of the namespace, which includes the names of ancestor namespaces.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
The full name of the namespace, which includes the names of ancestor namespaces.
See Also

Reference

INamespaceResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IParameterResolverResult Interface

IParameterResolverResult Interface
Provides the base requirements of a parameter result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterResolverResult : IResolverResult
Public Interface IParameterResolverResult
    Inherits IResolverResult

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IParameterResolverResult Properties

IParameterResolverResult Properties

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IParameterResolverResult.Parameter Property

IParameterResolverResultParameter Property
Gets a IParameterDefinition indicating the parameter.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParameterDefinition Parameter { get; }
ReadOnly Property Parameter As IParameterDefinition
    Get

Property Value

Type: IParameterDefinition
A IParameterDefinition indicating the parameter.
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolver Interface

IResolver Interface
Provides the base requirements of a .NET language resolver.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolver
Public Interface IResolver

The IResolver type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolver Methods

IResolver Methods

The IResolver type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolver.Resolve Method

IResolverResolve Method
Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve(
    IResolverRequest request
)
Function Resolve (
    request As IResolverRequest
) As IResolverResultSet

Parameters

request
Type: ActiproSoftware.Text.Languages.DotNet.ResolutionIResolverRequest
The IResolverRequest to process.

Return Value

Type: IResolverResultSet
An IResolverResultSet containing the results.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest Interface

IResolverRequest Interface
Provides the base requirements of a request for a .NET language resolve operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverRequest
Public Interface IResolverRequest

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest Properties

IResolverRequest Properties

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest.Context Property

IResolverRequestContext Property
Gets the IDotNetContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDotNetContext Context { get; }
ReadOnly Property Context As IDotNetContext
    Get

Property Value

Type: IDotNetContext
The IDotNetContext in which the request is based, if known.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverRequest.Expression Property

IResolverRequestExpression Property
Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Expression Expression { get; }
ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult Interface

IResolverResult Interface
Provides the base requirements of a single result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverResult
Public Interface IResolverResult

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeReference indicating the return type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult Properties

IResolverResult Properties

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeReference indicating the return type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.Kind Property

IResolverResultKind Property
Gets the ResolverResultKind indicating the kind of resolver result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ResolverResultKind Kind { get; }
ReadOnly Property Kind As ResolverResultKind
    Get

Property Value

Type: ResolverResultKind
The ResolverResultKind indicating the kind of resolver result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.Name Property

IResolverResultName Property
Gets a name identifying the result.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
A name identifying the result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.Type Property

IResolverResultType Property
Gets a ITypeReference indicating the return type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReference Type { get; }
ReadOnly Property Type As ITypeReference
    Get

Property Value

Type: ITypeReference
A ITypeReference indicating the return type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResult.TypeIsInstance Property

IResolverResultTypeIsInstance Property
Gets whether the return Type reference designates an instance of the type.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool TypeIsInstance { get; }
ReadOnly Property TypeIsInstance As Boolean
    Get

Property Value

Type: Boolean
true if the return Type reference designates an instance of the type; otherwise, false indicating that the reference designates the static type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultCollection Interface

IResolverResultCollection Interface
Provides the base requirements for a collection of IResolverResult objects.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverResultCollection : IList<IResolverResult>,
    ICollection<IResolverResult>, IEnumerable<IResolverResult>, IEnumerable
Public Interface IResolverResultCollection
    Inherits IList(Of IResolverResult), ICollection(Of IResolverResult),
    IEnumerable(Of IResolverResult), IEnumerable

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | (Inherited from ICollection IResolverResult .)
Public property | Item | (Inherited from IList IResolverResult .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IResolverResult .)
Public method | Clear | (Inherited from ICollection IResolverResult .)
Public method | Contains | (Inherited from ICollection IResolverResult .)
Public method | CopyTo | (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | (Inherited from IList IResolverResult .)
Public method | Insert | (Inherited from IList IResolverResult .)
Public method | Remove | (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | (Inherited from IList IResolverResult .)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace
ActiproSoftware.Text.Languages.DotNet.ResolutionIResolverResult


IResolverResultCollection Properties

IResolverResultCollection Properties

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | (Inherited from ICollection IResolverResult .)
Public property | Item | (Inherited from IList IResolverResult .)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultCollection Methods

IResolverResultCollection Methods

The IResolverResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IResolverResult .)
Public method | Clear | (Inherited from ICollection IResolverResult .)
Public method | Contains | (Inherited from ICollection IResolverResult .)
Public method | CopyTo | (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | (Inherited from IList IResolverResult .)
Public method | Insert | (Inherited from IList IResolverResult .)
Public method | Remove | (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | (Inherited from IList IResolverResult .)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultSet Interface

IResolverResultSet Interface
Provides the base requirements of a result set from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverResultSet
Public Interface IResolverResultSet

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultSet Properties

IResolverResultSet Properties

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IResolverResultSet.Results Property

IResolverResultSetResults Property
Gets the collection of results from the resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResultCollection Results { get; }
ReadOnly Property Results As IResolverResultCollection
    Get

Property Value

Type: IResolverResultCollection
The collection of results from the resolution operation.
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeMemberResolverResult Interface

ITypeMemberResolverResult Interface
Provides the base requirements of a type member result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeMemberResolverResult : IResolverResult
Public Interface ITypeMemberResolverResult
    Inherits IResolverResult

The ITypeMemberResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Member | Gets a ITypeMemberDefinition indicating the member.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeMemberResolverResult Properties

ITypeMemberResolverResult Properties

The ITypeMemberResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Member | Gets a ITypeMemberDefinition indicating the member.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeMemberResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeMemberResolverResult.Member Property

ITypeMemberResolverResultMember Property
Gets a ITypeMemberDefinition indicating the member.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeMemberDefinition Member { get; }
ReadOnly Property Member As ITypeMemberDefinition
    Get

Property Value

Type: ITypeMemberDefinition
A ITypeMemberDefinition indicating the member.
See Also

Reference

ITypeMemberResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeResolverResult Interface

ITypeResolverResult Interface
Provides the base requirements of a type result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeResolverResult : IResolverResult
Public Interface ITypeResolverResult
    Inherits IResolverResult

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ITypeResolverResult Properties

ITypeResolverResult Properties

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IVariableResolverResult Interface

IVariableResolverResult Interface
Provides the base requirements of a local variable result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IVariableResolverResult : IResolverResult
Public Interface IVariableResolverResult
    Inherits IResolverResult

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IVariableResolverResult Properties

IVariableResolverResult Properties

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeReference indicating the return type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


IVariableResolverResult.Variable Property

IVariableResolverResultVariable Property
Gets a IVariableDefinition indicating the variable.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IVariableDefinition Variable { get; }
ReadOnly Property Variable As IVariableDefinition
    Get

Property Value

Type: IVariableDefinition
A IVariableDefinition indicating the variable.
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind Class

ResolverResultKind Class
Specifies the kind of resolver result.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.DotNet.ResolutionResolverResultKind

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ResolverResultKind : Enum
Public NotInheritable Class ResolverResultKind
    Inherits Enum

The ResolverResultKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Namespace | The result is an INamespaceResolverResult.
 | Other | The result is an other kind of IResolverResult.
 | Parameter | The result is an IParameterResolverResult.
 | Type | The result is an ITypeResolverResult.
 | TypeMember | The result is an ITypeMemberResolverResult.
Public field | value__ |
 | Variable | The result is an IVariableResolverResult.
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind Methods

ResolverResultKind Methods

The ResolverResultKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind Fields

ResolverResultKind Fields

The ResolverResultKind type exposes the following members.

Fields
 | Name | Description
 | Namespace | The result is an INamespaceResolverResult.
 | Other | The result is an other kind of IResolverResult.
 | Parameter | The result is an IParameterResolverResult.
 | Type | The result is an ITypeResolverResult.
 | TypeMember | The result is an ITypeMemberResolverResult.
Public field | value__ |
 | Variable | The result is an IVariableResolverResult.
Top
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.Namespace Field

ResolverResultKindNamespace Field
The result is an INamespaceResolverResult.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Namespace = 0
Public Const Namespace As ResolverResultKind = 0

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.Other Field

ResolverResultKindOther Field
The result is an other kind of IResolverResult.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Other = 5
Public Const Other As ResolverResultKind = 5

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.Parameter Field

ResolverResultKindParameter Field
The result is an IParameterResolverResult.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Parameter = 3
Public Const Parameter As ResolverResultKind = 3

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.Type Field

ResolverResultKindType Field
The result is an ITypeResolverResult.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Type = 1
Public Const Type As ResolverResultKind = 1

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.TypeMember Field

ResolverResultKindTypeMember Field
The result is an ITypeMemberResolverResult.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind TypeMember = 2
Public Const TypeMember As ResolverResultKind = 2

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.value__ Field

ResolverResultKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.DotNet.Resolution.ResolverResultKind.value__"]

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ResolverResultKind.Variable Field

ResolverResultKindVariable Field
The result is an IVariableResolverResult.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Variable = 4
Public Const Variable As ResolverResultKind = 4

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.DotNet.Resolution Namespace


ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace

ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace
Contains the implementation types related to resolution for a .NET syntax language.
Classes
 | Class | Description
Public class | ResolverRequest | Represents a request for a .NET language resolve operation.


ResolverRequest Class

ResolverRequest Class
Represents a request for a .NET language resolve operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Resolution.ImplementationResolverRequest

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ResolverRequest : IResolverRequest
Public Class ResolverRequest
    Implements IResolverRequest

The ResolverRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ResolverRequest(Expression) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(IQualifiedName) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(QualifiedName) | Initializes a new instance of the ResolverRequest class.
Top
Properties
 | Name | Description
Public property | Context | Gets or sets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor

ResolverRequest Constructor
Overload List
 | Name | Description
Public method | ResolverRequest(Expression) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(IQualifiedName) | Initializes a new instance of the ResolverRequest class.
Public method | ResolverRequest(QualifiedName) | Initializes a new instance of the ResolverRequest class.
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor (Expression)

ResolverRequest Constructor (Expression)
Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ResolverRequest(
    Expression expression
)
Public Sub New (
    expression As Expression
)

Parameters

expression
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
The Expression to resolve.
See Also

Reference

ResolverRequest Class
ResolverRequest Overload
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor (IQualifiedName)

ResolverRequest Constructor (IQualifiedName)
Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ResolverRequest(
    IQualifiedName qualifiedName
)
Public Sub New (
    qualifiedName As IQualifiedName
)

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIQualifiedName
The IQualifiedName to resolve.
See Also

Reference

ResolverRequest Class
ResolverRequest Overload
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Constructor (QualifiedName)

ResolverRequest Constructor (QualifiedName)
Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ResolverRequest(
    QualifiedName qualifiedName
)
Public Sub New (
    qualifiedName As QualifiedName
)

Parameters

qualifiedName
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
The AST QualifiedName to resolve.
See Also

Reference

ResolverRequest Class
ResolverRequest Overload
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Properties

ResolverRequest Properties

The ResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets or sets the IDotNetContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest.Context Property

ResolverRequestContext Property
Gets or sets the IDotNetContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDotNetContext Context { get; set; }
Public Property Context As IDotNetContext
    Get
    Set

Property Value

Type: IDotNetContext
The IDotNetContext in which the request is based, if known.

Implements

IResolverRequestContext
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest.Expression Property

ResolverRequestExpression Property
Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; }
Public ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.

Implements

IResolverRequestExpression
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ResolverRequest Methods

ResolverRequest Methods

The ResolverRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.DotNet.Resolution.Implementation Namespace


ActiproSoftware.Text.Languages.JavaScript Namespace

ActiproSoftware.Text.Languages.JavaScript Namespace
Contains the classes related to implementing a JavaScript syntax language.
Classes
 | Class | Description
Public class | JavaScriptGrammarRootNonTerminal | Specifies the root non-terminal to use for a JavaScript grammar.
Interfaces
 | Interface | Description
Public interface | IJavaScriptClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for the JavaScript language.
Public interface | IJavaScriptGrammarOptions | Contains options for a JavaScript grammar.
Public interface | IJavaScriptParseData | Provides the base requirements of an object that stores the results of a JavaScript language parsing operation.
Public interface | IJavaScriptSymbol | Provides the base requirements of an object that represents a JavaScript symbol.
Public interface | IJavaScriptSymbolTable | Provides the base requirements of an object that represents a JavaScript symbol.
Public interface | IJsonParseData | Provides the base requirements of an object that stores the results of a JSON language parsing operation.


IJavaScriptClassificationTypeProvider Interface

IJavaScriptClassificationTypeProvider Interface
Provides the base requirements of an object that provides IClassificationType objects for the JavaScript language.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IJavaScriptClassificationTypeProvider
Public Interface IJavaScriptClassificationTypeProvider

The IJavaScriptClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | String | Gets the String classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider Properties

IJavaScriptClassificationTypeProvider Properties

The IJavaScriptClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | String | Gets the String classification type.
Top
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Comment Property

IJavaScriptClassificationTypeProviderComment Property
Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Comment { get; }
ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Identifier Property

IJavaScriptClassificationTypeProviderIdentifier Property
Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Identifier { get; }
ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Keyword Property

IJavaScriptClassificationTypeProviderKeyword Property
Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Keyword { get; }
ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Number Property

IJavaScriptClassificationTypeProviderNumber Property
Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Number { get; }
ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.Operator Property

IJavaScriptClassificationTypeProviderOperator Property
Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Operator { get; }
ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptClassificationTypeProvider.String Property

IJavaScriptClassificationTypeProviderString Property
Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType String { get; }
ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.
See Also

Reference

IJavaScriptClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptGrammarOptions Interface

IJavaScriptGrammarOptions Interface
Contains options for a JavaScript grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IJavaScriptGrammarOptions
Public Interface IJavaScriptGrammarOptions

The IJavaScriptGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptGrammarOptions Properties

IJavaScriptGrammarOptions Properties

The IJavaScriptGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

IJavaScriptGrammarOptions Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptGrammarOptions.RootNonTerminal Property

IJavaScriptGrammarOptionsRootNonTerminal Property
Gets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
JavaScriptGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As JavaScriptGrammarRootNonTerminal
    Get

Property Value

Type: JavaScriptGrammarRootNonTerminal
A JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

IJavaScriptGrammarOptions Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptParseData Interface

IJavaScriptParseData Interface
Provides the base requirements of an object that stores the results of a JavaScript language parsing operation.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IJavaScriptParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IJavaScriptParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IJavaScriptParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Public property | SymbolTable | Gets the table of symbols located within the document.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParseData


IJavaScriptParseData Properties

IJavaScriptParseData Properties

The IJavaScriptParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Public property | SymbolTable | Gets the table of symbols located within the document.
Top
See Also

Reference

IJavaScriptParseData Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptParseData.SymbolTable Property

IJavaScriptParseDataSymbolTable Property
Gets the table of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IJavaScriptSymbolTable SymbolTable { get; }
ReadOnly Property SymbolTable As IJavaScriptSymbolTable
    Get

Property Value

Type: IJavaScriptSymbolTable
The table of symbols located within the document.
See Also

Reference

IJavaScriptParseData Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbol Interface

IJavaScriptSymbol Interface
Provides the base requirements of an object that represents a JavaScript symbol.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IJavaScriptSymbol
Public Interface IJavaScriptSymbol

The IJavaScriptSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbol


IJavaScriptSymbol Properties

IJavaScriptSymbol Properties

The IJavaScriptSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

IJavaScriptSymbol Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbol.Name Property

IJavaScriptSymbolName Property
Gets the symbol name.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The symbol name.
See Also

Reference

IJavaScriptSymbol Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbol.UsageCount Property

IJavaScriptSymbolUsageCount Property
Gets or sets the usage count.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int UsageCount { get; set; }
Property UsageCount As Integer
    Get
    Set

Property Value

Type: Int32
The usage count.
See Also

Reference

IJavaScriptSymbol Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbolTable Interface

IJavaScriptSymbolTable Interface
Provides the base requirements of an object that represents a JavaScript symbol.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IJavaScriptSymbolTable
Public Interface IJavaScriptSymbolTable

The IJavaScriptSymbolTable type exposes the following members.

Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbol


IJavaScriptSymbolTable Properties

IJavaScriptSymbolTable Properties

The IJavaScriptSymbolTable type exposes the following members.

Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

IJavaScriptSymbolTable Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJavaScriptSymbolTable.Symbols Property

IJavaScriptSymbolTableSymbols Property
Gets the collection of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IJavaScriptSymbol> Symbols { get; }
ReadOnly Property Symbols As IEnumerable(Of IJavaScriptSymbol)
    Get

Property Value

Type: IEnumerable IJavaScriptSymbol
The collection of symbols located within the document.
See Also

Reference

IJavaScriptSymbolTable Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


IJsonParseData Interface

IJsonParseData Interface
Provides the base requirements of an object that stores the results of a JSON language parsing operation.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IJsonParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IJsonParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IJsonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParseData


IJsonParseData Properties

IJsonParseData Properties

The IJsonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IJsonParseData Interface
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal Class

JavaScriptGrammarRootNonTerminal Class
Specifies the root non-terminal to use for a JavaScript grammar.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.JavaScriptJavaScriptGrammarRootNonTerminal

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class JavaScriptGrammarRootNonTerminal : Enum
Public NotInheritable Class JavaScriptGrammarRootNonTerminal
    Inherits Enum

The JavaScriptGrammarRootNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CompilationUnit | Compilation unit (the default).
 | Expression | Expression.
 | Statement | Statement.
 | StatementList | Statement list.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal Methods

JavaScriptGrammarRootNonTerminal Methods

The JavaScriptGrammarRootNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal Fields

JavaScriptGrammarRootNonTerminal Fields

The JavaScriptGrammarRootNonTerminal type exposes the following members.

Fields
 | Name | Description
 | CompilationUnit | Compilation unit (the default).
 | Expression | Expression.
 | Statement | Statement.
 | StatementList | Statement list.
Public field | value__ |
Top
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal.CompilationUnit Field

JavaScriptGrammarRootNonTerminalCompilationUnit Field
Compilation unit (the default).

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const JavaScriptGrammarRootNonTerminal CompilationUnit = 0
Public Const CompilationUnit As JavaScriptGrammarRootNonTerminal = 0

Field Value

Type: JavaScriptGrammarRootNonTerminal
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal.Expression Field

JavaScriptGrammarRootNonTerminalExpression Field
Expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const JavaScriptGrammarRootNonTerminal Expression = 3
Public Const Expression As JavaScriptGrammarRootNonTerminal = 3

Field Value

Type: JavaScriptGrammarRootNonTerminal
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal.Statement Field

JavaScriptGrammarRootNonTerminalStatement Field
Statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const JavaScriptGrammarRootNonTerminal Statement = 2
Public Const Statement As JavaScriptGrammarRootNonTerminal = 2

Field Value

Type: JavaScriptGrammarRootNonTerminal
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal.StatementList Field

JavaScriptGrammarRootNonTerminalStatementList Field
Statement list.

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const JavaScriptGrammarRootNonTerminal StatementList = 1
Public Const StatementList As JavaScriptGrammarRootNonTerminal = 1

Field Value

Type: JavaScriptGrammarRootNonTerminal
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


JavaScriptGrammarRootNonTerminal.value__ Field

JavaScriptGrammarRootNonTerminalvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.JavaScript.JavaScriptGrammarRootNonTerminal.value__"]

Namespace: ActiproSoftware.Text.Languages.JavaScript
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

JavaScriptGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.JavaScript Namespace


ActiproSoftware.Text.Languages.JavaScript.Ast Namespace

ActiproSoftware.Text.Languages.JavaScript.Ast Namespace
Contains the types related to ASTs for a JavaScript syntax language.
Classes
 | Class | Description
Public class | LiteralExpressionKind | Specifies the type of literal expression.
Public class | OperatorKind | Specifies the kind of an operator.


LiteralExpressionKind Class

LiteralExpressionKind Class
Specifies the type of literal expression.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.JavaScript.AstLiteralExpressionKind

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LiteralExpressionKind : Enum
Public NotInheritable Class LiteralExpressionKind
    Inherits Enum

The LiteralExpressionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Boolean | A boolean.
 | DecimalInteger | A decimal integer.
 | DoubleQuoteString | A string of characters.
 | HexadecimalInteger | A hexadecimal integer.
 | None | No kind indicated.
 | Null | A null value.
 | Real | A real number.
 | RegularExpression | A regular expression.
 | SingleQuoteString | A string of characters.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind Methods

LiteralExpressionKind Methods

The LiteralExpressionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind Fields

LiteralExpressionKind Fields

The LiteralExpressionKind type exposes the following members.

Fields
 | Name | Description
 | Boolean | A boolean.
 | DecimalInteger | A decimal integer.
 | DoubleQuoteString | A string of characters.
 | HexadecimalInteger | A hexadecimal integer.
 | None | No kind indicated.
 | Null | A null value.
 | Real | A real number.
 | RegularExpression | A regular expression.
 | SingleQuoteString | A string of characters.
Public field | value__ |
Top
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.Boolean Field

LiteralExpressionKindBoolean Field
A boolean.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Boolean = 2
Public Const Boolean As LiteralExpressionKind = 2

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.DecimalInteger Field

LiteralExpressionKindDecimalInteger Field
A decimal integer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DecimalInteger = 3
Public Const DecimalInteger As LiteralExpressionKind = 3

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.DoubleQuoteString Field

LiteralExpressionKindDoubleQuoteString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DoubleQuoteString = 7
Public Const DoubleQuoteString As LiteralExpressionKind = 7

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.HexadecimalInteger Field

LiteralExpressionKindHexadecimalInteger Field
A hexadecimal integer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind HexadecimalInteger = 4
Public Const HexadecimalInteger As LiteralExpressionKind = 4

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.None Field

LiteralExpressionKindNone Field
No kind indicated.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind None = 0
Public Const None As LiteralExpressionKind = 0

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.Null Field

LiteralExpressionKindNull Field
A null value.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Null = 1
Public Const Null As LiteralExpressionKind = 1

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.Real Field

LiteralExpressionKindReal Field
A real number.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Real = 5
Public Const Real As LiteralExpressionKind = 5

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.RegularExpression Field

LiteralExpressionKindRegularExpression Field
A regular expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind RegularExpression = 8
Public Const RegularExpression As LiteralExpressionKind = 8

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.SingleQuoteString Field

LiteralExpressionKindSingleQuoteString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind SingleQuoteString = 6
Public Const SingleQuoteString As LiteralExpressionKind = 6

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


LiteralExpressionKind.value__ Field

LiteralExpressionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.JavaScript.Ast.LiteralExpressionKind.value__"]

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind Class

OperatorKind Class
Specifies the kind of an operator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.JavaScript.AstOperatorKind

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class OperatorKind : Enum
Public NotInheritable Class OperatorKind
    Inherits Enum

The OperatorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Addition | An addition operator.
 | BitwiseAnd | A bitwise AND operator.
 | BitwiseOr | A bitwise OR operator.
 | ConditionalAnd | A conditional AND binary operator.
 | ConditionalOr | A conditional OR binary operator.
 | Delete | An operator that deletes an object, an object's property, or an element at a specified index in an array.
 | Division | A division operator.
 | ExclusiveOr | A bitwise XOR operator.
 | GreaterThan | A greater than operator.
 | GreaterThanOrEqual | A greater than or equal operator.
 | In | An operator indicating if a property is in an object.
 | InstanceOf | An operator indicating if an object is of the specified type.
 | LeftShift | A left shift operator.
 | LessThan | A less than operator.
 | LessThanOrEqual | A less than or equal operator.
 | Modulus | A modulus operator.
 | Multiplication | A multiplication operator.
 | Negation | A negation operator.
 | None | No valid operator kind.
 | OnesComplement | A bitwise complement operator.
 | PostDecrement | An post-decrement operator.
 | PostIncrement | An post-increment operator.
 | PreDecrement | An pre-decrement operator.
 | PreIncrement | An pre-increment operator.
 | RightShift | A right shift operator.
 | StrictValueEquality | A strict value equality operator.
 | StrictValueInequality | A strict value inequality operator.
 | Subtraction | A subtraction operator.
 | TypeOf | An operator that returns a string indicating the type of the unevaluated operand.
Public field | value__ |
 | ValueEquality | A value equality operator.
 | ValueInequality | A value inequality operator.
 | Void | An operator that specifies an expression to be evaluated without returning a value.
 | ZeroFillRightShift | A zero fill right shift operator.
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind Methods

OperatorKind Methods

The OperatorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind Fields

OperatorKind Fields

The OperatorKind type exposes the following members.

Fields
 | Name | Description
 | Addition | An addition operator.
 | BitwiseAnd | A bitwise AND operator.
 | BitwiseOr | A bitwise OR operator.
 | ConditionalAnd | A conditional AND binary operator.
 | ConditionalOr | A conditional OR binary operator.
 | Delete | An operator that deletes an object, an object's property, or an element at a specified index in an array.
 | Division | A division operator.
 | ExclusiveOr | A bitwise XOR operator.
 | GreaterThan | A greater than operator.
 | GreaterThanOrEqual | A greater than or equal operator.
 | In | An operator indicating if a property is in an object.
 | InstanceOf | An operator indicating if an object is of the specified type.
 | LeftShift | A left shift operator.
 | LessThan | A less than operator.
 | LessThanOrEqual | A less than or equal operator.
 | Modulus | A modulus operator.
 | Multiplication | A multiplication operator.
 | Negation | A negation operator.
 | None | No valid operator kind.
 | OnesComplement | A bitwise complement operator.
 | PostDecrement | An post-decrement operator.
 | PostIncrement | An post-increment operator.
 | PreDecrement | An pre-decrement operator.
 | PreIncrement | An pre-increment operator.
 | RightShift | A right shift operator.
 | StrictValueEquality | A strict value equality operator.
 | StrictValueInequality | A strict value inequality operator.
 | Subtraction | A subtraction operator.
 | TypeOf | An operator that returns a string indicating the type of the unevaluated operand.
Public field | value__ |
 | ValueEquality | A value equality operator.
 | ValueInequality | A value inequality operator.
 | Void | An operator that specifies an expression to be evaluated without returning a value.
 | ZeroFillRightShift | A zero fill right shift operator.
Top
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Addition Field

OperatorKindAddition Field
An addition operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Addition = 1
Public Const Addition As OperatorKind = 1

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.BitwiseAnd Field

OperatorKindBitwiseAnd Field
A bitwise AND operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind BitwiseAnd = 6
Public Const BitwiseAnd As OperatorKind = 6

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.BitwiseOr Field

OperatorKindBitwiseOr Field
A bitwise OR operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind BitwiseOr = 7
Public Const BitwiseOr As OperatorKind = 7

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.ConditionalAnd Field

OperatorKindConditionalAnd Field
A conditional AND binary operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ConditionalAnd = 27
Public Const ConditionalAnd As OperatorKind = 27

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.ConditionalOr Field

OperatorKindConditionalOr Field
A conditional OR binary operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ConditionalOr = 26
Public Const ConditionalOr As OperatorKind = 26

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Delete Field

OperatorKindDelete Field
An operator that deletes an object, an object's property, or an element at a specified index in an array.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Delete = 30
Public Const Delete As OperatorKind = 30

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Division Field

OperatorKindDivision Field
A division operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Division = 4
Public Const Division As OperatorKind = 4

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.ExclusiveOr Field

OperatorKindExclusiveOr Field
A bitwise XOR operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ExclusiveOr = 8
Public Const ExclusiveOr As OperatorKind = 8

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.GreaterThan Field

OperatorKindGreaterThan Field
A greater than operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind GreaterThan = 12
Public Const GreaterThan As OperatorKind = 12

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.GreaterThanOrEqual Field

OperatorKindGreaterThanOrEqual Field
A greater than or equal operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind GreaterThanOrEqual = 25
Public Const GreaterThanOrEqual As OperatorKind = 25

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.In Field

OperatorKindIn Field
An operator indicating if a property is in an object.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind In = 29
Public Const In As OperatorKind = 29

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.InstanceOf Field

OperatorKindInstanceOf Field
An operator indicating if an object is of the specified type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind InstanceOf = 28
Public Const InstanceOf As OperatorKind = 28

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.LeftShift Field

OperatorKindLeftShift Field
A left shift operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LeftShift = 17
Public Const LeftShift As OperatorKind = 17

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.LessThan Field

OperatorKindLessThan Field
A less than operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LessThan = 11
Public Const LessThan As OperatorKind = 11

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.LessThanOrEqual Field

OperatorKindLessThanOrEqual Field
A less than or equal operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LessThanOrEqual = 24
Public Const LessThanOrEqual As OperatorKind = 24

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Modulus Field

OperatorKindModulus Field
A modulus operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Modulus = 5
Public Const Modulus As OperatorKind = 5

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Multiplication Field

OperatorKindMultiplication Field
A multiplication operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Multiplication = 3
Public Const Multiplication As OperatorKind = 3

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Negation Field

OperatorKindNegation Field
A negation operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Negation = 9
Public Const Negation As OperatorKind = 9

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.None Field

OperatorKindNone Field
No valid operator kind.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind None = 0
Public Const None As OperatorKind = 0

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.OnesComplement Field

OperatorKindOnesComplement Field
A bitwise complement operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind OnesComplement = 10
Public Const OnesComplement As OperatorKind = 10

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.PostDecrement Field

OperatorKindPostDecrement Field
An post-decrement operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PostDecrement = 16
Public Const PostDecrement As OperatorKind = 16

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.PostIncrement Field

OperatorKindPostIncrement Field
An post-increment operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PostIncrement = 15
Public Const PostIncrement As OperatorKind = 15

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.PreDecrement Field

OperatorKindPreDecrement Field
An pre-decrement operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PreDecrement = 14
Public Const PreDecrement As OperatorKind = 14

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.PreIncrement Field

OperatorKindPreIncrement Field
An pre-increment operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind PreIncrement = 13
Public Const PreIncrement As OperatorKind = 13

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.RightShift Field

OperatorKindRightShift Field
A right shift operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind RightShift = 18
Public Const RightShift As OperatorKind = 18

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.StrictValueEquality Field

OperatorKindStrictValueEquality Field
A strict value equality operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind StrictValueEquality = 22
Public Const StrictValueEquality As OperatorKind = 22

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.StrictValueInequality Field

OperatorKindStrictValueInequality Field
A strict value inequality operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind StrictValueInequality = 23
Public Const StrictValueInequality As OperatorKind = 23

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Subtraction Field

OperatorKindSubtraction Field
A subtraction operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Subtraction = 2
Public Const Subtraction As OperatorKind = 2

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.TypeOf Field

OperatorKindTypeOf Field
An operator that returns a string indicating the type of the unevaluated operand.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind TypeOf = 32
Public Const TypeOf As OperatorKind = 32

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.value__ Field

OperatorKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.JavaScript.Ast.OperatorKind.value__"]

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.ValueEquality Field

OperatorKindValueEquality Field
A value equality operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ValueEquality = 20
Public Const ValueEquality As OperatorKind = 20

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.ValueInequality Field

OperatorKindValueInequality Field
A value inequality operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ValueInequality = 21
Public Const ValueInequality As OperatorKind = 21

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.Void Field

OperatorKindVoid Field
An operator that specifies an expression to be evaluated without returning a value.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Void = 31
Public Const Void As OperatorKind = 31

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


OperatorKind.ZeroFillRightShift Field

OperatorKindZeroFillRightShift Field
A zero fill right shift operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ZeroFillRightShift = 19
Public Const ZeroFillRightShift As OperatorKind = 19

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.JavaScript.Ast Namespace


ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace
Contains the implementation types related to ASTs for a JavaScript syntax language.
Classes
 | Class | Description
Public class | Argument | Represents an argument.
Public class | ArrayInitializerExpression | Represents an array initializer expression.
Public class | AssignmentExpression | Represents an assignment expression.
Public class | BinaryOperatorExpression | Represents a binary operator expression.
Public class | BlockStatement | Represents a block statement.
Public class | BreakStatement | Represents a break statement.
Public class | CatchClause | Represents a catch clause.
Public class | CompilationUnit | Represents a compilation unit.
Public class | ConditionalExpression | Represents a conditional expression.
Public class | ContinueStatement | Represents a continue statement.
Public class | DebuggerStatement | Represents a debugger statement.
Public class | DoStatement | Represents a do statement.
Public class | Expression | Represents an expression.
Public class | ExpressionStatement | Represents an expression statement.
Public class | ForEachStatement | Represents a for each statement.
Public class | ForStatement | Represents a for statement.
Public class | FunctionBody | Represents a function body.
Public class | FunctionDeclaration | Represents a function declaration.
Public class | FunctionExpression | Represents a function expression.
Public class | IfStatement | Represents an if statement.
Public class | InstanceExpression | Represents an instance expression.
Public class | InvocationExpression | Represents an invocation expression.
Public class | JavaScriptAstNodeId | Contains the AST node IDs for the JavaScript language.
Public class | LabeledStatement | Represents a labeled statement.
Public class | LiteralExpression | Represents a literal expression.
Public class | MemberAccess | Represents a member access.
Public class | ObjectCreationExpression | Represents an object creation expression.
Public class | ObjectInitializerExpression | Represents an object initializer expression.
Public class | ParameterDeclaration | Represents a parameter declaration.
Public class | ParenthesizedExpression | Represents a parenthesized expression.
Public class | PropertyDeclaration | Represents a property declaration.
Public class | ReturnStatement | Represents a return statement.
Public class | SequenceExpression | Represents a sequence expression.
Public class | SimpleName | Represents a simple name.
Public class | SourceElement | Represents a source element.
Public class | Statement | Represents a statement.
Public class | SwitchSection | Represents a switch section.
Public class | SwitchStatement | Represents a switch statement.
Public class | ThrowStatement | Represents a throw statement.
Public class | TryStatement | Represents a try statement.
Public class | UnaryOperatorExpression | Represents an unary operator expression.
Public class | VariableDeclaration | Represents a variable declaration.
Public class | VariableDeclarationExpression | Represents a variable declaration expression.
Public class | VariableStatement | Represents a variable statement.
Public class | WhileStatement | Represents a while statement.
Public class | WithStatement | Represents a with statement.


Argument Class

Argument Class
Represents an argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArgument

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Argument : AstNodeBase
Public Class Argument
    Inherits AstNodeBase

The Argument type exposes the following members.

Constructors
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument Constructor

Argument Constructor
Initializes a new instance of the Argument class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Argument()
Public Sub New
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument Properties

Argument Properties

The Argument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument.Expression Property

ArgumentExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument.Id Property

ArgumentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument Methods

Argument Methods

The Argument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Argument.GetChildrenEnumerator Method

ArgumentGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Class

ArrayInitializerExpression Class
Represents an array initializer expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArrayInitializerExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ArrayInitializerExpression : Expression
Public Class ArrayInitializerExpression
    Inherits Expression

The ArrayInitializerExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayInitializerExpression | Initializes a new instance of the ArrayInitializerExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Constructor

ArrayInitializerExpression Constructor
Initializes a new instance of the ArrayInitializerExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ArrayInitializerExpression()
Public Sub New
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Properties

ArrayInitializerExpression Properties

The ArrayInitializerExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasInitializers | Returns whether the Initializers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Initializers | Gets the initializers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.HasInitializers Property

ArrayInitializerExpressionHasInitializers Property
Returns whether the Initializers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasInitializers { get; }
Public ReadOnly Property HasInitializers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.Id Property

ArrayInitializerExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.Initializers Property

ArrayInitializerExpressionInitializers Property
Gets the initializers.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Initializers { get; }
Public ReadOnly Property Initializers As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The initializers.
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression Methods

ArrayInitializerExpression Methods

The ArrayInitializerExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ArrayInitializerExpression.GetChildrenEnumerator Method

ArrayInitializerExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ArrayInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Class

AssignmentExpression Class
Represents an assignment expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationAssignmentExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AssignmentExpression : Expression
Public Class AssignmentExpression
    Inherits Expression

The AssignmentExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AssignmentExpression | Initializes a new instance of the AssignmentExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Constructor

AssignmentExpression Constructor
Initializes a new instance of the AssignmentExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssignmentExpression()
Public Sub New
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Properties

AssignmentExpression Properties

The AssignmentExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.Id Property

AssignmentExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.LeftExpression Property

AssignmentExpressionLeftExpression Property
Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.Operator Property

AssignmentExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.RightExpression Property

AssignmentExpressionRightExpression Property
Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression Methods

AssignmentExpression Methods

The AssignmentExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


AssignmentExpression.GetChildrenEnumerator Method

AssignmentExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssignmentExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Class

BinaryOperatorExpression Class
Represents a binary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBinaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BinaryOperatorExpression : Expression
Public Class BinaryOperatorExpression
    Inherits Expression

The BinaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryOperatorExpression | Initializes a new instance of the BinaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Constructor

BinaryOperatorExpression Constructor
Initializes a new instance of the BinaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BinaryOperatorExpression()
Public Sub New
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Properties

BinaryOperatorExpression Properties

The BinaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.Id Property

BinaryOperatorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.LeftExpression Property

BinaryOperatorExpressionLeftExpression Property
Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.Operator Property

BinaryOperatorExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.RightExpression Property

BinaryOperatorExpressionRightExpression Property
Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression Methods

BinaryOperatorExpression Methods

The BinaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BinaryOperatorExpression.GetChildrenEnumerator Method

BinaryOperatorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Class

BlockStatement Class
Represents a block statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBlockStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BlockStatement : Statement
Public Class BlockStatement
    Inherits Statement

The BlockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockStatement | Initializes a new instance of the BlockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Constructor

BlockStatement Constructor
Initializes a new instance of the BlockStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement()
Public Sub New
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Properties

BlockStatement Properties

The BlockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.ChildStatements Property

BlockStatementChildStatements Property
Gets the child statements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> ChildStatements { get; }
Public ReadOnly Property ChildStatements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The child statements.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.HasChildStatements Property

BlockStatementHasChildStatements Property
Returns whether the ChildStatements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildStatements { get; }
Public ReadOnly Property HasChildStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.Id Property

BlockStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement Methods

BlockStatement Methods

The BlockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BlockStatement.GetChildrenEnumerator Method

BlockStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Class

BreakStatement Class
Represents a break statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBreakStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BreakStatement : Statement
Public Class BreakStatement
    Inherits Statement

The BreakStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BreakStatement | Initializes a new instance of the BreakStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Constructor

BreakStatement Constructor
Initializes a new instance of the BreakStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BreakStatement()
Public Sub New
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Properties

BreakStatement Properties

The BreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement.Id Property

BreakStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement.Label Property

BreakStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Label { get; set; }
Public Property Label As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The label.
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement Methods

BreakStatement Methods

The BreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


BreakStatement.GetChildrenEnumerator Method

BreakStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Class

CatchClause Class
Represents a catch clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCatchClause

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CatchClause : AstNodeBase
Public Class CatchClause
    Inherits AstNodeBase

The CatchClause type exposes the following members.

Constructors
 | Name | Description
Public method | CatchClause | Initializes a new instance of the CatchClause class
Top
Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclaration | Gets or sets the variable declaration.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Constructor

CatchClause Constructor
Initializes a new instance of the CatchClause class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CatchClause()
Public Sub New
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Properties

CatchClause Properties

The CatchClause type exposes the following members.

Properties
 | Name | Description
Public property | CatchBlock | Gets or sets the catch block.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | VariableDeclaration | Gets or sets the variable declaration.
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.CatchBlock Property

CatchClauseCatchBlock Property
Gets or sets the catch block.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement CatchBlock { get; set; }
Public Property CatchBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The catch block.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.Id Property

CatchClauseId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.VariableDeclaration Property

CatchClauseVariableDeclaration Property
Gets or sets the variable declaration.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclaration VariableDeclaration { get; set; }
Public Property VariableDeclaration As VariableDeclaration
    Get
    Set

Property Value

Type: VariableDeclaration
The variable declaration.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause Methods

CatchClause Methods

The CatchClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CatchClause.GetChildrenEnumerator Method

CatchClauseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CatchClause Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Class

CompilationUnit Class
Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Constructor

CompilationUnit Constructor
Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Properties

CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.HasSourceElements Property

CompilationUnitHasSourceElements Property
Returns whether the SourceElements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSourceElements { get; }
Public ReadOnly Property HasSourceElements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.SourceElements Property

CompilationUnitSourceElements Property
Gets the source elements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SourceElement> SourceElements { get; }
Public ReadOnly Property SourceElements As IList(Of SourceElement)
    Get

Property Value

Type: IList SourceElement
The source elements.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit Methods

CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Class

ConditionalExpression Class
Represents a conditional expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationConditionalExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConditionalExpression : Expression
Public Class ConditionalExpression
    Inherits Expression

The ConditionalExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalExpression | Initializes a new instance of the ConditionalExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Constructor

ConditionalExpression Constructor
Initializes a new instance of the ConditionalExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConditionalExpression()
Public Sub New
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Properties

ConditionalExpression Properties

The ConditionalExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.ConditionExpression Property

ConditionalExpressionConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.FalseExpression Property

ConditionalExpressionFalseExpression Property
Gets or sets the false expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression FalseExpression { get; set; }
Public Property FalseExpression As Expression
    Get
    Set

Property Value

Type: Expression
The false expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.Id Property

ConditionalExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.TrueExpression Property

ConditionalExpressionTrueExpression Property
Gets or sets the true expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TrueExpression { get; set; }
Public Property TrueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The true expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression Methods

ConditionalExpression Methods

The ConditionalExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ConditionalExpression.GetChildrenEnumerator Method

ConditionalExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Class

ContinueStatement Class
Represents a continue statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationContinueStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ContinueStatement : Statement
Public Class ContinueStatement
    Inherits Statement

The ContinueStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueStatement | Initializes a new instance of the ContinueStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Constructor

ContinueStatement Constructor
Initializes a new instance of the ContinueStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContinueStatement()
Public Sub New
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Properties

ContinueStatement Properties

The ContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement.Id Property

ContinueStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement.Label Property

ContinueStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Label { get; set; }
Public Property Label As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The label.
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement Methods

ContinueStatement Methods

The ContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ContinueStatement.GetChildrenEnumerator Method

ContinueStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Class

DebuggerStatement Class
Represents a debugger statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDebuggerStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DebuggerStatement : Statement
Public Class DebuggerStatement
    Inherits Statement

The DebuggerStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerStatement | Initializes a new instance of the DebuggerStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Constructor

DebuggerStatement Constructor
Initializes a new instance of the DebuggerStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DebuggerStatement()
Public Sub New
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Properties

DebuggerStatement Properties

The DebuggerStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement.Id Property

DebuggerStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DebuggerStatement Methods

DebuggerStatement Methods

The DebuggerStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DebuggerStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Class

DoStatement Class
Represents a do statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDoStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DoStatement : Statement
Public Class DoStatement
    Inherits Statement

The DoStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DoStatement | Initializes a new instance of the DoStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Constructor

DoStatement Constructor
Initializes a new instance of the DoStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoStatement()
Public Sub New
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Properties

DoStatement Properties

The DoStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.ChildStatement Property

DoStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.ConditionExpression Property

DoStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.Id Property

DoStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement Methods

DoStatement Methods

The DoStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


DoStatement.GetChildrenEnumerator Method

DoStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DoStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression Class

Expression Class
Represents an expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
More...

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Expression : AstNodeBase
Public Class Expression
    Inherits AstNodeBase

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArrayInitializerExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationAssignmentExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBinaryOperatorExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationConditionalExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInstanceExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInvocationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLiteralExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationMemberAccess
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectCreationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectInitializerExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParenthesizedExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSequenceExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSimpleName
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationUnaryOperatorExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclarationExpression


Expression Constructor

Expression Constructor
Initializes a new instance of the Expression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression()
Public Sub New
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression Properties

Expression Properties

The Expression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression.Id Property

ExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Expression Methods

Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Class

ExpressionStatement Class
Represents an expression statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpressionStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExpressionStatement : Statement
Public Class ExpressionStatement
    Inherits Statement

The ExpressionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionStatement | Initializes a new instance of the ExpressionStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Constructor

ExpressionStatement Constructor
Initializes a new instance of the ExpressionStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExpressionStatement()
Public Sub New
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Properties

ExpressionStatement Properties

The ExpressionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement.Expression Property

ExpressionStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement.Id Property

ExpressionStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement Methods

ExpressionStatement Methods

The ExpressionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ExpressionStatement.GetChildrenEnumerator Method

ExpressionStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Class

ForEachStatement Class
Represents a for each statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForEachStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ForEachStatement : Statement
Public Class ForEachStatement
    Inherits Statement

The ForEachStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForEachStatement | Initializes a new instance of the ForEachStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Constructor

ForEachStatement Constructor
Initializes a new instance of the ForEachStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ForEachStatement()
Public Sub New
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Properties

ForEachStatement Properties

The ForEachStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.ChildStatement Property

ForEachStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.ElementExpression Property

ForEachStatementElementExpression Property
Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.EnumerableExpression Property

ForEachStatementEnumerableExpression Property
Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.Id Property

ForEachStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement Methods

ForEachStatement Methods

The ForEachStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForEachStatement.GetChildrenEnumerator Method

ForEachStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForEachStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Class

ForStatement Class
Represents a for statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ForStatement : Statement
Public Class ForStatement
    Inherits Statement

The ForStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForStatement | Initializes a new instance of the ForStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | IteratorExpression | Gets or sets the iterator expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Constructor

ForStatement Constructor
Initializes a new instance of the ForStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ForStatement()
Public Sub New
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Properties

ForStatement Properties

The ForStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | IteratorExpression | Gets or sets the iterator expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.ChildStatement Property

ForStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.ConditionExpression Property

ForStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.Id Property

ForStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.InitializerExpression Property

ForStatementInitializerExpression Property
Gets or sets the initializer expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression InitializerExpression { get; set; }
Public Property InitializerExpression As Expression
    Get
    Set

Property Value

Type: Expression
The initializer expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.IteratorExpression Property

ForStatementIteratorExpression Property
Gets or sets the iterator expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression IteratorExpression { get; set; }
Public Property IteratorExpression As Expression
    Get
    Set

Property Value

Type: Expression
The iterator expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement Methods

ForStatement Methods

The ForStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ForStatement.GetChildrenEnumerator Method

ForStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Class

FunctionBody Class
Represents a function body.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionBody

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FunctionBody : AstNodeBase
Public Class FunctionBody
    Inherits AstNodeBase

The FunctionBody type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionBody | Initializes a new instance of the FunctionBody class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Constructor

FunctionBody Constructor
Initializes a new instance of the FunctionBody class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionBody()
Public Sub New
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Properties

FunctionBody Properties

The FunctionBody type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSourceElements | Returns whether the SourceElements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | SourceElements | Gets the source elements.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.HasSourceElements Property

FunctionBodyHasSourceElements Property
Returns whether the SourceElements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSourceElements { get; }
Public ReadOnly Property HasSourceElements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.Id Property

FunctionBodyId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.SourceElements Property

FunctionBodySourceElements Property
Gets the source elements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SourceElement> SourceElements { get; }
Public ReadOnly Property SourceElements As IList(Of SourceElement)
    Get

Property Value

Type: IList SourceElement
The source elements.
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody Methods

FunctionBody Methods

The FunctionBody type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionBody.GetChildrenEnumerator Method

FunctionBodyGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionBody Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Class

FunctionDeclaration Class
Represents a function declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FunctionDeclaration : SourceElement
Public Class FunctionDeclaration
    Inherits SourceElement

The FunctionDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionDeclaration | Initializes a new instance of the FunctionDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Constructor

FunctionDeclaration Constructor
Initializes a new instance of the FunctionDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionDeclaration()
Public Sub New
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Properties

FunctionDeclaration Properties

The FunctionDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Body Property

FunctionDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionBody Body { get; set; }
Public Property Body As FunctionBody
    Get
    Set

Property Value

Type: FunctionBody
The body.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.HasParameters Property

FunctionDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Id Property

FunctionDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Name Property

FunctionDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.Parameters Property

FunctionDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration Methods

FunctionDeclaration Methods

The FunctionDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionDeclaration.GetChildrenEnumerator Method

FunctionDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Class

FunctionExpression Class
Represents a function expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FunctionExpression : Expression
Public Class FunctionExpression
    Inherits Expression

The FunctionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionExpression | Initializes a new instance of the FunctionExpression class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Constructor

FunctionExpression Constructor
Initializes a new instance of the FunctionExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionExpression()
Public Sub New
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Properties

FunctionExpression Properties

The FunctionExpression type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Body Property

FunctionExpressionBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionBody Body { get; set; }
Public Property Body As FunctionBody
    Get
    Set

Property Value

Type: FunctionBody
The body.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.HasParameters Property

FunctionExpressionHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Id Property

FunctionExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Name Property

FunctionExpressionName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.Parameters Property

FunctionExpressionParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression Methods

FunctionExpression Methods

The FunctionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


FunctionExpression.GetChildrenEnumerator Method

FunctionExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Class

IfStatement Class
Represents an if statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationIfStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IfStatement : Statement
Public Class IfStatement
    Inherits Statement

The IfStatement type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatement | Initializes a new instance of the IfStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Constructor

IfStatement Constructor
Initializes a new instance of the IfStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IfStatement()
Public Sub New
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Properties

IfStatement Properties

The IfStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseStatement | Gets or sets the false statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueStatement | Gets or sets the true statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.ConditionExpression Property

IfStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.FalseStatement Property

IfStatementFalseStatement Property
Gets or sets the false statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement FalseStatement { get; set; }
Public Property FalseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The false statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.Id Property

IfStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.TrueStatement Property

IfStatementTrueStatement Property
Gets or sets the true statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement TrueStatement { get; set; }
Public Property TrueStatement As Statement
    Get
    Set

Property Value

Type: Statement
The true statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement Methods

IfStatement Methods

The IfStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


IfStatement.GetChildrenEnumerator Method

IfStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Class

InstanceExpression Class
Represents an instance expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInstanceExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InstanceExpression : Expression
Public Class InstanceExpression
    Inherits Expression

The InstanceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InstanceExpression | Initializes a new instance of the InstanceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Constructor

InstanceExpression Constructor
Initializes a new instance of the InstanceExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InstanceExpression()
Public Sub New
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Properties

InstanceExpression Properties

The InstanceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression.Id Property

InstanceExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InstanceExpression Methods

InstanceExpression Methods

The InstanceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InstanceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Class

InvocationExpression Class
Represents an invocation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationInvocationExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvocationExpression : Expression
Public Class InvocationExpression
    Inherits Expression

The InvocationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InvocationExpression | Initializes a new instance of the InvocationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Constructor

InvocationExpression Constructor
Initializes a new instance of the InvocationExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvocationExpression()
Public Sub New
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Properties

InvocationExpression Properties

The InvocationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.Arguments Property

InvocationExpressionArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.HasArguments Property

InvocationExpressionHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.Id Property

InvocationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.TargetExpression Property

InvocationExpressionTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression Methods

InvocationExpression Methods

The InvocationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


InvocationExpression.GetChildrenEnumerator Method

InvocationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Class

JavaScriptAstNodeId Class
Contains the AST node IDs for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationJavaScriptAstNodeId

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptAstNodeId : AstNodeIdProviderBase
Public Class JavaScriptAstNodeId
    Inherits AstNodeIdProviderBase

The JavaScriptAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptAstNodeId | Initializes a new instance of the JavaScriptAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Argument | Gets the Argument AST node ID.
ArrayInitializerExpression | Gets the ArrayInitializerExpression AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DebuggerStatement | Gets the DebuggerStatement AST node ID.
DoStatement | Gets the DoStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FunctionBody | Gets the FunctionBody AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
FunctionExpression | Gets the FunctionExpression AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
ObjectInitializerExpression | Gets the ObjectInitializerExpression AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SequenceExpression | Gets the SequenceExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SourceElement | Gets the SourceElement AST node ID.
Statement | Gets the Statement AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryStatement | Gets the TryStatement AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
VariableDeclaration | Gets the VariableDeclaration AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableStatement | Gets the VariableStatement AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Constructor

JavaScriptAstNodeId Constructor
Initializes a new instance of the JavaScriptAstNodeId class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptAstNodeId()
Public Sub New
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Properties

JavaScriptAstNodeId Properties

The JavaScriptAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.MaxId Property

JavaScriptAstNodeIdMaxId Property
Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.MinId Property

JavaScriptAstNodeIdMinId Property
Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Methods

JavaScriptAstNodeId Methods

The JavaScriptAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ContainsId Method

JavaScriptAstNodeIdContainsId Method
Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.GetDescription Method

JavaScriptAstNodeIdGetDescription Method
Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.GetKey Method

JavaScriptAstNodeIdGetKey Method
Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId Fields

JavaScriptAstNodeId Fields

The JavaScriptAstNodeId type exposes the following members.

Fields
Name | Description
Argument | Gets the Argument AST node ID.
ArrayInitializerExpression | Gets the ArrayInitializerExpression AST node ID.
AssignmentExpression | Gets the AssignmentExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
CatchClause | Gets the CatchClause AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DebuggerStatement | Gets the DebuggerStatement AST node ID.
DoStatement | Gets the DoStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForEachStatement | Gets the ForEachStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FunctionBody | Gets the FunctionBody AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
FunctionExpression | Gets the FunctionExpression AST node ID.
IfStatement | Gets the IfStatement AST node ID.
InstanceExpression | Gets the InstanceExpression AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
LabeledStatement | Gets the LabeledStatement AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
MemberAccess | Gets the MemberAccess AST node ID.
ObjectCreationExpression | Gets the ObjectCreationExpression AST node ID.
ObjectInitializerExpression | Gets the ObjectInitializerExpression AST node ID.
ParameterDeclaration | Gets the ParameterDeclaration AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PropertyDeclaration | Gets the PropertyDeclaration AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SequenceExpression | Gets the SequenceExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SourceElement | Gets the SourceElement AST node ID.
Statement | Gets the Statement AST node ID.
SwitchSection | Gets the SwitchSection AST node ID.
SwitchStatement | Gets the SwitchStatement AST node ID.
ThrowStatement | Gets the ThrowStatement AST node ID.
TryStatement | Gets the TryStatement AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
VariableDeclaration | Gets the VariableDeclaration AST node ID.
VariableDeclarationExpression | Gets the VariableDeclarationExpression AST node ID.
VariableStatement | Gets the VariableStatement AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
Top
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.Argument Field

JavaScriptAstNodeIdArgument Field
Gets the Argument AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Argument = 13001
Public Const Argument As Integer = 13001

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ArrayInitializerExpression Field

JavaScriptAstNodeIdArrayInitializerExpression Field
Gets the ArrayInitializerExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ArrayInitializerExpression = 13002
Public Const ArrayInitializerExpression As Integer = 13002

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.AssignmentExpression Field

JavaScriptAstNodeIdAssignmentExpression Field
Gets the AssignmentExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AssignmentExpression = 13000
Public Const AssignmentExpression As Integer = 13000

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.BinaryOperatorExpression Field

JavaScriptAstNodeIdBinaryOperatorExpression Field
Gets the BinaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BinaryOperatorExpression = 13003
Public Const BinaryOperatorExpression As Integer = 13003

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.BlockStatement Field

JavaScriptAstNodeIdBlockStatement Field
Gets the BlockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BlockStatement = 13004
Public Const BlockStatement As Integer = 13004

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.BreakStatement Field

JavaScriptAstNodeIdBreakStatement Field
Gets the BreakStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BreakStatement = 13005
Public Const BreakStatement As Integer = 13005

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.CatchClause Field

JavaScriptAstNodeIdCatchClause Field
Gets the CatchClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CatchClause = 13006
Public Const CatchClause As Integer = 13006

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.CompilationUnit Field

JavaScriptAstNodeIdCompilationUnit Field
Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 13007
Public Const CompilationUnit As Integer = 13007

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ConditionalExpression Field

JavaScriptAstNodeIdConditionalExpression Field
Gets the ConditionalExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ConditionalExpression = 13008
Public Const ConditionalExpression As Integer = 13008

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ContinueStatement Field

JavaScriptAstNodeIdContinueStatement Field
Gets the ContinueStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContinueStatement = 13009
Public Const ContinueStatement As Integer = 13009

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.DebuggerStatement Field

JavaScriptAstNodeIdDebuggerStatement Field
Gets the DebuggerStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DebuggerStatement = 13010
Public Const DebuggerStatement As Integer = 13010

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.DoStatement Field

JavaScriptAstNodeIdDoStatement Field
Gets the DoStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DoStatement = 13011
Public Const DoStatement As Integer = 13011

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.Expression Field

JavaScriptAstNodeIdExpression Field
Gets the Expression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Expression = 13012
Public Const Expression As Integer = 13012

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ExpressionStatement Field

JavaScriptAstNodeIdExpressionStatement Field
Gets the ExpressionStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExpressionStatement = 13013
Public Const ExpressionStatement As Integer = 13013

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ForEachStatement Field

JavaScriptAstNodeIdForEachStatement Field
Gets the ForEachStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ForEachStatement = 13014
Public Const ForEachStatement As Integer = 13014

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ForStatement Field

JavaScriptAstNodeIdForStatement Field
Gets the ForStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ForStatement = 13015
Public Const ForStatement As Integer = 13015

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.FunctionBody Field

JavaScriptAstNodeIdFunctionBody Field
Gets the FunctionBody AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FunctionBody = 13016
Public Const FunctionBody As Integer = 13016

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.FunctionDeclaration Field

JavaScriptAstNodeIdFunctionDeclaration Field
Gets the FunctionDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FunctionDeclaration = 13017
Public Const FunctionDeclaration As Integer = 13017

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.FunctionExpression Field

JavaScriptAstNodeIdFunctionExpression Field
Gets the FunctionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FunctionExpression = 13018
Public Const FunctionExpression As Integer = 13018

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.IfStatement Field

JavaScriptAstNodeIdIfStatement Field
Gets the IfStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int IfStatement = 13019
Public Const IfStatement As Integer = 13019

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.InstanceExpression Field

JavaScriptAstNodeIdInstanceExpression Field
Gets the InstanceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InstanceExpression = 13020
Public Const InstanceExpression As Integer = 13020

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.InvocationExpression Field

JavaScriptAstNodeIdInvocationExpression Field
Gets the InvocationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InvocationExpression = 13021
Public Const InvocationExpression As Integer = 13021

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.LabeledStatement Field

JavaScriptAstNodeIdLabeledStatement Field
Gets the LabeledStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LabeledStatement = 13022
Public Const LabeledStatement As Integer = 13022

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.LiteralExpression Field

JavaScriptAstNodeIdLiteralExpression Field
Gets the LiteralExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralExpression = 13023
Public Const LiteralExpression As Integer = 13023

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.MemberAccess Field

JavaScriptAstNodeIdMemberAccess Field
Gets the MemberAccess AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MemberAccess = 13024
Public Const MemberAccess As Integer = 13024

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ObjectCreationExpression Field

JavaScriptAstNodeIdObjectCreationExpression Field
Gets the ObjectCreationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ObjectCreationExpression = 13025
Public Const ObjectCreationExpression As Integer = 13025

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ObjectInitializerExpression Field

JavaScriptAstNodeIdObjectInitializerExpression Field
Gets the ObjectInitializerExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ObjectInitializerExpression = 13026
Public Const ObjectInitializerExpression As Integer = 13026

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ParameterDeclaration Field

JavaScriptAstNodeIdParameterDeclaration Field
Gets the ParameterDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ParameterDeclaration = 13027
Public Const ParameterDeclaration As Integer = 13027

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ParenthesizedExpression Field

JavaScriptAstNodeIdParenthesizedExpression Field
Gets the ParenthesizedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ParenthesizedExpression = 13028
Public Const ParenthesizedExpression As Integer = 13028

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.PropertyDeclaration Field

JavaScriptAstNodeIdPropertyDeclaration Field
Gets the PropertyDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PropertyDeclaration = 13029
Public Const PropertyDeclaration As Integer = 13029

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ReturnStatement Field

JavaScriptAstNodeIdReturnStatement Field
Gets the ReturnStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReturnStatement = 13030
Public Const ReturnStatement As Integer = 13030

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SequenceExpression Field

JavaScriptAstNodeIdSequenceExpression Field
Gets the SequenceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SequenceExpression = 13031
Public Const SequenceExpression As Integer = 13031

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SimpleName Field

JavaScriptAstNodeIdSimpleName Field
Gets the SimpleName AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SimpleName = 13032
Public Const SimpleName As Integer = 13032

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SourceElement Field

JavaScriptAstNodeIdSourceElement Field
Gets the SourceElement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SourceElement = 13033
Public Const SourceElement As Integer = 13033

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.Statement Field

JavaScriptAstNodeIdStatement Field
Gets the Statement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Statement = 13034
Public Const Statement As Integer = 13034

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SwitchSection Field

JavaScriptAstNodeIdSwitchSection Field
Gets the SwitchSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SwitchSection = 13035
Public Const SwitchSection As Integer = 13035

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.SwitchStatement Field

JavaScriptAstNodeIdSwitchStatement Field
Gets the SwitchStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SwitchStatement = 13036
Public Const SwitchStatement As Integer = 13036

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.ThrowStatement Field

JavaScriptAstNodeIdThrowStatement Field
Gets the ThrowStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ThrowStatement = 13037
Public Const ThrowStatement As Integer = 13037

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.TryStatement Field

JavaScriptAstNodeIdTryStatement Field
Gets the TryStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TryStatement = 13038
Public Const TryStatement As Integer = 13038

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.UnaryOperatorExpression Field

JavaScriptAstNodeIdUnaryOperatorExpression Field
Gets the UnaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnaryOperatorExpression = 13039
Public Const UnaryOperatorExpression As Integer = 13039

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.VariableDeclaration Field

JavaScriptAstNodeIdVariableDeclaration Field
Gets the VariableDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int VariableDeclaration = 13040
Public Const VariableDeclaration As Integer = 13040

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.VariableDeclarationExpression Field

JavaScriptAstNodeIdVariableDeclarationExpression Field
Gets the VariableDeclarationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int VariableDeclarationExpression = 13041
Public Const VariableDeclarationExpression As Integer = 13041

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.VariableStatement Field

JavaScriptAstNodeIdVariableStatement Field
Gets the VariableStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int VariableStatement = 13042
Public Const VariableStatement As Integer = 13042

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.WhileStatement Field

JavaScriptAstNodeIdWhileStatement Field
Gets the WhileStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WhileStatement = 13043
Public Const WhileStatement As Integer = 13043

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


JavaScriptAstNodeId.WithStatement Field

JavaScriptAstNodeIdWithStatement Field
Gets the WithStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WithStatement = 13044
Public Const WithStatement As Integer = 13044

Field Value

Type: Int32
See Also

Reference

JavaScriptAstNodeId Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Class

LabeledStatement Class
Represents a labeled statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLabeledStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LabeledStatement : Statement
Public Class LabeledStatement
    Inherits Statement

The LabeledStatement type exposes the following members.

Constructors
 | Name | Description
Public method | LabeledStatement | Initializes a new instance of the LabeledStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Constructor

LabeledStatement Constructor
Initializes a new instance of the LabeledStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabeledStatement()
Public Sub New
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Properties

LabeledStatement Properties

The LabeledStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Label | Gets or sets the label.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.ChildStatement Property

LabeledStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.Id Property

LabeledStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.Label Property

LabeledStatementLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Label { get; set; }
Public Property Label As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The label.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement Methods

LabeledStatement Methods

The LabeledStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LabeledStatement.GetChildrenEnumerator Method

LabeledStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LabeledStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Class

LiteralExpression Class
Represents a literal expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLiteralExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LiteralExpression : Expression
Public Class LiteralExpression
    Inherits Expression

The LiteralExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LiteralExpression | Initializes a new instance of the LiteralExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Constructor

LiteralExpression Constructor
Initializes a new instance of the LiteralExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LiteralExpression()
Public Sub New
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Properties

LiteralExpression Properties

The LiteralExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind of literal.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression.Id Property

LiteralExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression.Kind Property

LiteralExpressionKind Property
Gets or sets the kind of literal.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LiteralExpressionKind Kind { get; set; }
Public Property Kind As LiteralExpressionKind
    Get
    Set

Property Value

Type: LiteralExpressionKind
The kind of literal.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression.StringValue Property

LiteralExpressionStringValue Property
Gets or sets the string value.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StringValue { get; set; }
Public Property StringValue As String
    Get
    Set

Property Value

Type: String
The string value.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


LiteralExpression Methods

LiteralExpression Methods

The LiteralExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Class

MemberAccess Class
Represents a member access.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationMemberAccess

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MemberAccess : Expression
Public Class MemberAccess
    Inherits Expression

The MemberAccess type exposes the following members.

Constructors
 | Name | Description
Public method | MemberAccess | Initializes a new instance of the MemberAccess class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Constructor

MemberAccess Constructor
Initializes a new instance of the MemberAccess class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MemberAccess()
Public Sub New
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Properties

MemberAccess Properties

The MemberAccess type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.Id Property

MemberAccessId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.Name Property

MemberAccessName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Name { get; set; }
Public Property Name As Expression
    Get
    Set

Property Value

Type: Expression
The name.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.TargetExpression Property

MemberAccessTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess Methods

MemberAccess Methods

The MemberAccess type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


MemberAccess.GetChildrenEnumerator Method

MemberAccessGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

MemberAccess Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Class

ObjectCreationExpression Class
Represents an object creation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectCreationExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ObjectCreationExpression : Expression
Public Class ObjectCreationExpression
    Inherits Expression

The ObjectCreationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectCreationExpression | Initializes a new instance of the ObjectCreationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Constructor

ObjectCreationExpression Constructor
Initializes a new instance of the ObjectCreationExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObjectCreationExpression()
Public Sub New
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Properties

ObjectCreationExpression Properties

The ObjectCreationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Type | Gets or sets the type.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.Arguments Property

ObjectCreationExpressionArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.HasArguments Property

ObjectCreationExpressionHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.Id Property

ObjectCreationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.Type Property

ObjectCreationExpressionType Property
Gets or sets the type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Type { get; set; }
Public Property Type As Expression
    Get
    Set

Property Value

Type: Expression
The type.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression Methods

ObjectCreationExpression Methods

The ObjectCreationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectCreationExpression.GetChildrenEnumerator Method

ObjectCreationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ObjectCreationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Class

ObjectInitializerExpression Class
Represents an object initializer expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationObjectInitializerExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ObjectInitializerExpression : Expression
Public Class ObjectInitializerExpression
    Inherits Expression

The ObjectInitializerExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectInitializerExpression | Initializes a new instance of the ObjectInitializerExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Constructor

ObjectInitializerExpression Constructor
Initializes a new instance of the ObjectInitializerExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObjectInitializerExpression()
Public Sub New
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Properties

ObjectInitializerExpression Properties

The ObjectInitializerExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasMembers | Returns whether the Members collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Members | Gets the members.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.HasMembers Property

ObjectInitializerExpressionHasMembers Property
Returns whether the Members collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMembers { get; }
Public ReadOnly Property HasMembers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.Id Property

ObjectInitializerExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.Members Property

ObjectInitializerExpressionMembers Property
Gets the members.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<PropertyDeclaration> Members { get; }
Public ReadOnly Property Members As IList(Of PropertyDeclaration)
    Get

Property Value

Type: IList PropertyDeclaration
The members.
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression Methods

ObjectInitializerExpression Methods

The ObjectInitializerExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ObjectInitializerExpression.GetChildrenEnumerator Method

ObjectInitializerExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ObjectInitializerExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Class

ParameterDeclaration Class
Represents a parameter declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParameterDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParameterDeclaration : AstNodeBase
Public Class ParameterDeclaration
    Inherits AstNodeBase

The ParameterDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterDeclaration | Initializes a new instance of the ParameterDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Constructor

ParameterDeclaration Constructor
Initializes a new instance of the ParameterDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParameterDeclaration()
Public Sub New
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Properties

ParameterDeclaration Properties

The ParameterDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration.Id Property

ParameterDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration.Name Property

ParameterDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration Methods

ParameterDeclaration Methods

The ParameterDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParameterDeclaration.GetChildrenEnumerator Method

ParameterDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParameterDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Class

ParenthesizedExpression Class
Represents a parenthesized expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParenthesizedExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParenthesizedExpression : Expression
Public Class ParenthesizedExpression
    Inherits Expression

The ParenthesizedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ParenthesizedExpression | Initializes a new instance of the ParenthesizedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Constructor

ParenthesizedExpression Constructor
Initializes a new instance of the ParenthesizedExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParenthesizedExpression()
Public Sub New
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Properties

ParenthesizedExpression Properties

The ParenthesizedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression.ChildExpression Property

ParenthesizedExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression.Id Property

ParenthesizedExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression Methods

ParenthesizedExpression Methods

The ParenthesizedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ParenthesizedExpression.GetChildrenEnumerator Method

ParenthesizedExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Class

PropertyDeclaration Class
Represents a property declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationPropertyDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyDeclaration : AstNodeBase
Public Class PropertyDeclaration
    Inherits AstNodeBase

The PropertyDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDeclaration | Initializes a new instance of the PropertyDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Constructor

PropertyDeclaration Constructor
Initializes a new instance of the PropertyDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyDeclaration()
Public Sub New
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Properties

PropertyDeclaration Properties

The PropertyDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Body Property

PropertyDeclarationBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionBody Body { get; set; }
Public Property Body As FunctionBody
    Get
    Set

Property Value

Type: FunctionBody
The body.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.HasParameters Property

PropertyDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Id Property

PropertyDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Initializer Property

PropertyDeclarationInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Name Property

PropertyDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Name { get; set; }
Public Property Name As Expression
    Get
    Set

Property Value

Type: Expression
The name.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.Parameters Property

PropertyDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ParameterDeclaration> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of ParameterDeclaration)
    Get

Property Value

Type: IList ParameterDeclaration
The parameters.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration Methods

PropertyDeclaration Methods

The PropertyDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


PropertyDeclaration.GetChildrenEnumerator Method

PropertyDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PropertyDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Class

ReturnStatement Class
Represents a return statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationReturnStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReturnStatement : Statement
Public Class ReturnStatement
    Inherits Statement

The ReturnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnStatement | Initializes a new instance of the ReturnStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Constructor

ReturnStatement Constructor
Initializes a new instance of the ReturnStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnStatement()
Public Sub New
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Properties

ReturnStatement Properties

The ReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement.Expression Property

ReturnStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement.Id Property

ReturnStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement Methods

ReturnStatement Methods

The ReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ReturnStatement.GetChildrenEnumerator Method

ReturnStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Class

SequenceExpression Class
Represents a sequence expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSequenceExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SequenceExpression : Expression
Public Class SequenceExpression
    Inherits Expression

The SequenceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SequenceExpression | Initializes a new instance of the SequenceExpression class
Top
Properties
 | Name | Description
Public property | ChildExpressions | Gets the child expressions.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildExpressions | Returns whether the ChildExpressions collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Constructor

SequenceExpression Constructor
Initializes a new instance of the SequenceExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SequenceExpression()
Public Sub New
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Properties

SequenceExpression Properties

The SequenceExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpressions | Gets the child expressions.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildExpressions | Returns whether the ChildExpressions collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.ChildExpressions Property

SequenceExpressionChildExpressions Property
Gets the child expressions.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> ChildExpressions { get; }
Public ReadOnly Property ChildExpressions As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The child expressions.
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.HasChildExpressions Property

SequenceExpressionHasChildExpressions Property
Returns whether the ChildExpressions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildExpressions { get; }
Public ReadOnly Property HasChildExpressions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.Id Property

SequenceExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression Methods

SequenceExpression Methods

The SequenceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SequenceExpression.GetChildrenEnumerator Method

SequenceExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SequenceExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Class

SimpleName Class
Represents a simple name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleName : Expression
Public Class SimpleName
    Inherits Expression

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String) | Initializes a new instance of the SimpleName class.
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Constructor

SimpleName Constructor
Overload List
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class.
Public method | SimpleName(String) | Initializes a new instance of the SimpleName class.
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Constructor

SimpleName Constructor
Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName()
Public Sub New
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Constructor (String)

SimpleName Constructor (String)
Initializes a new instance of the SimpleName class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The text value of the identifier.
See Also

Reference

SimpleName Class
SimpleName Overload
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Properties

SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text value of the identifier.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName.Id Property

SimpleNameId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property
Gets or sets the text value of the identifier.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text value of the identifier.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SimpleName Methods

SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Class

SourceElement Class
Represents a source element.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionDeclaration
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SourceElement : AstNodeBase
Public Class SourceElement
    Inherits AstNodeBase

The SourceElement type exposes the following members.

Constructors
 | Name | Description
Public method | SourceElement | Initializes a new instance of the SourceElement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Constructor

SourceElement Constructor
Initializes a new instance of the SourceElement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SourceElement()
Public Sub New
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Properties

SourceElement Properties

The SourceElement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement.Id Property

SourceElementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SourceElement Methods

SourceElement Methods

The SourceElement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SourceElement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement Class

Statement Class
Represents a statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
More...

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Statement : SourceElement
Public Class Statement
    Inherits SourceElement

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBlockStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationBreakStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationContinueStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDebuggerStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationDoStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpressionStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForEachStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationForStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationIfStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationLabeledStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationReturnStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationThrowStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationTryStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWhileStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWithStatement


Statement Constructor

Statement Constructor
Initializes a new instance of the Statement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement()
Public Sub New
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement Properties

Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides SourceElementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement.Id Property

StatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


Statement Methods

Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Class

SwitchSection Class
Represents a switch section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchSection

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SwitchSection : AstNodeBase
Public Class SwitchSection
    Inherits AstNodeBase

The SwitchSection type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchSection | Initializes a new instance of the SwitchSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Constructor

SwitchSection Constructor
Initializes a new instance of the SwitchSection class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SwitchSection()
Public Sub New
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Properties

SwitchSection Properties

The SwitchSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasLabels | Returns whether the Labels collection property contains at least one item.
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Labels | Gets the labels.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.HasLabels Property

SwitchSectionHasLabels Property
Returns whether the Labels collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasLabels { get; }
Public ReadOnly Property HasLabels As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.HasStatements Property

SwitchSectionHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.Id Property

SwitchSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.Labels Property

SwitchSectionLabels Property
Gets the labels.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Labels { get; }
Public ReadOnly Property Labels As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The labels.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.Statements Property

SwitchSectionStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection Methods

SwitchSection Methods

The SwitchSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchSection.GetChildrenEnumerator Method

SwitchSectionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchSection Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Class

SwitchStatement Class
Represents a switch statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SwitchStatement : Statement
Public Class SwitchStatement
    Inherits Statement

The SwitchStatement type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchStatement | Initializes a new instance of the SwitchStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Constructor

SwitchStatement Constructor
Initializes a new instance of the SwitchStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SwitchStatement()
Public Sub New
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Properties

SwitchStatement Properties

The SwitchStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasSections | Returns whether the Sections collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Sections | Gets the sections.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.Expression Property

SwitchStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.HasSections Property

SwitchStatementHasSections Property
Returns whether the Sections collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSections { get; }
Public ReadOnly Property HasSections As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.Id Property

SwitchStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.Sections Property

SwitchStatementSections Property
Gets the sections.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SwitchSection> Sections { get; }
Public ReadOnly Property Sections As IList(Of SwitchSection)
    Get

Property Value

Type: IList SwitchSection
The sections.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement Methods

SwitchStatement Methods

The SwitchStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


SwitchStatement.GetChildrenEnumerator Method

SwitchStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SwitchStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Class

ThrowStatement Class
Represents a throw statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationThrowStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ThrowStatement : Statement
Public Class ThrowStatement
    Inherits Statement

The ThrowStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ThrowStatement | Initializes a new instance of the ThrowStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Constructor

ThrowStatement Constructor
Initializes a new instance of the ThrowStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ThrowStatement()
Public Sub New
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Properties

ThrowStatement Properties

The ThrowStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement.Expression Property

ThrowStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement.Id Property

ThrowStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement Methods

ThrowStatement Methods

The ThrowStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ThrowStatement.GetChildrenEnumerator Method

ThrowStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ThrowStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Class

TryStatement Class
Represents a try statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationTryStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TryStatement : Statement
Public Class TryStatement
    Inherits Statement

The TryStatement type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatement | Initializes a new instance of the TryStatement class
Top
Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Constructor

TryStatement Constructor
Initializes a new instance of the TryStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TryStatement()
Public Sub New
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Properties

TryStatement Properties

The TryStatement type exposes the following members.

Properties
 | Name | Description
Public property | CatchClauses | Gets the catch clauses.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FinallyBlock | Gets or sets the finally block.
Public property | HasCatchClauses | Returns whether the CatchClauses collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TryBlock | Gets or sets the try block.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.CatchClauses Property

TryStatementCatchClauses Property
Gets the catch clauses.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<CatchClause> CatchClauses { get; }
Public ReadOnly Property CatchClauses As IList(Of CatchClause)
    Get

Property Value

Type: IList CatchClause
The catch clauses.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.FinallyBlock Property

TryStatementFinallyBlock Property
Gets or sets the finally block.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement FinallyBlock { get; set; }
Public Property FinallyBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The finally block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.HasCatchClauses Property

TryStatementHasCatchClauses Property
Returns whether the CatchClauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCatchClauses { get; }
Public ReadOnly Property HasCatchClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.Id Property

TryStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.TryBlock Property

TryStatementTryBlock Property
Gets or sets the try block.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement TryBlock { get; set; }
Public Property TryBlock As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The try block.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement Methods

TryStatement Methods

The TryStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


TryStatement.GetChildrenEnumerator Method

TryStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Class

UnaryOperatorExpression Class
Represents an unary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationUnaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnaryOperatorExpression : Expression
Public Class UnaryOperatorExpression
    Inherits Expression

The UnaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UnaryOperatorExpression | Initializes a new instance of the UnaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Constructor

UnaryOperatorExpression Constructor
Initializes a new instance of the UnaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnaryOperatorExpression()
Public Sub New
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Properties

UnaryOperatorExpression Properties

The UnaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.ChildExpression Property

UnaryOperatorExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.Id Property

UnaryOperatorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.Operator Property

UnaryOperatorExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression Methods

UnaryOperatorExpression Methods

The UnaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


UnaryOperatorExpression.GetChildrenEnumerator Method

UnaryOperatorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Class

VariableDeclaration Class
Represents a variable declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclaration

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VariableDeclaration : AstNodeBase
Public Class VariableDeclaration
    Inherits AstNodeBase

The VariableDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclaration | Initializes a new instance of the VariableDeclaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Constructor

VariableDeclaration Constructor
Initializes a new instance of the VariableDeclaration class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclaration()
Public Sub New
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Properties

VariableDeclaration Properties

The VariableDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Initializer | Gets or sets the initializer.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.Id Property

VariableDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.Initializer Property

VariableDeclarationInitializer Property
Gets or sets the initializer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Initializer { get; set; }
Public Property Initializer As Expression
    Get
    Set

Property Value

Type: Expression
The initializer.
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.Name Property

VariableDeclarationName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration Methods

VariableDeclaration Methods

The VariableDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclaration.GetChildrenEnumerator Method

VariableDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclaration Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Class

VariableDeclarationExpression Class
Represents a variable declaration expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclarationExpression

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VariableDeclarationExpression : Expression
Public Class VariableDeclarationExpression
    Inherits Expression

The VariableDeclarationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | VariableDeclarationExpression | Initializes a new instance of the VariableDeclarationExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Constructor

VariableDeclarationExpression Constructor
Initializes a new instance of the VariableDeclarationExpression class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableDeclarationExpression()
Public Sub New
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Properties

VariableDeclarationExpression Properties

The VariableDeclarationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.Declarations Property

VariableDeclarationExpressionDeclarations Property
Gets the declarations.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclaration> Declarations { get; }
Public ReadOnly Property Declarations As IList(Of VariableDeclaration)
    Get

Property Value

Type: IList VariableDeclaration
The declarations.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.HasDeclarations Property

VariableDeclarationExpressionHasDeclarations Property
Returns whether the Declarations collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarations { get; }
Public ReadOnly Property HasDeclarations As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.Id Property

VariableDeclarationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression Methods

VariableDeclarationExpression Methods

The VariableDeclarationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableDeclarationExpression.GetChildrenEnumerator Method

VariableDeclarationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableDeclarationExpression Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Class

VariableStatement Class
Represents a variable statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VariableStatement : Statement
Public Class VariableStatement
    Inherits Statement

The VariableStatement type exposes the following members.

Constructors
 | Name | Description
Public method | VariableStatement | Initializes a new instance of the VariableStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Constructor

VariableStatement Constructor
Initializes a new instance of the VariableStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VariableStatement()
Public Sub New
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Properties

VariableStatement Properties

The VariableStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Declarations | Gets the declarations.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDeclarations | Returns whether the Declarations collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.Declarations Property

VariableStatementDeclarations Property
Gets the declarations.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<VariableDeclaration> Declarations { get; }
Public ReadOnly Property Declarations As IList(Of VariableDeclaration)
    Get

Property Value

Type: IList VariableDeclaration
The declarations.
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.HasDeclarations Property

VariableStatementHasDeclarations Property
Returns whether the Declarations collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDeclarations { get; }
Public ReadOnly Property HasDeclarations As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.Id Property

VariableStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement Methods

VariableStatement Methods

The VariableStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


VariableStatement.GetChildrenEnumerator Method

VariableStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

VariableStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Class

WhileStatement Class
Represents a while statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWhileStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WhileStatement : Statement
Public Class WhileStatement
    Inherits Statement

The WhileStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WhileStatement | Initializes a new instance of the WhileStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Constructor

WhileStatement Constructor
Initializes a new instance of the WhileStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WhileStatement()
Public Sub New
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Properties

WhileStatement Properties

The WhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.ChildStatement Property

WhileStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.ConditionExpression Property

WhileStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.Id Property

WhileStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement Methods

WhileStatement Methods

The WhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WhileStatement.GetChildrenEnumerator Method

WhileStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Class

WithStatement Class
Represents a with statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationWithStatement

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WithStatement : Statement
Public Class WithStatement
    Inherits Statement

The WithStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WithStatement | Initializes a new instance of the WithStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Constructor

WithStatement Constructor
Initializes a new instance of the WithStatement class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WithStatement()
Public Sub New
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Properties

WithStatement Properties

The WithStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.ChildStatement Property

WithStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.Expression Property

WithStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.Id Property

WithStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement Methods

WithStatement Methods

The WithStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


WithStatement.GetChildrenEnumerator Method

WithStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.JavaScript.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace
Contains the core classes related to implementing a JavaScript syntax language.
Classes
 | Class | Description
Public class | JavaScriptClassificationTypeProvider | Represents a provider of IClassificationType objects for the JavaScript language.
Public class | JavaScriptCodeBlockFinder | Provides a JavaScript language code block finder service.
Public class | JavaScriptCompletionProvider | Provides IntelliPrompt completion data for the JavaScript language.
Public class | JavaScriptExampleTextProvider | Represents a example text provider for the JavaScript language.
Public class | JavaScriptGrammar | Represents a Grammar for the JavaScript language.
Public class | JavaScriptGrammarOptions | Contains options for a JavaScript grammar.
Public class | JavaScriptIndentProvider | Provides a JavaScript language indent provider service.
Public class | JavaScriptLexer | Represents a JavaScript lexer (lexical analyzer) implementation.
Public class | JavaScriptLexicalStateId | Contains the lexical state IDs for the JavaScript language.
Public class | JavaScriptOutliner | Provides a JavaScript language outliner service.
Public class | JavaScriptOutliningSource | Represents a JavaScript language range-based outlining source.
Public class | JavaScriptParseData | Stores the results of a JavaScript language parsing operation.
Public class | JavaScriptParser | Represents a parser for the JavaScript language.
Public class | JavaScriptSymbol | Represents a JavaScript symbol, located during parsing.
Public class | JavaScriptSymbolTable | Provides a JavaScript symbol table.
Public class | JavaScriptSyntaxLanguage | Represents a JavaScript syntax language definition.
Public class | JavaScriptTextFormatter | Provides a JavaScript language text formatter service.
Public class | JavaScriptTokenId | Contains the token IDs for the JavaScript language.
Public class | JavaScriptTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the JavaScript language.
Public class | JavaScriptTokenTagger | Represents an ITaggerT for the JavaScript language.
Public class | JavaScriptTokenTaggerProvider | Represents a provider of JavaScriptTokenTagger objects for documents that use the JavaScriptTokenTagger language.
Public class | JavaScriptTokenTaggerProviderTaggerFactory | Implements a factory that can creates JavaScriptTokenTagger objects for a document.
Public class | JsonExampleTextProvider | Represents a example text provider for the JSON language.
Public class | JsonGrammar | Represents a Grammar for the JSON language.
Public class | JsonIndentProvider | Provides a JSON language indent provider service.
Public class | JsonLexer | Represents a JSON lexer (lexical analyzer) implementation.
Public class | JsonOutliner | Provides a JSON language outliner service.
Public class | JsonOutliningSource | Represents a JSON language range-based outlining source.
Public class | JsonParseData | Stores the results of a JSON language parsing operation.
Public class | JsonParser | Represents a parser for the JSON language.
Public class | JsonSyntaxLanguage | Represents a JSON syntax language definition.
Public class | JsonTextFormatter | Provides a JSON language text formatter service.


JavaScriptClassificationTypeProvider Class

JavaScriptClassificationTypeProvider Class
Represents a provider of IClassificationType objects for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptClassificationTypeProvider : IJavaScriptClassificationTypeProvider
Public Class JavaScriptClassificationTypeProvider
    Implements IJavaScriptClassificationTypeProvider

The JavaScriptClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptClassificationTypeProvider | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Public method | JavaScriptClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Constructor

JavaScriptClassificationTypeProvider Constructor
Overload List
 | Name | Description
Public method | JavaScriptClassificationTypeProvider | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Public method | JavaScriptClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the JavaScriptClassificationTypeProvider class.
Top
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Constructor

JavaScriptClassificationTypeProvider Constructor
Initializes a new instance of the JavaScriptClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptClassificationTypeProvider()
Public Sub New
See Also

Reference

JavaScriptClassificationTypeProvider Class
JavaScriptClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

JavaScriptClassificationTypeProvider Constructor (IHighlightingStyleRegistry)
Initializes a new instance of the JavaScriptClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

JavaScriptClassificationTypeProvider Class
JavaScriptClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Properties

JavaScriptClassificationTypeProvider Properties

The JavaScriptClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Comment Property

JavaScriptClassificationTypeProviderComment Property
Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Comment { get; }
Public ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.

Implements

IJavaScriptClassificationTypeProviderComment
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Identifier Property

JavaScriptClassificationTypeProviderIdentifier Property
Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Identifier { get; }
Public ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.

Implements

IJavaScriptClassificationTypeProviderIdentifier
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Keyword Property

JavaScriptClassificationTypeProviderKeyword Property
Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Keyword { get; }
Public ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.

Implements

IJavaScriptClassificationTypeProviderKeyword
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Number Property

JavaScriptClassificationTypeProviderNumber Property
Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Number { get; }
Public ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.

Implements

IJavaScriptClassificationTypeProviderNumber
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Operator Property

JavaScriptClassificationTypeProviderOperator Property
Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Operator { get; }
Public ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.

Implements

IJavaScriptClassificationTypeProviderOperator
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.Registry Property

JavaScriptClassificationTypeProviderRegistry Property
Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.String Property

JavaScriptClassificationTypeProviderString Property
Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType String { get; }
Public ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.

Implements

IJavaScriptClassificationTypeProviderString
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider Methods

JavaScriptClassificationTypeProvider Methods

The JavaScriptClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptClassificationTypeProvider.RegisterAll Method

JavaScriptClassificationTypeProviderRegisterAll Method
Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

JavaScriptClassificationTypeProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Class

JavaScriptCodeBlockFinder Class
Provides a JavaScript language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptCodeBlockFinder : LLParseDataCodeBlockFinder
Public Class JavaScriptCodeBlockFinder
    Inherits LLParseDataCodeBlockFinder

The JavaScriptCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptCodeBlockFinder | Initializes a new instance of the JavaScriptCodeBlockFinder class.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Constructor

JavaScriptCodeBlockFinder Constructor
Initializes a new instance of the JavaScriptCodeBlockFinder class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptCodeBlockFinder()
Public Sub New
See Also

Reference

JavaScriptCodeBlockFinder Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Properties

JavaScriptCodeBlockFinder Properties

The JavaScriptCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

JavaScriptCodeBlockFinder Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCodeBlockFinder Methods

JavaScriptCodeBlockFinder Methods

The JavaScriptCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

JavaScriptCodeBlockFinder Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Class

JavaScriptCompletionProvider Class
Provides IntelliPrompt completion data for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptCompletionProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptCompletionProvider : CompletionProviderBase
Public Class JavaScriptCompletionProvider
    Inherits CompletionProviderBase

The JavaScriptCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptCompletionProvider | Initializes a new instance of the JavaScriptCompletionProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Constructor

JavaScriptCompletionProvider Constructor
Initializes a new instance of the JavaScriptCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptCompletionProvider()
Public Sub New
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Properties

JavaScriptCompletionProvider Properties

The JavaScriptCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider Methods

JavaScriptCompletionProvider Methods

The JavaScriptCompletionProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider.OnSessionOpening Method

JavaScriptCompletionProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptCompletionProvider.RequestSession Method

JavaScriptCompletionProviderRequestSession Method
Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

JavaScriptCompletionProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Class

JavaScriptExampleTextProvider Class
Represents a example text provider for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptExampleTextProvider : IExampleTextProvider
Public Class JavaScriptExampleTextProvider
    Implements IExampleTextProvider

The JavaScriptExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptExampleTextProvider | Initializes a new instance of the JavaScriptExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Constructor

JavaScriptExampleTextProvider Constructor
Initializes a new instance of the JavaScriptExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptExampleTextProvider()
Public Sub New
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Properties

JavaScriptExampleTextProvider Properties

The JavaScriptExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider.ExampleText Property

JavaScriptExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptExampleTextProvider Methods

JavaScriptExampleTextProvider Methods

The JavaScriptExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Class

JavaScriptGrammar Class
Represents a Grammar for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptGrammar

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptGrammar : Grammar
Public Class JavaScriptGrammar
    Inherits Grammar

The JavaScriptGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptGrammar | Initializes a new instance of the JavaScriptGrammar class using default options.
Public method | JavaScriptGrammar(IJavaScriptGrammarOptions) | Initializes a new instance of the JavaScriptGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Constructor

JavaScriptGrammar Constructor
Overload List
 | Name | Description
Public method | JavaScriptGrammar | Initializes a new instance of the JavaScriptGrammar class using default options.
Public method | JavaScriptGrammar(IJavaScriptGrammarOptions) | Initializes a new instance of the JavaScriptGrammar class.
Top
See Also

Reference

JavaScriptGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Constructor

JavaScriptGrammar Constructor
Initializes a new instance of the JavaScriptGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptGrammar()
Public Sub New
See Also

Reference

JavaScriptGrammar Class
JavaScriptGrammar Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Constructor (IJavaScriptGrammarOptions)

JavaScriptGrammar Constructor (IJavaScriptGrammarOptions)
Initializes a new instance of the JavaScriptGrammar class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptGrammar(
    IJavaScriptGrammarOptions options
)
Public Sub New (
    options As IJavaScriptGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptGrammarOptions
An IJavaScriptGrammarOptions that contains options for the grammar.
See Also

Reference

JavaScriptGrammar Class
JavaScriptGrammar Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Properties

JavaScriptGrammar Properties

The JavaScriptGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

JavaScriptGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammar Methods

JavaScriptGrammar Methods

The JavaScriptGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

JavaScriptGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Class

JavaScriptGrammarOptions Class
Contains options for a JavaScript grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptGrammarOptions

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptGrammarOptions : IJavaScriptGrammarOptions
Public Class JavaScriptGrammarOptions
    Implements IJavaScriptGrammarOptions

The JavaScriptGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptGrammarOptions | Initializes a new instance of the JavaScriptGrammarOptions class.
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Constructor

JavaScriptGrammarOptions Constructor
Initializes a new instance of the JavaScriptGrammarOptions class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptGrammarOptions()
Public Sub New
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Properties

JavaScriptGrammarOptions Properties

The JavaScriptGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions.RootNonTerminal Property

JavaScriptGrammarOptionsRootNonTerminal Property
Gets or sets a JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptGrammarRootNonTerminal RootNonTerminal { get; set; }
Public Property RootNonTerminal As JavaScriptGrammarRootNonTerminal
    Get
    Set

Property Value

Type: JavaScriptGrammarRootNonTerminal
A JavaScriptGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.

Implements

IJavaScriptGrammarOptionsRootNonTerminal
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptGrammarOptions Methods

JavaScriptGrammarOptions Methods

The JavaScriptGrammarOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptGrammarOptions Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Class

JavaScriptIndentProvider Class
Provides a JavaScript language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptIndentProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptIndentProvider : DelimiterIndentProvider
Public Class JavaScriptIndentProvider
    Inherits DelimiterIndentProvider

The JavaScriptIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptIndentProvider | Initializes a new instance of the JavaScriptIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Constructor

JavaScriptIndentProvider Constructor
Initializes a new instance of the JavaScriptIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptIndentProvider()
Public Sub New
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Properties

JavaScriptIndentProvider Properties

The JavaScriptIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.Mode Property

JavaScriptIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider Methods

JavaScriptIndentProvider Methods

The JavaScriptIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.GetIndentAmount Method

JavaScriptIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.OnDocumentTextChanged Method

JavaScriptIndentProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overrides Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptIndentProvider.OnDocumentTextChanging Method

JavaScriptIndentProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overrides Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

JavaScriptIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Class

JavaScriptLexer Class
Represents a JavaScript lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexer

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptLexer : MergableLexerBase
Public Class JavaScriptLexer
    Inherits MergableLexerBase

The JavaScriptLexer type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptLexer | Initializes a new instance of the JavaScriptLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Constructor

JavaScriptLexer Constructor
Initializes a new instance of the JavaScriptLexer class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptLexer()
Public Sub New
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Properties

JavaScriptLexer Properties

The JavaScriptLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.LexicalStates Property

JavaScriptLexerLexicalStates Property
Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Methods

JavaScriptLexer Methods

The JavaScriptLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.GetAllLexicalStateTransitions Method

JavaScriptLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.GetNextToken Method

JavaScriptLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.IsIdentifierPartCharacter Method

JavaScriptLexerIsIdentifierPartCharacter Method
Returns whether the specified character is an identifier part character.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierPartCharacter(
    char ch
)
Public Shared Function IsIdentifierPartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier part character; otherwise, false.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer.IsIdentifierStartCharacter Method

JavaScriptLexerIsIdentifierStartCharacter Method
Returns whether the specified character is an identifier start character.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierStartCharacter(
    char ch
)
Public Shared Function IsIdentifierStartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier start character; otherwise, false.
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexer Events

JavaScriptLexer Events

The JavaScriptLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JavaScriptLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Class

JavaScriptLexicalStateId Class
Contains the lexical state IDs for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexicalStateId

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptLexicalStateId : LexicalStateIdProviderBase
Public Class JavaScriptLexicalStateId
    Inherits LexicalStateIdProviderBase

The JavaScriptLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptLexicalStateId | Initializes a new instance of the JavaScriptLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Constructor

JavaScriptLexicalStateId Constructor
Initializes a new instance of the JavaScriptLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptLexicalStateId()
Public Sub New
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Properties

JavaScriptLexicalStateId Properties

The JavaScriptLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.MaxId Property

JavaScriptLexicalStateIdMaxId Property
Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.MinId Property

JavaScriptLexicalStateIdMinId Property
Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Methods

JavaScriptLexicalStateId Methods

The JavaScriptLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.ContainsId Method

JavaScriptLexicalStateIdContainsId Method
Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.GetDescription Method

JavaScriptLexicalStateIdGetDescription Method
Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.GetKey Method

JavaScriptLexicalStateIdGetKey Method
Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId Fields

JavaScriptLexicalStateId Fields

The JavaScriptLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptLexicalStateId.Default Field

JavaScriptLexicalStateIdDefault Field
Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Default = 13000
Public Const Default As Integer = 13000

Field Value

Type: Int32
See Also

Reference

JavaScriptLexicalStateId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Class

JavaScriptOutliner Class
Provides a JavaScript language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptOutliner

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptOutliner : IOutliner
Public Class JavaScriptOutliner
    Implements IOutliner

The JavaScriptOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptOutliner | Initializes a new instance of the JavaScriptOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Constructor

JavaScriptOutliner Constructor
Initializes a new instance of the JavaScriptOutliner class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptOutliner()
Public Sub New
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Properties

JavaScriptOutliner Properties

The JavaScriptOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner.UpdateTrigger Property

JavaScriptOutlinerUpdateTrigger Property
Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner Methods

JavaScriptOutliner Methods

The JavaScriptOutliner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliner.GetOutliningSource Method

JavaScriptOutlinerGetOutliningSource Method
Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

JavaScriptOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource Class

JavaScriptOutliningSource Class
Represents a JavaScript language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptOutliningSource

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptOutliningSource : RangeOutliningSourceBase
Public Class JavaScriptOutliningSource
    Inherits RangeOutliningSourceBase

The JavaScriptOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptOutliningSource | Initializes a new instance of the JavaScriptOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJavaScriptParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJavaScriptParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource Constructor

JavaScriptOutliningSource Constructor
Initializes a new instance of the JavaScriptOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource Methods

JavaScriptOutliningSource Methods

The JavaScriptOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJavaScriptParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJavaScriptParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesFromParseData Method

JavaScriptOutliningSourceAddNodesFromParseData Method
Overload List
 | Name | Description
Public method | AddNodesFromParseData(IJavaScriptParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJavaScriptParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesFromParseData Method (IJavaScriptParseData)

JavaScriptOutliningSourceAddNodesFromParseData Method (IJavaScriptParseData)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IJavaScriptParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IJavaScriptParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptParseData
The IJavaScriptParseData containing AST data.
See Also

Reference

JavaScriptOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesFromParseData Method (IJavaScriptParseData, ITextBufferReader)

JavaScriptOutliningSourceAddNodesFromParseData Method (IJavaScriptParseData, ITextBufferReader)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IJavaScriptParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IJavaScriptParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptParseData
The IJavaScriptParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

JavaScriptOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptOutliningSource.AddNodesRecursive Method

JavaScriptOutliningSourceAddNodesRecursive Method
Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

JavaScriptOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Class

JavaScriptParseData Class
Stores the results of a JavaScript language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParseData

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptParseData : LLParseData,
    IJavaScriptParseData, ILLParseData, IParseData, IParseErrorProvider
Public Class JavaScriptParseData
    Inherits LLParseData
    Implements IJavaScriptParseData, ILLParseData, IParseData, IParseErrorProvider

The JavaScriptParseData type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptParseData | Initializes a new instance of the JavaScriptParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Public property | SymbolTable | Gets or sets the table of symbols located within the document.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Constructor

JavaScriptParseData Constructor
Initializes a new instance of the JavaScriptParseData class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptParseData()
Public Sub New
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Properties

JavaScriptParseData Properties

The JavaScriptParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Public property | SymbolTable | Gets or sets the table of symbols located within the document.
Top
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData.SymbolTable Property

JavaScriptParseDataSymbolTable Property
Gets or sets the table of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IJavaScriptSymbolTable SymbolTable { get; set; }
Public Property SymbolTable As IJavaScriptSymbolTable
    Get
    Set

Property Value

Type: IJavaScriptSymbolTable
The table of symbols located within the document.

Implements

IJavaScriptParseDataSymbolTable
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParseData Methods

JavaScriptParseData Methods

The JavaScriptParseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Class

JavaScriptParser Class
Represents a parser for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParser

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptParser : LLParserBase
Public Class JavaScriptParser
    Inherits LLParserBase

The JavaScriptParser type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class.
Public method | JavaScriptParser(Grammar) | Initializes a new instance of the JavaScriptParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Constructor

JavaScriptParser Constructor
Overload List
 | Name | Description
Public method | JavaScriptParser | Initializes a new instance of the JavaScriptParser class.
Public method | JavaScriptParser(Grammar) | Initializes a new instance of the JavaScriptParser class.
Top
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Constructor

JavaScriptParser Constructor
Initializes a new instance of the JavaScriptParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptParser()
Public Sub New
See Also

Reference

JavaScriptParser Class
JavaScriptParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Constructor (Grammar)

JavaScriptParser Constructor (Grammar)
Initializes a new instance of the JavaScriptParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

JavaScriptParser Class
JavaScriptParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Properties

JavaScriptParser Properties

The JavaScriptParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser Methods

JavaScriptParser Methods

The JavaScriptParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser.CreateParseData Method

JavaScriptParserCreateParseData Method
Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser.CreateTokenReader Method

JavaScriptParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptParser.InitializeParserState Method

JavaScriptParserInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

JavaScriptParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Class

JavaScriptSymbol Class
Represents a JavaScript symbol, located during parsing.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbol

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptSymbol : IJavaScriptSymbol
Public Class JavaScriptSymbol
    Implements IJavaScriptSymbol

The JavaScriptSymbol type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptSymbol | Initializes a new instance of the JavaScriptSymbol class.
Top
Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Constructor

JavaScriptSymbol Constructor
Initializes a new instance of the JavaScriptSymbol class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptSymbol(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The symbol name.
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Properties

JavaScriptSymbol Properties

The JavaScriptSymbol type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the symbol name.
Public property | UsageCount | Gets or sets the usage count.
Top
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol.Name Property

JavaScriptSymbolName Property
Gets the symbol name.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The symbol name.

Implements

IJavaScriptSymbolName
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol.UsageCount Property

JavaScriptSymbolUsageCount Property
Gets or sets the usage count.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int UsageCount { get; set; }
Public Property UsageCount As Integer
    Get
    Set

Property Value

Type: Int32
The usage count.

Implements

IJavaScriptSymbolUsageCount
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbol Methods

JavaScriptSymbol Methods

The JavaScriptSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptSymbol Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Class

JavaScriptSymbolTable Class
Provides a JavaScript symbol table.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSymbolTable

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptSymbolTable : IJavaScriptSymbolTable
Public Class JavaScriptSymbolTable
    Implements IJavaScriptSymbolTable

The JavaScriptSymbolTable type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptSymbolTable | Initializes a new instance of the JavaScriptSymbolTable class
Top
Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Constructor

JavaScriptSymbolTable Constructor
Initializes a new instance of the JavaScriptSymbolTable class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptSymbolTable()
Public Sub New
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Properties

JavaScriptSymbolTable Properties

The JavaScriptSymbolTable type exposes the following members.

Properties
 | Name | Description
Public property | Symbols | Gets the collection of symbols located within the document.
Top
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable.Symbols Property

JavaScriptSymbolTableSymbols Property
Gets the collection of symbols located within the document.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IJavaScriptSymbol> Symbols { get; }
Public ReadOnly Property Symbols As IEnumerable(Of IJavaScriptSymbol)
    Get

Property Value

Type: IEnumerable IJavaScriptSymbol
The collection of symbols located within the document.

Implements

IJavaScriptSymbolTableSymbols
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSymbolTable Methods

JavaScriptSymbolTable Methods

The JavaScriptSymbolTable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptSymbolTable Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Class

JavaScriptSyntaxLanguage Class
Represents a JavaScript syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptSyntaxLanguage : SyntaxLanguage,
    ITextViewLifecycleEventSink
Public Class JavaScriptSyntaxLanguage
    Inherits SyntaxLanguage
    Implements ITextViewLifecycleEventSink

The JavaScriptSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptSyntaxLanguage | Initializes a new instance of the JavaScriptSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Constructor

JavaScriptSyntaxLanguage Constructor
Initializes a new instance of the JavaScriptSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptSyntaxLanguage()
Public Sub New
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Properties

JavaScriptSyntaxLanguage Properties

The JavaScriptSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Methods

JavaScriptSyntaxLanguage Methods

The JavaScriptSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptSyntaxLanguage Events

JavaScriptSyntaxLanguage Events

The JavaScriptSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JavaScriptSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Class

JavaScriptTextFormatter Class
Provides a JavaScript language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTextFormatter

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptTextFormatter : ITextFormatter
Public Class JavaScriptTextFormatter
    Implements ITextFormatter

The JavaScriptTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTextFormatter | Initializes a new instance of the JavaScriptTextFormatter class
Top
Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Constructor

JavaScriptTextFormatter Constructor
Initializes a new instance of the JavaScriptTextFormatter class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptTextFormatter()
Public Sub New
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Properties

JavaScriptTextFormatter Properties

The JavaScriptTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter.IsOpeningBraceOnNewLine Property

JavaScriptTextFormatterIsOpeningBraceOnNewLine Property
Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOpeningBraceOnNewLine { get; set; }
Public Property IsOpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter Methods

JavaScriptTextFormatter Methods

The JavaScriptTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTextFormatter.Format Method

JavaScriptTextFormatterFormat Method
Formats the specified snapshot range.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Format(
    TextSnapshotRange snapshotRange
)
Public Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The snapshot range.

Implements

ITextFormatterFormat(TextSnapshotRange)
See Also

Reference

JavaScriptTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Class

JavaScriptTokenId Class
Contains the token IDs for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenId

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptTokenId : TokenIdProviderBase
Public Class JavaScriptTokenId
    Inherits TokenIdProviderBase

The JavaScriptTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenId | Initializes a new instance of the JavaScriptTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Backslash | Gets the Backslash token ID.
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDebugger | Gets the KeywordDebugger token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelete | Gets the KeywordDelete token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInstanceOf | Gets the KeywordInstanceOf token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordVar | Gets the KeywordVar token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralRegularExpression | Gets the LiteralRegularExpression token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStrictEquality | Gets the OperatorStrictEquality token ID.
OperatorStrictInequality | Gets the OperatorStrictInequality token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
OperatorZeroFillRightShift | Gets the OperatorZeroFillRightShift token ID.
OperatorZeroFillRightShiftAssignment | Gets the OperatorZeroFillRightShiftAssignment token ID.
QuestionMark | Gets the QuestionMark token ID.
ReservedKeywordClass | Gets the ReservedKeywordClass token ID.
ReservedKeywordConst | Gets the ReservedKeywordConst token ID.
ReservedKeywordEnum | Gets the ReservedKeywordEnum token ID.
ReservedKeywordExport | Gets the ReservedKeywordExport token ID.
ReservedKeywordExtends | Gets the ReservedKeywordExtends token ID.
ReservedKeywordImplements | Gets the ReservedKeywordImplements token ID.
ReservedKeywordImport | Gets the ReservedKeywordImport token ID.
ReservedKeywordInterface | Gets the ReservedKeywordInterface token ID.
ReservedKeywordLet | Gets the ReservedKeywordLet token ID.
ReservedKeywordPackage | Gets the ReservedKeywordPackage token ID.
ReservedKeywordPrivate | Gets the ReservedKeywordPrivate token ID.
ReservedKeywordProtected | Gets the ReservedKeywordProtected token ID.
ReservedKeywordPublic | Gets the ReservedKeywordPublic token ID.
ReservedKeywordStatic | Gets the ReservedKeywordStatic token ID.
ReservedKeywordSuper | Gets the ReservedKeywordSuper token ID.
ReservedKeywordYield | Gets the ReservedKeywordYield token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Constructor

JavaScriptTokenId Constructor
Initializes a new instance of the JavaScriptTokenId class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptTokenId()
Public Sub New
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Properties

JavaScriptTokenId Properties

The JavaScriptTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.MaxId Property

JavaScriptTokenIdMaxId Property
Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.MinId Property

JavaScriptTokenIdMinId Property
Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Methods

JavaScriptTokenId Methods

The JavaScriptTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ContainsId Method

JavaScriptTokenIdContainsId Method
Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.GetDescription Method

JavaScriptTokenIdGetDescription Method
Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.GetKey Method

JavaScriptTokenIdGetKey Method
Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsCommentClassificationType Method

JavaScriptTokenIdIsCommentClassificationType Method
Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsIdentifierClassificationType Method

JavaScriptTokenIdIsIdentifierClassificationType Method
Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsKeywordClassificationType Method

JavaScriptTokenIdIsKeywordClassificationType Method
Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsNumberClassificationType Method

JavaScriptTokenIdIsNumberClassificationType Method
Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsOperatorClassificationType Method

JavaScriptTokenIdIsOperatorClassificationType Method
Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.IsStringClassificationType Method

JavaScriptTokenIdIsStringClassificationType Method
Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId Fields

JavaScriptTokenId Fields

The JavaScriptTokenId type exposes the following members.

Fields
Name | Description
Backslash | Gets the Backslash token ID.
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentMultiLine | Gets the CommentMultiLine token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDebugger | Gets the KeywordDebugger token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelete | Gets the KeywordDelete token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInstanceOf | Gets the KeywordInstanceOf token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNull | Gets the KeywordNull token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSwitch | Gets the KeywordSwitch token ID.
KeywordThis | Gets the KeywordThis token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordVar | Gets the KeywordVar token ID.
KeywordVoid | Gets the KeywordVoid token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralRegularExpression | Gets the LiteralRegularExpression token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorConditionalAnd | Gets the OperatorConditionalAnd token ID.
OperatorConditionalOr | Gets the OperatorConditionalOr token ID.
OperatorDecrement | Gets the OperatorDecrement token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorIncrement | Gets the OperatorIncrement token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorNegation | Gets the OperatorNegation token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStrictEquality | Gets the OperatorStrictEquality token ID.
OperatorStrictInequality | Gets the OperatorStrictInequality token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
OperatorZeroFillRightShift | Gets the OperatorZeroFillRightShift token ID.
OperatorZeroFillRightShiftAssignment | Gets the OperatorZeroFillRightShiftAssignment token ID.
QuestionMark | Gets the QuestionMark token ID.
ReservedKeywordClass | Gets the ReservedKeywordClass token ID.
ReservedKeywordConst | Gets the ReservedKeywordConst token ID.
ReservedKeywordEnum | Gets the ReservedKeywordEnum token ID.
ReservedKeywordExport | Gets the ReservedKeywordExport token ID.
ReservedKeywordExtends | Gets the ReservedKeywordExtends token ID.
ReservedKeywordImplements | Gets the ReservedKeywordImplements token ID.
ReservedKeywordImport | Gets the ReservedKeywordImport token ID.
ReservedKeywordInterface | Gets the ReservedKeywordInterface token ID.
ReservedKeywordLet | Gets the ReservedKeywordLet token ID.
ReservedKeywordPackage | Gets the ReservedKeywordPackage token ID.
ReservedKeywordPrivate | Gets the ReservedKeywordPrivate token ID.
ReservedKeywordProtected | Gets the ReservedKeywordProtected token ID.
ReservedKeywordPublic | Gets the ReservedKeywordPublic token ID.
ReservedKeywordStatic | Gets the ReservedKeywordStatic token ID.
ReservedKeywordSuper | Gets the ReservedKeywordSuper token ID.
ReservedKeywordYield | Gets the ReservedKeywordYield token ID.
SemiColon | Gets the SemiColon token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Backslash Field

JavaScriptTokenIdBackslash Field
Gets the Backslash token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Backslash = 13014
Public Const Backslash As Integer = 13014

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CloseCurlyBrace Field

JavaScriptTokenIdCloseCurlyBrace Field
Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 13004
Public Const CloseCurlyBrace As Integer = 13004

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CloseParenthesis Field

JavaScriptTokenIdCloseParenthesis Field
Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 13008
Public Const CloseParenthesis As Integer = 13008

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CloseSquareBrace Field

JavaScriptTokenIdCloseSquareBrace Field
Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 13006
Public Const CloseSquareBrace As Integer = 13006

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Colon Field

JavaScriptTokenIdColon Field
Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Colon = 13011
Public Const Colon As Integer = 13011

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Comma Field

JavaScriptTokenIdComma Field
Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Comma = 13010
Public Const Comma As Integer = 13010

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CommentMultiLine Field

JavaScriptTokenIdCommentMultiLine Field
Gets the CommentMultiLine token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentMultiLine = 13016
Public Const CommentMultiLine As Integer = 13016

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.CommentSingleLine Field

JavaScriptTokenIdCommentSingleLine Field
Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 13015
Public Const CommentSingleLine As Integer = 13015

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Dot Field

JavaScriptTokenIdDot Field
Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Dot = 13009
Public Const Dot As Integer = 13009

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Identifier Field

JavaScriptTokenIdIdentifier Field
Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Identifier = 13023
Public Const Identifier As Integer = 13023

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordBreak Field

JavaScriptTokenIdKeywordBreak Field
Gets the KeywordBreak token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordBreak = 13024
Public Const KeywordBreak As Integer = 13024

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordCase Field

JavaScriptTokenIdKeywordCase Field
Gets the KeywordCase token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCase = 13025
Public Const KeywordCase As Integer = 13025

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordCatch Field

JavaScriptTokenIdKeywordCatch Field
Gets the KeywordCatch token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCatch = 13026
Public Const KeywordCatch As Integer = 13026

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordContinue Field

JavaScriptTokenIdKeywordContinue Field
Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 13027
Public Const KeywordContinue As Integer = 13027

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDebugger Field

JavaScriptTokenIdKeywordDebugger Field
Gets the KeywordDebugger token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDebugger = 13028
Public Const KeywordDebugger As Integer = 13028

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDefault Field

JavaScriptTokenIdKeywordDefault Field
Gets the KeywordDefault token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDefault = 13029
Public Const KeywordDefault As Integer = 13029

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDelete Field

JavaScriptTokenIdKeywordDelete Field
Gets the KeywordDelete token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDelete = 13030
Public Const KeywordDelete As Integer = 13030

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordDo Field

JavaScriptTokenIdKeywordDo Field
Gets the KeywordDo token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDo = 13031
Public Const KeywordDo As Integer = 13031

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordElse Field

JavaScriptTokenIdKeywordElse Field
Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordElse = 13032
Public Const KeywordElse As Integer = 13032

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFalse Field

JavaScriptTokenIdKeywordFalse Field
Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 13033
Public Const KeywordFalse As Integer = 13033

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFinally Field

JavaScriptTokenIdKeywordFinally Field
Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 13034
Public Const KeywordFinally As Integer = 13034

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFor Field

JavaScriptTokenIdKeywordFor Field
Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFor = 13035
Public Const KeywordFor As Integer = 13035

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordFunction Field

JavaScriptTokenIdKeywordFunction Field
Gets the KeywordFunction token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFunction = 13036
Public Const KeywordFunction As Integer = 13036

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordIf Field

JavaScriptTokenIdKeywordIf Field
Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIf = 13037
Public Const KeywordIf As Integer = 13037

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordIn Field

JavaScriptTokenIdKeywordIn Field
Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIn = 13038
Public Const KeywordIn As Integer = 13038

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordInstanceOf Field

JavaScriptTokenIdKeywordInstanceOf Field
Gets the KeywordInstanceOf token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInstanceOf = 13039
Public Const KeywordInstanceOf As Integer = 13039

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordNew Field

JavaScriptTokenIdKeywordNew Field
Gets the KeywordNew token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNew = 13040
Public Const KeywordNew As Integer = 13040

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordNull Field

JavaScriptTokenIdKeywordNull Field
Gets the KeywordNull token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNull = 13041
Public Const KeywordNull As Integer = 13041

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordReturn Field

JavaScriptTokenIdKeywordReturn Field
Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 13042
Public Const KeywordReturn As Integer = 13042

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordSwitch Field

JavaScriptTokenIdKeywordSwitch Field
Gets the KeywordSwitch token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSwitch = 13043
Public Const KeywordSwitch As Integer = 13043

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordThis Field

JavaScriptTokenIdKeywordThis Field
Gets the KeywordThis token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordThis = 13044
Public Const KeywordThis As Integer = 13044

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordThrow Field

JavaScriptTokenIdKeywordThrow Field
Gets the KeywordThrow token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordThrow = 13045
Public Const KeywordThrow As Integer = 13045

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordTrue Field

JavaScriptTokenIdKeywordTrue Field
Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 13046
Public Const KeywordTrue As Integer = 13046

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordTry Field

JavaScriptTokenIdKeywordTry Field
Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTry = 13047
Public Const KeywordTry As Integer = 13047

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordTypeOf Field

JavaScriptTokenIdKeywordTypeOf Field
Gets the KeywordTypeOf token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTypeOf = 13048
Public Const KeywordTypeOf As Integer = 13048

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordVar Field

JavaScriptTokenIdKeywordVar Field
Gets the KeywordVar token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordVar = 13049
Public Const KeywordVar As Integer = 13049

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordVoid Field

JavaScriptTokenIdKeywordVoid Field
Gets the KeywordVoid token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordVoid = 13050
Public Const KeywordVoid As Integer = 13050

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordWhile Field

JavaScriptTokenIdKeywordWhile Field
Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 13051
Public Const KeywordWhile As Integer = 13051

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.KeywordWith Field

JavaScriptTokenIdKeywordWith Field
Gets the KeywordWith token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWith = 13052
Public Const KeywordWith As Integer = 13052

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LineContinuation Field

JavaScriptTokenIdLineContinuation Field
Gets the LineContinuation token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineContinuation = 13002
Public Const LineContinuation As Integer = 13002

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LineTerminator Field

JavaScriptTokenIdLineTerminator Field
Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineTerminator = 13001
Public Const LineTerminator As Integer = 13001

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralDecimalInteger Field

JavaScriptTokenIdLiteralDecimalInteger Field
Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 13017
Public Const LiteralDecimalInteger As Integer = 13017

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralDoubleQuoteString Field

JavaScriptTokenIdLiteralDoubleQuoteString Field
Gets the LiteralDoubleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDoubleQuoteString = 13018
Public Const LiteralDoubleQuoteString As Integer = 13018

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralHexadecimalInteger Field

JavaScriptTokenIdLiteralHexadecimalInteger Field
Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 13019
Public Const LiteralHexadecimalInteger As Integer = 13019

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralReal Field

JavaScriptTokenIdLiteralReal Field
Gets the LiteralReal token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralReal = 13020
Public Const LiteralReal As Integer = 13020

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralRegularExpression Field

JavaScriptTokenIdLiteralRegularExpression Field
Gets the LiteralRegularExpression token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralRegularExpression = 13021
Public Const LiteralRegularExpression As Integer = 13021

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.LiteralSingleQuoteString Field

JavaScriptTokenIdLiteralSingleQuoteString Field
Gets the LiteralSingleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralSingleQuoteString = 13022
Public Const LiteralSingleQuoteString As Integer = 13022

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OpenCurlyBrace Field

JavaScriptTokenIdOpenCurlyBrace Field
Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 13003
Public Const OpenCurlyBrace As Integer = 13003

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OpenParenthesis Field

JavaScriptTokenIdOpenParenthesis Field
Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 13007
Public Const OpenParenthesis As Integer = 13007

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OpenSquareBrace Field

JavaScriptTokenIdOpenSquareBrace Field
Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 13005
Public Const OpenSquareBrace As Integer = 13005

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorAddition Field

JavaScriptTokenIdOperatorAddition Field
Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 13077
Public Const OperatorAddition As Integer = 13077

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorAdditionAssignment Field

JavaScriptTokenIdOperatorAdditionAssignment Field
Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 13095
Public Const OperatorAdditionAssignment As Integer = 13095

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorAssignment Field

JavaScriptTokenIdOperatorAssignment Field
Gets the OperatorAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAssignment = 13094
Public Const OperatorAssignment As Integer = 13094

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseAnd Field

JavaScriptTokenIdOperatorBitwiseAnd Field
Gets the OperatorBitwiseAnd token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAnd = 13087
Public Const OperatorBitwiseAnd As Integer = 13087

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseAndAssignment Field

JavaScriptTokenIdOperatorBitwiseAndAssignment Field
Gets the OperatorBitwiseAndAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAndAssignment = 13103
Public Const OperatorBitwiseAndAssignment As Integer = 13103

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseOr Field

JavaScriptTokenIdOperatorBitwiseOr Field
Gets the OperatorBitwiseOr token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOr = 13088
Public Const OperatorBitwiseOr As Integer = 13088

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorBitwiseOrAssignment Field

JavaScriptTokenIdOperatorBitwiseOrAssignment Field
Gets the OperatorBitwiseOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOrAssignment = 13104
Public Const OperatorBitwiseOrAssignment As Integer = 13104

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorConditionalAnd Field

JavaScriptTokenIdOperatorConditionalAnd Field
Gets the OperatorConditionalAnd token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorConditionalAnd = 13092
Public Const OperatorConditionalAnd As Integer = 13092

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorConditionalOr Field

JavaScriptTokenIdOperatorConditionalOr Field
Gets the OperatorConditionalOr token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorConditionalOr = 13093
Public Const OperatorConditionalOr As Integer = 13093

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorDecrement Field

JavaScriptTokenIdOperatorDecrement Field
Gets the OperatorDecrement token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDecrement = 13083
Public Const OperatorDecrement As Integer = 13083

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorDivision Field

JavaScriptTokenIdOperatorDivision Field
Gets the OperatorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDivision = 13080
Public Const OperatorDivision As Integer = 13080

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorDivisionAssignment Field

JavaScriptTokenIdOperatorDivisionAssignment Field
Gets the OperatorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDivisionAssignment = 13098
Public Const OperatorDivisionAssignment As Integer = 13098

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorEquality Field

JavaScriptTokenIdOperatorEquality Field
Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 13073
Public Const OperatorEquality As Integer = 13073

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorExclusiveOr Field

JavaScriptTokenIdOperatorExclusiveOr Field
Gets the OperatorExclusiveOr token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOr = 13089
Public Const OperatorExclusiveOr As Integer = 13089

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorExclusiveOrAssignment Field

JavaScriptTokenIdOperatorExclusiveOrAssignment Field
Gets the OperatorExclusiveOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOrAssignment = 13105
Public Const OperatorExclusiveOrAssignment As Integer = 13105

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorGreaterThan Field

JavaScriptTokenIdOperatorGreaterThan Field
Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 13070
Public Const OperatorGreaterThan As Integer = 13070

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorGreaterThanOrEqual Field

JavaScriptTokenIdOperatorGreaterThanOrEqual Field
Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 13072
Public Const OperatorGreaterThanOrEqual As Integer = 13072

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorIncrement Field

JavaScriptTokenIdOperatorIncrement Field
Gets the OperatorIncrement token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorIncrement = 13082
Public Const OperatorIncrement As Integer = 13082

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorInequality Field

JavaScriptTokenIdOperatorInequality Field
Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 13074
Public Const OperatorInequality As Integer = 13074

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLeftShift Field

JavaScriptTokenIdOperatorLeftShift Field
Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 13084
Public Const OperatorLeftShift As Integer = 13084

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLeftShiftAssignment Field

JavaScriptTokenIdOperatorLeftShiftAssignment Field
Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 13100
Public Const OperatorLeftShiftAssignment As Integer = 13100

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLessThan Field

JavaScriptTokenIdOperatorLessThan Field
Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 13069
Public Const OperatorLessThan As Integer = 13069

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorLessThanOrEqual Field

JavaScriptTokenIdOperatorLessThanOrEqual Field
Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 13071
Public Const OperatorLessThanOrEqual As Integer = 13071

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorModulus Field

JavaScriptTokenIdOperatorModulus Field
Gets the OperatorModulus token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorModulus = 13081
Public Const OperatorModulus As Integer = 13081

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorModulusAssignment Field

JavaScriptTokenIdOperatorModulusAssignment Field
Gets the OperatorModulusAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorModulusAssignment = 13099
Public Const OperatorModulusAssignment As Integer = 13099

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorMultiplication Field

JavaScriptTokenIdOperatorMultiplication Field
Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 13079
Public Const OperatorMultiplication As Integer = 13079

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorMultiplicationAssignment Field

JavaScriptTokenIdOperatorMultiplicationAssignment Field
Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 13097
Public Const OperatorMultiplicationAssignment As Integer = 13097

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorNegation Field

JavaScriptTokenIdOperatorNegation Field
Gets the OperatorNegation token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorNegation = 13090
Public Const OperatorNegation As Integer = 13090

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorOnesComplement Field

JavaScriptTokenIdOperatorOnesComplement Field
Gets the OperatorOnesComplement token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorOnesComplement = 13091
Public Const OperatorOnesComplement As Integer = 13091

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorRightShift Field

JavaScriptTokenIdOperatorRightShift Field
Gets the OperatorRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorRightShift = 13085
Public Const OperatorRightShift As Integer = 13085

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorRightShiftAssignment Field

JavaScriptTokenIdOperatorRightShiftAssignment Field
Gets the OperatorRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorRightShiftAssignment = 13101
Public Const OperatorRightShiftAssignment As Integer = 13101

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorStrictEquality Field

JavaScriptTokenIdOperatorStrictEquality Field
Gets the OperatorStrictEquality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorStrictEquality = 13075
Public Const OperatorStrictEquality As Integer = 13075

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorStrictInequality Field

JavaScriptTokenIdOperatorStrictInequality Field
Gets the OperatorStrictInequality token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorStrictInequality = 13076
Public Const OperatorStrictInequality As Integer = 13076

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorSubtraction Field

JavaScriptTokenIdOperatorSubtraction Field
Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 13078
Public Const OperatorSubtraction As Integer = 13078

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorSubtractionAssignment Field

JavaScriptTokenIdOperatorSubtractionAssignment Field
Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 13096
Public Const OperatorSubtractionAssignment As Integer = 13096

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorZeroFillRightShift Field

JavaScriptTokenIdOperatorZeroFillRightShift Field
Gets the OperatorZeroFillRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorZeroFillRightShift = 13086
Public Const OperatorZeroFillRightShift As Integer = 13086

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.OperatorZeroFillRightShiftAssignment Field

JavaScriptTokenIdOperatorZeroFillRightShiftAssignment Field
Gets the OperatorZeroFillRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorZeroFillRightShiftAssignment = 13102
Public Const OperatorZeroFillRightShiftAssignment As Integer = 13102

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.QuestionMark Field

JavaScriptTokenIdQuestionMark Field
Gets the QuestionMark token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int QuestionMark = 13013
Public Const QuestionMark As Integer = 13013

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordClass Field

JavaScriptTokenIdReservedKeywordClass Field
Gets the ReservedKeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordClass = 13053
Public Const ReservedKeywordClass As Integer = 13053

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordConst Field

JavaScriptTokenIdReservedKeywordConst Field
Gets the ReservedKeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordConst = 13054
Public Const ReservedKeywordConst As Integer = 13054

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordEnum Field

JavaScriptTokenIdReservedKeywordEnum Field
Gets the ReservedKeywordEnum token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordEnum = 13055
Public Const ReservedKeywordEnum As Integer = 13055

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordExport Field

JavaScriptTokenIdReservedKeywordExport Field
Gets the ReservedKeywordExport token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordExport = 13056
Public Const ReservedKeywordExport As Integer = 13056

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordExtends Field

JavaScriptTokenIdReservedKeywordExtends Field
Gets the ReservedKeywordExtends token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordExtends = 13057
Public Const ReservedKeywordExtends As Integer = 13057

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordImplements Field

JavaScriptTokenIdReservedKeywordImplements Field
Gets the ReservedKeywordImplements token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordImplements = 13058
Public Const ReservedKeywordImplements As Integer = 13058

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordImport Field

JavaScriptTokenIdReservedKeywordImport Field
Gets the ReservedKeywordImport token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordImport = 13059
Public Const ReservedKeywordImport As Integer = 13059

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordInterface Field

JavaScriptTokenIdReservedKeywordInterface Field
Gets the ReservedKeywordInterface token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordInterface = 13060
Public Const ReservedKeywordInterface As Integer = 13060

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordLet Field

JavaScriptTokenIdReservedKeywordLet Field
Gets the ReservedKeywordLet token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordLet = 13061
Public Const ReservedKeywordLet As Integer = 13061

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordPackage Field

JavaScriptTokenIdReservedKeywordPackage Field
Gets the ReservedKeywordPackage token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordPackage = 13062
Public Const ReservedKeywordPackage As Integer = 13062

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordPrivate Field

JavaScriptTokenIdReservedKeywordPrivate Field
Gets the ReservedKeywordPrivate token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordPrivate = 13063
Public Const ReservedKeywordPrivate As Integer = 13063

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordProtected Field

JavaScriptTokenIdReservedKeywordProtected Field
Gets the ReservedKeywordProtected token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordProtected = 13064
Public Const ReservedKeywordProtected As Integer = 13064

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordPublic Field

JavaScriptTokenIdReservedKeywordPublic Field
Gets the ReservedKeywordPublic token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordPublic = 13065
Public Const ReservedKeywordPublic As Integer = 13065

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordStatic Field

JavaScriptTokenIdReservedKeywordStatic Field
Gets the ReservedKeywordStatic token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordStatic = 13066
Public Const ReservedKeywordStatic As Integer = 13066

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordSuper Field

JavaScriptTokenIdReservedKeywordSuper Field
Gets the ReservedKeywordSuper token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordSuper = 13067
Public Const ReservedKeywordSuper As Integer = 13067

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.ReservedKeywordYield Field

JavaScriptTokenIdReservedKeywordYield Field
Gets the ReservedKeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReservedKeywordYield = 13068
Public Const ReservedKeywordYield As Integer = 13068

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.SemiColon Field

JavaScriptTokenIdSemiColon Field
Gets the SemiColon token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SemiColon = 13012
Public Const SemiColon As Integer = 13012

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenId.Whitespace Field

JavaScriptTokenIdWhitespace Field
Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Whitespace = 13000
Public Const Whitespace As Integer = 13000

Field Value

Type: Int32
See Also

Reference

JavaScriptTokenId Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Class

JavaScriptTokenReader Class
Represents an object that can provide tokens to a ILLParser in a forward-only direction for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenReader

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptTokenReader : MergableTokenReader
Public Class JavaScriptTokenReader
    Inherits MergableTokenReader

The JavaScriptTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenReader | Initializes a new instance of the JavaScriptTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Constructor

JavaScriptTokenReader Constructor
Initializes a new instance of the JavaScriptTokenReader class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Properties

JavaScriptTokenReader Properties

The JavaScriptTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader Methods

JavaScriptTokenReader Methods

The JavaScriptTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenReader.GetNextToken Method

JavaScriptTokenReaderGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

JavaScriptTokenReader Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Class

JavaScriptTokenTagger Class
Represents an ITaggerT for the JavaScript language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTagger

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptTokenTagger : TokenTagger
Public Class JavaScriptTokenTagger
    Inherits TokenTagger

The JavaScriptTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenTagger | Initializes a new instance of the JavaScriptTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Constructor

JavaScriptTokenTagger Constructor
Initializes a new instance of the JavaScriptTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptTokenTagger(
    ICodeDocument document,
    IJavaScriptClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IJavaScriptClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptClassificationTypeProvider
A IJavaScriptClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Properties

JavaScriptTokenTagger Properties

The JavaScriptTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Methods

JavaScriptTokenTagger Methods

The JavaScriptTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger.ClassifyToken Method

JavaScriptTokenTaggerClassifyToken Method
Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTagger Events

JavaScriptTokenTagger Events

The JavaScriptTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

JavaScriptTokenTagger Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Class

JavaScriptTokenTaggerProvider Class
Represents a provider of JavaScriptTokenTagger objects for documents that use the JavaScriptTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase JavaScriptTokenTagger
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JavaScriptTokenTaggerProvider : TaggerProviderBase<JavaScriptTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class JavaScriptTokenTaggerProvider
    Inherits TaggerProviderBase(Of JavaScriptTokenTagger)
    Implements ICodeDocumentTaggerProvider

The JavaScriptTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JavaScriptTokenTaggerProvider | Initializes a new instance of the JavaScriptTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Constructor

JavaScriptTokenTaggerProvider Constructor
Initializes a new instance of the JavaScriptTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptTokenTaggerProvider(
    IJavaScriptClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IJavaScriptClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.JavaScriptIJavaScriptClassificationTypeProvider
A IJavaScriptClassificationTypeProvider that provides classification types.
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Properties

JavaScriptTokenTaggerProvider Properties

The JavaScriptTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider Methods

JavaScriptTokenTaggerProvider Methods

The JavaScriptTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider.GetTagger(T) Method

JavaScriptTokenTaggerProviderGetTaggerT Method
Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

JavaScriptTokenTaggerProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider.TaggerFactory Class

JavaScriptTokenTaggerProviderTaggerFactory Class
Implements a factory that can creates JavaScriptTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The JavaScriptTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an JavaScriptTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


TaggerFactory Methods

TaggerFactory Methods

The JavaScriptTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an JavaScriptTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JavaScriptTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JavaScriptTokenTaggerProvider.TaggerFactory.CreateTagger Method

JavaScriptTokenTaggerProviderTaggerFactoryCreateTagger Method
Creates an JavaScriptTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JavaScriptTokenTagger CreateTagger()
Public Function CreateTagger As JavaScriptTokenTagger

Return Value

Type: JavaScriptTokenTagger
An JavaScriptTokenTagger for the ICodeDocument.
See Also

Reference

JavaScriptTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Class

JsonExampleTextProvider Class
Represents a example text provider for the JSON language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonExampleTextProvider : IExampleTextProvider
Public Class JsonExampleTextProvider
    Implements IExampleTextProvider

The JsonExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JsonExampleTextProvider | Initializes a new instance of the JsonExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.1.581.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Constructor

JsonExampleTextProvider Constructor
Initializes a new instance of the JsonExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonExampleTextProvider()
Public Sub New
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Properties

JsonExampleTextProvider Properties

The JsonExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider.ExampleText Property

JsonExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonExampleTextProvider Methods

JsonExampleTextProvider Methods

The JsonExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonExampleTextProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Class

JsonGrammar Class
Represents a Grammar for the JSON language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonGrammar

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonGrammar : Grammar
Public Class JsonGrammar
    Inherits Grammar

The JsonGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | JsonGrammar | Initializes a new instance of the JsonGrammar class using default options.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Constructor

JsonGrammar Constructor
Initializes a new instance of the JsonGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonGrammar()
Public Sub New
See Also

Reference

JsonGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Properties

JsonGrammar Properties

The JsonGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

JsonGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonGrammar Methods

JsonGrammar Methods

The JsonGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

JsonGrammar Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Class

JsonIndentProvider Class
Provides a JSON language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonIndentProvider

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonIndentProvider : DelimiterIndentProvider
Public Class JsonIndentProvider
    Inherits DelimiterIndentProvider

The JsonIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | JsonIndentProvider | Initializes a new instance of the JsonIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Constructor

JsonIndentProvider Constructor
Initializes a new instance of the JsonIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonIndentProvider()
Public Sub New
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Properties

JsonIndentProvider Properties

The JsonIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.Mode Property

JsonIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider Methods

JsonIndentProvider Methods

The JsonIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanged(SyntaxEditor, EditorSnapshotChangedEventArgs).)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Overrides DelimiterIndentProviderOnDocumentTextChanging(SyntaxEditor, EditorSnapshotChangingEventArgs).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.GetIndentAmount Method

JsonIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.OnDocumentTextChanged Method

JsonIndentProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overrides Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonIndentProvider.OnDocumentTextChanging Method

JsonIndentProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overrides Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

JsonIndentProvider Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Class

JsonLexer Class
Represents a JSON lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonLexer

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonLexer : MergableLexerBase
Public Class JsonLexer
    Inherits MergableLexerBase

The JsonLexer type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLexer | Initializes a new instance of the JsonLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Constructor

JsonLexer Constructor
Initializes a new instance of the JsonLexer class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonLexer()
Public Sub New
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Properties

JsonLexer Properties

The JsonLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer.LexicalStates Property

JsonLexerLexicalStates Property
Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Methods

JsonLexer Methods

The JsonLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer.GetAllLexicalStateTransitions Method

JsonLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer.GetNextToken Method

JsonLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonLexer Events

JsonLexer Events

The JsonLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

JsonLexer Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Class

JsonOutliner Class
Provides a JSON language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonOutliner

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonOutliner : IOutliner
Public Class JsonOutliner
    Implements IOutliner

The JsonOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | JsonOutliner | Initializes a new instance of the JsonOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Constructor

JsonOutliner Constructor
Initializes a new instance of the JsonOutliner class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonOutliner()
Public Sub New
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Properties

JsonOutliner Properties

The JsonOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner.UpdateTrigger Property

JsonOutlinerUpdateTrigger Property
Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner Methods

JsonOutliner Methods

The JsonOutliner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliner.GetOutliningSource Method

JsonOutlinerGetOutliningSource Method
Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

JsonOutliner Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource Class

JsonOutliningSource Class
Represents a JSON language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonOutliningSource

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonOutliningSource : RangeOutliningSourceBase
Public Class JsonOutliningSource
    Inherits RangeOutliningSourceBase

The JsonOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | JsonOutliningSource | Initializes a new instance of the JsonOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJsonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJsonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource Constructor

JsonOutliningSource Constructor
Initializes a new instance of the JsonOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource Methods

JsonOutliningSource Methods

The JsonOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IJsonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJsonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesFromParseData Method

JsonOutliningSourceAddNodesFromParseData Method
Overload List
 | Name | Description
Public method | AddNodesFromParseData(IJsonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IJsonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesFromParseData Method (IJsonParseData)

JsonOutliningSourceAddNodesFromParseData Method (IJsonParseData)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IJsonParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IJsonParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJsonParseData
The IJsonParseData containing AST data.
See Also

Reference

JsonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesFromParseData Method (IJsonParseData, ITextBufferReader)

JsonOutliningSourceAddNodesFromParseData Method (IJsonParseData, ITextBufferReader)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IJsonParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IJsonParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.JavaScriptIJsonParseData
The IJsonParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

JsonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonOutliningSource.AddNodesRecursive Method

JsonOutliningSourceAddNodesRecursive Method
Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

JsonOutliningSource Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Class

JsonParseData Class
Stores the results of a JSON language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParseData

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonParseData : LLParseData,
    IJsonParseData, ILLParseData, IParseData, IParseErrorProvider
Public Class JsonParseData
    Inherits LLParseData
    Implements IJsonParseData, ILLParseData, IParseData, IParseErrorProvider

The JsonParseData type exposes the following members.

Constructors
 | Name | Description
Public method | JsonParseData | Initializes a new instance of the JsonParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Constructor

JsonParseData Constructor
Initializes a new instance of the JsonParseData class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonParseData()
Public Sub New
See Also

Reference

JsonParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Properties

JsonParseData Properties

The JsonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

JsonParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParseData Methods

JsonParseData Methods

The JsonParseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonParseData Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Class

JsonParser Class
Represents a parser for the JSON language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParser

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonParser : LLParserBase
Public Class JsonParser
    Inherits LLParserBase

The JsonParser type exposes the following members.

Constructors
 | Name | Description
Public method | JsonParser | Initializes a new instance of the JsonParser class.
Public method | JsonParser(Grammar) | Initializes a new instance of the JsonParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Constructor

JsonParser Constructor
Overload List
 | Name | Description
Public method | JsonParser | Initializes a new instance of the JsonParser class.
Public method | JsonParser(Grammar) | Initializes a new instance of the JsonParser class.
Top
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Constructor

JsonParser Constructor
Initializes a new instance of the JsonParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonParser()
Public Sub New
See Also

Reference

JsonParser Class
JsonParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Constructor (Grammar)

JsonParser Constructor (Grammar)
Initializes a new instance of the JsonParser class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

JsonParser Class
JsonParser Overload
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Properties

JsonParser Properties

The JsonParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser Methods

JsonParser Methods

The JsonParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser.CreateParseData Method

JsonParserCreateParseData Method
Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser.CreateTokenReader Method

JsonParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonParser.InitializeParserState Method

JsonParserInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.Text.Addons.JavaScript.Universal (in AS.Text.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

JsonParser Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Class

JsonSyntaxLanguage Class
Represents a JSON syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonSyntaxLanguage : SyntaxLanguage,
    ITextViewLifecycleEventSink
Public Class JsonSyntaxLanguage
    Inherits SyntaxLanguage
    Implements ITextViewLifecycleEventSink

The JsonSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | JsonSyntaxLanguage | Initializes a new instance of the JsonSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Constructor

JsonSyntaxLanguage Constructor
Initializes a new instance of the JsonSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonSyntaxLanguage()
Public Sub New
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Properties

JsonSyntaxLanguage Properties

The JsonSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Methods

JsonSyntaxLanguage Methods

The JsonSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonSyntaxLanguage Events

JsonSyntaxLanguage Events

The JsonSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

JsonSyntaxLanguage Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Class

JsonTextFormatter Class
Provides a JSON language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonTextFormatter

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class JsonTextFormatter : ITextFormatter
Public Class JsonTextFormatter
    Implements ITextFormatter

The JsonTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | JsonTextFormatter | Initializes a new instance of the JsonTextFormatter class
Top
Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Constructor

JsonTextFormatter Constructor
Initializes a new instance of the JsonTextFormatter class

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public JsonTextFormatter()
Public Sub New
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Properties

JsonTextFormatter Properties

The JsonTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | IsOpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter.IsOpeningBraceOnNewLine Property

JsonTextFormatterIsOpeningBraceOnNewLine Property
Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOpeningBraceOnNewLine { get; set; }
Public Property IsOpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter Methods

JsonTextFormatter Methods

The JsonTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


JsonTextFormatter.Format Method

JsonTextFormatterFormat Method
Formats the specified snapshot range.

Namespace: ActiproSoftware.Text.Languages.JavaScript.Implementation
Assembly: AS.SyntaxEditor.Addons.JavaScript.Universal (in AS.SyntaxEditor.Addons.JavaScript.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Format(
    TextSnapshotRange snapshotRange
)
Public Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The snapshot range.

Implements

ITextFormatterFormat(TextSnapshotRange)
See Also

Reference

JsonTextFormatter Class
ActiproSoftware.Text.Languages.JavaScript.Implementation Namespace


ActiproSoftware.Text.Languages.Python Namespace

ActiproSoftware.Text.Languages.Python Namespace
Contains the classes related to implementing a Python syntax language.
Classes
 | Class | Description
Public class | PythonContextKind | Specifies the kind of context.
Public class | PythonContextLocations | Contains common context locations for a Python language.
Public class | PythonDocstringDisplayMode | Indicates the display mode for Python docstring comments.
Public class | PythonGrammarRootNonTerminal | Specifies the root non-terminal to use for a Python grammar.
Public class | PythonSyntaxLanguageExtensions | Contains extension methods that make it easier to work with Python ISyntaxLanguage objects.
Public class | PythonVersion | Specifies the version of Python.
Interfaces
 | Interface | Description
Public interface | IPythonClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for the Python language.
Public interface | IPythonContext | Provides the base requirements for information about a Python language context of a certain offset within an ITextSnapshot.
Public interface | IPythonContextLocation | Provides the base requirements for an IPythonContext location, that determines what sort of resolver results are permitted.
Public interface | IPythonGrammarOptions | Contains options for a Python grammar.
Public interface | IPythonParseData | Provides the base requirements of an object that stores the results of a Python language parsing operation.


IPythonClassificationTypeProvider Interface

IPythonClassificationTypeProvider Interface
Provides the base requirements of an object that provides IClassificationType objects for the Python language.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPythonClassificationTypeProvider
Public Interface IPythonClassificationTypeProvider

The IPythonClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | String | Gets the String classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider Properties

IPythonClassificationTypeProvider Properties

The IPythonClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | String | Gets the String classification type.
Top
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Comment Property

IPythonClassificationTypeProviderComment Property
Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Comment { get; }
ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Identifier Property

IPythonClassificationTypeProviderIdentifier Property
Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Identifier { get; }
ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Keyword Property

IPythonClassificationTypeProviderKeyword Property
Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Keyword { get; }
ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Number Property

IPythonClassificationTypeProviderNumber Property
Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Number { get; }
ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.Operator Property

IPythonClassificationTypeProviderOperator Property
Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType Operator { get; }
ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.PythonSystemIdentifier Property

IPythonClassificationTypeProviderPythonSystemIdentifier Property
Gets the PythonSystemIdentifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType PythonSystemIdentifier { get; }
ReadOnly Property PythonSystemIdentifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The PythonSystemIdentifier classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonClassificationTypeProvider.String Property

IPythonClassificationTypeProviderString Property
Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType String { get; }
ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.
See Also

Reference

IPythonClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext Interface

IPythonContext Interface
Provides the base requirements for information about a Python language context of a certain offset within an ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPythonContext
Public Interface IPythonContext

The IPythonContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the PythonContextKind indicating the kind of context.
Public property | Location | Gets an optional IPythonContextLocation that provides more location information about the context.
Public property | Project | Gets the IProject with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Public property | Version | Gets the PythonVersion that indicates the Python version for which this context was created.
Top
Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the Project to return an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonContext Properties

IPythonContext Properties

The IPythonContext type exposes the following members.

Properties
 | Name | Description
Public property | ArgumentIndex | Gets the index of the current argument, if known, when the context is for the containing invocation.
Public property | ArgumentListSnapshotOffset | Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
Public property | ArgumentSnapshotOffset | Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
Public property | ContainingAstNode | Gets the IAstNode that contains the SnapshotOffset.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | Kind | Gets the PythonContextKind indicating the kind of context.
Public property | Location | Gets an optional IPythonContextLocation that provides more location information about the context.
Public property | Project | Gets the IProject with which this context is associated.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetExpression | Gets the target AST Expression for the context, if known.
Public property | TargetSnapshotOffset | Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.
Public property | Version | Gets the PythonVersion that indicates the Python version for which this context was created.
Top
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ArgumentIndex Property

IPythonContextArgumentIndex Property
Gets the index of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> ArgumentIndex { get; }
ReadOnly Property ArgumentIndex As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The index of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ArgumentListSnapshotOffset Property

IPythonContextArgumentListSnapshotOffset Property
Gets the TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentListSnapshotOffset { get; }
ReadOnly Property ArgumentListSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the argument list, if known, when the context is for the containing invocation.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ArgumentSnapshotOffset Property

IPythonContextArgumentSnapshotOffset Property
Gets the TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> ArgumentSnapshotOffset { get; }
ReadOnly Property ArgumentSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset of the current argument, if known, when the context is for the containing invocation.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.ContainingAstNode Property

IPythonContextContainingAstNode Property
Gets the IAstNode that contains the SnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode ContainingAstNode { get; }
ReadOnly Property ContainingAstNode As IAstNode
    Get

Property Value

Type: IAstNode
The IAstNode that contains the SnapshotOffset.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.InitializationSnapshotRange Property

IPythonContextInitializationSnapshotRange Property
Gets the TextSnapshotRange with which the context was initialized.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> InitializationSnapshotRange { get; }
ReadOnly Property InitializationSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The TextSnapshotRange with which the context was initialized.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Kind Property

IPythonContextKind Property
Gets the PythonContextKind indicating the kind of context.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PythonContextKind Kind { get; }
ReadOnly Property Kind As PythonContextKind
    Get

Property Value

Type: PythonContextKind
The PythonContextKind indicating the kind of context.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Location Property

IPythonContextLocation Property
Gets an optional IPythonContextLocation that provides more location information about the context.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPythonContextLocation Location { get; }
ReadOnly Property Location As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
An optional IPythonContextLocation that provides more location information about the context.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Project Property

IPythonContextProject Property
Gets the IProject with which this context is associated.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProject Project { get; }
ReadOnly Property Project As IProject
    Get

Property Value

Type: IProject
The IProject with which this context is associated.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.SnapshotOffset Property

IPythonContextSnapshotOffset Property
Gets the TextSnapshotOffset for which this context was created.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotOffset SnapshotOffset { get; }
ReadOnly Property SnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset for which this context was created.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.TargetExpression Property

IPythonContextTargetExpression Property
Gets the target AST Expression for the context, if known.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Expression TargetExpression { get; }
ReadOnly Property TargetExpression As Expression
    Get

Property Value

Type: Expression
The target AST Expression for the context, if known.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.TargetSnapshotOffset Property

IPythonContextTargetSnapshotOffset Property
Gets the TextSnapshotOffset, if known, against which to use as context for the resolver.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotOffset> TargetSnapshotOffset { get; }
ReadOnly Property TargetSnapshotOffset As Nullable(Of TextSnapshotOffset)
    Get

Property Value

Type: Nullable TextSnapshotOffset
The TextSnapshotOffset, if known, against which to use as context for the resolver.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Version Property

IPythonContextVersion Property
Gets the PythonVersion that indicates the Python version for which this context was created.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version for which this context was created.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext Methods

IPythonContext Methods

The IPythonContext type exposes the following members.

Methods
 | Name | Description
Public method | Resolve | Uses the IResolver on the Project to return an IResolverResultSet.
Top
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContext.Resolve Method

IPythonContextResolve Method
Uses the IResolver on the Project to return an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve()
Function Resolve As IResolverResultSet

Return Value

Type: IResolverResultSet
The IResolverResultSet that was returned by the resolver.
See Also

Reference

IPythonContext Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContextLocation Interface

IPythonContextLocation Interface
Provides the base requirements for an IPythonContext location, that determines what sort of resolver results are permitted.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPythonContextLocation
Public Interface IPythonContextLocation

The IPythonContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonContextLocation Methods

IPythonContextLocation Methods

The IPythonContextLocation type exposes the following members.

Methods
 | Name | Description
Public method | IsAllowed | Returns whether the specified IResolverResult is allowed within the context location.
Top
See Also

Reference

IPythonContextLocation Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonContextLocation.IsAllowed Method

IPythonContextLocationIsAllowed Method
Returns whether the specified IResolverResult is allowed within the context location.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAllowed(
    IResolverResult result
)
Function IsAllowed (
    result As IResolverResult
) As Boolean

Parameters

result
Type: ActiproSoftware.Text.Languages.Python.ResolutionIResolverResult
The IResolverResult to examine.

Return Value

Type: Boolean
true if the specified IResolverResult is allowed within the context location; otherwise, false.
See Also

Reference

IPythonContextLocation Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions Interface

IPythonGrammarOptions Interface
Contains options for a Python grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPythonGrammarOptions
Public Interface IPythonGrammarOptions

The IPythonGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions Properties

IPythonGrammarOptions Properties

The IPythonGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

IPythonGrammarOptions Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions.RootNonTerminal Property

IPythonGrammarOptionsRootNonTerminal Property
Gets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PythonGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As PythonGrammarRootNonTerminal
    Get

Property Value

Type: PythonGrammarRootNonTerminal
A PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

IPythonGrammarOptions Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonGrammarOptions.Version Property

IPythonGrammarOptionsVersion Property
Gets the PythonVersion that indicates the Python version supported by this grammar.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this grammar.
See Also

Reference

IPythonGrammarOptions Interface
ActiproSoftware.Text.Languages.Python Namespace


IPythonParseData Interface

IPythonParseData Interface
Provides the base requirements of an object that stores the results of a Python language parsing operation.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPythonParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IPythonParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IPythonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace
ActiproSoftware.Text.Languages.Python.ImplementationPythonParseData


IPythonParseData Properties

IPythonParseData Properties

The IPythonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IPythonParseData Interface
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind Class

PythonContextKind Class
Specifies the kind of context.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.PythonPythonContextKind

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PythonContextKind : Enum
Public NotInheritable Class PythonContextKind
    Inherits Enum

The PythonContextKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ContainingInvocation | The context and its resolve operations work on the invocation that contains the offset, if any.
 | Self | The context and its resolve operations work on the existing attribute referenced at the offset.
 | SelfAndSiblings | The context and its resolve operations work on the existing attribute and its siblings referenced at the offset.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind Methods

PythonContextKind Methods

The PythonContextKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PythonContextKind Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind Fields

PythonContextKind Fields

The PythonContextKind type exposes the following members.

Fields
 | Name | Description
 | ContainingInvocation | The context and its resolve operations work on the invocation that contains the offset, if any.
 | Self | The context and its resolve operations work on the existing attribute referenced at the offset.
 | SelfAndSiblings | The context and its resolve operations work on the existing attribute and its siblings referenced at the offset.
Public field | value__ |
Top
See Also

Reference

PythonContextKind Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind.ContainingInvocation Field

PythonContextKindContainingInvocation Field
The context and its resolve operations work on the invocation that contains the offset, if any.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonContextKind ContainingInvocation = 2
Public Const ContainingInvocation As PythonContextKind = 2

Field Value

Type: PythonContextKind
See Also

Reference

PythonContextKind Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind.Self Field

PythonContextKindSelf Field
The context and its resolve operations work on the existing attribute referenced at the offset.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonContextKind Self = 0
Public Const Self As PythonContextKind = 0

Field Value

Type: PythonContextKind
See Also

Reference

PythonContextKind Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind.SelfAndSiblings Field

PythonContextKindSelfAndSiblings Field
The context and its resolve operations work on the existing attribute and its siblings referenced at the offset.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonContextKind SelfAndSiblings = 1
Public Const SelfAndSiblings As PythonContextKind = 1

Field Value

Type: PythonContextKind
See Also

Reference

PythonContextKind Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextKind.value__ Field

PythonContextKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.PythonContextKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PythonContextKind Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations Class

PythonContextLocations Class
Contains common context locations for a Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.PythonPythonContextLocations

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class PythonContextLocations
Public NotInheritable Class PythonContextLocations

The PythonContextLocations type exposes the following members.

Properties
Name | Description
BoundName | Gets the IPythonContextLocation that represents a bound name specification.
Comment | Gets the IPythonContextLocation that represents a comment specification.
FromImportIdentifier | Gets the IPythonContextLocation that represents an imported identifier of a from...import statement.
FromImportName | Gets the IPythonContextLocation that represents the name of a from...import statement.
ImportName | Gets the IPythonContextLocation that represents the name of an import statement.
LiteralString | Gets the IPythonContextLocation that represents a literal string specification.
Unknown | Gets the IPythonContextLocation that represents an unknown specification.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations Properties

PythonContextLocations Properties

The PythonContextLocations type exposes the following members.

Properties
Name | Description
BoundName | Gets the IPythonContextLocation that represents a bound name specification.
Comment | Gets the IPythonContextLocation that represents a comment specification.
FromImportIdentifier | Gets the IPythonContextLocation that represents an imported identifier of a from...import statement.
FromImportName | Gets the IPythonContextLocation that represents the name of a from...import statement.
ImportName | Gets the IPythonContextLocation that represents the name of an import statement.
LiteralString | Gets the IPythonContextLocation that represents a literal string specification.
Unknown | Gets the IPythonContextLocation that represents an unknown specification.
Top
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.BoundName Property

PythonContextLocationsBoundName Property
Gets the IPythonContextLocation that represents a bound name specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation BoundName { get; }
Public Shared ReadOnly Property BoundName As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.Comment Property

PythonContextLocationsComment Property
Gets the IPythonContextLocation that represents a comment specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation Comment { get; }
Public Shared ReadOnly Property Comment As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.FromImportIdentifier Property

PythonContextLocationsFromImportIdentifier Property
Gets the IPythonContextLocation that represents an imported identifier of a from...import statement.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation FromImportIdentifier { get; }
Public Shared ReadOnly Property FromImportIdentifier As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.FromImportName Property

PythonContextLocationsFromImportName Property
Gets the IPythonContextLocation that represents the name of a from...import statement.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation FromImportName { get; }
Public Shared ReadOnly Property FromImportName As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.ImportName Property

PythonContextLocationsImportName Property
Gets the IPythonContextLocation that represents the name of an import statement.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation ImportName { get; }
Public Shared ReadOnly Property ImportName As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.LiteralString Property

PythonContextLocationsLiteralString Property
Gets the IPythonContextLocation that represents a literal string specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation LiteralString { get; }
Public Shared ReadOnly Property LiteralString As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonContextLocations.Unknown Property

PythonContextLocationsUnknown Property
Gets the IPythonContextLocation that represents an unknown specification.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonContextLocation Unknown { get; }
Public Shared ReadOnly Property Unknown As IPythonContextLocation
    Get

Property Value

Type: IPythonContextLocation
The IPythonContextLocation value.
See Also

Reference

PythonContextLocations Class
ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode Class

PythonDocstringDisplayMode Class
Indicates the display mode for Python docstring comments.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.PythonPythonDocstringDisplayMode

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PythonDocstringDisplayMode : Enum
Public NotInheritable Class PythonDocstringDisplayMode
    Inherits Enum

The PythonDocstringDisplayMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | The entire docstring is displayed.
 | Summary | Only the summary (text before the first empty line) is displayed.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode Methods

PythonDocstringDisplayMode Methods

The PythonDocstringDisplayMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PythonDocstringDisplayMode Class
ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode Fields

PythonDocstringDisplayMode Fields

The PythonDocstringDisplayMode type exposes the following members.

Fields
 | Name | Description
 | All | The entire docstring is displayed.
 | Summary | Only the summary (text before the first empty line) is displayed.
Public field | value__ |
Top
See Also

Reference

PythonDocstringDisplayMode Class
ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode.All Field

PythonDocstringDisplayModeAll Field
The entire docstring is displayed.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonDocstringDisplayMode All = 1
Public Const All As PythonDocstringDisplayMode = 1

Field Value

Type: PythonDocstringDisplayMode
See Also

Reference

PythonDocstringDisplayMode Class
ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode.Summary Field

PythonDocstringDisplayModeSummary Field
Only the summary (text before the first empty line) is displayed.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonDocstringDisplayMode Summary = 0
Public Const Summary As PythonDocstringDisplayMode = 0

Field Value

Type: PythonDocstringDisplayMode
See Also

Reference

PythonDocstringDisplayMode Class
ActiproSoftware.Text.Languages.Python Namespace


PythonDocstringDisplayMode.value__ Field

PythonDocstringDisplayModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.PythonDocstringDisplayMode.value__"]

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PythonDocstringDisplayMode Class
ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal Class

PythonGrammarRootNonTerminal Class
Specifies the root non-terminal to use for a Python grammar.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.PythonPythonGrammarRootNonTerminal

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PythonGrammarRootNonTerminal : Enum
Public NotInheritable Class PythonGrammarRootNonTerminal
    Inherits Enum

The PythonGrammarRootNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CompilationUnit | Compilation unit (the default).
 | Expression | Expression.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal Methods

PythonGrammarRootNonTerminal Methods

The PythonGrammarRootNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PythonGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal Fields

PythonGrammarRootNonTerminal Fields

The PythonGrammarRootNonTerminal type exposes the following members.

Fields
 | Name | Description
 | CompilationUnit | Compilation unit (the default).
 | Expression | Expression.
Public field | value__ |
Top
See Also

Reference

PythonGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal.CompilationUnit Field

PythonGrammarRootNonTerminalCompilationUnit Field
Compilation unit (the default).

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonGrammarRootNonTerminal CompilationUnit = 0
Public Const CompilationUnit As PythonGrammarRootNonTerminal = 0

Field Value

Type: PythonGrammarRootNonTerminal
See Also

Reference

PythonGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal.Expression Field

PythonGrammarRootNonTerminalExpression Field
Expression.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonGrammarRootNonTerminal Expression = 1
Public Const Expression As PythonGrammarRootNonTerminal = 1

Field Value

Type: PythonGrammarRootNonTerminal
See Also

Reference

PythonGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.Python Namespace


PythonGrammarRootNonTerminal.value__ Field

PythonGrammarRootNonTerminalvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.PythonGrammarRootNonTerminal.value__"]

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PythonGrammarRootNonTerminal Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions Class

PythonSyntaxLanguageExtensions Class
Contains extension methods that make it easier to work with Python ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.PythonPythonSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class PythonSyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class PythonSyntaxLanguageExtensions

The PythonSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetProject | Returns the IProject that can validate XML.
RegisterProject | Registers the IProject that can validate XML.
UnregisterProject | Unregisters the IProject that can validate XML.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions Methods

PythonSyntaxLanguageExtensions Methods

The PythonSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetProject | Returns the IProject that can validate XML.
RegisterProject | Registers the IProject that can validate XML.
UnregisterProject | Unregisters the IProject that can validate XML.
Top
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions.GetProject Method

PythonSyntaxLanguageExtensionsGetProject Method
Returns the IProject that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IProject GetProject(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetProject (
    language As ISyntaxLanguage
) As IProject

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IProject
The IProject instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions.RegisterProject Method

PythonSyntaxLanguageExtensionsRegisterProject Method
Registers the IProject that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterProject(
    this ISyntaxLanguage language,
    IProject value
)
<ExtensionAttribute>
Public Shared Sub RegisterProject (
    language As ISyntaxLanguage,
    value As IProject
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.Python.ReflectionIProject
The IProject instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonSyntaxLanguageExtensions.UnregisterProject Method

PythonSyntaxLanguageExtensionsUnregisterProject Method
Unregisters the IProject that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterProject(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterProject (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PythonSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Python Namespace


PythonVersion Class

PythonVersion Class
Specifies the version of Python.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.PythonPythonVersion

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PythonVersion : Enum
Public NotInheritable Class PythonVersion
    Inherits Enum

The PythonVersion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
Public field | value__ |
 | Version2 | Python version 2 compatibility.
 | Version3 | Python version 3 compatibility.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python Namespace


PythonVersion Methods

PythonVersion Methods

The PythonVersion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PythonVersion Class
ActiproSoftware.Text.Languages.Python Namespace


PythonVersion Fields

PythonVersion Fields

The PythonVersion type exposes the following members.

Fields
 | Name | Description
Public field | value__ |
 | Version2 | Python version 2 compatibility.
 | Version3 | Python version 3 compatibility.
Top
See Also

Reference

PythonVersion Class
ActiproSoftware.Text.Languages.Python Namespace


PythonVersion.value__ Field

PythonVersionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.PythonVersion.value__"]

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PythonVersion Class
ActiproSoftware.Text.Languages.Python Namespace


PythonVersion.Version2 Field

PythonVersionVersion2 Field
Python version 2 compatibility.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonVersion Version2 = 0
Public Const Version2 As PythonVersion = 0

Field Value

Type: PythonVersion
See Also

Reference

PythonVersion Class
ActiproSoftware.Text.Languages.Python Namespace


PythonVersion.Version3 Field

PythonVersionVersion3 Field
Python version 3 compatibility.

Namespace: ActiproSoftware.Text.Languages.Python
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PythonVersion Version3 = 1
Public Const Version3 As PythonVersion = 1

Field Value

Type: PythonVersion
See Also

Reference

PythonVersion Class
ActiproSoftware.Text.Languages.Python Namespace


ActiproSoftware.Text.Languages.Python.Ast Namespace

ActiproSoftware.Text.Languages.Python.Ast Namespace
Contains the types related to ASTs for a Python syntax language.
Classes
 | Class | Description
Public class | ArgumentKind | Specifies the type of argument.
Public class | LiteralExpressionKind | Specifies the type of literal expression.
Public class | OperatorKind | Specifies the kind of an operator.
Public class | ParameterKind | Specifies the type of parameter.


ArgumentKind Class

ArgumentKind Class
Specifies the type of argument.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.Python.AstArgumentKind

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ArgumentKind : Enum
Public NotInheritable Class ArgumentKind
    Inherits Enum

The ArgumentKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Dictionary | Dictionary.
 | Normal | Normal.
 | Tuple | Tuple.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


ArgumentKind Methods

ArgumentKind Methods

The ArgumentKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ArgumentKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ArgumentKind Fields

ArgumentKind Fields

The ArgumentKind type exposes the following members.

Fields
 | Name | Description
 | Dictionary | Dictionary.
 | Normal | Normal.
 | Tuple | Tuple.
Public field | value__ |
Top
See Also

Reference

ArgumentKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ArgumentKind.Dictionary Field

ArgumentKindDictionary Field
Dictionary.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ArgumentKind Dictionary = 2
Public Const Dictionary As ArgumentKind = 2

Field Value

Type: ArgumentKind
See Also

Reference

ArgumentKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ArgumentKind.Normal Field

ArgumentKindNormal Field
Normal.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ArgumentKind Normal = 0
Public Const Normal As ArgumentKind = 0

Field Value

Type: ArgumentKind
See Also

Reference

ArgumentKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ArgumentKind.Tuple Field

ArgumentKindTuple Field
Tuple.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ArgumentKind Tuple = 1
Public Const Tuple As ArgumentKind = 1

Field Value

Type: ArgumentKind
See Also

Reference

ArgumentKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ArgumentKind.value__ Field

ArgumentKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.Ast.ArgumentKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ArgumentKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind Class

LiteralExpressionKind Class
Specifies the type of literal expression.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.Python.AstLiteralExpressionKind

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LiteralExpressionKind : Enum
Public NotInheritable Class LiteralExpressionKind
    Inherits Enum

The LiteralExpressionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BinaryInteger | A binary integer.
 | Bytes | Bytes.
 | ConcatenatedString | A concatenated string.
 | DecimalInteger | A decimal integer.
 | DoubleQuoteLongString | A string of characters.
 | DoubleQuoteString | A string of characters.
 | HexadecimalInteger | A hexadecimal integer.
 | Imaginary | An imaginary number.
 | None | No kind indicated.
 | OctalInteger | An octal integer.
 | Real | A real number.
 | SingleQuoteLongString | A string of characters.
 | SingleQuoteString | A string of characters.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind Methods

LiteralExpressionKind Methods

The LiteralExpressionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind Fields

LiteralExpressionKind Fields

The LiteralExpressionKind type exposes the following members.

Fields
 | Name | Description
 | BinaryInteger | A binary integer.
 | Bytes | Bytes.
 | ConcatenatedString | A concatenated string.
 | DecimalInteger | A decimal integer.
 | DoubleQuoteLongString | A string of characters.
 | DoubleQuoteString | A string of characters.
 | HexadecimalInteger | A hexadecimal integer.
 | Imaginary | An imaginary number.
 | None | No kind indicated.
 | OctalInteger | An octal integer.
 | Real | A real number.
 | SingleQuoteLongString | A string of characters.
 | SingleQuoteString | A string of characters.
Public field | value__ |
Top
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.BinaryInteger Field

LiteralExpressionKindBinaryInteger Field
A binary integer.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind BinaryInteger = 1
Public Const BinaryInteger As LiteralExpressionKind = 1

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.Bytes Field

LiteralExpressionKindBytes Field
Bytes.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Bytes = 2
Public Const Bytes As LiteralExpressionKind = 2

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.ConcatenatedString Field

LiteralExpressionKindConcatenatedString Field
A concatenated string.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind ConcatenatedString = 3
Public Const ConcatenatedString As LiteralExpressionKind = 3

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.DecimalInteger Field

LiteralExpressionKindDecimalInteger Field
A decimal integer.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DecimalInteger = 4
Public Const DecimalInteger As LiteralExpressionKind = 4

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.DoubleQuoteLongString Field

LiteralExpressionKindDoubleQuoteLongString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DoubleQuoteLongString = 5
Public Const DoubleQuoteLongString As LiteralExpressionKind = 5

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.DoubleQuoteString Field

LiteralExpressionKindDoubleQuoteString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind DoubleQuoteString = 6
Public Const DoubleQuoteString As LiteralExpressionKind = 6

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.HexadecimalInteger Field

LiteralExpressionKindHexadecimalInteger Field
A hexadecimal integer.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind HexadecimalInteger = 7
Public Const HexadecimalInteger As LiteralExpressionKind = 7

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.Imaginary Field

LiteralExpressionKindImaginary Field
An imaginary number.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Imaginary = 8
Public Const Imaginary As LiteralExpressionKind = 8

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.None Field

LiteralExpressionKindNone Field
No kind indicated.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind None = 0
Public Const None As LiteralExpressionKind = 0

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.OctalInteger Field

LiteralExpressionKindOctalInteger Field
An octal integer.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind OctalInteger = 9
Public Const OctalInteger As LiteralExpressionKind = 9

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.Real Field

LiteralExpressionKindReal Field
A real number.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind Real = 10
Public Const Real As LiteralExpressionKind = 10

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.SingleQuoteLongString Field

LiteralExpressionKindSingleQuoteLongString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind SingleQuoteLongString = 11
Public Const SingleQuoteLongString As LiteralExpressionKind = 11

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.SingleQuoteString Field

LiteralExpressionKindSingleQuoteString Field
A string of characters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LiteralExpressionKind SingleQuoteString = 12
Public Const SingleQuoteString As LiteralExpressionKind = 12

Field Value

Type: LiteralExpressionKind
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


LiteralExpressionKind.value__ Field

LiteralExpressionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.Ast.LiteralExpressionKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LiteralExpressionKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind Class

OperatorKind Class
Specifies the kind of an operator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.Python.AstOperatorKind

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class OperatorKind : Enum
Public NotInheritable Class OperatorKind
    Inherits Enum

The OperatorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Addition | An addition operator.
 | BitwiseAnd | A bitwise AND operator.
 | BitwiseOr | A bitwise OR operator.
 | ConditionalAnd | A conditional AND binary operator.
 | ConditionalOr | A conditional OR binary operator.
 | Division | A division operator.
 | ExclusiveOr | A bitwise XOR operator.
 | FloorDivision | A floor division operator.
 | GreaterThan | A greater than operator.
 | GreaterThanOrEqual | A greater than or equal operator.
 | In | Contains operator.
 | LeftShift | A left shift operator.
 | LessThan | A less than operator.
 | LessThanOrEqual | A less than or equal operator.
 | MatrixMultiplication | Matrix multiplication operator.
 | Modulus | A modulus operator.
 | Multiplication | A multiplication operator.
 | Negation | A negation operator.
 | None | No valid operator kind.
 | NotIn | Opposite of contains operation.
 | OnesComplement | A bitwise complement operator.
 | Power | A multiplication operator.
 | ReferenceEquality | A reference equality operator.
 | ReferenceInequality | A reference inequality operator.
 | RightShift | A right shift operator.
 | Subtraction | A subtraction operator.
Public field | value__ |
 | ValueEquality | A value equality operator.
 | ValueInequality | A value inequality operator.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind Methods

OperatorKind Methods

The OperatorKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind Fields

OperatorKind Fields

The OperatorKind type exposes the following members.

Fields
 | Name | Description
 | Addition | An addition operator.
 | BitwiseAnd | A bitwise AND operator.
 | BitwiseOr | A bitwise OR operator.
 | ConditionalAnd | A conditional AND binary operator.
 | ConditionalOr | A conditional OR binary operator.
 | Division | A division operator.
 | ExclusiveOr | A bitwise XOR operator.
 | FloorDivision | A floor division operator.
 | GreaterThan | A greater than operator.
 | GreaterThanOrEqual | A greater than or equal operator.
 | In | Contains operator.
 | LeftShift | A left shift operator.
 | LessThan | A less than operator.
 | LessThanOrEqual | A less than or equal operator.
 | MatrixMultiplication | Matrix multiplication operator.
 | Modulus | A modulus operator.
 | Multiplication | A multiplication operator.
 | Negation | A negation operator.
 | None | No valid operator kind.
 | NotIn | Opposite of contains operation.
 | OnesComplement | A bitwise complement operator.
 | Power | A multiplication operator.
 | ReferenceEquality | A reference equality operator.
 | ReferenceInequality | A reference inequality operator.
 | RightShift | A right shift operator.
 | Subtraction | A subtraction operator.
Public field | value__ |
 | ValueEquality | A value equality operator.
 | ValueInequality | A value inequality operator.
Top
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Addition Field

OperatorKindAddition Field
An addition operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Addition = 1
Public Const Addition As OperatorKind = 1

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.BitwiseAnd Field

OperatorKindBitwiseAnd Field
A bitwise AND operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind BitwiseAnd = 8
Public Const BitwiseAnd As OperatorKind = 8

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.BitwiseOr Field

OperatorKindBitwiseOr Field
A bitwise OR operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind BitwiseOr = 9
Public Const BitwiseOr As OperatorKind = 9

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ConditionalAnd Field

OperatorKindConditionalAnd Field
A conditional AND binary operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ConditionalAnd = 24
Public Const ConditionalAnd As OperatorKind = 24

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ConditionalOr Field

OperatorKindConditionalOr Field
A conditional OR binary operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ConditionalOr = 23
Public Const ConditionalOr As OperatorKind = 23

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Division Field

OperatorKindDivision Field
A division operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Division = 5
Public Const Division As OperatorKind = 5

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ExclusiveOr Field

OperatorKindExclusiveOr Field
A bitwise XOR operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ExclusiveOr = 10
Public Const ExclusiveOr As OperatorKind = 10

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.FloorDivision Field

OperatorKindFloorDivision Field
A floor division operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind FloorDivision = 6
Public Const FloorDivision As OperatorKind = 6

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.GreaterThan Field

OperatorKindGreaterThan Field
A greater than operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind GreaterThan = 14
Public Const GreaterThan As OperatorKind = 14

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.GreaterThanOrEqual Field

OperatorKindGreaterThanOrEqual Field
A greater than or equal operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind GreaterThanOrEqual = 22
Public Const GreaterThanOrEqual As OperatorKind = 22

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.In Field

OperatorKindIn Field
Contains operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind In = 25
Public Const In As OperatorKind = 25

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.LeftShift Field

OperatorKindLeftShift Field
A left shift operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LeftShift = 15
Public Const LeftShift As OperatorKind = 15

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.LessThan Field

OperatorKindLessThan Field
A less than operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LessThan = 13
Public Const LessThan As OperatorKind = 13

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.LessThanOrEqual Field

OperatorKindLessThanOrEqual Field
A less than or equal operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind LessThanOrEqual = 21
Public Const LessThanOrEqual As OperatorKind = 21

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.MatrixMultiplication Field

OperatorKindMatrixMultiplication Field
Matrix multiplication operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind MatrixMultiplication = 27
Public Const MatrixMultiplication As OperatorKind = 27

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Modulus Field

OperatorKindModulus Field
A modulus operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Modulus = 7
Public Const Modulus As OperatorKind = 7

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Multiplication Field

OperatorKindMultiplication Field
A multiplication operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Multiplication = 3
Public Const Multiplication As OperatorKind = 3

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Negation Field

OperatorKindNegation Field
A negation operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Negation = 11
Public Const Negation As OperatorKind = 11

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.None Field

OperatorKindNone Field
No valid operator kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind None = 0
Public Const None As OperatorKind = 0

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.NotIn Field

OperatorKindNotIn Field
Opposite of contains operation.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind NotIn = 26
Public Const NotIn As OperatorKind = 26

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.OnesComplement Field

OperatorKindOnesComplement Field
A bitwise complement operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind OnesComplement = 12
Public Const OnesComplement As OperatorKind = 12

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Power Field

OperatorKindPower Field
A multiplication operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Power = 4
Public Const Power As OperatorKind = 4

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ReferenceEquality Field

OperatorKindReferenceEquality Field
A reference equality operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ReferenceEquality = 19
Public Const ReferenceEquality As OperatorKind = 19

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ReferenceInequality Field

OperatorKindReferenceInequality Field
A reference inequality operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ReferenceInequality = 20
Public Const ReferenceInequality As OperatorKind = 20

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.RightShift Field

OperatorKindRightShift Field
A right shift operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind RightShift = 16
Public Const RightShift As OperatorKind = 16

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.Subtraction Field

OperatorKindSubtraction Field
A subtraction operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind Subtraction = 2
Public Const Subtraction As OperatorKind = 2

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.value__ Field

OperatorKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.Ast.OperatorKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ValueEquality Field

OperatorKindValueEquality Field
A value equality operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ValueEquality = 17
Public Const ValueEquality As OperatorKind = 17

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


OperatorKind.ValueInequality Field

OperatorKindValueInequality Field
A value inequality operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OperatorKind ValueInequality = 18
Public Const ValueInequality As OperatorKind = 18

Field Value

Type: OperatorKind
See Also

Reference

OperatorKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind Class

ParameterKind Class
Specifies the type of parameter.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.Python.AstParameterKind

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ParameterKind : Enum
Public NotInheritable Class ParameterKind
    Inherits Enum

The ParameterKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Dictionary | Dictionary.
 | Normal | Normal.
 | Tuple | Tuple.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind Methods

ParameterKind Methods

The ParameterKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ParameterKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind Fields

ParameterKind Fields

The ParameterKind type exposes the following members.

Fields
 | Name | Description
 | Dictionary | Dictionary.
 | Normal | Normal.
 | Tuple | Tuple.
Public field | value__ |
Top
See Also

Reference

ParameterKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind.Dictionary Field

ParameterKindDictionary Field
Dictionary.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterKind Dictionary = 2
Public Const Dictionary As ParameterKind = 2

Field Value

Type: ParameterKind
See Also

Reference

ParameterKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind.Normal Field

ParameterKindNormal Field
Normal.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterKind Normal = 0
Public Const Normal As ParameterKind = 0

Field Value

Type: ParameterKind
See Also

Reference

ParameterKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind.Tuple Field

ParameterKindTuple Field
Tuple.

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParameterKind Tuple = 1
Public Const Tuple As ParameterKind = 1

Field Value

Type: ParameterKind
See Also

Reference

ParameterKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ParameterKind.value__ Field

ParameterKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.Ast.ParameterKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python.Ast
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ParameterKind Class
ActiproSoftware.Text.Languages.Python.Ast Namespace


ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace
Contains the implementation types related to ASTs for a Python syntax language.
Classes
 | Class | Description
Public class | Argument | Represents an argument.
Public class | AssertStatement | Represents an assert statement.
Public class | AssignmentStatement | Represents an assignment statement.
Public class | AttributeReferenceExpression | Represents an attribute reference expression.
Public class | BinaryOperatorExpression | Represents a binary operator expression.
Public class | BlockStatement | Represents a block statement.
Public class | BoundName | Represents a bound name.
Public class | BreakStatement | Represents a break statement.
Public class | ClassDeclaration | Represents a class declaration.
Public class | CompilationUnit | Represents a compilation unit.
Public class | ComprehensionClauseBase | Represents a comprehension clause base.
Public class | ComprehensionExpression | Represents a comprehension expression.
Public class | ComprehensionFor | Represents a comprehension for.
Public class | ComprehensionIf | Represents a comprehension if.
Public class | ConditionalExpression | Represents a conditional expression.
Public class | ContinueStatement | Represents a continue statement.
Public class | DeclarationBase | Represents a declaration base.
Public class | Decorator | Represents a decorator.
Public class | DeleteStatement | Represents a delete statement.
Public class | DictionaryExpression | Represents a dictionary expression.
Public class | Ellipsis | Represents an ellipsis.
Public class | ExecuteStatement | Represents an execute statement.
Public class | Expression | Represents an expression.
Public class | ExpressionStatement | Represents an expression statement.
Public class | ForStatement | Represents a for statement.
Public class | FromImportStatement | Represents a from import statement.
Public class | FunctionDeclaration | Represents a function declaration.
Public class | GeneratorExpression | Represents a generator expression.
Public class | GlobalStatement | Represents a global statement.
Public class | IfStatement | Represents an if statement.
Public class | IfStatementCondition | Represents an if statement condition.
Public class | ImportStatement | Represents an import statement.
Public class | InvocationExpression | Represents an invocation expression.
Public class | KeyValueExpression | Represents a key value expression.
Public class | LambdaExpression | Represents a lambda expression.
Public class | ListExpression | Represents a list expression.
Public class | LiteralExpression | Represents a literal expression.
Public class | NonLocalStatement | Represents a non local statement.
Public class | Parameter | Represents a parameter.
Public class | ParenthesizedExpression | Represents a parenthesized expression.
Public class | PassStatement | Represents a pass statement.
Public class | PrintStatement | Represents a print statement.
Public class | PythonAstNodeId | Contains the AST node IDs for the Python language.
Public class | RaiseStatement | Represents a raise statement.
Public class | ReturnStatement | Represents a return statement.
Public class | SetExpression | Represents a set expression.
Public class | SimpleName | Represents a simple name.
Public class | SliceExpression | Represents a slice expression.
Public class | SliceItem | Represents a slice item.
Public class | StarExpression | Represents a star expression.
Public class | Statement | Represents a statement.
Public class | StringConversionExpression | Represents a string conversion expression.
Public class | SubscriptionExpression | Represents a subscription expression.
Public class | TryStatement | Represents a try statement.
Public class | TryStatementExceptClause | Represents a try statement except clause.
Public class | TupleExpression | Represents a tuple expression.
Public class | UnaryOperatorExpression | Represents an unary operator expression.
Public class | WhileStatement | Represents a while statement.
Public class | WithStatement | Represents a with statement.
Public class | YieldExpression | Represents a yield expression.


Argument Class

Argument Class
Represents an argument.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationArgument

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Argument : AstNodeBase
Public Class Argument
    Inherits AstNodeBase

The Argument type exposes the following members.

Constructors
 | Name | Description
Public method | Argument | Initializes a new instance of the Argument class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument Constructor

Argument Constructor
Initializes a new instance of the Argument class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Argument()
Public Sub New
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument Properties

Argument Properties

The Argument type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Expression Property

ArgumentExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Id Property

ArgumentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Kind Property

ArgumentKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ArgumentKind Kind { get; set; }
Public Property Kind As ArgumentKind
    Get
    Set

Property Value

Type: ArgumentKind
The kind.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.Name Property

ArgumentName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument Methods

Argument Methods

The Argument type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Argument.GetChildrenEnumerator Method

ArgumentGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Argument Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Class

AssertStatement Class
Represents an assert statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssertStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AssertStatement : Statement
Public Class AssertStatement
    Inherits Statement

The AssertStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AssertStatement | Initializes a new instance of the AssertStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | MessageExpression | Gets or sets the message expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Constructor

AssertStatement Constructor
Initializes a new instance of the AssertStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssertStatement()
Public Sub New
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Properties

AssertStatement Properties

The AssertStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | MessageExpression | Gets or sets the message expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.ConditionExpression Property

AssertStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.Id Property

AssertStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.MessageExpression Property

AssertStatementMessageExpression Property
Gets or sets the message expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression MessageExpression { get; set; }
Public Property MessageExpression As Expression
    Get
    Set

Property Value

Type: Expression
The message expression.
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement Methods

AssertStatement Methods

The AssertStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssertStatement.GetChildrenEnumerator Method

AssertStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssertStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Class

AssignmentStatement Class
Represents an assignment statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssignmentStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AssignmentStatement : Statement
Public Class AssignmentStatement
    Inherits Statement

The AssignmentStatement type exposes the following members.

Constructors
 | Name | Description
Public method | AssignmentStatement | Initializes a new instance of the AssignmentStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Constructor

AssignmentStatement Constructor
Initializes a new instance of the AssignmentStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AssignmentStatement()
Public Sub New
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Properties

AssignmentStatement Properties

The AssignmentStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.Id Property

AssignmentStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.LeftExpression Property

AssignmentStatementLeftExpression Property
Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.Operator Property

AssignmentStatementOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.RightExpression Property

AssignmentStatementRightExpression Property
Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement Methods

AssignmentStatement Methods

The AssignmentStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AssignmentStatement.GetChildrenEnumerator Method

AssignmentStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AssignmentStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Class

AttributeReferenceExpression Class
Represents an attribute reference expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAttributeReferenceExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AttributeReferenceExpression : Expression
Public Class AttributeReferenceExpression
    Inherits Expression

The AttributeReferenceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeReferenceExpression | Initializes a new instance of the AttributeReferenceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Constructor

AttributeReferenceExpression Constructor
Initializes a new instance of the AttributeReferenceExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AttributeReferenceExpression()
Public Sub New
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Properties

AttributeReferenceExpression Properties

The AttributeReferenceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.Id Property

AttributeReferenceExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.Name Property

AttributeReferenceExpressionName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.TargetExpression Property

AttributeReferenceExpressionTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression Methods

AttributeReferenceExpression Methods

The AttributeReferenceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


AttributeReferenceExpression.GetChildrenEnumerator Method

AttributeReferenceExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AttributeReferenceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Class

BinaryOperatorExpression Class
Represents a binary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBinaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BinaryOperatorExpression : Expression
Public Class BinaryOperatorExpression
    Inherits Expression

The BinaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryOperatorExpression | Initializes a new instance of the BinaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Constructor

BinaryOperatorExpression Constructor
Initializes a new instance of the BinaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BinaryOperatorExpression()
Public Sub New
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Properties

BinaryOperatorExpression Properties

The BinaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | LeftExpression | Gets or sets the left expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | RightExpression | Gets or sets the right expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.Id Property

BinaryOperatorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.LeftExpression Property

BinaryOperatorExpressionLeftExpression Property
Gets or sets the left expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LeftExpression { get; set; }
Public Property LeftExpression As Expression
    Get
    Set

Property Value

Type: Expression
The left expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.Operator Property

BinaryOperatorExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.RightExpression Property

BinaryOperatorExpressionRightExpression Property
Gets or sets the right expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression RightExpression { get; set; }
Public Property RightExpression As Expression
    Get
    Set

Property Value

Type: Expression
The right expression.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression Methods

BinaryOperatorExpression Methods

The BinaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BinaryOperatorExpression.GetChildrenEnumerator Method

BinaryOperatorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BinaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Class

BlockStatement Class
Represents a block statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBlockStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BlockStatement : Statement
Public Class BlockStatement
    Inherits Statement

The BlockStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockStatement | Initializes a new instance of the BlockStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Constructor

BlockStatement Constructor
Initializes a new instance of the BlockStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement()
Public Sub New
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Properties

BlockStatement Properties

The BlockStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatements | Gets the child statements.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasChildStatements | Returns whether the ChildStatements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.ChildStatements Property

BlockStatementChildStatements Property
Gets the child statements.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> ChildStatements { get; }
Public ReadOnly Property ChildStatements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The child statements.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.HasChildStatements Property

BlockStatementHasChildStatements Property
Returns whether the ChildStatements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildStatements { get; }
Public ReadOnly Property HasChildStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.Id Property

BlockStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement Methods

BlockStatement Methods

The BlockStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BlockStatement.GetChildrenEnumerator Method

BlockStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

BlockStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Class

BoundName Class
Represents a bound name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBoundName

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BoundName : Expression
Public Class BoundName
    Inherits Expression

The BoundName type exposes the following members.

Constructors
 | Name | Description
Public method | BoundName | Initializes a new instance of the BoundName class
Top
Properties
 | Name | Description
Public property | Binding | Gets or sets the binding.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Original | Gets or sets the original.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResolvedBinding | Gets the resolved binding name.
Public property | ResolvedFirstName | Gets the resolved first name.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Constructor

BoundName Constructor
Initializes a new instance of the BoundName class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BoundName()
Public Sub New
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Properties

BoundName Properties

The BoundName type exposes the following members.

Properties
 | Name | Description
Public property | Binding | Gets or sets the binding.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Original | Gets or sets the original.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ResolvedBinding | Gets the resolved binding name.
Public property | ResolvedFirstName | Gets the resolved first name.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Binding Property

BoundNameBinding Property
Gets or sets the binding.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Binding { get; set; }
Public Property Binding As String
    Get
    Set

Property Value

Type: String
The binding.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Id Property

BoundNameId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Original Property

BoundNameOriginal Property
Gets or sets the original.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Original { get; set; }
Public Property Original As String
    Get
    Set

Property Value

Type: String
The original.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.ResolvedBinding Property

BoundNameResolvedBinding Property
Gets the resolved binding name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedBinding { get; }
Public ReadOnly Property ResolvedBinding As String
    Get

Property Value

Type: String
The resolved binding name.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.ResolvedFirstName Property

BoundNameResolvedFirstName Property
Gets the resolved first name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFirstName { get; }
Public ReadOnly Property ResolvedFirstName As String
    Get

Property Value

Type: String
The resolved first name.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.Value Property

BoundNameValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName Methods

BoundName Methods

The BoundName type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BoundName.ToString Method

BoundNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

BoundName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Class

BreakStatement Class
Represents a break statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBreakStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BreakStatement : Statement
Public Class BreakStatement
    Inherits Statement

The BreakStatement type exposes the following members.

Constructors
 | Name | Description
Public method | BreakStatement | Initializes a new instance of the BreakStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Constructor

BreakStatement Constructor
Initializes a new instance of the BreakStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BreakStatement()
Public Sub New
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Properties

BreakStatement Properties

The BreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement.Id Property

BreakStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


BreakStatement Methods

BreakStatement Methods

The BreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

BreakStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Class

ClassDeclaration Class
Represents a class declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationClassDeclaration

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ClassDeclaration : DeclarationBase
Public Class ClassDeclaration
    Inherits DeclarationBase

The ClassDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | ClassDeclaration | Initializes a new instance of the ClassDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasInheritance | Returns whether the Inheritance collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | Inheritance | Gets the inheritance.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Constructor

ClassDeclaration Constructor
Initializes a new instance of the ClassDeclaration class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassDeclaration()
Public Sub New
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Properties

ClassDeclaration Properties

The ClassDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasInheritance | Returns whether the Inheritance collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | Inheritance | Gets the inheritance.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.HasInheritance Property

ClassDeclarationHasInheritance Property
Returns whether the Inheritance collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasInheritance { get; }
Public ReadOnly Property HasInheritance As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.Id Property

ClassDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.Inheritance Property

ClassDeclarationInheritance Property
Gets the inheritance.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Inheritance { get; }
Public ReadOnly Property Inheritance As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The inheritance.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration Methods

ClassDeclaration Methods

The ClassDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ClassDeclaration.GetChildrenEnumerator Method

ClassDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ClassDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Class

CompilationUnit Class
Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Constructor

CompilationUnit Constructor
Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Properties

CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasStatements | Returns whether the Statements collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statements | Gets the statements.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.HasStatements Property

CompilationUnitHasStatements Property
Returns whether the Statements collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasStatements { get; }
Public ReadOnly Property HasStatements As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.Statements Property

CompilationUnitStatements Property
Gets the statements.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Statement> Statements { get; }
Public ReadOnly Property Statements As IList(Of Statement)
    Get

Property Value

Type: IList Statement
The statements.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit Methods

CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Class

ComprehensionClauseBase Class
Represents a comprehension clause base.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionFor
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionIf

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ComprehensionClauseBase : AstNodeBase
Public Class ComprehensionClauseBase
    Inherits AstNodeBase

The ComprehensionClauseBase type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionClauseBase | Initializes a new instance of the ComprehensionClauseBase class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Constructor

ComprehensionClauseBase Constructor
Initializes a new instance of the ComprehensionClauseBase class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ComprehensionClauseBase()
Public Sub New
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Properties

ComprehensionClauseBase Properties

The ComprehensionClauseBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase.Id Property

ComprehensionClauseBaseId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase.NextClause Property

ComprehensionClauseBaseNextClause Property
Gets or sets the next clause.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ComprehensionClauseBase NextClause { get; set; }
Public Property NextClause As ComprehensionClauseBase
    Get
    Set

Property Value

Type: ComprehensionClauseBase
The next clause.
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase Methods

ComprehensionClauseBase Methods

The ComprehensionClauseBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionClauseBase.GetChildrenEnumerator Method

ComprehensionClauseBaseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionClauseBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Class

ComprehensionExpression Class
Represents a comprehension expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ComprehensionExpression : Expression
Public Class ComprehensionExpression
    Inherits Expression

The ComprehensionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionExpression | Initializes a new instance of the ComprehensionExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clause | Gets or sets the clause.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Constructor

ComprehensionExpression Constructor
Initializes a new instance of the ComprehensionExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ComprehensionExpression()
Public Sub New
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Properties

ComprehensionExpression Properties

The ComprehensionExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Clause | Gets or sets the clause.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.ChildExpression Property

ComprehensionExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.Clause Property

ComprehensionExpressionClause Property
Gets or sets the clause.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ComprehensionClauseBase Clause { get; set; }
Public Property Clause As ComprehensionClauseBase
    Get
    Set

Property Value

Type: ComprehensionClauseBase
The clause.
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.Id Property

ComprehensionExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression Methods

ComprehensionExpression Methods

The ComprehensionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionExpression.GetChildrenEnumerator Method

ComprehensionExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Class

ComprehensionFor Class
Represents a comprehension for.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionFor

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ComprehensionFor : ComprehensionClauseBase
Public Class ComprehensionFor
    Inherits ComprehensionClauseBase

The ComprehensionFor type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionFor | Initializes a new instance of the ComprehensionFor class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Constructor

ComprehensionFor Constructor
Initializes a new instance of the ComprehensionFor class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ComprehensionFor()
Public Sub New
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Properties

ComprehensionFor Properties

The ComprehensionFor type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.ElementExpression Property

ComprehensionForElementExpression Property
Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.EnumerableExpression Property

ComprehensionForEnumerableExpression Property
Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.Id Property

ComprehensionForId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor Methods

ComprehensionFor Methods

The ComprehensionFor type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionFor.GetChildrenEnumerator Method

ComprehensionForGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionFor Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Class

ComprehensionIf Class
Represents a comprehension if.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionIf

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ComprehensionIf : ComprehensionClauseBase
Public Class ComprehensionIf
    Inherits ComprehensionClauseBase

The ComprehensionIf type exposes the following members.

Constructors
 | Name | Description
Public method | ComprehensionIf | Initializes a new instance of the ComprehensionIf class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Constructor

ComprehensionIf Constructor
Initializes a new instance of the ComprehensionIf class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ComprehensionIf()
Public Sub New
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Properties

ComprehensionIf Properties

The ComprehensionIf type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ComprehensionClauseBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | NextClause | Gets or sets the next clause. (Inherited from ComprehensionClauseBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf.ConditionExpression Property

ComprehensionIfConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf.Id Property

ComprehensionIfId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf Methods

ComprehensionIf Methods

The ComprehensionIf type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides ComprehensionClauseBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ComprehensionIf.GetChildrenEnumerator Method

ComprehensionIfGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ComprehensionIf Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Class

ConditionalExpression Class
Represents a conditional expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationConditionalExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ConditionalExpression : Expression
Public Class ConditionalExpression
    Inherits Expression

The ConditionalExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalExpression | Initializes a new instance of the ConditionalExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Constructor

ConditionalExpression Constructor
Initializes a new instance of the ConditionalExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ConditionalExpression()
Public Sub New
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Properties

ConditionalExpression Properties

The ConditionalExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | FalseExpression | Gets or sets the false expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TrueExpression | Gets or sets the true expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.ConditionExpression Property

ConditionalExpressionConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.FalseExpression Property

ConditionalExpressionFalseExpression Property
Gets or sets the false expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression FalseExpression { get; set; }
Public Property FalseExpression As Expression
    Get
    Set

Property Value

Type: Expression
The false expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.Id Property

ConditionalExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.TrueExpression Property

ConditionalExpressionTrueExpression Property
Gets or sets the true expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TrueExpression { get; set; }
Public Property TrueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The true expression.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression Methods

ConditionalExpression Methods

The ConditionalExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ConditionalExpression.GetChildrenEnumerator Method

ConditionalExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ConditionalExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Class

ContinueStatement Class
Represents a continue statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationContinueStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ContinueStatement : Statement
Public Class ContinueStatement
    Inherits Statement

The ContinueStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueStatement | Initializes a new instance of the ContinueStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Constructor

ContinueStatement Constructor
Initializes a new instance of the ContinueStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContinueStatement()
Public Sub New
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Properties

ContinueStatement Properties

The ContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement.Id Property

ContinueStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ContinueStatement Methods

ContinueStatement Methods

The ContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ContinueStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Class

DeclarationBase Class
Represents a declaration base.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationClassDeclaration
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFunctionDeclaration

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeclarationBase : Statement
Public Class DeclarationBase
    Inherits Statement

The DeclarationBase type exposes the following members.

Constructors
 | Name | Description
Public method | DeclarationBase | Initializes a new instance of the DeclarationBase class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Constructor

DeclarationBase Constructor
Initializes a new instance of the DeclarationBase class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeclarationBase()
Public Sub New
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Properties

DeclarationBase Properties

The DeclarationBase type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Decorators | Gets the decorators.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Body Property

DeclarationBaseBody Property
Gets or sets the body.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BlockStatement Body { get; set; }
Public Property Body As BlockStatement
    Get
    Set

Property Value

Type: BlockStatement
The body.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Decorators Property

DeclarationBaseDecorators Property
Gets the decorators.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Decorator> Decorators { get; }
Public ReadOnly Property Decorators As IList(Of Decorator)
    Get

Property Value

Type: IList Decorator
The decorators.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.HasDecorators Property

DeclarationBaseHasDecorators Property
Returns whether the Decorators collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDecorators { get; }
Public ReadOnly Property HasDecorators As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Id Property

DeclarationBaseId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.Name Property

DeclarationBaseName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase Methods

DeclarationBase Methods

The DeclarationBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeclarationBase.GetChildrenEnumerator Method

DeclarationBaseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DeclarationBase Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Class

Decorator Class
Represents a decorator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDecorator

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Decorator : AstNodeBase
Public Class Decorator
    Inherits AstNodeBase

The Decorator type exposes the following members.

Constructors
 | Name | Description
Public method | Decorator | Initializes a new instance of the Decorator class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Constructor

Decorator Constructor
Initializes a new instance of the Decorator class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Decorator()
Public Sub New
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Properties

Decorator Properties

The Decorator type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.Arguments Property

DecoratorArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.HasArguments Property

DecoratorHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.Id Property

DecoratorId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.Name Property

DecoratorName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator Methods

Decorator Methods

The Decorator type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Decorator.GetChildrenEnumerator Method

DecoratorGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Decorator Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Class

DeleteStatement Class
Represents a delete statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeleteStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeleteStatement : Statement
Public Class DeleteStatement
    Inherits Statement

The DeleteStatement type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteStatement | Initializes a new instance of the DeleteStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Constructor

DeleteStatement Constructor
Initializes a new instance of the DeleteStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeleteStatement()
Public Sub New
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Properties

DeleteStatement Properties

The DeleteStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement.Expression Property

DeleteStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement.Id Property

DeleteStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement Methods

DeleteStatement Methods

The DeleteStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DeleteStatement.GetChildrenEnumerator Method

DeleteStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DeleteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Class

DictionaryExpression Class
Represents a dictionary expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDictionaryExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DictionaryExpression : Expression
Public Class DictionaryExpression
    Inherits Expression

The DictionaryExpression type exposes the following members.

Constructors
 | Name | Description
Public method | DictionaryExpression | Initializes a new instance of the DictionaryExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Constructor

DictionaryExpression Constructor
Initializes a new instance of the DictionaryExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DictionaryExpression()
Public Sub New
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Properties

DictionaryExpression Properties

The DictionaryExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.HasItems Property

DictionaryExpressionHasItems Property
Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.Id Property

DictionaryExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.Items Property

DictionaryExpressionItems Property
Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression Methods

DictionaryExpression Methods

The DictionaryExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


DictionaryExpression.GetChildrenEnumerator Method

DictionaryExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

DictionaryExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Class

Ellipsis Class
Represents an ellipsis.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationEllipsis

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Ellipsis : Expression
Public Class Ellipsis
    Inherits Expression

The Ellipsis type exposes the following members.

Constructors
 | Name | Description
Public method | Ellipsis | Initializes a new instance of the Ellipsis class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Constructor

Ellipsis Constructor
Initializes a new instance of the Ellipsis class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Ellipsis()
Public Sub New
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Properties

Ellipsis Properties

The Ellipsis type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis.Id Property

EllipsisId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Ellipsis Methods

Ellipsis Methods

The Ellipsis type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Ellipsis Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Class

ExecuteStatement Class
Represents an execute statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExecuteStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExecuteStatement : Statement
Public Class ExecuteStatement
    Inherits Statement

The ExecuteStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExecuteStatement | Initializes a new instance of the ExecuteStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CodeExpression | Gets or sets the code expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | GlobalsExpression | Gets or sets the globals expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LocalsExpression | Gets or sets the locals expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Constructor

ExecuteStatement Constructor
Initializes a new instance of the ExecuteStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExecuteStatement()
Public Sub New
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Properties

ExecuteStatement Properties

The ExecuteStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | CodeExpression | Gets or sets the code expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | GlobalsExpression | Gets or sets the globals expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LocalsExpression | Gets or sets the locals expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.CodeExpression Property

ExecuteStatementCodeExpression Property
Gets or sets the code expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression CodeExpression { get; set; }
Public Property CodeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The code expression.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.GlobalsExpression Property

ExecuteStatementGlobalsExpression Property
Gets or sets the globals expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression GlobalsExpression { get; set; }
Public Property GlobalsExpression As Expression
    Get
    Set

Property Value

Type: Expression
The globals expression.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.Id Property

ExecuteStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.LocalsExpression Property

ExecuteStatementLocalsExpression Property
Gets or sets the locals expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LocalsExpression { get; set; }
Public Property LocalsExpression As Expression
    Get
    Set

Property Value

Type: Expression
The locals expression.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement Methods

ExecuteStatement Methods

The ExecuteStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExecuteStatement.GetChildrenEnumerator Method

ExecuteStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExecuteStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression Class

Expression Class
Represents an expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
More...

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Expression : AstNodeBase
Public Class Expression
    Inherits AstNodeBase

The Expression type exposes the following members.

Constructors
 | Name | Description
Public method | Expression | Initializes a new instance of the Expression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAttributeReferenceExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBinaryOperatorExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBoundName
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationConditionalExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDictionaryExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationEllipsis
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGeneratorExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationInvocationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationKeyValueExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLambdaExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationListExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLiteralExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParenthesizedExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSetExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSimpleName
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStarExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStringConversionExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSubscriptionExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTupleExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationUnaryOperatorExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationYieldExpression


Expression Constructor

Expression Constructor
Initializes a new instance of the Expression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression()
Public Sub New
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression Properties

Expression Properties

The Expression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression.Id Property

ExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Expression Methods

Expression Methods

The Expression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Expression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Class

ExpressionStatement Class
Represents an expression statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpressionStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExpressionStatement : Statement
Public Class ExpressionStatement
    Inherits Statement

The ExpressionStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionStatement | Initializes a new instance of the ExpressionStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Constructor

ExpressionStatement Constructor
Initializes a new instance of the ExpressionStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExpressionStatement()
Public Sub New
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Properties

ExpressionStatement Properties

The ExpressionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement.Expression Property

ExpressionStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement.Id Property

ExpressionStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement Methods

ExpressionStatement Methods

The ExpressionStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ExpressionStatement.GetChildrenEnumerator Method

ExpressionStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ExpressionStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Class

ForStatement Class
Represents a for statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationForStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ForStatement : Statement
Public Class ForStatement
    Inherits Statement

The ForStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ForStatement | Initializes a new instance of the ForStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Constructor

ForStatement Constructor
Initializes a new instance of the ForStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ForStatement()
Public Sub New
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Properties

ForStatement Properties

The ForStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElementExpression | Gets or sets the element expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EnumerableExpression | Gets or sets the enumerable expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.ElementExpression Property

ForStatementElementExpression Property
Gets or sets the element expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ElementExpression { get; set; }
Public Property ElementExpression As Expression
    Get
    Set

Property Value

Type: Expression
The element expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.ElseStatement Property

ForStatementElseStatement Property
Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.EnumerableExpression Property

ForStatementEnumerableExpression Property
Gets or sets the enumerable expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression EnumerableExpression { get; set; }
Public Property EnumerableExpression As Expression
    Get
    Set

Property Value

Type: Expression
The enumerable expression.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.Id Property

ForStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.LoopStatement Property

ForStatementLoopStatement Property
Gets or sets the loop statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement LoopStatement { get; set; }
Public Property LoopStatement As Statement
    Get
    Set

Property Value

Type: Statement
The loop statement.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement Methods

ForStatement Methods

The ForStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ForStatement.GetChildrenEnumerator Method

ForStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ForStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Class

FromImportStatement Class
Represents a from import statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFromImportStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FromImportStatement : Statement
Public Class FromImportStatement
    Inherits Statement

The FromImportStatement type exposes the following members.

Constructors
 | Name | Description
Public method | FromImportStatement | Initializes a new instance of the FromImportStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Identifiers | Gets the identifiers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleName | Gets or sets the module name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Constructor

FromImportStatement Constructor
Initializes a new instance of the FromImportStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FromImportStatement()
Public Sub New
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Properties

FromImportStatement Properties

The FromImportStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasIdentifiers | Returns whether the Identifiers collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Identifiers | Gets the identifiers.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleName | Gets or sets the module name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.HasIdentifiers Property

FromImportStatementHasIdentifiers Property
Returns whether the Identifiers collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasIdentifiers { get; }
Public ReadOnly Property HasIdentifiers As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.Id Property

FromImportStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.Identifiers Property

FromImportStatementIdentifiers Property
Gets the identifiers.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<BoundName> Identifiers { get; }
Public ReadOnly Property Identifiers As IList(Of BoundName)
    Get

Property Value

Type: IList BoundName
The identifiers.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.ModuleName Property

FromImportStatementModuleName Property
Gets or sets the module name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BoundName ModuleName { get; set; }
Public Property ModuleName As BoundName
    Get
    Set

Property Value

Type: BoundName
The module name.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement Methods

FromImportStatement Methods

The FromImportStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FromImportStatement.GetChildrenEnumerator Method

FromImportStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FromImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Class

FunctionDeclaration Class
Represents a function declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFunctionDeclaration

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FunctionDeclaration : DeclarationBase
Public Class FunctionDeclaration
    Inherits DeclarationBase

The FunctionDeclaration type exposes the following members.

Constructors
 | Name | Description
Public method | FunctionDeclaration | Initializes a new instance of the FunctionDeclaration class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DeclaringClass | Gets the declaring class, if the function is a method.
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | IsClassMethod | Gets whether this definition is a class method.
Public property | IsMethod | Gets whether this definition is a method.
Public property | IsStaticMethod | Gets whether this definition is a static method.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnAnnotationExpression | Gets or sets the return annotation expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Constructor

FunctionDeclaration Constructor
Initializes a new instance of the FunctionDeclaration class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FunctionDeclaration()
Public Sub New
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Properties

FunctionDeclaration Properties

The FunctionDeclaration type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the body. (Inherited from DeclarationBase.)
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | DeclaringClass | Gets the declaring class, if the function is a method.
Public property | Decorators | Gets the decorators. (Inherited from DeclarationBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasDecorators | Returns whether the Decorators collection property contains at least one item. (Inherited from DeclarationBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides DeclarationBaseId.)
Public property | IsClassMethod | Gets whether this definition is a class method.
Public property | IsMethod | Gets whether this definition is a method.
Public property | IsStaticMethod | Gets whether this definition is a static method.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name. (Inherited from DeclarationBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ReturnAnnotationExpression | Gets or sets the return annotation expression.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.DeclaringClass Property

FunctionDeclarationDeclaringClass Property
Gets the declaring class, if the function is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassDeclaration DeclaringClass { get; }
Public ReadOnly Property DeclaringClass As ClassDeclaration
    Get

Property Value

Type: ClassDeclaration
The declaring class, if the function is a method.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.HasParameters Property

FunctionDeclarationHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.Id Property

FunctionDeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.IsClassMethod Property

FunctionDeclarationIsClassMethod Property
Gets whether this definition is a class method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsClassMethod { get; }
Public ReadOnly Property IsClassMethod As Boolean
    Get

Property Value

Type: Boolean
true if this definition is a class method; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.IsMethod Property

FunctionDeclarationIsMethod Property
Gets whether this definition is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMethod { get; }
Public ReadOnly Property IsMethod As Boolean
    Get

Property Value

Type: Boolean
true if this definition is a method; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.IsStaticMethod Property

FunctionDeclarationIsStaticMethod Property
Gets whether this definition is a static method.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsStaticMethod { get; }
Public ReadOnly Property IsStaticMethod As Boolean
    Get

Property Value

Type: Boolean
true if this definition is a static method; otherwise, false.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.Parameters Property

FunctionDeclarationParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Parameter> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of Parameter)
    Get

Property Value

Type: IList Parameter
The parameters.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.ReturnAnnotationExpression Property

FunctionDeclarationReturnAnnotationExpression Property
Gets or sets the return annotation expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ReturnAnnotationExpression { get; set; }
Public Property ReturnAnnotationExpression As Expression
    Get
    Set

Property Value

Type: Expression
The return annotation expression.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration Methods

FunctionDeclaration Methods

The FunctionDeclaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides DeclarationBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


FunctionDeclaration.GetChildrenEnumerator Method

FunctionDeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

FunctionDeclaration Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Class

GeneratorExpression Class
Represents a generator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGeneratorExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GeneratorExpression : Expression
Public Class GeneratorExpression
    Inherits Expression

The GeneratorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | GeneratorExpression | Initializes a new instance of the GeneratorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Constructor

GeneratorExpression Constructor
Initializes a new instance of the GeneratorExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GeneratorExpression()
Public Sub New
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Properties

GeneratorExpression Properties

The GeneratorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression.ChildExpression Property

GeneratorExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression.Id Property

GeneratorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression Methods

GeneratorExpression Methods

The GeneratorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GeneratorExpression.GetChildrenEnumerator Method

GeneratorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GeneratorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Class

GlobalStatement Class
Represents a global statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGlobalStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GlobalStatement : Statement
Public Class GlobalStatement
    Inherits Statement

The GlobalStatement type exposes the following members.

Constructors
 | Name | Description
Public method | GlobalStatement | Initializes a new instance of the GlobalStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Constructor

GlobalStatement Constructor
Initializes a new instance of the GlobalStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GlobalStatement()
Public Sub New
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Properties

GlobalStatement Properties

The GlobalStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.HasNames Property

GlobalStatementHasNames Property
Returns whether the Names collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNames { get; }
Public ReadOnly Property HasNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.Id Property

GlobalStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.Names Property

GlobalStatementNames Property
Gets the names.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SimpleName> Names { get; }
Public ReadOnly Property Names As IList(Of SimpleName)
    Get

Property Value

Type: IList SimpleName
The names.
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement Methods

GlobalStatement Methods

The GlobalStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


GlobalStatement.GetChildrenEnumerator Method

GlobalStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

GlobalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Class

IfStatement Class
Represents an if statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IfStatement : Statement
Public Class IfStatement
    Inherits Statement

The IfStatement type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatement | Initializes a new instance of the IfStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Conditions | Gets the conditions.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasConditions | Returns whether the Conditions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Constructor

IfStatement Constructor
Initializes a new instance of the IfStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IfStatement()
Public Sub New
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Properties

IfStatement Properties

The IfStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Conditions | Gets the conditions.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasConditions | Returns whether the Conditions collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.Conditions Property

IfStatementConditions Property
Gets the conditions.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IfStatementCondition> Conditions { get; }
Public ReadOnly Property Conditions As IList(Of IfStatementCondition)
    Get

Property Value

Type: IList IfStatementCondition
The conditions.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.ElseStatement Property

IfStatementElseStatement Property
Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.HasConditions Property

IfStatementHasConditions Property
Returns whether the Conditions collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasConditions { get; }
Public ReadOnly Property HasConditions As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.Id Property

IfStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement Methods

IfStatement Methods

The IfStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatement.GetChildrenEnumerator Method

IfStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Class

IfStatementCondition Class
Represents an if statement condition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatementCondition

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IfStatementCondition : AstNodeBase
Public Class IfStatementCondition
    Inherits AstNodeBase

The IfStatementCondition type exposes the following members.

Constructors
 | Name | Description
Public method | IfStatementCondition | Initializes a new instance of the IfStatementCondition class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Constructor

IfStatementCondition Constructor
Initializes a new instance of the IfStatementCondition class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IfStatementCondition()
Public Sub New
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Properties

IfStatementCondition Properties

The IfStatementCondition type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.ConditionExpression Property

IfStatementConditionConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.Id Property

IfStatementConditionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.Statement Property

IfStatementConditionStatement Property
Gets or sets the statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement Statement { get; set; }
Public Property Statement As Statement
    Get
    Set

Property Value

Type: Statement
The statement.
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition Methods

IfStatementCondition Methods

The IfStatementCondition type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


IfStatementCondition.GetChildrenEnumerator Method

IfStatementConditionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

IfStatementCondition Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Class

ImportStatement Class
Represents an import statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationImportStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ImportStatement : Statement
Public Class ImportStatement
    Inherits Statement

The ImportStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ImportStatement | Initializes a new instance of the ImportStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasModuleNames | Returns whether the ModuleNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleNames | Gets the module names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Constructor

ImportStatement Constructor
Initializes a new instance of the ImportStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImportStatement()
Public Sub New
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Properties

ImportStatement Properties

The ImportStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasModuleNames | Returns whether the ModuleNames collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ModuleNames | Gets the module names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.HasModuleNames Property

ImportStatementHasModuleNames Property
Returns whether the ModuleNames collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasModuleNames { get; }
Public ReadOnly Property HasModuleNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.Id Property

ImportStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.ModuleNames Property

ImportStatementModuleNames Property
Gets the module names.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<BoundName> ModuleNames { get; }
Public ReadOnly Property ModuleNames As IList(Of BoundName)
    Get

Property Value

Type: IList BoundName
The module names.
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement Methods

ImportStatement Methods

The ImportStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ImportStatement.GetChildrenEnumerator Method

ImportStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ImportStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Class

InvocationExpression Class
Represents an invocation expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationInvocationExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvocationExpression : Expression
Public Class InvocationExpression
    Inherits Expression

The InvocationExpression type exposes the following members.

Constructors
 | Name | Description
Public method | InvocationExpression | Initializes a new instance of the InvocationExpression class
Top
Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Constructor

InvocationExpression Constructor
Initializes a new instance of the InvocationExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvocationExpression()
Public Sub New
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Properties

InvocationExpression Properties

The InvocationExpression type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets the arguments.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasArguments | Returns whether the Arguments collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.Arguments Property

InvocationExpressionArguments Property
Gets the arguments.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Argument> Arguments { get; }
Public ReadOnly Property Arguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The arguments.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.HasArguments Property

InvocationExpressionHasArguments Property
Returns whether the Arguments collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasArguments { get; }
Public ReadOnly Property HasArguments As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.Id Property

InvocationExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.TargetExpression Property

InvocationExpressionTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression Methods

InvocationExpression Methods

The InvocationExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


InvocationExpression.GetChildrenEnumerator Method

InvocationExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

InvocationExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Class

KeyValueExpression Class
Represents a key value expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationKeyValueExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class KeyValueExpression : Expression
Public Class KeyValueExpression
    Inherits Expression

The KeyValueExpression type exposes the following members.

Constructors
 | Name | Description
Public method | KeyValueExpression | Initializes a new instance of the KeyValueExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | KeyExpression | Gets or sets the key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Constructor

KeyValueExpression Constructor
Initializes a new instance of the KeyValueExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public KeyValueExpression()
Public Sub New
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Properties

KeyValueExpression Properties

The KeyValueExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | KeyExpression | Gets or sets the key expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.Id Property

KeyValueExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.KeyExpression Property

KeyValueExpressionKeyExpression Property
Gets or sets the key expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression KeyExpression { get; set; }
Public Property KeyExpression As Expression
    Get
    Set

Property Value

Type: Expression
The key expression.
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.ValueExpression Property

KeyValueExpressionValueExpression Property
Gets or sets the value expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ValueExpression { get; set; }
Public Property ValueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The value expression.
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression Methods

KeyValueExpression Methods

The KeyValueExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


KeyValueExpression.GetChildrenEnumerator Method

KeyValueExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

KeyValueExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Class

LambdaExpression Class
Represents a lambda expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLambdaExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LambdaExpression : Expression
Public Class LambdaExpression
    Inherits Expression

The LambdaExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LambdaExpression | Initializes a new instance of the LambdaExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Constructor

LambdaExpression Constructor
Initializes a new instance of the LambdaExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LambdaExpression()
Public Sub New
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Properties

LambdaExpression Properties

The LambdaExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasParameters | Returns whether the Parameters collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parameters | Gets the parameters.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.ChildExpression Property

LambdaExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.HasParameters Property

LambdaExpressionHasParameters Property
Returns whether the Parameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasParameters { get; }
Public ReadOnly Property HasParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.Id Property

LambdaExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.Parameters Property

LambdaExpressionParameters Property
Gets the parameters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Parameter> Parameters { get; }
Public ReadOnly Property Parameters As IList(Of Parameter)
    Get

Property Value

Type: IList Parameter
The parameters.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression Methods

LambdaExpression Methods

The LambdaExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LambdaExpression.GetChildrenEnumerator Method

LambdaExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

LambdaExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Class

ListExpression Class
Represents a list expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationListExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ListExpression : Expression
Public Class ListExpression
    Inherits Expression

The ListExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ListExpression | Initializes a new instance of the ListExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Constructor

ListExpression Constructor
Initializes a new instance of the ListExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ListExpression()
Public Sub New
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Properties

ListExpression Properties

The ListExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.HasItems Property

ListExpressionHasItems Property
Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.Id Property

ListExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.Items Property

ListExpressionItems Property
Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression Methods

ListExpression Methods

The ListExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ListExpression.GetChildrenEnumerator Method

ListExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ListExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Class

LiteralExpression Class
Represents a literal expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationLiteralExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LiteralExpression : Expression
Public Class LiteralExpression
    Inherits Expression

The LiteralExpression type exposes the following members.

Constructors
 | Name | Description
Public method | LiteralExpression | Initializes a new instance of the LiteralExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Constructor

LiteralExpression Constructor
Initializes a new instance of the LiteralExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LiteralExpression()
Public Sub New
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Properties

LiteralExpression Properties

The LiteralExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StringValue | Gets or sets the string value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression.Id Property

LiteralExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression.Kind Property

LiteralExpressionKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LiteralExpressionKind Kind { get; set; }
Public Property Kind As LiteralExpressionKind
    Get
    Set

Property Value

Type: LiteralExpressionKind
The kind.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression.StringValue Property

LiteralExpressionStringValue Property
Gets or sets the string value.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StringValue { get; set; }
Public Property StringValue As String
    Get
    Set

Property Value

Type: String
The string value.
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


LiteralExpression Methods

LiteralExpression Methods

The LiteralExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

LiteralExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Class

NonLocalStatement Class
Represents a non local statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationNonLocalStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NonLocalStatement : Statement
Public Class NonLocalStatement
    Inherits Statement

The NonLocalStatement type exposes the following members.

Constructors
 | Name | Description
Public method | NonLocalStatement | Initializes a new instance of the NonLocalStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Constructor

NonLocalStatement Constructor
Initializes a new instance of the NonLocalStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonLocalStatement()
Public Sub New
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Properties

NonLocalStatement Properties

The NonLocalStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNames | Returns whether the Names collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Names | Gets the names.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.HasNames Property

NonLocalStatementHasNames Property
Returns whether the Names collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNames { get; }
Public ReadOnly Property HasNames As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.Id Property

NonLocalStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.Names Property

NonLocalStatementNames Property
Gets the names.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SimpleName> Names { get; }
Public ReadOnly Property Names As IList(Of SimpleName)
    Get

Property Value

Type: IList SimpleName
The names.
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement Methods

NonLocalStatement Methods

The NonLocalStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


NonLocalStatement.GetChildrenEnumerator Method

NonLocalStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

NonLocalStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Class

Parameter Class
Represents a parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParameter

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Parameter : AstNodeBase
Public Class Parameter
    Inherits AstNodeBase

The Parameter type exposes the following members.

Constructors
 | Name | Description
Public method | Parameter | Initializes a new instance of the Parameter class
Top
Properties
 | Name | Description
Public property | AnnotationExpression | Gets or sets the annotation expression.
Public property | ChildParameters | Gets the child parameters.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildParameters | Returns whether the ChildParameters collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Constructor

Parameter Constructor
Initializes a new instance of the Parameter class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Parameter()
Public Sub New
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Properties

Parameter Properties

The Parameter type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationExpression | Gets or sets the annotation expression.
Public property | ChildParameters | Gets the child parameters.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildParameters | Returns whether the ChildParameters collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | InitializerExpression | Gets or sets the initializer expression.
Public property | Kind | Gets or sets the kind.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.AnnotationExpression Property

ParameterAnnotationExpression Property
Gets or sets the annotation expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression AnnotationExpression { get; set; }
Public Property AnnotationExpression As Expression
    Get
    Set

Property Value

Type: Expression
The annotation expression.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.ChildParameters Property

ParameterChildParameters Property
Gets the child parameters.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Parameter> ChildParameters { get; }
Public ReadOnly Property ChildParameters As IList(Of Parameter)
    Get

Property Value

Type: IList Parameter
The child parameters.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.HasChildParameters Property

ParameterHasChildParameters Property
Returns whether the ChildParameters collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildParameters { get; }
Public ReadOnly Property HasChildParameters As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.Id Property

ParameterId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.InitializerExpression Property

ParameterInitializerExpression Property
Gets or sets the initializer expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression InitializerExpression { get; set; }
Public Property InitializerExpression As Expression
    Get
    Set

Property Value

Type: Expression
The initializer expression.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.Kind Property

ParameterKind Property
Gets or sets the kind.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParameterKind Kind { get; set; }
Public Property Kind As ParameterKind
    Get
    Set

Property Value

Type: ParameterKind
The kind.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.Name Property

ParameterName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName Name { get; set; }
Public Property Name As SimpleName
    Get
    Set

Property Value

Type: SimpleName
The name.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter Methods

Parameter Methods

The Parameter type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Parameter.GetChildrenEnumerator Method

ParameterGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Parameter Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Class

ParenthesizedExpression Class
Represents a parenthesized expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParenthesizedExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParenthesizedExpression : Expression
Public Class ParenthesizedExpression
    Inherits Expression

The ParenthesizedExpression type exposes the following members.

Constructors
 | Name | Description
Public method | ParenthesizedExpression | Initializes a new instance of the ParenthesizedExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Constructor

ParenthesizedExpression Constructor
Initializes a new instance of the ParenthesizedExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParenthesizedExpression()
Public Sub New
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Properties

ParenthesizedExpression Properties

The ParenthesizedExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression.ChildExpression Property

ParenthesizedExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression.Id Property

ParenthesizedExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression Methods

ParenthesizedExpression Methods

The ParenthesizedExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ParenthesizedExpression.GetChildrenEnumerator Method

ParenthesizedExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ParenthesizedExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Class

PassStatement Class
Represents a pass statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPassStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PassStatement : Statement
Public Class PassStatement
    Inherits Statement

The PassStatement type exposes the following members.

Constructors
 | Name | Description
Public method | PassStatement | Initializes a new instance of the PassStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Constructor

PassStatement Constructor
Initializes a new instance of the PassStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PassStatement()
Public Sub New
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Properties

PassStatement Properties

The PassStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement.Id Property

PassStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PassStatement Methods

PassStatement Methods

The PassStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PassStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Class

PrintStatement Class
Represents a print statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPrintStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PrintStatement : Statement
Public Class PrintStatement
    Inherits Statement

The PrintStatement type exposes the following members.

Constructors
 | Name | Description
Public method | PrintStatement | Initializes a new instance of the PrintStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | OutputExpression | Gets or sets the output expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Constructor

PrintStatement Constructor
Initializes a new instance of the PrintStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PrintStatement()
Public Sub New
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Properties

PrintStatement Properties

The PrintStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | OutputExpression | Gets or sets the output expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.Id Property

PrintStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.OutputExpression Property

PrintStatementOutputExpression Property
Gets or sets the output expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression OutputExpression { get; set; }
Public Property OutputExpression As Expression
    Get
    Set

Property Value

Type: Expression
The output expression.
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.TargetExpression Property

PrintStatementTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement Methods

PrintStatement Methods

The PrintStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PrintStatement.GetChildrenEnumerator Method

PrintStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

PrintStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Class

PythonAstNodeId Class
Contains the AST node IDs for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPythonAstNodeId

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonAstNodeId : AstNodeIdProviderBase
Public Class PythonAstNodeId
    Inherits AstNodeIdProviderBase

The PythonAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | PythonAstNodeId | Initializes a new instance of the PythonAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Argument | Gets the Argument AST node ID.
AssertStatement | Gets the AssertStatement AST node ID.
AssignmentStatement | Gets the AssignmentStatement AST node ID.
AttributeReferenceExpression | Gets the AttributeReferenceExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BoundName | Gets the BoundName AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ComprehensionClauseBase | Gets the ComprehensionClauseBase AST node ID.
ComprehensionExpression | Gets the ComprehensionExpression AST node ID.
ComprehensionFor | Gets the ComprehensionFor AST node ID.
ComprehensionIf | Gets the ComprehensionIf AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DeclarationBase | Gets the DeclarationBase AST node ID.
Decorator | Gets the Decorator AST node ID.
DeleteStatement | Gets the DeleteStatement AST node ID.
DictionaryExpression | Gets the DictionaryExpression AST node ID.
Ellipsis | Gets the Ellipsis AST node ID.
ExecuteStatement | Gets the ExecuteStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromImportStatement | Gets the FromImportStatement AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
GeneratorExpression | Gets the GeneratorExpression AST node ID.
GlobalStatement | Gets the GlobalStatement AST node ID.
IfStatement | Gets the IfStatement AST node ID.
IfStatementCondition | Gets the IfStatementCondition AST node ID.
ImportStatement | Gets the ImportStatement AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
KeyValueExpression | Gets the KeyValueExpression AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
ListExpression | Gets the ListExpression AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
NonLocalStatement | Gets the NonLocalStatement AST node ID.
Parameter | Gets the Parameter AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PassStatement | Gets the PassStatement AST node ID.
PrintStatement | Gets the PrintStatement AST node ID.
RaiseStatement | Gets the RaiseStatement AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SetExpression | Gets the SetExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SliceExpression | Gets the SliceExpression AST node ID.
SliceItem | Gets the SliceItem AST node ID.
StarExpression | Gets the StarExpression AST node ID.
Statement | Gets the Statement AST node ID.
StringConversionExpression | Gets the StringConversionExpression AST node ID.
SubscriptionExpression | Gets the SubscriptionExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TryStatementExceptClause | Gets the TryStatementExceptClause AST node ID.
TupleExpression | Gets the TupleExpression AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
YieldExpression | Gets the YieldExpression AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Constructor

PythonAstNodeId Constructor
Initializes a new instance of the PythonAstNodeId class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonAstNodeId()
Public Sub New
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Properties

PythonAstNodeId Properties

The PythonAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.MaxId Property

PythonAstNodeIdMaxId Property
Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.MinId Property

PythonAstNodeIdMinId Property
Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Methods

PythonAstNodeId Methods

The PythonAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ContainsId Method

PythonAstNodeIdContainsId Method
Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GetDescription Method

PythonAstNodeIdGetDescription Method
Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GetKey Method

PythonAstNodeIdGetKey Method
Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId Fields

PythonAstNodeId Fields

The PythonAstNodeId type exposes the following members.

Fields
Name | Description
Argument | Gets the Argument AST node ID.
AssertStatement | Gets the AssertStatement AST node ID.
AssignmentStatement | Gets the AssignmentStatement AST node ID.
AttributeReferenceExpression | Gets the AttributeReferenceExpression AST node ID.
BinaryOperatorExpression | Gets the BinaryOperatorExpression AST node ID.
BlockStatement | Gets the BlockStatement AST node ID.
BoundName | Gets the BoundName AST node ID.
BreakStatement | Gets the BreakStatement AST node ID.
ClassDeclaration | Gets the ClassDeclaration AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
ComprehensionClauseBase | Gets the ComprehensionClauseBase AST node ID.
ComprehensionExpression | Gets the ComprehensionExpression AST node ID.
ComprehensionFor | Gets the ComprehensionFor AST node ID.
ComprehensionIf | Gets the ComprehensionIf AST node ID.
ConditionalExpression | Gets the ConditionalExpression AST node ID.
ContinueStatement | Gets the ContinueStatement AST node ID.
DeclarationBase | Gets the DeclarationBase AST node ID.
Decorator | Gets the Decorator AST node ID.
DeleteStatement | Gets the DeleteStatement AST node ID.
DictionaryExpression | Gets the DictionaryExpression AST node ID.
Ellipsis | Gets the Ellipsis AST node ID.
ExecuteStatement | Gets the ExecuteStatement AST node ID.
Expression | Gets the Expression AST node ID.
ExpressionStatement | Gets the ExpressionStatement AST node ID.
ForStatement | Gets the ForStatement AST node ID.
FromImportStatement | Gets the FromImportStatement AST node ID.
FunctionDeclaration | Gets the FunctionDeclaration AST node ID.
GeneratorExpression | Gets the GeneratorExpression AST node ID.
GlobalStatement | Gets the GlobalStatement AST node ID.
IfStatement | Gets the IfStatement AST node ID.
IfStatementCondition | Gets the IfStatementCondition AST node ID.
ImportStatement | Gets the ImportStatement AST node ID.
InvocationExpression | Gets the InvocationExpression AST node ID.
KeyValueExpression | Gets the KeyValueExpression AST node ID.
LambdaExpression | Gets the LambdaExpression AST node ID.
ListExpression | Gets the ListExpression AST node ID.
LiteralExpression | Gets the LiteralExpression AST node ID.
NonLocalStatement | Gets the NonLocalStatement AST node ID.
Parameter | Gets the Parameter AST node ID.
ParenthesizedExpression | Gets the ParenthesizedExpression AST node ID.
PassStatement | Gets the PassStatement AST node ID.
PrintStatement | Gets the PrintStatement AST node ID.
RaiseStatement | Gets the RaiseStatement AST node ID.
ReturnStatement | Gets the ReturnStatement AST node ID.
SetExpression | Gets the SetExpression AST node ID.
SimpleName | Gets the SimpleName AST node ID.
SliceExpression | Gets the SliceExpression AST node ID.
SliceItem | Gets the SliceItem AST node ID.
StarExpression | Gets the StarExpression AST node ID.
Statement | Gets the Statement AST node ID.
StringConversionExpression | Gets the StringConversionExpression AST node ID.
SubscriptionExpression | Gets the SubscriptionExpression AST node ID.
TryStatement | Gets the TryStatement AST node ID.
TryStatementExceptClause | Gets the TryStatementExceptClause AST node ID.
TupleExpression | Gets the TupleExpression AST node ID.
UnaryOperatorExpression | Gets the UnaryOperatorExpression AST node ID.
WhileStatement | Gets the WhileStatement AST node ID.
WithStatement | Gets the WithStatement AST node ID.
YieldExpression | Gets the YieldExpression AST node ID.
Top
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Argument Field

PythonAstNodeIdArgument Field
Gets the Argument AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Argument = 14001
Public Const Argument As Integer = 14001

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.AssertStatement Field

PythonAstNodeIdAssertStatement Field
Gets the AssertStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AssertStatement = 14002
Public Const AssertStatement As Integer = 14002

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.AssignmentStatement Field

PythonAstNodeIdAssignmentStatement Field
Gets the AssignmentStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AssignmentStatement = 14003
Public Const AssignmentStatement As Integer = 14003

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.AttributeReferenceExpression Field

PythonAstNodeIdAttributeReferenceExpression Field
Gets the AttributeReferenceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int AttributeReferenceExpression = 14004
Public Const AttributeReferenceExpression As Integer = 14004

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BinaryOperatorExpression Field

PythonAstNodeIdBinaryOperatorExpression Field
Gets the BinaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BinaryOperatorExpression = 14005
Public Const BinaryOperatorExpression As Integer = 14005

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BlockStatement Field

PythonAstNodeIdBlockStatement Field
Gets the BlockStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BlockStatement = 14006
Public Const BlockStatement As Integer = 14006

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BoundName Field

PythonAstNodeIdBoundName Field
Gets the BoundName AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BoundName = 14007
Public Const BoundName As Integer = 14007

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.BreakStatement Field

PythonAstNodeIdBreakStatement Field
Gets the BreakStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int BreakStatement = 14008
Public Const BreakStatement As Integer = 14008

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ClassDeclaration Field

PythonAstNodeIdClassDeclaration Field
Gets the ClassDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ClassDeclaration = 14009
Public Const ClassDeclaration As Integer = 14009

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.CompilationUnit Field

PythonAstNodeIdCompilationUnit Field
Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 14000
Public Const CompilationUnit As Integer = 14000

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionClauseBase Field

PythonAstNodeIdComprehensionClauseBase Field
Gets the ComprehensionClauseBase AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ComprehensionClauseBase = 14010
Public Const ComprehensionClauseBase As Integer = 14010

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionExpression Field

PythonAstNodeIdComprehensionExpression Field
Gets the ComprehensionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ComprehensionExpression = 14011
Public Const ComprehensionExpression As Integer = 14011

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionFor Field

PythonAstNodeIdComprehensionFor Field
Gets the ComprehensionFor AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ComprehensionFor = 14012
Public Const ComprehensionFor As Integer = 14012

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ComprehensionIf Field

PythonAstNodeIdComprehensionIf Field
Gets the ComprehensionIf AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ComprehensionIf = 14013
Public Const ComprehensionIf As Integer = 14013

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ConditionalExpression Field

PythonAstNodeIdConditionalExpression Field
Gets the ConditionalExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ConditionalExpression = 14014
Public Const ConditionalExpression As Integer = 14014

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ContinueStatement Field

PythonAstNodeIdContinueStatement Field
Gets the ContinueStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContinueStatement = 14015
Public Const ContinueStatement As Integer = 14015

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.DeclarationBase Field

PythonAstNodeIdDeclarationBase Field
Gets the DeclarationBase AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DeclarationBase = 14017
Public Const DeclarationBase As Integer = 14017

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Decorator Field

PythonAstNodeIdDecorator Field
Gets the Decorator AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Decorator = 14016
Public Const Decorator As Integer = 14016

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.DeleteStatement Field

PythonAstNodeIdDeleteStatement Field
Gets the DeleteStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DeleteStatement = 14018
Public Const DeleteStatement As Integer = 14018

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.DictionaryExpression Field

PythonAstNodeIdDictionaryExpression Field
Gets the DictionaryExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DictionaryExpression = 14019
Public Const DictionaryExpression As Integer = 14019

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Ellipsis Field

PythonAstNodeIdEllipsis Field
Gets the Ellipsis AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Ellipsis = 14020
Public Const Ellipsis As Integer = 14020

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ExecuteStatement Field

PythonAstNodeIdExecuteStatement Field
Gets the ExecuteStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExecuteStatement = 14021
Public Const ExecuteStatement As Integer = 14021

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Expression Field

PythonAstNodeIdExpression Field
Gets the Expression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Expression = 14022
Public Const Expression As Integer = 14022

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ExpressionStatement Field

PythonAstNodeIdExpressionStatement Field
Gets the ExpressionStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExpressionStatement = 14023
Public Const ExpressionStatement As Integer = 14023

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ForStatement Field

PythonAstNodeIdForStatement Field
Gets the ForStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ForStatement = 14024
Public Const ForStatement As Integer = 14024

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.FromImportStatement Field

PythonAstNodeIdFromImportStatement Field
Gets the FromImportStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FromImportStatement = 14025
Public Const FromImportStatement As Integer = 14025

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.FunctionDeclaration Field

PythonAstNodeIdFunctionDeclaration Field
Gets the FunctionDeclaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int FunctionDeclaration = 14026
Public Const FunctionDeclaration As Integer = 14026

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GeneratorExpression Field

PythonAstNodeIdGeneratorExpression Field
Gets the GeneratorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int GeneratorExpression = 14027
Public Const GeneratorExpression As Integer = 14027

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.GlobalStatement Field

PythonAstNodeIdGlobalStatement Field
Gets the GlobalStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int GlobalStatement = 14028
Public Const GlobalStatement As Integer = 14028

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.IfStatement Field

PythonAstNodeIdIfStatement Field
Gets the IfStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int IfStatement = 14029
Public Const IfStatement As Integer = 14029

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.IfStatementCondition Field

PythonAstNodeIdIfStatementCondition Field
Gets the IfStatementCondition AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int IfStatementCondition = 14030
Public Const IfStatementCondition As Integer = 14030

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ImportStatement Field

PythonAstNodeIdImportStatement Field
Gets the ImportStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ImportStatement = 14031
Public Const ImportStatement As Integer = 14031

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.InvocationExpression Field

PythonAstNodeIdInvocationExpression Field
Gets the InvocationExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InvocationExpression = 14032
Public Const InvocationExpression As Integer = 14032

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.KeyValueExpression Field

PythonAstNodeIdKeyValueExpression Field
Gets the KeyValueExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeyValueExpression = 14033
Public Const KeyValueExpression As Integer = 14033

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.LambdaExpression Field

PythonAstNodeIdLambdaExpression Field
Gets the LambdaExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LambdaExpression = 14034
Public Const LambdaExpression As Integer = 14034

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ListExpression Field

PythonAstNodeIdListExpression Field
Gets the ListExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ListExpression = 14035
Public Const ListExpression As Integer = 14035

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.LiteralExpression Field

PythonAstNodeIdLiteralExpression Field
Gets the LiteralExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralExpression = 14036
Public Const LiteralExpression As Integer = 14036

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.NonLocalStatement Field

PythonAstNodeIdNonLocalStatement Field
Gets the NonLocalStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int NonLocalStatement = 14037
Public Const NonLocalStatement As Integer = 14037

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Parameter Field

PythonAstNodeIdParameter Field
Gets the Parameter AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Parameter = 14038
Public Const Parameter As Integer = 14038

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ParenthesizedExpression Field

PythonAstNodeIdParenthesizedExpression Field
Gets the ParenthesizedExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ParenthesizedExpression = 14039
Public Const ParenthesizedExpression As Integer = 14039

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.PassStatement Field

PythonAstNodeIdPassStatement Field
Gets the PassStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PassStatement = 14040
Public Const PassStatement As Integer = 14040

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.PrintStatement Field

PythonAstNodeIdPrintStatement Field
Gets the PrintStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PrintStatement = 14041
Public Const PrintStatement As Integer = 14041

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.RaiseStatement Field

PythonAstNodeIdRaiseStatement Field
Gets the RaiseStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int RaiseStatement = 14042
Public Const RaiseStatement As Integer = 14042

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.ReturnStatement Field

PythonAstNodeIdReturnStatement Field
Gets the ReturnStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReturnStatement = 14043
Public Const ReturnStatement As Integer = 14043

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SetExpression Field

PythonAstNodeIdSetExpression Field
Gets the SetExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SetExpression = 14044
Public Const SetExpression As Integer = 14044

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SimpleName Field

PythonAstNodeIdSimpleName Field
Gets the SimpleName AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SimpleName = 14045
Public Const SimpleName As Integer = 14045

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SliceExpression Field

PythonAstNodeIdSliceExpression Field
Gets the SliceExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SliceExpression = 14046
Public Const SliceExpression As Integer = 14046

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SliceItem Field

PythonAstNodeIdSliceItem Field
Gets the SliceItem AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SliceItem = 14047
Public Const SliceItem As Integer = 14047

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.StarExpression Field

PythonAstNodeIdStarExpression Field
Gets the StarExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StarExpression = 14048
Public Const StarExpression As Integer = 14048

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.Statement Field

PythonAstNodeIdStatement Field
Gets the Statement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Statement = 14049
Public Const Statement As Integer = 14049

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.StringConversionExpression Field

PythonAstNodeIdStringConversionExpression Field
Gets the StringConversionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StringConversionExpression = 14050
Public Const StringConversionExpression As Integer = 14050

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.SubscriptionExpression Field

PythonAstNodeIdSubscriptionExpression Field
Gets the SubscriptionExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SubscriptionExpression = 14051
Public Const SubscriptionExpression As Integer = 14051

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.TryStatement Field

PythonAstNodeIdTryStatement Field
Gets the TryStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TryStatement = 14052
Public Const TryStatement As Integer = 14052

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.TryStatementExceptClause Field

PythonAstNodeIdTryStatementExceptClause Field
Gets the TryStatementExceptClause AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TryStatementExceptClause = 14053
Public Const TryStatementExceptClause As Integer = 14053

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.TupleExpression Field

PythonAstNodeIdTupleExpression Field
Gets the TupleExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TupleExpression = 14054
Public Const TupleExpression As Integer = 14054

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.UnaryOperatorExpression Field

PythonAstNodeIdUnaryOperatorExpression Field
Gets the UnaryOperatorExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int UnaryOperatorExpression = 14055
Public Const UnaryOperatorExpression As Integer = 14055

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.WhileStatement Field

PythonAstNodeIdWhileStatement Field
Gets the WhileStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WhileStatement = 14056
Public Const WhileStatement As Integer = 14056

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.WithStatement Field

PythonAstNodeIdWithStatement Field
Gets the WithStatement AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int WithStatement = 14057
Public Const WithStatement As Integer = 14057

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


PythonAstNodeId.YieldExpression Field

PythonAstNodeIdYieldExpression Field
Gets the YieldExpression AST node ID.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int YieldExpression = 14058
Public Const YieldExpression As Integer = 14058

Field Value

Type: Int32
See Also

Reference

PythonAstNodeId Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Class

RaiseStatement Class
Represents a raise statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationRaiseStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RaiseStatement : Statement
Public Class RaiseStatement
    Inherits Statement

The RaiseStatement type exposes the following members.

Constructors
 | Name | Description
Public method | RaiseStatement | Initializes a new instance of the RaiseStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptionTypeExpression | Gets or sets the exception type expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TracebackExpression | Gets or sets the traceback expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Constructor

RaiseStatement Constructor
Initializes a new instance of the RaiseStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RaiseStatement()
Public Sub New
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Properties

RaiseStatement Properties

The RaiseStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptionTypeExpression | Gets or sets the exception type expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TracebackExpression | Gets or sets the traceback expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Public property | ValueExpression | Gets or sets the value expression.
Top
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.ExceptionTypeExpression Property

RaiseStatementExceptionTypeExpression Property
Gets or sets the exception type expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ExceptionTypeExpression { get; set; }
Public Property ExceptionTypeExpression As Expression
    Get
    Set

Property Value

Type: Expression
The exception type expression.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.Id Property

RaiseStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.TracebackExpression Property

RaiseStatementTracebackExpression Property
Gets or sets the traceback expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TracebackExpression { get; set; }
Public Property TracebackExpression As Expression
    Get
    Set

Property Value

Type: Expression
The traceback expression.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.ValueExpression Property

RaiseStatementValueExpression Property
Gets or sets the value expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ValueExpression { get; set; }
Public Property ValueExpression As Expression
    Get
    Set

Property Value

Type: Expression
The value expression.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement Methods

RaiseStatement Methods

The RaiseStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


RaiseStatement.GetChildrenEnumerator Method

RaiseStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

RaiseStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Class

ReturnStatement Class
Represents a return statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationReturnStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReturnStatement : Statement
Public Class ReturnStatement
    Inherits Statement

The ReturnStatement type exposes the following members.

Constructors
 | Name | Description
Public method | ReturnStatement | Initializes a new instance of the ReturnStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Constructor

ReturnStatement Constructor
Initializes a new instance of the ReturnStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReturnStatement()
Public Sub New
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Properties

ReturnStatement Properties

The ReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Expression | Gets or sets the expression.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement.Expression Property

ReturnStatementExpression Property
Gets or sets the expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; set; }
Public Property Expression As Expression
    Get
    Set

Property Value

Type: Expression
The expression.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement.Id Property

ReturnStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement Methods

ReturnStatement Methods

The ReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ReturnStatement.GetChildrenEnumerator Method

ReturnStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ReturnStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Class

SetExpression Class
Represents a set expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSetExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SetExpression : Expression
Public Class SetExpression
    Inherits Expression

The SetExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SetExpression | Initializes a new instance of the SetExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Constructor

SetExpression Constructor
Initializes a new instance of the SetExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SetExpression()
Public Sub New
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Properties

SetExpression Properties

The SetExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.HasItems Property

SetExpressionHasItems Property
Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.Id Property

SetExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.Items Property

SetExpressionItems Property
Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression Methods

SetExpression Methods

The SetExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SetExpression.GetChildrenEnumerator Method

SetExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SetExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Class

SimpleName Class
Represents a simple name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSimpleName

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleName : Expression
Public Class SimpleName
    Inherits Expression

The SimpleName type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleName | Initializes a new instance of the SimpleName class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Constructor

SimpleName Constructor
Initializes a new instance of the SimpleName class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleName()
Public Sub New
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Properties

SimpleName Properties

The SimpleName type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Text | Gets or sets the text.
Public property | Value | Gets or sets the string-based value for the AST node. (Overrides AstNodeBaseValue.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.Id Property

SimpleNameId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.Text Property

SimpleNameText Property
Gets or sets the text.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.Value Property

SimpleNameValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName Methods

SimpleName Methods

The SimpleName type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides AstNodeBaseToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SimpleName.ToString Method

SimpleNameToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SimpleName Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Class

SliceExpression Class
Represents a slice expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SliceExpression : Expression
Public Class SliceExpression
    Inherits Expression

The SliceExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SliceExpression | Initializes a new instance of the SliceExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Constructor

SliceExpression Constructor
Initializes a new instance of the SliceExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SliceExpression()
Public Sub New
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Properties

SliceExpression Properties

The SliceExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.HasItems Property

SliceExpressionHasItems Property
Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.Id Property

SliceExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.Items Property

SliceExpressionItems Property
Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<SliceItem> Items { get; }
Public ReadOnly Property Items As IList(Of SliceItem)
    Get

Property Value

Type: IList SliceItem
The items.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.TargetExpression Property

SliceExpressionTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression Methods

SliceExpression Methods

The SliceExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceExpression.GetChildrenEnumerator Method

SliceExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SliceExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Class

SliceItem Class
Represents a slice item.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceItem

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SliceItem : AstNodeBase
Public Class SliceItem
    Inherits AstNodeBase

The SliceItem type exposes the following members.

Constructors
 | Name | Description
Public method | SliceItem | Initializes a new instance of the SliceItem class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasFirstColon | Gets or sets the has first colon.
Public property | HasSecondColon | Gets or sets the has second colon.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LowerBoundExpression | Gets or sets the lower bound expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StrideExpression | Gets or sets the stride expression.
Public property | UpperBoundExpression | Gets or sets the upper bound expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Constructor

SliceItem Constructor
Initializes a new instance of the SliceItem class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SliceItem()
Public Sub New
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Properties

SliceItem Properties

The SliceItem type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasFirstColon | Gets or sets the has first colon.
Public property | HasSecondColon | Gets or sets the has second colon.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LowerBoundExpression | Gets or sets the lower bound expression.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StrideExpression | Gets or sets the stride expression.
Public property | UpperBoundExpression | Gets or sets the upper bound expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.HasFirstColon Property

SliceItemHasFirstColon Property
Gets or sets the has first colon.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasFirstColon { get; set; }
Public Property HasFirstColon As Boolean
    Get
    Set

Property Value

Type: Boolean
The has first colon.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.HasSecondColon Property

SliceItemHasSecondColon Property
Gets or sets the has second colon.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSecondColon { get; set; }
Public Property HasSecondColon As Boolean
    Get
    Set

Property Value

Type: Boolean
The has second colon.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.Id Property

SliceItemId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.LowerBoundExpression Property

SliceItemLowerBoundExpression Property
Gets or sets the lower bound expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression LowerBoundExpression { get; set; }
Public Property LowerBoundExpression As Expression
    Get
    Set

Property Value

Type: Expression
The lower bound expression.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.StrideExpression Property

SliceItemStrideExpression Property
Gets or sets the stride expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression StrideExpression { get; set; }
Public Property StrideExpression As Expression
    Get
    Set

Property Value

Type: Expression
The stride expression.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.UpperBoundExpression Property

SliceItemUpperBoundExpression Property
Gets or sets the upper bound expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression UpperBoundExpression { get; set; }
Public Property UpperBoundExpression As Expression
    Get
    Set

Property Value

Type: Expression
The upper bound expression.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem Methods

SliceItem Methods

The SliceItem type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SliceItem.GetChildrenEnumerator Method

SliceItemGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SliceItem Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Class

StarExpression Class
Represents a star expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStarExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StarExpression : Expression
Public Class StarExpression
    Inherits Expression

The StarExpression type exposes the following members.

Constructors
 | Name | Description
Public method | StarExpression | Initializes a new instance of the StarExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Constructor

StarExpression Constructor
Initializes a new instance of the StarExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StarExpression()
Public Sub New
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Properties

StarExpression Properties

The StarExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression.ChildExpression Property

StarExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression.Id Property

StarExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression Methods

StarExpression Methods

The StarExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StarExpression.GetChildrenEnumerator Method

StarExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StarExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement Class

Statement Class
Represents a statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
More...

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Statement : AstNodeBase
Public Class Statement
    Inherits AstNodeBase

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssertStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationAssignmentStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBlockStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationBreakStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationContinueStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeclarationBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDeleteStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExecuteStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpressionStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationForStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationFromImportStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationGlobalStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationImportStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationNonLocalStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPassStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPrintStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationRaiseStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationReturnStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWhileStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWithStatement


Statement Constructor

Statement Constructor
Initializes a new instance of the Statement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement()
Public Sub New
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement Properties

Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement.Id Property

StatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


Statement Methods

Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Statement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Class

StringConversionExpression Class
Represents a string conversion expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStringConversionExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StringConversionExpression : Expression
Public Class StringConversionExpression
    Inherits Expression

The StringConversionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | StringConversionExpression | Initializes a new instance of the StringConversionExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Constructor

StringConversionExpression Constructor
Initializes a new instance of the StringConversionExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StringConversionExpression()
Public Sub New
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Properties

StringConversionExpression Properties

The StringConversionExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression.ChildExpression Property

StringConversionExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression.Id Property

StringConversionExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression Methods

StringConversionExpression Methods

The StringConversionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


StringConversionExpression.GetChildrenEnumerator Method

StringConversionExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

StringConversionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Class

SubscriptionExpression Class
Represents a subscription expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSubscriptionExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SubscriptionExpression : Expression
Public Class SubscriptionExpression
    Inherits Expression

The SubscriptionExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SubscriptionExpression | Initializes a new instance of the SubscriptionExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | IndexExpression | Gets or sets the index expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Constructor

SubscriptionExpression Constructor
Initializes a new instance of the SubscriptionExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SubscriptionExpression()
Public Sub New
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Properties

SubscriptionExpression Properties

The SubscriptionExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | IndexExpression | Gets or sets the index expression.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.Id Property

SubscriptionExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.IndexExpression Property

SubscriptionExpressionIndexExpression Property
Gets or sets the index expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression IndexExpression { get; set; }
Public Property IndexExpression As Expression
    Get
    Set

Property Value

Type: Expression
The index expression.
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.TargetExpression Property

SubscriptionExpressionTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression Methods

SubscriptionExpression Methods

The SubscriptionExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


SubscriptionExpression.GetChildrenEnumerator Method

SubscriptionExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

SubscriptionExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Class

TryStatement Class
Represents a try statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TryStatement : Statement
Public Class TryStatement
    Inherits Statement

The TryStatement type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatement | Initializes a new instance of the TryStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptClauses | Gets the except clauses.
Public property | ExecutedStatement | Gets or sets the executed statement.
Public property | FinallyStatement | Gets or sets the finally statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasExceptClauses | Returns whether the ExceptClauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Constructor

TryStatement Constructor
Initializes a new instance of the TryStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TryStatement()
Public Sub New
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Properties

TryStatement Properties

The TryStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | ExceptClauses | Gets the except clauses.
Public property | ExecutedStatement | Gets or sets the executed statement.
Public property | FinallyStatement | Gets or sets the finally statement.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasExceptClauses | Returns whether the ExceptClauses collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.ElseStatement Property

TryStatementElseStatement Property
Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.ExceptClauses Property

TryStatementExceptClauses Property
Gets the except clauses.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<TryStatementExceptClause> ExceptClauses { get; }
Public ReadOnly Property ExceptClauses As IList(Of TryStatementExceptClause)
    Get

Property Value

Type: IList TryStatementExceptClause
The except clauses.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.ExecutedStatement Property

TryStatementExecutedStatement Property
Gets or sets the executed statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ExecutedStatement { get; set; }
Public Property ExecutedStatement As Statement
    Get
    Set

Property Value

Type: Statement
The executed statement.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.FinallyStatement Property

TryStatementFinallyStatement Property
Gets or sets the finally statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement FinallyStatement { get; set; }
Public Property FinallyStatement As Statement
    Get
    Set

Property Value

Type: Statement
The finally statement.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.HasExceptClauses Property

TryStatementHasExceptClauses Property
Returns whether the ExceptClauses collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasExceptClauses { get; }
Public ReadOnly Property HasExceptClauses As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.Id Property

TryStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement Methods

TryStatement Methods

The TryStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatement.GetChildrenEnumerator Method

TryStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Class

TryStatementExceptClause Class
Represents a try statement except clause.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatementExceptClause

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TryStatementExceptClause : AstNodeBase
Public Class TryStatementExceptClause
    Inherits AstNodeBase

The TryStatementExceptClause type exposes the following members.

Constructors
 | Name | Description
Public method | TryStatementExceptClause | Initializes a new instance of the TryStatementExceptClause class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Constructor

TryStatementExceptClause Constructor
Initializes a new instance of the TryStatementExceptClause class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TryStatementExceptClause()
Public Sub New
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Properties

TryStatementExceptClause Properties

The TryStatementExceptClause type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Statement | Gets or sets the statement.
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.ConditionExpression Property

TryStatementExceptClauseConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.Id Property

TryStatementExceptClauseId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.Statement Property

TryStatementExceptClauseStatement Property
Gets or sets the statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement Statement { get; set; }
Public Property Statement As Statement
    Get
    Set

Property Value

Type: Statement
The statement.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.TargetExpression Property

TryStatementExceptClauseTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause Methods

TryStatementExceptClause Methods

The TryStatementExceptClause type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TryStatementExceptClause.GetChildrenEnumerator Method

TryStatementExceptClauseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TryStatementExceptClause Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Class

TupleExpression Class
Represents a tuple expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTupleExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TupleExpression : Expression
Public Class TupleExpression
    Inherits Expression

The TupleExpression type exposes the following members.

Constructors
 | Name | Description
Public method | TupleExpression | Initializes a new instance of the TupleExpression class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Constructor

TupleExpression Constructor
Initializes a new instance of the TupleExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TupleExpression()
Public Sub New
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Properties

TupleExpression Properties

The TupleExpression type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasItems | Returns whether the Items collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Items | Gets the items.
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.HasItems Property

TupleExpressionHasItems Property
Returns whether the Items collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasItems { get; }
Public ReadOnly Property HasItems As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.Id Property

TupleExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.Items Property

TupleExpressionItems Property
Gets the items.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Expression> Items { get; }
Public ReadOnly Property Items As IList(Of Expression)
    Get

Property Value

Type: IList Expression
The items.
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression Methods

TupleExpression Methods

The TupleExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


TupleExpression.GetChildrenEnumerator Method

TupleExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

TupleExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Class

UnaryOperatorExpression Class
Represents an unary operator expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationUnaryOperatorExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UnaryOperatorExpression : Expression
Public Class UnaryOperatorExpression
    Inherits Expression

The UnaryOperatorExpression type exposes the following members.

Constructors
 | Name | Description
Public method | UnaryOperatorExpression | Initializes a new instance of the UnaryOperatorExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Constructor

UnaryOperatorExpression Constructor
Initializes a new instance of the UnaryOperatorExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnaryOperatorExpression()
Public Sub New
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Properties

UnaryOperatorExpression Properties

The UnaryOperatorExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Operator | Gets or sets the operator.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.ChildExpression Property

UnaryOperatorExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.Id Property

UnaryOperatorExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.Operator Property

UnaryOperatorExpressionOperator Property
Gets or sets the operator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OperatorKind Operator { get; set; }
Public Property Operator As OperatorKind
    Get
    Set

Property Value

Type: OperatorKind
The operator.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression Methods

UnaryOperatorExpression Methods

The UnaryOperatorExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


UnaryOperatorExpression.GetChildrenEnumerator Method

UnaryOperatorExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

UnaryOperatorExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Class

WhileStatement Class
Represents a while statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWhileStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WhileStatement : Statement
Public Class WhileStatement
    Inherits Statement

The WhileStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WhileStatement | Initializes a new instance of the WhileStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Constructor

WhileStatement Constructor
Initializes a new instance of the WhileStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WhileStatement()
Public Sub New
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Properties

WhileStatement Properties

The WhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ConditionExpression | Gets or sets the condition expression.
Public property | ElseStatement | Gets or sets the else statement.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | LoopStatement | Gets or sets the loop statement.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.ConditionExpression Property

WhileStatementConditionExpression Property
Gets or sets the condition expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ConditionExpression { get; set; }
Public Property ConditionExpression As Expression
    Get
    Set

Property Value

Type: Expression
The condition expression.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.ElseStatement Property

WhileStatementElseStatement Property
Gets or sets the else statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ElseStatement { get; set; }
Public Property ElseStatement As Statement
    Get
    Set

Property Value

Type: Statement
The else statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.Id Property

WhileStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.LoopStatement Property

WhileStatementLoopStatement Property
Gets or sets the loop statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement LoopStatement { get; set; }
Public Property LoopStatement As Statement
    Get
    Set

Property Value

Type: Statement
The loop statement.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement Methods

WhileStatement Methods

The WhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WhileStatement.GetChildrenEnumerator Method

WhileStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WhileStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Class

WithStatement Class
Represents a with statement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationWithStatement

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WithStatement : Statement
Public Class WithStatement
    Inherits Statement

The WithStatement type exposes the following members.

Constructors
 | Name | Description
Public method | WithStatement | Initializes a new instance of the WithStatement class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ContextExpression | Gets or sets the context expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Constructor

WithStatement Constructor
Initializes a new instance of the WithStatement class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WithStatement()
Public Sub New
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Properties

WithStatement Properties

The WithStatement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | ChildStatement | Gets or sets the child statement.
Public property | ContextExpression | Gets or sets the context expression.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides StatementId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TargetExpression | Gets or sets the target expression.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.ChildStatement Property

WithStatementChildStatement Property
Gets or sets the child statement.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Statement ChildStatement { get; set; }
Public Property ChildStatement As Statement
    Get
    Set

Property Value

Type: Statement
The child statement.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.ContextExpression Property

WithStatementContextExpression Property
Gets or sets the context expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ContextExpression { get; set; }
Public Property ContextExpression As Expression
    Get
    Set

Property Value

Type: Expression
The context expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.Id Property

WithStatementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.TargetExpression Property

WithStatementTargetExpression Property
Gets or sets the target expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression TargetExpression { get; set; }
Public Property TargetExpression As Expression
    Get
    Set

Property Value

Type: Expression
The target expression.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement Methods

WithStatement Methods

The WithStatement type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


WithStatement.GetChildrenEnumerator Method

WithStatementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

WithStatement Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Class

YieldExpression Class
Represents a yield expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationYieldExpression

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class YieldExpression : Expression
Public Class YieldExpression
    Inherits Expression

The YieldExpression type exposes the following members.

Constructors
 | Name | Description
Public method | YieldExpression | Initializes a new instance of the YieldExpression class
Top
Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | UseSubiterator | Gets or sets the use subiterator.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Constructor

YieldExpression Constructor
Initializes a new instance of the YieldExpression class

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public YieldExpression()
Public Sub New
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Properties

YieldExpression Properties

The YieldExpression type exposes the following members.

Properties
 | Name | Description
Public property | ChildExpression | Gets or sets the child expression.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides ExpressionId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | UseSubiterator | Gets or sets the use subiterator.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.ChildExpression Property

YieldExpressionChildExpression Property
Gets or sets the child expression.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression ChildExpression { get; set; }
Public Property ChildExpression As Expression
    Get
    Set

Property Value

Type: Expression
The child expression.
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.Id Property

YieldExpressionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.UseSubiterator Property

YieldExpressionUseSubiterator Property
Gets or sets the use subiterator.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool UseSubiterator { get; set; }
Public Property UseSubiterator As Boolean
    Get
    Set

Property Value

Type: Boolean
The use subiterator.
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression Methods

YieldExpression Methods

The YieldExpression type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


YieldExpression.GetChildrenEnumerator Method

YieldExpressionGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Python.Ast.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

YieldExpression Class
ActiproSoftware.Text.Languages.Python.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.Python.Implementation Namespace

ActiproSoftware.Text.Languages.Python.Implementation Namespace
Contains the core classes related to implementing a Python syntax language.
Classes
 | Class | Description
Public class | PythonClassificationTypeProvider | Represents a provider of IClassificationType objects for the Python language.
Public class | PythonCodeBlockFinder | Provides a Python language code block finder service.
Public class | PythonCompletionProvider | Provides IntelliPrompt completion data for the Python language.
Public class | PythonContextFactory | Creates Python language IPythonContext objects for a TextSnapshotOffset.
Public class | PythonExampleTextProvider | Represents a example text provider for the Python language.
Public class | PythonGrammar | Represents a Grammar for the Python language.
Public class | PythonGrammarOptions | Contains options for a Python grammar.
Public class | PythonIndentProvider | Provides a Python language indent provider service.
Public class | PythonLexer | Represents a Python lexer (lexical analyzer) implementation.
Public class | PythonLexicalStateId | Contains the lexical state IDs for the Python language.
Public class | PythonNavigableSymbolProvider | Represents a navigable symbol provider for the Python language.
Public class | PythonOutliner | Provides a Python language outliner service.
Public class | PythonOutliningSource | Represents a Python language range-based outlining source.
Public class | PythonParameterInfoProvider | Provides IntelliPrompt parameter info data for the Python language.
Public class | PythonParseData | Stores the results of a Python language parsing operation.
Public class | PythonParser | Represents a parser for the Python language.
Public class | PythonQuickInfoProvider | Provides IntelliPrompt quick info data for the Python language.
Public class | PythonSyntaxLanguage | Represents a Python syntax language definition.
Public class | PythonTokenId | Contains the token IDs for the Python language.
Public class | PythonTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Python language.
Public class | PythonTokenTagger | Represents an ITaggerT for the Python language.
Public class | PythonTokenTaggerProvider | Represents a provider of PythonTokenTagger objects for documents that use the PythonTokenTagger language.
Public class | PythonTokenTaggerProviderTaggerFactory | Implements a factory that can creates PythonTokenTagger objects for a document.


PythonClassificationTypeProvider Class

PythonClassificationTypeProvider Class
Represents a provider of IClassificationType objects for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonClassificationTypeProvider : IPythonClassificationTypeProvider
Public Class PythonClassificationTypeProvider
    Implements IPythonClassificationTypeProvider

The PythonClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassificationTypeProvider | Initializes a new instance of the PythonClassificationTypeProvider class.
Public method | PythonClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the PythonClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Constructor

PythonClassificationTypeProvider Constructor
Overload List
 | Name | Description
Public method | PythonClassificationTypeProvider | Initializes a new instance of the PythonClassificationTypeProvider class.
Public method | PythonClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the PythonClassificationTypeProvider class.
Top
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Constructor

PythonClassificationTypeProvider Constructor
Initializes a new instance of the PythonClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonClassificationTypeProvider()
Public Sub New
See Also

Reference

PythonClassificationTypeProvider Class
PythonClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

PythonClassificationTypeProvider Constructor (IHighlightingStyleRegistry)
Initializes a new instance of the PythonClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

PythonClassificationTypeProvider Class
PythonClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Properties

PythonClassificationTypeProvider Properties

The PythonClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets the Comment classification type.
Public property | Identifier | Gets the Identifier classification type.
Public property | Keyword | Gets the Keyword classification type.
Public property | Number | Gets the Number classification type.
Public property | Operator | Gets the Operator classification type.
Public property | PythonSystemIdentifier | Gets the PythonSystemIdentifier classification type.
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | String | Gets the String classification type.
Top
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Comment Property

PythonClassificationTypeProviderComment Property
Gets the Comment classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Comment { get; }
Public ReadOnly Property Comment As IClassificationType
    Get

Property Value

Type: IClassificationType
The Comment classification type.

Implements

IPythonClassificationTypeProviderComment
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Identifier Property

PythonClassificationTypeProviderIdentifier Property
Gets the Identifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Identifier { get; }
Public ReadOnly Property Identifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The Identifier classification type.

Implements

IPythonClassificationTypeProviderIdentifier
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Keyword Property

PythonClassificationTypeProviderKeyword Property
Gets the Keyword classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Keyword { get; }
Public ReadOnly Property Keyword As IClassificationType
    Get

Property Value

Type: IClassificationType
The Keyword classification type.

Implements

IPythonClassificationTypeProviderKeyword
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Number Property

PythonClassificationTypeProviderNumber Property
Gets the Number classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Number { get; }
Public ReadOnly Property Number As IClassificationType
    Get

Property Value

Type: IClassificationType
The Number classification type.

Implements

IPythonClassificationTypeProviderNumber
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Operator Property

PythonClassificationTypeProviderOperator Property
Gets the Operator classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType Operator { get; }
Public ReadOnly Property Operator As IClassificationType
    Get

Property Value

Type: IClassificationType
The Operator classification type.

Implements

IPythonClassificationTypeProviderOperator
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.PythonSystemIdentifier Property

PythonClassificationTypeProviderPythonSystemIdentifier Property
Gets the PythonSystemIdentifier classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType PythonSystemIdentifier { get; }
Public ReadOnly Property PythonSystemIdentifier As IClassificationType
    Get

Property Value

Type: IClassificationType
The PythonSystemIdentifier classification type.

Implements

IPythonClassificationTypeProviderPythonSystemIdentifier
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.Registry Property

PythonClassificationTypeProviderRegistry Property
Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.String Property

PythonClassificationTypeProviderString Property
Gets the String classification type.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType String { get; }
Public ReadOnly Property String As IClassificationType
    Get

Property Value

Type: IClassificationType
The String classification type.

Implements

IPythonClassificationTypeProviderString
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider Methods

PythonClassificationTypeProvider Methods

The PythonClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonClassificationTypeProvider.RegisterAll Method

PythonClassificationTypeProviderRegisterAll Method
Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

PythonClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Class

PythonCodeBlockFinder Class
Provides a Python language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.Python.ImplementationPythonCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonCodeBlockFinder : LLParseDataCodeBlockFinder
Public Class PythonCodeBlockFinder
    Inherits LLParseDataCodeBlockFinder

The PythonCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCodeBlockFinder | Initializes a new instance of the PythonCodeBlockFinder class.
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Constructor

PythonCodeBlockFinder Constructor
Initializes a new instance of the PythonCodeBlockFinder class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonCodeBlockFinder()
Public Sub New
See Also

Reference

PythonCodeBlockFinder Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Properties

PythonCodeBlockFinder Properties

The PythonCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

PythonCodeBlockFinder Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCodeBlockFinder Methods

PythonCodeBlockFinder Methods

The PythonCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

PythonCodeBlockFinder Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Class

PythonCompletionProvider Class
Provides IntelliPrompt completion data for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonCompletionProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonCompletionProvider : CompletionProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class PythonCompletionProvider
    Inherits CompletionProviderBase
    Implements IEditorDocumentTextChangeEventSink

The PythonCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCompletionProvider | Initializes a new instance of the PythonCompletionProvider class.
Top
Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within description tips.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Constructor

PythonCompletionProvider Constructor
Initializes a new instance of the PythonCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonCompletionProvider()
Public Sub New
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Properties

PythonCompletionProvider Properties

The PythonCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within description tips.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.DocstringDisplayMode Property

PythonCompletionProviderDocstringDisplayMode Property
Gets or sets the docstring display mode within description tips.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonDocstringDisplayMode DocstringDisplayMode { get; set; }
Public Property DocstringDisplayMode As PythonDocstringDisplayMode
    Get
    Set

Property Value

Type: PythonDocstringDisplayMode
A PythonDocstringDisplayMode that indicates the docstring display mode within description tips.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider Methods

PythonCompletionProvider Methods

The PythonCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.CreateContext Method

PythonCompletionProviderCreateContext Method
Creates an IPythonContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IPythonContext CreateContext(
    IEditorView view
)
Protected Overridable Function CreateContext (
    view As IEditorView
) As IPythonContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IPythonContext
An IPythonContext for the caret's offset in the specified IEditorView.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.OnDocumentTextChanged Method

PythonCompletionProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.OnDocumentTextChanging Method

PythonCompletionProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.OnSessionOpening Method

PythonCompletionProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    ICompletionSession session
)
Protected Overridable Function OnSessionOpening (
    session As ICompletionSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptICompletionSession
The ICompletionSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
Remarks
The default implementation of this method sorts the items in the session.
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonCompletionProvider.RequestSession Method

PythonCompletionProviderRequestSession Method
Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

PythonCompletionProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory Class

PythonContextFactory Class
Creates Python language IPythonContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonContextFactory

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonContextFactory
Public Class PythonContextFactory

The PythonContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | PythonContextFactory | Initializes a new instance of the PythonContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, PythonContextKind) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FindIntersectingChildNode | Searches through the child nodes for a node that intersects the specified offset.
 | FindIntersectingDescendantNode | Recursively searches through the descendant nodes for a node that intersects with the specified offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory Constructor

PythonContextFactory Constructor
Initializes a new instance of the PythonContextFactory class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonContextFactory()
Public Sub New
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory Methods

PythonContextFactory Methods

The PythonContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, PythonContextKind) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | FindIntersectingChildNode | Searches through the child nodes for a node that intersects the specified offset.
 | FindIntersectingDescendantNode | Recursively searches through the descendant nodes for a node that intersects with the specified offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.
Top
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.CreateContext Method

PythonContextFactoryCreateContext Method
Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IPythonContext for the specified TextSnapshotOffset.
Public method | CreateContext(TextSnapshotOffset, PythonContextKind) | Creates an IPythonContext for the specified TextSnapshotOffset.
Top
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.CreateContext Method (TextSnapshotOffset)

PythonContextFactoryCreateContext Method (TextSnapshotOffset)
Creates an IPythonContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPythonContext CreateContext(
    TextSnapshotOffset snapshotOffset
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset
) As IPythonContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.

Return Value

Type: IPythonContext
The IPythonContext that was created.
See Also

Reference

PythonContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.CreateContext Method (TextSnapshotOffset, PythonContextKind)

PythonContextFactoryCreateContext Method (TextSnapshotOffset, PythonContextKind)
Creates an IPythonContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPythonContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    PythonContextKind kind
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As PythonContextKind
) As IPythonContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.PythonPythonContextKind
A PythonContextKind indicating the kind of context.

Return Value

Type: IPythonContext
The IPythonContext that was created.
See Also

Reference

PythonContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.FindIntersectingChildNode Method

PythonContextFactoryFindIntersectingChildNode Method
Searches through the child nodes for a node that intersects the specified offset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IAstNode FindIntersectingChildNode(
    IAstNode node,
    int offset
)
Public Shared Function FindIntersectingChildNode (
    node As IAstNode,
    offset As Integer
) As IAstNode

Parameters

node
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to exmaine.
offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that intersects with the specified offset, if any.
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.FindIntersectingDescendantNode Method

PythonContextFactoryFindIntersectingDescendantNode Method
Recursively searches through the descendant nodes for a node that intersects with the specified offset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IAstNode FindIntersectingDescendantNode(
    IAstNode node,
    int offset
)
Public Shared Function FindIntersectingDescendantNode (
    node As IAstNode,
    offset As Integer
) As IAstNode

Parameters

node
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that intersects with the specified offset, if any.
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonContextFactory.TranslateToParseDataSnapshot Method

PythonContextFactoryTranslateToParseDataSnapshot Method
Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotOffset TranslateToParseDataSnapshot(
    IPythonParseData parseData,
    TextSnapshotOffset snapshotOffset
)
Protected Overridable Function TranslateToParseDataSnapshot (
    parseData As IPythonParseData,
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotOffset

Parameters

parseData
Type: ActiproSoftware.Text.Languages.PythonIPythonParseData
The IPythonParseData to examine.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to translate.

Return Value

Type: TextSnapshotOffset
The translated offset.
See Also

Reference

PythonContextFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Class

PythonExampleTextProvider Class
Represents a example text provider for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonExampleTextProvider : IExampleTextProvider
Public Class PythonExampleTextProvider
    Implements IExampleTextProvider

The PythonExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonExampleTextProvider | Initializes a new instance of the PythonExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Constructor

PythonExampleTextProvider Constructor
Initializes a new instance of the PythonExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonExampleTextProvider()
Public Sub New
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Properties

PythonExampleTextProvider Properties

The PythonExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider.ExampleText Property

PythonExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonExampleTextProvider Methods

PythonExampleTextProvider Methods

The PythonExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonExampleTextProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Class

PythonGrammar Class
Represents a Grammar for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.Python.ImplementationPythonGrammar

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonGrammar : Grammar
Public Class PythonGrammar
    Inherits Grammar

The PythonGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | PythonGrammar | Initializes a new instance of the PythonGrammar class using default options.
Public method | PythonGrammar(IPythonGrammarOptions) | Initializes a new instance of the PythonGrammar class using default options.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Constructor

PythonGrammar Constructor
Overload List
 | Name | Description
Public method | PythonGrammar | Initializes a new instance of the PythonGrammar class using default options.
Public method | PythonGrammar(IPythonGrammarOptions) | Initializes a new instance of the PythonGrammar class using default options.
Top
See Also

Reference

PythonGrammar Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Constructor

PythonGrammar Constructor
Initializes a new instance of the PythonGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonGrammar()
Public Sub New
See Also

Reference

PythonGrammar Class
PythonGrammar Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Constructor (IPythonGrammarOptions)

PythonGrammar Constructor (IPythonGrammarOptions)
Initializes a new instance of the PythonGrammar class using default options.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonGrammar(
    IPythonGrammarOptions options
)
Public Sub New (
    options As IPythonGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.PythonIPythonGrammarOptions
An IPythonGrammarOptions that contains options for the grammar.
See Also

Reference

PythonGrammar Class
PythonGrammar Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Properties

PythonGrammar Properties

The PythonGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

PythonGrammar Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammar Methods

PythonGrammar Methods

The PythonGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

PythonGrammar Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Class

PythonGrammarOptions Class
Contains options for a Python grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonGrammarOptions

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonGrammarOptions : IPythonGrammarOptions
Public Class PythonGrammarOptions
    Implements IPythonGrammarOptions

The PythonGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PythonGrammarOptions | Initializes a new instance of the PythonGrammarOptions class.
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets or sets the PythonVersion that indicates the Python version supported by this grammar.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Constructor

PythonGrammarOptions Constructor
Initializes a new instance of the PythonGrammarOptions class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonGrammarOptions()
Public Sub New
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Properties

PythonGrammarOptions Properties

The PythonGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Public property | Version | Gets or sets the PythonVersion that indicates the Python version supported by this grammar.
Top
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions.RootNonTerminal Property

PythonGrammarOptionsRootNonTerminal Property
Gets or sets a PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonGrammarRootNonTerminal RootNonTerminal { get; set; }
Public Property RootNonTerminal As PythonGrammarRootNonTerminal
    Get
    Set

Property Value

Type: PythonGrammarRootNonTerminal
A PythonGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.

Implements

IPythonGrammarOptionsRootNonTerminal
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions.Version Property

PythonGrammarOptionsVersion Property
Gets or sets the PythonVersion that indicates the Python version supported by this grammar.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; set; }
Public Property Version As PythonVersion
    Get
    Set

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this grammar.

Implements

IPythonGrammarOptionsVersion
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonGrammarOptions Methods

PythonGrammarOptions Methods

The PythonGrammarOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonGrammarOptions Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Class

PythonIndentProvider Class
Provides a Python language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationDelimiterIndentProvider
ActiproSoftware.Text.Languages.Python.ImplementationPythonIndentProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonIndentProvider : DelimiterIndentProvider
Public Class PythonIndentProvider
    Inherits DelimiterIndentProvider

The PythonIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonIndentProvider | Initializes a new instance of the PythonIndentProvider class.
Top
Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Constructor

PythonIndentProvider Constructor
Initializes a new instance of the PythonIndentProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonIndentProvider()
Public Sub New
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Properties

PythonIndentProvider Properties

The PythonIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoIndentCurlyBraces | Gets or sets whether curly braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CanAutoIndentSquareBraces | Gets or sets whether square braces can be auto-indented. (Inherited from DelimiterIndentProvider.)
Public property | CloseCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that a close curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | CloseDelimiterIndentLevel | Gets or sets the additional indent level to apply to close delimiters when auto-indenting them. (Inherited from DelimiterIndentProvider.)
Public property | CloseSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that a close square brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text. (Overrides DelimiterIndentProviderMode.)
Public property | OpenCurlyBraceTokenId | Gets or sets the optional token ID value used to ensure that an open curly brace character is valid. (Inherited from DelimiterIndentProvider.)
Public property | OpenSquareBraceTokenId | Gets or sets the optional token ID value used to ensure that an open square brace character is valid. (Inherited from DelimiterIndentProvider.)
Top
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider.Mode Property

PythonIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IndentMode Mode { get; }
Public Overrides ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider Methods

PythonIndentProvider Methods

The PythonIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset. (Overrides DelimiterIndentProviderGetIndentAmount(TextSnapshotOffset, Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | IsValidEndDelimiter | Returns whether an IToken represents the specified end delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | IsValidStartDelimiter | Returns whether an IToken represents the specified start delimiter. (Inherited from DelimiterIndentProvider.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from DelimiterIndentProvider.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonIndentProvider.GetIndentAmount Method

PythonIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Overrides Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

PythonIndentProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Class

PythonLexer Class
Represents a Python lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexer

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonLexer : MergableLexerBase
Public Class PythonLexer
    Inherits MergableLexerBase

The PythonLexer type exposes the following members.

Constructors
 | Name | Description
Public method | PythonLexer | Initializes a new instance of the PythonLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
 | IsValidIdentifier | Returns whether the specified text is a valid identifier.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Constructor

PythonLexer Constructor
Initializes a new instance of the PythonLexer class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonLexer(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Properties

PythonLexer Properties

The PythonLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.LexicalStates Property

PythonLexerLexicalStates Property
Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.Version Property

PythonLexerVersion Property
Gets the PythonVersion that indicates the Python version supported by this language service.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Methods

PythonLexer Methods

The PythonLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
 | IsIdentifierPartCharacter | Returns whether the specified character is an identifier part character.
 | IsIdentifierStartCharacter | Returns whether the specified character is an identifier start character.
 | IsValidIdentifier | Returns whether the specified text is a valid identifier.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.GetAllLexicalStateTransitions Method

PythonLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.GetNextToken Method

PythonLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.IsIdentifierPartCharacter Method

PythonLexerIsIdentifierPartCharacter Method
Returns whether the specified character is an identifier part character.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierPartCharacter(
    char ch
)
Public Shared Function IsIdentifierPartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier part character; otherwise, false.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.IsIdentifierStartCharacter Method

PythonLexerIsIdentifierStartCharacter Method
Returns whether the specified character is an identifier start character.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierStartCharacter(
    char ch
)
Public Shared Function IsIdentifierStartCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is an identifier start character; otherwise, false.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer.IsValidIdentifier Method

PythonLexerIsValidIdentifier Method
Returns whether the specified text is a valid identifier.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsValidIdentifier(
    string text
)
Public Shared Function IsValidIdentifier (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The text to examine.

Return Value

Type: Boolean
true if the specified text is a valid identifier; otherwise, false.
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexer Events

PythonLexer Events

The PythonLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

PythonLexer Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Class

PythonLexicalStateId Class
Contains the lexical state IDs for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexicalStateId

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonLexicalStateId : LexicalStateIdProviderBase
Public Class PythonLexicalStateId
    Inherits LexicalStateIdProviderBase

The PythonLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | PythonLexicalStateId | Initializes a new instance of the PythonLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Constructor

PythonLexicalStateId Constructor
Initializes a new instance of the PythonLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonLexicalStateId()
Public Sub New
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Properties

PythonLexicalStateId Properties

The PythonLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.MaxId Property

PythonLexicalStateIdMaxId Property
Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.MinId Property

PythonLexicalStateIdMinId Property
Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Methods

PythonLexicalStateId Methods

The PythonLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.ContainsId Method

PythonLexicalStateIdContainsId Method
Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.GetDescription Method

PythonLexicalStateIdGetDescription Method
Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.GetKey Method

PythonLexicalStateIdGetKey Method
Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId Fields

PythonLexicalStateId Fields

The PythonLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
Top
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonLexicalStateId.Default Field

PythonLexicalStateIdDefault Field
Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Default = 14000
Public Const Default As Integer = 14000

Field Value

Type: Int32
See Also

Reference

PythonLexicalStateId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider Class

PythonNavigableSymbolProvider Class
Represents a navigable symbol provider for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonNavigableSymbolProvider : INavigableSymbolProvider
Public Class PythonNavigableSymbolProvider
    Implements INavigableSymbolProvider

The PythonNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonNavigableSymbolProvider | Initializes a new instance of the PythonNavigableSymbolProvider class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider Constructor

PythonNavigableSymbolProvider Constructor
Initializes a new instance of the PythonNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonNavigableSymbolProvider()
Public Sub New
See Also

Reference

PythonNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider Methods

PythonNavigableSymbolProvider Methods

The PythonNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonNavigableSymbolProvider.GetSymbols Method

PythonNavigableSymbolProviderGetSymbols Method
Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Public Overridable Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.

Implements

INavigableSymbolProviderGetSymbols(INavigableRequestContext, TextSnapshotOffset, INavigableSymbol)
See Also

Reference

PythonNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Class

PythonOutliner Class
Provides a Python language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonOutliner

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonOutliner : IOutliner
Public Class PythonOutliner
    Implements IOutliner

The PythonOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | PythonOutliner | Initializes a new instance of the PythonOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Constructor

PythonOutliner Constructor
Initializes a new instance of the PythonOutliner class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonOutliner()
Public Sub New
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Properties

PythonOutliner Properties

The PythonOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner.UpdateTrigger Property

PythonOutlinerUpdateTrigger Property
Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner Methods

PythonOutliner Methods

The PythonOutliner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliner.GetOutliningSource Method

PythonOutlinerGetOutliningSource Method
Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

PythonOutliner Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource Class

PythonOutliningSource Class
Represents a Python language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonOutliningSource

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonOutliningSource : RangeOutliningSourceBase
Public Class PythonOutliningSource
    Inherits RangeOutliningSourceBase

The PythonOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | PythonOutliningSource | Initializes a new instance of the PythonOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IPythonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IPythonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource Constructor

PythonOutliningSource Constructor
Initializes a new instance of the PythonOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource Methods

PythonOutliningSource Methods

The PythonOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IPythonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IPythonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesFromParseData Method

PythonOutliningSourceAddNodesFromParseData Method
Overload List
 | Name | Description
Public method | AddNodesFromParseData(IPythonParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IPythonParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesFromParseData Method (IPythonParseData)

PythonOutliningSourceAddNodesFromParseData Method (IPythonParseData)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IPythonParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IPythonParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.PythonIPythonParseData
The IPythonParseData containing AST data.
See Also

Reference

PythonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesFromParseData Method (IPythonParseData, ITextBufferReader)

PythonOutliningSourceAddNodesFromParseData Method (IPythonParseData, ITextBufferReader)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IPythonParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IPythonParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.PythonIPythonParseData
The IPythonParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

PythonOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonOutliningSource.AddNodesRecursive Method

PythonOutliningSourceAddNodesRecursive Method
Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

PythonOutliningSource Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Class

PythonParameterInfoProvider Class
Provides IntelliPrompt parameter info data for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonParameterInfoProvider : ParameterInfoProviderBase,
    IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink
Public Class PythonParameterInfoProvider
    Inherits ParameterInfoProviderBase
    Implements IEditorDocumentTextChangeEventSink, IEditorViewSelectionChangeEventSink

The PythonParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParameterInfoProvider | Initializes a new instance of the PythonParameterInfoProvider class.
Top
Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within parameter info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IPythonContext.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Constructor

PythonParameterInfoProvider Constructor
Initializes a new instance of the PythonParameterInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonParameterInfoProvider()
Public Sub New
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Properties

PythonParameterInfoProvider Properties

The PythonParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within parameter info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.DocstringDisplayMode Property

PythonParameterInfoProviderDocstringDisplayMode Property
Gets or sets the docstring display mode within parameter info.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonDocstringDisplayMode DocstringDisplayMode { get; set; }
Public Property DocstringDisplayMode As PythonDocstringDisplayMode
    Get
    Set

Property Value

Type: PythonDocstringDisplayMode
A PythonDocstringDisplayMode that indicates the docstring display mode within parameter info.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider Methods

PythonParameterInfoProvider Methods

The PythonParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IPythonContext for the caret's offset in the specified IEditorView.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView.
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IPythonContext.
Top
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.CreateContext Method

PythonParameterInfoProviderCreateContext Method
Creates an IPythonContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IPythonContext CreateContext(
    IEditorView view
)
Protected Overridable Function CreateContext (
    view As IEditorView
) As IPythonContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IPythonContext
An IPythonContext for the caret's offset in the specified IEditorView.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnDocumentTextChanged Method

PythonParameterInfoProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnDocumentTextChanging Method

PythonParameterInfoProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnSessionOpening Method

PythonParameterInfoProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IParameterInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IParameterInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.OnViewSelectionChanged Method

PythonParameterInfoProviderOnViewSelectionChanged Method
Occurs when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.RequestSession Method

PythonParameterInfoProviderRequestSession Method
Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view
)
Public Overrides Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

IParameterInfoProviderRequestSession(IEditorView)
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParameterInfoProvider.UpdateCurrentParameter Method

PythonParameterInfoProviderUpdateCurrentParameter Method
Updates the current parameter in the session's signatures, based on information in the specified IPythonContext.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool UpdateCurrentParameter(
    IParameterInfoSession session,
    IPythonContext context
)
Protected Overridable Function UpdateCurrentParameter (
    session As IParameterInfoSession,
    context As IPythonContext
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIParameterInfoSession
The IParameterInfoSession to update.
context
Type: ActiproSoftware.Text.Languages.PythonIPythonContext
The IPythonContext to examine.

Return Value

Type: Boolean
true if an update was made; otherwise, false.
See Also

Reference

PythonParameterInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Class

PythonParseData Class
Stores the results of a Python language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.Python.ImplementationPythonParseData

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonParseData : LLParseData,
    IPythonParseData, ILLParseData, IParseData, IParseErrorProvider
Public Class PythonParseData
    Inherits LLParseData
    Implements IPythonParseData, ILLParseData, IParseData, IParseErrorProvider

The PythonParseData type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParseData | Initializes a new instance of the PythonParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Constructor

PythonParseData Constructor
Initializes a new instance of the PythonParseData class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonParseData()
Public Sub New
See Also

Reference

PythonParseData Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Properties

PythonParseData Properties

The PythonParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

PythonParseData Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParseData Methods

PythonParseData Methods

The PythonParseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonParseData Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Class

PythonParser Class
Represents a parser for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonParser

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonParser : LLParserBase
Public Class PythonParser
    Inherits LLParserBase

The PythonParser type exposes the following members.

Constructors
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion) | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion, Grammar) | Initializes a new instance of the PythonParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor

PythonParser Constructor
Overload List
 | Name | Description
Public method | PythonParser | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion) | Initializes a new instance of the PythonParser class.
Public method | PythonParser(PythonVersion, Grammar) | Initializes a new instance of the PythonParser class.
Top
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor

PythonParser Constructor
Initializes a new instance of the PythonParser class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonParser()
Public Sub New
See Also

Reference

PythonParser Class
PythonParser Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor (PythonVersion)

PythonParser Constructor (PythonVersion)
Initializes a new instance of the PythonParser class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonParser(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonParser Class
PythonParser Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Constructor (PythonVersion, Grammar)

PythonParser Constructor (PythonVersion, Grammar)
Initializes a new instance of the PythonParser class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonParser(
    PythonVersion version,
    Grammar grammar
)
Public Sub New (
    version As PythonVersion,
    grammar As Grammar
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language service.
grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

PythonParser Class
PythonParser Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Properties

PythonParser Properties

The PythonParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language service.
Top
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.Version Property

PythonParserVersion Property
Gets the PythonVersion that indicates the Python version supported by this language service.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this language service.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser Methods

PythonParser Methods

The PythonParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.CreateParseData Method

PythonParserCreateParseData Method
Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.CreateTokenReader Method

PythonParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.InitializeParserState Method

PythonParserInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonParser.ParseExpression Method

PythonParserParseExpression Method
Parses the specified expression text.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPythonParseData ParseExpression(
    PythonVersion version,
    string text
)
Public Shared Function ParseExpression (
    version As PythonVersion,
    text As String
) As IPythonParseData

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version to use.
text
Type: SystemString
The expression text to parse.

Return Value

Type: IPythonParseData
The IPythonParseData that contains the parse results.
See Also

Reference

PythonParser Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Class

PythonQuickInfoProvider Class
Provides IntelliPrompt quick info data for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonQuickInfoProvider : QuickInfoProviderBase
Public Class PythonQuickInfoProvider
    Inherits QuickInfoProviderBase

The PythonQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonQuickInfoProvider | Initializes a new instance of the PythonQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within quick info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Constructor

PythonQuickInfoProvider Constructor
Initializes a new instance of the PythonQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonQuickInfoProvider()
Public Sub New
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Properties

PythonQuickInfoProvider Properties

The PythonQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | DocstringDisplayMode | Gets or sets the docstring display mode within quick info.
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.ContextTypes Property

PythonQuickInfoProviderContextTypes Property
Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.DocstringDisplayMode Property

PythonQuickInfoProviderDocstringDisplayMode Property
Gets or sets the docstring display mode within quick info.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonDocstringDisplayMode DocstringDisplayMode { get; set; }
Public Property DocstringDisplayMode As PythonDocstringDisplayMode
    Get
    Set

Property Value

Type: PythonDocstringDisplayMode
A PythonDocstringDisplayMode that indicates the docstring display mode within quick info.
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider Methods

PythonQuickInfoProvider Methods

The PythonQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.GetContext Method

PythonQuickInfoProviderGetContext Method
Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.GetContext Method (IEditorView, Int32)

PythonQuickInfoProviderGetContext Method (IEditorView, Int32)
Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

PythonQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.OnSessionOpening Method

PythonQuickInfoProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.RequestSession Method

PythonQuickInfoProviderRequestSession Method
Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

PythonQuickInfoProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonQuickInfoProvider.RequestSession Method (IEditorView, Object)

PythonQuickInfoProviderRequestSession Method (IEditorView, Object)
Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

PythonQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Class

PythonSyntaxLanguage Class
Represents a Python syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.Python.ImplementationPythonSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonSyntaxLanguage : SyntaxLanguage,
    ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink, ITextViewLifecycleEventSink
Public Class PythonSyntaxLanguage
    Inherits SyntaxLanguage
    Implements ICodeDocumentLifecycleEventSink, ICodeDocumentPropertyChangeEventSink, ITextViewLifecycleEventSink

The PythonSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | PythonSyntaxLanguage | Initializes a new instance of the PythonSyntaxLanguage class.
Public method | PythonSyntaxLanguage(PythonVersion) | Initializes a new instance of the PythonSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Constructor

PythonSyntaxLanguage Constructor
Overload List
 | Name | Description
Public method | PythonSyntaxLanguage | Initializes a new instance of the PythonSyntaxLanguage class.
Public method | PythonSyntaxLanguage(PythonVersion) | Initializes a new instance of the PythonSyntaxLanguage class.
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Constructor

PythonSyntaxLanguage Constructor
Initializes a new instance of the PythonSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonSyntaxLanguage()
Public Sub New
See Also

Reference

PythonSyntaxLanguage Class
PythonSyntaxLanguage Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Constructor (PythonVersion)

PythonSyntaxLanguage Constructor (PythonVersion)
Initializes a new instance of the PythonSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonSyntaxLanguage(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion that indicates the Python version supported by this language.
See Also

Reference

PythonSyntaxLanguage Class
PythonSyntaxLanguage Overload
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Properties

PythonSyntaxLanguage Properties

The PythonSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Public property | Version | Gets the PythonVersion that indicates the Python version supported by this language.
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.Version Property

PythonSyntaxLanguageVersion Property
Gets the PythonVersion that indicates the Python version supported by this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion that indicates the Python version supported by this language.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Methods

PythonSyntaxLanguage Methods

The PythonSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language.
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language.
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language.
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentAttached Method

PythonSyntaxLanguageOnDocumentAttached Method
Occurs when the specified ICodeDocument is attached to the language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentAttached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentAttached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentDetached Method

PythonSyntaxLanguageOnDocumentDetached Method
Occurs when the specified ICodeDocument is detached from the language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentDetached(
    ICodeDocument document
)
Protected Overridable Sub OnDocumentDetached (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that is attached.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentFileNameChanged Method

PythonSyntaxLanguageOnDocumentFileNameChanged Method
Occurs after the FileName property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentFileNameChanged(
    ICodeDocument document,
    StringPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentFileNameChanged (
    document As ICodeDocument,
    e As StringPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose FileName property is changed.
e
Type: ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs
The StringPropertyChangedEventArgs that contains the event data.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage.OnDocumentParseDataChanged Method

PythonSyntaxLanguageOnDocumentParseDataChanged Method
Occurs after the ParseData property is changed on an ICodeDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.SyntaxEditor.Addons.Python.Universal (in AS.SyntaxEditor.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentParseDataChanged(
    ICodeDocument document,
    ParseDataPropertyChangedEventArgs e
)
Protected Overridable Sub OnDocumentParseDataChanged (
    document As ICodeDocument,
    e As ParseDataPropertyChangedEventArgs
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument whose ParseData property is changed.
e
Type: ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
The ParseDataPropertyChangedEventArgs that contains the event data.
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonSyntaxLanguage Events

PythonSyntaxLanguage Events

The PythonSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

PythonSyntaxLanguage Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Class

PythonTokenId Class
Contains the token IDs for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenId

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonTokenId : TokenIdProviderBase
Public Class PythonTokenId
    Inherits TokenIdProviderBase

The PythonTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenId | Initializes a new instance of the PythonTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPythonSystemIdentifierClassificationType | Returns whether the specified ID value is part of the PythonSystemIdentifier.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
DecoratorDelimiter | Gets the DecoratorDelimiter token ID.
Dedent | Gets the Dedent token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
Indent | Gets the Indent token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordAssert | Gets the KeywordAssert token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDef | Gets the KeywordDef token ID.
KeywordDel | Gets the KeywordDel token ID.
KeywordElIf | Gets the KeywordElIf token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordExcept | Gets the KeywordExcept token ID.
KeywordExec | Gets the KeywordExec token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFrom | Gets the KeywordFrom token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImport | Gets the KeywordImport token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLambda | Gets the KeywordLambda token ID.
KeywordNone | Gets the KeywordNone token ID.
KeywordNonLocal | Gets the KeywordNonLocal token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordPass | Gets the KeywordPass token ID.
KeywordPrint | Gets the KeywordPrint token ID.
KeywordRaise | Gets the KeywordRaise token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordYield | Gets the KeywordYield token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralBinaryInteger | Gets the LiteralBinaryInteger token ID.
LiteralBytes | Gets the LiteralBytes token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteLongString | Gets the LiteralDoubleQuoteLongString token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralImaginary | Gets the LiteralImaginary token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralSingleQuoteLongString | Gets the LiteralSingleQuoteLongString token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorFloorDivision | Gets the OperatorFloorDivision token ID.
OperatorFloorDivisionAssignment | Gets the OperatorFloorDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPower | Gets the OperatorPower token ID.
OperatorPowerAssignment | Gets the OperatorPowerAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
ReverseQuote | Gets the ReverseQuote token ID.
RightArrow | Gets the RightArrow token ID.
SemiColon | Gets the SemiColon token ID.
SystemIdentifier | Gets the SystemIdentifier token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.610.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Constructor

PythonTokenId Constructor
Initializes a new instance of the PythonTokenId class

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonTokenId()
Public Sub New
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Properties

PythonTokenId Properties

The PythonTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.MaxId Property

PythonTokenIdMaxId Property
Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.MinId Property

PythonTokenIdMinId Property
Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Methods

PythonTokenId Methods

The PythonTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPythonSystemIdentifierClassificationType | Returns whether the specified ID value is part of the PythonSystemIdentifier.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.ContainsId Method

PythonTokenIdContainsId Method
Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.GetDescription Method

PythonTokenIdGetDescription Method
Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.GetKey Method

PythonTokenIdGetKey Method
Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsCommentClassificationType Method

PythonTokenIdIsCommentClassificationType Method
Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsIdentifierClassificationType Method

PythonTokenIdIsIdentifierClassificationType Method
Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsKeywordClassificationType Method

PythonTokenIdIsKeywordClassificationType Method
Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsNumberClassificationType Method

PythonTokenIdIsNumberClassificationType Method
Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsOperatorClassificationType Method

PythonTokenIdIsOperatorClassificationType Method
Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsPythonSystemIdentifierClassificationType Method

PythonTokenIdIsPythonSystemIdentifierClassificationType Method
Returns whether the specified ID value is part of the PythonSystemIdentifier.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsPythonSystemIdentifierClassificationType(
    int id
)
Public Shared Function IsPythonSystemIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.IsStringClassificationType Method

PythonTokenIdIsStringClassificationType Method
Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId Fields

PythonTokenId Fields

The PythonTokenId type exposes the following members.

Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
Comma | Gets the Comma token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
DecoratorDelimiter | Gets the DecoratorDelimiter token ID.
Dedent | Gets the Dedent token ID.
Dot | Gets the Dot token ID.
Identifier | Gets the Identifier token ID.
Indent | Gets the Indent token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordAssert | Gets the KeywordAssert token ID.
KeywordBreak | Gets the KeywordBreak token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordDef | Gets the KeywordDef token ID.
KeywordDel | Gets the KeywordDel token ID.
KeywordElIf | Gets the KeywordElIf token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordExcept | Gets the KeywordExcept token ID.
KeywordExec | Gets the KeywordExec token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFrom | Gets the KeywordFrom token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImport | Gets the KeywordImport token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordLambda | Gets the KeywordLambda token ID.
KeywordNone | Gets the KeywordNone token ID.
KeywordNonLocal | Gets the KeywordNonLocal token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordPass | Gets the KeywordPass token ID.
KeywordPrint | Gets the KeywordPrint token ID.
KeywordRaise | Gets the KeywordRaise token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordYield | Gets the KeywordYield token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralBinaryInteger | Gets the LiteralBinaryInteger token ID.
LiteralBytes | Gets the LiteralBytes token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralDoubleQuoteLongString | Gets the LiteralDoubleQuoteLongString token ID.
LiteralDoubleQuoteString | Gets the LiteralDoubleQuoteString token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralImaginary | Gets the LiteralImaginary token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralReal | Gets the LiteralReal token ID.
LiteralSingleQuoteLongString | Gets the LiteralSingleQuoteLongString token ID.
LiteralSingleQuoteString | Gets the LiteralSingleQuoteString token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorAssignment | Gets the OperatorAssignment token ID.
OperatorBitwiseAnd | Gets the OperatorBitwiseAnd token ID.
OperatorBitwiseAndAssignment | Gets the OperatorBitwiseAndAssignment token ID.
OperatorBitwiseOr | Gets the OperatorBitwiseOr token ID.
OperatorBitwiseOrAssignment | Gets the OperatorBitwiseOrAssignment token ID.
OperatorDivision | Gets the OperatorDivision token ID.
OperatorDivisionAssignment | Gets the OperatorDivisionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExclusiveOr | Gets the OperatorExclusiveOr token ID.
OperatorExclusiveOrAssignment | Gets the OperatorExclusiveOrAssignment token ID.
OperatorFloorDivision | Gets the OperatorFloorDivision token ID.
OperatorFloorDivisionAssignment | Gets the OperatorFloorDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorModulus | Gets the OperatorModulus token ID.
OperatorModulusAssignment | Gets the OperatorModulusAssignment token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorOnesComplement | Gets the OperatorOnesComplement token ID.
OperatorPower | Gets the OperatorPower token ID.
OperatorPowerAssignment | Gets the OperatorPowerAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
ReverseQuote | Gets the ReverseQuote token ID.
RightArrow | Gets the RightArrow token ID.
SemiColon | Gets the SemiColon token ID.
SystemIdentifier | Gets the SystemIdentifier token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CloseCurlyBrace Field

PythonTokenIdCloseCurlyBrace Field
Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 14008
Public Const CloseCurlyBrace As Integer = 14008

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CloseParenthesis Field

PythonTokenIdCloseParenthesis Field
Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 14004
Public Const CloseParenthesis As Integer = 14004

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CloseSquareBrace Field

PythonTokenIdCloseSquareBrace Field
Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 14006
Public Const CloseSquareBrace As Integer = 14006

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Colon Field

PythonTokenIdColon Field
Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Colon = 14010
Public Const Colon As Integer = 14010

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Comma Field

PythonTokenIdComma Field
Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Comma = 14009
Public Const Comma As Integer = 14009

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.CommentSingleLine Field

PythonTokenIdCommentSingleLine Field
Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 14016
Public Const CommentSingleLine As Integer = 14016

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.DecoratorDelimiter Field

PythonTokenIdDecoratorDelimiter Field
Gets the DecoratorDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DecoratorDelimiter = 14013
Public Const DecoratorDelimiter As Integer = 14013

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Dedent Field

PythonTokenIdDedent Field
Gets the Dedent token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Dedent = 14098
Public Const Dedent As Integer = 14098

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Dot Field

PythonTokenIdDot Field
Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Dot = 14011
Public Const Dot As Integer = 14011

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Identifier Field

PythonTokenIdIdentifier Field
Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Identifier = 14060
Public Const Identifier As Integer = 14060

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Indent Field

PythonTokenIdIndent Field
Gets the Indent token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Indent = 14097
Public Const Indent As Integer = 14097

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordAnd Field

PythonTokenIdKeywordAnd Field
Gets the KeywordAnd token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAnd = 14062
Public Const KeywordAnd As Integer = 14062

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordAs Field

PythonTokenIdKeywordAs Field
Gets the KeywordAs token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAs = 14063
Public Const KeywordAs As Integer = 14063

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordAssert Field

PythonTokenIdKeywordAssert Field
Gets the KeywordAssert token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAssert = 14064
Public Const KeywordAssert As Integer = 14064

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordBreak Field

PythonTokenIdKeywordBreak Field
Gets the KeywordBreak token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordBreak = 14065
Public Const KeywordBreak As Integer = 14065

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordClass Field

PythonTokenIdKeywordClass Field
Gets the KeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordClass = 14066
Public Const KeywordClass As Integer = 14066

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordContinue Field

PythonTokenIdKeywordContinue Field
Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 14067
Public Const KeywordContinue As Integer = 14067

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordDef Field

PythonTokenIdKeywordDef Field
Gets the KeywordDef token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDef = 14068
Public Const KeywordDef As Integer = 14068

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordDel Field

PythonTokenIdKeywordDel Field
Gets the KeywordDel token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDel = 14069
Public Const KeywordDel As Integer = 14069

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordElIf Field

PythonTokenIdKeywordElIf Field
Gets the KeywordElIf token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordElIf = 14070
Public Const KeywordElIf As Integer = 14070

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordElse Field

PythonTokenIdKeywordElse Field
Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordElse = 14071
Public Const KeywordElse As Integer = 14071

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordExcept Field

PythonTokenIdKeywordExcept Field
Gets the KeywordExcept token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordExcept = 14072
Public Const KeywordExcept As Integer = 14072

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordExec Field

PythonTokenIdKeywordExec Field
Gets the KeywordExec token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordExec = 14073
Public Const KeywordExec As Integer = 14073

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFalse Field

PythonTokenIdKeywordFalse Field
Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 14074
Public Const KeywordFalse As Integer = 14074

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFinally Field

PythonTokenIdKeywordFinally Field
Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 14075
Public Const KeywordFinally As Integer = 14075

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFor Field

PythonTokenIdKeywordFor Field
Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFor = 14076
Public Const KeywordFor As Integer = 14076

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordFrom Field

PythonTokenIdKeywordFrom Field
Gets the KeywordFrom token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFrom = 14077
Public Const KeywordFrom As Integer = 14077

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordGlobal Field

PythonTokenIdKeywordGlobal Field
Gets the KeywordGlobal token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGlobal = 14078
Public Const KeywordGlobal As Integer = 14078

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordIf Field

PythonTokenIdKeywordIf Field
Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIf = 14079
Public Const KeywordIf As Integer = 14079

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordImport Field

PythonTokenIdKeywordImport Field
Gets the KeywordImport token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordImport = 14080
Public Const KeywordImport As Integer = 14080

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordIn Field

PythonTokenIdKeywordIn Field
Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIn = 14081
Public Const KeywordIn As Integer = 14081

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordIs Field

PythonTokenIdKeywordIs Field
Gets the KeywordIs token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIs = 14082
Public Const KeywordIs As Integer = 14082

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordLambda Field

PythonTokenIdKeywordLambda Field
Gets the KeywordLambda token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLambda = 14083
Public Const KeywordLambda As Integer = 14083

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordNone Field

PythonTokenIdKeywordNone Field
Gets the KeywordNone token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNone = 14085
Public Const KeywordNone As Integer = 14085

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordNonLocal Field

PythonTokenIdKeywordNonLocal Field
Gets the KeywordNonLocal token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNonLocal = 14084
Public Const KeywordNonLocal As Integer = 14084

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordNot Field

PythonTokenIdKeywordNot Field
Gets the KeywordNot token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNot = 14086
Public Const KeywordNot As Integer = 14086

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordOr Field

PythonTokenIdKeywordOr Field
Gets the KeywordOr token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOr = 14087
Public Const KeywordOr As Integer = 14087

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordPass Field

PythonTokenIdKeywordPass Field
Gets the KeywordPass token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPass = 14088
Public Const KeywordPass As Integer = 14088

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordPrint Field

PythonTokenIdKeywordPrint Field
Gets the KeywordPrint token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPrint = 14089
Public Const KeywordPrint As Integer = 14089

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordRaise Field

PythonTokenIdKeywordRaise Field
Gets the KeywordRaise token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordRaise = 14090
Public Const KeywordRaise As Integer = 14090

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordReturn Field

PythonTokenIdKeywordReturn Field
Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 14091
Public Const KeywordReturn As Integer = 14091

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordTrue Field

PythonTokenIdKeywordTrue Field
Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 14092
Public Const KeywordTrue As Integer = 14092

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordTry Field

PythonTokenIdKeywordTry Field
Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTry = 14093
Public Const KeywordTry As Integer = 14093

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordWhile Field

PythonTokenIdKeywordWhile Field
Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 14094
Public Const KeywordWhile As Integer = 14094

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordWith Field

PythonTokenIdKeywordWith Field
Gets the KeywordWith token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWith = 14095
Public Const KeywordWith As Integer = 14095

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.KeywordYield Field

PythonTokenIdKeywordYield Field
Gets the KeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordYield = 14096
Public Const KeywordYield As Integer = 14096

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LineContinuation Field

PythonTokenIdLineContinuation Field
Gets the LineContinuation token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineContinuation = 14002
Public Const LineContinuation As Integer = 14002

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LineTerminator Field

PythonTokenIdLineTerminator Field
Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineTerminator = 14001
Public Const LineTerminator As Integer = 14001

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralBinaryInteger Field

PythonTokenIdLiteralBinaryInteger Field
Gets the LiteralBinaryInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralBinaryInteger = 14050
Public Const LiteralBinaryInteger As Integer = 14050

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralBytes Field

PythonTokenIdLiteralBytes Field
Gets the LiteralBytes token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralBytes = 14049
Public Const LiteralBytes As Integer = 14049

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralDecimalInteger Field

PythonTokenIdLiteralDecimalInteger Field
Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 14051
Public Const LiteralDecimalInteger As Integer = 14051

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralDoubleQuoteLongString Field

PythonTokenIdLiteralDoubleQuoteLongString Field
Gets the LiteralDoubleQuoteLongString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDoubleQuoteLongString = 14053
Public Const LiteralDoubleQuoteLongString As Integer = 14053

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralDoubleQuoteString Field

PythonTokenIdLiteralDoubleQuoteString Field
Gets the LiteralDoubleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDoubleQuoteString = 14052
Public Const LiteralDoubleQuoteString As Integer = 14052

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralHexadecimalInteger Field

PythonTokenIdLiteralHexadecimalInteger Field
Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 14054
Public Const LiteralHexadecimalInteger As Integer = 14054

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralImaginary Field

PythonTokenIdLiteralImaginary Field
Gets the LiteralImaginary token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralImaginary = 14055
Public Const LiteralImaginary As Integer = 14055

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralOctalInteger Field

PythonTokenIdLiteralOctalInteger Field
Gets the LiteralOctalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralOctalInteger = 14056
Public Const LiteralOctalInteger As Integer = 14056

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralReal Field

PythonTokenIdLiteralReal Field
Gets the LiteralReal token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralReal = 14057
Public Const LiteralReal As Integer = 14057

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralSingleQuoteLongString Field

PythonTokenIdLiteralSingleQuoteLongString Field
Gets the LiteralSingleQuoteLongString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralSingleQuoteLongString = 14059
Public Const LiteralSingleQuoteLongString As Integer = 14059

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.LiteralSingleQuoteString Field

PythonTokenIdLiteralSingleQuoteString Field
Gets the LiteralSingleQuoteString token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralSingleQuoteString = 14058
Public Const LiteralSingleQuoteString As Integer = 14058

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OpenCurlyBrace Field

PythonTokenIdOpenCurlyBrace Field
Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 14007
Public Const OpenCurlyBrace As Integer = 14007

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OpenParenthesis Field

PythonTokenIdOpenParenthesis Field
Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 14003
Public Const OpenParenthesis As Integer = 14003

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OpenSquareBrace Field

PythonTokenIdOpenSquareBrace Field
Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 14005
Public Const OpenSquareBrace As Integer = 14005

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorAddition Field

PythonTokenIdOperatorAddition Field
Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 14017
Public Const OperatorAddition As Integer = 14017

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorAdditionAssignment Field

PythonTokenIdOperatorAdditionAssignment Field
Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 14037
Public Const OperatorAdditionAssignment As Integer = 14037

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorAssignment Field

PythonTokenIdOperatorAssignment Field
Gets the OperatorAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAssignment = 14036
Public Const OperatorAssignment As Integer = 14036

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseAnd Field

PythonTokenIdOperatorBitwiseAnd Field
Gets the OperatorBitwiseAnd token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAnd = 14026
Public Const OperatorBitwiseAnd As Integer = 14026

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseAndAssignment Field

PythonTokenIdOperatorBitwiseAndAssignment Field
Gets the OperatorBitwiseAndAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseAndAssignment = 14044
Public Const OperatorBitwiseAndAssignment As Integer = 14044

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseOr Field

PythonTokenIdOperatorBitwiseOr Field
Gets the OperatorBitwiseOr token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOr = 14027
Public Const OperatorBitwiseOr As Integer = 14027

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorBitwiseOrAssignment Field

PythonTokenIdOperatorBitwiseOrAssignment Field
Gets the OperatorBitwiseOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorBitwiseOrAssignment = 14045
Public Const OperatorBitwiseOrAssignment As Integer = 14045

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorDivision Field

PythonTokenIdOperatorDivision Field
Gets the OperatorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDivision = 14021
Public Const OperatorDivision As Integer = 14021

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorDivisionAssignment Field

PythonTokenIdOperatorDivisionAssignment Field
Gets the OperatorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorDivisionAssignment = 14041
Public Const OperatorDivisionAssignment As Integer = 14041

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorEquality Field

PythonTokenIdOperatorEquality Field
Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 14034
Public Const OperatorEquality As Integer = 14034

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorExclusiveOr Field

PythonTokenIdOperatorExclusiveOr Field
Gets the OperatorExclusiveOr token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOr = 14028
Public Const OperatorExclusiveOr As Integer = 14028

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorExclusiveOrAssignment Field

PythonTokenIdOperatorExclusiveOrAssignment Field
Gets the OperatorExclusiveOrAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExclusiveOrAssignment = 14046
Public Const OperatorExclusiveOrAssignment As Integer = 14046

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorFloorDivision Field

PythonTokenIdOperatorFloorDivision Field
Gets the OperatorFloorDivision token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorFloorDivision = 14022
Public Const OperatorFloorDivision As Integer = 14022

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorFloorDivisionAssignment Field

PythonTokenIdOperatorFloorDivisionAssignment Field
Gets the OperatorFloorDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorFloorDivisionAssignment = 14042
Public Const OperatorFloorDivisionAssignment As Integer = 14042

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorGreaterThan Field

PythonTokenIdOperatorGreaterThan Field
Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 14031
Public Const OperatorGreaterThan As Integer = 14031

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorGreaterThanOrEqual Field

PythonTokenIdOperatorGreaterThanOrEqual Field
Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 14033
Public Const OperatorGreaterThanOrEqual As Integer = 14033

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorInequality Field

PythonTokenIdOperatorInequality Field
Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 14035
Public Const OperatorInequality As Integer = 14035

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLeftShift Field

PythonTokenIdOperatorLeftShift Field
Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 14024
Public Const OperatorLeftShift As Integer = 14024

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLeftShiftAssignment Field

PythonTokenIdOperatorLeftShiftAssignment Field
Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 14047
Public Const OperatorLeftShiftAssignment As Integer = 14047

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLessThan Field

PythonTokenIdOperatorLessThan Field
Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 14030
Public Const OperatorLessThan As Integer = 14030

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorLessThanOrEqual Field

PythonTokenIdOperatorLessThanOrEqual Field
Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 14032
Public Const OperatorLessThanOrEqual As Integer = 14032

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorModulus Field

PythonTokenIdOperatorModulus Field
Gets the OperatorModulus token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorModulus = 14023
Public Const OperatorModulus As Integer = 14023

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorModulusAssignment Field

PythonTokenIdOperatorModulusAssignment Field
Gets the OperatorModulusAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorModulusAssignment = 14043
Public Const OperatorModulusAssignment As Integer = 14043

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorMultiplication Field

PythonTokenIdOperatorMultiplication Field
Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 14019
Public Const OperatorMultiplication As Integer = 14019

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorMultiplicationAssignment Field

PythonTokenIdOperatorMultiplicationAssignment Field
Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 14039
Public Const OperatorMultiplicationAssignment As Integer = 14039

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorOnesComplement Field

PythonTokenIdOperatorOnesComplement Field
Gets the OperatorOnesComplement token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorOnesComplement = 14029
Public Const OperatorOnesComplement As Integer = 14029

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorPower Field

PythonTokenIdOperatorPower Field
Gets the OperatorPower token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorPower = 14020
Public Const OperatorPower As Integer = 14020

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorPowerAssignment Field

PythonTokenIdOperatorPowerAssignment Field
Gets the OperatorPowerAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorPowerAssignment = 14040
Public Const OperatorPowerAssignment As Integer = 14040

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorRightShift Field

PythonTokenIdOperatorRightShift Field
Gets the OperatorRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorRightShift = 14025
Public Const OperatorRightShift As Integer = 14025

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorRightShiftAssignment Field

PythonTokenIdOperatorRightShiftAssignment Field
Gets the OperatorRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorRightShiftAssignment = 14048
Public Const OperatorRightShiftAssignment As Integer = 14048

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorSubtraction Field

PythonTokenIdOperatorSubtraction Field
Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 14018
Public Const OperatorSubtraction As Integer = 14018

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.OperatorSubtractionAssignment Field

PythonTokenIdOperatorSubtractionAssignment Field
Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 14038
Public Const OperatorSubtractionAssignment As Integer = 14038

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.ReverseQuote Field

PythonTokenIdReverseQuote Field
Gets the ReverseQuote token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ReverseQuote = 14014
Public Const ReverseQuote As Integer = 14014

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.RightArrow Field

PythonTokenIdRightArrow Field
Gets the RightArrow token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int RightArrow = 14015
Public Const RightArrow As Integer = 14015

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.SemiColon Field

PythonTokenIdSemiColon Field
Gets the SemiColon token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SemiColon = 14012
Public Const SemiColon As Integer = 14012

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.SystemIdentifier Field

PythonTokenIdSystemIdentifier Field
Gets the SystemIdentifier token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int SystemIdentifier = 14061
Public Const SystemIdentifier As Integer = 14061

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenId.Whitespace Field

PythonTokenIdWhitespace Field
Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Whitespace = 14000
Public Const Whitespace As Integer = 14000

Field Value

Type: Int32
See Also

Reference

PythonTokenId Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Class

PythonTokenReader Class
Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenReader

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonTokenReader : MergableTokenReader
Public Class PythonTokenReader
    Inherits MergableTokenReader

The PythonTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenReader | Initializes a new instance of the PythonTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | TabSize | Gets or sets the tab size, used when watching for indent and dedent tokens.
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides MergableTokenReaderPop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides MergableTokenReaderPush.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Constructor

PythonTokenReader Constructor
Initializes a new instance of the PythonTokenReader class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Properties

PythonTokenReader Properties

The PythonTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | TabSize | Gets or sets the tab size, used when watching for indent and dedent tokens.
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.TabSize Property

PythonTokenReaderTabSize Property
Gets or sets the tab size, used when watching for indent and dedent tokens.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TabSize { get; set; }
Public Property TabSize As Integer
    Get
    Set

Property Value

Type: Int32
The tab size, used when watching for indent and dedent tokens.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader Methods

PythonTokenReader Methods

The PythonTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides MergableTokenReaderPop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides MergableTokenReaderPush.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.GetNextToken Method

PythonTokenReaderGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.Pop Method

PythonTokenReaderPop Method
Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Pop()
Public Overrides Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITokenReaderPop
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenReader.Push Method

PythonTokenReaderPush Method
Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Push()
Public Overrides Sub Push

Implements

ITokenReaderPush
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

PythonTokenReader Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Class

PythonTokenTagger Class
Represents an ITaggerT for the Python language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTagger

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonTokenTagger : TokenTagger
Public Class PythonTokenTagger
    Inherits TokenTagger

The PythonTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenTagger | Initializes a new instance of the PythonTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Constructor

PythonTokenTagger Constructor
Initializes a new instance of the PythonTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonTokenTagger(
    ICodeDocument document,
    IPythonClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IPythonClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.PythonIPythonClassificationTypeProvider
A IPythonClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Properties

PythonTokenTagger Properties

The PythonTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Methods

PythonTokenTagger Methods

The PythonTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger.ClassifyToken Method

PythonTokenTaggerClassifyToken Method
Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTagger Events

PythonTokenTagger Events

The PythonTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

PythonTokenTagger Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Class

PythonTokenTaggerProvider Class
Represents a provider of PythonTokenTagger objects for documents that use the PythonTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase PythonTokenTagger
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PythonTokenTaggerProvider : TaggerProviderBase<PythonTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class PythonTokenTaggerProvider
    Inherits TaggerProviderBase(Of PythonTokenTagger)
    Implements ICodeDocumentTaggerProvider

The PythonTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | PythonTokenTaggerProvider | Initializes a new instance of the PythonTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Constructor

PythonTokenTaggerProvider Constructor
Initializes a new instance of the PythonTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonTokenTaggerProvider(
    IPythonClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IPythonClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.PythonIPythonClassificationTypeProvider
A IPythonClassificationTypeProvider that provides classification types.
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Properties

PythonTokenTaggerProvider Properties

The PythonTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider Methods

PythonTokenTaggerProvider Methods

The PythonTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider.GetTagger(T) Method

PythonTokenTaggerProviderGetTaggerT Method
Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

PythonTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider.TaggerFactory Class

PythonTokenTaggerProviderTaggerFactory Class
Implements a factory that can creates PythonTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The PythonTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an PythonTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Implementation Namespace


TaggerFactory Methods

TaggerFactory Methods

The PythonTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an PythonTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PythonTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


PythonTokenTaggerProvider.TaggerFactory.CreateTagger Method

PythonTokenTaggerProviderTaggerFactoryCreateTagger Method
Creates an PythonTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Python.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonTokenTagger CreateTagger()
Public Function CreateTagger As PythonTokenTagger

Return Value

Type: PythonTokenTagger
An PythonTokenTagger for the ICodeDocument.
See Also

Reference

PythonTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Python.Implementation Namespace


ActiproSoftware.Text.Languages.Python.Reflection Namespace

ActiproSoftware.Text.Languages.Python.Reflection Namespace
Contains the types related to reflection for a Python syntax language.
Classes
 | Class | Description
Public class | AmbientPackageRepositoryProvider | Implements a class that can be used to provide a static IPackageRepository that is used for managing and caching packages by default.
Interfaces
 | Interface | Description
Public interface | IActiveModuleCollection | Provides the base requirements for a collection of active IModuleDefinition objects.
Public interface | IAliasedText | Provides the base requirements of possibly-aliased text.
Public interface | IAliasedTextCollection | Provides the base requirements for a collection of IAliasedText objects.
Public interface | IFieldDefinition | Provides the base requirements of a field definition.
Public interface | IFieldDefinitionCollection | Provides the base requirements for a collection of IFieldDefinition objects.
Public interface | IFunctionDefinition | Provides the base requirements of a function definition.
Public interface | IFunctionDefinitionCollection | Provides the base requirements for a collection of IFunctionDefinition objects.
Public interface | IImportDefinition | Provides the base requirements of an import definition.
Public interface | IImportDefinitionCollection | Provides the base requirements for a collection of IImportDefinition objects.
Public interface | IModuleDefinition | Provides the base requirements of a module definition.
Public interface | IModuleDefinitionCollection | Provides the base requirements for a collection of IModuleDefinition objects.
Public interface | IModuleReference | Provides the base requirements of a module.
Public interface | IPackageDefinition | Provides the base requirements of a package definition.
Public interface | IPackageReference | Provides the base requirements of a package.
Public interface | IPackageReferenceCollection | Provides the base requirements for a collection of IPackageReference objects.
Public interface | IPackageRepository | Provides the base requirements for a class that manages package instances and caching of data as appropriate.
Public interface | IParameterDefinition | Provides the base requirements of a parameter definition.
Public interface | IParameterDefinitionCollection | Provides the base requirements for a collection of IParameterDefinition objects.
Public interface | IProject | Represents a Python project.
Public interface | IReflectionDefinition | Provides the base requirements of a reflection definition.
Public interface | ITypeDefinition | Provides the base requirements of a type definition.
Public interface | ITypeDefinitionCollection | Provides the base requirements for a collection of ITypeDefinition objects.
Public interface | ITypeReference | Provides the base requirements of a type reference.
Public interface | ITypeReferenceCollection | Provides the base requirements for a collection of ITypeReference objects.
Public interface | IVariableDefinition | Provides the base requirements of a variable definition.
Public interface | IVariableDefinitionCollection | Provides the base requirements for a collection of IVariableDefinition objects.


AmbientPackageRepositoryProvider Class

AmbientPackageRepositoryProvider Class
Implements a class that can be used to provide a static IPackageRepository that is used for managing and caching packages by default.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.ReflectionAmbientPackageRepositoryProvider

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class AmbientPackageRepositoryProvider
Public NotInheritable Class AmbientPackageRepositoryProvider

The AmbientPackageRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IPackageRepository to use.
Top
Remarks
Set the Repository property to an IPackageRepository instance to register the default package respository.
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


AmbientPackageRepositoryProvider Properties

AmbientPackageRepositoryProvider Properties

The AmbientPackageRepositoryProvider type exposes the following members.

Properties
Name | Description
Repository | Gets or sets the default IPackageRepository to use.
Top
See Also

Reference

AmbientPackageRepositoryProvider Class
ActiproSoftware.Text.Languages.Python.Reflection Namespace


AmbientPackageRepositoryProvider.Repository Property

AmbientPackageRepositoryProviderRepository Property
Gets or sets the default IPackageRepository to use.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IPackageRepository Repository { get; set; }
Public Shared Property Repository As IPackageRepository
    Get
    Set

Property Value

Type: IPackageRepository
The default IPackageRepository to use.
See Also

Reference

AmbientPackageRepositoryProvider Class
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Interface

IActiveModuleCollection Interface
Provides the base requirements for a collection of active IModuleDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IActiveModuleCollection : IKeyedObservableCollection<IModuleDefinition>,
    IObservableCollection<IModuleDefinition>, IList<IModuleDefinition>, ICollection<IModuleDefinition>,
    IEnumerable<IModuleDefinition>, IEnumerable
Public Interface IActiveModuleCollection
    Inherits IKeyedObservableCollection(Of IModuleDefinition), IObservableCollection(Of IModuleDefinition),
    IList(Of IModuleDefinition), ICollection(Of IModuleDefinition), IEnumerable(Of IModuleDefinition),
    IEnumerable

The IActiveModuleCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add(T) | (Inherited from ICollection IModuleDefinition .)
Public method | Add(String, CompilationUnit) | Adds an IModuleDefinition for the specified CompilationUnit to the collection.
Public method | Clear | (Inherited from ICollection IModuleDefinition .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList IModuleDefinition .)
Public method | Insert | (Inherited from IList IModuleDefinition .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | (Inherited from IList IModuleDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Properties

IActiveModuleCollection Properties

The IActiveModuleCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Methods

IActiveModuleCollection Methods

The IActiveModuleCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | (Inherited from ICollection IModuleDefinition .)
Public method | Add(String, CompilationUnit) | Adds an IModuleDefinition for the specified CompilationUnit to the collection.
Public method | Clear | (Inherited from ICollection IModuleDefinition .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList IModuleDefinition .)
Public method | Insert | (Inherited from IList IModuleDefinition .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | (Inherited from IList IModuleDefinition .)
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection.Add Method

IActiveModuleCollectionAdd Method
Overload List
 | Name | Description
Public method | Add(T) | (Inherited from ICollection IModuleDefinition .)
Public method | Add(String, CompilationUnit) | Adds an IModuleDefinition for the specified CompilationUnit to the collection.
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection.Add Method (String, CompilationUnit)

IActiveModuleCollectionAdd Method (String, CompilationUnit)
Adds an IModuleDefinition for the specified CompilationUnit to the collection.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleDefinition Add(
    string sourceFileKey,
    CompilationUnit compilationUnit
)
Function Add (
    sourceFileKey As String,
    compilationUnit As CompilationUnit
) As IModuleDefinition

Parameters

sourceFileKey
Type: SystemString
The unique key that identifies the source file, which is generally a full file path or GUID.
compilationUnit
Type: ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit
The CompilationUnit to examine.

Return Value

Type: IModuleDefinition
The IModuleDefinition that was added.
See Also

Reference

IActiveModuleCollection Interface
Add Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IActiveModuleCollection Events

IActiveModuleCollection Events

The IActiveModuleCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IActiveModuleCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText Interface

IAliasedText Interface
Provides the base requirements of possibly-aliased text.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAliasedText
Public Interface IAliasedText

The IAliasedText type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias.
Public property | Text | Gets the text.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText Properties

IAliasedText Properties

The IAliasedText type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets the alias.
Public property | Text | Gets the text.
Top
See Also

Reference

IAliasedText Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText.Alias Property

IAliasedTextAlias Property
Gets the alias.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Alias { get; }
ReadOnly Property Alias As String
    Get

Property Value

Type: String
The alias.
See Also

Reference

IAliasedText Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedText.Text Property

IAliasedTextText Property
Gets the text.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text.
See Also

Reference

IAliasedText Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Interface

IAliasedTextCollection Interface
Provides the base requirements for a collection of IAliasedText objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAliasedTextCollection : IObservableCollection<IAliasedText>,
    IList<IAliasedText>, ICollection<IAliasedText>, IEnumerable<IAliasedText>,
    IEnumerable
Public Interface IAliasedTextCollection
    Inherits IObservableCollection(Of IAliasedText), IList(Of IAliasedText),
    ICollection(Of IAliasedText), IEnumerable(Of IAliasedText), IEnumerable

The IAliasedTextCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IAliasedText .)
Public property | IsReadOnly | (Inherited from ICollection IAliasedText .)
Public property | Item | (Inherited from IList IAliasedText .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IAliasedText .)
Public method | Clear | (Inherited from ICollection IAliasedText .)
Public method | Contains | (Inherited from ICollection IAliasedText .)
Public method | CopyTo | (Inherited from ICollection IAliasedText .)
Public method | GetEnumerator | (Inherited from IEnumerable IAliasedText .)
Public method | IndexOf | (Inherited from IList IAliasedText .)
Public method | Insert | (Inherited from IList IAliasedText .)
Public method | Remove | (Inherited from ICollection IAliasedText .)
Public method | RemoveAt | (Inherited from IList IAliasedText .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Properties

IAliasedTextCollection Properties

The IAliasedTextCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IAliasedText .)
Public property | IsReadOnly | (Inherited from ICollection IAliasedText .)
Public property | Item | (Inherited from IList IAliasedText .)
Top
See Also

Reference

IAliasedTextCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Methods

IAliasedTextCollection Methods

The IAliasedTextCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IAliasedText .)
Public method | Clear | (Inherited from ICollection IAliasedText .)
Public method | Contains | (Inherited from ICollection IAliasedText .)
Public method | CopyTo | (Inherited from ICollection IAliasedText .)
Public method | GetEnumerator | (Inherited from IEnumerable IAliasedText .)
Public method | IndexOf | (Inherited from IList IAliasedText .)
Public method | Insert | (Inherited from IList IAliasedText .)
Public method | Remove | (Inherited from ICollection IAliasedText .)
Public method | RemoveAt | (Inherited from IList IAliasedText .)
Top
See Also

Reference

IAliasedTextCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IAliasedTextCollection Events

IAliasedTextCollection Events

The IAliasedTextCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IAliasedTextCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition Interface

IFieldDefinition Interface
Provides the base requirements of a field definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IFieldDefinition : IReflectionDefinition
Public Interface IFieldDefinition
    Inherits IReflectionDefinition

The IFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the field is declared.
Public property | DeclaringType | Gets the declaring type.
Public property | Docstring | Gets the docstring for the field.
Public property | IsPublic | Gets whether the field is public.
Public property | IsStatic | Gets whether the field is static.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the field type, if known.
Public property | TypeExpressionTextRange | Gets the field type expression TextRange.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition Properties

IFieldDefinition Properties

The IFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the field is declared.
Public property | DeclaringType | Gets the declaring type.
Public property | Docstring | Gets the docstring for the field.
Public property | IsPublic | Gets whether the field is public.
Public property | IsStatic | Gets whether the field is static.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the field type, if known.
Public property | TypeExpressionTextRange | Gets the field type expression TextRange.
Top
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.DeclaringModule Property

IFieldDefinitionDeclaringModule Property
Gets the reference to the module in which the field is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the field is declared.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.DeclaringType Property

IFieldDefinitionDeclaringType Property
Gets the declaring type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The declaring type.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.Docstring Property

IFieldDefinitionDocstring Property
Gets the docstring for the field.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Docstring { get; }
ReadOnly Property Docstring As String
    Get

Property Value

Type: String
The docstring for the field.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.IsPublic Property

IFieldDefinitionIsPublic Property
Gets whether the field is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the field is public; otherwise, false.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.IsStatic Property

IFieldDefinitionIsStatic Property
Gets whether the field is static.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get

Property Value

Type: Boolean
true if the field is static; otherwise, false.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.Type Property

IFieldDefinitionType Property
Gets a ITypeDefinition indicating the field type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the field type, if known.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinition.TypeExpressionTextRange Property

IFieldDefinitionTypeExpressionTextRange Property
Gets the field type expression TextRange.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TypeExpressionTextRange { get; }
ReadOnly Property TypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The field type expression TextRange.
See Also

Reference

IFieldDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Interface

IFieldDefinitionCollection Interface
Provides the base requirements for a collection of IFieldDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IFieldDefinitionCollection : IObservableCollection<IFieldDefinition>,
    IList<IFieldDefinition>, ICollection<IFieldDefinition>, IEnumerable<IFieldDefinition>,
    IEnumerable
Public Interface IFieldDefinitionCollection
    Inherits IObservableCollection(Of IFieldDefinition), IList(Of IFieldDefinition),
    ICollection(Of IFieldDefinition), IEnumerable(Of IFieldDefinition), IEnumerable

The IFieldDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IFieldDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IFieldDefinition .)
Public property | ItemInt32 | (Inherited from IList IFieldDefinition .)
Public property | ItemString | Gets the IFieldDefinition with the specified name. [C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IFieldDefinition .)
Public method | Clear | (Inherited from ICollection IFieldDefinition .)
Public method | Contains | (Inherited from ICollection IFieldDefinition .)
Public method | CopyTo | (Inherited from ICollection IFieldDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IFieldDefinition .)
Public method | IndexOf | (Inherited from IList IFieldDefinition .)
Public method | Insert | (Inherited from IList IFieldDefinition .)
Public method | Remove | (Inherited from ICollection IFieldDefinition .)
Public method | RemoveAt | (Inherited from IList IFieldDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Properties

IFieldDefinitionCollection Properties

The IFieldDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IFieldDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IFieldDefinition .)
Public property | ItemInt32 | (Inherited from IList IFieldDefinition .)
Public property | ItemString | Gets the IFieldDefinition with the specified name. [C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection.Item Property

IFieldDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IFieldDefinition .)
Public property | ItemString | Gets the IFieldDefinition with the specified name. [C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection.Item Property (String)

IFieldDefinitionCollectionItem Property (String)
Gets the IFieldDefinition with the specified name.

[C#] In C#, this property is the indexer for the IFieldDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFieldDefinition this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As IFieldDefinition
    Get

Parameters

name
Type: SystemString
The name of the IFieldDefinition to return.

Property Value

Type: IFieldDefinition
The IFieldDefinition with the specified name.
See Also

Reference

IFieldDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Methods

IFieldDefinitionCollection Methods

The IFieldDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IFieldDefinition .)
Public method | Clear | (Inherited from ICollection IFieldDefinition .)
Public method | Contains | (Inherited from ICollection IFieldDefinition .)
Public method | CopyTo | (Inherited from ICollection IFieldDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IFieldDefinition .)
Public method | IndexOf | (Inherited from IList IFieldDefinition .)
Public method | Insert | (Inherited from IList IFieldDefinition .)
Public method | Remove | (Inherited from ICollection IFieldDefinition .)
Public method | RemoveAt | (Inherited from IList IFieldDefinition .)
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFieldDefinitionCollection Events

IFieldDefinitionCollection Events

The IFieldDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IFieldDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition Interface

IFunctionDefinition Interface
Provides the base requirements of a function definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IFunctionDefinition : IReflectionDefinition
Public Interface IFunctionDefinition
    Inherits IReflectionDefinition

The IFunctionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the function is declared.
Public property | DeclaringType | Gets the declaring type, if the function is a method.
Public property | Docstring | Gets the docstring for the type.
Public property | IsClassMethod | Gets whether the function is a class method.
Public property | IsMethod | Gets whether the function is a method.
Public property | IsPublic | Gets whether the function is public.
Public property | IsStaticMethod | Gets whether the function is a static method.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current function.
Public property | ReturnType | Gets a ITypeDefinition indicating the return type, if known.
Public property | ReturnTypeExpressionTextRange | Gets the return type expression TextRange, if known.
Public property | TextRange | Gets the TextRange of the function definition, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition Properties

IFunctionDefinition Properties

The IFunctionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the function is declared.
Public property | DeclaringType | Gets the declaring type, if the function is a method.
Public property | Docstring | Gets the docstring for the type.
Public property | IsClassMethod | Gets whether the function is a class method.
Public property | IsMethod | Gets whether the function is a method.
Public property | IsPublic | Gets whether the function is public.
Public property | IsStaticMethod | Gets whether the function is a static method.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Parameters | Gets the collection of parameters to the current function.
Public property | ReturnType | Gets a ITypeDefinition indicating the return type, if known.
Public property | ReturnTypeExpressionTextRange | Gets the return type expression TextRange, if known.
Public property | TextRange | Gets the TextRange of the function definition, if known.
Top
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.DeclaringModule Property

IFunctionDefinitionDeclaringModule Property
Gets the reference to the module in which the function is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the function is declared.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.DeclaringType Property

IFunctionDefinitionDeclaringType Property
Gets the declaring type, if the function is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition DeclaringType { get; }
ReadOnly Property DeclaringType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
The declaring type, if the function is a method.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.Docstring Property

IFunctionDefinitionDocstring Property
Gets the docstring for the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Docstring { get; }
ReadOnly Property Docstring As String
    Get

Property Value

Type: String
The docstring for the type.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsClassMethod Property

IFunctionDefinitionIsClassMethod Property
Gets whether the function is a class method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsClassMethod { get; }
ReadOnly Property IsClassMethod As Boolean
    Get

Property Value

Type: Boolean
true if the function is a class method; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsMethod Property

IFunctionDefinitionIsMethod Property
Gets whether the function is a method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsMethod { get; }
ReadOnly Property IsMethod As Boolean
    Get

Property Value

Type: Boolean
true if the function is a method; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsPublic Property

IFunctionDefinitionIsPublic Property
Gets whether the function is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the function is public; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.IsStaticMethod Property

IFunctionDefinitionIsStaticMethod Property
Gets whether the function is a static method.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsStaticMethod { get; }
ReadOnly Property IsStaticMethod As Boolean
    Get

Property Value

Type: Boolean
true if the function is a static method; otherwise, false.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.Parameters Property

IFunctionDefinitionParameters Property
Gets the collection of parameters to the current function.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParameterDefinitionCollection Parameters { get; }
ReadOnly Property Parameters As IParameterDefinitionCollection
    Get

Property Value

Type: IParameterDefinitionCollection
The collection of parameters to the current function.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.ReturnType Property

IFunctionDefinitionReturnType Property
Gets a ITypeDefinition indicating the return type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition ReturnType { get; }
ReadOnly Property ReturnType As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the return type, if known.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.ReturnTypeExpressionTextRange Property

IFunctionDefinitionReturnTypeExpressionTextRange Property
Gets the return type expression TextRange, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange ReturnTypeExpressionTextRange { get; }
ReadOnly Property ReturnTypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The return type expression TextRange, if known.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinition.TextRange Property

IFunctionDefinitionTextRange Property
Gets the TextRange of the function definition, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
The TextRange of the function definition, if known.
See Also

Reference

IFunctionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Interface

IFunctionDefinitionCollection Interface
Provides the base requirements for a collection of IFunctionDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IFunctionDefinitionCollection : IObservableCollection<IFunctionDefinition>,
    IList<IFunctionDefinition>, ICollection<IFunctionDefinition>, IEnumerable<IFunctionDefinition>,
    IEnumerable
Public Interface IFunctionDefinitionCollection
    Inherits IObservableCollection(Of IFunctionDefinition), IList(Of IFunctionDefinition),
    ICollection(Of IFunctionDefinition), IEnumerable(Of IFunctionDefinition), IEnumerable

The IFunctionDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IFunctionDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IFunctionDefinition .)
Public property | ItemInt32 | (Inherited from IList IFunctionDefinition .)
Public property | ItemString | Gets the IFunctionDefinition with the specified name. [C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IFunctionDefinition .)
Public method | Clear | (Inherited from ICollection IFunctionDefinition .)
Public method | Contains | (Inherited from ICollection IFunctionDefinition .)
Public method | CopyTo | (Inherited from ICollection IFunctionDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IFunctionDefinition .)
Public method | IndexOf | (Inherited from IList IFunctionDefinition .)
Public method | Insert | (Inherited from IList IFunctionDefinition .)
Public method | Remove | (Inherited from ICollection IFunctionDefinition .)
Public method | RemoveAt | (Inherited from IList IFunctionDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Properties

IFunctionDefinitionCollection Properties

The IFunctionDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IFunctionDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IFunctionDefinition .)
Public property | ItemInt32 | (Inherited from IList IFunctionDefinition .)
Public property | ItemString | Gets the IFunctionDefinition with the specified name. [C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection.Item Property

IFunctionDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IFunctionDefinition .)
Public property | ItemString | Gets the IFunctionDefinition with the specified name. [C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection.Item Property (String)

IFunctionDefinitionCollectionItem Property (String)
Gets the IFunctionDefinition with the specified name.

[C#] In C#, this property is the indexer for the IFunctionDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFunctionDefinition this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As IFunctionDefinition
    Get

Parameters

name
Type: SystemString
The name of the IFunctionDefinition to return.

Property Value

Type: IFunctionDefinition
The IFunctionDefinition with the specified name.
See Also

Reference

IFunctionDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Methods

IFunctionDefinitionCollection Methods

The IFunctionDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IFunctionDefinition .)
Public method | Clear | (Inherited from ICollection IFunctionDefinition .)
Public method | Contains | (Inherited from ICollection IFunctionDefinition .)
Public method | CopyTo | (Inherited from ICollection IFunctionDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IFunctionDefinition .)
Public method | IndexOf | (Inherited from IList IFunctionDefinition .)
Public method | Insert | (Inherited from IList IFunctionDefinition .)
Public method | Remove | (Inherited from ICollection IFunctionDefinition .)
Public method | RemoveAt | (Inherited from IList IFunctionDefinition .)
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IFunctionDefinitionCollection Events

IFunctionDefinitionCollection Events

The IFunctionDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IFunctionDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition Interface

IImportDefinition Interface
Provides the base requirements of an import definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IImportDefinition
Public Interface IImportDefinition

The IImportDefinition type exposes the following members.

Properties
 | Name | Description
Public property | MergedNames | Gets the collection of names from the source to import into the current namespace.
Public property | Source | Gets the import source.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition Properties

IImportDefinition Properties

The IImportDefinition type exposes the following members.

Properties
 | Name | Description
Public property | MergedNames | Gets the collection of names from the source to import into the current namespace.
Public property | Source | Gets the import source.
Top
See Also

Reference

IImportDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition.MergedNames Property

IImportDefinitionMergedNames Property
Gets the collection of names from the source to import into the current namespace.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAliasedTextCollection MergedNames { get; }
ReadOnly Property MergedNames As IAliasedTextCollection
    Get

Property Value

Type: IAliasedTextCollection
The collection of names from the source to import into the current namespace.
See Also

Reference

IImportDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinition.Source Property

IImportDefinitionSource Property
Gets the import source.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAliasedText Source { get; }
ReadOnly Property Source As IAliasedText
    Get

Property Value

Type: IAliasedText
The import source.
See Also

Reference

IImportDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Interface

IImportDefinitionCollection Interface
Provides the base requirements for a collection of IImportDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IImportDefinitionCollection : IObservableCollection<IImportDefinition>,
    IList<IImportDefinition>, ICollection<IImportDefinition>, IEnumerable<IImportDefinition>,
    IEnumerable
Public Interface IImportDefinitionCollection
    Inherits IObservableCollection(Of IImportDefinition), IList(Of IImportDefinition),
    ICollection(Of IImportDefinition), IEnumerable(Of IImportDefinition), IEnumerable

The IImportDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IImportDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IImportDefinition .)
Public property | Item | (Inherited from IList IImportDefinition .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IImportDefinition .)
Public method | Clear | (Inherited from ICollection IImportDefinition .)
Public method | Contains | (Inherited from ICollection IImportDefinition .)
Public method | CopyTo | (Inherited from ICollection IImportDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IImportDefinition .)
Public method | IndexOf | (Inherited from IList IImportDefinition .)
Public method | Insert | (Inherited from IList IImportDefinition .)
Public method | Remove | (Inherited from ICollection IImportDefinition .)
Public method | RemoveAt | (Inherited from IList IImportDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Properties

IImportDefinitionCollection Properties

The IImportDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IImportDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IImportDefinition .)
Public property | Item | (Inherited from IList IImportDefinition .)
Top
See Also

Reference

IImportDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Methods

IImportDefinitionCollection Methods

The IImportDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IImportDefinition .)
Public method | Clear | (Inherited from ICollection IImportDefinition .)
Public method | Contains | (Inherited from ICollection IImportDefinition .)
Public method | CopyTo | (Inherited from ICollection IImportDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IImportDefinition .)
Public method | IndexOf | (Inherited from IList IImportDefinition .)
Public method | Insert | (Inherited from IList IImportDefinition .)
Public method | Remove | (Inherited from ICollection IImportDefinition .)
Public method | RemoveAt | (Inherited from IList IImportDefinition .)
Top
See Also

Reference

IImportDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IImportDefinitionCollection Events

IImportDefinitionCollection Events

The IImportDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IImportDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition Interface

IModuleDefinition Interface
Provides the base requirements of a module definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IModuleDefinition : IKeyedObject,
    IModuleReference, IReflectionDefinition
Public Interface IModuleDefinition
    Inherits IKeyedObject, IModuleReference, IReflectionDefinition

The IModuleDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ExternalPublicNameReferences | Gets the optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.
Public property | FileLastModifiedDateTime | Gets or sets the last modified date/time of the module file, if known.
Public property | FileSize | Gets or sets the size of the module file, if known.
Public property | Functions | Gets the collection of functions defined in the module.
Public property | Imports | Gets the collection of imports defined in the module.
Public property | IsBuiltin | Gets whether the module is built-in. (Inherited from IModuleReference.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module. (Inherited from IModuleReference.)
Public property | Path | Gets the full file system path to the module. (Inherited from IModuleReference.)
Public property | PublicNames | Gets the optional collection of names publicly exposed by the module, which generally is specified by an __all__ variable.
Public property | Types | Gets the collection of types defined in the module.
Public property | Variables | Gets the collection of variables defined in the module.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition Properties

IModuleDefinition Properties

The IModuleDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ExternalPublicNameReferences | Gets the optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.
Public property | FileLastModifiedDateTime | Gets or sets the last modified date/time of the module file, if known.
Public property | FileSize | Gets or sets the size of the module file, if known.
Public property | Functions | Gets the collection of functions defined in the module.
Public property | Imports | Gets the collection of imports defined in the module.
Public property | IsBuiltin | Gets whether the module is built-in. (Inherited from IModuleReference.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module. (Inherited from IModuleReference.)
Public property | Path | Gets the full file system path to the module. (Inherited from IModuleReference.)
Public property | PublicNames | Gets the optional collection of names publicly exposed by the module, which generally is specified by an __all__ variable.
Public property | Types | Gets the collection of types defined in the module.
Public property | Variables | Gets the collection of variables defined in the module.
Top
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.ExternalPublicNameReferences Property

IModuleDefinitionExternalPublicNameReferences Property
Gets the optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<string> ExternalPublicNameReferences { get; }
ReadOnly Property ExternalPublicNameReferences As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The optional collection of externally referenced child packages and/or modules whose public names should be combined with the PublicNames.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.FileLastModifiedDateTime Property

IModuleDefinitionFileLastModifiedDateTime Property
Gets or sets the last modified date/time of the module file, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<DateTime> FileLastModifiedDateTime { get; set; }
Property FileLastModifiedDateTime As Nullable(Of DateTime)
    Get
    Set

Property Value

Type: Nullable DateTime
The last modified date/time of the module file, if known.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.FileSize Property

IModuleDefinitionFileSize Property
Gets or sets the size of the module file, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<long> FileSize { get; set; }
Property FileSize As Nullable(Of Long)
    Get
    Set

Property Value

Type: Nullable Int64
The size of the module file, if known.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Functions Property

IModuleDefinitionFunctions Property
Gets the collection of functions defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFunctionDefinitionCollection Functions { get; }
ReadOnly Property Functions As IFunctionDefinitionCollection
    Get

Property Value

Type: IFunctionDefinitionCollection
The collection of functions defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Imports Property

IModuleDefinitionImports Property
Gets the collection of imports defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IImportDefinitionCollection Imports { get; }
ReadOnly Property Imports As IImportDefinitionCollection
    Get

Property Value

Type: IImportDefinitionCollection
The collection of imports defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.PublicNames Property

IModuleDefinitionPublicNames Property
Gets the optional collection of names publicly exposed by the module, which generally is specified by an __all__ variable.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<string> PublicNames { get; }
ReadOnly Property PublicNames As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The optional collection of names publicly exposed by the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Types Property

IModuleDefinitionTypes Property
Gets the collection of types defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection Types { get; }
ReadOnly Property Types As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of types defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinition.Variables Property

IModuleDefinitionVariables Property
Gets the collection of variables defined in the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IVariableDefinitionCollection Variables { get; }
ReadOnly Property Variables As IVariableDefinitionCollection
    Get

Property Value

Type: IVariableDefinitionCollection
The collection of variables defined in the module.
See Also

Reference

IModuleDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Interface

IModuleDefinitionCollection Interface
Provides the base requirements for a collection of IModuleDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IModuleDefinitionCollection : IObservableCollection<IModuleDefinition>,
    IList<IModuleDefinition>, ICollection<IModuleDefinition>, IEnumerable<IModuleDefinition>,
    IEnumerable
Public Interface IModuleDefinitionCollection
    Inherits IObservableCollection(Of IModuleDefinition), IList(Of IModuleDefinition),
    ICollection(Of IModuleDefinition), IEnumerable(Of IModuleDefinition), IEnumerable

The IModuleDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the IModuleDefinition with the specified name. [C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IModuleDefinition .)
Public method | Clear | (Inherited from ICollection IModuleDefinition .)
Public method | Contains | (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf | (Inherited from IList IModuleDefinition .)
Public method | Insert | (Inherited from IList IModuleDefinition .)
Public method | Remove | (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | (Inherited from IList IModuleDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Properties

IModuleDefinitionCollection Properties

The IModuleDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IModuleDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IModuleDefinition .)
Public property | ItemInt32 | (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the IModuleDefinition with the specified name. [C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection.Item Property

IModuleDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IModuleDefinition .)
Public property | ItemString | Gets the IModuleDefinition with the specified name. [C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection.Item Property (String)

IModuleDefinitionCollectionItem Property (String)
Gets the IModuleDefinition with the specified name.

[C#] In C#, this property is the indexer for the IModuleDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleDefinition this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As IModuleDefinition
    Get

Parameters

name
Type: SystemString
The name of the IModuleDefinition to return.

Property Value

Type: IModuleDefinition
The IModuleDefinition with the specified name.
See Also

Reference

IModuleDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Methods

IModuleDefinitionCollection Methods

The IModuleDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IModuleDefinition .)
Public method | Clear | (Inherited from ICollection IModuleDefinition .)
Public method | Contains | (Inherited from ICollection IModuleDefinition .)
Public method | CopyTo | (Inherited from ICollection IModuleDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IModuleDefinition .)
Public method | IndexOf | (Inherited from IList IModuleDefinition .)
Public method | Insert | (Inherited from IList IModuleDefinition .)
Public method | Remove | (Inherited from ICollection IModuleDefinition .)
Public method | RemoveAt | (Inherited from IList IModuleDefinition .)
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleDefinitionCollection Events

IModuleDefinitionCollection Events

The IModuleDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IModuleDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference Interface

IModuleReference Interface
Provides the base requirements of a module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IModuleReference : IReflectionDefinition
Public Interface IModuleReference
    Inherits IReflectionDefinition

The IModuleReference type exposes the following members.

Properties
 | Name | Description
Public property | IsBuiltin | Gets whether the module is built-in.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module.
Public property | Path | Gets the full file system path to the module.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference Properties

IModuleReference Properties

The IModuleReference type exposes the following members.

Properties
 | Name | Description
Public property | IsBuiltin | Gets whether the module is built-in.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | PackagePath | Gets the file system path of the package that contains the module.
Public property | Path | Gets the full file system path to the module.
Top
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference.IsBuiltin Property

IModuleReferenceIsBuiltin Property
Gets whether the module is built-in.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBuiltin { get; }
ReadOnly Property IsBuiltin As Boolean
    Get

Property Value

Type: Boolean
true if the module is built-in; otherwise, false.
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference.PackagePath Property

IModuleReferencePackagePath Property
Gets the file system path of the package that contains the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string PackagePath { get; }
ReadOnly Property PackagePath As String
    Get

Property Value

Type: String
The file system path of the package that contains the module.
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IModuleReference.Path Property

IModuleReferencePath Property
Gets the full file system path to the module.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
The full file system path to the module.
See Also

Reference

IModuleReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition Interface

IPackageDefinition Interface
Provides the base requirements of a package definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPackageDefinition : IKeyedObject,
    IPackageReference, IReflectionDefinition
Public Interface IPackageDefinition
    Inherits IKeyedObject, IPackageReference, IReflectionDefinition

The IPackageDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ChildPackages | Gets the collection of child packages in the package.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Modules | Gets the collection of modules defined in the package.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package. (Inherited from IPackageReference.)
Public property | Version | Gets the PythonVersion used to parse the package.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition Properties

IPackageDefinition Properties

The IPackageDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ChildPackages | Gets the collection of child packages in the package.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Modules | Gets the collection of modules defined in the package.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package. (Inherited from IPackageReference.)
Public property | Version | Gets the PythonVersion used to parse the package.
Top
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition.ChildPackages Property

IPackageDefinitionChildPackages Property
Gets the collection of child packages in the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPackageReferenceCollection ChildPackages { get; }
ReadOnly Property ChildPackages As IPackageReferenceCollection
    Get

Property Value

Type: IPackageReferenceCollection
The collection of child packages in the package.
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition.Modules Property

IPackageDefinitionModules Property
Gets the collection of modules defined in the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleDefinitionCollection Modules { get; }
ReadOnly Property Modules As IModuleDefinitionCollection
    Get

Property Value

Type: IModuleDefinitionCollection
The collection of modules defined in the package.
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageDefinition.Version Property

IPackageDefinitionVersion Property
Gets the PythonVersion used to parse the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion used to parse the package.
See Also

Reference

IPackageDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReference Interface

IPackageReference Interface
Provides the base requirements of a package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPackageReference : IReflectionDefinition
Public Interface IPackageReference
    Inherits IReflectionDefinition

The IPackageReference type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReference Properties

IPackageReference Properties

The IPackageReference type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Path | Gets the full file system path to the package.
Top
See Also

Reference

IPackageReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReference.Path Property

IPackageReferencePath Property
Gets the full file system path to the package.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
The full file system path to the package.
See Also

Reference

IPackageReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Interface

IPackageReferenceCollection Interface
Provides the base requirements for a collection of IPackageReference objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPackageReferenceCollection : IObservableCollection<IPackageReference>,
    IList<IPackageReference>, ICollection<IPackageReference>, IEnumerable<IPackageReference>,
    IEnumerable
Public Interface IPackageReferenceCollection
    Inherits IObservableCollection(Of IPackageReference), IList(Of IPackageReference),
    ICollection(Of IPackageReference), IEnumerable(Of IPackageReference), IEnumerable

The IPackageReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IPackageReference .)
Public property | IsReadOnly | (Inherited from ICollection IPackageReference .)
Public property | ItemInt32 | (Inherited from IList IPackageReference .)
Public property | ItemString | Gets the IPackageReference with the specified name. [C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IPackageReference .)
Public method | Clear | (Inherited from ICollection IPackageReference .)
Public method | Contains | (Inherited from ICollection IPackageReference .)
Public method | CopyTo | (Inherited from ICollection IPackageReference .)
Public method | GetEnumerator | (Inherited from IEnumerable IPackageReference .)
Public method | IndexOf | (Inherited from IList IPackageReference .)
Public method | Insert | (Inherited from IList IPackageReference .)
Public method | Remove | (Inherited from ICollection IPackageReference .)
Public method | RemoveAt | (Inherited from IList IPackageReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Properties

IPackageReferenceCollection Properties

The IPackageReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IPackageReference .)
Public property | IsReadOnly | (Inherited from ICollection IPackageReference .)
Public property | ItemInt32 | (Inherited from IList IPackageReference .)
Public property | ItemString | Gets the IPackageReference with the specified name. [C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection.Item Property

IPackageReferenceCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IPackageReference .)
Public property | ItemString | Gets the IPackageReference with the specified name. [C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection.Item Property (String)

IPackageReferenceCollectionItem Property (String)
Gets the IPackageReference with the specified name.

[C#] In C#, this property is the indexer for the IPackageReferenceCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPackageReference this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As IPackageReference
    Get

Parameters

name
Type: SystemString
The name of the IPackageReference to return.

Property Value

Type: IPackageReference
The IPackageReference with the specified name.
See Also

Reference

IPackageReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Methods

IPackageReferenceCollection Methods

The IPackageReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IPackageReference .)
Public method | Clear | (Inherited from ICollection IPackageReference .)
Public method | Contains | (Inherited from ICollection IPackageReference .)
Public method | CopyTo | (Inherited from ICollection IPackageReference .)
Public method | GetEnumerator | (Inherited from IEnumerable IPackageReference .)
Public method | IndexOf | (Inherited from IList IPackageReference .)
Public method | Insert | (Inherited from IList IPackageReference .)
Public method | Remove | (Inherited from ICollection IPackageReference .)
Public method | RemoveAt | (Inherited from IList IPackageReference .)
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageReferenceCollection Events

IPackageReferenceCollection Events

The IPackageReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IPackageReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository Interface

IPackageRepository Interface
Provides the base requirements for a class that manages package instances and caching of data as appropriate.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPackageRepository
Public Interface IPackageRepository

The IPackageRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPackageDefinitionAsync | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | QueuePackageCacheUpdateAsync | Queues a package cache update operation, optionally recursing into child packages.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository Methods

IPackageRepository Methods

The IPackageRepository type exposes the following members.

Methods
 | Name | Description
Public method | GetPackageDefinitionAsync | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | QueuePackageCacheUpdateAsync | Queues a package cache update operation, optionally recursing into child packages.
Top
See Also

Reference

IPackageRepository Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository.GetPackageDefinitionAsync Method

IPackageRepositoryGetPackageDefinitionAsync Method
Returns an IPackageDefinition based on cached package data, if it is available.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<IPackageDefinition> GetPackageDefinitionAsync(
    PythonVersion version,
    string path
)
Function GetPackageDefinitionAsync (
    version As PythonVersion,
    path As String
) As Task(Of IPackageDefinition)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The root package path to examine.

Return Value

Type: Task IPackageDefinition
The cached IPackageDefinition data.
See Also

Reference

IPackageRepository Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IPackageRepository.QueuePackageCacheUpdateAsync Method

IPackageRepositoryQueuePackageCacheUpdateAsync Method
Queues a package cache update operation, optionally recursing into child packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task QueuePackageCacheUpdateAsync(
    PythonVersion version,
    string path,
    bool isRootPath,
    bool recurse
)
Function QueuePackageCacheUpdateAsync (
    version As PythonVersion,
    path As String,
    isRootPath As Boolean,
    recurse As Boolean
) As Task

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The root package path to examine.
isRootPath
Type: SystemBoolean
Whether this is a root path.
recurse
Type: SystemBoolean
Whether to recurse into child packages.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.Python.Reflection.IPackageRepository.QueuePackageCacheUpdateAsync(ActiproSoftware.Text.Languages.Python.PythonVersion,System.String,System.Boolean,System.Boolean)"]

See Also

Reference

IPackageRepository Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition Interface

IParameterDefinition Interface
Provides the base requirements of a parameter definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterDefinition : IReflectionDefinition
Public Interface IParameterDefinition
    Inherits IReflectionDefinition

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsDictionary | Gets whether this is a dictionary parameter.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsTuple | Gets whether this is a tuple parameter.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the parameter type, if known.
Public property | TypeExpressionTextRange | Gets the parameter type expression TextRange.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition Properties

IParameterDefinition Properties

The IParameterDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsDictionary | Gets whether this is a dictionary parameter.
Public property | IsOptional | Gets whether this is an optional parameter.
Public property | IsTuple | Gets whether this is a tuple parameter.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the parameter type, if known.
Public property | TypeExpressionTextRange | Gets the parameter type expression TextRange.
Top
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.IsDictionary Property

IParameterDefinitionIsDictionary Property
Gets whether this is a dictionary parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsDictionary { get; }
ReadOnly Property IsDictionary As Boolean
    Get

Property Value

Type: Boolean
true if this is a dictionary parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.IsOptional Property

IParameterDefinitionIsOptional Property
Gets whether this is an optional parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsOptional { get; }
ReadOnly Property IsOptional As Boolean
    Get

Property Value

Type: Boolean
true if this is an optional parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.IsTuple Property

IParameterDefinitionIsTuple Property
Gets whether this is a tuple parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsTuple { get; }
ReadOnly Property IsTuple As Boolean
    Get

Property Value

Type: Boolean
true if this is a tuple parameter; otherwise, false.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.Type Property

IParameterDefinitionType Property
Gets a ITypeDefinition indicating the parameter type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the parameter type, if known.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinition.TypeExpressionTextRange Property

IParameterDefinitionTypeExpressionTextRange Property
Gets the parameter type expression TextRange.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TypeExpressionTextRange { get; }
ReadOnly Property TypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The parameter type expression TextRange.
See Also

Reference

IParameterDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Interface

IParameterDefinitionCollection Interface
Provides the base requirements for a collection of IParameterDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterDefinitionCollection : IObservableCollection<IParameterDefinition>,
    IList<IParameterDefinition>, ICollection<IParameterDefinition>, IEnumerable<IParameterDefinition>,
    IEnumerable
Public Interface IParameterDefinitionCollection
    Inherits IObservableCollection(Of IParameterDefinition), IList(Of IParameterDefinition),
    ICollection(Of IParameterDefinition), IEnumerable(Of IParameterDefinition), IEnumerable

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | (Inherited from IList IParameterDefinition .)
Public property | ItemString | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IParameterDefinition .)
Public method | Clear | (Inherited from ICollection IParameterDefinition .)
Public method | Contains | (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IParameterDefinition .)
Public method | IndexOf | (Inherited from IList IParameterDefinition .)
Public method | Insert | (Inherited from IList IParameterDefinition .)
Public method | Remove | (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | (Inherited from IList IParameterDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Properties

IParameterDefinitionCollection Properties

The IParameterDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IParameterDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IParameterDefinition .)
Public property | ItemInt32 | (Inherited from IList IParameterDefinition .)
Public property | ItemString | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection.Item Property

IParameterDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IParameterDefinition .)
Public property | ItemString | Gets the IParameterDefinition with the specified name. [C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection.Item Property (String)

IParameterDefinitionCollectionItem Property (String)
Gets the IParameterDefinition with the specified name.

[C#] In C#, this property is the indexer for the IParameterDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParameterDefinition this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As IParameterDefinition
    Get

Parameters

name
Type: SystemString
The name of the IParameterDefinition to return.

Property Value

Type: IParameterDefinition
The IParameterDefinition with the specified name.
See Also

Reference

IParameterDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Methods

IParameterDefinitionCollection Methods

The IParameterDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IParameterDefinition .)
Public method | Clear | (Inherited from ICollection IParameterDefinition .)
Public method | Contains | (Inherited from ICollection IParameterDefinition .)
Public method | CopyTo | (Inherited from ICollection IParameterDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IParameterDefinition .)
Public method | IndexOf | (Inherited from IList IParameterDefinition .)
Public method | Insert | (Inherited from IList IParameterDefinition .)
Public method | Remove | (Inherited from ICollection IParameterDefinition .)
Public method | RemoveAt | (Inherited from IList IParameterDefinition .)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IParameterDefinitionCollection Events

IParameterDefinitionCollection Events

The IParameterDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IParameterDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject Interface

IProject Interface
Represents a Python project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IProject
Public Interface IProject

The IProject type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject Properties

IProject Properties

The IProject type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.ActiveModules Property

IProjectActiveModules Property
Gets the collection of active modules in this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IActiveModuleCollection ActiveModules { get; }
ReadOnly Property ActiveModules As IActiveModuleCollection
    Get

Property Value

Type: IActiveModuleCollection
The collection of active modules in this project.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.Resolver Property

IProjectResolver Property
Gets the IResolver to use for this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolver Resolver { get; }
ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.SearchPaths Property

IProjectSearchPaths Property
Gets the list of paths (in priority order) to search when looking for packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<string> SearchPaths { get; }
ReadOnly Property SearchPaths As IList(Of String)
    Get

Property Value

Type: IList String
The list of paths (in priority order) to search when looking for packages.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IProject.Version Property

IProjectVersion Property
Gets the PythonVersion used to parse packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PythonVersion Version { get; }
ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion used to parse packages.
See Also

Reference

IProject Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IReflectionDefinition Interface

IReflectionDefinition Interface
Provides the base requirements of a reflection definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IReflectionDefinition
Public Interface IReflectionDefinition

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IReflectionDefinition Properties

IReflectionDefinition Properties

The IReflectionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the definition's name.
Top
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IReflectionDefinition.Name Property

IReflectionDefinitionName Property
Gets the definition's name.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The definition's name.
See Also

Reference

IReflectionDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition Interface

ITypeDefinition Interface
Provides the base requirements of a type definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeDefinition : ITypeReference,
    IReflectionDefinition
Public Interface ITypeDefinition
    Inherits ITypeReference, IReflectionDefinition

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BaseTypes | Gets the collection of base type references.
Public property | DeclaringModule | Gets the reference to the module in which the type is declared. (Inherited from ITypeReference.)
Public property | Docstring | Gets the docstring for the type.
Public property | Fields | Gets the collection of fields defined in the type.
Public property | IsPublic | Gets whether the type is public.
Public property | Methods | Gets the collection of methods defined in the type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | NestedTypes | Gets the collection of nested types defined in the type.
Public property | TextRange | Gets the TextRange of the type definition, if known.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition Properties

ITypeDefinition Properties

The ITypeDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BaseTypes | Gets the collection of base type references.
Public property | DeclaringModule | Gets the reference to the module in which the type is declared. (Inherited from ITypeReference.)
Public property | Docstring | Gets the docstring for the type.
Public property | Fields | Gets the collection of fields defined in the type.
Public property | IsPublic | Gets whether the type is public.
Public property | Methods | Gets the collection of methods defined in the type.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | NestedTypes | Gets the collection of nested types defined in the type.
Public property | TextRange | Gets the TextRange of the type definition, if known.
Top
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.BaseTypes Property

ITypeDefinitionBaseTypes Property
Gets the collection of base type references.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReferenceCollection BaseTypes { get; }
ReadOnly Property BaseTypes As ITypeReferenceCollection
    Get

Property Value

Type: ITypeReferenceCollection
The collection of base type references.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.Docstring Property

ITypeDefinitionDocstring Property
Gets the docstring for the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Docstring { get; }
ReadOnly Property Docstring As String
    Get

Property Value

Type: String
The docstring for the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.Fields Property

ITypeDefinitionFields Property
Gets the collection of fields defined in the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFieldDefinitionCollection Fields { get; }
ReadOnly Property Fields As IFieldDefinitionCollection
    Get

Property Value

Type: IFieldDefinitionCollection
The collection of fields defined in the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.IsPublic Property

ITypeDefinitionIsPublic Property
Gets whether the type is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the type is public; otherwise, false.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.Methods Property

ITypeDefinitionMethods Property
Gets the collection of methods defined in the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFunctionDefinitionCollection Methods { get; }
ReadOnly Property Methods As IFunctionDefinitionCollection
    Get

Property Value

Type: IFunctionDefinitionCollection
The collection of methods defined in the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.NestedTypes Property

ITypeDefinitionNestedTypes Property
Gets the collection of nested types defined in the type.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinitionCollection NestedTypes { get; }
ReadOnly Property NestedTypes As ITypeDefinitionCollection
    Get

Property Value

Type: ITypeDefinitionCollection
The collection of nested types defined in the type.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinition.TextRange Property

ITypeDefinitionTextRange Property
Gets the TextRange of the type definition, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
The TextRange of the type definition, if known.
See Also

Reference

ITypeDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Interface

ITypeDefinitionCollection Interface
Provides the base requirements for a collection of ITypeDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeDefinitionCollection : IObservableCollection<ITypeDefinition>,
    IList<ITypeDefinition>, ICollection<ITypeDefinition>, IEnumerable<ITypeDefinition>,
    IEnumerable
Public Interface ITypeDefinitionCollection
    Inherits IObservableCollection(Of ITypeDefinition), IList(Of ITypeDefinition),
    ICollection(Of ITypeDefinition), IEnumerable(Of ITypeDefinition), IEnumerable

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | (Inherited from IList ITypeDefinition .)
Public property | ItemString | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeDefinition .)
Public method | Clear | (Inherited from ICollection ITypeDefinition .)
Public method | Contains | (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeDefinition .)
Public method | IndexOf | (Inherited from IList ITypeDefinition .)
Public method | Insert | (Inherited from IList ITypeDefinition .)
Public method | Remove | (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | (Inherited from IList ITypeDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Properties

ITypeDefinitionCollection Properties

The ITypeDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeDefinition .)
Public property | IsReadOnly | (Inherited from ICollection ITypeDefinition .)
Public property | ItemInt32 | (Inherited from IList ITypeDefinition .)
Public property | ItemString | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection.Item Property

ITypeDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList ITypeDefinition .)
Public property | ItemString | Gets the ITypeDefinition with the specified name. [C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection.Item Property (String)

ITypeDefinitionCollectionItem Property (String)
Gets the ITypeDefinition with the specified name.

[C#] In C#, this property is the indexer for the ITypeDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As ITypeDefinition
    Get

Parameters

name
Type: SystemString
The name of the ITypeDefinition to return.

Property Value

Type: ITypeDefinition
The ITypeDefinition with the specified name.
See Also

Reference

ITypeDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Methods

ITypeDefinitionCollection Methods

The ITypeDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeDefinition .)
Public method | Clear | (Inherited from ICollection ITypeDefinition .)
Public method | Contains | (Inherited from ICollection ITypeDefinition .)
Public method | CopyTo | (Inherited from ICollection ITypeDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeDefinition .)
Public method | IndexOf | (Inherited from IList ITypeDefinition .)
Public method | Insert | (Inherited from IList ITypeDefinition .)
Public method | Remove | (Inherited from ICollection ITypeDefinition .)
Public method | RemoveAt | (Inherited from IList ITypeDefinition .)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeDefinitionCollection Events

ITypeDefinitionCollection Events

The ITypeDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReference Interface

ITypeReference Interface
Provides the base requirements of a type reference.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeReference : IReflectionDefinition
Public Interface ITypeReference
    Inherits IReflectionDefinition

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReference Properties

ITypeReference Properties

The ITypeReference type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Top
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReference.DeclaringModule Property

ITypeReferenceDeclaringModule Property
Gets the reference to the module in which the type is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the type is declared.
See Also

Reference

ITypeReference Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Interface

ITypeReferenceCollection Interface
Provides the base requirements for a collection of ITypeReference objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeReferenceCollection : IObservableCollection<ITypeReference>,
    IList<ITypeReference>, ICollection<ITypeReference>, IEnumerable<ITypeReference>,
    IEnumerable
Public Interface ITypeReferenceCollection
    Inherits IObservableCollection(Of ITypeReference), IList(Of ITypeReference),
    ICollection(Of ITypeReference), IEnumerable(Of ITypeReference), IEnumerable

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | (Inherited from IList ITypeReference .)
Public property | ItemString | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeReference .)
Public method | Clear | (Inherited from ICollection ITypeReference .)
Public method | Contains | (Inherited from ICollection ITypeReference .)
Public method | CopyTo | (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeReference .)
Public method | IndexOf | (Inherited from IList ITypeReference .)
Public method | Insert | (Inherited from IList ITypeReference .)
Public method | Remove | (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | (Inherited from IList ITypeReference .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Properties

ITypeReferenceCollection Properties

The ITypeReferenceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ITypeReference .)
Public property | IsReadOnly | (Inherited from ICollection ITypeReference .)
Public property | ItemInt32 | (Inherited from IList ITypeReference .)
Public property | ItemString | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection.Item Property

ITypeReferenceCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList ITypeReference .)
Public property | ItemString | Gets the ITypeReference with the specified name. [C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection.Item Property (String)

ITypeReferenceCollectionItem Property (String)
Gets the ITypeReference with the specified name.

[C#] In C#, this property is the indexer for the ITypeReferenceCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeReference this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As ITypeReference
    Get

Parameters

name
Type: SystemString
The name of the ITypeReference to return.

Property Value

Type: ITypeReference
The ITypeReference with the specified name.
See Also

Reference

ITypeReferenceCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Methods

ITypeReferenceCollection Methods

The ITypeReferenceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ITypeReference .)
Public method | Clear | (Inherited from ICollection ITypeReference .)
Public method | Contains | (Inherited from ICollection ITypeReference .)
Public method | CopyTo | (Inherited from ICollection ITypeReference .)
Public method | GetEnumerator | (Inherited from IEnumerable ITypeReference .)
Public method | IndexOf | (Inherited from IList ITypeReference .)
Public method | Insert | (Inherited from IList ITypeReference .)
Public method | Remove | (Inherited from ICollection ITypeReference .)
Public method | RemoveAt | (Inherited from IList ITypeReference .)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ITypeReferenceCollection Events

ITypeReferenceCollection Events

The ITypeReferenceCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ITypeReferenceCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition Interface

IVariableDefinition Interface
Provides the base requirements of a variable definition.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IVariableDefinition : IReflectionDefinition
Public Interface IVariableDefinition
    Inherits IReflectionDefinition

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the variable is declared.
Public property | IsConstant | Gets whether the variable is a constant.
Public property | IsPublic | Gets whether the variable is public.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the variable type, if known.
Public property | TypeExpressionTextRange | Gets the variable type expression TextRange.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition Properties

IVariableDefinition Properties

The IVariableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the variable is declared.
Public property | IsConstant | Gets whether the variable is a constant.
Public property | IsPublic | Gets whether the variable is public.
Public property | Name | Gets the definition's name. (Inherited from IReflectionDefinition.)
Public property | Type | Gets a ITypeDefinition indicating the variable type, if known.
Public property | TypeExpressionTextRange | Gets the variable type expression TextRange.
Top
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.DeclaringModule Property

IVariableDefinitionDeclaringModule Property
Gets the reference to the module in which the variable is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleReference DeclaringModule { get; }
ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the variable is declared.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.IsConstant Property

IVariableDefinitionIsConstant Property
Gets whether the variable is a constant.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsConstant { get; }
ReadOnly Property IsConstant As Boolean
    Get

Property Value

Type: Boolean
true if the variable is a constant; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.IsPublic Property

IVariableDefinitionIsPublic Property
Gets whether the variable is public.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPublic { get; }
ReadOnly Property IsPublic As Boolean
    Get

Property Value

Type: Boolean
true if the variable is public; otherwise, false.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.Type Property

IVariableDefinitionType Property
Gets a ITypeDefinition indicating the variable type, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the variable type, if known.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinition.TypeExpressionTextRange Property

IVariableDefinitionTypeExpressionTextRange Property
Gets the variable type expression TextRange.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TypeExpressionTextRange { get; }
ReadOnly Property TypeExpressionTextRange As TextRange
    Get

Property Value

Type: TextRange
The variable type expression TextRange.
See Also

Reference

IVariableDefinition Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Interface

IVariableDefinitionCollection Interface
Provides the base requirements for a collection of IVariableDefinition objects.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IVariableDefinitionCollection : IObservableCollection<IVariableDefinition>,
    IList<IVariableDefinition>, ICollection<IVariableDefinition>, IEnumerable<IVariableDefinition>,
    IEnumerable
Public Interface IVariableDefinitionCollection
    Inherits IObservableCollection(Of IVariableDefinition), IList(Of IVariableDefinition),
    ICollection(Of IVariableDefinition), IEnumerable(Of IVariableDefinition), IEnumerable

The IVariableDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IVariableDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IVariableDefinition .)
Public property | ItemInt32 | (Inherited from IList IVariableDefinition .)
Public property | ItemString | Gets the IVariableDefinition with the specified name. [C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IVariableDefinition .)
Public method | Clear | (Inherited from ICollection IVariableDefinition .)
Public method | Contains | (Inherited from ICollection IVariableDefinition .)
Public method | CopyTo | (Inherited from ICollection IVariableDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IVariableDefinition .)
Public method | IndexOf | (Inherited from IList IVariableDefinition .)
Public method | Insert | (Inherited from IList IVariableDefinition .)
Public method | Remove | (Inherited from ICollection IVariableDefinition .)
Public method | RemoveAt | (Inherited from IList IVariableDefinition .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Properties

IVariableDefinitionCollection Properties

The IVariableDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IVariableDefinition .)
Public property | IsReadOnly | (Inherited from ICollection IVariableDefinition .)
Public property | ItemInt32 | (Inherited from IList IVariableDefinition .)
Public property | ItemString | Gets the IVariableDefinition with the specified name. [C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection.Item Property

IVariableDefinitionCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList IVariableDefinition .)
Public property | ItemString | Gets the IVariableDefinition with the specified name. [C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection.Item Property (String)

IVariableDefinitionCollectionItem Property (String)
Gets the IVariableDefinition with the specified name.

[C#] In C#, this property is the indexer for the IVariableDefinitionCollection interface.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IVariableDefinition this[
    string name
] { get; }
ReadOnly Property Item (
    name As String
) As IVariableDefinition
    Get

Parameters

name
Type: SystemString
The name of the IVariableDefinition to return.

Property Value

Type: IVariableDefinition
The IVariableDefinition with the specified name.
See Also

Reference

IVariableDefinitionCollection Interface
Item Overload
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Methods

IVariableDefinitionCollection Methods

The IVariableDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IVariableDefinition .)
Public method | Clear | (Inherited from ICollection IVariableDefinition .)
Public method | Contains | (Inherited from ICollection IVariableDefinition .)
Public method | CopyTo | (Inherited from ICollection IVariableDefinition .)
Public method | GetEnumerator | (Inherited from IEnumerable IVariableDefinition .)
Public method | IndexOf | (Inherited from IList IVariableDefinition .)
Public method | Insert | (Inherited from IList IVariableDefinition .)
Public method | Remove | (Inherited from ICollection IVariableDefinition .)
Public method | RemoveAt | (Inherited from IList IVariableDefinition .)
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


IVariableDefinitionCollection Events

IVariableDefinitionCollection Events

The IVariableDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IVariableDefinitionCollection Interface
ActiproSoftware.Text.Languages.Python.Reflection Namespace


ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace
Contains the implementation types related to reflection for a Python syntax language.
Classes
 | Class | Description
Public class | FileBasedPackageRepository | Represents an IPackageRepository that can cache data in the file system.
Public class | Project | Represents a Python project.
Public class | TypeReference | Represents a type reference.


FileBasedPackageRepository Class

FileBasedPackageRepository Class
Represents an IPackageRepository that can cache data in the file system.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Reflection.ImplementationFileBasedPackageRepository

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FileBasedPackageRepository : IPackageRepository
Public Class FileBasedPackageRepository
    Implements IPackageRepository

The FileBasedPackageRepository type exposes the following members.

Constructors
 | Name | Description
Public method | FileBasedPackageRepository | Initializes a new instance of the FileBasedPackageRepository class.
Top
Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPackageDefinitionAsync | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | QueuePackageCacheUpdateAsync | Queues a package cache update operation, optionally recursing into child packages.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository Constructor

FileBasedPackageRepository Constructor
Initializes a new instance of the FileBasedPackageRepository class.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FileBasedPackageRepository(
    string cachePath
)
Public Sub New (
    cachePath As String
)

Parameters

cachePath
Type: SystemString
The path to use for package cache files.
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository Properties

FileBasedPackageRepository Properties

The FileBasedPackageRepository type exposes the following members.

Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to use for assembly and documentation cache files.
Top
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository.CachePath Property

FileBasedPackageRepositoryCachePath Property
Gets or sets the path to use for assembly and documentation cache files.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string CachePath { get; set; }
Public Property CachePath As String
    Get
    Set

Property Value

Type: String
The path to use for assembly and documentation cache files.
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository Methods

FileBasedPackageRepository Methods

The FileBasedPackageRepository type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPackageDefinitionAsync | Returns an IPackageDefinition based on cached package data, if it is available.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | QueuePackageCacheUpdateAsync | Queues a package cache update operation, optionally recursing into child packages.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository.GetPackageDefinitionAsync Method

FileBasedPackageRepositoryGetPackageDefinitionAsync Method
Returns an IPackageDefinition based on cached package data, if it is available.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task<IPackageDefinition> GetPackageDefinitionAsync(
    PythonVersion version,
    string path
)
Public Function GetPackageDefinitionAsync (
    version As PythonVersion,
    path As String
) As Task(Of IPackageDefinition)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The root package path to examine.

Return Value

Type: Task IPackageDefinition
The cached IPackageDefinition data.

Implements

IPackageRepositoryGetPackageDefinitionAsync(PythonVersion, String)
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


FileBasedPackageRepository.QueuePackageCacheUpdateAsync Method

FileBasedPackageRepositoryQueuePackageCacheUpdateAsync Method
Queues a package cache update operation, optionally recursing into child packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Task QueuePackageCacheUpdateAsync(
    PythonVersion version,
    string path,
    bool isRootPath,
    bool recurse
)
Public Function QueuePackageCacheUpdateAsync (
    version As PythonVersion,
    path As String,
    isRootPath As Boolean,
    recurse As Boolean
) As Task

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
path
Type: SystemString
The package path to examine.
isRootPath
Type: SystemBoolean
Whether this is a root path.
recurse
Type: SystemBoolean
Whether to recurse into child packages.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.Text.Languages.Python.Reflection.Implementation.FileBasedPackageRepository.QueuePackageCacheUpdateAsync(ActiproSoftware.Text.Languages.Python.PythonVersion,System.String,System.Boolean,System.Boolean)"]

Implements

IPackageRepositoryQueuePackageCacheUpdateAsync(PythonVersion, String, Boolean, Boolean)
See Also

Reference

FileBasedPackageRepository Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Class

Project Class
Represents a Python project.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Reflection.ImplementationProject

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Project : IProject
Public Class Project
    Implements IProject

The Project type exposes the following members.

Constructors
 | Name | Description
Public method | Project | Initializes a new instance of the Project class.
Top
Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Constructor

Project Constructor
Initializes a new instance of the Project class.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Project(
    PythonVersion version
)
Public Sub New (
    version As PythonVersion
)

Parameters

version
Type: ActiproSoftware.Text.Languages.PythonPythonVersion
The PythonVersion to use for parsing.
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Properties

Project Properties

The Project type exposes the following members.

Properties
 | Name | Description
Public property | ActiveModules | Gets the collection of active modules in this project.
Public property | Resolver | Gets the IResolver to use for this project.
Public property | SearchPaths | Gets the list of paths (in priority order) to search when looking for packages.
Public property | Version | Gets the PythonVersion used to parse packages.
Top
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.ActiveModules Property

ProjectActiveModules Property
Gets the collection of active modules in this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IActiveModuleCollection ActiveModules { get; }
Public ReadOnly Property ActiveModules As IActiveModuleCollection
    Get

Property Value

Type: IActiveModuleCollection
The collection of active modules in this project.

Implements

IProjectActiveModules
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.Resolver Property

ProjectResolver Property
Gets the IResolver to use for this project.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IResolver Resolver { get; }
Public ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project.

Implements

IProjectResolver
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.SearchPaths Property

ProjectSearchPaths Property
Gets the list of paths (in priority order) to search when looking for packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<string> SearchPaths { get; }
Public ReadOnly Property SearchPaths As IList(Of String)
    Get

Property Value

Type: IList String
The list of paths (in priority order) to search when looking for packages.

Implements

IProjectSearchPaths
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project.Version Property

ProjectVersion Property
Gets the PythonVersion used to parse packages.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PythonVersion Version { get; }
Public ReadOnly Property Version As PythonVersion
    Get

Property Value

Type: PythonVersion
The PythonVersion used to parse packages.

Implements

IProjectVersion
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


Project Methods

Project Methods

The Project type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Project Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Class

TypeReference Class
Represents a type reference.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Reflection.ImplementationTypeReference

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TypeReference : ITypeReference,
    IReflectionDefinition
Public Class TypeReference
    Implements ITypeReference, IReflectionDefinition

The TypeReference type exposes the following members.

Constructors
 | Name | Description
Public method | TypeReference | Initializes a new instance of the TypeReference class.
Top
Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the references's name.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Constructor

TypeReference Constructor
Initializes a new instance of the TypeReference class.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypeReference(
    string modulePath,
    string typeName
)
Public Sub New (
    modulePath As String,
    typeName As String
)

Parameters

modulePath
Type: SystemString
The path to the declaring module.
typeName
Type: SystemString
The type name.
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Properties

TypeReference Properties

The TypeReference type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringModule | Gets the reference to the module in which the type is declared.
Public property | Name | Gets the references's name.
Top
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference.DeclaringModule Property

TypeReferenceDeclaringModule Property
Gets the reference to the module in which the type is declared.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IModuleReference DeclaringModule { get; }
Public ReadOnly Property DeclaringModule As IModuleReference
    Get

Property Value

Type: IModuleReference
The reference to the module in which the type is declared.

Implements

ITypeReferenceDeclaringModule
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference.Name Property

TypeReferenceName Property
Gets the references's name.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
The references's name.

Implements

IReflectionDefinitionName
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference Methods

TypeReference Methods

The TypeReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


TypeReference.ToString Method

TypeReferenceToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Languages.Python.Reflection.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

TypeReference Class
ActiproSoftware.Text.Languages.Python.Reflection.Implementation Namespace


ActiproSoftware.Text.Languages.Python.Resolution Namespace

ActiproSoftware.Text.Languages.Python.Resolution Namespace
Contains the types related to resolution for a Python syntax language.
Classes
 | Class | Description
Public class | FunctionReferenceKind | Specifies the kind of function reference.
Public class | ResolverResultKind | Specifies the kind of resolver result.
Interfaces
 | Interface | Description
Public interface | IFieldResolverResult | Provides the base requirements of a field result from an IResolver resolution operation.
Public interface | IFunctionResolverResult | Provides the base requirements of a function result from an IResolver resolution operation.
Public interface | IModuleResolverResult | Provides the base requirements of a module result from an IResolver resolution operation.
Public interface | IPackageResolverResult | Provides the base requirements of a package result from an IResolver resolution operation.
Public interface | IParameterResolverResult | Provides the base requirements of a parameter result from an IResolver resolution operation.
Public interface | IResolver | Provides the base requirements of a Python language resolver.
Public interface | IResolverRequest | Provides the base requirements of a request for a Python language resolve operation.
Public interface | IResolverResult | Provides the base requirements of a single result from an IResolver resolution operation.
Public interface | IResolverResultCollection | Provides the base requirements for a collection of IResolverResult objects.
Public interface | IResolverResultSet | Provides the base requirements of a result set from an IResolver resolution operation.
Public interface | ITypeResolverResult | Provides the base requirements of a type result from an IResolver resolution operation.
Public interface | IVariableResolverResult | Provides the base requirements of a variable result from an IResolver resolution operation.


FunctionReferenceKind Class

FunctionReferenceKind Class
Specifies the kind of function reference.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.Python.ResolutionFunctionReferenceKind

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class FunctionReferenceKind : Enum
Public NotInheritable Class FunctionReferenceKind
    Inherits Enum

The FunctionReferenceKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | FunctionInvocation | A function invocation.
 | FunctionReference | A function reference.
 | MethodInvocation | A method invocation, where the first argument is the target type instance.
 | MethodReference | A method reference, where the first argument is the target type instance.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind Methods

FunctionReferenceKind Methods

The FunctionReferenceKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind Fields

FunctionReferenceKind Fields

The FunctionReferenceKind type exposes the following members.

Fields
 | Name | Description
 | FunctionInvocation | A function invocation.
 | FunctionReference | A function reference.
 | MethodInvocation | A method invocation, where the first argument is the target type instance.
 | MethodReference | A method reference, where the first argument is the target type instance.
Public field | value__ |
Top
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind.FunctionInvocation Field

FunctionReferenceKindFunctionInvocation Field
A function invocation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const FunctionReferenceKind FunctionInvocation = 1
Public Const FunctionInvocation As FunctionReferenceKind = 1

Field Value

Type: FunctionReferenceKind
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind.FunctionReference Field

FunctionReferenceKindFunctionReference Field
A function reference.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const FunctionReferenceKind FunctionReference = 0
Public Const FunctionReference As FunctionReferenceKind = 0

Field Value

Type: FunctionReferenceKind
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind.MethodInvocation Field

FunctionReferenceKindMethodInvocation Field
A method invocation, where the first argument is the target type instance.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const FunctionReferenceKind MethodInvocation = 3
Public Const MethodInvocation As FunctionReferenceKind = 3

Field Value

Type: FunctionReferenceKind
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind.MethodReference Field

FunctionReferenceKindMethodReference Field
A method reference, where the first argument is the target type instance.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const FunctionReferenceKind MethodReference = 2
Public Const MethodReference As FunctionReferenceKind = 2

Field Value

Type: FunctionReferenceKind
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


FunctionReferenceKind.value__ Field

FunctionReferenceKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.Resolution.FunctionReferenceKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

FunctionReferenceKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult Interface

IFieldResolverResult Interface
Provides the base requirements of a field result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IFieldResolverResult : IResolverResult
Public Interface IFieldResolverResult
    Inherits IResolverResult

The IFieldResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets a IFieldDefinition indicating the field.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult Properties

IFieldResolverResult Properties

The IFieldResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets a IFieldDefinition indicating the field.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IFieldResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult.Field Property

IFieldResolverResultField Property
Gets a IFieldDefinition indicating the field.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFieldDefinition Field { get; }
ReadOnly Property Field As IFieldDefinition
    Get

Property Value

Type: IFieldDefinition
A IFieldDefinition indicating the field.
See Also

Reference

IFieldResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFieldResolverResult Methods

IFieldResolverResult Methods

The IFieldResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IFieldResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult Interface

IFunctionResolverResult Interface
Provides the base requirements of a function result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IFunctionResolverResult : IResolverResult
Public Interface IFunctionResolverResult
    Inherits IResolverResult

The IFunctionResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Function | Gets a IFunctionDefinition indicating the function.
Public property | InvocationArguments | Gets the list of invocation arguments passed into the function.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | ReferenceKind | Gets a FunctionReferenceKind specifying the kind of reference.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult Properties

IFunctionResolverResult Properties

The IFunctionResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Function | Gets a IFunctionDefinition indicating the function.
Public property | InvocationArguments | Gets the list of invocation arguments passed into the function.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | ReferenceKind | Gets a FunctionReferenceKind specifying the kind of reference.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult.Function Property

IFunctionResolverResultFunction Property
Gets a IFunctionDefinition indicating the function.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IFunctionDefinition Function { get; }
ReadOnly Property Function As IFunctionDefinition
    Get

Property Value

Type: IFunctionDefinition
A IFunctionDefinition indicating the function.
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult.InvocationArguments Property

IFunctionResolverResultInvocationArguments Property
Gets the list of invocation arguments passed into the function.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<Argument> InvocationArguments { get; }
ReadOnly Property InvocationArguments As IList(Of Argument)
    Get

Property Value

Type: IList Argument
The list of invocation arguments passed into the function.
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult.ReferenceKind Property

IFunctionResolverResultReferenceKind Property
Gets a FunctionReferenceKind specifying the kind of reference.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
FunctionReferenceKind ReferenceKind { get; }
ReadOnly Property ReferenceKind As FunctionReferenceKind
    Get

Property Value

Type: FunctionReferenceKind
A FunctionReferenceKind specifying the kind of reference.
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IFunctionResolverResult Methods

IFunctionResolverResult Methods

The IFunctionResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IFunctionResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult Interface

IModuleResolverResult Interface
Provides the base requirements of a module result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IModuleResolverResult : IResolverResult
Public Interface IModuleResolverResult
    Inherits IResolverResult

The IModuleResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether module members should be filtered by the module's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the module is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Module | Gets a IModuleReference indicating the module.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult Properties

IModuleResolverResult Properties

The IModuleResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether module members should be filtered by the module's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the module is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Module | Gets a IModuleReference indicating the module.
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult.FilterByPublicNames Property

IModuleResolverResultFilterByPublicNames Property
Gets whether module members should be filtered by the module's public names (__all__).

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool FilterByPublicNames { get; }
ReadOnly Property FilterByPublicNames As Boolean
    Get

Property Value

Type: Boolean
true if module members should be filtered by the module's public names; otherwise, false.
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult.IsWithinImportStatement Property

IModuleResolverResultIsWithinImportStatement Property
Gets whether the module is within an import statement.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWithinImportStatement { get; }
ReadOnly Property IsWithinImportStatement As Boolean
    Get

Property Value

Type: Boolean
true if the module is within an import statement; otherwise, false.
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult.Module Property

IModuleResolverResultModule Property
Gets a IModuleReference indicating the module.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleReference Module { get; }
ReadOnly Property Module As IModuleReference
    Get

Property Value

Type: IModuleReference
A IModuleReference indicating the module.
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IModuleResolverResult Methods

IModuleResolverResult Methods

The IModuleResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IModuleResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult Interface

IPackageResolverResult Interface
Provides the base requirements of a package result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPackageResolverResult : IResolverResult
Public Interface IPackageResolverResult
    Inherits IResolverResult

The IPackageResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether package members should be filtered by the package's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the package is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Package | Gets a IPackageReference indicating the package.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult Properties

IPackageResolverResult Properties

The IPackageResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | FilterByPublicNames | Gets whether package members should be filtered by the package's public names (__all__).
Public property | IsWithinImportStatement | Gets whether the package is within an import statement.
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Package | Gets a IPackageReference indicating the package.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult.FilterByPublicNames Property

IPackageResolverResultFilterByPublicNames Property
Gets whether package members should be filtered by the package's public names (__all__).

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool FilterByPublicNames { get; }
ReadOnly Property FilterByPublicNames As Boolean
    Get

Property Value

Type: Boolean
true if package members should be filtered by the package's public names; otherwise, false.
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult.IsWithinImportStatement Property

IPackageResolverResultIsWithinImportStatement Property
Gets whether the package is within an import statement.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWithinImportStatement { get; }
ReadOnly Property IsWithinImportStatement As Boolean
    Get

Property Value

Type: Boolean
true if the package is within an import statement; otherwise, false.
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult.Package Property

IPackageResolverResultPackage Property
Gets a IPackageReference indicating the package.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPackageReference Package { get; }
ReadOnly Property Package As IPackageReference
    Get

Property Value

Type: IPackageReference
A IPackageReference indicating the package.
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IPackageResolverResult Methods

IPackageResolverResult Methods

The IPackageResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IPackageResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult Interface

IParameterResolverResult Interface
Provides the base requirements of a parameter result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParameterResolverResult : IResolverResult
Public Interface IParameterResolverResult
    Inherits IResolverResult

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult Properties

IParameterResolverResult Properties

The IParameterResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Parameter | Gets a IParameterDefinition indicating the parameter.
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult.Parameter Property

IParameterResolverResultParameter Property
Gets a IParameterDefinition indicating the parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParameterDefinition Parameter { get; }
ReadOnly Property Parameter As IParameterDefinition
    Get

Property Value

Type: IParameterDefinition
A IParameterDefinition indicating the parameter.
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IParameterResolverResult Methods

IParameterResolverResult Methods

The IParameterResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IParameterResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver Interface

IResolver Interface
Provides the base requirements of a Python language resolver.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolver
Public Interface IResolver

The IResolver type exposes the following members.

Properties
 | Name | Description
Public property | MaximumImportRecursionLevel | Gets the maximum number of recursions that can be made when examining imports into other packages/modules.
Public property | Project | Gets the IProject for which this resolver was created.
Public property | UnknownReturnTypeReferenceCallback | Gets or sets a callback that is invoked when examining an IReflectionDefinition with an unknown return type.
Top
Methods
 | Name | Description
Public method | LoadAndResolveModule | Loads a module and attempts to resolve the return types of its members.
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver Properties

IResolver Properties

The IResolver type exposes the following members.

Properties
 | Name | Description
Public property | MaximumImportRecursionLevel | Gets the maximum number of recursions that can be made when examining imports into other packages/modules.
Public property | Project | Gets the IProject for which this resolver was created.
Public property | UnknownReturnTypeReferenceCallback | Gets or sets a callback that is invoked when examining an IReflectionDefinition with an unknown return type.
Top
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.MaximumImportRecursionLevel Property

IResolverMaximumImportRecursionLevel Property
Gets the maximum number of recursions that can be made when examining imports into other packages/modules.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int MaximumImportRecursionLevel { get; set; }
Property MaximumImportRecursionLevel As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of recursions that can be made when examining imports into other packages/modules. The default value is 10.
Remarks
Reducing this level can improve the time required to examine large packages that involve a lot import recursions, however it could also then lead to a subset of the real resolver results.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.Project Property

IResolverProject Property
Gets the IProject for which this resolver was created.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IProject Project { get; }
ReadOnly Property Project As IProject
    Get

Property Value

Type: IProject
The IProject for which this resolver was created.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.UnknownReturnTypeReferenceCallback Property

IResolverUnknownReturnTypeReferenceCallback Property
Gets or sets a callback that is invoked when examining an IReflectionDefinition with an unknown return type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Func<IReflectionDefinition, ITypeReference> UnknownReturnTypeReferenceCallback { get; set; }
Property UnknownReturnTypeReferenceCallback As Func(Of IReflectionDefinition, ITypeReference)
    Get
    Set

Property Value

Type: Func IReflectionDefinition, ITypeReference
A callback that is invoked when examining an IReflectionDefinition with an unknown return type.
Remarks
Callback implementations should examine the IReflectionDefinition and return an appropriate ITypeReference that references the return type, if the return type is known.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver Methods

IResolver Methods

The IResolver type exposes the following members.

Methods
 | Name | Description
Public method | LoadAndResolveModule | Loads a module and attempts to resolve the return types of its members.
Public method | Resolve | Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.
Top
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.LoadAndResolveModule Method

IResolverLoadAndResolveModule Method
Loads a module and attempts to resolve the return types of its members.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IModuleDefinition LoadAndResolveModule(
    string path,
    CompilationUnit compUnit,
    bool allowExternalModuleLookup
)
Function LoadAndResolveModule (
    path As String,
    compUnit As CompilationUnit,
    allowExternalModuleLookup As Boolean
) As IModuleDefinition

Parameters

path
Type: SystemString
The path to the module file.
compUnit
Type: ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit
The CompilationUnit to examine.
allowExternalModuleLookup
Type: SystemBoolean
Whether external module lookup is allowed during resolution.

Return Value

Type: IModuleDefinition
The IModuleDefinition that was loaded.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolver.Resolve Method

IResolverResolve Method
Performs a resolve operation on the specified IResolverRequest to an IResolverResultSet.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResultSet Resolve(
    IResolverRequest request
)
Function Resolve (
    request As IResolverRequest
) As IResolverResultSet

Parameters

request
Type: ActiproSoftware.Text.Languages.Python.ResolutionIResolverRequest
The IResolverRequest to process.

Return Value

Type: IResolverResultSet
An IResolverResultSet containing the results.
See Also

Reference

IResolver Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest Interface

IResolverRequest Interface
Provides the base requirements of a request for a Python language resolve operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverRequest
Public Interface IResolverRequest

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest Properties

IResolverRequest Properties

The IResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest.Context Property

IResolverRequestContext Property
Gets the IPythonContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPythonContext Context { get; }
ReadOnly Property Context As IPythonContext
    Get

Property Value

Type: IPythonContext
The IPythonContext in which the request is based, if known.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverRequest.Expression Property

IResolverRequestExpression Property
Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Expression Expression { get; }
ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.
See Also

Reference

IResolverRequest Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult Interface

IResolverResult Interface
Provides the base requirements of a single result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverResult
Public Interface IResolverResult

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeDefinition indicating the type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult Properties

IResolverResult Properties

The IResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result.
Public property | Name | Gets a name identifying the result.
Public property | Type | Gets a ITypeDefinition indicating the type.
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type.
Top
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Kind Property

IResolverResultKind Property
Gets the ResolverResultKind indicating the kind of resolver result.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ResolverResultKind Kind { get; }
ReadOnly Property Kind As ResolverResultKind
    Get

Property Value

Type: ResolverResultKind
The ResolverResultKind indicating the kind of resolver result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Name Property

IResolverResultName Property
Gets a name identifying the result.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
A name identifying the result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Type Property

IResolverResultType Property
Gets a ITypeDefinition indicating the type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypeDefinition Type { get; }
ReadOnly Property Type As ITypeDefinition
    Get

Property Value

Type: ITypeDefinition
A ITypeDefinition indicating the type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.TypeIsInstance Property

IResolverResultTypeIsInstance Property
Gets whether the return Type reference designates an instance of the type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool TypeIsInstance { get; }
ReadOnly Property TypeIsInstance As Boolean
    Get

Property Value

Type: Boolean
true if the return Type reference designates an instance of the type; otherwise, false indicating that the reference designates the static type.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult Methods

IResolverResult Methods

The IResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name.
Top
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResult.Clone Method

IResolverResultClone Method
Deep clones the resolver result using the specified alias as the name.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResult Clone(
    string alias
)
Function Clone (
    alias As String
) As IResolverResult

Parameters

alias
Type: SystemString
The alias.

Return Value

Type: IResolverResult
The cloned result.
See Also

Reference

IResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultCollection Interface

IResolverResultCollection Interface
Provides the base requirements for a collection of IResolverResult objects.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverResultCollection : IList<IResolverResult>,
    ICollection<IResolverResult>, IEnumerable<IResolverResult>, IEnumerable
Public Interface IResolverResultCollection
    Inherits IList(Of IResolverResult), ICollection(Of IResolverResult),
    IEnumerable(Of IResolverResult), IEnumerable

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | (Inherited from ICollection IResolverResult .)
Public property | Item | (Inherited from IList IResolverResult .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IResolverResult .)
Public method | Clear | (Inherited from ICollection IResolverResult .)
Public method | Contains | (Inherited from ICollection IResolverResult .)
Public method | CopyTo | (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | (Inherited from IList IResolverResult .)
Public method | Insert | (Inherited from IList IResolverResult .)
Public method | Remove | (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | (Inherited from IList IResolverResult .)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace
ActiproSoftware.Text.Languages.Python.ResolutionIResolverResult


IResolverResultCollection Properties

IResolverResultCollection Properties

The IResolverResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IResolverResult .)
Public property | IsReadOnly | (Inherited from ICollection IResolverResult .)
Public property | Item | (Inherited from IList IResolverResult .)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultCollection Methods

IResolverResultCollection Methods

The IResolverResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IResolverResult .)
Public method | Clear | (Inherited from ICollection IResolverResult .)
Public method | Contains | (Inherited from ICollection IResolverResult .)
Public method | CopyTo | (Inherited from ICollection IResolverResult .)
Public method | GetEnumerator | (Inherited from IEnumerable IResolverResult .)
Public method | IndexOf | (Inherited from IList IResolverResult .)
Public method | Insert | (Inherited from IList IResolverResult .)
Public method | Remove | (Inherited from ICollection IResolverResult .)
Public method | RemoveAt | (Inherited from IList IResolverResult .)
Top
See Also

Reference

IResolverResultCollection Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultSet Interface

IResolverResultSet Interface
Provides the base requirements of a result set from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IResolverResultSet
Public Interface IResolverResultSet

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultSet Properties

IResolverResultSet Properties

The IResolverResultSet type exposes the following members.

Properties
 | Name | Description
Public property | Results | Gets the collection of results from the resolution operation.
Top
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IResolverResultSet.Results Property

IResolverResultSetResults Property
Gets the collection of results from the resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IResolverResultCollection Results { get; }
ReadOnly Property Results As IResolverResultCollection
    Get

Property Value

Type: IResolverResultCollection
The collection of results from the resolution operation.
See Also

Reference

IResolverResultSet Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ITypeResolverResult Interface

ITypeResolverResult Interface
Provides the base requirements of a type result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypeResolverResult : IResolverResult
Public Interface ITypeResolverResult
    Inherits IResolverResult

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


ITypeResolverResult Properties

ITypeResolverResult Properties

The ITypeResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ITypeResolverResult Methods

ITypeResolverResult Methods

The ITypeResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ITypeResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult Interface

IVariableResolverResult Interface
Provides the base requirements of a variable result from an IResolver resolution operation.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IVariableResolverResult : IResolverResult
Public Interface IVariableResolverResult
    Inherits IResolverResult

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult Properties

IVariableResolverResult Properties

The IVariableResolverResult type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets the ResolverResultKind indicating the kind of resolver result. (Inherited from IResolverResult.)
Public property | Name | Gets a name identifying the result. (Inherited from IResolverResult.)
Public property | Type | Gets a ITypeDefinition indicating the type. (Inherited from IResolverResult.)
Public property | TypeIsInstance | Gets whether the return Type reference designates an instance of the type. (Inherited from IResolverResult.)
Public property | Variable | Gets a IVariableDefinition indicating the variable.
Top
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult.Variable Property

IVariableResolverResultVariable Property
Gets a IVariableDefinition indicating the variable.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IVariableDefinition Variable { get; }
ReadOnly Property Variable As IVariableDefinition
    Get

Property Value

Type: IVariableDefinition
A IVariableDefinition indicating the variable.
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


IVariableResolverResult Methods

IVariableResolverResult Methods

The IVariableResolverResult type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Deep clones the resolver result using the specified alias as the name. (Inherited from IResolverResult.)
Top
See Also

Reference

IVariableResolverResult Interface
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind Class

ResolverResultKind Class
Specifies the kind of resolver result.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.Python.ResolutionResolverResultKind

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ResolverResultKind : Enum
Public NotInheritable Class ResolverResultKind
    Inherits Enum

The ResolverResultKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Field | A field.
 | Function | A function or method.
 | Module | A module.
 | Package | A package.
 | Parameter | A parameter.
 | Type | A type.
Public field | value__ |
 | Variable | A variable.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind Methods

ResolverResultKind Methods

The ResolverResultKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind Fields

ResolverResultKind Fields

The ResolverResultKind type exposes the following members.

Fields
 | Name | Description
 | Field | A field.
 | Function | A function or method.
 | Module | A module.
 | Package | A package.
 | Parameter | A parameter.
 | Type | A type.
Public field | value__ |
 | Variable | A variable.
Top
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Field Field

ResolverResultKindField Field
A field.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Field = 3
Public Const Field As ResolverResultKind = 3

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Function Field

ResolverResultKindFunction Field
A function or method.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Function = 4
Public Const Function As ResolverResultKind = 4

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Module Field

ResolverResultKindModule Field
A module.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Module = 1
Public Const Module As ResolverResultKind = 1

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Package Field

ResolverResultKindPackage Field
A package.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Package = 0
Public Const Package As ResolverResultKind = 0

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Parameter Field

ResolverResultKindParameter Field
A parameter.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Parameter = 5
Public Const Parameter As ResolverResultKind = 5

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Type Field

ResolverResultKindType Field
A type.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Type = 2
Public Const Type As ResolverResultKind = 2

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.value__ Field

ResolverResultKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Python.Resolution.ResolverResultKind.value__"]

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ResolverResultKind.Variable Field

ResolverResultKindVariable Field
A variable.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResolverResultKind Variable = 6
Public Const Variable As ResolverResultKind = 6

Field Value

Type: ResolverResultKind
See Also

Reference

ResolverResultKind Class
ActiproSoftware.Text.Languages.Python.Resolution Namespace


ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace

ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace
Contains the implementation types related to resolution for a Python syntax language.
Classes
 | Class | Description
Public class | ResolverRequest | Represents a request for a Python language resolve operation.


ResolverRequest Class

ResolverRequest Class
Represents a request for a Python language resolve operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Python.Resolution.ImplementationResolverRequest

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ResolverRequest : IResolverRequest
Public Class ResolverRequest
    Implements IResolverRequest

The ResolverRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ResolverRequest | Initializes a new instance of the ResolverRequest class.
Top
Properties
 | Name | Description
Public property | Context | Gets or sets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest Constructor

ResolverRequest Constructor
Initializes a new instance of the ResolverRequest class.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ResolverRequest(
    Expression expression
)
Public Sub New (
    expression As Expression
)

Parameters

expression
Type: ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
The Expression to resolve.
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest Properties

ResolverRequest Properties

The ResolverRequest type exposes the following members.

Properties
 | Name | Description
Public property | Context | Gets or sets the IPythonContext in which the request is based, if known.
Public property | Expression | Gets the Expression to resolve.
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest.Context Property

ResolverRequestContext Property
Gets or sets the IPythonContext in which the request is based, if known.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPythonContext Context { get; set; }
Public Property Context As IPythonContext
    Get
    Set

Property Value

Type: IPythonContext
The IPythonContext in which the request is based, if known.

Implements

IResolverRequestContext
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest.Expression Property

ResolverRequestExpression Property
Gets the Expression to resolve.

Namespace: ActiproSoftware.Text.Languages.Python.Resolution.Implementation
Assembly: AS.Text.Addons.Python.Universal (in AS.Text.Addons.Python.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Expression Expression { get; }
Public ReadOnly Property Expression As Expression
    Get

Property Value

Type: Expression
The Expression to resolve.

Implements

IResolverRequestExpression
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ResolverRequest Methods

ResolverRequest Methods

The ResolverRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ResolverRequest Class
ActiproSoftware.Text.Languages.Python.Resolution.Implementation Namespace


ActiproSoftware.Text.Languages.VB Namespace

ActiproSoftware.Text.Languages.VB Namespace
Contains the classes related to implementing a VB syntax language.
Classes
 | Class | Description
Public class | VBContextLocations | Contains common context locations for a Visual Basic language.
Interfaces
 | Interface | Description
Public interface | IVBGrammarOptions | Contains options for a Visual Basic grammar.


IVBGrammarOptions Interface

IVBGrammarOptions Interface
Contains options for a Visual Basic grammar.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IVBGrammarOptions
Public Interface IVBGrammarOptions

The IVBGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB Namespace


IVBGrammarOptions Properties

IVBGrammarOptions Properties

The IVBGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.
Top
See Also

Reference

IVBGrammarOptions Interface
ActiproSoftware.Text.Languages.VB Namespace


IVBGrammarOptions.RootNonTerminal Property

IVBGrammarOptionsRootNonTerminal Property
Gets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DotNetGrammarRootNonTerminal RootNonTerminal { get; }
ReadOnly Property RootNonTerminal As DotNetGrammarRootNonTerminal
    Get

Property Value

Type: DotNetGrammarRootNonTerminal
A DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. The default value is CompilationUnit.
See Also

Reference

IVBGrammarOptions Interface
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations Class

VBContextLocations Class
Contains common context locations for a Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VBVBContextLocations

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class VBContextLocations
Public NotInheritable Class VBContextLocations

The VBContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespaceOrType | Gets the IDotNetContextLocation that represents a namespace/type specification within a using directive.
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations Properties

VBContextLocations Properties

The VBContextLocations type exposes the following members.

Properties
Name | Description
Attribute | Gets the IDotNetContextLocation that represents an attribute specification.
Comment | Gets the IDotNetContextLocation that represents a comment specification.
DocumentationComment | Gets the IDotNetContextLocation that represents a documentation comment specification.
ExpressionStart | Gets the IDotNetContextLocation that represents an expression start specification.
ImplicitLocalVariableType | Gets the IDotNetContextLocation that represents an implicit local variable type.
LiteralCharacter | Gets the IDotNetContextLocation that represents a literal character specification.
LiteralString | Gets the IDotNetContextLocation that represents a literal string specification.
ObjectCreationExpressionType | Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.
PreprocessorDirective | Gets the IDotNetContextLocation that represents a preprocessor directive specification.
Type | Gets the IDotNetContextLocation that represents a type name specification.
UsingDirectiveAliasedNamespaceOrType | Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.
UsingDirectiveNamespaceOrType | Gets the IDotNetContextLocation that represents a namespace/type specification within a using directive.
Top
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Attribute Property

VBContextLocationsAttribute Property
Gets the IDotNetContextLocation that represents an attribute specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Attribute { get; }
Public Shared ReadOnly Property Attribute As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Comment Property

VBContextLocationsComment Property
Gets the IDotNetContextLocation that represents a comment specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Comment { get; }
Public Shared ReadOnly Property Comment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.DocumentationComment Property

VBContextLocationsDocumentationComment Property
Gets the IDotNetContextLocation that represents a documentation comment specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation DocumentationComment { get; }
Public Shared ReadOnly Property DocumentationComment As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ExpressionStart Property

VBContextLocationsExpressionStart Property
Gets the IDotNetContextLocation that represents an expression start specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ExpressionStart { get; }
Public Shared ReadOnly Property ExpressionStart As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ImplicitLocalVariableType Property

VBContextLocationsImplicitLocalVariableType Property
Gets the IDotNetContextLocation that represents an implicit local variable type.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ImplicitLocalVariableType { get; }
Public Shared ReadOnly Property ImplicitLocalVariableType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.LiteralCharacter Property

VBContextLocationsLiteralCharacter Property
Gets the IDotNetContextLocation that represents a literal character specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralCharacter { get; }
Public Shared ReadOnly Property LiteralCharacter As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.LiteralString Property

VBContextLocationsLiteralString Property
Gets the IDotNetContextLocation that represents a literal string specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation LiteralString { get; }
Public Shared ReadOnly Property LiteralString As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.ObjectCreationExpressionType Property

VBContextLocationsObjectCreationExpressionType Property
Gets the IDotNetContextLocation that represents a type name specification within an object creation expression.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation ObjectCreationExpressionType { get; }
Public Shared ReadOnly Property ObjectCreationExpressionType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.PreprocessorDirective Property

VBContextLocationsPreprocessorDirective Property
Gets the IDotNetContextLocation that represents a preprocessor directive specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation PreprocessorDirective { get; }
Public Shared ReadOnly Property PreprocessorDirective As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.Type Property

VBContextLocationsType Property
Gets the IDotNetContextLocation that represents a type name specification.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation Type { get; }
Public Shared ReadOnly Property Type As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.UsingDirectiveAliasedNamespaceOrType Property

VBContextLocationsUsingDirectiveAliasedNamespaceOrType Property
Gets the IDotNetContextLocation that represents an aliased namespace/type specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveAliasedNamespaceOrType { get; }
Public Shared ReadOnly Property UsingDirectiveAliasedNamespaceOrType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


VBContextLocations.UsingDirectiveNamespaceOrType Property

VBContextLocationsUsingDirectiveNamespaceOrType Property
Gets the IDotNetContextLocation that represents a namespace/type specification within a using directive.

Namespace: ActiproSoftware.Text.Languages.VB
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetContextLocation UsingDirectiveNamespaceOrType { get; }
Public Shared ReadOnly Property UsingDirectiveNamespaceOrType As IDotNetContextLocation
    Get

Property Value

Type: IDotNetContextLocation
The IDotNetContextLocation value.
See Also

Reference

VBContextLocations Class
ActiproSoftware.Text.Languages.VB Namespace


ActiproSoftware.Text.Languages.VB.Implementation Namespace

ActiproSoftware.Text.Languages.VB.Implementation Namespace
Contains the core classes related to implementing a VB syntax language.
Classes
 | Class | Description
Public class | VBAutoCaseCorrector | Provides a Visual Basic language auto case-correction service.
Public class | VBCodeBlockFinder | Provides a Visual Basic language code block finder service.
Public class | VBCodeSnippetProvider | Provides a Visual Basic language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Public class | VBCompletionProvider | Provides IntelliPrompt completion data for the Visual Basic language.
Public class | VBContextFactory | Creates Visual Basic language IDotNetContext objects for a TextSnapshotOffset.
Public class | VBDocumentationCommentAutoCompleter | Provides a class that can auto-complete Visual Basic language documentation comments when appropriate.
Public class | VBExampleTextProvider | Represents a example text provider for the VB language.
Public class | VBGrammar | Represents a Grammar for the Visual Basic language.
Public class | VBGrammarOptions | Contains options for a Visual Basic grammar.
Public class | VBIndentProvider | Provides a Visual Basic language indent provider service.
Public class | VBLexer | Represents a Visual Basic lexer (lexical analyzer) implementation.
Public class | VBLexicalStateId | Contains the lexical state IDs for the Visual Basic language.
Public class | VBNavigableSymbolProvider | Represents a navigable symbol provider for the Visual Basic language.
Public class | VBOutliner | Provides a Visual Basic language outliner service.
Public class | VBOutliningSource | Represents a Visual Basic language range-based outlining source.
Public class | VBParameterInfoProvider | Provides IntelliPrompt parameter info data for the Visual Basic language.
Public class | VBParser | Represents a parser for the Visual Basic language.
Public class | VBProjectAssembly | Represents a Visual Basic project (source code-based) assembly.
Public class | VBQuickInfoProvider | Provides IntelliPrompt quick info data for the Visual Basic language.
Public class | VBSyntaxLanguage | Represents a Visual Basic syntax language definition.
Public class | VBTextFormatter | Provides a Visual Basic language text formatter service.
Public class | VBTokenId | Contains the token IDs for the Visual Basic language.
Public class | VBTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Visual Basic language.
Public class | VBTokenTagger | Represents an ITaggerT for the Visual Basic language.
Public class | VBTokenTaggerProvider | Represents a provider of VBTokenTagger objects for documents that use the VBTokenTagger language.


VBAutoCaseCorrector Class

VBAutoCaseCorrector Class
Provides a Visual Basic language auto case-correction service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationAutoCorrectorBase
ActiproSoftware.Text.Analysis.ImplementationAutoCaseCorrector
ActiproSoftware.Text.Languages.VB.ImplementationVBAutoCaseCorrector

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBAutoCaseCorrector : AutoCaseCorrector
Public Class VBAutoCaseCorrector
    Inherits AutoCaseCorrector

The VBAutoCaseCorrector type exposes the following members.

Constructors
 | Name | Description
Public method | VBAutoCaseCorrector | Initializes a new instance of the VBAutoCaseCorrector class
Top
Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Inherited from AutoCaseCorrector.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken. (Overrides AutoCaseCorrectorGetCaseCorrectText(ITextSnapshot, IToken).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBAutoCaseCorrector Constructor

VBAutoCaseCorrector Constructor
Initializes a new instance of the VBAutoCaseCorrector class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBAutoCaseCorrector()
Public Sub New
See Also

Reference

VBAutoCaseCorrector Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBAutoCaseCorrector Methods

VBAutoCaseCorrector Methods

The VBAutoCaseCorrector type exposes the following members.

Methods
 | Name | Description
Public method | AutoCorrect | Auto-corrects over the specified TextSnapshotRange. (Inherited from AutoCaseCorrector.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetCaseCorrectText | Returns the case-corrected text for the specified IToken. (Overrides AutoCaseCorrectorGetCaseCorrectText(ITextSnapshot, IToken).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language. (Inherited from AutoCorrectorBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from AutoCorrectorBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBAutoCaseCorrector Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBAutoCaseCorrector.GetCaseCorrectText Method

VBAutoCaseCorrectorGetCaseCorrectText Method
Returns the case-corrected text for the specified IToken.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetCaseCorrectText(
    ITextSnapshot snapshot,
    IToken token
)
Protected Overrides Function GetCaseCorrectText (
    snapshot As ITextSnapshot,
    token As IToken
) As String

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The source ITextSnapshot.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The case-corrected text for the specified IToken. Returns if no case-correction is required.
See Also

Reference

VBAutoCaseCorrector Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Class

VBCodeBlockFinder Class
Provides a Visual Basic language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCodeBlockFinderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBCodeBlockFinder : DotNetCodeBlockFinderBase
Public Class VBCodeBlockFinder
    Inherits DotNetCodeBlockFinderBase

The VBCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | VBCodeBlockFinder | Initializes a new instance of the VBCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Constructor

VBCodeBlockFinder Constructor
Initializes a new instance of the VBCodeBlockFinder class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBCodeBlockFinder()
Public Sub New
See Also

Reference

VBCodeBlockFinder Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Properties

VBCodeBlockFinder Properties

The VBCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

VBCodeBlockFinder Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeBlockFinder Methods

VBCodeBlockFinder Methods

The VBCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

VBCodeBlockFinder Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Class

VBCodeSnippetProvider Class
Provides a Visual Basic language code snippet provider that can manage the available code snippets and handle requests for display of IntelliPrompt code snippet sessions.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCodeSnippetProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBCodeSnippetProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBCodeSnippetProvider : CodeSnippetProvider
Public Class VBCodeSnippetProvider
    Inherits CodeSnippetProvider

The VBCodeSnippetProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBCodeSnippetProvider | Initializes a new instance of the VBCodeSnippetProvider class.
Top
Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Constructor

VBCodeSnippetProvider Constructor
Initializes a new instance of the VBCodeSnippetProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBCodeSnippetProvider()
Public Sub New
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Properties

VBCodeSnippetProvider Properties

The VBCodeSnippetProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseSensitive | Gets or sets whether code snippet shortcut matching requires a case-sensitive match. (Inherited from CodeSnippetProvider.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CodeSnippetProvider.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CodeSnippetProvider.)
Public property | RootFolder | Gets or sets the root ICodeSnippetFolder containing code snippets that are accessible by this provider. (Inherited from CodeSnippetProvider.)
Top
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider Methods

VBCodeSnippetProvider Methods

The VBCodeSnippetProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CheckForShortcut | Checks for a code snippet shortcut before the caret and opens a template session if one was found. (Inherited from CodeSnippetProvider.)
Protected method | CreateSelectionSession | Creates an ICodeSnippetSelectionSession for use with a RequestSelectionSession(IEditorView, CodeSnippetTypes) call. (Inherited from CodeSnippetProvider.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPossibleShortcutSnapshotRange | Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset. (Overrides CodeSnippetProviderGetPossibleShortcutSnapshotRange(TextSnapshotOffset).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnViewKeyDown | Occurs when a key is pressed down while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Protected method | OnViewKeyUp | Occurs when a key is released while focus is in the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestSelectionSession | Requests that an ICodeSnippetSelectionSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | RequestTemplateSession | Requests that an ICodeSnippetTemplateSession be opened for the specified IEditorView. (Inherited from CodeSnippetProvider.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCodeSnippetProvider.GetPossibleShortcutSnapshotRange Method

VBCodeSnippetProviderGetPossibleShortcutSnapshotRange Method
Returns a possible code snippet shortcut TextSnapshotRange, located immediately before the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override TextSnapshotRange GetPossibleShortcutSnapshotRange(
    TextSnapshotOffset snapshotOffset
)
Protected Overrides Function GetPossibleShortcutSnapshotRange (
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotRange

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: TextSnapshotRange
The TextSnapshotRange of the possible shortcut; or TextSnapshotRange.Deleted if there is no possible shortcut.
Remarks
Language implementations may wish to inherit this class and override this method to ensure the shortcut is not within a comment or other literal.
See Also

Reference

VBCodeSnippetProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Class

VBCompletionProvider Class
Provides IntelliPrompt completion data for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationCompletionProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetCompletionProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBCompletionProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBCompletionProvider : DotNetCompletionProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class VBCompletionProvider
    Inherits DotNetCompletionProviderBase
    Implements IEditorDocumentTextChangeEventSink

The VBCompletionProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBCompletionProvider | Initializes a new instance of the VBCompletionProvider class.
Top
Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Constructor

VBCompletionProvider Constructor
Initializes a new instance of the VBCompletionProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBCompletionProvider()
Public Sub New
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Properties

VBCompletionProvider Properties

The VBCompletionProvider type exposes the following members.

Properties
 | Name | Description
Public property | CanShowOnTypedWordStart | Gets or sets whether a completion list can auto-show when typing a new word. (Inherited from DotNetCompletionProviderBase.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from CompletionProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from CompletionProviderBase.)
Top
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider Methods

VBCompletionProvider Methods

The VBCompletionProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetCompletionProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified ICompletionSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetCompletionProviderBase.)
Public method | RequestSession | Requests that an ICompletionSession be opened for the specified IEditorView. (Overrides CompletionProviderBaseRequestSession(IEditorView, Boolean).)
Public method | ShouldShowForTypedWordStart | Returns whether the specified IEditorView supports automatic completion list display at its current caret location. (Overrides DotNetCompletionProviderBaseShouldShowForTypedWordStart(IEditorView).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.CreateContext Method

VBCompletionProviderCreateContext Method
Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.OnDocumentTextChanged Method

VBCompletionProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.OnDocumentTextChanging Method

VBCompletionProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.RequestSession Method

VBCompletionProviderRequestSession Method
Requests that an ICompletionSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view,
    bool canCommitWithoutPopup
)
Public Overrides Function RequestSession (
    view As IEditorView,
    canCommitWithoutPopup As Boolean
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
canCommitWithoutPopup
Type: SystemBoolean
Whether the session can immediately commit if a single match is made when the session is opened, commonly known as "complete word" functionality.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

ICompletionProviderRequestSession(IEditorView, Boolean)
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBCompletionProvider.ShouldShowForTypedWordStart Method

VBCompletionProviderShouldShowForTypedWordStart Method
Returns whether the specified IEditorView supports automatic completion list display at its current caret location.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ShouldShowForTypedWordStart(
    IEditorView view
)
Public Overrides Function ShouldShowForTypedWordStart (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if automatic completion list display is supported; otherwise, false.
See Also

Reference

VBCompletionProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory Class

VBContextFactory Class
Creates Visual Basic language IDotNetContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetContextFactoryBase
ActiproSoftware.Text.Languages.VB.ImplementationVBContextFactory

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBContextFactory : DotNetContextFactoryBase
Public Class VBContextFactory
    Inherits DotNetContextFactoryBase

The VBContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | VBContextFactory | Initializes a new instance of the VBContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory Constructor

VBContextFactory Constructor
Initializes a new instance of the VBContextFactory class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBContextFactory()
Public Sub New
See Also

Reference

VBContextFactory Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory Methods

VBContextFactory Methods

The VBContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetContainingAstNode | Returns the IAstNode that contains the specified offset. (Inherited from DotNetContextFactoryBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | IsQualifiedName | Returns whether the specified Expression can equate to a qualified name. (Inherited from DotNetContextFactoryBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DotNetContextFactoryBase.)
Top
See Also

Reference

VBContextFactory Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory.CreateContext Method

VBContextFactoryCreateContext Method
Overload List
 | Name | Description
Public method | CreateContext(TextSnapshotOffset) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Inherited from DotNetContextFactoryBase.)
Public method | CreateContext(TextSnapshotOffset, DotNetContextKind) | Creates an IDotNetContext for the specified TextSnapshotOffset. (Overrides DotNetContextFactoryBaseCreateContext(TextSnapshotOffset, DotNetContextKind).)
Top
See Also

Reference

VBContextFactory Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBContextFactory.CreateContext Method (TextSnapshotOffset, DotNetContextKind)

VBContextFactoryCreateContext Method (TextSnapshotOffset, DotNetContextKind)
Creates an IDotNetContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IDotNetContext CreateContext(
    TextSnapshotOffset snapshotOffset,
    DotNetContextKind kind
)
Public Overrides Function CreateContext (
    snapshotOffset As TextSnapshotOffset,
    kind As DotNetContextKind
) As IDotNetContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.
kind
Type: ActiproSoftware.Text.Languages.DotNetDotNetContextKind
A DotNetContextKind indicating the kind of context.

Return Value

Type: IDotNetContext
The IDotNetContext that was created.
See Also

Reference

VBContextFactory Class
CreateContext Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Class

VBDocumentationCommentAutoCompleter Class
Provides a class that can auto-complete Visual Basic language documentation comments when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDocumentationCommentAutoCompleterBase
ActiproSoftware.Text.Languages.VB.ImplementationVBDocumentationCommentAutoCompleter

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBDocumentationCommentAutoCompleter : DocumentationCommentAutoCompleterBase,
    IEditorDocumentTextChangeEventSink
Public Class VBDocumentationCommentAutoCompleter
    Inherits DocumentationCommentAutoCompleterBase
    Implements IEditorDocumentTextChangeEventSink

The VBDocumentationCommentAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | VBDocumentationCommentAutoCompleter | Initializes a new instance of the VBDocumentationCommentAutoCompleter class
Top
Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IDocumentationCommentAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Constructor

VBDocumentationCommentAutoCompleter Constructor
Initializes a new instance of the VBDocumentationCommentAutoCompleter class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBDocumentationCommentAutoCompleter()
Public Sub New
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Properties

VBDocumentationCommentAutoCompleter Properties

The VBDocumentationCommentAutoCompleter type exposes the following members.

Properties
 | Name | Description
Public property | IsEndTagCompletionEnabled | Gets or sets whether documentation comment end tag completion is enabled. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsNewLineGenerationEnabled | Gets or sets whether documentation comment delimiter auto-generation is enabled when pressing Enter while in a documentation comment. (Inherited from DocumentationCommentAutoCompleterBase.)
Public property | IsStubGenerationEnabled | Gets or sets whether stub documentation comment auto-generation is enabled when starting to type new documentation comments. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter Methods

VBDocumentationCommentAutoCompleter Methods

The VBDocumentationCommentAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InsertStubDocumentationComment | Attempts to insert a stub documentation comment at the caret's location. (Inherited from DocumentationCommentAutoCompleterBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from DocumentationCommentAutoCompleterBase.)
Top
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter.OnDocumentTextChanged Method

VBDocumentationCommentAutoCompleterOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBDocumentationCommentAutoCompleter.OnDocumentTextChanging Method

VBDocumentationCommentAutoCompleterOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBDocumentationCommentAutoCompleter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Class

VBExampleTextProvider Class
Represents a example text provider for the VB language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VB.ImplementationVBExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBExampleTextProvider : IExampleTextProvider
Public Class VBExampleTextProvider
    Implements IExampleTextProvider

The VBExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBExampleTextProvider | Initializes a new instance of the VBExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Constructor

VBExampleTextProvider Constructor
Initializes a new instance of the VBExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBExampleTextProvider()
Public Sub New
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Properties

VBExampleTextProvider Properties

The VBExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider.ExampleText Property

VBExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBExampleTextProvider Methods

VBExampleTextProvider Methods

The VBExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBExampleTextProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Class

VBGrammar Class
Represents a Grammar for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammar

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBGrammar : DotNetGrammarBase
Public Class VBGrammar
    Inherits DotNetGrammarBase

The VBGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | VBGrammar | Initializes a new instance of the VBGrammar class.
Public method | VBGrammar(IVBGrammarOptions) | Initializes a new instance of the VBGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Constructor

VBGrammar Constructor
Overload List
 | Name | Description
Public method | VBGrammar | Initializes a new instance of the VBGrammar class.
Public method | VBGrammar(IVBGrammarOptions) | Initializes a new instance of the VBGrammar class.
Top
See Also

Reference

VBGrammar Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Constructor

VBGrammar Constructor
Initializes a new instance of the VBGrammar class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBGrammar()
Public Sub New
See Also

Reference

VBGrammar Class
VBGrammar Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Constructor (IVBGrammarOptions)

VBGrammar Constructor (IVBGrammarOptions)
Initializes a new instance of the VBGrammar class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBGrammar(
    IVBGrammarOptions options
)
Public Sub New (
    options As IVBGrammarOptions
)

Parameters

options
Type: ActiproSoftware.Text.Languages.VBIVBGrammarOptions
An IVBGrammarOptions that contains options for the grammar.
See Also

Reference

VBGrammar Class
VBGrammar Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Properties

VBGrammar Properties

The VBGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

VBGrammar Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammar Methods

VBGrammar Methods

The VBGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

VBGrammar Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Class

VBGrammarOptions Class
Contains options for a Visual Basic grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarOptionsBase
ActiproSoftware.Text.Languages.VB.ImplementationVBGrammarOptions

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBGrammarOptions : DotNetGrammarOptionsBase,
    IVBGrammarOptions
Public Class VBGrammarOptions
    Inherits DotNetGrammarOptionsBase
    Implements IVBGrammarOptions

The VBGrammarOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VBGrammarOptions | Initializes a new instance of the VBGrammarOptions class
Top
Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Constructor

VBGrammarOptions Constructor
Initializes a new instance of the VBGrammarOptions class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBGrammarOptions()
Public Sub New
See Also

Reference

VBGrammarOptions Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Properties

VBGrammarOptions Properties

The VBGrammarOptions type exposes the following members.

Properties
 | Name | Description
Public property | RootNonTerminal | Gets or sets a DotNetGrammarRootNonTerminal indicating the root non-terminal of the grammar. (Inherited from DotNetGrammarOptionsBase.)
Top
See Also

Reference

VBGrammarOptions Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBGrammarOptions Methods

VBGrammarOptions Methods

The VBGrammarOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBGrammarOptions Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Class

VBIndentProvider Class
Provides a Visual Basic language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VB.ImplementationVBIndentProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBIndentProvider : IIndentProvider,
    IEditorDocumentTextChangeEventSink
Public Class VBIndentProvider
    Implements IIndentProvider, IEditorDocumentTextChangeEventSink

The VBIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBIndentProvider | Initializes a new instance of the VBIndentProvider class
Top
Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Constructor

VBIndentProvider Constructor
Initializes a new instance of the VBIndentProvider class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBIndentProvider()
Public Sub New
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Properties

VBIndentProvider Properties

The VBIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.Mode Property

VBIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IndentMode Mode { get; }
Public ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider Methods

VBIndentProvider Methods

The VBIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.GetIndentAmount Method

VBIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.OnDocumentTextChanged Method

VBIndentProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBIndentProvider.OnDocumentTextChanging Method

VBIndentProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBIndentProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Class

VBLexer Class
Represents a Visual Basic lexer (lexical analyzer) implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.VB.ImplementationVBLexer

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBLexer : MergableLexerBase
Public Class VBLexer
    Inherits MergableLexerBase

The VBLexer type exposes the following members.

Constructors
 | Name | Description
Public method | VBLexer | Initializes a new instance of the VBLexer class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Public method | IsKeyword | Returns whether the specified identifier is a keyword.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Constructor

VBLexer Constructor
Initializes a new instance of the VBLexer class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBLexer()
Public Sub New
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Properties

VBLexer Properties

The VBLexer type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.LexicalStates Property

VBLexerLexicalStates Property
Gets the collection of lexical states used by this lexer.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
The collection of lexical states used by this lexer.
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Methods

VBLexer Methods

The VBLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from MergableLexerBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Public method | IsKeyword | Returns whether the specified identifier is a keyword.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from MergableLexerBase.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.GetAllLexicalStateTransitions Method

VBLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.GetNextToken Method

VBLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating a lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer.IsKeyword Method

VBLexerIsKeyword Method
Returns whether the specified identifier is a keyword.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsKeyword(
    string identifier
)
Public Function IsKeyword (
    identifier As String
) As Boolean

Parameters

identifier
Type: SystemString
The identifier text.

Return Value

Type: Boolean
true if the specified identifier is a keyword; otherwise, false.
Remarks
This method does't return true for contextual keywords.
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexer Events

VBLexer Events

The VBLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

VBLexer Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Class

VBLexicalStateId Class
Contains the lexical state IDs for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBLexicalStateId

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBLexicalStateId : LexicalStateIdProviderBase
Public Class VBLexicalStateId
    Inherits LexicalStateIdProviderBase

The VBLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | VBLexicalStateId | Initializes a new instance of the VBLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
ImportsStatement | Gets the ImportsStatement lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
XmlNamespaceImportsClause | Gets the XmlNamespaceImportsClause lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Constructor

VBLexicalStateId Constructor
Initializes a new instance of the VBLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBLexicalStateId()
Public Sub New
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Properties

VBLexicalStateId Properties

The VBLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.MaxId Property

VBLexicalStateIdMaxId Property
Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.MinId Property

VBLexicalStateIdMinId Property
Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Methods

VBLexicalStateId Methods

The VBLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.ContainsId Method

VBLexicalStateIdContainsId Method
Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.GetDescription Method

VBLexicalStateIdGetDescription Method
Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.GetKey Method

VBLexicalStateIdGetKey Method
Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId Fields

VBLexicalStateId Fields

The VBLexicalStateId type exposes the following members.

Fields
Name | Description
Default | Gets the Default lexical state ID.
DocumentationComment | Gets the DocumentationComment lexical state ID.
ImportsStatement | Gets the ImportsStatement lexical state ID.
PreprocessorDirective | Gets the PreprocessorDirective lexical state ID.
XmlNamespaceImportsClause | Gets the XmlNamespaceImportsClause lexical state ID.
Top
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.Default Field

VBLexicalStateIdDefault Field
Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Default = 11000
Public Const Default As Integer = 11000

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.DocumentationComment Field

VBLexicalStateIdDocumentationComment Field
Gets the DocumentationComment lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationComment = 11003
Public Const DocumentationComment As Integer = 11003

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.ImportsStatement Field

VBLexicalStateIdImportsStatement Field
Gets the ImportsStatement lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ImportsStatement = 11001
Public Const ImportsStatement As Integer = 11001

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.PreprocessorDirective Field

VBLexicalStateIdPreprocessorDirective Field
Gets the PreprocessorDirective lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirective = 11004
Public Const PreprocessorDirective As Integer = 11004

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBLexicalStateId.XmlNamespaceImportsClause Field

VBLexicalStateIdXmlNamespaceImportsClause Field
Gets the XmlNamespaceImportsClause lexical state ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int XmlNamespaceImportsClause = 11002
Public Const XmlNamespaceImportsClause As Integer = 11002

Field Value

Type: Int32
See Also

Reference

VBLexicalStateId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider Class

VBNavigableSymbolProvider Class
Represents a navigable symbol provider for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetNavigableSymbolProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBNavigableSymbolProvider : DotNetNavigableSymbolProviderBase
Public Class VBNavigableSymbolProvider
    Inherits DotNetNavigableSymbolProviderBase

The VBNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBNavigableSymbolProvider | Initializes a new instance of the VBNavigableSymbolProvider class
Top
Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider Constructor

VBNavigableSymbolProvider Constructor
Initializes a new instance of the VBNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBNavigableSymbolProvider()
Public Sub New
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider Methods

VBNavigableSymbolProvider Methods

The VBNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateTypeMemberSymbol | Creates an INavigableSymbol for a TypeMemberDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeMemberSymbol(TypeMemberDeclaration, ITextSnapshot).)
Protected method | CreateTypeSymbol | Creates an INavigableSymbol for a TypeDeclaration. (Overrides DotNetNavigableSymbolProviderBaseCreateTypeSymbol(TypeDeclaration, ITextSnapshot).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol. (Inherited from DotNetNavigableSymbolProviderBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider.CreateTypeMemberSymbol Method

VBNavigableSymbolProviderCreateTypeMemberSymbol Method
Creates an INavigableSymbol for a TypeMemberDeclaration.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeMemberSymbol(
    TypeMemberDeclaration memberDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeMemberSymbol (
    memberDecl As TypeMemberDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

memberDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
The TypeMemberDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBNavigableSymbolProvider.CreateTypeSymbol Method

VBNavigableSymbolProviderCreateTypeSymbol Method
Creates an INavigableSymbol for a TypeDeclaration.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override INavigableSymbol CreateTypeSymbol(
    TypeDeclaration typeDecl,
    ITextSnapshot snapshot
)
Protected Overrides Function CreateTypeSymbol (
    typeDecl As TypeDeclaration,
    snapshot As ITextSnapshot
) As INavigableSymbol

Parameters

typeDecl
Type: ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
The TypeDeclaration to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

VBNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Class

VBOutliner Class
Provides a Visual Basic language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.VB.ImplementationVBOutliner

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBOutliner : IOutliner
Public Class VBOutliner
    Implements IOutliner

The VBOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | VBOutliner | Initializes a new instance of the VBOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Constructor

VBOutliner Constructor
Initializes a new instance of the VBOutliner class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBOutliner()
Public Sub New
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Properties

VBOutliner Properties

The VBOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner.UpdateTrigger Property

VBOutlinerUpdateTrigger Property
Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner Methods

VBOutliner Methods

The VBOutliner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliner.GetOutliningSource Method

VBOutlinerGetOutliningSource Method
Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

VBOutliner Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource Class

VBOutliningSource Class
Represents a Visual Basic language range-based outlining source.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Outlining.ImplementationRangeOutliningSourceBase
ActiproSoftware.Text.Languages.VB.ImplementationVBOutliningSource

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBOutliningSource : RangeOutliningSourceBase
Public Class VBOutliningSource
    Inherits RangeOutliningSourceBase

The VBOutliningSource type exposes the following members.

Constructors
 | Name | Description
Public method | VBOutliningSource | Initializes a new instance of the VBOutliningSource class.
Top
Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource Constructor

VBOutliningSource Constructor
Initializes a new instance of the VBOutliningSource class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBOutliningSource(
    ITextSnapshot snapshot
)
Public Sub New (
    snapshot As ITextSnapshot
)

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot to use for this outlining source.
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource Methods

VBOutliningSource Methods

The VBOutliningSource type exposes the following members.

Methods
 | Name | Description
Public method | AddNode | Marks that the TextRange is a closed node (has start and proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesRecursive | Recursively adds outlining nodes for a given IAstNode.
Public method | AddOpenNode | Marks that the TextRange is an open node (has start, but no proper end) with the specified IOutliningNodeDefinition. (Inherited from RangeOutliningSourceBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNodeAction | Returns information about the action to take when incrementally updating automatic outlining for a particular offset. (Inherited from RangeOutliningSourceBase.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | TranslateTo | Translates the outlining data to the specified ITextSnapshot. (Inherited from RangeOutliningSourceBase.)
Top
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesFromParseData Method

VBOutliningSourceAddNodesFromParseData Method
Overload List
 | Name | Description
Public method | AddNodesFromParseData(IDotNetParseData) | Adds nodes recursively based on AST information in the specified parse data.
Protected method | AddNodesFromParseData(IDotNetParseData, ITextBufferReader) | Adds nodes recursively based on AST information in the specified parse data.
Top
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesFromParseData Method (IDotNetParseData)

VBOutliningSourceAddNodesFromParseData Method (IDotNetParseData)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddNodesFromParseData(
    IDotNetParseData parseData
)
Public Overridable Sub AddNodesFromParseData (
    parseData As IDotNetParseData
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
See Also

Reference

VBOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)

VBOutliningSourceAddNodesFromParseData Method (IDotNetParseData, ITextBufferReader)
Adds nodes recursively based on AST information in the specified parse data.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void AddNodesFromParseData(
    IDotNetParseData parseData,
    ITextBufferReader reader
)
Protected Sub AddNodesFromParseData (
    parseData As IDotNetParseData,
    reader As ITextBufferReader
)

Parameters

parseData
Type: ActiproSoftware.Text.Languages.DotNetIDotNetParseData
The IDotNetParseData containing AST data.
reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
See Also

Reference

VBOutliningSource Class
AddNodesFromParseData Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBOutliningSource.AddNodesRecursive Method

VBOutliningSourceAddNodesRecursive Method
Recursively adds outlining nodes for a given IAstNode.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void AddNodesRecursive(
    ITextBufferReader reader,
    IAstNode astNode
)
Protected Overridable Sub AddNodesRecursive (
    reader As ITextBufferReader,
    astNode As IAstNode
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The optional ITextBufferReader to use for examining text.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode to examine.
See Also

Reference

VBOutliningSource Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Class

VBParameterInfoProvider Class
Provides IntelliPrompt parameter info data for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationParameterInfoProviderBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParameterInfoProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBParameterInfoProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBParameterInfoProvider : DotNetParameterInfoProviderBase,
    IEditorDocumentTextChangeEventSink
Public Class VBParameterInfoProvider
    Inherits DotNetParameterInfoProviderBase
    Implements IEditorDocumentTextChangeEventSink

The VBParameterInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBParameterInfoProvider | Initializes a new instance of the VBParameterInfoProvider class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Constructor

VBParameterInfoProvider Constructor
Initializes a new instance of the VBParameterInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBParameterInfoProvider()
Public Sub New
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Properties

VBParameterInfoProvider Properties

The VBParameterInfoProvider type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from ParameterInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from ParameterInfoProviderBase.)
Top
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider Methods

VBParameterInfoProvider Methods

The VBParameterInfoProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateContext | Creates an IDotNetContext for the caret's offset in the specified IEditorView. (Overrides DotNetParameterInfoProviderBaseCreateContext(IEditorView).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IParameterInfoSession is opened and displayed to the end user. The session may also be cancelled. (Inherited from DotNetParameterInfoProviderBase.)
Protected method | OnViewSelectionChanged | Occurs when the selection is changed in the specified IEditorView. (Inherited from DotNetParameterInfoProviderBase.)
Public method | RequestSession | Requests that an IParameterInfoSession be opened for the specified IEditorView. (Overrides ParameterInfoProviderBaseRequestSession(IEditorView).)
Public method | ToString | (Inherited from Object.)
Protected method | UpdateCurrentParameter | Updates the current parameter in the session's signatures, based on information in the specified IDotNetContext. (Inherited from DotNetParameterInfoProviderBase.)
Top
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.CreateContext Method

VBParameterInfoProviderCreateContext Method
Creates an IDotNetContext for the caret's offset in the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IDotNetContext CreateContext(
    IEditorView view
)
Protected Overrides Function CreateContext (
    view As IEditorView
) As IDotNetContext

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: IDotNetContext
An IDotNetContext for the caret's offset in the specified IEditorView.
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.OnDocumentTextChanged Method

VBParameterInfoProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.OnDocumentTextChanging Method

VBParameterInfoProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParameterInfoProvider.RequestSession Method

VBParameterInfoProviderRequestSession Method
Requests that an IParameterInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequestSession(
    IEditorView view
)
Public Overrides Function RequestSession (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.

Return Value

Type: Boolean
true if a session was opened; otherwise, false.

Implements

IParameterInfoProviderRequestSession(IEditorView)
See Also

Reference

VBParameterInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Class

VBParser Class
Represents a parser for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.VB.ImplementationVBParser

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBParser : DotNetParserBase
Public Class VBParser
    Inherits DotNetParserBase

The VBParser type exposes the following members.

Constructors
 | Name | Description
Public method | VBParser | Initializes a new instance of the VBParser class.
Public method | VBParser(Grammar) | Initializes a new instance of the VBParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Constructor

VBParser Constructor
Overload List
 | Name | Description
Public method | VBParser | Initializes a new instance of the VBParser class.
Public method | VBParser(Grammar) | Initializes a new instance of the VBParser class.
Top
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Constructor

VBParser Constructor
Initializes a new instance of the VBParser class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBParser()
Public Sub New
See Also

Reference

VBParser Class
VBParser Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Constructor (Grammar)

VBParser Constructor (Grammar)
Initializes a new instance of the VBParser class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

VBParser Class
VBParser Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Properties

VBParser Properties

The VBParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser Methods

VBParser Methods

The VBParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from DotNetParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Overrides LLParserBaseInitializeParseData(LLParseData, IParserState).)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
 | ParseExpression | Parses the specified expression text.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.CreateTokenReader Method

VBParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.InitializeParseData Method

VBParserInitializeParseData Method
Initializes a LLParseData using the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParseData(
    LLParseData parseData,
    IParserState state
)
Protected Overrides Sub InitializeParseData (
    parseData As LLParseData,
    state As IParserState
)

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
The LLParseData to initialize.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
Remarks
This method is called by default from the CreateParseData(IParseRequest, IParserState) method.
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.InitializeParserState Method

VBParserInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBParser.ParseExpression Method

VBParserParseExpression Method
Parses the specified expression text.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IDotNetParseData ParseExpression(
    string text
)
Public Shared Function ParseExpression (
    text As String
) As IDotNetParseData

Parameters

text
Type: SystemString
The expression text to parse.

Return Value

Type: IDotNetParseData
The IDotNetParseData that contains the parse results.
See Also

Reference

VBParser Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Class

VBProjectAssembly Class
Represents a Visual Basic project (source code-based) assembly.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.Reflection.ImplementationProjectAssembly
ActiproSoftware.Text.Languages.VB.ImplementationVBProjectAssembly

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBProjectAssembly : ProjectAssembly
Public Class VBProjectAssembly
    Inherits ProjectAssembly

The VBProjectAssembly type exposes the following members.

Constructors
 | Name | Description
Public method | VBProjectAssembly(String) | Initializes a new instance of the VBProjectAssembly class.
Public method | VBProjectAssembly(IAssemblyName) | Initializes a new instance of the VBProjectAssembly class.
Top
Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Constructor

VBProjectAssembly Constructor
Overload List
 | Name | Description
Public method | VBProjectAssembly(String) | Initializes a new instance of the VBProjectAssembly class.
Public method | VBProjectAssembly(IAssemblyName) | Initializes a new instance of the VBProjectAssembly class.
Top
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Constructor (String)

VBProjectAssembly Constructor (String)
Initializes a new instance of the VBProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBProjectAssembly(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The simple name of the assembly.
See Also

Reference

VBProjectAssembly Class
VBProjectAssembly Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Constructor (IAssemblyName)

VBProjectAssembly Constructor (IAssemblyName)
Initializes a new instance of the VBProjectAssembly class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBProjectAssembly(
    IAssemblyName assemblyName
)
Public Sub New (
    assemblyName As IAssemblyName
)

Parameters

assemblyName
Type: ActiproSoftware.Text.Languages.DotNet.ReflectionIAssemblyName
An IAssemblyName that contains assembly name information.
See Also

Reference

VBProjectAssembly Class
VBProjectAssembly Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Properties

VBProjectAssembly Properties

The VBProjectAssembly type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences | Gets the collection of assembly references for this assembly. (Inherited from ProjectAssembly.)
Public property | Documentation | Gets or sets the IAssemblyDocumentation that provides access to this assembly's type and member documentation. (Inherited from ProjectAssembly.)
Public property | GlobalNamespace | Gets the entry point into the INamespaceDefinition tree defined in this assembly. (Inherited from ProjectAssembly.)
Protected property | IsLanguageCaseSensitive | Gets whether the language associated with this project assembly is case-sensitive. (Overrides ProjectAssemblyIsLanguageCaseSensitive.)
Public property | Name | Gets the simple name of the assembly. (Inherited from ProjectAssembly.)
Public property | Namespaces | Gets the collection of INamespaceDefinition objects defined in this assembly. (Inherited from ProjectAssembly.)
Public property | Resolver | Gets the IResolver to use for this project assembly. (Overrides ProjectAssemblyResolver.)
Public property | SourceFiles | Gets the collection of source files in this project assembly. (Inherited from ProjectAssembly.)
Top
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly.IsLanguageCaseSensitive Property

VBProjectAssemblyIsLanguageCaseSensitive Property
Gets whether the language associated with this project assembly is case-sensitive.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsLanguageCaseSensitive { get; }
Protected Overrides ReadOnly Property IsLanguageCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the language associated with this project assembly is case-sensitive; otherwise, false.
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly.Resolver Property

VBProjectAssemblyResolver Property
Gets the IResolver to use for this project assembly.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IResolver Resolver { get; }
Public Overrides ReadOnly Property Resolver As IResolver
    Get

Property Value

Type: IResolver
The IResolver to use for this project assembly.

Implements

IProjectAssemblyResolver
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBProjectAssembly Methods

VBProjectAssembly Methods

The VBProjectAssembly type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAssemblyName | Returns an IAssemblyName that contains assembly name information. (Inherited from ProjectAssembly.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from ProjectAssembly.)
Public method | ToTreeString | Outputs the contents of the assembly in tree form. (Inherited from ProjectAssembly.)
Top
See Also

Reference

VBProjectAssembly Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Class

VBQuickInfoProvider Class
Provides IntelliPrompt quick info data for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBQuickInfoProvider : QuickInfoProviderBase
Public Class VBQuickInfoProvider
    Inherits QuickInfoProviderBase

The VBQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBQuickInfoProvider | Initializes a new instance of the VBQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Constructor

VBQuickInfoProvider Constructor
Initializes a new instance of the VBQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBQuickInfoProvider()
Public Sub New
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Properties

VBQuickInfoProvider Properties

The VBQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.ContextTypes Property

VBQuickInfoProviderContextTypes Property
Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider Methods

VBQuickInfoProvider Methods

The VBQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.GetContext Method

VBQuickInfoProviderGetContext Method
Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.GetContext Method (IEditorView, Int32)

VBQuickInfoProviderGetContext Method (IEditorView, Int32)
Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

VBQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.OnSessionOpening Method

VBQuickInfoProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.RequestSession Method

VBQuickInfoProviderRequestSession Method
Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

VBQuickInfoProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBQuickInfoProvider.RequestSession Method (IEditorView, Object)

VBQuickInfoProviderRequestSession Method (IEditorView, Object)
Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

VBQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Class

VBSyntaxLanguage Class
Represents a Visual Basic syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetSyntaxLanguageBase
ActiproSoftware.Text.Languages.VB.ImplementationVBSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBSyntaxLanguage : DotNetSyntaxLanguageBase,
    ITextViewLifecycleEventSink
Public Class VBSyntaxLanguage
    Inherits DotNetSyntaxLanguageBase
    Implements ITextViewLifecycleEventSink

The VBSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | VBSyntaxLanguage | Initializes a new instance of the VBSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Constructor

VBSyntaxLanguage Constructor
Initializes a new instance of the VBSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBSyntaxLanguage()
Public Sub New
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Properties

VBSyntaxLanguage Properties

The VBSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Methods

VBSyntaxLanguage Methods

The VBSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentAttached | Occurs when the specified ICodeDocument is attached to the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentDetached | Occurs when the specified ICodeDocument is detached from the language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentFileNameChanged | Occurs after the FileName property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnDocumentParseDataChanged | Occurs after the ParseData property is changed on an ICodeDocument that uses this language. (Inherited from DotNetSyntaxLanguageBase.)
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBSyntaxLanguage Events

VBSyntaxLanguage Events

The VBSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

VBSyntaxLanguage Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Class

VBTextFormatter Class
Provides a Visual Basic language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetTextFormatterBase
ActiproSoftware.Text.Languages.VB.ImplementationVBTextFormatter

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBTextFormatter : DotNetTextFormatterBase
Public Class VBTextFormatter
    Inherits DotNetTextFormatterBase

The VBTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | VBTextFormatter | Initializes a new instance of the VBTextFormatter class
Top
Properties
 | Name | Description
Public property | OpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range. (Overrides DotNetTextFormatterBaseFormat(TextSnapshotRange).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Constructor

VBTextFormatter Constructor
Initializes a new instance of the VBTextFormatter class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBTextFormatter()
Public Sub New
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Properties

VBTextFormatter Properties

The VBTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | OpeningBraceOnNewLine | Gets or sets a value indicating whether opening braces are on new lines.
Top
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter.OpeningBraceOnNewLine Property

VBTextFormatterOpeningBraceOnNewLine Property
Gets or sets a value indicating whether opening braces are on new lines.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OpeningBraceOnNewLine { get; set; }
Public Property OpeningBraceOnNewLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the opening braces are on new lines; otherwise, false.
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter Methods

VBTextFormatter Methods

The VBTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range. (Overrides DotNetTextFormatterBaseFormat(TextSnapshotRange).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTextFormatter.Format Method

VBTextFormatterFormat Method
Formats the specified snapshot range.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.SyntaxEditor.Addons.DotNet.Universal (in AS.SyntaxEditor.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Format(
    TextSnapshotRange snapshotRange
)
Public Overrides Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The snapshot range.

Implements

ITextFormatterFormat(TextSnapshotRange)
See Also

Reference

VBTextFormatter Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Class

VBTokenId Class
Contains the token IDs for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenId

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBTokenId : TokenIdProviderBase
Public Class VBTokenId
    Inherits TokenIdProviderBase

The VBTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenId | Initializes a new instance of the VBTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsVBXmlLiteralClassificationType | Returns whether the specified ID value is part of the VBXmlLiteral.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
ColonEquals | Gets the ColonEquals token ID.
Comma | Gets the Comma token ID.
CommentRem | Gets the CommentRem token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAggregate | Gets the ContextualKeywordAggregate token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordCustom | Gets the ContextualKeywordCustom token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordDistinct | Gets the ContextualKeywordDistinct token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordIIf | Gets the ContextualKeywordIIf token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordIsFalse | Gets the ContextualKeywordIsFalse token ID.
ContextualKeywordIsTrue | Gets the ContextualKeywordIsTrue token ID.
ContextualKeywordIterator | Gets the ContextualKeywordIterator token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordMid | Gets the ContextualKeywordMid token ID.
ContextualKeywordOrder | Gets the ContextualKeywordOrder token ID.
ContextualKeywordOut | Gets the ContextualKeywordOut token ID.
ContextualKeywordSkip | Gets the ContextualKeywordSkip token ID.
ContextualKeywordTake | Gets the ContextualKeywordTake token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
DotAt | Gets the DotAt token ID.
ExclamationPoint | Gets the ExclamationPoint token ID.
Identifier | Gets the Identifier token ID.
KeywordAddHandler | Gets the KeywordAddHandler token ID.
KeywordAddressOf | Gets the KeywordAddressOf token ID.
KeywordAlias | Gets the KeywordAlias token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAndAlso | Gets the KeywordAndAlso token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBoolean | Gets the KeywordBoolean token ID.
KeywordByRef | Gets the KeywordByRef token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordByVal | Gets the KeywordByVal token ID.
KeywordCall | Gets the KeywordCall token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordCBool | Gets the KeywordCBool token ID.
KeywordCByte | Gets the KeywordCByte token ID.
KeywordCChar | Gets the KeywordCChar token ID.
KeywordCDate | Gets the KeywordCDate token ID.
KeywordCDbl | Gets the KeywordCDbl token ID.
KeywordCDec | Gets the KeywordCDec token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordCInt | Gets the KeywordCInt token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordCLng | Gets the KeywordCLng token ID.
KeywordCObj | Gets the KeywordCObj token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordCSByte | Gets the KeywordCSByte token ID.
KeywordCShort | Gets the KeywordCShort token ID.
KeywordCSng | Gets the KeywordCSng token ID.
KeywordCStr | Gets the KeywordCStr token ID.
KeywordCType | Gets the KeywordCType token ID.
KeywordCUInt | Gets the KeywordCUInt token ID.
KeywordCULng | Gets the KeywordCULng token ID.
KeywordCUShort | Gets the KeywordCUShort token ID.
KeywordDate | Gets the KeywordDate token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDeclare | Gets the KeywordDeclare token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDim | Gets the KeywordDim token ID.
KeywordDirectCast | Gets the KeywordDirectCast token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordEach | Gets the KeywordEach token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordElseIf | Gets the KeywordElseIf token ID.
KeywordEnd | Gets the KeywordEnd token ID.
KeywordEndIf | Gets the KeywordEndIf token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordErase | Gets the KeywordErase token ID.
KeywordError | Gets the KeywordError token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExit | Gets the KeywordExit token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFriend | Gets the KeywordFriend token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordGet | Gets the KeywordGet token ID.
KeywordGetType | Gets the KeywordGetType token ID.
KeywordGetXmlNamespace | Gets the KeywordGetXmlNamespace token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordGoSub | Gets the KeywordGoSub token ID.
KeywordGoTo | Gets the KeywordGoTo token ID.
KeywordHandles | Gets the KeywordHandles token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplements | Gets the KeywordImplements token ID.
KeywordImports | Gets the KeywordImports token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInherits | Gets the KeywordInherits token ID.
KeywordInteger | Gets the KeywordInteger token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordIsNot | Gets the KeywordIsNot token ID.
KeywordLet | Gets the KeywordLet token ID.
KeywordLib | Gets the KeywordLib token ID.
KeywordLike | Gets the KeywordLike token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordLoop | Gets the KeywordLoop token ID.
KeywordMe | Gets the KeywordMe token ID.
KeywordMod | Gets the KeywordMod token ID.
KeywordModule | Gets the KeywordModule token ID.
KeywordMustInherit | Gets the KeywordMustInherit token ID.
KeywordMustOverride | Gets the KeywordMustOverride token ID.
KeywordMyBase | Gets the KeywordMyBase token ID.
KeywordMyClass | Gets the KeywordMyClass token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNarrowing | Gets the KeywordNarrowing token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNext | Gets the KeywordNext token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordNothing | Gets the KeywordNothing token ID.
KeywordNotInheritable | Gets the KeywordNotInheritable token ID.
KeywordNotOverridable | Gets the KeywordNotOverridable token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOf | Gets the KeywordOf token ID.
KeywordOn | Gets the KeywordOn token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOption | Gets the KeywordOption token ID.
KeywordOptional | Gets the KeywordOptional token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordOrElse | Gets the KeywordOrElse token ID.
KeywordOverloads | Gets the KeywordOverloads token ID.
KeywordOverridable | Gets the KeywordOverridable token ID.
KeywordOverrides | Gets the KeywordOverrides token ID.
KeywordParamArray | Gets the KeywordParamArray token ID.
KeywordPartial | Gets the KeywordPartial token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProperty | Gets the KeywordProperty token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordRaiseEvent | Gets the KeywordRaiseEvent token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordReDim | Gets the KeywordReDim token ID.
KeywordREM | Gets the KeywordREM token ID.
KeywordRemoveHandler | Gets the KeywordRemoveHandler token ID.
KeywordResume | Gets the KeywordResume token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSelect | Gets the KeywordSelect token ID.
KeywordSet | Gets the KeywordSet token ID.
KeywordShadows | Gets the KeywordShadows token ID.
KeywordShared | Gets the KeywordShared token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSingle | Gets the KeywordSingle token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordStep | Gets the KeywordStep token ID.
KeywordStop | Gets the KeywordStop token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStructure | Gets the KeywordStructure token ID.
KeywordSub | Gets the KeywordSub token ID.
KeywordSyncLock | Gets the KeywordSyncLock token ID.
KeywordThen | Gets the KeywordThen token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTo | Gets the KeywordTo token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTryCast | Gets the KeywordTryCast token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInteger | Gets the KeywordUInteger token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUntil | Gets the KeywordUntil token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVariant | Gets the KeywordVariant token ID.
KeywordWend | Gets the KeywordWend token ID.
KeywordWhen | Gets the KeywordWhen token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWidening | Gets the KeywordWidening token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordWithEvents | Gets the KeywordWithEvents token ID.
KeywordWriteOnly | Gets the KeywordWriteOnly token ID.
KeywordXor | Gets the KeywordXor token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDate | Gets the LiteralDate token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralFloatingPoint | Gets the LiteralFloatingPoint token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralString | Gets the LiteralString token ID.
LiteralXml | Gets the LiteralXml token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExponentiation | Gets the OperatorExponentiation token ID.
OperatorExponentiationAssignment | Gets the OperatorExponentiationAssignment token ID.
OperatorFloatingPointDivision | Gets the OperatorFloatingPointDivision token ID.
OperatorFloatingPointDivisionAssignment | Gets the OperatorFloatingPointDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorIntegerDivision | Gets the OperatorIntegerDivision token ID.
OperatorIntegerDivisionAssignment | Gets the OperatorIntegerDivisionAssignment token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStringConcatenation | Gets the OperatorStringConcatenation token ID.
OperatorStringConcatenationAssignment | Gets the OperatorStringConcatenationAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordConst | Gets the PreprocessorDirectiveKeywordConst token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordElseIf | Gets the PreprocessorDirectiveKeywordElseIf token ID.
PreprocessorDirectiveKeywordEndExternalSource | Gets the PreprocessorDirectiveKeywordEndExternalSource token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordExternalChecksum | Gets the PreprocessorDirectiveKeywordExternalChecksum token ID.
PreprocessorDirectiveKeywordExternalSource | Gets the PreprocessorDirectiveKeywordExternalSource token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
TripleDot | Gets the TripleDot token ID.
Whitespace | Gets the Whitespace token ID.
XmlAttribute | Gets the XmlAttribute token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v13.2.590.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Constructor

VBTokenId Constructor
Initializes a new instance of the VBTokenId class

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBTokenId()
Public Sub New
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Properties

VBTokenId Properties

The VBTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.MaxId Property

VBTokenIdMaxId Property
Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.MinId Property

VBTokenIdMinId Property
Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Methods

VBTokenId Methods

The VBTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsCommentClassificationType | Returns whether the specified ID value is part of the Comment.
 | IsIdentifierClassificationType | Returns whether the specified ID value is part of the Identifier.
 | IsKeywordClassificationType | Returns whether the specified ID value is part of the Keyword.
 | IsNumberClassificationType | Returns whether the specified ID value is part of the Number.
 | IsOperatorClassificationType | Returns whether the specified ID value is part of the Operator.
 | IsPreprocessorKeywordClassificationType | Returns whether the specified ID value is part of the PreprocessorKeyword.
 | IsStringClassificationType | Returns whether the specified ID value is part of the String.
 | IsVBXmlLiteralClassificationType | Returns whether the specified ID value is part of the VBXmlLiteral.
 | IsXmlDocumentationCommentClassificationType | Returns whether the specified ID value is part of the XmlDocumentationComment.
 | IsXmlDocumentationTagClassificationType | Returns whether the specified ID value is part of the XmlDocumentationTag.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContainsId Method

VBTokenIdContainsId Method
Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.GetDescription Method

VBTokenIdGetDescription Method
Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.GetKey Method

VBTokenIdGetKey Method
Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsCommentClassificationType Method

VBTokenIdIsCommentClassificationType Method
Returns whether the specified ID value is part of the Comment.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsCommentClassificationType(
    int id
)
Public Shared Function IsCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsIdentifierClassificationType Method

VBTokenIdIsIdentifierClassificationType Method
Returns whether the specified ID value is part of the Identifier.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsIdentifierClassificationType(
    int id
)
Public Shared Function IsIdentifierClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsKeywordClassificationType Method

VBTokenIdIsKeywordClassificationType Method
Returns whether the specified ID value is part of the Keyword.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsKeywordClassificationType(
    int id
)
Public Shared Function IsKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsNumberClassificationType Method

VBTokenIdIsNumberClassificationType Method
Returns whether the specified ID value is part of the Number.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsNumberClassificationType(
    int id
)
Public Shared Function IsNumberClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsOperatorClassificationType Method

VBTokenIdIsOperatorClassificationType Method
Returns whether the specified ID value is part of the Operator.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsOperatorClassificationType(
    int id
)
Public Shared Function IsOperatorClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsPreprocessorKeywordClassificationType Method

VBTokenIdIsPreprocessorKeywordClassificationType Method
Returns whether the specified ID value is part of the PreprocessorKeyword.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsPreprocessorKeywordClassificationType(
    int id
)
Public Shared Function IsPreprocessorKeywordClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsStringClassificationType Method

VBTokenIdIsStringClassificationType Method
Returns whether the specified ID value is part of the String.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsStringClassificationType(
    int id
)
Public Shared Function IsStringClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsVBXmlLiteralClassificationType Method

VBTokenIdIsVBXmlLiteralClassificationType Method
Returns whether the specified ID value is part of the VBXmlLiteral.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsVBXmlLiteralClassificationType(
    int id
)
Public Shared Function IsVBXmlLiteralClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsXmlDocumentationCommentClassificationType Method

VBTokenIdIsXmlDocumentationCommentClassificationType Method
Returns whether the specified ID value is part of the XmlDocumentationComment.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationCommentClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.IsXmlDocumentationTagClassificationType Method

VBTokenIdIsXmlDocumentationTagClassificationType Method
Returns whether the specified ID value is part of the XmlDocumentationTag.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlDocumentationTagClassificationType(
    int id
)
Public Shared Function IsXmlDocumentationTagClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId Fields

VBTokenId Fields

The VBTokenId type exposes the following members.

Fields
Name | Description
CloseCurlyBrace | Gets the CloseCurlyBrace token ID.
CloseParenthesis | Gets the CloseParenthesis token ID.
CloseSquareBrace | Gets the CloseSquareBrace token ID.
Colon | Gets the Colon token ID.
ColonEquals | Gets the ColonEquals token ID.
Comma | Gets the Comma token ID.
CommentRem | Gets the CommentRem token ID.
CommentSingleLine | Gets the CommentSingleLine token ID.
ContextualKeywordAggregate | Gets the ContextualKeywordAggregate token ID.
ContextualKeywordAscending | Gets the ContextualKeywordAscending token ID.
ContextualKeywordAsync | Gets the ContextualKeywordAsync token ID.
ContextualKeywordAwait | Gets the ContextualKeywordAwait token ID.
ContextualKeywordBy | Gets the ContextualKeywordBy token ID.
ContextualKeywordCustom | Gets the ContextualKeywordCustom token ID.
ContextualKeywordDescending | Gets the ContextualKeywordDescending token ID.
ContextualKeywordDistinct | Gets the ContextualKeywordDistinct token ID.
ContextualKeywordEquals | Gets the ContextualKeywordEquals token ID.
ContextualKeywordFrom | Gets the ContextualKeywordFrom token ID.
ContextualKeywordGroup | Gets the ContextualKeywordGroup token ID.
ContextualKeywordIIf | Gets the ContextualKeywordIIf token ID.
ContextualKeywordInto | Gets the ContextualKeywordInto token ID.
ContextualKeywordIsFalse | Gets the ContextualKeywordIsFalse token ID.
ContextualKeywordIsTrue | Gets the ContextualKeywordIsTrue token ID.
ContextualKeywordIterator | Gets the ContextualKeywordIterator token ID.
ContextualKeywordJoin | Gets the ContextualKeywordJoin token ID.
ContextualKeywordMid | Gets the ContextualKeywordMid token ID.
ContextualKeywordOrder | Gets the ContextualKeywordOrder token ID.
ContextualKeywordOut | Gets the ContextualKeywordOut token ID.
ContextualKeywordSkip | Gets the ContextualKeywordSkip token ID.
ContextualKeywordTake | Gets the ContextualKeywordTake token ID.
ContextualKeywordWhere | Gets the ContextualKeywordWhere token ID.
ContextualKeywordYield | Gets the ContextualKeywordYield token ID.
DocumentationCommentDelimiter | Gets the DocumentationCommentDelimiter token ID.
DocumentationCommentTag | Gets the DocumentationCommentTag token ID.
DocumentationCommentText | Gets the DocumentationCommentText token ID.
Dot | Gets the Dot token ID.
DotAt | Gets the DotAt token ID.
ExclamationPoint | Gets the ExclamationPoint token ID.
Identifier | Gets the Identifier token ID.
KeywordAddHandler | Gets the KeywordAddHandler token ID.
KeywordAddressOf | Gets the KeywordAddressOf token ID.
KeywordAlias | Gets the KeywordAlias token ID.
KeywordAnd | Gets the KeywordAnd token ID.
KeywordAndAlso | Gets the KeywordAndAlso token ID.
KeywordAs | Gets the KeywordAs token ID.
KeywordBoolean | Gets the KeywordBoolean token ID.
KeywordByRef | Gets the KeywordByRef token ID.
KeywordByte | Gets the KeywordByte token ID.
KeywordByVal | Gets the KeywordByVal token ID.
KeywordCall | Gets the KeywordCall token ID.
KeywordCase | Gets the KeywordCase token ID.
KeywordCatch | Gets the KeywordCatch token ID.
KeywordCBool | Gets the KeywordCBool token ID.
KeywordCByte | Gets the KeywordCByte token ID.
KeywordCChar | Gets the KeywordCChar token ID.
KeywordCDate | Gets the KeywordCDate token ID.
KeywordCDbl | Gets the KeywordCDbl token ID.
KeywordCDec | Gets the KeywordCDec token ID.
KeywordChar | Gets the KeywordChar token ID.
KeywordCInt | Gets the KeywordCInt token ID.
KeywordClass | Gets the KeywordClass token ID.
KeywordCLng | Gets the KeywordCLng token ID.
KeywordCObj | Gets the KeywordCObj token ID.
KeywordConst | Gets the KeywordConst token ID.
KeywordContinue | Gets the KeywordContinue token ID.
KeywordCSByte | Gets the KeywordCSByte token ID.
KeywordCShort | Gets the KeywordCShort token ID.
KeywordCSng | Gets the KeywordCSng token ID.
KeywordCStr | Gets the KeywordCStr token ID.
KeywordCType | Gets the KeywordCType token ID.
KeywordCUInt | Gets the KeywordCUInt token ID.
KeywordCULng | Gets the KeywordCULng token ID.
KeywordCUShort | Gets the KeywordCUShort token ID.
KeywordDate | Gets the KeywordDate token ID.
KeywordDecimal | Gets the KeywordDecimal token ID.
KeywordDeclare | Gets the KeywordDeclare token ID.
KeywordDefault | Gets the KeywordDefault token ID.
KeywordDelegate | Gets the KeywordDelegate token ID.
KeywordDim | Gets the KeywordDim token ID.
KeywordDirectCast | Gets the KeywordDirectCast token ID.
KeywordDo | Gets the KeywordDo token ID.
KeywordDouble | Gets the KeywordDouble token ID.
KeywordEach | Gets the KeywordEach token ID.
KeywordElse | Gets the KeywordElse token ID.
KeywordElseIf | Gets the KeywordElseIf token ID.
KeywordEnd | Gets the KeywordEnd token ID.
KeywordEndIf | Gets the KeywordEndIf token ID.
KeywordEnum | Gets the KeywordEnum token ID.
KeywordErase | Gets the KeywordErase token ID.
KeywordError | Gets the KeywordError token ID.
KeywordEvent | Gets the KeywordEvent token ID.
KeywordExit | Gets the KeywordExit token ID.
KeywordFalse | Gets the KeywordFalse token ID.
KeywordFinally | Gets the KeywordFinally token ID.
KeywordFor | Gets the KeywordFor token ID.
KeywordFriend | Gets the KeywordFriend token ID.
KeywordFunction | Gets the KeywordFunction token ID.
KeywordGet | Gets the KeywordGet token ID.
KeywordGetType | Gets the KeywordGetType token ID.
KeywordGetXmlNamespace | Gets the KeywordGetXmlNamespace token ID.
KeywordGlobal | Gets the KeywordGlobal token ID.
KeywordGoSub | Gets the KeywordGoSub token ID.
KeywordGoTo | Gets the KeywordGoTo token ID.
KeywordHandles | Gets the KeywordHandles token ID.
KeywordIf | Gets the KeywordIf token ID.
KeywordImplements | Gets the KeywordImplements token ID.
KeywordImports | Gets the KeywordImports token ID.
KeywordIn | Gets the KeywordIn token ID.
KeywordInherits | Gets the KeywordInherits token ID.
KeywordInteger | Gets the KeywordInteger token ID.
KeywordInterface | Gets the KeywordInterface token ID.
KeywordIs | Gets the KeywordIs token ID.
KeywordIsNot | Gets the KeywordIsNot token ID.
KeywordLet | Gets the KeywordLet token ID.
KeywordLib | Gets the KeywordLib token ID.
KeywordLike | Gets the KeywordLike token ID.
KeywordLong | Gets the KeywordLong token ID.
KeywordLoop | Gets the KeywordLoop token ID.
KeywordMe | Gets the KeywordMe token ID.
KeywordMod | Gets the KeywordMod token ID.
KeywordModule | Gets the KeywordModule token ID.
KeywordMustInherit | Gets the KeywordMustInherit token ID.
KeywordMustOverride | Gets the KeywordMustOverride token ID.
KeywordMyBase | Gets the KeywordMyBase token ID.
KeywordMyClass | Gets the KeywordMyClass token ID.
KeywordNamespace | Gets the KeywordNamespace token ID.
KeywordNarrowing | Gets the KeywordNarrowing token ID.
KeywordNew | Gets the KeywordNew token ID.
KeywordNext | Gets the KeywordNext token ID.
KeywordNot | Gets the KeywordNot token ID.
KeywordNothing | Gets the KeywordNothing token ID.
KeywordNotInheritable | Gets the KeywordNotInheritable token ID.
KeywordNotOverridable | Gets the KeywordNotOverridable token ID.
KeywordObject | Gets the KeywordObject token ID.
KeywordOf | Gets the KeywordOf token ID.
KeywordOn | Gets the KeywordOn token ID.
KeywordOperator | Gets the KeywordOperator token ID.
KeywordOption | Gets the KeywordOption token ID.
KeywordOptional | Gets the KeywordOptional token ID.
KeywordOr | Gets the KeywordOr token ID.
KeywordOrElse | Gets the KeywordOrElse token ID.
KeywordOverloads | Gets the KeywordOverloads token ID.
KeywordOverridable | Gets the KeywordOverridable token ID.
KeywordOverrides | Gets the KeywordOverrides token ID.
KeywordParamArray | Gets the KeywordParamArray token ID.
KeywordPartial | Gets the KeywordPartial token ID.
KeywordPrivate | Gets the KeywordPrivate token ID.
KeywordProperty | Gets the KeywordProperty token ID.
KeywordProtected | Gets the KeywordProtected token ID.
KeywordPublic | Gets the KeywordPublic token ID.
KeywordRaiseEvent | Gets the KeywordRaiseEvent token ID.
KeywordReadOnly | Gets the KeywordReadOnly token ID.
KeywordReDim | Gets the KeywordReDim token ID.
KeywordREM | Gets the KeywordREM token ID.
KeywordRemoveHandler | Gets the KeywordRemoveHandler token ID.
KeywordResume | Gets the KeywordResume token ID.
KeywordReturn | Gets the KeywordReturn token ID.
KeywordSByte | Gets the KeywordSByte token ID.
KeywordSelect | Gets the KeywordSelect token ID.
KeywordSet | Gets the KeywordSet token ID.
KeywordShadows | Gets the KeywordShadows token ID.
KeywordShared | Gets the KeywordShared token ID.
KeywordShort | Gets the KeywordShort token ID.
KeywordSingle | Gets the KeywordSingle token ID.
KeywordStatic | Gets the KeywordStatic token ID.
KeywordStep | Gets the KeywordStep token ID.
KeywordStop | Gets the KeywordStop token ID.
KeywordString | Gets the KeywordString token ID.
KeywordStructure | Gets the KeywordStructure token ID.
KeywordSub | Gets the KeywordSub token ID.
KeywordSyncLock | Gets the KeywordSyncLock token ID.
KeywordThen | Gets the KeywordThen token ID.
KeywordThrow | Gets the KeywordThrow token ID.
KeywordTo | Gets the KeywordTo token ID.
KeywordTrue | Gets the KeywordTrue token ID.
KeywordTry | Gets the KeywordTry token ID.
KeywordTryCast | Gets the KeywordTryCast token ID.
KeywordTypeOf | Gets the KeywordTypeOf token ID.
KeywordUInteger | Gets the KeywordUInteger token ID.
KeywordULong | Gets the KeywordULong token ID.
KeywordUntil | Gets the KeywordUntil token ID.
KeywordUShort | Gets the KeywordUShort token ID.
KeywordUsing | Gets the KeywordUsing token ID.
KeywordVariant | Gets the KeywordVariant token ID.
KeywordWend | Gets the KeywordWend token ID.
KeywordWhen | Gets the KeywordWhen token ID.
KeywordWhile | Gets the KeywordWhile token ID.
KeywordWidening | Gets the KeywordWidening token ID.
KeywordWith | Gets the KeywordWith token ID.
KeywordWithEvents | Gets the KeywordWithEvents token ID.
KeywordWriteOnly | Gets the KeywordWriteOnly token ID.
KeywordXor | Gets the KeywordXor token ID.
LineContinuation | Gets the LineContinuation token ID.
LineTerminator | Gets the LineTerminator token ID.
LiteralCharacter | Gets the LiteralCharacter token ID.
LiteralDate | Gets the LiteralDate token ID.
LiteralDecimalInteger | Gets the LiteralDecimalInteger token ID.
LiteralFloatingPoint | Gets the LiteralFloatingPoint token ID.
LiteralHexadecimalInteger | Gets the LiteralHexadecimalInteger token ID.
LiteralOctalInteger | Gets the LiteralOctalInteger token ID.
LiteralString | Gets the LiteralString token ID.
LiteralXml | Gets the LiteralXml token ID.
OpenCurlyBrace | Gets the OpenCurlyBrace token ID.
OpenParenthesis | Gets the OpenParenthesis token ID.
OpenSquareBrace | Gets the OpenSquareBrace token ID.
OperatorAddition | Gets the OperatorAddition token ID.
OperatorAdditionAssignment | Gets the OperatorAdditionAssignment token ID.
OperatorEquality | Gets the OperatorEquality token ID.
OperatorExponentiation | Gets the OperatorExponentiation token ID.
OperatorExponentiationAssignment | Gets the OperatorExponentiationAssignment token ID.
OperatorFloatingPointDivision | Gets the OperatorFloatingPointDivision token ID.
OperatorFloatingPointDivisionAssignment | Gets the OperatorFloatingPointDivisionAssignment token ID.
OperatorGreaterThan | Gets the OperatorGreaterThan token ID.
OperatorGreaterThanOrEqual | Gets the OperatorGreaterThanOrEqual token ID.
OperatorInequality | Gets the OperatorInequality token ID.
OperatorIntegerDivision | Gets the OperatorIntegerDivision token ID.
OperatorIntegerDivisionAssignment | Gets the OperatorIntegerDivisionAssignment token ID.
OperatorLeftShift | Gets the OperatorLeftShift token ID.
OperatorLeftShiftAssignment | Gets the OperatorLeftShiftAssignment token ID.
OperatorLessThan | Gets the OperatorLessThan token ID.
OperatorLessThanOrEqual | Gets the OperatorLessThanOrEqual token ID.
OperatorMultiplication | Gets the OperatorMultiplication token ID.
OperatorMultiplicationAssignment | Gets the OperatorMultiplicationAssignment token ID.
OperatorRightShift | Gets the OperatorRightShift token ID.
OperatorRightShiftAssignment | Gets the OperatorRightShiftAssignment token ID.
OperatorStringConcatenation | Gets the OperatorStringConcatenation token ID.
OperatorStringConcatenationAssignment | Gets the OperatorStringConcatenationAssignment token ID.
OperatorSubtraction | Gets the OperatorSubtraction token ID.
OperatorSubtractionAssignment | Gets the OperatorSubtractionAssignment token ID.
PreprocessorDirectiveKeywordConst | Gets the PreprocessorDirectiveKeywordConst token ID.
PreprocessorDirectiveKeywordElse | Gets the PreprocessorDirectiveKeywordElse token ID.
PreprocessorDirectiveKeywordElseIf | Gets the PreprocessorDirectiveKeywordElseIf token ID.
PreprocessorDirectiveKeywordEndExternalSource | Gets the PreprocessorDirectiveKeywordEndExternalSource token ID.
PreprocessorDirectiveKeywordEndIf | Gets the PreprocessorDirectiveKeywordEndIf token ID.
PreprocessorDirectiveKeywordEndRegion | Gets the PreprocessorDirectiveKeywordEndRegion token ID.
PreprocessorDirectiveKeywordExternalChecksum | Gets the PreprocessorDirectiveKeywordExternalChecksum token ID.
PreprocessorDirectiveKeywordExternalSource | Gets the PreprocessorDirectiveKeywordExternalSource token ID.
PreprocessorDirectiveKeywordIf | Gets the PreprocessorDirectiveKeywordIf token ID.
PreprocessorDirectiveKeywordRegion | Gets the PreprocessorDirectiveKeywordRegion token ID.
PreprocessorDirectiveText | Gets the PreprocessorDirectiveText token ID.
QuestionMark | Gets the QuestionMark token ID.
TripleDot | Gets the TripleDot token ID.
Whitespace | Gets the Whitespace token ID.
XmlAttribute | Gets the XmlAttribute token ID.
Top
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CloseCurlyBrace Field

VBTokenIdCloseCurlyBrace Field
Gets the CloseCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseCurlyBrace = 11006
Public Const CloseCurlyBrace As Integer = 11006

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CloseParenthesis Field

VBTokenIdCloseParenthesis Field
Gets the CloseParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseParenthesis = 11004
Public Const CloseParenthesis As Integer = 11004

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CloseSquareBrace Field

VBTokenIdCloseSquareBrace Field
Gets the CloseSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CloseSquareBrace = 11008
Public Const CloseSquareBrace As Integer = 11008

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Colon Field

VBTokenIdColon Field
Gets the Colon token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Colon = 11011
Public Const Colon As Integer = 11011

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ColonEquals Field

VBTokenIdColonEquals Field
Gets the ColonEquals token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ColonEquals = 11012
Public Const ColonEquals As Integer = 11012

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Comma Field

VBTokenIdComma Field
Gets the Comma token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Comma = 11009
Public Const Comma As Integer = 11009

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CommentRem Field

VBTokenIdCommentRem Field
Gets the CommentRem token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentRem = 11018
Public Const CommentRem As Integer = 11018

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.CommentSingleLine Field

VBTokenIdCommentSingleLine Field
Gets the CommentSingleLine token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentSingleLine = 11017
Public Const CommentSingleLine As Integer = 11017

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAggregate Field

VBTokenIdContextualKeywordAggregate Field
Gets the ContextualKeywordAggregate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAggregate = 11032
Public Const ContextualKeywordAggregate As Integer = 11032

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAscending Field

VBTokenIdContextualKeywordAscending Field
Gets the ContextualKeywordAscending token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAscending = 11033
Public Const ContextualKeywordAscending As Integer = 11033

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAsync Field

VBTokenIdContextualKeywordAsync Field
Gets the ContextualKeywordAsync token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAsync = 11034
Public Const ContextualKeywordAsync As Integer = 11034

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordAwait Field

VBTokenIdContextualKeywordAwait Field
Gets the ContextualKeywordAwait token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordAwait = 11035
Public Const ContextualKeywordAwait As Integer = 11035

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordBy Field

VBTokenIdContextualKeywordBy Field
Gets the ContextualKeywordBy token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordBy = 11036
Public Const ContextualKeywordBy As Integer = 11036

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordCustom Field

VBTokenIdContextualKeywordCustom Field
Gets the ContextualKeywordCustom token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordCustom = 11037
Public Const ContextualKeywordCustom As Integer = 11037

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordDescending Field

VBTokenIdContextualKeywordDescending Field
Gets the ContextualKeywordDescending token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordDescending = 11038
Public Const ContextualKeywordDescending As Integer = 11038

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordDistinct Field

VBTokenIdContextualKeywordDistinct Field
Gets the ContextualKeywordDistinct token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordDistinct = 11039
Public Const ContextualKeywordDistinct As Integer = 11039

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordEquals Field

VBTokenIdContextualKeywordEquals Field
Gets the ContextualKeywordEquals token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordEquals = 11040
Public Const ContextualKeywordEquals As Integer = 11040

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordFrom Field

VBTokenIdContextualKeywordFrom Field
Gets the ContextualKeywordFrom token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordFrom = 11041
Public Const ContextualKeywordFrom As Integer = 11041

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordGroup Field

VBTokenIdContextualKeywordGroup Field
Gets the ContextualKeywordGroup token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordGroup = 11042
Public Const ContextualKeywordGroup As Integer = 11042

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIIf Field

VBTokenIdContextualKeywordIIf Field
Gets the ContextualKeywordIIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIIf = 11043
Public Const ContextualKeywordIIf As Integer = 11043

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordInto Field

VBTokenIdContextualKeywordInto Field
Gets the ContextualKeywordInto token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordInto = 11044
Public Const ContextualKeywordInto As Integer = 11044

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIsFalse Field

VBTokenIdContextualKeywordIsFalse Field
Gets the ContextualKeywordIsFalse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIsFalse = 11045
Public Const ContextualKeywordIsFalse As Integer = 11045

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIsTrue Field

VBTokenIdContextualKeywordIsTrue Field
Gets the ContextualKeywordIsTrue token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIsTrue = 11046
Public Const ContextualKeywordIsTrue As Integer = 11046

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordIterator Field

VBTokenIdContextualKeywordIterator Field
Gets the ContextualKeywordIterator token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordIterator = 11047
Public Const ContextualKeywordIterator As Integer = 11047

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordJoin Field

VBTokenIdContextualKeywordJoin Field
Gets the ContextualKeywordJoin token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordJoin = 11048
Public Const ContextualKeywordJoin As Integer = 11048

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordMid Field

VBTokenIdContextualKeywordMid Field
Gets the ContextualKeywordMid token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordMid = 11049
Public Const ContextualKeywordMid As Integer = 11049

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordOrder Field

VBTokenIdContextualKeywordOrder Field
Gets the ContextualKeywordOrder token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOrder = 11050
Public Const ContextualKeywordOrder As Integer = 11050

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordOut Field

VBTokenIdContextualKeywordOut Field
Gets the ContextualKeywordOut token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordOut = 11051
Public Const ContextualKeywordOut As Integer = 11051

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordSkip Field

VBTokenIdContextualKeywordSkip Field
Gets the ContextualKeywordSkip token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordSkip = 11052
Public Const ContextualKeywordSkip As Integer = 11052

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordTake Field

VBTokenIdContextualKeywordTake Field
Gets the ContextualKeywordTake token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordTake = 11053
Public Const ContextualKeywordTake As Integer = 11053

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordWhere Field

VBTokenIdContextualKeywordWhere Field
Gets the ContextualKeywordWhere token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordWhere = 11054
Public Const ContextualKeywordWhere As Integer = 11054

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ContextualKeywordYield Field

VBTokenIdContextualKeywordYield Field
Gets the ContextualKeywordYield token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ContextualKeywordYield = 11055
Public Const ContextualKeywordYield As Integer = 11055

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DocumentationCommentDelimiter Field

VBTokenIdDocumentationCommentDelimiter Field
Gets the DocumentationCommentDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationCommentDelimiter = 11019
Public Const DocumentationCommentDelimiter As Integer = 11019

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DocumentationCommentTag Field

VBTokenIdDocumentationCommentTag Field
Gets the DocumentationCommentTag token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationCommentTag = 11020
Public Const DocumentationCommentTag As Integer = 11020

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DocumentationCommentText Field

VBTokenIdDocumentationCommentText Field
Gets the DocumentationCommentText token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentationCommentText = 11021
Public Const DocumentationCommentText As Integer = 11021

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Dot Field

VBTokenIdDot Field
Gets the Dot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Dot = 11010
Public Const Dot As Integer = 11010

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.DotAt Field

VBTokenIdDotAt Field
Gets the DotAt token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DotAt = 11015
Public Const DotAt As Integer = 11015

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.ExclamationPoint Field

VBTokenIdExclamationPoint Field
Gets the ExclamationPoint token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ExclamationPoint = 11013
Public Const ExclamationPoint As Integer = 11013

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Identifier Field

VBTokenIdIdentifier Field
Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Identifier = 11031
Public Const Identifier As Integer = 11031

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAddHandler Field

VBTokenIdKeywordAddHandler Field
Gets the KeywordAddHandler token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAddHandler = 11056
Public Const KeywordAddHandler As Integer = 11056

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAddressOf Field

VBTokenIdKeywordAddressOf Field
Gets the KeywordAddressOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAddressOf = 11057
Public Const KeywordAddressOf As Integer = 11057

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAlias Field

VBTokenIdKeywordAlias Field
Gets the KeywordAlias token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAlias = 11058
Public Const KeywordAlias As Integer = 11058

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAnd Field

VBTokenIdKeywordAnd Field
Gets the KeywordAnd token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAnd = 11059
Public Const KeywordAnd As Integer = 11059

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAndAlso Field

VBTokenIdKeywordAndAlso Field
Gets the KeywordAndAlso token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAndAlso = 11060
Public Const KeywordAndAlso As Integer = 11060

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordAs Field

VBTokenIdKeywordAs Field
Gets the KeywordAs token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordAs = 11061
Public Const KeywordAs As Integer = 11061

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordBoolean Field

VBTokenIdKeywordBoolean Field
Gets the KeywordBoolean token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordBoolean = 11062
Public Const KeywordBoolean As Integer = 11062

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordByRef Field

VBTokenIdKeywordByRef Field
Gets the KeywordByRef token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordByRef = 11063
Public Const KeywordByRef As Integer = 11063

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordByte Field

VBTokenIdKeywordByte Field
Gets the KeywordByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordByte = 11064
Public Const KeywordByte As Integer = 11064

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordByVal Field

VBTokenIdKeywordByVal Field
Gets the KeywordByVal token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordByVal = 11065
Public Const KeywordByVal As Integer = 11065

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCall Field

VBTokenIdKeywordCall Field
Gets the KeywordCall token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCall = 11066
Public Const KeywordCall As Integer = 11066

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCase Field

VBTokenIdKeywordCase Field
Gets the KeywordCase token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCase = 11067
Public Const KeywordCase As Integer = 11067

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCatch Field

VBTokenIdKeywordCatch Field
Gets the KeywordCatch token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCatch = 11068
Public Const KeywordCatch As Integer = 11068

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCBool Field

VBTokenIdKeywordCBool Field
Gets the KeywordCBool token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCBool = 11069
Public Const KeywordCBool As Integer = 11069

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCByte Field

VBTokenIdKeywordCByte Field
Gets the KeywordCByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCByte = 11070
Public Const KeywordCByte As Integer = 11070

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCChar Field

VBTokenIdKeywordCChar Field
Gets the KeywordCChar token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCChar = 11071
Public Const KeywordCChar As Integer = 11071

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCDate Field

VBTokenIdKeywordCDate Field
Gets the KeywordCDate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCDate = 11072
Public Const KeywordCDate As Integer = 11072

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCDbl Field

VBTokenIdKeywordCDbl Field
Gets the KeywordCDbl token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCDbl = 11073
Public Const KeywordCDbl As Integer = 11073

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCDec Field

VBTokenIdKeywordCDec Field
Gets the KeywordCDec token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCDec = 11074
Public Const KeywordCDec As Integer = 11074

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordChar Field

VBTokenIdKeywordChar Field
Gets the KeywordChar token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordChar = 11075
Public Const KeywordChar As Integer = 11075

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCInt Field

VBTokenIdKeywordCInt Field
Gets the KeywordCInt token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCInt = 11076
Public Const KeywordCInt As Integer = 11076

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordClass Field

VBTokenIdKeywordClass Field
Gets the KeywordClass token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordClass = 11077
Public Const KeywordClass As Integer = 11077

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCLng Field

VBTokenIdKeywordCLng Field
Gets the KeywordCLng token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCLng = 11078
Public Const KeywordCLng As Integer = 11078

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCObj Field

VBTokenIdKeywordCObj Field
Gets the KeywordCObj token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCObj = 11079
Public Const KeywordCObj As Integer = 11079

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordConst Field

VBTokenIdKeywordConst Field
Gets the KeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordConst = 11080
Public Const KeywordConst As Integer = 11080

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordContinue Field

VBTokenIdKeywordContinue Field
Gets the KeywordContinue token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordContinue = 11081
Public Const KeywordContinue As Integer = 11081

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCSByte Field

VBTokenIdKeywordCSByte Field
Gets the KeywordCSByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCSByte = 11082
Public Const KeywordCSByte As Integer = 11082

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCShort Field

VBTokenIdKeywordCShort Field
Gets the KeywordCShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCShort = 11083
Public Const KeywordCShort As Integer = 11083

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCSng Field

VBTokenIdKeywordCSng Field
Gets the KeywordCSng token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCSng = 11084
Public Const KeywordCSng As Integer = 11084

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCStr Field

VBTokenIdKeywordCStr Field
Gets the KeywordCStr token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCStr = 11085
Public Const KeywordCStr As Integer = 11085

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCType Field

VBTokenIdKeywordCType Field
Gets the KeywordCType token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCType = 11086
Public Const KeywordCType As Integer = 11086

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCUInt Field

VBTokenIdKeywordCUInt Field
Gets the KeywordCUInt token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCUInt = 11087
Public Const KeywordCUInt As Integer = 11087

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCULng Field

VBTokenIdKeywordCULng Field
Gets the KeywordCULng token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCULng = 11088
Public Const KeywordCULng As Integer = 11088

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordCUShort Field

VBTokenIdKeywordCUShort Field
Gets the KeywordCUShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordCUShort = 11089
Public Const KeywordCUShort As Integer = 11089

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDate Field

VBTokenIdKeywordDate Field
Gets the KeywordDate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDate = 11090
Public Const KeywordDate As Integer = 11090

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDecimal Field

VBTokenIdKeywordDecimal Field
Gets the KeywordDecimal token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDecimal = 11091
Public Const KeywordDecimal As Integer = 11091

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDeclare Field

VBTokenIdKeywordDeclare Field
Gets the KeywordDeclare token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDeclare = 11092
Public Const KeywordDeclare As Integer = 11092

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDefault Field

VBTokenIdKeywordDefault Field
Gets the KeywordDefault token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDefault = 11093
Public Const KeywordDefault As Integer = 11093

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDelegate Field

VBTokenIdKeywordDelegate Field
Gets the KeywordDelegate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDelegate = 11094
Public Const KeywordDelegate As Integer = 11094

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDim Field

VBTokenIdKeywordDim Field
Gets the KeywordDim token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDim = 11095
Public Const KeywordDim As Integer = 11095

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDirectCast Field

VBTokenIdKeywordDirectCast Field
Gets the KeywordDirectCast token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDirectCast = 11096
Public Const KeywordDirectCast As Integer = 11096

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDo Field

VBTokenIdKeywordDo Field
Gets the KeywordDo token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDo = 11097
Public Const KeywordDo As Integer = 11097

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordDouble Field

VBTokenIdKeywordDouble Field
Gets the KeywordDouble token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordDouble = 11098
Public Const KeywordDouble As Integer = 11098

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEach Field

VBTokenIdKeywordEach Field
Gets the KeywordEach token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEach = 11099
Public Const KeywordEach As Integer = 11099

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordElse Field

VBTokenIdKeywordElse Field
Gets the KeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordElse = 11100
Public Const KeywordElse As Integer = 11100

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordElseIf Field

VBTokenIdKeywordElseIf Field
Gets the KeywordElseIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordElseIf = 11101
Public Const KeywordElseIf As Integer = 11101

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEnd Field

VBTokenIdKeywordEnd Field
Gets the KeywordEnd token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEnd = 11102
Public Const KeywordEnd As Integer = 11102

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEndIf Field

VBTokenIdKeywordEndIf Field
Gets the KeywordEndIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEndIf = 11103
Public Const KeywordEndIf As Integer = 11103

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEnum Field

VBTokenIdKeywordEnum Field
Gets the KeywordEnum token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEnum = 11104
Public Const KeywordEnum As Integer = 11104

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordErase Field

VBTokenIdKeywordErase Field
Gets the KeywordErase token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordErase = 11105
Public Const KeywordErase As Integer = 11105

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordError Field

VBTokenIdKeywordError Field
Gets the KeywordError token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordError = 11106
Public Const KeywordError As Integer = 11106

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordEvent Field

VBTokenIdKeywordEvent Field
Gets the KeywordEvent token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordEvent = 11107
Public Const KeywordEvent As Integer = 11107

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordExit Field

VBTokenIdKeywordExit Field
Gets the KeywordExit token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordExit = 11108
Public Const KeywordExit As Integer = 11108

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFalse Field

VBTokenIdKeywordFalse Field
Gets the KeywordFalse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFalse = 11109
Public Const KeywordFalse As Integer = 11109

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFinally Field

VBTokenIdKeywordFinally Field
Gets the KeywordFinally token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFinally = 11110
Public Const KeywordFinally As Integer = 11110

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFor Field

VBTokenIdKeywordFor Field
Gets the KeywordFor token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFor = 11111
Public Const KeywordFor As Integer = 11111

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFriend Field

VBTokenIdKeywordFriend Field
Gets the KeywordFriend token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFriend = 11112
Public Const KeywordFriend As Integer = 11112

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordFunction Field

VBTokenIdKeywordFunction Field
Gets the KeywordFunction token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordFunction = 11113
Public Const KeywordFunction As Integer = 11113

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGet Field

VBTokenIdKeywordGet Field
Gets the KeywordGet token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGet = 11114
Public Const KeywordGet As Integer = 11114

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGetType Field

VBTokenIdKeywordGetType Field
Gets the KeywordGetType token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGetType = 11115
Public Const KeywordGetType As Integer = 11115

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGetXmlNamespace Field

VBTokenIdKeywordGetXmlNamespace Field
Gets the KeywordGetXmlNamespace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGetXmlNamespace = 11116
Public Const KeywordGetXmlNamespace As Integer = 11116

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGlobal Field

VBTokenIdKeywordGlobal Field
Gets the KeywordGlobal token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGlobal = 11117
Public Const KeywordGlobal As Integer = 11117

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGoSub Field

VBTokenIdKeywordGoSub Field
Gets the KeywordGoSub token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGoSub = 11118
Public Const KeywordGoSub As Integer = 11118

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordGoTo Field

VBTokenIdKeywordGoTo Field
Gets the KeywordGoTo token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordGoTo = 11119
Public Const KeywordGoTo As Integer = 11119

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordHandles Field

VBTokenIdKeywordHandles Field
Gets the KeywordHandles token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordHandles = 11120
Public Const KeywordHandles As Integer = 11120

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIf Field

VBTokenIdKeywordIf Field
Gets the KeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIf = 11121
Public Const KeywordIf As Integer = 11121

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordImplements Field

VBTokenIdKeywordImplements Field
Gets the KeywordImplements token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordImplements = 11122
Public Const KeywordImplements As Integer = 11122

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordImports Field

VBTokenIdKeywordImports Field
Gets the KeywordImports token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordImports = 11123
Public Const KeywordImports As Integer = 11123

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIn Field

VBTokenIdKeywordIn Field
Gets the KeywordIn token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIn = 11124
Public Const KeywordIn As Integer = 11124

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordInherits Field

VBTokenIdKeywordInherits Field
Gets the KeywordInherits token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInherits = 11125
Public Const KeywordInherits As Integer = 11125

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordInteger Field

VBTokenIdKeywordInteger Field
Gets the KeywordInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInteger = 11126
Public Const KeywordInteger As Integer = 11126

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordInterface Field

VBTokenIdKeywordInterface Field
Gets the KeywordInterface token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordInterface = 11127
Public Const KeywordInterface As Integer = 11127

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIs Field

VBTokenIdKeywordIs Field
Gets the KeywordIs token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIs = 11128
Public Const KeywordIs As Integer = 11128

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordIsNot Field

VBTokenIdKeywordIsNot Field
Gets the KeywordIsNot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordIsNot = 11129
Public Const KeywordIsNot As Integer = 11129

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLet Field

VBTokenIdKeywordLet Field
Gets the KeywordLet token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLet = 11130
Public Const KeywordLet As Integer = 11130

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLib Field

VBTokenIdKeywordLib Field
Gets the KeywordLib token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLib = 11131
Public Const KeywordLib As Integer = 11131

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLike Field

VBTokenIdKeywordLike Field
Gets the KeywordLike token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLike = 11132
Public Const KeywordLike As Integer = 11132

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLong Field

VBTokenIdKeywordLong Field
Gets the KeywordLong token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLong = 11133
Public Const KeywordLong As Integer = 11133

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordLoop Field

VBTokenIdKeywordLoop Field
Gets the KeywordLoop token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordLoop = 11134
Public Const KeywordLoop As Integer = 11134

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMe Field

VBTokenIdKeywordMe Field
Gets the KeywordMe token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordMe = 11135
Public Const KeywordMe As Integer = 11135

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMod Field

VBTokenIdKeywordMod Field
Gets the KeywordMod token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordMod = 11136
Public Const KeywordMod As Integer = 11136

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordModule Field

VBTokenIdKeywordModule Field
Gets the KeywordModule token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordModule = 11137
Public Const KeywordModule As Integer = 11137

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMustInherit Field

VBTokenIdKeywordMustInherit Field
Gets the KeywordMustInherit token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordMustInherit = 11138
Public Const KeywordMustInherit As Integer = 11138

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMustOverride Field

VBTokenIdKeywordMustOverride Field
Gets the KeywordMustOverride token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordMustOverride = 11139
Public Const KeywordMustOverride As Integer = 11139

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMyBase Field

VBTokenIdKeywordMyBase Field
Gets the KeywordMyBase token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordMyBase = 11140
Public Const KeywordMyBase As Integer = 11140

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordMyClass Field

VBTokenIdKeywordMyClass Field
Gets the KeywordMyClass token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordMyClass = 11141
Public Const KeywordMyClass As Integer = 11141

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNamespace Field

VBTokenIdKeywordNamespace Field
Gets the KeywordNamespace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNamespace = 11142
Public Const KeywordNamespace As Integer = 11142

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNarrowing Field

VBTokenIdKeywordNarrowing Field
Gets the KeywordNarrowing token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNarrowing = 11143
Public Const KeywordNarrowing As Integer = 11143

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNew Field

VBTokenIdKeywordNew Field
Gets the KeywordNew token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNew = 11144
Public Const KeywordNew As Integer = 11144

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNext Field

VBTokenIdKeywordNext Field
Gets the KeywordNext token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNext = 11145
Public Const KeywordNext As Integer = 11145

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNot Field

VBTokenIdKeywordNot Field
Gets the KeywordNot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNot = 11146
Public Const KeywordNot As Integer = 11146

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNothing Field

VBTokenIdKeywordNothing Field
Gets the KeywordNothing token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNothing = 11147
Public Const KeywordNothing As Integer = 11147

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNotInheritable Field

VBTokenIdKeywordNotInheritable Field
Gets the KeywordNotInheritable token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNotInheritable = 11148
Public Const KeywordNotInheritable As Integer = 11148

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordNotOverridable Field

VBTokenIdKeywordNotOverridable Field
Gets the KeywordNotOverridable token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordNotOverridable = 11149
Public Const KeywordNotOverridable As Integer = 11149

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordObject Field

VBTokenIdKeywordObject Field
Gets the KeywordObject token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordObject = 11150
Public Const KeywordObject As Integer = 11150

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOf Field

VBTokenIdKeywordOf Field
Gets the KeywordOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOf = 11151
Public Const KeywordOf As Integer = 11151

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOn Field

VBTokenIdKeywordOn Field
Gets the KeywordOn token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOn = 11152
Public Const KeywordOn As Integer = 11152

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOperator Field

VBTokenIdKeywordOperator Field
Gets the KeywordOperator token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOperator = 11153
Public Const KeywordOperator As Integer = 11153

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOption Field

VBTokenIdKeywordOption Field
Gets the KeywordOption token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOption = 11154
Public Const KeywordOption As Integer = 11154

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOptional Field

VBTokenIdKeywordOptional Field
Gets the KeywordOptional token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOptional = 11155
Public Const KeywordOptional As Integer = 11155

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOr Field

VBTokenIdKeywordOr Field
Gets the KeywordOr token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOr = 11156
Public Const KeywordOr As Integer = 11156

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOrElse Field

VBTokenIdKeywordOrElse Field
Gets the KeywordOrElse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOrElse = 11157
Public Const KeywordOrElse As Integer = 11157

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOverloads Field

VBTokenIdKeywordOverloads Field
Gets the KeywordOverloads token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOverloads = 11158
Public Const KeywordOverloads As Integer = 11158

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOverridable Field

VBTokenIdKeywordOverridable Field
Gets the KeywordOverridable token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOverridable = 11159
Public Const KeywordOverridable As Integer = 11159

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordOverrides Field

VBTokenIdKeywordOverrides Field
Gets the KeywordOverrides token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordOverrides = 11160
Public Const KeywordOverrides As Integer = 11160

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordParamArray Field

VBTokenIdKeywordParamArray Field
Gets the KeywordParamArray token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordParamArray = 11161
Public Const KeywordParamArray As Integer = 11161

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordPartial Field

VBTokenIdKeywordPartial Field
Gets the KeywordPartial token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPartial = 11162
Public Const KeywordPartial As Integer = 11162

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordPrivate Field

VBTokenIdKeywordPrivate Field
Gets the KeywordPrivate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPrivate = 11163
Public Const KeywordPrivate As Integer = 11163

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordProperty Field

VBTokenIdKeywordProperty Field
Gets the KeywordProperty token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordProperty = 11164
Public Const KeywordProperty As Integer = 11164

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordProtected Field

VBTokenIdKeywordProtected Field
Gets the KeywordProtected token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordProtected = 11165
Public Const KeywordProtected As Integer = 11165

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordPublic Field

VBTokenIdKeywordPublic Field
Gets the KeywordPublic token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordPublic = 11166
Public Const KeywordPublic As Integer = 11166

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordRaiseEvent Field

VBTokenIdKeywordRaiseEvent Field
Gets the KeywordRaiseEvent token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordRaiseEvent = 11167
Public Const KeywordRaiseEvent As Integer = 11167

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordReadOnly Field

VBTokenIdKeywordReadOnly Field
Gets the KeywordReadOnly token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReadOnly = 11168
Public Const KeywordReadOnly As Integer = 11168

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordReDim Field

VBTokenIdKeywordReDim Field
Gets the KeywordReDim token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReDim = 11169
Public Const KeywordReDim As Integer = 11169

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordREM Field

VBTokenIdKeywordREM Field
Gets the KeywordREM token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordREM = 11170
Public Const KeywordREM As Integer = 11170

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordRemoveHandler Field

VBTokenIdKeywordRemoveHandler Field
Gets the KeywordRemoveHandler token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordRemoveHandler = 11171
Public Const KeywordRemoveHandler As Integer = 11171

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordResume Field

VBTokenIdKeywordResume Field
Gets the KeywordResume token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordResume = 11172
Public Const KeywordResume As Integer = 11172

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordReturn Field

VBTokenIdKeywordReturn Field
Gets the KeywordReturn token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordReturn = 11173
Public Const KeywordReturn As Integer = 11173

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSByte Field

VBTokenIdKeywordSByte Field
Gets the KeywordSByte token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSByte = 11174
Public Const KeywordSByte As Integer = 11174

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSelect Field

VBTokenIdKeywordSelect Field
Gets the KeywordSelect token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSelect = 11175
Public Const KeywordSelect As Integer = 11175

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSet Field

VBTokenIdKeywordSet Field
Gets the KeywordSet token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSet = 11176
Public Const KeywordSet As Integer = 11176

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordShadows Field

VBTokenIdKeywordShadows Field
Gets the KeywordShadows token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordShadows = 11177
Public Const KeywordShadows As Integer = 11177

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordShared Field

VBTokenIdKeywordShared Field
Gets the KeywordShared token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordShared = 11178
Public Const KeywordShared As Integer = 11178

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordShort Field

VBTokenIdKeywordShort Field
Gets the KeywordShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordShort = 11179
Public Const KeywordShort As Integer = 11179

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSingle Field

VBTokenIdKeywordSingle Field
Gets the KeywordSingle token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSingle = 11180
Public Const KeywordSingle As Integer = 11180

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStatic Field

VBTokenIdKeywordStatic Field
Gets the KeywordStatic token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStatic = 11181
Public Const KeywordStatic As Integer = 11181

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStep Field

VBTokenIdKeywordStep Field
Gets the KeywordStep token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStep = 11182
Public Const KeywordStep As Integer = 11182

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStop Field

VBTokenIdKeywordStop Field
Gets the KeywordStop token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStop = 11183
Public Const KeywordStop As Integer = 11183

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordString Field

VBTokenIdKeywordString Field
Gets the KeywordString token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordString = 11184
Public Const KeywordString As Integer = 11184

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordStructure Field

VBTokenIdKeywordStructure Field
Gets the KeywordStructure token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordStructure = 11185
Public Const KeywordStructure As Integer = 11185

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSub Field

VBTokenIdKeywordSub Field
Gets the KeywordSub token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSub = 11186
Public Const KeywordSub As Integer = 11186

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordSyncLock Field

VBTokenIdKeywordSyncLock Field
Gets the KeywordSyncLock token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordSyncLock = 11187
Public Const KeywordSyncLock As Integer = 11187

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordThen Field

VBTokenIdKeywordThen Field
Gets the KeywordThen token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordThen = 11188
Public Const KeywordThen As Integer = 11188

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordThrow Field

VBTokenIdKeywordThrow Field
Gets the KeywordThrow token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordThrow = 11189
Public Const KeywordThrow As Integer = 11189

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTo Field

VBTokenIdKeywordTo Field
Gets the KeywordTo token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTo = 11190
Public Const KeywordTo As Integer = 11190

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTrue Field

VBTokenIdKeywordTrue Field
Gets the KeywordTrue token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTrue = 11191
Public Const KeywordTrue As Integer = 11191

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTry Field

VBTokenIdKeywordTry Field
Gets the KeywordTry token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTry = 11192
Public Const KeywordTry As Integer = 11192

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTryCast Field

VBTokenIdKeywordTryCast Field
Gets the KeywordTryCast token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTryCast = 11193
Public Const KeywordTryCast As Integer = 11193

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordTypeOf Field

VBTokenIdKeywordTypeOf Field
Gets the KeywordTypeOf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordTypeOf = 11194
Public Const KeywordTypeOf As Integer = 11194

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUInteger Field

VBTokenIdKeywordUInteger Field
Gets the KeywordUInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUInteger = 11195
Public Const KeywordUInteger As Integer = 11195

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordULong Field

VBTokenIdKeywordULong Field
Gets the KeywordULong token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordULong = 11196
Public Const KeywordULong As Integer = 11196

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUntil Field

VBTokenIdKeywordUntil Field
Gets the KeywordUntil token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUntil = 11197
Public Const KeywordUntil As Integer = 11197

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUShort Field

VBTokenIdKeywordUShort Field
Gets the KeywordUShort token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUShort = 11198
Public Const KeywordUShort As Integer = 11198

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordUsing Field

VBTokenIdKeywordUsing Field
Gets the KeywordUsing token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordUsing = 11199
Public Const KeywordUsing As Integer = 11199

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordVariant Field

VBTokenIdKeywordVariant Field
Gets the KeywordVariant token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordVariant = 11200
Public Const KeywordVariant As Integer = 11200

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWend Field

VBTokenIdKeywordWend Field
Gets the KeywordWend token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWend = 11201
Public Const KeywordWend As Integer = 11201

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWhen Field

VBTokenIdKeywordWhen Field
Gets the KeywordWhen token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWhen = 11202
Public Const KeywordWhen As Integer = 11202

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWhile Field

VBTokenIdKeywordWhile Field
Gets the KeywordWhile token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWhile = 11203
Public Const KeywordWhile As Integer = 11203

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWidening Field

VBTokenIdKeywordWidening Field
Gets the KeywordWidening token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWidening = 11204
Public Const KeywordWidening As Integer = 11204

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWith Field

VBTokenIdKeywordWith Field
Gets the KeywordWith token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWith = 11205
Public Const KeywordWith As Integer = 11205

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWithEvents Field

VBTokenIdKeywordWithEvents Field
Gets the KeywordWithEvents token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWithEvents = 11206
Public Const KeywordWithEvents As Integer = 11206

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordWriteOnly Field

VBTokenIdKeywordWriteOnly Field
Gets the KeywordWriteOnly token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordWriteOnly = 11207
Public Const KeywordWriteOnly As Integer = 11207

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.KeywordXor Field

VBTokenIdKeywordXor Field
Gets the KeywordXor token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int KeywordXor = 11208
Public Const KeywordXor As Integer = 11208

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LineContinuation Field

VBTokenIdLineContinuation Field
Gets the LineContinuation token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineContinuation = 11002
Public Const LineContinuation As Integer = 11002

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LineTerminator Field

VBTokenIdLineTerminator Field
Gets the LineTerminator token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LineTerminator = 11001
Public Const LineTerminator As Integer = 11001

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralCharacter Field

VBTokenIdLiteralCharacter Field
Gets the LiteralCharacter token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralCharacter = 11026
Public Const LiteralCharacter As Integer = 11026

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralDate Field

VBTokenIdLiteralDate Field
Gets the LiteralDate token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDate = 11028
Public Const LiteralDate As Integer = 11028

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralDecimalInteger Field

VBTokenIdLiteralDecimalInteger Field
Gets the LiteralDecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralDecimalInteger = 11022
Public Const LiteralDecimalInteger As Integer = 11022

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralFloatingPoint Field

VBTokenIdLiteralFloatingPoint Field
Gets the LiteralFloatingPoint token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralFloatingPoint = 11025
Public Const LiteralFloatingPoint As Integer = 11025

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralHexadecimalInteger Field

VBTokenIdLiteralHexadecimalInteger Field
Gets the LiteralHexadecimalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralHexadecimalInteger = 11023
Public Const LiteralHexadecimalInteger As Integer = 11023

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralOctalInteger Field

VBTokenIdLiteralOctalInteger Field
Gets the LiteralOctalInteger token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralOctalInteger = 11024
Public Const LiteralOctalInteger As Integer = 11024

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralString Field

VBTokenIdLiteralString Field
Gets the LiteralString token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralString = 11027
Public Const LiteralString As Integer = 11027

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.LiteralXml Field

VBTokenIdLiteralXml Field
Gets the LiteralXml token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LiteralXml = 11029
Public Const LiteralXml As Integer = 11029

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OpenCurlyBrace Field

VBTokenIdOpenCurlyBrace Field
Gets the OpenCurlyBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenCurlyBrace = 11005
Public Const OpenCurlyBrace As Integer = 11005

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OpenParenthesis Field

VBTokenIdOpenParenthesis Field
Gets the OpenParenthesis token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenParenthesis = 11003
Public Const OpenParenthesis As Integer = 11003

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OpenSquareBrace Field

VBTokenIdOpenSquareBrace Field
Gets the OpenSquareBrace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OpenSquareBrace = 11007
Public Const OpenSquareBrace As Integer = 11007

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorAddition Field

VBTokenIdOperatorAddition Field
Gets the OperatorAddition token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAddition = 11211
Public Const OperatorAddition As Integer = 11211

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorAdditionAssignment Field

VBTokenIdOperatorAdditionAssignment Field
Gets the OperatorAdditionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorAdditionAssignment = 11226
Public Const OperatorAdditionAssignment As Integer = 11226

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorEquality Field

VBTokenIdOperatorEquality Field
Gets the OperatorEquality token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorEquality = 11217
Public Const OperatorEquality As Integer = 11217

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorExponentiation Field

VBTokenIdOperatorExponentiation Field
Gets the OperatorExponentiation token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExponentiation = 11215
Public Const OperatorExponentiation As Integer = 11215

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorExponentiationAssignment Field

VBTokenIdOperatorExponentiationAssignment Field
Gets the OperatorExponentiationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorExponentiationAssignment = 11230
Public Const OperatorExponentiationAssignment As Integer = 11230

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorFloatingPointDivision Field

VBTokenIdOperatorFloatingPointDivision Field
Gets the OperatorFloatingPointDivision token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorFloatingPointDivision = 11213
Public Const OperatorFloatingPointDivision As Integer = 11213

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorFloatingPointDivisionAssignment Field

VBTokenIdOperatorFloatingPointDivisionAssignment Field
Gets the OperatorFloatingPointDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorFloatingPointDivisionAssignment = 11228
Public Const OperatorFloatingPointDivisionAssignment As Integer = 11228

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorGreaterThan Field

VBTokenIdOperatorGreaterThan Field
Gets the OperatorGreaterThan token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThan = 11218
Public Const OperatorGreaterThan As Integer = 11218

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorGreaterThanOrEqual Field

VBTokenIdOperatorGreaterThanOrEqual Field
Gets the OperatorGreaterThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorGreaterThanOrEqual = 11220
Public Const OperatorGreaterThanOrEqual As Integer = 11220

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorInequality Field

VBTokenIdOperatorInequality Field
Gets the OperatorInequality token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorInequality = 11221
Public Const OperatorInequality As Integer = 11221

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorIntegerDivision Field

VBTokenIdOperatorIntegerDivision Field
Gets the OperatorIntegerDivision token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorIntegerDivision = 11214
Public Const OperatorIntegerDivision As Integer = 11214

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorIntegerDivisionAssignment Field

VBTokenIdOperatorIntegerDivisionAssignment Field
Gets the OperatorIntegerDivisionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorIntegerDivisionAssignment = 11229
Public Const OperatorIntegerDivisionAssignment As Integer = 11229

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLeftShift Field

VBTokenIdOperatorLeftShift Field
Gets the OperatorLeftShift token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShift = 11222
Public Const OperatorLeftShift As Integer = 11222

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLeftShiftAssignment Field

VBTokenIdOperatorLeftShiftAssignment Field
Gets the OperatorLeftShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLeftShiftAssignment = 11231
Public Const OperatorLeftShiftAssignment As Integer = 11231

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLessThan Field

VBTokenIdOperatorLessThan Field
Gets the OperatorLessThan token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThan = 11216
Public Const OperatorLessThan As Integer = 11216

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorLessThanOrEqual Field

VBTokenIdOperatorLessThanOrEqual Field
Gets the OperatorLessThanOrEqual token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorLessThanOrEqual = 11219
Public Const OperatorLessThanOrEqual As Integer = 11219

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorMultiplication Field

VBTokenIdOperatorMultiplication Field
Gets the OperatorMultiplication token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplication = 11210
Public Const OperatorMultiplication As Integer = 11210

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorMultiplicationAssignment Field

VBTokenIdOperatorMultiplicationAssignment Field
Gets the OperatorMultiplicationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorMultiplicationAssignment = 11225
Public Const OperatorMultiplicationAssignment As Integer = 11225

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorRightShift Field

VBTokenIdOperatorRightShift Field
Gets the OperatorRightShift token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorRightShift = 11223
Public Const OperatorRightShift As Integer = 11223

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorRightShiftAssignment Field

VBTokenIdOperatorRightShiftAssignment Field
Gets the OperatorRightShiftAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorRightShiftAssignment = 11232
Public Const OperatorRightShiftAssignment As Integer = 11232

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorStringConcatenation Field

VBTokenIdOperatorStringConcatenation Field
Gets the OperatorStringConcatenation token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorStringConcatenation = 11209
Public Const OperatorStringConcatenation As Integer = 11209

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorStringConcatenationAssignment Field

VBTokenIdOperatorStringConcatenationAssignment Field
Gets the OperatorStringConcatenationAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorStringConcatenationAssignment = 11224
Public Const OperatorStringConcatenationAssignment As Integer = 11224

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorSubtraction Field

VBTokenIdOperatorSubtraction Field
Gets the OperatorSubtraction token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtraction = 11212
Public Const OperatorSubtraction As Integer = 11212

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.OperatorSubtractionAssignment Field

VBTokenIdOperatorSubtractionAssignment Field
Gets the OperatorSubtractionAssignment token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int OperatorSubtractionAssignment = 11227
Public Const OperatorSubtractionAssignment As Integer = 11227

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordConst Field

VBTokenIdPreprocessorDirectiveKeywordConst Field
Gets the PreprocessorDirectiveKeywordConst token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordConst = 11233
Public Const PreprocessorDirectiveKeywordConst As Integer = 11233

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordElse Field

VBTokenIdPreprocessorDirectiveKeywordElse Field
Gets the PreprocessorDirectiveKeywordElse token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElse = 11236
Public Const PreprocessorDirectiveKeywordElse As Integer = 11236

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordElseIf Field

VBTokenIdPreprocessorDirectiveKeywordElseIf Field
Gets the PreprocessorDirectiveKeywordElseIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordElseIf = 11235
Public Const PreprocessorDirectiveKeywordElseIf As Integer = 11235

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEndExternalSource Field

VBTokenIdPreprocessorDirectiveKeywordEndExternalSource Field
Gets the PreprocessorDirectiveKeywordEndExternalSource token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndExternalSource = 11239
Public Const PreprocessorDirectiveKeywordEndExternalSource As Integer = 11239

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEndIf Field

VBTokenIdPreprocessorDirectiveKeywordEndIf Field
Gets the PreprocessorDirectiveKeywordEndIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndIf = 11237
Public Const PreprocessorDirectiveKeywordEndIf As Integer = 11237

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordEndRegion Field

VBTokenIdPreprocessorDirectiveKeywordEndRegion Field
Gets the PreprocessorDirectiveKeywordEndRegion token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordEndRegion = 11241
Public Const PreprocessorDirectiveKeywordEndRegion As Integer = 11241

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordExternalChecksum Field

VBTokenIdPreprocessorDirectiveKeywordExternalChecksum Field
Gets the PreprocessorDirectiveKeywordExternalChecksum token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordExternalChecksum = 11242
Public Const PreprocessorDirectiveKeywordExternalChecksum As Integer = 11242

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordExternalSource Field

VBTokenIdPreprocessorDirectiveKeywordExternalSource Field
Gets the PreprocessorDirectiveKeywordExternalSource token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordExternalSource = 11238
Public Const PreprocessorDirectiveKeywordExternalSource As Integer = 11238

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordIf Field

VBTokenIdPreprocessorDirectiveKeywordIf Field
Gets the PreprocessorDirectiveKeywordIf token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordIf = 11234
Public Const PreprocessorDirectiveKeywordIf As Integer = 11234

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveKeywordRegion Field

VBTokenIdPreprocessorDirectiveKeywordRegion Field
Gets the PreprocessorDirectiveKeywordRegion token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveKeywordRegion = 11240
Public Const PreprocessorDirectiveKeywordRegion As Integer = 11240

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.PreprocessorDirectiveText Field

VBTokenIdPreprocessorDirectiveText Field
Gets the PreprocessorDirectiveText token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int PreprocessorDirectiveText = 11243
Public Const PreprocessorDirectiveText As Integer = 11243

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.QuestionMark Field

VBTokenIdQuestionMark Field
Gets the QuestionMark token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int QuestionMark = 11014
Public Const QuestionMark As Integer = 11014

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.TripleDot Field

VBTokenIdTripleDot Field
Gets the TripleDot token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int TripleDot = 11016
Public Const TripleDot As Integer = 11016

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.Whitespace Field

VBTokenIdWhitespace Field
Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Whitespace = 11000
Public Const Whitespace As Integer = 11000

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenId.XmlAttribute Field

VBTokenIdXmlAttribute Field
Gets the XmlAttribute token ID.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int XmlAttribute = 11030
Public Const XmlAttribute As Integer = 11030

Field Value

Type: Int32
See Also

Reference

VBTokenId Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Class

VBTokenReader Class
Represents an object that can provide tokens to a ILLParser in a forward-only direction for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenReader

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBTokenReader : MergableTokenReader
Public Class VBTokenReader
    Inherits MergableTokenReader

The VBTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenReader | Initializes a new instance of the VBTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Constructor

VBTokenReader Constructor
Initializes a new instance of the VBTokenReader class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Properties

VBTokenReader Properties

The VBTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader Methods

VBTokenReader Methods

The VBTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenReader.GetNextToken Method

VBTokenReaderGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

VBTokenReader Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Class

VBTokenTagger Class
Represents an ITaggerT for the Visual Basic language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTagger

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBTokenTagger : TokenTagger
Public Class VBTokenTagger
    Inherits TokenTagger

The VBTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenTagger | Initializes a new instance of the VBTokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Constructor

VBTokenTagger Constructor
Initializes a new instance of the VBTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBTokenTagger(
    ICodeDocument document,
    IDotNetClassificationTypeProvider classificationTypes
)
Public Sub New (
    document As ICodeDocument,
    classificationTypes As IDotNetClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypes
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Properties

VBTokenTagger Properties

The VBTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Methods

VBTokenTagger Methods

The VBTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Overrides TokenTaggerClassifyToken(IToken).)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger.ClassifyToken Method

VBTokenTaggerClassifyToken Method
Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IClassificationType ClassifyToken(
    IToken token
)
Public Overrides Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTagger Events

VBTokenTagger Events

The VBTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

VBTokenTagger Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Class

VBTokenTaggerProvider Class
Represents a provider of VBTokenTagger objects for documents that use the VBTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase VBTokenTagger
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class VBTokenTaggerProvider : TaggerProviderBase<VBTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class VBTokenTaggerProvider
    Inherits TaggerProviderBase(Of VBTokenTagger)
    Implements ICodeDocumentTaggerProvider

The VBTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | VBTokenTaggerProvider | Initializes a new instance of the VBTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Constructor

VBTokenTaggerProvider Constructor
Initializes a new instance of the VBTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public VBTokenTaggerProvider(
    IDotNetClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IDotNetClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.DotNetIDotNetClassificationTypeProvider
A IDotNetClassificationTypeProvider that provides classification types.
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Properties

VBTokenTaggerProvider Properties

The VBTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider Methods

VBTokenTaggerProvider Methods

The VBTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


VBTokenTaggerProvider.GetTagger(T) Method

VBTokenTaggerProviderGetTaggerT Method
Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.VB.Implementation
Assembly: AS.Text.Addons.DotNet.Universal (in AS.Text.Addons.DotNet.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

VBTokenTaggerProvider Class
ActiproSoftware.Text.Languages.VB.Implementation Namespace


ActiproSoftware.Text.Languages.Xml Namespace

ActiproSoftware.Text.Languages.Xml Namespace
Contains the classes related to implementing an XML syntax language.
Classes
 | Class | Description
Public class | XmlAttributeSpacingMode | The attribute spacing modes that an XmlTextFormatter can use.
Public class | XmlContextType | Specifies the type of IXmlContext.
Public class | XmlElementSpacingMode | The element spacing modes that an XmlTextFormatter can use.
Public class | XmlSyntaxLanguageExtensions | Contains extension methods that make it easier to work with XML ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IXmlAttributeContext | Provides the base requirements for resolved information about a XML attribute related to an IXmlContext.
Public interface | IXmlClassificationTypeProvider | Provides the base requirements of an object that provides IClassificationType objects for the XML language.
Public interface | IXmlContext | Provides the base requirements for information about the XML context of a certain offset within an ITextSnapshot.
Public interface | IXmlElementContext | Provides the base requirements for resolved information about a XML element related to an IXmlContext.
Public interface | IXmlEndTagAutoCompleter | Provides the base requirements for a class that can auto-complete XML end tags when appropriate.
Public interface | IXmlSchemaResolver | Provides the base requirements for a class that can manage XML schema data.
Public interface | IXmlValidator | Provides the base requirements for a class that can validate XML.


IXmlAttributeContext Interface

IXmlAttributeContext Interface
Provides the base requirements for resolved information about a XML attribute related to an IXmlContext.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlAttributeContext
Public Interface IXmlAttributeContext

The IXmlAttributeContext type exposes the following members.

Properties
 | Name | Description
Public property | Element | Gets the IXmlElementContext upon which this attribute is located.
Public property | Name | Gets the name of the attribute.
Public property | NameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the attribute name.
Public property | Namespace | Gets the namespace that defines the attribute.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the attribute.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the attribute's qualified name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext Properties

IXmlAttributeContext Properties

The IXmlAttributeContext type exposes the following members.

Properties
 | Name | Description
Public property | Element | Gets the IXmlElementContext upon which this attribute is located.
Public property | Name | Gets the name of the attribute.
Public property | NameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the attribute name.
Public property | Namespace | Gets the namespace that defines the attribute.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the attribute.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the attribute's qualified name.
Top
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.Element Property

IXmlAttributeContextElement Property
Gets the IXmlElementContext upon which this attribute is located.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IXmlElementContext Element { get; }
ReadOnly Property Element As IXmlElementContext
    Get

Property Value

Type: IXmlElementContext
The IXmlElementContext upon which this attribute is located.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.Name Property

IXmlAttributeContextName Property
Gets the name of the attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the attribute.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.NameSnapshotRange Property

IXmlAttributeContextNameSnapshotRange Property
Gets the TextSnapshotRange that specifies the range of the attribute name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange NameSnapshotRange { get; }
ReadOnly Property NameSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that specifies the range of the attribute name.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.Namespace Property

IXmlAttributeContextNamespace Property
Gets the namespace that defines the attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Namespace { get; }
ReadOnly Property Namespace As String
    Get

Property Value

Type: String
The namespace that defines the attribute.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.NamespacePrefix Property

IXmlAttributeContextNamespacePrefix Property
Gets the prefix of the namespace that defines the attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string NamespacePrefix { get; }
ReadOnly Property NamespacePrefix As String
    Get

Property Value

Type: String
The prefix of the namespace that defines the attribute.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlAttributeContext.QualifiedName Property

IXmlAttributeContextQualifiedName Property
Gets the XmlQualifiedName that contains the attribute's qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
XmlQualifiedName QualifiedName { get; }
ReadOnly Property QualifiedName As XmlQualifiedName
    Get

Property Value

Type: XmlQualifiedName
The XmlQualifiedName that contains the attribute's qualified name.
See Also

Reference

IXmlAttributeContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider Interface

IXmlClassificationTypeProvider Interface
Provides the base requirements of an object that provides IClassificationType objects for the XML language.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlClassificationTypeProvider
Public Interface IXmlClassificationTypeProvider

The IXmlClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider Properties

IXmlClassificationTypeProvider Properties

The IXmlClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlAttribute Property

IXmlClassificationTypeProviderXmlAttribute Property
Gets the XmlAttribute classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlAttribute { get; }
ReadOnly Property XmlAttribute As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttribute classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlAttributeValue Property

IXmlClassificationTypeProviderXmlAttributeValue Property
Gets the XmlAttributeValue classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlAttributeValue { get; }
ReadOnly Property XmlAttributeValue As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttributeValue classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlCDataSection Property

IXmlClassificationTypeProviderXmlCDataSection Property
Gets the XmlCDataSection classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlCDataSection { get; }
ReadOnly Property XmlCDataSection As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlCDataSection classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlComment Property

IXmlClassificationTypeProviderXmlComment Property
Gets the XmlComment classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlComment { get; }
ReadOnly Property XmlComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlComment classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlDeclaration Property

IXmlClassificationTypeProviderXmlDeclaration Property
Gets the XmlDeclaration classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlDeclaration { get; }
ReadOnly Property XmlDeclaration As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDeclaration classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlDelimiter Property

IXmlClassificationTypeProviderXmlDelimiter Property
Gets the XmlDelimiter classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlDelimiter { get; }
ReadOnly Property XmlDelimiter As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDelimiter classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlEntity Property

IXmlClassificationTypeProviderXmlEntity Property
Gets the XmlEntity classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlEntity { get; }
ReadOnly Property XmlEntity As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlEntity classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlName Property

IXmlClassificationTypeProviderXmlName Property
Gets the XmlName classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlName { get; }
ReadOnly Property XmlName As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlName classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlClassificationTypeProvider.XmlProcessingInstruction Property

IXmlClassificationTypeProviderXmlProcessingInstruction Property
Gets the XmlProcessingInstruction classification type.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType XmlProcessingInstruction { get; }
ReadOnly Property XmlProcessingInstruction As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlProcessingInstruction classification type.
See Also

Reference

IXmlClassificationTypeProvider Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext Interface

IXmlContext Interface
Provides the base requirements for information about the XML context of a certain offset within an ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlContext
Public Interface IXmlContext

The IXmlContext type exposes the following members.

Properties
 | Name | Description
Public property | ElementHierarchy | Gets a read-only list of IXmlElementContext objects that describes the element hierarchy.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | NamespaceDeclarations | Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context.
Public property | SchemaResolver | Gets the IXmlSchemaResolver to use.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetAttribute | Gets the IXmlAttributeContext that contains context information related to the target attribute.
Public property | TargetElement | Gets the IXmlElementContext that contains context information related to the target element.
Public property | Type | Gets an XmlContextType that specifies the type of context.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext Properties

IXmlContext Properties

The IXmlContext type exposes the following members.

Properties
 | Name | Description
Public property | ElementHierarchy | Gets a read-only list of IXmlElementContext objects that describes the element hierarchy.
Public property | InitializationSnapshotRange | Gets the TextSnapshotRange with which the context was initialized.
Public property | NamespaceDeclarations | Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context.
Public property | SchemaResolver | Gets the IXmlSchemaResolver to use.
Public property | SnapshotOffset | Gets the TextSnapshotOffset for which this context was created.
Public property | TargetAttribute | Gets the IXmlAttributeContext that contains context information related to the target attribute.
Public property | TargetElement | Gets the IXmlElementContext that contains context information related to the target element.
Public property | Type | Gets an XmlContextType that specifies the type of context.
Top
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.ElementHierarchy Property

IXmlContextElementHierarchy Property
Gets a read-only list of IXmlElementContext objects that describes the element hierarchy.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IXmlElementContext> ElementHierarchy { get; }
ReadOnly Property ElementHierarchy As IList(Of IXmlElementContext)
    Get

Property Value

Type: IList IXmlElementContext
A read-only list of IXmlElementContext objects that describes the element hierarchy.
Remarks
The element hierarchy is the list of parent elements that contain the current offset.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.InitializationSnapshotRange Property

IXmlContextInitializationSnapshotRange Property
Gets the TextSnapshotRange with which the context was initialized.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> InitializationSnapshotRange { get; }
ReadOnly Property InitializationSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The TextSnapshotRange with which the context was initialized.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.NamespaceDeclarations Property

IXmlContextNamespaceDeclarations Property
Gets the mapping dictionary of namespace to namespace prefixes that are declared at the context.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDictionary<string, string> NamespaceDeclarations { get; }
ReadOnly Property NamespaceDeclarations As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionary String, String
The mapping dictionary of namespace to namespace prefixes that are declared at the context.
Remarks
The dictionary keys are namespaces and the values are namespace prefixes.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.SchemaResolver Property

IXmlContextSchemaResolver Property
Gets the IXmlSchemaResolver to use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IXmlSchemaResolver SchemaResolver { get; }
ReadOnly Property SchemaResolver As IXmlSchemaResolver
    Get

Property Value

Type: IXmlSchemaResolver
The IXmlSchemaResolver to use.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.SnapshotOffset Property

IXmlContextSnapshotOffset Property
Gets the TextSnapshotOffset for which this context was created.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotOffset SnapshotOffset { get; }
ReadOnly Property SnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset for which this context was created.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.TargetAttribute Property

IXmlContextTargetAttribute Property
Gets the IXmlAttributeContext that contains context information related to the target attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IXmlAttributeContext TargetAttribute { get; }
ReadOnly Property TargetAttribute As IXmlAttributeContext
    Get

Property Value

Type: IXmlAttributeContext
The IXmlAttributeContext that contains context information related to the target attribute.
Remarks
This property is only populated if the context is related to an attribute.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.TargetElement Property

IXmlContextTargetElement Property
Gets the IXmlElementContext that contains context information related to the target element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IXmlElementContext TargetElement { get; }
ReadOnly Property TargetElement As IXmlElementContext
    Get

Property Value

Type: IXmlElementContext
The IXmlElementContext that contains context information related to the target element.
Remarks
This property is only populated if the context is related to an element or attribute.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlContext.Type Property

IXmlContextType Property
Gets an XmlContextType that specifies the type of context.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
XmlContextType Type { get; }
ReadOnly Property Type As XmlContextType
    Get

Property Value

Type: XmlContextType
An XmlContextType that specifies the type of context.
See Also

Reference

IXmlContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext Interface

IXmlElementContext Interface
Provides the base requirements for resolved information about a XML element related to an IXmlContext.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlElementContext
Public Interface IXmlElementContext

The IXmlElementContext type exposes the following members.

Properties
 | Name | Description
Public property | AstNode | Gets the IAstNode that defines the element, if known.
Public property | Attributes | Gets the dictionary of attributes for this element.
Public property | EndTagSnapshotRange | Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
Public property | Name | Gets the name of the element.
Public property | Namespace | Gets the namespace that defines the element.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the element.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the element's qualified name.
Public property | StartTagNameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the start tag name.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext Properties

IXmlElementContext Properties

The IXmlElementContext type exposes the following members.

Properties
 | Name | Description
Public property | AstNode | Gets the IAstNode that defines the element, if known.
Public property | Attributes | Gets the dictionary of attributes for this element.
Public property | EndTagSnapshotRange | Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
Public property | Name | Gets the name of the element.
Public property | Namespace | Gets the namespace that defines the element.
Public property | NamespacePrefix | Gets the prefix of the namespace that defines the element.
Public property | QualifiedName | Gets the XmlQualifiedName that contains the element's qualified name.
Public property | StartTagNameSnapshotRange | Gets the TextSnapshotRange that specifies the range of the start tag name.
Top
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.AstNode Property

IXmlElementContextAstNode Property
Gets the IAstNode that defines the element, if known.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode AstNode { get; }
ReadOnly Property AstNode As IAstNode
    Get

Property Value

Type: IAstNode
The IAstNode that defines the element, if known.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.Attributes Property

IXmlElementContextAttributes Property
Gets the dictionary of attributes for this element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDictionary<XmlQualifiedName, IXmlAttributeContext> Attributes { get; }
ReadOnly Property Attributes As IDictionary(Of XmlQualifiedName, IXmlAttributeContext)
    Get

Property Value

Type: IDictionary XmlQualifiedName, IXmlAttributeContext
The dictionary of attributes for this element.
Remarks
The dictionary keys are the attribute qualified names and the values are IXmlAttributeContext objects.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.EndTagSnapshotRange Property

IXmlElementContextEndTagSnapshotRange Property
Gets the nullable TextSnapshotRange that specifies the range of the end tag, if there is one.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> EndTagSnapshotRange { get; }
ReadOnly Property EndTagSnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The nullable TextSnapshotRange that specifies the range of the end tag, if there is one.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.Name Property

IXmlElementContextName Property
Gets the name of the element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the element.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.Namespace Property

IXmlElementContextNamespace Property
Gets the namespace that defines the element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Namespace { get; }
ReadOnly Property Namespace As String
    Get

Property Value

Type: String
The namespace that defines the element.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.NamespacePrefix Property

IXmlElementContextNamespacePrefix Property
Gets the prefix of the namespace that defines the element.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string NamespacePrefix { get; }
ReadOnly Property NamespacePrefix As String
    Get

Property Value

Type: String
The prefix of the namespace that defines the element.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.QualifiedName Property

IXmlElementContextQualifiedName Property
Gets the XmlQualifiedName that contains the element's qualified name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
XmlQualifiedName QualifiedName { get; }
ReadOnly Property QualifiedName As XmlQualifiedName
    Get

Property Value

Type: XmlQualifiedName
The XmlQualifiedName that contains the element's qualified name.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlElementContext.StartTagNameSnapshotRange Property

IXmlElementContextStartTagNameSnapshotRange Property
Gets the TextSnapshotRange that specifies the range of the start tag name.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange StartTagNameSnapshotRange { get; }
ReadOnly Property StartTagNameSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that specifies the range of the start tag name.
See Also

Reference

IXmlElementContext Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlEndTagAutoCompleter Interface

IXmlEndTagAutoCompleter Interface
Provides the base requirements for a class that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlEndTagAutoCompleter
Public Interface IXmlEndTagAutoCompleter

The IXmlEndTagAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlEndTagAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlEndTagAutoCompleter


IXmlEndTagAutoCompleter Methods

IXmlEndTagAutoCompleter Methods

The IXmlEndTagAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Top
See Also

Reference

IXmlEndTagAutoCompleter Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlEndTagAutoCompleter.AutoComplete Method

IXmlEndTagAutoCompleterAutoComplete Method
Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AutoComplete(
    IEditorView view
)
Sub AutoComplete (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.
See Also

Reference

IXmlEndTagAutoCompleter Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver Interface

IXmlSchemaResolver Interface
Provides the base requirements for a class that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlSchemaResolver
Public Interface IXmlSchemaResolver

The IXmlSchemaResolver type exposes the following members.

Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlSchemaResolver interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSchemaResolver


IXmlSchemaResolver Properties

IXmlSchemaResolver Properties

The IXmlSchemaResolver type exposes the following members.

Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Top
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.DefaultNamespace Property

IXmlSchemaResolverDefaultNamespace Property
Gets or sets the default XML namespace to use.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DefaultNamespace { get; set; }
Property DefaultNamespace As String
    Get
    Set

Property Value

Type: String
The default XML namespace to use.
Remarks
The default namespace is used to mimic an xmlns attribute setting on the root element, if no xmlns attribute is present. It sets an empty-string-keyed value into the DefaultNamespacePrefixMappings dictionary.
See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlSchemaResolver.DefaultNamespacePrefixMappings Property

IXmlSchemaResolverDefaultNamespacePrefixMappings Property
Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDictionary<string, string> DefaultNamespacePrefixMappings { get; }
ReadOnly Property DefaultNamespacePrefixMappings As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionary String, String
The mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Remarks
The dictionary keys are namespace prefixes and the values are namespaces. The namespace declarations in this dictionary are used to mimic xmlns attribute settings on the root element when no xmlns declaration attributes for the specified namespace prefix keys are present.

The DefaultNamespace property is simply a wrapper for setting an empty-string-keyed value in this dictionary.

See Also

Reference

IXmlSchemaResolver Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlValidator Interface

IXmlValidator Interface
Provides the base requirements for a class that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlValidator
Public Interface IXmlValidator

The IXmlValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates the XML that is being parsed.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlValidator interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


IXmlValidator Methods

IXmlValidator Methods

The IXmlValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Validates the XML that is being parsed.
Top
See Also

Reference

IXmlValidator Interface
ActiproSoftware.Text.Languages.Xml Namespace


IXmlValidator.Validate Method

IXmlValidatorValidate Method
Validates the XML that is being parsed.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> Validate(
    IParseRequest request,
    IAstNode ast
)
Function Validate (
    request As IParseRequest,
    ast As IAstNode
) As IEnumerable(Of IParseError)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
ast
Type: ActiproSoftware.Text.ParsingIAstNode
The root IAstNode of the parse result AST, if known.

Return Value

Type: IEnumerable IParseError
The collection of validation errors that were found, if any.
See Also

Reference

IXmlValidator Interface
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode Class

XmlAttributeSpacingMode Class
The attribute spacing modes that an XmlTextFormatter can use.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.XmlXmlAttributeSpacingMode

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class XmlAttributeSpacingMode : Enum
Public NotInheritable Class XmlAttributeSpacingMode
    Inherits Enum

The XmlAttributeSpacingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NormalizeWhitespace | Attributes will be separated by a single space.
 | Preserve | The attribute spacing is not modified.
 | SeparateLines | Each attribute will be on a separate line.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode Methods

XmlAttributeSpacingMode Methods

The XmlAttributeSpacingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

XmlAttributeSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode Fields

XmlAttributeSpacingMode Fields

The XmlAttributeSpacingMode type exposes the following members.

Fields
 | Name | Description
 | NormalizeWhitespace | Attributes will be separated by a single space.
 | Preserve | The attribute spacing is not modified.
 | SeparateLines | Each attribute will be on a separate line.
Public field | value__ |
Top
See Also

Reference

XmlAttributeSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode.NormalizeWhitespace Field

XmlAttributeSpacingModeNormalizeWhitespace Field
Attributes will be separated by a single space.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlAttributeSpacingMode NormalizeWhitespace = 1
Public Const NormalizeWhitespace As XmlAttributeSpacingMode = 1

Field Value

Type: XmlAttributeSpacingMode
See Also

Reference

XmlAttributeSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode.Preserve Field

XmlAttributeSpacingModePreserve Field
The attribute spacing is not modified.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlAttributeSpacingMode Preserve = 0
Public Const Preserve As XmlAttributeSpacingMode = 0

Field Value

Type: XmlAttributeSpacingMode
See Also

Reference

XmlAttributeSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode.SeparateLines Field

XmlAttributeSpacingModeSeparateLines Field
Each attribute will be on a separate line.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlAttributeSpacingMode SeparateLines = 2
Public Const SeparateLines As XmlAttributeSpacingMode = 2

Field Value

Type: XmlAttributeSpacingMode
See Also

Reference

XmlAttributeSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlAttributeSpacingMode.value__ Field

XmlAttributeSpacingModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Xml.XmlAttributeSpacingMode.value__"]

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

XmlAttributeSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType Class

XmlContextType Class
Specifies the type of IXmlContext.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.XmlXmlContextType

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class XmlContextType : Enum
Public NotInheritable Class XmlContextType
    Inherits Enum

The XmlContextType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | In default area (between elements or in an element block).
 | EndTagName | At the name of an end tag.
 | None | No context.
 | StartTagAttributeName | At the name of an attribute.
 | StartTagAttributeValue | At the value of an attribute.
 | StartTagDefault | After the start tag name, and possibly between attributes.
 | StartTagName | At the name of a start tag.
 | StartTagOther | At another part of a start tag.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType Methods

XmlContextType Methods

The XmlContextType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType Fields

XmlContextType Fields

The XmlContextType type exposes the following members.

Fields
 | Name | Description
 | Default | In default area (between elements or in an element block).
 | EndTagName | At the name of an end tag.
 | None | No context.
 | StartTagAttributeName | At the name of an attribute.
 | StartTagAttributeValue | At the value of an attribute.
 | StartTagDefault | After the start tag name, and possibly between attributes.
 | StartTagName | At the name of a start tag.
 | StartTagOther | At another part of a start tag.
Public field | value__ |
Top
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.Default Field

XmlContextTypeDefault Field
In default area (between elements or in an element block).

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType Default = 1
Public Const Default As XmlContextType = 1

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.EndTagName Field

XmlContextTypeEndTagName Field
At the name of an end tag.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType EndTagName = 7
Public Const EndTagName As XmlContextType = 7

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.None Field

XmlContextTypeNone Field
No context.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType None = 0
Public Const None As XmlContextType = 0

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.StartTagAttributeName Field

XmlContextTypeStartTagAttributeName Field
At the name of an attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType StartTagAttributeName = 4
Public Const StartTagAttributeName As XmlContextType = 4

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.StartTagAttributeValue Field

XmlContextTypeStartTagAttributeValue Field
At the value of an attribute.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType StartTagAttributeValue = 5
Public Const StartTagAttributeValue As XmlContextType = 5

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.StartTagDefault Field

XmlContextTypeStartTagDefault Field
After the start tag name, and possibly between attributes.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType StartTagDefault = 3
Public Const StartTagDefault As XmlContextType = 3

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.StartTagName Field

XmlContextTypeStartTagName Field
At the name of a start tag.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType StartTagName = 2
Public Const StartTagName As XmlContextType = 2

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.StartTagOther Field

XmlContextTypeStartTagOther Field
At another part of a start tag.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlContextType StartTagOther = 6
Public Const StartTagOther As XmlContextType = 6

Field Value

Type: XmlContextType
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlContextType.value__ Field

XmlContextTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Xml.XmlContextType.value__"]

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

XmlContextType Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode Class

XmlElementSpacingMode Class
The element spacing modes that an XmlTextFormatter can use.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Languages.XmlXmlElementSpacingMode

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class XmlElementSpacingMode : Enum
Public NotInheritable Class XmlElementSpacingMode
    Inherits Enum

The XmlElementSpacingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NormalizeEmptyLines | Elements will be separated by an empty line and extra empty lines will be removed.
 | Preserve | The element spacing is not modified.
 | RemoveEmptyLines | Elements will be on their own line an empty lines will be removed.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode Methods

XmlElementSpacingMode Methods

The XmlElementSpacingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

XmlElementSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode Fields

XmlElementSpacingMode Fields

The XmlElementSpacingMode type exposes the following members.

Fields
 | Name | Description
 | NormalizeEmptyLines | Elements will be separated by an empty line and extra empty lines will be removed.
 | Preserve | The element spacing is not modified.
 | RemoveEmptyLines | Elements will be on their own line an empty lines will be removed.
Public field | value__ |
Top
See Also

Reference

XmlElementSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode.NormalizeEmptyLines Field

XmlElementSpacingModeNormalizeEmptyLines Field
Elements will be separated by an empty line and extra empty lines will be removed.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlElementSpacingMode NormalizeEmptyLines = 1
Public Const NormalizeEmptyLines As XmlElementSpacingMode = 1

Field Value

Type: XmlElementSpacingMode
See Also

Reference

XmlElementSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode.Preserve Field

XmlElementSpacingModePreserve Field
The element spacing is not modified.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlElementSpacingMode Preserve = 0
Public Const Preserve As XmlElementSpacingMode = 0

Field Value

Type: XmlElementSpacingMode
See Also

Reference

XmlElementSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode.RemoveEmptyLines Field

XmlElementSpacingModeRemoveEmptyLines Field
Elements will be on their own line an empty lines will be removed.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlElementSpacingMode RemoveEmptyLines = 2
Public Const RemoveEmptyLines As XmlElementSpacingMode = 2

Field Value

Type: XmlElementSpacingMode
See Also

Reference

XmlElementSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlElementSpacingMode.value__ Field

XmlElementSpacingModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Languages.Xml.XmlElementSpacingMode.value__"]

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

XmlElementSpacingMode Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions Class

XmlSyntaxLanguageExtensions Class
Contains extension methods that make it easier to work with XML ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.XmlXmlSyntaxLanguageExtensions

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class XmlSyntaxLanguageExtensions
<ExtensionAttribute>
Public NotInheritable Class XmlSyntaxLanguageExtensions

The XmlSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data.
GetXmlValidator | Returns the IXmlValidator that can validate XML.
RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data.
RegisterXmlValidator | Registers the IXmlValidator that can validate XML.
UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data.
UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions Methods

XmlSyntaxLanguageExtensions Methods

The XmlSyntaxLanguageExtensions type exposes the following members.

Methods
Name | Description
GetXmlEndTagAutoCompleter | Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
GetXmlSchemaResolver | Returns the IXmlSchemaResolver that can manage XML schema data.
GetXmlValidator | Returns the IXmlValidator that can validate XML.
RegisterXmlEndTagAutoCompleter | Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
RegisterXmlSchemaResolver | Registers the IXmlSchemaResolver that can manage XML schema data.
RegisterXmlValidator | Registers the IXmlValidator that can validate XML.
UnregisterXmlEndTagAutoCompleter | Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.
UnregisterXmlSchemaResolver | Unregisters the IXmlSchemaResolver that can manage XML schema data.
UnregisterXmlValidator | Unregisters the IXmlValidator that can validate XML.
Top
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.GetXmlEndTagAutoCompleter Method

XmlSyntaxLanguageExtensionsGetXmlEndTagAutoCompleter Method
Returns the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IXmlEndTagAutoCompleter GetXmlEndTagAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetXmlEndTagAutoCompleter (
    language As ISyntaxLanguage
) As IXmlEndTagAutoCompleter

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IXmlEndTagAutoCompleter
The IXmlEndTagAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.GetXmlSchemaResolver Method

XmlSyntaxLanguageExtensionsGetXmlSchemaResolver Method
Returns the IXmlSchemaResolver that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IXmlSchemaResolver GetXmlSchemaResolver(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetXmlSchemaResolver (
    language As ISyntaxLanguage
) As IXmlSchemaResolver

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IXmlSchemaResolver
The IXmlSchemaResolver instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.GetXmlValidator Method

XmlSyntaxLanguageExtensionsGetXmlValidator Method
Returns the IXmlValidator that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IXmlValidator GetXmlValidator(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Function GetXmlValidator (
    language As ISyntaxLanguage
) As IXmlValidator

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Return Value

Type: IXmlValidator
The IXmlValidator instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.RegisterXmlEndTagAutoCompleter Method

XmlSyntaxLanguageExtensionsRegisterXmlEndTagAutoCompleter Method
Registers the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterXmlEndTagAutoCompleter(
    this ISyntaxLanguage language,
    IXmlEndTagAutoCompleter value
)
<ExtensionAttribute>
Public Shared Sub RegisterXmlEndTagAutoCompleter (
    language As ISyntaxLanguage,
    value As IXmlEndTagAutoCompleter
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.XmlIXmlEndTagAutoCompleter
The IXmlEndTagAutoCompleter instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.RegisterXmlSchemaResolver Method

XmlSyntaxLanguageExtensionsRegisterXmlSchemaResolver Method
Registers the IXmlSchemaResolver that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterXmlSchemaResolver(
    this ISyntaxLanguage language,
    IXmlSchemaResolver value
)
<ExtensionAttribute>
Public Shared Sub RegisterXmlSchemaResolver (
    language As ISyntaxLanguage,
    value As IXmlSchemaResolver
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.XmlIXmlSchemaResolver
The IXmlSchemaResolver instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.RegisterXmlValidator Method

XmlSyntaxLanguageExtensionsRegisterXmlValidator Method
Registers the IXmlValidator that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void RegisterXmlValidator(
    this ISyntaxLanguage language,
    IXmlValidator value
)
<ExtensionAttribute>
Public Shared Sub RegisterXmlValidator (
    language As ISyntaxLanguage,
    value As IXmlValidator
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.
value
Type: ActiproSoftware.Text.Languages.XmlIXmlValidator
The IXmlValidator instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.UnregisterXmlEndTagAutoCompleter Method

XmlSyntaxLanguageExtensionsUnregisterXmlEndTagAutoCompleter Method
Unregisters the IXmlEndTagAutoCompleter that can auto-complete XML end tags when appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterXmlEndTagAutoCompleter(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterXmlEndTagAutoCompleter (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.UnregisterXmlSchemaResolver Method

XmlSyntaxLanguageExtensionsUnregisterXmlSchemaResolver Method
Unregisters the IXmlSchemaResolver that can manage XML schema data.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterXmlSchemaResolver(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterXmlSchemaResolver (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


XmlSyntaxLanguageExtensions.UnregisterXmlValidator Method

XmlSyntaxLanguageExtensionsUnregisterXmlValidator Method
Unregisters the IXmlValidator that can validate XML.

Namespace: ActiproSoftware.Text.Languages.Xml
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void UnregisterXmlValidator(
    this ISyntaxLanguage language
)
<ExtensionAttribute>
Public Shared Sub UnregisterXmlValidator (
    language As ISyntaxLanguage
)

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to update.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlSyntaxLanguageExtensions Class
ActiproSoftware.Text.Languages.Xml Namespace


ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace
Contains the implementation types related to ASTs for a XML syntax language.
Classes
 | Class | Description
Public class | CDataSection | Represents a cData section.
Public class | Comment | Represents a comment.
Public class | CompilationUnit | Represents a compilation unit.
Public class | Declaration | Represents a declaration.
Public class | Element | Represents an element.
Public class | ElementAttribute | Represents an element attribute.
Public class | ElementContent | Represents an element content.
Public class | EndTag | Represents an end tag.
Public class | ProcessingInstruction | Represents a processing instruction.
Public class | XmlAstNodeId | Contains the AST node IDs for the XML language.


CDataSection Class

CDataSection Class
Represents a cData section.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCDataSection

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CDataSection : AstNodeBase
Public Class CDataSection
    Inherits AstNodeBase

The CDataSection type exposes the following members.

Constructors
 | Name | Description
Public method | CDataSection | Initializes a new instance of the CDataSection class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection Constructor

CDataSection Constructor
Initializes a new instance of the CDataSection class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CDataSection()
Public Sub New
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection Properties

CDataSection Properties

The CDataSection type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection.Id Property

CDataSectionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CDataSection Methods

CDataSection Methods

The CDataSection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CDataSection Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Class

Comment Class
Represents a comment.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationComment

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Comment : AstNodeBase
Public Class Comment
    Inherits AstNodeBase

The Comment type exposes the following members.

Constructors
 | Name | Description
Public method | Comment | Initializes a new instance of the Comment class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Constructor

Comment Constructor
Initializes a new instance of the Comment class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Comment()
Public Sub New
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Properties

Comment Properties

The Comment type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment.Id Property

CommentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Comment Methods

Comment Methods

The Comment type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Comment Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Class

CompilationUnit Class
Represents a compilation unit.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCompilationUnit

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CompilationUnit : AstNodeBase
Public Class CompilationUnit
    Inherits AstNodeBase

The CompilationUnit type exposes the following members.

Constructors
 | Name | Description
Public method | CompilationUnit | Initializes a new instance of the CompilationUnit class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Constructor

CompilationUnit Constructor
Initializes a new instance of the CompilationUnit class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CompilationUnit()
Public Sub New
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Properties

CompilationUnit Properties

The CompilationUnit type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.HasNodes Property

CompilationUnitHasNodes Property
Returns whether the Nodes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNodes { get; }
Public ReadOnly Property HasNodes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.Id Property

CompilationUnitId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.Nodes Property

CompilationUnitNodes Property
Gets the nodes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Nodes { get; }
Public ReadOnly Property Nodes As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The nodes.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit Methods

CompilationUnit Methods

The CompilationUnit type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


CompilationUnit.GetChildrenEnumerator Method

CompilationUnitGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

CompilationUnit Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Class

Declaration Class
Represents a declaration.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationDeclaration

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Declaration : AstNodeBase
Public Class Declaration
    Inherits AstNodeBase

The Declaration type exposes the following members.

Constructors
 | Name | Description
Public method | Declaration | Initializes a new instance of the Declaration class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.611.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Constructor

Declaration Constructor
Initializes a new instance of the Declaration class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Declaration()
Public Sub New
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Properties

Declaration Properties

The Declaration type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.HasNodes Property

DeclarationHasNodes Property
Returns whether the Nodes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNodes { get; }
Public ReadOnly Property HasNodes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.Id Property

DeclarationId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.Nodes Property

DeclarationNodes Property
Gets the nodes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Nodes { get; }
Public ReadOnly Property Nodes As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The nodes.
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration Methods

Declaration Methods

The Declaration type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Declaration.GetChildrenEnumerator Method

DeclarationGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Declaration Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Class

Element Class
Represents an element.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElement

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Element : AstNodeBase
Public Class Element
    Inherits AstNodeBase

The Element type exposes the following members.

Constructors
 | Name | Description
Public method | Element | Initializes a new instance of the Element class
Top
Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Content | Gets or sets the content.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EndTag | Gets or sets the end tag.
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Constructor

Element Constructor
Initializes a new instance of the Element class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Element()
Public Sub New
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Properties

Element Properties

The Element type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the attributes.
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | Content | Gets or sets the content.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | EndTag | Gets or sets the end tag.
Public property | HasAttributes | Returns whether the Attributes collection property contains at least one item.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Attributes Property

ElementAttributes Property
Gets the attributes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<ElementAttribute> Attributes { get; }
Public ReadOnly Property Attributes As IList(Of ElementAttribute)
    Get

Property Value

Type: IList ElementAttribute
The attributes.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Content Property

ElementContent Property
Gets or sets the content.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ElementContent Content { get; set; }
Public Property Content As ElementContent
    Get
    Set

Property Value

Type: ElementContent
The content.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.EndTag Property

ElementEndTag Property
Gets or sets the end tag.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EndTag EndTag { get; set; }
Public Property EndTag As EndTag
    Get
    Set

Property Value

Type: EndTag
The end tag.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.HasAttributes Property

ElementHasAttributes Property
Returns whether the Attributes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasAttributes { get; }
Public ReadOnly Property HasAttributes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Id Property

ElementId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.Name Property

ElementName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element Methods

Element Methods

The Element type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


Element.GetChildrenEnumerator Method

ElementGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

Element Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Class

ElementAttribute Class
Represents an element attribute.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementAttribute

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ElementAttribute : AstNodeBase
Public Class ElementAttribute
    Inherits AstNodeBase

The ElementAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ElementAttribute | Initializes a new instance of the ElementAttribute class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TextValue | Gets or sets the text value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Constructor

ElementAttribute Constructor
Initializes a new instance of the ElementAttribute class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ElementAttribute()
Public Sub New
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Properties

ElementAttribute Properties

The ElementAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Name | Gets or sets the name.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | TextValue | Gets or sets the text value.
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute.Id Property

ElementAttributeId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute.Name Property

ElementAttributeName Property
Gets or sets the name.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name.
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute.TextValue Property

ElementAttributeTextValue Property
Gets or sets the text value.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TextValue { get; set; }
Public Property TextValue As String
    Get
    Set

Property Value

Type: String
The text value.
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementAttribute Methods

ElementAttribute Methods

The ElementAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementAttribute Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Class

ElementContent Class
Represents an element content.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementContent

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ElementContent : AstNodeBase
Public Class ElementContent
    Inherits AstNodeBase

The ElementContent type exposes the following members.

Constructors
 | Name | Description
Public method | ElementContent | Initializes a new instance of the ElementContent class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Constructor

ElementContent Constructor
Initializes a new instance of the ElementContent class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ElementContent()
Public Sub New
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Properties

ElementContent Properties

The ElementContent type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | HasNodes | Returns whether the Nodes collection property contains at least one item.
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Nodes | Gets the nodes.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.HasNodes Property

ElementContentHasNodes Property
Returns whether the Nodes collection property contains at least one item.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNodes { get; }
Public ReadOnly Property HasNodes As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one item in the collection; otherwise, false.
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.Id Property

ElementContentId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.Nodes Property

ElementContentNodes Property
Gets the nodes.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Nodes { get; }
Public ReadOnly Property Nodes As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The nodes.
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent Methods

ElementContent Methods

The ElementContent type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Overrides AstNodeBaseGetChildrenEnumerator.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ElementContent.GetChildrenEnumerator Method

ElementContentGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overrides Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

ElementContent Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Class

EndTag Class
Represents an end tag.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationEndTag

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EndTag : AstNodeBase
Public Class EndTag
    Inherits AstNodeBase

The EndTag type exposes the following members.

Constructors
 | Name | Description
Public method | EndTag | Initializes a new instance of the EndTag class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Constructor

EndTag Constructor
Initializes a new instance of the EndTag class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EndTag()
Public Sub New
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Properties

EndTag Properties

The EndTag type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag.Id Property

EndTagId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


EndTag Methods

EndTag Methods

The EndTag type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

EndTag Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Class

ProcessingInstruction Class
Represents a processing instruction.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationProcessingInstruction

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ProcessingInstruction : AstNodeBase
Public Class ProcessingInstruction
    Inherits AstNodeBase

The ProcessingInstruction type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessingInstruction | Initializes a new instance of the ProcessingInstruction class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Constructor

ProcessingInstruction Constructor
Initializes a new instance of the ProcessingInstruction class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ProcessingInstruction()
Public Sub New
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Properties

ProcessingInstruction Properties

The ProcessingInstruction type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node. (Inherited from AstNodeBase.)
Public property | EndOffset | Gets or sets the end offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | HasChildren | Gets whether the AST node contains any child AST nodes. (Inherited from AstNodeBase.)
Public property | Id | Gets the An integer value that identifies the type of AST node. (Overrides AstNodeBaseId.)
Public property | Length | Gets the character length of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known. (Inherited from AstNodeBase.)
Public property | StartOffset | Gets or sets the start offset of this AST node, if known. (Inherited from AstNodeBase.)
Public property | Value | Gets or sets the string-based value for the AST node. (Inherited from AstNodeBase.)
Top
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction.Id Property

ProcessingInstructionId Property
Gets the An integer value that identifies the type of AST node.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The An integer value that identifies the type of AST node.

Implements

IAstNodeId
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ProcessingInstruction Methods

ProcessingInstruction Methods

The ProcessingInstruction type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset. (Inherited from AstNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset. (Inherited from AstNodeBase.)
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node. (Inherited from AstNodeBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from AstNodeBase.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form. (Inherited from AstNodeBase.)
Top
See Also

Reference

ProcessingInstruction Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Class

XmlAstNodeId Class
Contains the AST node IDs for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationXmlAstNodeId

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlAstNodeId : AstNodeIdProviderBase
Public Class XmlAstNodeId
    Inherits AstNodeIdProviderBase

The XmlAstNodeId type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAstNodeId | Initializes a new instance of the XmlAstNodeId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
CDataSection | Gets the CDataSection AST node ID.
Comment | Gets the Comment AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
Declaration | Gets the Declaration AST node ID.
Element | Gets the Element AST node ID.
ElementAttribute | Gets the ElementAttribute AST node ID.
ElementContent | Gets the ElementContent AST node ID.
EndTag | Gets the EndTag AST node ID.
ProcessingInstruction | Gets the ProcessingInstruction AST node ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.1.602.0 (http://www.actiprosoftware.com).
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Constructor

XmlAstNodeId Constructor
Initializes a new instance of the XmlAstNodeId class

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAstNodeId()
Public Sub New
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Properties

XmlAstNodeId Properties

The XmlAstNodeId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum AST node ID returned by this provider. (Overrides AstNodeIdProviderBaseMinId.)
Top
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.MaxId Property

XmlAstNodeIdMaxId Property
Gets the maximum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum AST node ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.MinId Property

XmlAstNodeIdMinId Property
Gets the minimum AST node ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum AST node ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Methods

XmlAstNodeId Methods

The XmlAstNodeId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this AST node ID provider. (Overrides AstNodeIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified AST node ID. (Overrides AstNodeIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ContainsId Method

XmlAstNodeIdContainsId Method
Returns whether the specified ID value is valid for this AST node ID provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.GetDescription Method

XmlAstNodeIdGetDescription Method
Returns the actual string representation for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The actual string representation for the specified AST node ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.GetKey Method

XmlAstNodeIdGetKey Method
Returns the string-based key for the specified AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The AST node ID to examine.

Return Value

Type: String
The string-based key for the specified AST node ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId Fields

XmlAstNodeId Fields

The XmlAstNodeId type exposes the following members.

Fields
Name | Description
CDataSection | Gets the CDataSection AST node ID.
Comment | Gets the Comment AST node ID.
CompilationUnit | Gets the CompilationUnit AST node ID.
Declaration | Gets the Declaration AST node ID.
Element | Gets the Element AST node ID.
ElementAttribute | Gets the ElementAttribute AST node ID.
ElementContent | Gets the ElementContent AST node ID.
EndTag | Gets the EndTag AST node ID.
ProcessingInstruction | Gets the ProcessingInstruction AST node ID.
Top
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.CDataSection Field

XmlAstNodeIdCDataSection Field
Gets the CDataSection AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CDataSection = 15001
Public Const CDataSection As Integer = 15001

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.Comment Field

XmlAstNodeIdComment Field
Gets the Comment AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Comment = 15002
Public Const Comment As Integer = 15002

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.CompilationUnit Field

XmlAstNodeIdCompilationUnit Field
Gets the CompilationUnit AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CompilationUnit = 15000
Public Const CompilationUnit As Integer = 15000

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.Declaration Field

XmlAstNodeIdDeclaration Field
Gets the Declaration AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Declaration = 15003
Public Const Declaration As Integer = 15003

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.Element Field

XmlAstNodeIdElement Field
Gets the Element AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Element = 15004
Public Const Element As Integer = 15004

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ElementAttribute Field

XmlAstNodeIdElementAttribute Field
Gets the ElementAttribute AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ElementAttribute = 15005
Public Const ElementAttribute As Integer = 15005

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ElementContent Field

XmlAstNodeIdElementContent Field
Gets the ElementContent AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ElementContent = 15006
Public Const ElementContent As Integer = 15006

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.EndTag Field

XmlAstNodeIdEndTag Field
Gets the EndTag AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EndTag = 15007
Public Const EndTag As Integer = 15007

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


XmlAstNodeId.ProcessingInstruction Field

XmlAstNodeIdProcessingInstruction Field
Gets the ProcessingInstruction AST node ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Ast.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ProcessingInstruction = 15008
Public Const ProcessingInstruction As Integer = 15008

Field Value

Type: Int32
See Also

Reference

XmlAstNodeId Class
ActiproSoftware.Text.Languages.Xml.Ast.Implementation Namespace


ActiproSoftware.Text.Languages.Xml.Implementation Namespace

ActiproSoftware.Text.Languages.Xml.Implementation Namespace
Contains the core classes related to implementing an XML syntax language.
Classes
 | Class | Description
Public class | XmlClassificationTypeProvider | Represents a provider of IClassificationType objects for the XML language.
Public class | XmlCodeBlockFinder | Provides a XML language code block finder service.
Public class | XmlContextFactory | Creates IXmlContext objects for a TextSnapshotOffset.
Public class | XmlEndTagAutoCompleter | Provides a class that can auto-complete XML end tags when appropriate.
Public class | XmlExampleTextProvider | Represents a example text provider for the XML language.
Public class | XmlGrammar | Represents a Grammar for the XML language.
Public class | XmlIndentProvider | Provides a XML language indent provider service.
Public class | XmlLexer | Represents a lexer for the XML language.
Public class | XmlLexicalStateId | Contains the lexical state IDs for the XML language.
Public class | XmlLineCommenter | Provides a XML language line commenter service.
Public class | XmlNavigableSymbolProvider | Represents a navigable symbol provider for the XML language.
Public class | XmlOutliner | Provides a XML language outliner service.
Public class | XmlParseData | Stores the results of a XML language parsing operation.
Public class | XmlParser | Represents a parser for the XML language.
Public class | XmlParserBase | Provides an abstract base class of a parser for the XML language.
Public class | XmlParserContext | Stores parser context information for a XML language grammar parser.
Public class | XmlQuickInfoProvider | Provides IntelliPrompt quick info data for the XML language.
Public class | XmlSchemaResolver | Provides a class that can manage XML schema data.
Public class | XmlSyntaxLanguage | Represents a XML syntax language definition.
Public class | XmlTextFormatter | Provides a XML language text formatter service.
Public class | XmlTokenId | Contains the token IDs for the XML language.
Public class | XmlTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for the XML language.
Public class | XmlTokenTagger | Represents a token tagger for the XML language.
Public class | XmlTokenTaggerProvider | Represents a provider of XmlTokenTagger objects for documents that use the XmlTokenTagger language.
Public class | XmlTokenTaggerProviderTaggerFactory | Implements a factory that can creates XmlTokenTagger objects for a document.
Interfaces
 | Interface | Description
Public interface | IXmlParseData | Provides the base requirements of an object that stores the results of a XML language parsing operation.


IXmlParseData Interface

IXmlParseData Interface
Provides the base requirements of an object that stores the results of a XML language parsing operation.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IXmlParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Interface IXmlParseData
    Inherits ILLParseData, IParseData, IParseErrorProvider

The IXmlParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | IsWellFormed | Gets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParseData


IXmlParseData Properties

IXmlParseData Properties

The IXmlParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result. (Inherited from ILLParseData.)
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | IsWellFormed | Gets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

IXmlParseData Interface
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


IXmlParseData.IsWellFormed Property

IXmlParseDataIsWellFormed Property
Gets whether the XML is well-formed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWellFormed { get; }
ReadOnly Property IsWellFormed As Boolean
    Get

Property Value

Type: Boolean
true if the XML is well-formed; otherwise, false.
See Also

Reference

IXmlParseData Interface
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Class

XmlClassificationTypeProvider Class
Represents a provider of IClassificationType objects for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlClassificationTypeProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlClassificationTypeProvider : IXmlClassificationTypeProvider
Public Class XmlClassificationTypeProvider
    Implements IXmlClassificationTypeProvider

The XmlClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlClassificationTypeProvider | Initializes a new instance of the XmlClassificationTypeProvider class.
Public method | XmlClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the XmlClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v10.2.530.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Constructor

XmlClassificationTypeProvider Constructor
Overload List
 | Name | Description
Public method | XmlClassificationTypeProvider | Initializes a new instance of the XmlClassificationTypeProvider class.
Public method | XmlClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the XmlClassificationTypeProvider class.
Top
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Constructor

XmlClassificationTypeProvider Constructor
Initializes a new instance of the XmlClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlClassificationTypeProvider()
Public Sub New
See Also

Reference

XmlClassificationTypeProvider Class
XmlClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

XmlClassificationTypeProvider Constructor (IHighlightingStyleRegistry)
Initializes a new instance of the XmlClassificationTypeProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlClassificationTypeProvider(
    IHighlightingStyleRegistry targetRegistry
)
Public Sub New (
    targetRegistry As IHighlightingStyleRegistry
)

Parameters

targetRegistry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

XmlClassificationTypeProvider Class
XmlClassificationTypeProvider Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Properties

XmlClassificationTypeProvider Properties

The XmlClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | Registry | Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
Public property | XmlAttribute | Gets the XmlAttribute classification type.
Public property | XmlAttributeValue | Gets the XmlAttributeValue classification type.
Public property | XmlCDataSection | Gets the XmlCDataSection classification type.
Public property | XmlComment | Gets the XmlComment classification type.
Public property | XmlDeclaration | Gets the XmlDeclaration classification type.
Public property | XmlDelimiter | Gets the XmlDelimiter classification type.
Public property | XmlEntity | Gets the XmlEntity classification type.
Public property | XmlName | Gets the XmlName classification type.
Public property | XmlProcessingInstruction | Gets the XmlProcessingInstruction classification type.
Top
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.Registry Property

XmlClassificationTypeProviderRegistry Property
Gets the IHighlightingStyleRegistry to use when registering classification types and highlighting styles.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry Registry { get; }
Public ReadOnly Property Registry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlAttribute Property

XmlClassificationTypeProviderXmlAttribute Property
Gets the XmlAttribute classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlAttribute { get; }
Public ReadOnly Property XmlAttribute As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttribute classification type.

Implements

IXmlClassificationTypeProviderXmlAttribute
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlAttributeValue Property

XmlClassificationTypeProviderXmlAttributeValue Property
Gets the XmlAttributeValue classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlAttributeValue { get; }
Public ReadOnly Property XmlAttributeValue As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlAttributeValue classification type.

Implements

IXmlClassificationTypeProviderXmlAttributeValue
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlCDataSection Property

XmlClassificationTypeProviderXmlCDataSection Property
Gets the XmlCDataSection classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlCDataSection { get; }
Public ReadOnly Property XmlCDataSection As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlCDataSection classification type.

Implements

IXmlClassificationTypeProviderXmlCDataSection
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlComment Property

XmlClassificationTypeProviderXmlComment Property
Gets the XmlComment classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlComment { get; }
Public ReadOnly Property XmlComment As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlComment classification type.

Implements

IXmlClassificationTypeProviderXmlComment
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlDeclaration Property

XmlClassificationTypeProviderXmlDeclaration Property
Gets the XmlDeclaration classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlDeclaration { get; }
Public ReadOnly Property XmlDeclaration As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDeclaration classification type.

Implements

IXmlClassificationTypeProviderXmlDeclaration
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlDelimiter Property

XmlClassificationTypeProviderXmlDelimiter Property
Gets the XmlDelimiter classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlDelimiter { get; }
Public ReadOnly Property XmlDelimiter As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlDelimiter classification type.

Implements

IXmlClassificationTypeProviderXmlDelimiter
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlEntity Property

XmlClassificationTypeProviderXmlEntity Property
Gets the XmlEntity classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlEntity { get; }
Public ReadOnly Property XmlEntity As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlEntity classification type.

Implements

IXmlClassificationTypeProviderXmlEntity
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlName Property

XmlClassificationTypeProviderXmlName Property
Gets the XmlName classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlName { get; }
Public ReadOnly Property XmlName As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlName classification type.

Implements

IXmlClassificationTypeProviderXmlName
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.XmlProcessingInstruction Property

XmlClassificationTypeProviderXmlProcessingInstruction Property
Gets the XmlProcessingInstruction classification type.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType XmlProcessingInstruction { get; }
Public ReadOnly Property XmlProcessingInstruction As IClassificationType
    Get

Property Value

Type: IClassificationType
The XmlProcessingInstruction classification type.

Implements

IXmlClassificationTypeProviderXmlProcessingInstruction
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider Methods

XmlClassificationTypeProvider Methods

The XmlClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlClassificationTypeProvider.RegisterAll Method

XmlClassificationTypeProviderRegisterAll Method
Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

XmlClassificationTypeProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Class

XmlCodeBlockFinder Class
Provides a XML language code block finder service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Analysis.ImplementationLLParseDataCodeBlockFinder
ActiproSoftware.Text.Languages.Xml.ImplementationXmlCodeBlockFinder

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlCodeBlockFinder : LLParseDataCodeBlockFinder
Public Class XmlCodeBlockFinder
    Inherits LLParseDataCodeBlockFinder

The XmlCodeBlockFinder type exposes the following members.

Constructors
 | Name | Description
Public method | XmlCodeBlockFinder | Initializes a new instance of the XmlCodeBlockFinder class
Top
Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Overrides LLParseDataCodeBlockFinderGetSnapshotRange(TextSnapshotRange, IAstNode, TextSnapshotRange).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Constructor

XmlCodeBlockFinder Constructor
Initializes a new instance of the XmlCodeBlockFinder class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlCodeBlockFinder()
Public Sub New
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Properties

XmlCodeBlockFinder Properties

The XmlCodeBlockFinder type exposes the following members.

Properties
 | Name | Description
Public property | Filter | Gets or sets the optional callback used to determine if a potential IAstNode result is valid. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder Methods

XmlCodeBlockFinder Methods

The XmlCodeBlockFinder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindContaining | Returns the TextSnapshotRange of the containing code block. (Inherited from LLParseDataCodeBlockFinder.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetSnapshotRange | Returns a TextSnapshotRange for the specified IAstNode. (Overrides LLParseDataCodeBlockFinderGetSnapshotRange(TextSnapshotRange, IAstNode, TextSnapshotRange).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Protected method | TranslateToParseDataSnapshot | Translates the specified snapshot offset to the parse data's Snapshot, if possible, prior to containing AST node lookup. (Inherited from LLParseDataCodeBlockFinder.)
Top
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlCodeBlockFinder.GetSnapshotRange Method

XmlCodeBlockFinderGetSnapshotRange Method
Returns a TextSnapshotRange for the specified IAstNode.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override TextSnapshotRange GetSnapshotRange(
    TextSnapshotRange searchSnapshotRange,
    IAstNode astNode,
    TextSnapshotRange astNodeSnapshotRange
)
Protected Overrides Function GetSnapshotRange (
    searchSnapshotRange As TextSnapshotRange,
    astNode As IAstNode,
    astNodeSnapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

searchSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange from which to begin the search.
astNode
Type: ActiproSoftware.Text.ParsingIAstNode
The IAstNode that was found to contain the search snapshot range.
astNodeSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The full snapshot range of the IAstNode.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange for the specified IAstNode.
Remarks
The default implementation of this method returns the astNodeSnapshotRange value. This method can optionally be used to adjust the snapshot range for an AST node as necessary.
See Also

Reference

XmlCodeBlockFinder Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory Class

XmlContextFactory Class
Creates IXmlContext objects for a TextSnapshotOffset.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlContextFactory

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlContextFactory
Public Class XmlContextFactory

The XmlContextFactory type exposes the following members.

Constructors
 | Name | Description
Public method | XmlContextFactory | Initializes a new instance of the XmlContextFactory class
Top
Methods
 | Name | Description
Public method | CreateContext | Creates an IXmlContext for the specified TextSnapshotOffset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory Constructor

XmlContextFactory Constructor
Initializes a new instance of the XmlContextFactory class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlContextFactory()
Public Sub New
See Also

Reference

XmlContextFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory Methods

XmlContextFactory Methods

The XmlContextFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateContext | Creates an IXmlContext for the specified TextSnapshotOffset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlContextFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlContextFactory.CreateContext Method

XmlContextFactoryCreateContext Method
Creates an IXmlContext for the specified TextSnapshotOffset.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IXmlContext CreateContext(
    TextSnapshotOffset snapshotOffset
)
Public Function CreateContext (
    snapshotOffset As TextSnapshotOffset
) As IXmlContext

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset for which to create a context.

Return Value

Type: IXmlContext
The IXmlContext that was created.
See Also

Reference

XmlContextFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter Class

XmlEndTagAutoCompleter Class
Provides a class that can auto-complete XML end tags when appropriate.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlEndTagAutoCompleter

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlEndTagAutoCompleter : IXmlEndTagAutoCompleter
Public Class XmlEndTagAutoCompleter
    Implements IXmlEndTagAutoCompleter

The XmlEndTagAutoCompleter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlEndTagAutoCompleter | Initializes a new instance of the XmlEndTagAutoCompleter class
Top
Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlEndTagAutoCompleter interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter Constructor

XmlEndTagAutoCompleter Constructor
Initializes a new instance of the XmlEndTagAutoCompleter class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlEndTagAutoCompleter()
Public Sub New
See Also

Reference

XmlEndTagAutoCompleter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter Methods

XmlEndTagAutoCompleter Methods

The XmlEndTagAutoCompleter type exposes the following members.

Methods
 | Name | Description
Public method | AutoComplete | Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlEndTagAutoCompleter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlEndTagAutoCompleter.AutoComplete Method

XmlEndTagAutoCompleterAutoComplete Method
Checks whether an automatic end tag insertion should occur in the specified IEditorView and performs it if appropriate.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AutoComplete(
    IEditorView view
)
Public Sub AutoComplete (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Implements

IXmlEndTagAutoCompleterAutoComplete(IEditorView)
See Also

Reference

XmlEndTagAutoCompleter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Class

XmlExampleTextProvider Class
Represents a example text provider for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlExampleTextProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlExampleTextProvider : IExampleTextProvider
Public Class XmlExampleTextProvider
    Implements IExampleTextProvider

The XmlExampleTextProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlExampleTextProvider | Initializes a new instance of the XmlExampleTextProvider class
Top
Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Constructor

XmlExampleTextProvider Constructor
Initializes a new instance of the XmlExampleTextProvider class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlExampleTextProvider()
Public Sub New
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Properties

XmlExampleTextProvider Properties

The XmlExampleTextProvider type exposes the following members.

Properties
 | Name | Description
Public property | ExampleText | Gets the example text, a code snippet of the related language.
Top
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider.ExampleText Property

XmlExampleTextProviderExampleText Property
Gets the example text, a code snippet of the related language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ExampleText { get; }
Public ReadOnly Property ExampleText As String
    Get

Property Value

Type: String
The example text, a code snippet of the related language.

Implements

IExampleTextProviderExampleText
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlExampleTextProvider Methods

XmlExampleTextProvider Methods

The XmlExampleTextProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlExampleTextProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Class

XmlGrammar Class
Represents a Grammar for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.Xml.ImplementationXmlGrammar

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlGrammar : Grammar
Public Class XmlGrammar
    Inherits Grammar

The XmlGrammar type exposes the following members.

Constructors
 | Name | Description
Public method | XmlGrammar | Initializes a new instance of the XmlGrammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Constructor

XmlGrammar Constructor
Initializes a new instance of the XmlGrammar class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlGrammar()
Public Sub New
See Also

Reference

XmlGrammar Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Properties

XmlGrammar Properties

The XmlGrammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Grammar.)
Public property | Key | Gets the string that identifies the grammar, generally the related language name. (Inherited from Grammar.)
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key. (Inherited from Grammar.)
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins. (Inherited from Grammar.)
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key. (Inherited from Grammar.)
Top
See Also

Reference

XmlGrammar Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlGrammar Methods

XmlGrammar Methods

The XmlGrammar type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage. (Inherited from Grammar.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form. (Inherited from Grammar.)
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled. (Inherited from Grammar.)
Top
See Also

Reference

XmlGrammar Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Class

XmlIndentProvider Class
Provides a XML language indent provider service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlIndentProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlIndentProvider : IIndentProvider,
    IEditorDocumentTextChangeEventSink
Public Class XmlIndentProvider
    Implements IIndentProvider, IEditorDocumentTextChangeEventSink

The XmlIndentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlIndentProvider | Initializes a new instance of the XmlIndentProvider class
Top
Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Constructor

XmlIndentProvider Constructor
Initializes a new instance of the XmlIndentProvider class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlIndentProvider()
Public Sub New
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Properties

XmlIndentProvider Properties

The XmlIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.Mode Property

XmlIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IndentMode Mode { get; }
Public ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.

Implements

IIndentProviderMode
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider Methods

XmlIndentProvider Methods

The XmlIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.GetIndentAmount Method

XmlIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Public Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.

Implements

IIndentProviderGetIndentAmount(TextSnapshotOffset, Int32)
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.OnDocumentTextChanged Method

XmlIndentProviderOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlIndentProvider.OnDocumentTextChanging Method

XmlIndentProviderOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

XmlIndentProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Class

XmlLexer Class
Represents a lexer for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexer

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlLexer : DynamicLexer
Public Class XmlLexer
    Inherits DynamicLexer

The XmlLexer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexer | Initializes a new instance of the XmlLexer class.
Top
Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered. (Inherited from DynamicLexer.)
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from DynamicLexer.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros. (Inherited from DynamicLexer.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states. (Inherited from DynamicLexer.)
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from DynamicLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from DynamicLexer.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from DynamicLexer.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from DynamicLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.2.550.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Constructor

XmlLexer Constructor
Initializes a new instance of the XmlLexer class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlLexer(
    IXmlClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IXmlClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.XmlIXmlClassificationTypeProvider
A IXmlClassificationTypeProvider that provides classification types used by this lexer.
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Properties

XmlLexer Properties

The XmlLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered. (Inherited from DynamicLexer.)
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from DynamicLexer.)
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros. (Inherited from DynamicLexer.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states. (Inherited from DynamicLexer.)
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from DynamicLexer.)
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Methods

XmlLexer Methods

The XmlLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from DynamicLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from DynamicLexer.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from DynamicLexer.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Inherited from DynamicLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexer Events

XmlLexer Events

The XmlLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

XmlLexer Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Class

XmlLexicalStateId Class
Contains the lexical state IDs for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexicalStateId

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlLexicalStateId : LexicalStateIdProviderBase
Public Class XmlLexicalStateId
    Inherits LexicalStateIdProviderBase

The XmlLexicalStateId type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLexicalStateId | Initializes a new instance of the XmlLexicalStateId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
CDataSection | Gets the CDataSection lexical state ID.
Comment | Gets the Comment lexical state ID.
Declaration | Gets the Declaration lexical state ID.
Default | Gets the Default lexical state ID.
DocTypeDeclaration | Gets the DocTypeDeclaration lexical state ID.
DocTypeDeclarationInternalSubset | Gets the DocTypeDeclarationInternalSubset lexical state ID.
EndTag | Gets the EndTag lexical state ID.
ProcessingInstruction | Gets the ProcessingInstruction lexical state ID.
StartTag | Gets the StartTag lexical state ID.
StartTagAttributeDoubleQuoteValue | Gets the StartTagAttributeDoubleQuoteValue lexical state ID.
StartTagAttributeSingleQuoteValue | Gets the StartTagAttributeSingleQuoteValue lexical state ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.543.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Constructor

XmlLexicalStateId Constructor
Initializes a new instance of the XmlLexicalStateId class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlLexicalStateId()
Public Sub New
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Properties

XmlLexicalStateId Properties

The XmlLexicalStateId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum lexical state ID returned by this provider. (Overrides LexicalStateIdProviderBaseMinId.)
Top
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.MaxId Property

XmlLexicalStateIdMaxId Property
Gets the maximum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum lexical state ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.MinId Property

XmlLexicalStateIdMinId Property
Gets the minimum lexical state ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum lexical state ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Methods

XmlLexicalStateId Methods

The XmlLexicalStateId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this lexical state ID provider. (Overrides LexicalStateIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified lexical state ID. (Overrides LexicalStateIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.ContainsId Method

XmlLexicalStateIdContainsId Method
Returns whether the specified ID value is valid for this lexical state ID provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.GetDescription Method

XmlLexicalStateIdGetDescription Method
Returns the actual string representation for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The actual string representation for the specified lexical state ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.GetKey Method

XmlLexicalStateIdGetKey Method
Returns the string-based key for the specified lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The lexical state ID to examine.

Return Value

Type: String
The string-based key for the specified lexical state ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId Fields

XmlLexicalStateId Fields

The XmlLexicalStateId type exposes the following members.

Fields
Name | Description
CDataSection | Gets the CDataSection lexical state ID.
Comment | Gets the Comment lexical state ID.
Declaration | Gets the Declaration lexical state ID.
Default | Gets the Default lexical state ID.
DocTypeDeclaration | Gets the DocTypeDeclaration lexical state ID.
DocTypeDeclarationInternalSubset | Gets the DocTypeDeclarationInternalSubset lexical state ID.
EndTag | Gets the EndTag lexical state ID.
ProcessingInstruction | Gets the ProcessingInstruction lexical state ID.
StartTag | Gets the StartTag lexical state ID.
StartTagAttributeDoubleQuoteValue | Gets the StartTagAttributeDoubleQuoteValue lexical state ID.
StartTagAttributeSingleQuoteValue | Gets the StartTagAttributeSingleQuoteValue lexical state ID.
Top
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.CDataSection Field

XmlLexicalStateIdCDataSection Field
Gets the CDataSection lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CDataSection = 11
Public Const CDataSection As Integer = 11

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.Comment Field

XmlLexicalStateIdComment Field
Gets the Comment lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Comment = 6
Public Const Comment As Integer = 6

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.Declaration Field

XmlLexicalStateIdDeclaration Field
Gets the Declaration lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Declaration = 10
Public Const Declaration As Integer = 10

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.Default Field

XmlLexicalStateIdDefault Field
Gets the Default lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Default = 1
Public Const Default As Integer = 1

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.DocTypeDeclaration Field

XmlLexicalStateIdDocTypeDeclaration Field
Gets the DocTypeDeclaration lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclaration = 8
Public Const DocTypeDeclaration As Integer = 8

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.DocTypeDeclarationInternalSubset Field

XmlLexicalStateIdDocTypeDeclarationInternalSubset Field
Gets the DocTypeDeclarationInternalSubset lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubset = 9
Public Const DocTypeDeclarationInternalSubset As Integer = 9

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.EndTag Field

XmlLexicalStateIdEndTag Field
Gets the EndTag lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EndTag = 5
Public Const EndTag As Integer = 5

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.ProcessingInstruction Field

XmlLexicalStateIdProcessingInstruction Field
Gets the ProcessingInstruction lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ProcessingInstruction = 7
Public Const ProcessingInstruction As Integer = 7

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.StartTag Field

XmlLexicalStateIdStartTag Field
Gets the StartTag lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTag = 2
Public Const StartTag As Integer = 2

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.StartTagAttributeDoubleQuoteValue Field

XmlLexicalStateIdStartTagAttributeDoubleQuoteValue Field
Gets the StartTagAttributeDoubleQuoteValue lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagAttributeDoubleQuoteValue = 3
Public Const StartTagAttributeDoubleQuoteValue As Integer = 3

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLexicalStateId.StartTagAttributeSingleQuoteValue Field

XmlLexicalStateIdStartTagAttributeSingleQuoteValue Field
Gets the StartTagAttributeSingleQuoteValue lexical state ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagAttributeSingleQuoteValue = 4
Public Const StartTagAttributeSingleQuoteValue As Integer = 4

Field Value

Type: Int32
See Also

Reference

XmlLexicalStateId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Class

XmlLineCommenter Class
Provides a XML language line commenter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationRangeLineCommenter
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLineCommenter

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlLineCommenter : RangeLineCommenter
Public Class XmlLineCommenter
    Inherits RangeLineCommenter

The XmlLineCommenter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlLineCommenter | Initializes a new instance of the XmlLineCommenter class.
Top
Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID. (Inherited from RangeLineCommenter.)
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Top
Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange. (Inherited from RangeLineCommenter.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any. (Overrides RangeLineCommenterFindCommentTextRange(TextSnapshotRange).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange. (Inherited from RangeLineCommenter.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Constructor

XmlLineCommenter Constructor
Initializes a new instance of the XmlLineCommenter class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlLineCommenter()
Public Sub New
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Properties

XmlLineCommenter Properties

The XmlLineCommenter type exposes the following members.

Properties
 | Name | Description
Public property | CommentTokenId | Gets or sets the comment token ID. (Inherited from RangeLineCommenter.)
Public property | EndDelimiter | Gets or sets the end delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Public property | StartDelimiter | Gets or sets the start delimiter text that is added or removed during comment/uncomment operations. (Inherited from RangeLineCommenter.)
Top
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter Methods

XmlLineCommenter Methods

The XmlLineCommenter type exposes the following members.

Methods
 | Name | Description
Public method | Comment | Comments out the lines of code in the specified TextSnapshotRange. (Inherited from RangeLineCommenter.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | FindCommentTextRange | Returns the full text range of the comment that surrounds the specified snapshot range, if any. (Overrides RangeLineCommenterFindCommentTextRange(TextSnapshotRange).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Public method | Uncomment | Uncomments the lines of code in the specified TextSnapshotRange. (Inherited from RangeLineCommenter.)
Top
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlLineCommenter.FindCommentTextRange Method

XmlLineCommenterFindCommentTextRange Method
Returns the full text range of the comment that surrounds the specified snapshot range, if any.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<TextRange> FindCommentTextRange(
    TextSnapshotRange snapshotRange
)
Protected Overrides Function FindCommentTextRange (
    snapshotRange As TextSnapshotRange
) As Nullable(Of TextRange)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: Nullable TextRange
The full text range of the comment that surrounds the specified snapshot range, if any.
See Also

Reference

XmlLineCommenter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider Class

XmlNavigableSymbolProvider Class
Represents a navigable symbol provider for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlNavigableSymbolProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlNavigableSymbolProvider : INavigableSymbolProvider
Public Class XmlNavigableSymbolProvider
    Implements INavigableSymbolProvider

The XmlNavigableSymbolProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlNavigableSymbolProvider | Initializes a new instance of the XmlNavigableSymbolProvider class
Top
Methods
 | Name | Description
Protected method | CreateAttributeSymbol | Creates an INavigableSymbol for an attribute.
Protected method | CreateElementSymbol | Creates an INavigableSymbol for an element.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider Constructor

XmlNavigableSymbolProvider Constructor
Initializes a new instance of the XmlNavigableSymbolProvider class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlNavigableSymbolProvider()
Public Sub New
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider Methods

XmlNavigableSymbolProvider Methods

The XmlNavigableSymbolProvider type exposes the following members.

Methods
 | Name | Description
Protected method | CreateAttributeSymbol | Creates an INavigableSymbol for an attribute.
Protected method | CreateElementSymbol | Creates an INavigableSymbol for an element.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetSymbols | Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider.CreateAttributeSymbol Method

XmlNavigableSymbolProviderCreateAttributeSymbol Method
Creates an INavigableSymbol for an attribute.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual INavigableSymbol CreateAttributeSymbol(
    ElementAttribute astNode,
    ITextSnapshot snapshot,
    int hierarchyLevel
)
Protected Overridable Function CreateAttributeSymbol (
    astNode As ElementAttribute,
    snapshot As ITextSnapshot,
    hierarchyLevel As Integer
) As INavigableSymbol

Parameters

astNode
Type: ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementAttribute
The ElementAttribute to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.
hierarchyLevel
Type: SystemInt32
The hierarchy level.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider.CreateElementSymbol Method

XmlNavigableSymbolProviderCreateElementSymbol Method
Creates an INavigableSymbol for an element.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual INavigableSymbol CreateElementSymbol(
    Element astNode,
    ITextSnapshot snapshot,
    int hierarchyLevel
)
Protected Overridable Function CreateElementSymbol (
    astNode As Element,
    snapshot As ITextSnapshot,
    hierarchyLevel As Integer
) As INavigableSymbol

Parameters

astNode
Type: ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElement
The Element to examine.
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot from which the AST was constructed.
hierarchyLevel
Type: SystemInt32
The hierarchy level.

Return Value

Type: INavigableSymbol
The INavigableSymbol that was created.
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlNavigableSymbolProvider.GetSymbols Method

XmlNavigableSymbolProviderGetSymbols Method
Returns a set of INavigableSymbol objects that are accessible within the optional parent INavigableSymbol.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual INavigableSymbolSet GetSymbols(
    INavigableRequestContext context,
    TextSnapshotOffset snapshotOffset,
    INavigableSymbol parentSymbol
)
Public Overridable Function GetSymbols (
    context As INavigableRequestContext,
    snapshotOffset As TextSnapshotOffset,
    parentSymbol As INavigableSymbol
) As INavigableSymbolSet

Parameters

context
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableRequestContext
An INavigableRequestContext that provides the context of the request.
snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset that contains the ITextSnapshot to examine, along with a contextual offset.
parentSymbol
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptINavigableSymbol
The optional parent INavigableSymbol to examine, or a null value if the root symbols are requested.

Return Value

Type: INavigableSymbolSet
An INavigableSymbolSet containing the INavigableSymbol objects that were located.

Implements

INavigableSymbolProviderGetSymbols(INavigableRequestContext, TextSnapshotOffset, INavigableSymbol)
See Also

Reference

XmlNavigableSymbolProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Class

XmlOutliner Class
Provides a XML language outliner service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlOutliner

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlOutliner : IOutliner
Public Class XmlOutliner
    Implements IOutliner

The XmlOutliner type exposes the following members.

Constructors
 | Name | Description
Public method | XmlOutliner | Initializes a new instance of the XmlOutliner class
Top
Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Constructor

XmlOutliner Constructor
Initializes a new instance of the XmlOutliner class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlOutliner()
Public Sub New
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Properties

XmlOutliner Properties

The XmlOutliner type exposes the following members.

Properties
 | Name | Description
Public property | UpdateTrigger | Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.
Top
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner.UpdateTrigger Property

XmlOutlinerUpdateTrigger Property
Gets an AutomaticOutliningUpdateTrigger indicating whether automatic outlining should update in the main thread following a text change, or rather be driven via parse data results.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomaticOutliningUpdateTrigger UpdateTrigger { get; }
Public ReadOnly Property UpdateTrigger As AutomaticOutliningUpdateTrigger
    Get

Property Value

Type: AutomaticOutliningUpdateTrigger
An AutomaticOutliningUpdateTrigger indicating the trigger by which automatic outlining should update.

Implements

IOutlinerUpdateTrigger
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner Methods

XmlOutliner Methods

The XmlOutliner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOutliningSource | Returns an IOutliningSource for the specified ITextSnapshot.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlOutliner.GetOutliningSource Method

XmlOutlinerGetOutliningSource Method
Returns an IOutliningSource for the specified ITextSnapshot.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IOutliningSource GetOutliningSource(
    ITextSnapshot snapshot
)
Public Function GetOutliningSource (
    snapshot As ITextSnapshot
) As IOutliningSource

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot for which to return an outlining source.

Return Value

Type: IOutliningSource
An IOutliningSource for the specified ITextSnapshot.

Implements

IOutlinerGetOutliningSource(ITextSnapshot)
See Also

Reference

XmlOutliner Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Class

XmlParseData Class
Stores the results of a XML language parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParseData

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlParseData : LLParseData,
    IXmlParseData, ILLParseData, IParseData, IParseErrorProvider
Public Class XmlParseData
    Inherits LLParseData
    Implements IXmlParseData, ILLParseData, IParseData, IParseErrorProvider

The XmlParseData type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParseData | Initializes a new instance of the XmlParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Constructor

XmlParseData Constructor
Initializes a new instance of the XmlParseData class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlParseData()
Public Sub New
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Properties

XmlParseData Properties

The XmlParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result. (Inherited from LLParseData.)
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors. (Inherited from LLParseData.)
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from LLParseData.)
Top
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData.IsWellFormed Property

XmlParseDataIsWellFormed Property
Gets or sets whether the XML is well-formed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWellFormed { get; set; }
Public Property IsWellFormed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the XML is well-formed; otherwise, false.

Implements

IXmlParseDataIsWellFormed
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParseData Methods

XmlParseData Methods

The XmlParseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlParseData Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Class

XmlParser Class
Represents a parser for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParser

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlParser : XmlParserBase
Public Class XmlParser
    Inherits XmlParserBase

The XmlParser type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class.
Public method | XmlParser(Grammar) | Initializes a new instance of the XmlParser class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from XmlParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from XmlParserBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Protected method | Validate | Validates XML if no parse errors were found. (Inherited from XmlParserBase.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Constructor

XmlParser Constructor
Overload List
 | Name | Description
Public method | XmlParser | Initializes a new instance of the XmlParser class.
Public method | XmlParser(Grammar) | Initializes a new instance of the XmlParser class.
Top
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Constructor

XmlParser Constructor
Initializes a new instance of the XmlParser class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlParser()
Public Sub New
See Also

Reference

XmlParser Class
XmlParser Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Constructor (Grammar)

XmlParser Constructor (Grammar)
Initializes a new instance of the XmlParser class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlParser(
    Grammar grammar
)
Public Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

XmlParser Class
XmlParser Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Properties

XmlParser Properties

The XmlParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser Methods

XmlParser Methods

The XmlParser type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Inherited from XmlParserBase.)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Overrides LLParserBaseCreateTokenReader(ITextBufferReader).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Inherited from XmlParserBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Protected method | Validate | Validates XML if no parse errors were found. (Inherited from XmlParserBase.)
Top
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParser.CreateTokenReader Method

XmlParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public Overrides Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

XmlParser Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Class

XmlParserBase Class
Provides an abstract base class of a parser for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParser

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XmlParserBase : LLParserBase
Public MustInherit Class XmlParserBase
    Inherits LLParserBase

The XmlParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlParserBase | Initializes a new instance of the XmlParserBase class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Protected method | Validate | Validates XML if no parse errors were found.
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Constructor

XmlParserBase Constructor
Initializes a new instance of the XmlParserBase class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected XmlParserBase(
    Grammar grammar
)
Protected Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar instance to use.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Properties

XmlParserBase Properties

The XmlParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser. (Inherited from LLParserBase.)
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase Methods

XmlParserBase Methods

The XmlParserBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState. (Overrides LLParserBaseCreateParseData(IParseRequest, IParserState).)
Protected method | CreateParserState | Creates an IParserState for a parse operation. (Inherited from LLParserBase.)
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens. (Inherited from LLParserBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState. (Inherited from LLParserBase.)
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running. (Overrides LLParserBaseInitializeParserState(IParserState, IParseRequest).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from LLParserBase.)
Public method | ToString | (Inherited from Object.)
Protected method | Validate | Validates XML if no parse errors were found.
Top
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase.CreateParseData Method

XmlParserBaseCreateParseData Method
Creates an IParseData for the specified IParserState.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overrides Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase.InitializeParserState Method

XmlParserBaseInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overrides Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserBase.Validate Method

XmlParserBaseValidate Method
Validates XML if no parse errors were found.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void Validate(
    IParseRequest request,
    IParserState state
)
Protected Overridable Sub Validate (
    request As IParseRequest,
    state As IParserState
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
See Also

Reference

XmlParserBase Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Class

XmlParserContext Class
Stores parser context information for a XML language grammar parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserContext

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlParserContext
Public Class XmlParserContext

The XmlParserContext type exposes the following members.

Constructors
 | Name | Description
Public method | XmlParserContext | Initializes a new instance of the XmlParserContext class.
Top
Properties
 | Name | Description
Public property | ElementStack | Gets the element stack.
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Constructor

XmlParserContext Constructor
Initializes a new instance of the XmlParserContext class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlParserContext()
Public Sub New
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Properties

XmlParserContext Properties

The XmlParserContext type exposes the following members.

Properties
 | Name | Description
Public property | ElementStack | Gets the element stack.
Public property | IsWellFormed | Gets or sets whether the XML is well-formed.
Top
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext.ElementStack Property

XmlParserContextElementStack Property
Gets the element stack.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Stack<IAstNode> ElementStack { get; }
Public ReadOnly Property ElementStack As Stack(Of IAstNode)
    Get

Property Value

Type: Stack IAstNode
The element stack.
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext.IsWellFormed Property

XmlParserContextIsWellFormed Property
Gets or sets whether the XML is well-formed.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWellFormed { get; set; }
Public Property IsWellFormed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the XML is well-formed; otherwise, false.
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlParserContext Methods

XmlParserContext Methods

The XmlParserContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlParserContext Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Class

XmlQuickInfoProvider Class
Provides IntelliPrompt quick info data for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPrompt.ImplementationQuickInfoProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlQuickInfoProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlQuickInfoProvider : QuickInfoProviderBase
Public Class XmlQuickInfoProvider
    Inherits QuickInfoProviderBase

The XmlQuickInfoProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlQuickInfoProvider | Initializes a new instance of the XmlQuickInfoProvider class.
Top
Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Constructor

XmlQuickInfoProvider Constructor
Initializes a new instance of the XmlQuickInfoProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlQuickInfoProvider()
Public Sub New
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Properties

XmlQuickInfoProvider Properties

The XmlQuickInfoProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanTrackMouseInput | Gets whether to track mouse input and allow mouse movement/hovers to possibly open another quick info session. (Inherited from QuickInfoProviderBase.)
Protected property | ContextTypes | Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods. (Overrides QuickInfoProviderBaseContextTypes.)
Public property | Key | Gets the string-based key that identifies the provider. (Inherited from QuickInfoProviderBase.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.ContextTypes Property

XmlQuickInfoProviderContextTypes Property
Gets the context Type objects that are supported by this provider, which are the list of custom types that are possibly returned by the GetContext(IHitTestResult) methods.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable<Type> ContextTypes { get; }
Protected Overrides ReadOnly Property ContextTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The context Type objects that are supported by this provider.
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider Methods

XmlQuickInfoProvider Methods

The XmlQuickInfoProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnSessionOpening | Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.GetContext Method

XmlQuickInfoProviderGetContext Method
Overload List
 | Name | Description
Public method | GetContext(IHitTestResult) | Returns an object describing the quick info context for the specified IHitTestResult, if any. (Inherited from QuickInfoProviderBase.)
Public method | GetContext(IEditorView, Int32) | Returns an object describing the quick info context for the specified text offset, if any. (Overrides QuickInfoProviderBaseGetContext(IEditorView, Int32).)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.GetContext Method (IEditorView, Int32)

XmlQuickInfoProviderGetContext Method (IEditorView, Int32)
Returns an object describing the quick info context for the specified text offset, if any.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetContext(
    IEditorView view,
    int offset
)
Public Overrides Function GetContext (
    view As IEditorView,
    offset As Integer
) As Object

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which the offset is located.
offset
Type: SystemInt32
The text offset to examine.

Return Value

Type: Object
An object describing the quick info context for the specified text offset, if any. A value indicates that no context is available.

Implements

IQuickInfoProviderGetContext(IEditorView, Int32)
Remarks
This method is called in response to keyboard events.
See Also

Reference

XmlQuickInfoProvider Class
GetContext Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.OnSessionOpening Method

XmlQuickInfoProviderOnSessionOpening Method
Allows an inheritor to modify, filter and sort automatically-generated items before the specified IQuickInfoSession is opened and displayed to the end user. The session may also be cancelled.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool OnSessionOpening(
    IQuickInfoSession session
)
Protected Overridable Function OnSessionOpening (
    session As IQuickInfoSession
) As Boolean

Parameters

session
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIQuickInfoSession
The IQuickInfoSession about to be opened.

Return Value

Type: Boolean
true if the session is allowed to open; otherwise, false.
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.RequestSession Method

XmlQuickInfoProviderRequestSession Method
Overload List
 | Name | Description
Protected method | RequestSession(IEditorView, Object) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Overrides QuickInfoProviderBaseRequestSession(IEditorView, Object).)
Public method | RequestSession(IEditorView, Object, Boolean) | Requests that an IQuickInfoSession be opened for the specified IEditorView. (Inherited from QuickInfoProviderBase.)
Top
See Also

Reference

XmlQuickInfoProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlQuickInfoProvider.RequestSession Method (IEditorView, Object)

XmlQuickInfoProviderRequestSession Method (IEditorView, Object)
Requests that an IQuickInfoSession be opened for the specified IEditorView.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool RequestSession(
    IEditorView view,
    Object context
)
Protected Overrides Function RequestSession (
    view As IEditorView,
    context As Object
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that will host the session.
context
Type: SystemObject
A context object returned by GetContext(IEditorView, Int32).

Return Value

Type: Boolean
true if a session was opened; otherwise, false.
See Also

Reference

XmlQuickInfoProvider Class
RequestSession Overload
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Class

XmlSchemaResolver Class
Provides a class that can manage XML schema data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSchemaResolver

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlSchemaResolver : IXmlSchemaResolver
Public Class XmlSchemaResolver
    Implements IXmlSchemaResolver

The XmlSchemaResolver type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSchemaResolver | Initializes a new instance of the XmlSchemaResolver class.
Top
Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the IXmlSchemaResolver interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Constructor

XmlSchemaResolver Constructor
Initializes a new instance of the XmlSchemaResolver class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlSchemaResolver()
Public Sub New
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Properties

XmlSchemaResolver Properties

The XmlSchemaResolver type exposes the following members.

Properties
 | Name | Description
Public property | DefaultNamespace | Gets or sets the default XML namespace to use.
Public property | DefaultNamespacePrefixMappings | Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.
Top
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.DefaultNamespace Property

XmlSchemaResolverDefaultNamespace Property
Gets or sets the default XML namespace to use.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DefaultNamespace { get; set; }
Public Property DefaultNamespace As String
    Get
    Set

Property Value

Type: String
The default XML namespace to use.

Implements

IXmlSchemaResolverDefaultNamespace
Remarks
The default namespace is used to mimic an xmlns attribute setting on the root element, if no xmlns attribute is present. It sets an empty-string-keyed value into the DefaultNamespacePrefixMappings dictionary.
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver.DefaultNamespacePrefixMappings Property

XmlSchemaResolverDefaultNamespacePrefixMappings Property
Gets the mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDictionary<string, string> DefaultNamespacePrefixMappings { get; }
Public ReadOnly Property DefaultNamespacePrefixMappings As IDictionary(Of String, String)
    Get

Property Value

Type: IDictionary String, String
The mapping dictionary of namespace prefix to namespaces that are declared by default without the need for xmlns attributes in elements.

Implements

IXmlSchemaResolverDefaultNamespacePrefixMappings
Remarks
The dictionary keys are namespace prefixes and the values are namespaces. The namespace declarations in this dictionary are used to mimic xmlns attribute settings on the root element when no xmlns declaration attributes for the specified namespace prefix keys are present.

The DefaultNamespace property is simply a wrapper for setting an empty-string-keyed value in this dictionary.

See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSchemaResolver Methods

XmlSchemaResolver Methods

The XmlSchemaResolver type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlSchemaResolver Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Class

XmlSyntaxLanguage Class
Represents a XML syntax language definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ImplementationSyntaxLanguage
ActiproSoftware.Text.Languages.Xml.ImplementationXmlSyntaxLanguage

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlSyntaxLanguage : SyntaxLanguage,
    IEditorDocumentTextChangeEventSink, ITextViewLifecycleEventSink
Public Class XmlSyntaxLanguage
    Inherits SyntaxLanguage
    Implements IEditorDocumentTextChangeEventSink, ITextViewLifecycleEventSink

The XmlSyntaxLanguage type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSyntaxLanguage | Initializes a new instance of the XmlSyntaxLanguage class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Constructor

XmlSyntaxLanguage Constructor
Initializes a new instance of the XmlSyntaxLanguage class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlSyntaxLanguage()
Public Sub New
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Properties

XmlSyntaxLanguage Properties

The XmlSyntaxLanguage type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string that identifies the language. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Methods

XmlSyntaxLanguage Methods

The XmlSyntaxLanguage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered. (Inherited from SyntaxLanguage.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetService(Object) | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetServiceT | Returns the service that has been registered with the specified type. (Inherited from SyntaxLanguage.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDocumentTextChanged | Occurs after a text change occurs to an IEditorDocument that uses this language.
Protected method | OnDocumentTextChanging | Occurs before a text change occurs to an IEditorDocument that uses this language.
Protected method | OnServiceAdded | Raises the ServiceAdded event. (Inherited from SyntaxLanguage.)
Protected method | OnServiceRemoved | Raises the ServiceRemoved event. (Inherited from SyntaxLanguage.)
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type. (Inherited from SyntaxLanguage.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterService(Object) | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Public method | UnregisterServiceT | Unregisters a service of the specified service type. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage.OnDocumentTextChanged Method

XmlSyntaxLanguageOnDocumentTextChanged Method
Occurs after a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Protected Overridable Sub OnDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage.OnDocumentTextChanging Method

XmlSyntaxLanguageOnDocumentTextChanging Method
Occurs before a text change occurs to an IEditorDocument that uses this language.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.SyntaxEditor.Addons.Xml.Universal (in AS.SyntaxEditor.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Protected Overridable Sub OnDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlSyntaxLanguage Events

XmlSyntaxLanguage Events

The XmlSyntaxLanguage type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object. (Inherited from SyntaxLanguage.)
Public event | ServiceRemoved | Occurs after a service is removed from the object. (Inherited from SyntaxLanguage.)
Top
See Also

Reference

XmlSyntaxLanguage Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Class

XmlTextFormatter Class
Provides a XML language text formatter service.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTextFormatter

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTextFormatter : ITextFormatter
Public Class XmlTextFormatter
    Implements ITextFormatter

The XmlTextFormatter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTextFormatter | Initializes a new instance of the XmlTextFormatter class
Top
Properties
 | Name | Description
Public property | AttributeSpacingMode | Gets or sets the attribute spacing mode.
Public property | ElementSpacingMode | Gets or sets the element spacing mode.
Public property | TagWrapLength | Gets or sets the tag wrap length.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Constructor

XmlTextFormatter Constructor
Initializes a new instance of the XmlTextFormatter class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTextFormatter()
Public Sub New
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Properties

XmlTextFormatter Properties

The XmlTextFormatter type exposes the following members.

Properties
 | Name | Description
Public property | AttributeSpacingMode | Gets or sets the attribute spacing mode.
Public property | ElementSpacingMode | Gets or sets the element spacing mode.
Public property | TagWrapLength | Gets or sets the tag wrap length.
Top
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.AttributeSpacingMode Property

XmlTextFormatterAttributeSpacingMode Property
Gets or sets the attribute spacing mode.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAttributeSpacingMode AttributeSpacingMode { get; set; }
Public Property AttributeSpacingMode As XmlAttributeSpacingMode
    Get
    Set

Property Value

Type: XmlAttributeSpacingMode
The attribute spacing mode. The default value is Preserve.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.ElementSpacingMode Property

XmlTextFormatterElementSpacingMode Property
Gets or sets the element spacing mode.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlElementSpacingMode ElementSpacingMode { get; set; }
Public Property ElementSpacingMode As XmlElementSpacingMode
    Get
    Set

Property Value

Type: XmlElementSpacingMode
The element spacing mode. The default value is Preserve.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.TagWrapLength Property

XmlTextFormatterTagWrapLength Property
Gets or sets the tag wrap length.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TagWrapLength { get; set; }
Public Property TagWrapLength As Integer
    Get
    Set

Property Value

Type: Int32
The tag wrap length. The default value is 0 which means disabled.
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter Methods

XmlTextFormatter Methods

The XmlTextFormatter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | Format | Formats the specified snapshot range.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTextFormatter.Format Method

XmlTextFormatterFormat Method
Formats the specified snapshot range.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Format(
    TextSnapshotRange snapshotRange
)
Public Sub Format (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The snapshot range.

Implements

ITextFormatterFormat(TextSnapshotRange)
See Also

Reference

XmlTextFormatter Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Class

XmlTokenId Class
Contains the token IDs for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenId

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTokenId : TokenIdProviderBase
Public Class XmlTokenId
    Inherits TokenIdProviderBase

The XmlTokenId type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenId | Initializes a new instance of the XmlTokenId class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsXmlAttributeClassificationType | Returns whether the specified ID value is part of the XmlAttribute.
 | IsXmlAttributeValueClassificationType | Returns whether the specified ID value is part of the XmlAttributeValue.
 | IsXmlCDataSectionClassificationType | Returns whether the specified ID value is part of the XmlCDataSection.
 | IsXmlCommentClassificationType | Returns whether the specified ID value is part of the XmlComment.
 | IsXmlDeclarationClassificationType | Returns whether the specified ID value is part of the XmlDeclaration.
 | IsXmlDelimiterClassificationType | Returns whether the specified ID value is part of the XmlDelimiter.
 | IsXmlEntityClassificationType | Returns whether the specified ID value is part of the XmlEntity.
 | IsXmlNameClassificationType | Returns whether the specified ID value is part of the XmlName.
 | IsXmlProcessingInstructionClassificationType | Returns whether the specified ID value is part of the XmlProcessingInstruction.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
CDataSectionEndDelimiter | Gets the CDataSectionEndDelimiter token ID.
CDataSectionStartDelimiter | Gets the CDataSectionStartDelimiter token ID.
CDataSectionText | Gets the CDataSectionText token ID.
CommentEndDelimiter | Gets the CommentEndDelimiter token ID.
CommentStartDelimiter | Gets the CommentStartDelimiter token ID.
CommentText | Gets the CommentText token ID.
DeclarationEndDelimiter | Gets the DeclarationEndDelimiter token ID.
DeclarationStartDelimiter | Gets the DeclarationStartDelimiter token ID.
DeclarationText | Gets the DeclarationText token ID.
Default | Gets the Default token ID.
DocTypeDeclarationEndDelimiter | Gets the DocTypeDeclarationEndDelimiter token ID.
DocTypeDeclarationInternalSubsetEndDelimiter | Gets the DocTypeDeclarationInternalSubsetEndDelimiter token ID.
DocTypeDeclarationInternalSubsetStartDelimiter | Gets the DocTypeDeclarationInternalSubsetStartDelimiter token ID.
DocTypeDeclarationInternalSubsetText | Gets the DocTypeDeclarationInternalSubsetText token ID.
DocTypeDeclarationStartDelimiter | Gets the DocTypeDeclarationStartDelimiter token ID.
EndTagEndDelimiter | Gets the EndTagEndDelimiter token ID.
EndTagStartDelimiter | Gets the EndTagStartDelimiter token ID.
EndTagText | Gets the EndTagText token ID.
Entity | Gets the Entity token ID.
Identifier | Gets the Identifier token ID.
InvalidEndTagStartDelimiter | Gets the InvalidEndTagStartDelimiter token ID.
InvalidStartTagStartDelimiter | Gets the InvalidStartTagStartDelimiter token ID.
ProcessingInstructionEndDelimiter | Gets the ProcessingInstructionEndDelimiter token ID.
ProcessingInstructionStartDelimiter | Gets the ProcessingInstructionStartDelimiter token ID.
ProcessingInstructionText | Gets the ProcessingInstructionText token ID.
StartTagAttributeName | Gets the StartTagAttributeName token ID.
StartTagAttributeValueEndDelimiter | Gets the StartTagAttributeValueEndDelimiter token ID.
StartTagAttributeValueStartDelimiter | Gets the StartTagAttributeValueStartDelimiter token ID.
StartTagAttributeValueText | Gets the StartTagAttributeValueText token ID.
StartTagEndDelimiter | Gets the StartTagEndDelimiter token ID.
StartTagName | Gets the StartTagName token ID.
StartTagNextTagStartDelimiter | Gets the StartTagNextTagStartDelimiter token ID.
StartTagStartDelimiter | Gets the StartTagStartDelimiter token ID.
StartTagText | Gets the StartTagText token ID.
Whitespace | Gets the Whitespace token ID.
Top
Remarks
This type was generated by the Actipro Language Designer tool v14.2.611.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Constructor

XmlTokenId Constructor
Initializes a new instance of the XmlTokenId class

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTokenId()
Public Sub New
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Properties

XmlTokenId Properties

The XmlTokenId type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum token ID returned by this provider. (Overrides TokenIdProviderBaseMaxId.)
Public property | MinId | Gets the minimum token ID returned by this provider. (Overrides TokenIdProviderBaseMinId.)
Top
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.MaxId Property

XmlTokenIdMaxId Property
Gets the maximum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MaxId { get; }
Public Overrides ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum token ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.MinId Property

XmlTokenIdMinId Property
Gets the minimum token ID returned by this provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int MinId { get; }
Public Overrides ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum token ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Methods

XmlTokenId Methods

The XmlTokenId type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this token ID provider. (Overrides TokenIdProviderBaseContainsId(Int32).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified token ID. (Overrides TokenIdProviderBaseGetDescription(Int32).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified token ID. (Overrides TokenIdProviderBaseGetKey(Int32).)
Public method | GetType | (Inherited from Object.)
 | IsXmlAttributeClassificationType | Returns whether the specified ID value is part of the XmlAttribute.
 | IsXmlAttributeValueClassificationType | Returns whether the specified ID value is part of the XmlAttributeValue.
 | IsXmlCDataSectionClassificationType | Returns whether the specified ID value is part of the XmlCDataSection.
 | IsXmlCommentClassificationType | Returns whether the specified ID value is part of the XmlComment.
 | IsXmlDeclarationClassificationType | Returns whether the specified ID value is part of the XmlDeclaration.
 | IsXmlDelimiterClassificationType | Returns whether the specified ID value is part of the XmlDelimiter.
 | IsXmlEntityClassificationType | Returns whether the specified ID value is part of the XmlEntity.
 | IsXmlNameClassificationType | Returns whether the specified ID value is part of the XmlName.
 | IsXmlProcessingInstructionClassificationType | Returns whether the specified ID value is part of the XmlProcessingInstruction.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ContainsId Method

XmlTokenIdContainsId Method
Returns whether the specified ID value is valid for this token ID provider.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool ContainsId(
    int id
)
Public Overrides Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.GetDescription Method

XmlTokenIdGetDescription Method
Returns the actual string representation for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetDescription(
    int id
)
Public Overrides Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The actual string representation for the specified token ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.GetKey Method

XmlTokenIdGetKey Method
Returns the string-based key for the specified token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string GetKey(
    int id
)
Public Overrides Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: String
The string-based key for the specified token ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlAttributeClassificationType Method

XmlTokenIdIsXmlAttributeClassificationType Method
Returns whether the specified ID value is part of the XmlAttribute.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlAttributeClassificationType(
    int id
)
Public Shared Function IsXmlAttributeClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlAttributeValueClassificationType Method

XmlTokenIdIsXmlAttributeValueClassificationType Method
Returns whether the specified ID value is part of the XmlAttributeValue.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlAttributeValueClassificationType(
    int id
)
Public Shared Function IsXmlAttributeValueClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlCDataSectionClassificationType Method

XmlTokenIdIsXmlCDataSectionClassificationType Method
Returns whether the specified ID value is part of the XmlCDataSection.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlCDataSectionClassificationType(
    int id
)
Public Shared Function IsXmlCDataSectionClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlCommentClassificationType Method

XmlTokenIdIsXmlCommentClassificationType Method
Returns whether the specified ID value is part of the XmlComment.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlCommentClassificationType(
    int id
)
Public Shared Function IsXmlCommentClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlDeclarationClassificationType Method

XmlTokenIdIsXmlDeclarationClassificationType Method
Returns whether the specified ID value is part of the XmlDeclaration.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlDeclarationClassificationType(
    int id
)
Public Shared Function IsXmlDeclarationClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlDelimiterClassificationType Method

XmlTokenIdIsXmlDelimiterClassificationType Method
Returns whether the specified ID value is part of the XmlDelimiter.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlDelimiterClassificationType(
    int id
)
Public Shared Function IsXmlDelimiterClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlEntityClassificationType Method

XmlTokenIdIsXmlEntityClassificationType Method
Returns whether the specified ID value is part of the XmlEntity.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlEntityClassificationType(
    int id
)
Public Shared Function IsXmlEntityClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlNameClassificationType Method

XmlTokenIdIsXmlNameClassificationType Method
Returns whether the specified ID value is part of the XmlName.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlNameClassificationType(
    int id
)
Public Shared Function IsXmlNameClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.IsXmlProcessingInstructionClassificationType Method

XmlTokenIdIsXmlProcessingInstructionClassificationType Method
Returns whether the specified ID value is part of the XmlProcessingInstruction.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsXmlProcessingInstructionClassificationType(
    int id
)
Public Shared Function IsXmlProcessingInstructionClassificationType (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The token ID to examine.

Return Value

Type: Boolean
true if the ID value is in the classification type; otherwise, false
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId Fields

XmlTokenId Fields

The XmlTokenId type exposes the following members.

Fields
Name | Description
CDataSectionEndDelimiter | Gets the CDataSectionEndDelimiter token ID.
CDataSectionStartDelimiter | Gets the CDataSectionStartDelimiter token ID.
CDataSectionText | Gets the CDataSectionText token ID.
CommentEndDelimiter | Gets the CommentEndDelimiter token ID.
CommentStartDelimiter | Gets the CommentStartDelimiter token ID.
CommentText | Gets the CommentText token ID.
DeclarationEndDelimiter | Gets the DeclarationEndDelimiter token ID.
DeclarationStartDelimiter | Gets the DeclarationStartDelimiter token ID.
DeclarationText | Gets the DeclarationText token ID.
Default | Gets the Default token ID.
DocTypeDeclarationEndDelimiter | Gets the DocTypeDeclarationEndDelimiter token ID.
DocTypeDeclarationInternalSubsetEndDelimiter | Gets the DocTypeDeclarationInternalSubsetEndDelimiter token ID.
DocTypeDeclarationInternalSubsetStartDelimiter | Gets the DocTypeDeclarationInternalSubsetStartDelimiter token ID.
DocTypeDeclarationInternalSubsetText | Gets the DocTypeDeclarationInternalSubsetText token ID.
DocTypeDeclarationStartDelimiter | Gets the DocTypeDeclarationStartDelimiter token ID.
EndTagEndDelimiter | Gets the EndTagEndDelimiter token ID.
EndTagStartDelimiter | Gets the EndTagStartDelimiter token ID.
EndTagText | Gets the EndTagText token ID.
Entity | Gets the Entity token ID.
Identifier | Gets the Identifier token ID.
InvalidEndTagStartDelimiter | Gets the InvalidEndTagStartDelimiter token ID.
InvalidStartTagStartDelimiter | Gets the InvalidStartTagStartDelimiter token ID.
ProcessingInstructionEndDelimiter | Gets the ProcessingInstructionEndDelimiter token ID.
ProcessingInstructionStartDelimiter | Gets the ProcessingInstructionStartDelimiter token ID.
ProcessingInstructionText | Gets the ProcessingInstructionText token ID.
StartTagAttributeName | Gets the StartTagAttributeName token ID.
StartTagAttributeValueEndDelimiter | Gets the StartTagAttributeValueEndDelimiter token ID.
StartTagAttributeValueStartDelimiter | Gets the StartTagAttributeValueStartDelimiter token ID.
StartTagAttributeValueText | Gets the StartTagAttributeValueText token ID.
StartTagEndDelimiter | Gets the StartTagEndDelimiter token ID.
StartTagName | Gets the StartTagName token ID.
StartTagNextTagStartDelimiter | Gets the StartTagNextTagStartDelimiter token ID.
StartTagStartDelimiter | Gets the StartTagStartDelimiter token ID.
StartTagText | Gets the StartTagText token ID.
Whitespace | Gets the Whitespace token ID.
Top
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CDataSectionEndDelimiter Field

XmlTokenIdCDataSectionEndDelimiter Field
Gets the CDataSectionEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CDataSectionEndDelimiter = 12029
Public Const CDataSectionEndDelimiter As Integer = 12029

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CDataSectionStartDelimiter Field

XmlTokenIdCDataSectionStartDelimiter Field
Gets the CDataSectionStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CDataSectionStartDelimiter = 12028
Public Const CDataSectionStartDelimiter As Integer = 12028

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CDataSectionText Field

XmlTokenIdCDataSectionText Field
Gets the CDataSectionText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CDataSectionText = 12027
Public Const CDataSectionText As Integer = 12027

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CommentEndDelimiter Field

XmlTokenIdCommentEndDelimiter Field
Gets the CommentEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentEndDelimiter = 12020
Public Const CommentEndDelimiter As Integer = 12020

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CommentStartDelimiter Field

XmlTokenIdCommentStartDelimiter Field
Gets the CommentStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentStartDelimiter = 12019
Public Const CommentStartDelimiter As Integer = 12019

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.CommentText Field

XmlTokenIdCommentText Field
Gets the CommentText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int CommentText = 12018
Public Const CommentText As Integer = 12018

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DeclarationEndDelimiter Field

XmlTokenIdDeclarationEndDelimiter Field
Gets the DeclarationEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DeclarationEndDelimiter = 12026
Public Const DeclarationEndDelimiter As Integer = 12026

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DeclarationStartDelimiter Field

XmlTokenIdDeclarationStartDelimiter Field
Gets the DeclarationStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DeclarationStartDelimiter = 12025
Public Const DeclarationStartDelimiter As Integer = 12025

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DeclarationText Field

XmlTokenIdDeclarationText Field
Gets the DeclarationText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DeclarationText = 12024
Public Const DeclarationText As Integer = 12024

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Default Field

XmlTokenIdDefault Field
Gets the Default token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Default = 12000
Public Const Default As Integer = 12000

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationEndDelimiter Field

XmlTokenIdDocTypeDeclarationEndDelimiter Field
Gets the DocTypeDeclarationEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationEndDelimiter = 12031
Public Const DocTypeDeclarationEndDelimiter As Integer = 12031

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationInternalSubsetEndDelimiter Field

XmlTokenIdDocTypeDeclarationInternalSubsetEndDelimiter Field
Gets the DocTypeDeclarationInternalSubsetEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubsetEndDelimiter = 12034
Public Const DocTypeDeclarationInternalSubsetEndDelimiter As Integer = 12034

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationInternalSubsetStartDelimiter Field

XmlTokenIdDocTypeDeclarationInternalSubsetStartDelimiter Field
Gets the DocTypeDeclarationInternalSubsetStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubsetStartDelimiter = 12033
Public Const DocTypeDeclarationInternalSubsetStartDelimiter As Integer = 12033

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationInternalSubsetText Field

XmlTokenIdDocTypeDeclarationInternalSubsetText Field
Gets the DocTypeDeclarationInternalSubsetText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationInternalSubsetText = 12032
Public Const DocTypeDeclarationInternalSubsetText As Integer = 12032

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.DocTypeDeclarationStartDelimiter Field

XmlTokenIdDocTypeDeclarationStartDelimiter Field
Gets the DocTypeDeclarationStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocTypeDeclarationStartDelimiter = 12030
Public Const DocTypeDeclarationStartDelimiter As Integer = 12030

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.EndTagEndDelimiter Field

XmlTokenIdEndTagEndDelimiter Field
Gets the EndTagEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EndTagEndDelimiter = 12017
Public Const EndTagEndDelimiter As Integer = 12017

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.EndTagStartDelimiter Field

XmlTokenIdEndTagStartDelimiter Field
Gets the EndTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EndTagStartDelimiter = 12016
Public Const EndTagStartDelimiter As Integer = 12016

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.EndTagText Field

XmlTokenIdEndTagText Field
Gets the EndTagText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int EndTagText = 12015
Public Const EndTagText As Integer = 12015

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Entity Field

XmlTokenIdEntity Field
Gets the Entity token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Entity = 12001
Public Const Entity As Integer = 12001

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Identifier Field

XmlTokenIdIdentifier Field
Gets the Identifier token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Identifier = 12002
Public Const Identifier As Integer = 12002

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.InvalidEndTagStartDelimiter Field

XmlTokenIdInvalidEndTagStartDelimiter Field
Gets the InvalidEndTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InvalidEndTagStartDelimiter = 12004
Public Const InvalidEndTagStartDelimiter As Integer = 12004

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.InvalidStartTagStartDelimiter Field

XmlTokenIdInvalidStartTagStartDelimiter Field
Gets the InvalidStartTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int InvalidStartTagStartDelimiter = 12005
Public Const InvalidStartTagStartDelimiter As Integer = 12005

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ProcessingInstructionEndDelimiter Field

XmlTokenIdProcessingInstructionEndDelimiter Field
Gets the ProcessingInstructionEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ProcessingInstructionEndDelimiter = 12023
Public Const ProcessingInstructionEndDelimiter As Integer = 12023

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ProcessingInstructionStartDelimiter Field

XmlTokenIdProcessingInstructionStartDelimiter Field
Gets the ProcessingInstructionStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ProcessingInstructionStartDelimiter = 12022
Public Const ProcessingInstructionStartDelimiter As Integer = 12022

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.ProcessingInstructionText Field

XmlTokenIdProcessingInstructionText Field
Gets the ProcessingInstructionText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int ProcessingInstructionText = 12021
Public Const ProcessingInstructionText As Integer = 12021

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeName Field

XmlTokenIdStartTagAttributeName Field
Gets the StartTagAttributeName token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagAttributeName = 12010
Public Const StartTagAttributeName As Integer = 12010

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeValueEndDelimiter Field

XmlTokenIdStartTagAttributeValueEndDelimiter Field
Gets the StartTagAttributeValueEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagAttributeValueEndDelimiter = 12014
Public Const StartTagAttributeValueEndDelimiter As Integer = 12014

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeValueStartDelimiter Field

XmlTokenIdStartTagAttributeValueStartDelimiter Field
Gets the StartTagAttributeValueStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagAttributeValueStartDelimiter = 12013
Public Const StartTagAttributeValueStartDelimiter As Integer = 12013

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagAttributeValueText Field

XmlTokenIdStartTagAttributeValueText Field
Gets the StartTagAttributeValueText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagAttributeValueText = 12012
Public Const StartTagAttributeValueText As Integer = 12012

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagEndDelimiter Field

XmlTokenIdStartTagEndDelimiter Field
Gets the StartTagEndDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagEndDelimiter = 12008
Public Const StartTagEndDelimiter As Integer = 12008

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagName Field

XmlTokenIdStartTagName Field
Gets the StartTagName token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagName = 12009
Public Const StartTagName As Integer = 12009

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagNextTagStartDelimiter Field

XmlTokenIdStartTagNextTagStartDelimiter Field
Gets the StartTagNextTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagNextTagStartDelimiter = 12011
Public Const StartTagNextTagStartDelimiter As Integer = 12011

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagStartDelimiter Field

XmlTokenIdStartTagStartDelimiter Field
Gets the StartTagStartDelimiter token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagStartDelimiter = 12007
Public Const StartTagStartDelimiter As Integer = 12007

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.StartTagText Field

XmlTokenIdStartTagText Field
Gets the StartTagText token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int StartTagText = 12006
Public Const StartTagText As Integer = 12006

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenId.Whitespace Field

XmlTokenIdWhitespace Field
Gets the Whitespace token ID.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Whitespace = 12003
Public Const Whitespace As Integer = 12003

Field Value

Type: Int32
See Also

Reference

XmlTokenId Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Class

XmlTokenReader Class
Represents an object that can provide tokens to a ILLParser in a forward-only direction for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenReader

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTokenReader : MergableTokenReader
Public Class XmlTokenReader
    Inherits MergableTokenReader

The XmlTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenReader | Initializes a new instance of the XmlTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Constructor

XmlTokenReader Constructor
Initializes a new instance of the XmlTokenReader class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Properties

XmlTokenReader Properties

The XmlTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader Methods

XmlTokenReader Methods

The XmlTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides MergableTokenReaderGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Inherited from MergableTokenReader.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Inherited from MergableTokenReader.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenReader.GetNextToken Method

XmlTokenReaderGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

XmlTokenReader Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Class

XmlTokenTagger Class
Represents a token tagger for the XML language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTagger

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTokenTagger : TokenTagger
Public Class XmlTokenTagger
    Inherits TokenTagger

The XmlTokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenTagger | Initializes a new instance of the XmlTokenTagger class.
Top
Properties
 | Name | Description
Public property | ClassificationTypeProvider | Gets the IXmlClassificationTypeProvider that provides classification types used by this token tagger.
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Inherited from TokenTagger.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Constructor

XmlTokenTagger Constructor
Initializes a new instance of the XmlTokenTagger class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTokenTagger(
    ICodeDocument document,
    IXmlClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    document As ICodeDocument,
    classificationTypeProvider As IXmlClassificationTypeProvider
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The specific ICodeDocument for which this token tagger will be used.
classificationTypeProvider
Type: ActiproSoftware.Text.Languages.XmlIXmlClassificationTypeProvider
A IXmlClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Properties

XmlTokenTagger Properties

The XmlTokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationTypeProvider | Gets the IXmlClassificationTypeProvider that provides classification types used by this token tagger.
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger.ClassificationTypeProvider Property

XmlTokenTaggerClassificationTypeProvider Property
Gets the IXmlClassificationTypeProvider that provides classification types used by this token tagger.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IXmlClassificationTypeProvider ClassificationTypeProvider { get; }
Public ReadOnly Property ClassificationTypeProvider As IXmlClassificationTypeProvider
    Get

Property Value

Type: IXmlClassificationTypeProvider
The IXmlClassificationTypeProvider that provides classification types used by this token tagger.
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Methods

XmlTokenTagger Methods

The XmlTokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate. (Inherited from TokenTagger.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from TokenTagger.)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange. (Inherited from TokenTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TokenTagger.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from TokenTagger.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTagger Events

XmlTokenTagger Events

The XmlTokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

XmlTokenTagger Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Class

XmlTokenTaggerProvider Class
Represents a provider of XmlTokenTagger objects for documents that use the XmlTokenTagger language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase XmlTokenTagger
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTaggerProvider

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTokenTaggerProvider : TaggerProviderBase<XmlTokenTagger>,
    ICodeDocumentTaggerProvider
Public Class XmlTokenTaggerProvider
    Inherits TaggerProviderBase(Of XmlTokenTagger)
    Implements ICodeDocumentTaggerProvider

The XmlTokenTaggerProvider type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTokenTaggerProvider | Initializes a new instance of the XmlTokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Remarks
This type was generated by the Actipro Language Designer tool v11.1.542.0 (http://www.actiprosoftware.com). Generated code is based on input created by Actipro Software LLC. Copyright (c) 2001-2017 Actipro Software LLC. All rights reserved.
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Constructor

XmlTokenTaggerProvider Constructor
Initializes a new instance of the XmlTokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTokenTaggerProvider(
    IXmlClassificationTypeProvider classificationTypeProvider
)
Public Sub New (
    classificationTypeProvider As IXmlClassificationTypeProvider
)

Parameters

classificationTypeProvider
Type: ActiproSoftware.Text.Languages.XmlIXmlClassificationTypeProvider
A IXmlClassificationTypeProvider that provides classification types.
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Properties

XmlTokenTaggerProvider Properties

The XmlTokenTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider Methods

XmlTokenTaggerProvider Methods

The XmlTokenTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns a tagger for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider.GetTagger(T) Method

XmlTokenTaggerProviderGetTaggerT Method
Returns a tagger for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires a tagger.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
A tagger for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

XmlTokenTaggerProvider Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider.TaggerFactory Class

XmlTokenTaggerProviderTaggerFactory Class
Implements a factory that can creates XmlTokenTagger objects for a document.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTaggerProviderTaggerFactory

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TaggerFactory
Public Class TaggerFactory

The XmlTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an XmlTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Languages.Xml.Implementation Namespace


TaggerFactory Methods

TaggerFactory Methods

The XmlTokenTaggerProviderTaggerFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagger | Creates an XmlTokenTagger for the ICodeDocument.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


XmlTokenTaggerProvider.TaggerFactory.CreateTagger Method

XmlTokenTaggerProviderTaggerFactoryCreateTagger Method
Creates an XmlTokenTagger for the ICodeDocument.

Namespace: ActiproSoftware.Text.Languages.Xml.Implementation
Assembly: AS.Text.Addons.Xml.Universal (in AS.Text.Addons.Xml.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTokenTagger CreateTagger()
Public Function CreateTagger As XmlTokenTagger

Return Value

Type: XmlTokenTagger
An XmlTokenTagger for the ICodeDocument.
See Also

Reference

XmlTokenTaggerProviderTaggerFactory Class
ActiproSoftware.Text.Languages.Xml.Implementation Namespace


ActiproSoftware.Text.Lexing Namespace

ActiproSoftware.Text.Lexing Namespace
Contains types related to lexing.
Classes
 | Class | Description
Public class | MergableLexerFlags | Specifies flags for an IMergableToken.
Public class | MergableLexerResult | Provides a lexer result for a token.
Interfaces
 | Interface | Description
Public interface | ILexer | Provides the base requirements of a lexer (lexical analyzer) for a language.
Public interface | ILexerContext | Provides the base requirements for a class that stores lexer context data, allowing a lexer to resume at the point represented by the context.
Public interface | ILexerTarget | Provides the base requirements for an object that should receive parse output from a lexer.
Public interface | ILexicalScope | Provides the base requirements for a lexical scope.
Public interface | ILexicalScopeCollection | Provides the base requirements for a collection of ILexicalScope objects.
Public interface | ILexicalScopeStateNode | Provides the base requirements for a node that stores lexical scope and state information.
Public interface | ILexicalState | Provides the base requirements for a lexical state.
Public interface | ILexicalStateCollection | Provides the base requirements for a collection of ILexicalState objects.
Public interface | ILexicalStateIdProvider | Provides the base requirements for a class that provides lexical state ID's.
Public interface | ILexicalStateTransition | Provides the base requirements for a transition from one lexical state to another.
Public interface | IMergableLexer | Provides the base requirements for a lexer (lexical analyzer) for a language that supports merging with other languages.
Public interface | IMergableToken | Represents the base requirements for a mergable token that has been assigned to a span of text by a mergable lexer.
Public interface | IMergableTokenLexerData | Provides the base requirements for an object that provides lexer data for a IMergableToken.
Public interface | IToken | Represents the base requirements for a token that has been assigned to a span of text by a lexer.
Public interface | ITokenIdProvider | Provides the base requirements for a class that provides token ID's.
Public interface | ITokenSet | Provides the base requirements for a class that stores token data for a range of text.


ILexer Interface

ILexer Interface
Provides the base requirements of a lexer (lexical analyzer) for a language.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexer : IKeyedObject
Public Interface ILexer
    Inherits IKeyedObject

The ILexer type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
Methods
 | Name | Description
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexer Properties

ILexer Properties

The ILexer type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexer.TokenIdProvider Property

ILexerTokenIdProvider Property
Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITokenIdProvider TokenIdProvider { get; }
ReadOnly Property TokenIdProvider As ITokenIdProvider
    Get

Property Value

Type: ITokenIdProvider
The ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexer Methods

ILexer Methods

The ILexer type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Top
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexer.Parse Method

ILexerParse Method
Lexically parses the specified TextRange of the ITextSnapshot.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange Parse(
    TextSnapshotRange snapshotRange,
    ILexerTarget parseTarget
)
Function Parse (
    snapshotRange As TextSnapshotRange,
    parseTarget As ILexerTarget
) As TextRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range to parse.
parseTarget
Type: ActiproSoftware.Text.LexingILexerTarget
The ILexerTarget that receives the parsing output.

Return Value

Type: TextRange
A TextRange containing the offset range that was modified.
See Also

Reference

ILexer Interface
ActiproSoftware.Text.Lexing Namespace


ILexerContext Interface

ILexerContext Interface
Provides the base requirements for a class that stores lexer context data, allowing a lexer to resume at the point represented by the context.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexerContext
Public Interface ILexerContext

The ILexerContext type exposes the following members.

Properties
 | Name | Description
Public property | ScopeState | Gets the ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexerContext Properties

ILexerContext Properties

The ILexerContext type exposes the following members.

Properties
 | Name | Description
Public property | ScopeState | Gets the ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.
Top
See Also

Reference

ILexerContext Interface
ActiproSoftware.Text.Lexing Namespace


ILexerContext.ScopeState Property

ILexerContextScopeState Property
Gets the ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScopeStateNode ScopeState { get; }
ReadOnly Property ScopeState As ILexicalScopeStateNode
    Get

Property Value

Type: ILexicalScopeStateNode
The ILexicalScopeStateNode that represents the stack of lexical scopes and states in place at where the context is resuming.
See Also

Reference

ILexerContext Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget Interface

ILexerTarget Interface
Provides the base requirements for an object that should receive parse output from a lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexerTarget
Public Interface ILexerTarget

The ILexerTarget type exposes the following members.

Properties
 | Name | Description
Public property | HasInitialContext | Gets whether an initial context is available, from which incremental parsing can resume.
Top
Methods
 | Name | Description
Public method | OnPostParse | Occurs after lexing ends.
Public method | OnPreParse | Occurs before lexing starts.
Public method | OnTokenParsed | Occurs when an IToken is parsed by the lexer.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexerTarget Properties

ILexerTarget Properties

The ILexerTarget type exposes the following members.

Properties
 | Name | Description
Public property | HasInitialContext | Gets whether an initial context is available, from which incremental parsing can resume.
Top
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.HasInitialContext Property

ILexerTargetHasInitialContext Property
Gets whether an initial context is available, from which incremental parsing can resume.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasInitialContext { get; }
ReadOnly Property HasInitialContext As Boolean
    Get

Property Value

Type: Boolean
true if an initial context is available; otherwise, false.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget Methods

ILexerTarget Methods

The ILexerTarget type exposes the following members.

Methods
 | Name | Description
Public method | OnPostParse | Occurs after lexing ends.
Public method | OnPreParse | Occurs before lexing starts.
Public method | OnTokenParsed | Occurs when an IToken is parsed by the lexer.
Top
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.OnPostParse Method

ILexerTargetOnPostParse Method
Occurs after lexing ends.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void OnPostParse(
    int endOffset
)
Sub OnPostParse (
    endOffset As Integer
)

Parameters

endOffset
Type: SystemInt32
The offset at which parsing has stopped.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.OnPreParse Method

ILexerTargetOnPreParse Method
Occurs before lexing starts.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexerContext OnPreParse(
    ref int startOffset
)
Function OnPreParse (
    ByRef startOffset As Integer
) As ILexerContext

Parameters

startOffset
Type: SystemInt32
The offset at which parsing will commence.

Return Value

Type: ILexerContext
A ILexerContext that contains information about the starting context.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexerTarget.OnTokenParsed Method

ILexerTargetOnTokenParsed Method
Occurs when an IToken is parsed by the lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool OnTokenParsed(
    IToken newToken,
    ILexicalScopeStateNode scopeStateNode
)
Function OnTokenParsed (
    newToken As IToken,
    scopeStateNode As ILexicalScopeStateNode
) As Boolean

Parameters

newToken
Type: ActiproSoftware.Text.LexingIToken
The IToken that was parsed.
scopeStateNode
Type: ActiproSoftware.Text.LexingILexicalScopeStateNode
The ILexicalScopeStateNode at the start of the token.

Return Value

Type: Boolean
true if the lexing should continue; otherwise, false.
See Also

Reference

ILexerTarget Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope Interface

ILexicalScope Interface
Provides the base requirements for a lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalScope
Public Interface ILexicalScope

The ILexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets whether ancestor end scope checking is enabled while parsing inside the scope.
Public property | LexicalState | Gets the ILexicalState that defines the lexical scope.
Public property | ParentTransition | Gets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets the ILexicalStateTransition that this scope performs after ending.
Top
Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalScope Properties

ILexicalScope Properties

The ILexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets whether ancestor end scope checking is enabled while parsing inside the scope.
Public property | LexicalState | Gets the ILexicalState that defines the lexical scope.
Public property | ParentTransition | Gets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets the ILexicalStateTransition that this scope performs after ending.
Top
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.IsAncestorEndScopeCheckEnabled Property

ILexicalScopeIsAncestorEndScopeCheckEnabled Property
Gets whether ancestor end scope checking is enabled while parsing inside the scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAncestorEndScopeCheckEnabled { get; }
ReadOnly Property IsAncestorEndScopeCheckEnabled As Boolean
    Get

Property Value

Type: Boolean
true if ancestor end scope checking is enabled; otherwise, false.
Remarks
When enabled, this allows ancestor scopes to be examined to see a pattern matches their end scope. In the event a match is found, this scope exits as well as the ancestor's scope.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.LexicalState Property

ILexicalScopeLexicalState Property
Gets the ILexicalState that defines the lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; }
ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that defines the lexical scope.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.ParentTransition Property

ILexicalScopeParentTransition Property
Gets the ILexicalStateTransition that is the parent of this scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalStateTransition ParentTransition { get; }
ReadOnly Property ParentTransition As ILexicalStateTransition
    Get

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is the parent of this scope.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.Tag Property

ILexicalScopeTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.Transition Property

ILexicalScopeTransition Property
Gets the ILexicalStateTransition that this scope performs after ending.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalStateTransition Transition { get; }
ReadOnly Property Transition As ILexicalStateTransition
    Get

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that this scope performs after ending. If the value is , then no state transition is performed when the scope ends.
Remarks
The state transition may be made to a child language.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope Methods

ILexicalScope Methods

The ILexicalScope type exposes the following members.

Methods
 | Name | Description
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Top
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.IsScopeEnd Method

ILexicalScopeIsScopeEnd Method
Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScope.IsScopeStart Method

ILexicalScopeIsScopeStart Method
Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

ILexicalScope Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeCollection Interface

ILexicalScopeCollection Interface
Provides the base requirements for a collection of ILexicalScope objects.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalScopeCollection : IList<ILexicalScope>,
    ICollection<ILexicalScope>, IEnumerable<ILexicalScope>, IEnumerable
Public Interface ILexicalScopeCollection
    Inherits IList(Of ILexicalScope), ICollection(Of ILexicalScope),
    IEnumerable(Of ILexicalScope), IEnumerable

The ILexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ILexicalScope .)
Public property | IsReadOnly | (Inherited from ICollection ILexicalScope .)
Public property | Item | (Inherited from IList ILexicalScope .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ILexicalScope .)
Public method | Clear | (Inherited from ICollection ILexicalScope .)
Public method | Contains | (Inherited from ICollection ILexicalScope .)
Public method | CopyTo | (Inherited from ICollection ILexicalScope .)
Public method | GetEnumerator | (Inherited from IEnumerable ILexicalScope .)
Public method | IndexOf | (Inherited from IList ILexicalScope .)
Public method | Insert | (Inherited from IList ILexicalScope .)
Public method | Remove | (Inherited from ICollection ILexicalScope .)
Public method | RemoveAt | (Inherited from IList ILexicalScope .)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeCollection


ILexicalScopeCollection Properties

ILexicalScopeCollection Properties

The ILexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ILexicalScope .)
Public property | IsReadOnly | (Inherited from ICollection ILexicalScope .)
Public property | Item | (Inherited from IList ILexicalScope .)
Top
See Also

Reference

ILexicalScopeCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeCollection Methods

ILexicalScopeCollection Methods

The ILexicalScopeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ILexicalScope .)
Public method | Clear | (Inherited from ICollection ILexicalScope .)
Public method | Contains | (Inherited from ICollection ILexicalScope .)
Public method | CopyTo | (Inherited from ICollection ILexicalScope .)
Public method | GetEnumerator | (Inherited from IEnumerable ILexicalScope .)
Public method | IndexOf | (Inherited from IList ILexicalScope .)
Public method | Insert | (Inherited from IList ILexicalScope .)
Public method | Remove | (Inherited from ICollection ILexicalScope .)
Public method | RemoveAt | (Inherited from IList ILexicalScope .)
Top
See Also

Reference

ILexicalScopeCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode Interface

ILexicalScopeStateNode Interface
Provides the base requirements for a node that stores lexical scope and state information.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalScopeStateNode
Public Interface ILexicalScopeStateNode

The ILexicalScopeStateNode type exposes the following members.

Properties
 | Name | Description
Public property | LexicalScope | Gets or sets the ILexicalScope represented by this node.
Public property | LexicalState | Gets or sets the ILexicalState represented by this node.
Public property | Parent | Gets or sets the parent ILexicalScopeStateNode.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode Properties

ILexicalScopeStateNode Properties

The ILexicalScopeStateNode type exposes the following members.

Properties
 | Name | Description
Public property | LexicalScope | Gets or sets the ILexicalScope represented by this node.
Public property | LexicalState | Gets or sets the ILexicalState represented by this node.
Public property | Parent | Gets or sets the parent ILexicalScopeStateNode.
Top
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode.LexicalScope Property

ILexicalScopeStateNodeLexicalScope Property
Gets or sets the ILexicalScope represented by this node.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScope LexicalScope { get; set; }
Property LexicalScope As ILexicalScope
    Get
    Set

Property Value

Type: ILexicalScope
The ILexicalScope represented by this node.
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode.LexicalState Property

ILexicalScopeStateNodeLexicalState Property
Gets or sets the ILexicalState represented by this node.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; set; }
Property LexicalState As ILexicalState
    Get
    Set

Property Value

Type: ILexicalState
The ILexicalState represented by this node.
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalScopeStateNode.Parent Property

ILexicalScopeStateNodeParent Property
Gets or sets the parent ILexicalScopeStateNode.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScopeStateNode Parent { get; set; }
Property Parent As ILexicalScopeStateNode
    Get
    Set

Property Value

Type: ILexicalScopeStateNode
The parent ILexicalScopeStateNode.
See Also

Reference

ILexicalScopeStateNode Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState Interface

ILexicalState Interface
Provides the base requirements for a lexical state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalState : IKeyedObject
Public Interface ILexicalState
    Inherits IKeyedObject

The ILexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | Id | Gets the ID value that identifies the lexical state.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Lexer | Gets the ILexer that contains the state.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalState Properties

ILexicalState Properties

The ILexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | Id | Gets the ID value that identifies the lexical state.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Lexer | Gets the ILexer that contains the state.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.ChildLexicalStates Property

ILexicalStateChildLexicalStates Property
Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalStateCollection ChildLexicalStates { get; }
ReadOnly Property ChildLexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
A ILexicalStateCollection containing the child lexical states.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.DefaultTokenId Property

ILexicalStateDefaultTokenId Property
Gets or sets the ID of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DefaultTokenId { get; set; }
Property DefaultTokenId As Integer
    Get
    Set

Property Value

Type: Int32
The ID of the default token that this state assigns.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Id Property

ILexicalStateId Property
Gets the ID value that identifies the lexical state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Id { get; }
ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID value that identifies the lexical state.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Lexer Property

ILexicalStateLexer Property
Gets the ILexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexer Lexer { get; }
ReadOnly Property Lexer As ILexer
    Get

Property Value

Type: ILexer
The ILexer that contains the state.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.LexicalScopes Property

ILexicalStateLexicalScopes Property
Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScopeCollection LexicalScopes { get; }
ReadOnly Property LexicalScopes As ILexicalScopeCollection
    Get

Property Value

Type: ILexicalScopeCollection
A ILexicalScopeCollection containing the lexical scopes.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Tag Property

ILexicalStateTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalState.Transition Property

ILexicalStateTransition Property
Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalStateTransition Transition { get; set; }
Property Transition As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is performed immediately after a start scope match.
Remarks
This provides a mechanism to automatically transition to another language when this state's start scope is matched. This state's end scope may be used to exit the child language.

ASP-style tags are an example of when to use this transition.

See Also

Reference

ILexicalState Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateCollection Interface

ILexicalStateCollection Interface
Provides the base requirements for a collection of ILexicalState objects.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalStateCollection : IList<ILexicalState>,
    ICollection<ILexicalState>, IEnumerable<ILexicalState>, IEnumerable
Public Interface ILexicalStateCollection
    Inherits IList(Of ILexicalState), ICollection(Of ILexicalState),
    IEnumerable(Of ILexicalState), IEnumerable

The ILexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ILexicalState .)
Public property | IsReadOnly | (Inherited from ICollection ILexicalState .)
Public property | Item | (Inherited from IList ILexicalState .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ILexicalState .)
Public method | Clear | (Inherited from ICollection ILexicalState .)
Public method | Contains | (Inherited from ICollection ILexicalState .)
Public method | CopyTo | (Inherited from ICollection ILexicalState .)
Public method | GetEnumerator | (Inherited from IEnumerable ILexicalState .)
Public method | IndexOf | (Inherited from IList ILexicalState .)
Public method | Insert | (Inherited from IList ILexicalState .)
Public method | Remove | (Inherited from ICollection ILexicalState .)
Public method | RemoveAt | (Inherited from IList ILexicalState .)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalStateCollection


ILexicalStateCollection Properties

ILexicalStateCollection Properties

The ILexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ILexicalState .)
Public property | IsReadOnly | (Inherited from ICollection ILexicalState .)
Public property | Item | (Inherited from IList ILexicalState .)
Top
See Also

Reference

ILexicalStateCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateCollection Methods

ILexicalStateCollection Methods

The ILexicalStateCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ILexicalState .)
Public method | Clear | (Inherited from ICollection ILexicalState .)
Public method | Contains | (Inherited from ICollection ILexicalState .)
Public method | CopyTo | (Inherited from ICollection ILexicalState .)
Public method | GetEnumerator | (Inherited from IEnumerable ILexicalState .)
Public method | IndexOf | (Inherited from IList ILexicalState .)
Public method | Insert | (Inherited from IList ILexicalState .)
Public method | Remove | (Inherited from ICollection ILexicalState .)
Public method | RemoveAt | (Inherited from IList ILexicalState .)
Top
See Also

Reference

ILexicalStateCollection Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateIdProvider Interface

ILexicalStateIdProvider Interface
Provides the base requirements for a class that provides lexical state ID's.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalStateIdProvider : IIdProvider
Public Interface ILexicalStateIdProvider
    Inherits IIdProvider

The ILexicalStateIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ILexicalStateIdProvider Properties

ILexicalStateIdProvider Properties

The ILexicalStateIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
See Also

Reference

ILexicalStateIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateIdProvider Methods

ILexicalStateIdProvider Methods

The ILexicalStateIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ILexicalStateIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition Interface

ILexicalStateTransition Interface
Provides the base requirements for a transition from one lexical state to another.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILexicalStateTransition
Public Interface ILexicalStateTransition

The ILexicalStateTransition type exposes the following members.

Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTransition


ILexicalStateTransition Properties

ILexicalStateTransition Properties

The ILexicalStateTransition type exposes the following members.

Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ChildLanguage Property

ILexicalStateTransitionChildLanguage Property
Gets the ISyntaxLanguage that contains the ChildLexicalState.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISyntaxLanguage ChildLanguage { get; }
ReadOnly Property ChildLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that contains the ChildLexicalState.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ChildLexicalScope Property

ILexicalStateTransitionChildLexicalScope Property
Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScope ChildLexicalScope { get; }
ReadOnly Property ChildLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ChildLexicalState Property

ILexicalStateTransitionChildLexicalState Property
Gets the ILexicalState into which a transition is made.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState ChildLexicalState { get; }
ReadOnly Property ChildLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState into which a transition is made.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


ILexicalStateTransition.ParentLexicalScope Property

ILexicalStateTransitionParentLexicalScope Property
Gets the ILexicalScope that owns this state transition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScope ParentLexicalScope { get; }
ReadOnly Property ParentLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that owns this state transition.
See Also

Reference

ILexicalStateTransition Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer Interface

IMergableLexer Interface
Provides the base requirements for a lexer (lexical analyzer) for a language that supports merging with other languages.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IMergableLexer : ILexer,
    IKeyedObject
Public Interface IMergableLexer
    Inherits ILexer, IKeyedObject

The IMergableLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


IMergableLexer Properties

IMergableLexer Properties

The IMergableLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.DefaultLexicalState Property

IMergableLexerDefaultLexicalState Property
Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState DefaultLexicalState { get; }
ReadOnly Property DefaultLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The root ILexicalState for when the language is entered.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.LexicalStateIdProvider Property

IMergableLexerLexicalStateIdProvider Property
Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalStateIdProvider LexicalStateIdProvider { get; }
ReadOnly Property LexicalStateIdProvider As ILexicalStateIdProvider
    Get

Property Value

Type: ILexicalStateIdProvider
The ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer Methods

IMergableLexer Methods

The IMergableLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.CreateChangeBatch Method

IMergableLexerCreateChangeBatch Method
Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDisposable CreateChangeBatch()
Function CreateChangeBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.CreateDocumentEndToken Method

IMergableLexerCreateDocumentEndToken Method
Creates an IMergableToken that represents the end of a document.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IMergableToken CreateDocumentEndToken(
    int startOffset,
    TextPosition startPosition,
    ILexicalState lexicalState
)
Function CreateDocumentEndToken (
    startOffset As Integer,
    startPosition As TextPosition,
    lexicalState As ILexicalState
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the IToken.
startPosition
Type: ActiproSoftware.TextTextPosition
The start TextPosition of the IToken.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the end of a document.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.CreateToken Method

IMergableLexerCreateToken Method
Creates an IMergableToken that represents the range of text with the specified lexer data.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IMergableToken CreateToken(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition,
    MergableLexerFlags lexerFlags,
    ILexicalState lexicalState,
    IMergableTokenLexerData lexerData
)
Function CreateToken (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition,
    lexerFlags As MergableLexerFlags,
    lexicalState As ILexicalState,
    lexerData As IMergableTokenLexerData
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
lexerFlags
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags for the token.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData that contains lexer information about the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the range of text with the specified lexer data.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.GetAllLexicalStateTransitions Method

IMergableLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.GetDefaultToken Method

IMergableLexerGetDefaultToken Method
Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MergableLexerResult GetDefaultToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Function GetDefaultToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.GetNextToken Method

IMergableLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer Events

IMergableLexer Events

The IMergableLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableLexer.Changed Event

IMergableLexerChanged Event
Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Changed
Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IMergableLexer Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken Interface

IMergableToken Interface
Represents the base requirements for a mergable token that has been assigned to a span of text by a mergable lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IMergableToken : IToken
Public Interface IMergableToken
    Inherits IToken

The IMergableToken type exposes the following members.

Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from IToken.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from IToken.)
Public property | Id | Gets the ID assigned to the token. (Inherited from IToken.)
Public property | Key | Gets the key assigned to the token. (Inherited from IToken.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from IToken.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token. (Inherited from IToken.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from IToken.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from IToken.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from IToken.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from IToken.)
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from IToken.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from IToken.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationMergableToken


IMergableToken Properties

IMergableToken Properties

The IMergableToken type exposes the following members.

Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from IToken.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from IToken.)
Public property | Id | Gets the ID assigned to the token. (Inherited from IToken.)
Public property | Key | Gets the key assigned to the token. (Inherited from IToken.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from IToken.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token. (Inherited from IToken.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from IToken.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from IToken.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from IToken.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from IToken.)
Top
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.AutoCaseCorrectText Property

IMergableTokenAutoCaseCorrectText Property
Gets the text that should be used for this IToken when performing an auto case correction operation on it.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string AutoCaseCorrectText { get; }
ReadOnly Property AutoCaseCorrectText As String
    Get

Property Value

Type: String
The text that should be used for this IToken when performing an auto case correction operation on it.
Remarks
Return a value to indicate that there is no auto case correction text available.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.ClassificationType Property

IMergableTokenClassificationType Property
Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.DeclaringLexicalState Property

IMergableTokenDeclaringLexicalState Property
Gets the ILexicalState that declares the pattern that matched the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState DeclaringLexicalState { get; }
ReadOnly Property DeclaringLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that declares the pattern that matched the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.Lexer Property

IMergableTokenLexer Property
Gets the IMergableLexer that created the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IMergableLexer Lexer { get; }
ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that created the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.LexicalScope Property

IMergableTokenLexicalScope Property
Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScope LexicalScope { get; }
ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.LexicalState Property

IMergableTokenLexicalState Property
Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; }
ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken Methods

IMergableToken Methods

The IMergableToken type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from IToken.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from IToken.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Top
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.HasFlag Method

IMergableTokenHasFlag Method
Returns whether the parse data has the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasFlag(
    MergableLexerFlags flag
)
Function HasFlag (
    flag As MergableLexerFlags
) As Boolean

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to check for.

Return Value

Type: Boolean
true if the parse data has the specified MergableLexerFlags flag; otherwise, false.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableToken.SetFlag Method

IMergableTokenSetFlag Method
Sets or clears the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SetFlag(
    MergableLexerFlags flag,
    bool setBit
)
Sub SetFlag (
    flag As MergableLexerFlags,
    setBit As Boolean
)

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to set or clear.
setBit
Type: SystemBoolean
Whether to set the flag; otherwise, the flag is cleared.
Remarks
This method should only be called by lexers.
See Also

Reference

IMergableToken Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData Interface

IMergableTokenLexerData Interface
Provides the base requirements for an object that provides lexer data for a IMergableToken.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IMergableTokenLexerData
Public Interface IMergableTokenLexerData

The IMergableTokenLexerData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTokenData
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeTokenData


IMergableTokenLexerData Properties

IMergableTokenLexerData Properties

The IMergableTokenLexerData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that created the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.ClassificationType Property

IMergableTokenLexerDataClassificationType Property
Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The key of the IClassificationType assigned to the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.Lexer Property

IMergableTokenLexerDataLexer Property
Gets the IMergableLexer that created the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IMergableLexer Lexer { get; }
ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that created the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.LexicalScope Property

IMergableTokenLexerDataLexicalScope Property
Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalScope LexicalScope { get; }
ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.LexicalState Property

IMergableTokenLexerDataLexicalState Property
Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILexicalState LexicalState { get; }
ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.TokenId Property

IMergableTokenLexerDataTokenId Property
Gets the token ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int TokenId { get; }
ReadOnly Property TokenId As Integer
    Get

Property Value

Type: Int32
The token ID assigned to the token.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IMergableTokenLexerData.TokenKey Property

IMergableTokenLexerDataTokenKey Property
Gets the token key assigned to the token, if it is known.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string TokenKey { get; }
ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The token key assigned to the token, if it is known.
See Also

Reference

IMergableTokenLexerData Interface
ActiproSoftware.Text.Lexing Namespace


IToken Interface

IToken Interface
Represents the base requirements for a token that has been assigned to a span of text by a lexer.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IToken
Public Interface IToken

The IToken type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


IToken Properties

IToken Properties

The IToken type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.EndOffset Property

ITokenEndOffset Property
Gets the offset after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset after the last character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.EndPosition Property

ITokenEndPosition Property
Gets the TextPosition after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition EndPosition { get; }
ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition after the last character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Id Property

ITokenId Property
Gets the ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Id { get; }
ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID assigned to the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Key Property

ITokenKey Property
Gets the key assigned to the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The key assigned to the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Length Property

ITokenLength Property
Gets or sets the absolute length of the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; set; }
Property Length As Integer
    Get
    Set

Property Value

Type: Int32
The absolute length of the token.
Remarks
The setter for this property is for internal use only. Altering its value will corrupt the ITextDocument IToken collection.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.LexicalStateId Property

ITokenLexicalStateId Property
Gets the ID assigned to the lexical state that contains the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LexicalStateId { get; }
ReadOnly Property LexicalStateId As Integer
    Get

Property Value

Type: Int32
The ID assigned to the lexical state that contains the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.PositionRange Property

ITokenPositionRange Property
Gets a TextPositionRange that specifies the text position range of the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; }
ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.StartOffset Property

ITokenStartOffset Property
Gets or sets the offset of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; set; }
Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The offset of the first character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.StartPosition Property

ITokenStartPosition Property
Gets the TextPosition of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition StartPosition { get; }
ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the first character in the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.TextRange Property

ITokenTextRange Property
Gets a TextRange that specifies the text range of the token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRange { get; }
ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
A TextRange that specifies the text range of the token.
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken Methods

IToken Methods
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Contains Method

ITokenContains Method
Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

IToken Interface
ActiproSoftware.Text.Lexing Namespace


IToken.Contains Method (Int32)

ITokenContains Method (Int32)
Returns whether the IToken contains the specified offset.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the IToken contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the IToken.
See Also

Reference

IToken Interface
Contains Overload
ActiproSoftware.Text.Lexing Namespace


IToken.Contains Method (TextPosition)

ITokenContains Method (TextPosition)
Returns whether the IToken contains the specified TextPosition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    TextPosition position
)
Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the IToken contains the specified TextPosition; otherwise, false.
Remarks
This method returns false if the position falls on the EndPosition position since this method indicates if the position is encompassed by the IToken.
See Also

Reference

IToken Interface
Contains Overload
ActiproSoftware.Text.Lexing Namespace


ITokenIdProvider Interface

ITokenIdProvider Interface
Provides the base requirements for a class that provides token ID's.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITokenIdProvider : IIdProvider
Public Interface ITokenIdProvider
    Inherits IIdProvider

The ITokenIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


ITokenIdProvider Properties

ITokenIdProvider Properties

The ITokenIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
See Also

Reference

ITokenIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ITokenIdProvider Methods

ITokenIdProvider Methods

The ITokenIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ITokenIdProvider Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet Interface

ITokenSet Interface
Provides the base requirements for a class that stores token data for a range of text.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITokenSet : IEnumerable<IToken>,
    IEnumerable, ITextRangeProvider
Public Interface ITokenSet
    Inherits IEnumerable(Of IToken), IEnumerable, ITextRangeProvider

The ITokenSet type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Tokens | Gets an IToken in the token set.
Top
Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable IToken .)
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace
ActiproSoftware.Text.Lexing.ImplementationTokenSet


ITokenSet Properties

ITokenSet Properties

The ITokenSet type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | Tokens | Gets an IToken in the token set.
Top
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.Count Property

ITokenSetCount Property
Gets the count of tokens that are stored in the token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of tokens that are stored in the token set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.FirstToken Property

ITokenSetFirstToken Property
Gets the first IToken in the set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken FirstToken { get; }
ReadOnly Property FirstToken As IToken
    Get

Property Value

Type: IToken
The first IToken in the set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.FirstTokenExtendsBack Property

ITokenSetFirstTokenExtendsBack Property
Gets whether the FirstToken extends back to another token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool FirstTokenExtendsBack { get; }
ReadOnly Property FirstTokenExtendsBack As Boolean
    Get

Property Value

Type: Boolean
true if the FirstToken extends back to another token set; otherwise, false.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.LastToken Property

ITokenSetLastToken Property
Gets the last IToken in the set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken LastToken { get; }
ReadOnly Property LastToken As IToken
    Get

Property Value

Type: IToken
The last IToken in the set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.LastTokenExtendsForward Property

ITokenSetLastTokenExtendsForward Property
Gets whether the LastToken extends forward to another token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool LastTokenExtendsForward { get; }
ReadOnly Property LastTokenExtendsForward As Boolean
    Get

Property Value

Type: Boolean
true if the LastToken extends forward to another token set; otherwise, false.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.ParseContext Property

ITokenSetParseContext Property
Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object ParseContext { get; }
ReadOnly Property ParseContext As Object
    Get

Property Value

Type: Object
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.Tokens Property

ITokenSetTokens Property
Gets an IToken in the token set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken this[
    int index
] { get; }
ReadOnly Property Tokens (
    index As Integer
) As IToken
    Get

Parameters

index
Type: SystemInt32
The index of the IToken to return.

Property Value

Type: IToken
An IToken in the token set.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet Methods

ITokenSet Methods

The ITokenSet type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable IToken .)
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Top
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


ITokenSet.IndexOf Method

ITokenSetIndexOf Method
Returns the index of the IToken in the set that contains the specified offset, if any.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndexOf(
    int offset,
    int hintIndex
)
Function IndexOf (
    offset As Integer,
    hintIndex As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset for which to search.
hintIndex
Type: SystemInt32
The hint index at which to begin searching; otherwise, -1.

Return Value

Type: Int32
The index of the IToken in the set that contains the specified offset; otherwise, -1.
See Also

Reference

ITokenSet Interface
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags Class

MergableLexerFlags Class
Specifies flags for an IMergableToken.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.LexingMergableLexerFlags

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MergableLexerFlags : Enum
<FlagsAttribute>
Public NotInheritable Class MergableLexerFlags
    Inherits Enum

The MergableLexerFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | DirectStateTransition | The token starts a scope which performs a direct lexical state transition.
 | LanguageEnd | The token marks the end of a child language.
 | LanguageStart | The token marks the start of a child language.
 | LooseMatch | A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.
 | None | There are no flags set.
 | ScopeEnd | The token ends a scope.
 | ScopeStart | The token starts a scope.
 | ScopeStateTransitionEnd | The token ends a scope for a scope lexical state transition.
 | ScopeStateTransitionStart | The token ends a scope but performs a scope lexical state transition.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags Methods

MergableLexerFlags Methods

The MergableLexerFlags type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags Fields

MergableLexerFlags Fields

The MergableLexerFlags type exposes the following members.

Fields
 | Name | Description
 | DirectStateTransition | The token starts a scope which performs a direct lexical state transition.
 | LanguageEnd | The token marks the end of a child language.
 | LanguageStart | The token marks the start of a child language.
 | LooseMatch | A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.
 | None | There are no flags set.
 | ScopeEnd | The token ends a scope.
 | ScopeStart | The token starts a scope.
 | ScopeStateTransitionEnd | The token ends a scope for a scope lexical state transition.
 | ScopeStateTransitionStart | The token ends a scope but performs a scope lexical state transition.
Public field | value__ |
Top
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.DirectStateTransition Field

MergableLexerFlagsDirectStateTransition Field
The token starts a scope which performs a direct lexical state transition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags DirectStateTransition = 8
Public Const DirectStateTransition As MergableLexerFlags = 8

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.LanguageEnd Field

MergableLexerFlagsLanguageEnd Field
The token marks the end of a child language.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags LanguageEnd = 128
Public Const LanguageEnd As MergableLexerFlags = 128

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.LanguageStart Field

MergableLexerFlagsLanguageStart Field
The token marks the start of a child language.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags LanguageStart = 64
Public Const LanguageStart As MergableLexerFlags = 64

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.LooseMatch Field

MergableLexerFlagsLooseMatch Field
A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags LooseMatch = 1
Public Const LooseMatch As MergableLexerFlags = 1

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.None Field

MergableLexerFlagsNone Field
There are no flags set.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags None = 0
Public Const None As MergableLexerFlags = 0

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.ScopeEnd Field

MergableLexerFlagsScopeEnd Field
The token ends a scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags ScopeEnd = 4
Public Const ScopeEnd As MergableLexerFlags = 4

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.ScopeStart Field

MergableLexerFlagsScopeStart Field
The token starts a scope.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags ScopeStart = 2
Public Const ScopeStart As MergableLexerFlags = 2

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.ScopeStateTransitionEnd Field

MergableLexerFlagsScopeStateTransitionEnd Field
The token ends a scope for a scope lexical state transition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags ScopeStateTransitionEnd = 32
Public Const ScopeStateTransitionEnd As MergableLexerFlags = 32

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.ScopeStateTransitionStart Field

MergableLexerFlagsScopeStateTransitionStart Field
The token ends a scope but performs a scope lexical state transition.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MergableLexerFlags ScopeStateTransitionStart = 16
Public Const ScopeStateTransitionStart As MergableLexerFlags = 16

Field Value

Type: MergableLexerFlags
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerFlags.value__ Field

MergableLexerFlagsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Lexing.MergableLexerFlags.value__"]

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MergableLexerFlags Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Class

MergableLexerResult Class
Provides a lexer result for a token.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.LexingMergableLexerResult

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MergableLexerResult
Public Class MergableLexerResult

The MergableLexerResult type exposes the following members.

Constructors
 | Name | Description
Public method | MergableLexerResult | Initializes a new instance of the MergableLexerResult class.
Top
Properties
 | Name | Description
Public property | LexerData | Gets the IMergableTokenLexerData to use for this token.
Public property | MatchType | Gets a MatchType indicating the type of match that was made.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
NoMatch | Gets a MergableLexerResult that can be used to indicate there was no match.
Top
See Also

Reference

ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Constructor

MergableLexerResult Constructor
Initializes a new instance of the MergableLexerResult class.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MergableLexerResult(
    MatchType matchType,
    IMergableTokenLexerData lexerData
)
Public Sub New (
    matchType As MatchType,
    lexerData As IMergableTokenLexerData
)

Parameters

matchType
Type: ActiproSoftware.Text.RegularExpressionsMatchType
A MatchType indicating the type of match that was made.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData to use for this token.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Properties

MergableLexerResult Properties

The MergableLexerResult type exposes the following members.

Properties
 | Name | Description
Public property | LexerData | Gets the IMergableTokenLexerData to use for this token.
Public property | MatchType | Gets a MatchType indicating the type of match that was made.
Top
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult.LexerData Property

MergableLexerResultLexerData Property
Gets the IMergableTokenLexerData to use for this token.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMergableTokenLexerData LexerData { get; }
Public ReadOnly Property LexerData As IMergableTokenLexerData
    Get

Property Value

Type: IMergableTokenLexerData
The IMergableTokenLexerData to use for this token.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult.MatchType Property

MergableLexerResultMatchType Property
Gets a MatchType indicating the type of match that was made.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MatchType MatchType { get; }
Public ReadOnly Property MatchType As MatchType
    Get

Property Value

Type: MatchType
A MatchType indicating the type of match that was made.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Methods

MergableLexerResult Methods

The MergableLexerResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult Fields

MergableLexerResult Fields

The MergableLexerResult type exposes the following members.

Fields
Name | Description
NoMatch | Gets a MergableLexerResult that can be used to indicate there was no match.
Top
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


MergableLexerResult.NoMatch Field

MergableLexerResultNoMatch Field
Gets a MergableLexerResult that can be used to indicate there was no match.

Namespace: ActiproSoftware.Text.Lexing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly MergableLexerResult NoMatch
Public Shared ReadOnly NoMatch As MergableLexerResult

Field Value

Type: MergableLexerResult
A MergableLexerResult that can be used to indicate there was no match.
See Also

Reference

MergableLexerResult Class
ActiproSoftware.Text.Lexing Namespace


ActiproSoftware.Text.Lexing.Implementation Namespace

ActiproSoftware.Text.Lexing.Implementation Namespace
Contains implementation types related to lexing.
Classes
 | Class | Description
Public class | DynamicLexer | Represents a dynamic lexer (lexical analyzer), one that is pattern-based.
Public class | DynamicLexicalMacro | Defines a macro, which is a named regular expression.
Public class | DynamicLexicalPattern | Represents a lexical pattern.
Public class | DynamicLexicalPatternGroup | Encapsulates a collection of DynamicLexicalPattern objects.
Public class | DynamicLexicalPatternType | Specifies the type of lexical pattern.
Public class | DynamicLexicalScope | Contains information about a lexical scope.
Public class | DynamicLexicalState | Contains information about a lexical state.
Public class | LexicalScopeBase | Provides the abstract base class for a lexical scope.
Public class | LexicalScopeCollection | Represents a collection of lexical scopes.
Public class | LexicalScopeTokenData | Provides IToken lexer data based on a token ID and an ILexicalScope.
Public class | LexicalStateBase | Provides the abstract base class for a lexical state.
Public class | LexicalStateCollection | Represents a collection of lexical states.
Public class | LexicalStateIdProviderBase | Represents an abstract base class for an object that provides static IDs for the lexical states of an ISyntaxLanguage.
Public class | LexicalStateTokenData | Provides IToken lexer data based on a token ID and on an ILexicalState.
Public class | LexicalStateTransition | Contains information about a transition from one lexical state to another.
Public class | MergableLexerBase | Represents the base implementation of a lexer (lexical analyzer) for a language that supports merging with other languages.
Public class | MergableLexerCoordinator | Coordinates lexer and state shifting for one or more mergable lexers.
Public class | MergableToken | Represents the default implementation of an IToken that can be used with an IMergableLexer.
Public class | ProgrammaticLexicalScope | Provides a lexical scope implementation that uses two delegates to perform the IsScopeStart(ITextBufferReader) and IsScopeEnd(ITextBufferReader) checks.
Public class | ProgrammaticLexicalScopeMatch | Represents the method that will handle token matching callbacks for ProgrammaticLexicalScope objects.
Public class | ProgrammaticLexicalState | Provides a default implementation for a lexical state.
Public class | TokenBase | Represents the base class for an IToken implementation.
Public class | TokenIdProviderBase | Represents an abstract base class for an object that provides static IDs for the tokens of an ISyntaxLanguage.
Public class | TokenSet | Stores token data for a range of text.
Interfaces
 | Interface | Description
Public interface | IDynamicLexer | Provides the base requirements for a dynamic lexer, one that is pattern based.
Public interface | IDynamicLexicalMacroCollection | Provides the base requirements for a collection of DynamicLexicalMacro objects.
Public interface | IDynamicLexicalPatternCollection | Provides the base requirements for a collection of DynamicLexicalPattern objects.
Public interface | IDynamicLexicalPatternGroupCollection | Provides the base requirements for a collection of DynamicLexicalPatternGroup objects.
Public interface | IDynamicLexicalScopeCollection | Provides the base requirements for a collection of DynamicLexicalScope objects.
Public interface | IDynamicLexicalStateCollection | Provides the base requirements for a collection of DynamicLexicalState objects.


DynamicLexer Class

DynamicLexer Class
Represents a dynamic lexer (lexical analyzer), one that is pattern-based.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexer

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DynamicLexer : MergableLexerBase,
    IDynamicLexer, IMergableLexer, ILexer, IKeyedObject
Public Class DynamicLexer
    Inherits MergableLexerBase
    Implements IDynamicLexer, IMergableLexer, ILexer, IKeyedObject

The DynamicLexer type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexer | Initializes a new instance of the DynamicLexer class.
Top
Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Overrides MergableLexerBaseGetDefaultToken(ITextBufferReader, ILexicalState).)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Overrides MergableLexerBaseOnChanged(EventArgs).)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILexer interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Constructor

DynamicLexer Constructor
Initializes a new instance of the DynamicLexer class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexer()
Public Sub New
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Properties

DynamicLexer Properties

The DynamicLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered. (Inherited from MergableLexerBase.)
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name. (Inherited from MergableLexerBase.)
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from MergableLexerBase.)
Top
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.DefaultLexicalState Property

DynamicLexerDefaultLexicalState Property
Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalState DefaultLexicalState { get; set; }
Public Property DefaultLexicalState As DynamicLexicalState
    Get
    Set

Property Value

Type: DynamicLexicalState
The root ILexicalState for when the language is entered.

Implements

IDynamicLexerDefaultLexicalState
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.Key Property

DynamicLexerKey Property
Gets or sets a string that identifies the lexer, generally the related language name.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
A string that identifies the lexer, generally the related language name.

Implements

IDynamicLexerKey
IKeyedObjectKey
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.LexicalMacros Property

DynamicLexerLexicalMacros Property
Gets the collection of lexical macros.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexicalMacroCollection LexicalMacros { get; }
Public ReadOnly Property LexicalMacros As IDynamicLexicalMacroCollection
    Get

Property Value

Type: IDynamicLexicalMacroCollection
A IDynamicLexicalMacroCollection containing the lexical macros.

Implements

IDynamicLexerLexicalMacros
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.LexicalStateIdProvider Property

DynamicLexerLexicalStateIdProvider Property
Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateIdProvider LexicalStateIdProvider { get; set; }
Public Property LexicalStateIdProvider As ILexicalStateIdProvider
    Get
    Set

Property Value

Type: ILexicalStateIdProvider
The ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Implements

IMergableLexerLexicalStateIdProvider
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.LexicalStates Property

DynamicLexerLexicalStates Property
Gets the collection of lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexicalStateCollection LexicalStates { get; }
Public ReadOnly Property LexicalStates As IDynamicLexicalStateCollection
    Get

Property Value

Type: IDynamicLexicalStateCollection
A IDynamicLexicalStateCollection containing the lexical states.

Implements

IDynamicLexerLexicalStates
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.TokenIdProvider Property

DynamicLexerTokenIdProvider Property
Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITokenIdProvider TokenIdProvider { get; set; }
Public Property TokenIdProvider As ITokenIdProvider
    Get
    Set

Property Value

Type: ITokenIdProvider
The ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Implements

ILexerTokenIdProvider
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Methods

DynamicLexer Methods

The DynamicLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from MergableLexerBase.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from MergableLexerBase.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from MergableLexerBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Overrides MergableLexerBaseGetAllLexicalStateTransitions.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Overrides MergableLexerBaseGetDefaultToken(ITextBufferReader, ILexicalState).)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested. (Inherited from MergableLexerBase.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Overrides MergableLexerBaseGetNextToken(ITextBufferReader, ILexicalState).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event. (Overrides MergableLexerBaseOnChanged(EventArgs).)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from MergableLexerBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.GetAllLexicalStateTransitions Method

DynamicLexerGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Overrides Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.GetDefaultToken Method

DynamicLexerGetDefaultToken Method
Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetDefaultToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetDefaultToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetDefaultToken(ITextBufferReader, ILexicalState)
IMergableLexerGetDefaultToken(ITextBufferReader, ILexicalState)
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.GetNextToken Method

DynamicLexerGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overrides Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer.OnChanged Method

DynamicLexerOnChanged Method
Raises the Changed event.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnChanged(
    EventArgs e
)
Protected Overrides Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs that contains the event data.
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexer Events

DynamicLexer Events

The DynamicLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from MergableLexerBase.)
Top
See Also

Reference

DynamicLexer Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Class

DynamicLexicalMacro Class
Defines a macro, which is a named regular expression.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalMacro

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DynamicLexicalMacro : IKeyedObject
Public Class DynamicLexicalMacro
    Implements IKeyedObject

The DynamicLexicalMacro type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalMacro | Initializes a new instance of the LexicalMacro class.
Top
Properties
 | Name | Description
Public property | Key | Gets a string-based key that identifies the object.
Public property | Pattern | Gets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Constructor

DynamicLexicalMacro Constructor
Initializes a new instance of the LexicalMacro class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalMacro(
    string key,
    string pattern
)
Public Sub New (
    key As String,
    pattern As String
)

Parameters

key
Type: SystemString
The key of the macro.
pattern
Type: SystemString
The text regular expression source.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Properties

DynamicLexicalMacro Properties

The DynamicLexicalMacro type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets a string-based key that identifies the object.
Public property | Pattern | Gets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.Key Property

DynamicLexicalMacroKey Property
Gets a string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
A string-based key that identifies the object.

Implements

IKeyedObjectKey
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.Pattern Property

DynamicLexicalMacroPattern Property
Gets the text regular expression source.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Pattern { get; }
Public ReadOnly Property Pattern As String
    Get

Property Value

Type: String
The text regular expression source.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.Tag Property

DynamicLexicalMacroTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro Methods

DynamicLexicalMacro Methods

The DynamicLexicalMacro type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalMacro.ToString Method

DynamicLexicalMacroToString Method
Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

DynamicLexicalMacro Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Class

DynamicLexicalPattern Class
Represents a lexical pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPattern

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DynamicLexicalPattern
Public Class DynamicLexicalPattern

The DynamicLexicalPattern type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalPattern | Initializes a new instance of the DynamicLexicalPattern class.
Top
Properties
 | Name | Description
Public property | LexicalPatternGroup | Gets the parent DynamicLexicalPatternGroup.
Public property | Pattern | Gets or sets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Constructor

DynamicLexicalPattern Constructor
Initializes a new instance of the DynamicLexicalPattern class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalPattern(
    string pattern
)
Public Sub New (
    pattern As String
)

Parameters

pattern
Type: SystemString
The text regular expression source.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Properties

DynamicLexicalPattern Properties

The DynamicLexicalPattern type exposes the following members.

Properties
 | Name | Description
Public property | LexicalPatternGroup | Gets the parent DynamicLexicalPatternGroup.
Public property | Pattern | Gets or sets the text regular expression source.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.LexicalPatternGroup Property

DynamicLexicalPatternLexicalPatternGroup Property
Gets the parent DynamicLexicalPatternGroup.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup LexicalPatternGroup { get; }
Public ReadOnly Property LexicalPatternGroup As DynamicLexicalPatternGroup
    Get

Property Value

Type: DynamicLexicalPatternGroup
The parent DynamicLexicalPatternGroup.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.Pattern Property

DynamicLexicalPatternPattern Property
Gets or sets the text regular expression source.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Pattern { get; set; }
Public Property Pattern As String
    Get
    Set

Property Value

Type: String
The text regular expression source.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.Tag Property

DynamicLexicalPatternTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern Methods

DynamicLexicalPattern Methods

The DynamicLexicalPattern type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPattern.ToString Method

DynamicLexicalPatternToString Method
Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

DynamicLexicalPattern Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup Class

DynamicLexicalPatternGroup Class
Encapsulates a collection of DynamicLexicalPattern objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPatternGroup

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DynamicLexicalPatternGroup : IKeyedObject
Public Class DynamicLexicalPatternGroup
    Implements IKeyedObject

The DynamicLexicalPatternGroup type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalPatternGroup | Initializes a new instance of the DynamicLexicalPatternGroup class.
Top
Properties
 | Name | Description
Public property | CaseSensitivity | Gets or sets a nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.
Public property | ClassificationType | Gets or sets the IClassificationType to use for tokens within the pattern group.
Public property | IsCaseSensitive | Gets whether the explicit patterns in the pattern group are case sensitive.
Public property | Key | Gets or sets a string-based key that identifies the object.
Public property | LexicalScope | Gets the DynamicLexicalScope, if any, that defines the pattern group.
Public property | LexicalState | Gets the DynamicLexicalState that defines the pattern group.
Public property | LookAheadPattern | Gets or sets the text regular expression source for the look-ahead.
Public property | LookBehindPattern | Gets or sets the text regular expression source for the look-behind.
Public property | Patterns | Gets the collection of lexical patterns.
Public property | PatternType | Gets or sets a DynamicLexicalPatternType indicating the type of pattern.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | TokenId | Gets or sets a numeric ID that identifies the token that this pattern group assigns.
Public property | TokenKey | Gets the key of the token that this pattern group assigns.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPattern


DynamicLexicalPatternGroup Constructor

DynamicLexicalPatternGroup Constructor
Initializes a new instance of the DynamicLexicalPatternGroup class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup(
    DynamicLexicalPatternType patternType,
    string tokenKey,
    IClassificationType classificationType
)
Public Sub New (
    patternType As DynamicLexicalPatternType,
    tokenKey As String,
    classificationType As IClassificationType
)

Parameters

patternType
Type: ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPatternType
A DynamicLexicalPatternType indicating the type of pattern.
tokenKey
Type: SystemString
The key of the token that this pattern group assigns.
classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType that this pattern group uses.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup Properties

DynamicLexicalPatternGroup Properties

The DynamicLexicalPatternGroup type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitivity | Gets or sets a nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.
Public property | ClassificationType | Gets or sets the IClassificationType to use for tokens within the pattern group.
Public property | IsCaseSensitive | Gets whether the explicit patterns in the pattern group are case sensitive.
Public property | Key | Gets or sets a string-based key that identifies the object.
Public property | LexicalScope | Gets the DynamicLexicalScope, if any, that defines the pattern group.
Public property | LexicalState | Gets the DynamicLexicalState that defines the pattern group.
Public property | LookAheadPattern | Gets or sets the text regular expression source for the look-ahead.
Public property | LookBehindPattern | Gets or sets the text regular expression source for the look-behind.
Public property | Patterns | Gets the collection of lexical patterns.
Public property | PatternType | Gets or sets a DynamicLexicalPatternType indicating the type of pattern.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | TokenId | Gets or sets a numeric ID that identifies the token that this pattern group assigns.
Public property | TokenKey | Gets the key of the token that this pattern group assigns.
Top
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.CaseSensitivity Property

DynamicLexicalPatternGroupCaseSensitivity Property
Gets or sets a nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<CaseSensitivity> CaseSensitivity { get; set; }
Public Property CaseSensitivity As Nullable(Of CaseSensitivity)
    Get
    Set

Property Value

Type: Nullable CaseSensitivity
A nullable CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the pattern group.
Remarks
A value indicates that the setting should be inherited from the parent LexicalState
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.ClassificationType Property

DynamicLexicalPatternGroupClassificationType Property
Gets or sets the IClassificationType to use for tokens within the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType to use for tokens within the pattern group.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.IsCaseSensitive Property

DynamicLexicalPatternGroupIsCaseSensitive Property
Gets whether the explicit patterns in the pattern group are case sensitive.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; }
Public ReadOnly Property IsCaseSensitive As Boolean
    Get

Property Value

Type: Boolean
true if the explicit patterns in the pattern group are case sensitive; otherwise, false.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.Key Property

DynamicLexicalPatternGroupKey Property
Gets or sets a string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
A string-based key that identifies the object.

Implements

IKeyedObjectKey
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LexicalScope Property

DynamicLexicalPatternGroupLexicalScope Property
Gets the DynamicLexicalScope, if any, that defines the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalScope LexicalScope { get; }
Public ReadOnly Property LexicalScope As DynamicLexicalScope
    Get

Property Value

Type: DynamicLexicalScope
The DynamicLexicalScope, if any, that defines the pattern group.
Remarks
If this value is , the pattern group was not defined by a lexical scope.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LexicalState Property

DynamicLexicalPatternGroupLexicalState Property
Gets the DynamicLexicalState that defines the pattern group.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As DynamicLexicalState
    Get

Property Value

Type: DynamicLexicalState
The DynamicLexicalState that defines the pattern group.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LookAheadPattern Property

DynamicLexicalPatternGroupLookAheadPattern Property
Gets or sets the text regular expression source for the look-ahead.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LookAheadPattern { get; set; }
Public Property LookAheadPattern As String
    Get
    Set

Property Value

Type: String
The text regular expression source for the look-ahead.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.LookBehindPattern Property

DynamicLexicalPatternGroupLookBehindPattern Property
Gets or sets the text regular expression source for the look-behind.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LookBehindPattern { get; set; }
Public Property LookBehindPattern As String
    Get
    Set

Property Value

Type: String
The text regular expression source for the look-behind.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.Patterns Property

DynamicLexicalPatternGroupPatterns Property
Gets the collection of lexical patterns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexicalPatternCollection Patterns { get; }
Public ReadOnly Property Patterns As IDynamicLexicalPatternCollection
    Get

Property Value

Type: IDynamicLexicalPatternCollection
A IDynamicLexicalPatternCollection containing the lexical patterns.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.PatternType Property

DynamicLexicalPatternGroupPatternType Property
Gets or sets a DynamicLexicalPatternType indicating the type of pattern.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternType PatternType { get; set; }
Public Property PatternType As DynamicLexicalPatternType
    Get
    Set

Property Value

Type: DynamicLexicalPatternType
A DynamicLexicalPatternType indicating the type of pattern.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.Tag Property

DynamicLexicalPatternGroupTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.TokenId Property

DynamicLexicalPatternGroupTokenId Property
Gets or sets a numeric ID that identifies the token that this pattern group assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TokenId { get; set; }
Public Property TokenId As Integer
    Get
    Set

Property Value

Type: Int32
A numeric ID that identifies the token that this pattern group assigns.
Remarks
This property is similar to the TokenKey property although TokenKey is a string, while TokenID is a number which can be cast to an enumeration.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.TokenKey Property

DynamicLexicalPatternGroupTokenKey Property
Gets the key of the token that this pattern group assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TokenKey { get; }
Public ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The key of the token that this pattern group assigns.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup Methods

DynamicLexicalPatternGroup Methods

The DynamicLexicalPatternGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Top
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternGroup.ToString Method

DynamicLexicalPatternGroupToString Method
Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

DynamicLexicalPatternGroup Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType Class

DynamicLexicalPatternType Class
Specifies the type of lexical pattern.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalPatternType

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DynamicLexicalPatternType : Enum
Public NotInheritable Class DynamicLexicalPatternType
    Inherits Enum

The DynamicLexicalPatternType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Explicit | An explicit pattern in which all pattern characters have no regex meaning.
 | Regex | A pattern in which regex characters have special meaning and can control regular expression parsing.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType Methods

DynamicLexicalPatternType Methods

The DynamicLexicalPatternType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DynamicLexicalPatternType Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType Fields

DynamicLexicalPatternType Fields

The DynamicLexicalPatternType type exposes the following members.

Fields
 | Name | Description
 | Explicit | An explicit pattern in which all pattern characters have no regex meaning.
 | Regex | A pattern in which regex characters have special meaning and can control regular expression parsing.
Public field | value__ |
Top
See Also

Reference

DynamicLexicalPatternType Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType.Explicit Field

DynamicLexicalPatternTypeExplicit Field
An explicit pattern in which all pattern characters have no regex meaning.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DynamicLexicalPatternType Explicit = 0
Public Const Explicit As DynamicLexicalPatternType = 0

Field Value

Type: DynamicLexicalPatternType
See Also

Reference

DynamicLexicalPatternType Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType.Regex Field

DynamicLexicalPatternTypeRegex Field
A pattern in which regex characters have special meaning and can control regular expression parsing.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DynamicLexicalPatternType Regex = 1
Public Const Regex As DynamicLexicalPatternType = 1

Field Value

Type: DynamicLexicalPatternType
See Also

Reference

DynamicLexicalPatternType Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalPatternType.value__ Field

DynamicLexicalPatternTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Lexing.Implementation.DynamicLexicalPatternType.value__"]

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DynamicLexicalPatternType Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Class

DynamicLexicalScope Class
Contains information about a lexical scope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalScope

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DynamicLexicalScope : LexicalScopeBase
Public Class DynamicLexicalScope
    Inherits LexicalScopeBase

The DynamicLexicalScope type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalScope | Initializes a new instance of the DynamicLexicalScope class
Top
Properties
 | Name | Description
Public property | EndLexicalPatternGroup | Gets or sets the lexical pattern group that ends the scope.
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Public property | LexicalState | Gets the DynamicLexicalState that defines the lexical scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | StartLexicalPatternGroup | Gets or sets the lexical pattern group that starts the scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Constructor

DynamicLexicalScope Constructor
Initializes a new instance of the DynamicLexicalScope class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalScope()
Public Sub New
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Properties

DynamicLexicalScope Properties

The DynamicLexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | EndLexicalPatternGroup | Gets or sets the lexical pattern group that ends the scope.
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Public property | LexicalState | Gets the DynamicLexicalState that defines the lexical scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | StartLexicalPatternGroup | Gets or sets the lexical pattern group that starts the scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.EndLexicalPatternGroup Property

DynamicLexicalScopeEndLexicalPatternGroup Property
Gets or sets the lexical pattern group that ends the scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup EndLexicalPatternGroup { get; set; }
Public Property EndLexicalPatternGroup As DynamicLexicalPatternGroup
    Get
    Set

Property Value

Type: DynamicLexicalPatternGroup
The DynamicLexicalPatternGroup that ends the scope.
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.LexicalState Property

DynamicLexicalScopeLexicalState Property
Gets the DynamicLexicalState that defines the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As DynamicLexicalState
    Get

Property Value

Type: DynamicLexicalState
The DynamicLexicalState that defines the lexical scope.
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.StartLexicalPatternGroup Property

DynamicLexicalScopeStartLexicalPatternGroup Property
Gets or sets the lexical pattern group that starts the scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalPatternGroup StartLexicalPatternGroup { get; set; }
Public Property StartLexicalPatternGroup As DynamicLexicalPatternGroup
    Get
    Set

Property Value

Type: DynamicLexicalPatternGroup
The DynamicLexicalPatternGroup that starts the scope.
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope Methods

DynamicLexicalScope Methods

The DynamicLexicalScope type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.IsScopeEnd Method

DynamicLexicalScopeIsScopeEnd Method
Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Public Overrides Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeEnd(ITextBufferReader)
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalScope.IsScopeStart Method

DynamicLexicalScopeIsScopeStart Method
Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Public Overrides Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeStart(ITextBufferReader)
See Also

Reference

DynamicLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Class

DynamicLexicalState Class
Contains information about a lexical state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalState

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DynamicLexicalState : LexicalStateBase
Public Class DynamicLexicalState
    Inherits LexicalStateBase

The DynamicLexicalState type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicLexicalState(String) | Initializes a new instance of the DynamicLexicalState class.
Public method | DynamicLexicalState(Int32, String) | Initializes a new instance of the DynamicLexicalState class.
Top
Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultCaseSensitivity | Gets or sets a CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups.
Public property | DefaultClassificationType | Gets or sets the IClassificationType of the default token that this state assigns.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the IDynamicLexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalPatternGroups | Gets the collection of lexical pattern groups.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Overrides LexicalStateBaseCreateChildLexicalStates.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Overrides LexicalStateBaseCreateLexicalScopes.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Constructor

DynamicLexicalState Constructor
Overload List
 | Name | Description
Public method | DynamicLexicalState(String) | Initializes a new instance of the DynamicLexicalState class.
Public method | DynamicLexicalState(Int32, String) | Initializes a new instance of the DynamicLexicalState class.
Top
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Constructor (String)

DynamicLexicalState Constructor (String)
Initializes a new instance of the DynamicLexicalState class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalState(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
The key of the lexical state.
See Also

Reference

DynamicLexicalState Class
DynamicLexicalState Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Constructor (Int32, String)

DynamicLexicalState Constructor (Int32, String)
Initializes a new instance of the DynamicLexicalState class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DynamicLexicalState(
    int id,
    string key
)
Public Sub New (
    id As Integer,
    key As String
)

Parameters

id
Type: SystemInt32
The ID of the lexical state.
key
Type: SystemString
The key of the lexical state.
See Also

Reference

DynamicLexicalState Class
DynamicLexicalState Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Properties

DynamicLexicalState Properties

The DynamicLexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultCaseSensitivity | Gets or sets a CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups.
Public property | DefaultClassificationType | Gets or sets the IClassificationType of the default token that this state assigns.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the IDynamicLexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalPatternGroups | Gets the collection of lexical pattern groups.
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.ChildLexicalStates Property

DynamicLexicalStateChildLexicalStates Property
Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexicalStateCollection ChildLexicalStates { get; }
Public ReadOnly Property ChildLexicalStates As IDynamicLexicalStateCollection
    Get

Property Value

Type: IDynamicLexicalStateCollection
A IDynamicLexicalStateCollection containing the child lexical states.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.DefaultCaseSensitivity Property

DynamicLexicalStateDefaultCaseSensitivity Property
Gets or sets a CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CaseSensitivity DefaultCaseSensitivity { get; set; }
Public Property DefaultCaseSensitivity As CaseSensitivity
    Get
    Set

Property Value

Type: CaseSensitivity
A CaseSensitivity determining how the lexer should handle case sensitivity for patterns in the state's pattern groups. The default value is CaseSensitivity.Insensitive.
Remarks
This property provides the default value for lexical pattern groups within the state without an explicit case sensitivity option set.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.DefaultClassificationType Property

DynamicLexicalStateDefaultClassificationType Property
Gets or sets the IClassificationType of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType DefaultClassificationType { get; set; }
Public Property DefaultClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType of the default token that this state assigns.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.Lexer Property

DynamicLexicalStateLexer Property
Gets the IDynamicLexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexer Lexer { get; }
Public ReadOnly Property Lexer As IDynamicLexer
    Get

Property Value

Type: IDynamicLexer
The IDynamicLexer that contains the state.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.LexicalPatternGroups Property

DynamicLexicalStateLexicalPatternGroups Property
Gets the collection of lexical pattern groups.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexicalPatternGroupCollection LexicalPatternGroups { get; }
Public ReadOnly Property LexicalPatternGroups As IDynamicLexicalPatternGroupCollection
    Get

Property Value

Type: IDynamicLexicalPatternGroupCollection
A IDynamicLexicalPatternGroupCollection containing the lexical pattern groups.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.LexicalScopes Property

DynamicLexicalStateLexicalScopes Property
Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDynamicLexicalScopeCollection LexicalScopes { get; }
Public ReadOnly Property LexicalScopes As IDynamicLexicalScopeCollection
    Get

Property Value

Type: IDynamicLexicalScopeCollection
A IDynamicLexicalScopeCollection containing the lexical scopes.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState Methods

DynamicLexicalState Methods

The DynamicLexicalState type exposes the following members.

Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Overrides LexicalStateBaseCreateChildLexicalStates.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Overrides LexicalStateBaseCreateLexicalScopes.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.CreateChildLexicalStates Method

DynamicLexicalStateCreateChildLexicalStates Method
Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override ILexicalStateCollection CreateChildLexicalStates()
Protected Overrides Function CreateChildLexicalStates As ILexicalStateCollection

Return Value

Type: ILexicalStateCollection
The ILexicalStateCollection that was created.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


DynamicLexicalState.CreateLexicalScopes Method

DynamicLexicalStateCreateLexicalScopes Method
Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override ILexicalScopeCollection CreateLexicalScopes()
Protected Overrides Function CreateLexicalScopes As ILexicalScopeCollection

Return Value

Type: ILexicalScopeCollection
The ILexicalScopeCollection that was created.
See Also

Reference

DynamicLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer Interface

IDynamicLexer Interface
Provides the base requirements for a dynamic lexer, one that is pattern based.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDynamicLexer : IMergableLexer,
    ILexer, IKeyedObject
Public Interface IDynamicLexer
    Inherits IMergableLexer, ILexer, IKeyedObject

The IDynamicLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from IMergableLexer.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from IMergableLexer.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from IMergableLexer.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from IMergableLexer.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from IMergableLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from IMergableLexer.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from IMergableLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from IMergableLexer.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer


IDynamicLexer Properties

IDynamicLexer Properties

The IDynamicLexer type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLexicalState | Gets or sets the root ILexicalState for when the language is entered.
Public property | Key | Gets or sets a string that identifies the lexer, generally the related language name.
Public property | LexicalMacros | Gets the collection of lexical macros.
Public property | LexicalStateIdProvider | Gets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer. (Inherited from IMergableLexer.)
Public property | LexicalStates | Gets the collection of lexical states.
Public property | TokenIdProvider | Gets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer. (Inherited from ILexer.)
Top
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.DefaultLexicalState Property

IDynamicLexerDefaultLexicalState Property
Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DynamicLexicalState DefaultLexicalState { get; set; }
Property DefaultLexicalState As DynamicLexicalState
    Get
    Set

Property Value

Type: DynamicLexicalState
The root ILexicalState for when the language is entered.
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.Key Property

IDynamicLexerKey Property
Gets or sets a string that identifies the lexer, generally the related language name.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Key { get; set; }
Property Key As String
    Get
    Set

Property Value

Type: String
A string that identifies the lexer, generally the related language name.

Implements

IKeyedObjectKey
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.LexicalMacros Property

IDynamicLexerLexicalMacros Property
Gets the collection of lexical macros.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDynamicLexicalMacroCollection LexicalMacros { get; }
ReadOnly Property LexicalMacros As IDynamicLexicalMacroCollection
    Get

Property Value

Type: IDynamicLexicalMacroCollection
A IDynamicLexicalMacroCollection containing the lexical macros.
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer.LexicalStates Property

IDynamicLexerLexicalStates Property
Gets the collection of lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDynamicLexicalStateCollection LexicalStates { get; }
ReadOnly Property LexicalStates As IDynamicLexicalStateCollection
    Get

Property Value

Type: IDynamicLexicalStateCollection
A IDynamicLexicalStateCollection containing the lexical states.
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer Methods

IDynamicLexer Methods

The IDynamicLexer type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur. (Inherited from IMergableLexer.)
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document. (Inherited from IMergableLexer.)
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data. (Inherited from IMergableLexer.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer. (Inherited from IMergableLexer.)
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader (Inherited from IMergableLexer.)
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match. (Inherited from IMergableLexer.)
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot. (Inherited from ILexer.)
Top
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexer Events

IDynamicLexer Events

The IDynamicLexer type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch. (Inherited from IMergableLexer.)
Top
See Also

Reference

IDynamicLexer Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Interface

IDynamicLexicalMacroCollection Interface
Provides the base requirements for a collection of DynamicLexicalMacro objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalMacroCollection : IKeyedObservableCollection<DynamicLexicalMacro>,
    IObservableCollection<DynamicLexicalMacro>, IList<DynamicLexicalMacro>, ICollection<DynamicLexicalMacro>,
    IEnumerable<DynamicLexicalMacro>, IEnumerable
Public Interface IDynamicLexicalMacroCollection
    Inherits IKeyedObservableCollection(Of DynamicLexicalMacro), IObservableCollection(Of DynamicLexicalMacro),
    IList(Of DynamicLexicalMacro), ICollection(Of DynamicLexicalMacro), IEnumerable(Of DynamicLexicalMacro),
    IEnumerable

The IDynamicLexicalMacroCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalMacro .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalMacro .)
Public property | ItemInt32 | (Inherited from IList DynamicLexicalMacro .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalMacro .)
Public method | Clear | (Inherited from ICollection DynamicLexicalMacro .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection DynamicLexicalMacro .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalMacro .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalMacro .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList DynamicLexicalMacro .)
Public method | Insert | (Inherited from IList DynamicLexicalMacro .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection DynamicLexicalMacro .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalMacro .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Properties

IDynamicLexicalMacroCollection Properties

The IDynamicLexicalMacroCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalMacro .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalMacro .)
Public property | ItemInt32 | (Inherited from IList DynamicLexicalMacro .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalMacroCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Methods

IDynamicLexicalMacroCollection Methods

The IDynamicLexicalMacroCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalMacro .)
Public method | Clear | (Inherited from ICollection DynamicLexicalMacro .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection DynamicLexicalMacro .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalMacro .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalMacro .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList DynamicLexicalMacro .)
Public method | Insert | (Inherited from IList DynamicLexicalMacro .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection DynamicLexicalMacro .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalMacro .)
Top
See Also

Reference

IDynamicLexicalMacroCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalMacroCollection Events

IDynamicLexicalMacroCollection Events

The IDynamicLexicalMacroCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalMacroCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Interface

IDynamicLexicalPatternCollection Interface
Provides the base requirements for a collection of DynamicLexicalPattern objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalPatternCollection : IObservableCollection<DynamicLexicalPattern>,
    IList<DynamicLexicalPattern>, ICollection<DynamicLexicalPattern>, IEnumerable<DynamicLexicalPattern>,
    IEnumerable
Public Interface IDynamicLexicalPatternCollection
    Inherits IObservableCollection(Of DynamicLexicalPattern), IList(Of DynamicLexicalPattern),
    ICollection(Of DynamicLexicalPattern), IEnumerable(Of DynamicLexicalPattern), IEnumerable

The IDynamicLexicalPatternCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalPattern .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalPattern .)
Public property | Item | (Inherited from IList DynamicLexicalPattern .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalPattern .)
Public method | Clear | (Inherited from ICollection DynamicLexicalPattern .)
Public method | Contains | (Inherited from ICollection DynamicLexicalPattern .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalPattern .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalPattern .)
Public method | IndexOf | (Inherited from IList DynamicLexicalPattern .)
Public method | Insert | (Inherited from IList DynamicLexicalPattern .)
Public method | Remove | (Inherited from ICollection DynamicLexicalPattern .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalPattern .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Properties

IDynamicLexicalPatternCollection Properties

The IDynamicLexicalPatternCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalPattern .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalPattern .)
Public property | Item | (Inherited from IList DynamicLexicalPattern .)
Top
See Also

Reference

IDynamicLexicalPatternCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Methods

IDynamicLexicalPatternCollection Methods

The IDynamicLexicalPatternCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalPattern .)
Public method | Clear | (Inherited from ICollection DynamicLexicalPattern .)
Public method | Contains | (Inherited from ICollection DynamicLexicalPattern .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalPattern .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalPattern .)
Public method | IndexOf | (Inherited from IList DynamicLexicalPattern .)
Public method | Insert | (Inherited from IList DynamicLexicalPattern .)
Public method | Remove | (Inherited from ICollection DynamicLexicalPattern .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalPattern .)
Top
See Also

Reference

IDynamicLexicalPatternCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternCollection Events

IDynamicLexicalPatternCollection Events

The IDynamicLexicalPatternCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalPatternCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Interface

IDynamicLexicalPatternGroupCollection Interface
Provides the base requirements for a collection of DynamicLexicalPatternGroup objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalPatternGroupCollection : IKeyedObservableCollection<DynamicLexicalPatternGroup>,
    IObservableCollection<DynamicLexicalPatternGroup>, IList<DynamicLexicalPatternGroup>, ICollection<DynamicLexicalPatternGroup>,
    IEnumerable<DynamicLexicalPatternGroup>, IEnumerable
Public Interface IDynamicLexicalPatternGroupCollection
    Inherits IKeyedObservableCollection(Of DynamicLexicalPatternGroup), IObservableCollection(Of DynamicLexicalPatternGroup),
    IList(Of DynamicLexicalPatternGroup), ICollection(Of DynamicLexicalPatternGroup), IEnumerable(Of DynamicLexicalPatternGroup),
    IEnumerable

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | ItemInt32 | (Inherited from IList DynamicLexicalPatternGroup .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Clear | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalPatternGroup .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Insert | (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalPatternGroup .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Properties

IDynamicLexicalPatternGroupCollection Properties

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public property | ItemInt32 | (Inherited from IList DynamicLexicalPatternGroup .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalPatternGroupCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Methods

IDynamicLexicalPatternGroupCollection Methods

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Clear | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalPatternGroup .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Insert | (Inherited from IList DynamicLexicalPatternGroup .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection DynamicLexicalPatternGroup .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalPatternGroup .)
Top
See Also

Reference

IDynamicLexicalPatternGroupCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalPatternGroupCollection Events

IDynamicLexicalPatternGroupCollection Events

The IDynamicLexicalPatternGroupCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalPatternGroupCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Interface

IDynamicLexicalScopeCollection Interface
Provides the base requirements for a collection of DynamicLexicalScope objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalScopeCollection : IObservableCollection<DynamicLexicalScope>,
    IList<DynamicLexicalScope>, ICollection<DynamicLexicalScope>, IEnumerable<DynamicLexicalScope>,
    IEnumerable
Public Interface IDynamicLexicalScopeCollection
    Inherits IObservableCollection(Of DynamicLexicalScope), IList(Of DynamicLexicalScope),
    ICollection(Of DynamicLexicalScope), IEnumerable(Of DynamicLexicalScope), IEnumerable

The IDynamicLexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalScope .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalScope .)
Public property | Item | (Inherited from IList DynamicLexicalScope .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalScope .)
Public method | Clear | (Inherited from ICollection DynamicLexicalScope .)
Public method | Contains | (Inherited from ICollection DynamicLexicalScope .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalScope .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalScope .)
Public method | IndexOf | (Inherited from IList DynamicLexicalScope .)
Public method | Insert | (Inherited from IList DynamicLexicalScope .)
Public method | Remove | (Inherited from ICollection DynamicLexicalScope .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalScope .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Properties

IDynamicLexicalScopeCollection Properties

The IDynamicLexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalScope .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalScope .)
Public property | Item | (Inherited from IList DynamicLexicalScope .)
Top
See Also

Reference

IDynamicLexicalScopeCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Methods

IDynamicLexicalScopeCollection Methods

The IDynamicLexicalScopeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalScope .)
Public method | Clear | (Inherited from ICollection DynamicLexicalScope .)
Public method | Contains | (Inherited from ICollection DynamicLexicalScope .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalScope .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalScope .)
Public method | IndexOf | (Inherited from IList DynamicLexicalScope .)
Public method | Insert | (Inherited from IList DynamicLexicalScope .)
Public method | Remove | (Inherited from ICollection DynamicLexicalScope .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalScope .)
Top
See Also

Reference

IDynamicLexicalScopeCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalScopeCollection Events

IDynamicLexicalScopeCollection Events

The IDynamicLexicalScopeCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalScopeCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Interface

IDynamicLexicalStateCollection Interface
Provides the base requirements for a collection of DynamicLexicalState objects.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDynamicLexicalStateCollection : IKeyedObservableCollection<DynamicLexicalState>,
    IObservableCollection<DynamicLexicalState>, IList<DynamicLexicalState>, ICollection<DynamicLexicalState>,
    IEnumerable<DynamicLexicalState>, IEnumerable
Public Interface IDynamicLexicalStateCollection
    Inherits IKeyedObservableCollection(Of DynamicLexicalState), IObservableCollection(Of DynamicLexicalState),
    IList(Of DynamicLexicalState), ICollection(Of DynamicLexicalState), IEnumerable(Of DynamicLexicalState),
    IEnumerable

The IDynamicLexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalState .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalState .)
Public property | ItemInt32 | (Inherited from IList DynamicLexicalState .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalState .)
Public method | Clear | (Inherited from ICollection DynamicLexicalState .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection DynamicLexicalState .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalState .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalState .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList DynamicLexicalState .)
Public method | Insert | (Inherited from IList DynamicLexicalState .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection DynamicLexicalState .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalState .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Properties

IDynamicLexicalStateCollection Properties

The IDynamicLexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection DynamicLexicalState .)
Public property | IsReadOnly | (Inherited from ICollection DynamicLexicalState .)
Public property | ItemInt32 | (Inherited from IList DynamicLexicalState .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalStateCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Methods

IDynamicLexicalStateCollection Methods

The IDynamicLexicalStateCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection DynamicLexicalState .)
Public method | Clear | (Inherited from ICollection DynamicLexicalState .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection DynamicLexicalState .)
Public method | CopyTo | (Inherited from ICollection DynamicLexicalState .)
Public method | GetEnumerator | (Inherited from IEnumerable DynamicLexicalState .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList DynamicLexicalState .)
Public method | Insert | (Inherited from IList DynamicLexicalState .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection DynamicLexicalState .)
Public method | RemoveAt | (Inherited from IList DynamicLexicalState .)
Top
See Also

Reference

IDynamicLexicalStateCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


IDynamicLexicalStateCollection Events

IDynamicLexicalStateCollection Events

The IDynamicLexicalStateCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IDynamicLexicalStateCollection Interface
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Class

LexicalScopeBase Class
Provides the abstract base class for a lexical scope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalScope
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScope

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class LexicalScopeBase : ILexicalScope
Public MustInherit Class LexicalScopeBase
    Implements ILexicalScope

The LexicalScopeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LexicalScopeBase | Initializes a new instance of the LexicalScopeBase class.
Top
Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope.
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Constructor

LexicalScopeBase Constructor
Initializes a new instance of the LexicalScopeBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected LexicalScopeBase()
Protected Sub New
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Properties

LexicalScopeBase Properties

The LexicalScopeBase type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope.
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope.
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending.
Top
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.IsAncestorEndScopeCheckEnabled Property

LexicalScopeBaseIsAncestorEndScopeCheckEnabled Property
Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAncestorEndScopeCheckEnabled { get; set; }
Public Property IsAncestorEndScopeCheckEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ancestor end scope checking is enabled; otherwise, false.

Implements

ILexicalScopeIsAncestorEndScopeCheckEnabled
Remarks
When enabled, this allows ancestor scopes to be examined to see a pattern matches their end scope. In the event a match is found, this scope exits as well as the ancestor's scope.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.LexicalStateCore Property

LexicalScopeBaseLexicalStateCore Property
Gets or sets the ILexicalState that defines the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexicalState LexicalStateCore { get; set; }
Protected Property LexicalStateCore As ILexicalState
    Get
    Set

Property Value

Type: ILexicalState
The ILexicalState that defines the lexical scope.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.ParentTransitionCore Property

LexicalScopeBaseParentTransitionCore Property
Gets or sets the ILexicalStateTransition that is the parent of this scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexicalStateTransition ParentTransitionCore { get; set; }
Protected Property ParentTransitionCore As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is the parent of this scope.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.Tag Property

LexicalScopeBaseTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

ILexicalScopeTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.Transition Property

LexicalScopeBaseTransition Property
Gets or sets the ILexicalStateTransition that this scope performs after ending.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateTransition Transition { get; set; }
Public Property Transition As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that this scope performs after ending. If the value is , then no state transition is performed when the scope ends.

Implements

ILexicalScopeTransition
Remarks
The state transition may be made to a child language.
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase Methods

LexicalScopeBase Methods

The LexicalScopeBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.IsScopeEnd Method

LexicalScopeBaseIsScopeEnd Method
Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Public MustOverride Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeEnd(ITextBufferReader)
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeBase.IsScopeStart Method

LexicalScopeBaseIsScopeStart Method
Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Public MustOverride Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeStart(ITextBufferReader)
See Also

Reference

LexicalScopeBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Class

LexicalScopeCollection Class
Represents a collection of lexical scopes.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LexicalScopeBase
ActiproSoftware.Text.UtilitySimpleObservableCollection LexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeCollection

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LexicalScopeCollection : SimpleObservableCollection<LexicalScopeBase>,
    ILexicalScopeCollection, IList<ILexicalScope>, ICollection<ILexicalScope>,
    IEnumerable<ILexicalScope>, IEnumerable
Public Class LexicalScopeCollection
    Inherits SimpleObservableCollection(Of LexicalScopeBase)
    Implements ILexicalScopeCollection, IList(Of ILexicalScope),
    ICollection(Of ILexicalScope), IEnumerable(Of ILexicalScope), IEnumerable

The LexicalScopeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalScopeCollection | Initializes a new instance of the LexicalScopeCollection class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection LexicalScopeBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | (Inherited from Collection LexicalScopeBase .)
Protected property | Items | (Inherited from Collection LexicalScopeBase .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection LexicalScopeBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection LexicalScopeBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | (Inherited from Collection LexicalScopeBase .)
Public method | CopyTo | (Inherited from Collection LexicalScopeBase .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection LexicalScopeBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection LexicalScopeBase .)
Public method | Insert | (Inherited from Collection LexicalScopeBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove | (Inherited from Collection LexicalScopeBase .)
Public method | RemoveAt | (Inherited from Collection LexicalScopeBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Constructor

LexicalScopeCollection Constructor
Initializes a new instance of the LexicalScopeCollection class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LexicalScopeCollection(
    ILexicalState parentLexicalState
)
Public Sub New (
    parentLexicalState As ILexicalState
)

Parameters

parentLexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The parent ILexicalState that should be assigned to children, if any.
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Properties

LexicalScopeCollection Properties

The LexicalScopeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection LexicalScopeBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | (Inherited from Collection LexicalScopeBase .)
Protected property | Items | (Inherited from Collection LexicalScopeBase .)
Top
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Methods

LexicalScopeCollection Methods

The LexicalScopeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection LexicalScopeBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection LexicalScopeBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | (Inherited from Collection LexicalScopeBase .)
Public method | CopyTo | (Inherited from Collection LexicalScopeBase .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection LexicalScopeBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection LexicalScopeBase .)
Public method | Insert | (Inherited from Collection LexicalScopeBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove | (Inherited from Collection LexicalScopeBase .)
Public method | RemoveAt | (Inherited from Collection LexicalScopeBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection.OnItemAdded Method

LexicalScopeCollectionOnItemAdded Method
Called after an item as been added into the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemAdded(
    int index,
    LexicalScopeBase value
)
Protected Overrides Sub OnItemAdded (
    index As Integer,
    value As LexicalScopeBase
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
The item that is added.
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection.OnItemRemoving Method

LexicalScopeCollectionOnItemRemoving Method
Called before an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemRemoving(
    int index,
    LexicalScopeBase value
)
Protected Overrides Sub OnItemRemoving (
    index As Integer,
    value As LexicalScopeBase
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
The item that is removed.
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeCollection Events

LexicalScopeCollection Events

The LexicalScopeCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

LexicalScopeCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Class

LexicalScopeTokenData Class
Provides IToken lexer data based on a token ID and an ILexicalScope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeTokenData

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LexicalScopeTokenData : IMergableTokenLexerData
Public Class LexicalScopeTokenData
    Implements IMergableTokenLexerData

The LexicalScopeTokenData type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalScopeTokenData | Initializes a new instance of the LexicalScopeTokenData class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Constructor

LexicalScopeTokenData Constructor
Initializes a new instance of the LexicalScopeTokenData class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LexicalScopeTokenData(
    ILexicalScope lexicalScope,
    int tokenId
)
Public Sub New (
    lexicalScope As ILexicalScope,
    tokenId As Integer
)

Parameters

lexicalScope
Type: ActiproSoftware.Text.LexingILexicalScope
The ILexicalScope that contains the token.
tokenId
Type: SystemInt32
The ID of the token.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Properties

LexicalScopeTokenData Properties

The LexicalScopeTokenData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.ClassificationType Property

LexicalScopeTokenDataClassificationType Property
Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; }
Public ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.

Implements

IMergableTokenLexerDataClassificationType
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.Lexer Property

LexicalScopeTokenDataLexer Property
Gets the IMergableLexer that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMergableLexer Lexer { get; }
Public ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that contains the token.

Implements

IMergableTokenLexerDataLexer
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.LexicalScope Property

LexicalScopeTokenDataLexicalScope Property
Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalScope LexicalScope { get; }
Public ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.

Implements

IMergableTokenLexerDataLexicalScope
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.LexicalState Property

LexicalScopeTokenDataLexicalState Property
Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.

Implements

IMergableTokenLexerDataLexicalState
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.TokenId Property

LexicalScopeTokenDataTokenId Property
Gets the token ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TokenId { get; }
Public ReadOnly Property TokenId As Integer
    Get

Property Value

Type: Int32
The token ID assigned to the token.

Implements

IMergableTokenLexerDataTokenId
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.TokenKey Property

LexicalScopeTokenDataTokenKey Property
Gets the token key assigned to the token, if it is known.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string TokenKey { get; }
Public Overridable ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The token key assigned to the token, if it is known.

Implements

IMergableTokenLexerDataTokenKey
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData Methods

LexicalScopeTokenData Methods

The LexicalScopeTokenData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.Equals Method

LexicalScopeTokenDataEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalScopeTokenData.GetHashCode Method

LexicalScopeTokenDataGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

LexicalScopeTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Class

LexicalStateBase Class
Provides the abstract base class for a lexical state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationDynamicLexicalState
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalState

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class LexicalStateBase : ILexicalState,
    IKeyedObject
Public MustInherit Class LexicalStateBase
    Implements ILexicalState, IKeyedObject

The LexicalStateBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LexicalStateBase | Initializes a new instance of the LexicalStateBase class.
Top
Properties
 | Name | Description
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns.
Public property | Id | Gets or sets the ID value that identifies the lexical state.
Public property | Key | Gets a string-based key that identifies the lexical state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Constructor

LexicalStateBase Constructor
Initializes a new instance of the LexicalStateBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected LexicalStateBase(
    int id,
    string key
)
Protected Sub New (
    id As Integer,
    key As String
)

Parameters

id
Type: SystemInt32
The ID of the lexical state.
key
Type: SystemString
The key of the lexical state.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Properties

LexicalStateBase Properties

The LexicalStateBase type exposes the following members.

Properties
 | Name | Description
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states.
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns.
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns.
Public property | Id | Gets or sets the ID value that identifies the lexical state.
Public property | Key | Gets a string-based key that identifies the lexical state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.
Top
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.ChildLexicalStatesCore Property

LexicalStateBaseChildLexicalStatesCore Property
Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexicalStateCollection ChildLexicalStatesCore { get; }
Protected ReadOnly Property ChildLexicalStatesCore As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
A LexicalStateCollection containing the child lexical states.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.DefaultTokenId Property

LexicalStateBaseDefaultTokenId Property
Gets or sets the ID of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int DefaultTokenId { get; set; }
Public Property DefaultTokenId As Integer
    Get
    Set

Property Value

Type: Int32
The ID of the default token that this state assigns.

Implements

ILexicalStateDefaultTokenId
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.DefaultTokenKey Property

LexicalStateBaseDefaultTokenKey Property
Gets or sets the key of the default token that this state assigns.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DefaultTokenKey { get; set; }
Public Property DefaultTokenKey As String
    Get
    Set

Property Value

Type: String
The key of the default token that this state assigns.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Id Property

LexicalStateBaseId Property
Gets or sets the ID value that identifies the lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set

Property Value

Type: Int32
The ID value that identifies the lexical state.

Implements

ILexicalStateId
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Key Property

LexicalStateBaseKey Property
Gets a string-based key that identifies the lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
A string-based key that identifies the lexical state.

Implements

IKeyedObjectKey
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.LexerCore Property

LexicalStateBaseLexerCore Property
Gets or sets the ILexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexer LexerCore { get; set; }
Protected Property LexerCore As ILexer
    Get
    Set

Property Value

Type: ILexer
The ILexer that contains the state.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.LexicalScopesCore Property

LexicalStateBaseLexicalScopesCore Property
Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexicalScopeCollection LexicalScopesCore { get; }
Protected ReadOnly Property LexicalScopesCore As ILexicalScopeCollection
    Get

Property Value

Type: ILexicalScopeCollection
A LexicalScopeCollection containing the lexical scopes.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Tag Property

LexicalStateBaseTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

ILexicalStateTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.Transition Property

LexicalStateBaseTransition Property
Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateTransition Transition { get; set; }
Public Property Transition As ILexicalStateTransition
    Get
    Set

Property Value

Type: ILexicalStateTransition
The ILexicalStateTransition that is performed immediately after a start scope match.

Implements

ILexicalStateTransition
Remarks
This provides a mechanism to automatically transition to another language when this state's start scope is matched. This state's end scope may be used to exit the child language.

ASP-style tags are an example of when to use this transition.

See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase Methods

LexicalStateBase Methods

The LexicalStateBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.CreateChildLexicalStates Method

LexicalStateBaseCreateChildLexicalStates Method
Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual ILexicalStateCollection CreateChildLexicalStates()
Protected Overridable Function CreateChildLexicalStates As ILexicalStateCollection

Return Value

Type: ILexicalStateCollection
The ILexicalStateCollection that was created.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateBase.CreateLexicalScopes Method

LexicalStateBaseCreateLexicalScopes Method
Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual ILexicalScopeCollection CreateLexicalScopes()
Protected Overridable Function CreateLexicalScopes As ILexicalScopeCollection

Return Value

Type: ILexicalScopeCollection
The ILexicalScopeCollection that was created.
See Also

Reference

LexicalStateBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Class

LexicalStateCollection Class
Represents a collection of lexical states.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection LexicalStateBase
ActiproSoftware.Text.UtilitySimpleObservableCollection LexicalStateBase
ActiproSoftware.Text.UtilityKeyedObservableCollection LexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationLexicalStateCollection

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LexicalStateCollection : KeyedObservableCollection<LexicalStateBase>,
    ILexicalStateCollection, IList<ILexicalState>, ICollection<ILexicalState>,
    IEnumerable<ILexicalState>, IEnumerable
Public Class LexicalStateCollection
    Inherits KeyedObservableCollection(Of LexicalStateBase)
    Implements ILexicalStateCollection, IList(Of ILexicalState),
    ICollection(Of ILexicalState), IEnumerable(Of ILexicalState), IEnumerable

The LexicalStateCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalStateCollection | Initializes a new instance of the LexicalStateCollection class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection LexicalStateBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection LexicalStateBase .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from KeyedObservableCollectionT.)
Protected property | Items | (Inherited from Collection LexicalStateBase .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection LexicalStateBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection LexicalStateBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from Collection LexicalStateBase .)
Public method | CopyTo | (Inherited from Collection LexicalStateBase .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexical states.
Public method | GetEnumerator | (Inherited from Collection LexicalStateBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from KeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from Collection LexicalStateBase .)
Public method | Insert | (Inherited from Collection LexicalStateBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from KeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from Collection LexicalStateBase .)
Public method | RemoveAt | (Inherited from Collection LexicalStateBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Constructor

LexicalStateCollection Constructor
Initializes a new instance of the LexicalStateCollection class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LexicalStateCollection(
    ILexer parentLexer
)
Public Sub New (
    parentLexer As ILexer
)

Parameters

parentLexer
Type: ActiproSoftware.Text.LexingILexer
The parent ILexer that should be assigned to children, if any.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Properties

LexicalStateCollection Properties

The LexicalStateCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection LexicalStateBase .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection LexicalStateBase .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from KeyedObservableCollectionT.)
Protected property | Items | (Inherited from Collection LexicalStateBase .)
Top
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Methods

LexicalStateCollection Methods

The LexicalStateCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection LexicalStateBase .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection LexicalStateBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from Collection LexicalStateBase .)
Public method | CopyTo | (Inherited from Collection LexicalStateBase .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexical states.
Public method | GetEnumerator | (Inherited from Collection LexicalStateBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from KeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from Collection LexicalStateBase .)
Public method | Insert | (Inherited from Collection LexicalStateBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Overrides SimpleObservableCollectionTOnItemAdded(Int32, T).)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Overrides SimpleObservableCollectionTOnItemRemoving(Int32, T).)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from KeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from Collection LexicalStateBase .)
Public method | RemoveAt | (Inherited from Collection LexicalStateBase .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection.GetAllLexicalStateTransitions Method

LexicalStateCollectionGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexical states.
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection.OnItemAdded Method

LexicalStateCollectionOnItemAdded Method
Called after an item as been added into the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemAdded(
    int index,
    LexicalStateBase value
)
Protected Overrides Sub OnItemAdded (
    index As Integer,
    value As LexicalStateBase
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
The item that is added.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection.OnItemRemoving Method

LexicalStateCollectionOnItemRemoving Method
Called before an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemRemoving(
    int index,
    LexicalStateBase value
)
Protected Overrides Sub OnItemRemoving (
    index As Integer,
    value As LexicalStateBase
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
The item that is removed.
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateCollection Events

LexicalStateCollection Events

The LexicalStateCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

LexicalStateCollection Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Class

LexicalStateIdProviderBase Class
Represents an abstract base class for an object that provides static IDs for the lexical states of an ISyntaxLanguage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexicalStateId
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexicalStateId
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexicalStateId
ActiproSoftware.Text.Languages.VB.ImplementationVBLexicalStateId
ActiproSoftware.Text.Languages.Xml.ImplementationXmlLexicalStateId

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class LexicalStateIdProviderBase : ILexicalStateIdProvider,
    IIdProvider
Public MustInherit Class LexicalStateIdProviderBase
    Implements ILexicalStateIdProvider, IIdProvider

The LexicalStateIdProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LexicalStateIdProviderBase | Initializes a new instance of the LexicalStateIdProviderBase class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified ID.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Constructor

LexicalStateIdProviderBase Constructor
Initializes a new instance of the LexicalStateIdProviderBase class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected LexicalStateIdProviderBase()
Protected Sub New
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Properties

LexicalStateIdProviderBase Properties

The LexicalStateIdProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.MaxId Property

LexicalStateIdProviderBaseMaxId Property
Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int MaxId { get; }
Public MustOverride ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.MinId Property

LexicalStateIdProviderBaseMinId Property
Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int MinId { get; }
Public MustOverride ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase Methods

LexicalStateIdProviderBase Methods

The LexicalStateIdProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified ID.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.ContainsId Method

LexicalStateIdProviderBaseContainsId Method
Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract bool ContainsId(
    int id
)
Public MustOverride Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.GetDescription Method

LexicalStateIdProviderBaseGetDescription Method
Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string GetDescription(
    int id
)
Public MustOverride Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateIdProviderBase.GetKey Method

LexicalStateIdProviderBaseGetKey Method
Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string GetKey(
    int id
)
Public MustOverride Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

LexicalStateIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Class

LexicalStateTokenData Class
Provides IToken lexer data based on a token ID and on an ILexicalState.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTokenData

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LexicalStateTokenData : IMergableTokenLexerData
Public Class LexicalStateTokenData
    Implements IMergableTokenLexerData

The LexicalStateTokenData type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalStateTokenData | Initializes a new instance of the LexicalStateTokenData class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Constructor

LexicalStateTokenData Constructor
Initializes a new instance of the LexicalStateTokenData class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LexicalStateTokenData(
    ILexicalState lexicalState,
    int tokenId
)
Public Sub New (
    lexicalState As ILexicalState,
    tokenId As Integer
)

Parameters

lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
tokenId
Type: SystemInt32
The ID of the token.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Properties

LexicalStateTokenData Properties

The LexicalStateTokenData type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | Lexer | Gets the IMergableLexer that contains the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | TokenId | Gets the token ID assigned to the token.
Public property | TokenKey | Gets the token key assigned to the token, if it is known.
Top
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.ClassificationType Property

LexicalStateTokenDataClassificationType Property
Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; }
Public ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.

Implements

IMergableTokenLexerDataClassificationType
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.Lexer Property

LexicalStateTokenDataLexer Property
Gets the IMergableLexer that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMergableLexer Lexer { get; }
Public ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that contains the token.

Implements

IMergableTokenLexerDataLexer
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.LexicalScope Property

LexicalStateTokenDataLexicalScope Property
Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalScope LexicalScope { get; }
Public ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.

Implements

IMergableTokenLexerDataLexicalScope
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.LexicalState Property

LexicalStateTokenDataLexicalState Property
Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalState LexicalState { get; }
Public ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.

Implements

IMergableTokenLexerDataLexicalState
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.TokenId Property

LexicalStateTokenDataTokenId Property
Gets the token ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TokenId { get; }
Public ReadOnly Property TokenId As Integer
    Get

Property Value

Type: Int32
The token ID assigned to the token.

Implements

IMergableTokenLexerDataTokenId
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.TokenKey Property

LexicalStateTokenDataTokenKey Property
Gets the token key assigned to the token, if it is known.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string TokenKey { get; }
Public Overridable ReadOnly Property TokenKey As String
    Get

Property Value

Type: String
The token key assigned to the token, if it is known.

Implements

IMergableTokenLexerDataTokenKey
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData Methods

LexicalStateTokenData Methods

The LexicalStateTokenData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.Equals Method

LexicalStateTokenDataEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTokenData.GetHashCode Method

LexicalStateTokenDataGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

LexicalStateTokenData Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Class

LexicalStateTransition Class
Contains information about a transition from one lexical state to another.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateTransition

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LexicalStateTransition : ILexicalStateTransition
Public Class LexicalStateTransition
    Implements ILexicalStateTransition

The LexicalStateTransition type exposes the following members.

Constructors
 | Name | Description
Public method | LexicalStateTransition | Initializes a new instance of the LexicalStateTransition class.
Top
Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Constructor

LexicalStateTransition Constructor
Initializes a new instance of the LexicalStateTransition class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LexicalStateTransition(
    ISyntaxLanguage childLanguage,
    ILexicalState childLexicalState,
    LexicalScopeBase childLexicalScope
)
Public Sub New (
    childLanguage As ISyntaxLanguage,
    childLexicalState As ILexicalState,
    childLexicalScope As LexicalScopeBase
)

Parameters

childLanguage
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage that contains the ChildLexicalState.
childLexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState into which a transition is made.
childLexicalScope
Type: ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
The ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Properties

LexicalStateTransition Properties

The LexicalStateTransition type exposes the following members.

Properties
 | Name | Description
Public property | ChildLanguage | Gets the ISyntaxLanguage that contains the ChildLexicalState.
Public property | ChildLexicalScope | Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.
Public property | ChildLexicalState | Gets the ILexicalState into which a transition is made.
Public property | ParentLexicalScope | Gets the ILexicalScope that owns this state transition.
Top
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ChildLanguage Property

LexicalStateTransitionChildLanguage Property
Gets the ISyntaxLanguage that contains the ChildLexicalState.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISyntaxLanguage ChildLanguage { get; }
Public ReadOnly Property ChildLanguage As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage that contains the ChildLexicalState.

Implements

ILexicalStateTransitionChildLanguage
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ChildLexicalScope Property

LexicalStateTransitionChildLexicalScope Property
Gets the ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalScope ChildLexicalScope { get; }
Public ReadOnly Property ChildLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that is used in the ChildLexicalState to end the transition and pop back up to the parent lexical state.

Implements

ILexicalStateTransitionChildLexicalScope
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ChildLexicalState Property

LexicalStateTransitionChildLexicalState Property
Gets the ILexicalState into which a transition is made.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalState ChildLexicalState { get; }
Public ReadOnly Property ChildLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState into which a transition is made.

Implements

ILexicalStateTransitionChildLexicalState
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition.ParentLexicalScope Property

LexicalStateTransitionParentLexicalScope Property
Gets the ILexicalScope that owns this state transition.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalScope ParentLexicalScope { get; }
Public ReadOnly Property ParentLexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope that owns this state transition.

Implements

ILexicalStateTransitionParentLexicalScope
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


LexicalStateTransition Methods

LexicalStateTransition Methods

The LexicalStateTransition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LexicalStateTransition Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Class

MergableLexerBase Class
Represents the base implementation of a lexer (lexical analyzer) for a language that supports merging with other languages.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
More...

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MergableLexerBase : IMergableLexer,
    ILexer, IKeyedObject
Public MustInherit Class MergableLexerBase
    Implements IMergableLexer, ILexer, IKeyedObject

The MergableLexerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MergableLexerBase | Initializes a new instance of the MergableLexerBase class.
Top
Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested.
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
Remarks
Instances of this object can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an instance is registered with the language for the ILexer interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpLexer
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptLexer
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonLexer
ActiproSoftware.Text.Languages.Python.ImplementationPythonLexer
ActiproSoftware.Text.Languages.VB.ImplementationVBLexer
ActiproSoftware.Text.Lexing.ImplementationDynamicLexer


MergableLexerBase Constructor

MergableLexerBase Constructor
Initializes a new instance of the MergableLexerBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MergableLexerBase()
Protected Sub New
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Properties

MergableLexerBase Properties

The MergableLexerBase type exposes the following members.

Properties
 | Name | Description
Protected property | DefaultLexicalStateCore | Gets or sets the root ILexicalState for when the language is entered.
Protected property | KeyCore | Gets or sets a string that identifies the lexer, generally the related language name.
Protected property | LexicalStateIdProviderCore | Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
Protected property | TokenIdProviderCore | Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
Top
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.DefaultLexicalStateCore Property

MergableLexerBaseDefaultLexicalStateCore Property
Gets or sets the root ILexicalState for when the language is entered.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexicalState DefaultLexicalStateCore { get; set; }
Protected Property DefaultLexicalStateCore As ILexicalState
    Get
    Set

Property Value

Type: ILexicalState
The root ILexicalState for when the language is entered.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.KeyCore Property

MergableLexerBaseKeyCore Property
Gets or sets a string that identifies the lexer, generally the related language name.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected string KeyCore { get; set; }
Protected Property KeyCore As String
    Get
    Set

Property Value

Type: String
A string that identifies the lexer, generally the related language name.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.LexicalStateIdProviderCore Property

MergableLexerBaseLexicalStateIdProviderCore Property
Gets or sets the ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ILexicalStateIdProvider LexicalStateIdProviderCore { get; set; }
Protected Property LexicalStateIdProviderCore As ILexicalStateIdProvider
    Get
    Set

Property Value

Type: ILexicalStateIdProvider
The ILexicalStateIdProvider that provides access to all the lexical state IDs and keys used by this lexer.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.TokenIdProviderCore Property

MergableLexerBaseTokenIdProviderCore Property
Gets or sets the ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ITokenIdProvider TokenIdProviderCore { get; set; }
Protected Property TokenIdProviderCore As ITokenIdProvider
    Get
    Set

Property Value

Type: ITokenIdProvider
The ITokenIdProvider that provides access to all the token IDs and keys used by this lexer.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Methods

MergableLexerBase Methods

The MergableLexerBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateChangeBatch | Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.
Public method | CreateDocumentEndToken | Creates an IMergableToken that represents the end of a document.
Public method | CreateToken | Creates an IMergableToken that represents the range of text with the specified lexer data.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAllLexicalStateTransitions | Returns a collection containing all ILexicalStateTransition objects within the lexer.
Public method | GetDefaultToken | Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIncrementalParseRange | Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested.
Public method | GetNextToken | Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.CreateChangeBatch Method

MergableLexerBaseCreateChangeBatch Method
Creates an IDisposable object such that while the object is not disposed, the lexer can be modified without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDisposable CreateChangeBatch()
Public Function CreateChangeBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.

Implements

IMergableLexerCreateChangeBatch
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.CreateDocumentEndToken Method

MergableLexerBaseCreateDocumentEndToken Method
Creates an IMergableToken that represents the end of a document.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IMergableToken CreateDocumentEndToken(
    int startOffset,
    TextPosition startPosition,
    ILexicalState lexicalState
)
Public Overridable Function CreateDocumentEndToken (
    startOffset As Integer,
    startPosition As TextPosition,
    lexicalState As ILexicalState
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the IToken.
startPosition
Type: ActiproSoftware.TextTextPosition
The start TextPosition of the IToken.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the end of a document.

Implements

IMergableLexerCreateDocumentEndToken(Int32, TextPosition, ILexicalState)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.CreateToken Method

MergableLexerBaseCreateToken Method
Creates an IMergableToken that represents the range of text with the specified lexer data.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IMergableToken CreateToken(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition,
    MergableLexerFlags lexerFlags,
    ILexicalState lexicalState,
    IMergableTokenLexerData lexerData
)
Public Overridable Function CreateToken (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition,
    lexerFlags As MergableLexerFlags,
    lexicalState As ILexicalState,
    lexerData As IMergableTokenLexerData
) As IMergableToken

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
lexerFlags
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags for the token.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData that contains lexer information about the token.

Return Value

Type: IMergableToken
An IMergableToken that represents the range of text with the specified lexer data.

Implements

IMergableLexerCreateToken(Int32, Int32, TextPosition, TextPosition, MergableLexerFlags, ILexicalState, IMergableTokenLexerData)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetAllLexicalStateTransitions Method

MergableLexerBaseGetAllLexicalStateTransitions Method
Returns a collection containing all ILexicalStateTransition objects within the lexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IEnumerable<ILexicalStateTransition> GetAllLexicalStateTransitions()
Public MustOverride Function GetAllLexicalStateTransitions As IEnumerable(Of ILexicalStateTransition)

Return Value

Type: IEnumerable ILexicalStateTransition
A collection containing all ILexicalStateTransition objects within the lexer.

Implements

IMergableLexerGetAllLexicalStateTransitions
Remarks
This method allows consumers to see which language transitions can be made within the lexer.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetDefaultToken Method

MergableLexerBaseGetDefaultToken Method
Returns a single-character MergableLexerResult representing the lexer result for the default token in the ILexicalState and seeks forward one position in the ITextBufferReader

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual MergableLexerResult GetDefaultToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public Overridable Function GetDefaultToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetDefaultToken(ITextBufferReader, ILexicalState)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetIncrementalParseRange Method

MergableLexerBaseGetIncrementalParseRange Method
Returns a TextSnapshotRange that indicates the minimum range to parse when incremental parsing for the specified TextSnapshotRange is requested.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TextSnapshotRange GetIncrementalParseRange(
    TextSnapshotRange snapshotRange
)
Protected Overridable Function GetIncrementalParseRange (
    snapshotRange As TextSnapshotRange
) As TextSnapshotRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The requested TextSnapshotRange to incrementally parse.

Return Value

Type: TextSnapshotRange
The actual TextSnapshotRange to incrementally parse.
Remarks
When performing incremental parsing, a larger snapshot range than the actual modified snapshot range should usually be parsed. For instance, if the end user types text at the end of a word that should make the word a keyword, incremental parsing should start at least at the start of the word or else it won't be recognized as a keyword.

The default implementation of this method starts incremental parsing at the start of the line at which the requested snapshot range begins.

This method is called by the default Parse(TextSnapshotRange, ILexerTarget) implementation to modify the snapshot range to parse.

See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.GetNextToken Method

MergableLexerBaseGetNextToken Method
Performs a lex to return the next MergableLexerResult from a ITextBufferReader and seeks past it if there is a match.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract MergableLexerResult GetNextToken(
    ITextBufferReader reader,
    ILexicalState lexicalState
)
Public MustOverride Function GetNextToken (
    reader As ITextBufferReader,
    lexicalState As ILexicalState
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that specifies the current state.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

IMergableLexerGetNextToken(ITextBufferReader, ILexicalState)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.OnChanged Method

MergableLexerBaseOnChanged Method
Raises the Changed event.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs that contains the event data.
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.Parse Method

MergableLexerBaseParse Method
Lexically parses the specified TextRange of the ITextSnapshot.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TextRange Parse(
    TextSnapshotRange snapshotRange,
    ILexerTarget parseTarget
)
Public Overridable Function Parse (
    snapshotRange As TextSnapshotRange,
    parseTarget As ILexerTarget
) As TextRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range to parse.
parseTarget
Type: ActiproSoftware.Text.LexingILexerTarget
The ILexerTarget that receives the parsing output.

Return Value

Type: TextRange
A TextRange containing the offset range that was modified.

Implements

ILexerParse(TextSnapshotRange, ILexerTarget)
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase Events

MergableLexerBase Events

The MergableLexerBase type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.
Top
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerBase.Changed Event

MergableLexerBaseChanged Event
Occurs after the lexer is changed via a block of code surrounded by CreateChangeBatch.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler

Implements

IMergableLexerChanged
See Also

Reference

MergableLexerBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator Class

MergableLexerCoordinator Class
Coordinates lexer and state shifting for one or more mergable lexers.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationMergableLexerCoordinator

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MergableLexerCoordinator
Public Class MergableLexerCoordinator

The MergableLexerCoordinator type exposes the following members.

Methods
 | Name | Description
 | Create | Creates an instance of a coordinator for the specified ITextBufferReader and IMergableLexer.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNextToken | Returns the next IMergableToken.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Public method | Pop | Pops the top coordinator state from the stack and restores the coordinator to that state.
Public method | Push | Pushes the coordinator state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Public method | ToString | (Inherited from Object.)
Top
Remarks
Features include: Forward-only reading in the ITextBufferReader.Retrieve one token at a time from a starting offset.Possible look-ahead token gathering and caching.Parse through a certain snapshot range and output to an ILexerTarget.
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator Methods

MergableLexerCoordinator Methods

The MergableLexerCoordinator type exposes the following members.

Methods
 | Name | Description
 | Create | Creates an instance of a coordinator for the specified ITextBufferReader and IMergableLexer.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNextToken | Returns the next IMergableToken.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
 | Parse | Lexically parses the specified TextRange of the ITextSnapshot.
Public method | Pop | Pops the top coordinator state from the stack and restores the coordinator to that state.
Public method | Push | Pushes the coordinator state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Create Method

MergableLexerCoordinatorCreate Method
Creates an instance of a coordinator for the specified ITextBufferReader and IMergableLexer.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static MergableLexerCoordinator Create(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Shared Function Create (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
) As MergableLexerCoordinator

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.

Return Value

Type: MergableLexerCoordinator
The MergableLexerCoordinator that was created.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.GetNextToken Method

MergableLexerCoordinatorGetNextToken Method
Returns the next IMergableToken.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMergableToken GetNextToken()
Public Function GetNextToken As IMergableToken

Return Value

Type: IMergableToken
The next IMergableToken.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Parse Method

MergableLexerCoordinatorParse Method
Lexically parses the specified TextRange of the ITextSnapshot.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextRange Parse(
    TextSnapshotRange snapshotRange,
    ILexerTarget lexerTarget
)
Public Shared Function Parse (
    snapshotRange As TextSnapshotRange,
    lexerTarget As ILexerTarget
) As TextRange

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
A TextSnapshotRange indicating the offset range to parse.
lexerTarget
Type: ActiproSoftware.Text.LexingILexerTarget
The ILexerTarget to update.

Return Value

Type: TextRange
A TextRange that was parsed.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Pop Method

MergableLexerCoordinatorPop Method
Pops the top coordinator state from the stack and restores the coordinator to that state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Pop()
Public Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableLexerCoordinator.Push Method

MergableLexerCoordinatorPush Method
Pushes the coordinator state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Push()
Public Sub Push
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

MergableLexerCoordinator Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Class

MergableToken Class
Represents the default implementation of an IToken that can be used with an IMergableLexer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenBase
ActiproSoftware.Text.Lexing.ImplementationMergableToken

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MergableToken : TokenBase,
    IMergableToken, IToken
Public Class MergableToken
    Inherits TokenBase
    Implements IMergableToken, IToken

The MergableToken type exposes the following members.

Constructors
 | Name | Description
Public method | MergableToken | Initializes a new instance of the MergableToken class.
Top
Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from TokenBase.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from TokenBase.)
Public property | Id | Gets the ID assigned to the token. (Overrides TokenBaseId.)
Public property | Key | Gets the key assigned to the token. (Overrides TokenBaseKey.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from TokenBase.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Protected property | LexerData | Gets an IMergableTokenLexerData that contains lexer information for the token.
Protected property | LexerFlags | Gets a MergableLexerFlags indicating lexer flags for the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state. (Overrides TokenBaseLexicalStateId.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from TokenBase.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from TokenBase.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from TokenBase.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from TokenBase.)
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from TokenBase.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from TokenBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from TokenBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Inherited from TokenBase.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Public method | ToString | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Public method | ToString(String) | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Constructor

MergableToken Constructor
Initializes a new instance of the MergableToken class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MergableToken(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition,
    MergableLexerFlags lexerFlags,
    ILexicalState lexicalState,
    IMergableTokenLexerData lexerData
)
Public Sub New (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition,
    lexerFlags As MergableLexerFlags,
    lexicalState As ILexicalState,
    lexerData As IMergableTokenLexerData
)

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
lexerFlags
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags for the token.
lexicalState
Type: ActiproSoftware.Text.LexingILexicalState
The ILexicalState that contains the token.
lexerData
Type: ActiproSoftware.Text.LexingIMergableTokenLexerData
The IMergableTokenLexerData that contains the lexer information about the token.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Properties

MergableToken Properties

The MergableToken type exposes the following members.

Properties
 | Name | Description
Public property | AutoCaseCorrectText | Gets the text that should be used for this IToken when performing an auto case correction operation on it.
Public property | ClassificationType | Gets the IClassificationType assigned to the token.
Public property | DeclaringLexicalState | Gets the ILexicalState that declares the pattern that matched the token.
Public property | EndOffset | Gets the offset after the last character in the token. (Inherited from TokenBase.)
Public property | EndPosition | Gets the TextPosition after the last character in the token. (Inherited from TokenBase.)
Public property | Id | Gets the ID assigned to the token. (Overrides TokenBaseId.)
Public property | Key | Gets the key assigned to the token. (Overrides TokenBaseKey.)
Public property | Length | Gets or sets the absolute length of the token. (Inherited from TokenBase.)
Public property | Lexer | Gets the IMergableLexer that created the token.
Protected property | LexerData | Gets an IMergableTokenLexerData that contains lexer information for the token.
Protected property | LexerFlags | Gets a MergableLexerFlags indicating lexer flags for the token.
Public property | LexicalScope | Gets the ILexicalScope, if any, that defines the token.
Public property | LexicalState | Gets the ILexicalState that contains the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state. (Overrides TokenBaseLexicalStateId.)
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token. (Inherited from TokenBase.)
Public property | StartOffset | Gets or sets the offset of the first character in the token. (Inherited from TokenBase.)
Public property | StartPosition | Gets the TextPosition of the first character in the token. (Inherited from TokenBase.)
Public property | TextRange | Gets a TextRange that specifies the text range of the token. (Inherited from TokenBase.)
Top
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.AutoCaseCorrectText Property

MergableTokenAutoCaseCorrectText Property
Gets the text that should be used for this IToken when performing an auto case correction operation on it.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string AutoCaseCorrectText { get; }
Public Overridable ReadOnly Property AutoCaseCorrectText As String
    Get

Property Value

Type: String
The text that should be used for this IToken when performing an auto case correction operation on it.

Implements

IMergableTokenAutoCaseCorrectText
Remarks
Return a value to indicate that there is no auto case correction text available.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.ClassificationType Property

MergableTokenClassificationType Property
Gets the IClassificationType assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IClassificationType ClassificationType { get; }
Public Overridable ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType assigned to the token.

Implements

IMergableTokenClassificationType
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.DeclaringLexicalState Property

MergableTokenDeclaringLexicalState Property
Gets the ILexicalState that declares the pattern that matched the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual ILexicalState DeclaringLexicalState { get; }
Public Overridable ReadOnly Property DeclaringLexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that declares the pattern that matched the token.

Implements

IMergableTokenDeclaringLexicalState
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.Id Property

MergableTokenId Property
Gets the ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int Id { get; }
Public Overrides ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID assigned to the token.

Implements

ITokenId
ITokenId
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.Key Property

MergableTokenKey Property
Gets the key assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string Key { get; }
Public Overrides ReadOnly Property Key As String
    Get

Property Value

Type: String
The key assigned to the token.

Implements

ITokenKey
ITokenKey
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.Lexer Property

MergableTokenLexer Property
Gets the IMergableLexer that created the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMergableLexer Lexer { get; }
Public ReadOnly Property Lexer As IMergableLexer
    Get

Property Value

Type: IMergableLexer
The IMergableLexer that created the token.

Implements

IMergableTokenLexer
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexerData Property

MergableTokenLexerData Property
Gets an IMergableTokenLexerData that contains lexer information for the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IMergableTokenLexerData LexerData { get; }
Protected ReadOnly Property LexerData As IMergableTokenLexerData
    Get

Property Value

Type: IMergableTokenLexerData
An IMergableTokenLexerData that contains lexer information for the token.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexerFlags Property

MergableTokenLexerFlags Property
Gets a MergableLexerFlags indicating lexer flags for the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MergableLexerFlags LexerFlags { get; }
Protected ReadOnly Property LexerFlags As MergableLexerFlags
    Get

Property Value

Type: MergableLexerFlags
A MergableLexerFlags indicating lexer flags for the token.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexicalScope Property

MergableTokenLexicalScope Property
Gets the ILexicalScope, if any, that defines the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual ILexicalScope LexicalScope { get; }
Public Overridable ReadOnly Property LexicalScope As ILexicalScope
    Get

Property Value

Type: ILexicalScope
The ILexicalScope, if any, that defines the token.

Implements

IMergableTokenLexicalScope
Remarks
If this value is , the token was not defined by a lexical scope.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexicalState Property

MergableTokenLexicalState Property
Gets the ILexicalState that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual ILexicalState LexicalState { get; }
Public Overridable ReadOnly Property LexicalState As ILexicalState
    Get

Property Value

Type: ILexicalState
The ILexicalState that contains the token.

Implements

IMergableTokenLexicalState
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.LexicalStateId Property

MergableTokenLexicalStateId Property
Gets the ID assigned to the lexical state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int LexicalStateId { get; }
Public Overrides ReadOnly Property LexicalStateId As Integer
    Get

Property Value

Type: Int32
The ID assigned to the lexical state.

Implements

ITokenLexicalStateId
ITokenLexicalStateId
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken Methods

MergableToken Methods

The MergableToken type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset. (Inherited from TokenBase.)
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition. (Inherited from TokenBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from TokenBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Inherited from TokenBase.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | Returns whether the parse data has the specified MergableLexerFlags flag.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetFlag | Sets or clears the specified MergableLexerFlags flag.
Public method | ToString | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Public method | ToString(String) | Creates and returns a string representation of the current object. (Inherited from TokenBase.)
Top
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.HasFlag Method

MergableTokenHasFlag Method
Returns whether the parse data has the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool HasFlag(
    MergableLexerFlags flag
)
Public Overridable Function HasFlag (
    flag As MergableLexerFlags
) As Boolean

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to check for.

Return Value

Type: Boolean
true if the parse data has the specified MergableLexerFlags flag; otherwise, false.

Implements

IMergableTokenHasFlag(MergableLexerFlags)
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


MergableToken.SetFlag Method

MergableTokenSetFlag Method
Sets or clears the specified MergableLexerFlags flag.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void SetFlag(
    MergableLexerFlags flag,
    bool setBit
)
Public Overridable Sub SetFlag (
    flag As MergableLexerFlags,
    setBit As Boolean
)

Parameters

flag
Type: ActiproSoftware.Text.LexingMergableLexerFlags
The MergableLexerFlags to set or clear.
setBit
Type: SystemBoolean
Whether to set the flag; otherwise, the flag is cleared.

Implements

IMergableTokenSetFlag(MergableLexerFlags, Boolean)
Remarks
This method should only be called by lexers.
See Also

Reference

MergableToken Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Class

ProgrammaticLexicalScope Class
Provides a lexical scope implementation that uses two delegates to perform the IsScopeStart(ITextBufferReader) and IsScopeEnd(ITextBufferReader) checks.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeBase
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScope

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ProgrammaticLexicalScope : LexicalScopeBase
Public Class ProgrammaticLexicalScope
    Inherits LexicalScopeBase

The ProgrammaticLexicalScope type exposes the following members.

Constructors
 | Name | Description
Public method | ProgrammaticLexicalScope | Initializes a new instance of the ProgrammaticLexicalScope class.
Top
Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Constructor

ProgrammaticLexicalScope Constructor
Initializes a new instance of the ProgrammaticLexicalScope class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ProgrammaticLexicalScope(
    ProgrammaticLexicalScopeMatch isScopeStartDelegate,
    ProgrammaticLexicalScopeMatch isScopeEndDelegate
)
Public Sub New (
    isScopeStartDelegate As ProgrammaticLexicalScopeMatch,
    isScopeEndDelegate As ProgrammaticLexicalScopeMatch
)

Parameters

isScopeStartDelegate
Type: ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScopeMatch
The ProgrammaticLexicalScopeMatch to use for matching the scope's start.
isScopeEndDelegate
Type: ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScopeMatch
The ProgrammaticLexicalScopeMatch to use for matching the scope's end.
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Properties

ProgrammaticLexicalScope Properties

The ProgrammaticLexicalScope type exposes the following members.

Properties
 | Name | Description
Public property | IsAncestorEndScopeCheckEnabled | Gets or sets whether ancestor end scope checking is enabled while parsing inside the scope. (Inherited from LexicalScopeBase.)
Protected property | LexicalStateCore | Gets or sets the ILexicalState that defines the lexical scope. (Inherited from LexicalScopeBase.)
Protected property | ParentTransitionCore | Gets or sets the ILexicalStateTransition that is the parent of this scope. (Inherited from LexicalScopeBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalScopeBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that this scope performs after ending. (Inherited from LexicalScopeBase.)
Top
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope Methods

ProgrammaticLexicalScope Methods

The ProgrammaticLexicalScope type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IsScopeEnd | Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope. (Overrides LexicalScopeBaseIsScopeEnd(ITextBufferReader).)
Public method | IsScopeStart | Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope. (Overrides LexicalScopeBaseIsScopeStart(ITextBufferReader).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope.IsScopeEnd Method

ProgrammaticLexicalScopeIsScopeEnd Method
Performs a lex to determine if the current text in the ITextBufferReader ends the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeEnd(
    ITextBufferReader reader
)
Public Overrides Function IsScopeEnd (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeEnd(ITextBufferReader)
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScope.IsScopeStart Method

ProgrammaticLexicalScopeIsScopeStart Method
Performs a lex to determine if the current text in the ITextBufferReader starts the lexical scope.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override MergableLexerResult IsScopeStart(
    ITextBufferReader reader
)
Public Overrides Function IsScopeStart (
    reader As ITextBufferReader
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
An ITextBufferReader that is reading a text source.

Return Value

Type: MergableLexerResult
A MergableLexerResult indicating the lexer result.

Implements

ILexicalScopeIsScopeStart(ITextBufferReader)
See Also

Reference

ProgrammaticLexicalScope Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch Class

ProgrammaticLexicalScopeMatch Class
Represents the method that will handle token matching callbacks for ProgrammaticLexicalScope objects.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalScopeMatch

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ProgrammaticLexicalScopeMatch : MulticastDelegate
Public NotInheritable Class ProgrammaticLexicalScopeMatch
    Inherits MulticastDelegate

Return Value

Type:
A MergableLexerResult indicating the lexer result.

The ProgrammaticLexicalScopeMatch type exposes the following members.

Constructors
 | Name | Description
Public method | ProgrammaticLexicalScopeMatch | Initializes a new instance of the ProgrammaticLexicalScopeMatch class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch Constructor

ProgrammaticLexicalScopeMatch Constructor
Initializes a new instance of the ProgrammaticLexicalScopeMatch class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ProgrammaticLexicalScopeMatch(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ProgrammaticLexicalScopeMatch Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch Properties

ProgrammaticLexicalScopeMatch Properties

The ProgrammaticLexicalScopeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

ProgrammaticLexicalScopeMatch Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch Methods

ProgrammaticLexicalScopeMatch Methods

The ProgrammaticLexicalScopeMatch type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ProgrammaticLexicalScopeMatch Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch.BeginInvoke Method

ProgrammaticLexicalScopeMatchBeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.BeginInvoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope,System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    ITextBufferReader reader,
    ILexicalScope lexicalScope,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    reader As ITextBufferReader,
    lexicalScope As ILexicalScope,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader

[Missing <param name="reader"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.BeginInvoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope,System.AsyncCallback,System.Object)"]

lexicalScope
Type: ActiproSoftware.Text.LexingILexicalScope

[Missing <param name="lexicalScope"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.BeginInvoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.BeginInvoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.BeginInvoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.BeginInvoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope,System.AsyncCallback,System.Object)"]

See Also

Reference

ProgrammaticLexicalScopeMatch Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch.EndInvoke Method

ProgrammaticLexicalScopeMatchEndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual MergableLexerResult EndInvoke(
    IAsyncResult result
)
Public Overridable Function EndInvoke (
    result As IAsyncResult
) As MergableLexerResult

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.EndInvoke(System.IAsyncResult)"]

Return Value

Type: MergableLexerResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ProgrammaticLexicalScopeMatch Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalScopeMatch.Invoke Method

ProgrammaticLexicalScopeMatchInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.Invoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope)"]

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual MergableLexerResult Invoke(
    ITextBufferReader reader,
    ILexicalScope lexicalScope
)
Public Overridable Function Invoke (
    reader As ITextBufferReader,
    lexicalScope As ILexicalScope
) As MergableLexerResult

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader

[Missing <param name="reader"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.Invoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope)"]

lexicalScope
Type: ActiproSoftware.Text.LexingILexicalScope

[Missing <param name="lexicalScope"/> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.Invoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope)"]

Return Value

Type: MergableLexerResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Lexing.Implementation.ProgrammaticLexicalScopeMatch.Invoke(ActiproSoftware.Text.ITextBufferReader,ActiproSoftware.Text.Lexing.ILexicalScope)"]

See Also

Reference

ProgrammaticLexicalScopeMatch Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Class

ProgrammaticLexicalState Class
Provides a default implementation for a lexical state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationLexicalStateBase
ActiproSoftware.Text.Lexing.ImplementationProgrammaticLexicalState

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ProgrammaticLexicalState : LexicalStateBase
Public Class ProgrammaticLexicalState
    Inherits LexicalStateBase

The ProgrammaticLexicalState type exposes the following members.

Constructors
 | Name | Description
Public method | ProgrammaticLexicalState | Initializes a new instance of the ProgrammaticLexicalState class.
Top
Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the ILexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Inherited from LexicalStateBase.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Inherited from LexicalStateBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Constructor

ProgrammaticLexicalState Constructor
Initializes a new instance of the ProgrammaticLexicalState class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ProgrammaticLexicalState(
    int id,
    string key
)
Public Sub New (
    id As Integer,
    key As String
)

Parameters

id
Type: SystemInt32
The ID of the lexical state.
key
Type: SystemString
The key of the lexical state.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Properties

ProgrammaticLexicalState Properties

The ProgrammaticLexicalState type exposes the following members.

Properties
 | Name | Description
Public property | ChildLexicalStates | Gets the collection of child lexical states.
Protected property | ChildLexicalStatesCore | Gets the collection of child lexical states. (Inherited from LexicalStateBase.)
Public property | DefaultTokenId | Gets or sets the ID of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | DefaultTokenKey | Gets or sets the key of the default token that this state assigns. (Inherited from LexicalStateBase.)
Public property | Id | Gets or sets the ID value that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Key | Gets a string-based key that identifies the lexical state. (Inherited from LexicalStateBase.)
Public property | Lexer | Gets the ILexer that contains the state.
Protected property | LexerCore | Gets or sets the ILexer that contains the state. (Inherited from LexicalStateBase.)
Public property | LexicalScopes | Gets the collection of lexical scopes.
Protected property | LexicalScopesCore | Gets the collection of lexical scopes. (Inherited from LexicalStateBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from LexicalStateBase.)
Public property | Transition | Gets or sets the ILexicalStateTransition that is performed immediately after a start scope match. (Inherited from LexicalStateBase.)
Top
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState.ChildLexicalStates Property

ProgrammaticLexicalStateChildLexicalStates Property
Gets the collection of child lexical states.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalStateCollection ChildLexicalStates { get; }
Public ReadOnly Property ChildLexicalStates As ILexicalStateCollection
    Get

Property Value

Type: ILexicalStateCollection
A ILexicalStateCollection containing the child lexical states.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState.Lexer Property

ProgrammaticLexicalStateLexer Property
Gets the ILexer that contains the state.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexer Lexer { get; }
Public ReadOnly Property Lexer As ILexer
    Get

Property Value

Type: ILexer
The ILexer that contains the state.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState.LexicalScopes Property

ProgrammaticLexicalStateLexicalScopes Property
Gets the collection of lexical scopes.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILexicalScopeCollection LexicalScopes { get; }
Public ReadOnly Property LexicalScopes As ILexicalScopeCollection
    Get

Property Value

Type: ILexicalScopeCollection
A ILexicalScopeCollection containing the lexical scopes.
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ProgrammaticLexicalState Methods

ProgrammaticLexicalState Methods

The ProgrammaticLexicalState type exposes the following members.

Methods
 | Name | Description
Protected method | CreateChildLexicalStates | Creates the ILexicalStateCollection collection that is returned by ChildLexicalStatesCore. (Inherited from LexicalStateBase.)
Protected method | CreateLexicalScopes | Creates the ILexicalScopeCollection collection that is returned by LexicalScopesCore. (Inherited from LexicalStateBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ProgrammaticLexicalState Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Class

TokenBase Class
Represents the base class for an IToken implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenBase
ActiproSoftware.Text.Lexing.ImplementationMergableToken

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TokenBase : IToken
Public MustInherit Class TokenBase
    Implements IToken

The TokenBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TokenBase | Initializes a new instance of the TokenBase class.
Top
Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Public method | ToString(String) | Creates and returns a string representation of the current object.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Constructor

TokenBase Constructor
Initializes a new instance of the TokenBase class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TokenBase(
    int startOffset,
    int length,
    TextPosition startPosition,
    TextPosition endPosition
)
Protected Sub New (
    startOffset As Integer,
    length As Integer,
    startPosition As TextPosition,
    endPosition As TextPosition
)

Parameters

startOffset
Type: SystemInt32
The start offset of the token.
length
Type: SystemInt32
The length of the token.
startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition of the first character in the token.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition after the last character in the token.
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Properties

TokenBase Properties

The TokenBase type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the offset after the last character in the token.
Public property | EndPosition | Gets the TextPosition after the last character in the token.
Public property | Id | Gets the ID assigned to the token.
Public property | Key | Gets the key assigned to the token.
Public property | Length | Gets or sets the absolute length of the token.
Public property | LexicalStateId | Gets the ID assigned to the lexical state that contains the token.
Public property | PositionRange | Gets a TextPositionRange that specifies the text position range of the token.
Public property | StartOffset | Gets or sets the offset of the first character in the token.
Public property | StartPosition | Gets the TextPosition of the first character in the token.
Public property | TextRange | Gets a TextRange that specifies the text range of the token.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.EndOffset Property

TokenBaseEndOffset Property
Gets the offset after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int EndOffset { get; }
Public ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset after the last character in the token.

Implements

ITokenEndOffset
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.EndPosition Property

TokenBaseEndPosition Property
Gets the TextPosition after the last character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition EndPosition { get; }
Public ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition after the last character in the token.

Implements

ITokenEndPosition
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Id Property

TokenBaseId Property
Gets the ID assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int Id { get; }
Public MustOverride ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
The ID assigned to the token.

Implements

ITokenId
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Key Property

TokenBaseKey Property
Gets the key assigned to the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Key { get; }
Public Overridable ReadOnly Property Key As String
    Get

Property Value

Type: String
The key assigned to the token.

Implements

ITokenKey
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Length Property

TokenBaseLength Property
Gets or sets the absolute length of the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set

Property Value

Type: Int32
The absolute length of the token.

Implements

ITokenLength
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.LexicalStateId Property

TokenBaseLexicalStateId Property
Gets the ID assigned to the lexical state that contains the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int LexicalStateId { get; }
Public Overridable ReadOnly Property LexicalStateId As Integer
    Get

Property Value

Type: Int32
The ID assigned to the lexical state that contains the token.

Implements

ITokenLexicalStateId
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.PositionRange Property

TokenBasePositionRange Property
Gets a TextPositionRange that specifies the text position range of the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; }
Public ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
A TextPositionRange that specifies the text position range of the token.

Implements

ITokenPositionRange
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.StartOffset Property

TokenBaseStartOffset Property
Gets or sets the offset of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int StartOffset { get; set; }
Public Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The offset of the first character in the token.

Implements

ITokenStartOffset
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.StartPosition Property

TokenBaseStartPosition Property
Gets the TextPosition of the first character in the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition StartPosition { get; }
Public ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the first character in the token.

Implements

ITokenStartPosition
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.TextRange Property

TokenBaseTextRange Property
Gets a TextRange that specifies the text range of the token.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; }
Public ReadOnly Property TextRange As TextRange
    Get

Property Value

Type: TextRange
A TextRange that specifies the text range of the token.

Implements

ITokenTextRange
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase Methods

TokenBase Methods

The TokenBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Public method | ToString(String) | Creates and returns a string representation of the current object.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Contains Method

TokenBaseContains Method
Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the IToken contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the IToken contains the specified TextPosition.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Contains Method (Int32)

TokenBaseContains Method (Int32)
Returns whether the IToken contains the specified offset.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the IToken contains the specified offset; otherwise, false.

Implements

ITokenContains(Int32)
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the IToken.
See Also

Reference

TokenBase Class
Contains Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Contains Method (TextPosition)

TokenBaseContains Method (TextPosition)
Returns whether the IToken contains the specified TextPosition.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TextPosition position
)
Public Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the IToken contains the specified TextPosition; otherwise, false.

Implements

ITokenContains(TextPosition)
Remarks
This method returns false if the position falls on the EndPosition position since this method indicates if the position is encompassed by the IToken.
See Also

Reference

TokenBase Class
Contains Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.Equals Method

TokenBaseEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.GetHashCode Method

TokenBaseGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.ToString Method

TokenBaseToString Method
Overload List
 | Name | Description
Public method | ToString | Creates and returns a string representation of the current object. (Overrides ObjectToString.)
Public method | ToString(String) | Creates and returns a string representation of the current object.
Top
See Also

Reference

TokenBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.ToString Method

TokenBaseToString Method
Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representation of the current object.
See Also

Reference

TokenBase Class
ToString Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenBase.ToString Method (String)

TokenBaseToString Method (String)
Creates and returns a string representation of the current object.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToString(
    string tokenDescription
)
Public Function ToString (
    tokenDescription As String
) As String

Parameters

tokenDescription
Type: SystemString
The description of the IToken.

Return Value

Type: String
A string representation of the current object.
See Also

Reference

TokenBase Class
ToString Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Class

TokenIdProviderBase Class
Represents an abstract base class for an object that provides static IDs for the tokens of an ISyntaxLanguage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenIdProviderBase
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenId
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenId
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenId
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenId
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenId

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TokenIdProviderBase : ITokenIdProvider,
    IIdProvider
Public MustInherit Class TokenIdProviderBase
    Implements ITokenIdProvider, IIdProvider

The TokenIdProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TokenIdProviderBase | Initializes a new instance of the TokenIdProviderBase class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified ID.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
DocumentEnd | Gets the DocumentEnd token ID, which is common among all languages.
Invalid | Gets the Invalid token ID, which is common among all languages.
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Constructor

TokenIdProviderBase Constructor
Initializes a new instance of the TokenIdProviderBase class

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TokenIdProviderBase()
Protected Sub New
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Properties

TokenIdProviderBase Properties

The TokenIdProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.MaxId Property

TokenIdProviderBaseMaxId Property
Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int MaxId { get; }
Public MustOverride ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.MinId Property

TokenIdProviderBaseMinId Property
Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int MinId { get; }
Public MustOverride ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Methods

TokenIdProviderBase Methods

The TokenIdProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified ID.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.ContainsId Method

TokenIdProviderBaseContainsId Method
Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract bool ContainsId(
    int id
)
Public MustOverride Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.GetDescription Method

TokenIdProviderBaseGetDescription Method
Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string GetDescription(
    int id
)
Public MustOverride Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.GetKey Method

TokenIdProviderBaseGetKey Method
Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string GetKey(
    int id
)
Public MustOverride Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase Fields

TokenIdProviderBase Fields

The TokenIdProviderBase type exposes the following members.

Fields
Name | Description
DocumentEnd | Gets the DocumentEnd token ID, which is common among all languages.
Invalid | Gets the Invalid token ID, which is common among all languages.
Top
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.DocumentEnd Field

TokenIdProviderBaseDocumentEnd Field
Gets the DocumentEnd token ID, which is common among all languages.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int DocumentEnd = -1
Public Const DocumentEnd As Integer = -1

Field Value

Type: Int32
The DocumentEnd token ID.
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenIdProviderBase.Invalid Field

TokenIdProviderBaseInvalid Field
Gets the Invalid token ID, which is common among all languages.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int Invalid = -2
Public Const Invalid As Integer = -2

Field Value

Type: Int32
The Invalid token ID.
See Also

Reference

TokenIdProviderBase Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Class

TokenSet Class
Stores token data for a range of text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Lexing.ImplementationTokenSet

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TokenSet : ITokenSet, IEnumerable<IToken>,
    IEnumerable, ITextRangeProvider
Public Class TokenSet
    Implements ITokenSet, IEnumerable(Of IToken),
    IEnumerable, ITextRangeProvider

The TokenSet type exposes the following members.

Constructors
 | Name | Description
Public method | TokenSet(TextRange, IEnumerableIToken, Object) | Initializes a new instance of the TokenSet class.
Public method | TokenSet(TextRange, IEnumerableTagSnapshotRangeITokenTag, Object) | Initializes a new instance of the TokenSet class.
Top
Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets the TextRange for which tokens in this set are available.
Public property | Tokens | Gets an IToken in the token set.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Constructor

TokenSet Constructor
Overload List
 | Name | Description
Public method | TokenSet(TextRange, IEnumerableIToken, Object) | Initializes a new instance of the TokenSet class.
Public method | TokenSet(TextRange, IEnumerableTagSnapshotRangeITokenTag, Object) | Initializes a new instance of the TokenSet class.
Top
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Constructor (TextRange, IEnumerable(IToken), Object)

TokenSet Constructor (TextRange, IEnumerableIToken, Object)
Initializes a new instance of the TokenSet class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TokenSet(
    TextRange textRange,
    IEnumerable<IToken> tokens,
    Object parseContext
)
Public Sub New (
    textRange As TextRange,
    tokens As IEnumerable(Of IToken),
    parseContext As Object
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange for which tokens in this set are available.
tokens
Type: System.Collections.GenericIEnumerable IToken
The enumerable collection of tokens to add to the set.
parseContext
Type: SystemObject
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
See Also

Reference

TokenSet Class
TokenSet Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Constructor (TextRange, IEnumerable(TagSnapshotRange(ITokenTag)), Object)

TokenSet Constructor (TextRange, IEnumerableTagSnapshotRangeITokenTag, Object)
Initializes a new instance of the TokenSet class.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TokenSet(
    TextRange textRange,
    IEnumerable<TagSnapshotRange<ITokenTag>> tagRanges,
    Object parseContext
)
Public Sub New (
    textRange As TextRange,
    tagRanges As IEnumerable(Of TagSnapshotRange(Of ITokenTag)),
    parseContext As Object
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange for which tokens in this set are available.
tagRanges
Type: System.Collections.GenericIEnumerable TagSnapshotRange ITokenTag
The enumerable collection of token tag ranges to add to the set.
parseContext
Type: SystemObject
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
See Also

Reference

TokenSet Class
TokenSet Overload
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Properties

TokenSet Properties

The TokenSet type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of tokens that are stored in the token set.
Public property | FirstToken | Gets the first IToken in the set.
Public property | FirstTokenExtendsBack | Gets whether the FirstToken extends back to another token set.
Public property | LastToken | Gets the last IToken in the set.
Public property | LastTokenExtendsForward | Gets whether the LastToken extends forward to another token set.
Public property | ParseContext | Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.
Public property | TextRange | Gets the TextRange for which tokens in this set are available.
Public property | Tokens | Gets an IToken in the token set.
Top
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.Count Property

TokenSetCount Property
Gets the count of tokens that are stored in the token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of tokens that are stored in the token set.

Implements

ITokenSetCount
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.FirstToken Property

TokenSetFirstToken Property
Gets the first IToken in the set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken FirstToken { get; }
Public ReadOnly Property FirstToken As IToken
    Get

Property Value

Type: IToken
The first IToken in the set.

Implements

ITokenSetFirstToken
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.FirstTokenExtendsBack Property

TokenSetFirstTokenExtendsBack Property
Gets whether the FirstToken extends back to another token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool FirstTokenExtendsBack { get; }
Public ReadOnly Property FirstTokenExtendsBack As Boolean
    Get

Property Value

Type: Boolean
true if the FirstToken extends back to another token set; otherwise, false.

Implements

ITokenSetFirstTokenExtendsBack
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.LastToken Property

TokenSetLastToken Property
Gets the last IToken in the set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken LastToken { get; }
Public ReadOnly Property LastToken As IToken
    Get

Property Value

Type: IToken
The last IToken in the set.

Implements

ITokenSetLastToken
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.LastTokenExtendsForward Property

TokenSetLastTokenExtendsForward Property
Gets whether the LastToken extends forward to another token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool LastTokenExtendsForward { get; }
Public ReadOnly Property LastTokenExtendsForward As Boolean
    Get

Property Value

Type: Boolean
true if the LastToken extends forward to another token set; otherwise, false.

Implements

ITokenSetLastTokenExtendsForward
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.ParseContext Property

TokenSetParseContext Property
Gets an optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ParseContext { get; }
Public ReadOnly Property ParseContext As Object
    Get

Property Value

Type: Object
An optional object that may be used to help provide context information when resuming incremental parsing near the end of this token set.

Implements

ITokenSetParseContext
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.TextRange Property

TokenSetTextRange Property
Gets the TextRange for which tokens in this set are available.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextRange TextRange { get; set; }
Public Property TextRange As TextRange
    Get
    Set

Property Value

Type: TextRange
The TextRange for which tokens in this set are available.

Implements

ITextRangeProviderTextRange
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.Tokens Property

TokenSetTokens Property
Gets an IToken in the token set.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken this[
    int index
] { get; }
Public ReadOnly Property Tokens (
    index As Integer
) As IToken
    Get

Parameters

index
Type: SystemInt32
The index of the IToken to return.

Property Value

Type: IToken
An IToken in the token set.

Implements

ITokenSetTokensInt32
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet Methods

TokenSet Methods

The TokenSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the IToken in the set that contains the specified offset, if any.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.GetEnumerator Method

TokenSetGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<IToken> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IToken)

Return Value

Type: IEnumerator IToken
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


TokenSet.IndexOf Method

TokenSetIndexOf Method
Returns the index of the IToken in the set that contains the specified offset, if any.

Namespace: ActiproSoftware.Text.Lexing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    int offset,
    int hintIndex
)
Public Function IndexOf (
    offset As Integer,
    hintIndex As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset for which to search.
hintIndex
Type: SystemInt32
The hint index at which to begin searching; otherwise, -1.

Return Value

Type: Int32
The index of the IToken in the set that contains the specified offset; otherwise, -1.

Implements

ITokenSetIndexOf(Int32, Int32)
See Also

Reference

TokenSet Class
ActiproSoftware.Text.Lexing.Implementation Namespace


ActiproSoftware.Text.Parsing Namespace

ActiproSoftware.Text.Parsing Namespace
Contains types related to parsing.
Classes
 | Class | Description
Public class | AmbientParseRequestDispatcherProvider | Implements a class that can be used to provide a static IParseRequestDispatcher that is used for parsing operations by default.
Public class | ParseDataPropertyChangedEventArgs | Provides event arguments for a property change event, indicating the old and new values.
Public class | ParseErrorLevel | Specifies the error level of an IParseError.
Public class | ParseRequestState | Specifies the current state of an IParseRequest.
Public class | SyntaxLanguageParsingExtensions | Contains parsing-related extension methods that make it easier to work with ISyntaxLanguage objects.
Interfaces
 | Interface | Description
Public interface | IAstNode | Provides the base requirements for an AST (abstract syntax tree) node.
Public interface | IAstNodeIdProvider | Provides the base requirements for a class that provides AST node ID's.
Public interface | IParseData | Provides the base requirements for a class that represents the result of a parsing operation.
Public interface | IParseError | Provides the base requirements for an object that indicates a message, warning or error related to parsing.
Public interface | IParseErrorProvider | Provides the base requirements for an object that returns a list of IParseError objects, and is generally implemented by IParseData instances if they support error reporting.
Public interface | IParser | Provides the base requirements of a parser (syntax/semantic analyzer) for a language.
Public interface | IParseRequest | Provides the base requirements of a parsing operation request.
Public interface | IParseRequestDispatcher | Provides the base requirements for a class that can queue up IParseRequest objects, prioritize and execute them on one or more worker threads, and notify an IParseTarget of the result.
Public interface | IParseTarget | Provides the base requirements for a class that can be notified with the results of a parsing operation.


AmbientParseRequestDispatcherProvider Class

AmbientParseRequestDispatcherProvider Class
Implements a class that can be used to provide a static IParseRequestDispatcher that is used for parsing operations by default.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ParsingAmbientParseRequestDispatcherProvider

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class AmbientParseRequestDispatcherProvider
Public NotInheritable Class AmbientParseRequestDispatcherProvider

The AmbientParseRequestDispatcherProvider type exposes the following members.

Properties
Name | Description
Dispatcher | Gets or sets the default IParseRequestDispatcher to use when a parsing operation request is made.
Top
Remarks
Set the Dispatcher property to an IParseRequestDispatcher instance to register the default dispatcher.
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


AmbientParseRequestDispatcherProvider Properties

AmbientParseRequestDispatcherProvider Properties

The AmbientParseRequestDispatcherProvider type exposes the following members.

Properties
Name | Description
Dispatcher | Gets or sets the default IParseRequestDispatcher to use when a parsing operation request is made.
Top
See Also

Reference

AmbientParseRequestDispatcherProvider Class
ActiproSoftware.Text.Parsing Namespace


AmbientParseRequestDispatcherProvider.Dispatcher Property

AmbientParseRequestDispatcherProviderDispatcher Property
Gets or sets the default IParseRequestDispatcher to use when a parsing operation request is made.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParseRequestDispatcher Dispatcher { get; set; }
Public Shared Property Dispatcher As IParseRequestDispatcher
    Get
    Set

Property Value

Type: IParseRequestDispatcher
The default IParseRequestDispatcher to use when a parsing operation request is made.
See Also

Reference

AmbientParseRequestDispatcherProvider Class
ActiproSoftware.Text.Parsing Namespace


IAstNode Interface

IAstNode Interface
Provides the base requirements for an AST (abstract syntax tree) node.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAstNode
Public Interface IAstNode

The IAstNode type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IAstNode Properties

IAstNode Properties

The IAstNode type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Children Property

IAstNodeChildren Property
Gets the list containing the child AST nodes of this AST node.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IAstNode> Children { get; }
ReadOnly Property Children As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The list containing the child AST nodes of this AST node.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.EndOffset Property

IAstNodeEndOffset Property
Gets or sets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> EndOffset { get; set; }
Property EndOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.HasChildren Property

IAstNodeHasChildren Property
Gets whether the AST node contains any child AST nodes.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasChildren { get; }
ReadOnly Property HasChildren As Boolean
    Get

Property Value

Type: Boolean
true if the AST node contains any child AST nodes; otherwise, false.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Id Property

IAstNodeId Property
Gets an integer value that identifies the type of AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Id { get; }
ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
An integer value that identifies the type of AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Length Property

IAstNodeLength Property
Gets the character length of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The character length of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Parent Property

IAstNodeParent Property
Gets or sets the parent IAstNode of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode Parent { get; set; }
Property Parent As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The parent IAstNode of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.StartOffset Property

IAstNodeStartOffset Property
Gets or sets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> StartOffset { get; set; }
Property StartOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Value Property

IAstNodeValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode Methods

IAstNode Methods

The IAstNode type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.Contains Method

IAstNodeContains Method
Returns whether the AST node contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the AST node contains the specified offset; otherwise, false.
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the AST node. This method also returns false if the AST node doesn't have known offsets.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.FindChildNode Method

IAstNodeFindChildNode Method
Searches through the child nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode FindChildNode(
    int offset
)
Function FindChildNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that contains the specified offset, if any.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.FindDescendantNode Method

IAstNodeFindDescendantNode Method
Recursively searches through the descendant nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode FindDescendantNode(
    int offset
)
Function FindDescendantNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that contains the specified offset, if any.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNode.ToTreeString Method

IAstNodeToTreeString Method
Outputs the contents of the AST node in tree form.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ToTreeString(
    int indentLevel
)
Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the AST node.
See Also

Reference

IAstNode Interface
ActiproSoftware.Text.Parsing Namespace


IAstNodeIdProvider Interface

IAstNodeIdProvider Interface
Provides the base requirements for a class that provides AST node ID's.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAstNodeIdProvider : IIdProvider
Public Interface IAstNodeIdProvider
    Inherits IIdProvider

The IAstNodeIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IAstNodeIdProvider Properties

IAstNodeIdProvider Properties

The IAstNodeIdProvider type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider. (Inherited from IIdProvider.)
Public property | MinId | Gets the minimum ID returned by this provider. (Inherited from IIdProvider.)
Top
See Also

Reference

IAstNodeIdProvider Interface
ActiproSoftware.Text.Parsing Namespace


IAstNodeIdProvider Methods

IAstNodeIdProvider Methods

The IAstNodeIdProvider type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider. (Inherited from IIdProvider.)
Public method | GetDescription | Returns the actual string representation for the specified ID. (Inherited from IIdProvider.)
Public method | GetKey | Returns the string-based key for the specified ID. (Inherited from IIdProvider.)
Top
See Also

Reference

IAstNodeIdProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParseData Interface

IParseData Interface
Provides the base requirements for a class that represents the result of a parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParseData
Public Interface IParseData
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IParseError Interface

IParseError Interface
Provides the base requirements for an object that indicates a message, warning or error related to parsing.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParseError
Public Interface IParseError

The IParseError type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the optional IClassificationType associated with the error.
Public property | Description | Gets the description of the error, which is displayed in the user interface.
Public property | Level | Gets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets the TextPositionRange of the error.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.Parsing.ImplementationParseError


IParseError Properties

IParseError Properties

The IParseError type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the optional IClassificationType associated with the error.
Public property | Description | Gets the description of the error, which is displayed in the user interface.
Public property | Level | Gets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets the TextPositionRange of the error.
Top
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.ClassificationType Property

IParseErrorClassificationType Property
Gets the optional IClassificationType associated with the error.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The optional IClassificationType associated with the error.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.Description Property

IParseErrorDescription Property
Gets the description of the error, which is displayed in the user interface.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the error, which is displayed in the user interface.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.Level Property

IParseErrorLevel Property
Gets a ParseErrorLevel indicating the error level.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ParseErrorLevel Level { get; }
ReadOnly Property Level As ParseErrorLevel
    Get

Property Value

Type: ParseErrorLevel
A ParseErrorLevel indicating the error level.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseError.PositionRange Property

IParseErrorPositionRange Property
Gets the TextPositionRange of the error.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; }
ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The TextPositionRange of the error.
Remarks
If no text position data is available for the error, the value should be TextPositionRange.Empty.
See Also

Reference

IParseError Interface
ActiproSoftware.Text.Parsing Namespace


IParseErrorProvider Interface

IParseErrorProvider Interface
Provides the base requirements for an object that returns a list of IParseError objects, and is generally implemented by IParseData instances if they support error reporting.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParseErrorProvider
Public Interface IParseErrorProvider

The IParseErrorProvider type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.ParsingIParseError


IParseErrorProvider Properties

IParseErrorProvider Properties

The IParseErrorProvider type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Gets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

IParseErrorProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParseErrorProvider.Errors Property

IParseErrorProviderErrors Property
Gets the collection of IParseError objects that specify parse errors.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> Errors { get; }
ReadOnly Property Errors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that specify parse errors.
See Also

Reference

IParseErrorProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParseErrorProvider.Snapshot Property

IParseErrorProviderSnapshot Property
Gets the ITextSnapshot, if known, from which the parse errors were created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot, if known, from which the parse errors were created.
See Also

Reference

IParseErrorProvider Interface
ActiproSoftware.Text.Parsing Namespace


IParser Interface

IParser Interface
Provides the base requirements of a parser (syntax/semantic analyzer) for a language.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParser : IKeyedObject
Public Interface IParser
    Inherits IKeyedObject

The IParser type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IParser Properties

IParser Properties

The IParser type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

IParser Interface
ActiproSoftware.Text.Parsing Namespace


IParser Methods

IParser Methods

The IParser type exposes the following members.

Methods
 | Name | Description
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Top
See Also

Reference

IParser Interface
ActiproSoftware.Text.Parsing Namespace


IParser.Parse Method

IParserParse Method
Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseData Parse(
    IParseRequest request
)
Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

IParser Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest Interface

IParseRequest Interface
Provides the base requirements of a parsing operation request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParseRequest
Public Interface IParseRequest

The IParseRequest type exposes the following members.

Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
ActiproSoftware.Text.Parsing.ImplementationParseRequest


IParseRequest Properties

IParseRequest Properties

The IParseRequest type exposes the following members.

Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.CreatedDateTime Property

IParseRequestCreatedDateTime Property
Gets the DateTime at which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DateTime CreatedDateTime { get; }
ReadOnly Property CreatedDateTime As DateTime
    Get

Property Value

Type: DateTime
The DateTime at which the parse request was created.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Language Property

IParseRequestLanguage Property
Gets the ISyntaxLanguage for which this parse request was created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISyntaxLanguage Language { get; }
ReadOnly Property Language As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage for which this parse request was created.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.ParseHashKey Property

IParseRequestParseHashKey Property
Gets a hash key that uniquely identifies the parse request for a source/target combination.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ParseHashKey { get; }
ReadOnly Property ParseHashKey As String
    Get

Property Value

Type: String
A hash key that uniquely identifies the parse request for a source/target combination.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Parser Property

IParseRequestParser Property
Gets the IParser that will perform the parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParser Parser { get; }
ReadOnly Property Parser As IParser
    Get

Property Value

Type: IParser
The IParser that will perform the parsing operation.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Priority Property

IParseRequestPriority Property
Gets an integer value describing the priority of the request, where a higher number has a higher priority.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Priority { get; }
ReadOnly Property Priority As Integer
    Get

Property Value

Type: Int32
An integer value describing the priority of the request, where a higher number has a higher priority. The default value is ParseRequest.MediumPriority.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.RepeatedRequestPause Property

IParseRequestRepeatedRequestPause Property
Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int RepeatedRequestPause { get; set; }
Property RepeatedRequestPause As Integer
    Get
    Set

Property Value

Type: Int32
The number of milliseconds to pause if there are repeated attempts for this same request. The default value is 250.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Snapshot Property

IParseRequestSnapshot Property
Gets the ITextSnapshot, if available, for which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot, if available, for which the parse request was created.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.SourceKey Property

IParseRequestSourceKey Property
Gets a text key, typically a filename, that uniquely identifies the text to parse.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string SourceKey { get; }
ReadOnly Property SourceKey As String
    Get

Property Value

Type: String
A text key, typically a filename, that uniquely identifies the text to parse.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.State Property

IParseRequestState Property
Gets or sets the current state of the request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ParseRequestState State { get; set; }
Property State As ParseRequestState
    Get
    Set

Property Value

Type: ParseRequestState
The current state of the request.
Remarks
This property should only be set by a IParseRequestDispatcher.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Tag Property

IParseRequestTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the control. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.Target Property

IParseRequestTarget Property
Gets the IParseTarget that will be notified once the parsing operation is complete.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseTarget Target { get; }
ReadOnly Property Target As IParseTarget
    Get

Property Value

Type: IParseTarget
The IParseTarget that will be notified once the parsing operation is complete.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequest.TextBufferReader Property

IParseRequestTextBufferReader Property
Gets the ITextBufferReader used to read the text that should be parsed.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextBufferReader TextBufferReader { get; }
ReadOnly Property TextBufferReader As ITextBufferReader
    Get

Property Value

Type: ITextBufferReader
The ITextBufferReader used to read the text that should be parsed.
See Also

Reference

IParseRequest Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher Interface

IParseRequestDispatcher Interface
Provides the base requirements for a class that can queue up IParseRequest objects, prioritize and execute them on one or more worker threads, and notify an IParseTarget of the result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParseRequestDispatcher : IDisposable
Public Interface IParseRequestDispatcher
    Inherits IDisposable

The IParseRequestDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace
[!:ActiproSoftware.Text.Parsing.Implementation.ThreadedParseRequestDispatcher]


IParseRequestDispatcher Properties

IParseRequestDispatcher Properties

The IParseRequestDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.IsBusy Property

IParseRequestDispatcherIsBusy Property
Gets whether the multi-threaded parser service is currently busy processing a request.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBusy { get; }
ReadOnly Property IsBusy As Boolean
    Get

Property Value

Type: Boolean
true if the multi-threaded parser service is currently busy processing a request; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.PendingRequestCount Property

IParseRequestDispatcherPendingRequestCount Property
Gets the number of pending requests remaining in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PendingRequestCount { get; }
ReadOnly Property PendingRequestCount As Integer
    Get

Property Value

Type: Int32
The number of pending requests remaining in the parse request queue.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher Methods

IParseRequestDispatcher Methods

The IParseRequestDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.GetPendingRequests Method

IParseRequestDispatcherGetPendingRequests Method
Gets an array of the pending requests in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseRequest[] GetPendingRequests()
Function GetPendingRequests As IParseRequest()

Field Value

Type: IParseRequest
An array of the pending requests in the parse request queue.

Return Value

Type: IParseRequest

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.IParseRequestDispatcher.GetPendingRequests"]

See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.HasPendingRequest Method

IParseRequestDispatcherHasPendingRequest Method
Returns whether there is currently a pending request with the specified hash key.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasPendingRequest(
    string parseHashKey
)
Function HasPendingRequest (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to search.

Return Value

Type: Boolean
true if there is currently a pending request with the specified hash key; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.QueueRequest Method

IParseRequestDispatcherQueueRequest Method
Adds an IParseRequest to the queue of pending requests.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void QueueRequest(
    IParseRequest request
)
Sub QueueRequest (
    request As IParseRequest
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that should be processed.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.RemovePendingRequests Method

IParseRequestDispatcherRemovePendingRequests Method
Removes any pending requests in the parse request queue that have the specified hash key.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int RemovePendingRequests(
    string parseHashKey
)
Function RemovePendingRequests (
    parseHashKey As String
) As Integer

Parameters

parseHashKey
Type: SystemString
The parse hash key for which to search.

Return Value

Type: Int32
The number of pending requests that were removed.
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.WaitForParse Method

IParseRequestDispatcherWaitForParse Method
Overload List
 | Name | Description
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

IParseRequestDispatcher Interface
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.WaitForParse Method (String)

IParseRequestDispatcherWaitForParse Method (String)
Waits a maximum of 250 milliseconds for the specified request to complete.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool WaitForParse(
    string parseHashKey
)
Function WaitForParse (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
WaitForParse Overload
ActiproSoftware.Text.Parsing Namespace


IParseRequestDispatcher.WaitForParse Method (String, Int32)

IParseRequestDispatcherWaitForParse Method (String, Int32)
Waits for the specified request to complete, up to a maximum number of milliseconds.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool WaitForParse(
    string parseHashKey,
    int maximumWaitTime
)
Function WaitForParse (
    parseHashKey As String,
    maximumWaitTime As Integer
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.
maximumWaitTime
Type: SystemInt32
The maximum wait time in milliseconds.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.
See Also

Reference

IParseRequestDispatcher Interface
WaitForParse Overload
ActiproSoftware.Text.Parsing Namespace


IParseTarget Interface

IParseTarget Interface
Provides the base requirements for a class that can be notified with the results of a parsing operation.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParseTarget
Public Interface IParseTarget

The IParseTarget type exposes the following members.

Properties
 | Name | Description
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Top
Methods
 | Name | Description
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


IParseTarget Properties

IParseTarget Properties

The IParseTarget type exposes the following members.

Properties
 | Name | Description
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Top
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


IParseTarget.UniqueId Property

IParseTargetUniqueId Property
Gets the Guid that uniquely identifies the control.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Guid UniqueId { get; }
ReadOnly Property UniqueId As Guid
    Get

Property Value

Type: Guid
The Guid that uniquely identifies the control.
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


IParseTarget Methods

IParseTarget Methods

The IParseTarget type exposes the following members.

Methods
 | Name | Description
Public method | NotifyParseComplete | Called when a parsing operation has completed, and passes the original request along with the result.
Top
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


IParseTarget.NotifyParseComplete Method

IParseTargetNotifyParseComplete Method
Called when a parsing operation has completed, and passes the original request along with the result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyParseComplete(
    IParseRequest request,
    IParseData result
)
Sub NotifyParseComplete (
    request As IParseRequest,
    result As IParseData
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
An IParseRequest that contains information about the parsing operation that was requested.
result
Type: ActiproSoftware.Text.ParsingIParseData
An IParseData that is the result of the parsing operation.
See Also

Reference

IParseTarget Interface
ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Class

ParseDataPropertyChangedEventArgs Class
Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityPropertyChangedEventArgs IParseData
ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParseDataPropertyChangedEventArgs : PropertyChangedEventArgs<IParseData>
Public Class ParseDataPropertyChangedEventArgs
    Inherits PropertyChangedEventArgs(Of IParseData)

The ParseDataPropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ParseDataPropertyChangedEventArgs | Initializes a new instance of the ParseDataPropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Constructor

ParseDataPropertyChangedEventArgs Constructor
Initializes a new instance of the ParseDataPropertyChangedEventArgs class.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseDataPropertyChangedEventArgs(
    IParseData oldValue,
    IParseData newValue
)
Public Sub New (
    oldValue As IParseData,
    newValue As IParseData
)

Parameters

oldValue
Type: ActiproSoftware.Text.ParsingIParseData
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.Text.ParsingIParseData
The new value of the property being tracked as reported by an event.
See Also

Reference

ParseDataPropertyChangedEventArgs Class
ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Properties

ParseDataPropertyChangedEventArgs Properties

The ParseDataPropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

ParseDataPropertyChangedEventArgs Class
ActiproSoftware.Text.Parsing Namespace


ParseDataPropertyChangedEventArgs Methods

ParseDataPropertyChangedEventArgs Methods

The ParseDataPropertyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParseDataPropertyChangedEventArgs Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel Class

ParseErrorLevel Class
Specifies the error level of an IParseError.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.ParsingParseErrorLevel

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ParseErrorLevel : Enum
Public NotInheritable Class ParseErrorLevel
    Inherits Enum

The ParseErrorLevel type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Error | An error.
 | Message | A message.
Public field | value__ |
 | Warning | A warning.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel Methods

ParseErrorLevel Methods

The ParseErrorLevel type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ParseErrorLevel Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel Fields

ParseErrorLevel Fields

The ParseErrorLevel type exposes the following members.

Fields
 | Name | Description
 | Error | An error.
 | Message | A message.
Public field | value__ |
 | Warning | A warning.
Top
See Also

Reference

ParseErrorLevel Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel.Error Field

ParseErrorLevelError Field
An error.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseErrorLevel Error = 0
Public Const Error As ParseErrorLevel = 0

Field Value

Type: ParseErrorLevel
See Also

Reference

ParseErrorLevel Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel.Message Field

ParseErrorLevelMessage Field
A message.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseErrorLevel Message = 2
Public Const Message As ParseErrorLevel = 2

Field Value

Type: ParseErrorLevel
See Also

Reference

ParseErrorLevel Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel.value__ Field

ParseErrorLevelvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Parsing.ParseErrorLevel.value__"]

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ParseErrorLevel Class
ActiproSoftware.Text.Parsing Namespace


ParseErrorLevel.Warning Field

ParseErrorLevelWarning Field
A warning.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseErrorLevel Warning = 1
Public Const Warning As ParseErrorLevel = 1

Field Value

Type: ParseErrorLevel
See Also

Reference

ParseErrorLevel Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState Class

ParseRequestState Class
Specifies the current state of an IParseRequest.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.ParsingParseRequestState

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ParseRequestState : Enum
Public NotInheritable Class ParseRequestState
    Inherits Enum

The ParseRequestState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Aborted | The request has been aborted, possibly removed for another newer request for the same parse hash key.
 | Created | The request has been created, but has not yet been queued.
 | Processed | The request has been processed.
 | Processing | The request is currently being processed by an IParser.
 | Queued | The request has been queued by an IParseRequestDispatcher.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


ParseRequestState Methods

ParseRequestState Methods

The ParseRequestState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState Fields

ParseRequestState Fields

The ParseRequestState type exposes the following members.

Fields
 | Name | Description
 | Aborted | The request has been aborted, possibly removed for another newer request for the same parse hash key.
 | Created | The request has been created, but has not yet been queued.
 | Processed | The request has been processed.
 | Processing | The request is currently being processed by an IParser.
 | Queued | The request has been queued by an IParseRequestDispatcher.
Public field | value__ |
Top
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState.Aborted Field

ParseRequestStateAborted Field
The request has been aborted, possibly removed for another newer request for the same parse hash key.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseRequestState Aborted = 4
Public Const Aborted As ParseRequestState = 4

Field Value

Type: ParseRequestState
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState.Created Field

ParseRequestStateCreated Field
The request has been created, but has not yet been queued.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseRequestState Created = 0
Public Const Created As ParseRequestState = 0

Field Value

Type: ParseRequestState
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState.Processed Field

ParseRequestStateProcessed Field
The request has been processed.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseRequestState Processed = 3
Public Const Processed As ParseRequestState = 3

Field Value

Type: ParseRequestState
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState.Processing Field

ParseRequestStateProcessing Field
The request is currently being processed by an IParser.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseRequestState Processing = 2
Public Const Processing As ParseRequestState = 2

Field Value

Type: ParseRequestState
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState.Queued Field

ParseRequestStateQueued Field
The request has been queued by an IParseRequestDispatcher.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ParseRequestState Queued = 1
Public Const Queued As ParseRequestState = 1

Field Value

Type: ParseRequestState
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


ParseRequestState.value__ Field

ParseRequestStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Parsing.ParseRequestState.value__"]

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ParseRequestState Class
ActiproSoftware.Text.Parsing Namespace


SyntaxLanguageParsingExtensions Class

SyntaxLanguageParsingExtensions Class
Contains parsing-related extension methods that make it easier to work with ISyntaxLanguage objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.ParsingSyntaxLanguageParsingExtensions

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class SyntaxLanguageParsingExtensions
<ExtensionAttribute>
Public NotInheritable Class SyntaxLanguageParsingExtensions

The SyntaxLanguageParsingExtensions type exposes the following members.

Methods
Name | Description
Parse | Parses text using the specified language's IParser service and returns the IParseData result.
Top
See Also

Reference

ActiproSoftware.Text.Parsing Namespace


SyntaxLanguageParsingExtensions Methods

SyntaxLanguageParsingExtensions Methods

The SyntaxLanguageParsingExtensions type exposes the following members.

Methods
Name | Description
Parse | Parses text using the specified language's IParser service and returns the IParseData result.
Top
See Also

Reference

SyntaxLanguageParsingExtensions Class
ActiproSoftware.Text.Parsing Namespace


SyntaxLanguageParsingExtensions.Parse Method

SyntaxLanguageParsingExtensionsParse Method
Parses text using the specified language's IParser service and returns the IParseData result.

Namespace: ActiproSoftware.Text.Parsing
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParseData Parse(
    this ISyntaxLanguage language,
    string text
)
<ExtensionAttribute>
Public Shared Function Parse (
    language As ISyntaxLanguage,
    text As String
) As IParseData

Parameters

language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage to examine for a parser.
text
Type: SystemString
The text to parse.

Return Value

Type: IParseData
The IParseData returned by the parser.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISyntaxLanguage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This method parses text directly in the calling thread.
See Also

Reference

SyntaxLanguageParsingExtensions Class
ActiproSoftware.Text.Parsing Namespace


ActiproSoftware.Text.Parsing.Implementation Namespace

ActiproSoftware.Text.Parsing.Implementation Namespace
Contains implementation types related to parsing.
Classes
 | Class | Description
Public class | AstNodeBase | Represents an abstract AST (abstract syntax tree) node implementation that is intended to be used as a base class for type-specific AST nodes.
Public class | AstNodeIdProviderBase | Represents an abstract base class for an object that provides static IDs for the AST nodes of an ISyntaxLanguage.
Public class | DefaultAstNode | Represents an AST (abstract syntax tree) node implementation that has a string value and optional child nodes.
Public class | ParseError | Represents an object that indicates a message, warning or error related to parsing.
Public class | ParserBase | Represents the base implementation of a parser (syntax/semantic analyzer) for a language.
Public class | ParseRequest | Represents a request for a parsing operation.
Public class | TaskBasedParseRequestDispatcher | Implements an IParseRequestDispatcher that uses a worker Task to process parse requests.


AstNodeBase Class

AstNodeBase Class
Represents an abstract AST (abstract syntax tree) node implementation that is intended to be used as a base class for type-specific AST nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
More...

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class AstNodeBase : IAstNode
Public MustInherit Class AstNodeBase
    Implements IAstNode

The AstNodeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AstNodeBase | Initializes a new instance of the AstNodeBase class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAccessorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArgument
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationArrayReallocateClause
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttribute
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeArgument
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationAttributeSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCatchClause
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationClassBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationCompilationUnitOption
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationConstructorBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDocumentationComment
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationElseIfSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEnumerationBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationEventBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationExternalAliasDirectiveSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationFixedSizeBufferDeclarator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceAccessorDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationInterfaceBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationMethodBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationNamespaceDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOperatorBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationOrdering
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationParameterDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPreprocessorDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationPropertyBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQualifiedName
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationQueryOperator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationRangeVariableDeclarator
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationReturnTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationStructureBody
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationSwitchSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeMemberDeclaration
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationTypeParameter
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirective
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationUsingDirectiveSection
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationVariableDeclarator
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationArgument
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCatchClause
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationFunctionBody
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationParameterDeclaration
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationPropertyDeclaration
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSourceElement
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationSwitchSection
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationVariableDeclaration
ActiproSoftware.Text.Languages.Python.Ast.ImplementationArgument
ActiproSoftware.Text.Languages.Python.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.Python.Ast.ImplementationComprehensionClauseBase
ActiproSoftware.Text.Languages.Python.Ast.ImplementationDecorator
ActiproSoftware.Text.Languages.Python.Ast.ImplementationExpression
ActiproSoftware.Text.Languages.Python.Ast.ImplementationIfStatementCondition
ActiproSoftware.Text.Languages.Python.Ast.ImplementationParameter
ActiproSoftware.Text.Languages.Python.Ast.ImplementationSliceItem
ActiproSoftware.Text.Languages.Python.Ast.ImplementationStatement
ActiproSoftware.Text.Languages.Python.Ast.ImplementationTryStatementExceptClause
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCDataSection
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationComment
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationCompilationUnit
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationDeclaration
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElement
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementAttribute
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationElementContent
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationEndTag
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationProcessingInstruction


AstNodeBase Constructor

AstNodeBase Constructor
Initializes a new instance of the AstNodeBase class

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AstNodeBase()
Protected Sub New
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase Properties

AstNodeBase Properties

The AstNodeBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Children Property

AstNodeBaseChildren Property
Gets the list containing the child AST nodes of this AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Children { get; }
Public ReadOnly Property Children As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The list containing the child AST nodes of this AST node.

Implements

IAstNodeChildren
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.EndOffset Property

AstNodeBaseEndOffset Property
Gets or sets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> EndOffset { get; set; }
Public Property EndOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.

Implements

IAstNodeEndOffset
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.HasChildren Property

AstNodeBaseHasChildren Property
Gets whether the AST node contains any child AST nodes.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get

Property Value

Type: Boolean
true if the AST node contains any child AST nodes; otherwise, false.

Implements

IAstNodeHasChildren
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Id Property

AstNodeBaseId Property
Gets an integer value that identifies the type of AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int Id { get; }
Public Overridable ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
An integer value that identifies the type of AST node, if known.

Implements

IAstNodeId
Remarks
This class' default implementation always returns 0.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Length Property

AstNodeBaseLength Property
Gets the character length of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The character length of this AST node, if known.

Implements

IAstNodeLength
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Parent Property

AstNodeBaseParent Property
Gets or sets the parent IAstNode of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode Parent { get; set; }
Public Property Parent As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The parent IAstNode of this AST node, if known.

Implements

IAstNodeParent
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.StartOffset Property

AstNodeBaseStartOffset Property
Gets or sets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> StartOffset { get; set; }
Public Property StartOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.

Implements

IAstNodeStartOffset
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Value Property

AstNodeBaseValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Value { get; set; }
Public Overridable Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase Methods

AstNodeBase Methods

The AstNodeBase type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Protected method | GetChildrenEnumerator | Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.Contains Method

AstNodeBaseContains Method
Returns whether the AST node contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the AST node contains the specified offset; otherwise, false.

Implements

IAstNodeContains(Int32)
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the AST node. This method also returns false if the AST node doesn't have known offsets.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.FindChildNode Method

AstNodeBaseFindChildNode Method
Searches through the child nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode FindChildNode(
    int offset
)
Public Function FindChildNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindChildNode(Int32)
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.FindDescendantNode Method

AstNodeBaseFindDescendantNode Method
Recursively searches through the descendant nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode FindDescendantNode(
    int offset
)
Public Function FindDescendantNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindDescendantNode(Int32)
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.GetChildrenEnumerator Method

AstNodeBaseGetChildrenEnumerator Method
Retrieves an IEnumerator object that can iterate the child IAstNode objects in this node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IEnumerator<IAstNode> GetChildrenEnumerator()
Protected Overridable Function GetChildrenEnumerator As IEnumerator(Of IAstNode)

Return Value

Type: IEnumerator IAstNode
An IEnumerator object that can iterate the child IAstNode objects in this node.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.ToString Method

AstNodeBaseToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeBase.ToTreeString Method

AstNodeBaseToTreeString Method
Outputs the contents of the AST node in tree form.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToTreeString(
    int indentLevel
)
Public Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the AST node.

Implements

IAstNodeToTreeString(Int32)
See Also

Reference

AstNodeBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Class

AstNodeIdProviderBase Class
Represents an abstract base class for an object that provides static IDs for the AST nodes of an ISyntaxLanguage.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationAstNodeIdProviderBase
ActiproSoftware.Text.Languages.DotNet.Ast.ImplementationDotNetAstNodeId
ActiproSoftware.Text.Languages.JavaScript.Ast.ImplementationJavaScriptAstNodeId
ActiproSoftware.Text.Languages.Python.Ast.ImplementationPythonAstNodeId
ActiproSoftware.Text.Languages.Xml.Ast.ImplementationXmlAstNodeId

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class AstNodeIdProviderBase : IAstNodeIdProvider,
    IIdProvider
Public MustInherit Class AstNodeIdProviderBase
    Implements IAstNodeIdProvider, IIdProvider

The AstNodeIdProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AstNodeIdProviderBase | Initializes a new instance of the AstNodeIdProviderBase class
Top
Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified ID.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Constructor

AstNodeIdProviderBase Constructor
Initializes a new instance of the AstNodeIdProviderBase class

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AstNodeIdProviderBase()
Protected Sub New
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Properties

AstNodeIdProviderBase Properties

The AstNodeIdProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | MaxId | Gets the maximum ID returned by this provider.
Public property | MinId | Gets the minimum ID returned by this provider.
Top
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.MaxId Property

AstNodeIdProviderBaseMaxId Property
Gets the maximum ID returned by this provider.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int MaxId { get; }
Public MustOverride ReadOnly Property MaxId As Integer
    Get

Property Value

Type: Int32
The maximum ID returned by this provider.

Implements

IIdProviderMaxId
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.MinId Property

AstNodeIdProviderBaseMinId Property
Gets the minimum ID returned by this provider.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract int MinId { get; }
Public MustOverride ReadOnly Property MinId As Integer
    Get

Property Value

Type: Int32
The minimum ID returned by this provider.

Implements

IIdProviderMinId
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase Methods

AstNodeIdProviderBase Methods

The AstNodeIdProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | ContainsId | Returns whether the specified ID value is valid for this ID provider.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDescription | Returns the actual string representation for the specified ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetKey | Returns the string-based key for the specified ID.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.ContainsId Method

AstNodeIdProviderBaseContainsId Method
Returns whether the specified ID value is valid for this ID provider.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract bool ContainsId(
    int id
)
Public MustOverride Function ContainsId (
    id As Integer
) As Boolean

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: Boolean
true if the ID value is valid; otherwise, false

Implements

IIdProviderContainsId(Int32)
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.GetDescription Method

AstNodeIdProviderBaseGetDescription Method
Returns the actual string representation for the specified ID.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string GetDescription(
    int id
)
Public MustOverride Function GetDescription (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The actual string representation for the specified ID.

Implements

IIdProviderGetDescription(Int32)
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


AstNodeIdProviderBase.GetKey Method

AstNodeIdProviderBaseGetKey Method
Returns the string-based key for the specified ID.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string GetKey(
    int id
)
Public MustOverride Function GetKey (
    id As Integer
) As String

Parameters

id
Type: SystemInt32
The ID to examine.

Return Value

Type: String
The string-based key for the specified ID.

Implements

IIdProviderGetKey(Int32)
See Also

Reference

AstNodeIdProviderBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Class

DefaultAstNode Class
Represents an AST (abstract syntax tree) node implementation that has a string value and optional child nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationDefaultAstNode

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DefaultAstNode : IAstNode
Public Class DefaultAstNode
    Implements IAstNode

The DefaultAstNode type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultAstNode | Initializes a new instance of the DefaultAstNode class
Top
Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Constructor

DefaultAstNode Constructor
Initializes a new instance of the DefaultAstNode class

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DefaultAstNode()
Public Sub New
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Properties

DefaultAstNode Properties

The DefaultAstNode type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the list containing the child AST nodes of this AST node.
Public property | EndOffset | Gets or sets the end offset of this AST node, if known.
Public property | HasChildren | Gets whether the AST node contains any child AST nodes.
Public property | Id | Gets an integer value that identifies the type of AST node, if known.
Public property | Length | Gets the character length of this AST node, if known.
Public property | Parent | Gets or sets the parent IAstNode of this AST node, if known.
Public property | StartOffset | Gets or sets the start offset of this AST node, if known.
Public property | Value | Gets or sets the string-based value for the AST node.
Top
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Children Property

DefaultAstNodeChildren Property
Gets the list containing the child AST nodes of this AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IAstNode> Children { get; }
Public ReadOnly Property Children As IList(Of IAstNode)
    Get

Property Value

Type: IList IAstNode
The list containing the child AST nodes of this AST node.

Implements

IAstNodeChildren
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.EndOffset Property

DefaultAstNodeEndOffset Property
Gets or sets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> EndOffset { get; set; }
Public Property EndOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.

Implements

IAstNodeEndOffset
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.HasChildren Property

DefaultAstNodeHasChildren Property
Gets whether the AST node contains any child AST nodes.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get

Property Value

Type: Boolean
true if the AST node contains any child AST nodes; otherwise, false.

Implements

IAstNodeHasChildren
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Id Property

DefaultAstNodeId Property
Gets an integer value that identifies the type of AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int Id { get; }
Public Overridable ReadOnly Property Id As Integer
    Get

Property Value

Type: Int32
An integer value that identifies the type of AST node, if known.

Implements

IAstNodeId
Remarks
This class' default implementation always returns 0.
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Length Property

DefaultAstNodeLength Property
Gets the character length of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The character length of this AST node, if known.

Implements

IAstNodeLength
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Parent Property

DefaultAstNodeParent Property
Gets or sets the parent IAstNode of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode Parent { get; set; }
Public Property Parent As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The parent IAstNode of this AST node, if known.

Implements

IAstNodeParent
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.StartOffset Property

DefaultAstNodeStartOffset Property
Gets or sets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> StartOffset { get; set; }
Public Property StartOffset As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.

Implements

IAstNodeStartOffset
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Value Property

DefaultAstNodeValue Property
Gets or sets the string-based value for the AST node.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The string-based value for the AST node.

Implements

IAstNodeValue
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode Methods

DefaultAstNode Methods

The DefaultAstNode type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the AST node contains the specified offset.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindChildNode | Searches through the child nodes for a node that contains the specified offset.
Public method | FindDescendantNode | Recursively searches through the descendant nodes for a node that contains the specified offset.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTreeString | Outputs the contents of the AST node in tree form.
Top
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.Contains Method

DefaultAstNodeContains Method
Returns whether the AST node contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int offset
)
Public Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to examine.

Return Value

Type: Boolean
true if the AST node contains the specified offset; otherwise, false.

Implements

IAstNodeContains(Int32)
Remarks
This method returns false if the offset falls on the EndOffset offset since this method indicates if the offset is encompassed by the AST node. This method also returns false if the AST node doesn't have known offsets.
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.FindChildNode Method

DefaultAstNodeFindChildNode Method
Searches through the child nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode FindChildNode(
    int offset
)
Public Function FindChildNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The child IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindChildNode(Int32)
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.FindDescendantNode Method

DefaultAstNodeFindDescendantNode Method
Recursively searches through the descendant nodes for a node that contains the specified offset.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode FindDescendantNode(
    int offset
)
Public Function FindDescendantNode (
    offset As Integer
) As IAstNode

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: IAstNode
The descendant IAstNode that contains the specified offset, if any.

Implements

IAstNodeFindDescendantNode(Int32)
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.ToString Method

DefaultAstNodeToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


DefaultAstNode.ToTreeString Method

DefaultAstNodeToTreeString Method
Outputs the contents of the AST node in tree form.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToTreeString(
    int indentLevel
)
Public Function ToTreeString (
    indentLevel As Integer
) As String

Parameters

indentLevel
Type: SystemInt32
The indentation level.

Return Value

Type: String
A string containing the tree form of the AST node.

Implements

IAstNodeToTreeString(Int32)
See Also

Reference

DefaultAstNode Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Class

ParseError Class
Represents an object that indicates a message, warning or error related to parsing.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParseError

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParseError : IParseError
Public Class ParseError
    Implements IParseError

The ParseError type exposes the following members.

Constructors
 | Name | Description
Public method | ParseError | Initializes a new instance of the ParseError class.
Public method | ParseError(ParseErrorLevel, String, TextPositionRange) | Initializes a new instance of the ParseError class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the error.
Public property | Description | Gets or sets the description of the error, which is displayed in the user interface.
Public property | Level | Gets or sets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets or sets the TextPositionRange of the error.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Constructor

ParseError Constructor
Overload List
 | Name | Description
Public method | ParseError | Initializes a new instance of the ParseError class.
Public method | ParseError(ParseErrorLevel, String, TextPositionRange) | Initializes a new instance of the ParseError class.
Top
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Constructor

ParseError Constructor
Initializes a new instance of the ParseError class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseError()
Public Sub New
See Also

Reference

ParseError Class
ParseError Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Constructor (ParseErrorLevel, String, TextPositionRange)

ParseError Constructor (ParseErrorLevel, String, TextPositionRange)
Initializes a new instance of the ParseError class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseError(
    ParseErrorLevel level,
    string description,
    TextPositionRange positionRange
)
Public Sub New (
    level As ParseErrorLevel,
    description As String,
    positionRange As TextPositionRange
)

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange of the error.
See Also

Reference

ParseError Class
ParseError Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Properties

ParseError Properties

The ParseError type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the error.
Public property | Description | Gets or sets the description of the error, which is displayed in the user interface.
Public property | Level | Gets or sets a ParseErrorLevel indicating the error level.
Public property | PositionRange | Gets or sets the TextPositionRange of the error.
Top
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.ClassificationType Property

ParseErrorClassificationType Property
Gets or sets the optional IClassificationType associated with the error.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The optional IClassificationType associated with the error.

Implements

IParseErrorClassificationType
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.Description Property

ParseErrorDescription Property
Gets or sets the description of the error, which is displayed in the user interface.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the error, which is displayed in the user interface.

Implements

IParseErrorDescription
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.Level Property

ParseErrorLevel Property
Gets or sets a ParseErrorLevel indicating the error level.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseErrorLevel Level { get; set; }
Public Property Level As ParseErrorLevel
    Get
    Set

Property Value

Type: ParseErrorLevel
A ParseErrorLevel indicating the error level.

Implements

IParseErrorLevel
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.PositionRange Property

ParseErrorPositionRange Property
Gets or sets the TextPositionRange of the error.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; set; }
Public Property PositionRange As TextPositionRange
    Get
    Set

Property Value

Type: TextPositionRange
The TextPositionRange of the error.

Implements

IParseErrorPositionRange
Remarks
If no text position data is available for the error, the value should be TextPositionRange.Empty.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError Methods

ParseError Methods

The ParseError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.Equals Method

ParseErrorEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.GetHashCode Method

ParseErrorGetHashCode Method
Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseError.ToString Method

ParseErrorToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ParseError Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Class

ParserBase Class
Represents the base implementation of a parser (syntax/semantic analyzer) for a language.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class ParserBase : IParser,
    IKeyedObject
Public MustInherit Class ParserBase
    Implements IParser, IKeyedObject

The ParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ParserBase | Initializes a new instance of the ParserBase class.
Top
Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Constructor

ParserBase Constructor
Initializes a new instance of the ParserBase class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ParserBase(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the parser.
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Properties

ParserBase Properties

The ParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name.
Top
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase.Key Property

ParserBaseKey Property
Gets or sets a string that identifies the parser, generally the related language name.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; protected set; }
Public Property Key As String
    Get
    Protected Set

Property Value

Type: String
A string that identifies the parser, generally the related language name.

Implements

IKeyedObjectKey
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase Methods

ParserBase Methods

The ParserBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParserBase.Parse Method

ParserBaseParse Method
Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IParseData Parse(
    IParseRequest request
)
Public MustOverride Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.

Implements

IParserParse(IParseRequest)
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

ParserBase Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Class

ParseRequest Class
Represents a request for a parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParseRequest

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParseRequest : IParseRequest
Public Class ParseRequest
    Implements IParseRequest

The ParseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ParseRequest(String, ITextBufferReader, ISyntaxLanguage, IParseTarget) | Initializes a new instance of the ParseRequest class.
Public method | ParseRequest(String, ITextBufferReader, IParser, IParseTarget) | Initializes a new instance of the ParseRequest class.
Top
Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets or sets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets or sets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetParseHashKey | Returns the ParseHashKey to use for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
HighPriority | Specifies a high priority.
LowPriority | Specifies a low priority.
MediumPriority | Specifies a medium priority.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Constructor

ParseRequest Constructor
Overload List
 | Name | Description
Public method | ParseRequest(String, ITextBufferReader, ISyntaxLanguage, IParseTarget) | Initializes a new instance of the ParseRequest class.
Public method | ParseRequest(String, ITextBufferReader, IParser, IParseTarget) | Initializes a new instance of the ParseRequest class.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Constructor (String, ITextBufferReader, ISyntaxLanguage, IParseTarget)

ParseRequest Constructor (String, ITextBufferReader, ISyntaxLanguage, IParseTarget)
Initializes a new instance of the ParseRequest class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseRequest(
    string sourceKey,
    ITextBufferReader textBufferReader,
    ISyntaxLanguage language,
    IParseTarget parseTarget
)
Public Sub New (
    sourceKey As String,
    textBufferReader As ITextBufferReader,
    language As ISyntaxLanguage,
    parseTarget As IParseTarget
)

Parameters

sourceKey
Type: SystemString
A text key, typically a filename, that uniquely identifies the text to parse.
textBufferReader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that contains the text to parse.
language
Type: ActiproSoftware.TextISyntaxLanguage
The ISyntaxLanguage for which this parse request was created.
parseTarget
Type: ActiproSoftware.Text.ParsingIParseTarget
An IParseTarget indicating the object that will receive the results of the parse.
See Also

Reference

ParseRequest Class
ParseRequest Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Constructor (String, ITextBufferReader, IParser, IParseTarget)

ParseRequest Constructor (String, ITextBufferReader, IParser, IParseTarget)
Initializes a new instance of the ParseRequest class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseRequest(
    string sourceKey,
    ITextBufferReader textBufferReader,
    IParser parser,
    IParseTarget parseTarget
)
Public Sub New (
    sourceKey As String,
    textBufferReader As ITextBufferReader,
    parser As IParser,
    parseTarget As IParseTarget
)

Parameters

sourceKey
Type: SystemString
A text key, typically a filename, that uniquely identifies the text to parse.
textBufferReader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that contains the text to parse.
parser
Type: ActiproSoftware.Text.ParsingIParser
The IParser that will perform the parsing operation.
parseTarget
Type: ActiproSoftware.Text.ParsingIParseTarget
An IParseTarget indicating the object that will receive the results of the parse.
See Also

Reference

ParseRequest Class
ParseRequest Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Properties

ParseRequest Properties

The ParseRequest type exposes the following members.

Properties
 | Name | Description
Public property | CreatedDateTime | Gets the DateTime at which the parse request was created.
Public property | Language | Gets the ISyntaxLanguage for which this parse request was created.
Public property | ParseHashKey | Gets a hash key that uniquely identifies the parse request for a source/target combination.
Public property | Parser | Gets the IParser that will perform the parsing operation.
Public property | Priority | Gets or sets an integer value describing the priority of the request, where a higher number has a higher priority.
Public property | RepeatedRequestPause | Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.
Public property | Snapshot | Gets or sets the ITextSnapshot, if available, for which the parse request was created.
Public property | SourceKey | Gets a text key, typically a filename, that uniquely identifies the text to parse.
Public property | State | Gets or sets the current state of the request.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | Target | Gets the IParseTarget that will be notified once the parsing operation is complete.
Public property | TextBufferReader | Gets the ITextBufferReader used to read the text that should be parsed.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.CreatedDateTime Property

ParseRequestCreatedDateTime Property
Gets the DateTime at which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime CreatedDateTime { get; }
Public ReadOnly Property CreatedDateTime As DateTime
    Get

Property Value

Type: DateTime
The DateTime at which the parse request was created.

Implements

IParseRequestCreatedDateTime
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Language Property

ParseRequestLanguage Property
Gets the ISyntaxLanguage for which this parse request was created.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISyntaxLanguage Language { get; }
Public ReadOnly Property Language As ISyntaxLanguage
    Get

Property Value

Type: ISyntaxLanguage
The ISyntaxLanguage for which this parse request was created.

Implements

IParseRequestLanguage
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.ParseHashKey Property

ParseRequestParseHashKey Property
Gets a hash key that uniquely identifies the parse request for a source/target combination.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ParseHashKey { get; }
Public ReadOnly Property ParseHashKey As String
    Get

Property Value

Type: String
A hash key that uniquely identifies the parse request for a source/target combination.

Implements

IParseRequestParseHashKey
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Parser Property

ParseRequestParser Property
Gets the IParser that will perform the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParser Parser { get; }
Public ReadOnly Property Parser As IParser
    Get

Property Value

Type: IParser
The IParser that will perform the parsing operation.

Implements

IParseRequestParser
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Priority Property

ParseRequestPriority Property
Gets or sets an integer value describing the priority of the request, where a higher number has a higher priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set

Property Value

Type: Int32
An integer value describing the priority of the request, where a higher number has a higher priority. The default value is ParseRequest.MediumPriority.

Implements

IParseRequestPriority
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.RepeatedRequestPause Property

ParseRequestRepeatedRequestPause Property
Gets or sets the number of milliseconds to pause if there are repeated attempts for this same request.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int RepeatedRequestPause { get; set; }
Public Property RepeatedRequestPause As Integer
    Get
    Set

Property Value

Type: Int32
The number of milliseconds to pause if there are repeated attempts for this same request. The default value is 250.

Implements

IParseRequestRepeatedRequestPause
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Snapshot Property

ParseRequestSnapshot Property
Gets or sets the ITextSnapshot, if available, for which the parse request was created.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; set; }
Public Property Snapshot As ITextSnapshot
    Get
    Set

Property Value

Type: ITextSnapshot
The ITextSnapshot, if available, for which the parse request was created.

Implements

IParseRequestSnapshot
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.SourceKey Property

ParseRequestSourceKey Property
Gets a text key, typically a filename, that uniquely identifies the text to parse.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SourceKey { get; }
Public ReadOnly Property SourceKey As String
    Get

Property Value

Type: String
A text key, typically a filename, that uniquely identifies the text to parse.

Implements

IParseRequestSourceKey
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.State Property

ParseRequestState Property
Gets or sets the current state of the request.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseRequestState State { get; set; }
Public Property State As ParseRequestState
    Get
    Set

Property Value

Type: ParseRequestState
The current state of the request.

Implements

IParseRequestState
Remarks
This property should only be set by a IParseRequestDispatcher.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Tag Property

ParseRequestTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the control. The default is .

Implements

IParseRequestTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.Target Property

ParseRequestTarget Property
Gets the IParseTarget that will be notified once the parsing operation is complete.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseTarget Target { get; }
Public ReadOnly Property Target As IParseTarget
    Get

Property Value

Type: IParseTarget
The IParseTarget that will be notified once the parsing operation is complete.

Implements

IParseRequestTarget
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.TextBufferReader Property

ParseRequestTextBufferReader Property
Gets the ITextBufferReader used to read the text that should be parsed.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextBufferReader TextBufferReader { get; }
Public ReadOnly Property TextBufferReader As ITextBufferReader
    Get

Property Value

Type: ITextBufferReader
The ITextBufferReader used to read the text that should be parsed.

Implements

IParseRequestTextBufferReader
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Methods

ParseRequest Methods

The ParseRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetParseHashKey | Returns the ParseHashKey to use for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.GetParseHashKey Method

ParseRequestGetParseHashKey Method
Returns the ParseHashKey to use for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string GetParseHashKey(
    ICodeDocument document
)
Public Shared Function GetParseHashKey (
    document As ICodeDocument
) As String

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument to examine.

Return Value

Type: String
The ParseHashKey to use for the specified ICodeDocument.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest Fields

ParseRequest Fields

The ParseRequest type exposes the following members.

Fields
Name | Description
HighPriority | Specifies a high priority.
LowPriority | Specifies a low priority.
MediumPriority | Specifies a medium priority.
Top
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.HighPriority Field

ParseRequestHighPriority Field
Specifies a high priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int HighPriority = 300
Public Const HighPriority As Integer = 300

Field Value

Type: Int32
The value is 300.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.LowPriority Field

ParseRequestLowPriority Field
Specifies a low priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int LowPriority = 100
Public Const LowPriority As Integer = 100

Field Value

Type: Int32
The value is 100.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


ParseRequest.MediumPriority Field

ParseRequestMediumPriority Field
Specifies a medium priority.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const int MediumPriority = 200
Public Const MediumPriority As Integer = 200

Field Value

Type: Int32
The value is 200.
See Also

Reference

ParseRequest Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher Class

TaskBasedParseRequestDispatcher Class
Implements an IParseRequestDispatcher that uses a worker Task to process parse requests.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.Parsing.ImplementationTaskBasedParseRequestDispatcher

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TaskBasedParseRequestDispatcher : DisposableObject,
    IParseRequestDispatcher, IDisposable
Public Class TaskBasedParseRequestDispatcher
    Inherits DisposableObject
    Implements IParseRequestDispatcher, IDisposable

The TaskBasedParseRequestDispatcher type exposes the following members.

Constructors
 | Name | Description
Public method | TaskBasedParseRequestDispatcher | Initializes a new instance of the TaskBasedParseRequestDispatcher class.
Public method | TaskBasedParseRequestDispatcher(Int32) | Initializes a new instance of the TaskBasedParseRequestDispatcher class.
Top
Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DisposableObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | GetType | (Inherited from Object.)
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | ToString | (Inherited from Object.)
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher Constructor

TaskBasedParseRequestDispatcher Constructor
Overload List
 | Name | Description
Public method | TaskBasedParseRequestDispatcher | Initializes a new instance of the TaskBasedParseRequestDispatcher class.
Public method | TaskBasedParseRequestDispatcher(Int32) | Initializes a new instance of the TaskBasedParseRequestDispatcher class.
Top
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher Constructor

TaskBasedParseRequestDispatcher Constructor
Initializes a new instance of the TaskBasedParseRequestDispatcher class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TaskBasedParseRequestDispatcher()
Public Sub New
See Also

Reference

TaskBasedParseRequestDispatcher Class
TaskBasedParseRequestDispatcher Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher Constructor (Int32)

TaskBasedParseRequestDispatcher Constructor (Int32)
Initializes a new instance of the TaskBasedParseRequestDispatcher class.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TaskBasedParseRequestDispatcher(
    int maxTaskCount
)
Public Sub New (
    maxTaskCount As Integer
)

Parameters

maxTaskCount
Type: SystemInt32
The maximum number of worker tasks to use. Must be at least 1, and should not generally exceed the number of processor cores in the machine.
See Also

Reference

TaskBasedParseRequestDispatcher Class
TaskBasedParseRequestDispatcher Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher Properties

TaskBasedParseRequestDispatcher Properties

The TaskBasedParseRequestDispatcher type exposes the following members.

Properties
 | Name | Description
Public property | IsBusy | Gets whether the multi-threaded parser service is currently busy processing a request.
Public property | PendingRequestCount | Gets the number of pending requests remaining in the parse request queue.
Top
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.IsBusy Property

TaskBasedParseRequestDispatcherIsBusy Property
Gets whether the multi-threaded parser service is currently busy processing a request.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsBusy { get; }
Public ReadOnly Property IsBusy As Boolean
    Get

Property Value

Type: Boolean
true if the multi-threaded parser service is currently busy processing a request; otherwise, false.

Implements

IParseRequestDispatcherIsBusy
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.PendingRequestCount Property

TaskBasedParseRequestDispatcherPendingRequestCount Property
Gets the number of pending requests remaining in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int PendingRequestCount { get; }
Public ReadOnly Property PendingRequestCount As Integer
    Get

Property Value

Type: Int32
The number of pending requests remaining in the parse request queue.

Implements

IParseRequestDispatcherPendingRequestCount
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher Methods

TaskBasedParseRequestDispatcher Methods

The TaskBasedParseRequestDispatcher type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DisposableObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPendingRequests | Gets an array of the pending requests in the parse request queue.
Public method | GetType | (Inherited from Object.)
Public method | HasPendingRequest | Returns whether there is currently a pending request with the specified hash key.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | QueueRequest | Adds an IParseRequest to the queue of pending requests.
Public method | RemovePendingRequests | Removes any pending requests in the parse request queue that have the specified hash key.
Public method | ToString | (Inherited from Object.)
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.GetPendingRequests Method

TaskBasedParseRequestDispatcherGetPendingRequests Method
Gets an array of the pending requests in the parse request queue.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseRequest[] GetPendingRequests()
Public Function GetPendingRequests As IParseRequest()

Field Value

Type: IParseRequest
An array of the pending requests in the parse request queue.

Return Value

Type: IParseRequest

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.Implementation.TaskBasedParseRequestDispatcher.GetPendingRequests"]

Implements

IParseRequestDispatcherGetPendingRequests
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.HasPendingRequest Method

TaskBasedParseRequestDispatcherHasPendingRequest Method
Returns whether there is currently a pending request with the specified hash key.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasPendingRequest(
    string parseHashKey
)
Public Function HasPendingRequest (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to search.

Return Value

Type: Boolean
true if there is currently a pending request with the specified hash key; otherwise, false.

Implements

IParseRequestDispatcherHasPendingRequest(String)
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.QueueRequest Method

TaskBasedParseRequestDispatcherQueueRequest Method
Adds an IParseRequest to the queue of pending requests.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void QueueRequest(
    IParseRequest request
)
Public Sub QueueRequest (
    request As IParseRequest
)

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that should be processed.

Implements

IParseRequestDispatcherQueueRequest(IParseRequest)
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.RemovePendingRequests Method

TaskBasedParseRequestDispatcherRemovePendingRequests Method
Removes any pending requests in the parse request queue that have the specified hash key.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int RemovePendingRequests(
    string parseHashKey
)
Public Function RemovePendingRequests (
    parseHashKey As String
) As Integer

Parameters

parseHashKey
Type: SystemString
The parse hash key for which to search.

Return Value

Type: Int32
The number of pending requests that were removed.

Implements

IParseRequestDispatcherRemovePendingRequests(String)
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.WaitForParse Method

TaskBasedParseRequestDispatcherWaitForParse Method
Overload List
 | Name | Description
Public method | WaitForParse(String) | Waits a maximum of 250 milliseconds for the specified request to complete.
Public method | WaitForParse(String, Int32) | Waits for the specified request to complete, up to a maximum number of milliseconds.
Top
See Also

Reference

TaskBasedParseRequestDispatcher Class
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.WaitForParse Method (String)

TaskBasedParseRequestDispatcherWaitForParse Method (String)
Waits a maximum of 250 milliseconds for the specified request to complete.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool WaitForParse(
    string parseHashKey
)
Public Function WaitForParse (
    parseHashKey As String
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.

Implements

IParseRequestDispatcherWaitForParse(String)
See Also

Reference

TaskBasedParseRequestDispatcher Class
WaitForParse Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


TaskBasedParseRequestDispatcher.WaitForParse Method (String, Int32)

TaskBasedParseRequestDispatcherWaitForParse Method (String, Int32)
Waits for the specified request to complete, up to a maximum number of milliseconds.

Namespace: ActiproSoftware.Text.Parsing.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool WaitForParse(
    string parseHashKey,
    int maximumWaitTime
)
Public Function WaitForParse (
    parseHashKey As String,
    maximumWaitTime As Integer
) As Boolean

Parameters

parseHashKey
Type: SystemString
The parse hash key identifying the request for which to wait.
maximumWaitTime
Type: SystemInt32
The maximum wait time in milliseconds.

Return Value

Type: Boolean
true if a wait occurred; otherwise, false.

Implements

IParseRequestDispatcherWaitForParse(String, Int32)
See Also

Reference

TaskBasedParseRequestDispatcher Class
WaitForParse Overload
ActiproSoftware.Text.Parsing.Implementation Namespace


ActiproSoftware.Text.Parsing.LLParser Namespace

ActiproSoftware.Text.Parsing.LLParser Namespace
Contains types related to the creation of an LL parser.
Classes
 | Class | Description
Public class | InvalidGrammarException | An exception that is thrown when a grammar is invalid.
Public class | ParserCallback | Defines a callback method that can be executed during a parsing operation.
Public class | ParserCanMatchCallback | Defines a can-match callback method that can be executed during a parsing operation for a NonTerminal.
Public class | ParserErrorCallback | Defines an error callback method that can be executed during a parsing operation.
Public class | ParserErrorResults | Provides access to the built-in IParserErrorResult instances, that indicate a result provided by a ParserErrorCallback.
Interfaces
 | Interface | Description
Public interface | IAstNodeBuilder | Provides the base requirements for an object that constructs an AST (abstract syntax tree).
Public interface | IAstNodeMatch | Provides the base requirements for an IAstNode match made within the current IAstNodeBuilder scope.
Public interface | IAstNodeMatchCollection | Provides the base requirements for a collection of IAstNodeMatch objects.
Public interface | ILLParseData | Provides the base requirements for an object that stores the results of a ILLParser parsing operation.
Public interface | ILLParser | Provides the base requirements of an IParser that executes based on a Grammar definition.
Public interface | IMatchCondition | Provides the base requirements for a match condition for an EbnfTerm.
Public interface | IParserErrorResult | Provides the base requirements for the result provided by a ParserErrorCallback.
Public interface | IParserState | Provides the base requirements for an object that tracks the current state of a ILLParser.
Public interface | ITokenReader | Provides the base requirements for an object that can provide tokens to a ILLParser in a forward-only direction.
Public interface | ITreeConstructionNode | Provides the base requirements for tree construction node, used to output an IAstNode for an EbnfProduction.
Public interface | ITypedTreeConstructionNodeTAstNode | Provides the base requirements for tree construction node, used to output a specific type of IAstNode for an EbnfProduction.


IAstNodeBuilder Interface

IAstNodeBuilder Interface
Provides the base requirements for an object that constructs an AST (abstract syntax tree).

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAstNodeBuilder
Public Interface IAstNodeBuilder

The IAstNodeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Matches | Gets the list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.
Public property | RootNode | Gets the root IAstNode that has been constructed.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeBuilder Properties

IAstNodeBuilder Properties

The IAstNodeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Matches | Gets the list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.
Public property | RootNode | Gets the root IAstNode that has been constructed.
Top
See Also

Reference

IAstNodeBuilder Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeBuilder.Matches Property

IAstNodeBuilderMatches Property
Gets the list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNodeMatchCollection Matches { get; }
ReadOnly Property Matches As IAstNodeMatchCollection
    Get

Property Value

Type: IAstNodeMatchCollection
The list of IAstNodeMatch objects that indicate the labeled IAstNode matches for the current IAstNodeBuilder scope.
See Also

Reference

IAstNodeBuilder Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeBuilder.RootNode Property

IAstNodeBuilderRootNode Property
Gets the root IAstNode that has been constructed.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode RootNode { get; }
ReadOnly Property RootNode As IAstNode
    Get

Property Value

Type: IAstNode
The root IAstNode that has been constructed.
See Also

Reference

IAstNodeBuilder Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch Interface

IAstNodeMatch Interface
Provides the base requirements for an IAstNode match made within the current IAstNodeBuilder scope.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAstNodeMatch
Public Interface IAstNodeMatch

The IAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch Properties

IAstNodeMatch Properties

The IAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
See Also

Reference

IAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch.Label Property

IAstNodeMatchLabel Property
Gets or sets the optional label applied to the match that can be used for identification during tree construction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Label { get; set; }
Property Label As String
    Get
    Set

Property Value

Type: String
The optional label applied to the match that can be used for identification during tree construction.
See Also

Reference

IAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatch.Node Property

IAstNodeMatchNode Property
Gets or sets the IAstNode that was matched.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode Node { get; set; }
Property Node As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The IAstNode that was matched.
See Also

Reference

IAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection Interface

IAstNodeMatchCollection Interface
Provides the base requirements for a collection of IAstNodeMatch objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAstNodeMatchCollection : IList<IAstNodeMatch>,
    ICollection<IAstNodeMatch>, IEnumerable<IAstNodeMatch>, IEnumerable
Public Interface IAstNodeMatchCollection
    Inherits IList(Of IAstNodeMatch), ICollection(Of IAstNodeMatch),
    IEnumerable(Of IAstNodeMatch), IEnumerable

The IAstNodeMatchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IAstNodeMatch .)
Public property | EndOffset | Gets the end offset of this match collection.
Public property | IsReadOnly | (Inherited from ICollection IAstNodeMatch .)
Public property | Item | (Inherited from IList IAstNodeMatch .)
Public property | StartOffset | Gets the end offset of this match collection.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IAstNodeMatch .)
Public method | Clear | (Inherited from ICollection IAstNodeMatch .)
Public method | Contains | (Inherited from ICollection IAstNodeMatch .)
Public method | CopyTo | (Inherited from ICollection IAstNodeMatch .)
Public method | GetEnumerator | (Inherited from IEnumerable IAstNodeMatch .)
Public method | IndexOf | (Inherited from IList IAstNodeMatch .)
Public method | Insert | (Inherited from IList IAstNodeMatch .)
Public method | Remove | (Inherited from ICollection IAstNodeMatch .)
Public method | RemoveAt | (Inherited from IList IAstNodeMatch .)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection Properties

IAstNodeMatchCollection Properties

The IAstNodeMatchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IAstNodeMatch .)
Public property | EndOffset | Gets the end offset of this match collection.
Public property | IsReadOnly | (Inherited from ICollection IAstNodeMatch .)
Public property | Item | (Inherited from IList IAstNodeMatch .)
Public property | StartOffset | Gets the end offset of this match collection.
Top
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection.EndOffset Property

IAstNodeMatchCollectionEndOffset Property
Gets the end offset of this match collection.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The end offset of this match collection.
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection.StartOffset Property

IAstNodeMatchCollectionStartOffset Property
Gets the end offset of this match collection.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The end offset of this match collection.
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IAstNodeMatchCollection Methods

IAstNodeMatchCollection Methods

The IAstNodeMatchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IAstNodeMatch .)
Public method | Clear | (Inherited from ICollection IAstNodeMatch .)
Public method | Contains | (Inherited from ICollection IAstNodeMatch .)
Public method | CopyTo | (Inherited from ICollection IAstNodeMatch .)
Public method | GetEnumerator | (Inherited from IEnumerable IAstNodeMatch .)
Public method | IndexOf | (Inherited from IList IAstNodeMatch .)
Public method | Insert | (Inherited from IList IAstNodeMatch .)
Public method | Remove | (Inherited from ICollection IAstNodeMatch .)
Public method | RemoveAt | (Inherited from IList IAstNodeMatch .)
Top
See Also

Reference

IAstNodeMatchCollection Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParseData Interface

ILLParseData Interface
Provides the base requirements for an object that stores the results of a ILLParser parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILLParseData : IParseData,
    IParseErrorProvider
Public Interface ILLParseData
    Inherits IParseData, IParseErrorProvider

The ILLParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result.
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParseData Properties

ILLParseData Properties

The ILLParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets the object that contains the abstract syntax tree result.
Public property | Errors | Gets the collection of IParseError objects that specify parse errors. (Inherited from IParseErrorProvider.)
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created. (Inherited from IParseErrorProvider.)
Top
See Also

Reference

ILLParseData Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParseData.Ast Property

ILLParseDataAst Property
Gets the object that contains the abstract syntax tree result.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode Ast { get; }
ReadOnly Property Ast As IAstNode
    Get

Property Value

Type: IAstNode
The object that contains the abstract syntax tree result.
See Also

Reference

ILLParseData Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser Interface

ILLParser Interface
Provides the base requirements of an IParser that executes based on a Grammar definition.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILLParser : IParser,
    IKeyedObject
Public Interface ILLParser
    Inherits IParser, IKeyedObject

The ILLParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from IParser.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser Properties

ILLParser Properties

The ILLParser type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser.Grammar Property

ILLParserGrammar Property
Gets the Grammar that is used by this parser.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Grammar Grammar { get; }
ReadOnly Property Grammar As Grammar
    Get

Property Value

Type: Grammar
The Grammar that is used by this parser.
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser Methods

ILLParser Methods

The ILLParser type exposes the following members.

Methods
 | Name | Description
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Inherited from IParser.)
Top
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ILLParser.CreateTokenReader Method

ILLParserCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.
See Also

Reference

ILLParser Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition Interface

IMatchCondition Interface
Provides the base requirements for a match condition for an EbnfTerm.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IMatchCondition
Public Interface IMatchCondition

The IMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Top
Methods
 | Name | Description
Public method | GetFirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition Properties

IMatchCondition Properties

The IMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Top
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition.CallbackCount Property

IMatchConditionCallbackCount Property
Gets the number of callbacks.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int CallbackCount { get; }
ReadOnly Property CallbackCount As Integer
    Get

Property Value

Type: Int32
The number of callbacks.
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition Methods

IMatchCondition Methods

The IMatchCondition type exposes the following members.

Methods
 | Name | Description
Public method | GetFirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IMatchCondition.GetFirstSet Method

IMatchConditionGetFirstSet Method
Returns the collection of terminals that provide the first-set for the match condition.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<Terminal> GetFirstSet(
    Grammar grammar
)
Function GetFirstSet (
    grammar As Grammar
) As IEnumerable(Of Terminal)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar

[Missing <param name="grammar"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.IMatchCondition.GetFirstSet(ActiproSoftware.Text.Parsing.LLParser.Implementation.Grammar)"]

Return Value

Type: IEnumerable Terminal
The collection of terminals that provide the first-set for the match condition.
See Also

Reference

IMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Class

InvalidGrammarException Class
An exception that is thrown when a grammar is invalid.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Text.Parsing.LLParserInvalidGrammarException

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvalidGrammarException : Exception
Public Class InvalidGrammarException
    Inherits Exception

The InvalidGrammarException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidGrammarException | Initializes a new instance of the InvalidGrammarException class.
Public method | InvalidGrammarException(String) | Initializes a new instance of the InvalidGrammarException class with a specified error message.
Public method | InvalidGrammarException(String, Exception) | Initializes a new instance of the InvalidGrammarException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor

InvalidGrammarException Constructor
Overload List
 | Name | Description
Public method | InvalidGrammarException | Initializes a new instance of the InvalidGrammarException class.
Public method | InvalidGrammarException(String) | Initializes a new instance of the InvalidGrammarException class with a specified error message.
Public method | InvalidGrammarException(String, Exception) | Initializes a new instance of the InvalidGrammarException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidGrammarException Class
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor

InvalidGrammarException Constructor
Initializes a new instance of the InvalidGrammarException class.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidGrammarException()
Public Sub New
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor (String)

InvalidGrammarException Constructor (String)
Initializes a new instance of the InvalidGrammarException class with a specified error message.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidGrammarException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Constructor (String, Exception)

InvalidGrammarException Constructor (String, Exception)
Initializes a new instance of the InvalidGrammarException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidGrammarException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

InvalidGrammarException Class
InvalidGrammarException Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Properties

InvalidGrammarException Properties

The InvalidGrammarException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
See Also

Reference

InvalidGrammarException Class
ActiproSoftware.Text.Parsing.LLParser Namespace


InvalidGrammarException Methods

InvalidGrammarException Methods

The InvalidGrammarException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

InvalidGrammarException Class
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult Interface

IParserErrorResult Interface
Provides the base requirements for the result provided by a ParserErrorCallback.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParserErrorResult
Public Interface IParserErrorResult

The IParserErrorResult type exposes the following members.

Properties
 | Name | Description
Public property | CanContinue | Gets whether to continue parsing and put an error token in place of the term that errored.
Public property | CanReportError | Gets whether the error should still be reported when appropriate.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult Properties

IParserErrorResult Properties

The IParserErrorResult type exposes the following members.

Properties
 | Name | Description
Public property | CanContinue | Gets whether to continue parsing and put an error token in place of the term that errored.
Public property | CanReportError | Gets whether the error should still be reported when appropriate.
Top
See Also

Reference

IParserErrorResult Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult.CanContinue Property

IParserErrorResultCanContinue Property
Gets whether to continue parsing and put an error token in place of the term that errored.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanContinue { get; }
ReadOnly Property CanContinue As Boolean
    Get

Property Value

Type: Boolean
true if the parser should continue and put an error token in place of the term that errored; otherwise, false.
See Also

Reference

IParserErrorResult Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserErrorResult.CanReportError Property

IParserErrorResultCanReportError Property
Gets whether the error should still be reported when appropriate.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanReportError { get; }
ReadOnly Property CanReportError As Boolean
    Get

Property Value

Type: Boolean
true if the error should still be reported when appropriate; otherwise, false.
See Also

Reference

IParserErrorResult Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState Interface

IParserState Interface
Provides the base requirements for an object that tracks the current state of a ILLParser.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IParserState
Public Interface IParserState

The IParserState type exposes the following members.

Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
Methods
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState Properties

IParserState Properties

The IParserState type exposes the following members.

Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.AstNodeBuilder Property

IParserStateAstNodeBuilder Property
Gets the IAstNodeBuilder to use for constructing AST node results.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNodeBuilder AstNodeBuilder { get; }
ReadOnly Property AstNodeBuilder As IAstNodeBuilder
    Get

Property Value

Type: IAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.CustomData Property

IParserStateCustomData Property
Gets or sets custom data that can be altered during a parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object CustomData { get; set; }
Property CustomData As Object
    Get
    Set

Property Value

Type: Object
Custom data that can be altered during a parsing operation.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ParseErrors Property

IParserStateParseErrors Property
Gets the collection of IParseError objects that will be returned in the IParseData parsing result.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> ParseErrors { get; }
ReadOnly Property ParseErrors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that will be returned in the IParseData parsing result.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.Parser Property

IParserStateParser Property
Gets the ILLParser for which this state is tracking data.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ILLParser Parser { get; }
ReadOnly Property Parser As ILLParser
    Get

Property Value

Type: ILLParser
The ILLParser for which this state is tracking data
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.Snapshot Property

IParserStateSnapshot Property
Gets the ITextSnapshot used to initiate the parsing operation, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.TokenReader Property

IParserStateTokenReader Property
Gets the ITokenReader that is used to read tokens during the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITokenReader TokenReader { get; }
ReadOnly Property TokenReader As ITokenReader
    Get

Property Value

Type: ITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.UntargetableParseErrorTokenIds Property

IParserStateUntargetableParseErrorTokenIds Property
Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<int> UntargetableParseErrorTokenIds { get; set; }
Property UntargetableParseErrorTokenIds As IEnumerable(Of Integer)
    Get
    Set

Property Value

Type: IEnumerable Int32
The collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Remarks
If a parse error is reported without a target token, the parser will normally place the parse error at the next token. If that token is one of the IDs found in this collection, the parse error will appear after the previous token instead. This property should be set to a collection of any IDs for visually-insignificant tokens that can be passed to the parser such as a line feed, line continuation, document end, etc.
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState Methods

IParserState Methods
Methods
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method

IParserStateReportError Method
Overload List
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method (IParseError)

IParserStateReportError Method (IParseError)
Reports an IParseError.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ReportError(
    IParseError parseError
)
Sub ReportError (
    parseError As IParseError
)

Parameters

parseError
Type: ActiproSoftware.Text.ParsingIParseError
The IParseError object that contains details about the error.
See Also

Reference

IParserState Interface
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method (ParseErrorLevel, String)

IParserStateReportError Method (ParseErrorLevel, String)
Reports an IParseError, using the look-ahead token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportError(
    ParseErrorLevel level,
    string description
)
Function ReportError (
    level As ParseErrorLevel,
    description As String
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportError Method (ParseErrorLevel, String, IToken)

IParserStateReportError Method (ParseErrorLevel, String, IToken)
Reports an IParseError, using the specified token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportError(
    ParseErrorLevel level,
    string description,
    IToken token
)
Function ReportError (
    level As ParseErrorLevel,
    description As String,
    token As IToken
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine for the error range. If not passed, the look-ahead token is used.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method

IParserStateReportNonTerminalExpectedError Method
Overload List
 | Name | Description
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method (NonTerminal)

IParserStateReportNonTerminalExpectedError Method (NonTerminal)
Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal
)
Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method (NonTerminal, IToken)

IParserStateReportNonTerminalExpectedError Method (NonTerminal, IToken)
Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    IToken token
)
Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    token As IToken
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)

IParserStateReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)
Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    TextPositionRange positionRange
)
Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method

IParserStateReportTerminalExpectedError Method
Overload List
 | Name | Description
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

IParserState Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method (Terminal)

IParserStateReportTerminalExpectedError Method (Terminal)
Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportTerminalExpectedError(
    Terminal terminal
)
Function ReportTerminalExpectedError (
    terminal As Terminal
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method (Terminal, IToken)

IParserStateReportTerminalExpectedError Method (Terminal, IToken)
Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportTerminalExpectedError(
    Terminal terminal,
    IToken token
)
Function ReportTerminalExpectedError (
    terminal As Terminal,
    token As IToken
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


IParserState.ReportTerminalExpectedError Method (Terminal, TextPositionRange)

IParserStateReportTerminalExpectedError Method (Terminal, TextPositionRange)
Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IParseError ReportTerminalExpectedError(
    Terminal terminal,
    TextPositionRange positionRange
)
Function ReportTerminalExpectedError (
    terminal As Terminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.
See Also

Reference

IParserState Interface
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader Interface

ITokenReader Interface
Provides the base requirements for an object that can provide tokens to a ILLParser in a forward-only direction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITokenReader
Public Interface ITokenReader

The ITokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader Properties

ITokenReader Properties

The ITokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.IsAtEnd Property

ITokenReaderIsAtEnd Property
Gets whether the current IToken is at the end of the text buffer.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtEnd { get; }
ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current IToken is at the end of the text buffer; otherwise, false.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.IsParserInErrorState Property

ITokenReaderIsParserInErrorState Property
Gets or sets whether the parser is currently recovering from an error state.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsParserInErrorState { get; set; }
Property IsParserInErrorState As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the parser is currently recovering from an error state; otherwise, false.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.LookAheadToken Property

ITokenReaderLookAheadToken Property
Returns the IToken that is immediately after the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken LookAheadToken { get; }
ReadOnly Property LookAheadToken As IToken
    Get

Property Value

Type: IToken
The IToken that is immediately after the current token.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Offset Property

ITokenReaderOffset Property
Gets the current offset, which is offset after the last Token that was read.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Offset { get; }
ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The current offset, which is offset after the last Token that was read.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.StackLevel Property

ITokenReaderStackLevel Property
Gets the current stack level from Push calls without corresponding Pop calls.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StackLevel { get; }
ReadOnly Property StackLevel As Integer
    Get

Property Value

Type: Int32
The current stack level.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Token Property

ITokenReaderToken Property
Gets the current IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken Token { get; }
ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The current IToken.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader Methods

ITokenReader Methods

The ITokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Top
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Advance Method

ITokenReaderAdvance Method
Advances to the next IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Advance()
Sub Advance
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AdvanceTo Method

ITokenReaderAdvanceTo Method
Overload List
 | Name | Description
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Top
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AdvanceTo Method (Int32)

ITokenReaderAdvanceTo Method (Int32)
Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AdvanceTo(
    int tokenId
)
Function AdvanceTo (
    tokenId As Integer
) As Boolean

Parameters

tokenId
Type: SystemInt32
The ID of IToken for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

ITokenReader Interface
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AdvanceTo Method (Int32[])

ITokenReaderAdvanceTo Method (Int32)
Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AdvanceTo(
    params int[] tokenIds
)
Function AdvanceTo (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The array of IToken IDs for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

ITokenReader Interface
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.AreNext Method

ITokenReaderAreNext Method
Returns whether the next look-ahead tokens match the specified sequence of token IDs.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreNext(
    params int[] tokenIds
)
Function AreNext (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The sequence of token IDs for which to search.

Return Value

Type: Boolean
true if the next look-ahead tokens match the specified sequence of token IDs; otherwise, false.
Remarks
This method is very useful within can-match callbacks that require two or more token look-aheads.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.GetLookAheadToken Method

ITokenReaderGetLookAheadToken Method
Returns the IToken that is the specified number of positions past the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken GetLookAheadToken(
    int count
)
Function GetLookAheadToken (
    count As Integer
) As IToken

Parameters

count
Type: SystemInt32
The number of positions past the current token to examine.

Return Value

Type: IToken
The IToken that is the specified number of positions past the current token.
Remarks
A parameter value of 1 will return the value of the LookAheadToken method without actually seeking past the next token.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.GetTokenText Method

ITokenReaderGetTokenText Method
Returns an IToken's encapsulated text from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetTokenText(
    IToken targetToken
)
Function GetTokenText (
    targetToken As IToken
) As String

Parameters

targetToken
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The IToken's encapsulated text from the text buffer using Newline for line ends.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Initialize Method

ITokenReaderInitialize Method
Initializes the token reader, which will be called by a ILLParser before the token reader is used.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Initialize()
Sub Initialize
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.OffsetToPosition Method

ITokenReaderOffsetToPosition Method
Returns the TextPosition that represents the specified offset within the text lines.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition OffsetToPosition(
    int offset
)
Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the snapshot.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the text lines.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Pop Method

ITokenReaderPop Method
Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Pop()
Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITokenReader.Push Method

ITokenReaderPush Method
Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Push()
Sub Push
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

ITokenReader Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode Interface

ITreeConstructionNode Interface
Provides the base requirements for tree construction node, used to output an IAstNode for an EbnfProduction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITreeConstructionNode
Public Interface ITreeConstructionNode

The ITreeConstructionNode type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode Properties

ITreeConstructionNode Properties

The ITreeConstructionNode type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.IsCompiled Property

ITreeConstructionNodeIsCompiled Property
Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsCompiled { get; }
ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.IsList Property

ITreeConstructionNodeIsList Property
Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsList { get; }
ReadOnly Property IsList As Boolean
    Get

Property Value

Type: Boolean
true if this node creates a list of IAstNode results.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode Methods

ITreeConstructionNode Methods

The ITreeConstructionNode type exposes the following members.

Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form.
Top
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.CreateNode Method

ITreeConstructionNodeCreateNode Method
Returns the IAstNode that is created for this tree construction node.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAstNode CreateNode(
    IAstNodeMatchCollection matches
)
Function CreateNode (
    matches As IAstNodeMatchCollection
) As IAstNode

Parameters

matches
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeMatchCollection
The collection of matched IAstNode objects within the current IAstNodeBuilder scope.

Return Value

Type: IAstNode
The IAstNode that is created for this tree construction node.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITreeConstructionNode.ToEbnfString Method

ITreeConstructionNodeToEbnfString Method
Outputs the contents of the production rule in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ToEbnfString()
Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the production rule.
See Also

Reference

ITreeConstructionNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode) Interface

ITypedTreeConstructionNodeTAstNode Interface
Provides the base requirements for tree construction node, used to output a specific type of IAstNode for an EbnfProduction.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITypedTreeConstructionNode<TAstNode> : ITreeConstructionNode
where TAstNode : class, IAstNode

Public Interface ITypedTreeConstructionNode(Of TAstNode As {Class, IAstNode})
    Inherits ITreeConstructionNode

Type Parameters

TAstNode
The type of IAstNode.

The ITypedTreeConstructionNodeTAstNode type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from ITreeConstructionNode.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from ITreeConstructionNode.)
Top
Methods
 | Name | Description
Public method | AddToCollectionPropertyTItem | Creates an ITreePropertyConstructionNode that adds values from one or more specified ITreeConstructionNode constructed nodes to a collection property.
Public method | AppendToPropertyTProperty | Creates an ITreePropertyConstructionNode that appends a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from ITreeConstructionNode.)
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form. (Inherited from ITreeConstructionNode.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode) Properties

ITypedTreeConstructionNodeTAstNode Properties

The ITypedTreeConstructionNodeTAstNode generic type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from ITreeConstructionNode.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from ITreeConstructionNode.)
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode) Methods

ITypedTreeConstructionNodeTAstNode Methods

The ITypedTreeConstructionNodeTAstNode generic type exposes the following members.

Methods
 | Name | Description
Public method | AddToCollectionPropertyTItem | Creates an ITreePropertyConstructionNode that adds values from one or more specified ITreeConstructionNode constructed nodes to a collection property.
Public method | AppendToPropertyTProperty | Creates an ITreePropertyConstructionNode that appends a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from ITreeConstructionNode.)
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.
Public method | ToEbnfString | Outputs the contents of the production rule in EBNF form. (Inherited from ITreeConstructionNode.)
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).AddToCollectionProperty(TItem) Method

ITypedTreeConstructionNodeTAstNodeAddToCollectionPropertyTItem Method
Creates an ITreePropertyConstructionNode that adds values from one or more specified ITreeConstructionNode constructed nodes to a collection property.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> AddToCollectionProperty<TItem>(
    Expression<Func<TAstNode, ICollection<TItem>>> expression,
    params ITreeConstructionNode[] children
)

Function AddToCollectionProperty(Of TItem) (
    expression As Expression(Of Func(Of TAstNode, ICollection(Of TItem))),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, ICollection TItem
The lambda expression indicating the collection property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TItem
The type of collection item.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, and AST node (any IAstNode-based class) property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string collection property type, the string values of the constructed nodes are added as items to the collection property. In the case of an integer collection property type, the numeric values of the constructed nodes are added as items to the collection property. In the case of a boolean collection property type, the boolean values of the constructed nodes are added as items to the collection property. In the case of an AST node collection type, the nodes are added as items to the collection property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).AppendToProperty(TProperty) Method

ITypedTreeConstructionNodeTAstNodeAppendToPropertyTProperty Method
Creates an ITreePropertyConstructionNode that appends a value to a property using the specified ITreeConstructionNode constructed nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> AppendToProperty<TProperty>(
    Expression<Func<TAstNode, TProperty>> expression,
    params ITreeConstructionNode[] children
)

Function AppendToProperty(Of TProperty) (
    expression As Expression(Of Func(Of TAstNode, TProperty)),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, TProperty
The lambda expression indicating the property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, and flags enumeration property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string property type, the string values of the constructed nodes are concatenated to form the value appended to the property. In the case of an integer property type, the numeric values of the constructed nodes are added together to form the value appended to the property. In the case of a boolean property type, the boolean values of the constructed nodes are or'ed together to form the value appended to the property. In the case of a flags enumeration property type, the constructed node values are matched against enumeration value names, or'ed together, and the result is used as the value appended to the property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetCollectionItemProperties Method

ITypedTreeConstructionNodeTAstNodeSetCollectionItemProperties Method
Overload List
 | Name | Description
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.
Public method | SetCollectionItemPropertiesTItem, TProperty(ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetCollectionItemProperties(TItem, TProperty) Method (Expression(Func(TAstNode, ICollection(TItem))), Expression(Func(TItem, TProperty)), ITreeConstructionNode[])

ITypedTreeConstructionNodeTAstNodeSetCollectionItemPropertiesTItem, TProperty Method (ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, ITreeConstructionNode)
Creates an ITreePropertyConstructionNode that sets a value to a property on each item in a collection property using the specified ITreeConstructionNode constructed nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetCollectionItemProperties<TItem, TProperty>(
    Expression<Func<TAstNode, ICollection<TItem>>> expression1,
    Expression<Func<TItem, TProperty>> expression2,
    params ITreeConstructionNode[] children
)
where TItem : new(), IAstNode

Function SetCollectionItemProperties(Of TItem As {New, IAstNode}, TProperty) (
    expression1 As Expression(Of Func(Of TAstNode, ICollection(Of TItem))),
    expression2 As Expression(Of Func(Of TItem, TProperty)),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression1
Type: System.Linq.ExpressionsExpression Func TAstNode, ICollection TItem
The lambda expression indicating the collection property to update.
expression2
Type: System.Linq.ExpressionsExpression Func TItem, TProperty
The lambda expression indicating the item property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TItem
The type of collection item type.
TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, enumeration, and AST node (any IAstNode-based class) property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string property type, the string values of the constructed nodes are concatenated to form the value set to the property. In the case of an integer property type, the numeric values of the constructed nodes are added together to form the value set to the property. In the case of a boolean property type, the boolean values of the constructed nodes are or'ed together to form the value set to the property. In the case of an enumeration property type, the first constructed node value is matched against an enumeration value name and is used as the value set to the property. In the case of a flags enumeration property type, the constructed node values are matched against enumeration value names, or'ed together, and the result is used as the value set to the property. In the case of an AST node type, the first constructed node is the value set to the property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetCollectionItemProperties Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetCollectionItemProperties(TItem, TProperty) Method (Expression(Func(TAstNode, ICollection(TItem))), Expression(Func(TItem, TProperty)), Object)

ITypedTreeConstructionNodeTAstNodeSetCollectionItemPropertiesTItem, TProperty Method (ExpressionFuncTAstNode, ICollectionTItem, ExpressionFuncTItem, TProperty, Object)
Creates an ITreePropertyConstructionNode that sets a single explicit value to a property on each item in a collection property.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetCollectionItemProperties<TItem, TProperty>(
    Expression<Func<TAstNode, ICollection<TItem>>> expression1,
    Expression<Func<TItem, TProperty>> expression2,
    Object explicitValue
)
where TItem : new(), IAstNode

Function SetCollectionItemProperties(Of TItem As {New, IAstNode}, TProperty) (
    expression1 As Expression(Of Func(Of TAstNode, ICollection(Of TItem))),
    expression2 As Expression(Of Func(Of TItem, TProperty)),
    explicitValue As Object
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression1
Type: System.Linq.ExpressionsExpression Func TAstNode, ICollection TItem
The lambda expression indicating the collection property to update.
expression2
Type: System.Linq.ExpressionsExpression Func TItem, TProperty
The lambda expression indicating the item property to update.
explicitValue
Type: SystemObject
The explicit value to set.

Type Parameters

TItem
The type of collection item type.
TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetCollectionItemProperties Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetProperty Method

ITypedTreeConstructionNodeTAstNodeSetProperty Method
Overload List
 | Name | Description
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, ITreeConstructionNode) | Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.
Public method | SetPropertyTProperty(ExpressionFuncTAstNode, TProperty, Object) | Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.
Top
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetProperty(TProperty) Method (Expression(Func(TAstNode, TProperty)), ITreeConstructionNode[])

ITypedTreeConstructionNodeTAstNodeSetPropertyTProperty Method (ExpressionFuncTAstNode, TProperty, ITreeConstructionNode)
Creates an ITreePropertyConstructionNode that sets a value to a property using the specified ITreeConstructionNode constructed nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetProperty<TProperty>(
    Expression<Func<TAstNode, TProperty>> expression,
    params ITreeConstructionNode[] children
)

Function SetProperty(Of TProperty) (
    expression As Expression(Of Func(Of TAstNode, TProperty)),
    ParamArray children As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, TProperty
The lambda expression indicating the property to update.
children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
Remarks
String, integer, boolean, enumeration, and AST node (any IAstNode-based class) property types are supported.

Multiple ITreeConstructionNode constructed nodes can be passed to this method. In the case of a string property type, the string values of the constructed nodes are concatenated to form the value set to the property. In the case of an integer property type, the numeric values of the constructed nodes are added together to form the value set to the property. In the case of a boolean property type, the boolean values of the constructed nodes are or'ed together to form the value set to the property. In the case of an enumeration property type, the first constructed node value is matched against an enumeration value name and is used as the value set to the property. In the case of a flags enumeration property type, the constructed node values are matched against enumeration value names, or'ed together, and the result is used as the value set to the property. In the case of an AST node type, the first constructed node is the value set to the property.

See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetProperty Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ITypedTreeConstructionNode(TAstNode).SetProperty(TProperty) Method (Expression(Func(TAstNode, TProperty)), Object)

ITypedTreeConstructionNodeTAstNodeSetPropertyTProperty Method (ExpressionFuncTAstNode, TProperty, Object)
Creates an ITreePropertyConstructionNode that sets a single explicit value to a property.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITypedTreeConstructionNode<TAstNode> SetProperty<TProperty>(
    Expression<Func<TAstNode, TProperty>> expression,
    Object explicitValue
)

Function SetProperty(Of TProperty) (
    expression As Expression(Of Func(Of TAstNode, TProperty)),
    explicitValue As Object
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

expression
Type: System.Linq.ExpressionsExpression Func TAstNode, TProperty
The lambda expression indicating the property to update.
explicitValue
Type: SystemObject
The explicit value to set.

Type Parameters

TProperty
The property type.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode upon which the property was created.
See Also

Reference

ITypedTreeConstructionNodeTAstNode Interface
SetProperty Overload
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback Class

ParserCallback Class
Defines a callback method that can be executed during a parsing operation.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.Text.Parsing.LLParserParserCallback

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ParserCallback : MulticastDelegate
Public NotInheritable Class ParserCallback
    Inherits MulticastDelegate

The ParserCallback type exposes the following members.

Constructors
 | Name | Description
Public method | ParserCallback | Initializes a new instance of the ParserCallback class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback Constructor

ParserCallback Constructor
Initializes a new instance of the ParserCallback class

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserCallback(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ParserCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback Properties

ParserCallback Properties

The ParserCallback type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

ParserCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback Methods

ParserCallback Methods

The ParserCallback type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParserCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback.BeginInvoke Method

ParserCallbackBeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    IParserState state,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    state As IParserState,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState

[Missing <param name="state"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

See Also

Reference

ParserCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback.EndInvoke Method

ParserCallbackEndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void EndInvoke(
    IAsyncResult result
)
Public Overridable Sub EndInvoke (
    result As IAsyncResult
)

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ParserCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCallback.Invoke Method

ParserCallbackInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Invoke(
    IParserState state
)
Public Overridable Sub Invoke (
    state As IParserState
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState

[Missing <param name="state"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

See Also

Reference

ParserCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback Class

ParserCanMatchCallback Class
Defines a can-match callback method that can be executed during a parsing operation for a NonTerminal.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.Text.Parsing.LLParserParserCanMatchCallback

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ParserCanMatchCallback : MulticastDelegate
Public NotInheritable Class ParserCanMatchCallback
    Inherits MulticastDelegate

Return Value

Type:
true if the NonTerminal can match with the current state; otherwise, false.

The ParserCanMatchCallback type exposes the following members.

Constructors
 | Name | Description
Public method | ParserCanMatchCallback | Initializes a new instance of the ParserCanMatchCallback class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback Constructor

ParserCanMatchCallback Constructor
Initializes a new instance of the ParserCanMatchCallback class

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserCanMatchCallback(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ParserCanMatchCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback Properties

ParserCanMatchCallback Properties

The ParserCanMatchCallback type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

ParserCanMatchCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback Methods

ParserCanMatchCallback Methods

The ParserCanMatchCallback type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParserCanMatchCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback.BeginInvoke Method

ParserCanMatchCallbackBeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    IParserState state,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    state As IParserState,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState

[Missing <param name="state"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

See Also

Reference

ParserCanMatchCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback.EndInvoke Method

ParserCanMatchCallbackEndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool EndInvoke(
    IAsyncResult result
)
Public Overridable Function EndInvoke (
    result As IAsyncResult
) As Boolean

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.EndInvoke(System.IAsyncResult)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ParserCanMatchCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserCanMatchCallback.Invoke Method

ParserCanMatchCallbackInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Invoke(
    IParserState state
)
Public Overridable Function Invoke (
    state As IParserState
) As Boolean

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState

[Missing <param name="state"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserCanMatchCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

See Also

Reference

ParserCanMatchCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback Class

ParserErrorCallback Class
Defines an error callback method that can be executed during a parsing operation.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.Text.Parsing.LLParserParserErrorCallback

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ParserErrorCallback : MulticastDelegate
Public NotInheritable Class ParserErrorCallback
    Inherits MulticastDelegate

Return Value

Type:
An IParserErrorResult value indicating a result.

The ParserErrorCallback type exposes the following members.

Constructors
 | Name | Description
Public method | ParserErrorCallback | Initializes a new instance of the ParserErrorCallback class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback Constructor

ParserErrorCallback Constructor
Initializes a new instance of the ParserErrorCallback class

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserErrorCallback(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

ParserErrorCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback Properties

ParserErrorCallback Properties

The ParserErrorCallback type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

ParserErrorCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback Methods

ParserErrorCallback Methods

The ParserErrorCallback type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParserErrorCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback.BeginInvoke Method

ParserErrorCallbackBeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    IParserState state,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    state As IParserState,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState

[Missing <param name="state"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.BeginInvoke(ActiproSoftware.Text.Parsing.LLParser.IParserState,System.AsyncCallback,System.Object)"]

See Also

Reference

ParserErrorCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback.EndInvoke Method

ParserErrorCallbackEndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IParserErrorResult EndInvoke(
    IAsyncResult result
)
Public Overridable Function EndInvoke (
    result As IAsyncResult
) As IParserErrorResult

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.EndInvoke(System.IAsyncResult)"]

Return Value

Type: IParserErrorResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.EndInvoke(System.IAsyncResult)"]

See Also

Reference

ParserErrorCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorCallback.Invoke Method

ParserErrorCallbackInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IParserErrorResult Invoke(
    IParserState state
)
Public Overridable Function Invoke (
    state As IParserState
) As IParserErrorResult

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState

[Missing <param name="state"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

Return Value

Type: IParserErrorResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.ParserErrorCallback.Invoke(ActiproSoftware.Text.Parsing.LLParser.IParserState)"]

See Also

Reference

ParserErrorCallback Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults Class

ParserErrorResults Class
Provides access to the built-in IParserErrorResult instances, that indicate a result provided by a ParserErrorCallback.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParserParserErrorResults

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class ParserErrorResults
Public NotInheritable Class ParserErrorResults

The ParserErrorResults type exposes the following members.

Properties
Name | Description
Continue | Gets the IParserErrorResult that indicates to potentially report errors but continue on.
Default | Gets the IParserErrorResult that indicates to potentially report errors and return a match failure.
Ignore | Gets the IParserErrorResult that indicates to never report errors and continue on.
NoReport | Gets the IParserErrorResult that indicates to never report errors and return a match failure.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults Properties

ParserErrorResults Properties

The ParserErrorResults type exposes the following members.

Properties
Name | Description
Continue | Gets the IParserErrorResult that indicates to potentially report errors but continue on.
Default | Gets the IParserErrorResult that indicates to potentially report errors and return a match failure.
Ignore | Gets the IParserErrorResult that indicates to never report errors and continue on.
NoReport | Gets the IParserErrorResult that indicates to never report errors and return a match failure.
Top
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.Continue Property

ParserErrorResultsContinue Property
Gets the IParserErrorResult that indicates to potentially report errors but continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParserErrorResult Continue { get; }
Public Shared ReadOnly Property Continue As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to potentially report errors but continue on.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.Default Property

ParserErrorResultsDefault Property
Gets the IParserErrorResult that indicates to potentially report errors and return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParserErrorResult Default { get; }
Public Shared ReadOnly Property Default As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to potentially report errors and return a match failure.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.Ignore Property

ParserErrorResultsIgnore Property
Gets the IParserErrorResult that indicates to never report errors and continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParserErrorResult Ignore { get; }
Public Shared ReadOnly Property Ignore As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to never report errors and continue on.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ParserErrorResults.NoReport Property

ParserErrorResultsNoReport Property
Gets the IParserErrorResult that indicates to never report errors and return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IParserErrorResult NoReport { get; }
Public Shared ReadOnly Property NoReport As IParserErrorResult
    Get

Property Value

Type: IParserErrorResult
The IParserErrorResult that indicates to never report errors and return a match failure.
See Also

Reference

ParserErrorResults Class
ActiproSoftware.Text.Parsing.LLParser Namespace


ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace
Contains types related to the debugging of an LL parser.
Classes
 | Class | Description
Public class | DebuggerMode | Specifies the mode that an IDebugger is in.
Interfaces
 | Interface | Description
Public interface | IBreakpoint | Provides the base requirements for a breakpoint within an IDebugger.
Public interface | IDebuggableAstNode | Provides the base requirements for a debuggable IAstNode.
Public interface | IDebuggableAstNodeMatch | Provides the base requirements for a debuggable IAstNodeMatch.
Public interface | IDebuggableEbnfTerm | Provides the base requirements for a debuggable EbnfTerm.
Public interface | IDebuggableMatchCondition | Provides the base requirements for a debuggable IMatchCondition.
Public interface | IDebuggableNonTerminal | Provides the base requirements for a debuggable NonTerminal.
Public interface | IDebuggableSymbol | Provides the base requirements for a debuggable Symbol.
Public interface | IDebuggableTerminal | Provides the base requirements for a debuggable Terminal.
Public interface | IDebugger | Provides the base requirements for a Grammar debugger that can control parser execution and obtain detailed information about parser state.
Public interface | IDebuggerState | Provides the base requirements for an object that contains information about the current IDebugger state.


DebuggerMode Class

DebuggerMode Class
Specifies the mode that an IDebugger is in.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.Parsing.LLParser.DebuggingDebuggerMode

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DebuggerMode : Enum
Public NotInheritable Class DebuggerMode
    Inherits Enum

The DebuggerMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Paused | The debugger is paused at a breakpoint.
 | Running | The debugger is running.
 | Stopped | The debugger is not running.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


DebuggerMode Methods

DebuggerMode Methods

The DebuggerMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DebuggerMode Class
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


DebuggerMode Fields

DebuggerMode Fields

The DebuggerMode type exposes the following members.

Fields
 | Name | Description
 | Paused | The debugger is paused at a breakpoint.
 | Running | The debugger is running.
 | Stopped | The debugger is not running.
Public field | value__ |
Top
See Also

Reference

DebuggerMode Class
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


DebuggerMode.Paused Field

DebuggerModePaused Field
The debugger is paused at a breakpoint.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DebuggerMode Paused = 2
Public Const Paused As DebuggerMode = 2

Field Value

Type: DebuggerMode
See Also

Reference

DebuggerMode Class
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


DebuggerMode.Running Field

DebuggerModeRunning Field
The debugger is running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DebuggerMode Running = 1
Public Const Running As DebuggerMode = 1

Field Value

Type: DebuggerMode
See Also

Reference

DebuggerMode Class
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


DebuggerMode.Stopped Field

DebuggerModeStopped Field
The debugger is not running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DebuggerMode Stopped = 0
Public Const Stopped As DebuggerMode = 0

Field Value

Type: DebuggerMode
See Also

Reference

DebuggerMode Class
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


DebuggerMode.value__ Field

DebuggerModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Parsing.LLParser.Debugging.DebuggerMode.value__"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DebuggerMode Class
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IBreakpoint Interface

IBreakpoint Interface
Provides the base requirements for a breakpoint within an IDebugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IBreakpoint
Public Interface IBreakpoint

The IBreakpoint type exposes the following members.

Properties
 | Name | Description
Public property | Symbol | Gets the IDebuggableSymbol at which to break.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IBreakpoint Properties

IBreakpoint Properties

The IBreakpoint type exposes the following members.

Properties
 | Name | Description
Public property | Symbol | Gets the IDebuggableSymbol at which to break.
Top
See Also

Reference

IBreakpoint Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IBreakpoint.Symbol Property

IBreakpointSymbol Property
Gets the IDebuggableSymbol at which to break.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDebuggableSymbol Symbol { get; }
ReadOnly Property Symbol As IDebuggableSymbol
    Get

Property Value

Type: IDebuggableSymbol
The IDebuggableSymbol at which to break.
See Also

Reference

IBreakpoint Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode Interface

IDebuggableAstNode Interface
Provides the base requirements for a debuggable IAstNode.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableAstNode
Public Interface IDebuggableAstNode

The IDebuggableAstNode type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the end offset of this AST node, if known.
Public property | StartOffset | Gets the start offset of this AST node, if known.
Public property | TreeString | Gets the AST node string representation.
Public property | Value | Gets the AST node value.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode Properties

IDebuggableAstNode Properties

The IDebuggableAstNode type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets the end offset of this AST node, if known.
Public property | StartOffset | Gets the start offset of this AST node, if known.
Public property | TreeString | Gets the AST node string representation.
Public property | Value | Gets the AST node value.
Top
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.EndOffset Property

IDebuggableAstNodeEndOffset Property
Gets the end offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> EndOffset { get; }
ReadOnly Property EndOffset As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The end offset of this AST node, if known.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.StartOffset Property

IDebuggableAstNodeStartOffset Property
Gets the start offset of this AST node, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> StartOffset { get; }
ReadOnly Property StartOffset As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The start offset of this AST node, if known.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.TreeString Property

IDebuggableAstNodeTreeString Property
Gets the AST node string representation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string TreeString { get; }
ReadOnly Property TreeString As String
    Get

Property Value

Type: String
The AST node string representation.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNode.Value Property

IDebuggableAstNodeValue Property
Gets the AST node value.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Value { get; }
ReadOnly Property Value As String
    Get

Property Value

Type: String
The AST node value.
See Also

Reference

IDebuggableAstNode Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch Interface

IDebuggableAstNodeMatch Interface
Provides the base requirements for a debuggable IAstNodeMatch.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableAstNodeMatch
Public Interface IDebuggableAstNodeMatch

The IDebuggableAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets the IDebuggableAstNode that was matched.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch Properties

IDebuggableAstNodeMatch Properties

The IDebuggableAstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets the IDebuggableAstNode that was matched.
Top
See Also

Reference

IDebuggableAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch.Label Property

IDebuggableAstNodeMatchLabel Property
Gets the optional label applied to the match that can be used for identification during tree construction.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Label { get; }
ReadOnly Property Label As String
    Get

Property Value

Type: String
The optional label applied to the match that can be used for identification during tree construction.
See Also

Reference

IDebuggableAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableAstNodeMatch.Node Property

IDebuggableAstNodeMatchNode Property
Gets the IDebuggableAstNode that was matched.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDebuggableAstNode Node { get; }
ReadOnly Property Node As IDebuggableAstNode
    Get

Property Value

Type: IDebuggableAstNode
The IDebuggableAstNode that was matched.
See Also

Reference

IDebuggableAstNodeMatch Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm Interface

IDebuggableEbnfTerm Interface
Provides the base requirements for a debuggable EbnfTerm.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableEbnfTerm
Public Interface IDebuggableEbnfTerm

The IDebuggableEbnfTerm type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets or sets the compiled TextPositionRange of the node within an EBNF representation of the grammar.
Public property | MatchCondition | Gets the IDebuggableMatchCondition to use for this term.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm Properties

IDebuggableEbnfTerm Properties

The IDebuggableEbnfTerm type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets or sets the compiled TextPositionRange of the node within an EBNF representation of the grammar.
Public property | MatchCondition | Gets the IDebuggableMatchCondition to use for this term.
Top
See Also

Reference

IDebuggableEbnfTerm Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm.EbnfPositionRange Property

IDebuggableEbnfTermEbnfPositionRange Property
Gets or sets the compiled TextPositionRange of the node within an EBNF representation of the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange EbnfPositionRange { get; }
ReadOnly Property EbnfPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The compiled TextPositionRange of the node within an EBNF representation of the grammar.
See Also

Reference

IDebuggableEbnfTerm Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableEbnfTerm.MatchCondition Property

IDebuggableEbnfTermMatchCondition Property
Gets the IDebuggableMatchCondition to use for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDebuggableMatchCondition MatchCondition { get; }
ReadOnly Property MatchCondition As IDebuggableMatchCondition
    Get

Property Value

Type: IDebuggableMatchCondition
The IDebuggableMatchCondition to use for this term.
See Also

Reference

IDebuggableEbnfTerm Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition Interface

IDebuggableMatchCondition Interface
Provides the base requirements for a debuggable IMatchCondition.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableMatchCondition
Public Interface IDebuggableMatchCondition

The IDebuggableMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Public property | FirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition Properties

IDebuggableMatchCondition Properties

The IDebuggableMatchCondition type exposes the following members.

Properties
 | Name | Description
Public property | CallbackCount | Gets the number of callbacks.
Public property | FirstSet | Returns the collection of terminals that provide the first-set for the match condition.
Top
See Also

Reference

IDebuggableMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition.CallbackCount Property

IDebuggableMatchConditionCallbackCount Property
Gets the number of callbacks.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int CallbackCount { get; }
ReadOnly Property CallbackCount As Integer
    Get

Property Value

Type: Int32
The number of callbacks.
See Also

Reference

IDebuggableMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableMatchCondition.FirstSet Property

IDebuggableMatchConditionFirstSet Property
Returns the collection of terminals that provide the first-set for the match condition.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IDebuggableTerminal> FirstSet { get; }
ReadOnly Property FirstSet As IEnumerable(Of IDebuggableTerminal)
    Get

Return Value

Type: IEnumerable IDebuggableTerminal
The collection of terminals that provide the first-set for the match condition.
See Also

Reference

IDebuggableMatchCondition Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableNonTerminal Interface

IDebuggableNonTerminal Interface
Provides the base requirements for a debuggable NonTerminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableNonTerminal : IDebuggableSymbol
Public Interface IDebuggableNonTerminal
    Inherits IDebuggableSymbol

The IDebuggableNonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableNonTerminal Properties

IDebuggableNonTerminal Properties

The IDebuggableNonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

IDebuggableNonTerminal Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol Interface

IDebuggableSymbol Interface
Provides the base requirements for a debuggable Symbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableSymbol
Public Interface IDebuggableSymbol

The IDebuggableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar.
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors.
Public property | Key | Gets the string that identifies the symbol.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol Properties

IDebuggableSymbol Properties

The IDebuggableSymbol type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar.
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors.
Public property | Key | Gets the string that identifies the symbol.
Top
See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol.EbnfPositionRange Property

IDebuggableSymbolEbnfPositionRange Property
Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange EbnfPositionRange { get; }
ReadOnly Property EbnfPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The compiled TextPositionRange of the symbol within an EBNF representation of the grammar.
See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol.ErrorAlias Property

IDebuggableSymbolErrorAlias Property
Gets the alias to use for this symbol when reporting errors.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ErrorAlias { get; }
ReadOnly Property ErrorAlias As String
    Get

Property Value

Type: String
The alias to use for this symbol when reporting errors.
Remarks

Terminals always report errors and use their Key if no error alias is specified. Non-terminals will only report errors if an error alias is specified.

See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableSymbol.Key Property

IDebuggableSymbolKey Property
Gets the string that identifies the symbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The string that identifies the symbol.
See Also

Reference

IDebuggableSymbol Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableTerminal Interface

IDebuggableTerminal Interface
Provides the base requirements for a debuggable Terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggableTerminal : IDebuggableSymbol
Public Interface IDebuggableTerminal
    Inherits IDebuggableSymbol

The IDebuggableTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Id | Gets the ID that identifies the terminal.
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableTerminal Properties

IDebuggableTerminal Properties

The IDebuggableTerminal type exposes the following members.

Properties
 | Name | Description
Public property | EbnfPositionRange | Gets the compiled TextPositionRange of the symbol within an EBNF representation of the grammar. (Inherited from IDebuggableSymbol.)
Public property | ErrorAlias | Gets the alias to use for this symbol when reporting errors. (Inherited from IDebuggableSymbol.)
Public property | Id | Gets the ID that identifies the terminal.
Public property | Key | Gets the string that identifies the symbol. (Inherited from IDebuggableSymbol.)
Top
See Also

Reference

IDebuggableTerminal Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggableTerminal.Id Property

IDebuggableTerminalId Property
Gets the ID that identifies the terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<int> Id { get; }
ReadOnly Property Id As Nullable(Of Integer)
    Get

Property Value

Type: Nullable Int32
The ID that identifies the terminal.
See Also

Reference

IDebuggableTerminal Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Interface

IDebugger Interface
Provides the base requirements for a Grammar debugger that can control parser execution and obtain detailed information about parser state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebugger
Public Interface IDebugger

The IDebugger type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Public method | NotifyBreak | Called by the parser to notify the debugger it has paused execution.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Top
Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Properties

IDebugger Properties

The IDebugger type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.IsAttached Property

IDebuggerIsAttached Property
Gets whether the debugger is currently attached to an ICodeDocument.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAttached { get; }
ReadOnly Property IsAttached As Boolean
    Get

Property Value

Type: Boolean
true if the debugger is currently attached to an ICodeDocument; otherwise, false.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Mode Property

IDebuggerMode Property
Gets the current DebuggerMode of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DebuggerMode Mode { get; }
ReadOnly Property Mode As DebuggerMode
    Get

Property Value

Type: DebuggerMode
The current DebuggerMode of the debugger.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.State Property

IDebuggerState Property
Gets the IDebuggerState that contains information about the current state of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDebuggerState State { get; }
ReadOnly Property State As IDebuggerState
    Get

Property Value

Type: IDebuggerState
The IDebuggerState that contains information about the current state of the debugger.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Methods

IDebugger Methods

The IDebugger type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Public method | NotifyBreak | Called by the parser to notify the debugger it has paused execution.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Top
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Attach Method

IDebuggerAttach Method
Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Attach(
    ICodeDocument document
)
Function Attach (
    document As ICodeDocument
) As Boolean

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument to debug.

Return Value

Type: Boolean
true if the debugger was attached; otherwise, false.
Remarks
This method will return false if the debugger is already attached to a document, if the document doesn't have an ISyntaxLanguage, or if the syntax language's IParser isn't an ILLParser.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Detach Method

IDebuggerDetach Method
Detaches from the currently-attached document, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Detach()
Sub Detach
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.NotifyBreak Method

IDebuggerNotifyBreak Method
Called by the parser to notify the debugger it has paused execution.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyBreak()
Sub NotifyBreak
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Pause Method

IDebuggerPause Method
Requests that the debugger pause execution if the it is currently running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Pause()
Sub Pause
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Start Method

IDebuggerStart Method
Starts debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Start()
Function Start As Boolean

Return Value

Type: Boolean
true if debugging started; otherwise, false.
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.StepInto Method

IDebuggerStepInto Method
Steps into the next debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void StepInto()
Sub StepInto
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.StepOut Method

IDebuggerStepOut Method
Steps out of the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void StepOut()
Sub StepOut
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.StepOver Method

IDebuggerStepOver Method
Steps over the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void StepOver()
Sub StepOver
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.Stop Method

IDebuggerStop Method
Stops debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Stop()
Sub Stop
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger Events

IDebugger Events

The IDebugger type exposes the following members.

Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebugger.ModeChanged Event

IDebuggerModeChanged Event
Occurs when the Mode property changes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler ModeChanged
Event ModeChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IDebugger Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState Interface

IDebuggerState Interface
Provides the base requirements for an object that contains information about the current IDebugger state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDebuggerState
Public Interface IDebuggerState

The IDebuggerState type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets the collection of IBreakpoint objects.
Public property | Ebnf | Gets the textual EBNF representation of the grammar.
Public property | IsBreakForCanMatch | Gets whether the current pause is related to a can-match check for an EbnfTerm.
Public property | Matches | Gets the list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.
Public property | NonTerminals | Gets the read-only list of IDebuggableNonTerminal objects defined in the grammar.
Public property | NonTerminalStack | Gets the stack of IDebuggableNonTerminal objects into which the parser has entered.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | RootNode | Gets the root IDebuggableAstNode that has been constructed.
Public property | Terminals | Gets the read-only list of IDebuggableTerminal objects defined in the grammar.
Public property | TermStack | Gets the stack of IDebuggableEbnfTerm objects into which the parser has entered.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Top
Methods
 | Name | Description
Public method | AddBreakpoint | Adds an IBreakpoint for an IDebuggableSymbol.
Public method | RemoveBreakpoint | Removes an IBreakpoint for an IDebuggableSymbol.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState Properties

IDebuggerState Properties

The IDebuggerState type exposes the following members.

Properties
 | Name | Description
Public property | Breakpoints | Gets the collection of IBreakpoint objects.
Public property | Ebnf | Gets the textual EBNF representation of the grammar.
Public property | IsBreakForCanMatch | Gets whether the current pause is related to a can-match check for an EbnfTerm.
Public property | Matches | Gets the list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.
Public property | NonTerminals | Gets the read-only list of IDebuggableNonTerminal objects defined in the grammar.
Public property | NonTerminalStack | Gets the stack of IDebuggableNonTerminal objects into which the parser has entered.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | RootNode | Gets the root IDebuggableAstNode that has been constructed.
Public property | Terminals | Gets the read-only list of IDebuggableTerminal objects defined in the grammar.
Public property | TermStack | Gets the stack of IDebuggableEbnfTerm objects into which the parser has entered.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Top
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Breakpoints Property

IDebuggerStateBreakpoints Property
Gets the collection of IBreakpoint objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IBreakpoint> Breakpoints { get; }
ReadOnly Property Breakpoints As IList(Of IBreakpoint)
    Get

Property Value

Type: IList IBreakpoint
The collection of IBreakpoint objects.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Ebnf Property

IDebuggerStateEbnf Property
Gets the textual EBNF representation of the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Ebnf { get; }
ReadOnly Property Ebnf As String
    Get

Property Value

Type: String
The textual EBNF representation of the grammar.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.IsBreakForCanMatch Property

IDebuggerStateIsBreakForCanMatch Property
Gets whether the current pause is related to a can-match check for an EbnfTerm.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBreakForCanMatch { get; }
ReadOnly Property IsBreakForCanMatch As Boolean
    Get

Property Value

Type: Boolean
true if the current pause is related to a can-match check; otherwise, false.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Matches Property

IDebuggerStateMatches Property
Gets the list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IDebuggableAstNodeMatch> Matches { get; }
ReadOnly Property Matches As IList(Of IDebuggableAstNodeMatch)
    Get

Property Value

Type: IList IDebuggableAstNodeMatch
The list of IDebuggableAstNodeMatch objects that indicate the labeled AST node matches for the current scope.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.NonTerminals Property

IDebuggerStateNonTerminals Property
Gets the read-only list of IDebuggableNonTerminal objects defined in the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IDebuggableNonTerminal> NonTerminals { get; }
ReadOnly Property NonTerminals As IList(Of IDebuggableNonTerminal)
    Get

Property Value

Type: IList IDebuggableNonTerminal
The read-only list of IDebuggableNonTerminal objects defined in the grammar.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.NonTerminalStack Property

IDebuggerStateNonTerminalStack Property
Gets the stack of IDebuggableNonTerminal objects into which the parser has entered.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Stack<IDebuggableNonTerminal> NonTerminalStack { get; }
ReadOnly Property NonTerminalStack As Stack(Of IDebuggableNonTerminal)
    Get

Property Value

Type: Stack IDebuggableNonTerminal
The stack of IDebuggableNonTerminal objects into which the parser has entered.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.ParseErrors Property

IDebuggerStateParseErrors Property
Gets the collection of IParseError objects that will be returned in the IParseData parsing result.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IParseError> ParseErrors { get; }
ReadOnly Property ParseErrors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that will be returned in the IParseData parsing result.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.RootNode Property

IDebuggerStateRootNode Property
Gets the root IDebuggableAstNode that has been constructed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDebuggableAstNode RootNode { get; }
ReadOnly Property RootNode As IDebuggableAstNode
    Get

Property Value

Type: IDebuggableAstNode
The root IDebuggableAstNode that has been constructed.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.Terminals Property

IDebuggerStateTerminals Property
Gets the read-only list of IDebuggableTerminal objects defined in the grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IDebuggableTerminal> Terminals { get; }
ReadOnly Property Terminals As IList(Of IDebuggableTerminal)
    Get

Property Value

Type: IList IDebuggableTerminal
The read-only list of IDebuggableTerminal objects defined in the grammar.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.TermStack Property

IDebuggerStateTermStack Property
Gets the stack of IDebuggableEbnfTerm objects into which the parser has entered.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Stack<IDebuggableEbnfTerm> TermStack { get; }
ReadOnly Property TermStack As Stack(Of IDebuggableEbnfTerm)
    Get

Property Value

Type: Stack IDebuggableEbnfTerm
The stack of IDebuggableEbnfTerm objects into which the parser has entered.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.TokenReader Property

IDebuggerStateTokenReader Property
Gets the ITokenReader that is used to read tokens during the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITokenReader TokenReader { get; }
ReadOnly Property TokenReader As ITokenReader
    Get

Property Value

Type: ITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState Methods

IDebuggerState Methods

The IDebuggerState type exposes the following members.

Methods
 | Name | Description
Public method | AddBreakpoint | Adds an IBreakpoint for an IDebuggableSymbol.
Public method | RemoveBreakpoint | Removes an IBreakpoint for an IDebuggableSymbol.
Top
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.AddBreakpoint Method

IDebuggerStateAddBreakpoint Method
Adds an IBreakpoint for an IDebuggableSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AddBreakpoint(
    IDebuggableSymbol symbol
)
Sub AddBreakpoint (
    symbol As IDebuggableSymbol
)

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.DebuggingIDebuggableSymbol
The IDebuggableSymbol for which a breakpoint should be created.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


IDebuggerState.RemoveBreakpoint Method

IDebuggerStateRemoveBreakpoint Method
Removes an IBreakpoint for an IDebuggableSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RemoveBreakpoint(
    IDebuggableSymbol symbol
)
Sub RemoveBreakpoint (
    symbol As IDebuggableSymbol
)

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.DebuggingIDebuggableSymbol
The IDebuggableSymbol for which a breakpoint should be removed.
See Also

Reference

IDebuggerState Interface
ActiproSoftware.Text.Parsing.LLParser.Debugging Namespace


ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace

ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace
Contains implementation types related to the debugging of an LL parser.
Classes
 | Class | Description
Public class | Debugger | Represents a Grammar debugger that can control parser execution and obtain detailed information about parser state.
Public class | InfiniteLifetimeObjectBase | Provides the abstract base class for an object that can be proxied across an AppDomain and always remains active.


Debugger Class

Debugger Class
Represents a Grammar debugger that can control parser execution and obtain detailed information about parser state.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.Debugging.ImplementationDebugger

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Debugger : IDebugger
Public Class Debugger
    Implements IDebugger

The Debugger type exposes the following members.

Constructors
 | Name | Description
Public method | Debugger | Initializes a new instance of the Debugger class
Top
Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnModeChanged | Raises the ModeChanged event.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Constructor

Debugger Constructor
Initializes a new instance of the Debugger class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Debugger()
Public Sub New
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Properties

Debugger Properties

The Debugger type exposes the following members.

Properties
 | Name | Description
Public property | IsAttached | Gets whether the debugger is currently attached to an ICodeDocument.
Public property | Mode | Gets the current DebuggerMode of the debugger.
Public property | State | Gets the IDebuggerState that contains information about the current state of the debugger.
Top
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.IsAttached Property

DebuggerIsAttached Property
Gets whether the debugger is currently attached to an ICodeDocument.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAttached { get; }
Public ReadOnly Property IsAttached As Boolean
    Get

Property Value

Type: Boolean
true if the debugger is currently attached to an ICodeDocument; otherwise, false.

Implements

IDebuggerIsAttached
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Mode Property

DebuggerMode Property
Gets the current DebuggerMode of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DebuggerMode Mode { get; }
Public ReadOnly Property Mode As DebuggerMode
    Get

Property Value

Type: DebuggerMode
The current DebuggerMode of the debugger.

Implements

IDebuggerMode
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.State Property

DebuggerState Property
Gets the IDebuggerState that contains information about the current state of the debugger.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDebuggerState State { get; }
Public ReadOnly Property State As IDebuggerState
    Get

Property Value

Type: IDebuggerState
The IDebuggerState that contains information about the current state of the debugger.

Implements

IDebuggerState
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Methods

Debugger Methods

The Debugger type exposes the following members.

Methods
 | Name | Description
Public method | Attach | Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.
Public method | Detach | Detaches from the currently-attached document, if any.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnModeChanged | Raises the ModeChanged event.
Public method | Pause | Requests that the debugger pause execution if the it is currently running.
Public method | Start | Starts debugging on the attached document.
Public method | StepInto | Steps into the next debuggable location.
Public method | StepOut | Steps out of the current debuggable location.
Public method | StepOver | Steps over the current debuggable location.
Public method | Stop | Stops debugging on the attached document.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Attach Method

DebuggerAttach Method
Attempts to attach the debugger to the specified ICodeDocument using the IParser indicated by its ISyntaxLanguage.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Attach(
    ICodeDocument document
)
Public Function Attach (
    document As ICodeDocument
) As Boolean

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument to debug.

Return Value

Type: Boolean
true if the debugger was attached; otherwise, false.

Implements

IDebuggerAttach(ICodeDocument)
Remarks
This method will return false if the debugger is already attached to a document, if the document doesn't have an ISyntaxLanguage, or if the syntax language's IParser isn't an ILLParser.
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Detach Method

DebuggerDetach Method
Detaches from the currently-attached document, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Detach()
Public Sub Detach

Implements

IDebuggerDetach
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.OnModeChanged Method

DebuggerOnModeChanged Method
Raises the ModeChanged event.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnModeChanged(
    EventArgs e
)
Protected Overridable Sub OnModeChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Pause Method

DebuggerPause Method
Requests that the debugger pause execution if the it is currently running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Pause()
Public Sub Pause

Implements

IDebuggerPause
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Start Method

DebuggerStart Method
Starts debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Start()
Public Function Start As Boolean

Return Value

Type: Boolean
true if debugging started; otherwise, false.

Implements

IDebuggerStart
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.StepInto Method

DebuggerStepInto Method
Steps into the next debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void StepInto()
Public Sub StepInto

Implements

IDebuggerStepInto
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.StepOut Method

DebuggerStepOut Method
Steps out of the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void StepOut()
Public Sub StepOut

Implements

IDebuggerStepOut
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.StepOver Method

DebuggerStepOver Method
Steps over the current debuggable location.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void StepOver()
Public Sub StepOver

Implements

IDebuggerStepOver
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.Stop Method

DebuggerStop Method
Stops debugging on the attached document.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Stop()
Public Sub Stop

Implements

IDebuggerStop
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger Events

Debugger Events

The Debugger type exposes the following members.

Events
 | Name | Description
Public event | ModeChanged | Occurs when the Mode property changes.
Top
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


Debugger.ModeChanged Event

DebuggerModeChanged Event
Occurs when the Mode property changes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ModeChanged
Public Event ModeChanged As EventHandler

Value

Type: SystemEventHandler

Implements

IDebuggerModeChanged
See Also

Reference

Debugger Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase Class

InfiniteLifetimeObjectBase Class
Provides the abstract base class for an object that can be proxied across an AppDomain and always remains active.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.Debugging.ImplementationInfiniteLifetimeObjectBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class InfiniteLifetimeObjectBase
Public MustInherit Class InfiniteLifetimeObjectBase

The InfiniteLifetimeObjectBase type exposes the following members.

Constructors
 | Name | Description
Protected method | InfiniteLifetimeObjectBase | Initializes a new instance of the InfiniteLifetimeObjectBase class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase Constructor

InfiniteLifetimeObjectBase Constructor
Initializes a new instance of the InfiniteLifetimeObjectBase class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected InfiniteLifetimeObjectBase()
Protected Sub New
See Also

Reference

InfiniteLifetimeObjectBase Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


InfiniteLifetimeObjectBase Methods

InfiniteLifetimeObjectBase Methods

The InfiniteLifetimeObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

InfiniteLifetimeObjectBase Class
ActiproSoftware.Text.Parsing.LLParser.Debugging.Implementation Namespace


ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace
Contains implementation types related to the creation of an LL parser.
Classes
 | Class | Description
Public class | AstNodeMatch | Represents an IAstNode match made within the current IAstNodeBuilder scope.
Public class | EbnfAlternation | Represents an alternation expression within an EBNF production.
Public class | EbnfConcatenation | Represents a concatenation expression within an EBNF production.
Public class | EbnfNonTerminal | Represents a non-terminal symbol within an EBNF production.
Public class | EbnfProduction | Represents an EBNF production, which consists of an EbnfTerm-based pattern expression and a ITreeConstructionNode-based tree constructor.
Public class | EbnfQuantifiableTerm | Represents the abstract base class for a term within an EBNF production that can be sequentially matched a specified minimum and maximum times.
Public class | EbnfQuantifier | Represents a term within an EBNF production whose child term can be sequentially matched a specified minimum and maximum times.
Public class | EbnfSymbol | Represents the abstract base class for a symbol within an EBNF production.
Public class | EbnfTerm | Represents the abstract base class for a term within an EBNF production.
Public class | EbnfTerminal | Represents a terminal symbol within an EBNF production.
Public class | Grammar | Represents a grammar that can be used with a recursive descent parser.
Public class | LLParseData | Stores the results of a ILLParser parsing operation.
Public class | LLParserBase | Represents the base class for an IParser that executes based on a Grammar definition.
Public class | MergableTokenReader | Represents an object that can provide tokens to a ILLParser in a forward-only direction for a IMergableLexer.
Public class | NonTerminal | Represents a non-terminal symbol within a grammar.
Public class | ParentTreeConstructionNodeBase | Represents an abstract ITreeConstructionNode base class that can contain child tree construction nodes.
Public class | ParserState | Represents an object that tracks the current state of a ILLParser.
Public class | Symbol | Represents an abstract base class for a symbol within a grammar.
Public class | Terminal | Represents a terminal symbol within a grammar.
Public class | TokenReaderBase | Represents the abstract base class of an object that can provide tokens to a ILLParser in a forward-only direction.
Public class | TreeConstructionNodeBase | Represents an abstract base class a tree construction node, used to output an IAstNode for an EbnfProduction.


AstNodeMatch Class

AstNodeMatch Class
Represents an IAstNode match made within the current IAstNodeBuilder scope.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationAstNodeMatch

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AstNodeMatch : IAstNodeMatch
Public Class AstNodeMatch
    Implements IAstNodeMatch

The AstNodeMatch type exposes the following members.

Constructors
 | Name | Description
Public method | AstNodeMatch | Initializes a new instance of the AstNodeMatch class
Top
Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch Constructor

AstNodeMatch Constructor
Initializes a new instance of the AstNodeMatch class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AstNodeMatch()
Public Sub New
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch Properties

AstNodeMatch Properties

The AstNodeMatch type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the optional label applied to the match that can be used for identification during tree construction.
Public property | Node | Gets or sets the IAstNode that was matched.
Top
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch.Label Property

AstNodeMatchLabel Property
Gets or sets the optional label applied to the match that can be used for identification during tree construction.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set

Property Value

Type: String
The optional label applied to the match that can be used for identification during tree construction.

Implements

IAstNodeMatchLabel
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch.Node Property

AstNodeMatchNode Property
Gets or sets the IAstNode that was matched.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode Node { get; set; }
Public Property Node As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The IAstNode that was matched.

Implements

IAstNodeMatchNode
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch Methods

AstNodeMatch Methods

The AstNodeMatch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


AstNodeMatch.ToString Method

AstNodeMatchToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

AstNodeMatch Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Class

EbnfAlternation Class
Represents an alternation expression within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfAlternation

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EbnfAlternation : EbnfQuantifiableTerm
Public NotInheritable Class EbnfAlternation
    Inherits EbnfQuantifiableTerm

The EbnfAlternation type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfAlternation | Initializes a new instance of the EbnfAlternation class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Productions | Gets the list of EbnfProduction objects within the alternation.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Constructor

EbnfAlternation Constructor
Initializes a new instance of the EbnfAlternation class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfAlternation(
    params EbnfProduction[] productions
)
Public Sub New (
    ParamArray productions As EbnfProduction()
)

Parameters

productions
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction
The EbnfProduction objects within the expression.
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Properties

EbnfAlternation Properties

The EbnfAlternation type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Productions | Gets the list of EbnfProduction objects within the alternation.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation.Productions Property

EbnfAlternationProductions Property
Gets the list of EbnfProduction objects within the alternation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<EbnfProduction> Productions { get; }
Public ReadOnly Property Productions As IList(Of EbnfProduction)
    Get

Property Value

Type: IList EbnfProduction
The list of EbnfProduction objects within the alternation.
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation Methods

EbnfAlternation Methods

The EbnfAlternation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfAlternation.ToString Method

EbnfAlternationToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfAlternation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Class

EbnfConcatenation Class
Represents a concatenation expression within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfConcatenation

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EbnfConcatenation : EbnfQuantifiableTerm
Public NotInheritable Class EbnfConcatenation
    Inherits EbnfQuantifiableTerm

The EbnfConcatenation type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfConcatenation | Initializes a new instance of the EbnfConcatenation class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Overrides EbnfTermLabel.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terms | Gets the list of EbnfTerm objects within the expression.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Constructor

EbnfConcatenation Constructor
Initializes a new instance of the EbnfConcatenation class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfConcatenation(
    params EbnfTerm[] terms
)
Public Sub New (
    ParamArray terms As EbnfTerm()
)

Parameters

terms
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
The EbnfTerm objects within the expression.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Properties

EbnfConcatenation Properties

The EbnfConcatenation type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Overrides EbnfTermLabel.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terms | Gets the list of EbnfTerm objects within the expression.
Top
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation.Label Property

EbnfConcatenationLabel Property
Gets or sets the label to apply to this term that may be used when rewriting.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string Label { get; set; }
Public Overrides Property Label As String
    Get
    Set

Property Value

Type: String
The label to apply to this term that may be used when rewriting.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation.Terms Property

EbnfConcatenationTerms Property
Gets the list of EbnfTerm objects within the expression.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<EbnfTerm> Terms { get; }
Public ReadOnly Property Terms As IList(Of EbnfTerm)
    Get

Property Value

Type: IList EbnfTerm
The list of EbnfTerm objects within the expression.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation Methods

EbnfConcatenation Methods

The EbnfConcatenation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfConcatenation.ToString Method

EbnfConcatenationToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfConcatenation Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Class

EbnfNonTerminal Class
Represents a non-terminal symbol within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfNonTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EbnfNonTerminal : EbnfSymbol
Public NotInheritable Class EbnfNonTerminal
    Inherits EbnfSymbol

The EbnfNonTerminal type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfNonTerminal | Initializes a new instance of the EbnfNonTerminal class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | NonTerminal | Gets or sets the NonTerminal that is referenced by this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Constructor

EbnfNonTerminal Constructor
Initializes a new instance of the EbnfNonTerminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfNonTerminal(
    NonTerminal nonTerminal
)
Public Sub New (
    nonTerminal As NonTerminal
)

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that is referenced by this term.
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Properties

EbnfNonTerminal Properties

The EbnfNonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | NonTerminal | Gets or sets the NonTerminal that is referenced by this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal.NonTerminal Property

EbnfNonTerminalNonTerminal Property
Gets or sets the NonTerminal that is referenced by this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonTerminal NonTerminal { get; set; }
Public Property NonTerminal As NonTerminal
    Get
    Set

Property Value

Type: NonTerminal
The NonTerminal that is referenced by this term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal Methods

EbnfNonTerminal Methods

The EbnfNonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfNonTerminal.ToString Method

EbnfNonTerminalToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfNonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Class

EbnfProduction Class
Represents an EBNF production, which consists of an EbnfTerm-based pattern expression and a ITreeConstructionNode-based tree constructor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EbnfProduction : EbnfQuantifiableTerm
Public NotInheritable Class EbnfProduction
    Inherits EbnfQuantifiableTerm

The EbnfProduction type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfProduction(EbnfTerm) | Initializes a new instance of the EbnfProduction class.
Public method | EbnfProduction(EbnfTerm, ITreeConstructionNode) | Initializes a new instance of the EbnfProduction class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | PatternExpression | Gets or sets the EbnfTerm that is the pattern expression.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | TreeConstructor | Gets or sets the ITreeConstructionNode that specifies how to construct the syntax tree results.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Overrides EbnfTermToProduction.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
Operators
Name | Description
BitwiseOr |
(EbnfAlternation to EbnfProduction) |
(EbnfConcatenation to EbnfProduction) |
(EbnfNonTerminal to EbnfProduction) |
(EbnfQuantifier to EbnfProduction) |
(EbnfTerminal to EbnfProduction) |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Constructor

EbnfProduction Constructor
Overload List
 | Name | Description
Public method | EbnfProduction(EbnfTerm) | Initializes a new instance of the EbnfProduction class.
Public method | EbnfProduction(EbnfTerm, ITreeConstructionNode) | Initializes a new instance of the EbnfProduction class.
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Constructor (EbnfTerm)

EbnfProduction Constructor (EbnfTerm)
Initializes a new instance of the EbnfProduction class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction(
    EbnfTerm patternExpression
)
Public Sub New (
    patternExpression As EbnfTerm
)

Parameters

patternExpression
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
The EbnfTerm that is the pattern expression.
See Also

Reference

EbnfProduction Class
EbnfProduction Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Constructor (EbnfTerm, ITreeConstructionNode)

EbnfProduction Constructor (EbnfTerm, ITreeConstructionNode)
Initializes a new instance of the EbnfProduction class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction(
    EbnfTerm patternExpression,
    ITreeConstructionNode treeConstructor
)
Public Sub New (
    patternExpression As EbnfTerm,
    treeConstructor As ITreeConstructionNode
)

Parameters

patternExpression
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
The EbnfTerm that is the pattern expression.
treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The ITreeConstructionNode that specifies how to rewrite the parse results.
See Also

Reference

EbnfProduction Class
EbnfProduction Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Properties

EbnfProduction Properties

The EbnfProduction type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | PatternExpression | Gets or sets the EbnfTerm that is the pattern expression.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | TreeConstructor | Gets or sets the ITreeConstructionNode that specifies how to construct the syntax tree results.
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.PatternExpression Property

EbnfProductionPatternExpression Property
Gets or sets the EbnfTerm that is the pattern expression.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm PatternExpression { get; set; }
Public Property PatternExpression As EbnfTerm
    Get
    Set

Property Value

Type: EbnfTerm
The EbnfTerm that is the pattern expression.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.TreeConstructor Property

EbnfProductionTreeConstructor Property
Gets or sets the ITreeConstructionNode that specifies how to construct the syntax tree results.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITreeConstructionNode TreeConstructor { get; set; }
Public Property TreeConstructor As ITreeConstructionNode
    Get
    Set

Property Value

Type: ITreeConstructionNode
The ITreeConstructionNode that specifies how to construct the syntax tree results.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Methods

EbnfProduction Methods

The EbnfProduction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Overrides EbnfTermToProduction.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnComplete Method

EbnfProductionOnComplete Method
Sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnError Method

EbnfProductionOnError Method
Sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnErrorContinue Method

EbnfProductionOnErrorContinue Method
Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnErrorContinue()
Public Function OnErrorContinue As EbnfProduction

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnErrorIgnore Method

EbnfProductionOnErrorIgnore Method
Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnErrorIgnore()
Public Function OnErrorIgnore As EbnfProduction

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnErrorNoReport Method

EbnfProductionOnErrorNoReport Method
Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnErrorNoReport()
Public Function OnErrorNoReport As EbnfProduction

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnInitialize Method

EbnfProductionOnInitialize Method
Sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.OnSuccess Method

EbnfProductionOnSuccess Method
Sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfProduction

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfProduction
The modified term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.ToProduction Method

EbnfProductionToProduction Method
Returns an EbnfProduction for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override EbnfProduction ToProduction()
Public Overrides Function ToProduction As EbnfProduction

Return Value

Type: EbnfProduction
An EbnfProduction for this term.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.ToString Method

EbnfProductionToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Operators and Type Conversions

EbnfProduction Operators and Type Conversions

The EbnfProduction type exposes the following members.

Operators
Name | Description
BitwiseOr |
(EbnfAlternation to EbnfProduction) |
(EbnfConcatenation to EbnfProduction) |
(EbnfNonTerminal to EbnfProduction) |
(EbnfQuantifier to EbnfProduction) |
(EbnfTerminal to EbnfProduction) |
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction.BitwiseOr Operator

EbnfProductionBitwiseOr Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    EbnfProduction left,
    EbnfProduction right
)
Public Shared Operator Or (
    left As EbnfProduction,
    right As EbnfProduction
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction)"]

See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion Operators

EbnfProduction Conversion Operators
Overload List
Name | Description
(EbnfAlternation to EbnfProduction) |
(EbnfConcatenation to EbnfProduction) |
(EbnfNonTerminal to EbnfProduction) |
(EbnfQuantifier to EbnfProduction) |
(EbnfTerminal to EbnfProduction) |
Top
See Also

Reference

EbnfProduction Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfAlternation to EbnfProduction)

EbnfProduction Conversion (EbnfAlternation to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfAlternation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfAlternation term
)
Public Shared Widening Operator CType (
    term As EbnfAlternation
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfAlternation

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfAlternation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfAlternation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfConcatenation to EbnfProduction)

EbnfProduction Conversion (EbnfConcatenation to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfConcatenation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfConcatenation term
)
Public Shared Widening Operator CType (
    term As EbnfConcatenation
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfConcatenation

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfConcatenation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfConcatenation)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfNonTerminal to EbnfProduction)

EbnfProduction Conversion (EbnfNonTerminal to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfNonTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfNonTerminal term
)
Public Shared Widening Operator CType (
    term As EbnfNonTerminal
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfNonTerminal

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfNonTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfNonTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfQuantifier to EbnfProduction)

EbnfProduction Conversion (EbnfQuantifier to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfQuantifier)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfQuantifier term
)
Public Shared Widening Operator CType (
    term As EbnfQuantifier
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifier

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfQuantifier)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfQuantifier)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfProduction Implicit Conversion (EbnfTerminal to EbnfProduction)

EbnfProduction Conversion (EbnfTerminal to EbnfProduction)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator EbnfProduction (
    EbnfTerminal term
)
Public Shared Widening Operator CType (
    term As EbnfTerminal
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerminal

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction.op_Implicit(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerminal)~ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfProduction"]

See Also

Reference

EbnfProduction Class
Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Class

EbnfQuantifiableTerm Class
Represents the abstract base class for a term within an EBNF production that can be sequentially matched a specified minimum and maximum times.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfAlternation
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfConcatenation
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfProduction
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class EbnfQuantifiableTerm : EbnfTerm
Public MustInherit Class EbnfQuantifiableTerm
    Inherits EbnfTerm

The EbnfQuantifiableTerm type exposes the following members.

Constructors
 | Name | Description
Protected method | EbnfQuantifiableTerm | Initializes a new instance of the EbnfQuantifiableTerm class
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted.
Public method | Range | Marks the term such that a range of instances are permitted.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | (Inherited from Object.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Constructor

EbnfQuantifiableTerm Constructor
Initializes a new instance of the EbnfQuantifiableTerm class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected EbnfQuantifiableTerm()
Protected Sub New
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Properties

EbnfQuantifiableTerm Properties

The EbnfQuantifiableTerm type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm Methods

EbnfQuantifiableTerm Methods

The EbnfQuantifiableTerm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Marks the term such that one to many instances are permitted.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Marks the term such that zero or one instances are permitted.
Public method | Range | Marks the term such that a range of instances are permitted.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | (Inherited from Object.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted.
Top
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnComplete Method

EbnfQuantifiableTermOnComplete Method
Sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OneOrMore Method

EbnfQuantifiableTermOneOrMore Method
Marks the term such that one to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier OneOrMore()
Public Function OneOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnError Method

EbnfQuantifiableTermOnError Method
Sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnErrorContinue Method

EbnfQuantifiableTermOnErrorContinue Method
Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorContinue()
Public Function OnErrorContinue As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnErrorIgnore Method

EbnfQuantifiableTermOnErrorIgnore Method
Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorIgnore()
Public Function OnErrorIgnore As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnErrorNoReport Method

EbnfQuantifiableTermOnErrorNoReport Method
Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorNoReport()
Public Function OnErrorNoReport As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnInitialize Method

EbnfQuantifiableTermOnInitialize Method
Sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.OnSuccess Method

EbnfQuantifiableTermOnSuccess Method
Sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.Optional Method

EbnfQuantifiableTermOptional Method
Marks the term such that zero or one instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier Optional()
Public Function Optional As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.Range Method

EbnfQuantifiableTermRange Method
Marks the term such that a range of instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier Range(
    int min,
    Nullable<int> max
)
Public Function Range (
    min As Integer,
    max As Nullable(Of Integer)
) As EbnfQuantifier

Parameters

min
Type: SystemInt32
The minimum number of instances.
max
Type: SystemNullable Int32
The maximum number of instances.

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.SetLabel Method

EbnfQuantifiableTermSetLabel Method
Sets the Label for the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm SetLabel(
    string label
)
Public Function SetLabel (
    label As String
) As EbnfQuantifiableTerm

Parameters

label
Type: SystemString
The Label for the term.

Return Value

Type: EbnfQuantifiableTerm
The modified term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifiableTerm.ZeroOrMore Method

EbnfQuantifiableTermZeroOrMore Method
Marks the term such that zero to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier ZeroOrMore()
Public Function ZeroOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this term.
See Also

Reference

EbnfQuantifiableTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Class

EbnfQuantifier Class
Represents a term within an EBNF production whose child term can be sequentially matched a specified minimum and maximum times.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifier

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EbnfQuantifier : EbnfTerm
Public NotInheritable Class EbnfQuantifier
    Inherits EbnfTerm

The EbnfQuantifier type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfQuantifier | Initializes a new instance of the EbnfQuantifier class.
Top
Properties
 | Name | Description
Public property | Child | Gets or sets the EbnfQuantifiableTerm that is quantified by this term.
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Maximum | Gets or sets the maximum number of instances that the term may occur.
Public property | Minimum | Gets or sets the minimum number of instances that the term may occur.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public method | SetLabel | Sets the Label for the term. (Overrides EbnfTermSetLabel(String).)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Constructor

EbnfQuantifier Constructor
Initializes a new instance of the EbnfQuantifier class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier(
    EbnfQuantifiableTerm child,
    int minimum,
    Nullable<int> maximum
)
Public Sub New (
    child As EbnfQuantifiableTerm,
    minimum As Integer,
    maximum As Nullable(Of Integer)
)

Parameters

child
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
The EbnfQuantifiableTerm to quantify.
minimum
Type: SystemInt32
The minimum number of instances that the term may occur.
maximum
Type: SystemNullable Int32
The maximum number of instances that the term may occur.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Properties

EbnfQuantifier Properties

The EbnfQuantifier type exposes the following members.

Properties
 | Name | Description
Public property | Child | Gets or sets the EbnfQuantifiableTerm that is quantified by this term.
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | Maximum | Gets or sets the maximum number of instances that the term may occur.
Public property | Minimum | Gets or sets the minimum number of instances that the term may occur.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.Child Property

EbnfQuantifierChild Property
Gets or sets the EbnfQuantifiableTerm that is quantified by this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm Child { get; set; }
Public Property Child As EbnfQuantifiableTerm
    Get
    Set

Property Value

Type: EbnfQuantifiableTerm
The EbnfQuantifiableTerm that is quantified by this term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.Maximum Property

EbnfQuantifierMaximum Property
Gets or sets the maximum number of instances that the term may occur.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> Maximum { get; set; }
Public Property Maximum As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The maximum number of instances that the term may occur.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.Minimum Property

EbnfQuantifierMinimum Property
Gets or sets the minimum number of instances that the term may occur.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The minimum number of instances that the term may occur.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier Methods

EbnfQuantifier Methods

The EbnfQuantifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public method | SetLabel | Sets the Label for the term. (Overrides EbnfTermSetLabel(String).)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.SetLabel Method

EbnfQuantifierSetLabel Method
Sets the Label for the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override EbnfTerm SetLabel(
    string newLabel
)
Public Overrides Function SetLabel (
    newLabel As String
) As EbnfTerm

Parameters

newLabel
Type: SystemString
The Label for the term.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfQuantifier.ToString Method

EbnfQuantifierToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfQuantifier Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Class

EbnfSymbol Class
Represents the abstract base class for a symbol within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfNonTerminal
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class EbnfSymbol : EbnfQuantifiableTerm
Public MustInherit Class EbnfSymbol
    Inherits EbnfQuantifiableTerm

The EbnfSymbol type exposes the following members.

Constructors
 | Name | Description
Protected method | EbnfSymbol | Initializes a new instance of the EbnfSymbol class
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | (Inherited from Object.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Constructor

EbnfSymbol Constructor
Initializes a new instance of the EbnfSymbol class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected EbnfSymbol()
Protected Sub New
See Also

Reference

EbnfSymbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Properties

EbnfSymbol Properties

The EbnfSymbol type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Top
See Also

Reference

EbnfSymbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfSymbol Methods

EbnfSymbol Methods

The EbnfSymbol type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | (Inherited from Object.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfSymbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Class

EbnfTerm Class
Represents the abstract base class for a term within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifier

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class EbnfTerm
Public MustInherit Class EbnfTerm

The EbnfTerm type exposes the following members.

Constructors
 | Name | Description
Protected method | EbnfTerm | Initializes a new instance of the EbnfTerm class
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term.
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting.
Public property | MatchCondition | Gets the IMatchCondition to use for this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form.
Public method | ToProduction | Returns an EbnfProduction for this term.
Public method | ToString | (Inherited from Object.)
Top
Operators
Name | Description
Addition |
BitwiseOr |
GreaterThan |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Constructor

EbnfTerm Constructor
Initializes a new instance of the EbnfTerm class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected EbnfTerm()
Protected Sub New
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Properties

EbnfTerm Properties

The EbnfTerm type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term.
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting.
Public property | MatchCondition | Gets the IMatchCondition to use for this term.
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed.
Top
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.CompleteCallback Property

EbnfTermCompleteCallback Property
Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserCallback CompleteCallback { get; set; }
Public Property CompleteCallback As ParserCallback
    Get
    Set

Property Value

Type: ParserCallback
The delegate that will be called after the term is parsed.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.ErrorCallback Property

EbnfTermErrorCallback Property
Gets or sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserErrorCallback ErrorCallback { get; set; }
Public Property ErrorCallback As ParserErrorCallback
    Get
    Set

Property Value

Type: ParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.InitializeCallback Property

EbnfTermInitializeCallback Property
Gets or sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserCallback InitializeCallback { get; set; }
Public Property InitializeCallback As ParserCallback
    Get
    Set

Property Value

Type: ParserCallback
The delegate that will be called before the term is parsed.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.IsCompiled Property

EbnfTermIsCompiled Property
Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.Label Property

EbnfTermLabel Property
Gets or sets the label to apply to this term that may be used when rewriting.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Label { get; set; }
Public Overridable Property Label As String
    Get
    Set

Property Value

Type: String
The label to apply to this term that may be used when rewriting.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.MatchCondition Property

EbnfTermMatchCondition Property
Gets the IMatchCondition to use for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMatchCondition MatchCondition { get; }
Public ReadOnly Property MatchCondition As IMatchCondition
    Get

Property Value

Type: IMatchCondition
The IMatchCondition to use for this term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.SuccessCallback Property

EbnfTermSuccessCallback Property
Gets or sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserCallback SuccessCallback { get; set; }
Public Property SuccessCallback As ParserCallback
    Get
    Set

Property Value

Type: ParserCallback
The delegate that will be called when the term is successfully parsed.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Methods

EbnfTerm Methods

The EbnfTerm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed.
Public method | SetLabel | Sets the Label for the term.
Public method | ToEbnfString | Outputs the contents of the term in EBNF form.
Public method | ToProduction | Returns an EbnfProduction for this term.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnComplete Method

EbnfTermOnComplete Method
Sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnError Method

EbnfTermOnError Method
Sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnErrorContinue Method

EbnfTermOnErrorContinue Method
Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnErrorContinue()
Public Function OnErrorContinue As EbnfTerm

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnErrorIgnore Method

EbnfTermOnErrorIgnore Method
Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnErrorIgnore()
Public Function OnErrorIgnore As EbnfTerm

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnErrorNoReport Method

EbnfTermOnErrorNoReport Method
Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnErrorNoReport()
Public Function OnErrorNoReport As EbnfTerm

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnInitialize Method

EbnfTermOnInitialize Method
Sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.OnSuccess Method

EbnfTermOnSuccess Method
Sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerm OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.SetLabel Method

EbnfTermSetLabel Method
Sets the Label for the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual EbnfTerm SetLabel(
    string newLabel
)
Public Overridable Function SetLabel (
    newLabel As String
) As EbnfTerm

Parameters

newLabel
Type: SystemString
The Label for the term.

Return Value

Type: EbnfTerm
The modified term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.ToEbnfString Method

EbnfTermToEbnfString Method
Outputs the contents of the term in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToEbnfString()
Public Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.ToProduction Method

EbnfTermToProduction Method
Returns an EbnfProduction for this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual EbnfProduction ToProduction()
Public Overridable Function ToProduction As EbnfProduction

Return Value

Type: EbnfProduction
An EbnfProduction for this term.
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm Operators

EbnfTerm Operators

The EbnfTerm type exposes the following members.

Operators
Name | Description
Addition |
BitwiseOr |
GreaterThan |
LessThan |
Top
See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.Addition Operator

EbnfTermAddition Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    EbnfTerm left,
    EbnfTerm right
)
Public Shared Operator + (
    left As EbnfTerm,
    right As EbnfTerm
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.BitwiseOr Operator

EbnfTermBitwiseOr Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    EbnfTerm left,
    EbnfTerm right
)
Public Shared Operator Or (
    left As EbnfTerm,
    right As EbnfTerm
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.GreaterThan Operator

EbnfTermGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfProduction operator >(
    EbnfTerm term,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator > (
    term As EbnfTerm,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerm.LessThan Operator

EbnfTermLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfProduction operator <(
    EbnfTerm term,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator < (
    term As EbnfTerm,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

term
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="term"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

EbnfTerm Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Class

EbnfTerminal Class
Represents a terminal symbol within an EBNF production.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfQuantifiableTerm
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EbnfTerminal : EbnfSymbol
Public NotInheritable Class EbnfTerminal
    Inherits EbnfSymbol

The EbnfTerminal type exposes the following members.

Constructors
 | Name | Description
Public method | EbnfTerminal | Initializes a new instance of the EbnfTerminal class.
Top
Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terminal | Gets or sets the Terminal that is referenced by this term.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Constructor

EbnfTerminal Constructor
Initializes a new instance of the EbnfTerminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfTerminal(
    Terminal terminal
)
Public Sub New (
    terminal As Terminal
)

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that is referenced by this term.
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Properties

EbnfTerminal Properties

The EbnfTerminal type exposes the following members.

Properties
 | Name | Description
Public property | CompleteCallback | Gets or sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfTerm.)
Public property | ErrorCallback | Gets or sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfTerm.)
Public property | InitializeCallback | Gets or sets the delegate that will be called before the term is parsed. (Inherited from EbnfTerm.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from EbnfTerm.)
Public property | Label | Gets or sets the label to apply to this term that may be used when rewriting. (Inherited from EbnfTerm.)
Public property | MatchCondition | Gets the IMatchCondition to use for this term. (Inherited from EbnfTerm.)
Public property | SuccessCallback | Gets or sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfTerm.)
Public property | Terminal | Gets or sets the Terminal that is referenced by this term.
Top
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal.Terminal Property

EbnfTerminalTerminal Property
Gets or sets the Terminal that is referenced by this term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Terminal Terminal { get; set; }
Public Property Terminal As Terminal
    Get
    Set

Property Value

Type: Terminal
The Terminal that is referenced by this term.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal Methods

EbnfTerminal Methods

The EbnfTerminal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OneOrMore | Marks the term such that one to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | OnError | Sets the delegate that will be called when an error occurs while parsing the term. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorContinue | Marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorIgnore | Marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from EbnfQuantifiableTerm.)
Public method | OnErrorNoReport | Marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from EbnfQuantifiableTerm.)
Public method | OnInitialize | Sets the delegate that will be called before the term is parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | OnSuccess | Sets the delegate that will be called when the term is successfully parsed. (Inherited from EbnfQuantifiableTerm.)
Public method | Optional | Marks the term such that zero or one instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | Range | Marks the term such that a range of instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Public method | SetLabel | Sets the Label for the term. (Inherited from EbnfQuantifiableTerm.)
Public method | ToEbnfString | Outputs the contents of the term in EBNF form. (Inherited from EbnfTerm.)
Public method | ToProduction | Returns an EbnfProduction for this term. (Inherited from EbnfTerm.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ZeroOrMore | Marks the term such that zero to many instances are permitted. (Inherited from EbnfQuantifiableTerm.)
Top
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


EbnfTerminal.ToString Method

EbnfTerminalToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

EbnfTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Class

Grammar Class
Represents a grammar that can be used with a recursive descent parser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetGrammarBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptGrammar
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonGrammar
ActiproSoftware.Text.Languages.Python.ImplementationPythonGrammar
ActiproSoftware.Text.Languages.Xml.ImplementationXmlGrammar

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Grammar : IKeyedObject
Public Class Grammar
    Implements IKeyedObject

The Grammar type exposes the following members.

Constructors
 | Name | Description
Public method | Grammar | Initializes a new instance of the Grammar class.
Top
Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets the string that identifies the grammar, generally the related language name.
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins.
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key.
Top
Methods
 | Name | Description
 | Ast(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.
 | AstTAstNode | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.
 | AstChildFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.
 | AstChildFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.
 | AstConditional(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalTAstNode(ITreeConstructionNode) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalFrom | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and child nodes from the children of an IAstNodeMatch that has the specified label, but only if there is at least one child available.
 | AstCount | Creates an ITreeConstructionNode that generates an IAstNode whose value is the count of IAstNode objects generated by contained nodes.
 | AstFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.
 | AstFromTAstNode(String) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.
 | AstLeftAssociativityTAstNode, TDerivedAstNode | Creates an ITypedTreeConstructionNodeTAstNode that attempts to make a child node left associative instead of right associative, useful for scenarios such as binary operators.
 | AstValueOf | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes.
 | AstValueOfConditional | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | CanAlwaysMatch | Implements a ParserCanMatchCallback that always returns true, and is useful for assigning to non-terminals that are called from the Root non-terminal for a Grammar.
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form.
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled.
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Constructor

Grammar Constructor
Initializes a new instance of the Grammar class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Grammar(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the grammar, generally the related language name.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Properties

Grammar Properties

The Grammar type exposes the following members.

Properties
 | Name | Description
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets the string that identifies the grammar, generally the related language name.
Public property | NonTerminals | Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.
Public property | Root | Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins.
Public property | Terminals | Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.IsCompiled Property

GrammarIsCompiled Property
Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Key Property

GrammarKey Property
Gets the string that identifies the grammar, generally the related language name.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string that identifies the grammar, generally the related language name.

Implements

IKeyedObjectKey
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.NonTerminals Property

GrammarNonTerminals Property
Gets a dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDictionary<string, NonTerminal> NonTerminals { get; }
Public ReadOnly Property NonTerminals As IDictionary(Of String, NonTerminal)
    Get

Property Value

Type: IDictionary String, NonTerminal
A dictionary of all non-terminals defined in the grammar, with the key being the non-terminal string key.
Remarks
This property returns until the grammar has been compiled.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Root Property

GrammarRoot Property
Gets or sets the root NonTerminal of the grammar, meaning the first non-terminal that is attempted to be matched when parsing begins.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonTerminal Root { get; set; }
Public Property Root As NonTerminal
    Get
    Set

Property Value

Type: NonTerminal
The root NonTerminal of the grammar.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Terminals Property

GrammarTerminals Property
Gets a dictionary of all terminals defined in the grammar, with the key being the terminal string key.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDictionary<string, Terminal> Terminals { get; }
Public ReadOnly Property Terminals As IDictionary(Of String, Terminal)
    Get

Property Value

Type: IDictionary String, Terminal
A dictionary of all terminals defined in the grammar, with the key being the terminal string key.
Remarks
This property returns until the grammar has been compiled.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar Methods

Grammar Methods

The Grammar type exposes the following members.

Methods
 | Name | Description
 | Ast(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.
 | AstTAstNode | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.
 | AstChildFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.
 | AstChildFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.
 | AstChildrenFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.
 | AstConditional(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalTAstNode(ITreeConstructionNode) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.
 | AstConditionalFrom | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and child nodes from the children of an IAstNodeMatch that has the specified label, but only if there is at least one child available.
 | AstCount | Creates an ITreeConstructionNode that generates an IAstNode whose value is the count of IAstNode objects generated by contained nodes.
 | AstFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.
 | AstFromTAstNode(String) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.
 | AstLeftAssociativityTAstNode, TDerivedAstNode | Creates an ITypedTreeConstructionNodeTAstNode that attempts to make a child node left associative instead of right associative, useful for scenarios such as binary operators.
 | AstValueOf | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes.
 | AstValueOfConditional | Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
 | CanAlwaysMatch | Implements a ParserCanMatchCallback that always returns true, and is useful for assigning to non-terminals that are called from the Root non-terminal for a Grammar.
Public method | Compile | Compiles the grammar, which prepares the grammar and its elements for parsing usage.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the grammar in EBNF form.
Public method | ToString | (Inherited from Object.)
Public method | Validate | Validates that the grammar and its elements are configured correctly and ready to be compiled.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Ast Method

GrammarAst Method
Overload List
Name | Description
AstTAstNode | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.
Ast(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Ast(TAstNode) Method

GrammarAstTAstNode Method
Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> Ast<TAstNode>()
where TAstNode : class, new(), IAstNode

Public Shared Function Ast(Of TAstNode As {Class, New, IAstNode}) As ITypedTreeConstructionNode(Of TAstNode)

Type Parameters

TAstNode
The type of IAstNode-based class to create.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
Ast Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Ast Method (String, ITreeConstructionNode[])

GrammarAst Method (String, ITreeConstructionNode)
Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode Ast(
    string value,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function Ast (
    value As String,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

value
Type: SystemString
The value to assign to the generated IAstNode.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
Ast Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildFrom Method

GrammarAstChildFrom Method
Overload List
Name | Description
AstChildFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.
AstChildFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildFrom Method (String)

GrammarAstChildFrom Method (String)
Creates an ITreeConstructionNode that generates an IAstNode from the first child of an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildFrom(
    string label
)
Public Shared Function AstChildFrom (
    label As String
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildFrom Method (String, Int32)

GrammarAstChildFrom Method (String, Int32)
Creates an ITreeConstructionNode that generates an IAstNode from the specified child of an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildFrom(
    string label,
    int childIndex
)
Public Shared Function AstChildFrom (
    label As String,
    childIndex As Integer
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.
childIndex
Type: SystemInt32
The index of the child.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildrenFrom Method

GrammarAstChildrenFrom Method
Overload List
Name | Description
AstChildrenFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.
AstChildrenFrom(String, Int32) | Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildrenFrom Method (String)

GrammarAstChildrenFrom Method (String)
Creates an ITreeConstructionNode that generates an IAstNode from the children of an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildrenFrom(
    string label
)
Public Shared Function AstChildrenFrom (
    label As String
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildrenFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstChildrenFrom Method (String, Int32)

GrammarAstChildrenFrom Method (String, Int32)
Creates an ITreeConstructionNode that generates an IAstNode from the descendants at the specified nesting level of an IAstNodeMatch that has the specified label, useful for gathering desired nodes two or more levels deep.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstChildrenFrom(
    string label,
    int nestingLevel
)
Public Shared Function AstChildrenFrom (
    label As String,
    nestingLevel As Integer
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.
nestingLevel
Type: SystemInt32
The zero-based target nesting level, where 0 means direct children.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstChildrenFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditional Method

GrammarAstConditional Method
Overload List
Name | Description
AstConditionalTAstNode(ITreeConstructionNode) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.
AstConditional(String, ITreeConstructionNode) | Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditional(TAstNode) Method (ITreeConstructionNode[])

GrammarAstConditionalTAstNode Method (ITreeConstructionNode)
Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type, but only if there is more than one child available. If one child is available, it is directly returned.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> AstConditional<TAstNode>(
    params ITreeConstructionNode[] childNodes
)
where TAstNode : class, new(), IAstNode

Public Shared Function AstConditional(Of TAstNode As {Class, New, IAstNode}) (
    ParamArray childNodes As ITreeConstructionNode()
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Type Parameters

TAstNode

[Missing <typeparam name="TAstNode"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Grammar.AstConditional``1(ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode[])"]

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
AstConditional Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditional Method (String, ITreeConstructionNode[])

GrammarAstConditional Method (String, ITreeConstructionNode)
Creates an ITreeConstructionNode that generates an IAstNode with the specified value and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstConditional(
    string value,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function AstConditional (
    value As String,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

value
Type: SystemString
The value to assign to the generated IAstNode.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstConditional Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstConditionalFrom Method

GrammarAstConditionalFrom Method
Creates an ITreeConstructionNode that generates an IAstNode with the specified value and child nodes from the children of an IAstNodeMatch that has the specified label, but only if there is at least one child available.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstConditionalFrom(
    string value,
    string label
)
Public Shared Function AstConditionalFrom (
    value As String,
    label As String
) As ITreeConstructionNode

Parameters

value
Type: SystemString
The value to assign to the generated IAstNode.
label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstCount Method

GrammarAstCount Method
Creates an ITreeConstructionNode that generates an IAstNode whose value is the count of IAstNode objects generated by contained nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstCount(
    params ITreeConstructionNode[] countNodes
)
Public Shared Function AstCount (
    ParamArray countNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

countNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstFrom Method

GrammarAstFrom Method
Overload List
Name | Description
AstFrom(String) | Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.
AstFromTAstNode(String) | Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.
Top
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstFrom Method (String)

GrammarAstFrom Method (String)
Creates an ITreeConstructionNode that generates an IAstNode from an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstFrom(
    string label
)
Public Shared Function AstFrom (
    label As String
) As ITreeConstructionNode

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
AstFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstFrom(TAstNode) Method (String)

GrammarAstFromTAstNode Method (String)
Creates an ITypedTreeConstructionNodeTAstNode that generates an IAstNode of the specified type from an IAstNodeMatch that has the specified label.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> AstFrom<TAstNode>(
    string label
)
where TAstNode : class, IAstNode

Public Shared Function AstFrom(Of TAstNode As {Class, IAstNode}) (
    label As String
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

label
Type: SystemString
The IAstNodeMatch for which to search.

Type Parameters

TAstNode
The type of IAstNode-based class to create.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
AstFrom Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstLeftAssociativity(TAstNode, TDerivedAstNode) Method

GrammarAstLeftAssociativityTAstNode, TDerivedAstNode Method
Creates an ITypedTreeConstructionNodeTAstNode that attempts to make a child node left associative instead of right associative, useful for scenarios such as binary operators.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITypedTreeConstructionNode<TAstNode> AstLeftAssociativity<TAstNode, TDerivedAstNode>(
    ITreeConstructionNode childNode,
    Expression<Func<TDerivedAstNode, TAstNode>> leftPropExpression,
    Expression<Func<TDerivedAstNode, TAstNode>> rightPropExpression,
    Func<TDerivedAstNode, TDerivedAstNode, bool> condition
)
where TAstNode : class, IAstNode
where TDerivedAstNode : class, TAstNode

Public Shared Function AstLeftAssociativity(Of TAstNode As {Class, IAstNode}, TDerivedAstNode As {Class, TAstNode}) (
    childNode As ITreeConstructionNode,
    leftPropExpression As Expression(Of Func(Of TDerivedAstNode, TAstNode)),
    rightPropExpression As Expression(Of Func(Of TDerivedAstNode, TAstNode)),
    condition As Func(Of TDerivedAstNode, TDerivedAstNode, Boolean)
) As ITypedTreeConstructionNode(Of TAstNode)

Parameters

childNode
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The child ITreeConstructionNode object.
leftPropExpression
Type: System.Linq.ExpressionsExpression Func TDerivedAstNode, TAstNode
The lambda expression indicating the property for the left side branch.
rightPropExpression
Type: System.Linq.ExpressionsExpression Func TDerivedAstNode, TAstNode
The lambda expression indicating the property for the right side branch.
condition
Type: SystemFunc TDerivedAstNode, TDerivedAstNode, Boolean
The optional lambda expression that is passed both the root and child nodes and returns true if the associativity change is permitted.

Type Parameters

TAstNode
The type of IAstNode-based class to return.
TDerivedAstNode
The type of IAstNode (that must inherit TAstNode) that supports associativity.

Return Value

Type: ITypedTreeConstructionNode TAstNode
The ITypedTreeConstructionNodeTAstNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstValueOf Method

GrammarAstValueOf Method
Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstValueOf(
    ITreeConstructionNode valueOfNode,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function AstValueOf (
    valueOfNode As ITreeConstructionNode,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

valueOfNode
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The ITreeConstructionNode whose constructed IAstNode value will be used.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.AstValueOfConditional Method

GrammarAstValueOfConditional Method
Creates an ITreeConstructionNode that generates an IAstNode with the value of the specified ITreeConstructionNode's constructed node, and optional child nodes, but only if there is more than one child available. If one child is available, it is directly returned.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ITreeConstructionNode AstValueOfConditional(
    ITreeConstructionNode valueOfNode,
    params ITreeConstructionNode[] childNodes
)
Public Shared Function AstValueOfConditional (
    valueOfNode As ITreeConstructionNode,
    ParamArray childNodes As ITreeConstructionNode()
) As ITreeConstructionNode

Parameters

valueOfNode
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The ITreeConstructionNode whose constructed IAstNode value will be used.
childNodes
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The optional child ITreeConstructionNode objects.

Return Value

Type: ITreeConstructionNode
The ITreeConstructionNode that was created.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.CanAlwaysMatch Method

GrammarCanAlwaysMatch Method
Implements a ParserCanMatchCallback that always returns true, and is useful for assigning to non-terminals that are called from the Root non-terminal for a Grammar.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool CanAlwaysMatch(
    IParserState state
)
Public Shared Function CanAlwaysMatch (
    state As IParserState
) As Boolean

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
A IParserState that provides information about the parser's current state.

Return Value

Type: Boolean
Always true.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Compile Method

GrammarCompile Method
Compiles the grammar, which prepares the grammar and its elements for parsing usage.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Compile()
Public Sub Compile
Remarks
Compiling the grammar also means that all elements of the language will be locked and no longer able to be modified.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.ToEbnfString Method

GrammarToEbnfString Method
Outputs the contents of the grammar in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToEbnfString()
Public Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the grammar.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Grammar.Validate Method

GrammarValidate Method
Validates that the grammar and its elements are configured correctly and ready to be compiled.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Validate()
Public Sub Validate
Remarks
An exception will be thrown if validation fails.
See Also

Reference

Grammar Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Class

LLParseData Class
Stores the results of a ILLParser parsing operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParseData
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParseData
ActiproSoftware.Text.Languages.Python.ImplementationPythonParseData
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParseData

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LLParseData : ILLParseData,
    IParseData, IParseErrorProvider
Public Class LLParseData
    Implements ILLParseData, IParseData, IParseErrorProvider

The LLParseData type exposes the following members.

Constructors
 | Name | Description
Public method | LLParseData | Initializes a new instance of the LLParseData class
Top
Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result.
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Constructor

LLParseData Constructor
Initializes a new instance of the LLParseData class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LLParseData()
Public Sub New
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Properties

LLParseData Properties

The LLParseData type exposes the following members.

Properties
 | Name | Description
Public property | Ast | Gets or sets the object that contains the abstract syntax tree result.
Public property | Errors | Gets or sets the collection of IParseError objects that specify parse errors.
Public property | Snapshot | Gets the ITextSnapshot, if known, from which the parse errors were created.
Top
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData.Ast Property

LLParseDataAst Property
Gets or sets the object that contains the abstract syntax tree result.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNode Ast { get; set; }
Public Property Ast As IAstNode
    Get
    Set

Property Value

Type: IAstNode
The object that contains the abstract syntax tree result.

Implements

ILLParseDataAst
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData.Errors Property

LLParseDataErrors Property
Gets or sets the collection of IParseError objects that specify parse errors.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IParseError> Errors { get; set; }
Public Property Errors As IEnumerable(Of IParseError)
    Get
    Set

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that specify parse errors.

Implements

IParseErrorProviderErrors
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData.Snapshot Property

LLParseDataSnapshot Property
Gets the ITextSnapshot, if known, from which the parse errors were created.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; set; }
Public Property Snapshot As ITextSnapshot
    Get
    Set

Property Value

Type: ITextSnapshot
The ITextSnapshot, if known, from which the parse errors were created.

Implements

IParseErrorProviderSnapshot
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParseData Methods

LLParseData Methods

The LLParseData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LLParseData Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Class

LLParserBase Class
Represents the base class for an IParser that executes based on a Grammar definition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.ImplementationParserBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParserBase
ActiproSoftware.Text.Languages.DotNet.ImplementationDotNetParserBase
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptParser
ActiproSoftware.Text.Languages.JavaScript.ImplementationJsonParser
ActiproSoftware.Text.Languages.Python.ImplementationPythonParser
ActiproSoftware.Text.Languages.Xml.ImplementationXmlParserBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class LLParserBase : ParserBase,
    ILLParser, IParser, IKeyedObject
Public MustInherit Class LLParserBase
    Inherits ParserBase
    Implements ILLParser, IParser, IKeyedObject

The LLParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LLParserBase | Initializes a new instance of the LLParserBase class.
Top
Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState, after the parse operation has completed.
Protected method | CreateParserState | Creates an IParserState for a parse operation.
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState.
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Constructor

LLParserBase Constructor
Initializes a new instance of the LLParserBase class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected LLParserBase(
    Grammar grammar
)
Protected Sub New (
    grammar As Grammar
)

Parameters

grammar
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationGrammar
The Grammar to use.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Properties

LLParserBase Properties

The LLParserBase type exposes the following members.

Properties
 | Name | Description
Public property | Grammar | Gets the Grammar that is used by this parser.
Public property | Key | Gets or sets a string that identifies the parser, generally the related language name. (Inherited from ParserBase.)
Top
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.Grammar Property

LLParserBaseGrammar Property
Gets the Grammar that is used by this parser.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Grammar Grammar { get; }
Public ReadOnly Property Grammar As Grammar
    Get

Property Value

Type: Grammar
The Grammar that is used by this parser.

Implements

ILLParserGrammar
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase Methods

LLParserBase Methods

The LLParserBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateParseData | Creates an IParseData for the specified IParserState, after the parse operation has completed.
Protected method | CreateParserState | Creates an IParserState for a parse operation.
Public method | CreateTokenReader | Creates an ITokenReader that is used by the parser to read through tokens.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | InitializeParseData | Initializes a LLParseData using the specified IParserState.
Protected method | InitializeParserState | Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Parse | Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data. (Overrides ParserBaseParse(IParseRequest).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.CreateParseData Method

LLParserBaseCreateParseData Method
Creates an IParseData for the specified IParserState, after the parse operation has completed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IParseData CreateParseData(
    IParseRequest request,
    IParserState state
)
Protected Overridable Function CreateParseData (
    request As IParseRequest,
    state As IParserState
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.

Return Value

Type: IParseData
The IParseData that was created.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.CreateParserState Method

LLParserBaseCreateParserState Method
Creates an IParserState for a parse operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IParserState CreateParserState(
    ITokenReader tokenReader,
    IAstNodeBuilder astNodeBuilder,
    ITextSnapshot snapshot
)
Protected Overridable Function CreateParserState (
    tokenReader As ITokenReader,
    astNodeBuilder As IAstNodeBuilder,
    snapshot As ITextSnapshot
) As IParserState

Parameters

tokenReader
Type: ActiproSoftware.Text.Parsing.LLParserITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
astNodeBuilder
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.

Return Value

Type: IParserState
The IParserState that was created.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.CreateTokenReader Method

LLParserBaseCreateTokenReader Method
Creates an ITokenReader that is used by the parser to read through tokens.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract ITokenReader CreateTokenReader(
    ITextBufferReader reader
)
Public MustOverride Function CreateTokenReader (
    reader As ITextBufferReader
) As ITokenReader

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader that provides access to the text buffer.

Return Value

Type: ITokenReader
An ITokenReader that is used by the parser to read through tokens.

Implements

ILLParserCreateTokenReader(ITextBufferReader)
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.InitializeParseData Method

LLParserBaseInitializeParseData Method
Initializes a LLParseData using the specified IParserState.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void InitializeParseData(
    LLParseData parseData,
    IParserState state
)
Protected Overridable Sub InitializeParseData (
    parseData As LLParseData,
    state As IParserState
)

Parameters

parseData
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationLLParseData
The LLParseData to initialize.
state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to examine.
Remarks
This method is called by default from the CreateParseData(IParseRequest, IParserState) method.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.InitializeParserState Method

LLParserBaseInitializeParserState Method
Initializes the IParserState, allowing its CustomData property to be configured based on data from the IParseRequest, immediately prior to the parse operation running.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void InitializeParserState(
    IParserState state,
    IParseRequest request
)
Protected Overridable Sub InitializeParserState (
    state As IParserState,
    request As IParseRequest
)

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
The IParserState to initialize.
request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that initiated the parse operation.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


LLParserBase.Parse Method

LLParserBaseParse Method
Performs a parsing operation using the parameters specified in the supplied IParseRequest and returns the resulting parse data.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IParseData Parse(
    IParseRequest request
)
Public Overrides Function Parse (
    request As IParseRequest
) As IParseData

Parameters

request
Type: ActiproSoftware.Text.ParsingIParseRequest
The IParseRequest that contains data about the requested parsing operation.

Return Value

Type: IParseData
An IParseData that is the result of the parsing operation.

Implements

IParserParse(IParseRequest)
IParserParse(IParseRequest)
Remarks
A IParseRequestDispatcher typically calls this method when a queued parse request is ready to be processed.
See Also

Reference

LLParserBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Class

MergableTokenReader Class
Represents an object that can provide tokens to a ILLParser in a forward-only direction for a IMergableLexer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenReader
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenReader
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenReader
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenReader
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenReader

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MergableTokenReader : TokenReaderBase
Public Class MergableTokenReader
    Inherits TokenReaderBase

The MergableTokenReader type exposes the following members.

Constructors
 | Name | Description
Public method | MergableTokenReader | Initializes a new instance of the MergableTokenReader class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides TokenReaderBaseGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides TokenReaderBasePop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides TokenReaderBasePush.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Constructor

MergableTokenReader Constructor
Initializes a new instance of the MergableTokenReader class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MergableTokenReader(
    ITextBufferReader reader,
    IMergableLexer rootLexer
)
Public Sub New (
    reader As ITextBufferReader,
    rootLexer As IMergableLexer
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
rootLexer
Type: ActiproSoftware.Text.LexingIMergableLexer
The root IMergableLexer.
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Properties

MergableTokenReader Properties

The MergableTokenReader type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer. (Inherited from TokenReaderBase.)
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state. (Inherited from TokenReaderBase.)
Public property | LookAheadToken | Returns the IToken that is immediately after the current token. (Inherited from TokenReaderBase.)
Public property | Offset | Gets the current offset, which is offset after the last Token that was read. (Inherited from TokenReaderBase.)
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls. (Inherited from TokenReaderBase.)
Public property | Token | Gets the current IToken. (Inherited from TokenReaderBase.)
Top
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader Methods

MergableTokenReader Methods

The MergableTokenReader type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any. (Inherited from TokenReaderBase.)
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs. (Inherited from TokenReaderBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token. (Inherited from TokenReaderBase.)
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader. (Overrides TokenReaderBaseGetNextToken.)
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends. (Inherited from TokenReaderBase.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used. (Inherited from TokenReaderBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines. (Inherited from TokenReaderBase.)
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state. (Overrides TokenReaderBasePop.)
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation. (Overrides TokenReaderBasePush.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader.GetNextToken Method

MergableTokenReaderGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IToken GetNextToken()
Protected Overrides Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader.Pop Method

MergableTokenReaderPop Method
Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Pop()
Public Overrides Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITokenReaderPop
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


MergableTokenReader.Push Method

MergableTokenReaderPush Method
Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Push()
Public Overrides Sub Push

Implements

ITokenReaderPush
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

MergableTokenReader Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Class

NonTerminal Class
Represents a non-terminal symbol within a grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NonTerminal : Symbol
Public Class NonTerminal
    Inherits Symbol

The NonTerminal type exposes the following members.

Constructors
 | Name | Description
Public method | NonTerminal | Initializes a new instance of the NonTerminal class.
Top
Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | Production | Gets or sets the EbnfProduction for this non-terminal.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Constructor

NonTerminal Constructor
Initializes a new instance of the NonTerminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonTerminal(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the symbol.
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Properties

NonTerminal Properties

The NonTerminal type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | Production | Gets or sets the EbnfProduction for this non-terminal.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal.Production Property

NonTerminalProduction Property
Gets or sets the EbnfProduction for this non-terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfProduction Production { get; set; }
Public Property Production As EbnfProduction
    Get
    Set

Property Value

Type: EbnfProduction
The EbnfProduction for this non-terminal.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal Methods

NonTerminal Methods

The NonTerminal type exposes the following members.

Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal.ToTerm Method

NonTerminalToTerm Method
Overload List
 | Name | Description
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Top
See Also

Reference

NonTerminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


NonTerminal.ToTerm Method (String)

NonTerminalToTerm Method (String)
Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override EbnfSymbol ToTerm(
    string label
)
Public Overrides Function ToTerm (
    label As String
) As EbnfSymbol

Parameters

label
Type: SystemString
The string label to use.

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

NonTerminal Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Class

ParentTreeConstructionNodeBase Class
Represents an abstract ITreeConstructionNode base class that can contain child tree construction nodes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTreeConstructionNodeBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationParentTreeConstructionNodeBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class ParentTreeConstructionNodeBase : TreeConstructionNodeBase
Public MustInherit Class ParentTreeConstructionNodeBase
    Inherits TreeConstructionNodeBase

The ParentTreeConstructionNodeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ParentTreeConstructionNodeBase | Initializes a new instance of the ParentTreeConstructionNodeBase class.
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects. (Overrides TreeConstructionNodeBaseChildren.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from TreeConstructionNodeBase.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from TreeConstructionNodeBase.)
Top
Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from TreeConstructionNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form. (Inherited from TreeConstructionNodeBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Constructor

ParentTreeConstructionNodeBase Constructor
Initializes a new instance of the ParentTreeConstructionNodeBase class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ParentTreeConstructionNodeBase(
    params ITreeConstructionNode[] children
)
Protected Sub New (
    ParamArray children As ITreeConstructionNode()
)

Parameters

children
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode
The collection of child nodes.
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Properties

ParentTreeConstructionNodeBase Properties

The ParentTreeConstructionNodeBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects. (Overrides TreeConstructionNodeBaseChildren.)
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from TreeConstructionNodeBase.)
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results. (Inherited from TreeConstructionNodeBase.)
Top
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase.Children Property

ParentTreeConstructionNodeBaseChildren Property
Gets the collection of child ITreeConstructionNode objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<ITreeConstructionNode> Children { get; }
Public Overrides ReadOnly Property Children As IEnumerable(Of ITreeConstructionNode)
    Get

Property Value

Type: IEnumerable ITreeConstructionNode
The collection of child ITreeConstructionNode objects.
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParentTreeConstructionNodeBase Methods

ParentTreeConstructionNodeBase Methods

The ParentTreeConstructionNodeBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node. (Inherited from TreeConstructionNodeBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form. (Inherited from TreeConstructionNodeBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParentTreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Class

ParserState Class
Represents an object that tracks the current state of a ILLParser.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationParserState

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParserState : IParserState
Public Class ParserState
    Implements IParserState

The ParserState type exposes the following members.

Constructors
 | Name | Description
Public method | ParserState | Initializes a new instance of the ParserState class.
Top
Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Constructor

ParserState Constructor
Initializes a new instance of the ParserState class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserState(
    ILLParser parser,
    ITokenReader tokenReader,
    IAstNodeBuilder astNodeBuilder,
    ITextSnapshot snapshot
)
Public Sub New (
    parser As ILLParser,
    tokenReader As ITokenReader,
    astNodeBuilder As IAstNodeBuilder,
    snapshot As ITextSnapshot
)

Parameters

parser
Type: ActiproSoftware.Text.Parsing.LLParserILLParser
The ILLParser for which this state is tracking data.
tokenReader
Type: ActiproSoftware.Text.Parsing.LLParserITokenReader
The ITokenReader that is used to read tokens during the parsing operation.
astNodeBuilder
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results
snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Properties

ParserState Properties

The ParserState type exposes the following members.

Properties
 | Name | Description
Public property | AstNodeBuilder | Gets the IAstNodeBuilder to use for constructing AST node results.
Public property | CustomData | Gets or sets custom data that can be altered during a parsing operation.
Public property | ParseErrors | Gets the collection of IParseError objects that will be returned in the IParseData parsing result.
Public property | Parser | Gets the ILLParser for which this state is tracking data.
Public property | Snapshot | Gets the ITextSnapshot used to initiate the parsing operation, if known.
Public property | TokenReader | Gets the ITokenReader that is used to read tokens during the parsing operation.
Public property | UntargetableParseErrorTokenIds | Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.AstNodeBuilder Property

ParserStateAstNodeBuilder Property
Gets the IAstNodeBuilder to use for constructing AST node results.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAstNodeBuilder AstNodeBuilder { get; }
Public ReadOnly Property AstNodeBuilder As IAstNodeBuilder
    Get

Property Value

Type: IAstNodeBuilder
The IAstNodeBuilder to use for constructing AST node results.

Implements

IParserStateAstNodeBuilder
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.CustomData Property

ParserStateCustomData Property
Gets or sets custom data that can be altered during a parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object CustomData { get; set; }
Public Property CustomData As Object
    Get
    Set

Property Value

Type: Object
Custom data that can be altered during a parsing operation.

Implements

IParserStateCustomData
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ParseErrors Property

ParserStateParseErrors Property
Gets the collection of IParseError objects that will be returned in the IParseData parsing result.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IParseError> ParseErrors { get; }
Public ReadOnly Property ParseErrors As IEnumerable(Of IParseError)
    Get

Property Value

Type: IEnumerable IParseError
The collection of IParseError objects that will be returned in the IParseData parsing result.

Implements

IParserStateParseErrors
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.Parser Property

ParserStateParser Property
Gets the ILLParser for which this state is tracking data.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ILLParser Parser { get; }
Public ReadOnly Property Parser As ILLParser
    Get

Property Value

Type: ILLParser
The ILLParser for which this state is tracking data

Implements

IParserStateParser
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.Snapshot Property

ParserStateSnapshot Property
Gets the ITextSnapshot used to initiate the parsing operation, if known.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; }
Public ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot used to initiate the parsing operation, if known.

Implements

IParserStateSnapshot
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.TokenReader Property

ParserStateTokenReader Property
Gets the ITokenReader that is used to read tokens during the parsing operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITokenReader TokenReader { get; }
Public ReadOnly Property TokenReader As ITokenReader
    Get

Property Value

Type: ITokenReader
The ITokenReader that is used to read tokens during the parsing operation.

Implements

IParserStateTokenReader
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.UntargetableParseErrorTokenIds Property

ParserStateUntargetableParseErrorTokenIds Property
Gets or sets the collection of token IDs that should be avoided when determining where untargeted parse errors will appear.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<int> UntargetableParseErrorTokenIds { get; set; }
Public Property UntargetableParseErrorTokenIds As IEnumerable(Of Integer)
    Get
    Set

Property Value

Type: IEnumerable Int32
The collection of token IDs that should be avoided when determining where untargeted parse errors will appear.

Implements

IParserStateUntargetableParseErrorTokenIds
Remarks
If a parse error is reported without a target token, the parser will normally place the parse error at the next token. If that token is one of the IDs found in this collection, the parse error will appear after the previous token instead. This property should be set to a collection of any IDs for visually-insignificant tokens that can be passed to the parser such as a line feed, line continuation, document end, etc.
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState Methods

ParserState Methods

The ParserState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method

ParserStateReportError Method
Overload List
 | Name | Description
Public method | ReportError(IParseError) | Reports an IParseError.
Public method | ReportError(ParseErrorLevel, String) | Reports an IParseError, using the look-ahead token for its range.
Public method | ReportError(ParseErrorLevel, String, IToken) | Reports an IParseError, using the specified token for its range.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method (IParseError)

ParserStateReportError Method (IParseError)
Reports an IParseError.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void ReportError(
    IParseError parseError
)
Public Overridable Sub ReportError (
    parseError As IParseError
)

Parameters

parseError
Type: ActiproSoftware.Text.ParsingIParseError
The IParseError object that contains details about the error.

Implements

IParserStateReportError(IParseError)
See Also

Reference

ParserState Class
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method (ParseErrorLevel, String)

ParserStateReportError Method (ParseErrorLevel, String)
Reports an IParseError, using the look-ahead token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportError(
    ParseErrorLevel level,
    string description
)
Public Function ReportError (
    level As ParseErrorLevel,
    description As String
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportError(ParseErrorLevel, String)
See Also

Reference

ParserState Class
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportError Method (ParseErrorLevel, String, IToken)

ParserStateReportError Method (ParseErrorLevel, String, IToken)
Reports an IParseError, using the specified token for its range.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportError(
    ParseErrorLevel level,
    string description,
    IToken token
)
Public Function ReportError (
    level As ParseErrorLevel,
    description As String,
    token As IToken
) As IParseError

Parameters

level
Type: ActiproSoftware.Text.ParsingParseErrorLevel
A ParseErrorLevel indicating the error level.
description
Type: SystemString
The description of the error, which is displayed in the user interface.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine for the error range. If not passed, the look-ahead token is used.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportError(ParseErrorLevel, String, IToken)
See Also

Reference

ParserState Class
ReportError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method

ParserStateReportNonTerminalExpectedError Method
Overload List
 | Name | Description
Public method | ReportNonTerminalExpectedError(NonTerminal) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, IToken) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Public method | ReportNonTerminalExpectedError(NonTerminal, TextPositionRange) | Reports an IParseError indicating that a NonTerminal was expected, but not found.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method (NonTerminal)

ParserStateReportNonTerminalExpectedError Method (NonTerminal)
Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal
)
Public Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportNonTerminalExpectedError(NonTerminal)
See Also

Reference

ParserState Class
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method (NonTerminal, IToken)

ParserStateReportNonTerminalExpectedError Method (NonTerminal, IToken)
Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    IToken token
)
Public Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    token As IToken
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportNonTerminalExpectedError(NonTerminal, IToken)
See Also

Reference

ParserState Class
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)

ParserStateReportNonTerminalExpectedError Method (NonTerminal, TextPositionRange)
Reports an IParseError indicating that a NonTerminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportNonTerminalExpectedError(
    NonTerminal nonTerminal,
    TextPositionRange positionRange
)
Public Function ReportNonTerminalExpectedError (
    nonTerminal As NonTerminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

nonTerminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
The NonTerminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportNonTerminalExpectedError(NonTerminal, TextPositionRange)
See Also

Reference

ParserState Class
ReportNonTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method

ParserStateReportTerminalExpectedError Method
Overload List
 | Name | Description
Public method | ReportTerminalExpectedError(Terminal) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, IToken) | Reports an IParseError indicating that a Terminal was expected, but not found.
Public method | ReportTerminalExpectedError(Terminal, TextPositionRange) | Reports an IParseError indicating that a Terminal was expected, but not found.
Top
See Also

Reference

ParserState Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method (Terminal)

ParserStateReportTerminalExpectedError Method (Terminal)
Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportTerminalExpectedError(
    Terminal terminal
)
Public Function ReportTerminalExpectedError (
    terminal As Terminal
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportTerminalExpectedError(Terminal)
See Also

Reference

ParserState Class
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method (Terminal, IToken)

ParserStateReportTerminalExpectedError Method (Terminal, IToken)
Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportTerminalExpectedError(
    Terminal terminal,
    IToken token
)
Public Function ReportTerminalExpectedError (
    terminal As Terminal,
    token As IToken
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
token
Type: ActiproSoftware.Text.LexingIToken
The IToken at which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportTerminalExpectedError(Terminal, IToken)
See Also

Reference

ParserState Class
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ParserState.ReportTerminalExpectedError Method (Terminal, TextPositionRange)

ParserStateReportTerminalExpectedError Method (Terminal, TextPositionRange)
Reports an IParseError indicating that a Terminal was expected, but not found.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IParseError ReportTerminalExpectedError(
    Terminal terminal,
    TextPositionRange positionRange
)
Public Function ReportTerminalExpectedError (
    terminal As Terminal,
    positionRange As TextPositionRange
) As IParseError

Parameters

terminal
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal
The Terminal that was expected.
positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange over which the error should be reported.

Return Value

Type: IParseError
The IParseError that was reported.

Implements

IParserStateReportTerminalExpectedError(Terminal, TextPositionRange)
See Also

Reference

ParserState Class
ReportTerminalExpectedError Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Class

Symbol Class
Represents an abstract base class for a symbol within a grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationNonTerminal
ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class Symbol : IKeyedObject
Public MustInherit Class Symbol
    Implements IKeyedObject

The Symbol type exposes the following members.

Constructors
 | Name | Description
Protected method | Symbol | Initializes a new instance of the Symbol class.
Top
Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets or sets the string that identifies the symbol.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol.
Top
Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted.
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted.
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol.
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol.
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted.
Top
Operators
Name | Description
Addition(EbnfTerm, Symbol) |
Addition(Symbol, EbnfTerm) |
Addition(Symbol, Symbol) |
BitwiseOr(EbnfTerm, Symbol) |
BitwiseOr(Symbol, EbnfTerm) |
BitwiseOr(Symbol, Symbol) |
GreaterThan |
LessThan |
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Constructor

Symbol Constructor
Initializes a new instance of the Symbol class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Symbol(
    string key
)
Protected Sub New (
    key As String
)

Parameters

key
Type: SystemString
A string that identifies the symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Properties

Symbol Properties

The Symbol type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | Key | Gets or sets the string that identifies the symbol.
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol.
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.CanMatchCallback Property

SymbolCanMatchCallback Property
Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParserCanMatchCallback CanMatchCallback { get; set; }
Public Property CanMatchCallback As ParserCanMatchCallback
    Get
    Set

Property Value

Type: ParserCanMatchCallback
The delegate that will be called when the non-terminal needs to determine at run-time whether it can parse.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ErrorAlias Property

SymbolErrorAlias Property
Gets or sets the alias to use for this symbol when reporting errors.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ErrorAlias { get; set; }
Public Property ErrorAlias As String
    Get
    Set

Property Value

Type: String
The alias to use for this symbol when reporting errors.
Remarks

Terminals always report errors and use their Key if no error alias is specified. Non-terminals will only report errors if an error alias is specified.

Once the grammar has been compiled, the setter of this property will throw an exception if called.

See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.IsCompiled Property

SymbolIsCompiled Property
Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Key Property

SymbolKey Property
Gets or sets the string that identifies the symbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
The string that identifies the symbol.

Implements

IKeyedObjectKey
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.SetLabel Property

SymbolSetLabel Property
Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfSymbol this[
    string label
] { get; }
Public ReadOnly Property SetLabel (
    label As String
) As EbnfSymbol
    Get

Parameters

label
Type: SystemString
The string label to use.

Property Value

Type: EbnfSymbol
The EbnfSymbol that was created.
Remarks
This indexer is defined as shorthand syntax for calling the ToTerm(String) method.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Methods

Symbol Methods

The Symbol type exposes the following members.

Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure.
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted.
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term.
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed.
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed.
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted.
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol.
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol.
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted.
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.CanMatch Method

SymbolCanMatch Method
Returns whether the symbol can start to match using callbacks or the current look-ahead token.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMatch(
    IParserState state
)
Public Function CanMatch (
    state As IParserState
) As Boolean

Parameters

state
Type: ActiproSoftware.Text.Parsing.LLParserIParserState
An IParserState that provides information about the current parser state.

Return Value

Type: Boolean
true if the symbol can start to match; otherwise, false.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnComplete Method

SymbolOnComplete Method
Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnComplete(
    ParserCallback callback
)
Public Function OnComplete (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called after the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OneOrMore Method

SymbolOneOrMore Method
Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier OneOrMore()
Public Function OneOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnError Method

SymbolOnError Method
Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnError(
    ParserErrorCallback callback
)
Public Function OnError (
    callback As ParserErrorCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserErrorCallback
The delegate that will be called when an error occurs while parsing the term.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnErrorContinue Method

SymbolOnErrorContinue Method
Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorContinue()
Public Function OnErrorContinue As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnErrorIgnore Method

SymbolOnErrorIgnore Method
Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorIgnore()
Public Function OnErrorIgnore As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnErrorNoReport Method

SymbolOnErrorNoReport Method
Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnErrorNoReport()
Public Function OnErrorNoReport As EbnfQuantifiableTerm

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnInitialize Method

SymbolOnInitialize Method
Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnInitialize(
    ParserCallback callback
)
Public Function OnInitialize (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called before the term is parsed.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.OnSuccess Method

SymbolOnSuccess Method
Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifiableTerm OnSuccess(
    ParserCallback callback
)
Public Function OnSuccess (
    callback As ParserCallback
) As EbnfQuantifiableTerm

Parameters

callback
Type: ActiproSoftware.Text.Parsing.LLParserParserCallback
The delegate that will be called when the term is successfully parsed.

Return Value

Type: EbnfQuantifiableTerm
The EbnfTerm that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Optional Method

SymbolOptional Method
Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier Optional()
Public Function Optional As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Range Method

SymbolRange Method
Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier Range(
    int min,
    Nullable<int> max
)
Public Function Range (
    min As Integer,
    max As Nullable(Of Integer)
) As EbnfQuantifier

Parameters

min
Type: SystemInt32
The minimum number of instances.
max
Type: SystemNullable Int32
The maximum number of instances.

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToString Method

SymbolToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToTerm Method

SymbolToTerm Method
Overload List
 | Name | Description
Public method | ToTerm | Wraps this symbol with an EbnfSymbol.
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol.
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToTerm Method

SymbolToTerm Method
Wraps this symbol with an EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfSymbol ToTerm()
Public Function ToTerm As EbnfSymbol

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

Symbol Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ToTerm Method (String)

SymbolToTerm Method (String)
Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract EbnfSymbol ToTerm(
    string label
)
Public MustOverride Function ToTerm (
    label As String
) As EbnfSymbol

Parameters

label
Type: SystemString
The string label to use.

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

Symbol Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.ZeroOrMore Method

SymbolZeroOrMore Method
Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EbnfQuantifier ZeroOrMore()
Public Function ZeroOrMore As EbnfQuantifier

Return Value

Type: EbnfQuantifier
The EbnfQuantifier term that wraps this symbol.
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol Operators

Symbol Operators

The Symbol type exposes the following members.

Operators
Name | Description
Addition(EbnfTerm, Symbol) |
Addition(Symbol, EbnfTerm) |
Addition(Symbol, Symbol) |
BitwiseOr(EbnfTerm, Symbol) |
BitwiseOr(Symbol, EbnfTerm) |
BitwiseOr(Symbol, Symbol) |
GreaterThan |
LessThan |
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator

SymbolAddition Operator
Overload List
Name | Description
Addition(EbnfTerm, Symbol) |
Addition(Symbol, EbnfTerm) |
Addition(Symbol, Symbol) |
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator (EbnfTerm, Symbol)

SymbolAddition Operator (EbnfTerm, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    EbnfTerm left,
    Symbol right
)
Public Shared Operator + (
    left As EbnfTerm,
    right As Symbol
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
Addition Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator (Symbol, EbnfTerm)

SymbolAddition Operator (Symbol, EbnfTerm)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    Symbol left,
    EbnfTerm right
)
Public Shared Operator + (
    left As Symbol,
    right As EbnfTerm
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

Symbol Class
Addition Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.Addition Operator (Symbol, Symbol)

SymbolAddition Operator (Symbol, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfConcatenation operator +(
    Symbol left,
    Symbol right
)
Public Shared Operator + (
    left As Symbol,
    right As Symbol
) As EbnfConcatenation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfConcatenation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_Addition(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
Addition Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator

SymbolBitwiseOr Operator
Overload List
Name | Description
BitwiseOr(EbnfTerm, Symbol) |
BitwiseOr(Symbol, EbnfTerm) |
BitwiseOr(Symbol, Symbol) |
Top
See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator (EbnfTerm, Symbol)

SymbolBitwiseOr Operator (EbnfTerm, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    EbnfTerm left,
    Symbol right
)
Public Shared Operator Or (
    left As EbnfTerm,
    right As Symbol
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
BitwiseOr Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator (Symbol, EbnfTerm)

SymbolBitwiseOr Operator (Symbol, EbnfTerm)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    Symbol left,
    EbnfTerm right
)
Public Shared Operator Or (
    left As Symbol,
    right As EbnfTerm
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationEbnfTerm

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.EbnfTerm)"]

See Also

Reference

Symbol Class
BitwiseOr Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.BitwiseOr Operator (Symbol, Symbol)

SymbolBitwiseOr Operator (Symbol, Symbol)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfAlternation operator |(
    Symbol left,
    Symbol right
)
Public Shared Operator Or (
    left As Symbol,
    right As Symbol
) As EbnfAlternation

Parameters

left
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

right
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

Return Value

Type: EbnfAlternation

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_BitwiseOr(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol)"]

See Also

Reference

Symbol Class
BitwiseOr Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.GreaterThan Operator

SymbolGreaterThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfProduction operator >(
    Symbol symbol,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator > (
    symbol As Symbol,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="symbol"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_GreaterThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Symbol.LessThan Operator

SymbolLessThan Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EbnfProduction operator <(
    Symbol symbol,
    ITreeConstructionNode treeConstructor
)
Public Shared Operator < (
    symbol As Symbol,
    treeConstructor As ITreeConstructionNode
) As EbnfProduction

Parameters

symbol
Type: ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol

[Missing <param name="symbol"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

treeConstructor
Type: ActiproSoftware.Text.Parsing.LLParserITreeConstructionNode

[Missing <param name="treeConstructor"/> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

Return Value

Type: EbnfProduction

[Missing <returns> documentation for "M:ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol.op_LessThan(ActiproSoftware.Text.Parsing.LLParser.Implementation.Symbol,ActiproSoftware.Text.Parsing.LLParser.ITreeConstructionNode)"]

See Also

Reference

Symbol Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Class

Terminal Class
Represents a terminal symbol within a grammar.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationSymbol
ActiproSoftware.Text.Parsing.LLParser.ImplementationTerminal

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Terminal : Symbol
Public Class Terminal
    Inherits Symbol

The Terminal type exposes the following members.

Constructors
 | Name | Description
Public method | Terminal(Int32) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, ITokenIdProvider) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, String) | Initializes a new instance of the Terminal class.
Top
Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | Id | Gets or sets the ID that identifies the terminal.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor

Terminal Constructor
Overload List
 | Name | Description
Public method | Terminal(Int32) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, ITokenIdProvider) | Initializes a new instance of the Terminal class.
Public method | Terminal(NullableInt32, String) | Initializes a new instance of the Terminal class.
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor (Int32)

Terminal Constructor (Int32)
Initializes a new instance of the Terminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Terminal(
    int id
)
Public Sub New (
    id As Integer
)

Parameters

id
Type: SystemInt32
The ID that identifies the terminal.
See Also

Reference

Terminal Class
Terminal Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor (Nullable(Int32), ITokenIdProvider)

Terminal Constructor (NullableInt32, ITokenIdProvider)
Initializes a new instance of the Terminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Terminal(
    Nullable<int> id,
    ITokenIdProvider tokenIdProvider
)
Public Sub New (
    id As Nullable(Of Integer),
    tokenIdProvider As ITokenIdProvider
)

Parameters

id
Type: SystemNullable Int32
The ID that identifies the terminal.
tokenIdProvider
Type: ActiproSoftware.Text.LexingITokenIdProvider
An ITokenIdProvider that can provide a key for the specified token ID.
See Also

Reference

Terminal Class
Terminal Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Constructor (Nullable(Int32), String)

Terminal Constructor (NullableInt32, String)
Initializes a new instance of the Terminal class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Terminal(
    Nullable<int> id,
    string key
)
Public Sub New (
    id As Nullable(Of Integer),
    key As String
)

Parameters

id
Type: SystemNullable Int32
The ID that identifies the terminal.
key
Type: SystemString
A string that identifies the symbol.
See Also

Reference

Terminal Class
Terminal Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Properties

Terminal Properties

The Terminal type exposes the following members.

Properties
 | Name | Description
Public property | CanMatchCallback | Gets or sets the delegate that will be called when the non-terminal needs to determine at run-time whether it can parse. (Inherited from Symbol.)
Public property | ErrorAlias | Gets or sets the alias to use for this symbol when reporting errors. (Inherited from Symbol.)
Public property | Id | Gets or sets the ID that identifies the terminal.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method. (Inherited from Symbol.)
Public property | Key | Gets or sets the string that identifies the symbol. (Inherited from Symbol.)
Public property | SetLabel | Wraps this symbol with a labeled EbnfSymbol. (Inherited from Symbol.)
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal.Id Property

TerminalId Property
Gets or sets the ID that identifies the terminal.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> Id { get; set; }
Public Property Id As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The ID that identifies the terminal.
Remarks
Once the grammar has been compiled, the setter of this property will throw an exception if called.
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal Methods

Terminal Methods

The Terminal type exposes the following members.

Methods
 | Name | Description
Public method | CanMatch | Returns whether the symbol can start to match using callbacks or the current look-ahead token. (Inherited from Symbol.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnComplete | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called after the term is parsed, regardless of success or failure. (Inherited from Symbol.)
Public method | OneOrMore | Wraps this symbol with an EbnfQuantifier such that one to many instances are permitted. (Inherited from Symbol.)
Public method | OnError | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when an error occurs while parsing the term. (Inherited from Symbol.)
Public method | OnErrorContinue | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, the error will be reported but parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorIgnore | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will continue on. (Inherited from Symbol.)
Public method | OnErrorNoReport | Wraps this symbol with an EbnfSymbol and marks that if an error occurs while parsing the term, no error will be reported and parsing will return a match failure. (Inherited from Symbol.)
Public method | OnInitialize | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called before the term is parsed. (Inherited from Symbol.)
Public method | OnSuccess | Wraps this symbol with an EbnfSymbol and sets the delegate that will be called when the term is successfully parsed. (Inherited from Symbol.)
Public method | Optional | Wraps this symbol with an EbnfQuantifier such that zero or one instances are permitted. (Inherited from Symbol.)
Public method | Range | Wraps this symbol with an EbnfQuantifier such that a range of instances are permitted. (Inherited from Symbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Symbol.)
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Public method | ZeroOrMore | Wraps this symbol with an EbnfQuantifier such that zero to many instances are permitted. (Inherited from Symbol.)
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal.ToTerm Method

TerminalToTerm Method
Overload List
 | Name | Description
Public method | ToTerm | Wraps this symbol with an EbnfSymbol. (Inherited from Symbol.)
Public method | ToTerm(String) | Wraps this symbol with a labeled EbnfSymbol. (Overrides SymbolToTerm(String).)
Top
See Also

Reference

Terminal Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


Terminal.ToTerm Method (String)

TerminalToTerm Method (String)
Wraps this symbol with a labeled EbnfSymbol.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override EbnfSymbol ToTerm(
    string label
)
Public Overrides Function ToTerm (
    label As String
) As EbnfSymbol

Parameters

label
Type: SystemString
The string label to use.

Return Value

Type: EbnfSymbol
The EbnfSymbol that was created.
See Also

Reference

Terminal Class
ToTerm Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Class

TokenReaderBase Class
Represents the abstract base class of an object that can provide tokens to a ILLParser in a forward-only direction.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTokenReaderBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationMergableTokenReader

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TokenReaderBase : ITokenReader
Public MustInherit Class TokenReaderBase
    Implements ITokenReader

The TokenReaderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TokenReaderBase | Initializes a new instance of the TokenReaderBase class.
Top
Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Constructor

TokenReaderBase Constructor
Initializes a new instance of the TokenReaderBase class.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TokenReaderBase(
    ITextBufferReader reader
)
Protected Sub New (
    reader As ITextBufferReader
)

Parameters

reader
Type: ActiproSoftware.TextITextBufferReader
The ITextBufferReader to use for consuming text.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Properties

TokenReaderBase Properties

The TokenReaderBase type exposes the following members.

Properties
 | Name | Description
Public property | IsAtEnd | Gets whether the current IToken is at the end of the text buffer.
Public property | IsParserInErrorState | Gets or sets whether the parser is currently recovering from an error state.
Public property | LookAheadToken | Returns the IToken that is immediately after the current token.
Public property | Offset | Gets the current offset, which is offset after the last Token that was read.
Public property | StackLevel | Gets the current stack level from Push calls without corresponding Pop calls.
Public property | Token | Gets the current IToken.
Top
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.IsAtEnd Property

TokenReaderBaseIsAtEnd Property
Gets whether the current IToken is at the end of the text buffer.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAtEnd { get; }
Public ReadOnly Property IsAtEnd As Boolean
    Get

Property Value

Type: Boolean
true if the current IToken is at the end of the text buffer; otherwise, false.

Implements

ITokenReaderIsAtEnd
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.IsParserInErrorState Property

TokenReaderBaseIsParserInErrorState Property
Gets or sets whether the parser is currently recovering from an error state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsParserInErrorState { get; set; }
Public Property IsParserInErrorState As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the parser is currently recovering from an error state; otherwise, false.

Implements

ITokenReaderIsParserInErrorState
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.LookAheadToken Property

TokenReaderBaseLookAheadToken Property
Returns the IToken that is immediately after the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken LookAheadToken { get; }
Public ReadOnly Property LookAheadToken As IToken
    Get

Property Value

Type: IToken
The IToken that is immediately after the current token.

Implements

ITokenReaderLookAheadToken
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Offset Property

TokenReaderBaseOffset Property
Gets the current offset, which is offset after the last Token that was read.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Offset { get; }
Public ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The current offset, which is offset after the last Token that was read.

Implements

ITokenReaderOffset
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.StackLevel Property

TokenReaderBaseStackLevel Property
Gets the current stack level from Push calls without corresponding Pop calls.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int StackLevel { get; }
Public ReadOnly Property StackLevel As Integer
    Get

Property Value

Type: Int32
The current stack level.

Implements

ITokenReaderStackLevel
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Token Property

TokenReaderBaseToken Property
Gets the current IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken Token { get; }
Public ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The current IToken.

Implements

ITokenReaderToken
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase Methods

TokenReaderBase Methods

The TokenReaderBase type exposes the following members.

Methods
 | Name | Description
Public method | Advance | Advances to the next IToken.
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AreNext | Returns whether the next look-ahead tokens match the specified sequence of token IDs.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLookAheadToken | Returns the IToken that is the specified number of positions past the current token.
Protected method | GetNextToken | Returns the next IToken that will be consumed by the token reader.
Public method | GetTokenText | Returns an IToken's encapsulated text from the text buffer using Newline for line ends.
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Initializes the token reader, which will be called by a ILLParser before the token reader is used.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the text lines.
Public method | Pop | Pops the top token reader state from the stack and restores the token reader to that state.
Public method | Push | Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Advance Method

TokenReaderBaseAdvance Method
Advances to the next IToken.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Advance()
Public Sub Advance

Implements

ITokenReaderAdvance
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AdvanceTo Method

TokenReaderBaseAdvanceTo Method
Overload List
 | Name | Description
Public method | AdvanceTo(Int32) | Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.
Public method | AdvanceTo(Int32) | Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.
Top
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AdvanceTo Method (Int32)

TokenReaderBaseAdvanceTo Method (Int32)
Advances to the next IToken with the specified ID, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AdvanceTo(
    int tokenId
)
Public Function AdvanceTo (
    tokenId As Integer
) As Boolean

Parameters

tokenId
Type: SystemInt32
The ID of IToken for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.

Implements

ITokenReaderAdvanceTo(Int32)
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

TokenReaderBase Class
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AdvanceTo Method (Int32[])

TokenReaderBaseAdvanceTo Method (Int32)
Advances to the next IToken with one of the specified IDs, such that the LookAheadToken property will be pointing to the matched token, if any.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AdvanceTo(
    params int[] tokenIds
)
Public Function AdvanceTo (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The array of IToken IDs for which to search.

Return Value

Type: Boolean
true if an IToken was found before the end of document; otherwise, false.

Implements

ITokenReaderAdvanceTo(Int32)
Remarks
If this method is successful, the LookAheadToken will be the IToken that was located.
See Also

Reference

TokenReaderBase Class
AdvanceTo Overload
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.AreNext Method

TokenReaderBaseAreNext Method
Returns whether the next look-ahead tokens match the specified sequence of token IDs.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreNext(
    params int[] tokenIds
)
Public Function AreNext (
    ParamArray tokenIds As Integer()
) As Boolean

Parameters

tokenIds
Type: SystemInt32
The sequence of token IDs for which to search.

Return Value

Type: Boolean
true if the next look-ahead tokens match the specified sequence of token IDs; otherwise, false.

Implements

ITokenReaderAreNext(Int32)
Remarks
This method is very useful within can-match callbacks that require two or more token look-aheads.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.GetLookAheadToken Method

TokenReaderBaseGetLookAheadToken Method
Returns the IToken that is the specified number of positions past the current token.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken GetLookAheadToken(
    int count
)
Public Function GetLookAheadToken (
    count As Integer
) As IToken

Parameters

count
Type: SystemInt32
The number of positions past the current token to examine.

Return Value

Type: IToken
The IToken that is the specified number of positions past the current token.

Implements

ITokenReaderGetLookAheadToken(Int32)
Remarks
A parameter value of 1 will return the value of the LookAheadToken method without actually seeking past the next token.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.GetNextToken Method

TokenReaderBaseGetNextToken Method
Returns the next IToken that will be consumed by the token reader.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IToken GetNextToken()
Protected MustOverride Function GetNextToken As IToken

Return Value

Type: IToken
The next IToken that will be consumed by the token reader.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.GetTokenText Method

TokenReaderBaseGetTokenText Method
Returns an IToken's encapsulated text from the text buffer using Newline for line ends.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetTokenText(
    IToken targetToken
)
Public Function GetTokenText (
    targetToken As IToken
) As String

Parameters

targetToken
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: String
The IToken's encapsulated text from the text buffer using Newline for line ends.

Implements

ITokenReaderGetTokenText(IToken)
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Initialize Method

TokenReaderBaseInitialize Method
Initializes the token reader, which will be called by a ILLParser before the token reader is used.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Initialize()
Public Sub Initialize

Implements

ITokenReaderInitialize
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.OffsetToPosition Method

TokenReaderBaseOffsetToPosition Method
Returns the TextPosition that represents the specified offset within the text lines.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition OffsetToPosition(
    int offset
)
Public Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the snapshot.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the text lines.

Implements

ITokenReaderOffsetToPosition(Int32)
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Pop Method

TokenReaderBasePop Method
Pops the top token reader state from the stack and restores the token reader to that state.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Pop()
Public Overridable Function Pop As Boolean

Return Value

Type: Boolean
true if a pop occurred; otherwise, false.

Implements

ITokenReaderPop
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TokenReaderBase.Push Method

TokenReaderBasePush Method
Pushes the token reader state onto a stack for later restoration, generally to begin a multiple token look-ahead operation.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Push()
Public Overridable Sub Push

Implements

ITokenReaderPush
Remarks
Any call to this method must have a corresponding Pop call.
See Also

Reference

TokenReaderBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Class

TreeConstructionNodeBase Class
Represents an abstract base class a tree construction node, used to output an IAstNode for an EbnfProduction.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Parsing.LLParser.ImplementationTreeConstructionNodeBase
ActiproSoftware.Text.Parsing.LLParser.ImplementationParentTreeConstructionNodeBase

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TreeConstructionNodeBase : ITreeConstructionNode
Public MustInherit Class TreeConstructionNodeBase
    Implements ITreeConstructionNode

The TreeConstructionNodeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TreeConstructionNodeBase | Initializes a new instance of the TreeConstructionNodeBase class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Constructor

TreeConstructionNodeBase Constructor
Initializes a new instance of the TreeConstructionNodeBase class

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TreeConstructionNodeBase()
Protected Sub New
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Properties

TreeConstructionNodeBase Properties

The TreeConstructionNodeBase type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of child ITreeConstructionNode objects.
Public property | IsCompiled | Gets whether the grammar and its elements are compiled, via a call to its Compile method.
Public property | IsList | Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.
Top
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.Children Property

TreeConstructionNodeBaseChildren Property
Gets the collection of child ITreeConstructionNode objects.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IEnumerable<ITreeConstructionNode> Children { get; }
Public Overridable ReadOnly Property Children As IEnumerable(Of ITreeConstructionNode)
    Get

Property Value

Type: IEnumerable ITreeConstructionNode
The collection of child ITreeConstructionNode objects.
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.IsCompiled Property

TreeConstructionNodeBaseIsCompiled Property
Gets whether the grammar and its elements are compiled, via a call to its Compile method.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
    Get

Property Value

Type: Boolean
true if the grammar and its elements are compiled; otherwise, false.

Implements

ITreeConstructionNodeIsCompiled
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.IsList Property

TreeConstructionNodeBaseIsList Property
Gets whether this tree construction node returns a placeholder node that contains a list of IAstNode results.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsList { get; }
Public Overridable ReadOnly Property IsList As Boolean
    Get

Property Value

Type: Boolean
true if this node creates a list of IAstNode results.

Implements

ITreeConstructionNodeIsList
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase Methods

TreeConstructionNodeBase Methods

The TreeConstructionNodeBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateNode | Returns the IAstNode that is created for this tree construction node.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToEbnfString | Outputs the contents of the rewrite node in EBNF form.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.CreateNode Method

TreeConstructionNodeBaseCreateNode Method
Returns the IAstNode that is created for this tree construction node.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IAstNode CreateNode(
    IAstNodeMatchCollection matches
)
Public MustOverride Function CreateNode (
    matches As IAstNodeMatchCollection
) As IAstNode

Parameters

matches
Type: ActiproSoftware.Text.Parsing.LLParserIAstNodeMatchCollection
The collection of matched IAstNode objects within the current IAstNodeBuilder scope.

Return Value

Type: IAstNode
The IAstNode that is created for this tree construction node.

Implements

ITreeConstructionNodeCreateNode(IAstNodeMatchCollection)
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


TreeConstructionNodeBase.ToEbnfString Method

TreeConstructionNodeBaseToEbnfString Method
Outputs the contents of the rewrite node in EBNF form.

Namespace: ActiproSoftware.Text.Parsing.LLParser.Implementation
Assembly: AS.Text.LLParser.Universal (in AS.Text.LLParser.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string ToEbnfString()
Public Overridable Function ToEbnfString As String

Return Value

Type: String
A string containing the EBNF form of the rewrite node.

Implements

ITreeConstructionNodeToEbnfString
See Also

Reference

TreeConstructionNodeBase Class
ActiproSoftware.Text.Parsing.LLParser.Implementation Namespace


ActiproSoftware.Text.RegularExpressions Namespace

ActiproSoftware.Text.RegularExpressions Namespace
Contains types related to working with regular expressions.
Classes
 | Class | Description
Public class | CharClass | Stores information about a character class.
Public class | CharInterval | Stores an interval of characters.
Public class | InvalidRegexPatternException | An exception that is thrown when parsing invalid regular expression patterns.
Public class | MatchType | Represents the type of regular expression match that was made.
Public class | RegexHelper | Provides helper methods for working with regular expression patterns.


CharClass Class

CharClass Class
Stores information about a character class.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.RegularExpressionsCharClass

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CharClass : ICollection<CharInterval>,
    IEnumerable<CharInterval>, IEnumerable
Public Class CharClass
    Implements ICollection(Of CharInterval), IEnumerable(Of CharInterval),
    IEnumerable

The CharClass type exposes the following members.

Constructors
 | Name | Description
Public method | CharClass | Initializes a new instance of the CharClass class.
Public method | CharClass(Char) | Initializes a new instance of the CharClass class with a character.
Public method | CharClass(String) | Initializes a new instance of the CharClass class with a string of characters.
Public method | CharClass(CharClass) | Initializes a new instance of the CharClass class with another CharClass.
Public method | CharClass(CharInterval) | Initializes a new instance of the CharClass class with an array of CharInterval objects.
Public method | CharClass(Char, Boolean) | Initializes a new instance of the CharClass class with a character and an optional complement.
Public method | CharClass(Char, Char) | Initializes a new instance of the CharClass class with an interval of characters.
Public method | CharClass(Char, Char, Boolean) | Initializes a new instance of the CharClass class with an interval of characters and an optional complement.
Top
Properties
 | Name | Description
 | All | Gets a CharClass that contains all Unicode characters.
 | Alpha | Gets a CharClass that contains all alphabetic characters.
Public property | CharacterCount | Gets the number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.
Public property | Count | Gets the number of elements contained in the CharClass instance.
 | Digit | Gets a CharClass that contains all Unicode decimal digits.
Public property | HasCategorySpecification | Gets whether there is at least one Unicode generate category specification in the character class.
 | HexDigit | Gets a CharClass that contains all Unicode hexidecimal digits.
Public property | IsNegated | Gets whether the character class is negated.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | IsSingleCharacter | Gets whether the character class only contains an interval for a single character.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the CharClass class.
 | LineTerminator | Gets a CharClass that contains all Unicode line terminators.
 | LineTerminatorWhitespace | Gets a CharClass that contains all Unicode line terminators and whitespace characters.
 | NonAlpha | Gets a CharClass that contains no alphabetic digits.
 | NonDigit | Gets a CharClass that contains no Unicode decimal digits.
 | None | Gets a CharClass that contains no characters.
 | NonHexDigit | Gets a CharClass that contains no Unicode hexidecimal digits.
 | NonLineTerminator | Gets a CharClass that contains no Unicode line terminators.
 | NonLineTerminatorWhitespace | Gets a CharClass that contains no Unicode line terminators or whitespace characters.
 | NonWhitespace | Gets a CharClass that contains no Unicode whitespace characters.
 | NonWord | Gets a CharClass that contains no word characters.
 | Whitespace | Gets a CharClass that contains all Unicode whitespace characters.
 | Word | Gets a CharClass that contains all word characters.
Top
Methods
 | Name | Description
Public method | Add(Char) | Adds a single character to the character class.
Public method | Add(CharInterval) | Adds an interval of characters to the character class.
Public method | Add(Char, Char) | Adds an interval of characters to the character class.
Public method | AddCategory(UnicodeCategory, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddCategory(String, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddRange(CharClass) | Adds the contents of a CharClass to the collection.
Public method | AddRange(CharInterval) | Adds the contents of a CharInterval array to the collection.
Public method | Clear | Clears the characters in this CharClass instance, but does not reset the IsNegated flag.
Public method | Contains(Char) | Returns whether the specified character is in the character class.
Public method | Contains(CharClass) | Returns whether the specified character class is in the character class.
Public method | Contains(CharInterval) | Returns whether the specified interval is in the character class.
Public method | Contains(Char, Char) | Returns whether the specified interval of characters is in the character class.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetCategorySpecification | Returns whether a certain Unicode general category is specified in this character class, and if so, whether it is positive or negative matching.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove(Char) | Removes the specified character from the character class.
Public method | Remove(CharInterval) | Removes the specified character interval from the character class.
Public method | RemoveCategory(UnicodeCategory) | Removes the specified Unicode general category from the character class.
Public method | RemoveCategory(String) | Removes the specified Unicode general category from the character class.
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor

CharClass Constructor
Overload List
 | Name | Description
Public method | CharClass | Initializes a new instance of the CharClass class.
Public method | CharClass(Char) | Initializes a new instance of the CharClass class with a character.
Public method | CharClass(String) | Initializes a new instance of the CharClass class with a string of characters.
Public method | CharClass(CharClass) | Initializes a new instance of the CharClass class with another CharClass.
Public method | CharClass(CharInterval) | Initializes a new instance of the CharClass class with an array of CharInterval objects.
Public method | CharClass(Char, Boolean) | Initializes a new instance of the CharClass class with a character and an optional complement.
Public method | CharClass(Char, Char) | Initializes a new instance of the CharClass class with an interval of characters.
Public method | CharClass(Char, Char, Boolean) | Initializes a new instance of the CharClass class with an interval of characters and an optional complement.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor

CharClass Constructor
Initializes a new instance of the CharClass class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass()
Public Sub New
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char)

CharClass Constructor (Char)
Initializes a new instance of the CharClass class with a character.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    char ch
)
Public Sub New (
    ch As Char
)

Parameters

ch
Type: SystemChar
A character to add to the character class.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (String)

CharClass Constructor (String)
Initializes a new instance of the CharClass class with a string of characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    string characters
)
Public Sub New (
    characters As String
)

Parameters

characters
Type: SystemString
The string of characters to add to the character class.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (CharClass)

CharClass Constructor (CharClass)
Initializes a new instance of the CharClass class with another CharClass.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    CharClass charClass
)
Public Sub New (
    charClass As CharClass
)

Parameters

charClass
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The CharClass whose items should be added.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (CharInterval[])

CharClass Constructor (CharInterval)
Initializes a new instance of the CharClass class with an array of CharInterval objects.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    CharInterval[] intervals
)
Public Sub New (
    intervals As CharInterval()
)

Parameters

intervals
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The array of CharInterval objects that should be added.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char, Boolean)

CharClass Constructor (Char, Boolean)
Initializes a new instance of the CharClass class with a character and an optional complement.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    char ch,
    bool isNegated
)
Public Sub New (
    ch As Char,
    isNegated As Boolean
)

Parameters

ch
Type: SystemChar
A character to add to the character class.
isNegated
Type: SystemBoolean
Whether to negate the character class after adding the initial character.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char, Char)

CharClass Constructor (Char, Char)
Initializes a new instance of the CharClass class with an interval of characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    char start,
    char end
)
Public Sub New (
    start As Char,
    end As Char
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Constructor (Char, Char, Boolean)

CharClass Constructor (Char, Char, Boolean)
Initializes a new instance of the CharClass class with an interval of characters and an optional complement.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharClass(
    char start,
    char end,
    bool isNegated
)
Public Sub New (
    start As Char,
    end As Char,
    isNegated As Boolean
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
isNegated
Type: SystemBoolean
Whether to negate the character class after adding the initial character range.
See Also

Reference

CharClass Class
CharClass Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Properties

CharClass Properties

The CharClass type exposes the following members.

Properties
 | Name | Description
 | All | Gets a CharClass that contains all Unicode characters.
 | Alpha | Gets a CharClass that contains all alphabetic characters.
Public property | CharacterCount | Gets the number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.
Public property | Count | Gets the number of elements contained in the CharClass instance.
 | Digit | Gets a CharClass that contains all Unicode decimal digits.
Public property | HasCategorySpecification | Gets whether there is at least one Unicode generate category specification in the character class.
 | HexDigit | Gets a CharClass that contains all Unicode hexidecimal digits.
Public property | IsNegated | Gets whether the character class is negated.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | IsSingleCharacter | Gets whether the character class only contains an interval for a single character.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the CharClass class.
 | LineTerminator | Gets a CharClass that contains all Unicode line terminators.
 | LineTerminatorWhitespace | Gets a CharClass that contains all Unicode line terminators and whitespace characters.
 | NonAlpha | Gets a CharClass that contains no alphabetic digits.
 | NonDigit | Gets a CharClass that contains no Unicode decimal digits.
 | None | Gets a CharClass that contains no characters.
 | NonHexDigit | Gets a CharClass that contains no Unicode hexidecimal digits.
 | NonLineTerminator | Gets a CharClass that contains no Unicode line terminators.
 | NonLineTerminatorWhitespace | Gets a CharClass that contains no Unicode line terminators or whitespace characters.
 | NonWhitespace | Gets a CharClass that contains no Unicode whitespace characters.
 | NonWord | Gets a CharClass that contains no word characters.
 | Whitespace | Gets a CharClass that contains all Unicode whitespace characters.
 | Word | Gets a CharClass that contains all word characters.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.All Property

CharClassAll Property
Gets a CharClass that contains all Unicode characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass All { get; }
Public Shared ReadOnly Property All As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode characters.
Remarks
This character class is the equivalent of [\u0000-\uFFFF].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Alpha Property

CharClassAlpha Property
Gets a CharClass that contains all alphabetic characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass Alpha { get; }
Public Shared ReadOnly Property Alpha As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all alphabetic characters.
Remarks
This character class is the equivalent of \p{L} (all letters).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.CharacterCount Property

CharClassCharacterCount Property
Gets the number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CharacterCount { get; }
Public ReadOnly Property CharacterCount As Integer
    Get

Property Value

Type: Int32
The number of characters contained in the CharClass intervals, excluding any Unicode general categories specified.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Count Property

CharClassCount Property
Gets the number of elements contained in the CharClass instance.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the CharClass instance.

Implements

ICollectionTCount
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Digit Property

CharClassDigit Property
Gets a CharClass that contains all Unicode decimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass Digit { get; }
Public Shared ReadOnly Property Digit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode decimal digits.
Remarks
This character class is the equivalent of \d and \p{Nd}.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.HasCategorySpecification Property

CharClassHasCategorySpecification Property
Gets whether there is at least one Unicode generate category specification in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCategorySpecification { get; }
Public ReadOnly Property HasCategorySpecification As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one Unicode generate category specification in the character class; otherwise, false.
Remarks
Use the GetCategorySpecification(UnicodeCategory) method to test whether a specific UnicodeCategory is specified, and whether it is positive or negative.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.HexDigit Property

CharClassHexDigit Property
Gets a CharClass that contains all Unicode hexidecimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass HexDigit { get; }
Public Shared ReadOnly Property HexDigit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode hexidecimal digits.
Remarks
This character class is the equivalent of [0-9a-fA-F].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.IsNegated Property

CharClassIsNegated Property
Gets whether the character class is negated.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNegated { get; set; }
Public Property IsNegated As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the character class is negated; otherwise, false.
Remarks
The negation is the opposite of the character class, specified by a ^ character after the open square brace. When negated, the return value of Contains(Char) is toggled.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.IsReadOnly Property

CharClassIsReadOnly Property
Gets whether the collection is read-only.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the colletion is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.IsSingleCharacter Property

CharClassIsSingleCharacter Property
Gets whether the character class only contains an interval for a single character.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSingleCharacter { get; }
Public ReadOnly Property IsSingleCharacter As Boolean
    Get

Property Value

Type: Boolean
true if the character class only contains an interval for a single character; otherwise, false.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Item Property

CharClassItem Property
Gets the interval at the specified index.

[C#] In C#, this property is the indexer for the CharClass class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharInterval this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As CharInterval
    Get

Parameters

index
Type: SystemInt32
The index of the interval to return.

Property Value

Type: CharInterval
The CharInterval at the specified index.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.LineTerminator Property

CharClassLineTerminator Property
Gets a CharClass that contains all Unicode line terminators.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass LineTerminator { get; }
Public Shared ReadOnly Property LineTerminator As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode line terminators.
Remarks
This character class is the equivalent of [\n\r\p{Zl}\p{Zp}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.LineTerminatorWhitespace Property

CharClassLineTerminatorWhitespace Property
Gets a CharClass that contains all Unicode line terminators and whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass LineTerminatorWhitespace { get; }
Public Shared ReadOnly Property LineTerminatorWhitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode line terminators and whitespace characters.
Remarks
This character class is the equivalent of \s or [\f\n\r\t\v\x85\p{Z}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonAlpha Property

CharClassNonAlpha Property
Gets a CharClass that contains no alphabetic digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonAlpha { get; }
Public Shared ReadOnly Property NonAlpha As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no alphabetic digits.
Remarks
This character class is the equivalent of \P{L} (no letters).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonDigit Property

CharClassNonDigit Property
Gets a CharClass that contains no Unicode decimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonDigit { get; }
Public Shared ReadOnly Property NonDigit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode decimal digits.
Remarks
This character class is the equivalent of \D.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.None Property

CharClassNone Property
Gets a CharClass that contains no characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass None { get; }
Public Shared ReadOnly Property None As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no characters.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonHexDigit Property

CharClassNonHexDigit Property
Gets a CharClass that contains no Unicode hexidecimal digits.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonHexDigit { get; }
Public Shared ReadOnly Property NonHexDigit As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode hexidecimal digits.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonLineTerminator Property

CharClassNonLineTerminator Property
Gets a CharClass that contains no Unicode line terminators.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonLineTerminator { get; }
Public Shared ReadOnly Property NonLineTerminator As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode line terminators.
Remarks
This character class is the equivalent of [^\n\r\p{Zl}\p{Zp}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonLineTerminatorWhitespace Property

CharClassNonLineTerminatorWhitespace Property
Gets a CharClass that contains no Unicode line terminators or whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonLineTerminatorWhitespace { get; }
Public Shared ReadOnly Property NonLineTerminatorWhitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode line terminators or whitespace characters.
Remarks
This character class is the equivalent of \S or [^\f\n\r\t\v\x85\p{Z}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonWhitespace Property

CharClassNonWhitespace Property
Gets a CharClass that contains no Unicode whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonWhitespace { get; }
Public Shared ReadOnly Property NonWhitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no Unicode whitespace characters.
Remarks
This character class is the equivalent of [^\f\t\v\x85\p{Zs}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.NonWord Property

CharClassNonWord Property
Gets a CharClass that contains no word characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass NonWord { get; }
Public Shared ReadOnly Property NonWord As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains no word characters.
Remarks
This character class is the equivalent of \W and [^\p{L}\p{Nd}\p{Pc}] (no letters, decimal digits, and connectors like underscore).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Whitespace Property

CharClassWhitespace Property
Gets a CharClass that contains all Unicode whitespace characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass Whitespace { get; }
Public Shared ReadOnly Property Whitespace As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all Unicode whitespace characters.
Remarks
This character class is the equivalent of [\f\t\v\x85\p{Zs}].
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Word Property

CharClassWord Property
Gets a CharClass that contains all word characters.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static CharClass Word { get; }
Public Shared ReadOnly Property Word As CharClass
    Get

Property Value

Type: CharClass
A CharClass that contains all word characters.
Remarks
Remarks
This character class is the equivalent of \w and [\p{L}\p{Nd}\p{Pc}] (all letters, decimal digits, and connectors like underscore).
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass Methods

CharClass Methods

The CharClass type exposes the following members.

Methods
 | Name | Description
Public method | Add(Char) | Adds a single character to the character class.
Public method | Add(CharInterval) | Adds an interval of characters to the character class.
Public method | Add(Char, Char) | Adds an interval of characters to the character class.
Public method | AddCategory(UnicodeCategory, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddCategory(String, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddRange(CharClass) | Adds the contents of a CharClass to the collection.
Public method | AddRange(CharInterval) | Adds the contents of a CharInterval array to the collection.
Public method | Clear | Clears the characters in this CharClass instance, but does not reset the IsNegated flag.
Public method | Contains(Char) | Returns whether the specified character is in the character class.
Public method | Contains(CharClass) | Returns whether the specified character class is in the character class.
Public method | Contains(CharInterval) | Returns whether the specified interval is in the character class.
Public method | Contains(Char, Char) | Returns whether the specified interval of characters is in the character class.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetCategorySpecification | Returns whether a certain Unicode general category is specified in this character class, and if so, whether it is positive or negative matching.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | Returns a hash code for this object. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove(Char) | Removes the specified character from the character class.
Public method | Remove(CharInterval) | Removes the specified character interval from the character class.
Public method | RemoveCategory(UnicodeCategory) | Removes the specified Unicode general category from the character class.
Public method | RemoveCategory(String) | Removes the specified Unicode general category from the character class.
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method

CharClassAdd Method
Overload List
 | Name | Description
Public method | Add(Char) | Adds a single character to the character class.
Public method | Add(CharInterval) | Adds an interval of characters to the character class.
Public method | Add(Char, Char) | Adds an interval of characters to the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method (Char)

CharClassAdd Method (Char)
Adds a single character to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    char ch
)
Public Sub Add (
    ch As Char
)

Parameters

ch
Type: SystemChar
The character to add.
See Also

Reference

CharClass Class
Add Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method (CharInterval)

CharClassAdd Method (CharInterval)
Adds an interval of characters to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    CharInterval interval
)
Public Sub Add (
    interval As CharInterval
)

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The interval of characters to add.

Implements

ICollectionTAdd(T)
See Also

Reference

CharClass Class
Add Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Add Method (Char, Char)

CharClassAdd Method (Char, Char)
Adds an interval of characters to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    char start,
    char end
)
Public Sub Add (
    start As Char,
    end As Char
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
See Also

Reference

CharClass Class
Add Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddCategory Method

CharClassAddCategory Method
Overload List
 | Name | Description
Public method | AddCategory(UnicodeCategory, Boolean) | Adds the specified Unicode general category to the character class.
Public method | AddCategory(String, Boolean) | Adds the specified Unicode general category to the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddCategory Method (UnicodeCategory, Boolean)

CharClassAddCategory Method (UnicodeCategory, Boolean)
Adds the specified Unicode general category to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddCategory(
    UnicodeCategory category,
    bool negate
)
Public Sub AddCategory (
    category As UnicodeCategory,
    negate As Boolean
)

Parameters

category
Type: System.GlobalizationUnicodeCategory
A UnicodeCategory indicating the category.
negate
Type: SystemBoolean
Whether to negate the category.
See Also

Reference

CharClass Class
AddCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddCategory Method (String, Boolean)

CharClassAddCategory Method (String, Boolean)
Adds the specified Unicode general category to the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddCategory(
    string categoryName,
    bool negate
)
Public Sub AddCategory (
    categoryName As String,
    negate As Boolean
)

Parameters

categoryName
Type: SystemString
The name of the category. For example, Lu is used for uppercase letters.
negate
Type: SystemBoolean
Whether to negate the category.
See Also

Reference

CharClass Class
AddCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddRange Method

CharClassAddRange Method
Overload List
 | Name | Description
Public method | AddRange(CharClass) | Adds the contents of a CharClass to the collection.
Public method | AddRange(CharInterval) | Adds the contents of a CharInterval array to the collection.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddRange Method (CharClass)

CharClassAddRange Method (CharClass)
Adds the contents of a CharClass to the collection.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddRange(
    CharClass charClass
)
Public Sub AddRange (
    charClass As CharClass
)

Parameters

charClass
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The CharClass whose values are to be added.
See Also

Reference

CharClass Class
AddRange Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.AddRange Method (CharInterval[])

CharClassAddRange Method (CharInterval)
Adds the contents of a CharInterval array to the collection.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddRange(
    CharInterval[] intervals
)
Public Sub AddRange (
    intervals As CharInterval()
)

Parameters

intervals
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The CharInterval array whose values are to be added.
See Also

Reference

CharClass Class
AddRange Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Clear Method

CharClassClear Method
Clears the characters in this CharClass instance, but does not reset the IsNegated flag.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method

CharClassContains Method
Overload List
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is in the character class.
Public method | Contains(CharClass) | Returns whether the specified character class is in the character class.
Public method | Contains(CharInterval) | Returns whether the specified interval is in the character class.
Public method | Contains(Char, Char) | Returns whether the specified interval of characters is in the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (Char)

CharClassContains Method (Char)
Returns whether the specified character is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    char ch
)
Public Function Contains (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to look for in the collection.

Return Value

Type: Boolean
true if the character is in the collection; otherwise, false.
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (CharClass)

CharClassContains Method (CharClass)
Returns whether the specified character class is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    CharClass charClass
)
Public Function Contains (
    charClass As CharClass
) As Boolean

Parameters

charClass
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The CharClass to look for in the collection.

Return Value

Type: Boolean
true if the character class is in the collection; otherwise, false.
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (CharInterval)

CharClassContains Method (CharInterval)
Returns whether the specified interval is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    CharInterval interval
)
Public Function Contains (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The CharInterval to look for in the collection.

Return Value

Type: Boolean
true if the interval is in the collection; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Contains Method (Char, Char)

CharClassContains Method (Char, Char)
Returns whether the specified interval of characters is in the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    char start,
    char end
)
Public Function Contains (
    start As Char,
    end As Char
) As Boolean

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.

Return Value

Type: Boolean
true if the interval of characters is in the collection; otherwise, false.
See Also

Reference

CharClass Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.CopyTo Method

CharClassCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    CharInterval[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As CharInterval(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The one-dimensional CharInterval array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Equals Method

CharClassEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.GetCategorySpecification Method

CharClassGetCategorySpecification Method
Returns whether a certain Unicode general category is specified in this character class, and if so, whether it is positive or negative matching.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> GetCategorySpecification(
    UnicodeCategory category
)
Public Function GetCategorySpecification (
    category As UnicodeCategory
) As Nullable(Of Boolean)

Parameters

category
Type: System.GlobalizationUnicodeCategory
A UnicodeCategory indicating the category.

Return Value

Type: Nullable Boolean
true if the category is specified as a positive match. false if the category is specified as a negative match. if the category is not specified.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.GetEnumerator Method

CharClassGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<CharInterval> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of CharInterval)

Return Value

Type: IEnumerator CharInterval
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.GetHashCode Method

CharClassGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Remove Method

CharClassRemove Method
Overload List
 | Name | Description
Public method | Remove(Char) | Removes the specified character from the character class.
Public method | Remove(CharInterval) | Removes the specified character interval from the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Remove Method (Char)

CharClassRemove Method (Char)
Removes the specified character from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    char ch
)
Public Function Remove (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to remove.

Return Value

Type: Boolean
true if the character was removed; otherwise, false.
See Also

Reference

CharClass Class
Remove Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.Remove Method (CharInterval)

CharClassRemove Method (CharInterval)
Removes the specified character interval from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    CharInterval interval
)
Public Function Remove (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The character interval to remove.

Return Value

Type: Boolean
true if the character interval was removed; otherwise, false.

Implements

ICollectionTRemove(T)
See Also

Reference

CharClass Class
Remove Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.RemoveCategory Method

CharClassRemoveCategory Method
Overload List
 | Name | Description
Public method | RemoveCategory(UnicodeCategory) | Removes the specified Unicode general category from the character class.
Public method | RemoveCategory(String) | Removes the specified Unicode general category from the character class.
Top
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.RemoveCategory Method (UnicodeCategory)

CharClassRemoveCategory Method (UnicodeCategory)
Removes the specified Unicode general category from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveCategory(
    UnicodeCategory category
)
Public Sub RemoveCategory (
    category As UnicodeCategory
)

Parameters

category
Type: System.GlobalizationUnicodeCategory
A UnicodeCategory indicating the category.
See Also

Reference

CharClass Class
RemoveCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.RemoveCategory Method (String)

CharClassRemoveCategory Method (String)
Removes the specified Unicode general category from the character class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveCategory(
    string categoryName
)
Public Sub RemoveCategory (
    categoryName As String
)

Parameters

categoryName
Type: SystemString
The name of the category. For example, Lu is used for uppercase letters.
See Also

Reference

CharClass Class
RemoveCategory Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharClass.ToString Method

CharClassToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

CharClass Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Class

CharInterval Class
Stores an interval of characters.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.Text.RegularExpressionsCharInterval

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CharInterval : ValueType
Public NotInheritable Class CharInterval
    Inherits ValueType

The CharInterval type exposes the following members.

Constructors
 | Name | Description
Public method | CharInterval(Char) | Initializes a new instance of the CharInterval class.
Public method | CharInterval(Char, Char) | Initializes a new instance of the CharInterval class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of characters contained in interval.
Public property | End | Gets or sets the end character in the interval of this CharInterval.
Public property | Start | Gets or sets the start character in the interval of this CharInterval.
Top
Methods
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is contained by the interval.
Public method | Contains(CharInterval) | Returns whether the specified character interval is contained by the interval.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetIntersection | Creates the intersection of the interval with another CharInterval.
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith | Returns whether the specified character interval intersects with the interval.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Constructor

CharInterval Constructor
Overload List
 | Name | Description
Public method | CharInterval(Char) | Initializes a new instance of the CharInterval class.
Public method | CharInterval(Char, Char) | Initializes a new instance of the CharInterval class.
Top
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Constructor (Char)

CharInterval Constructor (Char)
Initializes a new instance of the CharInterval class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharInterval(
    char ch
)
Public Sub New (
    ch As Char
)

Parameters

ch
Type: SystemChar
The character in the interval.
See Also

Reference

CharInterval Class
CharInterval Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Constructor (Char, Char)

CharInterval Constructor (Char, Char)
Initializes a new instance of the CharInterval class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharInterval(
    char start,
    char end
)
Public Sub New (
    start As Char,
    end As Char
)

Parameters

start
Type: SystemChar
The start character in the interval.
end
Type: SystemChar
The end character in the interval.
See Also

Reference

CharInterval Class
CharInterval Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Properties

CharInterval Properties

The CharInterval type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of characters contained in interval.
Public property | End | Gets or sets the end character in the interval of this CharInterval.
Public property | Start | Gets or sets the start character in the interval of this CharInterval.
Top
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Count Property

CharIntervalCount Property
Gets the number of characters contained in interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of characters contained in interval.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.End Property

CharIntervalEnd Property
Gets or sets the end character in the interval of this CharInterval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char End { get; set; }
Public Property End As Char
    Get
    Set

Property Value

Type: Char
The end character in the interval of this CharInterval.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Start Property

CharIntervalStart Property
Gets or sets the start character in the interval of this CharInterval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char Start { get; set; }
Public Property Start As Char
    Get
    Set

Property Value

Type: Char
The start character in the interval of this CharInterval.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Methods

CharInterval Methods

The CharInterval type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is contained by the interval.
Public method | Contains(CharInterval) | Returns whether the specified character interval is contained by the interval.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetIntersection | Creates the intersection of the interval with another CharInterval.
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith | Returns whether the specified character interval intersects with the interval.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Contains Method

CharIntervalContains Method
Overload List
 | Name | Description
Public method | Contains(Char) | Returns whether the specified character is contained by the interval.
Public method | Contains(CharInterval) | Returns whether the specified character interval is contained by the interval.
Top
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Contains Method (Char)

CharIntervalContains Method (Char)
Returns whether the specified character is contained by the interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    char ch
)
Public Function Contains (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to test.

Return Value

Type: Boolean
true if the specified character is contained by the interval; otherwise, false.
See Also

Reference

CharInterval Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Contains Method (CharInterval)

CharIntervalContains Method (CharInterval)
Returns whether the specified character interval is contained by the interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    CharInterval interval
)
Public Function Contains (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The character interval to test.

Return Value

Type: Boolean
true if the specified character interval is contained by the interval; otherwise, false.
See Also

Reference

CharInterval Class
Contains Overload
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Equals Method

CharIntervalEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.GetHashCode Method

CharIntervalGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.GetIntersection Method

CharIntervalGetIntersection Method
Creates the intersection of the interval with another CharInterval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CharInterval GetIntersection(
    CharInterval interval
)
Public Function GetIntersection (
    interval As CharInterval
) As CharInterval

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The CharInterval used to find the intersection.

Return Value

Type: CharInterval
The intersection of the interval with another CharInterval.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.IntersectsWith Method

CharIntervalIntersectsWith Method
Returns whether the specified character interval intersects with the interval.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    CharInterval interval
)
Public Function IntersectsWith (
    interval As CharInterval
) As Boolean

Parameters

interval
Type: ActiproSoftware.Text.RegularExpressionsCharInterval
The character interval to test.

Return Value

Type: Boolean
true if the specified character interval intersects with the interval; otherwise, false.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.ToString Method

CharIntervalToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval Operators

CharInterval Operators

The CharInterval type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Equality Operator

CharIntervalEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    CharInterval left,
    CharInterval right
)
Public Shared Operator = (
    left As CharInterval,
    right As CharInterval
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

right
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Equality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


CharInterval.Inequality Operator

CharIntervalInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    CharInterval left,
    CharInterval right
)
Public Shared Operator <> (
    left As CharInterval,
    right As CharInterval
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

right
Type: ActiproSoftware.Text.RegularExpressionsCharInterval

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.RegularExpressions.CharInterval.op_Inequality(ActiproSoftware.Text.RegularExpressions.CharInterval,ActiproSoftware.Text.RegularExpressions.CharInterval)"]

See Also

Reference

CharInterval Class
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Class

InvalidRegexPatternException Class
An exception that is thrown when parsing invalid regular expression patterns.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.Text.RegularExpressionsInvalidRegexPatternException

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvalidRegexPatternException : Exception
Public Class InvalidRegexPatternException
    Inherits Exception

The InvalidRegexPatternException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidRegexPatternException | Initializes a new instance of the InvalidRegexPatternException class.
Public method | InvalidRegexPatternException(String) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message.
Public method | InvalidRegexPatternException(String, Exception) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor

InvalidRegexPatternException Constructor
Overload List
 | Name | Description
Public method | InvalidRegexPatternException | Initializes a new instance of the InvalidRegexPatternException class.
Public method | InvalidRegexPatternException(String) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message.
Public method | InvalidRegexPatternException(String, Exception) | Initializes a new instance of the InvalidRegexPatternException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidRegexPatternException Class
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor

InvalidRegexPatternException Constructor
Initializes a new instance of the InvalidRegexPatternException class.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidRegexPatternException()
Public Sub New
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor (String)

InvalidRegexPatternException Constructor (String)
Initializes a new instance of the InvalidRegexPatternException class with a specified error message.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidRegexPatternException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Constructor (String, Exception)

InvalidRegexPatternException Constructor (String, Exception)
Initializes a new instance of the InvalidRegexPatternException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidRegexPatternException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

InvalidRegexPatternException Class
InvalidRegexPatternException Overload
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Properties

InvalidRegexPatternException Properties

The InvalidRegexPatternException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
See Also

Reference

InvalidRegexPatternException Class
ActiproSoftware.Text.RegularExpressions Namespace


InvalidRegexPatternException Methods

InvalidRegexPatternException Methods

The InvalidRegexPatternException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

InvalidRegexPatternException Class
ActiproSoftware.Text.RegularExpressions Namespace


MatchType Class

MatchType Class
Represents the type of regular expression match that was made.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.RegularExpressionsMatchType

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MatchType : Enum
Public NotInheritable Class MatchType
    Inherits Enum

The MatchType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ExactMatch | An exact match was made.
 | LooseMatch | A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.
 | NoMatch | No match was made.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


MatchType Methods

MatchType Methods

The MatchType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MatchType Class
ActiproSoftware.Text.RegularExpressions Namespace


MatchType Fields

MatchType Fields

The MatchType type exposes the following members.

Fields
 | Name | Description
 | ExactMatch | An exact match was made.
 | LooseMatch | A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.
 | NoMatch | No match was made.
Public field | value__ |
Top
See Also

Reference

MatchType Class
ActiproSoftware.Text.RegularExpressions Namespace


MatchType.ExactMatch Field

MatchTypeExactMatch Field
An exact match was made.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MatchType ExactMatch = 1
Public Const ExactMatch As MatchType = 1

Field Value

Type: MatchType
See Also

Reference

MatchType Class
ActiproSoftware.Text.RegularExpressions Namespace


MatchType.LooseMatch Field

MatchTypeLooseMatch Field
A loose match was made. This occurs when using a case insensitivity of AutoCorrect and a non-exact match was found.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MatchType LooseMatch = 2
Public Const LooseMatch As MatchType = 2

Field Value

Type: MatchType
See Also

Reference

MatchType Class
ActiproSoftware.Text.RegularExpressions Namespace


MatchType.NoMatch Field

MatchTypeNoMatch Field
No match was made.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MatchType NoMatch = 0
Public Const NoMatch As MatchType = 0

Field Value

Type: MatchType
See Also

Reference

MatchType Class
ActiproSoftware.Text.RegularExpressions Namespace


MatchType.value__ Field

MatchTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.RegularExpressions.MatchType.value__"]

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MatchType Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper Class

RegexHelper Class
Provides helper methods for working with regular expression patterns.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.RegularExpressionsRegexHelper

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class RegexHelper
Public NotInheritable Class RegexHelper

The RegexHelper type exposes the following members.

Methods
Name | Description
Escape(String) | Escapes all special characters in the specified regex search pattern.
Escape(String, Boolean) | Escapes all special characters in the specified regex search or replace pattern.
IsPatternSpecialChar | Returns whether the specified character is a search pattern special character.
Validate(String, Boolean) | Validates the specified regular expression pattern.
Validate(String, Boolean, HashSetString) | Validates the specified regular expression pattern and referenced lexical macros.
Top
See Also

Reference

ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper Methods

RegexHelper Methods

The RegexHelper type exposes the following members.

Methods
Name | Description
Escape(String) | Escapes all special characters in the specified regex search pattern.
Escape(String, Boolean) | Escapes all special characters in the specified regex search or replace pattern.
IsPatternSpecialChar | Returns whether the specified character is a search pattern special character.
Validate(String, Boolean) | Validates the specified regular expression pattern.
Validate(String, Boolean, HashSetString) | Validates the specified regular expression pattern and referenced lexical macros.
Top
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Escape Method

RegexHelperEscape Method
Overload List
Name | Description
Escape(String) | Escapes all special characters in the specified regex search pattern.
Escape(String, Boolean) | Escapes all special characters in the specified regex search or replace pattern.
Top
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Escape Method (String)

RegexHelperEscape Method (String)
Escapes all special characters in the specified regex search pattern.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string Escape(
    string pattern
)
Public Shared Function Escape (
    pattern As String
) As String

Parameters

pattern
Type: SystemString
The search pattern to escape.

Return Value

Type: String
The escaped pattern.
See Also

Reference

RegexHelper Class
Escape Overload
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Escape Method (String, Boolean)

RegexHelperEscape Method (String, Boolean)
Escapes all special characters in the specified regex search or replace pattern.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string Escape(
    string pattern,
    bool isReplacePattern
)
Public Shared Function Escape (
    pattern As String,
    isReplacePattern As Boolean
) As String

Parameters

pattern
Type: SystemString
The pattern to escape.
isReplacePattern
Type: SystemBoolean
Whether the pattern is a replace pattern.

Return Value

Type: String
The escaped pattern.
See Also

Reference

RegexHelper Class
Escape Overload
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.IsPatternSpecialChar Method

RegexHelperIsPatternSpecialChar Method
Returns whether the specified character is a search pattern special character.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsPatternSpecialChar(
    char ch
)
Public Shared Function IsPatternSpecialChar (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is a find pattern special character; otherwise, false.
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Validate Method

RegexHelperValidate Method
Overload List
Name | Description
Validate(String, Boolean) | Validates the specified regular expression pattern.
Validate(String, Boolean, HashSetString) | Validates the specified regular expression pattern and referenced lexical macros.
Top
See Also

Reference

RegexHelper Class
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Validate Method (String, Boolean)

RegexHelperValidate Method (String, Boolean)
Validates the specified regular expression pattern.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void Validate(
    string pattern,
    bool allowCapturing
)
Public Shared Sub Validate (
    pattern As String,
    allowCapturing As Boolean
)

Parameters

pattern
Type: SystemString
The pattern to examine.
allowCapturing
Type: SystemBoolean
Whether to allow capturing.
Remarks
An exception will be thrown if the pattern is invalid.
See Also

Reference

RegexHelper Class
Validate Overload
ActiproSoftware.Text.RegularExpressions Namespace


RegexHelper.Validate Method (String, Boolean, HashSet(String))

RegexHelperValidate Method (String, Boolean, HashSetString)
Validates the specified regular expression pattern and referenced lexical macros.

Namespace: ActiproSoftware.Text.RegularExpressions
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void Validate(
    string pattern,
    bool allowCapturing,
    HashSet<string> macroKeys
)
Public Shared Sub Validate (
    pattern As String,
    allowCapturing As Boolean,
    macroKeys As HashSet(Of String)
)

Parameters

pattern
Type: SystemString
The pattern to examine.
allowCapturing
Type: SystemBoolean
Whether to allow capturing.
macroKeys
Type: System.Collections.GenericHashSet String
The set of available lexical macro keys.
Remarks
An exception will be thrown if the pattern is invalid.
See Also

Reference

RegexHelper Class
Validate Overload
ActiproSoftware.Text.RegularExpressions Namespace


ActiproSoftware.Text.Searching Namespace

ActiproSoftware.Text.Searching Namespace
Contains types related to searching within text documents.
Classes
 | Class | Description
Public class | SearchOperationType | Specifies the type of search operation.
Public class | SearchPatternProviders | Provides access to the built-in ISearchPatternProvider instances, that can provide regular expression find/replace patterns based on a supplied pattern.
Interfaces
 | Interface | Description
Public interface | ISearchCapture | Provides the base requirements for a single capture by a regular expression match within an ISearchResult.
Public interface | ISearchCaptureCollection | Provides the base requirements for a collection of ISearchCapture objects.
Public interface | ISearchOptions | Provides the base requirements for a class that stores options for a find/replace operation.
Public interface | ISearchPatternProvider | Provides the base requirements for an object that can provide regular expression find/replace patterns based on a supplied pattern.
Public interface | ISearchPatternProviderCollection | Provides the base requirements for a collection of ISearchPatternProvider objects.
Public interface | ISearchPatternProviderFactory | Provides the base requirements for a factory capable of creating ISearchPatternProvider objects.
Public interface | ISearchResult | Provides the base requirements for a class that stores a single result of a search operation.
Public interface | ISearchResultCollection | Provides the base requirements for a collection of ISearchResult objects.
Public interface | ISearchResultSet | Provides the base requirements for a class that stores the results of a search operation.


ISearchCapture Interface

ISearchCapture Interface
Provides the base requirements for a single capture by a regular expression match within an ISearchResult.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchCapture : ITextRangeProvider,
    IKeyedObject
Public Interface ISearchCapture
    Inherits ITextRangeProvider, IKeyedObject

The ISearchCapture type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Text | Gets the text that was captured.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchCapture Properties

ISearchCapture Properties

The ISearchCapture type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Text | Gets the text that was captured.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ISearchCapture Interface
ActiproSoftware.Text.Searching Namespace


ISearchCapture.Text Property

ISearchCaptureText Property
Gets the text that was captured.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; }
ReadOnly Property Text As String
    Get

Property Value

Type: String
The text that was captured.
See Also

Reference

ISearchCapture Interface
ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Interface

ISearchCaptureCollection Interface
Provides the base requirements for a collection of ISearchCapture objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchCaptureCollection : IKeyedObservableCollection<ISearchCapture>,
    IObservableCollection<ISearchCapture>, IList<ISearchCapture>, ICollection<ISearchCapture>,
    IEnumerable<ISearchCapture>, IEnumerable
Public Interface ISearchCaptureCollection
    Inherits IKeyedObservableCollection(Of ISearchCapture), IObservableCollection(Of ISearchCapture),
    IList(Of ISearchCapture), ICollection(Of ISearchCapture), IEnumerable(Of ISearchCapture),
    IEnumerable

The ISearchCaptureCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISearchCapture .)
Public property | IsReadOnly | (Inherited from ICollection ISearchCapture .)
Public property | ItemInt32 | (Inherited from IList ISearchCapture .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ISearchCapture .)
Public method | Clear | (Inherited from ICollection ISearchCapture .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ISearchCapture .)
Public method | CopyTo | (Inherited from ICollection ISearchCapture .)
Public method | GetEnumerator | (Inherited from IEnumerable ISearchCapture .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ISearchCapture .)
Public method | Insert | (Inherited from IList ISearchCapture .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ISearchCapture .)
Public method | RemoveAt | (Inherited from IList ISearchCapture .)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Properties

ISearchCaptureCollection Properties

The ISearchCaptureCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISearchCapture .)
Public property | IsReadOnly | (Inherited from ICollection ISearchCapture .)
Public property | ItemInt32 | (Inherited from IList ISearchCapture .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Inherited from IKeyedObservableCollectionT.)
Top
See Also

Reference

ISearchCaptureCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Methods

ISearchCaptureCollection Methods

The ISearchCaptureCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ISearchCapture .)
Public method | Clear | (Inherited from ICollection ISearchCapture .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from IKeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from ICollection ISearchCapture .)
Public method | CopyTo | (Inherited from ICollection ISearchCapture .)
Public method | GetEnumerator | (Inherited from IEnumerable ISearchCapture .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Inherited from IKeyedObservableCollectionT.)
Public method | IndexOf(T) | (Inherited from IList ISearchCapture .)
Public method | Insert | (Inherited from IList ISearchCapture .)
Public method | Remove(String) | Removes the T with the specified key. (Inherited from IKeyedObservableCollectionT.)
Public method | Remove(T) | (Inherited from ICollection ISearchCapture .)
Public method | RemoveAt | (Inherited from IList ISearchCapture .)
Top
See Also

Reference

ISearchCaptureCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchCaptureCollection Events

ISearchCaptureCollection Events

The ISearchCaptureCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ISearchCaptureCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions Interface

ISearchOptions Interface
Provides the base requirements for a class that stores options for a find/replace operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchOptions
Public Interface ISearchOptions

The ISearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find.
Public property | MatchCase | Gets or sets whether searches should be case sensitive.
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words.
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found.
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).
Public property | ReplaceText | Gets or sets the text with which to replace (replace operations only).
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchOptions Properties

ISearchOptions Properties

The ISearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find.
Public property | MatchCase | Gets or sets whether searches should be case sensitive.
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words.
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found.
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).
Public property | ReplaceText | Gets or sets the text with which to replace (replace operations only).
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.FindText Property

ISearchOptionsFindText Property
Gets or sets the text to find.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string FindText { get; set; }
Property FindText As String
    Get
    Set

Property Value

Type: String
The text to find.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.MatchCase Property

ISearchOptionsMatchCase Property
Gets or sets whether searches should be case sensitive.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool MatchCase { get; set; }
Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be case sensitive; otherwise, false.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.MatchWholeWord Property

ISearchOptionsMatchWholeWord Property
Gets or sets whether searches should only match whole words.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool MatchWholeWord { get; set; }
Property MatchWholeWord As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should only match whole words; otherwise, false.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.MaximumResultCount Property

ISearchOptionsMaximumResultCount Property
Gets or sets the maximum number of results that can be found.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int MaximumResultCount { get; set; }
Property MaximumResultCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of results that can be found.
Remarks
The count must be larger than zero.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.PatternProvider Property

ISearchOptionsPatternProvider Property
Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.).

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchPatternProvider PatternProvider { get; set; }
Property PatternProvider As ISearchPatternProvider
    Get
    Set

Property Value

Type: ISearchPatternProvider
A ISearchPatternProvider specifying the search pattern provider.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.ReplaceText Property

ISearchOptionsReplaceText Property
Gets or sets the text with which to replace (replace operations only).

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ReplaceText { get; set; }
Property ReplaceText As String
    Get
    Set

Property Value

Type: String
The text with which to replace.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchOptions.SearchUp Property

ISearchOptionsSearchUp Property
Gets or sets whether to search backwards.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SearchUp { get; set; }
Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.
See Also

Reference

ISearchOptions Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider Interface

ISearchPatternProvider Interface
Provides the base requirements for an object that can provide regular expression find/replace patterns based on a supplied pattern.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchPatternProvider : IKeyedObject
Public Interface ISearchPatternProvider
    Inherits IKeyedObject

The ISearchPatternProvider type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the search pattern provider.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | RequiresCaseSensitivity | Gets whether this pattern requires case sensitivity.
Top
Methods
 | Name | Description
Public method | GetFindPattern | Returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses this provider.
Public method | GetReplacePattern | Returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses this provider.
Top
Remarks
All find/replace operations are performed using the built-in regular expression engine. This interface allows for the creation of custom pattern formats and enables them to be converted to the core regular expression pattern syntax.
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider Properties

ISearchPatternProvider Properties

The ISearchPatternProvider type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description of the search pattern provider.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | RequiresCaseSensitivity | Gets whether this pattern requires case sensitivity.
Top
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.Description Property

ISearchPatternProviderDescription Property
Gets the description of the search pattern provider.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the search pattern provider.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.RequiresCaseSensitivity Property

ISearchPatternProviderRequiresCaseSensitivity Property
Gets whether this pattern requires case sensitivity.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RequiresCaseSensitivity { get; }
ReadOnly Property RequiresCaseSensitivity As Boolean
    Get

Property Value

Type: Boolean
true if this pattern requires case sensitivity; otherwise, false.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider Methods

ISearchPatternProvider Methods

The ISearchPatternProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetFindPattern | Returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses this provider.
Public method | GetReplacePattern | Returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses this provider.
Top
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.GetFindPattern Method

ISearchPatternProviderGetFindPattern Method
Returns the regular expression match pattern to use for find operations, based on the supplied pattern that uses this provider.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetFindPattern(
    string pattern
)
Function GetFindPattern (
    pattern As String
) As String

Parameters

pattern
Type: SystemString
The pattern to convert using this provider.

Return Value

Type: String
The regular expression match pattern to use for find operations.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProvider.GetReplacePattern Method

ISearchPatternProviderGetReplacePattern Method
Returns the regular expression match pattern to use for replace operations, based on the supplied pattern that uses this provider.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetReplacePattern(
    string pattern
)
Function GetReplacePattern (
    pattern As String
) As String

Parameters

pattern
Type: SystemString
The pattern to convert using this provider.

Return Value

Type: String
The regular expression match pattern to use for replace operations.
See Also

Reference

ISearchPatternProvider Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderCollection Interface

ISearchPatternProviderCollection Interface
Provides the base requirements for a collection of ISearchPatternProvider objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchPatternProviderCollection : IList<ISearchPatternProvider>,
    ICollection<ISearchPatternProvider>, IEnumerable<ISearchPatternProvider>, IEnumerable,
    IList, ICollection
Public Interface ISearchPatternProviderCollection
    Inherits IList(Of ISearchPatternProvider), ICollection(Of ISearchPatternProvider),
    IEnumerable(Of ISearchPatternProvider), IEnumerable, IList, ICollection

The ISearchPatternProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISearchPatternProvider .)
Public property | IsFixedSize | (Inherited from IList.)
Public property | IsReadOnly | (Inherited from ICollection ISearchPatternProvider .)
Public property | IsSynchronized | (Inherited from ICollection.)
Public property | Item | (Inherited from IList ISearchPatternProvider .)
Public property | SyncRoot | (Inherited from ICollection.)
Top
Methods
 | Name | Description
Public method | Add(Object) | (Inherited from IList.)
Public method | Add(T) | (Inherited from ICollection ISearchPatternProvider .)
Public method | Clear | (Inherited from ICollection ISearchPatternProvider .)
Public method | Contains(Object) | (Inherited from IList.)
Public method | Contains(T) | (Inherited from ICollection ISearchPatternProvider .)
Public method | CopyTo(Array, Int32) | (Inherited from ICollection.)
Public method | CopyTo(T, Int32) | (Inherited from ICollection ISearchPatternProvider .)
Public method | GetEnumerator | (Inherited from IEnumerable ISearchPatternProvider .)
Public method | IndexOf(Object) | (Inherited from IList.)
Public method | IndexOf(T) | (Inherited from IList ISearchPatternProvider .)
Public method | Insert(Int32, T) | (Inherited from IList ISearchPatternProvider .)
Public method | Insert(Int32, Object) | (Inherited from IList.)
Public method | Remove(Object) | (Inherited from IList.)
Public method | Remove(T) | (Inherited from ICollection ISearchPatternProvider .)
Public method | RemoveAt | (Inherited from IList ISearchPatternProvider .)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace
ActiproSoftware.Text.SearchingISearchPatternProvider
ActiproSoftware.Text.Searching.ImplementationSearchPatternProviderCollection


ISearchPatternProviderCollection Properties

ISearchPatternProviderCollection Properties

The ISearchPatternProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISearchPatternProvider .)
Public property | IsFixedSize | (Inherited from IList.)
Public property | IsReadOnly | (Inherited from ICollection ISearchPatternProvider .)
Public property | IsSynchronized | (Inherited from ICollection.)
Public property | Item | (Inherited from IList ISearchPatternProvider .)
Public property | SyncRoot | (Inherited from ICollection.)
Top
See Also

Reference

ISearchPatternProviderCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderCollection Methods

ISearchPatternProviderCollection Methods

The ISearchPatternProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(Object) | (Inherited from IList.)
Public method | Add(T) | (Inherited from ICollection ISearchPatternProvider .)
Public method | Clear | (Inherited from ICollection ISearchPatternProvider .)
Public method | Contains(Object) | (Inherited from IList.)
Public method | Contains(T) | (Inherited from ICollection ISearchPatternProvider .)
Public method | CopyTo(Array, Int32) | (Inherited from ICollection.)
Public method | CopyTo(T, Int32) | (Inherited from ICollection ISearchPatternProvider .)
Public method | GetEnumerator | (Inherited from IEnumerable ISearchPatternProvider .)
Public method | IndexOf(Object) | (Inherited from IList.)
Public method | IndexOf(T) | (Inherited from IList ISearchPatternProvider .)
Public method | Insert(Int32, T) | (Inherited from IList ISearchPatternProvider .)
Public method | Insert(Int32, Object) | (Inherited from IList.)
Public method | Remove(Object) | (Inherited from IList.)
Public method | Remove(T) | (Inherited from ICollection ISearchPatternProvider .)
Public method | RemoveAt | (Inherited from IList ISearchPatternProvider .)
Top
See Also

Reference

ISearchPatternProviderCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderFactory Interface

ISearchPatternProviderFactory Interface
Provides the base requirements for a factory capable of creating ISearchPatternProvider objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchPatternProviderFactory
Public Interface ISearchPatternProviderFactory

The ISearchPatternProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace
ActiproSoftware.Text.Searching.ImplementationDefaultSearchPatternProviderFactory


ISearchPatternProviderFactory Methods

ISearchPatternProviderFactory Methods

The ISearchPatternProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Top
See Also

Reference

ISearchPatternProviderFactory Interface
ActiproSoftware.Text.Searching Namespace


ISearchPatternProviderFactory.CreateProviders Method

ISearchPatternProviderFactoryCreateProviders Method
Creates the collection of ISearchPatternProvider objects to use.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchPatternProviderCollection CreateProviders()
Function CreateProviders As ISearchPatternProviderCollection

Return Value

Type: ISearchPatternProviderCollection
A ISearchPatternProviderCollection containing the ISearchPatternProvider objects that were created.
See Also

Reference

ISearchPatternProviderFactory Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult Interface

ISearchResult Interface
Provides the base requirements for a class that stores a single result of a search operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchResult : ITextRangeProvider
Public Interface ISearchResult
    Inherits ITextRangeProvider

The ISearchResult type exposes the following members.

Properties
 | Name | Description
Public property | Captures | Gets the read-only collection of captures.
Public property | FindSnapshotRange | Gets a TextSnapshotRange that contains the text that was found.
Public property | ReplaceSnapshotRange | Gets a TextSnapshotRange that contains the text that was replaced.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchResult Properties

ISearchResult Properties

The ISearchResult type exposes the following members.

Properties
 | Name | Description
Public property | Captures | Gets the read-only collection of captures.
Public property | FindSnapshotRange | Gets a TextSnapshotRange that contains the text that was found.
Public property | ReplaceSnapshotRange | Gets a TextSnapshotRange that contains the text that was replaced.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Top
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult.Captures Property

ISearchResultCaptures Property
Gets the read-only collection of captures.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchCaptureCollection Captures { get; }
ReadOnly Property Captures As ISearchCaptureCollection
    Get

Property Value

Type: ISearchCaptureCollection
The read-only collection of captures.
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult.FindSnapshotRange Property

ISearchResultFindSnapshotRange Property
Gets a TextSnapshotRange that contains the text that was found.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange FindSnapshotRange { get; }
ReadOnly Property FindSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the text that was found.
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResult.ReplaceSnapshotRange Property

ISearchResultReplaceSnapshotRange Property
Gets a TextSnapshotRange that contains the text that was replaced.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange ReplaceSnapshotRange { get; }
ReadOnly Property ReplaceSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the text that was replaced.
Remarks
The TextSnapshotRange is marked as deleted if no replace was performed.
See Also

Reference

ISearchResult Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultCollection Interface

ISearchResultCollection Interface
Provides the base requirements for a collection of ISearchResult objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchResultCollection : IList<ISearchResult>,
    ICollection<ISearchResult>, IEnumerable<ISearchResult>, IEnumerable
Public Interface ISearchResultCollection
    Inherits IList(Of ISearchResult), ICollection(Of ISearchResult),
    IEnumerable(Of ISearchResult), IEnumerable

The ISearchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISearchResult .)
Public property | IsReadOnly | (Inherited from ICollection ISearchResult .)
Public property | Item | (Inherited from IList ISearchResult .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ISearchResult .)
Public method | Clear | (Inherited from ICollection ISearchResult .)
Public method | Contains | (Inherited from ICollection ISearchResult .)
Public method | CopyTo | (Inherited from ICollection ISearchResult .)
Public method | GetEnumerator | (Inherited from IEnumerable ISearchResult .)
Public method | IndexOf | (Inherited from IList ISearchResult .)
Public method | Insert | (Inherited from IList ISearchResult .)
Public method | Remove | (Inherited from ICollection ISearchResult .)
Public method | RemoveAt | (Inherited from IList ISearchResult .)
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchResultCollection Properties

ISearchResultCollection Properties

The ISearchResultCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection ISearchResult .)
Public property | IsReadOnly | (Inherited from ICollection ISearchResult .)
Public property | Item | (Inherited from IList ISearchResult .)
Top
See Also

Reference

ISearchResultCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultCollection Methods

ISearchResultCollection Methods

The ISearchResultCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection ISearchResult .)
Public method | Clear | (Inherited from ICollection ISearchResult .)
Public method | Contains | (Inherited from ICollection ISearchResult .)
Public method | CopyTo | (Inherited from ICollection ISearchResult .)
Public method | GetEnumerator | (Inherited from IEnumerable ISearchResult .)
Public method | IndexOf | (Inherited from IList ISearchResult .)
Public method | Insert | (Inherited from IList ISearchResult .)
Public method | Remove | (Inherited from ICollection ISearchResult .)
Public method | RemoveAt | (Inherited from IList ISearchResult .)
Top
See Also

Reference

ISearchResultCollection Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet Interface

ISearchResultSet Interface
Provides the base requirements for a class that stores the results of a search operation.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISearchResultSet
Public Interface ISearchResultSet

The ISearchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


ISearchResultSet Properties

ISearchResultSet Properties

The ISearchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.OperationType Property

ISearchResultSetOperationType Property
Gets or sets a SearchOperationType that indicates the search operation type that was performed.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SearchOperationType OperationType { get; set; }
Property OperationType As SearchOperationType
    Get
    Set

Property Value

Type: SearchOperationType
A SearchOperationType that indicates the search operation type that was performed.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.Options Property

ISearchResultSetOptions Property
Gets or sets a copy of the ISearchOptions that were used to generate this result set.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchOptions Options { get; set; }
Property Options As ISearchOptions
    Get
    Set

Property Value

Type: ISearchOptions
A copy of the ISearchOptions that were used to generate this result set.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.Results Property

ISearchResultSetResults Property
Gets the collection of ISearchResult objects.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultCollection Results { get; }
ReadOnly Property Results As ISearchResultCollection
    Get

Property Value

Type: ISearchResultCollection
The collection of ISearchResult objects.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


ISearchResultSet.Wrapped Property

ISearchResultSetWrapped Property
Gets or sets whether the find operation wrapped when it reached the end of the search text range.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Wrapped { get; set; }
Property Wrapped As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the find operation wrapped; otherwise, false.
See Also

Reference

ISearchResultSet Interface
ActiproSoftware.Text.Searching Namespace


SearchOperationType Class

SearchOperationType Class
Specifies the type of search operation.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.SearchingSearchOperationType

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SearchOperationType : Enum
Public NotInheritable Class SearchOperationType
    Inherits Enum

The SearchOperationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | FindAll | Finds all occurrences of the find text.
 | FindNext | Finds the next occurrence of the find text.
 | FindNextIncremental | Finds the next occurrence of the find text via incremental search mode.
 | ReplaceAll | Replaces all occurrences of the find text with the replace text.
 | ReplaceNext | Replaces the next occurrence of the find text with the replace text.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


SearchOperationType Methods

SearchOperationType Methods

The SearchOperationType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType Fields

SearchOperationType Fields

The SearchOperationType type exposes the following members.

Fields
 | Name | Description
 | FindAll | Finds all occurrences of the find text.
 | FindNext | Finds the next occurrence of the find text.
 | FindNextIncremental | Finds the next occurrence of the find text via incremental search mode.
 | ReplaceAll | Replaces all occurrences of the find text with the replace text.
 | ReplaceNext | Replaces the next occurrence of the find text with the replace text.
Public field | value__ |
Top
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType.FindAll Field

SearchOperationTypeFindAll Field
Finds all occurrences of the find text.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SearchOperationType FindAll = 2
Public Const FindAll As SearchOperationType = 2

Field Value

Type: SearchOperationType
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType.FindNext Field

SearchOperationTypeFindNext Field
Finds the next occurrence of the find text.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SearchOperationType FindNext = 0
Public Const FindNext As SearchOperationType = 0

Field Value

Type: SearchOperationType
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType.FindNextIncremental Field

SearchOperationTypeFindNextIncremental Field
Finds the next occurrence of the find text via incremental search mode.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SearchOperationType FindNextIncremental = 4
Public Const FindNextIncremental As SearchOperationType = 4

Field Value

Type: SearchOperationType
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType.ReplaceAll Field

SearchOperationTypeReplaceAll Field
Replaces all occurrences of the find text with the replace text.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SearchOperationType ReplaceAll = 3
Public Const ReplaceAll As SearchOperationType = 3

Field Value

Type: SearchOperationType
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType.ReplaceNext Field

SearchOperationTypeReplaceNext Field
Replaces the next occurrence of the find text with the replace text.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SearchOperationType ReplaceNext = 1
Public Const ReplaceNext As SearchOperationType = 1

Field Value

Type: SearchOperationType
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchOperationType.value__ Field

SearchOperationTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Searching.SearchOperationType.value__"]

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SearchOperationType Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders Class

SearchPatternProviders Class
Provides access to the built-in ISearchPatternProvider instances, that can provide regular expression find/replace patterns based on a supplied pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.SearchingSearchPatternProviders

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class SearchPatternProviders
Public NotInheritable Class SearchPatternProviders

The SearchPatternProviders type exposes the following members.

Properties
Name | Description
Acronym | Gets the ISearchPatternProvider for an acronym search.
Normal | Gets the ISearchPatternProvider for a normal search.
RegularExpression | Gets the ISearchPatternProvider for a regular expression search.
Shorthand | Gets the ISearchPatternProvider for a shorthand search.
Wildcard | Gets the ISearchPatternProvider for a wildcard search.
Top
See Also

Reference

ActiproSoftware.Text.Searching Namespace


SearchPatternProviders Properties

SearchPatternProviders Properties

The SearchPatternProviders type exposes the following members.

Properties
Name | Description
Acronym | Gets the ISearchPatternProvider for an acronym search.
Normal | Gets the ISearchPatternProvider for a normal search.
RegularExpression | Gets the ISearchPatternProvider for a regular expression search.
Shorthand | Gets the ISearchPatternProvider for a shorthand search.
Wildcard | Gets the ISearchPatternProvider for a wildcard search.
Top
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Acronym Property

SearchPatternProvidersAcronym Property
Gets the ISearchPatternProvider for an acronym search.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Acronym { get; }
Public Shared ReadOnly Property Acronym As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for an acronym search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Normal Property

SearchPatternProvidersNormal Property
Gets the ISearchPatternProvider for a normal search.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Normal { get; }
Public Shared ReadOnly Property Normal As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a normal search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.RegularExpression Property

SearchPatternProvidersRegularExpression Property
Gets the ISearchPatternProvider for a regular expression search.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider RegularExpression { get; }
Public Shared ReadOnly Property RegularExpression As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a regular expression search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Shorthand Property

SearchPatternProvidersShorthand Property
Gets the ISearchPatternProvider for a shorthand search.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Shorthand { get; }
Public Shared ReadOnly Property Shorthand As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a shorthand search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


SearchPatternProviders.Wildcard Property

SearchPatternProvidersWildcard Property
Gets the ISearchPatternProvider for a wildcard search.

Namespace: ActiproSoftware.Text.Searching
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchPatternProvider Wildcard { get; }
Public Shared ReadOnly Property Wildcard As ISearchPatternProvider
    Get

Property Value

Type: ISearchPatternProvider
The ISearchPatternProvider for a wildcard search.
See Also

Reference

SearchPatternProviders Class
ActiproSoftware.Text.Searching Namespace


ActiproSoftware.Text.Searching.Implementation Namespace

ActiproSoftware.Text.Searching.Implementation Namespace
Contains implementation types related to searching within text documents.
Classes
 | Class | Description
Public class | DefaultSearchPatternProviderFactory | The default factory implementation that creates ISearchPatternProvider objects.
Public class | SearchPatternProviderCollection | Encapsulates a collection of ISearchPatternProvider objects.
Public class | SearchResultSet | Stores the results of a find operation.
Public class | TextSearcher | Provides core functionality for searching within an ITextSnapshot that is typically wrapped by external helper methods.


DefaultSearchPatternProviderFactory Class

DefaultSearchPatternProviderFactory Class
The default factory implementation that creates ISearchPatternProvider objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Searching.ImplementationDefaultSearchPatternProviderFactory

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DefaultSearchPatternProviderFactory : ISearchPatternProviderFactory
Public Class DefaultSearchPatternProviderFactory
    Implements ISearchPatternProviderFactory

The DefaultSearchPatternProviderFactory type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultSearchPatternProviderFactory | Initializes a new instance of the DefaultSearchPatternProviderFactory class
Top
Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace


DefaultSearchPatternProviderFactory Constructor

DefaultSearchPatternProviderFactory Constructor
Initializes a new instance of the DefaultSearchPatternProviderFactory class

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DefaultSearchPatternProviderFactory()
Public Sub New
See Also

Reference

DefaultSearchPatternProviderFactory Class
ActiproSoftware.Text.Searching.Implementation Namespace


DefaultSearchPatternProviderFactory Methods

DefaultSearchPatternProviderFactory Methods

The DefaultSearchPatternProviderFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProviders | Creates the collection of ISearchPatternProvider objects to use.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DefaultSearchPatternProviderFactory Class
ActiproSoftware.Text.Searching.Implementation Namespace


DefaultSearchPatternProviderFactory.CreateProviders Method

DefaultSearchPatternProviderFactoryCreateProviders Method
Creates the collection of ISearchPatternProvider objects to use.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual ISearchPatternProviderCollection CreateProviders()
Public Overridable Function CreateProviders As ISearchPatternProviderCollection

Return Value

Type: ISearchPatternProviderCollection
A ISearchPatternProviderCollection containing the ISearchPatternProvider objects that were created.

Implements

ISearchPatternProviderFactoryCreateProviders
See Also

Reference

DefaultSearchPatternProviderFactory Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Class

SearchPatternProviderCollection Class
Encapsulates a collection of ISearchPatternProvider objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ISearchPatternProvider
ActiproSoftware.Text.UtilitySimpleObservableCollection ISearchPatternProvider
ActiproSoftware.Text.Searching.ImplementationSearchPatternProviderCollection

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SearchPatternProviderCollection : SimpleObservableCollection<ISearchPatternProvider>,
    ISearchPatternProviderCollection, IList<ISearchPatternProvider>, ICollection<ISearchPatternProvider>,
    IEnumerable<ISearchPatternProvider>, IEnumerable, IList, ICollection
Public Class SearchPatternProviderCollection
    Inherits SimpleObservableCollection(Of ISearchPatternProvider)
    Implements ISearchPatternProviderCollection, IList(Of ISearchPatternProvider),
    ICollection(Of ISearchPatternProvider), IEnumerable(Of ISearchPatternProvider), IEnumerable,
    IList, ICollection

The SearchPatternProviderCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SearchPatternProviderCollection | Initializes a new instance of the SearchPatternProviderCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection ISearchPatternProvider .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | (Inherited from Collection ISearchPatternProvider .)
Protected property | Items | (Inherited from Collection ISearchPatternProvider .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection ISearchPatternProvider .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection ISearchPatternProvider .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | (Inherited from Collection ISearchPatternProvider .)
Public method | CopyTo | (Inherited from Collection ISearchPatternProvider .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection ISearchPatternProvider .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection ISearchPatternProvider .)
Public method | Insert | (Inherited from Collection ISearchPatternProvider .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | (Inherited from Collection ISearchPatternProvider .)
Public method | RemoveAt | (Inherited from Collection ISearchPatternProvider .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace
ActiproSoftware.Text.SearchingISearchPatternProvider


SearchPatternProviderCollection Constructor

SearchPatternProviderCollection Constructor
Initializes a new instance of the SearchPatternProviderCollection class

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SearchPatternProviderCollection()
Public Sub New
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Properties

SearchPatternProviderCollection Properties

The SearchPatternProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection ISearchPatternProvider .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | (Inherited from Collection ISearchPatternProvider .)
Protected property | Items | (Inherited from Collection ISearchPatternProvider .)
Top
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Methods

SearchPatternProviderCollection Methods

The SearchPatternProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection ISearchPatternProvider .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection ISearchPatternProvider .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains | (Inherited from Collection ISearchPatternProvider .)
Public method | CopyTo | (Inherited from Collection ISearchPatternProvider .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection ISearchPatternProvider .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection ISearchPatternProvider .)
Public method | Insert | (Inherited from Collection ISearchPatternProvider .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | (Inherited from Collection ISearchPatternProvider .)
Public method | RemoveAt | (Inherited from Collection ISearchPatternProvider .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchPatternProviderCollection Events

SearchPatternProviderCollection Events

The SearchPatternProviderCollection type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

SearchPatternProviderCollection Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Class

SearchResultSet Class
Stores the results of a find operation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Searching.ImplementationSearchResultSet

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SearchResultSet : ISearchResultSet
Public Class SearchResultSet
    Implements ISearchResultSet

The SearchResultSet type exposes the following members.

Constructors
 | Name | Description
Public method | SearchResultSet | Initializes a new instance of the SearchResultSet class.
Top
Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Constructor

SearchResultSet Constructor
Initializes a new instance of the SearchResultSet class.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SearchResultSet(
    SearchOperationType operationType,
    ISearchOptions options,
    bool wrapped
)
Public Sub New (
    operationType As SearchOperationType,
    options As ISearchOptions,
    wrapped As Boolean
)

Parameters

operationType
Type: ActiproSoftware.Text.SearchingSearchOperationType
A SearchOperationType that indicates the search operation type that was performed.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
A copy of the ISearchOptions that were used to generate this result set.
wrapped
Type: SystemBoolean
Whether the find operation wrapped when it reached the end of the search text range.
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Properties

SearchResultSet Properties

The SearchResultSet type exposes the following members.

Properties
 | Name | Description
Public property | OperationType | Gets or sets a SearchOperationType that indicates the search operation type that was performed.
Public property | Options | Gets or sets a copy of the ISearchOptions that were used to generate this result set.
Public property | Results | Gets the collection of ISearchResult objects.
Public property | Wrapped | Gets or sets whether the find operation wrapped when it reached the end of the search text range.
Top
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.OperationType Property

SearchResultSetOperationType Property
Gets or sets a SearchOperationType that indicates the search operation type that was performed.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SearchOperationType OperationType { get; set; }
Public Property OperationType As SearchOperationType
    Get
    Set

Property Value

Type: SearchOperationType
A SearchOperationType that indicates the search operation type that was performed.

Implements

ISearchResultSetOperationType
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.Options Property

SearchResultSetOptions Property
Gets or sets a copy of the ISearchOptions that were used to generate this result set.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchOptions Options { get; set; }
Public Property Options As ISearchOptions
    Get
    Set

Property Value

Type: ISearchOptions
A copy of the ISearchOptions that were used to generate this result set.

Implements

ISearchResultSetOptions
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.Results Property

SearchResultSetResults Property
Gets the collection of ISearchResult objects.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchResultCollection Results { get; }
Public ReadOnly Property Results As ISearchResultCollection
    Get

Property Value

Type: ISearchResultCollection
The collection of ISearchResult objects.

Implements

ISearchResultSetResults
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.Wrapped Property

SearchResultSetWrapped Property
Gets or sets whether the find operation wrapped when it reached the end of the search text range.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Wrapped { get; set; }
Public Property Wrapped As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the find operation wrapped; otherwise, false.

Implements

ISearchResultSetWrapped
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet Methods

SearchResultSet Methods

The SearchResultSet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


SearchResultSet.ToString Method

SearchResultSetToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SearchResultSet Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher Class

TextSearcher Class
Provides core functionality for searching within an ITextSnapshot that is typically wrapped by external helper methods.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Searching.ImplementationTextSearcher

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class TextSearcher
Public NotInheritable Class TextSearcher

The TextSearcher type exposes the following members.

Methods
Name | Description
FindAll | Performs a find all operation over a specific range of the snapshot.
FindNext | Performs a find next operation over a specific range of the snapshot.
ReplaceAll | Performs a replace all operation over a specific range of the snapshot.
ReplaceNext | Performs a replace next operation over a specific range of the snapshot.
Top
See Also

Reference

ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher Methods

TextSearcher Methods

The TextSearcher type exposes the following members.

Methods
Name | Description
FindAll | Performs a find all operation over a specific range of the snapshot.
FindNext | Performs a find next operation over a specific range of the snapshot.
ReplaceAll | Performs a replace all operation over a specific range of the snapshot.
ReplaceNext | Performs a replace next operation over a specific range of the snapshot.
Top
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.FindAll Method

TextSearcherFindAll Method
Performs a find all operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchResultSet FindAll(
    ITextSnapshot snapshot,
    ISearchOptions options,
    TextRange searchTextRange
)
Public Shared Function FindAll (
    snapshot As ITextSnapshot,
    options As ISearchOptions,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot in which to search.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.FindNext Method

TextSearcherFindNext Method
Performs a find next operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchResultSet FindNext(
    ITextSnapshot snapshot,
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Public Shared Function FindNext (
    snapshot As ITextSnapshot,
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot in which to search.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.ReplaceAll Method

TextSearcherReplaceAll Method
Performs a replace all operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchResultSet ReplaceAll(
    ITextDocument document,
    Object source,
    ISearchOptions options,
    params TextRange[] searchTextRanges
)
Public Shared Function ReplaceAll (
    document As ITextDocument,
    source As Object,
    options As ISearchOptions,
    ParamArray searchTextRanges As TextRange()
) As ISearchResultSet

Parameters

document
Type: ActiproSoftware.TextITextDocument
The ITextDocument in which to search.
source
Type: SystemObject
The optional source of the text change, which is most often an editor view if specified.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
searchTextRanges
Type: ActiproSoftware.TextTextRange
The TextRange array of offsets to search. If everything should be searched, specify the range 0 to the length of the document's current ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


TextSearcher.ReplaceNext Method

TextSearcherReplaceNext Method
Performs a replace next operation over a specific range of the snapshot.

Namespace: ActiproSoftware.Text.Searching.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ISearchResultSet ReplaceNext(
    ITextDocument document,
    Object source,
    ISearchOptions options,
    int startOffset,
    bool canWrap,
    TextRange searchTextRange
)
Public Shared Function ReplaceNext (
    document As ITextDocument,
    source As Object,
    options As ISearchOptions,
    startOffset As Integer,
    canWrap As Boolean,
    searchTextRange As TextRange
) As ISearchResultSet

Parameters

document
Type: ActiproSoftware.TextITextDocument
The ITextDocument in which to search.
source
Type: SystemObject
The optional source of the text change, which is most often an editor view if specified.
options
Type: ActiproSoftware.Text.SearchingISearchOptions
The ISearchOptions to use.
startOffset
Type: SystemInt32
The offset at which to start the search.
canWrap
Type: SystemBoolean
Whether the search can wrap at the end of the search text range.
searchTextRange
Type: ActiproSoftware.TextTextRange
The TextRange of offsets to search. If all should be searched, specify the range 0 to the length of the document's current ITextSnapshot.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

TextSearcher Class
ActiproSoftware.Text.Searching.Implementation Namespace


ActiproSoftware.Text.Tagging Namespace

ActiproSoftware.Text.Tagging Namespace
Contains types related to tagging text ranges with custom data.
Classes
 | Class | Description
Public class | TagAggregatorBaseT | An abstract base class for an object that aggregates ITag objects from multiple ITaggerT instances.
Public class | TaggerKeys | Specifies the names of the built-in ITaggerT objects that are included with this product.
Public class | TagsChangedEventArgs | Event arguments for when an ITaggerT alters tags on text.
Public class | TagSnapshotRangeT | Implements an object that represents an ITag and its associated TextSnapshotRange.
Public class | TagVersionRangeT | Implements an object that represents an ITag and its associated ITextVersionRange.
Interfaces
 | Interface | Description
Public interface | IClassificationTag | Provides the base requirements for an IClassificationType that can be associated with some text range.
Public interface | ICodeDocumentTaggerProvider | Provides the base requirements for a object that can create ITaggerT objects for an ICodeDocument.
Public interface | ICollapsedRegionTag | Provides the base requirements for a collapsed region of text.
Public interface | ICollectionTaggerT | Provides the base requirements for an ITaggerT that maintains a simple collection of tagged ranges.
Public interface | IDelimiterHighlightTag | Provides the base requirements for an ITag that spans a delimiter highlight.
Public interface | IIndicatorTag | Provides the base requirements for an indicator, which covers range of text and render a glyph in an editor's indicator margin for that range.
Public interface | IIntraTextSpacerTag | Provides the base requirements for a spacer that can be inserted between two text characters.
Public interface | IReadOnlyRegionTag | Provides the base requirements for an IReadOnlyRegionTag that can be associated with some text range to mark it as read-only.
Public interface | ISquiggleTag | Provides the base requirements for a squiggle line, generally used for error display, that can be associated with some text range.
Public interface | ITag | Provides the base requirements for a data object that can be associated with some text range.
Public interface | ITagAggregatorT | Provides the base requirements for a object that aggregates ITag objects from multiple ITaggerT instances.
Public interface | ITaggerT | Provides the base requirements for a object that can provide ITag objects that intersect with specified text ranges within an ICodeDocument.
Public interface | ITagSearchOptionsT | Provides the base requirements for a class that stores tag search operation options.
Public interface | ITextViewTaggerProvider | Provides the base requirements for a object that can create ITaggerT objects for an ITextView.
Public interface | ITokenTag | Provides the base requirements for an IToken from an ILexer that can be associated with some text range.


IClassificationTag Interface

IClassificationTag Interface
Provides the base requirements for an IClassificationType that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IClassificationTag : ITag
Public Interface IClassificationTag
    Inherits ITag

The IClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with this tag.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationClassificationTag


IClassificationTag Properties

IClassificationTag Properties

The IClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with this tag.
Top
See Also

Reference

IClassificationTag Interface
ActiproSoftware.Text.Tagging Namespace


IClassificationTag.ClassificationType Property

IClassificationTagClassificationType Property
Gets the IClassificationType associated with this tag.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; }
ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with this tag.
See Also

Reference

IClassificationTag Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider Interface

ICodeDocumentTaggerProvider Interface
Provides the base requirements for a object that can create ITaggerT objects for an ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICodeDocumentTaggerProvider
Public Interface ICodeDocumentTaggerProvider

The ICodeDocumentTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProviderTTagger


ICodeDocumentTaggerProvider Properties

ICodeDocumentTaggerProvider Properties

The ICodeDocumentTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider.TagTypes Property

ICodeDocumentTaggerProviderTagTypes Property
Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<Type> TagTypes { get; }
ReadOnly Property TagTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The ITag Type objects that are supported by the ITaggerT objects created by this provider.
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider Methods

ICodeDocumentTaggerProvider Methods

The ICodeDocumentTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Top
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICodeDocumentTaggerProvider.GetTagger(T) Method

ICodeDocumentTaggerProviderGetTaggerT Method
Returns an ITaggerT for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ICodeDocument.
See Also

Reference

ICodeDocumentTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ICollapsedRegionTag Interface

ICollapsedRegionTag Interface
Provides the base requirements for a collapsed region of text.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICollapsedRegionTag : ITag
Public Interface ICollapsedRegionTag
    Inherits ITag
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Interface

ICollectionTaggerT Interface
Provides the base requirements for an ITaggerT that maintains a simple collection of tagged ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICollectionTagger<T> : ITagger<T>,
    IOrderable, IKeyedObject
where T : ITag

Public Interface ICollectionTagger(Of T As ITag)
    Inherits ITagger(Of T), IOrderable, IKeyedObject

Type Parameters

T
The tag type.

The ICollectionTaggerT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the ICollectionTagger interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the tagger and detaches it. (Inherited from ITaggerT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from ITaggerT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from ITaggerT.)
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed. (Inherited from ITaggerT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Properties

ICollectionTaggerT Properties

The ICollectionTaggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the ICollectionTagger interface.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Count Property

ICollectionTaggerTCount Property
Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Item Property

ICollectionTaggerTItem Property
Gets the tag range that points to the specified tag.

[C#] In C#, this property is the indexer for the ICollectionTagger interface.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> this[
    T tag
] { get; }
ReadOnly Property Item (
    tag As T
) As TagVersionRange(Of T)
    Get

Parameters

tag
Type: T
The tag for which to search.

Property Value

Type: TagVersionRange T
The tag range that points to the specified tag.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Methods

ICollectionTaggerT Methods

The ICollectionTaggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the tagger and detaches it. (Inherited from ITaggerT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from ITaggerT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method

ICollectionTaggerTAdd Method
Overload List
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method (TagVersionRange(T))

ICollectionTaggerTAdd Method (TagVersionRangeT)
Adds a tag range to the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Add(
    TagVersionRange<T> tagRange
)
Sub Add (
    tagRange As TagVersionRange(Of T)
)

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to add to the collection.
Remarks
This is the lowest-level method used for adding a tag range, and gives the most control over snapshot translation options.
See Also

Reference

ICollectionTaggerT Interface
Add Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method (ITextSnapshotLine, T)

ICollectionTaggerTAdd Method (ITextSnapshotLine, T)
Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> Add(
    ITextSnapshotLine snapshotLine,
    T tag
)
Function Add (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength and LineBased flags.
See Also

Reference

ICollectionTaggerT Interface
Add Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Add Method (TextSnapshotRange, T)

ICollectionTaggerTAdd Method (TextSnapshotRange, T)
Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> Add(
    TextSnapshotRange snapshotRange,
    T tag
)
Function Add (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength flag.
See Also

Reference

ICollectionTaggerT Interface
Add Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Clear Method

ICollectionTaggerTClear Method
Removes all items from the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Contains Method

ICollectionTaggerTContains Method
Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    TagVersionRange<T> tagRange
)
Function Contains (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The object to locate in the collection.

Return Value

Type: Boolean
true if the item is found in the collection; otherwise, false.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).CopyTo Method

ICollectionTaggerTCopyTo Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Tagging.ICollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CopyTo(
    TagVersionRange<T>[] array,
    int arrayIndex
)
Sub CopyTo (
    array As TagVersionRange(Of T)(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.TaggingTagVersionRange T

[Missing <param name="array"/> documentation for "M:ActiproSoftware.Text.Tagging.ICollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

arrayIndex
Type: SystemInt32

[Missing <param name="arrayIndex"/> documentation for "M:ActiproSoftware.Text.Tagging.ICollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).CreateBatch Method

ICollectionTaggerTCreateBatch Method
Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDisposable CreateBatch()
Function CreateBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).FindNext Method

ICollectionTaggerTFindNext Method
Overload List
 | Name | Description
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).FindNext Method (ITextSnapshotLine, ITagSearchOptions(T))

ICollectionTaggerTFindNext Method (ITextSnapshotLine, ITagSearchOptionsT)
Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> FindNext(
    ITextSnapshotLine snapshotLine,
    ITagSearchOptions<T> options
)
Function FindNext (
    snapshotLine As ITextSnapshotLine,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The ITextSnapshotLine from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.
See Also

Reference

ICollectionTaggerT Interface
FindNext Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).FindNext Method (TextSnapshotOffset, ITagSearchOptions(T))

ICollectionTaggerTFindNext Method (TextSnapshotOffset, ITagSearchOptionsT)
Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> FindNext(
    TextSnapshotOffset snapshotOffset,
    ITagSearchOptions<T> options
)
Function FindNext (
    snapshotOffset As TextSnapshotOffset,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.
See Also

Reference

ICollectionTaggerT Interface
FindNext Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).GetEnumerator Method

ICollectionTaggerTGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerator<TagVersionRange<T>> GetEnumerator()
Function GetEnumerator As IEnumerator(Of TagVersionRange(Of T))

Return Value

Type: IEnumerator TagVersionRange T
An IEnumerator object for the entire collection
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Remove Method

ICollectionTaggerTRemove Method
Overload List
 | Name | Description
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Remove Method (T)

ICollectionTaggerTRemove Method (T)
Removes a specific tag instance from the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove(
    T tag
)
Function Remove (
    tag As T
) As Boolean

Parameters

tag
Type: T
The ITag to remove from the collection.

Return Value

Type: Boolean
true if the tag was successfully removed from the collection; otherwise, false
See Also

Reference

ICollectionTaggerT Interface
Remove Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Remove Method (TagVersionRange(T))

ICollectionTaggerTRemove Method (TagVersionRangeT)
Removes the first occurrence of a specific tag range from the collection.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove(
    TagVersionRange<T> tagRange
)
Function Remove (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to remove from the collection.

Return Value

Type: Boolean
true if the tag range was successfully removed from the collection; otherwise, false
See Also

Reference

ICollectionTaggerT Interface
Remove Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).RemoveAll Method

ICollectionTaggerTRemoveAll Method
Removes all objects that match the conditions defined by the specified predicate.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int RemoveAll(
    Predicate<TagVersionRange<T>> match
)
Function RemoveAll (
    match As Predicate(Of TagVersionRange(Of T))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange T
The predicate that defines the conditions for removal.

Return Value

Type: Int32
The number of objects that were removed.
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Toggle Method

ICollectionTaggerTToggle Method
Overload List
 | Name | Description
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Toggle Method (ITextSnapshotLine, T)

ICollectionTaggerTToggle Method (ITextSnapshotLine, T)
Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> Toggle(
    ITextSnapshotLine snapshotLine,
    T tag
)
Function Toggle (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add, if no tag is already on the line.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.
See Also

Reference

ICollectionTaggerT Interface
Toggle Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T).Toggle Method (TextSnapshotRange, T)

ICollectionTaggerTToggle Method (TextSnapshotRange, T)
Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagVersionRange<T> Toggle(
    TextSnapshotRange snapshotRange,
    T tag
)
Function Toggle (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add, if no tag is already in the text range.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.
See Also

Reference

ICollectionTaggerT Interface
Toggle Overload
ActiproSoftware.Text.Tagging Namespace


ICollectionTagger(T) Events

ICollectionTaggerT Events

The ICollectionTaggerT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from ITaggerT.)
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed. (Inherited from ITaggerT.)
Top
See Also

Reference

ICollectionTaggerT Interface
ActiproSoftware.Text.Tagging Namespace


IDelimiterHighlightTag Interface

IDelimiterHighlightTag Interface
Provides the base requirements for an ITag that spans a delimiter highlight.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDelimiterHighlightTag : ITag
Public Interface IDelimiterHighlightTag
    Inherits ITag

The IDelimiterHighlightTag type exposes the following members.

Properties
 | Name | Description
Public property | MatchEdges | Gets which edges of the delimiter's range are considered part of the highlight.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IDelimiterHighlightTag Properties

IDelimiterHighlightTag Properties

The IDelimiterHighlightTag type exposes the following members.

Properties
 | Name | Description
Public property | MatchEdges | Gets which edges of the delimiter's range are considered part of the highlight.
Top
See Also

Reference

IDelimiterHighlightTag Interface
ActiproSoftware.Text.Tagging Namespace


IDelimiterHighlightTag.MatchEdges Property

IDelimiterHighlightTagMatchEdges Property
Gets which edges of the delimiter's range are considered part of the highlight.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
StructureMatchEdges MatchEdges { get; }
ReadOnly Property MatchEdges As StructureMatchEdges
    Get

Property Value

Type: StructureMatchEdges
A StructureMatchEdges that specifies the valid edges.
See Also

Reference

IDelimiterHighlightTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag Interface

IIndicatorTag Interface
Provides the base requirements for an indicator, which covers range of text and render a glyph in an editor's indicator margin for that range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIndicatorTag : ITag
Public Interface IIndicatorTag
    Inherits ITag

The IIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IIndicatorTag Properties

IIndicatorTag Properties

The IIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag.ContentProvider Property

IIndicatorTagContentProvider Property
Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IContentProvider ContentProvider { get; set; }
Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag.Tag Property

IIndicatorTagTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag Methods

IIndicatorTag Methods

The IIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.
Top
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIndicatorTag.CreateGlyph Method

IIndicatorTagCreateGlyph Method
Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
FrameworkElement CreateGlyph(
    IEditorViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Function CreateGlyph (
    viewLine As IEditorViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
) As FrameworkElement

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The current ITextViewLine being examined.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: Windows.FoundationRect
The bounds in which the indicator will be rendered.

Return Value

Type: FrameworkElement
The FrameworkElement that should be used as a glyph in an editor's indicator margin.
Remarks
Return a value to indicate that
See Also

Reference

IIndicatorTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag Interface

IIntraTextSpacerTag Interface
Provides the base requirements for a spacer that can be inserted between two text characters.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIntraTextSpacerTag : ITag
Public Interface IIntraTextSpacerTag
    Inherits ITag

The IIntraTextSpacerTag type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline.
Public property | Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Public property | Size | Gets the size of the spacer.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag Properties

IIntraTextSpacerTag Properties

The IIntraTextSpacerTag type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline.
Public property | Key | Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
Public property | Size | Gets the size of the spacer.
Top
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag.Baseline Property

IIntraTextSpacerTagBaseline Property
Gets the baseline of the spacer, which is the distance from the top of the spacer to the text baseline.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double Baseline { get; }
ReadOnly Property Baseline As Double
    Get

Property Value

Type: Double
The baseline of the spacer, which is the distance from the top of the spacer to the text baseline.
Remarks
This property can return the height of the spacer to sit the spacer on top of the text baseline.
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag.Key Property

IIntraTextSpacerTagKey Property
Gets an object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Key { get; }
ReadOnly Property Key As Object
    Get

Property Value

Type: Object
An object that can be used to uniquely identify the spacer, so that an adornment can be rendered within its bounds.
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IIntraTextSpacerTag.Size Property

IIntraTextSpacerTagSize Property
Gets the size of the spacer.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Size Size { get; }
ReadOnly Property Size As Size
    Get

Property Value

Type: Size
The size of the spacer.
Remarks
This must be a fixed size.
See Also

Reference

IIntraTextSpacerTag Interface
ActiproSoftware.Text.Tagging Namespace


IReadOnlyRegionTag Interface

IReadOnlyRegionTag Interface
Provides the base requirements for an IReadOnlyRegionTag that can be associated with some text range to mark it as read-only.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IReadOnlyRegionTag : ITag
Public Interface IReadOnlyRegionTag
    Inherits ITag

The IReadOnlyRegionTag type exposes the following members.

Properties
 | Name | Description
Public property | IsReadOnly | Gets whether the tagged text range is currently read-only.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationReadOnlyRegionTag


IReadOnlyRegionTag Properties

IReadOnlyRegionTag Properties

The IReadOnlyRegionTag type exposes the following members.

Properties
 | Name | Description
Public property | IsReadOnly | Gets whether the tagged text range is currently read-only.
Top
See Also

Reference

IReadOnlyRegionTag Interface
ActiproSoftware.Text.Tagging Namespace


IReadOnlyRegionTag.IsReadOnly Property

IReadOnlyRegionTagIsReadOnly Property
Gets whether the tagged text range is currently read-only.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the tagged text range is currently read-only; otherwise, false.
See Also

Reference

IReadOnlyRegionTag Interface
ActiproSoftware.Text.Tagging Namespace


ISquiggleTag Interface

ISquiggleTag Interface
Provides the base requirements for a squiggle line, generally used for error display, that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISquiggleTag : ITag
Public Interface ISquiggleTag
    Inherits ITag

The ISquiggleTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ISquiggleTag Properties

ISquiggleTag Properties

The ISquiggleTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the optional IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

ISquiggleTag Interface
ActiproSoftware.Text.Tagging Namespace


ISquiggleTag.ClassificationType Property

ISquiggleTagClassificationType Property
Gets or sets the optional IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IClassificationType ClassificationType { get; set; }
Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The optional IClassificationType associated with the tag.
See Also

Reference

ISquiggleTag Interface
ActiproSoftware.Text.Tagging Namespace


ISquiggleTag.ContentProvider Property

ISquiggleTagContentProvider Property
Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IContentProvider ContentProvider { get; set; }
Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
See Also

Reference

ISquiggleTag Interface
ActiproSoftware.Text.Tagging Namespace


ITag Interface

ITag Interface
Provides the base requirements for a data object that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITag
Public Interface ITag
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T) Interface

ITagAggregatorT Interface
Provides the base requirements for a object that aggregates ITag objects from multiple ITaggerT instances.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITagAggregator<T> : IDisposable
where T : ITag

Public Interface ITagAggregator(Of T As ITag)
    Inherits IDisposable

Type Parameters

T
The type of ITag associated with this aggregator.

The ITagAggregatorT type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T) Methods

ITagAggregatorT Methods

The ITagAggregatorT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).GetTags Method

ITagAggregatorTGetTags Method
Overload List
 | Name | Description
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).GetTags Method (TextSnapshotRange[])

ITagAggregatorTGetTags Method (TextSnapshotRange)
Returns the tag ranges that intersect with the specified snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<T>> GetTags(
    params TextSnapshotRange[] snapshotRanges
)
Function GetTags (
    ParamArray snapshotRanges As TextSnapshotRange()
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextTextSnapshotRange
The array of snapshot ranges.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified snapshot ranges.
See Also

Reference

ITagAggregatorT Interface
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).GetTags Method (NormalizedTextSnapshotRangeCollection, Object)

ITagAggregatorTGetTags Method (NormalizedTextSnapshotRangeCollection, Object)
Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.
See Also

Reference

ITagAggregatorT Interface
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T) Events

ITagAggregatorT Events

The ITagAggregatorT generic type exposes the following members.

Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagAggregator(T).TagsChanged Event

ITagAggregatorTTagsChanged Event
Occurs after available tags for a specified TextSnapshotRange have changed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<TagsChangedEventArgs> TagsChanged
Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs
See Also

Reference

ITagAggregatorT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T) Interface

ITaggerT Interface
Provides the base requirements for a object that can provide ITag objects that intersect with specified text ranges within an ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITagger<T> : IOrderable,
    IKeyedObject
where T : ITag

Public Interface ITagger(Of T As ITag)
    Inherits IOrderable, IKeyedObject

Type Parameters

T
The type of tag associated with this tagger.

The ITaggerT type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
Methods
 | Name | Description
Public method | Close | Closes the tagger and detaches it.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed.
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace
ActiproSoftware.Text.Tagging.ImplementationTokenTagger


ITagger(T) Properties

ITaggerT Properties

The ITaggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from IOrderable.)
Top
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T) Methods

ITaggerT Methods

The ITaggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the tagger and detaches it.
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).Close Method

ITaggerTClose Method
Closes the tagger and detaches it.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Close()
Sub Close
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).GetTags Method

ITaggerTGetTags Method
Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T) Events

ITaggerT Events

The ITaggerT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed.
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).Closed Event

ITaggerTClosed Event
Occurs after the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Closed
Event Closed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagger(T).TagsChanged Event

ITaggerTTagsChanged Event
Occurs after available tags for a specified TextSnapshotRange have changed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<TagsChangedEventArgs> TagsChanged
Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs
See Also

Reference

ITaggerT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T) Interface

ITagSearchOptionsT Interface
Provides the base requirements for a class that stores tag search operation options.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITagSearchOptions<T>
where T : ITag

Public Interface ITagSearchOptions(Of T As ITag)

Type Parameters

T
The tag type.

The ITagSearchOptionsT type exposes the following members.

Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T) Properties

ITagSearchOptionsT Properties

The ITagSearchOptionsT generic type exposes the following members.

Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T).CanWrap Property

ITagSearchOptionsTCanWrap Property
Gets or sets whether the search can wrap at the end of the search text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanWrap { get; set; }
Property CanWrap As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the search can wrap at the end of the search text range; otherwise, false.
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T).Filter Property

ITagSearchOptionsTFilter Property
Gets or sets the optional callback used to determine if a potential search result is valid.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Predicate<TagVersionRange<T>> Filter { get; set; }
Property Filter As Predicate(Of TagVersionRange(Of T))
    Get
    Set

Property Value

Type: Predicate TagVersionRange T
The optional callback used to determine if a potential search result is valid.
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITagSearchOptions(T).SearchUp Property

ITagSearchOptionsTSearchUp Property
Gets or sets whether to search backwards.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SearchUp { get; set; }
Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.
See Also

Reference

ITagSearchOptionsT Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider Interface

ITextViewTaggerProvider Interface
Provides the base requirements for a object that can create ITaggerT objects for an ITextView.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextViewTaggerProvider
Public Interface ITextViewTaggerProvider

The ITextViewTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider Properties

ITextViewTaggerProvider Properties

The ITextViewTaggerProvider type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider.TagTypes Property

ITextViewTaggerProviderTagTypes Property
Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<Type> TagTypes { get; }
ReadOnly Property TagTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The ITag Type objects that are supported by the ITaggerT objects created by this provider.
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider Methods

ITextViewTaggerProvider Methods

The ITextViewTaggerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Top
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITextViewTaggerProvider.GetTagger(T) Method

ITextViewTaggerProviderGetTaggerT Method
Returns an ITaggerT for the specified ITextView.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITagger<T> GetTagger<T>(
    ITextView view
)
where T : ITag

Function GetTagger(Of T As ITag) (
    view As ITextView
) As ITagger(Of T)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ITextView.
See Also

Reference

ITextViewTaggerProvider Interface
ActiproSoftware.Text.Tagging Namespace


ITokenTag Interface

ITokenTag Interface
Provides the base requirements for an IToken from an ILexer that can be associated with some text range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITokenTag : ITag
Public Interface ITokenTag
    Inherits ITag

The ITokenTag type exposes the following members.

Properties
 | Name | Description
Public property | Token | Gets the lexer IToken associated with this tag.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


ITokenTag Properties

ITokenTag Properties

The ITokenTag type exposes the following members.

Properties
 | Name | Description
Public property | Token | Gets the lexer IToken associated with this tag.
Top
See Also

Reference

ITokenTag Interface
ActiproSoftware.Text.Tagging Namespace


ITokenTag.Token Property

ITokenTagToken Property
Gets the lexer IToken associated with this tag.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IToken Token { get; }
ReadOnly Property Token As IToken
    Get

Property Value

Type: IToken
The lexer IToken associated with this tag.
See Also

Reference

ITokenTag Interface
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Class

TagAggregatorBaseT Class
An abstract base class for an object that aggregates ITag objects from multiple ITaggerT instances.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.TaggingTagAggregatorBaseT

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TagAggregatorBase<T> : DisposableObject,
    ITagAggregator<T>, IDisposable
where T : ITag

Public MustInherit Class TagAggregatorBase(Of T As ITag)
    Inherits DisposableObject
    Implements ITagAggregator(Of T), IDisposable

Type Parameters

T
The type of ITag associated with this aggregator.

The TagAggregatorBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | TagAggregatorBaseT | Initializes a new instance of the TagAggregatorBase class.
Protected method | TagAggregatorBaseT(Boolean) | Initializes a new instance of the TagAggregatorBase class.
Top
Properties
 | Name | Description
Protected property | CanAttachToEvents | Gets whether the tag aggregator can attach to events.
Protected property | IsDisposed | Gets whether this object has been disposed.
Top
Methods
 | Name | Description
Protected method | AttachDocument | Attaches to a new document.
Protected method | DetachDocument | Detaches the document.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTaggers | Returns the list of available taggers.
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Public method | GetType | (Inherited from Object.)
Protected method | IsRefreshRequired | Returns whether a Refresh is required when the specified service is added to or removed from the document's language.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnTagsChanged | Raises the TagsChanged event.
Protected method | Refresh | Refreshes the tag aggregator by reloading the taggers being watched.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Constructor

TagAggregatorBaseT Constructor
Overload List
 | Name | Description
Protected method | TagAggregatorBaseT | Initializes a new instance of the TagAggregatorBase class.
Protected method | TagAggregatorBaseT(Boolean) | Initializes a new instance of the TagAggregatorBase class.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Constructor

TagAggregatorBaseT Constructor
Initializes a new instance of the TagAggregatorBase class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TagAggregatorBase()
Protected Sub New
See Also

Reference

TagAggregatorBaseT Class
TagAggregatorBaseT Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Constructor (Boolean)

TagAggregatorBaseT Constructor (Boolean)
Initializes a new instance of the TagAggregatorBase class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TagAggregatorBase(
    bool canAttachToEvents
)
Protected Sub New (
    canAttachToEvents As Boolean
)

Parameters

canAttachToEvents
Type: SystemBoolean
Whether to attach to events such as document language changes.
See Also

Reference

TagAggregatorBaseT Class
TagAggregatorBaseT Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Properties

TagAggregatorBaseT Properties

The TagAggregatorBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CanAttachToEvents | Gets whether the tag aggregator can attach to events.
Protected property | IsDisposed | Gets whether this object has been disposed.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).CanAttachToEvents Property

TagAggregatorBaseTCanAttachToEvents Property
Gets whether the tag aggregator can attach to events.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected bool CanAttachToEvents { get; }
Protected ReadOnly Property CanAttachToEvents As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).IsDisposed Property

TagAggregatorBaseTIsDisposed Property
Gets whether this object has been disposed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected bool IsDisposed { get; }
Protected ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
true if this object has been disposed; otherwise, false.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Methods

TagAggregatorBaseT Methods

The TagAggregatorBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AttachDocument | Attaches to a new document.
Protected method | DetachDocument | Detaches the document.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTaggers | Returns the list of available taggers.
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Public method | GetType | (Inherited from Object.)
Protected method | IsRefreshRequired | Returns whether a Refresh is required when the specified service is added to or removed from the document's language.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnTagsChanged | Raises the TagsChanged event.
Protected method | Refresh | Refreshes the tag aggregator by reloading the taggers being watched.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).AttachDocument Method

TagAggregatorBaseTAttachDocument Method
Attaches to a new document.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void AttachDocument(
    ICodeDocument newDocument
)
Protected Sub AttachDocument (
    newDocument As ICodeDocument
)

Parameters

newDocument
Type: ActiproSoftware.TextICodeDocument
The new ICodeDocument.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).DetachDocument Method

TagAggregatorBaseTDetachDocument Method
Detaches the document.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void DetachDocument()
Protected Sub DetachDocument
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).Dispose Method

TagAggregatorBaseTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).Dispose Method (Boolean)

TagAggregatorBaseTDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

TagAggregatorBaseT Class
Dispose Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTaggers Method

TagAggregatorBaseTGetTaggers Method
Returns the list of available taggers.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IList<ITagger<T>> GetTaggers()
Protected Overridable Function GetTaggers As IList(Of ITagger(Of T))

Return Value

Type: IList ITagger T
The list of available taggers.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTags Method

TagAggregatorBaseTGetTags Method
Overload List
 | Name | Description
Public method | GetTags(TextSnapshotRange) | Returns the tag ranges that intersect with the specified snapshot ranges.
Public method | GetTags(NormalizedTextSnapshotRangeCollection, Object) | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTags Method (TextSnapshotRange[])

TagAggregatorBaseTGetTags Method (TextSnapshotRange)
Returns the tag ranges that intersect with the specified snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<TagSnapshotRange<T>> GetTags(
    params TextSnapshotRange[] snapshotRanges
)
Public Function GetTags (
    ParamArray snapshotRanges As TextSnapshotRange()
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextTextSnapshotRange
The array of snapshot ranges.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified snapshot ranges.

Implements

ITagAggregatorTGetTags(TextSnapshotRange)
See Also

Reference

TagAggregatorBaseT Class
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).GetTags Method (NormalizedTextSnapshotRangeCollection, Object)

TagAggregatorBaseTGetTags Method (NormalizedTextSnapshotRangeCollection, Object)
Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITagAggregatorTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

TagAggregatorBaseT Class
GetTags Overload
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).IsRefreshRequired Method

TagAggregatorBaseTIsRefreshRequired Method
Returns whether a Refresh is required when the specified service is added to or removed from the document's language.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsRefreshRequired(
    Object service
)
Protected Overridable Function IsRefreshRequired (
    service As Object
) As Boolean

Parameters

service
Type: SystemObject
The service to examine.

Return Value

Type: Boolean
true if a refresh is required; otherwise, false.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).OnTagsChanged Method

TagAggregatorBaseTOnTagsChanged Method
Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTagsChanged(
    TagsChangedEventArgs e
)
Protected Overridable Sub OnTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).Refresh Method

TagAggregatorBaseTRefresh Method
Refreshes the tag aggregator by reloading the taggers being watched.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void Refresh()
Protected Sub Refresh
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T) Events

TagAggregatorBaseT Events

The TagAggregatorBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | TagsChanged | Occurs after available tags for a specified TextSnapshotRange have changed.
Top
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TagAggregatorBase(T).TagsChanged Event

TagAggregatorBaseTTagsChanged Event
Occurs after available tags for a specified TextSnapshotRange have changed.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TagsChangedEventArgs> TagsChanged
Public Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs

Implements

ITagAggregatorTTagsChanged
See Also

Reference

TagAggregatorBaseT Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys Class

TaggerKeys Class
Specifies the names of the built-in ITaggerT objects that are included with this product.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.TaggingTaggerKeys

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class TaggerKeys
Public NotInheritable Class TaggerKeys

The TaggerKeys type exposes the following members.

Fields
Name | Description
BookmarkIndicator | The bookmark indicator tagger.
BreakpointIndicator | The breakpoint indicator tagger.
CurrentStatementIndicator | The current statement indicator tagger.
FindMatchHighlight | The find match highlight tagger.
Token | The token tagger, that also generally provides the core classification types for text.
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TaggerKeys Fields

TaggerKeys Fields

The TaggerKeys type exposes the following members.

Fields
Name | Description
BookmarkIndicator | The bookmark indicator tagger.
BreakpointIndicator | The breakpoint indicator tagger.
CurrentStatementIndicator | The current statement indicator tagger.
FindMatchHighlight | The find match highlight tagger.
Token | The token tagger, that also generally provides the core classification types for text.
Top
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.BookmarkIndicator Field

TaggerKeysBookmarkIndicator Field
The bookmark indicator tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string BookmarkIndicator = "BookmarkIndicator"
Public Const BookmarkIndicator As String = "BookmarkIndicator"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.BreakpointIndicator Field

TaggerKeysBreakpointIndicator Field
The breakpoint indicator tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string BreakpointIndicator = "BreakpointIndicator"
Public Const BreakpointIndicator As String = "BreakpointIndicator"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.CurrentStatementIndicator Field

TaggerKeysCurrentStatementIndicator Field
The current statement indicator tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string CurrentStatementIndicator = "CurrentStatementIndicator"
Public Const CurrentStatementIndicator As String = "CurrentStatementIndicator"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.FindMatchHighlight Field

TaggerKeysFindMatchHighlight Field
The find match highlight tagger.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string FindMatchHighlight = "FindMatchHighlight"
Public Const FindMatchHighlight As String = "FindMatchHighlight"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TaggerKeys.Token Field

TaggerKeysToken Field
The token tagger, that also generally provides the core classification types for text.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string Token = "Token"
Public Const Token As String = "Token"

Field Value

Type: String
See Also

Reference

TaggerKeys Class
ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Class

TagsChangedEventArgs Class
Event arguments for when an ITaggerT alters tags on text.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.TextTextSnapshotRangeEventArgs
ActiproSoftware.Text.TaggingTagsChangedEventArgs

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TagsChangedEventArgs : TextSnapshotRangeEventArgs
Public Class TagsChangedEventArgs
    Inherits TextSnapshotRangeEventArgs

The TagsChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TagsChangedEventArgs | Initializes a new instance of the TagsChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change. (Inherited from TextSnapshotRangeEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Constructor

TagsChangedEventArgs Constructor
Initializes a new instance of the TagsChangedEventArgs class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagsChangedEventArgs(
    TextSnapshotRange snapshotRange
)
Public Sub New (
    snapshotRange As TextSnapshotRange
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange of the change.
See Also

Reference

TagsChangedEventArgs Class
ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Properties

TagsChangedEventArgs Properties

The TagsChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange of the change. (Inherited from TextSnapshotRangeEventArgs.)
Top
See Also

Reference

TagsChangedEventArgs Class
ActiproSoftware.Text.Tagging Namespace


TagsChangedEventArgs Methods

TagsChangedEventArgs Methods

The TagsChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TagsChangedEventArgs Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Class

TagSnapshotRangeT Class
Implements an object that represents an ITag and its associated TextSnapshotRange.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.TaggingTagSnapshotRangeT

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TagSnapshotRange<T>
where T : ITag

Public Class TagSnapshotRange(Of T As ITag)

Type Parameters

T
The type of tag associated with this range.

The TagSnapshotRangeT type exposes the following members.

Constructors
 | Name | Description
Public method | TagSnapshotRangeT | Initializes a new instance of the TagSnapshotRange class.
Top
Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange over which the Tag applies.
Public property | Tag | Gets the ITag data object associated with this range.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Constructor

TagSnapshotRangeT Constructor
Initializes a new instance of the TagSnapshotRange class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagSnapshotRange(
    TextSnapshotRange snapshotRange,
    T tag
)
Public Sub New (
    snapshotRange As TextSnapshotRange,
    tag As T
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which the Tag applies.
tag
Type: T
The ITag data object associated with this range.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Properties

TagSnapshotRangeT Properties

The TagSnapshotRangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | SnapshotRange | Gets the TextSnapshotRange over which the Tag applies.
Public property | Tag | Gets the ITag data object associated with this range.
Top
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).SnapshotRange Property

TagSnapshotRangeTSnapshotRange Property
Gets the TextSnapshotRange over which the Tag applies.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange SnapshotRange { get; }
Public ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange over which the Tag applies.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).Tag Property

TagSnapshotRangeTTag Property
Gets the ITag data object associated with this range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Tag { get; }
Public ReadOnly Property Tag As T
    Get

Property Value

Type: T
The ITag data object associated with this range.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T) Methods

TagSnapshotRangeT Methods

The TagSnapshotRangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).Equals Method

TagSnapshotRangeTEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).GetHashCode Method

TagSnapshotRangeTGetHashCode Method
Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagSnapshotRange(T).ToString Method

TagSnapshotRangeTToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TagSnapshotRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Class

TagVersionRangeT Class
Implements an object that represents an ITag and its associated ITextVersionRange.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.TaggingTagVersionRangeT

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TagVersionRange<T>
where T : ITag

Public Class TagVersionRange(Of T As ITag)

Type Parameters

T
The type of tag associated with this range.

The TagVersionRangeT type exposes the following members.

Constructors
 | Name | Description
Public method | TagVersionRangeT(ITextVersionRange, T) | Initializes a new instance of the TagVersionRange class.
Public method | TagVersionRangeT(TextSnapshotRange, TextRangeTrackingModes, T) | Initializes a new instance of the TagVersionRange class.
Top
Properties
 | Name | Description
Public property | Tag | Gets the ITag data object associated with this range.
Public property | VersionRange | Gets the ITextVersionRange over which the Tag applies.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Constructor

TagVersionRangeT Constructor
Overload List
 | Name | Description
Public method | TagVersionRangeT(ITextVersionRange, T) | Initializes a new instance of the TagVersionRange class.
Public method | TagVersionRangeT(TextSnapshotRange, TextRangeTrackingModes, T) | Initializes a new instance of the TagVersionRange class.
Top
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Constructor (ITextVersionRange, T)

TagVersionRangeT Constructor (ITextVersionRange, T)
Initializes a new instance of the TagVersionRange class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange(
    ITextVersionRange versionRange,
    T tag
)
Public Sub New (
    versionRange As ITextVersionRange,
    tag As T
)

Parameters

versionRange
Type: ActiproSoftware.TextITextVersionRange
The ITextVersionRange over which the Tag applies.
tag
Type: T
The ITag data object associated with this range.
See Also

Reference

TagVersionRangeT Class
TagVersionRangeT Overload
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Constructor (TextSnapshotRange, TextRangeTrackingModes, T)

TagVersionRangeT Constructor (TextSnapshotRange, TextRangeTrackingModes, T)
Initializes a new instance of the TagVersionRange class.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange(
    TextSnapshotRange snapshotRange,
    TextRangeTrackingModes trackingModes,
    T tag
)
Public Sub New (
    snapshotRange As TextSnapshotRange,
    trackingModes As TextRangeTrackingModes,
    tag As T
)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange over which the Tag applies.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.
tag
Type: T
The ITag data object associated with this range.
See Also

Reference

TagVersionRangeT Class
TagVersionRangeT Overload
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Properties

TagVersionRangeT Properties

The TagVersionRangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets the ITag data object associated with this range.
Public property | VersionRange | Gets the ITextVersionRange over which the Tag applies.
Top
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).Tag Property

TagVersionRangeTTag Property
Gets the ITag data object associated with this range.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Tag { get; }
Public ReadOnly Property Tag As T
    Get

Property Value

Type: T
The ITag data object associated with this range.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).VersionRange Property

TagVersionRangeTVersionRange Property
Gets the ITextVersionRange over which the Tag applies.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextVersionRange VersionRange { get; }
Public ReadOnly Property VersionRange As ITextVersionRange
    Get

Property Value

Type: ITextVersionRange
The ITextVersionRange over which the Tag applies.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T) Methods

TagVersionRangeT Methods

The TagVersionRangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).Equals Method

TagVersionRangeTEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


TagVersionRange(T).GetHashCode Method

TagVersionRangeTGetHashCode Method
Serves as a hash function for a particular type.

Namespace: ActiproSoftware.Text.Tagging
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

TagVersionRangeT Class
ActiproSoftware.Text.Tagging Namespace


ActiproSoftware.Text.Tagging.Implementation Namespace

ActiproSoftware.Text.Tagging.Implementation Namespace
Contains implementation types related to tagging text ranges with custom data.
Classes
 | Class | Description
Public class | BookmarkIndicatorTag | Represents an IIndicatorTag that renders a bookmark indicator.
Public class | BookmarkIndicatorTagger | Provides BookmarkIndicatorTag objects over text ranges.
Public class | BreakpointIndicatorTag | Represents an IIndicatorTag that renders a breakpoint over a text range.
Public class | BreakpointIndicatorTagger | Provides BreakpointIndicatorTag objects over text ranges.
Public class | ClassificationTag | Represents an ITag that can be used to associate an IClassificationType with some text range by implementing IClassificationTag.
Public class | CodeDocumentTaggerProviderTTagger | Provides an ICodeDocumentTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ICodeDocument instance parameter.
Public class | CollectionTaggerT | Provides a thread-safe ITaggerT implementation that maintains a simple collection of tagged ranges.
Public class | CurrentStatementIndicatorTag | Represents an IIndicatorTag that renders a current statement marker over a text range.
Public class | CurrentStatementIndicatorTagger | Provides CurrentStatementIndicatorTag objects over text ranges.
Public class | DelimiterHighlightTagger | Provides a view-based classification tagger that tags delimiter pairs or sets.
Public class | IndicatorClassificationTagBase | Provides the abstract base class for an ITag that can be used to mark an indicator and classification over a text range.
Public class | IndicatorClassificationTaggerBaseTTag | Represents the abstract base class for providing IIndicatorTag and IClassificationTag objects over text ranges.
Public class | IndicatorTagBase | Provides the abstract base class for an ITag that can be used to mark an indicator over a text range.
Public class | IndicatorTaggerBaseTTag | Represents the abstract base class for providing IIndicatorTag objects over text ranges.
Public class | ParseErrorTagger | Provides an ITaggerT implementation that tags IParseError objects found in a document's parse data.
Public class | ReadOnlyRegionTag | Represents an ITag that can be used to mark a text range as read-only, and can optionally associate an IClassificationType.
Public class | SearchResultHighlightTagger | Provides a view-based classification tagger that tags search results.
Public class | SquiggleTag | Provides a basic ISquiggleTag implementation, generally used for error display, that can be associated with some text range.
Public class | StyleRegistryClassificationTag | Provides a ClassificationTag implementation that uses an alternate IHighlightingStyleRegistry, and can be associated with some text range.
Public class | TaggerBaseT | Provides an abstract base class for an ITaggerT implementation.
Public class | TaggerProviderBaseTTagger | Provides an abstract tagger provider base class that automatically returns the TagTypes supported based on reflection of the TTagger type.
Public class | TagSearchOptionsT | Stores tag search operation options.
Public class | TextViewTaggerProviderTTagger | Provides an ITextViewTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ITextView instance parameter.
Public class | TokenClassificationTag | Represents an ITag that can be used to associate an IClassificationType and an IToken with some text range by implementing IClassificationTag and ITokenTag.
Public class | TokenTagger | An ITaggerT implementation that provides ITokenTag and IClassificationTag objects based on a language's ILexer.
Public class | TokenTaggerProviderTTagger | Provides an ICodeDocumentTaggerProvider capable of creating TokenTagger objects which have a constructor that accepts a single ICodeDocument instance parameter.


BookmarkIndicatorTag Class

BookmarkIndicatorTag Class
Represents an IIndicatorTag that renders a bookmark indicator.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BookmarkIndicatorTag : IndicatorTagBase,
    INotifyPropertyChanged
Public Class BookmarkIndicatorTag
    Inherits IndicatorTagBase
    Implements INotifyPropertyChanged

The BookmarkIndicatorTag type exposes the following members.

Constructors
 | Name | Description
Public method | BookmarkIndicatorTag | Initializes a new instance of the BookmarkIndicatorTag class
Top
Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the bookmark is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Overrides IndicatorTagBaseCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Constructor

BookmarkIndicatorTag Constructor
Initializes a new instance of the BookmarkIndicatorTag class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BookmarkIndicatorTag()
Public Sub New
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Properties

BookmarkIndicatorTag Properties

The BookmarkIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the bookmark is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.IsEnabled Property

BookmarkIndicatorTagIsEnabled Property
Gets or sets whether the bookmark is enabled.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the bookmark is enabled; otherwise, false.
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Methods

BookmarkIndicatorTag Methods

The BookmarkIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Overrides IndicatorTagBaseCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.CreateGlyph Method

BookmarkIndicatorTagCreateGlyph Method
Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override FrameworkElement CreateGlyph(
    IEditorViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public Overrides Function CreateGlyph (
    viewLine As IEditorViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
) As FrameworkElement

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The current ITextViewLine being examined.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: Windows.FoundationRect
The bounds in which the indicator will be rendered.

Return Value

Type: FrameworkElement
The FrameworkElement that should be used as a glyph in an editor's indicator margin.

Implements

IIndicatorTagCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.NotifyPropertyChanged Method

BookmarkIndicatorTagNotifyPropertyChanged Method
Notifies that a property has changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.OnPropertyChanged Method

BookmarkIndicatorTagOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag Events

BookmarkIndicatorTag Events

The BookmarkIndicatorTag type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTag.PropertyChanged Event

BookmarkIndicatorTagPropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

BookmarkIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Class

BookmarkIndicatorTagger Class
Provides BookmarkIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase BookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger BookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase BookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BookmarkIndicatorTagger : IndicatorTaggerBase<BookmarkIndicatorTag>
Public Class BookmarkIndicatorTagger
    Inherits IndicatorTaggerBase(Of BookmarkIndicatorTag)

The BookmarkIndicatorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | BookmarkIndicatorTagger | Initializes a new instance of the BookmarkIndicatorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Constructor

BookmarkIndicatorTagger Constructor
Initializes a new instance of the BookmarkIndicatorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BookmarkIndicatorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Properties

BookmarkIndicatorTagger Properties

The BookmarkIndicatorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Methods

BookmarkIndicatorTagger Methods

The BookmarkIndicatorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BookmarkIndicatorTagger Events

BookmarkIndicatorTagger Events

The BookmarkIndicatorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BookmarkIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Class

BreakpointIndicatorTag Class
Represents an IIndicatorTag that renders a breakpoint over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BreakpointIndicatorTag : IndicatorClassificationTagBase,
    INotifyPropertyChanged
Public Class BreakpointIndicatorTag
    Inherits IndicatorClassificationTagBase
    Implements INotifyPropertyChanged

The BreakpointIndicatorTag type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointIndicatorTag | Initializes a new instance of the BreakpointIndicatorTag class
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the breakpoint is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Overrides IndicatorTagBaseCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Constructor

BreakpointIndicatorTag Constructor
Initializes a new instance of the BreakpointIndicatorTag class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BreakpointIndicatorTag()
Public Sub New
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Properties

BreakpointIndicatorTag Properties

The BreakpointIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | IsEnabled | Gets or sets whether the breakpoint is enabled.
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.ClassificationType Property

BreakpointIndicatorTagClassificationType Property
Gets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IClassificationType ClassificationType { get; }
Public Overrides ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.IsEnabled Property

BreakpointIndicatorTagIsEnabled Property
Gets or sets whether the breakpoint is enabled.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the breakpoint is enabled; otherwise, false.
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Methods

BreakpointIndicatorTag Methods

The BreakpointIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Overrides IndicatorTagBaseCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.CreateGlyph Method

BreakpointIndicatorTagCreateGlyph Method
Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override FrameworkElement CreateGlyph(
    IEditorViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public Overrides Function CreateGlyph (
    viewLine As IEditorViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
) As FrameworkElement

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The current ITextViewLine being examined.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: Windows.FoundationRect
The bounds in which the indicator will be rendered.

Return Value

Type: FrameworkElement
The FrameworkElement that should be used as a glyph in an editor's indicator margin.

Implements

IIndicatorTagCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.NotifyPropertyChanged Method

BreakpointIndicatorTagNotifyPropertyChanged Method
Notifies that a property has changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.OnPropertyChanged Method

BreakpointIndicatorTagOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag Events

BreakpointIndicatorTag Events

The BreakpointIndicatorTag type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTag.PropertyChanged Event

BreakpointIndicatorTagPropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

BreakpointIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Class

BreakpointIndicatorTagger Class
Provides BreakpointIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBase BreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BreakpointIndicatorTagger : IndicatorClassificationTaggerBase<BreakpointIndicatorTag>
Public Class BreakpointIndicatorTagger
    Inherits IndicatorClassificationTaggerBase(Of BreakpointIndicatorTag)

The BreakpointIndicatorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | BreakpointIndicatorTagger | Initializes a new instance of the BreakpointIndicatorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Constructor

BreakpointIndicatorTagger Constructor
Initializes a new instance of the BreakpointIndicatorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BreakpointIndicatorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Properties

BreakpointIndicatorTagger Properties

The BreakpointIndicatorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Methods

BreakpointIndicatorTagger Methods

The BreakpointIndicatorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


BreakpointIndicatorTagger Events

BreakpointIndicatorTagger Events

The BreakpointIndicatorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

BreakpointIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Class

ClassificationTag Class
Represents an ITag that can be used to associate an IClassificationType with some text range by implementing IClassificationTag.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationClassificationTag
ActiproSoftware.Text.Tagging.ImplementationReadOnlyRegionTag
ActiproSoftware.Text.Tagging.ImplementationStyleRegistryClassificationTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ClassificationTag : IClassificationTag,
    ITag
Public Class ClassificationTag
    Implements IClassificationTag, ITag

The ClassificationTag type exposes the following members.

Constructors
 | Name | Description
Public method | ClassificationTag | Initializes a new instance of the ClassificationTag class.
Public method | ClassificationTag(IClassificationType) | Initializes a new instance of the ClassificationTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Constructor

ClassificationTag Constructor
Overload List
 | Name | Description
Public method | ClassificationTag | Initializes a new instance of the ClassificationTag class.
Public method | ClassificationTag(IClassificationType) | Initializes a new instance of the ClassificationTag class.
Top
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Constructor

ClassificationTag Constructor
Initializes a new instance of the ClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassificationTag()
Public Sub New
See Also

Reference

ClassificationTag Class
ClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Constructor (IClassificationType)

ClassificationTag Constructor (IClassificationType)
Initializes a new instance of the ClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ClassificationTag(
    IClassificationType classificationType
)
Public Sub New (
    classificationType As IClassificationType
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
See Also

Reference

ClassificationTag Class
ClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Properties

ClassificationTag Properties

The ClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Top
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag.ClassificationType Property

ClassificationTagClassificationType Property
Gets or sets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag Methods

ClassificationTag Methods

The ClassificationTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ClassificationTag.ToString Method

ClassificationTagToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

ClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Class

CodeDocumentTaggerProviderTTagger Class
Provides an ICodeDocumentTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ICodeDocument instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase TTagger
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProviderTTagger
ActiproSoftware.Text.Tagging.ImplementationTokenTaggerProviderTTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CodeDocumentTaggerProvider<TTagger> : TaggerProviderBase<TTagger>,
    ICodeDocumentTaggerProvider
where TTagger : class

Public Class CodeDocumentTaggerProvider(Of TTagger As Class)
    Inherits TaggerProviderBase(Of TTagger)
    Implements ICodeDocumentTaggerProvider

Type Parameters

TTagger
The Type of ITaggerT that this provider creates. The tagger type must have a constructor that accepts a single ICodeDocument instance parameter.

The CodeDocumentTaggerProviderTTagger type exposes the following members.

Constructors
 | Name | Description
Public method | CodeDocumentTaggerProviderTTagger | Initializes a new instance of the CodeDocumentTaggerProvider class.
Public method | CodeDocumentTaggerProviderTTagger(Object) | Initializes a new instance of the CodeDocumentTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Constructor

CodeDocumentTaggerProviderTTagger Constructor
Overload List
 | Name | Description
Public method | CodeDocumentTaggerProviderTTagger | Initializes a new instance of the CodeDocumentTaggerProvider class.
Public method | CodeDocumentTaggerProviderTTagger(Object) | Initializes a new instance of the CodeDocumentTaggerProvider class.
Top
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Constructor

CodeDocumentTaggerProviderTTagger Constructor
Initializes a new instance of the CodeDocumentTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CodeDocumentTaggerProvider()
Public Sub New
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
CodeDocumentTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Constructor (Object)

CodeDocumentTaggerProviderTTagger Constructor (Object)
Initializes a new instance of the CodeDocumentTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CodeDocumentTaggerProvider(
    Object singletonKey
)
Public Sub New (
    singletonKey As Object
)

Parameters

singletonKey
Type: SystemObject
When a non-null value is passed, the tagger will be stored as a singleton under the specified key in the document's properties.
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
CodeDocumentTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Properties

CodeDocumentTaggerProviderTTagger Properties

The CodeDocumentTaggerProviderTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger) Methods

CodeDocumentTaggerProviderTTagger Methods

The CodeDocumentTaggerProviderTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CodeDocumentTaggerProvider(TTagger).GetTagger(T) Method

CodeDocumentTaggerProviderTTaggerGetTaggerT Method
Returns an ITaggerT for the specified ICodeDocument.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ICodeDocument document
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    document As ICodeDocument
) As ITagger(Of T)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The ICodeDocument that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ICodeDocument.

Implements

ICodeDocumentTaggerProviderGetTaggerT(ICodeDocument)
See Also

Reference

CodeDocumentTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Class

CollectionTaggerT Class
Provides a thread-safe ITaggerT implementation that maintains a simple collection of tagged ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase T
ActiproSoftware.Text.Tagging.ImplementationCollectionTaggerT
ActiproSoftware.Text.Tagging.ImplementationDelimiterHighlightTagger
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBaseTTag
ActiproSoftware.Text.Tagging.ImplementationParseErrorTagger
ActiproSoftware.Text.Tagging.ImplementationSearchResultHighlightTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class CollectionTagger<T> : TaggerBase<T>,
    ICollection<TagVersionRange<T>>, IEnumerable<TagVersionRange<T>>, IEnumerable,
    ICollectionTagger<T>, ITagger<T>, IOrderable, IKeyedObject, INotifyCollectionChanged
where T : class, ITag

Public MustInherit Class CollectionTagger(Of T As {Class, ITag})
    Inherits TaggerBase(Of T)
    Implements ICollection(Of TagVersionRange(Of T)), IEnumerable(Of TagVersionRange(Of T)),
    IEnumerable, ICollectionTagger(Of T), ITagger(Of T), IOrderable,
    IKeyedObject, INotifyCollectionChanged

Type Parameters

T
The type of tag associated with this tagger.

The CollectionTaggerT type exposes the following members.

Constructors
 | Name | Description
Protected method | CollectionTaggerT | Initializes a new instance of the CollectionTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Constructor

CollectionTaggerT Constructor
Initializes a new instance of the CollectionTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected CollectionTagger(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Properties

CollectionTaggerT Properties

The CollectionTaggerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Count Property

CollectionTaggerTCount Property
Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.

Implements

ICollectionTCount
ICollectionTaggerTCount
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Item Property

CollectionTaggerTItem Property
Gets the tag range that points to the specified tag.

[C#] In C#, this property is the indexer for the CollectionTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> this[
    T tag
] { get; }
Public ReadOnly Property Item (
    tag As T
) As TagVersionRange(Of T)
    Get

Parameters

tag
Type: T
The tag for which to search.

Property Value

Type: TagVersionRange T
The tag range that points to the specified tag.

Implements

ICollectionTaggerTItemT
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Methods

CollectionTaggerT Methods

The CollectionTaggerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection.
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo |
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate.
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method

CollectionTaggerTAdd Method
Overload List
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection.
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method (TagVersionRange(T))

CollectionTaggerTAdd Method (TagVersionRangeT)
Adds a tag range to the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    TagVersionRange<T> tagRange
)
Public Sub Add (
    tagRange As TagVersionRange(Of T)
)

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to add to the collection.

Implements

ICollectionTAdd(T)
ICollectionTaggerTAdd(TagVersionRangeT)
Remarks
This is the lowest-level method used for adding a tag range, and gives the most control over snapshot translation options.
See Also

Reference

CollectionTaggerT Class
Add Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method (ITextSnapshotLine, T)

CollectionTaggerTAdd Method (ITextSnapshotLine, T)
Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Add(
    ITextSnapshotLine snapshotLine,
    T tag
)
Public Function Add (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.

Implements

ICollectionTaggerTAdd(ITextSnapshotLine, T)
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength and LineBased flags.
See Also

Reference

CollectionTaggerT Class
Add Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Add Method (TextSnapshotRange, T)

CollectionTaggerTAdd Method (TextSnapshotRange, T)
Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Add(
    TextSnapshotRange snapshotRange,
    T tag
)
Public Function Add (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created.

Implements

ICollectionTaggerTAdd(TextSnapshotRange, T)
Remarks
The generated ITextVersionRange is created with the DeleteWhenZeroLength flag.
See Also

Reference

CollectionTaggerT Class
Add Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Clear Method

CollectionTaggerTClear Method
Removes all items from the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
ICollectionTaggerTClear
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Contains Method

CollectionTaggerTContains Method
Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    TagVersionRange<T> tagRange
)
Public Function Contains (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The object to locate in the collection.

Return Value

Type: Boolean
true if the item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
ICollectionTaggerTContains(TagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).CopyTo Method

CollectionTaggerTCopyTo Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Tagging.Implementation.CollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    TagVersionRange<T>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As TagVersionRange(Of T)(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.TaggingTagVersionRange T

[Missing <param name="array"/> documentation for "M:ActiproSoftware.Text.Tagging.Implementation.CollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

arrayIndex
Type: SystemInt32

[Missing <param name="arrayIndex"/> documentation for "M:ActiproSoftware.Text.Tagging.Implementation.CollectionTagger`1.CopyTo(ActiproSoftware.Text.Tagging.TagVersionRange{`0}[],System.Int32)"]

Implements

ICollectionTCopyTo(T, Int32)
ICollectionTaggerTCopyTo(TagVersionRangeT, Int32)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).CreateBatch Method

CollectionTaggerTCreateBatch Method
Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDisposable CreateBatch()
Public Function CreateBatch As IDisposable

Return Value

Type: IDisposable
An IDisposable object. Once disposed, the batch is ended.

Implements

ICollectionTaggerTCreateBatch
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).FindNext Method

CollectionTaggerTFindNext Method
Overload List
 | Name | Description
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).FindNext Method (ITextSnapshotLine, ITagSearchOptions(T))

CollectionTaggerTFindNext Method (ITextSnapshotLine, ITagSearchOptionsT)
Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> FindNext(
    ITextSnapshotLine snapshotLine,
    ITagSearchOptions<T> options
)
Public Function FindNext (
    snapshotLine As ITextSnapshotLine,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The ITextSnapshotLine from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.

Implements

ICollectionTaggerTFindNext(ITextSnapshotLine, ITagSearchOptionsT)
See Also

Reference

CollectionTaggerT Class
FindNext Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).FindNext Method (TextSnapshotOffset, ITagSearchOptions(T))

CollectionTaggerTFindNext Method (TextSnapshotOffset, ITagSearchOptionsT)
Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> FindNext(
    TextSnapshotOffset snapshotOffset,
    ITagSearchOptions<T> options
)
Public Function FindNext (
    snapshotOffset As TextSnapshotOffset,
    options As ITagSearchOptions(Of T)
) As TagVersionRange(Of T)

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset from which to start the search.
options
Type: ActiproSoftware.Text.TaggingITagSearchOptions T
The optional ITagSearchOptionsT that specifies search options.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was found, if any.

Implements

ICollectionTaggerTFindNext(TextSnapshotOffset, ITagSearchOptionsT)
See Also

Reference

CollectionTaggerT Class
FindNext Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).GetEnumerator Method

CollectionTaggerTGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<TagVersionRange<T>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TagVersionRange(Of T))

Return Value

Type: IEnumerator TagVersionRange T
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
ICollectionTaggerTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).GetTags Method

CollectionTaggerTGetTags Method
Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public Overrides Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Remove Method

CollectionTaggerTRemove Method
Overload List
 | Name | Description
Public method | Remove(T) | Removes a specific tag instance from the collection.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection.
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Remove Method (T)

CollectionTaggerTRemove Method (T)
Removes a specific tag instance from the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    T tag
)
Public Function Remove (
    tag As T
) As Boolean

Parameters

tag
Type: T
The ITag to remove from the collection.

Return Value

Type: Boolean
true if the tag was successfully removed from the collection; otherwise, false

Implements

ICollectionTaggerTRemove(TagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
Remove Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Remove Method (TagVersionRange(T))

CollectionTaggerTRemove Method (TagVersionRangeT)
Removes the first occurrence of a specific tag range from the collection.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    TagVersionRange<T> tagRange
)
Public Function Remove (
    tagRange As TagVersionRange(Of T)
) As Boolean

Parameters

tagRange
Type: ActiproSoftware.Text.TaggingTagVersionRange T
The tag range to remove from the collection.

Return Value

Type: Boolean
true if the tag range was successfully removed from the collection; otherwise, false

Implements

ICollectionTRemove(T)
ICollectionTaggerTRemove(TagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
Remove Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).RemoveAll Method

CollectionTaggerTRemoveAll Method
Removes all objects that match the conditions defined by the specified predicate.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int RemoveAll(
    Predicate<TagVersionRange<T>> match
)
Public Function RemoveAll (
    match As Predicate(Of TagVersionRange(Of T))
) As Integer

Parameters

match
Type: SystemPredicate TagVersionRange T
The predicate that defines the conditions for removal.

Return Value

Type: Int32
The number of objects that were removed.

Implements

ICollectionTaggerTRemoveAll(PredicateTagVersionRangeT)
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Toggle Method

CollectionTaggerTToggle Method
Overload List
 | Name | Description
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Toggle Method (ITextSnapshotLine, T)

CollectionTaggerTToggle Method (ITextSnapshotLine, T)
Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Toggle(
    ITextSnapshotLine snapshotLine,
    T tag
)
Public Function Toggle (
    snapshotLine As ITextSnapshotLine,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotLine
Type: ActiproSoftware.TextITextSnapshotLine
The target ITextSnapshotLine.
tag
Type: T
The ITag to add, if no tag is already on the line.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.

Implements

ICollectionTaggerTToggle(ITextSnapshotLine, T)
See Also

Reference

CollectionTaggerT Class
Toggle Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).Toggle Method (TextSnapshotRange, T)

CollectionTaggerTToggle Method (TextSnapshotRange, T)
Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag).

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagVersionRange<T> Toggle(
    TextSnapshotRange snapshotRange,
    T tag
)
Public Function Toggle (
    snapshotRange As TextSnapshotRange,
    tag As T
) As TagVersionRange(Of T)

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The target TextSnapshotRange.
tag
Type: T
The ITag to add, if no tag is already in the text range.

Return Value

Type: TagVersionRange T
The TagVersionRangeT that was created, if a tag was added.

Implements

ICollectionTaggerTToggle(TextSnapshotRange, T)
See Also

Reference

CollectionTaggerT Class
Toggle Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T) Events

CollectionTaggerT Events

The CollectionTaggerT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed.
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CollectionTagger(T).CollectionChanged Event

CollectionTaggerTCollectionChanged Event
Occurs when the collection is changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

CollectionTaggerT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Class

CurrentStatementIndicatorTag Class
Represents an IIndicatorTag that renders a current statement marker over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CurrentStatementIndicatorTag : IndicatorClassificationTagBase
Public Class CurrentStatementIndicatorTag
    Inherits IndicatorClassificationTagBase

The CurrentStatementIndicatorTag type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentStatementIndicatorTag | Initializes a new instance of the CurrentStatementIndicatorTag class
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Overrides IndicatorTagBaseCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Constructor

CurrentStatementIndicatorTag Constructor
Initializes a new instance of the CurrentStatementIndicatorTag class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CurrentStatementIndicatorTag()
Public Sub New
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Properties

CurrentStatementIndicatorTag Properties

The CurrentStatementIndicatorTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag. (Overrides IndicatorClassificationTagBaseClassificationType.)
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag.ClassificationType Property

CurrentStatementIndicatorTagClassificationType Property
Gets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IClassificationType ClassificationType { get; }
Public Overrides ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag Methods

CurrentStatementIndicatorTag Methods

The CurrentStatementIndicatorTag type exposes the following members.

Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Overrides IndicatorTagBaseCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTag.CreateGlyph Method

CurrentStatementIndicatorTagCreateGlyph Method
Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override FrameworkElement CreateGlyph(
    IEditorViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public Overrides Function CreateGlyph (
    viewLine As IEditorViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
) As FrameworkElement

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The current ITextViewLine being examined.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: Windows.FoundationRect
The bounds in which the indicator will be rendered.

Return Value

Type: FrameworkElement
The FrameworkElement that should be used as a glyph in an editor's indicator margin.

Implements

IIndicatorTagCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

CurrentStatementIndicatorTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Class

CurrentStatementIndicatorTagger Class
Provides CurrentStatementIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBase CurrentStatementIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CurrentStatementIndicatorTagger : IndicatorClassificationTaggerBase<CurrentStatementIndicatorTag>
Public Class CurrentStatementIndicatorTagger
    Inherits IndicatorClassificationTaggerBase(Of CurrentStatementIndicatorTag)

The CurrentStatementIndicatorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentStatementIndicatorTagger | Initializes a new instance of the CurrentStatementIndicatorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Constructor

CurrentStatementIndicatorTagger Constructor
Initializes a new instance of the CurrentStatementIndicatorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CurrentStatementIndicatorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Properties

CurrentStatementIndicatorTagger Properties

The CurrentStatementIndicatorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Methods

CurrentStatementIndicatorTagger Methods

The CurrentStatementIndicatorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


CurrentStatementIndicatorTagger Events

CurrentStatementIndicatorTagger Events

The CurrentStatementIndicatorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

CurrentStatementIndicatorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Class

DelimiterHighlightTagger Class
Provides a view-based classification tagger that tags delimiter pairs or sets.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase IDelimiterHighlightTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger IDelimiterHighlightTag
ActiproSoftware.Text.Tagging.ImplementationDelimiterHighlightTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DelimiterHighlightTagger : CollectionTagger<IDelimiterHighlightTag>,
    IParser, IKeyedObject, IParseTarget
Public Class DelimiterHighlightTagger
    Inherits CollectionTagger(Of IDelimiterHighlightTag)
    Implements IParser, IKeyedObject, IParseTarget

The DelimiterHighlightTagger type exposes the following members.

Constructors
 | Name | Description
Public method | DelimiterHighlightTagger | Initializes a new instance of the DelimiterHighlightTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Constructor

DelimiterHighlightTagger Constructor
Initializes a new instance of the DelimiterHighlightTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DelimiterHighlightTagger(
    IEditorView view
)
Public Sub New (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The view to which this manager is attached.
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Properties

DelimiterHighlightTagger Properties

The DelimiterHighlightTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Methods

DelimiterHighlightTagger Methods

The DelimiterHighlightTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger.OnClosed Method

DelimiterHighlightTaggerOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
Remarks
Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


DelimiterHighlightTagger Events

DelimiterHighlightTagger Events

The DelimiterHighlightTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

DelimiterHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Class

IndicatorClassificationTagBase Class
Provides the abstract base class for an ITag that can be used to mark an indicator and classification over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class IndicatorClassificationTagBase : IndicatorTagBase,
    IClassificationTag, ITag
Public MustInherit Class IndicatorClassificationTagBase
    Inherits IndicatorTagBase
    Implements IClassificationTag, ITag

The IndicatorClassificationTagBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorClassificationTagBase | Initializes a new instance of the IndicatorClassificationTagBase class
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Inherited from IndicatorTagBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Constructor

IndicatorClassificationTagBase Constructor
Initializes a new instance of the IndicatorClassificationTagBase class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IndicatorClassificationTagBase()
Protected Sub New
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Properties

IndicatorClassificationTagBase Properties

The IndicatorClassificationTagBase type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI. (Inherited from IndicatorTagBase.)
Public property | Tag | Gets or sets the object that contains user-defined data about the object. (Inherited from IndicatorTagBase.)
Top
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase.ClassificationType Property

IndicatorClassificationTagBaseClassificationType Property
Gets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IClassificationType ClassificationType { get; }
Public MustOverride ReadOnly Property ClassificationType As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTagBase Methods

IndicatorClassificationTagBase Methods

The IndicatorClassificationTagBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin. (Inherited from IndicatorTagBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndicatorClassificationTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Class

IndicatorClassificationTaggerBaseTTag Class
Represents the abstract base class for providing IIndicatorTag and IClassificationTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase TTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger TTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBase TTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBaseTTag
ActiproSoftware.Text.Tagging.ImplementationBreakpointIndicatorTagger
ActiproSoftware.Text.Tagging.ImplementationCurrentStatementIndicatorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class IndicatorClassificationTaggerBase<TTag> : IndicatorTaggerBase<TTag>,
    ITagger<IClassificationTag>, IOrderable, IKeyedObject
where TTag : class, IIndicatorTag, IClassificationTag

Public MustInherit Class IndicatorClassificationTaggerBase(Of TTag As {Class, IIndicatorTag, IClassificationTag})
    Inherits IndicatorTaggerBase(Of TTag)
    Implements ITagger(Of IClassificationTag), IOrderable,
    IKeyedObject

Type Parameters

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.Text.Tagging.Implementation.IndicatorClassificationTaggerBase`1"]

The IndicatorClassificationTaggerBaseTTag type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorClassificationTaggerBaseTTag | Initializes a new instance of the IndicatorClassificationTaggerBase class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Constructor

IndicatorClassificationTaggerBaseTTag Constructor
Initializes a new instance of the IndicatorClassificationTaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IndicatorClassificationTaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Properties

IndicatorClassificationTaggerBaseTTag Properties

The IndicatorClassificationTaggerBaseTTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Methods

IndicatorClassificationTaggerBaseTTag Methods

The IndicatorClassificationTaggerBaseTTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event. (Inherited from IndicatorTaggerBaseTTag.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorClassificationTaggerBase(TTag) Events

IndicatorClassificationTaggerBaseTTag Events

The IndicatorClassificationTaggerBaseTTag generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorClassificationTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Class

IndicatorTagBase Class
Provides the abstract base class for an ITag that can be used to mark an indicator over a text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationIndicatorTagBase
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTagBase

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class IndicatorTagBase : IIndicatorTag,
    ITag
Public MustInherit Class IndicatorTagBase
    Implements IIndicatorTag, ITag

The IndicatorTagBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorTagBase | Initializes a new instance of the IndicatorTagBase class
Top
Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Constructor

IndicatorTagBase Constructor
Initializes a new instance of the IndicatorTagBase class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IndicatorTagBase()
Protected Sub New
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Properties

IndicatorTagBase Properties

The IndicatorTagBase type exposes the following members.

Properties
 | Name | Description
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Top
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.ContentProvider Property

IndicatorTagBaseContentProvider Property
Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IContentProvider ContentProvider { get; set; }
Public Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Implements

IIndicatorTagContentProvider
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.Tag Property

IndicatorTagBaseTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .

Implements

IIndicatorTagTag
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase Methods

IndicatorTagBase Methods

The IndicatorTagBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateGlyph | Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTagBase.CreateGlyph Method

IndicatorTagBaseCreateGlyph Method
Creates the FrameworkElement that should be used as a glyph in an editor's indicator margin.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract FrameworkElement CreateGlyph(
    IEditorViewLine viewLine,
    TagSnapshotRange<IIndicatorTag> tagRange,
    Rect bounds
)
Public MustOverride Function CreateGlyph (
    viewLine As IEditorViewLine,
    tagRange As TagSnapshotRange(Of IIndicatorTag),
    bounds As Rect
) As FrameworkElement

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The current ITextViewLine being examined.
tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange IIndicatorTag
The ITag and the range it covers.
bounds
Type: Windows.FoundationRect
The bounds in which the indicator will be rendered.

Return Value

Type: FrameworkElement
The FrameworkElement that should be used as a glyph in an editor's indicator margin.

Implements

IIndicatorTagCreateGlyph(IEditorViewLine, TagSnapshotRangeIIndicatorTag, Rect)
See Also

Reference

IndicatorTagBase Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Class

IndicatorTaggerBaseTTag Class
Represents the abstract base class for providing IIndicatorTag objects over text ranges.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase TTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger TTag
ActiproSoftware.Text.Tagging.ImplementationIndicatorTaggerBaseTTag
ActiproSoftware.Text.Tagging.ImplementationBookmarkIndicatorTagger
ActiproSoftware.Text.Tagging.ImplementationIndicatorClassificationTaggerBaseTTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class IndicatorTaggerBase<TTag> : CollectionTagger<TTag>,
    ITagger<IIndicatorTag>, IOrderable, IKeyedObject
where TTag : class, IIndicatorTag

Public MustInherit Class IndicatorTaggerBase(Of TTag As {Class, IIndicatorTag})
    Inherits CollectionTagger(Of TTag)
    Implements ITagger(Of IIndicatorTag), IOrderable,
    IKeyedObject

Type Parameters

TTag

[Missing <typeparam name="TTag"/> documentation for "T:ActiproSoftware.Text.Tagging.Implementation.IndicatorTaggerBase`1"]

The IndicatorTaggerBaseTTag type exposes the following members.

Constructors
 | Name | Description
Protected method | IndicatorTaggerBaseTTag | Initializes a new instance of the IndicatorTaggerBase class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Constructor

IndicatorTaggerBaseTTag Constructor
Initializes a new instance of the IndicatorTaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IndicatorTaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Properties

IndicatorTaggerBaseTTag Properties

The IndicatorTaggerBaseTTag generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Methods

IndicatorTaggerBaseTTag Methods

The IndicatorTaggerBaseTTag generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Inherited from TaggerBaseT.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag).RaiseTagsChanged Method

IndicatorTaggerBaseTTagRaiseTagsChanged Method
Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RaiseTagsChanged(
    TagsChangedEventArgs e
)
Public Sub RaiseTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


IndicatorTaggerBase(TTag) Events

IndicatorTaggerBaseTTag Events

The IndicatorTaggerBaseTTag generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

IndicatorTaggerBaseTTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Class

ParseErrorTagger Class
Provides an ITaggerT implementation that tags IParseError objects found in a document's parse data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ISquiggleTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger ISquiggleTag
ActiproSoftware.Text.Tagging.ImplementationParseErrorTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ParseErrorTagger : CollectionTagger<ISquiggleTag>
Public Class ParseErrorTagger
    Inherits CollectionTagger(Of ISquiggleTag)

The ParseErrorTagger type exposes the following members.

Constructors
 | Name | Description
Public method | ParseErrorTagger | Initializes a new instance of the ParseErrorTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Constructor

ParseErrorTagger Constructor
Initializes a new instance of the ParseErrorTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ParseErrorTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Properties

ParseErrorTagger Properties

The ParseErrorTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Methods

ParseErrorTagger Methods

The ParseErrorTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger.OnClosed Method

ParseErrorTaggerOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
Remarks
Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ParseErrorTagger Events

ParseErrorTagger Events

The ParseErrorTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ParseErrorTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Class

ReadOnlyRegionTag Class
Represents an ITag that can be used to mark a text range as read-only, and can optionally associate an IClassificationType.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationClassificationTag
ActiproSoftware.Text.Tagging.ImplementationReadOnlyRegionTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReadOnlyRegionTag : ClassificationTag,
    IReadOnlyRegionTag, ITag
Public Class ReadOnlyRegionTag
    Inherits ClassificationTag
    Implements IReadOnlyRegionTag, ITag

The ReadOnlyRegionTag type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyRegionTag | Initializes a new instance of the ReadOnlyRegionTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | IsReadOnly | Gets or sets whether the tagged text range is currently read-only.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Constructor

ReadOnlyRegionTag Constructor
Initializes a new instance of the ReadOnlyRegionTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyRegionTag()
Public Sub New
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Properties

ReadOnlyRegionTag Properties

The ReadOnlyRegionTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | IsReadOnly | Gets or sets whether the tagged text range is currently read-only.
Top
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag.IsReadOnly Property

ReadOnlyRegionTagIsReadOnly Property
Gets or sets whether the tagged text range is currently read-only.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tagged text range is currently read-only; otherwise, false.

Implements

IReadOnlyRegionTagIsReadOnly
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ReadOnlyRegionTag Methods

ReadOnlyRegionTag Methods

The ReadOnlyRegionTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

ReadOnlyRegionTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Class

SearchResultHighlightTagger Class
Provides a view-based classification tagger that tags search results.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase IClassificationTag
ActiproSoftware.Text.Tagging.ImplementationCollectionTagger IClassificationTag
ActiproSoftware.Text.Tagging.ImplementationSearchResultHighlightTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SearchResultHighlightTagger : CollectionTagger<IClassificationTag>
Public Class SearchResultHighlightTagger
    Inherits CollectionTagger(Of IClassificationTag)

The SearchResultHighlightTagger type exposes the following members.

Constructors
 | Name | Description
Public method | SearchResultHighlightTagger | Initializes a new instance of the SearchResultHighlightTagger class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Constructor

SearchResultHighlightTagger Constructor
Initializes a new instance of the SearchResultHighlightTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SearchResultHighlightTagger(
    IEditorView view
)
Public Sub New (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The view to which this manager is attached.
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Properties

SearchResultHighlightTagger Properties

The SearchResultHighlightTagger type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection. (Inherited from CollectionTaggerT.)
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Item | Gets the tag range that points to the specified tag. [C#] In C#, this property is the indexer for the CollectionTagger class. (Inherited from CollectionTaggerT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Methods

SearchResultHighlightTagger Methods

The SearchResultHighlightTagger type exposes the following members.

Methods
 | Name | Description
Public method | Add(TagVersionRangeT) | Adds a tag range to the collection. (Inherited from CollectionTaggerT.)
Public method | Add(ITextSnapshotLine, T) | Adds a tag range that is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Add(TextSnapshotRange, T) | Adds a tag range that is applied to a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | Clear | Removes all items from the collection. (Inherited from CollectionTaggerT.)
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Contains | Determines whether the collection contains a specific value. (Inherited from CollectionTaggerT.)
Public method | CopyTo | (Inherited from CollectionTaggerT.)
Public method | CreateBatch | Creates an IDisposable object such that while the object is not disposed, items can be added to this collection without any change events being fired, thereby allowing batch updates to occur. (Inherited from CollectionTaggerT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindNext(ITextSnapshotLine, ITagSearchOptionsT) | Finds the next line-based tag (e.g. a bookmark indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | FindNext(TextSnapshotOffset, ITagSearchOptionsT) | Finds the next text range-based tag (e.g. a breakpoint indicator tag), using the specified search options. (Inherited from CollectionTaggerT.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection. (Inherited from CollectionTaggerT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Inherited from CollectionTaggerT.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | Remove(T) | Removes a specific tag instance from the collection. (Inherited from CollectionTaggerT.)
Public method | Remove(TagVersionRangeT) | Removes the first occurrence of a specific tag range from the collection. (Inherited from CollectionTaggerT.)
Public method | RemoveAll | Removes all objects that match the conditions defined by the specified predicate. (Inherited from CollectionTaggerT.)
Public method | Toggle(ITextSnapshotLine, T) | Toggles whether a tag is associated with a single snapshot line (e.g. a bookmark indicator tag). (Inherited from CollectionTaggerT.)
Public method | Toggle(TextSnapshotRange, T) | Toggles whether a tag is associated with a snapshot text range (e.g. a breakpoint indicator tag). (Inherited from CollectionTaggerT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger.OnClosed Method

SearchResultHighlightTaggerOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
Remarks
Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SearchResultHighlightTagger Events

SearchResultHighlightTagger Events

The SearchResultHighlightTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | CollectionChanged | Occurs when the collection is changed. (Inherited from CollectionTaggerT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

SearchResultHighlightTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Class

SquiggleTag Class
Provides a basic ISquiggleTag implementation, generally used for error display, that can be associated with some text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationSquiggleTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SquiggleTag : ISquiggleTag,
    ITag
Public Class SquiggleTag
    Implements ISquiggleTag, ITag

The SquiggleTag type exposes the following members.

Constructors
 | Name | Description
Public method | SquiggleTag | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IContentProvider) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType, IContentProvider) | Initializes a new instance of the SquiggleTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor

SquiggleTag Constructor
Overload List
 | Name | Description
Public method | SquiggleTag | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IContentProvider) | Initializes a new instance of the SquiggleTag class.
Public method | SquiggleTag(IClassificationType, IContentProvider) | Initializes a new instance of the SquiggleTag class.
Top
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor

SquiggleTag Constructor
Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SquiggleTag()
Public Sub New
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor (IClassificationType)

SquiggleTag Constructor (IClassificationType)
Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SquiggleTag(
    IClassificationType classificationType
)
Public Sub New (
    classificationType As IClassificationType
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor (IContentProvider)

SquiggleTag Constructor (IContentProvider)
Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SquiggleTag(
    IContentProvider contentProvider
)
Public Sub New (
    contentProvider As IContentProvider
)

Parameters

contentProvider
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIContentProvider
The IContentProvider associated with the tag.
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Constructor (IClassificationType, IContentProvider)

SquiggleTag Constructor (IClassificationType, IContentProvider)
Initializes a new instance of the SquiggleTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SquiggleTag(
    IClassificationType classificationType,
    IContentProvider contentProvider
)
Public Sub New (
    classificationType As IClassificationType,
    contentProvider As IContentProvider
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
contentProvider
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IntelliPromptIContentProvider
The IContentProvider associated with the tag.
See Also

Reference

SquiggleTag Class
SquiggleTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Properties

SquiggleTag Properties

The SquiggleTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | ContentProvider | Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.
Top
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag.ClassificationType Property

SquiggleTagClassificationType Property
Gets or sets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

ISquiggleTagClassificationType
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag.ContentProvider Property

SquiggleTagContentProvider Property
Gets or sets the optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IContentProvider ContentProvider { get; set; }
Public Property ContentProvider As IContentProvider
    Get
    Set

Property Value

Type: IContentProvider
The optional IContentProvider used to provide content for IntelliPrompt quick info popups or other UI.

Implements

ISquiggleTagContentProvider
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


SquiggleTag Methods

SquiggleTag Methods

The SquiggleTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SquiggleTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Class

StyleRegistryClassificationTag Class
Provides a ClassificationTag implementation that uses an alternate IHighlightingStyleRegistry, and can be associated with some text range.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationClassificationTag
ActiproSoftware.Text.Tagging.ImplementationStyleRegistryClassificationTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StyleRegistryClassificationTag : ClassificationTag,
    IHighlightingStyleRegistryProvider
Public Class StyleRegistryClassificationTag
    Inherits ClassificationTag
    Implements IHighlightingStyleRegistryProvider

The StyleRegistryClassificationTag type exposes the following members.

Constructors
 | Name | Description
Public method | StyleRegistryClassificationTag | Initializes a new instance of the StyleRegistryClassificationTag class.
Public method | StyleRegistryClassificationTag(IClassificationType, IHighlightingStyleRegistry) | Initializes a new instance of the StyleRegistryClassificationTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry associated with this object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Constructor

StyleRegistryClassificationTag Constructor
Overload List
 | Name | Description
Public method | StyleRegistryClassificationTag | Initializes a new instance of the StyleRegistryClassificationTag class.
Public method | StyleRegistryClassificationTag(IClassificationType, IHighlightingStyleRegistry) | Initializes a new instance of the StyleRegistryClassificationTag class.
Top
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Constructor

StyleRegistryClassificationTag Constructor
Initializes a new instance of the StyleRegistryClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StyleRegistryClassificationTag()
Public Sub New
See Also

Reference

StyleRegistryClassificationTag Class
StyleRegistryClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Constructor (IClassificationType, IHighlightingStyleRegistry)

StyleRegistryClassificationTag Constructor (IClassificationType, IHighlightingStyleRegistry)
Initializes a new instance of the StyleRegistryClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StyleRegistryClassificationTag(
    IClassificationType classificationType,
    IHighlightingStyleRegistry highlightingStyleRegistry
)
Public Sub New (
    classificationType As IClassificationType,
    highlightingStyleRegistry As IHighlightingStyleRegistry
)

Parameters

classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
highlightingStyleRegistry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The custom IHighlightingStyleRegistry associated with this object.
See Also

Reference

StyleRegistryClassificationTag Class
StyleRegistryClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Properties

StyleRegistryClassificationTag Properties

The StyleRegistryClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag. (Inherited from ClassificationTag.)
Public property | HighlightingStyleRegistry | Gets or sets the custom IHighlightingStyleRegistry associated with this object.
Top
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag.HighlightingStyleRegistry Property

StyleRegistryClassificationTagHighlightingStyleRegistry Property
Gets or sets the custom IHighlightingStyleRegistry associated with this object.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Public Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The custom IHighlightingStyleRegistry associated with this object.

Implements

IHighlightingStyleRegistryProviderHighlightingStyleRegistry
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


StyleRegistryClassificationTag Methods

StyleRegistryClassificationTag Methods

The StyleRegistryClassificationTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Inherited from ClassificationTag.)
Top
See Also

Reference

StyleRegistryClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Class

TaggerBaseT Class
Provides an abstract base class for an ITaggerT implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBaseT
ActiproSoftware.Text.Tagging.ImplementationCollectionTaggerT
ActiproSoftware.Text.Tagging.ImplementationTokenTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TaggerBase<T> : ITagger<T>,
    IOrderable, IKeyedObject
where T : ITag

Public MustInherit Class TaggerBase(Of T As ITag)
    Implements ITagger(Of T), IOrderable, IKeyedObject

Type Parameters

T
The type of tag associated with this tagger.

The TaggerBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument) | Initializes a new instance of the TaggerBase class.
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument, Boolean) | Initializes a new instance of the TaggerBase class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached.
Public property | Key | Gets the string-based key that identifies the object.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger.
Public method | Close | Closes the manager and detaches it from the view.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view.
Protected method | OnTagsChanged | Raises the TagsChanged event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed.
Public event | TagsChanged | Occurs after a range of tags have changed.
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Constructor

TaggerBaseT Constructor
Overload List
 | Name | Description
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument) | Initializes a new instance of the TaggerBase class.
Protected method | TaggerBaseT(String, IEnumerableOrdering, ICodeDocument, Boolean) | Initializes a new instance of the TaggerBase class.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Constructor (String, IEnumerable(Ordering), ICodeDocument)

TaggerBaseT Constructor (String, IEnumerableOrdering, ICodeDocument)
Initializes a new instance of the TaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

TaggerBaseT Class
TaggerBaseT Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Constructor (String, IEnumerable(Ordering), ICodeDocument, Boolean)

TaggerBaseT Constructor (String, IEnumerableOrdering, ICodeDocument, Boolean)
Initializes a new instance of the TaggerBase class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TaggerBase(
    string key,
    IEnumerable<Ordering> orderings,
    ICodeDocument document,
    bool isForLanguage
)
Protected Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering),
    document As ICodeDocument,
    isForLanguage As Boolean
)

Parameters

key
Type: SystemString
The string-based key that identifies the object.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
isForLanguage
Type: SystemBoolean
Indicates whether this tagger is for a language. If true, the tagger is closed when the document's language changes.
See Also

Reference

TaggerBaseT Class
TaggerBaseT Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Properties

TaggerBaseT Properties

The TaggerBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached.
Public property | Key | Gets the string-based key that identifies the object.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Document Property

TaggerBaseTDocument Property
Gets the document to which this manager is attached.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICodeDocument Document { get; }
Public ReadOnly Property Document As ICodeDocument
    Get

Property Value

Type: ICodeDocument
The document to which this manager is attached.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Key Property

TaggerBaseTKey Property
Gets the string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key that identifies the object.

Implements

IKeyedObjectKey
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Orderings Property

TaggerBaseTOrderings Property
Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<Ordering> Orderings { get; }
Public ReadOnly Property Orderings As IEnumerable(Of Ordering)
    Get

Property Value

Type: IEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Implements

IOrderableOrderings
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Methods

TaggerBaseT Methods

The TaggerBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger.
Public method | Close | Closes the manager and detaches it from the view.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view.
Protected method | OnTagsChanged | Raises the TagsChanged event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).ChangeDocument Method

TaggerBaseTChangeDocument Method
Changes the document associated with the tagger.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void ChangeDocument(
    ICodeDocument newDocument
)
Protected Sub ChangeDocument (
    newDocument As ICodeDocument
)

Parameters

newDocument
Type: ActiproSoftware.TextICodeDocument
The new ICodeDocument.
Remarks
This method is used when a view-based tagger needs to update the associated document.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Close Method

TaggerBaseTClose Method
Closes the manager and detaches it from the view.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

ITaggerTClose
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).GetTags Method

TaggerBaseTGetTags Method
Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IEnumerable<TagSnapshotRange<T>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public MustOverride Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of T))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange T
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).OnClosed Method

TaggerBaseTOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnClosed()
Protected Overridable Sub OnClosed
Remarks
The default implementation of this method does nothing. Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).OnTagsChanged Method

TaggerBaseTOnTagsChanged Method
Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTagsChanged(
    TagsChangedEventArgs e
)
Protected Overridable Sub OnTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T) Events

TaggerBaseT Events

The TaggerBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed.
Public event | TagsChanged | Occurs after a range of tags have changed.
Top
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).Closed Event

TaggerBaseTClosed Event
Occurs after the tagger is closed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Closed
Public Event Closed As EventHandler

Value

Type: SystemEventHandler

Implements

ITaggerTClosed
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerBase(T).TagsChanged Event

TaggerBaseTTagsChanged Event
Occurs after a range of tags have changed.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TagsChangedEventArgs> TagsChanged
Public Event TagsChanged As EventHandler(Of TagsChangedEventArgs)

Value

Type: SystemEventHandler TagsChangedEventArgs

Implements

ITaggerTTagsChanged
See Also

Reference

TaggerBaseT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger) Class

TaggerProviderBaseTTagger Class
Provides an abstract tagger provider base class that automatically returns the TagTypes supported based on reflection of the TTagger type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBaseTTagger
More...

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TaggerProviderBase<TTagger>
where TTagger : class

Public MustInherit Class TaggerProviderBase(Of TTagger As Class)

Type Parameters

TTagger
The Type of ITaggerT that this factory creates.

The TaggerProviderBaseTTagger type exposes the following members.

Constructors
 | Name | Description
Protected method | TaggerProviderBaseTTagger | Initializes a new instance of the TaggerProviderBaseTTagger class
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBaseTTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTaggerProvider
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTaggerProvider
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTaggerProvider
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTaggerProvider
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTaggerProvider
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProviderTTagger
ActiproSoftware.Text.Tagging.ImplementationTextViewTaggerProviderTTagger


TaggerProviderBase(TTagger) Constructor

TaggerProviderBaseTTagger Constructor
Initializes a new instance of the TaggerProviderBaseTTagger class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TaggerProviderBase()
Protected Sub New
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger) Properties

TaggerProviderBaseTTagger Properties

The TaggerProviderBaseTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.
Top
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger).TagTypes Property

TaggerProviderBaseTTaggerTagTypes Property
Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<Type> TagTypes { get; }
Public ReadOnly Property TagTypes As IEnumerable(Of Type)
    Get

Property Value

Type: IEnumerable Type
The ITag Type objects that are supported by the ITaggerT objects created by this provider.
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TaggerProviderBase(TTagger) Methods

TaggerProviderBaseTTagger Methods

The TaggerProviderBaseTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TaggerProviderBaseTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Class

TagSearchOptionsT Class
Stores tag search operation options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTagSearchOptionsT

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TagSearchOptions<T> : ITagSearchOptions<T>
where T : ITag

Public Class TagSearchOptions(Of T As ITag)
    Implements ITagSearchOptions(Of T)

Type Parameters

T
The tag type.

The TagSearchOptionsT type exposes the following members.

Constructors
 | Name | Description
Public method | TagSearchOptionsT | Initializes a new instance of the TagSearchOptionsT class
Top
Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Constructor

TagSearchOptionsT Constructor
Initializes a new instance of the TagSearchOptionsT class

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TagSearchOptions()
Public Sub New
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Properties

TagSearchOptionsT Properties

The TagSearchOptionsT generic type exposes the following members.

Properties
 | Name | Description
Public property | CanWrap | Gets or sets whether the search can wrap at the end of the search text range.
Public property | Filter | Gets or sets the optional callback used to determine if a potential search result is valid.
Public property | SearchUp | Gets or sets whether to search backwards.
Top
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T).CanWrap Property

TagSearchOptionsTCanWrap Property
Gets or sets whether the search can wrap at the end of the search text range.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanWrap { get; set; }
Public Property CanWrap As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the search can wrap at the end of the search text range; otherwise, false.

Implements

ITagSearchOptionsTCanWrap
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T).Filter Property

TagSearchOptionsTFilter Property
Gets or sets the optional callback used to determine if a potential search result is valid.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Predicate<TagVersionRange<T>> Filter { get; set; }
Public Property Filter As Predicate(Of TagVersionRange(Of T))
    Get
    Set

Property Value

Type: Predicate TagVersionRange T
The optional callback used to determine if a potential search result is valid.

Implements

ITagSearchOptionsTFilter
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T).SearchUp Property

TagSearchOptionsTSearchUp Property
Gets or sets whether to search backwards.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SearchUp { get; set; }
Public Property SearchUp As Boolean
    Get
    Set

Property Value

Type: Boolean
true if searches should be performed backwards; otherwise, false.

Implements

ITagSearchOptionsTSearchUp
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TagSearchOptions(T) Methods

TagSearchOptionsT Methods

The TagSearchOptionsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TagSearchOptionsT Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Class

TextViewTaggerProviderTTagger Class
Provides an ITextViewTaggerProvider capable of creating ITaggerT objects which have a constructor that accepts a single ITextView instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase TTagger
ActiproSoftware.Text.Tagging.ImplementationTextViewTaggerProviderTTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextViewTaggerProvider<TTagger> : TaggerProviderBase<TTagger>,
    ITextViewTaggerProvider
where TTagger : class

Public Class TextViewTaggerProvider(Of TTagger As Class)
    Inherits TaggerProviderBase(Of TTagger)
    Implements ITextViewTaggerProvider

Type Parameters

TTagger
The Type of ITaggerT that this provider creates. The tagger type must have a constructor that accepts a single ITextView instance parameter.

The TextViewTaggerProviderTTagger type exposes the following members.

Constructors
 | Name | Description
Public method | TextViewTaggerProviderTTagger | Initializes a new instance of the TextViewTaggerProvider class.
Public method | TextViewTaggerProviderTTagger(Object) | Initializes a new instance of the TextViewTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Constructor

TextViewTaggerProviderTTagger Constructor
Overload List
 | Name | Description
Public method | TextViewTaggerProviderTTagger | Initializes a new instance of the TextViewTaggerProvider class.
Public method | TextViewTaggerProviderTTagger(Object) | Initializes a new instance of the TextViewTaggerProvider class.
Top
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Constructor

TextViewTaggerProviderTTagger Constructor
Initializes a new instance of the TextViewTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextViewTaggerProvider()
Public Sub New
See Also

Reference

TextViewTaggerProviderTTagger Class
TextViewTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Constructor (Object)

TextViewTaggerProviderTTagger Constructor (Object)
Initializes a new instance of the TextViewTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextViewTaggerProvider(
    Object singletonKey
)
Public Sub New (
    singletonKey As Object
)

Parameters

singletonKey
Type: SystemObject
When a non-null value is passed, the tagger will be stored as a singleton under the specified key in the views's properties.
See Also

Reference

TextViewTaggerProviderTTagger Class
TextViewTaggerProviderTTagger Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Properties

TextViewTaggerProviderTTagger Properties

The TextViewTaggerProviderTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger) Methods

TextViewTaggerProviderTTagger Methods

The TextViewTaggerProviderTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns an ITaggerT for the specified ITextView.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TextViewTaggerProvider(TTagger).GetTagger(T) Method

TextViewTaggerProviderTTaggerGetTaggerT Method
Returns an ITaggerT for the specified ITextView.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITagger<T> GetTagger<T>(
    ITextView view
)
where T : ITag

Public Function GetTagger(Of T As ITag) (
    view As ITextView
) As ITagger(Of T)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that requires an ITaggerT.

Type Parameters

T
The type of ITag created by the tagger.

Return Value

Type: ITagger T
An ITaggerT for the specified ITextView.

Implements

ITextViewTaggerProviderGetTaggerT(ITextView)
See Also

Reference

TextViewTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Class

TokenClassificationTag Class
Represents an ITag that can be used to associate an IClassificationType and an IToken with some text range by implementing IClassificationTag and ITokenTag.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTokenClassificationTag

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TokenClassificationTag : IClassificationTag,
    ITag, ITokenTag
Public Class TokenClassificationTag
    Implements IClassificationTag, ITag, ITokenTag

The TokenClassificationTag type exposes the following members.

Constructors
 | Name | Description
Public method | TokenClassificationTag | Initializes a new instance of the TokenClassificationTag class.
Public method | TokenClassificationTag(IToken, IClassificationType) | Initializes a new instance of the TokenClassificationTag class.
Top
Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | Token | Gets or sets the lexer IToken associated with this tag.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Constructor

TokenClassificationTag Constructor
Overload List
 | Name | Description
Public method | TokenClassificationTag | Initializes a new instance of the TokenClassificationTag class.
Public method | TokenClassificationTag(IToken, IClassificationType) | Initializes a new instance of the TokenClassificationTag class.
Top
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Constructor

TokenClassificationTag Constructor
Initializes a new instance of the TokenClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TokenClassificationTag()
Public Sub New
See Also

Reference

TokenClassificationTag Class
TokenClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Constructor (IToken, IClassificationType)

TokenClassificationTag Constructor (IToken, IClassificationType)
Initializes a new instance of the TokenClassificationTag class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TokenClassificationTag(
    IToken token,
    IClassificationType classificationType
)
Public Sub New (
    token As IToken,
    classificationType As IClassificationType
)

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The lexer IToken associated with this tag.
classificationType
Type: ActiproSoftware.TextIClassificationType
The IClassificationType associated with the tag.
See Also

Reference

TokenClassificationTag Class
TokenClassificationTag Overload
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Properties

TokenClassificationTag Properties

The TokenClassificationTag type exposes the following members.

Properties
 | Name | Description
Public property | ClassificationType | Gets or sets the IClassificationType associated with the tag.
Public property | Token | Gets or sets the lexer IToken associated with this tag.
Top
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag.ClassificationType Property

TokenClassificationTagClassificationType Property
Gets or sets the IClassificationType associated with the tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType ClassificationType { get; set; }
Public Property ClassificationType As IClassificationType
    Get
    Set

Property Value

Type: IClassificationType
The IClassificationType associated with the tag.

Implements

IClassificationTagClassificationType
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag.Token Property

TokenClassificationTagToken Property
Gets or sets the lexer IToken associated with this tag.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IToken Token { get; set; }
Public Property Token As IToken
    Get
    Set

Property Value

Type: IToken
The lexer IToken associated with this tag.

Implements

ITokenTagToken
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag Methods

TokenClassificationTag Methods

The TokenClassificationTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenClassificationTag.ToString Method

TokenClassificationTagToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TokenClassificationTag Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Class

TokenTagger Class
An ITaggerT implementation that provides ITokenTag and IClassificationTag objects based on a language's ILexer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerBase ITokenTag
ActiproSoftware.Text.Tagging.ImplementationTokenTagger
ActiproSoftware.Text.Languages.CSharp.ImplementationCSharpTokenTagger
ActiproSoftware.Text.Languages.JavaScript.ImplementationJavaScriptTokenTagger
ActiproSoftware.Text.Languages.Python.ImplementationPythonTokenTagger
ActiproSoftware.Text.Languages.VB.ImplementationVBTokenTagger
ActiproSoftware.Text.Languages.Xml.ImplementationXmlTokenTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TokenTagger : TaggerBase<ITokenTag>,
    ITagger<IClassificationTag>, IOrderable, IKeyedObject
Public Class TokenTagger
    Inherits TaggerBase(Of ITokenTag)
    Implements ITagger(Of IClassificationTag), IOrderable,
    IKeyedObject

The TokenTagger type exposes the following members.

Constructors
 | Name | Description
Public method | TokenTagger | Initializes a new instance of the TokenTagger class.
Top
Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate.
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Constructor

TokenTagger Constructor
Initializes a new instance of the TokenTagger class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TokenTagger(
    ICodeDocument document
)
Public Sub New (
    document As ICodeDocument
)

Parameters

document
Type: ActiproSoftware.TextICodeDocument
The document to which this manager is attached.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Properties

TokenTagger Properties

The TokenTagger type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document to which this manager is attached. (Inherited from TaggerBaseT.)
Public property | Key | Gets the string-based key that identifies the object. (Inherited from TaggerBaseT.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects. (Inherited from TaggerBaseT.)
Top
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Methods

TokenTagger Methods

The TokenTagger type exposes the following members.

Methods
 | Name | Description
Protected method | ChangeDocument | Changes the document associated with the tagger. (Inherited from TaggerBaseT.)
Public method | ClassifyToken | Returns an IClassificationType for the specified IToken, if one is appropriate.
Public method | Close | Closes the manager and detaches it from the view. (Inherited from TaggerBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTags | Returns the tag ranges that intersect with the specified normalized snapshot ranges. (Overrides TaggerBaseTGetTags(NormalizedTextSnapshotRangeCollection, Object).)
Protected method | GetTokens | Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides TaggerBaseTOnClosed.)
Protected method | OnTagsChanged | Raises the TagsChanged event. (Inherited from TaggerBaseT.)
Public method | RaiseTagsChanged | Raises the TagsChanged event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.ClassifyToken Method

TokenTaggerClassifyToken Method
Returns an IClassificationType for the specified IToken, if one is appropriate.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IClassificationType ClassifyToken(
    IToken token
)
Public Overridable Function ClassifyToken (
    token As IToken
) As IClassificationType

Parameters

token
Type: ActiproSoftware.Text.LexingIToken
The IToken to examine.

Return Value

Type: IClassificationType
An IClassificationType for the specified IToken, if one is appropriate.
Remarks
The default implementation of this method automatically returns the classification type if the token is an IMergableToken.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.GetTags Method

TokenTaggerGetTags Method
Returns the tag ranges that intersect with the specified normalized snapshot ranges.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<TagSnapshotRange<ITokenTag>> GetTags(
    NormalizedTextSnapshotRangeCollection snapshotRanges,
    Object parameter
)
Public Overrides Function GetTags (
    snapshotRanges As NormalizedTextSnapshotRangeCollection,
    parameter As Object
) As IEnumerable(Of TagSnapshotRange(Of ITokenTag))

Parameters

snapshotRanges
Type: ActiproSoftware.TextNormalizedTextSnapshotRangeCollection
The collection of normalized snapshot ranges.
parameter
Type: SystemObject
An optional parameter that provides contextual information about the tag request.

Return Value

Type: IEnumerable TagSnapshotRange ITokenTag
The tag ranges that intersect with the specified normalized snapshot ranges.

Implements

ITaggerTGetTags(NormalizedTextSnapshotRangeCollection, Object)
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.GetTokens Method

TokenTaggerGetTokens Method
Returns the ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ITokenSet GetTokens(
    ILexer lexer,
    TextSnapshotRange desiredSnapshotRange,
    Object parseContext,
    bool canUpdateLineContexts,
    out int invalidateThroughOffset
)
Protected Function GetTokens (
    lexer As ILexer,
    desiredSnapshotRange As TextSnapshotRange,
    parseContext As Object,
    canUpdateLineContexts As Boolean,
    <OutAttribute> ByRef invalidateThroughOffset As Integer
) As ITokenSet

Parameters

lexer
Type: ActiproSoftware.Text.LexingILexer
The ILexer to use for token generation.
desiredSnapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange that should be examined.
parseContext
Type: SystemObject
An optional object that may be used to help provide context information when resuming incremental parsing.
canUpdateLineContexts
Type: SystemBoolean
Whether line contexts can be updated.
invalidateThroughOffset
Type: SystemInt32
Returns the offset through which tokens were invalidated.

Return Value

Type: ITokenSet
The ITokenSet containing the tokens that were parsed for the specified TextSnapshotRange.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.OnClosed Method

TokenTaggerOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
Remarks
Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger.RaiseTagsChanged Method

TokenTaggerRaiseTagsChanged Method
Raises the TagsChanged event.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RaiseTagsChanged(
    TagsChangedEventArgs e
)
Public Sub RaiseTagsChanged (
    e As TagsChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.Text.TaggingTagsChangedEventArgs
A TagsChangedEventArgs that contains the event data.
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTagger Events

TokenTagger Events

The TokenTagger type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs after the tagger is closed. (Inherited from TaggerBaseT.)
Public event | TagsChanged | Occurs after a range of tags have changed. (Inherited from TaggerBaseT.)
Top
See Also

Reference

TokenTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Class

TokenTaggerProviderTTagger Class
Provides an ICodeDocumentTaggerProvider capable of creating TokenTagger objects which have a constructor that accepts a single ICodeDocument instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.Tagging.ImplementationTaggerProviderBase TTagger
ActiproSoftware.Text.Tagging.ImplementationCodeDocumentTaggerProvider TTagger
ActiproSoftware.Text.Tagging.ImplementationTokenTaggerProviderTTagger

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TokenTaggerProvider<TTagger> : CodeDocumentTaggerProvider<TTagger>
where TTagger : class, Object, ITagger<ITokenTag>

Public Class TokenTaggerProvider(Of TTagger As {Class, Object, ITagger(Of ITokenTag)})
    Inherits CodeDocumentTaggerProvider(Of TTagger)

Type Parameters

TTagger
The Type of ITaggerT that this factory creates. The tagger type must have a constructor that accepts a single ICodeDocument instance parameter.

The TokenTaggerProviderTTagger type exposes the following members.

Constructors
 | Name | Description
Public method | TokenTaggerProviderTTagger | Initializes a new instance of the TokenTaggerProvider class.
Top
Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument. (Inherited from CodeDocumentTaggerProviderTTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Constructor

TokenTaggerProviderTTagger Constructor
Initializes a new instance of the TokenTaggerProvider class.

Namespace: ActiproSoftware.Text.Tagging.Implementation
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TokenTaggerProvider()
Public Sub New
See Also

Reference

TokenTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Properties

TokenTaggerProviderTTagger Properties

The TokenTaggerProviderTTagger generic type exposes the following members.

Properties
 | Name | Description
Public property | TagTypes | Gets the ITag Type objects that are supported by the ITaggerT objects created by this provider. (Inherited from TaggerProviderBaseTTagger.)
Top
See Also

Reference

TokenTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


TokenTaggerProvider(TTagger) Methods

TokenTaggerProviderTTagger Methods

The TokenTaggerProviderTTagger generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTaggerT | Returns an ITaggerT for the specified ICodeDocument. (Inherited from CodeDocumentTaggerProviderTTagger.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TokenTaggerProviderTTagger Class
ActiproSoftware.Text.Tagging.Implementation Namespace


ActiproSoftware.Text.Undo Namespace

ActiproSoftware.Text.Undo Namespace
Contains types related to managing the undo/redo stacks of text documents.
Classes
 | Class | Description
Public class | ObservableUndoableTextChangeStack | Provides wrapper for an IUndoableTextChangeStack that implements IObservableVectorT, allowing it to be used as an items source in UI controls.
Public class | SavePointChangeType | Specifies the type of changes that have been made to a character range since the last save point.
Public class | UndoRedoRequestEventArgs | Event arguments for when an undo or redo operation is requesting to be applied to an ITextDocument.
Interfaces
 | Interface | Description
Public interface | IUndoableTextChange | Provides the base requirements for a single undoable text change unit.
Public interface | IUndoableTextChangeStack | Provides the base requirements for a simple last-in-first-out collection of IUndoableTextChange objects.
Public interface | IUndoHistory | Provides the base requirements for an object that tracks undo and redo history for a document and allows re-application of those text changes.


IUndoableTextChange Interface

IUndoableTextChange Interface
Provides the base requirements for a single undoable text change unit.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IUndoableTextChange
Public Interface IUndoableTextChange

The IUndoableTextChange type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | Description | Gets the description of the contents of the text change, usually displayed in the user interface.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | SelectionPositionRange | Gets the TextPositionRange that specifies the range of text that was selected before the text change occurred.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
Remarks
This interface only stores the necessary information to reconstruct an ITextChange for undo/redo purposes.
See Also

Reference

ActiproSoftware.Text.Undo Namespace


IUndoableTextChange Properties

IUndoableTextChange Properties

The IUndoableTextChange type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Gets custom data that can be persisted with the text change and restored when undo operations occur later on.
Public property | Description | Gets the description of the contents of the text change, usually displayed in the user interface.
Public property | IsMerged | Gets whether this text change is the result of a merge of two or more text changes.
Public property | Operations | Gets the read-only list of ITextChangeOperation objects that make up this text change.
Public property | RetainSelection | Gets whether to prevent the caret from moving to the end of the text change in the active view.
Public property | SelectionPositionRange | Gets the TextPositionRange that specifies the range of text that was selected before the text change occurred.
Public property | Type | Gets an ITextChangeType indicating the type of change that was made.
Top
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.CustomData Property

IUndoableTextChangeCustomData Property
Gets custom data that can be persisted with the text change and restored when undo operations occur later on.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object CustomData { get; }
ReadOnly Property CustomData As Object
    Get

Property Value

Type: Object
The custom data.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.Description Property

IUndoableTextChangeDescription Property
Gets the description of the contents of the text change, usually displayed in the user interface.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the contents of the text change, usually displayed in the user interface.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.IsMerged Property

IUndoableTextChangeIsMerged Property
Gets whether this text change is the result of a merge of two or more text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsMerged { get; }
ReadOnly Property IsMerged As Boolean
    Get

Property Value

Type: Boolean
true if this text change is the result of a merge of two or more text changes; otherwise, false.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.Operations Property

IUndoableTextChangeOperations Property
Gets the read-only list of ITextChangeOperation objects that make up this text change.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<ITextChangeOperation> Operations { get; }
ReadOnly Property Operations As IList(Of ITextChangeOperation)
    Get

Property Value

Type: IList ITextChangeOperation
The read-only list of ITextChangeOperation objects that make up this text change.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.RetainSelection Property

IUndoableTextChangeRetainSelection Property
Gets whether to prevent the caret from moving to the end of the text change in the active view.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RetainSelection { get; }
ReadOnly Property RetainSelection As Boolean
    Get

Property Value

Type: Boolean
true if the caret move should be prevented; otherwise, false.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.SelectionPositionRange Property

IUndoableTextChangeSelectionPositionRange Property
Gets the TextPositionRange that specifies the range of text that was selected before the text change occurred.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange SelectionPositionRange { get; }
ReadOnly Property SelectionPositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The TextPositionRange that specifies the range of text that was selected before the text change occurred.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChange.Type Property

IUndoableTextChangeType Property
Gets an ITextChangeType indicating the type of change that was made.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextChangeType Type { get; }
ReadOnly Property Type As ITextChangeType
    Get

Property Value

Type: ITextChangeType
An ITextChangeType indicating the type of change that was made.
See Also

Reference

IUndoableTextChange Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Interface

IUndoableTextChangeStack Interface
Provides the base requirements for a simple last-in-first-out collection of IUndoableTextChange objects.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IUndoableTextChangeStack : IEnumerable<IUndoableTextChange>,
    IEnumerable
Public Interface IUndoableTextChangeStack
    Inherits IEnumerable(Of IUndoableTextChange), IEnumerable

The IUndoableTextChangeStack type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
Methods
 | Name | Description
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | (Inherited from IEnumerable IUndoableTextChange .)
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Top
Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Properties

IUndoableTextChangeStack Properties

The IUndoableTextChangeStack type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.Capacity Property

IUndoableTextChangeStackCapacity Property
Gets or sets the capacity of the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Capacity { get; set; }
Property Capacity As Integer
    Get
    Set

Property Value

Type: Int32
The capacity of the stack.
Remarks
If a new text change added to the stack causes the stack to exceed its capacity, the text changes at the bottom of the stack are removed until the stack no longer exceeds its capacity.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.Count Property

IUndoableTextChangeStackCount Property
Gets the count of text changes on the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of text changes on the stack.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.IsAtSavePoint Property

IUndoableTextChangeStackIsAtSavePoint Property
Gets whether the last text change on the stack is a save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsAtSavePoint { get; }
ReadOnly Property IsAtSavePoint As Boolean
    Get

Property Value

Type: Boolean
true if the last text change on the stack is a save point; otherwise, false.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Methods

IUndoableTextChangeStack Methods

The IUndoableTextChangeStack type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | GetEnumerator | (Inherited from IEnumerable IUndoableTextChange .)
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Top
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.CopyTo Method

IUndoableTextChangeStackCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CopyTo(
    IUndoableTextChange[] array,
    int arrayIndex
)
Sub CopyTo (
    array As IUndoableTextChange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The one-dimensional IUndoableTextChange array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.GetTextChange Method

IUndoableTextChangeStackGetTextChange Method
Gets the IUndoableTextChange that the specified location in the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IUndoableTextChange GetTextChange(
    int index
)
Function GetTextChange (
    index As Integer
) As IUndoableTextChange

Parameters

index
Type: SystemInt32
The index of the text change to check.

Return Value

Type: IUndoableTextChange
The IUndoableTextChange that the specified location in the stack.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.IndexOf Method

IUndoableTextChangeStackIndexOf Method
Returns the index of the IUndoableTextChange in the list.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndexOf(
    IUndoableTextChange textChange
)
Function IndexOf (
    textChange As IUndoableTextChange
) As Integer

Parameters

textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange to look for in the list.

Return Value

Type: Int32
The index of the IUndoableTextChange in the list, or -1 if not found.
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack Events

IUndoableTextChangeStack Events

The IUndoableTextChangeStack type exposes the following members.

Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Top
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.CapacityChanged Event

IUndoableTextChangeStackCapacityChanged Event
Occurs when the capacity of the stack is changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler CapacityChanged
Event CapacityChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoableTextChangeStack.StackChanged Event

IUndoableTextChangeStackStackChanged Event
Occurs when the contents of the stack are changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler StackChanged
Event StackChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IUndoableTextChangeStack Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory Interface

IUndoHistory Interface
Provides the base requirements for an object that tracks undo and redo history for a document and allows re-application of those text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IUndoHistory
Public Interface IUndoHistory

The IUndoHistory type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo | Gets whether at least one redo text change is available to execute.
Public property | CanUndo | Gets whether at least one undo text change is available to execute.
Public property | RedoStack | Gets the IUndoableTextChangeStack containing the redo stack.
Public property | UndoStack | Gets the IUndoableTextChangeStack containing the undo stack.
Top
Methods
 | Name | Description
Public method | Clear | Clears the undo and redo stacks, without resetting change tracking.
Public method | Clear(Boolean) | Clears the undo and redo stacks.
Public method | GetChangeTypeForLineRange | Gets the SavePointChangeType for the specified line range.
Public method | Redo | Performs the top redo text change.
Public method | Redo(Int32) | Performs the specified number of redo text changes.
Public method | Undo | Performs the top undo text change.
Public method | Undo(Int32) | Performs the specified number of undo text changes.
Top
Events
 | Name | Description
Public event | Cleared | Occurs when the undo history is programmatically cleared.
Public event | UndoRedoRequested | Occurs when an undo or redo operation is requested.
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


IUndoHistory Properties

IUndoHistory Properties

The IUndoHistory type exposes the following members.

Properties
 | Name | Description
Public property | CanRedo | Gets whether at least one redo text change is available to execute.
Public property | CanUndo | Gets whether at least one undo text change is available to execute.
Public property | RedoStack | Gets the IUndoableTextChangeStack containing the redo stack.
Public property | UndoStack | Gets the IUndoableTextChangeStack containing the undo stack.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.CanRedo Property

IUndoHistoryCanRedo Property
Gets whether at least one redo text change is available to execute.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanRedo { get; }
ReadOnly Property CanRedo As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one redo text change is available to execute; otherwise, false.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.CanUndo Property

IUndoHistoryCanUndo Property
Gets whether at least one undo text change is available to execute.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanUndo { get; }
ReadOnly Property CanUndo As Boolean
    Get

Property Value

Type: Boolean
true if there is at least one undo text change is available to execute; otherwise, false.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.RedoStack Property

IUndoHistoryRedoStack Property
Gets the IUndoableTextChangeStack containing the redo stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IUndoableTextChangeStack RedoStack { get; }
ReadOnly Property RedoStack As IUndoableTextChangeStack
    Get

Property Value

Type: IUndoableTextChangeStack
The IUndoableTextChangeStack containing the redo stack.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.UndoStack Property

IUndoHistoryUndoStack Property
Gets the IUndoableTextChangeStack containing the undo stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IUndoableTextChangeStack UndoStack { get; }
ReadOnly Property UndoStack As IUndoableTextChangeStack
    Get

Property Value

Type: IUndoableTextChangeStack
The IUndoableTextChangeStack containing the undo stack.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory Methods

IUndoHistory Methods

The IUndoHistory type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the undo and redo stacks, without resetting change tracking.
Public method | Clear(Boolean) | Clears the undo and redo stacks.
Public method | GetChangeTypeForLineRange | Gets the SavePointChangeType for the specified line range.
Public method | Redo | Performs the top redo text change.
Public method | Redo(Int32) | Performs the specified number of redo text changes.
Public method | Undo | Performs the top undo text change.
Public method | Undo(Int32) | Performs the specified number of undo text changes.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Clear Method

IUndoHistoryClear Method
Overload List
 | Name | Description
Public method | Clear | Clears the undo and redo stacks, without resetting change tracking.
Public method | Clear(Boolean) | Clears the undo and redo stacks.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Clear Method

IUndoHistoryClear Method
Clears the undo and redo stacks, without resetting change tracking.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

IUndoHistory Interface
Clear Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Clear Method (Boolean)

IUndoHistoryClear Method (Boolean)
Clears the undo and redo stacks.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Clear(
    bool resetChangeTracking
)
Sub Clear (
    resetChangeTracking As Boolean
)

Parameters

resetChangeTracking
Type: SystemBoolean
Whether to also reset all change tracking.
See Also

Reference

IUndoHistory Interface
Clear Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.GetChangeTypeForLineRange Method

IUndoHistoryGetChangeTypeForLineRange Method
Gets the SavePointChangeType for the specified line range.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SavePointChangeType GetChangeTypeForLineRange(
    int startLineIndex,
    int endLineIndex
)
Function GetChangeTypeForLineRange (
    startLineIndex As Integer,
    endLineIndex As Integer
) As SavePointChangeType

Parameters

startLineIndex
Type: SystemInt32
The start index of the line range to examine.
endLineIndex
Type: SystemInt32
The end index of the line range to examine.

Return Value

Type: SavePointChangeType
The SavePointChangeType for the specified line range.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Redo Method

IUndoHistoryRedo Method
Overload List
 | Name | Description
Public method | Redo | Performs the top redo text change.
Public method | Redo(Int32) | Performs the specified number of redo text changes.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Redo Method

IUndoHistoryRedo Method
Performs the top redo text change.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Redo()
Function Redo As Boolean

Return Value

Type: Boolean
true if redo text change occurred successfully; otherwise, false.
See Also

Reference

IUndoHistory Interface
Redo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Redo Method (Int32)

IUndoHistoryRedo Method (Int32)
Performs the specified number of redo text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Redo(
    int count
)
Function Redo (
    count As Integer
) As Integer

Parameters

count
Type: SystemInt32
The number of redo text changes to perform.

Return Value

Type: Int32
The number of redo text changes that were performed.
See Also

Reference

IUndoHistory Interface
Redo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Undo Method

IUndoHistoryUndo Method
Overload List
 | Name | Description
Public method | Undo | Performs the top undo text change.
Public method | Undo(Int32) | Performs the specified number of undo text changes.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Undo Method

IUndoHistoryUndo Method
Performs the top undo text change.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Undo()
Function Undo As Boolean

Return Value

Type: Boolean
true if undo text change occurred successfully; otherwise, false.
See Also

Reference

IUndoHistory Interface
Undo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Undo Method (Int32)

IUndoHistoryUndo Method (Int32)
Performs the specified number of undo text changes.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Undo(
    int count
)
Function Undo (
    count As Integer
) As Integer

Parameters

count
Type: SystemInt32
The number of undo text changes to perform.

Return Value

Type: Int32
The number of undo text changes that were performed.
See Also

Reference

IUndoHistory Interface
Undo Overload
ActiproSoftware.Text.Undo Namespace


IUndoHistory Events

IUndoHistory Events

The IUndoHistory type exposes the following members.

Events
 | Name | Description
Public event | Cleared | Occurs when the undo history is programmatically cleared.
Public event | UndoRedoRequested | Occurs when an undo or redo operation is requested.
Top
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.Cleared Event

IUndoHistoryCleared Event
Occurs when the undo history is programmatically cleared.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Cleared
Event Cleared As EventHandler

Value

Type: SystemEventHandler
Remarks
This event is raised when the Clear method is called.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


IUndoHistory.UndoRedoRequested Event

IUndoHistoryUndoRedoRequested Event
Occurs when an undo or redo operation is requested.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<UndoRedoRequestEventArgs> UndoRedoRequested
Event UndoRedoRequested As EventHandler(Of UndoRedoRequestEventArgs)

Value

Type: SystemEventHandler UndoRedoRequestEventArgs
Remarks
This event is raised when the Undo or Redo method is called.
See Also

Reference

IUndoHistory Interface
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Class

ObservableUndoableTextChangeStack Class
Provides wrapper for an IUndoableTextChangeStack that implements IObservableVectorT, allowing it to be used as an items source in UI controls.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.UndoObservableUndoableTextChangeStack

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ObservableUndoableTextChangeStack : DisposableObject,
    IObservableVector<Object>, IList<Object>, ICollection<Object>,
    IEnumerable<Object>, IEnumerable, IUndoableTextChangeStack, IEnumerable<IUndoableTextChange>
Public Class ObservableUndoableTextChangeStack
    Inherits DisposableObject
    Implements IObservableVector(Of Object), IList(Of Object),
    ICollection(Of Object), IEnumerable(Of Object), IEnumerable,
    IUndoableTextChangeStack, IEnumerable(Of IUndoableTextChange)

The ObservableUndoableTextChangeStack type exposes the following members.

Constructors
 | Name | Description
Public method | ObservableUndoableTextChangeStack | Initializes a new instance of the ObservableUndoableTextChangeStack class.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
Methods
 | Name | Description
Public method | Contains | Returns whether the collection contains the specified IUndoableTextChange.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Public event | VectorChanged | Occurs when the collection is changed.
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Constructor

ObservableUndoableTextChangeStack Constructor
Initializes a new instance of the ObservableUndoableTextChangeStack class.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableUndoableTextChangeStack(
    IUndoableTextChangeStack stack
)
Public Sub New (
    stack As IUndoableTextChangeStack
)

Parameters

stack
Type: ActiproSoftware.Text.UndoIUndoableTextChangeStack
The IUndoableTextChangeStack to wrap.
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Properties

ObservableUndoableTextChangeStack Properties

The ObservableUndoableTextChangeStack type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the stack.
Public property | Count | Gets the count of text changes on the stack.
Public property | IsAtSavePoint | Gets whether the last text change on the stack is a save point.
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Capacity Property

ObservableUndoableTextChangeStackCapacity Property
Gets or sets the capacity of the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Capacity { get; set; }
Public Property Capacity As Integer
    Get
    Set

Property Value

Type: Int32
The capacity of the stack.

Implements

IUndoableTextChangeStackCapacity
Remarks
If a new text change added to the stack causes the stack to exceed its capacity, the text changes at the bottom of the stack are removed until the stack no longer exceeds its capacity.
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Count Property

ObservableUndoableTextChangeStackCount Property
Gets the count of text changes on the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of text changes on the stack.

Implements

ICollectionTCount
IUndoableTextChangeStackCount
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.IsAtSavePoint Property

ObservableUndoableTextChangeStackIsAtSavePoint Property
Gets whether the last text change on the stack is a save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAtSavePoint { get; }
Public ReadOnly Property IsAtSavePoint As Boolean
    Get

Property Value

Type: Boolean
true if the last text change on the stack is a save point; otherwise, false.

Implements

IUndoableTextChangeStackIsAtSavePoint
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Methods

ObservableUndoableTextChangeStack Methods

The ObservableUndoableTextChangeStack type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Returns whether the collection contains the specified IUndoableTextChange.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DisposableObject.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetTextChange | Gets the IUndoableTextChange that the specified location in the stack.
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the IUndoableTextChange in the list.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Contains Method

ObservableUndoableTextChangeStackContains Method
Returns whether the collection contains the specified IUndoableTextChange.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    IUndoableTextChange textChange
)
Public Function Contains (
    textChange As IUndoableTextChange
) As Boolean

Parameters

textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange to look for in the list.

Return Value

Type: Boolean
true if the collection contains the specified IUndoableTextChange; otherwise, false.
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.CopyTo Method

ObservableUndoableTextChangeStackCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    IUndoableTextChange[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As IUndoableTextChange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The one-dimensional IUndoableTextChange array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

IUndoableTextChangeStackCopyTo(IUndoableTextChange, Int32)
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Dispose Method

ObservableUndoableTextChangeStackDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DisposableObject.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DisposableObjectDispose(Boolean).)
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.Dispose Method (Boolean)

ObservableUndoableTextChangeStackDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

ObservableUndoableTextChangeStack Class
Dispose Overload
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.GetEnumerator Method

ObservableUndoableTextChangeStackGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<IUndoableTextChange> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IUndoableTextChange)

Return Value

Type: IEnumerator IUndoableTextChange
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.GetTextChange Method

ObservableUndoableTextChangeStackGetTextChange Method
Gets the IUndoableTextChange that the specified location in the stack.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IUndoableTextChange GetTextChange(
    int index
)
Public Function GetTextChange (
    index As Integer
) As IUndoableTextChange

Parameters

index
Type: SystemInt32
The index of the text change to check.

Return Value

Type: IUndoableTextChange
The IUndoableTextChange that the specified location in the stack.

Implements

IUndoableTextChangeStackGetTextChange(Int32)
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.IndexOf Method

ObservableUndoableTextChangeStackIndexOf Method
Returns the index of the IUndoableTextChange in the list.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    IUndoableTextChange textChange
)
Public Function IndexOf (
    textChange As IUndoableTextChange
) As Integer

Parameters

textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange to look for in the list.

Return Value

Type: Int32
The index of the IUndoableTextChange in the list, or -1 if not found.

Implements

IUndoableTextChangeStackIndexOf(IUndoableTextChange)
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack Events

ObservableUndoableTextChangeStack Events

The ObservableUndoableTextChangeStack type exposes the following members.

Events
 | Name | Description
Public event | CapacityChanged | Occurs when the capacity of the stack is changed.
Public event | StackChanged | Occurs when the contents of the stack are changed.
Public event | VectorChanged | Occurs when the collection is changed.
Top
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.CapacityChanged Event

ObservableUndoableTextChangeStackCapacityChanged Event
Occurs when the capacity of the stack is changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler CapacityChanged
Public Event CapacityChanged As EventHandler

Value

Type: SystemEventHandler

Implements

IUndoableTextChangeStackCapacityChanged
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.StackChanged Event

ObservableUndoableTextChangeStackStackChanged Event
Occurs when the contents of the stack are changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler StackChanged
Public Event StackChanged As EventHandler

Value

Type: SystemEventHandler

Implements

IUndoableTextChangeStackStackChanged
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


ObservableUndoableTextChangeStack.VectorChanged Event

ObservableUndoableTextChangeStackVectorChanged Event
Occurs when the collection is changed.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event VectorChangedEventHandler<Object> VectorChanged
Public Event VectorChanged As VectorChangedEventHandler(Of Object)

Value

Type: Windows.Foundation.CollectionsVectorChangedEventHandler Object
See Also

Reference

ObservableUndoableTextChangeStack Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType Class

SavePointChangeType Class
Specifies the type of changes that have been made to a character range since the last save point.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.UndoSavePointChangeType

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SavePointChangeType : Enum
Public NotInheritable Class SavePointChangeType
    Inherits Enum

The SavePointChangeType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | There are no changes from the original text.
 | RevertedChanges | These are reverted changes where undo was performed after the last save point.
 | SavedChanges | There are saved changed made since the last save point.
 | UnsavedChanges | There are unsaved changes made since the last save point.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


SavePointChangeType Methods

SavePointChangeType Methods

The SavePointChangeType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType Fields

SavePointChangeType Fields

The SavePointChangeType type exposes the following members.

Fields
 | Name | Description
 | None | There are no changes from the original text.
 | RevertedChanges | These are reverted changes where undo was performed after the last save point.
 | SavedChanges | There are saved changed made since the last save point.
 | UnsavedChanges | There are unsaved changes made since the last save point.
Public field | value__ |
Top
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType.None Field

SavePointChangeTypeNone Field
There are no changes from the original text.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SavePointChangeType None = 0
Public Const None As SavePointChangeType = 0

Field Value

Type: SavePointChangeType
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType.RevertedChanges Field

SavePointChangeTypeRevertedChanges Field
These are reverted changes where undo was performed after the last save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SavePointChangeType RevertedChanges = 3
Public Const RevertedChanges As SavePointChangeType = 3

Field Value

Type: SavePointChangeType
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType.SavedChanges Field

SavePointChangeTypeSavedChanges Field
There are saved changed made since the last save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SavePointChangeType SavedChanges = 1
Public Const SavedChanges As SavePointChangeType = 1

Field Value

Type: SavePointChangeType
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType.UnsavedChanges Field

SavePointChangeTypeUnsavedChanges Field
There are unsaved changes made since the last save point.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SavePointChangeType UnsavedChanges = 2
Public Const UnsavedChanges As SavePointChangeType = 2

Field Value

Type: SavePointChangeType
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


SavePointChangeType.value__ Field

SavePointChangeTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Undo.SavePointChangeType.value__"]

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SavePointChangeType Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Class

UndoRedoRequestEventArgs Class
Event arguments for when an undo or redo operation is requesting to be applied to an ITextDocument.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UndoUndoRedoRequestEventArgs

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UndoRedoRequestEventArgs : EventArgs
Public Class UndoRedoRequestEventArgs
    Inherits EventArgs

The UndoRedoRequestEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UndoRedoRequestEventArgs | Initializes a new instance of the UndoRedoRequestEventArgs class.
Top
Properties
 | Name | Description
Public property | Document | Gets the ITextDocument that is affected by this event, if known.
Public property | IsUndo | Gets whether this event is for an undo operation.
Public property | TextChange | Gets the IUndoableTextChange that is made to the document.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Constructor

UndoRedoRequestEventArgs Constructor
Initializes a new instance of the UndoRedoRequestEventArgs class.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UndoRedoRequestEventArgs(
    ITextDocument document,
    IUndoableTextChange textChange,
    bool isUndo
)
Public Sub New (
    document As ITextDocument,
    textChange As IUndoableTextChange,
    isUndo As Boolean
)

Parameters

document
Type: ActiproSoftware.TextITextDocument
The ITextDocument that is affected by this event, if known.
textChange
Type: ActiproSoftware.Text.UndoIUndoableTextChange
The IUndoableTextChange that is made.
isUndo
Type: SystemBoolean
true the event is for an undo operation; otherwise, false, meaning redo.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Properties

UndoRedoRequestEventArgs Properties

The UndoRedoRequestEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the ITextDocument that is affected by this event, if known.
Public property | IsUndo | Gets whether this event is for an undo operation.
Public property | TextChange | Gets the IUndoableTextChange that is made to the document.
Top
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs.Document Property

UndoRedoRequestEventArgsDocument Property
Gets the ITextDocument that is affected by this event, if known.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextDocument Document { get; }
Public ReadOnly Property Document As ITextDocument
    Get

Property Value

Type: ITextDocument
The ITextDocument that is affected by this event, if known.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs.IsUndo Property

UndoRedoRequestEventArgsIsUndo Property
Gets whether this event is for an undo operation.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsUndo { get; }
Public ReadOnly Property IsUndo As Boolean
    Get

Property Value

Type: Boolean
true the event is for an undo operation; otherwise, false, meaning redo.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs.TextChange Property

UndoRedoRequestEventArgsTextChange Property
Gets the IUndoableTextChange that is made to the document.

Namespace: ActiproSoftware.Text.Undo
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IUndoableTextChange TextChange { get; }
Public ReadOnly Property TextChange As IUndoableTextChange
    Get

Property Value

Type: IUndoableTextChange
The IUndoableTextChange that is made to the document.
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


UndoRedoRequestEventArgs Methods

UndoRedoRequestEventArgs Methods

The UndoRedoRequestEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

UndoRedoRequestEventArgs Class
ActiproSoftware.Text.Undo Namespace


ActiproSoftware.Text.Utility Namespace

ActiproSoftware.Text.Utility Namespace
Contains utility classes.
Classes
 | Class | Description
Public class | CollectionChangeEventArgsT | Event arguments for various SimpleObservableCollectionT change events.
Public class | DisposableObject | Provides a base class that implements the IDisposable interface. This class functions in accordance with the Disposable design pattern.
Public class | EventHandlerPriority | Specifies the priority that applied to an event handler.
Public class | IntegerList | Represents a list of integers.
Public class | KeyedObservableCollectionT | Provides a generic keyed collection that provides notifications when items are added or removed.
Public class | KeyedSynchronizedCollectionT | Provides a thread-safe generic keyed collection that provides notifications when items are added or removed.
Public class | LipsumGenerator | A utility class that can generate 'lorem ipsum' placeholder text.
Public class | OrderableHelper | Provides numerous utility methods for working with IOrderable objects.
Public class | Ordering | Provides data used to order one object relative to another.
Public class | OrderPlacement | Specifies the placement order for an Ordering.
Public class | PropertyChangedEventArgsT | Provides event arguments for a property change event, indicating the old and new values.
Public class | PropertyDictionary | Provides a thread-safe dictionary of properties.
Public class | PropertyDictionaryCreatorTValue | Creates a property value.
Public class | Range | Represents an ordered pair of min and max values.
Public class | RangeCollection | Provides an implementation of a collection of Range objects.
Public class | SimpleObservableCollectionT | Provides a generic collection that provides notifications when items are added or removed.
Public class | SimpleSynchronizedCollectionT | Provides a thread-safe generic collection that provides notifications when items are added or removed.
Public class | StringHelper | Provides numerous utility methods for working with strings.
Public class | StringPropertyChangedEventArgs | Provides event arguments for a property change event, indicating the old and new values.
Public class | WeakEventListenerTInstance, TEventArgs | Provides a listener that allows for "weak" listening to events.
Public class | WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 | Provides the delegate for an event action.
Interfaces
 | Interface | Description
Public interface | IKeyedObject | Provides the base requirements for an object that has a string-based key.
Public interface | IKeyedObservableCollectionT | Provides the base requirements for a collection that has string-based unique keys.
Public interface | IObservableCollectionT | Provides the base requirements for a collection that raises events when changed.
Public interface | IOrderable | Provides the base requirements for an object that can be ordered by name against other named objects.
Public interface | IServiceLocator | Provides the base requirements for an object that can store and provide services.


CollectionChangeEventArgs(T) Class

CollectionChangeEventArgsT Class
Event arguments for various SimpleObservableCollectionT change events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityCollectionChangeEventArgsT

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CollectionChangeEventArgs<T> : EventArgs

Public Class CollectionChangeEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The Type of item.

The CollectionChangeEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionChangeEventArgsT | Initializes a new instance of the CollectionChangeEventArgs class.
Top
Properties
 | Name | Description
Public property | Index | Gets the index at which the item is/was located.
Public property | Item | Gets the T that is affected by this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T) Constructor

CollectionChangeEventArgsT Constructor
Initializes a new instance of the CollectionChangeEventArgs class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollectionChangeEventArgs(
    int index,
    T item
)
Public Sub New (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which the item is/was located.
item
Type: T
The T that is affected by this event.
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T) Properties

CollectionChangeEventArgsT Properties

The CollectionChangeEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the index at which the item is/was located.
Public property | Item | Gets the T that is affected by this event.
Top
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T).Index Property

CollectionChangeEventArgsTIndex Property
Gets the index at which the item is/was located.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index at which the item is/was located.
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T).Item Property

CollectionChangeEventArgsTItem Property
Gets the T that is affected by this event.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Item { get; }
Public ReadOnly Property Item As T
    Get

Property Value

Type: T
The T that is affected by this event.
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


CollectionChangeEventArgs(T) Methods

CollectionChangeEventArgsT Methods

The CollectionChangeEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CollectionChangeEventArgsT Class
ActiproSoftware.Text.Utility Namespace


DisposableObject Class

DisposableObject Class
Provides a base class that implements the IDisposable interface. This class functions in accordance with the Disposable design pattern.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityDisposableObject
ActiproSoftware.Text.Parsing.ImplementationTaskBasedParseRequestDispatcher
ActiproSoftware.Text.TaggingTagAggregatorBaseT
ActiproSoftware.Text.UndoObservableUndoableTextChangeStack

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DisposableObject : IDisposable
Public MustInherit Class DisposableObject
    Implements IDisposable

The DisposableObject type exposes the following members.

Constructors
 | Name | Description
Protected method | DisposableObject | Initializes a new instance of the DisposableObject class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


DisposableObject Constructor

DisposableObject Constructor
Initializes a new instance of the DisposableObject class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DisposableObject()
Protected Sub New
Remarks
The default constructor initializes all fields to their default values.
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


DisposableObject Methods

DisposableObject Methods

The DisposableObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


DisposableObject.Dispose Method

DisposableObjectDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


DisposableObject.Dispose Method

DisposableObjectDispose Method
Releases all resources used by the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DisposableObject Class
Dispose Overload
ActiproSoftware.Text.Utility Namespace


DisposableObject.Dispose Method (Boolean)

DisposableObjectDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

DisposableObject Class
Dispose Overload
ActiproSoftware.Text.Utility Namespace


DisposableObject.Finalize Method

DisposableObjectFinalize Method
Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

DisposableObject Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority Class

EventHandlerPriority Class
Specifies the priority that applied to an event handler.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.UtilityEventHandlerPriority

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EventHandlerPriority : Enum
Public NotInheritable Class EventHandlerPriority
    Inherits Enum

The EventHandlerPriority type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | High | High priority.
 | Low | Low priority.
 | Medium | Medium priority.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


EventHandlerPriority Methods

EventHandlerPriority Methods

The EventHandlerPriority type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

EventHandlerPriority Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority Fields

EventHandlerPriority Fields

The EventHandlerPriority type exposes the following members.

Fields
 | Name | Description
 | High | High priority.
 | Low | Low priority.
 | Medium | Medium priority.
Public field | value__ |
Top
See Also

Reference

EventHandlerPriority Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority.High Field

EventHandlerPriorityHigh Field
High priority.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EventHandlerPriority High = 2
Public Const High As EventHandlerPriority = 2

Field Value

Type: EventHandlerPriority
See Also

Reference

EventHandlerPriority Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority.Low Field

EventHandlerPriorityLow Field
Low priority.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EventHandlerPriority Low = 0
Public Const Low As EventHandlerPriority = 0

Field Value

Type: EventHandlerPriority
See Also

Reference

EventHandlerPriority Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority.Medium Field

EventHandlerPriorityMedium Field
Medium priority.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EventHandlerPriority Medium = 1
Public Const Medium As EventHandlerPriority = 1

Field Value

Type: EventHandlerPriority
See Also

Reference

EventHandlerPriority Class
ActiproSoftware.Text.Utility Namespace


EventHandlerPriority.value__ Field

EventHandlerPriorityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Utility.EventHandlerPriority.value__"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

EventHandlerPriority Class
ActiproSoftware.Text.Utility Namespace


IKeyedObject Interface

IKeyedObject Interface
Provides the base requirements for an object that has a string-based key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IKeyedObject
Public Interface IKeyedObject

The IKeyedObject type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IKeyedObject Properties

IKeyedObject Properties

The IKeyedObject type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object.
Top
See Also

Reference

IKeyedObject Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObject.Key Property

IKeyedObjectKey Property
Gets the string-based key that identifies the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key that identifies the object.
See Also

Reference

IKeyedObject Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Interface

IKeyedObservableCollectionT Interface
Provides the base requirements for a collection that has string-based unique keys.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IKeyedObservableCollection<T> : IObservableCollection<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable
where T : class, IKeyedObject

Public Interface IKeyedObservableCollection(Of T As {Class, IKeyedObject})
    Inherits IObservableCollection(Of T), IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable

Type Parameters

T
The Type of item in the collection.

The IKeyedObservableCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection T.)
Public property | IsReadOnly | (Inherited from ICollection T.)
Public property | ItemInt32 | (Inherited from IList T.)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection T.)
Public method | Clear | (Inherited from ICollection T.)
Public method | Contains(T) | (Inherited from ICollection T.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | (Inherited from ICollection T.)
Public method | GetEnumerator | (Inherited from IEnumerable T.)
Public method | IndexOf(T) | (Inherited from IList T.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from IList T.)
Public method | Remove(T) | (Inherited from ICollection T.)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | (Inherited from IList T.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Properties

IKeyedObservableCollectionT Properties

The IKeyedObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection T .)
Public property | IsReadOnly | (Inherited from ICollection T .)
Public property | ItemInt32 | (Inherited from IList T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Item Property

IKeyedObservableCollectionTItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from IList T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Item Property (String)

IKeyedObservableCollectionTItem Property (String)
Gets the T with the specified key.

[C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
T this[
    string key
] { get; }
ReadOnly Property Item (
    key As String
) As T
    Get

Parameters

key
Type: SystemString
The key of the T to return.

Property Value

Type: T
The T with the specified key.
See Also

Reference

IKeyedObservableCollectionT Interface
Item Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Methods

IKeyedObservableCollectionT Methods

The IKeyedObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection T .)
Public method | Clear | (Inherited from ICollection T .)
Public method | Contains(T) | (Inherited from ICollection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | (Inherited from ICollection T .)
Public method | GetEnumerator | (Inherited from IEnumerable T .)
Public method | IndexOf(T) | (Inherited from IList T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from IList T .)
Public method | Remove(T) | (Inherited from ICollection T .)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | (Inherited from IList T .)
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Contains Method

IKeyedObservableCollectionTContains Method
Overload List
 | Name | Description
Public method | Contains(T) | (Inherited from ICollection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Contains Method (String)

IKeyedObservableCollectionTContains Method (String)
Determines whether a T with the specified key is in the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    string key
)
Function Contains (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T with the specified key is found in the collection; otherwise, false.
See Also

Reference

IKeyedObservableCollectionT Interface
Contains Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).IndexOf Method

IKeyedObservableCollectionTIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | (Inherited from IList T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).IndexOf Method (String)

IKeyedObservableCollectionTIndexOf Method (String)
Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndexOf(
    string key
)
Function IndexOf (
    key As String
) As Integer

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of a T with the specified key within the entire collection, if found; otherwise, -1.
See Also

Reference

IKeyedObservableCollectionT Interface
IndexOf Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Remove Method

IKeyedObservableCollectionTRemove Method
Overload List
 | Name | Description
Public method | Remove(T) | (Inherited from ICollection T .)
Public method | Remove(String) | Removes the T with the specified key.
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T).Remove Method (String)

IKeyedObservableCollectionTRemove Method (String)
Removes the T with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove(
    string key
)
Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T was removed; otherwise, false.
See Also

Reference

IKeyedObservableCollectionT Interface
Remove Overload
ActiproSoftware.Text.Utility Namespace


IKeyedObservableCollection(T) Events

IKeyedObservableCollectionT Events

The IKeyedObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from IObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from IObservableCollectionT.)
Top
See Also

Reference

IKeyedObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IntegerList Class

IntegerList Class
Represents a list of integers.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityIntegerList

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IntegerList
Public Class IntegerList

The IntegerList type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerList | Initializes a new instance of the IntegerList class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of integers in the list.
Public property | Item | Gets or sets the integer at the specified index. [C#] In C#, this property is the indexer for the IntegerList class.
Top
Methods
 | Name | Description
Public method | Add | Adds an integer to the end of the list.
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Increment | Increments all integers in the list after the specified index by the delta value.
Public method | Insert | Inserts an integer into the list.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RemoveAt | Removes the integer at the specified index from the list.
Public method | RemoveRange | Removes a range of integers from the list.
Public method | ToArray | Copies the integer of the collection to a new integer array.
Public method | ToString | (Inherited from Object.)
Top
Remarks
The implementation uses a short array to track the values until the values become too large, at which point an integer array is used. This saves on memory for smaller-valued lists.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IntegerList Constructor

IntegerList Constructor
Initializes a new instance of the IntegerList class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IntegerList(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The initial capacity of the list.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList Properties

IntegerList Properties

The IntegerList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of integers in the list.
Public property | Item | Gets or sets the integer at the specified index. [C#] In C#, this property is the indexer for the IntegerList class.
Top
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Count Property

IntegerListCount Property
Gets the number of integers in the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of integers in the list.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Item Property

IntegerListItem Property
Gets or sets the integer at the specified index.

[C#] In C#, this property is the indexer for the IntegerList class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int this[
    int index
] { get; set; }
Public Property Item (
    index As Integer
) As Integer
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the integer to return.

Property Value

Type: Int32
The integer at the specified index.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList Methods

IntegerList Methods

The IntegerList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an integer to the end of the list.
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Increment | Increments all integers in the list after the specified index by the delta value.
Public method | Insert | Inserts an integer into the list.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RemoveAt | Removes the integer at the specified index from the list.
Public method | RemoveRange | Removes a range of integers from the list.
Public method | ToArray | Copies the integer of the collection to a new integer array.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Add Method

IntegerListAdd Method
Adds an integer to the end of the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Add(
    int value
)
Public Function Add (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The value to add.

Return Value

Type: Int32
The index at which the integer was added.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.BinarySearch Method

IntegerListBinarySearch Method
Performs a binary search for the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int BinarySearch(
    int value
)
Public Function BinarySearch (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The value for which to search.

Return Value

Type: Int32
The index of the specified value in the specified array, if value is found. If value is not found and value is less than one or more elements in array, a negative number which is the bitwise complement of the index of the first element that is larger than value. If value is not found and value is greater than any of the elements in array, a negative number which is the bitwise complement of (the index of the last element plus 1).
Remarks
This method should only be used if the integers in the list are guaranteed to be sorted.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Increment Method

IntegerListIncrement Method
Increments all integers in the list after the specified index by the delta value.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Increment(
    int index,
    int delta
)
Public Sub Increment (
    index As Integer,
    delta As Integer
)

Parameters

index
Type: SystemInt32
The index at which to start incrementing value.
delta
Type: SystemInt32
The amount by which to increment.
Remarks
This method should only be used if the integers in the list are guaranteed to be sorted.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.Insert Method

IntegerListInsert Method
Inserts an integer into the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Insert(
    int index,
    int value
)
Public Sub Insert (
    index As Integer,
    value As Integer
)

Parameters

index
Type: SystemInt32
The index at which to insert.
value
Type: SystemInt32
The value to insert.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.RemoveAt Method

IntegerListRemoveAt Method
Removes the integer at the specified index from the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the integer to remove.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.RemoveRange Method

IntegerListRemoveRange Method
Removes a range of integers from the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveRange(
    int index,
    int count
)
Public Sub RemoveRange (
    index As Integer,
    count As Integer
)

Parameters

index
Type: SystemInt32
The zero-based starting index of the range of integers to remove.
count
Type: SystemInt32
The number of integers to remove.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IntegerList.ToArray Method

IntegerListToArray Method
Copies the integer of the collection to a new integer array.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int[] ToArray()
Public Function ToArray As Integer()

Return Value

Type: Int32
An array of integers.
See Also

Reference

IntegerList Class
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Interface

IObservableCollectionT Interface
Provides the base requirements for a collection that raises events when changed.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IObservableCollection<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable
where T : class

Public Interface IObservableCollection(Of T As Class)
    Inherits IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable

Type Parameters

T
The Type of item in the collection.

The IObservableCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection T.)
Public property | IsReadOnly | (Inherited from ICollection T.)
Public property | Item | (Inherited from IList T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection T.)
Public method | Clear | (Inherited from ICollection T.)
Public method | Contains | (Inherited from ICollection T.)
Public method | CopyTo | (Inherited from ICollection T.)
Public method | GetEnumerator | (Inherited from IEnumerable T.)
Public method | IndexOf | (Inherited from IList T.)
Public method | Insert | (Inherited from IList T.)
Public method | Remove | (Inherited from ICollection T.)
Public method | RemoveAt | (Inherited from IList T.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Properties

IObservableCollectionT Properties

The IObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection T .)
Public property | IsReadOnly | (Inherited from ICollection T .)
Public property | Item | (Inherited from IList T .)
Top
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Methods

IObservableCollectionT Methods

The IObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection T .)
Public method | Clear | (Inherited from ICollection T .)
Public method | Contains | (Inherited from ICollection T .)
Public method | CopyTo | (Inherited from ICollection T .)
Public method | GetEnumerator | (Inherited from IEnumerable T .)
Public method | IndexOf | (Inherited from IList T .)
Public method | Insert | (Inherited from IList T .)
Public method | Remove | (Inherited from ICollection T .)
Public method | RemoveAt | (Inherited from IList T .)
Top
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T) Events

IObservableCollectionT Events

The IObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemAdded Event

IObservableCollectionTItemAdded Event
Occurs after an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemAdded
Event ItemAdded As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemAdding Event

IObservableCollectionTItemAdding Event
Occurs before an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemAdding
Event ItemAdding As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemRemoved Event

IObservableCollectionTItemRemoved Event
Occurs after an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemRemoved
Event ItemRemoved As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IObservableCollection(T).ItemRemoving Event

IObservableCollectionTItemRemoving Event
Occurs before an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<T>> ItemRemoving
Event ItemRemoving As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

IObservableCollectionT Interface
ActiproSoftware.Text.Utility Namespace


IOrderable Interface

IOrderable Interface
Provides the base requirements for an object that can be ordered by name against other named objects.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IOrderable : IKeyedObject
Public Interface IOrderable
    Inherits IKeyedObject

The IOrderable type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IOrderable Properties

IOrderable Properties

The IOrderable type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

IOrderable Interface
ActiproSoftware.Text.Utility Namespace


IOrderable.Orderings Property

IOrderableOrderings Property
Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<Ordering> Orderings { get; }
ReadOnly Property Orderings As IEnumerable(Of Ordering)
    Get

Property Value

Type: IEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
See Also

Reference

IOrderable Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator Interface

IServiceLocator Interface
Provides the base requirements for an object that can store and provide services.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IServiceLocator
Public Interface IServiceLocator

The IServiceLocator type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
Remarks
When calling the non-generic methods on this interface, the object key used to register the service should generally be a Type instance.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


IServiceLocator Methods

IServiceLocator Methods

The IServiceLocator type exposes the following members.

Methods
 | Name | Description
Public method | GetAllServiceTypes | Returns a collection of all the service types that have been registered.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetAllServiceTypes Method

IServiceLocatorGetAllServiceTypes Method
Returns a collection of all the service types that have been registered.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<Object> GetAllServiceTypes()
Function GetAllServiceTypes As IEnumerable(Of Object)

Return Value

Type: IEnumerable Object
A collection of all the service types that have been registered.
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetService Method

IServiceLocatorGetService Method
Overload List
 | Name | Description
Public method | GetServiceT | Returns the service that has been registered with the specified type.
Public method | GetService(Object) | Returns the service that has been registered with the specified type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetService(T) Method

IServiceLocatorGetServiceT Method
Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
T GetService<T>()

Function GetService(Of T) As T

Type Parameters

T
The type of service to return.

Return Value

Type: T
The service that has been registered with the specified type.
See Also

Reference

IServiceLocator Interface
GetService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.GetService Method (Object)

IServiceLocatorGetService Method (Object)
Returns the service that has been registered with the specified type.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object GetService(
    Object serviceType
)
Function GetService (
    serviceType As Object
) As Object

Parameters

serviceType
Type: SystemObject
The type of service to return.

Return Value

Type: Object
The service that has been registered with the specified type.
See Also

Reference

IServiceLocator Interface
GetService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.RegisterService Method

IServiceLocatorRegisterService Method
Overload List
 | Name | Description
Public method | RegisterServiceT(T) | Registers a service instance for the specified service type.
Public method | RegisterService(Object, Object) | Registers a service instance for the specified service type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.RegisterService(T) Method (T)

IServiceLocatorRegisterServiceT Method (T)
Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RegisterService<T>(
    T service
)

Sub RegisterService(Of T) (
    service As T
)

Parameters

service
Type: T
The service object instance.

Type Parameters

T
The type of service.
See Also

Reference

IServiceLocator Interface
RegisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.RegisterService Method (Object, Object)

IServiceLocatorRegisterService Method (Object, Object)
Registers a service instance for the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RegisterService(
    Object serviceType,
    Object service
)
Sub RegisterService (
    serviceType As Object,
    service As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.
service
Type: SystemObject
The service object instance.
See Also

Reference

IServiceLocator Interface
RegisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.UnregisterService Method

IServiceLocatorUnregisterService Method
Overload List
 | Name | Description
Public method | UnregisterServiceT | Unregisters a service of the specified service type.
Public method | UnregisterService(Object) | Unregisters a service of the specified service type.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.UnregisterService(T) Method

IServiceLocatorUnregisterServiceT Method
Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void UnregisterService<T>()

Sub UnregisterService(Of T)

Type Parameters

T
The type of service.
See Also

Reference

IServiceLocator Interface
UnregisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator.UnregisterService Method (Object)

IServiceLocatorUnregisterService Method (Object)
Unregisters a service of the specified service type.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void UnregisterService(
    Object serviceType
)
Sub UnregisterService (
    serviceType As Object
)

Parameters

serviceType
Type: SystemObject
The type of service.
See Also

Reference

IServiceLocator Interface
UnregisterService Overload
ActiproSoftware.Text.Utility Namespace


IServiceLocator Events

IServiceLocator Events

The IServiceLocator type exposes the following members.

Events
 | Name | Description
Public event | ServiceAdded | Occurs after a service is added to the object.
Public event | ServiceRemoved | Occurs after a service is removed from the object.
Top
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.ServiceAdded Event

IServiceLocatorServiceAdded Event
Occurs after a service is added to the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<Object>> ServiceAdded
Event ServiceAdded As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


IServiceLocator.ServiceRemoved Event

IServiceLocatorServiceRemoved Event
Occurs after a service is removed from the object.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<CollectionChangeEventArgs<Object>> ServiceRemoved
Event ServiceRemoved As EventHandler(Of CollectionChangeEventArgs(Of Object))

Value

Type: SystemEventHandler CollectionChangeEventArgs Object
See Also

Reference

IServiceLocator Interface
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Class

KeyedObservableCollectionT Class
Provides a generic keyed collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollection T
ActiproSoftware.Text.UtilityKeyedObservableCollectionT
ActiproSoftware.Text.Lexing.ImplementationLexicalStateCollection
ActiproSoftware.Text.UtilityKeyedSynchronizedCollectionT
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Margins.ImplementationEditorViewMarginCollection
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Margins.ImplementationPrinterViewMarginCollection

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class KeyedObservableCollection<T> : SimpleObservableCollection<T>,
    IKeyedObservableCollection<T>, IObservableCollection<T>, IList<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable
where T : class, IKeyedObject

Public Class KeyedObservableCollection(Of T As {Class, IKeyedObject})
    Inherits SimpleObservableCollection(Of T)
    Implements IKeyedObservableCollection(Of T), IObservableCollection(Of T),
    IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Text.Utility.KeyedObservableCollection`1"]

The KeyedObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | KeyedObservableCollectionT | Initializes a new instance of the KeyedObservableCollectionT class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection T.)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(T) | (Inherited from Collection T.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | (Inherited from Collection T.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from Collection T.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | (Inherited from Collection T.)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Constructor

KeyedObservableCollectionT Constructor
Initializes a new instance of the KeyedObservableCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public KeyedObservableCollection()
Public Sub New
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Properties

KeyedObservableCollectionT Properties

The KeyedObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Item Property

KeyedObservableCollectionTItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Item Property (String)

KeyedObservableCollectionTItem Property (String)
Gets the T with the specified key.

[C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual T this[
    string key
] { get; }
Public Overridable ReadOnly Property Item (
    key As String
) As T
    Get

Parameters

key
Type: SystemString
The key of the T to return.

Property Value

Type: T
The T with the specified key.

Implements

IKeyedObservableCollectionTItemString
See Also

Reference

KeyedObservableCollectionT Class
Item Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Methods

KeyedObservableCollectionT Methods

The KeyedObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Contains(T) | (Inherited from Collection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Public method | CopyTo | (Inherited from Collection T .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key.
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Protected method | SetItem | Replaces the item at the specified index. (Inherited from SimpleObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Contains Method

KeyedObservableCollectionTContains Method
Overload List
 | Name | Description
Public method | Contains(T) | (Inherited from Collection T .)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Contains Method (String)

KeyedObservableCollectionTContains Method (String)
Determines whether a T with the specified key is in the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    string key
)
Public Function Contains (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T with the specified key is found in the collection; otherwise, false.

Implements

IKeyedObservableCollectionTContains(String)
See Also

Reference

KeyedObservableCollectionT Class
Contains Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).IndexOf Method

KeyedObservableCollectionTIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).IndexOf Method (String)

KeyedObservableCollectionTIndexOf Method (String)
Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int IndexOf(
    string key
)
Public Overridable Function IndexOf (
    key As String
) As Integer

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of a T with the specified key within the entire collection, if found; otherwise, -1.

Implements

IKeyedObservableCollectionTIndexOf(String)
See Also

Reference

KeyedObservableCollectionT Class
IndexOf Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Remove Method

KeyedObservableCollectionTRemove Method
Overload List
 | Name | Description
Public method | Remove(T) | (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key.
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T).Remove Method (String)

KeyedObservableCollectionTRemove Method (String)
Removes the T with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Remove(
    string key
)
Public Overridable Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T was removed; otherwise, false.

Implements

IKeyedObservableCollectionTRemove(String)
See Also

Reference

KeyedObservableCollectionT Class
Remove Overload
ActiproSoftware.Text.Utility Namespace


KeyedObservableCollection(T) Events

KeyedObservableCollectionT Events

The KeyedObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

KeyedObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Class

KeyedSynchronizedCollectionT Class
Provides a thread-safe generic keyed collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollection T
ActiproSoftware.Text.UtilityKeyedObservableCollection T
ActiproSoftware.Text.UtilityKeyedSynchronizedCollectionT

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class KeyedSynchronizedCollection<T> : KeyedObservableCollection<T>
where T : class, IKeyedObject

Public Class KeyedSynchronizedCollection(Of T As {Class, IKeyedObject})
    Inherits KeyedObservableCollection(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.Text.Utility.KeyedSynchronizedCollection`1"]

The KeyedSynchronizedCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | KeyedSynchronizedCollectionT | Initializes a new instance of the KeyedSynchronizedCollectionT class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection T.)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Overrides KeyedObservableCollectionTItemString.)
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from Collection T.)
Public method | CopyTo | (Inherited from Collection T.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from Collection T.)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Overrides KeyedObservableCollectionTIndexOf(String).)
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | (Inherited from Collection T.)
Public method | Remove(String) | Removes the T with the specified key. (Overrides KeyedObservableCollectionTRemove(String).)
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Constructor

KeyedSynchronizedCollectionT Constructor
Initializes a new instance of the KeyedSynchronizedCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public KeyedSynchronizedCollection()
Public Sub New
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Properties

KeyedSynchronizedCollectionT Properties

The KeyedSynchronizedCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Overrides KeyedObservableCollectionTItemString.)
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Item Property

KeyedSynchronizedCollectionTItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from Collection T .)
Public property | ItemString | Gets the T with the specified key. [C#] In C#, this property is the indexer for the IKeyedObservableCollection interface. (Overrides KeyedObservableCollectionTItemString.)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Item Property (String)

KeyedSynchronizedCollectionTItem Property (String)
Gets the T with the specified key.

[C#] In C#, this property is the indexer for the IKeyedObservableCollection interface.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override T this[
    string key
] { get; }
Public Overrides ReadOnly Property Item (
    key As String
) As T
    Get

Parameters

key
Type: SystemString
The key of the T to return.

Property Value

Type: T
The T with the specified key.

Implements

IKeyedObservableCollectionTItemString
See Also

Reference

KeyedSynchronizedCollectionT Class
Item Overload
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Methods

KeyedSynchronizedCollectionT Methods

The KeyedSynchronizedCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains(String) | Determines whether a T with the specified key is in the collection. (Inherited from KeyedObservableCollectionT.)
Public method | Contains(T) | (Inherited from Collection T .)
Public method | CopyTo | (Inherited from Collection T .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Overrides KeyedObservableCollectionTIndexOf(String).)
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove(T) | (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key. (Overrides KeyedObservableCollectionTRemove(String).)
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).ClearItems Method

KeyedSynchronizedCollectionTClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).IndexOf Method

KeyedSynchronizedCollectionTIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | (Inherited from Collection T .)
Public method | IndexOf(String) | Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection. (Overrides KeyedObservableCollectionTIndexOf(String).)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).IndexOf Method (String)

KeyedSynchronizedCollectionTIndexOf Method (String)
Searches for a T with the specified key and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int IndexOf(
    string key
)
Public Overrides Function IndexOf (
    key As String
) As Integer

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of a T with the specified key within the entire collection, if found; otherwise, -1.

Implements

IKeyedObservableCollectionTIndexOf(String)
See Also

Reference

KeyedSynchronizedCollectionT Class
IndexOf Overload
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).InsertItem Method

KeyedSynchronizedCollectionTInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which to insert the item.
item
Type: T
The item to insert.
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Remove Method

KeyedSynchronizedCollectionTRemove Method
Overload List
 | Name | Description
Public method | Remove(T) | (Inherited from Collection T .)
Public method | Remove(String) | Removes the T with the specified key. (Overrides KeyedObservableCollectionTRemove(String).)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).Remove Method (String)

KeyedSynchronizedCollectionTRemove Method (String)
Removes the T with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Remove(
    string key
)
Public Overrides Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the collection.

Return Value

Type: Boolean
true if a T was removed; otherwise, false.

Implements

IKeyedObservableCollectionTRemove(String)
See Also

Reference

KeyedSynchronizedCollectionT Class
Remove Overload
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).RemoveItem Method

KeyedSynchronizedCollectionTRemoveItem Method
Removes the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T).SetItem Method

KeyedSynchronizedCollectionTSetItem Method
Replaces the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index of the item to replace.
item
Type: T
The item with which to replace.
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


KeyedSynchronizedCollection(T) Events

KeyedSynchronizedCollectionT Events

The KeyedSynchronizedCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

KeyedSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Class

LipsumGenerator Class
A utility class that can generate 'lorem ipsum' placeholder text.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityLipsumGenerator

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LipsumGenerator
Public Class LipsumGenerator

The LipsumGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | LipsumGenerator | Initializes a new instance of the LipsumGenerator class.
Public method | LipsumGenerator(String, String) | Initializes a new instance of the LipsumGenerator class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateParagraph | Generates a single paragraph of text.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


LipsumGenerator Constructor

LipsumGenerator Constructor
Overload List
 | Name | Description
Public method | LipsumGenerator | Initializes a new instance of the LipsumGenerator class.
Public method | LipsumGenerator(String, String) | Initializes a new instance of the LipsumGenerator class.
Top
See Also

Reference

LipsumGenerator Class
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Constructor

LipsumGenerator Constructor
Initializes a new instance of the LipsumGenerator class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LipsumGenerator()
Public Sub New
See Also

Reference

LipsumGenerator Class
LipsumGenerator Overload
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Constructor (String, String)

LipsumGenerator Constructor (String, String)
Initializes a new instance of the LipsumGenerator class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LipsumGenerator(
    string startingWords,
    string words
)
Public Sub New (
    startingWords As String,
    words As String
)

Parameters

startingWords
Type: SystemString
The words that can start the first paragraph.
words
Type: SystemString
The words.
See Also

Reference

LipsumGenerator Class
LipsumGenerator Overload
ActiproSoftware.Text.Utility Namespace


LipsumGenerator Methods

LipsumGenerator Methods

The LipsumGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GenerateParagraph | Generates a single paragraph of text.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LipsumGenerator Class
ActiproSoftware.Text.Utility Namespace


LipsumGenerator.GenerateParagraph Method

LipsumGeneratorGenerateParagraph Method
Generates a single paragraph of text.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GenerateParagraph(
    bool useStartingWords,
    int wordCount
)
Public Function GenerateParagraph (
    useStartingWords As Boolean,
    wordCount As Integer
) As String

Parameters

useStartingWords
Type: SystemBoolean
Whether to use the starting words to begin the paragraph (e.g. Lorem ipsum dolor sit amet...).
wordCount
Type: SystemInt32
The number of words in the paragraph.

Return Value

Type: String
The generated text.
See Also

Reference

LipsumGenerator Class
ActiproSoftware.Text.Utility Namespace


OrderableHelper Class

OrderableHelper Class
Provides numerous utility methods for working with IOrderable objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityOrderableHelper

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class OrderableHelper
Public NotInheritable Class OrderableHelper
Methods
Name | Description
SortT(IEnumerableT) | Returns a sorted array of IOrderable items.
SortT(IEnumerableT, ComparisonT, ComparisonT) | Sorts a list of items, giving precedence to IOrderable items.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


OrderableHelper Methods

OrderableHelper Methods
Methods
Name | Description
SortT(IEnumerableT) | Returns a sorted array of IOrderable items.
SortT(IEnumerableT, ComparisonT, ComparisonT) | Sorts a list of items, giving precedence to IOrderable items.
Top
See Also

Reference

OrderableHelper Class
ActiproSoftware.Text.Utility Namespace


OrderableHelper.Sort Method

OrderableHelperSort Method
Overload List
Name | Description
SortT(IEnumerableT) | Returns a sorted array of IOrderable items.
SortT(IEnumerableT, ComparisonT, ComparisonT) | Sorts a list of items, giving precedence to IOrderable items.
Top
See Also

Reference

OrderableHelper Class
ActiproSoftware.Text.Utility Namespace


OrderableHelper.Sort(T) Method (IEnumerable(T))

OrderableHelperSortT Method (IEnumerableT)
Returns a sorted array of IOrderable items.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static T[] Sort<T>(
    IEnumerable<T> unsortedItems
)
where T : IOrderable

Public Shared Function Sort(Of T As IOrderable) (
    unsortedItems As IEnumerable(Of T)
) As T()

Parameters

unsortedItems
Type: System.Collections.GenericIEnumerable T
The collection of unsorted IOrderable items.

Type Parameters

T
The item type.

Return Value

Type: T
A sorted array of IOrderable items.
See Also

Reference

OrderableHelper Class
Sort Overload
ActiproSoftware.Text.Utility Namespace


OrderableHelper.Sort(T) Method (IEnumerable(T), Comparison(T), Comparison(T))

OrderableHelperSortT Method (IEnumerableT, ComparisonT, ComparisonT)
Sorts a list of items, giving precedence to IOrderable items.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static T[] Sort<T>(
    IEnumerable<T> unsortedItems,
    Comparison<T> preComparison,
    Comparison<T> fallbackComparison
)

Public Shared Function Sort(Of T) (
    unsortedItems As IEnumerable(Of T),
    preComparison As Comparison(Of T),
    fallbackComparison As Comparison(Of T)
) As T()

Parameters

unsortedItems
Type: System.Collections.GenericIEnumerable T
The collection of unsorted items.
preComparison
Type: SystemComparison T
An optional comparison that executes before the default logic.
fallbackComparison
Type: SystemComparison T
An optional fallback comparison delegate.

Type Parameters

T
The item type.

Return Value

Type: T
A sorted array of items.
See Also

Reference

OrderableHelper Class
Sort Overload
ActiproSoftware.Text.Utility Namespace


Ordering Class

Ordering Class
Provides data used to order one object relative to another.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityOrdering

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Ordering
Public Class Ordering

The Ordering type exposes the following members.

Constructors
 | Name | Description
Public method | Ordering | Initializes a new instance of the Ordering class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key of the object relative to which the ordering's owner should be positioned.
Public property | Placement | Gets the OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


Ordering Constructor

Ordering Constructor
Initializes a new instance of the Ordering class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Ordering(
    string key,
    OrderPlacement placement
)
Public Sub New (
    key As String,
    placement As OrderPlacement
)

Parameters

key
Type: SystemString
The string-based key of the object relative to which the ordering's owner should be positioned.
placement
Type: ActiproSoftware.Text.UtilityOrderPlacement
The OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering Properties

Ordering Properties

The Ordering type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key of the object relative to which the ordering's owner should be positioned.
Public property | Placement | Gets the OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering.Key Property

OrderingKey Property
Gets the string-based key of the object relative to which the ordering's owner should be positioned.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key of the object relative to which the ordering's owner should be positioned.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering.Placement Property

OrderingPlacement Property
Gets the OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OrderPlacement Placement { get; }
Public ReadOnly Property Placement As OrderPlacement
    Get

Property Value

Type: OrderPlacement
The OrderPlacement that indicates how to position the ordering's owner relative to the object specified by Key.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering Methods

Ordering Methods

The Ordering type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ObjectToString.)
Top
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


Ordering.ToString Method

OrderingToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

Ordering Class
ActiproSoftware.Text.Utility Namespace


OrderPlacement Class

OrderPlacement Class
Specifies the placement order for an Ordering.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.Text.UtilityOrderPlacement

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class OrderPlacement : Enum
Public NotInheritable Class OrderPlacement
    Inherits Enum

The OrderPlacement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | After | The object that contains the Ordering is after the object specified in the Ordering.
 | Before | The object that contains the Ordering is before the object specified in the Ordering.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


OrderPlacement Methods

OrderPlacement Methods

The OrderPlacement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

OrderPlacement Class
ActiproSoftware.Text.Utility Namespace


OrderPlacement Fields

OrderPlacement Fields

The OrderPlacement type exposes the following members.

Fields
 | Name | Description
 | After | The object that contains the Ordering is after the object specified in the Ordering.
 | Before | The object that contains the Ordering is before the object specified in the Ordering.
Public field | value__ |
Top
See Also

Reference

OrderPlacement Class
ActiproSoftware.Text.Utility Namespace


OrderPlacement.After Field

OrderPlacementAfter Field
The object that contains the Ordering is after the object specified in the Ordering.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OrderPlacement After = 0
Public Const After As OrderPlacement = 0

Field Value

Type: OrderPlacement
See Also

Reference

OrderPlacement Class
ActiproSoftware.Text.Utility Namespace


OrderPlacement.Before Field

OrderPlacementBefore Field
The object that contains the Ordering is before the object specified in the Ordering.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const OrderPlacement Before = 1
Public Const Before As OrderPlacement = 1

Field Value

Type: OrderPlacement
See Also

Reference

OrderPlacement Class
ActiproSoftware.Text.Utility Namespace


OrderPlacement.value__ Field

OrderPlacementvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.Text.Utility.OrderPlacement.value__"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

OrderPlacement Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Class

PropertyChangedEventArgsT Class
Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityPropertyChangedEventArgsT
ActiproSoftware.Text.ParsingParseDataPropertyChangedEventArgs
ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyChangedEventArgs<T> : EventArgs

Public Class PropertyChangedEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The return type of the property.

The PropertyChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChangedEventArgsT | Initializes a new instance of the PropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Constructor

PropertyChangedEventArgsT Constructor
Initializes a new instance of the PropertyChangedEventArgs class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyChangedEventArgs(
    T oldValue,
    T newValue
)
Public Sub New (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Properties

PropertyChangedEventArgsT Properties

The PropertyChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T).NewValue Property

PropertyChangedEventArgsTNewValue Property
Gets the new value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T NewValue { get; }
Public ReadOnly Property NewValue As T
    Get

Property Value

Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T).OldValue Property

PropertyChangedEventArgsTOldValue Property
Gets the previous value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T OldValue { get; }
Public ReadOnly Property OldValue As T
    Get

Property Value

Type: T
The previous value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyChangedEventArgs(T) Methods

PropertyChangedEventArgsT Methods

The PropertyChangedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary Class

PropertyDictionary Class
Provides a thread-safe dictionary of properties.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityPropertyDictionary

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyDictionary
Public Class PropertyDictionary

The PropertyDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDictionary | Initializes a new instance of the PropertyDictionary class
Top
Properties
 | Name | Description
Public property | Item | Gets or sets the value of the property with the specified key. [C#] In C#, this property is the indexer for the PropertyDictionary class.
Public property | Keys | Gets the collection of property keys that have been registered in this dictionary.
Top
Methods
 | Name | Description
Public method | Add | Adds a property to the dictionary.
Public method | ContainsKey | Returns whether the dictionary contains a property with the specified key.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOrCreateSingletonTValue(PropertyDictionaryCreatorTValue) |
Public method | GetOrCreateSingletonTValue(Object, PropertyDictionaryCreatorTValue) |
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | Removes the property with the specified key from the dictionary.
Public method | ToString | (Inherited from Object.)
Public method | TryGetValueTValue | Attempts to return the value of the property with the specified key.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


PropertyDictionary Constructor

PropertyDictionary Constructor
Initializes a new instance of the PropertyDictionary class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyDictionary()
Public Sub New
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary Properties

PropertyDictionary Properties

The PropertyDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets or sets the value of the property with the specified key. [C#] In C#, this property is the indexer for the PropertyDictionary class.
Public property | Keys | Gets the collection of property keys that have been registered in this dictionary.
Top
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Item Property

PropertyDictionaryItem Property
Gets or sets the value of the property with the specified key.

[C#] In C#, this property is the indexer for the PropertyDictionary class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object this[
    Object key
] { get; set; }
Public Property Item (
    key As Object
) As Object
    Get
    Set

Parameters

key
Type: SystemObject
The property key for which to search.

Property Value

Type: Object
The value of the property with the specified key.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Keys Property

PropertyDictionaryKeys Property
Gets the collection of property keys that have been registered in this dictionary.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyCollection<Object> Keys { get; }
Public ReadOnly Property Keys As ReadOnlyCollection(Of Object)
    Get

Property Value

Type: ReadOnlyCollection Object
The collection of property keys that have been registered in this dictionary.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary Methods

PropertyDictionary Methods

The PropertyDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a property to the dictionary.
Public method | ContainsKey | Returns whether the dictionary contains a property with the specified key.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOrCreateSingletonTValue(PropertyDictionaryCreatorTValue) |
Public method | GetOrCreateSingletonTValue(Object, PropertyDictionaryCreatorTValue) |
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | Removes the property with the specified key from the dictionary.
Public method | ToString | (Inherited from Object.)
Public method | TryGetValueTValue | Attempts to return the value of the property with the specified key.
Top
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Add Method

PropertyDictionaryAdd Method
Adds a property to the dictionary.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    Object key,
    Object value
)
Public Sub Add (
    key As Object,
    value As Object
)

Parameters

key
Type: SystemObject
A key that identifies the property.
value
Type: SystemObject
The property value.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.ContainsKey Method

PropertyDictionaryContainsKey Method
Returns whether the dictionary contains a property with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ContainsKey(
    Object key
)
Public Function ContainsKey (
    key As Object
) As Boolean

Parameters

key
Type: SystemObject
The property key for which to search.

Return Value

Type: Boolean
true if the dictionary contains a property with the specified key; otherwise, false.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.GetOrCreateSingleton Method

PropertyDictionaryGetOrCreateSingleton Method
Overload List
 | Name | Description
Public method | GetOrCreateSingletonTValue(PropertyDictionaryCreatorTValue) |
Public method | GetOrCreateSingletonTValue(Object, PropertyDictionaryCreatorTValue) |
Top
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.GetOrCreateSingleton(TValue) Method (PropertyDictionary.Creator(TValue))

PropertyDictionaryGetOrCreateSingletonTValue Method (PropertyDictionaryCreatorTValue)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TValue GetOrCreateSingleton<TValue>(
    PropertyDictionaryCreator<TValue> creator
)

Public Function GetOrCreateSingleton(Of TValue) (
    creator As PropertyDictionaryCreator(Of TValue)
) As TValue

Parameters

creator
Type: ActiproSoftware.Text.UtilityPropertyDictionaryCreator TValue

[Missing <param name="creator"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Type Parameters

TValue

[Missing <typeparam name="TValue"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Return Value

Type: TValue

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

See Also

Reference

PropertyDictionary Class
GetOrCreateSingleton Overload
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.GetOrCreateSingleton(TValue) Method (Object, PropertyDictionary.Creator(TValue))

PropertyDictionaryGetOrCreateSingletonTValue Method (Object, PropertyDictionaryCreatorTValue)

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TValue GetOrCreateSingleton<TValue>(
    Object key,
    PropertyDictionaryCreator<TValue> creator
)

Public Function GetOrCreateSingleton(Of TValue) (
    key As Object,
    creator As PropertyDictionaryCreator(Of TValue)
) As TValue

Parameters

key
Type: SystemObject

[Missing <param name="key"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

creator
Type: ActiproSoftware.Text.UtilityPropertyDictionaryCreator TValue

[Missing <param name="creator"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Type Parameters

TValue

[Missing <typeparam name="TValue"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

Return Value

Type: TValue

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.GetOrCreateSingleton``1(System.Object,ActiproSoftware.Text.Utility.PropertyDictionary.Creator{``0})"]

See Also

Reference

PropertyDictionary Class
GetOrCreateSingleton Overload
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Remove Method

PropertyDictionaryRemove Method
Removes the property with the specified key from the dictionary.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    Object key
)
Public Function Remove (
    key As Object
) As Boolean

Parameters

key
Type: SystemObject
The key of the property to remove.

Return Value

Type: Boolean
true if a property was removed; otherwise, false.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.TryGetValue(TValue) Method

PropertyDictionaryTryGetValueTValue Method
Attempts to return the value of the property with the specified key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool TryGetValue<TValue>(
    Object key,
    out TValue value
)

Public Function TryGetValue(Of TValue) (
    key As Object,
    <OutAttribute> ByRef value As TValue
) As Boolean

Parameters

key
Type: SystemObject
The property key for which to search.
value
Type: TValue
Returns the property value.

Type Parameters

TValue
The type of property value.

Return Value

Type: Boolean
true if a value was returned; otherwise, false.
See Also

Reference

PropertyDictionary Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Creator(TValue) Class

PropertyDictionaryCreatorTValue Class
Creates a property value.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.Text.UtilityPropertyDictionaryCreatorTValue

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class Creator<TValue> : MulticastDelegate

Public NotInheritable Class Creator(Of TValue)
    Inherits MulticastDelegate

Type Parameters

TValue
The type of object to create.

Return Value

Type:
The property value that was created.

The PropertyDictionaryCreatorTValue type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDictionaryCreatorTValue | Initializes a new instance of the PropertyDictionaryCreatorTValue class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Creator(TValue) Constructor

PropertyDictionaryCreatorTValue Constructor
Initializes a new instance of the PropertyDictionaryCreatorTValue class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Creator(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

PropertyDictionaryCreatorTValue Class
ActiproSoftware.Text.Utility Namespace


Creator(TValue) Properties

CreatorTValue Properties

The PropertyDictionaryCreatorTValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

PropertyDictionaryCreatorTValue Class
ActiproSoftware.Text.Utility Namespace


Creator(TValue) Methods

CreatorTValue Methods

The PropertyDictionaryCreatorTValue generic type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyDictionaryCreatorTValue Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Creator(TValue).BeginInvoke Method

PropertyDictionaryCreatorTValueBeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.BeginInvoke(System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.BeginInvoke(System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.BeginInvoke(System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.BeginInvoke(System.AsyncCallback,System.Object)"]

See Also

Reference

PropertyDictionaryCreatorTValue Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Creator(TValue).EndInvoke Method

PropertyDictionaryCreatorTValueEndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TValue EndInvoke(
    IAsyncResult result
)
Public Overridable Function EndInvoke (
    result As IAsyncResult
) As TValue

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.EndInvoke(System.IAsyncResult)"]

Return Value

Type: TValue

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.EndInvoke(System.IAsyncResult)"]

See Also

Reference

PropertyDictionaryCreatorTValue Class
ActiproSoftware.Text.Utility Namespace


PropertyDictionary.Creator(TValue).Invoke Method

PropertyDictionaryCreatorTValueInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.Invoke"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TValue Invoke()
Public Overridable Function Invoke As TValue

Return Value

Type: TValue

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.PropertyDictionary.Creator`1.Invoke"]

See Also

Reference

PropertyDictionaryCreatorTValue Class
ActiproSoftware.Text.Utility Namespace


Range Class

Range Class
Represents an ordered pair of min and max values.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.Text.UtilityRange

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class Range : ValueType
Public NotInheritable Class Range
    Inherits ValueType

The Range type exposes the following members.

Constructors
 | Name | Description
Public method | Range(Int32) | Initializes a new instance of the Range class with the specified min and max value.
Public method | Range(Int32, Int32) | Initializes a new instance of the Range class with the specified min and max values.
Top
Properties
 | Name | Description
 | Empty | Returns an empty Range.
Public property | IsEmpty | Returns whether the Range is empty.
Public property | IsNormalized | Gets whether the range is normalized (the maximum value is greater than or equal to the minimum).
Public property | Length | Gets the length of this Range.
Public property | Max | Gets or sets the maximum value of this Range.
Public property | Min | Gets or sets the minimum value of this Range.
Top
Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the range inclusively contains the specified value.
Public method | Contains(Range) | Returns whether the range inclusively contains the specified Range.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith | Returns whether the range intersects with the specified Range.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Normalize | Normalizes the range values (ensures that the maximum value is greater than or equal to the minimum).
Public method | OverlapsWith | Returns whether the Range overlaps with, or crosses, the specified Range.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Union | Changes this Range to be the union of this Range with another Range.
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


Range Constructor

Range Constructor
Overload List
 | Name | Description
Public method | Range(Int32) | Initializes a new instance of the Range class with the specified min and max value.
Public method | Range(Int32, Int32) | Initializes a new instance of the Range class with the specified min and max values.
Top
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range Constructor (Int32)

Range Constructor (Int32)
Initializes a new instance of the Range class with the specified min and max value.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Range(
    int value
)
Public Sub New (
    value As Integer
)

Parameters

value
Type: SystemInt32
The value to use for both the min and max.
See Also

Reference

Range Class
Range Overload
ActiproSoftware.Text.Utility Namespace


Range Constructor (Int32, Int32)

Range Constructor (Int32, Int32)
Initializes a new instance of the Range class with the specified min and max values.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Range(
    int min,
    int max
)
Public Sub New (
    min As Integer,
    max As Integer
)

Parameters

min
Type: SystemInt32
The minimum value of the range.
max
Type: SystemInt32
The maximum value of the range.
See Also

Reference

Range Class
Range Overload
ActiproSoftware.Text.Utility Namespace


Range Properties

Range Properties

The Range type exposes the following members.

Properties
 | Name | Description
 | Empty | Returns an empty Range.
Public property | IsEmpty | Returns whether the Range is empty.
Public property | IsNormalized | Gets whether the range is normalized (the maximum value is greater than or equal to the minimum).
Public property | Length | Gets the length of this Range.
Public property | Max | Gets or sets the maximum value of this Range.
Public property | Min | Gets or sets the minimum value of this Range.
Top
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Empty Property

RangeEmpty Property
Returns an empty Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Range Empty { get; }
Public Shared ReadOnly Property Empty As Range
    Get

Property Value

Type: Range
A Range that is empty.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.IsEmpty Property

RangeIsEmpty Property
Returns whether the Range is empty.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if the Range is empty; otherwise, false.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.IsNormalized Property

RangeIsNormalized Property
Gets whether the range is normalized (the maximum value is greater than or equal to the minimum).

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNormalized { get; }
Public ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the range is normalized; otherwise, false.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Length Property

RangeLength Property
Gets the length of this Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The length of this Range.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Max Property

RangeMax Property
Gets or sets the maximum value of this Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set

Property Value

Type: Int32
The maximum value of this Range.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Min Property

RangeMin Property
Gets or sets the minimum value of this Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set

Property Value

Type: Int32
The minimum value of this Range.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range Methods

Range Methods

The Range type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Int32) | Returns whether the range inclusively contains the specified value.
Public method | Contains(Range) | Returns whether the range inclusively contains the specified Range.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Public method | IntersectsWith | Returns whether the range intersects with the specified Range.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Normalize | Normalizes the range values (ensures that the maximum value is greater than or equal to the minimum).
Public method | OverlapsWith | Returns whether the Range overlaps with, or crosses, the specified Range.
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Public method | Union | Changes this Range to be the union of this Range with another Range.
Top
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Contains Method

RangeContains Method
Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the range inclusively contains the specified value.
Public method | Contains(Range) | Returns whether the range inclusively contains the specified Range.
Top
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Contains Method (Int32)

RangeContains Method (Int32)
Returns whether the range inclusively contains the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int value
)
Public Function Contains (
    value As Integer
) As Boolean

Parameters

value
Type: SystemInt32
The value to check.

Return Value

Type: Boolean
true if the range inclusively contains the specified value; otherwise, false.
See Also

Reference

Range Class
Contains Overload
ActiproSoftware.Text.Utility Namespace


Range.Contains Method (Range)

RangeContains Method (Range)
Returns whether the range inclusively contains the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    Range range
)
Public Function Contains (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to check.

Return Value

Type: Boolean
true if the range inclusively contains the specified Range; otherwise, false.
See Also

Reference

Range Class
Contains Overload
ActiproSoftware.Text.Utility Namespace


Range.Equals Method

RangeEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.GetHashCode Method

RangeGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.IntersectsWith Method

RangeIntersectsWith Method
Returns whether the range intersects with the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IntersectsWith(
    Range range
)
Public Function IntersectsWith (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to check.

Return Value

Type: Boolean
true if the range intersects with the specified Range; otherwise, false.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Normalize Method

RangeNormalize Method
Normalizes the range values (ensures that the maximum value is greater than or equal to the minimum).

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Normalize()
Public Sub Normalize
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.OverlapsWith Method

RangeOverlapsWith Method
Returns whether the Range overlaps with, or crosses, the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    Range range
)
Public Function OverlapsWith (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to examine.

Return Value

Type: Boolean
true if the Range overlaps with, or crosses, the specified Range; otherwise, false.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.ToString Method

RangeToString Method
Converts the object to a String.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Union Method

RangeUnion Method
Changes this Range to be the union of this Range with another Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Union(
    Range range
)
Public Sub Union (
    range As Range
)

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range with which to merge.
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range Operators

Range Operators

The Range type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Equality Operator

RangeEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    Range left,
    Range right
)
Public Shared Operator = (
    left As Range,
    right As Range
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

right
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Equality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


Range.Inequality Operator

RangeInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    Range left,
    Range right
)
Public Shared Operator <> (
    left As Range,
    right As Range
) As Boolean

Parameters

left
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="left"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

right
Type: ActiproSoftware.Text.UtilityRange

[Missing <param name="right"/> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.Range.op_Inequality(ActiproSoftware.Text.Utility.Range,ActiproSoftware.Text.Utility.Range)"]

See Also

Reference

Range Class
ActiproSoftware.Text.Utility Namespace


RangeCollection Class

RangeCollection Class
Provides an implementation of a collection of Range objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityRangeCollection

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RangeCollection : IEnumerable<Range>,
    IEnumerable
Public Class RangeCollection
    Implements IEnumerable(Of Range), IEnumerable

The RangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | RangeCollection | Initializes a new instance of the RangeCollection class.
Public method | RangeCollection(String) | Initializes a new instance of the RangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the RangeCollection class.
Public property | Key | Gets a unique string key that identifies the collection instance.
Top
Methods
 | Name | Description
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Clear | Removes all elements in this collection.
Public method | Contains | Returns whether the specified value is in the contained ranges.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the range that contains the specified value.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Merge | Merges the specified Range into the collection.
Public method | OverlapsWith | Returns whether the specified Range overlaps with a Range in the list.
Public method | ToString | (Inherited from Object.)
Public method | Unmerge | Removes any range portions that cross the specified Range.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


RangeCollection Constructor

RangeCollection Constructor
Overload List
 | Name | Description
Public method | RangeCollection | Initializes a new instance of the RangeCollection class.
Public method | RangeCollection(String) | Initializes a new instance of the RangeCollection class.
Top
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection Constructor

RangeCollection Constructor
Initializes a new instance of the RangeCollection class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeCollection()
Public Sub New
See Also

Reference

RangeCollection Class
RangeCollection Overload
ActiproSoftware.Text.Utility Namespace


RangeCollection Constructor (String)

RangeCollection Constructor (String)
Initializes a new instance of the RangeCollection class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RangeCollection(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
A unique string key that identifies the collection instance.
See Also

Reference

RangeCollection Class
RangeCollection Overload
ActiproSoftware.Text.Utility Namespace


RangeCollection Properties

RangeCollection Properties

The RangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the interval at the specified index. [C#] In C#, this property is the indexer for the RangeCollection class.
Public property | Key | Gets a unique string key that identifies the collection instance.
Top
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Count Property

RangeCollectionCount Property
Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Item Property

RangeCollectionItem Property
Gets the interval at the specified index.

[C#] In C#, this property is the indexer for the RangeCollection class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Range this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As Range
    Get

Parameters

index
Type: SystemInt32
The index of the interval to return.

Property Value

Type: Range
The Range at the specified index.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Key Property

RangeCollectionKey Property
Gets a unique string key that identifies the collection instance.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
A unique string key that identifies the collection instance.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection Methods

RangeCollection Methods

The RangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | BinarySearch | Performs a binary search for the specified value.
Public method | Clear | Removes all elements in this collection.
Public method | Contains | Returns whether the specified value is in the contained ranges.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index of the range that contains the specified value.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Merge | Merges the specified Range into the collection.
Public method | OverlapsWith | Returns whether the specified Range overlaps with a Range in the list.
Public method | ToString | (Inherited from Object.)
Public method | Unmerge | Removes any range portions that cross the specified Range.
Top
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.BinarySearch Method

RangeCollectionBinarySearch Method
Performs a binary search for the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int BinarySearch(
    int value
)
Public Function BinarySearch (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The value for which to search.

Return Value

Type: Int32
The index of the specified value in the specified array, if value is found. If value is not found and value is less than one or more elements in array, a negative number which is the bitwise complement of the index of the first element that is larger than value. If value is not found and value is greater than any of the elements in array, a negative number which is the bitwise complement of (the index of the last element plus 1).
Remarks
This method should only be used if the integers in the list are guaranteed to be sorted.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Clear Method

RangeCollectionClear Method
Removes all elements in this collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Contains Method

RangeCollectionContains Method
Returns whether the specified value is in the contained ranges.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    int value
)
Public Function Contains (
    value As Integer
) As Boolean

Parameters

value
Type: SystemInt32
The values for which to search.

Return Value

Type: Boolean
true if the specified value is in the contained ranges; otherwise, false.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.CopyTo Method

RangeCollectionCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    Range[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Range(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.Text.UtilityRange
The one-dimensional Range array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.GetEnumerator Method

RangeCollectionGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<Range> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Range)

Return Value

Type: IEnumerator Range
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.IndexOf Method

RangeCollectionIndexOf Method
Returns the index of the range that contains the specified value.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    int value
)
Public Function IndexOf (
    value As Integer
) As Integer

Parameters

value
Type: SystemInt32
The values for which to search.

Return Value

Type: Int32
The index of the range that contains the specified value, or -1 if not found.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Merge Method

RangeCollectionMerge Method
Merges the specified Range into the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Range[] Merge(
    Range range
)
Public Function Merge (
    range As Range
) As Range()

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to merge.

Return Value

Type: Range
The array of Range objects in which a merge was made.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.OverlapsWith Method

RangeCollectionOverlapsWith Method
Returns whether the specified Range overlaps with a Range in the list.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    Range range
)
Public Function OverlapsWith (
    range As Range
) As Boolean

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to examine.

Return Value

Type: Boolean
true if the specified Range overlaps with a Range in the list; otherwise, false.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


RangeCollection.Unmerge Method

RangeCollectionUnmerge Method
Removes any range portions that cross the specified Range.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Range[] Unmerge(
    Range range
)
Public Function Unmerge (
    range As Range
) As Range()

Parameters

range
Type: ActiproSoftware.Text.UtilityRange
The Range to remove.

Return Value

Type: Range
The array of Range objects in which a merge was made.
See Also

Reference

RangeCollection Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Class

SimpleObservableCollectionT Class
Provides a generic collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollectionT
ActiproSoftware.Text.Analysis.ImplementationStructureMatchResultCollection
ActiproSoftware.Text.Lexing.ImplementationLexicalScopeCollection
ActiproSoftware.Text.Searching.ImplementationSearchPatternProviderCollection
ActiproSoftware.Text.UtilityKeyedObservableCollectionT
ActiproSoftware.Text.UtilitySimpleSynchronizedCollectionT

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleObservableCollection<T> : Collection<T>
where T : class

Public Class SimpleObservableCollection(Of T As Class)
    Inherits Collection(Of T)

Type Parameters

T
The type of collection item.

The SimpleObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleObservableCollectionT | Initializes a new instance of the SimpleObservableCollectionT class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified.
Public property | Item | (Inherited from Collection T.)
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection.
Protected method | CheckReadOnly | Throws an exception if the collection is read-only.
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection.
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides CollectionTClearItems.)
Public method | Contains | (Inherited from Collection T.)
Public method | CopyTo | (Inherited from Collection T.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T.)
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection.
Protected method | OnItemAdding | Called before an item as been added into the collection.
Protected method | OnItemRemoved | Called after an item has been removed from the collection.
Protected method | OnItemRemoving | Called before an item has been removed from the collection.
Public method | Remove | (Inherited from Collection T.)
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Constructor

SimpleObservableCollectionT Constructor
Initializes a new instance of the SimpleObservableCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleObservableCollection()
Public Sub New
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Properties

SimpleObservableCollectionT Properties

The SimpleObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified.
Public property | Item | (Inherited from Collection T .)
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).IsReadOnly Property

SimpleObservableCollectionTIsReadOnly Property
Gets whether the collection is allowed to be modified.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is allowed to be modified; otherwise, false.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Methods

SimpleObservableCollectionT Methods

The SimpleObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection.
Protected method | CheckReadOnly | Throws an exception if the collection is read-only.
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection.
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides CollectionTClearItems.)
Public method | Contains | (Inherited from Collection T .)
Public method | CopyTo | (Inherited from Collection T .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T .)
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection.
Protected method | OnItemAdding | Called before an item as been added into the collection.
Protected method | OnItemRemoved | Called after an item has been removed from the collection.
Protected method | OnItemRemoving | Called before an item has been removed from the collection.
Public method | Remove | (Inherited from Collection T .)
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).BlockReentrancy Method

SimpleObservableCollectionTBlockReentrancy Method
Disallows reentrant attempts to change this collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IDisposable BlockReentrancy()
Protected Function BlockReentrancy As IDisposable

Return Value

Type: IDisposable
An IDisposable object that can be used to dispose of the object.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).CheckReadOnly Method

SimpleObservableCollectionTCheckReadOnly Method
Throws an exception if the collection is read-only.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void CheckReadOnly()
Protected Overridable Sub CheckReadOnly
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).CheckReentrancy Method

SimpleObservableCollectionTCheckReentrancy Method
Checks for reentrant attempts to change this collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void CheckReentrancy()
Protected Sub CheckReentrancy
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ClearItems Method

SimpleObservableCollectionTClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).InsertItem Method

SimpleObservableCollectionTInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which to insert the item.
item
Type: T
The item to insert.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemAdded Method

SimpleObservableCollectionTOnItemAdded Method
Called after an item as been added into the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemAdded(
    int index,
    T value
)
Protected Overridable Sub OnItemAdded (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: T
The item that is added.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemAdding Method

SimpleObservableCollectionTOnItemAdding Method
Called before an item as been added into the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemAdding(
    int index,
    T value
)
Protected Overridable Sub OnItemAdding (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is added.
value
Type: T
The item that is added.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemRemoved Method

SimpleObservableCollectionTOnItemRemoved Method
Called after an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemRemoved(
    int index,
    T value
)
Protected Overridable Sub OnItemRemoved (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: T
The item that is removed.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).OnItemRemoving Method

SimpleObservableCollectionTOnItemRemoving Method
Called before an item has been removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemRemoving(
    int index,
    T value
)
Protected Overridable Sub OnItemRemoving (
    index As Integer,
    value As T
)

Parameters

index
Type: SystemInt32
The index at which the item is removed.
value
Type: T
The item that is removed.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).RemoveItem Method

SimpleObservableCollectionTRemoveItem Method
Removes the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).SetItem Method

SimpleObservableCollectionTSetItem Method
Replaces the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index of the item to replace.
item
Type: T
The item with which to replace.
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T) Events

SimpleObservableCollectionT Events

The SimpleObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection.
Public event | ItemAdding | Occurs before an item is added to the collection.
Public event | ItemRemoved | Occurs after an item is removed from the collection.
Public event | ItemRemoving | Occurs before an item is removed from the collection.
Top
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemAdded Event

SimpleObservableCollectionTItemAdded Event
Occurs after an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemAdded
Public Event ItemAdded As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemAdding Event

SimpleObservableCollectionTItemAdding Event
Occurs before an item is added to the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemAdding
Public Event ItemAdding As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemRemoved Event

SimpleObservableCollectionTItemRemoved Event
Occurs after an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemRemoved
Public Event ItemRemoved As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleObservableCollection(T).ItemRemoving Event

SimpleObservableCollectionTItemRemoving Event
Occurs before an item is removed from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CollectionChangeEventArgs<T>> ItemRemoving
Public Event ItemRemoving As EventHandler(Of CollectionChangeEventArgs(Of T))

Value

Type: SystemEventHandler CollectionChangeEventArgs T
See Also

Reference

SimpleObservableCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Class

SimpleSynchronizedCollectionT Class
Provides a thread-safe generic collection that provides notifications when items are added or removed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
ActiproSoftware.Text.UtilitySimpleObservableCollection T
ActiproSoftware.Text.UtilitySimpleSynchronizedCollectionT

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleSynchronizedCollection<T> : SimpleObservableCollection<T>
where T : class

Public Class SimpleSynchronizedCollection(Of T As Class)
    Inherits SimpleObservableCollection(Of T)

Type Parameters

T
The type of collection item.

The SimpleSynchronizedCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleSynchronizedCollectionT | Initializes a new instance of the SimpleSynchronizedCollectionT class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | (Inherited from Collection T.)
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection T.)
Public method | CopyTo | (Inherited from Collection T.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T.)
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | (Inherited from Collection T.)
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Constructor

SimpleSynchronizedCollectionT Constructor
Initializes a new instance of the SimpleSynchronizedCollectionT class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleSynchronizedCollection()
Public Sub New
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Properties

SimpleSynchronizedCollectionT Properties

The SimpleSynchronizedCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsReadOnly | Gets whether the collection is allowed to be modified. (Inherited from SimpleObservableCollectionT.)
Public property | Item | (Inherited from Collection T .)
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Methods

SimpleSynchronizedCollectionT Methods

The SimpleSynchronizedCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReadOnly | Throws an exception if the collection is read-only. (Inherited from SimpleObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from SimpleObservableCollectionT.)
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides SimpleObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection T .)
Public method | CopyTo | (Inherited from Collection T .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T .)
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides SimpleObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnItemAdded | Called after an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemAdding | Called before an item as been added into the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoved | Called after an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Protected method | OnItemRemoving | Called before an item has been removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public method | Remove | (Inherited from Collection T .)
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index. (Overrides SimpleObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the item at the specified index. (Overrides SimpleObservableCollectionTSetItem(Int32, T).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).ClearItems Method

SimpleSynchronizedCollectionTClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).InsertItem Method

SimpleSynchronizedCollectionTInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index at which to insert the item.
item
Type: T
The item to insert.
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).RemoveItem Method

SimpleSynchronizedCollectionTRemoveItem Method
Removes the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index of the item to remove.
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T).SetItem Method

SimpleSynchronizedCollectionTSetItem Method
Replaces the item at the specified index.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The index of the item to replace.
item
Type: T
The item with which to replace.
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


SimpleSynchronizedCollection(T) Events

SimpleSynchronizedCollectionT Events

The SimpleSynchronizedCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | ItemAdded | Occurs after an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemAdding | Occurs before an item is added to the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoved | Occurs after an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Public event | ItemRemoving | Occurs before an item is removed from the collection. (Inherited from SimpleObservableCollectionT.)
Top
See Also

Reference

SimpleSynchronizedCollectionT Class
ActiproSoftware.Text.Utility Namespace


StringHelper Class

StringHelper Class
Provides numerous utility methods for working with strings.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityStringHelper

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class StringHelper
Public NotInheritable Class StringHelper

The StringHelper type exposes the following members.

Methods
Name | Description
ContainsRtlCharacters | Returns whether the specified text string contains any right-to-left characters.
CreateDescription | Returns a description from a key.
GetIndentAmount | Returns the indent amount of the specified text.
GetIndentText | Returns the string to use for indenting by the specified amount.
GetLineTerminatorText | Returns the text representation of the specified LineTerminator.
IsRtlCharacter | Returns whether the specified character is a right-to-left character.
TrimTrailingWhitespace | Trims the trailing whitespace off of the specified text.
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


StringHelper Methods

StringHelper Methods

The StringHelper type exposes the following members.

Methods
Name | Description
ContainsRtlCharacters | Returns whether the specified text string contains any right-to-left characters.
CreateDescription | Returns a description from a key.
GetIndentAmount | Returns the indent amount of the specified text.
GetIndentText | Returns the string to use for indenting by the specified amount.
GetLineTerminatorText | Returns the text representation of the specified LineTerminator.
IsRtlCharacter | Returns whether the specified character is a right-to-left character.
TrimTrailingWhitespace | Trims the trailing whitespace off of the specified text.
Top
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.ContainsRtlCharacters Method

StringHelperContainsRtlCharacters Method
Returns whether the specified text string contains any right-to-left characters.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool ContainsRtlCharacters(
    string text
)
Public Shared Function ContainsRtlCharacters (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The string to examine.

Return Value

Type: Boolean
true if the string contains any right-to-left characters; otherwise, false.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.CreateDescription Method

StringHelperCreateDescription Method
Returns a description from a key.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string CreateDescription(
    string key
)
Public Shared Function CreateDescription (
    key As String
) As String

Parameters

key
Type: SystemString
The key to examine.

Return Value

Type: String
The description that was created.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetIndentAmount Method

StringHelperGetIndentAmount Method
Returns the indent amount of the specified text.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static int GetIndentAmount(
    string text,
    int tabSize
)
Public Shared Function GetIndentAmount (
    text As String,
    tabSize As Integer
) As Integer

Parameters

text
Type: SystemString
The text to examine.
tabSize
Type: SystemInt32
The tab size.

Return Value

Type: Int32
The indent amount of the specified text.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetIndentText Method

StringHelperGetIndentText Method
Returns the string to use for indenting by the specified amount.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string GetIndentText(
    bool convertTabsToSpaces,
    int tabSize,
    int indentAmount
)
Public Shared Function GetIndentText (
    convertTabsToSpaces As Boolean,
    tabSize As Integer,
    indentAmount As Integer
) As String

Parameters

convertTabsToSpaces
Type: SystemBoolean
Whether to convert tabs to spaces.
tabSize
Type: SystemInt32
The number of columns in a tab.
indentAmount
Type: SystemInt32
The number of columns to indent.

Return Value

Type: String
The string to use for indenting by the specified amount.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.GetLineTerminatorText Method

StringHelperGetLineTerminatorText Method
Returns the text representation of the specified LineTerminator.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static string GetLineTerminatorText(
    LineTerminator lineTerminator
)
Public Shared Function GetLineTerminatorText (
    lineTerminator As LineTerminator
) As String

Parameters

lineTerminator
Type: ActiproSoftware.TextLineTerminator
The LineTerminator to examine.

Return Value

Type: String
The text representation of the specified LineTerminator.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.IsRtlCharacter Method

StringHelperIsRtlCharacter Method
Returns whether the specified character is a right-to-left character.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool IsRtlCharacter(
    char ch
)
Public Shared Function IsRtlCharacter (
    ch As Char
) As Boolean

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: Boolean
true if the specified character is a right-to-left character; otherwise, false.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringHelper.TrimTrailingWhitespace Method

StringHelperTrimTrailingWhitespace Method
Trims the trailing whitespace off of the specified text.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool TrimTrailingWhitespace(
    ref string text
)
Public Shared Function TrimTrailingWhitespace (
    ByRef text As String
) As Boolean

Parameters

text
Type: SystemString
The text to modify.

Return Value

Type: Boolean
true if a change was made; otherwise, false.
See Also

Reference

StringHelper Class
ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Class

StringPropertyChangedEventArgs Class
Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.Text.UtilityPropertyChangedEventArgs String
ActiproSoftware.Text.UtilityStringPropertyChangedEventArgs

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StringPropertyChangedEventArgs : PropertyChangedEventArgs<string>
Public Class StringPropertyChangedEventArgs
    Inherits PropertyChangedEventArgs(Of String)

The StringPropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyChangedEventArgs | Initializes a new instance of the StringPropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Constructor

StringPropertyChangedEventArgs Constructor
Initializes a new instance of the StringPropertyChangedEventArgs class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StringPropertyChangedEventArgs(
    string oldValue,
    string newValue
)
Public Sub New (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The previous value of the property being tracked as reported by an event.
newValue
Type: SystemString
The new value of the property being tracked as reported by an event.
See Also

Reference

StringPropertyChangedEventArgs Class
ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Properties

StringPropertyChangedEventArgs Properties

The StringPropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

StringPropertyChangedEventArgs Class
ActiproSoftware.Text.Utility Namespace


StringPropertyChangedEventArgs Methods

StringPropertyChangedEventArgs Methods

The StringPropertyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StringPropertyChangedEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Class

WeakEventListenerTInstance, TEventArgs Class
Provides a listener that allows for "weak" listening to events.
Inheritance Hierarchy
SystemObject
ActiproSoftware.Text.UtilityWeakEventListenerTInstance, TEventArgs

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WeakEventListener<TInstance, TEventArgs>
where TInstance : class
where TEventArgs : EventArgs

Public Class WeakEventListener(Of TInstance As Class, TEventArgs As EventArgs)

Type Parameters

TInstance
The instance type that owns the listener.
TEventArgs
The event arguments type.

The WeakEventListenerTInstance, TEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WeakEventListenerTInstance, TEventArgs(TInstance) | Initializes a new instance of the WeakEventListener class.
Public method | WeakEventListenerTInstance, TEventArgs(TInstance, WeakEventListenerTInstance, TEventArgsEventActionTInstance, Object, TEventArgs, ActionWeakEventListenerTInstance, TEventArgs) | Initializes a new instance of the WeakEventListenerTInstance, TEventArgs class
Top
Properties
 | Name | Description
Public property | OnDetachAction | Gets or sets the delegate to execute when the event is detached.
Public property | OnEventAction | Gets or sets the delegate to execute when the event is raised.
Top
Methods
 | Name | Description
Public method | Detach | Detaches the event listener from the event.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnEvent | The method that handles the event.
Public method | ToString | (Inherited from Object.)
Top
Remarks
Make sure that only variables (i.e. not fields) for the event source are used when adding/removing event ties; otherwise this will not result in a "weak" listener. The instance type should also be disposable and should detach the event listener in the finalizer or a memory leak of WeakEventListener objects may occur.
See Also

Reference

ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Constructor

WeakEventListenerTInstance, TEventArgs Constructor
Overload List
 | Name | Description
Public method | WeakEventListenerTInstance, TEventArgs(TInstance) | Initializes a new instance of the WeakEventListener class.
Public method | WeakEventListenerTInstance, TEventArgs(TInstance, WeakEventListenerTInstance, TEventArgsEventActionTInstance, Object, TEventArgs, ActionWeakEventListenerTInstance, TEventArgs) | Initializes a new instance of the WeakEventListenerTInstance, TEventArgs class
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Constructor (TInstance)

WeakEventListenerTInstance, TEventArgs Constructor (TInstance)
Initializes a new instance of the WeakEventListener class.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WeakEventListener(
    TInstance instance
)
Public Sub New (
    instance As TInstance
)

Parameters

instance
Type: TInstance
The instance that owns the listener.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
WeakEventListenerTInstance, TEventArgs Overload
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Constructor (TInstance, WeakEventListener(TInstance, TEventArgs).EventAction(TInstance, Object, TEventArgs), Action(WeakEventListener(TInstance, TEventArgs)))

WeakEventListenerTInstance, TEventArgs Constructor (TInstance, WeakEventListenerTInstance, TEventArgsEventActionTInstance, Object, TEventArgs, ActionWeakEventListenerTInstance, TEventArgs)
Initializes a new instance of the WeakEventListenerTInstance, TEventArgs class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WeakEventListener(
    TInstance instance,
    WeakEventListenerTInstance, TEventArgsEventAction<TInstance, Object, TEventArgs> onEventAction,
    Action<WeakEventListener<TInstance, TEventArgs>> onDetachAction
)
Public Sub New (
    instance As TInstance,
    onEventAction As WeakEventListenerTInstance, TEventArgsEventAction(Of TInstance, Object, TEventArgs),
    onDetachAction As Action(Of WeakEventListener(Of TInstance, TEventArgs))
)

Parameters

instance
Type: TInstance

[Missing <param name="instance"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.#ctor(`0,ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}.EventAction{`0,System.Object,`1},System.Action{ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}})"]

onEventAction
Type: ActiproSoftware.Text.UtilityWeakEventListenerTInstance, TEventArgsEventAction TInstance, Object, TEventArgs

[Missing <param name="onEventAction"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.#ctor(`0,ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}.EventAction{`0,System.Object,`1},System.Action{ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}})"]

onDetachAction
Type: SystemAction WeakEventListener TInstance, TEventArgs

[Missing <param name="onDetachAction"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.#ctor(`0,ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}.EventAction{`0,System.Object,`1},System.Action{ActiproSoftware.Text.Utility.WeakEventListener{`0,`1}})"]

See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
WeakEventListenerTInstance, TEventArgs Overload
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Properties

WeakEventListenerTInstance, TEventArgs Properties

The WeakEventListenerTInstance, TEventArgs generic type exposes the following members.

Properties
 | Name | Description
Public property | OnDetachAction | Gets or sets the delegate to execute when the event is detached.
Public property | OnEventAction | Gets or sets the delegate to execute when the event is raised.
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).OnDetachAction Property

WeakEventListenerTInstance, TEventArgsOnDetachAction Property
Gets or sets the delegate to execute when the event is detached.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Action<WeakEventListener<TInstance, TEventArgs>> OnDetachAction { get; set; }
Public Property OnDetachAction As Action(Of WeakEventListener(Of TInstance, TEventArgs))
    Get
    Set

Property Value

Type: Action WeakEventListener TInstance, TEventArgs
The delegate to execute when the event is detached.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).OnEventAction Property

WeakEventListenerTInstance, TEventArgsOnEventAction Property
Gets or sets the delegate to execute when the event is raised.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WeakEventListenerTInstance, TEventArgsEventAction<TInstance, Object, TEventArgs> OnEventAction { get; set; }
Public Property OnEventAction As WeakEventListenerTInstance, TEventArgsEventAction(Of TInstance, Object, TEventArgs)
    Get
    Set

Property Value

Type: WeakEventListenerTInstance, TEventArgsEventAction TInstance, Object, TEventArgs
The delegate to execute when the event is raised.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs) Methods

WeakEventListenerTInstance, TEventArgs Methods

The WeakEventListenerTInstance, TEventArgs generic type exposes the following members.

Methods
 | Name | Description
Public method | Detach | Detaches the event listener from the event.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnEvent | The method that handles the event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).Detach Method

WeakEventListenerTInstance, TEventArgsDetach Method
Detaches the event listener from the event.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Detach()
Public Sub Detach
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).OnEvent Method

WeakEventListenerTInstance, TEventArgsOnEvent Method
The method that handles the event.

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void OnEvent(
    Object source,
    TEventArgs eventArgs
)
Public Sub OnEvent (
    source As Object,
    eventArgs As TEventArgs
)

Parameters

source
Type: SystemObject
The source of the event.
eventArgs
Type: TEventArgs
The event arguments.
See Also

Reference

WeakEventListenerTInstance, TEventArgs Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).EventAction(T1, T2, T3) Class

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
Provides the delegate for an event action.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.Text.UtilityWeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EventAction<T1, T2, T3> : MulticastDelegate

Public NotInheritable Class EventAction(Of T1, T2, T3)
    Inherits MulticastDelegate

Type Parameters

T1
The first parameter type.
T2
The second parameter type.
T3
The third parameter type.

The WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 generic type exposes the following members.

Constructors
 | Name | Description
Public method | WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 | Initializes a new instance of the WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).EventAction(T1, T2, T3) Constructor

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Constructor
Initializes a new instance of the WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 class

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EventAction(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
ActiproSoftware.Text.Utility Namespace


EventAction(T1, T2, T3) Properties

EventActionT1, T2, T3 Properties

The WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 generic type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
ActiproSoftware.Text.Utility Namespace


EventAction(T1, T2, T3) Methods

EventActionT1, T2, T3 Methods

The WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 generic type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).EventAction(T1, T2, T3).BeginInvoke Method

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3BeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    T1 arg1,
    T2 arg2,
    T3 arg3,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    arg1 As T1,
    arg2 As T2,
    arg3 As T3,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

arg1
Type: T1

[Missing <param name="arg1"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

arg2
Type: T2

[Missing <param name="arg2"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

arg3
Type: T3

[Missing <param name="arg3"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.BeginInvoke(`2,`3,`4,System.AsyncCallback,System.Object)"]

See Also

Reference

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).EventAction(T1, T2, T3).EndInvoke Method

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3EndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void EndInvoke(
    IAsyncResult result
)
Public Overridable Sub EndInvoke (
    result As IAsyncResult
)

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.EndInvoke(System.IAsyncResult)"]

See Also

Reference

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
ActiproSoftware.Text.Utility Namespace


WeakEventListener(TInstance, TEventArgs).EventAction(T1, T2, T3).Invoke Method

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3Invoke Method

[Missing <summary> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.Invoke(`2,`3,`4)"]

Namespace: ActiproSoftware.Text.Utility
Assembly: AS.Text.Universal (in AS.Text.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Invoke(
    T1 arg1,
    T2 arg2,
    T3 arg3
)
Public Overridable Sub Invoke (
    arg1 As T1,
    arg2 As T2,
    arg3 As T3
)

Parameters

arg1
Type: T1

[Missing <param name="arg1"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.Invoke(`2,`3,`4)"]

arg2
Type: T2

[Missing <param name="arg2"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.Invoke(`2,`3,`4)"]

arg3
Type: T3

[Missing <param name="arg3"/> documentation for "M:ActiproSoftware.Text.Utility.WeakEventListener`2.EventAction`3.Invoke(`2,`3,`4)"]

See Also

Reference

WeakEventListenerTInstance, TEventArgsEventActionT1, T2, T3 Class
ActiproSoftware.Text.Utility Namespace


ActiproSoftware.Themes Namespace

ActiproSoftware.Themes Namespace

[Missing <summary> documentation for "N:ActiproSoftware.Themes"]

Classes
 | Class | Description
Public class | GridsCellTemplates | Represents a [!:ResourceDictionary] related to the property editors defined in this assembly.


GridsCellTemplates Class

GridsCellTemplates Class
Represents a [!:ResourceDictionary] related to the property editors defined in this assembly.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlResourceDictionary
ActiproSoftware.ThemesGridsCellTemplates

Namespace: ActiproSoftware.Themes
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GridsCellTemplates : ResourceDictionary,
    IComponentConnector, IComponentConnector2
Public Class GridsCellTemplates
    Inherits ResourceDictionary
    Implements IComponentConnector, IComponentConnector2

The GridsCellTemplates type exposes the following members.

Constructors
 | Name | Description
Public method | GridsCellTemplates | Initializes a new instance of the GridsCellTemplates class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Size | Gets the number of elements contained in the collection. (Inherited from ResourceDictionary.)
Public property | Source | Gets or sets a Uniform Resource Identifier (URI) that provides the source location of a merged resource dictionary. (Inherited from ResourceDictionary.)
Public property | ThemeDictionaries | Gets a collection of merged resource dictionaries that are specifically keyed and composed to address theme scenarios, for example supplying theme values for HighContrast. (Inherited from ResourceDictionary.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all items from this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Connect | Connect()
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | First | Returns an iterator for the items in the collection. (Inherited from ResourceDictionary.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingConnector |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | GetView | Retrieves a view against the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | HasKey | Returns whether the ResourceDictionary has an entry with the requested key. (Inherited from ResourceDictionary.)
Public method | InitializeComponent | InitializeComponent()
Public method | Insert | Adds a new entry to the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Lookup | Returns the value from the requested key, if an entry with that key exists. (Inherited from ResourceDictionary.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | Remove | Removes a specific item from the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.Themes Namespace


GridsCellTemplates Constructor

GridsCellTemplates Constructor
Initializes a new instance of the GridsCellTemplates class

Namespace: ActiproSoftware.Themes
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridsCellTemplates()
Public Sub New
See Also

Reference

GridsCellTemplates Class
ActiproSoftware.Themes Namespace


GridsCellTemplates Properties

GridsCellTemplates Properties

The GridsCellTemplates type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Size | Gets the number of elements contained in the collection. (Inherited from ResourceDictionary.)
Public property | Source | Gets or sets a Uniform Resource Identifier (URI) that provides the source location of a merged resource dictionary. (Inherited from ResourceDictionary.)
Public property | ThemeDictionaries | Gets a collection of merged resource dictionaries that are specifically keyed and composed to address theme scenarios, for example supplying theme values for HighContrast. (Inherited from ResourceDictionary.)
Top
See Also

Reference

GridsCellTemplates Class
ActiproSoftware.Themes Namespace


GridsCellTemplates Methods

GridsCellTemplates Methods

The GridsCellTemplates type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all items from this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Connect | Connect()
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | First | Returns an iterator for the items in the collection. (Inherited from ResourceDictionary.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingConnector |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | GetView | Retrieves a view against the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | HasKey | Returns whether the ResourceDictionary has an entry with the requested key. (Inherited from ResourceDictionary.)
Public method | InitializeComponent | InitializeComponent()
Public method | Insert | Adds a new entry to the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Lookup | Returns the value from the requested key, if an entry with that key exists. (Inherited from ResourceDictionary.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | Remove | Removes a specific item from the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

GridsCellTemplates Class
ActiproSoftware.Themes Namespace


GridsCellTemplates.Connect Method

GridsCellTemplatesConnect Method
Connect()

Namespace: ActiproSoftware.Themes
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Connect(
    int connectionId,
    Object target
)
Public Sub Connect (
    connectionId As Integer,
    target As Object
)

Parameters

connectionId
Type: SystemInt32

[Missing <param name="connectionId"/> documentation for "M:ActiproSoftware.Themes.GridsCellTemplates.Connect(System.Int32,System.Object)"]

target
Type: SystemObject

[Missing <param name="target"/> documentation for "M:ActiproSoftware.Themes.GridsCellTemplates.Connect(System.Int32,System.Object)"]

Implements

IComponentConnectorConnect(Int32, Object)
See Also

Reference

GridsCellTemplates Class
ActiproSoftware.Themes Namespace


GridsCellTemplates.GetBindingConnector Method

GridsCellTemplatesGetBindingConnector Method

[Missing <summary> documentation for "M:ActiproSoftware.Themes.GridsCellTemplates.GetBindingConnector(System.Int32,System.Object)"]

Namespace: ActiproSoftware.Themes
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IComponentConnector GetBindingConnector(
    int connectionId,
    Object target
)
Public Function GetBindingConnector (
    connectionId As Integer,
    target As Object
) As IComponentConnector

Parameters

connectionId
Type: SystemInt32

[Missing <param name="connectionId"/> documentation for "M:ActiproSoftware.Themes.GridsCellTemplates.GetBindingConnector(System.Int32,System.Object)"]

target
Type: SystemObject

[Missing <param name="target"/> documentation for "M:ActiproSoftware.Themes.GridsCellTemplates.GetBindingConnector(System.Int32,System.Object)"]

Return Value

Type: IComponentConnector

[Missing <returns> documentation for "M:ActiproSoftware.Themes.GridsCellTemplates.GetBindingConnector(System.Int32,System.Object)"]

Implements

IComponentConnector2GetBindingConnector(Int32, Object)
See Also

Reference

GridsCellTemplates Class
ActiproSoftware.Themes Namespace


GridsCellTemplates.InitializeComponent Method

GridsCellTemplatesInitializeComponent Method
InitializeComponent()

Namespace: ActiproSoftware.Themes
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void InitializeComponent()
Public Sub InitializeComponent
See Also

Reference

GridsCellTemplates Class
ActiproSoftware.Themes Namespace


ActiproSoftware.UI.Xaml Namespace

ActiproSoftware.UI.Xaml Namespace
Contains some core classes used throughout various products.
Classes
 | Class | Description
Public class | CancelableEventArgs | Provides cancelable event arguments.
Public class | DateRange | Represents a date range, which is an inclusive pair of DateTime objects representing dates.
Public class | DateRangeCollection | Represents a collection of DateRange objects.
Public class | DayOfWeekFormatPattern | Specifies various format patterns for a DayOfWeek value.
Public class | DeferrableObservableCollectionT | Provides an ObservableCollectionT that is capable of suspending its property change notifications until a bulk update is complete.
Public class | ObservableObjectBase | A simple object that implements INotifyPropertyChanged.
Public class | PropertyChangedEventArgsT | Provides event arguments for a property change event, indicating the old and new values.
Public class | Unit | Represents a length measurement.
Public class | UnitType | Specifies the unit of measurement.


CancelableEventArgs Class

CancelableEventArgs Class
Provides cancelable event arguments.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
More...

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CancelableEventArgs : EventArgs
Public Class CancelableEventArgs
    Inherits EventArgs

The CancelableEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CancelableEventArgs | Initializes a new instance of the CancelableEventArgs class with the Cancel property set to false.
Public method | CancelableEventArgs(Boolean) | Initializes a new instance of the CancelableEventArgs class with the Cancel property set to the given value.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabItemEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnEventArgs
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
ActiproSoftware.UI.Xaml.Controls.ViewsTaskCardEventArgs
ActiproSoftware.UI.Xaml.Controls.ViewsTaskColumnEventArgs


CancelableEventArgs Constructor

CancelableEventArgs Constructor
Overload List
 | Name | Description
Public method | CancelableEventArgs | Initializes a new instance of the CancelableEventArgs class with the Cancel property set to false.
Public method | CancelableEventArgs(Boolean) | Initializes a new instance of the CancelableEventArgs class with the Cancel property set to the given value.
Top
See Also

Reference

CancelableEventArgs Class
ActiproSoftware.UI.Xaml Namespace


CancelableEventArgs Constructor

CancelableEventArgs Constructor
Initializes a new instance of the CancelableEventArgs class with the Cancel property set to false.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CancelableEventArgs()
Public Sub New
See Also

Reference

CancelableEventArgs Class
CancelableEventArgs Overload
ActiproSoftware.UI.Xaml Namespace


CancelableEventArgs Constructor (Boolean)

CancelableEventArgs Constructor (Boolean)
Initializes a new instance of the CancelableEventArgs class with the Cancel property set to the given value.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CancelableEventArgs(
    bool cancel
)
Public Sub New (
    cancel As Boolean
)

Parameters

cancel
Type: SystemBoolean
true to cancel the event; otherwise, false.
See Also

Reference

CancelableEventArgs Class
CancelableEventArgs Overload
ActiproSoftware.UI.Xaml Namespace


CancelableEventArgs Properties

CancelableEventArgs Properties

The CancelableEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled.
Top
See Also

Reference

CancelableEventArgs Class
ActiproSoftware.UI.Xaml Namespace


CancelableEventArgs.Cancel Property

CancelableEventArgsCancel Property
Gets or sets a value indicating whether the event should be canceled.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
true to cancel the event; otherwise, false.
See Also

Reference

CancelableEventArgs Class
ActiproSoftware.UI.Xaml Namespace


CancelableEventArgs Methods

CancelableEventArgs Methods

The CancelableEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CancelableEventArgs Class
ActiproSoftware.UI.Xaml Namespace


DateRange Class

DateRange Class
Represents a date range, which is an inclusive pair of DateTime objects representing dates.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.UI.XamlDateRange

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DateRange : ValueType,
    IComparable<DateRange>, IEnumerable<DateTime>, IEnumerable,
    IEquatable<DateRange>
Public NotInheritable Class DateRange
    Inherits ValueType
    Implements IComparable(Of DateRange), IEnumerable(Of DateTime),
    IEnumerable, IEquatable(Of DateRange)

The DateRange type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of dates contained in the range.
Public property | EndDate | Gets the end date of this range.
Public property | StartDate | Gets the start date of this range.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Contains(DateTime) | Determines whether the specified date is contained in this range.
Public method | Contains(DateRange) | Determines whether the specified date range is contained in this range.
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(DateRange) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | (Inherited from Object.)
 | FromDate | Gets a date range for specified single date.
 | FromDecade | Gets a date range for the decade that contains the specified date.
 | FromMonth | Gets a date range for the month that contains the specified date.
 | FromRange | Gets a date range for specified range.
 | FromYear | Gets a date range for the year that contains the specified date.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, this range.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Compares two DateRange objects to determine whether they are equal.
GreaterThan | Compares two DateRange objects to determine whether the first instance is greater than the second instance.
Inequality | Compares two DateRange objects to determine whether they are not equal.
LessThan | Compares two DateRange objects to determine whether the first instance is less than the second instance.
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace


DateRange Properties

DateRange Properties

The DateRange type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of dates contained in the range.
Public property | EndDate | Gets the end date of this range.
Public property | StartDate | Gets the start date of this range.
Top
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.Count Property

DateRangeCount Property
Gets the number of dates contained in the range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of dates contained in the range.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.EndDate Property

DateRangeEndDate Property
Gets the end date of this range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime EndDate { get; }
Public ReadOnly Property EndDate As DateTime
    Get

Property Value

Type: DateTime
The end date of this range.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.StartDate Property

DateRangeStartDate Property
Gets the start date of this range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime StartDate { get; }
Public ReadOnly Property StartDate As DateTime
    Get

Property Value

Type: DateTime
The start date of this range.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange Methods

DateRange Methods

The DateRange type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current object with another object of the same type.
Public method | Contains(DateTime) | Determines whether the specified date is contained in this range.
Public method | Contains(DateRange) | Determines whether the specified date range is contained in this range.
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(DateRange) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | (Inherited from Object.)
 | FromDate | Gets a date range for specified single date.
 | FromDecade | Gets a date range for the decade that contains the specified date.
 | FromMonth | Gets a date range for the month that contains the specified date.
 | FromRange | Gets a date range for specified range.
 | FromYear | Gets a date range for the year that contains the specified date.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, this range.
Public method | ToString | Returns the fully qualified type name of this instance. (Overrides ValueTypeToString.)
Top
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.CompareTo Method

DateRangeCompareTo Method
Compares the current object with another object of the same type.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CompareTo(
    DateRange other
)
Public Function CompareTo (
    other As DateRange
) As Integer

Parameters

other
Type: ActiproSoftware.UI.XamlDateRange
An object to compare with this object.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has the following meanings: Less than zero means this object is less than the other parameter. Zero means this object is equal to other. Greater than zero means this object is greater than other.

Implements

IComparableTCompareTo(T)
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.Contains Method

DateRangeContains Method
Overload List
 | Name | Description
Public method | Contains(DateTime) | Determines whether the specified date is contained in this range.
Public method | Contains(DateRange) | Determines whether the specified date range is contained in this range.
Top
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.Contains Method (DateTime)

DateRangeContains Method (DateTime)
Determines whether the specified date is contained in this range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    DateTime date
)
Public Function Contains (
    date As DateTime
) As Boolean

Parameters

date
Type: SystemDateTime
The date to examine.

Return Value

Type: Boolean
true if the specified date is contained in this range; otherwise, false.
See Also

Reference

DateRange Class
Contains Overload
ActiproSoftware.UI.Xaml Namespace


DateRange.Contains Method (DateRange)

DateRangeContains Method (DateRange)
Determines whether the specified date range is contained in this range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    DateRange dateRange
)
Public Function Contains (
    dateRange As DateRange
) As Boolean

Parameters

dateRange
Type: ActiproSoftware.UI.XamlDateRange
The date range.

Return Value

Type: Boolean
true if the specified date range is contained in this range; otherwise, false.
See Also

Reference

DateRange Class
Contains Overload
ActiproSoftware.UI.Xaml Namespace


DateRange.Equals Method

DateRangeEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(DateRange) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.Equals Method (Object)

DateRangeEquals Method (Object)
Indicates whether this instance and a specified object are equal.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Another object to compare to.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

DateRange Class
Equals Overload
ActiproSoftware.UI.Xaml Namespace


DateRange.Equals Method (DateRange)

DateRangeEquals Method (DateRange)
Indicates whether the current object is equal to another object of the same type.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Equals(
    DateRange other
)
Public Function Equals (
    other As DateRange
) As Boolean

Parameters

other
Type: ActiproSoftware.UI.XamlDateRange
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

DateRange Class
Equals Overload
ActiproSoftware.UI.Xaml Namespace


DateRange.FromDate Method

DateRangeFromDate Method
Gets a date range for specified single date.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DateRange FromDate(
    DateTime date
)
Public Shared Function FromDate (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The start date.

Return Value

Type: DateRange
A date range for the specified single date.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.FromDecade Method

DateRangeFromDecade Method
Gets a date range for the decade that contains the specified date.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DateRange FromDecade(
    DateTime date
)
Public Shared Function FromDecade (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The date.

Return Value

Type: DateRange
A date range for the decade that contains the specified date.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.FromMonth Method

DateRangeFromMonth Method
Gets a date range for the month that contains the specified date.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DateRange FromMonth(
    DateTime date
)
Public Shared Function FromMonth (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The date.

Return Value

Type: DateRange
A date range for the month that contains the specified date.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.FromRange Method

DateRangeFromRange Method
Gets a date range for specified range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DateRange FromRange(
    DateTime startDate,
    DateTime endDate
)
Public Shared Function FromRange (
    startDate As DateTime,
    endDate As DateTime
) As DateRange

Parameters

startDate
Type: SystemDateTime
The start date.
endDate
Type: SystemDateTime
The end date.

Return Value

Type: DateRange
A date range for the specified range.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.FromYear Method

DateRangeFromYear Method
Gets a date range for the year that contains the specified date.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DateRange FromYear(
    DateTime date
)
Public Shared Function FromYear (
    date As DateTime
) As DateRange

Parameters

date
Type: SystemDateTime
The date.

Return Value

Type: DateRange
A date range for the year that contains the specified date.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.GetEnumerator Method

DateRangeGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<DateTime> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DateTime)

Return Value

Type: IEnumerator DateTime
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.GetHashCode Method

DateRangeGetHashCode Method
Returns the hash code for this instance.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.OverlapsWith Method

DateRangeOverlapsWith Method
Determines whether the specified date range overlaps with, or crosses, this range.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    DateRange otherRange
)
Public Function OverlapsWith (
    otherRange As DateRange
) As Boolean

Parameters

otherRange
Type: ActiproSoftware.UI.XamlDateRange
The date range to examine.

Return Value

Type: Boolean
true if the specified date range overlaps with, or crosses, this range; otherwise false.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.ToString Method

DateRangeToString Method
Returns the fully qualified type name of this instance.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String containing a fully qualified type name.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange Operators

DateRange Operators

The DateRange type exposes the following members.

Operators
Name | Description
Equality | Compares two DateRange objects to determine whether they are equal.
GreaterThan | Compares two DateRange objects to determine whether the first instance is greater than the second instance.
Inequality | Compares two DateRange objects to determine whether they are not equal.
LessThan | Compares two DateRange objects to determine whether the first instance is less than the second instance.
Top
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.Equality Operator

DateRangeEquality Operator
Compares two DateRange objects to determine whether they are equal.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    DateRange left,
    DateRange right
)
Public Shared Operator = (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.XamlDateRange
The left.
right
Type: ActiproSoftware.UI.XamlDateRange
The right.

Return Value

Type: Boolean
true if both DateRange objects are equal; otherwise, false.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.GreaterThan Operator

DateRangeGreaterThan Operator
Compares two DateRange objects to determine whether the first instance is greater than the second instance.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator >(
    DateRange left,
    DateRange right
)
Public Shared Operator > (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.XamlDateRange
The left.
right
Type: ActiproSoftware.UI.XamlDateRange
The right.

Return Value

Type: Boolean
true if the first DateRange is less greater the second DateRange; otherwise, false.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.Inequality Operator

DateRangeInequality Operator
Compares two DateRange objects to determine whether they are not equal.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    DateRange left,
    DateRange right
)
Public Shared Operator <> (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.XamlDateRange
The left.
right
Type: ActiproSoftware.UI.XamlDateRange
The right.

Return Value

Type: Boolean
true if both DateRange objects are not equal; otherwise, false.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRange.LessThan Operator

DateRangeLessThan Operator
Compares two DateRange objects to determine whether the first instance is less than the second instance.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator <(
    DateRange left,
    DateRange right
)
Public Shared Operator < (
    left As DateRange,
    right As DateRange
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.XamlDateRange
The left.
right
Type: ActiproSoftware.UI.XamlDateRange
The right.

Return Value

Type: Boolean
true if the first DateRange is less than the second DateRange; otherwise, false.
See Also

Reference

DateRange Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection Class

DateRangeCollection Class
Represents a collection of DateRange objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlDateRangeCollection

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateRangeCollection : ICollection<DateRange>,
    IEnumerable<DateRange>, IEnumerable, INotifyCollectionChanged
Public Class DateRangeCollection
    Implements ICollection(Of DateRange), IEnumerable(Of DateRange),
    IEnumerable, INotifyCollectionChanged

The DateRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DateRangeCollection | Initializes a new instance of the DateRangeCollection struct.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of DateRange items in the collection.
Public property | DayCount | Gets the number of days contained in the collection.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | Item | Gets the DateRange at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds a new DateRange item to the collection.
Public method | Clear | Clears the collection.
Public method | Contains(DateTime) | Returns whether the collection contains the specified DateTime.
Public method | Contains(DateRange) | Returns whether the collection contains the specified DateRange item.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(DateTime) | Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.
Public method | IndexOf(DateRange) | Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, any range in this collection.
Public method | Remove | Removes the specified DateRange item from the collection.
Public method | SetToMultipleDateRanges | Clears the collection, setting it to multiple DateRange items.
Public method | SetToSingleDateRange | Clears the collection, setting it to a single DateRange.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace


DateRangeCollection Constructor

DateRangeCollection Constructor
Initializes a new instance of the DateRangeCollection struct.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateRangeCollection()
Public Sub New
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection Properties

DateRangeCollection Properties

The DateRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of DateRange items in the collection.
Public property | DayCount | Gets the number of days contained in the collection.
Public property | IsReadOnly | Gets whether the collection is read-only.
Public property | Item | Gets the DateRange at the specified index.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Count Property

DateRangeCollectionCount Property
Gets the number of DateRange items in the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of DateRange items in the collection.

Implements

ICollectionTCount
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.DayCount Property

DateRangeCollectionDayCount Property
Gets the number of days contained in the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int DayCount { get; }
Public ReadOnly Property DayCount As Integer
    Get

Property Value

Type: Int32
The number of days contained in the collection.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.IsReadOnly Property

DateRangeCollectionIsReadOnly Property
Gets whether the collection is read-only.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Item Property

DateRangeCollectionItem Property
Gets the DateRange at the specified index.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateRange this[
    int index
] { get; }
Public ReadOnly Property Item (
    index As Integer
) As DateRange
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: DateRange
The DateRange at the specified index
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection Methods

DateRangeCollection Methods

The DateRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a new DateRange item to the collection.
Public method | Clear | Clears the collection.
Public method | Contains(DateTime) | Returns whether the collection contains the specified DateTime.
Public method | Contains(DateRange) | Returns whether the collection contains the specified DateRange item.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(DateTime) | Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.
Public method | IndexOf(DateRange) | Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OverlapsWith | Determines whether the specified date range overlaps with, or crosses, any range in this collection.
Public method | Remove | Removes the specified DateRange item from the collection.
Public method | SetToMultipleDateRanges | Clears the collection, setting it to multiple DateRange items.
Public method | SetToSingleDateRange | Clears the collection, setting it to a single DateRange.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Add Method

DateRangeCollectionAdd Method
Adds a new DateRange item to the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    DateRange item
)
Public Sub Add (
    item As DateRange
)

Parameters

item
Type: ActiproSoftware.UI.XamlDateRange
The DateRange to add.

Implements

ICollectionTAdd(T)
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Clear Method

DateRangeCollectionClear Method
Clears the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Contains Method

DateRangeCollectionContains Method
Overload List
 | Name | Description
Public method | Contains(DateTime) | Returns whether the collection contains the specified DateTime.
Public method | Contains(DateRange) | Returns whether the collection contains the specified DateRange item.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Contains Method (DateTime)

DateRangeCollectionContains Method (DateTime)
Returns whether the collection contains the specified DateTime.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    DateTime date
)
Public Function Contains (
    date As DateTime
) As Boolean

Parameters

date
Type: SystemDateTime
The DateTime for which to search.

Return Value

Type: Boolean
true if the collection contains the specified DateTime; otherwise, false.
See Also

Reference

DateRangeCollection Class
Contains Overload
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Contains Method (DateRange)

DateRangeCollectionContains Method (DateRange)
Returns whether the collection contains the specified DateRange item.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    DateRange item
)
Public Function Contains (
    item As DateRange
) As Boolean

Parameters

item
Type: ActiproSoftware.UI.XamlDateRange
The DateRange item for which to search.

Return Value

Type: Boolean
true if the collection contains the specified DateRange item; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

DateRangeCollection Class
Contains Overload
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.CopyTo Method

DateRangeCollectionCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    DateRange[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As DateRange(),
    arrayIndex As Integer
)

Parameters

array
Type: ActiproSoftware.UI.XamlDateRange
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.GetEnumerator Method

DateRangeCollectionGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<DateRange> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DateRange)

Return Value

Type: IEnumerator DateRange
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.IndexOf Method

DateRangeCollectionIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(DateTime) | Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.
Public method | IndexOf(DateRange) | Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.IndexOf Method (DateTime)

DateRangeCollectionIndexOf Method (DateTime)
Searches for the specified DateTime and returns the zero-based index of the DateRange that contains it, if any.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    DateTime date
)
Public Function IndexOf (
    date As DateTime
) As Integer

Parameters

date
Type: SystemDateTime
The DateTime for which to search.

Return Value

Type: Int32
The zero-based index of the DateRange that contains the specified DateTime, if found; otherwise -1.
See Also

Reference

DateRangeCollection Class
IndexOf Overload
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.IndexOf Method (DateRange)

DateRangeCollectionIndexOf Method (DateRange)
Searches for the specified DateRange and returns the zero-based index of the DateRange that contains it, if any.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    DateRange item
)
Public Function IndexOf (
    item As DateRange
) As Integer

Parameters

item
Type: ActiproSoftware.UI.XamlDateRange
The DateRange for which to search.

Return Value

Type: Int32
The zero-based index of the DateRange that contains the specified DateRange, if found; otherwise -1.
See Also

Reference

DateRangeCollection Class
IndexOf Overload
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.OverlapsWith Method

DateRangeCollectionOverlapsWith Method
Determines whether the specified date range overlaps with, or crosses, any range in this collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool OverlapsWith(
    DateRange range
)
Public Function OverlapsWith (
    range As DateRange
) As Boolean

Parameters

range
Type: ActiproSoftware.UI.XamlDateRange
The date range to examine.

Return Value

Type: Boolean
true if the specified date range overlaps with, or crosses, any range in this collection; otherwise false.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.Remove Method

DateRangeCollectionRemove Method
Removes the specified DateRange item from the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    DateRange item
)
Public Function Remove (
    item As DateRange
) As Boolean

Parameters

item
Type: ActiproSoftware.UI.XamlDateRange
The DateRange to remove.

Return Value

Type: Boolean
true if anything was removed; otherwise, false.

Implements

ICollectionTRemove(T)
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.SetToMultipleDateRanges Method

DateRangeCollectionSetToMultipleDateRanges Method
Clears the collection, setting it to multiple DateRange items.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SetToMultipleDateRanges(
    IEnumerable<DateRange> items
)
Public Sub SetToMultipleDateRanges (
    items As IEnumerable(Of DateRange)
)

Parameters

items
Type: System.Collections.GenericIEnumerable DateRange
The collection of DateRange items to add.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.SetToSingleDateRange Method

DateRangeCollectionSetToSingleDateRange Method
Clears the collection, setting it to a single DateRange.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SetToSingleDateRange(
    DateRange item
)
Public Sub SetToSingleDateRange (
    item As DateRange
)

Parameters

item
Type: ActiproSoftware.UI.XamlDateRange
The DateRange containing the date range.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.ToString Method

DateRangeCollectionToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection Events

DateRangeCollection Events

The DateRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection has changed.
Top
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DateRangeCollection.CollectionChanged Event

DateRangeCollectionCollectionChanged Event
Occurs when the collection has changed.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

DateRangeCollection Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern Class

DayOfWeekFormatPattern Class
Specifies various format patterns for a DayOfWeek value.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.XamlDayOfWeekFormatPattern

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DayOfWeekFormatPattern : Enum
Public NotInheritable Class DayOfWeekFormatPattern
    Inherits Enum

The DayOfWeekFormatPattern type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Abbreviated | Indicates a format that uses an abbreviated text for the day of the week.
 | AbbreviatedUppercase | Indicates a format that uses an all-uppercase abbreviated text for the day of the week.
 | Full | Indicates a format that uses the full text of the day of the week.
 | Shortest | Indicates a format that uses the shortest text possible, while still being unique, for the day of the week.
 | ShortestUppercase | Indicates an all-uppercase format that uses the shortest text possible, while still being unique, for the day of the week.
 | SingleLetter | Indicates a format that uses a single letter for the day of the week.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern Methods

DayOfWeekFormatPattern Methods

The DayOfWeekFormatPattern type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern Fields

DayOfWeekFormatPattern Fields

The DayOfWeekFormatPattern type exposes the following members.

Fields
 | Name | Description
 | Abbreviated | Indicates a format that uses an abbreviated text for the day of the week.
 | AbbreviatedUppercase | Indicates a format that uses an all-uppercase abbreviated text for the day of the week.
 | Full | Indicates a format that uses the full text of the day of the week.
 | Shortest | Indicates a format that uses the shortest text possible, while still being unique, for the day of the week.
 | ShortestUppercase | Indicates an all-uppercase format that uses the shortest text possible, while still being unique, for the day of the week.
 | SingleLetter | Indicates a format that uses a single letter for the day of the week.
Public field | value__ |
Top
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.Abbreviated Field

DayOfWeekFormatPatternAbbreviated Field
Indicates a format that uses an abbreviated text for the day of the week.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DayOfWeekFormatPattern Abbreviated = 3
Public Const Abbreviated As DayOfWeekFormatPattern = 3

Field Value

Type: DayOfWeekFormatPattern
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.AbbreviatedUppercase Field

DayOfWeekFormatPatternAbbreviatedUppercase Field
Indicates a format that uses an all-uppercase abbreviated text for the day of the week.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DayOfWeekFormatPattern AbbreviatedUppercase = 4
Public Const AbbreviatedUppercase As DayOfWeekFormatPattern = 4

Field Value

Type: DayOfWeekFormatPattern
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.Full Field

DayOfWeekFormatPatternFull Field
Indicates a format that uses the full text of the day of the week.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DayOfWeekFormatPattern Full = 5
Public Const Full As DayOfWeekFormatPattern = 5

Field Value

Type: DayOfWeekFormatPattern
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.Shortest Field

DayOfWeekFormatPatternShortest Field
Indicates a format that uses the shortest text possible, while still being unique, for the day of the week.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DayOfWeekFormatPattern Shortest = 1
Public Const Shortest As DayOfWeekFormatPattern = 1

Field Value

Type: DayOfWeekFormatPattern
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.ShortestUppercase Field

DayOfWeekFormatPatternShortestUppercase Field
Indicates an all-uppercase format that uses the shortest text possible, while still being unique, for the day of the week.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DayOfWeekFormatPattern ShortestUppercase = 2
Public Const ShortestUppercase As DayOfWeekFormatPattern = 2

Field Value

Type: DayOfWeekFormatPattern
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.SingleLetter Field

DayOfWeekFormatPatternSingleLetter Field
Indicates a format that uses a single letter for the day of the week.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DayOfWeekFormatPattern SingleLetter = 0
Public Const SingleLetter As DayOfWeekFormatPattern = 0

Field Value

Type: DayOfWeekFormatPattern
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DayOfWeekFormatPattern.value__ Field

DayOfWeekFormatPatternvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.DayOfWeekFormatPattern.value__"]

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DayOfWeekFormatPattern Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Class

DeferrableObservableCollectionT Class
Provides an ObservableCollectionT that is capable of suspending its property change notifications until a bulk update is complete.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.UI.XamlDeferrableObservableCollectionT
More...

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeferrableObservableCollection<T> : ObservableCollection<T>

Public Class DeferrableObservableCollection(Of T)
    Inherits ObservableCollection(Of T)

Type Parameters

T
The type of items.

The DeferrableObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | DeferrableObservableCollectionT | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT) | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT, Boolean) | Initializes a new instance of the DeferrableObservableCollectionT class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes.
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended.
Public property | Item | (Inherited from Collection T.)
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection.
Public method | BeginUpdate | Flags that a bulk update is about to begin.
Protected method | BlockReentrancy | (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | (Inherited from ObservableCollection T.)
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | (Inherited from ObservableCollection T.)
Public method | Contains | (Inherited from Collection T.)
Public method | CopyTo | (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T.)
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection T.)
Protected method | MoveItem | (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Overrides ObservableCollectionTOnPropertyChanged(PropertyChangedEventArgs).)
Public method | Remove | (Inherited from Collection T.)
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | (Inherited from ObservableCollection T.)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.UI.XamlDeferrableObservableCollectionT
ActiproSoftware.UI.Xaml.Controls.ChartsDeferrableObservableItemCollectionT
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollectionBaseT
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlAutoHideTabStripCollection
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObjectCollection
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDocumentWindowCollection
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlRaftingHostCollection
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowCollection
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowContainerCollection
ActiproSoftware.UI.Xaml.Controls.DockingToolWindowContainerCollection
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroQualitativeRangeCollection
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYRangeCollection
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYSeriesCollection


DeferrableObservableCollection(T) Constructor

DeferrableObservableCollectionT Constructor
Overload List
 | Name | Description
Public method | DeferrableObservableCollectionT | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT) | Initializes a new instance of the DeferrableObservableCollectionT class.
Public method | DeferrableObservableCollectionT(IComparerT, Boolean) | Initializes a new instance of the DeferrableObservableCollectionT class.
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Constructor

DeferrableObservableCollectionT Constructor
Initializes a new instance of the DeferrableObservableCollectionT class.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection()
Public Sub New
See Also

Reference

DeferrableObservableCollectionT Class
DeferrableObservableCollectionT Overload
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Constructor (IComparer(T))

DeferrableObservableCollectionT Constructor (IComparerT)
Initializes a new instance of the DeferrableObservableCollectionT class.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection(
    IComparer<T> sortComparer
)
Public Sub New (
    sortComparer As IComparer(Of T)
)

Parameters

sortComparer
Type: System.Collections.GenericIComparer T
A comparer used to sort items; otherwise .
See Also

Reference

DeferrableObservableCollectionT Class
DeferrableObservableCollectionT Overload
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Constructor (IComparer(T), Boolean)

DeferrableObservableCollectionT Constructor (IComparerT, Boolean)
Initializes a new instance of the DeferrableObservableCollectionT class.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection(
    IComparer<T> sortComparer,
    bool useStableSort
)
Public Sub New (
    sortComparer As IComparer(Of T),
    useStableSort As Boolean
)

Parameters

sortComparer
Type: System.Collections.GenericIComparer T
A comparer used to sort items; otherwise .
useStableSort
Type: SystemBoolean
if set to true then equivalent items will be maintained in the order they are added.
See Also

Reference

DeferrableObservableCollectionT Class
DeferrableObservableCollectionT Overload
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Properties

DeferrableObservableCollectionT Properties

The DeferrableObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes.
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended.
Public property | Item | (Inherited from Collection T .)
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).IsDirty Property

DeferrableObservableCollectionTIsDirty Property
Gets whether there are any suspended property changes.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDirty { get; }
Public ReadOnly Property IsDirty As Boolean
    Get

Property Value

Type: Boolean
true if there are any suspended property changes; otherwise, false.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).IsPropertyChangeSuspended Property

DeferrableObservableCollectionTIsPropertyChangeSuspended Property
Gets whether property change notifications are currently suspended.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPropertyChangeSuspended { get; }
Public ReadOnly Property IsPropertyChangeSuspended As Boolean
    Get

Property Value

Type: Boolean
true if property change notifications are currently suspended; otherwise, false.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Methods

DeferrableObservableCollectionT Methods

The DeferrableObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection.
Public method | BeginUpdate | Flags that a bulk update is about to begin.
Protected method | BlockReentrancy | (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection T .)
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | (Inherited from ObservableCollection T .)
Public method | Contains | (Inherited from Collection T .)
Public method | CopyTo | (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T .)
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection T .)
Protected method | MoveItem | (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Overrides ObservableCollectionTOnPropertyChanged(PropertyChangedEventArgs).)
Public method | Remove | (Inherited from Collection T .)
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | (Inherited from ObservableCollection T .)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).AddRange Method

DeferrableObservableCollectionTAddRange Method
Adds multiple items to the collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddRange(
    IEnumerable<T> items
)
Public Sub AddRange (
    items As IEnumerable(Of T)
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The collection of items to add.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).BeginUpdate Method

DeferrableObservableCollectionTBeginUpdate Method
Flags that a bulk update is about to begin.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void BeginUpdate()
Public Sub BeginUpdate
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).EndUpdate Method

DeferrableObservableCollectionTEndUpdate Method
Flags that a bulk update has ended.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void EndUpdate()
Public Sub EndUpdate
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).InsertItem Method

DeferrableObservableCollectionTInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).OnCollectionChanged Method

DeferrableObservableCollectionTOnCollectionChanged Method
Raises the CollectionChanged event with the provided arguments.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overrides Sub OnCollectionChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
A NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).OnPropertyChanged Method

DeferrableObservableCollectionTOnPropertyChanged Method
Raises the PropertyChanged event with the provided arguments.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
A PropertyChangedEventArgs that contains the event data.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).SetItem Method

DeferrableObservableCollectionTSetItem Method
Replaces the element at the specified index.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T).ToArray Method

DeferrableObservableCollectionTToArray Method
Returns a strongly-typed array containing the items in this collection.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T[] ToArray()
Public Function ToArray As T()

Return Value

Type: T
A strongly-typed array containing the items in this collection.
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


DeferrableObservableCollection(T) Events

DeferrableObservableCollectionT Events

The DeferrableObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | (Inherited from ObservableCollection T .)
Top
See Also

Reference

DeferrableObservableCollectionT Class
ActiproSoftware.UI.Xaml Namespace


ObservableObjectBase Class

ObservableObjectBase Class
A simple object that implements INotifyPropertyChanged.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
More...

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class ObservableObjectBase : INotifyPropertyChanged
Public MustInherit Class ObservableObjectBase
    Implements INotifyPropertyChanged

The ObservableObjectBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ObservableObjectBase | Initializes a new instance of the ObservableObjectBase class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.ChartsLegendKey
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesDataPointBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditorProperty
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroDataPointBase


ObservableObjectBase Constructor

ObservableObjectBase Constructor
Initializes a new instance of the ObservableObjectBase class

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ObservableObjectBase()
Protected Sub New
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.UI.Xaml Namespace


ObservableObjectBase Methods

ObservableObjectBase Methods

The ObservableObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.UI.Xaml Namespace


ObservableObjectBase.NotifyPropertyChanged Method

ObservableObjectBaseNotifyPropertyChanged Method
Notifies that a property has changed.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.UI.Xaml Namespace


ObservableObjectBase.OnPropertyChanged Method

ObservableObjectBaseOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.UI.Xaml Namespace


ObservableObjectBase Events

ObservableObjectBase Events

The ObservableObjectBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.UI.Xaml Namespace


ObservableObjectBase.PropertyChanged Event

ObservableObjectBasePropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ObservableObjectBase Class
ActiproSoftware.UI.Xaml Namespace


PropertyChangedEventArgs(T) Class

PropertyChangedEventArgsT Class
Provides event arguments for a property change event, indicating the old and new values.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlPropertyChangedEventArgsT
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorDocumentChangedEventArgs
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorDocumentLanguageChangedEventArgs
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewChangedEventArgs

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyChangedEventArgs<T> : EventArgs

Public Class PropertyChangedEventArgs(Of T)
    Inherits EventArgs

Type Parameters

T
The return type of the property.

The PropertyChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChangedEventArgsT | Initializes a new instance of the PropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace


PropertyChangedEventArgs(T) Constructor

PropertyChangedEventArgsT Constructor
Initializes a new instance of the PropertyChangedEventArgs class.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyChangedEventArgs(
    T oldValue,
    T newValue
)
Public Sub New (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The previous value of the property being tracked as reported by an event.
newValue
Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.UI.Xaml Namespace


PropertyChangedEventArgs(T) Properties

PropertyChangedEventArgsT Properties

The PropertyChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event.
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event.
Top
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.UI.Xaml Namespace


PropertyChangedEventArgs(T).NewValue Property

PropertyChangedEventArgsTNewValue Property
Gets the new value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T NewValue { get; }
Public ReadOnly Property NewValue As T
    Get

Property Value

Type: T
The new value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.UI.Xaml Namespace


PropertyChangedEventArgs(T).OldValue Property

PropertyChangedEventArgsTOldValue Property
Gets the previous value of the property being tracked as reported by an event.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T OldValue { get; }
Public ReadOnly Property OldValue As T
    Get

Property Value

Type: T
The previous value of the property being tracked as reported by an event.
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.UI.Xaml Namespace


PropertyChangedEventArgs(T) Methods

PropertyChangedEventArgsT Methods

The PropertyChangedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyChangedEventArgsT Class
ActiproSoftware.UI.Xaml Namespace


Unit Class

Unit Class
Represents a length measurement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlUnit

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Unit
Public Class Unit

The Unit type exposes the following members.

Constructors
 | Name | Description
Public method | Unit | Initializes a new instance of the Unit class.
Public method | Unit(Double) | Initializes a new instance of the Unit struct.
Public method | Unit(String) | Initializes a new instance of the Unit struct.
Public method | Unit(Double, UnitType) | Initializes a new instance of the Unit struct.
Public method | Unit(String, CultureInfo) | Initializes a new instance of the Unit struct.
Top
Properties
 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Type | Gets the type of units used by Value.
Public property | Value | Gets the value.
Top
Methods
 | Name | Description
 | Centimeter | Creates a new Unit instance with the specified centimeters.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetPixels | Gets the number of pixels represented by this Unit using the specified width when the Type is set to Percentage.
Public method | GetType | (Inherited from Object.)
 | Inch | Creates a new Unit instance with the specified inches.
Protected method | MemberwiseClone | (Inherited from Object.)
 | Parse(String) | Parses the specified string.
 | Parse(String, CultureInfo) | Parses the specified string using the specified CultureInfo.
 | Percentage | Creates a new Unit instance with the specified percentage.
 | Pixel | Creates a new Unit instance with the specified pixels.
 | Point | Creates a new Unit instance with the specified points.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns a String representation of this instance using the specified IFormatProvider to convert the Value.
 | ValidateIsGreaterThan | Validates that the object is a Unit greater than the specified number.
 | ValidateIsGreaterThanOrEqual | Validates that the object is a Unit greater than or equal to the specified number.
 | ValidateIsPositive | Validates that the object is a Unit greater than or equal to 0.
Top
Operators
Name | Description
Equality | Compares two Unit objects to determine whether they are equal.
(Double to Unit) | Performs an implicit conversion from Double to Unit.
Inequality | Compares two Unit objects to determine whether they are not equal.
Top
Fields
Name | Description
Empty | Represents an empty Unit. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace


Unit Constructor

Unit Constructor
Overload List
 | Name | Description
Public method | Unit | Initializes a new instance of the Unit class.
Public method | Unit(Double) | Initializes a new instance of the Unit struct.
Public method | Unit(String) | Initializes a new instance of the Unit struct.
Public method | Unit(Double, UnitType) | Initializes a new instance of the Unit struct.
Public method | Unit(String, CultureInfo) | Initializes a new instance of the Unit struct.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit Constructor

Unit Constructor
Initializes a new instance of the Unit class.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit()
Public Sub New
See Also

Reference

Unit Class
Unit Overload
ActiproSoftware.UI.Xaml Namespace


Unit Constructor (Double)

Unit Constructor (Double)
Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit(
    double value
)
Public Sub New (
    value As Double
)

Parameters

value
Type: SystemDouble
The value.
See Also

Reference

Unit Class
Unit Overload
ActiproSoftware.UI.Xaml Namespace


Unit Constructor (String)

Unit Constructor (String)
Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit(
    string value
)
Public Sub New (
    value As String
)

Parameters

value
Type: SystemString
The value.
See Also

Reference

Unit Class
Unit Overload
ActiproSoftware.UI.Xaml Namespace


Unit Constructor (Double, UnitType)

Unit Constructor (Double, UnitType)
Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit(
    double value,
    UnitType type
)
Public Sub New (
    value As Double,
    type As UnitType
)

Parameters

value
Type: SystemDouble
The value.
type
Type: ActiproSoftware.UI.XamlUnitType
The type.
See Also

Reference

Unit Class
Unit Overload
ActiproSoftware.UI.Xaml Namespace


Unit Constructor (String, CultureInfo)

Unit Constructor (String, CultureInfo)
Initializes a new instance of the Unit struct.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit(
    string value,
    CultureInfo culture
)
Public Sub New (
    value As String,
    culture As CultureInfo
)

Parameters

value
Type: SystemString
The value.
culture
Type: System.GlobalizationCultureInfo
The culture.
See Also

Reference

Unit Class
Unit Overload
ActiproSoftware.UI.Xaml Namespace


Unit Properties

Unit Properties

The Unit type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Gets a value indicating whether this instance is empty.
Public property | Type | Gets the type of units used by Value.
Public property | Value | Gets the value.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.IsEmpty Property

UnitIsEmpty Property
Gets a value indicating whether this instance is empty.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if this instance is empty; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Type Property

UnitType Property
Gets the type of units used by Value.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UnitType Type { get; set; }
Public Property Type As UnitType
    Get
    Set

Property Value

Type: UnitType
The type of units.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Value Property

UnitValue Property
Gets the value.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit Methods

Unit Methods

The Unit type exposes the following members.

Methods
 | Name | Description
 | Centimeter | Creates a new Unit instance with the specified centimeters.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetPixels | Gets the number of pixels represented by this Unit using the specified width when the Type is set to Percentage.
Public method | GetType | (Inherited from Object.)
 | Inch | Creates a new Unit instance with the specified inches.
Protected method | MemberwiseClone | (Inherited from Object.)
 | Parse(String) | Parses the specified string.
 | Parse(String, CultureInfo) | Parses the specified string using the specified CultureInfo.
 | Percentage | Creates a new Unit instance with the specified percentage.
 | Pixel | Creates a new Unit instance with the specified pixels.
 | Point | Creates a new Unit instance with the specified points.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns a String representation of this instance using the specified IFormatProvider to convert the Value.
 | ValidateIsGreaterThan | Validates that the object is a Unit greater than the specified number.
 | ValidateIsGreaterThanOrEqual | Validates that the object is a Unit greater than or equal to the specified number.
 | ValidateIsPositive | Validates that the object is a Unit greater than or equal to 0.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Centimeter Method

UnitCentimeter Method
Creates a new Unit instance with the specified centimeters.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Centimeter(
    double value
)
Public Shared Function Centimeter (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The centimeter value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Centimeter(System.Double)"]

See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Equals Method

UnitEquals Method
Indicates whether this instance and a specified object are equal.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
Another object to compare to.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.GetHashCode Method

UnitGetHashCode Method
Returns the hash code for this instance.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.GetPixels Method

UnitGetPixels Method
Gets the number of pixels represented by this Unit using the specified width when the Type is set to Percentage.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double GetPixels(
    double width
)
Public Function GetPixels (
    width As Double
) As Double

Parameters

width
Type: SystemDouble
The width.

Return Value

Type: Double

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.GetPixels(System.Double)"]

See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Inch Method

UnitInch Method
Creates a new Unit instance with the specified inches.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Inch(
    double value
)
Public Shared Function Inch (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The inch value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Inch(System.Double)"]

See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Parse Method

UnitParse Method
Overload List
Name | Description
Parse(String) | Parses the specified string.
Parse(String, CultureInfo) | Parses the specified string using the specified CultureInfo.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Parse Method (String)

UnitParse Method (String)
Parses the specified string.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Parse(
    string value
)
Public Shared Function Parse (
    value As String
) As Unit

Parameters

value
Type: SystemString
The string to parse.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Parse(System.String)"]

See Also

Reference

Unit Class
Parse Overload
ActiproSoftware.UI.Xaml Namespace


Unit.Parse Method (String, CultureInfo)

UnitParse Method (String, CultureInfo)
Parses the specified string using the specified CultureInfo.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Parse(
    string value,
    CultureInfo culture
)
Public Shared Function Parse (
    value As String,
    culture As CultureInfo
) As Unit

Parameters

value
Type: SystemString
The string to parse.
culture
Type: System.GlobalizationCultureInfo
The culture.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Parse(System.String,System.Globalization.CultureInfo)"]

See Also

Reference

Unit Class
Parse Overload
ActiproSoftware.UI.Xaml Namespace


Unit.Percentage Method

UnitPercentage Method
Creates a new Unit instance with the specified percentage.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Percentage(
    double value
)
Public Shared Function Percentage (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The percentage value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Percentage(System.Double)"]

See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Pixel Method

UnitPixel Method
Creates a new Unit instance with the specified pixels.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Pixel(
    double value
)
Public Shared Function Pixel (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The pixel value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Pixel(System.Double)"]

See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Point Method

UnitPoint Method
Creates a new Unit instance with the specified points.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Unit Point(
    double value
)
Public Shared Function Point (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The point value.

Return Value

Type: Unit

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.Point(System.Double)"]

See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.ToString Method

UnitToString Method
Overload List
 | Name | Description
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns a String representation of this instance using the specified IFormatProvider to convert the Value.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.ToString Method

UnitToString Method
Returns a String representation of this instance.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String representation of this instance.
See Also

Reference

Unit Class
ToString Overload
ActiproSoftware.UI.Xaml Namespace


Unit.ToString Method (IFormatProvider)

UnitToString Method (IFormatProvider)
Returns a String representation of this instance using the specified IFormatProvider to convert the Value.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToString(
    IFormatProvider formatProvider
)
Public Function ToString (
    formatProvider As IFormatProvider
) As String

Parameters

formatProvider
Type: SystemIFormatProvider
The format provider.

Return Value

Type: String

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Unit.ToString(System.IFormatProvider)"]

See Also

Reference

Unit Class
ToString Overload
ActiproSoftware.UI.Xaml Namespace


Unit.ValidateIsGreaterThan Method

UnitValidateIsGreaterThan Method
Validates that the object is a Unit greater than the specified number.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool ValidateIsGreaterThan(
    Object value,
    double min
)
Public Shared Function ValidateIsGreaterThan (
    value As Object,
    min As Double
) As Boolean

Parameters

value
Type: SystemObject
The object to validate.
min
Type: SystemDouble
The number that the value must be greater than.

Return Value

Type: Boolean
true if the validation is successful; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.ValidateIsGreaterThanOrEqual Method

UnitValidateIsGreaterThanOrEqual Method
Validates that the object is a Unit greater than or equal to the specified number.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool ValidateIsGreaterThanOrEqual(
    Object value,
    double min
)
Public Shared Function ValidateIsGreaterThanOrEqual (
    value As Object,
    min As Double
) As Boolean

Parameters

value
Type: SystemObject
The object to validate.
min
Type: SystemDouble
The number that the value must be greater than or equal to.

Return Value

Type: Boolean
true if the validation is successful; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.ValidateIsPositive Method

UnitValidateIsPositive Method
Validates that the object is a Unit greater than or equal to 0.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool ValidateIsPositive(
    Object value
)
Public Shared Function ValidateIsPositive (
    value As Object
) As Boolean

Parameters

value
Type: SystemObject
The object to validate.

Return Value

Type: Boolean
true if the validation is successful; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit Operators and Type Conversions

Unit Operators and Type Conversions

The Unit type exposes the following members.

Operators
Name | Description
Equality | Compares two Unit objects to determine whether they are equal.
(Double to Unit) | Performs an implicit conversion from Double to Unit.
Inequality | Compares two Unit objects to determine whether they are not equal.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Equality Operator

UnitEquality Operator
Compares two Unit objects to determine whether they are equal.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    Unit left,
    Unit right
)
Public Shared Operator = (
    left As Unit,
    right As Unit
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.XamlUnit
The left.
right
Type: ActiproSoftware.UI.XamlUnit
The right.

Return Value

Type: Boolean
true if both Unit objects are equal; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit Implicit Conversion (Double to Unit)

Unit Conversion (Double to Unit)
Performs an implicit conversion from Double to Unit.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static implicit operator Unit (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Unit

Parameters

value
Type: SystemDouble
The value.

Return Value

Type: Unit
The result of the conversion.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Inequality Operator

UnitInequality Operator
Compares two Unit objects to determine whether they are not equal.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    Unit left,
    Unit right
)
Public Shared Operator <> (
    left As Unit,
    right As Unit
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.XamlUnit
The left.
right
Type: ActiproSoftware.UI.XamlUnit
The right.

Return Value

Type: Boolean
true if both Unit objects are not equal; otherwise, false.
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit Fields

Unit Fields

The Unit type exposes the following members.

Fields
Name | Description
Empty | Represents an empty Unit. This field is read-only.
Top
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


Unit.Empty Field

UnitEmpty Field
Represents an empty Unit. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly Unit Empty
Public Shared ReadOnly Empty As Unit

Field Value

Type: Unit
See Also

Reference

Unit Class
ActiproSoftware.UI.Xaml Namespace


UnitType Class

UnitType Class
Specifies the unit of measurement.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.XamlUnitType

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class UnitType : Enum
Public NotInheritable Class UnitType
    Inherits Enum

The UnitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Centimeter | Indicates the measurement is in centimeters.
 | Inch | Indicates the measurement is in inches.
 | Percentage | Indicates the measurement is a percentage.
 | Pixel | Indicates the measurement is in pixels.
 | Point | Indicates the measurement is in points.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml Namespace


UnitType Methods

UnitType Methods

The UnitType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType Fields

UnitType Fields

The UnitType type exposes the following members.

Fields
 | Name | Description
 | Centimeter | Indicates the measurement is in centimeters.
 | Inch | Indicates the measurement is in inches.
 | Percentage | Indicates the measurement is a percentage.
 | Pixel | Indicates the measurement is in pixels.
 | Point | Indicates the measurement is in points.
Public field | value__ |
Top
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType.Centimeter Field

UnitTypeCentimeter Field
Indicates the measurement is in centimeters.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const UnitType Centimeter = 4
Public Const Centimeter As UnitType = 4

Field Value

Type: UnitType
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType.Inch Field

UnitTypeInch Field
Indicates the measurement is in inches.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const UnitType Inch = 3
Public Const Inch As UnitType = 3

Field Value

Type: UnitType
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType.Percentage Field

UnitTypePercentage Field
Indicates the measurement is a percentage.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const UnitType Percentage = 2
Public Const Percentage As UnitType = 2

Field Value

Type: UnitType
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType.Pixel Field

UnitTypePixel Field
Indicates the measurement is in pixels.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const UnitType Pixel = 1
Public Const Pixel As UnitType = 1

Field Value

Type: UnitType
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType.Point Field

UnitTypePoint Field
Indicates the measurement is in points.

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const UnitType Point = 5
Public Const Point As UnitType = 5

Field Value

Type: UnitType
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


UnitType.value__ Field

UnitTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.UnitType.value__"]

Namespace: ActiproSoftware.UI.Xaml
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

UnitType Class
ActiproSoftware.UI.Xaml Namespace


ActiproSoftware.UI.Xaml.Controls Namespace

ActiproSoftware.UI.Xaml.Controls Namespace
Contains some core controls and related classes.
Classes
 | Class | Description
Public class | AppBarHint | Represents an app bar hint.
Public class | ContentTransitionPreview | Represents a control that previews various IContentTransition objects.
Public class | Corners | Specifies zero or more corners of a rectangle as a combination of flags.
Public class | EditableContentControl | Represents a control that displays content by default but can toggle to an editable mode for editing the content.
Public class | HeaderedItemsControl | A base class for an ItemsControl that has a header.
Public class | HorizontalListBox | Represents a horizontal ListBox.
Public class | OrientedContainer | Represents a control that can be oriented horizontally or vertically, with its child element being rotated 90 degrees when vertical.
Public class | RadialSlider | Represents a radial slider.
Public class | ResizeOperation | Specifies a resize operation.
Public class | RingSlice | Represents a Path that renders a ring slice.
Public class | RingSpinner | Provides a spinnable ring-shaped busy indicator.
Public class | RoundMode | Specifies the mode of rounding a value.
Public class | Side | Specifies a single side of a rectangle.
Public class | Sides | Specifies zero or more sides of a rectangle as a combination of flags.
Public class | TransitioningContentPresenter | Represents a control that can display various content transitions between two elements.
Public class | UniformGrid | UniformGrid is a Panel that arranges content in a grid where all the cells in the grid have the same size.
Public class | WrapPanel | WrapPanel is a Panel that stacks children horizontally left to right, wrapping children that extend past its width onto new rows top-to-bottom, and also has an option for an alternate vertical orientation.
Interfaces
 | Interface | Description
Public interface | IOrientedElement | Provides the base requirements for an element that has an Orientation property.


AppBarHint Class

AppBarHint Class
Represents an app bar hint.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.ControlsAppBarHint

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AppBarHint : ContentControl
Public Class AppBarHint
    Inherits ContentControl

The AppBarHint type exposes the following members.

Constructors
 | Name | Description
Public method | AppBarHint | Initializes an instance of the AppBarHint class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Occurs when the pointer enters the control. (Overrides ControlOnPointerEntered(PointerRoutedEventArgs).)
Protected method | OnPointerExited | Occurs when the pointer exits the control. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Occurs when the pointer moves over the control. (Overrides ControlOnPointerMoved(PointerRoutedEventArgs).)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Occurs when the control is tapped. (Overrides ControlOnTapped(TappedRoutedEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint Constructor

AppBarHint Constructor
Initializes an instance of the AppBarHint class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AppBarHint()
Public Sub New
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint Properties

AppBarHint Properties

The AppBarHint type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint Methods

AppBarHint Methods

The AppBarHint type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Occurs when the pointer enters the control. (Overrides ControlOnPointerEntered(PointerRoutedEventArgs).)
Protected method | OnPointerExited | Occurs when the pointer exits the control. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Occurs when the pointer moves over the control. (Overrides ControlOnPointerMoved(PointerRoutedEventArgs).)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Occurs when the control is tapped. (Overrides ControlOnTapped(TappedRoutedEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint.OnApplyTemplate Method

AppBarHintOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint.OnPointerEntered Method

AppBarHintOnPointerEntered Method
Occurs when the pointer enters the control.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerEntered(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerEntered (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint.OnPointerExited Method

AppBarHintOnPointerExited Method
Occurs when the pointer exits the control.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerExited(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerExited (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint.OnPointerMoved Method

AppBarHintOnPointerMoved Method
Occurs when the pointer moves over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerMoved(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerMoved (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint.OnTapped Method

AppBarHintOnTapped Method
Occurs when the control is tapped.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnTapped(
    TappedRoutedEventArgs e
)
Protected Overrides Sub OnTapped (
    e As TappedRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputTappedRoutedEventArgs
An RoutedEventArgs that contains the event data.
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


AppBarHint Events

AppBarHint Events

The AppBarHint type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AppBarHint Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview Class

ContentTransitionPreview Class
Represents a control that previews various IContentTransition objects.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.ControlsContentTransitionPreview

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ContentTransitionPreview : Control
Public Class ContentTransitionPreview
    Inherits Control

The ContentTransitionPreview type exposes the following members.

Constructors
 | Name | Description
Public method | ContentTransitionPreview | Initializes a new instance of the ContentTransitionPreview class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultDirection | Gets or sets the default ContentTransitionDirection to use for transitions that use a direction.
Public property | DefaultDuration | Gets or sets the default length of time for which a transition plays, not counting repetitions.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transition | Gets or sets the IContentTransition to preview.
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DefaultDirectionProperty | Identifies the DefaultDirection dependency property. This field is read-only.
DefaultDurationProperty | Identifies the DefaultDuration dependency property. This field is read-only.
TransitionProperty | Identifies the Transition dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview Constructor

ContentTransitionPreview Constructor
Initializes a new instance of the ContentTransitionPreview class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionPreview()
Public Sub New
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview Properties

ContentTransitionPreview Properties

The ContentTransitionPreview type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultDirection | Gets or sets the default ContentTransitionDirection to use for transitions that use a direction.
Public property | DefaultDuration | Gets or sets the default length of time for which a transition plays, not counting repetitions.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transition | Gets or sets the IContentTransition to preview.
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.DefaultDirection Property

ContentTransitionPreviewDefaultDirection Property
Gets or sets the default ContentTransitionDirection to use for transitions that use a direction.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionDirection DefaultDirection { get; set; }
Public Property DefaultDirection As ContentTransitionDirection
    Get
    Set

Property Value

Type: ContentTransitionDirection
The default ContentTransitionDirection to use for transitions that use a direction. The default value is Forward.
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.DefaultDuration Property

ContentTransitionPreviewDefaultDuration Property
Gets or sets the default length of time for which a transition plays, not counting repetitions.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Duration DefaultDuration { get; set; }
Public Property DefaultDuration As Duration
    Get
    Set

Property Value

Type: Duration
The presenter's default simple duration for transitions: the amount of time a transition takes to complete a single forward iteration. The default value is 0.6 seconds.
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.Transition Property

ContentTransitionPreviewTransition Property
Gets or sets the IContentTransition to preview.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IContentTransition Transition { get; set; }
Public Property Transition As IContentTransition
    Get
    Set

Property Value

Type: IContentTransition
The IContentTransition to preview.
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview Methods

ContentTransitionPreview Methods

The ContentTransitionPreview type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.OnApplyTemplate Method

ContentTransitionPreviewOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview Events

ContentTransitionPreview Events

The ContentTransitionPreview type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview Fields

ContentTransitionPreview Fields

The ContentTransitionPreview type exposes the following members.

Fields
Name | Description
DefaultDirectionProperty | Identifies the DefaultDirection dependency property. This field is read-only.
DefaultDurationProperty | Identifies the DefaultDuration dependency property. This field is read-only.
TransitionProperty | Identifies the Transition dependency property. This field is read-only.
Top
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.DefaultDirectionProperty Field

ContentTransitionPreviewDefaultDirectionProperty Field
Identifies the DefaultDirection dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultDirectionProperty
Public Shared ReadOnly DefaultDirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultDirection dependency property.
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.DefaultDurationProperty Field

ContentTransitionPreviewDefaultDurationProperty Field
Identifies the DefaultDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultDurationProperty
Public Shared ReadOnly DefaultDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultDuration dependency property.
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


ContentTransitionPreview.TransitionProperty Field

ContentTransitionPreviewTransitionProperty Field
Identifies the Transition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TransitionProperty
Public Shared ReadOnly TransitionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Transition dependency property.
See Also

Reference

ContentTransitionPreview Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners Class

Corners Class
Specifies zero or more corners of a rectangle as a combination of flags.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.ControlsCorners

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class Corners : Enum
<FlagsAttribute>
Public NotInheritable Class Corners
    Inherits Enum

The Corners type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates all four corners, top-left, top-right, bottom-left and bottom-right.
 | Bottom | Indicates the bottom corners, bottom-left and bottom-right.
 | BottomLeft | Indicates the bottom-right corner.
 | BottomRight | Indicates the bottom-left corner.
 | Left | Indicates the left corners, top-left and bottom-left.
 | None | Indicates no corners.
 | Right | Indicates the right corners, top-right and bottom-right.
 | Top | Indicates the top corners, top-left and top-right.
 | TopLeft | Indicates the top-left corner.
 | TopRight | Indicates the top-right corner.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


Corners Methods

Corners Methods

The Corners type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners Fields

Corners Fields

The Corners type exposes the following members.

Fields
 | Name | Description
 | All | Indicates all four corners, top-left, top-right, bottom-left and bottom-right.
 | Bottom | Indicates the bottom corners, bottom-left and bottom-right.
 | BottomLeft | Indicates the bottom-right corner.
 | BottomRight | Indicates the bottom-left corner.
 | Left | Indicates the left corners, top-left and bottom-left.
 | None | Indicates no corners.
 | Right | Indicates the right corners, top-right and bottom-right.
 | Top | Indicates the top corners, top-left and top-right.
 | TopLeft | Indicates the top-left corner.
 | TopRight | Indicates the top-right corner.
Public field | value__ |
Top
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.All Field

CornersAll Field
Indicates all four corners, top-left, top-right, bottom-left and bottom-right.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners All = 15
Public Const All As Corners = 15

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.Bottom Field

CornersBottom Field
Indicates the bottom corners, bottom-left and bottom-right.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners Bottom = 12
Public Const Bottom As Corners = 12

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.BottomLeft Field

CornersBottomLeft Field
Indicates the bottom-right corner.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners BottomLeft = 8
Public Const BottomLeft As Corners = 8

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.BottomRight Field

CornersBottomRight Field
Indicates the bottom-left corner.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners BottomRight = 4
Public Const BottomRight As Corners = 4

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.Left Field

CornersLeft Field
Indicates the left corners, top-left and bottom-left.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners Left = 9
Public Const Left As Corners = 9

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.None Field

CornersNone Field
Indicates no corners.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners None = 0
Public Const None As Corners = 0

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.Right Field

CornersRight Field
Indicates the right corners, top-right and bottom-right.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners Right = 6
Public Const Right As Corners = 6

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.Top Field

CornersTop Field
Indicates the top corners, top-left and top-right.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners Top = 3
Public Const Top As Corners = 3

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.TopLeft Field

CornersTopLeft Field
Indicates the top-left corner.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners TopLeft = 1
Public Const TopLeft As Corners = 1

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.TopRight Field

CornersTopRight Field
Indicates the top-right corner.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Corners TopRight = 2
Public Const TopRight As Corners = 2

Field Value

Type: Corners
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


Corners.value__ Field

Cornersvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Corners.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Corners Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl Class

EditableContentControl Class
Represents a control that displays content by default but can toggle to an editable mode for editing the content.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.ControlsEditableContentControl

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditableContentControl : ContentControl
Public Class EditableContentControl
    Inherits ContentControl

The EditableContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | EditableContentControl | Initializes an instance of the EditableContentControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EditableContent | Gets or sets the content being edited.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditing | Gets or sets whether the content is currently being edited.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
EditableContentProperty | Identifies the EditableContent dependency property. This field is read-only.
IsEditingProperty | Identifies the IsEditing dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl Constructor

EditableContentControl Constructor
Initializes an instance of the EditableContentControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditableContentControl()
Public Sub New
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl Properties

EditableContentControl Properties

The EditableContentControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EditableContent | Gets or sets the content being edited.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditing | Gets or sets whether the content is currently being edited.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.EditableContent Property

EditableContentControlEditableContent Property
Gets or sets the content being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object EditableContent { get; set; }
Public Property EditableContent As Object
    Get
    Set

Property Value

Type: Object
The content being edited.
Remarks
This property is for internal use only.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.IsEditing Property

EditableContentControlIsEditing Property
Gets or sets whether the content is currently being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEditing { get; set; }
Public Property IsEditing As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content is currently being edited; otherwise, false.
Remarks
This property toggles the UI of the control between display and edit modes.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.IsKeyboardFocusWithin Property

EditableContentControlIsKeyboardFocusWithin Property
Gets whether keyboard focus is within the control.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsKeyboardFocusWithin { get; }
Public ReadOnly Property IsKeyboardFocusWithin As Boolean
    Get

Property Value

Type: Boolean
true if keyboard focus is within the control; otherwise, false.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl Methods

EditableContentControl Methods

The EditableContentControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.OnGotFocus Method

EditableContentControlOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.OnKeyDown Method

EditableContentControlOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.OnLostFocus Method

EditableContentControlOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl Events

EditableContentControl Events

The EditableContentControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl Fields

EditableContentControl Fields

The EditableContentControl type exposes the following members.

Fields
Name | Description
EditableContentProperty | Identifies the EditableContent dependency property. This field is read-only.
IsEditingProperty | Identifies the IsEditing dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
Top
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.EditableContentProperty Field

EditableContentControlEditableContentProperty Field
Identifies the EditableContent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EditableContentProperty
Public Shared ReadOnly EditableContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EditableContent dependency property.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.IsEditingProperty Field

EditableContentControlIsEditingProperty Field
Identifies the IsEditing dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditingProperty
Public Shared ReadOnly IsEditingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditing dependency property.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


EditableContentControl.IsKeyboardFocusWithinProperty Field

EditableContentControlIsKeyboardFocusWithinProperty Field
Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsKeyboardFocusWithinProperty
Public Shared ReadOnly IsKeyboardFocusWithinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsKeyboardFocusWithin dependency property.
See Also

Reference

EditableContentControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl Class

HeaderedItemsControl Class
A base class for an ItemsControl that has a header.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.ControlsHeaderedItemsControl
ActiproSoftware.UI.Xaml.Controls.ViewsTaskColumn

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HeaderedItemsControl : ItemsControl
Public Class HeaderedItemsControl
    Inherits ItemsControl

The HeaderedItemsControl type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderedItemsControl | Initializes a new instance of the HeaderedItemsControl class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the data used for the header of each control. This is a dependency property.
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. This is a dependency property.
Public property | HeaderTemplateSelector | Gets or sets the template selector used to display the content of the control's header. This is a dependency property.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl Constructor

HeaderedItemsControl Constructor
Initializes a new instance of the HeaderedItemsControl class

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HeaderedItemsControl()
Public Sub New
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl Properties

HeaderedItemsControl Properties

The HeaderedItemsControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the data used for the header of each control. This is a dependency property.
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. This is a dependency property.
Public property | HeaderTemplateSelector | Gets or sets the template selector used to display the content of the control's header. This is a dependency property.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl.Header Property

HeaderedItemsControlHeader Property
Gets or sets the data used for the header of each control. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Header { get; set; }
Public Property Header As Object
    Get
    Set

Property Value

Type: Object
A header object. The default value is .
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl.HeaderTemplate Property

HeaderedItemsControlHeaderTemplate Property
Gets or sets the template used to display the content of the control's header. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate HeaderTemplate { get; set; }
Public Property HeaderTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A data template. The default value is .
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl.HeaderTemplateSelector Property

HeaderedItemsControlHeaderTemplateSelector Property
Gets or sets the template selector used to display the content of the control's header. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector HeaderTemplateSelector { get; set; }
Public Property HeaderTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A data template selector. The default value is .
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl Methods

HeaderedItemsControl Methods

The HeaderedItemsControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl Events

HeaderedItemsControl Events

The HeaderedItemsControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl Fields

HeaderedItemsControl Fields

The HeaderedItemsControl type exposes the following members.

Fields
Name | Description
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property. This field is read-only.
Top
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl.HeaderProperty Field

HeaderedItemsControlHeaderProperty Field
Identifies the Header dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderProperty
Public Shared ReadOnly HeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Header dependency property.
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl.HeaderTemplateProperty Field

HeaderedItemsControlHeaderTemplateProperty Field
Identifies the HeaderTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateProperty
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplate dependency property.
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HeaderedItemsControl.HeaderTemplateSelectorProperty Field

HeaderedItemsControlHeaderTemplateSelectorProperty Field
Identifies the HeaderTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateSelectorProperty
Public Shared ReadOnly HeaderTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplateSelector dependency property.
See Also

Reference

HeaderedItemsControl Class
ActiproSoftware.UI.Xaml.Controls Namespace


HorizontalListBox Class

HorizontalListBox Class
Represents a horizontal ListBox.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
Windows.UI.Xaml.Controls.PrimitivesSelector
Windows.UI.Xaml.ControlsListBox
ActiproSoftware.UI.Xaml.ControlsHorizontalListBox

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HorizontalListBox : ListBox
Public Class HorizontalListBox
    Inherits ListBox

The HorizontalListBox type exposes the following members.

Constructors
 | Name | Description
Public method | HorizontalListBox | Initializes an instance of the HorizontalListBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedItems | Gets the list of currently selected items for the ListBox control. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for the ListBox control. (Inherited from ListBox.)
Public property | SingleSelectionFollowsFocus | (Inherited from ListBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in the ListBox control. (Inherited from ListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


HorizontalListBox Constructor

HorizontalListBox Constructor
Initializes an instance of the HorizontalListBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HorizontalListBox()
Public Sub New
See Also

Reference

HorizontalListBox Class
ActiproSoftware.UI.Xaml.Controls Namespace


HorizontalListBox Properties

HorizontalListBox Properties

The HorizontalListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedItems | Gets the list of currently selected items for the ListBox control. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for the ListBox control. (Inherited from ListBox.)
Public property | SingleSelectionFollowsFocus | (Inherited from ListBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

HorizontalListBox Class
ActiproSoftware.UI.Xaml.Controls Namespace


HorizontalListBox Methods

HorizontalListBox Methods

The HorizontalListBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in the ListBox control. (Inherited from ListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

HorizontalListBox Class
ActiproSoftware.UI.Xaml.Controls Namespace


HorizontalListBox.OnKeyDown Method

HorizontalListBoxOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

HorizontalListBox Class
ActiproSoftware.UI.Xaml.Controls Namespace


HorizontalListBox Events

HorizontalListBox Events

The HorizontalListBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

HorizontalListBox Class
ActiproSoftware.UI.Xaml.Controls Namespace


IOrientedElement Interface

IOrientedElement Interface
Provides the base requirements for an element that has an Orientation property.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IOrientedElement
Public Interface IOrientedElement

The IOrientedElement type exposes the following members.

Properties
 | Name | Description
Public property | Orientation | Gets the orientation of the element.
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


IOrientedElement Properties

IOrientedElement Properties

The IOrientedElement type exposes the following members.

Properties
 | Name | Description
Public property | Orientation | Gets the orientation of the element.
Top
See Also

Reference

IOrientedElement Interface
ActiproSoftware.UI.Xaml.Controls Namespace


IOrientedElement.Orientation Property

IOrientedElementOrientation Property
Gets the orientation of the element.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Orientation Orientation { get; }
ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The orientation of the element.
See Also

Reference

IOrientedElement Interface
ActiproSoftware.UI.Xaml.Controls Namespace


IOrientedElement Methods

IOrientedElement Methods

The IOrientedElement type exposes the following members.

Extension Methods
 | Name | Description
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Top
See Also

Reference

IOrientedElement Interface
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer Class

OrientedContainer Class
Represents a control that can be oriented horizontally or vertically, with its child element being rotated 90 degrees when vertical.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.ControlsOrientedContainer

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class OrientedContainer : Control
Public Class OrientedContainer
    Inherits Control

The OrientedContainer type exposes the following members.

Constructors
 | Name | Description
Public method | OrientedContainer | Initializes a new instance of the OrientedContainer class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets or sets the child FrameworkElement displayed by this container.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsHorizontal | Gets or sets whether the container is currently oriented horizontally.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ChildProperty | Identifies the Child dependency property. This field is read-only.
IsHorizontalProperty | Identifies the IsHorizontal dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
This control helps with the lack of a LayoutTransform property in WinRT that would be used for rotation.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer Constructor

OrientedContainer Constructor
Initializes a new instance of the OrientedContainer class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public OrientedContainer()
Public Sub New
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer Properties

OrientedContainer Properties

The OrientedContainer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets or sets the child FrameworkElement displayed by this container.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsHorizontal | Gets or sets whether the container is currently oriented horizontally.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.Child Property

OrientedContainerChild Property
Gets or sets the child FrameworkElement displayed by this container.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The child FrameworkElement displayed by this container.
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.IsHorizontal Property

OrientedContainerIsHorizontal Property
Gets or sets whether the container is currently oriented horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHorizontal { get; set; }
Public Property IsHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the container is currently oriented horizontally; otherwise, false.
Remarks
When this property is false, the child element is rotated 90 degrees.
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer Methods

OrientedContainer Methods

The OrientedContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.ArrangeOverride Method

OrientedContainerArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.ArrangeOverride Method (Size)

OrientedContainerArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

OrientedContainer Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.MeasureOverride Method

OrientedContainerMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.MeasureOverride Method (Size)

OrientedContainerMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

OrientedContainer Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.OnApplyTemplate Method

OrientedContainerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer Events

OrientedContainer Events

The OrientedContainer type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer Fields

OrientedContainer Fields

The OrientedContainer type exposes the following members.

Fields
Name | Description
ChildProperty | Identifies the Child dependency property. This field is read-only.
IsHorizontalProperty | Identifies the IsHorizontal dependency property. This field is read-only.
Top
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.ChildProperty Field

OrientedContainerChildProperty Field
Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


OrientedContainer.IsHorizontalProperty Field

OrientedContainerIsHorizontalProperty Field
Identifies the IsHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHorizontalProperty
Public Shared ReadOnly IsHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHorizontal dependency property.
See Also

Reference

OrientedContainer Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider Class

RadialSlider Class
Represents a radial slider.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.PrimitivesRangeBase
ActiproSoftware.UI.Xaml.ControlsRadialSlider
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesEmbeddedRadialSlider

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RadialSlider : RangeBase
Public Class RadialSlider
    Inherits RangeBase

The RadialSlider type exposes the following members.

Constructors
 | Name | Description
Public method | RadialSlider | Initializes an instance of the RadialSlider class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range control. (Inherited from RangeBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible Value of the range control. (Inherited from RangeBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the slider's radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle.
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state.
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed.
Public property | ThumbStyle | Gets or sets the Style to use for the thumb.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | ets or sets the current setting of the range control, which may be coerced. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed. (Inherited from RangeBase.)
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed. (Inherited from RangeBase.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RangeBaseOnValueChanged(Double, Double).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Protected method | SetValueCore | Sets the Value property and applies snapping.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
ThumbArrowAngleProperty | Identifies the ThumbArrowAngle dependency property. This field is read-only.
ThumbBackgroundProperty | Identifies the ThumbBackground dependency property. This field is read-only.
ThumbPressedBackgroundProperty | Identifies the ThumbPressedBackground dependency property. This field is read-only.
ThumbStyleProperty | Identifies the ThumbStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider Constructor

RadialSlider Constructor
Initializes an instance of the RadialSlider class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RadialSlider()
Public Sub New
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider Properties

RadialSlider Properties

The RadialSlider type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range control. (Inherited from RangeBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible Value of the range control. (Inherited from RangeBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the slider's radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle.
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state.
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed.
Public property | ThumbStyle | Gets or sets the Style to use for the thumb.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | ets or sets the current setting of the range control, which may be coerced. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.IntermediateValue Property

RadialSliderIntermediateValue Property
Gets or sets the value of the slider while the user is interacting with it, before the value is snapped.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double IntermediateValue { get; set; }
Public Property IntermediateValue As Double
    Get
    Set

Property Value

Type: Double
A temporary value.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.Radius Property

RadialSliderRadius Property
Gets or sets the slider's radius.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The slider's radius. The default value is 100.0.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbArrowAngle Property

RadialSliderThumbArrowAngle Property
Gets or sets the thumb's arrow angle.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ThumbArrowAngle { get; set; }
Public Property ThumbArrowAngle As Double
    Get
    Set

Property Value

Type: Double
The thumb's arrow angle. The default value is 180.0, meaning it will face down when up at 0 degrees in the slider.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbBackground Property

RadialSliderThumbBackground Property
Gets or sets the background Brush to render when the thumb is in a normal state.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ThumbBackground { get; set; }
Public Property ThumbBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush to render when the thumb is in a normal state.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbPressedBackground Property

RadialSliderThumbPressedBackground Property
Gets or sets the background Brush to render when the thumb is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ThumbPressedBackground { get; set; }
Public Property ThumbPressedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush to render when the thumb is pressed.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbStyle Property

RadialSliderThumbStyle Property
Gets or sets the Style to use for the thumb.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ThumbStyle { get; set; }
Public Property ThumbStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the thumb.
Remarks
Use this property if a custom thumb Style is desired.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider Methods

RadialSlider Methods

The RadialSlider type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed. (Inherited from RangeBase.)
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed. (Inherited from RangeBase.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RangeBaseOnValueChanged(Double, Double).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Protected method | SetValueCore | Sets the Value property and applies snapping.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.OnApplyTemplate Method

RadialSliderOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.OnCreateAutomationPeer Method

RadialSliderOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.OnValueChanged Method

RadialSliderOnValueChanged Method
Occurs when the Value property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.SetValueCore Method

RadialSliderSetValueCore Method
Sets the Value property and applies snapping.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void SetValueCore(
    double value
)
Protected Sub SetValueCore (
    value As Double
)

Parameters

value
Type: SystemDouble
The value to set.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider Events

RadialSlider Events

The RadialSlider type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from RangeBase.)
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider Fields

RadialSlider Fields

The RadialSlider type exposes the following members.

Fields
Name | Description
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
ThumbArrowAngleProperty | Identifies the ThumbArrowAngle dependency property. This field is read-only.
ThumbBackgroundProperty | Identifies the ThumbBackground dependency property. This field is read-only.
ThumbPressedBackgroundProperty | Identifies the ThumbPressedBackground dependency property. This field is read-only.
ThumbStyleProperty | Identifies the ThumbStyle dependency property. This field is read-only.
Top
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.IntermediateValueProperty Field

RadialSliderIntermediateValueProperty Field
Identifies the IntermediateValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IntermediateValueProperty
Public Shared ReadOnly IntermediateValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IntermediateValue dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.RadiusProperty Field

RadialSliderRadiusProperty Field
Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbArrowAngleProperty Field

RadialSliderThumbArrowAngleProperty Field
Identifies the ThumbArrowAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbArrowAngleProperty
Public Shared ReadOnly ThumbArrowAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbArrowAngle dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbBackgroundProperty Field

RadialSliderThumbBackgroundProperty Field
Identifies the ThumbBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbBackgroundProperty
Public Shared ReadOnly ThumbBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbBackground dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbPressedBackgroundProperty Field

RadialSliderThumbPressedBackgroundProperty Field
Identifies the ThumbPressedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbPressedBackgroundProperty
Public Shared ReadOnly ThumbPressedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbPressedBackground dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


RadialSlider.ThumbStyleProperty Field

RadialSliderThumbStyleProperty Field
Identifies the ThumbStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThumbStyleProperty
Public Shared ReadOnly ThumbStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThumbStyle dependency property.
See Also

Reference

RadialSlider Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation Class

ResizeOperation Class
Specifies a resize operation.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.ControlsResizeOperation

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ResizeOperation : Enum
Public NotInheritable Class ResizeOperation
    Inherits Enum

The ResizeOperation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | East | East.
 | None | No resize operation.
 | North | North.
 | NorthEast | North-east.
 | NorthWest | North-west.
 | South | South.
 | SouthEast | South-east.
 | SouthWest | South-west.
Public field | value__ |
 | West | West.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation Methods

ResizeOperation Methods

The ResizeOperation type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation Fields

ResizeOperation Fields

The ResizeOperation type exposes the following members.

Fields
 | Name | Description
 | East | East.
 | None | No resize operation.
 | North | North.
 | NorthEast | North-east.
 | NorthWest | North-west.
 | South | South.
 | SouthEast | South-east.
 | SouthWest | South-west.
Public field | value__ |
 | West | West.
Top
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.East Field

ResizeOperationEast Field
East.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation East = 61442
Public Const East As ResizeOperation = 61442

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.None Field

ResizeOperationNone Field
No resize operation.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation None = 61440
Public Const None As ResizeOperation = 61440

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.North Field

ResizeOperationNorth Field
North.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation North = 61443
Public Const North As ResizeOperation = 61443

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.NorthEast Field

ResizeOperationNorthEast Field
North-east.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation NorthEast = 61445
Public Const NorthEast As ResizeOperation = 61445

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.NorthWest Field

ResizeOperationNorthWest Field
North-west.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation NorthWest = 61444
Public Const NorthWest As ResizeOperation = 61444

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.South Field

ResizeOperationSouth Field
South.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation South = 61446
Public Const South As ResizeOperation = 61446

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.SouthEast Field

ResizeOperationSouthEast Field
South-east.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation SouthEast = 61448
Public Const SouthEast As ResizeOperation = 61448

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.SouthWest Field

ResizeOperationSouthWest Field
South-west.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation SouthWest = 61447
Public Const SouthWest As ResizeOperation = 61447

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.value__ Field

ResizeOperationvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.ResizeOperation.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


ResizeOperation.West Field

ResizeOperationWest Field
West.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeOperation West = 61441
Public Const West As ResizeOperation = 61441

Field Value

Type: ResizeOperation
See Also

Reference

ResizeOperation Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice Class

RingSlice Class
Represents a Path that renders a ring slice.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ShapesShape
Windows.UI.Xaml.ShapesPath
ActiproSoftware.UI.Xaml.ControlsRingSlice

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RingSlice : Path
Public Class RingSlice
    Inherits Path

The RingSlice type exposes the following members.

Constructors
 | Name | Description
Public method | RingSlice | Initializes an instance of the RingSlice class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | Data | Gets or sets a Geometry that specifies the shape to be drawn. (Inherited from Path.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EndAngle | Gets or sets the end angle.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | Fill | Gets or sets the Brush that specifies how to paint the interior of the shape. (Inherited from Shape.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape before it is drawn. (Inherited from Shape.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRenderedWhenFullCircle | Gets or sets whether the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the ring's outer radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicates the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashOffset | Gets or sets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape stroke outline. (Inherited from Shape.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAlphaMask | (Inherited from Shape.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
EndAngleProperty | Identifies the EndAngle dependency property. This field is read-only.
IsRenderedWhenFullCircleProperty | Identifies the IsRenderedWhenFullCircle dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice Constructor

RingSlice Constructor
Initializes an instance of the RingSlice class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RingSlice()
Public Sub New
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice Properties

RingSlice Properties

The RingSlice type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | Data | Gets or sets a Geometry that specifies the shape to be drawn. (Inherited from Path.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EndAngle | Gets or sets the end angle.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | Fill | Gets or sets the Brush that specifies how to paint the interior of the shape. (Inherited from Shape.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape before it is drawn. (Inherited from Shape.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRenderedWhenFullCircle | Gets or sets whether the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the ring's outer radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicates the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashOffset | Gets or sets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape stroke outline. (Inherited from Shape.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.EndAngle Property

RingSliceEndAngle Property
Gets or sets the end angle.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set

Property Value

Type: Double
The end angle. The default value is 360.0.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.IsRenderedWhenFullCircle Property

RingSliceIsRenderedWhenFullCircle Property
Gets or sets whether the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsRenderedWhenFullCircle { get; set; }
Public Property IsRenderedWhenFullCircle As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the ring slice renders a full circle when the StartAngle and EndAngle are different values, but are normalized to the same value; otherwise, false. The default value is true.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.Radius Property

RingSliceRadius Property
Gets or sets the ring's outer radius.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The ring's outer radius. The default value is 40.0.
Remarks
This ring is rendered inward from this radius.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.StartAngle Property

RingSliceStartAngle Property
Gets or sets the start angle.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set

Property Value

Type: Double
The start angle. The default value is 0.0.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice Methods

RingSlice Methods

The RingSlice type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAlphaMask | (Inherited from Shape.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.ArrangeOverride Method

RingSliceArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.ArrangeOverride Method (Size)

RingSliceArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

RingSlice Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.MeasureOverride Method

RingSliceMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.MeasureOverride Method (Size)

RingSliceMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

RingSlice Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice Events

RingSlice Events

The RingSlice type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice Fields

RingSlice Fields

The RingSlice type exposes the following members.

Fields
Name | Description
EndAngleProperty | Identifies the EndAngle dependency property. This field is read-only.
IsRenderedWhenFullCircleProperty | Identifies the IsRenderedWhenFullCircle dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
Top
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.EndAngleProperty Field

RingSliceEndAngleProperty Field
Identifies the EndAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EndAngleProperty
Public Shared ReadOnly EndAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EndAngle dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.IsRenderedWhenFullCircleProperty Field

RingSliceIsRenderedWhenFullCircleProperty Field
Identifies the IsRenderedWhenFullCircle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRenderedWhenFullCircleProperty
Public Shared ReadOnly IsRenderedWhenFullCircleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRenderedWhenFullCircle dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.RadiusProperty Field

RingSliceRadiusProperty Field
Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSlice.StartAngleProperty Field

RingSliceStartAngleProperty Field
Identifies the StartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartAngleProperty
Public Shared ReadOnly StartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartAngle dependency property.
See Also

Reference

RingSlice Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner Class

RingSpinner Class
Provides a spinnable ring-shaped busy indicator.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.ControlsRingSpinner

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RingSpinner : Control
Public Class RingSpinner
    Inherits Control

The RingSpinner type exposes the following members.

Constructors
 | Name | Description
Public method | RingSpinner | Initializes an instance of the RingSpinner class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinning | Gets or sets whether the control is spinning.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LineCap | Gets or sets the ring line cap.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets the ring's outer radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsSpinningProperty | Identifies the IsSpinning dependency property. This field is read-only.
LineCapProperty | Identifies the LineCap dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner Constructor

RingSpinner Constructor
Initializes an instance of the RingSpinner class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RingSpinner()
Public Sub New
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner Properties

RingSpinner Properties

The RingSpinner type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinning | Gets or sets whether the control is spinning.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LineCap | Gets or sets the ring line cap.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets the ring's outer radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.IsSpinning Property

RingSpinnerIsSpinning Property
Gets or sets whether the control is spinning.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSpinning { get; set; }
Public Property IsSpinning As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control is spinning; otherwise, false. The default value is false.
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.LineCap Property

RingSpinnerLineCap Property
Gets or sets the ring line cap.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PenLineCap LineCap { get; set; }
Public Property LineCap As PenLineCap
    Get
    Set

Property Value

Type: PenLineCap
The ring line cap. The default value is Round.
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.Radius Property

RingSpinnerRadius Property
Gets the ring's outer radius.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Radius { get; }
Public ReadOnly Property Radius As Double
    Get

Property Value

Type: Double
The ring's outer radius. The default value is 8.0.
Remarks
This ring is rendered inward from this radius.
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner Methods

RingSpinner Methods

The RingSpinner type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.ArrangeOverride Method

RingSpinnerArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.ArrangeOverride Method (Size)

RingSpinnerArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

RingSpinner Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.MeasureOverride Method

RingSpinnerMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.MeasureOverride Method (Size)

RingSpinnerMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

RingSpinner Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.OnApplyTemplate Method

RingSpinnerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner Events

RingSpinner Events

The RingSpinner type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner Fields

RingSpinner Fields

The RingSpinner type exposes the following members.

Fields
Name | Description
IsSpinningProperty | Identifies the IsSpinning dependency property. This field is read-only.
LineCapProperty | Identifies the LineCap dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
Top
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.IsSpinningProperty Field

RingSpinnerIsSpinningProperty Field
Identifies the IsSpinning dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSpinningProperty
Public Shared ReadOnly IsSpinningProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSpinning dependency property.
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.LineCapProperty Field

RingSpinnerLineCapProperty Field
Identifies the LineCap dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineCapProperty
Public Shared ReadOnly LineCapProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineCap dependency property.
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RingSpinner.RadiusProperty Field

RingSpinnerRadiusProperty Field
Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RingSpinner Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode Class

RoundMode Class
Specifies the mode of rounding a value.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.ControlsRoundMode

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class RoundMode : Enum
Public NotInheritable Class RoundMode
    Inherits Enum

The RoundMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Ceiling | The smallest integer greater than or equal to the value is returned.
 | CeilingToEven | The smallest even integer greater than or equal to the value is returned.
 | CeilingToOdd | The smallest odd integer greater than or equal to the value is returned.
 | Floor | The largest integer less than or equal to the value is returned.
 | FloorToEven | The largest even integer less than or equal to the value is returned.
 | FloorToOdd | The largest odd integer less than or equal to the value is returned.
 | None | No rounding is applied.
 | Round | The closest integer to the value is returned.
 | RoundToEven | The closest even integer to the value is returned.
 | RoundToOdd | The closest odd integer to the value is returned.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode Methods

RoundMode Methods

The RoundMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode Fields

RoundMode Fields

The RoundMode type exposes the following members.

Fields
 | Name | Description
 | Ceiling | The smallest integer greater than or equal to the value is returned.
 | CeilingToEven | The smallest even integer greater than or equal to the value is returned.
 | CeilingToOdd | The smallest odd integer greater than or equal to the value is returned.
 | Floor | The largest integer less than or equal to the value is returned.
 | FloorToEven | The largest even integer less than or equal to the value is returned.
 | FloorToOdd | The largest odd integer less than or equal to the value is returned.
 | None | No rounding is applied.
 | Round | The closest integer to the value is returned.
 | RoundToEven | The closest even integer to the value is returned.
 | RoundToOdd | The closest odd integer to the value is returned.
Public field | value__ |
Top
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.Ceiling Field

RoundModeCeiling Field
The smallest integer greater than or equal to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode Ceiling = 4
Public Const Ceiling As RoundMode = 4

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.CeilingToEven Field

RoundModeCeilingToEven Field
The smallest even integer greater than or equal to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode CeilingToEven = 5
Public Const CeilingToEven As RoundMode = 5

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.CeilingToOdd Field

RoundModeCeilingToOdd Field
The smallest odd integer greater than or equal to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode CeilingToOdd = 6
Public Const CeilingToOdd As RoundMode = 6

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.Floor Field

RoundModeFloor Field
The largest integer less than or equal to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode Floor = 1
Public Const Floor As RoundMode = 1

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.FloorToEven Field

RoundModeFloorToEven Field
The largest even integer less than or equal to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode FloorToEven = 2
Public Const FloorToEven As RoundMode = 2

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.FloorToOdd Field

RoundModeFloorToOdd Field
The largest odd integer less than or equal to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode FloorToOdd = 3
Public Const FloorToOdd As RoundMode = 3

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.None Field

RoundModeNone Field
No rounding is applied.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode None = 0
Public Const None As RoundMode = 0

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.Round Field

RoundModeRound Field
The closest integer to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode Round = 7
Public Const Round As RoundMode = 7

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.RoundToEven Field

RoundModeRoundToEven Field
The closest even integer to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode RoundToEven = 8
Public Const RoundToEven As RoundMode = 8

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.RoundToOdd Field

RoundModeRoundToOdd Field
The closest odd integer to the value is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RoundMode RoundToOdd = 9
Public Const RoundToOdd As RoundMode = 9

Field Value

Type: RoundMode
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


RoundMode.value__ Field

RoundModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.RoundMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

RoundMode Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side Class

Side Class
Specifies a single side of a rectangle.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.ControlsSide

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class Side : Enum
Public NotInheritable Class Side
    Inherits Enum

The Side type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Bottom | Indicates the bottom side.
 | Left | Indicates the left side.
 | Right | Indicates the right side.
 | Top | Indicates the top side.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


Side Methods

Side Methods

The Side type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side Fields

Side Fields

The Side type exposes the following members.

Fields
 | Name | Description
 | Bottom | Indicates the bottom side.
 | Left | Indicates the left side.
 | Right | Indicates the right side.
 | Top | Indicates the top side.
Public field | value__ |
Top
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side.Bottom Field

SideBottom Field
Indicates the bottom side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Side Bottom = 3
Public Const Bottom As Side = 3

Field Value

Type: Side
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side.Left Field

SideLeft Field
Indicates the left side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Side Left = 0
Public Const Left As Side = 0

Field Value

Type: Side
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side.Right Field

SideRight Field
Indicates the right side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Side Right = 2
Public Const Right As Side = 2

Field Value

Type: Side
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side.Top Field

SideTop Field
Indicates the top side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Side Top = 1
Public Const Top As Side = 1

Field Value

Type: Side
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Side.value__ Field

Sidevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Side.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Side Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides Class

Sides Class
Specifies zero or more sides of a rectangle as a combination of flags.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.ControlsSides

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class Sides : Enum
<FlagsAttribute>
Public NotInheritable Class Sides
    Inherits Enum

The Sides type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates all four sides, left, top, right, and bottom.
 | Bottom | Indicates the bottom side.
 | Left | Indicates the left side.
 | None | Indicates no sides.
 | Right | Indicates the right side.
 | Top | Indicates the top side.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


Sides Methods

Sides Methods

The Sides type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides Fields

Sides Fields

The Sides type exposes the following members.

Fields
 | Name | Description
 | All | Indicates all four sides, left, top, right, and bottom.
 | Bottom | Indicates the bottom side.
 | Left | Indicates the left side.
 | None | Indicates no sides.
 | Right | Indicates the right side.
 | Top | Indicates the top side.
Public field | value__ |
Top
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.All Field

SidesAll Field
Indicates all four sides, left, top, right, and bottom.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Sides All = 15
Public Const All As Sides = 15

Field Value

Type: Sides
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.Bottom Field

SidesBottom Field
Indicates the bottom side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Sides Bottom = 8
Public Const Bottom As Sides = 8

Field Value

Type: Sides
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.Left Field

SidesLeft Field
Indicates the left side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Sides Left = 1
Public Const Left As Sides = 1

Field Value

Type: Sides
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.None Field

SidesNone Field
Indicates no sides.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Sides None = 0
Public Const None As Sides = 0

Field Value

Type: Sides
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.Right Field

SidesRight Field
Indicates the right side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Sides Right = 4
Public Const Right As Sides = 4

Field Value

Type: Sides
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.Top Field

SidesTop Field
Indicates the top side.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Sides Top = 2
Public Const Top As Sides = 2

Field Value

Type: Sides
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


Sides.value__ Field

Sidesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Sides.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Sides Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter Class

TransitioningContentPresenter Class
Represents a control that can display various content transitions between two elements.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TransitioningContentPresenter : Control
Public Class TransitioningContentPresenter
    Inherits Control

The TransitioningContentPresenter type exposes the following members.

Constructors
 | Name | Description
Public method | TransitioningContentPresenter | Initializes a new instance of the TransitioningContentPresenter class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content presented by this control.
Public property | ContentTemplate | Gets or sets the DataTemplate used by this control to present the content.
Public property | ContentTemplateSelector | Gets or sets the DataTemplateSelector used by this control to present the content.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultDirection | Gets or sets the default ContentTransitionDirection to use for transitions that use a direction.
Public property | DefaultDuration | Gets or sets the default length of time for which a transition plays, not counting repetitions.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transition | Gets or sets the IContentTransition to use for transitioning between two elements.
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTransitionCompleted | Raises the TransitionCompleted event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TransitionCompleted | Occurs after a transition has completed.
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ContentProperty | Identifies the Content dependency property. This field is read-only.
ContentTemplateProperty | Identifies the ContentTemplate dependency property. This field is read-only.
ContentTemplateSelectorProperty | Identifies the ContentTemplateSelector dependency property. This field is read-only.
DefaultDirectionProperty | Identifies the DefaultDirection dependency property. This field is read-only.
DefaultDurationProperty | Identifies the DefaultDuration dependency property. This field is read-only.
TransitionProperty | Identifies the Transition dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter Constructor

TransitioningContentPresenter Constructor
Initializes a new instance of the TransitioningContentPresenter class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TransitioningContentPresenter()
Public Sub New
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter Properties

TransitioningContentPresenter Properties

The TransitioningContentPresenter type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content presented by this control.
Public property | ContentTemplate | Gets or sets the DataTemplate used by this control to present the content.
Public property | ContentTemplateSelector | Gets or sets the DataTemplateSelector used by this control to present the content.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultDirection | Gets or sets the default ContentTransitionDirection to use for transitions that use a direction.
Public property | DefaultDuration | Gets or sets the default length of time for which a transition plays, not counting repetitions.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transition | Gets or sets the IContentTransition to use for transitioning between two elements.
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.Content Property

TransitioningContentPresenterContent Property
Gets or sets the content presented by this control.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Content { get; set; }
Public Property Content As Object
    Get
    Set

Property Value

Type: Object
The content presented by this control.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.ContentTemplate Property

TransitioningContentPresenterContentTemplate Property
Gets or sets the DataTemplate used by this control to present the content.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ContentTemplate { get; set; }
Public Property ContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate used by this control to present the content.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.ContentTemplateSelector Property

TransitioningContentPresenterContentTemplateSelector Property
Gets or sets the DataTemplateSelector used by this control to present the content.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector ContentTemplateSelector { get; set; }
Public Property ContentTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector used by this control to present the content.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.DefaultDirection Property

TransitioningContentPresenterDefaultDirection Property
Gets or sets the default ContentTransitionDirection to use for transitions that use a direction.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionDirection DefaultDirection { get; set; }
Public Property DefaultDirection As ContentTransitionDirection
    Get
    Set

Property Value

Type: ContentTransitionDirection
The default ContentTransitionDirection to use for transitions that use a direction. The default value is Forward.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.DefaultDuration Property

TransitioningContentPresenterDefaultDuration Property
Gets or sets the default length of time for which a transition plays, not counting repetitions.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Duration DefaultDuration { get; set; }
Public Property DefaultDuration As Duration
    Get
    Set

Property Value

Type: Duration
The presenter's default simple duration for transitions: the amount of time a transition takes to complete a single forward iteration. The default value is 0.2 seconds.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.Transition Property

TransitioningContentPresenterTransition Property
Gets or sets the IContentTransition to use for transitioning between two elements.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IContentTransition Transition { get; set; }
Public Property Transition As IContentTransition
    Get
    Set

Property Value

Type: IContentTransition
The IContentTransition to use for transitioning between two elements.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter Methods

TransitioningContentPresenter Methods

The TransitioningContentPresenter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTransitionCompleted | Raises the TransitionCompleted event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.OnApplyTemplate Method

TransitioningContentPresenterOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.OnTransitionCompleted Method

TransitioningContentPresenterOnTransitionCompleted Method
Raises the TransitionCompleted event.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTransitionCompleted(
    Object fromContent,
    Object toContent
)
Protected Overridable Sub OnTransitionCompleted (
    fromContent As Object,
    toContent As Object
)

Parameters

fromContent
Type: SystemObject
The element from which a transition occurred.
toContent
Type: SystemObject
The element to which a transition is occurred.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter Events

TransitioningContentPresenter Events

The TransitioningContentPresenter type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TransitionCompleted | Occurs after a transition has completed.
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.TransitionCompleted Event

TransitioningContentPresenterTransitionCompleted Event
Occurs after a transition has completed.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyChangedEventArgs<Object>> TransitionCompleted
Public Event TransitionCompleted As EventHandler(Of PropertyChangedEventArgs(Of Object))

Value

Type: SystemEventHandler PropertyChangedEventArgs Object
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter Fields

TransitioningContentPresenter Fields

The TransitioningContentPresenter type exposes the following members.

Fields
Name | Description
ContentProperty | Identifies the Content dependency property. This field is read-only.
ContentTemplateProperty | Identifies the ContentTemplate dependency property. This field is read-only.
ContentTemplateSelectorProperty | Identifies the ContentTemplateSelector dependency property. This field is read-only.
DefaultDirectionProperty | Identifies the DefaultDirection dependency property. This field is read-only.
DefaultDurationProperty | Identifies the DefaultDuration dependency property. This field is read-only.
TransitionProperty | Identifies the Transition dependency property. This field is read-only.
Top
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.ContentProperty Field

TransitioningContentPresenterContentProperty Field
Identifies the Content dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContentProperty
Public Shared ReadOnly ContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Content dependency property.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.ContentTemplateProperty Field

TransitioningContentPresenterContentTemplateProperty Field
Identifies the ContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContentTemplateProperty
Public Shared ReadOnly ContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContentTemplate dependency property.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.ContentTemplateSelectorProperty Field

TransitioningContentPresenterContentTemplateSelectorProperty Field
Identifies the ContentTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContentTemplateSelectorProperty
Public Shared ReadOnly ContentTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContentTemplateSelector dependency property.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.DefaultDirectionProperty Field

TransitioningContentPresenterDefaultDirectionProperty Field
Identifies the DefaultDirection dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultDirectionProperty
Public Shared ReadOnly DefaultDirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultDirection dependency property.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.DefaultDurationProperty Field

TransitioningContentPresenterDefaultDurationProperty Field
Identifies the DefaultDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultDurationProperty
Public Shared ReadOnly DefaultDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultDuration dependency property.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


TransitioningContentPresenter.TransitionProperty Field

TransitioningContentPresenterTransitionProperty Field
Identifies the Transition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TransitionProperty
Public Shared ReadOnly TransitionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Transition dependency property.
See Also

Reference

TransitioningContentPresenter Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid Class

UniformGrid Class
UniformGrid is a Panel that arranges content in a grid where all the cells in the grid have the same size.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.ControlsUniformGrid

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UniformGrid : Panel
Public Class UniformGrid
    Inherits Panel

The UniformGrid type exposes the following members.

Constructors
 | Name | Description
Public method | UniformGrid | Initializes a new instance of the UniformGrid class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Columns | Gets or sets the number of columns that are in the grid.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FirstColumn | Gets or sets the number of leading blank cells in the first row of the grid.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Rows | Gets or sets the number of rows that are in the grid.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ColumnsProperty | Identifies the Columns dependency property. This field is read-only.
FirstColumnProperty | Identifies the FirstColumn dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid Constructor

UniformGrid Constructor
Initializes a new instance of the UniformGrid class

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UniformGrid()
Public Sub New
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid Properties

UniformGrid Properties

The UniformGrid type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Columns | Gets or sets the number of columns that are in the grid.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FirstColumn | Gets or sets the number of leading blank cells in the first row of the grid.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Rows | Gets or sets the number of rows that are in the grid.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.Columns Property

UniformGridColumns Property
Gets or sets the number of columns that are in the grid.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Columns { get; set; }
Public Property Columns As Integer
    Get
    Set

Property Value

Type: Int32
The number of columns that are in the grid. The default value is 0.
Remarks
A value of zero (0) specifies that the column count is computed based on the number of rows and the number of visible child elements that are in the grid.

The value of the FirstColumn property must be less than the value of the Columns property for the grid to work correctly.

See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.FirstColumn Property

UniformGridFirstColumn Property
Gets or sets the number of leading blank cells in the first row of the grid.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FirstColumn { get; set; }
Public Property FirstColumn As Integer
    Get
    Set

Property Value

Type: Int32
The number of leading blank cells in the first row of the grid. The default value is 0.
Remarks
The value must be less than the value of the Columns property for the grid to work correctly.
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.Rows Property

UniformGridRows Property
Gets or sets the number of rows that are in the grid.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Rows { get; set; }
Public Property Rows As Integer
    Get
    Set

Property Value

Type: Int32
The number of rows that are in the grid. The default value is 0.
Remarks
A value of zero (0) specifies that the row count is computed based on the number of columns and the number of visible child elements that are in the grid.
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid Methods

UniformGrid Methods

The UniformGrid type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.ArrangeOverride Method

UniformGridArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.ArrangeOverride Method (Size)

UniformGridArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

UniformGrid Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.MeasureOverride Method

UniformGridMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.MeasureOverride Method (Size)

UniformGridMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

UniformGrid Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid Events

UniformGrid Events

The UniformGrid type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid Fields

UniformGrid Fields

The UniformGrid type exposes the following members.

Fields
Name | Description
ColumnsProperty | Identifies the Columns dependency property. This field is read-only.
FirstColumnProperty | Identifies the FirstColumn dependency property. This field is read-only.
Top
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.ColumnsProperty Field

UniformGridColumnsProperty Field
Identifies the Columns dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColumnsProperty
Public Shared ReadOnly ColumnsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Columns dependency property.
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


UniformGrid.FirstColumnProperty Field

UniformGridFirstColumnProperty Field
Identifies the FirstColumn dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FirstColumnProperty
Public Shared ReadOnly FirstColumnProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FirstColumn dependency property.
See Also

Reference

UniformGrid Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel Class

WrapPanel Class
WrapPanel is a Panel that stacks children horizontally left to right, wrapping children that extend past its width onto new rows top-to-bottom, and also has an option for an alternate vertical orientation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.ControlsWrapPanel

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WrapPanel : Panel
Public Class WrapPanel
    Inherits Panel

The WrapPanel type exposes the following members.

Constructors
 | Name | Description
Public method | WrapPanel | Initializes a new instance of the WrapPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Controls the direction that children are laid out. This is a dependency property.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
OrientationProperty | Controls the direction that children are laid out. Horizontal orientation will flow chidren left-to-right, top-to-bottom. Vertical orientation will flow children top-to-bottom, left-to-right.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel Constructor

WrapPanel Constructor
Initializes a new instance of the WrapPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WrapPanel()
Public Sub New
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel Properties

WrapPanel Properties

The WrapPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Controls the direction that children are laid out. This is a dependency property.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel.Orientation Property

WrapPanelOrientation Property
Controls the direction that children are laid out. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation that designates the layout. The default value is Horizontal.
Remarks
Horizontal orientation will flow chidren left-to-right, top-to-bottom. Vertical orientation will flow children top-to-bottom, left-to-right.
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel Methods

WrapPanel Methods

The WrapPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel.ArrangeOverride Method

WrapPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Top
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel.ArrangeOverride Method (Size)

WrapPanelArrangeOverride Method (Size)
Arranges and performs layout on children given a size to layout within.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The size WrapPanel is suggested to occupy for layout.

Return Value

Type: Size
The size WrapPanel occupies after layout.
See Also

Reference

WrapPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel.MeasureOverride Method

WrapPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Top
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel.MeasureOverride Method (Size)

WrapPanelMeasureOverride Method (Size)
Measures all children given an available size and returns its desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the WrapPanel is suggested to fit inside.

Return Value

Type: Size
The desired size of the WrapPanel.
See Also

Reference

WrapPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel Events

WrapPanel Events

The WrapPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel Fields

WrapPanel Fields

The WrapPanel type exposes the following members.

Fields
Name | Description
OrientationProperty | Controls the direction that children are laid out. Horizontal orientation will flow chidren left-to-right, top-to-bottom. Vertical orientation will flow children top-to-bottom, left-to-right.
Top
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


WrapPanel.OrientationProperty Field

WrapPanelOrientationProperty Field
Controls the direction that children are laid out. Horizontal orientation will flow chidren left-to-right, top-to-bottom. Vertical orientation will flow children top-to-bottom, left-to-right.

Namespace: ActiproSoftware.UI.Xaml.Controls
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

WrapPanel Class
ActiproSoftware.UI.Xaml.Controls Namespace


ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace

[Missing <summary> documentation for "N:ActiproSoftware.UI.Xaml.Controls.Automation.Peers"]

Classes
 | Class | Description
Public class | RadialSliderAutomationPeer | Exposes RadialSlider types to UI Automation.


RadialSliderAutomationPeer Class

RadialSliderAutomationPeer Class
Exposes RadialSlider types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Automation.PeersRadialSliderAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Automation.Peers
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RadialSliderAutomationPeer : FrameworkElementAutomationPeer
Public Class RadialSliderAutomationPeer
    Inherits FrameworkElementAutomationPeer

The RadialSliderAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | RadialSliderAutomationPeer | Initializes a new instance of the RadialSliderAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Constructor

RadialSliderAutomationPeer Constructor
Initializes a new instance of the RadialSliderAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Automation.Peers
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RadialSliderAutomationPeer(
    RadialSlider owner
)
Public Sub New (
    owner As RadialSlider
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.ControlsRadialSlider
The owner element.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Properties

RadialSliderAutomationPeer Properties

The RadialSliderAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer Methods

RadialSliderAutomationPeer Methods

The RadialSliderAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer.GetAutomationControlTypeCore Method

RadialSliderAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Automation.Peers
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer.GetClassNameCore Method

RadialSliderAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Automation.Peers
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


RadialSliderAutomationPeer.GetLocalizedControlTypeCore Method

RadialSliderAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Automation.Peers
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

RadialSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace
Contains classes that support implementing bar code controls.
Classes
 | Class | Description
Public class | BarCode | Represents a control that can display a bar code.
Public class | BarCodeSymbology | Provides the base class for a bar code symbology.
Public class | CodabarSymbology | Represents a bar code symbology implementation for Codabar. This symbology is also known as Ames Code, ANSI/AIM Codabar, Code 2 of 7, Monarch, NW-7, Rationalized Codabar, and USD-4.
Public class | Code128Symbology | Represents a bar code symbology implementation for Code 128.
Public class | Code39ExtendedSymbology | Represents a bar code symbology implementation for Code 39 Extended. This symbology is also known as Code 39 Full ASCII.
Public class | Code39Symbology | Represents a bar code symbology implementation for Code 39. This symbology is also known as Alpha39, Code 39 mod 43, Code 3 of 9, Code 3/9, USD-3, and USS Code 39.
Public class | Code93ExtendedSymbology | Represents a bar code symbology implementation for Code 93 Extended. This symbology is also known as Code 93 Full ASCII.
Public class | Code93Symbology | Represents a bar code symbology implementation for Code 93.
Public class | Ean13Symbology | Represents a bar code symbology implementation for EAN-13. This symbology is also known as European Article Number 13, and Japanese Article Number (JAN) in Japan.
Public class | Ean8Symbology | Represents a bar code symbology implementation for EAN-8.
Public class | Grid2DBarCodeSymbology | Provides the base class for a two dimensional grid bar code symbology.
Public class | Interleaved2of5Symbology | Represents a bar code symbology implementation for Interleaved 2 of 5.
Public class | LinearBarCodeSymbology | Provides the base class for a one-dimensional bar code symbology.
Public class | LinearBarCodeSymbologyInstruction | Specifies an instruction for a LinearBarCodeSymbology.
Public class | LinearBarCodeValueDisplayStyle | Specifies the display style for the value of a LinearBarCodeSymbology.
Public class | QrCodeSymbology | Represents a bar code symbology implementation for QrCode.
Public class | QrEncodingMode | Specifies the various encoding modes supported by QrCodeSymbology.
Public class | QrErrorCorrectionLevel | Specifies the various error correction levels supported by QrCodeSymbology.
Public class | QrVersion | Specifies the various versions supported by QrCodeSymbology. The size of the symbol for Micro QR Code symbols is always 9 + (2 * microVersion). For the 40 versions of regular QR Code symbols, the size is 17 + (4 * version). All versions are square.
Public class | UpcASymbology | Represents a bar code symbology implementation for UPC-A. This symbology is also known as Universal Product Code version A.
Public class | UpcESymbology | Represents a bar code symbology implementation for UPC-E.


BarCode Class

BarCode Class
Represents a control that can display a bar code.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCode

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BarCode : Control
Public Class BarCode
    Inherits Control

The BarCode type exposes the following members.

Constructors
 | Name | Description
Public method | BarCode | Initializes a new instance of the BarCode class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Caption | Gets or sets the caption to display above the bar code.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the border.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCaption | Gets a value indicating whether Caption has a non-null/empty value.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Symbology | Gets or sets the BarCodeSymbology used to render the core bar code.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this type. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CaptionProperty | Identifies the Caption dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
HasCaptionProperty | Identifies the HasCaption dependency property. This field is read-only.
SymbologyProperty | Identifies the Symbology dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode Constructor

BarCode Constructor
Initializes a new instance of the BarCode class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BarCode()
Public Sub New
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode Properties

BarCode Properties

The BarCode type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Caption | Gets or sets the caption to display above the bar code.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the border.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCaption | Gets a value indicating whether Caption has a non-null/empty value.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Symbology | Gets or sets the BarCodeSymbology used to render the core bar code.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.Caption Property

BarCodeCaption Property
Gets or sets the caption to display above the bar code.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String
The caption to display above the bar code.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.CornerRadius Property

BarCodeCornerRadius Property
Gets or sets the corner radius of the border.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the border.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.HasCaption Property

BarCodeHasCaption Property
Gets a value indicating whether Caption has a non-null/empty value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCaption { get; }
Public ReadOnly Property HasCaption As Boolean
    Get

Property Value

Type: Boolean
true if Caption has a non-null/empty value; otherwise, false. The default value is false.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.Symbology Property

BarCodeSymbology Property
Gets or sets the BarCodeSymbology used to render the core bar code.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BarCodeSymbology Symbology { get; set; }
Public Property Symbology As BarCodeSymbology
    Get
    Set

Property Value

Type: BarCodeSymbology
The BarCodeSymbology used to render the core bar code.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode Methods

BarCode Methods

The BarCode type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this type. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.OnApplyTemplate Method

BarCodeOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.OnCreateAutomationPeer Method

BarCodeOnCreateAutomationPeer Method
Creates and returns an AutomationPeer object for this type.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The AutomationPeer that was created.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode Events

BarCode Events

The BarCode type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode Fields

BarCode Fields

The BarCode type exposes the following members.

Fields
Name | Description
CaptionProperty | Identifies the Caption dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
HasCaptionProperty | Identifies the HasCaption dependency property. This field is read-only.
SymbologyProperty | Identifies the Symbology dependency property. This field is read-only.
Top
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.CaptionProperty Field

BarCodeCaptionProperty Field
Identifies the Caption dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CaptionProperty
Public Shared ReadOnly CaptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Caption dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.CornerRadiusProperty Field

BarCodeCornerRadiusProperty Field
Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.HasCaptionProperty Field

BarCodeHasCaptionProperty Field
Identifies the HasCaption dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCaptionProperty
Public Shared ReadOnly HasCaptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCaption dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCode.SymbologyProperty Field

BarCodeSymbologyProperty Field
Identifies the Symbology dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SymbologyProperty
Public Shared ReadOnly SymbologyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Symbology dependency property.
See Also

Reference

BarCode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology Class

BarCodeSymbology Class
Provides the base class for a bar code symbology.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesGrid2DBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class BarCodeSymbology : Control
Public MustInherit Class BarCodeSymbology
    Inherits Control

The BarCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeSymbology | Initializes a new instance of the BarCodeSymbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the Value to the specified Canvas.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value.
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
ZoomLevelProperty | Identifies the ZoomLevel dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology Constructor

BarCodeSymbology Constructor
Initializes a new instance of the BarCodeSymbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BarCodeSymbology()
Public Sub New
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology Properties

BarCodeSymbology Properties

The BarCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code.
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.DisplayName Property

BarCodeSymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract string DisplayName { get; }
Public MustOverride ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.Value Property

BarCodeSymbologyValue Property
Gets or sets the value to encode in the bar code.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value to encode in the bar code.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.ZoomLevel Property

BarCodeSymbologyZoomLevel Property
Gets or sets the zoom level of the rendered bar code.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ZoomLevel { get; set; }
Public Property ZoomLevel As Double
    Get
    Set

Property Value

Type: Double
The zoom level of the rendered bar code. The default value is 1.0.
Remarks
It is highly recommended to only set this property to integer levels to ensure that bar codes render crisply and without anti-aliasing.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology Methods

BarCodeSymbology Methods

The BarCodeSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the Value to the specified Canvas.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.MeasureDesiredSize Method

BarCodeSymbologyMeasureDesiredSize Method
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Size MeasureDesiredSize(
    Size availableSize
)
Protected MustOverride Function MeasureDesiredSize (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.MeasureOverride Method

BarCodeSymbologyMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.MeasureOverride Method (Size)

BarCodeSymbologyMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Size MeasureOverride(
    Size availableSize
)
Protected Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

BarCodeSymbology Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.OnApplyTemplate Method

BarCodeSymbologyOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.OnValueChanged Method

BarCodeSymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overridable Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.Refresh Method

BarCodeSymbologyRefresh Method
Refreshes the bar code rendering.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.Render Method

BarCodeSymbologyRender Method
Renders the Value to the specified Canvas.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void Render(
    Canvas canvas,
    Rect bounds
)
Protected MustOverride Sub Render (
    canvas As Canvas,
    bounds As Rect
)

Parameters

canvas
Type: Windows.UI.Xaml.ControlsCanvas
The Canvas in which to render.
bounds
Type: Windows.FoundationRect
The bounds in which to render.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.ValidateValue Method

BarCodeSymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract ValidationResult ValidateValue(
    string value
)
Public MustOverride Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology Events

BarCodeSymbology Events

The BarCodeSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology Fields

BarCodeSymbology Fields

The BarCodeSymbology type exposes the following members.

Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
ZoomLevelProperty | Identifies the ZoomLevel dependency property. This field is read-only.
Top
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.ValueProperty Field

BarCodeSymbologyValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


BarCodeSymbology.ZoomLevelProperty Field

BarCodeSymbologyZoomLevelProperty Field
Identifies the ZoomLevel dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomLevelProperty
Public Shared ReadOnly ZoomLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomLevel dependency property.
See Also

Reference

BarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology Class

CodabarSymbology Class
Represents a bar code symbology implementation for Codabar.

This symbology is also known as Ames Code, ANSI/AIM Codabar, Code 2 of 7, Monarch, NW-7, Rationalized Codabar, and USD-4.

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCodabarSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CodabarSymbology : LinearBarCodeSymbology
Public Class CodabarSymbology
    Inherits LinearBarCodeSymbology

The CodabarSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | CodabarSymbology | Initializes an instance of the CodabarSymbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters are visible in the displayed value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Codabar is a linear symbology, developed in 1972 by Pitney Bowes, Inc. It is most commonly used by libraries, blood banks, and on FedEx airbills.

This symbology can encode 16 characters (0 through 9, and -$:/.+), along with 4 start/stop characters.

Each encoded value must start and stop with A, B, C, or D. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology is self-checking, so no checksum or check digit is required.

For detailed documentation on this symbology's features and how to use them, please see the Codabar documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology Constructor

CodabarSymbology Constructor
Initializes an instance of the CodabarSymbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CodabarSymbology()
Public Sub New
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology Properties

CodabarSymbology Properties

The CodabarSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters are visible in the displayed value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology.AreStartStopCharactersVisible Property

CodabarSymbologyAreStartStopCharactersVisible Property
Gets or sets whether the start/stop characters are visible in the displayed value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreStartStopCharactersVisible { get; set; }
Public Property AreStartStopCharactersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the start/stop characters are visible in the displayed value; otherwise, false. The default value is false.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology.DisplayName Property

CodabarSymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology Methods

CodabarSymbology Methods

The CodabarSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology.OnValueChanged Method

CodabarSymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology.ValidateValue Method

CodabarSymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology Events

CodabarSymbology Events

The CodabarSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology Fields

CodabarSymbology Fields

The CodabarSymbology type exposes the following members.

Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


CodabarSymbology.AreStartStopCharactersVisibleProperty Field

CodabarSymbologyAreStartStopCharactersVisibleProperty Field
Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreStartStopCharactersVisibleProperty
Public Shared ReadOnly AreStartStopCharactersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreStartStopCharactersVisible dependency property.
See Also

Reference

CodabarSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology Class

Code128Symbology Class
Represents a bar code symbology implementation for Code 128.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode128Symbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Code128Symbology : LinearBarCodeSymbology
Public Class Code128Symbology
    Inherits LinearBarCodeSymbology

The Code128Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code128Symbology | Initializes an instance of the Code128Symbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
Fnc1Char | The character that can be used to encode FNC1.
Fnc2Char | The character that can be used to encode FNC2.
Fnc3Char | The character that can be used to encode FNC3.
Fnc4Char | The character that can be used to encode FNC4.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Code 128 is a high-density barcode symbology, used extensively worldwide in shipping and packaging industries.

This symbology can encode all of the lower 128 ASCII characters. It is especially efficient when encoding sequential numbers since they are merged into a single output character width.

This symbology implementation auto-calculates and inserts a check character.

For detailed documentation on this symbology's features and how to use them, please see the Code 128 documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology Constructor

Code128Symbology Constructor
Initializes an instance of the Code128Symbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Code128Symbology()
Public Sub New
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology Properties

Code128Symbology Properties

The Code128Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.DisplayName Property

Code128SymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology Methods

Code128Symbology Methods

The Code128Symbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.OnValueChanged Method

Code128SymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.ValidateValue Method

Code128SymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology Events

Code128Symbology Events

The Code128Symbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology Fields

Code128Symbology Fields

The Code128Symbology type exposes the following members.

Fields
Name | Description
Fnc1Char | The character that can be used to encode FNC1.
Fnc2Char | The character that can be used to encode FNC2.
Fnc3Char | The character that can be used to encode FNC3.
Fnc4Char | The character that can be used to encode FNC4.
Top
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.Fnc1Char Field

Code128SymbologyFnc1Char Field
The character that can be used to encode FNC1.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const char Fnc1Char = ''
Public Const Fnc1Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.Fnc2Char Field

Code128SymbologyFnc2Char Field
The character that can be used to encode FNC2.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const char Fnc2Char = ''
Public Const Fnc2Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.Fnc3Char Field

Code128SymbologyFnc3Char Field
The character that can be used to encode FNC3.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const char Fnc3Char = ''
Public Const Fnc3Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code128Symbology.Fnc4Char Field

Code128SymbologyFnc4Char Field
The character that can be used to encode FNC4.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const char Fnc4Char = ''
Public Const Fnc4Char As Char = ""C

Field Value

Type: Char
See Also

Reference

Code128Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology Class

Code39ExtendedSymbology Class
Represents a bar code symbology implementation for Code 39 Extended.

This symbology is also known as Code 39 Full ASCII.

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode39Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode39ExtendedSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Code39ExtendedSymbology : Code39Symbology
Public Class Code39ExtendedSymbology
    Inherits Code39Symbology

The Code39ExtendedSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code39ExtendedSymbology | Initializes a new instance of the Code39ExtendedSymbology class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code39Symbology.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides Code39SymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added. (Inherited from Code39Symbology.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code39Symbology.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code39SymbologyPreprocessCharacter(Char).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code39SymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Code 39 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 39.

This symbology can encode all of the lower 128 ASCII characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology is self-checking, so no checksum or check digit is required. However if the IsChecksumEnabled property is true, the symbology's implementation auto-calculates and inserts a check digit. This is referred to as Code 39 mod 43.

The standard implementation of Code 39 is available in Code39Symbology. That implementation allows for encoding a subset of the characters able to be encoded by this symbology.

For detailed documentation on this symbology's features and how to use them, please see the Code 39 Extended documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology Constructor

Code39ExtendedSymbology Constructor
Initializes a new instance of the Code39ExtendedSymbology class

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Code39ExtendedSymbology()
Public Sub New
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology Properties

Code39ExtendedSymbology Properties

The Code39ExtendedSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code39Symbology.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides Code39SymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added. (Inherited from Code39Symbology.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology.DisplayName Property

Code39ExtendedSymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology Methods

Code39ExtendedSymbology Methods

The Code39ExtendedSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code39Symbology.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code39SymbologyPreprocessCharacter(Char).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code39SymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology.PreprocessCharacter Method

Code39ExtendedSymbologyPreprocessCharacter Method
Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string PreprocessCharacter(
    char ch
)
Protected Overrides Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology.ValidateValue Method

Code39ExtendedSymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39ExtendedSymbology Events

Code39ExtendedSymbology Events

The Code39ExtendedSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Code39ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology Class

Code39Symbology Class
Represents a bar code symbology implementation for Code 39.

This symbology is also known as Alpha39, Code 39 mod 43, Code 3 of 9, Code 3/9, USD-3, and USS Code 39.

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode39Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode39ExtendedSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Code39Symbology : LinearBarCodeSymbology
Public Class Code39Symbology
    Inherits LinearBarCodeSymbology

The Code39Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code39Symbology | Initializes an instance of the Code39Symbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Code 39 is a linear symbology, and is one of the first alphanumeric bar codes. Each character encoded is made up of 5 bars and 4 spaces for a total of 9 elements. 3 out of the 9 element are always wide. Although it is not as dense of a symbology such as Code 128, it is one of the most widely supported symbologies by devices.

This symbology can encode numbers, uppercase letters, and -$% ./+ characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology is self-checking, so no checksum or check digit is required. However if the IsChecksumEnabled property is true, the symbology's implementation auto-calculates and inserts a check digit. This is referred to as Code 39 mod 43.

An extended implementation of Code 39 is available in Code39ExtendedSymbology. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 39 concepts.

For detailed documentation on this symbology's features and how to use them, please see the Code 39 documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology Constructor

Code39Symbology Constructor
Initializes an instance of the Code39Symbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Code39Symbology()
Public Sub New
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology Properties

Code39Symbology Properties

The Code39Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.AreStartStopCharactersVisible Property

Code39SymbologyAreStartStopCharactersVisible Property
Gets or sets whether the start/stop characters (*) are visible in the displayed value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreStartStopCharactersVisible { get; set; }
Public Property AreStartStopCharactersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the start/stop characters (*) are visible in the displayed value; otherwise, false. The default value is false.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.DisplayName Property

Code39SymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.IsChecksumEnabled Property

Code39SymbologyIsChecksumEnabled Property
Gets or sets whether the optional checksum should be added.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsChecksumEnabled { get; set; }
Public Property IsChecksumEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the optional checksum should be added; otherwise, false. The default value is false.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology Methods

Code39Symbology Methods

The Code39Symbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.OnValueChanged Method

Code39SymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.PreprocessCharacter Method

Code39SymbologyPreprocessCharacter Method
Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string PreprocessCharacter(
    char ch
)
Protected Overridable Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.ValidateValue Method

Code39SymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology Events

Code39Symbology Events

The Code39Symbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology Fields

Code39Symbology Fields

The Code39Symbology type exposes the following members.

Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.AreStartStopCharactersVisibleProperty Field

Code39SymbologyAreStartStopCharactersVisibleProperty Field
Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreStartStopCharactersVisibleProperty
Public Shared ReadOnly AreStartStopCharactersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreStartStopCharactersVisible dependency property.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code39Symbology.IsChecksumEnabledProperty Field

Code39SymbologyIsChecksumEnabledProperty Field
Identifies the IsChecksumEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsChecksumEnabledProperty
Public Shared ReadOnly IsChecksumEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsChecksumEnabled dependency property.
See Also

Reference

Code39Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology Class

Code93ExtendedSymbology Class
Represents a bar code symbology implementation for Code 93 Extended.

This symbology is also known as Code 93 Full ASCII.

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode93Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode93ExtendedSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Code93ExtendedSymbology : Code93Symbology
Public Class Code93ExtendedSymbology
    Inherits Code93Symbology

The Code93ExtendedSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code93ExtendedSymbology | Initializes a new instance of the Code93ExtendedSymbology class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code93Symbology.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides Code93SymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code93Symbology.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code93SymbologyPreprocessCharacter(Char).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code93SymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Code 93 Extended is a linear symbology, and supports the encoding of many more characters than standard Code 93.

This symbology can encode all of the lower 128 ASCII characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology implementation auto-calculates and inserts two check characters.

The standard implementation of Code 93 is available in Code93Symbology. That implementation allows for encoding a subset of the characters able to be encoded by this symbology.

For detailed documentation on this symbology's features and how to use them, please see the Code 93 Extended documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology Constructor

Code93ExtendedSymbology Constructor
Initializes a new instance of the Code93ExtendedSymbology class

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Code93ExtendedSymbology()
Public Sub New
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology Properties

Code93ExtendedSymbology Properties

The Code93ExtendedSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value. (Inherited from Code93Symbology.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides Code93SymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology.DisplayName Property

Code93ExtendedSymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology Methods

Code93ExtendedSymbology Methods

The Code93ExtendedSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from Code93Symbology.)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary. (Overrides Code93SymbologyPreprocessCharacter(Char).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides Code93SymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology.PreprocessCharacter Method

Code93ExtendedSymbologyPreprocessCharacter Method
Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string PreprocessCharacter(
    char ch
)
Protected Overrides Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology.ValidateValue Method

Code93ExtendedSymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93ExtendedSymbology Events

Code93ExtendedSymbology Events

The Code93ExtendedSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Code93ExtendedSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology Class

Code93Symbology Class
Represents a bar code symbology implementation for Code 93.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode93Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode93ExtendedSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Code93Symbology : LinearBarCodeSymbology
Public Class Code93Symbology
    Inherits LinearBarCodeSymbology

The Code93Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Code93Symbology | Initializes an instance of the Code93Symbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Code 93 is a linear symbology, designed in 1982 by Intermec to provide a higher density and data security enhancement to Code 39. Each Code 93 character is divided into nine modules and always has three bars and three spaces. This symbology is primarily used by the Canadian postal office.

This symbology can encode numbers, uppercase letters, and -. $/+% characters.

Each encoded value must start and stop with *, which is automatically inserted. The AreStartStopCharactersVisible property determines whether these start/stop characters are included in the DisplayValue.

This symbology implementation auto-calculates and inserts two check characters.

An extended implementation of Code 93 is available in Code93ExtendedSymbology. That implementation allows for all lower 128 ASCII characters to be encoded based on the core Code 93 concepts.

For detailed documentation on this symbology's features and how to use them, please see the Code 93 documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology Constructor

Code93Symbology Constructor
Initializes an instance of the Code93Symbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Code93Symbology()
Public Sub New
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology Properties

Code93Symbology Properties

The Code93Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreStartStopCharactersVisible | Gets or sets whether the start/stop characters (*) are visible in the displayed value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology.AreStartStopCharactersVisible Property

Code93SymbologyAreStartStopCharactersVisible Property
Gets or sets whether the start/stop characters (*) are visible in the displayed value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreStartStopCharactersVisible { get; set; }
Public Property AreStartStopCharactersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the start/stop characters (*) are visible in the displayed value; otherwise, false. The default value is false.
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology.DisplayName Property

Code93SymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology Methods

Code93Symbology Methods

The Code93Symbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Protected method | PreprocessCharacter | Pre-processes the specified character and expands it if necessary.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology.OnValueChanged Method

Code93SymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology.PreprocessCharacter Method

Code93SymbologyPreprocessCharacter Method
Pre-processes the specified character and expands it if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string PreprocessCharacter(
    char ch
)
Protected Overridable Function PreprocessCharacter (
    ch As Char
) As String

Parameters

ch
Type: SystemChar
The character to examine.

Return Value

Type: String
The pre-processing result.
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology.ValidateValue Method

Code93SymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology Events

Code93Symbology Events

The Code93Symbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology Fields

Code93Symbology Fields

The Code93Symbology type exposes the following members.

Fields
Name | Description
AreStartStopCharactersVisibleProperty | Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.
Top
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Code93Symbology.AreStartStopCharactersVisibleProperty Field

Code93SymbologyAreStartStopCharactersVisibleProperty Field
Identifies the AreStartStopCharactersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreStartStopCharactersVisibleProperty
Public Shared ReadOnly AreStartStopCharactersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreStartStopCharactersVisible dependency property.
See Also

Reference

Code93Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology Class

Ean13Symbology Class
Represents a bar code symbology implementation for EAN-13.

This symbology is also known as European Article Number 13, and Japanese Article Number (JAN) in Japan.

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesEan13Symbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Ean13Symbology : LinearBarCodeSymbology
Public Class Ean13Symbology
    Inherits LinearBarCodeSymbology

The Ean13Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Ean13Symbology | Initializes an instance of the Ean13Symbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
EAN-13 is a linear symbology, based on the original 12-digit Universal Product Code (UPC) system developed in North America. EAN-13 bar codes are used worldwide for marking retail goods.

This symbology can encode 13 numeric characters, divided into four parts: system code, manufacturer code, product code, and check digit.

This symbology implementation auto-calculates and inserts a check digit.

For detailed documentation on this symbology's features and how to use them, please see the EAN-13 documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology Constructor

Ean13Symbology Constructor
Initializes an instance of the Ean13Symbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Ean13Symbology()
Public Sub New
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology Properties

Ean13Symbology Properties

The Ean13Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology.DisplayName Property

Ean13SymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology Methods

Ean13Symbology Methods

The Ean13Symbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology.OnValueChanged Method

Ean13SymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology.ValidateValue Method

Ean13SymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean13Symbology Events

Ean13Symbology Events

The Ean13Symbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Ean13Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology Class

Ean8Symbology Class
Represents a bar code symbology implementation for EAN-8.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesEan8Symbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Ean8Symbology : LinearBarCodeSymbology
Public Class Ean8Symbology
    Inherits LinearBarCodeSymbology

The Ean8Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Ean8Symbology | Initializes an instance of the Ean8Symbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
EAN-8 is a linear symbology, used on smaller retail packages where EAN-13 bar codes don't fit.

This symbology can encode 8 numeric characters, divided into three parts: system code, product code, and check digit.

This symbology implementation auto-calculates and inserts a check digit.

For detailed documentation on this symbology's features and how to use them, please see the EAN-8 documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology Constructor

Ean8Symbology Constructor
Initializes an instance of the Ean8Symbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Ean8Symbology()
Public Sub New
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology Properties

Ean8Symbology Properties

The Ean8Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology.DisplayName Property

Ean8SymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology Methods

Ean8Symbology Methods

The Ean8Symbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology.OnValueChanged Method

Ean8SymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology.ValidateValue Method

Ean8SymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Ean8Symbology Events

Ean8Symbology Events

The Ean8Symbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Ean8Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology Class

Grid2DBarCodeSymbology Class
Provides the base class for a two dimensional grid bar code symbology.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesGrid2DBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesQrCodeSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class Grid2DBarCodeSymbology : BarCodeSymbology
Public MustInherit Class Grid2DBarCodeSymbology
    Inherits BarCodeSymbology

The Grid2DBarCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Protected method | Grid2DBarCodeSymbology | Initializes a new instance of the Grid2DBarCodeSymbology class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides BarCodeSymbologyMeasureDesiredSize(Size).)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Overrides BarCodeSymbologyRender(Canvas, Rect).)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CellSizeProperty | Identifies the CellSize dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology Constructor

Grid2DBarCodeSymbology Constructor
Initializes a new instance of the Grid2DBarCodeSymbology class

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Grid2DBarCodeSymbology()
Protected Sub New
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology Properties

Grid2DBarCodeSymbology Properties

The Grid2DBarCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology.CellSize Property

Grid2DBarCodeSymbologyCellSize Property
Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CellSize { get; set; }
Public Property CellSize As Integer
    Get
    Set

Property Value

Type: Int32
The size of the cell.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology.QuietZoneThickness Property

Grid2DBarCodeSymbologyQuietZoneThickness Property
Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness QuietZoneThickness { get; set; }
Public Property QuietZoneThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The quiet zone.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology Methods

Grid2DBarCodeSymbology Methods

The Grid2DBarCodeSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides BarCodeSymbologyMeasureDesiredSize(Size).)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Overrides BarCodeSymbologyRender(Canvas, Rect).)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology.MeasureDesiredSize Method

Grid2DBarCodeSymbologyMeasureDesiredSize Method
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Size MeasureDesiredSize(
    Size availableSize
)
Protected Overrides Function MeasureDesiredSize (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology.Render Method

Grid2DBarCodeSymbologyRender Method
Renders the [!:Value] to the specified Canvas.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Render(
    Canvas canvas,
    Rect bounds
)
Protected Overrides Sub Render (
    canvas As Canvas,
    bounds As Rect
)

Parameters

canvas
Type: Windows.UI.Xaml.ControlsCanvas
The Canvas in which to render.
bounds
Type: Windows.FoundationRect
The bounds in which to render.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology Events

Grid2DBarCodeSymbology Events

The Grid2DBarCodeSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology Fields

Grid2DBarCodeSymbology Fields

The Grid2DBarCodeSymbology type exposes the following members.

Fields
Name | Description
CellSizeProperty | Identifies the CellSize dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
Top
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology.CellSizeProperty Field

Grid2DBarCodeSymbologyCellSizeProperty Field
Identifies the CellSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellSizeProperty
Public Shared ReadOnly CellSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellSize dependency property.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Grid2DBarCodeSymbology.QuietZoneThicknessProperty Field

Grid2DBarCodeSymbologyQuietZoneThicknessProperty Field
Identifies the QuietZoneThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty QuietZoneThicknessProperty
Public Shared ReadOnly QuietZoneThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the QuietZoneThickness dependency property.
See Also

Reference

Grid2DBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology Class

Interleaved2of5Symbology Class
Represents a bar code symbology implementation for Interleaved 2 of 5.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesInterleaved2of5Symbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Interleaved2of5Symbology : LinearBarCodeSymbology
Public Class Interleaved2of5Symbology
    Inherits LinearBarCodeSymbology

The Interleaved2of5Symbology type exposes the following members.

Constructors
 | Name | Description
Public method | Interleaved2of5Symbology | Initializes an instance of the Interleaved2of5Symbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
Interleaved 2 of 5 is a linear symbology, that provides higher density than the Industrial 2 of 5 symbology that it is based on. It is most commonly used by the distribution and warehouse industry.

This symbology can encode numeric digits, and requires that an even number of digits (including the optional check digit) are encoded. This symbology implementation will automatically add a 0 at the start of the encoded value to ensure that an even number of digits are encoded.

The symbology's implementation auto-calculates and inserts an optional check digit if the IsChecksumEnabled property is true.

For detailed documentation on this symbology's features and how to use them, please see the Interleaved 2 of 5 documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology Constructor

Interleaved2of5Symbology Constructor
Initializes an instance of the Interleaved2of5Symbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Interleaved2of5Symbology()
Public Sub New
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology Properties

Interleaved2of5Symbology Properties

The Interleaved2of5Symbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecksumEnabled | Gets or sets whether the optional checksum should be added.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology.DisplayName Property

Interleaved2of5SymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology.IsChecksumEnabled Property

Interleaved2of5SymbologyIsChecksumEnabled Property
Gets or sets whether the optional checksum should be added.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsChecksumEnabled { get; set; }
Public Property IsChecksumEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the optional checksum should be added; otherwise, false. The default value is false.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology Methods

Interleaved2of5Symbology Methods

The Interleaved2of5Symbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology.OnValueChanged Method

Interleaved2of5SymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology.ValidateValue Method

Interleaved2of5SymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology Events

Interleaved2of5Symbology Events

The Interleaved2of5Symbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology Fields

Interleaved2of5Symbology Fields

The Interleaved2of5Symbology type exposes the following members.

Fields
Name | Description
IsChecksumEnabledProperty | Identifies the IsChecksumEnabled dependency property. This field is read-only.
Top
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


Interleaved2of5Symbology.IsChecksumEnabledProperty Field

Interleaved2of5SymbologyIsChecksumEnabledProperty Field
Identifies the IsChecksumEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsChecksumEnabledProperty
Public Shared ReadOnly IsChecksumEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsChecksumEnabled dependency property.
See Also

Reference

Interleaved2of5Symbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology Class

LinearBarCodeSymbology Class
Provides the base class for a one-dimensional bar code symbology.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class LinearBarCodeSymbology : BarCodeSymbology
Public MustInherit Class LinearBarCodeSymbology
    Inherits BarCodeSymbology

The LinearBarCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Protected method | LinearBarCodeSymbology | Initializes a new instance of the LinearBarCodeSymbology class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars.
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides BarCodeSymbologyMeasureDesiredSize(Size).)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Overrides BarCodeSymbologyRender(Canvas, Rect).)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BarHeightProperty | Identifies the BarHeight dependency property. This field is read-only.
BarWidthRatioProperty | Identifies the BarWidthRatio dependency property. This field is read-only.
DisplayValueProperty | Identifies the DisplayValue dependency property. This field is read-only.
MinBarHeightWidthRatioProperty | Identifies the MinBarHeightWidthRatio dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
ValueDisplayStyleProperty | Identifies the ValueDisplayStyle dependency property. This field is read-only.
ValueIntrusionOffsetProperty | Identifies the ValueIntrusionOffset dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCodabarSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode128Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode39Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesCode93Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesEan13Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesEan8Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesInterleaved2of5Symbology
ActiproSoftware.UI.Xaml.Controls.BarCodesUpcASymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesUpcESymbology


LinearBarCodeSymbology Constructor

LinearBarCodeSymbology Constructor
Initializes a new instance of the LinearBarCodeSymbology class

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected LinearBarCodeSymbology()
Protected Sub New
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology Properties

LinearBarCodeSymbology Properties

The LinearBarCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars.
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Inherited from BarCodeSymbology.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.BarHeight Property

LinearBarCodeSymbologyBarHeight Property
Gets or sets the desired height of the bars.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double BarHeight { get; set; }
Public Property BarHeight As Double
    Get
    Set

Property Value

Type: Double
The desired height of the bars. The default value is 35.
Remarks
When calculating the desired height of the bar code, the BarHeight property will be used unless its height is less than the percentage of the desired width specified by MinBarHeightWidthRatio. In that case the MinBarHeightWidthRatio percentage of the desired width is used for height. This ensures that the bar code is always sized to be read properly.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.BarWidthRatio Property

LinearBarCodeSymbologyBarWidthRatio Property
Gets or sets the width ratio of wide lines to narrow lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double BarWidthRatio { get; set; }
Public Property BarWidthRatio As Double
    Get
    Set

Property Value

Type: Double
The width ratio of wide lines to narrow lines. The default value is 2, meaning that wide lines are twice as thick as narrow lines.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.DisplayValue Property

LinearBarCodeSymbologyDisplayValue Property
Gets or sets the value that is displayed if ValueDisplayStyle is not None.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DisplayValue { get; protected set; }
Public Property DisplayValue As String
    Get
    Protected Set

Property Value

Type: String
The value that is displayed if ValueDisplayStyle is not None.
Remarks
This property must be set by each symbology implementation.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.MinBarHeightWidthRatio Property

LinearBarCodeSymbologyMinBarHeightWidthRatio Property
Gets or sets the minimum ratio that the height of the bar code must be in relation to its width.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinBarHeightWidthRatio { get; set; }
Public Property MinBarHeightWidthRatio As Double
    Get
    Set

Property Value

Type: Double
The minimum ratio that the height of the bar code must be in relation to its width. The default value is 0.15 (15%).
Remarks
Many symbologies indicate that the bar code's height must be at least x% of its width. For instance, Code 39 specifies that the height must be at least 15% of the width.

When calculating the desired height of the bar code, the BarHeight property will be used unless its height is less than the percentage of the desired width specified by MinBarHeightWidthRatio. In that case the MinBarHeightWidthRatio percentage of the desired width is used for height. This ensures that the bar code is always sized to be read properly.

See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.QuietZoneThickness Property

LinearBarCodeSymbologyQuietZoneThickness Property
Gets or sets the Thickness of the quiet zone.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness QuietZoneThickness { get; set; }
Public Property QuietZoneThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the quiet zone. The default value is 10,0,10,0.
Remarks
The quiet zone is the margin whitespace area that appears around the bar code.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.ValueDisplayStyle Property

LinearBarCodeSymbologyValueDisplayStyle Property
Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LinearBarCodeValueDisplayStyle ValueDisplayStyle { get; set; }
Public Property ValueDisplayStyle As LinearBarCodeValueDisplayStyle
    Get
    Set

Property Value

Type: LinearBarCodeValueDisplayStyle
A LinearBarCodeValueDisplayStyle that indicates how the value should rendered. The default value is Centered.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.ValueIntrusionOffset Property

LinearBarCodeSymbologyValueIntrusionOffset Property
Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ValueIntrusionOffset { get; set; }
Public Property ValueIntrusionOffset As Double
    Get
    Set

Property Value

Type: Double
The distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. The default value is 0.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology Methods

LinearBarCodeSymbology Methods

The LinearBarCodeSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Overrides BarCodeSymbologyMeasureDesiredSize(Size).)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Inherited from BarCodeSymbology.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Overrides BarCodeSymbologyRender(Canvas, Rect).)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Inherited from BarCodeSymbology.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.MeasureDesiredSize Method

LinearBarCodeSymbologyMeasureDesiredSize Method
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Size MeasureDesiredSize(
    Size availableSize
)
Protected Overrides Function MeasureDesiredSize (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.Render Method

LinearBarCodeSymbologyRender Method
Renders the [!:Value] to the specified Canvas.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Render(
    Canvas canvas,
    Rect bounds
)
Protected Overrides Sub Render (
    canvas As Canvas,
    bounds As Rect
)

Parameters

canvas
Type: Windows.UI.Xaml.ControlsCanvas
The Canvas in which to render.
bounds
Type: Windows.FoundationRect
The bounds in which to render.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology Events

LinearBarCodeSymbology Events

The LinearBarCodeSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology Fields

LinearBarCodeSymbology Fields

The LinearBarCodeSymbology type exposes the following members.

Fields
Name | Description
BarHeightProperty | Identifies the BarHeight dependency property. This field is read-only.
BarWidthRatioProperty | Identifies the BarWidthRatio dependency property. This field is read-only.
DisplayValueProperty | Identifies the DisplayValue dependency property. This field is read-only.
MinBarHeightWidthRatioProperty | Identifies the MinBarHeightWidthRatio dependency property. This field is read-only.
QuietZoneThicknessProperty | Identifies the QuietZoneThickness dependency property. This field is read-only.
ValueDisplayStyleProperty | Identifies the ValueDisplayStyle dependency property. This field is read-only.
ValueIntrusionOffsetProperty | Identifies the ValueIntrusionOffset dependency property. This field is read-only.
Top
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.BarHeightProperty Field

LinearBarCodeSymbologyBarHeightProperty Field
Identifies the BarHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarHeightProperty
Public Shared ReadOnly BarHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarHeight dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.BarWidthRatioProperty Field

LinearBarCodeSymbologyBarWidthRatioProperty Field
Identifies the BarWidthRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarWidthRatioProperty
Public Shared ReadOnly BarWidthRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarWidthRatio dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.DisplayValueProperty Field

LinearBarCodeSymbologyDisplayValueProperty Field
Identifies the DisplayValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayValueProperty
Public Shared ReadOnly DisplayValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayValue dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.MinBarHeightWidthRatioProperty Field

LinearBarCodeSymbologyMinBarHeightWidthRatioProperty Field
Identifies the MinBarHeightWidthRatio dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinBarHeightWidthRatioProperty
Public Shared ReadOnly MinBarHeightWidthRatioProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinBarHeightWidthRatio dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.QuietZoneThicknessProperty Field

LinearBarCodeSymbologyQuietZoneThicknessProperty Field
Identifies the QuietZoneThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty QuietZoneThicknessProperty
Public Shared ReadOnly QuietZoneThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the QuietZoneThickness dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.ValueDisplayStyleProperty Field

LinearBarCodeSymbologyValueDisplayStyleProperty Field
Identifies the ValueDisplayStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueDisplayStyleProperty
Public Shared ReadOnly ValueDisplayStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueDisplayStyle dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbology.ValueIntrusionOffsetProperty Field

LinearBarCodeSymbologyValueIntrusionOffsetProperty Field
Identifies the ValueIntrusionOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueIntrusionOffsetProperty
Public Shared ReadOnly ValueIntrusionOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueIntrusionOffset dependency property.
See Also

Reference

LinearBarCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction Class

LinearBarCodeSymbologyInstruction Class
Specifies an instruction for a LinearBarCodeSymbology.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbologyInstruction

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LinearBarCodeSymbologyInstruction : Enum
Public NotInheritable Class LinearBarCodeSymbologyInstruction
    Inherits Enum

The LinearBarCodeSymbologyInstruction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Black1 | A narrow black line.
 | Black2 | A wide black line (2x narrow).
 | Black3 | A wide black line (3x narrow).
 | Black4 | A wide black line (4x narrow).
 | BlackAscender2 | A wide black line (2x narrow) that only covers the top two-thirds of a normal size line.
 | BlackDescender2 | A wide black line (2x narrow) that only covers the bottom two-thirds of a normal size line.
 | BlackHalfDescender2 | A wide black line (2x narrow) that only covers the bottom third of a normal size line.
 | BlackHalfTracker2 | A wide black line (2x narrow) that only covers the middle third of a normal size line.
 | CharacterEnd | The end of a character.
 | ControlCharacterStart | The start of a control character.
 | EncodedCharacterStart | The start of an encoded character.
Public field | value__ |
 | White1 | A narrow white line.
 | White2 | A wide white line (2x narrow).
 | White3 | A wide white line (3x narrow).
 | White4 | A wide white line (4x narrow).
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction Methods

LinearBarCodeSymbologyInstruction Methods

The LinearBarCodeSymbologyInstruction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction Fields

LinearBarCodeSymbologyInstruction Fields

The LinearBarCodeSymbologyInstruction type exposes the following members.

Fields
 | Name | Description
 | Black1 | A narrow black line.
 | Black2 | A wide black line (2x narrow).
 | Black3 | A wide black line (3x narrow).
 | Black4 | A wide black line (4x narrow).
 | BlackAscender2 | A wide black line (2x narrow) that only covers the top two-thirds of a normal size line.
 | BlackDescender2 | A wide black line (2x narrow) that only covers the bottom two-thirds of a normal size line.
 | BlackHalfDescender2 | A wide black line (2x narrow) that only covers the bottom third of a normal size line.
 | BlackHalfTracker2 | A wide black line (2x narrow) that only covers the middle third of a normal size line.
 | CharacterEnd | The end of a character.
 | ControlCharacterStart | The start of a control character.
 | EncodedCharacterStart | The start of an encoded character.
Public field | value__ |
 | White1 | A narrow white line.
 | White2 | A wide white line (2x narrow).
 | White3 | A wide white line (3x narrow).
 | White4 | A wide white line (4x narrow).
Top
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.Black1 Field

LinearBarCodeSymbologyInstructionBlack1 Field
A narrow black line.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction Black1 = 0
Public Const Black1 As LinearBarCodeSymbologyInstruction = 0

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.Black2 Field

LinearBarCodeSymbologyInstructionBlack2 Field
A wide black line (2x narrow).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction Black2 = 1
Public Const Black2 As LinearBarCodeSymbologyInstruction = 1

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.Black3 Field

LinearBarCodeSymbologyInstructionBlack3 Field
A wide black line (3x narrow).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction Black3 = 2
Public Const Black3 As LinearBarCodeSymbologyInstruction = 2

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.Black4 Field

LinearBarCodeSymbologyInstructionBlack4 Field
A wide black line (4x narrow).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction Black4 = 3
Public Const Black4 As LinearBarCodeSymbologyInstruction = 3

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.BlackAscender2 Field

LinearBarCodeSymbologyInstructionBlackAscender2 Field
A wide black line (2x narrow) that only covers the top two-thirds of a normal size line.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction BlackAscender2 = 4
Public Const BlackAscender2 As LinearBarCodeSymbologyInstruction = 4

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.BlackDescender2 Field

LinearBarCodeSymbologyInstructionBlackDescender2 Field
A wide black line (2x narrow) that only covers the bottom two-thirds of a normal size line.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction BlackDescender2 = 5
Public Const BlackDescender2 As LinearBarCodeSymbologyInstruction = 5

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.BlackHalfDescender2 Field

LinearBarCodeSymbologyInstructionBlackHalfDescender2 Field
A wide black line (2x narrow) that only covers the bottom third of a normal size line.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction BlackHalfDescender2 = 6
Public Const BlackHalfDescender2 As LinearBarCodeSymbologyInstruction = 6

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.BlackHalfTracker2 Field

LinearBarCodeSymbologyInstructionBlackHalfTracker2 Field
A wide black line (2x narrow) that only covers the middle third of a normal size line.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction BlackHalfTracker2 = 7
Public Const BlackHalfTracker2 As LinearBarCodeSymbologyInstruction = 7

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.CharacterEnd Field

LinearBarCodeSymbologyInstructionCharacterEnd Field
The end of a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction CharacterEnd = 14
Public Const CharacterEnd As LinearBarCodeSymbologyInstruction = 14

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.ControlCharacterStart Field

LinearBarCodeSymbologyInstructionControlCharacterStart Field
The start of a control character.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction ControlCharacterStart = 12
Public Const ControlCharacterStart As LinearBarCodeSymbologyInstruction = 12

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.EncodedCharacterStart Field

LinearBarCodeSymbologyInstructionEncodedCharacterStart Field
The start of an encoded character.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction EncodedCharacterStart = 13
Public Const EncodedCharacterStart As LinearBarCodeSymbologyInstruction = 13

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.value__ Field

LinearBarCodeSymbologyInstructionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.BarCodes.LinearBarCodeSymbologyInstruction.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.White1 Field

LinearBarCodeSymbologyInstructionWhite1 Field
A narrow white line.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction White1 = 8
Public Const White1 As LinearBarCodeSymbologyInstruction = 8

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.White2 Field

LinearBarCodeSymbologyInstructionWhite2 Field
A wide white line (2x narrow).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction White2 = 9
Public Const White2 As LinearBarCodeSymbologyInstruction = 9

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.White3 Field

LinearBarCodeSymbologyInstructionWhite3 Field
A wide white line (3x narrow).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction White3 = 10
Public Const White3 As LinearBarCodeSymbologyInstruction = 10

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeSymbologyInstruction.White4 Field

LinearBarCodeSymbologyInstructionWhite4 Field
A wide white line (4x narrow).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeSymbologyInstruction White4 = 11
Public Const White4 As LinearBarCodeSymbologyInstruction = 11

Field Value

Type: LinearBarCodeSymbologyInstruction
See Also

Reference

LinearBarCodeSymbologyInstruction Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle Class

LinearBarCodeValueDisplayStyle Class
Specifies the display style for the value of a LinearBarCodeSymbology.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeValueDisplayStyle

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LinearBarCodeValueDisplayStyle : Enum
Public NotInheritable Class LinearBarCodeValueDisplayStyle
    Inherits Enum

The LinearBarCodeValueDisplayStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Centered | The value is centered horizontally.
 | CharactersAlignedWithBars | The characters in the value are centered under the bars that represent each character.
 | LeftAligned | The value is left-aligned.
 | None | The value is not displayed.
 | QuietZoneExtension | The first and last characters are drawn in the lead/tail quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as UPC-A.
 | QuietZoneExtensionLeft | The first character is drawn in the lead quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as EIN-13.
 | RightAligned | The value is right-aligned.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle Methods

LinearBarCodeValueDisplayStyle Methods

The LinearBarCodeValueDisplayStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle Fields

LinearBarCodeValueDisplayStyle Fields

The LinearBarCodeValueDisplayStyle type exposes the following members.

Fields
 | Name | Description
 | Centered | The value is centered horizontally.
 | CharactersAlignedWithBars | The characters in the value are centered under the bars that represent each character.
 | LeftAligned | The value is left-aligned.
 | None | The value is not displayed.
 | QuietZoneExtension | The first and last characters are drawn in the lead/tail quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as UPC-A.
 | QuietZoneExtensionLeft | The first character is drawn in the lead quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as EIN-13.
 | RightAligned | The value is right-aligned.
Public field | value__ |
Top
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.Centered Field

LinearBarCodeValueDisplayStyleCentered Field
The value is centered horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle Centered = 1
Public Const Centered As LinearBarCodeValueDisplayStyle = 1

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.CharactersAlignedWithBars Field

LinearBarCodeValueDisplayStyleCharactersAlignedWithBars Field
The characters in the value are centered under the bars that represent each character.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle CharactersAlignedWithBars = 4
Public Const CharactersAlignedWithBars As LinearBarCodeValueDisplayStyle = 4

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.LeftAligned Field

LinearBarCodeValueDisplayStyleLeftAligned Field
The value is left-aligned.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle LeftAligned = 2
Public Const LeftAligned As LinearBarCodeValueDisplayStyle = 2

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.None Field

LinearBarCodeValueDisplayStyleNone Field
The value is not displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle None = 0
Public Const None As LinearBarCodeValueDisplayStyle = 0

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.QuietZoneExtension Field

LinearBarCodeValueDisplayStyleQuietZoneExtension Field
The first and last characters are drawn in the lead/tail quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as UPC-A.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle QuietZoneExtension = 5
Public Const QuietZoneExtension As LinearBarCodeValueDisplayStyle = 5

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.QuietZoneExtensionLeft Field

LinearBarCodeValueDisplayStyleQuietZoneExtensionLeft Field
The first character is drawn in the lead quiet zones and the remaining characters are centered under the encoded character runs. This is used for symbologies such as EIN-13.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle QuietZoneExtensionLeft = 6
Public Const QuietZoneExtensionLeft As LinearBarCodeValueDisplayStyle = 6

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.RightAligned Field

LinearBarCodeValueDisplayStyleRightAligned Field
The value is right-aligned.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LinearBarCodeValueDisplayStyle RightAligned = 3
Public Const RightAligned As LinearBarCodeValueDisplayStyle = 3

Field Value

Type: LinearBarCodeValueDisplayStyle
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


LinearBarCodeValueDisplayStyle.value__ Field

LinearBarCodeValueDisplayStylevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.BarCodes.LinearBarCodeValueDisplayStyle.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LinearBarCodeValueDisplayStyle Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology Class

QrCodeSymbology Class
Represents a bar code symbology implementation for QrCode.
Data tables that are used in the creation of a symbol.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesGrid2DBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesQrCodeSymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class QrCodeSymbology : Grid2DBarCodeSymbology
Public Class QrCodeSymbology
    Inherits Grid2DBarCodeSymbology

The QrCodeSymbology type exposes the following members.

Constructors
 | Name | Description
Public method | QrCodeSymbology | Initializes a new instance of the QrCodeSymbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AllowLowercase | Gets or sets a value indicating whether lowercase characters are allowed. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EncodingMode | Gets or sets the mode used to encode the specified value. This is a dependency property.
Public property | ErrorCorrectionLevel | Gets or sets the percentage of data loss that can occur on a symbol before it becomes unreadable. As the error correction level increases, the amount of data that can be encoded decreases. This is a dependency property.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaskIndex | Gets or sets the QR mask applied to the code. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | Version | Gets or sets the version of the QR symbol. This value determines the number of modules that compose the symbol, thus contributing to the maximum amount of data that can be encoded. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from Grid2DBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from Grid2DBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AllowLowercaseProperty | Identifies the AllowLowercase dependency property. This field is read-only.
EncodingModeProperty | Identifies the EncodingMode dependency property. This field is read-only.
ErrorCorrectionLevelProperty | Identifies the ErrorCorrectionLevel dependency property. This field is read-only.
MaskIndexProperty | Identifies the MaskIndex dependency property. This field is read-only.
VersionProperty | Identifies the Version dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
QR Code is a two dimensional grid symbology, developed in 1994 by Denso. It was initially intended for use in production control of automotive parts, but it has become widespread in other fields.

This symbology can encode a maximum of 7089 numerical characters, 4296 alphanumeric characters, 2953 binary characters, or 1817 Kanji characters.

For detailed documentation on this symbology's features and how to use them, please see the QrCode documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology Constructor

QrCodeSymbology Constructor
Initializes a new instance of the QrCodeSymbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QrCodeSymbology()
Public Sub New
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology Properties

QrCodeSymbology Properties

The QrCodeSymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AllowLowercase | Gets or sets a value indicating whether lowercase characters are allowed. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CellSize | Gets or sets the number of pixels wide and high that each cell of the symbol grid should be when rendered. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EncodingMode | Gets or sets the mode used to encode the specified value. This is a dependency property.
Public property | ErrorCorrectionLevel | Gets or sets the percentage of data loss that can occur on a symbol before it becomes unreadable. As the error correction level increases, the amount of data that can be encoded decreases. This is a dependency property.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaskIndex | Gets or sets the QR mask applied to the code. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the thickness of the margin on each side of the rendered symbol. This is a dependency property. (Inherited from Grid2DBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | Version | Gets or sets the version of the QR symbol. This value determines the number of modules that compose the symbol, thus contributing to the maximum amount of data that can be encoded. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.AllowLowercase Property

QrCodeSymbologyAllowLowercase Property
Gets or sets a value indicating whether lowercase characters are allowed. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AllowLowercase { get; set; }
Public Property AllowLowercase As Boolean
    Get
    Set

Property Value

Type: Boolean
true if lowercase characters are allowed; otherwise, false will force all lowercase characters to be uppercase. The default value is false.
Remarks
The QR code specification does not allow lowercase characters when using the alphanumeric encoding mode. Therefore, when allowing lowercase characters the binary encoding mode must be used.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.DisplayName Property

QrCodeSymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.EncodingMode Property

QrCodeSymbologyEncodingMode Property
Gets or sets the mode used to encode the specified value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<QrEncodingMode> EncodingMode { get; set; }
Public Property EncodingMode As Nullable(Of QrEncodingMode)
    Get
    Set

Property Value

Type: Nullable QrEncodingMode
The QR encoding mode. The default value is , which indicates the encoding mode will be auto-selected based on the specified value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.ErrorCorrectionLevel Property

QrCodeSymbologyErrorCorrectionLevel Property
Gets or sets the percentage of data loss that can occur on a symbol before it becomes unreadable. As the error correction level increases, the amount of data that can be encoded decreases. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public QrErrorCorrectionLevel ErrorCorrectionLevel { get; set; }
Public Property ErrorCorrectionLevel As QrErrorCorrectionLevel
    Get
    Set

Property Value

Type: QrErrorCorrectionLevel
The error correction level.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.MaskIndex Property

QrCodeSymbologyMaskIndex Property
Gets or sets the QR mask applied to the code. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<int> MaskIndex { get; set; }
Public Property MaskIndex As Nullable(Of Integer)
    Get
    Set

Property Value

Type: Nullable Int32
The QR mask applied to the code. The default value is , which indicates the mask will be auto-selected based on the specified value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.Version Property

QrCodeSymbologyVersion Property
Gets or sets the version of the QR symbol. This value determines the number of modules that compose the symbol, thus contributing to the maximum amount of data that can be encoded. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<QrVersion> Version { get; set; }
Public Property Version As Nullable(Of QrVersion)
    Get
    Set

Property Value

Type: Nullable QrVersion
The version of the QR symbol. The default value is , which indicates the version will be auto-selected based on the specified value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology Methods

QrCodeSymbology Methods

The QrCodeSymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from Grid2DBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from Grid2DBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.OnValueChanged Method

QrCodeSymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.ValidateValue Method

QrCodeSymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology Events

QrCodeSymbology Events

The QrCodeSymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology Fields

QrCodeSymbology Fields

The QrCodeSymbology type exposes the following members.

Fields
Name | Description
AllowLowercaseProperty | Identifies the AllowLowercase dependency property. This field is read-only.
EncodingModeProperty | Identifies the EncodingMode dependency property. This field is read-only.
ErrorCorrectionLevelProperty | Identifies the ErrorCorrectionLevel dependency property. This field is read-only.
MaskIndexProperty | Identifies the MaskIndex dependency property. This field is read-only.
VersionProperty | Identifies the Version dependency property. This field is read-only.
Top
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.AllowLowercaseProperty Field

QrCodeSymbologyAllowLowercaseProperty Field
Identifies the AllowLowercase dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AllowLowercaseProperty
Public Shared ReadOnly AllowLowercaseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AllowLowercase dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.EncodingModeProperty Field

QrCodeSymbologyEncodingModeProperty Field
Identifies the EncodingMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EncodingModeProperty
Public Shared ReadOnly EncodingModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EncodingMode dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.ErrorCorrectionLevelProperty Field

QrCodeSymbologyErrorCorrectionLevelProperty Field
Identifies the ErrorCorrectionLevel dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ErrorCorrectionLevelProperty
Public Shared ReadOnly ErrorCorrectionLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ErrorCorrectionLevel dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.MaskIndexProperty Field

QrCodeSymbologyMaskIndexProperty Field
Identifies the MaskIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskIndexProperty
Public Shared ReadOnly MaskIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaskIndex dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrCodeSymbology.VersionProperty Field

QrCodeSymbologyVersionProperty Field
Identifies the Version dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty VersionProperty
Public Shared ReadOnly VersionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Version dependency property.
See Also

Reference

QrCodeSymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode Class

QrEncodingMode Class
Specifies the various encoding modes supported by QrCodeSymbology.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.BarCodesQrEncodingMode

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class QrEncodingMode : Enum
Public NotInheritable Class QrEncodingMode
    Inherits Enum

The QrEncodingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Alphanumeric | Indicates that the data to be encoded will contain letters, numbers, and a limited set of symbols.
 | Binary | Indicates that the data to be encoded will be 8-bit bytes.
 | Kanji | Indicates that the data to be encoded will contain 8-bit bytes which represent Kanji characters.
 | Numeric | Indicates that the data to be encoded will contain only decimal numbers (0 through 9).
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode Methods

QrEncodingMode Methods

The QrEncodingMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode Fields

QrEncodingMode Fields

The QrEncodingMode type exposes the following members.

Fields
 | Name | Description
 | Alphanumeric | Indicates that the data to be encoded will contain letters, numbers, and a limited set of symbols.
 | Binary | Indicates that the data to be encoded will be 8-bit bytes.
 | Kanji | Indicates that the data to be encoded will contain 8-bit bytes which represent Kanji characters.
 | Numeric | Indicates that the data to be encoded will contain only decimal numbers (0 through 9).
Public field | value__ |
Top
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode.Alphanumeric Field

QrEncodingModeAlphanumeric Field
Indicates that the data to be encoded will contain letters, numbers, and a limited set of symbols.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrEncodingMode Alphanumeric = 1
Public Const Alphanumeric As QrEncodingMode = 1

Field Value

Type: QrEncodingMode
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode.Binary Field

QrEncodingModeBinary Field
Indicates that the data to be encoded will be 8-bit bytes.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrEncodingMode Binary = 2
Public Const Binary As QrEncodingMode = 2

Field Value

Type: QrEncodingMode
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode.Kanji Field

QrEncodingModeKanji Field
Indicates that the data to be encoded will contain 8-bit bytes which represent Kanji characters.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrEncodingMode Kanji = 3
Public Const Kanji As QrEncodingMode = 3

Field Value

Type: QrEncodingMode
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode.Numeric Field

QrEncodingModeNumeric Field
Indicates that the data to be encoded will contain only decimal numbers (0 through 9).

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrEncodingMode Numeric = 0
Public Const Numeric As QrEncodingMode = 0

Field Value

Type: QrEncodingMode
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrEncodingMode.value__ Field

QrEncodingModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.BarCodes.QrEncodingMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

QrEncodingMode Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel Class

QrErrorCorrectionLevel Class
Specifies the various error correction levels supported by QrCodeSymbology.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.BarCodesQrErrorCorrectionLevel

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class QrErrorCorrectionLevel : Enum
Public NotInheritable Class QrErrorCorrectionLevel
    Inherits Enum

The QrErrorCorrectionLevel type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | H | Indicates that the error correction level should be 30%.
 | L | Indicates that the error correction level should be 7%.
 | M | Indicates that the error correction level should be 15%.
 | Q | Indicates that the error correction level should be 25%.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel Methods

QrErrorCorrectionLevel Methods

The QrErrorCorrectionLevel type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel Fields

QrErrorCorrectionLevel Fields

The QrErrorCorrectionLevel type exposes the following members.

Fields
 | Name | Description
 | H | Indicates that the error correction level should be 30%.
 | L | Indicates that the error correction level should be 7%.
 | M | Indicates that the error correction level should be 15%.
 | Q | Indicates that the error correction level should be 25%.
Public field | value__ |
Top
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel.H Field

QrErrorCorrectionLevelH Field
Indicates that the error correction level should be 30%.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrErrorCorrectionLevel H = 3
Public Const H As QrErrorCorrectionLevel = 3

Field Value

Type: QrErrorCorrectionLevel
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel.L Field

QrErrorCorrectionLevelL Field
Indicates that the error correction level should be 7%.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrErrorCorrectionLevel L = 0
Public Const L As QrErrorCorrectionLevel = 0

Field Value

Type: QrErrorCorrectionLevel
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel.M Field

QrErrorCorrectionLevelM Field
Indicates that the error correction level should be 15%.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrErrorCorrectionLevel M = 1
Public Const M As QrErrorCorrectionLevel = 1

Field Value

Type: QrErrorCorrectionLevel
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel.Q Field

QrErrorCorrectionLevelQ Field
Indicates that the error correction level should be 25%.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrErrorCorrectionLevel Q = 2
Public Const Q As QrErrorCorrectionLevel = 2

Field Value

Type: QrErrorCorrectionLevel
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrErrorCorrectionLevel.value__ Field

QrErrorCorrectionLevelvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.BarCodes.QrErrorCorrectionLevel.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

QrErrorCorrectionLevel Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion Class

QrVersion Class
Specifies the various versions supported by QrCodeSymbology. The size of the symbol for Micro QR Code symbols is always 9 + (2 * microVersion). For the 40 versions of regular QR Code symbols, the size is 17 + (4 * version). All versions are square.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.BarCodesQrVersion

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class QrVersion : Enum
Public NotInheritable Class QrVersion
    Inherits Enum

The QrVersion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
Public field | value__ |
 | Version1 | Indicates that the version should be 1. The symbol size is 21.
 | Version10 | Indicates that the version should be 10. The symbol size is 57.
 | Version11 | Indicates that the version should be 11. The symbol size is 61.
 | Version12 | Indicates that the version should be 12. The symbol size is 65.
 | Version13 | Indicates that the version should be 13. The symbol size is 69.
 | Version14 | Indicates that the version should be 14. The symbol size is 73.
 | Version15 | Indicates that the version should be 15. The symbol size is 77.
 | Version16 | Indicates that the version should be 16. The symbol size is 81.
 | Version17 | Indicates that the version should be 17. The symbol size is 85.
 | Version18 | Indicates that the version should be 18. The symbol size is 89.
 | Version19 | Indicates that the version should be 19. The symbol size is 93.
 | Version2 | Indicates that the version should be 2. The symbol size is 25.
 | Version20 | Indicates that the version should be 20. The symbol size is 97.
 | Version21 | Indicates that the version should be 21. The symbol size is 101.
 | Version22 | Indicates that the version should be 22. The symbol size is 105.
 | Version23 | Indicates that the version should be 23. The symbol size is 109.
 | Version24 | Indicates that the version should be 24. The symbol size is 113.
 | Version25 | Indicates that the version should be 25. The symbol size is 117.
 | Version26 | Indicates that the version should be 26. The symbol size is 121.
 | Version27 | Indicates that the version should be 27. The symbol size is 125.
 | Version28 | Indicates that the version should be 28. The symbol size is 129.
 | Version29 | Indicates that the version should be 29. The symbol size is 133.
 | Version3 | Indicates that the version should be 3. The symbol size is 29.
 | Version30 | Indicates that the version should be 30. The symbol size is 137.
 | Version31 | Indicates that the version should be 31. The symbol size is 141.
 | Version32 | Indicates that the version should be 32. The symbol size is 145.
 | Version33 | Indicates that the version should be 33. The symbol size is 149.
 | Version34 | Indicates that the version should be 34. The symbol size is 153.
 | Version35 | Indicates that the version should be 35. The symbol size is 157.
 | Version36 | Indicates that the version should be 36. The symbol size is 161.
 | Version37 | Indicates that the version should be 37. The symbol size is 165.
 | Version38 | Indicates that the version should be 38. The symbol size is 169.
 | Version39 | Indicates that the version should be 39. The symbol size is 173.
 | Version4 | Indicates that the version should be 4. The symbol size is 33.
 | Version40 | Indicates that the version should be 40. The symbol size is 177.
 | Version5 | Indicates that the version should be 5. The symbol size is 37.
 | Version6 | Indicates that the version should be 6. The symbol size is 41.
 | Version7 | Indicates that the version should be 7. The symbol size is 45.
 | Version8 | Indicates that the version should be 8. The symbol size is 49.
 | Version9 | Indicates that the version should be 9. The symbol size is 53.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion Methods

QrVersion Methods

The QrVersion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion Fields

QrVersion Fields

The QrVersion type exposes the following members.

Fields
 | Name | Description
Public field | value__ |
 | Version1 | Indicates that the version should be 1. The symbol size is 21.
 | Version10 | Indicates that the version should be 10. The symbol size is 57.
 | Version11 | Indicates that the version should be 11. The symbol size is 61.
 | Version12 | Indicates that the version should be 12. The symbol size is 65.
 | Version13 | Indicates that the version should be 13. The symbol size is 69.
 | Version14 | Indicates that the version should be 14. The symbol size is 73.
 | Version15 | Indicates that the version should be 15. The symbol size is 77.
 | Version16 | Indicates that the version should be 16. The symbol size is 81.
 | Version17 | Indicates that the version should be 17. The symbol size is 85.
 | Version18 | Indicates that the version should be 18. The symbol size is 89.
 | Version19 | Indicates that the version should be 19. The symbol size is 93.
 | Version2 | Indicates that the version should be 2. The symbol size is 25.
 | Version20 | Indicates that the version should be 20. The symbol size is 97.
 | Version21 | Indicates that the version should be 21. The symbol size is 101.
 | Version22 | Indicates that the version should be 22. The symbol size is 105.
 | Version23 | Indicates that the version should be 23. The symbol size is 109.
 | Version24 | Indicates that the version should be 24. The symbol size is 113.
 | Version25 | Indicates that the version should be 25. The symbol size is 117.
 | Version26 | Indicates that the version should be 26. The symbol size is 121.
 | Version27 | Indicates that the version should be 27. The symbol size is 125.
 | Version28 | Indicates that the version should be 28. The symbol size is 129.
 | Version29 | Indicates that the version should be 29. The symbol size is 133.
 | Version3 | Indicates that the version should be 3. The symbol size is 29.
 | Version30 | Indicates that the version should be 30. The symbol size is 137.
 | Version31 | Indicates that the version should be 31. The symbol size is 141.
 | Version32 | Indicates that the version should be 32. The symbol size is 145.
 | Version33 | Indicates that the version should be 33. The symbol size is 149.
 | Version34 | Indicates that the version should be 34. The symbol size is 153.
 | Version35 | Indicates that the version should be 35. The symbol size is 157.
 | Version36 | Indicates that the version should be 36. The symbol size is 161.
 | Version37 | Indicates that the version should be 37. The symbol size is 165.
 | Version38 | Indicates that the version should be 38. The symbol size is 169.
 | Version39 | Indicates that the version should be 39. The symbol size is 173.
 | Version4 | Indicates that the version should be 4. The symbol size is 33.
 | Version40 | Indicates that the version should be 40. The symbol size is 177.
 | Version5 | Indicates that the version should be 5. The symbol size is 37.
 | Version6 | Indicates that the version should be 6. The symbol size is 41.
 | Version7 | Indicates that the version should be 7. The symbol size is 45.
 | Version8 | Indicates that the version should be 8. The symbol size is 49.
 | Version9 | Indicates that the version should be 9. The symbol size is 53.
Top
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.value__ Field

QrVersionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.BarCodes.QrVersion.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version1 Field

QrVersionVersion1 Field
Indicates that the version should be 1. The symbol size is 21.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version1 = 0
Public Const Version1 As QrVersion = 0

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version10 Field

QrVersionVersion10 Field
Indicates that the version should be 10. The symbol size is 57.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version10 = 9
Public Const Version10 As QrVersion = 9

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version11 Field

QrVersionVersion11 Field
Indicates that the version should be 11. The symbol size is 61.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version11 = 10
Public Const Version11 As QrVersion = 10

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version12 Field

QrVersionVersion12 Field
Indicates that the version should be 12. The symbol size is 65.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version12 = 11
Public Const Version12 As QrVersion = 11

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version13 Field

QrVersionVersion13 Field
Indicates that the version should be 13. The symbol size is 69.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version13 = 12
Public Const Version13 As QrVersion = 12

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version14 Field

QrVersionVersion14 Field
Indicates that the version should be 14. The symbol size is 73.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version14 = 13
Public Const Version14 As QrVersion = 13

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version15 Field

QrVersionVersion15 Field
Indicates that the version should be 15. The symbol size is 77.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version15 = 14
Public Const Version15 As QrVersion = 14

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version16 Field

QrVersionVersion16 Field
Indicates that the version should be 16. The symbol size is 81.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version16 = 15
Public Const Version16 As QrVersion = 15

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version17 Field

QrVersionVersion17 Field
Indicates that the version should be 17. The symbol size is 85.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version17 = 16
Public Const Version17 As QrVersion = 16

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version18 Field

QrVersionVersion18 Field
Indicates that the version should be 18. The symbol size is 89.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version18 = 17
Public Const Version18 As QrVersion = 17

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version19 Field

QrVersionVersion19 Field
Indicates that the version should be 19. The symbol size is 93.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version19 = 18
Public Const Version19 As QrVersion = 18

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version2 Field

QrVersionVersion2 Field
Indicates that the version should be 2. The symbol size is 25.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version2 = 1
Public Const Version2 As QrVersion = 1

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version20 Field

QrVersionVersion20 Field
Indicates that the version should be 20. The symbol size is 97.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version20 = 19
Public Const Version20 As QrVersion = 19

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version21 Field

QrVersionVersion21 Field
Indicates that the version should be 21. The symbol size is 101.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version21 = 20
Public Const Version21 As QrVersion = 20

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version22 Field

QrVersionVersion22 Field
Indicates that the version should be 22. The symbol size is 105.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version22 = 21
Public Const Version22 As QrVersion = 21

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version23 Field

QrVersionVersion23 Field
Indicates that the version should be 23. The symbol size is 109.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version23 = 22
Public Const Version23 As QrVersion = 22

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version24 Field

QrVersionVersion24 Field
Indicates that the version should be 24. The symbol size is 113.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version24 = 23
Public Const Version24 As QrVersion = 23

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version25 Field

QrVersionVersion25 Field
Indicates that the version should be 25. The symbol size is 117.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version25 = 24
Public Const Version25 As QrVersion = 24

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version26 Field

QrVersionVersion26 Field
Indicates that the version should be 26. The symbol size is 121.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version26 = 25
Public Const Version26 As QrVersion = 25

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version27 Field

QrVersionVersion27 Field
Indicates that the version should be 27. The symbol size is 125.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version27 = 26
Public Const Version27 As QrVersion = 26

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version28 Field

QrVersionVersion28 Field
Indicates that the version should be 28. The symbol size is 129.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version28 = 27
Public Const Version28 As QrVersion = 27

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version29 Field

QrVersionVersion29 Field
Indicates that the version should be 29. The symbol size is 133.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version29 = 28
Public Const Version29 As QrVersion = 28

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version3 Field

QrVersionVersion3 Field
Indicates that the version should be 3. The symbol size is 29.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version3 = 2
Public Const Version3 As QrVersion = 2

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version30 Field

QrVersionVersion30 Field
Indicates that the version should be 30. The symbol size is 137.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version30 = 29
Public Const Version30 As QrVersion = 29

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version31 Field

QrVersionVersion31 Field
Indicates that the version should be 31. The symbol size is 141.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version31 = 30
Public Const Version31 As QrVersion = 30

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version32 Field

QrVersionVersion32 Field
Indicates that the version should be 32. The symbol size is 145.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version32 = 31
Public Const Version32 As QrVersion = 31

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version33 Field

QrVersionVersion33 Field
Indicates that the version should be 33. The symbol size is 149.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version33 = 32
Public Const Version33 As QrVersion = 32

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version34 Field

QrVersionVersion34 Field
Indicates that the version should be 34. The symbol size is 153.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version34 = 33
Public Const Version34 As QrVersion = 33

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version35 Field

QrVersionVersion35 Field
Indicates that the version should be 35. The symbol size is 157.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version35 = 34
Public Const Version35 As QrVersion = 34

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version36 Field

QrVersionVersion36 Field
Indicates that the version should be 36. The symbol size is 161.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version36 = 35
Public Const Version36 As QrVersion = 35

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version37 Field

QrVersionVersion37 Field
Indicates that the version should be 37. The symbol size is 165.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version37 = 36
Public Const Version37 As QrVersion = 36

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version38 Field

QrVersionVersion38 Field
Indicates that the version should be 38. The symbol size is 169.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version38 = 37
Public Const Version38 As QrVersion = 37

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version39 Field

QrVersionVersion39 Field
Indicates that the version should be 39. The symbol size is 173.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version39 = 38
Public Const Version39 As QrVersion = 38

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version4 Field

QrVersionVersion4 Field
Indicates that the version should be 4. The symbol size is 33.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version4 = 3
Public Const Version4 As QrVersion = 3

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version40 Field

QrVersionVersion40 Field
Indicates that the version should be 40. The symbol size is 177.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version40 = 39
Public Const Version40 As QrVersion = 39

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version5 Field

QrVersionVersion5 Field
Indicates that the version should be 5. The symbol size is 37.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version5 = 4
Public Const Version5 As QrVersion = 4

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version6 Field

QrVersionVersion6 Field
Indicates that the version should be 6. The symbol size is 41.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version6 = 5
Public Const Version6 As QrVersion = 5

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version7 Field

QrVersionVersion7 Field
Indicates that the version should be 7. The symbol size is 45.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version7 = 6
Public Const Version7 As QrVersion = 6

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version8 Field

QrVersionVersion8 Field
Indicates that the version should be 8. The symbol size is 49.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version8 = 7
Public Const Version8 As QrVersion = 7

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


QrVersion.Version9 Field

QrVersionVersion9 Field
Indicates that the version should be 9. The symbol size is 53.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const QrVersion Version9 = 8
Public Const Version9 As QrVersion = 8

Field Value

Type: QrVersion
See Also

Reference

QrVersion Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology Class

UpcASymbology Class
Represents a bar code symbology implementation for UPC-A.

This symbology is also known as Universal Product Code version A.

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesUpcASymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UpcASymbology : LinearBarCodeSymbology
Public Class UpcASymbology
    Inherits LinearBarCodeSymbology

The UpcASymbology type exposes the following members.

Constructors
 | Name | Description
Public method | UpcASymbology | Initializes an instance of the UpcASymbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
UPC-A is a linear symbology, widely used in the United States and Canada for tracking trade items in stores.

This symbology can encode 12 numeric characters, divided into four parts: system code, manufacturer code, product code, and check digit.

This symbology implementation auto-calculates and inserts a check digit.

For detailed documentation on this symbology's features and how to use them, please see the UPC-A documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology Constructor

UpcASymbology Constructor
Initializes an instance of the UpcASymbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UpcASymbology()
Public Sub New
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology Properties

UpcASymbology Properties

The UpcASymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology.DisplayName Property

UpcASymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology Methods

UpcASymbology Methods

The UpcASymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology.OnValueChanged Method

UpcASymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology.ValidateValue Method

UpcASymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcASymbology Events

UpcASymbology Events

The UpcASymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

UpcASymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology Class

UpcESymbology Class
Represents a bar code symbology implementation for UPC-E.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.BarCodesBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesLinearBarCodeSymbology
ActiproSoftware.UI.Xaml.Controls.BarCodesUpcESymbology

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class UpcESymbology : LinearBarCodeSymbology
Public Class UpcESymbology
    Inherits LinearBarCodeSymbology

The UpcESymbology type exposes the following members.

Constructors
 | Name | Description
Public method | UpcESymbology | Initializes an instance of the UpcESymbology class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
Remarks
UPC-E is a linear symbology, used on smaller retail packages where UPC-A bar codes don't fit.

This symbology can encode 8 numeric characters, divided into three parts: system code, product code, and check digit.

This symbology uses a check digit, but it is not currently calculated automatically.

For detailed documentation on this symbology's features and how to use them, please see the UPC-E documentation topic.

See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology Constructor

UpcESymbology Constructor
Initializes an instance of the UpcESymbology class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UpcESymbology()
Public Sub New
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology Properties

UpcESymbology Properties

The UpcESymbology type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHeight | Gets or sets the desired height of the bars. (Inherited from LinearBarCodeSymbology.)
Public property | BarWidthRatio | Gets or sets the width ratio of wide lines to narrow lines. (Inherited from LinearBarCodeSymbology.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets the display name of the symbology. (Overrides BarCodeSymbologyDisplayName.)
Public property | DisplayValue | Gets or sets the value that is displayed if ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinBarHeightWidthRatio | Gets or sets the minimum ratio that the height of the bar code must be in relation to its width. (Inherited from LinearBarCodeSymbology.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QuietZoneThickness | Gets or sets the Thickness of the quiet zone. (Inherited from LinearBarCodeSymbology.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value to encode in the bar code. (Inherited from BarCodeSymbology.)
Public property | ValueDisplayStyle | Gets or sets a LinearBarCodeValueDisplayStyle that indicates how the value should rendered. (Inherited from LinearBarCodeSymbology.)
Public property | ValueIntrusionOffset | Gets or sets the distance that the Value text intrudes into the bar code when ValueDisplayStyle is not None. (Inherited from LinearBarCodeSymbology.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomLevel | Gets or sets the zoom level of the rendered bar code. (Inherited from BarCodeSymbology.)
Top
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology.DisplayName Property

UpcESymbologyDisplayName Property
Gets the display name of the symbology.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The display name of the symbology.
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology Methods

UpcESymbology Methods

The UpcESymbology type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureDesiredSize | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from LinearBarCodeSymbology.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children. (Inherited from BarCodeSymbology.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from BarCodeSymbology.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the value of the Value property is changed. (Overrides BarCodeSymbologyOnValueChanged(String, String).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the bar code rendering. (Inherited from BarCodeSymbology.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | Render | Renders the [!:Value] to the specified Canvas. (Inherited from LinearBarCodeSymbology.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Public method | ValidateValue | Validates that the symbology can parse the specified value. (Overrides BarCodeSymbologyValidateValue(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology.OnValueChanged Method

UpcESymbologyOnValueChanged Method
Occurs when the value of the Value property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    string oldValue,
    string newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As String,
    newValue As String
)

Parameters

oldValue
Type: SystemString
The old value.
newValue
Type: SystemString
The new value.
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology.ValidateValue Method

UpcESymbologyValidateValue Method
Validates that the symbology can parse the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override ValidationResult ValidateValue(
    string value
)
Public Overrides Function ValidateValue (
    value As String
) As ValidationResult

Parameters

value
Type: SystemString
The value to validate.

Return Value

Type: ValidationResult
A ValidationResult containing the result of the validation.
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


UpcESymbology Events

UpcESymbology Events

The UpcESymbology type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

UpcESymbology Class
ActiproSoftware.UI.Xaml.Controls.BarCodes Namespace


ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace
Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | BarCodeAutomationPeer | Exposes the BarCode control to UI Automation.


BarCodeAutomationPeer Class

BarCodeAutomationPeer Class
Exposes the BarCode control to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.PeersBarCodeAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BarCodeAutomationPeer : FrameworkElementAutomationPeer
Public Class BarCodeAutomationPeer
    Inherits FrameworkElementAutomationPeer

The BarCodeAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | BarCodeAutomationPeer | Initializes an instance of the BarCodeAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the AutomationControlType for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text string describing the element that is associated with this automation peer. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


BarCodeAutomationPeer Constructor

BarCodeAutomationPeer Constructor
Initializes an instance of the BarCodeAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BarCodeAutomationPeer(
    FrameworkElement owner
)
Public Sub New (
    owner As FrameworkElement
)

Parameters

owner
Type: Windows.UI.XamlFrameworkElement
The owner of the automation peer.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


BarCodeAutomationPeer Properties

BarCodeAutomationPeer Properties

The BarCodeAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


BarCodeAutomationPeer Methods

BarCodeAutomationPeer Methods

The BarCodeAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the AutomationControlType for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the text string describing the element that is associated with this automation peer. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


BarCodeAutomationPeer.GetAutomationControlTypeCore Method

BarCodeAutomationPeerGetAutomationControlTypeCore Method
Gets the AutomationControlType for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
A AutomationControlType indicating the control type.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


BarCodeAutomationPeer.GetClassNameCore Method

BarCodeAutomationPeerGetClassNameCore Method
Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


BarCodeAutomationPeer.GetNameCore Method

BarCodeAutomationPeerGetNameCore Method
Gets the text string describing the element that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers
Assembly: AS.BarCodes.Universal (in AS.BarCodes.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

BarCodeAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.BarCodes.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.Charts Namespace

ActiproSoftware.UI.Xaml.Controls.Charts Namespace
Contains classes that support implementing chart controls.
Classes
 | Class | Description
Public class | AggregationKind | Specifies the various kinds of built-in aggregation functions.
Public class | AreaSeries | Represents an area series for use in a XYChart.
Public class | AxisPosition | Specifies the position of the axis in relation to the chart.
Public class | BarSeries | Represents a bar series for use in a XYChart.
Public class | ChartMarker | Represents a control capable of rendering predefined shapes.
Public class | ChartMarkerShapeKind | Specifies the various predefined shapes supported by ChartMarker.
Public class | ChartMarkerVisibility | Specifies the visibility of the various kinds of ChartMarker.
Public class | DataPointLabel | A label on a data point.
Public class | DeferrableObservableItemCollectionT | Represents a collection of objects that can be observed for items being removed and added by any means, including Clear and Replace.
Public class | DonutChart | Represents a donut chart control, which is a pie chart with the center cut out.
Public class | GridLineVisibility | Specifies which axes that grid lines will be visible for.
Public class | GridStripeVisibility | Specifies which axes that grid stripes will be visible for.
Public class | InvalidAxisException | An exception thrown when an axis is bound to an incorrect data type.
Public class | LabelCollisionMode | Specifies how data point labels resolve collisions.
Public class | LabelPositioningMode | Specifies how data point labels are positioned.
Public class | LabelVisibility | Specifies the visibility of data point labels on the chart.
Public class | LegendHorizontalPosition | Specifies the horizontal position of the legend in relation to its parent chart.
Public class | LegendKey | Describes a key shown in a legend.
Public class | LegendVerticalPosition | Specifies the vertical position of the legend in relation to its parent chart.
Public class | LineSeries | Represents a line series for use in a XYChart.
Public class | LineSeriesVisibility | Specifies the visibility of the various kinds of a line.
Public class | NonNumericValueException | An exception for when a non-numeric value is provided.
Public class | PieChart | A control that displays a pie chart based on given data.
Public class | PieSeries | Represents a pie series for use in a PieChart or DonutChart.
Public class | PieSeriesChildPosition | The position of the child pie series.
Public class | PieSliceLabelInsideFitMode | Determines what happens if a label does not fit inside the pie slice.
Public class | PieSliceLabelPosition | Determines where the pie slice labels are positioned.
Public class | PieSliceStyleSelector | A base class that selects a style for a given PieSlice.
Public class | ScatterSeries | Represents a scatter series for use in a XYChart.
Public class | SeriesStyleSelector | Provides a way to apply series styles based on custom logic.
Public class | TimeSpanConverter | Converts TimeSpan to and from a String.
Public class | TimeUnit | Specifies a unit of time.
Public class | XYAxisCollection | Represents a collection of XYAxisBase objects.
Public class | XYChart | Represents a chart control that uses an X/Y coordinate system.
Public class | XYDataPoint | Represents a data point presented by a a XYSeriesBase series.
Public class | XYDateTimeAxis | Represents an axis for data in DateTime format.
Public class | XYDecimalAxis | Represents an axis for data in Decimal format.
Public class | XYDecimalAxisBaseT | Represents an axis for data in Decimal format.
Public class | XYDoubleAxis | Represents an axis for data in Double format.
Public class | XYGroupedAxis | XYGroupedAxis is an axis type used for displaying non-value data, such as strings and complex types. It can group, label, and sort data based on custom criteria.
Public class | XYPercentageAxis | Represents an axis for data displayed as stacked in percentage mode.
Public class | XYRange | Represents a range for use in a XYChart.
Public class | XYRangeCollection | Represents a collection of XYRange objects.
Public class | XYSeriesCollection | Represents a collection of XYRange objects.
Public class | XYSeriesLineKind | Specifies the line kinds supported by a LineSeries and AreaSeries series.
Public class | XYSeriesStackKind | Specifies the stacking methods supported by a XYSeriesBase series.
Interfaces
 | Interface | Description
Public interface | ILabelPositioner | Positions data point labels.
Public interface | IPieSliceStyleSelector | Provides the base requirements for a class that determines how a pie slice will be styled.
Public interface | ISeriesStyleSelector | Provides the base requirements for a class that determines how a series will be styled.


AggregationKind Class

AggregationKind Class
Specifies the various kinds of built-in aggregation functions.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsAggregationKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class AggregationKind : Enum
Public NotInheritable Class AggregationKind
    Inherits Enum

The AggregationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Average | Indicates that the values will be averaged together.
 | First | Indicates that the first value will be used.
 | Last | Indicates that the last value will be used.
 | Maximum | Indicates that the maximum value will be used.
 | Minimum | Indicates that the minimum value will be used.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind Methods

AggregationKind Methods

The AggregationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind Fields

AggregationKind Fields

The AggregationKind type exposes the following members.

Fields
 | Name | Description
 | Average | Indicates that the values will be averaged together.
 | First | Indicates that the first value will be used.
 | Last | Indicates that the last value will be used.
 | Maximum | Indicates that the maximum value will be used.
 | Minimum | Indicates that the minimum value will be used.
Public field | value__ |
Top
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind.Average Field

AggregationKindAverage Field
Indicates that the values will be averaged together.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AggregationKind Average = 0
Public Const Average As AggregationKind = 0

Field Value

Type: AggregationKind
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind.First Field

AggregationKindFirst Field
Indicates that the first value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AggregationKind First = 3
Public Const First As AggregationKind = 3

Field Value

Type: AggregationKind
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind.Last Field

AggregationKindLast Field
Indicates that the last value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AggregationKind Last = 4
Public Const Last As AggregationKind = 4

Field Value

Type: AggregationKind
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind.Maximum Field

AggregationKindMaximum Field
Indicates that the maximum value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AggregationKind Maximum = 1
Public Const Maximum As AggregationKind = 1

Field Value

Type: AggregationKind
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind.Minimum Field

AggregationKindMinimum Field
Indicates that the minimum value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AggregationKind Minimum = 2
Public Const Minimum As AggregationKind = 2

Field Value

Type: AggregationKind
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AggregationKind.value__ Field

AggregationKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.AggregationKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

AggregationKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries Class

AreaSeries Class
Represents an area series for use in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsAreaSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AreaSeries : LineSeriesBase
Public Class AreaSeries
    Inherits LineSeriesBase

The AreaSeries type exposes the following members.

Constructors
 | Name | Description
Public method | AreaSeries | Initializes a new instance of the AreaSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Overrides LineSeriesBaseLabelPositioningMode.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries Constructor

AreaSeries Constructor
Initializes a new instance of the AreaSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AreaSeries()
Public Sub New
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries Properties

AreaSeries Properties

The AreaSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Overrides LineSeriesBaseLabelPositioningMode.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries.AreaStyle Property

AreaSeriesAreaStyle Property
Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style AreaStyle { get; set; }
Public Property AreaStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries.LabelPositioningMode Property

AreaSeriesLabelPositioningMode Property
Gets or sets the LabelPositioningMode used to determine how labels are laid out.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override LabelPositioningMode LabelPositioningMode { get; set; }
Public Overrides Property LabelPositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The label positioning mode. The default value is FromBaseline.
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries.LineVisibility Property

AreaSeriesLineVisibility Property
Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LineSeriesVisibility LineVisibility { get; set; }
Public Property LineVisibility As LineSeriesVisibility
    Get
    Set

Property Value

Type: LineSeriesVisibility
A LineSeriesVisibility indicating which lines are rendered along the series. The default value is LineSeriesVisibility.None.
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries Methods

AreaSeries Methods

The AreaSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries Events

AreaSeries Events

The AreaSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries Fields

AreaSeries Fields

The AreaSeries type exposes the following members.

Fields
Name | Description
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries.AreaStyleProperty Field

AreaSeriesAreaStyleProperty Field
Identifies the AreaStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaStyleProperty
Public Shared ReadOnly AreaStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaStyle dependency property.
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries.LabelPositioningModeProperty Field

AreaSeriesLabelPositioningModeProperty Field
Identifies the LabelPositioningMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositioningModeProperty
Public Shared ReadOnly LabelPositioningModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPositioningMode dependency property.
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AreaSeries.LineVisibilityProperty Field

AreaSeriesLineVisibilityProperty Field
Identifies the LineVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineVisibilityProperty
Public Shared ReadOnly LineVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineVisibility dependency property.
See Also

Reference

AreaSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AxisPosition Class

AxisPosition Class
Specifies the position of the axis in relation to the chart.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsAxisPosition

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class AxisPosition : Enum
Public NotInheritable Class AxisPosition
    Inherits Enum

The AxisPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | FarEdge | Indicates that the axis will be placed on the far (top / right) edge of the chart.
 | NearEdge | Indicates that the axis will be placed on the near (bottom / left) edge of the chart.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AxisPosition Methods

AxisPosition Methods

The AxisPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

AxisPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AxisPosition Fields

AxisPosition Fields

The AxisPosition type exposes the following members.

Fields
 | Name | Description
 | FarEdge | Indicates that the axis will be placed on the far (top / right) edge of the chart.
 | NearEdge | Indicates that the axis will be placed on the near (bottom / left) edge of the chart.
Public field | value__ |
Top
See Also

Reference

AxisPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AxisPosition.FarEdge Field

AxisPositionFarEdge Field
Indicates that the axis will be placed on the far (top / right) edge of the chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AxisPosition FarEdge = 1
Public Const FarEdge As AxisPosition = 1

Field Value

Type: AxisPosition
See Also

Reference

AxisPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AxisPosition.NearEdge Field

AxisPositionNearEdge Field
Indicates that the axis will be placed on the near (bottom / left) edge of the chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const AxisPosition NearEdge = 0
Public Const NearEdge As AxisPosition = 0

Field Value

Type: AxisPosition
See Also

Reference

AxisPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


AxisPosition.value__ Field

AxisPositionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.AxisPosition.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

AxisPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


BarSeries Class

BarSeries Class
Represents a bar series for use in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsBarSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BarSeries : BarSeriesBase
Public Class BarSeries
    Inherits BarSeriesBase

The BarSeries type exposes the following members.

Constructors
 | Name | Description
Public method | BarSeries | Initializes a new instance of the BarSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from BarSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from BarSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from BarSeriesBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from BarSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


BarSeries Constructor

BarSeries Constructor
Initializes a new instance of the BarSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BarSeries()
Public Sub New
See Also

Reference

BarSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


BarSeries Properties

BarSeries Properties

The BarSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from BarSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from BarSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from BarSeriesBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from BarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from BarSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

BarSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


BarSeries Methods

BarSeries Methods

The BarSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

BarSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


BarSeries Events

BarSeries Events

The BarSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

BarSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker Class

ChartMarker Class
Represents a control capable of rendering predefined shapes.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsChartMarker

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ChartMarker : Control
Public Class ChartMarker
    Inherits Control

The ChartMarker type exposes the following members.

Constructors
 | Name | Description
Public method | ChartMarker | Initializes a new instance of the ChartMarker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Protected property | Path | Gets the Path associated with the marker.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ShapeKind | Gets or sets a ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker Constructor

ChartMarker Constructor
Initializes a new instance of the ChartMarker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ChartMarker()
Public Sub New
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker Properties

ChartMarker Properties

The ChartMarker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Protected property | Path | Gets the Path associated with the marker.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ShapeKind | Gets or sets a ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker.Path Property

ChartMarkerPath Property
Gets the Path associated with the marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Path Path { get; }
Protected ReadOnly Property Path As Path
    Get

Property Value

Type: Path
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker.ShapeKind Property

ChartMarkerShapeKind Property
Gets or sets a ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ChartMarkerShapeKind ShapeKind { get; set; }
Public Property ShapeKind As ChartMarkerShapeKind
    Get
    Set

Property Value

Type: ChartMarkerShapeKind
A ChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. The default value is ChartMarkerShapeKind.Ellipse.
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker Methods

ChartMarker Methods

The ChartMarker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker.OnApplyTemplate Method

ChartMarkerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker.UpdatePath Method

ChartMarkerUpdatePath Method
Updates the Geometry of the Path element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdatePath()
Protected Overridable Sub UpdatePath
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker Events

ChartMarker Events

The ChartMarker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker Fields

ChartMarker Fields

The ChartMarker type exposes the following members.

Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarker.ShapeKindProperty Field

ChartMarkerShapeKindProperty Field
Identifies the ShapeKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShapeKindProperty
Public Shared ReadOnly ShapeKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ShapeKind dependency property.
See Also

Reference

ChartMarker Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind Class

ChartMarkerShapeKind Class
Specifies the various predefined shapes supported by ChartMarker.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsChartMarkerShapeKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ChartMarkerShapeKind : Enum
Public NotInheritable Class ChartMarkerShapeKind
    Inherits Enum

The ChartMarkerShapeKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Diamond | Indicates a diamond shape will be rendered.
 | Ellipse | Indicates an ellipse shape will be rendered.
 | Hexagon | Indicates a hexagon shape will be rendered.
 | Octagon | Indicates an octagon shape will be rendered.
 | Pentagon | Indicates a pentagon shape will be rendered.
 | Rectangle | Indicates a rectangle shape will be rendered.
 | Star4Points | Indicates an 4-pointed star shape will be rendered.
 | Star5Points | Indicates an 5-pointed star shape will be rendered.
 | Star6Points | Indicates an 6-pointed star shape will be rendered.
 | Star8Points | Indicates an 8-pointed star shape will be rendered.
 | Triangle | Indicates a triangle shape will be rendered.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind Methods

ChartMarkerShapeKind Methods

The ChartMarkerShapeKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind Fields

ChartMarkerShapeKind Fields

The ChartMarkerShapeKind type exposes the following members.

Fields
 | Name | Description
 | Diamond | Indicates a diamond shape will be rendered.
 | Ellipse | Indicates an ellipse shape will be rendered.
 | Hexagon | Indicates a hexagon shape will be rendered.
 | Octagon | Indicates an octagon shape will be rendered.
 | Pentagon | Indicates a pentagon shape will be rendered.
 | Rectangle | Indicates a rectangle shape will be rendered.
 | Star4Points | Indicates an 4-pointed star shape will be rendered.
 | Star5Points | Indicates an 5-pointed star shape will be rendered.
 | Star6Points | Indicates an 6-pointed star shape will be rendered.
 | Star8Points | Indicates an 8-pointed star shape will be rendered.
 | Triangle | Indicates a triangle shape will be rendered.
Public field | value__ |
Top
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Diamond Field

ChartMarkerShapeKindDiamond Field
Indicates a diamond shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Diamond = 0
Public Const Diamond As ChartMarkerShapeKind = 0

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Ellipse Field

ChartMarkerShapeKindEllipse Field
Indicates an ellipse shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Ellipse = 1
Public Const Ellipse As ChartMarkerShapeKind = 1

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Hexagon Field

ChartMarkerShapeKindHexagon Field
Indicates a hexagon shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Hexagon = 2
Public Const Hexagon As ChartMarkerShapeKind = 2

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Octagon Field

ChartMarkerShapeKindOctagon Field
Indicates an octagon shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Octagon = 4
Public Const Octagon As ChartMarkerShapeKind = 4

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Pentagon Field

ChartMarkerShapeKindPentagon Field
Indicates a pentagon shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Pentagon = 3
Public Const Pentagon As ChartMarkerShapeKind = 3

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Rectangle Field

ChartMarkerShapeKindRectangle Field
Indicates a rectangle shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Rectangle = 5
Public Const Rectangle As ChartMarkerShapeKind = 5

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Star4Points Field

ChartMarkerShapeKindStar4Points Field
Indicates an 4-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Star4Points = 6
Public Const Star4Points As ChartMarkerShapeKind = 6

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Star5Points Field

ChartMarkerShapeKindStar5Points Field
Indicates an 5-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Star5Points = 7
Public Const Star5Points As ChartMarkerShapeKind = 7

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Star6Points Field

ChartMarkerShapeKindStar6Points Field
Indicates an 6-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Star6Points = 8
Public Const Star6Points As ChartMarkerShapeKind = 8

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Star8Points Field

ChartMarkerShapeKindStar8Points Field
Indicates an 8-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Star8Points = 9
Public Const Star8Points As ChartMarkerShapeKind = 9

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.Triangle Field

ChartMarkerShapeKindTriangle Field
Indicates a triangle shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerShapeKind Triangle = 10
Public Const Triangle As ChartMarkerShapeKind = 10

Field Value

Type: ChartMarkerShapeKind
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerShapeKind.value__ Field

ChartMarkerShapeKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.ChartMarkerShapeKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility Class

ChartMarkerVisibility Class
Specifies the visibility of the various kinds of ChartMarker.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsChartMarkerVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class ChartMarkerVisibility : Enum
<FlagsAttribute>
Public NotInheritable Class ChartMarkerVisibility
    Inherits Enum

The ChartMarkerVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | First | Indicates that the first marker will be visible.
 | High | Indicates that high markers will be visible.
 | Last | Indicates that the last marker will be visible.
 | Low | Indicates that low markers will be visible.
 | Negative | Indicates that negative markers will be visible.
 | None | Indicates that no markers will be visible.
 | Positive | Indicates that positive markers will be visible.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility Methods

ChartMarkerVisibility Methods

The ChartMarkerVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility Fields

ChartMarkerVisibility Fields

The ChartMarkerVisibility type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | First | Indicates that the first marker will be visible.
 | High | Indicates that high markers will be visible.
 | Last | Indicates that the last marker will be visible.
 | Low | Indicates that low markers will be visible.
 | Negative | Indicates that negative markers will be visible.
 | None | Indicates that no markers will be visible.
 | Positive | Indicates that positive markers will be visible.
Public field | value__ |
Top
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.All Field

ChartMarkerVisibilityAll Field
Indicates that all markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility All = 63
Public Const All As ChartMarkerVisibility = 63

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.First Field

ChartMarkerVisibilityFirst Field
Indicates that the first marker will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility First = 16
Public Const First As ChartMarkerVisibility = 16

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.High Field

ChartMarkerVisibilityHigh Field
Indicates that high markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility High = 4
Public Const High As ChartMarkerVisibility = 4

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.Last Field

ChartMarkerVisibilityLast Field
Indicates that the last marker will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility Last = 32
Public Const Last As ChartMarkerVisibility = 32

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.Low Field

ChartMarkerVisibilityLow Field
Indicates that low markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility Low = 8
Public Const Low As ChartMarkerVisibility = 8

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.Negative Field

ChartMarkerVisibilityNegative Field
Indicates that negative markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility Negative = 2
Public Const Negative As ChartMarkerVisibility = 2

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.None Field

ChartMarkerVisibilityNone Field
Indicates that no markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility None = 0
Public Const None As ChartMarkerVisibility = 0

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.Positive Field

ChartMarkerVisibilityPositive Field
Indicates that positive markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ChartMarkerVisibility Positive = 1
Public Const Positive As ChartMarkerVisibility = 1

Field Value

Type: ChartMarkerVisibility
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ChartMarkerVisibility.value__ Field

ChartMarkerVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.ChartMarkerVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel Class

DataPointLabel Class
A label on a data point.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsDataPointLabel

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DataPointLabel : Control
Public Class DataPointLabel
    Inherits Control

The DataPointLabel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredPosition | Gets or sets the desired position.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SeriesDefaultBrush | Gets or sets the series default brush.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the label text.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | WasMouseInsideBounds | Gets or sets a value indicating whether the data point was mouse inside bounds.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | Hide | Begins the animation to hide the data point label.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Begins the animation to show the data point label.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
SeriesDefaultBrushProperty | Identifies the SeriesDefaultBrush dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
WasMouseInsideBoundsProperty | Identifies the WasMouseInsideBounds dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel Properties

DataPointLabel Properties

The DataPointLabel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredPosition | Gets or sets the desired position.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SeriesDefaultBrush | Gets or sets the series default brush.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the label text.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | WasMouseInsideBounds | Gets or sets a value indicating whether the data point was mouse inside bounds.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.DesiredPosition Property

DataPointLabelDesiredPosition Property
Gets or sets the desired position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point DesiredPosition { get; set; }
Public Property DesiredPosition As Point
    Get
    Set

Property Value

Type: Point
The desired position.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.SeriesDefaultBrush Property

DataPointLabelSeriesDefaultBrush Property
Gets or sets the series default brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SeriesDefaultBrush { get; set; }
Public Property SeriesDefaultBrush As Brush
    Get
    Set

Property Value

Type: Brush
The series default brush.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.Text Property

DataPointLabelText Property
Gets or sets the label text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The label text.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.WasMouseInsideBounds Property

DataPointLabelWasMouseInsideBounds Property
Gets or sets a value indicating whether the data point was mouse inside bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool WasMouseInsideBounds { get; set; }
Public Property WasMouseInsideBounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data point was mouse inside bounds; otherwise, false.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel Methods

DataPointLabel Methods

The DataPointLabel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | Hide | Begins the animation to hide the data point label.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Begins the animation to show the data point label.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.Hide Method

DataPointLabelHide Method
Begins the animation to hide the data point label.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Hide()
Public Sub Hide
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.OnApplyTemplate Method

DataPointLabelOnApplyTemplate Method
When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.Show Method

DataPointLabelShow Method
Begins the animation to show the data point label.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Show()
Public Sub Show
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel Events

DataPointLabel Events

The DataPointLabel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel Fields

DataPointLabel Fields

The DataPointLabel type exposes the following members.

Fields
Name | Description
SeriesDefaultBrushProperty | Identifies the SeriesDefaultBrush dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
WasMouseInsideBoundsProperty | Identifies the WasMouseInsideBounds dependency property. This field is read-only.
Top
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.SeriesDefaultBrushProperty Field

DataPointLabelSeriesDefaultBrushProperty Field
Identifies the SeriesDefaultBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SeriesDefaultBrushProperty
Public Shared ReadOnly SeriesDefaultBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SeriesDefaultBrush dependency property.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.TextProperty Field

DataPointLabelTextProperty Field
Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DataPointLabel.WasMouseInsideBoundsProperty Field

DataPointLabelWasMouseInsideBoundsProperty Field
Identifies the WasMouseInsideBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WasMouseInsideBoundsProperty
Public Shared ReadOnly WasMouseInsideBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WasMouseInsideBounds dependency property.
See Also

Reference

DataPointLabel Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Class

DeferrableObservableItemCollectionT Class
Represents a collection of objects that can be observed for items being removed and added by any means, including Clear and Replace.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.UI.XamlDeferrableObservableCollection T
ActiproSoftware.UI.Xaml.Controls.ChartsDeferrableObservableItemCollectionT
ActiproSoftware.UI.Xaml.Controls.ChartsXYAxisCollection
ActiproSoftware.UI.Xaml.Controls.ChartsXYRangeCollection
ActiproSoftware.UI.Xaml.Controls.ChartsXYSeriesCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DeferrableObservableItemCollection<T> : DeferrableObservableCollection<T>
where T : class

Public Class DeferrableObservableItemCollection(Of T As Class)
    Inherits DeferrableObservableCollection(Of T)

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Charts.DeferrableObservableItemCollection`1"]

The DeferrableObservableItemCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection T.)
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | (Inherited from ObservableCollection T.)
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection T.)
Public method | CopyTo | (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T.)
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection T.)
Protected method | MoveItem | (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection T.)
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Properties

DeferrableObservableItemCollectionT Properties

The DeferrableObservableItemCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection T .)
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Methods

DeferrableObservableItemCollectionT Methods

The DeferrableObservableItemCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection T .)
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection T .)
Public method | CopyTo | (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection T .)
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection T .)
Protected method | MoveItem | (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection T .)
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T).ClearItems Method

DeferrableObservableItemCollectionTClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T).InsertItem Method

DeferrableObservableItemCollectionTInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T).RemoveItem Method

DeferrableObservableItemCollectionTRemoveItem Method
Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T).SetItem Method

DeferrableObservableItemCollectionTSetItem Method
Replaces the element at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: T
The new value for the element at the specified index.
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DeferrableObservableItemCollection(T) Events

DeferrableObservableItemCollectionT Events

The DeferrableObservableItemCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | (Inherited from ObservableCollection T .)
Top
See Also

Reference

DeferrableObservableItemCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart Class

DonutChart Class
Represents a donut chart control, which is a pie chart with the center cut out.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsPieChart
ActiproSoftware.UI.Xaml.Controls.ChartsDonutChart

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DonutChart : PieChart
Public Class DonutChart
    Inherits PieChart

The DonutChart type exposes the following members.

Constructors
 | Name | Description
Public method | DonutChart | Initializes a new instance of the DonutChart class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface. (Inherited from PieChart.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HoleRadiusPercentage | Gets the hole radius percentage.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible. (Inherited from PieChart.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position. (Inherited from PieChart.)
Public property | LegendMargin | Gets or sets the legend margin. (Inherited from PieChart.)
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend. (Inherited from PieChart.)
Public property | LegendVerticalPosition | Gets or sets the legend vertical position. (Inherited from PieChart.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the series. (Inherited from PieChart.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead. (Inherited from PieChart.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Inherited from PieChart.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PieChart.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes this instance. (Inherited from PieChart.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HoleRadiusPercentageProperty | Identifies the HoleRadiusPercentage dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart Constructor

DonutChart Constructor
Initializes a new instance of the DonutChart class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DonutChart()
Public Sub New
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart Properties

DonutChart Properties

The DonutChart type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface. (Inherited from PieChart.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HoleRadiusPercentage | Gets the hole radius percentage.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible. (Inherited from PieChart.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position. (Inherited from PieChart.)
Public property | LegendMargin | Gets or sets the legend margin. (Inherited from PieChart.)
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend. (Inherited from PieChart.)
Public property | LegendVerticalPosition | Gets or sets the legend vertical position. (Inherited from PieChart.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the series. (Inherited from PieChart.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead. (Inherited from PieChart.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart.HoleRadiusPercentage Property

DonutChartHoleRadiusPercentage Property
Gets the hole radius percentage.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double HoleRadiusPercentage { get; set; }
Public Property HoleRadiusPercentage As Double
    Get
    Set

Property Value

Type: Double
The hole radius percentage.
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart Methods

DonutChart Methods

The DonutChart type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior. (Inherited from PieChart.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PieChart.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes this instance. (Inherited from PieChart.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart Events

DonutChart Events

The DonutChart type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart Fields

DonutChart Fields

The DonutChart type exposes the following members.

Fields
Name | Description
HoleRadiusPercentageProperty | Identifies the HoleRadiusPercentage dependency property. This field is read-only.
Top
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


DonutChart.HoleRadiusPercentageProperty Field

DonutChartHoleRadiusPercentageProperty Field
Identifies the HoleRadiusPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HoleRadiusPercentageProperty
Public Shared ReadOnly HoleRadiusPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HoleRadiusPercentage dependency property.
See Also

Reference

DonutChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility Class

GridLineVisibility Class
Specifies which axes that grid lines will be visible for.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsGridLineVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class GridLineVisibility : Enum
<FlagsAttribute>
Public NotInheritable Class GridLineVisibility
    Inherits Enum

The GridLineVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that grid lines will be visible for both the X and Y axis.
 | None | Indicates that grid lines will not be visible.
Public field | value__ |
 | X | Indicates that grid lines will be visible for the X axis.
 | Y | Indicates that grid lines will be visible for the Y axis.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility Methods

GridLineVisibility Methods

The GridLineVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility Fields

GridLineVisibility Fields

The GridLineVisibility type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that grid lines will be visible for both the X and Y axis.
 | None | Indicates that grid lines will not be visible.
Public field | value__ |
 | X | Indicates that grid lines will be visible for the X axis.
 | Y | Indicates that grid lines will be visible for the Y axis.
Top
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility.All Field

GridLineVisibilityAll Field
Indicates that grid lines will be visible for both the X and Y axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridLineVisibility All = 3
Public Const All As GridLineVisibility = 3

Field Value

Type: GridLineVisibility
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility.None Field

GridLineVisibilityNone Field
Indicates that grid lines will not be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridLineVisibility None = 0
Public Const None As GridLineVisibility = 0

Field Value

Type: GridLineVisibility
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility.value__ Field

GridLineVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.GridLineVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility.X Field

GridLineVisibilityX Field
Indicates that grid lines will be visible for the X axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridLineVisibility X = 1
Public Const X As GridLineVisibility = 1

Field Value

Type: GridLineVisibility
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridLineVisibility.Y Field

GridLineVisibilityY Field
Indicates that grid lines will be visible for the Y axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridLineVisibility Y = 2
Public Const Y As GridLineVisibility = 2

Field Value

Type: GridLineVisibility
See Also

Reference

GridLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility Class

GridStripeVisibility Class
Specifies which axes that grid stripes will be visible for.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsGridStripeVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class GridStripeVisibility : Enum
Public NotInheritable Class GridStripeVisibility
    Inherits Enum

The GridStripeVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | Indicates that grid stripes will not be visible.
Public field | value__ |
 | X | Indicates that grid stripes will be visible for the X axis.
 | Y | Indicates that grid stripes will be visible for the Y axis.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility Methods

GridStripeVisibility Methods

The GridStripeVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

GridStripeVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility Fields

GridStripeVisibility Fields

The GridStripeVisibility type exposes the following members.

Fields
 | Name | Description
 | None | Indicates that grid stripes will not be visible.
Public field | value__ |
 | X | Indicates that grid stripes will be visible for the X axis.
 | Y | Indicates that grid stripes will be visible for the Y axis.
Top
See Also

Reference

GridStripeVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility.None Field

GridStripeVisibilityNone Field
Indicates that grid stripes will not be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridStripeVisibility None = 0
Public Const None As GridStripeVisibility = 0

Field Value

Type: GridStripeVisibility
See Also

Reference

GridStripeVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility.value__ Field

GridStripeVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.GridStripeVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

GridStripeVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility.X Field

GridStripeVisibilityX Field
Indicates that grid stripes will be visible for the X axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridStripeVisibility X = 1
Public Const X As GridStripeVisibility = 1

Field Value

Type: GridStripeVisibility
See Also

Reference

GridStripeVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


GridStripeVisibility.Y Field

GridStripeVisibilityY Field
Indicates that grid stripes will be visible for the Y axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const GridStripeVisibility Y = 2
Public Const Y As GridStripeVisibility = 2

Field Value

Type: GridStripeVisibility
See Also

Reference

GridStripeVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ILabelPositioner Interface

ILabelPositioner Interface
Positions data point labels.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ILabelPositioner
Public Interface ILabelPositioner

The ILabelPositioner type exposes the following members.

Methods
 | Name | Description
Public method | GetRotationPointForLabel | Gets the rotation point for a given DataPointLabel.
Public method | SetLabelPosition | Sets the label position.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ILabelPositioner Methods

ILabelPositioner Methods

The ILabelPositioner type exposes the following members.

Methods
 | Name | Description
Public method | GetRotationPointForLabel | Gets the rotation point for a given DataPointLabel.
Public method | SetLabelPosition | Sets the label position.
Top
See Also

Reference

ILabelPositioner Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ILabelPositioner.GetRotationPointForLabel Method

ILabelPositionerGetRotationPointForLabel Method
Gets the rotation point for a given DataPointLabel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Point GetRotationPointForLabel(
    DataPointLabel label,
    IEnumerable<DataPointLabel> allLabels
)
Function GetRotationPointForLabel (
    label As DataPointLabel,
    allLabels As IEnumerable(Of DataPointLabel)
) As Point

Parameters

label
Type: ActiproSoftware.UI.Xaml.Controls.ChartsDataPointLabel
The label.
allLabels
Type: System.Collections.GenericIEnumerable DataPointLabel
All labels.

Return Value

Type: Point
The rotation point for a given DataPointLabel.
See Also

Reference

ILabelPositioner Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ILabelPositioner.SetLabelPosition Method

ILabelPositionerSetLabelPosition Method
Sets the label position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SetLabelPosition(
    DataPointLabel label,
    IEnumerable<DataPointLabel> allLabels
)
Sub SetLabelPosition (
    label As DataPointLabel,
    allLabels As IEnumerable(Of DataPointLabel)
)

Parameters

label
Type: ActiproSoftware.UI.Xaml.Controls.ChartsDataPointLabel
The label.
allLabels
Type: System.Collections.GenericIEnumerable DataPointLabel
All labels.
See Also

Reference

ILabelPositioner Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Class

InvalidAxisException Class
An exception thrown when an axis is bound to an incorrect data type.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.UI.Xaml.Controls.ChartsInvalidAxisException

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvalidAxisException : Exception
Public Class InvalidAxisException
    Inherits Exception

The InvalidAxisException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidAxisException | Initializes a new instance of the InvalidAxisException class.
Public method | InvalidAxisException(String) | Initializes a new instance of the Exception class with a specified error message.
Public method | InvalidAxisException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Constructor

InvalidAxisException Constructor
Overload List
 | Name | Description
Public method | InvalidAxisException | Initializes a new instance of the InvalidAxisException class.
Public method | InvalidAxisException(String) | Initializes a new instance of the Exception class with a specified error message.
Public method | InvalidAxisException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidAxisException Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Constructor

InvalidAxisException Constructor
Initializes a new instance of the InvalidAxisException class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidAxisException()
Public Sub New
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Constructor (String)

InvalidAxisException Constructor (String)
Initializes a new instance of the Exception class with a specified error message.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidAxisException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Constructor (String, Exception)

InvalidAxisException Constructor (String, Exception)
Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidAxisException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidAxisException Class
InvalidAxisException Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Properties

InvalidAxisException Properties

The InvalidAxisException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
See Also

Reference

InvalidAxisException Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


InvalidAxisException Methods

InvalidAxisException Methods

The InvalidAxisException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

InvalidAxisException Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


IPieSliceStyleSelector Interface

IPieSliceStyleSelector Interface
Provides the base requirements for a class that determines how a pie slice will be styled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPieSliceStyleSelector
Public Interface IPieSliceStyleSelector

The IPieSliceStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. The Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. The Style must have TargetType of PieSlice.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


IPieSliceStyleSelector Methods

IPieSliceStyleSelector Methods

The IPieSliceStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. The Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. The Style must have TargetType of PieSlice.
Top
See Also

Reference

IPieSliceStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


IPieSliceStyleSelector.SelectChildPieSliceStyle Method

IPieSliceStyleSelectorSelectChildPieSliceStyle Method
Selects the child pie slice style. The Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectChildPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Color parentFill,
    Style defaultStyle
)
Function SelectChildPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    parentFill As Color,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
parentFill
Type: Windows.UIColor
The parent fill color.
defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.
See Also

Reference

IPieSliceStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


IPieSliceStyleSelector.SelectPieSliceStyle Method

IPieSliceStyleSelectorSelectPieSliceStyle Method
Selects the pie slice style. The Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Style defaultStyle
)
Function SelectPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.
See Also

Reference

IPieSliceStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector Interface

ISeriesStyleSelector Interface
Provides the base requirements for a class that determines how a series will be styled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISeriesStyleSelector
Public Interface ISeriesStyleSelector

The ISeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector Methods

ISeriesStyleSelector Methods

The ISeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Top
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector.SelectAreaStyle Method

ISeriesStyleSelectorSelectAreaStyle Method
Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectAreaStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectAreaStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector.SelectBarStyle Method

ISeriesStyleSelectorSelectBarStyle Method
Returns the bar Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectBarStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectBarStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector.SelectLegendMarkerStyle Method

ISeriesStyleSelectorSelectLegendMarkerStyle Method
Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectLegendMarkerStyle(
    XYSeriesBase series,
    Style defaultStyle
)
Function SelectLegendMarkerStyle (
    series As XYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector.SelectLineStyle Method

ISeriesStyleSelectorSelectLineStyle Method
Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectLineStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectLineStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ISeriesStyleSelector.SelectMarkerStyle Method

ISeriesStyleSelectorSelectMarkerStyle Method
Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Style SelectMarkerStyle(
    SeriesBase series,
    Style defaultStyle
)
Function SelectMarkerStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

ISeriesStyleSelector Interface
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelCollisionMode Class

LabelCollisionMode Class
Specifies how data point labels resolve collisions.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsLabelCollisionMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LabelCollisionMode : Enum
Public NotInheritable Class LabelCollisionMode
    Inherits Enum

The LabelCollisionMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | Indicates that data point labels will not attempt to resolve collision and can overlap.
 | Stacked | Indicates that overlapping data point labels will stack above or below each other, away from the baseline.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelCollisionMode Methods

LabelCollisionMode Methods

The LabelCollisionMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LabelCollisionMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelCollisionMode Fields

LabelCollisionMode Fields

The LabelCollisionMode type exposes the following members.

Fields
 | Name | Description
 | None | Indicates that data point labels will not attempt to resolve collision and can overlap.
 | Stacked | Indicates that overlapping data point labels will stack above or below each other, away from the baseline.
Public field | value__ |
Top
See Also

Reference

LabelCollisionMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelCollisionMode.None Field

LabelCollisionModeNone Field
Indicates that data point labels will not attempt to resolve collision and can overlap.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelCollisionMode None = 0
Public Const None As LabelCollisionMode = 0

Field Value

Type: LabelCollisionMode
See Also

Reference

LabelCollisionMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelCollisionMode.Stacked Field

LabelCollisionModeStacked Field
Indicates that overlapping data point labels will stack above or below each other, away from the baseline.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelCollisionMode Stacked = 1
Public Const Stacked As LabelCollisionMode = 1

Field Value

Type: LabelCollisionMode
See Also

Reference

LabelCollisionMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelCollisionMode.value__ Field

LabelCollisionModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.LabelCollisionMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LabelCollisionMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelPositioningMode Class

LabelPositioningMode Class
Specifies how data point labels are positioned.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsLabelPositioningMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LabelPositioningMode : Enum
Public NotInheritable Class LabelPositioningMode
    Inherits Enum

The LabelPositioningMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | FromAverage | Indicates that data point labels will be positioned away from the average primary value of data points on the secondary axis.
 | FromBaseline | Indicates that data point labels will be positioned away from the baseline.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelPositioningMode Methods

LabelPositioningMode Methods

The LabelPositioningMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LabelPositioningMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelPositioningMode Fields

LabelPositioningMode Fields

The LabelPositioningMode type exposes the following members.

Fields
 | Name | Description
 | FromAverage | Indicates that data point labels will be positioned away from the average primary value of data points on the secondary axis.
 | FromBaseline | Indicates that data point labels will be positioned away from the baseline.
Public field | value__ |
Top
See Also

Reference

LabelPositioningMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelPositioningMode.FromAverage Field

LabelPositioningModeFromAverage Field
Indicates that data point labels will be positioned away from the average primary value of data points on the secondary axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelPositioningMode FromAverage = 1
Public Const FromAverage As LabelPositioningMode = 1

Field Value

Type: LabelPositioningMode
See Also

Reference

LabelPositioningMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelPositioningMode.FromBaseline Field

LabelPositioningModeFromBaseline Field
Indicates that data point labels will be positioned away from the baseline.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelPositioningMode FromBaseline = 0
Public Const FromBaseline As LabelPositioningMode = 0

Field Value

Type: LabelPositioningMode
See Also

Reference

LabelPositioningMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelPositioningMode.value__ Field

LabelPositioningModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.LabelPositioningMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LabelPositioningMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility Class

LabelVisibility Class
Specifies the visibility of data point labels on the chart.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsLabelVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LabelVisibility : Enum
Public NotInheritable Class LabelVisibility
    Inherits Enum

The LabelVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Hidden | Indicates that data point labels are not shown.
 | PointerAxis | Indicates that data point labels on the secondary axis value closest to the mouse pointer are visible.
 | PointerProximity | Indicates that data point labels near the mouse pointer are visible.
Public field | value__ |
 | Visible | Indicates that data point labels are always visible.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility Methods

LabelVisibility Methods

The LabelVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility Fields

LabelVisibility Fields

The LabelVisibility type exposes the following members.

Fields
 | Name | Description
 | Hidden | Indicates that data point labels are not shown.
 | PointerAxis | Indicates that data point labels on the secondary axis value closest to the mouse pointer are visible.
 | PointerProximity | Indicates that data point labels near the mouse pointer are visible.
Public field | value__ |
 | Visible | Indicates that data point labels are always visible.
Top
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility.Hidden Field

LabelVisibilityHidden Field
Indicates that data point labels are not shown.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelVisibility Hidden = 0
Public Const Hidden As LabelVisibility = 0

Field Value

Type: LabelVisibility
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility.PointerAxis Field

LabelVisibilityPointerAxis Field
Indicates that data point labels on the secondary axis value closest to the mouse pointer are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelVisibility PointerAxis = 3
Public Const PointerAxis As LabelVisibility = 3

Field Value

Type: LabelVisibility
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility.PointerProximity Field

LabelVisibilityPointerProximity Field
Indicates that data point labels near the mouse pointer are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelVisibility PointerProximity = 2
Public Const PointerProximity As LabelVisibility = 2

Field Value

Type: LabelVisibility
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility.value__ Field

LabelVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.LabelVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LabelVisibility.Visible Field

LabelVisibilityVisible Field
Indicates that data point labels are always visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LabelVisibility Visible = 1
Public Const Visible As LabelVisibility = 1

Field Value

Type: LabelVisibility
See Also

Reference

LabelVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition Class

LegendHorizontalPosition Class
Specifies the horizontal position of the legend in relation to its parent chart.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsLegendHorizontalPosition

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LegendHorizontalPosition : Enum
Public NotInheritable Class LegendHorizontalPosition
    Inherits Enum

The LegendHorizontalPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CenterInside | Indicates that the legend will be centered horizontally inside the drawing surface of the chart control.
 | CenterOutside | Indicates that the legend will be centered horizontally in the chart control.
 | LeftInside | Indicates that the legend will be placed to the left of the chart control.
 | LeftOutside | Indicates that the legend will be placed to the left of the drawing surface of the chart control.
 | RightInside | Indicates that the legend will be placed to the right of the chart control.
 | RightOutside | Indicates that the legend will be placed to the right of the drawing surface of the chart control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition Methods

LegendHorizontalPosition Methods

The LegendHorizontalPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition Fields

LegendHorizontalPosition Fields

The LegendHorizontalPosition type exposes the following members.

Fields
 | Name | Description
 | CenterInside | Indicates that the legend will be centered horizontally inside the drawing surface of the chart control.
 | CenterOutside | Indicates that the legend will be centered horizontally in the chart control.
 | LeftInside | Indicates that the legend will be placed to the left of the chart control.
 | LeftOutside | Indicates that the legend will be placed to the left of the drawing surface of the chart control.
 | RightInside | Indicates that the legend will be placed to the right of the chart control.
 | RightOutside | Indicates that the legend will be placed to the right of the drawing surface of the chart control.
Public field | value__ |
Top
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.CenterInside Field

LegendHorizontalPositionCenterInside Field
Indicates that the legend will be centered horizontally inside the drawing surface of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendHorizontalPosition CenterInside = 1
Public Const CenterInside As LegendHorizontalPosition = 1

Field Value

Type: LegendHorizontalPosition
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.CenterOutside Field

LegendHorizontalPositionCenterOutside Field
Indicates that the legend will be centered horizontally in the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendHorizontalPosition CenterOutside = 0
Public Const CenterOutside As LegendHorizontalPosition = 0

Field Value

Type: LegendHorizontalPosition
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.LeftInside Field

LegendHorizontalPositionLeftInside Field
Indicates that the legend will be placed to the left of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendHorizontalPosition LeftInside = 2
Public Const LeftInside As LegendHorizontalPosition = 2

Field Value

Type: LegendHorizontalPosition
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.LeftOutside Field

LegendHorizontalPositionLeftOutside Field
Indicates that the legend will be placed to the left of the drawing surface of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendHorizontalPosition LeftOutside = 3
Public Const LeftOutside As LegendHorizontalPosition = 3

Field Value

Type: LegendHorizontalPosition
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.RightInside Field

LegendHorizontalPositionRightInside Field
Indicates that the legend will be placed to the right of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendHorizontalPosition RightInside = 4
Public Const RightInside As LegendHorizontalPosition = 4

Field Value

Type: LegendHorizontalPosition
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.RightOutside Field

LegendHorizontalPositionRightOutside Field
Indicates that the legend will be placed to the right of the drawing surface of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendHorizontalPosition RightOutside = 5
Public Const RightOutside As LegendHorizontalPosition = 5

Field Value

Type: LegendHorizontalPosition
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendHorizontalPosition.value__ Field

LegendHorizontalPositionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.LegendHorizontalPosition.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LegendHorizontalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey Class

LegendKey Class
Describes a key shown in a legend.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.ChartsLegendKey

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LegendKey : ObservableObjectBase
Public Class LegendKey
    Inherits ObservableObjectBase

The LegendKey type exposes the following members.

Constructors
 | Name | Description
Public method | LegendKey | Initializes a new instance of the LegendKey class
Top
Properties
 | Name | Description
Public property | Label | Gets or sets the label.
Public property | LegendMarkerStyle | Gets or sets the legend marker style.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey Constructor

LegendKey Constructor
Initializes a new instance of the LegendKey class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendKey()
Public Sub New
See Also

Reference

LegendKey Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey Properties

LegendKey Properties

The LegendKey type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets the label.
Public property | LegendMarkerStyle | Gets or sets the legend marker style.
Top
See Also

Reference

LegendKey Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey.Label Property

LegendKeyLabel Property
Gets or sets the label.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set

Property Value

Type: String
The label.
See Also

Reference

LegendKey Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey.LegendMarkerStyle Property

LegendKeyLegendMarkerStyle Property
Gets or sets the legend marker style.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LegendMarkerStyle { get; set; }
Public Property LegendMarkerStyle As Style
    Get
    Set

Property Value

Type: Style
The legend marker style.
See Also

Reference

LegendKey Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey Methods

LegendKey Methods

The LegendKey type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LegendKey Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendKey Events

LegendKey Events

The LegendKey type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LegendKey Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition Class

LegendVerticalPosition Class
Specifies the vertical position of the legend in relation to its parent chart.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsLegendVerticalPosition

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LegendVerticalPosition : Enum
Public NotInheritable Class LegendVerticalPosition
    Inherits Enum

The LegendVerticalPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | BottomInside | Indicates that the legend will be placed to the bottom of the drawing surface of the chart control.
 | BottomOutside | Indicates that the legend will be placed to the bottom of the chart control.
 | CenterInside | Indicates that the legend will be centered vertically inside the drawing surface of the chart control.
 | CenterOutside | Indicates that the legend will be centered vertically in the chart control.
 | TopInside | Indicates that the legend will be placed to the top of the drawing surface of the chart control.
 | TopOutside | Indicates that the legend will be placed to the top of the chart control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition Methods

LegendVerticalPosition Methods

The LegendVerticalPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition Fields

LegendVerticalPosition Fields

The LegendVerticalPosition type exposes the following members.

Fields
 | Name | Description
 | BottomInside | Indicates that the legend will be placed to the bottom of the drawing surface of the chart control.
 | BottomOutside | Indicates that the legend will be placed to the bottom of the chart control.
 | CenterInside | Indicates that the legend will be centered vertically inside the drawing surface of the chart control.
 | CenterOutside | Indicates that the legend will be centered vertically in the chart control.
 | TopInside | Indicates that the legend will be placed to the top of the drawing surface of the chart control.
 | TopOutside | Indicates that the legend will be placed to the top of the chart control.
Public field | value__ |
Top
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.BottomInside Field

LegendVerticalPositionBottomInside Field
Indicates that the legend will be placed to the bottom of the drawing surface of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendVerticalPosition BottomInside = 5
Public Const BottomInside As LegendVerticalPosition = 5

Field Value

Type: LegendVerticalPosition
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.BottomOutside Field

LegendVerticalPositionBottomOutside Field
Indicates that the legend will be placed to the bottom of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendVerticalPosition BottomOutside = 4
Public Const BottomOutside As LegendVerticalPosition = 4

Field Value

Type: LegendVerticalPosition
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.CenterInside Field

LegendVerticalPositionCenterInside Field
Indicates that the legend will be centered vertically inside the drawing surface of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendVerticalPosition CenterInside = 1
Public Const CenterInside As LegendVerticalPosition = 1

Field Value

Type: LegendVerticalPosition
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.CenterOutside Field

LegendVerticalPositionCenterOutside Field
Indicates that the legend will be centered vertically in the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendVerticalPosition CenterOutside = 0
Public Const CenterOutside As LegendVerticalPosition = 0

Field Value

Type: LegendVerticalPosition
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.TopInside Field

LegendVerticalPositionTopInside Field
Indicates that the legend will be placed to the top of the drawing surface of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendVerticalPosition TopInside = 3
Public Const TopInside As LegendVerticalPosition = 3

Field Value

Type: LegendVerticalPosition
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.TopOutside Field

LegendVerticalPositionTopOutside Field
Indicates that the legend will be placed to the top of the chart control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LegendVerticalPosition TopOutside = 2
Public Const TopOutside As LegendVerticalPosition = 2

Field Value

Type: LegendVerticalPosition
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LegendVerticalPosition.value__ Field

LegendVerticalPositionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.LegendVerticalPosition.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LegendVerticalPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeries Class

LineSeries Class
Represents a line series for use in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsLineSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LineSeries : LineSeriesBase
Public Class LineSeries
    Inherits LineSeriesBase

The LineSeries type exposes the following members.

Constructors
 | Name | Description
Public method | LineSeries | Initializes a new instance of the LineSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from LineSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeries Constructor

LineSeries Constructor
Initializes a new instance of the LineSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LineSeries()
Public Sub New
See Also

Reference

LineSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeries Properties

LineSeries Properties

The LineSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out. (Inherited from LineSeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from LineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from LineSeriesBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

LineSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeries Methods

LineSeries Methods

The LineSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

LineSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeries Events

LineSeries Events

The LineSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

LineSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility Class

LineSeriesVisibility Class
Specifies the visibility of the various kinds of a line.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsLineSeriesVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class LineSeriesVisibility : Enum
<FlagsAttribute>
Public NotInheritable Class LineSeriesVisibility
    Inherits Enum

The LineSeriesVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | Negative | Indicates that negative lines will be visible.
 | None | Indicates that no lines will be visible.
 | Positive | Indicates that positive lines will be visible.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility Methods

LineSeriesVisibility Methods

The LineSeriesVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility Fields

LineSeriesVisibility Fields

The LineSeriesVisibility type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | Negative | Indicates that negative lines will be visible.
 | None | Indicates that no lines will be visible.
 | Positive | Indicates that positive lines will be visible.
Public field | value__ |
Top
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility.All Field

LineSeriesVisibilityAll Field
Indicates that all markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineSeriesVisibility All = 3
Public Const All As LineSeriesVisibility = 3

Field Value

Type: LineSeriesVisibility
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility.Negative Field

LineSeriesVisibilityNegative Field
Indicates that negative lines will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineSeriesVisibility Negative = 2
Public Const Negative As LineSeriesVisibility = 2

Field Value

Type: LineSeriesVisibility
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility.None Field

LineSeriesVisibilityNone Field
Indicates that no lines will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineSeriesVisibility None = 0
Public Const None As LineSeriesVisibility = 0

Field Value

Type: LineSeriesVisibility
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility.Positive Field

LineSeriesVisibilityPositive Field
Indicates that positive lines will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LineSeriesVisibility Positive = 1
Public Const Positive As LineSeriesVisibility = 1

Field Value

Type: LineSeriesVisibility
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


LineSeriesVisibility.value__ Field

LineSeriesVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.LineSeriesVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Class

NonNumericValueException Class
An exception for when a non-numeric value is provided.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.UI.Xaml.Controls.ChartsNonNumericValueException

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NonNumericValueException : Exception
Public Class NonNumericValueException
    Inherits Exception

The NonNumericValueException type exposes the following members.

Constructors
 | Name | Description
Public method | NonNumericValueException | Initializes a new instance of the NonNumericValueException class.
Public method | NonNumericValueException(String) | Initializes a new instance of the Exception class with a specified error message.
Public method | NonNumericValueException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Constructor

NonNumericValueException Constructor
Overload List
 | Name | Description
Public method | NonNumericValueException | Initializes a new instance of the NonNumericValueException class.
Public method | NonNumericValueException(String) | Initializes a new instance of the Exception class with a specified error message.
Public method | NonNumericValueException(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

NonNumericValueException Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Constructor

NonNumericValueException Constructor
Initializes a new instance of the NonNumericValueException class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonNumericValueException()
Public Sub New
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Constructor (String)

NonNumericValueException Constructor (String)
Initializes a new instance of the Exception class with a specified error message.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonNumericValueException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Constructor (String, Exception)

NonNumericValueException Constructor (String, Exception)
Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonNumericValueException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

NonNumericValueException Class
NonNumericValueException Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Properties

NonNumericValueException Properties

The NonNumericValueException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
See Also

Reference

NonNumericValueException Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


NonNumericValueException Methods

NonNumericValueException Methods

The NonNumericValueException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

NonNumericValueException Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart Class

PieChart Class
A control that displays a pie chart based on given data.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsPieChart
ActiproSoftware.UI.Xaml.Controls.ChartsDonutChart

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PieChart : Control
Public Class PieChart
    Inherits Control

The PieChart type exposes the following members.

Constructors
 | Name | Description
Public method | PieChart | Initializes a new instance of the PieChart class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendMargin | Gets or sets the legend margin.
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the series.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes this instance.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendMarginProperty | Identifies the LegendMargin dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
TetherBrushProperty | Identifies the TetherBrush dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart Constructor

PieChart Constructor
Initializes a new instance of the PieChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieChart()
Public Sub New
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart Properties

PieChart Properties

The PieChart type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | DrawingSurfaceSize | Gets or sets the size of the drawing surface.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendMargin | Gets or sets the legend margin.
Public property | LegendStyle | Gets or sets the legend style. Must have a TargetType of Legend.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the series.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TetherBrush | Gets or sets the brush used to draw label tethers. Remarks If TetherBrush is not set, then Foreground will be used instead.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.DrawingSurfaceSize Property

PieChartDrawingSurfaceSize Property
Gets or sets the size of the drawing surface.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Size DrawingSurfaceSize { get; }
Protected ReadOnly Property DrawingSurfaceSize As Size
    Get

Return Value

Type: Size
Size.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.IsLegendVisible Property

PieChartIsLegendVisible Property
Gets or sets a value indicating whether this instance is legend visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLegendVisible { get; set; }
Public Property IsLegendVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is legend visible; otherwise, false.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendHorizontalPosition Property

PieChartLegendHorizontalPosition Property
Gets or sets the legend horizontal position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendHorizontalPosition LegendHorizontalPosition { get; set; }
Public Property LegendHorizontalPosition As LegendHorizontalPosition
    Get
    Set

Property Value

Type: LegendHorizontalPosition
The legend horizontal position.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendMargin Property

PieChartLegendMargin Property
Gets or sets the legend margin.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness LegendMargin { get; set; }
Public Property LegendMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The legend margin.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendStyle Property

PieChartLegendStyle Property
Gets or sets the legend style. Must have a TargetType of Legend.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LegendStyle { get; set; }
Public Property LegendStyle As Style
    Get
    Set

Property Value

Type: Style
The legend style.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendVerticalPosition Property

PieChartLegendVerticalPosition Property
Gets or sets the legend vertical position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendVerticalPosition LegendVerticalPosition { get; set; }
Public Property LegendVerticalPosition As LegendVerticalPosition
    Get
    Set

Property Value

Type: LegendVerticalPosition
The legend vertical position.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.Series Property

PieChartSeries Property
Gets the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<PieSeries> Series { get; }
Public ReadOnly Property Series As ObservableCollection(Of PieSeries)
    Get

Property Value

Type: ObservableCollection PieSeries
The series.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.TetherBrush Property

PieChartTetherBrush Property
Gets or sets the brush used to draw label tethers.
Remarks
If TetherBrush is not set, then Foreground will be used instead.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TetherBrush { get; set; }
Public Property TetherBrush As Brush
    Get
    Set

Property Value

Type: Brush
The tether brush.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart Methods

PieChart Methods

The PieChart type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes this instance.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.MeasureOverride Method

PieChartMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Top
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.MeasureOverride Method (Size)

PieChartMeasureOverride Method (Size)
Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

PieChart Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.OnApplyTemplate Method

PieChartOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.Refresh Method

PieChartRefresh Method
Refreshes this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart Events

PieChart Events

The PieChart type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart Fields

PieChart Fields

The PieChart type exposes the following members.

Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendMarginProperty | Identifies the LegendMargin dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
TetherBrushProperty | Identifies the TetherBrush dependency property. This field is read-only.
Top
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.IsLegendVisibleProperty Field

PieChartIsLegendVisibleProperty Field
Identifies the IsLegendVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLegendVisibleProperty
Public Shared ReadOnly IsLegendVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendHorizontalPositionProperty Field

PieChartLegendHorizontalPositionProperty Field
Identifies the LegendHorizontalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendHorizontalPositionProperty
Public Shared ReadOnly LegendHorizontalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendHorizontalPosition dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendMarginProperty Field

PieChartLegendMarginProperty Field
Identifies the LegendMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendMarginProperty
Public Shared ReadOnly LegendMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendMargin dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendStyleProperty Field

PieChartLegendStyleProperty Field
Identifies the LegendStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStyleProperty
Public Shared ReadOnly LegendStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStyle dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.LegendVerticalPositionProperty Field

PieChartLegendVerticalPositionProperty Field
Identifies the LegendVerticalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendVerticalPositionProperty
Public Shared ReadOnly LegendVerticalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendVerticalPosition dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieChart.TetherBrushProperty Field

PieChartTetherBrushProperty Field
Identifies the TetherBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TetherBrushProperty
Public Shared ReadOnly TetherBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TetherBrush dependency property.
See Also

Reference

PieChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries Class

PieSeries Class
Represents a pie series for use in a PieChart or DonutChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsPieSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PieSeries : Control
Public Class PieSeries
    Inherits Control

The PieSeries type exposes the following members.

Constructors
 | Name | Description
Public method | PieSeries | Initializes a new instance of the PieSeries class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreChildLabelsVisible | Gets or sets a value indicating whether child labels are visible or not.
Public property | AreChildrenVisibleInLegend | Gets or sets a value indicating whether children are visible in the legend or not.
Public property | AreLabelsVisible | Gets or sets a value indicating whether labels are visible or not.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ChildLabelBrush | Gets or sets the brush used for child pie slice labels.
Public property | ChildLabelPosition | Gets or sets the child label position.
Public property | ChildLabelStyle | Gets or sets the style applied to child pie slice labels. Style should have TargetType of TextBlock.
Public property | ChildrenLength | Gets or sets the length of the children.
Public property | ChildrenPath | Gets or sets the children path.
Public property | ChildrenPosition | Gets or sets the children position.
Public property | ChildSliceLabelFormat | Gets or sets the child slice label format.
Public property | ChildSliceLabelFunc | Gets or sets the child slice label func.
Public property | ChildSliceTitlePath | Gets or sets the child slice title path.
Public property | ChildSliceValuePath | Gets or sets the child slice value path.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOtherThresholdPercent | Gets or sets a value indicating whether this instance is other threshold percent.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsVisibleInLegend | Gets or sets a value indicating whether this instance is visible in legend.
Public property | ItemsSource | Gets or sets the items source.
Public property | LabelBrush | Gets or sets the brush used for labels.
Public property | LabelInsideFitMode | Gets or sets the label inside fit mode.
Public property | LabelPosition | Gets or sets the label position.
Public property | LabelStyle | Gets or sets the style applied to pie slice labels. Style should have TargetType of TextBlock.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Length | Gets or sets the size of pie series in relation to the other pie series.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OtherThreshold | Gets or sets the threshold for the "Other" slice.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SliceLabelFormat | Gets or sets the slice label format.
Public property | SliceLabelFunc | Gets or sets the slice label func.
Public property | SliceStyleSelector | Gets or sets the slice style selector, which determines the style used for each pie slice.
Public property | SliceTitlePath | Gets or sets the slice title path.
Public property | SliceValuePath | Gets or sets the slice value path.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Protected method | FireRefresh | Fires the Refresh event.
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refresh | Occurs when a property on pie series is changed that requires the pie chart to be refreshed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreChildLabelsVisibleProperty | Identifies the AreChildLabelsVisible dependency property. This field is read-only.
AreChildrenVisibleInLegendProperty | Identifies the AreChildrenVisibleInLegend dependency property. This field is read-only.
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
ChildLabelBrushProperty | Identifies the ChildLabelBrush dependency property. This field is read-only.
ChildLabelPositionProperty | Identifies the ChildLabelPosition dependency property. This field is read-only.
ChildLabelStyleProperty | Identifies the ChildLabelStyle dependency property. This field is read-only.
ChildLengthProperty | Identifies the ChildrenLength dependency property. This field is read-only.
ChildPositionProperty | Identifies the ChildrenPosition dependency property. This field is read-only.
ChildrenPathProperty | Identifies the ChildrenPath dependency property. This field is read-only.
ChildSliceLabelFormatProperty | Identifies the ChildSliceLabelFormat dependency property. This field is read-only.
ChildSliceLabelFuncProperty | Identifies the ChildSliceLabelFunc dependency property. This field is read-only.
ChildSliceTitlePathProperty | Identifies the ChildSliceTitlePath dependency property. This field is read-only.
ChildValuePathProperty | Identifies the ChildSliceValuePath dependency property. This field is read-only.
IsOtherThresholdPercentProperty | Identifies the IsOtherThresholdPercent dependency property. This field is read-only.
IsVisibleInLegendProperty | Identifies the IsVisibleInLegend dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
LabelBrushProperty | Identifies the LabelBrush dependency property. This field is read-only.
LabelInsideFitModeProperty | Identifies the LabelInsideFitMode dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
LengthProperty | Identifies the Length dependency property. This field is read-only.
OtherThresholdProperty | Identifies the OtherThreshold dependency property. This field is read-only.
SliceLabelFormatProperty | Identifies the SliceLabelFormat dependency property. This field is read-only.
SliceLabelFuncProperty | Identifies the SliceLabelFunc dependency property. This field is read-only.
SliceStyleSelectorProperty | Identifies the SliceStyleSelector dependency property. This field is read-only.
SliceTitlePathProperty | Identifies the SliceTitlePath dependency property. This field is read-only.
SliceValuePathProperty | Identifies the SliceValuePath dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries Constructor

PieSeries Constructor
Initializes a new instance of the PieSeries class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSeries()
Public Sub New
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries Properties

PieSeries Properties

The PieSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreChildLabelsVisible | Gets or sets a value indicating whether child labels are visible or not.
Public property | AreChildrenVisibleInLegend | Gets or sets a value indicating whether children are visible in the legend or not.
Public property | AreLabelsVisible | Gets or sets a value indicating whether labels are visible or not.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ChildLabelBrush | Gets or sets the brush used for child pie slice labels.
Public property | ChildLabelPosition | Gets or sets the child label position.
Public property | ChildLabelStyle | Gets or sets the style applied to child pie slice labels. Style should have TargetType of TextBlock.
Public property | ChildrenLength | Gets or sets the length of the children.
Public property | ChildrenPath | Gets or sets the children path.
Public property | ChildrenPosition | Gets or sets the children position.
Public property | ChildSliceLabelFormat | Gets or sets the child slice label format.
Public property | ChildSliceLabelFunc | Gets or sets the child slice label func.
Public property | ChildSliceTitlePath | Gets or sets the child slice title path.
Public property | ChildSliceValuePath | Gets or sets the child slice value path.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOtherThresholdPercent | Gets or sets a value indicating whether this instance is other threshold percent.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsVisibleInLegend | Gets or sets a value indicating whether this instance is visible in legend.
Public property | ItemsSource | Gets or sets the items source.
Public property | LabelBrush | Gets or sets the brush used for labels.
Public property | LabelInsideFitMode | Gets or sets the label inside fit mode.
Public property | LabelPosition | Gets or sets the label position.
Public property | LabelStyle | Gets or sets the style applied to pie slice labels. Style should have TargetType of TextBlock.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Length | Gets or sets the size of pie series in relation to the other pie series.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OtherThreshold | Gets or sets the threshold for the "Other" slice.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SliceLabelFormat | Gets or sets the slice label format.
Public property | SliceLabelFunc | Gets or sets the slice label func.
Public property | SliceStyleSelector | Gets or sets the slice style selector, which determines the style used for each pie slice.
Public property | SliceTitlePath | Gets or sets the slice title path.
Public property | SliceValuePath | Gets or sets the slice value path.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.AreChildLabelsVisible Property

PieSeriesAreChildLabelsVisible Property
Gets or sets a value indicating whether child labels are visible or not.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreChildLabelsVisible { get; set; }
Public Property AreChildLabelsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if child labels are visible; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.AreChildrenVisibleInLegend Property

PieSeriesAreChildrenVisibleInLegend Property
Gets or sets a value indicating whether children are visible in the legend or not.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreChildrenVisibleInLegend { get; set; }
Public Property AreChildrenVisibleInLegend As Boolean
    Get
    Set

Property Value

Type: Boolean
true if children are visible in the legend; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.AreLabelsVisible Property

PieSeriesAreLabelsVisible Property
Gets or sets a value indicating whether labels are visible or not.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreLabelsVisible { get; set; }
Public Property AreLabelsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if labels are visible; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLabelBrush Property

PieSeriesChildLabelBrush Property
Gets or sets the brush used for child pie slice labels.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ChildLabelBrush { get; set; }
Public Property ChildLabelBrush As Brush
    Get
    Set

Property Value

Type: Brush
The child label brush.
Remarks
If ChildLabelBrush is not set, then LabelBrush will be used, or Foreground if neither are set.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLabelPosition Property

PieSeriesChildLabelPosition Property
Gets or sets the child label position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSliceLabelPosition ChildLabelPosition { get; set; }
Public Property ChildLabelPosition As PieSliceLabelPosition
    Get
    Set

Property Value

Type: PieSliceLabelPosition
The child label position.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLabelStyle Property

PieSeriesChildLabelStyle Property
Gets or sets the style applied to child pie slice labels. Style should have TargetType of TextBlock.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ChildLabelStyle { get; set; }
Public Property ChildLabelStyle As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildrenLength Property

PieSeriesChildrenLength Property
Gets or sets the length of the children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ChildrenLength { get; set; }
Public Property ChildrenLength As Double
    Get
    Set

Property Value

Type: Double
The length of the children.
Remarks
Length is the size of children in relation to the other pie series.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildrenPath Property

PieSeriesChildrenPath Property
Gets or sets the children path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ChildrenPath { get; set; }
Public Property ChildrenPath As String
    Get
    Set

Property Value

Type: String
The children path.
Remarks
This is a path to a property on a value in ItemsSource that is an IEnumerable containing child data.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildrenPosition Property

PieSeriesChildrenPosition Property
Gets or sets the children position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSeriesChildPosition ChildrenPosition { get; set; }
Public Property ChildrenPosition As PieSeriesChildPosition
    Get
    Set

Property Value

Type: PieSeriesChildPosition
The children position.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceLabelFormat Property

PieSeriesChildSliceLabelFormat Property
Gets or sets the child slice label format.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ChildSliceLabelFormat { get; set; }
Public Property ChildSliceLabelFormat As String
    Get
    Set

Property Value

Type: String
The child slice label format.
Remarks
This property is ignored if ChildSliceLabelFunc is specified. The label format has three parameters: {0} is the percentage of the child pie slice. {1} is the original value of the child pie slice. {2} is the title of the child pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceLabelFunc Property

PieSeriesChildSliceLabelFunc Property
Gets or sets the child slice label func.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<double, Object, string, string> ChildSliceLabelFunc { get; set; }
Public Property ChildSliceLabelFunc As Func(Of Double, Object, String, String)
    Get
    Set

Property Value

Type: Func Double, Object, String, String
The child slice label func.
Remarks
This is a custom function that takes the pie slice percentage, original value, and title as parameters and returns the label of your choice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceTitlePath Property

PieSeriesChildSliceTitlePath Property
Gets or sets the child slice title path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ChildSliceTitlePath { get; set; }
Public Property ChildSliceTitlePath As String
    Get
    Set

Property Value

Type: String
The child slice title path.
Remarks
This is a path to a property on a value of child items that represents the title of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceValuePath Property

PieSeriesChildSliceValuePath Property
Gets or sets the child slice value path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ChildSliceValuePath { get; set; }
Public Property ChildSliceValuePath As String
    Get
    Set

Property Value

Type: String
The child slice value path.
Remarks
This is a path to a property on a value of child items that represents the value of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.IsOtherThresholdPercent Property

PieSeriesIsOtherThresholdPercent Property
Gets or sets a value indicating whether this instance is other threshold percent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOtherThresholdPercent { get; set; }
Public Property IsOtherThresholdPercent As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is other threshold percent; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.IsVisibleInLegend Property

PieSeriesIsVisibleInLegend Property
Gets or sets a value indicating whether this instance is visible in legend.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsVisibleInLegend { get; set; }
Public Property IsVisibleInLegend As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is visible in legend; otherwise, false.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ItemsSource Property

PieSeriesItemsSource Property
Gets or sets the items source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable ItemsSource { get; set; }
Public Property ItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The items source.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelBrush Property

PieSeriesLabelBrush Property
Gets or sets the brush used for labels.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LabelBrush { get; set; }
Public Property LabelBrush As Brush
    Get
    Set

Property Value

Type: Brush
The label brush.
Remarks
If LabelBrush is not set, then Foreground will be used instead.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelInsideFitMode Property

PieSeriesLabelInsideFitMode Property
Gets or sets the label inside fit mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSliceLabelInsideFitMode LabelInsideFitMode { get; set; }
Public Property LabelInsideFitMode As PieSliceLabelInsideFitMode
    Get
    Set

Property Value

Type: PieSliceLabelInsideFitMode
The label inside fit mode.
Remarks
This determines how the label reacts when it doesn't fit inside the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelPosition Property

PieSeriesLabelPosition Property
Gets or sets the label position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSliceLabelPosition LabelPosition { get; set; }
Public Property LabelPosition As PieSliceLabelPosition
    Get
    Set

Property Value

Type: PieSliceLabelPosition
The label position.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelStyle Property

PieSeriesLabelStyle Property
Gets or sets the style applied to pie slice labels. Style should have TargetType of TextBlock.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LabelStyle { get; set; }
Public Property LabelStyle As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.Length Property

PieSeriesLength Property
Gets or sets the size of pie series in relation to the other pie series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Length { get; set; }
Public Property Length As Double
    Get
    Set

Property Value

Type: Double
The length.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.OtherThreshold Property

PieSeriesOtherThreshold Property
Gets or sets the threshold for the "Other" slice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double OtherThreshold { get; set; }
Public Property OtherThreshold As Double
    Get
    Set

Property Value

Type: Double
The other threshold.
Remarks
If IsOtherThresholdPercent is true, then this value represents a percentage between 0.0 and 1.0. Otherwise, it represents a numerical value. All values beneath the other threshold will be aggregated into an "Other" pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceLabelFormat Property

PieSeriesSliceLabelFormat Property
Gets or sets the slice label format.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SliceLabelFormat { get; set; }
Public Property SliceLabelFormat As String
    Get
    Set

Property Value

Type: String
The slice label format.
Remarks
This property is ignored if SliceLabelFunc is specified. {0} is the percentage of the pie slice. {1} is the original value of the pie slice. {2} is the title of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceLabelFunc Property

PieSeriesSliceLabelFunc Property
Gets or sets the slice label func.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<double, Object, string, string> SliceLabelFunc { get; set; }
Public Property SliceLabelFunc As Func(Of Double, Object, String, String)
    Get
    Set

Property Value

Type: Func Double, Object, String, String
The slice label func.
Remarks
This is a custom function that takes the pie slice percentage, original value, and title as parameters and returns the label of your choice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceStyleSelector Property

PieSeriesSliceStyleSelector Property
Gets or sets the slice style selector, which determines the style used for each pie slice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPieSliceStyleSelector SliceStyleSelector { get; set; }
Public Property SliceStyleSelector As IPieSliceStyleSelector
    Get
    Set

Property Value

Type: IPieSliceStyleSelector
The slice style selector.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceTitlePath Property

PieSeriesSliceTitlePath Property
Gets or sets the slice title path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SliceTitlePath { get; set; }
Public Property SliceTitlePath As String
    Get
    Set

Property Value

Type: String
The slice title path.
Remarks
This is a path to a property on a value in ItemsSource that represents the value of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceValuePath Property

PieSeriesSliceValuePath Property
Gets or sets the slice value path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SliceValuePath { get; set; }
Public Property SliceValuePath As String
    Get
    Set

Property Value

Type: String
The slice value path.
Remarks
This is a path to a property on a value in ItemsSource that represents the value of the pie slice.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries Methods

PieSeries Methods

The PieSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Protected method | FireRefresh | Fires the Refresh event.
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.FireRefresh Method

PieSeriesFireRefresh Method
Fires the Refresh event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void FireRefresh()
Protected Sub FireRefresh
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries Events

PieSeries Events

The PieSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refresh | Occurs when a property on pie series is changed that requires the pie chart to be refreshed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.Refresh Event

PieSeriesRefresh Event
Occurs when a property on pie series is changed that requires the pie chart to be refreshed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Refresh
Public Event Refresh As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries Fields

PieSeries Fields

The PieSeries type exposes the following members.

Fields
Name | Description
AreChildLabelsVisibleProperty | Identifies the AreChildLabelsVisible dependency property. This field is read-only.
AreChildrenVisibleInLegendProperty | Identifies the AreChildrenVisibleInLegend dependency property. This field is read-only.
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
ChildLabelBrushProperty | Identifies the ChildLabelBrush dependency property. This field is read-only.
ChildLabelPositionProperty | Identifies the ChildLabelPosition dependency property. This field is read-only.
ChildLabelStyleProperty | Identifies the ChildLabelStyle dependency property. This field is read-only.
ChildLengthProperty | Identifies the ChildrenLength dependency property. This field is read-only.
ChildPositionProperty | Identifies the ChildrenPosition dependency property. This field is read-only.
ChildrenPathProperty | Identifies the ChildrenPath dependency property. This field is read-only.
ChildSliceLabelFormatProperty | Identifies the ChildSliceLabelFormat dependency property. This field is read-only.
ChildSliceLabelFuncProperty | Identifies the ChildSliceLabelFunc dependency property. This field is read-only.
ChildSliceTitlePathProperty | Identifies the ChildSliceTitlePath dependency property. This field is read-only.
ChildValuePathProperty | Identifies the ChildSliceValuePath dependency property. This field is read-only.
IsOtherThresholdPercentProperty | Identifies the IsOtherThresholdPercent dependency property. This field is read-only.
IsVisibleInLegendProperty | Identifies the IsVisibleInLegend dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
LabelBrushProperty | Identifies the LabelBrush dependency property. This field is read-only.
LabelInsideFitModeProperty | Identifies the LabelInsideFitMode dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
LengthProperty | Identifies the Length dependency property. This field is read-only.
OtherThresholdProperty | Identifies the OtherThreshold dependency property. This field is read-only.
SliceLabelFormatProperty | Identifies the SliceLabelFormat dependency property. This field is read-only.
SliceLabelFuncProperty | Identifies the SliceLabelFunc dependency property. This field is read-only.
SliceStyleSelectorProperty | Identifies the SliceStyleSelector dependency property. This field is read-only.
SliceTitlePathProperty | Identifies the SliceTitlePath dependency property. This field is read-only.
SliceValuePathProperty | Identifies the SliceValuePath dependency property. This field is read-only.
Top
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.AreChildLabelsVisibleProperty Field

PieSeriesAreChildLabelsVisibleProperty Field
Identifies the AreChildLabelsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreChildLabelsVisibleProperty
Public Shared ReadOnly AreChildLabelsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreChildLabelsVisible dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.AreChildrenVisibleInLegendProperty Field

PieSeriesAreChildrenVisibleInLegendProperty Field
Identifies the AreChildrenVisibleInLegend dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreChildrenVisibleInLegendProperty
Public Shared ReadOnly AreChildrenVisibleInLegendProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreChildrenVisibleInLegend dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.AreLabelsVisibleProperty Field

PieSeriesAreLabelsVisibleProperty Field
Identifies the AreLabelsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreLabelsVisibleProperty
Public Shared ReadOnly AreLabelsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreLabelsVisible dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLabelBrushProperty Field

PieSeriesChildLabelBrushProperty Field
Identifies the ChildLabelBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLabelBrushProperty
Public Shared ReadOnly ChildLabelBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildLabelBrush dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLabelPositionProperty Field

PieSeriesChildLabelPositionProperty Field
Identifies the ChildLabelPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLabelPositionProperty
Public Shared ReadOnly ChildLabelPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildLabelPosition dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLabelStyleProperty Field

PieSeriesChildLabelStyleProperty Field
Identifies the ChildLabelStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLabelStyleProperty
Public Shared ReadOnly ChildLabelStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildLabelStyle dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildLengthProperty Field

PieSeriesChildLengthProperty Field
Identifies the ChildrenLength dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildLengthProperty
Public Shared ReadOnly ChildLengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildrenLength dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildPositionProperty Field

PieSeriesChildPositionProperty Field
Identifies the ChildrenPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildPositionProperty
Public Shared ReadOnly ChildPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildrenPosition dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildrenPathProperty Field

PieSeriesChildrenPathProperty Field
Identifies the ChildrenPath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildrenPathProperty
Public Shared ReadOnly ChildrenPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildrenPath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceLabelFormatProperty Field

PieSeriesChildSliceLabelFormatProperty Field
Identifies the ChildSliceLabelFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceLabelFormatProperty
Public Shared ReadOnly ChildSliceLabelFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceLabelFormat dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceLabelFuncProperty Field

PieSeriesChildSliceLabelFuncProperty Field
Identifies the ChildSliceLabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceLabelFuncProperty
Public Shared ReadOnly ChildSliceLabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceLabelFunc dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildSliceTitlePathProperty Field

PieSeriesChildSliceTitlePathProperty Field
Identifies the ChildSliceTitlePath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildSliceTitlePathProperty
Public Shared ReadOnly ChildSliceTitlePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceTitlePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ChildValuePathProperty Field

PieSeriesChildValuePathProperty Field
Identifies the ChildSliceValuePath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildValuePathProperty
Public Shared ReadOnly ChildValuePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ChildSliceValuePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.IsOtherThresholdPercentProperty Field

PieSeriesIsOtherThresholdPercentProperty Field
Identifies the IsOtherThresholdPercent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOtherThresholdPercentProperty
Public Shared ReadOnly IsOtherThresholdPercentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOtherThresholdPercent dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.IsVisibleInLegendProperty Field

PieSeriesIsVisibleInLegendProperty Field
Identifies the IsVisibleInLegend dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsVisibleInLegendProperty
Public Shared ReadOnly IsVisibleInLegendProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsVisibleInLegend dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.ItemsSourceProperty Field

PieSeriesItemsSourceProperty Field
Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelBrushProperty Field

PieSeriesLabelBrushProperty Field
Identifies the LabelBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelBrushProperty
Public Shared ReadOnly LabelBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelBrush dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelInsideFitModeProperty Field

PieSeriesLabelInsideFitModeProperty Field
Identifies the LabelInsideFitMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelInsideFitModeProperty
Public Shared ReadOnly LabelInsideFitModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelInsideFitMode dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelPositionProperty Field

PieSeriesLabelPositionProperty Field
Identifies the LabelPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositionProperty
Public Shared ReadOnly LabelPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPosition dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LabelStyleProperty Field

PieSeriesLabelStyleProperty Field
Identifies the LabelStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelStyleProperty
Public Shared ReadOnly LabelStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelStyle dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.LengthProperty Field

PieSeriesLengthProperty Field
Identifies the Length dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LengthProperty
Public Shared ReadOnly LengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Length dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.OtherThresholdProperty Field

PieSeriesOtherThresholdProperty Field
Identifies the OtherThreshold dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OtherThresholdProperty
Public Shared ReadOnly OtherThresholdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OtherThreshold dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceLabelFormatProperty Field

PieSeriesSliceLabelFormatProperty Field
Identifies the SliceLabelFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceLabelFormatProperty
Public Shared ReadOnly SliceLabelFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceLabelFormat dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceLabelFuncProperty Field

PieSeriesSliceLabelFuncProperty Field
Identifies the SliceLabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceLabelFuncProperty
Public Shared ReadOnly SliceLabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceLabelFunc dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceStyleSelectorProperty Field

PieSeriesSliceStyleSelectorProperty Field
Identifies the SliceStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceStyleSelectorProperty
Public Shared ReadOnly SliceStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceStyleSelector dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceTitlePathProperty Field

PieSeriesSliceTitlePathProperty Field
Identifies the SliceTitlePath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceTitlePathProperty
Public Shared ReadOnly SliceTitlePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceTitlePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeries.SliceValuePathProperty Field

PieSeriesSliceValuePathProperty Field
Identifies the SliceValuePath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliceValuePathProperty
Public Shared ReadOnly SliceValuePathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliceValuePath dependency property.
See Also

Reference

PieSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeriesChildPosition Class

PieSeriesChildPosition Class
The position of the child pie series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsPieSeriesChildPosition

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PieSeriesChildPosition : Enum
Public NotInheritable Class PieSeriesChildPosition
    Inherits Enum

The PieSeriesChildPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Inside | The child pie series will be positioned on the inside of the parent pie series.
 | Outside | The child pie series will be positioned on the outside of the parent pie series.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeriesChildPosition Methods

PieSeriesChildPosition Methods

The PieSeriesChildPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PieSeriesChildPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeriesChildPosition Fields

PieSeriesChildPosition Fields

The PieSeriesChildPosition type exposes the following members.

Fields
 | Name | Description
 | Inside | The child pie series will be positioned on the inside of the parent pie series.
 | Outside | The child pie series will be positioned on the outside of the parent pie series.
Public field | value__ |
Top
See Also

Reference

PieSeriesChildPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeriesChildPosition.Inside Field

PieSeriesChildPositionInside Field
The child pie series will be positioned on the inside of the parent pie series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PieSeriesChildPosition Inside = 0
Public Const Inside As PieSeriesChildPosition = 0

Field Value

Type: PieSeriesChildPosition
See Also

Reference

PieSeriesChildPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeriesChildPosition.Outside Field

PieSeriesChildPositionOutside Field
The child pie series will be positioned on the outside of the parent pie series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PieSeriesChildPosition Outside = 1
Public Const Outside As PieSeriesChildPosition = 1

Field Value

Type: PieSeriesChildPosition
See Also

Reference

PieSeriesChildPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSeriesChildPosition.value__ Field

PieSeriesChildPositionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.PieSeriesChildPosition.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PieSeriesChildPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelInsideFitMode Class

PieSliceLabelInsideFitMode Class
Determines what happens if a label does not fit inside the pie slice.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsPieSliceLabelInsideFitMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PieSliceLabelInsideFitMode : Enum
Public NotInheritable Class PieSliceLabelInsideFitMode
    Inherits Enum

The PieSliceLabelInsideFitMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Hide | The label will be automatically hidden.
 | None | The label will overlap the bounds of the pie slice.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelInsideFitMode Methods

PieSliceLabelInsideFitMode Methods

The PieSliceLabelInsideFitMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PieSliceLabelInsideFitMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelInsideFitMode Fields

PieSliceLabelInsideFitMode Fields

The PieSliceLabelInsideFitMode type exposes the following members.

Fields
 | Name | Description
 | Hide | The label will be automatically hidden.
 | None | The label will overlap the bounds of the pie slice.
Public field | value__ |
Top
See Also

Reference

PieSliceLabelInsideFitMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelInsideFitMode.Hide Field

PieSliceLabelInsideFitModeHide Field
The label will be automatically hidden.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PieSliceLabelInsideFitMode Hide = 1
Public Const Hide As PieSliceLabelInsideFitMode = 1

Field Value

Type: PieSliceLabelInsideFitMode
See Also

Reference

PieSliceLabelInsideFitMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelInsideFitMode.None Field

PieSliceLabelInsideFitModeNone Field
The label will overlap the bounds of the pie slice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PieSliceLabelInsideFitMode None = 0
Public Const None As PieSliceLabelInsideFitMode = 0

Field Value

Type: PieSliceLabelInsideFitMode
See Also

Reference

PieSliceLabelInsideFitMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelInsideFitMode.value__ Field

PieSliceLabelInsideFitModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.PieSliceLabelInsideFitMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PieSliceLabelInsideFitMode Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelPosition Class

PieSliceLabelPosition Class
Determines where the pie slice labels are positioned.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsPieSliceLabelPosition

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PieSliceLabelPosition : Enum
Public NotInheritable Class PieSliceLabelPosition
    Inherits Enum

The PieSliceLabelPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Inside | Labels will be placed inside each pie slice.
 | Sides | Labels will be placed in a column on either side of the pie chart.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelPosition Methods

PieSliceLabelPosition Methods

The PieSliceLabelPosition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PieSliceLabelPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelPosition Fields

PieSliceLabelPosition Fields

The PieSliceLabelPosition type exposes the following members.

Fields
 | Name | Description
 | Inside | Labels will be placed inside each pie slice.
 | Sides | Labels will be placed in a column on either side of the pie chart.
Public field | value__ |
Top
See Also

Reference

PieSliceLabelPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelPosition.Inside Field

PieSliceLabelPositionInside Field
Labels will be placed inside each pie slice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PieSliceLabelPosition Inside = 0
Public Const Inside As PieSliceLabelPosition = 0

Field Value

Type: PieSliceLabelPosition
See Also

Reference

PieSliceLabelPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelPosition.Sides Field

PieSliceLabelPositionSides Field
Labels will be placed in a column on either side of the pie chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PieSliceLabelPosition Sides = 1
Public Const Sides As PieSliceLabelPosition = 1

Field Value

Type: PieSliceLabelPosition
See Also

Reference

PieSliceLabelPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceLabelPosition.value__ Field

PieSliceLabelPositionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.PieSliceLabelPosition.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PieSliceLabelPosition Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceStyleSelector Class

PieSliceStyleSelector Class
A base class that selects a style for a given PieSlice.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.ChartsPieSliceStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PieSliceStyleSelector : IPieSliceStyleSelector
Public Class PieSliceStyleSelector
    Implements IPieSliceStyleSelector

The PieSliceStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PieSliceStyleSelector | Initializes a new instance of the PieSliceStyleSelector class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceStyleSelector Constructor

PieSliceStyleSelector Constructor
Initializes a new instance of the PieSliceStyleSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSliceStyleSelector()
Public Sub New
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceStyleSelector Methods

PieSliceStyleSelector Methods

The PieSliceStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceStyleSelector.SelectChildPieSliceStyle Method

PieSliceStyleSelectorSelectChildPieSliceStyle Method
Selects the child pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectChildPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Color parentFill,
    Style defaultStyle
)
Public Overridable Function SelectChildPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    parentFill As Color,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
parentFill
Type: Windows.UIColor
The parent fill color.
defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: Style
A Style for a PieSlice.

Implements

IPieSliceStyleSelectorSelectChildPieSliceStyle(Int32, Int32, Color, Style)
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


PieSliceStyleSelector.SelectPieSliceStyle Method

PieSliceStyleSelectorSelectPieSliceStyle Method
Selects the pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Style defaultStyle
)
Public Overridable Function SelectPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: Style
A Style for a PieSlice.

Implements

IPieSliceStyleSelectorSelectPieSliceStyle(Int32, Int32, Style)
See Also

Reference

PieSliceStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ScatterSeries Class

ScatterSeries Class
Represents a scatter series for use in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsScatterSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ScatterSeries : XYSeriesBase
Public Class ScatterSeries
    Inherits XYSeriesBase

The ScatterSeries type exposes the following members.

Constructors
 | Name | Description
Public method | ScatterSeries | Initializes a new instance of the ScatterSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ScatterSeries Constructor

ScatterSeries Constructor
Initializes a new instance of the ScatterSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScatterSeries()
Public Sub New
See Also

Reference

ScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ScatterSeries Properties

ScatterSeries Properties

The ScatterSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

ScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ScatterSeries.MinimumMargin Property

ScatterSeriesMinimumMargin Property
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> MinimumMargin { get; }
Protected Overrides ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

ScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ScatterSeries Methods

ScatterSeries Methods

The ScatterSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ScatterSeries Events

ScatterSeries Events

The ScatterSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector Class

SeriesStyleSelector Class
Provides a way to apply series styles based on custom logic.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.ChartsSeriesStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SeriesStyleSelector : ISeriesStyleSelector
Public Class SeriesStyleSelector
    Implements ISeriesStyleSelector

The SeriesStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesStyleSelector | Initializes a new instance of the SeriesStyleSelector class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector Constructor

SeriesStyleSelector Constructor
Initializes a new instance of the SeriesStyleSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesStyleSelector()
Public Sub New
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector Methods

SeriesStyleSelector Methods

The SeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the bar Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector.SelectAreaStyle Method

SeriesStyleSelectorSelectAreaStyle Method
Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectAreaStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector.SelectBarStyle Method

SeriesStyleSelectorSelectBarStyle Method
Returns the bar Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectBarStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectBarStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectBarStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector.SelectLegendMarkerStyle Method

SeriesStyleSelectorSelectLegendMarkerStyle Method
Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectLegendMarkerStyle(
    XYSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLegendMarkerStyle (
    series As XYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLegendMarkerStyle(XYSeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector.SelectLineStyle Method

SeriesStyleSelectorSelectLineStyle Method
Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectLineStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLineStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


SeriesStyleSelector.SelectMarkerStyle Method

SeriesStyleSelectorSelectMarkerStyle Method
Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectMarkerStyle(SeriesBase, Style)
See Also

Reference

SeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter Class

TimeSpanConverter Class
Converts TimeSpan to and from a String.
Inheritance Hierarchy
SystemObject
TypeConverter
ActiproSoftware.UI.Xaml.Controls.ChartsTimeSpanConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimeSpanConverter : TypeConverter
Public Class TimeSpanConverter
    Inherits TypeConverter

The TimeSpanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanConverter | Initializes a new instance of the TimeSpanConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | Returns whether the type converter can convert an object to the specified type. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | Converts the specified value object to the specified type. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter Constructor

TimeSpanConverter Constructor
Initializes a new instance of the TimeSpanConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpanConverter()
Public Sub New
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter Methods

TimeSpanConverter Methods

The TimeSpanConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom | Returns whether the type converter can convert an object from the specified type to the type of this converter. (Overrides TypeConverter.CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | Returns whether the type converter can convert an object to the specified type. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | Converts from the specified value to the intended conversion type of the converter. (Overrides TypeConverter.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | Converts the specified value object to the specified type. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter.CanConvertFrom Method

TimeSpanConverterCanConvertFrom Method
Returns whether the type converter can convert an object from the specified type to the type of this converter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: ITypeDescriptorContext
An object that provides a format context.
sourceType
Type: SystemType
The type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter.CanConvertTo Method

TimeSpanConverterCanConvertTo Method
Returns whether the type converter can convert an object to the specified type.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: ITypeDescriptorContext
An object that provides a format context.
destinationType
Type: SystemType
The type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter.ConvertFrom Method

TimeSpanConverterConvertFrom Method
Converts from the specified value to the intended conversion type of the converter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: ITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The value to convert to the type of this converter.

Return Value

Type: Object
The converted value.
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeSpanConverter.ConvertTo Method

TimeSpanConverterConvertTo Method
Converts the specified value object to the specified type.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: ITypeDescriptorContext
An object that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The object to convert.
destinationType
Type: SystemType
The type to convert the object to.

Return Value

Type: Object
The converted object.
See Also

Reference

TimeSpanConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit Class

TimeUnit Class
Specifies a unit of time.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsTimeUnit

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TimeUnit : Enum
Public NotInheritable Class TimeUnit
    Inherits Enum

The TimeUnit type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Day | Indicates a day time unit.
 | Hour | Indicates a hour time unit.
 | Millisecond | Indicates a millisecond time unit.
 | Minute | Indicates a minute time unit.
 | Month | Indicates a month time unit.
 | Second | Indicates a second time unit.
Public field | value__ |
 | Week | Indicates a week time unit.
 | Year | Indicates a year time unit.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit Methods

TimeUnit Methods

The TimeUnit type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit Fields

TimeUnit Fields

The TimeUnit type exposes the following members.

Fields
 | Name | Description
 | Day | Indicates a day time unit.
 | Hour | Indicates a hour time unit.
 | Millisecond | Indicates a millisecond time unit.
 | Minute | Indicates a minute time unit.
 | Month | Indicates a month time unit.
 | Second | Indicates a second time unit.
Public field | value__ |
 | Week | Indicates a week time unit.
 | Year | Indicates a year time unit.
Top
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Day Field

TimeUnitDay Field
Indicates a day time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Day = 4
Public Const Day As TimeUnit = 4

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Hour Field

TimeUnitHour Field
Indicates a hour time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Hour = 3
Public Const Hour As TimeUnit = 3

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Millisecond Field

TimeUnitMillisecond Field
Indicates a millisecond time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Millisecond = 0
Public Const Millisecond As TimeUnit = 0

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Minute Field

TimeUnitMinute Field
Indicates a minute time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Minute = 2
Public Const Minute As TimeUnit = 2

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Month Field

TimeUnitMonth Field
Indicates a month time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Month = 5
Public Const Month As TimeUnit = 5

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Second Field

TimeUnitSecond Field
Indicates a second time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Second = 1
Public Const Second As TimeUnit = 1

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.value__ Field

TimeUnitvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.TimeUnit.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Week Field

TimeUnitWeek Field
Indicates a week time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Week = 6
Public Const Week As TimeUnit = 6

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


TimeUnit.Year Field

TimeUnitYear Field
Indicates a year time unit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TimeUnit Year = 7
Public Const Year As TimeUnit = 7

Field Value

Type: TimeUnit
See Also

Reference

TimeUnit Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYAxisCollection Class

XYAxisCollection Class
Represents a collection of XYAxisBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XYAxisBase
System.Collections.ObjectModelObservableCollection XYAxisBase
ActiproSoftware.UI.XamlDeferrableObservableCollection XYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsDeferrableObservableItemCollection XYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYAxisCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYAxisCollection : DeferrableObservableItemCollection<XYAxisBase>
Public Class XYAxisCollection
    Inherits DeferrableObservableItemCollection(Of XYAxisBase)

The XYAxisCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XYAxisCollection | Initializes a new instance of the XYAxisCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XYAxisBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XYAxisBase .)
Protected property | Items | (Inherited from Collection XYAxisBase .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XYAxisBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XYAxisBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XYAxisBase .)
Public method | Clear | (Inherited from Collection XYAxisBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | (Inherited from Collection XYAxisBase .)
Public method | CopyTo | (Inherited from Collection XYAxisBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XYAxisBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XYAxisBase .)
Public method | Insert | (Inherited from Collection XYAxisBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XYAxisBase .)
Protected method | MoveItem | (Inherited from ObservableCollection XYAxisBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XYAxisBase .)
Public method | RemoveAt | (Inherited from Collection XYAxisBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XYAxisBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XYAxisBase .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYAxisCollection Constructor

XYAxisCollection Constructor
Initializes a new instance of the XYAxisCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYAxisCollection()
Public Sub New
See Also

Reference

XYAxisCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYAxisCollection Properties

XYAxisCollection Properties

The XYAxisCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XYAxisBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XYAxisBase .)
Protected property | Items | (Inherited from Collection XYAxisBase .)
Top
See Also

Reference

XYAxisCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYAxisCollection Methods

XYAxisCollection Methods

The XYAxisCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XYAxisBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XYAxisBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XYAxisBase .)
Public method | Clear | (Inherited from Collection XYAxisBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | (Inherited from Collection XYAxisBase .)
Public method | CopyTo | (Inherited from Collection XYAxisBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XYAxisBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XYAxisBase .)
Public method | Insert | (Inherited from Collection XYAxisBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XYAxisBase .)
Protected method | MoveItem | (Inherited from ObservableCollection XYAxisBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XYAxisBase .)
Public method | RemoveAt | (Inherited from Collection XYAxisBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XYAxisCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYAxisCollection Events

XYAxisCollection Events

The XYAxisCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XYAxisBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XYAxisBase .)
Top
See Also

Reference

XYAxisCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart Class

XYChart Class
Represents a chart control that uses an X/Y coordinate system.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsXYChart

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYChart : Control
Public Class XYChart
    Inherits Control

The XYChart type exposes the following members.

Constructors
 | Name | Description
Public method | XYChart | Initializes a new instance of the XYChart class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineMajorBrush | Gets or sets the grid line major brush.
Public property | GridLineMajorVisibility | Gets or sets the grid line major visibility.
Public property | GridLineMinorBrush | Gets or sets the grid line minor brush.
Public property | GridLineMinorVisibility | Gets or sets the grid line minor visibility.
Public property | GridStripeAlternatingBrush | Gets or sets the grid stripe alternating brush.
Public property | GridStripeBrush | Gets or sets the grid stripe brush.
Public property | GridStripeVisibility | Gets or sets the grid stripe visibility.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsLegendVisible | Gets or sets a value indicating whether the legend is visible. This is a dependency property.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the horizontal position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | LegendKeys | Gets the collection of legend keys displayed in the legend.
Public property | LegendStyle | Gets or sets the Style applied to the legend. The Style must have a TargetType of ItemsControl.
Public property | LegendVerticalPosition | Gets or sets the vertical position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PaddingPercentage | The percentage of the chart size used for padding. Valid values are 0.0d (0%) to 1.0d (100%).
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxes | Gets the collection of X axes displayed by this chart.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxes | Gets the collection of Y axes displayed by this chart.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the UI Automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the mouse pointer exits the control. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Called before the mouse pointer is moved. (Overrides ControlOnPointerMoved(PointerRoutedEventArgs).)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
GridLineMajorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMajorVisibilityProperty | Identifies the GridLineMajorVisibility dependency property. This field is read-only.
GridLineMinorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMinorVisibilityProperty | Identifies the GridLineMinorVisibility dependency property. This field is read-only.
GridStripeAlternatingBrushProperty | Identifies the GridStripeAlternatingBrush dependency property. This field is read-only.
GridStripeBrushProperty | Identifies the GridStripeBrush dependency property. This field is read-only.
GridStripeVisibilityProperty | Identifies the GridStripeVisibility dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
PaddingPercentageProperty | Identifies the PaddingPercentage dependency property. This field is read-only.
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart Constructor

XYChart Constructor
Initializes a new instance of the XYChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYChart()
Public Sub New
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart Properties

XYChart Properties

The XYChart type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineMajorBrush | Gets or sets the grid line major brush.
Public property | GridLineMajorVisibility | Gets or sets the grid line major visibility.
Public property | GridLineMinorBrush | Gets or sets the grid line minor brush.
Public property | GridLineMinorVisibility | Gets or sets the grid line minor visibility.
Public property | GridStripeAlternatingBrush | Gets or sets the grid stripe alternating brush.
Public property | GridStripeBrush | Gets or sets the grid stripe brush.
Public property | GridStripeVisibility | Gets or sets the grid stripe visibility.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsLegendVisible | Gets or sets a value indicating whether the legend is visible. This is a dependency property.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the horizontal position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | LegendKeys | Gets the collection of legend keys displayed in the legend.
Public property | LegendStyle | Gets or sets the Style applied to the legend. The Style must have a TargetType of ItemsControl.
Public property | LegendVerticalPosition | Gets or sets the vertical position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | PaddingPercentage | The percentage of the chart size used for padding. Valid values are 0.0d (0%) to 1.0d (100%).
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxes | Gets the collection of X axes displayed by this chart.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxes | Gets the collection of Y axes displayed by this chart.
Top
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.AxisBaselineStyle Property

XYChartAxisBaselineStyle Property
Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style AxisBaselineStyle { get; set; }
Public Property AxisBaselineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the baseline along the chart. The default value is .
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMajorBrush Property

XYChartGridLineMajorBrush Property
Gets or sets the grid line major brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush GridLineMajorBrush { get; set; }
Public Property GridLineMajorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid line major brush.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMajorVisibility Property

XYChartGridLineMajorVisibility Property
Gets or sets the grid line major visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridLineVisibility GridLineMajorVisibility { get; set; }
Public Property GridLineMajorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The grid line major visibility.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMinorBrush Property

XYChartGridLineMinorBrush Property
Gets or sets the grid line minor brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush GridLineMinorBrush { get; set; }
Public Property GridLineMinorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid line minor brush.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMinorVisibility Property

XYChartGridLineMinorVisibility Property
Gets or sets the grid line minor visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridLineVisibility GridLineMinorVisibility { get; set; }
Public Property GridLineMinorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The grid line minor visibility.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridStripeAlternatingBrush Property

XYChartGridStripeAlternatingBrush Property
Gets or sets the grid stripe alternating brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush GridStripeAlternatingBrush { get; set; }
Public Property GridStripeAlternatingBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid stripe alternating brush.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridStripeBrush Property

XYChartGridStripeBrush Property
Gets or sets the grid stripe brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush GridStripeBrush { get; set; }
Public Property GridStripeBrush As Brush
    Get
    Set

Property Value

Type: Brush
The grid stripe brush.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridStripeVisibility Property

XYChartGridStripeVisibility Property
Gets or sets the grid stripe visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridStripeVisibility GridStripeVisibility { get; set; }
Public Property GridStripeVisibility As GridStripeVisibility
    Get
    Set

Property Value

Type: GridStripeVisibility
The grid stripe visibility.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.IsAxisBaselineVisible Property

XYChartIsAxisBaselineVisible Property
Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAxisBaselineVisible { get; set; }
Public Property IsAxisBaselineVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a line is rendered at the baseline value; otherwise, false. The default value is false.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.IsLegendVisible Property

XYChartIsLegendVisible Property
Gets or sets a value indicating whether the legend is visible. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLegendVisible { get; set; }
Public Property IsLegendVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the legend is visible; otherwise, false. The default value is false.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LabelCollisionMode Property

XYChartLabelCollisionMode Property
Gets or sets the label collision mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelCollisionMode LabelCollisionMode { get; set; }
Public Property LabelCollisionMode As LabelCollisionMode
    Get
    Set

Property Value

Type: LabelCollisionMode
The label collision mode.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendHorizontalPosition Property

XYChartLegendHorizontalPosition Property
Gets or sets the horizontal position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendHorizontalPosition LegendHorizontalPosition { get; set; }
Public Property LegendHorizontalPosition As LegendHorizontalPosition
    Get
    Set

Property Value

Type: LegendHorizontalPosition
The horizontal position of the legend.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendKeys Property

XYChartLegendKeys Property
Gets the collection of legend keys displayed in the legend.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<LegendKey> LegendKeys { get; }
Public ReadOnly Property LegendKeys As ObservableCollection(Of LegendKey)
    Get

Property Value

Type: ObservableCollection LegendKey
The collection of legend keys.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendStyle Property

XYChartLegendStyle Property
Gets or sets the Style applied to the legend. The Style must have a TargetType of ItemsControl.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LegendStyle { get; set; }
Public Property LegendStyle As Style
    Get
    Set

Property Value

Type: Style
The style to apply to the legend.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendVerticalPosition Property

XYChartLegendVerticalPosition Property
Gets or sets the vertical position of the legend. Inside positions will place the legend inside the chart itself. Outside positions will place the legend relative to the entire control, including axes and titles.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendVerticalPosition LegendVerticalPosition { get; set; }
Public Property LegendVerticalPosition As LegendVerticalPosition
    Get
    Set

Property Value

Type: LegendVerticalPosition
The vertical position of the legend.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.PaddingPercentage Property

XYChartPaddingPercentage Property
The percentage of the chart size used for padding. Valid values are 0.0d (0%) to 1.0d (100%).

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness PaddingPercentage { get; set; }
Public Property PaddingPercentage As Thickness
    Get
    Set

Property Value

Type: Thickness
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.Series Property

XYChartSeries Property
Gets the collection of series displayed by this chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYSeriesCollection Series { get; }
Public ReadOnly Property Series As XYSeriesCollection
    Get

Property Value

Type: XYSeriesCollection
The collection of series displayed by this chart.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.SeriesStyleSelector Property

XYChartSeriesStyleSelector Property
Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISeriesStyleSelector SeriesStyleSelector { get; set; }
Public Property SeriesStyleSelector As ISeriesStyleSelector
    Get
    Set

Property Value

Type: ISeriesStyleSelector
A SeriesStyleSelector object that contains logic that chooses the style to use for each element in the associated series. The default value is .
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.XAxes Property

XYChartXAxes Property
Gets the collection of X axes displayed by this chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYAxisCollection XAxes { get; }
Public ReadOnly Property XAxes As XYAxisCollection
    Get

Property Value

Type: XYAxisCollection
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.YAxes Property

XYChartYAxes Property
Gets the collection of Y axes displayed by this chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYAxisCollection YAxes { get; }
Public ReadOnly Property YAxes As XYAxisCollection
    Get

Property Value

Type: XYAxisCollection
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart Methods

XYChart Methods

The XYChart type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the UI Automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the mouse pointer exits the control. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Called before the mouse pointer is moved. (Overrides ControlOnPointerMoved(PointerRoutedEventArgs).)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.ArrangeOverride Method

XYChartArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior.
Top
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.ArrangeOverride Method (Size)

XYChartArrangeOverride Method (Size)
Provides the behavior for the Arrange pass of Silverlight layout. Classes can override this method to define their own Arrange pass behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this object should use to arrange itself and its children.

Return Value

Type: Size
The actual size that is used after the element is arranged in layout.
See Also

Reference

XYChart Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.MeasureOverride Method

XYChartMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Top
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.MeasureOverride Method (Size)

XYChartMeasureOverride Method (Size)
Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

XYChart Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.OnApplyTemplate Method

XYChartOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.OnCreateAutomationPeer Method

XYChartOnCreateAutomationPeer Method
When implemented in a derived class, returns class-specific AutomationPeer implementations for the UI Automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.OnPointerExited Method

XYChartOnPointerExited Method
Called before the mouse pointer exits the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerExited(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerExited (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.OnPointerMoved Method

XYChartOnPointerMoved Method
Called before the mouse pointer is moved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerMoved(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerMoved (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.Refresh Method

XYChartRefresh Method
Updates the chart based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart Events

XYChart Events

The XYChart type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart Fields

XYChart Fields

The XYChart type exposes the following members.

Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
GridLineMajorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMajorVisibilityProperty | Identifies the GridLineMajorVisibility dependency property. This field is read-only.
GridLineMinorBrushProperty | Identifies the GridLineMinorBrush dependency property. This field is read-only.
GridLineMinorVisibilityProperty | Identifies the GridLineMinorVisibility dependency property. This field is read-only.
GridStripeAlternatingBrushProperty | Identifies the GridStripeAlternatingBrush dependency property. This field is read-only.
GridStripeBrushProperty | Identifies the GridStripeBrush dependency property. This field is read-only.
GridStripeVisibilityProperty | Identifies the GridStripeVisibility dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendStyleProperty | Identifies the LegendStyle dependency property. This field is read-only.
LegendVerticalPositionProperty | Identifies the LegendVerticalPosition dependency property. This field is read-only.
PaddingPercentageProperty | Identifies the PaddingPercentage dependency property. This field is read-only.
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.AxisBaselineStyleProperty Field

XYChartAxisBaselineStyleProperty Field
Identifies the AxisBaselineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AxisBaselineStyleProperty
Public Shared ReadOnly AxisBaselineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AxisBaselineStyle dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMajorBrushProperty Field

XYChartGridLineMajorBrushProperty Field
Identifies the GridLineMinorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMajorBrushProperty
Public Shared ReadOnly GridLineMajorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMinorBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMajorVisibilityProperty Field

XYChartGridLineMajorVisibilityProperty Field
Identifies the GridLineMajorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMajorVisibilityProperty
Public Shared ReadOnly GridLineMajorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMajorVisibility dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMinorBrushProperty Field

XYChartGridLineMinorBrushProperty Field
Identifies the GridLineMinorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMinorBrushProperty
Public Shared ReadOnly GridLineMinorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMinorBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridLineMinorVisibilityProperty Field

XYChartGridLineMinorVisibilityProperty Field
Identifies the GridLineMinorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineMinorVisibilityProperty
Public Shared ReadOnly GridLineMinorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineMinorVisibility dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridStripeAlternatingBrushProperty Field

XYChartGridStripeAlternatingBrushProperty Field
Identifies the GridStripeAlternatingBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridStripeAlternatingBrushProperty
Public Shared ReadOnly GridStripeAlternatingBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridStripeAlternatingBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridStripeBrushProperty Field

XYChartGridStripeBrushProperty Field
Identifies the GridStripeBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridStripeBrushProperty
Public Shared ReadOnly GridStripeBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridStripeBrush dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.GridStripeVisibilityProperty Field

XYChartGridStripeVisibilityProperty Field
Identifies the GridStripeVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridStripeVisibilityProperty
Public Shared ReadOnly GridStripeVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridStripeVisibility dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.IsAxisBaselineVisibleProperty Field

XYChartIsAxisBaselineVisibleProperty Field
Identifies the IsAxisBaselineVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAxisBaselineVisibleProperty
Public Shared ReadOnly IsAxisBaselineVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAxisBaselineVisible dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.IsLegendVisibleProperty Field

XYChartIsLegendVisibleProperty Field
Identifies the IsLegendVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLegendVisibleProperty
Public Shared ReadOnly IsLegendVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LabelCollisionModeProperty Field

XYChartLabelCollisionModeProperty Field
Identifies the LabelCollisionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelCollisionModeProperty
Public Shared ReadOnly LabelCollisionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelCollisionMode dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendHorizontalPositionProperty Field

XYChartLegendHorizontalPositionProperty Field
Identifies the LegendHorizontalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendHorizontalPositionProperty
Public Shared ReadOnly LegendHorizontalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendHorizontalPosition dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendStyleProperty Field

XYChartLegendStyleProperty Field
Identifies the LegendStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStyleProperty
Public Shared ReadOnly LegendStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStyle dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.LegendVerticalPositionProperty Field

XYChartLegendVerticalPositionProperty Field
Identifies the LegendVerticalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendVerticalPositionProperty
Public Shared ReadOnly LegendVerticalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendVerticalPosition dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.PaddingPercentageProperty Field

XYChartPaddingPercentageProperty Field
Identifies the PaddingPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingPercentageProperty
Public Shared ReadOnly PaddingPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PaddingPercentage dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYChart.SeriesStyleSelectorProperty Field

XYChartSeriesStyleSelectorProperty Field
Identifies the SeriesStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SeriesStyleSelectorProperty
Public Shared ReadOnly SeriesStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SeriesStyleSelector dependency property.
See Also

Reference

XYChart Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint Class

XYDataPoint Class
Represents a data point presented by a a XYSeriesBase series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesDataPointBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDataPoint

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYDataPoint : DataPointBase
Public Class XYDataPoint
    Inherits DataPointBase

The XYDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | XYDataPoint | Initializes a new instance of the XYDataPoint class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from DataPointBase.)
Public property | OriginalValue | Gets the original value.
Public property | StackedDataPoint | Gets the XYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint Constructor

XYDataPoint Constructor
Initializes a new instance of the XYDataPoint class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYDataPoint()
Public Sub New
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint Properties

XYDataPoint Properties

The XYDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from DataPointBase.)
Public property | OriginalValue | Gets the original value.
Public property | StackedDataPoint | Gets the XYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint.OriginalValue Property

XYDataPointOriginalValue Property
Gets the original value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object OriginalValue { get; }
Public ReadOnly Property OriginalValue As Object
    Get

Property Value

Type: Object
The original value.
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint.StackedDataPoint Property

XYDataPointStackedDataPoint Property
Gets the XYDataPoint that this data point is stacked on top of.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYDataPoint StackedDataPoint { get; }
Public ReadOnly Property StackedDataPoint As XYDataPoint
    Get

Property Value

Type: XYDataPoint
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint.XValue Property

XYDataPointXValue Property
Gets the X-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object XValue { get; }
Public ReadOnly Property XValue As Object
    Get

Property Value

Type: Object
The X-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint.XValueResolved Property

XYDataPointXValueResolved Property
Gets the resolved X-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object XValueResolved { get; }
Public ReadOnly Property XValueResolved As Object
    Get

Property Value

Type: Object
The resolved X-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint.YValue Property

XYDataPointYValue Property
Gets the Y-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object YValue { get; }
Public ReadOnly Property YValue As Object
    Get

Property Value

Type: Object
The Y-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint.YValueResolved Property

XYDataPointYValueResolved Property
Gets the resolved Y-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object YValueResolved { get; }
Public ReadOnly Property YValueResolved As Object
    Get

Property Value

Type: Object
The resolved Y-value of the data point.
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint Methods

XYDataPoint Methods

The XYDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDataPoint Events

XYDataPoint Events

The XYDataPoint type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

XYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis Class

XYDateTimeAxis Class
Represents an axis for data in DateTime format.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDateTimeAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYDateTimeAxis : XYAxisBase
Public Class XYDateTimeAxis
    Inherits XYAxisBase

The XYDateTimeAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYDateTimeAxis | Creates a new XYDateTimeAxis.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | SlotIntervalUnit | The time unit that the SlotInterval represents for data points of the axis when using slotted layout.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorIntervalUnit | The unit of time that TickMajorInterval represents.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorIntervalUnit | The unit of time that TickMinorInterval represents.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
SlotIntervalUnitProperty | Identifies the SlotIntervalUnit dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMajorIntervalUnitProperty | Identifies the TickMajorIntervalUnit dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
TickMinorIntervalUnitProperty | Identifies the TickMinorIntervalUnit dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis Constructor

XYDateTimeAxis Constructor
Creates a new XYDateTimeAxis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYDateTimeAxis()
Public Sub New
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis Properties

XYDateTimeAxis Properties

The XYDateTimeAxis type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | SlotIntervalUnit | The time unit that the SlotInterval represents for data points of the axis when using slotted layout.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorIntervalUnit | The unit of time that TickMajorInterval represents.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorIntervalUnit | The unit of time that TickMinorInterval represents.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.Baseline Property

XYDateTimeAxisBaseline Property
The baseline value for the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Baseline { get; set; }
Public Property Baseline As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.LabelFunc Property

XYDateTimeAxisLabelFunc Property
Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<DateTime, DateTime, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of DateTime, DateTime, String)
    Get
    Set

Property Value

Type: Func DateTime, DateTime, String
The function used to determine axis labels.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.Maximum Property

XYDateTimeAxisMaximum Property
The maximum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.Minimum Property

XYDateTimeAxisMinimum Property
The minimum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.SlotInterval Property

XYDateTimeAxisSlotInterval Property
The slot interval for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SlotInterval { get; set; }
Public Property SlotInterval As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace
XYDateTimeAxisSlotIntervalUnit


XYDateTimeAxis.SlotIntervalUnit Property

XYDateTimeAxisSlotIntervalUnit Property
The time unit that the SlotInterval represents for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeUnit SlotIntervalUnit { get; set; }
Public Property SlotIntervalUnit As TimeUnit
    Get
    Set

Property Value

Type: TimeUnit
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace
XYDateTimeAxisSlotInterval


XYDateTimeAxis.TickMajorInterval Property

XYDateTimeAxisTickMajorInterval Property
The interval at which to display major ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TickMajorInterval { get; set; }
Public Property TickMajorInterval As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace
XYDateTimeAxisTickMajorIntervalUnit


XYDateTimeAxis.TickMajorIntervalUnit Property

XYDateTimeAxisTickMajorIntervalUnit Property
The unit of time that TickMajorInterval represents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeUnit TickMajorIntervalUnit { get; set; }
Public Property TickMajorIntervalUnit As TimeUnit
    Get
    Set

Property Value

Type: TimeUnit
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace
XYDateTimeAxisTickMajorInterval


XYDateTimeAxis.TickMinorInterval Property

XYDateTimeAxisTickMinorInterval Property
The interval at which to display minor ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int TickMinorInterval { get; set; }
Public Property TickMinorInterval As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace
XYDateTimeAxisTickMinorIntervalUnit


XYDateTimeAxis.TickMinorIntervalUnit Property

XYDateTimeAxisTickMinorIntervalUnit Property
The unit of time that TickMinorInterval represents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeUnit TickMinorIntervalUnit { get; set; }
Public Property TickMinorIntervalUnit As TimeUnit
    Get
    Set

Property Value

Type: TimeUnit
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace
XYDateTimeAxisTickMinorInterval


XYDateTimeAxis Methods

XYDateTimeAxis Methods

The XYDateTimeAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis Events

XYDateTimeAxis Events

The XYDateTimeAxis type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis Fields

XYDateTimeAxis Fields

The XYDateTimeAxis type exposes the following members.

Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
SlotIntervalUnitProperty | Identifies the SlotIntervalUnit dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMajorIntervalUnitProperty | Identifies the TickMajorIntervalUnit dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
TickMinorIntervalUnitProperty | Identifies the TickMinorIntervalUnit dependency property. This field is read-only.
Top
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.BaselineProperty Field

XYDateTimeAxisBaselineProperty Field
Identifies the Baseline dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaselineProperty
Public Shared ReadOnly BaselineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Baseline dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.LabelFuncProperty Field

XYDateTimeAxisLabelFuncProperty Field
Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.MaximumProperty Field

XYDateTimeAxisMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.MinimumProperty Field

XYDateTimeAxisMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.SlotIntervalProperty Field

XYDateTimeAxisSlotIntervalProperty Field
Identifies the SlotInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalProperty
Public Shared ReadOnly SlotIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotInterval dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.SlotIntervalUnitProperty Field

XYDateTimeAxisSlotIntervalUnitProperty Field
Identifies the SlotIntervalUnit dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalUnitProperty
Public Shared ReadOnly SlotIntervalUnitProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotIntervalUnit dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.TickMajorIntervalProperty Field

XYDateTimeAxisTickMajorIntervalProperty Field
Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.TickMajorIntervalUnitProperty Field

XYDateTimeAxisTickMajorIntervalUnitProperty Field
Identifies the TickMajorIntervalUnit dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalUnitProperty
Public Shared ReadOnly TickMajorIntervalUnitProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorIntervalUnit dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.TickMinorIntervalProperty Field

XYDateTimeAxisTickMinorIntervalProperty Field
Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDateTimeAxis.TickMinorIntervalUnitProperty Field

XYDateTimeAxisTickMinorIntervalUnitProperty Field
Identifies the TickMinorIntervalUnit dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalUnitProperty
Public Shared ReadOnly TickMinorIntervalUnitProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorIntervalUnit dependency property.
See Also

Reference

XYDateTimeAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxis Class

XYDecimalAxis Class
Represents an axis for data in Decimal format.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDecimalAxisBase Object
ActiproSoftware.UI.Xaml.Controls.ChartsXYDecimalAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYDecimalAxis : XYDecimalAxisBase<Object>
Public Class XYDecimalAxis
    Inherits XYDecimalAxisBase(Of Object)

The XYDecimalAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYDecimalAxis | Initializes a new instance of the XYDecimalAxis class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout. (Inherited from XYDecimalAxisBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxis Constructor

XYDecimalAxis Constructor
Initializes a new instance of the XYDecimalAxis class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYDecimalAxis()
Public Sub New
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxis Properties

XYDecimalAxis Properties

The XYDecimalAxis type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis. (Inherited from XYDecimalAxisBaseT.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout. (Inherited from XYDecimalAxisBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks. (Inherited from XYDecimalAxisBaseT.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxis Methods

XYDecimalAxis Methods

The XYDecimalAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxis Events

XYDecimalAxis Events

The XYDecimalAxis type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYDecimalAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T) Class

XYDecimalAxisBaseT Class
Represents an axis for data in Decimal format.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDecimalAxisBaseT
ActiproSoftware.UI.Xaml.Controls.ChartsXYDecimalAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYDecimalAxisBase<T> : XYAxisBase

Public Class XYDecimalAxisBase(Of T)
    Inherits XYAxisBase

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Charts.XYDecimalAxisBase`1"]

The XYDecimalAxisBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | XYDecimalAxisBaseT | Creates a new XYDecimalAxis.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T) Constructor

XYDecimalAxisBaseT Constructor
Creates a new XYDecimalAxis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYDecimalAxisBase()
Public Sub New
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T) Properties

XYDecimalAxisBaseT Properties

The XYDecimalAxisBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).Baseline Property

XYDecimalAxisBaseTBaseline Property
The baseline value for the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Baseline { get; set; }
Public Property Baseline As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).LabelFunc Property

XYDecimalAxisBaseTLabelFunc Property
Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<decimal, decimal, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Decimal, Decimal, String)
    Get
    Set

Property Value

Type: Func Decimal, Decimal, String
The function used to determine axis labels.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).Maximum Property

XYDecimalAxisBaseTMaximum Property
The maximum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Maximum { get; set; }
Public Property Maximum As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).Minimum Property

XYDecimalAxisBaseTMinimum Property
The minimum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Minimum { get; set; }
Public Property Minimum As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).SlotInterval Property

XYDecimalAxisBaseTSlotInterval Property
The slot interval for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T SlotInterval { get; set; }
Public Property SlotInterval As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMajorInterval Property

XYDecimalAxisBaseTTickMajorInterval Property
The interval at which to display major ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T TickMajorInterval { get; set; }
Public Property TickMajorInterval As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMinorInterval Property

XYDecimalAxisBaseTTickMinorInterval Property
The interval at which to display minor ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T TickMinorInterval { get; set; }
Public Property TickMinorInterval As T
    Get
    Set

Property Value

Type: T
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T) Methods

XYDecimalAxisBaseT Methods

The XYDecimalAxisBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T) Events

XYDecimalAxisBaseT Events

The XYDecimalAxisBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T) Fields

XYDecimalAxisBaseT Fields

The XYDecimalAxisBaseT generic type exposes the following members.

Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).BaselineProperty Field

XYDecimalAxisBaseTBaselineProperty Field
Identifies the Baseline dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaselineProperty
Public Shared ReadOnly BaselineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Baseline dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).LabelFuncProperty Field

XYDecimalAxisBaseTLabelFuncProperty Field
Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).MaximumProperty Field

XYDecimalAxisBaseTMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).MinimumProperty Field

XYDecimalAxisBaseTMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).SlotIntervalProperty Field

XYDecimalAxisBaseTSlotIntervalProperty Field
Identifies the SlotInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalProperty
Public Shared ReadOnly SlotIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotInterval dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMajorIntervalProperty Field

XYDecimalAxisBaseTTickMajorIntervalProperty Field
Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDecimalAxisBase(T).TickMinorIntervalProperty Field

XYDecimalAxisBaseTTickMinorIntervalProperty Field
Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYDecimalAxisBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis Class

XYDoubleAxis Class
Represents an axis for data in Double format.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDoubleAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYDoubleAxis : XYAxisBase
Public Class XYDoubleAxis
    Inherits XYAxisBase

The XYDoubleAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYDoubleAxis | Creates a new XYDoubleAxis.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis Constructor

XYDoubleAxis Constructor
Creates a new XYDoubleAxis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYDoubleAxis()
Public Sub New
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis Properties

XYDoubleAxis Properties

The XYDoubleAxis type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | Baseline | The baseline value for the axis.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | The maximum value of the axis.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | The minimum value of the axis.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotInterval | The slot interval for data points of the axis when using slotted layout.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | The interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | The interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.Baseline Property

XYDoubleAxisBaseline Property
The baseline value for the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Baseline { get; set; }
Public Property Baseline As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.LabelFunc Property

XYDoubleAxisLabelFunc Property
Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. Normally, the first and second parameters of the function will be the value of the axis point represented by the label. When used on the secondary axis on a Bar Series, the first parameter will represent the starting value of a given slot on the axis, and the second parameter will represent the ending value of a given slot on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<double, double, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Double, Double, String)
    Get
    Set

Property Value

Type: Func Double, Double, String
The function used to determine axis labels.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.Maximum Property

XYDoubleAxisMaximum Property
The maximum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.Minimum Property

XYDoubleAxisMinimum Property
The minimum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.SlotInterval Property

XYDoubleAxisSlotInterval Property
The slot interval for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SlotInterval { get; set; }
Public Property SlotInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.TickMajorInterval Property

XYDoubleAxisTickMajorInterval Property
The interval at which to display major ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TickMajorInterval { get; set; }
Public Property TickMajorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.TickMinorInterval Property

XYDoubleAxisTickMinorInterval Property
The interval at which to display minor ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TickMinorInterval { get; set; }
Public Property TickMinorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis Methods

XYDoubleAxis Methods

The XYDoubleAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis Events

XYDoubleAxis Events

The XYDoubleAxis type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis Fields

XYDoubleAxis Fields

The XYDoubleAxis type exposes the following members.

Fields
Name | Description
BaselineProperty | Identifies the Baseline dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SlotIntervalProperty | Identifies the SlotInterval dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.BaselineProperty Field

XYDoubleAxisBaselineProperty Field
Identifies the Baseline dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BaselineProperty
Public Shared ReadOnly BaselineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Baseline dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.LabelFuncProperty Field

XYDoubleAxisLabelFuncProperty Field
Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.MaximumProperty Field

XYDoubleAxisMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.MinimumProperty Field

XYDoubleAxisMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.SlotIntervalProperty Field

XYDoubleAxisSlotIntervalProperty Field
Identifies the SlotInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotIntervalProperty
Public Shared ReadOnly SlotIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotInterval dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.TickMajorIntervalProperty Field

XYDoubleAxisTickMajorIntervalProperty Field
Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYDoubleAxis.TickMinorIntervalProperty Field

XYDoubleAxisTickMinorIntervalProperty Field
Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYDoubleAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis Class

XYGroupedAxis Class
XYGroupedAxis is an axis type used for displaying non-value data, such as strings and complex types. It can group, label, and sort data based on custom criteria.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYGroupedAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYGroupedAxis : XYAxisBase
Public Class XYGroupedAxis
    Inherits XYAxisBase

The XYGroupedAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYGroupedAxis | Creates a new XYDoubleAxis.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupingFunc | The function used to group items for a XYGroupedAxis. The function takes two data items and returns a Boolean indicating whether or not the items are grouped.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | The function used to label groups of items. The function takes a single data item from a group and returns a String used to label the group.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SortingFunc | The function used to sort groups of items. The function takes two data items from seperate groups and returns an Int32 comparing the two values. XYGroupedAxis should have SortFunc -- takes two groups and returns an int, like a comparable ("group" is first item in group) If the function returns a negative value, then the first instance is sorted before the second. If the function returns zero, then the instances are considered equal and sorted next to each other. If the function returns a positive value, then the first instance is sorted after the second.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
GroupingFuncProperty | Identifies the GroupingFunc dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
SortingFuncProperty | Identifies the SortingFunc dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis Constructor

XYGroupedAxis Constructor
Creates a new XYDoubleAxis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYGroupedAxis()
Public Sub New
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis Properties

XYGroupedAxis Properties

The XYGroupedAxis type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupingFunc | The function used to group items for a XYGroupedAxis. The function takes two data items and returns a Boolean indicating whether or not the items are grouped.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | The function used to label groups of items. The function takes a single data item from a group and returns a String used to label the group.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SortingFunc | The function used to sort groups of items. The function takes two data items from seperate groups and returns an Int32 comparing the two values. XYGroupedAxis should have SortFunc -- takes two groups and returns an int, like a comparable ("group" is first item in group) If the function returns a negative value, then the first instance is sorted before the second. If the function returns zero, then the instances are considered equal and sorted next to each other. If the function returns a positive value, then the first instance is sorted after the second.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis.GroupingFunc Property

XYGroupedAxisGroupingFunc Property
The function used to group items for a XYGroupedAxis. The function takes two data items and returns a Boolean indicating whether or not the items are grouped.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<Object, Object, bool> GroupingFunc { get; set; }
Public Property GroupingFunc As Func(Of Object, Object, Boolean)
    Get
    Set

Property Value

Type: Func Object, Object, Boolean
The grouping function.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis.LabelFunc Property

XYGroupedAxisLabelFunc Property
The function used to label groups of items. The function takes a single data item from a group and returns a String used to label the group.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<Object, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Object, String)
    Get
    Set

Property Value

Type: Func Object, String
The label function.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis.SortingFunc Property

XYGroupedAxisSortingFunc Property
The function used to sort groups of items. The function takes two data items from seperate groups and returns an Int32 comparing the two values. XYGroupedAxis should have SortFunc -- takes two groups and returns an int, like a comparable ("group" is first item in group) If the function returns a negative value, then the first instance is sorted before the second. If the function returns zero, then the instances are considered equal and sorted next to each other. If the function returns a positive value, then the first instance is sorted after the second.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<Object, Object, int> SortingFunc { get; set; }
Public Property SortingFunc As Func(Of Object, Object, Integer)
    Get
    Set

Property Value

Type: Func Object, Object, Int32
The sorting function.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis Methods

XYGroupedAxis Methods

The XYGroupedAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis Events

XYGroupedAxis Events

The XYGroupedAxis type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis Fields

XYGroupedAxis Fields

The XYGroupedAxis type exposes the following members.

Fields
Name | Description
GroupingFuncProperty | Identifies the GroupingFunc dependency property. This field is read-only.
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
SortingFuncProperty | Identifies the SortingFunc dependency property. This field is read-only.
Top
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis.GroupingFuncProperty Field

XYGroupedAxisGroupingFuncProperty Field
Identifies the GroupingFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GroupingFuncProperty
Public Shared ReadOnly GroupingFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GroupingFunc dependency property.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis.LabelFuncProperty Field

XYGroupedAxisLabelFuncProperty Field
Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYGroupedAxis.SortingFuncProperty Field

XYGroupedAxisSortingFuncProperty Field
Identifies the SortingFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortingFuncProperty
Public Shared ReadOnly SortingFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortingFunc dependency property.
See Also

Reference

XYGroupedAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis Class

XYPercentageAxis Class
Represents an axis for data displayed as stacked in percentage mode.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYPercentageAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYPercentageAxis : XYAxisBase
Public Class XYPercentageAxis
    Inherits XYAxisBase

The XYPercentageAxis type exposes the following members.

Constructors
 | Name | Description
Public method | XYPercentageAxis | Initializes a new instance of the XYPercentageAxis class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. The first parameter of the function will be the value of the axis point represented by the label. In the case of XYPercentageAxis, it will be a percentage value between 0.0 and 1.0.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | Gets or sets the interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | Gets or sets the interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis Constructor

XYPercentageAxis Constructor
Initializes a new instance of the XYPercentageAxis class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYPercentageAxis()
Public Sub New
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis Properties

XYPercentageAxis Properties

The XYPercentageAxis type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible. (Inherited from XYAxisBase.)
Public property | AreMajorTicksVisible | Whether or not major ticks are visible. (Inherited from XYAxisBase.)
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible. (Inherited from XYAxisBase.)
Public property | AxisType | The type of data on the axis. (Inherited from XYAxisBase.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing. (Inherited from XYAxisBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from XYAxisBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels. (Inherited from XYAxisBase.)
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property. (Inherited from XYAxisBase.)
Public property | LabelFunc | Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. The first parameter of the function will be the value of the axis point represented by the label. In the case of XYPercentageAxis, it will be a percentage value between 0.0 and 1.0.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock. (Inherited from XYAxisBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position. (Inherited from XYAxisBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart. (Inherited from XYAxisBase.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorInterval | Gets or sets the interval at which to display major ticks.
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | TickMinorInterval | Gets or sets the interval at which to display minor ticks.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path. (Inherited from XYAxisBase.)
Public property | Title | Gets or sets the axis title. (Inherited from XYAxisBase.)
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter. (Inherited from XYAxisBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis.LabelFunc Property

XYPercentageAxisLabelFunc Property
Gets or sets the function used to determine axis labels. When set, LabelFormat will be ignored. The first parameter of the function will be the value of the axis point represented by the label. In the case of XYPercentageAxis, it will be a percentage value between 0.0 and 1.0.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<double, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Double, String)
    Get
    Set

Property Value

Type: Func Double, String
The function used to determine axis labels.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis.TickMajorInterval Property

XYPercentageAxisTickMajorInterval Property
Gets or sets the interval at which to display major ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TickMajorInterval { get; set; }
Public Property TickMajorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis.TickMinorInterval Property

XYPercentageAxisTickMinorInterval Property
Gets or sets the interval at which to display minor ticks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TickMinorInterval { get; set; }
Public Property TickMinorInterval As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis Methods

XYPercentageAxis Methods

The XYPercentageAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from XYAxisBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis Events

XYPercentageAxis Events

The XYPercentageAxis type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed. (Inherited from XYAxisBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis Fields

XYPercentageAxis Fields

The XYPercentageAxis type exposes the following members.

Fields
Name | Description
LabelFuncProperty | Identifies the LabelFunc dependency property. This field is read-only.
TickMajorIntervalProperty | Identifies the TickMajorInterval dependency property. This field is read-only.
TickMinorIntervalProperty | Identifies the TickMinorInterval dependency property. This field is read-only.
Top
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis.LabelFuncProperty Field

XYPercentageAxisLabelFuncProperty Field
Identifies the LabelFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFuncProperty
Public Shared ReadOnly LabelFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFunc dependency property.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis.TickMajorIntervalProperty Field

XYPercentageAxisTickMajorIntervalProperty Field
Identifies the TickMajorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorIntervalProperty
Public Shared ReadOnly TickMajorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorInterval dependency property.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYPercentageAxis.TickMinorIntervalProperty Field

XYPercentageAxisTickMinorIntervalProperty Field
Identifies the TickMinorInterval dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorIntervalProperty
Public Shared ReadOnly TickMinorIntervalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorInterval dependency property.
See Also

Reference

XYPercentageAxis Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange Class

XYRange Class
Represents a range for use in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.ChartsXYRange

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYRange : Control
Public Class XYRange
    Inherits Control

The XYRange type exposes the following members.

Constructors
 | Name | Description
Public method | XYRange | Initializes a new instance of the XYRange class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the range based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange Constructor

XYRange Constructor
Initializes a new instance of the XYRange class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYRange()
Public Sub New
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange Properties

XYRange Properties

The XYRange type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.Maximum Property

XYRangeMaximum Property
Gets or sets the maximum value of the range. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Maximum { get; set; }
Public Property Maximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value of the range. The default value is .
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.Minimum Property

XYRangeMinimum Property
Gets or sets the minimum value of the range. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Minimum { get; set; }
Public Property Minimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value of the range. The default value is .
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.Orientation Property

XYRangeOrientation Property
Gets or sets the orientation of the range. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the range. The default value is Orientation.Horizontal.
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange Methods

XYRange Methods

The XYRange type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the range based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.Refresh Method

XYRangeRefresh Method
Updates the range based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange Events

XYRange Events

The XYRange type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange Fields

XYRange Fields

The XYRange type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.MaximumProperty Field

XYRangeMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.MinimumProperty Field

XYRangeMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRange.OrientationProperty Field

XYRangeOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

XYRange Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRangeCollection Class

XYRangeCollection Class
Represents a collection of XYRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XYRange
System.Collections.ObjectModelObservableCollection XYRange
ActiproSoftware.UI.XamlDeferrableObservableCollection XYRange
ActiproSoftware.UI.Xaml.Controls.ChartsDeferrableObservableItemCollection XYRange
ActiproSoftware.UI.Xaml.Controls.ChartsXYRangeCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYRangeCollection : DeferrableObservableItemCollection<XYRange>
Public Class XYRangeCollection
    Inherits DeferrableObservableItemCollection(Of XYRange)

The XYRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XYRangeCollection | Initializes a new instance of the XYRangeCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XYRange .)
Protected property | Items | (Inherited from Collection XYRange .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XYRange .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XYRange .)
Public method | Clear | (Inherited from Collection XYRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | (Inherited from Collection XYRange .)
Public method | CopyTo | (Inherited from Collection XYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XYRange .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XYRange .)
Public method | Insert | (Inherited from Collection XYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XYRange .)
Protected method | MoveItem | (Inherited from ObservableCollection XYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XYRange .)
Public method | RemoveAt | (Inherited from Collection XYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XYRange .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XYRange .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRangeCollection Constructor

XYRangeCollection Constructor
Initializes a new instance of the XYRangeCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYRangeCollection()
Public Sub New
See Also

Reference

XYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRangeCollection Properties

XYRangeCollection Properties

The XYRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XYRange .)
Protected property | Items | (Inherited from Collection XYRange .)
Top
See Also

Reference

XYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRangeCollection Methods

XYRangeCollection Methods

The XYRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XYRange .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XYRange .)
Public method | Clear | (Inherited from Collection XYRange .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | (Inherited from Collection XYRange .)
Public method | CopyTo | (Inherited from Collection XYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XYRange .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XYRange .)
Public method | Insert | (Inherited from Collection XYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XYRange .)
Protected method | MoveItem | (Inherited from ObservableCollection XYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XYRange .)
Public method | RemoveAt | (Inherited from Collection XYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYRangeCollection Events

XYRangeCollection Events

The XYRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XYRange .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XYRange .)
Top
See Also

Reference

XYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesCollection Class

XYSeriesCollection Class
Represents a collection of XYRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XYSeriesBase
System.Collections.ObjectModelObservableCollection XYSeriesBase
ActiproSoftware.UI.XamlDeferrableObservableCollection XYSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsDeferrableObservableItemCollection XYSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYSeriesCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYSeriesCollection : DeferrableObservableItemCollection<XYSeriesBase>
Public Class XYSeriesCollection
    Inherits DeferrableObservableItemCollection(Of XYSeriesBase)

The XYSeriesCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XYSeriesCollection | Initializes a new instance of the XYSeriesCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XYSeriesBase .)
Protected property | Items | (Inherited from Collection XYSeriesBase .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XYSeriesBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XYSeriesBase .)
Public method | Clear | (Inherited from Collection XYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | (Inherited from Collection XYSeriesBase .)
Public method | CopyTo | (Inherited from Collection XYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XYSeriesBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XYSeriesBase .)
Public method | Insert | (Inherited from Collection XYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XYSeriesBase .)
Protected method | MoveItem | (Inherited from ObservableCollection XYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XYSeriesBase .)
Public method | RemoveAt | (Inherited from Collection XYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XYSeriesBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XYSeriesBase .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesCollection Constructor

XYSeriesCollection Constructor
Initializes a new instance of the XYSeriesCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYSeriesCollection()
Public Sub New
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesCollection Properties

XYSeriesCollection Properties

The XYSeriesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XYSeriesBase .)
Protected property | Items | (Inherited from Collection XYSeriesBase .)
Top
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesCollection Methods

XYSeriesCollection Methods

The XYSeriesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XYSeriesBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XYSeriesBase .)
Public method | Clear | (Inherited from Collection XYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from DeferrableObservableItemCollectionT.)
Public method | Contains | (Inherited from Collection XYSeriesBase .)
Public method | CopyTo | (Inherited from Collection XYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XYSeriesBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XYSeriesBase .)
Public method | Insert | (Inherited from Collection XYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XYSeriesBase .)
Protected method | MoveItem | (Inherited from ObservableCollection XYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XYSeriesBase .)
Public method | RemoveAt | (Inherited from Collection XYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from DeferrableObservableItemCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableItemCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesCollection Events

XYSeriesCollection Events

The XYSeriesCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XYSeriesBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XYSeriesBase .)
Top
See Also

Reference

XYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind Class

XYSeriesLineKind Class
Specifies the line kinds supported by a LineSeries and AreaSeries series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsXYSeriesLineKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class XYSeriesLineKind : Enum
Public NotInheritable Class XYSeriesLineKind
    Inherits Enum

The XYSeriesLineKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Normal | Indicates a normal line will be used to connect the data points.
 | Spline | Indicates a spline will be used to connect the data points.
 | Step | Indicates stepped lines will be used to connect the data points.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind Methods

XYSeriesLineKind Methods

The XYSeriesLineKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

XYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind Fields

XYSeriesLineKind Fields

The XYSeriesLineKind type exposes the following members.

Fields
 | Name | Description
 | Normal | Indicates a normal line will be used to connect the data points.
 | Spline | Indicates a spline will be used to connect the data points.
 | Step | Indicates stepped lines will be used to connect the data points.
Public field | value__ |
Top
See Also

Reference

XYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind.Normal Field

XYSeriesLineKindNormal Field
Indicates a normal line will be used to connect the data points.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XYSeriesLineKind Normal = 0
Public Const Normal As XYSeriesLineKind = 0

Field Value

Type: XYSeriesLineKind
See Also

Reference

XYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind.Spline Field

XYSeriesLineKindSpline Field
Indicates a spline will be used to connect the data points.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XYSeriesLineKind Spline = 1
Public Const Spline As XYSeriesLineKind = 1

Field Value

Type: XYSeriesLineKind
See Also

Reference

XYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind.Step Field

XYSeriesLineKindStep Field
Indicates stepped lines will be used to connect the data points.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XYSeriesLineKind Step = 2
Public Const Step As XYSeriesLineKind = 2

Field Value

Type: XYSeriesLineKind
See Also

Reference

XYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesLineKind.value__ Field

XYSeriesLineKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.XYSeriesLineKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

XYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind Class

XYSeriesStackKind Class
Specifies the stacking methods supported by a XYSeriesBase series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ChartsXYSeriesStackKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class XYSeriesStackKind : Enum
Public NotInheritable Class XYSeriesStackKind
    Inherits Enum

The XYSeriesStackKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | Indicates the series will not be stacked.
 | Normal | Indicates the series will be stacked by adding its values to the values of other stacked series.
 | Percentage | Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind Methods

XYSeriesStackKind Methods

The XYSeriesStackKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

XYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind Fields

XYSeriesStackKind Fields

The XYSeriesStackKind type exposes the following members.

Fields
 | Name | Description
 | None | Indicates the series will not be stacked.
 | Normal | Indicates the series will be stacked by adding its values to the values of other stacked series.
 | Percentage | Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.
Public field | value__ |
Top
See Also

Reference

XYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind.None Field

XYSeriesStackKindNone Field
Indicates the series will not be stacked.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XYSeriesStackKind None = 0
Public Const None As XYSeriesStackKind = 0

Field Value

Type: XYSeriesStackKind
See Also

Reference

XYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind.Normal Field

XYSeriesStackKindNormal Field
Indicates the series will be stacked by adding its values to the values of other stacked series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XYSeriesStackKind Normal = 1
Public Const Normal As XYSeriesStackKind = 1

Field Value

Type: XYSeriesStackKind
See Also

Reference

XYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind.Percentage Field

XYSeriesStackKindPercentage Field
Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XYSeriesStackKind Percentage = 2
Public Const Percentage As XYSeriesStackKind = 2

Field Value

Type: XYSeriesStackKind
See Also

Reference

XYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


XYSeriesStackKind.value__ Field

XYSeriesStackKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.XYSeriesStackKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

XYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.Charts Namespace


ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace
Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | XYChartAutomationPeer | Exposes the XYChart control to UI Automation.


XYChartAutomationPeer Class

XYChartAutomationPeer Class
Exposes the XYChart control to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.PeersXYChartAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XYChartAutomationPeer : FrameworkElementAutomationPeer
Public Class XYChartAutomationPeer
    Inherits FrameworkElementAutomationPeer

The XYChartAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | XYChartAutomationPeer | Initializes a new instance of the XYChartAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer Constructor

XYChartAutomationPeer Constructor
Initializes a new instance of the XYChartAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYChartAutomationPeer(
    XYChart owner
)
Public Sub New (
    owner As XYChart
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.ChartsXYChart
The owner.
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer Properties

XYChartAutomationPeer Properties

The XYChartAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer Methods

XYChartAutomationPeer Methods

The XYChartAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer.GetChildrenCore Method

XYChartAutomationPeerGetChildrenCore Method
Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As IList(Of AutomationPeer)

Return Value

Type: IList AutomationPeer
A list of child AutomationPeer elements.
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace


XYChartAutomationPeer.GetClassNameCore Method

XYChartAutomationPeerGetClassNameCore Method
Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

XYChartAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Charts.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
Contains types related to chart palettes.
Classes
 | Class | Description
Public class | ColorSelectionHint | Specifies a hint for how a SeriesPaletteStyleSelector should select colors for a series.
Public class | Palette | Provides a palette of colors for use in charts.
Public class | PaletteData | Stores palette data.
Public class | PaletteKind | Specifies the built-in palette options for a SeriesPaletteStyleSelector.
Public class | PaletteStyleSelectorBaseT | The base class for style selectors that use palettes.
Public class | PieSlicePaletteStyleSelector | Selects a style for a given PieSlice using a palette of colors.
Public class | SeriesBrushKind | Specifies the kind of brush to use for a series element.
Public class | SeriesPaletteData | Stores series-related palette data.
Public class | SeriesPaletteStyleSelector | Provides a way to apply series styles based on a palette of colors.


ColorSelectionHint Class

ColorSelectionHint Class
Specifies a hint for how a SeriesPaletteStyleSelector should select colors for a series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesColorSelectionHint

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ColorSelectionHint : Enum
Public NotInheritable Class ColorSelectionHint
    Inherits Enum

The ColorSelectionHint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
 | UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


ColorSelectionHint Methods

ColorSelectionHint Methods

The ColorSelectionHint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


ColorSelectionHint Fields

ColorSelectionHint Fields

The ColorSelectionHint type exposes the following members.

Fields
 | Name | Description
 | Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
 | UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.
Public field | value__ |
Top
See Also

Reference

ColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


ColorSelectionHint.Sequential Field

ColorSelectionHintSequential Field
Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ColorSelectionHint Sequential = 0
Public Const Sequential As ColorSelectionHint = 0

Field Value

Type: ColorSelectionHint
See Also

Reference

ColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


ColorSelectionHint.UniformDistribution Field

ColorSelectionHintUniformDistribution Field
Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ColorSelectionHint UniformDistribution = 1
Public Const UniformDistribution As ColorSelectionHint = 1

Field Value

Type: ColorSelectionHint
See Also

Reference

ColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


ColorSelectionHint.value__ Field

ColorSelectionHintvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.Palettes.ColorSelectionHint.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Class

Palette Class
Provides a palette of colors for use in charts.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPalette

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Palette
Public Class Palette

The Palette type exposes the following members.

Constructors
 | Name | Description
Public method | Palette | Initializes a new instance of the Palette class.
Public method | Palette(Color) | Initializes a new instance of the Palette class.
Public method | Palette(PaletteKind) | Initializes a new instance of the Palette class.
Top
Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a ColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a PaletteKind that indicates the built-in palette to use.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Constructor

Palette Constructor
Overload List
 | Name | Description
Public method | Palette | Initializes a new instance of the Palette class.
Public method | Palette(Color) | Initializes a new instance of the Palette class.
Public method | Palette(PaletteKind) | Initializes a new instance of the Palette class.
Top
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Constructor

Palette Constructor
Initializes a new instance of the Palette class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Palette()
Public Sub New
See Also

Reference

Palette Class
Palette Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Constructor (Color[])

Palette Constructor (Color)
Initializes a new instance of the Palette class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Palette(
    params Color[] paletteBaseColors
)
Public Sub New (
    ParamArray paletteBaseColors As Color()
)

Parameters

paletteBaseColors
Type: Windows.UIColor
The palette Color values.
See Also

Reference

Palette Class
Palette Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Constructor (PaletteKind)

Palette Constructor (PaletteKind)
Initializes a new instance of the Palette class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Palette(
    PaletteKind kind
)
Public Sub New (
    kind As PaletteKind
)

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteKind
A PaletteKind that indicates the built-in palette to use.
See Also

Reference

Palette Class
Palette Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Properties

Palette Properties

The Palette type exposes the following members.

Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a ColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a PaletteKind that indicates the built-in palette to use.
Top
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette.BaseColors Property

PaletteBaseColors Property
Gets the collection of palette base Color objects used to generate the palette.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<Color> BaseColors { get; }
Public ReadOnly Property BaseColors As ObservableCollection(Of Color)
    Get

Property Value

Type: ObservableCollection Color
The collection of palette base Color objects used to generate the palette.
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette.Colors Property

PaletteColors Property
Gets the read-only collection of Color objects in this palette.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<Color> Colors { get; }
Public ReadOnly Property Colors As ReadOnlyObservableCollection(Of Color)
    Get

Property Value

Type: ReadOnlyObservableCollection Color
The read-only collection of Color objects in this palette.
Remarks
This collection includes the BaseColors values, along with other shade variants if the IsShadeGenerationEnabled property is set to true.
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
PaletteIsShadeGenerationEnabled


Palette.ColorSelectionHint Property

PaletteColorSelectionHint Property
Gets or sets a ColorSelectionHint that provides a hint on how to perform color selection for this palette.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ColorSelectionHint ColorSelectionHint { get; set; }
Public Property ColorSelectionHint As ColorSelectionHint
    Get
    Set

Property Value

Type: ColorSelectionHint
A ColorSelectionHint that provides a hint on how to perform color selection for this palette. The default hint is UniformDistribution.
Remarks
See the documentation on the ColorSelectionHint for more information on usage.
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette.IsShadeGenerationEnabled Property

PaletteIsShadeGenerationEnabled Property
Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsShadeGenerationEnabled { get; set; }
Public Property IsShadeGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if shade generation is enabled; otherwise, false.
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette.Kind Property

PaletteKind Property
Gets or sets a PaletteKind that indicates the built-in palette to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PaletteKind Kind { get; set; }
Public Property Kind As PaletteKind
    Get
    Set

Property Value

Type: PaletteKind
A PaletteKind that indicates the built-in palette to use.
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Methods

Palette Methods

The Palette type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette.OnChanged Method

PaletteOnChanged Method
Raises the Changed event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette Events

Palette Events

The Palette type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


Palette.Changed Event

PaletteChanged Event
Occurs after the palette has been changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Palette Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteData Class

PaletteData Class
Stores palette data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteData
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesSeriesPaletteData

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PaletteData
Public Class PaletteData

The PaletteData type exposes the following members.

Constructors
 | Name | Description
Public method | PaletteData | Initializes a new instance of the PaletteData class
Top
Properties
 | Name | Description
Public property | Color | Gets or sets the palette color.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteData Constructor

PaletteData Constructor
Initializes a new instance of the PaletteData class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PaletteData()
Public Sub New
See Also

Reference

PaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteData Properties

PaletteData Properties

The PaletteData type exposes the following members.

Properties
 | Name | Description
Public property | Color | Gets or sets the palette color.
Top
See Also

Reference

PaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteData.Color Property

PaletteDataColor Property
Gets or sets the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public UIColor Color { get; set; }
Public Property Color As UIColor
    Get
    Set

Property Value

Type: UIColor
The palette color.
See Also

Reference

PaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteData Methods

PaletteData Methods

The PaletteData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind Class

PaletteKind Class
Specifies the built-in palette options for a SeriesPaletteStyleSelector.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PaletteKind : Enum
Public NotInheritable Class PaletteKind
    Inherits Enum

The PaletteKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Autumn | Red to green colors.
 | Beach | Blue, yellow, and green colors.
 | Default | The default colors.
 | Earth | Yellow and brown colors.
 | Fishbowl | Blue, tan, and orange colors.
 | Forest | Green, blue, and brown colors.
 | IceCream | Muted blue, beige, and pink colors.
 | Melon | Muted pastel colors.
 | Mesa | Blue/green, tan, and red colors.
 | Plum | Purple colors.
 | Rainbow | Rainbow colors.
 | Retro | Purple, orange, and green colors.
 | Roman | Red, tan, and blue colors.
 | Rose | Rose reddish colors.
 | Sand | Muted blue and tan colors.
 | Sea | Blue and green colors.
 | Tulip | Red, green, yellow, and purple colors.
Public field | value__ |
 | Vibrant | Magenta, blue, and green colors.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind Methods

PaletteKind Methods

The PaletteKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind Fields

PaletteKind Fields

The PaletteKind type exposes the following members.

Fields
 | Name | Description
 | Autumn | Red to green colors.
 | Beach | Blue, yellow, and green colors.
 | Default | The default colors.
 | Earth | Yellow and brown colors.
 | Fishbowl | Blue, tan, and orange colors.
 | Forest | Green, blue, and brown colors.
 | IceCream | Muted blue, beige, and pink colors.
 | Melon | Muted pastel colors.
 | Mesa | Blue/green, tan, and red colors.
 | Plum | Purple colors.
 | Rainbow | Rainbow colors.
 | Retro | Purple, orange, and green colors.
 | Roman | Red, tan, and blue colors.
 | Rose | Rose reddish colors.
 | Sand | Muted blue and tan colors.
 | Sea | Blue and green colors.
 | Tulip | Red, green, yellow, and purple colors.
Public field | value__ |
 | Vibrant | Magenta, blue, and green colors.
Top
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Autumn Field

PaletteKindAutumn Field
Red to green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Autumn = 1
Public Const Autumn As PaletteKind = 1

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Beach Field

PaletteKindBeach Field
Blue, yellow, and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Beach = 2
Public Const Beach As PaletteKind = 2

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Default Field

PaletteKindDefault Field
The default colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Default = 0
Public Const Default As PaletteKind = 0

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Earth Field

PaletteKindEarth Field
Yellow and brown colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Earth = 3
Public Const Earth As PaletteKind = 3

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Fishbowl Field

PaletteKindFishbowl Field
Blue, tan, and orange colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Fishbowl = 4
Public Const Fishbowl As PaletteKind = 4

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Forest Field

PaletteKindForest Field
Green, blue, and brown colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Forest = 5
Public Const Forest As PaletteKind = 5

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.IceCream Field

PaletteKindIceCream Field
Muted blue, beige, and pink colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind IceCream = 6
Public Const IceCream As PaletteKind = 6

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Melon Field

PaletteKindMelon Field
Muted pastel colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Melon = 7
Public Const Melon As PaletteKind = 7

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Mesa Field

PaletteKindMesa Field
Blue/green, tan, and red colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Mesa = 8
Public Const Mesa As PaletteKind = 8

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Plum Field

PaletteKindPlum Field
Purple colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Plum = 9
Public Const Plum As PaletteKind = 9

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Rainbow Field

PaletteKindRainbow Field
Rainbow colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Rainbow = 10
Public Const Rainbow As PaletteKind = 10

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Retro Field

PaletteKindRetro Field
Purple, orange, and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Retro = 11
Public Const Retro As PaletteKind = 11

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Roman Field

PaletteKindRoman Field
Red, tan, and blue colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Roman = 12
Public Const Roman As PaletteKind = 12

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Rose Field

PaletteKindRose Field
Rose reddish colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Rose = 13
Public Const Rose As PaletteKind = 13

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Sand Field

PaletteKindSand Field
Muted blue and tan colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Sand = 14
Public Const Sand As PaletteKind = 14

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Sea Field

PaletteKindSea Field
Blue and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Sea = 15
Public Const Sea As PaletteKind = 15

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Tulip Field

PaletteKindTulip Field
Red, green, yellow, and purple colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Tulip = 16
Public Const Tulip As PaletteKind = 16

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.value__ Field

PaletteKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.Palettes.PaletteKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteKind.Vibrant Field

PaletteKindVibrant Field
Magenta, blue, and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PaletteKind Vibrant = 17
Public Const Vibrant As PaletteKind = 17

Field Value

Type: PaletteKind
See Also

Reference

PaletteKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Class

PaletteStyleSelectorBaseT Class
The base class for style selectors that use palettes.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteStyleSelectorBaseT
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPieSlicePaletteStyleSelector
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesSeriesPaletteStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PaletteStyleSelectorBase<T>
where T : new(), PaletteData

Public Class PaletteStyleSelectorBase(Of T As {New, PaletteData})

Type Parameters

T
The type of PaletteData.

The PaletteStyleSelectorBaseT type exposes the following members.

Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPaletteData | Returns the proper palette data for a given item.
Protected method | GetSettersFromStyle | Gets the setters from style.
Public method | GetType | (Inherited from Object.)
Protected method | InvalidatePaletteData | Invalidates the palette data.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
UnsetColor | Gets the 'unset' color value.
UnsetStrokeThickness | Gets the 'unset' stroke thickness value.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Properties

PaletteStyleSelectorBaseT Properties

The PaletteStyleSelectorBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use.
Top
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).Palette Property

PaletteStyleSelectorBaseTPalette Property
Gets or sets the Palette of colors to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Palette Palette { get; set; }
Public Property Palette As Palette
    Get
    Set

Property Value

Type: Palette
The Palette of colors to use.
Exceptions
Exception | Condition
ArgumentNullException | value
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Methods

PaletteStyleSelectorBaseT Methods

The PaletteStyleSelectorBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPaletteData | Returns the proper palette data for a given item.
Protected method | GetSettersFromStyle | Gets the setters from style.
Public method | GetType | (Inherited from Object.)
Protected method | InvalidatePaletteData | Invalidates the palette data.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).GetPaletteData Method

PaletteStyleSelectorBaseTGetPaletteData Method
Returns the proper palette data for a given item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected T GetPaletteData(
    int index,
    int count
)
Protected Function GetPaletteData (
    index As Integer,
    count As Integer
) As T

Parameters

index
Type: SystemInt32
The item index.
count
Type: SystemInt32
The item count.

Return Value

Type: T
The proper palette data for a given item.
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).GetSettersFromStyle Method

PaletteStyleSelectorBaseTGetSettersFromStyle Method
Gets the setters from style.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IEnumerable<Setter> GetSettersFromStyle(
    Style defaultStyle
)
Protected Function GetSettersFromStyle (
    defaultStyle As Style
) As IEnumerable(Of Setter)

Parameters

defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: IEnumerable Setter
An IEnumerableT of setters from a given style.
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).InvalidatePaletteData Method

PaletteStyleSelectorBaseTInvalidatePaletteData Method
Invalidates the palette data.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void InvalidatePaletteData()
Protected Sub InvalidatePaletteData
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T) Fields

PaletteStyleSelectorBaseT Fields

The PaletteStyleSelectorBaseT generic type exposes the following members.

Fields
Name | Description
UnsetColor | Gets the 'unset' color value.
UnsetStrokeThickness | Gets the 'unset' stroke thickness value.
Top
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).UnsetColor Field

PaletteStyleSelectorBaseTUnsetColor Field
Gets the 'unset' color value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static readonly Color UnsetColor
Protected Shared ReadOnly UnsetColor As Color

Field Value

Type: Color
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PaletteStyleSelectorBase(T).UnsetStrokeThickness Field

PaletteStyleSelectorBaseTUnsetStrokeThickness Field
Gets the 'unset' stroke thickness value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected const double UnsetStrokeThickness = -1.79769313486232E+308
Protected Const UnsetStrokeThickness As Double = -1.79769313486232E+308

Field Value

Type: Double
See Also

Reference

PaletteStyleSelectorBaseT Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Class

PieSlicePaletteStyleSelector Class
Selects a style for a given PieSlice using a palette of colors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteStyleSelectorBase PaletteData
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPieSlicePaletteStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PieSlicePaletteStyleSelector : PaletteStyleSelectorBase<PaletteData>,
    IPieSliceStyleSelector
Public Class PieSlicePaletteStyleSelector
    Inherits PaletteStyleSelectorBase(Of PaletteData)
    Implements IPieSliceStyleSelector

The PieSlicePaletteStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PieSlicePaletteStyleSelector | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Public method | PieSlicePaletteStyleSelector(Palette) | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Top
Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Public method | GetType | (Inherited from Object.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Constructor

PieSlicePaletteStyleSelector Constructor
Overload List
 | Name | Description
Public method | PieSlicePaletteStyleSelector | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Public method | PieSlicePaletteStyleSelector(Palette) | Initializes a new instance of the PieSlicePaletteStyleSelector class.
Top
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Constructor

PieSlicePaletteStyleSelector Constructor
Initializes a new instance of the PieSlicePaletteStyleSelector class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSlicePaletteStyleSelector()
Public Sub New
See Also

Reference

PieSlicePaletteStyleSelector Class
PieSlicePaletteStyleSelector Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Constructor (Palette)

PieSlicePaletteStyleSelector Constructor (Palette)
Initializes a new instance of the PieSlicePaletteStyleSelector class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSlicePaletteStyleSelector(
    Palette palette
)
Public Sub New (
    palette As Palette
)

Parameters

palette
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPalette
The Palette of colors to use.
See Also

Reference

PieSlicePaletteStyleSelector Class
PieSlicePaletteStyleSelector Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Properties

PieSlicePaletteStyleSelector Properties

The PieSlicePaletteStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector Methods

PieSlicePaletteStyleSelector Methods

The PieSlicePaletteStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Public method | GetType | (Inherited from Object.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectChildPieSliceStyle | Selects the child pie slice style. Style must have TargetType of PieSlice.
Public method | SelectPieSliceStyle | Selects the pie slice style. Style must have TargetType of PieSlice.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector.SelectChildPieSliceStyle Method

PieSlicePaletteStyleSelectorSelectChildPieSliceStyle Method
Selects the child pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectChildPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Color parentFill,
    Style defaultStyle
)
Public Function SelectChildPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    parentFill As Color,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
parentFill
Type: Windows.UIColor
The parent fill color.
defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.

Implements

IPieSliceStyleSelectorSelectChildPieSliceStyle(Int32, Int32, Color, Style)
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


PieSlicePaletteStyleSelector.SelectPieSliceStyle Method

PieSlicePaletteStyleSelectorSelectPieSliceStyle Method
Selects the pie slice style. Style must have TargetType of PieSlice.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectPieSliceStyle(
    int pieSliceIndex,
    int pieSliceCount,
    Style defaultStyle
)
Public Function SelectPieSliceStyle (
    pieSliceIndex As Integer,
    pieSliceCount As Integer,
    defaultStyle As Style
) As Style

Parameters

pieSliceIndex
Type: SystemInt32
Index of the pie slice.
pieSliceCount
Type: SystemInt32
The pie slice count.
defaultStyle
Type: Windows.UI.XamlStyle
The default style.

Return Value

Type: Style
A Style for PieSlice.

Implements

IPieSliceStyleSelectorSelectPieSliceStyle(Int32, Int32, Style)
See Also

Reference

PieSlicePaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind Class

SeriesBrushKind Class
Specifies the kind of brush to use for a series element.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesSeriesBrushKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SeriesBrushKind : Enum
Public NotInheritable Class SeriesBrushKind
    Inherits Enum

The SeriesBrushKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CylinderGradient | Use a gradient, creating a cylindrical appearance.
 | Dark | Use a slightly darker version of the palette color.
 | DarkToLightGradient | Use a gradient, from the Dark to Light color.
 | Default | Use the exact palette color.
 | Light | Use a slightly lighter version of the palette color.
 | LightToDarkGradient | Use a gradient, from the Light to Dark color.
 | SemiTransparent | Use a semi-transparent version of the palette color.
 | SemiTransparentGradient | Use a gradient, from a semi-transparent version of the palette color to an almost completely transparent version of the palette color.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind Methods

SeriesBrushKind Methods

The SeriesBrushKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind Fields

SeriesBrushKind Fields

The SeriesBrushKind type exposes the following members.

Fields
 | Name | Description
 | CylinderGradient | Use a gradient, creating a cylindrical appearance.
 | Dark | Use a slightly darker version of the palette color.
 | DarkToLightGradient | Use a gradient, from the Dark to Light color.
 | Default | Use the exact palette color.
 | Light | Use a slightly lighter version of the palette color.
 | LightToDarkGradient | Use a gradient, from the Light to Dark color.
 | SemiTransparent | Use a semi-transparent version of the palette color.
 | SemiTransparentGradient | Use a gradient, from a semi-transparent version of the palette color to an almost completely transparent version of the palette color.
Public field | value__ |
Top
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.CylinderGradient Field

SeriesBrushKindCylinderGradient Field
Use a gradient, creating a cylindrical appearance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind CylinderGradient = 7
Public Const CylinderGradient As SeriesBrushKind = 7

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.Dark Field

SeriesBrushKindDark Field
Use a slightly darker version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind Dark = 2
Public Const Dark As SeriesBrushKind = 2

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.DarkToLightGradient Field

SeriesBrushKindDarkToLightGradient Field
Use a gradient, from the Dark to Light color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind DarkToLightGradient = 5
Public Const DarkToLightGradient As SeriesBrushKind = 5

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.Default Field

SeriesBrushKindDefault Field
Use the exact palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind Default = 0
Public Const Default As SeriesBrushKind = 0

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.Light Field

SeriesBrushKindLight Field
Use a slightly lighter version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind Light = 1
Public Const Light As SeriesBrushKind = 1

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.LightToDarkGradient Field

SeriesBrushKindLightToDarkGradient Field
Use a gradient, from the Light to Dark color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind LightToDarkGradient = 6
Public Const LightToDarkGradient As SeriesBrushKind = 6

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.SemiTransparent Field

SeriesBrushKindSemiTransparent Field
Use a semi-transparent version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind SemiTransparent = 3
Public Const SemiTransparent As SeriesBrushKind = 3

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.SemiTransparentGradient Field

SeriesBrushKindSemiTransparentGradient Field
Use a gradient, from a semi-transparent version of the palette color to an almost completely transparent version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SeriesBrushKind SemiTransparentGradient = 4
Public Const SemiTransparentGradient As SeriesBrushKind = 4

Field Value

Type: SeriesBrushKind
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesBrushKind.value__ Field

SeriesBrushKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Charts.Palettes.SeriesBrushKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData Class

SeriesPaletteData Class
Stores series-related palette data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteData
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesSeriesPaletteData

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SeriesPaletteData : PaletteData
Public Class SeriesPaletteData
    Inherits PaletteData

The SeriesPaletteData type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesPaletteData | Initializes a new instance of the SeriesPaletteData class
Top
Properties
 | Name | Description
Public property | AreaHorizontalBrush | Gets or sets a cached Brush used for horizontal area series.
Public property | AreaVerticalBrush | Gets or sets a cached Brush used for vertical area series.
Public property | BarHorizontalBrush | Gets or sets a cached Brush used for horizontal bar series.
Public property | BarStrokeBrush | Gets or sets a cached Brush used for the stroke around bar series.
Public property | BarVerticalBrush | Gets or sets a cached Brush used for vertical bar series.
Public property | Color | Gets or sets the palette color. (Inherited from PaletteData.)
Public property | LegendBrush | Gets or sets a cached Brush.
Public property | LineBrush | Gets or sets a cached Brush.
Public property | MarkerBrush | Gets or sets a cached Brush.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData Constructor

SeriesPaletteData Constructor
Initializes a new instance of the SeriesPaletteData class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesPaletteData()
Public Sub New
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData Properties

SeriesPaletteData Properties

The SeriesPaletteData type exposes the following members.

Properties
 | Name | Description
Public property | AreaHorizontalBrush | Gets or sets a cached Brush used for horizontal area series.
Public property | AreaVerticalBrush | Gets or sets a cached Brush used for vertical area series.
Public property | BarHorizontalBrush | Gets or sets a cached Brush used for horizontal bar series.
Public property | BarStrokeBrush | Gets or sets a cached Brush used for the stroke around bar series.
Public property | BarVerticalBrush | Gets or sets a cached Brush used for vertical bar series.
Public property | Color | Gets or sets the palette color. (Inherited from PaletteData.)
Public property | LegendBrush | Gets or sets a cached Brush.
Public property | LineBrush | Gets or sets a cached Brush.
Public property | MarkerBrush | Gets or sets a cached Brush.
Top
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.AreaHorizontalBrush Property

SeriesPaletteDataAreaHorizontalBrush Property
Gets or sets a cached Brush used for horizontal area series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaHorizontalBrush { get; set; }
Public Property AreaHorizontalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for horizontal area series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.AreaVerticalBrush Property

SeriesPaletteDataAreaVerticalBrush Property
Gets or sets a cached Brush used for vertical area series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaVerticalBrush { get; set; }
Public Property AreaVerticalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for vertical area series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.BarHorizontalBrush Property

SeriesPaletteDataBarHorizontalBrush Property
Gets or sets a cached Brush used for horizontal bar series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BarHorizontalBrush { get; set; }
Public Property BarHorizontalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for horizontal bar series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.BarStrokeBrush Property

SeriesPaletteDataBarStrokeBrush Property
Gets or sets a cached Brush used for the stroke around bar series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BarStrokeBrush { get; set; }
Public Property BarStrokeBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for the stroke around bar series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.BarVerticalBrush Property

SeriesPaletteDataBarVerticalBrush Property
Gets or sets a cached Brush used for vertical bar series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BarVerticalBrush { get; set; }
Public Property BarVerticalBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush used for vertical bar series.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.LegendBrush Property

SeriesPaletteDataLegendBrush Property
Gets or sets a cached Brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LegendBrush { get; set; }
Public Property LegendBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.LineBrush Property

SeriesPaletteDataLineBrush Property
Gets or sets a cached Brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineBrush { get; set; }
Public Property LineBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData.MarkerBrush Property

SeriesPaletteDataMarkerBrush Property
Gets or sets a cached Brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerBrush { get; set; }
Public Property MarkerBrush As Brush
    Get
    Set

Property Value

Type: Brush
The cached Brush.
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteData Methods

SeriesPaletteData Methods

The SeriesPaletteData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SeriesPaletteData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Class

SeriesPaletteStyleSelector Class
Provides a way to apply series styles based on a palette of colors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPaletteStyleSelectorBase SeriesPaletteData
ActiproSoftware.UI.Xaml.Controls.Charts.PalettesSeriesPaletteStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SeriesPaletteStyleSelector : PaletteStyleSelectorBase<SeriesPaletteData>,
    ISeriesStyleSelector
Public Class SeriesPaletteStyleSelector
    Inherits PaletteStyleSelectorBase(Of SeriesPaletteData)
    Implements ISeriesStyleSelector

The SeriesPaletteStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesPaletteStyleSelector | Initializes a new instance of the SeriesPaletteStyleSelector class.
Public method | SeriesPaletteStyleSelector(Palette) | Initializes a new instance of the SeriesPaletteStyleSelector class.
Top
Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | BarBrushCustom | Gets or sets the custom Brush to use for the fill inside bars.
Public property | BarBrushKind | Gets or sets the kind of brush to use for the fill inside bars.
Public property | BarStrokeBrushCustom | Gets or sets the custom Brush to use for the stroke around bars.
Public property | BarStrokeBrushKind | Gets or sets the kind of brush to use for the stroke around bars.
Public property | BarStrokeThickness | Gets or sets the thickness of the stroke around bars.
Public property | BarStrokeTintColor | Gets or sets the tint color to apply to the resulting brush from the BarStrokeBrushKind setting.
Public property | BarTintColor | Gets or sets the tint color to apply to the resulting brush from the BarBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Public method | GetType | (Inherited from Object.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the area Style to use for the specified bar series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Constructor

SeriesPaletteStyleSelector Constructor
Overload List
 | Name | Description
Public method | SeriesPaletteStyleSelector | Initializes a new instance of the SeriesPaletteStyleSelector class.
Public method | SeriesPaletteStyleSelector(Palette) | Initializes a new instance of the SeriesPaletteStyleSelector class.
Top
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Constructor

SeriesPaletteStyleSelector Constructor
Initializes a new instance of the SeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesPaletteStyleSelector()
Public Sub New
See Also

Reference

SeriesPaletteStyleSelector Class
SeriesPaletteStyleSelector Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Constructor (Palette)

SeriesPaletteStyleSelector Constructor (Palette)
Initializes a new instance of the SeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesPaletteStyleSelector(
    Palette palette
)
Public Sub New (
    palette As Palette
)

Parameters

palette
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PalettesPalette
The Palette of colors to use.
See Also

Reference

SeriesPaletteStyleSelector Class
SeriesPaletteStyleSelector Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector Properties

SeriesPaletteStyleSelector Properties

The SeriesPaletteStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | BarBrushCustom | Gets or sets the custom Brush to use for the fill inside bars.
Public property | BarBrushKind | Gets or sets the kind of brush to use for the fill inside bars.
Public property | BarStrokeBrushCustom | Gets or sets the custom Brush to use for the stroke around bars.
Public property | BarStrokeBrushKind | Gets or sets the kind of brush to use for the stroke around bars.
Public property | BarStrokeThickness | Gets or sets the thickness of the stroke around bars.
Public property | BarStrokeTintColor | Gets or sets the tint color to apply to the resulting brush from the BarStrokeBrushKind setting.
Public property | BarTintColor | Gets or sets the tint color to apply to the resulting brush from the BarBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the Palette of colors to use. (Inherited from PaletteStyleSelectorBaseT.)
Top
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.AreaBrushCustom Property

SeriesPaletteStyleSelectorAreaBrushCustom Property
Gets or sets the custom Brush to use for areas.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaBrushCustom { get; set; }
Public Property AreaBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for areas.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorAreaBrushKind


SeriesPaletteStyleSelector.AreaBrushKind Property

SeriesPaletteStyleSelectorAreaBrushKind Property
Gets or sets the kind of brush to use for areas.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesBrushKind AreaBrushKind { get; set; }
Public Property AreaBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for areas.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorAreaBrushCustom
SeriesPaletteStyleSelectorAreaTintColor


SeriesPaletteStyleSelector.AreaTintColor Property

SeriesPaletteStyleSelectorAreaTintColor Property
Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color AreaTintColor { get; set; }
Public Property AreaTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorAreaBrushKind


SeriesPaletteStyleSelector.BarBrushCustom Property

SeriesPaletteStyleSelectorBarBrushCustom Property
Gets or sets the custom Brush to use for the fill inside bars.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BarBrushCustom { get; set; }
Public Property BarBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the fill inside bars.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the BarBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarBrushKind


SeriesPaletteStyleSelector.BarBrushKind Property

SeriesPaletteStyleSelectorBarBrushKind Property
Gets or sets the kind of brush to use for the fill inside bars.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesBrushKind BarBrushKind { get; set; }
Public Property BarBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for the fill inside bars.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarTintColor


SeriesPaletteStyleSelector.BarStrokeBrushCustom Property

SeriesPaletteStyleSelectorBarStrokeBrushCustom Property
Gets or sets the custom Brush to use for the stroke around bars.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BarStrokeBrushCustom { get; set; }
Public Property BarStrokeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the stroke around bars.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the BarStrokeBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarStrokeBrushKind


SeriesPaletteStyleSelector.BarStrokeBrushKind Property

SeriesPaletteStyleSelectorBarStrokeBrushKind Property
Gets or sets the kind of brush to use for the stroke around bars.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesBrushKind BarStrokeBrushKind { get; set; }
Public Property BarStrokeBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for the stroke around bars.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarStrokeBrushCustom
SeriesPaletteStyleSelectorBarStrokeTintColor


SeriesPaletteStyleSelector.BarStrokeThickness Property

SeriesPaletteStyleSelectorBarStrokeThickness Property
Gets or sets the thickness of the stroke around bars.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double BarStrokeThickness { get; set; }
Public Property BarStrokeThickness As Double
    Get
    Set

Property Value

Type: Double
A NullableT indicating the thickness of the stroke around bars.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.BarStrokeTintColor Property

SeriesPaletteStyleSelectorBarStrokeTintColor Property
Gets or sets the tint color to apply to the resulting brush from the BarStrokeBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color BarStrokeTintColor { get; set; }
Public Property BarStrokeTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarStrokeBrushKind


SeriesPaletteStyleSelector.BarTintColor Property

SeriesPaletteStyleSelectorBarTintColor Property
Gets or sets the tint color to apply to the resulting brush from the BarBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color BarTintColor { get; set; }
Public Property BarTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorBarBrushKind


SeriesPaletteStyleSelector.LineBrushCustom Property

SeriesPaletteStyleSelectorLineBrushCustom Property
Gets or sets the custom Brush to use for lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineBrushCustom { get; set; }
Public Property LineBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for lines.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the LineBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorLineBrushKind


SeriesPaletteStyleSelector.LineBrushKind Property

SeriesPaletteStyleSelectorLineBrushKind Property
Gets or sets the kind of brush to use for lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesBrushKind LineBrushKind { get; set; }
Public Property LineBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for lines.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorLineBrushCustom
SeriesPaletteStyleSelectorLineTintColor


SeriesPaletteStyleSelector.LineTintColor Property

SeriesPaletteStyleSelectorLineTintColor Property
Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color LineTintColor { get; set; }
Public Property LineTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorLineBrushKind


SeriesPaletteStyleSelector.MarkerBrushCustom Property

SeriesPaletteStyleSelectorMarkerBrushCustom Property
Gets or sets the custom Brush to use for markers.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerBrushCustom { get; set; }
Public Property MarkerBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for markers.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerBrushKind setting.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorMarkerBrushKind


SeriesPaletteStyleSelector.MarkerBrushKind Property

SeriesPaletteStyleSelectorMarkerBrushKind Property
Gets or sets the kind of brush to use for markers.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesBrushKind MarkerBrushKind { get; set; }
Public Property MarkerBrushKind As SeriesBrushKind
    Get
    Set

Property Value

Type: SeriesBrushKind
A SeriesBrushKind indicating the kind of brush to use for markers.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorMarkerBrushCustom
SeriesPaletteStyleSelectorMarkerTintColor


SeriesPaletteStyleSelector.MarkerTintColor Property

SeriesPaletteStyleSelectorMarkerTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color MarkerTintColor { get; set; }
Public Property MarkerTintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color, if tinting should be applied.
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace
SeriesPaletteStyleSelectorMarkerBrushKind


SeriesPaletteStyleSelector Methods

SeriesPaletteStyleSelector Methods

The SeriesPaletteStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPaletteData | Returns the proper palette data for a given item. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | GetSettersFromStyle | Gets the setters from style. (Inherited from PaletteStyleSelectorBaseT.)
Public method | GetType | (Inherited from Object.)
Protected method | InvalidatePaletteData | Invalidates the palette data. (Inherited from PaletteStyleSelectorBaseT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectBarStyle | Returns the area Style to use for the specified bar series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectAreaStyle Method

SeriesPaletteStyleSelectorSelectAreaStyle Method
Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectAreaStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Function SelectAreaStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectAreaStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectBarStyle Method

SeriesPaletteStyleSelectorSelectBarStyle Method
Returns the area Style to use for the specified bar series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectBarStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Function SelectBarStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified bar series.

Implements

ISeriesStyleSelectorSelectBarStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectLegendMarkerStyle Method

SeriesPaletteStyleSelectorSelectLegendMarkerStyle Method
Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectLegendMarkerStyle(
    XYSeriesBase series,
    Style defaultStyle
)
Public Function SelectLegendMarkerStyle (
    series As XYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLegendMarkerStyle(XYSeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectLineStyle Method

SeriesPaletteStyleSelectorSelectLineStyle Method
Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectLineStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Function SelectLineStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectLineStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


SeriesPaletteStyleSelector.SelectMarkerStyle Method

SeriesPaletteStyleSelectorSelectMarkerStyle Method
Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Palettes
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style SelectMarkerStyle(
    SeriesBase series,
    Style defaultStyle
)
Public Function SelectMarkerStyle (
    series As SeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.

Implements

ISeriesStyleSelectorSelectMarkerStyle(SeriesBase, Style)
See Also

Reference

SeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Charts.Palettes Namespace


ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace
Contains the primitive classes used for charts.
Classes
 | Class | Description
Public class | AxisTick | Represents a tick on an axis.
Public class | AxisVisual | Visualizes a given axis.
Public class | BarSeriesBase | Represents a base class for bar series used in a XYChart.
Public class | ChartCanvas | Represents a panel were child elements are positioned using explicit/relative coordinates.
Public class | ChartPanel | ChartPanel is responsible for orchestrating the layout / arrangement of different chart elements, and the order in which they refresh, measure, and arrange.
Public class | DataPointBase | Represents a base class for a data point presented by a chart series.
Public class | DataPointLabeler | Responsible for displaying labels for data points.
Public class | DateTimeInterval | Represents an interval of time.
Public class | DesignTimeData | Used to display sample chart data at design-time.
Public class | GridVisual | Draws a grid behind the chart at major and minor points on the X and Y axis.
Public class | InvalidPropertyPathException | InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Public class | LabelInfo | Information that describes a data point label.
Public class | Legend | The legend control used to display a collection of LegendKey in a chart.
Public class | LegendItem | Represents an item used in a chart legend.
Public class | LineSeriesBase | Represents a base class for line and area series for use in a XYChart.
Public class | PieSlice | A single pie slice in a pie series.
Public class | SeriesBase | Provides the base class for a series.
Public class | SeriesItemsSourceConverter | Represents a type converter for the ItemsSource type.
Public class | XAxisVisual | Draws an axis given axis data.
Public class | XYAxisBase | Represents the base functionality of a chart axis.
Public class | XYSeriesBase | Provides the base class for a series that uses an X/Y axis.
Public class | YAxisVisual | Draws an axis given axis data.


AxisTick Class

AxisTick Class
Represents a tick on an axis.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesAxisTick

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AxisTick
Public Class AxisTick

The AxisTick type exposes the following members.

Constructors
 | Name | Description
Public method | AxisTick(Double) | Initializes a new instance of the AxisTick class.
Public method | AxisTick(String, Double) | Initializes a new instance of the AxisTick class.
Top
Properties
 | Name | Description
Public property | Label | The String representation of the data at the tick point.
Public property | Position | The position on the axis that the tick resides.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified AxisTick is equal to the current AxisTick. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick Constructor

AxisTick Constructor
Overload List
 | Name | Description
Public method | AxisTick(Double) | Initializes a new instance of the AxisTick class.
Public method | AxisTick(String, Double) | Initializes a new instance of the AxisTick class.
Top
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick Constructor (Double)

AxisTick Constructor (Double)
Initializes a new instance of the AxisTick class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AxisTick(
    double position
)
Public Sub New (
    position As Double
)

Parameters

position
Type: SystemDouble
The position.
See Also

Reference

AxisTick Class
AxisTick Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick Constructor (String, Double)

AxisTick Constructor (String, Double)
Initializes a new instance of the AxisTick class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AxisTick(
    string label,
    double position
)
Public Sub New (
    label As String,
    position As Double
)

Parameters

label
Type: SystemString
The label.
position
Type: SystemDouble
The position.
See Also

Reference

AxisTick Class
AxisTick Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick Properties

AxisTick Properties

The AxisTick type exposes the following members.

Properties
 | Name | Description
Public property | Label | The String representation of the data at the tick point.
Public property | Position | The position on the axis that the tick resides.
Top
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick.Label Property

AxisTickLabel Property
The String representation of the data at the tick point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Label { get; }
Public ReadOnly Property Label As String
    Get

Property Value

Type: String
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick.Position Property

AxisTickPosition Property
The position on the axis that the tick resides.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Position { get; }
Public ReadOnly Property Position As Double
    Get

Property Value

Type: Double
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick Methods

AxisTick Methods

The AxisTick type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified AxisTick is equal to the current AxisTick. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick.Equals Method

AxisTickEquals Method
Determines whether the specified AxisTick is equal to the current AxisTick.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The AxisTick to compare with the current AxisTick.

Return Value

Type: Boolean
true if the specified AxisTick is equal to the current AxisTick; otherwise, false.
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick.GetHashCode Method

AxisTickGetHashCode Method
Serves as a hash function for a particular type.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisTick.ToString Method

AxisTickToString Method
Returns a String that represents this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

AxisTick Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual Class

AxisVisual Class
Visualizes a given axis.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesAxisVisual
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXAxisVisual
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesYAxisVisual

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class AxisVisual : Control
Public MustInherit Class AxisVisual
    Inherits Control

The AxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary.
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible.
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
 | DrawLineOnGeometry | Draws a line on a given geometry.
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis.
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis.
Protected method | DrawSpine | Draws an axis spine.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
 | GetRealNumberOrDefault | Provides the given argumentValue if it is not infinity, otherwise provides the given default argumentValue.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
 | GetTextBlockMeasuredSize | Gets the measured size of the text block.
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | IsSpineVisible | Determines whether or not the spine is visible.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Redraws the axis.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitlePosition | Updates the title position.
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
Infinity | Size with width and height of infinity.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual Properties

AxisVisual Properties

The AxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary.
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.TickMajorMidPixel Property

AxisVisualTickMajorMidPixel Property
Gets the major tick position snapped to mid-pixel, if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected double TickMajorMidPixel { get; }
Protected ReadOnly Property TickMajorMidPixel As Double
    Get

Return Value

Type: Double
The major tick position snapped to mid-pixel, if necessary.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.TickMinorMidPixel Property

AxisVisualTickMinorMidPixel Property
Gets the minor tick position snapped to mid-pixel, if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected double TickMinorMidPixel { get; }
Protected ReadOnly Property TickMinorMidPixel As Double
    Get

Return Value

Type: Double
The minor tick position snapped to mid-pixel, if necessary.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual Methods

AxisVisual Methods

The AxisVisual type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible.
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
 | DrawLineOnGeometry | Draws a line on a given geometry.
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis.
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis.
Protected method | DrawSpine | Draws an axis spine.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
 | GetRealNumberOrDefault | Provides the given argumentValue if it is not infinity, otherwise provides the given default argumentValue.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
 | GetTextBlockMeasuredSize | Gets the measured size of the text block.
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | IsSpineVisible | Determines whether or not the spine is visible.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Redraws the axis.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitlePosition | Updates the title position.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.AreAnyTicksVisible Method

AxisVisualAreAnyTicksVisible Method
Determines if any ticks are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected bool AreAnyTicksVisible(
    Size plotSize
)
Protected Function AreAnyTicksVisible (
    plotSize As Size
) As Boolean

Parameters

plotSize
Type: Windows.FoundationSize
The plot size.

Return Value

Type: Boolean
True if any ticks are visible, otherwise false.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.DrawLineOnGeometry Method

AxisVisualDrawLineOnGeometry Method
Draws a line on a given geometry.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static void DrawLineOnGeometry(
    PathGeometry geometry,
    double x1,
    double y1,
    double x2,
    double y2
)
Protected Shared Sub DrawLineOnGeometry (
    geometry As PathGeometry,
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double
)

Parameters

geometry
Type: Windows.UI.Xaml.MediaPathGeometry
The PathGeometry to draw the line on.
x1
Type: SystemDouble
The starting X point of the line.
y1
Type: SystemDouble
The starting Y point of the line.
x2
Type: SystemDouble
The ending X point of the line.
y2
Type: SystemDouble
The ending Y point of the line.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.DrawMajorTickAtPosition Method

AxisVisualDrawMajorTickAtPosition Method
Draws a major tick at a given position on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void DrawMajorTickAtPosition(
    double position,
    Size plotSize
)
Protected MustOverride Sub DrawMajorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.DrawMinorTickAtPosition Method

AxisVisualDrawMinorTickAtPosition Method
Draws a minor tick at a given position on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void DrawMinorTickAtPosition(
    double position,
    Size plotSize
)
Protected MustOverride Sub DrawMinorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.DrawSpine Method

AxisVisualDrawSpine Method
Draws an axis spine.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void DrawSpine(
    Size plotSize
)
Protected MustOverride Sub DrawSpine (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.AxisVisual.DrawSpine(Windows.Foundation.Size)"]

See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.GetRealNumberOrDefault Method

AxisVisualGetRealNumberOrDefault Method
Provides the given argumentValue if it is not infinity, otherwise provides the given default argumentValue.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static double GetRealNumberOrDefault(
    double value,
    double defaultValue
)
Protected Shared Function GetRealNumberOrDefault (
    value As Double,
    defaultValue As Double
) As Double

Parameters

value
Type: SystemDouble
The argumentValue to be returned if real.
defaultValue
Type: SystemDouble
The default argumentValue to be returned if the primary argumentValue is infinity.

Return Value

Type: Double
The argumentValue if it is not infinity, otherwise the default argumentValue.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.GetTextBlockMeasuredSize Method

AxisVisualGetTextBlockMeasuredSize Method
Gets the measured size of the text block.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static Size GetTextBlockMeasuredSize(
    TextBlock textBlock
)
Protected Shared Function GetTextBlockMeasuredSize (
    textBlock As TextBlock
) As Size

Parameters

textBlock
Type: Windows.UI.Xaml.ControlsTextBlock
The text block.

Return Value

Type: Size
The measured size of the text block.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.GetTitleTemplateFromResources Method

AxisVisualGetTitleTemplateFromResources Method
Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract DataTemplate GetTitleTemplateFromResources(
    ResourceDictionary resources
)
Protected MustOverride Function GetTitleTemplateFromResources (
    resources As ResourceDictionary
) As DataTemplate

Parameters

resources
Type: Windows.UI.XamlResourceDictionary
The ResourceDictionary to retrieve the title template from.

Return Value

Type: DataTemplate
The template for the axis title.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.IsSpineVisible Method

AxisVisualIsSpineVisible Method
Determines whether or not the spine is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSpineVisible()
Public Function IsSpineVisible As Boolean

Return Value

Type: Boolean
true if the spine is visible; otherwise, false.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.OnApplyTemplate Method

AxisVisualOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.PlaceLabelAtPosition Method

AxisVisualPlaceLabelAtPosition Method
Place the axis label at the given position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void PlaceLabelAtPosition(
    TextBlock label,
    double position,
    double angle,
    Size plotSize
)
Protected MustOverride Sub PlaceLabelAtPosition (
    label As TextBlock,
    position As Double,
    angle As Double,
    plotSize As Size
)

Parameters

label
Type: Windows.UI.Xaml.ControlsTextBlock
The axis label to lay out.
position
Type: SystemDouble
The position to draw the axis label at.
angle
Type: SystemDouble
The angle to draw the axis label at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.Refresh Method

AxisVisualRefresh Method
Redraws the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    Size plotSize
)
Public Overridable Sub Refresh (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.AxisVisual.Refresh(Windows.Foundation.Size)"]

See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.UpdateTitlePosition Method

AxisVisualUpdateTitlePosition Method
Updates the title position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateTitlePosition(
    Size plotSize
)
Protected MustOverride Sub UpdateTitlePosition (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.AxisVisual.UpdateTitlePosition(Windows.Foundation.Size)"]

See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual Events

AxisVisual Events

The AxisVisual type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual Fields

AxisVisual Fields

The AxisVisual type exposes the following members.

Fields
Name | Description
Infinity | Size with width and height of infinity.
Top
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


AxisVisual.Infinity Field

AxisVisualInfinity Field
Size with width and height of infinity.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static readonly Size Infinity
Protected Shared ReadOnly Infinity As Size

Field Value

Type: Size
See Also

Reference

AxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase Class

BarSeriesBase Class
Represents a base class for bar series used in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsBarSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class BarSeriesBase : XYSeriesBase
Public MustInherit Class BarSeriesBase
    Inherits XYSeriesBase

The BarSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | BarSeriesBase | Initializes a new instance of the BarSeriesBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Overrides SeriesBaseLogicalOrientation.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides XYSeriesBaseRequiresSlottedLayout.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
BarTemplateProperty | Identifies the BarTemplate dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase Constructor

BarSeriesBase Constructor
Initializes a new instance of the BarSeriesBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected BarSeriesBase()
Protected Sub New
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase Properties

BarSeriesBase Properties

The BarSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarTemplate | Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LogicalOrientation | Gets the logical orientation of the series. (Overrides SeriesBaseLogicalOrientation.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides XYSeriesBaseRequiresSlottedLayout.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.BarStyle Property

BarSeriesBaseBarStyle Property
Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style BarStyle { get; set; }
Public Property BarStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.BarTemplate Property

BarSeriesBaseBarTemplate Property
Gets or sets DataTemplate that is used to customize the content of a single bar in a bar series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate BarTemplate { get; set; }
Public Property BarTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The bar template. The default value is .
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.LabelPositioningMode Property

BarSeriesBaseLabelPositioningMode Property
Gets or sets the LabelPositioningMode used to determine how labels are laid out.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelPositioningMode LabelPositioningMode { get; set; }
Public Property LabelPositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The label positioning mode. The default value is FromBaseline.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.LogicalOrientation Property

BarSeriesBaseLogicalOrientation Property
Gets the logical orientation of the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Orientation LogicalOrientation { get; }
Public Overrides ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.MarkerVisibility Property

BarSeriesBaseMarkerVisibility Property
Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As ChartMarkerVisibility
    Get
    Set

Property Value

Type: ChartMarkerVisibility
A ChartMarkerVisibility indicating which markers are rendered along the series. The default value is ChartMarkerVisibility.None.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.MinimumMargin Property

BarSeriesBaseMinimumMargin Property
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> MinimumMargin { get; }
Protected Overrides ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.Orientation Property

BarSeriesBaseOrientation Property
Gets or sets the orientation of the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the series. The default value is Orientation.Horizontal.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.RequiresSlottedLayout Property

BarSeriesBaseRequiresSlottedLayout Property
Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool RequiresSlottedLayout { get; }
Public Overrides ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase Methods

BarSeriesBase Methods

The BarSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase Events

BarSeriesBase Events

The BarSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase Fields

BarSeriesBase Fields

The BarSeriesBase type exposes the following members.

Fields
Name | Description
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
BarTemplateProperty | Identifies the BarTemplate dependency property. This field is read-only.
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.BarStyleProperty Field

BarSeriesBaseBarStyleProperty Field
Identifies the BarStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarStyleProperty
Public Shared ReadOnly BarStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarStyle dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.BarTemplateProperty Field

BarSeriesBaseBarTemplateProperty Field
Identifies the BarTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarTemplateProperty
Public Shared ReadOnly BarTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarTemplate dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.LabelPositioningModeProperty Field

BarSeriesBaseLabelPositioningModeProperty Field
Identifies the LabelPositioningMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositioningModeProperty
Public Shared ReadOnly LabelPositioningModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.MarkerVisibilityProperty Field

BarSeriesBaseMarkerVisibilityProperty Field
Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


BarSeriesBase.OrientationProperty Field

BarSeriesBaseOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

BarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas Class

ChartCanvas Class
Represents a panel were child elements are positioned using explicit/relative coordinates.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesChartCanvas

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ChartCanvas : Panel
Public Class ChartCanvas
    Inherits Panel

The ChartCanvas type exposes the following members.

Constructors
 | Name | Description
Public method | ChartCanvas | Initializes a new instance of the ChartCanvas class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
 | GetZIndex | Gets the value of the ZIndexProperty attached property for the specified element.
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
 | SetZIndex | Sets the value of the ZIndexProperty attached property to the specified element.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
ZIndexProperty | Identifies the ZIndex dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas Constructor

ChartCanvas Constructor
Initializes a new instance of the ChartCanvas class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ChartCanvas()
Public Sub New
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas Properties

ChartCanvas Properties

The ChartCanvas type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas Methods

ChartCanvas Methods

The ChartCanvas type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
 | GetZIndex | Gets the value of the ZIndexProperty attached property for the specified element.
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
 | SetZIndex | Sets the value of the ZIndexProperty attached property to the specified element.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.ArrangeOverride Method

ChartCanvasArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.ArrangeOverride Method (Size)

ChartCanvasArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

ChartCanvas Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.GetX Method

ChartCanvasGetX Method
Gets the value of the XProperty attached property for a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static double GetX(
    DependencyObject element
)
Public Shared Function GetX (
    element As DependencyObject
) As Double

Parameters

element
Type: Windows.UI.XamlDependencyObject
The element to which the attached property is retrieved.

Return Value

Type: Double
The X-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.GetY Method

ChartCanvasGetY Method
Gets the value of the YProperty attached property for a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static double GetY(
    DependencyObject element
)
Public Shared Function GetY (
    element As DependencyObject
) As Double

Parameters

element
Type: Windows.UI.XamlDependencyObject
The element to which the attached property is retrieved.

Return Value

Type: Double
The Y-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.GetZIndex Method

ChartCanvasGetZIndex Method
Gets the value of the ZIndexProperty attached property for the specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static int GetZIndex(
    UIElement element
)
Public Shared Function GetZIndex (
    element As UIElement
) As Integer

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is retrieved.

Return Value

Type: Int32
The element's value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.MeasureOverride Method

ChartCanvasMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.MeasureOverride Method (Size)

ChartCanvasMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

ChartCanvas Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.SetX Method

ChartCanvasSetX Method
Sets the value of the XProperty attached property to a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetX(
    DependencyObject element,
    double value
)
Public Shared Sub SetX (
    element As DependencyObject,
    value As Double
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The element to which the attached property is written.
value
Type: SystemDouble
The X-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.SetY Method

ChartCanvasSetY Method
Sets the value of the YProperty attached property to a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetY(
    DependencyObject element,
    double value
)
Public Shared Sub SetY (
    element As DependencyObject,
    value As Double
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The element to which the attached property is written.
value
Type: SystemDouble
The Y-coordinate value.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.SetZIndex Method

ChartCanvasSetZIndex Method
Sets the value of the ZIndexProperty attached property to the specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetZIndex(
    UIElement element,
    int value
)
Public Shared Sub SetZIndex (
    element As UIElement,
    value As Integer
)

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is written.
value
Type: SystemInt32
The value to set.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas Events

ChartCanvas Events

The ChartCanvas type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas Fields

ChartCanvas Fields

The ChartCanvas type exposes the following members.

Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
ZIndexProperty | Identifies the ZIndex dependency property. This field is read-only.
Top
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.XProperty Field

ChartCanvasXProperty Field
Identifies the X dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XProperty
Public Shared ReadOnly XProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the X dependency property.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.YProperty Field

ChartCanvasYProperty Field
Identifies the Y dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YProperty
Public Shared ReadOnly YProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Y dependency property.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartCanvas.ZIndexProperty Field

ChartCanvasZIndexProperty Field
Identifies the ZIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZIndexProperty
Public Shared ReadOnly ZIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZIndex dependency property.
See Also

Reference

ChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel Class

ChartPanel Class
ChartPanel is responsible for orchestrating the layout / arrangement of different chart elements, and the order in which they refresh, measure, and arrange.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesChartPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ChartPanel : Panel
Public Class ChartPanel
    Inherits Panel

The ChartPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ChartPanel | Initializes a new instance of the ChartPanel class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | PaddingPercentage | Gets or sets the padding percentage.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | Teardown | Tears down the control.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendVerticalPositionProperty | The legend vertical position property
PaddingPercentageProperty | The padding percentage property
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel Constructor

ChartPanel Constructor
Initializes a new instance of the ChartPanel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ChartPanel()
Public Sub New
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel Properties

ChartPanel Properties

The ChartPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsLegendVisible | Gets or sets a value indicating whether this instance is legend visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendHorizontalPosition | Gets or sets the legend horizontal position.
Public property | LegendVerticalPosition | Gets or sets the legend vertical position.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | PaddingPercentage | Gets or sets the padding percentage.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.IsLegendVisible Property

ChartPanelIsLegendVisible Property
Gets or sets a value indicating whether this instance is legend visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLegendVisible { get; set; }
Public Property IsLegendVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is legend visible; otherwise, false.
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.LegendHorizontalPosition Property

ChartPanelLegendHorizontalPosition Property
Gets or sets the legend horizontal position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendHorizontalPosition LegendHorizontalPosition { get; set; }
Public Property LegendHorizontalPosition As LegendHorizontalPosition
    Get
    Set

Property Value

Type: LegendHorizontalPosition
The legend horizontal position.
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.LegendVerticalPosition Property

ChartPanelLegendVerticalPosition Property
Gets or sets the legend vertical position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendVerticalPosition LegendVerticalPosition { get; set; }
Public Property LegendVerticalPosition As LegendVerticalPosition
    Get
    Set

Property Value

Type: LegendVerticalPosition
The legend vertical position.
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.PaddingPercentage Property

ChartPanelPaddingPercentage Property
Gets or sets the padding percentage.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness PaddingPercentage { get; set; }
Public Property PaddingPercentage As Thickness
    Get
    Set

Property Value

Type: Thickness
The padding percentage.
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel Methods

ChartPanel Methods

The ChartPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | Teardown | Tears down the control.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.ArrangeOverride Method

ChartPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior.
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.ArrangeOverride Method (Size)

ChartPanelArrangeOverride Method (Size)
Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this object should use to arrange itself and its children.

Return Value

Type: Size
The actual size that is used after the element is arranged in layout.
See Also

Reference

ChartPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.MeasureOverride Method

ChartPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.MeasureOverride Method (Size)

ChartPanelMeasureOverride Method (Size)
Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

ChartPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.Teardown Method

ChartPanelTeardown Method
Tears down the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Teardown()
Public Sub Teardown
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel Events

ChartPanel Events

The ChartPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel Fields

ChartPanel Fields

The ChartPanel type exposes the following members.

Fields
Name | Description
IsLegendVisibleProperty | Identifies the IsLegendVisible dependency property. This field is read-only.
LegendHorizontalPositionProperty | Identifies the LegendHorizontalPosition dependency property. This field is read-only.
LegendVerticalPositionProperty | The legend vertical position property
PaddingPercentageProperty | The padding percentage property
Top
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.IsLegendVisibleProperty Field

ChartPanelIsLegendVisibleProperty Field
Identifies the IsLegendVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLegendVisibleProperty
Public Shared ReadOnly IsLegendVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.LegendHorizontalPositionProperty Field

ChartPanelLegendHorizontalPositionProperty Field
Identifies the LegendHorizontalPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendHorizontalPositionProperty
Public Shared ReadOnly LegendHorizontalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLegendVisible dependency property.
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.LegendVerticalPositionProperty Field

ChartPanelLegendVerticalPositionProperty Field
The legend vertical position property

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendVerticalPositionProperty
Public Shared ReadOnly LegendVerticalPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ChartPanel.PaddingPercentageProperty Field

ChartPanelPaddingPercentageProperty Field
The padding percentage property

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PaddingPercentageProperty
Public Shared ReadOnly PaddingPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ChartPanel Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointBase Class

DataPointBase Class
Represents a base class for a data point presented by a chart series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesDataPointBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDataPoint

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DataPointBase : ObservableObjectBase
Public MustInherit Class DataPointBase
    Inherits ObservableObjectBase

The DataPointBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataPointBase | Initializes a new instance of the DataPointBase class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointBase Constructor

DataPointBase Constructor
Initializes a new instance of the DataPointBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DataPointBase()
Protected Sub New
See Also

Reference

DataPointBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointBase Properties

DataPointBase Properties

The DataPointBase type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
See Also

Reference

DataPointBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointBase.Index Property

DataPointBaseIndex Property
Gets or sets the index of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the data point; The default value is 0.
See Also

Reference

DataPointBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointBase Methods

DataPointBase Methods

The DataPointBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DataPointBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointBase Events

DataPointBase Events

The DataPointBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DataPointBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler Class

DataPointLabeler Class
Responsible for displaying labels for data points.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesDataPointLabeler

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DataPointLabeler : Control
Public Class DataPointLabeler
    Inherits Control

The DataPointLabeler type exposes the following members.

Constructors
 | Name | Description
Public method | DataPointLabeler | Initializes a new instance of the DataPointLabeler class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | LabelExcess | Gets the excess space outside of bounds taken up by the labels.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlotMargin | Gets or sets the plot margin.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | AddLabel | Adds a label based on a given LabelInfo.
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearLabels | Clears all labels.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FinalizeLabels | Finalizes the labels. Called after all labels have been added for this draw operation.
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | NotifyMouseExited | Notifies that the mouse exited.
Public method | NotifyMouseMoved | Notifies that the mouse was moved.
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler Constructor

DataPointLabeler Constructor
Initializes a new instance of the DataPointLabeler class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataPointLabeler()
Public Sub New
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler Properties

DataPointLabeler Properties

The DataPointLabeler type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelCollisionMode | Gets or sets the label collision mode.
Public property | LabelExcess | Gets the excess space outside of bounds taken up by the labels.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlotMargin | Gets or sets the plot margin.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.LabelCollisionMode Property

DataPointLabelerLabelCollisionMode Property
Gets or sets the label collision mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelCollisionMode LabelCollisionMode { get; set; }
Public Property LabelCollisionMode As LabelCollisionMode
    Get
    Set

Property Value

Type: LabelCollisionMode
The label collision mode.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.LabelExcess Property

DataPointLabelerLabelExcess Property
Gets the excess space outside of bounds taken up by the labels.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Thickness LabelExcess { get; }
Public Overridable ReadOnly Property LabelExcess As Thickness
    Get

Property Value

Type: Thickness
The excess space outside of bounds taken up by the labels.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.PlotMargin Property

DataPointLabelerPlotMargin Property
Gets or sets the plot margin.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness PlotMargin { get; set; }
Public Property PlotMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The plot margin.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler Methods

DataPointLabeler Methods

The DataPointLabeler type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | AddLabel | Adds a label based on a given LabelInfo.
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearLabels | Clears all labels.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FinalizeLabels | Finalizes the labels. Called after all labels have been added for this draw operation.
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | NotifyMouseExited | Notifies that the mouse exited.
Public method | NotifyMouseMoved | Notifies that the mouse was moved.
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.AddLabel Method

DataPointLabelerAddLabel Method
Adds a label based on a given LabelInfo.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddLabel(
    LabelInfo labelInfo
)
Public Overridable Sub AddLabel (
    labelInfo As LabelInfo
)

Parameters

labelInfo
Type: ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLabelInfo
The label info to build the label from.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.ClearLabels Method

DataPointLabelerClearLabels Method
Clears all labels.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void ClearLabels()
Public Overridable Sub ClearLabels
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.FinalizeLabels Method

DataPointLabelerFinalizeLabels Method
Finalizes the labels. Called after all labels have been added for this draw operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void FinalizeLabels(
    Size plotSize
)
Public Sub FinalizeLabels (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.DataPointLabeler.FinalizeLabels(Windows.Foundation.Size)"]

See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.NotifyMouseExited Method

DataPointLabelerNotifyMouseExited Method
Notifies that the mouse exited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void NotifyMouseExited()
Public Sub NotifyMouseExited
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.NotifyMouseMoved Method

DataPointLabelerNotifyMouseMoved Method
Notifies that the mouse was moved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void NotifyMouseMoved(
    Point mousePosition
)
Public Sub NotifyMouseMoved (
    mousePosition As Point
)

Parameters

mousePosition
Type: Windows.FoundationPoint
The mouse position.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.OnApplyTemplate Method

DataPointLabelerOnApplyTemplate Method
When overridden in a derived class, is invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in an application. For more information, see Remarks.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler Events

DataPointLabeler Events

The DataPointLabeler type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler Fields

DataPointLabeler Fields

The DataPointLabeler type exposes the following members.

Fields
Name | Description
LabelCollisionModeProperty | Identifies the LabelCollisionMode dependency property. This field is read-only.
Top
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DataPointLabeler.LabelCollisionModeProperty Field

DataPointLabelerLabelCollisionModeProperty Field
Identifies the LabelCollisionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelCollisionModeProperty
Public Shared ReadOnly LabelCollisionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelCollisionMode dependency property.
See Also

Reference

DataPointLabeler Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval Class

DateTimeInterval Class
Represents an interval of time.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesDateTimeInterval

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateTimeInterval
Public Class DateTimeInterval

The DateTimeInterval type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeInterval | Initializes a new instance of the DateTimeInterval class
Top
Properties
 | Name | Description
Public property | Unit | Gets or sets the unit of time represented by Value.
Public property | Value | Gets or sets the value of the interval.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Public method | ToTimeSpan | Converts the current DateTimeInterval to a TimeSpan.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval Constructor

DateTimeInterval Constructor
Initializes a new instance of the DateTimeInterval class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTimeInterval()
Public Sub New
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval Properties

DateTimeInterval Properties

The DateTimeInterval type exposes the following members.

Properties
 | Name | Description
Public property | Unit | Gets or sets the unit of time represented by Value.
Public property | Value | Gets or sets the value of the interval.
Top
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval.Unit Property

DateTimeIntervalUnit Property
Gets or sets the unit of time represented by Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<TimeUnit> Unit { get; set; }
Public Property Unit As Nullable(Of TimeUnit)
    Get
    Set

Property Value

Type: Nullable TimeUnit
The unit of time represented by Value.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace
DateTimeIntervalValue


DateTimeInterval.Value Property

DateTimeIntervalValue Property
Gets or sets the value of the interval.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<long> Value { get; set; }
Public Property Value As Nullable(Of Long)
    Get
    Set

Property Value

Type: Nullable Int64
The value of the interval.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace
DateTimeIntervalUnit


DateTimeInterval Methods

DateTimeInterval Methods

The DateTimeInterval type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Public method | ToTimeSpan | Converts the current DateTimeInterval to a TimeSpan.
Top
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval.Equals Method

DateTimeIntervalEquals Method
Determines whether the specified Object is equal to this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval.GetHashCode Method

DateTimeIntervalGetHashCode Method
Returns a hash code for this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval.ToString Method

DateTimeIntervalToString Method
Returns a String that represents this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DateTimeInterval.ToTimeSpan Method

DateTimeIntervalToTimeSpan Method
Converts the current DateTimeInterval to a TimeSpan.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan ToTimeSpan(
    DateTime dateTime
)
Public Function ToTimeSpan (
    dateTime As DateTime
) As TimeSpan

Parameters

dateTime
Type: SystemDateTime

[Missing <param name="dateTime"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.DateTimeInterval.ToTimeSpan(System.DateTime)"]

Return Value

Type: TimeSpan
A TimeSpan from the current DateTimeInterval.
See Also

Reference

DateTimeInterval Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData Class

DesignTimeData Class
Used to display sample chart data at design-time.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesDesignTimeData

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DesignTimeData
Public Class DesignTimeData

The DesignTimeData type exposes the following members.

Constructors
 | Name | Description
Public method | DesignTimeData | Initializes a new instance of the DesignTimeData class
Top
Properties
 | Name | Description
Public property | Title | Gets or sets the title.
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
 | BuildDesignTimeData | Builds design-time data.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData Constructor

DesignTimeData Constructor
Initializes a new instance of the DesignTimeData class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DesignTimeData()
Public Sub New
See Also

Reference

DesignTimeData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData Properties

DesignTimeData Properties

The DesignTimeData type exposes the following members.

Properties
 | Name | Description
Public property | Title | Gets or sets the title.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

DesignTimeData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData.Title Property

DesignTimeDataTitle Property
Gets or sets the title.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title.
See Also

Reference

DesignTimeData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData.Value Property

DesignTimeDataValue Property
Gets or sets the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value.
See Also

Reference

DesignTimeData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData Methods

DesignTimeData Methods

The DesignTimeData type exposes the following members.

Methods
 | Name | Description
 | BuildDesignTimeData | Builds design-time data.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DesignTimeData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


DesignTimeData.BuildDesignTimeData Method

DesignTimeDataBuildDesignTimeData Method
Builds design-time data.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IEnumerable<DesignTimeData> BuildDesignTimeData()
Public Shared Function BuildDesignTimeData As IEnumerable(Of DesignTimeData)

Return Value

Type: IEnumerable DesignTimeData
An IEnumerableT of sample data.
See Also

Reference

DesignTimeData Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual Class

GridVisual Class
Draws a grid behind the chart at major and minor points on the X and Y axis.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesGridVisual

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GridVisual : Control
Public Class GridVisual
    Inherits Control

The GridVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LineMajorBrush | Gets or sets the line major brush.
Public property | LineMajorVisibility | Gets or sets the major line visibility.
Public property | LineMinorBrush | Gets or sets the line minor brush.
Public property | LineMinorVisibility | Gets or sets the minor line visibility.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | StripeAlternatingBrush | Gets or sets the brush used to fill alternate stripes.
Public property | StripeBrush | Gets or sets the brush used to fill stripes.
Public property | StripeVisibility | Gets or sets the stripe visibility.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Clears and redraws the grid.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
LineMajorBrushProperty | Identifies the LineMajorBrush dependency property. This field is read-only.
LineMajorVisibilityProperty | Identifies the LineMajorVisibility dependency property. This field is read-only.
LineMinorBrushProperty | Identifies the LineMinorBrush dependency property. This field is read-only.
LineMinorVisibilityProperty | Identifies the LineMinorVisibility dependency property. This field is read-only.
StripeAlternatingBrushProperty | Identifies the StripeAlternatingBrush dependency property. This field is read-only.
StripeBrushProperty | Identifies the StripeBrush dependency property. This field is read-only.
StripeVisibilityProperty | Identifies the StripeVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual Properties

GridVisual Properties

The GridVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LineMajorBrush | Gets or sets the line major brush.
Public property | LineMajorVisibility | Gets or sets the major line visibility.
Public property | LineMinorBrush | Gets or sets the line minor brush.
Public property | LineMinorVisibility | Gets or sets the minor line visibility.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | StripeAlternatingBrush | Gets or sets the brush used to fill alternate stripes.
Public property | StripeBrush | Gets or sets the brush used to fill stripes.
Public property | StripeVisibility | Gets or sets the stripe visibility.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMajorBrush Property

GridVisualLineMajorBrush Property
Gets or sets the line major brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineMajorBrush { get; set; }
Public Property LineMajorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The line major brush.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMajorVisibility Property

GridVisualLineMajorVisibility Property
Gets or sets the major line visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridLineVisibility LineMajorVisibility { get; set; }
Public Property LineMajorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The major line visibility.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMinorBrush Property

GridVisualLineMinorBrush Property
Gets or sets the line minor brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineMinorBrush { get; set; }
Public Property LineMinorBrush As Brush
    Get
    Set

Property Value

Type: Brush
The line minor brush.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMinorVisibility Property

GridVisualLineMinorVisibility Property
Gets or sets the minor line visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridLineVisibility LineMinorVisibility { get; set; }
Public Property LineMinorVisibility As GridLineVisibility
    Get
    Set

Property Value

Type: GridLineVisibility
The minor line visibility.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.StripeAlternatingBrush Property

GridVisualStripeAlternatingBrush Property
Gets or sets the brush used to fill alternate stripes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush StripeAlternatingBrush { get; set; }
Public Property StripeAlternatingBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill alternate stripes.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.StripeBrush Property

GridVisualStripeBrush Property
Gets or sets the brush used to fill stripes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush StripeBrush { get; set; }
Public Property StripeBrush As Brush
    Get
    Set

Property Value

Type: Brush
The brush used to fill stripes.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.StripeVisibility Property

GridVisualStripeVisibility Property
Gets or sets the stripe visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridStripeVisibility StripeVisibility { get; set; }
Public Property StripeVisibility As GridStripeVisibility
    Get
    Set

Property Value

Type: GridStripeVisibility
The stripe visibility.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual Methods

GridVisual Methods

The GridVisual type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Clears and redraws the grid.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.OnApplyTemplate Method

GridVisualOnApplyTemplate Method
When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.Refresh Method

GridVisualRefresh Method
Clears and redraws the grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    Size plotSize
)
Public Overridable Sub Refresh (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.GridVisual.Refresh(Windows.Foundation.Size)"]

See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual Events

GridVisual Events

The GridVisual type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual Fields

GridVisual Fields

The GridVisual type exposes the following members.

Fields
Name | Description
LineMajorBrushProperty | Identifies the LineMajorBrush dependency property. This field is read-only.
LineMajorVisibilityProperty | Identifies the LineMajorVisibility dependency property. This field is read-only.
LineMinorBrushProperty | Identifies the LineMinorBrush dependency property. This field is read-only.
LineMinorVisibilityProperty | Identifies the LineMinorVisibility dependency property. This field is read-only.
StripeAlternatingBrushProperty | Identifies the StripeAlternatingBrush dependency property. This field is read-only.
StripeBrushProperty | Identifies the StripeBrush dependency property. This field is read-only.
StripeVisibilityProperty | Identifies the StripeVisibility dependency property. This field is read-only.
Top
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMajorBrushProperty Field

GridVisualLineMajorBrushProperty Field
Identifies the LineMajorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMajorBrushProperty
Public Shared ReadOnly LineMajorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMajorBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMajorVisibilityProperty Field

GridVisualLineMajorVisibilityProperty Field
Identifies the LineMajorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMajorVisibilityProperty
Public Shared ReadOnly LineMajorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMajorVisibility dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMinorBrushProperty Field

GridVisualLineMinorBrushProperty Field
Identifies the LineMinorBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMinorBrushProperty
Public Shared ReadOnly LineMinorBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMinorBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.LineMinorVisibilityProperty Field

GridVisualLineMinorVisibilityProperty Field
Identifies the LineMinorVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineMinorVisibilityProperty
Public Shared ReadOnly LineMinorVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineMinorVisibility dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.StripeAlternatingBrushProperty Field

GridVisualStripeAlternatingBrushProperty Field
Identifies the StripeAlternatingBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StripeAlternatingBrushProperty
Public Shared ReadOnly StripeAlternatingBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StripeAlternatingBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.StripeBrushProperty Field

GridVisualStripeBrushProperty Field
Identifies the StripeBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StripeBrushProperty
Public Shared ReadOnly StripeBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StripeBrush dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


GridVisual.StripeVisibilityProperty Field

GridVisualStripeVisibilityProperty Field
Identifies the StripeVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StripeVisibilityProperty
Public Shared ReadOnly StripeVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StripeVisibility dependency property.
See Also

Reference

GridVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Class

InvalidPropertyPathException Class
InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesInvalidPropertyPathException

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvalidPropertyPathException : Exception
Public Class InvalidPropertyPathException
    Inherits Exception

The InvalidPropertyPathException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor

InvalidPropertyPathException Constructor
Overload List
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor

InvalidPropertyPathException Constructor
Initializes a new instance of the InvalidPropertyPathException class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException()
Public Sub New
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor (String)

InvalidPropertyPathException Constructor (String)
Initializes a new instance of the InvalidPropertyPathException class with a specified error message.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Constructor (String, Exception)

InvalidPropertyPathException Constructor (String, Exception)
Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Properties

InvalidPropertyPathException Properties

The InvalidPropertyPathException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


InvalidPropertyPathException Methods

InvalidPropertyPathException Methods

The InvalidPropertyPathException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo Class

LabelInfo Class
Information that describes a data point label.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLabelInfo

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LabelInfo
Public Class LabelInfo

The LabelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LabelInfo | Initializes a new instance of the LabelInfo class
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the angle.
Public property | Color | Gets or sets the color.
Public property | DataPointPosition | Gets or sets the data point position.
Public property | IsAboveBaseline | Gets or sets a value indicating whether this instance is above baseline.
Public property | IsHorizontal | Gets or sets a value indicating whether this instance is horizontal.
Public property | LabelOrigin | Gets the label origin.
Public property | LabelOriginX | Gets or sets the label origin X.
Public property | LabelOriginY | Gets or sets the label origin Y.
Public property | PositioningMode | Gets or sets the positioning mode.
Public property | SeriesIndex | Gets or sets the series index.
Public property | Style | Gets or sets the label style.
Public property | Text | Gets or sets the text.
Public property | Visibility | Gets or sets the visibility.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo Constructor

LabelInfo Constructor
Initializes a new instance of the LabelInfo class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelInfo()
Public Sub New
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo Properties

LabelInfo Properties

The LabelInfo type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the angle.
Public property | Color | Gets or sets the color.
Public property | DataPointPosition | Gets or sets the data point position.
Public property | IsAboveBaseline | Gets or sets a value indicating whether this instance is above baseline.
Public property | IsHorizontal | Gets or sets a value indicating whether this instance is horizontal.
Public property | LabelOrigin | Gets the label origin.
Public property | LabelOriginX | Gets or sets the label origin X.
Public property | LabelOriginY | Gets or sets the label origin Y.
Public property | PositioningMode | Gets or sets the positioning mode.
Public property | SeriesIndex | Gets or sets the series index.
Public property | Style | Gets or sets the label style.
Public property | Text | Gets or sets the text.
Public property | Visibility | Gets or sets the visibility.
Top
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.Angle Property

LabelInfoAngle Property
Gets or sets the angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
The angle.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.Color Property

LabelInfoColor Property
Gets or sets the color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set

Property Value

Type: Color
The color.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.DataPointPosition Property

LabelInfoDataPointPosition Property
Gets or sets the data point position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point DataPointPosition { get; set; }
Public Property DataPointPosition As Point
    Get
    Set

Property Value

Type: Point
The data point position.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.IsAboveBaseline Property

LabelInfoIsAboveBaseline Property
Gets or sets a value indicating whether this instance is above baseline.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAboveBaseline { get; set; }
Public Property IsAboveBaseline As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is above baseline; otherwise, false.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.IsHorizontal Property

LabelInfoIsHorizontal Property
Gets or sets a value indicating whether this instance is horizontal.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHorizontal { get; set; }
Public Property IsHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if this instance is horizontal; otherwise, false.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.LabelOrigin Property

LabelInfoLabelOrigin Property
Gets the label origin.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point LabelOrigin { get; }
Public ReadOnly Property LabelOrigin As Point
    Get

Property Value

Type: Point
The label origin.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.LabelOriginX Property

LabelInfoLabelOriginX Property
Gets or sets the label origin X.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LabelOriginX { get; set; }
Public Property LabelOriginX As Double
    Get
    Set

Property Value

Type: Double
The label origin X.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.LabelOriginY Property

LabelInfoLabelOriginY Property
Gets or sets the label origin Y.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LabelOriginY { get; set; }
Public Property LabelOriginY As Double
    Get
    Set

Property Value

Type: Double
The label origin Y.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.PositioningMode Property

LabelInfoPositioningMode Property
Gets or sets the positioning mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelPositioningMode PositioningMode { get; set; }
Public Property PositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The positioning mode.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.SeriesIndex Property

LabelInfoSeriesIndex Property
Gets or sets the series index.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SeriesIndex { get; set; }
Public Property SeriesIndex As Integer
    Get
    Set

Property Value

Type: Int32
The series index.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.Style Property

LabelInfoStyle Property
Gets or sets the label style.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style Style { get; set; }
Public Property Style As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.Text Property

LabelInfoText Property
Gets or sets the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo.Visibility Property

LabelInfoVisibility Property
Gets or sets the visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelVisibility Visibility { get; set; }
Public Property Visibility As LabelVisibility
    Get
    Set

Property Value

Type: LabelVisibility
The visibility.
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LabelInfo Methods

LabelInfo Methods

The LabelInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LabelInfo Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


Legend Class

Legend Class
The legend control used to display a collection of LegendKey in a chart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLegend

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Legend : ItemsControl
Public Class Legend
    Inherits ItemsControl

The Legend type exposes the following members.

Constructors
 | Name | Description
Public method | Legend | Creates an instance of Legend.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


Legend Constructor

Legend Constructor
Creates an instance of Legend.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Legend()
Public Sub New
See Also

Reference

Legend Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


Legend Properties

Legend Properties

The Legend type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Legend Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


Legend Methods

Legend Methods

The Legend type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Legend Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


Legend Events

Legend Events

The Legend type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Legend Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LegendItem Class

LegendItem Class
Represents an item used in a chart legend.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLegendItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LegendItem
Public Class LegendItem

The LegendItem type exposes the following members.

Constructors
 | Name | Description
Public method | LegendItem | Initializes a new instance of the LegendItem class
Top
Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the ChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LegendItem Constructor

LegendItem Constructor
Initializes a new instance of the LegendItem class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LegendItem()
Public Sub New
See Also

Reference

LegendItem Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LegendItem Properties

LegendItem Properties

The LegendItem type exposes the following members.

Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the ChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
See Also

Reference

LegendItem Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LegendItem.MarkerStyle Property

LegendItemMarkerStyle Property
Gets the Style applied to the ChartMarker used to present the legend item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; }
Public ReadOnly Property MarkerStyle As Style
    Get

Property Value

Type: Style
See Also

Reference

LegendItem Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LegendItem.Text Property

LegendItemText Property
Gets a description of the legend item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

LegendItem Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LegendItem Methods

LegendItem Methods

The LegendItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LegendItem Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase Class

LineSeriesBase Class
Represents a base class for line and area series for use in a XYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsAreaSeries
ActiproSoftware.UI.Xaml.Controls.ChartsLineSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class LineSeriesBase : XYSeriesBase
Public MustInherit Class LineSeriesBase
    Inherits XYSeriesBase

The LineSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LineSeriesBase | Initializes a new instance of the LineSeriesBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase Constructor

LineSeriesBase Constructor
Initializes a new instance of the LineSeriesBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected LineSeriesBase()
Protected Sub New
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase Properties

LineSeriesBase Properties

The LineSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series. (Inherited from XYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelPositioningMode | Gets or sets the LabelPositioningMode used to determine how labels are laid out.
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | LineKind | Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides XYSeriesBaseMinimumMargin.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from XYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property. (Inherited from XYSeriesBase.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from XYSeriesBase.)
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.LabelPositioningMode Property

LineSeriesBaseLabelPositioningMode Property
Gets or sets the LabelPositioningMode used to determine how labels are laid out.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual LabelPositioningMode LabelPositioningMode { get; set; }
Public Overridable Property LabelPositioningMode As LabelPositioningMode
    Get
    Set

Property Value

Type: LabelPositioningMode
The label positioning mode. The default value is FromAverage.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.LineKind Property

LineSeriesBaseLineKind Property
Gets or sets a XYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYSeriesLineKind LineKind { get; set; }
Public Property LineKind As XYSeriesLineKind
    Get
    Set

Property Value

Type: XYSeriesLineKind
A XYSeriesLineKind, which indicates what kind of line should be rendered by the series. The default value is XYSeriesLineKind.Normal.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.LineStyle Property

LineSeriesBaseLineStyle Property
Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LineStyle { get; set; }
Public Property LineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.MarkerVisibility Property

LineSeriesBaseMarkerVisibility Property
Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As ChartMarkerVisibility
    Get
    Set

Property Value

Type: ChartMarkerVisibility
A ChartMarkerVisibility indicating which markers are rendered along the series. The default value is ChartMarkerVisibility.None.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.MinimumMargin Property

LineSeriesBaseMinimumMargin Property
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> MinimumMargin { get; }
Protected Overrides ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase Methods

LineSeriesBase Methods

The LineSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from XYSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from XYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase Events

LineSeriesBase Events

The LineSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed. (Inherited from XYSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase Fields

LineSeriesBase Fields

The LineSeriesBase type exposes the following members.

Fields
Name | Description
LabelPositioningModeProperty | Identifies the LabelPositioningMode dependency property. This field is read-only.
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.LabelPositioningModeProperty Field

LineSeriesBaseLabelPositioningModeProperty Field
Identifies the LabelPositioningMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositioningModeProperty
Public Shared ReadOnly LabelPositioningModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPositioningMode dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.LineKindProperty Field

LineSeriesBaseLineKindProperty Field
Identifies the LineKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineKindProperty
Public Shared ReadOnly LineKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineKind dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.LineStyleProperty Field

LineSeriesBaseLineStyleProperty Field
Identifies the LineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineStyleProperty
Public Shared ReadOnly LineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineStyle dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


LineSeriesBase.MarkerVisibilityProperty Field

LineSeriesBaseMarkerVisibilityProperty Field
Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

LineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice Class

PieSlice Class
A single pie slice in a pie series.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesPieSlice

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PieSlice : Control
Public Class PieSlice
    Inherits Control

The PieSlice type exposes the following members.

Constructors
 | Name | Description
Public method | PieSlice | Initializes a new instance of the PieSlice class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CollisionPolygon | Gets the collision polygon.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DrawingBounds | Gets or sets the drawing bounds.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EndAngle | Gets the end angle.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HoleRadius | Gets or sets the hole radius.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelPosition | Gets or sets the label position.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OriginalItems | Gets the original items.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathData | Gets or sets the path data.
Public property | Percentage | Gets or sets the percentage.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Values | Gets the values.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetTetherEndPoint | Gets the tether end point.
Public method | GetTetherStartPoint | Gets the tether start point.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DrawingBoundsProperty | Identifies the DrawingBounds dependency property. This field is read-only.
HoleRadiusProperty | Identifies the HoleRadius dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
PathDataProperty | Identifies the PathData dependency property. This field is read-only.
PercentageProperty | Identifies the Percentage dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice Constructor

PieSlice Constructor
Initializes a new instance of the PieSlice class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSlice()
Public Sub New
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice Properties

PieSlice Properties

The PieSlice type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CollisionPolygon | Gets the collision polygon.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DrawingBounds | Gets or sets the drawing bounds.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EndAngle | Gets the end angle.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HoleRadius | Gets or sets the hole radius.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelPosition | Gets or sets the label position.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OriginalItems | Gets the original items.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathData | Gets or sets the path data.
Public property | Percentage | Gets or sets the percentage.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | StartAngle | Gets or sets the start angle.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Values | Gets the values.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.CollisionPolygon Property

PieSliceCollisionPolygon Property
Gets the collision polygon.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<Point> CollisionPolygon { get; }
Public ReadOnly Property CollisionPolygon As IEnumerable(Of Point)
    Get

Property Value

Type: IEnumerable Point
The collision polygon.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.DrawingBounds Property

PieSliceDrawingBounds Property
Gets or sets the drawing bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect DrawingBounds { get; set; }
Public Property DrawingBounds As Rect
    Get
    Set

Property Value

Type: Rect
The drawing bounds.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.EndAngle Property

PieSliceEndAngle Property
Gets the end angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double EndAngle { get; }
Public ReadOnly Property EndAngle As Double
    Get

Property Value

Type: Double
The end angle.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.HoleRadius Property

PieSliceHoleRadius Property
Gets or sets the hole radius.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double HoleRadius { get; set; }
Public Property HoleRadius As Double
    Get
    Set

Property Value

Type: Double
The hole radius.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.LabelPosition Property

PieSliceLabelPosition Property
Gets or sets the label position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PieSliceLabelPosition LabelPosition { get; set; }
Public Property LabelPosition As PieSliceLabelPosition
    Get
    Set

Property Value

Type: PieSliceLabelPosition
The label position.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.OriginalItems Property

PieSliceOriginalItems Property
Gets the original items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Object> OriginalItems { get; }
Public ReadOnly Property OriginalItems As IList(Of Object)
    Get

Property Value

Type: IList Object
The original items.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.PathData Property

PieSlicePathData Property
Gets or sets the path data.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Geometry PathData { get; set; }
Public Property PathData As Geometry
    Get
    Set

Property Value

Type: Geometry
The path data.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.Percentage Property

PieSlicePercentage Property
Gets or sets the percentage.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Percentage { get; set; }
Public Property Percentage As Double
    Get
    Set

Property Value

Type: Double
The percentage.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.Radius Property

PieSliceRadius Property
Gets or sets the radius.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The radius.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.StartAngle Property

PieSliceStartAngle Property
Gets or sets the start angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set

Property Value

Type: Double
The start angle.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.Title Property

PieSliceTitle Property
Gets or sets the title.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.Values Property

PieSliceValues Property
Gets the values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<Object> Values { get; }
Public ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The values.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice Methods

PieSlice Methods

The PieSlice type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetTetherEndPoint | Gets the tether end point.
Public method | GetTetherStartPoint | Gets the tether start point.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.GetTetherEndPoint Method

PieSliceGetTetherEndPoint Method
Gets the tether end point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point GetTetherEndPoint(
    Rect drawingBounds
)
Public Function GetTetherEndPoint (
    drawingBounds As Rect
) As Point

Parameters

drawingBounds
Type: Windows.FoundationRect
The drawing bounds.

Return Value

Type: Point
A Point where the tether ends.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.GetTetherStartPoint Method

PieSliceGetTetherStartPoint Method
Gets the tether start point.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point GetTetherStartPoint(
    Rect drawingBounds
)
Public Function GetTetherStartPoint (
    drawingBounds As Rect
) As Point

Parameters

drawingBounds
Type: Windows.FoundationRect
The drawing bounds.

Return Value

Type: Point
A Point where the tether starts.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.MeasureOverride Method

PieSliceMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.
Top
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.MeasureOverride Method (Size)

PieSliceMeasureOverride Method (Size)
Provides the behavior for the Measure pass of layout. Classes can override this method to define their own Measure pass behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this object can give to child objects. Infinity (PositiveInfinity) can be specified as a value to indicate that the object will size to whatever content is available.

Return Value

Type: Size
The size that this object determines it needs during layout, based on its calculations of the allocated sizes for child objects; or based on other considerations, such as a fixed container size.
See Also

Reference

PieSlice Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.OnApplyTemplate Method

PieSliceOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice Events

PieSlice Events

The PieSlice type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice Fields

PieSlice Fields

The PieSlice type exposes the following members.

Fields
Name | Description
DrawingBoundsProperty | Identifies the DrawingBounds dependency property. This field is read-only.
HoleRadiusProperty | Identifies the HoleRadius dependency property. This field is read-only.
LabelPositionProperty | Identifies the LabelPosition dependency property. This field is read-only.
PathDataProperty | Identifies the PathData dependency property. This field is read-only.
PercentageProperty | Identifies the Percentage dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
StartAngleProperty | Identifies the StartAngle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
Top
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.DrawingBoundsProperty Field

PieSliceDrawingBoundsProperty Field
Identifies the DrawingBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DrawingBoundsProperty
Public Shared ReadOnly DrawingBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DrawingBounds dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.HoleRadiusProperty Field

PieSliceHoleRadiusProperty Field
Identifies the HoleRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HoleRadiusProperty
Public Shared ReadOnly HoleRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HoleRadius dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.LabelPositionProperty Field

PieSliceLabelPositionProperty Field
Identifies the LabelPosition dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelPositionProperty
Public Shared ReadOnly LabelPositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelPosition dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.PathDataProperty Field

PieSlicePathDataProperty Field
Identifies the PathData dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PathDataProperty
Public Shared ReadOnly PathDataProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PathData dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.PercentageProperty Field

PieSlicePercentageProperty Field
Identifies the Percentage dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PercentageProperty
Public Shared ReadOnly PercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Percentage dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.RadiusProperty Field

PieSliceRadiusProperty Field
Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.StartAngleProperty Field

PieSliceStartAngleProperty Field
Identifies the StartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StartAngleProperty
Public Shared ReadOnly StartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StartAngle dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


PieSlice.TitleProperty Field

PieSliceTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

PieSlice Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase Class

SeriesBase Class
Provides the base class for a series.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class SeriesBase : Control
Public MustInherit Class SeriesBase
    Inherits Control

The SeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SeriesBase | Initializes a new instance of the SeriesBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property.
Public property | LabelAngle | Gets or sets the label angle.
Public property | LabelFormat | Gets or sets the label format.
Public property | LabelFunc | Gets or sets the label function.
Public property | LabelStyle | Gets or sets the label style.
Public property | LabelVisibility | Gets or sets the label visibility.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LogicalOrientation | Gets the logical orientation of the series.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase Constructor

SeriesBase Constructor
Initializes a new instance of the SeriesBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected SeriesBase()
Protected Sub New
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase Properties

SeriesBase Properties

The SeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property.
Public property | LabelAngle | Gets or sets the label angle.
Public property | LabelFormat | Gets or sets the label format.
Public property | LabelFunc | Gets or sets the label function.
Public property | LabelStyle | Gets or sets the label style.
Public property | LabelVisibility | Gets or sets the label visibility.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LogicalOrientation | Gets the logical orientation of the series.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.Index Property

SeriesBaseIndex Property
Gets the index of this series in the associated chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of this series in the associated chart. The default value is -1.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.ItemsSource Property

SeriesBaseItemsSource Property
Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ItemsSource { get; set; }
Public Property ItemsSource As Object
    Get
    Set

Property Value

Type: Object
A collection used to generate the data points of the SeriesBase. The default value is .
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.LabelAngle Property

SeriesBaseLabelAngle Property
Gets or sets the label angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LabelAngle { get; set; }
Public Property LabelAngle As Double
    Get
    Set

Property Value

Type: Double
The label angle.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.LabelFormat Property

SeriesBaseLabelFormat Property
Gets or sets the label format.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LabelFormat { get; set; }
Public Property LabelFormat As String
    Get
    Set

Property Value

Type: String
The label format.
Remarks
The format string will be passed the following parameters:
  • {0} is the value on the primary axis.
  • {1} is the value on the secondary axis.
  • {2} is the value on the X axis.
  • {3} is the value on the Y axis.
The format is ignored if LabelFunc is specified.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.LabelFunc Property

SeriesBaseLabelFunc Property
Gets or sets the label function.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<Object, Object, Object, Object, Object, string> LabelFunc { get; set; }
Public Property LabelFunc As Func(Of Object, Object, Object, Object, Object, String)
    Get
    Set

Property Value

Type: Func Object, Object, Object, Object, Object, String
The label function.
Remarks
This is a Func that determines what the label text will be. The parameters are primary axis value, secondary axis value, X axis value, Y axis value, and original value.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.LabelStyle Property

SeriesBaseLabelStyle Property
Gets or sets the label style.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LabelStyle { get; set; }
Public Property LabelStyle As Style
    Get
    Set

Property Value

Type: Style
The label style.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.LabelVisibility Property

SeriesBaseLabelVisibility Property
Gets or sets the label visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LabelVisibility LabelVisibility { get; set; }
Public Property LabelVisibility As LabelVisibility
    Get
    Set

Property Value

Type: LabelVisibility
The label visibility.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.LogicalOrientation Property

SeriesBaseLogicalOrientation Property
Gets the logical orientation of the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Orientation LogicalOrientation { get; }
Public Overridable ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase Methods

SeriesBase Methods

The SeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.GetLabelText Method

SeriesBaseGetLabelText Method
Gets the label text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string GetLabelText(
    Object primaryValue,
    Object secondaryValue,
    Object xValue,
    Object yValue,
    Object originalValue
)
Protected Overridable Function GetLabelText (
    primaryValue As Object,
    secondaryValue As Object,
    xValue As Object,
    yValue As Object,
    originalValue As Object
) As String

Parameters

primaryValue
Type: SystemObject
The primary value.
secondaryValue
Type: SystemObject
The secondary value.
xValue
Type: SystemObject
The x value.
yValue
Type: SystemObject
The y value.
originalValue
Type: SystemObject
The original value.

Return Value

Type: String
The text to apply to the label.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.OnItemsSourceChanged Method

SeriesBaseOnItemsSourceChanged Method
Occurs when the ItemsSource value is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the ItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the ItemsSource property.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.OnItemsSourceCollectionChanged Method

SeriesBaseOnItemsSourceCollectionChanged Method
Handles the CollectionChanged event of the ItemsSource collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceCollectionChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnItemsSourceCollectionChanged (
    sender As Object,
    e As NotifyCollectionChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
The NotifyCollectionChangedEventArgs instance containing the event data.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.Refresh Method

SeriesBaseRefresh Method
Updates the series based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Refresh()
Public MustOverride Sub Refresh
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase Events

SeriesBase Events

The SeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase Fields

SeriesBase Fields

The SeriesBase type exposes the following members.

Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.IndexProperty Field

SeriesBaseIndexProperty Field
Identifies the read-only Index dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndexProperty
Public Shared ReadOnly IndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Index dependency property.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesBase.ItemsSourceProperty Field

SeriesBaseItemsSourceProperty Field
Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

SeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter Class

SeriesItemsSourceConverter Class
Represents a type converter for the ItemsSource type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesItemsSourceConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SeriesItemsSourceConverter
Public NotInheritable Class SeriesItemsSourceConverter

The SeriesItemsSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesItemsSourceConverter | Initializes a new instance of the SeriesItemsSourceConverter class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter Constructor

SeriesItemsSourceConverter Constructor
Initializes a new instance of the SeriesItemsSourceConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SeriesItemsSourceConverter()
Public Sub New
See Also

Reference

SeriesItemsSourceConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


SeriesItemsSourceConverter Methods

SeriesItemsSourceConverter Methods

The SeriesItemsSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SeriesItemsSourceConverter Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual Class

XAxisVisual Class
Draws an axis given axis data.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesAxisVisual
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXAxisVisual

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XAxisVisual : AxisVisual
Public Class XAxisVisual
    Inherits AxisVisual

The XAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual Properties

XAxisVisual Properties

The XAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual Methods

XAxisVisual Methods

The XAxisVisual type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.ArrangeOverride Method

XAxisVisualArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.ArrangeOverride Method (Size)

XAxisVisualArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

XAxisVisual Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.DrawMajorTickAtPosition Method

XAxisVisualDrawMajorTickAtPosition Method
Draws a major tick at a given position on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void DrawMajorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMajorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.DrawMinorTickAtPosition Method

XAxisVisualDrawMinorTickAtPosition Method
Draws a minor tick at a given position on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void DrawMinorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMinorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.DrawSpine Method

XAxisVisualDrawSpine Method
Draws an axis spine.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void DrawSpine(
    Size plotSize
)
Protected Overrides Sub DrawSpine (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.XAxisVisual.DrawSpine(Windows.Foundation.Size)"]

See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.GetTitleTemplateFromResources Method

XAxisVisualGetTitleTemplateFromResources Method
Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate GetTitleTemplateFromResources(
    ResourceDictionary resources
)
Protected Overrides Function GetTitleTemplateFromResources (
    resources As ResourceDictionary
) As DataTemplate

Parameters

resources
Type: Windows.UI.XamlResourceDictionary
The ResourceDictionary to retrieve the title template from.

Return Value

Type: DataTemplate
The template for the axis title.
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.MeasureOverride Method

XAxisVisualMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.MeasureOverride Method (Size)

XAxisVisualMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a argumentValue to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

XAxisVisual Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.PlaceLabelAtPosition Method

XAxisVisualPlaceLabelAtPosition Method
Place the axis label at the given position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PlaceLabelAtPosition(
    TextBlock label,
    double position,
    double angle,
    Size plotSize
)
Protected Overrides Sub PlaceLabelAtPosition (
    label As TextBlock,
    position As Double,
    angle As Double,
    plotSize As Size
)

Parameters

label
Type: Windows.UI.Xaml.ControlsTextBlock
The axis label to lay out.
position
Type: SystemDouble
The position to draw the axis label at.
angle
Type: SystemDouble
The angle to draw the axis label at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
Exceptions
Exception | Condition
ArgumentNullException | label
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual.UpdateTitlePosition Method

XAxisVisualUpdateTitlePosition Method
Updates the title position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateTitlePosition(
    Size plotSize
)
Protected Overrides Sub UpdateTitlePosition (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.XAxisVisual.UpdateTitlePosition(Windows.Foundation.Size)"]

See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XAxisVisual Events

XAxisVisual Events

The XAxisVisual type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase Class

XYAxisBase Class
Represents the base functionality of a chart axis.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYAxisBase
ActiproSoftware.UI.Xaml.Controls.ChartsXYDateTimeAxis
ActiproSoftware.UI.Xaml.Controls.ChartsXYDecimalAxisBaseT
ActiproSoftware.UI.Xaml.Controls.ChartsXYDoubleAxis
ActiproSoftware.UI.Xaml.Controls.ChartsXYGroupedAxis
ActiproSoftware.UI.Xaml.Controls.ChartsXYPercentageAxis

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XYAxisBase : Control
Public MustInherit Class XYAxisBase
    Inherits Control

The XYAxisBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible.
Public property | AreMajorTicksVisible | Whether or not major ticks are visible.
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible.
Public property | AxisType | The type of data on the axis.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels.
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path.
Public property | Title | Gets or sets the axis title.
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
 | OnPropertyChanged | Called when property changed.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
AreMajorTicksVisibleProperty | Identifies the AreMajorTicksVisible dependency property. This field is read-only.
AreMinorTicksVisibleProperty | Identifies the AreMinorTicksVisible dependency property. This field is read-only.
BarGroupSpacingProperty | Identifies the BarGroupSpacing dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
LabelAngleProperty | Identifies the LabelAngle dependency property. This field is read-only.
LabelFormatProperty | Identifies the LabelFormat dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
PositionProperty | Identifies the Position dependency property. This field is read-only.
TickMajorStyleProperty | Identifies the TickMajorStyle dependency property. This field is read-only.
TickMinorStyleProperty | Identifies the TickMinorStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TitleStyleProperty | Identifies the TitleStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase Properties

XYAxisBase Properties

The XYAxisBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreLabelsVisible | Whether or not axis labels are visible.
Public property | AreMajorTicksVisible | Whether or not major ticks are visible.
Public property | AreMinorTicksVisible | Whether or not minor ticks are visible.
Public property | AxisType | The type of data on the axis.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarGroupSpacing | Gets or sets the bar group spacing.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | LabelAngle | The angle at which to draw the axis labels.
Public property | LabelFormat | Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property.
Public property | LabelStyle | The style to apply to axis labels. TargetType of the Style must be a TextBlock.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Position | Gets or sets the axis position.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TickMajorStyle | The style to apply to major ticks. TargetType of the Style must be a Path.
Public property | TickMinorStyle | The style to apply to minor ticks. TargetType of the Style must be a Path.
Public property | Title | Gets or sets the axis title.
Public property | TitleStyle | Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AreLabelsVisible Property

XYAxisBaseAreLabelsVisible Property
Whether or not axis labels are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreLabelsVisible { get; set; }
Public Property AreLabelsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AreMajorTicksVisible Property

XYAxisBaseAreMajorTicksVisible Property
Whether or not major ticks are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreMajorTicksVisible { get; set; }
Public Property AreMajorTicksVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AreMinorTicksVisible Property

XYAxisBaseAreMinorTicksVisible Property
Whether or not minor ticks are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreMinorTicksVisible { get; set; }
Public Property AreMinorTicksVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AxisType Property

XYAxisBaseAxisType Property
The type of data on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type AxisType { get; }
Public ReadOnly Property AxisType As Type
    Get

Property Value

Type: Type
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.BarGroupSpacing Property

XYAxisBaseBarGroupSpacing Property
Gets or sets the bar group spacing.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit BarGroupSpacing { get; set; }
Public Property BarGroupSpacing As Unit
    Get
    Set

Property Value

Type: Unit
The bar group spacing.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.BarSpacing Property

XYAxisBaseBarSpacing Property
Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit BarSpacing { get; set; }
Public Property BarSpacing As Unit
    Get
    Set

Property Value

Type: Unit
The amount of spacing applied to either side of the individual bar shapes. The default value is 1px.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.LabelAngle Property

XYAxisBaseLabelAngle Property
The angle at which to draw the axis labels.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LabelAngle { get; set; }
Public Property LabelAngle As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.LabelFormat Property

XYAxisBaseLabelFormat Property
Gets or sets the string format used when presenting a label on an axis tick. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LabelFormat { get; set; }
Public Property LabelFormat As String
    Get
    Set

Property Value

Type: String
The string format used when presenting a label on an axis tick.
Remarks
The format string will be passed the following parameters:
  • {0} - The value of the axis tick, or null when the axis is slotted, such as on a bar chart. -
  • {1} - The starting value of the current slot when the axis is slotted, such as on a bar chart. Otherwise, null. -
  • {2} - The ending value of the current slot when the axis is slotted, such as on a bar chart. Otherwise, null. -
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.LabelStyle Property

XYAxisBaseLabelStyle Property
The style to apply to axis labels. TargetType of the Style must be a TextBlock.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LabelStyle { get; set; }
Public Property LabelStyle As Style
    Get
    Set

Property Value

Type: Style
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.Position Property

XYAxisBasePosition Property
Gets or sets the axis position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AxisPosition Position { get; set; }
Public Property Position As AxisPosition
    Get
    Set

Property Value

Type: AxisPosition
The axis position.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.Ranges Property

XYAxisBaseRanges Property
Gets the collection of ranges displayed by this chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYRangeCollection Ranges { get; }
Public ReadOnly Property Ranges As XYRangeCollection
    Get

Property Value

Type: XYRangeCollection
The collection of ranges displayed by this chart.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TickMajorStyle Property

XYAxisBaseTickMajorStyle Property
The style to apply to major ticks. TargetType of the Style must be a Path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TickMajorStyle { get; set; }
Public Property TickMajorStyle As Style
    Get
    Set

Property Value

Type: Style
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TickMinorStyle Property

XYAxisBaseTickMinorStyle Property
The style to apply to minor ticks. TargetType of the Style must be a Path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TickMinorStyle { get; set; }
Public Property TickMinorStyle As Style
    Get
    Set

Property Value

Type: Style
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.Title Property

XYAxisBaseTitle Property
Gets or sets the axis title.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Title { get; set; }
Public Property Title As Object
    Get
    Set

Property Value

Type: Object
The title displayed on the axis.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TitleStyle Property

XYAxisBaseTitleStyle Property
Gets or sets the style to apply to the axis title. TargetType of the Style must be a ContentPresenter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TitleStyle { get; set; }
Public Property TitleStyle As Style
    Get
    Set

Property Value

Type: Style
The style to apply to the axis title.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase Methods

XYAxisBase Methods

The XYAxisBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
 | OnPropertyChanged | Called when property changed.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.OnApplyTemplate Method

XYAxisBaseOnApplyTemplate Method
When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.OnPropertyChanged Method

XYAxisBaseOnPropertyChanged Method
Called when property changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static void OnPropertyChanged(
    DependencyObject sender,
    DependencyPropertyChangedEventArgs args
)
Protected Shared Sub OnPropertyChanged (
    sender As DependencyObject,
    args As DependencyPropertyChangedEventArgs
)

Parameters

sender
Type: Windows.UI.XamlDependencyObject
The sender.
args
Type: Windows.UI.XamlDependencyPropertyChangedEventArgs
The DependencyPropertyChangedEventArgs instance containing the event data.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase Events

XYAxisBase Events

The XYAxisBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when XYAxisBase is refershed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.Refreshed Event

XYAxisBaseRefreshed Event
Occurs when XYAxisBase is refershed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Refreshed
Public Event Refreshed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase Fields

XYAxisBase Fields

The XYAxisBase type exposes the following members.

Fields
Name | Description
AreLabelsVisibleProperty | Identifies the AreLabelsVisible dependency property. This field is read-only.
AreMajorTicksVisibleProperty | Identifies the AreMajorTicksVisible dependency property. This field is read-only.
AreMinorTicksVisibleProperty | Identifies the AreMinorTicksVisible dependency property. This field is read-only.
BarGroupSpacingProperty | Identifies the BarGroupSpacing dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
LabelAngleProperty | Identifies the LabelAngle dependency property. This field is read-only.
LabelFormatProperty | Identifies the LabelFormat dependency property. This field is read-only.
LabelStyleProperty | Identifies the LabelStyle dependency property. This field is read-only.
PositionProperty | Identifies the Position dependency property. This field is read-only.
TickMajorStyleProperty | Identifies the TickMajorStyle dependency property. This field is read-only.
TickMinorStyleProperty | Identifies the TickMinorStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TitleStyleProperty | Identifies the TitleStyle dependency property. This field is read-only.
Top
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AreLabelsVisibleProperty Field

XYAxisBaseAreLabelsVisibleProperty Field
Identifies the AreLabelsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreLabelsVisibleProperty
Public Shared ReadOnly AreLabelsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreLabelsVisible dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AreMajorTicksVisibleProperty Field

XYAxisBaseAreMajorTicksVisibleProperty Field
Identifies the AreMajorTicksVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreMajorTicksVisibleProperty
Public Shared ReadOnly AreMajorTicksVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreMajorTicksVisible dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.AreMinorTicksVisibleProperty Field

XYAxisBaseAreMinorTicksVisibleProperty Field
Identifies the AreMinorTicksVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreMinorTicksVisibleProperty
Public Shared ReadOnly AreMinorTicksVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreMinorTicksVisible dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.BarGroupSpacingProperty Field

XYAxisBaseBarGroupSpacingProperty Field
Identifies the BarGroupSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarGroupSpacingProperty
Public Shared ReadOnly BarGroupSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarGroupSpacing dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.BarSpacingProperty Field

XYAxisBaseBarSpacingProperty Field
Identifies the BarSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarSpacingProperty
Public Shared ReadOnly BarSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarSpacing dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.LabelAngleProperty Field

XYAxisBaseLabelAngleProperty Field
Identifies the LabelAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelAngleProperty
Public Shared ReadOnly LabelAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFormat dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.LabelFormatProperty Field

XYAxisBaseLabelFormatProperty Field
Identifies the LabelFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelFormatProperty
Public Shared ReadOnly LabelFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelFormat dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.LabelStyleProperty Field

XYAxisBaseLabelStyleProperty Field
Identifies the LabelStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LabelStyleProperty
Public Shared ReadOnly LabelStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LabelStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.PositionProperty Field

XYAxisBasePositionProperty Field
Identifies the Position dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PositionProperty
Public Shared ReadOnly PositionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Position dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TickMajorStyleProperty Field

XYAxisBaseTickMajorStyleProperty Field
Identifies the TickMajorStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMajorStyleProperty
Public Shared ReadOnly TickMajorStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMajorStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TickMinorStyleProperty Field

XYAxisBaseTickMinorStyleProperty Field
Identifies the TickMinorStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TickMinorStyleProperty
Public Shared ReadOnly TickMinorStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TickMinorStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TitleProperty Field

XYAxisBaseTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYAxisBase.TitleStyleProperty Field

XYAxisBaseTitleStyleProperty Field
Identifies the TitleStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleStyleProperty
Public Shared ReadOnly TitleStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleStyle dependency property.
See Also

Reference

XYAxisBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase Class

XYSeriesBase Class
Provides the base class for a series that uses an X/Y axis.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.ChartsScatterSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XYSeriesBase : SeriesBase
Public MustInherit Class XYSeriesBase
    Inherits SeriesBase

The XYSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | XYSeriesBase | Initializes a new instance of the XYSeriesBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property.
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property.
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Overrides SeriesBaseRefresh.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XAxisProperty | Identifies the XAxis dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YAxisProperty | Identifies the YAxis dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase Constructor

XYSeriesBase Constructor
Initializes a new instance of the XYSeriesBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected XYSeriesBase()
Protected Sub New
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase Properties

XYSeriesBase Properties

The XYSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the XYChart that owns this series.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from SeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the SeriesBase. This is a dependency property. (Inherited from SeriesBase.)
Public property | LabelAngle | Gets or sets the label angle. (Inherited from SeriesBase.)
Public property | LabelFormat | Gets or sets the label format. (Inherited from SeriesBase.)
Public property | LabelFunc | Gets or sets the label function. (Inherited from SeriesBase.)
Public property | LabelStyle | Gets or sets the label style. (Inherited from SeriesBase.)
Public property | LabelVisibility | Gets or sets the label visibility. (Inherited from SeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Public property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from SeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | MinimumMargin | Gets the minimum margin around the plotted area required by the series.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis to be used for this series. This is a dependency property.
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxis | Gets or sets the Y axis to be used for this series. This is a dependency property.
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.AggregationFactor Property

XYSeriesBaseAggregationFactor Property
Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AggregationFactor { get; set; }
Public Property AggregationFactor As Double
    Get
    Set

Property Value

Type: Double
A factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. The default value is 0.2.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.Chart Property

XYSeriesBaseChart Property
Gets the XYChart that owns this series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYChart Chart { get; }
Public ReadOnly Property Chart As XYChart
    Get

Property Value

Type: XYChart
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.Description Property

XYSeriesBaseDescription Property
Gets or sets a description of the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
A description of the series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.IsAggregationEnabled Property

XYSeriesBaseIsAggregationEnabled Property
Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAggregationEnabled { get; set; }
Public Property IsAggregationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data points will be an aggregation of the source data; otherwise, false. The default value is true.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendMarkerStyle Property

XYSeriesBaseLegendMarkerStyle Property
Gets or sets a Style, which is applied to the ChartMarker element used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LegendMarkerStyle { get; set; }
Public Property LegendMarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the ChartMarker used when presenting a legend item for the series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendStringFormat Property

XYSeriesBaseLegendStringFormat Property
Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format used when presenting legend item for the series. The default value is "{0}".
Remarks
The format string will be passed the following parameters:
  • {0} - The value of the primary axis. -
  • {1} - The value of the secondary axis. -
  • {2} - The X value. -
  • {3} - The Y value. -
  • {4} - Reserved. -
  • {5} - Description. -
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.MarkerStyle Property

XYSeriesBaseMarkerStyle Property
Gets or sets a Style, which is applied to the ChartMarker elements used to render the markers along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; set; }
Public Property MarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the ChartMarker used to render the markers along the series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.MinimumMargin Property

XYSeriesBaseMinimumMargin Property
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Nullable<Thickness> MinimumMargin { get; }
Protected Overridable ReadOnly Property MinimumMargin As Nullable(Of Thickness)
    Get

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.PrimaryAggregationKind Property

XYSeriesBasePrimaryAggregationKind Property
Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AggregationKind PrimaryAggregationKind { get; set; }
Public Property PrimaryAggregationKind As AggregationKind
    Get
    Set

Property Value

Type: AggregationKind
A AggregationKind indicating which kind of aggregation to perform along the primary axis. The default value is AggregationKind.Average.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.RequiresSlottedLayout Property

XYSeriesBaseRequiresSlottedLayout Property
Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool RequiresSlottedLayout { get; }
Public Overridable ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.SecondaryAggregationKind Property

XYSeriesBaseSecondaryAggregationKind Property
Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AggregationKind SecondaryAggregationKind { get; set; }
Public Property SecondaryAggregationKind As AggregationKind
    Get
    Set

Property Value

Type: AggregationKind
A AggregationKind indicating which kind of aggregation to perform along the secondary axis. The default value is AggregationKind.First.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.StackKind Property

XYSeriesBaseStackKind Property
Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYSeriesStackKind StackKind { get; set; }
Public Property StackKind As XYSeriesStackKind
    Get
    Set

Property Value

Type: XYSeriesStackKind
The kind of stacking applied to the series. The default value is XYSeriesStackKind.None.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.XAxis Property

XYSeriesBaseXAxis Property
Gets or sets the X axis to be used for this series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYAxisBase XAxis { get; set; }
Public Property XAxis As XYAxisBase
    Get
    Set

Property Value

Type: XYAxisBase
The X axis to be used for this series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.XPath Property

XYSeriesBaseXPath Property
Gets or sets the path to the item property represented along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string XPath { get; set; }
Public Property XPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the X-axis. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.YAxis Property

XYSeriesBaseYAxis Property
Gets or sets the Y axis to be used for this series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XYAxisBase YAxis { get; set; }
Public Property YAxis As XYAxisBase
    Get
    Set

Property Value

Type: XYAxisBase
The Y axis to be used for this series. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.YPath Property

XYSeriesBaseYPath Property
Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string YPath { get; set; }
Public Property YPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the Y-axis. The default value is .
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase Methods

XYSeriesBase Methods

The XYSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetLabelText | Gets the label text. (Inherited from SeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from SeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from SeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Overrides SeriesBaseRefresh.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.NormalizeValue Method

XYSeriesBaseNormalizeValue Method
Normalizes the value using the specified baseline

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Object NormalizeValue(
    Object value,
    Object baselineValue
)
Protected Overridable Function NormalizeValue (
    value As Object,
    baselineValue As Object
) As Object

Parameters

value
Type: SystemObject
The value to normalize.
baselineValue
Type: SystemObject
The baseline value.

Return Value

Type: Object
A normalized value.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.Refresh Method

XYSeriesBaseRefresh Method
Updates the series based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase Events

XYSeriesBase Events

The XYSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | Refreshed | Occurs when the series is refreshed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.Refreshed Event

XYSeriesBaseRefreshed Event
Occurs when the series is refreshed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Refreshed
Public Event Refreshed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase Fields

XYSeriesBase Fields

The XYSeriesBase type exposes the following members.

Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XAxisProperty | Identifies the XAxis dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YAxisProperty | Identifies the YAxis dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.AggregationFactorProperty Field

XYSeriesBaseAggregationFactorProperty Field
Identifies the AggregationFactor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AggregationFactorProperty
Public Shared ReadOnly AggregationFactorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AggregationFactor dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.DescriptionProperty Field

XYSeriesBaseDescriptionProperty Field
Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.IsAggregationEnabledProperty Field

XYSeriesBaseIsAggregationEnabledProperty Field
Identifies the IsAggregationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAggregationEnabledProperty
Public Shared ReadOnly IsAggregationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAggregationEnabled dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendMarkerStyleProperty Field

XYSeriesBaseLegendMarkerStyleProperty Field
Identifies the LegendMarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendMarkerStyleProperty
Public Shared ReadOnly LegendMarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendMarkerStyle dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.LegendStringFormatProperty Field

XYSeriesBaseLegendStringFormatProperty Field
Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.MarkerStyleProperty Field

XYSeriesBaseMarkerStyleProperty Field
Identifies the MarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleProperty
Public Shared ReadOnly MarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyle dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.PrimaryAggregationKindProperty Field

XYSeriesBasePrimaryAggregationKindProperty Field
Identifies the PrimaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryAggregationKindProperty
Public Shared ReadOnly PrimaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryAggregationKind dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.SecondaryAggregationKindProperty Field

XYSeriesBaseSecondaryAggregationKindProperty Field
Identifies the SecondaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecondaryAggregationKindProperty
Public Shared ReadOnly SecondaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SecondaryAggregationKind dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.StackKindProperty Field

XYSeriesBaseStackKindProperty Field
Identifies the StackKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StackKindProperty
Public Shared ReadOnly StackKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StackKind dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.XAxisProperty Field

XYSeriesBaseXAxisProperty Field
Identifies the XAxis dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XAxisProperty
Public Shared ReadOnly XAxisProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XAxis dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.XPathProperty Field

XYSeriesBaseXPathProperty Field
Identifies the XPath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XPathProperty
Public Shared ReadOnly XPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XPath dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.YAxisProperty Field

XYSeriesBaseYAxisProperty Field
Identifies the YAxis dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YAxisProperty
Public Shared ReadOnly YAxisProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YAxis dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


XYSeriesBase.YPathProperty Field

XYSeriesBaseYPathProperty Field
Identifies the YPath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YPathProperty
Public Shared ReadOnly YPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YPath dependency property.
See Also

Reference

XYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual Class

YAxisVisual Class
Draws an axis given axis data.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesAxisVisual
ActiproSoftware.UI.Xaml.Controls.Charts.PrimitivesYAxisVisual

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class YAxisVisual : AxisVisual
Public Class YAxisVisual
    Inherits AxisVisual

The YAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual Properties

YAxisVisual Properties

The YAxisVisual type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Protected property | TickMajorMidPixel | Gets the major tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Protected property | TickMinorMidPixel | Gets the minor tick position snapped to mid-pixel, if necessary. (Inherited from AxisVisual.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual Methods

YAxisVisual Methods

The YAxisVisual type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Protected method | AreAnyTicksVisible | Determines if any ticks are visible. (Inherited from AxisVisual.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | DrawMajorTickAtPosition | Draws a major tick at a given position on the axis. (Overrides AxisVisualDrawMajorTickAtPosition(Double, Size).)
Protected method | DrawMinorTickAtPosition | Draws a minor tick at a given position on the axis. (Overrides AxisVisualDrawMinorTickAtPosition(Double, Size).)
Protected method | DrawSpine | Draws an axis spine. (Overrides AxisVisualDrawSpine(Size).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Protected method | GetTitleTemplateFromResources | Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary. (Overrides AxisVisualGetTitleTemplateFromResources(ResourceDictionary).)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | IsSpineVisible | Determines whether or not the spine is visible. (Inherited from AxisVisual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AxisVisual.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlaceLabelAtPosition | Place the axis label at the given position. (Overrides AxisVisualPlaceLabelAtPosition(TextBlock, Double, Double, Size).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Redraws the axis. (Inherited from AxisVisual.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitlePosition | Updates the title position. (Overrides AxisVisualUpdateTitlePosition(Size).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.ArrangeOverride Method

YAxisVisualArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.ArrangeOverride Method (Size)

YAxisVisualArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

YAxisVisual Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.DrawMajorTickAtPosition Method

YAxisVisualDrawMajorTickAtPosition Method
Draws a major tick at a given position on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void DrawMajorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMajorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.DrawMinorTickAtPosition Method

YAxisVisualDrawMinorTickAtPosition Method
Draws a minor tick at a given position on the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void DrawMinorTickAtPosition(
    double position,
    Size plotSize
)
Protected Overrides Sub DrawMinorTickAtPosition (
    position As Double,
    plotSize As Size
)

Parameters

position
Type: SystemDouble
The position to draw the tick at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.DrawSpine Method

YAxisVisualDrawSpine Method
Draws an axis spine.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void DrawSpine(
    Size plotSize
)
Protected Overrides Sub DrawSpine (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.YAxisVisual.DrawSpine(Windows.Foundation.Size)"]

See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.GetTitleTemplateFromResources Method

YAxisVisualGetTitleTemplateFromResources Method
Retrieves the appropriate DataTemplate for the axis title from the given ResourceDictionary.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate GetTitleTemplateFromResources(
    ResourceDictionary resources
)
Protected Overrides Function GetTitleTemplateFromResources (
    resources As ResourceDictionary
) As DataTemplate

Parameters

resources
Type: Windows.UI.XamlResourceDictionary
The ResourceDictionary to retrieve the title template from.

Return Value

Type: DataTemplate
The template for the axis title.
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.MeasureOverride Method

YAxisVisualMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.MeasureOverride Method (Size)

YAxisVisualMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a argumentValue to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

YAxisVisual Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.PlaceLabelAtPosition Method

YAxisVisualPlaceLabelAtPosition Method
Place the axis label at the given position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PlaceLabelAtPosition(
    TextBlock label,
    double position,
    double angle,
    Size plotSize
)
Protected Overrides Sub PlaceLabelAtPosition (
    label As TextBlock,
    position As Double,
    angle As Double,
    plotSize As Size
)

Parameters

label
Type: Windows.UI.Xaml.ControlsTextBlock
The axis label to lay out.
position
Type: SystemDouble
The position to draw the axis label at.
angle
Type: SystemDouble
The angle to draw the axis label at.
plotSize
Type: Windows.FoundationSize
Size of the plot.
Exceptions
Exception | Condition
ArgumentNullException | label
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual.UpdateTitlePosition Method

YAxisVisualUpdateTitlePosition Method
Updates the title position.

Namespace: ActiproSoftware.UI.Xaml.Controls.Charts.Primitives
Assembly: AS.Charts.Universal (in AS.Charts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateTitlePosition(
    Size plotSize
)
Protected Overrides Sub UpdateTitlePosition (
    plotSize As Size
)

Parameters

plotSize
Type: Windows.FoundationSize

[Missing <param name="plotSize"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Charts.Primitives.YAxisVisual.UpdateTitlePosition(Windows.Foundation.Size)"]

See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


YAxisVisual Events

YAxisVisual Events

The YAxisVisual type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

YAxisVisual Class
ActiproSoftware.UI.Xaml.Controls.Charts.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace
Supports animated transitions of content.
Classes
 | Class | Description
Public class | ContentTransitionBase | The base class for a content transition between two elements.
Public class | ContentTransitionDirection | Specifies the direction of a transition.
Public class | ContentTransitionMode | Specifies the mode of a transition.
Public class | FadeContentTransition | A crossfade transition between two elements.
Public class | FadedZoomContentTransition | A crossfade transition between two elements that zooms the new content in as well.
Public class | SlideContentTransition | A slide transition between two elements that moves one element over the other, or alternatively pushes the other.
Public class | StoryboardContentTransitionBase | A base class for a Storyboard-based transition between two elements.
Interfaces
 | Interface | Description
Public interface | IContentTransition | Provides the base requirements of a content transition between two elements.


ContentTransitionBase Class

ContentTransitionBase Class
The base class for a content transition between two elements.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsStoryboardContentTransitionBase

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class ContentTransitionBase : DependencyObject,
    IContentTransition
Public MustInherit Class ContentTransitionBase
    Inherits DependencyObject
    Implements IContentTransition

The ContentTransitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ContentTransitionBase | Initializes a new instance of the ContentTransitionBase class
Top
Properties
 | Name | Description
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost.
Top
Methods
 | Name | Description
Public method | BeginTransition | Begins a transition.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
 | GetOppositeDirection | Returns the opposite ContentTransitionDirection of the specified ContentTransitionDirection.
 | GetOppositeMode | Returns the opposite ContentTransitionMode of the specified ContentTransitionMode.
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.
 | GetResolvedDirection | Returns a resolved ContentTransitionDirection value between an instance setting and a default setting.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed.
Protected method | OnStarted | Occurs when the transition should be started.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running.
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Fields
Name | Description
ClipToBoundsProperty | Identifies the ClipToBounds dependency property. This field is read-only.
IsToContentTopMostProperty | Identifies the IsToContentTopMost dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase Constructor

ContentTransitionBase Constructor
Initializes a new instance of the ContentTransitionBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ContentTransitionBase()
Protected Sub New
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase Properties

ContentTransitionBase Properties

The ContentTransitionBase type exposes the following members.

Properties
 | Name | Description
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost.
Top
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.ClipToBounds Property

ContentTransitionBaseClipToBounds Property
Gets or sets whether the transition should clip the content elements to the container bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ClipToBounds { get; set; }
Public Property ClipToBounds As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the transition should clip the content elements to the container bounds; otherwise, false. The default value is false.

Implements

IContentTransitionClipToBounds
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.IsToContentTopMost Property

ContentTransitionBaseIsToContentTopMost Property
Gets or sets whether the "to" content is topmost.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsToContentTopMost { get; set; }
Public Property IsToContentTopMost As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the "to" content is topmost; otherwise, false. The default value is true.

Implements

IContentTransitionIsToContentTopMost
Remarks
Transitions that "reveal" the "to" content should return false.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase Methods

ContentTransitionBase Methods

The ContentTransitionBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginTransition | Begins a transition.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
 | GetOppositeDirection | Returns the opposite ContentTransitionDirection of the specified ContentTransitionDirection.
 | GetOppositeMode | Returns the opposite ContentTransitionMode of the specified ContentTransitionMode.
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.
 | GetResolvedDirection | Returns a resolved ContentTransitionDirection value between an instance setting and a default setting.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed.
Protected method | OnStarted | Occurs when the transition should be started.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running.
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.BeginTransition Method

ContentTransitionBaseBeginTransition Method
Begins a transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void BeginTransition(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    FrameworkElement toContent
)
Public Sub BeginTransition (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    toContent As FrameworkElement
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.

Implements

IContentTransitionBeginTransition(TransitioningContentPresenter, FrameworkElement, FrameworkElement)
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.EndTransition Method

ContentTransitionBaseEndTransition Method
Ends a transition, and notifies the presenter that the transition is complete.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void EndTransition(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    Object fromContentData,
    FrameworkElement toContent,
    Object toContentData
)
Protected Sub EndTransition (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    fromContentData As Object,
    toContent As FrameworkElement,
    toContentData As Object
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
fromContentData
Type: SystemObject
Optional data related to the "from" element that is passed to the OnCompleted(TransitioningContentPresenter, FrameworkElement, Object, FrameworkElement, Object) method.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.
toContentData
Type: SystemObject
Optional data related to the "to" element that is passed to the OnCompleted(TransitioningContentPresenter, FrameworkElement, Object, FrameworkElement, Object) method.
Remarks
This method must be called at the end of the transition so that the presenter is notified of the transition completion.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.GetOppositeDirection Method

ContentTransitionBaseGetOppositeDirection Method
Returns the opposite ContentTransitionDirection of the specified ContentTransitionDirection.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ContentTransitionDirection GetOppositeDirection(
    ContentTransitionDirection direction
)
Public Shared Function GetOppositeDirection (
    direction As ContentTransitionDirection
) As ContentTransitionDirection

Parameters

direction
Type: ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionDirection
The ContentTransitionDirection to examine.

Return Value

Type: ContentTransitionDirection
The opposite ContentTransitionDirection of the specified ContentTransitionDirection.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.GetOppositeMode Method

ContentTransitionBaseGetOppositeMode Method
Returns the opposite ContentTransitionMode of the specified ContentTransitionMode.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static ContentTransitionMode GetOppositeMode(
    ContentTransitionMode mode
)
Public Shared Function GetOppositeMode (
    mode As ContentTransitionMode
) As ContentTransitionMode

Parameters

mode
Type: ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionMode
The ContentTransitionMode to examine.

Return Value

Type: ContentTransitionMode
The opposite ContentTransitionMode of the specified ContentTransitionMode.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.GetOppositeTransition Method

ContentTransitionBaseGetOppositeTransition Method
Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IContentTransition GetOppositeTransition()
Public MustOverride Function GetOppositeTransition As IContentTransition

Return Value

Type: IContentTransition
A variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Implements

IContentTransitionGetOppositeTransition
Remarks
Override this method to return an opposite variation of the transition if the transition supports the concept.

If the transition uses a ContentTransitionMode, its value should be flipped using the GetOppositeMode(ContentTransitionMode) method.

See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.GetResolvedDirection Method

ContentTransitionBaseGetResolvedDirection Method
Returns a resolved ContentTransitionDirection value between an instance setting and a default setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected static ContentTransitionDirection GetResolvedDirection(
    ContentTransitionDirection instanceDirection,
    ContentTransitionDirection defaultDirection
)
Protected Shared Function GetResolvedDirection (
    instanceDirection As ContentTransitionDirection,
    defaultDirection As ContentTransitionDirection
) As ContentTransitionDirection

Parameters

instanceDirection
Type: ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionDirection
The instance ContentTransitionDirection setting.
defaultDirection
Type: ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionDirection
The default ContentTransitionDirection setting.

Return Value

Type: ContentTransitionDirection
The resolved ContentTransitionDirection value.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.OnCompleted Method

ContentTransitionBaseOnCompleted Method
Occurs when the transition has completed.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnCompleted(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    Object fromContentData,
    FrameworkElement toContent,
    Object toContentData
)
Protected Overridable Sub OnCompleted (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    fromContentData As Object,
    toContent As FrameworkElement,
    toContentData As Object
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
fromContentData
Type: SystemObject
Optional data related to the "from" element.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.
toContentData
Type: SystemObject
Optional data related to the "to" element.
Remarks
Place code to perform any post-transition cleanup in an override of this method.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.OnStarted Method

ContentTransitionBaseOnStarted Method
Occurs when the transition should be started.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnStarted(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    FrameworkElement toContent
)
Protected Overridable Sub OnStarted (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    toContent As FrameworkElement
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.
Remarks
Place code to perform the transition in an override of this method.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.StopTransition Method

ContentTransitionBaseStopTransition Method
Stops the transition if it is currently running.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void StopTransition(
    TransitioningContentPresenter presenter
)
Public Overridable Sub StopTransition (
    presenter As TransitioningContentPresenter
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.

Implements

IContentTransitionStopTransition(TransitioningContentPresenter)
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase Fields

ContentTransitionBase Fields

The ContentTransitionBase type exposes the following members.

Fields
Name | Description
ClipToBoundsProperty | Identifies the ClipToBounds dependency property. This field is read-only.
IsToContentTopMostProperty | Identifies the IsToContentTopMost dependency property. This field is read-only.
Top
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.ClipToBoundsProperty Field

ContentTransitionBaseClipToBoundsProperty Field
Identifies the ClipToBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClipToBoundsProperty
Public Shared ReadOnly ClipToBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClipToBounds dependency property.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionBase.IsToContentTopMostProperty Field

ContentTransitionBaseIsToContentTopMostProperty Field
Identifies the IsToContentTopMost dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsToContentTopMostProperty
Public Shared ReadOnly IsToContentTopMostProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsToContentTopMost dependency property.
See Also

Reference

ContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection Class

ContentTransitionDirection Class
Specifies the direction of a transition.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionDirection

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ContentTransitionDirection : Enum
Public NotInheritable Class ContentTransitionDirection
    Inherits Enum

The ContentTransitionDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Backward | The transition occurs in a forward direction, typically right to left.
 | BackwardDown | The transition occurs in a diagonal backward and downward direction, typically top/right to bottom/left.
 | BackwardUp | The transition occurs in a diagonal backward and upward direction, typically bottom/right to top/left.
 | Default | The default direction.
 | Down | The transition occurs in a downward direction.
 | Forward | The transition occurs in a forward direction, typically left to right.
 | ForwardDown | The transition occurs in a diagonal forward and downward direction, typically top/left to bottom/right.
 | ForwardUp | The transition occurs in a diagonal forward and upward direction, typically bottom/left to top/right.
 | Up | The transition occurs in an upward direction.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection Methods

ContentTransitionDirection Methods

The ContentTransitionDirection type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection Fields

ContentTransitionDirection Fields

The ContentTransitionDirection type exposes the following members.

Fields
 | Name | Description
 | Backward | The transition occurs in a forward direction, typically right to left.
 | BackwardDown | The transition occurs in a diagonal backward and downward direction, typically top/right to bottom/left.
 | BackwardUp | The transition occurs in a diagonal backward and upward direction, typically bottom/right to top/left.
 | Default | The default direction.
 | Down | The transition occurs in a downward direction.
 | Forward | The transition occurs in a forward direction, typically left to right.
 | ForwardDown | The transition occurs in a diagonal forward and downward direction, typically top/left to bottom/right.
 | ForwardUp | The transition occurs in a diagonal forward and upward direction, typically bottom/left to top/right.
 | Up | The transition occurs in an upward direction.
Public field | value__ |
Top
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.Backward Field

ContentTransitionDirectionBackward Field
The transition occurs in a forward direction, typically right to left.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection Backward = 4
Public Const Backward As ContentTransitionDirection = 4

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.BackwardDown Field

ContentTransitionDirectionBackwardDown Field
The transition occurs in a diagonal backward and downward direction, typically top/right to bottom/left.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection BackwardDown = 7
Public Const BackwardDown As ContentTransitionDirection = 7

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.BackwardUp Field

ContentTransitionDirectionBackwardUp Field
The transition occurs in a diagonal backward and upward direction, typically bottom/right to top/left.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection BackwardUp = 8
Public Const BackwardUp As ContentTransitionDirection = 8

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.Default Field

ContentTransitionDirectionDefault Field
The default direction.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection Default = 0
Public Const Default As ContentTransitionDirection = 0

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.Down Field

ContentTransitionDirectionDown Field
The transition occurs in a downward direction.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection Down = 1
Public Const Down As ContentTransitionDirection = 1

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.Forward Field

ContentTransitionDirectionForward Field
The transition occurs in a forward direction, typically left to right.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection Forward = 3
Public Const Forward As ContentTransitionDirection = 3

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.ForwardDown Field

ContentTransitionDirectionForwardDown Field
The transition occurs in a diagonal forward and downward direction, typically top/left to bottom/right.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection ForwardDown = 5
Public Const ForwardDown As ContentTransitionDirection = 5

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.ForwardUp Field

ContentTransitionDirectionForwardUp Field
The transition occurs in a diagonal forward and upward direction, typically bottom/left to top/right.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection ForwardUp = 6
Public Const ForwardUp As ContentTransitionDirection = 6

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.Up Field

ContentTransitionDirectionUp Field
The transition occurs in an upward direction.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionDirection Up = 2
Public Const Up As ContentTransitionDirection = 2

Field Value

Type: ContentTransitionDirection
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionDirection.value__ Field

ContentTransitionDirectionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.ContentTransitions.ContentTransitionDirection.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ContentTransitionDirection Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionMode Class

ContentTransitionMode Class
Specifies the mode of a transition.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionMode

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ContentTransitionMode : Enum
Public NotInheritable Class ContentTransitionMode
    Inherits Enum

The ContentTransitionMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | In | The transition is moving new content into the presenter to cover existing content.
 | Out | The transition is moving existing content out of the presenter to reveal other content.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionMode Methods

ContentTransitionMode Methods

The ContentTransitionMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ContentTransitionMode Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionMode Fields

ContentTransitionMode Fields

The ContentTransitionMode type exposes the following members.

Fields
 | Name | Description
 | In | The transition is moving new content into the presenter to cover existing content.
 | Out | The transition is moving existing content out of the presenter to reveal other content.
Public field | value__ |
Top
See Also

Reference

ContentTransitionMode Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionMode.In Field

ContentTransitionModeIn Field
The transition is moving new content into the presenter to cover existing content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionMode In = 0
Public Const In As ContentTransitionMode = 0

Field Value

Type: ContentTransitionMode
See Also

Reference

ContentTransitionMode Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionMode.Out Field

ContentTransitionModeOut Field
The transition is moving existing content out of the presenter to reveal other content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContentTransitionMode Out = 1
Public Const Out As ContentTransitionMode = 1

Field Value

Type: ContentTransitionMode
See Also

Reference

ContentTransitionMode Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ContentTransitionMode.value__ Field

ContentTransitionModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.ContentTransitions.ContentTransitionMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ContentTransitionMode Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition Class

FadeContentTransition Class
A crossfade transition between two elements.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsStoryboardContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsFadeContentTransition

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FadeContentTransition : StoryboardContentTransitionBase
Public Class FadeContentTransition
    Inherits StoryboardContentTransitionBase

The FadeContentTransition type exposes the following members.

Constructors
 | Name | Description
Public method | FadeContentTransition | Initializes a new instance of the FadeContentTransition class
Top
Properties
 | Name | Description
Public property | BeginTime | Gets or sets the time at which this transition should begin.
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Duration | Gets or sets the length of time for which this transition plays, not counting repetitions.
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Public property | Mode | Gets or sets a ContentTransitionMode specifying the mode of the transition.
Top
Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Clone | Creates a clone of the transition.
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content. (Overrides StoryboardContentTransitionBaseGetFromContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Overrides ContentTransitionBaseGetOppositeTransition.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content. (Overrides StoryboardContentTransitionBaseGetToContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Inherited from StoryboardContentTransitionBase.)
Protected method | OnStarted | Occurs when the transition should be started. (Inherited from StoryboardContentTransitionBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Inherited from StoryboardContentTransitionBase.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Fields
Name | Description
BeginTimeProperty | Identifies the BeginTime dependency property. This field is read-only.
DurationProperty | Identifies the Duration dependency property. This field is read-only.
ModeProperty | Identifies the Mode dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition Constructor

FadeContentTransition Constructor
Initializes a new instance of the FadeContentTransition class

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FadeContentTransition()
Public Sub New
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition Properties

FadeContentTransition Properties

The FadeContentTransition type exposes the following members.

Properties
 | Name | Description
Public property | BeginTime | Gets or sets the time at which this transition should begin.
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Duration | Gets or sets the length of time for which this transition plays, not counting repetitions.
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Public property | Mode | Gets or sets a ContentTransitionMode specifying the mode of the transition.
Top
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.BeginTime Property

FadeContentTransitionBeginTime Property
Gets or sets the time at which this transition should begin.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan BeginTime { get; set; }
Public Property BeginTime As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The time at which this transition should begin, relative to the parent's begin time.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.Duration Property

FadeContentTransitionDuration Property
Gets or sets the length of time for which this transition plays, not counting repetitions.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Duration Duration { get; set; }
Public Property Duration As Duration
    Get
    Set

Property Value

Type: Duration
The transition's simple duration: the amount of time this effect takes to complete a single forward iteration. The default value is Automatic.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.Mode Property

FadeContentTransitionMode Property
Gets or sets a ContentTransitionMode specifying the mode of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionMode Mode { get; set; }
Public Property Mode As ContentTransitionMode
    Get
    Set

Property Value

Type: ContentTransitionMode
A ContentTransitionMode specifying the mode of the transition.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition Methods

FadeContentTransition Methods

The FadeContentTransition type exposes the following members.

Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Clone | Creates a clone of the transition.
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content. (Overrides StoryboardContentTransitionBaseGetFromContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Overrides ContentTransitionBaseGetOppositeTransition.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content. (Overrides StoryboardContentTransitionBaseGetToContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Inherited from StoryboardContentTransitionBase.)
Protected method | OnStarted | Occurs when the transition should be started. (Inherited from StoryboardContentTransitionBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Inherited from StoryboardContentTransitionBase.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.Clone Method

FadeContentTransitionClone Method
Creates a clone of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FadeContentTransition Clone()
Public Function Clone As FadeContentTransition

Return Value

Type: FadeContentTransition
The clone that was created.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.GetFromContentStoryboard Method

FadeContentTransitionGetFromContentStoryboard Method
Returns the Storyboard to apply to the "from" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Storyboard GetFromContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetFromContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Storyboard.

Return Value

Type: Storyboard
The Storyboard to apply to the "from" content.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.GetFromContentStyle Method

FadeContentTransitionGetFromContentStyle Method
Overload List
 | Name | Description
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Top
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.GetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)

FadeContentTransitionGetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "from" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Style GetFromContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetFromContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "from" content during the transition.
See Also

Reference

FadeContentTransition Class
GetFromContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.GetOppositeTransition Method

FadeContentTransitionGetOppositeTransition Method
Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IContentTransition GetOppositeTransition()
Public Overrides Function GetOppositeTransition As IContentTransition

Return Value

Type: IContentTransition
A variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Implements

IContentTransitionGetOppositeTransition
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.GetToContentStoryboard Method

FadeContentTransitionGetToContentStoryboard Method
Returns the Storyboard to apply to the "to" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Storyboard GetToContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetToContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Storyboard.

Return Value

Type: Storyboard
The Storyboard to apply to the "to" content.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition Fields

FadeContentTransition Fields

The FadeContentTransition type exposes the following members.

Fields
Name | Description
BeginTimeProperty | Identifies the BeginTime dependency property. This field is read-only.
DurationProperty | Identifies the Duration dependency property. This field is read-only.
ModeProperty | Identifies the Mode dependency property. This field is read-only.
Top
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.BeginTimeProperty Field

FadeContentTransitionBeginTimeProperty Field
Identifies the BeginTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BeginTimeProperty
Public Shared ReadOnly BeginTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BeginTime dependency property.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.DurationProperty Field

FadeContentTransitionDurationProperty Field
Identifies the Duration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DurationProperty
Public Shared ReadOnly DurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Duration dependency property.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadeContentTransition.ModeProperty Field

FadeContentTransitionModeProperty Field
Identifies the Mode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ModeProperty
Public Shared ReadOnly ModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Mode dependency property.
See Also

Reference

FadeContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition Class

FadedZoomContentTransition Class
A crossfade transition between two elements that zooms the new content in as well.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsStoryboardContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsFadedZoomContentTransition

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FadedZoomContentTransition : StoryboardContentTransitionBase
Public Class FadedZoomContentTransition
    Inherits StoryboardContentTransitionBase

The FadedZoomContentTransition type exposes the following members.

Constructors
 | Name | Description
Public method | FadedZoomContentTransition | Initializes a new instance of the FadedZoomContentTransition class
Top
Properties
 | Name | Description
Public property | BeginTime | Gets or sets the time at which this transition should begin.
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Duration | Gets or sets the length of time for which this transition plays, not counting repetitions.
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Public property | Mode | Gets or sets a ContentTransitionMode specifying the mode of the transition.
Public property | ZoomInPercentage | Gets or sets the percentage by which to scale inner-zoomed content (content that extends inside of the transition presenter).
Public property | ZoomOutPercentage | Gets or sets the percentage by which to scale outer-zoomed content (content that extends outside of the transition presenter).
Top
Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Clone | Creates a clone of the transition.
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content. (Overrides StoryboardContentTransitionBaseGetFromContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Overrides ContentTransitionBaseGetOppositeTransition.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content. (Overrides StoryboardContentTransitionBaseGetToContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Overrides StoryboardContentTransitionBaseGetToContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Inherited from StoryboardContentTransitionBase.)
Protected method | OnStarted | Occurs when the transition should be started. (Inherited from StoryboardContentTransitionBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Inherited from StoryboardContentTransitionBase.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Fields
Name | Description
BeginTimeProperty | Identifies the BeginTime dependency property. This field is read-only.
DurationProperty | Identifies the Duration dependency property. This field is read-only.
ModeProperty | Identifies the Mode dependency property. This field is read-only.
ZoomInPercentageProperty | Identifies the ZoomInPercentage dependency property. This field is read-only.
ZoomOutPercentageProperty | Identifies the ZoomOutPercentage dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition Constructor

FadedZoomContentTransition Constructor
Initializes a new instance of the FadedZoomContentTransition class

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FadedZoomContentTransition()
Public Sub New
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition Properties

FadedZoomContentTransition Properties

The FadedZoomContentTransition type exposes the following members.

Properties
 | Name | Description
Public property | BeginTime | Gets or sets the time at which this transition should begin.
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Duration | Gets or sets the length of time for which this transition plays, not counting repetitions.
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Public property | Mode | Gets or sets a ContentTransitionMode specifying the mode of the transition.
Public property | ZoomInPercentage | Gets or sets the percentage by which to scale inner-zoomed content (content that extends inside of the transition presenter).
Public property | ZoomOutPercentage | Gets or sets the percentage by which to scale outer-zoomed content (content that extends outside of the transition presenter).
Top
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.BeginTime Property

FadedZoomContentTransitionBeginTime Property
Gets or sets the time at which this transition should begin.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan BeginTime { get; set; }
Public Property BeginTime As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The time at which this transition should begin, relative to the parent's begin time.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.Duration Property

FadedZoomContentTransitionDuration Property
Gets or sets the length of time for which this transition plays, not counting repetitions.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Duration Duration { get; set; }
Public Property Duration As Duration
    Get
    Set

Property Value

Type: Duration
The transition's simple duration: the amount of time this effect takes to complete a single forward iteration. The default value is Automatic.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.Mode Property

FadedZoomContentTransitionMode Property
Gets or sets a ContentTransitionMode specifying the mode of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionMode Mode { get; set; }
Public Property Mode As ContentTransitionMode
    Get
    Set

Property Value

Type: ContentTransitionMode
A ContentTransitionMode specifying the mode of the transition.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.ZoomInPercentage Property

FadedZoomContentTransitionZoomInPercentage Property
Gets or sets the percentage by which to scale inner-zoomed content (content that extends inside of the transition presenter).

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ZoomInPercentage { get; set; }
Public Property ZoomInPercentage As Double
    Get
    Set

Property Value

Type: Double
The percentage by which to scale inner-zoomed content (content that extends inside of the transition presenter). The default value is 0.2.
Remarks
The value must be between 0 and 0.5.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.ZoomOutPercentage Property

FadedZoomContentTransitionZoomOutPercentage Property
Gets or sets the percentage by which to scale outer-zoomed content (content that extends outside of the transition presenter).

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ZoomOutPercentage { get; set; }
Public Property ZoomOutPercentage As Double
    Get
    Set

Property Value

Type: Double
The percentage by which to scale outer-zoomed content (content that extends outside of the transition presenter). The default value is 0.2.
Remarks
The value must be between 0 and 0.5.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition Methods

FadedZoomContentTransition Methods

The FadedZoomContentTransition type exposes the following members.

Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Clone | Creates a clone of the transition.
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content. (Overrides StoryboardContentTransitionBaseGetFromContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Overrides ContentTransitionBaseGetOppositeTransition.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content. (Overrides StoryboardContentTransitionBaseGetToContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Overrides StoryboardContentTransitionBaseGetToContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Inherited from StoryboardContentTransitionBase.)
Protected method | OnStarted | Occurs when the transition should be started. (Inherited from StoryboardContentTransitionBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Inherited from StoryboardContentTransitionBase.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.Clone Method

FadedZoomContentTransitionClone Method
Creates a clone of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FadedZoomContentTransition Clone()
Public Function Clone As FadedZoomContentTransition

Return Value

Type: FadedZoomContentTransition
The clone that was created.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetFromContentStoryboard Method

FadedZoomContentTransitionGetFromContentStoryboard Method
Returns the Storyboard to apply to the "from" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Storyboard GetFromContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetFromContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Storyboard.

Return Value

Type: Storyboard
The Storyboard to apply to the "from" content.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetFromContentStyle Method

FadedZoomContentTransitionGetFromContentStyle Method
Overload List
 | Name | Description
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Top
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)

FadedZoomContentTransitionGetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "from" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Style GetFromContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetFromContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "from" content during the transition.
See Also

Reference

FadedZoomContentTransition Class
GetFromContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetOppositeTransition Method

FadedZoomContentTransitionGetOppositeTransition Method
Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IContentTransition GetOppositeTransition()
Public Overrides Function GetOppositeTransition As IContentTransition

Return Value

Type: IContentTransition
A variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Implements

IContentTransitionGetOppositeTransition
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetToContentStoryboard Method

FadedZoomContentTransitionGetToContentStoryboard Method
Returns the Storyboard to apply to the "to" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Storyboard GetToContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetToContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Storyboard.

Return Value

Type: Storyboard
The Storyboard to apply to the "to" content.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetToContentStyle Method

FadedZoomContentTransitionGetToContentStyle Method
Overload List
 | Name | Description
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Overrides StoryboardContentTransitionBaseGetToContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Top
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.GetToContentStyle Method (TransitioningContentPresenter, FrameworkElement)

FadedZoomContentTransitionGetToContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "to" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Style GetToContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetToContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "to" content during the transition.
See Also

Reference

FadedZoomContentTransition Class
GetToContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition Fields

FadedZoomContentTransition Fields

The FadedZoomContentTransition type exposes the following members.

Fields
Name | Description
BeginTimeProperty | Identifies the BeginTime dependency property. This field is read-only.
DurationProperty | Identifies the Duration dependency property. This field is read-only.
ModeProperty | Identifies the Mode dependency property. This field is read-only.
ZoomInPercentageProperty | Identifies the ZoomInPercentage dependency property. This field is read-only.
ZoomOutPercentageProperty | Identifies the ZoomOutPercentage dependency property. This field is read-only.
Top
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.BeginTimeProperty Field

FadedZoomContentTransitionBeginTimeProperty Field
Identifies the BeginTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BeginTimeProperty
Public Shared ReadOnly BeginTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BeginTime dependency property.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.DurationProperty Field

FadedZoomContentTransitionDurationProperty Field
Identifies the Duration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DurationProperty
Public Shared ReadOnly DurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Duration dependency property.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.ModeProperty Field

FadedZoomContentTransitionModeProperty Field
Identifies the Mode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ModeProperty
Public Shared ReadOnly ModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Mode dependency property.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.ZoomInPercentageProperty Field

FadedZoomContentTransitionZoomInPercentageProperty Field
Identifies the ZoomInPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomInPercentageProperty
Public Shared ReadOnly ZoomInPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomInPercentage dependency property.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


FadedZoomContentTransition.ZoomOutPercentageProperty Field

FadedZoomContentTransitionZoomOutPercentageProperty Field
Identifies the ZoomOutPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomOutPercentageProperty
Public Shared ReadOnly ZoomOutPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomOutPercentage dependency property.
See Also

Reference

FadedZoomContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition Interface

IContentTransition Interface
Provides the base requirements of a content transition between two elements.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IContentTransition
Public Interface IContentTransition

The IContentTransition type exposes the following members.

Properties
 | Name | Description
Public property | ClipToBounds | Gets whether the transition should clip the content elements to the container bounds.
Public property | IsToContentTopMost | Gets whether the "to" content is topmost.
Top
Methods
 | Name | Description
Public method | BeginTransition | Begins a transition.
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.
Public method | StopTransition | Stops the transition if it is currently running.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition Properties

IContentTransition Properties

The IContentTransition type exposes the following members.

Properties
 | Name | Description
Public property | ClipToBounds | Gets whether the transition should clip the content elements to the container bounds.
Public property | IsToContentTopMost | Gets whether the "to" content is topmost.
Top
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition.ClipToBounds Property

IContentTransitionClipToBounds Property
Gets whether the transition should clip the content elements to the container bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ClipToBounds { get; }
ReadOnly Property ClipToBounds As Boolean
    Get

Property Value

Type: Boolean
true if the transition should clip the content elements to the container bounds; otherwise, false. The default value is false.
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition.IsToContentTopMost Property

IContentTransitionIsToContentTopMost Property
Gets whether the "to" content is topmost.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsToContentTopMost { get; }
ReadOnly Property IsToContentTopMost As Boolean
    Get

Property Value

Type: Boolean
true if the "to" content is topmost; otherwise, false. The default value is true.
Remarks
Transitions that "reveal" the "to" content should return false.
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition Methods

IContentTransition Methods

The IContentTransition type exposes the following members.

Methods
 | Name | Description
Public method | BeginTransition | Begins a transition.
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.
Public method | StopTransition | Stops the transition if it is currently running.
Top
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition.BeginTransition Method

IContentTransitionBeginTransition Method
Begins a transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void BeginTransition(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    FrameworkElement toContent
)
Sub BeginTransition (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    toContent As FrameworkElement
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition.GetOppositeTransition Method

IContentTransitionGetOppositeTransition Method
Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IContentTransition GetOppositeTransition()
Function GetOppositeTransition As IContentTransition

Return Value

Type: IContentTransition
A variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.
Remarks
Override this method to return an opposite variation of the transition if the transition supports the concept.
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


IContentTransition.StopTransition Method

IContentTransitionStopTransition Method
Stops the transition if it is currently running.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void StopTransition(
    TransitioningContentPresenter presenter
)
Sub StopTransition (
    presenter As TransitioningContentPresenter
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
See Also

Reference

IContentTransition Interface
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition Class

SlideContentTransition Class
A slide transition between two elements that moves one element over the other, or alternatively pushes the other.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsStoryboardContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsSlideContentTransition

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SlideContentTransition : StoryboardContentTransitionBase
Public Class SlideContentTransition
    Inherits StoryboardContentTransitionBase

The SlideContentTransition type exposes the following members.

Constructors
 | Name | Description
Public method | SlideContentTransition | Initializes a new instance of the SlideContentTransition class.
Top
Properties
 | Name | Description
Public property | BeginTime | Gets or sets the time at which this transition should begin.
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Direction | Gets or sets a ContentTransitionDirection specifying the direction of the transition.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Duration | Gets or sets the length of time for which this transition plays, not counting repetitions.
Public property | IsFromContentPushed | Gets or sets whether the "from" content is pushed by the "to" content.
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Public property | Mode | Gets or sets a ContentTransitionMode specifying the mode of the transition.
Top
Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Clone | Creates a clone of the transition.
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content. (Overrides StoryboardContentTransitionBaseGetFromContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Overrides ContentTransitionBaseGetOppositeTransition.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content. (Overrides StoryboardContentTransitionBaseGetToContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Overrides StoryboardContentTransitionBaseGetToContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Inherited from StoryboardContentTransitionBase.)
Protected method | OnStarted | Occurs when the transition should be started. (Inherited from StoryboardContentTransitionBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Inherited from StoryboardContentTransitionBase.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Fields
Name | Description
BeginTimeProperty | Identifies the BeginTime dependency property. This field is read-only.
DirectionProperty | Identifies the Direction dependency property. This field is read-only.
DurationProperty | Identifies the Duration dependency property. This field is read-only.
IsFromContentPushedProperty | Identifies the IsFromContentPushed dependency property. This field is read-only.
ModeProperty | Identifies the Mode dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition Constructor

SlideContentTransition Constructor
Initializes a new instance of the SlideContentTransition class.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SlideContentTransition()
Public Sub New
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition Properties

SlideContentTransition Properties

The SlideContentTransition type exposes the following members.

Properties
 | Name | Description
Public property | BeginTime | Gets or sets the time at which this transition should begin.
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Direction | Gets or sets a ContentTransitionDirection specifying the direction of the transition.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Duration | Gets or sets the length of time for which this transition plays, not counting repetitions.
Public property | IsFromContentPushed | Gets or sets whether the "from" content is pushed by the "to" content.
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Public property | Mode | Gets or sets a ContentTransitionMode specifying the mode of the transition.
Top
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.BeginTime Property

SlideContentTransitionBeginTime Property
Gets or sets the time at which this transition should begin.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan BeginTime { get; set; }
Public Property BeginTime As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The time at which this transition should begin, relative to the parent's begin time.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.Direction Property

SlideContentTransitionDirection Property
Gets or sets a ContentTransitionDirection specifying the direction of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionDirection Direction { get; set; }
Public Property Direction As ContentTransitionDirection
    Get
    Set

Property Value

Type: ContentTransitionDirection
A ContentTransitionDirection specifying the direction of the transition.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.Duration Property

SlideContentTransitionDuration Property
Gets or sets the length of time for which this transition plays, not counting repetitions.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Duration Duration { get; set; }
Public Property Duration As Duration
    Get
    Set

Property Value

Type: Duration
The transition's simple duration: the amount of time this effect takes to complete a single forward iteration. The default value is Automatic.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.IsFromContentPushed Property

SlideContentTransitionIsFromContentPushed Property
Gets or sets whether the "from" content is pushed by the "to" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsFromContentPushed { get; set; }
Public Property IsFromContentPushed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the "from" content is pushed by the "to" content; otherwise, false. The default value is false.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.Mode Property

SlideContentTransitionMode Property
Gets or sets a ContentTransitionMode specifying the mode of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContentTransitionMode Mode { get; set; }
Public Property Mode As ContentTransitionMode
    Get
    Set

Property Value

Type: ContentTransitionMode
A ContentTransitionMode specifying the mode of the transition.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition Methods

SlideContentTransition Methods

The SlideContentTransition type exposes the following members.

Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Clone | Creates a clone of the transition.
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content. (Overrides StoryboardContentTransitionBaseGetFromContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Overrides ContentTransitionBaseGetOppositeTransition.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content. (Overrides StoryboardContentTransitionBaseGetToContentStoryboard(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Overrides StoryboardContentTransitionBaseGetToContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Inherited from StoryboardContentTransitionBase.)
Protected method | OnStarted | Occurs when the transition should be started. (Inherited from StoryboardContentTransitionBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Inherited from StoryboardContentTransitionBase.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.Clone Method

SlideContentTransitionClone Method
Creates a clone of the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SlideContentTransition Clone()
Public Function Clone As SlideContentTransition

Return Value

Type: SlideContentTransition
The clone that was created.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetFromContentStoryboard Method

SlideContentTransitionGetFromContentStoryboard Method
Returns the Storyboard to apply to the "from" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Storyboard GetFromContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetFromContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Storyboard
The Storyboard to apply to the "from" content.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetFromContentStyle Method

SlideContentTransitionGetFromContentStyle Method
Overload List
 | Name | Description
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Overrides StoryboardContentTransitionBaseGetFromContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Top
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)

SlideContentTransitionGetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "from" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Style GetFromContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetFromContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "from" content during the transition.
See Also

Reference

SlideContentTransition Class
GetFromContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetOppositeTransition Method

SlideContentTransitionGetOppositeTransition Method
Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IContentTransition GetOppositeTransition()
Public Overrides Function GetOppositeTransition As IContentTransition

Return Value

Type: IContentTransition
A variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition.

Implements

IContentTransitionGetOppositeTransition
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetToContentStoryboard Method

SlideContentTransitionGetToContentStoryboard Method
Returns the Storyboard to apply to the "to" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Storyboard GetToContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetToContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Storyboard
The Storyboard to apply to the "to" content.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetToContentStyle Method

SlideContentTransitionGetToContentStyle Method
Overload List
 | Name | Description
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Overrides StoryboardContentTransitionBaseGetToContentStyle(TransitioningContentPresenter, FrameworkElement).)
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition. (Inherited from StoryboardContentTransitionBase.)
Top
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.GetToContentStyle Method (TransitioningContentPresenter, FrameworkElement)

SlideContentTransitionGetToContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "to" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Style GetToContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overrides Function GetToContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "to" content during the transition.
See Also

Reference

SlideContentTransition Class
GetToContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition Fields

SlideContentTransition Fields

The SlideContentTransition type exposes the following members.

Fields
Name | Description
BeginTimeProperty | Identifies the BeginTime dependency property. This field is read-only.
DirectionProperty | Identifies the Direction dependency property. This field is read-only.
DurationProperty | Identifies the Duration dependency property. This field is read-only.
IsFromContentPushedProperty | Identifies the IsFromContentPushed dependency property. This field is read-only.
ModeProperty | Identifies the Mode dependency property. This field is read-only.
Top
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.BeginTimeProperty Field

SlideContentTransitionBeginTimeProperty Field
Identifies the BeginTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BeginTimeProperty
Public Shared ReadOnly BeginTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BeginTime dependency property.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.DirectionProperty Field

SlideContentTransitionDirectionProperty Field
Identifies the Direction dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DirectionProperty
Public Shared ReadOnly DirectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Direction dependency property.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.DurationProperty Field

SlideContentTransitionDurationProperty Field
Identifies the Duration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DurationProperty
Public Shared ReadOnly DurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Duration dependency property.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.IsFromContentPushedProperty Field

SlideContentTransitionIsFromContentPushedProperty Field
Identifies the IsFromContentPushed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFromContentPushedProperty
Public Shared ReadOnly IsFromContentPushedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFromContentPushed dependency property.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


SlideContentTransition.ModeProperty Field

SlideContentTransitionModeProperty Field
Identifies the Mode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ModeProperty
Public Shared ReadOnly ModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Mode dependency property.
See Also

Reference

SlideContentTransition Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase Class

StoryboardContentTransitionBase Class
A base class for a Storyboard-based transition between two elements.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsStoryboardContentTransitionBase
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsFadeContentTransition
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsFadedZoomContentTransition
ActiproSoftware.UI.Xaml.Controls.ContentTransitionsSlideContentTransition

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class StoryboardContentTransitionBase : ContentTransitionBase
Public MustInherit Class StoryboardContentTransitionBase
    Inherits ContentTransitionBase

The StoryboardContentTransitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | StoryboardContentTransitionBase | Initializes a new instance of the StoryboardContentTransitionBase class
Top
Properties
 | Name | Description
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Top
Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content.
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition.
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Inherited from ContentTransitionBase.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content.
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition.
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Overrides ContentTransitionBaseOnCompleted(TransitioningContentPresenter, FrameworkElement, Object, FrameworkElement, Object).)
Protected method | OnStarted | Occurs when the transition should be started. (Overrides ContentTransitionBaseOnStarted(TransitioningContentPresenter, FrameworkElement, FrameworkElement).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Overrides ContentTransitionBaseStopTransition(TransitioningContentPresenter).)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase Constructor

StoryboardContentTransitionBase Constructor
Initializes a new instance of the StoryboardContentTransitionBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected StoryboardContentTransitionBase()
Protected Sub New
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase Properties

StoryboardContentTransitionBase Properties

The StoryboardContentTransitionBase type exposes the following members.

Properties
 | Name | Description
Public property | ClipToBounds | Gets or sets whether the transition should clip the content elements to the container bounds. (Inherited from ContentTransitionBase.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | IsToContentTopMost | Gets or sets whether the "to" content is topmost. (Inherited from ContentTransitionBase.)
Top
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase Methods

StoryboardContentTransitionBase Methods

The StoryboardContentTransitionBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginTransition | Begins a transition. (Inherited from ContentTransitionBase.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | EndTransition | Ends a transition, and notifies the presenter that the transition is complete. (Inherited from ContentTransitionBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetFromContentStoryboard | Returns the Storyboard to apply to the "from" content.
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition.
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetOppositeTransition | Returns a variation of the transition that can be used for backing out a content that was inserted into the presenter using this transition. (Inherited from ContentTransitionBase.)
Protected method | GetToContentStoryboard | Returns the Storyboard to apply to the "to" content.
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition.
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCompleted | Occurs when the transition has completed. (Overrides ContentTransitionBaseOnCompleted(TransitioningContentPresenter, FrameworkElement, Object, FrameworkElement, Object).)
Protected method | OnStarted | Occurs when the transition should be started. (Overrides ContentTransitionBaseOnStarted(TransitioningContentPresenter, FrameworkElement, FrameworkElement).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StopTransition | Stops the transition if it is currently running. (Overrides ContentTransitionBaseStopTransition(TransitioningContentPresenter).)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetFromContentStoryboard Method

StoryboardContentTransitionBaseGetFromContentStoryboard Method
Returns the Storyboard to apply to the "from" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Storyboard GetFromContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overridable Function GetFromContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Storyboard
The Storyboard to apply to the "from" content.
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetFromContentStyle Method

StoryboardContentTransitionBaseGetFromContentStyle Method
Overload List
 | Name | Description
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "from" content during the transition.
Protected method | GetFromContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "from" content during the transition.
Top
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)

StoryboardContentTransitionBaseGetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "from" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Style GetFromContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overridable Function GetFromContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "from" content during the transition.
See Also

Reference

StoryboardContentTransitionBase Class
GetFromContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement, FrameworkElement)

StoryboardContentTransitionBaseGetFromContentStyle Method (TransitioningContentPresenter, FrameworkElement, FrameworkElement)
Returns the Style to apply to the "from" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Style GetFromContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    FrameworkElement toContent
)
Protected Overridable Function GetFromContentStyle (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    toContent As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.

Return Value

Type: Style
The Style to apply to the "from" content during the transition.
See Also

Reference

StoryboardContentTransitionBase Class
GetFromContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetToContentStoryboard Method

StoryboardContentTransitionBaseGetToContentStoryboard Method
Returns the Storyboard to apply to the "to" content.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Storyboard GetToContentStoryboard(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overridable Function GetToContentStoryboard (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Storyboard

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Storyboard
The Storyboard to apply to the "to" content.
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetToContentStyle Method

StoryboardContentTransitionBaseGetToContentStyle Method
Overload List
 | Name | Description
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement) | Returns the Style to apply to the "to" content during the transition.
Protected method | GetToContentStyle(TransitioningContentPresenter, FrameworkElement, FrameworkElement) | Returns the Style to apply to the "to" content during the transition.
Top
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetToContentStyle Method (TransitioningContentPresenter, FrameworkElement)

StoryboardContentTransitionBaseGetToContentStyle Method (TransitioningContentPresenter, FrameworkElement)
Returns the Style to apply to the "to" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Style GetToContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement content
)
Protected Overridable Function GetToContentStyle (
    presenter As TransitioningContentPresenter,
    content As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
content
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.

Return Value

Type: Style
The Style to apply to the "to" content during the transition.
See Also

Reference

StoryboardContentTransitionBase Class
GetToContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.GetToContentStyle Method (TransitioningContentPresenter, FrameworkElement, FrameworkElement)

StoryboardContentTransitionBaseGetToContentStyle Method (TransitioningContentPresenter, FrameworkElement, FrameworkElement)
Returns the Style to apply to the "to" content during the transition.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Style GetToContentStyle(
    TransitioningContentPresenter presenter,
    FrameworkElement toContent,
    FrameworkElement fromContent
)
Protected Overridable Function GetToContentStyle (
    presenter As TransitioningContentPresenter,
    toContent As FrameworkElement,
    fromContent As FrameworkElement
) As Style

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
toContent
Type: Windows.UI.XamlFrameworkElement
The element requesting a Style.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.

Return Value

Type: Style
The Style to apply to the "to" content during the transition.
See Also

Reference

StoryboardContentTransitionBase Class
GetToContentStyle Overload
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.OnCompleted Method

StoryboardContentTransitionBaseOnCompleted Method
Occurs when the transition has completed.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnCompleted(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    Object fromContentData,
    FrameworkElement toContent,
    Object toContentData
)
Protected Overrides Sub OnCompleted (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    fromContentData As Object,
    toContent As FrameworkElement,
    toContentData As Object
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
fromContentData
Type: SystemObject
Optional data related to the "from" element.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.
toContentData
Type: SystemObject
Optional data related to the "to" element.
Remarks
Place code to perform any post-transition cleanup in an override of this method.
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.OnStarted Method

StoryboardContentTransitionBaseOnStarted Method
Occurs when the transition should be started.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnStarted(
    TransitioningContentPresenter presenter,
    FrameworkElement fromContent,
    FrameworkElement toContent
)
Protected Overrides Sub OnStarted (
    presenter As TransitioningContentPresenter,
    fromContent As FrameworkElement,
    toContent As FrameworkElement
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.
fromContent
Type: Windows.UI.XamlFrameworkElement
The element from which a transition is occurring.
toContent
Type: Windows.UI.XamlFrameworkElement
The element to which a transition is occurring.
Remarks
Place code to perform the transition in an override of this method.
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


StoryboardContentTransitionBase.StopTransition Method

StoryboardContentTransitionBaseStopTransition Method
Stops the transition if it is currently running.

Namespace: ActiproSoftware.UI.Xaml.Controls.ContentTransitions
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void StopTransition(
    TransitioningContentPresenter presenter
)
Public Overrides Sub StopTransition (
    presenter As TransitioningContentPresenter
)

Parameters

presenter
Type: ActiproSoftware.UI.Xaml.ControlsTransitioningContentPresenter
The TransitioningContentPresenter that is managing the transition.

Implements

IContentTransitionStopTransition(TransitioningContentPresenter)
See Also

Reference

StoryboardContentTransitionBase Class
ActiproSoftware.UI.Xaml.Controls.ContentTransitions Namespace


ActiproSoftware.UI.Xaml.Controls.Docking Namespace

ActiproSoftware.UI.Xaml.Controls.Docking Namespace
Contains classes that support implementing docking windows & MDI.
Classes
 | Class | Description
Public class | AdvancedTabControl | Represents a tab control with advanced features.
Public class | AdvancedTabControlMenuEventArgs | Provides event arguments for customizing a menu that is opening within an AdvancedTabControl.
Public class | AdvancedTabItem | Represents a tab item for use in an AdvancedTabControl.
Public class | AdvancedTabItemEventArgs | Provides event arguments for AdvancedTabItem-related drag events.
Public class | ContextContentAlignment | Indicates the alignment around the primary content (e.g. title) that the contextual content appears.
Public class | DockGuideKinds | Specifies multiple dock guide kinds.
Public class | DockHost | Represents a root host that can contain a docking window hierarchy.
Public class | DockingMenuEventArgs | Provides event arguments for customizing a docking-related context or drop-down menu.
Public class | DockingMenuKind | Specifies the kind of context or drop-down menu used by the docking elements.
Public class | DockingWindow | Represents the base class for a docking window implementation.
Public class | DockingWindowCollection | Represents an observable collection of DockingWindow objects.
Public class | DockingWindowCollectionBaseT | Represents the base class for an observable collection of DockingWindow objects.
Public class | DockingWindowDefaultLocationEventArgs | Provides event arguments for DockingWindow-related default location events.
Public class | DockingWindowEventArgs | Provides event arguments for DockingWindow-related events.
Public class | DockingWindowItemKind | Indicates the kind of container that is generated for a DockSite item.
Public class | DockingWindowsAutoHidingEventArgs | Provides event arguments for DockingWindow auto-hiding events.
Public class | DockingWindowsDragOverEventArgs | Provides event arguments for when one or more docking windows are dragged over a new dock target, with support for hiding certain dock guides by altering the AllowedDockGuideKinds property.
Public class | DockingWindowsEventArgs | Provides event arguments for DockingWindow-related events that deal with potentially muliple windows.
Public class | DockingWindowState | Indicates the state for a DockingWindow.
Public class | DockSite | Represents a dock site, the root control for docking window host functionality.
Public class | DocumentWindow | Represents a document window.
Public class | DocumentWindowCollection | Represents an observable collection of DocumentWindow objects.
Public class | FloatingWindowOpeningEventArgs | Provides event arguments for floating window opening events.
Public class | MdiKind | Specifies the kind of MDI (multiple-document interface).
Public class | ReadOnlyDockingWindowBaseCollectionT | Represents the base class for a read-only observable collection of DockingWindow objects.
Public class | ReadOnlyDockingWindowCollection | Represents a read-only observable collection of DockingWindow objects.
Public class | ReadOnlyToolWindowCollection | Represents a read-only observable collection of ToolWindow objects.
Public class | ResizeMode | Specifies whether a window can be resized and, if so, how it can be resized.
Public class | SimpleSwitcher | Implements a SwitcherBase that has no user interface and simply processes keystrokes.
Public class | SingleTabLayoutBehavior | Indicates the behavior of single tabs in their associated containers.
Public class | SizeToContentModes | Specifies the modes when size-to-content should be applied.
Public class | SplitContainer | Represents a container that has multiple split panes of content.
Public class | StandardMdiHost | Represents a container that hosts docking windows in a standard, or windowed, MDI (multiple-document interface) mode.
Public class | StandardSwitcher | Implements a SwitcherBase that is similar to the switcher found in Visual Studio.
Public class | TabbedMdiContainer | Represents a container of one or more documents in tabbed MDI.
Public class | TabbedMdiHost | Represents a container that hosts docking windows in a tabbed MDI (multiple-document interface) mode.
Public class | TabFlashMode | Specifies the flash mode to apply to a tab.
Public class | TabHighlightKind | Specifies the kind of highlight to apply to a tab.
Public class | TabLayoutKind | Specifies the kind of tab, which affects its layout.
Public class | TabOverflowBehavior | Indicates the overflow behavior of tabs.
Public class | ToolWindow | Represents a tool window.
Public class | ToolWindowCollection | Represents an observable collection of ToolWindow objects.
Public class | ToolWindowContainer | Represents a container of one or more tool windows.
Public class | ToolWindowContainerCollection | Represents an observable collection of ToolWindowContainer objects.
Public class | WindowControl | Represents a ContentControl that renders like a normal native Window but can be used in other non-top-level contexts.
Public class | WindowState | Specifies whether a window is minimized, maximized, or restored.
Public class | Workspace | Represents a control that can contain a MDI host, and around which tool windows are docked.
Interfaces
 | Interface | Description
Public interface | IDockTarget | Provides the base requirements for an object that is a possible target for a docking operation.


AdvancedTabControl Class

AdvancedTabControl Class
Represents a tab control with advanced features.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesTabbedMdiContainerTabControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesToolWindowContainerTabControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabControl : ItemsControl
Public Class AdvancedTabControl
    Inherits ItemsControl

The AdvancedTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabControl | Initializes an instance of the AdvancedTabControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible.
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported.
Public property | CanScrollForward | Gets whether scrolling forward is supported.
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled.
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones.
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button.
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border.
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border.
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed.
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible.
Public property | IsOverflowed | Gets whether the tabs are overflowed.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation.
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled.
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible.
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu.
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab.
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement.
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content.
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward.
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content.
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward.
Public property | ScrollOffset | Gets the scroll offset.
Public property | SelectedContent | Gets the selected content.
Public property | SelectedContentTemplate | Gets the selected content template.
Public property | SelectedContentTemplateSelector | Gets the selected content template selector.
Public property | SelectedItem | Gets or sets the selected item.
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use.
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active.
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive.
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it.
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab.
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use.
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active.
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive.
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it.
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab.
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab.
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs.
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use.
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active.
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive.
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it.
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab.
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabPadding | Gets or sets the tab padding.
Public property | TabSpacing | Gets or sets the spacing between tabs.
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection changes. (Overrides ItemsControlOnItemsChanged(Object).)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectionChanged | Occurs when the selection is changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MenuOpening | Occurs before a context or drop-down menu is opening.
Public event | NewTabRequested | Occurs when a new tab is requested.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button.
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreScrollButtonsVisibleProperty | Identifies the AreScrollButtonsVisible dependency property. This field is read-only.
AreTabEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreTabEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
CanScrollBackwardProperty | Identifies the CanScrollBackward dependency property. This field is read-only.
CanScrollForwardProperty | Identifies the CanScrollForward dependency property. This field is read-only.
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
CanTabsDragProperty | Identifies the CanTabsDrag dependency property. This field is read-only.
CanTabsHighlightOnPointerOverWhenInactiveProperty | Identifies the CanTabsHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanTabsPinProperty | Identifies the CanTabsPin dependency property. This field is read-only.
CanTabsPromoteProperty | Identifies the CanTabsPromote dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HighlightBrushActiveProperty | Identifies the HighlightBrushActive dependency property. This field is read-only.
HighlightBrushInactiveProperty | Identifies the HighlightBrushInactive dependency property. This field is read-only.
HighlightThicknessProperty | Identifies the HighlightThickness dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
IsLayoutAnimationEnabledProperty | Identifies the IsLayoutAnimationEnabled dependency property. This field is read-only.
IsMenuButtonVisibleProperty | Identifies the IsMenuButtonVisible dependency property. This field is read-only.
IsOverflowedProperty | Identifies the IsOverflowed dependency property. This field is read-only.
IsTabContentHorizontalProperty | Identifies the IsTabContentHorizontal dependency property. This field is read-only.
IsTabKeyboardAccessEnabledProperty | Identifies the IsTabKeyboardAccessEnabled dependency property. This field is read-only.
IsTabKeyboardSwitchingEnabledProperty | Identifies the IsTabKeyboardSwitchingEnabled dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
NewTabButtonStyleProperty | Identifies the NewTabButtonStyle dependency property. This field is read-only.
OverflowMenuButtonContentTemplateProperty | Identifies the OverflowMenuButtonContentTemplate dependency property. This field is read-only.
RotatedBorderThicknessProperty | Identifies the RotatedBorderThickness dependency property. This field is read-only.
RotatedHighlightThicknessProperty | Identifies the RotatedHighlightThickness dependency property. This field is read-only.
RotatedPaddingProperty | Identifies the RotatedPadding dependency property. This field is read-only.
ScrollBackwardButtonContentTemplateProperty | Identifies the ScrollBackwardButtonContentTemplate dependency property. This field is read-only.
ScrollForwardButtonContentTemplateProperty | Identifies the ScrollForwardButtonContentTemplate dependency property. This field is read-only.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property. This field is read-only.
SelectedContentProperty | Identifies the SelectedContent dependency property. This field is read-only.
SelectedContentTemplateProperty | Identifies the SelectedContentTemplate dependency property. This field is read-only.
SelectedContentTemplateSelectorProperty | Identifies the SelectedContentTemplateSelector dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
TabBackgroundActiveSelectedProperty | Identifies the TabBackgroundActiveSelected dependency property. This field is read-only.
TabBackgroundInactiveSelectedProperty | Identifies the TabBackgroundInactiveSelected dependency property. This field is read-only.
TabBackgroundPointerOverProperty | Identifies the TabBackgroundPointerOver dependency property. This field is read-only.
TabBackgroundPreviewActiveSelectedProperty | Identifies the TabBackgroundPreviewActiveSelected dependency property. This field is read-only.
TabBackgroundPreviewPointerOverProperty | Identifies the TabBackgroundPreviewPointerOver dependency property. This field is read-only.
TabBackgroundPreviewProperty | Identifies the TabBackgroundPreview dependency property. This field is read-only.
TabBackgroundProperty | Identifies the TabBackground dependency property. This field is read-only.
TabBorderBrushActiveSelectedProperty | Identifies the TabBorderBrushActiveSelected dependency property. This field is read-only.
TabBorderBrushInactiveSelectedProperty | Identifies the TabBorderBrushInactiveSelected dependency property. This field is read-only.
TabBorderBrushPointerOverProperty | Identifies the TabBorderBrushPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewActiveSelectedProperty | Identifies the TabBorderBrushPreviewActiveSelected dependency property. This field is read-only.
TabBorderBrushPreviewPointerOverProperty | Identifies the TabBorderBrushPreviewPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewProperty | Identifies the TabBorderBrushPreview dependency property. This field is read-only.
TabBorderBrushProperty | Identifies the TabBorderBrush dependency property. This field is read-only.
TabCornerRadiusProperty | Identifies the TabCornerRadius dependency property. This field is read-only.
TabEmbeddedButtonStyleProperty | Identifies the TabEmbeddedButtonStyle dependency property. This field is read-only.
TabForegroundActiveSelectedProperty | Identifies the TabForegroundActiveSelected dependency property. This field is read-only.
TabForegroundInactiveSelectedProperty | Identifies the TabForegroundInactiveSelected dependency property. This field is read-only.
TabForegroundPointerOverProperty | Identifies the TabForegroundPointerOver dependency property. This field is read-only.
TabForegroundPreviewActiveSelectedProperty | Identifies the TabForegroundPreviewActiveSelected dependency property. This field is read-only.
TabForegroundPreviewPointerOverProperty | Identifies the TabForegroundPreviewPointerOver dependency property. This field is read-only.
TabForegroundPreviewProperty | Identifies the TabForegroundPreview dependency property. This field is read-only.
TabForegroundProperty | Identifies the TabForeground dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabPaddingProperty | Identifies the TabPadding dependency property. This field is read-only.
TabSpacingProperty | Identifies the TabSpacing dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl Constructor

AdvancedTabControl Constructor
Initializes an instance of the AdvancedTabControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabControl()
Public Sub New
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl Properties

AdvancedTabControl Properties

The AdvancedTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible.
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported.
Public property | CanScrollForward | Gets whether scrolling forward is supported.
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled.
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones.
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button.
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border.
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border.
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed.
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible.
Public property | IsOverflowed | Gets whether the tabs are overflowed.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation.
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled.
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible.
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu.
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab.
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement.
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement.
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content.
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward.
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content.
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward.
Public property | ScrollOffset | Gets the scroll offset.
Public property | SelectedContent | Gets the selected content.
Public property | SelectedContentTemplate | Gets the selected content template.
Public property | SelectedContentTemplateSelector | Gets the selected content template selector.
Public property | SelectedItem | Gets or sets the selected item.
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use.
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active.
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive.
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it.
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab.
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use.
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active.
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive.
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it.
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab.
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab.
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs.
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use.
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active.
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive.
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it.
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab.
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabPadding | Gets or sets the tab padding.
Public property | TabSpacing | Gets or sets the spacing between tabs.
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.AreScrollButtonsVisible Property

AdvancedTabControlAreScrollButtonsVisible Property
Gets whether the scroll buttons are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreScrollButtonsVisible { get; }
Public ReadOnly Property AreScrollButtonsVisible As Boolean
    Get

Property Value

Type: Boolean
true if the scroll buttons are visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.AreTabEmbeddedButtonsAlwaysVisible Property

AdvancedTabControlAreTabEmbeddedButtonsAlwaysVisible Property
Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreTabEmbeddedButtonsAlwaysVisible { get; set; }
Public Property AreTabEmbeddedButtonsAlwaysVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tab embedded buttons are always visible, even when the tab is unselected; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanScrollBackward Property

AdvancedTabControlCanScrollBackward Property
Gets whether scrolling backward is supported.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanScrollBackward { get; }
Public ReadOnly Property CanScrollBackward As Boolean
    Get

Property Value

Type: Boolean
true if scrolling backward is supported; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanScrollForward Property

AdvancedTabControlCanScrollForward Property
Gets whether scrolling forward is supported.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanScrollForward { get; }
Public ReadOnly Property CanScrollForward As Boolean
    Get

Property Value

Type: Boolean
true if scrolling forward is supported; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsCloseOnMiddleClick Property

AdvancedTabControlCanTabsCloseOnMiddleClick Property
Gets or sets whether tabs can close when a middle-click is performed over them.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanTabsCloseOnMiddleClick { get; set; }
Public Property CanTabsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can close when a middle-click is performed over them; otherwise, false. The default value is true.
Remarks
The CanClose property must also be set to true for this behavior to work.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsDrag Property

AdvancedTabControlCanTabsDrag Property
Gets or sets whether the dragging of tabs to reorder is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanTabsDrag { get; set; }
Public Property CanTabsDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dragging of tabs to reorder is enabled; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsHighlightOnPointerOverWhenInactive Property

AdvancedTabControlCanTabsHighlightOnPointerOverWhenInactive Property
Gets or sets whether tabs can highlight when the pointer is over inactive ones.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanTabsHighlightOnPointerOverWhenInactive { get; set; }
Public Property CanTabsHighlightOnPointerOverWhenInactive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can highlight when the pointer is over inactive ones; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsPin Property

AdvancedTabControlCanTabsPin Property
Gets or sets whether tabs display an embedded pin button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanTabsPin { get; set; }
Public Property CanTabsPin As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded pin button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsPromote Property

AdvancedTabControlCanTabsPromote Property
Gets or sets whether tabs display an embedded promote from preview layout kind button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanTabsPromote { get; set; }
Public Property CanTabsPromote As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded promote from preview layout kind button; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.EmbeddedButtonStyle Property

AdvancedTabControlEmbeddedButtonStyle Property
Gets or sets the Style to use for embedded buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style EmbeddedButtonStyle { get; set; }
Public Property EmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HasNewTabButton Property

AdvancedTabControlHasNewTabButton Property
Gets or sets whether a new tab button is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNewTabButton { get; set; }
Public Property HasNewTabButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a new tab button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HasTabCloseButtons Property

AdvancedTabControlHasTabCloseButtons Property
Gets or sets whether tabs have an embedded close button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabCloseButtons { get; set; }
Public Property HasTabCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs have an embedded close button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HasTabImages Property

AdvancedTabControlHasTabImages Property
Gets or sets whether tabs display an embedded image when one is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabImages { get; set; }
Public Property HasTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded image when one is available; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushActive Property

AdvancedTabControlHighlightBrushActive Property
Gets or sets the Brush to use for rendering an active highlight effect around the content border.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush HighlightBrushActive { get; set; }
Public Property HighlightBrushActive As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering an active highlight effect around the content border.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushInactive Property

AdvancedTabControlHighlightBrushInactive Property
Gets or sets the Brush to use for rendering an inactive highlight effect around the content border.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush HighlightBrushInactive { get; set; }
Public Property HighlightBrushInactive As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering an inactive highlight effect around the content border. The default value is 0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HighlightThickness Property

AdvancedTabControlHighlightThickness Property
Gets or sets the thickness of the highlight effect around the content border.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness HighlightThickness { get; set; }
Public Property HighlightThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The thickness of the highlight effect around the content border. The default value is 0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsActive Property

AdvancedTabControlIsActive Property
Gets or sets whether the tab control is active, generally meaning it contains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab control is active; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsKeyboardFocusWithin Property

AdvancedTabControlIsKeyboardFocusWithin Property
Gets whether keyboard focus is within the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsKeyboardFocusWithin { get; }
Public ReadOnly Property IsKeyboardFocusWithin As Boolean
    Get

Property Value

Type: Boolean
true if keyboard focus is within the control; otherwise, false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsLayoutAnimationEnabled Property

AdvancedTabControlIsLayoutAnimationEnabled Property
Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLayoutAnimationEnabled { get; set; }
Public Property IsLayoutAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects are applied during layout, such as when tabs are added or removed; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsMenuButtonVisible Property

AdvancedTabControlIsMenuButtonVisible Property
Gets whether the drop-down menu button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMenuButtonVisible { get; }
Public ReadOnly Property IsMenuButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the drop-down menu button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsOverflowed Property

AdvancedTabControlIsOverflowed Property
Gets whether the tabs are overflowed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOverflowed { get; }
Public ReadOnly Property IsOverflowed As Boolean
    Get

Property Value

Type: Boolean
true if the tabs are overflowed; otherwise, false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabContentHorizontal Property

AdvancedTabControlIsTabContentHorizontal Property
Gets or sets whether the tab content layout is in a horizontal orientation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabContentHorizontal { get; set; }
Public Property IsTabContentHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab content layout is in a horizontal orientation; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardAccessEnabled Property

AdvancedTabControlIsTabKeyboardAccessEnabled Property
Gets or sets whether keyboard access to directly select a tab is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabKeyboardAccessEnabled { get; set; }
Public Property IsTabKeyboardAccessEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if keyboard access to directly select a tab is enabled; otherwise, false. The default value is true.
Remarks
When enabled, Ctrl+1 will activate the first tab in a normal state, with Ctrl+2 activating the second normal tab, and so on. Ctrl+Alt+1 will activate the first tab in a pinned state, with Ctrl+Alt+2 activating the second pinned tab, and so on.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardSwitchingEnabled Property

AdvancedTabControlIsTabKeyboardSwitchingEnabled Property
Gets or sets whether keyboard access to switch to the previous/next tab is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabKeyboardSwitchingEnabled { get; set; }
Public Property IsTabKeyboardSwitchingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if keyboard access to switch to the previous/next tab is enabled; otherwise, false. The default value is true.
Remarks
When enabled, Ctrl+Tab will switch to the next tab and Ctrl+Shift+Tab will switch to the previous tab.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabStripVisible Property

AdvancedTabControlIsTabStripVisible Property
Gets or sets whether the tabstrip is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabStripVisible { get; set; }
Public Property IsTabStripVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tabstrip is visible; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MaxTabExtent Property

AdvancedTabControlMaxTabExtent Property
Gets or sets the maximum extent of a tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MaxTabExtent { get; set; }
Public Property MaxTabExtent As Double
    Get
    Set

Property Value

Type: Double
The maximum extent of a tab. The default value is 260.0.
Remarks
Set the MinTabExtent to the same as the MaxTabExtent to produce fixed-size tabs.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MenuButtonContentTemplate Property

AdvancedTabControlMenuButtonContentTemplate Property
Gets or sets the DataTemplate to use for the drop-down menu button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate MenuButtonContentTemplate { get; set; }
Public Property MenuButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the drop-down menu button content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MinTabExtent Property

AdvancedTabControlMinTabExtent Property
Gets or sets the minimum extent of a tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinTabExtent { get; set; }
Public Property MinTabExtent As Double
    Get
    Set

Property Value

Type: Double
The minimum extent of a tab. The default value is 30.0.
Remarks
Set the MinTabExtent to the same as the MaxTabExtent to produce fixed-size tabs. This property will be ignored when a TabOverflowBehavior that involves shrinking is active and the tabs enter an overflow scenario.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.NewTabButtonStyle Property

AdvancedTabControlNewTabButtonStyle Property
Gets or sets the Style to use for the new tab button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style NewTabButtonStyle { get; set; }
Public Property NewTabButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the new tab button.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OpenMenuCommand Property

AdvancedTabControlOpenMenuCommand Property
Gets the ICommand that can be used to open the drop-down menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand OpenMenuCommand { get; }
Public ReadOnly Property OpenMenuCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to open the drop-down menu.
Remarks
Pass the source button element as the command parameter.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OverflowMenuButtonContentTemplate Property

AdvancedTabControlOverflowMenuButtonContentTemplate Property
Gets or sets the DataTemplate to use for the overflow drop-down menu button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate OverflowMenuButtonContentTemplate { get; set; }
Public Property OverflowMenuButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the overflow drop-down menu button content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RequestNewTabCommand Property

AdvancedTabControlRequestNewTabCommand Property
Gets the ICommand that can be used to request a new tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RequestNewTabCommand { get; }
Public ReadOnly Property RequestNewTabCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to request a new tab.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RotatedBorderThickness Property

AdvancedTabControlRotatedBorderThickness Property
Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness RotatedBorderThickness { get; set; }
Public Property RotatedBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The BorderThickness value, but automatically rotated based on the TabStripPlacement. The default value is 0.
Remarks
This property should not be set, as it will be set internally.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RotatedHighlightThickness Property

AdvancedTabControlRotatedHighlightThickness Property
Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness RotatedHighlightThickness { get; set; }
Public Property RotatedHighlightThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The HighlightThickness value, but automatically rotated based on the TabStripPlacement. The default value is 0.
Remarks
This property should not be set, as it will be set internally.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RotatedPadding Property

AdvancedTabControlRotatedPadding Property
Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness RotatedPadding { get; set; }
Public Property RotatedPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Padding value, but automatically rotated based on the TabStripPlacement. The default value is 0.
Remarks
This property should not be set, as it will be set internally.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollBackwardButtonContentTemplate Property

AdvancedTabControlScrollBackwardButtonContentTemplate Property
Gets or sets the DataTemplate to use for the scroll backward button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollBackwardButtonContentTemplate { get; set; }
Public Property ScrollBackwardButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll backward content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollBackwardCommand Property

AdvancedTabControlScrollBackwardCommand Property
Gets the ICommand that can be used to scroll backward.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ScrollBackwardCommand { get; }
Public ReadOnly Property ScrollBackwardCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to scroll backward.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollForwardButtonContentTemplate Property

AdvancedTabControlScrollForwardButtonContentTemplate Property
Gets or sets the DataTemplate to use for the scroll forward button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollForwardButtonContentTemplate { get; set; }
Public Property ScrollForwardButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll forward content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollForwardCommand Property

AdvancedTabControlScrollForwardCommand Property
Gets the ICommand that can be used to scroll forward.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ScrollForwardCommand { get; }
Public ReadOnly Property ScrollForwardCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to scroll forward.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollOffset Property

AdvancedTabControlScrollOffset Property
Gets the scroll offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ScrollOffset { get; }
Public ReadOnly Property ScrollOffset As Double
    Get

Property Value

Type: Double
The scroll offset.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedContent Property

AdvancedTabControlSelectedContent Property
Gets the selected content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object SelectedContent { get; }
Public ReadOnly Property SelectedContent As Object
    Get

Property Value

Type: Object
The selected content.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedContentTemplate Property

AdvancedTabControlSelectedContentTemplate Property
Gets the selected content template.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate SelectedContentTemplate { get; }
Public ReadOnly Property SelectedContentTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The selected content template.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedContentTemplateSelector Property

AdvancedTabControlSelectedContentTemplateSelector Property
Gets the selected content template selector.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector SelectedContentTemplateSelector { get; }
Public ReadOnly Property SelectedContentTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The selected content template selector.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedItem Property

AdvancedTabControlSelectedItem Property
Gets or sets the selected item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object SelectedItem { get; set; }
Public Property SelectedItem As Object
    Get
    Set

Property Value

Type: Object
The selected item.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectItemCommand Property

AdvancedTabControlSelectItemCommand Property
Gets the ICommand that can be used to select an item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SelectItemCommand { get; }
Public ReadOnly Property SelectItemCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to select an item.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackground Property

AdvancedTabControlTabBackground Property
Gets or sets the tabs' background Brush to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackground { get; set; }
Public Property TabBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundActiveSelected Property

AdvancedTabControlTabBackgroundActiveSelected Property
Gets or sets the tabs' background Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackgroundActiveSelected { get; set; }
Public Property TabBackgroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundInactiveSelected Property

AdvancedTabControlTabBackgroundInactiveSelected Property
Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackgroundInactiveSelected { get; set; }
Public Property TabBackgroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPointerOver Property

AdvancedTabControlTabBackgroundPointerOver Property
Gets or sets the tabs' background Brush to use when the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPointerOver { get; set; }
Public Property TabBackgroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreview Property

AdvancedTabControlTabBackgroundPreview Property
Gets or sets the tabs' background Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPreview { get; set; }
Public Property TabBackgroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewActiveSelected Property

AdvancedTabControlTabBackgroundPreviewActiveSelected Property
Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPreviewActiveSelected { get; set; }
Public Property TabBackgroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewPointerOver Property

AdvancedTabControlTabBackgroundPreviewPointerOver Property
Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBackgroundPreviewPointerOver { get; set; }
Public Property TabBackgroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrush Property

AdvancedTabControlTabBorderBrush Property
Gets or sets the tabs' border Brush to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrush { get; set; }
Public Property TabBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushActiveSelected Property

AdvancedTabControlTabBorderBrushActiveSelected Property
Gets or sets the tabs' border Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushActiveSelected { get; set; }
Public Property TabBorderBrushActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushInactiveSelected Property

AdvancedTabControlTabBorderBrushInactiveSelected Property
Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushInactiveSelected { get; set; }
Public Property TabBorderBrushInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPointerOver Property

AdvancedTabControlTabBorderBrushPointerOver Property
Gets or sets the tabs' border Brush to use when the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPointerOver { get; set; }
Public Property TabBorderBrushPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreview Property

AdvancedTabControlTabBorderBrushPreview Property
Gets or sets the tabs' border Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPreview { get; set; }
Public Property TabBorderBrushPreview As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewActiveSelected Property

AdvancedTabControlTabBorderBrushPreviewActiveSelected Property
Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPreviewActiveSelected { get; set; }
Public Property TabBorderBrushPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewPointerOver Property

AdvancedTabControlTabBorderBrushPreviewPointerOver Property
Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabBorderBrushPreviewPointerOver { get; set; }
Public Property TabBorderBrushPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabCornerRadius Property

AdvancedTabControlTabCornerRadius Property
Gets or sets the corner radius of tab borders, relative to a top-facing tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius TabCornerRadius { get; set; }
Public Property TabCornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of tab borders, relative to a top-facing tab.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabEmbeddedButtonStyle Property

AdvancedTabControlTabEmbeddedButtonStyle Property
Gets or sets the Style to use for embedded buttons within tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TabEmbeddedButtonStyle { get; set; }
Public Property TabEmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons within tabs.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForeground Property

AdvancedTabControlTabForeground Property
Gets or sets the tabs' foreground Brush to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForeground { get; set; }
Public Property TabForeground As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundActiveSelected Property

AdvancedTabControlTabForegroundActiveSelected Property
Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForegroundActiveSelected { get; set; }
Public Property TabForegroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundInactiveSelected Property

AdvancedTabControlTabForegroundInactiveSelected Property
Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForegroundInactiveSelected { get; set; }
Public Property TabForegroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPointerOver Property

AdvancedTabControlTabForegroundPointerOver Property
Gets or sets the tabs' foreground Brush to use when the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForegroundPointerOver { get; set; }
Public Property TabForegroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreview Property

AdvancedTabControlTabForegroundPreview Property
Gets or sets the tabs' foreground Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForegroundPreview { get; set; }
Public Property TabForegroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewActiveSelected Property

AdvancedTabControlTabForegroundPreviewActiveSelected Property
Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForegroundPreviewActiveSelected { get; set; }
Public Property TabForegroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewPointerOver Property

AdvancedTabControlTabForegroundPreviewPointerOver Property
Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush TabForegroundPreviewPointerOver { get; set; }
Public Property TabForegroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabOverflowBehavior Property

AdvancedTabControlTabOverflowBehavior Property
Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabOverflowBehavior TabOverflowBehavior { get; set; }
Public Property TabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. The default value is Shrink.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabPadding Property

AdvancedTabControlTabPadding Property
Gets or sets the tab padding.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness TabPadding { get; set; }
Public Property TabPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The tab padding. The default value is 5,2.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabSpacing Property

AdvancedTabControlTabSpacing Property
Gets or sets the spacing between tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TabSpacing { get; set; }
Public Property TabSpacing As Double
    Get
    Set

Property Value

Type: Double
The spacing between tabs. The default value is 0.0.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabStripPlacement Property

AdvancedTabControlTabStripPlacement Property
Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed. The default value is Top.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl Methods

AdvancedTabControl Methods

The AdvancedTabControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection changes. (Overrides ItemsControlOnItemsChanged(Object).)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectionChanged | Occurs when the selection is changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ArrangeOverride Method

AdvancedTabControlArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ArrangeOverride Method (Size)

AdvancedTabControlArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

AdvancedTabControl Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ClearContainerForItemOverride Method

AdvancedTabControlClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.GetContainerForItemOverride Method

AdvancedTabControlGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsItemItsOwnContainerOverride Method

AdvancedTabControlIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnApplyTemplate Method

AdvancedTabControlOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnCreateAutomationPeer Method

AdvancedTabControlOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnGotFocus Method

AdvancedTabControlOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnItemsChanged Method

AdvancedTabControlOnItemsChanged Method
Occurs when the Items collection changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemsChanged(
    Object e
)
Protected Overrides Sub OnItemsChanged (
    e As Object
)

Parameters

e
Type: SystemObject
The event arguments.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnKeyDown Method

AdvancedTabControlOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnLostFocus Method

AdvancedTabControlOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OnSelectionChanged Method

AdvancedTabControlOnSelectionChanged Method
Occurs when the selection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.ControlsSelectionChangedEventArgs
The SelectionChangedEventArgs containing data related to this event.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.PrepareContainerForItemOverride Method

AdvancedTabControlPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.UpdateHighlightBrushes Method

AdvancedTabControlUpdateHighlightBrushes Method
Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateHighlightBrushes()
Protected Overridable Sub UpdateHighlightBrushes
Remarks
The default implementation of this method does nothing.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl Events

AdvancedTabControl Events

The AdvancedTabControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MenuOpening | Occurs before a context or drop-down menu is opening.
Public event | NewTabRequested | Occurs when a new tab is requested.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button.
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MenuOpening Event

AdvancedTabControlMenuOpening Event
Occurs before a context or drop-down menu is opening.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<AdvancedTabControlMenuEventArgs> MenuOpening
Public Event MenuOpening As EventHandler(Of AdvancedTabControlMenuEventArgs)

Value

Type: SystemEventHandler AdvancedTabControlMenuEventArgs
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.NewTabRequested Event

AdvancedTabControlNewTabRequested Event
Occurs when a new tab is requested.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler NewTabRequested
Public Event NewTabRequested As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabClosing Event

AdvancedTabControlTabClosing Event
Occurs before a tab is closed due to clicking on its close button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<AdvancedTabItemEventArgs> TabClosing
Public Event TabClosing As EventHandler(Of AdvancedTabItemEventArgs)

Value

Type: SystemEventHandler AdvancedTabItemEventArgs
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl Fields

AdvancedTabControl Fields

The AdvancedTabControl type exposes the following members.

Fields
Name | Description
AreScrollButtonsVisibleProperty | Identifies the AreScrollButtonsVisible dependency property. This field is read-only.
AreTabEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreTabEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
CanScrollBackwardProperty | Identifies the CanScrollBackward dependency property. This field is read-only.
CanScrollForwardProperty | Identifies the CanScrollForward dependency property. This field is read-only.
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
CanTabsDragProperty | Identifies the CanTabsDrag dependency property. This field is read-only.
CanTabsHighlightOnPointerOverWhenInactiveProperty | Identifies the CanTabsHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanTabsPinProperty | Identifies the CanTabsPin dependency property. This field is read-only.
CanTabsPromoteProperty | Identifies the CanTabsPromote dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HighlightBrushActiveProperty | Identifies the HighlightBrushActive dependency property. This field is read-only.
HighlightBrushInactiveProperty | Identifies the HighlightBrushInactive dependency property. This field is read-only.
HighlightThicknessProperty | Identifies the HighlightThickness dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
IsLayoutAnimationEnabledProperty | Identifies the IsLayoutAnimationEnabled dependency property. This field is read-only.
IsMenuButtonVisibleProperty | Identifies the IsMenuButtonVisible dependency property. This field is read-only.
IsOverflowedProperty | Identifies the IsOverflowed dependency property. This field is read-only.
IsTabContentHorizontalProperty | Identifies the IsTabContentHorizontal dependency property. This field is read-only.
IsTabKeyboardAccessEnabledProperty | Identifies the IsTabKeyboardAccessEnabled dependency property. This field is read-only.
IsTabKeyboardSwitchingEnabledProperty | Identifies the IsTabKeyboardSwitchingEnabled dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
NewTabButtonStyleProperty | Identifies the NewTabButtonStyle dependency property. This field is read-only.
OverflowMenuButtonContentTemplateProperty | Identifies the OverflowMenuButtonContentTemplate dependency property. This field is read-only.
RotatedBorderThicknessProperty | Identifies the RotatedBorderThickness dependency property. This field is read-only.
RotatedHighlightThicknessProperty | Identifies the RotatedHighlightThickness dependency property. This field is read-only.
RotatedPaddingProperty | Identifies the RotatedPadding dependency property. This field is read-only.
ScrollBackwardButtonContentTemplateProperty | Identifies the ScrollBackwardButtonContentTemplate dependency property. This field is read-only.
ScrollForwardButtonContentTemplateProperty | Identifies the ScrollForwardButtonContentTemplate dependency property. This field is read-only.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property. This field is read-only.
SelectedContentProperty | Identifies the SelectedContent dependency property. This field is read-only.
SelectedContentTemplateProperty | Identifies the SelectedContentTemplate dependency property. This field is read-only.
SelectedContentTemplateSelectorProperty | Identifies the SelectedContentTemplateSelector dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
TabBackgroundActiveSelectedProperty | Identifies the TabBackgroundActiveSelected dependency property. This field is read-only.
TabBackgroundInactiveSelectedProperty | Identifies the TabBackgroundInactiveSelected dependency property. This field is read-only.
TabBackgroundPointerOverProperty | Identifies the TabBackgroundPointerOver dependency property. This field is read-only.
TabBackgroundPreviewActiveSelectedProperty | Identifies the TabBackgroundPreviewActiveSelected dependency property. This field is read-only.
TabBackgroundPreviewPointerOverProperty | Identifies the TabBackgroundPreviewPointerOver dependency property. This field is read-only.
TabBackgroundPreviewProperty | Identifies the TabBackgroundPreview dependency property. This field is read-only.
TabBackgroundProperty | Identifies the TabBackground dependency property. This field is read-only.
TabBorderBrushActiveSelectedProperty | Identifies the TabBorderBrushActiveSelected dependency property. This field is read-only.
TabBorderBrushInactiveSelectedProperty | Identifies the TabBorderBrushInactiveSelected dependency property. This field is read-only.
TabBorderBrushPointerOverProperty | Identifies the TabBorderBrushPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewActiveSelectedProperty | Identifies the TabBorderBrushPreviewActiveSelected dependency property. This field is read-only.
TabBorderBrushPreviewPointerOverProperty | Identifies the TabBorderBrushPreviewPointerOver dependency property. This field is read-only.
TabBorderBrushPreviewProperty | Identifies the TabBorderBrushPreview dependency property. This field is read-only.
TabBorderBrushProperty | Identifies the TabBorderBrush dependency property. This field is read-only.
TabCornerRadiusProperty | Identifies the TabCornerRadius dependency property. This field is read-only.
TabEmbeddedButtonStyleProperty | Identifies the TabEmbeddedButtonStyle dependency property. This field is read-only.
TabForegroundActiveSelectedProperty | Identifies the TabForegroundActiveSelected dependency property. This field is read-only.
TabForegroundInactiveSelectedProperty | Identifies the TabForegroundInactiveSelected dependency property. This field is read-only.
TabForegroundPointerOverProperty | Identifies the TabForegroundPointerOver dependency property. This field is read-only.
TabForegroundPreviewActiveSelectedProperty | Identifies the TabForegroundPreviewActiveSelected dependency property. This field is read-only.
TabForegroundPreviewPointerOverProperty | Identifies the TabForegroundPreviewPointerOver dependency property. This field is read-only.
TabForegroundPreviewProperty | Identifies the TabForegroundPreview dependency property. This field is read-only.
TabForegroundProperty | Identifies the TabForeground dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabPaddingProperty | Identifies the TabPadding dependency property. This field is read-only.
TabSpacingProperty | Identifies the TabSpacing dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.AreScrollButtonsVisibleProperty Field

AdvancedTabControlAreScrollButtonsVisibleProperty Field
Identifies the AreScrollButtonsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreScrollButtonsVisibleProperty
Public Shared ReadOnly AreScrollButtonsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreScrollButtonsVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.AreTabEmbeddedButtonsAlwaysVisibleProperty Field

AdvancedTabControlAreTabEmbeddedButtonsAlwaysVisibleProperty Field
Identifies the AreTabEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreTabEmbeddedButtonsAlwaysVisibleProperty
Public Shared ReadOnly AreTabEmbeddedButtonsAlwaysVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreTabEmbeddedButtonsAlwaysVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanScrollBackwardProperty Field

AdvancedTabControlCanScrollBackwardProperty Field
Identifies the CanScrollBackward dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanScrollBackwardProperty
Public Shared ReadOnly CanScrollBackwardProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanScrollBackward dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanScrollForwardProperty Field

AdvancedTabControlCanScrollForwardProperty Field
Identifies the CanScrollForward dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanScrollForwardProperty
Public Shared ReadOnly CanScrollForwardProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanScrollForward dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsCloseOnMiddleClickProperty Field

AdvancedTabControlCanTabsCloseOnMiddleClickProperty Field
Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsCloseOnMiddleClickProperty
Public Shared ReadOnly CanTabsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsCloseOnMiddleClick dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsDragProperty Field

AdvancedTabControlCanTabsDragProperty Field
Identifies the CanTabsDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsDragProperty
Public Shared ReadOnly CanTabsDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsDrag dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsHighlightOnPointerOverWhenInactiveProperty Field

AdvancedTabControlCanTabsHighlightOnPointerOverWhenInactiveProperty Field
Identifies the CanTabsHighlightOnPointerOverWhenInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsHighlightOnPointerOverWhenInactiveProperty
Public Shared ReadOnly CanTabsHighlightOnPointerOverWhenInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsHighlightOnPointerOverWhenInactive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsPinProperty Field

AdvancedTabControlCanTabsPinProperty Field
Identifies the CanTabsPin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsPinProperty
Public Shared ReadOnly CanTabsPinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsPin dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.CanTabsPromoteProperty Field

AdvancedTabControlCanTabsPromoteProperty Field
Identifies the CanTabsPromote dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsPromoteProperty
Public Shared ReadOnly CanTabsPromoteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsPromote dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.EmbeddedButtonStyleProperty Field

AdvancedTabControlEmbeddedButtonStyleProperty Field
Identifies the EmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmbeddedButtonStyleProperty
Public Shared ReadOnly EmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmbeddedButtonStyle dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HasNewTabButtonProperty Field

AdvancedTabControlHasNewTabButtonProperty Field
Identifies the HasNewTabButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasNewTabButtonProperty
Public Shared ReadOnly HasNewTabButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasNewTabButton dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HasTabCloseButtonsProperty Field

AdvancedTabControlHasTabCloseButtonsProperty Field
Identifies the HasTabCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabCloseButtonsProperty
Public Shared ReadOnly HasTabCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabCloseButtons dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HasTabImagesProperty Field

AdvancedTabControlHasTabImagesProperty Field
Identifies the HasTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabImagesProperty
Public Shared ReadOnly HasTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabImages dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushActiveProperty Field

AdvancedTabControlHighlightBrushActiveProperty Field
Identifies the HighlightBrushActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightBrushActiveProperty
Public Shared ReadOnly HighlightBrushActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightBrushActive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HighlightBrushInactiveProperty Field

AdvancedTabControlHighlightBrushInactiveProperty Field
Identifies the HighlightBrushInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightBrushInactiveProperty
Public Shared ReadOnly HighlightBrushInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightBrushInactive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.HighlightThicknessProperty Field

AdvancedTabControlHighlightThicknessProperty Field
Identifies the HighlightThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightThicknessProperty
Public Shared ReadOnly HighlightThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightThickness dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsActiveProperty Field

AdvancedTabControlIsActiveProperty Field
Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsKeyboardFocusWithinProperty Field

AdvancedTabControlIsKeyboardFocusWithinProperty Field
Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsKeyboardFocusWithinProperty
Public Shared ReadOnly IsKeyboardFocusWithinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsKeyboardFocusWithin dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsLayoutAnimationEnabledProperty Field

AdvancedTabControlIsLayoutAnimationEnabledProperty Field
Identifies the IsLayoutAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLayoutAnimationEnabledProperty
Public Shared ReadOnly IsLayoutAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLayoutAnimationEnabled dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsMenuButtonVisibleProperty Field

AdvancedTabControlIsMenuButtonVisibleProperty Field
Identifies the IsMenuButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMenuButtonVisibleProperty
Public Shared ReadOnly IsMenuButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMenuButtonVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsOverflowedProperty Field

AdvancedTabControlIsOverflowedProperty Field
Identifies the IsOverflowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOverflowedProperty
Public Shared ReadOnly IsOverflowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOverflowed dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabContentHorizontalProperty Field

AdvancedTabControlIsTabContentHorizontalProperty Field
Identifies the IsTabContentHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabContentHorizontalProperty
Public Shared ReadOnly IsTabContentHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabContentHorizontal dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardAccessEnabledProperty Field

AdvancedTabControlIsTabKeyboardAccessEnabledProperty Field
Identifies the IsTabKeyboardAccessEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabKeyboardAccessEnabledProperty
Public Shared ReadOnly IsTabKeyboardAccessEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabKeyboardAccessEnabled dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabKeyboardSwitchingEnabledProperty Field

AdvancedTabControlIsTabKeyboardSwitchingEnabledProperty Field
Identifies the IsTabKeyboardSwitchingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabKeyboardSwitchingEnabledProperty
Public Shared ReadOnly IsTabKeyboardSwitchingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabKeyboardSwitchingEnabled dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.IsTabStripVisibleProperty Field

AdvancedTabControlIsTabStripVisibleProperty Field
Identifies the IsTabStripVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabStripVisibleProperty
Public Shared ReadOnly IsTabStripVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabStripVisible dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MaxTabExtentProperty Field

AdvancedTabControlMaxTabExtentProperty Field
Identifies the MaxTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxTabExtentProperty
Public Shared ReadOnly MaxTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxTabExtent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MenuButtonContentTemplateProperty Field

AdvancedTabControlMenuButtonContentTemplateProperty Field
Identifies the MenuButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MenuButtonContentTemplateProperty
Public Shared ReadOnly MenuButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MenuButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.MinTabExtentProperty Field

AdvancedTabControlMinTabExtentProperty Field
Identifies the MinTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinTabExtentProperty
Public Shared ReadOnly MinTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinTabExtent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.NewTabButtonStyleProperty Field

AdvancedTabControlNewTabButtonStyleProperty Field
Identifies the NewTabButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NewTabButtonStyleProperty
Public Shared ReadOnly NewTabButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NewTabButtonStyle dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.OverflowMenuButtonContentTemplateProperty Field

AdvancedTabControlOverflowMenuButtonContentTemplateProperty Field
Identifies the OverflowMenuButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OverflowMenuButtonContentTemplateProperty
Public Shared ReadOnly OverflowMenuButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OverflowMenuButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RotatedBorderThicknessProperty Field

AdvancedTabControlRotatedBorderThicknessProperty Field
Identifies the RotatedBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotatedBorderThicknessProperty
Public Shared ReadOnly RotatedBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RotatedBorderThickness dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RotatedHighlightThicknessProperty Field

AdvancedTabControlRotatedHighlightThicknessProperty Field
Identifies the RotatedHighlightThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotatedHighlightThicknessProperty
Public Shared ReadOnly RotatedHighlightThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RotatedHighlightThickness dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.RotatedPaddingProperty Field

AdvancedTabControlRotatedPaddingProperty Field
Identifies the RotatedPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RotatedPaddingProperty
Public Shared ReadOnly RotatedPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RotatedPadding dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollBackwardButtonContentTemplateProperty Field

AdvancedTabControlScrollBackwardButtonContentTemplateProperty Field
Identifies the ScrollBackwardButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollBackwardButtonContentTemplateProperty
Public Shared ReadOnly ScrollBackwardButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollBackwardButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollForwardButtonContentTemplateProperty Field

AdvancedTabControlScrollForwardButtonContentTemplateProperty Field
Identifies the ScrollForwardButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollForwardButtonContentTemplateProperty
Public Shared ReadOnly ScrollForwardButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollForwardButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.ScrollOffsetProperty Field

AdvancedTabControlScrollOffsetProperty Field
Identifies the ScrollOffset dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollOffsetProperty
Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollOffset dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedContentProperty Field

AdvancedTabControlSelectedContentProperty Field
Identifies the SelectedContent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedContentProperty
Public Shared ReadOnly SelectedContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedContent dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedContentTemplateProperty Field

AdvancedTabControlSelectedContentTemplateProperty Field
Identifies the SelectedContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedContentTemplateProperty
Public Shared ReadOnly SelectedContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedContentTemplate dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedContentTemplateSelectorProperty Field

AdvancedTabControlSelectedContentTemplateSelectorProperty Field
Identifies the SelectedContentTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedContentTemplateSelectorProperty
Public Shared ReadOnly SelectedContentTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedContentTemplateSelector dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.SelectedItemProperty Field

AdvancedTabControlSelectedItemProperty Field
Identifies the SelectedItem dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedItemProperty
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedItem dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundActiveSelectedProperty Field

AdvancedTabControlTabBackgroundActiveSelectedProperty Field
Identifies the TabBackgroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundActiveSelectedProperty
Public Shared ReadOnly TabBackgroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundInactiveSelectedProperty Field

AdvancedTabControlTabBackgroundInactiveSelectedProperty Field
Identifies the TabBackgroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundInactiveSelectedProperty
Public Shared ReadOnly TabBackgroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPointerOverProperty Field

AdvancedTabControlTabBackgroundPointerOverProperty Field
Identifies the TabBackgroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPointerOverProperty
Public Shared ReadOnly TabBackgroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewActiveSelectedProperty Field

AdvancedTabControlTabBackgroundPreviewActiveSelectedProperty Field
Identifies the TabBackgroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPreviewActiveSelectedProperty
Public Shared ReadOnly TabBackgroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewPointerOverProperty Field

AdvancedTabControlTabBackgroundPreviewPointerOverProperty Field
Identifies the TabBackgroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPreviewPointerOverProperty
Public Shared ReadOnly TabBackgroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundPreviewProperty Field

AdvancedTabControlTabBackgroundPreviewProperty Field
Identifies the TabBackgroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundPreviewProperty
Public Shared ReadOnly TabBackgroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackgroundPreview dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBackgroundProperty Field

AdvancedTabControlTabBackgroundProperty Field
Identifies the TabBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBackgroundProperty
Public Shared ReadOnly TabBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBackground dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushActiveSelectedProperty Field

AdvancedTabControlTabBorderBrushActiveSelectedProperty Field
Identifies the TabBorderBrushActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushActiveSelectedProperty
Public Shared ReadOnly TabBorderBrushActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushInactiveSelectedProperty Field

AdvancedTabControlTabBorderBrushInactiveSelectedProperty Field
Identifies the TabBorderBrushInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushInactiveSelectedProperty
Public Shared ReadOnly TabBorderBrushInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushInactiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPointerOverProperty Field

AdvancedTabControlTabBorderBrushPointerOverProperty Field
Identifies the TabBorderBrushPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPointerOverProperty
Public Shared ReadOnly TabBorderBrushPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewActiveSelectedProperty Field

AdvancedTabControlTabBorderBrushPreviewActiveSelectedProperty Field
Identifies the TabBorderBrushPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPreviewActiveSelectedProperty
Public Shared ReadOnly TabBorderBrushPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewPointerOverProperty Field

AdvancedTabControlTabBorderBrushPreviewPointerOverProperty Field
Identifies the TabBorderBrushPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPreviewPointerOverProperty
Public Shared ReadOnly TabBorderBrushPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushPreviewProperty Field

AdvancedTabControlTabBorderBrushPreviewProperty Field
Identifies the TabBorderBrushPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushPreviewProperty
Public Shared ReadOnly TabBorderBrushPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrushPreview dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabBorderBrushProperty Field

AdvancedTabControlTabBorderBrushProperty Field
Identifies the TabBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabBorderBrushProperty
Public Shared ReadOnly TabBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabBorderBrush dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabCornerRadiusProperty Field

AdvancedTabControlTabCornerRadiusProperty Field
Identifies the TabCornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabCornerRadiusProperty
Public Shared ReadOnly TabCornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabCornerRadius dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabEmbeddedButtonStyleProperty Field

AdvancedTabControlTabEmbeddedButtonStyleProperty Field
Identifies the TabEmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabEmbeddedButtonStyleProperty
Public Shared ReadOnly TabEmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabEmbeddedButtonStyle dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundActiveSelectedProperty Field

AdvancedTabControlTabForegroundActiveSelectedProperty Field
Identifies the TabForegroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundActiveSelectedProperty
Public Shared ReadOnly TabForegroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundInactiveSelectedProperty Field

AdvancedTabControlTabForegroundInactiveSelectedProperty Field
Identifies the TabForegroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundInactiveSelectedProperty
Public Shared ReadOnly TabForegroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPointerOverProperty Field

AdvancedTabControlTabForegroundPointerOverProperty Field
Identifies the TabForegroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPointerOverProperty
Public Shared ReadOnly TabForegroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewActiveSelectedProperty Field

AdvancedTabControlTabForegroundPreviewActiveSelectedProperty Field
Identifies the TabForegroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPreviewActiveSelectedProperty
Public Shared ReadOnly TabForegroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewPointerOverProperty Field

AdvancedTabControlTabForegroundPreviewPointerOverProperty Field
Identifies the TabForegroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPreviewPointerOverProperty
Public Shared ReadOnly TabForegroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundPreviewProperty Field

AdvancedTabControlTabForegroundPreviewProperty Field
Identifies the TabForegroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundPreviewProperty
Public Shared ReadOnly TabForegroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForegroundPreview dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabForegroundProperty Field

AdvancedTabControlTabForegroundProperty Field
Identifies the TabForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabForegroundProperty
Public Shared ReadOnly TabForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabForeground dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabOverflowBehaviorProperty Field

AdvancedTabControlTabOverflowBehaviorProperty Field
Identifies the TabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabOverflowBehaviorProperty
Public Shared ReadOnly TabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabOverflowBehavior dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabPaddingProperty Field

AdvancedTabControlTabPaddingProperty Field
Identifies the TabPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabPaddingProperty
Public Shared ReadOnly TabPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabPadding dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabSpacingProperty Field

AdvancedTabControlTabSpacingProperty Field
Identifies the TabSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabSpacingProperty
Public Shared ReadOnly TabSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabSpacing dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControl.TabStripPlacementProperty Field

AdvancedTabControlTabStripPlacementProperty Field
Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

AdvancedTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Class

AdvancedTabControlMenuEventArgs Class
Provides event arguments for customizing a menu that is opening within an AdvancedTabControl.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControlMenuEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabControlMenuEventArgs : EventArgs
Public Class AdvancedTabControlMenuEventArgs
    Inherits EventArgs

The AdvancedTabControlMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabControlMenuEventArgs | Initializes a new instance of the AdvancedTabControlMenuEventArgs class
Top
Properties
 | Name | Description
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Public property | TabItem | Gets the related AdvancedTabItem, if any.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Constructor

AdvancedTabControlMenuEventArgs Constructor
Initializes a new instance of the AdvancedTabControlMenuEventArgs class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabControlMenuEventArgs()
Public Sub New
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Properties

AdvancedTabControlMenuEventArgs Properties

The AdvancedTabControlMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Public property | TabItem | Gets the related AdvancedTabItem, if any.
Top
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs.Menu Property

AdvancedTabControlMenuEventArgsMenu Property
Gets or sets the MenuFlyout that is about to be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MenuFlyout Menu { get; set; }
Public Property Menu As MenuFlyout
    Get
    Set

Property Value

Type: MenuFlyout
The MenuFlyout that is about to be displayed.
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs.TabItem Property

AdvancedTabControlMenuEventArgsTabItem Property
Gets the related AdvancedTabItem, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabItem TabItem { get; }
Public ReadOnly Property TabItem As AdvancedTabItem
    Get

Property Value

Type: AdvancedTabItem
The related AdvancedTabItem, if any.
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabControlMenuEventArgs Methods

AdvancedTabControlMenuEventArgs Methods

The AdvancedTabControlMenuEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdvancedTabControlMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem Class

AdvancedTabItem Class
Represents a tab item for use in an AdvancedTabControl.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
HeaderedContentControl
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabItem : HeaderedContentControl
Public Class AdvancedTabItem
    Inherits HeaderedContentControl

The AdvancedTabItem type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItem | Initializes an instance of the AdvancedTabItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreEmbeddedButtonsAlwaysVisible | Gets or sets whether embedded buttons are always visible, even when the tab is unselected.
Public property | ArrangeHeightAnimated | Gets or sets the arrange height of the tab. This property is for internal use only.
Public property | ArrangeWidthAnimated | Gets or sets the arrange width of the tab. This property is for internal use only.
Public property | ArrangeXAnimated | Gets or sets the arrange x-coordinate of the tab. This property is for internal use only.
Public property | ArrangeYAnimated | Gets or sets the arrange y-coordinate of the tab. This property is for internal use only.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BackgroundActiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is active.
Public property | BackgroundInactiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is inactive.
Public property | BackgroundPointerOver | Gets or sets the control's background Brush to use when the pointer is over it.
Public property | BackgroundPreview | Gets or sets the control's background Brush to use when the tab is a preview tab.
Public property | BackgroundPreviewActiveSelected | Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BackgroundPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderBrushActiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is active.
Public property | BorderBrushInactiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is inactive.
Public property | BorderBrushPointerOver | Gets or sets the control's border Brush to use when the pointer is over it.
Public property | BorderBrushPreview | Gets or sets the control's border Brush to use when the tab is a preview tab.
Public property | BorderBrushPreviewActiveSelected | Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BorderBrushPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the tab displays an embedded close button.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanHighlightOnPointerOverWhenInactive | Gets or sets whether the tab can highlight when the pointer is over it and it is inactive.
Public property | CanPin | Gets or sets whether the tab displays an embedded pin button.
Public property | CanPromote | Gets or sets whether the tab displays an embedded promote from preview layout kind button.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can be used to close the tab.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets the contextual content to display.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | ForegroundActiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is active.
Public property | ForegroundInactiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive.
Public property | ForegroundPointerOver | Gets or sets the control's foreground Brush to use when the pointer is over it.
Public property | ForegroundPreview | Gets or sets the control's foreground Brush to use when the tab is a preview tab.
Public property | ForegroundPreviewActiveSelected | Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | ForegroundPreviewPointerOver | Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it.
Public property | HasCloseButton | Gets whether the tab has an embedded close button based on its current state.
Public property | HasToggleLayoutKindButton | Gets whether the tab has an embedded toggle layout kind button based on its current state.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightKind | Gets a TabHighlightKind indicating the kind of highlight to apply to the tab.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets a ImageSource for an image that renders on the tab.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsCloseButtonVisible | Gets whether the embedded close button is visible.
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsLoadAnimationEnabled | Gets or sets whether animation effects may be applied when the tab is loaded.
Public property | IsReadOnly | Gets or sets whether the tab's contents are read-only.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the tab is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsToggleLayoutKindButtonVisible | Gets whether the embedded toggle layout kind button is visible.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | PromoteButtonContentTemplate | Gets or sets the DataTemplate to use for the promote button content.
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabStripPlacement | Gets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | ToggleLayoutKindCommand | Gets the ICommand that can be used to toggle the tab's layout kind.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the tab, removing it from the containing tab control.
Public method | DragMove | Starts a drag/move.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleLayoutKind | Toggles the tab's LayoutKind.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
ArrangeHeightAnimatedProperty | Identifies the ArrangeHeightAnimated dependency property. This field is read-only.
ArrangeWidthAnimatedProperty | Identifies the ArrangeWidthAnimated dependency property. This field is read-only.
ArrangeXAnimatedProperty | Identifies the ArrangeXAnimated dependency property. This field is read-only.
ArrangeYAnimatedProperty | Identifies the ArrangeYAnimated dependency property. This field is read-only.
BackgroundActiveSelectedProperty | Identifies the BackgroundActiveSelected dependency property. This field is read-only.
BackgroundInactiveSelectedProperty | Identifies the BackgroundInactiveSelected dependency property. This field is read-only.
BackgroundPointerOverProperty | Identifies the BackgroundPointerOver dependency property. This field is read-only.
BackgroundPreviewActiveSelectedProperty | Identifies the BackgroundPreviewActiveSelected dependency property. This field is read-only.
BackgroundPreviewPointerOverProperty | Identifies the BackgroundPreviewPointerOver dependency property. This field is read-only.
BackgroundPreviewProperty | Identifies the BackgroundPreview dependency property. This field is read-only.
BorderBrushActiveSelectedProperty | Identifies the BorderBrushActiveSelected dependency property. This field is read-only.
BorderBrushInactiveSelectedProperty | Identifies the BorderBrushInactiveSelected dependency property. This field is read-only.
BorderBrushPointerOverProperty | Identifies the BorderBrushPointerOver dependency property. This field is read-only.
BorderBrushPreviewActiveSelectedProperty | Identifies the BorderBrushPreviewActiveSelected dependency property. This field is read-only.
BorderBrushPreviewPointerOverProperty | Identifies the BorderBrushPreviewPointerOver dependency property. This field is read-only.
BorderBrushPreviewProperty | Identifies the BorderBrushPreview dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanHighlightOnPointerOverWhenInactiveProperty | Identifies the CanHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanPinProperty | Identifies the CanPin dependency property. This field is read-only.
CanPromoteProperty | Identifies the CanPromote dependency property. This field is read-only.
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
ForegroundActiveSelectedProperty | Identifies the ForegroundActiveSelected dependency property. This field is read-only.
ForegroundInactiveSelectedProperty | Identifies the ForegroundInactiveSelected dependency property. This field is read-only.
ForegroundPointerOverProperty | Identifies the ForegroundPointerOver dependency property. This field is read-only.
ForegroundPreviewActiveSelectedProperty | Identifies the ForegroundPreviewActiveSelected dependency property. This field is read-only.
ForegroundPreviewPointerOverProperty | Identifies the ForegroundPreviewPointerOver dependency property. This field is read-only.
ForegroundPreviewProperty | Identifies the ForegroundPreview dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasToggleLayoutKindButtonProperty | Identifies the HasToggleLayoutKindButton dependency property. This field is read-only.
HighlightKindProperty | Identifies the HighlightKind dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
IsLoadAnimationEnabledProperty | Identifies the IsLoadAnimationEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
IsToggleLayoutKindButtonVisibleProperty | Identifies the IsToggleLayoutKindButtonVisible dependency property. This field is read-only.
LayoutKindProperty | Identifies the LayoutKind dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
PromoteButtonContentTemplateProperty | Identifies the PromoteButtonContentTemplate dependency property. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem Constructor

AdvancedTabItem Constructor
Initializes an instance of the AdvancedTabItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabItem()
Public Sub New
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem Properties

AdvancedTabItem Properties

The AdvancedTabItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreEmbeddedButtonsAlwaysVisible | Gets or sets whether embedded buttons are always visible, even when the tab is unselected.
Public property | ArrangeHeightAnimated | Gets or sets the arrange height of the tab. This property is for internal use only.
Public property | ArrangeWidthAnimated | Gets or sets the arrange width of the tab. This property is for internal use only.
Public property | ArrangeXAnimated | Gets or sets the arrange x-coordinate of the tab. This property is for internal use only.
Public property | ArrangeYAnimated | Gets or sets the arrange y-coordinate of the tab. This property is for internal use only.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BackgroundActiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is active.
Public property | BackgroundInactiveSelected | Gets or sets the control's background Brush to use when the tab is selected and its content is inactive.
Public property | BackgroundPointerOver | Gets or sets the control's background Brush to use when the pointer is over it.
Public property | BackgroundPreview | Gets or sets the control's background Brush to use when the tab is a preview tab.
Public property | BackgroundPreviewActiveSelected | Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BackgroundPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderBrushActiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is active.
Public property | BorderBrushInactiveSelected | Gets or sets the control's border Brush to use when the tab is selected and its content is inactive.
Public property | BorderBrushPointerOver | Gets or sets the control's border Brush to use when the pointer is over it.
Public property | BorderBrushPreview | Gets or sets the control's border Brush to use when the tab is a preview tab.
Public property | BorderBrushPreviewActiveSelected | Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | BorderBrushPreviewPointerOver | Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the tab displays an embedded close button.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanHighlightOnPointerOverWhenInactive | Gets or sets whether the tab can highlight when the pointer is over it and it is inactive.
Public property | CanPin | Gets or sets whether the tab displays an embedded pin button.
Public property | CanPromote | Gets or sets whether the tab displays an embedded promote from preview layout kind button.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can be used to close the tab.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets the contextual content to display.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | ForegroundActiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is active.
Public property | ForegroundInactiveSelected | Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive.
Public property | ForegroundPointerOver | Gets or sets the control's foreground Brush to use when the pointer is over it.
Public property | ForegroundPreview | Gets or sets the control's foreground Brush to use when the tab is a preview tab.
Public property | ForegroundPreviewActiveSelected | Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active.
Public property | ForegroundPreviewPointerOver | Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it.
Public property | HasCloseButton | Gets whether the tab has an embedded close button based on its current state.
Public property | HasToggleLayoutKindButton | Gets whether the tab has an embedded toggle layout kind button based on its current state.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightKind | Gets a TabHighlightKind indicating the kind of highlight to apply to the tab.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets a ImageSource for an image that renders on the tab.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsCloseButtonVisible | Gets whether the embedded close button is visible.
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsLoadAnimationEnabled | Gets or sets whether animation effects may be applied when the tab is loaded.
Public property | IsReadOnly | Gets or sets whether the tab's contents are read-only.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the tab is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsToggleLayoutKindButtonVisible | Gets whether the embedded toggle layout kind button is visible.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | PromoteButtonContentTemplate | Gets or sets the DataTemplate to use for the promote button content.
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabStripPlacement | Gets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | ToggleLayoutKindCommand | Gets the ICommand that can be used to toggle the tab's layout kind.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.AreEmbeddedButtonsAlwaysVisible Property

AdvancedTabItemAreEmbeddedButtonsAlwaysVisible Property
Gets or sets whether embedded buttons are always visible, even when the tab is unselected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreEmbeddedButtonsAlwaysVisible { get; set; }
Public Property AreEmbeddedButtonsAlwaysVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if embedded buttons are always visible, even when the tab is unselected; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeHeightAnimated Property

AdvancedTabItemArrangeHeightAnimated Property
Gets or sets the arrange height of the tab. This property is for internal use only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ArrangeHeightAnimated { get; set; }
Public Property ArrangeHeightAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange height of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeWidthAnimated Property

AdvancedTabItemArrangeWidthAnimated Property
Gets or sets the arrange width of the tab. This property is for internal use only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ArrangeWidthAnimated { get; set; }
Public Property ArrangeWidthAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange width of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeXAnimated Property

AdvancedTabItemArrangeXAnimated Property
Gets or sets the arrange x-coordinate of the tab. This property is for internal use only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ArrangeXAnimated { get; set; }
Public Property ArrangeXAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange x-coordinate of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeYAnimated Property

AdvancedTabItemArrangeYAnimated Property
Gets or sets the arrange y-coordinate of the tab. This property is for internal use only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ArrangeYAnimated { get; set; }
Public Property ArrangeYAnimated As Double
    Get
    Set

Property Value

Type: Double
The arrange y-coordinate of the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundActiveSelected Property

AdvancedTabItemBackgroundActiveSelected Property
Gets or sets the control's background Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BackgroundActiveSelected { get; set; }
Public Property BackgroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundInactiveSelected Property

AdvancedTabItemBackgroundInactiveSelected Property
Gets or sets the control's background Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BackgroundInactiveSelected { get; set; }
Public Property BackgroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPointerOver Property

AdvancedTabItemBackgroundPointerOver Property
Gets or sets the control's background Brush to use when the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BackgroundPointerOver { get; set; }
Public Property BackgroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreview Property

AdvancedTabItemBackgroundPreview Property
Gets or sets the control's background Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BackgroundPreview { get; set; }
Public Property BackgroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewActiveSelected Property

AdvancedTabItemBackgroundPreviewActiveSelected Property
Gets or sets the control's background Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BackgroundPreviewActiveSelected { get; set; }
Public Property BackgroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewPointerOver Property

AdvancedTabItemBackgroundPreviewPointerOver Property
Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BackgroundPreviewPointerOver { get; set; }
Public Property BackgroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushActiveSelected Property

AdvancedTabItemBorderBrushActiveSelected Property
Gets or sets the control's border Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrushActiveSelected { get; set; }
Public Property BorderBrushActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushInactiveSelected Property

AdvancedTabItemBorderBrushInactiveSelected Property
Gets or sets the control's border Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrushInactiveSelected { get; set; }
Public Property BorderBrushInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPointerOver Property

AdvancedTabItemBorderBrushPointerOver Property
Gets or sets the control's border Brush to use when the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrushPointerOver { get; set; }
Public Property BorderBrushPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreview Property

AdvancedTabItemBorderBrushPreview Property
Gets or sets the control's border Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrushPreview { get; set; }
Public Property BorderBrushPreview As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewActiveSelected Property

AdvancedTabItemBorderBrushPreviewActiveSelected Property
Gets or sets the control's border Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrushPreviewActiveSelected { get; set; }
Public Property BorderBrushPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewPointerOver Property

AdvancedTabItemBorderBrushPreviewPointerOver Property
Gets or sets the control's border Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BorderBrushPreviewPointerOver { get; set; }
Public Property BorderBrushPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The border Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanClose Property

AdvancedTabItemCanClose Property
Gets or sets whether the tab displays an embedded close button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanClose { get; set; }
Public Property CanClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab displays an embedded close button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanHighlightOnPointerOverWhenInactive Property

AdvancedTabItemCanHighlightOnPointerOverWhenInactive Property
Gets or sets whether the tab can highlight when the pointer is over it and it is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanHighlightOnPointerOverWhenInactive { get; set; }
Public Property CanHighlightOnPointerOverWhenInactive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab can highlight when the pointer is over it and it is inactive; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanPin Property

AdvancedTabItemCanPin Property
Gets or sets whether the tab displays an embedded pin button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanPin { get; set; }
Public Property CanPin As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab displays an embedded pin button; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanPromote Property

AdvancedTabItemCanPromote Property
Gets or sets whether the tab displays an embedded promote from preview layout kind button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanPromote { get; set; }
Public Property CanPromote As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab displays an embedded promote from preview layout kind button; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CloseButtonContentTemplate Property

AdvancedTabItemCloseButtonContentTemplate Property
Gets or sets the DataTemplate to use for the close button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate CloseButtonContentTemplate { get; set; }
Public Property CloseButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the close content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CloseCommand Property

AdvancedTabItemCloseCommand Property
Gets the ICommand that can be used to close the tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to close the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ContextContent Property

AdvancedTabItemContextContent Property
Gets the contextual content to display.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ContextContent { get; }
Public ReadOnly Property ContextContent As Object
    Get

Property Value

Type: Object
The contextual content to display.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ContextContentTemplate Property

AdvancedTabItemContextContentTemplate Property
Gets or sets the DataTemplate to use for displaying contextual content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ContextContentTemplate { get; set; }
Public Property ContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for displaying contextual content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CornerRadius Property

AdvancedTabItemCornerRadius Property
Gets or sets the corner radius of the tab border, relative to a top-facing tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the tab border, relative to a top-facing tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.EmbeddedButtonStyle Property

AdvancedTabItemEmbeddedButtonStyle Property
Gets or sets the Style to use for embedded buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style EmbeddedButtonStyle { get; set; }
Public Property EmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.FlashColor Property

AdvancedTabItemFlashColor Property
Gets or sets the flash color to use if flashing is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color FlashColor { get; set; }
Public Property FlashColor As Color
    Get
    Set

Property Value

Type: Color
The flash color to use if flashing is enabled. The default value is #80FFA000.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.FlashMode Property

AdvancedTabItemFlashMode Property
Gets or sets the flash mode for the tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabFlashMode FlashMode { get; set; }
Public Property FlashMode As TabFlashMode
    Get
    Set

Property Value

Type: TabFlashMode
The flash mode for the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundActiveSelected Property

AdvancedTabItemForegroundActiveSelected Property
Gets or sets the control's foreground Brush to use when the tab is selected and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ForegroundActiveSelected { get; set; }
Public Property ForegroundActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundInactiveSelected Property

AdvancedTabItemForegroundInactiveSelected Property
Gets or sets the control's foreground Brush to use when the tab is selected and its content is inactive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ForegroundInactiveSelected { get; set; }
Public Property ForegroundInactiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPointerOver Property

AdvancedTabItemForegroundPointerOver Property
Gets or sets the control's foreground Brush to use when the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ForegroundPointerOver { get; set; }
Public Property ForegroundPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreview Property

AdvancedTabItemForegroundPreview Property
Gets or sets the control's foreground Brush to use when the tab is a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ForegroundPreview { get; set; }
Public Property ForegroundPreview As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewActiveSelected Property

AdvancedTabItemForegroundPreviewActiveSelected Property
Gets or sets the control's foreground Brush to use when the tab is a preview tab, is selected, and its content is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ForegroundPreviewActiveSelected { get; set; }
Public Property ForegroundPreviewActiveSelected As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewPointerOver Property

AdvancedTabItemForegroundPreviewPointerOver Property
Gets or sets the control's foreground Brush to use when the tab is a preview tab and the pointer is over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ForegroundPreviewPointerOver { get; set; }
Public Property ForegroundPreviewPointerOver As Brush
    Get
    Set

Property Value

Type: Brush
The foreground Brush.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.HasCloseButton Property

AdvancedTabItemHasCloseButton Property
Gets whether the tab has an embedded close button based on its current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCloseButton { get; }
Public ReadOnly Property HasCloseButton As Boolean
    Get

Property Value

Type: Boolean
true if the tab has an embedded close button based on its current state; otherwise, false. The default value is false.
Remarks
When this property is true, space is reserved in the tab for the close button. The actual visibility of the close button depends on the IsCloseButtonVisible property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.HasToggleLayoutKindButton Property

AdvancedTabItemHasToggleLayoutKindButton Property
Gets whether the tab has an embedded toggle layout kind button based on its current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasToggleLayoutKindButton { get; }
Public ReadOnly Property HasToggleLayoutKindButton As Boolean
    Get

Property Value

Type: Boolean
true if the tab has an embedded toggle layout kind button based on its current state; otherwise, false. The default value is false.
Remarks
When this property is true, space is reserved in the tab for the toggle layout kind button. The actual visibility of the toggle layout kind button depends on the IsToggleLayoutKindButtonVisible property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.HighlightKind Property

AdvancedTabItemHighlightKind Property
Gets a TabHighlightKind indicating the kind of highlight to apply to the tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabHighlightKind HighlightKind { get; }
Public ReadOnly Property HighlightKind As TabHighlightKind
    Get

Property Value

Type: TabHighlightKind
A TabHighlightKind indicating the kind of highlight to apply to the tab. The default value is None.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ImageSource Property

AdvancedTabItemImageSource Property
Gets or sets a ImageSource for an image that renders on the tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
A ImageSource for an image that renders on the tab.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsCloseButtonVisible Property

AdvancedTabItemIsCloseButtonVisible Property
Gets whether the embedded close button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCloseButtonVisible { get; }
Public ReadOnly Property IsCloseButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded close button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsContentHorizontal Property

AdvancedTabItemIsContentHorizontal Property
Gets or sets whether the content layout is in a horizontal orientation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsContentHorizontal { get; set; }
Public Property IsContentHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content layout is in a horizontal orientation; otherwise, false. The default value is true.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsImageVisible Property

AdvancedTabItemIsImageVisible Property
Gets whether the embedded image is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsImageVisible { get; }
Public ReadOnly Property IsImageVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded image is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsLoadAnimationEnabled Property

AdvancedTabItemIsLoadAnimationEnabled Property
Gets or sets whether animation effects may be applied when the tab is loaded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLoadAnimationEnabled { get; set; }
Public Property IsLoadAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects may be applied when the tab is loaded; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsReadOnly Property

AdvancedTabItemIsReadOnly Property
Gets or sets whether the tab's contents are read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab's contents are read-only; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsSelected Property

AdvancedTabItemIsSelected Property
Gets or sets whether the tab is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab is selected; otherwise, false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsToggleLayoutKindButtonVisible Property

AdvancedTabItemIsToggleLayoutKindButtonVisible Property
Gets whether the embedded toggle layout kind button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsToggleLayoutKindButtonVisible { get; }
Public ReadOnly Property IsToggleLayoutKindButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded toggle layout kind button is visible; otherwise, false. The default value is false.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.LayoutKind Property

AdvancedTabItemLayoutKind Property
Gets or sets the TabLayoutKind that indicates how the tab will be positioned.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabLayoutKind LayoutKind { get; set; }
Public Property LayoutKind As TabLayoutKind
    Get
    Set

Property Value

Type: TabLayoutKind
The TabLayoutKind that indicates how the tab will be positioned. The default value is Normal.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.PinButtonContentTemplate Property

AdvancedTabItemPinButtonContentTemplate Property
Gets or sets the DataTemplate to use for the pin button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate PinButtonContentTemplate { get; set; }
Public Property PinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the pin content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.PromoteButtonContentTemplate Property

AdvancedTabItemPromoteButtonContentTemplate Property
Gets or sets the DataTemplate to use for the promote button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate PromoteButtonContentTemplate { get; set; }
Public Property PromoteButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the promote content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ReadOnlyContextContentTemplate Property

AdvancedTabItemReadOnlyContextContentTemplate Property
Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ReadOnlyContextContentTemplate { get; set; }
Public Property ReadOnlyContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.TabStripPlacement Property

AdvancedTabItemTabStripPlacement Property
Gets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; }
Public ReadOnly Property TabStripPlacement As Side
    Get

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.TintColor Property

AdvancedTabItemTintColor Property
Gets or sets the tint color applied to the Background and BorderBrush brushes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color TintColor { get; set; }
Public Property TintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color applied to the Background and BorderBrush brushes. The default value is Transparent, which indicates no tinting should be applied.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ToggleLayoutKindCommand Property

AdvancedTabItemToggleLayoutKindCommand Property
Gets the ICommand that can be used to toggle the tab's layout kind.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ToggleLayoutKindCommand { get; }
Public ReadOnly Property ToggleLayoutKindCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to toggle the tab's layout kind.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.UnpinButtonContentTemplate Property

AdvancedTabItemUnpinButtonContentTemplate Property
Gets or sets the DataTemplate to use for the unpin button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate UnpinButtonContentTemplate { get; set; }
Public Property UnpinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the unpin content.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem Methods

AdvancedTabItem Methods

The AdvancedTabItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the tab, removing it from the containing tab control.
Public method | DragMove | Starts a drag/move.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleLayoutKind | Toggles the tab's LayoutKind.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.Close Method

AdvancedTabItemClose Method
Closes the tab, removing it from the containing tab control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.DragMove Method

AdvancedTabItemDragMove Method
Starts a drag/move.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void DragMove(
    InputPointerButtonEventArgs sourceEventArgs
)
Public Sub DragMove (
    sourceEventArgs As InputPointerButtonEventArgs
)

Parameters

sourceEventArgs
Type: ActiproSoftware.UI.Xaml.InputInputPointerButtonEventArgs
The source InputPointerButtonEventArgs, which can be used to capture the pointer.
Remarks
The primary button of the pointer in the event arguments must be pressed down when calling this method. The pointer will be captured.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.OnApplyTemplate Method

AdvancedTabItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.OnCreateAutomationPeer Method

AdvancedTabItemOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.OnGotFocus Method

AdvancedTabItemOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.OnLostFocus Method

AdvancedTabItemOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ToggleLayoutKind Method

AdvancedTabItemToggleLayoutKind Method
Toggles the tab's LayoutKind.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ToggleLayoutKind()
Public Sub ToggleLayoutKind
Remarks
Normal tabs will switch to Pinned layout. All other layout kinds switch back to Normal.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem Events

AdvancedTabItem Events

The AdvancedTabItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem Fields

AdvancedTabItem Fields

The AdvancedTabItem type exposes the following members.

Fields
Name | Description
AreEmbeddedButtonsAlwaysVisibleProperty | Identifies the AreEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.
ArrangeHeightAnimatedProperty | Identifies the ArrangeHeightAnimated dependency property. This field is read-only.
ArrangeWidthAnimatedProperty | Identifies the ArrangeWidthAnimated dependency property. This field is read-only.
ArrangeXAnimatedProperty | Identifies the ArrangeXAnimated dependency property. This field is read-only.
ArrangeYAnimatedProperty | Identifies the ArrangeYAnimated dependency property. This field is read-only.
BackgroundActiveSelectedProperty | Identifies the BackgroundActiveSelected dependency property. This field is read-only.
BackgroundInactiveSelectedProperty | Identifies the BackgroundInactiveSelected dependency property. This field is read-only.
BackgroundPointerOverProperty | Identifies the BackgroundPointerOver dependency property. This field is read-only.
BackgroundPreviewActiveSelectedProperty | Identifies the BackgroundPreviewActiveSelected dependency property. This field is read-only.
BackgroundPreviewPointerOverProperty | Identifies the BackgroundPreviewPointerOver dependency property. This field is read-only.
BackgroundPreviewProperty | Identifies the BackgroundPreview dependency property. This field is read-only.
BorderBrushActiveSelectedProperty | Identifies the BorderBrushActiveSelected dependency property. This field is read-only.
BorderBrushInactiveSelectedProperty | Identifies the BorderBrushInactiveSelected dependency property. This field is read-only.
BorderBrushPointerOverProperty | Identifies the BorderBrushPointerOver dependency property. This field is read-only.
BorderBrushPreviewActiveSelectedProperty | Identifies the BorderBrushPreviewActiveSelected dependency property. This field is read-only.
BorderBrushPreviewPointerOverProperty | Identifies the BorderBrushPreviewPointerOver dependency property. This field is read-only.
BorderBrushPreviewProperty | Identifies the BorderBrushPreview dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanHighlightOnPointerOverWhenInactiveProperty | Identifies the CanHighlightOnPointerOverWhenInactive dependency property. This field is read-only.
CanPinProperty | Identifies the CanPin dependency property. This field is read-only.
CanPromoteProperty | Identifies the CanPromote dependency property. This field is read-only.
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
ForegroundActiveSelectedProperty | Identifies the ForegroundActiveSelected dependency property. This field is read-only.
ForegroundInactiveSelectedProperty | Identifies the ForegroundInactiveSelected dependency property. This field is read-only.
ForegroundPointerOverProperty | Identifies the ForegroundPointerOver dependency property. This field is read-only.
ForegroundPreviewActiveSelectedProperty | Identifies the ForegroundPreviewActiveSelected dependency property. This field is read-only.
ForegroundPreviewPointerOverProperty | Identifies the ForegroundPreviewPointerOver dependency property. This field is read-only.
ForegroundPreviewProperty | Identifies the ForegroundPreview dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasToggleLayoutKindButtonProperty | Identifies the HasToggleLayoutKindButton dependency property. This field is read-only.
HighlightKindProperty | Identifies the HighlightKind dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
IsLoadAnimationEnabledProperty | Identifies the IsLoadAnimationEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
IsToggleLayoutKindButtonVisibleProperty | Identifies the IsToggleLayoutKindButtonVisible dependency property. This field is read-only.
LayoutKindProperty | Identifies the LayoutKind dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
PromoteButtonContentTemplateProperty | Identifies the PromoteButtonContentTemplate dependency property. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.AreEmbeddedButtonsAlwaysVisibleProperty Field

AdvancedTabItemAreEmbeddedButtonsAlwaysVisibleProperty Field
Identifies the AreEmbeddedButtonsAlwaysVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreEmbeddedButtonsAlwaysVisibleProperty
Public Shared ReadOnly AreEmbeddedButtonsAlwaysVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreEmbeddedButtonsAlwaysVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeHeightAnimatedProperty Field

AdvancedTabItemArrangeHeightAnimatedProperty Field
Identifies the ArrangeHeightAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeHeightAnimatedProperty
Public Shared ReadOnly ArrangeHeightAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeHeightAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeWidthAnimatedProperty Field

AdvancedTabItemArrangeWidthAnimatedProperty Field
Identifies the ArrangeWidthAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeWidthAnimatedProperty
Public Shared ReadOnly ArrangeWidthAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeWidthAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeXAnimatedProperty Field

AdvancedTabItemArrangeXAnimatedProperty Field
Identifies the ArrangeXAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeXAnimatedProperty
Public Shared ReadOnly ArrangeXAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeXAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ArrangeYAnimatedProperty Field

AdvancedTabItemArrangeYAnimatedProperty Field
Identifies the ArrangeYAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrangeYAnimatedProperty
Public Shared ReadOnly ArrangeYAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrangeYAnimated dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundActiveSelectedProperty Field

AdvancedTabItemBackgroundActiveSelectedProperty Field
Identifies the BackgroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundActiveSelectedProperty
Public Shared ReadOnly BackgroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundInactiveSelectedProperty Field

AdvancedTabItemBackgroundInactiveSelectedProperty Field
Identifies the BackgroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundInactiveSelectedProperty
Public Shared ReadOnly BackgroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPointerOverProperty Field

AdvancedTabItemBackgroundPointerOverProperty Field
Identifies the BackgroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPointerOverProperty
Public Shared ReadOnly BackgroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewActiveSelectedProperty Field

AdvancedTabItemBackgroundPreviewActiveSelectedProperty Field
Identifies the BackgroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPreviewActiveSelectedProperty
Public Shared ReadOnly BackgroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewPointerOverProperty Field

AdvancedTabItemBackgroundPreviewPointerOverProperty Field
Identifies the BackgroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPreviewPointerOverProperty
Public Shared ReadOnly BackgroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BackgroundPreviewProperty Field

AdvancedTabItemBackgroundPreviewProperty Field
Identifies the BackgroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BackgroundPreviewProperty
Public Shared ReadOnly BackgroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BackgroundPreview dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushActiveSelectedProperty Field

AdvancedTabItemBorderBrushActiveSelectedProperty Field
Identifies the BorderBrushActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushActiveSelectedProperty
Public Shared ReadOnly BorderBrushActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushInactiveSelectedProperty Field

AdvancedTabItemBorderBrushInactiveSelectedProperty Field
Identifies the BorderBrushInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushInactiveSelectedProperty
Public Shared ReadOnly BorderBrushInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushInactiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPointerOverProperty Field

AdvancedTabItemBorderBrushPointerOverProperty Field
Identifies the BorderBrushPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPointerOverProperty
Public Shared ReadOnly BorderBrushPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewActiveSelectedProperty Field

AdvancedTabItemBorderBrushPreviewActiveSelectedProperty Field
Identifies the BorderBrushPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPreviewActiveSelectedProperty
Public Shared ReadOnly BorderBrushPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewPointerOverProperty Field

AdvancedTabItemBorderBrushPreviewPointerOverProperty Field
Identifies the BorderBrushPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPreviewPointerOverProperty
Public Shared ReadOnly BorderBrushPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.BorderBrushPreviewProperty Field

AdvancedTabItemBorderBrushPreviewProperty Field
Identifies the BorderBrushPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BorderBrushPreviewProperty
Public Shared ReadOnly BorderBrushPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BorderBrushPreview dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanCloseProperty Field

AdvancedTabItemCanCloseProperty Field
Identifies the CanClose dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseProperty
Public Shared ReadOnly CanCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanClose dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanHighlightOnPointerOverWhenInactiveProperty Field

AdvancedTabItemCanHighlightOnPointerOverWhenInactiveProperty Field
Identifies the CanHighlightOnPointerOverWhenInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanHighlightOnPointerOverWhenInactiveProperty
Public Shared ReadOnly CanHighlightOnPointerOverWhenInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanHighlightOnPointerOverWhenInactive dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanPinProperty Field

AdvancedTabItemCanPinProperty Field
Identifies the CanPin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanPinProperty
Public Shared ReadOnly CanPinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanPin dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CanPromoteProperty Field

AdvancedTabItemCanPromoteProperty Field
Identifies the CanPromote dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanPromoteProperty
Public Shared ReadOnly CanPromoteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanPromote dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CloseButtonContentTemplateProperty Field

AdvancedTabItemCloseButtonContentTemplateProperty Field
Identifies the CloseButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CloseButtonContentTemplateProperty
Public Shared ReadOnly CloseButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CloseButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ContextContentProperty Field

AdvancedTabItemContextContentProperty Field
Identifies the ContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentProperty
Public Shared ReadOnly ContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContent dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ContextContentTemplateProperty Field

AdvancedTabItemContextContentTemplateProperty Field
Identifies the ContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentTemplateProperty
Public Shared ReadOnly ContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.CornerRadiusProperty Field

AdvancedTabItemCornerRadiusProperty Field
Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.EmbeddedButtonStyleProperty Field

AdvancedTabItemEmbeddedButtonStyleProperty Field
Identifies the EmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmbeddedButtonStyleProperty
Public Shared ReadOnly EmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmbeddedButtonStyle dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.FlashColorProperty Field

AdvancedTabItemFlashColorProperty Field
Identifies the FlashColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashColorProperty
Public Shared ReadOnly FlashColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashColor dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.FlashModeProperty Field

AdvancedTabItemFlashModeProperty Field
Identifies the FlashMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashModeProperty
Public Shared ReadOnly FlashModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashMode dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundActiveSelectedProperty Field

AdvancedTabItemForegroundActiveSelectedProperty Field
Identifies the ForegroundActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundActiveSelectedProperty
Public Shared ReadOnly ForegroundActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundInactiveSelectedProperty Field

AdvancedTabItemForegroundInactiveSelectedProperty Field
Identifies the ForegroundInactiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundInactiveSelectedProperty
Public Shared ReadOnly ForegroundInactiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundInactiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPointerOverProperty Field

AdvancedTabItemForegroundPointerOverProperty Field
Identifies the ForegroundPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPointerOverProperty
Public Shared ReadOnly ForegroundPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewActiveSelectedProperty Field

AdvancedTabItemForegroundPreviewActiveSelectedProperty Field
Identifies the ForegroundPreviewActiveSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPreviewActiveSelectedProperty
Public Shared ReadOnly ForegroundPreviewActiveSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPreviewActiveSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewPointerOverProperty Field

AdvancedTabItemForegroundPreviewPointerOverProperty Field
Identifies the ForegroundPreviewPointerOver dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPreviewPointerOverProperty
Public Shared ReadOnly ForegroundPreviewPointerOverProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPreviewPointerOver dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ForegroundPreviewProperty Field

AdvancedTabItemForegroundPreviewProperty Field
Identifies the ForegroundPreview dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundPreviewProperty
Public Shared ReadOnly ForegroundPreviewProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ForegroundPreview dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.HasCloseButtonProperty Field

AdvancedTabItemHasCloseButtonProperty Field
Identifies the HasCloseButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCloseButtonProperty
Public Shared ReadOnly HasCloseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCloseButton dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.HasToggleLayoutKindButtonProperty Field

AdvancedTabItemHasToggleLayoutKindButtonProperty Field
Identifies the HasToggleLayoutKindButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasToggleLayoutKindButtonProperty
Public Shared ReadOnly HasToggleLayoutKindButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasToggleLayoutKindButton dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.HighlightKindProperty Field

AdvancedTabItemHighlightKindProperty Field
Identifies the HighlightKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightKindProperty
Public Shared ReadOnly HighlightKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightKind dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ImageSourceProperty Field

AdvancedTabItemImageSourceProperty Field
Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsCloseButtonVisibleProperty Field

AdvancedTabItemIsCloseButtonVisibleProperty Field
Identifies the IsCloseButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCloseButtonVisibleProperty
Public Shared ReadOnly IsCloseButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCloseButtonVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsContentHorizontalProperty Field

AdvancedTabItemIsContentHorizontalProperty Field
Identifies the IsContentHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContentHorizontalProperty
Public Shared ReadOnly IsContentHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContentHorizontal dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsImageVisibleProperty Field

AdvancedTabItemIsImageVisibleProperty Field
Identifies the IsImageVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsImageVisibleProperty
Public Shared ReadOnly IsImageVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsImageVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsLoadAnimationEnabledProperty Field

AdvancedTabItemIsLoadAnimationEnabledProperty Field
Identifies the IsLoadAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLoadAnimationEnabledProperty
Public Shared ReadOnly IsLoadAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLoadAnimationEnabled dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsReadOnlyProperty Field

AdvancedTabItemIsReadOnlyProperty Field
Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsSelectedProperty Field

AdvancedTabItemIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.IsToggleLayoutKindButtonVisibleProperty Field

AdvancedTabItemIsToggleLayoutKindButtonVisibleProperty Field
Identifies the IsToggleLayoutKindButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsToggleLayoutKindButtonVisibleProperty
Public Shared ReadOnly IsToggleLayoutKindButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsToggleLayoutKindButtonVisible dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.LayoutKindProperty Field

AdvancedTabItemLayoutKindProperty Field
Identifies the LayoutKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LayoutKindProperty
Public Shared ReadOnly LayoutKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LayoutKind dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.PinButtonContentTemplateProperty Field

AdvancedTabItemPinButtonContentTemplateProperty Field
Identifies the PinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PinButtonContentTemplateProperty
Public Shared ReadOnly PinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PinButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.PromoteButtonContentTemplateProperty Field

AdvancedTabItemPromoteButtonContentTemplateProperty Field
Identifies the PromoteButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromoteButtonContentTemplateProperty
Public Shared ReadOnly PromoteButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromoteButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.ReadOnlyContextContentTemplateProperty Field

AdvancedTabItemReadOnlyContextContentTemplateProperty Field
Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReadOnlyContextContentTemplateProperty
Public Shared ReadOnly ReadOnlyContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReadOnlyContextContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.TabStripPlacementProperty Field

AdvancedTabItemTabStripPlacementProperty Field
Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.TintColorProperty Field

AdvancedTabItemTintColorProperty Field
Identifies the TintColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TintColorProperty
Public Shared ReadOnly TintColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TintColor dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItem.UnpinButtonContentTemplateProperty Field

AdvancedTabItemUnpinButtonContentTemplateProperty Field
Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnpinButtonContentTemplateProperty
Public Shared ReadOnly UnpinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnpinButtonContentTemplate dependency property.
See Also

Reference

AdvancedTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItemEventArgs Class

AdvancedTabItemEventArgs Class
Provides event arguments for AdvancedTabItem-related drag events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabItemEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabItemEventArgs : CancelableEventArgs
Public Class AdvancedTabItemEventArgs
    Inherits CancelableEventArgs

The AdvancedTabItemEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItemEventArgs | Initializes a new instance of the AdvancedTabItemEventArgs class
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | TabItem | Gets or sets the AdvancedTabItem that is the focus of this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItemEventArgs Constructor

AdvancedTabItemEventArgs Constructor
Initializes a new instance of the AdvancedTabItemEventArgs class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabItemEventArgs()
Public Sub New
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItemEventArgs Properties

AdvancedTabItemEventArgs Properties

The AdvancedTabItemEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | TabItem | Gets or sets the AdvancedTabItem that is the focus of this event.
Top
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItemEventArgs.TabItem Property

AdvancedTabItemEventArgsTabItem Property
Gets or sets the AdvancedTabItem that is the focus of this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabItem TabItem { get; set; }
Public Property TabItem As AdvancedTabItem
    Get
    Set

Property Value

Type: AdvancedTabItem
The AdvancedTabItem that is the focus of this event.
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


AdvancedTabItemEventArgs Methods

AdvancedTabItemEventArgs Methods

The AdvancedTabItemEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdvancedTabItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ContextContentAlignment Class

ContextContentAlignment Class
Indicates the alignment around the primary content (e.g. title) that the contextual content appears.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingContextContentAlignment

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ContextContentAlignment : Enum
Public NotInheritable Class ContextContentAlignment
    Inherits Enum

The ContextContentAlignment type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Far | The context content will appear on the far side (right side of titles in title bars, near other buttons).
 | Near | The context content will appear on the near side (left side of titles in title bars).
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ContextContentAlignment Methods

ContextContentAlignment Methods

The ContextContentAlignment type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ContextContentAlignment Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ContextContentAlignment Fields

ContextContentAlignment Fields

The ContextContentAlignment type exposes the following members.

Fields
 | Name | Description
 | Far | The context content will appear on the far side (right side of titles in title bars, near other buttons).
 | Near | The context content will appear on the near side (left side of titles in title bars).
Public field | value__ |
Top
See Also

Reference

ContextContentAlignment Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ContextContentAlignment.Far Field

ContextContentAlignmentFar Field
The context content will appear on the far side (right side of titles in title bars, near other buttons).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContextContentAlignment Far = 1
Public Const Far As ContextContentAlignment = 1

Field Value

Type: ContextContentAlignment
See Also

Reference

ContextContentAlignment Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ContextContentAlignment.Near Field

ContextContentAlignmentNear Field
The context content will appear on the near side (left side of titles in title bars).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ContextContentAlignment Near = 0
Public Const Near As ContextContentAlignment = 0

Field Value

Type: ContextContentAlignment
See Also

Reference

ContextContentAlignment Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ContextContentAlignment.value__ Field

ContextContentAlignmentvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.ContextContentAlignment.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ContextContentAlignment Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds Class

DockGuideKinds Class
Specifies multiple dock guide kinds.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingDockGuideKinds

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class DockGuideKinds : Enum
<FlagsAttribute>
Public NotInheritable Class DockGuideKinds
    Inherits Enum

The DockGuideKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Center | The center dock guide.
 | Inner | All inner dock guides.
 | InnerBottom | The inner bottom dock guide.
 | InnerLeft | The inner left dock guide.
 | InnerRight | The inner right dock guide.
 | InnerTop | The inner top dock guide.
 | None | No dock guides.
 | Outer | All outer dock guides.
 | OuterBottom | The outer bottom dock guide.
 | OuterLeft | The outer left dock guide.
 | OuterRight | The outer right dock guide.
 | OuterTop | The outer top dock guide.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds Methods

DockGuideKinds Methods

The DockGuideKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds Fields

DockGuideKinds Fields

The DockGuideKinds type exposes the following members.

Fields
 | Name | Description
 | Center | The center dock guide.
 | Inner | All inner dock guides.
 | InnerBottom | The inner bottom dock guide.
 | InnerLeft | The inner left dock guide.
 | InnerRight | The inner right dock guide.
 | InnerTop | The inner top dock guide.
 | None | No dock guides.
 | Outer | All outer dock guides.
 | OuterBottom | The outer bottom dock guide.
 | OuterLeft | The outer left dock guide.
 | OuterRight | The outer right dock guide.
 | OuterTop | The outer top dock guide.
Public field | value__ |
Top
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.Center Field

DockGuideKindsCenter Field
The center dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds Center = 256
Public Const Center As DockGuideKinds = 256

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.Inner Field

DockGuideKindsInner Field
All inner dock guides.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds Inner = 240
Public Const Inner As DockGuideKinds = 240

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.InnerBottom Field

DockGuideKindsInnerBottom Field
The inner bottom dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds InnerBottom = 128
Public Const InnerBottom As DockGuideKinds = 128

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.InnerLeft Field

DockGuideKindsInnerLeft Field
The inner left dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds InnerLeft = 16
Public Const InnerLeft As DockGuideKinds = 16

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.InnerRight Field

DockGuideKindsInnerRight Field
The inner right dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds InnerRight = 64
Public Const InnerRight As DockGuideKinds = 64

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.InnerTop Field

DockGuideKindsInnerTop Field
The inner top dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds InnerTop = 32
Public Const InnerTop As DockGuideKinds = 32

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.None Field

DockGuideKindsNone Field
No dock guides.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds None = 0
Public Const None As DockGuideKinds = 0

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.Outer Field

DockGuideKindsOuter Field
All outer dock guides.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds Outer = 15
Public Const Outer As DockGuideKinds = 15

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.OuterBottom Field

DockGuideKindsOuterBottom Field
The outer bottom dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds OuterBottom = 8
Public Const OuterBottom As DockGuideKinds = 8

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.OuterLeft Field

DockGuideKindsOuterLeft Field
The outer left dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds OuterLeft = 1
Public Const OuterLeft As DockGuideKinds = 1

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.OuterRight Field

DockGuideKindsOuterRight Field
The outer right dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds OuterRight = 4
Public Const OuterRight As DockGuideKinds = 4

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.OuterTop Field

DockGuideKindsOuterTop Field
The outer top dock guide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockGuideKinds OuterTop = 2
Public Const OuterTop As DockGuideKinds = 2

Field Value

Type: DockGuideKinds
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockGuideKinds.value__ Field

DockGuideKindsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.DockGuideKinds.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DockGuideKinds Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost Class

DockHost Class
Represents a root host that can contain a docking window hierarchy.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.DockingDockHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockHost : Control, IDockTarget
Public Class DockHost
    Inherits Control
    Implements IDockTarget

The DockHost type exposes the following members.

Constructors
 | Name | Description
Public method | DockHost | Initializes an instance of the DockHost class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.
Public property | AutoHidePopupToolWindow | Gets the ToolWindow that is currently open in the auto-hide popup, if any.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets or sets the FrameworkElement that is the child content of this container.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets the icon ImageSource for a window that contains this dock host.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoHidePopupOpen | Gets whether the auto-hide popup is currently open.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MdiHost | Gets the TabbedMdiHost or StandardMdiHost that is currently in use, if any.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets the title text for a window that contains this dock host.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Workspace | Gets the Workspace, if any, that is in the dock host.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | CloseAutoHidePopup | Closes the auto-hide popup.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Occurs when the pointer is pressed over the control. (Overrides ControlOnPointerPressed(PointerRoutedEventArgs).)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AutoHidePopupToolWindowProperty | Identifies the AutoHidePopupToolWindow dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost Constructor

DockHost Constructor
Initializes an instance of the DockHost class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost()
Public Sub New
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost Properties

DockHost Properties

The DockHost type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.
Public property | AutoHidePopupToolWindow | Gets the ToolWindow that is currently open in the auto-hide popup, if any.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets or sets the FrameworkElement that is the child content of this container.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets the icon ImageSource for a window that contains this dock host.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoHidePopupOpen | Gets whether the auto-hide popup is currently open.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MdiHost | Gets the TabbedMdiHost or StandardMdiHost that is currently in use, if any.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets the title text for a window that contains this dock host.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Workspace | Gets the Workspace, if any, that is in the dock host.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideBottomContainers Property

DockHostAutoHideBottomContainers Property
Gets the collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideBottomContainers { get; }
Public ReadOnly Property AutoHideBottomContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the bottom auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideLeftContainers Property

DockHostAutoHideLeftContainers Property
Gets the collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideLeftContainers { get; }
Public ReadOnly Property AutoHideLeftContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the left auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHidePopupToolWindow Property

DockHostAutoHidePopupToolWindow Property
Gets the ToolWindow that is currently open in the auto-hide popup, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow AutoHidePopupToolWindow { get; }
Public ReadOnly Property AutoHidePopupToolWindow As ToolWindow
    Get

Property Value

Type: ToolWindow
The ToolWindow that is currently open in the auto-hide popup, if any.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideRightContainers Property

DockHostAutoHideRightContainers Property
Gets the collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideRightContainers { get; }
Public ReadOnly Property AutoHideRightContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the right auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplate Property

DockHostAutoHideTabItemTemplate Property
Gets or sets the DataTemplate to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate AutoHideTabItemTemplate { get; set; }
Public Property AutoHideTabItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the auto-hide tab items.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplateSelector Property

DockHostAutoHideTabItemTemplateSelector Property
Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector AutoHideTabItemTemplateSelector { get; set; }
Public Property AutoHideTabItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for rendering the auto-hide tab items.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideTopContainers Property

DockHostAutoHideTopContainers Property
Gets the collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideTopContainers { get; }
Public ReadOnly Property AutoHideTopContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the top auto-hide tabstrip.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.Child Property

DockHostChild Property
Gets or sets the FrameworkElement that is the child content of this container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement that is the child content of this container.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.Icon Property

DockHostIcon Property
Gets the icon ImageSource for a window that contains this dock host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImageSource Icon { get; }
Public ReadOnly Property Icon As ImageSource
    Get

Property Value

Type: ImageSource
The icon ImageSource for a window that contains this dock host.
Remarks
This property value is based on the FloatingWindowIcon property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.IsAutoHidePopupOpen Property

DockHostIsAutoHidePopupOpen Property
Gets whether the auto-hide popup is currently open.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAutoHidePopupOpen { get; }
Public ReadOnly Property IsAutoHidePopupOpen As Boolean
    Get

Property Value

Type: Boolean
true if the auto-hide popup is currently open; otherwise, false.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.MdiHost Property

DockHostMdiHost Property
Gets the TabbedMdiHost or StandardMdiHost that is currently in use, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MdiHostBase MdiHost { get; }
Public ReadOnly Property MdiHost As MdiHostBase
    Get

Property Value

Type: MdiHostBase
The TabbedMdiHost or StandardMdiHost that is currently in use, if any.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.SplitterSize Property

DockHostSplitterSize Property
Gets or sets the size of splitters.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SplitterSize { get; set; }
Public Property SplitterSize As Double
    Get
    Set

Property Value

Type: Double
The size of splitters. The default value is 5.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.Title Property

DockHostTitle Property
Gets the title text for a window that contains this dock host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
The title text for a window that contains this dock host.
Remarks
This property value is based on the FloatingWindowTitle property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.UniqueId Property

DockHostUniqueId Property
Gets the Guid that uniquely identifies the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; }
Public ReadOnly Property UniqueId As Guid
    Get

Property Value

Type: Guid
The Guid that uniquely identifies the control.
Remarks
A new Guid value is assigned to this property every time the application is run.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.Workspace Property

DockHostWorkspace Property
Gets the Workspace, if any, that is in the dock host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Workspace Workspace { get; }
Public ReadOnly Property Workspace As Workspace
    Get

Property Value

Type: Workspace
The Workspace, if any, that is in the dock host.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost Methods

DockHost Methods

The DockHost type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | CloseAutoHidePopup | Closes the auto-hide popup.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Occurs when the pointer is pressed over the control. (Overrides ControlOnPointerPressed(PointerRoutedEventArgs).)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.ArrangeOverride Method

DockHostArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.ArrangeOverride Method (Size)

DockHostArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

DockHost Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.CloseAutoHidePopup Method

DockHostCloseAutoHidePopup Method
Closes the auto-hide popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CloseAutoHidePopup(
    bool closeImmediately,
    bool blurFocus
)
Public Sub CloseAutoHidePopup (
    closeImmediately As Boolean,
    blurFocus As Boolean
)

Parameters

closeImmediately
Type: SystemBoolean
Whether to close the popup immediately.
blurFocus
Type: SystemBoolean
Whether to blur focus.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.OnApplyTemplate Method

DockHostOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.OnCreateAutomationPeer Method

DockHostOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.OnGotFocus Method

DockHostOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.OnKeyDown Method

DockHostOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.OnPointerPressed Method

DockHostOnPointerPressed Method
Occurs when the pointer is pressed over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerPressed(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerPressed (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.ToString Method

DockHostToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost Events

DockHost Events

The DockHost type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost Fields

DockHost Fields

The DockHost type exposes the following members.

Fields
Name | Description
AutoHidePopupToolWindowProperty | Identifies the AutoHidePopupToolWindow dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
Top
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHidePopupToolWindowProperty Field

DockHostAutoHidePopupToolWindowProperty Field
Identifies the AutoHidePopupToolWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupToolWindowProperty
Public Shared ReadOnly AutoHidePopupToolWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupToolWindow dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplateProperty Field

DockHostAutoHideTabItemTemplateProperty Field
Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateProperty
Public Shared ReadOnly AutoHideTabItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplate dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.AutoHideTabItemTemplateSelectorProperty Field

DockHostAutoHideTabItemTemplateSelectorProperty Field
Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateSelectorProperty
Public Shared ReadOnly AutoHideTabItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplateSelector dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.ChildProperty Field

DockHostChildProperty Field
Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.IconProperty Field

DockHostIconProperty Field
Identifies the Icon dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IconProperty
Public Shared ReadOnly IconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Icon dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.SplitterSizeProperty Field

DockHostSplitterSizeProperty Field
Identifies the SplitterSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SplitterSizeProperty
Public Shared ReadOnly SplitterSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SplitterSize dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.TitleProperty Field

DockHostTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockHost.UniqueIdProperty Field

DockHostUniqueIdProperty Field
Identifies the UniqueId dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UniqueIdProperty
Public Shared ReadOnly UniqueIdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UniqueId dependency property.
See Also

Reference

DockHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuEventArgs Class

DockingMenuEventArgs Class
Provides event arguments for customizing a docking-related context or drop-down menu.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingMenuEventArgs : DockingWindowEventArgs
Public Class DockingMenuEventArgs
    Inherits DockingWindowEventArgs

The DockingMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingMenuEventArgs | Initializes a new instance of the DockingMenuEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Kind | Gets a DockingMenuKind indicating the menu kind.
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuEventArgs Constructor

DockingMenuEventArgs Constructor
Initializes a new instance of the DockingMenuEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingMenuEventArgs(
    DockingMenuKind kind
)
Public Sub New (
    kind As DockingMenuKind
)

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuKind
A DockingMenuKind indicating the menu kind.
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuEventArgs Properties

DockingMenuEventArgs Properties

The DockingMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Kind | Gets a DockingMenuKind indicating the menu kind.
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuEventArgs.Kind Property

DockingMenuEventArgsKind Property
Gets a DockingMenuKind indicating the menu kind.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingMenuKind Kind { get; }
Public ReadOnly Property Kind As DockingMenuKind
    Get

Property Value

Type: DockingMenuKind
A DockingMenuKind indicating the menu kind.
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuEventArgs.Menu Property

DockingMenuEventArgsMenu Property
Gets or sets the MenuFlyout that is about to be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MenuFlyout Menu { get; set; }
Public Property Menu As MenuFlyout
    Get
    Set

Property Value

Type: MenuFlyout
The MenuFlyout that is about to be displayed.
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuEventArgs Methods

DockingMenuEventArgs Methods

The DockingMenuEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind Class

DockingMenuKind Class
Specifies the kind of context or drop-down menu used by the docking elements.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DockingMenuKind : Enum
Public NotInheritable Class DockingMenuKind
    Inherits Enum

The DockingMenuKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AutoHideContextMenu | Context menu for an auto-hide well. If the menu is displayed for a particular tab, the related docking window is passed in the event arguments.
 | StandardMdiWindowControlContextMenu | Context menu for a standard MDI window control. The related docking window is passed in the event arguments.
 | TabbedMdiContainerOverflowMenu | Overflow menu for a tabbed MDI container. The container's currently-selected docking window is passed in the event arguments.
 | TabbedMdiContainerTabContextMenu | Context menu for a tabbed MDI container tab. The related docking window is passed in the event arguments.
 | ToolWindowContainerOverflowMenu | Overflow menu for a tool window container. The container's currently-selected docking window is passed in the event arguments.
 | ToolWindowContainerTabContextMenu | Context menu for a tool window container tab. The related docking window is passed in the event arguments.
 | ToolWindowContainerTitleBarContextMenu | Context menu for a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.
 | ToolWindowContainerTitleBarOptionsMenu | Options menu, displayed when clicking an options button in a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.
 | Unknown | The menu kind is not known.
Public field | value__ |
 | WindowControlContextMenu | Context menu for a window control.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind Methods

DockingMenuKind Methods

The DockingMenuKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind Fields

DockingMenuKind Fields

The DockingMenuKind type exposes the following members.

Fields
 | Name | Description
 | AutoHideContextMenu | Context menu for an auto-hide well. If the menu is displayed for a particular tab, the related docking window is passed in the event arguments.
 | StandardMdiWindowControlContextMenu | Context menu for a standard MDI window control. The related docking window is passed in the event arguments.
 | TabbedMdiContainerOverflowMenu | Overflow menu for a tabbed MDI container. The container's currently-selected docking window is passed in the event arguments.
 | TabbedMdiContainerTabContextMenu | Context menu for a tabbed MDI container tab. The related docking window is passed in the event arguments.
 | ToolWindowContainerOverflowMenu | Overflow menu for a tool window container. The container's currently-selected docking window is passed in the event arguments.
 | ToolWindowContainerTabContextMenu | Context menu for a tool window container tab. The related docking window is passed in the event arguments.
 | ToolWindowContainerTitleBarContextMenu | Context menu for a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.
 | ToolWindowContainerTitleBarOptionsMenu | Options menu, displayed when clicking an options button in a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.
 | Unknown | The menu kind is not known.
Public field | value__ |
 | WindowControlContextMenu | Context menu for a window control.
Top
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.AutoHideContextMenu Field

DockingMenuKindAutoHideContextMenu Field
Context menu for an auto-hide well. If the menu is displayed for a particular tab, the related docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind AutoHideContextMenu = 1
Public Const AutoHideContextMenu As DockingMenuKind = 1

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.StandardMdiWindowControlContextMenu Field

DockingMenuKindStandardMdiWindowControlContextMenu Field
Context menu for a standard MDI window control. The related docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind StandardMdiWindowControlContextMenu = 2
Public Const StandardMdiWindowControlContextMenu As DockingMenuKind = 2

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.TabbedMdiContainerOverflowMenu Field

DockingMenuKindTabbedMdiContainerOverflowMenu Field
Overflow menu for a tabbed MDI container. The container's currently-selected docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind TabbedMdiContainerOverflowMenu = 3
Public Const TabbedMdiContainerOverflowMenu As DockingMenuKind = 3

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.TabbedMdiContainerTabContextMenu Field

DockingMenuKindTabbedMdiContainerTabContextMenu Field
Context menu for a tabbed MDI container tab. The related docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind TabbedMdiContainerTabContextMenu = 4
Public Const TabbedMdiContainerTabContextMenu As DockingMenuKind = 4

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.ToolWindowContainerOverflowMenu Field

DockingMenuKindToolWindowContainerOverflowMenu Field
Overflow menu for a tool window container. The container's currently-selected docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind ToolWindowContainerOverflowMenu = 5
Public Const ToolWindowContainerOverflowMenu As DockingMenuKind = 5

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.ToolWindowContainerTabContextMenu Field

DockingMenuKindToolWindowContainerTabContextMenu Field
Context menu for a tool window container tab. The related docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind ToolWindowContainerTabContextMenu = 6
Public Const ToolWindowContainerTabContextMenu As DockingMenuKind = 6

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.ToolWindowContainerTitleBarContextMenu Field

DockingMenuKindToolWindowContainerTitleBarContextMenu Field
Context menu for a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind ToolWindowContainerTitleBarContextMenu = 7
Public Const ToolWindowContainerTitleBarContextMenu As DockingMenuKind = 7

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.ToolWindowContainerTitleBarOptionsMenu Field

DockingMenuKindToolWindowContainerTitleBarOptionsMenu Field
Options menu, displayed when clicking an options button in a tool window container title bar. The container's currently-selected docking window is passed in the event arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind ToolWindowContainerTitleBarOptionsMenu = 8
Public Const ToolWindowContainerTitleBarOptionsMenu As DockingMenuKind = 8

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.Unknown Field

DockingMenuKindUnknown Field
The menu kind is not known.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind Unknown = 0
Public Const Unknown As DockingMenuKind = 0

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.value__ Field

DockingMenuKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.DockingMenuKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingMenuKind.WindowControlContextMenu Field

DockingMenuKindWindowControlContextMenu Field
Context menu for a window control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingMenuKind WindowControlContextMenu = 9
Public Const WindowControlContextMenu As DockingMenuKind = 9

Field Value

Type: DockingMenuKind
See Also

Reference

DockingMenuKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Class

DockingWindow Class
Represents the base class for a docking window implementation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingDocumentWindow
ActiproSoftware.UI.Xaml.Controls.DockingToolWindow

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DockingWindow : ContentControl,
    INotifyPropertyChanged, IDockTarget
Public MustInherit Class DockingWindow
    Inherits ContentControl
    Implements INotifyPropertyChanged, IDockTarget

The DockingWindow type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindow | Initializes a new instance of the DockingWindow class.
Protected method | DockingWindow(Boolean) | Initializes a new instance of the DockingWindow class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state.
Public property | CanClose | Gets or sets whether the window may be closed.
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed.
Public property | CanDock | Gets or sets whether the window may be docked.
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location.
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location.
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site.
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site.
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI.
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI.
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI.
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI.
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost.
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized.
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can Close the window.
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state.
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container.
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container.
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container.
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FloatCommand | Gets the ICommand that can Float the window.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area.
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI.
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI.
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container.
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI.
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenCommand | Gets the ICommand that can Open the window.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data.
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content.
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state.
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI.
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview).
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab.
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled.
Public property | TabFlashMode | Gets or sets the flash mode for the tab.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs.
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs.
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes.
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window, removing it from the layout.
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout.
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout.
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite.
Public method | DragMove | Programmatically starts a drag/move.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Float | Floats the window to a default location with its current size.
Public method | Float(Point) | Floats the window to the specified location with its current size.
Public method | Float(Size) | Floats the window to a default location with the specified size.
Public method | Float(NullablePoint, NullableSize) | Floats the window to the specified optional location and size.
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container.
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container.
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container.
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site.
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area.
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area.
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI.
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI.
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI.
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI.
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains keyboard focus within its hierarchy. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes.
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | Open | Opens the window, inserting it into the layout.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value.
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value.
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value.
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value.
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value.
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value.
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value.
Protected method | UpdateCommands | Updates the enabled states of the commands.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CanAttachProperty | Identifies the CanAttach dependency property. This field is read-only.
CanAttachResolvedProperty | Identifies the CanAttachResolved dependency property. This field is read-only.
CanBecomeDocumentResolvedProperty | Identifies the CanBecomeDocumentResolved dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanCloseResolvedProperty | Identifies the CanCloseResolved dependency property. This field is read-only.
CanDockProperty | Identifies the CanDock dependency property. This field is read-only.
CanDockResolvedProperty | Identifies the CanDockResolved dependency property. This field is read-only.
CanDragTabProperty | Identifies the CanDragTab dependency property. This field is read-only.
CanDragTabResolvedProperty | Identifies the CanDragTabResolved dependency property. This field is read-only.
CanDragToLinkedDockSitesProperty | Identifies the CanDragToLinkedDockSites dependency property. This field is read-only.
CanDragToLinkedDockSitesResolvedProperty | Identifies the CanDragToLinkedDockSitesResolved dependency property. This field is read-only.
CanFloatProperty | Identifies the CanFloat dependency property. This field is read-only.
CanFloatResolvedProperty | Identifies the CanFloatResolved dependency property. This field is read-only.
CanSerializeProperty | Identifies the CanSerialize dependency property. This field is read-only.
CanStandardMdiMaximizeProperty | Identifies the CanStandardMdiMaximize dependency property. This field is read-only.
CanStandardMdiMaximizeResolvedProperty | Identifies the CanStandardMdiMaximizeResolved dependency property. This field is read-only.
CanStandardMdiMinimizeProperty | Identifies the CanStandardMdiMinimize dependency property. This field is read-only.
CanStandardMdiMinimizeResolvedProperty | Identifies the CanStandardMdiMinimizeResolved dependency property. This field is read-only.
ContainerDockedSizeProperty | Identifies the ContainerDockedSize dependency property. This field is read-only.
ContainerMaxSizeProperty | Identifies the ContainerMaxSize dependency property. This field is read-only.
ContainerMinSizeProperty | Identifies the ContainerMinSize dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
LastActiveDateTimeProperty | Identifies the LastActiveDateTime dependency property. This field is read-only.
SerializationIdProperty | Identifies the SerializationId dependency property. This field is read-only.
SizeToContentModesProperty | Identifies the SizeToContentModes dependency property. This field is read-only.
StandardMdiBoundsProperty | Identifies the StandardMdiBounds dependency property. This field is read-only.
StandardMdiTitleBarContextContentTemplateProperty | Identifies the StandardMdiTitleBarContextContentTemplate dependency property. This field is read-only.
StandardMdiWindowStateProperty | Identifies the StandardMdiWindowState dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabbedMdiLayoutKindProperty | Identifies the TabbedMdiLayoutKind dependency property. This field is read-only.
TabbedMdiTabContextContentTemplateProperty | Identifies the TabbedMdiTabContextContentTemplate dependency property. This field is read-only.
TabFlashColorProperty | Identifies the TabFlashColor dependency property. This field is read-only.
TabFlashModeProperty | Identifies the TabFlashMode dependency property. This field is read-only.
TabTextProperty | Identifies the TabText dependency property. This field is read-only.
TabTextResolvedProperty | Identifies the TabTextResolved dependency property. This field is read-only.
TabTintColorProperty | Identifies the TabTintColor dependency property. This field is read-only.
TabToolTipProperty | Identifies the TabToolTip dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
WindowGroupNameProperty | Identifies the WindowGroupName dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Constructor

DockingWindow Constructor
Overload List
 | Name | Description
Protected method | DockingWindow | Initializes a new instance of the DockingWindow class.
Protected method | DockingWindow(Boolean) | Initializes a new instance of the DockingWindow class.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Constructor

DockingWindow Constructor
Initializes a new instance of the DockingWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DockingWindow()
Protected Sub New
See Also

Reference

DockingWindow Class
DockingWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Constructor (Boolean)

DockingWindow Constructor (Boolean)
Initializes a new instance of the DockingWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DockingWindow(
    bool isContainerForItem
)
Protected Sub New (
    isContainerForItem As Boolean
)

Parameters

isContainerForItem
Type: SystemBoolean
Whether the window has been auto-created as a container for an item.
See Also

Reference

DockingWindow Class
DockingWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Properties

DockingWindow Properties

The DockingWindow type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state.
Public property | CanClose | Gets or sets whether the window may be closed.
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed.
Public property | CanDock | Gets or sets whether the window may be docked.
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location.
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location.
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site.
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site.
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI.
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI.
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI.
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI.
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost.
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized.
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can Close the window.
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state.
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container.
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container.
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container.
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FloatCommand | Gets the ICommand that can Float the window.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area.
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI.
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI.
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container.
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI.
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenCommand | Gets the ICommand that can Open the window.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data.
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content.
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state.
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI.
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview).
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab.
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled.
Public property | TabFlashMode | Gets or sets the flash mode for the tab.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs.
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs.
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes.
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ActivateCommand Property

DockingWindowActivateCommand Property
Gets or sets the ICommand that can Activate the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ActivateCommand { get; }
Public ReadOnly Property ActivateCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Activate the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanAttach Property

DockingWindowCanAttach Property
Gets or sets whether the window may be attached to another window, creating a tabbed grouping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanAttach { get; set; }
Public Property CanAttach As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be attached to another window, creating a tabbed grouping.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanAttachResolved Property

DockingWindowCanAttachResolved Property
Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAttachResolved { get; protected set; }
Public Property CanAttachResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be attached to another window, creating a tabbed grouping; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanBecomeDocumentResolved Property

DockingWindowCanBecomeDocumentResolved Property
Gets a resolved value indicating whether the window may be placed in a document state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanBecomeDocumentResolved { get; protected set; }
Public Property CanBecomeDocumentResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be placed in a document state; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanClose Property

DockingWindowCanClose Property
Gets or sets whether the window may be closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanClose { get; set; }
Public Property CanClose As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be closed.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanCloseResolved Property

DockingWindowCanCloseResolved Property
Gets a resolved value indicating whether the window may be closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCloseResolved { get; protected set; }
Public Property CanCloseResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be closed; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDock Property

DockingWindowCanDock Property
Gets or sets whether the window may be docked.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanDock { get; set; }
Public Property CanDock As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be docked.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDockResolved Property

DockingWindowCanDockResolved Property
Gets a resolved value indicating whether the window may be docked.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDockResolved { get; protected set; }
Public Property CanDockResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be docked; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragTab Property

DockingWindowCanDragTab Property
Gets or sets whether the window's tab may be dragged to another location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanDragTab { get; set; }
Public Property CanDragTab As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window's tab may be dragged to another location.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragTabResolved Property

DockingWindowCanDragTabResolved Property
Gets a resolved value indicating whether the window's tab may be dragged to another location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDragTabResolved { get; protected set; }
Public Property CanDragTabResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window's tab may be dragged to another location; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSites Property

DockingWindowCanDragToLinkedDockSites Property
Gets or sets whether the window may be dragged to a linked dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanDragToLinkedDockSites { get; set; }
Public Property CanDragToLinkedDockSites As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be dragged to a linked dock site.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSitesResolved Property

DockingWindowCanDragToLinkedDockSitesResolved Property
Gets a resolved value indicating whether the window may be dragged to a linked dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDragToLinkedDockSitesResolved { get; protected set; }
Public Property CanDragToLinkedDockSitesResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be dragged to a linked dock site; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanFloat Property

DockingWindowCanFloat Property
Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanFloat { get; set; }
Public Property CanFloat As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanFloatResolved Property

DockingWindowCanFloatResolved Property
Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanFloatResolved { get; protected set; }
Public Property CanFloatResolved As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanMoveToNewHorizontalContainer Property

DockingWindowCanMoveToNewHorizontalContainer Property
Gets whether the window can move to a new horizontal container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveToNewHorizontalContainer { get; }
Public ReadOnly Property CanMoveToNewHorizontalContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to a new horizontal container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container that has more than one docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanMoveToNewVerticalContainer Property

DockingWindowCanMoveToNewVerticalContainer Property
Gets whether the window can move to a new vertical container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveToNewVerticalContainer { get; }
Public ReadOnly Property CanMoveToNewVerticalContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to a new vertical container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container that has more than one docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanMoveToNextContainer Property

DockingWindowCanMoveToNextContainer Property
Gets whether the window can move to the next container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveToNextContainer { get; }
Public ReadOnly Property CanMoveToNextContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to the next container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container and there is another tabbed MDI container after it in the layout.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanMoveToPreviousContainer Property

DockingWindowCanMoveToPreviousContainer Property
Gets whether the window can move to the previous container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveToPreviousContainer { get; }
Public ReadOnly Property CanMoveToPreviousContainer As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to the previous container; otherwise, false.
Remarks
This property returns true when the window is currently within a tabbed MDI container and there is another tabbed MDI container before it in the layout.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanMoveToPrimaryMdiHost Property

DockingWindowCanMoveToPrimaryMdiHost Property
Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveToPrimaryMdiHost { get; }
Public ReadOnly Property CanMoveToPrimaryMdiHost As Boolean
    Get

Property Value

Type: Boolean
true if the window can move to the primary MDI host; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanSerialize Property

DockingWindowCanSerialize Property
Gets or sets whether the window's layout information may be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanSerialize { get; set; }
Public Property CanSerialize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window's layout information may be serialized; otherwise, false. The default value is true.
Remarks
When false, this property designates that the window should not be included in serialized layout information.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximize Property

DockingWindowCanStandardMdiMaximize Property
Gets or sets whether the window may be maximized when hosted in a StandardMdiHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanStandardMdiMaximize { get; set; }
Public Property CanStandardMdiMaximize As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be maximized when hosted in a StandardMdiHost.
Remarks
If set to , the resolved value will use the global StandardMdiHost setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximizeResolved Property

DockingWindowCanStandardMdiMaximizeResolved Property
Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanStandardMdiMaximizeResolved { get; }
Public ReadOnly Property CanStandardMdiMaximizeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the window may be maximized when hosted in a StandardMdiHost; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimize Property

DockingWindowCanStandardMdiMinimize Property
Gets or sets whether the window may be minimized when hosted in a StandardMdiHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanStandardMdiMinimize { get; set; }
Public Property CanStandardMdiMinimize As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the window may be minimized when hosted in a StandardMdiHost.
Remarks
If set to , the resolved value will use the global StandardMdiHost setting.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimizeResolved Property

DockingWindowCanStandardMdiMinimizeResolved Property
Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanStandardMdiMinimizeResolved { get; }
Public ReadOnly Property CanStandardMdiMinimizeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the window may be attached to another window; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CloseCommand Property

DockingWindowCloseCommand Property
Gets the ICommand that can Close the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Close the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CloseOthersCommand Property

DockingWindowCloseOthersCommand Property
Gets or sets the ICommand that can close all other windows in the current container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CloseOthersCommand { get; }
Public ReadOnly Property CloseOthersCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close all other windows in the current container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerDockedSize Property

DockingWindowContainerDockedSize Property
Gets or sets the Size of the docking window's container when it is in a docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerDockedSize { get; set; }
Public Property ContainerDockedSize As Size
    Get
    Set

Property Value

Type: Size
The Size of the docking window's container when it is in a docked state.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerMaxSize Property

DockingWindowContainerMaxSize Property
Gets or sets the maximum Size of the docking window's container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerMaxSize { get; set; }
Public Property ContainerMaxSize As Size
    Get
    Set

Property Value

Type: Size
The maximum Size of the docking window's container.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerMaxSizeResolved Property

DockingWindowContainerMaxSizeResolved Property
Gets the resolved maximum Size of the docking window's container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerMaxSizeResolved { get; }
Public ReadOnly Property ContainerMaxSizeResolved As Size
    Get

Property Value

Type: Size
The maximum Size of the docking window's container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerMinSize Property

DockingWindowContainerMinSize Property
Gets or sets the minimum Size of the docking window's container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerMinSize { get; set; }
Public Property ContainerMinSize As Size
    Get
    Set

Property Value

Type: Size
The minimum Size of the docking window's container.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerMinSizeResolved Property

DockingWindowContainerMinSizeResolved Property
Gets the resolved minimum Size of the docking window's container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerMinSizeResolved { get; }
Public ReadOnly Property ContainerMinSizeResolved As Size
    Get

Property Value

Type: Size
The minimum Size of the docking window's container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Description Property

DockingWindowDescription Property
Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description for the docking window, which may be used in Ctrl+Tab switching UI.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.DestroyCommand Property

DockingWindowDestroyCommand Property
Gets or sets the ICommand that can Destroy the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand DestroyCommand { get; }
Public ReadOnly Property DestroyCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Destroy the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.DockHost Property

DockingWindowDockHost Property
Gets the DockHost in which the window is currently located.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost in which the window is currently located.
Remarks
The primary dock host is the one directly within the DockSite hierarchy. Floating dock hosts are top-level containers that are external to the DockSite hierarchy's primary dock host.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.DockSite Property

DockingWindowDockSite Property
Gets the DockSite that is managing this docking window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this docking window.

Implements

IDockTargetDockSite
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.FloatCommand Property

DockingWindowFloatCommand Property
Gets the ICommand that can Float the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand FloatCommand { get; }
Public ReadOnly Property FloatCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Float the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ImageSource Property

DockingWindowImageSource Property
Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImageSource ImageSource { get; set; }
Public Property ImageSource As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The ImageSource specifying the 16x16 image for the docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsActive Property

DockingWindowIsActive Property
Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is currently active; otherwise, false.
Remarks
This property is set to true when the ActiveWindow is this window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsContainerForItem Property

DockingWindowIsContainerForItem Property
Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsContainerForItem { get; }
Public ReadOnly Property IsContainerForItem As Boolean
    Get

Property Value

Type: Boolean
true if this window was auto-created as a container for an item; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsOpen Property

DockingWindowIsOpen Property
Gets or sets whether the docking window is currently open in the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is currently open in the layout; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsSelected Property

DockingWindowIsSelected Property
Gets or sets whether the docking window is currently selected in its parent container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the docking window is currently selected in its parent container; otherwise, false.
Remarks
The container is generally a TabbedMdiContainer, StandardMdiHost, or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.LastActiveDateTime Property

DockingWindowLastActiveDateTime Property
Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime LastActiveDateTime { get; }
Public ReadOnly Property LastActiveDateTime As DateTime
    Get

Property Value

Type: DateTime
The DateTime at which the window was last active, meaning the primary window that was focused.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToMdiCommand Property

DockingWindowMoveToMdiCommand Property
Gets or sets the ICommand that can change the window into a document within a MDI area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MoveToMdiCommand { get; }
Public ReadOnly Property MoveToMdiCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can change the window into a document within a MDI area.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToNewHorizontalContainerCommand Property

DockingWindowMoveToNewHorizontalContainerCommand Property
Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MoveToNewHorizontalContainerCommand { get; }
Public ReadOnly Property MoveToNewHorizontalContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to a new horizontal container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToNewVerticalContainerCommand Property

DockingWindowMoveToNewVerticalContainerCommand Property
Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MoveToNewVerticalContainerCommand { get; }
Public ReadOnly Property MoveToNewVerticalContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to a new vertical container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToNextContainerCommand Property

DockingWindowMoveToNextContainerCommand Property
Gets or sets the ICommand that can move the window to the next container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MoveToNextContainerCommand { get; }
Public ReadOnly Property MoveToNextContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to the next container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToPreviousContainerCommand Property

DockingWindowMoveToPreviousContainerCommand Property
Gets or sets the ICommand that can move the window to the previous container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MoveToPreviousContainerCommand { get; }
Public ReadOnly Property MoveToPreviousContainerCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to the previous container.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToPrimaryMdiHostCommand Property

DockingWindowMoveToPrimaryMdiHostCommand Property
Gets or sets the ICommand that can move the window to the primary MDI host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MoveToPrimaryMdiHostCommand { get; }
Public ReadOnly Property MoveToPrimaryMdiHostCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window to the primary MDI host.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OpenCommand Property

DockingWindowOpenCommand Property
Gets the ICommand that can Open the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand OpenCommand { get; }
Public ReadOnly Property OpenCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can Open the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ParentContainer Property

DockingWindowParentContainer Property
Gets the DockingWindowContainerBase that currently contains the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowContainerBase ParentContainer { get; }
Public ReadOnly Property ParentContainer As DockingWindowContainerBase
    Get

Property Value

Type: DockingWindowContainerBase
The DockingWindowContainerBase that currently contains the window.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.SerializationId Property

DockingWindowSerializationId Property
Gets or sets the unique ID to use when matching up windows with serialized layout data.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SerializationId { get; set; }
Public Property SerializationId As String
    Get
    Set

Property Value

Type: String
The unique ID to use when matching up windows with serialized layout data.
Remarks
When deserializing a saved layout, the layout information has to be matched up with related windows, which is done via this property. Each window needs to have a unique serialization ID, specified by this property. When this property is , the window's Name property will be used instead. While the Name property must conform to standard .NET identifier syntax, this property can use any characters in its value.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.SetTabbedMdiLayoutKindCommand Property

DockingWindowSetTabbedMdiLayoutKindCommand Property
Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SetTabbedMdiLayoutKindCommand { get; }
Public ReadOnly Property SetTabbedMdiLayoutKindCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.SizeToContentModes Property

DockingWindowSizeToContentModes Property
Gets or sets a SizeToContentModes that indicates when to try to size-to-content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SizeToContentModes SizeToContentModes { get; set; }
Public Property SizeToContentModes As SizeToContentModes
    Get
    Set

Property Value

Type: SizeToContentModes
A SizeToContentModes that specifies the modes. The default value is None.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StandardMdiBounds Property

DockingWindowStandardMdiBounds Property
Gets or sets the bounds of this docking window when in standard MDI 'restored' state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect StandardMdiBounds { get; set; }
Public Property StandardMdiBounds As Rect
    Get
    Set

Property Value

Type: Rect
The bounds of this docking window when in standard MDI 'restored' state.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StandardMdiTitleBarContextContentTemplate Property

DockingWindowStandardMdiTitleBarContextContentTemplate Property
Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate StandardMdiTitleBarContextContentTemplate { get; set; }
Public Property StandardMdiTitleBarContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StandardMdiWindowState Property

DockingWindowStandardMdiWindowState Property
Gets or sets the WindowState of this docking window when in standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WindowState StandardMdiWindowState { get; set; }
Public Property StandardMdiWindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
The WindowState of this docking window when in standard MDI.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.State Property

DockingWindowState Property
Gets or sets the DockingWindowState that specifies the current state of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowState State { get; set; }
Public Property State As DockingWindowState
    Get
    Set

Property Value

Type: DockingWindowState
The DockingWindowState that specifies the current state of the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabbedMdiLayoutKind Property

DockingWindowTabbedMdiLayoutKind Property
Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabLayoutKind TabbedMdiLayoutKind { get; set; }
Public Property TabbedMdiLayoutKind As TabLayoutKind
    Get
    Set

Property Value

Type: TabLayoutKind
The TabLayoutKind that indicates how the tab will be positioned.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabbedMdiTabContextContentTemplate Property

DockingWindowTabbedMdiTabContextContentTemplate Property
Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate TabbedMdiTabContextContentTemplate { get; set; }
Public Property TabbedMdiTabContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for displaying contextual content in a tabbed MDI tab.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabFlashColor Property

DockingWindowTabFlashColor Property
Gets or sets the flash color to use if tab flashing is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color TabFlashColor { get; set; }
Public Property TabFlashColor As Color
    Get
    Set

Property Value

Type: Color
The flash color to use if tab flashing is enabled. The default value is #80FFA000.
Remarks
Tab flashing can be enabled via the TabFlashMode property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabFlashMode Property

DockingWindowTabFlashMode Property
Gets or sets the flash mode for the tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabFlashMode TabFlashMode { get; set; }
Public Property TabFlashMode As TabFlashMode
    Get
    Set

Property Value

Type: TabFlashMode
The flash mode for the tab.
Remarks
The tab flash color can be set via the TabFlashColor property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabText Property

DockingWindowTabText Property
Gets or sets the optional text to only display on tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TabText { get; set; }
Public Property TabText As String
    Get
    Set

Property Value

Type: String
The optional text to only display on tabs.
Remarks
If this text is not specified, the Title will display on tabs.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabTextResolved Property

DockingWindowTabTextResolved Property
Gets the resolved optional text to only display on tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TabTextResolved { get; }
Public ReadOnly Property TabTextResolved As String
    Get

Property Value

Type: String
The resolved optional text to only display on tabs.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabTintColor Property

DockingWindowTabTintColor Property
Gets or sets the color used to tint the tab background and border brushes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color TabTintColor { get; set; }
Public Property TabTintColor As Color
    Get
    Set

Property Value

Type: Color
The color used to tint the tab background and border brushes.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabToolTip Property

DockingWindowTabToolTip Property
Gets or sets the tooltip content to use for tabs that represent the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object TabToolTip { get; set; }
Public Property TabToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip content to use for tabs that represent the window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Title Property

DockingWindowTitle Property
Gets or sets the title for the docking window, which appears in several places throughout the UI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title for the docking window.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UniqueId Property

DockingWindowUniqueId Property
Gets the Guid that uniquely identifies the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; }
Public ReadOnly Property UniqueId As Guid
    Get

Property Value

Type: Guid
The Guid that uniquely identifies the control.
Remarks
A new Guid value is assigned to this property every time the application is run. Use the SerializationId property to designate an ID that uniquely identifies the window for layout deserialization purposes.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.WindowGroupName Property

DockingWindowWindowGroupName Property
Gets or sets an optional name that specifies a group of windows that have an affinity.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string WindowGroupName { get; set; }
Public Property WindowGroupName As String
    Get
    Set

Property Value

Type: String
The optional name that specifies a group of windows that have an affinity.
Remarks
Say that there are three windows that should generally be attached together. All of them should be assigned the same group name (e.g. Bottom). When a window is first opened and no previous location is found for it, it will search for other windows that are already open in the same state and have the same group name. If any are found, it will default to attaching to the most recently activated one.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Methods

DockingWindow Methods

The DockingWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window, removing it from the layout.
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout.
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout.
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite.
Public method | DragMove | Programmatically starts a drag/move.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Float | Floats the window to a default location with its current size.
Public method | Float(Point) | Floats the window to the specified location with its current size.
Public method | Float(Size) | Floats the window to a default location with the specified size.
Public method | Float(NullablePoint, NullableSize) | Floats the window to the specified optional location and size.
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container.
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container.
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container.
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site.
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area.
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area.
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI.
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI.
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI.
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI.
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains keyboard focus within its hierarchy. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes.
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | Open | Opens the window, inserting it into the layout.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value.
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value.
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value.
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value.
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value.
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value.
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value.
Protected method | UpdateCommands | Updates the enabled states of the commands.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Activate Method

DockingWindowActivate Method
Overload List
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Activate Method

DockingWindowActivate Method
Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Activate()
Public Sub Activate
See Also

Reference

DockingWindow Class
Activate Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Activate Method (Boolean)

DockingWindowActivate Method (Boolean)
Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Activate(
    bool focus
)
Public Sub Activate (
    focus As Boolean
)

Parameters

focus
Type: SystemBoolean
Whether to focus the window as well.
See Also

Reference

DockingWindow Class
Activate Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Close Method

DockingWindowClose Method
Closes the window, removing it from the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Close()
Public Function Close As Boolean

Return Value

Type: Boolean
true if the docking window was closed successfully; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CloseOthers Method

DockingWindowCloseOthers Method
Overload List
 | Name | Description
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout.
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CloseOthers Method

DockingWindowCloseOthers Method
Closes all other windows marked as closeable in the same parent container, removing them from the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CloseOthers()
Public Function CloseOthers As Boolean

Return Value

Type: Boolean
true if the other docking windows were closed successfully; otherwise, false.
See Also

Reference

DockingWindow Class
CloseOthers Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CloseOthers Method (Boolean)

DockingWindowCloseOthers Method (Boolean)
Closes all other windows in the same parent container, removing them from the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CloseOthers(
    bool onlyCloseable
)
Public Function CloseOthers (
    onlyCloseable As Boolean
) As Boolean

Parameters

onlyCloseable
Type: SystemBoolean
Only close windows whose CanCloseResolved property is true.

Return Value

Type: Boolean
true if the other docking windows were closed successfully; otherwise, false.
See Also

Reference

DockingWindow Class
CloseOthers Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Destroy Method

DockingWindowDestroy Method
Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Destroy()
Public Sub Destroy
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.DragMove Method

DockingWindowDragMove Method
Programmatically starts a drag/move.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void DragMove(
    InputPointerButtonEventArgs sourceEventArgs
)
Public Sub DragMove (
    sourceEventArgs As InputPointerButtonEventArgs
)

Parameters

sourceEventArgs
Type: ActiproSoftware.UI.Xaml.InputInputPointerButtonEventArgs
The source InputPointerButtonEventArgs, which can be used to capture the pointer.
Remarks
The primary button of the pointer in the event arguments must be pressed down when calling this method. The pointer will be captured.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Float Method

DockingWindowFloat Method
Overload List
 | Name | Description
Public method | Float | Floats the window to a default location with its current size.
Public method | Float(Point) | Floats the window to the specified location with its current size.
Public method | Float(Size) | Floats the window to a default location with the specified size.
Public method | Float(NullablePoint, NullableSize) | Floats the window to the specified optional location and size.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Float Method

DockingWindowFloat Method
Floats the window to a default location with its current size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Float()
Public Sub Float
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Float Method (Point)

DockingWindowFloat Method (Point)
Floats the window to the specified location with its current size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Float(
    Point location
)
Public Sub Float (
    location As Point
)

Parameters

location
Type: Windows.FoundationPoint
A Point specifying the target location of the floating dock host.
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Float Method (Size)

DockingWindowFloat Method (Size)
Floats the window to a default location with the specified size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Float(
    Size size
)
Public Sub Float (
    size As Size
)

Parameters

size
Type: Windows.FoundationSize
A Size specifying the target size of the floating dock host.
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Float Method (Nullable(Point), Nullable(Size))

DockingWindowFloat Method (NullablePoint, NullableSize)
Floats the window to the specified optional location and size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Float(
    Nullable<Point> location,
    Nullable<Size> size
)
Public MustOverride Sub Float (
    location As Nullable(Of Point),
    size As Nullable(Of Size)
)

Parameters

location
Type: SystemNullable Point
An optional Point specifying the target location of the floating dock host.
size
Type: SystemNullable Size
An optional Size specifying the target size of the floating dock host.
Remarks
When location is not specified, it will float to a default location. When size is not specified, it will float with its current size.
See Also

Reference

DockingWindow Class
Float Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToFirst Method

DockingWindowMoveToFirst Method
Moves the DockingWindow to be the first item in the current parent container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MoveToFirst()
Public Sub MoveToFirst
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToIndex Method

DockingWindowMoveToIndex Method
Moves the DockingWindow to the specified location in the current parent container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MoveToIndex(
    int index
)
Public Sub MoveToIndex (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index where the window should be moved.
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToLast Method

DockingWindowMoveToLast Method
Moves the DockingWindow to be the last item in the current parent container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MoveToLast()
Public Sub MoveToLast
Remarks
The container is generally a TabbedMdiContainer or ToolWindowContainer.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToLinkedDockSite Method

DockingWindowMoveToLinkedDockSite Method
Moves the DockingWindow to the specified linked dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MoveToLinkedDockSite(
    DockSite targetDockSite
)
Public Sub MoveToLinkedDockSite (
    targetDockSite As DockSite
)

Parameters

targetDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The dock site where the window should be moved.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToMdi Method

DockingWindowMoveToMdi Method
Overload List
 | Name | Description
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area.
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToMdi Method

DockingWindowMoveToMdi Method
Changes the DockingWindow into a document within a MDI area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MoveToMdi()
Public Sub MoveToMdi
Remarks
Using this method places the DockingWindow in a Document State.
See Also

Reference

DockingWindow Class
MoveToMdi Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToMdi Method (DockHost)

DockingWindowMoveToMdi Method (DockHost)
Changes the DockingWindow into a document within a specific DockHost's MDI area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MoveToMdi(
    DockHost dockHost
)
Public Sub MoveToMdi (
    dockHost As DockHost
)

Parameters

dockHost
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The DockHost that contains a MDI area in which to move the window.
Remarks
Using this method places the DockingWindow in a Document State.
See Also

Reference

DockingWindow Class
MoveToMdi Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToNewHorizontalContainer Method

DockingWindowMoveToNewHorizontalContainer Method
Moves the window to a new horizontal container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveToNewHorizontalContainer()
Public Function MoveToNewHorizontalContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to a new horizontal container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToNewVerticalContainer Method

DockingWindowMoveToNewVerticalContainer Method
Moves the window to a new vertical container within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveToNewVerticalContainer()
Public Function MoveToNewVerticalContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to a new vertical container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToNextContainer Method

DockingWindowMoveToNextContainer Method
Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveToNextContainer()
Public Function MoveToNextContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to the next container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.MoveToPreviousContainer Method

DockingWindowMoveToPreviousContainer Method
Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveToPreviousContainer()
Public Function MoveToPreviousContainer As Boolean

Return Value

Type: Boolean
true if the window was moved to the previous container; otherwise, false.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.NotifyPropertyChanged Method

DockingWindowNotifyPropertyChanged Method
Notifies that a property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OnDefaultLocationRequested Method

DockingWindowOnDefaultLocationRequested Method
Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDefaultLocationRequested(
    DockingWindowDefaultLocationEventArgs e
)
Protected Overridable Sub OnDefaultLocationRequested (
    e As DockingWindowDefaultLocationEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowDefaultLocationEventArgs
The DockingWindowDefaultLocationEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OnDockSiteChanged Method

DockingWindowOnDockSiteChanged Method
Occurs when the value of the DockSite property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDockSiteChanged(
    DockSite oldValue,
    DockSite newValue
)
Protected Overridable Sub OnDockSiteChanged (
    oldValue As DockSite,
    newValue As DockSite
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The new value.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OnGotFocus Method

DockingWindowOnGotFocus Method
Occurs when the control gains keyboard focus within its hierarchy.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The KeyboardFocusChangedEventArgs that contains data related to this event.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OnIsSelectedChanged Method

DockingWindowOnIsSelectedChanged Method
Occurs when the value of the IsSelected property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIsSelectedChanged()
Protected Overridable Sub OnIsSelectedChanged
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OnPropertyChanged Method

DockingWindowOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.OnStateChanged Method

DockingWindowOnStateChanged Method
Occurs when the value of the State property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnStateChanged(
    DockingWindowState oldValue,
    DockingWindowState newValue
)
Protected Overridable Sub OnStateChanged (
    oldValue As DockingWindowState,
    newValue As DockingWindowState
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The new value.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.Open Method

DockingWindowOpen Method
Opens the window, inserting it into the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Open()
Public Sub Open
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ToString Method

DockingWindowToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanAttachResolved Method

DockingWindowUpdateCanAttachResolved Method
Updates the CanAttachResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanAttachResolved()
Protected MustOverride Sub UpdateCanAttachResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanBecomeDocumentResolved Method

DockingWindowUpdateCanBecomeDocumentResolved Method
Updates the CanBecomeDocumentResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateCanBecomeDocumentResolved()
Protected Overridable Sub UpdateCanBecomeDocumentResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanCloseResolved Method

DockingWindowUpdateCanCloseResolved Method
Updates the CanCloseResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanCloseResolved()
Protected MustOverride Sub UpdateCanCloseResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanDockResolved Method

DockingWindowUpdateCanDockResolved Method
Updates the CanDockResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanDockResolved()
Protected MustOverride Sub UpdateCanDockResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanDragTabResolved Method

DockingWindowUpdateCanDragTabResolved Method
Updates the CanDragTabResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanDragTabResolved()
Protected MustOverride Sub UpdateCanDragTabResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanDragToLinkedDockSitesResolved Method

DockingWindowUpdateCanDragToLinkedDockSitesResolved Method
Updates the CanDragToLinkedDockSitesResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanDragToLinkedDockSitesResolved()
Protected MustOverride Sub UpdateCanDragToLinkedDockSitesResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCanFloatResolved Method

DockingWindowUpdateCanFloatResolved Method
Updates the CanFloatResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateCanFloatResolved()
Protected MustOverride Sub UpdateCanFloatResolved
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UpdateCommands Method

DockingWindowUpdateCommands Method
Updates the enabled states of the commands.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateCommands()
Protected Overridable Sub UpdateCommands
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Events

DockingWindow Events

The DockingWindow type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.DefaultLocationRequested Event

DockingWindowDefaultLocationRequested Event
Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowDefaultLocationEventArgs> DefaultLocationRequested
Public Event DefaultLocationRequested As EventHandler(Of DockingWindowDefaultLocationEventArgs)

Value

Type: SystemEventHandler DockingWindowDefaultLocationEventArgs
Remarks
The handler should examine the event arguments and set the Target and/or Side properties as appropriate.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.PropertyChanged Event

DockingWindowPropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow Fields

DockingWindow Fields

The DockingWindow type exposes the following members.

Fields
Name | Description
CanAttachProperty | Identifies the CanAttach dependency property. This field is read-only.
CanAttachResolvedProperty | Identifies the CanAttachResolved dependency property. This field is read-only.
CanBecomeDocumentResolvedProperty | Identifies the CanBecomeDocumentResolved dependency property. This field is read-only.
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
CanCloseResolvedProperty | Identifies the CanCloseResolved dependency property. This field is read-only.
CanDockProperty | Identifies the CanDock dependency property. This field is read-only.
CanDockResolvedProperty | Identifies the CanDockResolved dependency property. This field is read-only.
CanDragTabProperty | Identifies the CanDragTab dependency property. This field is read-only.
CanDragTabResolvedProperty | Identifies the CanDragTabResolved dependency property. This field is read-only.
CanDragToLinkedDockSitesProperty | Identifies the CanDragToLinkedDockSites dependency property. This field is read-only.
CanDragToLinkedDockSitesResolvedProperty | Identifies the CanDragToLinkedDockSitesResolved dependency property. This field is read-only.
CanFloatProperty | Identifies the CanFloat dependency property. This field is read-only.
CanFloatResolvedProperty | Identifies the CanFloatResolved dependency property. This field is read-only.
CanSerializeProperty | Identifies the CanSerialize dependency property. This field is read-only.
CanStandardMdiMaximizeProperty | Identifies the CanStandardMdiMaximize dependency property. This field is read-only.
CanStandardMdiMaximizeResolvedProperty | Identifies the CanStandardMdiMaximizeResolved dependency property. This field is read-only.
CanStandardMdiMinimizeProperty | Identifies the CanStandardMdiMinimize dependency property. This field is read-only.
CanStandardMdiMinimizeResolvedProperty | Identifies the CanStandardMdiMinimizeResolved dependency property. This field is read-only.
ContainerDockedSizeProperty | Identifies the ContainerDockedSize dependency property. This field is read-only.
ContainerMaxSizeProperty | Identifies the ContainerMaxSize dependency property. This field is read-only.
ContainerMinSizeProperty | Identifies the ContainerMinSize dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
ImageSourceProperty | Identifies the ImageSource dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
LastActiveDateTimeProperty | Identifies the LastActiveDateTime dependency property. This field is read-only.
SerializationIdProperty | Identifies the SerializationId dependency property. This field is read-only.
SizeToContentModesProperty | Identifies the SizeToContentModes dependency property. This field is read-only.
StandardMdiBoundsProperty | Identifies the StandardMdiBounds dependency property. This field is read-only.
StandardMdiTitleBarContextContentTemplateProperty | Identifies the StandardMdiTitleBarContextContentTemplate dependency property. This field is read-only.
StandardMdiWindowStateProperty | Identifies the StandardMdiWindowState dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabbedMdiLayoutKindProperty | Identifies the TabbedMdiLayoutKind dependency property. This field is read-only.
TabbedMdiTabContextContentTemplateProperty | Identifies the TabbedMdiTabContextContentTemplate dependency property. This field is read-only.
TabFlashColorProperty | Identifies the TabFlashColor dependency property. This field is read-only.
TabFlashModeProperty | Identifies the TabFlashMode dependency property. This field is read-only.
TabTextProperty | Identifies the TabText dependency property. This field is read-only.
TabTextResolvedProperty | Identifies the TabTextResolved dependency property. This field is read-only.
TabTintColorProperty | Identifies the TabTintColor dependency property. This field is read-only.
TabToolTipProperty | Identifies the TabToolTip dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
UniqueIdProperty | Identifies the UniqueId dependency property. This field is read-only.
WindowGroupNameProperty | Identifies the WindowGroupName dependency property. This field is read-only.
Top
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanAttachProperty Field

DockingWindowCanAttachProperty Field
Identifies the CanAttach dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAttachProperty
Public Shared ReadOnly CanAttachProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAttach dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanAttachResolvedProperty Field

DockingWindowCanAttachResolvedProperty Field
Identifies the CanAttachResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAttachResolvedProperty
Public Shared ReadOnly CanAttachResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAttachResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanBecomeDocumentResolvedProperty Field

DockingWindowCanBecomeDocumentResolvedProperty Field
Identifies the CanBecomeDocumentResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanBecomeDocumentResolvedProperty
Public Shared ReadOnly CanBecomeDocumentResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanBecomeDocumentResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanCloseProperty Field

DockingWindowCanCloseProperty Field
Identifies the CanClose dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseProperty
Public Shared ReadOnly CanCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanClose dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanCloseResolvedProperty Field

DockingWindowCanCloseResolvedProperty Field
Identifies the CanCloseResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseResolvedProperty
Public Shared ReadOnly CanCloseResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanCloseResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDockProperty Field

DockingWindowCanDockProperty Field
Identifies the CanDock dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDockProperty
Public Shared ReadOnly CanDockProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDock dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDockResolvedProperty Field

DockingWindowCanDockResolvedProperty Field
Identifies the CanDockResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDockResolvedProperty
Public Shared ReadOnly CanDockResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDockResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragTabProperty Field

DockingWindowCanDragTabProperty Field
Identifies the CanDragTab dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragTabProperty
Public Shared ReadOnly CanDragTabProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragTab dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragTabResolvedProperty Field

DockingWindowCanDragTabResolvedProperty Field
Identifies the CanDragTabResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragTabResolvedProperty
Public Shared ReadOnly CanDragTabResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragTabResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSitesProperty Field

DockingWindowCanDragToLinkedDockSitesProperty Field
Identifies the CanDragToLinkedDockSites dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragToLinkedDockSitesProperty
Public Shared ReadOnly CanDragToLinkedDockSitesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragToLinkedDockSites dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanDragToLinkedDockSitesResolvedProperty Field

DockingWindowCanDragToLinkedDockSitesResolvedProperty Field
Identifies the CanDragToLinkedDockSitesResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragToLinkedDockSitesResolvedProperty
Public Shared ReadOnly CanDragToLinkedDockSitesResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragToLinkedDockSitesResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanFloatProperty Field

DockingWindowCanFloatProperty Field
Identifies the CanFloat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanFloatProperty
Public Shared ReadOnly CanFloatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanFloat dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanFloatResolvedProperty Field

DockingWindowCanFloatResolvedProperty Field
Identifies the CanFloatResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanFloatResolvedProperty
Public Shared ReadOnly CanFloatResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanFloatResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanSerializeProperty Field

DockingWindowCanSerializeProperty Field
Identifies the CanSerialize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanSerializeProperty
Public Shared ReadOnly CanSerializeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanSerialize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximizeProperty Field

DockingWindowCanStandardMdiMaximizeProperty Field
Identifies the CanStandardMdiMaximize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMaximizeProperty
Public Shared ReadOnly CanStandardMdiMaximizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMaximize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMaximizeResolvedProperty Field

DockingWindowCanStandardMdiMaximizeResolvedProperty Field
Identifies the CanStandardMdiMaximizeResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMaximizeResolvedProperty
Public Shared ReadOnly CanStandardMdiMaximizeResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMaximizeResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimizeProperty Field

DockingWindowCanStandardMdiMinimizeProperty Field
Identifies the CanStandardMdiMinimize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMinimizeProperty
Public Shared ReadOnly CanStandardMdiMinimizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMinimize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.CanStandardMdiMinimizeResolvedProperty Field

DockingWindowCanStandardMdiMinimizeResolvedProperty Field
Identifies the CanStandardMdiMinimizeResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanStandardMdiMinimizeResolvedProperty
Public Shared ReadOnly CanStandardMdiMinimizeResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanStandardMdiMinimizeResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerDockedSizeProperty Field

DockingWindowContainerDockedSizeProperty Field
Identifies the ContainerDockedSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerDockedSizeProperty
Public Shared ReadOnly ContainerDockedSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerDockedSize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerMaxSizeProperty Field

DockingWindowContainerMaxSizeProperty Field
Identifies the ContainerMaxSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerMaxSizeProperty
Public Shared ReadOnly ContainerMaxSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerMaxSize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ContainerMinSizeProperty Field

DockingWindowContainerMinSizeProperty Field
Identifies the ContainerMinSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerMinSizeProperty
Public Shared ReadOnly ContainerMinSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerMinSize dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.DescriptionProperty Field

DockingWindowDescriptionProperty Field
Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.ImageSourceProperty Field

DockingWindowImageSourceProperty Field
Identifies the ImageSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ImageSourceProperty
Public Shared ReadOnly ImageSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ImageSource dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsActiveProperty Field

DockingWindowIsActiveProperty Field
Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsOpenProperty Field

DockingWindowIsOpenProperty Field
Identifies the IsOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOpenProperty
Public Shared ReadOnly IsOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOpen dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.IsSelectedProperty Field

DockingWindowIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.LastActiveDateTimeProperty Field

DockingWindowLastActiveDateTimeProperty Field
Identifies the LastActiveDateTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LastActiveDateTimeProperty
Public Shared ReadOnly LastActiveDateTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LastActiveDateTime dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.SerializationIdProperty Field

DockingWindowSerializationIdProperty Field
Identifies the SerializationId dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SerializationIdProperty
Public Shared ReadOnly SerializationIdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SerializationId dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.SizeToContentModesProperty Field

DockingWindowSizeToContentModesProperty Field
Identifies the SizeToContentModes dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeToContentModesProperty
Public Shared ReadOnly SizeToContentModesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeToContentModes dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StandardMdiBoundsProperty Field

DockingWindowStandardMdiBoundsProperty Field
Identifies the StandardMdiBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardMdiBoundsProperty
Public Shared ReadOnly StandardMdiBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardMdiBounds dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StandardMdiTitleBarContextContentTemplateProperty Field

DockingWindowStandardMdiTitleBarContextContentTemplateProperty Field
Identifies the StandardMdiTitleBarContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardMdiTitleBarContextContentTemplateProperty
Public Shared ReadOnly StandardMdiTitleBarContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardMdiTitleBarContextContentTemplate dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StandardMdiWindowStateProperty Field

DockingWindowStandardMdiWindowStateProperty Field
Identifies the StandardMdiWindowState dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardMdiWindowStateProperty
Public Shared ReadOnly StandardMdiWindowStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardMdiWindowState dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.StateProperty Field

DockingWindowStateProperty Field
Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabbedMdiLayoutKindProperty Field

DockingWindowTabbedMdiLayoutKindProperty Field
Identifies the TabbedMdiLayoutKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabbedMdiLayoutKindProperty
Public Shared ReadOnly TabbedMdiLayoutKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabbedMdiLayoutKind dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabbedMdiTabContextContentTemplateProperty Field

DockingWindowTabbedMdiTabContextContentTemplateProperty Field
Identifies the TabbedMdiTabContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabbedMdiTabContextContentTemplateProperty
Public Shared ReadOnly TabbedMdiTabContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabbedMdiTabContextContentTemplate dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabFlashColorProperty Field

DockingWindowTabFlashColorProperty Field
Identifies the TabFlashColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabFlashColorProperty
Public Shared ReadOnly TabFlashColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabFlashColor dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabFlashModeProperty Field

DockingWindowTabFlashModeProperty Field
Identifies the TabFlashMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabFlashModeProperty
Public Shared ReadOnly TabFlashModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabFlashMode dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabTextProperty Field

DockingWindowTabTextProperty Field
Identifies the TabText dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabTextProperty
Public Shared ReadOnly TabTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabText dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabTextResolvedProperty Field

DockingWindowTabTextResolvedProperty Field
Identifies the TabTextResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabTextResolvedProperty
Public Shared ReadOnly TabTextResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabTextResolved dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabTintColorProperty Field

DockingWindowTabTintColorProperty Field
Identifies the TabTintColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabTintColorProperty
Public Shared ReadOnly TabTintColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabTintColor dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TabToolTipProperty Field

DockingWindowTabToolTipProperty Field
Identifies the TabToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabToolTipProperty
Public Shared ReadOnly TabToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabToolTip dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.TitleProperty Field

DockingWindowTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.UniqueIdProperty Field

DockingWindowUniqueIdProperty Field
Identifies the UniqueId dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UniqueIdProperty
Public Shared ReadOnly UniqueIdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UniqueId dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindow.WindowGroupNameProperty Field

DockingWindowWindowGroupNameProperty Field
Identifies the WindowGroupName dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WindowGroupNameProperty
Public Shared ReadOnly WindowGroupNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WindowGroupName dependency property.
See Also

Reference

DockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollection Class

DockingWindowCollection Class
Represents an observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection DockingWindow
System.Collections.ObjectModelObservableCollection DockingWindow
ActiproSoftware.UI.XamlDeferrableObservableCollection DockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollectionBase DockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowCollection : DockingWindowCollectionBase<DockingWindow>
Public Class DockingWindowCollection
    Inherits DockingWindowCollectionBase(Of DockingWindow)

The DockingWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowCollection | Initializes a new instance of the DockingWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection DockingWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Protected property | Items | (Inherited from Collection DockingWindow .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection DockingWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection DockingWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection DockingWindow .)
Public method | Clear | (Inherited from Collection DockingWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection DockingWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | (Inherited from Collection DockingWindow .)
Public method | CopyTo | (Inherited from Collection DockingWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection DockingWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | (Inherited from Collection DockingWindow .)
Public method | Insert | (Inherited from Collection DockingWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection DockingWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection DockingWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection DockingWindow .)
Public method | RemoveAt | (Inherited from Collection DockingWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection DockingWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection DockingWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection DockingWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollection Constructor

DockingWindowCollection Constructor
Initializes a new instance of the DockingWindowCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowCollection()
Public Sub New
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollection Properties

DockingWindowCollection Properties

The DockingWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection DockingWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Protected property | Items | (Inherited from Collection DockingWindow .)
Top
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollection Methods

DockingWindowCollection Methods

The DockingWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection DockingWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection DockingWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection DockingWindow .)
Public method | Clear | (Inherited from Collection DockingWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection DockingWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | (Inherited from Collection DockingWindow .)
Public method | CopyTo | (Inherited from Collection DockingWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection DockingWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | (Inherited from Collection DockingWindow .)
Public method | Insert | (Inherited from Collection DockingWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection DockingWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection DockingWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection DockingWindow .)
Public method | RemoveAt | (Inherited from Collection DockingWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection DockingWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollection Events

DockingWindowCollection Events

The DockingWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection DockingWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection DockingWindow .)
Top
See Also

Reference

DockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T) Class

DockingWindowCollectionBaseT Class
Represents the base class for an observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
System.Collections.ObjectModelObservableCollection T
ActiproSoftware.UI.XamlDeferrableObservableCollection T
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollectionBaseT
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollection
ActiproSoftware.UI.Xaml.Controls.DockingDocumentWindowCollection
ActiproSoftware.UI.Xaml.Controls.DockingToolWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowCollectionBase<T> : DeferrableObservableCollection<T>
where T : DockingWindow

Public Class DockingWindowCollectionBase(Of T As DockingWindow)
    Inherits DeferrableObservableCollection(Of T)

Type Parameters

T
The type of DockingWindow in this collection.

The DockingWindowCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowCollectionBaseT | Initializes a new instance of the DockingWindowCollectionBaseT class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection T.)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection T.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | (Inherited from Collection T.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection T.)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection T.)
Protected method | CheckReentrancy | (Inherited from ObservableCollection T.)
Public method | Clear | (Inherited from Collection T.)
Protected method | ClearItems | (Inherited from ObservableCollection T.)
Public method | Contains(T) | (Inherited from Collection T.)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | (Inherited from Collection T.)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from Collection T.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from Collection T.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection T.)
Protected method | MoveItem | (Inherited from ObservableCollection T.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection T.)
Public method | RemoveAt | (Inherited from Collection T.)
Protected method | RemoveItem | (Inherited from ObservableCollection T.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection T.)
Protected event | PropertyChanged | (Inherited from ObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T) Constructor

DockingWindowCollectionBaseT Constructor
Initializes a new instance of the DockingWindowCollectionBaseT class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowCollectionBase()
Public Sub New
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T) Properties

DockingWindowCollectionBaseT Properties

The DockingWindowCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection T .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemInt32 | (Inherited from Collection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | (Inherited from Collection T .)
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).Item Property

DockingWindowCollectionBaseTItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from Collection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).Item Property (Guid)

DockingWindowCollectionBaseTItem Property (Guid)
Gets the item with the specified UniqueId value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T this[
    Guid uniqueId
] { get; }
Public ReadOnly Property Item (
    uniqueId As Guid
) As T
    Get

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Property Value

Type: T
The item with the specified UniqueId value.
See Also

Reference

DockingWindowCollectionBaseT Class
Item Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).Item Property (String)

DockingWindowCollectionBaseTItem Property (String)
Gets the item with the specified Name value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As T
    Get

Parameters

name
Type: SystemString
The name value to locate in the collection.

Property Value

Type: T
The item with the specified Name value.
See Also

Reference

DockingWindowCollectionBaseT Class
Item Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T) Methods

DockingWindowCollectionBaseT Methods

The DockingWindowCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection T .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection T .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection T .)
Public method | Clear | (Inherited from Collection T .)
Protected method | ClearItems | (Inherited from ObservableCollection T .)
Public method | Contains(T) | (Inherited from Collection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | (Inherited from Collection T .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from Collection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Public method | Insert | (Inherited from Collection T .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection T .)
Protected method | MoveItem | (Inherited from ObservableCollection T .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection T .)
Public method | RemoveAt | (Inherited from Collection T .)
Protected method | RemoveItem | (Inherited from ObservableCollection T .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).Contains Method

DockingWindowCollectionBaseTContains Method
Overload List
 | Name | Description
Public method | Contains(T) | (Inherited from Collection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).Contains Method (Guid)

DockingWindowCollectionBaseTContains Method (Guid)
Determines whether an item with the specified UniqueId value is in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    Guid uniqueId
)
Public Function Contains (
    uniqueId As Guid
) As Boolean

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified UniqueId value is found in the collection; otherwise, false.
See Also

Reference

DockingWindowCollectionBaseT Class
Contains Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).Contains Method (String)

DockingWindowCollectionBaseTContains Method (String)
Determines whether an item with the specified Name value is in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified Name value is found in the collection; otherwise, false.
See Also

Reference

DockingWindowCollectionBaseT Class
Contains Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).IndexOf Method

DockingWindowCollectionBaseTIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | (Inherited from Collection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).IndexOf Method (Guid)

DockingWindowCollectionBaseTIndexOf Method (Guid)
Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    Guid uniqueId
)
Public Function IndexOf (
    uniqueId As Guid
) As Integer

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified UniqueId value within the entire collection, if found; otherwise, -1.
See Also

Reference

DockingWindowCollectionBaseT Class
IndexOf Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T).IndexOf Method (String)

DockingWindowCollectionBaseTIndexOf Method (String)
Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified Name value within the entire collection, if found; otherwise, -1.
See Also

Reference

DockingWindowCollectionBaseT Class
IndexOf Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowCollectionBase(T) Events

DockingWindowCollectionBaseT Events

The DockingWindowCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection T .)
Protected event | PropertyChanged | (Inherited from ObservableCollection T .)
Top
See Also

Reference

DockingWindowCollectionBaseT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Class

DockingWindowDefaultLocationEventArgs Class
Provides event arguments for DockingWindow-related default location events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowDefaultLocationEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowDefaultLocationEventArgs : DockingWindowEventArgs
Public Class DockingWindowDefaultLocationEventArgs
    Inherits DockingWindowEventArgs

The DockingWindowDefaultLocationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowDefaultLocationEventArgs | Initializes a new instance of the DockingWindowDefaultLocationEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Side | Gets or sets the optional Side to dock against the Target control.
Public property | State | Gets the DockingWindowState in which the window is requesting a default location.
Public property | Target | Gets or sets the IDockTarget against which to dock.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Constructor

DockingWindowDefaultLocationEventArgs Constructor
Initializes a new instance of the DockingWindowDefaultLocationEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowDefaultLocationEventArgs(
    DockingWindow window,
    DockingWindowState state
)
Public Sub New (
    window As DockingWindow,
    state As DockingWindowState
)

Parameters

window
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The DockingWindow that is the focus of this event.
state
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The DockingWindowState in which the window is requesting a default location.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Properties

DockingWindowDefaultLocationEventArgs Properties

The DockingWindowDefaultLocationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Side | Gets or sets the optional Side to dock against the Target control.
Public property | State | Gets the DockingWindowState in which the window is requesting a default location.
Public property | Target | Gets or sets the IDockTarget against which to dock.
Public property | Window | Gets or sets the DockingWindow that is the focus of this event. (Inherited from DockingWindowEventArgs.)
Top
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.Side Property

DockingWindowDefaultLocationEventArgsSide Property
Gets or sets the optional Side to dock against the Target control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Side> Side { get; set; }
Public Property Side As Nullable(Of Side)
    Get
    Set

Property Value

Type: Nullable Side
The optional Side to dock against the Target control.
Remarks
Specify a value to designate an "attach".
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.State Property

DockingWindowDefaultLocationEventArgsState Property
Gets the DockingWindowState in which the window is requesting a default location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowState State { get; }
Public ReadOnly Property State As DockingWindowState
    Get

Property Value

Type: DockingWindowState
The DockingWindowState in which the window is requesting a default location.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs.Target Property

DockingWindowDefaultLocationEventArgsTarget Property
Gets or sets the IDockTarget against which to dock.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDockTarget Target { get; set; }
Public Property Target As IDockTarget
    Get
    Set

Property Value

Type: IDockTarget
The IDockTarget against which to dock.
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowDefaultLocationEventArgs Methods

DockingWindowDefaultLocationEventArgs Methods

The DockingWindowDefaultLocationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowDefaultLocationEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowEventArgs Class

DockingWindowEventArgs Class
Provides event arguments for DockingWindow-related events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowDefaultLocationEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowEventArgs : CancelableEventArgs
Public Class DockingWindowEventArgs
    Inherits CancelableEventArgs

The DockingWindowEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowEventArgs | Initializes a new instance of the DockingWindowEventArgs class
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Window | Gets or sets the DockingWindow that is the focus of this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowEventArgs Constructor

DockingWindowEventArgs Constructor
Initializes a new instance of the DockingWindowEventArgs class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowEventArgs()
Public Sub New
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowEventArgs Properties

DockingWindowEventArgs Properties

The DockingWindowEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Window | Gets or sets the DockingWindow that is the focus of this event.
Top
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowEventArgs.Window Property

DockingWindowEventArgsWindow Property
Gets or sets the DockingWindow that is the focus of this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow Window { get; set; }
Public Property Window As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is the focus of this event.
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowEventArgs Methods

DockingWindowEventArgs Methods

The DockingWindowEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowItemKind Class

DockingWindowItemKind Class
Indicates the kind of container that is generated for a DockSite item.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowItemKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DockingWindowItemKind : Enum
Public NotInheritable Class DockingWindowItemKind
    Inherits Enum

The DockingWindowItemKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Document | The item is a document window.
 | Tool | The item is a tool window.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowItemKind Methods

DockingWindowItemKind Methods

The DockingWindowItemKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DockingWindowItemKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowItemKind Fields

DockingWindowItemKind Fields

The DockingWindowItemKind type exposes the following members.

Fields
 | Name | Description
 | Document | The item is a document window.
 | Tool | The item is a tool window.
Public field | value__ |
Top
See Also

Reference

DockingWindowItemKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowItemKind.Document Field

DockingWindowItemKindDocument Field
The item is a document window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowItemKind Document = 0
Public Const Document As DockingWindowItemKind = 0

Field Value

Type: DockingWindowItemKind
See Also

Reference

DockingWindowItemKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowItemKind.Tool Field

DockingWindowItemKindTool Field
The item is a tool window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowItemKind Tool = 1
Public Const Tool As DockingWindowItemKind = 1

Field Value

Type: DockingWindowItemKind
See Also

Reference

DockingWindowItemKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowItemKind.value__ Field

DockingWindowItemKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.DockingWindowItemKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DockingWindowItemKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Class

DockingWindowsAutoHidingEventArgs Class
Provides event arguments for DockingWindow auto-hiding events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsAutoHidingEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowsAutoHidingEventArgs : DockingWindowsEventArgs
Public Class DockingWindowsAutoHidingEventArgs
    Inherits DockingWindowsEventArgs

The DockingWindowsAutoHidingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowsAutoHidingEventArgs | Initializes a new instance of the DockingWindowsAutoHidingEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Side | Gets or sets the Side upon which the docking windows will be auto-hidden.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Constructor

DockingWindowsAutoHidingEventArgs Constructor
Initializes a new instance of the DockingWindowsAutoHidingEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowsAutoHidingEventArgs(
    IEnumerable<DockingWindow> windows
)
Public Sub New (
    windows As IEnumerable(Of DockingWindow)
)

Parameters

windows
Type: System.Collections.GenericIEnumerable DockingWindow
The collection of DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Properties

DockingWindowsAutoHidingEventArgs Properties

The DockingWindowsAutoHidingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Side | Gets or sets the Side upon which the docking windows will be auto-hidden.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs.Side Property

DockingWindowsAutoHidingEventArgsSide Property
Gets or sets the Side upon which the docking windows will be auto-hidden.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side Side { get; set; }
Public Property Side As Side
    Get
    Set

Property Value

Type: Side
The Side upon which the docking windows will be auto-hidden.
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsAutoHidingEventArgs Methods

DockingWindowsAutoHidingEventArgs Methods

The DockingWindowsAutoHidingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowsAutoHidingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Class

DockingWindowsDragOverEventArgs Class
Provides event arguments for when one or more docking windows are dragged over a new dock target, with support for hiding certain dock guides by altering the AllowedDockGuideKinds property.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsDragOverEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowsDragOverEventArgs : DockingWindowsEventArgs
Public Class DockingWindowsDragOverEventArgs
    Inherits DockingWindowsEventArgs

The DockingWindowsDragOverEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowsDragOverEventArgs | Initializes a new instance of the DockingWindowsDragOverEventArgs class.
Top
Properties
 | Name | Description
Public property | AllowedDockGuideKinds | Gets or sets the dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | DraggedDockHost | Gets the DockHost that is being dragged, and that contains the Windows.
Public property | SupportedDockGuideKinds | Gets the dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
Public property | Target | Gets the IDockTarget that the drag is over.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Constructor

DockingWindowsDragOverEventArgs Constructor
Initializes a new instance of the DockingWindowsDragOverEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowsDragOverEventArgs(
    DockHost draggedDockHost,
    IDockTarget target,
    DockGuideKinds supportedDockGuideKinds
)
Public Sub New (
    draggedDockHost As DockHost,
    target As IDockTarget,
    supportedDockGuideKinds As DockGuideKinds
)

Parameters

draggedDockHost
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The DockHost that is being dragged, and that contains the Windows.
target
Type: ActiproSoftware.UI.Xaml.Controls.DockingIDockTarget
The IDockTarget that the drag is over.
supportedDockGuideKinds
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockGuideKinds
The dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Properties

DockingWindowsDragOverEventArgs Properties

The DockingWindowsDragOverEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AllowedDockGuideKinds | Gets or sets the dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | DraggedDockHost | Gets the DockHost that is being dragged, and that contains the Windows.
Public property | SupportedDockGuideKinds | Gets the dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
Public property | Target | Gets the IDockTarget that the drag is over.
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event. (Inherited from DockingWindowsEventArgs.)
Top
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs.AllowedDockGuideKinds Property

DockingWindowsDragOverEventArgsAllowedDockGuideKinds Property
Gets or sets the dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideKinds AllowedDockGuideKinds { get; set; }
Public Property AllowedDockGuideKinds As DockGuideKinds
    Get
    Set

Property Value

Type: DockGuideKinds
The dock guide kinds that are allowed by this DraggedDockHost and dock Target combination.
Remarks
Remove dock guide kind flags from this property to prevent the related dock guide from showing.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs.DraggedDockHost Property

DockingWindowsDragOverEventArgsDraggedDockHost Property
Gets the DockHost that is being dragged, and that contains the Windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DraggedDockHost { get; }
Public ReadOnly Property DraggedDockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that is being dragged, and that contains the Windows.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs.SupportedDockGuideKinds Property

DockingWindowsDragOverEventArgsSupportedDockGuideKinds Property
Gets the dock guide kinds that are supported by this DraggedDockHost and dock Target combination.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideKinds SupportedDockGuideKinds { get; }
Public ReadOnly Property SupportedDockGuideKinds As DockGuideKinds
    Get

Property Value

Type: DockGuideKinds
The dock guide kinds that are supported by this DraggedDockHost and dock Target combination.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace
DockingWindowsDragOverEventArgsAllowedDockGuideKinds


DockingWindowsDragOverEventArgs.Target Property

DockingWindowsDragOverEventArgsTarget Property
Gets the IDockTarget that the drag is over.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDockTarget Target { get; }
Public ReadOnly Property Target As IDockTarget
    Get

Property Value

Type: IDockTarget
The IDockTarget that the drag is over.
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsDragOverEventArgs Methods

DockingWindowsDragOverEventArgs Methods

The DockingWindowsDragOverEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowsDragOverEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs Class

DockingWindowsEventArgs Class
Provides event arguments for DockingWindow-related events that deal with potentially muliple windows.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsAutoHidingEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsDragOverEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowsEventArgs : CancelableEventArgs
Public Class DockingWindowsEventArgs
    Inherits CancelableEventArgs

The DockingWindowsEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowsEventArgs(DockHost) | Initializes a new instance of the DockingWindowsEventArgs class.
Public method | DockingWindowsEventArgs(IEnumerableDockingWindow) | Initializes a new instance of the DockingWindowsEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs Constructor

DockingWindowsEventArgs Constructor
Overload List
 | Name | Description
Public method | DockingWindowsEventArgs(DockHost) | Initializes a new instance of the DockingWindowsEventArgs class.
Public method | DockingWindowsEventArgs(IEnumerableDockingWindow) | Initializes a new instance of the DockingWindowsEventArgs class.
Top
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs Constructor (DockHost)

DockingWindowsEventArgs Constructor (DockHost)
Initializes a new instance of the DockingWindowsEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowsEventArgs(
    DockHost dockHost
)
Public Sub New (
    dockHost As DockHost
)

Parameters

dockHost
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The DockHost containing the DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsEventArgs Class
DockingWindowsEventArgs Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs Constructor (IEnumerable(DockingWindow))

DockingWindowsEventArgs Constructor (IEnumerableDockingWindow)
Initializes a new instance of the DockingWindowsEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowsEventArgs(
    IEnumerable<DockingWindow> windows
)
Public Sub New (
    windows As IEnumerable(Of DockingWindow)
)

Parameters

windows
Type: System.Collections.GenericIEnumerable DockingWindow
The collection of DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsEventArgs Class
DockingWindowsEventArgs Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs Properties

DockingWindowsEventArgs Properties

The DockingWindowsEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Windows | Gets the collection of DockingWindow controls that are the focus of this event.
Top
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs.Windows Property

DockingWindowsEventArgsWindows Property
Gets the collection of DockingWindow controls that are the focus of this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As IEnumerable(Of DockingWindow)
    Get

Property Value

Type: IEnumerable DockingWindow
The collection of DockingWindow controls that are the focus of this event.
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowsEventArgs Methods

DockingWindowsEventArgs Methods

The DockingWindowsEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowsEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState Class

DockingWindowState Class
Indicates the state for a DockingWindow.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DockingWindowState : Enum
Public NotInheritable Class DockingWindowState
    Inherits Enum

The DockingWindowState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AutoHide | The window is auto-hidden in a container along the side of a dock host.
 | Docked | The window is docked in a container outside of the MDI (multiple document interface) area.
 | Document | The window is a document within the MDI (multiple document interface) area.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState Methods

DockingWindowState Methods

The DockingWindowState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState Fields

DockingWindowState Fields

The DockingWindowState type exposes the following members.

Fields
 | Name | Description
 | AutoHide | The window is auto-hidden in a container along the side of a dock host.
 | Docked | The window is docked in a container outside of the MDI (multiple document interface) area.
 | Document | The window is a document within the MDI (multiple document interface) area.
Public field | value__ |
Top
See Also

Reference

DockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState.AutoHide Field

DockingWindowStateAutoHide Field
The window is auto-hidden in a container along the side of a dock host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowState AutoHide = 2
Public Const AutoHide As DockingWindowState = 2

Field Value

Type: DockingWindowState
See Also

Reference

DockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState.Docked Field

DockingWindowStateDocked Field
The window is docked in a container outside of the MDI (multiple document interface) area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowState Docked = 0
Public Const Docked As DockingWindowState = 0

Field Value

Type: DockingWindowState
See Also

Reference

DockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState.Document Field

DockingWindowStateDocument Field
The window is a document within the MDI (multiple document interface) area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowState Document = 1
Public Const Document As DockingWindowState = 1

Field Value

Type: DockingWindowState
See Also

Reference

DockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockingWindowState.value__ Field

DockingWindowStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.DockingWindowState.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite Class

DockSite Class
Represents a dock site, the root control for docking window host functionality.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.DockingDockSite

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockSite : Control, IDockTarget
Public Class DockSite
    Inherits Control
    Implements IDockTarget

The DockSite type exposes the following members.

Constructors
 | Name | Description
Public method | DockSite | Initializes an instance of the DockSite class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateNextDocumentCommand | Gets the ICommand that can activate the next document.
Public property | ActivatePreviousDocumentCommand | Gets the ICommand that can activate the previous document.
Public property | ActivatePrimaryDocumentCommand | Gets the ICommand that can activate the primary document.
Public property | ActiveWindow | Gets the DockingWindow that is currently active.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreDocumentWindowsDestroyedOnClose | Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed.
Public property | AreNewTabsInsertedBeforeExistingTabs | Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container.
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.
Public property | AutoHidePerContainer | Gets or sets whether auto-hide state toggles affect all the windows in the parent ToolWindowContainer.
Public property | AutoHidePopupCloseAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup close.
Public property | AutoHidePopupOpenAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup open.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDocumentWindowsClose | Gets or sets the global setting for whether document windows can be closed.
Public property | CanDocumentWindowsDragToLinkedDockSites | Gets or sets the global setting for whether document windows may be dragged to a linked DockSite.
Public property | CanDocumentWindowsFloat | Gets or sets the global setting for whether document windows may be contained in a floating window.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanToolWindowsAttach | Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping.
Public property | CanToolWindowsAutoHide | Gets or sets the global setting for whether tool windows may be placed in auto-hide mode.
Public property | CanToolWindowsBecomeDocuments | Gets or sets the global setting for whether tool windows may be placed in a document state.
Public property | CanToolWindowsClose | Gets or sets the global setting for whether tool windows can be closed.
Public property | CanToolWindowsCloseOnMiddleClick | Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button.
Public property | CanToolWindowsDock | Gets or sets the global setting for whether tool windows can be docked.
Public property | CanToolWindowsDragToFloatingDockHostsWithWorkspaces | Gets or sets the whether tool windows may be dragged to floating dock hosts that contain a workspace.
Public property | CanToolWindowsDragToLinkedDockSites | Gets or sets the global setting for whether tool windows may be dragged to a linked DockSite.
Public property | CanToolWindowsFloat | Gets or sets the global setting for whether tool windows may be floated into separate top-level containers.
Public property | CanToolWindowTabsDrag | Gets or sets the global setting for whether tool window tabs may be dragged to another location.
Public property | CanUpdateItemsSourceOnUnregister | Gets or sets whether to try and remove an item from its items source when the related container DockingWindow is unregistered.
Public property | CascadeDocumentsCommand | Gets the ICommand that can cascade the open documents.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets or sets the FrameworkElement that is the child content of this dock site.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseAllDocumentsCommand | Gets the ICommand that can close all open documents.
Public property | ClosePerContainer | Gets or sets whether close operations affect all the windows in the parent ToolWindowContainer.
Public property | ClosePrimaryDocumentCommand | Gets the ICommand that can close the primary document.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DocumentItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each document item.
Public property | DocumentItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | DocumentItemsSource | Gets or sets a collection used to generate document windows for use in the DockSite.
Public property | DocumentItemTemplate | Gets or sets the DataTemplate used to display each document item.
Public property | DocumentItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each document item.
Public property | Documents | Gets the collection of DockingWindow controls that are currently open in the MDI area.
Public property | DocumentWindows | Gets the DocumentWindowCollection of document windows that are currently registered with the DockSite.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FloatingDockHosts | Gets the collection of floating dock hosts, which are those that are top-level and external to the DockSite hierarchy's primary dock host.
Public property | FloatingWindowIcon | Gets or sets the ImageSource for floating window icons, which should be set if document windows are allowed to float.
Public property | FloatingWindowSnapToScreenThreshold | Gets or sets the minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen.
Public property | FloatingWindowTitle | Gets or sets the title text for floating windows, which should be set if document windows are allowed to float..
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasDocuments | Gets whether the DockSite currently has any open documents.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HostedFloatingWindowContainer | Gets or sets the FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows. The FrameworkElement must be the DockSite or one of it's visual ancestors.
Public property | InactiveFloatingWindowFadeDelay | Gets or sets the duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out.
Public property | InactiveFloatingWindowFadeDuration | Gets or sets the duration in milliseconds over which an inactive hosted floating window will fade.
Public property | InactiveFloatingWindowFadeOpacity | Gets or sets the target opacity to which inactive hosted floating windows to fade.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDockGuideAnimationEnabled | Gets or sets whether dock guide animation is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFloatingWindowSnapToScreenEnabled | Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsInactiveFloatingWindowFadeEnabled | Gets or sets whether hosted floating windows will fade out following inactivity.
Public property | IsLiveSplittingEnabled | Gets or sets whether live splitting of docking windows is enabled.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LinkedDockSites | Gets the linked DockSites, to which registered docking windows can be docked into.
Public property | MagnetismGapDistance | Gets or sets the distance between windows that are snapped together via magnetism.
Public property | MagnetismSnapDistance | Gets or sets the distance at which magnetism begins to snap windows being dragged.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MdiKind | Gets or sets the kind of MDI currently in use.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryDockHost | Gets the primary dock host, which is the one that is implicitly created within the DockSite's template.
Public property | PrimaryDocument | Gets the DockingWindow that currently is the primary document in the dock site.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetMdiKindCommand | Gets the ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Switcher | Gets or sets the SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TileDocumentsHorizontallyCommand | Gets the ICommand that can tile the open documents horizontally.
Public property | TileDocumentsVerticallyCommand | Gets the ICommand that can tile the open documents vertically.
Public property | ToolItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each tool item.
Public property | ToolItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | ToolItemsSource | Gets or sets a collection used to generate tool windows for use in the DockSite.
Public property | ToolItemTemplate | Gets or sets the DataTemplate used to display each tool item.
Public property | ToolItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each tool item.
Public property | ToolWindows | Gets the ToolWindowCollection of tool windows that are currently registered with the DockSite.
Public property | ToolWindowsHaveCloseButtons | Gets or sets whether ToolWindowContainer controls can have title bar close buttons.
Public property | ToolWindowsHaveOptionsButtons | Gets or sets whether ToolWindowContainer controls can have title bar options buttons.
Public property | ToolWindowsHaveTabImages | Gets or sets the global setting for whether tool windows have images on tabs.
Public property | ToolWindowsHaveTitleBarIcons | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.
Public property | ToolWindowsHaveTitleBars | Gets or sets the global setting for whether tool windows display a title bar when not in MDI.
Public property | ToolWindowsHaveToggleAutoHideButtons | Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons.
Public property | ToolWindowsSingleTabLayoutBehavior | Gets or sets the global setting for the behavior used when a single tool window is in a container.
Public property | ToolWindowsTabOverflowBehavior | Gets or sets the global setting for the overflow behavior of the tool window tabs.
Public property | ToolWindowsTabStripPlacement | Gets or sets a Side indicating the side upon which the tool window tabs are located.
Public property | ToolWindowsTitleBarContextContentAlignment | Gets or sets the alignment of tool window container title bar context content.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDragFloatPreviews | Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | ActivateNextDocument | Activates the next document by selecting it and focusing its content.
Public method | ActivatePreviousDocument | Activates the previous document by selecting it and focusing its content.
Public method | ActivatePrimaryDocument | Activates the primary document by focusing its content.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
 | ApplyContainerStyle | Applies the style of the specified container window.
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | CascadeDocuments | Cascades all open documents, if using tabbed or standard MDI.
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DockingWindow, Object, DockingWindowItemKind) method.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | CloseAllDocuments | Closes all open documents.
Public method | ClosePrimaryDocument | Closes the primary document.
Public method | ContainerFromDocumentItem | Returns the DocumentWindow corresponding to the given item contained in DocumentItemsSource.
Public method | ContainerFromItem | Returns the DockingWindow corresponding to the given item contained in DocumentItemsSource or ToolItemsSource.
Public method | ContainerFromToolItem | Returns the ToolWindow corresponding to the given item contained in ToolItemsSource.
Public method | DockSiteRegistryConstructor | Initializes a new instance of the DockSite class.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the DockingWindow that is used to display the given item.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container.
Public method | LinkDockSite | Links this DockSite to the specified DockSite and vice versa, allowing docking windows to be seamlessly moved between the dock sites.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDocumentItemsSourceChanged | Called when the DocumentItemsSource property changes.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnFloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMdiKindChanged | Occurs when the MdiKind property is changed.
Protected method | OnMenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Protected method | OnNewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnToolItemsSourceChanged | Called when the ToolItemsSource property changes.
Protected method | OnWindowActivated | Occurs after a DockingWindow has been activated.
Protected method | OnWindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Protected method | OnWindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Protected method | OnWindowDeactivated | Occurs after a DockingWindow has been deactivated.
Protected method | OnWindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnWindowRegistered | Occurs after a DockingWindow has been registered.
Protected method | OnWindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Protected method | OnWindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Protected method | OnWindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Protected method | OnWindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Protected method | OnWindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Protected method | OnWindowsOpening | Occurs before one or more DockingWindow controls is opened.
Protected method | OnWindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Protected method | OnWindowUnregistered | Occurs after a DockingWindow has been unregistered.
Protected method | PrepareContainerForItemOverride | Prepares the specified DockingWindow to display the specified item.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | TileDocumentsHorizontally | Tiles all open documents horizontally, if using tabbed or standard MDI.
Public method | TileDocumentsVertically | Tiles all open documents vertically, if using tabbed or standard MDI.
Public method | ToHierarchyString | Creates a string that contains a textual representation of the dock site hierarchy, useful for debugging purposes.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnlinkDockSite | Unlinks this DockSite from the specified DockSite and vice versa.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MdiKindChanged | Occurs when the MdiKind property is changed.
Public event | MenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Public event | NewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | WindowActivated | Occurs after a DockingWindow has been activated.
Public event | WindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Public event | WindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Public event | WindowDeactivated | Occurs after a DockingWindow has been deactivated.
Public event | WindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | WindowRegistered | Occurs after a DockingWindow has been registered.
Public event | WindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Public event | WindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Public event | WindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Public event | WindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Public event | WindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Public event | WindowsOpening | Occurs before one or more DockingWindow controls is opened.
Public event | WindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Public event | WindowUnregistered | Occurs after a DockingWindow has been unregistered.
Top
Fields
Name | Description
ActiveWindowProperty | Identifies the ActiveWindow dependency property. This field is read-only.
AreDocumentWindowsDestroyedOnCloseProperty | Identifies the AreDocumentWindowsDestroyedOnClose dependency property. This field is read-only.
AreNewTabsInsertedBeforeExistingTabsProperty | Identifies the AreNewTabsInsertedBeforeExistingTabs dependency property. This field is read-only.
AutoHidePerContainerProperty | Identifies the AutoHidePerContainer dependency property. This field is read-only.
AutoHidePopupCloseAnimationDurationProperty | Identifies the AutoHidePopupCloseAnimationDuration dependency property. This field is read-only.
AutoHidePopupOpenAnimationDurationProperty | Identifies the AutoHidePopupOpenAnimationDuration dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
CanDocumentWindowsCloseProperty | Identifies the CanDocumentWindowsClose dependency property. This field is read-only.
CanDocumentWindowsDragToLinkedDockSitesProperty | Identifies the CanDocumentWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanDocumentWindowsFloatProperty | Identifies the CanDocumentWindowsFloat dependency property. This field is read-only.
CanToolWindowsAttachProperty | Identifies the CanToolWindowsAttach dependency property. This field is read-only.
CanToolWindowsAutoHideProperty | Identifies the CanToolWindowsAutoHide dependency property. This field is read-only.
CanToolWindowsBecomeDocumentsProperty | Identifies the CanToolWindowsBecomeDocuments dependency property. This field is read-only.
CanToolWindowsCloseOnMiddleClickProperty | Identifies the CanToolWindowsCloseOnMiddleClick dependency property. This field is read-only.
CanToolWindowsCloseProperty | Identifies the CanToolWindowsClose dependency property. This field is read-only.
CanToolWindowsDockProperty | Identifies the CanToolWindowsDock dependency property. This field is read-only.
CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty | Identifies the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property. This field is read-only.
CanToolWindowsDragToLinkedDockSitesProperty | Identifies the CanToolWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanToolWindowsFloatProperty | Identifies the CanToolWindowsFloat dependency property. This field is read-only.
CanToolWindowTabsDragProperty | Identifies the CanToolWindowTabsDrag dependency property. This field is read-only.
CanUpdateItemsSourceOnUnregisterProperty | Identifies the CanUpdateItemsSourceOnUnregister dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ClosePerContainerProperty | Identifies the ClosePerContainer dependency property. This field is read-only.
DocumentItemContainerStyleProperty | Identifies the DocumentItemContainerStyle dependency property. This field is read-only.
DocumentItemContainerStyleSelectorProperty | Identifies the DocumentItemContainerStyleSelector dependency property. This field is read-only.
DocumentItemsSourceProperty | Identifies the DocumentItemsSource dependency property. This field is read-only.
DocumentItemTemplateProperty | Identifies the DocumentItemTemplate dependency property. This field is read-only.
DocumentItemTemplateSelectorProperty | Identifies the DocumentItemTemplateSelector dependency property. This field is read-only.
FloatingWindowIconProperty | Identifies the FloatingWindowIcon dependency property. This field is read-only.
FloatingWindowSnapToScreenThresholdProperty | Identifies the FloatingWindowSnapToScreenThreshold dependency property. This field is read-only.
FloatingWindowTitleProperty | Identifies the FloatingWindowTitle dependency property. This field is read-only.
HostedFloatingWindowContainerProperty | Identifies the HostedFloatingWindowContainer dependency property. This field is read-only.
InactiveFloatingWindowFadeDelayProperty | Identifies the InactiveFloatingWindowFadeDelay dependency property. This field is read-only.
InactiveFloatingWindowFadeDurationProperty | Identifies the InactiveFloatingWindowFadeDuration dependency property. This field is read-only.
InactiveFloatingWindowFadeOpacityProperty | Identifies the InactiveFloatingWindowFadeOpacity dependency property. This field is read-only.
IsDockGuideAnimationEnabledProperty | Identifies the IsDockGuideAnimationEnabled dependency property. This field is read-only.
IsFloatingWindowSnapToScreenEnabledProperty | Identifies the IsFloatingWindowSnapToScreenEnabled dependency property. This field is read-only.
IsInactiveFloatingWindowFadeEnabledProperty | Identifies the IsInactiveFloatingWindowFadeEnabled dependency property. This field is read-only.
IsLiveSplittingEnabledProperty | Identifies the IsLiveSplittingEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
MagnetismGapDistanceProperty | Identifies the MagnetismGapDistance dependency property. This field is read-only.
MagnetismSnapDistanceProperty | Identifies the MagnetismSnapDistance dependency property. This field is read-only.
MdiKindProperty | Identifies the MdiKind dependency property. This field is read-only.
PrimaryDocumentProperty | Identifies the PrimaryDocument dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
SwitcherProperty | Identifies the Switcher dependency property. This field is read-only.
ToolItemContainerStyleProperty | Identifies the ToolItemContainerStyle dependency property. This field is read-only.
ToolItemContainerStyleSelectorProperty | Identifies the ToolItemContainerStyleSelector dependency property. This field is read-only.
ToolItemsSourceProperty | Identifies the ToolItemsSource dependency property. This field is read-only.
ToolItemTemplateProperty | Identifies the ToolItemTemplate dependency property. This field is read-only.
ToolItemTemplateSelectorProperty | Identifies the ToolItemTemplateSelector dependency property. This field is read-only.
ToolWindowsHaveCloseButtonsProperty | Identifies the ToolWindowsHaveCloseButtons dependency property. This field is read-only.
ToolWindowsHaveOptionsButtonsProperty | Identifies the ToolWindowsHaveOptionsButtons dependency property. This field is read-only.
ToolWindowsHaveTabImagesProperty | Identifies the ToolWindowsHaveTabImages dependency property. This field is read-only.
ToolWindowsHaveTitleBarIconsProperty | Identifies the ToolWindowsHaveTitleBarIcons dependency property. This field is read-only.
ToolWindowsHaveTitleBarsProperty | Identifies the ToolWindowsHaveTitleBars dependency property. This field is read-only.
ToolWindowsHaveToggleAutoHideButtonsProperty | Identifies the ToolWindowsHaveToggleAutoHideButtons dependency property. This field is read-only.
ToolWindowsSingleTabLayoutBehaviorProperty | Identifies the ToolWindowsSingleTabLayoutBehavior dependency property. This field is read-only.
ToolWindowsTabOverflowBehaviorProperty | Identifies the ToolWindowsTabOverflowBehavior dependency property. This field is read-only.
ToolWindowsTabStripPlacementProperty | Identifies the ToolWindowsTabStripPlacement dependency property. This field is read-only.
ToolWindowsTitleBarContextContentAlignmentProperty | Identifies the ToolWindowsTitleBarContextContentAlignment dependency property. This field is read-only.
UseDragFloatPreviewsProperty | Identifies the UseDragFloatPreviews dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite Constructor

DockSite Constructor
Initializes an instance of the DockSite class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite()
Public Sub New
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite Properties

DockSite Properties

The DockSite type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateNextDocumentCommand | Gets the ICommand that can activate the next document.
Public property | ActivatePreviousDocumentCommand | Gets the ICommand that can activate the previous document.
Public property | ActivatePrimaryDocumentCommand | Gets the ICommand that can activate the primary document.
Public property | ActiveWindow | Gets the DockingWindow that is currently active.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreDocumentWindowsDestroyedOnClose | Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed.
Public property | AreNewTabsInsertedBeforeExistingTabs | Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container.
Public property | AutoHideBottomContainers | Gets the collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.
Public property | AutoHideLeftContainers | Gets the collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.
Public property | AutoHidePerContainer | Gets or sets whether auto-hide state toggles affect all the windows in the parent ToolWindowContainer.
Public property | AutoHidePopupCloseAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup close.
Public property | AutoHidePopupOpenAnimationDuration | Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup open.
Public property | AutoHideRightContainers | Gets the collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.
Public property | AutoHideTabItemTemplate | Gets or sets the DataTemplate to use for rendering the auto-hide tab items.
Public property | AutoHideTabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.
Public property | AutoHideTopContainers | Gets the collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDocumentWindowsClose | Gets or sets the global setting for whether document windows can be closed.
Public property | CanDocumentWindowsDragToLinkedDockSites | Gets or sets the global setting for whether document windows may be dragged to a linked DockSite.
Public property | CanDocumentWindowsFloat | Gets or sets the global setting for whether document windows may be contained in a floating window.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanToolWindowsAttach | Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping.
Public property | CanToolWindowsAutoHide | Gets or sets the global setting for whether tool windows may be placed in auto-hide mode.
Public property | CanToolWindowsBecomeDocuments | Gets or sets the global setting for whether tool windows may be placed in a document state.
Public property | CanToolWindowsClose | Gets or sets the global setting for whether tool windows can be closed.
Public property | CanToolWindowsCloseOnMiddleClick | Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button.
Public property | CanToolWindowsDock | Gets or sets the global setting for whether tool windows can be docked.
Public property | CanToolWindowsDragToFloatingDockHostsWithWorkspaces | Gets or sets the whether tool windows may be dragged to floating dock hosts that contain a workspace.
Public property | CanToolWindowsDragToLinkedDockSites | Gets or sets the global setting for whether tool windows may be dragged to a linked DockSite.
Public property | CanToolWindowsFloat | Gets or sets the global setting for whether tool windows may be floated into separate top-level containers.
Public property | CanToolWindowTabsDrag | Gets or sets the global setting for whether tool window tabs may be dragged to another location.
Public property | CanUpdateItemsSourceOnUnregister | Gets or sets whether to try and remove an item from its items source when the related container DockingWindow is unregistered.
Public property | CascadeDocumentsCommand | Gets the ICommand that can cascade the open documents.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets or sets the FrameworkElement that is the child content of this dock site.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseAllDocumentsCommand | Gets the ICommand that can close all open documents.
Public property | ClosePerContainer | Gets or sets whether close operations affect all the windows in the parent ToolWindowContainer.
Public property | ClosePrimaryDocumentCommand | Gets the ICommand that can close the primary document.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DocumentItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each document item.
Public property | DocumentItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | DocumentItemsSource | Gets or sets a collection used to generate document windows for use in the DockSite.
Public property | DocumentItemTemplate | Gets or sets the DataTemplate used to display each document item.
Public property | DocumentItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each document item.
Public property | Documents | Gets the collection of DockingWindow controls that are currently open in the MDI area.
Public property | DocumentWindows | Gets the DocumentWindowCollection of document windows that are currently registered with the DockSite.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FloatingDockHosts | Gets the collection of floating dock hosts, which are those that are top-level and external to the DockSite hierarchy's primary dock host.
Public property | FloatingWindowIcon | Gets or sets the ImageSource for floating window icons, which should be set if document windows are allowed to float.
Public property | FloatingWindowSnapToScreenThreshold | Gets or sets the minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen.
Public property | FloatingWindowTitle | Gets or sets the title text for floating windows, which should be set if document windows are allowed to float..
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasDocuments | Gets whether the DockSite currently has any open documents.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HostedFloatingWindowContainer | Gets or sets the FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows. The FrameworkElement must be the DockSite or one of it's visual ancestors.
Public property | InactiveFloatingWindowFadeDelay | Gets or sets the duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out.
Public property | InactiveFloatingWindowFadeDuration | Gets or sets the duration in milliseconds over which an inactive hosted floating window will fade.
Public property | InactiveFloatingWindowFadeOpacity | Gets or sets the target opacity to which inactive hosted floating windows to fade.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDockGuideAnimationEnabled | Gets or sets whether dock guide animation is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFloatingWindowSnapToScreenEnabled | Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsInactiveFloatingWindowFadeEnabled | Gets or sets whether hosted floating windows will fade out following inactivity.
Public property | IsLiveSplittingEnabled | Gets or sets whether live splitting of docking windows is enabled.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LinkedDockSites | Gets the linked DockSites, to which registered docking windows can be docked into.
Public property | MagnetismGapDistance | Gets or sets the distance between windows that are snapped together via magnetism.
Public property | MagnetismSnapDistance | Gets or sets the distance at which magnetism begins to snap windows being dragged.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MdiKind | Gets or sets the kind of MDI currently in use.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryDockHost | Gets the primary dock host, which is the one that is implicitly created within the DockSite's template.
Public property | PrimaryDocument | Gets the DockingWindow that currently is the primary document in the dock site.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetMdiKindCommand | Gets the ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.
Public property | SplitterSize | Gets or sets the size of splitters.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Switcher | Gets or sets the SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TileDocumentsHorizontallyCommand | Gets the ICommand that can tile the open documents horizontally.
Public property | TileDocumentsVerticallyCommand | Gets the ICommand that can tile the open documents vertically.
Public property | ToolItemContainerStyle | Gets or sets the Style that is applied to the container DockingWindow generated for each tool item.
Public property | ToolItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.
Public property | ToolItemsSource | Gets or sets a collection used to generate tool windows for use in the DockSite.
Public property | ToolItemTemplate | Gets or sets the DataTemplate used to display each tool item.
Public property | ToolItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each tool item.
Public property | ToolWindows | Gets the ToolWindowCollection of tool windows that are currently registered with the DockSite.
Public property | ToolWindowsHaveCloseButtons | Gets or sets whether ToolWindowContainer controls can have title bar close buttons.
Public property | ToolWindowsHaveOptionsButtons | Gets or sets whether ToolWindowContainer controls can have title bar options buttons.
Public property | ToolWindowsHaveTabImages | Gets or sets the global setting for whether tool windows have images on tabs.
Public property | ToolWindowsHaveTitleBarIcons | Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.
Public property | ToolWindowsHaveTitleBars | Gets or sets the global setting for whether tool windows display a title bar when not in MDI.
Public property | ToolWindowsHaveToggleAutoHideButtons | Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons.
Public property | ToolWindowsSingleTabLayoutBehavior | Gets or sets the global setting for the behavior used when a single tool window is in a container.
Public property | ToolWindowsTabOverflowBehavior | Gets or sets the global setting for the overflow behavior of the tool window tabs.
Public property | ToolWindowsTabStripPlacement | Gets or sets a Side indicating the side upon which the tool window tabs are located.
Public property | ToolWindowsTitleBarContextContentAlignment | Gets or sets the alignment of tool window container title bar context content.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDragFloatPreviews | Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActivateNextDocumentCommand Property

DockSiteActivateNextDocumentCommand Property
Gets the ICommand that can activate the next document.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ActivateNextDocumentCommand { get; }
Public ReadOnly Property ActivateNextDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can activate the next document.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActivatePreviousDocumentCommand Property

DockSiteActivatePreviousDocumentCommand Property
Gets the ICommand that can activate the previous document.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ActivatePreviousDocumentCommand { get; }
Public ReadOnly Property ActivatePreviousDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can activate the previous document.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActivatePrimaryDocumentCommand Property

DockSiteActivatePrimaryDocumentCommand Property
Gets the ICommand that can activate the primary document.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ActivatePrimaryDocumentCommand { get; }
Public ReadOnly Property ActivatePrimaryDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can activate the primary document.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActiveWindow Property

DockSiteActiveWindow Property
Gets the DockingWindow that is currently active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow ActiveWindow { get; }
Public ReadOnly Property ActiveWindow As DockingWindow
    Get

Property Value

Type: DockingWindow
The DockingWindow that is currently active.
Remarks
Only one docking window can be active at any given time.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AreDocumentWindowsDestroyedOnClose Property

DockSiteAreDocumentWindowsDestroyedOnClose Property
Gets or sets whether document windows are automatically destroyed (removed from the DockSite) when closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreDocumentWindowsDestroyedOnClose { get; set; }
Public Property AreDocumentWindowsDestroyedOnClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows are automatically destroyed (removed from the DockSite) when closed; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AreNewTabsInsertedBeforeExistingTabs Property

DockSiteAreNewTabsInsertedBeforeExistingTabs Property
Gets or sets whether new tabs are inserted before existing tabs when they are added, such as when dragging and attaching a tool window to an existing tool window container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreNewTabsInsertedBeforeExistingTabs { get; set; }
Public Property AreNewTabsInsertedBeforeExistingTabs As Boolean
    Get
    Set

Property Value

Type: Boolean
true if new tabs are inserted before existing tabs when they are added; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideBottomContainers Property

DockSiteAutoHideBottomContainers Property
Gets the collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideBottomContainers { get; }
Public ReadOnly Property AutoHideBottomContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary bottom auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideLeftContainers Property

DockSiteAutoHideLeftContainers Property
Gets the collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideLeftContainers { get; }
Public ReadOnly Property AutoHideLeftContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary left auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHidePerContainer Property

DockSiteAutoHidePerContainer Property
Gets or sets whether auto-hide state toggles affect all the windows in the parent ToolWindowContainer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AutoHidePerContainer { get; set; }
Public Property AutoHidePerContainer As Boolean
    Get
    Set

Property Value

Type: Boolean
true if auto-hide state toggles affect all the windows in the parent ToolWindowContainer; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHidePopupCloseAnimationDuration Property

DockSiteAutoHidePopupCloseAnimationDuration Property
Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AutoHidePopupCloseAnimationDuration { get; set; }
Public Property AutoHidePopupCloseAnimationDuration As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of the animation that is applied to an auto-hide popup close. The default value is 150ms.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHidePopupOpenAnimationDuration Property

DockSiteAutoHidePopupOpenAnimationDuration Property
Gets or sets the duration in milliseconds of the animation that is applied to an auto-hide popup open.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AutoHidePopupOpenAnimationDuration { get; set; }
Public Property AutoHidePopupOpenAnimationDuration As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of the animation that is applied to an auto-hide popup open. The default value is 150ms.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideRightContainers Property

DockSiteAutoHideRightContainers Property
Gets the collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideRightContainers { get; }
Public ReadOnly Property AutoHideRightContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary right auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplate Property

DockSiteAutoHideTabItemTemplate Property
Gets or sets the DataTemplate to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate AutoHideTabItemTemplate { get; set; }
Public Property AutoHideTabItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the auto-hide tab items.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplateSelector Property

DockSiteAutoHideTabItemTemplateSelector Property
Gets or sets the DataTemplateSelector to use for rendering the auto-hide tab items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector AutoHideTabItemTemplateSelector { get; set; }
Public Property AutoHideTabItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for rendering the auto-hide tab items.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideTopContainers Property

DockSiteAutoHideTopContainers Property
Gets the collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection AutoHideTopContainers { get; }
Public ReadOnly Property AutoHideTopContainers As ToolWindowContainerCollection
    Get

Property Value

Type: ToolWindowContainerCollection
The collection of ToolWindowContainer items that appear in the primary top auto-hide tabstrip.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanDocumentWindowsClose Property

DockSiteCanDocumentWindowsClose Property
Gets or sets the global setting for whether document windows can be closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentWindowsClose { get; set; }
Public Property CanDocumentWindowsClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows can be closed; otherwise, false. The default value is true.
Remarks
This setting only affects document windows whose CanClose property is set to . Any other setting on the document window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanDocumentWindowsDragToLinkedDockSites Property

DockSiteCanDocumentWindowsDragToLinkedDockSites Property
Gets or sets the global setting for whether document windows may be dragged to a linked DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentWindowsDragToLinkedDockSites { get; set; }
Public Property CanDocumentWindowsDragToLinkedDockSites As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows may be dragged to a linked DockSite; otherwise, false. The default value is true.
Remarks
This setting only affects document windows whose CanDragToLinkedDockSites property is set to . Any other setting on the document window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanDocumentWindowsFloat Property

DockSiteCanDocumentWindowsFloat Property
Gets or sets the global setting for whether document windows may be contained in a floating window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentWindowsFloat { get; set; }
Public Property CanDocumentWindowsFloat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document windows may be contained in a floating window; otherwise, false. The default value is false.
Remarks
This setting only affects document windows whose CanFloat property is set to . Any other setting on the document window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsAttach Property

DockSiteCanToolWindowsAttach Property
Gets or sets the global setting for whether tool windows may be attached to another tool window, creating a tabbed grouping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsAttach { get; set; }
Public Property CanToolWindowsAttach As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be attached to another tool window; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanAttach property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsAutoHide Property

DockSiteCanToolWindowsAutoHide Property
Gets or sets the global setting for whether tool windows may be placed in auto-hide mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsAutoHide { get; set; }
Public Property CanToolWindowsAutoHide As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be placed in auto-hide mode; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanAutoHide property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsBecomeDocuments Property

DockSiteCanToolWindowsBecomeDocuments Property
Gets or sets the global setting for whether tool windows may be placed in a document state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsBecomeDocuments { get; set; }
Public Property CanToolWindowsBecomeDocuments As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be placed in a document state; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanBecomeDocument property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsClose Property

DockSiteCanToolWindowsClose Property
Gets or sets the global setting for whether tool windows can be closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsClose { get; set; }
Public Property CanToolWindowsClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows can be closed; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanClose property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsCloseOnMiddleClick Property

DockSiteCanToolWindowsCloseOnMiddleClick Property
Gets or sets a value indicating whether tool windows can be closed by clicking the tab with the middle mouse button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsCloseOnMiddleClick { get; set; }
Public Property CanToolWindowsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows can be closed by clicking the tab with the middle mouse button; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsDock Property

DockSiteCanToolWindowsDock Property
Gets or sets the global setting for whether tool windows can be docked.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsDock { get; set; }
Public Property CanToolWindowsDock As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows can be docked; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanDock property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspaces Property

DockSiteCanToolWindowsDragToFloatingDockHostsWithWorkspaces Property
Gets or sets the whether tool windows may be dragged to floating dock hosts that contain a workspace.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsDragToFloatingDockHostsWithWorkspaces { get; set; }
Public Property CanToolWindowsDragToFloatingDockHostsWithWorkspaces As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be dragged to floating dock hosts that contain a workspace; otherwise, false. The default value is true.
Remarks
When false, tool windows can still be dragged and docked against floating dock hosts that only contain tool windows.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsDragToLinkedDockSites Property

DockSiteCanToolWindowsDragToLinkedDockSites Property
Gets or sets the global setting for whether tool windows may be dragged to a linked DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsDragToLinkedDockSites { get; set; }
Public Property CanToolWindowsDragToLinkedDockSites As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be dragged to a linked DockSite; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanDragToLinkedDockSites property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsFloat Property

DockSiteCanToolWindowsFloat Property
Gets or sets the global setting for whether tool windows may be floated into separate top-level containers.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowsFloat { get; set; }
Public Property CanToolWindowsFloat As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows may be floated into separate top-level containers; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanFloat property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowTabsDrag Property

DockSiteCanToolWindowTabsDrag Property
Gets or sets the global setting for whether tool window tabs may be dragged to another location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanToolWindowTabsDrag { get; set; }
Public Property CanToolWindowTabsDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool window tabs may be dragged to another location; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose CanDragTab property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanUpdateItemsSourceOnUnregister Property

DockSiteCanUpdateItemsSourceOnUnregister Property
Gets or sets whether to try and remove an item from its items source when the related container DockingWindow is unregistered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanUpdateItemsSourceOnUnregister { get; set; }
Public Property CanUpdateItemsSourceOnUnregister As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item should try to be removed; otherwise, false. The default value is true.
Remarks
This feature is only active when using the DocumentItemsSource or ToolItemsSource properties, and the functionality only works if the items source implements IList and is not read-only. Otherwise, the WindowUnregistered event should be monitored and the items source updated manually.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CascadeDocumentsCommand Property

DockSiteCascadeDocumentsCommand Property
Gets the ICommand that can cascade the open documents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CascadeDocumentsCommand { get; }
Public ReadOnly Property CascadeDocumentsCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can cascade the open documents.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.Child Property

DockSiteChild Property
Gets or sets the FrameworkElement that is the child content of this dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement that is the child content of this dock site.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CloseAllDocumentsCommand Property

DockSiteCloseAllDocumentsCommand Property
Gets the ICommand that can close all open documents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CloseAllDocumentsCommand { get; }
Public ReadOnly Property CloseAllDocumentsCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close all open documents.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ClosePerContainer Property

DockSiteClosePerContainer Property
Gets or sets whether close operations affect all the windows in the parent ToolWindowContainer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ClosePerContainer { get; set; }
Public Property ClosePerContainer As Boolean
    Get
    Set

Property Value

Type: Boolean
true if close operations affect all the windows in the parent ToolWindowContainer; otherwise, false. The default value is false.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ClosePrimaryDocumentCommand Property

DockSiteClosePrimaryDocumentCommand Property
Gets the ICommand that can close the primary document.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClosePrimaryDocumentCommand { get; }
Public ReadOnly Property ClosePrimaryDocumentCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the primary document.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemContainerStyle Property

DockSiteDocumentItemContainerStyle Property
Gets or sets the Style that is applied to the container DockingWindow generated for each document item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style DocumentItemContainerStyle { get; set; }
Public Property DocumentItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the container DockingWindow generated for each document item. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemContainerStyleSelector Property

DockSiteDocumentItemContainerStyleSelector Property
Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StyleSelector DocumentItemContainerStyleSelector { get; set; }
Public Property DocumentItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the style to use as the DocumentItemContainerStyle. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemsSource Property

DockSiteDocumentItemsSource Property
Gets or sets a collection used to generate document windows for use in the DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable DocumentItemsSource { get; set; }
Public Property DocumentItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection that is used to generate generate document windows for use in the DockSite. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemTemplate Property

DockSiteDocumentItemTemplate Property
Gets or sets the DataTemplate used to display each document item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DocumentItemTemplate { get; set; }
Public Property DocumentItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the data objects. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemTemplateSelector Property

DockSiteDocumentItemTemplateSelector Property
Gets or sets the custom logic for choosing a template used to display each document item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector DocumentItemTemplateSelector { get; set; }
Public Property DocumentItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.Documents Property

DockSiteDocuments Property
Gets the collection of DockingWindow controls that are currently open in the MDI area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowCollection Documents { get; }
Public ReadOnly Property Documents As ReadOnlyDockingWindowCollection
    Get

Property Value

Type: ReadOnlyDockingWindowCollection
The collection of DockingWindow controls that are currently open in the MDI area.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentWindows Property

DockSiteDocumentWindows Property
Gets the DocumentWindowCollection of document windows that are currently registered with the DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindowCollection DocumentWindows { get; }
Public ReadOnly Property DocumentWindows As DocumentWindowCollection
    Get

Property Value

Type: DocumentWindowCollection
The DocumentWindowCollection of document windows that are currently registered with the DockSite.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingDockHosts Property

DockSiteFloatingDockHosts Property
Gets the collection of floating dock hosts, which are those that are top-level and external to the DockSite hierarchy's primary dock host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<DockHost> FloatingDockHosts { get; }
Public ReadOnly Property FloatingDockHosts As ReadOnlyObservableCollection(Of DockHost)
    Get

Property Value

Type: ReadOnlyObservableCollection DockHost
The collection of floating dock hosts.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowIcon Property

DockSiteFloatingWindowIcon Property
Gets or sets the ImageSource for floating window icons, which should be set if document windows are allowed to float.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImageSource FloatingWindowIcon { get; set; }
Public Property FloatingWindowIcon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The ImageSource for floating window icons.
Remarks
The value is generally the same as your application icon.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowSnapToScreenThreshold Property

DockSiteFloatingWindowSnapToScreenThreshold Property
Gets or sets the minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double FloatingWindowSnapToScreenThreshold { get; set; }
Public Property FloatingWindowSnapToScreenThreshold As Double
    Get
    Set

Property Value

Type: Double
The minimum length of a floating window that must be visible over a screen's edge to avoid snap-to-screen. The default value is 70.0.
Remarks
This feature is only used when the IsFloatingWindowSnapToScreenEnabled property is true. If a floating window is completely beyond the screen edge, it will be fully snapped back onto the screen. If a floating window is only partially beyond the screen edge, but the visible portion is less than this property's value, it will be snapped partially back onto the screen.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowTitle Property

DockSiteFloatingWindowTitle Property
Gets or sets the title text for floating windows, which should be set if document windows are allowed to float..

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FloatingWindowTitle { get; set; }
Public Property FloatingWindowTitle As String
    Get
    Set

Property Value

Type: String
The title text for floating windows.
Remarks
The value is generally the same as your application name.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.HasDocuments Property

DockSiteHasDocuments Property
Gets whether the DockSite currently has any open documents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDocuments { get; }
Public ReadOnly Property HasDocuments As Boolean
    Get

Return Value

Type: Boolean
true if the DockSite currently has any open documents; otherwise, false.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.HostedFloatingWindowContainer Property

DockSiteHostedFloatingWindowContainer Property
Gets or sets the FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows. The FrameworkElement must be the DockSite or one of it's visual ancestors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement HostedFloatingWindowContainer { get; set; }
Public Property HostedFloatingWindowContainer As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement whose bounds should be used to restrict the movement of hosted floating windows; otherwise which indicates to use the DockSite itself.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDelay Property

DockSiteInactiveFloatingWindowFadeDelay Property
Gets or sets the duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double InactiveFloatingWindowFadeDelay { get; set; }
Public Property InactiveFloatingWindowFadeDelay As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds of inactivity that must take place for a hosted floating window before it starts to fade out. The default value is 20 seconds.
Remarks
The IsInactiveFloatingWindowFadeEnabled property must be set to true for this property to be used.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDuration Property

DockSiteInactiveFloatingWindowFadeDuration Property
Gets or sets the duration in milliseconds over which an inactive hosted floating window will fade.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double InactiveFloatingWindowFadeDuration { get; set; }
Public Property InactiveFloatingWindowFadeDuration As Double
    Get
    Set

Property Value

Type: Double
The duration in milliseconds over which an inactive hosted floating window will fade. The default value is 20 seconds.
Remarks
The IsInactiveFloatingWindowFadeEnabled property must be set to true for this property to be used.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeOpacity Property

DockSiteInactiveFloatingWindowFadeOpacity Property
Gets or sets the target opacity to which inactive hosted floating windows to fade.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double InactiveFloatingWindowFadeOpacity { get; set; }
Public Property InactiveFloatingWindowFadeOpacity As Double
    Get
    Set

Property Value

Type: Double
The target opacity to which inactive hosted floating windows to fade. The default value is 0.25 (25% opacity).
Remarks
The IsInactiveFloatingWindowFadeEnabled property must be set to true for this property to be used.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsDockGuideAnimationEnabled Property

DockSiteIsDockGuideAnimationEnabled Property
Gets or sets whether dock guide animation is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDockGuideAnimationEnabled { get; set; }
Public Property IsDockGuideAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if dock guide animation is enabled; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsFloatingWindowSnapToScreenEnabled Property

DockSiteIsFloatingWindowSnapToScreenEnabled Property
Gets or sets whether floating windows are snapped onto the closest screen when displayed via a method other than being dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsFloatingWindowSnapToScreenEnabled { get; set; }
Public Property IsFloatingWindowSnapToScreenEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if floating windows are snapped onto the closest screen when displayed via a method other than being dragged; otherwise, false. The default value is true.
Remarks
This feature ensures that floating windows are fully visible on-screen when being programmatically displayed, such as when a layout is loaded.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsInactiveFloatingWindowFadeEnabled Property

DockSiteIsInactiveFloatingWindowFadeEnabled Property
Gets or sets whether hosted floating windows will fade out following inactivity.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsInactiveFloatingWindowFadeEnabled { get; set; }
Public Property IsInactiveFloatingWindowFadeEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if hosted floating windows will fade out following inactivity; otherwise, false. The default value is true.
Remarks
This option only applied when hosted floating windows are in use.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsLiveSplittingEnabled Property

DockSiteIsLiveSplittingEnabled Property
Gets or sets whether live splitting of docking windows is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLiveSplittingEnabled { get; set; }
Public Property IsLiveSplittingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if live splitting of docking windows is enabled; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsTabLayoutAnimationEnabled Property

DockSiteIsTabLayoutAnimationEnabled Property
Gets or sets whether animation effects are applied during tab layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabLayoutAnimationEnabled { get; set; }
Public Property IsTabLayoutAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects are applied during tab layout, such as when tabs are added or removed; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.LinkedDockSites Property

DockSiteLinkedDockSites Property
Gets the linked DockSites, to which registered docking windows can be docked into.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<DockSite> LinkedDockSites { get; }
Public ReadOnly Property LinkedDockSites As IEnumerable(Of DockSite)
    Get

Property Value

Type: IEnumerable DockSite
The linked DockSites, to which registered docking windows can be docked into.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MagnetismGapDistance Property

DockSiteMagnetismGapDistance Property
Gets or sets the distance between windows that are snapped together via magnetism.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MagnetismGapDistance { get; set; }
Public Property MagnetismGapDistance As Double
    Get
    Set

Property Value

Type: Double
The distance between windows that are snapped together via magnetism. The default value is 1.
Remarks
If this value is greater than 0, there will be a gap between windows that are snapped together when magnetism is enabled by the MagnetismSnapDistance property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MagnetismSnapDistance Property

DockSiteMagnetismSnapDistance Property
Gets or sets the distance at which magnetism begins to snap windows being dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MagnetismSnapDistance { get; set; }
Public Property MagnetismSnapDistance As Double
    Get
    Set

Property Value

Type: Double
The distance at which magnetism begins to snap windows being dragged. The default value is 5.
Remarks
If this value is greater than 0, magnetism is enabled. Set it to 0 to disable magnetism. Magnetism tries to snap corners of a window being dragged to other window corners around it. Increase this property's value to increase the range over which the magnetism will work. Magnetism also takes effect when resizing via window borders.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MdiKind Property

DockSiteMdiKind Property
Gets or sets the kind of MDI currently in use.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MdiKind MdiKind { get; set; }
Public Property MdiKind As MdiKind
    Get
    Set

Property Value

Type: MdiKind
A MdiKind indicating the kind of MDI currently in use. The default value is None.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.PrimaryDockHost Property

DockSitePrimaryDockHost Property
Gets the primary dock host, which is the one that is implicitly created within the DockSite's template.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost PrimaryDockHost { get; }
Public ReadOnly Property PrimaryDockHost As DockHost
    Get

Property Value

Type: DockHost
The primary dock host.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.PrimaryDocument Property

DockSitePrimaryDocument Property
Gets the DockingWindow that currently is the primary document in the dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow PrimaryDocument { get; }
Public ReadOnly Property PrimaryDocument As DockingWindow
    Get

Property Value

Type: DockingWindow
The DockingWindow that currently is the primary document in the dock site.
Remarks
The primary document is the same as ActiveWindow if the active window is a document. When the ActiveWindow is not a document, then the primary document is the open document that was last activated.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.SetMdiKindCommand Property

DockSiteSetMdiKindCommand Property
Gets the ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SetMdiKindCommand { get; }
Public ReadOnly Property SetMdiKindCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can set the MDI kind to the MdiKind enumeration value specified in the command parameter.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.SplitterSize Property

DockSiteSplitterSize Property
Gets or sets the size of splitters.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SplitterSize { get; set; }
Public Property SplitterSize As Double
    Get
    Set

Property Value

Type: Double
The size of splitters. The default value is 5.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.Switcher Property

DockSiteSwitcher Property
Gets or sets the SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SwitcherBase Switcher { get; set; }
Public Property Switcher As SwitcherBase
    Get
    Set

Property Value

Type: SwitcherBase
The SwitcherBase that will be used to provide Ctrl+Tab window switching capabilities.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.TileDocumentsHorizontallyCommand Property

DockSiteTileDocumentsHorizontallyCommand Property
Gets the ICommand that can tile the open documents horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand TileDocumentsHorizontallyCommand { get; }
Public ReadOnly Property TileDocumentsHorizontallyCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can tile the open documents horizontally.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.TileDocumentsVerticallyCommand Property

DockSiteTileDocumentsVerticallyCommand Property
Gets the ICommand that can tile the open documents vertically.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand TileDocumentsVerticallyCommand { get; }
Public ReadOnly Property TileDocumentsVerticallyCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can tile the open documents vertically.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemContainerStyle Property

DockSiteToolItemContainerStyle Property
Gets or sets the Style that is applied to the container DockingWindow generated for each tool item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ToolItemContainerStyle { get; set; }
Public Property ToolItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that is applied to the container DockingWindow generated for each tool item. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemContainerStyleSelector Property

DockSiteToolItemContainerStyleSelector Property
Gets or sets custom style-selection logic for a style that can be applied to each generated container DockingWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StyleSelector ToolItemContainerStyleSelector { get; set; }
Public Property ToolItemContainerStyleSelector As StyleSelector
    Get
    Set

Property Value

Type: StyleSelector
A StyleSelector object that contains logic that chooses the style to use as the ToolItemContainerStyle. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemsSource Property

DockSiteToolItemsSource Property
Gets or sets a collection used to generate tool windows for use in the DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable ToolItemsSource { get; set; }
Public Property ToolItemsSource As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
A collection that is used to generate generate tool windows for use in the DockSite. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemTemplate Property

DockSiteToolItemTemplate Property
Gets or sets the DataTemplate used to display each tool item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ToolItemTemplate { get; set; }
Public Property ToolItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that specifies the visualization of the data objects. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemTemplateSelector Property

DockSiteToolItemTemplateSelector Property
Gets or sets the custom logic for choosing a template used to display each tool item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector ToolItemTemplateSelector { get; set; }
Public Property ToolItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
A custom DataTemplateSelector object that provides logic and returns a DataTemplate. The default value is .
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindows Property

DockSiteToolWindows Property
Gets the ToolWindowCollection of tool windows that are currently registered with the DockSite.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowCollection ToolWindows { get; }
Public ReadOnly Property ToolWindows As ToolWindowCollection
    Get

Property Value

Type: ToolWindowCollection
The ToolWindowCollection of tool windows that are currently registered with the DockSite.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveCloseButtons Property

DockSiteToolWindowsHaveCloseButtons Property
Gets or sets whether ToolWindowContainer controls can have title bar close buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveCloseButtons { get; set; }
Public Property ToolWindowsHaveCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ToolWindowContainer controls can have title bar close buttons; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveOptionsButtons Property

DockSiteToolWindowsHaveOptionsButtons Property
Gets or sets whether ToolWindowContainer controls can have title bar options buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveOptionsButtons { get; set; }
Public Property ToolWindowsHaveOptionsButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ToolWindowContainer controls can have title bar options buttons; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveTabImages Property

DockSiteToolWindowsHaveTabImages Property
Gets or sets the global setting for whether tool windows have images on tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveTabImages { get; set; }
Public Property ToolWindowsHaveTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows have images on tabs; otherwise, false. The default value is false.
Remarks
This setting does not affect tabbed MDI, since TabbedMdiHost has its own HasTabImages property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBarIcons Property

DockSiteToolWindowsHaveTitleBarIcons Property
Gets or sets the global setting for whether tool window title bars display the icon of the selected tool window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveTitleBarIcons { get; set; }
Public Property ToolWindowsHaveTitleBarIcons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool window title bars display the icon of the selected tool window; otherwise, false. The default value is false.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBars Property

DockSiteToolWindowsHaveTitleBars Property
Gets or sets the global setting for whether tool windows display a title bar when not in MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveTitleBars { get; set; }
Public Property ToolWindowsHaveTitleBars As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tool windows display a title bar when not in MDI; otherwise, false. The default value is true.
Remarks
This setting only affects tool windows whose HasTitleBar property is set to . Any other setting on the tool window instance overrides this global setting.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveToggleAutoHideButtons Property

DockSiteToolWindowsHaveToggleAutoHideButtons Property
Gets or sets whether ToolWindowContainer controls can have title bar toggle auto-hide buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ToolWindowsHaveToggleAutoHideButtons { get; set; }
Public Property ToolWindowsHaveToggleAutoHideButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if ToolWindowContainer controls can have title bar toggle auto-hide buttons; otherwise, false. The default value is true.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsSingleTabLayoutBehavior Property

DockSiteToolWindowsSingleTabLayoutBehavior Property
Gets or sets the global setting for the behavior used when a single tool window is in a container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SingleTabLayoutBehavior ToolWindowsSingleTabLayoutBehavior { get; set; }
Public Property ToolWindowsSingleTabLayoutBehavior As SingleTabLayoutBehavior
    Get
    Set

Property Value

Type: SingleTabLayoutBehavior
The behavior used when a single tool window is in a container. The default value is SingleTabLayoutBehavior.Hide.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsTabOverflowBehavior Property

DockSiteToolWindowsTabOverflowBehavior Property
Gets or sets the global setting for the overflow behavior of the tool window tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabOverflowBehavior ToolWindowsTabOverflowBehavior { get; set; }
Public Property ToolWindowsTabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The overflow behavior of the tool window tabs. The default value is TabOverflowBehavior.Shrink.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsTabStripPlacement Property

DockSiteToolWindowsTabStripPlacement Property
Gets or sets a Side indicating the side upon which the tool window tabs are located.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side ToolWindowsTabStripPlacement { get; set; }
Public Property ToolWindowsTabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
A Side indicating the side upon which the tool window tabs are located. The default value is Bottom.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsTitleBarContextContentAlignment Property

DockSiteToolWindowsTitleBarContextContentAlignment Property
Gets or sets the alignment of tool window container title bar context content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContextContentAlignment ToolWindowsTitleBarContextContentAlignment { get; set; }
Public Property ToolWindowsTitleBarContextContentAlignment As ContextContentAlignment
    Get
    Set

Property Value

Type: ContextContentAlignment
The alignment of tool window container title bar context content. The default value is Far.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.UseDragFloatPreviews Property

DockSiteUseDragFloatPreviews Property
Gets or sets whether to use float previews when dragging windows instead of instantly creating floating windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool UseDragFloatPreviews { get; set; }
Public Property UseDragFloatPreviews As Boolean
    Get
    Set

Property Value

Type: Boolean
true if float previews should be used when dragging windows instead of instantly creating floating windows; otherwise, false. The default value is false.
Remarks
This property should be set to true when docking window content contains a large number of elements that may not measure/arrange quickly. When this property is true, fewer layout cycles occur since a float preview is used to show where the floating window will be created instead of instantly moving the dragged windows into a floating window.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite Methods

DockSite Methods

The DockSite type exposes the following members.

Methods
 | Name | Description
Public method | ActivateNextDocument | Activates the next document by selecting it and focusing its content.
Public method | ActivatePreviousDocument | Activates the previous document by selecting it and focusing its content.
Public method | ActivatePrimaryDocument | Activates the primary document by focusing its content.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
 | ApplyContainerStyle | Applies the style of the specified container window.
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | CascadeDocuments | Cascades all open documents, if using tabbed or standard MDI.
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DockingWindow, Object, DockingWindowItemKind) method.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | CloseAllDocuments | Closes all open documents.
Public method | ClosePrimaryDocument | Closes the primary document.
Public method | ContainerFromDocumentItem | Returns the DocumentWindow corresponding to the given item contained in DocumentItemsSource.
Public method | ContainerFromItem | Returns the DockingWindow corresponding to the given item contained in DocumentItemsSource or ToolItemsSource.
Public method | ContainerFromToolItem | Returns the ToolWindow corresponding to the given item contained in ToolItemsSource.
Public method | DockSiteRegistryConstructor | Initializes a new instance of the DockSite class.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the DockingWindow that is used to display the given item.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container.
Public method | LinkDockSite | Links this DockSite to the specified DockSite and vice versa, allowing docking windows to be seamlessly moved between the dock sites.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDocumentItemsSourceChanged | Called when the DocumentItemsSource property changes.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnFloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMdiKindChanged | Occurs when the MdiKind property is changed.
Protected method | OnMenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Protected method | OnNewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnToolItemsSourceChanged | Called when the ToolItemsSource property changes.
Protected method | OnWindowActivated | Occurs after a DockingWindow has been activated.
Protected method | OnWindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Protected method | OnWindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Protected method | OnWindowDeactivated | Occurs after a DockingWindow has been deactivated.
Protected method | OnWindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Protected method | OnWindowRegistered | Occurs after a DockingWindow has been registered.
Protected method | OnWindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Protected method | OnWindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Protected method | OnWindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Protected method | OnWindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Protected method | OnWindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Protected method | OnWindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Protected method | OnWindowsOpening | Occurs before one or more DockingWindow controls is opened.
Protected method | OnWindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Protected method | OnWindowUnregistered | Occurs after a DockingWindow has been unregistered.
Protected method | PrepareContainerForItemOverride | Prepares the specified DockingWindow to display the specified item.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | TileDocumentsHorizontally | Tiles all open documents horizontally, if using tabbed or standard MDI.
Public method | TileDocumentsVertically | Tiles all open documents vertically, if using tabbed or standard MDI.
Public method | ToHierarchyString | Creates a string that contains a textual representation of the dock site hierarchy, useful for debugging purposes.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnlinkDockSite | Unlinks this DockSite from the specified DockSite and vice versa.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActivateNextDocument Method

DockSiteActivateNextDocument Method
Activates the next document by selecting it and focusing its content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ActivateNextDocument()
Public Sub ActivateNextDocument
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActivatePreviousDocument Method

DockSiteActivatePreviousDocument Method
Activates the previous document by selecting it and focusing its content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ActivatePreviousDocument()
Public Sub ActivatePreviousDocument
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActivatePrimaryDocument Method

DockSiteActivatePrimaryDocument Method
Activates the primary document by focusing its content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ActivatePrimaryDocument()
Public Sub ActivatePrimaryDocument
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ApplyContainerStyle Method

DockSiteApplyContainerStyle Method
Applies the style of the specified container window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void ApplyContainerStyle(
    Object item,
    DockingWindow container,
    StyleSelector styleSelector,
    Style style
)
Public Shared Sub ApplyContainerStyle (
    item As Object,
    container As DockingWindow,
    styleSelector As StyleSelector,
    style As Style
)

Parameters

item
Type: SystemObject
The data item.
container
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The container window whose style should be set.
styleSelector
Type: Windows.UI.Xaml.ControlsStyleSelector
The option style selector.
style
Type: Windows.UI.XamlStyle
The desired specific style.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CascadeDocuments Method

DockSiteCascadeDocuments Method
Cascades all open documents, if using tabbed or standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CascadeDocuments()
Public Sub CascadeDocuments
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ClearContainerForItemOverride Method

DockSiteClearContainerForItemOverride Method
When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DockingWindow, Object, DockingWindowItemKind) method.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void ClearContainerForItemOverride(
    DockingWindow container,
    Object item,
    DockingWindowItemKind kind
)
Protected Overridable Sub ClearContainerForItemOverride (
    container As DockingWindow,
    item As Object,
    kind As DockingWindowItemKind
)

Parameters

container
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The container DockingWindow.
item
Type: SystemObject
The item.
kind
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowItemKind
The kind of the item.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CloseAllDocuments Method

DockSiteCloseAllDocuments Method
Closes all open documents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CloseAllDocuments()
Public Function CloseAllDocuments As Boolean

Return Value

Type: Boolean
true if all open documents were closed; otherwise, false.
Remarks
Only documents that are closable are closed.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ClosePrimaryDocument Method

DockSiteClosePrimaryDocument Method
Closes the primary document.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ClosePrimaryDocument()
Public Function ClosePrimaryDocument As Boolean

Return Value

Type: Boolean
true if the primary document was closed; otherwise, false.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ContainerFromDocumentItem Method

DockSiteContainerFromDocumentItem Method
Returns the DocumentWindow corresponding to the given item contained in DocumentItemsSource.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindow ContainerFromDocumentItem(
    Object item
)
Public Function ContainerFromDocumentItem (
    item As Object
) As DocumentWindow

Parameters

item
Type: SystemObject
The Object item to find the DocumentWindow for.

Return Value

Type: DocumentWindow
A DocumentWindow that corresponds to the given item; otherwise, indicates the item does not belong to the item collection.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ContainerFromItem Method

DockSiteContainerFromItem Method
Returns the DockingWindow corresponding to the given item contained in DocumentItemsSource or ToolItemsSource.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow ContainerFromItem(
    Object item
)
Public Function ContainerFromItem (
    item As Object
) As DockingWindow

Parameters

item
Type: SystemObject
The Object item to find the DockingWindow for.

Return Value

Type: DockingWindow
A DockingWindow that corresponds to the given item; otherwise, indicates the item does not belong to either item collection.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ContainerFromToolItem Method

DockSiteContainerFromToolItem Method
Returns the ToolWindow corresponding to the given item contained in ToolItemsSource.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow ContainerFromToolItem(
    Object item
)
Public Function ContainerFromToolItem (
    item As Object
) As ToolWindow

Parameters

item
Type: SystemObject
The Object item to find the ToolWindow for.

Return Value

Type: ToolWindow
A ToolWindow that corresponds to the given item; otherwise, indicates the item does not belong to the item collection.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DockSiteRegistryConstructor Method

DockSiteDockSiteRegistryConstructor Method
Initializes a new instance of the DockSite class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void DockSiteRegistryConstructor()
Public Sub DockSiteRegistryConstructor
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.GetContainerForItemOverride Method

DockSiteGetContainerForItemOverride Method
Creates or identifies the DockingWindow that is used to display the given item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DockingWindow GetContainerForItemOverride(
    DockingWindowItemKind kind
)
Protected Overridable Function GetContainerForItemOverride (
    kind As DockingWindowItemKind
) As DockingWindow

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowItemKind
The kind of the item.

Return Value

Type: DockingWindow
The DockingWindow that is used to display the given item.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsItemItsOwnContainerOverride Method

DockSiteIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsItemItsOwnContainerOverride(
    Object item,
    DockingWindowItemKind kind
)
Protected Overridable Function IsItemItsOwnContainerOverride (
    item As Object,
    kind As DockingWindowItemKind
) As Boolean

Parameters

item
Type: SystemObject
The item to check.
kind
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowItemKind
The kind of the item.

Return Value

Type: Boolean
true if the item is (or is eligible to be) its own container; otherwise, false.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.LinkDockSite Method

DockSiteLinkDockSite Method
Links this DockSite to the specified DockSite and vice versa, allowing docking windows to be seamlessly moved between the dock sites.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void LinkDockSite(
    DockSite dockSite
)
Public Sub LinkDockSite (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The DockSite to link.
Remarks
This method will completely link this DockSite to the specified DockSite. There is no need to call LinkDockSite(DockSite) on both DockSites.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnApplyTemplate Method

DockSiteOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnCreateAutomationPeer Method

DockSiteOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnDocumentItemsSourceChanged Method

DockSiteOnDocumentItemsSourceChanged Method
Called when the DocumentItemsSource property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnDocumentItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the DocumentItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the DocumentItemsSource property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnFloatingWindowOpening Method

DockSiteOnFloatingWindowOpening Method
Occurs when a floating window is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnFloatingWindowOpening(
    FloatingWindowOpeningEventArgs e
)
Protected Overridable Sub OnFloatingWindowOpening (
    e As FloatingWindowOpeningEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingFloatingWindowOpeningEventArgs
The FloatingWindowOpeningEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnMdiKindChanged Method

DockSiteOnMdiKindChanged Method
Occurs when the MdiKind property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnMdiKindChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnMdiKindChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnMenuOpening Method

DockSiteOnMenuOpening Method
Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnMenuOpening(
    DockingMenuEventArgs e
)
Protected Overridable Sub OnMenuOpening (
    e As DockingMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuEventArgs
The DockingMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnNewWindowRequested Method

DockSiteOnNewWindowRequested Method
Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnNewWindowRequested(
    RoutedEventArgs e
)
Protected Overridable Sub OnNewWindowRequested (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnPrimaryDocumentChanged Method

DockSiteOnPrimaryDocumentChanged Method
Occurs when the PrimaryDocument property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPrimaryDocumentChanged(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnPrimaryDocumentChanged (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnToolItemsSourceChanged Method

DockSiteOnToolItemsSourceChanged Method
Called when the ToolItemsSource property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnToolItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnToolItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the ToolItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the ToolItemsSource property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowActivated Method

DockSiteOnWindowActivated Method
Occurs after a DockingWindow has been activated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowActivated(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowActivated (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowAutoHidePopupClosed Method

DockSiteOnWindowAutoHidePopupClosed Method
Occurs after an auto-hide popup has been closed that displayed a ToolWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowAutoHidePopupClosed(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowAutoHidePopupClosed (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowAutoHidePopupOpened Method

DockSiteOnWindowAutoHidePopupOpened Method
Occurs after an auto-hide popup has been opened that displays a ToolWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowAutoHidePopupOpened(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowAutoHidePopupOpened (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowDeactivated Method

DockSiteOnWindowDeactivated Method
Occurs after a DockingWindow has been deactivated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowDeactivated(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowDeactivated (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowDefaultLocationRequested Method

DockSiteOnWindowDefaultLocationRequested Method
Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowDefaultLocationRequested(
    DockingWindowDefaultLocationEventArgs e
)
Protected Overridable Sub OnWindowDefaultLocationRequested (
    e As DockingWindowDefaultLocationEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowDefaultLocationEventArgs
The DockingWindowDefaultLocationEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowRegistered Method

DockSiteOnWindowRegistered Method
Occurs after a DockingWindow has been registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowRegistered(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowRegistered (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsAutoHiding Method

DockSiteOnWindowsAutoHiding Method
Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsAutoHiding(
    DockingWindowsAutoHidingEventArgs e
)
Protected Overridable Sub OnWindowsAutoHiding (
    e As DockingWindowsAutoHidingEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsAutoHidingEventArgs
The DockingWindowsAutoHidingEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsClosed Method

DockSiteOnWindowsClosed Method
Occurs after one or more DockingWindow controls have been closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsClosed(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsClosed (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsClosing Method

DockSiteOnWindowsClosing Method
Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsClosing(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsClosing (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsDragged Method

DockSiteOnWindowsDragged Method
Occurs after one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDragged(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsDragged (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsDragging Method

DockSiteOnWindowsDragging Method
Occurs before one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDragging(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsDragging (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsDragOver Method

DockSiteOnWindowsDragOver Method
Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsDragOver(
    DockingWindowsDragOverEventArgs e
)
Protected Overridable Sub OnWindowsDragOver (
    e As DockingWindowsDragOverEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsDragOverEventArgs
The DockingWindowsDragOverEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsOpened Method

DockSiteOnWindowsOpened Method
Occurs after one or more DockingWindow controls have been opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsOpened(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsOpened (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsOpening Method

DockSiteOnWindowsOpening Method
Occurs before one or more DockingWindow controls is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsOpening(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsOpening (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowsStateChanged Method

DockSiteOnWindowsStateChanged Method
Occurs after one or more DockingWindow controls' states have changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsStateChanged(
    DockingWindowsEventArgs e
)
Protected Overridable Sub OnWindowsStateChanged (
    e As DockingWindowsEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowsEventArgs
The DockingWindowsEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.OnWindowUnregistered Method

DockSiteOnWindowUnregistered Method
Occurs after a DockingWindow has been unregistered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowUnregistered(
    DockingWindowEventArgs e
)
Protected Overridable Sub OnWindowUnregistered (
    e As DockingWindowEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowEventArgs
The DockingWindowEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.PrepareContainerForItemOverride Method

DockSitePrepareContainerForItemOverride Method
Prepares the specified DockingWindow to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void PrepareContainerForItemOverride(
    DockingWindow container,
    Object item,
    DockingWindowItemKind kind
)
Protected Overridable Sub PrepareContainerForItemOverride (
    container As DockingWindow,
    item As Object,
    kind As DockingWindowItemKind
)

Parameters

container
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The DockingWindow used to display the specified item.
item
Type: SystemObject
The item.
kind
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowItemKind
The kind of the item.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.TileDocumentsHorizontally Method

DockSiteTileDocumentsHorizontally Method
Tiles all open documents horizontally, if using tabbed or standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileDocumentsHorizontally()
Public Sub TileDocumentsHorizontally
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.TileDocumentsVertically Method

DockSiteTileDocumentsVertically Method
Tiles all open documents vertically, if using tabbed or standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileDocumentsVertically()
Public Sub TileDocumentsVertically
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToHierarchyString Method

DockSiteToHierarchyString Method
Creates a string that contains a textual representation of the dock site hierarchy, useful for debugging purposes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ToHierarchyString()
Public Function ToHierarchyString As String

Return Value

Type: String
The string that was created.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.UnlinkDockSite Method

DockSiteUnlinkDockSite Method
Unlinks this DockSite from the specified DockSite and vice versa.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void UnlinkDockSite(
    DockSite dockSite
)
Public Sub UnlinkDockSite (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The DockSite to unlink.
Remarks
This method will completely unlink this DockSite from the specified DockSite. There is no need to call UnlinkDockSite(DockSite) on both DockSites.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite Events

DockSite Events

The DockSite type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FloatingWindowOpening | Occurs when a floating window is opening, allowing for customization before it is displayed.
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MdiKindChanged | Occurs when the MdiKind property is changed.
Public event | MenuOpening | Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.
Public event | NewWindowRequested | Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryDocumentChanged | Occurs when the PrimaryDocument property has changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | WindowActivated | Occurs after a DockingWindow has been activated.
Public event | WindowAutoHidePopupClosed | Occurs after an auto-hide popup has been closed that displayed a ToolWindow.
Public event | WindowAutoHidePopupOpened | Occurs after an auto-hide popup has been opened that displays a ToolWindow.
Public event | WindowDeactivated | Occurs after a DockingWindow has been deactivated.
Public event | WindowDefaultLocationRequested | Occurs when a DockingWindow's default location is requested.
Public event | WindowRegistered | Occurs after a DockingWindow has been registered.
Public event | WindowsAutoHiding | Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.
Public event | WindowsClosed | Occurs after one or more DockingWindow controls have been closed.
Public event | WindowsClosing | Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.
Public event | WindowsDragged | Occurs after one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragging | Occurs before one or more DockingWindow controls are dragged by the end user.
Public event | WindowsDragOver | Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.
Public event | WindowsOpened | Occurs after one or more DockingWindow controls have been opened.
Public event | WindowsOpening | Occurs before one or more DockingWindow controls is opened.
Public event | WindowsStateChanged | Occurs after one or more DockingWindow controls' states have changed.
Public event | WindowUnregistered | Occurs after a DockingWindow has been unregistered.
Top
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowOpening Event

DockSiteFloatingWindowOpening Event
Occurs when a floating window is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<FloatingWindowOpeningEventArgs> FloatingWindowOpening
Public Event FloatingWindowOpening As EventHandler(Of FloatingWindowOpeningEventArgs)

Value

Type: SystemEventHandler FloatingWindowOpeningEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MdiKindChanged Event

DockSiteMdiKindChanged Event
Occurs when the MdiKind property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler MdiKindChanged
Public Event MdiKindChanged As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MenuOpening Event

DockSiteMenuOpening Event
Occurs when a docking-related context menu is opening, allowing for customization before it is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingMenuEventArgs> MenuOpening
Public Event MenuOpening As EventHandler(Of DockingMenuEventArgs)

Value

Type: SystemEventHandler DockingMenuEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.NewWindowRequested Event

DockSiteNewWindowRequested Event
Occurs when a new DockingWindow is requested, generally via a user click on a new tab button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler NewWindowRequested
Public Event NewWindowRequested As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.PrimaryDocumentChanged Event

DockSitePrimaryDocumentChanged Event
Occurs when the PrimaryDocument property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> PrimaryDocumentChanged
Public Event PrimaryDocumentChanged As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowActivated Event

DockSiteWindowActivated Event
Occurs after a DockingWindow has been activated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowActivated
Public Event WindowActivated As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowAutoHidePopupClosed Event

DockSiteWindowAutoHidePopupClosed Event
Occurs after an auto-hide popup has been closed that displayed a ToolWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowAutoHidePopupClosed
Public Event WindowAutoHidePopupClosed As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowAutoHidePopupOpened Event

DockSiteWindowAutoHidePopupOpened Event
Occurs after an auto-hide popup has been opened that displays a ToolWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowAutoHidePopupOpened
Public Event WindowAutoHidePopupOpened As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowDeactivated Event

DockSiteWindowDeactivated Event
Occurs after a DockingWindow has been deactivated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowDeactivated
Public Event WindowDeactivated As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowDefaultLocationRequested Event

DockSiteWindowDefaultLocationRequested Event
Occurs when a DockingWindow's default location is requested.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowDefaultLocationEventArgs> WindowDefaultLocationRequested
Public Event WindowDefaultLocationRequested As EventHandler(Of DockingWindowDefaultLocationEventArgs)

Value

Type: SystemEventHandler DockingWindowDefaultLocationEventArgs
Remarks
The handler should examine the event arguments and set the Target and/or Side properties as appropriate.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowRegistered Event

DockSiteWindowRegistered Event
Occurs after a DockingWindow has been registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowRegistered
Public Event WindowRegistered As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsAutoHiding Event

DockSiteWindowsAutoHiding Event
Occurs before one or more DockingWindow controls are auto-hidden, allowing for side customization.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsAutoHidingEventArgs> WindowsAutoHiding
Public Event WindowsAutoHiding As EventHandler(Of DockingWindowsAutoHidingEventArgs)

Value

Type: SystemEventHandler DockingWindowsAutoHidingEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsClosed Event

DockSiteWindowsClosed Event
Occurs after one or more DockingWindow controls have been closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsClosed
Public Event WindowsClosed As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsClosing Event

DockSiteWindowsClosing Event
Occurs before one or more DockingWindow controls are closed, allowing for cancellation of the close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsClosing
Public Event WindowsClosing As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsDragged Event

DockSiteWindowsDragged Event
Occurs after one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsDragged
Public Event WindowsDragged As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsDragging Event

DockSiteWindowsDragging Event
Occurs before one or more DockingWindow controls are dragged by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsDragging
Public Event WindowsDragging As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsDragOver Event

DockSiteWindowsDragOver Event
Occurs when one or more docking windows are dragged over a new dock target, allowing for certain dock guides to be hidden.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsDragOverEventArgs> WindowsDragOver
Public Event WindowsDragOver As EventHandler(Of DockingWindowsDragOverEventArgs)

Value

Type: SystemEventHandler DockingWindowsDragOverEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsOpened Event

DockSiteWindowsOpened Event
Occurs after one or more DockingWindow controls have been opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsOpened
Public Event WindowsOpened As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsOpening Event

DockSiteWindowsOpening Event
Occurs before one or more DockingWindow controls is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsOpening
Public Event WindowsOpening As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowsStateChanged Event

DockSiteWindowsStateChanged Event
Occurs after one or more DockingWindow controls' states have changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowsEventArgs> WindowsStateChanged
Public Event WindowsStateChanged As EventHandler(Of DockingWindowsEventArgs)

Value

Type: SystemEventHandler DockingWindowsEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.WindowUnregistered Event

DockSiteWindowUnregistered Event
Occurs after a DockingWindow has been unregistered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> WindowUnregistered
Public Event WindowUnregistered As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite Fields

DockSite Fields

The DockSite type exposes the following members.

Fields
Name | Description
ActiveWindowProperty | Identifies the ActiveWindow dependency property. This field is read-only.
AreDocumentWindowsDestroyedOnCloseProperty | Identifies the AreDocumentWindowsDestroyedOnClose dependency property. This field is read-only.
AreNewTabsInsertedBeforeExistingTabsProperty | Identifies the AreNewTabsInsertedBeforeExistingTabs dependency property. This field is read-only.
AutoHidePerContainerProperty | Identifies the AutoHidePerContainer dependency property. This field is read-only.
AutoHidePopupCloseAnimationDurationProperty | Identifies the AutoHidePopupCloseAnimationDuration dependency property. This field is read-only.
AutoHidePopupOpenAnimationDurationProperty | Identifies the AutoHidePopupOpenAnimationDuration dependency property. This field is read-only.
AutoHideTabItemTemplateProperty | Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.
AutoHideTabItemTemplateSelectorProperty | Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.
CanDocumentWindowsCloseProperty | Identifies the CanDocumentWindowsClose dependency property. This field is read-only.
CanDocumentWindowsDragToLinkedDockSitesProperty | Identifies the CanDocumentWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanDocumentWindowsFloatProperty | Identifies the CanDocumentWindowsFloat dependency property. This field is read-only.
CanToolWindowsAttachProperty | Identifies the CanToolWindowsAttach dependency property. This field is read-only.
CanToolWindowsAutoHideProperty | Identifies the CanToolWindowsAutoHide dependency property. This field is read-only.
CanToolWindowsBecomeDocumentsProperty | Identifies the CanToolWindowsBecomeDocuments dependency property. This field is read-only.
CanToolWindowsCloseOnMiddleClickProperty | Identifies the CanToolWindowsCloseOnMiddleClick dependency property. This field is read-only.
CanToolWindowsCloseProperty | Identifies the CanToolWindowsClose dependency property. This field is read-only.
CanToolWindowsDockProperty | Identifies the CanToolWindowsDock dependency property. This field is read-only.
CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty | Identifies the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property. This field is read-only.
CanToolWindowsDragToLinkedDockSitesProperty | Identifies the CanToolWindowsDragToLinkedDockSites dependency property. This field is read-only.
CanToolWindowsFloatProperty | Identifies the CanToolWindowsFloat dependency property. This field is read-only.
CanToolWindowTabsDragProperty | Identifies the CanToolWindowTabsDrag dependency property. This field is read-only.
CanUpdateItemsSourceOnUnregisterProperty | Identifies the CanUpdateItemsSourceOnUnregister dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ClosePerContainerProperty | Identifies the ClosePerContainer dependency property. This field is read-only.
DocumentItemContainerStyleProperty | Identifies the DocumentItemContainerStyle dependency property. This field is read-only.
DocumentItemContainerStyleSelectorProperty | Identifies the DocumentItemContainerStyleSelector dependency property. This field is read-only.
DocumentItemsSourceProperty | Identifies the DocumentItemsSource dependency property. This field is read-only.
DocumentItemTemplateProperty | Identifies the DocumentItemTemplate dependency property. This field is read-only.
DocumentItemTemplateSelectorProperty | Identifies the DocumentItemTemplateSelector dependency property. This field is read-only.
FloatingWindowIconProperty | Identifies the FloatingWindowIcon dependency property. This field is read-only.
FloatingWindowSnapToScreenThresholdProperty | Identifies the FloatingWindowSnapToScreenThreshold dependency property. This field is read-only.
FloatingWindowTitleProperty | Identifies the FloatingWindowTitle dependency property. This field is read-only.
HostedFloatingWindowContainerProperty | Identifies the HostedFloatingWindowContainer dependency property. This field is read-only.
InactiveFloatingWindowFadeDelayProperty | Identifies the InactiveFloatingWindowFadeDelay dependency property. This field is read-only.
InactiveFloatingWindowFadeDurationProperty | Identifies the InactiveFloatingWindowFadeDuration dependency property. This field is read-only.
InactiveFloatingWindowFadeOpacityProperty | Identifies the InactiveFloatingWindowFadeOpacity dependency property. This field is read-only.
IsDockGuideAnimationEnabledProperty | Identifies the IsDockGuideAnimationEnabled dependency property. This field is read-only.
IsFloatingWindowSnapToScreenEnabledProperty | Identifies the IsFloatingWindowSnapToScreenEnabled dependency property. This field is read-only.
IsInactiveFloatingWindowFadeEnabledProperty | Identifies the IsInactiveFloatingWindowFadeEnabled dependency property. This field is read-only.
IsLiveSplittingEnabledProperty | Identifies the IsLiveSplittingEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
MagnetismGapDistanceProperty | Identifies the MagnetismGapDistance dependency property. This field is read-only.
MagnetismSnapDistanceProperty | Identifies the MagnetismSnapDistance dependency property. This field is read-only.
MdiKindProperty | Identifies the MdiKind dependency property. This field is read-only.
PrimaryDocumentProperty | Identifies the PrimaryDocument dependency property. This field is read-only.
SplitterSizeProperty | Identifies the SplitterSize dependency property. This field is read-only.
SwitcherProperty | Identifies the Switcher dependency property. This field is read-only.
ToolItemContainerStyleProperty | Identifies the ToolItemContainerStyle dependency property. This field is read-only.
ToolItemContainerStyleSelectorProperty | Identifies the ToolItemContainerStyleSelector dependency property. This field is read-only.
ToolItemsSourceProperty | Identifies the ToolItemsSource dependency property. This field is read-only.
ToolItemTemplateProperty | Identifies the ToolItemTemplate dependency property. This field is read-only.
ToolItemTemplateSelectorProperty | Identifies the ToolItemTemplateSelector dependency property. This field is read-only.
ToolWindowsHaveCloseButtonsProperty | Identifies the ToolWindowsHaveCloseButtons dependency property. This field is read-only.
ToolWindowsHaveOptionsButtonsProperty | Identifies the ToolWindowsHaveOptionsButtons dependency property. This field is read-only.
ToolWindowsHaveTabImagesProperty | Identifies the ToolWindowsHaveTabImages dependency property. This field is read-only.
ToolWindowsHaveTitleBarIconsProperty | Identifies the ToolWindowsHaveTitleBarIcons dependency property. This field is read-only.
ToolWindowsHaveTitleBarsProperty | Identifies the ToolWindowsHaveTitleBars dependency property. This field is read-only.
ToolWindowsHaveToggleAutoHideButtonsProperty | Identifies the ToolWindowsHaveToggleAutoHideButtons dependency property. This field is read-only.
ToolWindowsSingleTabLayoutBehaviorProperty | Identifies the ToolWindowsSingleTabLayoutBehavior dependency property. This field is read-only.
ToolWindowsTabOverflowBehaviorProperty | Identifies the ToolWindowsTabOverflowBehavior dependency property. This field is read-only.
ToolWindowsTabStripPlacementProperty | Identifies the ToolWindowsTabStripPlacement dependency property. This field is read-only.
ToolWindowsTitleBarContextContentAlignmentProperty | Identifies the ToolWindowsTitleBarContextContentAlignment dependency property. This field is read-only.
UseDragFloatPreviewsProperty | Identifies the UseDragFloatPreviews dependency property. This field is read-only.
Top
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ActiveWindowProperty Field

DockSiteActiveWindowProperty Field
Identifies the ActiveWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveWindowProperty
Public Shared ReadOnly ActiveWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveWindow dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AreDocumentWindowsDestroyedOnCloseProperty Field

DockSiteAreDocumentWindowsDestroyedOnCloseProperty Field
Identifies the AreDocumentWindowsDestroyedOnClose dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreDocumentWindowsDestroyedOnCloseProperty
Public Shared ReadOnly AreDocumentWindowsDestroyedOnCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreDocumentWindowsDestroyedOnClose dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AreNewTabsInsertedBeforeExistingTabsProperty Field

DockSiteAreNewTabsInsertedBeforeExistingTabsProperty Field
Identifies the AreNewTabsInsertedBeforeExistingTabs dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreNewTabsInsertedBeforeExistingTabsProperty
Public Shared ReadOnly AreNewTabsInsertedBeforeExistingTabsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreNewTabsInsertedBeforeExistingTabs dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHidePerContainerProperty Field

DockSiteAutoHidePerContainerProperty Field
Identifies the AutoHidePerContainer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePerContainerProperty
Public Shared ReadOnly AutoHidePerContainerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePerContainer dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHidePopupCloseAnimationDurationProperty Field

DockSiteAutoHidePopupCloseAnimationDurationProperty Field
Identifies the AutoHidePopupCloseAnimationDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupCloseAnimationDurationProperty
Public Shared ReadOnly AutoHidePopupCloseAnimationDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupCloseAnimationDuration dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHidePopupOpenAnimationDurationProperty Field

DockSiteAutoHidePopupOpenAnimationDurationProperty Field
Identifies the AutoHidePopupOpenAnimationDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHidePopupOpenAnimationDurationProperty
Public Shared ReadOnly AutoHidePopupOpenAnimationDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHidePopupOpenAnimationDuration dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplateProperty Field

DockSiteAutoHideTabItemTemplateProperty Field
Identifies the AutoHideTabItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateProperty
Public Shared ReadOnly AutoHideTabItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplate dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.AutoHideTabItemTemplateSelectorProperty Field

DockSiteAutoHideTabItemTemplateSelectorProperty Field
Identifies the AutoHideTabItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabItemTemplateSelectorProperty
Public Shared ReadOnly AutoHideTabItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabItemTemplateSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanDocumentWindowsCloseProperty Field

DockSiteCanDocumentWindowsCloseProperty Field
Identifies the CanDocumentWindowsClose dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentWindowsCloseProperty
Public Shared ReadOnly CanDocumentWindowsCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentWindowsClose dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanDocumentWindowsDragToLinkedDockSitesProperty Field

DockSiteCanDocumentWindowsDragToLinkedDockSitesProperty Field
Identifies the CanDocumentWindowsDragToLinkedDockSites dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentWindowsDragToLinkedDockSitesProperty
Public Shared ReadOnly CanDocumentWindowsDragToLinkedDockSitesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentWindowsDragToLinkedDockSites dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanDocumentWindowsFloatProperty Field

DockSiteCanDocumentWindowsFloatProperty Field
Identifies the CanDocumentWindowsFloat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentWindowsFloatProperty
Public Shared ReadOnly CanDocumentWindowsFloatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentWindowsFloat dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsAttachProperty Field

DockSiteCanToolWindowsAttachProperty Field
Identifies the CanToolWindowsAttach dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsAttachProperty
Public Shared ReadOnly CanToolWindowsAttachProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsAttach dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsAutoHideProperty Field

DockSiteCanToolWindowsAutoHideProperty Field
Identifies the CanToolWindowsAutoHide dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsAutoHideProperty
Public Shared ReadOnly CanToolWindowsAutoHideProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsAutoHide dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsBecomeDocumentsProperty Field

DockSiteCanToolWindowsBecomeDocumentsProperty Field
Identifies the CanToolWindowsBecomeDocuments dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsBecomeDocumentsProperty
Public Shared ReadOnly CanToolWindowsBecomeDocumentsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsBecomeDocuments dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsCloseOnMiddleClickProperty Field

DockSiteCanToolWindowsCloseOnMiddleClickProperty Field
Identifies the CanToolWindowsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsCloseOnMiddleClickProperty
Public Shared ReadOnly CanToolWindowsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsCloseOnMiddleClick dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsCloseProperty Field

DockSiteCanToolWindowsCloseProperty Field
Identifies the CanToolWindowsClose dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsCloseProperty
Public Shared ReadOnly CanToolWindowsCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsClose dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsDockProperty Field

DockSiteCanToolWindowsDockProperty Field
Identifies the CanToolWindowsDock dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsDockProperty
Public Shared ReadOnly CanToolWindowsDockProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsDock dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty Field

DockSiteCanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty Field
Identifies the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty
Public Shared ReadOnly CanToolWindowsDragToFloatingDockHostsWithWorkspacesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsDragToFloatingDockHostsWithWorkspaces dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsDragToLinkedDockSitesProperty Field

DockSiteCanToolWindowsDragToLinkedDockSitesProperty Field
Identifies the CanToolWindowsDragToLinkedDockSites dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsDragToLinkedDockSitesProperty
Public Shared ReadOnly CanToolWindowsDragToLinkedDockSitesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsDragToLinkedDockSites dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowsFloatProperty Field

DockSiteCanToolWindowsFloatProperty Field
Identifies the CanToolWindowsFloat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowsFloatProperty
Public Shared ReadOnly CanToolWindowsFloatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowsFloat dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanToolWindowTabsDragProperty Field

DockSiteCanToolWindowTabsDragProperty Field
Identifies the CanToolWindowTabsDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToolWindowTabsDragProperty
Public Shared ReadOnly CanToolWindowTabsDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToolWindowTabsDrag dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.CanUpdateItemsSourceOnUnregisterProperty Field

DockSiteCanUpdateItemsSourceOnUnregisterProperty Field
Identifies the CanUpdateItemsSourceOnUnregister dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanUpdateItemsSourceOnUnregisterProperty
Public Shared ReadOnly CanUpdateItemsSourceOnUnregisterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanUpdateItemsSourceOnUnregister dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ChildProperty Field

DockSiteChildProperty Field
Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ClosePerContainerProperty Field

DockSiteClosePerContainerProperty Field
Identifies the ClosePerContainer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClosePerContainerProperty
Public Shared ReadOnly ClosePerContainerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClosePerContainer dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemContainerStyleProperty Field

DockSiteDocumentItemContainerStyleProperty Field
Identifies the DocumentItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemContainerStyleProperty
Public Shared ReadOnly DocumentItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemContainerStyle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemContainerStyleSelectorProperty Field

DockSiteDocumentItemContainerStyleSelectorProperty Field
Identifies the DocumentItemContainerStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemContainerStyleSelectorProperty
Public Shared ReadOnly DocumentItemContainerStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemContainerStyleSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemsSourceProperty Field

DockSiteDocumentItemsSourceProperty Field
Identifies the DocumentItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemsSourceProperty
Public Shared ReadOnly DocumentItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemsSource dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemTemplateProperty Field

DockSiteDocumentItemTemplateProperty Field
Identifies the DocumentItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemTemplateProperty
Public Shared ReadOnly DocumentItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemTemplate dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.DocumentItemTemplateSelectorProperty Field

DockSiteDocumentItemTemplateSelectorProperty Field
Identifies the DocumentItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentItemTemplateSelectorProperty
Public Shared ReadOnly DocumentItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DocumentItemTemplateSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowIconProperty Field

DockSiteFloatingWindowIconProperty Field
Identifies the FloatingWindowIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowIconProperty
Public Shared ReadOnly FloatingWindowIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowIcon dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowSnapToScreenThresholdProperty Field

DockSiteFloatingWindowSnapToScreenThresholdProperty Field
Identifies the FloatingWindowSnapToScreenThreshold dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowSnapToScreenThresholdProperty
Public Shared ReadOnly FloatingWindowSnapToScreenThresholdProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowSnapToScreenThreshold dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.FloatingWindowTitleProperty Field

DockSiteFloatingWindowTitleProperty Field
Identifies the FloatingWindowTitle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FloatingWindowTitleProperty
Public Shared ReadOnly FloatingWindowTitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FloatingWindowTitle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.HostedFloatingWindowContainerProperty Field

DockSiteHostedFloatingWindowContainerProperty Field
Identifies the HostedFloatingWindowContainer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HostedFloatingWindowContainerProperty
Public Shared ReadOnly HostedFloatingWindowContainerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HostedFloatingWindowContainer dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDelayProperty Field

DockSiteInactiveFloatingWindowFadeDelayProperty Field
Identifies the InactiveFloatingWindowFadeDelay dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InactiveFloatingWindowFadeDelayProperty
Public Shared ReadOnly InactiveFloatingWindowFadeDelayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InactiveFloatingWindowFadeDelay dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeDurationProperty Field

DockSiteInactiveFloatingWindowFadeDurationProperty Field
Identifies the InactiveFloatingWindowFadeDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InactiveFloatingWindowFadeDurationProperty
Public Shared ReadOnly InactiveFloatingWindowFadeDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InactiveFloatingWindowFadeDuration dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.InactiveFloatingWindowFadeOpacityProperty Field

DockSiteInactiveFloatingWindowFadeOpacityProperty Field
Identifies the InactiveFloatingWindowFadeOpacity dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InactiveFloatingWindowFadeOpacityProperty
Public Shared ReadOnly InactiveFloatingWindowFadeOpacityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InactiveFloatingWindowFadeOpacity dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsDockGuideAnimationEnabledProperty Field

DockSiteIsDockGuideAnimationEnabledProperty Field
Identifies the IsDockGuideAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDockGuideAnimationEnabledProperty
Public Shared ReadOnly IsDockGuideAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDockGuideAnimationEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsFloatingWindowSnapToScreenEnabledProperty Field

DockSiteIsFloatingWindowSnapToScreenEnabledProperty Field
Identifies the IsFloatingWindowSnapToScreenEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFloatingWindowSnapToScreenEnabledProperty
Public Shared ReadOnly IsFloatingWindowSnapToScreenEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFloatingWindowSnapToScreenEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsInactiveFloatingWindowFadeEnabledProperty Field

DockSiteIsInactiveFloatingWindowFadeEnabledProperty Field
Identifies the IsInactiveFloatingWindowFadeEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsInactiveFloatingWindowFadeEnabledProperty
Public Shared ReadOnly IsInactiveFloatingWindowFadeEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsInactiveFloatingWindowFadeEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsLiveSplittingEnabledProperty Field

DockSiteIsLiveSplittingEnabledProperty Field
Identifies the IsLiveSplittingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLiveSplittingEnabledProperty
Public Shared ReadOnly IsLiveSplittingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLiveSplittingEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.IsTabLayoutAnimationEnabledProperty Field

DockSiteIsTabLayoutAnimationEnabledProperty Field
Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabLayoutAnimationEnabledProperty
Public Shared ReadOnly IsTabLayoutAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabLayoutAnimationEnabled dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MagnetismGapDistanceProperty Field

DockSiteMagnetismGapDistanceProperty Field
Identifies the MagnetismGapDistance dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MagnetismGapDistanceProperty
Public Shared ReadOnly MagnetismGapDistanceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MagnetismGapDistance dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MagnetismSnapDistanceProperty Field

DockSiteMagnetismSnapDistanceProperty Field
Identifies the MagnetismSnapDistance dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MagnetismSnapDistanceProperty
Public Shared ReadOnly MagnetismSnapDistanceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MagnetismSnapDistance dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.MdiKindProperty Field

DockSiteMdiKindProperty Field
Identifies the MdiKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MdiKindProperty
Public Shared ReadOnly MdiKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MdiKind dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.PrimaryDocumentProperty Field

DockSitePrimaryDocumentProperty Field
Identifies the PrimaryDocument dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryDocumentProperty
Public Shared ReadOnly PrimaryDocumentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryDocument dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.SplitterSizeProperty Field

DockSiteSplitterSizeProperty Field
Identifies the SplitterSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SplitterSizeProperty
Public Shared ReadOnly SplitterSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SplitterSize dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.SwitcherProperty Field

DockSiteSwitcherProperty Field
Identifies the Switcher dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwitcherProperty
Public Shared ReadOnly SwitcherProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Switcher dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemContainerStyleProperty Field

DockSiteToolItemContainerStyleProperty Field
Identifies the ToolItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemContainerStyleProperty
Public Shared ReadOnly ToolItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemContainerStyle dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemContainerStyleSelectorProperty Field

DockSiteToolItemContainerStyleSelectorProperty Field
Identifies the ToolItemContainerStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemContainerStyleSelectorProperty
Public Shared ReadOnly ToolItemContainerStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemContainerStyleSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemsSourceProperty Field

DockSiteToolItemsSourceProperty Field
Identifies the ToolItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemsSourceProperty
Public Shared ReadOnly ToolItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemsSource dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemTemplateProperty Field

DockSiteToolItemTemplateProperty Field
Identifies the ToolItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemTemplateProperty
Public Shared ReadOnly ToolItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemTemplate dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolItemTemplateSelectorProperty Field

DockSiteToolItemTemplateSelectorProperty Field
Identifies the ToolItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolItemTemplateSelectorProperty
Public Shared ReadOnly ToolItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolItemTemplateSelector dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveCloseButtonsProperty Field

DockSiteToolWindowsHaveCloseButtonsProperty Field
Identifies the ToolWindowsHaveCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveCloseButtonsProperty
Public Shared ReadOnly ToolWindowsHaveCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveCloseButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveOptionsButtonsProperty Field

DockSiteToolWindowsHaveOptionsButtonsProperty Field
Identifies the ToolWindowsHaveOptionsButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveOptionsButtonsProperty
Public Shared ReadOnly ToolWindowsHaveOptionsButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveOptionsButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveTabImagesProperty Field

DockSiteToolWindowsHaveTabImagesProperty Field
Identifies the ToolWindowsHaveTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveTabImagesProperty
Public Shared ReadOnly ToolWindowsHaveTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveTabImages dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBarIconsProperty Field

DockSiteToolWindowsHaveTitleBarIconsProperty Field
Identifies the ToolWindowsHaveTitleBarIcons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveTitleBarIconsProperty
Public Shared ReadOnly ToolWindowsHaveTitleBarIconsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveTitleBarIcons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveTitleBarsProperty Field

DockSiteToolWindowsHaveTitleBarsProperty Field
Identifies the ToolWindowsHaveTitleBars dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveTitleBarsProperty
Public Shared ReadOnly ToolWindowsHaveTitleBarsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveTitleBars dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsHaveToggleAutoHideButtonsProperty Field

DockSiteToolWindowsHaveToggleAutoHideButtonsProperty Field
Identifies the ToolWindowsHaveToggleAutoHideButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsHaveToggleAutoHideButtonsProperty
Public Shared ReadOnly ToolWindowsHaveToggleAutoHideButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsHaveToggleAutoHideButtons dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsSingleTabLayoutBehaviorProperty Field

DockSiteToolWindowsSingleTabLayoutBehaviorProperty Field
Identifies the ToolWindowsSingleTabLayoutBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsSingleTabLayoutBehaviorProperty
Public Shared ReadOnly ToolWindowsSingleTabLayoutBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsSingleTabLayoutBehavior dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsTabOverflowBehaviorProperty Field

DockSiteToolWindowsTabOverflowBehaviorProperty Field
Identifies the ToolWindowsTabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsTabOverflowBehaviorProperty
Public Shared ReadOnly ToolWindowsTabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsTabOverflowBehavior dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsTabStripPlacementProperty Field

DockSiteToolWindowsTabStripPlacementProperty Field
Identifies the ToolWindowsTabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsTabStripPlacementProperty
Public Shared ReadOnly ToolWindowsTabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsTabStripPlacement dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.ToolWindowsTitleBarContextContentAlignmentProperty Field

DockSiteToolWindowsTitleBarContextContentAlignmentProperty Field
Identifies the ToolWindowsTitleBarContextContentAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowsTitleBarContextContentAlignmentProperty
Public Shared ReadOnly ToolWindowsTitleBarContextContentAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowsTitleBarContextContentAlignment dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DockSite.UseDragFloatPreviewsProperty Field

DockSiteUseDragFloatPreviewsProperty Field
Identifies the UseDragFloatPreviews dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDragFloatPreviewsProperty
Public Shared ReadOnly UseDragFloatPreviewsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDragFloatPreviews dependency property.
See Also

Reference

DockSite Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Class

DocumentWindow Class
Represents a document window.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingDocumentWindow

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DocumentWindow : DockingWindow
Public Class DocumentWindow
    Inherits DockingWindow

The DocumentWindow type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentWindow | Initializes a new instance of the DocumentWindow class. When creating instances of DocumentWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | DocumentWindow(Boolean) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the DocumentWindow class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FileName | Gets or sets the full path to the document.
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsReadOnly | Gets or sets whether the document window is currently in a read-only state.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | Attach | Attaches the DocumentWindow to the specified target, generally making a tabbed group.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the DocumentWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the DocumentWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Inherited from DockingWindow.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains keyboard focus within its hierarchy. (Inherited from DockingWindow.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindow.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Inherited from DockingWindow.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindow.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
FileNameProperty | Identifies the FileName dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Constructor

DocumentWindow Constructor
Overload List
 | Name | Description
Public method | DocumentWindow | Initializes a new instance of the DocumentWindow class. When creating instances of DocumentWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | DocumentWindow(Boolean) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite) | Initializes a new instance of the DocumentWindow class.
Public method | DocumentWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the DocumentWindow class.
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Constructor

DocumentWindow Constructor
Initializes a new instance of the DocumentWindow class. When creating instances of DocumentWindow programmatically, use a constructor that accepts a DockSite instead.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindow()
Public Sub New
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Constructor (Boolean)

DocumentWindow Constructor (Boolean)
Initializes a new instance of the DocumentWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindow(
    bool isContainerForItem
)
Public Sub New (
    isContainerForItem As Boolean
)

Parameters

isContainerForItem
Type: SystemBoolean
Whether the window is a container for an item.
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Constructor (DockSite)

DocumentWindow Constructor (DockSite)
Initializes a new instance of the DocumentWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindow(
    DockSite dockSite
)
Public Sub New (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The DockSite with which to register this window.
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Constructor (DockSite, String, String, ImageSource, Object)

DocumentWindow Constructor (DockSite, String, String, ImageSource, Object)
Initializes a new instance of the DocumentWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindow(
    DockSite dockSite,
    string serializationId,
    string title,
    ImageSource imageSource,
    Object content
)
Public Sub New (
    dockSite As DockSite,
    serializationId As String,
    title As String,
    imageSource As ImageSource,
    content As Object
)

Parameters

dockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The DockSite with which to register this window.
serializationId
Type: SystemString
The serialization ID of the window, used during layout serialization.
title
Type: SystemString
The title of the window.
imageSource
Type: Windows.UI.Xaml.MediaImageSource
The image source for the window's icon.
content
Type: SystemObject
The content of the window.
See Also

Reference

DocumentWindow Class
DocumentWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Properties

DocumentWindow Properties

The DocumentWindow type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FileName | Gets or sets the full path to the document.
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsReadOnly | Gets or sets whether the document window is currently in a read-only state.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.FileName Property

DocumentWindowFileName Property
Gets or sets the full path to the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The full path to the document.
Remarks
This property is displayed on switchers.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.IsReadOnly Property

DocumentWindowIsReadOnly Property
Gets or sets whether the document window is currently in a read-only state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document window is currently in a read-only state; otherwise, false. The default value is false.
Remarks
This flag is purely a visual cue to the end user that the contents of the document window are read-only.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Methods

DocumentWindow Methods

The DocumentWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | Attach | Attaches the DocumentWindow to the specified target, generally making a tabbed group.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the DocumentWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the DocumentWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Inherited from DockingWindow.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains keyboard focus within its hierarchy. (Inherited from DockingWindow.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindow.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Inherited from DockingWindow.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindow.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.Attach Method

DocumentWindowAttach Method
Attaches the DocumentWindow to the specified target, generally making a tabbed group.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Attach(
    IDockTarget target
)
Public Sub Attach (
    target As IDockTarget
)

Parameters

target
Type: ActiproSoftware.UI.Xaml.Controls.DockingIDockTarget
The IDockTarget against which to attach.
Remarks
The target must be another DocumentWindow or TabbedMdiContainer.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.Dock Method

DocumentWindowDock Method
Docks the DocumentWindow to the side of a specified target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dock(
    IDockTarget target,
    Side side
)
Public Sub Dock (
    target As IDockTarget,
    side As Side
)

Parameters

target
Type: ActiproSoftware.UI.Xaml.Controls.DockingIDockTarget
The IDockTarget that is the target of the dock.
side
Type: ActiproSoftware.UI.Xaml.ControlsSide
The target's Side against which to dock.
Remarks
The target must be another DocumentWindow or TabbedMdiContainer. Use the Attach(IDockTarget) method to dock into a particular target.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.Float Method

DocumentWindowFloat Method
Overload List
 | Name | Description
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the DocumentWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.Float Method (Nullable(Point), Nullable(Size))

DocumentWindowFloat Method (NullablePoint, NullableSize)
Floats the DocumentWindow to the specified optional location and size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Float(
    Nullable<Point> location,
    Nullable<Size> size
)
Public Overrides Sub Float (
    location As Nullable(Of Point),
    size As Nullable(Of Size)
)

Parameters

location
Type: SystemNullable Point
An optional Point specifying the target location of the floating dock host.
size
Type: SystemNullable Size
An optional Size specifying the target size of the floating dock host.
Remarks
When location is not specified, it will float to a default location. When size is not specified, it will float with its current size. Using this method places the DocumentWindow in a new MDI host within a floating dock host.
See Also

Reference

DocumentWindow Class
Float Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.OnCreateAutomationPeer Method

DocumentWindowOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.OnStateChanged Method

DocumentWindowOnStateChanged Method
Occurs when the value of the State property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnStateChanged(
    DockingWindowState oldValue,
    DockingWindowState newValue
)
Protected Overrides Sub OnStateChanged (
    oldValue As DockingWindowState,
    newValue As DockingWindowState
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The new value.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.UpdateCanAttachResolved Method

DocumentWindowUpdateCanAttachResolved Method
Updates the CanAttachResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanAttachResolved()
Protected Overrides Sub UpdateCanAttachResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.UpdateCanCloseResolved Method

DocumentWindowUpdateCanCloseResolved Method
Updates the CanCloseResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanCloseResolved()
Protected Overrides Sub UpdateCanCloseResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.UpdateCanDockResolved Method

DocumentWindowUpdateCanDockResolved Method
Updates the CanDockResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanDockResolved()
Protected Overrides Sub UpdateCanDockResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.UpdateCanDragTabResolved Method

DocumentWindowUpdateCanDragTabResolved Method
Updates the CanDragTabResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragTabResolved()
Protected Overrides Sub UpdateCanDragTabResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.UpdateCanDragToLinkedDockSitesResolved Method

DocumentWindowUpdateCanDragToLinkedDockSitesResolved Method
Updates the CanDragToLinkedDockSitesResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragToLinkedDockSitesResolved()
Protected Overrides Sub UpdateCanDragToLinkedDockSitesResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.UpdateCanFloatResolved Method

DocumentWindowUpdateCanFloatResolved Method
Updates the CanFloatResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanFloatResolved()
Protected Overrides Sub UpdateCanFloatResolved
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Events

DocumentWindow Events

The DocumentWindow type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow Fields

DocumentWindow Fields

The DocumentWindow type exposes the following members.

Fields
Name | Description
FileNameProperty | Identifies the FileName dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
Top
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.FileNameProperty Field

DocumentWindowFileNameProperty Field
Identifies the FileName dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FileNameProperty
Public Shared ReadOnly FileNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FileName dependency property.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindow.IsReadOnlyProperty Field

DocumentWindowIsReadOnlyProperty Field
Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

DocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindowCollection Class

DocumentWindowCollection Class
Represents an observable collection of DocumentWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection DocumentWindow
System.Collections.ObjectModelObservableCollection DocumentWindow
ActiproSoftware.UI.XamlDeferrableObservableCollection DocumentWindow
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollectionBase DocumentWindow
ActiproSoftware.UI.Xaml.Controls.DockingDocumentWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DocumentWindowCollection : DockingWindowCollectionBase<DocumentWindow>
Public Class DocumentWindowCollection
    Inherits DockingWindowCollectionBase(Of DocumentWindow)

The DocumentWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentWindowCollection | Initializes a new instance of the DocumentWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection DocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | (Inherited from Collection DocumentWindow .)
Protected property | Items | (Inherited from Collection DocumentWindow .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection DocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection DocumentWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection DocumentWindow .)
Public method | Clear | (Inherited from Collection DocumentWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection DocumentWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | (Inherited from Collection DocumentWindow .)
Public method | CopyTo | (Inherited from Collection DocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection DocumentWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | (Inherited from Collection DocumentWindow .)
Public method | Insert | (Inherited from Collection DocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection DocumentWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection DocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection DocumentWindow .)
Public method | RemoveAt | (Inherited from Collection DocumentWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection DocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection DocumentWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection DocumentWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindowCollection Constructor

DocumentWindowCollection Constructor
Initializes a new instance of the DocumentWindowCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindowCollection()
Public Sub New
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindowCollection Properties

DocumentWindowCollection Properties

The DocumentWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection DocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | (Inherited from Collection DocumentWindow .)
Protected property | Items | (Inherited from Collection DocumentWindow .)
Top
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindowCollection Methods

DocumentWindowCollection Methods

The DocumentWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection DocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection DocumentWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection DocumentWindow .)
Public method | Clear | (Inherited from Collection DocumentWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection DocumentWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | (Inherited from Collection DocumentWindow .)
Public method | CopyTo | (Inherited from Collection DocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection DocumentWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | (Inherited from Collection DocumentWindow .)
Public method | Insert | (Inherited from Collection DocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection DocumentWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection DocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection DocumentWindow .)
Public method | RemoveAt | (Inherited from Collection DocumentWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection DocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


DocumentWindowCollection Events

DocumentWindowCollection Events

The DocumentWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection DocumentWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection DocumentWindow .)
Top
See Also

Reference

DocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Class

FloatingWindowOpeningEventArgs Class
Provides event arguments for floating window opening events.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlRoutedEventArgs
ActiproSoftware.UI.Xaml.Controls.DockingFloatingWindowOpeningEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FloatingWindowOpeningEventArgs : RoutedEventArgs
Public Class FloatingWindowOpeningEventArgs
    Inherits RoutedEventArgs

The FloatingWindowOpeningEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FloatingWindowOpeningEventArgs | Initializes a new instance of the FloatingWindowOpeningEventArgs class.
Top
Properties
 | Name | Description
Public property | DockHost | Gets the DockHost that will be the child of the floating window.
Public property | DockHostChild | Gets the child FrameworkElement of the DockHost.
Public property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | Size | Gets or sets the Size of the floating window.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Constructor

FloatingWindowOpeningEventArgs Constructor
Initializes a new instance of the FloatingWindowOpeningEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FloatingWindowOpeningEventArgs(
    DockHost dockHost
)
Public Sub New (
    dockHost As DockHost
)

Parameters

dockHost
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The DockHost that will be the child of the floating window.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Properties

FloatingWindowOpeningEventArgs Properties

The FloatingWindowOpeningEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DockHost | Gets the DockHost that will be the child of the floating window.
Public property | DockHostChild | Gets the child FrameworkElement of the DockHost.
Public property | OriginalSource | Gets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | Size | Gets or sets the Size of the floating window.
Top
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs.DockHost Property

FloatingWindowOpeningEventArgsDockHost Property
Gets the DockHost that will be the child of the floating window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that will be the child of the floating window.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs.DockHostChild Property

FloatingWindowOpeningEventArgsDockHostChild Property
Gets the child FrameworkElement of the DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement DockHostChild { get; }
Public ReadOnly Property DockHostChild As FrameworkElement
    Get

Property Value

Type: FrameworkElement
The child FrameworkElement of the DockHost.
Remarks
The Child property isn't populated when drag previews are used. This property always provides access to the element that will become the DockHost child in those scenarios.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs.Size Property

FloatingWindowOpeningEventArgsSize Property
Gets or sets the Size of the floating window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The Size of the floating window.
Remarks
This property is initialized to the default size and can be adjusted as appropriate.
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


FloatingWindowOpeningEventArgs Methods

FloatingWindowOpeningEventArgs Methods

The FloatingWindowOpeningEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FloatingWindowOpeningEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


IDockTarget Interface

IDockTarget Interface
Provides the base requirements for an object that is a possible target for a docking operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDockTarget
Public Interface IDockTarget

The IDockTarget type exposes the following members.

Properties
 | Name | Description
Public property | DockHost | Gets the owner DockHost.
Public property | DockSite | Gets the DockSite that is managing this object.
Top
Methods
 | Name | Description
Public method | GetState | Returns the DockingWindowState that specifies the state of the docking location around the target.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


IDockTarget Properties

IDockTarget Properties

The IDockTarget type exposes the following members.

Properties
 | Name | Description
Public property | DockHost | Gets the owner DockHost.
Public property | DockSite | Gets the DockSite that is managing this object.
Top
See Also

Reference

IDockTarget Interface
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


IDockTarget.DockHost Property

IDockTargetDockHost Property
Gets the owner DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DockHost DockHost { get; }
ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The owner DockHost.
See Also

Reference

IDockTarget Interface
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


IDockTarget.DockSite Property

IDockTargetDockSite Property
Gets the DockSite that is managing this object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DockSite DockSite { get; }
ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this object.
See Also

Reference

IDockTarget Interface
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


IDockTarget Methods

IDockTarget Methods

The IDockTarget type exposes the following members.

Methods
 | Name | Description
Public method | GetState | Returns the DockingWindowState that specifies the state of the docking location around the target.
Top
See Also

Reference

IDockTarget Interface
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


IDockTarget.GetState Method

IDockTargetGetState Method
Returns the DockingWindowState that specifies the state of the docking location around the target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DockingWindowState GetState(
    Nullable<Side> side
)
Function GetState (
    side As Nullable(Of Side)
) As DockingWindowState

Parameters

side
Type: SystemNullable Side

[Missing <param name="side"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Docking.IDockTarget.GetState(System.Nullable{ActiproSoftware.UI.Xaml.Controls.Side})"]

Field Value

Type: DockingWindowState
The DockingWindowState that specifies the state of the docking location around the target.

Return Value

Type: DockingWindowState

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Docking.IDockTarget.GetState(System.Nullable{ActiproSoftware.UI.Xaml.Controls.Side})"]

See Also

Reference

IDockTarget Interface
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind Class

MdiKind Class
Specifies the kind of MDI (multiple-document interface).
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingMdiKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MdiKind : Enum
Public NotInheritable Class MdiKind
    Inherits Enum

The MdiKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | No MDI.
 | Standard | Standard (windowed) MDI.
 | Tabbed | Tabbed MDI.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind Methods

MdiKind Methods

The MdiKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MdiKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind Fields

MdiKind Fields

The MdiKind type exposes the following members.

Fields
 | Name | Description
 | None | No MDI.
 | Standard | Standard (windowed) MDI.
 | Tabbed | Tabbed MDI.
Public field | value__ |
Top
See Also

Reference

MdiKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind.None Field

MdiKindNone Field
No MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MdiKind None = 0
Public Const None As MdiKind = 0

Field Value

Type: MdiKind
See Also

Reference

MdiKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind.Standard Field

MdiKindStandard Field
Standard (windowed) MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MdiKind Standard = 2
Public Const Standard As MdiKind = 2

Field Value

Type: MdiKind
See Also

Reference

MdiKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind.Tabbed Field

MdiKindTabbed Field
Tabbed MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MdiKind Tabbed = 1
Public Const Tabbed As MdiKind = 1

Field Value

Type: MdiKind
See Also

Reference

MdiKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


MdiKind.value__ Field

MdiKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.MdiKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MdiKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Class

ReadOnlyDockingWindowBaseCollectionT Class
Represents the base class for a read-only observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelReadOnlyCollection T
System.Collections.ObjectModelReadOnlyObservableCollection T
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyDockingWindowBaseCollectionT
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyDockingWindowCollection
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyToolWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReadOnlyDockingWindowBaseCollection<T> : ReadOnlyObservableCollection<T>
where T : DockingWindow

Public Class ReadOnlyDockingWindowBaseCollection(Of T As DockingWindow)
    Inherits ReadOnlyObservableCollection(Of T)

Type Parameters

T
The type of DockingWindow in this collection.

The ReadOnlyDockingWindowBaseCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyDockingWindowBaseCollectionT | Initializes a new instance of the ReadOnlyDockingWindowBaseCollectionT class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from ReadOnlyCollection T.)
Public property | ItemInt32 | (Inherited from ReadOnlyCollection T.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | (Inherited from ReadOnlyCollection T.)
Top
Methods
 | Name | Description
Public method | Contains(T) | (Inherited from ReadOnlyCollection T.)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | (Inherited from ReadOnlyCollection T.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ReadOnlyCollection T.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection T.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from ReadOnlyObservableCollection T.)
Protected method | OnPropertyChanged | (Inherited from ReadOnlyObservableCollection T.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Protected event | CollectionChanged | (Inherited from ReadOnlyObservableCollection T.)
Protected event | PropertyChanged | (Inherited from ReadOnlyObservableCollection T.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Constructor

ReadOnlyDockingWindowBaseCollectionT Constructor
Initializes a new instance of the ReadOnlyDockingWindowBaseCollectionT class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowBaseCollection(
    ObservableCollection<T> list
)
Public Sub New (
    list As ObservableCollection(Of T)
)

Parameters

list
Type: System.Collections.ObjectModelObservableCollection T
The collection with which to create this instance.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Properties

ReadOnlyDockingWindowBaseCollectionT Properties

The ReadOnlyDockingWindowBaseCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ReadOnlyCollection T .)
Public property | ItemInt32 | (Inherited from ReadOnlyCollection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Protected property | Items | (Inherited from ReadOnlyCollection T .)
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Item Property

ReadOnlyDockingWindowBaseCollectionTItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from ReadOnlyCollection T .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection.
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Item Property (Guid)

ReadOnlyDockingWindowBaseCollectionTItem Property (Guid)
Gets the item with the specified UniqueId value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T this[
    Guid uniqueId
] { get; }
Public ReadOnly Property Item (
    uniqueId As Guid
) As T
    Get

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Property Value

Type: T
The item with the specified UniqueId value.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Item Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Item Property (String)

ReadOnlyDockingWindowBaseCollectionTItem Property (String)
Gets the item with the specified Name value.

[C#] In C#, this property is the indexer for the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As T
    Get

Parameters

name
Type: SystemString
The name value to locate in the collection.

Property Value

Type: T
The item with the specified Name value.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Item Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Methods

ReadOnlyDockingWindowBaseCollectionT Methods

The ReadOnlyDockingWindowBaseCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Contains(T) | (Inherited from ReadOnlyCollection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Public method | CopyTo | (Inherited from ReadOnlyCollection T .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ReadOnlyCollection T .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from ReadOnlyObservableCollection T .)
Protected method | OnPropertyChanged | (Inherited from ReadOnlyObservableCollection T .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Contains Method

ReadOnlyDockingWindowBaseCollectionTContains Method
Overload List
 | Name | Description
Public method | Contains(T) | (Inherited from ReadOnlyCollection T .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection.
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Contains Method (Guid)

ReadOnlyDockingWindowBaseCollectionTContains Method (Guid)
Determines whether an item with the specified UniqueId value is in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    Guid uniqueId
)
Public Function Contains (
    uniqueId As Guid
) As Boolean

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified UniqueId value is found in the collection; otherwise, false.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Contains Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).Contains Method (String)

ReadOnlyDockingWindowBaseCollectionTContains Method (String)
Determines whether an item with the specified Name value is in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Boolean
true if an item with the specified Name value is found in the collection; otherwise, false.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
Contains Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).IndexOf Method

ReadOnlyDockingWindowBaseCollectionTIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection T .)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).IndexOf Method (Guid)

ReadOnlyDockingWindowBaseCollectionTIndexOf Method (Guid)
Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    Guid uniqueId
)
Public Function IndexOf (
    uniqueId As Guid
) As Integer

Parameters

uniqueId
Type: SystemGuid
The unique ID value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified UniqueId value within the entire collection, if found; otherwise, -1.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
IndexOf Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).IndexOf Method (String)

ReadOnlyDockingWindowBaseCollectionTIndexOf Method (String)
Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name value to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of an item with the specified Name value within the entire collection, if found; otherwise, -1.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
IndexOf Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T).ToArray Method

ReadOnlyDockingWindowBaseCollectionTToArray Method
Returns a strongly-typed array containing the items in this collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T[] ToArray()
Public Function ToArray As T()

Return Value

Type: T
A strongly-typed array containing the items in this collection.
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowBaseCollection(T) Events

ReadOnlyDockingWindowBaseCollectionT Events

The ReadOnlyDockingWindowBaseCollectionT generic type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | (Inherited from ReadOnlyObservableCollection T .)
Protected event | PropertyChanged | (Inherited from ReadOnlyObservableCollection T .)
Top
See Also

Reference

ReadOnlyDockingWindowBaseCollectionT Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Class

ReadOnlyDockingWindowCollection Class
Represents a read-only observable collection of DockingWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelReadOnlyCollection DockingWindow
System.Collections.ObjectModelReadOnlyObservableCollection DockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyDockingWindowBaseCollection DockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyDockingWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReadOnlyDockingWindowCollection : ReadOnlyDockingWindowBaseCollection<DockingWindow>
Public Class ReadOnlyDockingWindowCollection
    Inherits ReadOnlyDockingWindowBaseCollection(Of DockingWindow)

The ReadOnlyDockingWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyDockingWindowCollection | Initializes an instance of the ReadOnlyDockingWindowCollection class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from ReadOnlyCollection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | (Inherited from ReadOnlyCollection DockingWindow .)
Protected property | Items | (Inherited from ReadOnlyCollection DockingWindow .)
Top
Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | (Inherited from ReadOnlyCollection DockingWindow .)
Public method | CopyTo | (Inherited from ReadOnlyCollection DockingWindow .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ReadOnlyCollection DockingWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection DockingWindow .)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected method | OnPropertyChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Protected event | CollectionChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected event | PropertyChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Constructor

ReadOnlyDockingWindowCollection Constructor
Initializes an instance of the ReadOnlyDockingWindowCollection class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowCollection(
    ObservableCollection<DockingWindow> list
)
Public Sub New (
    list As ObservableCollection(Of DockingWindow)
)

Parameters

list
Type: System.Collections.ObjectModelObservableCollection DockingWindow
The collection with which to create this instance.
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Properties

ReadOnlyDockingWindowCollection Properties

The ReadOnlyDockingWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ReadOnlyCollection DockingWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | (Inherited from ReadOnlyCollection DockingWindow .)
Protected property | Items | (Inherited from ReadOnlyCollection DockingWindow .)
Top
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Methods

ReadOnlyDockingWindowCollection Methods

The ReadOnlyDockingWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | (Inherited from ReadOnlyCollection DockingWindow .)
Public method | CopyTo | (Inherited from ReadOnlyCollection DockingWindow .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ReadOnlyCollection DockingWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection DockingWindow .)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected method | OnPropertyChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyDockingWindowCollection Events

ReadOnlyDockingWindowCollection Events

The ReadOnlyDockingWindowCollection type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Protected event | PropertyChanged | (Inherited from ReadOnlyObservableCollection DockingWindow .)
Top
See Also

Reference

ReadOnlyDockingWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyToolWindowCollection Class

ReadOnlyToolWindowCollection Class
Represents a read-only observable collection of ToolWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelReadOnlyCollection ToolWindow
System.Collections.ObjectModelReadOnlyObservableCollection ToolWindow
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyDockingWindowBaseCollection ToolWindow
ActiproSoftware.UI.Xaml.Controls.DockingReadOnlyToolWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ReadOnlyToolWindowCollection : ReadOnlyDockingWindowBaseCollection<ToolWindow>
Public Class ReadOnlyToolWindowCollection
    Inherits ReadOnlyDockingWindowBaseCollection(Of ToolWindow)

The ReadOnlyToolWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ReadOnlyToolWindowCollection | Initializes an instance of the ReadOnlyToolWindowCollection class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from ReadOnlyCollection ToolWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | (Inherited from ReadOnlyCollection ToolWindow .)
Protected property | Items | (Inherited from ReadOnlyCollection ToolWindow .)
Top
Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | (Inherited from ReadOnlyCollection ToolWindow .)
Public method | CopyTo | (Inherited from ReadOnlyCollection ToolWindow .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ReadOnlyCollection ToolWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection ToolWindow .)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected method | OnPropertyChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Protected event | CollectionChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected event | PropertyChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyToolWindowCollection Constructor

ReadOnlyToolWindowCollection Constructor
Initializes an instance of the ReadOnlyToolWindowCollection class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyToolWindowCollection(
    ObservableCollection<ToolWindow> list
)
Public Sub New (
    list As ObservableCollection(Of ToolWindow)
)

Parameters

list
Type: System.Collections.ObjectModelObservableCollection ToolWindow
The collection with which to create this instance.
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyToolWindowCollection Properties

ReadOnlyToolWindowCollection Properties

The ReadOnlyToolWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ReadOnlyCollection ToolWindow .)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public property | ItemInt32 | (Inherited from ReadOnlyCollection ToolWindow .)
Protected property | Items | (Inherited from ReadOnlyCollection ToolWindow .)
Top
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyToolWindowCollection Methods

ReadOnlyToolWindowCollection Methods

The ReadOnlyToolWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | Contains(T) | (Inherited from ReadOnlyCollection ToolWindow .)
Public method | CopyTo | (Inherited from ReadOnlyCollection ToolWindow .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ReadOnlyCollection ToolWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | IndexOf(T) | (Inherited from ReadOnlyCollection ToolWindow .)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected method | OnPropertyChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from ReadOnlyDockingWindowBaseCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ReadOnlyToolWindowCollection Events

ReadOnlyToolWindowCollection Events

The ReadOnlyToolWindowCollection type exposes the following members.

Events
 | Name | Description
Protected event | CollectionChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Protected event | PropertyChanged | (Inherited from ReadOnlyObservableCollection ToolWindow .)
Top
See Also

Reference

ReadOnlyToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode Class

ResizeMode Class
Specifies whether a window can be resized and, if so, how it can be resized.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingResizeMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class ResizeMode : Enum
Public NotInheritable Class ResizeMode
    Inherits Enum

The ResizeMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CanMinimize | A window can only be minimized and restored. The Minimize and Maximize buttons are both shown, but only the Minimize button is enabled.
 | CanResize | A window can be resized. The Minimize and Maximize buttons are both shown and enabled.
 | NoResize | A window cannot be resized. The Minimize and Maximize buttons are not displayed in the title bar.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode Methods

ResizeMode Methods

The ResizeMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

ResizeMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode Fields

ResizeMode Fields

The ResizeMode type exposes the following members.

Fields
 | Name | Description
 | CanMinimize | A window can only be minimized and restored. The Minimize and Maximize buttons are both shown, but only the Minimize button is enabled.
 | CanResize | A window can be resized. The Minimize and Maximize buttons are both shown and enabled.
 | NoResize | A window cannot be resized. The Minimize and Maximize buttons are not displayed in the title bar.
Public field | value__ |
Top
See Also

Reference

ResizeMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode.CanMinimize Field

ResizeModeCanMinimize Field
A window can only be minimized and restored. The Minimize and Maximize buttons are both shown, but only the Minimize button is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeMode CanMinimize = 1
Public Const CanMinimize As ResizeMode = 1

Field Value

Type: ResizeMode
See Also

Reference

ResizeMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode.CanResize Field

ResizeModeCanResize Field
A window can be resized. The Minimize and Maximize buttons are both shown and enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeMode CanResize = 2
Public Const CanResize As ResizeMode = 2

Field Value

Type: ResizeMode
See Also

Reference

ResizeMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode.NoResize Field

ResizeModeNoResize Field
A window cannot be resized. The Minimize and Maximize buttons are not displayed in the title bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const ResizeMode NoResize = 0
Public Const NoResize As ResizeMode = 0

Field Value

Type: ResizeMode
See Also

Reference

ResizeMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ResizeMode.value__ Field

ResizeModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.ResizeMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

ResizeMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SimpleSwitcher Class

SimpleSwitcher Class
Implements a SwitcherBase that has no user interface and simply processes keystrokes.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSwitcherBase
ActiproSoftware.UI.Xaml.Controls.DockingSimpleSwitcher

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SimpleSwitcher : SwitcherBase
Public Class SimpleSwitcher
    Inherits SwitcherBase

The SimpleSwitcher type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleSwitcher | Initializes a new instance of the SimpleSwitcher class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnClosed | Invoked when the switcher is closed. (Inherited from SwitcherBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from SwitcherBase.)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Inherited from SwitcherBase.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SimpleSwitcher Constructor

SimpleSwitcher Constructor
Initializes a new instance of the SimpleSwitcher class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SimpleSwitcher()
Public Sub New
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SimpleSwitcher Properties

SimpleSwitcher Properties

The SimpleSwitcher type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SimpleSwitcher Methods

SimpleSwitcher Methods

The SimpleSwitcher type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnClosed | Invoked when the switcher is closed. (Inherited from SwitcherBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from SwitcherBase.)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Inherited from SwitcherBase.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SimpleSwitcher.OnSelectedWindowChanged Method

SimpleSwitcherOnSelectedWindowChanged Method
Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnSelectedWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overrides Sub OnSelectedWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new value.
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SimpleSwitcher Events

SimpleSwitcher Events

The SimpleSwitcher type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimpleSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SingleTabLayoutBehavior Class

SingleTabLayoutBehavior Class
Indicates the behavior of single tabs in their associated containers.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingSingleTabLayoutBehavior

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SingleTabLayoutBehavior : Enum
Public NotInheritable Class SingleTabLayoutBehavior
    Inherits Enum

The SingleTabLayoutBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Hide | Indicates that the tab panel will be hidden when there is a single tab.
 | Show | Indicates that the single tab will be displayed normally.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SingleTabLayoutBehavior Methods

SingleTabLayoutBehavior Methods

The SingleTabLayoutBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SingleTabLayoutBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SingleTabLayoutBehavior Fields

SingleTabLayoutBehavior Fields

The SingleTabLayoutBehavior type exposes the following members.

Fields
 | Name | Description
 | Hide | Indicates that the tab panel will be hidden when there is a single tab.
 | Show | Indicates that the single tab will be displayed normally.
Public field | value__ |
Top
See Also

Reference

SingleTabLayoutBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SingleTabLayoutBehavior.Hide Field

SingleTabLayoutBehaviorHide Field
Indicates that the tab panel will be hidden when there is a single tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SingleTabLayoutBehavior Hide = 0
Public Const Hide As SingleTabLayoutBehavior = 0

Field Value

Type: SingleTabLayoutBehavior
See Also

Reference

SingleTabLayoutBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SingleTabLayoutBehavior.Show Field

SingleTabLayoutBehaviorShow Field
Indicates that the single tab will be displayed normally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SingleTabLayoutBehavior Show = 1
Public Const Show As SingleTabLayoutBehavior = 1

Field Value

Type: SingleTabLayoutBehavior
See Also

Reference

SingleTabLayoutBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SingleTabLayoutBehavior.value__ Field

SingleTabLayoutBehaviorvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.SingleTabLayoutBehavior.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SingleTabLayoutBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes Class

SizeToContentModes Class
Specifies the modes when size-to-content should be applied.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingSizeToContentModes

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class SizeToContentModes : Enum
<FlagsAttribute>
Public NotInheritable Class SizeToContentModes
    Inherits Enum

The SizeToContentModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Floating | Size-to-content when entering a floating window.
 | None | No size-to-content modes.
 | StandardMdi | Size-to-content when entering standard MDI.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes Methods

SizeToContentModes Methods

The SizeToContentModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SizeToContentModes Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes Fields

SizeToContentModes Fields

The SizeToContentModes type exposes the following members.

Fields
 | Name | Description
 | Floating | Size-to-content when entering a floating window.
 | None | No size-to-content modes.
 | StandardMdi | Size-to-content when entering standard MDI.
Public field | value__ |
Top
See Also

Reference

SizeToContentModes Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes.Floating Field

SizeToContentModesFloating Field
Size-to-content when entering a floating window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SizeToContentModes Floating = 2
Public Const Floating As SizeToContentModes = 2

Field Value

Type: SizeToContentModes
See Also

Reference

SizeToContentModes Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes.None Field

SizeToContentModesNone Field
No size-to-content modes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SizeToContentModes None = 0
Public Const None As SizeToContentModes = 0

Field Value

Type: SizeToContentModes
See Also

Reference

SizeToContentModes Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes.StandardMdi Field

SizeToContentModesStandardMdi Field
Size-to-content when entering standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SizeToContentModes StandardMdi = 1
Public Const StandardMdi As SizeToContentModes = 1

Field Value

Type: SizeToContentModes
See Also

Reference

SizeToContentModes Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SizeToContentModes.value__ Field

SizeToContentModesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.SizeToContentModes.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SizeToContentModes Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer Class

SplitContainer Class
Represents a container that has multiple split panes of content.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.DockingSplitContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SplitContainer : Control,
    IOrientedElement
Public Class SplitContainer
    Inherits Control
    Implements IOrientedElement

The SplitContainer type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainer | Initializes an instance of the SplitContainer class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Children | Gets the collection of child FrameworkElement objects.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ResizeSlots | Resizes the slots based on the specified ratios, if any.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer Constructor

SplitContainer Constructor
Initializes an instance of the SplitContainer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SplitContainer()
Public Sub New
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer Properties

SplitContainer Properties

The SplitContainer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Children | Gets the collection of child FrameworkElement objects.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.Children Property

SplitContainerChildren Property
Gets the collection of child FrameworkElement objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<FrameworkElement> Children { get; }
Public ReadOnly Property Children As ObservableCollection(Of FrameworkElement)
    Get

Property Value

Type: ObservableCollection FrameworkElement
The collection of child FrameworkElement objects.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.DockHost Property

SplitContainerDockHost Property
Gets the DockHost that contains this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.DockSite Property

SplitContainerDockSite Property
Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.Orientation Property

SplitContainerOrientation Property
Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer Methods

SplitContainer Methods

The SplitContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ResizeSlots | Resizes the slots based on the specified ratios, if any.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.OnApplyTemplate Method

SplitContainerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.OnCreateAutomationPeer Method

SplitContainerOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.ResizeSlots Method

SplitContainerResizeSlots Method
Resizes the slots based on the specified ratios, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ResizeSlots(
    params double[] desiredRatios
)
Public Sub ResizeSlots (
    ParamArray desiredRatios As Double()
)

Parameters

desiredRatios
Type: SystemDouble
This list of zero or more desired ratios.
Remarks
If desiredRatios contains 0-1 items, then the slots will be resized equally. Otherwise, the specified ratio will be applied to the associated slot (i.e. the slot that shared the same index). If there are more slots than there are desired ratios, then the last ratio will be repeated for the remaining slots.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.ToString Method

SplitContainerToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer Events

SplitContainer Events

The SplitContainer type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer Fields

SplitContainer Fields

The SplitContainer type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


SplitContainer.OrientationProperty Field

SplitContainerOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost Class

StandardMdiHost Class
Represents a container that hosts docking windows in a standard, or windowed, MDI (multiple-document interface) mode.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesMdiHostBase
ActiproSoftware.UI.Xaml.Controls.DockingStandardMdiHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardMdiHost : MdiHostBase,
    IDockTarget
Public Class StandardMdiHost
    Inherits MdiHostBase
    Implements IDockTarget

The StandardMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiHost | Initializes an instance of the StandardMdiHost class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreMaximizedWindowFramesVisible | Gets or sets whether the frames should be displayed when the windows are maximized.
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanWindowsMaximize | Gets or sets whether the windows in this host can be maximized.
Public property | CanWindowsMinimize | Gets or sets whether the windows in this host can be minimized.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ClosePrimaryWindowCommand | Gets the ICommand that can close the PrimaryWindow.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoCascadeEnabled | Gets or sets a value indicating whether the windows should be automatically cascaded on the initial load.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExternalMaximizedUIRequired | Gets whether external maximized window UI (generally minimize, restore, and close buttons) should be visible.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsScrollingEnabled | Gets or sets a value indicating whether scrolling is supported by the standard MDI host.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizePrimaryWindowCommand | Gets the ICommand that can maximize the PrimaryWindow.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizePrimaryWindowCommand | Gets the ICommand that can minimize the PrimaryWindow.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestorePrimaryWindowCommand | Gets the ICommand that can restore the PrimaryWindow.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Public method | ArrangeMinimizedWindows | Re-arranges the minimized windows.
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | Cascade | Cascades the open documents.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ClosePrimaryWindow | Closes the PrimaryWindow, if any.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | MaximizePrimaryWindow | Maximizes the PrimaryWindow, if any.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MinimizePrimaryWindow | Minimizes the PrimaryWindow, if any.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides MdiHostBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Inherited from MdiHostBase.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Overrides MdiHostBaseOnPrimaryWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | RestorePrimaryWindow | Restores the PrimaryWindow, if any.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreMaximizedWindowFramesVisibleProperty | Identifies the AreMaximizedWindowFramesVisible dependency property. This field is read-only.
AreWindowsMaximizedProperty | Identifies the AreWindowsMaximized dependency property. This field is read-only.
CanWindowsMaximizeProperty | Identifies the CanWindowsMaximize dependency property. This field is read-only.
CanWindowsMinimizeProperty | Identifies the CanWindowsMinimize dependency property. This field is read-only.
IsAutoCascadeEnabledProperty | Identifies the IsAutoCascadeEnabled dependency property. This field is read-only.
IsExternalMaximizedUIRequiredProperty | Identifies the IsExternalMaximizedUIRequired dependency property. This field is read-only.
IsScrollingEnabledProperty | Identifies the IsScrollingEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost Constructor

StandardMdiHost Constructor
Initializes an instance of the StandardMdiHost class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardMdiHost()
Public Sub New
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost Properties

StandardMdiHost Properties

The StandardMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreMaximizedWindowFramesVisible | Gets or sets whether the frames should be displayed when the windows are maximized.
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanWindowsMaximize | Gets or sets whether the windows in this host can be maximized.
Public property | CanWindowsMinimize | Gets or sets whether the windows in this host can be minimized.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ClosePrimaryWindowCommand | Gets the ICommand that can close the PrimaryWindow.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoCascadeEnabled | Gets or sets a value indicating whether the windows should be automatically cascaded on the initial load.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExternalMaximizedUIRequired | Gets whether external maximized window UI (generally minimize, restore, and close buttons) should be visible.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsScrollingEnabled | Gets or sets a value indicating whether scrolling is supported by the standard MDI host.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizePrimaryWindowCommand | Gets the ICommand that can maximize the PrimaryWindow.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizePrimaryWindowCommand | Gets the ICommand that can minimize the PrimaryWindow.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestorePrimaryWindowCommand | Gets the ICommand that can restore the PrimaryWindow.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.AreMaximizedWindowFramesVisible Property

StandardMdiHostAreMaximizedWindowFramesVisible Property
Gets or sets whether the frames should be displayed when the windows are maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreMaximizedWindowFramesVisible { get; set; }
Public Property AreMaximizedWindowFramesVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the frames should be displayed when the windows are maximized; otherwise, false. The default value is true.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.AreWindowsMaximized Property

StandardMdiHostAreWindowsMaximized Property
Gets or sets whether windows in the host are currently maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreWindowsMaximized { get; set; }
Public Property AreWindowsMaximized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if windows in the host are currently maximized; otherwise, false. The default value is false.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.CanWindowsMaximize Property

StandardMdiHostCanWindowsMaximize Property
Gets or sets whether the windows in this host can be maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanWindowsMaximize { get; set; }
Public Property CanWindowsMaximize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows in this host can be maximized; otherwise, false. The default value is true.
Remarks
This setting only affects docking windows whose CanStandardMdiMaximize property is set to . Any other setting on the docking window instance overrides this global setting.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.CanWindowsMinimize Property

StandardMdiHostCanWindowsMinimize Property
Gets or sets whether the windows in this host can be minimized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanWindowsMinimize { get; set; }
Public Property CanWindowsMinimize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows in this host can be minimized; otherwise, false. The default value is true.
Remarks
This setting only affects docking windows whose CanStandardMdiMinimize property is set to . Any other setting on the docking window instance overrides this global setting.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.ClosePrimaryWindowCommand Property

StandardMdiHostClosePrimaryWindowCommand Property
Gets the ICommand that can close the PrimaryWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClosePrimaryWindowCommand { get; }
Public ReadOnly Property ClosePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.IsAutoCascadeEnabled Property

StandardMdiHostIsAutoCascadeEnabled Property
Gets or sets a value indicating whether the windows should be automatically cascaded on the initial load.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAutoCascadeEnabled { get; set; }
Public Property IsAutoCascadeEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows should be automatically cascaded on the initial load; otherwise false. The default value is true.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.IsExternalMaximizedUIRequired Property

StandardMdiHostIsExternalMaximizedUIRequired Property
Gets whether external maximized window UI (generally minimize, restore, and close buttons) should be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsExternalMaximizedUIRequired { get; }
Public ReadOnly Property IsExternalMaximizedUIRequired As Boolean
    Get

Property Value

Type: Boolean
true if external maximized window UI should be visible; otherwise false. The default value is false.
Remarks
This property can be bound to the visibility of an external UI panel. It is only true when a document is maximized and AreMaximizedWindowFramesVisible is false.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.IsScrollingEnabled Property

StandardMdiHostIsScrollingEnabled Property
Gets or sets a value indicating whether scrolling is supported by the standard MDI host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsScrollingEnabled { get; set; }
Public Property IsScrollingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if scrolling is supported by the standard MDI host; otherwise false. The default value is false.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.MaximizePrimaryWindowCommand Property

StandardMdiHostMaximizePrimaryWindowCommand Property
Gets the ICommand that can maximize the PrimaryWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MaximizePrimaryWindowCommand { get; }
Public ReadOnly Property MaximizePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can maximize the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.MinimizePrimaryWindowCommand Property

StandardMdiHostMinimizePrimaryWindowCommand Property
Gets the ICommand that can minimize the PrimaryWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MinimizePrimaryWindowCommand { get; }
Public ReadOnly Property MinimizePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can minimize the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.RestorePrimaryWindowCommand Property

StandardMdiHostRestorePrimaryWindowCommand Property
Gets the ICommand that can restore the PrimaryWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RestorePrimaryWindowCommand { get; }
Public ReadOnly Property RestorePrimaryWindowCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can restore the PrimaryWindow.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.Windows Property

StandardMdiHostWindows Property
Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost Methods

StandardMdiHost Methods

The StandardMdiHost type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Public method | ArrangeMinimizedWindows | Re-arranges the minimized windows.
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | Cascade | Cascades the open documents.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ClosePrimaryWindow | Closes the PrimaryWindow, if any.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | MaximizePrimaryWindow | Maximizes the PrimaryWindow, if any.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MinimizePrimaryWindow | Minimizes the PrimaryWindow, if any.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides MdiHostBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Inherited from MdiHostBase.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Overrides MdiHostBaseOnPrimaryWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | RestorePrimaryWindow | Restores the PrimaryWindow, if any.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.ArrangeMinimizedWindows Method

StandardMdiHostArrangeMinimizedWindows Method
Re-arranges the minimized windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ArrangeMinimizedWindows()
Public Sub ArrangeMinimizedWindows
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.Cascade Method

StandardMdiHostCascade Method
Cascades the open documents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Cascade()
Public Sub Cascade
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.ClosePrimaryWindow Method

StandardMdiHostClosePrimaryWindow Method
Closes the PrimaryWindow, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ClosePrimaryWindow()
Public Sub ClosePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.GetDocuments Method

StandardMdiHostGetDocuments Method
Returns the list of docking windows within the MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed IList<DockingWindow> GetDocuments()
Public Overrides NotOverridable Function GetDocuments As IList(Of DockingWindow)

Return Value

Type: IList DockingWindow
The list of docking windows within the MDI.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.MaximizePrimaryWindow Method

StandardMdiHostMaximizePrimaryWindow Method
Maximizes the PrimaryWindow, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MaximizePrimaryWindow()
Public Sub MaximizePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.MinimizePrimaryWindow Method

StandardMdiHostMinimizePrimaryWindow Method
Minimizes the PrimaryWindow, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void MinimizePrimaryWindow()
Public Sub MinimizePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.OnApplyTemplate Method

StandardMdiHostOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.OnCreateAutomationPeer Method

StandardMdiHostOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.OnPrimaryWindowChanged Method

StandardMdiHostOnPrimaryWindowChanged Method
Occurs when the value of the PrimaryWindow property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPrimaryWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overrides Sub OnPrimaryWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new value.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.RestorePrimaryWindow Method

StandardMdiHostRestorePrimaryWindow Method
Restores the PrimaryWindow, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RestorePrimaryWindow()
Public Sub RestorePrimaryWindow
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.TileHorizontally Method

StandardMdiHostTileHorizontally Method
Tiles the open documents horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileHorizontally()
Public Sub TileHorizontally
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.TileVertically Method

StandardMdiHostTileVertically Method
Tiles the open documents vertically.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileVertically()
Public Sub TileVertically
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost Events

StandardMdiHost Events

The StandardMdiHost type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost Fields

StandardMdiHost Fields

The StandardMdiHost type exposes the following members.

Fields
Name | Description
AreMaximizedWindowFramesVisibleProperty | Identifies the AreMaximizedWindowFramesVisible dependency property. This field is read-only.
AreWindowsMaximizedProperty | Identifies the AreWindowsMaximized dependency property. This field is read-only.
CanWindowsMaximizeProperty | Identifies the CanWindowsMaximize dependency property. This field is read-only.
CanWindowsMinimizeProperty | Identifies the CanWindowsMinimize dependency property. This field is read-only.
IsAutoCascadeEnabledProperty | Identifies the IsAutoCascadeEnabled dependency property. This field is read-only.
IsExternalMaximizedUIRequiredProperty | Identifies the IsExternalMaximizedUIRequired dependency property. This field is read-only.
IsScrollingEnabledProperty | Identifies the IsScrollingEnabled dependency property. This field is read-only.
Top
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.AreMaximizedWindowFramesVisibleProperty Field

StandardMdiHostAreMaximizedWindowFramesVisibleProperty Field
Identifies the AreMaximizedWindowFramesVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreMaximizedWindowFramesVisibleProperty
Public Shared ReadOnly AreMaximizedWindowFramesVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreMaximizedWindowFramesVisible dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.AreWindowsMaximizedProperty Field

StandardMdiHostAreWindowsMaximizedProperty Field
Identifies the AreWindowsMaximized dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreWindowsMaximizedProperty
Public Shared ReadOnly AreWindowsMaximizedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreWindowsMaximized dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.CanWindowsMaximizeProperty Field

StandardMdiHostCanWindowsMaximizeProperty Field
Identifies the CanWindowsMaximize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanWindowsMaximizeProperty
Public Shared ReadOnly CanWindowsMaximizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanWindowsMaximize dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.CanWindowsMinimizeProperty Field

StandardMdiHostCanWindowsMinimizeProperty Field
Identifies the CanWindowsMinimize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanWindowsMinimizeProperty
Public Shared ReadOnly CanWindowsMinimizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanWindowsMinimize dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.IsAutoCascadeEnabledProperty Field

StandardMdiHostIsAutoCascadeEnabledProperty Field
Identifies the IsAutoCascadeEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoCascadeEnabledProperty
Public Shared ReadOnly IsAutoCascadeEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoCascadeEnabled dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.IsExternalMaximizedUIRequiredProperty Field

StandardMdiHostIsExternalMaximizedUIRequiredProperty Field
Identifies the IsExternalMaximizedUIRequired dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExternalMaximizedUIRequiredProperty
Public Shared ReadOnly IsExternalMaximizedUIRequiredProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExternalMaximizedUIRequired dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardMdiHost.IsScrollingEnabledProperty Field

StandardMdiHostIsScrollingEnabledProperty Field
Identifies the IsScrollingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsScrollingEnabledProperty
Public Shared ReadOnly IsScrollingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsScrollingEnabled dependency property.
See Also

Reference

StandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher Class

StandardSwitcher Class
Implements a SwitcherBase that is similar to the switcher found in Visual Studio.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSwitcherBase
ActiproSoftware.UI.Xaml.Controls.DockingStandardSwitcher

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardSwitcher : SwitcherBase
Public Class StandardSwitcher
    Inherits SwitcherBase

The StandardSwitcher type exposes the following members.

Constructors
 | Name | Description
Public method | StandardSwitcher | Initializes an instance of the StandardSwitcher class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreDocumentsVisible | Gets or sets a value indicating whether the documents are visible in the switcher.
Public property | AreToolWindowsVisible | Gets or sets a value indicating whether the tool windows are visible in the switcher.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | FooterTemplate | Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HeaderTemplate | Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for rendering items.
Public property | ItemTemplate | Gets or sets the DataTemplate to use for rendering items.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxDocumentColumnCount | Gets or sets the maximum number of document columns to display.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxRowCount | Gets or sets the maximum number of item rows that can be displayed.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ScrollButtonStyle | Gets or sets the Style to use for a scroll button.
Public property | ScrollDownButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll down button content.
Public property | ScrollUpButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll up button content.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Invoked when the switcher is closed. (Overrides SwitcherBaseOnClosed.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides SwitcherBaseOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Overrides SwitcherBaseOnOpened.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreDocumentsVisibleProperty | Identifies the AreDocumentsVisible dependency property. This field is read-only.
AreToolWindowsVisibleProperty | Identifies the AreToolWindowsVisible dependency property. This field is read-only.
FooterTemplateProperty | Identifies the FooterTemplate dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
MaxDocumentColumnCountProperty | Identifies the MaxDocumentColumnCount dependency property. This field is read-only.
MaxRowCountProperty | Identifies the MaxRowCount dependency property. This field is read-only.
ScrollButtonStyleProperty | Identifies the ScrollButtonStyle dependency property. This field is read-only.
ScrollDownButtonContentTemplateProperty | Identifies the ScrollDownButtonContentTemplate dependency property. This field is read-only.
ScrollUpButtonContentTemplateProperty | Identifies the ScrollUpButtonContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher Constructor

StandardSwitcher Constructor
Initializes an instance of the StandardSwitcher class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardSwitcher()
Public Sub New
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher Properties

StandardSwitcher Properties

The StandardSwitcher type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreDocumentsVisible | Gets or sets a value indicating whether the documents are visible in the switcher.
Public property | AreToolWindowsVisible | Gets or sets a value indicating whether the tool windows are visible in the switcher.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active. (Inherited from SwitcherBase.)
Public property | Documents | Gets the collection of open documents in the MDI area. (Inherited from SwitcherBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | FooterTemplate | Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HeaderTemplate | Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets whether the switcher is currently open and active. (Inherited from SwitcherBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for rendering items.
Public property | ItemTemplate | Gets or sets the DataTemplate to use for rendering items.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxDocumentColumnCount | Gets or sets the maximum number of document columns to display.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxRowCount | Gets or sets the maximum number of item rows that can be displayed.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ScrollButtonStyle | Gets or sets the Style to use for a scroll button.
Public property | ScrollDownButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll down button content.
Public property | ScrollUpButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll up button content.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected. (Inherited from SwitcherBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area. (Inherited from SwitcherBase.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.AreDocumentsVisible Property

StandardSwitcherAreDocumentsVisible Property
Gets or sets a value indicating whether the documents are visible in the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreDocumentsVisible { get; set; }
Public Property AreDocumentsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the documents are visible in the switcher; otherwise false. The default value is true.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.AreToolWindowsVisible Property

StandardSwitcherAreToolWindowsVisible Property
Gets or sets a value indicating whether the tool windows are visible in the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreToolWindowsVisible { get; set; }
Public Property AreToolWindowsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tool windows are visible in the switcher; otherwise false. The default value is true.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.FooterTemplate Property

StandardSwitcherFooterTemplate Property
Gets or sets the DataTemplate to use for the footer area of the switcher, whose content is the SelectedWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate FooterTemplate { get; set; }
Public Property FooterTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the footer area of the switcher.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.HeaderTemplate Property

StandardSwitcherHeaderTemplate Property
Gets or sets the DataTemplate to use for the header area of the switcher, whose content is the SelectedWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate HeaderTemplate { get; set; }
Public Property HeaderTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the header area of the switcher.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ItemContainerStyle Property

StandardSwitcherItemContainerStyle Property
Gets or sets the Style to use for rendering items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ItemContainerStyle { get; set; }
Public Property ItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for rendering items.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ItemTemplate Property

StandardSwitcherItemTemplate Property
Gets or sets the DataTemplate to use for rendering items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ItemTemplate { get; set; }
Public Property ItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering items.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.MaxDocumentColumnCount Property

StandardSwitcherMaxDocumentColumnCount Property
Gets or sets the maximum number of document columns to display.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int MaxDocumentColumnCount { get; set; }
Public Property MaxDocumentColumnCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of document columns to display. The default value is 3.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.MaxRowCount Property

StandardSwitcherMaxRowCount Property
Gets or sets the maximum number of item rows that can be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int MaxRowCount { get; set; }
Public Property MaxRowCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of item rows that can be displayed. The default value is 15.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ScrollButtonStyle Property

StandardSwitcherScrollButtonStyle Property
Gets or sets the Style to use for a scroll button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ScrollButtonStyle { get; set; }
Public Property ScrollButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for a scroll button.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ScrollDownButtonContentTemplate Property

StandardSwitcherScrollDownButtonContentTemplate Property
Gets or sets the DataTemplate to use for the scroll down button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollDownButtonContentTemplate { get; set; }
Public Property ScrollDownButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll down button content.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ScrollUpButtonContentTemplate Property

StandardSwitcherScrollUpButtonContentTemplate Property
Gets or sets the DataTemplate to use for the scroll up button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollUpButtonContentTemplate { get; set; }
Public Property ScrollUpButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the scroll up button content.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher Methods

StandardSwitcher Methods

The StandardSwitcher type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the switcher. (Inherited from SwitcherBase.)
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher. (Inherited from SwitcherBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher. (Inherited from SwitcherBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Invoked when the switcher is closed. (Overrides SwitcherBaseOnClosed.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides SwitcherBaseOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Inherited from SwitcherBase.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from SwitcherBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened. (Overrides SwitcherBaseOnOpened.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides SwitcherBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | SelectNextDocument | Selects the next document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousDocument | Selects the previous document in the switcher. (Inherited from SwitcherBase.)
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher. (Inherited from SwitcherBase.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.OnApplyTemplate Method

StandardSwitcherOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.OnClosed Method

StandardSwitcherOnClosed Method
Invoked when the switcher is closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.OnKeyDown Method

StandardSwitcherOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.OnOpened Method

StandardSwitcherOnOpened Method
Invoked when the switcher is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnOpened()
Protected Overrides Sub OnOpened
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.OnSelectedWindowChanged Method

StandardSwitcherOnSelectedWindowChanged Method
Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnSelectedWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overrides Sub OnSelectedWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new value.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher Events

StandardSwitcher Events

The StandardSwitcher type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher Fields

StandardSwitcher Fields

The StandardSwitcher type exposes the following members.

Fields
Name | Description
AreDocumentsVisibleProperty | Identifies the AreDocumentsVisible dependency property. This field is read-only.
AreToolWindowsVisibleProperty | Identifies the AreToolWindowsVisible dependency property. This field is read-only.
FooterTemplateProperty | Identifies the FooterTemplate dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemTemplateProperty | Identifies the ItemTemplate dependency property. This field is read-only.
MaxDocumentColumnCountProperty | Identifies the MaxDocumentColumnCount dependency property. This field is read-only.
MaxRowCountProperty | Identifies the MaxRowCount dependency property. This field is read-only.
ScrollButtonStyleProperty | Identifies the ScrollButtonStyle dependency property. This field is read-only.
ScrollDownButtonContentTemplateProperty | Identifies the ScrollDownButtonContentTemplate dependency property. This field is read-only.
ScrollUpButtonContentTemplateProperty | Identifies the ScrollUpButtonContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.AreDocumentsVisibleProperty Field

StandardSwitcherAreDocumentsVisibleProperty Field
Identifies the AreDocumentsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreDocumentsVisibleProperty
Public Shared ReadOnly AreDocumentsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreDocumentsVisible dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.AreToolWindowsVisibleProperty Field

StandardSwitcherAreToolWindowsVisibleProperty Field
Identifies the AreToolWindowsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreToolWindowsVisibleProperty
Public Shared ReadOnly AreToolWindowsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreToolWindowsVisible dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.FooterTemplateProperty Field

StandardSwitcherFooterTemplateProperty Field
Identifies the FooterTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FooterTemplateProperty
Public Shared ReadOnly FooterTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FooterTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.HeaderTemplateProperty Field

StandardSwitcherHeaderTemplateProperty Field
Identifies the HeaderTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateProperty
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ItemContainerStyleProperty Field

StandardSwitcherItemContainerStyleProperty Field
Identifies the ItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemContainerStyleProperty
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemContainerStyle dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ItemTemplateProperty Field

StandardSwitcherItemTemplateProperty Field
Identifies the ItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemTemplateProperty
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.MaxDocumentColumnCountProperty Field

StandardSwitcherMaxDocumentColumnCountProperty Field
Identifies the MaxDocumentColumnCount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxDocumentColumnCountProperty
Public Shared ReadOnly MaxDocumentColumnCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxDocumentColumnCount dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.MaxRowCountProperty Field

StandardSwitcherMaxRowCountProperty Field
Identifies the MaxRowCount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxRowCountProperty
Public Shared ReadOnly MaxRowCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxRowCount dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ScrollButtonStyleProperty Field

StandardSwitcherScrollButtonStyleProperty Field
Identifies the ScrollButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollButtonStyleProperty
Public Shared ReadOnly ScrollButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollButtonStyle dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ScrollDownButtonContentTemplateProperty Field

StandardSwitcherScrollDownButtonContentTemplateProperty Field
Identifies the ScrollDownButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollDownButtonContentTemplateProperty
Public Shared ReadOnly ScrollDownButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollDownButtonContentTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


StandardSwitcher.ScrollUpButtonContentTemplateProperty Field

StandardSwitcherScrollUpButtonContentTemplateProperty Field
Identifies the ScrollUpButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollUpButtonContentTemplateProperty
Public Shared ReadOnly ScrollUpButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollUpButtonContentTemplate dependency property.
See Also

Reference

StandardSwitcher Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer Class

TabbedMdiContainer Class
Represents a container of one or more documents in tabbed MDI.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockingWindowContainerBase
ActiproSoftware.UI.Xaml.Controls.DockingTabbedMdiContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TabbedMdiContainer : DockingWindowContainerBase,
    IDockTarget, IOrientedElement
Public Class TabbedMdiContainer
    Inherits DockingWindowContainerBase
    Implements IDockTarget, IOrientedElement

The TabbedMdiContainer type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiContainer | Initializes an instance of the TabbedMdiContainer class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from DockingWindowContainerBase.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides DockingWindowContainerBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed. (Overrides DockingWindowContainerBaseOnWindowsChanged(NotifyCollectionChangedEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Inherited from DockingWindowContainerBase.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateVisualState | Updates the visual state. (Inherited from DockingWindowContainerBase.)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Inherited from DockingWindowContainerBase.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer Constructor

TabbedMdiContainer Constructor
Initializes an instance of the TabbedMdiContainer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabbedMdiContainer()
Public Sub New
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer Properties

TabbedMdiContainer Properties

The TabbedMdiContainer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available.
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasNewTabButton Property

TabbedMdiContainerHasNewTabButton Property
Gets or sets whether a new tab button is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasNewTabButton { get; set; }
Public Property HasNewTabButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a new tab button is visible; otherwise, false. The default value is false.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasTabCloseButtons Property

TabbedMdiContainerHasTabCloseButtons Property
Gets or sets whether close buttons should appear on document tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabCloseButtons { get; set; }
Public Property HasTabCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if close buttons should appear on document tabs; otherwise, false. The default value is true.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasTabPinButtons Property

TabbedMdiContainerHasTabPinButtons Property
Gets or sets whether pin buttons should appear on document tabs (normal layout kind).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabPinButtons { get; set; }
Public Property HasTabPinButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if pin buttons should appear on document tabs (normal layout kind); otherwise, false. The default value is false.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasTabPromoteButtons Property

TabbedMdiContainerHasTabPromoteButtons Property
Gets or sets whether promote buttons should appear on document tabs (preview layout kind).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabPromoteButtons { get; set; }
Public Property HasTabPromoteButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if promote buttons should appear on document tabs (preview layout kind); otherwise, false. The default value is true.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.Windows Property

TabbedMdiContainerWindows Property
Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer Methods

TabbedMdiContainer Methods

The TabbedMdiContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from DockingWindowContainerBase.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Overrides DockingWindowContainerBaseOnSelectedWindowChanged(DockingWindow, DockingWindow).)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed. (Overrides DockingWindowContainerBaseOnWindowsChanged(NotifyCollectionChangedEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Inherited from DockingWindowContainerBase.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Inherited from DockingWindowContainerBase.)
Protected method | UpdateVisualState | Updates the visual state. (Inherited from DockingWindowContainerBase.)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Inherited from DockingWindowContainerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.OnCreateAutomationPeer Method

TabbedMdiContainerOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.OnDockSiteChanged Method

TabbedMdiContainerOnDockSiteChanged Method
Occurs when the DockSite property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDockSiteChanged(
    DockSite oldDockSite,
    DockSite newDockSite
)
Protected Overrides Sub OnDockSiteChanged (
    oldDockSite As DockSite,
    newDockSite As DockSite
)

Parameters

oldDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The old value.
newDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The new value.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.OnKeyDown Method

TabbedMdiContainerOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.OnSelectedWindowChanged Method

TabbedMdiContainerOnSelectedWindowChanged Method
Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnSelectedWindowChanged(
    DockingWindow oldSelectedWindow,
    DockingWindow newSelectedWindow
)
Protected Overrides Sub OnSelectedWindowChanged (
    oldSelectedWindow As DockingWindow,
    newSelectedWindow As DockingWindow
)

Parameters

oldSelectedWindow
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old selected window.
newSelectedWindow
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new selected window.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.OnTabControlMenuOpening Method

TabbedMdiContainerOnTabControlMenuOpening Method
Occurs when a menu on the tab control is opening.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnTabControlMenuOpening(
    AdvancedTabControlMenuEventArgs e
)
Protected Overrides Sub OnTabControlMenuOpening (
    e As AdvancedTabControlMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControlMenuEventArgs
The AdvancedTabControlMenuEventArgs that contains the event data.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.OnWindowsChanged Method

TabbedMdiContainerOnWindowsChanged Method
Occurs when the Windows collection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnWindowsChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overrides Sub OnWindowsChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
A NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.UpdateDockingWindowStates Method

TabbedMdiContainerUpdateDockingWindowStates Method
Updates the DockingWindowState associated with all child docking windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateDockingWindowStates()
Protected Overrides Sub UpdateDockingWindowStates
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer Events

TabbedMdiContainer Events

The TabbedMdiContainer type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer Fields

TabbedMdiContainer Fields

The TabbedMdiContainer type exposes the following members.

Fields
Name | Description
HasNewTabButtonProperty | Identifies the HasNewTabButton dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
Top
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasNewTabButtonProperty Field

TabbedMdiContainerHasNewTabButtonProperty Field
Identifies the HasNewTabButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasNewTabButtonProperty
Public Shared ReadOnly HasNewTabButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasNewTabButton dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasTabCloseButtonsProperty Field

TabbedMdiContainerHasTabCloseButtonsProperty Field
Identifies the HasTabCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabCloseButtonsProperty
Public Shared ReadOnly HasTabCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabCloseButtons dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasTabPinButtonsProperty Field

TabbedMdiContainerHasTabPinButtonsProperty Field
Identifies the HasTabPinButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPinButtonsProperty
Public Shared ReadOnly HasTabPinButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPinButtons dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiContainer.HasTabPromoteButtonsProperty Field

TabbedMdiContainerHasTabPromoteButtonsProperty Field
Identifies the HasTabPromoteButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPromoteButtonsProperty
Public Shared ReadOnly HasTabPromoteButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPromoteButtons dependency property.
See Also

Reference

TabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost Class

TabbedMdiHost Class
Represents a container that hosts docking windows in a tabbed MDI (multiple-document interface) mode.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesMdiHostBase
ActiproSoftware.UI.Xaml.Controls.DockingTabbedMdiHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TabbedMdiHost : MdiHostBase,
    IDockTarget
Public Class TabbedMdiHost
    Inherits MdiHostBase
    Implements IDockTarget

The TabbedMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiHost | Initializes an instance of the TabbedMdiHost class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDocumentsAttach | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping.
Public property | CanDocumentsCloseOnMiddleClick | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button.
Public property | CanDocumentsDock | Gets or sets the global setting for whether documents can be docked to a new container.
Public property | CanDocumentTabsDrag | Gets or sets the global setting for whether document tabs may be dragged to another location.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets the FrameworkElement child of the host, which can be a SplitContainer or TabbedMdiContainer.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainersHaveNewTabButtons | Gets or sets whether containers have new tab buttons.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmptyContent | Gets or sets the content to display when there are no documents visible in the host.
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no documents visible in the host.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether document tabs display an embedded image when one is available.
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained tab controls in a TabbedMdiContainer.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the overflow behavior of the document tabs.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | Cascade | Cascades the open documents.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from MdiHostBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Overrides MdiHostBaseOnDockHostChanged(DockHost, DockHost).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Inherited from MdiHostBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileHorizontally(Int32) | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | TileVertically(Int32) | Tiles the open documents horizontally.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CanDocumentsAttachProperty | Identifies the CanDocumentsAttach dependency property. This field is read-only.
CanDocumentsCloseOnMiddleClickProperty | Identifies the CanDocumentsCloseOnMiddleClick dependency property. This field is read-only.
CanDocumentsDockProperty | Identifies the CanDocumentsDock dependency property. This field is read-only.
CanDocumentTabsDragProperty | Identifies the CanDocumentTabsDrag dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ContainersHaveNewTabButtonsProperty | Identifies the ContainersHaveNewTabButtons dependency property. This field is read-only.
EmptyContentProperty | Identifies the EmptyContent dependency property. This field is read-only.
EmptyContentTemplateProperty | Identifies the EmptyContentTemplate dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost Constructor

TabbedMdiHost Constructor
Initializes an instance of the TabbedMdiHost class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabbedMdiHost()
Public Sub New
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost Properties

TabbedMdiHost Properties

The TabbedMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDocumentsAttach | Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping.
Public property | CanDocumentsCloseOnMiddleClick | Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button.
Public property | CanDocumentsDock | Gets or sets the global setting for whether documents can be docked to a new container.
Public property | CanDocumentTabsDrag | Gets or sets the global setting for whether document tabs may be dragged to another location.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Child | Gets the FrameworkElement child of the host, which can be a SplitContainer or TabbedMdiContainer.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainersHaveNewTabButtons | Gets or sets whether containers have new tab buttons.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from MdiHostBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from MdiHostBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmptyContent | Gets or sets the content to display when there are no documents visible in the host.
Public property | EmptyContentTemplate | Gets or sets the DataTemplate to display when there are no documents visible in the host.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasTabCloseButtons | Gets or sets whether close buttons should appear on document tabs.
Public property | HasTabImages | Gets or sets whether document tabs display an embedded image when one is available.
Public property | HasTabPinButtons | Gets or sets whether pin buttons should appear on document tabs (normal layout kind).
Public property | HasTabPromoteButtons | Gets or sets whether promote buttons should appear on document tabs (preview layout kind).
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents). (Inherited from MdiHostBase.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host. (Inherited from MdiHostBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained tab controls in a TabbedMdiContainer.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the overflow behavior of the document tabs.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsAttach Property

TabbedMdiHostCanDocumentsAttach Property
Gets or sets the global setting for whether documents may be attached to another document, creating a tabbed grouping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentsAttach { get; set; }
Public Property CanDocumentsAttach As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documents may be attached to another document; otherwise, false. The default value is true.
Remarks
This setting only affects documents whose CanAttach property is set to . Any other setting on the document instance overrides this global setting.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsCloseOnMiddleClick Property

TabbedMdiHostCanDocumentsCloseOnMiddleClick Property
Gets or sets a value indicating whether documents can be closed by clicking the tab with the middle mouse button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentsCloseOnMiddleClick { get; set; }
Public Property CanDocumentsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documents can be closed by clicking the tab with the middle mouse button; otherwise, false. The default value is true.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsDock Property

TabbedMdiHostCanDocumentsDock Property
Gets or sets the global setting for whether documents can be docked to a new container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentsDock { get; set; }
Public Property CanDocumentsDock As Boolean
    Get
    Set

Property Value

Type: Boolean
true if documents can be docked to a new container; otherwise, false. The default value is true.
Remarks
This setting only affects documents whose CanDock property is set to . Any other setting on the document instance overrides this global setting.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentTabsDrag Property

TabbedMdiHostCanDocumentTabsDrag Property
Gets or sets the global setting for whether document tabs may be dragged to another location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDocumentTabsDrag { get; set; }
Public Property CanDocumentTabsDrag As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document tabs may be dragged to another location; otherwise, false. The default value is true.
Remarks
This setting only affects documents whose CanDragTab property is set to . Any other setting on the document instance overrides this global setting.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.Child Property

TabbedMdiHostChild Property
Gets the FrameworkElement child of the host, which can be a SplitContainer or TabbedMdiContainer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement Child { get; set; }
Public Property Child As FrameworkElement
    Get
    Set

Property Value

Type: FrameworkElement
The FrameworkElement child of the host. The default value is .
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.ContainersHaveNewTabButtons Property

TabbedMdiHostContainersHaveNewTabButtons Property
Gets or sets whether containers have new tab buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ContainersHaveNewTabButtons { get; set; }
Public Property ContainersHaveNewTabButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if containers have new tab buttons; otherwise, false. The default value is false.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.EmptyContent Property

TabbedMdiHostEmptyContent Property
Gets or sets the content to display when there are no documents visible in the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object EmptyContent { get; set; }
Public Property EmptyContent As Object
    Get
    Set

Property Value

Type: Object
The content to display when there are no documents visible in the host.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.EmptyContentTemplate Property

TabbedMdiHostEmptyContentTemplate Property
Gets or sets the DataTemplate to display when there are no documents visible in the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate EmptyContentTemplate { get; set; }
Public Property EmptyContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to display when there are no documents visible in the host.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabCloseButtons Property

TabbedMdiHostHasTabCloseButtons Property
Gets or sets whether close buttons should appear on document tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabCloseButtons { get; set; }
Public Property HasTabCloseButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if close buttons should appear on document tabs; otherwise, false. The default value is true.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabImages Property

TabbedMdiHostHasTabImages Property
Gets or sets whether document tabs display an embedded image when one is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabImages { get; set; }
Public Property HasTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if document tabs display an embedded image when one is available; otherwise, false. The default value is false.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabPinButtons Property

TabbedMdiHostHasTabPinButtons Property
Gets or sets whether pin buttons should appear on document tabs (normal layout kind).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabPinButtons { get; set; }
Public Property HasTabPinButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if pin buttons should appear on document tabs (normal layout kind); otherwise, false. The default value is false.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabPromoteButtons Property

TabbedMdiHostHasTabPromoteButtons Property
Gets or sets whether promote buttons should appear on document tabs (preview layout kind).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabPromoteButtons { get; set; }
Public Property HasTabPromoteButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if promote buttons should appear on document tabs (preview layout kind); otherwise, false. The default value is true.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TabControlStyle Property

TabbedMdiHostTabControlStyle Property
Gets or sets the Style to use for the contained tab controls in a TabbedMdiContainer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TabControlStyle { get; set; }
Public Property TabControlStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the contained tab controls in a TabbedMdiContainer.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TabOverflowBehavior Property

TabbedMdiHostTabOverflowBehavior Property
Gets or sets the overflow behavior of the document tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabOverflowBehavior TabOverflowBehavior { get; set; }
Public Property TabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The overflow behavior of the document tabs. The default value is Menu.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TabStripPlacement Property

TabbedMdiHostTabStripPlacement Property
Gets or sets a Side indicating the side upon which the tabs are located.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
A Side indicating the side upon which the tabs are located. The default value is Top.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost Methods

TabbedMdiHost Methods

The TabbedMdiHost type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | Cascade | Cascades the open documents.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDocuments | Returns the list of docking windows within the MDI. (Overrides MdiHostBaseGetDocuments.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from MdiHostBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed. (Overrides MdiHostBaseOnDockHostChanged(DockHost, DockHost).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed. (Inherited from MdiHostBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileHorizontally(Int32) | Tiles the open documents horizontally.
Public method | TileVertically | Tiles the open documents vertically.
Public method | TileVertically(Int32) | Tiles the open documents horizontally.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.Cascade Method

TabbedMdiHostCascade Method
Cascades the open documents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Cascade()
Public Sub Cascade
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.GetDocuments Method

TabbedMdiHostGetDocuments Method
Returns the list of docking windows within the MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override sealed IList<DockingWindow> GetDocuments()
Public Overrides NotOverridable Function GetDocuments As IList(Of DockingWindow)

Return Value

Type: IList DockingWindow
The list of docking windows within the MDI.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.OnDockHostChanged Method

TabbedMdiHostOnDockHostChanged Method
Occurs when the value of the DockHost property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDockHostChanged(
    DockHost oldValue,
    DockHost newValue
)
Protected Overrides Sub OnDockHostChanged (
    oldValue As DockHost,
    newValue As DockHost
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The new value.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TileHorizontally Method

TabbedMdiHostTileHorizontally Method
Overload List
 | Name | Description
Public method | TileHorizontally | Tiles the open documents horizontally.
Public method | TileHorizontally(Int32) | Tiles the open documents horizontally.
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TileHorizontally Method

TabbedMdiHostTileHorizontally Method
Tiles the open documents horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileHorizontally()
Public Sub TileHorizontally
See Also

Reference

TabbedMdiHost Class
TileHorizontally Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TileHorizontally Method (Int32)

TabbedMdiHostTileHorizontally Method (Int32)
Tiles the open documents horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileHorizontally(
    int maxColumnCount
)
Public Sub TileHorizontally (
    maxColumnCount As Integer
)

Parameters

maxColumnCount
Type: SystemInt32
The maximum column count
See Also

Reference

TabbedMdiHost Class
TileHorizontally Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TileVertically Method

TabbedMdiHostTileVertically Method
Overload List
 | Name | Description
Public method | TileVertically | Tiles the open documents vertically.
Public method | TileVertically(Int32) | Tiles the open documents horizontally.
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TileVertically Method

TabbedMdiHostTileVertically Method
Tiles the open documents vertically.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileVertically()
Public Sub TileVertically
See Also

Reference

TabbedMdiHost Class
TileVertically Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TileVertically Method (Int32)

TabbedMdiHostTileVertically Method (Int32)
Tiles the open documents horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void TileVertically(
    int maxRowCount
)
Public Sub TileVertically (
    maxRowCount As Integer
)

Parameters

maxRowCount
Type: SystemInt32
The maximum row count
See Also

Reference

TabbedMdiHost Class
TileVertically Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost Events

TabbedMdiHost Events

The TabbedMdiHost type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed. (Inherited from MdiHostBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost Fields

TabbedMdiHost Fields

The TabbedMdiHost type exposes the following members.

Fields
Name | Description
CanDocumentsAttachProperty | Identifies the CanDocumentsAttach dependency property. This field is read-only.
CanDocumentsCloseOnMiddleClickProperty | Identifies the CanDocumentsCloseOnMiddleClick dependency property. This field is read-only.
CanDocumentsDockProperty | Identifies the CanDocumentsDock dependency property. This field is read-only.
CanDocumentTabsDragProperty | Identifies the CanDocumentTabsDrag dependency property. This field is read-only.
ChildProperty | Identifies the Child dependency property. This field is read-only.
ContainersHaveNewTabButtonsProperty | Identifies the ContainersHaveNewTabButtons dependency property. This field is read-only.
EmptyContentProperty | Identifies the EmptyContent dependency property. This field is read-only.
EmptyContentTemplateProperty | Identifies the EmptyContentTemplate dependency property. This field is read-only.
HasTabCloseButtonsProperty | Identifies the HasTabCloseButtons dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
HasTabPinButtonsProperty | Identifies the HasTabPinButtons dependency property. This field is read-only.
HasTabPromoteButtonsProperty | Identifies the HasTabPromoteButtons dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsAttachProperty Field

TabbedMdiHostCanDocumentsAttachProperty Field
Identifies the CanDocumentsAttach dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentsAttachProperty
Public Shared ReadOnly CanDocumentsAttachProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentsAttach dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsCloseOnMiddleClickProperty Field

TabbedMdiHostCanDocumentsCloseOnMiddleClickProperty Field
Identifies the CanDocumentsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentsCloseOnMiddleClickProperty
Public Shared ReadOnly CanDocumentsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentsCloseOnMiddleClick dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentsDockProperty Field

TabbedMdiHostCanDocumentsDockProperty Field
Identifies the CanDocumentsDock dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentsDockProperty
Public Shared ReadOnly CanDocumentsDockProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentsDock dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.CanDocumentTabsDragProperty Field

TabbedMdiHostCanDocumentTabsDragProperty Field
Identifies the CanDocumentTabsDrag dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDocumentTabsDragProperty
Public Shared ReadOnly CanDocumentTabsDragProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDocumentTabsDrag dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.ChildProperty Field

TabbedMdiHostChildProperty Field
Identifies the Child dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ChildProperty
Public Shared ReadOnly ChildProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Child dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.ContainersHaveNewTabButtonsProperty Field

TabbedMdiHostContainersHaveNewTabButtonsProperty Field
Identifies the ContainersHaveNewTabButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainersHaveNewTabButtonsProperty
Public Shared ReadOnly ContainersHaveNewTabButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainersHaveNewTabButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.EmptyContentProperty Field

TabbedMdiHostEmptyContentProperty Field
Identifies the EmptyContent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmptyContentProperty
Public Shared ReadOnly EmptyContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmptyContent dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.EmptyContentTemplateProperty Field

TabbedMdiHostEmptyContentTemplateProperty Field
Identifies the EmptyContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmptyContentTemplateProperty
Public Shared ReadOnly EmptyContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmptyContentTemplate dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabCloseButtonsProperty Field

TabbedMdiHostHasTabCloseButtonsProperty Field
Identifies the HasTabCloseButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabCloseButtonsProperty
Public Shared ReadOnly HasTabCloseButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabCloseButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabImagesProperty Field

TabbedMdiHostHasTabImagesProperty Field
Identifies the HasTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabImagesProperty
Public Shared ReadOnly HasTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabImages dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabPinButtonsProperty Field

TabbedMdiHostHasTabPinButtonsProperty Field
Identifies the HasTabPinButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPinButtonsProperty
Public Shared ReadOnly HasTabPinButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPinButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.HasTabPromoteButtonsProperty Field

TabbedMdiHostHasTabPromoteButtonsProperty Field
Identifies the HasTabPromoteButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabPromoteButtonsProperty
Public Shared ReadOnly HasTabPromoteButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabPromoteButtons dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TabControlStyleProperty Field

TabbedMdiHostTabControlStyleProperty Field
Identifies the TabControlStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabControlStyleProperty
Public Shared ReadOnly TabControlStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabControlStyle dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TabOverflowBehaviorProperty Field

TabbedMdiHostTabOverflowBehaviorProperty Field
Identifies the TabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabOverflowBehaviorProperty
Public Shared ReadOnly TabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabOverflowBehavior dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabbedMdiHost.TabStripPlacementProperty Field

TabbedMdiHostTabStripPlacementProperty Field
Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

TabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode Class

TabFlashMode Class
Specifies the flash mode to apply to a tab.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingTabFlashMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TabFlashMode : Enum
Public NotInheritable Class TabFlashMode
    Inherits Enum

The TabFlashMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Blink | An all-on or all-off flash mode.
 | None | No flashing.
 | Smooth | A smooth transition flash mode.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode Methods

TabFlashMode Methods

The TabFlashMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TabFlashMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode Fields

TabFlashMode Fields

The TabFlashMode type exposes the following members.

Fields
 | Name | Description
 | Blink | An all-on or all-off flash mode.
 | None | No flashing.
 | Smooth | A smooth transition flash mode.
Public field | value__ |
Top
See Also

Reference

TabFlashMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode.Blink Field

TabFlashModeBlink Field
An all-on or all-off flash mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabFlashMode Blink = 1
Public Const Blink As TabFlashMode = 1

Field Value

Type: TabFlashMode
See Also

Reference

TabFlashMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode.None Field

TabFlashModeNone Field
No flashing.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabFlashMode None = 0
Public Const None As TabFlashMode = 0

Field Value

Type: TabFlashMode
See Also

Reference

TabFlashMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode.Smooth Field

TabFlashModeSmooth Field
A smooth transition flash mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabFlashMode Smooth = 2
Public Const Smooth As TabFlashMode = 2

Field Value

Type: TabFlashMode
See Also

Reference

TabFlashMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabFlashMode.value__ Field

TabFlashModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.TabFlashMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TabFlashMode Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind Class

TabHighlightKind Class
Specifies the kind of highlight to apply to a tab.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingTabHighlightKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TabHighlightKind : Enum
Public NotInheritable Class TabHighlightKind
    Inherits Enum

The TabHighlightKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ActiveSelected | Active selected, for a normal or pinned tab.
 | InactiveSelected | Inactive selected.
 | None | No highlight, for a normal or pinned tab.
 | PointerOver | Pointer over, for a normal or pinned tab.
 | Preview | No highlight, for a preview tab.
 | PreviewActiveSelected | Active selected, for a preview tab.
 | PreviewPointerOver | Pointer over, for a preview tab.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind Methods

TabHighlightKind Methods

The TabHighlightKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind Fields

TabHighlightKind Fields

The TabHighlightKind type exposes the following members.

Fields
 | Name | Description
 | ActiveSelected | Active selected, for a normal or pinned tab.
 | InactiveSelected | Inactive selected.
 | None | No highlight, for a normal or pinned tab.
 | PointerOver | Pointer over, for a normal or pinned tab.
 | Preview | No highlight, for a preview tab.
 | PreviewActiveSelected | Active selected, for a preview tab.
 | PreviewPointerOver | Pointer over, for a preview tab.
Public field | value__ |
Top
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.ActiveSelected Field

TabHighlightKindActiveSelected Field
Active selected, for a normal or pinned tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind ActiveSelected = 4
Public Const ActiveSelected As TabHighlightKind = 4

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.InactiveSelected Field

TabHighlightKindInactiveSelected Field
Inactive selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind InactiveSelected = 6
Public Const InactiveSelected As TabHighlightKind = 6

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.None Field

TabHighlightKindNone Field
No highlight, for a normal or pinned tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind None = 0
Public Const None As TabHighlightKind = 0

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.PointerOver Field

TabHighlightKindPointerOver Field
Pointer over, for a normal or pinned tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind PointerOver = 2
Public Const PointerOver As TabHighlightKind = 2

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.Preview Field

TabHighlightKindPreview Field
No highlight, for a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind Preview = 1
Public Const Preview As TabHighlightKind = 1

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.PreviewActiveSelected Field

TabHighlightKindPreviewActiveSelected Field
Active selected, for a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind PreviewActiveSelected = 5
Public Const PreviewActiveSelected As TabHighlightKind = 5

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.PreviewPointerOver Field

TabHighlightKindPreviewPointerOver Field
Pointer over, for a preview tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabHighlightKind PreviewPointerOver = 3
Public Const PreviewPointerOver As TabHighlightKind = 3

Field Value

Type: TabHighlightKind
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabHighlightKind.value__ Field

TabHighlightKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.TabHighlightKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TabHighlightKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind Class

TabLayoutKind Class
Specifies the kind of tab, which affects its layout.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingTabLayoutKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TabLayoutKind : Enum
Public NotInheritable Class TabLayoutKind
    Inherits Enum

The TabLayoutKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Normal | Indicates a normal tab.
 | Pinned | Indicates a tab that is pinned to the front of the tab strip.
 | Preview | Indicates a tab that is intended to be temporary and appears at the very end of the tab strip.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind Methods

TabLayoutKind Methods

The TabLayoutKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TabLayoutKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind Fields

TabLayoutKind Fields

The TabLayoutKind type exposes the following members.

Fields
 | Name | Description
 | Normal | Indicates a normal tab.
 | Pinned | Indicates a tab that is pinned to the front of the tab strip.
 | Preview | Indicates a tab that is intended to be temporary and appears at the very end of the tab strip.
Public field | value__ |
Top
See Also

Reference

TabLayoutKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind.Normal Field

TabLayoutKindNormal Field
Indicates a normal tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabLayoutKind Normal = 0
Public Const Normal As TabLayoutKind = 0

Field Value

Type: TabLayoutKind
See Also

Reference

TabLayoutKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind.Pinned Field

TabLayoutKindPinned Field
Indicates a tab that is pinned to the front of the tab strip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabLayoutKind Pinned = 1
Public Const Pinned As TabLayoutKind = 1

Field Value

Type: TabLayoutKind
See Also

Reference

TabLayoutKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind.Preview Field

TabLayoutKindPreview Field
Indicates a tab that is intended to be temporary and appears at the very end of the tab strip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabLayoutKind Preview = 2
Public Const Preview As TabLayoutKind = 2

Field Value

Type: TabLayoutKind
See Also

Reference

TabLayoutKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabLayoutKind.value__ Field

TabLayoutKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.TabLayoutKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TabLayoutKind Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior Class

TabOverflowBehavior Class
Indicates the overflow behavior of tabs.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingTabOverflowBehavior

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TabOverflowBehavior : Enum
Public NotInheritable Class TabOverflowBehavior
    Inherits Enum

The TabOverflowBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Menu | Indicates an overflow menu will be displayed.
 | None | Indicates no overflow behavior will be used.
 | Scroll | Indicates the tabs will support scrolling.
 | ScrollWithMenu | Indicates the tabs will support scrolling and an overflow menu will be displayed.
 | Shrink | Indicates the tabs will be stretched down to fit in the available space.
 | ShrinkWithMenu | Indicates the tabs will be stretched down to fit in the available space and an overflow menu will be displayed.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior Methods

TabOverflowBehavior Methods

The TabOverflowBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior Fields

TabOverflowBehavior Fields

The TabOverflowBehavior type exposes the following members.

Fields
 | Name | Description
 | Menu | Indicates an overflow menu will be displayed.
 | None | Indicates no overflow behavior will be used.
 | Scroll | Indicates the tabs will support scrolling.
 | ScrollWithMenu | Indicates the tabs will support scrolling and an overflow menu will be displayed.
 | Shrink | Indicates the tabs will be stretched down to fit in the available space.
 | ShrinkWithMenu | Indicates the tabs will be stretched down to fit in the available space and an overflow menu will be displayed.
Public field | value__ |
Top
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.Menu Field

TabOverflowBehaviorMenu Field
Indicates an overflow menu will be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabOverflowBehavior Menu = 1
Public Const Menu As TabOverflowBehavior = 1

Field Value

Type: TabOverflowBehavior
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.None Field

TabOverflowBehaviorNone Field
Indicates no overflow behavior will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabOverflowBehavior None = 0
Public Const None As TabOverflowBehavior = 0

Field Value

Type: TabOverflowBehavior
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.Scroll Field

TabOverflowBehaviorScroll Field
Indicates the tabs will support scrolling.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabOverflowBehavior Scroll = 4
Public Const Scroll As TabOverflowBehavior = 4

Field Value

Type: TabOverflowBehavior
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.ScrollWithMenu Field

TabOverflowBehaviorScrollWithMenu Field
Indicates the tabs will support scrolling and an overflow menu will be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabOverflowBehavior ScrollWithMenu = 5
Public Const ScrollWithMenu As TabOverflowBehavior = 5

Field Value

Type: TabOverflowBehavior
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.Shrink Field

TabOverflowBehaviorShrink Field
Indicates the tabs will be stretched down to fit in the available space.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabOverflowBehavior Shrink = 2
Public Const Shrink As TabOverflowBehavior = 2

Field Value

Type: TabOverflowBehavior
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.ShrinkWithMenu Field

TabOverflowBehaviorShrinkWithMenu Field
Indicates the tabs will be stretched down to fit in the available space and an overflow menu will be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TabOverflowBehavior ShrinkWithMenu = 3
Public Const ShrinkWithMenu As TabOverflowBehavior = 3

Field Value

Type: TabOverflowBehavior
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


TabOverflowBehavior.value__ Field

TabOverflowBehaviorvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.TabOverflowBehavior.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TabOverflowBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Class

ToolWindow Class
Represents a tool window.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
ActiproSoftware.UI.Xaml.Controls.DockingToolWindow

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindow : DockingWindow
Public Class ToolWindow
    Inherits DockingWindow

The ToolWindow type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindow | Initializes a new instance of the ToolWindow class. When creating instances of ToolWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | ToolWindow(Boolean) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the ToolWindow class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoHideCommand | Gets the ICommand that can move the window into an auto-hide state.
Public property | AutoHideTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAutoHide | Gets or sets whether the tool window may be placed in auto-hide mode.
Public property | CanAutoHideResolved | Gets a resolved value indicating whether the tool window may be placed in auto-hide mode.
Public property | CanBecomeDocument | Gets or sets whether the tool window may be placed in a document state.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainerAutoHideSize | Gets or sets the Size of the tool window's container when it is in an auto-hide state.
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultDockSide | Gets or sets the default Side that the tool window will dock towards when no prior location is known.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockCommand | Gets the ICommand that can move the window into a docked state.
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasOptionsButton | Gets or sets whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasOptionsButtonResolved | Gets a resolved value indicating whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasTitleBar | Gets or sets whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | HasTitleBarResolved | Gets a resolved value indicating whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsAutoHidePopupOpen | Gets whether the tool window is currently visible within an auto-hide popup.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | ToolWindowContainerTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.
Public property | ToolWindowContainerTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | Attach | Attaches the ToolWindow to the specified target, generally making a tabbed group.
Public method | AutoHide | Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the ToolWindow back to its default docked location.
Public method | Dock(IDockTarget, Side) | Docks the ToolWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the ToolWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCurrentSide | Returns a Side indicating where the tool window is located, if it is currently open.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Overrides DockingWindowOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains keyboard focus within its hierarchy. (Inherited from DockingWindow.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides DockingWindowToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Overrides DockingWindowUpdateCanBecomeDocumentResolved.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowUpdateCommands.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AutoHideTabContextContentTemplateProperty | Identifies the AutoHideTabContextContentTemplate dependency property. This field is read-only.
CanAutoHideProperty | Identifies the CanAutoHide dependency property. This field is read-only.
CanAutoHideResolvedProperty | Identifies the CanAutoHideResolved dependency property. This field is read-only.
CanBecomeDocumentProperty | Identifies the CanBecomeDocument dependency property. This field is read-only.
ContainerAutoHideSizeProperty | Identifies the ContainerAutoHideSize dependency property. This field is read-only.
DefaultDockSideProperty | Identifies the DefaultDockSide dependency property. This field is read-only.
HasOptionsButtonProperty | Identifies the HasOptionsButton dependency property. This field is read-only.
HasOptionsButtonResolvedProperty | Identifies the HasOptionsButtonResolved dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
HasTitleBarResolvedProperty | Identifies the HasTitleBarResolved dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
ToolWindowContainerTabContextContentTemplateProperty | Identifies the ToolWindowContainerTabContextContentTemplate dependency property. This field is read-only.
ToolWindowContainerTitleBarContextContentTemplateProperty | Identifies the ToolWindowContainerTitleBarContextContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Constructor

ToolWindow Constructor
Overload List
 | Name | Description
Public method | ToolWindow | Initializes a new instance of the ToolWindow class. When creating instances of ToolWindow programmatically, use a constructor that accepts a DockSite instead.
Public method | ToolWindow(Boolean) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite) | Initializes a new instance of the ToolWindow class.
Public method | ToolWindow(DockSite, String, String, ImageSource, Object) | Initializes a new instance of the ToolWindow class.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Constructor

ToolWindow Constructor
Initializes a new instance of the ToolWindow class. When creating instances of ToolWindow programmatically, use a constructor that accepts a DockSite instead.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow()
Public Sub New
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Constructor (Boolean)

ToolWindow Constructor (Boolean)
Initializes a new instance of the ToolWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow(
    bool isContainerForItem
)
Public Sub New (
    isContainerForItem As Boolean
)

Parameters

isContainerForItem
Type: SystemBoolean
Whether the window is a container for an item.
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Constructor (DockSite)

ToolWindow Constructor (DockSite)
Initializes a new instance of the ToolWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow(
    DockSite dockSite
)
Public Sub New (
    dockSite As DockSite
)

Parameters

dockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The DockSite with which to register this window.
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Constructor (DockSite, String, String, ImageSource, Object)

ToolWindow Constructor (DockSite, String, String, ImageSource, Object)
Initializes a new instance of the ToolWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow(
    DockSite dockSite,
    string serializationId,
    string title,
    ImageSource imageSource,
    Object content
)
Public Sub New (
    dockSite As DockSite,
    serializationId As String,
    title As String,
    imageSource As ImageSource,
    content As Object
)

Parameters

dockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The DockSite with which to register this window.
serializationId
Type: SystemString
The serialization ID of the window, used during layout serialization.
title
Type: SystemString
The title of the window.
imageSource
Type: Windows.UI.Xaml.MediaImageSource
The image source for the window's icon.
content
Type: SystemObject
The content of the window.
See Also

Reference

ToolWindow Class
ToolWindow Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Properties

ToolWindow Properties

The ToolWindow type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivateCommand | Gets or sets the ICommand that can Activate the window. (Inherited from DockingWindow.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoHideCommand | Gets the ICommand that can move the window into an auto-hide state.
Public property | AutoHideTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAttach | Gets or sets whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAttachResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CanAutoHide | Gets or sets whether the tool window may be placed in auto-hide mode.
Public property | CanAutoHideResolved | Gets a resolved value indicating whether the tool window may be placed in auto-hide mode.
Public property | CanBecomeDocument | Gets or sets whether the tool window may be placed in a document state.
Public property | CanBecomeDocumentResolved | Gets a resolved value indicating whether the window may be placed in a document state. (Inherited from DockingWindow.)
Public property | CanClose | Gets or sets whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanCloseResolved | Gets a resolved value indicating whether the window may be closed. (Inherited from DockingWindow.)
Public property | CanDock | Gets or sets whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDockResolved | Gets a resolved value indicating whether the window may be docked. (Inherited from DockingWindow.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragTab | Gets or sets whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragTabResolved | Gets a resolved value indicating whether the window's tab may be dragged to another location. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSites | Gets or sets whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanDragToLinkedDockSitesResolved | Gets a resolved value indicating whether the window may be dragged to a linked dock site. (Inherited from DockingWindow.)
Public property | CanFloat | Gets or sets whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanFloatResolved | Gets a resolved value indicating whether the window may be moved into a separate top-level floating DockHost that is external to the DockSite hierarchy's primary DockHost. (Inherited from DockingWindow.)
Public property | CanMoveToNewHorizontalContainer | Gets whether the window can move to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNewVerticalContainer | Gets whether the window can move to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToNextContainer | Gets whether the window can move to the next container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPreviousContainer | Gets whether the window can move to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | CanMoveToPrimaryMdiHost | Gets whether the window can move to the primary MDI host, which is the one directly within the main DockSite hierarchy and not on a floating DockHost. (Inherited from DockingWindow.)
Public property | CanSerialize | Gets or sets whether the window's layout information may be serialized. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximize | Gets or sets whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMaximizeResolved | Gets a resolved value indicating whether the window may be maximized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimize | Gets or sets whether the window may be minimized when hosted in a StandardMdiHost. (Inherited from DockingWindow.)
Public property | CanStandardMdiMinimizeResolved | Gets a resolved value indicating whether the window may be attached to another window, creating a tabbed grouping. (Inherited from DockingWindow.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can Close the window. (Inherited from DockingWindow.)
Public property | CloseOthersCommand | Gets or sets the ICommand that can close all other windows in the current container. (Inherited from DockingWindow.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainerAutoHideSize | Gets or sets the Size of the tool window's container when it is in an auto-hide state.
Public property | ContainerDockedSize | Gets or sets the Size of the docking window's container when it is in a docked state. (Inherited from DockingWindow.)
Public property | ContainerMaxSize | Gets or sets the maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMaxSizeResolved | Gets the resolved maximum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSize | Gets or sets the minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | ContainerMinSizeResolved | Gets the resolved minimum Size of the docking window's container. (Inherited from DockingWindow.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultDockSide | Gets or sets the default Side that the tool window will dock towards when no prior location is known.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets the description for the docking window, which may be used in Ctrl+Tab switching UI. (Inherited from DockingWindow.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DestroyCommand | Gets or sets the ICommand that can Destroy the window. (Inherited from DockingWindow.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockCommand | Gets the ICommand that can move the window into a docked state.
Public property | DockHost | Gets the DockHost in which the window is currently located. (Inherited from DockingWindow.)
Public property | DockSite | Gets the DockSite that is managing this docking window. (Inherited from DockingWindow.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FloatCommand | Gets the ICommand that can Float the window. (Inherited from DockingWindow.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasOptionsButton | Gets or sets whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasOptionsButtonResolved | Gets a resolved value indicating whether the tool window displays an options button in its ToolWindowContainer title bar.
Public property | HasTitleBar | Gets or sets whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | HasTitleBarResolved | Gets a resolved value indicating whether the tool window displays a title bar in its parent ToolWindowContainer.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the ImageSource specifying the 16x16 image for the docking window, used in switcher UI and also sometimes on tabs. (Inherited from DockingWindow.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the docking window is currently active, meaning the primary window that currently/last had focus. (Inherited from DockingWindow.)
Public property | IsAutoHidePopupOpen | Gets whether the tool window is currently visible within an auto-hide popup.
Public property | IsContainerForItem | Gets whether this window was auto-created as a container for an item, which occurs when using the DocumentItemsSource or ToolItemsSource properties. (Inherited from DockingWindow.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets whether the docking window is currently open in the layout. (Inherited from DockingWindow.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the docking window is currently selected in its parent container. (Inherited from DockingWindow.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from DockingWindow.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MoveToMdiCommand | Gets or sets the ICommand that can change the window into a document within a MDI area. (Inherited from DockingWindow.)
Public property | MoveToNewHorizontalContainerCommand | Gets or sets the ICommand that can move the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNewVerticalContainerCommand | Gets or sets the ICommand that can move the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToNextContainerCommand | Gets or sets the ICommand that can move the window to the next container. (Inherited from DockingWindow.)
Public property | MoveToPreviousContainerCommand | Gets or sets the ICommand that can move the window to the previous container within tabbed MDI. (Inherited from DockingWindow.)
Public property | MoveToPrimaryMdiHostCommand | Gets or sets the ICommand that can move the window to the primary MDI host. (Inherited from DockingWindow.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenCommand | Gets the ICommand that can Open the window. (Inherited from DockingWindow.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | ParentContainer | Gets the DockingWindowContainerBase that currently contains the window. (Inherited from DockingWindow.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SerializationId | Gets or sets the unique ID to use when matching up windows with serialized layout data. (Inherited from DockingWindow.)
Public property | SetTabbedMdiLayoutKindCommand | Gets or sets the ICommand that can set the TabbedMdiLayoutKind property to the TabLayoutKind value specified in the command parameter. (Inherited from DockingWindow.)
Public property | SizeToContentModes | Gets or sets a SizeToContentModes that indicates when to try to size-to-content. (Inherited from DockingWindow.)
Public property | StandardMdiBounds | Gets or sets the bounds of this docking window when in standard MDI 'restored' state. (Inherited from DockingWindow.)
Public property | StandardMdiTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a standard MDI window's title bar for this window. (Inherited from DockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the WindowState of this docking window when in standard MDI. (Inherited from DockingWindow.)
Public property | State | Gets or sets the DockingWindowState that specifies the current state of the window. (Inherited from DockingWindow.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabbedMdiLayoutKind | Gets or sets the TabLayoutKind that indicates how the tab will be positioned (normal, pinned, or preview). (Inherited from DockingWindow.)
Public property | TabbedMdiTabContextContentTemplate | Gets or sets the DataTemplate to use for displaying contextual content in a tabbed MDI tab. (Inherited from DockingWindow.)
Public property | TabFlashColor | Gets or sets the flash color to use if tab flashing is enabled. (Inherited from DockingWindow.)
Public property | TabFlashMode | Gets or sets the flash mode for the tab. (Inherited from DockingWindow.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabText | Gets or sets the optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTextResolved | Gets the resolved optional text to only display on tabs. (Inherited from DockingWindow.)
Public property | TabTintColor | Gets or sets the color used to tint the tab background and border brushes. (Inherited from DockingWindow.)
Public property | TabToolTip | Gets or sets the tooltip content to use for tabs that represent the window. (Inherited from DockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title for the docking window, which appears in several places throughout the UI. (Inherited from DockingWindow.)
Public property | ToolWindowContainerTabContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.
Public property | ToolWindowContainerTitleBarContextContentTemplate | Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UniqueId | Gets the Guid that uniquely identifies the control. (Inherited from DockingWindow.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowGroupName | Gets or sets an optional name that specifies a group of windows that have an affinity. (Inherited from DockingWindow.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.AutoHideCommand Property

ToolWindowAutoHideCommand Property
Gets the ICommand that can move the window into an auto-hide state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand AutoHideCommand { get; }
Public ReadOnly Property AutoHideCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window into an auto-hide state.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.AutoHideTabContextContentTemplate Property

ToolWindowAutoHideTabContextContentTemplate Property
Gets or sets the DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate AutoHideTabContextContentTemplate { get; set; }
Public Property AutoHideTabContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in an auto-hide tab for this window.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.CanAutoHide Property

ToolWindowCanAutoHide Property
Gets or sets whether the tool window may be placed in auto-hide mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanAutoHide { get; set; }
Public Property CanAutoHide As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window may be placed in auto-hide mode.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.CanAutoHideResolved Property

ToolWindowCanAutoHideResolved Property
Gets a resolved value indicating whether the tool window may be placed in auto-hide mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAutoHideResolved { get; }
Public ReadOnly Property CanAutoHideResolved As Boolean
    Get

Property Value

Type: Boolean
true if the tool window may be placed in auto-hide mode; otherwise, false.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.CanBecomeDocument Property

ToolWindowCanBecomeDocument Property
Gets or sets whether the tool window may be placed in a document state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanBecomeDocument { get; set; }
Public Property CanBecomeDocument As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window may be placed in a document state.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ContainerAutoHideSize Property

ToolWindowContainerAutoHideSize Property
Gets or sets the Size of the tool window's container when it is in an auto-hide state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerAutoHideSize { get; set; }
Public Property ContainerAutoHideSize As Size
    Get
    Set

Property Value

Type: Size
The Size of the tool window's container when it is in an auto-hide state.
Remarks
The container is a ToolWindowContainer.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.DefaultDockSide Property

ToolWindowDefaultDockSide Property
Gets or sets the default Side that the tool window will dock towards when no prior location is known.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side DefaultDockSide { get; set; }
Public Property DefaultDockSide As Side
    Get
    Set

Property Value

Type: Side
The default Side that the tool window will dock towards when no prior location is known. The default value is Right.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.DockCommand Property

ToolWindowDockCommand Property
Gets the ICommand that can move the window into a docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand DockCommand { get; }
Public ReadOnly Property DockCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can move the window into a docked state.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasOptionsButton Property

ToolWindowHasOptionsButton Property
Gets or sets whether the tool window displays an options button in its ToolWindowContainer title bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> HasOptionsButton { get; set; }
Public Property HasOptionsButton As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window displays an options button in its ToolWindowContainer title bar.
Remarks
If set to , the resolved value will use the global DockSite setting. If this value resolves to true then the window will display a drop-down menu button.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasOptionsButtonResolved Property

ToolWindowHasOptionsButtonResolved Property
Gets a resolved value indicating whether the tool window displays an options button in its ToolWindowContainer title bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasOptionsButtonResolved { get; }
Public ReadOnly Property HasOptionsButtonResolved As Boolean
    Get

Property Value

Type: Boolean
true if the tool window displays an options button in its ToolWindowContainer title bar; otherwise, false.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasTitleBar Property

ToolWindowHasTitleBar Property
Gets or sets whether the tool window displays a title bar in its parent ToolWindowContainer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> HasTitleBar { get; set; }
Public Property HasTitleBar As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the tool window displays a title bar in its parent ToolWindowContainer.
Remarks
If set to , the resolved value will use the global DockSite setting.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasTitleBarResolved Property

ToolWindowHasTitleBarResolved Property
Gets a resolved value indicating whether the tool window displays a title bar in its parent ToolWindowContainer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTitleBarResolved { get; }
Public ReadOnly Property HasTitleBarResolved As Boolean
    Get

Property Value

Type: Boolean
true if the tool window displays a title bar in its parent ToolWindowContainer; otherwise, false.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.IsAutoHidePopupOpen Property

ToolWindowIsAutoHidePopupOpen Property
Gets whether the tool window is currently visible within an auto-hide popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAutoHidePopupOpen { get; }
Public ReadOnly Property IsAutoHidePopupOpen As Boolean
    Get

Property Value

Type: Boolean
true if the tool window is currently visible within an auto-hide popup; otherwise, false. The default value is false.
Remarks
This property is only true when the tool window is an auto-hide State and it is the AutoHidePopupToolWindow in the containing dock host.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTabContextContentTemplate Property

ToolWindowToolWindowContainerTabContextContentTemplate Property
Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ToolWindowContainerTabContextContentTemplate { get; set; }
Public Property ToolWindowContainerTabContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in a tool window container's tab for this tool window.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTitleBarContextContentTemplate Property

ToolWindowToolWindowContainerTitleBarContextContentTemplate Property
Gets or sets the DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ToolWindowContainerTitleBarContextContentTemplate { get; set; }
Public Property ToolWindowContainerTitleBarContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing contextual content that should be rendered in a tool window container's title bar when this tool window is active.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Methods

ToolWindow Methods

The ToolWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the window by opening it (if closed), ensuring that it is brought to front, and focusing it. (Inherited from DockingWindow.)
Public method | Activate(Boolean) | Activates the window by opening it (if closed), ensuring that it is brought to front, and optionally focusing it. (Inherited from DockingWindow.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | Attach | Attaches the ToolWindow to the specified target, generally making a tabbed group.
Public method | AutoHide | Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window, removing it from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers | Closes all other windows marked as closeable in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | CloseOthers(Boolean) | Closes all other windows in the same parent container, removing them from the layout. (Inherited from DockingWindow.)
Public method | Destroy | Ensures the window is closed (removed from the layout) and also unregisters it from the DockSite. (Inherited from DockingWindow.)
Public method | Dock | Docks the ToolWindow back to its default docked location.
Public method | Dock(IDockTarget, Side) | Docks the ToolWindow to the side of a specified target.
Public method | DragMove | Programmatically starts a drag/move. (Inherited from DockingWindow.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the ToolWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCurrentSide | Returns a Side indicating where the tool window is located, if it is currently open.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveToFirst | Moves the DockingWindow to be the first item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToIndex | Moves the DockingWindow to the specified location in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLast | Moves the DockingWindow to be the last item in the current parent container. (Inherited from DockingWindow.)
Public method | MoveToLinkedDockSite | Moves the DockingWindow to the specified linked dock site. (Inherited from DockingWindow.)
Public method | MoveToMdi | Changes the DockingWindow into a document within a MDI area. (Inherited from DockingWindow.)
Public method | MoveToMdi(DockHost) | Changes the DockingWindow into a document within a specific DockHost's MDI area. (Inherited from DockingWindow.)
Public method | MoveToNewHorizontalContainer | Moves the window to a new horizontal container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNewVerticalContainer | Moves the window to a new vertical container within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToNextContainer | Moves the window to the next container (i.e. the one that appears after it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Public method | MoveToPreviousContainer | Moves the window to the previous container (i.e. the one that appears before it in the layout) within tabbed MDI. (Inherited from DockingWindow.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from DockingWindow.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the value of the DockSite property has changed. (Overrides DockingWindowOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains keyboard focus within its hierarchy. (Inherited from DockingWindow.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsSelectedChanged | Occurs when the value of the IsSelected property changes. (Inherited from DockingWindow.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from DockingWindow.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Occurs when the value of the State property has changed. (Overrides DockingWindowOnStateChanged(DockingWindowState, DockingWindowState).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | Open | Opens the window, inserting it into the layout. (Inherited from DockingWindow.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides DockingWindowToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCanAttachResolved | Updates the CanAttachResolved value. (Overrides DockingWindowUpdateCanAttachResolved.)
Protected method | UpdateCanBecomeDocumentResolved | Updates the CanBecomeDocumentResolved value. (Overrides DockingWindowUpdateCanBecomeDocumentResolved.)
Protected method | UpdateCanCloseResolved | Updates the CanCloseResolved value. (Overrides DockingWindowUpdateCanCloseResolved.)
Protected method | UpdateCanDockResolved | Updates the CanDockResolved value. (Overrides DockingWindowUpdateCanDockResolved.)
Protected method | UpdateCanDragTabResolved | Updates the CanDragTabResolved value. (Overrides DockingWindowUpdateCanDragTabResolved.)
Protected method | UpdateCanDragToLinkedDockSitesResolved | Updates the CanDragToLinkedDockSitesResolved value. (Overrides DockingWindowUpdateCanDragToLinkedDockSitesResolved.)
Protected method | UpdateCanFloatResolved | Updates the CanFloatResolved value. (Overrides DockingWindowUpdateCanFloatResolved.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowUpdateCommands.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.Attach Method

ToolWindowAttach Method
Attaches the ToolWindow to the specified target, generally making a tabbed group.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Attach(
    IDockTarget target
)
Public Sub Attach (
    target As IDockTarget
)

Parameters

target
Type: ActiproSoftware.UI.Xaml.Controls.DockingIDockTarget
The IDockTarget against which to attach.
Remarks
The target can be another docking window, TabbedMdiContainer, or ToolWindowContainer. Use the Dock(IDockTarget, Side) method to dock to the side of the target instead.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.AutoHide Method

ToolWindowAutoHide Method
Overload List
 | Name | Description
Public method | AutoHide | Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.AutoHide Method

ToolWindowAutoHide Method
Auto-hides the ToolWindow to the closest outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AutoHide()
Public Sub AutoHide
Remarks
Using this method places the ToolWindow in an AutoHide State. Use the AutoHide(Side) method overload to auto-hide to a specific side.
See Also

Reference

ToolWindow Class
AutoHide Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.AutoHide Method (Side)

ToolWindowAutoHide Method (Side)
Auto-hides the ToolWindow to the specified outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AutoHide(
    Side side
)
Public Sub AutoHide (
    side As Side
)

Parameters

side
Type: ActiproSoftware.UI.Xaml.ControlsSide
A Side indicating the side upon which to auto-hide.
Remarks
Using this method places the ToolWindow in an AutoHide State. Use the AutoHide method overload to auto-hide to the control's default side.
See Also

Reference

ToolWindow Class
AutoHide Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.Dock Method

ToolWindowDock Method
Overload List
 | Name | Description
Public method | Dock | Docks the ToolWindow back to its default docked location.
Public method | Dock(IDockTarget, Side) | Docks the ToolWindow to the side of a specified target.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.Dock Method

ToolWindowDock Method
Docks the ToolWindow back to its default docked location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dock()
Public Sub Dock
Remarks
Using this method places the ToolWindow in a Docked State. If the tool window isn't currently open or isn't in a Docked state, it will attempt to restore to the previous docked location. If one isn't available, a default docked location will be selected based on WindowGroupName, DefaultLocationRequested, and DefaultDockSide.
See Also

Reference

ToolWindow Class
Dock Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.Dock Method (IDockTarget, Side)

ToolWindowDock Method (IDockTarget, Side)
Docks the ToolWindow to the side of a specified target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dock(
    IDockTarget target,
    Side side
)
Public Sub Dock (
    target As IDockTarget,
    side As Side
)

Parameters

target
Type: ActiproSoftware.UI.Xaml.Controls.DockingIDockTarget
The IDockTarget that is the target of the dock.
side
Type: ActiproSoftware.UI.Xaml.ControlsSide
The target's Side against which to dock.
Remarks
Use the Dock method overload to dock back to its previous docked location. Use the Attach(IDockTarget) method to dock into a particular target.
See Also

Reference

ToolWindow Class
Dock Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.Float Method

ToolWindowFloat Method
Overload List
 | Name | Description
Public method | Float | Floats the window to a default location with its current size. (Inherited from DockingWindow.)
Public method | Float(Point) | Floats the window to the specified location with its current size. (Inherited from DockingWindow.)
Public method | Float(Size) | Floats the window to a default location with the specified size. (Inherited from DockingWindow.)
Public method | Float(NullablePoint, NullableSize) | Floats the ToolWindow to the specified optional location and size. (Overrides DockingWindowFloat(NullablePoint, NullableSize).)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.Float Method (Nullable(Point), Nullable(Size))

ToolWindowFloat Method (NullablePoint, NullableSize)
Floats the ToolWindow to the specified optional location and size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Float(
    Nullable<Point> location,
    Nullable<Size> size
)
Public Overrides Sub Float (
    location As Nullable(Of Point),
    size As Nullable(Of Size)
)

Parameters

location
Type: SystemNullable Point
An optional Point specifying the target location of the floating dock host.
size
Type: SystemNullable Size
An optional Size specifying the target size of the floating dock host.
Remarks
When location is not specified, it will float to a default location. When size is not specified, it will float with its current size. Using this method places the ToolWindow in a Docked State within a floating dock host.
See Also

Reference

ToolWindow Class
Float Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.GetCurrentSide Method

ToolWindowGetCurrentSide Method
Returns a Side indicating where the tool window is located, if it is currently open.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Side> GetCurrentSide()
Public Function GetCurrentSide As Nullable(Of Side)

Return Value

Type: Nullable Side
A Side indicating where the tool window is located, if it is currently open.
Remarks
If the tool window is open in a Document state, is returned. If the tool window is open in an AutoHide state, the auto-hide dock Side is returned. If the tool window is open in a Docked state and the containing dock host has a workspace (no tool window inner-fill), a Side indicating the location of the tool window relative to the workspace is returned. If the tool window is open in a Docked state and the containing dock host does not has a workspace (tool window inner-fill is active), a Side indicating the location of the tool window's midpoint relative to the dock host's bounds is returned. Otherwise, if the tool window is closed, is returned.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.OnCreateAutomationPeer Method

ToolWindowOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.OnDockSiteChanged Method

ToolWindowOnDockSiteChanged Method
Occurs when the value of the DockSite property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDockSiteChanged(
    DockSite oldValue,
    DockSite newValue
)
Protected Overrides Sub OnDockSiteChanged (
    oldValue As DockSite,
    newValue As DockSite
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The new value.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.OnStateChanged Method

ToolWindowOnStateChanged Method
Occurs when the value of the State property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnStateChanged(
    DockingWindowState oldValue,
    DockingWindowState newValue
)
Protected Overrides Sub OnStateChanged (
    oldValue As DockingWindowState,
    newValue As DockingWindowState
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowState
The new value.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ToString Method

ToolWindowToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanAttachResolved Method

ToolWindowUpdateCanAttachResolved Method
Updates the CanAttachResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanAttachResolved()
Protected Overrides Sub UpdateCanAttachResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanBecomeDocumentResolved Method

ToolWindowUpdateCanBecomeDocumentResolved Method
Updates the CanBecomeDocumentResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanBecomeDocumentResolved()
Protected Overrides Sub UpdateCanBecomeDocumentResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanCloseResolved Method

ToolWindowUpdateCanCloseResolved Method
Updates the CanCloseResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanCloseResolved()
Protected Overrides Sub UpdateCanCloseResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanDockResolved Method

ToolWindowUpdateCanDockResolved Method
Updates the CanDockResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanDockResolved()
Protected Overrides Sub UpdateCanDockResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanDragTabResolved Method

ToolWindowUpdateCanDragTabResolved Method
Updates the CanDragTabResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragTabResolved()
Protected Overrides Sub UpdateCanDragTabResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanDragToLinkedDockSitesResolved Method

ToolWindowUpdateCanDragToLinkedDockSitesResolved Method
Updates the CanDragToLinkedDockSitesResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanDragToLinkedDockSitesResolved()
Protected Overrides Sub UpdateCanDragToLinkedDockSitesResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCanFloatResolved Method

ToolWindowUpdateCanFloatResolved Method
Updates the CanFloatResolved value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCanFloatResolved()
Protected Overrides Sub UpdateCanFloatResolved
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.UpdateCommands Method

ToolWindowUpdateCommands Method
Updates the enabled states of the commands.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCommands()
Protected Overrides Sub UpdateCommands
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Events

ToolWindow Events

The ToolWindow type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DefaultLocationRequested | Occurs when a DockingWindow's default location is requested. (Inherited from DockingWindow.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from DockingWindow.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow Fields

ToolWindow Fields

The ToolWindow type exposes the following members.

Fields
Name | Description
AutoHideTabContextContentTemplateProperty | Identifies the AutoHideTabContextContentTemplate dependency property. This field is read-only.
CanAutoHideProperty | Identifies the CanAutoHide dependency property. This field is read-only.
CanAutoHideResolvedProperty | Identifies the CanAutoHideResolved dependency property. This field is read-only.
CanBecomeDocumentProperty | Identifies the CanBecomeDocument dependency property. This field is read-only.
ContainerAutoHideSizeProperty | Identifies the ContainerAutoHideSize dependency property. This field is read-only.
DefaultDockSideProperty | Identifies the DefaultDockSide dependency property. This field is read-only.
HasOptionsButtonProperty | Identifies the HasOptionsButton dependency property. This field is read-only.
HasOptionsButtonResolvedProperty | Identifies the HasOptionsButtonResolved dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
HasTitleBarResolvedProperty | Identifies the HasTitleBarResolved dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
ToolWindowContainerTabContextContentTemplateProperty | Identifies the ToolWindowContainerTabContextContentTemplate dependency property. This field is read-only.
ToolWindowContainerTitleBarContextContentTemplateProperty | Identifies the ToolWindowContainerTitleBarContextContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.AutoHideTabContextContentTemplateProperty Field

ToolWindowAutoHideTabContextContentTemplateProperty Field
Identifies the AutoHideTabContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoHideTabContextContentTemplateProperty
Public Shared ReadOnly AutoHideTabContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoHideTabContextContentTemplate dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.CanAutoHideProperty Field

ToolWindowCanAutoHideProperty Field
Identifies the CanAutoHide dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoHideProperty
Public Shared ReadOnly CanAutoHideProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoHide dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.CanAutoHideResolvedProperty Field

ToolWindowCanAutoHideResolvedProperty Field
Identifies the CanAutoHideResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoHideResolvedProperty
Public Shared ReadOnly CanAutoHideResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoHideResolved dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.CanBecomeDocumentProperty Field

ToolWindowCanBecomeDocumentProperty Field
Identifies the CanBecomeDocument dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanBecomeDocumentProperty
Public Shared ReadOnly CanBecomeDocumentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanBecomeDocument dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ContainerAutoHideSizeProperty Field

ToolWindowContainerAutoHideSizeProperty Field
Identifies the ContainerAutoHideSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainerAutoHideSizeProperty
Public Shared ReadOnly ContainerAutoHideSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainerAutoHideSize dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.DefaultDockSideProperty Field

ToolWindowDefaultDockSideProperty Field
Identifies the DefaultDockSide dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultDockSideProperty
Public Shared ReadOnly DefaultDockSideProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultDockSide dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasOptionsButtonProperty Field

ToolWindowHasOptionsButtonProperty Field
Identifies the HasOptionsButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasOptionsButtonProperty
Public Shared ReadOnly HasOptionsButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasOptionsButton dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasOptionsButtonResolvedProperty Field

ToolWindowHasOptionsButtonResolvedProperty Field
Identifies the HasOptionsButtonResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasOptionsButtonResolvedProperty
Public Shared ReadOnly HasOptionsButtonResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasOptionsButtonResolved dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasTitleBarProperty Field

ToolWindowHasTitleBarProperty Field
Identifies the HasTitleBar dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarProperty
Public Shared ReadOnly HasTitleBarProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBar dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.HasTitleBarResolvedProperty Field

ToolWindowHasTitleBarResolvedProperty Field
Identifies the HasTitleBarResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarResolvedProperty
Public Shared ReadOnly HasTitleBarResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBarResolved dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.IsAutoHidePopupOpenProperty Field

ToolWindowIsAutoHidePopupOpenProperty Field
Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoHidePopupOpenProperty
Public Shared ReadOnly IsAutoHidePopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoHidePopupOpen dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTabContextContentTemplateProperty Field

ToolWindowToolWindowContainerTabContextContentTemplateProperty Field
Identifies the ToolWindowContainerTabContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowContainerTabContextContentTemplateProperty
Public Shared ReadOnly ToolWindowContainerTabContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowContainerTabContextContentTemplate dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindow.ToolWindowContainerTitleBarContextContentTemplateProperty Field

ToolWindowToolWindowContainerTitleBarContextContentTemplateProperty Field
Identifies the ToolWindowContainerTitleBarContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToolWindowContainerTitleBarContextContentTemplateProperty
Public Shared ReadOnly ToolWindowContainerTitleBarContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToolWindowContainerTitleBarContextContentTemplate dependency property.
See Also

Reference

ToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowCollection Class

ToolWindowCollection Class
Represents an observable collection of ToolWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ToolWindow
System.Collections.ObjectModelObservableCollection ToolWindow
ActiproSoftware.UI.XamlDeferrableObservableCollection ToolWindow
ActiproSoftware.UI.Xaml.Controls.DockingDockingWindowCollectionBase ToolWindow
ActiproSoftware.UI.Xaml.Controls.DockingToolWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindowCollection : DockingWindowCollectionBase<ToolWindow>
Public Class ToolWindowCollection
    Inherits DockingWindowCollectionBase(Of ToolWindow)

The ToolWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowCollection | Initializes a new instance of the ToolWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection ToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | (Inherited from Collection ToolWindow .)
Protected property | Items | (Inherited from Collection ToolWindow .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection ToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection ToolWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection ToolWindow .)
Public method | Clear | (Inherited from Collection ToolWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection ToolWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | (Inherited from Collection ToolWindow .)
Public method | CopyTo | (Inherited from Collection ToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection ToolWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | (Inherited from Collection ToolWindow .)
Public method | Insert | (Inherited from Collection ToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection ToolWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection ToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection ToolWindow .)
Public method | RemoveAt | (Inherited from Collection ToolWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection ToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection ToolWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection ToolWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowCollection Constructor

ToolWindowCollection Constructor
Initializes a new instance of the ToolWindowCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowCollection()
Public Sub New
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowCollection Properties

ToolWindowCollection Properties

The ToolWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection ToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | ItemGuid | Gets the item with the specified UniqueId value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemString | Gets the item with the specified Name value. [C#] In C#, this property is the indexer for the collection. (Inherited from DockingWindowCollectionBaseT.)
Public property | ItemInt32 | (Inherited from Collection ToolWindow .)
Protected property | Items | (Inherited from Collection ToolWindow .)
Top
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowCollection Methods

ToolWindowCollection Methods

The ToolWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection ToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection ToolWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection ToolWindow .)
Public method | Clear | (Inherited from Collection ToolWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection ToolWindow .)
Public method | Contains(Guid) | Determines whether an item with the specified UniqueId value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(String) | Determines whether an item with the specified Name value is in the collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | Contains(T) | (Inherited from Collection ToolWindow .)
Public method | CopyTo | (Inherited from Collection ToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection ToolWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf(Guid) | Searches for an item with the specified UniqueId value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(String) | Searches for an item with the specified Name value and returns the zero-based index of the first occurrence within the entire collection. (Inherited from DockingWindowCollectionBaseT.)
Public method | IndexOf(T) | (Inherited from Collection ToolWindow .)
Public method | Insert | (Inherited from Collection ToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection ToolWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection ToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection ToolWindow .)
Public method | RemoveAt | (Inherited from Collection ToolWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection ToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowCollection Events

ToolWindowCollection Events

The ToolWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection ToolWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection ToolWindow .)
Top
See Also

Reference

ToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer Class

ToolWindowContainer Class
Represents a container of one or more tool windows.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockingWindowContainerBase
ActiproSoftware.UI.Xaml.Controls.DockingToolWindowContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindowContainer : DockingWindowContainerBase,
    IDockTarget, IOrientedElement
Public Class ToolWindowContainer
    Inherits DockingWindowContainerBase
    Implements IDockTarget, IOrientedElement

The ToolWindowContainer type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainer | Initializes an instance of the ToolWindowContainer class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoHideCommand | Gets the ICommand that can auto-hide the windows in the container.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can close the windows in the container.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockCommand | Gets the ICommand that can dock the windows in the container.
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the container has a title bar close button if the SelectedWindow is closable.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTitleBarIcon | Gets or sets whether the container is capable of displaying the selected window's icon in the title bar.
Public property | HasToggleAutoHideButton | Gets or sets whether the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsCloseButtonVisible | Gets whether the container's close button is visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the container's maximize button is visible.
Public property | IsMinimizeButtonVisible | Gets whether the container's minimize button is visible.
Public property | IsOptionsButtonVisible | Gets whether the container's options button is visible.
Public property | IsRestoreButtonVisible | Gets whether the container's restore button is visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsToggleAutoHideButtonVisible | Gets whether the container's toggle auto-hide button is visible.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeButtonContentTemplate | Gets or sets the DataTemplate to use for the maximize button content.
Public property | MaximizeCommand | Gets the ICommand that can maximize the window that hosts the container.
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeButtonContentTemplate | Gets or sets the DataTemplate to use for the minimize button content.
Public property | MinimizeCommand | Gets the ICommand that can minimize the window that hosts the container.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenOptionsMenuCommand | Gets the ICommand that can open the options menu.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreButtonContentTemplate | Gets or sets the DataTemplate to use for the restore button content.
Public property | RestoreCommand | Gets the ICommand that can restore the window that hosts the container.
Public property | SelectedToolWindow | Gets the ToolWindow that is currently selected in the container.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | SingleTabLayoutBehavior | Gets or sets the behavior used when a single ToolWindow is in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TitleBarContextContentAlignment | Gets or sets the alignment of title bar context content.
Public property | TitleFontFamily | Gets or sets the title's font family.
Public property | TitleFontSize | Gets or sets the title's font size.
Public property | TitleFontWeight | Gets or sets the title's font weight.
Public property | ToggleAutoHideCommand | Gets the ICommand that can toggle the container between an auto-hide and docked state.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | AutoHide | Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the tool windows in the container, removing them from the layout.
Public method | Dock | Docks the contained ToolWindow controls back to their default docked location.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides DockingWindowContainerBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed. (Inherited from DockingWindowContainerBase.)
Public method | OpenOptionsMenu | Options the options menu for the SelectedWindow.
Public method | OpenOptionsMenu(FrameworkElement) | Options the options menu for the SelectedWindow under the specified placement target element.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowContainerBaseUpdateCommands.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Overrides DockingWindowContainerBaseUpdateIsTabStripVisible.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Overrides DockingWindowContainerBaseUpdateTitleBarButtonVisibility.)
Protected method | UpdateVisualState | Updates the visual state. (Overrides DockingWindowContainerBaseUpdateVisualState(Boolean).)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Overrides DockingWindowContainerBaseValidateChildType(DockingWindow).)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasTitleBarIconProperty | Identifies the HasTitleBarIcon dependency property. This field is read-only.
HasToggleAutoHideButtonProperty | Identifies the HasToggleAutoHideButton dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsOptionsButtonVisibleProperty | Identifies the IsOptionsButtonVisible dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
IsToggleAutoHideButtonVisibleProperty | Identifies the IsToggleAutoHideButtonVisible dependency property. This field is read-only.
MaximizeButtonContentTemplateProperty | Identifies the MaximizeButtonContentTemplate dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinimizeButtonContentTemplateProperty | Identifies the MinimizeButtonContentTemplate dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
RestoreButtonContentTemplateProperty | Identifies the RestoreButtonContentTemplate dependency property. This field is read-only.
SingleTabLayoutBehaviorProperty | Identifies the SingleTabLayoutBehavior dependency property. This field is read-only.
TitleBarContextContentAlignmentProperty | Identifies the TitleBarContextContentAlignment dependency property. This field is read-only.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. This field is read-only.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. This field is read-only.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer Constructor

ToolWindowContainer Constructor
Initializes an instance of the ToolWindowContainer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainer()
Public Sub New
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer Properties

ToolWindowContainer Properties

The ToolWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoHideCommand | Gets the ICommand that can auto-hide the windows in the container.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from DockingWindowContainerBase.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseButtonContentTemplate | Gets or sets the DataTemplate to use for the close button content.
Public property | CloseCommand | Gets the ICommand that can close the windows in the container.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockCommand | Gets the ICommand that can dock the windows in the container.
Public property | DockHost | Gets the DockHost that contains this control. (Inherited from DockingWindowContainerBase.)
Public property | DockSite | Gets the DockSite that is managing this control. (Inherited from DockingWindowContainerBase.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the container has a title bar close button if the SelectedWindow is closable.
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from DockingWindowContainerBase.)
Public property | HasTitleBarIcon | Gets or sets whether the container is capable of displaying the selected window's icon in the title bar.
Public property | HasToggleAutoHideButton | Gets or sets whether the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it. (Inherited from DockingWindowContainerBase.)
Public property | IsCloseButtonVisible | Gets whether the container's close button is visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the container's maximize button is visible.
Public property | IsMinimizeButtonVisible | Gets whether the container's minimize button is visible.
Public property | IsOptionsButtonVisible | Gets whether the container's options button is visible.
Public property | IsRestoreButtonVisible | Gets whether the container's restore button is visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed. (Inherited from DockingWindowContainerBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible. (Inherited from DockingWindowContainerBase.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsToggleAutoHideButtonVisible | Gets whether the container's toggle auto-hide button is visible.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeButtonContentTemplate | Gets or sets the DataTemplate to use for the maximize button content.
Public property | MaximizeCommand | Gets the ICommand that can maximize the window that hosts the container.
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeButtonContentTemplate | Gets or sets the DataTemplate to use for the minimize button content.
Public property | MinimizeCommand | Gets the ICommand that can minimize the window that hosts the container.
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from DockingWindowContainerBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenOptionsMenuCommand | Gets the ICommand that can open the options menu.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PinButtonContentTemplate | Gets or sets the DataTemplate to use for the pin button content.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreButtonContentTemplate | Gets or sets the DataTemplate to use for the restore button content.
Public property | RestoreCommand | Gets the ICommand that can restore the window that hosts the container.
Public property | SelectedToolWindow | Gets the ToolWindow that is currently selected in the container.
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container. (Inherited from DockingWindowContainerBase.)
Public property | SingleTabLayoutBehavior | Gets or sets the behavior used when a single ToolWindow is in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container. (Inherited from DockingWindowContainerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Protected property | TabControl | Gets the tab control in the container's user interface. (Inherited from DockingWindowContainerBase.)
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl. (Inherited from DockingWindowContainerBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers. (Inherited from DockingWindowContainerBase.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from DockingWindowContainerBase.)
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located. (Inherited from DockingWindowContainerBase.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TitleBarContextContentAlignment | Gets or sets the alignment of title bar context content.
Public property | TitleFontFamily | Gets or sets the title's font family.
Public property | TitleFontSize | Gets or sets the title's font size.
Public property | TitleFontWeight | Gets or sets the title's font weight.
Public property | ToggleAutoHideCommand | Gets the ICommand that can toggle the container between an auto-hide and docked state.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UnpinButtonContentTemplate | Gets or sets the DataTemplate to use for the unpin button content.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Windows | Gets the collection of child DockingWindow objects.
Protected property | WindowsCore | Gets the collection of child DockingWindow objects. (Inherited from DockingWindowContainerBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.AutoHideCommand Property

ToolWindowContainerAutoHideCommand Property
Gets the ICommand that can auto-hide the windows in the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand AutoHideCommand { get; }
Public ReadOnly Property AutoHideCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can auto-hide the windows in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.CloseButtonContentTemplate Property

ToolWindowContainerCloseButtonContentTemplate Property
Gets or sets the DataTemplate to use for the close button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate CloseButtonContentTemplate { get; set; }
Public Property CloseButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the close button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.CloseCommand Property

ToolWindowContainerCloseCommand Property
Gets the ICommand that can close the windows in the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the windows in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.DockCommand Property

ToolWindowContainerDockCommand Property
Gets the ICommand that can dock the windows in the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand DockCommand { get; }
Public ReadOnly Property DockCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can dock the windows in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.EmbeddedButtonStyle Property

ToolWindowContainerEmbeddedButtonStyle Property
Gets or sets the Style to use for embedded buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style EmbeddedButtonStyle { get; set; }
Public Property EmbeddedButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for embedded buttons.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.HasCloseButton Property

ToolWindowContainerHasCloseButton Property
Gets or sets whether the container has a title bar close button if the SelectedWindow is closable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCloseButton { get; set; }
Public Property HasCloseButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the container has a title bar close button if the SelectedWindow is closable; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.HasTitleBarIcon Property

ToolWindowContainerHasTitleBarIcon Property
Gets or sets whether the container is capable of displaying the selected window's icon in the title bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTitleBarIcon { get; set; }
Public Property HasTitleBarIcon As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying the selected window's icon in the title bar; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.HasToggleAutoHideButton Property

ToolWindowContainerHasToggleAutoHideButton Property
Gets or sets whether the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasToggleAutoHideButton { get; set; }
Public Property HasToggleAutoHideButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the container has a title bar toggle auto-hide button if the SelectedWindow can auto-hide; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsCloseButtonVisible Property

ToolWindowContainerIsCloseButtonVisible Property
Gets whether the container's close button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCloseButtonVisible { get; }
Public ReadOnly Property IsCloseButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's close button is visible; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsMaximizeButtonVisible Property

ToolWindowContainerIsMaximizeButtonVisible Property
Gets whether the container's maximize button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMaximizeButtonVisible { get; }
Public ReadOnly Property IsMaximizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's maximize button is visible; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsMinimizeButtonVisible Property

ToolWindowContainerIsMinimizeButtonVisible Property
Gets whether the container's minimize button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMinimizeButtonVisible { get; }
Public ReadOnly Property IsMinimizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's minimize button is visible; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsOptionsButtonVisible Property

ToolWindowContainerIsOptionsButtonVisible Property
Gets whether the container's options button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOptionsButtonVisible { get; }
Public ReadOnly Property IsOptionsButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's options button is visible; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsRestoreButtonVisible Property

ToolWindowContainerIsRestoreButtonVisible Property
Gets whether the container's restore button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsRestoreButtonVisible { get; }
Public ReadOnly Property IsRestoreButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's restore button is visible; otherwise, false. The default value is false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsToggleAutoHideButtonVisible Property

ToolWindowContainerIsToggleAutoHideButtonVisible Property
Gets whether the container's toggle auto-hide button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsToggleAutoHideButtonVisible { get; }
Public ReadOnly Property IsToggleAutoHideButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the container's toggle auto-hide button is visible; otherwise, false. The default value is true.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MaximizeButtonContentTemplate Property

ToolWindowContainerMaximizeButtonContentTemplate Property
Gets or sets the DataTemplate to use for the maximize button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate MaximizeButtonContentTemplate { get; set; }
Public Property MaximizeButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the maximize button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MaximizeCommand Property

ToolWindowContainerMaximizeCommand Property
Gets the ICommand that can maximize the window that hosts the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MaximizeCommand { get; }
Public ReadOnly Property MaximizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can maximize the window that hosts the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MenuButtonContentTemplate Property

ToolWindowContainerMenuButtonContentTemplate Property
Gets or sets the DataTemplate to use for the drop-down menu button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate MenuButtonContentTemplate { get; set; }
Public Property MenuButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the drop-down menu button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MinimizeButtonContentTemplate Property

ToolWindowContainerMinimizeButtonContentTemplate Property
Gets or sets the DataTemplate to use for the minimize button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate MinimizeButtonContentTemplate { get; set; }
Public Property MinimizeButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the minimize button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MinimizeCommand Property

ToolWindowContainerMinimizeCommand Property
Gets the ICommand that can minimize the window that hosts the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MinimizeCommand { get; }
Public ReadOnly Property MinimizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can minimize the window that hosts the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenuCommand Property

ToolWindowContainerOpenOptionsMenuCommand Property
Gets the ICommand that can open the options menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand OpenOptionsMenuCommand { get; }
Public ReadOnly Property OpenOptionsMenuCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can open the options menu.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.PinButtonContentTemplate Property

ToolWindowContainerPinButtonContentTemplate Property
Gets or sets the DataTemplate to use for the pin button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate PinButtonContentTemplate { get; set; }
Public Property PinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the pin button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.RestoreButtonContentTemplate Property

ToolWindowContainerRestoreButtonContentTemplate Property
Gets or sets the DataTemplate to use for the restore button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate RestoreButtonContentTemplate { get; set; }
Public Property RestoreButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the restore button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.RestoreCommand Property

ToolWindowContainerRestoreCommand Property
Gets the ICommand that can restore the window that hosts the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RestoreCommand { get; }
Public ReadOnly Property RestoreCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can restore the window that hosts the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.SelectedToolWindow Property

ToolWindowContainerSelectedToolWindow Property
Gets the ToolWindow that is currently selected in the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindow SelectedToolWindow { get; }
Public ReadOnly Property SelectedToolWindow As ToolWindow
    Get

Property Value

Type: ToolWindow
The ToolWindow that is currently selected in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.SingleTabLayoutBehavior Property

ToolWindowContainerSingleTabLayoutBehavior Property
Gets or sets the behavior used when a single ToolWindow is in the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SingleTabLayoutBehavior SingleTabLayoutBehavior { get; set; }
Public Property SingleTabLayoutBehavior As SingleTabLayoutBehavior
    Get
    Set

Property Value

Type: SingleTabLayoutBehavior
The behavior used when a single ToolWindow is in the container.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleBarContextContentAlignment Property

ToolWindowContainerTitleBarContextContentAlignment Property
Gets or sets the alignment of title bar context content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContextContentAlignment TitleBarContextContentAlignment { get; set; }
Public Property TitleBarContextContentAlignment As ContextContentAlignment
    Get
    Set

Property Value

Type: ContextContentAlignment
The alignment of title bar context content. The default value is Far.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleFontFamily Property

ToolWindowContainerTitleFontFamily Property
Gets or sets the title's font family.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontFamily TitleFontFamily { get; set; }
Public Property TitleFontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The title's font family.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleFontSize Property

ToolWindowContainerTitleFontSize Property
Gets or sets the title's font size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TitleFontSize { get; set; }
Public Property TitleFontSize As Double
    Get
    Set

Property Value

Type: Double
The title's font size.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleFontWeight Property

ToolWindowContainerTitleFontWeight Property
Gets or sets the title's font weight.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontWeight TitleFontWeight { get; set; }
Public Property TitleFontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The title's font weight. The default value is Normal.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.ToggleAutoHideCommand Property

ToolWindowContainerToggleAutoHideCommand Property
Gets the ICommand that can toggle the container between an auto-hide and docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ToggleAutoHideCommand { get; }
Public ReadOnly Property ToggleAutoHideCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can toggle the container between an auto-hide and docked state.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UnpinButtonContentTemplate Property

ToolWindowContainerUnpinButtonContentTemplate Property
Gets or sets the DataTemplate to use for the unpin button content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate UnpinButtonContentTemplate { get; set; }
Public Property UnpinButtonContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the unpin button content.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.Windows Property

ToolWindowContainerWindows Property
Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<DockingWindow> Windows { get; }
Public ReadOnly Property Windows As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer Methods

ToolWindowContainer Methods

The ToolWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | AutoHide | Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the tool windows in the container, removing them from the layout.
Public method | Dock | Docks the contained ToolWindow controls back to their default docked location.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides DockingWindowContainerBaseOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed. (Overrides DockingWindowContainerBaseOnDockSiteChanged(DockSite, DockSite).)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from DockingWindowContainerBase.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed. (Inherited from DockingWindowContainerBase.)
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening. (Overrides DockingWindowContainerBaseOnTabControlMenuOpening(AdvancedTabControlMenuEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed. (Inherited from DockingWindowContainerBase.)
Public method | OpenOptionsMenu | Options the options menu for the SelectedWindow.
Public method | OpenOptionsMenu(FrameworkElement) | Options the options menu for the SelectedWindow under the specified placement target element.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from DockingWindowContainerBase.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCommands | Updates the enabled states of the commands. (Overrides DockingWindowContainerBaseUpdateCommands.)
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows. (Overrides DockingWindowContainerBaseUpdateDockingWindowStates.)
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property. (Overrides DockingWindowContainerBaseUpdateIsTabStripVisible.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility. (Overrides DockingWindowContainerBaseUpdateTitleBarButtonVisibility.)
Protected method | UpdateVisualState | Updates the visual state. (Overrides DockingWindowContainerBaseUpdateVisualState(Boolean).)
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container. (Overrides DockingWindowContainerBaseValidateChildType(DockingWindow).)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.AutoHide Method

ToolWindowContainerAutoHide Method
Overload List
 | Name | Description
Public method | AutoHide | Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.
Public method | AutoHide(Side) | Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.AutoHide Method

ToolWindowContainerAutoHide Method
Auto-hides the contained ToolWindow controls to the outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AutoHide()
Public Sub AutoHide
Remarks
Using this method places the contained ToolWindow controls in an AutoHide State. Use the AutoHide(Side) method overload to auto-hide to a specific side.
See Also

Reference

ToolWindowContainer Class
AutoHide Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.AutoHide Method (Side)

ToolWindowContainerAutoHide Method (Side)
Auto-hides the contained ToolWindow controls to the specified outer-edge of the ancestor DockHost.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AutoHide(
    Side side
)
Public Sub AutoHide (
    side As Side
)

Parameters

side
Type: ActiproSoftware.UI.Xaml.ControlsSide
A Side indicating the side upon which to auto-hide.
Remarks
Using this method places the contained ToolWindow controls in an AutoHide State. Use the AutoHide method overload to auto-hide to the control's default side.
See Also

Reference

ToolWindowContainer Class
AutoHide Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.Close Method

ToolWindowContainerClose Method
Closes the tool windows in the container, removing them from the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Close()
Public Function Close As Boolean

Return Value

Type: Boolean
true if all tool windows were closed successfully; otherwise, false.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.Dock Method

ToolWindowContainerDock Method
Docks the contained ToolWindow controls back to their default docked location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dock()
Public Sub Dock
Remarks
Using this method places the contained ToolWindow controls in a Docked State.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OnApplyTemplate Method

ToolWindowContainerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OnCreateAutomationPeer Method

ToolWindowContainerOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OnDockSiteChanged Method

ToolWindowContainerOnDockSiteChanged Method
Occurs when the DockSite property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDockSiteChanged(
    DockSite oldDockSite,
    DockSite newDockSite
)
Protected Overrides Sub OnDockSiteChanged (
    oldDockSite As DockSite,
    newDockSite As DockSite
)

Parameters

oldDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The old value.
newDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The new value.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OnKeyDown Method

ToolWindowContainerOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OnTabControlMenuOpening Method

ToolWindowContainerOnTabControlMenuOpening Method
Occurs when a menu on the tab control is opening.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnTabControlMenuOpening(
    AdvancedTabControlMenuEventArgs e
)
Protected Overrides Sub OnTabControlMenuOpening (
    e As AdvancedTabControlMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControlMenuEventArgs
The AdvancedTabControlMenuEventArgs that contains the event data.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenu Method

ToolWindowContainerOpenOptionsMenu Method
Overload List
 | Name | Description
Public method | OpenOptionsMenu | Options the options menu for the SelectedWindow.
Public method | OpenOptionsMenu(FrameworkElement) | Options the options menu for the SelectedWindow under the specified placement target element.
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenu Method

ToolWindowContainerOpenOptionsMenu Method
Options the options menu for the SelectedWindow.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void OpenOptionsMenu()
Public Sub OpenOptionsMenu
See Also

Reference

ToolWindowContainer Class
OpenOptionsMenu Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.OpenOptionsMenu Method (FrameworkElement)

ToolWindowContainerOpenOptionsMenu Method (FrameworkElement)
Options the options menu for the SelectedWindow under the specified placement target element.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void OpenOptionsMenu(
    FrameworkElement placementTarget
)
Public Sub OpenOptionsMenu (
    placementTarget As FrameworkElement
)

Parameters

placementTarget
Type: Windows.UI.XamlFrameworkElement
The optional FrameworkElement under which to open the menu.
See Also

Reference

ToolWindowContainer Class
OpenOptionsMenu Overload
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UpdateCommands Method

ToolWindowContainerUpdateCommands Method
Updates the enabled states of the commands.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateCommands()
Protected Overrides Sub UpdateCommands
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UpdateDockingWindowStates Method

ToolWindowContainerUpdateDockingWindowStates Method
Updates the DockingWindowState associated with all child docking windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateDockingWindowStates()
Protected Overrides Sub UpdateDockingWindowStates
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UpdateIsTabStripVisible Method

ToolWindowContainerUpdateIsTabStripVisible Method
Updates the IsTabStripVisible property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateIsTabStripVisible()
Protected Overrides Sub UpdateIsTabStripVisible
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UpdateTitleBarButtonVisibility Method

ToolWindowContainerUpdateTitleBarButtonVisibility Method
Updates the title bar button visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateTitleBarButtonVisibility()
Protected Overrides Sub UpdateTitleBarButtonVisibility
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UpdateVisualState Method

ToolWindowContainerUpdateVisualState Method
Updates the visual state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateVisualState(
    bool useTransitions
)
Protected Overrides Sub UpdateVisualState (
    useTransitions As Boolean
)

Parameters

useTransitions
Type: SystemBoolean
Whether to use transitions.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.ValidateChildType Method

ToolWindowContainerValidateChildType Method
Validates that the specified child DockingWindow type is valid for this container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ValidateChildType(
    DockingWindow window
)
Protected Overrides Sub ValidateChildType (
    window As DockingWindow
)

Parameters

window
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The DockingWindow to examine.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer Events

ToolWindowContainer Events

The ToolWindowContainer type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer Fields

ToolWindowContainer Fields

The ToolWindowContainer type exposes the following members.

Fields
Name | Description
CloseButtonContentTemplateProperty | Identifies the CloseButtonContentTemplate dependency property. This field is read-only.
EmbeddedButtonStyleProperty | Identifies the EmbeddedButtonStyle dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasTitleBarIconProperty | Identifies the HasTitleBarIcon dependency property. This field is read-only.
HasToggleAutoHideButtonProperty | Identifies the HasToggleAutoHideButton dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsOptionsButtonVisibleProperty | Identifies the IsOptionsButtonVisible dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
IsToggleAutoHideButtonVisibleProperty | Identifies the IsToggleAutoHideButtonVisible dependency property. This field is read-only.
MaximizeButtonContentTemplateProperty | Identifies the MaximizeButtonContentTemplate dependency property. This field is read-only.
MenuButtonContentTemplateProperty | Identifies the MenuButtonContentTemplate dependency property. This field is read-only.
MinimizeButtonContentTemplateProperty | Identifies the MinimizeButtonContentTemplate dependency property. This field is read-only.
PinButtonContentTemplateProperty | Identifies the PinButtonContentTemplate dependency property. This field is read-only.
RestoreButtonContentTemplateProperty | Identifies the RestoreButtonContentTemplate dependency property. This field is read-only.
SingleTabLayoutBehaviorProperty | Identifies the SingleTabLayoutBehavior dependency property. This field is read-only.
TitleBarContextContentAlignmentProperty | Identifies the TitleBarContextContentAlignment dependency property. This field is read-only.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. This field is read-only.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. This field is read-only.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. This field is read-only.
UnpinButtonContentTemplateProperty | Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.
Top
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.CloseButtonContentTemplateProperty Field

ToolWindowContainerCloseButtonContentTemplateProperty Field
Identifies the CloseButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CloseButtonContentTemplateProperty
Public Shared ReadOnly CloseButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CloseButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.EmbeddedButtonStyleProperty Field

ToolWindowContainerEmbeddedButtonStyleProperty Field
Identifies the EmbeddedButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EmbeddedButtonStyleProperty
Public Shared ReadOnly EmbeddedButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EmbeddedButtonStyle dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.HasCloseButtonProperty Field

ToolWindowContainerHasCloseButtonProperty Field
Identifies the HasCloseButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCloseButtonProperty
Public Shared ReadOnly HasCloseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCloseButton dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.HasTitleBarIconProperty Field

ToolWindowContainerHasTitleBarIconProperty Field
Identifies the HasTitleBarIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarIconProperty
Public Shared ReadOnly HasTitleBarIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBarIcon dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.HasToggleAutoHideButtonProperty Field

ToolWindowContainerHasToggleAutoHideButtonProperty Field
Identifies the HasToggleAutoHideButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasToggleAutoHideButtonProperty
Public Shared ReadOnly HasToggleAutoHideButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasToggleAutoHideButton dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsCloseButtonVisibleProperty Field

ToolWindowContainerIsCloseButtonVisibleProperty Field
Identifies the IsCloseButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCloseButtonVisibleProperty
Public Shared ReadOnly IsCloseButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCloseButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsMaximizeButtonVisibleProperty Field

ToolWindowContainerIsMaximizeButtonVisibleProperty Field
Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizeButtonVisibleProperty
Public Shared ReadOnly IsMaximizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizeButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsMinimizeButtonVisibleProperty Field

ToolWindowContainerIsMinimizeButtonVisibleProperty Field
Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMinimizeButtonVisibleProperty
Public Shared ReadOnly IsMinimizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMinimizeButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsOptionsButtonVisibleProperty Field

ToolWindowContainerIsOptionsButtonVisibleProperty Field
Identifies the IsOptionsButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOptionsButtonVisibleProperty
Public Shared ReadOnly IsOptionsButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOptionsButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsRestoreButtonVisibleProperty Field

ToolWindowContainerIsRestoreButtonVisibleProperty Field
Identifies the IsRestoreButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRestoreButtonVisibleProperty
Public Shared ReadOnly IsRestoreButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRestoreButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.IsToggleAutoHideButtonVisibleProperty Field

ToolWindowContainerIsToggleAutoHideButtonVisibleProperty Field
Identifies the IsToggleAutoHideButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsToggleAutoHideButtonVisibleProperty
Public Shared ReadOnly IsToggleAutoHideButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsToggleAutoHideButtonVisible dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MaximizeButtonContentTemplateProperty Field

ToolWindowContainerMaximizeButtonContentTemplateProperty Field
Identifies the MaximizeButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximizeButtonContentTemplateProperty
Public Shared ReadOnly MaximizeButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaximizeButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MenuButtonContentTemplateProperty Field

ToolWindowContainerMenuButtonContentTemplateProperty Field
Identifies the MenuButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MenuButtonContentTemplateProperty
Public Shared ReadOnly MenuButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MenuButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.MinimizeButtonContentTemplateProperty Field

ToolWindowContainerMinimizeButtonContentTemplateProperty Field
Identifies the MinimizeButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimizeButtonContentTemplateProperty
Public Shared ReadOnly MinimizeButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinimizeButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.PinButtonContentTemplateProperty Field

ToolWindowContainerPinButtonContentTemplateProperty Field
Identifies the PinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PinButtonContentTemplateProperty
Public Shared ReadOnly PinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PinButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.RestoreButtonContentTemplateProperty Field

ToolWindowContainerRestoreButtonContentTemplateProperty Field
Identifies the RestoreButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RestoreButtonContentTemplateProperty
Public Shared ReadOnly RestoreButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RestoreButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.SingleTabLayoutBehaviorProperty Field

ToolWindowContainerSingleTabLayoutBehaviorProperty Field
Identifies the SingleTabLayoutBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SingleTabLayoutBehaviorProperty
Public Shared ReadOnly SingleTabLayoutBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SingleTabLayoutBehavior dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleBarContextContentAlignmentProperty Field

ToolWindowContainerTitleBarContextContentAlignmentProperty Field
Identifies the TitleBarContextContentAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleBarContextContentAlignmentProperty
Public Shared ReadOnly TitleBarContextContentAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleBarContextContentAlignment dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleFontFamilyProperty Field

ToolWindowContainerTitleFontFamilyProperty Field
Identifies the TitleFontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleFontFamilyProperty
Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleFontFamily dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleFontSizeProperty Field

ToolWindowContainerTitleFontSizeProperty Field
Identifies the TitleFontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleFontSizeProperty
Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleFontSize dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.TitleFontWeightProperty Field

ToolWindowContainerTitleFontWeightProperty Field
Identifies the TitleFontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleFontWeightProperty
Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleFontWeight dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainer.UnpinButtonContentTemplateProperty Field

ToolWindowContainerUnpinButtonContentTemplateProperty Field
Identifies the UnpinButtonContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnpinButtonContentTemplateProperty
Public Shared ReadOnly UnpinButtonContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnpinButtonContentTemplate dependency property.
See Also

Reference

ToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainerCollection Class

ToolWindowContainerCollection Class
Represents an observable collection of ToolWindowContainer objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ToolWindowContainer
System.Collections.ObjectModelObservableCollection ToolWindowContainer
ActiproSoftware.UI.XamlDeferrableObservableCollection ToolWindowContainer
ActiproSoftware.UI.Xaml.Controls.DockingToolWindowContainerCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindowContainerCollection : DeferrableObservableCollection<ToolWindowContainer>
Public Class ToolWindowContainerCollection
    Inherits DeferrableObservableCollection(Of ToolWindowContainer)

The ToolWindowContainerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainerCollection | Initializes a new instance of the ToolWindowContainerCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection ToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection ToolWindowContainer .)
Protected property | Items | (Inherited from Collection ToolWindowContainer .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection ToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Clear | (Inherited from Collection ToolWindowContainer .)
Protected method | ClearItems | (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Contains | (Inherited from Collection ToolWindowContainer .)
Public method | CopyTo | (Inherited from Collection ToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection ToolWindowContainer .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection ToolWindowContainer .)
Public method | Insert | (Inherited from Collection ToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | MoveItem | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection ToolWindowContainer .)
Public method | RemoveAt | (Inherited from Collection ToolWindowContainer .)
Protected method | RemoveItem | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection ToolWindowContainer .)
Protected event | PropertyChanged | (Inherited from ObservableCollection ToolWindowContainer .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainerCollection Constructor

ToolWindowContainerCollection Constructor
Initializes a new instance of the ToolWindowContainerCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerCollection()
Public Sub New
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainerCollection Properties

ToolWindowContainerCollection Properties

The ToolWindowContainerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection ToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection ToolWindowContainer .)
Protected property | Items | (Inherited from Collection ToolWindowContainer .)
Top
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainerCollection Methods

ToolWindowContainerCollection Methods

The ToolWindowContainerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection ToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Clear | (Inherited from Collection ToolWindowContainer .)
Protected method | ClearItems | (Inherited from ObservableCollection ToolWindowContainer .)
Public method | Contains | (Inherited from Collection ToolWindowContainer .)
Public method | CopyTo | (Inherited from Collection ToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection ToolWindowContainer .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection ToolWindowContainer .)
Public method | Insert | (Inherited from Collection ToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | MoveItem | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection ToolWindowContainer .)
Public method | RemoveAt | (Inherited from Collection ToolWindowContainer .)
Protected method | RemoveItem | (Inherited from ObservableCollection ToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ToolWindowContainerCollection Events

ToolWindowContainerCollection Events

The ToolWindowContainerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection ToolWindowContainer .)
Protected event | PropertyChanged | (Inherited from ObservableCollection ToolWindowContainer .)
Top
See Also

Reference

ToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl Class

WindowControl Class
Represents a ContentControl that renders like a normal native Window but can be used in other non-top-level contexts.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingWindowControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesFloatingWindowControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesStandardMdiWindowControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WindowControl : ContentControl
Public Class WindowControl
    Inherits ContentControl

The WindowControl type exposes the following members.

Constructors
 | Name | Description
Public method | WindowControl | Initializes an instance of the WindowControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the window can close.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can close the window.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent.
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button.
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon.
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button.
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button.
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button.
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the window is currently active.
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible.
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized.
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible.
Public property | IsMoving | Gets whether the window is currently being dragged to move its location.
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only.
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size.
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreCommand | Gets the ICommand that can restore the window.
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window.
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title.
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window.
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated | Called when the window gains focus within.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Called when the window is about to close.
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure.
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDeactivated | Called when the window loses focus within.
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragMoved | Called after the window has been moved from a drag.
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag.
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDragResized | Called after the window has been resized from a drag.
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize.
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the window is moved.
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action.
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Shows the window.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleWindowState | Toggles the window's state based on its current state.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Activated | Occurs when the window gains focus within.
Public event | Closed | Occurs when the window is about to close.
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when the window loses focus within.
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragMoved | Occurs after the window has been moved from a drag.
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag.
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragResized | Occurs after the window has been resized from a drag.
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize.
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window is moved.
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Opened | Occurs when the window is opened.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs after the window's WindowState property has changed.
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action.
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu.
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
ContextContentTemplateSelectorProperty | Identifies the ContextContentTemplateSelector dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasIconProperty | Identifies the HasIcon dependency property. This field is read-only.
HasMaximizeButtonProperty | Identifies the HasMaximizeButton dependency property. This field is read-only.
HasMinimizeButtonProperty | Identifies the HasMinimizeButton dependency property. This field is read-only.
HasRestoreButtonProperty | Identifies the HasRestoreButton dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMaximizedFrameVisibleProperty | Identifies the IsMaximizedFrameVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsMovingProperty | Identifies the IsMoving dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsResizingProperty | Identifies the IsResizing dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
LeftProperty | Identifies the Left dependency property. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
ResizeModeProperty | Identifies the ResizeMode dependency property. This field is read-only.
RestoredBoundsProperty | Identifies the RestoredBounds dependency property. This field is read-only.
TitleBarFontWeightProperty | Identifies the TitleBarFontWeight dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TopProperty | Identifies the Top dependency property. This field is read-only.
WindowStateProperty | Identifies the WindowState dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl Constructor

WindowControl Constructor
Initializes an instance of the WindowControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WindowControl()
Public Sub New
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl Properties

WindowControl Properties

The WindowControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the window can close.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can close the window.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title.
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent.
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button.
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon.
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button.
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button.
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button.
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the window is currently active.
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible.
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized.
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible.
Public property | IsMoving | Gets whether the window is currently being dragged to move its location.
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only.
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size.
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreCommand | Gets the ICommand that can restore the window.
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window.
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title.
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.CanClose Property

WindowControlCanClose Property
Gets or sets whether the window can close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanClose { get; set; }
Public Property CanClose As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window can close; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.CloseCommand Property

WindowControlCloseCommand Property
Gets the ICommand that can close the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CloseCommand { get; }
Public ReadOnly Property CloseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can close the window.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ContextContent Property

WindowControlContextContent Property
Gets or sets the context content that is displayed on the title bar next to the title.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ContextContent { get; set; }
Public Property ContextContent As Object
    Get
    Set

Property Value

Type: Object
The context content that is displayed on the title bar next to the title. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ContextContentTemplate Property

WindowControlContextContentTemplate Property
Gets or sets the DataTemplate to use for the ContextContent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ContextContentTemplate { get; set; }
Public Property ContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the ContextContent. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ContextContentTemplateSelector Property

WindowControlContextContentTemplateSelector Property
Gets or sets the DataTemplateSelector to use for the ContextContent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector ContextContentTemplateSelector { get; set; }
Public Property ContextContentTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the ContextContent. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.CornerRadius Property

WindowControlCornerRadius Property
Gets or sets the CornerRadius of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The CornerRadius of the window. The default value is 0.0.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasCloseButton Property

WindowControlHasCloseButton Property
Gets or sets whether the window is capable of displaying a close button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasCloseButton { get; set; }
Public Property HasCloseButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a close button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasIcon Property

WindowControlHasIcon Property
Gets or sets whether the window is capable of displaying an icon.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasIcon { get; set; }
Public Property HasIcon As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying an icon; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasMaximizeButton Property

WindowControlHasMaximizeButton Property
Gets or sets whether the window is capable of displaying a maximize button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMaximizeButton { get; set; }
Public Property HasMaximizeButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a maximize button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasMinimizeButton Property

WindowControlHasMinimizeButton Property
Gets or sets whether the window is capable of displaying a minimize button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMinimizeButton { get; set; }
Public Property HasMinimizeButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a minimize button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasRestoreButton Property

WindowControlHasRestoreButton Property
Gets or sets whether the window is capable of displaying a restore button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasRestoreButton { get; set; }
Public Property HasRestoreButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a restore button; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasTitleBar Property

WindowControlHasTitleBar Property
Gets or sets whether the window is capable of displaying a title bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTitleBar { get; set; }
Public Property HasTitleBar As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is capable of displaying a title bar; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Icon Property

WindowControlIcon Property
Gets or sets the ImageSource displayed as the window icon.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ImageSource Icon { get; set; }
Public Property Icon As ImageSource
    Get
    Set

Property Value

Type: ImageSource
The ImageSource displayed as the window icon. The default value is .
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsActive Property

WindowControlIsActive Property
Gets whether the window is currently active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsActive { get; protected set; }
Public Property IsActive As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the window is currently active; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsCloseButtonVisible Property

WindowControlIsCloseButtonVisible Property
Gets whether the window's close button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCloseButtonVisible { get; }
Public ReadOnly Property IsCloseButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's close button is visible; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMaximizeButtonVisible Property

WindowControlIsMaximizeButtonVisible Property
Gets whether the window's maximize button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMaximizeButtonVisible { get; }
Public ReadOnly Property IsMaximizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's maximize button is visible; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMaximizedFrameVisible Property

WindowControlIsMaximizedFrameVisible Property
Gets or sets whether the frame should be displayed when the window is maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMaximizedFrameVisible { get; set; }
Public Property IsMaximizedFrameVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the frame should be displayed when the window is maximized; otherwise, false. The default value is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMinimizeButtonVisible Property

WindowControlIsMinimizeButtonVisible Property
Gets whether the window's minimize button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMinimizeButtonVisible { get; }
Public ReadOnly Property IsMinimizeButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's minimize button is visible; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMoving Property

WindowControlIsMoving Property
Gets whether the window is currently being dragged to move its location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMoving { get; }
Public ReadOnly Property IsMoving As Boolean
    Get

Property Value

Type: Boolean
true if the window is currently being dragged to move its location; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsReadOnly Property

WindowControlIsReadOnly Property
Gets or sets whether the windows's contents are read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the windows's contents are read-only; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsResizing Property

WindowControlIsResizing Property
Gets whether the window is currently being dragged to alter its size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsResizing { get; }
Public ReadOnly Property IsResizing As Boolean
    Get

Property Value

Type: Boolean
true if the window is currently being dragged to alter its size; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsRestoreButtonVisible Property

WindowControlIsRestoreButtonVisible Property
Gets whether the window's restore button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsRestoreButtonVisible { get; }
Public ReadOnly Property IsRestoreButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the window's restore button is visible; otherwise, false. The default value is false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Left Property

WindowControlLeft Property
Gets or sets the position of the window's left edge, in relation to its container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Left { get; set; }
Public Property Left As Double
    Get
    Set

Property Value

Type: Double
The position of the window's left edge, in relation to its container.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.MaximizeCommand Property

WindowControlMaximizeCommand Property
Gets the ICommand that can maximize the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MaximizeCommand { get; }
Public ReadOnly Property MaximizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can maximize the window.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.MinimizeCommand Property

WindowControlMinimizeCommand Property
Gets the ICommand that can minimize the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand MinimizeCommand { get; }
Public ReadOnly Property MinimizeCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can minimize the window.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ReadOnlyContextContentTemplate Property

WindowControlReadOnlyContextContentTemplate Property
Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ReadOnlyContextContentTemplate { get; set; }
Public Property ReadOnlyContextContentTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ResizeMode Property

WindowControlResizeMode Property
Gets or sets a ResizeMode indicating how the window is able to resize.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ResizeMode ResizeMode { get; set; }
Public Property ResizeMode As ResizeMode
    Get
    Set

Property Value

Type: ResizeMode
A ResizeMode indicating how the window is able to resize. The default value is CanResize.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.RestoreCommand Property

WindowControlRestoreCommand Property
Gets the ICommand that can restore the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RestoreCommand { get; }
Public ReadOnly Property RestoreCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can restore the window.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.RestoredBounds Property

WindowControlRestoredBounds Property
Gets or sets the bounds of this window when in a 'restored' state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect RestoredBounds { get; set; }
Public Property RestoredBounds As Rect
    Get
    Set

Property Value

Type: Rect
The bounds of this window when in a 'restored' state.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Title Property

WindowControlTitle Property
Gets or sets the title of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title of the window.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.TitleBarFontWeight Property

WindowControlTitleBarFontWeight Property
Gets or sets the FontWeight of the title.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontWeight TitleBarFontWeight { get; set; }
Public Property TitleBarFontWeight As FontWeight
    Get
    Set

Property Value

Type: FontWeight
The FontWeight of the title. The default value is Normal.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Top Property

WindowControlTop Property
Gets or sets the position of the window's top edge, in relation to its container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Top { get; set; }
Public Property Top As Double
    Get
    Set

Property Value

Type: Double
The position of the window's top edge, in relation to its container.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.WindowState Property

WindowControlWindowState Property
Gets or sets a WindowState indicating the current state of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WindowState WindowState { get; set; }
Public Property WindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
A WindowState indicating the current state of the window. The default value is Normal.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl Methods

WindowControl Methods

The WindowControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window.
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated | Called when the window gains focus within.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnClosed | Called when the window is about to close.
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure.
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDeactivated | Called when the window loses focus within.
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragMoved | Called after the window has been moved from a drag.
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag.
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDragResized | Called after the window has been resized from a drag.
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize.
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the window is moved.
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action.
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Shows the window.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleWindowState | Toggles the window's state based on its current state.
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Activate Method

WindowControlActivate Method
Attempts to bring the window to the foreground and activates it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Activate()
Public Overridable Function Activate As Boolean

Return Value

Type: Boolean
true if the window was successfully activated; otherwise, false.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Close Method

WindowControlClose Method
Closes the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.DragMove Method

WindowControlDragMove Method
Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void DragMove(
    InputPointerButtonEventArgs e
)
Public Sub DragMove (
    e As InputPointerButtonEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.InputInputPointerButtonEventArgs
The InputPointerButtonEventArgs that can wrap a platform-specific input event args instance.
Remarks
The primary button of the pointer in the event arguments must be pressed down when calling this method. The pointer will be captured.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.GetAdjustedBounds Method

WindowControlGetAdjustedBounds Method
Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Rect GetAdjustedBounds(
    Rect bounds,
    ResizeOperation resizeOperation
)
Public Overridable Function GetAdjustedBounds (
    bounds As Rect,
    resizeOperation As ResizeOperation
) As Rect

Parameters

bounds
Type: Windows.FoundationRect
The bounds to examine.
resizeOperation
Type: ActiproSoftware.UI.Xaml.ControlsResizeOperation
The active resize operation.

Return Value

Type: Rect
The adjusted bounds.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HitTestResizeOperation Method

WindowControlHitTestResizeOperation Method
Hit tests the specified Point to see if it might cause a resize operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ResizeOperation HitTestResizeOperation(
    Point point
)
Public Function HitTestResizeOperation (
    point As Point
) As ResizeOperation

Parameters

point
Type: Windows.FoundationPoint
The Point, in control coordinates, to hit test.

Return Value

Type: ResizeOperation
The resize operation that can be caused by dragging at the Point.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnActivated Method

WindowControlOnActivated Method
Called when the window gains focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnActivated(
    RoutedEventArgs e
)
Protected Overridable Sub OnActivated (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnApplyTemplate Method

WindowControlOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnClosed Method

WindowControlOnClosed Method
Called when the window is about to close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnClosed(
    RoutedEventArgs e
)
Protected Overridable Sub OnClosed (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnClosing Method

WindowControlOnClosing Method
Called directly after Close is called, and can be handled to cancel window closure.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnClosing(
    CancelableEventArgs e
)
Protected Overridable Sub OnClosing (
    e As CancelableEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.XamlCancelableEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnCreateAutomationPeer Method

WindowControlOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnDeactivated Method

WindowControlOnDeactivated Method
Called when the window loses focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDeactivated(
    RoutedEventArgs e
)
Protected Overridable Sub OnDeactivated (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnDragMoved Method

WindowControlOnDragMoved Method
Called after the window has been moved from a drag.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDragMoved(
    RoutedEventArgs e
)
Protected Overridable Sub OnDragMoved (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnDragMoving Method

WindowControlOnDragMoving Method
Called before the window is moved from a drag, and can be handled to cancel the drag.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDragMoving(
    CancelableEventArgs e
)
Protected Overridable Sub OnDragMoving (
    e As CancelableEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.XamlCancelableEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnDragResized Method

WindowControlOnDragResized Method
Called after the window has been resized from a drag.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDragResized(
    RoutedEventArgs e
)
Protected Overridable Sub OnDragResized (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnDragResizing Method

WindowControlOnDragResizing Method
Called before the window is resized from a drag, and can be handled to cancel the resize.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDragResizing(
    CancelableEventArgs e
)
Protected Overridable Sub OnDragResizing (
    e As CancelableEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.XamlCancelableEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnGotFocus Method

WindowControlOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnLocationChanged Method

WindowControlOnLocationChanged Method
Called when the window is moved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnLocationChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnLocationChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnLostFocus Method

WindowControlOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnOpened Method

WindowControlOnOpened Method
Called when the window is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnOpened(
    RoutedEventArgs e
)
Protected Overridable Sub OnOpened (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnStateChanged Method

WindowControlOnStateChanged Method
Called after the window's WindowState property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnStateChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnStateChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnTitleBarDoubleTapped Method

WindowControlOnTitleBarDoubleTapped Method
Called when the title-bar is double-tapped, and can be handled to cancel the default action.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTitleBarDoubleTapped(
    CancelableEventArgs e
)
Protected Overridable Sub OnTitleBarDoubleTapped (
    e As CancelableEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.XamlCancelableEventArgs
A CancelRoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.OnTitleBarMenuOpening Method

WindowControlOnTitleBarMenuOpening Method
Called when the title-bar should display a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTitleBarMenuOpening(
    DockingMenuEventArgs e
)
Protected Overridable Sub OnTitleBarMenuOpening (
    e As DockingMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuEventArgs
A DockingMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Show Method

WindowControlShow Method
Shows the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Show()
Public Sub Show
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ToggleWindowState Method

WindowControlToggleWindowState Method
Toggles the window's state based on its current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ToggleWindowState()
Public Sub ToggleWindowState
Remarks
This method is generally called when the title bar is double-tapped.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl Events

WindowControl Events

The WindowControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Activated | Occurs when the window gains focus within.
Public event | Closed | Occurs when the window is about to close.
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when the window loses focus within.
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragMoved | Occurs after the window has been moved from a drag.
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag.
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragResized | Occurs after the window has been resized from a drag.
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize.
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window is moved.
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Opened | Occurs when the window is opened.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs after the window's WindowState property has changed.
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action.
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu.
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Activated Event

WindowControlActivated Event
Occurs when the window gains focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Activated
Public Event Activated As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Closed Event

WindowControlClosed Event
Occurs when the window is about to close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Closed
Public Event Closed As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Closing Event

WindowControlClosing Event
Occurs directly after Close is called, and can be handled to cancel window closure.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CancelableEventArgs> Closing
Public Event Closing As EventHandler(Of CancelableEventArgs)

Value

Type: SystemEventHandler CancelableEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Deactivated Event

WindowControlDeactivated Event
Occurs when the window loses focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Deactivated
Public Event Deactivated As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.DragMoved Event

WindowControlDragMoved Event
Occurs after the window has been moved from a drag.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler DragMoved
Public Event DragMoved As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.DragMoving Event

WindowControlDragMoving Event
Occurs before the window is moved from a drag, and can be handled to cancel the drag.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CancelableEventArgs> DragMoving
Public Event DragMoving As EventHandler(Of CancelableEventArgs)

Value

Type: SystemEventHandler CancelableEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.DragResized Event

WindowControlDragResized Event
Occurs after the window has been resized from a drag.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler DragResized
Public Event DragResized As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.DragResizing Event

WindowControlDragResizing Event
Occurs before the window is resized from a drag, and can be handled to cancel the resize.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CancelableEventArgs> DragResizing
Public Event DragResizing As EventHandler(Of CancelableEventArgs)

Value

Type: SystemEventHandler CancelableEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.LocationChanged Event

WindowControlLocationChanged Event
Occurs when the window is moved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler LocationChanged
Public Event LocationChanged As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.Opened Event

WindowControlOpened Event
Occurs when the window is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler Opened
Public Event Opened As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.StateChanged Event

WindowControlStateChanged Event
Occurs after the window's WindowState property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler StateChanged
Public Event StateChanged As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.TitleBarDoubleTapped Event

WindowControlTitleBarDoubleTapped Event
Occurs when the title-bar is double-tapped, and can be handled to cancel the default action.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CancelableEventArgs> TitleBarDoubleTapped
Public Event TitleBarDoubleTapped As EventHandler(Of CancelableEventArgs)

Value

Type: SystemEventHandler CancelableEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.TitleBarMenuOpening Event

WindowControlTitleBarMenuOpening Event
Occurs when the title-bar should display a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingMenuEventArgs> TitleBarMenuOpening
Public Event TitleBarMenuOpening As EventHandler(Of DockingMenuEventArgs)

Value

Type: SystemEventHandler DockingMenuEventArgs
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl Fields

WindowControl Fields

The WindowControl type exposes the following members.

Fields
Name | Description
CanCloseProperty | Identifies the CanClose dependency property. This field is read-only.
ContextContentProperty | Identifies the ContextContent dependency property. This field is read-only.
ContextContentTemplateProperty | Identifies the ContextContentTemplate dependency property. This field is read-only.
ContextContentTemplateSelectorProperty | Identifies the ContextContentTemplateSelector dependency property. This field is read-only.
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
HasCloseButtonProperty | Identifies the HasCloseButton dependency property. This field is read-only.
HasIconProperty | Identifies the HasIcon dependency property. This field is read-only.
HasMaximizeButtonProperty | Identifies the HasMaximizeButton dependency property. This field is read-only.
HasMinimizeButtonProperty | Identifies the HasMinimizeButton dependency property. This field is read-only.
HasRestoreButtonProperty | Identifies the HasRestoreButton dependency property. This field is read-only.
HasTitleBarProperty | Identifies the HasTitleBar dependency property. This field is read-only.
IconProperty | Identifies the Icon dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsCloseButtonVisibleProperty | Identifies the IsCloseButtonVisible dependency property. This field is read-only.
IsMaximizeButtonVisibleProperty | Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.
IsMaximizedFrameVisibleProperty | Identifies the IsMaximizedFrameVisible dependency property. This field is read-only.
IsMinimizeButtonVisibleProperty | Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.
IsMovingProperty | Identifies the IsMoving dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsResizingProperty | Identifies the IsResizing dependency property. This field is read-only.
IsRestoreButtonVisibleProperty | Identifies the IsRestoreButtonVisible dependency property. This field is read-only.
LeftProperty | Identifies the Left dependency property. This field is read-only.
ReadOnlyContextContentTemplateProperty | Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.
ResizeModeProperty | Identifies the ResizeMode dependency property. This field is read-only.
RestoredBoundsProperty | Identifies the RestoredBounds dependency property. This field is read-only.
TitleBarFontWeightProperty | Identifies the TitleBarFontWeight dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TopProperty | Identifies the Top dependency property. This field is read-only.
WindowStateProperty | Identifies the WindowState dependency property. This field is read-only.
Top
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.CanCloseProperty Field

WindowControlCanCloseProperty Field
Identifies the CanClose dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCloseProperty
Public Shared ReadOnly CanCloseProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanClose dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ContextContentProperty Field

WindowControlContextContentProperty Field
Identifies the ContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentProperty
Public Shared ReadOnly ContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContent dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ContextContentTemplateProperty Field

WindowControlContextContentTemplateProperty Field
Identifies the ContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentTemplateProperty
Public Shared ReadOnly ContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentTemplate dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ContextContentTemplateSelectorProperty Field

WindowControlContextContentTemplateSelectorProperty Field
Identifies the ContextContentTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentTemplateSelectorProperty
Public Shared ReadOnly ContextContentTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentTemplateSelector dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.CornerRadiusProperty Field

WindowControlCornerRadiusProperty Field
Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasCloseButtonProperty Field

WindowControlHasCloseButtonProperty Field
Identifies the HasCloseButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasCloseButtonProperty
Public Shared ReadOnly HasCloseButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasCloseButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasIconProperty Field

WindowControlHasIconProperty Field
Identifies the HasIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasIconProperty
Public Shared ReadOnly HasIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasIcon dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasMaximizeButtonProperty Field

WindowControlHasMaximizeButtonProperty Field
Identifies the HasMaximizeButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasMaximizeButtonProperty
Public Shared ReadOnly HasMaximizeButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasMaximizeButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasMinimizeButtonProperty Field

WindowControlHasMinimizeButtonProperty Field
Identifies the HasMinimizeButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasMinimizeButtonProperty
Public Shared ReadOnly HasMinimizeButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasMinimizeButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasRestoreButtonProperty Field

WindowControlHasRestoreButtonProperty Field
Identifies the HasRestoreButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasRestoreButtonProperty
Public Shared ReadOnly HasRestoreButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasRestoreButton dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.HasTitleBarProperty Field

WindowControlHasTitleBarProperty Field
Identifies the HasTitleBar dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTitleBarProperty
Public Shared ReadOnly HasTitleBarProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTitleBar dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IconProperty Field

WindowControlIconProperty Field
Identifies the Icon dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IconProperty
Public Shared ReadOnly IconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Icon dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsActiveProperty Field

WindowControlIsActiveProperty Field
Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsCloseButtonVisibleProperty Field

WindowControlIsCloseButtonVisibleProperty Field
Identifies the IsCloseButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCloseButtonVisibleProperty
Public Shared ReadOnly IsCloseButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCloseButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMaximizeButtonVisibleProperty Field

WindowControlIsMaximizeButtonVisibleProperty Field
Identifies the IsMaximizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizeButtonVisibleProperty
Public Shared ReadOnly IsMaximizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizeButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMaximizedFrameVisibleProperty Field

WindowControlIsMaximizedFrameVisibleProperty Field
Identifies the IsMaximizedFrameVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMaximizedFrameVisibleProperty
Public Shared ReadOnly IsMaximizedFrameVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMaximizedFrameVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMinimizeButtonVisibleProperty Field

WindowControlIsMinimizeButtonVisibleProperty Field
Identifies the IsMinimizeButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMinimizeButtonVisibleProperty
Public Shared ReadOnly IsMinimizeButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMinimizeButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsMovingProperty Field

WindowControlIsMovingProperty Field
Identifies the IsMoving dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMovingProperty
Public Shared ReadOnly IsMovingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMoving dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsReadOnlyProperty Field

WindowControlIsReadOnlyProperty Field
Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsResizingProperty Field

WindowControlIsResizingProperty Field
Identifies the IsResizing dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizingProperty
Public Shared ReadOnly IsResizingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizing dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.IsRestoreButtonVisibleProperty Field

WindowControlIsRestoreButtonVisibleProperty Field
Identifies the IsRestoreButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRestoreButtonVisibleProperty
Public Shared ReadOnly IsRestoreButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRestoreButtonVisible dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.LeftProperty Field

WindowControlLeftProperty Field
Identifies the Left dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LeftProperty
Public Shared ReadOnly LeftProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Left dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ReadOnlyContextContentTemplateProperty Field

WindowControlReadOnlyContextContentTemplateProperty Field
Identifies the ReadOnlyContextContentTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReadOnlyContextContentTemplateProperty
Public Shared ReadOnly ReadOnlyContextContentTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReadOnlyContextContentTemplate dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.ResizeModeProperty Field

WindowControlResizeModeProperty Field
Identifies the ResizeMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResizeModeProperty
Public Shared ReadOnly ResizeModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResizeMode dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.RestoredBoundsProperty Field

WindowControlRestoredBoundsProperty Field
Identifies the RestoredBounds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RestoredBoundsProperty
Public Shared ReadOnly RestoredBoundsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RestoredBounds dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.TitleBarFontWeightProperty Field

WindowControlTitleBarFontWeightProperty Field
Identifies the TitleBarFontWeight dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleBarFontWeightProperty
Public Shared ReadOnly TitleBarFontWeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleBarFontWeight dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.TitleProperty Field

WindowControlTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.TopProperty Field

WindowControlTopProperty Field
Identifies the Top dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TopProperty
Public Shared ReadOnly TopProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Top dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowControl.WindowStateProperty Field

WindowControlWindowStateProperty Field
Identifies the WindowState dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WindowStateProperty
Public Shared ReadOnly WindowStateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WindowState dependency property.
See Also

Reference

WindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState Class

WindowState Class
Specifies whether a window is minimized, maximized, or restored.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.DockingWindowState

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class WindowState : Enum
Public NotInheritable Class WindowState
    Inherits Enum

The WindowState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Maximized | The window is maximized.
 | Minimized | The window is minimized.
 | Normal | The window is restored.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState Methods

WindowState Methods

The WindowState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

WindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState Fields

WindowState Fields

The WindowState type exposes the following members.

Fields
 | Name | Description
 | Maximized | The window is maximized.
 | Minimized | The window is minimized.
 | Normal | The window is restored.
Public field | value__ |
Top
See Also

Reference

WindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState.Maximized Field

WindowStateMaximized Field
The window is maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WindowState Maximized = 2
Public Const Maximized As WindowState = 2

Field Value

Type: WindowState
See Also

Reference

WindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState.Minimized Field

WindowStateMinimized Field
The window is minimized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WindowState Minimized = 1
Public Const Minimized As WindowState = 1

Field Value

Type: WindowState
See Also

Reference

WindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState.Normal Field

WindowStateNormal Field
The window is restored.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WindowState Normal = 0
Public Const Normal As WindowState = 0

Field Value

Type: WindowState
See Also

Reference

WindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


WindowState.value__ Field

WindowStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.WindowState.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

WindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace Class

Workspace Class
Represents a control that can contain a MDI host, and around which tool windows are docked.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingWorkspace

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Workspace : ContentControl, IDockTarget
Public Class Workspace
    Inherits ContentControl
    Implements IDockTarget

The Workspace type exposes the following members.

Constructors
 | Name | Description
Public method | Workspace | Initializes an instance of the Workspace class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace Constructor

Workspace Constructor
Initializes an instance of the Workspace class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Workspace()
Public Sub New
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace Properties

Workspace Properties

The Workspace type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace.DockHost Property

WorkspaceDockHost Property
Gets the DockHost that contains this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.

Implements

IDockTargetDockHost
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace.DockSite Property

WorkspaceDockSite Property
Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.

Implements

IDockTargetDockSite
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace Methods

Workspace Methods

The Workspace type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace.OnContentChanged Method

WorkspaceOnContentChanged Method
Occurs when the content changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Protected Overrides Sub OnContentChanged (
    oldContent As Object,
    newContent As Object
)

Parameters

oldContent
Type: SystemObject
The old content.
newContent
Type: SystemObject
The new content.
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace.OnCreateAutomationPeer Method

WorkspaceOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace.OnGotFocus Method

WorkspaceOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


Workspace Events

Workspace Events

The Workspace type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

Workspace Class
ActiproSoftware.UI.Xaml.Controls.Docking Namespace


ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace
Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | AdvancedTabControlAutomationPeer | Exposes AdvancedTabControl types to UI Automation.
Public class | AdvancedTabItemAutomationPeer | Exposes AdvancedTabItem types to UI Automation.
Public class | AdvancedTabItemWrapperAutomationPeer | Exposes AdvancedTabItem types to UI Automation.
Public class | DockHostAutomationPeer | Exposes DockHost types to UI Automation.
Public class | DockingWindowAutomationPeerBase | Exposes DockingWindow types to UI Automation.
Public class | DockingWindowContainerBaseAutomationPeer | Exposes DockingWindowContainerBase types to UI Automation.
Public class | DockSiteAutomationPeer | Exposes DockSite types to UI Automation.
Public class | DocumentWindowAutomationPeer | Exposes DocumentWindow types to UI Automation.
Public class | SplitContainerAutomationPeer | Exposes SplitContainer types to UI Automation.
Public class | StandardMdiHostAutomationPeer | Exposes StandardMdiHost types to UI Automation.
Public class | TabbedMdiContainerAutomationPeer | Exposes TabbedMdiContainer types to UI Automation.
Public class | ToolWindowAutomationPeer | Exposes ToolWindow types to UI Automation.
Public class | ToolWindowContainerAutomationPeer | Exposes ToolWindowContainer types to UI Automation.
Public class | WindowControlAutomationPeer | Exposes WindowControl types to UI Automation.
Public class | WorkspaceAutomationPeer | Exposes Workspace types to UI Automation.


AdvancedTabControlAutomationPeer Class

AdvancedTabControlAutomationPeer Class
Exposes AdvancedTabControl types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
Windows.UI.Xaml.Automation.PeersItemsControlAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersAdvancedTabControlAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabControlAutomationPeer : ItemsControlAutomationPeer
Public Class AdvancedTabControlAutomationPeer
    Inherits ItemsControlAutomationPeer

The AdvancedTabControlAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabControlAutomationPeer | Initializes a new instance of the AdvancedTabControlAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | CreateItemAutomationPeer | (Inherited from ItemsControlAutomationPeer.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindItemByProperty | Retrieves an element by the specified property value. (Inherited from ItemsControlAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | OnCreateItemAutomationPeer | (Inherited from ItemsControlAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer Constructor

AdvancedTabControlAutomationPeer Constructor
Initializes a new instance of the AdvancedTabControlAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabControlAutomationPeer(
    AdvancedTabControl owner
)
Public Sub New (
    owner As AdvancedTabControl
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControl
The owner element.
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer Properties

AdvancedTabControlAutomationPeer Properties

The AdvancedTabControlAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer Methods

AdvancedTabControlAutomationPeer Methods

The AdvancedTabControlAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | CreateItemAutomationPeer | (Inherited from ItemsControlAutomationPeer.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindItemByProperty | Retrieves an element by the specified property value. (Inherited from ItemsControlAutomationPeer.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | OnCreateItemAutomationPeer | (Inherited from ItemsControlAutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabControlAutomationPeer.GetAutomationIdCore Method

AdvancedTabControlAutomationPeerGetAutomationIdCore Method
Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

AdvancedTabControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Class

AdvancedTabItemAutomationPeer Class
Exposes AdvancedTabItem types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersItemAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersAdvancedTabItemAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabItemAutomationPeer : ItemAutomationPeer
Public Class AdvancedTabItemAutomationPeer
    Inherits ItemAutomationPeer

The AdvancedTabItemAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItemAutomationPeer | Initializes a new instance of the AdvancedTabItemAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Realize | Makes the virtual item fully accessible as a Microsoft UI Automation element. (Inherited from ItemAutomationPeer.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Constructor

AdvancedTabItemAutomationPeer Constructor
Initializes a new instance of the AdvancedTabItemAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabItemAutomationPeer(
    Object owner,
    AdvancedTabControlAutomationPeer tabControlAutomationPeer
)
Public Sub New (
    owner As Object,
    tabControlAutomationPeer As AdvancedTabControlAutomationPeer
)

Parameters

owner
Type: SystemObject
The owner element.
tabControlAutomationPeer
Type: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersAdvancedTabControlAutomationPeer
The items control.
See Also

Reference

AdvancedTabItemAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Properties

AdvancedTabItemAutomationPeer Properties

The AdvancedTabItemAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Item | Gets the data item in the Items collection that is associated with this ItemAutomationPeer. (Inherited from ItemAutomationPeer.)
Public property | ItemsControlAutomationPeer | Gets the ItemsControlAutomationPeer that is associated with the ItemsControl that holds the Items collection. (Inherited from ItemAutomationPeer.)
Top
See Also

Reference

AdvancedTabItemAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemAutomationPeer Methods

AdvancedTabItemAutomationPeer Methods

The AdvancedTabItemAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Realize | Makes the virtual item fully accessible as a Microsoft UI Automation element. (Inherited from ItemAutomationPeer.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

AdvancedTabItemAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Class

AdvancedTabItemWrapperAutomationPeer Class
Exposes AdvancedTabItem types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersAdvancedTabItemWrapperAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabItemWrapperAutomationPeer : FrameworkElementAutomationPeer
Public Class AdvancedTabItemWrapperAutomationPeer
    Inherits FrameworkElementAutomationPeer

The AdvancedTabItemWrapperAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabItemWrapperAutomationPeer | Initializes a new instance of the AdvancedTabItemWrapperAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Constructor

AdvancedTabItemWrapperAutomationPeer Constructor
Initializes a new instance of the AdvancedTabItemWrapperAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabItemWrapperAutomationPeer(
    AdvancedTabItem owner
)
Public Sub New (
    owner As AdvancedTabItem
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabItem
The owner element.
See Also

Reference

AdvancedTabItemWrapperAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Properties

AdvancedTabItemWrapperAutomationPeer Properties

The AdvancedTabItemWrapperAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

AdvancedTabItemWrapperAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


AdvancedTabItemWrapperAutomationPeer Methods

AdvancedTabItemWrapperAutomationPeer Methods

The AdvancedTabItemWrapperAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClassName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

AdvancedTabItemWrapperAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Class

DockHostAutomationPeer Class
Exposes DockHost types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockHostAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockHostAutomationPeer : FrameworkElementAutomationPeer
Public Class DockHostAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockHostAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DockHostAutomationPeer | Initializes a new instance of the DockHostAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Constructor

DockHostAutomationPeer Constructor
Initializes a new instance of the DockHostAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHostAutomationPeer(
    DockHost owner
)
Public Sub New (
    owner As DockHost
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The owner element.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Properties

DockHostAutomationPeer Properties

The DockHostAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer Methods

DockHostAutomationPeer Methods

The DockHostAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetAutomationControlTypeCore Method

DockHostAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetAutomationIdCore Method

DockHostAutomationPeerGetAutomationIdCore Method
Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetChildrenCore Method

DockHostAutomationPeerGetChildrenCore Method
Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As IList(Of AutomationPeer)

Return Value

Type: IList AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetClassNameCore Method

DockHostAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetClickablePointCore Method

DockHostAutomationPeerGetClickablePointCore Method
Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockHostAutomationPeer.GetLocalizedControlTypeCore Method

DockHostAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DockHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Class

DockingWindowAutomationPeerBase Class
Exposes DockingWindow types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockingWindowAutomationPeerBase
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDocumentWindowAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersToolWindowAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DockingWindowAutomationPeerBase : FrameworkElementAutomationPeer
Public MustInherit Class DockingWindowAutomationPeerBase
    Inherits FrameworkElementAutomationPeer

The DockingWindowAutomationPeerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindowAutomationPeerBase | Initializes a new instance of the DockingWindowAutomationPeerBase class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Constructor

DockingWindowAutomationPeerBase Constructor
Initializes a new instance of the DockingWindowAutomationPeerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DockingWindowAutomationPeerBase(
    DockingWindow owner
)
Protected Sub New (
    owner As DockingWindow
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The owner element.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Properties

DockingWindowAutomationPeerBase Properties

The DockingWindowAutomationPeerBase type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase Methods

DockingWindowAutomationPeerBase Methods

The DockingWindowAutomationPeerBase type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetAutomationControlTypeCore Method

DockingWindowAutomationPeerBaseGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetClassNameCore Method

DockingWindowAutomationPeerBaseGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowAutomationPeerBase.GetNameCore Method

DockingWindowAutomationPeerBaseGetNameCore Method
Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

DockingWindowAutomationPeerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Class

DockingWindowContainerBaseAutomationPeer Class
Exposes DockingWindowContainerBase types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockingWindowContainerBaseAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersTabbedMdiContainerAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersToolWindowContainerAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DockingWindowContainerBaseAutomationPeer : FrameworkElementAutomationPeer
Public MustInherit Class DockingWindowContainerBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockingWindowContainerBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindowContainerBaseAutomationPeer | Initializes a new instance of the DockingWindowContainerBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Constructor

DockingWindowContainerBaseAutomationPeer Constructor
Initializes a new instance of the DockingWindowContainerBaseAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DockingWindowContainerBaseAutomationPeer(
    DockingWindowContainerBase owner
)
Protected Sub New (
    owner As DockingWindowContainerBase
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockingWindowContainerBase
The owner element.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Properties

DockingWindowContainerBaseAutomationPeer Properties

The DockingWindowContainerBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer Methods

DockingWindowContainerBaseAutomationPeer Methods

The DockingWindowContainerBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetAutomationControlTypeCore Method

DockingWindowContainerBaseAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetAutomationIdCore Method

DockingWindowContainerBaseAutomationPeerGetAutomationIdCore Method
Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetAutomationIdCore()
Protected Overrides Function GetAutomationIdCore As String

Return Value

Type: String
The string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetChildrenCore Method

DockingWindowContainerBaseAutomationPeerGetChildrenCore Method
Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As IList(Of AutomationPeer)

Return Value

Type: IList AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockingWindowContainerBaseAutomationPeer.GetClassNameCore Method

DockingWindowContainerBaseAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockingWindowContainerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Class

DockSiteAutomationPeer Class
Exposes DockSite types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockSiteAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockSiteAutomationPeer : FrameworkElementAutomationPeer
Public Class DockSiteAutomationPeer
    Inherits FrameworkElementAutomationPeer

The DockSiteAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DockSiteAutomationPeer | Initializes a new instance of the DockSiteAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Constructor

DockSiteAutomationPeer Constructor
Initializes a new instance of the DockSiteAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSiteAutomationPeer(
    DockSite owner
)
Public Sub New (
    owner As DockSite
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The owner element.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Properties

DockSiteAutomationPeer Properties

The DockSiteAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer Methods

DockSiteAutomationPeer Methods

The DockSiteAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetAutomationControlTypeCore Method

DockSiteAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetClassNameCore Method

DockSiteAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetClickablePointCore Method

DockSiteAutomationPeerGetClickablePointCore Method
Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DockSiteAutomationPeer.GetLocalizedControlTypeCore Method

DockSiteAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DockSiteAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Class

DocumentWindowAutomationPeer Class
Exposes DocumentWindow types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockingWindowAutomationPeerBase
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDocumentWindowAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DocumentWindowAutomationPeer : DockingWindowAutomationPeerBase
Public Class DocumentWindowAutomationPeer
    Inherits DockingWindowAutomationPeerBase

The DocumentWindowAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentWindowAutomationPeer | Initializes a new instance of the DocumentWindowAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Constructor

DocumentWindowAutomationPeer Constructor
Initializes a new instance of the DocumentWindowAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DocumentWindowAutomationPeer(
    DocumentWindow owner
)
Public Sub New (
    owner As DocumentWindow
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingDocumentWindow
The owner element.
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Properties

DocumentWindowAutomationPeer Properties

The DocumentWindowAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer Methods

DocumentWindowAutomationPeer Methods

The DocumentWindowAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


DocumentWindowAutomationPeer.GetLocalizedControlTypeCore Method

DocumentWindowAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

DocumentWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Class

SplitContainerAutomationPeer Class
Exposes SplitContainer types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersSplitContainerAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SplitContainerAutomationPeer : FrameworkElementAutomationPeer
Public Class SplitContainerAutomationPeer
    Inherits FrameworkElementAutomationPeer

The SplitContainerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainerAutomationPeer | Initializes a new instance of the SplitContainerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates the explicit control orientation, if any. (Overrides AutomationPeerGetOrientationCore.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Constructor

SplitContainerAutomationPeer Constructor
Initializes a new instance of the SplitContainerAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SplitContainerAutomationPeer(
    SplitContainer owner
)
Public Sub New (
    owner As SplitContainer
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingSplitContainer
The owner element.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Properties

SplitContainerAutomationPeer Properties

The SplitContainerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer Methods

SplitContainerAutomationPeer Methods

The SplitContainerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Gets a value that indicates the explicit control orientation, if any. (Overrides AutomationPeerGetOrientationCore.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetAutomationControlTypeCore Method

SplitContainerAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetClassNameCore Method

SplitContainerAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetClickablePointCore Method

SplitContainerAutomationPeerGetClickablePointCore Method
Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetLocalizedControlTypeCore Method

SplitContainerAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


SplitContainerAutomationPeer.GetOrientationCore Method

SplitContainerAutomationPeerGetOrientationCore Method
Gets a value that indicates the explicit control orientation, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationOrientation GetOrientationCore()
Protected Overrides Function GetOrientationCore As AutomationOrientation

Return Value

Type: AutomationOrientation
The orientation.
See Also

Reference

SplitContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Class

StandardMdiHostAutomationPeer Class
Exposes StandardMdiHost types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersStandardMdiHostAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardMdiHostAutomationPeer : FrameworkElementAutomationPeer
Public Class StandardMdiHostAutomationPeer
    Inherits FrameworkElementAutomationPeer

The StandardMdiHostAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiHostAutomationPeer | Initializes a new instance of the StandardMdiHostAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Constructor

StandardMdiHostAutomationPeer Constructor
Initializes a new instance of the StandardMdiHostAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardMdiHostAutomationPeer(
    StandardMdiHost owner
)
Public Sub New (
    owner As StandardMdiHost
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingStandardMdiHost
The owner element.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Properties

StandardMdiHostAutomationPeer Properties

The StandardMdiHostAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer Methods

StandardMdiHostAutomationPeer Methods

The StandardMdiHostAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetAutomationControlTypeCore Method

StandardMdiHostAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetChildrenCore Method

StandardMdiHostAutomationPeerGetChildrenCore Method
Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As IList(Of AutomationPeer)

Return Value

Type: IList AutomationPeer
The collection of AutomationPeer objects for child elements.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetClassNameCore Method

StandardMdiHostAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetClickablePointCore Method

StandardMdiHostAutomationPeerGetClickablePointCore Method
Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


StandardMdiHostAutomationPeer.GetLocalizedControlTypeCore Method

StandardMdiHostAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

StandardMdiHostAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Class

TabbedMdiContainerAutomationPeer Class
Exposes TabbedMdiContainer types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockingWindowContainerBaseAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersTabbedMdiContainerAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TabbedMdiContainerAutomationPeer : DockingWindowContainerBaseAutomationPeer
Public Class TabbedMdiContainerAutomationPeer
    Inherits DockingWindowContainerBaseAutomationPeer

The TabbedMdiContainerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiContainerAutomationPeer | Initializes a new instance of the TabbedMdiContainerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Constructor

TabbedMdiContainerAutomationPeer Constructor
Initializes a new instance of the TabbedMdiContainerAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabbedMdiContainerAutomationPeer(
    TabbedMdiContainer owner
)
Public Sub New (
    owner As TabbedMdiContainer
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingTabbedMdiContainer
The owner element.
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Properties

TabbedMdiContainerAutomationPeer Properties

The TabbedMdiContainerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer Methods

TabbedMdiContainerAutomationPeer Methods

The TabbedMdiContainerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


TabbedMdiContainerAutomationPeer.GetLocalizedControlTypeCore Method

TabbedMdiContainerAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

TabbedMdiContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Class

ToolWindowAutomationPeer Class
Exposes ToolWindow types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockingWindowAutomationPeerBase
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersToolWindowAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindowAutomationPeer : DockingWindowAutomationPeerBase
Public Class ToolWindowAutomationPeer
    Inherits DockingWindowAutomationPeerBase

The ToolWindowAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowAutomationPeer | Initializes a new instance of the ToolWindowAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Constructor

ToolWindowAutomationPeer Constructor
Initializes a new instance of the ToolWindowAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowAutomationPeer(
    ToolWindow owner
)
Public Sub New (
    owner As ToolWindow
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingToolWindow
The owner element.
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Properties

ToolWindowAutomationPeer Properties

The ToolWindowAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer Methods

ToolWindowAutomationPeer Methods

The ToolWindowAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Inherited from DockingWindowAutomationPeerBase.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowAutomationPeer.GetLocalizedControlTypeCore Method

ToolWindowAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

ToolWindowAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Class

ToolWindowContainerAutomationPeer Class
Exposes ToolWindowContainer types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersDockingWindowContainerBaseAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersToolWindowContainerAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindowContainerAutomationPeer : DockingWindowContainerBaseAutomationPeer
Public Class ToolWindowContainerAutomationPeer
    Inherits DockingWindowContainerBaseAutomationPeer

The ToolWindowContainerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainerAutomationPeer | Initializes a new instance of the ToolWindowContainerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Constructor

ToolWindowContainerAutomationPeer Constructor
Initializes a new instance of the ToolWindowContainerAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerAutomationPeer(
    ToolWindowContainer owner
)
Public Sub New (
    owner As ToolWindowContainer
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingToolWindowContainer
The owner element.
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Properties

ToolWindowContainerAutomationPeer Properties

The ToolWindowContainerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer Methods

ToolWindowContainerAutomationPeer Methods

The ToolWindowContainerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the string that uniquely identifies the FrameworkElement that is associated with this FrameworkElementAutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from DockingWindowContainerBaseAutomationPeer.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ToolWindowContainerAutomationPeer.GetLocalizedControlTypeCore Method

ToolWindowContainerAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

ToolWindowContainerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Class

WindowControlAutomationPeer Class
Exposes WindowControl types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersWindowControlAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WindowControlAutomationPeer : FrameworkElementAutomationPeer,
    ITransformProvider, IWindowProvider
Public Class WindowControlAutomationPeer
    Inherits FrameworkElementAutomationPeer
    Implements ITransformProvider, IWindowProvider

The WindowControlAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | WindowControlAutomationPeer | Initializes a new instance of the WindowControlAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides AutomationPeerGetPatternCore(PatternInterface).)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Constructor

WindowControlAutomationPeer Constructor
Initializes a new instance of the WindowControlAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WindowControlAutomationPeer(
    WindowControl owner
)
Public Sub New (
    owner As WindowControl
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingWindowControl
The owner element.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Properties

WindowControlAutomationPeer Properties

The WindowControlAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer Methods

WindowControlAutomationPeer Methods

The WindowControlAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets text that describes the element that is associated with this automation peer. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Gets the object that supports the specified control pattern of the element that is associated with this automation peer. (Overrides AutomationPeerGetPatternCore(PatternInterface).)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetAutomationControlTypeCore Method

WindowControlAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetClassNameCore Method

WindowControlAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetLocalizedControlTypeCore Method

WindowControlAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetNameCore Method

WindowControlAutomationPeerGetNameCore Method
Gets text that describes the element that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetNameCore()
Protected Overrides Function GetNameCore As String

Return Value

Type: String
The name.
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WindowControlAutomationPeer.GetPatternCore Method

WindowControlAutomationPeerGetPatternCore Method
Gets the object that supports the specified control pattern of the element that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object GetPatternCore(
    PatternInterface patternInterface
)
Protected Overrides Function GetPatternCore (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: Windows.UI.Xaml.Automation.PeersPatternInterface
A value in the enumeration.

Return Value

Type: Object
This method will return a 'this' pointer in the follow cases:
  • If patternInterface is Transform. -
  • If patternInterface is Window. -
See Also

Reference

WindowControlAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Class

WorkspaceAutomationPeer Class
Exposes Workspace types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.PeersWorkspaceAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class WorkspaceAutomationPeer : FrameworkElementAutomationPeer
Public Class WorkspaceAutomationPeer
    Inherits FrameworkElementAutomationPeer

The WorkspaceAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | WorkspaceAutomationPeer | Initializes a new instance of the WorkspaceAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Constructor

WorkspaceAutomationPeer Constructor
Initializes a new instance of the WorkspaceAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WorkspaceAutomationPeer(
    Workspace owner
)
Public Sub New (
    owner As Workspace
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.DockingWorkspace
The owner element.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Properties

WorkspaceAutomationPeer Properties

The WorkspaceAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer Methods

WorkspaceAutomationPeer Methods

The WorkspaceAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Overrides AutomationPeerGetClickablePointCore.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetAutomationControlTypeCore Method

WorkspaceAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetClassNameCore Method

WorkspaceAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetClickablePointCore Method

WorkspaceAutomationPeerGetClickablePointCore Method
Gets a point on the element that is associated with the automation peer that responds to a mouse click.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Point GetClickablePointCore()
Protected Overrides Function GetClickablePointCore As Point

Return Value

Type: Point
A point in the clickable area of the element.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


WorkspaceAutomationPeer.GetLocalizedControlTypeCore Method

WorkspaceAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

WorkspaceAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace
Contains primitive classes used for Docking & MDI controls.
Classes
 | Class | Description
Public class | AdvancedTabPanel | Represents a Panel that is used by an AdvancedTabControl.
Public class | AutoHideContainerSplitter | Represents a splitter for an auto-hide container.
Public class | AutoHideTabGroup | Represents a tab group that can contain dockable windows in auto-hide mode.
Public class | AutoHideTabItem | Represents a tab item the provides access to a dockable window in auto-hide mode.
Public class | AutoHideTabStrip | Represents an auto-hide tab strip.
Public class | DockGuideBase | Represents a dock guide for the outer bottom side of a dock host.
Public class | DockGuideCenter | Represents a center dock guide.
Public class | DockGuideCross | Represents a cross-shaped container for other dock guides.
Public class | DockGuideInnerBottom | Represents an inner bottom dock guide.
Public class | DockGuideInnerLeft | Represents an inner left dock guide.
Public class | DockGuideInnerRight | Represents an inner right dock guide.
Public class | DockGuideInnerTop | Represents an inner top dock guide.
Public class | DockGuideOuterBottom | Represents an outer bottom dock guide.
Public class | DockGuideOuterLeft | Represents an outer left dock guide.
Public class | DockGuideOuterRight | Represents an outer right dock guide.
Public class | DockGuideOuterTop | Represents an outer top dock guide.
Public class | DockingWindowContainerBase | Represents the base class for a control that can contain multiple docking windows, with one selected.
Public class | DockPreview | Represents a dock preview that shows when dragging over a dock guide.
Public class | FloatingWindowControl | Represents a WindowControl that is used as the root control of a hosted floating window.
Public class | FloatPreview | Represents a float preview that can show when not dragging over a dock guide.
Public class | MdiHostBase | Represents the base class for a container that hosts docking windows in a MDI (multiple-document interface).
Public class | NewTabButton | Represents a new tab button.
Public class | NonUIElementConverter | Represents a value converter that only passes through a value if it isn't a UIElement.
Public class | SplitContainerPanel | Represents a Panel that is used by a SplitContainer.
Public class | SplitContainerSplitter | Represents a splitter within a SplitContainer.
Public class | SplitterBase | Represents an abstract base class for a splitter.
Public class | StandardMdiItemsControl | Represents an ItemsControl that displays standard MDI windows.
Public class | StandardMdiPanel | Represents a Panel that is used by a StandardMdiItemsControl.
Public class | StandardMdiWindowControl | Represents a WindowControl that is used as the root control of a hosted floating window.
Public class | StandardSwitcherItem | Represents an item in a StandardSwitcher.
Public class | SwitcherBase | Provides the base class for a component that provides Ctrl+Tab-like switching of docking windows.
Public class | TabbedMdiContainerTabControl | Represents an AdvancedTabControl for use within a TabbedMdiContainer.
Public class | TabItemBorder | Renders a border for a tab item.
Public class | TitleBarPanel | Represents a Panel within a title bar.
Public class | TitleConverter | Represents a value converter that can shorten long text by only allowing a certain prefix number of characters at the start, then injecting the patch string, and allowing a certain suffix number of characters at the end.
Public class | ToolWindowContainerTabControl | Represents an AdvancedTabControl for use within a ToolWindowContainer.


AdvancedTabPanel Class

AdvancedTabPanel Class
Represents a Panel that is used by an AdvancedTabControl.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesAdvancedTabPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdvancedTabPanel : Panel,
    IOrientedElement
Public Class AdvancedTabPanel
    Inherits Panel
    Implements IOrientedElement

The AdvancedTabPanel type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedTabPanel | Initializes an instance of the AdvancedTabPanel class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel Constructor

AdvancedTabPanel Constructor
Initializes an instance of the AdvancedTabPanel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdvancedTabPanel()
Public Sub New
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel Properties

AdvancedTabPanel Properties

The AdvancedTabPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel.Orientation Property

AdvancedTabPanelOrientation Property
Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel Methods

AdvancedTabPanel Methods

The AdvancedTabPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel.ArrangeOverride Method

AdvancedTabPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel.ArrangeOverride Method (Size)

AdvancedTabPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

AdvancedTabPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel.MeasureOverride Method

AdvancedTabPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel.MeasureOverride Method (Size)

AdvancedTabPanelMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

AdvancedTabPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel Events

AdvancedTabPanel Events

The AdvancedTabPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel Fields

AdvancedTabPanel Fields

The AdvancedTabPanel type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AdvancedTabPanel.OrientationProperty Field

AdvancedTabPanelOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

AdvancedTabPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Class

AutoHideContainerSplitter Class
Represents a splitter for an auto-hide container.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSplitterBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesAutoHideContainerSplitter

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AutoHideContainerSplitter : SplitterBase,
    IOrientedElement
Public Class AutoHideContainerSplitter
    Inherits SplitterBase
    Implements IOrientedElement

The AutoHideContainerSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideContainerSplitter | Initializes an instance of the AutoHideContainerSplitter class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Constructor

AutoHideContainerSplitter Constructor
Initializes an instance of the AutoHideContainerSplitter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutoHideContainerSplitter()
Public Sub New
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Properties

AutoHideContainerSplitter Properties

The AutoHideContainerSplitter type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Methods

AutoHideContainerSplitter Methods

The AutoHideContainerSplitter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideContainerSplitter Events

AutoHideContainerSplitter Events

The AutoHideContainerSplitter type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AutoHideContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup Class

AutoHideTabGroup Class
Represents a tab group that can contain dockable windows in auto-hide mode.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesAutoHideTabGroup

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AutoHideTabGroup : ItemsControl
Public Class AutoHideTabGroup
    Inherits ItemsControl

The AutoHideTabGroup type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideTabGroup | Initializes an instance of the AutoHideTabGroup class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup Constructor

AutoHideTabGroup Constructor
Initializes an instance of the AutoHideTabGroup class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutoHideTabGroup()
Public Sub New
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup Properties

AutoHideTabGroup Properties

The AutoHideTabGroup type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup.Placement Property

AutoHideTabGroupPlacement Property
Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side Placement { get; set; }
Public Property Placement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup Methods

AutoHideTabGroup Methods

The AutoHideTabGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup.ClearContainerForItemOverride Method

AutoHideTabGroupClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup.GetContainerForItemOverride Method

AutoHideTabGroupGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup.IsItemItsOwnContainerOverride Method

AutoHideTabGroupIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup.PrepareContainerForItemOverride Method

AutoHideTabGroupPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup Events

AutoHideTabGroup Events

The AutoHideTabGroup type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup Fields

AutoHideTabGroup Fields

The AutoHideTabGroup type exposes the following members.

Fields
Name | Description
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabGroup.PlacementProperty Field

AutoHideTabGroupPlacementProperty Field
Identifies the Placement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlacementProperty
Public Shared ReadOnly PlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Placement dependency property.
See Also

Reference

AutoHideTabGroup Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem Class

AutoHideTabItem Class
Represents a tab item the provides access to a dockable window in auto-hide mode.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesAutoHideTabItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AutoHideTabItem : ContentControl
Public Class AutoHideTabItem
    Inherits ContentControl

The AutoHideTabItem type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideTabItem | Initializes an instance of the AutoHideTabItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoHidePopupOpen | Gets or sets whether the related auto-hide popup is currently visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem Constructor

AutoHideTabItem Constructor
Initializes an instance of the AutoHideTabItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutoHideTabItem()
Public Sub New
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem Properties

AutoHideTabItem Properties

The AutoHideTabItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoHidePopupOpen | Gets or sets whether the related auto-hide popup is currently visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsImageVisible | Gets whether the embedded image is visible.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.CornerRadius Property

AutoHideTabItemCornerRadius Property
Gets or sets the corner radius of the tab border, relative to a top-facing tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the tab border, relative to a top-facing tab.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsAutoHidePopupOpen Property

AutoHideTabItemIsAutoHidePopupOpen Property
Gets or sets whether the related auto-hide popup is currently visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAutoHidePopupOpen { get; set; }
Public Property IsAutoHidePopupOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the related auto-hide popup is currently visible; otherwise, false. The default value is false.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsImageVisible Property

AutoHideTabItemIsImageVisible Property
Gets whether the embedded image is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsImageVisible { get; }
Public ReadOnly Property IsImageVisible As Boolean
    Get

Property Value

Type: Boolean
true if the embedded image is visible; otherwise, false. The default value is false.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.Placement Property

AutoHideTabItemPlacement Property
Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side Placement { get; set; }
Public Property Placement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem Methods

AutoHideTabItem Methods

The AutoHideTabItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.OnApplyTemplate Method

AutoHideTabItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem Events

AutoHideTabItem Events

The AutoHideTabItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem Fields

AutoHideTabItem Fields

The AutoHideTabItem type exposes the following members.

Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsAutoHidePopupOpenProperty | Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.
IsImageVisibleProperty | Identifies the IsImageVisible dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
Top
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.CornerRadiusProperty Field

AutoHideTabItemCornerRadiusProperty Field
Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsAutoHidePopupOpenProperty Field

AutoHideTabItemIsAutoHidePopupOpenProperty Field
Identifies the IsAutoHidePopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoHidePopupOpenProperty
Public Shared ReadOnly IsAutoHidePopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoHidePopupOpen dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.IsImageVisibleProperty Field

AutoHideTabItemIsImageVisibleProperty Field
Identifies the IsImageVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsImageVisibleProperty
Public Shared ReadOnly IsImageVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsImageVisible dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabItem.PlacementProperty Field

AutoHideTabItemPlacementProperty Field
Identifies the Placement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlacementProperty
Public Shared ReadOnly PlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Placement dependency property.
See Also

Reference

AutoHideTabItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip Class

AutoHideTabStrip Class
Represents an auto-hide tab strip.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesAutoHideTabStrip

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AutoHideTabStrip : ItemsControl
Public Class AutoHideTabStrip
    Inherits ItemsControl

The AutoHideTabStrip type exposes the following members.

Constructors
 | Name | Description
Public method | AutoHideTabStrip | Initializes an instance of the AutoHideTabStrip class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsHorizontal | Gets whether the tabstrip is positioned horizontally.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemTemplate | Gets or sets the DataTemplate to use for rendering the tab items.
Public property | TabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the tab items.
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsHorizontalProperty | Identifies the IsHorizontal dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
TabItemTemplateProperty | Identifies the TabItemTemplate dependency property. This field is read-only.
TabItemTemplateSelectorProperty | Identifies the TabItemTemplateSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip Constructor

AutoHideTabStrip Constructor
Initializes an instance of the AutoHideTabStrip class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutoHideTabStrip()
Public Sub New
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip Properties

AutoHideTabStrip Properties

The AutoHideTabStrip type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsHorizontal | Gets whether the tabstrip is positioned horizontally.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Placement | Gets or sets the side upon which the tabstrip is placed.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemTemplate | Gets or sets the DataTemplate to use for rendering the tab items.
Public property | TabItemTemplateSelector | Gets or sets the DataTemplateSelector to use for rendering the tab items.
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.IsHorizontal Property

AutoHideTabStripIsHorizontal Property
Gets whether the tabstrip is positioned horizontally.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHorizontal { get; }
Public ReadOnly Property IsHorizontal As Boolean
    Get

Property Value

Type: Boolean
true if the tabstrip is positioned horizontally; otherwise, false.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.Placement Property

AutoHideTabStripPlacement Property
Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side Placement { get; set; }
Public Property Placement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplate Property

AutoHideTabStripTabItemTemplate Property
Gets or sets the DataTemplate to use for rendering the tab items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate TabItemTemplate { get; set; }
Public Property TabItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for rendering the tab items.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplateSelector Property

AutoHideTabStripTabItemTemplateSelector Property
Gets or sets the DataTemplateSelector to use for rendering the tab items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector TabItemTemplateSelector { get; set; }
Public Property TabItemTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for rendering the tab items.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip Methods

AutoHideTabStrip Methods

The AutoHideTabStrip type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.ClearContainerForItemOverride Method

AutoHideTabStripClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.GetContainerForItemOverride Method

AutoHideTabStripGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.IsItemItsOwnContainerOverride Method

AutoHideTabStripIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.PrepareContainerForItemOverride Method

AutoHideTabStripPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip Events

AutoHideTabStrip Events

The AutoHideTabStrip type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip Fields

AutoHideTabStrip Fields

The AutoHideTabStrip type exposes the following members.

Fields
Name | Description
IsHorizontalProperty | Identifies the IsHorizontal dependency property. This field is read-only.
PlacementProperty | Identifies the Placement dependency property. This field is read-only.
TabItemTemplateProperty | Identifies the TabItemTemplate dependency property. This field is read-only.
TabItemTemplateSelectorProperty | Identifies the TabItemTemplateSelector dependency property. This field is read-only.
Top
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.IsHorizontalProperty Field

AutoHideTabStripIsHorizontalProperty Field
Identifies the IsHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHorizontalProperty
Public Shared ReadOnly IsHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHorizontal dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.PlacementProperty Field

AutoHideTabStripPlacementProperty Field
Identifies the Placement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlacementProperty
Public Shared ReadOnly PlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Placement dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplateProperty Field

AutoHideTabStripTabItemTemplateProperty Field
Identifies the TabItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemTemplateProperty
Public Shared ReadOnly TabItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemTemplate dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


AutoHideTabStrip.TabItemTemplateSelectorProperty Field

AutoHideTabStripTabItemTemplateSelectorProperty Field
Identifies the TabItemTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemTemplateSelectorProperty
Public Shared ReadOnly TabItemTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemTemplateSelector dependency property.
See Also

Reference

AutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase Class

DockGuideBase Class
Represents a dock guide for the outer bottom side of a dock host.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DockGuideBase : ContentControl
Public MustInherit Class DockGuideBase
    Inherits ContentControl

The DockGuideBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DockGuideBase | Initializes a new instance of the DockGuideBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control.
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideCenter
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerBottom
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerLeft
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerRight
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerTop
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterBottom
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterLeft
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterRight
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterTop


DockGuideBase Constructor

DockGuideBase Constructor
Initializes a new instance of the DockGuideBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DockGuideBase()
Protected Sub New
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase Properties

DockGuideBase Properties

The DockGuideBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control.
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase.IsSelected Property

DockGuideBaseIsSelected Property
Gets or sets whether the dock guide is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the dock guide is selected; otherwise, false.
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase.Side Property

DockGuideBaseSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract Nullable<Side> Side { get; }
Public MustOverride ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase.Target Property

DockGuideBaseTarget Property
Gets the target control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDockTarget Target { get; }
Public ReadOnly Property Target As IDockTarget
    Get

Property Value

Type: IDockTarget
The target control.
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase Methods

DockGuideBase Methods

The DockGuideBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase Events

DockGuideBase Events

The DockGuideBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase Fields

DockGuideBase Fields

The DockGuideBase type exposes the following members.

Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideBase.IsSelectedProperty Field

DockGuideBaseIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

DockGuideBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCenter Class

DockGuideCenter Class
Represents a center dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideCenter

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideCenter : DockGuideBase
Public Class DockGuideCenter
    Inherits DockGuideBase

The DockGuideCenter type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideCenter | Initializes an instance of the DockGuideCenter class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCenter Constructor

DockGuideCenter Constructor
Initializes an instance of the DockGuideCenter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideCenter()
Public Sub New
See Also

Reference

DockGuideCenter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCenter Properties

DockGuideCenter Properties

The DockGuideCenter type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideCenter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCenter.Side Property

DockGuideCenterSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideCenter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCenter Methods

DockGuideCenter Methods

The DockGuideCenter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideCenter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCenter Events

DockGuideCenter Events

The DockGuideCenter type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideCenter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCross Class

DockGuideCross Class
Represents a cross-shaped container for other dock guides.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideCross

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideCross : Control
Public Class DockGuideCross
    Inherits Control

The DockGuideCross type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideCross | Initializes an instance of the DockGuideCross class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCross Constructor

DockGuideCross Constructor
Initializes an instance of the DockGuideCross class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideCross()
Public Sub New
See Also

Reference

DockGuideCross Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCross Properties

DockGuideCross Properties

The DockGuideCross type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideCross Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCross Methods

DockGuideCross Methods

The DockGuideCross type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideCross Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCross.OnApplyTemplate Method

DockGuideCrossOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DockGuideCross Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideCross Events

DockGuideCross Events

The DockGuideCross type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideCross Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Class

DockGuideInnerBottom Class
Represents an inner bottom dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerBottom

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideInnerBottom : DockGuideBase
Public Class DockGuideInnerBottom
    Inherits DockGuideBase

The DockGuideInnerBottom type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerBottom | Initializes an instance of the DockGuideInnerBottom class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Constructor

DockGuideInnerBottom Constructor
Initializes an instance of the DockGuideInnerBottom class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideInnerBottom()
Public Sub New
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Properties

DockGuideInnerBottom Properties

The DockGuideInnerBottom type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerBottom.Side Property

DockGuideInnerBottomSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Methods

DockGuideInnerBottom Methods

The DockGuideInnerBottom type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerBottom Events

DockGuideInnerBottom Events

The DockGuideInnerBottom type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideInnerBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Class

DockGuideInnerLeft Class
Represents an inner left dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerLeft

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideInnerLeft : DockGuideBase
Public Class DockGuideInnerLeft
    Inherits DockGuideBase

The DockGuideInnerLeft type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerLeft | Initializes an instance of the DockGuideInnerLeft class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Constructor

DockGuideInnerLeft Constructor
Initializes an instance of the DockGuideInnerLeft class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideInnerLeft()
Public Sub New
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Properties

DockGuideInnerLeft Properties

The DockGuideInnerLeft type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerLeft.Side Property

DockGuideInnerLeftSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Methods

DockGuideInnerLeft Methods

The DockGuideInnerLeft type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerLeft Events

DockGuideInnerLeft Events

The DockGuideInnerLeft type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideInnerLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerRight Class

DockGuideInnerRight Class
Represents an inner right dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerRight

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideInnerRight : DockGuideBase
Public Class DockGuideInnerRight
    Inherits DockGuideBase

The DockGuideInnerRight type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerRight | Initializes an instance of the DockGuideInnerRight class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerRight Constructor

DockGuideInnerRight Constructor
Initializes an instance of the DockGuideInnerRight class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideInnerRight()
Public Sub New
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerRight Properties

DockGuideInnerRight Properties

The DockGuideInnerRight type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerRight.Side Property

DockGuideInnerRightSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerRight Methods

DockGuideInnerRight Methods

The DockGuideInnerRight type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerRight Events

DockGuideInnerRight Events

The DockGuideInnerRight type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideInnerRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerTop Class

DockGuideInnerTop Class
Represents an inner top dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideInnerTop

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideInnerTop : DockGuideBase
Public Class DockGuideInnerTop
    Inherits DockGuideBase

The DockGuideInnerTop type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideInnerTop | Initializes an instance of the DockGuideInnerTop class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerTop Constructor

DockGuideInnerTop Constructor
Initializes an instance of the DockGuideInnerTop class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideInnerTop()
Public Sub New
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerTop Properties

DockGuideInnerTop Properties

The DockGuideInnerTop type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerTop.Side Property

DockGuideInnerTopSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerTop Methods

DockGuideInnerTop Methods

The DockGuideInnerTop type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideInnerTop Events

DockGuideInnerTop Events

The DockGuideInnerTop type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideInnerTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Class

DockGuideOuterBottom Class
Represents an outer bottom dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterBottom

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideOuterBottom : DockGuideBase
Public Class DockGuideOuterBottom
    Inherits DockGuideBase

The DockGuideOuterBottom type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterBottom | Initializes an instance of the DockGuideOuterBottom class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Constructor

DockGuideOuterBottom Constructor
Initializes an instance of the DockGuideOuterBottom class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideOuterBottom()
Public Sub New
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Properties

DockGuideOuterBottom Properties

The DockGuideOuterBottom type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterBottom.Side Property

DockGuideOuterBottomSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Methods

DockGuideOuterBottom Methods

The DockGuideOuterBottom type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterBottom Events

DockGuideOuterBottom Events

The DockGuideOuterBottom type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideOuterBottom Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Class

DockGuideOuterLeft Class
Represents an outer left dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterLeft

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideOuterLeft : DockGuideBase
Public Class DockGuideOuterLeft
    Inherits DockGuideBase

The DockGuideOuterLeft type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterLeft | Initializes an instance of the DockGuideOuterLeft class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Constructor

DockGuideOuterLeft Constructor
Initializes an instance of the DockGuideOuterLeft class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideOuterLeft()
Public Sub New
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Properties

DockGuideOuterLeft Properties

The DockGuideOuterLeft type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterLeft.Side Property

DockGuideOuterLeftSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Methods

DockGuideOuterLeft Methods

The DockGuideOuterLeft type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterLeft Events

DockGuideOuterLeft Events

The DockGuideOuterLeft type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideOuterLeft Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterRight Class

DockGuideOuterRight Class
Represents an outer right dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterRight

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideOuterRight : DockGuideBase
Public Class DockGuideOuterRight
    Inherits DockGuideBase

The DockGuideOuterRight type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterRight | Initializes an instance of the DockGuideOuterRight class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterRight Constructor

DockGuideOuterRight Constructor
Initializes an instance of the DockGuideOuterRight class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideOuterRight()
Public Sub New
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterRight Properties

DockGuideOuterRight Properties

The DockGuideOuterRight type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterRight.Side Property

DockGuideOuterRightSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterRight Methods

DockGuideOuterRight Methods

The DockGuideOuterRight type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterRight Events

DockGuideOuterRight Events

The DockGuideOuterRight type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideOuterRight Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterTop Class

DockGuideOuterTop Class
Represents an outer top dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockGuideOuterTop

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockGuideOuterTop : DockGuideBase
Public Class DockGuideOuterTop
    Inherits DockGuideBase

The DockGuideOuterTop type exposes the following members.

Constructors
 | Name | Description
Public method | DockGuideOuterTop | Initializes an instance of the DockGuideOuterTop class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterTop Constructor

DockGuideOuterTop Constructor
Initializes an instance of the DockGuideOuterTop class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockGuideOuterTop()
Public Sub New
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterTop Properties

DockGuideOuterTop Properties

The DockGuideOuterTop type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the dock guide is selected. (Inherited from DockGuideBase.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Side | Gets the optional dock Side relative to the dock guide's target. (Overrides DockGuideBaseSide.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Target | Gets the target control. (Inherited from DockGuideBase.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterTop.Side Property

DockGuideOuterTopSide Property
Gets the optional dock Side relative to the dock guide's target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Nullable<Side> Side { get; }
Public Overrides ReadOnly Property Side As Nullable(Of Side)
    Get

Property Value

Type: Nullable Side
The optional dock Side relative to the dock guide's target.
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterTop Methods

DockGuideOuterTop Methods

The DockGuideOuterTop type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockGuideOuterTop Events

DockGuideOuterTop Events

The DockGuideOuterTop type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockGuideOuterTop Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Class

DockingWindowContainerBase Class
Represents the base class for a control that can contain multiple docking windows, with one selected.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockingWindowContainerBase
ActiproSoftware.UI.Xaml.Controls.DockingTabbedMdiContainer
ActiproSoftware.UI.Xaml.Controls.DockingToolWindowContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DockingWindowContainerBase : Control,
    IOrientedElement
Public MustInherit Class DockingWindowContainerBase
    Inherits Control
    Implements IOrientedElement

The DockingWindowContainerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DockingWindowContainerBase | Initializes an instance of the DockingWindowContainerBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed.
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible.
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Protected property | TabControl | Gets the tab control in the container's user interface.
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers.
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | WindowsCore | Gets the collection of child DockingWindow objects.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCommands | Updates the enabled states of the commands.
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows.
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility.
Protected method | UpdateVisualState | Updates the visual state.
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container.
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledResolvedProperty | Identifies the IsTabLayoutAnimationEnabledResolved dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabItemContainerStyleProperty | Identifies the TabItemContainerStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Constructor

DockingWindowContainerBase Constructor
Initializes an instance of the DockingWindowContainerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DockingWindowContainerBase()
Protected Sub New
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Properties

DockingWindowContainerBase Properties

The DockingWindowContainerBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the container is currently active, due to focus being within it.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabLayoutAnimationEnabled | Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed.
Public property | IsTabLayoutAnimationEnabledResolved | Gets whether animation effects are applied during tab layout, such as when tabs are added or removed.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets whether the tabstrip is visible.
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected in the container.
Public property | State | Gets the DockingWindowState that specifies the current state of the container.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Protected property | TabControl | Gets the tab control in the container's user interface.
Public property | TabControlStyle | Gets or sets the Style to use for the contained TabControl.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabItemContainerStyle | Gets or sets the Style to use for rendering the tab item containers.
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.
Public property | TabStripPlacement | Gets or sets a Side indicating the side upon which the tabs are located.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Protected property | WindowsCore | Gets the collection of child DockingWindow objects.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.CanTabsCloseOnMiddleClick Property

DockingWindowContainerBaseCanTabsCloseOnMiddleClick Property
Gets or sets whether tabs can close when a middle-click is performed over them.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanTabsCloseOnMiddleClick { get; set; }
Public Property CanTabsCloseOnMiddleClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs can close when a middle-click is performed over them; otherwise, false. The default value is true.
Remarks
The CanClose property must also be set to true for this behavior to work.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.DockHost Property

DockingWindowContainerBaseDockHost Property
Gets the DockHost that contains this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.DockSite Property

DockingWindowContainerBaseDockSite Property
Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.HasTabImages Property

DockingWindowContainerBaseHasTabImages Property
Gets or sets whether tabs display an embedded image when one is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasTabImages { get; set; }
Public Property HasTabImages As Boolean
    Get
    Set

Property Value

Type: Boolean
true if tabs display an embedded image when one is available; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsActive Property

DockingWindowContainerBaseIsActive Property
Gets whether the container is currently active, due to focus being within it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get

Property Value

Type: Boolean
true if the container is currently active, due to focus being within it; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabled Property

DockingWindowContainerBaseIsTabLayoutAnimationEnabled Property
Gets or sets whether animation effects should be applied during tab layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabLayoutAnimationEnabled { get; set; }
Public Property IsTabLayoutAnimationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if animation effects should be applied during tab layout, such as when tabs are added or removed; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabledResolved Property

DockingWindowContainerBaseIsTabLayoutAnimationEnabledResolved Property
Gets whether animation effects are applied during tab layout, such as when tabs are added or removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabLayoutAnimationEnabledResolved { get; }
Public ReadOnly Property IsTabLayoutAnimationEnabledResolved As Boolean
    Get

Property Value

Type: Boolean
true if animation effects are applied during tab layout, such as when tabs are added or removed; otherwise, false. The default value is false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabStripVisible Property

DockingWindowContainerBaseIsTabStripVisible Property
Gets whether the tabstrip is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTabStripVisible { get; protected set; }
Public Property IsTabStripVisible As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the tabstrip is visible; otherwise, false.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MaxTabExtent Property

DockingWindowContainerBaseMaxTabExtent Property
Gets or sets the maximum extent of a tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MaxTabExtent { get; set; }
Public Property MaxTabExtent As Double
    Get
    Set

Property Value

Type: Double
The maximum extent of a tab. The default value is 260.0.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MinTabExtent Property

DockingWindowContainerBaseMinTabExtent Property
Gets or sets the minimum extent of a tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinTabExtent { get; set; }
Public Property MinTabExtent As Double
    Get
    Set

Property Value

Type: Double
The minimum extent of a tab. The default value is 30.0.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.SelectedWindow Property

DockingWindowContainerBaseSelectedWindow Property
Gets or sets the DockingWindow that is currently selected in the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow SelectedWindow { get; set; }
Public Property SelectedWindow As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is currently selected in the container.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.State Property

DockingWindowContainerBaseState Property
Gets the DockingWindowState that specifies the current state of the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowState State { get; }
Public ReadOnly Property State As DockingWindowState
    Get

Property Value

Type: DockingWindowState
The DockingWindowState that specifies the current state of the container.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabControl Property

DockingWindowContainerBaseTabControl Property
Gets the tab control in the container's user interface.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AdvancedTabControl TabControl { get; }
Protected ReadOnly Property TabControl As AdvancedTabControl
    Get

Property Value

Type: AdvancedTabControl
The tab control in the container's user interface.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabControlStyle Property

DockingWindowContainerBaseTabControlStyle Property
Gets or sets the Style to use for the contained TabControl.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TabControlStyle { get; set; }
Public Property TabControlStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the contained TabControl.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabItemContainerStyle Property

DockingWindowContainerBaseTabItemContainerStyle Property
Gets or sets the Style to use for rendering the tab item containers.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TabItemContainerStyle { get; set; }
Public Property TabItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for rendering the tab item containers.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabOverflowBehavior Property

DockingWindowContainerBaseTabOverflowBehavior Property
Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabOverflowBehavior TabOverflowBehavior { get; set; }
Public Property TabOverflowBehavior As TabOverflowBehavior
    Get
    Set

Property Value

Type: TabOverflowBehavior
The TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. The default value is Shrink.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabStripPlacement Property

DockingWindowContainerBaseTabStripPlacement Property
Gets or sets a Side indicating the side upon which the tabs are located.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
A Side indicating the side upon which the tabs are located. The default value is Bottom.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.WindowsCore Property

DockingWindowContainerBaseWindowsCore Property
Gets the collection of child DockingWindow objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ObservableCollection<DockingWindow> WindowsCore { get; }
Protected ReadOnly Property WindowsCore As ObservableCollection(Of DockingWindow)
    Get

Property Value

Type: ObservableCollection DockingWindow
The collection of child DockingWindow objects.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Methods

DockingWindowContainerBase Methods

The DockingWindowContainerBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockSiteChanged | Occurs when the DockSite property is changed.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTabControlMenuOpening | Occurs when a menu on the tab control is opening.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnWindowsChanged | Occurs when the Windows collection is changed.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateCommands | Updates the enabled states of the commands.
Protected method | UpdateDockingWindowStates | Updates the DockingWindowState associated with all child docking windows.
Protected method | UpdateIsTabStripVisible | Updates the IsTabStripVisible property.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateTitleBarButtonVisibility | Updates the title bar button visibility.
Protected method | UpdateVisualState | Updates the visual state.
Protected method | ValidateChildType | Validates that the specified child DockingWindow type is valid for this container.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnApplyTemplate Method

DockingWindowContainerBaseOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnDockSiteChanged Method

DockingWindowContainerBaseOnDockSiteChanged Method
Occurs when the DockSite property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDockSiteChanged(
    DockSite oldDockSite,
    DockSite newDockSite
)
Protected Overridable Sub OnDockSiteChanged (
    oldDockSite As DockSite,
    newDockSite As DockSite
)

Parameters

oldDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The old value.
newDockSite
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The new value.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnGotFocus Method

DockingWindowContainerBaseOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnLostFocus Method

DockingWindowContainerBaseOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnSelectedWindowChanged Method

DockingWindowContainerBaseOnSelectedWindowChanged Method
Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedWindowChanged(
    DockingWindow oldSelectedWindow,
    DockingWindow newSelectedWindow
)
Protected Overridable Sub OnSelectedWindowChanged (
    oldSelectedWindow As DockingWindow,
    newSelectedWindow As DockingWindow
)

Parameters

oldSelectedWindow
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old selected window.
newSelectedWindow
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new selected window.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnTabControlMenuOpening Method

DockingWindowContainerBaseOnTabControlMenuOpening Method
Occurs when a menu on the tab control is opening.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnTabControlMenuOpening(
    AdvancedTabControlMenuEventArgs e
)
Protected Overridable Sub OnTabControlMenuOpening (
    e As AdvancedTabControlMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControlMenuEventArgs
The AdvancedTabControlMenuEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.OnWindowsChanged Method

DockingWindowContainerBaseOnWindowsChanged Method
Occurs when the Windows collection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnWindowsChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnWindowsChanged (
    e As NotifyCollectionChangedEventArgs
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
A NotifyCollectionChangedEventArgs that contains the event data.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.ToString Method

DockingWindowContainerBaseToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateCommands Method

DockingWindowContainerBaseUpdateCommands Method
Updates the enabled states of the commands.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateCommands()
Protected Overridable Sub UpdateCommands
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateDockingWindowStates Method

DockingWindowContainerBaseUpdateDockingWindowStates Method
Updates the DockingWindowState associated with all child docking windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void UpdateDockingWindowStates()
Protected MustOverride Sub UpdateDockingWindowStates
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateIsTabStripVisible Method

DockingWindowContainerBaseUpdateIsTabStripVisible Method
Updates the IsTabStripVisible property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateIsTabStripVisible()
Protected Overridable Sub UpdateIsTabStripVisible
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateTitleBarButtonVisibility Method

DockingWindowContainerBaseUpdateTitleBarButtonVisibility Method
Updates the title bar button visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateTitleBarButtonVisibility()
Protected Overridable Sub UpdateTitleBarButtonVisibility
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.UpdateVisualState Method

DockingWindowContainerBaseUpdateVisualState Method
Updates the visual state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateVisualState(
    bool useTransitions
)
Protected Overridable Sub UpdateVisualState (
    useTransitions As Boolean
)

Parameters

useTransitions
Type: SystemBoolean
Whether to use transitions.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.ValidateChildType Method

DockingWindowContainerBaseValidateChildType Method
Validates that the specified child DockingWindow type is valid for this container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void ValidateChildType(
    DockingWindow window
)
Protected Overridable Sub ValidateChildType (
    window As DockingWindow
)

Parameters

window
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The DockingWindow to examine.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Events

DockingWindowContainerBase Events

The DockingWindowContainerBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase Fields

DockingWindowContainerBase Fields

The DockingWindowContainerBase type exposes the following members.

Fields
Name | Description
CanTabsCloseOnMiddleClickProperty | Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.
HasTabImagesProperty | Identifies the HasTabImages dependency property. This field is read-only.
IsActiveProperty | Identifies the IsActive dependency property. This field is read-only.
IsTabLayoutAnimationEnabledProperty | Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.
IsTabLayoutAnimationEnabledResolvedProperty | Identifies the IsTabLayoutAnimationEnabledResolved dependency property. This field is read-only.
IsTabStripVisibleProperty | Identifies the IsTabStripVisible dependency property. This field is read-only.
MaxTabExtentProperty | Identifies the MaxTabExtent dependency property. This field is read-only.
MinTabExtentProperty | Identifies the MinTabExtent dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
TabControlStyleProperty | Identifies the TabControlStyle dependency property. This field is read-only.
TabItemContainerStyleProperty | Identifies the TabItemContainerStyle dependency property. This field is read-only.
TabOverflowBehaviorProperty | Identifies the TabOverflowBehavior dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.CanTabsCloseOnMiddleClickProperty Field

DockingWindowContainerBaseCanTabsCloseOnMiddleClickProperty Field
Identifies the CanTabsCloseOnMiddleClick dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanTabsCloseOnMiddleClickProperty
Public Shared ReadOnly CanTabsCloseOnMiddleClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanTabsCloseOnMiddleClick dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.HasTabImagesProperty Field

DockingWindowContainerBaseHasTabImagesProperty Field
Identifies the HasTabImages dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasTabImagesProperty
Public Shared ReadOnly HasTabImagesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasTabImages dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsActiveProperty Field

DockingWindowContainerBaseIsActiveProperty Field
Identifies the IsActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsActiveProperty
Public Shared ReadOnly IsActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsActive dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabledProperty Field

DockingWindowContainerBaseIsTabLayoutAnimationEnabledProperty Field
Identifies the IsTabLayoutAnimationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabLayoutAnimationEnabledProperty
Public Shared ReadOnly IsTabLayoutAnimationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabLayoutAnimationEnabled dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabLayoutAnimationEnabledResolvedProperty Field

DockingWindowContainerBaseIsTabLayoutAnimationEnabledResolvedProperty Field
Identifies the IsTabLayoutAnimationEnabledResolved dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabLayoutAnimationEnabledResolvedProperty
Public Shared ReadOnly IsTabLayoutAnimationEnabledResolvedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabLayoutAnimationEnabledResolved dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.IsTabStripVisibleProperty Field

DockingWindowContainerBaseIsTabStripVisibleProperty Field
Identifies the IsTabStripVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTabStripVisibleProperty
Public Shared ReadOnly IsTabStripVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTabStripVisible dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MaxTabExtentProperty Field

DockingWindowContainerBaseMaxTabExtentProperty Field
Identifies the MaxTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxTabExtentProperty
Public Shared ReadOnly MaxTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxTabExtent dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.MinTabExtentProperty Field

DockingWindowContainerBaseMinTabExtentProperty Field
Identifies the MinTabExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinTabExtentProperty
Public Shared ReadOnly MinTabExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinTabExtent dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.SelectedWindowProperty Field

DockingWindowContainerBaseSelectedWindowProperty Field
Identifies the SelectedWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedWindowProperty
Public Shared ReadOnly SelectedWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedWindow dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.StateProperty Field

DockingWindowContainerBaseStateProperty Field
Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabControlStyleProperty Field

DockingWindowContainerBaseTabControlStyleProperty Field
Identifies the TabControlStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabControlStyleProperty
Public Shared ReadOnly TabControlStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabControlStyle dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabItemContainerStyleProperty Field

DockingWindowContainerBaseTabItemContainerStyleProperty Field
Identifies the TabItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabItemContainerStyleProperty
Public Shared ReadOnly TabItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabItemContainerStyle dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabOverflowBehaviorProperty Field

DockingWindowContainerBaseTabOverflowBehaviorProperty Field
Identifies the TabOverflowBehavior dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabOverflowBehaviorProperty
Public Shared ReadOnly TabOverflowBehaviorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabOverflowBehavior dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockingWindowContainerBase.TabStripPlacementProperty Field

DockingWindowContainerBaseTabStripPlacementProperty Field
Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

DockingWindowContainerBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview Class

DockPreview Class
Represents a dock preview that shows when dragging over a dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesDockPreview

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockPreview : Control
Public Class DockPreview
    Inherits Control

The DockPreview type exposes the following members.

Constructors
 | Name | Description
Public method | DockPreview | Initializes an instance of the DockPreview class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Geometry | Gets or sets the preview geometry.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview Constructor

DockPreview Constructor
Initializes an instance of the DockPreview class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockPreview()
Public Sub New
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview Properties

DockPreview Properties

The DockPreview type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Geometry | Gets or sets the preview geometry.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview.Geometry Property

DockPreviewGeometry Property
Gets or sets the preview geometry.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Geometry Geometry { get; set; }
Public Property Geometry As Geometry
    Get
    Set

Property Value

Type: Geometry
The preview geometry.
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview Methods

DockPreview Methods

The DockPreview type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview Events

DockPreview Events

The DockPreview type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview Fields

DockPreview Fields

The DockPreview type exposes the following members.

Fields
Name | Description
GeometryProperty | Identifies the Geometry dependency property. This field is read-only.
Top
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


DockPreview.GeometryProperty Field

DockPreviewGeometryProperty Field
Identifies the Geometry dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GeometryProperty
Public Shared ReadOnly GeometryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Geometry dependency property.
See Also

Reference

DockPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl Class

FloatingWindowControl Class
Represents a WindowControl that is used as the root control of a hosted floating window.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingWindowControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesFloatingWindowControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FloatingWindowControl : WindowControl
Public Class FloatingWindowControl
    Inherits WindowControl

The FloatingWindowControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite that is managing the window.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Overrides WindowControlActivate.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Inherited from WindowControl.)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Overrides WindowControlOnClosing(CancelableEventArgs).)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Overrides WindowControlOnDeactivated(RoutedEventArgs).)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from WindowControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the window is moved. (Inherited from WindowControl.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from WindowControl.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Inherited from WindowControl.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Inherited from WindowControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl Properties

FloatingWindowControl Properties

The FloatingWindowControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite that is managing the window.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl.DockSite Property

FloatingWindowControlDockSite Property
Gets the DockSite that is managing the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing the window.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl Methods

FloatingWindowControl Methods

The FloatingWindowControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Overrides WindowControlActivate.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Inherited from WindowControl.)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Overrides WindowControlOnClosing(CancelableEventArgs).)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Overrides WindowControlOnDeactivated(RoutedEventArgs).)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from WindowControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the window is moved. (Inherited from WindowControl.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from WindowControl.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Inherited from WindowControl.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Inherited from WindowControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl.Activate Method

FloatingWindowControlActivate Method
Attempts to bring the window to the foreground and activates it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Activate()
Public Overrides Function Activate As Boolean

Return Value

Type: Boolean
true if the window was successfully activated; otherwise, false.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl.GetAdjustedBounds Method

FloatingWindowControlGetAdjustedBounds Method
Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Rect GetAdjustedBounds(
    Rect bounds,
    ResizeOperation resizeOperation
)
Public Overrides Function GetAdjustedBounds (
    bounds As Rect,
    resizeOperation As ResizeOperation
) As Rect

Parameters

bounds
Type: Windows.FoundationRect
The bounds to examine.
resizeOperation
Type: ActiproSoftware.UI.Xaml.ControlsResizeOperation
The active resize operation.

Return Value

Type: Rect
The adjusted bounds.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl.OnActivated Method

FloatingWindowControlOnActivated Method
Called when the window gains focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnActivated(
    RoutedEventArgs e
)
Protected Overrides Sub OnActivated (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl.OnClosing Method

FloatingWindowControlOnClosing Method
Called directly after Close is called, and can be handled to cancel window closure.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosing(
    CancelableEventArgs e
)
Protected Overrides Sub OnClosing (
    e As CancelableEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.XamlCancelableEventArgs
A CancelRoutedEventArgs that contains the event data.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl.OnDeactivated Method

FloatingWindowControlOnDeactivated Method
Called when the window loses focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDeactivated(
    RoutedEventArgs e
)
Protected Overrides Sub OnDeactivated (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatingWindowControl Events

FloatingWindowControl Events

The FloatingWindowControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

FloatingWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatPreview Class

FloatPreview Class
Represents a float preview that can show when not dragging over a dock guide.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesFloatPreview

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FloatPreview : Control
Public Class FloatPreview
    Inherits Control

The FloatPreview type exposes the following members.

Constructors
 | Name | Description
Public method | FloatPreview | Initializes an instance of the FloatPreview class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatPreview Constructor

FloatPreview Constructor
Initializes an instance of the FloatPreview class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FloatPreview()
Public Sub New
See Also

Reference

FloatPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatPreview Properties

FloatPreview Properties

The FloatPreview type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

FloatPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatPreview Methods

FloatPreview Methods

The FloatPreview type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

FloatPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


FloatPreview Events

FloatPreview Events

The FloatPreview type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

FloatPreview Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase Class

MdiHostBase Class
Represents the base class for a container that hosts docking windows in a MDI (multiple-document interface).
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesMdiHostBase
ActiproSoftware.UI.Xaml.Controls.DockingStandardMdiHost
ActiproSoftware.UI.Xaml.Controls.DockingTabbedMdiHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MdiHostBase : Control
Public MustInherit Class MdiHostBase
    Inherits Control

The MdiHostBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MdiHostBase | Initializes a new instance of the MdiHostBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents).
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDocuments | Returns the list of docking windows within the MDI.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsEmptyProperty | Identifies the IsEmpty dependency property. This field is read-only.
PrimaryWindowProperty | Identifies the PrimaryWindow dependency property key. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase Constructor

MdiHostBase Constructor
Initializes a new instance of the MdiHostBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MdiHostBase()
Protected Sub New
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase Properties

MdiHostBase Properties

The MdiHostBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockSite | Gets the DockSite that is managing this control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEmpty | Gets whether the host is currently empty (doesn't contain any visible documents).
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryWindow | Gets the primary DockingWindow within the host.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.DockHost Property

MdiHostBaseDockHost Property
Gets the DockHost that contains this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.DockSite Property

MdiHostBaseDockSite Property
Gets the DockSite that is managing this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this control.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.IsEmpty Property

MdiHostBaseIsEmpty Property
Gets whether the host is currently empty (doesn't contain any visible documents).

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; protected set; }
Public Property IsEmpty As Boolean
    Get
    Protected Set

Property Value

Type: Boolean
true if the host is currently empty (doesn't contain any visible documents); otherwise, false. The default value is true.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindow Property

MdiHostBasePrimaryWindow Property
Gets the primary DockingWindow within the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow PrimaryWindow { get; }
Public ReadOnly Property PrimaryWindow As DockingWindow
    Get

Property Value

Type: DockingWindow
The primary DockingWindow within the host. The default value is .
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase Methods

MdiHostBase Methods

The MdiHostBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDocuments | Returns the list of docking windows within the MDI.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDockHostChanged | Occurs when the value of the DockHost property has changed.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPrimaryWindowChanged | Occurs when the value of the PrimaryWindow property has changed.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.GetDocuments Method

MdiHostBaseGetDocuments Method
Returns the list of docking windows within the MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract IList<DockingWindow> GetDocuments()
Public MustOverride Function GetDocuments As IList(Of DockingWindow)

Return Value

Type: IList DockingWindow
The list of docking windows within the MDI.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.OnApplyTemplate Method

MdiHostBaseOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.OnDockHostChanged Method

MdiHostBaseOnDockHostChanged Method
Occurs when the value of the DockHost property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDockHostChanged(
    DockHost oldValue,
    DockHost newValue
)
Protected Overridable Sub OnDockHostChanged (
    oldValue As DockHost,
    newValue As DockHost
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockHost
The new value.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.OnPrimaryWindowChanged Method

MdiHostBaseOnPrimaryWindowChanged Method
Occurs when the value of the PrimaryWindow property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPrimaryWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overridable Sub OnPrimaryWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new value.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase Events

MdiHostBase Events

The MdiHostBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PrimaryWindowChanged | Occurs when PrimaryWindow is changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindowChanged Event

MdiHostBasePrimaryWindowChanged Event
Occurs when PrimaryWindow is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowEventArgs> PrimaryWindowChanged
Public Event PrimaryWindowChanged As EventHandler(Of DockingWindowEventArgs)

Value

Type: SystemEventHandler DockingWindowEventArgs
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase Fields

MdiHostBase Fields

The MdiHostBase type exposes the following members.

Fields
Name | Description
IsEmptyProperty | Identifies the IsEmpty dependency property. This field is read-only.
PrimaryWindowProperty | Identifies the PrimaryWindow dependency property key. This field is read-only.
Top
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.IsEmptyProperty Field

MdiHostBaseIsEmptyProperty Field
Identifies the IsEmpty dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEmptyProperty
Public Shared ReadOnly IsEmptyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEmpty dependency property.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


MdiHostBase.PrimaryWindowProperty Field

MdiHostBasePrimaryWindowProperty Field
Identifies the PrimaryWindow dependency property key. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryWindowProperty
Public Shared ReadOnly PrimaryWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryWindow dependency property key.
See Also

Reference

MdiHostBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton Class

NewTabButton Class
Represents a new tab button.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
Windows.UI.Xaml.Controls.PrimitivesButtonBase
Windows.UI.Xaml.ControlsButton
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesNewTabButton

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NewTabButton : Button
Public Class NewTabButton
    Inherits Button

The NewTabButton type exposes the following members.

Constructors
 | Name | Description
Public method | NewTabButton | Initializes an instance of the NewTabButton class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClickMode | Gets or sets a value that indicates when the Click event occurs, in terms of device behavior. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the button border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | Flyout | Gets or sets the flyout associated with this button. (Inherited from Button.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPointerOver | Gets a value that indicates whether a device pointer is located over this button control. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently in a pressed state. (Inherited from ButtonBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Click | Occurs when a button control is clicked. (Inherited from ButtonBase.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton Constructor

NewTabButton Constructor
Initializes an instance of the NewTabButton class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NewTabButton()
Public Sub New
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton Properties

NewTabButton Properties

The NewTabButton type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClickMode | Gets or sets a value that indicates when the Click event occurs, in terms of device behavior. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the button border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | Flyout | Gets or sets the flyout associated with this button. (Inherited from Button.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsContentHorizontal | Gets or sets whether the content layout is in a horizontal orientation.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPointerOver | Gets a value that indicates whether a device pointer is located over this button control. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently in a pressed state. (Inherited from ButtonBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton.CornerRadius Property

NewTabButtonCornerRadius Property
Gets or sets the corner radius of the button border, relative to a top-facing tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the button border, relative to a top-facing tab.
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton.IsContentHorizontal Property

NewTabButtonIsContentHorizontal Property
Gets or sets whether the content layout is in a horizontal orientation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsContentHorizontal { get; set; }
Public Property IsContentHorizontal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the content layout is in a horizontal orientation; otherwise, false. The default value is true.
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton.TabStripPlacement Property

NewTabButtonTabStripPlacement Property
Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton Methods

NewTabButton Methods

The NewTabButton type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton Events

NewTabButton Events

The NewTabButton type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Click | Occurs when a button control is clicked. (Inherited from ButtonBase.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton Fields

NewTabButton Fields

The NewTabButton type exposes the following members.

Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
IsContentHorizontalProperty | Identifies the IsContentHorizontal dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
Top
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton.CornerRadiusProperty Field

NewTabButtonCornerRadiusProperty Field
Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton.IsContentHorizontalProperty Field

NewTabButtonIsContentHorizontalProperty Field
Identifies the IsContentHorizontal dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContentHorizontalProperty
Public Shared ReadOnly IsContentHorizontalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContentHorizontal dependency property.
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NewTabButton.TabStripPlacementProperty Field

NewTabButtonTabStripPlacementProperty Field
Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

NewTabButton Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NonUIElementConverter Class

NonUIElementConverter Class
Represents a value converter that only passes through a value if it isn't a UIElement.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesNonUIElementConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class NonUIElementConverter : IValueConverter
Public NotInheritable Class NonUIElementConverter
    Implements IValueConverter

The NonUIElementConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NonUIElementConverter | Initializes a new instance of the NonUIElementConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NonUIElementConverter Constructor

NonUIElementConverter Constructor
Initializes a new instance of the NonUIElementConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NonUIElementConverter()
Public Sub New
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NonUIElementConverter Methods

NonUIElementConverter Methods

The NonUIElementConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NonUIElementConverter.Convert Method

NonUIElementConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


NonUIElementConverter.ConvertBack Method

NonUIElementConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

NonUIElementConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel Class

SplitContainerPanel Class
Represents a Panel that is used by a SplitContainer.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSplitContainerPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SplitContainerPanel : Panel,
    IOrientedElement
Public Class SplitContainerPanel
    Inherits Panel
    Implements IOrientedElement

The SplitContainerPanel type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainerPanel | Initializes an instance of the SplitContainerPanel class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotElements | Gets the collection of slot elements.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
 | GetSlotLength | Gets the value of the SlotLength attached property for the specified object.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
 | SetSlotLength | Sets the value of the SlotLength attached property to the specified object.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SlotLengthProperty | Identifies the SlotLength dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel Constructor

SplitContainerPanel Constructor
Initializes an instance of the SplitContainerPanel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SplitContainerPanel()
Public Sub New
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel Properties

SplitContainerPanel Properties

The SplitContainerPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SlotElements | Gets the collection of slot elements.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.Orientation Property

SplitContainerPanelOrientation Property
Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.SlotElements Property

SplitContainerPanelSlotElements Property
Gets the collection of slot elements.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DeferrableObservableCollection<UIElement> SlotElements { get; }
Public ReadOnly Property SlotElements As DeferrableObservableCollection(Of UIElement)
    Get

Property Value

Type: DeferrableObservableCollection UIElement
The collection of slot elements.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel Methods

SplitContainerPanel Methods

The SplitContainerPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
 | GetSlotLength | Gets the value of the SlotLength attached property for the specified object.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
 | SetSlotLength | Sets the value of the SlotLength attached property to the specified object.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.ArrangeOverride Method

SplitContainerPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.ArrangeOverride Method (Size)

SplitContainerPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

SplitContainerPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.GetSlotLength Method

SplitContainerPanelGetSlotLength Method
Gets the value of the SlotLength attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static double GetSlotLength(
    DependencyObject obj
)
Public Shared Function GetSlotLength (
    obj As DependencyObject
) As Double

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object from which the property value is read.

Return Value

Type: Double
The object's value.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.MeasureOverride Method

SplitContainerPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.MeasureOverride Method (Size)

SplitContainerPanelMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

SplitContainerPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.SetSlotLength Method

SplitContainerPanelSetSlotLength Method
Sets the value of the SlotLength attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetSlotLength(
    DependencyObject obj,
    double value
)
Public Shared Sub SetSlotLength (
    obj As DependencyObject,
    value As Double
)

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object to which the attached property is written.
value
Type: SystemDouble
The value to set.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel Events

SplitContainerPanel Events

The SplitContainerPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel Fields

SplitContainerPanel Fields

The SplitContainerPanel type exposes the following members.

Fields
Name | Description
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SlotLengthProperty | Identifies the SlotLength dependency property. This field is read-only.
Top
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.OrientationProperty Field

SplitContainerPanelOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerPanel.SlotLengthProperty Field

SplitContainerPanelSlotLengthProperty Field
Identifies the SlotLength dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SlotLengthProperty
Public Shared ReadOnly SlotLengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SlotLength dependency property.
See Also

Reference

SplitContainerPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerSplitter Class

SplitContainerSplitter Class
Represents a splitter within a SplitContainer.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSplitterBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSplitContainerSplitter

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SplitContainerSplitter : SplitterBase,
    IOrientedElement
Public Class SplitContainerSplitter
    Inherits SplitterBase
    Implements IOrientedElement

The SplitContainerSplitter type exposes the following members.

Constructors
 | Name | Description
Public method | SplitContainerSplitter | Initializes an instance of the SplitContainerSplitter class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerSplitter Constructor

SplitContainerSplitter Constructor
Initializes an instance of the SplitContainerSplitter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SplitContainerSplitter()
Public Sub New
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerSplitter Properties

SplitContainerSplitter Properties

The SplitContainerSplitter type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted. (Inherited from SplitterBase.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the splitter. (Inherited from SplitterBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerSplitter Methods

SplitContainerSplitter Methods

The SplitContainerSplitter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from SplitterBase.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitContainerSplitter Events

SplitContainerSplitter Events

The SplitContainerSplitter type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SplitContainerSplitter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase Class

SplitterBase Class
Represents an abstract base class for a splitter.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSplitterBase
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesAutoHideContainerSplitter
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSplitContainerSplitter

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class SplitterBase : Control
Public MustInherit Class SplitterBase
    Inherits Control

The SplitterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SplitterBase | Initializes an instance of the SplitterBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the splitter.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase Constructor

SplitterBase Constructor
Initializes an instance of the SplitterBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected SplitterBase()
Protected Sub New
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase Properties

SplitterBase Properties

The SplitterBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets whether the splitter is currently highlighted.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the splitter.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase.IsHighlighted Property

SplitterBaseIsHighlighted Property
Gets or sets whether the splitter is currently highlighted.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHighlighted { get; set; }
Public Property IsHighlighted As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the splitter is currently highlighted; otherwise, false. The default value is false.
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase.Orientation Property

SplitterBaseOrientation Property
Gets or sets the Orientation of the splitter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the splitter. The default value is Horizontal.
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase Methods

SplitterBase Methods

The SplitterBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase.OnApplyTemplate Method

SplitterBaseOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase Events

SplitterBase Events

The SplitterBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase Fields

SplitterBase Fields

The SplitterBase type exposes the following members.

Fields
Name | Description
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase.IsHighlightedProperty Field

SplitterBaseIsHighlightedProperty Field
Identifies the IsHighlighted dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHighlightedProperty
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHighlighted dependency property.
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SplitterBase.OrientationProperty Field

SplitterBaseOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

SplitterBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Class

StandardMdiItemsControl Class
Represents an ItemsControl that displays standard MDI windows.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesStandardMdiItemsControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardMdiItemsControl : ItemsControl
Public Class StandardMdiItemsControl
    Inherits ItemsControl

The StandardMdiItemsControl type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiItemsControl | Initializes an instance of the StandardMdiItemsControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Constructor

StandardMdiItemsControl Constructor
Initializes an instance of the StandardMdiItemsControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardMdiItemsControl()
Public Sub New
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Properties

StandardMdiItemsControl Properties

The StandardMdiItemsControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Methods

StandardMdiItemsControl Methods

The StandardMdiItemsControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.ClearContainerForItemOverride Method

StandardMdiItemsControlClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.GetContainerForItemOverride Method

StandardMdiItemsControlGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.IsItemItsOwnContainerOverride Method

StandardMdiItemsControlIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl.PrepareContainerForItemOverride Method

StandardMdiItemsControlPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiItemsControl Events

StandardMdiItemsControl Events

The StandardMdiItemsControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardMdiItemsControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel Class

StandardMdiPanel Class
Represents a Panel that is used by a StandardMdiItemsControl.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesStandardMdiPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardMdiPanel : Panel
Public Class StandardMdiPanel
    Inherits Panel

The StandardMdiPanel type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiPanel | Initializes a new instance of the StandardMdiPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel Constructor

StandardMdiPanel Constructor
Initializes a new instance of the StandardMdiPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardMdiPanel()
Public Sub New
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel Properties

StandardMdiPanel Properties

The StandardMdiPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel Methods

StandardMdiPanel Methods

The StandardMdiPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel.ArrangeOverride Method

StandardMdiPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel.ArrangeOverride Method (Size)

StandardMdiPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

StandardMdiPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel.MeasureOverride Method

StandardMdiPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel.MeasureOverride Method (Size)

StandardMdiPanelMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

StandardMdiPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiPanel Events

StandardMdiPanel Events

The StandardMdiPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardMdiPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Class

StandardMdiWindowControl Class
Represents a WindowControl that is used as the root control of a hosted floating window.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.DockingWindowControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesStandardMdiWindowControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardMdiWindowControl : WindowControl
Public Class StandardMdiWindowControl
    Inherits WindowControl

The StandardMdiWindowControl type exposes the following members.

Constructors
 | Name | Description
Public method | StandardMdiWindowControl | Initializes an instance of the StandardMdiWindowControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockingWindow | Gets the DockingWindow that is wrapped by this control.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from WindowControl.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Overrides WindowControlOnClosed(RoutedEventArgs).)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Inherited from WindowControl.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides WindowControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the window is moved. (Overrides WindowControlOnLocationChanged(RoutedEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides WindowControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Overrides WindowControlOnStateChanged(RoutedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Overrides WindowControlOnTitleBarMenuOpening(DockingMenuEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Constructor

StandardMdiWindowControl Constructor
Initializes an instance of the StandardMdiWindowControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardMdiWindowControl()
Public Sub New
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Properties

StandardMdiWindowControl Properties

The StandardMdiWindowControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanClose | Gets or sets whether the window can close. (Inherited from WindowControl.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseCommand | Gets the ICommand that can close the window. (Inherited from WindowControl.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextContent | Gets or sets the context content that is displayed on the title bar next to the title. (Inherited from WindowControl.)
Public property | ContextContentTemplate | Gets or sets the DataTemplate to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextContentTemplateSelector | Gets or sets the DataTemplateSelector to use for the ContextContent. (Inherited from WindowControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the CornerRadius of the window. (Inherited from WindowControl.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockHost | Gets the DockHost that contains this control.
Public property | DockingWindow | Gets the DockingWindow that is wrapped by this control.
Public property | DockSite | Gets the DockSite that is managing this docking window.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasCloseButton | Gets or sets whether the window is capable of displaying a close button. (Inherited from WindowControl.)
Public property | HasIcon | Gets or sets whether the window is capable of displaying an icon. (Inherited from WindowControl.)
Public property | HasMaximizeButton | Gets or sets whether the window is capable of displaying a maximize button. (Inherited from WindowControl.)
Public property | HasMinimizeButton | Gets or sets whether the window is capable of displaying a minimize button. (Inherited from WindowControl.)
Public property | HasRestoreButton | Gets or sets whether the window is capable of displaying a restore button. (Inherited from WindowControl.)
Public property | HasTitleBar | Gets or sets whether the window is capable of displaying a title bar. (Inherited from WindowControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets the ImageSource displayed as the window icon. (Inherited from WindowControl.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets whether the window is currently active. (Inherited from WindowControl.)
Public property | IsCloseButtonVisible | Gets whether the window's close button is visible. (Inherited from WindowControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMaximizeButtonVisible | Gets whether the window's maximize button is visible. (Inherited from WindowControl.)
Public property | IsMaximizedFrameVisible | Gets or sets whether the frame should be displayed when the window is maximized. (Inherited from WindowControl.)
Public property | IsMinimizeButtonVisible | Gets whether the window's minimize button is visible. (Inherited from WindowControl.)
Public property | IsMoving | Gets whether the window is currently being dragged to move its location. (Inherited from WindowControl.)
Public property | IsReadOnly | Gets or sets whether the windows's contents are read-only. (Inherited from WindowControl.)
Public property | IsResizing | Gets whether the window is currently being dragged to alter its size. (Inherited from WindowControl.)
Public property | IsRestoreButtonVisible | Gets whether the window's restore button is visible. (Inherited from WindowControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to its container. (Inherited from WindowControl.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaximizeCommand | Gets the ICommand that can maximize the window. (Inherited from WindowControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinimizeCommand | Gets the ICommand that can minimize the window. (Inherited from WindowControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | ReadOnlyContextContentTemplate | Gets or sets the DataTemplate to assign to ContextContentTemplate when the IsReadOnly property is true. (Inherited from WindowControl.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResizeMode | Gets or sets a ResizeMode indicating how the window is able to resize. (Inherited from WindowControl.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RestoreCommand | Gets the ICommand that can restore the window. (Inherited from WindowControl.)
Public property | RestoredBounds | Gets or sets the bounds of this window when in a 'restored' state. (Inherited from WindowControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets or sets the title of the window. (Inherited from WindowControl.)
Public property | TitleBarFontWeight | Gets or sets the FontWeight of the title. (Inherited from WindowControl.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to its container. (Inherited from WindowControl.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WindowState | Gets or sets a WindowState indicating the current state of the window. (Inherited from WindowControl.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.DockHost Property

StandardMdiWindowControlDockHost Property
Gets the DockHost that contains this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockHost DockHost { get; }
Public ReadOnly Property DockHost As DockHost
    Get

Property Value

Type: DockHost
The DockHost that contains this control.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.DockingWindow Property

StandardMdiWindowControlDockingWindow Property
Gets the DockingWindow that is wrapped by this control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow DockingWindow { get; }
Public ReadOnly Property DockingWindow As DockingWindow
    Get

Property Value

Type: DockingWindow
The DockingWindow that is wrapped by this control.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.DockSite Property

StandardMdiWindowControlDockSite Property
Gets the DockSite that is managing this docking window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite that is managing this docking window.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Methods

StandardMdiWindowControl Methods

The StandardMdiWindowControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from WindowControl.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the window. (Inherited from WindowControl.)
Public method | DragMove | Allows a window to be dragged by a pointer with its primary button down over an exposed area of the window's client rectangle. (Inherited from WindowControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAdjustedBounds | Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism. (Overrides WindowControlGetAdjustedBounds(Rect, ResizeOperation).)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTestResizeOperation | Hit tests the specified Point to see if it might cause a resize operation. (Inherited from WindowControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnActivated | Called when the window gains focus within. (Overrides WindowControlOnActivated(RoutedEventArgs).)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from WindowControl.)
Protected method | OnClosed | Called when the window is about to close. (Overrides WindowControlOnClosed(RoutedEventArgs).)
Protected method | OnClosing | Called directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Protected method | OnContentChanged | Occurs when the content changes. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from WindowControl.)
Protected method | OnDeactivated | Called when the window loses focus within. (Inherited from WindowControl.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragMoved | Called after the window has been moved from a drag. (Inherited from WindowControl.)
Protected method | OnDragMoving | Called before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDragResized | Called after the window has been resized from a drag. (Inherited from WindowControl.)
Protected method | OnDragResizing | Called before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides WindowControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLocationChanged | Called when the window is moved. (Overrides WindowControlOnLocationChanged(RoutedEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides WindowControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Called when the window is opened. (Inherited from WindowControl.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnStateChanged | Called after the window's WindowState property has changed. (Overrides WindowControlOnStateChanged(RoutedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnTitleBarDoubleTapped | Called when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Protected method | OnTitleBarMenuOpening | Called when the title-bar should display a context menu. (Overrides WindowControlOnTitleBarMenuOpening(DockingMenuEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | Show | Shows the window. (Inherited from WindowControl.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToggleWindowState | Toggles the window's state based on its current state. (Inherited from WindowControl.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.GetAdjustedBounds Method

StandardMdiWindowControlGetAdjustedBounds Method
Returns an adjusted version of the specified bounds, which can provide support for features such as magnetism.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Rect GetAdjustedBounds(
    Rect bounds,
    ResizeOperation resizeOperation
)
Public Overrides Function GetAdjustedBounds (
    bounds As Rect,
    resizeOperation As ResizeOperation
) As Rect

Parameters

bounds
Type: Windows.FoundationRect
The bounds to examine.
resizeOperation
Type: ActiproSoftware.UI.Xaml.ControlsResizeOperation
The active resize operation.

Return Value

Type: Rect
The adjusted bounds.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnActivated Method

StandardMdiWindowControlOnActivated Method
Called when the window gains focus within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnActivated(
    RoutedEventArgs e
)
Protected Overrides Sub OnActivated (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnClosed Method

StandardMdiWindowControlOnClosed Method
Called when the window is about to close.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed(
    RoutedEventArgs e
)
Protected Overrides Sub OnClosed (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnContentChanged Method

StandardMdiWindowControlOnContentChanged Method
Occurs when the content changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Protected Overrides Sub OnContentChanged (
    oldContent As Object,
    newContent As Object
)

Parameters

oldContent
Type: SystemObject
The old content.
newContent
Type: SystemObject
The new content.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnGotFocus Method

StandardMdiWindowControlOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnLocationChanged Method

StandardMdiWindowControlOnLocationChanged Method
Called when the window is moved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLocationChanged(
    RoutedEventArgs e
)
Protected Overrides Sub OnLocationChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnLostFocus Method

StandardMdiWindowControlOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnStateChanged Method

StandardMdiWindowControlOnStateChanged Method
Called after the window's WindowState property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnStateChanged(
    RoutedEventArgs e
)
Protected Overrides Sub OnStateChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl.OnTitleBarMenuOpening Method

StandardMdiWindowControlOnTitleBarMenuOpening Method
Called when the title-bar should display a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnTitleBarMenuOpening(
    DockingMenuEventArgs e
)
Protected Overrides Sub OnTitleBarMenuOpening (
    e As DockingMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingMenuEventArgs
A DockingMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardMdiWindowControl Events

StandardMdiWindowControl Events

The StandardMdiWindowControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Activated | Occurs when the window gains focus within. (Inherited from WindowControl.)
Public event | Closed | Occurs when the window is about to close. (Inherited from WindowControl.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from WindowControl.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when the window loses focus within. (Inherited from WindowControl.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragMoved | Occurs after the window has been moved from a drag. (Inherited from WindowControl.)
Public event | DragMoving | Occurs before the window is moved from a drag, and can be handled to cancel the drag. (Inherited from WindowControl.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragResized | Occurs after the window has been resized from a drag. (Inherited from WindowControl.)
Public event | DragResizing | Occurs before the window is resized from a drag, and can be handled to cancel the resize. (Inherited from WindowControl.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window is moved. (Inherited from WindowControl.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Opened | Occurs when the window is opened. (Inherited from WindowControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs after the window's WindowState property has changed. (Inherited from WindowControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TitleBarDoubleTapped | Occurs when the title-bar is double-tapped, and can be handled to cancel the default action. (Inherited from WindowControl.)
Public event | TitleBarMenuOpening | Occurs when the title-bar should display a context menu. (Inherited from WindowControl.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardMdiWindowControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem Class

StandardSwitcherItem Class
Represents an item in a StandardSwitcher.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesStandardSwitcherItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StandardSwitcherItem : ContentControl
Public Class StandardSwitcherItem
    Inherits ContentControl

The StandardSwitcherItem type exposes the following members.

Constructors
 | Name | Description
Public method | StandardSwitcherItem | Initializes a new instance of the StandardSwitcherItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Occurs when the content is changed. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem Constructor

StandardSwitcherItem Constructor
Initializes a new instance of the StandardSwitcherItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StandardSwitcherItem()
Public Sub New
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem Properties

StandardSwitcherItem Properties

The StandardSwitcherItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem.IsSelected Property

StandardSwitcherItemIsSelected Property
Gets or sets whether the item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is selected; otherwise, false.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem Methods

StandardSwitcherItem Methods

The StandardSwitcherItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Occurs when the content is changed. (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem.OnApplyTemplate Method

StandardSwitcherItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem.OnContentChanged Method

StandardSwitcherItemOnContentChanged Method
Occurs when the content is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Protected Overrides Sub OnContentChanged (
    oldContent As Object,
    newContent As Object
)

Parameters

oldContent
Type: SystemObject
The old content.
newContent
Type: SystemObject
The new content.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem Events

StandardSwitcherItem Events

The StandardSwitcherItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem Fields

StandardSwitcherItem Fields

The StandardSwitcherItem type exposes the following members.

Fields
Name | Description
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


StandardSwitcherItem.IsSelectedProperty Field

StandardSwitcherItemIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

StandardSwitcherItem Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase Class

SwitcherBase Class
Provides the base class for a component that provides Ctrl+Tab-like switching of docking windows.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesSwitcherBase
ActiproSoftware.UI.Xaml.Controls.DockingSimpleSwitcher
ActiproSoftware.UI.Xaml.Controls.DockingStandardSwitcher

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class SwitcherBase : Control
Public MustInherit Class SwitcherBase
    Inherits Control

The SwitcherBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SwitcherBase | Initializes a new instance of the SwitcherBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active.
Public property | Documents | Gets the collection of open documents in the MDI area.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets whether the switcher is currently open and active.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the switcher.
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnClosed | Invoked when the switcher is closed.
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Overrides ControlOnKeyUp(KeyRoutedEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | SelectNextDocument | Selects the next document in the switcher.
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher.
Protected method | SelectPreviousDocument | Selects the previous document in the switcher.
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DockSiteProperty | Identifies the DockSite dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase Constructor

SwitcherBase Constructor
Initializes a new instance of the SwitcherBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected SwitcherBase(
    bool canSortByLastFocusedDateTime
)
Protected Sub New (
    canSortByLastFocusedDateTime As Boolean
)

Parameters

canSortByLastFocusedDateTime
Type: SystemBoolean
Whether to sort docking windows by last focused date/time.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase Properties

SwitcherBase Properties

The SwitcherBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DockSite | Gets the DockSite for which the switcher is currently active.
Public property | Documents | Gets the collection of open documents in the MDI area.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOpen | Gets whether the switcher is currently open and active.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedWindow | Gets or sets the DockingWindow that is currently selected.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToolWindows | Gets the collection of open tool windows that are not in the MDI area.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.DockSite Property

SwitcherBaseDockSite Property
Gets the DockSite for which the switcher is currently active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSite DockSite { get; }
Public ReadOnly Property DockSite As DockSite
    Get

Property Value

Type: DockSite
The DockSite for which the switcher is currently active.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.Documents Property

SwitcherBaseDocuments Property
Gets the collection of open documents in the MDI area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyDockingWindowCollection Documents { get; }
Public ReadOnly Property Documents As ReadOnlyDockingWindowCollection
    Get

Property Value

Type: ReadOnlyDockingWindowCollection
The collection of open documents in the MDI area.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.IsOpen Property

SwitcherBaseIsOpen Property
Gets whether the switcher is currently open and active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get

Property Value

Type: Boolean
true if the switcher is currently open and active; otherwise, false.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.SelectedWindow Property

SwitcherBaseSelectedWindow Property
Gets or sets the DockingWindow that is currently selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow SelectedWindow { get; set; }
Public Property SelectedWindow As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is currently selected.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.ToolWindows Property

SwitcherBaseToolWindows Property
Gets the collection of open tool windows that are not in the MDI area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyToolWindowCollection ToolWindows { get; }
Public ReadOnly Property ToolWindows As ReadOnlyToolWindowCollection
    Get

Property Value

Type: ReadOnlyToolWindowCollection
The collection of open tool windows that are not in the MDI area.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase Methods

SwitcherBase Methods

The SwitcherBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Close | Closes the switcher.
Protected method | CreatePopup | Creates a Popup that can be used to host this switcher.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsActivationKey | Returns whether the specified key is a key combination that can activate the switcher.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnClosed | Invoked when the switcher is closed.
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Occurs when a key is released. (Overrides ControlOnKeyUp(KeyRoutedEventArgs).)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnOpened | Invoked when the switcher is opened.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectedWindowChanged | Occurs when the SelectedWindow property is changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | SelectNextDocument | Selects the next document in the switcher.
Protected method | SelectNextToolWindow | Selects the next tool window in the switcher.
Protected method | SelectPreviousDocument | Selects the previous document in the switcher.
Protected method | SelectPreviousToolWindow | Selects the previous tool window in the switcher.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.Close Method

SwitcherBaseClose Method
Closes the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.CreatePopup Method

SwitcherBaseCreatePopup Method
Creates a Popup that can be used to host this switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Popup CreatePopup()
Protected Overridable Function CreatePopup As Popup

Return Value

Type: Popup
The Popup that was created.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.IsActivationKey Method

SwitcherBaseIsActivationKey Method
Returns whether the specified key is a key combination that can activate the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsActivationKey(
    KeyRoutedEventArgs e
)
Protected Overridable Function IsActivationKey (
    e As KeyRoutedEventArgs
) As Boolean

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
A KeyRoutedEventArgs that contains the event data.

Return Value

Type: Boolean
true if the key combination can activate the switcher; otherwise, false.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.OnClosed Method

SwitcherBaseOnClosed Method
Invoked when the switcher is closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnClosed()
Protected Overridable Sub OnClosed
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.OnKeyDown Method

SwitcherBaseOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.OnKeyUp Method

SwitcherBaseOnKeyUp Method
Occurs when a key is released.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyUp(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyUp (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
A KeyRoutedEventArgs that contains the event data.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.OnLostFocus Method

SwitcherBaseOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.OnOpened Method

SwitcherBaseOnOpened Method
Invoked when the switcher is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnOpened()
Protected Overridable Sub OnOpened
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.OnSelectedWindowChanged Method

SwitcherBaseOnSelectedWindowChanged Method
Occurs when the SelectedWindow property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSelectedWindowChanged(
    DockingWindow oldValue,
    DockingWindow newValue
)
Protected Overridable Sub OnSelectedWindowChanged (
    oldValue As DockingWindow,
    newValue As DockingWindow
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The old value.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The new value.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextDocument Method

SwitcherBaseSelectNextDocument Method
Selects the next document in the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void SelectNextDocument()
Protected Overridable Sub SelectNextDocument
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.SelectNextToolWindow Method

SwitcherBaseSelectNextToolWindow Method
Selects the next tool window in the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void SelectNextToolWindow()
Protected Overridable Sub SelectNextToolWindow
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousDocument Method

SwitcherBaseSelectPreviousDocument Method
Selects the previous document in the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void SelectPreviousDocument()
Protected Overridable Sub SelectPreviousDocument
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.SelectPreviousToolWindow Method

SwitcherBaseSelectPreviousToolWindow Method
Selects the previous tool window in the switcher.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void SelectPreviousToolWindow()
Protected Overridable Sub SelectPreviousToolWindow
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase Events

SwitcherBase Events

The SwitcherBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase Fields

SwitcherBase Fields

The SwitcherBase type exposes the following members.

Fields
Name | Description
DockSiteProperty | Identifies the DockSite dependency property. This field is read-only.
IsOpenProperty | Identifies the IsOpen dependency property. This field is read-only.
SelectedWindowProperty | Identifies the SelectedWindow dependency property. This field is read-only.
Top
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.DockSiteProperty Field

SwitcherBaseDockSiteProperty Field
Identifies the DockSite dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DockSiteProperty
Public Shared ReadOnly DockSiteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DockSite dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.IsOpenProperty Field

SwitcherBaseIsOpenProperty Field
Identifies the IsOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOpenProperty
Public Shared ReadOnly IsOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOpen dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


SwitcherBase.SelectedWindowProperty Field

SwitcherBaseSelectedWindowProperty Field
Identifies the SelectedWindow dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedWindowProperty
Public Shared ReadOnly SelectedWindowProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedWindow dependency property.
See Also

Reference

SwitcherBase Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Class

TabbedMdiContainerTabControl Class
Represents an AdvancedTabControl for use within a TabbedMdiContainer.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesTabbedMdiContainerTabControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TabbedMdiContainerTabControl : AdvancedTabControl
Public Class TabbedMdiContainerTabControl
    Inherits AdvancedTabControl

The TabbedMdiContainerTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | TabbedMdiContainerTabControl | Initializes an instance of the TabbedMdiContainerTabControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from AdvancedTabControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the selected content. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplate | Gets the selected content template. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplateSelector | Gets the selected content template selector. (Inherited from AdvancedTabControl.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from AdvancedTabControl.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed. (Inherited from AdvancedTabControl.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from AdvancedTabControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from AdvancedTabControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection changes. (Inherited from AdvancedTabControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from AdvancedTabControl.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Overrides AdvancedTabControlOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Overrides AdvancedTabControlUpdateHighlightBrushes.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Constructor

TabbedMdiContainerTabControl Constructor
Initializes an instance of the TabbedMdiContainerTabControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabbedMdiContainerTabControl()
Public Sub New
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Properties

TabbedMdiContainerTabControl Properties

The TabbedMdiContainerTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from AdvancedTabControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the selected content. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplate | Gets the selected content template. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplateSelector | Gets the selected content template selector. (Inherited from AdvancedTabControl.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from AdvancedTabControl.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed. (Inherited from AdvancedTabControl.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Methods

TabbedMdiContainerTabControl Methods

The TabbedMdiContainerTabControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from AdvancedTabControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from AdvancedTabControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection changes. (Inherited from AdvancedTabControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from AdvancedTabControl.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectionChanged | Occurs when the selection has changed. (Overrides AdvancedTabControlOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Overrides AdvancedTabControlUpdateHighlightBrushes.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.ClearContainerForItemOverride Method

TabbedMdiContainerTabControlClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.OnSelectionChanged Method

TabbedMdiContainerTabControlOnSelectionChanged Method
Occurs when the selection has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overrides Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.ControlsSelectionChangedEventArgs
The SelectionChangedEventArgs containing arguments related to this event.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.PrepareContainerForItemOverride Method

TabbedMdiContainerTabControlPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl.UpdateHighlightBrushes Method

TabbedMdiContainerTabControlUpdateHighlightBrushes Method
Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateHighlightBrushes()
Protected Overrides Sub UpdateHighlightBrushes
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabbedMdiContainerTabControl Events

TabbedMdiContainerTabControl Events

The TabbedMdiContainerTabControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TabbedMdiContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder Class

TabItemBorder Class
Renders a border for a tab item.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesTabItemBorder

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TabItemBorder : ContentControl
Public Class TabItemBorder
    Inherits ContentControl

The TabItemBorder type exposes the following members.

Constructors
 | Name | Description
Public method | TabItemBorder | Initializes an instance of the TabItemBorder class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UnrotatedBorderThickness | Gets or sets the unrotated thickness of the tab border, based on a top-facing tab placement.
Public property | UnrotatedCornerRadius | Gets or sets the unrotated corner radius of the tab border, based on a top-facing tab placement.
Public property | UntintedBackground | Gets or sets the untinted Brush that specifies how the tab's interior is painted.
Public property | UntintedBorderBrush | Gets or sets the untinted Brush that specifies how the tab's outline is painted.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UnrotatedBorderThicknessProperty | Identifies the UnrotatedBorderThickness dependency property. This field is read-only.
UnrotatedCornerRadiusProperty | Identifies the UnrotatedCornerRadius dependency property. This field is read-only.
UntintedBackgroundProperty | Identifies the UntintedBackground dependency property. This field is read-only.
UntintedBorderBrushProperty | Identifies the UntintedBorderBrush dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder Constructor

TabItemBorder Constructor
Initializes an instance of the TabItemBorder class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabItemBorder()
Public Sub New
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder Properties

TabItemBorder Properties

The TabItemBorder type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | Gets or sets the corner radius of the tab border, relative to a top-facing tab.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlashColor | Gets or sets the flash color to use if flashing is enabled.
Public property | FlashMode | Gets or sets the flash mode for the tab.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TintColor | Gets or sets the tint color applied to the Background and BorderBrush brushes.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UnrotatedBorderThickness | Gets or sets the unrotated thickness of the tab border, based on a top-facing tab placement.
Public property | UnrotatedCornerRadius | Gets or sets the unrotated corner radius of the tab border, based on a top-facing tab placement.
Public property | UntintedBackground | Gets or sets the untinted Brush that specifies how the tab's interior is painted.
Public property | UntintedBorderBrush | Gets or sets the untinted Brush that specifies how the tab's outline is painted.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.CornerRadius Property

TabItemBorderCornerRadius Property
Gets or sets the corner radius of the tab border, relative to a top-facing tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius CornerRadius { get; set; }
Public Property CornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The corner radius of the tab border, relative to a top-facing tab.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.FlashColor Property

TabItemBorderFlashColor Property
Gets or sets the flash color to use if flashing is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color FlashColor { get; set; }
Public Property FlashColor As Color
    Get
    Set

Property Value

Type: Color
The flash color to use if flashing is enabled. The default value is #80FFA000.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.FlashMode Property

TabItemBorderFlashMode Property
Gets or sets the flash mode for the tab.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabFlashMode FlashMode { get; set; }
Public Property FlashMode As TabFlashMode
    Get
    Set

Property Value

Type: TabFlashMode
The flash mode for the tab.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.TabStripPlacement Property

TabItemBorderTabStripPlacement Property
Gets or sets the side upon which the tabstrip is placed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side TabStripPlacement { get; set; }
Public Property TabStripPlacement As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip is placed.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.TintColor Property

TabItemBorderTintColor Property
Gets or sets the tint color applied to the Background and BorderBrush brushes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color TintColor { get; set; }
Public Property TintColor As Color
    Get
    Set

Property Value

Type: Color
The tint color applied to the Background and BorderBrush brushes. The default value is Transparent, which indicates no tinting should be applied.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UnrotatedBorderThickness Property

TabItemBorderUnrotatedBorderThickness Property
Gets or sets the unrotated thickness of the tab border, based on a top-facing tab placement.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness UnrotatedBorderThickness { get; set; }
Public Property UnrotatedBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The unrotated thickness of the tab border, based on a top-facing tab placement.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UnrotatedCornerRadius Property

TabItemBorderUnrotatedCornerRadius Property
Gets or sets the unrotated corner radius of the tab border, based on a top-facing tab placement.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius UnrotatedCornerRadius { get; set; }
Public Property UnrotatedCornerRadius As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The unrotated corner radius of the tab border, based on a top-facing tab placement.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBackground Property

TabItemBorderUntintedBackground Property
Gets or sets the untinted Brush that specifies how the tab's interior is painted.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush UntintedBackground { get; set; }
Public Property UntintedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The untinted Brush that specifies how the tab's interior is painted.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBorderBrush Property

TabItemBorderUntintedBorderBrush Property
Gets or sets the untinted Brush that specifies how the tab's outline is painted.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush UntintedBorderBrush { get; set; }
Public Property UntintedBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The untinted Brush that specifies how the tab's outline is painted.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder Methods

TabItemBorder Methods

The TabItemBorder type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder Events

TabItemBorder Events

The TabItemBorder type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder Fields

TabItemBorder Fields

The TabItemBorder type exposes the following members.

Fields
Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. This field is read-only.
FlashColorProperty | Identifies the FlashColor dependency property. This field is read-only.
FlashModeProperty | Identifies the FlashMode dependency property. This field is read-only.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property. This field is read-only.
TintColorProperty | Identifies the TintColor dependency property. This field is read-only.
UnrotatedBorderThicknessProperty | Identifies the UnrotatedBorderThickness dependency property. This field is read-only.
UnrotatedCornerRadiusProperty | Identifies the UnrotatedCornerRadius dependency property. This field is read-only.
UntintedBackgroundProperty | Identifies the UntintedBackground dependency property. This field is read-only.
UntintedBorderBrushProperty | Identifies the UntintedBorderBrush dependency property. This field is read-only.
Top
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.CornerRadiusProperty Field

TabItemBorderCornerRadiusProperty Field
Identifies the CornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CornerRadiusProperty
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CornerRadius dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.FlashColorProperty Field

TabItemBorderFlashColorProperty Field
Identifies the FlashColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashColorProperty
Public Shared ReadOnly FlashColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashColor dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.FlashModeProperty Field

TabItemBorderFlashModeProperty Field
Identifies the FlashMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FlashModeProperty
Public Shared ReadOnly FlashModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FlashMode dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.TabStripPlacementProperty Field

TabItemBorderTabStripPlacementProperty Field
Identifies the TabStripPlacement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TabStripPlacementProperty
Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TabStripPlacement dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.TintColorProperty Field

TabItemBorderTintColorProperty Field
Identifies the TintColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TintColorProperty
Public Shared ReadOnly TintColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TintColor dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UnrotatedBorderThicknessProperty Field

TabItemBorderUnrotatedBorderThicknessProperty Field
Identifies the UnrotatedBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnrotatedBorderThicknessProperty
Public Shared ReadOnly UnrotatedBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnrotatedBorderThickness dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UnrotatedCornerRadiusProperty Field

TabItemBorderUnrotatedCornerRadiusProperty Field
Identifies the UnrotatedCornerRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UnrotatedCornerRadiusProperty
Public Shared ReadOnly UnrotatedCornerRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UnrotatedCornerRadius dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBackgroundProperty Field

TabItemBorderUntintedBackgroundProperty Field
Identifies the UntintedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UntintedBackgroundProperty
Public Shared ReadOnly UntintedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UntintedBackground dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TabItemBorder.UntintedBorderBrushProperty Field

TabItemBorderUntintedBorderBrushProperty Field
Identifies the UntintedBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UntintedBorderBrushProperty
Public Shared ReadOnly UntintedBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UntintedBorderBrush dependency property.
See Also

Reference

TabItemBorder Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel Class

TitleBarPanel Class
Represents a Panel within a title bar.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesTitleBarPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TitleBarPanel : Panel
Public Class TitleBarPanel
    Inherits Panel

The TitleBarPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TitleBarPanel | Initializes a new instance of the TitleBarPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextContentAlignment | Gets or sets the alignment of context content.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
 | GetIsContextContent | Gets the value of the IsContextContent attached property for the specified object.
 | GetIsFiller | Gets the value of the IsFiller attached property for the specified object.
 | GetIsHeader | Gets the value of the IsHeader attached property for the specified object.
 | GetIsIcon | Gets the value of the IsIcon attached property for the specified object.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
 | SetIsContextContent | Sets the value of the IsContextContent attached property to the specified object.
 | SetIsFiller | Sets the value of the IsFiller attached property to the specified object.
 | SetIsHeader | Sets the value of the IsHeader attached property to the specified object.
 | SetIsIcon | Sets the value of the IsIcon attached property to the specified object.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ContextContentAlignmentProperty | Identifies the ContextContentAlignment dependency property. This field is read-only.
IsContextContentProperty | Identifies the IsContextContent dependency property. This field is read-only.
IsFillerProperty | Identifies the IsFiller dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsIconProperty | Identifies the IsIcon dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel Constructor

TitleBarPanel Constructor
Initializes a new instance of the TitleBarPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TitleBarPanel()
Public Sub New
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel Properties

TitleBarPanel Properties

The TitleBarPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextContentAlignment | Gets or sets the alignment of context content.
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.ContextContentAlignment Property

TitleBarPanelContextContentAlignment Property
Gets or sets the alignment of context content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ContextContentAlignment ContextContentAlignment { get; set; }
Public Property ContextContentAlignment As ContextContentAlignment
    Get
    Set

Property Value

Type: ContextContentAlignment
The alignment of context content. The default value is Far.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel Methods

TitleBarPanel Methods

The TitleBarPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
 | GetIsContextContent | Gets the value of the IsContextContent attached property for the specified object.
 | GetIsFiller | Gets the value of the IsFiller attached property for the specified object.
 | GetIsHeader | Gets the value of the IsHeader attached property for the specified object.
 | GetIsIcon | Gets the value of the IsIcon attached property for the specified object.
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
 | SetIsContextContent | Sets the value of the IsContextContent attached property to the specified object.
 | SetIsFiller | Sets the value of the IsFiller attached property to the specified object.
 | SetIsHeader | Sets the value of the IsHeader attached property to the specified object.
 | SetIsIcon | Sets the value of the IsIcon attached property to the specified object.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.ArrangeOverride Method

TitleBarPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.ArrangeOverride Method (Size)

TitleBarPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TitleBarPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsContextContent Method

TitleBarPanelGetIsContextContent Method
Gets the value of the IsContextContent attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool GetIsContextContent(
    DependencyObject obj
)
Public Shared Function GetIsContextContent (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsFiller Method

TitleBarPanelGetIsFiller Method
Gets the value of the IsFiller attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool GetIsFiller(
    DependencyObject obj
)
Public Shared Function GetIsFiller (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsHeader Method

TitleBarPanelGetIsHeader Method
Gets the value of the IsHeader attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool GetIsHeader(
    DependencyObject obj
)
Public Shared Function GetIsHeader (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.GetIsIcon Method

TitleBarPanelGetIsIcon Method
Gets the value of the IsIcon attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool GetIsIcon(
    DependencyObject obj
)
Public Shared Function GetIsIcon (
    obj As DependencyObject
) As Boolean

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object from which the property value is read.

Return Value

Type: Boolean
The object's value.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.MeasureOverride Method

TitleBarPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns the element's desired size based on the size of its children.
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.MeasureOverride Method (Size)

TitleBarPanelMeasureOverride Method (Size)
Measures all children given an available size and returns the element's desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the element is suggested to fit inside.

Return Value

Type: Size
The desired size of the element.
See Also

Reference

TitleBarPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsContextContent Method

TitleBarPanelSetIsContextContent Method
Sets the value of the IsContextContent attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetIsContextContent(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsContextContent (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsFiller Method

TitleBarPanelSetIsFiller Method
Sets the value of the IsFiller attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetIsFiller(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsFiller (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsHeader Method

TitleBarPanelSetIsHeader Method
Sets the value of the IsHeader attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetIsHeader(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsHeader (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.SetIsIcon Method

TitleBarPanelSetIsIcon Method
Sets the value of the IsIcon attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetIsIcon(
    DependencyObject obj,
    bool value
)
Public Shared Sub SetIsIcon (
    obj As DependencyObject,
    value As Boolean
)

Parameters

obj
Type: Windows.UI.XamlDependencyObject
The object to which the attached property is written.
value
Type: SystemBoolean
The value to set.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel Events

TitleBarPanel Events

The TitleBarPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel Fields

TitleBarPanel Fields

The TitleBarPanel type exposes the following members.

Fields
Name | Description
ContextContentAlignmentProperty | Identifies the ContextContentAlignment dependency property. This field is read-only.
IsContextContentProperty | Identifies the IsContextContent dependency property. This field is read-only.
IsFillerProperty | Identifies the IsFiller dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsIconProperty | Identifies the IsIcon dependency property. This field is read-only.
Top
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.ContextContentAlignmentProperty Field

TitleBarPanelContextContentAlignmentProperty Field
Identifies the ContextContentAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContextContentAlignmentProperty
Public Shared ReadOnly ContextContentAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContextContentAlignment dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.IsContextContentProperty Field

TitleBarPanelIsContextContentProperty Field
Identifies the IsContextContent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsContextContentProperty
Public Shared ReadOnly IsContextContentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsContextContent dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.IsFillerProperty Field

TitleBarPanelIsFillerProperty Field
Identifies the IsFiller dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFillerProperty
Public Shared ReadOnly IsFillerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFiller dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.IsHeaderProperty Field

TitleBarPanelIsHeaderProperty Field
Identifies the IsHeader dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHeaderProperty
Public Shared ReadOnly IsHeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHeader dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleBarPanel.IsIconProperty Field

TitleBarPanelIsIconProperty Field
Identifies the IsIcon dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsIconProperty
Public Shared ReadOnly IsIconProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsIcon dependency property.
See Also

Reference

TitleBarPanel Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter Class

TitleConverter Class
Represents a value converter that can shorten long text by only allowing a certain prefix number of characters at the start, then injecting the patch string, and allowing a certain suffix number of characters at the end.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesTitleConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TitleConverter : IValueConverter
Public Class TitleConverter
    Implements IValueConverter

The TitleConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TitleConverter | Initializes a new instance of the TitleConverter class
Top
Properties
 | Name | Description
Public property | Patch | Gets or sets the string to use in the middle of the string when the title exceeds a maximum length.
Public property | Prefix | Gets or sets the maximum allowed length of the title's prefix.
Public property | Suffix | Gets or sets the maximum allowed length of the title's suffix.
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter Constructor

TitleConverter Constructor
Initializes a new instance of the TitleConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TitleConverter()
Public Sub New
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter Properties

TitleConverter Properties

The TitleConverter type exposes the following members.

Properties
 | Name | Description
Public property | Patch | Gets or sets the string to use in the middle of the string when the title exceeds a maximum length.
Public property | Prefix | Gets or sets the maximum allowed length of the title's prefix.
Public property | Suffix | Gets or sets the maximum allowed length of the title's suffix.
Top
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter.Patch Property

TitleConverterPatch Property
Gets or sets the string to use in the middle of the string when the title exceeds a maximum length.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Patch { get; set; }
Public Property Patch As String
    Get
    Set

Property Value

Type: String
The string to use in the middle of the string when the title exceeds a maximum length. The default value is ....
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter.Prefix Property

TitleConverterPrefix Property
Gets or sets the maximum allowed length of the title's prefix.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Prefix { get; set; }
Public Property Prefix As Integer
    Get
    Set

Property Value

Type: Int32
The maximum allowed length of the title's prefix. The default value is 20.
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter.Suffix Property

TitleConverterSuffix Property
Gets or sets the maximum allowed length of the title's suffix.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Suffix { get; set; }
Public Property Suffix As Integer
    Get
    Set

Property Value

Type: Int32
The maximum allowed length of the title's suffix. The default value is 15.
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter Methods

TitleConverter Methods

The TitleConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter.Convert Method

TitleConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


TitleConverter.ConvertBack Method

TitleConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

TitleConverter Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Class

ToolWindowContainerTabControl Class
Represents an AdvancedTabControl for use within a ToolWindowContainer.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.DockingAdvancedTabControl
ActiproSoftware.UI.Xaml.Controls.Docking.PrimitivesToolWindowContainerTabControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ToolWindowContainerTabControl : AdvancedTabControl
Public Class ToolWindowContainerTabControl
    Inherits AdvancedTabControl

The ToolWindowContainerTabControl type exposes the following members.

Constructors
 | Name | Description
Public method | ToolWindowContainerTabControl | Initializes an instance of the ToolWindowContainerTabControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from AdvancedTabControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the selected content. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplate | Gets the selected content template. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplateSelector | Gets the selected content template selector. (Inherited from AdvancedTabControl.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from AdvancedTabControl.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed. (Inherited from AdvancedTabControl.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from AdvancedTabControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from AdvancedTabControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection changes. (Inherited from AdvancedTabControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from AdvancedTabControl.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from AdvancedTabControl.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Inherited from AdvancedTabControl.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Constructor

ToolWindowContainerTabControl Constructor
Initializes an instance of the ToolWindowContainerTabControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ToolWindowContainerTabControl()
Public Sub New
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Properties

ToolWindowContainerTabControl Properties

The ToolWindowContainerTabControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreScrollButtonsVisible | Gets whether the scroll buttons are visible. (Inherited from AdvancedTabControl.)
Public property | AreTabEmbeddedButtonsAlwaysVisible | Gets or sets whether tab embedded buttons are always visible, even when the tab is unselected. (Inherited from AdvancedTabControl.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanScrollBackward | Gets whether scrolling backward is supported. (Inherited from AdvancedTabControl.)
Public property | CanScrollForward | Gets whether scrolling forward is supported. (Inherited from AdvancedTabControl.)
Public property | CanTabsCloseOnMiddleClick | Gets or sets whether tabs can close when a middle-click is performed over them. (Inherited from AdvancedTabControl.)
Public property | CanTabsDrag | Gets or sets whether the dragging of tabs to reorder is enabled. (Inherited from AdvancedTabControl.)
Public property | CanTabsHighlightOnPointerOverWhenInactive | Gets or sets whether tabs can highlight when the pointer is over inactive ones. (Inherited from AdvancedTabControl.)
Public property | CanTabsPin | Gets or sets whether tabs display an embedded pin button. (Inherited from AdvancedTabControl.)
Public property | CanTabsPromote | Gets or sets whether tabs display an embedded promote from preview layout kind button. (Inherited from AdvancedTabControl.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons. (Inherited from AdvancedTabControl.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | HasNewTabButton | Gets or sets whether a new tab button is available. (Inherited from AdvancedTabControl.)
Public property | HasTabCloseButtons | Gets or sets whether tabs have an embedded close button. (Inherited from AdvancedTabControl.)
Public property | HasTabImages | Gets or sets whether tabs display an embedded image when one is available. (Inherited from AdvancedTabControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightBrushActive | Gets or sets the Brush to use for rendering an active highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightBrushInactive | Gets or sets the Brush to use for rendering an inactive highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HighlightThickness | Gets or sets the thickness of the highlight effect around the content border. (Inherited from AdvancedTabControl.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsActive | Gets or sets whether the tab control is active, generally meaning it contains focus. (Inherited from AdvancedTabControl.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from AdvancedTabControl.)
Public property | IsLayoutAnimationEnabled | Gets or sets whether animation effects are applied during layout, such as when tabs are added or removed. (Inherited from AdvancedTabControl.)
Public property | IsMenuButtonVisible | Gets whether the drop-down menu button is visible. (Inherited from AdvancedTabControl.)
Public property | IsOverflowed | Gets whether the tabs are overflowed. (Inherited from AdvancedTabControl.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabContentHorizontal | Gets or sets whether the tab content layout is in a horizontal orientation. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardAccessEnabled | Gets or sets whether keyboard access to directly select a tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabKeyboardSwitchingEnabled | Gets or sets whether keyboard access to switch to the previous/next tab is enabled. (Inherited from AdvancedTabControl.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTabStripVisible | Gets or sets whether the tabstrip is visible. (Inherited from AdvancedTabControl.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxTabExtent | Gets or sets the maximum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MenuButtonContentTemplate | Gets or sets the DataTemplate to use for the drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinTabExtent | Gets or sets the minimum extent of a tab. (Inherited from AdvancedTabControl.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewTabButtonStyle | Gets or sets the Style to use for the new tab button. (Inherited from AdvancedTabControl.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenMenuCommand | Gets the ICommand that can be used to open the drop-down menu. (Inherited from AdvancedTabControl.)
Public property | OverflowMenuButtonContentTemplate | Gets or sets the DataTemplate to use for the overflow drop-down menu button content. (Inherited from AdvancedTabControl.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequestNewTabCommand | Gets the ICommand that can be used to request a new tab. (Inherited from AdvancedTabControl.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RotatedBorderThickness | Gets or sets the BorderThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedHighlightThickness | Gets or sets the HighlightThickness value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | RotatedPadding | Gets or sets the Padding value, but automatically rotated based on the TabStripPlacement. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll backward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollBackwardCommand | Gets the ICommand that can be used to scroll backward. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardButtonContentTemplate | Gets or sets the DataTemplate to use for the scroll forward button content. (Inherited from AdvancedTabControl.)
Public property | ScrollForwardCommand | Gets the ICommand that can be used to scroll forward. (Inherited from AdvancedTabControl.)
Public property | ScrollOffset | Gets the scroll offset. (Inherited from AdvancedTabControl.)
Public property | SelectedContent | Gets the selected content. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplate | Gets the selected content template. (Inherited from AdvancedTabControl.)
Public property | SelectedContentTemplateSelector | Gets the selected content template selector. (Inherited from AdvancedTabControl.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from AdvancedTabControl.)
Public property | SelectItemCommand | Gets the ICommand that can be used to select an item. (Inherited from AdvancedTabControl.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabBackground | Gets or sets the tabs' background Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundActiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundInactiveSelected | Gets or sets the tabs' background Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPointerOver | Gets or sets the tabs' background Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreview | Gets or sets the tabs' background Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewActiveSelected | Gets or sets the tabs' background Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBackgroundPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrush | Gets or sets the tabs' border Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushActiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushInactiveSelected | Gets or sets the tabs' border Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPointerOver | Gets or sets the tabs' border Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreview | Gets or sets the tabs' border Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewActiveSelected | Gets or sets the tabs' border Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabBorderBrushPreviewPointerOver | Gets or sets the tabs' border Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabCornerRadius | Gets or sets the corner radius of tab borders, relative to a top-facing tab. (Inherited from AdvancedTabControl.)
Public property | TabEmbeddedButtonStyle | Gets or sets the Style to use for embedded buttons within tabs. (Inherited from AdvancedTabControl.)
Public property | TabForeground | Gets or sets the tabs' foreground Brush to use. (Inherited from AdvancedTabControl.)
Public property | TabForegroundActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundInactiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is selected and its content is inactive. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPointerOver | Gets or sets the tabs' foreground Brush to use when the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreview | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewActiveSelected | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab, is selected, and its content is active. (Inherited from AdvancedTabControl.)
Public property | TabForegroundPreviewPointerOver | Gets or sets the tabs' foreground Brush to use when the tab is a preview tab and the pointer is over it. (Inherited from AdvancedTabControl.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | TabOverflowBehavior | Gets or sets the TabOverflowBehavior that indicates the logic to use in tab overflow scenarios. (Inherited from AdvancedTabControl.)
Public property | TabPadding | Gets or sets the tab padding. (Inherited from AdvancedTabControl.)
Public property | TabSpacing | Gets or sets the spacing between tabs. (Inherited from AdvancedTabControl.)
Public property | TabStripPlacement | Gets or sets the side upon which the tabstrip is placed. (Inherited from AdvancedTabControl.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Methods

ToolWindowContainerTabControl Methods

The ToolWindowContainerTabControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from AdvancedTabControl.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides AdvancedTabControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from AdvancedTabControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Inherited from AdvancedTabControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from AdvancedTabControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from AdvancedTabControl.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from AdvancedTabControl.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection changes. (Inherited from AdvancedTabControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from AdvancedTabControl.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from AdvancedTabControl.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from AdvancedTabControl.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides AdvancedTabControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateHighlightBrushes | Optionally updates the HighlightBrushActive and HighlightBrushInactive properties based on the selected tab. (Inherited from AdvancedTabControl.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl.ClearContainerForItemOverride Method

ToolWindowContainerTabControlClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl.PrepareContainerForItemOverride Method

ToolWindowContainerTabControlPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Primitives
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ToolWindowContainerTabControl Events

ToolWindowContainerTabControl Events

The ToolWindowContainerTabControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MenuOpening | Occurs before a context or drop-down menu is opening. (Inherited from AdvancedTabControl.)
Public event | NewTabRequested | Occurs when a new tab is requested. (Inherited from AdvancedTabControl.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | TabClosing | Occurs before a tab is closed due to clicking on its close button. (Inherited from AdvancedTabControl.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolWindowContainerTabControl Class
ActiproSoftware.UI.Xaml.Controls.Docking.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace
Contains classes that are used to serialize layout data for the DockSite control.
Classes
 | Class | Description
Public class | DockingWindowDeserializationBehavior | Specifies the various behaviors available when deserializing a DockingWindow.
Public class | DockingWindowDeserializingEventArgs | Provides event arguments that are used for DockingWindow deserializing event.
Public class | DockSiteLayoutSerializer | Provides DockSite layout serialization and deserialization functionality.
Public class | DockSiteSerializationBehavior | Specifies the various behaviors available when deserializing a DockSite.
Public class | XmlAutoHideHost | Represents a serializable version of the auto-hide portion of a DockHost, used for saving to XML layout.
Public class | XmlAutoHideTabStrip | Represents a serializable version of the auto-hide tab strip on each side of a DockHost, used for saving to XML layout.
Public class | XmlAutoHideTabStripCollection | Represents a list of XmlAutoHideTabStrip objects.
Public class | XmlDockingObject | Represents the base class for a docking object, used for saving to XML layout.
Public class | XmlDockingObjectCollection | Represents a list of XmlObjectBase objects.
Public class | XmlDockingWindow | Represents a serializable version of the DockingWindow class, used for saving to XML layout.
Public class | XmlDockingWindowContainer | Represents a serializable version of the DockingWindowContainerBase class reference, used for saving to XML layout.
Public class | XmlDockingWindowRef | Represents a serializable version of the DockingWindow class reference, used for saving to XML layout.
Public class | XmlDockingWindowState | Indicates the state for a XmlDockingWindow.
Public class | XmlDockSiteLayout | Represents the serializable root node for a DockSite layout.
Public class | XmlDocumentWindow | Represents a serializable version of the DocumentWindow class, used for saving to XML layout.
Public class | XmlDocumentWindowCollection | Represents a list of XmlDocumentWindow objects.
Public class | XmlDocumentWindowRef | Represents a serializable version of the DocumentWindow class reference, used for saving to XML layout.
Public class | XmlRaftedDocumentWindowContainer | Represents a serializable version of the deprecated RaftedDocumentWindowContainer class reference, used for saving to XML layout.
Public class | XmlRaftingHost | Represents a serializable version of a floating DockHost, used for saving to XML layout.
Public class | XmlRaftingHostCollection | Represents a list of XmlRaftingHost objects.
Public class | XmlSplitContainer | Represents a serializable version of the SplitContainer class reference, used for saving to XML layout.
Public class | XmlStandardMdiHost | Represents a serializable version of the StandardMdiHost class reference, used for saving to XML layout.
Public class | XmlTabbedMdiContainer | Represents a serializable version of the XmlTabbedMdiContainer class reference, used for saving to XML layout.
Public class | XmlTabbedMdiHost | Represents a serializable version of the TabbedMdiHost class, used for saving to XML layout.
Public class | XmlToolWindow | Represents a serializable version of the ToolWindow class, used for saving to XML layout.
Public class | XmlToolWindowCollection | Represents a list of XmlToolWindow objects.
Public class | XmlToolWindowContainer | Represents a serializable version of the ToolWindowContainer class reference, used for saving to XML layout.
Public class | XmlToolWindowContainerCollection | Represents a list of XmlToolWindowContainer objects.
Public class | XmlToolWindowRef | Represents a serializable version of the ToolWindow class reference, used for saving to XML layout.
Public class | XmlTrack | Represents a serializable version of the Track class reference, used for saving to XML layout.
Public class | XmlWorkspace | Represents a serializable version of the Workspace class, used for saving to XML layout.


DockingWindowDeserializationBehavior Class

DockingWindowDeserializationBehavior Class
Specifies the various behaviors available when deserializing a DockingWindow.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationDockingWindowDeserializationBehavior

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DockingWindowDeserializationBehavior : Enum
Public NotInheritable Class DockingWindowDeserializationBehavior
    Inherits Enum

The DockingWindowDeserializationBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AutoCreate | Indicates that the DockingWindow will be auto-created, if possible, before restoring the layout data.
 | Discard | Indicates that the layout data will be discarded if the associated DockingWindow does not exist.
 | LazyLoad | Indicates that the layout data will be stored by the DockSite and will be restored when the associated DockingWindow is registered.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializationBehavior Methods

DockingWindowDeserializationBehavior Methods

The DockingWindowDeserializationBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DockingWindowDeserializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializationBehavior Fields

DockingWindowDeserializationBehavior Fields

The DockingWindowDeserializationBehavior type exposes the following members.

Fields
 | Name | Description
 | AutoCreate | Indicates that the DockingWindow will be auto-created, if possible, before restoring the layout data.
 | Discard | Indicates that the layout data will be discarded if the associated DockingWindow does not exist.
 | LazyLoad | Indicates that the layout data will be stored by the DockSite and will be restored when the associated DockingWindow is registered.
Public field | value__ |
Top
See Also

Reference

DockingWindowDeserializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializationBehavior.AutoCreate Field

DockingWindowDeserializationBehaviorAutoCreate Field
Indicates that the DockingWindow will be auto-created, if possible, before restoring the layout data.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowDeserializationBehavior AutoCreate = 1
Public Const AutoCreate As DockingWindowDeserializationBehavior = 1

Field Value

Type: DockingWindowDeserializationBehavior
See Also

Reference

DockingWindowDeserializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializationBehavior.Discard Field

DockingWindowDeserializationBehaviorDiscard Field
Indicates that the layout data will be discarded if the associated DockingWindow does not exist.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowDeserializationBehavior Discard = 0
Public Const Discard As DockingWindowDeserializationBehavior = 0

Field Value

Type: DockingWindowDeserializationBehavior
See Also

Reference

DockingWindowDeserializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializationBehavior.LazyLoad Field

DockingWindowDeserializationBehaviorLazyLoad Field
Indicates that the layout data will be stored by the DockSite and will be restored when the associated DockingWindow is registered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockingWindowDeserializationBehavior LazyLoad = 2
Public Const LazyLoad As DockingWindowDeserializationBehavior = 2

Field Value

Type: DockingWindowDeserializationBehavior
See Also

Reference

DockingWindowDeserializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializationBehavior.value__ Field

DockingWindowDeserializationBehaviorvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.Serialization.DockingWindowDeserializationBehavior.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DockingWindowDeserializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Class

DockingWindowDeserializingEventArgs Class
Provides event arguments that are used for DockingWindow deserializing event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationDockingWindowDeserializingEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockingWindowDeserializingEventArgs : EventArgs
Public Class DockingWindowDeserializingEventArgs
    Inherits EventArgs

The DockingWindowDeserializingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DockingWindowDeserializingEventArgs | Initializes a new instance of the ItemSerializationEventArgs class.
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates whether the default processing should be cancelled.
Public property | Node | Gets the serializable XmlDockingWindow that is used to represent the Window.
Public property | Window | Gets or sets the DockingWindow that is represented by the serializable Node.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Constructor

DockingWindowDeserializingEventArgs Constructor
Initializes a new instance of the ItemSerializationEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowDeserializingEventArgs(
    DockingWindow window,
    XmlDockingWindow node
)
Public Sub New (
    window As DockingWindow,
    node As XmlDockingWindow
)

Parameters

window
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockingWindow
The DockingWindow that is represented by the serializable Node.
node
Type: ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindow
The serializable XmlDockingWindow that is used to represent the Window.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Properties

DockingWindowDeserializingEventArgs Properties

The DockingWindowDeserializingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates whether the default processing should be cancelled.
Public property | Node | Gets the serializable XmlDockingWindow that is used to represent the Window.
Public property | Window | Gets or sets the DockingWindow that is represented by the serializable Node.
Top
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs.Handled Property

DockingWindowDeserializingEventArgsHandled Property
Gets or sets a value that indicates whether the default processing should be cancelled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs.Node Property

DockingWindowDeserializingEventArgsNode Property
Gets the serializable XmlDockingWindow that is used to represent the Window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockingWindow Node { get; }
Public ReadOnly Property Node As XmlDockingWindow
    Get

Property Value

Type: XmlDockingWindow
The serializable XmlDockingWindow that is used to represent the Window.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs.Window Property

DockingWindowDeserializingEventArgsWindow Property
Gets or sets the DockingWindow that is represented by the serializable Node.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindow Window { get; set; }
Public Property Window As DockingWindow
    Get
    Set

Property Value

Type: DockingWindow
The DockingWindow that is represented by the serializable Node.
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockingWindowDeserializingEventArgs Methods

DockingWindowDeserializingEventArgs Methods

The DockingWindowDeserializingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DockingWindowDeserializingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Class

DockSiteLayoutSerializer Class
Provides DockSite layout serialization and deserialization functionality.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlSerializerBase DockSite, XmlDockSiteLayout
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationDockSiteLayoutSerializer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DockSiteLayoutSerializer : XmlSerializerBase<DockSite, XmlDockSiteLayout>
Public Class DockSiteLayoutSerializer
    Inherits XmlSerializerBase(Of DockSite, XmlDockSiteLayout)

The DockSiteLayoutSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | DockSiteLayoutSerializer | Initializes an instance of the DockSiteLayoutSerializer class.
Public method | DockSiteLayoutSerializer(XmlDockSiteLayout) | Initializes an instance of the DockSiteLayoutSerializer class.
Top
Properties
 | Name | Description
Public property | CanSerializeUnusedLazyLoadData | Gets or sets whether unused lazy load data can be serialized.
Public property | CustomTypes | Gets the collection of custom Types that can be serialized and deserialized using this serializer. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | DocumentWindowDeserializationBehavior | Gets or sets the DocumentWindow deserialization behavior.
Public property | RootNode | Gets or sets the root TXmlObj node that is serialized and deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | SerializationBehavior | Gets or sets the DockSite serialization behavior.
Public property | ToolWindowDeserializationBehavior | Gets or sets the ToolWindow deserialization behavior.
Top
Methods
 | Name | Description
Public method | ApplyTo | Applies the information contained within this serializer to the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjApplyTo(TObj).)
Public method | CreateRootNodeFor | Creates a root node for the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjCreateRootNodeFor(TObj).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | GetXmlSerializer | Returns the XmlSerializer to use for serialization and deserialization. (Overrides XmlSerializerBaseTObj, TXmlObjGetXmlSerializer.)
Public method | LoadFromStream(Stream) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromStream(Stream, TObj) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String, TObj) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader, TObj) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | RaiseDockingWindowDeserializing | Raises the DockingWindowDeserializing event with the specified arguments.
Protected method | RaiseObjectDeserialized | Raises the ObjectDeserialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | RaiseObjectSerialized | Raises the ObjectSerialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream, TObj) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString(TObj) | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter, TObj) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | ToString | (Inherited from Object.)
Protected method | WriteHeader | Allows for dynamic injection of an XML comment or other data before the main serialization routine occurs. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
Events
 | Name | Description
Public event | DockingWindowDeserializing | Occurs when an object is deserialized.
Public event | ObjectDeserialized | Occurs when an object is deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public event | ObjectSerialized | Occurs when an object is serialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Constructor

DockSiteLayoutSerializer Constructor
Overload List
 | Name | Description
Public method | DockSiteLayoutSerializer | Initializes an instance of the DockSiteLayoutSerializer class.
Public method | DockSiteLayoutSerializer(XmlDockSiteLayout) | Initializes an instance of the DockSiteLayoutSerializer class.
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Constructor

DockSiteLayoutSerializer Constructor
Initializes an instance of the DockSiteLayoutSerializer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSiteLayoutSerializer()
Public Sub New
See Also

Reference

DockSiteLayoutSerializer Class
DockSiteLayoutSerializer Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Constructor (XmlDockSiteLayout)

DockSiteLayoutSerializer Constructor (XmlDockSiteLayout)
Initializes an instance of the DockSiteLayoutSerializer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSiteLayoutSerializer(
    XmlDockSiteLayout layout
)
Public Sub New (
    layout As XmlDockSiteLayout
)

Parameters

layout
Type: ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockSiteLayout
The root XmlDockSiteLayout node.
See Also

Reference

DockSiteLayoutSerializer Class
DockSiteLayoutSerializer Overload
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Properties

DockSiteLayoutSerializer Properties

The DockSiteLayoutSerializer type exposes the following members.

Properties
 | Name | Description
Public property | CanSerializeUnusedLazyLoadData | Gets or sets whether unused lazy load data can be serialized.
Public property | CustomTypes | Gets the collection of custom Types that can be serialized and deserialized using this serializer. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | DocumentWindowDeserializationBehavior | Gets or sets the DocumentWindow deserialization behavior.
Public property | RootNode | Gets or sets the root TXmlObj node that is serialized and deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public property | SerializationBehavior | Gets or sets the DockSite serialization behavior.
Public property | ToolWindowDeserializationBehavior | Gets or sets the ToolWindow deserialization behavior.
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.CanSerializeUnusedLazyLoadData Property

DockSiteLayoutSerializerCanSerializeUnusedLazyLoadData Property
Gets or sets whether unused lazy load data can be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanSerializeUnusedLazyLoadData { get; set; }
Public Property CanSerializeUnusedLazyLoadData As Boolean
    Get
    Set

Property Value

Type: Boolean
true if unused lazy load data can be serialized; otherwise, false. The default value is false.
Remarks
When a layout is deserialized and ToolWindowDeserializationBehavior or DocumentWindowDeserializationBehavior are LazyLoad, lazy load data is stored for the windows if windows in the layout are not yet registered with the DockSite. If they later become registered, their lazy load data allows them to be restored to their previous location in the layout. If a layout is serialized without one of these windows being registered, normally it will discard the lazy load data so that it does not accumulate over time. Change this property to true to allow that lazy load data to be retained during serialization.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.DocumentWindowDeserializationBehavior Property

DockSiteLayoutSerializerDocumentWindowDeserializationBehavior Property
Gets or sets the DocumentWindow deserialization behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowDeserializationBehavior DocumentWindowDeserializationBehavior { get; set; }
Public Property DocumentWindowDeserializationBehavior As DockingWindowDeserializationBehavior
    Get
    Set

Property Value

Type: DockingWindowDeserializationBehavior
The DocumentWindow deserialization behavior.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.SerializationBehavior Property

DockSiteLayoutSerializerSerializationBehavior Property
Gets or sets the DockSite serialization behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSiteSerializationBehavior SerializationBehavior { get; set; }
Public Property SerializationBehavior As DockSiteSerializationBehavior
    Get
    Set

Property Value

Type: DockSiteSerializationBehavior
The DockSite serialization behavior.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.ToolWindowDeserializationBehavior Property

DockSiteLayoutSerializerToolWindowDeserializationBehavior Property
Gets or sets the ToolWindow deserialization behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockingWindowDeserializationBehavior ToolWindowDeserializationBehavior { get; set; }
Public Property ToolWindowDeserializationBehavior As DockingWindowDeserializationBehavior
    Get
    Set

Property Value

Type: DockingWindowDeserializationBehavior
The ToolWindow deserialization behavior.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Methods

DockSiteLayoutSerializer Methods

The DockSiteLayoutSerializer type exposes the following members.

Methods
 | Name | Description
Public method | ApplyTo | Applies the information contained within this serializer to the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjApplyTo(TObj).)
Public method | CreateRootNodeFor | Creates a root node for the specified object. (Overrides XmlSerializerBaseTObj, TXmlObjCreateRootNodeFor(TObj).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | GetXmlSerializer | Returns the XmlSerializer to use for serialization and deserialization. (Overrides XmlSerializerBaseTObj, TXmlObjGetXmlSerializer.)
Public method | LoadFromStream(Stream) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromStream(Stream, TObj) | Deserializes the RootNode from the specified Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromString(String, TObj) | Deserializes the RootNode from the specified XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | LoadFromXmlReader(XmlReader, TObj) | Deserializes the RootNode from the specified XmlReader. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | RaiseDockingWindowDeserializing | Raises the DockingWindowDeserializing event with the specified arguments.
Protected method | RaiseObjectDeserialized | Raises the ObjectDeserialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Protected method | RaiseObjectSerialized | Raises the ObjectSerialized event with the specified arguments. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToStream(Stream, TObj) | Serializes the RootNode to XML within a Stream. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToString(TObj) | Serializes the RootNode to an XML string. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | SaveToXmlWriter(XmlWriter, TObj) | Serializes the RootNode to XML by using an XmlWriter. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public method | ToString | (Inherited from Object.)
Protected method | WriteHeader | Allows for dynamic injection of an XML comment or other data before the main serialization routine occurs. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.ApplyTo Method

DockSiteLayoutSerializerApplyTo Method
Applies the information contained within this serializer to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void ApplyTo(
    DockSite obj
)
Public Overrides Sub ApplyTo (
    obj As DockSite
)

Parameters

obj
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The object to update with deserialized information.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.CreateRootNodeFor Method

DockSiteLayoutSerializerCreateRootNodeFor Method
Creates a root node for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override XmlDockSiteLayout CreateRootNodeFor(
    DockSite obj
)
Public Overrides Function CreateRootNodeFor (
    obj As DockSite
) As XmlDockSiteLayout

Parameters

obj
Type: ActiproSoftware.UI.Xaml.Controls.DockingDockSite
The object for which to create a root node.

Return Value

Type: XmlDockSiteLayout
The root node that was created.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.GetXmlSerializer Method

DockSiteLayoutSerializerGetXmlSerializer Method
Returns the XmlSerializer to use for serialization and deserialization.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override XmlSerializer GetXmlSerializer()
Protected Overrides Function GetXmlSerializer As XmlSerializer

Return Value

Type: XmlSerializer
The XmlSerializer that was created.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.RaiseDockingWindowDeserializing Method

DockSiteLayoutSerializerRaiseDockingWindowDeserializing Method
Raises the DockingWindowDeserializing event with the specified arguments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void RaiseDockingWindowDeserializing(
    DockingWindowDeserializingEventArgs eventArgs
)
Protected Overridable Sub RaiseDockingWindowDeserializing (
    eventArgs As DockingWindowDeserializingEventArgs
)

Parameters

eventArgs
Type: ActiproSoftware.UI.Xaml.Controls.Docking.SerializationDockingWindowDeserializingEventArgs
The DockingWindowDeserializingEventArgs instance containing the event data.
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer Events

DockSiteLayoutSerializer Events

The DockSiteLayoutSerializer type exposes the following members.

Events
 | Name | Description
Public event | DockingWindowDeserializing | Occurs when an object is deserialized.
Public event | ObjectDeserialized | Occurs when an object is deserialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Public event | ObjectSerialized | Occurs when an object is serialized. (Inherited from XmlSerializerBaseTObj, TXmlObj.)
Top
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteLayoutSerializer.DockingWindowDeserializing Event

DockSiteLayoutSerializerDockingWindowDeserializing Event
Occurs when an object is deserialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DockingWindowDeserializingEventArgs> DockingWindowDeserializing
Public Event DockingWindowDeserializing As EventHandler(Of DockingWindowDeserializingEventArgs)

Value

Type: SystemEventHandler DockingWindowDeserializingEventArgs
See Also

Reference

DockSiteLayoutSerializer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior Class

DockSiteSerializationBehavior Class
Specifies the various behaviors available when deserializing a DockSite.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationDockSiteSerializationBehavior

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DockSiteSerializationBehavior : Enum
Public NotInheritable Class DockSiteSerializationBehavior
    Inherits Enum

The DockSiteSerializationBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that the entire layout will be serialized.
 | ToolWindowsOnly | Indicates that only the layout of the tool windows will be serialized.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior Methods

DockSiteSerializationBehavior Methods

The DockSiteSerializationBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DockSiteSerializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior Fields

DockSiteSerializationBehavior Fields

The DockSiteSerializationBehavior type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that the entire layout will be serialized.
 | ToolWindowsOnly | Indicates that only the layout of the tool windows will be serialized.
Public field | value__ |
Top
See Also

Reference

DockSiteSerializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior.All Field

DockSiteSerializationBehaviorAll Field
Indicates that the entire layout will be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockSiteSerializationBehavior All = 1
Public Const All As DockSiteSerializationBehavior = 1

Field Value

Type: DockSiteSerializationBehavior
See Also

Reference

DockSiteSerializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior.ToolWindowsOnly Field

DockSiteSerializationBehaviorToolWindowsOnly Field
Indicates that only the layout of the tool windows will be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DockSiteSerializationBehavior ToolWindowsOnly = 0
Public Const ToolWindowsOnly As DockSiteSerializationBehavior = 0

Field Value

Type: DockSiteSerializationBehavior
See Also

Reference

DockSiteSerializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


DockSiteSerializationBehavior.value__ Field

DockSiteSerializationBehaviorvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.Serialization.DockSiteSerializationBehavior.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DockSiteSerializationBehavior Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideHost Class

XmlAutoHideHost Class
Represents a serializable version of the auto-hide portion of a DockHost, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlAutoHideHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlAutoHideHost : XmlObjectBase
Public Class XmlAutoHideHost
    Inherits XmlObjectBase

The XmlAutoHideHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAutoHideHost | Initializes a new instance of the XmlAutoHideHost class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideHost Constructor

XmlAutoHideHost Constructor
Initializes a new instance of the XmlAutoHideHost class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAutoHideHost()
Public Sub New
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideHost Properties

XmlAutoHideHost Properties

The XmlAutoHideHost type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideHost.Children Property

XmlAutoHideHostChildren Property
Gets the collection of children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAutoHideTabStripCollection Children { get; }
Public ReadOnly Property Children As XmlAutoHideTabStripCollection
    Get

Property Value

Type: XmlAutoHideTabStripCollection
The collection of children.
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideHost Methods

XmlAutoHideHost Methods

The XmlAutoHideHost type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlAutoHideHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Class

XmlAutoHideTabStrip Class
Represents a serializable version of the auto-hide tab strip on each side of a DockHost, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlAutoHideTabStrip

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlAutoHideTabStrip : XmlObjectBase
Public Class XmlAutoHideTabStrip
    Inherits XmlObjectBase

The XmlAutoHideTabStrip type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAutoHideTabStrip | Initializes a new instance of the XmlAutoHideTabStrip class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Side | Gets or sets the side upon which the tabstrip appears.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Constructor

XmlAutoHideTabStrip Constructor
Initializes a new instance of the XmlAutoHideTabStrip class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAutoHideTabStrip()
Public Sub New
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Properties

XmlAutoHideTabStrip Properties

The XmlAutoHideTabStrip type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | Side | Gets or sets the side upon which the tabstrip appears.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip.Children Property

XmlAutoHideTabStripChildren Property
Gets the collection of children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindowContainerCollection Children { get; }
Public ReadOnly Property Children As XmlToolWindowContainerCollection
    Get

Property Value

Type: XmlToolWindowContainerCollection
The collection of children.
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip.Side Property

XmlAutoHideTabStripSide Property
Gets or sets the side upon which the tabstrip appears.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Side Side { get; set; }
Public Property Side As Side
    Get
    Set

Property Value

Type: Side
The side upon which the tabstrip appears.
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStrip Methods

XmlAutoHideTabStrip Methods

The XmlAutoHideTabStrip type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlAutoHideTabStrip Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Class

XmlAutoHideTabStripCollection Class
Represents a list of XmlAutoHideTabStrip objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlAutoHideTabStrip
System.Collections.ObjectModelObservableCollection XmlAutoHideTabStrip
ActiproSoftware.UI.XamlDeferrableObservableCollection XmlAutoHideTabStrip
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlAutoHideTabStripCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlAutoHideTabStripCollection : DeferrableObservableCollection<XmlAutoHideTabStrip>
Public Class XmlAutoHideTabStripCollection
    Inherits DeferrableObservableCollection(Of XmlAutoHideTabStrip)

The XmlAutoHideTabStripCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlAutoHideTabStripCollection | Initializes a new instance of the XmlAutoHideTabStripCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlAutoHideTabStrip .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlAutoHideTabStrip .)
Protected property | Items | (Inherited from Collection XmlAutoHideTabStrip .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Clear | (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Contains | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | CopyTo | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | Insert | (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | RemoveAt | (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Constructor

XmlAutoHideTabStripCollection Constructor
Initializes a new instance of the XmlAutoHideTabStripCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAutoHideTabStripCollection()
Public Sub New
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Properties

XmlAutoHideTabStripCollection Properties

The XmlAutoHideTabStripCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlAutoHideTabStrip .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlAutoHideTabStrip .)
Protected property | Items | (Inherited from Collection XmlAutoHideTabStrip .)
Top
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Methods

XmlAutoHideTabStripCollection Methods

The XmlAutoHideTabStripCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Clear | (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Public method | Contains | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | CopyTo | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | Insert | (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlAutoHideTabStrip .)
Public method | RemoveAt | (Inherited from Collection XmlAutoHideTabStrip .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlAutoHideTabStripCollection Events

XmlAutoHideTabStripCollection Events

The XmlAutoHideTabStripCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlAutoHideTabStrip .)
Top
See Also

Reference

XmlAutoHideTabStripCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObject Class

XmlDockingObject Class
Represents the base class for a docking object, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XmlDockingObject : XmlObjectBase
Public MustInherit Class XmlDockingObject
    Inherits XmlObjectBase

The XmlDockingObject type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingObject | Initializes a new instance of the XmlDockingObject class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlRaftingHost
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlSplitContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlTrack
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlWorkspace


XmlDockingObject Constructor

XmlDockingObject Constructor
Initializes a new instance of the XmlDockingObject class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected XmlDockingObject()
Protected Sub New
See Also

Reference

XmlDockingObject Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObject Properties

XmlDockingObject Properties

The XmlDockingObject type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlDockingObject Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObject Methods

XmlDockingObject Methods

The XmlDockingObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDockingObject Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Class

XmlDockingObjectCollection Class
Represents a list of XmlObjectBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlObjectBase
System.Collections.ObjectModelObservableCollection XmlObjectBase
ActiproSoftware.UI.XamlDeferrableObservableCollection XmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObjectCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlDockingObjectCollection : DeferrableObservableCollection<XmlObjectBase>
Public Class XmlDockingObjectCollection
    Inherits DeferrableObservableCollection(Of XmlObjectBase)

The XmlDockingObjectCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDockingObjectCollection | Initializes a new instance of the XmlDockingObjectCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlObjectBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlObjectBase .)
Protected property | Items | (Inherited from Collection XmlObjectBase .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlObjectBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlObjectBase .)
Public method | Clear | (Inherited from Collection XmlObjectBase .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlObjectBase .)
Public method | Contains | (Inherited from Collection XmlObjectBase .)
Public method | CopyTo | (Inherited from Collection XmlObjectBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlObjectBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlObjectBase .)
Public method | Insert | (Inherited from Collection XmlObjectBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlObjectBase .)
Public method | RemoveAt | (Inherited from Collection XmlObjectBase .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlObjectBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlObjectBase .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Constructor

XmlDockingObjectCollection Constructor
Initializes a new instance of the XmlDockingObjectCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection()
Public Sub New
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Properties

XmlDockingObjectCollection Properties

The XmlDockingObjectCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlObjectBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlObjectBase .)
Protected property | Items | (Inherited from Collection XmlObjectBase .)
Top
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Methods

XmlDockingObjectCollection Methods

The XmlDockingObjectCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlObjectBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlObjectBase .)
Public method | Clear | (Inherited from Collection XmlObjectBase .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlObjectBase .)
Public method | Contains | (Inherited from Collection XmlObjectBase .)
Public method | CopyTo | (Inherited from Collection XmlObjectBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlObjectBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlObjectBase .)
Public method | Insert | (Inherited from Collection XmlObjectBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlObjectBase .)
Public method | RemoveAt | (Inherited from Collection XmlObjectBase .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlObjectBase .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingObjectCollection Events

XmlDockingObjectCollection Events

The XmlDockingObjectCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlObjectBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlObjectBase .)
Top
See Also

Reference

XmlDockingObjectCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow Class

XmlDockingWindow Class
Represents a serializable version of the DockingWindow class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDocumentWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindow

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XmlDockingWindow : XmlDockingObject
Public MustInherit Class XmlDockingWindow
    Inherits XmlDockingObject

The XmlDockingWindow type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingWindow | Initializes an instance of the XmlDockingWindow class.
Top
Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | IsOpen | Gets or sets whether the window is open.
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Public property | Name | Gets or sets the name of the window.
Public property | SerializationId | Gets or sets the serialization ID of the window.
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window.
Public property | State | Gets or sets the current state of the window.
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control.
Public property | TypeSerializable | Gets or sets the type of the associated control.
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized.
Public method | ShouldSerializeName | Determines if the Name property should be serialized.
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized.
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized.
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized.
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized.
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow Constructor

XmlDockingWindow Constructor
Initializes an instance of the XmlDockingWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected XmlDockingWindow()
Protected Sub New
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow Properties

XmlDockingWindow Properties

The XmlDockingWindow type exposes the following members.

Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | IsOpen | Gets or sets whether the window is open.
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.
Public property | Name | Gets or sets the name of the window.
Public property | SerializationId | Gets or sets the serialization ID of the window.
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI.
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI.
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window.
Public property | State | Gets or sets the current state of the window.
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control.
Public property | TypeSerializable | Gets or sets the type of the associated control.
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ContainerDockedSize Property

XmlDockingWindowContainerDockedSize Property
Gets or sets the size of the docking window's container when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerDockedSize { get; set; }
Public Property ContainerDockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the docking window's container when in a Docked state.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ContainerDockedSizeSerializable Property

XmlDockingWindowContainerDockedSizeSerializable Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ContainerDockedSizeSerializable { get; set; }
Public Property ContainerDockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.IsOpen Property

XmlDockingWindowIsOpen Property
Gets or sets whether the window is open.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOpen { get; set; }
Public Property IsOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the window is open; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.LastActiveDateTime Property

XmlDockingWindowLastActiveDateTime Property
Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime LastActiveDateTime { get; set; }
Public Property LastActiveDateTime As DateTime
    Get
    Set

Property Value

Type: DateTime
The DateTime at which the window was last active, meaning the primary window that was focused.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.Name Property

XmlDockingWindowName Property
Gets or sets the name of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.SerializationId Property

XmlDockingWindowSerializationId Property
Gets or sets the serialization ID of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SerializationId { get; set; }
Public Property SerializationId As String
    Get
    Set

Property Value

Type: String
The serialization ID of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiBounds Property

XmlDockingWindowStandardMdiBounds Property
Gets or sets the current bounds of the window in standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Rect> StandardMdiBounds { get; set; }
Public Property StandardMdiBounds As Nullable(Of Rect)
    Get
    Set

Property Value

Type: Nullable Rect
The current bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiBoundsSerializable Property

XmlDockingWindowStandardMdiBoundsSerializable Property
Gets or sets the current bounds of the window in standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StandardMdiBoundsSerializable { get; set; }
Public Property StandardMdiBoundsSerializable As String
    Get
    Set

Property Value

Type: String
The current bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiRestoreBounds Property

XmlDockingWindowStandardMdiRestoreBounds Property
Gets or sets the restore bounds of the window in standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Rect> StandardMdiRestoreBounds { get; set; }
Public Property StandardMdiRestoreBounds As Nullable(Of Rect)
    Get
    Set

Property Value

Type: Nullable Rect
The restore bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiRestoreBoundsSerializable Property

XmlDockingWindowStandardMdiRestoreBoundsSerializable Property
Gets or sets the restore bounds of the window in standard MDI.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string StandardMdiRestoreBoundsSerializable { get; set; }
Public Property StandardMdiRestoreBoundsSerializable As String
    Get
    Set

Property Value

Type: String
The restore bounds of the window in standard MDI.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.StandardMdiWindowState Property

XmlDockingWindowStandardMdiWindowState Property
Gets or sets the standard MDI state of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WindowState StandardMdiWindowState { get; set; }
Public Property StandardMdiWindowState As WindowState
    Get
    Set

Property Value

Type: WindowState
The standard MDI state of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.State Property

XmlDockingWindowState Property
Gets or sets the current state of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockingWindowState State { get; set; }
Public Property State As XmlDockingWindowState
    Get
    Set

Property Value

Type: XmlDockingWindowState
The current state of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.TabbedMdiLayoutKind Property

XmlDockingWindowTabbedMdiLayoutKind Property
Gets or sets the tab layout kind.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TabLayoutKind TabbedMdiLayoutKind { get; set; }
Public Property TabbedMdiLayoutKind As TabLayoutKind
    Get
    Set

Property Value

Type: TabLayoutKind
The tab layout kind.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.Type Property

XmlDockingWindowType Property
Gets or sets the type of the associated control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type Type { get; set; }
Public Property Type As Type
    Get
    Set

Property Value

Type: Type
The type of the associated control.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.TypeSerializable Property

XmlDockingWindowTypeSerializable Property
Gets or sets the type of the associated control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TypeSerializable { get; set; }
Public Property TypeSerializable As String
    Get
    Set

Property Value

Type: String
The type of the associated control.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.UniqueId Property

XmlDockingWindowUniqueId Property
Gets or sets the unique ID of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the window.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow Methods

XmlDockingWindow Methods

The XmlDockingWindow type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized.
Public method | ShouldSerializeName | Determines if the Name property should be serialized.
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized.
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized.
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized.
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized.
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeContainerDockedSizeSerializable Method

XmlDockingWindowShouldSerializeContainerDockedSizeSerializable Method
Determines if the ContainerDockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeContainerDockedSizeSerializable()
Public Overridable Function ShouldSerializeContainerDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the ContainerDockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeLastActiveDateTime Method

XmlDockingWindowShouldSerializeLastActiveDateTime Method
Determines if the LastActiveDateTime property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeLastActiveDateTime()
Public Overridable Function ShouldSerializeLastActiveDateTime As Boolean

Return Value

Type: Boolean
true if the LastActiveDateTime property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeName Method

XmlDockingWindowShouldSerializeName Method
Determines if the Name property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeName()
Public Overridable Function ShouldSerializeName As Boolean

Return Value

Type: Boolean
true if the Name property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeSerializationId Method

XmlDockingWindowShouldSerializeSerializationId Method
Determines if the SerializationId property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeSerializationId()
Public Overridable Function ShouldSerializeSerializationId As Boolean

Return Value

Type: Boolean
true if the SerializationId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeStandardMdiBoundsSerializable Method

XmlDockingWindowShouldSerializeStandardMdiBoundsSerializable Method
Determines if the StandardMdiBoundsSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeStandardMdiBoundsSerializable()
Public Overridable Function ShouldSerializeStandardMdiBoundsSerializable As Boolean

Return Value

Type: Boolean
true if the StandardMdiBoundsSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeStandardMdiWindowState Method

XmlDockingWindowShouldSerializeStandardMdiWindowState Method
Determines if the StandardMdiWindowState property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeStandardMdiWindowState()
Public Overridable Function ShouldSerializeStandardMdiWindowState As Boolean

Return Value

Type: Boolean
true if the StandardMdiWindowState property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeTabbedMdiLayoutKind Method

XmlDockingWindowShouldSerializeTabbedMdiLayoutKind Method
Determines if the TabbedMdiLayoutKind property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeTabbedMdiLayoutKind()
Public Overridable Function ShouldSerializeTabbedMdiLayoutKind As Boolean

Return Value

Type: Boolean
true if the TabbedMdiLayoutKind property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeTypeSerializable Method

XmlDockingWindowShouldSerializeTypeSerializable Method
Determines if the TypeSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeTypeSerializable()
Public Overridable Function ShouldSerializeTypeSerializable As Boolean

Return Value

Type: Boolean
true if the TypeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindow.ShouldSerializeUniqueId Method

XmlDockingWindowShouldSerializeUniqueId Method
Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Class

XmlDockingWindowContainer Class
Represents a serializable version of the DockingWindowContainerBase class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlRaftedDocumentWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlTabbedMdiContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XmlDockingWindowContainer : XmlDockingObject
Public MustInherit Class XmlDockingWindowContainer
    Inherits XmlDockingObject

The XmlDockingWindowContainer type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingWindowContainer | Initializes an instance of the XmlDockingWindowContainer class.
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Constructor

XmlDockingWindowContainer Constructor
Initializes an instance of the XmlDockingWindowContainer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected XmlDockingWindowContainer()
Protected Sub New
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Properties

XmlDockingWindowContainer Properties

The XmlDockingWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.Children Property

XmlDockingWindowContainerChildren Property
Gets the collection of children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection Children { get; }
Public ReadOnly Property Children As XmlDockingObjectCollection
    Get

Property Value

Type: XmlDockingObjectCollection
The collection of children.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.DockedSize Property

XmlDockingWindowContainerDockedSize Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size DockedSize { get; set; }
Public Property DockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the control when in a Docked state.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.DockedSizeSerializable Property

XmlDockingWindowContainerDockedSizeSerializable Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DockedSizeSerializable { get; set; }
Public Property DockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.SelectedWindowUniqueId Property

XmlDockingWindowContainerSelectedWindowUniqueId Property
Gets or sets the unique ID of the selected window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid SelectedWindowUniqueId { get; set; }
Public Property SelectedWindowUniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the selected window.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer Methods

XmlDockingWindowContainer Methods

The XmlDockingWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.ShouldSerializeDockedSizeSerializable Method

XmlDockingWindowContainerShouldSerializeDockedSizeSerializable Method
Determines if the DockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeDockedSizeSerializable()
Public Overridable Function ShouldSerializeDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the DockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowContainer.ShouldSerializeSelectedWindowUniqueId Method

XmlDockingWindowContainerShouldSerializeSelectedWindowUniqueId Method
Determines if the SelectedWindowUniqueId property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeSelectedWindowUniqueId()
Public Overridable Function ShouldSerializeSelectedWindowUniqueId As Boolean

Return Value

Type: Boolean
true if the SelectedWindowUniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Class

XmlDockingWindowRef Class
Represents a serializable version of the DockingWindow class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDocumentWindowRef
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowRef

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class XmlDockingWindowRef : XmlDockingObject
Public MustInherit Class XmlDockingWindowRef
    Inherits XmlDockingObject

The XmlDockingWindowRef type exposes the following members.

Constructors
 | Name | Description
Protected method | XmlDockingWindowRef | Initializes a new instance of the XmlDockingWindowRef class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Constructor

XmlDockingWindowRef Constructor
Initializes a new instance of the XmlDockingWindowRef class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected XmlDockingWindowRef()
Protected Sub New
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Properties

XmlDockingWindowRef Properties

The XmlDockingWindowRef type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowRef.UniqueId Property

XmlDockingWindowRefUniqueId Property
Gets or sets the unique ID of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the window.
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowRef Methods

XmlDockingWindowRef Methods

The XmlDockingWindowRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowRef.ShouldSerializeUniqueId Method

XmlDockingWindowRefShouldSerializeUniqueId Method
Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlDockingWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState Class

XmlDockingWindowState Class
Indicates the state for a XmlDockingWindow.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowState

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class XmlDockingWindowState : Enum
Public NotInheritable Class XmlDockingWindowState
    Inherits Enum

The XmlDockingWindowState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AutoHide | The window is auto-hidden in a container along the side of a dock host.
 | Docked | The window is docked in a container outside of the MDI (multiple document interface) area.
 | Document | The window is a document within the MDI (multiple document interface) area.
 | Floating | Deprecated, for compatibility with old versions only.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState Methods

XmlDockingWindowState Methods

The XmlDockingWindowState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState Fields

XmlDockingWindowState Fields

The XmlDockingWindowState type exposes the following members.

Fields
 | Name | Description
 | AutoHide | The window is auto-hidden in a container along the side of a dock host.
 | Docked | The window is docked in a container outside of the MDI (multiple document interface) area.
 | Document | The window is a document within the MDI (multiple document interface) area.
 | Floating | Deprecated, for compatibility with old versions only.
Public field | value__ |
Top
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState.AutoHide Field

XmlDockingWindowStateAutoHide Field
The window is auto-hidden in a container along the side of a dock host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlDockingWindowState AutoHide = 2
Public Const AutoHide As XmlDockingWindowState = 2

Field Value

Type: XmlDockingWindowState
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState.Docked Field

XmlDockingWindowStateDocked Field
The window is docked in a container outside of the MDI (multiple document interface) area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlDockingWindowState Docked = 0
Public Const Docked As XmlDockingWindowState = 0

Field Value

Type: XmlDockingWindowState
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState.Document Field

XmlDockingWindowStateDocument Field
The window is a document within the MDI (multiple document interface) area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlDockingWindowState Document = 1
Public Const Document As XmlDockingWindowState = 1

Field Value

Type: XmlDockingWindowState
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState.Floating Field

XmlDockingWindowStateFloating Field
Deprecated, for compatibility with old versions only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const XmlDockingWindowState Floating = 3
Public Const Floating As XmlDockingWindowState = 3

Field Value

Type: XmlDockingWindowState
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockingWindowState.value__ Field

XmlDockingWindowStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Docking.Serialization.XmlDockingWindowState.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

XmlDockingWindowState Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Class

XmlDockSiteLayout Class
Represents the serializable root node for a DockSite layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockSiteLayout

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlDockSiteLayout : XmlObjectBase
Public Class XmlDockSiteLayout
    Inherits XmlObjectBase

The XmlDockSiteLayout type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDockSiteLayout | Initializes an instance of the XmlDockSiteLayout class.
Top
Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the dock site.
Public property | Content | Gets or sets the content of the dock site.
Public property | DocumentWindows | Gets the collection of document windows.
Public property | RaftingHosts | Gets the collection of rafting hosts.
Public property | SerializationFormat | Gets or sets the serialization format used when saving the layout.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | ToolWindows | Gets the collection of tool windows.
Public property | Version | Gets or sets the layout version.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDocumentWindows | Determines if the DocumentWindows property should be serialized.
Public method | ShouldSerializeRaftingHosts | Determines if the RaftingHosts property should be serialized.
Public method | ShouldSerializeToolWindows | Determines if the ToolWindows property should be serialized.
Public method | ShouldSerializeVersion | Determines if the Version property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Constructor

XmlDockSiteLayout Constructor
Initializes an instance of the XmlDockSiteLayout class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockSiteLayout()
Public Sub New
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Properties

XmlDockSiteLayout Properties

The XmlDockSiteLayout type exposes the following members.

Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the dock site.
Public property | Content | Gets or sets the content of the dock site.
Public property | DocumentWindows | Gets the collection of document windows.
Public property | RaftingHosts | Gets the collection of rafting hosts.
Public property | SerializationFormat | Gets or sets the serialization format used when saving the layout.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | ToolWindows | Gets the collection of tool windows.
Public property | Version | Gets or sets the layout version.
Top
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.AutoHideHost Property

XmlDockSiteLayoutAutoHideHost Property
Gets or sets the auto-hide host of the dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAutoHideHost AutoHideHost { get; set; }
Public Property AutoHideHost As XmlAutoHideHost
    Get
    Set

Property Value

Type: XmlAutoHideHost
The auto-hide host of the dock site.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.Content Property

XmlDockSiteLayoutContent Property
Gets or sets the content of the dock site.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the dock site.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.DocumentWindows Property

XmlDockSiteLayoutDocumentWindows Property
Gets the collection of document windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDocumentWindowCollection DocumentWindows { get; }
Public ReadOnly Property DocumentWindows As XmlDocumentWindowCollection
    Get

Property Value

Type: XmlDocumentWindowCollection
The collection of document windows.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.RaftingHosts Property

XmlDockSiteLayoutRaftingHosts Property
Gets the collection of rafting hosts.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlRaftingHostCollection RaftingHosts { get; }
Public ReadOnly Property RaftingHosts As XmlRaftingHostCollection
    Get

Property Value

Type: XmlRaftingHostCollection
The collection of rafting hosts.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.SerializationFormat Property

XmlDockSiteLayoutSerializationFormat Property
Gets or sets the serialization format used when saving the layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DockSiteSerializationBehavior SerializationFormat { get; set; }
Public Property SerializationFormat As DockSiteSerializationBehavior
    Get
    Set

Property Value

Type: DockSiteSerializationBehavior
The serialization format used when saving the layout.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ToolWindows Property

XmlDockSiteLayoutToolWindows Property
Gets the collection of tool windows.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindowCollection ToolWindows { get; }
Public ReadOnly Property ToolWindows As XmlToolWindowCollection
    Get

Property Value

Type: XmlToolWindowCollection
The collection of tool windows.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.Version Property

XmlDockSiteLayoutVersion Property
Gets or sets the layout version.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Version { get; set; }
Public Property Version As Integer
    Get
    Set

Property Value

Type: Int32
The layout version.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout Methods

XmlDockSiteLayout Methods

The XmlDockSiteLayout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDocumentWindows | Determines if the DocumentWindows property should be serialized.
Public method | ShouldSerializeRaftingHosts | Determines if the RaftingHosts property should be serialized.
Public method | ShouldSerializeToolWindows | Determines if the ToolWindows property should be serialized.
Public method | ShouldSerializeVersion | Determines if the Version property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeDocumentWindows Method

XmlDockSiteLayoutShouldSerializeDocumentWindows Method
Determines if the DocumentWindows property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeDocumentWindows()
Public Overridable Function ShouldSerializeDocumentWindows As Boolean

Return Value

Type: Boolean
true if the DocumentWindows property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeRaftingHosts Method

XmlDockSiteLayoutShouldSerializeRaftingHosts Method
Determines if the RaftingHosts property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeRaftingHosts()
Public Overridable Function ShouldSerializeRaftingHosts As Boolean

Return Value

Type: Boolean
true if the RaftingHosts property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeToolWindows Method

XmlDockSiteLayoutShouldSerializeToolWindows Method
Determines if the ToolWindows property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeToolWindows()
Public Overridable Function ShouldSerializeToolWindows As Boolean

Return Value

Type: Boolean
true if the ToolWindows property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDockSiteLayout.ShouldSerializeVersion Method

XmlDockSiteLayoutShouldSerializeVersion Method
Determines if the Version property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeVersion()
Public Overridable Function ShouldSerializeVersion As Boolean

Return Value

Type: Boolean
true if the Version property should be serialized; otherwise, false.
See Also

Reference

XmlDockSiteLayout Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindow Class

XmlDocumentWindow Class
Represents a serializable version of the DocumentWindow class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDocumentWindow

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlDocumentWindow : XmlDockingWindow
Public Class XmlDocumentWindow
    Inherits XmlDockingWindow

The XmlDocumentWindow type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDocumentWindow | Initializes a new instance of the XmlDocumentWindow class
Top
Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | FileName | Gets or sets the filename of the window.
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeFileName | Determines if the FileName property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindow Constructor

XmlDocumentWindow Constructor
Initializes a new instance of the XmlDocumentWindow class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDocumentWindow()
Public Sub New
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindow Properties

XmlDocumentWindow Properties

The XmlDocumentWindow type exposes the following members.

Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | FileName | Gets or sets the filename of the window.
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindow.FileName Property

XmlDocumentWindowFileName Property
Gets or sets the filename of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
The filename of the window.
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindow Methods

XmlDocumentWindow Methods

The XmlDocumentWindow type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeFileName | Determines if the FileName property should be serialized.
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindow.ShouldSerializeFileName Method

XmlDocumentWindowShouldSerializeFileName Method
Determines if the FileName property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeFileName()
Public Overridable Function ShouldSerializeFileName As Boolean

Return Value

Type: Boolean
true if the FileName property should be serialized; otherwise, false.
See Also

Reference

XmlDocumentWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Class

XmlDocumentWindowCollection Class
Represents a list of XmlDocumentWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlDocumentWindow
System.Collections.ObjectModelObservableCollection XmlDocumentWindow
ActiproSoftware.UI.XamlDeferrableObservableCollection XmlDocumentWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDocumentWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlDocumentWindowCollection : DeferrableObservableCollection<XmlDocumentWindow>
Public Class XmlDocumentWindowCollection
    Inherits DeferrableObservableCollection(Of XmlDocumentWindow)

The XmlDocumentWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDocumentWindowCollection | Initializes a new instance of the XmlDocumentWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlDocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlDocumentWindow .)
Protected property | Items | (Inherited from Collection XmlDocumentWindow .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlDocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Clear | (Inherited from Collection XmlDocumentWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Contains | (Inherited from Collection XmlDocumentWindow .)
Public method | CopyTo | (Inherited from Collection XmlDocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlDocumentWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlDocumentWindow .)
Public method | Insert | (Inherited from Collection XmlDocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlDocumentWindow .)
Public method | RemoveAt | (Inherited from Collection XmlDocumentWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlDocumentWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Constructor

XmlDocumentWindowCollection Constructor
Initializes a new instance of the XmlDocumentWindowCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDocumentWindowCollection()
Public Sub New
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Properties

XmlDocumentWindowCollection Properties

The XmlDocumentWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlDocumentWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlDocumentWindow .)
Protected property | Items | (Inherited from Collection XmlDocumentWindow .)
Top
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Methods

XmlDocumentWindowCollection Methods

The XmlDocumentWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlDocumentWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Clear | (Inherited from Collection XmlDocumentWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlDocumentWindow .)
Public method | Contains | (Inherited from Collection XmlDocumentWindow .)
Public method | CopyTo | (Inherited from Collection XmlDocumentWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlDocumentWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlDocumentWindow .)
Public method | Insert | (Inherited from Collection XmlDocumentWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlDocumentWindow .)
Public method | RemoveAt | (Inherited from Collection XmlDocumentWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowCollection Events

XmlDocumentWindowCollection Events

The XmlDocumentWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlDocumentWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlDocumentWindow .)
Top
See Also

Reference

XmlDocumentWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Class

XmlDocumentWindowRef Class
Represents a serializable version of the DocumentWindow class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDocumentWindowRef

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlDocumentWindowRef : XmlDockingWindowRef
Public Class XmlDocumentWindowRef
    Inherits XmlDockingWindowRef

The XmlDocumentWindowRef type exposes the following members.

Constructors
 | Name | Description
Public method | XmlDocumentWindowRef | Initializes a new instance of the XmlDocumentWindowRef class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Constructor

XmlDocumentWindowRef Constructor
Initializes a new instance of the XmlDocumentWindowRef class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDocumentWindowRef()
Public Sub New
See Also

Reference

XmlDocumentWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Properties

XmlDocumentWindowRef Properties

The XmlDocumentWindowRef type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

XmlDocumentWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlDocumentWindowRef Methods

XmlDocumentWindowRef Methods

The XmlDocumentWindowRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlDocumentWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Class

XmlRaftedDocumentWindowContainer Class
Represents a serializable version of the deprecated RaftedDocumentWindowContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlRaftedDocumentWindowContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlRaftedDocumentWindowContainer : XmlDockingWindowContainer
Public Class XmlRaftedDocumentWindowContainer
    Inherits XmlDockingWindowContainer

The XmlRaftedDocumentWindowContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRaftedDocumentWindowContainer | Initializes a new instance of the XmlRaftedDocumentWindowContainer class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Constructor

XmlRaftedDocumentWindowContainer Constructor
Initializes a new instance of the XmlRaftedDocumentWindowContainer class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlRaftedDocumentWindowContainer()
Public Sub New
See Also

Reference

XmlRaftedDocumentWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Properties

XmlRaftedDocumentWindowContainer Properties

The XmlRaftedDocumentWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlRaftedDocumentWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftedDocumentWindowContainer Methods

XmlRaftedDocumentWindowContainer Methods

The XmlRaftedDocumentWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlRaftedDocumentWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost Class

XmlRaftingHost Class
Represents a serializable version of a floating DockHost, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlRaftingHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlRaftingHost : XmlDockingObject
Public Class XmlRaftingHost
    Inherits XmlDockingObject

The XmlRaftingHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRaftingHost | Initializes a new instance of the XmlRaftingHost class
Top
Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the host.
Public property | Content | Gets or sets the content of the host.
Public property | IsMaximized | Gets or sets a value indicating whether the associated window is maximized.
Public property | Location | Gets or sets the location of the host.
Public property | LocationSerializable | Gets or sets the location of the host.
Public property | Size | Gets or sets the size of the host.
Public property | SizeSerializable | Gets or sets the size of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the control.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost Constructor

XmlRaftingHost Constructor
Initializes a new instance of the XmlRaftingHost class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlRaftingHost()
Public Sub New
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost Properties

XmlRaftingHost Properties

The XmlRaftingHost type exposes the following members.

Properties
 | Name | Description
Public property | AutoHideHost | Gets or sets the auto-hide host of the host.
Public property | Content | Gets or sets the content of the host.
Public property | IsMaximized | Gets or sets a value indicating whether the associated window is maximized.
Public property | Location | Gets or sets the location of the host.
Public property | LocationSerializable | Gets or sets the location of the host.
Public property | Size | Gets or sets the size of the host.
Public property | SizeSerializable | Gets or sets the size of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the control.
Top
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.AutoHideHost Property

XmlRaftingHostAutoHideHost Property
Gets or sets the auto-hide host of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlAutoHideHost AutoHideHost { get; set; }
Public Property AutoHideHost As XmlAutoHideHost
    Get
    Set

Property Value

Type: XmlAutoHideHost
The auto-hide host of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.Content Property

XmlRaftingHostContent Property
Gets or sets the content of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.IsMaximized Property

XmlRaftingHostIsMaximized Property
Gets or sets a value indicating whether the associated window is maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMaximized { get; set; }
Public Property IsMaximized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the associated window is maximized; otherwise, false.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.Location Property

XmlRaftingHostLocation Property
Gets or sets the location of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Point> Location { get; set; }
Public Property Location As Nullable(Of Point)
    Get
    Set

Property Value

Type: Nullable Point
The location of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.LocationSerializable Property

XmlRaftingHostLocationSerializable Property
Gets or sets the location of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LocationSerializable { get; set; }
Public Property LocationSerializable As String
    Get
    Set

Property Value

Type: String
The location of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.Size Property

XmlRaftingHostSize Property
Gets or sets the size of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Size { get; set; }
Public Property Size As Size
    Get
    Set

Property Value

Type: Size
The size of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.SizeSerializable Property

XmlRaftingHostSizeSerializable Property
Gets or sets the size of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string SizeSerializable { get; set; }
Public Property SizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the host.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.UniqueId Property

XmlRaftingHostUniqueId Property
Gets or sets the unique ID of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the control.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost Methods

XmlRaftingHost Methods

The XmlRaftingHost type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHost.ShouldSerializeUniqueId Method

XmlRaftingHostShouldSerializeUniqueId Method
Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlRaftingHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Class

XmlRaftingHostCollection Class
Represents a list of XmlRaftingHost objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlRaftingHost
System.Collections.ObjectModelObservableCollection XmlRaftingHost
ActiproSoftware.UI.XamlDeferrableObservableCollection XmlRaftingHost
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlRaftingHostCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlRaftingHostCollection : DeferrableObservableCollection<XmlRaftingHost>
Public Class XmlRaftingHostCollection
    Inherits DeferrableObservableCollection(Of XmlRaftingHost)

The XmlRaftingHostCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlRaftingHostCollection | Initializes a new instance of the XmlRaftingHostCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlRaftingHost .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlRaftingHost .)
Protected property | Items | (Inherited from Collection XmlRaftingHost .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlRaftingHost .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Clear | (Inherited from Collection XmlRaftingHost .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Contains | (Inherited from Collection XmlRaftingHost .)
Public method | CopyTo | (Inherited from Collection XmlRaftingHost .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlRaftingHost .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlRaftingHost .)
Public method | Insert | (Inherited from Collection XmlRaftingHost .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlRaftingHost .)
Public method | RemoveAt | (Inherited from Collection XmlRaftingHost .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlRaftingHost .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlRaftingHost .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Constructor

XmlRaftingHostCollection Constructor
Initializes a new instance of the XmlRaftingHostCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlRaftingHostCollection()
Public Sub New
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Properties

XmlRaftingHostCollection Properties

The XmlRaftingHostCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlRaftingHost .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlRaftingHost .)
Protected property | Items | (Inherited from Collection XmlRaftingHost .)
Top
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Methods

XmlRaftingHostCollection Methods

The XmlRaftingHostCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlRaftingHost .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Clear | (Inherited from Collection XmlRaftingHost .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlRaftingHost .)
Public method | Contains | (Inherited from Collection XmlRaftingHost .)
Public method | CopyTo | (Inherited from Collection XmlRaftingHost .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlRaftingHost .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlRaftingHost .)
Public method | Insert | (Inherited from Collection XmlRaftingHost .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlRaftingHost .)
Public method | RemoveAt | (Inherited from Collection XmlRaftingHost .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlRaftingHost .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlRaftingHostCollection Events

XmlRaftingHostCollection Events

The XmlRaftingHostCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlRaftingHost .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlRaftingHost .)
Top
See Also

Reference

XmlRaftingHostCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer Class

XmlSplitContainer Class
Represents a serializable version of the SplitContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlSplitContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlSplitContainer : XmlDockingObject
Public Class XmlSplitContainer
    Inherits XmlDockingObject

The XmlSplitContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSplitContainer | Initializes an instance of the XmlSplitContainer class.
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | Orientation | Gets or sets the orientation of the container.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer Constructor

XmlSplitContainer Constructor
Initializes an instance of the XmlSplitContainer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlSplitContainer()
Public Sub New
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer Properties

XmlSplitContainer Properties

The XmlSplitContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children.
Public property | DockedSize | Gets or sets the size of the control when in a Docked state.
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | Orientation | Gets or sets the orientation of the container.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer.Children Property

XmlSplitContainerChildren Property
Gets the collection of children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection Children { get; }
Public ReadOnly Property Children As XmlDockingObjectCollection
    Get

Property Value

Type: XmlDockingObjectCollection
The collection of children.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer.DockedSize Property

XmlSplitContainerDockedSize Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size DockedSize { get; set; }
Public Property DockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the control when in a Docked state.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer.DockedSizeSerializable Property

XmlSplitContainerDockedSizeSerializable Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DockedSizeSerializable { get; set; }
Public Property DockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer.Orientation Property

XmlSplitContainerOrientation Property
Gets or sets the orientation of the container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the container.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer Methods

XmlSplitContainer Methods

The XmlSplitContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlSplitContainer.ShouldSerializeDockedSizeSerializable Method

XmlSplitContainerShouldSerializeDockedSizeSerializable Method
Determines if the DockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeDockedSizeSerializable()
Public Overridable Function ShouldSerializeDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the DockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlSplitContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Class

XmlStandardMdiHost Class
Represents a serializable version of the StandardMdiHost class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlStandardMdiHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlStandardMdiHost : XmlObjectBase
Public Class XmlStandardMdiHost
    Inherits XmlObjectBase

The XmlStandardMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlStandardMdiHost | Initializes a new instance of the XmlStandardMdiHost class
Top
Properties
 | Name | Description
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Constructor

XmlStandardMdiHost Constructor
Initializes a new instance of the XmlStandardMdiHost class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlStandardMdiHost()
Public Sub New
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Properties

XmlStandardMdiHost Properties

The XmlStandardMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | AreWindowsMaximized | Gets or sets whether windows in the host are currently maximized.
Public property | Children | Gets the collection of children.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlStandardMdiHost.AreWindowsMaximized Property

XmlStandardMdiHostAreWindowsMaximized Property
Gets or sets whether windows in the host are currently maximized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreWindowsMaximized { get; set; }
Public Property AreWindowsMaximized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if windows in the host are currently maximized; otherwise, false.
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlStandardMdiHost.Children Property

XmlStandardMdiHostChildren Property
Gets the collection of children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlDockingObjectCollection Children { get; }
Public ReadOnly Property Children As XmlDockingObjectCollection
    Get

Property Value

Type: XmlDockingObjectCollection
The collection of children.
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlStandardMdiHost Methods

XmlStandardMdiHost Methods

The XmlStandardMdiHost type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlStandardMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Class

XmlTabbedMdiContainer Class
Represents a serializable version of the XmlTabbedMdiContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlTabbedMdiContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTabbedMdiContainer : XmlDockingWindowContainer
Public Class XmlTabbedMdiContainer
    Inherits XmlDockingWindowContainer

The XmlTabbedMdiContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTabbedMdiContainer | Initializes a new instance of the XmlTabbedMdiContainer class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Constructor

XmlTabbedMdiContainer Constructor
Initializes a new instance of the XmlTabbedMdiContainer class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTabbedMdiContainer()
Public Sub New
See Also

Reference

XmlTabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Properties

XmlTabbedMdiContainer Properties

The XmlTabbedMdiContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlTabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiContainer Methods

XmlTabbedMdiContainer Methods

The XmlTabbedMdiContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTabbedMdiContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Class

XmlTabbedMdiHost Class
Represents a serializable version of the TabbedMdiHost class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlTabbedMdiHost

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTabbedMdiHost : XmlObjectBase
Public Class XmlTabbedMdiHost
    Inherits XmlObjectBase

The XmlTabbedMdiHost type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTabbedMdiHost | Initializes a new instance of the XmlTabbedMdiHost class
Top
Properties
 | Name | Description
Public property | Content | Gets or sets the content of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Constructor

XmlTabbedMdiHost Constructor
Initializes a new instance of the XmlTabbedMdiHost class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTabbedMdiHost()
Public Sub New
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Properties

XmlTabbedMdiHost Properties

The XmlTabbedMdiHost type exposes the following members.

Properties
 | Name | Description
Public property | Content | Gets or sets the content of the host.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost.Content Property

XmlTabbedMdiHostContent Property
Gets or sets the content of the host.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the host.
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTabbedMdiHost Methods

XmlTabbedMdiHost Methods

The XmlTabbedMdiHost type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTabbedMdiHost Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow Class

XmlToolWindow Class
Represents a serializable version of the ToolWindow class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindow

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlToolWindow : XmlDockingWindow
Public Class XmlToolWindow
    Inherits XmlDockingWindow

The XmlToolWindow type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindow | Initializes an instance of the XmlToolWindow class.
Top
Properties
 | Name | Description
Public property | ContainerAutoHideSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerAutoHideSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerAutoHideSizeSerializable | Determines if the ContainerAutoHideSizeSerializable property should be serialized.
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow Constructor

XmlToolWindow Constructor
Initializes an instance of the XmlToolWindow class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindow()
Public Sub New
See Also

Reference

XmlToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow Properties

XmlToolWindow Properties

The XmlToolWindow type exposes the following members.

Properties
 | Name | Description
Public property | ContainerAutoHideSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerAutoHideSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindow.)
Public property | IsOpen | Gets or sets whether the window is open. (Inherited from XmlDockingWindow.)
Public property | LastActiveDateTime | Gets or sets the DateTime at which the window was last active, meaning the primary window that was focused. (Inherited from XmlDockingWindow.)
Public property | Name | Gets or sets the name of the window. (Inherited from XmlDockingWindow.)
Public property | SerializationId | Gets or sets the serialization ID of the window. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBounds | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiBoundsSerializable | Gets or sets the current bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBounds | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiRestoreBoundsSerializable | Gets or sets the restore bounds of the window in standard MDI. (Inherited from XmlDockingWindow.)
Public property | StandardMdiWindowState | Gets or sets the standard MDI state of the window. (Inherited from XmlDockingWindow.)
Public property | State | Gets or sets the current state of the window. (Inherited from XmlDockingWindow.)
Public property | TabbedMdiLayoutKind | Gets or sets the tab layout kind. (Inherited from XmlDockingWindow.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | Type | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | TypeSerializable | Gets or sets the type of the associated control. (Inherited from XmlDockingWindow.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindow.)
Top
See Also

Reference

XmlToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow.ContainerAutoHideSize Property

XmlToolWindowContainerAutoHideSize Property
Gets or sets the size of the docking window's container when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerAutoHideSize { get; set; }
Public Property ContainerAutoHideSize As Size
    Get
    Set

Property Value

Type: Size
The size of the docking window's container when in a Docked state.
See Also

Reference

XmlToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow.ContainerAutoHideSizeSerializable Property

XmlToolWindowContainerAutoHideSizeSerializable Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ContainerAutoHideSizeSerializable { get; set; }
Public Property ContainerAutoHideSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow Methods

XmlToolWindow Methods

The XmlToolWindow type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerAutoHideSizeSerializable | Determines if the ContainerAutoHideSizeSerializable property should be serialized.
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeLastActiveDateTime | Determines if the LastActiveDateTime property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeName | Determines if the Name property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeSerializationId | Determines if the SerializationId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiBoundsSerializable | Determines if the StandardMdiBoundsSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeStandardMdiWindowState | Determines if the StandardMdiWindowState property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTabbedMdiLayoutKind | Determines if the TabbedMdiLayoutKind property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeTypeSerializable | Determines if the TypeSerializable property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindow.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindow.ShouldSerializeContainerAutoHideSizeSerializable Method

XmlToolWindowShouldSerializeContainerAutoHideSizeSerializable Method
Determines if the ContainerAutoHideSizeSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeContainerAutoHideSizeSerializable()
Public Overridable Function ShouldSerializeContainerAutoHideSizeSerializable As Boolean

Return Value

Type: Boolean
true if the ContainerAutoHideSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlToolWindow Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Class

XmlToolWindowCollection Class
Represents a list of XmlToolWindow objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlToolWindow
System.Collections.ObjectModelObservableCollection XmlToolWindow
ActiproSoftware.UI.XamlDeferrableObservableCollection XmlToolWindow
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlToolWindowCollection : DeferrableObservableCollection<XmlToolWindow>
Public Class XmlToolWindowCollection
    Inherits DeferrableObservableCollection(Of XmlToolWindow)

The XmlToolWindowCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowCollection | Initializes a new instance of the XmlToolWindowCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlToolWindow .)
Protected property | Items | (Inherited from Collection XmlToolWindow .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlToolWindow .)
Public method | Clear | (Inherited from Collection XmlToolWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlToolWindow .)
Public method | Contains | (Inherited from Collection XmlToolWindow .)
Public method | CopyTo | (Inherited from Collection XmlToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlToolWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlToolWindow .)
Public method | Insert | (Inherited from Collection XmlToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlToolWindow .)
Public method | RemoveAt | (Inherited from Collection XmlToolWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlToolWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlToolWindow .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Constructor

XmlToolWindowCollection Constructor
Initializes a new instance of the XmlToolWindowCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindowCollection()
Public Sub New
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Properties

XmlToolWindowCollection Properties

The XmlToolWindowCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlToolWindow .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlToolWindow .)
Protected property | Items | (Inherited from Collection XmlToolWindow .)
Top
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Methods

XmlToolWindowCollection Methods

The XmlToolWindowCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlToolWindow .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlToolWindow .)
Public method | Clear | (Inherited from Collection XmlToolWindow .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlToolWindow .)
Public method | Contains | (Inherited from Collection XmlToolWindow .)
Public method | CopyTo | (Inherited from Collection XmlToolWindow .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlToolWindow .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlToolWindow .)
Public method | Insert | (Inherited from Collection XmlToolWindow .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlToolWindow .)
Public method | RemoveAt | (Inherited from Collection XmlToolWindow .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlToolWindow .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowCollection Events

XmlToolWindowCollection Events

The XmlToolWindowCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlToolWindow .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlToolWindow .)
Top
See Also

Reference

XmlToolWindowCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Class

XmlToolWindowContainer Class
Represents a serializable version of the ToolWindowContainer class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowContainer

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlToolWindowContainer : XmlDockingWindowContainer
Public Class XmlToolWindowContainer
    Inherits XmlDockingWindowContainer

The XmlToolWindowContainer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowContainer | Initializes a new instance of the XmlToolWindowContainer class
Top
Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Constructor

XmlToolWindowContainer Constructor
Initializes a new instance of the XmlToolWindowContainer class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindowContainer()
Public Sub New
See Also

Reference

XmlToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Properties

XmlToolWindowContainer Properties

The XmlToolWindowContainer type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets the collection of children. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSize | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | DockedSizeSerializable | Gets or sets the size of the control when in a Docked state. (Inherited from XmlDockingWindowContainer.)
Public property | SelectedWindowUniqueId | Gets or sets the unique ID of the selected window. (Inherited from XmlDockingWindowContainer.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainer Methods

XmlToolWindowContainer Methods

The XmlToolWindowContainer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeDockedSizeSerializable | Determines if the DockedSizeSerializable property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ShouldSerializeSelectedWindowUniqueId | Determines if the SelectedWindowUniqueId property should be serialized. (Inherited from XmlDockingWindowContainer.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlToolWindowContainer Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Class

XmlToolWindowContainerCollection Class
Represents a list of XmlToolWindowContainer objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection XmlToolWindowContainer
System.Collections.ObjectModelObservableCollection XmlToolWindowContainer
ActiproSoftware.UI.XamlDeferrableObservableCollection XmlToolWindowContainer
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowContainerCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlToolWindowContainerCollection : DeferrableObservableCollection<XmlToolWindowContainer>
Public Class XmlToolWindowContainerCollection
    Inherits DeferrableObservableCollection(Of XmlToolWindowContainer)

The XmlToolWindowContainerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowContainerCollection | Initializes a new instance of the XmlToolWindowContainerCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlToolWindowContainer .)
Protected property | Items | (Inherited from Collection XmlToolWindowContainer .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Clear | (Inherited from Collection XmlToolWindowContainer .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Contains | (Inherited from Collection XmlToolWindowContainer .)
Public method | CopyTo | (Inherited from Collection XmlToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlToolWindowContainer .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlToolWindowContainer .)
Public method | Insert | (Inherited from Collection XmlToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlToolWindowContainer .)
Public method | RemoveAt | (Inherited from Collection XmlToolWindowContainer .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlToolWindowContainer .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Constructor

XmlToolWindowContainerCollection Constructor
Initializes a new instance of the XmlToolWindowContainerCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindowContainerCollection()
Public Sub New
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Properties

XmlToolWindowContainerCollection Properties

The XmlToolWindowContainerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection XmlToolWindowContainer .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection XmlToolWindowContainer .)
Protected property | Items | (Inherited from Collection XmlToolWindowContainer .)
Top
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Methods

XmlToolWindowContainerCollection Methods

The XmlToolWindowContainerCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection XmlToolWindowContainer .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Clear | (Inherited from Collection XmlToolWindowContainer .)
Protected method | ClearItems | (Inherited from ObservableCollection XmlToolWindowContainer .)
Public method | Contains | (Inherited from Collection XmlToolWindowContainer .)
Public method | CopyTo | (Inherited from Collection XmlToolWindowContainer .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection XmlToolWindowContainer .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection XmlToolWindowContainer .)
Public method | Insert | (Inherited from Collection XmlToolWindowContainer .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from DeferrableObservableCollectionT.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | MoveItem | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection XmlToolWindowContainer .)
Public method | RemoveAt | (Inherited from Collection XmlToolWindowContainer .)
Protected method | RemoveItem | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from DeferrableObservableCollectionT.)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowContainerCollection Events

XmlToolWindowContainerCollection Events

The XmlToolWindowContainerCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection XmlToolWindowContainer .)
Protected event | PropertyChanged | (Inherited from ObservableCollection XmlToolWindowContainer .)
Top
See Also

Reference

XmlToolWindowContainerCollection Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowRef Class

XmlToolWindowRef Class
Represents a serializable version of the ToolWindow class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingWindowRef
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlToolWindowRef

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlToolWindowRef : XmlDockingWindowRef
Public Class XmlToolWindowRef
    Inherits XmlDockingWindowRef

The XmlToolWindowRef type exposes the following members.

Constructors
 | Name | Description
Public method | XmlToolWindowRef | Initializes a new instance of the XmlToolWindowRef class
Top
Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowRef Constructor

XmlToolWindowRef Constructor
Initializes a new instance of the XmlToolWindowRef class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlToolWindowRef()
Public Sub New
See Also

Reference

XmlToolWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowRef Properties

XmlToolWindowRef Properties

The XmlToolWindowRef type exposes the following members.

Properties
 | Name | Description
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window. (Inherited from XmlDockingWindowRef.)
Top
See Also

Reference

XmlToolWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlToolWindowRef Methods

XmlToolWindowRef Methods

The XmlToolWindowRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized. (Inherited from XmlDockingWindowRef.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlToolWindowRef Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack Class

XmlTrack Class
Represents a serializable version of the Track class reference, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlTrack

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlTrack : XmlDockingObject
Public Class XmlTrack
    Inherits XmlDockingObject

The XmlTrack type exposes the following members.

Constructors
 | Name | Description
Public method | XmlTrack | Initializes an instance of the XmlTrack class.
Top
Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack Constructor

XmlTrack Constructor
Initializes an instance of the XmlTrack class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlTrack()
Public Sub New
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack Properties

XmlTrack Properties

The XmlTrack type exposes the following members.

Properties
 | Name | Description
Public property | ContainerDockedSize | Gets or sets the size of the docking window's container when in a Docked state.
Public property | ContainerDockedSizeSerializable | Gets or sets the size of the control when in a Docked state.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Public property | UniqueId | Gets or sets the unique ID of the window.
Top
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack.ContainerDockedSize Property

XmlTrackContainerDockedSize Property
Gets or sets the size of the docking window's container when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size ContainerDockedSize { get; set; }
Public Property ContainerDockedSize As Size
    Get
    Set

Property Value

Type: Size
The size of the docking window's container when in a Docked state.
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack.ContainerDockedSizeSerializable Property

XmlTrackContainerDockedSizeSerializable Property
Gets or sets the size of the control when in a Docked state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ContainerDockedSizeSerializable { get; set; }
Public Property ContainerDockedSizeSerializable As String
    Get
    Set

Property Value

Type: String
The size of the control when in a Docked state.
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack.UniqueId Property

XmlTrackUniqueId Property
Gets or sets the unique ID of the window.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set

Property Value

Type: Guid
The unique ID of the window.
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack Methods

XmlTrack Methods

The XmlTrack type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ShouldSerializeContainerDockedSizeSerializable | Determines if the ContainerDockedSizeSerializable property should be serialized.
Public method | ShouldSerializeUniqueId | Determines if the UniqueId property should be serialized.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack.ShouldSerializeContainerDockedSizeSerializable Method

XmlTrackShouldSerializeContainerDockedSizeSerializable Method
Determines if the ContainerDockedSizeSerializable property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeContainerDockedSizeSerializable()
Public Overridable Function ShouldSerializeContainerDockedSizeSerializable As Boolean

Return Value

Type: Boolean
true if the ContainerDockedSizeSerializable property should be serialized; otherwise, false.
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlTrack.ShouldSerializeUniqueId Method

XmlTrackShouldSerializeUniqueId Method
Determines if the UniqueId property should be serialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldSerializeUniqueId()
Public Overridable Function ShouldSerializeUniqueId As Boolean

Return Value

Type: Boolean
true if the UniqueId property should be serialized; otherwise, false.
See Also

Reference

XmlTrack Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlWorkspace Class

XmlWorkspace Class
Represents a serializable version of the Workspace class, used for saving to XML layout.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.SerializationXmlObjectBase
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlDockingObject
ActiproSoftware.UI.Xaml.Controls.Docking.SerializationXmlWorkspace

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class XmlWorkspace : XmlDockingObject
Public Class XmlWorkspace
    Inherits XmlDockingObject

The XmlWorkspace type exposes the following members.

Constructors
 | Name | Description
Public method | XmlWorkspace | Initializes a new instance of the XmlWorkspace class
Top
Properties
 | Name | Description
Public property | Content | Gets or sets the content of the workspace.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlWorkspace Constructor

XmlWorkspace Constructor
Initializes a new instance of the XmlWorkspace class

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlWorkspace()
Public Sub New
See Also

Reference

XmlWorkspace Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlWorkspace Properties

XmlWorkspace Properties

The XmlWorkspace type exposes the following members.

Properties
 | Name | Description
Public property | Content | Gets or sets the content of the workspace.
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from XmlObjectBase.)
Top
See Also

Reference

XmlWorkspace Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlWorkspace.Content Property

XmlWorkspaceContent Property
Gets or sets the content of the workspace.

Namespace: ActiproSoftware.UI.Xaml.Controls.Docking.Serialization
Assembly: AS.Docking.Universal (in AS.Docking.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public XmlObjectBase Content { get; set; }
Public Property Content As XmlObjectBase
    Get
    Set

Property Value

Type: XmlObjectBase
The content of the workspace.
See Also

Reference

XmlWorkspace Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


XmlWorkspace Methods

XmlWorkspace Methods

The XmlWorkspace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

XmlWorkspace Class
ActiproSoftware.UI.Xaml.Controls.Docking.Serialization Namespace


ActiproSoftware.UI.Xaml.Controls.Editors Namespace

ActiproSoftware.UI.Xaml.Controls.Editors Namespace
Contains classes that support implementing editor controls.
Classes
 | Class | Description
Public class | BrushEditBox | Represents a Brush edit box.
Public class | BrushKind | Specifies the kind of brush.
Public class | BrushPicker | Represents a Brush picker.
Public class | Calculator | Represents a calculator control.
Public class | CalculatorOperationKind | Specifies an operation used with a calculator.
Public class | ColorEditBox | Represents a Color edit box.
Public class | ColorPicker | Represents a color picker control.
Public class | CornerRadiusEditBox | Represents a CornerRadius edit box.
Public class | CornerRadiusPicker | Represents a CornerRadius picker.
Public class | Country | Specifies the various countries and associated data.
Public class | CountryComboBox | A drop-down list for country selection, populated with Country objects.
Public class | CountryCurrencyMapping | A mapping between a Country and a Currency.
Public class | Currency | Specifies a country's currency.
Public class | CurrencyComboBox | A drop-down list for currency selection, populated with Currency objects.
Public class | DateEditBox | Represents a date-only edit box.
Public class | DatePicker | Represents a date picker.
Public class | DateTimeEditBox | Represents a date/time edit box.
Public class | DateTimePicker | Represents a date/time picker.
Public class | DaysOfWeek | Specifies the various days of the week as enumeration flags.
Public class | DoubleEditBox | Represents a Double edit box.
Public class | DoubleEditBoxPickerKind | Specifies the kind of Style to apply to the DoublePicker used within a DoubleEditBox's popup.
Public class | DoublePicker | Represents a Double picker.
Public class | EnumEditBox | Represents an Enum edit box.
Public class | EnumListBox | Represents a list box that automatically presents the values of an enumeration.
Public class | EnumListBoxItem | Represents a selectable item in a EnumListBox.
Public class | EnumPicker | Represents an Enum picker.
Public class | GradientStopSlider | A slider for manipulating gradient stops.
Public class | GuidEditBox | Represents an Guid edit box.
Public class | HsbColorPicker | Represents a color picker control that allows for visual selection of hue, saturation, and brightness.
Public class | Int16EditBox | Represents an Int16 edit box.
Public class | Int16EditBoxPickerKind | Specifies the kind of Style to apply to the Int16Picker used within a Int16EditBox's popup.
Public class | Int16Picker | Represents an Int16 picker.
Public class | Int32EditBox | Represents an Int32 edit box.
Public class | Int32EditBoxPickerKind | Specifies the kind of Style to apply to the Int32Picker used within a Int32EditBox's popup.
Public class | Int32Picker | Represents an Int32 picker.
Public class | Int64EditBox | Represents an Int64 edit box.
Public class | Int64EditBoxPickerKind | Specifies the kind of Style to apply to the Int64Picker used within a Int64EditBox's popup.
Public class | Int64Picker | Represents an Int64 picker.
Public class | MaskedTextBox | Represents a TextBox that restricts input based on a specified mask.
Public class | MaskKind | Specifies the mask kinds supported by a MaskedTextBox.
Public class | MaskPromptVisibility | Specifies the visibility of mask prompts within a MaskedTextBox.
Public class | MonthCalendar | Represents a month calendar control.
Public class | MonthCalendarItem | Represents a month calendar item.
Public class | MonthCalendarSelectionMode | Specifies the various selection modes of a MonthCalendar.
Public class | MonthCalendarViewMode | Specifies the various views of a MonthCalendar.
Public class | MonthCalendarViewResetMode | Specifies the view reset mode of a MonthCalendar when it loses focus.
Public class | PartEditBoxCommitTriggers | Specifies the triggers that force a PartEditBoxBase-derived control to immediately commit any changes.
Public class | PointEditBox | Represents a Point edit box.
Public class | PointPicker | Represents a Point picker.
Public class | RadialHuePicker | Represents a radial color hue picker control.
Public class | Rating | Represents a rating control that allows the user to set or view a rating of an entity.
Public class | RatingItem | Represents a single item in a Rating control.
Public class | RatingItemState | Specifies the various states supported by RatingItem.
Public class | RectEditBox | Represents a Rect edit box.
Public class | RectPicker | Represents a Rect picker.
Public class | SaturationBrightnessPicker | Represents a saturation/brightness picker control.
Public class | SingleEditBox | Represents a Single edit box.
Public class | SingleEditBoxPickerKind | Specifies the kind of Style to apply to the SinglePicker used within a SingleEditBox's popup.
Public class | SinglePicker | Represents a Single picker.
Public class | SizeEditBox | Represents a Size edit box.
Public class | SizePicker | Represents a Size picker.
Public class | SpinWrapping | Specifies the various wrapping behaviors supported when spinning a value in a part edit box.
Public class | ThicknessEditBox | Represents a Thickness edit box.
Public class | ThicknessPicker | Represents a Thickness picker.
Public class | TimeEditBox | Represents a time-only edit box.
Public class | TimePicker | Represents a time picker.
Public class | TimeSpanEditBox | Represents a timespan edit box.
Public class | TimeSpanPicker | Represents a TimeSpan picker.


BrushEditBox Class

BrushEditBox Class
Represents a Brush edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Brush
ActiproSoftware.UI.Xaml.Controls.EditorsBrushEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BrushEditBox : PartEditBoxBase<Brush>
Public Class BrushEditBox
    Inherits PartEditBoxBase(Of Brush)

The BrushEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | BrushEditBox | Initializes an instance of the BrushEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox Constructor

BrushEditBox Constructor
Initializes an instance of the BrushEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BrushEditBox()
Public Sub New
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox Properties

BrushEditBox Properties

The BrushEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.HasPopupButtonWhenReadOnly Property

BrushEditBoxHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.HasSwatch Property

BrushEditBoxHasSwatch Property
Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.IsAlphaEnabled Property

BrushEditBoxIsAlphaEnabled Property
Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the brush value colors is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.IsGradientAllowed Property

BrushEditBoxIsGradientAllowed Property
Gets or sets whether gradient brush values can be entered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if gradient brush values can be entered; otherwise, false. The default value is true.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.SwatchBrush Property

BrushEditBoxSwatchBrush Property
Gets the Brush that renders a sample swatch.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SwatchBrush { get; }
Public ReadOnly Property SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush that renders a sample swatch.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.SwatchMargin Property

BrushEditBoxSwatchMargin Property
Gets or sets the Thickness of the margin around the sample swatch.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness SwatchMargin { get; set; }
Public Property SwatchMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the margin around the sample swatch.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox Methods

BrushEditBox Methods

The BrushEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.ConvertToString Method

BrushEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Brush valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Brush
) As String

Parameters

valueToConvert
Type: Windows.UI.Xaml.MediaBrush
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.CreateIncrementalChangeRequest Method

BrushEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Brush> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Brush)

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Brush
The incremental change (spin) request that was created.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.GenerateParts Method

BrushEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.IsValidValue Method

BrushEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Brush value
)
Protected Overrides Function IsValidValue (
    value As Brush
) As Boolean

Parameters

value
Type: Windows.UI.Xaml.MediaBrush
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.OnApplyTemplate Method

BrushEditBoxOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.OnIntermediateValueChanged Method

BrushEditBoxOnIntermediateValueChanged Method
Invoked when the value of the IntermediateValue property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnIntermediateValueChanged(
    Brush oldValue,
    Brush newValue
)
Protected Overrides Sub OnIntermediateValueChanged (
    oldValue As Brush,
    newValue As Brush
)

Parameters

oldValue
Type: Windows.UI.Xaml.MediaBrush
The old value of the property.
newValue
Type: Windows.UI.Xaml.MediaBrush
The new value of the property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.RaiseValueChangedEvent Method

BrushEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.ResetValue Method

BrushEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.TryConvertFromString Method

BrushEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Brush value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Brush
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: Windows.UI.Xaml.MediaBrush
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox Events

BrushEditBox Events

The BrushEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.ValueChanged Event

BrushEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox Fields

BrushEditBox Fields

The BrushEditBox type exposes the following members.

Fields
Name | Description
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.HasSwatchProperty Field

BrushEditBoxHasSwatchProperty Field
Identifies the HasSwatch dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSwatchProperty
Public Shared ReadOnly HasSwatchProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSwatch dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.IsAlphaEnabledProperty Field

BrushEditBoxIsAlphaEnabledProperty Field
Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.IsGradientAllowedProperty Field

BrushEditBoxIsGradientAllowedProperty Field
Identifies the IsGradientAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientAllowedProperty
Public Shared ReadOnly IsGradientAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradientAllowed dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.SwatchBrushProperty Field

BrushEditBoxSwatchBrushProperty Field
Identifies the SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchBrushProperty
Public Shared ReadOnly SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchBrush dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushEditBox.SwatchMarginProperty Field

BrushEditBoxSwatchMarginProperty Field
Identifies the SwatchMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchMarginProperty
Public Shared ReadOnly SwatchMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchMargin dependency property.
See Also

Reference

BrushEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind Class

BrushKind Class
Specifies the kind of brush.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsBrushKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class BrushKind : Enum
Public NotInheritable Class BrushKind
    Inherits Enum

The BrushKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | DiagonalDownwardLinearGradient | Indicates that the brush is a diagonal downward linear gradient.
 | DiagonalUpwardLinearGradient | Indicates that the brush is a diagonal upward linear gradient.
 | HorizontalLinearGradient | Indicates that the brush is a horizontal linear gradient.
 | None | Indicates that there is no brush.
 | SolidColor | Indicates that the brush is a solid color.
Public field | value__ |
 | VerticalLinearGradient | Indicates that the brush is a vertical linear gradient.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind Methods

BrushKind Methods

The BrushKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind Fields

BrushKind Fields

The BrushKind type exposes the following members.

Fields
 | Name | Description
 | DiagonalDownwardLinearGradient | Indicates that the brush is a diagonal downward linear gradient.
 | DiagonalUpwardLinearGradient | Indicates that the brush is a diagonal upward linear gradient.
 | HorizontalLinearGradient | Indicates that the brush is a horizontal linear gradient.
 | None | Indicates that there is no brush.
 | SolidColor | Indicates that the brush is a solid color.
Public field | value__ |
 | VerticalLinearGradient | Indicates that the brush is a vertical linear gradient.
Top
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.DiagonalDownwardLinearGradient Field

BrushKindDiagonalDownwardLinearGradient Field
Indicates that the brush is a diagonal downward linear gradient.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const BrushKind DiagonalDownwardLinearGradient = 4
Public Const DiagonalDownwardLinearGradient As BrushKind = 4

Field Value

Type: BrushKind
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.DiagonalUpwardLinearGradient Field

BrushKindDiagonalUpwardLinearGradient Field
Indicates that the brush is a diagonal upward linear gradient.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const BrushKind DiagonalUpwardLinearGradient = 5
Public Const DiagonalUpwardLinearGradient As BrushKind = 5

Field Value

Type: BrushKind
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.HorizontalLinearGradient Field

BrushKindHorizontalLinearGradient Field
Indicates that the brush is a horizontal linear gradient.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const BrushKind HorizontalLinearGradient = 2
Public Const HorizontalLinearGradient As BrushKind = 2

Field Value

Type: BrushKind
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.None Field

BrushKindNone Field
Indicates that there is no brush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const BrushKind None = 0
Public Const None As BrushKind = 0

Field Value

Type: BrushKind
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.SolidColor Field

BrushKindSolidColor Field
Indicates that the brush is a solid color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const BrushKind SolidColor = 1
Public Const SolidColor As BrushKind = 1

Field Value

Type: BrushKind
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.value__ Field

BrushKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.BrushKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushKind.VerticalLinearGradient Field

BrushKindVerticalLinearGradient Field
Indicates that the brush is a vertical linear gradient.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const BrushKind VerticalLinearGradient = 3
Public Const VerticalLinearGradient As BrushKind = 3

Field Value

Type: BrushKind
See Also

Reference

BrushKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker Class

BrushPicker Class
Represents a Brush picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsBrushPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BrushPicker : PickerBase
Public Class BrushPicker
    Inherits PickerBase

The BrushPicker type exposes the following members.

Constructors
 | Name | Description
Public method | BrushPicker | Initializes an instance of the BrushPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AddGradientStopButtonToolTip | Gets or sets the tooltip for the add gradient stop button.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrushKind | Gets a BrushKind indicating the kind of brush that is being edited.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGradient | Gets whether the brush being edited is a GradientBrush.
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNull | Gets whether the brush being edited is a null value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RemoveGradientStopButtonToolTip | Gets or sets the tooltip for the remove gradient stop button.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ReverseGradientStopsButtonToolTip | Gets or sets the tooltip for the reverse gradient stops button.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AddGradientStopButtonToolTipProperty | Identifies the AddGradientStopButtonToolTip dependency property. This field is read-only.
BrushKindProperty | Identifies the BrushKind dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
IsGradientProperty | Identifies the IsGradient dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsNullProperty | Identifies the IsNull dependency property. This field is read-only.
RemoveGradientStopButtonToolTipProperty | Identifies the RemoveGradientStopButtonToolTip dependency property. This field is read-only.
ReverseGradientStopsButtonToolTipProperty | Identifies the ReverseGradientStopsButtonToolTip dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker Constructor

BrushPicker Constructor
Initializes an instance of the BrushPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BrushPicker()
Public Sub New
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker Properties

BrushPicker Properties

The BrushPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AddGradientStopButtonToolTip | Gets or sets the tooltip for the add gradient stop button.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrushKind | Gets a BrushKind indicating the kind of brush that is being edited.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGradient | Gets whether the brush being edited is a GradientBrush.
Public property | IsGradientAllowed | Gets or sets whether gradient brush values can be entered.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNull | Gets whether the brush being edited is a null value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RemoveGradientStopButtonToolTip | Gets or sets the tooltip for the remove gradient stop button.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ReverseGradientStopsButtonToolTip | Gets or sets the tooltip for the reverse gradient stops button.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.AddGradientStopButtonToolTip Property

BrushPickerAddGradientStopButtonToolTip Property
Gets or sets the tooltip for the add gradient stop button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object AddGradientStopButtonToolTip { get; set; }
Public Property AddGradientStopButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the add gradient stop button.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.BrushKind Property

BrushPickerBrushKind Property
Gets a BrushKind indicating the kind of brush that is being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BrushKind BrushKind { get; }
Public ReadOnly Property BrushKind As BrushKind
    Get

Property Value

Type: BrushKind
A BrushKind indicating the kind of brush that is being edited.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsAlphaEnabled Property

BrushPickerIsAlphaEnabled Property
Gets or sets whether the alpha channel (transparency) of the brush value colors are enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the brush value colors is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsGradient Property

BrushPickerIsGradient Property
Gets whether the brush being edited is a GradientBrush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGradient { get; }
Public ReadOnly Property IsGradient As Boolean
    Get

Property Value

Type: Boolean
true if the brush being edited is a GradientBrush; otherwise, false.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsGradientAllowed Property

BrushPickerIsGradientAllowed Property
Gets or sets whether gradient brush values can be entered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if gradient brush values can be entered; otherwise, false. The default value is true.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsNull Property

BrushPickerIsNull Property
Gets whether the brush being edited is a null value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get

Property Value

Type: Boolean
true if the brush being edited is a null value; otherwise, false.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsNullAllowed Property

BrushPickerIsNullAllowed Property
Gets or sets a value indicating whether null values are allowed to be entered by the user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if null values are allowed to be entered by the user; otherwise false. The default value is true.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.RemoveGradientStopButtonToolTip Property

BrushPickerRemoveGradientStopButtonToolTip Property
Gets or sets the tooltip for the remove gradient stop button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object RemoveGradientStopButtonToolTip { get; set; }
Public Property RemoveGradientStopButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the remove gradient stop button.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.ReverseGradientStopsButtonToolTip Property

BrushPickerReverseGradientStopsButtonToolTip Property
Gets or sets the tooltip for the reverse gradient stops button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ReverseGradientStopsButtonToolTip { get; set; }
Public Property ReverseGradientStopsButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the reverse gradient stops button.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.SelectedColor Property

BrushPickerSelectedColor Property
Gets or sets the currently selected Color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The currently selected Color.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.Value Property

BrushPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush Value { get; set; }
Public Property Value As Brush
    Get
    Set

Property Value

Type: Brush
The value of the control.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker Methods

BrushPicker Methods

The BrushPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.OnApplyTemplate Method

BrushPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker Events

BrushPicker Events

The BrushPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.ValueChanged Event

BrushPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker Fields

BrushPicker Fields

The BrushPicker type exposes the following members.

Fields
Name | Description
AddGradientStopButtonToolTipProperty | Identifies the AddGradientStopButtonToolTip dependency property. This field is read-only.
BrushKindProperty | Identifies the BrushKind dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsGradientAllowedProperty | Identifies the IsGradientAllowed dependency property. This field is read-only.
IsGradientProperty | Identifies the IsGradient dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsNullProperty | Identifies the IsNull dependency property. This field is read-only.
RemoveGradientStopButtonToolTipProperty | Identifies the RemoveGradientStopButtonToolTip dependency property. This field is read-only.
ReverseGradientStopsButtonToolTipProperty | Identifies the ReverseGradientStopsButtonToolTip dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.AddGradientStopButtonToolTipProperty Field

BrushPickerAddGradientStopButtonToolTipProperty Field
Identifies the AddGradientStopButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AddGradientStopButtonToolTipProperty
Public Shared ReadOnly AddGradientStopButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AddGradientStopButtonToolTip dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.BrushKindProperty Field

BrushPickerBrushKindProperty Field
Identifies the BrushKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrushKindProperty
Public Shared ReadOnly BrushKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BrushKind dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsAlphaEnabledProperty Field

BrushPickerIsAlphaEnabledProperty Field
Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsGradientAllowedProperty Field

BrushPickerIsGradientAllowedProperty Field
Identifies the IsGradientAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientAllowedProperty
Public Shared ReadOnly IsGradientAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradientAllowed dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsGradientProperty Field

BrushPickerIsGradientProperty Field
Identifies the IsGradient dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGradientProperty
Public Shared ReadOnly IsGradientProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGradient dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsNullAllowedProperty Field

BrushPickerIsNullAllowedProperty Field
Identifies the IsNullAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullAllowedProperty
Public Shared ReadOnly IsNullAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNullAllowed dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.IsNullProperty Field

BrushPickerIsNullProperty Field
Identifies the IsNull dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullProperty
Public Shared ReadOnly IsNullProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNull dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.RemoveGradientStopButtonToolTipProperty Field

BrushPickerRemoveGradientStopButtonToolTipProperty Field
Identifies the RemoveGradientStopButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RemoveGradientStopButtonToolTipProperty
Public Shared ReadOnly RemoveGradientStopButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RemoveGradientStopButtonToolTip dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.ReverseGradientStopsButtonToolTipProperty Field

BrushPickerReverseGradientStopsButtonToolTipProperty Field
Identifies the ReverseGradientStopsButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ReverseGradientStopsButtonToolTipProperty
Public Shared ReadOnly ReverseGradientStopsButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ReverseGradientStopsButtonToolTip dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.SelectedColorProperty Field

BrushPickerSelectedColorProperty Field
Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


BrushPicker.ValueProperty Field

BrushPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

BrushPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator Class

Calculator Class
Represents a calculator control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.EditorsCalculator

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Calculator : Control
Public Class Calculator
    Inherits Control

The Calculator type exposes the following members.

Constructors
 | Name | Description
Public method | Calculator | Initializes an instance of the Calculator class.
Top
Properties
 | Name | Description
Public property | AcceptsEscape | Gets or sets whether to accept the Escape key for clearing the calculator's current entry and value.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AddToMemoryCommand | Gets the ICommand that can add to memory.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BackspaceCommand | Gets the ICommand that can backspace a digit.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculateCommand | Gets the ICommand that can calculate the result.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClearCommand | Gets the ICommand that can clear the current entry and value.
Public property | ClearEntryCommand | Gets the ICommand that can clear the current entry.
Public property | ClearMemoryCommand | Gets the ICommand that can clear memory.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DigitButtonStyle | Gets or sets the Style to use for digit buttons.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayFontSize | Gets or sets the display font size.
Public property | DisplayText | Gets the text that represents the calculator output.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasDisplay | Gets or sets whether the calculator output is displayed.
Public property | HasMemoryButtons | Gets or sets whether the memory buttons are displayed.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InsertDecimalSeparatorCommand | Gets the ICommand that can insert a decimal separator.
Public property | InsertDigitCommand | Gets the ICommand that can insert a digit.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOutOfRange | Gets whether the calculated value is outside the Minimum and Maximum range.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MemoryButtonStyle | Gets or sets the Style to use for memory buttons.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OperationButtonStyle | Gets or sets the Style to use for operation buttons.
Public property | OperationCommand | Gets the ICommand that can execute an operation.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RecallMemoryCommand | Gets the ICommand that can recall memory.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetMemoryCommand | Gets the ICommand that can set memory.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SubtractFromMemoryCommand | Gets the ICommand that can subtract from memory.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the current calculated value.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AcceptsEscapeProperty | Identifies the AcceptsEscape dependency property. This field is read-only.
DigitButtonStyleProperty | Identifies the DigitButtonStyle dependency property. This field is read-only.
DisplayFontSizeProperty | Identifies the DisplayFontSize dependency property. This field is read-only.
DisplayTextProperty | Identifies the DisplayText dependency property. This field is read-only.
HasDisplayProperty | Identifies the HasDisplay dependency property. This field is read-only.
HasMemoryButtonsProperty | Identifies the HasMemoryButtons dependency property. This field is read-only.
IsOutOfRangeProperty | Identifies the IsOutOfRange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MemoryButtonStyleProperty | Identifies the MemoryButtonStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OperationButtonStyleProperty | Identifies the OperationButtonStyle dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator Constructor

Calculator Constructor
Initializes an instance of the Calculator class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Calculator()
Public Sub New
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator Properties

Calculator Properties

The Calculator type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsEscape | Gets or sets whether to accept the Escape key for clearing the calculator's current entry and value.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AddToMemoryCommand | Gets the ICommand that can add to memory.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BackspaceCommand | Gets the ICommand that can backspace a digit.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculateCommand | Gets the ICommand that can calculate the result.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClearCommand | Gets the ICommand that can clear the current entry and value.
Public property | ClearEntryCommand | Gets the ICommand that can clear the current entry.
Public property | ClearMemoryCommand | Gets the ICommand that can clear memory.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DigitButtonStyle | Gets or sets the Style to use for digit buttons.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayFontSize | Gets or sets the display font size.
Public property | DisplayText | Gets the text that represents the calculator output.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasDisplay | Gets or sets whether the calculator output is displayed.
Public property | HasMemoryButtons | Gets or sets whether the memory buttons are displayed.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InsertDecimalSeparatorCommand | Gets the ICommand that can insert a decimal separator.
Public property | InsertDigitCommand | Gets the ICommand that can insert a digit.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsOutOfRange | Gets whether the calculated value is outside the Minimum and Maximum range.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MemoryButtonStyle | Gets or sets the Style to use for memory buttons.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OperationButtonStyle | Gets or sets the Style to use for operation buttons.
Public property | OperationCommand | Gets the ICommand that can execute an operation.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RecallMemoryCommand | Gets the ICommand that can recall memory.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetMemoryCommand | Gets the ICommand that can set memory.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SubtractFromMemoryCommand | Gets the ICommand that can subtract from memory.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the current calculated value.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.AcceptsEscape Property

CalculatorAcceptsEscape Property
Gets or sets whether to accept the Escape key for clearing the calculator's current entry and value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AcceptsEscape { get; set; }
Public Property AcceptsEscape As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Escape key should be accepted; otherwise, false. The default value is true.
Remarks
The Shift+Del key can also be used to clear the calculator's current entry and value.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.AddToMemoryCommand Property

CalculatorAddToMemoryCommand Property
Gets the ICommand that can add to memory.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand AddToMemoryCommand { get; }
Public ReadOnly Property AddToMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can add to memory.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.BackspaceCommand Property

CalculatorBackspaceCommand Property
Gets the ICommand that can backspace a digit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand BackspaceCommand { get; }
Public ReadOnly Property BackspaceCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can backspace a digit.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.CalculateCommand Property

CalculatorCalculateCommand Property
Gets the ICommand that can calculate the result.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand CalculateCommand { get; }
Public ReadOnly Property CalculateCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can calculate the result.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.ClearCommand Property

CalculatorClearCommand Property
Gets the ICommand that can clear the current entry and value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClearCommand { get; }
Public ReadOnly Property ClearCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear the current entry and value.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.ClearEntryCommand Property

CalculatorClearEntryCommand Property
Gets the ICommand that can clear the current entry.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClearEntryCommand { get; }
Public ReadOnly Property ClearEntryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear the current entry.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.ClearMemoryCommand Property

CalculatorClearMemoryCommand Property
Gets the ICommand that can clear memory.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClearMemoryCommand { get; }
Public ReadOnly Property ClearMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear memory.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.DigitButtonStyle Property

CalculatorDigitButtonStyle Property
Gets or sets the Style to use for digit buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style DigitButtonStyle { get; set; }
Public Property DigitButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for digit buttons.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.DisplayFontSize Property

CalculatorDisplayFontSize Property
Gets or sets the display font size.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double DisplayFontSize { get; set; }
Public Property DisplayFontSize As Double
    Get
    Set

Property Value

Type: Double
The display font size.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.DisplayText Property

CalculatorDisplayText Property
Gets the text that represents the calculator output.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DisplayText { get; }
Public ReadOnly Property DisplayText As String
    Get

Property Value

Type: String
The text that represents the calculator output. The default value is "0".
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.HasDisplay Property

CalculatorHasDisplay Property
Gets or sets whether the calculator output is displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasDisplay { get; set; }
Public Property HasDisplay As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the calculator output is displayed; otherwise, false. The default value is true.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.HasMemoryButtons Property

CalculatorHasMemoryButtons Property
Gets or sets whether the memory buttons are displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMemoryButtons { get; set; }
Public Property HasMemoryButtons As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the memory buttons are displayed; otherwise, false. The default value is true.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.InsertDecimalSeparatorCommand Property

CalculatorInsertDecimalSeparatorCommand Property
Gets the ICommand that can insert a decimal separator.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand InsertDecimalSeparatorCommand { get; }
Public ReadOnly Property InsertDecimalSeparatorCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can insert a decimal separator.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.InsertDigitCommand Property

CalculatorInsertDigitCommand Property
Gets the ICommand that can insert a digit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand InsertDigitCommand { get; }
Public ReadOnly Property InsertDigitCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can insert a digit.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.IsOutOfRange Property

CalculatorIsOutOfRange Property
Gets whether the calculated value is outside the Minimum and Maximum range.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOutOfRange { get; }
Public ReadOnly Property IsOutOfRange As Boolean
    Get

Property Value

Type: Boolean
true if the calculated value is outside the Minimum and Maximum range; otherwise, false.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace
CalculatorMinimum
CalculatorMaximum


Calculator.Maximum Property

CalculatorMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace
CalculatorIsOutOfRange


Calculator.MemoryButtonStyle Property

CalculatorMemoryButtonStyle Property
Gets or sets the Style to use for memory buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MemoryButtonStyle { get; set; }
Public Property MemoryButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for memory buttons.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.Minimum Property

CalculatorMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace
CalculatorIsOutOfRange


Calculator.OperationButtonStyle Property

CalculatorOperationButtonStyle Property
Gets or sets the Style to use for operation buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style OperationButtonStyle { get; set; }
Public Property OperationButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for operation buttons.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OperationCommand Property

CalculatorOperationCommand Property
Gets the ICommand that can execute an operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand OperationCommand { get; }
Public ReadOnly Property OperationCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can execute an operation.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.RecallMemoryCommand Property

CalculatorRecallMemoryCommand Property
Gets the ICommand that can recall memory.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RecallMemoryCommand { get; }
Public ReadOnly Property RecallMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can recall memory.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.SetMemoryCommand Property

CalculatorSetMemoryCommand Property
Gets the ICommand that can set memory.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SetMemoryCommand { get; }
Public ReadOnly Property SetMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can set memory.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.SubtractFromMemoryCommand Property

CalculatorSubtractFromMemoryCommand Property
Gets the ICommand that can subtract from memory.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SubtractFromMemoryCommand { get; }
Public ReadOnly Property SubtractFromMemoryCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can subtract from memory.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.Value Property

CalculatorValue Property
Gets or sets the current calculated value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The current calculated value. The default value is 0.0.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator Methods

Calculator Methods

The Calculator type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OnApplyTemplate Method

CalculatorOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OnCreateAutomationPeer Method

CalculatorOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OnGotFocus Method

CalculatorOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OnKeyDown Method

CalculatorOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OnLostFocus Method

CalculatorOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator Events

Calculator Events

The Calculator type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.ValueChanged Event

CalculatorValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator Fields

Calculator Fields

The Calculator type exposes the following members.

Fields
Name | Description
AcceptsEscapeProperty | Identifies the AcceptsEscape dependency property. This field is read-only.
DigitButtonStyleProperty | Identifies the DigitButtonStyle dependency property. This field is read-only.
DisplayFontSizeProperty | Identifies the DisplayFontSize dependency property. This field is read-only.
DisplayTextProperty | Identifies the DisplayText dependency property. This field is read-only.
HasDisplayProperty | Identifies the HasDisplay dependency property. This field is read-only.
HasMemoryButtonsProperty | Identifies the HasMemoryButtons dependency property. This field is read-only.
IsOutOfRangeProperty | Identifies the IsOutOfRange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MemoryButtonStyleProperty | Identifies the MemoryButtonStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OperationButtonStyleProperty | Identifies the OperationButtonStyle dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.AcceptsEscapeProperty Field

CalculatorAcceptsEscapeProperty Field
Identifies the AcceptsEscape dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AcceptsEscapeProperty
Public Shared ReadOnly AcceptsEscapeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AcceptsEscape dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.DigitButtonStyleProperty Field

CalculatorDigitButtonStyleProperty Field
Identifies the DigitButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DigitButtonStyleProperty
Public Shared ReadOnly DigitButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DigitButtonStyle dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.DisplayFontSizeProperty Field

CalculatorDisplayFontSizeProperty Field
Identifies the DisplayFontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayFontSizeProperty
Public Shared ReadOnly DisplayFontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayFontSize dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.DisplayTextProperty Field

CalculatorDisplayTextProperty Field
Identifies the DisplayText dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayTextProperty
Public Shared ReadOnly DisplayTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayText dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.HasDisplayProperty Field

CalculatorHasDisplayProperty Field
Identifies the HasDisplay dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasDisplayProperty
Public Shared ReadOnly HasDisplayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasDisplay dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.HasMemoryButtonsProperty Field

CalculatorHasMemoryButtonsProperty Field
Identifies the HasMemoryButtons dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasMemoryButtonsProperty
Public Shared ReadOnly HasMemoryButtonsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasMemoryButtons dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.IsOutOfRangeProperty Field

CalculatorIsOutOfRangeProperty Field
Identifies the IsOutOfRange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOutOfRangeProperty
Public Shared ReadOnly IsOutOfRangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOutOfRange dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.MaximumProperty Field

CalculatorMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.MemoryButtonStyleProperty Field

CalculatorMemoryButtonStyleProperty Field
Identifies the MemoryButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MemoryButtonStyleProperty
Public Shared ReadOnly MemoryButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MemoryButtonStyle dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.MinimumProperty Field

CalculatorMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.OperationButtonStyleProperty Field

CalculatorOperationButtonStyleProperty Field
Identifies the OperationButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OperationButtonStyleProperty
Public Shared ReadOnly OperationButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OperationButtonStyle dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Calculator.ValueProperty Field

CalculatorValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Calculator Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind Class

CalculatorOperationKind Class
Specifies an operation used with a calculator.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsCalculatorOperationKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CalculatorOperationKind : Enum
Public NotInheritable Class CalculatorOperationKind
    Inherits Enum

The CalculatorOperationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Add | Add.
 | Divide | Divide.
 | Multiply | Multiply.
 | Percent | Convert the entry to a percentage of the previous operand.
 | Reciprocal | Reciprocal (1/x).
 | SquareRoot | Square root.
 | Subtract | Subtract.
 | ToggleSign | Toggle whether the number is positve or negative.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind Methods

CalculatorOperationKind Methods

The CalculatorOperationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind Fields

CalculatorOperationKind Fields

The CalculatorOperationKind type exposes the following members.

Fields
 | Name | Description
 | Add | Add.
 | Divide | Divide.
 | Multiply | Multiply.
 | Percent | Convert the entry to a percentage of the previous operand.
 | Reciprocal | Reciprocal (1/x).
 | SquareRoot | Square root.
 | Subtract | Subtract.
 | ToggleSign | Toggle whether the number is positve or negative.
Public field | value__ |
Top
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.Add Field

CalculatorOperationKindAdd Field
Add.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind Add = 0
Public Const Add As CalculatorOperationKind = 0

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.Divide Field

CalculatorOperationKindDivide Field
Divide.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind Divide = 3
Public Const Divide As CalculatorOperationKind = 3

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.Multiply Field

CalculatorOperationKindMultiply Field
Multiply.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind Multiply = 2
Public Const Multiply As CalculatorOperationKind = 2

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.Percent Field

CalculatorOperationKindPercent Field
Convert the entry to a percentage of the previous operand.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind Percent = 4
Public Const Percent As CalculatorOperationKind = 4

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.Reciprocal Field

CalculatorOperationKindReciprocal Field
Reciprocal (1/x).

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind Reciprocal = 5
Public Const Reciprocal As CalculatorOperationKind = 5

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.SquareRoot Field

CalculatorOperationKindSquareRoot Field
Square root.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind SquareRoot = 6
Public Const SquareRoot As CalculatorOperationKind = 6

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.Subtract Field

CalculatorOperationKindSubtract Field
Subtract.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind Subtract = 1
Public Const Subtract As CalculatorOperationKind = 1

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.ToggleSign Field

CalculatorOperationKindToggleSign Field
Toggle whether the number is positve or negative.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CalculatorOperationKind ToggleSign = 7
Public Const ToggleSign As CalculatorOperationKind = 7

Field Value

Type: CalculatorOperationKind
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CalculatorOperationKind.value__ Field

CalculatorOperationKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.CalculatorOperationKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CalculatorOperationKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox Class

ColorEditBox Class
Represents a Color edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Color
ActiproSoftware.UI.Xaml.Controls.EditorsColorEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ColorEditBox : PartEditBoxBase<Nullable<Color>>
Public Class ColorEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Color))

The ColorEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | ColorEditBox | Initializes an instance of the ColorEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox Constructor

ColorEditBox Constructor
Initializes an instance of the ColorEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ColorEditBox()
Public Sub New
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox Properties

ColorEditBox Properties

The ColorEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | HasSwatch | Gets or sets whether the edit box should display a swatch that previews the Value.
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SwatchBrush | Gets the Brush that renders a sample swatch.
Public property | SwatchMargin | Gets or sets the Thickness of the margin around the sample swatch.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.HasPopupButtonWhenReadOnly Property

ColorEditBoxHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.HasSwatch Property

ColorEditBoxHasSwatch Property
Gets or sets whether the edit box should display a swatch that previews the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box should display a swatch that previews the Value; otherwise, false. The default value is true.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.IsAlphaEnabled Property

ColorEditBoxIsAlphaEnabled Property
Gets or sets whether the alpha channel (transparency) of the color value is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the color value is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.SwatchBrush Property

ColorEditBoxSwatchBrush Property
Gets the Brush that renders a sample swatch.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SwatchBrush { get; }
Public ReadOnly Property SwatchBrush As Brush
    Get

Property Value

Type: Brush
The Brush that renders a sample swatch.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.SwatchMargin Property

ColorEditBoxSwatchMargin Property
Gets or sets the Thickness of the margin around the sample swatch.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness SwatchMargin { get; set; }
Public Property SwatchMargin As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the margin around the sample swatch.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox Methods

ColorEditBox Methods

The ColorEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides PartEditBoxBaseTOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Overrides PartEditBoxBaseTOnIntermediateValueChanged(T, T).)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.ConvertToString Method

ColorEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Color> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Color)
) As String

Parameters

valueToConvert
Type: SystemNullable Color
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.CreateIncrementalChangeRequest Method

ColorEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Color>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Color))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Color
The incremental change (spin) request that was created.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.GenerateParts Method

ColorEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.IsValidValue Method

ColorEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Color> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Color)
) As Boolean

Parameters

value
Type: SystemNullable Color
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.OnApplyTemplate Method

ColorEditBoxOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.OnIntermediateValueChanged Method

ColorEditBoxOnIntermediateValueChanged Method
Invoked when the value of the IntermediateValue property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnIntermediateValueChanged(
    Nullable<Color> oldValue,
    Nullable<Color> newValue
)
Protected Overrides Sub OnIntermediateValueChanged (
    oldValue As Nullable(Of Color),
    newValue As Nullable(Of Color)
)

Parameters

oldValue
Type: SystemNullable Color
The old value of the property.
newValue
Type: SystemNullable Color
The new value of the property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.RaiseValueChangedEvent Method

ColorEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.ResetValue Method

ColorEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.TryConvertFromString Method

ColorEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Color> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Color)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Color
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox Events

ColorEditBox Events

The ColorEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.ValueChanged Event

ColorEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox Fields

ColorEditBox Fields

The ColorEditBox type exposes the following members.

Fields
Name | Description
HasSwatchProperty | Identifies the HasSwatch dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
SwatchBrushProperty | Identifies the SwatchBrush dependency property. This field is read-only.
SwatchMarginProperty | Identifies the SwatchMargin dependency property. This field is read-only.
Top
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.HasSwatchProperty Field

ColorEditBoxHasSwatchProperty Field
Identifies the HasSwatch dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasSwatchProperty
Public Shared ReadOnly HasSwatchProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasSwatch dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.IsAlphaEnabledProperty Field

ColorEditBoxIsAlphaEnabledProperty Field
Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.SwatchBrushProperty Field

ColorEditBoxSwatchBrushProperty Field
Identifies the SwatchBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchBrushProperty
Public Shared ReadOnly SwatchBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchBrush dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorEditBox.SwatchMarginProperty Field

ColorEditBoxSwatchMarginProperty Field
Identifies the SwatchMargin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SwatchMarginProperty
Public Shared ReadOnly SwatchMarginProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SwatchMargin dependency property.
See Also

Reference

ColorEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker Class

ColorPicker Class
Represents a color picker control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsColorPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ColorPicker : PickerBase
Public Class ColorPicker
    Inherits PickerBase

The ColorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPicker | Initializes an instance of the ColorPicker class.
Top
Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the Value.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | B | Gets or sets the RGB blue component (0 - 255) of the Value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the Value.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | G | Gets or sets the RGB green component (0 - 255) of the Value.
Public property | HasColorEditBox | Gets or sets whether an embedded ColorEditBox should appear in the picker for hex-based color entry.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the Value.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box text areas within the control are editable.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | R | Gets or sets the RGB red component (0 - 255) of the Value.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the Value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the selected color.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BProperty | Identifies the B dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
GProperty | Identifies the G dependency property. This field is read-only.
HasColorEditBoxProperty | Identifies the HasColorEditBox dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
RProperty | Identifies the R dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker Constructor

ColorPicker Constructor
Initializes an instance of the ColorPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ColorPicker()
Public Sub New
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker Properties

ColorPicker Properties

The ColorPicker type exposes the following members.

Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the Value.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | B | Gets or sets the RGB blue component (0 - 255) of the Value.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the Value.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | G | Gets or sets the RGB green component (0 - 255) of the Value.
Public property | HasColorEditBox | Gets or sets whether an embedded ColorEditBox should appear in the picker for hex-based color entry.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the Value.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAlphaEnabled | Gets or sets whether the alpha channel (transparency) of the color value is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box text areas within the control are editable.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | R | Gets or sets the RGB red component (0 - 255) of the Value.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the Value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the selected color.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.A Property

ColorPickerA Property
Gets or sets the alpha transparency component (0 - 255) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int A { get; set; }
Public Property A As Integer
    Get
    Set

Property Value

Type: Int32
The alpha transparency component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.B Property

ColorPickerB Property
Gets or sets the RGB blue component (0 - 255) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int B { get; set; }
Public Property B As Integer
    Get
    Set

Property Value

Type: Int32
The RGB blue component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.Brightness Property

ColorPickerBrightness Property
Gets or sets the HSB brightness component (0 - 1.0) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
The HSB brightness component (0 - 1.0) of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.G Property

ColorPickerG Property
Gets or sets the RGB green component (0 - 255) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int G { get; set; }
Public Property G As Integer
    Get
    Set

Property Value

Type: Int32
The RGB green component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.HasColorEditBox Property

ColorPickerHasColorEditBox Property
Gets or sets whether an embedded ColorEditBox should appear in the picker for hex-based color entry.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasColorEditBox { get; set; }
Public Property HasColorEditBox As Boolean
    Get
    Set

Property Value

Type: Boolean
true if an embedded ColorEditBox should appear in the picker for hex-based color entry; otherwise, false. The default value is true.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.Hue Property

ColorPickerHue Property
Gets or sets the HSB hue component (0 - 359.00) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The HSB hue component (0 - 359.00) of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.IsAlphaEnabled Property

ColorPickerIsAlphaEnabled Property
Gets or sets whether the alpha channel (transparency) of the color value is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the alpha channel (transparency) of the color value is enabled; otherwise, false. The default value is true.
Remarks
When disabled, no transparency is supported.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.IsEditable Property

ColorPickerIsEditable Property
Gets or sets a value indicating whether the edit box text areas within the control are editable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box text areas within the control are editable; otherwise false. The default value is true.
Remarks
When false, the edit boxes behave more like a ComboBox.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.R Property

ColorPickerR Property
Gets or sets the RGB red component (0 - 255) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int R { get; set; }
Public Property R As Integer
    Get
    Set

Property Value

Type: Int32
The RGB red component of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.Saturation Property

ColorPickerSaturation Property
Gets or sets the HSB saturation component (0 - 1.0) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
The HSB saturation component (0 - 1.0) of the Value.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.Value Property

ColorPickerValue Property
Gets or sets the selected color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color Value { get; set; }
Public Property Value As Color
    Get
    Set

Property Value

Type: Color
The selected color.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker Methods

ColorPicker Methods

The ColorPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker Events

ColorPicker Events

The ColorPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.ValueChanged Event

ColorPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker Fields

ColorPicker Fields

The ColorPicker type exposes the following members.

Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BProperty | Identifies the B dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
GProperty | Identifies the G dependency property. This field is read-only.
HasColorEditBoxProperty | Identifies the HasColorEditBox dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
IsAlphaEnabledProperty | Identifies the IsAlphaEnabled dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
RProperty | Identifies the R dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.AProperty Field

ColorPickerAProperty Field
Identifies the A dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AProperty
Public Shared ReadOnly AProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the A dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.BProperty Field

ColorPickerBProperty Field
Identifies the B dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BProperty
Public Shared ReadOnly BProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the B dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.BrightnessProperty Field

ColorPickerBrightnessProperty Field
Identifies the Brightness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessProperty
Public Shared ReadOnly BrightnessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Brightness dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.GProperty Field

ColorPickerGProperty Field
Identifies the G dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GProperty
Public Shared ReadOnly GProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the G dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.HasColorEditBoxProperty Field

ColorPickerHasColorEditBoxProperty Field
Identifies the HasColorEditBox dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasColorEditBoxProperty
Public Shared ReadOnly HasColorEditBoxProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasColorEditBox dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.HueProperty Field

ColorPickerHueProperty Field
Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.IsAlphaEnabledProperty Field

ColorPickerIsAlphaEnabledProperty Field
Identifies the IsAlphaEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAlphaEnabledProperty
Public Shared ReadOnly IsAlphaEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAlphaEnabled dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.IsEditableProperty Field

ColorPickerIsEditableProperty Field
Identifies the IsEditable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditableProperty
Public Shared ReadOnly IsEditableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditable dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.RProperty Field

ColorPickerRProperty Field
Identifies the R dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RProperty
Public Shared ReadOnly RProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the R dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.SaturationProperty Field

ColorPickerSaturationProperty Field
Identifies the Saturation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationProperty
Public Shared ReadOnly SaturationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Saturation dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ColorPicker.ValueProperty Field

ColorPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

ColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox Class

CornerRadiusEditBox Class
Represents a CornerRadius edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable CornerRadius
ActiproSoftware.UI.Xaml.Controls.EditorsCornerRadiusEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CornerRadiusEditBox : PartEditBoxBase<Nullable<CornerRadius>>
Public Class CornerRadiusEditBox
    Inherits PartEditBoxBase(Of Nullable(Of CornerRadius))

The CornerRadiusEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusEditBox | Initializes an instance of the CornerRadiusEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox Constructor

CornerRadiusEditBox Constructor
Initializes an instance of the CornerRadiusEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadiusEditBox()
Public Sub New
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox Properties

CornerRadiusEditBox Properties

The CornerRadiusEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.Format Property

CornerRadiusEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.LargeChange Property

CornerRadiusEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius LargeChange { get; set; }
Public Property LargeChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The large change value. The default value is 5.0.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.Maximum Property

CornerRadiusEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The highest possible value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.Minimum Property

CornerRadiusEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The lowest possible value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.ResolvedFormat Property

CornerRadiusEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.SmallChange Property

CornerRadiusEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The small change value. The default value is 1.0.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox Methods

CornerRadiusEditBox Methods

The CornerRadiusEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.ConvertToString Method

CornerRadiusEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<CornerRadius> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of CornerRadius)
) As String

Parameters

valueToConvert
Type: SystemNullable CornerRadius
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.CreateIncrementalChangeRequest Method

CornerRadiusEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<CornerRadius>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of CornerRadius))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable CornerRadius
The incremental change (spin) request that was created.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.GenerateParts Method

CornerRadiusEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.IsValidValue Method

CornerRadiusEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<CornerRadius> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of CornerRadius)
) As Boolean

Parameters

value
Type: SystemNullable CornerRadius
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.RaiseValueChangedEvent Method

CornerRadiusEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.ResetValue Method

CornerRadiusEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.TryConvertFromString Method

CornerRadiusEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<CornerRadius> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of CornerRadius)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable CornerRadius
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox Events

CornerRadiusEditBox Events

The CornerRadiusEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.ValueChanged Event

CornerRadiusEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox Fields

CornerRadiusEditBox Fields

The CornerRadiusEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.FormatProperty Field

CornerRadiusEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.LargeChangeProperty Field

CornerRadiusEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.MaximumProperty Field

CornerRadiusEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.MinimumProperty Field

CornerRadiusEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.ResolvedFormatProperty Field

CornerRadiusEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusEditBox.SmallChangeProperty Field

CornerRadiusEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

CornerRadiusEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker Class

CornerRadiusPicker Class
Represents a CornerRadius picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsCornerRadiusPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CornerRadiusPicker : PickerBase
Public Class CornerRadiusPicker
    Inherits PickerBase

The CornerRadiusPicker type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusPicker | Initializes an instance of the CornerRadiusPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker Constructor

CornerRadiusPicker Constructor
Initializes an instance of the CornerRadiusPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadiusPicker()
Public Sub New
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker Properties

CornerRadiusPicker Properties

The CornerRadiusPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.Maximum Property

CornerRadiusPickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The highest possible value.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.Minimum Property

CornerRadiusPickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The lowest possible value.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.SmallChange Property

CornerRadiusPickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The small change value. The default value is 1.0.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.Value Property

CornerRadiusPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Value { get; set; }
Public Property Value As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
The value of the control.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker Methods

CornerRadiusPicker Methods

The CornerRadiusPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.OnApplyTemplate Method

CornerRadiusPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker Events

CornerRadiusPicker Events

The CornerRadiusPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.ValueChanged Event

CornerRadiusPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker Fields

CornerRadiusPicker Fields

The CornerRadiusPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.MaximumProperty Field

CornerRadiusPickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.MinimumProperty Field

CornerRadiusPickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.SmallChangeProperty Field

CornerRadiusPickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CornerRadiusPicker.ValueProperty Field

CornerRadiusPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

CornerRadiusPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country Class

Country Class
Specifies the various countries and associated data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.EditorsCountry

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Country
Public Class Country

The Country type exposes the following members.

Constructors
 | Name | Description
Public method | Country(String, String) | Initializes an instance of the Country class.
Public method | Country(String, String, String) | Initializes an instance of the Country class.
Top
Properties
 | Name | Description
Public property | Alpha2Code | Gets the two-letter Country code.
Public property | Alpha3Code | Gets the three-letter Country code.
Public property | Code | Obsolete. Gets the two-letter Country code.
 | Countries | Gets the global collection of Country objects used by CountryComboBox.
Public property | Name | Gets or sets the name of the Country.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country Constructor

Country Constructor
Overload List
 | Name | Description
Public method | Country(String, String) | Initializes an instance of the Country class.
Public method | Country(String, String, String) | Initializes an instance of the Country class.
Top
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country Constructor (String, String)

Country Constructor (String, String)
Initializes an instance of the Country class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Country(
    string name,
    string alpha2Code
)
Public Sub New (
    name As String,
    alpha2Code As String
)

Parameters

name
Type: SystemString
The name of the Country.
alpha2Code
Type: SystemString
The two letter Country code.
See Also

Reference

Country Class
Country Overload
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country Constructor (String, String, String)

Country Constructor (String, String, String)
Initializes an instance of the Country class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Country(
    string name,
    string alpha2Code,
    string alpha3Code
)
Public Sub New (
    name As String,
    alpha2Code As String,
    alpha3Code As String
)

Parameters

name
Type: SystemString
The name of the Country.
alpha2Code
Type: SystemString
The two-letter Country code.
alpha3Code
Type: SystemString
The three-letter Country code.
See Also

Reference

Country Class
Country Overload
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country Properties

Country Properties

The Country type exposes the following members.

Properties
 | Name | Description
Public property | Alpha2Code | Gets the two-letter Country code.
Public property | Alpha3Code | Gets the three-letter Country code.
Public property | Code | Obsolete. Gets the two-letter Country code.
 | Countries | Gets the global collection of Country objects used by CountryComboBox.
Public property | Name | Gets or sets the name of the Country.
Top
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country.Alpha2Code Property

CountryAlpha2Code Property
Gets the two-letter Country code.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alpha2Code { get; }
Public ReadOnly Property Alpha2Code As String
    Get

Property Value

Type: String
The two-letter Country code.
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country.Alpha3Code Property

CountryAlpha3Code Property
Gets the three-letter Country code.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Alpha3Code { get; }
Public ReadOnly Property Alpha3Code As String
    Get

Property Value

Type: String
The three-letter Country code.
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country.Code Property

CountryCode Property

Note: This API is now obsolete.

Gets the two-letter Country code.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use the Alpha2Code property instead.", false)]
public string Code { get; }
<ObsoleteAttribute("Use the Alpha2Code property instead.", false)>
Public ReadOnly Property Code As String
    Get

Property Value

Type: String
The two-letter Country code.
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country.Countries Property

CountryCountries Property
Gets the global collection of Country objects used by CountryComboBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DeferrableObservableCollection<Country> Countries { get; }
Public Shared ReadOnly Property Countries As DeferrableObservableCollection(Of Country)
    Get

Property Value

Type: DeferrableObservableCollection Country
A collection of Country objects.
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country.Name Property

CountryName Property
Gets or sets the name of the Country.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the Country.
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Country Methods

Country Methods

The Country type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Country Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryComboBox Class

CountryComboBox Class
A drop-down list for country selection, populated with Country objects.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
Windows.UI.Xaml.Controls.PrimitivesSelector
Windows.UI.Xaml.ControlsComboBox
ActiproSoftware.UI.Xaml.Controls.EditorsCountryComboBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CountryComboBox : ComboBox
Public Class CountryComboBox
    Inherits ComboBox

The CountryComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | CountryComboBox | Initializes an instance of the CountryComboBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from ComboBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from ComboBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down portion of the ComboBox is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets a value that indicates whether the user can edit text in the text box portion of the ComboBox. This property always returns false. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectionBoxHighlighted | Gets a value that indicates whether the SelectionBoxItem component is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsTextSearchEnabled | (Inherited from ComboBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LightDismissOverlayMode | (Inherited from ComboBox.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | This property is ignored. Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from ComboBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item shown when the ComboBox is closed. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the template applied to the selection box content. (Inherited from ComboBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TemplateSettings | Gets an object that provides calculated values that can be referenced as TemplateBinding sources when defining templates for a ComboBox control. (Inherited from ComboBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnDropDownClosed | Invoked when the DropDownClosed event is raised. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Invoked when the DropDownOpened event is raised. (Inherited from ComboBox.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down portion of the ComboBox closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down portion of the ComboBox opens. (Inherited from ComboBox.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryComboBox Constructor

CountryComboBox Constructor
Initializes an instance of the CountryComboBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CountryComboBox()
Public Sub New
See Also

Reference

CountryComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryComboBox Properties

CountryComboBox Properties

The CountryComboBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from ComboBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from ComboBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down portion of the ComboBox is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets a value that indicates whether the user can edit text in the text box portion of the ComboBox. This property always returns false. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectionBoxHighlighted | Gets a value that indicates whether the SelectionBoxItem component is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsTextSearchEnabled | (Inherited from ComboBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LightDismissOverlayMode | (Inherited from ComboBox.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | This property is ignored. Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from ComboBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item shown when the ComboBox is closed. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the template applied to the selection box content. (Inherited from ComboBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TemplateSettings | Gets an object that provides calculated values that can be referenced as TemplateBinding sources when defining templates for a ComboBox control. (Inherited from ComboBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

CountryComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryComboBox Methods

CountryComboBox Methods

The CountryComboBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnDropDownClosed | Invoked when the DropDownClosed event is raised. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Invoked when the DropDownOpened event is raised. (Inherited from ComboBox.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

CountryComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryComboBox Events

CountryComboBox Events

The CountryComboBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down portion of the ComboBox closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down portion of the ComboBox opens. (Inherited from ComboBox.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

CountryComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping Class

CountryCurrencyMapping Class
A mapping between a Country and a Currency.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.EditorsCountryCurrencyMapping

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CountryCurrencyMapping
Public Class CountryCurrencyMapping

The CountryCurrencyMapping type exposes the following members.

Constructors
 | Name | Description
Public method | CountryCurrencyMapping | Initializes an instance of the CountryCurrencyMapping class.
Top
Properties
 | Name | Description
Public property | CountryCode | Gets the 2 letter country code for this mapping.
Public property | CurrencyCode | Gets the 3 letter currency code for this mapping.
 | Mappings | Gets the global collection of CountryCurrencyMapping objects.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping Constructor

CountryCurrencyMapping Constructor
Initializes an instance of the CountryCurrencyMapping class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CountryCurrencyMapping(
    string countryCode,
    string currencyCode
)
Public Sub New (
    countryCode As String,
    currencyCode As String
)

Parameters

countryCode
Type: SystemString
The 2 letter Country code.
currencyCode
Type: SystemString
The 3 letter Currency code.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping Properties

CountryCurrencyMapping Properties

The CountryCurrencyMapping type exposes the following members.

Properties
 | Name | Description
Public property | CountryCode | Gets the 2 letter country code for this mapping.
Public property | CurrencyCode | Gets the 3 letter currency code for this mapping.
 | Mappings | Gets the global collection of CountryCurrencyMapping objects.
Top
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping.CountryCode Property

CountryCurrencyMappingCountryCode Property
Gets the 2 letter country code for this mapping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string CountryCode { get; }
Public ReadOnly Property CountryCode As String
    Get

Property Value

Type: String
The 2 letter country code for this mapping.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping.CurrencyCode Property

CountryCurrencyMappingCurrencyCode Property
Gets the 3 letter currency code for this mapping.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string CurrencyCode { get; }
Public ReadOnly Property CurrencyCode As String
    Get

Property Value

Type: String
The 3 letter currency code for this mapping.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping.Mappings Property

CountryCurrencyMappingMappings Property
Gets the global collection of CountryCurrencyMapping objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DeferrableObservableCollection<CountryCurrencyMapping> Mappings { get; }
Public Shared ReadOnly Property Mappings As DeferrableObservableCollection(Of CountryCurrencyMapping)
    Get

Property Value

Type: DeferrableObservableCollection CountryCurrencyMapping
A collection of CountryCurrencyMapping objects.
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CountryCurrencyMapping Methods

CountryCurrencyMapping Methods

The CountryCurrencyMapping type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CountryCurrencyMapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency Class

Currency Class
Specifies a country's currency.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.EditorsCurrency

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Currency
Public Class Currency

The Currency type exposes the following members.

Constructors
 | Name | Description
Public method | Currency | Initializes an instance of the Currency class.
Top
Properties
 | Name | Description
Public property | Code | Gets the 3 letter Currency code.
 | Currencies | Gets the global collection of Currency objects used by CurrencyComboBox.
Public property | Description | Gets the description of the currency, which is a concatenation of the other properties.
Public property | Name | Gets or sets the name of the Currency (i.e. Dollar).
Public property | Symbol | Gets or sets the Currency symbol.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency Constructor

Currency Constructor
Initializes an instance of the Currency class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Currency(
    string code,
    string name,
    string symbol
)
Public Sub New (
    code As String,
    name As String,
    symbol As String
)

Parameters

code
Type: SystemString
The 3 letter Currency code.
name
Type: SystemString
The plural name of the Currency (i.e. Dollars).
symbol
Type: SystemString
The Currency symbol.
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency Properties

Currency Properties

The Currency type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets the 3 letter Currency code.
 | Currencies | Gets the global collection of Currency objects used by CurrencyComboBox.
Public property | Description | Gets the description of the currency, which is a concatenation of the other properties.
Public property | Name | Gets or sets the name of the Currency (i.e. Dollar).
Public property | Symbol | Gets or sets the Currency symbol.
Top
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency.Code Property

CurrencyCode Property
Gets the 3 letter Currency code.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get

Property Value

Type: String
The 3 letter Currency code.
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency.Currencies Property

CurrencyCurrencies Property
Gets the global collection of Currency objects used by CurrencyComboBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static DeferrableObservableCollection<Currency> Currencies { get; }
Public Shared ReadOnly Property Currencies As DeferrableObservableCollection(Of Currency)
    Get

Property Value

Type: DeferrableObservableCollection Currency
A collection of Currency objects.
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency.Description Property

CurrencyDescription Property
Gets the description of the currency, which is a concatenation of the other properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the currency, which is a concatenation of the other properties.
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency.Name Property

CurrencyName Property
Gets or sets the name of the Currency (i.e. Dollar).

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the Currency (i.e. Dollar).
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency.Symbol Property

CurrencySymbol Property
Gets or sets the Currency symbol.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Symbol { get; set; }
Public Property Symbol As String
    Get
    Set

Property Value

Type: String
The Currency symbol.
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Currency Methods

Currency Methods

The Currency type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Currency Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CurrencyComboBox Class

CurrencyComboBox Class
A drop-down list for currency selection, populated with Currency objects.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
Windows.UI.Xaml.Controls.PrimitivesSelector
Windows.UI.Xaml.ControlsComboBox
ActiproSoftware.UI.Xaml.Controls.EditorsCurrencyComboBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CurrencyComboBox : ComboBox
Public Class CurrencyComboBox
    Inherits ComboBox

The CurrencyComboBox type exposes the following members.

Constructors
 | Name | Description
Public method | CurrencyComboBox | Initializes an instance of the CurrencyComboBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from ComboBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from ComboBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down portion of the ComboBox is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets a value that indicates whether the user can edit text in the text box portion of the ComboBox. This property always returns false. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectionBoxHighlighted | Gets a value that indicates whether the SelectionBoxItem component is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsTextSearchEnabled | (Inherited from ComboBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LightDismissOverlayMode | (Inherited from ComboBox.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | This property is ignored. Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from ComboBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item shown when the ComboBox is closed. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the template applied to the selection box content. (Inherited from ComboBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TemplateSettings | Gets an object that provides calculated values that can be referenced as TemplateBinding sources when defining templates for a ComboBox control. (Inherited from ComboBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnDropDownClosed | Invoked when the DropDownClosed event is raised. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Invoked when the DropDownOpened event is raised. (Inherited from ComboBox.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down portion of the ComboBox closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down portion of the ComboBox opens. (Inherited from ComboBox.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CurrencyComboBox Constructor

CurrencyComboBox Constructor
Initializes an instance of the CurrencyComboBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CurrencyComboBox()
Public Sub New
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CurrencyComboBox Properties

CurrencyComboBox Properties

The CurrencyComboBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from ComboBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from ComboBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down portion of the ComboBox is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets a value that indicates whether the user can edit text in the text box portion of the ComboBox. This property always returns false. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectionBoxHighlighted | Gets a value that indicates whether the SelectionBoxItem component is highlighted. (Inherited from ComboBox.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsTextSearchEnabled | (Inherited from ComboBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LightDismissOverlayMode | (Inherited from ComboBox.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | This property is ignored. Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from ComboBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item shown when the ComboBox is closed. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the template applied to the selection box content. (Inherited from ComboBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TemplateSettings | Gets an object that provides calculated values that can be referenced as TemplateBinding sources when defining templates for a ComboBox control. (Inherited from ComboBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CurrencyComboBox Methods

CurrencyComboBox Methods

The CurrencyComboBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnDropDownClosed | Invoked when the DropDownClosed event is raised. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Invoked when the DropDownOpened event is raised. (Inherited from ComboBox.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


CurrencyComboBox Events

CurrencyComboBox Events

The CurrencyComboBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down portion of the ComboBox closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down portion of the ComboBox opens. (Inherited from ComboBox.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

CurrencyComboBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox Class

DateEditBox Class
Represents a date-only edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable DateTime
ActiproSoftware.UI.Xaml.Controls.EditorsDateTimeEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsDateEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateEditBox : DateTimeEditBox
Public Class DateEditBox
    Inherits DateTimeEditBox

The DateEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | DateEditBox | Initializes an instance of the DateEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from DateTimeEditBox.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides DateTimeEditBoxTryConvertFromString(String, Boolean, NullableDateTime).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox Constructor

DateEditBox Constructor
Initializes an instance of the DateEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateEditBox()
Public Sub New
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox Properties

DateEditBox Properties

The DateEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from DateTimeEditBox.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox.CanRetainTime Property

DateEditBoxCanRetainTime Property
Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanRetainTime { get; set; }
Public Property CanRetainTime As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the various DateTime values can retain the time-portion; otherwise, false. The default value is false.
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox Methods

DateEditBox Methods

The DateEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides DateTimeEditBoxTryConvertFromString(String, Boolean, NullableDateTime).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox.ResetValue Method

DateEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox.TryConvertFromString Method

DateEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<DateTime> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of DateTime)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable DateTime
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox Events

DateEditBox Events

The DateEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox Fields

DateEditBox Fields

The DateEditBox type exposes the following members.

Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
Top
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateEditBox.CanRetainTimeProperty Field

DateEditBoxCanRetainTimeProperty Field
Identifies the CanRetainTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRetainTimeProperty
Public Shared ReadOnly CanRetainTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRetainTime dependency property.
See Also

Reference

DateEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker Class

DatePicker Class
Represents a date picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsDatePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DatePicker : PickerBase
Public Class DatePicker
    Inherits PickerBase

The DatePicker type exposes the following members.

Constructors
 | Name | Description
Public method | DatePicker | Initializes an instance of the DatePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker Constructor

DatePicker Constructor
Initializes an instance of the DatePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DatePicker()
Public Sub New
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker Properties

DatePicker Properties

The DatePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.CanRetainTime Property

DatePickerCanRetainTime Property
Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanRetainTime { get; set; }
Public Property CanRetainTime As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the various DateTime values can retain the time-portion; otherwise, false. The default value is false.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.Maximum Property

DatePickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.Minimum Property

DatePickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.Value Property

DatePickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

Property Value

Type: DateTime
The value of the control.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker Methods

DatePicker Methods

The DatePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker Events

DatePicker Events

The DatePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.ValueChanged Event

DatePickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker Fields

DatePicker Fields

The DatePicker type exposes the following members.

Fields
Name | Description
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.CanRetainTimeProperty Field

DatePickerCanRetainTimeProperty Field
Identifies the CanRetainTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRetainTimeProperty
Public Shared ReadOnly CanRetainTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRetainTime dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.MaximumProperty Field

DatePickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.MinimumProperty Field

DatePickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DatePicker.ValueProperty Field

DatePickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DatePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox Class

DateTimeEditBox Class
Represents a date/time edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable DateTime
ActiproSoftware.UI.Xaml.Controls.EditorsDateTimeEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsDateEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsTimeEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateTimeEditBox : PartEditBoxBase<Nullable<DateTime>>
Public Class DateTimeEditBox
    Inherits PartEditBoxBase(Of Nullable(Of DateTime))

The DateTimeEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeEditBox | Initializes an instance of the DateTimeEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox Constructor

DateTimeEditBox Constructor
Initializes an instance of the DateTimeEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTimeEditBox()
Public Sub New
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox Properties

DateTimeEditBox Properties

The DateTimeEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.Format Property

DateTimeEditBoxFormat Property
Gets or sets the date/time format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The date/time format string. The default value is "g".
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.HasPopupButtonWhenReadOnly Property

DateTimeEditBoxHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.Maximum Property

DateTimeEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.Minimum Property

DateTimeEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.ResolvedFormat Property

DateTimeEditBoxResolvedFormat Property
Gets the resolved date/time format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved date/time format string.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox Methods

DateTimeEditBox Methods

The DateTimeEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.ConvertToString Method

DateTimeEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<DateTime> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of DateTime)
) As String

Parameters

valueToConvert
Type: SystemNullable DateTime
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.CreateIncrementalChangeRequest Method

DateTimeEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<DateTime>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of DateTime))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable DateTime
The incremental change (spin) request that was created.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.GenerateParts Method

DateTimeEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.IsValidValue Method

DateTimeEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<DateTime> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of DateTime)
) As Boolean

Parameters

value
Type: SystemNullable DateTime
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.RaiseValueChangedEvent Method

DateTimeEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.ResetValue Method

DateTimeEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.TryConvertFromString Method

DateTimeEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<DateTime> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of DateTime)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable DateTime
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox Events

DateTimeEditBox Events

The DateTimeEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.ValueChanged Event

DateTimeEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox Fields

DateTimeEditBox Fields

The DateTimeEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.FormatProperty Field

DateTimeEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.MaximumProperty Field

DateTimeEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.MinimumProperty Field

DateTimeEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimeEditBox.ResolvedFormatProperty Field

DateTimeEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

DateTimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker Class

DateTimePicker Class
Represents a date/time picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsDateTimePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateTimePicker : PickerBase
Public Class DateTimePicker
    Inherits PickerBase

The DateTimePicker type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimePicker | Initializes an instance of the DateTimePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker Constructor

DateTimePicker Constructor
Initializes an instance of the DateTimePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTimePicker()
Public Sub New
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker Properties

DateTimePicker Properties

The DateTimePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.Maximum Property

DateTimePickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.Minimum Property

DateTimePickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.Value Property

DateTimePickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

Property Value

Type: DateTime
The value of the control.
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker Methods

DateTimePicker Methods

The DateTimePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.OnApplyTemplate Method

DateTimePickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker Events

DateTimePicker Events

The DateTimePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.ValueChanged Event

DateTimePickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker Fields

DateTimePicker Fields

The DateTimePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.MaximumProperty Field

DateTimePickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.MinimumProperty Field

DateTimePickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DateTimePicker.ValueProperty Field

DateTimePickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DateTimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek Class

DaysOfWeek Class
Specifies the various days of the week as enumeration flags.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsDaysOfWeek

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class DaysOfWeek : Enum
<FlagsAttribute>
Public NotInheritable Class DaysOfWeek
    Inherits Enum

The DaysOfWeek type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates all of the days of the week.
 | Friday | Indicates Friday.
 | Monday | Indicates Monday.
 | None | Indicates none of the days of the week.
 | Saturday | Indicates Saturday.
 | Sunday | Indicates Sunday.
 | Thursday | Indicates Thursday.
 | Tuesday | Indicates Tuesday.
Public field | value__ |
 | Wednesday | Indicates Wednesday.
 | Weekdays | Indicates the weekdays, Monday through Friday.
 | Weekend | Indicates the weekend days, Sunday and Saturday.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek Methods

DaysOfWeek Methods

The DaysOfWeek type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek Fields

DaysOfWeek Fields

The DaysOfWeek type exposes the following members.

Fields
 | Name | Description
 | All | Indicates all of the days of the week.
 | Friday | Indicates Friday.
 | Monday | Indicates Monday.
 | None | Indicates none of the days of the week.
 | Saturday | Indicates Saturday.
 | Sunday | Indicates Sunday.
 | Thursday | Indicates Thursday.
 | Tuesday | Indicates Tuesday.
Public field | value__ |
 | Wednesday | Indicates Wednesday.
 | Weekdays | Indicates the weekdays, Monday through Friday.
 | Weekend | Indicates the weekend days, Sunday and Saturday.
Top
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.All Field

DaysOfWeekAll Field
Indicates all of the days of the week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek All = 127
Public Const All As DaysOfWeek = 127

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Friday Field

DaysOfWeekFriday Field
Indicates Friday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Friday = 32
Public Const Friday As DaysOfWeek = 32

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Monday Field

DaysOfWeekMonday Field
Indicates Monday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Monday = 2
Public Const Monday As DaysOfWeek = 2

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.None Field

DaysOfWeekNone Field
Indicates none of the days of the week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek None = 0
Public Const None As DaysOfWeek = 0

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Saturday Field

DaysOfWeekSaturday Field
Indicates Saturday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Saturday = 64
Public Const Saturday As DaysOfWeek = 64

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Sunday Field

DaysOfWeekSunday Field
Indicates Sunday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Sunday = 1
Public Const Sunday As DaysOfWeek = 1

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Thursday Field

DaysOfWeekThursday Field
Indicates Thursday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Thursday = 16
Public Const Thursday As DaysOfWeek = 16

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Tuesday Field

DaysOfWeekTuesday Field
Indicates Tuesday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Tuesday = 4
Public Const Tuesday As DaysOfWeek = 4

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.value__ Field

DaysOfWeekvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.DaysOfWeek.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Wednesday Field

DaysOfWeekWednesday Field
Indicates Wednesday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Wednesday = 8
Public Const Wednesday As DaysOfWeek = 8

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Weekdays Field

DaysOfWeekWeekdays Field
Indicates the weekdays, Monday through Friday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Weekdays = 62
Public Const Weekdays As DaysOfWeek = 62

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DaysOfWeek.Weekend Field

DaysOfWeekWeekend Field
Indicates the weekend days, Sunday and Saturday.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DaysOfWeek Weekend = 65
Public Const Weekend As DaysOfWeek = 65

Field Value

Type: DaysOfWeek
See Also

Reference

DaysOfWeek Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox Class

DoubleEditBox Class
Represents a Double edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Double
ActiproSoftware.UI.Xaml.Controls.EditorsDoubleEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DoubleEditBox : PartEditBoxBase<Nullable<double>>
Public Class DoubleEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Double))

The DoubleEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleEditBox | Initializes an instance of the DoubleEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox Constructor

DoubleEditBox Constructor
Initializes an instance of the DoubleEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoubleEditBox()
Public Sub New
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox Properties

DoubleEditBox Properties

The DoubleEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.CalculatorPopupPickerStyle Property

DoubleEditBoxCalculatorPopupPickerStyle Property
Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.Format Property

DoubleEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsNaNAllowed Property

DoubleEditBoxIsNaNAllowed Property
Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsNegativeInfinityAllowed Property

DoubleEditBoxIsNegativeInfinityAllowed Property
Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsPositiveInfinityAllowed Property

DoubleEditBoxIsPositiveInfinityAllowed Property
Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.LargeChange Property

DoubleEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LargeChange { get; set; }
Public Property LargeChange As Double
    Get
    Set

Property Value

Type: Double
The large change value. The default value is 5.0.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.Maximum Property

DoubleEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.Minimum Property

DoubleEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.PickerKind Property

DoubleEditBoxPickerKind Property
Gets or sets a DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoubleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As DoubleEditBoxPickerKind
    Get
    Set

Property Value

Type: DoubleEditBoxPickerKind
A DoubleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.ResolvedFormat Property

DoubleEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.SmallChange Property

DoubleEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change value. The default value is 1.0.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox Methods

DoubleEditBox Methods

The DoubleEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.ConvertToString Method

DoubleEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<double> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Double)
) As String

Parameters

valueToConvert
Type: SystemNullable Double
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.CreateIncrementalChangeRequest Method

DoubleEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<double>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Double))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Double
The incremental change (spin) request that was created.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.GenerateParts Method

DoubleEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsValidValue Method

DoubleEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<double> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Double)
) As Boolean

Parameters

value
Type: SystemNullable Double
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.ProcessTextInput Method

DoubleEditBoxProcessTextInput Method
Processes typed text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.RaiseValueChangedEvent Method

DoubleEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.ResetValue Method

DoubleEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.TryConvertFromString Method

DoubleEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<double> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Double)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Double
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox Events

DoubleEditBox Events

The DoubleEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.ValueChanged Event

DoubleEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox Fields

DoubleEditBox Fields

The DoubleEditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.CalculatorPopupPickerStyleProperty Field

DoubleEditBoxCalculatorPopupPickerStyleProperty Field
Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.FormatProperty Field

DoubleEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsNaNAllowedProperty Field

DoubleEditBoxIsNaNAllowedProperty Field
Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsNegativeInfinityAllowedProperty Field

DoubleEditBoxIsNegativeInfinityAllowedProperty Field
Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.IsPositiveInfinityAllowedProperty Field

DoubleEditBoxIsPositiveInfinityAllowedProperty Field
Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.LargeChangeProperty Field

DoubleEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.MaximumProperty Field

DoubleEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.MinimumProperty Field

DoubleEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.PickerKindProperty Field

DoubleEditBoxPickerKindProperty Field
Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.ResolvedFormatProperty Field

DoubleEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBox.SmallChangeProperty Field

DoubleEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DoubleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBoxPickerKind Class

DoubleEditBoxPickerKind Class
Specifies the kind of Style to apply to the DoublePicker used within a DoubleEditBox's popup.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsDoubleEditBoxPickerKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DoubleEditBoxPickerKind : Enum
Public NotInheritable Class DoubleEditBoxPickerKind
    Inherits Enum

The DoubleEditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default DoublePicker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBoxPickerKind Methods

DoubleEditBoxPickerKind Methods

The DoubleEditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DoubleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBoxPickerKind Fields

DoubleEditBoxPickerKind Fields

The DoubleEditBoxPickerKind type exposes the following members.

Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default DoublePicker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

DoubleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBoxPickerKind.Calculator Field

DoubleEditBoxPickerKindCalculator Field
Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DoubleEditBoxPickerKind Calculator = 1
Public Const Calculator As DoubleEditBoxPickerKind = 1

Field Value

Type: DoubleEditBoxPickerKind
See Also

Reference

DoubleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBoxPickerKind.Default Field

DoubleEditBoxPickerKindDefault Field
Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default DoublePicker style, which is templated to contain a radial slider control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DoubleEditBoxPickerKind Default = 0
Public Const Default As DoubleEditBoxPickerKind = 0

Field Value

Type: DoubleEditBoxPickerKind
See Also

Reference

DoubleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoubleEditBoxPickerKind.value__ Field

DoubleEditBoxPickerKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.DoubleEditBoxPickerKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DoubleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker Class

DoublePicker Class
Represents a Double picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsDoublePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DoublePicker : RadialSliderPickerBase
Public Class DoublePicker
    Inherits RadialSliderPickerBase

The DoublePicker type exposes the following members.

Constructors
 | Name | Description
Public method | DoublePicker | Initializes an instance of the DoublePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker Constructor

DoublePicker Constructor
Initializes an instance of the DoublePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoublePicker()
Public Sub New
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker Properties

DoublePicker Properties

The DoublePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.Maximum Property

DoublePickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible value.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.Minimum Property

DoublePickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible value.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.SmallChange Property

DoublePickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change value. The default value is 1.0.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.Value Property

DoublePickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value of the control.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker Methods

DoublePicker Methods

The DoublePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.OnApplyTemplate Method

DoublePickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker Events

DoublePicker Events

The DoublePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.ValueChanged Event

DoublePickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker Fields

DoublePicker Fields

The DoublePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.MaximumProperty Field

DoublePickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.MinimumProperty Field

DoublePickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.SmallChangeProperty Field

DoublePickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


DoublePicker.ValueProperty Field

DoublePickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

DoublePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox Class

EnumEditBox Class
Represents an Enum edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Object
ActiproSoftware.UI.Xaml.Controls.EditorsEnumEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumEditBox : PartEditBoxBase<Object>
Public Class EnumEditBox
    Inherits PartEditBoxBase(Of Object)

The EnumEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | EnumEditBox | Initializes an instance of the EnumEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Overrides PartEditBoxBaseTOnValueChanged(T, T).)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox Constructor

EnumEditBox Constructor
Initializes an instance of the EnumEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumEditBox()
Public Sub New
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox Properties

EnumEditBox Properties

The EnumEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.EnumSortComparer Property

EnumEditBoxEnumSortComparer Property
Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.EnumType Property

EnumEditBoxEnumType Property
Gets or sets the enumeration type.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.HasPopupButtonWhenReadOnly Property

EnumEditBoxHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.UseDisplayAttributes Property

EnumEditBoxUseDisplayAttributes Property
Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox Methods

EnumEditBox Methods

The EnumEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Overrides PartEditBoxBaseTOnValueChanged(T, T).)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.ConvertToString Method

EnumEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Object valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Object
) As String

Parameters

valueToConvert
Type: SystemObject
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.CreateIncrementalChangeRequest Method

EnumEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Object> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Object)

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Object
The incremental change (spin) request that was created.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.GenerateParts Method

EnumEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.IsValidValue Method

EnumEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Object value
)
Protected Overrides Function IsValidValue (
    value As Object
) As Boolean

Parameters

value
Type: SystemObject
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.OnValueChanged Method

EnumEditBoxOnValueChanged Method
Invoked when the value of the Value property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    Object oldValue,
    Object newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Object,
    newValue As Object
)

Parameters

oldValue
Type: SystemObject
The old value of the property.
newValue
Type: SystemObject
The new value of the property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.RaiseValueChangedEvent Method

EnumEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.ResetValue Method

EnumEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.TryConvertFromString Method

EnumEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Object value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Object
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemObject
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox Events

EnumEditBox Events

The EnumEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.ValueChanged Event

EnumEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox Fields

EnumEditBox Fields

The EnumEditBox type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.EnumSortComparerProperty Field

EnumEditBoxEnumSortComparerProperty Field
Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.EnumTypeProperty Field

EnumEditBoxEnumTypeProperty Field
Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumEditBox.UseDisplayAttributesProperty Field

EnumEditBoxUseDisplayAttributesProperty Field
Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

EnumEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox Class

EnumListBox Class
Represents a list box that automatically presents the values of an enumeration.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
Windows.UI.Xaml.Controls.PrimitivesSelector
Windows.UI.Xaml.ControlsListBox
ActiproSoftware.UI.Xaml.Controls.EditorsEnumListBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumListBox : ListBox
Public Class EnumListBox
    Inherits ListBox

The EnumListBox type exposes the following members.

Constructors
 | Name | Description
Public method | EnumListBox | Initializes a new instance of the EnumListBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | EnumValue | Gets or sets the current enumeration value.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFlagsEnum | Gets a value indicating whether the EnumType has the FlagsAttribute.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedItems | Gets the list of currently selected items for the ListBox control. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for the ListBox control. (Inherited from ListBox.)
Public property | SingleSelectionFollowsFocus | (Inherited from ListBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in the ListBox control. (Inherited from ListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
EnumValueProperty | Identifies the EnumValue dependency property. This field is read-only.
IsFlagsEnumProperty | Identifies the IsFlagsEnum dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox Constructor

EnumListBox Constructor
Initializes a new instance of the EnumListBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumListBox()
Public Sub New
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox Properties

EnumListBox Properties

The EnumListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | EnumValue | Gets or sets the current enumeration value.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFlagsEnum | Gets a value indicating whether the EnumType has the FlagsAttribute.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the selected item. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the selected item. (Inherited from Selector.)
Public property | SelectedItems | Gets the list of currently selected items for the ListBox control. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the selected item, obtained by using the SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the property path that is used to get the SelectedValue property of the SelectedItem property. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for the ListBox control. (Inherited from ListBox.)
Public property | SingleSelectionFollowsFocus | (Inherited from ListBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.EnumSortComparer Property

EnumListBoxEnumSortComparer Property
Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.EnumType Property

EnumListBoxEnumType Property
Gets or sets the enumeration type.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.EnumValue Property

EnumListBoxEnumValue Property
Gets or sets the current enumeration value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object EnumValue { get; set; }
Public Property EnumValue As Object
    Get
    Set

Property Value

Type: Object
The current enumeration value.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.IsFlagsEnum Property

EnumListBoxIsFlagsEnum Property
Gets a value indicating whether the EnumType has the FlagsAttribute.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsFlagsEnum { get; }
Public ReadOnly Property IsFlagsEnum As Boolean
    Get

Property Value

Type: Boolean
true if the EnumType has the FlagsAttribute; otherwise false.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.UseDisplayAttributes Property

EnumListBoxUseDisplayAttributes Property
Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox Methods

EnumListBox Methods

The EnumListBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in the ListBox control. (Inherited from ListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.GetContainerForItemOverride Method

EnumListBoxGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.IsItemItsOwnContainerOverride Method

EnumListBoxIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.PrepareContainerForItemOverride Method

EnumListBoxPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox Events

EnumListBox Events

The EnumListBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the currently selected item changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox Fields

EnumListBox Fields

The EnumListBox type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
EnumValueProperty | Identifies the EnumValue dependency property. This field is read-only.
IsFlagsEnumProperty | Identifies the IsFlagsEnum dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
Top
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.EnumSortComparerProperty Field

EnumListBoxEnumSortComparerProperty Field
Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.EnumTypeProperty Field

EnumListBoxEnumTypeProperty Field
Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.EnumValueProperty Field

EnumListBoxEnumValueProperty Field
Identifies the EnumValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumValueProperty
Public Shared ReadOnly EnumValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumValue dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.IsFlagsEnumProperty Field

EnumListBoxIsFlagsEnumProperty Field
Identifies the IsFlagsEnum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFlagsEnumProperty
Public Shared ReadOnly IsFlagsEnumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFlagsEnum dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBox.UseDisplayAttributesProperty Field

EnumListBoxUseDisplayAttributesProperty Field
Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

EnumListBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem Class

EnumListBoxItem Class
Represents a selectable item in a EnumListBox.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
Windows.UI.Xaml.Controls.PrimitivesSelectorItem
Windows.UI.Xaml.ControlsListBoxItem
ActiproSoftware.UI.Xaml.Controls.EditorsEnumListBoxItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumListBoxItem : ListBoxItem
Public Class EnumListBoxItem
    Inherits ListBoxItem

The EnumListBoxItem type exposes the following members.

Constructors
 | Name | Description
Public method | EnumListBoxItem | Initializes a new instance of the EnumListBoxItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGroupStart | Gets a value indicating whether the enumeration value starts a group.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPartiallySelected | Gets a value indicating whether the enumeration value represented by this item is partially selected.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether the item is selected in a selector. (Inherited from SelectorItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsGroupStartProperty | Identifies the IsGroupStart dependency property. This field is read-only.
IsPartiallySelectedProperty | Identifies the IsPartiallySelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem Constructor

EnumListBoxItem Constructor
Initializes a new instance of the EnumListBoxItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumListBoxItem()
Public Sub New
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem Properties

EnumListBoxItem Properties

The EnumListBoxItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGroupStart | Gets a value indicating whether the enumeration value starts a group.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPartiallySelected | Gets a value indicating whether the enumeration value represented by this item is partially selected.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether the item is selected in a selector. (Inherited from SelectorItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem.IsGroupStart Property

EnumListBoxItemIsGroupStart Property
Gets a value indicating whether the enumeration value starts a group.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGroupStart { get; }
Public ReadOnly Property IsGroupStart As Boolean
    Get

Property Value

Type: Boolean
true if the enumeration value starts a group; otherwise false.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem.IsPartiallySelected Property

EnumListBoxItemIsPartiallySelected Property
Gets a value indicating whether the enumeration value represented by this item is partially selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPartiallySelected { get; }
Public ReadOnly Property IsPartiallySelected As Boolean
    Get

Property Value

Type: Boolean
true if the enumeration value represented by this item is partially selected; otherwise false.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem Methods

EnumListBoxItem Methods

The EnumListBoxItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem.OnApplyTemplate Method

EnumListBoxItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem Events

EnumListBoxItem Events

The EnumListBoxItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem Fields

EnumListBoxItem Fields

The EnumListBoxItem type exposes the following members.

Fields
Name | Description
IsGroupStartProperty | Identifies the IsGroupStart dependency property. This field is read-only.
IsPartiallySelectedProperty | Identifies the IsPartiallySelected dependency property. This field is read-only.
Top
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem.IsGroupStartProperty Field

EnumListBoxItemIsGroupStartProperty Field
Identifies the IsGroupStart dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsGroupStartProperty
Public Shared ReadOnly IsGroupStartProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsGroupStart dependency property.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumListBoxItem.IsPartiallySelectedProperty Field

EnumListBoxItemIsPartiallySelectedProperty Field
Identifies the IsPartiallySelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPartiallySelectedProperty
Public Shared ReadOnly IsPartiallySelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPartiallySelected dependency property.
See Also

Reference

EnumListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker Class

EnumPicker Class
Represents an Enum picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsEnumPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumPicker : PickerBase
Public Class EnumPicker
    Inherits PickerBase

The EnumPicker type exposes the following members.

Constructors
 | Name | Description
Public method | EnumPicker | Initializes an instance of the EnumPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker Constructor

EnumPicker Constructor
Initializes an instance of the EnumPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumPicker()
Public Sub New
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker Properties

EnumPicker Properties

The EnumPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | EnumSortComparer | Gets or sets the IComparerT used to sort the enumeration values.
Public property | EnumType | Gets or sets the enumeration type.
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseDisplayAttributes | Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.EnumSortComparer Property

EnumPickerEnumSortComparer Property
Gets or sets the IComparerT used to sort the enumeration values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
The IComparerT used to sort the enumeration values; otherwise to indicate no sorting, which will use the order the enumeration values are defined.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.EnumType Property

EnumPickerEnumType Property
Gets or sets the enumeration type.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
The enumeration type.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.UseDisplayAttributes Property

EnumPickerUseDisplayAttributes Property
Gets or sets a value indicating whether enumeration values should be displayed using an associated DisplayAttribute, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
true if enumeration values should be displayed using an associated DisplayAttribute, if any; otherwise false. The default value is false.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.Value Property

EnumPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
The value of the control.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker Methods

EnumPicker Methods

The EnumPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker Events

EnumPicker Events

The EnumPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.ValueChanged Event

EnumPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker Fields

EnumPicker Fields

The EnumPicker type exposes the following members.

Fields
Name | Description
EnumSortComparerProperty | Identifies the EnumSortComparer dependency property. This field is read-only.
EnumTypeProperty | Identifies the EnumType dependency property. This field is read-only.
UseDisplayAttributesProperty | Identifies the UseDisplayAttributes dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.EnumSortComparerProperty Field

EnumPickerEnumSortComparerProperty Field
Identifies the EnumSortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumSortComparerProperty
Public Shared ReadOnly EnumSortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumSortComparer dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.EnumTypeProperty Field

EnumPickerEnumTypeProperty Field
Identifies the EnumType dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty EnumTypeProperty
Public Shared ReadOnly EnumTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the EnumType dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.UseDisplayAttributesProperty Field

EnumPickerUseDisplayAttributesProperty Field
Identifies the UseDisplayAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty UseDisplayAttributesProperty
Public Shared ReadOnly UseDisplayAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the UseDisplayAttributes dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


EnumPicker.ValueProperty Field

EnumPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

EnumPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider Class

GradientStopSlider Class
A slider for manipulating gradient stops.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.EditorsGradientStopSlider

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GradientStopSlider : Control
Public Class GradientStopSlider
    Inherits Control

The GradientStopSlider type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopSlider | Initializes an instance of the GradientStopSlider class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveBrush | Gets or sets the Brush to render and adjust with the slider.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AddStopCommand | Gets the ICommand that calls the AddStop method.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAddStops | Gets or sets whether stops can be added.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRemoveStops | Gets or sets whether stops can be removed.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RemoveSelectedStopCommand | Gets the ICommand that calls the RemoveSelectedStop method.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ReverseStopsCommand | Gets the ICommand that calls the ReverseStops method.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | SelectedStopIndex | Gets or sets the index of the selected stop.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TrackGradientBrush | Gets the resolved GradientBrush to render in the track and adjust with the slider.
Public property | TrackHeight | Gets or sets the height of the slider track.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | AddStop | Adds a new gradient stop.
Public method | AddStop(NullableDouble) | Adds a new gradient stop.
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the control, such as when an external change is made to ActiveBrush that is unable to be detected.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | RemoveSelectedStop | Removes the selected gradient stop.
Public method | ReverseStops | Reverses the gradient stops in the ActiveBrush.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ActiveBrushProperty | Identifies the ActiveBrush dependency property. This field is read-only.
CanAddStopsProperty | Identifies the CanAddStops dependency property. This field is read-only.
CanRemoveStopsProperty | Identifies the CanRemoveStops dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
SelectedStopIndexProperty | Identifies the SelectedStopIndex dependency property. This field is read-only.
TrackGradientBrushProperty | Identifies the TrackGradientBrush dependency property. This field is read-only.
TrackHeightProperty | Identifies the TrackHeight dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider Constructor

GradientStopSlider Constructor
Initializes an instance of the GradientStopSlider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GradientStopSlider()
Public Sub New
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider Properties

GradientStopSlider Properties

The GradientStopSlider type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveBrush | Gets or sets the Brush to render and adjust with the slider.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AddStopCommand | Gets the ICommand that calls the AddStop method.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAddStops | Gets or sets whether stops can be added.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRemoveStops | Gets or sets whether stops can be removed.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RemoveSelectedStopCommand | Gets the ICommand that calls the RemoveSelectedStop method.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ReverseStopsCommand | Gets the ICommand that calls the ReverseStops method.
Public property | SelectedColor | Gets or sets the currently selected Color.
Public property | SelectedStopIndex | Gets or sets the index of the selected stop.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TrackGradientBrush | Gets the resolved GradientBrush to render in the track and adjust with the slider.
Public property | TrackHeight | Gets or sets the height of the slider track.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.ActiveBrush Property

GradientStopSliderActiveBrush Property
Gets or sets the Brush to render and adjust with the slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ActiveBrush { get; set; }
Public Property ActiveBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to render and adjust with the slider.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.AddStopCommand Property

GradientStopSliderAddStopCommand Property
Gets the ICommand that calls the AddStop method.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand AddStopCommand { get; }
Public ReadOnly Property AddStopCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that calls the AddStop method.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.CanAddStops Property

GradientStopSliderCanAddStops Property
Gets or sets whether stops can be added.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAddStops { get; set; }
Public Property CanAddStops As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stops can be added; otherwise, false. The default value is true.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.CanRemoveStops Property

GradientStopSliderCanRemoveStops Property
Gets or sets whether stops can be removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanRemoveStops { get; set; }
Public Property CanRemoveStops As Boolean
    Get
    Set

Property Value

Type: Boolean
true if stops can be removed; otherwise, false. The default value is true.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.RemoveSelectedStopCommand Property

GradientStopSliderRemoveSelectedStopCommand Property
Gets the ICommand that calls the RemoveSelectedStop method.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RemoveSelectedStopCommand { get; }
Public ReadOnly Property RemoveSelectedStopCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that calls the RemoveSelectedStop method.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.ReverseStopsCommand Property

GradientStopSliderReverseStopsCommand Property
Gets the ICommand that calls the ReverseStops method.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ReverseStopsCommand { get; }
Public ReadOnly Property ReverseStopsCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that calls the ReverseStops method.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.SelectedColor Property

GradientStopSliderSelectedColor Property
Gets or sets the currently selected Color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set

Property Value

Type: Color
The currently selected Color.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.SelectedStopIndex Property

GradientStopSliderSelectedStopIndex Property
Gets or sets the index of the selected stop.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SelectedStopIndex { get; set; }
Public Property SelectedStopIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index of the selected stop.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.TrackGradientBrush Property

GradientStopSliderTrackGradientBrush Property
Gets the resolved GradientBrush to render in the track and adjust with the slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GradientBrush TrackGradientBrush { get; }
Public ReadOnly Property TrackGradientBrush As GradientBrush
    Get

Property Value

Type: GradientBrush
The GradientBrush to render in the track and adjust with the slider.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.TrackHeight Property

GradientStopSliderTrackHeight Property
Gets or sets the height of the slider track.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TrackHeight { get; set; }
Public Property TrackHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the slider track. The default value is 12.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider Methods

GradientStopSlider Methods

The GradientStopSlider type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | AddStop | Adds a new gradient stop.
Public method | AddStop(NullableDouble) | Adds a new gradient stop.
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the control, such as when an external change is made to ActiveBrush that is unable to be detected.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | RemoveSelectedStop | Removes the selected gradient stop.
Public method | ReverseStops | Reverses the gradient stops in the ActiveBrush.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.AddStop Method

GradientStopSliderAddStop Method
Overload List
 | Name | Description
Public method | AddStop | Adds a new gradient stop.
Public method | AddStop(NullableDouble) | Adds a new gradient stop.
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.AddStop Method

GradientStopSliderAddStop Method
Adds a new gradient stop.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddStop()
Public Sub AddStop
See Also

Reference

GradientStopSlider Class
AddStop Overload
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.AddStop Method (Nullable(Double))

GradientStopSliderAddStop Method (NullableDouble)
Adds a new gradient stop.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddStop(
    Nullable<double> stopOffset
)
Public Sub AddStop (
    stopOffset As Nullable(Of Double)
)

Parameters

stopOffset
Type: SystemNullable Double
The optional specific offset for the new gradient stop.
See Also

Reference

GradientStopSlider Class
AddStop Overload
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.OnApplyTemplate Method

GradientStopSliderOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.OnCreateAutomationPeer Method

GradientStopSliderOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.Refresh Method

GradientStopSliderRefresh Method
Refreshes the control, such as when an external change is made to ActiveBrush that is unable to be detected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.RemoveSelectedStop Method

GradientStopSliderRemoveSelectedStop Method
Removes the selected gradient stop.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveSelectedStop()
Public Sub RemoveSelectedStop
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.ReverseStops Method

GradientStopSliderReverseStops Method
Reverses the gradient stops in the ActiveBrush.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ReverseStops()
Public Sub ReverseStops
Remarks
Gradient stops at offset 1.0 will be moved to offset 0.0 gradient stops at offset 0.0 will be moved to offset 1.0. Gradient stops at offset 0.5 will not be changed.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider Events

GradientStopSlider Events

The GradientStopSlider type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider Fields

GradientStopSlider Fields

The GradientStopSlider type exposes the following members.

Fields
Name | Description
ActiveBrushProperty | Identifies the ActiveBrush dependency property. This field is read-only.
CanAddStopsProperty | Identifies the CanAddStops dependency property. This field is read-only.
CanRemoveStopsProperty | Identifies the CanRemoveStops dependency property. This field is read-only.
SelectedColorProperty | Identifies the SelectedColor dependency property. This field is read-only.
SelectedStopIndexProperty | Identifies the SelectedStopIndex dependency property. This field is read-only.
TrackGradientBrushProperty | Identifies the TrackGradientBrush dependency property. This field is read-only.
TrackHeightProperty | Identifies the TrackHeight dependency property. This field is read-only.
Top
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.ActiveBrushProperty Field

GradientStopSliderActiveBrushProperty Field
Identifies the ActiveBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveBrushProperty
Public Shared ReadOnly ActiveBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveBrush dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.CanAddStopsProperty Field

GradientStopSliderCanAddStopsProperty Field
Identifies the CanAddStops dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAddStopsProperty
Public Shared ReadOnly CanAddStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAddStops dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.CanRemoveStopsProperty Field

GradientStopSliderCanRemoveStopsProperty Field
Identifies the CanRemoveStops dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRemoveStopsProperty
Public Shared ReadOnly CanRemoveStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRemoveStops dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.SelectedColorProperty Field

GradientStopSliderSelectedColorProperty Field
Identifies the SelectedColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedColorProperty
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedColor dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.SelectedStopIndexProperty Field

GradientStopSliderSelectedStopIndexProperty Field
Identifies the SelectedStopIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedStopIndexProperty
Public Shared ReadOnly SelectedStopIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedStopIndex dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.TrackGradientBrushProperty Field

GradientStopSliderTrackGradientBrushProperty Field
Identifies the TrackGradientBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TrackGradientBrushProperty
Public Shared ReadOnly TrackGradientBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TrackGradientBrush dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GradientStopSlider.TrackHeightProperty Field

GradientStopSliderTrackHeightProperty Field
Identifies the TrackHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TrackHeightProperty
Public Shared ReadOnly TrackHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TrackHeight dependency property.
See Also

Reference

GradientStopSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox Class

GuidEditBox Class
Represents an Guid edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Guid
ActiproSoftware.UI.Xaml.Controls.EditorsGuidEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GuidEditBox : PartEditBoxBase<Nullable<Guid>>
Public Class GuidEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Guid))

The GuidEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | GuidEditBox | Initializes an instance of the GuidEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the GUID format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewGuidButtonToolTip | Gets or sets the tooltip for the new GUID button.
Public property | NewGuidCommand | Gets the ICommand that can be used to generate a new GUID.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved GUID format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides PartEditBoxBaseTOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
NewGuidButtonToolTipProperty | Identifies the NewGuidButtonToolTip dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox Constructor

GuidEditBox Constructor
Initializes an instance of the GuidEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GuidEditBox()
Public Sub New
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox Properties

GuidEditBox Properties

The GuidEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the GUID format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NewGuidButtonToolTip | Gets or sets the tooltip for the new GUID button.
Public property | NewGuidCommand | Gets the ICommand that can be used to generate a new GUID.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved GUID format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.Format Property

GuidEditBoxFormat Property
Gets or sets the GUID format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The GUID format string. The default value is "D".
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.NewGuidButtonToolTip Property

GuidEditBoxNewGuidButtonToolTip Property
Gets or sets the tooltip for the new GUID button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object NewGuidButtonToolTip { get; set; }
Public Property NewGuidButtonToolTip As Object
    Get
    Set

Property Value

Type: Object
The tooltip for the new GUID button.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.NewGuidCommand Property

GuidEditBoxNewGuidCommand Property
Gets the ICommand that can be used to generate a new GUID.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand NewGuidCommand { get; }
Public ReadOnly Property NewGuidCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to generate a new GUID.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.ResolvedFormat Property

GuidEditBoxResolvedFormat Property
Gets the resolved GUID format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved GUID format string.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox Methods

GuidEditBox Methods

The GuidEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides PartEditBoxBaseTOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.ConvertToString Method

GuidEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Guid> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Guid)
) As String

Parameters

valueToConvert
Type: SystemNullable Guid
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.CreateIncrementalChangeRequest Method

GuidEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Guid>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Guid))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Guid
The incremental change (spin) request that was created.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.GenerateParts Method

GuidEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.IsValidValue Method

GuidEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Guid> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Guid)
) As Boolean

Parameters

value
Type: SystemNullable Guid
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.OnKeyDown Method

GuidEditBoxOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.RaiseValueChangedEvent Method

GuidEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.ResetValue Method

GuidEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.TryConvertFromString Method

GuidEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Guid> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Guid)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Guid
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox Events

GuidEditBox Events

The GuidEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.ValueChanged Event

GuidEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox Fields

GuidEditBox Fields

The GuidEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
NewGuidButtonToolTipProperty | Identifies the NewGuidButtonToolTip dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
Top
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.FormatProperty Field

GuidEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.NewGuidButtonToolTipProperty Field

GuidEditBoxNewGuidButtonToolTipProperty Field
Identifies the NewGuidButtonToolTip dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NewGuidButtonToolTipProperty
Public Shared ReadOnly NewGuidButtonToolTipProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NewGuidButtonToolTip dependency property.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


GuidEditBox.ResolvedFormatProperty Field

GuidEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

GuidEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker Class

HsbColorPicker Class
Represents a color picker control that allows for visual selection of hue, saturation, and brightness.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsHsbColorPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HsbColorPicker : PickerBase
Public Class HsbColorPicker
    Inherits PickerBase

The HsbColorPicker type exposes the following members.

Constructors
 | Name | Description
Public method | HsbColorPicker | Initializes an instance of the HsbColorPicker class.
Top
Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the color.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the color.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the color.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the color.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker Constructor

HsbColorPicker Constructor
Initializes an instance of the HsbColorPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HsbColorPicker()
Public Sub New
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker Properties

HsbColorPicker Properties

The HsbColorPicker type exposes the following members.

Properties
 | Name | Description
Public property | A | Gets or sets the alpha transparency component (0 - 255) of the color.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the HSB brightness component (0 - 1.0) of the color.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the HSB hue component (0 - 359.00) of the color.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Saturation | Gets or sets the HSB saturation component (0 - 1.0) of the color.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.A Property

HsbColorPickerA Property
Gets or sets the alpha transparency component (0 - 255) of the color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int A { get; set; }
Public Property A As Integer
    Get
    Set

Property Value

Type: Int32
The alpha transparency component of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.Brightness Property

HsbColorPickerBrightness Property
Gets or sets the HSB brightness component (0 - 1.0) of the color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
The HSB brightness component (0 - 1.0) of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.Hue Property

HsbColorPickerHue Property
Gets or sets the HSB hue component (0 - 359.00) of the color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The HSB hue component (0 - 359.00) of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.Saturation Property

HsbColorPickerSaturation Property
Gets or sets the HSB saturation component (0 - 1.0) of the color.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
The HSB saturation component (0 - 1.0) of the color.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker Methods

HsbColorPicker Methods

The HsbColorPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.OnApplyTemplate Method

HsbColorPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker Events

HsbColorPicker Events

The HsbColorPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.BrightnessChanged Event

HsbColorPickerBrightnessChanged Event
Occurs after the Brightness property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler BrightnessChanged
Public Event BrightnessChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.HueChanged Event

HsbColorPickerHueChanged Event
Occurs after the Hue property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler HueChanged
Public Event HueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.SaturationChanged Event

HsbColorPickerSaturationChanged Event
Occurs after the Saturation property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler SaturationChanged
Public Event SaturationChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker Fields

HsbColorPicker Fields

The HsbColorPicker type exposes the following members.

Fields
Name | Description
AProperty | Identifies the A dependency property. This field is read-only.
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.AProperty Field

HsbColorPickerAProperty Field
Identifies the A dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AProperty
Public Shared ReadOnly AProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the A dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.BrightnessProperty Field

HsbColorPickerBrightnessProperty Field
Identifies the Brightness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessProperty
Public Shared ReadOnly BrightnessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Brightness dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.HueProperty Field

HsbColorPickerHueProperty Field
Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


HsbColorPicker.SaturationProperty Field

HsbColorPickerSaturationProperty Field
Identifies the Saturation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationProperty
Public Shared ReadOnly SaturationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Saturation dependency property.
See Also

Reference

HsbColorPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox Class

Int16EditBox Class
Represents an Int16 edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int16
ActiproSoftware.UI.Xaml.Controls.EditorsInt16EditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int16EditBox : PartEditBoxBase<Nullable<short>>
Public Class Int16EditBox
    Inherits PartEditBoxBase(Of Nullable(Of Short))

The Int16EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int16EditBox | Initializes an instance of the Int16EditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox Constructor

Int16EditBox Constructor
Initializes an instance of the Int16EditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int16EditBox()
Public Sub New
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox Properties

Int16EditBox Properties

The Int16EditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.CalculatorPopupPickerStyle Property

Int16EditBoxCalculatorPopupPickerStyle Property
Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.Format Property

Int16EditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.LargeChange Property

Int16EditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short LargeChange { get; set; }
Public Property LargeChange As Short
    Get
    Set

Property Value

Type: Int16
The large change value. The default value is 5.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.Maximum Property

Int16EditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
The highest possible value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.Minimum Property

Int16EditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
The lowest possible value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.PickerKind Property

Int16EditBoxPickerKind Property
Gets or sets an Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int16EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int16EditBoxPickerKind
    Get
    Set

Property Value

Type: Int16EditBoxPickerKind
An Int16EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.ResolvedFormat Property

Int16EditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.SmallChange Property

Int16EditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
The small change value. The default value is 1.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox Methods

Int16EditBox Methods

The Int16EditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.ConvertToString Method

Int16EditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<short> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Short)
) As String

Parameters

valueToConvert
Type: SystemNullable Int16
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.CreateIncrementalChangeRequest Method

Int16EditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<short>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Short))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int16
The incremental change (spin) request that was created.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.GenerateParts Method

Int16EditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.IsValidValue Method

Int16EditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<short> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Short)
) As Boolean

Parameters

value
Type: SystemNullable Int16
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.RaiseValueChangedEvent Method

Int16EditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.ResetValue Method

Int16EditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.TryConvertFromString Method

Int16EditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<short> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Short)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int16
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox Events

Int16EditBox Events

The Int16EditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.ValueChanged Event

Int16EditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox Fields

Int16EditBox Fields

The Int16EditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.CalculatorPopupPickerStyleProperty Field

Int16EditBoxCalculatorPopupPickerStyleProperty Field
Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.FormatProperty Field

Int16EditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.LargeChangeProperty Field

Int16EditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.MaximumProperty Field

Int16EditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.MinimumProperty Field

Int16EditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.PickerKindProperty Field

Int16EditBoxPickerKindProperty Field
Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.ResolvedFormatProperty Field

Int16EditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBox.SmallChangeProperty Field

Int16EditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int16EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBoxPickerKind Class

Int16EditBoxPickerKind Class
Specifies the kind of Style to apply to the Int16Picker used within a Int16EditBox's popup.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsInt16EditBoxPickerKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class Int16EditBoxPickerKind : Enum
Public NotInheritable Class Int16EditBoxPickerKind
    Inherits Enum

The Int16EditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int16Picker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBoxPickerKind Methods

Int16EditBoxPickerKind Methods

The Int16EditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Int16EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBoxPickerKind Fields

Int16EditBoxPickerKind Fields

The Int16EditBoxPickerKind type exposes the following members.

Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int16Picker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

Int16EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBoxPickerKind.Calculator Field

Int16EditBoxPickerKindCalculator Field
Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Int16EditBoxPickerKind Calculator = 1
Public Const Calculator As Int16EditBoxPickerKind = 1

Field Value

Type: Int16EditBoxPickerKind
See Also

Reference

Int16EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBoxPickerKind.Default Field

Int16EditBoxPickerKindDefault Field
Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int16Picker style, which is templated to contain a radial slider control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Int16EditBoxPickerKind Default = 0
Public Const Default As Int16EditBoxPickerKind = 0

Field Value

Type: Int16EditBoxPickerKind
See Also

Reference

Int16EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16EditBoxPickerKind.value__ Field

Int16EditBoxPickerKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.Int16EditBoxPickerKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Int16EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker Class

Int16Picker Class
Represents an Int16 picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsInt16Picker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int16Picker : RadialSliderPickerBase
Public Class Int16Picker
    Inherits RadialSliderPickerBase

The Int16Picker type exposes the following members.

Constructors
 | Name | Description
Public method | Int16Picker | Initializes an instance of the Int16Picker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker Constructor

Int16Picker Constructor
Initializes an instance of the Int16Picker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int16Picker()
Public Sub New
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker Properties

Int16Picker Properties

The Int16Picker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.Maximum Property

Int16PickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
The highest possible value.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.Minimum Property

Int16PickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
The lowest possible value.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.SmallChange Property

Int16PickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
The small change value. The default value is 1.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.Value Property

Int16PickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Value { get; set; }
Public Property Value As Short
    Get
    Set

Property Value

Type: Int16
The value of the control.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker Methods

Int16Picker Methods

The Int16Picker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.OnApplyTemplate Method

Int16PickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker Events

Int16Picker Events

The Int16Picker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.ValueChanged Event

Int16PickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker Fields

Int16Picker Fields

The Int16Picker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.MaximumProperty Field

Int16PickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.MinimumProperty Field

Int16PickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.SmallChangeProperty Field

Int16PickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int16Picker.ValueProperty Field

Int16PickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int16Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox Class

Int32EditBox Class
Represents an Int32 edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int32
ActiproSoftware.UI.Xaml.Controls.EditorsInt32EditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int32EditBox : PartEditBoxBase<Nullable<int>>
Public Class Int32EditBox
    Inherits PartEditBoxBase(Of Nullable(Of Integer))

The Int32EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int32EditBox | Initializes an instance of the Int32EditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox Constructor

Int32EditBox Constructor
Initializes an instance of the Int32EditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int32EditBox()
Public Sub New
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox Properties

Int32EditBox Properties

The Int32EditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.CalculatorPopupPickerStyle Property

Int32EditBoxCalculatorPopupPickerStyle Property
Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.Format Property

Int32EditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.LargeChange Property

Int32EditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int LargeChange { get; set; }
Public Property LargeChange As Integer
    Get
    Set

Property Value

Type: Int32
The large change value. The default value is 5.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.Maximum Property

Int32EditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
The highest possible value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.Minimum Property

Int32EditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The lowest possible value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.PickerKind Property

Int32EditBoxPickerKind Property
Gets or sets an Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int32EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int32EditBoxPickerKind
    Get
    Set

Property Value

Type: Int32EditBoxPickerKind
An Int32EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.ResolvedFormat Property

Int32EditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.SmallChange Property

Int32EditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
The small change value. The default value is 1.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox Methods

Int32EditBox Methods

The Int32EditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.ConvertToString Method

Int32EditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<int> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Integer)
) As String

Parameters

valueToConvert
Type: SystemNullable Int32
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.CreateIncrementalChangeRequest Method

Int32EditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<int>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Integer))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int32
The incremental change (spin) request that was created.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.GenerateParts Method

Int32EditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.IsValidValue Method

Int32EditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<int> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Integer)
) As Boolean

Parameters

value
Type: SystemNullable Int32
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.RaiseValueChangedEvent Method

Int32EditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.ResetValue Method

Int32EditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.TryConvertFromString Method

Int32EditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<int> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Integer)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int32
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox Events

Int32EditBox Events

The Int32EditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.ValueChanged Event

Int32EditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox Fields

Int32EditBox Fields

The Int32EditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.CalculatorPopupPickerStyleProperty Field

Int32EditBoxCalculatorPopupPickerStyleProperty Field
Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.FormatProperty Field

Int32EditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.LargeChangeProperty Field

Int32EditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.MaximumProperty Field

Int32EditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.MinimumProperty Field

Int32EditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.PickerKindProperty Field

Int32EditBoxPickerKindProperty Field
Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.ResolvedFormatProperty Field

Int32EditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBox.SmallChangeProperty Field

Int32EditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int32EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBoxPickerKind Class

Int32EditBoxPickerKind Class
Specifies the kind of Style to apply to the Int32Picker used within a Int32EditBox's popup.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsInt32EditBoxPickerKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class Int32EditBoxPickerKind : Enum
Public NotInheritable Class Int32EditBoxPickerKind
    Inherits Enum

The Int32EditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int32Picker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBoxPickerKind Methods

Int32EditBoxPickerKind Methods

The Int32EditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Int32EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBoxPickerKind Fields

Int32EditBoxPickerKind Fields

The Int32EditBoxPickerKind type exposes the following members.

Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int32Picker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

Int32EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBoxPickerKind.Calculator Field

Int32EditBoxPickerKindCalculator Field
Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Int32EditBoxPickerKind Calculator = 1
Public Const Calculator As Int32EditBoxPickerKind = 1

Field Value

Type: Int32EditBoxPickerKind
See Also

Reference

Int32EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBoxPickerKind.Default Field

Int32EditBoxPickerKindDefault Field
Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int32Picker style, which is templated to contain a radial slider control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Int32EditBoxPickerKind Default = 0
Public Const Default As Int32EditBoxPickerKind = 0

Field Value

Type: Int32EditBoxPickerKind
See Also

Reference

Int32EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32EditBoxPickerKind.value__ Field

Int32EditBoxPickerKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.Int32EditBoxPickerKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Int32EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker Class

Int32Picker Class
Represents an Int32 picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsInt32Picker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int32Picker : RadialSliderPickerBase
Public Class Int32Picker
    Inherits RadialSliderPickerBase

The Int32Picker type exposes the following members.

Constructors
 | Name | Description
Public method | Int32Picker | Initializes an instance of the Int32Picker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker Constructor

Int32Picker Constructor
Initializes an instance of the Int32Picker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int32Picker()
Public Sub New
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker Properties

Int32Picker Properties

The Int32Picker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.Maximum Property

Int32PickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
The highest possible value.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.Minimum Property

Int32PickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
The lowest possible value.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.SmallChange Property

Int32PickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
The small change value. The default value is 1.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.Value Property

Int32PickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set

Property Value

Type: Int32
The value of the control.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker Methods

Int32Picker Methods

The Int32Picker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.OnApplyTemplate Method

Int32PickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker Events

Int32Picker Events

The Int32Picker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.ValueChanged Event

Int32PickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker Fields

Int32Picker Fields

The Int32Picker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.MaximumProperty Field

Int32PickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.MinimumProperty Field

Int32PickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.SmallChangeProperty Field

Int32PickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int32Picker.ValueProperty Field

Int32PickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int32Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox Class

Int64EditBox Class
Represents an Int64 edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Int64
ActiproSoftware.UI.Xaml.Controls.EditorsInt64EditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int64EditBox : PartEditBoxBase<Nullable<long>>
Public Class Int64EditBox
    Inherits PartEditBoxBase(Of Nullable(Of Long))

The Int64EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | Int64EditBox | Initializes an instance of the Int64EditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox Constructor

Int64EditBox Constructor
Initializes an instance of the Int64EditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int64EditBox()
Public Sub New
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox Properties

Int64EditBox Properties

The Int64EditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.CalculatorPopupPickerStyle Property

Int64EditBoxCalculatorPopupPickerStyle Property
Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.Format Property

Int64EditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "D".
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.LargeChange Property

Int64EditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long LargeChange { get; set; }
Public Property LargeChange As Long
    Get
    Set

Property Value

Type: Int64
The large change value. The default value is 5.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.Maximum Property

Int64EditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
The highest possible value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.Minimum Property

Int64EditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
The lowest possible value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.PickerKind Property

Int64EditBoxPickerKind Property
Gets or sets an Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int64EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int64EditBoxPickerKind
    Get
    Set

Property Value

Type: Int64EditBoxPickerKind
An Int64EditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.ResolvedFormat Property

Int64EditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.SmallChange Property

Int64EditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
The small change value. The default value is 1.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox Methods

Int64EditBox Methods

The Int64EditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.ConvertToString Method

Int64EditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<long> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Long)
) As String

Parameters

valueToConvert
Type: SystemNullable Int64
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.CreateIncrementalChangeRequest Method

Int64EditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<long>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Long))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Int64
The incremental change (spin) request that was created.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.GenerateParts Method

Int64EditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.IsValidValue Method

Int64EditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<long> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Long)
) As Boolean

Parameters

value
Type: SystemNullable Int64
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.RaiseValueChangedEvent Method

Int64EditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.ResetValue Method

Int64EditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.TryConvertFromString Method

Int64EditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<long> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Long)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Int64
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox Events

Int64EditBox Events

The Int64EditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.ValueChanged Event

Int64EditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox Fields

Int64EditBox Fields

The Int64EditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.CalculatorPopupPickerStyleProperty Field

Int64EditBoxCalculatorPopupPickerStyleProperty Field
Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.FormatProperty Field

Int64EditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.LargeChangeProperty Field

Int64EditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.MaximumProperty Field

Int64EditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.MinimumProperty Field

Int64EditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.PickerKindProperty Field

Int64EditBoxPickerKindProperty Field
Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.ResolvedFormatProperty Field

Int64EditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBox.SmallChangeProperty Field

Int64EditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int64EditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBoxPickerKind Class

Int64EditBoxPickerKind Class
Specifies the kind of Style to apply to the Int64Picker used within a Int64EditBox's popup.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsInt64EditBoxPickerKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class Int64EditBoxPickerKind : Enum
Public NotInheritable Class Int64EditBoxPickerKind
    Inherits Enum

The Int64EditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int64Picker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBoxPickerKind Methods

Int64EditBoxPickerKind Methods

The Int64EditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

Int64EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBoxPickerKind Fields

Int64EditBoxPickerKind Fields

The Int64EditBoxPickerKind type exposes the following members.

Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int64Picker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

Int64EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBoxPickerKind.Calculator Field

Int64EditBoxPickerKindCalculator Field
Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Int64EditBoxPickerKind Calculator = 1
Public Const Calculator As Int64EditBoxPickerKind = 1

Field Value

Type: Int64EditBoxPickerKind
See Also

Reference

Int64EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBoxPickerKind.Default Field

Int64EditBoxPickerKindDefault Field
Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default Int64Picker style, which is templated to contain a radial slider control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const Int64EditBoxPickerKind Default = 0
Public Const Default As Int64EditBoxPickerKind = 0

Field Value

Type: Int64EditBoxPickerKind
See Also

Reference

Int64EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64EditBoxPickerKind.value__ Field

Int64EditBoxPickerKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.Int64EditBoxPickerKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

Int64EditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker Class

Int64Picker Class
Represents an Int64 picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsInt64Picker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int64Picker : RadialSliderPickerBase
Public Class Int64Picker
    Inherits RadialSliderPickerBase

The Int64Picker type exposes the following members.

Constructors
 | Name | Description
Public method | Int64Picker | Initializes an instance of the Int64Picker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker Constructor

Int64Picker Constructor
Initializes an instance of the Int64Picker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int64Picker()
Public Sub New
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker Properties

Int64Picker Properties

The Int64Picker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.Maximum Property

Int64PickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
The highest possible value.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.Minimum Property

Int64PickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
The lowest possible value.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.SmallChange Property

Int64PickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
The small change value. The default value is 1.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.Value Property

Int64PickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set

Property Value

Type: Int64
The value of the control.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker Methods

Int64Picker Methods

The Int64Picker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.OnApplyTemplate Method

Int64PickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker Events

Int64Picker Events

The Int64Picker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.ValueChanged Event

Int64PickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker Fields

Int64Picker Fields

The Int64Picker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.MaximumProperty Field

Int64PickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.MinimumProperty Field

Int64PickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.SmallChangeProperty Field

Int64PickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Int64Picker.ValueProperty Field

Int64PickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Int64Picker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox Class

MaskedTextBox Class
Represents a TextBox that restricts input based on a specified mask.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsTextBox
ActiproSoftware.UI.Xaml.Controls.EditorsMaskedTextBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MaskedTextBox : TextBox
Public Class MaskedTextBox
    Inherits TextBox

The MaskedTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedTextBox | Initializes an instance of the MaskedTextBox class.
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets the value that determines whether the text box allows and displays the newline or return characters. (Inherited from TextBox.)
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredCandidateWindowAlignment | (Inherited from TextBox.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from TextBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from TextBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScope | Gets or sets the context for input used by this TextBox . (Inherited from TextBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | IsColorFontEnabled | Gets or sets a value that determines whether color glyphs, such as emoji, are shown in color. (Inherited from TextBox.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMatched | Gets whether the input text successfully matches the pattern.
Public property | IsReadOnly | Gets or sets the value that determines if the user can change the text in the text box. (Inherited from TextBox.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpellCheckEnabled | Gets or sets a value that specifies whether the TextBox input interacts with a spell check engine. (Inherited from TextBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextPredictionEnabled | Gets or sets a value that determines whether text prediction features ("autocomplete") should be enabled for this TextBox. (Inherited from TextBox.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the value that specifies the maximum number of characters allowed for user input. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from TextBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PreventKeyboardDisplayOnProgrammaticFocus | Gets or sets a value that indicates whether the on-screen keyboard is shown when the control receives focus programmatically. (Inherited from TextBox.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionHighlightColor | Gets or sets the brush used to highlight the selected text. (Inherited from TextBox.)
Public property | SelectionLength | Gets or sets the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionStart | Gets or sets the starting position of the text selected in the text box. (Inherited from TextBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets how the text should be aligned in the text box. (Inherited from TextBox.)
Public property | TextReadingOrder | (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how line breaking occurs if a line of text extends beyond the available width of the text box. (Inherited from TextBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLinguisticAlternativesAsync | (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex | Returns a rectangular region for the leading or trailing edge of a character at a specific character index. (Inherited from TextBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects the entire contents of the text box. (Inherited from TextBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | CandidateWindowBoundsChanged | (Inherited from TextBox.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextMenuOpening | Occurs when the system processes an interaction that displays a context menu. (Inherited from TextBox.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | IsMatchedChanged | Occurs after the IsMatched property value changes.
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Paste | Occurs when text is pasted into the control. (Inherited from TextBox.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TextChanged | Occurs when content changes in the text box. (Inherited from TextBox.)
Public event | TextChanging | (Inherited from TextBox.)
Public event | TextCompositionChanged | (Inherited from TextBox.)
Public event | TextCompositionEnded | (Inherited from TextBox.)
Public event | TextCompositionStarted | (Inherited from TextBox.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsCaseAutoCorrectedProperty | Identifies the IsCaseAutoCorrected dependency property. This field is read-only.
IsCaseSensitiveProperty | Identifies the IsCaseSensitive dependency property. This field is read-only.
IsMatchedProperty | Identifies the IsMatched dependency property. This field is read-only.
MaskKindProperty | Identifies the MaskKind dependency property. This field is read-only.
MaskProperty | Identifies the Mask dependency property. This field is read-only.
PromptCharProperty | Identifies the PromptChar dependency property. This field is read-only.
PromptVisibilityProperty | Identifies the PromptVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox Constructor

MaskedTextBox Constructor
Initializes an instance of the MaskedTextBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MaskedTextBox()
Public Sub New
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox Properties

MaskedTextBox Properties

The MaskedTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets the value that determines whether the text box allows and displays the newline or return characters. (Inherited from TextBox.)
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredCandidateWindowAlignment | (Inherited from TextBox.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from TextBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from TextBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScope | Gets or sets the context for input used by this TextBox . (Inherited from TextBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsCaseAutoCorrected | Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.
Public property | IsCaseSensitive | Gets or sets whether the mask is case sensitive.
Public property | IsColorFontEnabled | Gets or sets a value that determines whether color glyphs, such as emoji, are shown in color. (Inherited from TextBox.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMatched | Gets whether the input text successfully matches the pattern.
Public property | IsReadOnly | Gets or sets the value that determines if the user can change the text in the text box. (Inherited from TextBox.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpellCheckEnabled | Gets or sets a value that specifies whether the TextBox input interacts with a spell check engine. (Inherited from TextBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextPredictionEnabled | Gets or sets a value that determines whether text prediction features ("autocomplete") should be enabled for this TextBox. (Inherited from TextBox.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Mask | Gets or sets the text that designates the input mask.
Public property | MaskKind | Gets or sets the kind of input mask.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the value that specifies the maximum number of characters allowed for user input. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from TextBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PreventKeyboardDisplayOnProgrammaticFocus | Gets or sets a value that indicates whether the on-screen keyboard is shown when the control receives focus programmatically. (Inherited from TextBox.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | PromptChar | Gets or sets the character used to indicate required input.
Public property | PromptVisibility | Gets or sets the visibility of mask prompts.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionHighlightColor | Gets or sets the brush used to highlight the selected text. (Inherited from TextBox.)
Public property | SelectionLength | Gets or sets the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionStart | Gets or sets the starting position of the text selected in the text box. (Inherited from TextBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets how the text should be aligned in the text box. (Inherited from TextBox.)
Public property | TextReadingOrder | (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how line breaking occurs if a line of text extends beyond the available width of the text box. (Inherited from TextBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsCaseAutoCorrected Property

MaskedTextBoxIsCaseAutoCorrected Property
Gets or sets whether characters entered will have their case auto-corrected to match the defined mask.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCaseAutoCorrected { get; set; }
Public Property IsCaseAutoCorrected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if characters entered will have their case auto-corrected to match the defined mask; otherwise, false. The default value is false.
Remarks
When this property is set to true, then the IsCaseSensitive property is ignored.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsCaseSensitive Property

MaskedTextBoxIsCaseSensitive Property
Gets or sets whether the mask is case sensitive.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mask is case sensitive; otherwise, false. The default value is false.
Remarks
When the IsCaseAutoCorrected property is set to true, this property is ignored.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsMatched Property

MaskedTextBoxIsMatched Property
Gets whether the input text successfully matches the pattern.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMatched { get; }
Public ReadOnly Property IsMatched As Boolean
    Get

Property Value

Type: Boolean
true if the input text successfully matches the pattern; otherwise, false.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.Mask Property

MaskedTextBoxMask Property
Gets or sets the text that designates the input mask.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set

Property Value

Type: String
The text that designates the input mask. The default value is .
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.MaskKind Property

MaskedTextBoxMaskKind Property
Gets or sets the kind of input mask.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MaskKind MaskKind { get; set; }
Public Property MaskKind As MaskKind
    Get
    Set

Property Value

Type: MaskKind
The kind of input mask. The default value is Regex.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.PromptChar Property

MaskedTextBoxPromptChar Property
Gets or sets the character used to indicate required input.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char PromptChar { get; set; }
Public Property PromptChar As Char
    Get
    Set

Property Value

Type: Char
The character used to indicate required input. The default value is \u2022.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.PromptVisibility Property

MaskedTextBoxPromptVisibility Property
Gets or sets the visibility of mask prompts.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MaskPromptVisibility PromptVisibility { get; set; }
Public Property PromptVisibility As MaskPromptVisibility
    Get
    Set

Property Value

Type: MaskPromptVisibility
A MaskPromptVisibility that indicates the visibility of mask prompts. The default value is FocusedOnly.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox Methods

MaskedTextBox Methods

The MaskedTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLinguisticAlternativesAsync | (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex | Returns a rectangular region for the leading or trailing edge of a character at a specific character index. (Inherited from TextBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects the entire contents of the text box. (Inherited from TextBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.OnGotFocus Method

MaskedTextBoxOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.OnLostFocus Method

MaskedTextBoxOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox Events

MaskedTextBox Events

The MaskedTextBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | CandidateWindowBoundsChanged | (Inherited from TextBox.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextMenuOpening | Occurs when the system processes an interaction that displays a context menu. (Inherited from TextBox.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | IsMatchedChanged | Occurs after the IsMatched property value changes.
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Paste | Occurs when text is pasted into the control. (Inherited from TextBox.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TextChanged | Occurs when content changes in the text box. (Inherited from TextBox.)
Public event | TextChanging | (Inherited from TextBox.)
Public event | TextCompositionChanged | (Inherited from TextBox.)
Public event | TextCompositionEnded | (Inherited from TextBox.)
Public event | TextCompositionStarted | (Inherited from TextBox.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsMatchedChanged Event

MaskedTextBoxIsMatchedChanged Event
Occurs after the IsMatched property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler IsMatchedChanged
Public Event IsMatchedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox Fields

MaskedTextBox Fields

The MaskedTextBox type exposes the following members.

Fields
Name | Description
IsCaseAutoCorrectedProperty | Identifies the IsCaseAutoCorrected dependency property. This field is read-only.
IsCaseSensitiveProperty | Identifies the IsCaseSensitive dependency property. This field is read-only.
IsMatchedProperty | Identifies the IsMatched dependency property. This field is read-only.
MaskKindProperty | Identifies the MaskKind dependency property. This field is read-only.
MaskProperty | Identifies the Mask dependency property. This field is read-only.
PromptCharProperty | Identifies the PromptChar dependency property. This field is read-only.
PromptVisibilityProperty | Identifies the PromptVisibility dependency property. This field is read-only.
Top
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsCaseAutoCorrectedProperty Field

MaskedTextBoxIsCaseAutoCorrectedProperty Field
Identifies the IsCaseAutoCorrected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCaseAutoCorrectedProperty
Public Shared ReadOnly IsCaseAutoCorrectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCaseAutoCorrected dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsCaseSensitiveProperty Field

MaskedTextBoxIsCaseSensitiveProperty Field
Identifies the IsCaseSensitive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCaseSensitiveProperty
Public Shared ReadOnly IsCaseSensitiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCaseSensitive dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.IsMatchedProperty Field

MaskedTextBoxIsMatchedProperty Field
Identifies the IsMatched dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMatchedProperty
Public Shared ReadOnly IsMatchedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMatched dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.MaskKindProperty Field

MaskedTextBoxMaskKindProperty Field
Identifies the MaskKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskKindProperty
Public Shared ReadOnly MaskKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaskKind dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.MaskProperty Field

MaskedTextBoxMaskProperty Field
Identifies the Mask dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaskProperty
Public Shared ReadOnly MaskProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Mask dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.PromptCharProperty Field

MaskedTextBoxPromptCharProperty Field
Identifies the PromptChar dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromptCharProperty
Public Shared ReadOnly PromptCharProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromptChar dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskedTextBox.PromptVisibilityProperty Field

MaskedTextBoxPromptVisibilityProperty Field
Identifies the PromptVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PromptVisibilityProperty
Public Shared ReadOnly PromptVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PromptVisibility dependency property.
See Also

Reference

MaskedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskKind Class

MaskKind Class
Specifies the mask kinds supported by a MaskedTextBox.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsMaskKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MaskKind : Enum
Public NotInheritable Class MaskKind
    Inherits Enum

The MaskKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Regex | The mask is defined as a regular expression.
Public field | value__ |
 | Wildcard | The mask is defined using wild card characters.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskKind Methods

MaskKind Methods

The MaskKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MaskKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskKind Fields

MaskKind Fields

The MaskKind type exposes the following members.

Fields
 | Name | Description
 | Regex | The mask is defined as a regular expression.
Public field | value__ |
 | Wildcard | The mask is defined using wild card characters.
Top
See Also

Reference

MaskKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskKind.Regex Field

MaskKindRegex Field
The mask is defined as a regular expression.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MaskKind Regex = 0
Public Const Regex As MaskKind = 0

Field Value

Type: MaskKind
See Also

Reference

MaskKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskKind.value__ Field

MaskKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.MaskKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MaskKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskKind.Wildcard Field

MaskKindWildcard Field
The mask is defined using wild card characters.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MaskKind Wildcard = 1
Public Const Wildcard As MaskKind = 1

Field Value

Type: MaskKind
See Also

Reference

MaskKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility Class

MaskPromptVisibility Class
Specifies the visibility of mask prompts within a MaskedTextBox.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsMaskPromptVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MaskPromptVisibility : Enum
Public NotInheritable Class MaskPromptVisibility
    Inherits Enum

The MaskPromptVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Always | Prompts will always be visible.
 | FocusedOnly | Prompts will only be visible when the control contains the focus.
 | Never | Prompts will never be visible.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility Methods

MaskPromptVisibility Methods

The MaskPromptVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MaskPromptVisibility Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility Fields

MaskPromptVisibility Fields

The MaskPromptVisibility type exposes the following members.

Fields
 | Name | Description
 | Always | Prompts will always be visible.
 | FocusedOnly | Prompts will only be visible when the control contains the focus.
 | Never | Prompts will never be visible.
Public field | value__ |
Top
See Also

Reference

MaskPromptVisibility Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility.Always Field

MaskPromptVisibilityAlways Field
Prompts will always be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MaskPromptVisibility Always = 1
Public Const Always As MaskPromptVisibility = 1

Field Value

Type: MaskPromptVisibility
See Also

Reference

MaskPromptVisibility Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility.FocusedOnly Field

MaskPromptVisibilityFocusedOnly Field
Prompts will only be visible when the control contains the focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MaskPromptVisibility FocusedOnly = 0
Public Const FocusedOnly As MaskPromptVisibility = 0

Field Value

Type: MaskPromptVisibility
See Also

Reference

MaskPromptVisibility Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility.Never Field

MaskPromptVisibilityNever Field
Prompts will never be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MaskPromptVisibility Never = 2
Public Const Never As MaskPromptVisibility = 2

Field Value

Type: MaskPromptVisibility
See Also

Reference

MaskPromptVisibility Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MaskPromptVisibility.value__ Field

MaskPromptVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.MaskPromptVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MaskPromptVisibility Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar Class

MonthCalendar Class
Represents a month calendar control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendar

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MonthCalendar : Control
Public Class MonthCalendar
    Inherits Control

The MonthCalendar type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendar | Initializes a new instance of the MonthCalendar class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveDate | Gets or sets the active date in the calendar.
Public property | ActiveViewMode | Gets or sets the active view mode of the calendar.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalendarWeekRule | Gets or sets the calendar week rule, which determines how weeks are numbered.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClearButtonStyle | Gets or sets the Style to apply to the Clear button.
Public property | ClearButtonText | Gets or sets the text to display in the Clear button.
Public property | ClearSelectionCommand | Gets the ICommand that is used to clear the selection.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DayItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day items.
Public property | DayItemTemplate | Gets or sets the DataTemplate to use for day items.
Public property | DayNameItemContainerStyle | Gets or sets the Style to apply to day name items.
Public property | DayNameItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day name items.
Public property | DayNameItemTemplate | Gets or sets the DataTemplate to use for day name items.
Public property | DayOfWeekFormatPattern | Gets or sets the format pattern used for DayOfWeek values.
Public property | DecadeItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging decade items.
Public property | DecadeItemTemplate | Gets or sets the DataTemplate to use for decade items.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledDaysOfWeek | Gets or sets the disabled days of the week.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FirstDayOfWeek | Gets or sets the first day of the week.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GoToNextViewCommand | Gets the ICommand that is used to go to the next view.
Public property | GoToPreviousViewCommand | Gets the ICommand that is used to go to the next view.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsClearButtonVisible | Gets or sets whether the clear button is visible.
Public property | IsDateDisabledFunc | Gets or sets a function that is called when a day cell is rendered to determine if it should be disabled.
Public property | IsDayOfWeekSelectionEnabled | Gets or sets whether the day of week headers can be used to select dates.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsTodayButtonVisible | Gets or sets whether the Today button is visible.
Public property | IsTodayHighlighted | Gets or sets whether DateTime.Today is highlighted.
Public property | IsWeekNumberColumnVisible | Gets or sets whether the week number column is visible.
Public property | IsWeekNumberSelectionEnabled | Gets or sets whether the week numbers can be used to select dates.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxSelectionCount | Gets or sets the maximum number of dates that can be selected.
Public property | MaxViewMode | Gets or sets the maximum view mode allowed.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MonthItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging month items.
Public property | MonthItemTemplate | Gets or sets the DataTemplate to use for month items.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NavigationButtonStyle | Gets or sets the Style to apply to the navigation buttons.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectDateCommand | Gets the ICommand that is used to select a date.
Public property | SelectDayOfWeekCommand | Gets the ICommand that is used to select an entire day of week.
Public property | SelectedDate | Gets or sets the selected date, if any, in the calendar.
Public property | SelectedDates | Gets the currently-selected dates in the calendar.
Public property | SelectionMode | Gets or sets the selection mode of the calendar.
Public property | SelectTodayCommand | Gets the ICommand that is used to select today's date.
Public property | SelectWeekCommand | Gets the ICommand that is used to select an entire week.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets the title that is displayed for the active view.
Public property | TitleButtonStyle | Gets or sets the Style to apply to the title button.
Public property | TodayButtonStyle | Gets or sets the Style to apply to the Today button.
Public property | TodayButtonText | Gets the text to display in the Today button.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | ViewResetMode | Gets or sets the view reset mode, which can be used to reset the view when the calendar loses focus.
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | WeekNumberItemContainerStyle | Gets or sets the Style to apply to week number items.
Public property | WeekNumberItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging week number items.
Public property | WeekNumberItemTemplate | Gets or sets the DataTemplate to use for week number items.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YearItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging year items.
Public property | YearItemTemplate | Gets or sets the DataTemplate to use for year items.
Public property | ZoomInCommand | Gets the ICommand that is used to zoom in.
Public property | ZoomOutCommand | Gets the ICommand that is used to zoom out.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the control.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectToday | Selects today's date.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateDayItem | Updates a MonthCalendarItem for the specified day.
Protected method | UpdateDayNameItem | Updates a MonthCalendarItem for the specified day of week.
Protected method | UpdateDecadeItem | Updates a MonthCalendarItem for the specified decade.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateMonthItem | Updates a MonthCalendarItem for the specified month.
Protected method | UpdateWeekNumberItem | Updates a MonthCalendarItem for the specified week number.
Protected method | UpdateYearItem | Updates a MonthCalendarItem for the specified year.
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs after the SelectedDate property value and/or SelectedDates collection changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ActiveDateProperty | Identifies the ActiveDate dependency property. This field is read-only.
ActiveViewModeProperty | Identifies the ActiveViewMode dependency property. This field is read-only.
CalendarWeekRuleProperty | Identifies the CalendarWeekRule dependency property. This field is read-only.
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
ClearButtonStyleProperty | Identifies the ClearButtonStyle dependency property. This field is read-only.
ClearButtonTextProperty | Identifies the ClearButtonText dependency property. This field is read-only.
DayItemsPanelTemplateProperty | Identifies the DayItemsPanelTemplate dependency property. This field is read-only.
DayItemTemplateProperty | Identifies the DayItemTemplate dependency property. This field is read-only.
DayNameItemContainerStyleProperty | Identifies the DayNameItemContainerStyle dependency property. This field is read-only.
DayNameItemsPanelTemplateProperty | Identifies the DayNameItemsPanelTemplate dependency property. This field is read-only.
DayNameItemTemplateProperty | Identifies the DayNameItemTemplate dependency property. This field is read-only.
DayOfWeekFormatPatternProperty | Identifies the DayOfWeekFormatPattern dependency property. This field is read-only.
DecadeItemsPanelTemplateProperty | Identifies the DecadeItemsPanelTemplate dependency property. This field is read-only.
DecadeItemTemplateProperty | Identifies the DecadeItemTemplate dependency property. This field is read-only.
DisabledDaysOfWeekProperty | Identifies the DisabledDaysOfWeek dependency property. This field is read-only.
FirstDayOfWeekProperty | Identifies the FirstDayOfWeek dependency property. This field is read-only.
IsClearButtonVisibleProperty | Identifies the IsClearButtonVisible dependency property. This field is read-only.
IsDateDisabledFuncProperty | Identifies the IsDateDisabledFunc dependency property. This field is read-only.
IsDayOfWeekSelectionEnabledProperty | Identifies the IsDayOfWeekSelectionEnabled dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
IsTodayButtonVisibleProperty | Identifies the IsTodayButtonVisible dependency property. This field is read-only.
IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property. This field is read-only.
IsWeekNumberColumnVisibleProperty | Identifies the IsWeekNumberColumnVisible dependency property. This field is read-only.
IsWeekNumberSelectionEnabledProperty | Identifies the IsWeekNumberSelectionEnabled dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MaxSelectionCountProperty | Identifies the MaxSelectionCount dependency property. This field is read-only.
MaxViewModeProperty | Identifies the MaxViewMode dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MonthItemsPanelTemplateProperty | Identifies the MonthItemsPanelTemplate dependency property. This field is read-only.
MonthItemTemplateProperty | Identifies the MonthItemTemplate dependency property. This field is read-only.
NavigationButtonStyleProperty | Identifies the NavigationButtonStyle dependency property. This field is read-only.
SelectedDateProperty | Identifies the SelectedDate dependency property. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TitleButtonStyleProperty | Identifies the TitleButtonStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TodayButtonStyleProperty | Identifies the TodayButtonStyle dependency property. This field is read-only.
TodayButtonTextProperty | Identifies the TodayButtonText dependency property. This field is read-only.
ViewResetModeProperty | Identifies the ViewResetMode dependency property. This field is read-only.
WeekNumberItemContainerStyleProperty | Identifies the WeekNumberItemContainerStyle dependency property. This field is read-only.
WeekNumberItemsPanelTemplateProperty | Identifies the WeekNumberItemsPanelTemplate dependency property. This field is read-only.
WeekNumberItemTemplateProperty | Identifies the WeekNumberItemTemplate dependency property. This field is read-only.
YearItemsPanelTemplateProperty | Identifies the YearItemsPanelTemplate dependency property. This field is read-only.
YearItemTemplateProperty | Identifies the YearItemTemplate dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar Constructor

MonthCalendar Constructor
Initializes a new instance of the MonthCalendar class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendar()
Public Sub New
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar Properties

MonthCalendar Properties

The MonthCalendar type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveDate | Gets or sets the active date in the calendar.
Public property | ActiveViewMode | Gets or sets the active view mode of the calendar.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalendarWeekRule | Gets or sets the calendar week rule, which determines how weeks are numbered.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanRetainTime | Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClearButtonStyle | Gets or sets the Style to apply to the Clear button.
Public property | ClearButtonText | Gets or sets the text to display in the Clear button.
Public property | ClearSelectionCommand | Gets the ICommand that is used to clear the selection.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DayItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day items.
Public property | DayItemTemplate | Gets or sets the DataTemplate to use for day items.
Public property | DayNameItemContainerStyle | Gets or sets the Style to apply to day name items.
Public property | DayNameItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging day name items.
Public property | DayNameItemTemplate | Gets or sets the DataTemplate to use for day name items.
Public property | DayOfWeekFormatPattern | Gets or sets the format pattern used for DayOfWeek values.
Public property | DecadeItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging decade items.
Public property | DecadeItemTemplate | Gets or sets the DataTemplate to use for decade items.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledDaysOfWeek | Gets or sets the disabled days of the week.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FirstDayOfWeek | Gets or sets the first day of the week.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GoToNextViewCommand | Gets the ICommand that is used to go to the next view.
Public property | GoToPreviousViewCommand | Gets the ICommand that is used to go to the next view.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsClearButtonVisible | Gets or sets whether the clear button is visible.
Public property | IsDateDisabledFunc | Gets or sets a function that is called when a day cell is rendered to determine if it should be disabled.
Public property | IsDayOfWeekSelectionEnabled | Gets or sets whether the day of week headers can be used to select dates.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsTodayButtonVisible | Gets or sets whether the Today button is visible.
Public property | IsTodayHighlighted | Gets or sets whether DateTime.Today is highlighted.
Public property | IsWeekNumberColumnVisible | Gets or sets whether the week number column is visible.
Public property | IsWeekNumberSelectionEnabled | Gets or sets whether the week numbers can be used to select dates.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxSelectionCount | Gets or sets the maximum number of dates that can be selected.
Public property | MaxViewMode | Gets or sets the maximum view mode allowed.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MonthItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging month items.
Public property | MonthItemTemplate | Gets or sets the DataTemplate to use for month items.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NavigationButtonStyle | Gets or sets the Style to apply to the navigation buttons.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectDateCommand | Gets the ICommand that is used to select a date.
Public property | SelectDayOfWeekCommand | Gets the ICommand that is used to select an entire day of week.
Public property | SelectedDate | Gets or sets the selected date, if any, in the calendar.
Public property | SelectedDates | Gets the currently-selected dates in the calendar.
Public property | SelectionMode | Gets or sets the selection mode of the calendar.
Public property | SelectTodayCommand | Gets the ICommand that is used to select today's date.
Public property | SelectWeekCommand | Gets the ICommand that is used to select an entire week.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Title | Gets the title that is displayed for the active view.
Public property | TitleButtonStyle | Gets or sets the Style to apply to the title button.
Public property | TodayButtonStyle | Gets or sets the Style to apply to the Today button.
Public property | TodayButtonText | Gets the text to display in the Today button.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | ViewResetMode | Gets or sets the view reset mode, which can be used to reset the view when the calendar loses focus.
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | WeekNumberItemContainerStyle | Gets or sets the Style to apply to week number items.
Public property | WeekNumberItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging week number items.
Public property | WeekNumberItemTemplate | Gets or sets the DataTemplate to use for week number items.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YearItemsPanelTemplate | Gets or sets the ItemsPanelTemplate to use for arranging year items.
Public property | YearItemTemplate | Gets or sets the DataTemplate to use for year items.
Public property | ZoomInCommand | Gets the ICommand that is used to zoom in.
Public property | ZoomOutCommand | Gets the ICommand that is used to zoom out.
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ActiveDate Property

MonthCalendarActiveDate Property
Gets or sets the active date in the calendar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime ActiveDate { get; set; }
Public Property ActiveDate As DateTime
    Get
    Set

Property Value

Type: DateTime
The active date in the calendar.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ActiveViewMode Property

MonthCalendarActiveViewMode Property
Gets or sets the active view mode of the calendar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendarViewMode ActiveViewMode { get; set; }
Public Property ActiveViewMode As MonthCalendarViewMode
    Get
    Set

Property Value

Type: MonthCalendarViewMode
The active view mode of the calendar. The default value is MonthCalendarViewMode.Month.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.CalendarWeekRule Property

MonthCalendarCalendarWeekRule Property
Gets or sets the calendar week rule, which determines how weeks are numbered.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<CalendarWeekRule> CalendarWeekRule { get; set; }
Public Property CalendarWeekRule As Nullable(Of CalendarWeekRule)
    Get
    Set

Property Value

Type: Nullable CalendarWeekRule
The calendar week rule. When set to , the calendar week rule is pulled from the current culture. The default value is .
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.CanRetainTime Property

MonthCalendarCanRetainTime Property
Gets or sets whether the various DateTime values can retain the time-portion, or if it is reset to midnight.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanRetainTime { get; set; }
Public Property CanRetainTime As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the various DateTime values can retain the time-portion; otherwise, false. The default value is false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ClearButtonStyle Property

MonthCalendarClearButtonStyle Property
Gets or sets the Style to apply to the Clear button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ClearButtonStyle { get; set; }
Public Property ClearButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the Clear button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ClearButtonText Property

MonthCalendarClearButtonText Property
Gets or sets the text to display in the Clear button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ClearButtonText { get; set; }
Public Property ClearButtonText As String
    Get
    Set

Property Value

Type: String
The text to display in the Clear button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ClearSelectionCommand Property

MonthCalendarClearSelectionCommand Property
Gets the ICommand that is used to clear the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClearSelectionCommand { get; }
Public ReadOnly Property ClearSelectionCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to clear the selection.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayItemsPanelTemplate Property

MonthCalendarDayItemsPanelTemplate Property
Gets or sets the ItemsPanelTemplate to use for arranging day items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate DayItemsPanelTemplate { get; set; }
Public Property DayItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging day items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayItemTemplate Property

MonthCalendarDayItemTemplate Property
Gets or sets the DataTemplate to use for day items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DayItemTemplate { get; set; }
Public Property DayItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for day items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayNameItemContainerStyle Property

MonthCalendarDayNameItemContainerStyle Property
Gets or sets the Style to apply to day name items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style DayNameItemContainerStyle { get; set; }
Public Property DayNameItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to day name items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayNameItemsPanelTemplate Property

MonthCalendarDayNameItemsPanelTemplate Property
Gets or sets the ItemsPanelTemplate to use for arranging day name items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate DayNameItemsPanelTemplate { get; set; }
Public Property DayNameItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging day name items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayNameItemTemplate Property

MonthCalendarDayNameItemTemplate Property
Gets or sets the DataTemplate to use for day name items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DayNameItemTemplate { get; set; }
Public Property DayNameItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for day name items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayOfWeekFormatPattern Property

MonthCalendarDayOfWeekFormatPattern Property
Gets or sets the format pattern used for DayOfWeek values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DayOfWeekFormatPattern DayOfWeekFormatPattern { get; set; }
Public Property DayOfWeekFormatPattern As DayOfWeekFormatPattern
    Get
    Set

Property Value

Type: DayOfWeekFormatPattern
The format pattern used for DayOfWeek values. The default value is DayOfWeekFormatPattern.AbbreviatedUppercase.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DecadeItemsPanelTemplate Property

MonthCalendarDecadeItemsPanelTemplate Property
Gets or sets the ItemsPanelTemplate to use for arranging decade items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate DecadeItemsPanelTemplate { get; set; }
Public Property DecadeItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging decade items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DecadeItemTemplate Property

MonthCalendarDecadeItemTemplate Property
Gets or sets the DataTemplate to use for decade items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DecadeItemTemplate { get; set; }
Public Property DecadeItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for decade items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DisabledDaysOfWeek Property

MonthCalendarDisabledDaysOfWeek Property
Gets or sets the disabled days of the week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DaysOfWeek DisabledDaysOfWeek { get; set; }
Public Property DisabledDaysOfWeek As DaysOfWeek
    Get
    Set

Property Value

Type: DaysOfWeek
The disabled days of the week. The default value is DaysOfWeek.None.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.FirstDayOfWeek Property

MonthCalendarFirstDayOfWeek Property
Gets or sets the first day of the week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<DayOfWeek> FirstDayOfWeek { get; set; }
Public Property FirstDayOfWeek As Nullable(Of DayOfWeek)
    Get
    Set

Property Value

Type: Nullable DayOfWeek
The first day of the week. When set to , the first day of the week is pulled from the current culture. The default value is .
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.GoToNextViewCommand Property

MonthCalendarGoToNextViewCommand Property
Gets the ICommand that is used to go to the next view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand GoToNextViewCommand { get; }
Public ReadOnly Property GoToNextViewCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to go to the next view.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.GoToPreviousViewCommand Property

MonthCalendarGoToPreviousViewCommand Property
Gets the ICommand that is used to go to the next view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand GoToPreviousViewCommand { get; }
Public ReadOnly Property GoToPreviousViewCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to go to the next view.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsClearButtonVisible Property

MonthCalendarIsClearButtonVisible Property
Gets or sets whether the clear button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsClearButtonVisible { get; set; }
Public Property IsClearButtonVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the clear button is visible; otherwise false. The default value is false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsDateDisabledFunc Property

MonthCalendarIsDateDisabledFunc Property
Gets or sets a function that is called when a day cell is rendered to determine if it should be disabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Func<DateTime, bool> IsDateDisabledFunc { get; set; }
Public Property IsDateDisabledFunc As Func(Of DateTime, Boolean)
    Get
    Set

Property Value

Type: Func DateTime, Boolean
A function that is called when a day cell is rendered to determine if it should be disabled.
Remarks
This function is not called for dates that are outside of the Minimum and Maximum range, nor for dates that are disabled by the DisabledDaysOfWeek property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsDayOfWeekSelectionEnabled Property

MonthCalendarIsDayOfWeekSelectionEnabled Property
Gets or sets whether the day of week headers can be used to select dates.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDayOfWeekSelectionEnabled { get; set; }
Public Property IsDayOfWeekSelectionEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the day of week headers can be used to select dates; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsKeyboardFocusWithin Property

MonthCalendarIsKeyboardFocusWithin Property
Gets whether keyboard focus is within the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsKeyboardFocusWithin { get; }
Public ReadOnly Property IsKeyboardFocusWithin As Boolean
    Get

Property Value

Type: Boolean
true if keyboard focus is within the control; otherwise, false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsTodayButtonVisible Property

MonthCalendarIsTodayButtonVisible Property
Gets or sets whether the Today button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTodayButtonVisible { get; set; }
Public Property IsTodayButtonVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Today button is visible; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsTodayHighlighted Property

MonthCalendarIsTodayHighlighted Property
Gets or sets whether DateTime.Today is highlighted.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTodayHighlighted { get; set; }
Public Property IsTodayHighlighted As Boolean
    Get
    Set

Property Value

Type: Boolean
true if DateTime.Today is highlighted; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsWeekNumberColumnVisible Property

MonthCalendarIsWeekNumberColumnVisible Property
Gets or sets whether the week number column is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWeekNumberColumnVisible { get; set; }
Public Property IsWeekNumberColumnVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the week number column is visible; otherwise false. The default value is false.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsWeekNumberSelectionEnabled Property

MonthCalendarIsWeekNumberSelectionEnabled Property
Gets or sets whether the week numbers can be used to select dates.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWeekNumberSelectionEnabled { get; set; }
Public Property IsWeekNumberSelectionEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the week numbers can be used to select dates; otherwise false. The default value is true.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.Maximum Property

MonthCalendarMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MaxSelectionCount Property

MonthCalendarMaxSelectionCount Property
Gets or sets the maximum number of dates that can be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int MaxSelectionCount { get; set; }
Public Property MaxSelectionCount As Integer
    Get
    Set

Property Value

Type: Int32
The maximum number of dates that can be selected. The default value is -1, which indicates no upper limit.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MaxViewMode Property

MonthCalendarMaxViewMode Property
Gets or sets the maximum view mode allowed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendarViewMode MaxViewMode { get; set; }
Public Property MaxViewMode As MonthCalendarViewMode
    Get
    Set

Property Value

Type: MonthCalendarViewMode
The maximum view mode allowed. The default value is MonthCalendarViewMode.Century.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace
MonthCalendarActiveViewMode


MonthCalendar.Minimum Property

MonthCalendarMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MonthItemsPanelTemplate Property

MonthCalendarMonthItemsPanelTemplate Property
Gets or sets the ItemsPanelTemplate to use for arranging month items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate MonthItemsPanelTemplate { get; set; }
Public Property MonthItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging month items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MonthItemTemplate Property

MonthCalendarMonthItemTemplate Property
Gets or sets the DataTemplate to use for month items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate MonthItemTemplate { get; set; }
Public Property MonthItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for month items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.NavigationButtonStyle Property

MonthCalendarNavigationButtonStyle Property
Gets or sets the Style to apply to the navigation buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style NavigationButtonStyle { get; set; }
Public Property NavigationButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the navigation buttons.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectDateCommand Property

MonthCalendarSelectDateCommand Property
Gets the ICommand that is used to select a date.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SelectDateCommand { get; }
Public ReadOnly Property SelectDateCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select a date.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectDayOfWeekCommand Property

MonthCalendarSelectDayOfWeekCommand Property
Gets the ICommand that is used to select an entire day of week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SelectDayOfWeekCommand { get; }
Public ReadOnly Property SelectDayOfWeekCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select an entire day of week.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectedDate Property

MonthCalendarSelectedDate Property
Gets or sets the selected date, if any, in the calendar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<DateTime> SelectedDate { get; set; }
Public Property SelectedDate As Nullable(Of DateTime)
    Get
    Set

Property Value

Type: Nullable DateTime
The selected date, if any, in the calendar.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectedDates Property

MonthCalendarSelectedDates Property
Gets the currently-selected dates in the calendar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateRangeCollection SelectedDates { get; }
Public ReadOnly Property SelectedDates As DateRangeCollection
    Get

Property Value

Type: DateRangeCollection
The currently-selected dates in the calendar.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectionMode Property

MonthCalendarSelectionMode Property
Gets or sets the selection mode of the calendar.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendarSelectionMode SelectionMode { get; set; }
Public Property SelectionMode As MonthCalendarSelectionMode
    Get
    Set

Property Value

Type: MonthCalendarSelectionMode
The selection mode of the calendar. The default value is MonthCalendarSelectionMode.Single.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectTodayCommand Property

MonthCalendarSelectTodayCommand Property
Gets the ICommand that is used to select today's date.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SelectTodayCommand { get; }
Public ReadOnly Property SelectTodayCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select today's date.
Remarks
This command calls the SelectToday method.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectWeekCommand Property

MonthCalendarSelectWeekCommand Property
Gets the ICommand that is used to select an entire week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SelectWeekCommand { get; }
Public ReadOnly Property SelectWeekCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to select an entire week.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.Title Property

MonthCalendarTitle Property
Gets the title that is displayed for the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get

Property Value

Type: String
The title that is displayed for the active view.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TitleButtonStyle Property

MonthCalendarTitleButtonStyle Property
Gets or sets the Style to apply to the title button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TitleButtonStyle { get; set; }
Public Property TitleButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the title button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TodayButtonStyle Property

MonthCalendarTodayButtonStyle Property
Gets or sets the Style to apply to the Today button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style TodayButtonStyle { get; set; }
Public Property TodayButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to the Today button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TodayButtonText Property

MonthCalendarTodayButtonText Property
Gets the text to display in the Today button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TodayButtonText { get; }
Public ReadOnly Property TodayButtonText As String
    Get

Property Value

Type: String
The text to display in the Today button.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ViewResetMode Property

MonthCalendarViewResetMode Property
Gets or sets the view reset mode, which can be used to reset the view when the calendar loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendarViewResetMode ViewResetMode { get; set; }
Public Property ViewResetMode As MonthCalendarViewResetMode
    Get
    Set

Property Value

Type: MonthCalendarViewResetMode
The view reset mode, which can be used to reset the view when the calendar loses focus. The default value is MonthCalendarViewResetMode.None.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.WeekNumberItemContainerStyle Property

MonthCalendarWeekNumberItemContainerStyle Property
Gets or sets the Style to apply to week number items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style WeekNumberItemContainerStyle { get; set; }
Public Property WeekNumberItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to apply to week number items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.WeekNumberItemsPanelTemplate Property

MonthCalendarWeekNumberItemsPanelTemplate Property
Gets or sets the ItemsPanelTemplate to use for arranging week number items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate WeekNumberItemsPanelTemplate { get; set; }
Public Property WeekNumberItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging week number items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.WeekNumberItemTemplate Property

MonthCalendarWeekNumberItemTemplate Property
Gets or sets the DataTemplate to use for week number items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate WeekNumberItemTemplate { get; set; }
Public Property WeekNumberItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for week number items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.YearItemsPanelTemplate Property

MonthCalendarYearItemsPanelTemplate Property
Gets or sets the ItemsPanelTemplate to use for arranging year items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate YearItemsPanelTemplate { get; set; }
Public Property YearItemsPanelTemplate As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for arranging year items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.YearItemTemplate Property

MonthCalendarYearItemTemplate Property
Gets or sets the DataTemplate to use for year items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate YearItemTemplate { get; set; }
Public Property YearItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for year items.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ZoomInCommand Property

MonthCalendarZoomInCommand Property
Gets the ICommand that is used to zoom in.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ZoomInCommand { get; }
Public ReadOnly Property ZoomInCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to zoom in.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ZoomOutCommand Property

MonthCalendarZoomOutCommand Property
Gets the ICommand that is used to zoom out.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ZoomOutCommand { get; }
Public ReadOnly Property ZoomOutCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that is used to zoom out.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar Methods

MonthCalendar Methods

The MonthCalendar type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the control.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectToday | Selects today's date.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateDayItem | Updates a MonthCalendarItem for the specified day.
Protected method | UpdateDayNameItem | Updates a MonthCalendarItem for the specified day of week.
Protected method | UpdateDecadeItem | Updates a MonthCalendarItem for the specified decade.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateMonthItem | Updates a MonthCalendarItem for the specified month.
Protected method | UpdateWeekNumberItem | Updates a MonthCalendarItem for the specified week number.
Protected method | UpdateYearItem | Updates a MonthCalendarItem for the specified year.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.OnApplyTemplate Method

MonthCalendarOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.OnCreateAutomationPeer Method

MonthCalendarOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.OnGotFocus Method

MonthCalendarOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.OnKeyDown Method

MonthCalendarOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.OnLostFocus Method

MonthCalendarOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.Refresh Method

MonthCalendarRefresh Method
Refreshes the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh(
    bool requiresNewView
)
Public Sub Refresh (
    requiresNewView As Boolean
)

Parameters

requiresNewView
Type: SystemBoolean
Whether a new view is required (if UI elements are changing instead of only simple data).
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectToday Method

MonthCalendarSelectToday Method
Selects today's date.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SelectToday()
Public Sub SelectToday
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.UpdateDayItem Method

MonthCalendarUpdateDayItem Method
Updates a MonthCalendarItem for the specified day.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateDayItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateDayItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.UpdateDayNameItem Method

MonthCalendarUpdateDayNameItem Method
Updates a MonthCalendarItem for the specified day of week.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateDayNameItem(
    MonthCalendarItem item,
    DayOfWeek dayOfWeek
)
Protected Overridable Sub UpdateDayNameItem (
    item As MonthCalendarItem,
    dayOfWeek As DayOfWeek
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
dayOfWeek
Type: SystemDayOfWeek
The upated day of week.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.UpdateDecadeItem Method

MonthCalendarUpdateDecadeItem Method
Updates a MonthCalendarItem for the specified decade.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateDecadeItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateDecadeItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.UpdateMonthItem Method

MonthCalendarUpdateMonthItem Method
Updates a MonthCalendarItem for the specified month.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateMonthItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateMonthItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.UpdateWeekNumberItem Method

MonthCalendarUpdateWeekNumberItem Method
Updates a MonthCalendarItem for the specified week number.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateWeekNumberItem(
    MonthCalendarItem item,
    int weekNumber
)
Protected Overridable Sub UpdateWeekNumberItem (
    item As MonthCalendarItem,
    weekNumber As Integer
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
weekNumber
Type: SystemInt32
The updated week number.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.UpdateYearItem Method

MonthCalendarUpdateYearItem Method
Updates a MonthCalendarItem for the specified year.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateYearItem(
    MonthCalendarItem item,
    DateTime date
)
Protected Overridable Sub UpdateYearItem (
    item As MonthCalendarItem,
    date As DateTime
)

Parameters

item
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem
The MonthCalendarItem to update.
date
Type: SystemDateTime
The date for which to update the model.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar Events

MonthCalendar Events

The MonthCalendar type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs after the SelectedDate property value and/or SelectedDates collection changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectionChanged Event

MonthCalendarSelectionChanged Event
Occurs after the SelectedDate property value and/or SelectedDates collection changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar Fields

MonthCalendar Fields

The MonthCalendar type exposes the following members.

Fields
Name | Description
ActiveDateProperty | Identifies the ActiveDate dependency property. This field is read-only.
ActiveViewModeProperty | Identifies the ActiveViewMode dependency property. This field is read-only.
CalendarWeekRuleProperty | Identifies the CalendarWeekRule dependency property. This field is read-only.
CanRetainTimeProperty | Identifies the CanRetainTime dependency property. This field is read-only.
ClearButtonStyleProperty | Identifies the ClearButtonStyle dependency property. This field is read-only.
ClearButtonTextProperty | Identifies the ClearButtonText dependency property. This field is read-only.
DayItemsPanelTemplateProperty | Identifies the DayItemsPanelTemplate dependency property. This field is read-only.
DayItemTemplateProperty | Identifies the DayItemTemplate dependency property. This field is read-only.
DayNameItemContainerStyleProperty | Identifies the DayNameItemContainerStyle dependency property. This field is read-only.
DayNameItemsPanelTemplateProperty | Identifies the DayNameItemsPanelTemplate dependency property. This field is read-only.
DayNameItemTemplateProperty | Identifies the DayNameItemTemplate dependency property. This field is read-only.
DayOfWeekFormatPatternProperty | Identifies the DayOfWeekFormatPattern dependency property. This field is read-only.
DecadeItemsPanelTemplateProperty | Identifies the DecadeItemsPanelTemplate dependency property. This field is read-only.
DecadeItemTemplateProperty | Identifies the DecadeItemTemplate dependency property. This field is read-only.
DisabledDaysOfWeekProperty | Identifies the DisabledDaysOfWeek dependency property. This field is read-only.
FirstDayOfWeekProperty | Identifies the FirstDayOfWeek dependency property. This field is read-only.
IsClearButtonVisibleProperty | Identifies the IsClearButtonVisible dependency property. This field is read-only.
IsDateDisabledFuncProperty | Identifies the IsDateDisabledFunc dependency property. This field is read-only.
IsDayOfWeekSelectionEnabledProperty | Identifies the IsDayOfWeekSelectionEnabled dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
IsTodayButtonVisibleProperty | Identifies the IsTodayButtonVisible dependency property. This field is read-only.
IsTodayHighlightedProperty | Identifies the IsTodayHighlighted dependency property. This field is read-only.
IsWeekNumberColumnVisibleProperty | Identifies the IsWeekNumberColumnVisible dependency property. This field is read-only.
IsWeekNumberSelectionEnabledProperty | Identifies the IsWeekNumberSelectionEnabled dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MaxSelectionCountProperty | Identifies the MaxSelectionCount dependency property. This field is read-only.
MaxViewModeProperty | Identifies the MaxViewMode dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MonthItemsPanelTemplateProperty | Identifies the MonthItemsPanelTemplate dependency property. This field is read-only.
MonthItemTemplateProperty | Identifies the MonthItemTemplate dependency property. This field is read-only.
NavigationButtonStyleProperty | Identifies the NavigationButtonStyle dependency property. This field is read-only.
SelectedDateProperty | Identifies the SelectedDate dependency property. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TitleButtonStyleProperty | Identifies the TitleButtonStyle dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
TodayButtonStyleProperty | Identifies the TodayButtonStyle dependency property. This field is read-only.
TodayButtonTextProperty | Identifies the TodayButtonText dependency property. This field is read-only.
ViewResetModeProperty | Identifies the ViewResetMode dependency property. This field is read-only.
WeekNumberItemContainerStyleProperty | Identifies the WeekNumberItemContainerStyle dependency property. This field is read-only.
WeekNumberItemsPanelTemplateProperty | Identifies the WeekNumberItemsPanelTemplate dependency property. This field is read-only.
WeekNumberItemTemplateProperty | Identifies the WeekNumberItemTemplate dependency property. This field is read-only.
YearItemsPanelTemplateProperty | Identifies the YearItemsPanelTemplate dependency property. This field is read-only.
YearItemTemplateProperty | Identifies the YearItemTemplate dependency property. This field is read-only.
Top
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ActiveDateProperty Field

MonthCalendarActiveDateProperty Field
Identifies the ActiveDate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveDateProperty
Public Shared ReadOnly ActiveDateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveDate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ActiveViewModeProperty Field

MonthCalendarActiveViewModeProperty Field
Identifies the ActiveViewMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveViewModeProperty
Public Shared ReadOnly ActiveViewModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveViewMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.CalendarWeekRuleProperty Field

MonthCalendarCalendarWeekRuleProperty Field
Identifies the CalendarWeekRule dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalendarWeekRuleProperty
Public Shared ReadOnly CalendarWeekRuleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalendarWeekRule dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.CanRetainTimeProperty Field

MonthCalendarCanRetainTimeProperty Field
Identifies the CanRetainTime dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanRetainTimeProperty
Public Shared ReadOnly CanRetainTimeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanRetainTime dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ClearButtonStyleProperty Field

MonthCalendarClearButtonStyleProperty Field
Identifies the ClearButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClearButtonStyleProperty
Public Shared ReadOnly ClearButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClearButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ClearButtonTextProperty Field

MonthCalendarClearButtonTextProperty Field
Identifies the ClearButtonText dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClearButtonTextProperty
Public Shared ReadOnly ClearButtonTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClearButtonText dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayItemsPanelTemplateProperty Field

MonthCalendarDayItemsPanelTemplateProperty Field
Identifies the DayItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayItemsPanelTemplateProperty
Public Shared ReadOnly DayItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayItemTemplateProperty Field

MonthCalendarDayItemTemplateProperty Field
Identifies the DayItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayItemTemplateProperty
Public Shared ReadOnly DayItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayNameItemContainerStyleProperty Field

MonthCalendarDayNameItemContainerStyleProperty Field
Identifies the DayNameItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayNameItemContainerStyleProperty
Public Shared ReadOnly DayNameItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayNameItemContainerStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayNameItemsPanelTemplateProperty Field

MonthCalendarDayNameItemsPanelTemplateProperty Field
Identifies the DayNameItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayNameItemsPanelTemplateProperty
Public Shared ReadOnly DayNameItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayNameItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayNameItemTemplateProperty Field

MonthCalendarDayNameItemTemplateProperty Field
Identifies the DayNameItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayNameItemTemplateProperty
Public Shared ReadOnly DayNameItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayNameItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DayOfWeekFormatPatternProperty Field

MonthCalendarDayOfWeekFormatPatternProperty Field
Identifies the DayOfWeekFormatPattern dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DayOfWeekFormatPatternProperty
Public Shared ReadOnly DayOfWeekFormatPatternProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DayOfWeekFormatPattern dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DecadeItemsPanelTemplateProperty Field

MonthCalendarDecadeItemsPanelTemplateProperty Field
Identifies the DecadeItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecadeItemsPanelTemplateProperty
Public Shared ReadOnly DecadeItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecadeItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DecadeItemTemplateProperty Field

MonthCalendarDecadeItemTemplateProperty Field
Identifies the DecadeItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecadeItemTemplateProperty
Public Shared ReadOnly DecadeItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecadeItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.DisabledDaysOfWeekProperty Field

MonthCalendarDisabledDaysOfWeekProperty Field
Identifies the DisabledDaysOfWeek dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisabledDaysOfWeekProperty
Public Shared ReadOnly DisabledDaysOfWeekProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisabledDaysOfWeek dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.FirstDayOfWeekProperty Field

MonthCalendarFirstDayOfWeekProperty Field
Identifies the FirstDayOfWeek dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FirstDayOfWeekProperty
Public Shared ReadOnly FirstDayOfWeekProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FirstDayOfWeek dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsClearButtonVisibleProperty Field

MonthCalendarIsClearButtonVisibleProperty Field
Identifies the IsClearButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsClearButtonVisibleProperty
Public Shared ReadOnly IsClearButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsClearButtonVisible dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsDateDisabledFuncProperty Field

MonthCalendarIsDateDisabledFuncProperty Field
Identifies the IsDateDisabledFunc dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDateDisabledFuncProperty
Public Shared ReadOnly IsDateDisabledFuncProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDateDisabledFunc dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsDayOfWeekSelectionEnabledProperty Field

MonthCalendarIsDayOfWeekSelectionEnabledProperty Field
Identifies the IsDayOfWeekSelectionEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDayOfWeekSelectionEnabledProperty
Public Shared ReadOnly IsDayOfWeekSelectionEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDayOfWeekSelectionEnabled dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsKeyboardFocusWithinProperty Field

MonthCalendarIsKeyboardFocusWithinProperty Field
Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsKeyboardFocusWithinProperty
Public Shared ReadOnly IsKeyboardFocusWithinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsKeyboardFocusWithin dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsTodayButtonVisibleProperty Field

MonthCalendarIsTodayButtonVisibleProperty Field
Identifies the IsTodayButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTodayButtonVisibleProperty
Public Shared ReadOnly IsTodayButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTodayButtonVisible dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsTodayHighlightedProperty Field

MonthCalendarIsTodayHighlightedProperty Field
Identifies the IsTodayHighlighted dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTodayHighlightedProperty
Public Shared ReadOnly IsTodayHighlightedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTodayHighlighted dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsWeekNumberColumnVisibleProperty Field

MonthCalendarIsWeekNumberColumnVisibleProperty Field
Identifies the IsWeekNumberColumnVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWeekNumberColumnVisibleProperty
Public Shared ReadOnly IsWeekNumberColumnVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWeekNumberColumnVisible dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.IsWeekNumberSelectionEnabledProperty Field

MonthCalendarIsWeekNumberSelectionEnabledProperty Field
Identifies the IsWeekNumberSelectionEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWeekNumberSelectionEnabledProperty
Public Shared ReadOnly IsWeekNumberSelectionEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWeekNumberSelectionEnabled dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MaximumProperty Field

MonthCalendarMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MaxSelectionCountProperty Field

MonthCalendarMaxSelectionCountProperty Field
Identifies the MaxSelectionCount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxSelectionCountProperty
Public Shared ReadOnly MaxSelectionCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxSelectionCount dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MaxViewModeProperty Field

MonthCalendarMaxViewModeProperty Field
Identifies the MaxViewMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxViewModeProperty
Public Shared ReadOnly MaxViewModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxViewMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MinimumProperty Field

MonthCalendarMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MonthItemsPanelTemplateProperty Field

MonthCalendarMonthItemsPanelTemplateProperty Field
Identifies the MonthItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MonthItemsPanelTemplateProperty
Public Shared ReadOnly MonthItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MonthItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.MonthItemTemplateProperty Field

MonthCalendarMonthItemTemplateProperty Field
Identifies the MonthItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MonthItemTemplateProperty
Public Shared ReadOnly MonthItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MonthItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.NavigationButtonStyleProperty Field

MonthCalendarNavigationButtonStyleProperty Field
Identifies the NavigationButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NavigationButtonStyleProperty
Public Shared ReadOnly NavigationButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NavigationButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectedDateProperty Field

MonthCalendarSelectedDateProperty Field
Identifies the SelectedDate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedDateProperty
Public Shared ReadOnly SelectedDateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedDate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.SelectionModeProperty Field

MonthCalendarSelectionModeProperty Field
Identifies the SelectionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionModeProperty
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TitleButtonStyleProperty Field

MonthCalendarTitleButtonStyleProperty Field
Identifies the TitleButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleButtonStyleProperty
Public Shared ReadOnly TitleButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TitleButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TitleProperty Field

MonthCalendarTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TodayButtonStyleProperty Field

MonthCalendarTodayButtonStyleProperty Field
Identifies the TodayButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TodayButtonStyleProperty
Public Shared ReadOnly TodayButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TodayButtonStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.TodayButtonTextProperty Field

MonthCalendarTodayButtonTextProperty Field
Identifies the TodayButtonText dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TodayButtonTextProperty
Public Shared ReadOnly TodayButtonTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TodayButtonText dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.ViewResetModeProperty Field

MonthCalendarViewResetModeProperty Field
Identifies the ViewResetMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ViewResetModeProperty
Public Shared ReadOnly ViewResetModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ViewResetMode dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.WeekNumberItemContainerStyleProperty Field

MonthCalendarWeekNumberItemContainerStyleProperty Field
Identifies the WeekNumberItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WeekNumberItemContainerStyleProperty
Public Shared ReadOnly WeekNumberItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WeekNumberItemContainerStyle dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.WeekNumberItemsPanelTemplateProperty Field

MonthCalendarWeekNumberItemsPanelTemplateProperty Field
Identifies the WeekNumberItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WeekNumberItemsPanelTemplateProperty
Public Shared ReadOnly WeekNumberItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WeekNumberItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.WeekNumberItemTemplateProperty Field

MonthCalendarWeekNumberItemTemplateProperty Field
Identifies the WeekNumberItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WeekNumberItemTemplateProperty
Public Shared ReadOnly WeekNumberItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WeekNumberItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.YearItemsPanelTemplateProperty Field

MonthCalendarYearItemsPanelTemplateProperty Field
Identifies the YearItemsPanelTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YearItemsPanelTemplateProperty
Public Shared ReadOnly YearItemsPanelTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YearItemsPanelTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendar.YearItemTemplateProperty Field

MonthCalendarYearItemTemplateProperty Field
Identifies the YearItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YearItemTemplateProperty
Public Shared ReadOnly YearItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YearItemTemplate dependency property.
See Also

Reference

MonthCalendar Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem Class

MonthCalendarItem Class
Represents a month calendar item.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MonthCalendarItem : ContentControl
Public Class MonthCalendarItem
    Inherits ContentControl

The MonthCalendarItem type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendarItem | Initializes a new instance of the MonthCalendarItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Command | Gets or sets the ICommand to execute when the item is tapped.
Public property | CommandParameter | Gets or sets the ICommand parameter to pass when the item is tapped.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainsToday | Gets or sets a value indicating whether the item contains DateTime.Today.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | Date | Gets the date associated with this item.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHeader | Gets or sets whether the item is a header and shouldn't show visual state highlights.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsInactive | Gets or sets whether the item is outside of the active view.
Public property | IsPressed | Gets whether the item is pressed.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CommandParameterProperty | Identifies the CommandParameter dependency property. This field is read-only.
CommandProperty | Identifies the Command dependency property. This field is read-only.
ContainsTodayProperty | Identifies the ContainsToday dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsInactiveProperty | Identifies the IsInactive dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem Constructor

MonthCalendarItem Constructor
Initializes a new instance of the MonthCalendarItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendarItem()
Public Sub New
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem Properties

MonthCalendarItem Properties

The MonthCalendarItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Command | Gets or sets the ICommand to execute when the item is tapped.
Public property | CommandParameter | Gets or sets the ICommand parameter to pass when the item is tapped.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContainsToday | Gets or sets a value indicating whether the item contains DateTime.Today.
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | Date | Gets the date associated with this item.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHeader | Gets or sets whether the item is a header and shouldn't show visual state highlights.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsInactive | Gets or sets whether the item is outside of the active view.
Public property | IsPressed | Gets whether the item is pressed.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the item is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.Command Property

MonthCalendarItemCommand Property
Gets or sets the ICommand to execute when the item is tapped.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand Command { get; set; }
Public Property Command As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand to execute when the item is tapped.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.CommandParameter Property

MonthCalendarItemCommandParameter Property
Gets or sets the ICommand parameter to pass when the item is tapped.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object CommandParameter { get; set; }
Public Property CommandParameter As Object
    Get
    Set

Property Value

Type: Object
The ICommand parameter to pass when the item is tapped.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.ContainsToday Property

MonthCalendarItemContainsToday Property
Gets or sets a value indicating whether the item contains DateTime.Today.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ContainsToday { get; set; }
Public Property ContainsToday As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item contains DateTime.Today; otherwise false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.Date Property

MonthCalendarItemDate Property
Gets the date associated with this item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<DateTime> Date { get; }
Public ReadOnly Property Date As Nullable(Of DateTime)
    Get

Property Value

Type: Nullable DateTime
The date associated with this item.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsHeader Property

MonthCalendarItemIsHeader Property
Gets or sets whether the item is a header and shouldn't show visual state highlights.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHeader { get; set; }
Public Property IsHeader As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is a header and shouldn't show visual state highlights; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsInactive Property

MonthCalendarItemIsInactive Property
Gets or sets whether the item is outside of the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsInactive { get; set; }
Public Property IsInactive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is outside of the active view; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsPressed Property

MonthCalendarItemIsPressed Property
Gets whether the item is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPressed { get; }
Public ReadOnly Property IsPressed As Boolean
    Get

Property Value

Type: Boolean
true if the item is pressed; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsSelected Property

MonthCalendarItemIsSelected Property
Gets or sets whether the item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is selected; otherwise, false. The default value is false.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem Methods

MonthCalendarItem Methods

The MonthCalendarItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.OnApplyTemplate Method

MonthCalendarItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.OnGotFocus Method

MonthCalendarItemOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.OnKeyDown Method

MonthCalendarItemOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.OnLostFocus Method

MonthCalendarItemOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem Events

MonthCalendarItem Events

The MonthCalendarItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem Fields

MonthCalendarItem Fields

The MonthCalendarItem type exposes the following members.

Fields
Name | Description
CommandParameterProperty | Identifies the CommandParameter dependency property. This field is read-only.
CommandProperty | Identifies the Command dependency property. This field is read-only.
ContainsTodayProperty | Identifies the ContainsToday dependency property. This field is read-only.
IsHeaderProperty | Identifies the IsHeader dependency property. This field is read-only.
IsInactiveProperty | Identifies the IsInactive dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.CommandParameterProperty Field

MonthCalendarItemCommandParameterProperty Field
Identifies the CommandParameter dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommandParameterProperty
Public Shared ReadOnly CommandParameterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CommandParameter dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.CommandProperty Field

MonthCalendarItemCommandProperty Field
Identifies the Command dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommandProperty
Public Shared ReadOnly CommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Command dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.ContainsTodayProperty Field

MonthCalendarItemContainsTodayProperty Field
Identifies the ContainsToday dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ContainsTodayProperty
Public Shared ReadOnly ContainsTodayProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ContainsToday dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsHeaderProperty Field

MonthCalendarItemIsHeaderProperty Field
Identifies the IsHeader dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHeaderProperty
Public Shared ReadOnly IsHeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHeader dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsInactiveProperty Field

MonthCalendarItemIsInactiveProperty Field
Identifies the IsInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsInactiveProperty
Public Shared ReadOnly IsInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsInactive dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsPressedProperty Field

MonthCalendarItemIsPressedProperty Field
Identifies the IsPressed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPressedProperty
Public Shared ReadOnly IsPressedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPressed dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarItem.IsSelectedProperty Field

MonthCalendarItemIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

MonthCalendarItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode Class

MonthCalendarSelectionMode Class
Specifies the various selection modes of a MonthCalendar.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarSelectionMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MonthCalendarSelectionMode : Enum
Public NotInheritable Class MonthCalendarSelectionMode
    Inherits Enum

The MonthCalendarSelectionMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Extended | Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift).
 | Multiple | Indicates that multiple items can be selected, without holding down a modifier key.
 | Range | Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift), but must be in a contiguous range.
 | Single | Indicates that only one item can be selected.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode Methods

MonthCalendarSelectionMode Methods

The MonthCalendarSelectionMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode Fields

MonthCalendarSelectionMode Fields

The MonthCalendarSelectionMode type exposes the following members.

Fields
 | Name | Description
 | Extended | Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift).
 | Multiple | Indicates that multiple items can be selected, without holding down a modifier key.
 | Range | Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift), but must be in a contiguous range.
 | Single | Indicates that only one item can be selected.
Public field | value__ |
Top
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode.Extended Field

MonthCalendarSelectionModeExtended Field
Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift).

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarSelectionMode Extended = 2
Public Const Extended As MonthCalendarSelectionMode = 2

Field Value

Type: MonthCalendarSelectionMode
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode.Multiple Field

MonthCalendarSelectionModeMultiple Field
Indicates that multiple items can be selected, without holding down a modifier key.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarSelectionMode Multiple = 1
Public Const Multiple As MonthCalendarSelectionMode = 1

Field Value

Type: MonthCalendarSelectionMode
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode.Range Field

MonthCalendarSelectionModeRange Field
Indicates that multiple items can be selected by holding down a modifier key (e.g. Control and/or Shift), but must be in a contiguous range.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarSelectionMode Range = 3
Public Const Range As MonthCalendarSelectionMode = 3

Field Value

Type: MonthCalendarSelectionMode
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode.Single Field

MonthCalendarSelectionModeSingle Field
Indicates that only one item can be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarSelectionMode Single = 0
Public Const Single As MonthCalendarSelectionMode = 0

Field Value

Type: MonthCalendarSelectionMode
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarSelectionMode.value__ Field

MonthCalendarSelectionModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.MonthCalendarSelectionMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MonthCalendarSelectionMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode Class

MonthCalendarViewMode Class
Specifies the various views of a MonthCalendar.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarViewMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MonthCalendarViewMode : Enum
Public NotInheritable Class MonthCalendarViewMode
    Inherits Enum

The MonthCalendarViewMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Century | Indicates that the calendar will present a century view.
 | Decade | Indicates that the calendar will present a decade view.
 | Month | Indicates that the calendar will present a month view.
Public field | value__ |
 | Year | Indicates that the calendar will present a year view.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode Methods

MonthCalendarViewMode Methods

The MonthCalendarViewMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode Fields

MonthCalendarViewMode Fields

The MonthCalendarViewMode type exposes the following members.

Fields
 | Name | Description
 | Century | Indicates that the calendar will present a century view.
 | Decade | Indicates that the calendar will present a decade view.
 | Month | Indicates that the calendar will present a month view.
Public field | value__ |
 | Year | Indicates that the calendar will present a year view.
Top
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode.Century Field

MonthCalendarViewModeCentury Field
Indicates that the calendar will present a century view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewMode Century = 3
Public Const Century As MonthCalendarViewMode = 3

Field Value

Type: MonthCalendarViewMode
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode.Decade Field

MonthCalendarViewModeDecade Field
Indicates that the calendar will present a decade view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewMode Decade = 2
Public Const Decade As MonthCalendarViewMode = 2

Field Value

Type: MonthCalendarViewMode
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode.Month Field

MonthCalendarViewModeMonth Field
Indicates that the calendar will present a month view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewMode Month = 0
Public Const Month As MonthCalendarViewMode = 0

Field Value

Type: MonthCalendarViewMode
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode.value__ Field

MonthCalendarViewModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.MonthCalendarViewMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewMode.Year Field

MonthCalendarViewModeYear Field
Indicates that the calendar will present a year view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewMode Year = 1
Public Const Year As MonthCalendarViewMode = 1

Field Value

Type: MonthCalendarViewMode
See Also

Reference

MonthCalendarViewMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode Class

MonthCalendarViewResetMode Class
Specifies the view reset mode of a MonthCalendar when it loses focus.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendarViewResetMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MonthCalendarViewResetMode : Enum
Public NotInheritable Class MonthCalendarViewResetMode
    Inherits Enum

The MonthCalendarViewResetMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Active | Indicates that the calendar view will be zoomed into the month view that contains the active date.
 | FirstSelected | Indicates that the calendar view will be zoomed into the month view that contains the first selected date.
 | None | Indicates that the calendar view will not be reset.
 | Today | Indicates that the calendar view will be zoomed into the month view that contains DateTime.Today.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode Methods

MonthCalendarViewResetMode Methods

The MonthCalendarViewResetMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode Fields

MonthCalendarViewResetMode Fields

The MonthCalendarViewResetMode type exposes the following members.

Fields
 | Name | Description
 | Active | Indicates that the calendar view will be zoomed into the month view that contains the active date.
 | FirstSelected | Indicates that the calendar view will be zoomed into the month view that contains the first selected date.
 | None | Indicates that the calendar view will not be reset.
 | Today | Indicates that the calendar view will be zoomed into the month view that contains DateTime.Today.
Public field | value__ |
Top
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode.Active Field

MonthCalendarViewResetModeActive Field
Indicates that the calendar view will be zoomed into the month view that contains the active date.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewResetMode Active = 2
Public Const Active As MonthCalendarViewResetMode = 2

Field Value

Type: MonthCalendarViewResetMode
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode.FirstSelected Field

MonthCalendarViewResetModeFirstSelected Field
Indicates that the calendar view will be zoomed into the month view that contains the first selected date.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewResetMode FirstSelected = 3
Public Const FirstSelected As MonthCalendarViewResetMode = 3

Field Value

Type: MonthCalendarViewResetMode
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode.None Field

MonthCalendarViewResetModeNone Field
Indicates that the calendar view will not be reset.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewResetMode None = 0
Public Const None As MonthCalendarViewResetMode = 0

Field Value

Type: MonthCalendarViewResetMode
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode.Today Field

MonthCalendarViewResetModeToday Field
Indicates that the calendar view will be zoomed into the month view that contains DateTime.Today.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MonthCalendarViewResetMode Today = 1
Public Const Today As MonthCalendarViewResetMode = 1

Field Value

Type: MonthCalendarViewResetMode
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


MonthCalendarViewResetMode.value__ Field

MonthCalendarViewResetModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.MonthCalendarViewResetMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MonthCalendarViewResetMode Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers Class

PartEditBoxCommitTriggers Class
Specifies the triggers that force a PartEditBoxBase-derived control to immediately commit any changes.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsPartEditBoxCommitTriggers

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class PartEditBoxCommitTriggers : Enum
<FlagsAttribute>
Public NotInheritable Class PartEditBoxCommitTriggers
    Inherits Enum

The PartEditBoxCommitTriggers type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ActivePartChange | Indicates that changes will be committed when the active part changes. Other changes will only be committed when the control loses focus.
 | All | Indicates that changes will be always be committed immediately.
 | Default | Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus or when the Enter key is pressed. This is the same as EnterKeyDown | SpinnerChange.
 | EnterKeyDown | Indicates that changes made will be committed when the Enter key is pressed. Other changes will only be committed when the control loses focus.
 | None | Indicates that changes will only be committed when the control loses focus.
 | SpinnerChange | Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus.
 | StringValueChange | Indicates that changes will be committed immediately when typing and other text edits occur. Other changes will only be committed when the control loses focus.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers Methods

PartEditBoxCommitTriggers Methods

The PartEditBoxCommitTriggers type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers Fields

PartEditBoxCommitTriggers Fields

The PartEditBoxCommitTriggers type exposes the following members.

Fields
 | Name | Description
 | ActivePartChange | Indicates that changes will be committed when the active part changes. Other changes will only be committed when the control loses focus.
 | All | Indicates that changes will be always be committed immediately.
 | Default | Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus or when the Enter key is pressed. This is the same as EnterKeyDown | SpinnerChange.
 | EnterKeyDown | Indicates that changes made will be committed when the Enter key is pressed. Other changes will only be committed when the control loses focus.
 | None | Indicates that changes will only be committed when the control loses focus.
 | SpinnerChange | Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus.
 | StringValueChange | Indicates that changes will be committed immediately when typing and other text edits occur. Other changes will only be committed when the control loses focus.
Public field | value__ |
Top
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.ActivePartChange Field

PartEditBoxCommitTriggersActivePartChange Field
Indicates that changes will be committed when the active part changes. Other changes will only be committed when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers ActivePartChange = 4
Public Const ActivePartChange As PartEditBoxCommitTriggers = 4

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.All Field

PartEditBoxCommitTriggersAll Field
Indicates that changes will be always be committed immediately.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers All = 15
Public Const All As PartEditBoxCommitTriggers = 15

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.Default Field

PartEditBoxCommitTriggersDefault Field
Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus or when the Enter key is pressed. This is the same as EnterKeyDown | SpinnerChange.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers Default = 3
Public Const Default As PartEditBoxCommitTriggers = 3

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.EnterKeyDown Field

PartEditBoxCommitTriggersEnterKeyDown Field
Indicates that changes made will be committed when the Enter key is pressed. Other changes will only be committed when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers EnterKeyDown = 1
Public Const EnterKeyDown As PartEditBoxCommitTriggers = 1

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.None Field

PartEditBoxCommitTriggersNone Field
Indicates that changes will only be committed when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers None = 0
Public Const None As PartEditBoxCommitTriggers = 0

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.SpinnerChange Field

PartEditBoxCommitTriggersSpinnerChange Field
Indicates that changes made using an associated Spinner will be committed immediately. Other changes will only be committed when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers SpinnerChange = 2
Public Const SpinnerChange As PartEditBoxCommitTriggers = 2

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.StringValueChange Field

PartEditBoxCommitTriggersStringValueChange Field
Indicates that changes will be committed immediately when typing and other text edits occur. Other changes will only be committed when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PartEditBoxCommitTriggers StringValueChange = 8
Public Const StringValueChange As PartEditBoxCommitTriggers = 8

Field Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PartEditBoxCommitTriggers.value__ Field

PartEditBoxCommitTriggersvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.PartEditBoxCommitTriggers.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PartEditBoxCommitTriggers Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox Class

PointEditBox Class
Represents a Point edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Point
ActiproSoftware.UI.Xaml.Controls.EditorsPointEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PointEditBox : PartEditBoxBase<Nullable<Point>>
Public Class PointEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Point))

The PointEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | PointEditBox | Initializes an instance of the PointEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox Constructor

PointEditBox Constructor
Initializes an instance of the PointEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PointEditBox()
Public Sub New
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox Properties

PointEditBox Properties

The PointEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.Format Property

PointEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.LargeChange Property

PointEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point LargeChange { get; set; }
Public Property LargeChange As Point
    Get
    Set

Property Value

Type: Point
The large change value. The default value is 5.0.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.Maximum Property

PointEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
The highest possible value.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.Minimum Property

PointEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
The lowest possible value.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.ResolvedFormat Property

PointEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.SmallChange Property

PointEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
The small change value. The default value is 1.0.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox Methods

PointEditBox Methods

The PointEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.ConvertToString Method

PointEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Point> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Point)
) As String

Parameters

valueToConvert
Type: SystemNullable Point
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.CreateIncrementalChangeRequest Method

PointEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Point>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Point))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Point
The incremental change (spin) request that was created.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.GenerateParts Method

PointEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.IsValidValue Method

PointEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Point> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Point)
) As Boolean

Parameters

value
Type: SystemNullable Point
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.RaiseValueChangedEvent Method

PointEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.ResetValue Method

PointEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.TryConvertFromString Method

PointEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Point> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Point)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Point
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox Events

PointEditBox Events

The PointEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.ValueChanged Event

PointEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox Fields

PointEditBox Fields

The PointEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.FormatProperty Field

PointEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.LargeChangeProperty Field

PointEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.MaximumProperty Field

PointEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.MinimumProperty Field

PointEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.ResolvedFormatProperty Field

PointEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointEditBox.SmallChangeProperty Field

PointEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

PointEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker Class

PointPicker Class
Represents a Point picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsPointPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PointPicker : PickerBase
Public Class PointPicker
    Inherits PickerBase

The PointPicker type exposes the following members.

Constructors
 | Name | Description
Public method | PointPicker | Initializes an instance of the PointPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker Constructor

PointPicker Constructor
Initializes an instance of the PointPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PointPicker()
Public Sub New
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker Properties

PointPicker Properties

The PointPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.Maximum Property

PointPickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
The highest possible value.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.Minimum Property

PointPickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
The lowest possible value.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.SmallChange Property

PointPickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
The small change value. The default value is 1.0.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.Value Property

PointPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Value { get; set; }
Public Property Value As Point
    Get
    Set

Property Value

Type: Point
The value of the control.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker Methods

PointPicker Methods

The PointPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.OnApplyTemplate Method

PointPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker Events

PointPicker Events

The PointPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.ValueChanged Event

PointPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker Fields

PointPicker Fields

The PointPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.MaximumProperty Field

PointPickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.MinimumProperty Field

PointPickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.SmallChangeProperty Field

PointPickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


PointPicker.ValueProperty Field

PointPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PointPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker Class

RadialHuePicker Class
Represents a radial color hue picker control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.EditorsRadialHuePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RadialHuePicker : ContentControl
Public Class RadialHuePicker
    Inherits ContentControl

The RadialHuePicker type exposes the following members.

Constructors
 | Name | Description
Public method | RadialHuePicker | Initializes an instance of the RadialHuePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the ring's outer radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SliderRadius | Gets the slider's radius.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HueProperty | Identifies the Hue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
SliderRadiusProperty | Identifies the SliderRadius dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker Constructor

RadialHuePicker Constructor
Initializes an instance of the RadialHuePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RadialHuePicker()
Public Sub New
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker Properties

RadialHuePicker Properties

The RadialHuePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the ring's outer radius.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SliderRadius | Gets the slider's radius.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.Hue Property

RadialHuePickerHue Property
Gets or sets the color hue.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The color hue. The default value is 0.0.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.Radius Property

RadialHuePickerRadius Property
Gets or sets the ring's outer radius.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Radius { get; set; }
Public Property Radius As Double
    Get
    Set

Property Value

Type: Double
The ring's outer radius. The default value is 130.0.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.SliderRadius Property

RadialHuePickerSliderRadius Property
Gets the slider's radius.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SliderRadius { get; }
Public ReadOnly Property SliderRadius As Double
    Get

Property Value

Type: Double
The slider's radius.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker Methods

RadialHuePicker Methods

The RadialHuePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.OnApplyTemplate Method

RadialHuePickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.OnCreateAutomationPeer Method

RadialHuePickerOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker Events

RadialHuePicker Events

The RadialHuePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | HueChanged | Occurs after the Hue property value changes.
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.HueChanged Event

RadialHuePickerHueChanged Event
Occurs after the Hue property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler HueChanged
Public Event HueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker Fields

RadialHuePicker Fields

The RadialHuePicker type exposes the following members.

Fields
Name | Description
HueProperty | Identifies the Hue dependency property. This field is read-only.
RadiusProperty | Identifies the Radius dependency property. This field is read-only.
SliderRadiusProperty | Identifies the SliderRadius dependency property. This field is read-only.
Top
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.HueProperty Field

RadialHuePickerHueProperty Field
Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.RadiusProperty Field

RadialHuePickerRadiusProperty Field
Identifies the Radius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RadiusProperty
Public Shared ReadOnly RadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Radius dependency property.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RadialHuePicker.SliderRadiusProperty Field

RadialHuePickerSliderRadiusProperty Field
Identifies the SliderRadius dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SliderRadiusProperty
Public Shared ReadOnly SliderRadiusProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SliderRadius dependency property.
See Also

Reference

RadialHuePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating Class

Rating Class
Represents a rating control that allows the user to set or view a rating of an entity.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.EditorsRating

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Rating : ItemsControl, IOrientedElement
Public Class Rating
    Inherits ItemsControl
    Implements IOrientedElement

The Rating type exposes the following members.

Constructors
 | Name | Description
Public method | Rating | Initializes an instance of the Rating class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AverageValue | Gets or sets the average rating value currently presented by the control.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClearValueCommand | Gets the ICommand that can clear the value.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | ItemCount | Gets or sets the number of items to display in the rating.
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the rating value currently presented by the control, if any.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection has changed. (Overrides ItemsControlOnItemsChanged(Object).)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
AverageValueProperty | Identifies the AverageValue dependency property. This field is read-only.
ItemCountProperty | Identifies the read-only ItemCount dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating Constructor

Rating Constructor
Initializes an instance of the Rating class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rating()
Public Sub New
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating Properties

Rating Properties

The Rating type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AverageValue | Gets or sets the average rating value currently presented by the control.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClearValueCommand | Gets the ICommand that can clear the value.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | ItemCount | Gets or sets the number of items to display in the rating.
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the rating value currently presented by the control, if any.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.AverageValue Property

RatingAverageValue Property
Gets or sets the average rating value currently presented by the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AverageValue { get; set; }
Public Property AverageValue As Double
    Get
    Set

Property Value

Type: Double
The average rating value currently presented by the control. The default value is 0.0.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.ClearValueCommand Property

RatingClearValueCommand Property
Gets the ICommand that can clear the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ClearValueCommand { get; }
Public ReadOnly Property ClearValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can clear the value.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.ItemCount Property

RatingItemCount Property
Gets or sets the number of items to display in the rating.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int ItemCount { get; set; }
Public Property ItemCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of items to display in the rating. The default value is 0.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.Orientation Property

RatingOrientation Property
Gets or sets the Orientation of the child element layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Horizontal.

Implements

IOrientedElementOrientation
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.Value Property

RatingValue Property
Gets or sets the rating value currently presented by the control, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<double> Value { get; set; }
Public Property Value As Nullable(Of Double)
    Get
    Set

Property Value

Type: Nullable Double
The rating value currently presented by the control, if any. The default value is .
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating Methods

Rating Methods

The Rating type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines whether the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Occurs when the Items collection has changed. (Overrides ItemsControlOnItemsChanged(Object).)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.OnCreateAutomationPeer Method

RatingOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.OnItemsChanged Method

RatingOnItemsChanged Method
Occurs when the Items collection has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemsChanged(
    Object e
)
Protected Overrides Sub OnItemsChanged (
    e As Object
)

Parameters

e
Type: SystemObject
The Object that contains the event data.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.OnKeyDown Method

RatingOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating Events

Rating Events

The Rating type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.ValueChanged Event

RatingValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating Fields

Rating Fields

The Rating type exposes the following members.

Fields
Name | Description
AverageValueProperty | Identifies the AverageValue dependency property. This field is read-only.
ItemCountProperty | Identifies the read-only ItemCount dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.AverageValueProperty Field

RatingAverageValueProperty Field
Identifies the AverageValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AverageValueProperty
Public Shared ReadOnly AverageValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AverageValue dependency property.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.ItemCountProperty Field

RatingItemCountProperty Field
Identifies the read-only ItemCount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemCountProperty
Public Shared ReadOnly ItemCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemCount dependency property.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.OrientationProperty Field

RatingOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


Rating.ValueProperty Field

RatingValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

Rating Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem Class

RatingItem Class
Represents a single item in a Rating control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.EditorsRatingItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RatingItem : ContentControl, IOrientedElement
Public Class RatingItem
    Inherits ContentControl
    Implements IOrientedElement

The RatingItem type exposes the following members.

Constructors
 | Name | Description
Public method | RatingItem | Initializes an instance of the RatingItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AverageGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ClipPercentage | Gets the clip percentage to apply on the foreground glyph.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NormalGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph in the normal (unselected) state.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in the end user's value selection.
Public property | State | Gets the current item state.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ActiveGlyphTemplateProperty | Identifies the ActiveGlyphTemplate dependency property. This field is read-only.
AverageGlyphTemplateProperty | Identifies the AverageGlyphTemplate dependency property. This field is read-only.
ClipPercentageProperty | Identifies the ClipPercentage dependency property. This field is read-only.
NormalGlyphTemplateProperty | Identifies the NormalGlyphTemplate dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedGlyphTemplateProperty | Identifies the SelectedGlyphTemplate dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem Constructor

RatingItem Constructor
Initializes an instance of the RatingItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RatingItem()
Public Sub New
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem Properties

RatingItem Properties

The RatingItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AverageGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ClipPercentage | Gets the clip percentage to apply on the foreground glyph.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NormalGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph in the normal (unselected) state.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedGlyphTemplate | Gets or sets the DataTemplate to use for the item glyph when the item is involved in the end user's value selection.
Public property | State | Gets the current item state.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.ActiveGlyphTemplate Property

RatingItemActiveGlyphTemplate Property
Gets or sets the DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ActiveGlyphTemplate { get; set; }
Public Property ActiveGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph when the end user's pointer actively over this item or one after it.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.AverageGlyphTemplate Property

RatingItemAverageGlyphTemplate Property
Gets or sets the DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate AverageGlyphTemplate { get; set; }
Public Property AverageGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph when the item is involved in rendering an average value for the overall rating.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.ClipPercentage Property

RatingItemClipPercentage Property
Gets the clip percentage to apply on the foreground glyph.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ClipPercentage { get; }
Public ReadOnly Property ClipPercentage As Double
    Get

Property Value

Type: Double
The clip percentage to apply on the foreground glyph.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.NormalGlyphTemplate Property

RatingItemNormalGlyphTemplate Property
Gets or sets the DataTemplate to use for the item glyph in the normal (unselected) state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate NormalGlyphTemplate { get; set; }
Public Property NormalGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph in the normal (unselected) state.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.Orientation Property

RatingItemOrientation Property
Gets the Orientation of the child element layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; }
Public ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The Orientation of the child element layout. The default value is Vertical.

Implements

IOrientedElementOrientation
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.SelectedGlyphTemplate Property

RatingItemSelectedGlyphTemplate Property
Gets or sets the DataTemplate to use for the item glyph when the item is involved in the end user's value selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate SelectedGlyphTemplate { get; set; }
Public Property SelectedGlyphTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the item glyph when the item is involved in the end user's value selection.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.State Property

RatingItemState Property
Gets the current item state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RatingItemState State { get; }
Public ReadOnly Property State As RatingItemState
    Get

Property Value

Type: RatingItemState
A RatingItemState that indicates the current item state.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem Methods

RatingItem Methods

The RatingItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.OnApplyTemplate Method

RatingItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem Events

RatingItem Events

The RatingItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem Fields

RatingItem Fields

The RatingItem type exposes the following members.

Fields
Name | Description
ActiveGlyphTemplateProperty | Identifies the ActiveGlyphTemplate dependency property. This field is read-only.
AverageGlyphTemplateProperty | Identifies the AverageGlyphTemplate dependency property. This field is read-only.
ClipPercentageProperty | Identifies the ClipPercentage dependency property. This field is read-only.
NormalGlyphTemplateProperty | Identifies the NormalGlyphTemplate dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
SelectedGlyphTemplateProperty | Identifies the SelectedGlyphTemplate dependency property. This field is read-only.
StateProperty | Identifies the State dependency property. This field is read-only.
Top
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.ActiveGlyphTemplateProperty Field

RatingItemActiveGlyphTemplateProperty Field
Identifies the ActiveGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActiveGlyphTemplateProperty
Public Shared ReadOnly ActiveGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActiveGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.AverageGlyphTemplateProperty Field

RatingItemAverageGlyphTemplateProperty Field
Identifies the AverageGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AverageGlyphTemplateProperty
Public Shared ReadOnly AverageGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AverageGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.ClipPercentageProperty Field

RatingItemClipPercentageProperty Field
Identifies the ClipPercentage dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClipPercentageProperty
Public Shared ReadOnly ClipPercentageProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ClipPercentage dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.NormalGlyphTemplateProperty Field

RatingItemNormalGlyphTemplateProperty Field
Identifies the NormalGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NormalGlyphTemplateProperty
Public Shared ReadOnly NormalGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NormalGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.OrientationProperty Field

RatingItemOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.SelectedGlyphTemplateProperty Field

RatingItemSelectedGlyphTemplateProperty Field
Identifies the SelectedGlyphTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedGlyphTemplateProperty
Public Shared ReadOnly SelectedGlyphTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedGlyphTemplate dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItem.StateProperty Field

RatingItemStateProperty Field
Identifies the State dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StateProperty
Public Shared ReadOnly StateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the State dependency property.
See Also

Reference

RatingItem Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState Class

RatingItemState Class
Specifies the various states supported by RatingItem.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsRatingItemState

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class RatingItemState : Enum
Public NotInheritable Class RatingItemState
    Inherits Enum

The RatingItemState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Active | The rating item or one of the items after it has the end user's pointer actively over it.
 | Average | The rating item is involved in rendering an average value for the overall rating.
 | Normal | The rating item is in a normal (unselected) state.
 | Selected | The rating item is involved in the end user's value selection.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState Methods

RatingItemState Methods

The RatingItemState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState Fields

RatingItemState Fields

The RatingItemState type exposes the following members.

Fields
 | Name | Description
 | Active | The rating item or one of the items after it has the end user's pointer actively over it.
 | Average | The rating item is involved in rendering an average value for the overall rating.
 | Normal | The rating item is in a normal (unselected) state.
 | Selected | The rating item is involved in the end user's value selection.
Public field | value__ |
Top
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState.Active Field

RatingItemStateActive Field
The rating item or one of the items after it has the end user's pointer actively over it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RatingItemState Active = 1
Public Const Active As RatingItemState = 1

Field Value

Type: RatingItemState
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState.Average Field

RatingItemStateAverage Field
The rating item is involved in rendering an average value for the overall rating.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RatingItemState Average = 2
Public Const Average As RatingItemState = 2

Field Value

Type: RatingItemState
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState.Normal Field

RatingItemStateNormal Field
The rating item is in a normal (unselected) state.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RatingItemState Normal = 0
Public Const Normal As RatingItemState = 0

Field Value

Type: RatingItemState
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState.Selected Field

RatingItemStateSelected Field
The rating item is involved in the end user's value selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const RatingItemState Selected = 3
Public Const Selected As RatingItemState = 3

Field Value

Type: RatingItemState
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RatingItemState.value__ Field

RatingItemStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.RatingItemState.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

RatingItemState Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox Class

RectEditBox Class
Represents a Rect edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Rect
ActiproSoftware.UI.Xaml.Controls.EditorsRectEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RectEditBox : PartEditBoxBase<Nullable<Rect>>
Public Class RectEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Rect))

The RectEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | RectEditBox | Initializes an instance of the RectEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox Constructor

RectEditBox Constructor
Initializes an instance of the RectEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RectEditBox()
Public Sub New
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox Properties

RectEditBox Properties

The RectEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.Format Property

RectEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.LargeChange Property

RectEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect LargeChange { get; set; }
Public Property LargeChange As Rect
    Get
    Set

Property Value

Type: Rect
The large change value. The default value is 5.0.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.Maximum Property

RectEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
The highest possible value.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.Minimum Property

RectEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
The lowest possible value.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.ResolvedFormat Property

RectEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.SmallChange Property

RectEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
The small change value. The default value is 1.0.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox Methods

RectEditBox Methods

The RectEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.ConvertToString Method

RectEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Rect> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Rect)
) As String

Parameters

valueToConvert
Type: SystemNullable Rect
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.CreateIncrementalChangeRequest Method

RectEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Rect>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Rect))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Rect
The incremental change (spin) request that was created.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.GenerateParts Method

RectEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.IsValidValue Method

RectEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Rect> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Rect)
) As Boolean

Parameters

value
Type: SystemNullable Rect
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.RaiseValueChangedEvent Method

RectEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.ResetValue Method

RectEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.TryConvertFromString Method

RectEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Rect> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Rect)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Rect
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox Events

RectEditBox Events

The RectEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.ValueChanged Event

RectEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox Fields

RectEditBox Fields

The RectEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.FormatProperty Field

RectEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.LargeChangeProperty Field

RectEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.MaximumProperty Field

RectEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.MinimumProperty Field

RectEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.ResolvedFormatProperty Field

RectEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectEditBox.SmallChangeProperty Field

RectEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

RectEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker Class

RectPicker Class
Represents a Rect picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsRectPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RectPicker : PickerBase
Public Class RectPicker
    Inherits PickerBase

The RectPicker type exposes the following members.

Constructors
 | Name | Description
Public method | RectPicker | Initializes an instance of the RectPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker Constructor

RectPicker Constructor
Initializes an instance of the RectPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RectPicker()
Public Sub New
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker Properties

RectPicker Properties

The RectPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.Maximum Property

RectPickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
The highest possible value.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.Minimum Property

RectPickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
The lowest possible value.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.SmallChange Property

RectPickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
The small change value. The default value is 1.0.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.Value Property

RectPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Value { get; set; }
Public Property Value As Rect
    Get
    Set

Property Value

Type: Rect
The value of the control.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker Methods

RectPicker Methods

The RectPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.OnApplyTemplate Method

RectPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker Events

RectPicker Events

The RectPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.ValueChanged Event

RectPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker Fields

RectPicker Fields

The RectPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.MaximumProperty Field

RectPickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.MinimumProperty Field

RectPickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.SmallChangeProperty Field

RectPickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


RectPicker.ValueProperty Field

RectPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

RectPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker Class

SaturationBrightnessPicker Class
Represents a saturation/brightness picker control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.EditorsSaturationBrightnessPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SaturationBrightnessPicker : Control
Public Class SaturationBrightnessPicker
    Inherits Control

The SaturationBrightnessPicker type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationBrightnessPicker | Initializes an instance of the SaturationBrightnessPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the color brightness.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Saturation | Gets or sets the color saturation.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker Constructor

SaturationBrightnessPicker Constructor
Initializes an instance of the SaturationBrightnessPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SaturationBrightnessPicker()
Public Sub New
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker Properties

SaturationBrightnessPicker Properties

The SaturationBrightnessPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Brightness | Gets or sets the color brightness.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the color hue.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Saturation | Gets or sets the color saturation.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.Brightness Property

SaturationBrightnessPickerBrightness Property
Gets or sets the color brightness.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Brightness { get; set; }
Public Property Brightness As Double
    Get
    Set

Property Value

Type: Double
The color brightness.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.Hue Property

SaturationBrightnessPickerHue Property
Gets or sets the color hue.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The color hue.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.Saturation Property

SaturationBrightnessPickerSaturation Property
Gets or sets the color saturation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set

Property Value

Type: Double
The color saturation.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker Methods

SaturationBrightnessPicker Methods

The SaturationBrightnessPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.OnApplyTemplate Method

SaturationBrightnessPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.OnCreateAutomationPeer Method

SaturationBrightnessPickerOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker Events

SaturationBrightnessPicker Events

The SaturationBrightnessPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | BrightnessChanged | Occurs after the Brightness property value changes.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SaturationChanged | Occurs after the Saturation property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.BrightnessChanged Event

SaturationBrightnessPickerBrightnessChanged Event
Occurs after the Brightness property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler BrightnessChanged
Public Event BrightnessChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.SaturationChanged Event

SaturationBrightnessPickerSaturationChanged Event
Occurs after the Saturation property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler SaturationChanged
Public Event SaturationChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker Fields

SaturationBrightnessPicker Fields

The SaturationBrightnessPicker type exposes the following members.

Fields
Name | Description
BrightnessProperty | Identifies the Brightness dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationProperty | Identifies the Saturation dependency property. This field is read-only.
Top
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.BrightnessProperty Field

SaturationBrightnessPickerBrightnessProperty Field
Identifies the Brightness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessProperty
Public Shared ReadOnly BrightnessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Brightness dependency property.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.HueProperty Field

SaturationBrightnessPickerHueProperty Field
Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SaturationBrightnessPicker.SaturationProperty Field

SaturationBrightnessPickerSaturationProperty Field
Identifies the Saturation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationProperty
Public Shared ReadOnly SaturationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Saturation dependency property.
See Also

Reference

SaturationBrightnessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox Class

SingleEditBox Class
Represents a Single edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Single
ActiproSoftware.UI.Xaml.Controls.EditorsSingleEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SingleEditBox : PartEditBoxBase<Nullable<float>>
Public Class SingleEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Single))

The SingleEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | SingleEditBox | Initializes an instance of the SingleEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox Constructor

SingleEditBox Constructor
Initializes an instance of the SingleEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SingleEditBox()
Public Sub New
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox Properties

SingleEditBox Properties

The SingleEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CalculatorPopupPickerStyle | Gets or sets the popup picker Style that uses a Calculator control.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNaNAllowed | Gets or sets whether NaN is accepted as a value.
Public property | IsNegativeInfinityAllowed | Gets or sets whether NegativeInfinity is accepted as a value.
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsPositiveInfinityAllowed | Gets or sets whether PositiveInfinity is accepted as a value.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PickerKind | Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.CalculatorPopupPickerStyle Property

SingleEditBoxCalculatorPopupPickerStyle Property
Gets or sets the popup picker Style that uses a Calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CalculatorPopupPickerStyle { get; set; }
Public Property CalculatorPopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that uses a Calculator control.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.Format Property

SingleEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsNaNAllowed Property

SingleEditBoxIsNaNAllowed Property
Gets or sets whether NaN is accepted as a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NaN is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsNegativeInfinityAllowed Property

SingleEditBoxIsNegativeInfinityAllowed Property
Gets or sets whether NegativeInfinity is accepted as a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if NegativeInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsPositiveInfinityAllowed Property

SingleEditBoxIsPositiveInfinityAllowed Property
Gets or sets whether PositiveInfinity is accepted as a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if PositiveInfinity is accepted as a value; otherwise, false. The default value is false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.LargeChange Property

SingleEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float LargeChange { get; set; }
Public Property LargeChange As Single
    Get
    Set

Property Value

Type: Single
The large change value. The default value is 5.0.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.Maximum Property

SingleEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
The highest possible value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.Minimum Property

SingleEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
The lowest possible value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.PickerKind Property

SingleEditBoxPickerKind Property
Gets or sets a SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SingleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As SingleEditBoxPickerKind
    Get
    Set

Property Value

Type: SingleEditBoxPickerKind
A SingleEditBoxPickerKind indicating the pre-defined Style to apply to the picker used within the popup. The default value is Calculator in WPF and Default in UWP.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.ResolvedFormat Property

SingleEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.SmallChange Property

SingleEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
The small change value. The default value is 1.0.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox Methods

SingleEditBox Methods

The SingleEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Overrides PartEditBoxBaseTProcessTextInput(String).)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.ConvertToString Method

SingleEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<float> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Single)
) As String

Parameters

valueToConvert
Type: SystemNullable Single
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.CreateIncrementalChangeRequest Method

SingleEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<float>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Single))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Single
The incremental change (spin) request that was created.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.GenerateParts Method

SingleEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsValidValue Method

SingleEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<float> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Single)
) As Boolean

Parameters

value
Type: SystemNullable Single
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.ProcessTextInput Method

SingleEditBoxProcessTextInput Method
Processes typed text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool ProcessTextInput(
    string text
)
Protected Overrides Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.RaiseValueChangedEvent Method

SingleEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.ResetValue Method

SingleEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.TryConvertFromString Method

SingleEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<float> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Single)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Single
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox Events

SingleEditBox Events

The SingleEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.ValueChanged Event

SingleEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox Fields

SingleEditBox Fields

The SingleEditBox type exposes the following members.

Fields
Name | Description
CalculatorPopupPickerStyleProperty | Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.
FormatProperty | Identifies the Format dependency property. This field is read-only.
IsNaNAllowedProperty | Identifies the IsNaNAllowed dependency property. This field is read-only.
IsNegativeInfinityAllowedProperty | Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.
IsPositiveInfinityAllowedProperty | Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
PickerKindProperty | Identifies the PickerKind dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.CalculatorPopupPickerStyleProperty Field

SingleEditBoxCalculatorPopupPickerStyleProperty Field
Identifies the CalculatorPopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CalculatorPopupPickerStyleProperty
Public Shared ReadOnly CalculatorPopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CalculatorPopupPickerStyle dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.FormatProperty Field

SingleEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsNaNAllowedProperty Field

SingleEditBoxIsNaNAllowedProperty Field
Identifies the IsNaNAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNaNAllowedProperty
Public Shared ReadOnly IsNaNAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNaNAllowed dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsNegativeInfinityAllowedProperty Field

SingleEditBoxIsNegativeInfinityAllowedProperty Field
Identifies the IsNegativeInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNegativeInfinityAllowedProperty
Public Shared ReadOnly IsNegativeInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNegativeInfinityAllowed dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.IsPositiveInfinityAllowedProperty Field

SingleEditBoxIsPositiveInfinityAllowedProperty Field
Identifies the IsPositiveInfinityAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPositiveInfinityAllowedProperty
Public Shared ReadOnly IsPositiveInfinityAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPositiveInfinityAllowed dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.LargeChangeProperty Field

SingleEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.MaximumProperty Field

SingleEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.MinimumProperty Field

SingleEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.PickerKindProperty Field

SingleEditBoxPickerKindProperty Field
Identifies the PickerKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PickerKindProperty
Public Shared ReadOnly PickerKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PickerKind dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.ResolvedFormatProperty Field

SingleEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBox.SmallChangeProperty Field

SingleEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SingleEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBoxPickerKind Class

SingleEditBoxPickerKind Class
Specifies the kind of Style to apply to the SinglePicker used within a SingleEditBox's popup.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsSingleEditBoxPickerKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SingleEditBoxPickerKind : Enum
Public NotInheritable Class SingleEditBoxPickerKind
    Inherits Enum

The SingleEditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default SinglePicker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBoxPickerKind Methods

SingleEditBoxPickerKind Methods

The SingleEditBoxPickerKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SingleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBoxPickerKind Fields

SingleEditBoxPickerKind Fields

The SingleEditBoxPickerKind type exposes the following members.

Fields
 | Name | Description
 | Calculator | Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.
 | Default | Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default SinglePicker style, which is templated to contain a radial slider control.
Public field | value__ |
Top
See Also

Reference

SingleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBoxPickerKind.Calculator Field

SingleEditBoxPickerKindCalculator Field
Uses the Style set to the CalculatorPopupPickerStyle property, which is templated to contain a calculator control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SingleEditBoxPickerKind Calculator = 1
Public Const Calculator As SingleEditBoxPickerKind = 1

Field Value

Type: SingleEditBoxPickerKind
See Also

Reference

SingleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBoxPickerKind.Default Field

SingleEditBoxPickerKindDefault Field
Use the Style set to the PopupPickerStyle property, and if that is not specified, uses the default SinglePicker style, which is templated to contain a radial slider control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SingleEditBoxPickerKind Default = 0
Public Const Default As SingleEditBoxPickerKind = 0

Field Value

Type: SingleEditBoxPickerKind
See Also

Reference

SingleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SingleEditBoxPickerKind.value__ Field

SingleEditBoxPickerKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.SingleEditBoxPickerKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SingleEditBoxPickerKind Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker Class

SinglePicker Class
Represents a Single picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsSinglePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SinglePicker : RadialSliderPickerBase
Public Class SinglePicker
    Inherits RadialSliderPickerBase

The SinglePicker type exposes the following members.

Constructors
 | Name | Description
Public method | SinglePicker | Initializes an instance of the SinglePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker Constructor

SinglePicker Constructor
Initializes an instance of the SinglePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SinglePicker()
Public Sub New
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker Properties

SinglePicker Properties

The SinglePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider. (Inherited from RadialSliderPickerBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup. (Inherited from RadialSliderPickerBase.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount. (Inherited from RadialSliderPickerBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.Maximum Property

SinglePickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
The highest possible value.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.Minimum Property

SinglePickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
The lowest possible value.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.SmallChange Property

SinglePickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
The small change value. The default value is 1.0.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.Value Property

SinglePickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Value { get; set; }
Public Property Value As Single
    Get
    Set

Property Value

Type: Single
The value of the control.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker Methods

SinglePicker Methods

The SinglePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.OnApplyTemplate Method

SinglePickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker Events

SinglePicker Events

The SinglePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.ValueChanged Event

SinglePickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker Fields

SinglePicker Fields

The SinglePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.MaximumProperty Field

SinglePickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.MinimumProperty Field

SinglePickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.SmallChangeProperty Field

SinglePickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SinglePicker.ValueProperty Field

SinglePickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

SinglePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox Class

SizeEditBox Class
Represents a Size edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Size
ActiproSoftware.UI.Xaml.Controls.EditorsSizeEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SizeEditBox : PartEditBoxBase<Nullable<Size>>
Public Class SizeEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Size))

The SizeEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | SizeEditBox | Initializes an instance of the SizeEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox Constructor

SizeEditBox Constructor
Initializes an instance of the SizeEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SizeEditBox()
Public Sub New
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox Properties

SizeEditBox Properties

The SizeEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.Format Property

SizeEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.LargeChange Property

SizeEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size LargeChange { get; set; }
Public Property LargeChange As Size
    Get
    Set

Property Value

Type: Size
The large change value. The default value is 5.0.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.Maximum Property

SizeEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
The highest possible value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.Minimum Property

SizeEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
The lowest possible value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.ResolvedFormat Property

SizeEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.SmallChange Property

SizeEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
The small change value. The default value is 1.0.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox Methods

SizeEditBox Methods

The SizeEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.ConvertToString Method

SizeEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Size> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Size)
) As String

Parameters

valueToConvert
Type: SystemNullable Size
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.CreateIncrementalChangeRequest Method

SizeEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Size>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Size))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Size
The incremental change (spin) request that was created.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.GenerateParts Method

SizeEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.IsValidValue Method

SizeEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Size> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Size)
) As Boolean

Parameters

value
Type: SystemNullable Size
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.RaiseValueChangedEvent Method

SizeEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.ResetValue Method

SizeEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.TryConvertFromString Method

SizeEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Size> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Size)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Size
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox Events

SizeEditBox Events

The SizeEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.ValueChanged Event

SizeEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox Fields

SizeEditBox Fields

The SizeEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.FormatProperty Field

SizeEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.LargeChangeProperty Field

SizeEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.MaximumProperty Field

SizeEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.MinimumProperty Field

SizeEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.ResolvedFormatProperty Field

SizeEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizeEditBox.SmallChangeProperty Field

SizeEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SizeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker Class

SizePicker Class
Represents a Size picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsSizePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SizePicker : PickerBase
Public Class SizePicker
    Inherits PickerBase

The SizePicker type exposes the following members.

Constructors
 | Name | Description
Public method | SizePicker | Initializes an instance of the SizePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker Constructor

SizePicker Constructor
Initializes an instance of the SizePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SizePicker()
Public Sub New
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker Properties

SizePicker Properties

The SizePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.Maximum Property

SizePickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
The highest possible value.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.Minimum Property

SizePickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
The lowest possible value.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.SmallChange Property

SizePickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
The small change value. The default value is 1.0.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.Value Property

SizePickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Value { get; set; }
Public Property Value As Size
    Get
    Set

Property Value

Type: Size
The value of the control.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker Methods

SizePicker Methods

The SizePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.OnApplyTemplate Method

SizePickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker Events

SizePicker Events

The SizePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.ValueChanged Event

SizePickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker Fields

SizePicker Fields

The SizePicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.MaximumProperty Field

SizePickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.MinimumProperty Field

SizePickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.SmallChangeProperty Field

SizePickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SizePicker.ValueProperty Field

SizePickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

SizePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping Class

SpinWrapping Class
Specifies the various wrapping behaviors supported when spinning a value in a part edit box.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.EditorsSpinWrapping

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class SpinWrapping : Enum
Public NotInheritable Class SpinWrapping
    Inherits Enum

The SpinWrapping type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | NoWrap | Indicates that the values will not wrap when the minimum or maximum are reached.
 | SimpleWrap | Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value).
Public field | value__ |
 | Wrap | Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value), but may or may not include special handling (see remarks for more information).
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping Methods

SpinWrapping Methods

The SpinWrapping type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SpinWrapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping Fields

SpinWrapping Fields

The SpinWrapping type exposes the following members.

Fields
 | Name | Description
 | NoWrap | Indicates that the values will not wrap when the minimum or maximum are reached.
 | SimpleWrap | Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value).
Public field | value__ |
 | Wrap | Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value), but may or may not include special handling (see remarks for more information).
Top
See Also

Reference

SpinWrapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping.NoWrap Field

SpinWrappingNoWrap Field
Indicates that the values will not wrap when the minimum or maximum are reached.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SpinWrapping NoWrap = 0
Public Const NoWrap As SpinWrapping = 0

Field Value

Type: SpinWrapping
See Also

Reference

SpinWrapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping.SimpleWrap Field

SpinWrappingSimpleWrap Field
Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value).

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SpinWrapping SimpleWrap = 1
Public Const SimpleWrap As SpinWrapping = 1

Field Value

Type: SpinWrapping
Remarks
Some types can support more advanced wrapping behaviors, such as DateTime. For example, if you increment the minute part of the time "4:59pm", then there are three possible outcomes: 1. "4:59pm" - This is equivalent to the NoWrap option. 2. "4:00pm" - This is equivalent to the SimpleWrap option. 3. "5:00pm" - This is equivalent to the Wrap option, which affects the hour part.
See Also

Reference

SpinWrapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping.value__ Field

SpinWrappingvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.SpinWrapping.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SpinWrapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


SpinWrapping.Wrap Field

SpinWrappingWrap Field
Indicates that the values will wrap when the minimum or maximum are reached (e.g. incrementing the maximum value will result in the minimum value), but may or may not include special handling (see remarks for more information).

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SpinWrapping Wrap = 2
Public Const Wrap As SpinWrapping = 2

Field Value

Type: SpinWrapping
Remarks
Some types can support more advanced wrapping behaviors, such as DateTime. For example, if you increment the minute part of the time "4:59pm", then there are three possible outcomes: 1. "4:59pm" - This is equivalent to the NoWrap option. 2. "4:00pm" - This is equivalent to the SimpleWrap option. 3. "5:00pm" - This is equivalent to the Wrap option, which affects the hour part.
See Also

Reference

SpinWrapping Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox Class

ThicknessEditBox Class
Represents a Thickness edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable Thickness
ActiproSoftware.UI.Xaml.Controls.EditorsThicknessEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ThicknessEditBox : PartEditBoxBase<Nullable<Thickness>>
Public Class ThicknessEditBox
    Inherits PartEditBoxBase(Of Nullable(Of Thickness))

The ThicknessEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessEditBox | Initializes an instance of the ThicknessEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox Constructor

ThicknessEditBox Constructor
Initializes an instance of the ThicknessEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ThicknessEditBox()
Public Sub New
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox Properties

ThicknessEditBox Properties

The ThicknessEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the number format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Inherited from PartEditBoxBaseT.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved number format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.Format Property

ThicknessEditBoxFormat Property
Gets or sets the number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The number format string. The default value is "G".
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.LargeChange Property

ThicknessEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness LargeChange { get; set; }
Public Property LargeChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The large change value. The default value is 5.0.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.Maximum Property

ThicknessEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
The highest possible value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.Minimum Property

ThicknessEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
The lowest possible value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.ResolvedFormat Property

ThicknessEditBoxResolvedFormat Property
Gets the resolved number format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved number format string.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.SmallChange Property

ThicknessEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The small change value. The default value is 1.0.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox Methods

ThicknessEditBox Methods

The ThicknessEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.ConvertToString Method

ThicknessEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<Thickness> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of Thickness)
) As String

Parameters

valueToConvert
Type: SystemNullable Thickness
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.CreateIncrementalChangeRequest Method

ThicknessEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<Thickness>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of Thickness))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable Thickness
The incremental change (spin) request that was created.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.GenerateParts Method

ThicknessEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.IsValidValue Method

ThicknessEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<Thickness> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of Thickness)
) As Boolean

Parameters

value
Type: SystemNullable Thickness
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.RaiseValueChangedEvent Method

ThicknessEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.ResetValue Method

ThicknessEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.TryConvertFromString Method

ThicknessEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<Thickness> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of Thickness)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable Thickness
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox Events

ThicknessEditBox Events

The ThicknessEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.ValueChanged Event

ThicknessEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox Fields

ThicknessEditBox Fields

The ThicknessEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.FormatProperty Field

ThicknessEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.LargeChangeProperty Field

ThicknessEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.MaximumProperty Field

ThicknessEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.MinimumProperty Field

ThicknessEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.ResolvedFormatProperty Field

ThicknessEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessEditBox.SmallChangeProperty Field

ThicknessEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

ThicknessEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker Class

ThicknessPicker Class
Represents a Thickness picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsThicknessPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ThicknessPicker : PickerBase
Public Class ThicknessPicker
    Inherits PickerBase

The ThicknessPicker type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessPicker | Initializes an instance of the ThicknessPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker Constructor

ThicknessPicker Constructor
Initializes an instance of the ThicknessPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ThicknessPicker()
Public Sub New
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker Properties

ThicknessPicker Properties

The ThicknessPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.Maximum Property

ThicknessPickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
The highest possible value.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.Minimum Property

ThicknessPickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
The lowest possible value.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.SmallChange Property

ThicknessPickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
The small change value. The default value is 1.0.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.Value Property

ThicknessPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Value { get; set; }
Public Property Value As Thickness
    Get
    Set

Property Value

Type: Thickness
The value of the control.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker Methods

ThicknessPicker Methods

The ThicknessPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.OnApplyTemplate Method

ThicknessPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker Events

ThicknessPicker Events

The ThicknessPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.ValueChanged Event

ThicknessPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker Fields

ThicknessPicker Fields

The ThicknessPicker type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.MaximumProperty Field

ThicknessPickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.MinimumProperty Field

ThicknessPickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.SmallChangeProperty Field

ThicknessPickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ThicknessPicker.ValueProperty Field

ThicknessPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

ThicknessPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox Class

TimeEditBox Class
Represents a time-only edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable DateTime
ActiproSoftware.UI.Xaml.Controls.EditorsDateTimeEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsTimeEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimeEditBox : DateTimeEditBox
Public Class TimeEditBox
    Inherits DateTimeEditBox

The TimeEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | TimeEditBox | Initializes an instance of the TimeEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides DateTimeEditBoxHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Inherited from DateTimeEditBox.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox Constructor

TimeEditBox Constructor
Initializes an instance of the TimeEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeEditBox()
Public Sub New
See Also

Reference

TimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox Properties

TimeEditBox Properties

The TimeEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the date/time format string. (Inherited from DateTimeEditBox.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides DateTimeEditBoxHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value. (Inherited from DateTimeEditBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value. (Inherited from DateTimeEditBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved date/time format string. (Inherited from DateTimeEditBox.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox.HasPopupButtonWhenReadOnly Property

TimeEditBoxHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

TimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox Methods

TimeEditBox Methods

The TimeEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Inherited from DateTimeEditBox.)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Inherited from DateTimeEditBox.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Inherited from DateTimeEditBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Inherited from DateTimeEditBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Inherited from DateTimeEditBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides DateTimeEditBoxResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Inherited from DateTimeEditBox.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox.ResetValue Method

TimeEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

TimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeEditBox Events

TimeEditBox Events

The TimeEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from DateTimeEditBox.)
Top
See Also

Reference

TimeEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker Class

TimePicker Class
Represents a time picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsTimePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimePicker : PickerBase
Public Class TimePicker
    Inherits PickerBase

The TimePicker type exposes the following members.

Constructors
 | Name | Description
Public method | TimePicker | Initializes an instance of the TimePicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hour | Gets or sets the hour value.
Public property | HourDegreeMaximum | Gets the highest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeMinimum | Gets the lowest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeValue | Gets or sets the hour value in degrees.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPM | Gets whether the time is PM.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minute | Gets or sets the minute value.
Public property | MinuteDegreeMaximum | Gets the highest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeMinimum | Gets the lowest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeValue | Gets or sets the minute value in degrees.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
HourDegreeMaximumProperty | Identifies the HourDegreeMaximum dependency property. This field is read-only.
HourDegreeMinimumProperty | Identifies the HourDegreeMinimum dependency property. This field is read-only.
HourDegreeValueProperty | Identifies the HourDegreeValue dependency property. This field is read-only.
HourProperty | Identifies the Hour dependency property. This field is read-only.
IsPMProperty | Identifies the IsPM dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinuteDegreeMaximumProperty | Identifies the MinuteDegreeMaximum dependency property. This field is read-only.
MinuteDegreeMinimumProperty | Identifies the MinuteDegreeMinimum dependency property. This field is read-only.
MinuteDegreeValueProperty | Identifies the MinuteDegreeValue dependency property. This field is read-only.
MinuteProperty | Identifies the Minute dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker Constructor

TimePicker Constructor
Initializes an instance of the TimePicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimePicker()
Public Sub New
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker Properties

TimePicker Properties

The TimePicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hour | Gets or sets the hour value.
Public property | HourDegreeMaximum | Gets the highest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeMinimum | Gets the lowest possible hour degree value, which can be bound to a radial slider.
Public property | HourDegreeValue | Gets or sets the hour value in degrees.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPM | Gets whether the time is PM.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minute | Gets or sets the minute value.
Public property | MinuteDegreeMaximum | Gets the highest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeMinimum | Gets the lowest possible minute degree value, which can be bound to a radial slider.
Public property | MinuteDegreeValue | Gets or sets the minute value in degrees.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.Hour Property

TimePickerHour Property
Gets or sets the hour value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Hour { get; set; }
Public Property Hour As Integer
    Get
    Set

Property Value

Type: Int32
The hour value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourDegreeMaximum Property

TimePickerHourDegreeMaximum Property
Gets the highest possible hour degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double HourDegreeMaximum { get; }
Public ReadOnly Property HourDegreeMaximum As Double
    Get

Property Value

Type: Double
The highest possible hour degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourDegreeMinimum Property

TimePickerHourDegreeMinimum Property
Gets the lowest possible hour degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double HourDegreeMinimum { get; }
Public ReadOnly Property HourDegreeMinimum As Double
    Get

Property Value

Type: Double
The lowest possible hour degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourDegreeValue Property

TimePickerHourDegreeValue Property
Gets or sets the hour value in degrees.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int HourDegreeValue { get; set; }
Public Property HourDegreeValue As Integer
    Get
    Set

Property Value

Type: Int32
The hour value in degrees.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.IsPM Property

TimePickerIsPM Property
Gets whether the time is PM.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPM { get; }
Public ReadOnly Property IsPM As Boolean
    Get

Property Value

Type: Boolean
true if the time is PM; otherwise, false.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.Maximum Property

TimePickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
The highest possible value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.Minimum Property

TimePickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
The lowest possible value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.Minute Property

TimePickerMinute Property
Gets or sets the minute value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Minute { get; set; }
Public Property Minute As Integer
    Get
    Set

Property Value

Type: Int32
The minute value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteDegreeMaximum Property

TimePickerMinuteDegreeMaximum Property
Gets the highest possible minute degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinuteDegreeMaximum { get; }
Public ReadOnly Property MinuteDegreeMaximum As Double
    Get

Property Value

Type: Double
The highest possible minute degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteDegreeMinimum Property

TimePickerMinuteDegreeMinimum Property
Gets the lowest possible minute degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinuteDegreeMinimum { get; }
Public ReadOnly Property MinuteDegreeMinimum As Double
    Get

Property Value

Type: Double
The lowest possible minute degree value.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteDegreeValue Property

TimePickerMinuteDegreeValue Property
Gets or sets the minute value in degrees.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int MinuteDegreeValue { get; set; }
Public Property MinuteDegreeValue As Integer
    Get
    Set

Property Value

Type: Int32
The degree minute value in degrees.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.Value Property

TimePickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Value { get; set; }
Public Property Value As DateTime
    Get
    Set

Property Value

Type: DateTime
The value of the control.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker Methods

TimePicker Methods

The TimePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.OnApplyTemplate Method

TimePickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker Events

TimePicker Events

The TimePicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.ValueChanged Event

TimePickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker Fields

TimePicker Fields

The TimePicker type exposes the following members.

Fields
Name | Description
HourDegreeMaximumProperty | Identifies the HourDegreeMaximum dependency property. This field is read-only.
HourDegreeMinimumProperty | Identifies the HourDegreeMinimum dependency property. This field is read-only.
HourDegreeValueProperty | Identifies the HourDegreeValue dependency property. This field is read-only.
HourProperty | Identifies the Hour dependency property. This field is read-only.
IsPMProperty | Identifies the IsPM dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinuteDegreeMaximumProperty | Identifies the MinuteDegreeMaximum dependency property. This field is read-only.
MinuteDegreeMinimumProperty | Identifies the MinuteDegreeMinimum dependency property. This field is read-only.
MinuteDegreeValueProperty | Identifies the MinuteDegreeValue dependency property. This field is read-only.
MinuteProperty | Identifies the Minute dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourDegreeMaximumProperty Field

TimePickerHourDegreeMaximumProperty Field
Identifies the HourDegreeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourDegreeMaximumProperty
Public Shared ReadOnly HourDegreeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HourDegreeMaximum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourDegreeMinimumProperty Field

TimePickerHourDegreeMinimumProperty Field
Identifies the HourDegreeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourDegreeMinimumProperty
Public Shared ReadOnly HourDegreeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HourDegreeMinimum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourDegreeValueProperty Field

TimePickerHourDegreeValueProperty Field
Identifies the HourDegreeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourDegreeValueProperty
Public Shared ReadOnly HourDegreeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HourDegreeValue dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.HourProperty Field

TimePickerHourProperty Field
Identifies the Hour dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HourProperty
Public Shared ReadOnly HourProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hour dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.IsPMProperty Field

TimePickerIsPMProperty Field
Identifies the IsPM dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPMProperty
Public Shared ReadOnly IsPMProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPM dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MaximumProperty Field

TimePickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinimumProperty Field

TimePickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteDegreeMaximumProperty Field

TimePickerMinuteDegreeMaximumProperty Field
Identifies the MinuteDegreeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteDegreeMaximumProperty
Public Shared ReadOnly MinuteDegreeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinuteDegreeMaximum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteDegreeMinimumProperty Field

TimePickerMinuteDegreeMinimumProperty Field
Identifies the MinuteDegreeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteDegreeMinimumProperty
Public Shared ReadOnly MinuteDegreeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinuteDegreeMinimum dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteDegreeValueProperty Field

TimePickerMinuteDegreeValueProperty Field
Identifies the MinuteDegreeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteDegreeValueProperty
Public Shared ReadOnly MinuteDegreeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinuteDegreeValue dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.MinuteProperty Field

TimePickerMinuteProperty Field
Identifies the Minute dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinuteProperty
Public Shared ReadOnly MinuteProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minute dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimePicker.ValueProperty Field

TimePickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

TimePicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox Class

TimeSpanEditBox Class
Represents a timespan edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase Nullable TimeSpan
ActiproSoftware.UI.Xaml.Controls.EditorsTimeSpanEditBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimeSpanEditBox : PartEditBoxBase<Nullable<TimeSpan>>
Public Class TimeSpanEditBox
    Inherits PartEditBoxBase(Of Nullable(Of TimeSpan))

The TimeSpanEditBox type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanEditBox | Initializes an instance of the TimeSpanEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the timespan format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved timespan format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox Constructor

TimeSpanEditBox Constructor
Initializes an instance of the TimeSpanEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpanEditBox()
Public Sub New
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox Properties

TimeSpanEditBox Properties

The TimeSpanEditBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in. (Inherited from PartEditBoxBaseT.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes. (Inherited from PartEditBoxBaseT.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset. (Inherited from PartEditBoxBaseT.)
Protected property | CurrentText | Gets the current text value in the TextBox. (Inherited from PartEditBoxBaseT.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Format | Gets or sets the timespan format string.
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true. (Inherited from PartEditBoxBaseT.)
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available. (Inherited from PartEditBoxBaseT.)
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only. (Overrides PartEditBoxBaseTHasPopupButtonWhenReadOnly.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from PartEditBoxBaseT.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from PartEditBoxBaseT.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text. (Inherited from PartEditBoxBaseT.)
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation. (Inherited from PartEditBoxBaseT.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts. (Inherited from PartEditBoxBaseT.)
Public property | IsClearButtonVisible | Gets whether the clear button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable. (Inherited from PartEditBoxBaseT.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsPopupOpen | Gets or sets whether the popup is open. (Inherited from PartEditBoxBaseT.)
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only. (Inherited from PartEditBoxBaseT.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible. (Inherited from PartEditBoxBaseT.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets the large change value.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts. (Inherited from PartEditBoxBaseT.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from PartEditBoxBaseT.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background. (Inherited from PartEditBoxBaseT.)
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border. (Inherited from PartEditBoxBaseT.)
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup. (Inherited from PartEditBoxBaseT.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value. (Inherited from PartEditBoxBaseT.)
Public property | ResolvedFormat | Gets the resolved timespan format string.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets the small change value.
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount. (Inherited from PartEditBoxBaseT.)
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part. (Inherited from PartEditBoxBaseT.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control. (Inherited from PartEditBoxBaseT.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.Format Property

TimeSpanEditBoxFormat Property
Gets or sets the timespan format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
The timespan format string. The default value is "g".
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.HasPopupButtonWhenReadOnly Property

TimeSpanEditBoxHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool HasPopupButtonWhenReadOnly { get; }
Protected Overrides ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.LargeChange Property

TimeSpanEditBoxLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan LargeChange { get; set; }
Public Property LargeChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The large change value. The default value is 7.3:5:5:050.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.Maximum Property

TimeSpanEditBoxMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The highest possible value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.Minimum Property

TimeSpanEditBoxMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The lowest possible value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.ResolvedFormat Property

TimeSpanEditBoxResolvedFormat Property
Gets the resolved timespan format string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ResolvedFormat { get; }
Public ReadOnly Property ResolvedFormat As String
    Get

Property Value

Type: String
The resolved timespan format string.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.SmallChange Property

TimeSpanEditBoxSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The small change value. The default value is 1.1:1:1:1.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox Methods

TimeSpanEditBox Methods

The TimeSpanEditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated. (Inherited from PartEditBoxBaseT.)
Protected method | ConvertToString | Converts the specified value to a string representation. (Overrides PartEditBoxBaseTConvertToString(T).)
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request. (Overrides PartEditBoxBaseTCreateIncrementalChangeRequest(IncrementalChangeRequestKind).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box. (Overrides PartEditBoxBaseTGenerateParts.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts. (Inherited from PartEditBoxBaseT.)
Protected method | IsValidValue | Returns whether the specified value is valid. (Overrides PartEditBoxBaseTIsValidValue(T).)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from PartEditBoxBaseT.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PartEditBoxBaseT.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from PartEditBoxBaseT.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from PartEditBoxBaseT.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes. (Inherited from PartEditBoxBaseT.)
Protected method | ProcessTextInput | Processes typed text. (Inherited from PartEditBoxBaseT.)
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event. (Overrides PartEditBoxBaseTRaiseValueChangedEvent.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value. (Overrides PartEditBoxBaseTResetValue.)
Public method | SelectAll | Selects all text in the edit box. (Inherited from PartEditBoxBaseT.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value. (Overrides PartEditBoxBaseTTryConvertFromString(String, Boolean, T).)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.ConvertToString Method

TimeSpanEditBoxConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string ConvertToString(
    Nullable<TimeSpan> valueToConvert
)
Protected Overrides Function ConvertToString (
    valueToConvert As Nullable(Of TimeSpan)
) As String

Parameters

valueToConvert
Type: SystemNullable TimeSpan
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.CreateIncrementalChangeRequest Method

TimeSpanEditBoxCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IncrementalChangeRequest<Nullable<TimeSpan>> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected Overrides Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of Nullable(Of TimeSpan))

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest Nullable TimeSpan
The incremental change (spin) request that was created.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.GenerateParts Method

TimeSpanEditBoxGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPart> GenerateParts()
Protected Overrides Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.IsValidValue Method

TimeSpanEditBoxIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValidValue(
    Nullable<TimeSpan> value
)
Protected Overrides Function IsValidValue (
    value As Nullable(Of TimeSpan)
) As Boolean

Parameters

value
Type: SystemNullable TimeSpan
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.RaiseValueChangedEvent Method

TimeSpanEditBoxRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RaiseValueChangedEvent()
Protected Overrides Sub RaiseValueChangedEvent
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.ResetValue Method

TimeSpanEditBoxResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ResetValue()
Protected Overrides Sub ResetValue
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.TryConvertFromString Method

TimeSpanEditBoxTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out Nullable<TimeSpan> value
)
Protected Overrides Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As Nullable(Of TimeSpan)
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: SystemNullable TimeSpan
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox Events

TimeSpanEditBox Events

The TimeSpanEditBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.ValueChanged Event

TimeSpanEditBoxValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox Fields

TimeSpanEditBox Fields

The TimeSpanEditBox type exposes the following members.

Fields
Name | Description
FormatProperty | Identifies the Format dependency property. This field is read-only.
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
ResolvedFormatProperty | Identifies the ResolvedFormat dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
Top
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.FormatProperty Field

TimeSpanEditBoxFormatProperty Field
Identifies the Format dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FormatProperty
Public Shared ReadOnly FormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Format dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.LargeChangeProperty Field

TimeSpanEditBoxLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.MaximumProperty Field

TimeSpanEditBoxMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.MinimumProperty Field

TimeSpanEditBoxMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.ResolvedFormatProperty Field

TimeSpanEditBoxResolvedFormatProperty Field
Identifies the ResolvedFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ResolvedFormatProperty
Public Shared ReadOnly ResolvedFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ResolvedFormat dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanEditBox.SmallChangeProperty Field

TimeSpanEditBoxSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

TimeSpanEditBox Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker Class

TimeSpanPicker Class
Represents a TimeSpan picker.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsTimeSpanPicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimeSpanPicker : PickerBase
Public Class TimeSpanPicker
    Inherits PickerBase

The TimeSpanPicker type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanPicker | Initializes an instance of the TimeSpanPicker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | Days | Gets the days component (0 - 255) of the Value.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hours | Gets the hours component (0 - 23) of the Value.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Milliseconds | Gets the milliseconds component (0 - 999) of the Value.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minutes | Gets the minutes component (0 - 59) of the Value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Seconds | Gets the seconds component (0 - 59) of the Value.
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
DaysProperty | Identifies the Days dependency property. This field is read-only.
HoursProperty | Identifies the Hours dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MillisecondsProperty | Identifies the Milliseconds dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinutesProperty | Identifies the Minutes dependency property. This field is read-only.
SecondsProperty | Identifies the Seconds dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker Constructor

TimeSpanPicker Constructor
Initializes an instance of the TimeSpanPicker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpanPicker()
Public Sub New
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker Properties

TimeSpanPicker Properties

The TimeSpanPicker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | Days | Gets the days component (0 - 255) of the Value.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hours | Gets the hours component (0 - 23) of the Value.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible value.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Milliseconds | Gets the milliseconds component (0 - 999) of the Value.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible value.
Public property | Minutes | Gets the minutes component (0 - 59) of the Value.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Seconds | Gets the seconds component (0 - 59) of the Value.
Public property | SmallChange | Gets or sets the small change value.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Days Property

TimeSpanPickerDays Property
Gets the days component (0 - 255) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Days { get; }
Public ReadOnly Property Days As Integer
    Get

Property Value

Type: Int32
The days component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Hours Property

TimeSpanPickerHours Property
Gets the hours component (0 - 23) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Hours { get; }
Public ReadOnly Property Hours As Integer
    Get

Property Value

Type: Int32
The hours component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Maximum Property

TimeSpanPickerMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The highest possible value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Milliseconds Property

TimeSpanPickerMilliseconds Property
Gets the milliseconds component (0 - 999) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Milliseconds { get; }
Public ReadOnly Property Milliseconds As Integer
    Get

Property Value

Type: Int32
The milliseconds component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Minimum Property

TimeSpanPickerMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The lowest possible value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Minutes Property

TimeSpanPickerMinutes Property
Gets the minutes component (0 - 59) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Minutes { get; }
Public ReadOnly Property Minutes As Integer
    Get

Property Value

Type: Int32
The minutes component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Seconds Property

TimeSpanPickerSeconds Property
Gets the seconds component (0 - 59) of the Value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Seconds { get; }
Public ReadOnly Property Seconds As Integer
    Get

Property Value

Type: Int32
The seconds component of the Value.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.SmallChange Property

TimeSpanPickerSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The small change value. The default value is 1.0.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.Value Property

TimeSpanPickerValue Property
Gets or sets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Value { get; set; }
Public Property Value As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
The value of the control.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker Methods

TimeSpanPicker Methods

The TimeSpanPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.OnApplyTemplate Method

TimeSpanPickerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker Events

TimeSpanPicker Events

The TimeSpanPicker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.ValueChanged Event

TimeSpanPickerValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker Fields

TimeSpanPicker Fields

The TimeSpanPicker type exposes the following members.

Fields
Name | Description
DaysProperty | Identifies the Days dependency property. This field is read-only.
HoursProperty | Identifies the Hours dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MillisecondsProperty | Identifies the Milliseconds dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
MinutesProperty | Identifies the Minutes dependency property. This field is read-only.
SecondsProperty | Identifies the Seconds dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.DaysProperty Field

TimeSpanPickerDaysProperty Field
Identifies the Days dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DaysProperty
Public Shared ReadOnly DaysProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Days dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.HoursProperty Field

TimeSpanPickerHoursProperty Field
Identifies the Hours dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HoursProperty
Public Shared ReadOnly HoursProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hours dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.MaximumProperty Field

TimeSpanPickerMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.MillisecondsProperty Field

TimeSpanPickerMillisecondsProperty Field
Identifies the Milliseconds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MillisecondsProperty
Public Shared ReadOnly MillisecondsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Milliseconds dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.MinimumProperty Field

TimeSpanPickerMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.MinutesProperty Field

TimeSpanPickerMinutesProperty Field
Identifies the Minutes dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinutesProperty
Public Shared ReadOnly MinutesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minutes dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.SecondsProperty Field

TimeSpanPickerSecondsProperty Field
Identifies the Seconds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecondsProperty
Public Shared ReadOnly SecondsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Seconds dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.SmallChangeProperty Field

TimeSpanPickerSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


TimeSpanPicker.ValueProperty Field

TimeSpanPickerValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

TimeSpanPicker Class
ActiproSoftware.UI.Xaml.Controls.Editors Namespace


ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace

[Missing <summary> documentation for "N:ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers"]

Classes
 | Class | Description
Public class | CalculatorAutomationPeer | Exposes Calculator types to UI Automation.
Public class | GradientStopSliderAutomationPeer | Exposes GradientStopSlider types to UI Automation.
Public class | HueRingAutomationPeer | Exposes HueRing types to UI Automation.
Public class | MonthCalendarAutomationPeer | Exposes MonthCalendar types to UI Automation.
Public class | PartEditBoxBaseAutomationPeerT | Exposes PartEditBoxBaseT types to UI Automation.
Public class | PickerBaseAutomationPeer | Exposes PickerBase types to UI Automation.
Public class | RadialHuePickerAutomationPeer | Exposes RadialHuePicker types to UI Automation.
Public class | RatingAutomationPeer | Exposes Rating types to UI Automation.
Public class | SaturationBrightnessPickerAutomationPeer | Exposes SaturationBrightnessPicker types to UI Automation.


CalculatorAutomationPeer Class

CalculatorAutomationPeer Class
Exposes Calculator types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersCalculatorAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CalculatorAutomationPeer : FrameworkElementAutomationPeer
Public Class CalculatorAutomationPeer
    Inherits FrameworkElementAutomationPeer

The CalculatorAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | CalculatorAutomationPeer | Initializes a new instance of the CalculatorAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Constructor

CalculatorAutomationPeer Constructor
Initializes a new instance of the CalculatorAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CalculatorAutomationPeer(
    Calculator owner
)
Public Sub New (
    owner As Calculator
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.EditorsCalculator
The owner element.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Properties

CalculatorAutomationPeer Properties

The CalculatorAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer Methods

CalculatorAutomationPeer Methods

The CalculatorAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer.GetAutomationControlTypeCore Method

CalculatorAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer.GetClassNameCore Method

CalculatorAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


CalculatorAutomationPeer.GetLocalizedControlTypeCore Method

CalculatorAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

CalculatorAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Class

GradientStopSliderAutomationPeer Class
Exposes GradientStopSlider types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersGradientStopSliderAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GradientStopSliderAutomationPeer : FrameworkElementAutomationPeer
Public Class GradientStopSliderAutomationPeer
    Inherits FrameworkElementAutomationPeer

The GradientStopSliderAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopSliderAutomationPeer | Initializes a new instance of the GradientStopSliderAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Constructor

GradientStopSliderAutomationPeer Constructor
Initializes a new instance of the GradientStopSliderAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GradientStopSliderAutomationPeer(
    GradientStopSlider owner
)
Public Sub New (
    owner As GradientStopSlider
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.EditorsGradientStopSlider
The owner element.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Properties

GradientStopSliderAutomationPeer Properties

The GradientStopSliderAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer Methods

GradientStopSliderAutomationPeer Methods

The GradientStopSliderAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer.GetAutomationControlTypeCore Method

GradientStopSliderAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer.GetClassNameCore Method

GradientStopSliderAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


GradientStopSliderAutomationPeer.GetLocalizedControlTypeCore Method

GradientStopSliderAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

GradientStopSliderAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Class

HueRingAutomationPeer Class
Exposes HueRing types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersHueRingAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HueRingAutomationPeer : FrameworkElementAutomationPeer
Public Class HueRingAutomationPeer
    Inherits FrameworkElementAutomationPeer

The HueRingAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | HueRingAutomationPeer | Initializes a new instance of the HueRingAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Constructor

HueRingAutomationPeer Constructor
Initializes a new instance of the HueRingAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HueRingAutomationPeer(
    HueRing owner
)
Public Sub New (
    owner As HueRing
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesHueRing
The owner element.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Properties

HueRingAutomationPeer Properties

The HueRingAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer Methods

HueRingAutomationPeer Methods

The HueRingAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer.GetAutomationControlTypeCore Method

HueRingAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer.GetClassNameCore Method

HueRingAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


HueRingAutomationPeer.GetLocalizedControlTypeCore Method

HueRingAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

HueRingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Class

MonthCalendarAutomationPeer Class
Exposes MonthCalendar types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersMonthCalendarAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MonthCalendarAutomationPeer : FrameworkElementAutomationPeer
Public Class MonthCalendarAutomationPeer
    Inherits FrameworkElementAutomationPeer

The MonthCalendarAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | MonthCalendarAutomationPeer | Initializes a new instance of the MonthCalendarAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Constructor

MonthCalendarAutomationPeer Constructor
Initializes a new instance of the MonthCalendarAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MonthCalendarAutomationPeer(
    MonthCalendar owner
)
Public Sub New (
    owner As MonthCalendar
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.EditorsMonthCalendar
The owner element.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Properties

MonthCalendarAutomationPeer Properties

The MonthCalendarAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer Methods

MonthCalendarAutomationPeer Methods

The MonthCalendarAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer.GetAutomationControlTypeCore Method

MonthCalendarAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer.GetClassNameCore Method

MonthCalendarAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


MonthCalendarAutomationPeer.GetLocalizedControlTypeCore Method

MonthCalendarAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

MonthCalendarAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Class

PartEditBoxBaseAutomationPeerT Class
Exposes PartEditBoxBaseT types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersPartEditBoxBaseAutomationPeerT

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PartEditBoxBaseAutomationPeer<T> : FrameworkElementAutomationPeer,
    IExpandCollapseProvider, IValueProvider

Public Class PartEditBoxBaseAutomationPeer(Of T)
    Inherits FrameworkElementAutomationPeer
    Implements IExpandCollapseProvider, IValueProvider

Type Parameters

T
The type of value being edited.

The PartEditBoxBaseAutomationPeerT type exposes the following members.

Constructors
 | Name | Description
Public method | PartEditBoxBaseAutomationPeerT | Initializes a new instance of the PartEditBoxBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Public property | Value | Gets the value of the control.
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Equals | (Inherited from Object.)
Public method | Expand | Displays all child nodes, controls, or content of the control.
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Gets the control pattern that is associated with the specified PatternInterface. (Overrides AutomationPeerGetPatternCore(PatternInterface).)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue(String) | Sets the value of a control.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Constructor

PartEditBoxBaseAutomationPeerT Constructor
Initializes a new instance of the PartEditBoxBaseAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PartEditBoxBaseAutomationPeer(
    PartEditBoxBase<T> owner
)
Public Sub New (
    owner As PartEditBoxBase(Of T)
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBase T
The owner element.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Properties

PartEditBoxBaseAutomationPeerT Properties

The PartEditBoxBaseAutomationPeerT generic type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | ExpandCollapseState | Gets the state, expanded or collapsed, of the control.
Public property | IsReadOnly | Gets a value that indicates whether the value of a control is read-only.
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Public property | Value | Gets the value of the control.
Top
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).ExpandCollapseState Property

PartEditBoxBaseAutomationPeerTExpandCollapseState Property
Gets the state, expanded or collapsed, of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExpandCollapseState ExpandCollapseState { get; }
Public ReadOnly Property ExpandCollapseState As ExpandCollapseState
    Get

Property Value

Type: ExpandCollapseState

Return Value

Type: ExpandCollapseState
The state, expanded or collapsed, of the control.

Implements

IExpandCollapseProviderExpandCollapseState
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).IsReadOnly Property

PartEditBoxBaseAutomationPeerTIsReadOnly Property
Gets a value that indicates whether the value of a control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the value is read-only; false if it can be modified.

Implements

IValueProviderIsReadOnly
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Value Property

PartEditBoxBaseAutomationPeerTValue Property
Gets the value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get

Property Value

Type: String
The value of the control.

Implements

IValueProviderValue
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T) Methods

PartEditBoxBaseAutomationPeerT Methods

The PartEditBoxBaseAutomationPeerT generic type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Collapse | Hides all nodes, controls, or content that are descendants of the control.
Public method | Equals | (Inherited from Object.)
Public method | Expand | Displays all child nodes, controls, or content of the control.
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Gets the control pattern that is associated with the specified PatternInterface. (Overrides AutomationPeerGetPatternCore(PatternInterface).)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue(String) | Sets the value of a control.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Collapse Method

PartEditBoxBaseAutomationPeerTCollapse Method
Hides all nodes, controls, or content that are descendants of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Collapse()
Public Sub Collapse

Implements

IExpandCollapseProviderCollapse
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).Expand Method

PartEditBoxBaseAutomationPeerTExpand Method
Displays all child nodes, controls, or content of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Expand()
Public Sub Expand

Implements

IExpandCollapseProviderExpand
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetAutomationControlTypeCore Method

PartEditBoxBaseAutomationPeerTGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetClassNameCore Method

PartEditBoxBaseAutomationPeerTGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetLocalizedControlTypeCore Method

PartEditBoxBaseAutomationPeerTGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).GetPatternCore Method

PartEditBoxBaseAutomationPeerTGetPatternCore Method
Gets the control pattern that is associated with the specified PatternInterface.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object GetPatternCore(
    PatternInterface patternInterface
)
Protected Overrides Function GetPatternCore (
    patternInterface As PatternInterface
) As Object

Parameters

patternInterface
Type: Windows.UI.Xaml.Automation.PeersPatternInterface
A value from the PatternInterface enumeration.

Return Value

Type: Object
The object that implements the pattern interface; if the peer does not support this interface.
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).SetValue Method

PartEditBoxBaseAutomationPeerTSetValue Method
Overload List
 | Name | Description
Public method | SetValue(String) | Sets the value of a control.
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Top
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PartEditBoxBaseAutomationPeer(T).SetValue Method (String)

PartEditBoxBaseAutomationPeerTSetValue Method (String)
Sets the value of a control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SetValue(
    string value
)
Public Sub SetValue (
    value As String
)

Parameters

value
Type: SystemString
The value to set. The provider is responsible for converting the value to the appropriate data type.

Implements

IValueProviderSetValue(String)
See Also

Reference

PartEditBoxBaseAutomationPeerT Class
SetValue Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Class

PickerBaseAutomationPeer Class
Exposes PickerBase types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersPickerBaseAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PickerBaseAutomationPeer : FrameworkElementAutomationPeer
Public Class PickerBaseAutomationPeer
    Inherits FrameworkElementAutomationPeer

The PickerBaseAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | PickerBaseAutomationPeer | Initializes a new instance of the PickerBaseAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Constructor

PickerBaseAutomationPeer Constructor
Initializes a new instance of the PickerBaseAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PickerBaseAutomationPeer(
    PickerBase owner
)
Public Sub New (
    owner As PickerBase
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
The owner element.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Properties

PickerBaseAutomationPeer Properties

The PickerBaseAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer Methods

PickerBaseAutomationPeer Methods

The PickerBaseAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer.GetAutomationControlTypeCore Method

PickerBaseAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer.GetClassNameCore Method

PickerBaseAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


PickerBaseAutomationPeer.GetLocalizedControlTypeCore Method

PickerBaseAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

PickerBaseAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Class

RadialHuePickerAutomationPeer Class
Exposes RadialHuePicker types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersRadialHuePickerAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RadialHuePickerAutomationPeer : FrameworkElementAutomationPeer
Public Class RadialHuePickerAutomationPeer
    Inherits FrameworkElementAutomationPeer

The RadialHuePickerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | RadialHuePickerAutomationPeer | Initializes a new instance of the RadialHuePickerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Constructor

RadialHuePickerAutomationPeer Constructor
Initializes a new instance of the RadialHuePickerAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RadialHuePickerAutomationPeer(
    RadialHuePicker owner
)
Public Sub New (
    owner As RadialHuePicker
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.EditorsRadialHuePicker
The owner element.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Properties

RadialHuePickerAutomationPeer Properties

The RadialHuePickerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer Methods

RadialHuePickerAutomationPeer Methods

The RadialHuePickerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer.GetAutomationControlTypeCore Method

RadialHuePickerAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer.GetClassNameCore Method

RadialHuePickerAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RadialHuePickerAutomationPeer.GetLocalizedControlTypeCore Method

RadialHuePickerAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

RadialHuePickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Class

RatingAutomationPeer Class
Exposes Rating types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersRatingAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RatingAutomationPeer : FrameworkElementAutomationPeer
Public Class RatingAutomationPeer
    Inherits FrameworkElementAutomationPeer

The RatingAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | RatingAutomationPeer | Initializes a new instance of the RatingAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Constructor

RatingAutomationPeer Constructor
Initializes a new instance of the RatingAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RatingAutomationPeer(
    Rating owner
)
Public Sub New (
    owner As Rating
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.EditorsRating
The owner element.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Properties

RatingAutomationPeer Properties

The RatingAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer Methods

RatingAutomationPeer Methods

The RatingAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer.GetAutomationControlTypeCore Method

RatingAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer.GetClassNameCore Method

RatingAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


RatingAutomationPeer.GetLocalizedControlTypeCore Method

RatingAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

RatingAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Class

SaturationBrightnessPickerAutomationPeer Class
Exposes SaturationBrightnessPicker types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.PeersSaturationBrightnessPickerAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SaturationBrightnessPickerAutomationPeer : FrameworkElementAutomationPeer
Public Class SaturationBrightnessPickerAutomationPeer
    Inherits FrameworkElementAutomationPeer

The SaturationBrightnessPickerAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationBrightnessPickerAutomationPeer | Initializes a new instance of the SaturationBrightnessPickerAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Constructor

SaturationBrightnessPickerAutomationPeer Constructor
Initializes a new instance of the SaturationBrightnessPickerAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SaturationBrightnessPickerAutomationPeer(
    SaturationBrightnessPicker owner
)
Public Sub New (
    owner As SaturationBrightnessPicker
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.EditorsSaturationBrightnessPicker
The owner element.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Properties

SaturationBrightnessPickerAutomationPeer Properties

The SaturationBrightnessPickerAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer Methods

SaturationBrightnessPickerAutomationPeer Methods

The SaturationBrightnessPickerAutomationPeer type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetChildren or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer.GetAutomationControlTypeCore Method

SaturationBrightnessPickerAutomationPeerGetAutomationControlTypeCore Method
Gets the control type for the element that is associated with the UI Automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationControlType GetAutomationControlTypeCore()
Protected Overrides Function GetAutomationControlTypeCore As AutomationControlType

Return Value

Type: AutomationControlType
The control type.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer.GetClassNameCore Method

SaturationBrightnessPickerAutomationPeerGetClassNameCore Method
Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The class name.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


SaturationBrightnessPickerAutomationPeer.GetLocalizedControlTypeCore Method

SaturationBrightnessPickerAutomationPeerGetLocalizedControlTypeCore Method
Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetLocalizedControlTypeCore()
Protected Overrides Function GetLocalizedControlTypeCore As String

Return Value

Type: String
The control type.
See Also

Reference

SaturationBrightnessPickerAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace
Contains property editor classes that support integration of Editors with PropertyGrid.
Classes
 | Class | Description
Public class | BrushPropertyEditor |
Public class | BuiltinPropertyEditors |
Public class | ColorPropertyEditor |
Public class | CornerRadiusPropertyEditor |
Public class | DatePropertyEditor |
Public class | DateTimePropertyEditor |
Public class | DoublePropertyEditor |
Public class | EnumPropertyEditor |
Public class | GuidPropertyEditor |
Public class | Int16PropertyEditor |
Public class | Int32PropertyEditor |
Public class | Int64PropertyEditor |
Public class | MaskedStringPropertyEditor |
Public class | NullableColorPropertyEditor |
Public class | NullableCornerRadiusPropertyEditor |
Public class | NullableDatePropertyEditor |
Public class | NullableDateTimePropertyEditor |
Public class | NullableDoublePropertyEditor |
Public class | NullableGuidPropertyEditor |
Public class | NullableInt16PropertyEditor |
Public class | NullableInt32PropertyEditor |
Public class | NullableInt64PropertyEditor |
Public class | NullablePointPropertyEditor |
Public class | NullableRectPropertyEditor |
Public class | NullableSinglePropertyEditor |
Public class | NullableSizePropertyEditor |
Public class | NullableThicknessPropertyEditor |
Public class | NullableTimePropertyEditor |
Public class | NullableTimeSpanPropertyEditor |
Public class | PointPropertyEditor |
Public class | PropertyEditorsResourceDictionary |
Public class | RectPropertyEditor |
Public class | SinglePropertyEditor |
Public class | SizePropertyEditor |
Public class | ThicknessPropertyEditor |
Public class | TimePropertyEditor |
Public class | TimeSpanPropertyEditor |


BrushPropertyEditor Class

BrushPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BrushPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsBrushPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BrushPropertyEditor : PartEditBoxPropertyEditorBase
Public Class BrushPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The BrushPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BrushPropertyEditor | Initializes a new instance of the BrushPropertyEditor class
Protected method | BrushPropertyEditor(Type) | Initializes a new instance of the BrushPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch |
Public property | IsAlphaEnabled |
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsGradientAllowed |
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor

BrushPropertyEditor Constructor
Overload List
 | Name | Description
Public method | BrushPropertyEditor | Initializes a new instance of the BrushPropertyEditor class
Protected method | BrushPropertyEditor(Type) | Initializes a new instance of the BrushPropertyEditor class
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor

BrushPropertyEditor Constructor
Initializes a new instance of the BrushPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BrushPropertyEditor()
Public Sub New
See Also

Reference

BrushPropertyEditor Class
BrushPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor (Type)

BrushPropertyEditor Constructor (Type)
Initializes a new instance of the BrushPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected BrushPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BrushPropertyEditor.#ctor(System.Type)"]

See Also

Reference

BrushPropertyEditor Class
BrushPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Properties

BrushPropertyEditor Properties

The BrushPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch |
Public property | IsAlphaEnabled |
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsGradientAllowed |
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.HasSwatch Property

BrushPropertyEditorHasSwatch Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BrushPropertyEditor.HasSwatch"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.IsAlphaEnabled Property

BrushPropertyEditorIsAlphaEnabled Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BrushPropertyEditor.IsAlphaEnabled"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.IsGradientAllowed Property

BrushPropertyEditorIsGradientAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BrushPropertyEditor.IsGradientAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsGradientAllowed { get; set; }
Public Property IsGradientAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor.PredefinedValueTemplateKey Property

BrushPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BrushPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Methods

BrushPropertyEditor Methods

The BrushPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BrushPropertyEditor Events

BrushPropertyEditor Events

The BrushPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Class

BuiltinPropertyEditors Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsBuiltinPropertyEditors

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class BuiltinPropertyEditors
Public NotInheritable Class BuiltinPropertyEditors

The BuiltinPropertyEditors type exposes the following members.

Methods
Name | Description
GetIsEnabled |
SetIsEnabled |
Top
Fields
Name | Description
IsEnabledProperty |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Methods

BuiltinPropertyEditors Methods

The BuiltinPropertyEditors type exposes the following members.

Methods
Name | Description
GetIsEnabled |
SetIsEnabled |
Top
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.GetIsEnabled Method

BuiltinPropertyEditorsGetIsEnabled Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.GetIsEnabled(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.IPropertyEditorsProvider)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool GetIsEnabled(
    IPropertyEditorsProvider obj
)
Public Shared Function GetIsEnabled (
    obj As IPropertyEditorsProvider
) As Boolean

Parameters

obj
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsIPropertyEditorsProvider

[Missing <param name="obj"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.GetIsEnabled(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.IPropertyEditorsProvider)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.GetIsEnabled(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.IPropertyEditorsProvider)"]

See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.SetIsEnabled Method

BuiltinPropertyEditorsSetIsEnabled Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.SetIsEnabled(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.IPropertyEditorsProvider,System.Boolean)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetIsEnabled(
    IPropertyEditorsProvider obj,
    bool value
)
Public Shared Sub SetIsEnabled (
    obj As IPropertyEditorsProvider,
    value As Boolean
)

Parameters

obj
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsIPropertyEditorsProvider

[Missing <param name="obj"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.SetIsEnabled(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.IPropertyEditorsProvider,System.Boolean)"]

value
Type: SystemBoolean

[Missing <param name="value"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.SetIsEnabled(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.IPropertyEditorsProvider,System.Boolean)"]

See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors Fields

BuiltinPropertyEditors Fields

The BuiltinPropertyEditors type exposes the following members.

Fields
Name | Description
IsEnabledProperty |
Top
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


BuiltinPropertyEditors.IsEnabledProperty Field

BuiltinPropertyEditorsIsEnabledProperty Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.BuiltinPropertyEditors.IsEnabledProperty"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEnabledProperty
Public Shared ReadOnly IsEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
See Also

Reference

BuiltinPropertyEditors Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Class

ColorPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ColorPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableColorPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ColorPropertyEditor : PartEditBoxPropertyEditorBase
Public Class ColorPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The ColorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPropertyEditor | Initializes a new instance of the ColorPropertyEditor class
Protected method | ColorPropertyEditor(Type) | Initializes a new instance of the ColorPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch |
Public property | IsAlphaEnabled |
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor

ColorPropertyEditor Constructor
Overload List
 | Name | Description
Public method | ColorPropertyEditor | Initializes a new instance of the ColorPropertyEditor class
Protected method | ColorPropertyEditor(Type) | Initializes a new instance of the ColorPropertyEditor class
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor

ColorPropertyEditor Constructor
Initializes a new instance of the ColorPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ColorPropertyEditor()
Public Sub New
See Also

Reference

ColorPropertyEditor Class
ColorPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor (Type)

ColorPropertyEditor Constructor (Type)
Initializes a new instance of the ColorPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ColorPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ColorPropertyEditor.#ctor(System.Type)"]

See Also

Reference

ColorPropertyEditor Class
ColorPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Properties

ColorPropertyEditor Properties

The ColorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch |
Public property | IsAlphaEnabled |
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.HasSwatch Property

ColorPropertyEditorHasSwatch Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ColorPropertyEditor.HasSwatch"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasSwatch { get; set; }
Public Property HasSwatch As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.IsAlphaEnabled Property

ColorPropertyEditorIsAlphaEnabled Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ColorPropertyEditor.IsAlphaEnabled"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAlphaEnabled { get; set; }
Public Property IsAlphaEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor.PredefinedValueTemplateKey Property

ColorPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ColorPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Methods

ColorPropertyEditor Methods

The ColorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ColorPropertyEditor Events

ColorPropertyEditor Events

The ColorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Class

CornerRadiusPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsCornerRadiusPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableCornerRadiusPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CornerRadiusPropertyEditor : PartEditBoxPropertyEditorBase
Public Class CornerRadiusPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The CornerRadiusPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusPropertyEditor | Initializes a new instance of the CornerRadiusPropertyEditor class
Protected method | CornerRadiusPropertyEditor(Type) | Initializes a new instance of the CornerRadiusPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Constructor

CornerRadiusPropertyEditor Constructor
Overload List
 | Name | Description
Public method | CornerRadiusPropertyEditor | Initializes a new instance of the CornerRadiusPropertyEditor class
Protected method | CornerRadiusPropertyEditor(Type) | Initializes a new instance of the CornerRadiusPropertyEditor class
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Constructor

CornerRadiusPropertyEditor Constructor
Initializes a new instance of the CornerRadiusPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadiusPropertyEditor()
Public Sub New
See Also

Reference

CornerRadiusPropertyEditor Class
CornerRadiusPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Constructor (Type)

CornerRadiusPropertyEditor Constructor (Type)
Initializes a new instance of the CornerRadiusPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected CornerRadiusPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.#ctor(System.Type)"]

See Also

Reference

CornerRadiusPropertyEditor Class
CornerRadiusPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Properties

CornerRadiusPropertyEditor Properties

The CornerRadiusPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.Format Property

CornerRadiusPropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.LargeChange Property

CornerRadiusPropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius LargeChange { get; set; }
Public Property LargeChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.Maximum Property

CornerRadiusPropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Maximum { get; set; }
Public Property Maximum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.Minimum Property

CornerRadiusPropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius Minimum { get; set; }
Public Property Minimum As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.PredefinedValueTemplateKey Property

CornerRadiusPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor.SmallChange Property

CornerRadiusPropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.CornerRadiusPropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CornerRadius SmallChange { get; set; }
Public Property SmallChange As CornerRadius
    Get
    Set

Property Value

Type: CornerRadius
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Methods

CornerRadiusPropertyEditor Methods

The CornerRadiusPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


CornerRadiusPropertyEditor Events

CornerRadiusPropertyEditor Events

The CornerRadiusPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Class

DatePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DatePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDatePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableDatePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DatePropertyEditor : DateTimePropertyEditor
Public Class DatePropertyEditor
    Inherits DateTimePropertyEditor

The DatePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DatePropertyEditor | Initializes a new instance of the DatePropertyEditor class
Protected method | DatePropertyEditor(Type) | Initializes a new instance of the DatePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Constructor

DatePropertyEditor Constructor
Overload List
 | Name | Description
Public method | DatePropertyEditor | Initializes a new instance of the DatePropertyEditor class
Protected method | DatePropertyEditor(Type) | Initializes a new instance of the DatePropertyEditor class
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Constructor

DatePropertyEditor Constructor
Initializes a new instance of the DatePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DatePropertyEditor()
Public Sub New
See Also

Reference

DatePropertyEditor Class
DatePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Constructor (Type)

DatePropertyEditor Constructor (Type)
Initializes a new instance of the DatePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DatePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DatePropertyEditor.#ctor(System.Type)"]

See Also

Reference

DatePropertyEditor Class
DatePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Properties

DatePropertyEditor Properties

The DatePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor.PredefinedValueTemplateKey Property

DatePropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DatePropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Methods

DatePropertyEditor Methods

The DatePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DatePropertyEditor Events

DatePropertyEditor Events

The DatePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Class

DateTimePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DateTimePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDatePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsTimePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateTimePropertyEditor : PartEditBoxPropertyEditorBase
Public Class DateTimePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The DateTimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimePropertyEditor | Initializes a new instance of the DateTimePropertyEditor class
Protected method | DateTimePropertyEditor(Type) | Initializes a new instance of the DateTimePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Constructor

DateTimePropertyEditor Constructor
Overload List
 | Name | Description
Public method | DateTimePropertyEditor | Initializes a new instance of the DateTimePropertyEditor class
Protected method | DateTimePropertyEditor(Type) | Initializes a new instance of the DateTimePropertyEditor class
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Constructor

DateTimePropertyEditor Constructor
Initializes a new instance of the DateTimePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTimePropertyEditor()
Public Sub New
See Also

Reference

DateTimePropertyEditor Class
DateTimePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Constructor (Type)

DateTimePropertyEditor Constructor (Type)
Initializes a new instance of the DateTimePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DateTimePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DateTimePropertyEditor.#ctor(System.Type)"]

See Also

Reference

DateTimePropertyEditor Class
DateTimePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Properties

DateTimePropertyEditor Properties

The DateTimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.Format Property

DateTimePropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DateTimePropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.Maximum Property

DateTimePropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DateTimePropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Maximum { get; set; }
Public Property Maximum As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.Minimum Property

DateTimePropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DateTimePropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateTime Minimum { get; set; }
Public Property Minimum As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor.PredefinedValueTemplateKey Property

DateTimePropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DateTimePropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Methods

DateTimePropertyEditor Methods

The DateTimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DateTimePropertyEditor Events

DateTimePropertyEditor Events

The DateTimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Class

DoublePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDoublePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableDoublePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DoublePropertyEditor : PartEditBoxPropertyEditorBase
Public Class DoublePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The DoublePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DoublePropertyEditor | Initializes a new instance of the DoublePropertyEditor class
Protected method | DoublePropertyEditor(Type) | Initializes a new instance of the DoublePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed |
Public property | IsNegativeInfinityAllowed |
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed |
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Constructor

DoublePropertyEditor Constructor
Overload List
 | Name | Description
Public method | DoublePropertyEditor | Initializes a new instance of the DoublePropertyEditor class
Protected method | DoublePropertyEditor(Type) | Initializes a new instance of the DoublePropertyEditor class
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Constructor

DoublePropertyEditor Constructor
Initializes a new instance of the DoublePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoublePropertyEditor()
Public Sub New
See Also

Reference

DoublePropertyEditor Class
DoublePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Constructor (Type)

DoublePropertyEditor Constructor (Type)
Initializes a new instance of the DoublePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DoublePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.#ctor(System.Type)"]

See Also

Reference

DoublePropertyEditor Class
DoublePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Properties

DoublePropertyEditor Properties

The DoublePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed |
Public property | IsNegativeInfinityAllowed |
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed |
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.Format Property

DoublePropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.IsNaNAllowed Property

DoublePropertyEditorIsNaNAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.IsNaNAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.IsNegativeInfinityAllowed Property

DoublePropertyEditorIsNegativeInfinityAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.IsNegativeInfinityAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.IsPositiveInfinityAllowed Property

DoublePropertyEditorIsPositiveInfinityAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.IsPositiveInfinityAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.LargeChange Property

DoublePropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LargeChange { get; set; }
Public Property LargeChange As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.Maximum Property

DoublePropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.Minimum Property

DoublePropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.PickerKind Property

DoublePropertyEditorPickerKind Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.PickerKind"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DoubleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As DoubleEditBoxPickerKind
    Get
    Set

Property Value

Type: DoubleEditBoxPickerKind
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.PredefinedValueTemplateKey Property

DoublePropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor.SmallChange Property

DoublePropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.DoublePropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Methods

DoublePropertyEditor Methods

The DoublePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


DoublePropertyEditor Events

DoublePropertyEditor Events

The DoublePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Class

EnumPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.EnumPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsEnumPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumPropertyEditor : PartEditBoxPropertyEditorBase
Public Class EnumPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The EnumPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | EnumPropertyEditor | Initializes a new instance of the EnumPropertyEditor class
Protected method | EnumPropertyEditor(Type) | Initializes a new instance of the EnumPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | EnumSortComparer |
Public property | EnumType |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | UseDisplayAttributes |
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Constructor

EnumPropertyEditor Constructor
Overload List
 | Name | Description
Public method | EnumPropertyEditor | Initializes a new instance of the EnumPropertyEditor class
Protected method | EnumPropertyEditor(Type) | Initializes a new instance of the EnumPropertyEditor class
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Constructor

EnumPropertyEditor Constructor
Initializes a new instance of the EnumPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumPropertyEditor()
Public Sub New
See Also

Reference

EnumPropertyEditor Class
EnumPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Constructor (Type)

EnumPropertyEditor Constructor (Type)
Initializes a new instance of the EnumPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected EnumPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.EnumPropertyEditor.#ctor(System.Type)"]

See Also

Reference

EnumPropertyEditor Class
EnumPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Properties

EnumPropertyEditor Properties

The EnumPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | EnumSortComparer |
Public property | EnumType |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | UseDisplayAttributes |
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.EnumSortComparer Property

EnumPropertyEditorEnumSortComparer Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.EnumPropertyEditor.EnumSortComparer"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IComparer<Enum> EnumSortComparer { get; set; }
Public Property EnumSortComparer As IComparer(Of Enum)
    Get
    Set

Property Value

Type: IComparer Enum
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.EnumType Property

EnumPropertyEditorEnumType Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.EnumPropertyEditor.EnumType"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type EnumType { get; set; }
Public Property EnumType As Type
    Get
    Set

Property Value

Type: Type
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.PredefinedValueTemplateKey Property

EnumPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.EnumPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor.UseDisplayAttributes Property

EnumPropertyEditorUseDisplayAttributes Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.EnumPropertyEditor.UseDisplayAttributes"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool UseDisplayAttributes { get; set; }
Public Property UseDisplayAttributes As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Methods

EnumPropertyEditor Methods

The EnumPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


EnumPropertyEditor Events

EnumPropertyEditor Events

The EnumPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

EnumPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Class

GuidPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.GuidPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsGuidPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableGuidPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GuidPropertyEditor : PartEditBoxPropertyEditorBase
Public Class GuidPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The GuidPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | GuidPropertyEditor | Initializes a new instance of the GuidPropertyEditor class
Protected method | GuidPropertyEditor(Type) | Initializes a new instance of the GuidPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Constructor

GuidPropertyEditor Constructor
Overload List
 | Name | Description
Public method | GuidPropertyEditor | Initializes a new instance of the GuidPropertyEditor class
Protected method | GuidPropertyEditor(Type) | Initializes a new instance of the GuidPropertyEditor class
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Constructor

GuidPropertyEditor Constructor
Initializes a new instance of the GuidPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GuidPropertyEditor()
Public Sub New
See Also

Reference

GuidPropertyEditor Class
GuidPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Constructor (Type)

GuidPropertyEditor Constructor (Type)
Initializes a new instance of the GuidPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected GuidPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.GuidPropertyEditor.#ctor(System.Type)"]

See Also

Reference

GuidPropertyEditor Class
GuidPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Properties

GuidPropertyEditor Properties

The GuidPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor.Format Property

GuidPropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.GuidPropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor.PredefinedValueTemplateKey Property

GuidPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.GuidPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Methods

GuidPropertyEditor Methods

The GuidPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


GuidPropertyEditor Events

GuidPropertyEditor Events

The GuidPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

GuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Class

Int16PropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt16PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt16PropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int16PropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int16PropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int16PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int16PropertyEditor | Initializes a new instance of the Int16PropertyEditor class
Protected method | Int16PropertyEditor(Type) | Initializes a new instance of the Int16PropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Constructor

Int16PropertyEditor Constructor
Overload List
 | Name | Description
Public method | Int16PropertyEditor | Initializes a new instance of the Int16PropertyEditor class
Protected method | Int16PropertyEditor(Type) | Initializes a new instance of the Int16PropertyEditor class
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Constructor

Int16PropertyEditor Constructor
Initializes a new instance of the Int16PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int16PropertyEditor()
Public Sub New
See Also

Reference

Int16PropertyEditor Class
Int16PropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Constructor (Type)

Int16PropertyEditor Constructor (Type)
Initializes a new instance of the Int16PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Int16PropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.#ctor(System.Type)"]

See Also

Reference

Int16PropertyEditor Class
Int16PropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Properties

Int16PropertyEditor Properties

The Int16PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.Format Property

Int16PropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.LargeChange Property

Int16PropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short LargeChange { get; set; }
Public Property LargeChange As Short
    Get
    Set

Property Value

Type: Int16
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.Maximum Property

Int16PropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Maximum { get; set; }
Public Property Maximum As Short
    Get
    Set

Property Value

Type: Int16
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.Minimum Property

Int16PropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short Minimum { get; set; }
Public Property Minimum As Short
    Get
    Set

Property Value

Type: Int16
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.PickerKind Property

Int16PropertyEditorPickerKind Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.PickerKind"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int16EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int16EditBoxPickerKind
    Get
    Set

Property Value

Type: Int16EditBoxPickerKind
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.PredefinedValueTemplateKey Property

Int16PropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor.SmallChange Property

Int16PropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int16PropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public short SmallChange { get; set; }
Public Property SmallChange As Short
    Get
    Set

Property Value

Type: Int16
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Methods

Int16PropertyEditor Methods

The Int16PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int16PropertyEditor Events

Int16PropertyEditor Events

The Int16PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Class

Int32PropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt32PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt32PropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int32PropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int32PropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int32PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int32PropertyEditor | Initializes a new instance of the Int32PropertyEditor class
Protected method | Int32PropertyEditor(Type) | Initializes a new instance of the Int32PropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Constructor

Int32PropertyEditor Constructor
Overload List
 | Name | Description
Public method | Int32PropertyEditor | Initializes a new instance of the Int32PropertyEditor class
Protected method | Int32PropertyEditor(Type) | Initializes a new instance of the Int32PropertyEditor class
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Constructor

Int32PropertyEditor Constructor
Initializes a new instance of the Int32PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int32PropertyEditor()
Public Sub New
See Also

Reference

Int32PropertyEditor Class
Int32PropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Constructor (Type)

Int32PropertyEditor Constructor (Type)
Initializes a new instance of the Int32PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Int32PropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.#ctor(System.Type)"]

See Also

Reference

Int32PropertyEditor Class
Int32PropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Properties

Int32PropertyEditor Properties

The Int32PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.Format Property

Int32PropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.LargeChange Property

Int32PropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int LargeChange { get; set; }
Public Property LargeChange As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.Maximum Property

Int32PropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Maximum { get; set; }
Public Property Maximum As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.Minimum Property

Int32PropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Minimum { get; set; }
Public Property Minimum As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.PickerKind Property

Int32PropertyEditorPickerKind Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.PickerKind"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int32EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int32EditBoxPickerKind
    Get
    Set

Property Value

Type: Int32EditBoxPickerKind
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.PredefinedValueTemplateKey Property

Int32PropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor.SmallChange Property

Int32PropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int32PropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SmallChange { get; set; }
Public Property SmallChange As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Methods

Int32PropertyEditor Methods

The Int32PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int32PropertyEditor Events

Int32PropertyEditor Events

The Int32PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Class

Int64PropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt64PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt64PropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class Int64PropertyEditor : PartEditBoxPropertyEditorBase
Public Class Int64PropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The Int64PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | Int64PropertyEditor | Initializes a new instance of the Int64PropertyEditor class
Protected method | Int64PropertyEditor(Type) | Initializes a new instance of the Int64PropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Constructor

Int64PropertyEditor Constructor
Overload List
 | Name | Description
Public method | Int64PropertyEditor | Initializes a new instance of the Int64PropertyEditor class
Protected method | Int64PropertyEditor(Type) | Initializes a new instance of the Int64PropertyEditor class
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Constructor

Int64PropertyEditor Constructor
Initializes a new instance of the Int64PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int64PropertyEditor()
Public Sub New
See Also

Reference

Int64PropertyEditor Class
Int64PropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Constructor (Type)

Int64PropertyEditor Constructor (Type)
Initializes a new instance of the Int64PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Int64PropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.#ctor(System.Type)"]

See Also

Reference

Int64PropertyEditor Class
Int64PropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Properties

Int64PropertyEditor Properties

The Int64PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.Format Property

Int64PropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.LargeChange Property

Int64PropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long LargeChange { get; set; }
Public Property LargeChange As Long
    Get
    Set

Property Value

Type: Int64
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.Maximum Property

Int64PropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Maximum { get; set; }
Public Property Maximum As Long
    Get
    Set

Property Value

Type: Int64
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.Minimum Property

Int64PropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long Minimum { get; set; }
Public Property Minimum As Long
    Get
    Set

Property Value

Type: Int64
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.PickerKind Property

Int64PropertyEditorPickerKind Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.PickerKind"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Int64EditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As Int64EditBoxPickerKind
    Get
    Set

Property Value

Type: Int64EditBoxPickerKind
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.PredefinedValueTemplateKey Property

Int64PropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor.SmallChange Property

Int64PropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Int64PropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public long SmallChange { get; set; }
Public Property SmallChange As Long
    Get
    Set

Property Value

Type: Int64
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Methods

Int64PropertyEditor Methods

The Int64PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


Int64PropertyEditor Events

Int64PropertyEditor Events

The Int64PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

Int64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Class

MaskedStringPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsMaskedStringPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MaskedStringPropertyEditor : PropertyEditorBase
Public Class MaskedStringPropertyEditor
    Inherits PropertyEditorBase

The MaskedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | MaskedStringPropertyEditor | Initializes a new instance of the MaskedStringPropertyEditor class
Top
Properties
 | Name | Description
Public property | IsCaseAutoCorrected |
Public property | IsCaseSensitive |
Public property | Mask |
Public property | MaskKind |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PromptChar |
Public property | PromptVisibility |
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Constructor

MaskedStringPropertyEditor Constructor
Initializes a new instance of the MaskedStringPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MaskedStringPropertyEditor()
Public Sub New
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Properties

MaskedStringPropertyEditor Properties

The MaskedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsCaseAutoCorrected |
Public property | IsCaseSensitive |
Public property | Mask |
Public property | MaskKind |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PromptChar |
Public property | PromptVisibility |
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.IsCaseAutoCorrected Property

MaskedStringPropertyEditorIsCaseAutoCorrected Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.IsCaseAutoCorrected"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCaseAutoCorrected { get; set; }
Public Property IsCaseAutoCorrected As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.IsCaseSensitive Property

MaskedStringPropertyEditorIsCaseSensitive Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.IsCaseSensitive"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.Mask Property

MaskedStringPropertyEditorMask Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.Mask"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set

Property Value

Type: String
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.MaskKind Property

MaskedStringPropertyEditorMaskKind Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.MaskKind"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MaskKind MaskKind { get; set; }
Public Property MaskKind As MaskKind
    Get
    Set

Property Value

Type: MaskKind
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.PredefinedValueTemplateKey Property

MaskedStringPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.PromptChar Property

MaskedStringPropertyEditorPromptChar Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.PromptChar"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public char PromptChar { get; set; }
Public Property PromptChar As Char
    Get
    Set

Property Value

Type: Char
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor.PromptVisibility Property

MaskedStringPropertyEditorPromptVisibility Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.MaskedStringPropertyEditor.PromptVisibility"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MaskPromptVisibility PromptVisibility { get; set; }
Public Property PromptVisibility As MaskPromptVisibility
    Get
    Set

Property Value

Type: MaskPromptVisibility
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Methods

MaskedStringPropertyEditor Methods

The MaskedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


MaskedStringPropertyEditor Events

MaskedStringPropertyEditor Events

The MaskedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MaskedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Class

NullableColorPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableColorPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableColorPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableColorPropertyEditor : ColorPropertyEditor
Public Class NullableColorPropertyEditor
    Inherits ColorPropertyEditor

The NullableColorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableColorPropertyEditor | Initializes a new instance of the NullableColorPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | (Inherited from ColorPropertyEditor.)
Public property | IsAlphaEnabled | (Inherited from ColorPropertyEditor.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from ColorPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Constructor

NullableColorPropertyEditor Constructor
Initializes a new instance of the NullableColorPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableColorPropertyEditor()
Public Sub New
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Properties

NullableColorPropertyEditor Properties

The NullableColorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasSwatch | (Inherited from ColorPropertyEditor.)
Public property | IsAlphaEnabled | (Inherited from ColorPropertyEditor.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from ColorPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Methods

NullableColorPropertyEditor Methods

The NullableColorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableColorPropertyEditor Events

NullableColorPropertyEditor Events

The NullableColorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Class

NullableCornerRadiusPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableCornerRadiusPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsCornerRadiusPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableCornerRadiusPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableCornerRadiusPropertyEditor : CornerRadiusPropertyEditor
Public Class NullableCornerRadiusPropertyEditor
    Inherits CornerRadiusPropertyEditor

The NullableCornerRadiusPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableCornerRadiusPropertyEditor | Initializes a new instance of the NullableCornerRadiusPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from CornerRadiusPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from CornerRadiusPropertyEditor.)
Public property | Maximum | (Inherited from CornerRadiusPropertyEditor.)
Public property | Minimum | (Inherited from CornerRadiusPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from CornerRadiusPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from CornerRadiusPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Constructor

NullableCornerRadiusPropertyEditor Constructor
Initializes a new instance of the NullableCornerRadiusPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableCornerRadiusPropertyEditor()
Public Sub New
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Properties

NullableCornerRadiusPropertyEditor Properties

The NullableCornerRadiusPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from CornerRadiusPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from CornerRadiusPropertyEditor.)
Public property | Maximum | (Inherited from CornerRadiusPropertyEditor.)
Public property | Minimum | (Inherited from CornerRadiusPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from CornerRadiusPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from CornerRadiusPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Methods

NullableCornerRadiusPropertyEditor Methods

The NullableCornerRadiusPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableCornerRadiusPropertyEditor Events

NullableCornerRadiusPropertyEditor Events

The NullableCornerRadiusPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableCornerRadiusPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Class

NullableDatePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableDatePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDatePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableDatePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableDatePropertyEditor : DatePropertyEditor
Public Class NullableDatePropertyEditor
    Inherits DatePropertyEditor

The NullableDatePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDatePropertyEditor | Initializes a new instance of the NullableDatePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from DatePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Constructor

NullableDatePropertyEditor Constructor
Initializes a new instance of the NullableDatePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableDatePropertyEditor()
Public Sub New
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Properties

NullableDatePropertyEditor Properties

The NullableDatePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from DatePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Methods

NullableDatePropertyEditor Methods

The NullableDatePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDatePropertyEditor Events

NullableDatePropertyEditor Events

The NullableDatePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDatePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Class

NullableDateTimePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableDateTimePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableDateTimePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableDateTimePropertyEditor : DateTimePropertyEditor
Public Class NullableDateTimePropertyEditor
    Inherits DateTimePropertyEditor

The NullableDateTimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDateTimePropertyEditor | Initializes a new instance of the NullableDateTimePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from DateTimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Constructor

NullableDateTimePropertyEditor Constructor
Initializes a new instance of the NullableDateTimePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableDateTimePropertyEditor()
Public Sub New
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Properties

NullableDateTimePropertyEditor Properties

The NullableDateTimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from DateTimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Methods

NullableDateTimePropertyEditor Methods

The NullableDateTimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDateTimePropertyEditor Events

NullableDateTimePropertyEditor Events

The NullableDateTimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDateTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Class

NullableDoublePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableDoublePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDoublePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableDoublePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableDoublePropertyEditor : DoublePropertyEditor
Public Class NullableDoublePropertyEditor
    Inherits DoublePropertyEditor

The NullableDoublePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableDoublePropertyEditor | Initializes a new instance of the NullableDoublePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DoublePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | (Inherited from DoublePropertyEditor.)
Public property | IsNegativeInfinityAllowed | (Inherited from DoublePropertyEditor.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | (Inherited from DoublePropertyEditor.)
Public property | LargeChange | (Inherited from DoublePropertyEditor.)
Public property | Maximum | (Inherited from DoublePropertyEditor.)
Public property | Minimum | (Inherited from DoublePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from DoublePropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from DoublePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from DoublePropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Constructor

NullableDoublePropertyEditor Constructor
Initializes a new instance of the NullableDoublePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableDoublePropertyEditor()
Public Sub New
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Properties

NullableDoublePropertyEditor Properties

The NullableDoublePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DoublePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | (Inherited from DoublePropertyEditor.)
Public property | IsNegativeInfinityAllowed | (Inherited from DoublePropertyEditor.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | (Inherited from DoublePropertyEditor.)
Public property | LargeChange | (Inherited from DoublePropertyEditor.)
Public property | Maximum | (Inherited from DoublePropertyEditor.)
Public property | Minimum | (Inherited from DoublePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from DoublePropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from DoublePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from DoublePropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Methods

NullableDoublePropertyEditor Methods

The NullableDoublePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableDoublePropertyEditor Events

NullableDoublePropertyEditor Events

The NullableDoublePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableDoublePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Class

NullableGuidPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableGuidPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsGuidPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableGuidPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableGuidPropertyEditor : GuidPropertyEditor
Public Class NullableGuidPropertyEditor
    Inherits GuidPropertyEditor

The NullableGuidPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableGuidPropertyEditor | Initializes a new instance of the NullableGuidPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from GuidPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from GuidPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Constructor

NullableGuidPropertyEditor Constructor
Initializes a new instance of the NullableGuidPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableGuidPropertyEditor()
Public Sub New
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Properties

NullableGuidPropertyEditor Properties

The NullableGuidPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from GuidPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from GuidPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Methods

NullableGuidPropertyEditor Methods

The NullableGuidPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableGuidPropertyEditor Events

NullableGuidPropertyEditor Events

The NullableGuidPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableGuidPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Class

NullableInt16PropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableInt16PropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt16PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt16PropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableInt16PropertyEditor : Int16PropertyEditor
Public Class NullableInt16PropertyEditor
    Inherits Int16PropertyEditor

The NullableInt16PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt16PropertyEditor | Initializes a new instance of the NullableInt16PropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from Int16PropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from Int16PropertyEditor.)
Public property | Maximum | (Inherited from Int16PropertyEditor.)
Public property | Minimum | (Inherited from Int16PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from Int16PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from Int16PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from Int16PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Constructor

NullableInt16PropertyEditor Constructor
Initializes a new instance of the NullableInt16PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableInt16PropertyEditor()
Public Sub New
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Properties

NullableInt16PropertyEditor Properties

The NullableInt16PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from Int16PropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from Int16PropertyEditor.)
Public property | Maximum | (Inherited from Int16PropertyEditor.)
Public property | Minimum | (Inherited from Int16PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from Int16PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from Int16PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from Int16PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Methods

NullableInt16PropertyEditor Methods

The NullableInt16PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt16PropertyEditor Events

NullableInt16PropertyEditor Events

The NullableInt16PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt16PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Class

NullableInt32PropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableInt32PropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt32PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt32PropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableInt32PropertyEditor : Int32PropertyEditor
Public Class NullableInt32PropertyEditor
    Inherits Int32PropertyEditor

The NullableInt32PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt32PropertyEditor | Initializes a new instance of the NullableInt32PropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from Int32PropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from Int32PropertyEditor.)
Public property | Maximum | (Inherited from Int32PropertyEditor.)
Public property | Minimum | (Inherited from Int32PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from Int32PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from Int32PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from Int32PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Constructor

NullableInt32PropertyEditor Constructor
Initializes a new instance of the NullableInt32PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableInt32PropertyEditor()
Public Sub New
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Properties

NullableInt32PropertyEditor Properties

The NullableInt32PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from Int32PropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from Int32PropertyEditor.)
Public property | Maximum | (Inherited from Int32PropertyEditor.)
Public property | Minimum | (Inherited from Int32PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from Int32PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from Int32PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from Int32PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Methods

NullableInt32PropertyEditor Methods

The NullableInt32PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt32PropertyEditor Events

NullableInt32PropertyEditor Events

The NullableInt32PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt32PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Class

NullableInt64PropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableInt64PropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt64PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableInt64PropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableInt64PropertyEditor : Int64PropertyEditor
Public Class NullableInt64PropertyEditor
    Inherits Int64PropertyEditor

The NullableInt64PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableInt64PropertyEditor | Initializes a new instance of the NullableInt64PropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from Int64PropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from Int64PropertyEditor.)
Public property | Maximum | (Inherited from Int64PropertyEditor.)
Public property | Minimum | (Inherited from Int64PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from Int64PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from Int64PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from Int64PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Constructor

NullableInt64PropertyEditor Constructor
Initializes a new instance of the NullableInt64PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableInt64PropertyEditor()
Public Sub New
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Properties

NullableInt64PropertyEditor Properties

The NullableInt64PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from Int64PropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from Int64PropertyEditor.)
Public property | Maximum | (Inherited from Int64PropertyEditor.)
Public property | Minimum | (Inherited from Int64PropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from Int64PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from Int64PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from Int64PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Methods

NullableInt64PropertyEditor Methods

The NullableInt64PropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableInt64PropertyEditor Events

NullableInt64PropertyEditor Events

The NullableInt64PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableInt64PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Class

NullablePointPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullablePointPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsPointPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullablePointPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullablePointPropertyEditor : PointPropertyEditor
Public Class NullablePointPropertyEditor
    Inherits PointPropertyEditor

The NullablePointPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullablePointPropertyEditor | Initializes a new instance of the NullablePointPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from PointPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from PointPropertyEditor.)
Public property | Maximum | (Inherited from PointPropertyEditor.)
Public property | Minimum | (Inherited from PointPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from PointPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from PointPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Constructor

NullablePointPropertyEditor Constructor
Initializes a new instance of the NullablePointPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullablePointPropertyEditor()
Public Sub New
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Properties

NullablePointPropertyEditor Properties

The NullablePointPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from PointPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from PointPropertyEditor.)
Public property | Maximum | (Inherited from PointPropertyEditor.)
Public property | Minimum | (Inherited from PointPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from PointPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from PointPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Methods

NullablePointPropertyEditor Methods

The NullablePointPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullablePointPropertyEditor Events

NullablePointPropertyEditor Events

The NullablePointPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullablePointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Class

NullableRectPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableRectPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsRectPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableRectPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableRectPropertyEditor : RectPropertyEditor
Public Class NullableRectPropertyEditor
    Inherits RectPropertyEditor

The NullableRectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableRectPropertyEditor | Initializes a new instance of the NullableRectPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from RectPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from RectPropertyEditor.)
Public property | Maximum | (Inherited from RectPropertyEditor.)
Public property | Minimum | (Inherited from RectPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from RectPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from RectPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Constructor

NullableRectPropertyEditor Constructor
Initializes a new instance of the NullableRectPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableRectPropertyEditor()
Public Sub New
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Properties

NullableRectPropertyEditor Properties

The NullableRectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from RectPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from RectPropertyEditor.)
Public property | Maximum | (Inherited from RectPropertyEditor.)
Public property | Minimum | (Inherited from RectPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from RectPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from RectPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Methods

NullableRectPropertyEditor Methods

The NullableRectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableRectPropertyEditor Events

NullableRectPropertyEditor Events

The NullableRectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableRectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Class

NullableSinglePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableSinglePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsSinglePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableSinglePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableSinglePropertyEditor : SinglePropertyEditor
Public Class NullableSinglePropertyEditor
    Inherits SinglePropertyEditor

The NullableSinglePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableSinglePropertyEditor | Initializes a new instance of the NullableSinglePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from SinglePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | (Inherited from SinglePropertyEditor.)
Public property | IsNegativeInfinityAllowed | (Inherited from SinglePropertyEditor.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | (Inherited from SinglePropertyEditor.)
Public property | LargeChange | (Inherited from SinglePropertyEditor.)
Public property | Maximum | (Inherited from SinglePropertyEditor.)
Public property | Minimum | (Inherited from SinglePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from SinglePropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from SinglePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from SinglePropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Constructor

NullableSinglePropertyEditor Constructor
Initializes a new instance of the NullableSinglePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableSinglePropertyEditor()
Public Sub New
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Properties

NullableSinglePropertyEditor Properties

The NullableSinglePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from SinglePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed | (Inherited from SinglePropertyEditor.)
Public property | IsNegativeInfinityAllowed | (Inherited from SinglePropertyEditor.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed | (Inherited from SinglePropertyEditor.)
Public property | LargeChange | (Inherited from SinglePropertyEditor.)
Public property | Maximum | (Inherited from SinglePropertyEditor.)
Public property | Minimum | (Inherited from SinglePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind | (Inherited from SinglePropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from SinglePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from SinglePropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Methods

NullableSinglePropertyEditor Methods

The NullableSinglePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSinglePropertyEditor Events

NullableSinglePropertyEditor Events

The NullableSinglePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableSinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Class

NullableSizePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableSizePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsSizePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableSizePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableSizePropertyEditor : SizePropertyEditor
Public Class NullableSizePropertyEditor
    Inherits SizePropertyEditor

The NullableSizePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableSizePropertyEditor | Initializes a new instance of the NullableSizePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from SizePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from SizePropertyEditor.)
Public property | Maximum | (Inherited from SizePropertyEditor.)
Public property | Minimum | (Inherited from SizePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from SizePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from SizePropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Constructor

NullableSizePropertyEditor Constructor
Initializes a new instance of the NullableSizePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableSizePropertyEditor()
Public Sub New
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Properties

NullableSizePropertyEditor Properties

The NullableSizePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from SizePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from SizePropertyEditor.)
Public property | Maximum | (Inherited from SizePropertyEditor.)
Public property | Minimum | (Inherited from SizePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from SizePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from SizePropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Methods

NullableSizePropertyEditor Methods

The NullableSizePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableSizePropertyEditor Events

NullableSizePropertyEditor Events

The NullableSizePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableSizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Class

NullableThicknessPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableThicknessPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsThicknessPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableThicknessPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableThicknessPropertyEditor : ThicknessPropertyEditor
Public Class NullableThicknessPropertyEditor
    Inherits ThicknessPropertyEditor

The NullableThicknessPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableThicknessPropertyEditor | Initializes a new instance of the NullableThicknessPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from ThicknessPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from ThicknessPropertyEditor.)
Public property | Maximum | (Inherited from ThicknessPropertyEditor.)
Public property | Minimum | (Inherited from ThicknessPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from ThicknessPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from ThicknessPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Constructor

NullableThicknessPropertyEditor Constructor
Initializes a new instance of the NullableThicknessPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableThicknessPropertyEditor()
Public Sub New
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Properties

NullableThicknessPropertyEditor Properties

The NullableThicknessPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from ThicknessPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from ThicknessPropertyEditor.)
Public property | Maximum | (Inherited from ThicknessPropertyEditor.)
Public property | Minimum | (Inherited from ThicknessPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from ThicknessPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from ThicknessPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Methods

NullableThicknessPropertyEditor Methods

The NullableThicknessPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableThicknessPropertyEditor Events

NullableThicknessPropertyEditor Events

The NullableThicknessPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Class

NullableTimePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableTimePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableTimePropertyEditor : TimePropertyEditor
Public Class NullableTimePropertyEditor
    Inherits TimePropertyEditor

The NullableTimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableTimePropertyEditor | Initializes a new instance of the NullableTimePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from TimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Constructor

NullableTimePropertyEditor Constructor
Initializes a new instance of the NullableTimePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableTimePropertyEditor()
Public Sub New
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Properties

NullableTimePropertyEditor Properties

The NullableTimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from TimePropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Methods

NullableTimePropertyEditor Methods

The NullableTimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimePropertyEditor Events

NullableTimePropertyEditor Events

The NullableTimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableTimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Class

NullableTimeSpanPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.NullableTimeSpanPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsTimeSpanPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimeSpanPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableTimeSpanPropertyEditor : TimeSpanPropertyEditor
Public Class NullableTimeSpanPropertyEditor
    Inherits TimeSpanPropertyEditor

The NullableTimeSpanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableTimeSpanPropertyEditor | Initializes a new instance of the NullableTimeSpanPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from TimeSpanPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from TimeSpanPropertyEditor.)
Public property | Maximum | (Inherited from TimeSpanPropertyEditor.)
Public property | Minimum | (Inherited from TimeSpanPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from TimeSpanPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from TimeSpanPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Constructor

NullableTimeSpanPropertyEditor Constructor
Initializes a new instance of the NullableTimeSpanPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableTimeSpanPropertyEditor()
Public Sub New
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Properties

NullableTimeSpanPropertyEditor Properties

The NullableTimeSpanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from TimeSpanPropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange | (Inherited from TimeSpanPropertyEditor.)
Public property | Maximum | (Inherited from TimeSpanPropertyEditor.)
Public property | Minimum | (Inherited from TimeSpanPropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Inherited from TimeSpanPropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange | (Inherited from TimeSpanPropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Methods

NullableTimeSpanPropertyEditor Methods

The NullableTimeSpanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


NullableTimeSpanPropertyEditor Events

NullableTimeSpanPropertyEditor Events

The NullableTimeSpanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableTimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Class

PointPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsPointPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullablePointPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PointPropertyEditor : PartEditBoxPropertyEditorBase
Public Class PointPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The PointPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | PointPropertyEditor | Initializes a new instance of the PointPropertyEditor class
Protected method | PointPropertyEditor(Type) | Initializes a new instance of the PointPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Constructor

PointPropertyEditor Constructor
Overload List
 | Name | Description
Public method | PointPropertyEditor | Initializes a new instance of the PointPropertyEditor class
Protected method | PointPropertyEditor(Type) | Initializes a new instance of the PointPropertyEditor class
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Constructor

PointPropertyEditor Constructor
Initializes a new instance of the PointPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PointPropertyEditor()
Public Sub New
See Also

Reference

PointPropertyEditor Class
PointPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Constructor (Type)

PointPropertyEditor Constructor (Type)
Initializes a new instance of the PointPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected PointPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.#ctor(System.Type)"]

See Also

Reference

PointPropertyEditor Class
PointPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Properties

PointPropertyEditor Properties

The PointPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.Format Property

PointPropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.LargeChange Property

PointPropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point LargeChange { get; set; }
Public Property LargeChange As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.Maximum Property

PointPropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Maximum { get; set; }
Public Property Maximum As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.Minimum Property

PointPropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point Minimum { get; set; }
Public Property Minimum As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.PredefinedValueTemplateKey Property

PointPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor.SmallChange Property

PointPropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PointPropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Point SmallChange { get; set; }
Public Property SmallChange As Point
    Get
    Set

Property Value

Type: Point
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Methods

PointPropertyEditor Methods

The PointPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PointPropertyEditor Events

PointPropertyEditor Events

The PointPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PointPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Class

PropertyEditorsResourceDictionary Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary"]

Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlResourceDictionary
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsPropertyEditorsResourceDictionary

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PropertyEditorsResourceDictionary : ResourceDictionary,
    IComponentConnector, IComponentConnector2
Public NotInheritable Class PropertyEditorsResourceDictionary
    Inherits ResourceDictionary
    Implements IComponentConnector, IComponentConnector2

The PropertyEditorsResourceDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditorsResourceDictionary | Initializes a new instance of the PropertyEditorsResourceDictionary class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
 | Instance |
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Size | Gets the number of elements contained in the collection. (Inherited from ResourceDictionary.)
Public property | Source | Gets or sets a Uniform Resource Identifier (URI) that provides the source location of a merged resource dictionary. (Inherited from ResourceDictionary.)
Public property | ThemeDictionaries | Gets a collection of merged resource dictionaries that are specifically keyed and composed to address theme scenarios, for example supplying theme values for HighContrast. (Inherited from ResourceDictionary.)
Top
Methods
 | Name | Description
Public method | Clear | Removes all items from this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Connect |
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | First | Returns an iterator for the items in the collection. (Inherited from ResourceDictionary.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingConnector |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | GetView | Retrieves a view against the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | HasKey | Returns whether the ResourceDictionary has an entry with the requested key. (Inherited from ResourceDictionary.)
Public method | InitializeComponent |
Public method | Insert | Adds a new entry to the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Lookup | Returns the value from the requested key, if an entry with that key exists. (Inherited from ResourceDictionary.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | Remove | Removes a specific item from the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Constructor

PropertyEditorsResourceDictionary Constructor
Initializes a new instance of the PropertyEditorsResourceDictionary class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditorsResourceDictionary()
Public Sub New
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Properties

PropertyEditorsResourceDictionary Properties

The PropertyEditorsResourceDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
 | Instance |
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Size | Gets the number of elements contained in the collection. (Inherited from ResourceDictionary.)
Public property | Source | Gets or sets a Uniform Resource Identifier (URI) that provides the source location of a merged resource dictionary. (Inherited from ResourceDictionary.)
Public property | ThemeDictionaries | Gets a collection of merged resource dictionaries that are specifically keyed and composed to address theme scenarios, for example supplying theme values for HighContrast. (Inherited from ResourceDictionary.)
Top
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary.Instance Property

PropertyEditorsResourceDictionaryInstance Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.Instance"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static PropertyEditorsResourceDictionary Instance { get; }
Public Shared ReadOnly Property Instance As PropertyEditorsResourceDictionary
    Get

Property Value

Type: PropertyEditorsResourceDictionary
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary Methods

PropertyEditorsResourceDictionary Methods

The PropertyEditorsResourceDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all items from this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Connect |
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | First | Returns an iterator for the items in the collection. (Inherited from ResourceDictionary.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingConnector |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | GetView | Retrieves a view against the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | HasKey | Returns whether the ResourceDictionary has an entry with the requested key. (Inherited from ResourceDictionary.)
Public method | InitializeComponent |
Public method | Insert | Adds a new entry to the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Lookup | Returns the value from the requested key, if an entry with that key exists. (Inherited from ResourceDictionary.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | Remove | Removes a specific item from the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary.Connect Method

PropertyEditorsResourceDictionaryConnect Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.Connect(System.Int32,System.Object)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Connect(
    int connectionId,
    Object target
)
Public Sub Connect (
    connectionId As Integer,
    target As Object
)

Parameters

connectionId
Type: SystemInt32

[Missing <param name="connectionId"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.Connect(System.Int32,System.Object)"]

target
Type: SystemObject

[Missing <param name="target"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.Connect(System.Int32,System.Object)"]

Implements

IComponentConnectorConnect(Int32, Object)
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary.GetBindingConnector Method

PropertyEditorsResourceDictionaryGetBindingConnector Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.GetBindingConnector(System.Int32,System.Object)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IComponentConnector GetBindingConnector(
    int connectionId,
    Object target
)
Public Function GetBindingConnector (
    connectionId As Integer,
    target As Object
) As IComponentConnector

Parameters

connectionId
Type: SystemInt32

[Missing <param name="connectionId"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.GetBindingConnector(System.Int32,System.Object)"]

target
Type: SystemObject

[Missing <param name="target"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.GetBindingConnector(System.Int32,System.Object)"]

Return Value

Type: IComponentConnector

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.GetBindingConnector(System.Int32,System.Object)"]

Implements

IComponentConnector2GetBindingConnector(Int32, Object)
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


PropertyEditorsResourceDictionary.InitializeComponent Method

PropertyEditorsResourceDictionaryInitializeComponent Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PropertyEditorsResourceDictionary.InitializeComponent"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void InitializeComponent()
Public Sub InitializeComponent
See Also

Reference

PropertyEditorsResourceDictionary Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Class

RectPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsRectPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableRectPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RectPropertyEditor : PartEditBoxPropertyEditorBase
Public Class RectPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The RectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | RectPropertyEditor | Initializes a new instance of the RectPropertyEditor class
Protected method | RectPropertyEditor(Type) | Initializes a new instance of the RectPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Constructor

RectPropertyEditor Constructor
Overload List
 | Name | Description
Public method | RectPropertyEditor | Initializes a new instance of the RectPropertyEditor class
Protected method | RectPropertyEditor(Type) | Initializes a new instance of the RectPropertyEditor class
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Constructor

RectPropertyEditor Constructor
Initializes a new instance of the RectPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RectPropertyEditor()
Public Sub New
See Also

Reference

RectPropertyEditor Class
RectPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Constructor (Type)

RectPropertyEditor Constructor (Type)
Initializes a new instance of the RectPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected RectPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.#ctor(System.Type)"]

See Also

Reference

RectPropertyEditor Class
RectPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Properties

RectPropertyEditor Properties

The RectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.Format Property

RectPropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.LargeChange Property

RectPropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect LargeChange { get; set; }
Public Property LargeChange As Rect
    Get
    Set

Property Value

Type: Rect
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.Maximum Property

RectPropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Maximum { get; set; }
Public Property Maximum As Rect
    Get
    Set

Property Value

Type: Rect
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.Minimum Property

RectPropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Minimum { get; set; }
Public Property Minimum As Rect
    Get
    Set

Property Value

Type: Rect
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.PredefinedValueTemplateKey Property

RectPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor.SmallChange Property

RectPropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.RectPropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect SmallChange { get; set; }
Public Property SmallChange As Rect
    Get
    Set

Property Value

Type: Rect
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Methods

RectPropertyEditor Methods

The RectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


RectPropertyEditor Events

RectPropertyEditor Events

The RectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

RectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Class

SinglePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsSinglePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableSinglePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SinglePropertyEditor : PartEditBoxPropertyEditorBase
Public Class SinglePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The SinglePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SinglePropertyEditor | Initializes a new instance of the SinglePropertyEditor class
Protected method | SinglePropertyEditor(Type) | Initializes a new instance of the SinglePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed |
Public property | IsNegativeInfinityAllowed |
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed |
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Constructor

SinglePropertyEditor Constructor
Overload List
 | Name | Description
Public method | SinglePropertyEditor | Initializes a new instance of the SinglePropertyEditor class
Protected method | SinglePropertyEditor(Type) | Initializes a new instance of the SinglePropertyEditor class
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Constructor

SinglePropertyEditor Constructor
Initializes a new instance of the SinglePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SinglePropertyEditor()
Public Sub New
See Also

Reference

SinglePropertyEditor Class
SinglePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Constructor (Type)

SinglePropertyEditor Constructor (Type)
Initializes a new instance of the SinglePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected SinglePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.#ctor(System.Type)"]

See Also

Reference

SinglePropertyEditor Class
SinglePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Properties

SinglePropertyEditor Properties

The SinglePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNaNAllowed |
Public property | IsNegativeInfinityAllowed |
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsPositiveInfinityAllowed |
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PickerKind |
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.Format Property

SinglePropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.IsNaNAllowed Property

SinglePropertyEditorIsNaNAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.IsNaNAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNaNAllowed { get; set; }
Public Property IsNaNAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.IsNegativeInfinityAllowed Property

SinglePropertyEditorIsNegativeInfinityAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.IsNegativeInfinityAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNegativeInfinityAllowed { get; set; }
Public Property IsNegativeInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.IsPositiveInfinityAllowed Property

SinglePropertyEditorIsPositiveInfinityAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.IsPositiveInfinityAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPositiveInfinityAllowed { get; set; }
Public Property IsPositiveInfinityAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.LargeChange Property

SinglePropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float LargeChange { get; set; }
Public Property LargeChange As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.Maximum Property

SinglePropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Maximum { get; set; }
Public Property Maximum As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.Minimum Property

SinglePropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float Minimum { get; set; }
Public Property Minimum As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.PickerKind Property

SinglePropertyEditorPickerKind Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.PickerKind"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SingleEditBoxPickerKind PickerKind { get; set; }
Public Property PickerKind As SingleEditBoxPickerKind
    Get
    Set

Property Value

Type: SingleEditBoxPickerKind
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.PredefinedValueTemplateKey Property

SinglePropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor.SmallChange Property

SinglePropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SinglePropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public float SmallChange { get; set; }
Public Property SmallChange As Single
    Get
    Set

Property Value

Type: Single
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Methods

SinglePropertyEditor Methods

The SinglePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SinglePropertyEditor Events

SinglePropertyEditor Events

The SinglePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SinglePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Class

SizePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsSizePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableSizePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SizePropertyEditor : PartEditBoxPropertyEditorBase
Public Class SizePropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The SizePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SizePropertyEditor | Initializes a new instance of the SizePropertyEditor class
Protected method | SizePropertyEditor(Type) | Initializes a new instance of the SizePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Constructor

SizePropertyEditor Constructor
Overload List
 | Name | Description
Public method | SizePropertyEditor | Initializes a new instance of the SizePropertyEditor class
Protected method | SizePropertyEditor(Type) | Initializes a new instance of the SizePropertyEditor class
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Constructor

SizePropertyEditor Constructor
Initializes a new instance of the SizePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SizePropertyEditor()
Public Sub New
See Also

Reference

SizePropertyEditor Class
SizePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Constructor (Type)

SizePropertyEditor Constructor (Type)
Initializes a new instance of the SizePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected SizePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.#ctor(System.Type)"]

See Also

Reference

SizePropertyEditor Class
SizePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Properties

SizePropertyEditor Properties

The SizePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.Format Property

SizePropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.LargeChange Property

SizePropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size LargeChange { get; set; }
Public Property LargeChange As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.Maximum Property

SizePropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Maximum { get; set; }
Public Property Maximum As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.Minimum Property

SizePropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size Minimum { get; set; }
Public Property Minimum As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.PredefinedValueTemplateKey Property

SizePropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor.SmallChange Property

SizePropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.SizePropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Size SmallChange { get; set; }
Public Property SmallChange As Size
    Get
    Set

Property Value

Type: Size
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Methods

SizePropertyEditor Methods

The SizePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


SizePropertyEditor Events

SizePropertyEditor Events

The SizePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SizePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Class

ThicknessPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsThicknessPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableThicknessPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ThicknessPropertyEditor : PartEditBoxPropertyEditorBase
Public Class ThicknessPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The ThicknessPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessPropertyEditor | Initializes a new instance of the ThicknessPropertyEditor class
Protected method | ThicknessPropertyEditor(Type) | Initializes a new instance of the ThicknessPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Constructor

ThicknessPropertyEditor Constructor
Overload List
 | Name | Description
Public method | ThicknessPropertyEditor | Initializes a new instance of the ThicknessPropertyEditor class
Protected method | ThicknessPropertyEditor(Type) | Initializes a new instance of the ThicknessPropertyEditor class
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Constructor

ThicknessPropertyEditor Constructor
Initializes a new instance of the ThicknessPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ThicknessPropertyEditor()
Public Sub New
See Also

Reference

ThicknessPropertyEditor Class
ThicknessPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Constructor (Type)

ThicknessPropertyEditor Constructor (Type)
Initializes a new instance of the ThicknessPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected ThicknessPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.#ctor(System.Type)"]

See Also

Reference

ThicknessPropertyEditor Class
ThicknessPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Properties

ThicknessPropertyEditor Properties

The ThicknessPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.Format Property

ThicknessPropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.LargeChange Property

ThicknessPropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness LargeChange { get; set; }
Public Property LargeChange As Thickness
    Get
    Set

Property Value

Type: Thickness
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.Maximum Property

ThicknessPropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Maximum { get; set; }
Public Property Maximum As Thickness
    Get
    Set

Property Value

Type: Thickness
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.Minimum Property

ThicknessPropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Minimum { get; set; }
Public Property Minimum As Thickness
    Get
    Set

Property Value

Type: Thickness
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.PredefinedValueTemplateKey Property

ThicknessPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor.SmallChange Property

ThicknessPropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.ThicknessPropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness SmallChange { get; set; }
Public Property SmallChange As Thickness
    Get
    Set

Property Value

Type: Thickness
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Methods

ThicknessPropertyEditor Methods

The ThicknessPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ThicknessPropertyEditor Events

ThicknessPropertyEditor Events

The ThicknessPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ThicknessPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Class

TimePropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimePropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimePropertyEditor : DateTimePropertyEditor
Public Class TimePropertyEditor
    Inherits DateTimePropertyEditor

The TimePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | TimePropertyEditor | Initializes a new instance of the TimePropertyEditor class
Protected method | TimePropertyEditor(Type) | Initializes a new instance of the TimePropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Constructor

TimePropertyEditor Constructor
Overload List
 | Name | Description
Public method | TimePropertyEditor | Initializes a new instance of the TimePropertyEditor class
Protected method | TimePropertyEditor(Type) | Initializes a new instance of the TimePropertyEditor class
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Constructor

TimePropertyEditor Constructor
Initializes a new instance of the TimePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimePropertyEditor()
Public Sub New
See Also

Reference

TimePropertyEditor Class
TimePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Constructor (Type)

TimePropertyEditor Constructor (Type)
Initializes a new instance of the TimePropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TimePropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimePropertyEditor.#ctor(System.Type)"]

See Also

Reference

TimePropertyEditor Class
TimePropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Properties

TimePropertyEditor Properties

The TimePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format | (Inherited from DateTimePropertyEditor.)
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Maximum | (Inherited from DateTimePropertyEditor.)
Public property | Minimum | (Inherited from DateTimePropertyEditor.)
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides DateTimePropertyEditorPredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor.PredefinedValueTemplateKey Property

TimePropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimePropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Methods

TimePropertyEditor Methods

The TimePropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimePropertyEditor Events

TimePropertyEditor Events

The TimePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

TimePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Class

TimeSpanPropertyEditor Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsTimeSpanPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsNullableTimeSpanPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TimeSpanPropertyEditor : PartEditBoxPropertyEditorBase
Public Class TimeSpanPropertyEditor
    Inherits PartEditBoxPropertyEditorBase

The TimeSpanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanPropertyEditor | Initializes a new instance of the TimeSpanPropertyEditor class
Protected method | TimeSpanPropertyEditor(Type) | Initializes a new instance of the TimeSpanPropertyEditor class
Top
Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Constructor

TimeSpanPropertyEditor Constructor
Overload List
 | Name | Description
Public method | TimeSpanPropertyEditor | Initializes a new instance of the TimeSpanPropertyEditor class
Protected method | TimeSpanPropertyEditor(Type) | Initializes a new instance of the TimeSpanPropertyEditor class
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Constructor

TimeSpanPropertyEditor Constructor
Initializes a new instance of the TimeSpanPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpanPropertyEditor()
Public Sub New
See Also

Reference

TimeSpanPropertyEditor Class
TimeSpanPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Constructor (Type)

TimeSpanPropertyEditor Constructor (Type)
Initializes a new instance of the TimeSpanPropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TimeSpanPropertyEditor(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.#ctor(System.Type)"]

See Also

Reference

TimeSpanPropertyEditor Class
TimeSpanPropertyEditor Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Properties

TimeSpanPropertyEditor Properties

The TimeSpanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | Format |
Public property | HasClearButton | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | HasPopup | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsArrowKeyPartNavigationEnabled | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsEditable | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | IsNullAllowed | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | LargeChange |
Public property | Maximum |
Public property | Minimum |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText | (Inherited from PartEditBoxPropertyEditorBase.)
Protected property | PredefinedValueTemplateKey | (Overrides PropertyEditorBasePredefinedValueTemplateKey.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SmallChange |
Public property | SpinWrapping | (Inherited from PartEditBoxPropertyEditorBase.)
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.Format Property

TimeSpanPropertyEditorFormat Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.Format"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.LargeChange Property

TimeSpanPropertyEditorLargeChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.LargeChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan LargeChange { get; set; }
Public Property LargeChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.Maximum Property

TimeSpanPropertyEditorMaximum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.Maximum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Maximum { get; set; }
Public Property Maximum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.Minimum Property

TimeSpanPropertyEditorMinimum Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.Minimum"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan Minimum { get; set; }
Public Property Minimum As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.PredefinedValueTemplateKey Property

TimeSpanPropertyEditorPredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object PredefinedValueTemplateKey { get; }
Protected Overrides ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor.SmallChange Property

TimeSpanPropertyEditorSmallChange Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.TimeSpanPropertyEditor.SmallChange"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TimeSpan SmallChange { get; set; }
Public Property SmallChange As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Methods

TimeSpanPropertyEditor Methods

The TimeSpanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


TimeSpanPropertyEditor Events

TimeSpanPropertyEditor Events

The TimeSpanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

TimeSpanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors Namespace


ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace
Contains property editor primitive classes that support integration of Editors with PropertyGrid.
Classes
 | Class | Description
Public class | PartEditBoxPropertyEditorBase |
Public class | PropertyEditorBase |


PartEditBoxPropertyEditorBase Class

PartEditBoxPropertyEditorBase Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class PartEditBoxPropertyEditorBase : PropertyEditorBase
Public MustInherit Class PartEditBoxPropertyEditorBase
    Inherits PropertyEditorBase

The PartEditBoxPropertyEditorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PartEditBoxPropertyEditorBase | Initializes a new instance of the PartEditBoxPropertyEditorBase class
Top
Properties
 | Name | Description
Public property | CommitTriggers |
Public property | HasClearButton |
Public property | HasPopup |
Public property | IsArrowKeyPartNavigationEnabled |
Public property | IsEditable |
Public property | IsNullAllowed |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText |
Protected property | PredefinedValueTemplateKey | (Inherited from PropertyEditorBase.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping |
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsBrushPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsCornerRadiusPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDateTimePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsDoublePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsEnumPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsGuidPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt16PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt32PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsInt64PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsPointPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsRectPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsSinglePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsSizePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsThicknessPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsTimeSpanPropertyEditor


PartEditBoxPropertyEditorBase Constructor

PartEditBoxPropertyEditorBase Constructor
Initializes a new instance of the PartEditBoxPropertyEditorBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected PartEditBoxPropertyEditorBase(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.#ctor(System.Type)"]

See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase Properties

PartEditBoxPropertyEditorBase Properties

The PartEditBoxPropertyEditorBase type exposes the following members.

Properties
 | Name | Description
Public property | CommitTriggers |
Public property | HasClearButton |
Public property | HasPopup |
Public property | IsArrowKeyPartNavigationEnabled |
Public property | IsEditable |
Public property | IsNullAllowed |
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PlaceholderText |
Protected property | PredefinedValueTemplateKey | (Inherited from PropertyEditorBase.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | SpinWrapping |
Public property | ValueTemplate | (Inherited from PropertyEditorBase.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.CommitTriggers Property

PartEditBoxPropertyEditorBaseCommitTriggers Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.CommitTriggers"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PartEditBoxCommitTriggers CommitTriggers { get; set; }
Public Property CommitTriggers As PartEditBoxCommitTriggers
    Get
    Set

Property Value

Type: PartEditBoxCommitTriggers
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.HasClearButton Property

PartEditBoxPropertyEditorBaseHasClearButton Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.HasClearButton"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasClearButton { get; set; }
Public Property HasClearButton As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.HasPopup Property

PartEditBoxPropertyEditorBaseHasPopup Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.HasPopup"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasPopup { get; set; }
Public Property HasPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsArrowKeyPartNavigationEnabled Property

PartEditBoxPropertyEditorBaseIsArrowKeyPartNavigationEnabled Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.IsArrowKeyPartNavigationEnabled"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsArrowKeyPartNavigationEnabled { get; set; }
Public Property IsArrowKeyPartNavigationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsEditable Property

PartEditBoxPropertyEditorBaseIsEditable Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.IsEditable"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.IsNullAllowed Property

PartEditBoxPropertyEditorBaseIsNullAllowed Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.IsNullAllowed"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.PlaceholderText Property

PartEditBoxPropertyEditorBasePlaceholderText Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.PlaceholderText"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string PlaceholderText { get; set; }
Public Property PlaceholderText As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase.SpinWrapping Property

PartEditBoxPropertyEditorBaseSpinWrapping Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PartEditBoxPropertyEditorBase.SpinWrapping"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase Methods

PartEditBoxPropertyEditorBase Methods

The PartEditBoxPropertyEditorBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate | (Inherited from PropertyEditorBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PartEditBoxPropertyEditorBase Events

PartEditBoxPropertyEditorBase Events

The PartEditBoxPropertyEditorBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PartEditBoxPropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Class

PropertyEditorBase Class

[Missing <summary> documentation for "T:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PropertyEditorBase"]

Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditorsMaskedStringPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPartEditBoxPropertyEditorBase

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class PropertyEditorBase : PropertyEditor
Public MustInherit Class PropertyEditorBase
    Inherits PropertyEditor

The PropertyEditorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyEditorBase | Initializes a new instance of the PropertyEditorBase class
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey |
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | (Overrides PropertyEditorValueTemplate.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Protected method | CreateValueTemplate |
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Constructor

PropertyEditorBase Constructor
Initializes a new instance of the PropertyEditorBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected PropertyEditorBase(
    Type propertyType
)
Protected Sub New (
    propertyType As Type
)

Parameters

propertyType
Type: SystemType

[Missing <param name="propertyType"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PropertyEditorBase.#ctor(System.Type)"]

See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Properties

PropertyEditorBase Properties

The PropertyEditorBase type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Protected property | PredefinedValueTemplateKey |
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | (Overrides PropertyEditorValueTemplate.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase.PredefinedValueTemplateKey Property

PropertyEditorBasePredefinedValueTemplateKey Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PropertyEditorBase.PredefinedValueTemplateKey"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Object PredefinedValueTemplateKey { get; }
Protected MustOverride ReadOnly Property PredefinedValueTemplateKey As Object
    Get

Property Value

Type: Object
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase.ValueTemplate Property

PropertyEditorBaseValueTemplate Property

[Missing <summary> documentation for "P:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PropertyEditorBase.ValueTemplate"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override DataTemplate ValueTemplate { get; set; }
Public Overrides Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Methods

PropertyEditorBase Methods

The PropertyEditorBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateValueTemplate |
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase.CreateValueTemplate Method

PropertyEditorBaseCreateValueTemplate Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PropertyEditorBase.CreateValueTemplate"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives
Assembly: AS.Editors.Interop.Grids.Universal (in AS.Editors.Interop.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DataTemplate CreateValueTemplate()
Protected Overridable Function CreateValueTemplate As DataTemplate

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives.PropertyEditorBase.CreateValueTemplate"]

See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


PropertyEditorBase Events

PropertyEditorBase Events

The PropertyEditorBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyEditorBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace
Contains the primitive classes used for editors.
Classes
 | Class | Description
Public class | DateToDecadeStringConverter | Represents the converter that converts DateTime to decade string values.
Public class | EmbeddedRadialSlider | Represents a RadialSlider that is intended to be embedded within a popup.
Public class | EmbeddedTextBox | Represents a TextBox that can be embedded into other controls.
Public class | EnumValueNameSortComparer | Sorts enumeration values by name, in ascending order.
Public class | EnumValueToStringConverter | Represents the converter that converts an enum value to a string representation.
Public class | GradientStopSliderPanel | Represents a Panel for arranging thumbs in a GradientStopSlider.
Public class | GradientStopThumb | Represents a thumb for dragging a gradient stop in a GradientStopSlider.
Public class | HueRing | Represents a ring that renders color hues.
Public class | IncrementalChangeRequestT | Represents a request for an incremental (spin) change to a value.
Public class | IncrementalChangeRequestKind | Specifies the kind of incremental change request.
Public class | InputScopeConverter | Represents the converter that converts InputScopeNameValue to InputScope values.
Public class | PartEditBoxBaseT | Represents the abstract base class for a part-based edit box.
Public class | PickerBase | Provides an abstract base class that can be used for pickers.
Public class | RadialSliderPickerBase | Provides an abstract base class that can be used for pickers that use radial sliders.
Public class | RatingPanel | Represents a Panel for arranging items in a Rating.
Public class | SaturationBrightnessSquare | Represents a square that renders the saturation and brightness variants of a color.
Interfaces
 | Interface | Description
Public interface | IPart | Provides the base requirements for a part within a part-based edit box.


DateToDecadeStringConverter Class

DateToDecadeStringConverter Class
Represents the converter that converts DateTime to decade string values.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesDateToDecadeStringConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DateToDecadeStringConverter : IValueConverter
Public Class DateToDecadeStringConverter
    Implements IValueConverter

The DateToDecadeStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DateToDecadeStringConverter | Initializes a new instance of the DateToDecadeStringConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter Constructor

DateToDecadeStringConverter Constructor
Initializes a new instance of the DateToDecadeStringConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DateToDecadeStringConverter()
Public Sub New
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter Methods

DateToDecadeStringConverter Methods

The DateToDecadeStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter.Convert Method

DateToDecadeStringConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


DateToDecadeStringConverter.ConvertBack Method

DateToDecadeStringConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

DateToDecadeStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Class

EmbeddedRadialSlider Class
Represents a RadialSlider that is intended to be embedded within a popup.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.PrimitivesRangeBase
ActiproSoftware.UI.Xaml.ControlsRadialSlider
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesEmbeddedRadialSlider

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EmbeddedRadialSlider : RadialSlider
Public Class EmbeddedRadialSlider
    Inherits RadialSlider

The EmbeddedRadialSlider type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedRadialSlider | Initializes an instance of the EmbeddedRadialSlider class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped. (Inherited from RadialSlider.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range control. (Inherited from RangeBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible Value of the range control. (Inherited from RangeBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the slider's radius. (Inherited from RadialSlider.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle. (Inherited from RadialSlider.)
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state. (Inherited from RadialSlider.)
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed. (Inherited from RadialSlider.)
Public property | ThumbStyle | Gets or sets the Style to use for the thumb. (Inherited from RadialSlider.)
Public property | TotalEndAngle | Gets or sets the total end angle.
Public property | TotalStartAngle | Gets or sets the total start angle.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | ets or sets the current setting of the range control, which may be coerced. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides RadialSliderOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from RadialSlider.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed. (Overrides RangeBaseOnMaximumChanged(Double, Double).)
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed. (Overrides RangeBaseOnMinimumChanged(Double, Double).)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RadialSliderOnValueChanged(Double, Double).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Protected method | SetValueCore | Sets the Value property and applies snapping. (Inherited from RadialSlider.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
TotalEndAngleProperty | Identifies the TotalEndAngle dependency property. This field is read-only.
TotalStartAngleProperty | Identifies the TotalStartAngle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Constructor

EmbeddedRadialSlider Constructor
Initializes an instance of the EmbeddedRadialSlider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EmbeddedRadialSlider()
Public Sub New
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Properties

EmbeddedRadialSlider Properties

The EmbeddedRadialSlider type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IntermediateValue | Gets or sets the value of the slider while the user is interacting with it, before the value is snapped. (Inherited from RadialSlider.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range control. (Inherited from RangeBase.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible Value of the range control. (Inherited from RangeBase.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Radius | Gets or sets the slider's radius. (Inherited from RadialSlider.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets a value to be added to or subtracted from the Value of the range control. (Inherited from RangeBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ThumbArrowAngle | Gets or sets the thumb's arrow angle. (Inherited from RadialSlider.)
Public property | ThumbBackground | Gets or sets the background Brush to render when the thumb is in a normal state. (Inherited from RadialSlider.)
Public property | ThumbPressedBackground | Gets or sets the background Brush to render when the thumb is pressed. (Inherited from RadialSlider.)
Public property | ThumbStyle | Gets or sets the Style to use for the thumb. (Inherited from RadialSlider.)
Public property | TotalEndAngle | Gets or sets the total end angle.
Public property | TotalStartAngle | Gets or sets the total start angle.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | ets or sets the current setting of the range control, which may be coerced. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalEndAngle Property

EmbeddedRadialSliderTotalEndAngle Property
Gets or sets the total end angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TotalEndAngle { get; set; }
Public Property TotalEndAngle As Double
    Get
    Set

Property Value

Type: Double
The total end angle.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalStartAngle Property

EmbeddedRadialSliderTotalStartAngle Property
Gets or sets the total start angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TotalStartAngle { get; set; }
Public Property TotalStartAngle As Double
    Get
    Set

Property Value

Type: Double
The total start angle.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Methods

EmbeddedRadialSlider Methods

The EmbeddedRadialSlider type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides RadialSliderOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from RadialSlider.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed. (Overrides RangeBaseOnMaximumChanged(Double, Double).)
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed. (Overrides RangeBaseOnMinimumChanged(Double, Double).)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed. (Overrides RadialSliderOnValueChanged(Double, Double).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Protected method | SetValueCore | Sets the Value property and applies snapping. (Inherited from RadialSlider.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnApplyTemplate Method

EmbeddedRadialSliderOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnMaximumChanged Method

EmbeddedRadialSliderOnMaximumChanged Method
Occurs when the Maximum property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnMaximumChanged(
    double oldMaximum,
    double newMaximum
)
Protected Overrides Sub OnMaximumChanged (
    oldMaximum As Double,
    newMaximum As Double
)

Parameters

oldMaximum
Type: SystemDouble
The old value.
newMaximum
Type: SystemDouble
The new value.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnMinimumChanged Method

EmbeddedRadialSliderOnMinimumChanged Method
Occurs when the Minimum property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnMinimumChanged(
    double oldMinimum,
    double newMinimum
)
Protected Overrides Sub OnMinimumChanged (
    oldMinimum As Double,
    newMinimum As Double
)

Parameters

oldMinimum
Type: SystemDouble
The old value.
newMinimum
Type: SystemDouble
The new value.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.OnValueChanged Method

EmbeddedRadialSliderOnValueChanged Method
Occurs when the Value property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overrides Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Events

EmbeddedRadialSlider Events

The EmbeddedRadialSlider type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes. (Inherited from RangeBase.)
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider Fields

EmbeddedRadialSlider Fields

The EmbeddedRadialSlider type exposes the following members.

Fields
Name | Description
TotalEndAngleProperty | Identifies the TotalEndAngle dependency property. This field is read-only.
TotalStartAngleProperty | Identifies the TotalStartAngle dependency property. This field is read-only.
Top
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalEndAngleProperty Field

EmbeddedRadialSliderTotalEndAngleProperty Field
Identifies the TotalEndAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TotalEndAngleProperty
Public Shared ReadOnly TotalEndAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TotalEndAngle dependency property.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedRadialSlider.TotalStartAngleProperty Field

EmbeddedRadialSliderTotalStartAngleProperty Field
Identifies the TotalStartAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TotalStartAngleProperty
Public Shared ReadOnly TotalStartAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TotalStartAngle dependency property.
See Also

Reference

EmbeddedRadialSlider Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox Class

EmbeddedTextBox Class
Represents a TextBox that can be embedded into other controls.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsTextBox
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesEmbeddedTextBox

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EmbeddedTextBox : TextBox
Public Class EmbeddedTextBox
    Inherits TextBox

The EmbeddedTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedTextBox | Initializes an instance of the EmbeddedTextBox class.
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets the value that determines whether the text box allows and displays the newline or return characters. (Inherited from TextBox.)
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredCandidateWindowAlignment | (Inherited from TextBox.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from TextBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from TextBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScope | Gets or sets the context for input used by this TextBox . (Inherited from TextBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsColorFontEnabled | Gets or sets a value that determines whether color glyphs, such as emoji, are shown in color. (Inherited from TextBox.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets the value that determines if the user can change the text in the text box. (Inherited from TextBox.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpellCheckEnabled | Gets or sets a value that specifies whether the TextBox input interacts with a spell check engine. (Inherited from TextBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextPredictionEnabled | Gets or sets a value that determines whether text prediction features ("autocomplete") should be enabled for this TextBox. (Inherited from TextBox.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the value that specifies the maximum number of characters allowed for user input. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from TextBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PreventKeyboardDisplayOnProgrammaticFocus | Gets or sets a value that indicates whether the on-screen keyboard is shown when the control receives focus programmatically. (Inherited from TextBox.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionHighlightColor | Gets or sets the brush used to highlight the selected text. (Inherited from TextBox.)
Public property | SelectionLength | Gets or sets the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionStart | Gets or sets the starting position of the text selected in the text box. (Inherited from TextBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets how the text should be aligned in the text box. (Inherited from TextBox.)
Public property | TextReadingOrder | (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how line breaking occurs if a line of text extends beyond the available width of the text box. (Inherited from TextBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLinguisticAlternativesAsync | (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex | Returns a rectangular region for the leading or trailing edge of a character at a specific character index. (Inherited from TextBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects the entire contents of the text box. (Inherited from TextBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | CandidateWindowBoundsChanged | (Inherited from TextBox.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextMenuOpening | Occurs when the system processes an interaction that displays a context menu. (Inherited from TextBox.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Paste | Occurs when text is pasted into the control. (Inherited from TextBox.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs before the KeyDown event occurs, allowing for a key to be intercepted.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TextChanged | Occurs when content changes in the text box. (Inherited from TextBox.)
Public event | TextChanging | (Inherited from TextBox.)
Public event | TextCompositionChanged | (Inherited from TextBox.)
Public event | TextCompositionEnded | (Inherited from TextBox.)
Public event | TextCompositionStarted | (Inherited from TextBox.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox Constructor

EmbeddedTextBox Constructor
Initializes an instance of the EmbeddedTextBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EmbeddedTextBox()
Public Sub New
See Also

Reference

EmbeddedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox Properties

EmbeddedTextBox Properties

The EmbeddedTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets the value that determines whether the text box allows and displays the newline or return characters. (Inherited from TextBox.)
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredCandidateWindowAlignment | (Inherited from TextBox.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Header | Gets or sets the content for the control's header. (Inherited from TextBox.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header. (Inherited from TextBox.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScope | Gets or sets the context for input used by this TextBox . (Inherited from TextBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsColorFontEnabled | Gets or sets a value that determines whether color glyphs, such as emoji, are shown in color. (Inherited from TextBox.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets the value that determines if the user can change the text in the text box. (Inherited from TextBox.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpellCheckEnabled | Gets or sets a value that specifies whether the TextBox input interacts with a spell check engine. (Inherited from TextBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextPredictionEnabled | Gets or sets a value that determines whether text prediction features ("autocomplete") should be enabled for this TextBox. (Inherited from TextBox.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the value that specifies the maximum number of characters allowed for user input. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation. (Inherited from TextBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PreventKeyboardDisplayOnProgrammaticFocus | Gets or sets a value that indicates whether the on-screen keyboard is shown when the control receives focus programmatically. (Inherited from TextBox.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionHighlightColor | Gets or sets the brush used to highlight the selected text. (Inherited from TextBox.)
Public property | SelectionLength | Gets or sets the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionStart | Gets or sets the starting position of the text selected in the text box. (Inherited from TextBox.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets how the text should be aligned in the text box. (Inherited from TextBox.)
Public property | TextReadingOrder | (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how line breaking occurs if a line of text extends beyond the available width of the text box. (Inherited from TextBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

EmbeddedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox Methods

EmbeddedTextBox Methods

The EmbeddedTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLinguisticAlternativesAsync | (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex | Returns a rectangular region for the leading or trailing edge of a character at a specific character index. (Inherited from TextBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects the entire contents of the text box. (Inherited from TextBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

EmbeddedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox.OnKeyDown Method

EmbeddedTextBoxOnKeyDown Method
Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
A KeyRoutedEventArgs that contains the event data.
See Also

Reference

EmbeddedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox Events

EmbeddedTextBox Events

The EmbeddedTextBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | CandidateWindowBoundsChanged | (Inherited from TextBox.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextMenuOpening | Occurs when the system processes an interaction that displays a context menu. (Inherited from TextBox.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | Paste | Occurs when text is pasted into the control. (Inherited from TextBox.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs before the KeyDown event occurs, allowing for a key to be intercepted.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | TextChanged | Occurs when content changes in the text box. (Inherited from TextBox.)
Public event | TextChanging | (Inherited from TextBox.)
Public event | TextCompositionChanged | (Inherited from TextBox.)
Public event | TextCompositionEnded | (Inherited from TextBox.)
Public event | TextCompositionStarted | (Inherited from TextBox.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

EmbeddedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EmbeddedTextBox.PreviewKeyDown Event

EmbeddedTextBoxPreviewKeyDown Event
Occurs before the KeyDown event occurs, allowing for a key to be intercepted.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event KeyEventHandler PreviewKeyDown
Public Event PreviewKeyDown As KeyEventHandler

Value

Type: Windows.UI.Xaml.InputKeyEventHandler
See Also

Reference

EmbeddedTextBox Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Class

EnumValueNameSortComparer Class
Sorts enumeration values by name, in ascending order.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesEnumValueNameSortComparer

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumValueNameSortComparer : IComparer<Enum>
Public Class EnumValueNameSortComparer
    Implements IComparer(Of Enum)

The EnumValueNameSortComparer type exposes the following members.

Constructors
 | Name | Description
Public method | EnumValueNameSortComparer | Initializes a new instance of the EnumValueNameSortComparer class
Top
Properties
Name | Description
Instance | Gets a global instance of this comparer.
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Constructor

EnumValueNameSortComparer Constructor
Initializes a new instance of the EnumValueNameSortComparer class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumValueNameSortComparer()
Public Sub New
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Properties

EnumValueNameSortComparer Properties

The EnumValueNameSortComparer type exposes the following members.

Properties
Name | Description
Instance | Gets a global instance of this comparer.
Top
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer.Instance Property

EnumValueNameSortComparerInstance Property
Gets a global instance of this comparer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EnumValueNameSortComparer Instance { get; }
Public Shared ReadOnly Property Instance As EnumValueNameSortComparer
    Get

Property Value

Type: EnumValueNameSortComparer
A global instance of this comparer.
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer Methods

EnumValueNameSortComparer Methods

The EnumValueNameSortComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueNameSortComparer.Compare Method

EnumValueNameSortComparerCompare Method
Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Compare(
    Enum x,
    Enum y
)
Public Function Compare (
    x As Enum,
    y As Enum
) As Integer

Parameters

x
Type: SystemEnum
The first object to compare.
y
Type: SystemEnum
The second object to compare.

Return Value

Type: Int32
Value Condition Less than zero - x is less than y. Zero - x equals y. Greater than zero - x is greater than y.

Implements

IComparerTCompare(T, T)
See Also

Reference

EnumValueNameSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueToStringConverter Class

EnumValueToStringConverter Class
Represents the converter that converts an enum value to a string representation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesEnumValueToStringConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EnumValueToStringConverter : IValueConverter
Public Class EnumValueToStringConverter
    Implements IValueConverter

The EnumValueToStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | EnumValueToStringConverter | Initializes a new instance of the EnumValueToStringConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueToStringConverter Constructor

EnumValueToStringConverter Constructor
Initializes a new instance of the EnumValueToStringConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EnumValueToStringConverter()
Public Sub New
See Also

Reference

EnumValueToStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueToStringConverter Methods

EnumValueToStringConverter Methods

The EnumValueToStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EnumValueToStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueToStringConverter.Convert Method

EnumValueToStringConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

EnumValueToStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


EnumValueToStringConverter.ConvertBack Method

EnumValueToStringConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

EnumValueToStringConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Class

GradientStopSliderPanel Class
Represents a Panel for arranging thumbs in a GradientStopSlider.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesGradientStopSliderPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GradientStopSliderPanel : Panel
Public Class GradientStopSliderPanel
    Inherits Panel

The GradientStopSliderPanel type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopSliderPanel | Initializes a new instance of the GradientStopSliderPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Constructor

GradientStopSliderPanel Constructor
Initializes a new instance of the GradientStopSliderPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GradientStopSliderPanel()
Public Sub New
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Properties

GradientStopSliderPanel Properties

The GradientStopSliderPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Methods

GradientStopSliderPanel Methods

The GradientStopSliderPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel.ArrangeOverride Method

GradientStopSliderPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel.ArrangeOverride Method (Size)

GradientStopSliderPanelArrangeOverride Method (Size)
Arranges and performs layout on children given a size to layout within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The size Panel is suggested to occupy for layout.

Return Value

Type: Size
The size Panel occupies after layout.
See Also

Reference

GradientStopSliderPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel.MeasureOverride Method

GradientStopSliderPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel.MeasureOverride Method (Size)

GradientStopSliderPanelMeasureOverride Method (Size)
Measures all children given an available size and returns its desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the Panel is suggested to fit inside.

Return Value

Type: Size
The desired size of the Panel.
See Also

Reference

GradientStopSliderPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopSliderPanel Events

GradientStopSliderPanel Events

The GradientStopSliderPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

GradientStopSliderPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb Class

GradientStopThumb Class
Represents a thumb for dragging a gradient stop in a GradientStopSlider.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesGradientStopThumb

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class GradientStopThumb : Control
Public Class GradientStopThumb
    Inherits Control

The GradientStopThumb type exposes the following members.

Constructors
 | Name | Description
Public method | GradientStopThumb | Initializes an instance of the GradientStopThumb class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDragging | Gets whether the thumb is being dragged by a pointer.
Public property | IsDraggingToRemove | Gets whether the thumb is being dragged by a pointer into a location where it will be removed.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the thumb is currently selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | RemoveIfAllowed | Removes the gradient stop, if the slider allows it.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsDraggingToRemoveProperty | Identifies the IsDraggingToRemove dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb Constructor

GradientStopThumb Constructor
Initializes an instance of the GradientStopThumb class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GradientStopThumb()
Public Sub New
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb Properties

GradientStopThumb Properties

The GradientStopThumb type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDragging | Gets whether the thumb is being dragged by a pointer.
Public property | IsDraggingToRemove | Gets whether the thumb is being dragged by a pointer into a location where it will be removed.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether the thumb is currently selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDragging Property

GradientStopThumbIsDragging Property
Gets whether the thumb is being dragged by a pointer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get

Property Value

Type: Boolean
true if the thumb is being dragged by a pointer; otherwise, false.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDraggingToRemove Property

GradientStopThumbIsDraggingToRemove Property
Gets whether the thumb is being dragged by a pointer into a location where it will be removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDraggingToRemove { get; }
Public ReadOnly Property IsDraggingToRemove As Boolean
    Get

Property Value

Type: Boolean
true if the thumb is being dragged by a pointer into a location where it will be removed; otherwise, false.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.IsSelected Property

GradientStopThumbIsSelected Property
Gets or sets whether the thumb is currently selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the thumb is currently selected; otherwise, false.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb Methods

GradientStopThumb Methods

The GradientStopThumb type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | RemoveIfAllowed | Removes the gradient stop, if the slider allows it.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.OnKeyDown Method

GradientStopThumbOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.RemoveIfAllowed Method

GradientStopThumbRemoveIfAllowed Method
Removes the gradient stop, if the slider allows it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveIfAllowed()
Public Sub RemoveIfAllowed
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb Events

GradientStopThumb Events

The GradientStopThumb type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb Fields

GradientStopThumb Fields

The GradientStopThumb type exposes the following members.

Fields
Name | Description
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsDraggingToRemoveProperty | Identifies the IsDraggingToRemove dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
Top
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDraggingProperty Field

GradientStopThumbIsDraggingProperty Field
Identifies the IsDragging dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingProperty
Public Shared ReadOnly IsDraggingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDragging dependency property.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.IsDraggingToRemoveProperty Field

GradientStopThumbIsDraggingToRemoveProperty Field
Identifies the IsDraggingToRemove dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingToRemoveProperty
Public Shared ReadOnly IsDraggingToRemoveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDraggingToRemove dependency property.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


GradientStopThumb.IsSelectedProperty Field

GradientStopThumbIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

GradientStopThumb Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing Class

HueRing Class
Represents a ring that renders color hues.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesHueRing

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class HueRing : Control
Public Class HueRing
    Inherits Control

The HueRing type exposes the following members.

Constructors
 | Name | Description
Public method | HueRing | Initializes an instance of the HueRing class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Length | Gets or sets the length of the ring.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
LengthProperty | Identifies the Length dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing Constructor

HueRing Constructor
Initializes an instance of the HueRing class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HueRing()
Public Sub New
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing Properties

HueRing Properties

The HueRing type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | Length | Gets or sets the length of the ring.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing.Length Property

HueRingLength Property
Gets or sets the length of the ring.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Length { get; set; }
Public Property Length As Double
    Get
    Set

Property Value

Type: Double
The length of the ring. The default value is 40.0.
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing Methods

HueRing Methods

The HueRing type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing.ArrangeOverride Method

HueRingArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing.ArrangeOverride Method (Size)

HueRingArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

HueRing Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing.OnApplyTemplate Method

HueRingOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing.OnCreateAutomationPeer Method

HueRingOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing Events

HueRing Events

The HueRing type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing Fields

HueRing Fields

The HueRing type exposes the following members.

Fields
Name | Description
LengthProperty | Identifies the Length dependency property. This field is read-only.
Top
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


HueRing.LengthProperty Field

HueRingLengthProperty Field
Identifies the Length dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LengthProperty
Public Shared ReadOnly LengthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Length dependency property.
See Also

Reference

HueRing Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Class

IncrementalChangeRequestT Class
Represents a request for an incremental (spin) change to a value.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestT

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class IncrementalChangeRequest<T>

Public Class IncrementalChangeRequest(Of T)

Type Parameters

T
The part value type.

The IncrementalChangeRequestT type exposes the following members.

Constructors
 | Name | Description
Public method | IncrementalChangeRequestT | Initializes an instance of the IncrementalChangeRequest class.
Top
Properties
 | Name | Description
Public property | Kind | Gets or sets the kind of request.
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value.
Public property | Value | Gets or sets the base value upon which to apply the incremental change.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Constructor

IncrementalChangeRequestT Constructor
Initializes an instance of the IncrementalChangeRequest class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IncrementalChangeRequest()
Public Sub New
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Properties

IncrementalChangeRequestT Properties

The IncrementalChangeRequestT generic type exposes the following members.

Properties
 | Name | Description
Public property | Kind | Gets or sets the kind of request.
Public property | LargeChange | Gets or sets the large change value.
Public property | Maximum | Gets or sets the highest possible value.
Public property | Minimum | Gets or sets the lowest possible value.
Public property | SmallChange | Gets or sets the small change value.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value.
Public property | Value | Gets or sets the base value upon which to apply the incremental change.
Top
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Kind Property

IncrementalChangeRequestTKind Property
Gets or sets the kind of request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IncrementalChangeRequestKind Kind { get; set; }
Public Property Kind As IncrementalChangeRequestKind
    Get
    Set

Property Value

Type: IncrementalChangeRequestKind
An IncrementalChangeRequestKind that specifies the kind of request.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).LargeChange Property

IncrementalChangeRequestTLargeChange Property
Gets or sets the large change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T LargeChange { get; set; }
Public Property LargeChange As T
    Get
    Set

Property Value

Type: T
The large change value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Maximum Property

IncrementalChangeRequestTMaximum Property
Gets or sets the highest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Maximum { get; set; }
Public Property Maximum As T
    Get
    Set

Property Value

Type: T
The highest possible value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Minimum Property

IncrementalChangeRequestTMinimum Property
Gets or sets the lowest possible value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Minimum { get; set; }
Public Property Minimum As T
    Get
    Set

Property Value

Type: T
The lowest possible value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).SmallChange Property

IncrementalChangeRequestTSmallChange Property
Gets or sets the small change value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T SmallChange { get; set; }
Public Property SmallChange As T
    Get
    Set

Property Value

Type: T
The small change value.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).SpinWrapping Property

IncrementalChangeRequestTSpinWrapping Property
Gets or sets the wrapping behavior used when spinning past a minimum or maximum value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
The wrapping behavior used when spinning past a minimum or maximum value. The default value is SpinBehavior.NoWrap.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T).Value Property

IncrementalChangeRequestTValue Property
Gets or sets the base value upon which to apply the incremental change.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set

Property Value

Type: T
The base value upon which to apply the incremental change.
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequest(T) Methods

IncrementalChangeRequestT Methods

The IncrementalChangeRequestT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IncrementalChangeRequestT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind Class

IncrementalChangeRequestKind Class
Specifies the kind of incremental change request.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class IncrementalChangeRequestKind : Enum
Public NotInheritable Class IncrementalChangeRequestKind
    Inherits Enum

The IncrementalChangeRequestKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Decrease | Single decrement.
 | Increase | Single increment.
 | MultipleDecrease | Multiple decrements.
 | MultipleIncrease | Multiple increments.
 | None | No change.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind Methods

IncrementalChangeRequestKind Methods

The IncrementalChangeRequestKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind Fields

IncrementalChangeRequestKind Fields

The IncrementalChangeRequestKind type exposes the following members.

Fields
 | Name | Description
 | Decrease | Single decrement.
 | Increase | Single increment.
 | MultipleDecrease | Multiple decrements.
 | MultipleIncrease | Multiple increments.
 | None | No change.
Public field | value__ |
Top
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind.Decrease Field

IncrementalChangeRequestKindDecrease Field
Single decrement.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IncrementalChangeRequestKind Decrease = 3
Public Const Decrease As IncrementalChangeRequestKind = 3

Field Value

Type: IncrementalChangeRequestKind
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind.Increase Field

IncrementalChangeRequestKindIncrease Field
Single increment.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IncrementalChangeRequestKind Increase = 1
Public Const Increase As IncrementalChangeRequestKind = 1

Field Value

Type: IncrementalChangeRequestKind
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind.MultipleDecrease Field

IncrementalChangeRequestKindMultipleDecrease Field
Multiple decrements.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IncrementalChangeRequestKind MultipleDecrease = 4
Public Const MultipleDecrease As IncrementalChangeRequestKind = 4

Field Value

Type: IncrementalChangeRequestKind
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind.MultipleIncrease Field

IncrementalChangeRequestKindMultipleIncrease Field
Multiple increments.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IncrementalChangeRequestKind MultipleIncrease = 2
Public Const MultipleIncrease As IncrementalChangeRequestKind = 2

Field Value

Type: IncrementalChangeRequestKind
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind.None Field

IncrementalChangeRequestKindNone Field
No change.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IncrementalChangeRequestKind None = 0
Public Const None As IncrementalChangeRequestKind = 0

Field Value

Type: IncrementalChangeRequestKind
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IncrementalChangeRequestKind.value__ Field

IncrementalChangeRequestKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Editors.Primitives.IncrementalChangeRequestKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

IncrementalChangeRequestKind Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


InputScopeConverter Class

InputScopeConverter Class
Represents the converter that converts InputScopeNameValue to InputScope values.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesInputScopeConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InputScopeConverter : IValueConverter
Public Class InputScopeConverter
    Implements IValueConverter

The InputScopeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | InputScopeConverter | Initializes a new instance of the InputScopeConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


InputScopeConverter Constructor

InputScopeConverter Constructor
Initializes a new instance of the InputScopeConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InputScopeConverter()
Public Sub New
See Also

Reference

InputScopeConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


InputScopeConverter Methods

InputScopeConverter Methods

The InputScopeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

InputScopeConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


InputScopeConverter.Convert Method

InputScopeConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

InputScopeConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


InputScopeConverter.ConvertBack Method

InputScopeConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

InputScopeConverter Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart Interface

IPart Interface
Provides the base requirements for a part within a part-based edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPart
Public Interface IPart

The IPart type exposes the following members.

Properties
 | Name | Description
Public property | IsEditable | Gets whether the part is editable.
Public property | IsLiteral | Gets whether the part is a literal.
Public property | IsOptional | Gets whether this part is optional.
Public property | Length | Gets the character length of the part within the text.
Public property | StartOffset | Gets the start offset of the part within the text.
Public property | StringValue | Gets or sets the current string value of the part, if known.
Top
Methods
 | Name | Description
Public method | TryParseText | Tries to parse the text starting offset and returns the offset through which parsing was completed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart Properties

IPart Properties

The IPart type exposes the following members.

Properties
 | Name | Description
Public property | IsEditable | Gets whether the part is editable.
Public property | IsLiteral | Gets whether the part is a literal.
Public property | IsOptional | Gets whether this part is optional.
Public property | Length | Gets the character length of the part within the text.
Public property | StartOffset | Gets the start offset of the part within the text.
Public property | StringValue | Gets or sets the current string value of the part, if known.
Top
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.IsEditable Property

IPartIsEditable Property
Gets whether the part is editable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsEditable { get; }
ReadOnly Property IsEditable As Boolean
    Get

Property Value

Type: Boolean
true if the part is editable; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.IsLiteral Property

IPartIsLiteral Property
Gets whether the part is a literal.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLiteral { get; }
ReadOnly Property IsLiteral As Boolean
    Get

Property Value

Type: Boolean
true if the part is a literal; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.IsOptional Property

IPartIsOptional Property
Gets whether this part is optional.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsOptional { get; }
ReadOnly Property IsOptional As Boolean
    Get

Property Value

Type: Boolean
true if this part is optional; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.Length Property

IPartLength Property
Gets the character length of the part within the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; set; }
Property Length As Integer
    Get
    Set

Property Value

Type: Int32
The character length of the part within the text.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.StartOffset Property

IPartStartOffset Property
Gets the start offset of the part within the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; set; }
Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The start offset of the part within the text.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.StringValue Property

IPartStringValue Property
Gets or sets the current string value of the part, if known.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string StringValue { get; set; }
Property StringValue As String
    Get
    Set

Property Value

Type: String
The current string value of the part, if known.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart Methods

IPart Methods

The IPart type exposes the following members.

Methods
 | Name | Description
Public method | TryParseText | Tries to parse the text starting offset and returns the offset through which parsing was completed.
Top
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


IPart.TryParseText Method

IPartTryParseText Method
Tries to parse the text starting offset and returns the offset through which parsing was completed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool TryParseText(
    IList<IPart> parts,
    string text,
    int startOffset,
    CultureInfo culture,
    out int offset
)
Function TryParseText (
    parts As IList(Of IPart),
    text As String,
    startOffset As Integer,
    culture As CultureInfo,
    <OutAttribute> ByRef offset As Integer
) As Boolean

Parameters

parts
Type: System.Collections.GenericIList IPart
The part collection in which this part is a member.
text
Type: SystemString
The text to examine.
startOffset
Type: SystemInt32
The start offset.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use.
offset
Type: SystemInt32
Returns the offset through which parsing was completed.

Return Value

Type: Boolean
true if parsing was successful; otherwise, false.
See Also

Reference

IPart Interface
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Class

PartEditBoxBaseT Class
Represents the abstract base class for a part-based edit box.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBaseT
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class PartEditBoxBase<T> : Control

Public MustInherit Class PartEditBoxBase(Of T)
    Inherits Control

Type Parameters

T
The type of value being edited.

The PartEditBoxBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | PartEditBoxBaseT | Initializes an instance of the DateTimeEditBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length.
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset.
Protected property | CurrentText | Gets the current text value in the TextBox.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only.
Public property | Header | Gets or sets the content for the control's header.
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text.
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsClearButtonVisible | Gets whether the clear button is visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible.
Public property | IsPopupOpen | Gets or sets whether the popup is open.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background.
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border.
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated.
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated.
Protected method | ConvertToString | Converts the specified value to a string representation.
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box.
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts.
Protected method | IsValidValue | Returns whether the specified value is valid.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes.
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes.
Protected method | ProcessTextInput | Processes typed text.
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value.
Public method | SelectAll | Selects all text in the edit box.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ActivePartIndexProperty | Identifies the ActivePartIndex dependency property. This field is read-only.
CommitTriggersProperty | Identifies the CommitTriggers dependency property. This field is read-only.
HasClearButtonProperty | Identifies the HasClearButton dependency property. This field is read-only.
HasPopupProperty | Identifies the HasPopup dependency property. This field is read-only.
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
InputScopeNameValueProperty | Identifies the InputScopeNameValue dependency property. This field is read-only.
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
IsArrowKeyPartNavigationEnabledProperty | Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.
IsClearButtonVisibleProperty | Identifies the IsClearButtonVisible dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsPopupButtonVisibleProperty | Identifies the IsPopupButtonVisible dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSpinnerVisibleProperty | Identifies the IsSpinnerVisible dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
PopupBackgroundProperty | Identifies the PopupBackground dependency property. This field is read-only.
PopupBorderBrushProperty | Identifies the PopupBorderBrush dependency property. This field is read-only.
PopupPickerStyleProperty | Identifies the PopupPickerStyle dependency property. This field is read-only.
SpinWrappingProperty | Identifies the SpinWrapping dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPartEditBoxBaseT
ActiproSoftware.UI.Xaml.Controls.EditorsBrushEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsColorEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsCornerRadiusEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsDateTimeEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsDoubleEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsEnumEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsGuidEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsInt16EditBox
ActiproSoftware.UI.Xaml.Controls.EditorsInt32EditBox
ActiproSoftware.UI.Xaml.Controls.EditorsInt64EditBox
ActiproSoftware.UI.Xaml.Controls.EditorsPointEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsRectEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsSingleEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsSizeEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsThicknessEditBox
ActiproSoftware.UI.Xaml.Controls.EditorsTimeSpanEditBox


PartEditBoxBase(T) Constructor

PartEditBoxBaseT Constructor
Initializes an instance of the DateTimeEditBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected PartEditBoxBase()
Protected Sub New
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Properties

PartEditBoxBaseT Properties

The PartEditBoxBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActivePartIndex | Gets the index of the part that the caret is currently in.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CommitTriggers | Gets or sets the triggers that will force this control to commit any changes.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Protected property | CurrentSelectionLength | Gets the current text selection length.
Protected property | CurrentSelectionStartOffset | Gets the current text selection start offset.
Protected property | CurrentText | Gets the current text value in the TextBox.
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasClearButton | Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true.
Public property | HasPopup | Gets or sets a value indicating whether the control has a popup available.
Protected property | HasPopupButtonWhenReadOnly | Gets whether the control should display the popup button when the control is read-only.
Public property | Header | Gets or sets the content for the control's header.
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the content of the control's header.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputScopeNameValue | Gets or sets the InputScopeNameValue to use for the editable text.
Public property | IntermediateValue | Gets the current value of the control, that stays in relative sync with the editable text representation.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsArrowKeyPartNavigationEnabled | Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.
Public property | IsClearButtonVisible | Gets whether the clear button is visible.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEditable | Gets or sets a value indicating whether the edit box's text area is editable.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsNullAllowed | Gets or sets a value indicating whether null values are allowed to be entered by the user.
Public property | IsPopupButtonVisible | Gets whether the toggle popup button is visible.
Public property | IsPopupOpen | Gets or sets whether the popup is open.
Public property | IsReadOnly | Gets or sets a value indicating whether the edit box is read-only.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSpinnerVisible | Gets whether the spinner is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | Parts | Gets the collection of parts.
Public property | PlaceholderText | Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PopupBackground | Gets or sets the Brush to use for the popup background.
Public property | PopupBorderBrush | Gets or sets the Brush to use for the popup border.
Public property | PopupPickerStyle | Gets or sets the optional custom Style that can be applied to the picker within the popup.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | ResetValueCommand | Gets the ICommand that resets the value to a default value.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallDecrementValueCommand | Gets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets the ICommand that can be used to increment the value by a small amount.
Public property | SpinWrapping | Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the committed value of the control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ActivePartIndex Property

PartEditBoxBaseTActivePartIndex Property
Gets the index of the part that the caret is currently in.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int ActivePartIndex { get; }
Public ReadOnly Property ActivePartIndex As Integer
    Get

Property Value

Type: Int32
The index of the part that the caret is currently in.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CommitTriggers Property

PartEditBoxBaseTCommitTriggers Property
Gets or sets the triggers that will force this control to commit any changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PartEditBoxCommitTriggers CommitTriggers { get; set; }
Public Property CommitTriggers As PartEditBoxCommitTriggers
    Get
    Set

Property Value

Type: PartEditBoxCommitTriggers
A PartEditBoxCommitTriggers indicating the triggers that will force this control to commit any changes. The default value is PartEditBoxCommitTriggers.Default.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CurrentSelectionLength Property

PartEditBoxBaseTCurrentSelectionLength Property
Gets the current text selection length.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected int CurrentSelectionLength { get; }
Protected ReadOnly Property CurrentSelectionLength As Integer
    Get

Property Value

Type: Int32
The current text selection length.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CurrentSelectionStartOffset Property

PartEditBoxBaseTCurrentSelectionStartOffset Property
Gets the current text selection start offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected int CurrentSelectionStartOffset { get; }
Protected ReadOnly Property CurrentSelectionStartOffset As Integer
    Get

Property Value

Type: Int32
The current text selection start offset.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CurrentText Property

PartEditBoxBaseTCurrentText Property
Gets the current text value in the TextBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected string CurrentText { get; }
Protected ReadOnly Property CurrentText As String
    Get

Property Value

Type: String
The current text value in the TextBox.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasClearButton Property

PartEditBoxBaseTHasClearButton Property
Gets or sets a value indicating whether the control has a clear button when focused and the IsNullAllowed property is true.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasClearButton { get; set; }
Public Property HasClearButton As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control has a clear button when focused and the IsNullAllowed property is true; otherwise false. The default value is true.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasPopup Property

PartEditBoxBaseTHasPopup Property
Gets or sets a value indicating whether the control has a popup available.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasPopup { get; set; }
Public Property HasPopup As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the control has a popup available; otherwise false. The default value is true.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasPopupButtonWhenReadOnly Property

PartEditBoxBaseTHasPopupButtonWhenReadOnly Property
Gets whether the control should display the popup button when the control is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool HasPopupButtonWhenReadOnly { get; }
Protected Overridable ReadOnly Property HasPopupButtonWhenReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the control should display the popup button when the control is read-only; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Header Property

PartEditBoxBaseTHeader Property
Gets or sets the content for the control's header.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Header { get; set; }
Public Property Header As Object
    Get
    Set

Property Value

Type: Object
The content of the control's header.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HeaderTemplate Property

PartEditBoxBaseTHeaderTemplate Property
Gets or sets the DataTemplate used to display the content of the control's header.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate HeaderTemplate { get; set; }
Public Property HeaderTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The template that specifies the visualization of the header object.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InputScopeNameValue Property

PartEditBoxBaseTInputScopeNameValue Property
Gets or sets the InputScopeNameValue to use for the editable text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InputScopeNameValue InputScopeNameValue { get; set; }
Public Property InputScopeNameValue As InputScopeNameValue
    Get
    Set

Property Value

Type: InputScopeNameValue
The InputScopeNameValue to use for the editable text.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IntermediateValue Property

PartEditBoxBaseTIntermediateValue Property
Gets the current value of the control, that stays in relative sync with the editable text representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T IntermediateValue { get; }
Public ReadOnly Property IntermediateValue As T
    Get

Property Value

Type: T
The current value of the control.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsArrowKeyPartNavigationEnabled Property

PartEditBoxBaseTIsArrowKeyPartNavigationEnabled Property
Gets or sets a value indicating whether the left/right arrow keys can be used to move between and select editable parts.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsArrowKeyPartNavigationEnabled { get; set; }
Public Property IsArrowKeyPartNavigationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the left/right arrow keys can be used to move between and select editable parts; otherwise false. The default value is true.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsClearButtonVisible Property

PartEditBoxBaseTIsClearButtonVisible Property
Gets whether the clear button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsClearButtonVisible { get; }
Public ReadOnly Property IsClearButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the clear button is visible; otherwise false. The default value is false.
Remarks
The HasClearButton property and other state-related info determines whether the clear button is visible.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsEditable Property

PartEditBoxBaseTIsEditable Property
Gets or sets a value indicating whether the edit box's text area is editable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEditable { get; set; }
Public Property IsEditable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box's text area is editable; otherwise false. The default value is true.
Remarks
When false, the edit box behaves more like a ComboBox.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsNullAllowed Property

PartEditBoxBaseTIsNullAllowed Property
Gets or sets a value indicating whether null values are allowed to be entered by the user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsNullAllowed { get; set; }
Public Property IsNullAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if null values are allowed to be entered by the user; otherwise false. The default value is false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupButtonVisible Property

PartEditBoxBaseTIsPopupButtonVisible Property
Gets whether the toggle popup button is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPopupButtonVisible { get; }
Public ReadOnly Property IsPopupButtonVisible As Boolean
    Get

Property Value

Type: Boolean
true if the toggle popup button is visible; otherwise false. The default value is false.
Remarks
The HasPopup and HasPopupButtonWhenReadOnly properties, and other state-related info determines whether the toggle popup button is visible.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupOpen Property

PartEditBoxBaseTIsPopupOpen Property
Gets or sets whether the popup is open.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPopupOpen { get; set; }
Public Property IsPopupOpen As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the popup is open; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsReadOnly Property

PartEditBoxBaseTIsReadOnly Property
Gets or sets a value indicating whether the edit box is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the edit box is read-only; otherwise false. The default value is false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsSpinnerVisible Property

PartEditBoxBaseTIsSpinnerVisible Property
Gets whether the spinner is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSpinnerVisible { get; }
Public ReadOnly Property IsSpinnerVisible As Boolean
    Get

Property Value

Type: Boolean
true if the spinner is visible; otherwise false. The default value is false.
Remarks
The [!:SpinnerVisibility] property and other state-related info determines whether the spinner is visible.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Parts Property

PartEditBoxBaseTParts Property
Gets the collection of parts.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList<IPart> Parts { get; }
Public ReadOnly Property Parts As IList(Of IPart)
    Get

Property Value

Type: IList IPart
The collection of parts.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PlaceholderText Property

PartEditBoxBaseTPlaceholderText Property
Gets or sets the text that is displayed in the control until the value is changed by a user action or some other operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string PlaceholderText { get; set; }
Public Property PlaceholderText As String
    Get
    Set

Property Value

Type: String
The text that is displayed in the control until the value is changed by a user action or some other operation.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBackground Property

PartEditBoxBaseTPopupBackground Property
Gets or sets the Brush to use for the popup background.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush PopupBackground { get; set; }
Public Property PopupBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for the popup background.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBorderBrush Property

PartEditBoxBaseTPopupBorderBrush Property
Gets or sets the Brush to use for the popup border.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush PopupBorderBrush { get; set; }
Public Property PopupBorderBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for the popup border.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupPickerStyle Property

PartEditBoxBaseTPopupPickerStyle Property
Gets or sets the optional custom Style that can be applied to the picker within the popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style PopupPickerStyle { get; set; }
Public Property PopupPickerStyle As Style
    Get
    Set

Property Value

Type: Style
The optional custom Style that can be applied to the picker within the popup.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ResetValueCommand Property

PartEditBoxBaseTResetValueCommand Property
Gets the ICommand that resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ResetValueCommand { get; }
Public ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that resets the value to a default value.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SmallDecrementValueCommand Property

PartEditBoxBaseTSmallDecrementValueCommand Property
Gets the ICommand that can be used to decrement the value by a small amount.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SmallDecrementValueCommand { get; }
Public ReadOnly Property SmallDecrementValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to decrement the value by a small amount.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SmallIncrementValueCommand Property

PartEditBoxBaseTSmallIncrementValueCommand Property
Gets the ICommand that can be used to increment the value by a small amount.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SmallIncrementValueCommand { get; }
Public ReadOnly Property SmallIncrementValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to increment the value by a small amount.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SpinWrapping Property

PartEditBoxBaseTSpinWrapping Property
Gets or sets the wrapping behavior used when spinning past a minimum or maximum value in the active part.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SpinWrapping SpinWrapping { get; set; }
Public Property SpinWrapping As SpinWrapping
    Get
    Set

Property Value

Type: SpinWrapping
The wrapping behavior used when spinning past a minimum or maximum value in the active part. The default value is SpinWrapping.NoWrap.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Value Property

PartEditBoxBaseTValue Property
Gets or sets the committed value of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set

Property Value

Type: T
The committed value of the control.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Methods

PartEditBoxBaseT Methods

The PartEditBoxBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated.
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated.
Protected method | ConvertToString | Converts the specified value to a string representation.
Protected method | CreateIncrementalChangeRequest | Creates an incremental change (spin) request.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Protected method | GenerateParts | Generates the parts for the edit box.
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | InvalidateParts | Invalidates the parts.
Protected method | IsValidValue | Returns whether the specified value is valid.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIntermediateValueChanged | Invoked when the value of the IntermediateValue property changes.
Protected method | OnIsNullAllowedChanged | Invoked when the value of the IsNullAllowed property changes.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Invoked when the value of the Value property changes.
Protected method | ProcessTextInput | Processes typed text.
Protected method | RaiseValueChangedEvent | Raises the ValueChanged event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Protected method | ResetValue | Resets the value to a default value.
Public method | SelectAll | Selects all text in the edit box.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryConvertFromString | Tries to convert the specified text to a value.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Commit Method

PartEditBoxBaseTCommit Method
Overload List
 | Name | Description
Public method | Commit | Commits any pending text updates and returns whether the Value has been updated.
Public method | Commit(Boolean) | Commits any pending text updates and returns whether the Value has been updated.
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Commit Method

PartEditBoxBaseTCommit Method
Commits any pending text updates and returns whether the Value has been updated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Commit()
Public Function Commit As Boolean

Return Value

Type: Boolean
true if the value has been updated; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
Commit Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).Commit Method (Boolean)

PartEditBoxBaseTCommit Method (Boolean)
Commits any pending text updates and returns whether the Value has been updated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Commit(
    bool allowTextUpdate
)
Public Function Commit (
    allowTextUpdate As Boolean
) As Boolean

Parameters

allowTextUpdate
Type: SystemBoolean
Whether to allow the text to be updated if a valid value is parsed.

Return Value

Type: Boolean
true if the value has been updated; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
Commit Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ConvertToString Method

PartEditBoxBaseTConvertToString Method
Converts the specified value to a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract string ConvertToString(
    T valueToConvert
)
Protected MustOverride Function ConvertToString (
    valueToConvert As T
) As String

Parameters

valueToConvert
Type: T
The value.

Return Value

Type: String
The string representation of the specified value.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CreateIncrementalChangeRequest Method

PartEditBoxBaseTCreateIncrementalChangeRequest Method
Creates an incremental change (spin) request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IncrementalChangeRequest<T> CreateIncrementalChangeRequest(
    IncrementalChangeRequestKind kind
)
Protected MustOverride Function CreateIncrementalChangeRequest (
    kind As IncrementalChangeRequestKind
) As IncrementalChangeRequest(Of T)

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesIncrementalChangeRequestKind
The kind of request.

Return Value

Type: IncrementalChangeRequest T
The incremental change (spin) request that was created.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).GenerateParts Method

PartEditBoxBaseTGenerateParts Method
Generates the parts for the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IList<IPart> GenerateParts()
Protected MustOverride Function GenerateParts As IList(Of IPart)

Return Value

Type: IList IPart
The parts that were generated.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InvalidateParts Method

PartEditBoxBaseTInvalidateParts Method
Invalidates the parts.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void InvalidateParts()
Protected Sub InvalidateParts
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsValidValue Method

PartEditBoxBaseTIsValidValue Method
Returns whether the specified value is valid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsValidValue(
    T value
)
Protected MustOverride Function IsValidValue (
    value As T
) As Boolean

Parameters

value
Type: T
The value to examine.

Return Value

Type: Boolean
true if the value is valid; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnApplyTemplate Method

PartEditBoxBaseTOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnCreateAutomationPeer Method

PartEditBoxBaseTOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnGotFocus Method

PartEditBoxBaseTOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnIntermediateValueChanged Method

PartEditBoxBaseTOnIntermediateValueChanged Method
Invoked when the value of the IntermediateValue property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIntermediateValueChanged(
    T oldValue,
    T newValue
)
Protected Overridable Sub OnIntermediateValueChanged (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The old value of the property.
newValue
Type: T
The new value of the property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnIsNullAllowedChanged Method

PartEditBoxBaseTOnIsNullAllowedChanged Method
Invoked when the value of the IsNullAllowed property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIsNullAllowedChanged(
    bool oldValue,
    bool newValue
)
Protected Overridable Sub OnIsNullAllowedChanged (
    oldValue As Boolean,
    newValue As Boolean
)

Parameters

oldValue
Type: SystemBoolean
The old value of the property.
newValue
Type: SystemBoolean
The new value of the property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnKeyDown Method

PartEditBoxBaseTOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnLostFocus Method

PartEditBoxBaseTOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).OnValueChanged Method

PartEditBoxBaseTOnValueChanged Method
Invoked when the value of the Value property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnValueChanged(
    T oldValue,
    T newValue
)
Protected Overridable Sub OnValueChanged (
    oldValue As T,
    newValue As T
)

Parameters

oldValue
Type: T
The old value of the property.
newValue
Type: T
The new value of the property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ProcessTextInput Method

PartEditBoxBaseTProcessTextInput Method
Processes typed text.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool ProcessTextInput(
    string text
)
Protected Overridable Function ProcessTextInput (
    text As String
) As Boolean

Parameters

text
Type: SystemString
The typed text.

Return Value

Type: Boolean
true if the typed text was handled and should not be allowed to be entered; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).RaiseValueChangedEvent Method

PartEditBoxBaseTRaiseValueChangedEvent Method
Raises the ValueChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void RaiseValueChangedEvent()
Protected MustOverride Sub RaiseValueChangedEvent
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ResetValue Method

PartEditBoxBaseTResetValue Method
Resets the value to a default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void ResetValue()
Protected MustOverride Sub ResetValue
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SelectAll Method

PartEditBoxBaseTSelectAll Method
Selects all text in the edit box.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SelectAll()
Public Sub SelectAll
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).TryConvertFromString Method

PartEditBoxBaseTTryConvertFromString Method
Tries to convert the specified text to a value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool TryConvertFromString(
    string textToConvert,
    bool canCoerce,
    out T value
)
Protected MustOverride Function TryConvertFromString (
    textToConvert As String,
    canCoerce As Boolean,
    <OutAttribute> ByRef value As T
) As Boolean

Parameters

textToConvert
Type: SystemString
The text.
canCoerce
Type: SystemBoolean
Whether the returned value should be coerced to fall within the allowed value range.
value
Type: T
Returns the value for the specified text.

Return Value

Type: Boolean
true if the text was converted to a value successfully; otherwise, false.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Events

PartEditBoxBaseT Events

The PartEditBoxBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T) Fields

PartEditBoxBaseT Fields

The PartEditBoxBaseT generic type exposes the following members.

Fields
Name | Description
ActivePartIndexProperty | Identifies the ActivePartIndex dependency property. This field is read-only.
CommitTriggersProperty | Identifies the CommitTriggers dependency property. This field is read-only.
HasClearButtonProperty | Identifies the HasClearButton dependency property. This field is read-only.
HasPopupProperty | Identifies the HasPopup dependency property. This field is read-only.
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
InputScopeNameValueProperty | Identifies the InputScopeNameValue dependency property. This field is read-only.
IntermediateValueProperty | Identifies the IntermediateValue dependency property. This field is read-only.
IsArrowKeyPartNavigationEnabledProperty | Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.
IsClearButtonVisibleProperty | Identifies the IsClearButtonVisible dependency property. This field is read-only.
IsEditableProperty | Identifies the IsEditable dependency property. This field is read-only.
IsNullAllowedProperty | Identifies the IsNullAllowed dependency property. This field is read-only.
IsPopupButtonVisibleProperty | Identifies the IsPopupButtonVisible dependency property. This field is read-only.
IsPopupOpenProperty | Identifies the IsPopupOpen dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSpinnerVisibleProperty | Identifies the IsSpinnerVisible dependency property. This field is read-only.
PlaceholderTextProperty | Identifies the PlaceholderText dependency property. This field is read-only.
PopupBackgroundProperty | Identifies the PopupBackground dependency property. This field is read-only.
PopupBorderBrushProperty | Identifies the PopupBorderBrush dependency property. This field is read-only.
PopupPickerStyleProperty | Identifies the PopupPickerStyle dependency property. This field is read-only.
SpinWrappingProperty | Identifies the SpinWrapping dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ActivePartIndexProperty Field

PartEditBoxBaseTActivePartIndexProperty Field
Identifies the ActivePartIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ActivePartIndexProperty
Public Shared ReadOnly ActivePartIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ActivePartIndex dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).CommitTriggersProperty Field

PartEditBoxBaseTCommitTriggersProperty Field
Identifies the CommitTriggers dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CommitTriggersProperty
Public Shared ReadOnly CommitTriggersProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CommitTriggers dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasClearButtonProperty Field

PartEditBoxBaseTHasClearButtonProperty Field
Identifies the HasClearButton dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasClearButtonProperty
Public Shared ReadOnly HasClearButtonProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasClearButton dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HasPopupProperty Field

PartEditBoxBaseTHasPopupProperty Field
Identifies the HasPopup dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HasPopupProperty
Public Shared ReadOnly HasPopupProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HasPopup dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HeaderProperty Field

PartEditBoxBaseTHeaderProperty Field
Identifies the Header dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderProperty
Public Shared ReadOnly HeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Header dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).HeaderTemplateProperty Field

PartEditBoxBaseTHeaderTemplateProperty Field
Identifies the HeaderTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateProperty
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplate dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).InputScopeNameValueProperty Field

PartEditBoxBaseTInputScopeNameValueProperty Field
Identifies the InputScopeNameValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty InputScopeNameValueProperty
Public Shared ReadOnly InputScopeNameValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the InputScopeNameValue dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IntermediateValueProperty Field

PartEditBoxBaseTIntermediateValueProperty Field
Identifies the IntermediateValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IntermediateValueProperty
Public Shared ReadOnly IntermediateValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IntermediateValue dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsArrowKeyPartNavigationEnabledProperty Field

PartEditBoxBaseTIsArrowKeyPartNavigationEnabledProperty Field
Identifies the IsArrowKeyPartNavigationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsArrowKeyPartNavigationEnabledProperty
Public Shared ReadOnly IsArrowKeyPartNavigationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsArrowKeyPartNavigationEnabled dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsClearButtonVisibleProperty Field

PartEditBoxBaseTIsClearButtonVisibleProperty Field
Identifies the IsClearButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsClearButtonVisibleProperty
Public Shared ReadOnly IsClearButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsClearButtonVisible dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsEditableProperty Field

PartEditBoxBaseTIsEditableProperty Field
Identifies the IsEditable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsEditableProperty
Public Shared ReadOnly IsEditableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsEditable dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsNullAllowedProperty Field

PartEditBoxBaseTIsNullAllowedProperty Field
Identifies the IsNullAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsNullAllowedProperty
Public Shared ReadOnly IsNullAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsNullAllowed dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupButtonVisibleProperty Field

PartEditBoxBaseTIsPopupButtonVisibleProperty Field
Identifies the IsPopupButtonVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupButtonVisibleProperty
Public Shared ReadOnly IsPopupButtonVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupButtonVisible dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsPopupOpenProperty Field

PartEditBoxBaseTIsPopupOpenProperty Field
Identifies the IsPopupOpen dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPopupOpenProperty
Public Shared ReadOnly IsPopupOpenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPopupOpen dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsReadOnlyProperty Field

PartEditBoxBaseTIsReadOnlyProperty Field
Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).IsSpinnerVisibleProperty Field

PartEditBoxBaseTIsSpinnerVisibleProperty Field
Identifies the IsSpinnerVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSpinnerVisibleProperty
Public Shared ReadOnly IsSpinnerVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSpinnerVisible dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PlaceholderTextProperty Field

PartEditBoxBaseTPlaceholderTextProperty Field
Identifies the PlaceholderText dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PlaceholderTextProperty
Public Shared ReadOnly PlaceholderTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PlaceholderText dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBackgroundProperty Field

PartEditBoxBaseTPopupBackgroundProperty Field
Identifies the PopupBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupBackgroundProperty
Public Shared ReadOnly PopupBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupBackground dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupBorderBrushProperty Field

PartEditBoxBaseTPopupBorderBrushProperty Field
Identifies the PopupBorderBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupBorderBrushProperty
Public Shared ReadOnly PopupBorderBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupBorderBrush dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).PopupPickerStyleProperty Field

PartEditBoxBaseTPopupPickerStyleProperty Field
Identifies the PopupPickerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PopupPickerStyleProperty
Public Shared ReadOnly PopupPickerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PopupPickerStyle dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).SpinWrappingProperty Field

PartEditBoxBaseTSpinWrappingProperty Field
Identifies the SpinWrapping dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SpinWrappingProperty
Public Shared ReadOnly SpinWrappingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SpinWrapping dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PartEditBoxBase(T).ValueProperty Field

PartEditBoxBaseTValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PartEditBoxBaseT Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PickerBase Class

PickerBase Class
Provides an abstract base class that can be used for pickers.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class PickerBase : Control
Public MustInherit Class PickerBase
    Inherits Control

The PickerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PickerBase | Initializes an instance of the PickerBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsBrushPicker
ActiproSoftware.UI.Xaml.Controls.EditorsColorPicker
ActiproSoftware.UI.Xaml.Controls.EditorsCornerRadiusPicker
ActiproSoftware.UI.Xaml.Controls.EditorsDatePicker
ActiproSoftware.UI.Xaml.Controls.EditorsDateTimePicker
ActiproSoftware.UI.Xaml.Controls.EditorsEnumPicker
ActiproSoftware.UI.Xaml.Controls.EditorsHsbColorPicker
ActiproSoftware.UI.Xaml.Controls.EditorsPointPicker
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsRectPicker
ActiproSoftware.UI.Xaml.Controls.EditorsSizePicker
ActiproSoftware.UI.Xaml.Controls.EditorsThicknessPicker
ActiproSoftware.UI.Xaml.Controls.EditorsTimePicker
ActiproSoftware.UI.Xaml.Controls.EditorsTimeSpanPicker


PickerBase Constructor

PickerBase Constructor
Initializes an instance of the PickerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected PickerBase()
Protected Sub New
See Also

Reference

PickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PickerBase Properties

PickerBase Properties

The PickerBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PickerBase Methods

PickerBase Methods

The PickerBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PickerBase.OnCreateAutomationPeer Method

PickerBaseOnCreateAutomationPeer Method
Returns an AutomationPeer object for this control instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
An AutomationPeer instance.
See Also

Reference

PickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


PickerBase Events

PickerBase Events

The PickerBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Class

RadialSliderPickerBase Class
Provides an abstract base class that can be used for pickers that use radial sliders.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesPickerBase
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRadialSliderPickerBase
ActiproSoftware.UI.Xaml.Controls.EditorsDoublePicker
ActiproSoftware.UI.Xaml.Controls.EditorsInt16Picker
ActiproSoftware.UI.Xaml.Controls.EditorsInt32Picker
ActiproSoftware.UI.Xaml.Controls.EditorsInt64Picker
ActiproSoftware.UI.Xaml.Controls.EditorsSinglePicker

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class RadialSliderPickerBase : PickerBase
Public MustInherit Class RadialSliderPickerBase
    Inherits PickerBase

The RadialSliderPickerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | RadialSliderPickerBase | Initializes a new instance of the RadialSliderPickerBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider.
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider.
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider.
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider.
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DegreeLargeChangeProperty | Identifies the DegreeLargeChange dependency property. This field is read-only.
DegreeMaximumProperty | Identifies the DegreeMaximum dependency property. This field is read-only.
DegreeMinimumProperty | Identifies the DegreeMinimum dependency property. This field is read-only.
DegreeSmallChangeProperty | Identifies the DegreeSmallChange dependency property. This field is read-only.
DegreeValueProperty | Identifies the DegreeValue dependency property. This field is read-only.
SetValueAndClosePopupCommandProperty | Identifies the SetValueAndClosePopupCommand dependency property. This field is read-only.
SmallDecrementValueCommandProperty | Identifies the SmallDecrementValueCommand dependency property. This field is read-only.
SmallIncrementValueCommandProperty | Identifies the SmallIncrementValueCommand dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Constructor

RadialSliderPickerBase Constructor
Initializes a new instance of the RadialSliderPickerBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected RadialSliderPickerBase()
Protected Sub New
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Properties

RadialSliderPickerBase Properties

The RadialSliderPickerBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DegreeLargeChange | Gets or sets the large change degree value, which can be bound to a radial slider.
Public property | DegreeMaximum | Gets or sets the highest possible degree value, which can be bound to a radial slider.
Public property | DegreeMinimum | Gets or sets the lowest possible degree value, which can be bound to a radial slider.
Public property | DegreeSmallChange | Gets or sets the small change degree value, which can be bound to a radial slider.
Public property | DegreeValue | Gets or sets the degree value of the control, which can be bound to a radial slider.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SetValueAndClosePopupCommand | Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.
Public property | SmallDecrementValueCommand | Gets or sets the ICommand that can be used to decrement the value by a small amount.
Public property | SmallIncrementValueCommand | Gets or sets the ICommand that can be used to increment the value by a small amount.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeLargeChange Property

RadialSliderPickerBaseDegreeLargeChange Property
Gets or sets the large change degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double DegreeLargeChange { get; set; }
Public Property DegreeLargeChange As Double
    Get
    Set

Property Value

Type: Double
The large change degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMaximum Property

RadialSliderPickerBaseDegreeMaximum Property
Gets or sets the highest possible degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double DegreeMaximum { get; set; }
Public Property DegreeMaximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMinimum Property

RadialSliderPickerBaseDegreeMinimum Property
Gets or sets the lowest possible degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double DegreeMinimum { get; set; }
Public Property DegreeMinimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeSmallChange Property

RadialSliderPickerBaseDegreeSmallChange Property
Gets or sets the small change degree value, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double DegreeSmallChange { get; set; }
Public Property DegreeSmallChange As Double
    Get
    Set

Property Value

Type: Double
The small change degree value.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeValue Property

RadialSliderPickerBaseDegreeValue Property
Gets or sets the degree value of the control, which can be bound to a radial slider.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double DegreeValue { get; set; }
Public Property DegreeValue As Double
    Get
    Set

Property Value

Type: Double
The degree value of the control.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SetValueAndClosePopupCommand Property

RadialSliderPickerBaseSetValueAndClosePopupCommand Property
Gets or sets the ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SetValueAndClosePopupCommand { get; set; }
Public Property SetValueAndClosePopupCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand that can be used to set the value to the object specified in the parameter, and then close the containing popup.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallDecrementValueCommand Property

RadialSliderPickerBaseSmallDecrementValueCommand Property
Gets or sets the ICommand that can be used to decrement the value by a small amount.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SmallDecrementValueCommand { get; set; }
Public Property SmallDecrementValueCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand that can be used to decrement the value by a small amount.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallIncrementValueCommand Property

RadialSliderPickerBaseSmallIncrementValueCommand Property
Gets or sets the ICommand that can be used to increment the value by a small amount.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SmallIncrementValueCommand { get; set; }
Public Property SmallIncrementValueCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand that can be used to increment the value by a small amount.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Methods

RadialSliderPickerBase Methods

The RadialSliderPickerBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns an AutomationPeer object for this control instance. (Inherited from PickerBase.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Events

RadialSliderPickerBase Events

The RadialSliderPickerBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase Fields

RadialSliderPickerBase Fields

The RadialSliderPickerBase type exposes the following members.

Fields
Name | Description
DegreeLargeChangeProperty | Identifies the DegreeLargeChange dependency property. This field is read-only.
DegreeMaximumProperty | Identifies the DegreeMaximum dependency property. This field is read-only.
DegreeMinimumProperty | Identifies the DegreeMinimum dependency property. This field is read-only.
DegreeSmallChangeProperty | Identifies the DegreeSmallChange dependency property. This field is read-only.
DegreeValueProperty | Identifies the DegreeValue dependency property. This field is read-only.
SetValueAndClosePopupCommandProperty | Identifies the SetValueAndClosePopupCommand dependency property. This field is read-only.
SmallDecrementValueCommandProperty | Identifies the SmallDecrementValueCommand dependency property. This field is read-only.
SmallIncrementValueCommandProperty | Identifies the SmallIncrementValueCommand dependency property. This field is read-only.
Top
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeLargeChangeProperty Field

RadialSliderPickerBaseDegreeLargeChangeProperty Field
Identifies the DegreeLargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeLargeChangeProperty
Public Shared ReadOnly DegreeLargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeLargeChange dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMaximumProperty Field

RadialSliderPickerBaseDegreeMaximumProperty Field
Identifies the DegreeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeMaximumProperty
Public Shared ReadOnly DegreeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeMaximum dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeMinimumProperty Field

RadialSliderPickerBaseDegreeMinimumProperty Field
Identifies the DegreeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeMinimumProperty
Public Shared ReadOnly DegreeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeMinimum dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeSmallChangeProperty Field

RadialSliderPickerBaseDegreeSmallChangeProperty Field
Identifies the DegreeSmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeSmallChangeProperty
Public Shared ReadOnly DegreeSmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeSmallChange dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.DegreeValueProperty Field

RadialSliderPickerBaseDegreeValueProperty Field
Identifies the DegreeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DegreeValueProperty
Public Shared ReadOnly DegreeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DegreeValue dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SetValueAndClosePopupCommandProperty Field

RadialSliderPickerBaseSetValueAndClosePopupCommandProperty Field
Identifies the SetValueAndClosePopupCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SetValueAndClosePopupCommandProperty
Public Shared ReadOnly SetValueAndClosePopupCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SetValueAndClosePopupCommand dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallDecrementValueCommandProperty Field

RadialSliderPickerBaseSmallDecrementValueCommandProperty Field
Identifies the SmallDecrementValueCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallDecrementValueCommandProperty
Public Shared ReadOnly SmallDecrementValueCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallDecrementValueCommand dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RadialSliderPickerBase.SmallIncrementValueCommandProperty Field

RadialSliderPickerBaseSmallIncrementValueCommandProperty Field
Identifies the SmallIncrementValueCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallIncrementValueCommandProperty
Public Shared ReadOnly SmallIncrementValueCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallIncrementValueCommand dependency property.
See Also

Reference

RadialSliderPickerBase Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel Class

RatingPanel Class
Represents a Panel for arranging items in a Rating.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
Windows.UI.Xaml.ControlsStackPanel
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesRatingPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class RatingPanel : StackPanel
Public Class RatingPanel
    Inherits StackPanel

The RatingPanel type exposes the following members.

Constructors
 | Name | Description
Public method | RatingPanel | Initializes a new instance of the RatingPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreHorizontalSnapPointsRegular | Gets a value that indicates whether the horizontal snap points for the StackPanel are equidistant from each other. (Inherited from StackPanel.)
Public property | AreScrollSnapPointsRegular | Gets or sets a value that indicates whether the generated snap points used for panning in the StackPanel are equidistant from each other. (Inherited from StackPanel.)
Public property | AreVerticalSnapPointsRegular | Gets a value that indicates whether the vertical snap points for the StackPanel are equidistant from each other. (Inherited from StackPanel.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | (Inherited from StackPanel.)
Public property | BorderThickness | (Inherited from StackPanel.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | (Inherited from StackPanel.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | Padding | (Inherited from StackPanel.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetInsertionIndexes | (Inherited from StackPanel.)
Public method | GetIrregularSnapPoints | Returns the set of distances between irregular snap points for a specified orientation and alignment. (Inherited from StackPanel.)
Public method | GetRegularSnapPoints | Gets the distance between regular snap points for a specified orientation and alignment. (Inherited from StackPanel.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | HorizontalSnapPointsChanged | Occurs when the measurements for horizontal snap points change. (Inherited from StackPanel.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | VerticalSnapPointsChanged | Occurs when the measurements for vertical snap points change. (Inherited from StackPanel.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel Constructor

RatingPanel Constructor
Initializes a new instance of the RatingPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public RatingPanel()
Public Sub New
See Also

Reference

RatingPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel Properties

RatingPanel Properties

The RatingPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreHorizontalSnapPointsRegular | Gets a value that indicates whether the horizontal snap points for the StackPanel are equidistant from each other. (Inherited from StackPanel.)
Public property | AreScrollSnapPointsRegular | Gets or sets a value that indicates whether the generated snap points used for panning in the StackPanel are equidistant from each other. (Inherited from StackPanel.)
Public property | AreVerticalSnapPointsRegular | Gets a value that indicates whether the vertical snap points for the StackPanel are equidistant from each other. (Inherited from StackPanel.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | (Inherited from StackPanel.)
Public property | BorderThickness | (Inherited from StackPanel.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | CornerRadius | (Inherited from StackPanel.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | Padding | (Inherited from StackPanel.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel Methods

RatingPanel Methods

The RatingPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetInsertionIndexes | (Inherited from StackPanel.)
Public method | GetIrregularSnapPoints | Returns the set of distances between irregular snap points for a specified orientation and alignment. (Inherited from StackPanel.)
Public method | GetRegularSnapPoints | Gets the distance between regular snap points for a specified orientation and alignment. (Inherited from StackPanel.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel.ArrangeOverride Method

RatingPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | Arranges and performs layout on children given a size to layout within.
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel.ArrangeOverride Method (Size)

RatingPanelArrangeOverride Method (Size)
Arranges and performs layout on children given a size to layout within.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The size Panel is suggested to occupy for layout.

Return Value

Type: Size
The size Panel occupies after layout.
See Also

Reference

RatingPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel.MeasureOverride Method

RatingPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | Measures all children given an available size and returns its desired size based on the size of its children.
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel.MeasureOverride Method (Size)

RatingPanelMeasureOverride Method (Size)
Measures all children given an available size and returns its desired size based on the size of its children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The size the Panel is suggested to fit inside.

Return Value

Type: Size
The desired size of the Panel.
See Also

Reference

RatingPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


RatingPanel Events

RatingPanel Events

The RatingPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | HorizontalSnapPointsChanged | Occurs when the measurements for horizontal snap points change. (Inherited from StackPanel.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | VerticalSnapPointsChanged | Occurs when the measurements for vertical snap points change. (Inherited from StackPanel.)
Top
See Also

Reference

RatingPanel Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Class

SaturationBrightnessSquare Class
Represents a square that renders the saturation and brightness variants of a color.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Editors.PrimitivesSaturationBrightnessSquare

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SaturationBrightnessSquare : Control
Public Class SaturationBrightnessSquare
    Inherits Control

The SaturationBrightnessSquare type exposes the following members.

Constructors
 | Name | Description
Public method | SaturationBrightnessSquare | Initializes an instance of the SaturationBrightnessSquare class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrightnessBrush | Gets the Brush used to render brightness.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the base color hue.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SaturationBrush | Gets the Brush used to render saturation.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BrightnessBrushProperty | Identifies the BrightnessBrush dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationBrushProperty | Identifies the SaturationBrush dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Constructor

SaturationBrightnessSquare Constructor
Initializes an instance of the SaturationBrightnessSquare class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SaturationBrightnessSquare()
Public Sub New
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Properties

SaturationBrightnessSquare Properties

The SaturationBrightnessSquare type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrightnessBrush | Gets the Brush used to render brightness.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Hue | Gets or sets the base color hue.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SaturationBrush | Gets the Brush used to render saturation.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.BrightnessBrush Property

SaturationBrightnessSquareBrightnessBrush Property
Gets the Brush used to render brightness.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush BrightnessBrush { get; }
Public ReadOnly Property BrightnessBrush As Brush
    Get

Property Value

Type: Brush
The Brush used to render brightness.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.Hue Property

SaturationBrightnessSquareHue Property
Gets or sets the base color hue.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Hue { get; set; }
Public Property Hue As Double
    Get
    Set

Property Value

Type: Double
The base color hue.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.SaturationBrush Property

SaturationBrightnessSquareSaturationBrush Property
Gets the Brush used to render saturation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SaturationBrush { get; }
Public ReadOnly Property SaturationBrush As Brush
    Get

Property Value

Type: Brush
The Brush used to render saturation.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Methods

SaturationBrightnessSquare Methods

The SaturationBrightnessSquare type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Events

SaturationBrightnessSquare Events

The SaturationBrightnessSquare type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare Fields

SaturationBrightnessSquare Fields

The SaturationBrightnessSquare type exposes the following members.

Fields
Name | Description
BrightnessBrushProperty | Identifies the BrightnessBrush dependency property. This field is read-only.
HueProperty | Identifies the Hue dependency property. This field is read-only.
SaturationBrushProperty | Identifies the SaturationBrush dependency property. This field is read-only.
Top
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.BrightnessBrushProperty Field

SaturationBrightnessSquareBrightnessBrushProperty Field
Identifies the BrightnessBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrightnessBrushProperty
Public Shared ReadOnly BrightnessBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BrightnessBrush dependency property.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.HueProperty Field

SaturationBrightnessSquareHueProperty Field
Identifies the Hue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HueProperty
Public Shared ReadOnly HueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Hue dependency property.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


SaturationBrightnessSquare.SaturationBrushProperty Field

SaturationBrightnessSquareSaturationBrushProperty Field
Identifies the SaturationBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Editors.Primitives
Assembly: AS.Editors.Universal (in AS.Editors.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SaturationBrushProperty
Public Shared ReadOnly SaturationBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SaturationBrush dependency property.
See Also

Reference

SaturationBrightnessSquare Class
ActiproSoftware.UI.Xaml.Controls.Editors.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.Grids Namespace

ActiproSoftware.UI.Xaml.Controls.Grids Namespace
Contains classes that support implementing tree and grid controls.
Classes
 | Class | Description
Public class | PropertyGrid | Represents a property grid control.
Public class | PropertyGridItem | Represents an item for a PropertyGrid control.
Public class | PropertyGridItemActionHandler | A delegate that can process the specified PropertyGridItemActionRequest.
Public class | PropertyGridItemActionHandlerDictionary | Represents a dictionary of Type to PropertyGridItemActionHandler objects.
Public class | PropertyGridItemActionRequest | Stores information about a request for a PropertyGridItemActionHandler.
Public class | PropertyGridItemAdapter | Provides an abstract base class for a TreeListBoxItemAdapter that can be used in a PropertyGrid.
Public class | PropertyGridItemStyleSelector | Chooses a Style based on the data object and the data-bound element.
Public class | PropertyGridItemTemplateSelector | Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGridItem.
Public class | PropertyGridNameTemplateSelector | Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid name cell.
Public class | PropertyGridValueTemplateSelector | Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid value cell.
Public class | PropertyModelChildChangeEventArgs | Provides event arguments for IPropertyModel child change events, such as when a child item is added to or removed from a collection.
Public class | PropertyModelValueChangeEventArgs | Provides event arguments for IPropertyModel value change events.
Public class | TreeExpansionKind | Specifies the kind of expand or collapse.
Public class | TreeItemChildrenQueryMode | Specifies the mode by which a tree item's children are queried.
Public class | TreeItemDropArea | Specifies a drop area when a drag is over a target item.
Public class | TreeItemExpandability | Specifies a tree item's support for expansion toggling.
Public class | TreeListBox | Represents an advanced single-column tree view control.
Public class | TreeListBoxItem | Represents an item for a TreeListBox control.
Public class | TreeListBoxItemAdapter | An adapter that can provide an item's hierarchy and visual state data for usage in a TreeListBox.
Public class | TreeListBoxItemEventArgs | Provides event arguments for TreeListBox item-related events.
Public class | TreeListBoxItemExpansionEventArgs | Provides event arguments for TreeListBox item expand and collapse-related events.
Public class | TreeListBoxItemMenuEventArgs | Provides event arguments for TreeListBox item menu events.
Public class | TreeListView | Represents an advanced multi-column tree view control.
Public class | TreeListViewColumn | Represents a column definition for a TreeListView control.
Public class | TreeListViewColumnAutoWidthMode | Specifies which column cells are used to calculate auto-width.
Public class | TreeListViewColumnEventArgs | Provides event arguments for TreeListViewColumn events.
Public class | TreeListViewColumnHeader | Represents an item for a TreeListBox control.
Public class | TreeListViewColumnHeaderRole | Specifies the role for a TreeListViewColumnHeader within a TreeListView.
Public class | TreeListViewColumnMenuEventArgs | Provides event arguments for TreeListViewColumn menu events.
Public class | TreeListViewItem | Represents an item for a TreeListView control.
Public class | TreeListViewItemCell | Represents an item for a TreeListView control.
Public class | TreeMultiDragKind | Specifies the item multi-drag mode for a tree control.
Public class | TreeMultiSelectionKind | Specifies the item multi-select mode for a tree control.
Interfaces
 | Interface | Description
Public interface | ISelectedTreeItemCollection | Provides the base requirements for a collection of selected tree items.
Public interface | ITreeItemNavigator | Provides the base requirements for an object that can navigate a tree of items.
Public interface | ITreeItemVirtualPlaceholder | Provides the base requirements for an object that is a virtual placeholder for a tree item, used with data virtualization.


ISelectedTreeItemCollection Interface

ISelectedTreeItemCollection Interface
Provides the base requirements for a collection of selected tree items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ISelectedTreeItemCollection : IList<Object>,
    ICollection<Object>, IEnumerable<Object>, IEnumerable,
    IObservableVector<Object>
Public Interface ISelectedTreeItemCollection
    Inherits IList(Of Object), ICollection(Of Object),
    IEnumerable(Of Object), IEnumerable, IObservableVector(Of Object)

The ISelectedTreeItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection Object .)
Public property | IsReadOnly | (Inherited from ICollection Object .)
Public property | Item | (Inherited from IList Object .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection Object .)
Public method | Clear | (Inherited from ICollection Object .)
Public method | Contains | (Inherited from ICollection Object .)
Public method | CopyTo | (Inherited from ICollection Object .)
Public method | GetEnumerator | (Inherited from IEnumerable Object .)
Public method | IndexOf | (Inherited from IList Object .)
Public method | Insert | (Inherited from IList Object .)
Public method | Remove | (Inherited from ICollection Object .)
Public method | RemoveAt | (Inherited from IList Object .)
Top
Events
 | Name | Description
Public event | VectorChanged | Occurs when the vector changes. (Inherited from IObservableVector Object .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ISelectedTreeItemCollection Properties

ISelectedTreeItemCollection Properties

The ISelectedTreeItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection Object .)
Public property | IsReadOnly | (Inherited from ICollection Object .)
Public property | Item | (Inherited from IList Object .)
Top
See Also

Reference

ISelectedTreeItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ISelectedTreeItemCollection Methods

ISelectedTreeItemCollection Methods

The ISelectedTreeItemCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection Object .)
Public method | Clear | (Inherited from ICollection Object .)
Public method | Contains | (Inherited from ICollection Object .)
Public method | CopyTo | (Inherited from ICollection Object .)
Public method | GetEnumerator | (Inherited from IEnumerable Object .)
Public method | IndexOf | (Inherited from IList Object .)
Public method | Insert | (Inherited from IList Object .)
Public method | Remove | (Inherited from ICollection Object .)
Public method | RemoveAt | (Inherited from IList Object .)
Top
See Also

Reference

ISelectedTreeItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ISelectedTreeItemCollection Events

ISelectedTreeItemCollection Events

The ISelectedTreeItemCollection type exposes the following members.

Events
 | Name | Description
Public event | VectorChanged | Occurs when the vector changes. (Inherited from IObservableVector Object .)
Top
See Also

Reference

ISelectedTreeItemCollection Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator Interface

ITreeItemNavigator Interface
Provides the base requirements for an object that can navigate a tree of items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITreeItemNavigator
Public Interface ITreeItemNavigator

The ITreeItemNavigator type exposes the following members.

Properties
 | Name | Description
Public property | CurrentItem | Gets the current item.
Public property | Depth | Gets the item depth.
Top
Methods
 | Name | Description
Public method | GoToCommonAncestor | Moves to the common ancestor item of CurrentItem and the specified other item.
Public method | GoToFirstChild | Moves to the first child item.
Public method | GoToFirstVisible | Moves to the first visible item.
Public method | GoToLastVisible | Moves to the last visible item.
Public method | GoToNextSibling | Moves to the next sibling item.
Public method | GoToNextVisible | Moves to the next visible item.
Public method | GoToParent | Moves to the parent item.
Public method | GoToPreviousSibling | Moves to the previous sibling item.
Public method | GoToPreviousVisible | Moves to the previous visible item.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator Properties

ITreeItemNavigator Properties

The ITreeItemNavigator type exposes the following members.

Properties
 | Name | Description
Public property | CurrentItem | Gets the current item.
Public property | Depth | Gets the item depth.
Top
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.CurrentItem Property

ITreeItemNavigatorCurrentItem Property
Gets the current item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object CurrentItem { get; }
ReadOnly Property CurrentItem As Object
    Get

Property Value

Type: Object
The current item.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.Depth Property

ITreeItemNavigatorDepth Property
Gets the item depth.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Depth { get; }
ReadOnly Property Depth As Integer
    Get

Property Value

Type: Int32
The item depth.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator Methods

ITreeItemNavigator Methods

The ITreeItemNavigator type exposes the following members.

Methods
 | Name | Description
Public method | GoToCommonAncestor | Moves to the common ancestor item of CurrentItem and the specified other item.
Public method | GoToFirstChild | Moves to the first child item.
Public method | GoToFirstVisible | Moves to the first visible item.
Public method | GoToLastVisible | Moves to the last visible item.
Public method | GoToNextSibling | Moves to the next sibling item.
Public method | GoToNextVisible | Moves to the next visible item.
Public method | GoToParent | Moves to the parent item.
Public method | GoToPreviousSibling | Moves to the previous sibling item.
Public method | GoToPreviousVisible | Moves to the previous visible item.
Top
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToCommonAncestor Method

ITreeItemNavigatorGoToCommonAncestor Method
Moves to the common ancestor item of CurrentItem and the specified other item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToCommonAncestor(
    Object otherItem
)
Function GoToCommonAncestor (
    otherItem As Object
) As Boolean

Parameters

otherItem
Type: SystemObject
The other item.

Return Value

Type: Boolean
true if a common ancestor was found, which could be the same as CurrentItem prior to method invocation; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToFirstChild Method

ITreeItemNavigatorGoToFirstChild Method
Moves to the first child item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToFirstChild()
Function GoToFirstChild As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToFirstVisible Method

ITreeItemNavigatorGoToFirstVisible Method
Moves to the first visible item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToFirstVisible()
Function GoToFirstVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToLastVisible Method

ITreeItemNavigatorGoToLastVisible Method
Moves to the last visible item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToLastVisible()
Function GoToLastVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToNextSibling Method

ITreeItemNavigatorGoToNextSibling Method
Moves to the next sibling item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextSibling()
Function GoToNextSibling As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToNextVisible Method

ITreeItemNavigatorGoToNextVisible Method
Moves to the next visible item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToNextVisible()
Function GoToNextVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToParent Method

ITreeItemNavigatorGoToParent Method
Moves to the parent item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToParent()
Function GoToParent As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToPreviousSibling Method

ITreeItemNavigatorGoToPreviousSibling Method
Moves to the previous sibling item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousSibling()
Function GoToPreviousSibling As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemNavigator.GoToPreviousVisible Method

ITreeItemNavigatorGoToPreviousVisible Method
Moves to the previous visible item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GoToPreviousVisible()
Function GoToPreviousVisible As Boolean

Return Value

Type: Boolean
true if a move was successfully made; otherwise, false.
See Also

Reference

ITreeItemNavigator Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemVirtualPlaceholder Interface

ITreeItemVirtualPlaceholder Interface
Provides the base requirements for an object that is a virtual placeholder for a tree item, used with data virtualization.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITreeItemVirtualPlaceholder
Public Interface ITreeItemVirtualPlaceholder

The ITreeItemVirtualPlaceholder type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the index of the item within its parent collection.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemVirtualPlaceholder Properties

ITreeItemVirtualPlaceholder Properties

The ITreeItemVirtualPlaceholder type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the index of the item within its parent collection.
Top
See Also

Reference

ITreeItemVirtualPlaceholder Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ITreeItemVirtualPlaceholder.Index Property

ITreeItemVirtualPlaceholderIndex Property
Gets the index of the item within its parent collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Index { get; }
ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the item within its parent collection.
See Also

Reference

ITreeItemVirtualPlaceholder Interface
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid Class

PropertyGrid Class
Represents a property grid control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
ActiproSoftware.UI.Xaml.Controls.GridsTreeListView
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGrid

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGrid : TreeListView,
    IPropertyEditorsProvider
Public Class PropertyGrid
    Inherits TreeListView
    Implements IPropertyEditorsProvider

The PropertyGrid type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGrid | Initializes an instance of the PropertyGrid class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreCategoriesAutoExpanded | Gets or sets whether categories are auto-expanded when they are added into the property grid.
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible. (Inherited from TreeListView.)
Public property | AreInheritedPropertiesBrowsable | Gets or sets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets or sets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets or sets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrowsableAttributes | Gets or sets a list of Attribute objects that are used to determine which properties are browsable.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
 | CancelPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when an Escape key down event is received by a PropertyGridItem.
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user. (Inherited from TreeListView.)
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user. (Inherited from TreeListView.)
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user. (Inherited from TreeListView.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Public property | CanSummaryAutoSize | Gets or sets whether the user can double-tap the summary splitter to auto-size to the summary area content.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | Columns | Gets the collection of columns in the control. (Inherited from TreeListView.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataFactory | Gets or sets the IDataFactory used to return the data models for objects.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | DataObject | Gets or sets the data object for which the control displays properties.
Public property | DataObjects | Gets or sets the data objects for which the control displays properties.
Public property | DefaultBooleanValueTemplate | Gets or sets a DataTemplate for editing a Boolean value with a two-state CheckBox.
Public property | DefaultBrushValueTemplate | Gets or sets a DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultColorValueTemplate | Gets or sets a DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultExtendedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Public property | DefaultFontFamilyValueTemplate | Gets or sets a DataTemplate for editing a FontFamily value with a ComboBox that contains system font families.
Public property | DefaultFontStretchValueTemplate | Gets or sets a DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options.
Public property | DefaultFontStyleValueTemplate | Gets or sets a DataTemplate for editing a FontStyle value with a ComboBox that contains font style options.
Public property | DefaultFontWeightValueTemplate | Gets or sets a DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options.
Public property | DefaultLimitedObjectValueTemplate | Gets or sets a DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultLimitedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultNullableBooleanValueTemplate | Gets or sets a DataTemplate for editing a nullable Boolean with a three-state CheckBox.
 | DefaultPropertyEditors | Gets the collection of property editors that are used by default in all PropertyGrid instances, examined alongside the PropertyEditors collection for each PropertyGrid instance.
Public property | DefaultStringNameTemplate | Gets or sets a DataTemplate with a read-only TextBlock that can be used for name column cells.
Public property | DefaultStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DefaultSuggestedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button. (Inherited from TreeListView.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility. (Inherited from TreeListView.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsCategorized | Gets or sets whether properties are categorized.
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled. (Inherited from TreeListView.)
Public property | IsDefaultItemContextMenuEnabled | Gets or sets whether the default context menu is enabled for property grid items.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from TreeListBox.)
Public property | IsReadOnly | Gets or sets whether the value editors are read-only.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsSummaryResizable | Gets or sets whether the summary area is resizable.
Public property | IsSummaryToggleAllowed | Gets or sets whether the summary area's visibility is allowed to be toggled.
Public property | IsSummaryVisible | Gets or sets whether the summary area is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MiscCategoryName | Gets or sets the name used for the miscellaneous category.
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NameColumnIndex | Gets the index of the name column.
Public property | NameColumnMaxWidth | Gets or sets the maximum width of the name column, which comes into play as the property grid or its columns are resized.
Public property | NameContainerStyle | Gets or sets the Style to use for the name column cells.
Public property | NameTemplate | Gets or sets the DataTemplate to use for the name column cells.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for the name column cells.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyEditors | Gets the PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.
 | PropertyEditorsModifierKey | Gets the resource key that should reference an instance of [!:PropertyGridPropertyEditorsModifierKey]. This key is loaded by the PropertyGrid, allowing for customization of the property editors directly from XAML.
Public property | PropertyExpandability | Gets or sets a PropertyExpandability that indicates the expandability of properties.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting data models.
 | StartPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when a Tab or typing key down event is received by a PropertyGridItem.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SummaryHeight | Gets or sets the height of the summary area.
Public property | SummaryTemplate | Gets or sets a DataTemplate used to display the selected item in the summary area.
Public property | SummaryTemplateSelector | Gets or sets a DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleSummaryVisibilityCommand | Gets the ICommand used to toggle the IsSummaryVisible property.
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | ValueColumnIndex | Gets the index of the value column.
Public property | ValueContainerStyle | Gets or sets the Style to use for the value column cells.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for the value column cells.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for the value column cells.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from TreeListView.)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Inherited from TreeListBox.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListViewGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListViewIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from TreeListView.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListViewOnApplyTemplate.)
Protected method | OnChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Overrides TreeListBoxOnItemMenuRequested(TreeListBoxItemMenuEventArgs).)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBox.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Protected method | OnPropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Inherited from TreeListView.)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from TreeListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Public event | ColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Public event | PropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | RootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreCategoriesAutoExpandedProperty | Identifies the AreCategoriesAutoExpanded dependency property. This field is read-only.
AreInheritedPropertiesBrowsableProperty | Identifies the AreInheritedPropertiesBrowsable dependency property. This field is read-only.
AreNestedCategoriesSupportedProperty | Identifies the AreNestedCategoriesSupported dependency property. This field is read-only.
ArePropertiesAutoExpandedProperty | Identifies the ArePropertiesAutoExpanded dependency property. This field is read-only.
AreReadOnlyPropertiesBrowsableProperty | Identifies the AreReadOnlyPropertiesBrowsable dependency property. This field is read-only.
BrowsableAttributesProperty | Identifies the BrowsableAttributes dependency property. This field is read-only.
CanSummaryAutoSizeProperty | Identifies the CanSummaryAutoSize dependency property. This field is read-only.
CollectionPropertyDisplayModeProperty | Identifies the CollectionPropertyDisplayMode dependency property. This field is read-only.
DataFactoryProperty | Identifies the DataFactory dependency property. This field is read-only.
DataObjectProperty | Identifies the DataObject dependency property. This field is read-only.
DataObjectsProperty | Identifies the DataObjects dependency property. This field is read-only.
DefaultBooleanValueTemplateProperty | Identifies the DefaultBooleanValueTemplate dependency property. This field is read-only.
DefaultBrushValueTemplateProperty | Identifies the DefaultBrushValueTemplate dependency property. This field is read-only.
DefaultColorValueTemplateProperty | Identifies the DefaultColorValueTemplate dependency property. This field is read-only.
DefaultExtendedStringValueTemplateProperty | Identifies the DefaultExtendedStringValueTemplate dependency property. This field is read-only.
DefaultFontFamilyValueTemplateProperty | Identifies the DefaultFontFamilyValueTemplate dependency property. This field is read-only.
DefaultFontStretchValueTemplateProperty | Identifies the DefaultFontStretchValueTemplate dependency property. This field is read-only.
DefaultFontStyleValueTemplateProperty | Identifies the DefaultFontStyleValueTemplate dependency property. This field is read-only.
DefaultFontWeightValueTemplateProperty | Identifies the DefaultFontWeightValueTemplate dependency property. This field is read-only.
DefaultLimitedObjectValueTemplateProperty | Identifies the DefaultLimitedObjectValueTemplate dependency property. This field is read-only.
DefaultLimitedStringValueTemplateProperty | Identifies the DefaultLimitedStringValueTemplate dependency property. This field is read-only.
DefaultNullableBooleanValueTemplateProperty | Identifies the DefaultNullableBooleanValueTemplate dependency property. This field is read-only.
DefaultStringNameTemplateProperty | Identifies the DefaultStringNameTemplate dependency property. This field is read-only.
DefaultStringValueTemplateProperty | Identifies the DefaultStringValueTemplate dependency property. This field is read-only.
DefaultSuggestedStringValueTemplateProperty | Identifies the DefaultSuggestedStringValueTemplate dependency property. This field is read-only.
IsCategorizedProperty | Identifies the IsCategorized dependency property. This field is read-only.
IsDefaultItemContextMenuEnabledProperty | Identifies the IsDefaultItemContextMenuEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSummaryResizableProperty | Identifies the IsSummaryResizable dependency property. This field is read-only.
IsSummaryToggleAllowedProperty | Identifies the IsSummaryToggleAllowed dependency property. This field is read-only.
IsSummaryVisibleProperty | Identifies the IsSummaryVisible dependency property. This field is read-only.
MiscCategoryNameProperty | Identifies the MiscCategoryName dependency property. This field is read-only.
NameColumnMaxWidthProperty | Identifies the NameColumnMaxWidth dependency property. This field is read-only.
NameContainerStyleProperty | Identifies the NameContainerStyle dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
PropertyExpandabilityProperty | Identifies the PropertyExpandability dependency property. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SummaryHeightProperty | Identifies the SummaryHeight dependency property. This field is read-only.
SummaryTemplateProperty | Identifies the SummaryTemplate dependency property. This field is read-only.
SummaryTemplateSelectorProperty | Identifies the SummaryTemplateSelector dependency property. This field is read-only.
ValueContainerStyleProperty | Identifies the ValueContainerStyle dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid Constructor

PropertyGrid Constructor
Initializes an instance of the PropertyGrid class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGrid()
Public Sub New
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid Properties

PropertyGrid Properties

The PropertyGrid type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreCategoriesAutoExpanded | Gets or sets whether categories are auto-expanded when they are added into the property grid.
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible. (Inherited from TreeListView.)
Public property | AreInheritedPropertiesBrowsable | Gets or sets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets or sets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets or sets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BrowsableAttributes | Gets or sets a list of Attribute objects that are used to determine which properties are browsable.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
 | CancelPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when an Escape key down event is received by a PropertyGridItem.
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user. (Inherited from TreeListView.)
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user. (Inherited from TreeListView.)
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user. (Inherited from TreeListView.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Public property | CanSummaryAutoSize | Gets or sets whether the user can double-tap the summary splitter to auto-size to the summary area content.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | Columns | Gets the collection of columns in the control. (Inherited from TreeListView.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataFactory | Gets or sets the IDataFactory used to return the data models for objects.
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | DataObject | Gets or sets the data object for which the control displays properties.
Public property | DataObjects | Gets or sets the data objects for which the control displays properties.
Public property | DefaultBooleanValueTemplate | Gets or sets a DataTemplate for editing a Boolean value with a two-state CheckBox.
Public property | DefaultBrushValueTemplate | Gets or sets a DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultColorValueTemplate | Gets or sets a DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Public property | DefaultExtendedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Public property | DefaultFontFamilyValueTemplate | Gets or sets a DataTemplate for editing a FontFamily value with a ComboBox that contains system font families.
Public property | DefaultFontStretchValueTemplate | Gets or sets a DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options.
Public property | DefaultFontStyleValueTemplate | Gets or sets a DataTemplate for editing a FontStyle value with a ComboBox that contains font style options.
Public property | DefaultFontWeightValueTemplate | Gets or sets a DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options.
Public property | DefaultLimitedObjectValueTemplate | Gets or sets a DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultLimitedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Public property | DefaultNullableBooleanValueTemplate | Gets or sets a DataTemplate for editing a nullable Boolean with a three-state CheckBox.
 | DefaultPropertyEditors | Gets the collection of property editors that are used by default in all PropertyGrid instances, examined alongside the PropertyEditors collection for each PropertyGrid instance.
Public property | DefaultStringNameTemplate | Gets or sets a DataTemplate with a read-only TextBlock that can be used for name column cells.
Public property | DefaultStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DefaultSuggestedStringValueTemplate | Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button. (Inherited from TreeListView.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility. (Inherited from TreeListView.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsCategorized | Gets or sets whether properties are categorized.
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled. (Inherited from TreeListView.)
Public property | IsDefaultItemContextMenuEnabled | Gets or sets whether the default context menu is enabled for property grid items.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from TreeListBox.)
Public property | IsReadOnly | Gets or sets whether the value editors are read-only.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsSummaryResizable | Gets or sets whether the summary area is resizable.
Public property | IsSummaryToggleAllowed | Gets or sets whether the summary area's visibility is allowed to be toggled.
Public property | IsSummaryVisible | Gets or sets whether the summary area is visible.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MiscCategoryName | Gets or sets the name used for the miscellaneous category.
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NameColumnIndex | Gets the index of the name column.
Public property | NameColumnMaxWidth | Gets or sets the maximum width of the name column, which comes into play as the property grid or its columns are resized.
Public property | NameContainerStyle | Gets or sets the Style to use for the name column cells.
Public property | NameTemplate | Gets or sets the DataTemplate to use for the name column cells.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for the name column cells.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyEditors | Gets the PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.
 | PropertyEditorsModifierKey | Gets the resource key that should reference an instance of [!:PropertyGridPropertyEditorsModifierKey]. This key is loaded by the PropertyGrid, allowing for customization of the property editors directly from XAML.
Public property | PropertyExpandability | Gets or sets a PropertyExpandability that indicates the expandability of properties.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting data models.
 | StartPropertyValueEditHandlers | Gets a mapping between control types and associated delegates to be performed when a Tab or typing key down event is received by a PropertyGridItem.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | SummaryHeight | Gets or sets the height of the summary area.
Public property | SummaryTemplate | Gets or sets a DataTemplate used to display the selected item in the summary area.
Public property | SummaryTemplateSelector | Gets or sets a DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleSummaryVisibilityCommand | Gets the ICommand used to toggle the IsSummaryVisible property.
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | ValueColumnIndex | Gets the index of the value column.
Public property | ValueContainerStyle | Gets or sets the Style to use for the value column cells.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for the value column cells.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for the value column cells.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreCategoriesAutoExpanded Property

PropertyGridAreCategoriesAutoExpanded Property
Gets or sets whether categories are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreCategoriesAutoExpanded { get; set; }
Public Property AreCategoriesAutoExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if categories are auto-expanded when they are added into the property grid; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreInheritedPropertiesBrowsable Property

PropertyGridAreInheritedPropertiesBrowsable Property
Gets or sets whether inherited properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreInheritedPropertiesBrowsable { get; set; }
Public Property AreInheritedPropertiesBrowsable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if inherited properties are browsable and are displayed in the property grid; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreNestedCategoriesSupported Property

PropertyGridAreNestedCategoriesSupported Property
Gets or sets whether nested categories are supported, using a special syntax in the category name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreNestedCategoriesSupported { get; set; }
Public Property AreNestedCategoriesSupported As Boolean
    Get
    Set

Property Value

Type: Boolean
true if nested categories are supported; otherwise false. The default value is false.
Remarks
To specify a nested category, the category names should be separated by a '\'. Individual category names can be wrapped with single or double quotes, as needed.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ArePropertiesAutoExpanded Property

PropertyGridArePropertiesAutoExpanded Property
Gets or sets whether expandable properties are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ArePropertiesAutoExpanded { get; set; }
Public Property ArePropertiesAutoExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if expandable properties are auto-expanded when they are added into the property grid; otherwise false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreReadOnlyPropertiesBrowsable Property

PropertyGridAreReadOnlyPropertiesBrowsable Property
Gets or sets whether read-only properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreReadOnlyPropertiesBrowsable { get; set; }
Public Property AreReadOnlyPropertiesBrowsable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if read-only properties are browsable and are displayed in the property grid; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.BrowsableAttributes Property

PropertyGridBrowsableAttributes Property
Gets or sets a list of Attribute objects that are used to determine which properties are browsable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<Attribute> BrowsableAttributes { get; set; }
Public Property BrowsableAttributes As IEnumerable(Of Attribute)
    Get
    Set

Property Value

Type: IEnumerable Attribute
The list of Attribute objects that are used to determine which properties are browsable. The default value is a list with a single entry of BrowsableAttribute.Yes.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.CancelPropertyValueEditHandlers Property

PropertyGridCancelPropertyValueEditHandlers Property
Gets a mapping between control types and associated delegates to be performed when an Escape key down event is received by a PropertyGridItem.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static PropertyGridItemActionHandlerDictionary CancelPropertyValueEditHandlers { get; }
Public Shared ReadOnly Property CancelPropertyValueEditHandlers As PropertyGridItemActionHandlerDictionary
    Get

Property Value

Type: PropertyGridItemActionHandlerDictionary
A mapping between control types and associated delegates.
Remarks
When a KeyDown event is raised on a PropertyGridItem, the PropertyGrid will use the control with focus to find an associated delegate in the CancelPropertyValueEditHandlers dictionary. If a matching entry is found, it will be executed. Exact type matches will be used first, then each base type will be queried.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.CanSummaryAutoSize Property

PropertyGridCanSummaryAutoSize Property
Gets or sets whether the user can double-tap the summary splitter to auto-size to the summary area content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanSummaryAutoSize { get; set; }
Public Property CanSummaryAutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the user can double-tap the summary splitter to auto-size to the summary area content; otherwise, false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.CategoryEditors Property

PropertyGridCategoryEditors Property
Gets the category editors that can consume and display one or more properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorCollection CategoryEditors { get; }
Public ReadOnly Property CategoryEditors As CategoryEditorCollection
    Get

Property Value

Type: CategoryEditorCollection
The category editors that can consume and display one or more properties.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.CollectionPropertyDisplayMode Property

PropertyGridCollectionPropertyDisplayMode Property
Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollectionPropertyDisplayMode CollectionPropertyDisplayMode { get; set; }
Public Property CollectionPropertyDisplayMode As CollectionPropertyDisplayMode
    Get
    Set

Property Value

Type: CollectionPropertyDisplayMode
A CollectionPropertyDisplayMode that indicates the display mode of collection properties. The default value is CollectionPropertyDisplayMode.Default.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DataFactory Property

PropertyGridDataFactory Property
Gets or sets the IDataFactory used to return the data models for objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataFactory DataFactory { get; set; }
Public Property DataFactory As IDataFactory
    Get
    Set

Property Value

Type: IDataFactory
The IDataFactory used to return the data models for objects.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DataObject Property

PropertyGridDataObject Property
Gets or sets the data object for which the control displays properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object DataObject { get; set; }
Public Property DataObject As Object
    Get
    Set

Property Value

Type: Object
The data object for which the control displays properties.
Remarks
The DataObject property sets that a single object should be browsed in the property grid. If multiple objects are being browsed, this property returns the first one in the list specified by DataObjects. If no objects are being browsed, is returned. Setting this DataObject property replaces the value of the DataObjects property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DataObjects Property

PropertyGridDataObjects Property
Gets or sets the data objects for which the control displays properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable DataObjects { get; set; }
Public Property DataObjects As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The data objects for which the control displays properties.
Remarks
Set this property if multiple data objects should be browsed at the same time. The property grid only displays the properties that are common to all the data objects. Setting this DataObjects property replaces the value of the DataObject property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultBooleanValueTemplate Property

PropertyGridDefaultBooleanValueTemplate Property
Gets or sets a DataTemplate for editing a Boolean value with a two-state CheckBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultBooleanValueTemplate { get; set; }
Public Property DefaultBooleanValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultBrushValueTemplate Property

PropertyGridDefaultBrushValueTemplate Property
Gets or sets a DataTemplate for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultBrushValueTemplate { get; set; }
Public Property DefaultBrushValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultColorValueTemplate Property

PropertyGridDefaultColorValueTemplate Property
Gets or sets a DataTemplate for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultColorValueTemplate { get; set; }
Public Property DefaultColorValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultExtendedStringValueTemplate Property

PropertyGridDefaultExtendedStringValueTemplate Property
Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultExtendedStringValueTemplate { get; set; }
Public Property DefaultExtendedStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontFamilyValueTemplate Property

PropertyGridDefaultFontFamilyValueTemplate Property
Gets or sets a DataTemplate for editing a FontFamily value with a ComboBox that contains system font families.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontFamilyValueTemplate { get; set; }
Public Property DefaultFontFamilyValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontStretchValueTemplate Property

PropertyGridDefaultFontStretchValueTemplate Property
Gets or sets a DataTemplate for editing a FontStretch value with a ComboBox that contains font stretch options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontStretchValueTemplate { get; set; }
Public Property DefaultFontStretchValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontStyleValueTemplate Property

PropertyGridDefaultFontStyleValueTemplate Property
Gets or sets a DataTemplate for editing a FontStyle value with a ComboBox that contains font style options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontStyleValueTemplate { get; set; }
Public Property DefaultFontStyleValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontWeightValueTemplate Property

PropertyGridDefaultFontWeightValueTemplate Property
Gets or sets a DataTemplate for editing a FontWeight value with a ComboBox that contains font weight options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultFontWeightValueTemplate { get; set; }
Public Property DefaultFontWeightValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultLimitedObjectValueTemplate Property

PropertyGridDefaultLimitedObjectValueTemplate Property
Gets or sets a DataTemplate for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultLimitedObjectValueTemplate { get; set; }
Public Property DefaultLimitedObjectValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultLimitedStringValueTemplate Property

PropertyGridDefaultLimitedStringValueTemplate Property
Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultLimitedStringValueTemplate { get; set; }
Public Property DefaultLimitedStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultNullableBooleanValueTemplate Property

PropertyGridDefaultNullableBooleanValueTemplate Property
Gets or sets a DataTemplate for editing a nullable Boolean with a three-state CheckBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultNullableBooleanValueTemplate { get; set; }
Public Property DefaultNullableBooleanValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultPropertyEditors Property

PropertyGridDefaultPropertyEditors Property
Gets the collection of property editors that are used by default in all PropertyGrid instances, examined alongside the PropertyEditors collection for each PropertyGrid instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static PropertyEditorCollection DefaultPropertyEditors { get; }
Public Shared ReadOnly Property DefaultPropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The collection of property editors that are used by default in all PropertyGrid instances.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace
PropertyGridPropertyEditors


PropertyGrid.DefaultStringNameTemplate Property

PropertyGridDefaultStringNameTemplate Property
Gets or sets a DataTemplate with a read-only TextBlock that can be used for name column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultStringNameTemplate { get; set; }
Public Property DefaultStringNameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultStringValueTemplate Property

PropertyGridDefaultStringValueTemplate Property
Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with a TextBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultStringValueTemplate { get; set; }
Public Property DefaultStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultSuggestedStringValueTemplate Property

PropertyGridDefaultSuggestedStringValueTemplate Property
Gets or sets a DataTemplate for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate DefaultSuggestedStringValueTemplate { get; set; }
Public Property DefaultSuggestedStringValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
A DataTemplate that can be used for value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsCategorized Property

PropertyGridIsCategorized Property
Gets or sets whether properties are categorized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCategorized { get; set; }
Public Property IsCategorized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if properties are categorized; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsDefaultItemContextMenuEnabled Property

PropertyGridIsDefaultItemContextMenuEnabled Property
Gets or sets whether the default context menu is enabled for property grid items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDefaultItemContextMenuEnabled { get; set; }
Public Property IsDefaultItemContextMenuEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the default context menu is enabled for property grid items; otherwise false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsReadOnly Property

PropertyGridIsReadOnly Property
Gets or sets whether the value editors are read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if value editors are read-only; otherwise, false. The default value is false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsSummaryResizable Property

PropertyGridIsSummaryResizable Property
Gets or sets whether the summary area is resizable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSummaryResizable { get; set; }
Public Property IsSummaryResizable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the summary is resizable; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsSummaryToggleAllowed Property

PropertyGridIsSummaryToggleAllowed Property
Gets or sets whether the summary area's visibility is allowed to be toggled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSummaryToggleAllowed { get; set; }
Public Property IsSummaryToggleAllowed As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the summary area's visibility is allowed to be toggled; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsSummaryVisible Property

PropertyGridIsSummaryVisible Property
Gets or sets whether the summary area is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSummaryVisible { get; set; }
Public Property IsSummaryVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the summary area is visible; otherwise, false. The default value is true.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.MiscCategoryName Property

PropertyGridMiscCategoryName Property
Gets or sets the name used for the miscellaneous category.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string MiscCategoryName { get; set; }
Public Property MiscCategoryName As String
    Get
    Set

Property Value

Type: String
The name used for the miscellaneous category. The default value is "Misc".
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameColumnIndex Property

PropertyGridNameColumnIndex Property
Gets the index of the name column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int NameColumnIndex { get; }
Public ReadOnly Property NameColumnIndex As Integer
    Get

Property Value

Type: Int32
The index of the name column.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameColumnMaxWidth Property

PropertyGridNameColumnMaxWidth Property
Gets or sets the maximum width of the name column, which comes into play as the property grid or its columns are resized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double NameColumnMaxWidth { get; set; }
Public Property NameColumnMaxWidth As Double
    Get
    Set

Property Value

Type: Double
The maximum width of the name column.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameContainerStyle Property

PropertyGridNameContainerStyle Property
Gets or sets the Style to use for the name column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style NameContainerStyle { get; set; }
Public Property NameContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameTemplate Property

PropertyGridNameTemplate Property
Gets or sets the DataTemplate to use for the name column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate NameTemplate { get; set; }
Public Property NameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameTemplateSelector Property

PropertyGridNameTemplateSelector Property
Gets or sets the DataTemplateSelector to use for the name column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector NameTemplateSelector { get; set; }
Public Property NameTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the name column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.Properties Property

PropertyGridProperties Property
Gets the explicitly-defined properties that should be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelCollection Properties { get; }
Public ReadOnly Property Properties As PropertyModelCollection
    Get

Property Value

Type: PropertyModelCollection
The explicitly-defined properties that should be displayed.
Remarks
These properties will be merged with the properties generated from the DataObjects property. If DataObjects is null or empty, then only these properties will be displayed.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.PropertyEditors Property

PropertyGridPropertyEditors Property
Gets the PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditorCollection PropertyEditors { get; }
Public ReadOnly Property PropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The PropertyEditorCollection that contains property editor definitions specifically for this property grid instance.

Implements

IPropertyEditorsProviderPropertyEditors
Remarks
The DefaultPropertyEditors collection contains other property editors that apply to all PropertyGrid instances.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace
PropertyGridDefaultPropertyEditors


PropertyGrid.PropertyEditorsModifierKey Property

PropertyGridPropertyEditorsModifierKey Property
Gets the resource key that should reference an instance of [!:PropertyGridPropertyEditorsModifierKey]. This key is loaded by the PropertyGrid, allowing for customization of the property editors directly from XAML.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Object PropertyEditorsModifierKey { get; }
Public Shared ReadOnly Property PropertyEditorsModifierKey As Object
    Get

Property Value

Type: Object
A resource key whose value is the string "PropertyGridPropertyEditorsModifierKey".
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.PropertyExpandability Property

PropertyGridPropertyExpandability Property
Gets or sets a PropertyExpandability that indicates the expandability of properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyExpandability PropertyExpandability { get; set; }
Public Property PropertyExpandability As PropertyExpandability
    Get
    Set

Property Value

Type: PropertyExpandability
A PropertyExpandability that indicates the expandability of properties. The default value is PropertyExpandability.Default.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SortComparer Property

PropertyGridSortComparer Property
Gets or sets the DataModelSortComparer to use for sorting data models.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelSortComparer SortComparer { get; set; }
Public Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting data models. The default value is a DataModelSortComparer instance.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.StartPropertyValueEditHandlers Property

PropertyGridStartPropertyValueEditHandlers Property
Gets a mapping between control types and associated delegates to be performed when a Tab or typing key down event is received by a PropertyGridItem.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static PropertyGridItemActionHandlerDictionary StartPropertyValueEditHandlers { get; }
Public Shared ReadOnly Property StartPropertyValueEditHandlers As PropertyGridItemActionHandlerDictionary
    Get

Property Value

Type: PropertyGridItemActionHandlerDictionary
A mapping between control types and associated delegates.
Remarks
When a KeyDown event is raised on a PropertyGridItem, the PropertyGrid will use the control that should gain focus to find an associated delegate in the StartPropertyValueEditHandlers dictionary. If a matching entry is found, it will be executed. Exact type matches will be used first, then each base type will be queried.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SummaryHeight Property

PropertyGridSummaryHeight Property
Gets or sets the height of the summary area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SummaryHeight { get; set; }
Public Property SummaryHeight As Double
    Get
    Set

Property Value

Type: Double
The height of the summary area. The default value is 78.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SummaryTemplate Property

PropertyGridSummaryTemplate Property
Gets or sets a DataTemplate used to display the selected item in the summary area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate SummaryTemplate { get; set; }
Public Property SummaryTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate used to display the selected item in the summary area. The default value is .
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SummaryTemplateSelector Property

PropertyGridSummaryTemplateSelector Property
Gets or sets a DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector SummaryTemplateSelector { get; set; }
Public Property SummaryTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector used to select a DataTemplate, which is used to display the selected item in the summary area. The default value is .
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ToggleSummaryVisibilityCommand Property

PropertyGridToggleSummaryVisibilityCommand Property
Gets the ICommand used to toggle the IsSummaryVisible property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ToggleSummaryVisibilityCommand { get; }
Public ReadOnly Property ToggleSummaryVisibilityCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to toggle the IsSummaryVisible property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueColumnIndex Property

PropertyGridValueColumnIndex Property
Gets the index of the value column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int ValueColumnIndex { get; }
Public ReadOnly Property ValueColumnIndex As Integer
    Get

Property Value

Type: Int32
The index of the value column.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueContainerStyle Property

PropertyGridValueContainerStyle Property
Gets or sets the Style to use for the value column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ValueContainerStyle { get; set; }
Public Property ValueContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueTemplate Property

PropertyGridValueTemplate Property
Gets or sets the DataTemplate to use for the value column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ValueTemplate { get; set; }
Public Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for the value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueTemplateSelector Property

PropertyGridValueTemplateSelector Property
Gets or sets the DataTemplateSelector to use for the value column cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector ValueTemplateSelector { get; set; }
Public Property ValueTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for the value column cells.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid Methods

PropertyGrid Methods

The PropertyGrid type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from TreeListView.)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Inherited from TreeListBox.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListViewGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListViewIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from TreeListView.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListViewOnApplyTemplate.)
Protected method | OnChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Protected method | OnChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Overrides TreeListBoxOnItemMenuRequested(TreeListBoxItemMenuEventArgs).)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBox.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Protected method | OnPropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Inherited from TreeListView.)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from TreeListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit. (Inherited from TreeListView.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.GetContainerForItemOverride Method

PropertyGridGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsItemItsOwnContainerOverride Method

PropertyGridIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnApplyTemplate Method

PropertyGridOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnChildPropertyAdded Method

PropertyGridOnChildPropertyAdded Method
Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyAdded(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyAdded (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnChildPropertyAdding Method

PropertyGridOnChildPropertyAdding Method
Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyAdding(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyAdding (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnChildPropertyRemoved Method

PropertyGridOnChildPropertyRemoved Method
Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyRemoved(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyRemoved (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnChildPropertyRemoving Method

PropertyGridOnChildPropertyRemoving Method
Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChildPropertyRemoving(
    PropertyModelChildChangeEventArgs e
)
Protected Overridable Sub OnChildPropertyRemoving (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnItemMenuRequested Method

PropertyGridOnItemMenuRequested Method
Occurs when an item requests a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnItemMenuRequested(
    TreeListBoxItemMenuEventArgs e
)
Protected Overrides Sub OnItemMenuRequested (
    e As TreeListBoxItemMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemMenuEventArgs
The TreeListBoxItemMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnPropertyValueChanged Method

PropertyGridOnPropertyValueChanged Method
Occurs after the value is set for an IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyValueChanged(
    PropertyModelValueChangeEventArgs e
)
Protected Overridable Sub OnPropertyValueChanged (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.OnPropertyValueChanging Method

PropertyGridOnPropertyValueChanging Method
Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyValueChanging(
    PropertyModelValueChangeEventArgs e
)
Protected Overridable Sub OnPropertyValueChanging (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.TryCommitPropertyValueEdit Method

PropertyGridTryCommitPropertyValueEdit Method
Tries to commit a pending property value edit, generally in response to an Enter key press.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected bool TryCommitPropertyValueEdit()
Protected Function TryCommitPropertyValueEdit As Boolean

Return Value

Type: Boolean
true if the commit was handled; otherwise, false.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid Events

PropertyGrid Events

The PropertyGrid type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ChildPropertyAdded | Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyAdding | Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.
Public event | ChildPropertyRemoved | Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ChildPropertyRemoving | Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu. (Inherited from TreeListView.)
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed. (Inherited from TreeListView.)
Public event | ColumnReordered | Occurs after a column is reordered by the end user. (Inherited from TreeListView.)
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes. (Inherited from TreeListView.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyValueChanged | Occurs after the value is set for an IPropertyModel.
Public event | PropertyValueChanging | Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | RootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ChildPropertyAdded Event

PropertyGridChildPropertyAdded Event
Occurs after a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyAdded
Public Event ChildPropertyAdded As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ChildPropertyAdding Event

PropertyGridChildPropertyAdding Event
Occurs before a IPropertyModel representing a child is added to a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyAdding
Public Event ChildPropertyAdding As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ChildPropertyRemoved Event

PropertyGridChildPropertyRemoved Event
Occurs after a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyRemoved
Public Event ChildPropertyRemoved As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ChildPropertyRemoving Event

PropertyGridChildPropertyRemoving Event
Occurs before a IPropertyModel representing a child is removed from a parent IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelChildChangeEventArgs> ChildPropertyRemoving
Public Event ChildPropertyRemoving As EventHandler(Of PropertyModelChildChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelChildChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.PropertyValueChanged Event

PropertyGridPropertyValueChanged Event
Occurs after the value is set for an IPropertyModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelValueChangeEventArgs> PropertyValueChanged
Public Event PropertyValueChanged As EventHandler(Of PropertyModelValueChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelValueChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.PropertyValueChanging Event

PropertyGridPropertyValueChanging Event
Occurs before the value is set for an IPropertyModel, allowing the value change to be canceled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyModelValueChangeEventArgs> PropertyValueChanging
Public Event PropertyValueChanging As EventHandler(Of PropertyModelValueChangeEventArgs)

Value

Type: SystemEventHandler PropertyModelValueChangeEventArgs
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid Fields

PropertyGrid Fields

The PropertyGrid type exposes the following members.

Fields
Name | Description
AreCategoriesAutoExpandedProperty | Identifies the AreCategoriesAutoExpanded dependency property. This field is read-only.
AreInheritedPropertiesBrowsableProperty | Identifies the AreInheritedPropertiesBrowsable dependency property. This field is read-only.
AreNestedCategoriesSupportedProperty | Identifies the AreNestedCategoriesSupported dependency property. This field is read-only.
ArePropertiesAutoExpandedProperty | Identifies the ArePropertiesAutoExpanded dependency property. This field is read-only.
AreReadOnlyPropertiesBrowsableProperty | Identifies the AreReadOnlyPropertiesBrowsable dependency property. This field is read-only.
BrowsableAttributesProperty | Identifies the BrowsableAttributes dependency property. This field is read-only.
CanSummaryAutoSizeProperty | Identifies the CanSummaryAutoSize dependency property. This field is read-only.
CollectionPropertyDisplayModeProperty | Identifies the CollectionPropertyDisplayMode dependency property. This field is read-only.
DataFactoryProperty | Identifies the DataFactory dependency property. This field is read-only.
DataObjectProperty | Identifies the DataObject dependency property. This field is read-only.
DataObjectsProperty | Identifies the DataObjects dependency property. This field is read-only.
DefaultBooleanValueTemplateProperty | Identifies the DefaultBooleanValueTemplate dependency property. This field is read-only.
DefaultBrushValueTemplateProperty | Identifies the DefaultBrushValueTemplate dependency property. This field is read-only.
DefaultColorValueTemplateProperty | Identifies the DefaultColorValueTemplate dependency property. This field is read-only.
DefaultExtendedStringValueTemplateProperty | Identifies the DefaultExtendedStringValueTemplate dependency property. This field is read-only.
DefaultFontFamilyValueTemplateProperty | Identifies the DefaultFontFamilyValueTemplate dependency property. This field is read-only.
DefaultFontStretchValueTemplateProperty | Identifies the DefaultFontStretchValueTemplate dependency property. This field is read-only.
DefaultFontStyleValueTemplateProperty | Identifies the DefaultFontStyleValueTemplate dependency property. This field is read-only.
DefaultFontWeightValueTemplateProperty | Identifies the DefaultFontWeightValueTemplate dependency property. This field is read-only.
DefaultLimitedObjectValueTemplateProperty | Identifies the DefaultLimitedObjectValueTemplate dependency property. This field is read-only.
DefaultLimitedStringValueTemplateProperty | Identifies the DefaultLimitedStringValueTemplate dependency property. This field is read-only.
DefaultNullableBooleanValueTemplateProperty | Identifies the DefaultNullableBooleanValueTemplate dependency property. This field is read-only.
DefaultStringNameTemplateProperty | Identifies the DefaultStringNameTemplate dependency property. This field is read-only.
DefaultStringValueTemplateProperty | Identifies the DefaultStringValueTemplate dependency property. This field is read-only.
DefaultSuggestedStringValueTemplateProperty | Identifies the DefaultSuggestedStringValueTemplate dependency property. This field is read-only.
IsCategorizedProperty | Identifies the IsCategorized dependency property. This field is read-only.
IsDefaultItemContextMenuEnabledProperty | Identifies the IsDefaultItemContextMenuEnabled dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSummaryResizableProperty | Identifies the IsSummaryResizable dependency property. This field is read-only.
IsSummaryToggleAllowedProperty | Identifies the IsSummaryToggleAllowed dependency property. This field is read-only.
IsSummaryVisibleProperty | Identifies the IsSummaryVisible dependency property. This field is read-only.
MiscCategoryNameProperty | Identifies the MiscCategoryName dependency property. This field is read-only.
NameColumnMaxWidthProperty | Identifies the NameColumnMaxWidth dependency property. This field is read-only.
NameContainerStyleProperty | Identifies the NameContainerStyle dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
PropertyExpandabilityProperty | Identifies the PropertyExpandability dependency property. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SummaryHeightProperty | Identifies the SummaryHeight dependency property. This field is read-only.
SummaryTemplateProperty | Identifies the SummaryTemplate dependency property. This field is read-only.
SummaryTemplateSelectorProperty | Identifies the SummaryTemplateSelector dependency property. This field is read-only.
ValueContainerStyleProperty | Identifies the ValueContainerStyle dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
Top
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreCategoriesAutoExpandedProperty Field

PropertyGridAreCategoriesAutoExpandedProperty Field
Identifies the AreCategoriesAutoExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreCategoriesAutoExpandedProperty
Public Shared ReadOnly AreCategoriesAutoExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreCategoriesAutoExpanded dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreInheritedPropertiesBrowsableProperty Field

PropertyGridAreInheritedPropertiesBrowsableProperty Field
Identifies the AreInheritedPropertiesBrowsable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreInheritedPropertiesBrowsableProperty
Public Shared ReadOnly AreInheritedPropertiesBrowsableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreInheritedPropertiesBrowsable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreNestedCategoriesSupportedProperty Field

PropertyGridAreNestedCategoriesSupportedProperty Field
Identifies the AreNestedCategoriesSupported dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreNestedCategoriesSupportedProperty
Public Shared ReadOnly AreNestedCategoriesSupportedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreNestedCategoriesSupported dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ArePropertiesAutoExpandedProperty Field

PropertyGridArePropertiesAutoExpandedProperty Field
Identifies the ArePropertiesAutoExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArePropertiesAutoExpandedProperty
Public Shared ReadOnly ArePropertiesAutoExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArePropertiesAutoExpanded dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.AreReadOnlyPropertiesBrowsableProperty Field

PropertyGridAreReadOnlyPropertiesBrowsableProperty Field
Identifies the AreReadOnlyPropertiesBrowsable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreReadOnlyPropertiesBrowsableProperty
Public Shared ReadOnly AreReadOnlyPropertiesBrowsableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreReadOnlyPropertiesBrowsable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.BrowsableAttributesProperty Field

PropertyGridBrowsableAttributesProperty Field
Identifies the BrowsableAttributes dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BrowsableAttributesProperty
Public Shared ReadOnly BrowsableAttributesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BrowsableAttributes dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.CanSummaryAutoSizeProperty Field

PropertyGridCanSummaryAutoSizeProperty Field
Identifies the CanSummaryAutoSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanSummaryAutoSizeProperty
Public Shared ReadOnly CanSummaryAutoSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanSummaryAutoSize dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.CollectionPropertyDisplayModeProperty Field

PropertyGridCollectionPropertyDisplayModeProperty Field
Identifies the CollectionPropertyDisplayMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CollectionPropertyDisplayModeProperty
Public Shared ReadOnly CollectionPropertyDisplayModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CollectionPropertyDisplayMode dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DataFactoryProperty Field

PropertyGridDataFactoryProperty Field
Identifies the DataFactory dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataFactoryProperty
Public Shared ReadOnly DataFactoryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataFactory dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DataObjectProperty Field

PropertyGridDataObjectProperty Field
Identifies the DataObject dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataObjectProperty
Public Shared ReadOnly DataObjectProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataObject dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DataObjectsProperty Field

PropertyGridDataObjectsProperty Field
Identifies the DataObjects dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataObjectsProperty
Public Shared ReadOnly DataObjectsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataObjects dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultBooleanValueTemplateProperty Field

PropertyGridDefaultBooleanValueTemplateProperty Field
Identifies the DefaultBooleanValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultBooleanValueTemplateProperty
Public Shared ReadOnly DefaultBooleanValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultBooleanValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultBrushValueTemplateProperty Field

PropertyGridDefaultBrushValueTemplateProperty Field
Identifies the DefaultBrushValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultBrushValueTemplateProperty
Public Shared ReadOnly DefaultBrushValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultBrushValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultColorValueTemplateProperty Field

PropertyGridDefaultColorValueTemplateProperty Field
Identifies the DefaultColorValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultColorValueTemplateProperty
Public Shared ReadOnly DefaultColorValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultColorValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultExtendedStringValueTemplateProperty Field

PropertyGridDefaultExtendedStringValueTemplateProperty Field
Identifies the DefaultExtendedStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultExtendedStringValueTemplateProperty
Public Shared ReadOnly DefaultExtendedStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultExtendedStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontFamilyValueTemplateProperty Field

PropertyGridDefaultFontFamilyValueTemplateProperty Field
Identifies the DefaultFontFamilyValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontFamilyValueTemplateProperty
Public Shared ReadOnly DefaultFontFamilyValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontFamilyValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontStretchValueTemplateProperty Field

PropertyGridDefaultFontStretchValueTemplateProperty Field
Identifies the DefaultFontStretchValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontStretchValueTemplateProperty
Public Shared ReadOnly DefaultFontStretchValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontStretchValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontStyleValueTemplateProperty Field

PropertyGridDefaultFontStyleValueTemplateProperty Field
Identifies the DefaultFontStyleValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontStyleValueTemplateProperty
Public Shared ReadOnly DefaultFontStyleValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontStyleValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultFontWeightValueTemplateProperty Field

PropertyGridDefaultFontWeightValueTemplateProperty Field
Identifies the DefaultFontWeightValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultFontWeightValueTemplateProperty
Public Shared ReadOnly DefaultFontWeightValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultFontWeightValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultLimitedObjectValueTemplateProperty Field

PropertyGridDefaultLimitedObjectValueTemplateProperty Field
Identifies the DefaultLimitedObjectValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultLimitedObjectValueTemplateProperty
Public Shared ReadOnly DefaultLimitedObjectValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultLimitedObjectValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultLimitedStringValueTemplateProperty Field

PropertyGridDefaultLimitedStringValueTemplateProperty Field
Identifies the DefaultLimitedStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultLimitedStringValueTemplateProperty
Public Shared ReadOnly DefaultLimitedStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultLimitedStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultNullableBooleanValueTemplateProperty Field

PropertyGridDefaultNullableBooleanValueTemplateProperty Field
Identifies the DefaultNullableBooleanValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultNullableBooleanValueTemplateProperty
Public Shared ReadOnly DefaultNullableBooleanValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultNullableBooleanValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultStringNameTemplateProperty Field

PropertyGridDefaultStringNameTemplateProperty Field
Identifies the DefaultStringNameTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultStringNameTemplateProperty
Public Shared ReadOnly DefaultStringNameTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultStringNameTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultStringValueTemplateProperty Field

PropertyGridDefaultStringValueTemplateProperty Field
Identifies the DefaultStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultStringValueTemplateProperty
Public Shared ReadOnly DefaultStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.DefaultSuggestedStringValueTemplateProperty Field

PropertyGridDefaultSuggestedStringValueTemplateProperty Field
Identifies the DefaultSuggestedStringValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultSuggestedStringValueTemplateProperty
Public Shared ReadOnly DefaultSuggestedStringValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultSuggestedStringValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsCategorizedProperty Field

PropertyGridIsCategorizedProperty Field
Identifies the IsCategorized dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCategorizedProperty
Public Shared ReadOnly IsCategorizedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCategorized dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsDefaultItemContextMenuEnabledProperty Field

PropertyGridIsDefaultItemContextMenuEnabledProperty Field
Identifies the IsDefaultItemContextMenuEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDefaultItemContextMenuEnabledProperty
Public Shared ReadOnly IsDefaultItemContextMenuEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDefaultItemContextMenuEnabled dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsReadOnlyProperty Field

PropertyGridIsReadOnlyProperty Field
Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsSummaryResizableProperty Field

PropertyGridIsSummaryResizableProperty Field
Identifies the IsSummaryResizable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSummaryResizableProperty
Public Shared ReadOnly IsSummaryResizableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSummaryResizable dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsSummaryToggleAllowedProperty Field

PropertyGridIsSummaryToggleAllowedProperty Field
Identifies the IsSummaryToggleAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSummaryToggleAllowedProperty
Public Shared ReadOnly IsSummaryToggleAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSummaryToggleAllowed dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.IsSummaryVisibleProperty Field

PropertyGridIsSummaryVisibleProperty Field
Identifies the IsSummaryVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSummaryVisibleProperty
Public Shared ReadOnly IsSummaryVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSummaryVisible dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.MiscCategoryNameProperty Field

PropertyGridMiscCategoryNameProperty Field
Identifies the MiscCategoryName dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MiscCategoryNameProperty
Public Shared ReadOnly MiscCategoryNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MiscCategoryName dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameColumnMaxWidthProperty Field

PropertyGridNameColumnMaxWidthProperty Field
Identifies the NameColumnMaxWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameColumnMaxWidthProperty
Public Shared ReadOnly NameColumnMaxWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameColumnMaxWidth dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameContainerStyleProperty Field

PropertyGridNameContainerStyleProperty Field
Identifies the NameContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameContainerStyleProperty
Public Shared ReadOnly NameContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameTemplateProperty Field

PropertyGridNameTemplateProperty Field
Identifies the NameTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateProperty
Public Shared ReadOnly NameTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.NameTemplateSelectorProperty Field

PropertyGridNameTemplateSelectorProperty Field
Identifies the NameTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateSelectorProperty
Public Shared ReadOnly NameTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplateSelector dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.PropertyExpandabilityProperty Field

PropertyGridPropertyExpandabilityProperty Field
Identifies the PropertyExpandability dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PropertyExpandabilityProperty
Public Shared ReadOnly PropertyExpandabilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PropertyExpandability dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SortComparerProperty Field

PropertyGridSortComparerProperty Field
Identifies the SortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortComparerProperty
Public Shared ReadOnly SortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortComparer dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SummaryHeightProperty Field

PropertyGridSummaryHeightProperty Field
Identifies the SummaryHeight dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SummaryHeightProperty
Public Shared ReadOnly SummaryHeightProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SummaryHeight dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SummaryTemplateProperty Field

PropertyGridSummaryTemplateProperty Field
Identifies the SummaryTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SummaryTemplateProperty
Public Shared ReadOnly SummaryTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SummaryTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.SummaryTemplateSelectorProperty Field

PropertyGridSummaryTemplateSelectorProperty Field
Identifies the SummaryTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SummaryTemplateSelectorProperty
Public Shared ReadOnly SummaryTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SummaryTemplateSelector dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueContainerStyleProperty Field

PropertyGridValueContainerStyleProperty Field
Identifies the ValueContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueContainerStyleProperty
Public Shared ReadOnly ValueContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueContainerStyle dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueTemplateProperty Field

PropertyGridValueTemplateProperty Field
Identifies the ValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateProperty
Public Shared ReadOnly ValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplate dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGrid.ValueTemplateSelectorProperty Field

PropertyGridValueTemplateSelectorProperty Field
Identifies the ValueTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateSelectorProperty
Public Shared ReadOnly ValueTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateSelector dependency property.
See Also

Reference

PropertyGrid Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem Class

PropertyGridItem Class
Represents an item for a PropertyGrid control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItem
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewItem
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItem : TreeListViewItem
Public Class PropertyGridItem
    Inherits TreeListViewItem

The PropertyGridItem type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItem | Initializes an instance of the PropertyGridItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineBrush | Gets or sets the Brush used for row grid lines.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | IndentIndicatorBackground | Gets or sets the Brush used for the indent indicator background.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from TreeListBoxItem.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped. (Overrides TreeListBoxItemOnDoubleTapped(InputPointerButtonEventArgs).)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Inherited from TreeListViewItem.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TreeListBoxItemOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryCancelPropertyValueEdit | Tries to cancel a pending property value edit, generally in response to an Escape key press.
Protected method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
GridLineBrushProperty | Identifies the GridLineBrush dependency property. This field is read-only.
IndentIndicatorBackgroundProperty | Identifies the IndentIndicatorBackground dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem Constructor

PropertyGridItem Constructor
Initializes an instance of the PropertyGridItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItem()
Public Sub New
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem Properties

PropertyGridItem Properties

The PropertyGridItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GridLineBrush | Gets or sets the Brush used for row grid lines.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | IndentIndicatorBackground | Gets or sets the Brush used for the indent indicator background.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.GridLineBrush Property

PropertyGridItemGridLineBrush Property
Gets or sets the Brush used for row grid lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush GridLineBrush { get; set; }
Public Property GridLineBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used for row grid lines.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.IndentIndicatorBackground Property

PropertyGridItemIndentIndicatorBackground Property
Gets or sets the Brush used for the indent indicator background.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush IndentIndicatorBackground { get; set; }
Public Property IndentIndicatorBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used for the indent indicator background.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem Methods

PropertyGridItem Methods

The PropertyGridItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from TreeListBoxItem.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped. (Overrides TreeListBoxItemOnDoubleTapped(InputPointerButtonEventArgs).)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Inherited from TreeListViewItem.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides TreeListBoxItemOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Protected method | TryCancelPropertyValueEdit | Tries to cancel a pending property value edit, generally in response to an Escape key press.
Protected method | TryCommitPropertyValueEdit | Tries to commit a pending property value edit, generally in response to an Enter key press.
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.OnDoubleTapped Method

PropertyGridItemOnDoubleTapped Method
Overload List
 | Name | Description
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped. (Overrides TreeListBoxItemOnDoubleTapped(InputPointerButtonEventArgs).)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.OnDoubleTapped Method (InputPointerButtonEventArgs)

PropertyGridItemOnDoubleTapped Method (InputPointerButtonEventArgs)
Occurs when the item is double-tapped.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDoubleTapped(
    InputPointerButtonEventArgs e
)
Protected Overrides Sub OnDoubleTapped (
    e As InputPointerButtonEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.InputInputPointerButtonEventArgs
The InputPointerButtonEventArgs containing data related to this event.
See Also

Reference

PropertyGridItem Class
OnDoubleTapped Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.OnKeyDown Method

PropertyGridItemOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.TryCancelPropertyValueEdit Method

PropertyGridItemTryCancelPropertyValueEdit Method
Tries to cancel a pending property value edit, generally in response to an Escape key press.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool TryCancelPropertyValueEdit()
Protected Overridable Function TryCancelPropertyValueEdit As Boolean

Return Value

Type: Boolean
true if the cancel was handled; otherwise, false.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.TryCommitPropertyValueEdit Method

PropertyGridItemTryCommitPropertyValueEdit Method
Tries to commit a pending property value edit, generally in response to an Enter key press.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool TryCommitPropertyValueEdit()
Protected Overridable Function TryCommitPropertyValueEdit As Boolean

Return Value

Type: Boolean
true if the commit was handled; otherwise, false.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem Events

PropertyGridItem Events

The PropertyGridItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem Fields

PropertyGridItem Fields

The PropertyGridItem type exposes the following members.

Fields
Name | Description
GridLineBrushProperty | Identifies the GridLineBrush dependency property. This field is read-only.
IndentIndicatorBackgroundProperty | Identifies the IndentIndicatorBackground dependency property. This field is read-only.
Top
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.GridLineBrushProperty Field

PropertyGridItemGridLineBrushProperty Field
Identifies the GridLineBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GridLineBrushProperty
Public Shared ReadOnly GridLineBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GridLineBrush dependency property.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItem.IndentIndicatorBackgroundProperty Field

PropertyGridItemIndentIndicatorBackgroundProperty Field
Identifies the IndentIndicatorBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentIndicatorBackgroundProperty
Public Shared ReadOnly IndentIndicatorBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentIndicatorBackground dependency property.
See Also

Reference

PropertyGridItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler Class

PropertyGridItemActionHandler Class
A delegate that can process the specified PropertyGridItemActionRequest.
Inheritance Hierarchy
SystemObject
SystemDelegate
SystemMulticastDelegate
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemActionHandler

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PropertyGridItemActionHandler : MulticastDelegate
Public NotInheritable Class PropertyGridItemActionHandler
    Inherits MulticastDelegate

Return Value

Type:
true if the request was processed successfully; otherwise, false.

The PropertyGridItemActionHandler type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemActionHandler | Initializes a new instance of the PropertyGridItemActionHandler class
Top
Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler Constructor

PropertyGridItemActionHandler Constructor
Initializes a new instance of the PropertyGridItemActionHandler class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemActionHandler(
    Object object,
    IntPtr method
)
Public Sub New (
    object As Object,
    method As IntPtr
)

Parameters

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.#ctor(System.Object,System.IntPtr)"]

method
Type: SystemIntPtr

[Missing <param name="method"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.#ctor(System.Object,System.IntPtr)"]

See Also

Reference

PropertyGridItemActionHandler Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler Properties

PropertyGridItemActionHandler Properties

The PropertyGridItemActionHandler type exposes the following members.

Properties
 | Name | Description
Public property | Target | (Inherited from Delegate.)
Top
See Also

Reference

PropertyGridItemActionHandler Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler Methods

PropertyGridItemActionHandler Methods

The PropertyGridItemActionHandler type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke |
Public method | DynamicInvoke | (Inherited from Delegate.)
Public method | EndInvoke |
Public method | Equals | (Inherited from MulticastDelegate.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from MulticastDelegate.)
Public method | GetInvocationList | (Inherited from MulticastDelegate.)
Public method | GetType | (Inherited from Object.)
Public method | Invoke |
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridItemActionHandler Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler.BeginInvoke Method

PropertyGridItemActionHandlerBeginInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.BeginInvoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest,System.AsyncCallback,System.Object)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IAsyncResult BeginInvoke(
    PropertyGridItemActionRequest request,
    AsyncCallback callback,
    Object object
)
Public Overridable Function BeginInvoke (
    request As PropertyGridItemActionRequest,
    callback As AsyncCallback,
    object As Object
) As IAsyncResult

Parameters

request
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemActionRequest

[Missing <param name="request"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.BeginInvoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.BeginInvoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest,System.AsyncCallback,System.Object)"]

object
Type: SystemObject

[Missing <param name="object"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.BeginInvoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.BeginInvoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest,System.AsyncCallback,System.Object)"]

See Also

Reference

PropertyGridItemActionHandler Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler.EndInvoke Method

PropertyGridItemActionHandlerEndInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.EndInvoke(System.IAsyncResult)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool EndInvoke(
    IAsyncResult result
)
Public Overridable Function EndInvoke (
    result As IAsyncResult
) As Boolean

Parameters

result
Type: SystemIAsyncResult

[Missing <param name="result"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.EndInvoke(System.IAsyncResult)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.EndInvoke(System.IAsyncResult)"]

See Also

Reference

PropertyGridItemActionHandler Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandler.Invoke Method

PropertyGridItemActionHandlerInvoke Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.Invoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Invoke(
    PropertyGridItemActionRequest request
)
Public Overridable Function Invoke (
    request As PropertyGridItemActionRequest
) As Boolean

Parameters

request
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemActionRequest

[Missing <param name="request"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.Invoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionHandler.Invoke(ActiproSoftware.UI.Xaml.Controls.Grids.PropertyGridItemActionRequest)"]

See Also

Reference

PropertyGridItemActionHandler Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Class

PropertyGridItemActionHandlerDictionary Class
Represents a dictionary of Type to PropertyGridItemActionHandler objects.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary Type, PropertyGridItemActionHandler
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemActionHandlerDictionary

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemActionHandlerDictionary : Dictionary<Type, PropertyGridItemActionHandler>
Public Class PropertyGridItemActionHandlerDictionary
    Inherits Dictionary(Of Type, PropertyGridItemActionHandler)

The PropertyGridItemActionHandlerDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemActionHandlerDictionary | Initializes a new instance of the PropertyGridItemActionHandlerDictionary class
Top
Properties
 | Name | Description
Public property | Comparer | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Count | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Item | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Keys | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Values | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Clear | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsKey | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsValue | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ToString | (Inherited from Object.)
Public method | TryGetValue | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Constructor

PropertyGridItemActionHandlerDictionary Constructor
Initializes a new instance of the PropertyGridItemActionHandlerDictionary class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemActionHandlerDictionary()
Public Sub New
See Also

Reference

PropertyGridItemActionHandlerDictionary Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Properties

PropertyGridItemActionHandlerDictionary Properties

The PropertyGridItemActionHandlerDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Count | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Item | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Keys | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public property | Values | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
See Also

Reference

PropertyGridItemActionHandlerDictionary Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionHandlerDictionary Methods

PropertyGridItemActionHandlerDictionary Methods

The PropertyGridItemActionHandlerDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Clear | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsKey | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ContainsValue | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Public method | ToString | (Inherited from Object.)
Public method | TryGetValue | (Inherited from Dictionary Type, PropertyGridItemActionHandler .)
Top
See Also

Reference

PropertyGridItemActionHandlerDictionary Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest Class

PropertyGridItemActionRequest Class
Stores information about a request for a PropertyGridItemActionHandler.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemActionRequest

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemActionRequest
Public Class PropertyGridItemActionRequest

The PropertyGridItemActionRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemActionRequest | Initializes a new instance of the PropertyGridItemActionRequest class.
Top
Properties
 | Name | Description
Public property | Container | Gets the PropertyGridItem container.
Public property | Element | Gets the FrameworkElement in the container that is the focus of this request.
Public property | Text | Gets the typed text, if any, that triggered the request.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest Constructor

PropertyGridItemActionRequest Constructor
Initializes a new instance of the PropertyGridItemActionRequest class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemActionRequest(
    PropertyGridItem container,
    FrameworkElement element,
    string text
)
Public Sub New (
    container As PropertyGridItem,
    element As FrameworkElement,
    text As String
)

Parameters

container
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItem
The PropertyGridItem container.
element
Type: Windows.UI.XamlFrameworkElement
The FrameworkElement in the container that is the focus of this request.
text
Type: SystemString
The typed text, if any, that triggered the request.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest Properties

PropertyGridItemActionRequest Properties

The PropertyGridItemActionRequest type exposes the following members.

Properties
 | Name | Description
Public property | Container | Gets the PropertyGridItem container.
Public property | Element | Gets the FrameworkElement in the container that is the focus of this request.
Public property | Text | Gets the typed text, if any, that triggered the request.
Top
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest.Container Property

PropertyGridItemActionRequestContainer Property
Gets the PropertyGridItem container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItem Container { get; }
Public ReadOnly Property Container As PropertyGridItem
    Get

Property Value

Type: PropertyGridItem
The PropertyGridItem container.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest.Element Property

PropertyGridItemActionRequestElement Property
Gets the FrameworkElement in the container that is the focus of this request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FrameworkElement Element { get; }
Public ReadOnly Property Element As FrameworkElement
    Get

Property Value

Type: FrameworkElement
The FrameworkElement in the container that is the focus of this request.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest.Text Property

PropertyGridItemActionRequestText Property
Gets the typed text, if any, that triggered the request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The typed text, if any, that triggered the request.
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemActionRequest Methods

PropertyGridItemActionRequest Methods

The PropertyGridItemActionRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridItemActionRequest Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter Class

PropertyGridItemAdapter Class
Provides an abstract base class for a TreeListBoxItemAdapter that can be used in a PropertyGrid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemAdapter
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemAdapter

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemAdapter : TreeListBoxItemAdapter
Public Class PropertyGridItemAdapter
    Inherits TreeListBoxItemAdapter

The PropertyGridItemAdapter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemAdapter | Initializes a new instance of the PropertyGridItemAdapter class.
Top
Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried. (Inherited from TreeListBoxItemAdapter.)
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability. (Inherited from TreeListBoxItemAdapter.)
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states. (Inherited from TreeListBoxItemAdapter.)
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability. (Inherited from TreeListBoxItemAdapter.)
Top
Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items. (Inherited from TreeListBoxItemAdapter.)
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled. (Inherited from TreeListBoxItemAdapter.)
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets active filter conditions. (Inherited from TreeListBoxItemAdapter.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item. (Overrides TreeListBoxItemAdapterGetChildren(TreeListBox, Object).)
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetExpandability | Returns the expandability of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the indent amount of the specified item. (Overrides TreeListBoxItemAdapterGetIndentAmount(TreeListBox, Object, Int32).)
Public method | GetIsDraggable | Returns whether the specified item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditable | Returns whether the specified item is editable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditing | Returns whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsExpanded | Returns whether the specified item is expanded. (Overrides TreeListBoxItemAdapterGetIsExpanded(TreeListBox, Object).)
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelected | Returns whether the specified item is selected. (Overrides TreeListBoxItemAdapterGetIsSelected(TreeListBox, Object).)
Public method | GetPath | Returns the item's string path. (Inherited from TreeListBoxItemAdapter.)
Public method | GetSearchText | Returns the item's text by which to match when searching. (Inherited from TreeListBoxItemAdapter.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeDataObject | Initializes a DataPackage based on the specified items. (Inherited from TreeListBoxItemAdapter.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnDragOverAsync | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDropAsync | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsEditing | Sets whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsExpanded | Sets whether the specified item is expanded. (Overrides TreeListBoxItemAdapterSetIsExpanded(TreeListBox, Object, Boolean).)
Public method | SetIsSelected | Sets whether the specified item is selected. (Overrides TreeListBoxItemAdapterSetIsSelected(TreeListBox, Object, Boolean).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter Constructor

PropertyGridItemAdapter Constructor
Initializes a new instance of the PropertyGridItemAdapter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemAdapter()
Public Sub New
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter Properties

PropertyGridItemAdapter Properties

The PropertyGridItemAdapter type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items. (Inherited from TreeListBoxItemAdapter.)
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried. (Inherited from TreeListBoxItemAdapter.)
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability. (Inherited from TreeListBoxItemAdapter.)
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded. (Inherited from TreeListBoxItemAdapter.)
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected. (Inherited from TreeListBoxItemAdapter.)
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states. (Inherited from TreeListBoxItemAdapter.)
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item. (Inherited from TreeListBoxItemAdapter.)
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability. (Inherited from TreeListBoxItemAdapter.)
Top
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter Methods

PropertyGridItemAdapter Methods

The PropertyGridItemAdapter type exposes the following members.

Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items. (Inherited from TreeListBoxItemAdapter.)
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled. (Inherited from TreeListBoxItemAdapter.)
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets active filter conditions. (Inherited from TreeListBoxItemAdapter.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item. (Overrides TreeListBoxItemAdapterGetChildren(TreeListBox, Object).)
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetExpandability | Returns the expandability of the specified item. (Inherited from TreeListBoxItemAdapter.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the indent amount of the specified item. (Overrides TreeListBoxItemAdapterGetIndentAmount(TreeListBox, Object, Int32).)
Public method | GetIsDraggable | Returns whether the specified item is draggable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditable | Returns whether the specified item is editable. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsEditing | Returns whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsExpanded | Returns whether the specified item is expanded. (Overrides TreeListBoxItemAdapterGetIsExpanded(TreeListBox, Object).)
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected. (Inherited from TreeListBoxItemAdapter.)
Public method | GetIsSelected | Returns whether the specified item is selected. (Overrides TreeListBoxItemAdapterGetIsSelected(TreeListBox, Object).)
Public method | GetPath | Returns the item's string path. (Inherited from TreeListBoxItemAdapter.)
Public method | GetSearchText | Returns the item's text by which to match when searching. (Inherited from TreeListBoxItemAdapter.)
Public method | GetType | (Inherited from Object.)
Public method | InitializeDataObject | Initializes a DataPackage based on the specified items. (Inherited from TreeListBoxItemAdapter.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnDragOverAsync | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback. (Inherited from TreeListBoxItemAdapter.)
Public method | OnDropAsync | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsEditing | Sets whether the specified item is currently being edited. (Inherited from TreeListBoxItemAdapter.)
Public method | SetIsExpanded | Sets whether the specified item is expanded. (Overrides TreeListBoxItemAdapterSetIsExpanded(TreeListBox, Object, Boolean).)
Public method | SetIsSelected | Sets whether the specified item is selected. (Overrides TreeListBoxItemAdapterSetIsSelected(TreeListBox, Object, Boolean).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter.GetChildren Method

PropertyGridItemAdapterGetChildren Method
Returns an IEnumerable that will be used to provide child items for the specified parent item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable GetChildren(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetChildren (
    ownerControl As TreeListBox,
    item As Object
) As IEnumerable

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: IEnumerable
An IEnumerable that will be used to provide child items for the specified parent item.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter.GetIndentAmount Method

PropertyGridItemAdapterGetIndentAmount Method
Returns the indent amount of the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override double GetIndentAmount(
    TreeListBox ownerControl,
    Object item,
    int depth
)
Public Overrides Function GetIndentAmount (
    ownerControl As TreeListBox,
    item As Object,
    depth As Integer
) As Double

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.
depth
Type: SystemInt32
The item depth.

Return Value

Type: Double
The indent amount.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter.GetIsExpanded Method

PropertyGridItemAdapterGetIsExpanded Method
Returns whether the specified item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool GetIsExpanded(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetIsExpanded (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is expanded; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter.GetIsSelected Method

PropertyGridItemAdapterGetIsSelected Method
Returns whether the specified item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool GetIsSelected(
    TreeListBox ownerControl,
    Object item
)
Public Overrides Function GetIsSelected (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is selected; otherwise, false.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter.SetIsExpanded Method

PropertyGridItemAdapterSetIsExpanded Method
Sets whether the specified item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void SetIsExpanded(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overrides Sub SetIsExpanded (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemAdapter.SetIsSelected Method

PropertyGridItemAdapterSetIsSelected Method
Sets whether the specified item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void SetIsSelected(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overrides Sub SetIsSelected (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
See Also

Reference

PropertyGridItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector Class

PropertyGridItemStyleSelector Class
Chooses a Style based on the data object and the data-bound element.
Inheritance Hierarchy
SystemObject
Windows.UI.Xaml.ControlsStyleSelector
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemStyleSelector : StyleSelector
Public Class PropertyGridItemStyleSelector
    Inherits StyleSelector

The PropertyGridItemStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemStyleSelector | Initializes a new instance of the PropertyGridItemStyleSelector class
Top
Properties
 | Name | Description
Public property | CategoryEditorStyle | Gets or sets the Style to use for category editors.
Public property | CategoryStyle | Gets or sets the Style to use for categories.
Public property | PropertyStyle | Gets or sets the Style to use for properties.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectStyle | Returns a specific Style based on custom logic. (Inherited from StyleSelector.)
Protected method | SelectStyleCore | Returns a Style based on custom logic. (Overrides StyleSelectorSelectStyleCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector Constructor

PropertyGridItemStyleSelector Constructor
Initializes a new instance of the PropertyGridItemStyleSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemStyleSelector()
Public Sub New
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector Properties

PropertyGridItemStyleSelector Properties

The PropertyGridItemStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | CategoryEditorStyle | Gets or sets the Style to use for category editors.
Public property | CategoryStyle | Gets or sets the Style to use for categories.
Public property | PropertyStyle | Gets or sets the Style to use for properties.
Top
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector.CategoryEditorStyle Property

PropertyGridItemStyleSelectorCategoryEditorStyle Property
Gets or sets the Style to use for category editors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CategoryEditorStyle { get; set; }
Public Property CategoryEditorStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for category editors.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector.CategoryStyle Property

PropertyGridItemStyleSelectorCategoryStyle Property
Gets or sets the Style to use for categories.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CategoryStyle { get; set; }
Public Property CategoryStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for categories.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector.PropertyStyle Property

PropertyGridItemStyleSelectorPropertyStyle Property
Gets or sets the Style to use for properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style PropertyStyle { get; set; }
Public Property PropertyStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for properties.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector Methods

PropertyGridItemStyleSelector Methods

The PropertyGridItemStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectStyle | Returns a specific Style based on custom logic. (Inherited from StyleSelector.)
Protected method | SelectStyleCore | Returns a Style based on custom logic. (Overrides StyleSelectorSelectStyleCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemStyleSelector.SelectStyleCore Method

PropertyGridItemStyleSelectorSelectStyleCore Method
Returns a Style based on custom logic.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Style SelectStyleCore(
    Object item,
    DependencyObject container
)
Protected Overrides Function SelectStyleCore (
    item As Object,
    container As DependencyObject
) As Style

Parameters

item
Type: SystemObject
The data object.
container
Type: Windows.UI.XamlDependencyObject
The data-bound element.

Return Value

Type: Style
The Style to use.
See Also

Reference

PropertyGridItemStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemTemplateSelector Class

PropertyGridItemTemplateSelector Class
Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGridItem.
Inheritance Hierarchy
SystemObject
Windows.UI.Xaml.ControlsDataTemplateSelector
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemTemplateSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemTemplateSelector : DataTemplateSelector
Public Class PropertyGridItemTemplateSelector
    Inherits DataTemplateSelector

The PropertyGridItemTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemTemplateSelector | Initializes a new instance of the PropertyGridItemTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectTemplate(Object) | Returns a specific DataTemplate for a given item. (Inherited from DataTemplateSelector.)
Public method | SelectTemplate(Object, DependencyObject) | Returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemTemplateSelector Constructor

PropertyGridItemTemplateSelector Constructor
Initializes a new instance of the PropertyGridItemTemplateSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemTemplateSelector()
Public Sub New
See Also

Reference

PropertyGridItemTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemTemplateSelector Methods

PropertyGridItemTemplateSelector Methods

The PropertyGridItemTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectTemplate(Object) | Returns a specific DataTemplate for a given item. (Inherited from DataTemplateSelector.)
Public method | SelectTemplate(Object, DependencyObject) | Returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridItemTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemTemplateSelector.SelectTemplateCore Method

PropertyGridItemTemplateSelectorSelectTemplateCore Method
Overload List
 | Name | Description
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridItemTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridItemTemplateSelector.SelectTemplateCore Method (Object, DependencyObject)

PropertyGridItemTemplateSelectorSelectTemplateCore Method (Object, DependencyObject)
Returns a DataTemplate based on custom logic.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate SelectTemplateCore(
    Object item,
    DependencyObject container
)
Protected Overrides Function SelectTemplateCore (
    item As Object,
    container As DependencyObject
) As DataTemplate

Parameters

item
Type: SystemObject
The data object.
container
Type: Windows.UI.XamlDependencyObject
The data-bound element.

Return Value

Type: DataTemplate
The DataTemplate to use.
See Also

Reference

PropertyGridItemTemplateSelector Class
SelectTemplateCore Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridNameTemplateSelector Class

PropertyGridNameTemplateSelector Class
Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid name cell.
Inheritance Hierarchy
SystemObject
Windows.UI.Xaml.ControlsDataTemplateSelector
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridNameTemplateSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridNameTemplateSelector : DataTemplateSelector
Public Class PropertyGridNameTemplateSelector
    Inherits DataTemplateSelector

The PropertyGridNameTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridNameTemplateSelector | Initializes a new instance of the PropertyGridNameTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectTemplate(Object) | Returns a specific DataTemplate for a given item. (Inherited from DataTemplateSelector.)
Public method | SelectTemplate(Object, DependencyObject) | Returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridNameTemplateSelector Constructor

PropertyGridNameTemplateSelector Constructor
Initializes a new instance of the PropertyGridNameTemplateSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridNameTemplateSelector()
Public Sub New
See Also

Reference

PropertyGridNameTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridNameTemplateSelector Methods

PropertyGridNameTemplateSelector Methods

The PropertyGridNameTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectTemplate(Object) | Returns a specific DataTemplate for a given item. (Inherited from DataTemplateSelector.)
Public method | SelectTemplate(Object, DependencyObject) | Returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridNameTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridNameTemplateSelector.SelectTemplateCore Method

PropertyGridNameTemplateSelectorSelectTemplateCore Method
Overload List
 | Name | Description
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridNameTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridNameTemplateSelector.SelectTemplateCore Method (Object, DependencyObject)

PropertyGridNameTemplateSelectorSelectTemplateCore Method (Object, DependencyObject)
Returns a DataTemplate based on custom logic.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate SelectTemplateCore(
    Object item,
    DependencyObject container
)
Protected Overrides Function SelectTemplateCore (
    item As Object,
    container As DependencyObject
) As DataTemplate

Parameters

item
Type: SystemObject
The data object.
container
Type: Windows.UI.XamlDependencyObject
The data-bound element.

Return Value

Type: DataTemplate
The DataTemplate to use.
See Also

Reference

PropertyGridNameTemplateSelector Class
SelectTemplateCore Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridValueTemplateSelector Class

PropertyGridValueTemplateSelector Class
Chooses a DataTemplate based on the data object and the data-bound element for a PropertyGrid value cell.
Inheritance Hierarchy
SystemObject
Windows.UI.Xaml.ControlsDataTemplateSelector
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridValueTemplateSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridValueTemplateSelector : DataTemplateSelector
Public Class PropertyGridValueTemplateSelector
    Inherits DataTemplateSelector

The PropertyGridValueTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridValueTemplateSelector | Initializes a new instance of the PropertyGridValueTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetDefaultTemplate | Returns a default DataTemplate from the specified PropertyGrid.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectTemplate(Object) | Returns a specific DataTemplate for a given item. (Inherited from DataTemplateSelector.)
Public method | SelectTemplate(Object, DependencyObject) | Returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridValueTemplateSelector Constructor

PropertyGridValueTemplateSelector Constructor
Initializes a new instance of the PropertyGridValueTemplateSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridValueTemplateSelector()
Public Sub New
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridValueTemplateSelector Methods

PropertyGridValueTemplateSelector Methods

The PropertyGridValueTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetDefaultTemplate | Returns a default DataTemplate from the specified PropertyGrid.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectTemplate(Object) | Returns a specific DataTemplate for a given item. (Inherited from DataTemplateSelector.)
Public method | SelectTemplate(Object, DependencyObject) | Returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridValueTemplateSelector.GetDefaultTemplate Method

PropertyGridValueTemplateSelectorGetDefaultTemplate Method
Returns a default DataTemplate from the specified PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DataTemplate GetDefaultTemplate(
    PropertyGrid propGrid,
    DefaultValueTemplateKind kind
)
Protected Function GetDefaultTemplate (
    propGrid As PropertyGrid,
    kind As DefaultValueTemplateKind
) As DataTemplate

Parameters

propGrid
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyGrid
The PropertyGrid to examine.
kind
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsDefaultValueTemplateKind
The kind of default template to return.

Return Value

Type: DataTemplate
A default DataTemplate from the specified PropertyGrid.
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridValueTemplateSelector.SelectTemplateCore Method

PropertyGridValueTemplateSelectorSelectTemplateCore Method
Overload List
 | Name | Description
Protected method | SelectTemplateCore(Object) | When implemented by a derived class, returns a specific DataTemplate for a given item or container. (Inherited from DataTemplateSelector.)
Protected method | SelectTemplateCore(Object, DependencyObject) | Returns a DataTemplate based on custom logic. (Overrides DataTemplateSelectorSelectTemplateCore(Object, DependencyObject).)
Top
See Also

Reference

PropertyGridValueTemplateSelector Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyGridValueTemplateSelector.SelectTemplateCore Method (Object, DependencyObject)

PropertyGridValueTemplateSelectorSelectTemplateCore Method (Object, DependencyObject)
Returns a DataTemplate based on custom logic.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate SelectTemplateCore(
    Object item,
    DependencyObject container
)
Protected Overrides Function SelectTemplateCore (
    item As Object,
    container As DependencyObject
) As DataTemplate

Parameters

item
Type: SystemObject
The data object.
container
Type: Windows.UI.XamlDependencyObject
The data-bound element.

Return Value

Type: DataTemplate
The DataTemplate to use.
See Also

Reference

PropertyGridValueTemplateSelector Class
SelectTemplateCore Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Class

PropertyModelChildChangeEventArgs Class
Provides event arguments for IPropertyModel child change events, such as when a child item is added to or removed from a collection.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyModelChildChangeEventArgs : CancelableEventArgs
Public Class PropertyModelChildChangeEventArgs
    Inherits CancelableEventArgs

The PropertyModelChildChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, IPropertyModel) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, Object) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | ChildPropertyModel | Gets the IPropertyModel for the child being added to or removed from the parent, if known.
Public property | ChildValue | Gets or sets the child value.
Public property | ParentPropertyModel | Gets the IPropertyModel for the parent.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Constructor

PropertyModelChildChangeEventArgs Constructor
Overload List
 | Name | Description
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, IPropertyModel) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Public method | PropertyModelChildChangeEventArgs(IPropertyModel, Object) | Initializes a new instance of the PropertyModelChildChangeEventArgs class.
Top
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Constructor (IPropertyModel, IPropertyModel)

PropertyModelChildChangeEventArgs Constructor (IPropertyModel, IPropertyModel)
Initializes a new instance of the PropertyModelChildChangeEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelChildChangeEventArgs(
    IPropertyModel parentPropertyModel,
    IPropertyModel childPropertyModel
)
Public Sub New (
    parentPropertyModel As IPropertyModel,
    childPropertyModel As IPropertyModel
)

Parameters

parentPropertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the parent.
childPropertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the child being added to or removed from the parent, if known.
See Also

Reference

PropertyModelChildChangeEventArgs Class
PropertyModelChildChangeEventArgs Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Constructor (IPropertyModel, Object)

PropertyModelChildChangeEventArgs Constructor (IPropertyModel, Object)
Initializes a new instance of the PropertyModelChildChangeEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelChildChangeEventArgs(
    IPropertyModel parentPropertyModel,
    Object childValue
)
Public Sub New (
    parentPropertyModel As IPropertyModel,
    childValue As Object
)

Parameters

parentPropertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the parent.
childValue
Type: SystemObject
The child value.
See Also

Reference

PropertyModelChildChangeEventArgs Class
PropertyModelChildChangeEventArgs Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Properties

PropertyModelChildChangeEventArgs Properties

The PropertyModelChildChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | ChildPropertyModel | Gets the IPropertyModel for the child being added to or removed from the parent, if known.
Public property | ChildValue | Gets or sets the child value.
Public property | ParentPropertyModel | Gets the IPropertyModel for the parent.
Top
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs.ChildPropertyModel Property

PropertyModelChildChangeEventArgsChildPropertyModel Property
Gets the IPropertyModel for the child being added to or removed from the parent, if known.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPropertyModel ChildPropertyModel { get; }
Public ReadOnly Property ChildPropertyModel As IPropertyModel
    Get

Property Value

Type: IPropertyModel
The IPropertyModel for the child being added to or removed from the parent, if known.
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs.ChildValue Property

PropertyModelChildChangeEventArgsChildValue Property
Gets or sets the child value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ChildValue { get; set; }
Public Property ChildValue As Object
    Get
    Set

Property Value

Type: Object
The child value.
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs.ParentPropertyModel Property

PropertyModelChildChangeEventArgsParentPropertyModel Property
Gets the IPropertyModel for the parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPropertyModel ParentPropertyModel { get; }
Public ReadOnly Property ParentPropertyModel As IPropertyModel
    Get

Property Value

Type: IPropertyModel
The IPropertyModel for the parent.
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelChildChangeEventArgs Methods

PropertyModelChildChangeEventArgs Methods

The PropertyModelChildChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyModelChildChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Class

PropertyModelValueChangeEventArgs Class
Provides event arguments for IPropertyModel value change events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyModelValueChangeEventArgs : CancelableEventArgs
Public Class PropertyModelValueChangeEventArgs
    Inherits CancelableEventArgs

The PropertyModelValueChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelValueChangeEventArgs | Initializes a new instance of the PropertyModelValueChangeEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | PropertyModel | Gets the IPropertyModel for the property whose value is being updated.
Public property | Value | Gets the updated property value.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Constructor

PropertyModelValueChangeEventArgs Constructor
Initializes a new instance of the PropertyModelValueChangeEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelValueChangeEventArgs(
    IPropertyModel propertyModel,
    Object value
)
Public Sub New (
    propertyModel As IPropertyModel,
    value As Object
)

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel for the property whose value is being updated.
value
Type: SystemObject
The updated property value.
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Properties

PropertyModelValueChangeEventArgs Properties

The PropertyModelValueChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | PropertyModel | Gets the IPropertyModel for the property whose value is being updated.
Public property | Value | Gets the updated property value.
Top
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelValueChangeEventArgs.PropertyModel Property

PropertyModelValueChangeEventArgsPropertyModel Property
Gets the IPropertyModel for the property whose value is being updated.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPropertyModel PropertyModel { get; }
Public ReadOnly Property PropertyModel As IPropertyModel
    Get

Property Value

Type: IPropertyModel
The IPropertyModel for the property whose value is being updated.
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelValueChangeEventArgs.Value Property

PropertyModelValueChangeEventArgsValue Property
Gets the updated property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Value { get; }
Public ReadOnly Property Value As Object
    Get

Property Value

Type: Object
The updated property value.
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


PropertyModelValueChangeEventArgs Methods

PropertyModelValueChangeEventArgs Methods

The PropertyModelValueChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyModelValueChangeEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind Class

TreeExpansionKind Class
Specifies the kind of expand or collapse.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeExpansionKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeExpansionKind : Enum
Public NotInheritable Class TreeExpansionKind
    Inherits Enum

The TreeExpansionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | All items are recursively affected.
 | Branch | A branch of items are recursively affected.
 | Single | A single item is affected.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind Methods

TreeExpansionKind Methods

The TreeExpansionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeExpansionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind Fields

TreeExpansionKind Fields

The TreeExpansionKind type exposes the following members.

Fields
 | Name | Description
 | All | All items are recursively affected.
 | Branch | A branch of items are recursively affected.
 | Single | A single item is affected.
Public field | value__ |
Top
See Also

Reference

TreeExpansionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind.All Field

TreeExpansionKindAll Field
All items are recursively affected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeExpansionKind All = 2
Public Const All As TreeExpansionKind = 2

Field Value

Type: TreeExpansionKind
See Also

Reference

TreeExpansionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind.Branch Field

TreeExpansionKindBranch Field
A branch of items are recursively affected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeExpansionKind Branch = 1
Public Const Branch As TreeExpansionKind = 1

Field Value

Type: TreeExpansionKind
See Also

Reference

TreeExpansionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind.Single Field

TreeExpansionKindSingle Field
A single item is affected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeExpansionKind Single = 0
Public Const Single As TreeExpansionKind = 0

Field Value

Type: TreeExpansionKind
See Also

Reference

TreeExpansionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeExpansionKind.value__ Field

TreeExpansionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeExpansionKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeExpansionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemChildrenQueryMode Class

TreeItemChildrenQueryMode Class
Specifies the mode by which a tree item's children are queried.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeItemChildrenQueryMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeItemChildrenQueryMode : Enum
Public NotInheritable Class TreeItemChildrenQueryMode
    Inherits Enum

The TreeItemChildrenQueryMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | OnDisplay | Query the item's children when all of the item's ancestors are expanded. The item is only expandable if there is at least one child item.
 | OnExpansion | The item is only expandable by default. When the item is expanded, query the item's children, and disable expandability if there are no child items.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemChildrenQueryMode Methods

TreeItemChildrenQueryMode Methods

The TreeItemChildrenQueryMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeItemChildrenQueryMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemChildrenQueryMode Fields

TreeItemChildrenQueryMode Fields

The TreeItemChildrenQueryMode type exposes the following members.

Fields
 | Name | Description
 | OnDisplay | Query the item's children when all of the item's ancestors are expanded. The item is only expandable if there is at least one child item.
 | OnExpansion | The item is only expandable by default. When the item is expanded, query the item's children, and disable expandability if there are no child items.
Public field | value__ |
Top
See Also

Reference

TreeItemChildrenQueryMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemChildrenQueryMode.OnDisplay Field

TreeItemChildrenQueryModeOnDisplay Field
Query the item's children when all of the item's ancestors are expanded. The item is only expandable if there is at least one child item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemChildrenQueryMode OnDisplay = 0
Public Const OnDisplay As TreeItemChildrenQueryMode = 0

Field Value

Type: TreeItemChildrenQueryMode
See Also

Reference

TreeItemChildrenQueryMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemChildrenQueryMode.OnExpansion Field

TreeItemChildrenQueryModeOnExpansion Field
The item is only expandable by default. When the item is expanded, query the item's children, and disable expandability if there are no child items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemChildrenQueryMode OnExpansion = 1
Public Const OnExpansion As TreeItemChildrenQueryMode = 1

Field Value

Type: TreeItemChildrenQueryMode
See Also

Reference

TreeItemChildrenQueryMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemChildrenQueryMode.value__ Field

TreeItemChildrenQueryModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeItemChildrenQueryMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeItemChildrenQueryMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea Class

TreeItemDropArea Class
Specifies a drop area when a drag is over a target item.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeItemDropArea

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeItemDropArea : Enum
Public NotInheritable Class TreeItemDropArea
    Inherits Enum

The TreeItemDropArea type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | After | The drag is over the bottom portion of the target item, hinting to to insert after the target item.
 | Before | The drag is over the top portion of the target item, hinting to to insert before the target item.
 | None | The drag is not over a target item.
 | On | The drag is directly over the target item, hinting to insert into the target item.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea Methods

TreeItemDropArea Methods

The TreeItemDropArea type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea Fields

TreeItemDropArea Fields

The TreeItemDropArea type exposes the following members.

Fields
 | Name | Description
 | After | The drag is over the bottom portion of the target item, hinting to to insert after the target item.
 | Before | The drag is over the top portion of the target item, hinting to to insert before the target item.
 | None | The drag is not over a target item.
 | On | The drag is directly over the target item, hinting to insert into the target item.
Public field | value__ |
Top
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea.After Field

TreeItemDropAreaAfter Field
The drag is over the bottom portion of the target item, hinting to to insert after the target item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemDropArea After = 3
Public Const After As TreeItemDropArea = 3

Field Value

Type: TreeItemDropArea
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea.Before Field

TreeItemDropAreaBefore Field
The drag is over the top portion of the target item, hinting to to insert before the target item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemDropArea Before = 1
Public Const Before As TreeItemDropArea = 1

Field Value

Type: TreeItemDropArea
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea.None Field

TreeItemDropAreaNone Field
The drag is not over a target item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemDropArea None = 0
Public Const None As TreeItemDropArea = 0

Field Value

Type: TreeItemDropArea
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea.On Field

TreeItemDropAreaOn Field
The drag is directly over the target item, hinting to insert into the target item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemDropArea On = 2
Public Const On As TreeItemDropArea = 2

Field Value

Type: TreeItemDropArea
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemDropArea.value__ Field

TreeItemDropAreavalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeItemDropArea.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeItemDropArea Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemExpandability Class

TreeItemExpandability Class
Specifies a tree item's support for expansion toggling.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeItemExpandability

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeItemExpandability : Enum
Public NotInheritable Class TreeItemExpandability
    Inherits Enum

The TreeItemExpandability type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Auto | Logic is used to determine whether the item supports expansion toggling.
 | Never | The item doesn't support expansion toggling.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemExpandability Methods

TreeItemExpandability Methods

The TreeItemExpandability type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeItemExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemExpandability Fields

TreeItemExpandability Fields

The TreeItemExpandability type exposes the following members.

Fields
 | Name | Description
 | Auto | Logic is used to determine whether the item supports expansion toggling.
 | Never | The item doesn't support expansion toggling.
Public field | value__ |
Top
See Also

Reference

TreeItemExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemExpandability.Auto Field

TreeItemExpandabilityAuto Field
Logic is used to determine whether the item supports expansion toggling.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemExpandability Auto = 0
Public Const Auto As TreeItemExpandability = 0

Field Value

Type: TreeItemExpandability
See Also

Reference

TreeItemExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemExpandability.Never Field

TreeItemExpandabilityNever Field
The item doesn't support expansion toggling.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeItemExpandability Never = 1
Public Const Never As TreeItemExpandability = 1

Field Value

Type: TreeItemExpandability
See Also

Reference

TreeItemExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeItemExpandability.value__ Field

TreeItemExpandabilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeItemExpandability.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeItemExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox Class

TreeListBox Class
Represents an advanced single-column tree view control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
ActiproSoftware.UI.Xaml.Controls.GridsTreeListView

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListBox : ItemsControl
Public Class TreeListBox
    Inherits ItemsControl

The TreeListBox type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBox | Initializes an instance of the TreeListBox class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc.
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved.
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RootItem | Gets or sets the root item to display in the control.
Public property | SelectedItem | Gets or sets the primary selected item.
Public property | SelectedItems | Gets the collection of selected items.
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | BringItemIntoView | Brings the specified node's container into view.
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed.
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed.
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemByFullPath | Returns the item with the specified full path.
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried.
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides ControlOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides ControlOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides ControlOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides ControlOnDrop(DragEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed.
Protected method | OnItemCollapsing | Occurs before an item is collapsed.
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Protected method | OnItemExpanded | Occurs after an item is expanded.
Protected method | OnItemExpanding | Occurs before an item is expanded.
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu.
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected.
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs when the RootItem property is changed.
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed.
Protected method | OnSelectionChanged | Occurs when the selection is changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | ItemCollapsed | Occurs after an item is collapsed.
Public event | ItemCollapsing | Occurs before an item is collapsed.
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Public event | ItemExpanded | Occurs after an item is expanded.
Public event | ItemExpanding | Occurs before an item is expanded.
Public event | ItemMenuRequested | Occurs when an item requests a context menu.
Public event | ItemSelecting | Occurs before an item is selected.
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | RootItemChanged | Occurs when the RootItem property is changed.
Public event | SelectionChanged | Occurs when the selection is changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AutoExpandItemsOnFilterProperty | Identifies the AutoExpandItemsOnFilter dependency property. This field is read-only.
CanDragItemsProperty | Identifies the CanDragItems dependency property. This field is read-only.
DataFilterProperty | Identifies the DataFilter dependency property. This field is read-only.
IndentIncrementProperty | Identifies the IndentIncrement dependency property. This field is read-only.
IsDataVirtualizationEnabledProperty | Identifies the IsDataVirtualizationEnabled dependency property. This field is read-only.
IsFilterActiveProperty | Identifies the IsFilterActive dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
IsRootItemVisibleProperty | Identifies the IsRootItemVisible dependency property. This field is read-only.
ItemAdapterProperty | Identifies the ItemAdapter dependency property. This field is read-only.
ItemDataFormat | Specifies the data format to use for item data.
MultiDragKindProperty | Identifies the MultiDragKind dependency property. This field is read-only.
MultiSelectionKindProperty | Identifies the MultiSelectionKind dependency property. This field is read-only.
PathSeparatorProperty | Identifies the PathSeparator dependency property. This field is read-only.
RootItemProperty | Identifies the RootItem dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TopLevelIndentProperty | Identifies the TopLevelIndent dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox Constructor

TreeListBox Constructor
Initializes an instance of the TreeListBox class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBox()
Public Sub New
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox Properties

TreeListBox Properties

The TreeListBox type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc.
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved.
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RootItem | Gets or sets the root item to display in the control.
Public property | SelectedItem | Gets or sets the primary selected item.
Public property | SelectedItems | Gets the collection of selected items.
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.AutoExpandItemsOnFilter Property

TreeListBoxAutoExpandItemsOnFilter Property
Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AutoExpandItemsOnFilter { get; set; }
Public Property AutoExpandItemsOnFilter As Boolean
    Get
    Set

Property Value

Type: Boolean
true if items that are included by a filter will be made visible; otherwise, false. The default value is false.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.CanDragItems Property

TreeListBoxCanDragItems Property
Gets or sets whether to allow dragging of selected items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanDragItems { get; set; }
Public Property CanDragItems As Boolean
    Get
    Set

Property Value

Type: Boolean
true if dragging of selected items is allowed; otherwise, false.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.DataFilter Property

TreeListBoxDataFilter Property
Gets or sets the IDataFilter to use when IsFilterActive is true.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataFilter DataFilter { get; set; }
Public Property DataFilter As IDataFilter
    Get
    Set

Property Value

Type: IDataFilter
The IDataFilter to use when IsFilterActive is true.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IndentIncrement Property

TreeListBoxIndentIncrement Property
Gets or sets the incremental amount by which to indent an item for each depth level.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double IndentIncrement { get; set; }
Public Property IndentIncrement As Double
    Get
    Set

Property Value

Type: Double
The incremental amount by which to indent an item for each depth level. The default value is 20.0.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsDataVirtualizationEnabled Property

TreeListBoxIsDataVirtualizationEnabled Property
Gets or sets whether data virtualization is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDataVirtualizationEnabled { get; set; }
Public Property IsDataVirtualizationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if data virtualization is enabled; otherwise, false. The default value is false.
Remarks
Only set this property to true when using virtualized collections that implement IList. In most scenarios, this data virtualization feature is not needed since UI virtualization is always active in the control.

When the data virtualization feature is enabled, as a query for child items is made, an ITreeItemVirtualPlaceholder will be created for each child item. The only property initially touched on the virtualized collection is Count. Then when an item's UI container is first requested, the ITreeItemVirtualPlaceholder will be used to call into the virtualized collection's indexer and retrieve the real item. This allows for virtualized data retrieval of paged sections as needed, instead of the entire collection at once.

See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsFilterActive Property

TreeListBoxIsFilterActive Property
Gets or sets whether a filter is currently active.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsFilterActive { get; set; }
Public Property IsFilterActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a filter is currently active; otherwise, false. The default value is false.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsKeyboardFocusWithin Property

TreeListBoxIsKeyboardFocusWithin Property
Gets whether keyboard focus is within the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsKeyboardFocusWithin { get; }
Public ReadOnly Property IsKeyboardFocusWithin As Boolean
    Get

Property Value

Type: Boolean
true if keyboard focus is within the control; otherwise, false.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsRootItemVisible Property

TreeListBoxIsRootItemVisible Property
Gets or sets whether the RootItem is visible, or whether its children are the top-level node items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsRootItemVisible { get; set; }
Public Property IsRootItemVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the RootItem is the sole top-level node item; otherwise, false. The default value is false.
Remarks
When true, the RootItem itself will be the sole top-level node item. When false, the RootItem's children will be the top-level node items.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemAdapter Property

TreeListBoxItemAdapter Property
Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItemAdapter ItemAdapter { get; set; }
Public Property ItemAdapter As TreeListBoxItemAdapter
    Get
    Set

Property Value

Type: TreeListBoxItemAdapter
The TreeListBoxItemAdapter that adapts items with the UI.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.MultiDragKind Property

TreeListBoxMultiDragKind Property
Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeMultiDragKind MultiDragKind { get; set; }
Public Property MultiDragKind As TreeMultiDragKind
    Get
    Set

Property Value

Type: TreeMultiDragKind
A TreeMultiDragKind that indicates the dragging support when multiple items are involved. The default value is None, meaning only single item selections can be dragged when CanDragItems is true.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.MultiSelectionKind Property

TreeListBoxMultiSelectionKind Property
Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeMultiSelectionKind MultiSelectionKind { get; set; }
Public Property MultiSelectionKind As TreeMultiSelectionKind
    Get
    Set

Property Value

Type: TreeMultiSelectionKind
A TreeMultiSelectionKind that indicates the selection support when multiple items are involved. The default value is Any.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.PathSeparator Property

TreeListBoxPathSeparator Property
Gets or sets the delimiter string that the tree item full path uses.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string PathSeparator { get; set; }
Public Property PathSeparator As String
    Get
    Set

Property Value

Type: String
The delimiter string that the tree item full path uses. The default value is \.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.RootItem Property

TreeListBoxRootItem Property
Gets or sets the root item to display in the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object RootItem { get; set; }
Public Property RootItem As Object
    Get
    Set

Property Value

Type: Object
The root item to display in the control.
Remarks
Set this property instead of ItemsSource.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectedItem Property

TreeListBoxSelectedItem Property
Gets or sets the primary selected item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object SelectedItem { get; set; }
Public Property SelectedItem As Object
    Get
    Set

Property Value

Type: Object
The primary selected item.
Remarks
This property's setter can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectedItems Property

TreeListBoxSelectedItems Property
Gets the collection of selected items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISelectedTreeItemCollection SelectedItems { get; }
Public ReadOnly Property SelectedItems As ISelectedTreeItemCollection
    Get

Property Value

Type: ISelectedTreeItemCollection
The collection of selected items.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectionMode Property

TreeListBoxSelectionMode Property
Gets or sets a SelectionMode that indicates the selection behavior.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectionMode SelectionMode { get; set; }
Public Property SelectionMode As SelectionMode
    Get
    Set

Property Value

Type: SelectionMode
A SelectionMode that indicates the selection behavior. The default value is Single.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.TopLevelIndent Property

TreeListBoxTopLevelIndent Property
Gets or sets the amount by which to indent a top-level item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double TopLevelIndent { get; set; }
Public Property TopLevelIndent As Double
    Get
    Set

Property Value

Type: Double
The incremental amount by which to indent a top-level item. The default value is 20.0.
Remarks
When top-level items aren't expandable, set this property to 0 to reclaim the space that would have been used by the expander.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox Methods

TreeListBox Methods

The TreeListBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | BringItemIntoView | Brings the specified node's container into view.
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Overrides ItemsControlClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed.
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed.
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ItemsControlGetContainerForItemOverride.)
Public method | GetFullPath | Returns the full path of the specified item.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemByFullPath | Returns the item with the specified full path.
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried.
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides ItemsControlIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides ControlOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides ControlOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides ControlOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides ControlOnDrop(DragEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed.
Protected method | OnItemCollapsing | Occurs before an item is collapsed.
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Protected method | OnItemExpanded | Occurs after an item is expanded.
Protected method | OnItemExpanding | Occurs before an item is expanded.
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu.
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected.
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs when the RootItem property is changed.
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed.
Protected method | OnSelectionChanged | Occurs when the selection is changed.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControlPrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ArrangeOverride Method

TreeListBoxArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ArrangeOverride Method (Size)

TreeListBoxArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListBox Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.BringItemIntoView Method

TreeListBoxBringItemIntoView Method
Brings the specified node's container into view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BringItemIntoView(
    Object item
)
Public Function BringItemIntoView (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The node whose container needs to scroll into view.

Return Value

Type: Boolean
true if the node's container was brought into view; otherwise, false.
Remarks
This method can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node. For that case, it is recommended to use the BringItemIntoViewByFullPath(String) method that searches by full path instead, since that can be much faster.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.BringItemIntoViewByFullPath Method

TreeListBoxBringItemIntoViewByFullPath Method
Brings the container for the item with the specified full path into view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool BringItemIntoViewByFullPath(
    string fullPath
)
Public Function BringItemIntoViewByFullPath (
    fullPath As String
) As Boolean

Parameters

fullPath
Type: SystemString
The full path to the item whose container needs to scroll into view.

Return Value

Type: Boolean
true if the item's container was brought into view; otherwise, false.
Remarks
This method requires that the ItemAdapter supplies a path for each item.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ClearContainerForItemOverride Method

TreeListBoxClearContainerForItemOverride Method
Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub ClearContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.FocusItem Method

TreeListBoxFocusItem Method
Focuses the container for the specified node, scrolling it into view as needed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void FocusItem(
    Object item
)
Public Sub FocusItem (
    item As Object
)

Parameters

item
Type: SystemObject
The node whose container should be focused.
Remarks
This method can be a bottleneck in very large trees where the specified node hasn't yet been exposed to the control by its ancestor nodes all being expanded. In that scenario, a full tree search is required to locate the node. For that case, it is recommended to use the FocusItemByFullPath(String) method that searches by full path instead, since that can be much faster.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.FocusItemByFullPath Method

TreeListBoxFocusItemByFullPath Method
Focuses the container for the node with the specified full path, scrolling it into view as needed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void FocusItemByFullPath(
    string fullPath
)
Public Sub FocusItemByFullPath (
    fullPath As String
)

Parameters

fullPath
Type: SystemString
The full path to the node whose container should be focused.
Remarks
This method requires that the ItemAdapter supplies a path for each item.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.GetContainerForItemOverride Method

TreeListBoxGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.GetFullPath Method

TreeListBoxGetFullPath Method
Returns the full path of the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string GetFullPath(
    Object item
)
Public Function GetFullPath (
    item As Object
) As String

Parameters

item
Type: SystemObject
The item to examine.

Return Value

Type: String
The full path of the specified item.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.GetItemByFullPath Method

TreeListBoxGetItemByFullPath Method
Returns the item with the specified full path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object GetItemByFullPath(
    string fullPath
)
Public Function GetItemByFullPath (
    fullPath As String
) As Object

Parameters

fullPath
Type: SystemString
The full path to the item.

Return Value

Type: Object
The item with the specified full path.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.GetItemNavigator Method

TreeListBoxGetItemNavigator Method
Returns the ITreeItemNavigator for the specified item, if the item is a visible item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITreeItemNavigator GetItemNavigator(
    Object item
)
Public Function GetItemNavigator (
    item As Object
) As ITreeItemNavigator

Parameters

item
Type: SystemObject
The visible item to examine.

Return Value

Type: ITreeItemNavigator
The ITreeItemNavigator for the specified item, if the item is a visible item.
Remarks
This navigator can be used to navigate the item tree. No navigator will be returned if the item is not a visible item in this control.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.InvalidateChildren Method

TreeListBoxInvalidateChildren Method
Invalidates the children of the specified item, allowing the children to be requeried.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void InvalidateChildren(
    Object item
)
Public Sub InvalidateChildren (
    item As Object
)

Parameters

item
Type: SystemObject
The item to examine.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsItemItsOwnContainerOverride Method

TreeListBoxIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnApplyTemplate Method

TreeListBoxOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnDragEnter Method

TreeListBoxOnDragEnter Method
Occurs when an object is dragged inside of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs e
)
Protected Overrides Sub OnDragEnter (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnDragLeave Method

TreeListBoxOnDragLeave Method
Occurs when an object is dragged outside of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDragLeave(
    DragEventArgs e
)
Protected Overrides Sub OnDragLeave (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnDragOver Method

TreeListBoxOnDragOver Method
Occurs when an object is dragged over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDragOver(
    DragEventArgs e
)
Protected Overrides Sub OnDragOver (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnDrop Method

TreeListBoxOnDrop Method
Occurs when an object is dropped over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDrop(
    DragEventArgs e
)
Protected Overrides Sub OnDrop (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnGotFocus Method

TreeListBoxOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemCollapsed Method

TreeListBoxOnItemCollapsed Method
Occurs after an item is collapsed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemCollapsed(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemCollapsed (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemCollapsing Method

TreeListBoxOnItemCollapsing Method
Occurs before an item is collapsed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemCollapsing(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemCollapsing (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemDefaultActionExecuting Method

TreeListBoxOnItemDefaultActionExecuting Method
Occurs before the default action is executed for an item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemDefaultActionExecuting(
    TreeListBoxItemEventArgs e
)
Protected Overridable Sub OnItemDefaultActionExecuting (
    e As TreeListBoxItemEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemEventArgs
The TreeListBoxItemEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemExpanded Method

TreeListBoxOnItemExpanded Method
Occurs after an item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemExpanded(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemExpanded (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemExpanding Method

TreeListBoxOnItemExpanding Method
Occurs before an item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemExpanding(
    TreeListBoxItemExpansionEventArgs e
)
Protected Overridable Sub OnItemExpanding (
    e As TreeListBoxItemExpansionEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemExpansionEventArgs
The TreeListBoxItemExpansionEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemMenuRequested Method

TreeListBoxOnItemMenuRequested Method
Occurs when an item requests a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemMenuRequested(
    TreeListBoxItemMenuEventArgs e
)
Protected Overridable Sub OnItemMenuRequested (
    e As TreeListBoxItemMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemMenuEventArgs
The TreeListBoxItemMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnItemSelecting Method

TreeListBoxOnItemSelecting Method
Occurs before an item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemSelecting(
    TreeListBoxItemEventArgs e
)
Protected Overridable Sub OnItemSelecting (
    e As TreeListBoxItemEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemEventArgs
The TreeListBoxItemEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnLostFocus Method

TreeListBoxOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnRootItemChanged Method

TreeListBoxOnRootItemChanged Method
Occurs when the RootItem property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnRootItemChanged(
    RoutedEventArgs e
)
Protected Overridable Sub OnRootItemChanged (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnScrollViewerScrollChanged Method

TreeListBoxOnScrollViewerScrollChanged Method
Occurs when the scroll viewer's scroll is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnScrollViewerScrollChanged(
    ScrollViewerViewChangedEventArgs e
)
Protected Overridable Sub OnScrollViewerScrollChanged (
    e As ScrollViewerViewChangedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.ControlsScrollViewerViewChangedEventArgs
The ScrollViewerViewChangedEventArgs that contains data related to the event.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.OnSelectionChanged Method

TreeListBoxOnSelectionChanged Method
Occurs when the selection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSelectionChanged(
    SelectionChangedEventArgs e
)
Protected Overridable Sub OnSelectionChanged (
    e As SelectionChangedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.ControlsSelectionChangedEventArgs
The SelectionChangedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.PrepareContainerForItemOverride Method

TreeListBoxPrepareContainerForItemOverride Method
Prepares the specified element to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Protected Overrides Sub PrepareContainerForItemOverride (
    element As DependencyObject,
    item As Object
)

Parameters

element
Type: Windows.UI.XamlDependencyObject
The DependencyObject that is the wrapper element.
item
Type: SystemObject
The item that is being wrapped.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectItemByFullPath Method

TreeListBoxSelectItemByFullPath Method
Sets the SelectedItem to the node with the specified full path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SelectItemByFullPath(
    string fullPath
)
Public Sub SelectItemByFullPath (
    fullPath As String
)

Parameters

fullPath
Type: SystemString
The full path to the node whose container should be selected.
Remarks
This method requires that the ItemAdapter supplies a path for each item.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox Events

TreeListBox Events

The TreeListBox type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | ItemCollapsed | Occurs after an item is collapsed.
Public event | ItemCollapsing | Occurs before an item is collapsed.
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item.
Public event | ItemExpanded | Occurs after an item is expanded.
Public event | ItemExpanding | Occurs before an item is expanded.
Public event | ItemMenuRequested | Occurs when an item requests a context menu.
Public event | ItemSelecting | Occurs before an item is selected.
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | RootItemChanged | Occurs when the RootItem property is changed.
Public event | SelectionChanged | Occurs when the selection is changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemCollapsed Event

TreeListBoxItemCollapsed Event
Occurs after an item is collapsed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemCollapsed
Public Event ItemCollapsed As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemCollapsing Event

TreeListBoxItemCollapsing Event
Occurs before an item is collapsed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemCollapsing
Public Event ItemCollapsing As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
Remarks
Set the event argument's Cancel property to true to prevent the collapse.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemDefaultActionExecuting Event

TreeListBoxItemDefaultActionExecuting Event
Occurs before the default action is executed for an item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemEventArgs> ItemDefaultActionExecuting
Public Event ItemDefaultActionExecuting As EventHandler(Of TreeListBoxItemEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemEventArgs
Remarks
Set the event argument's Cancel property to true to prevent a default action from executing, which could be executing a DefaultActionCommand or toggling the item's expansion.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemExpanded Event

TreeListBoxItemExpanded Event
Occurs after an item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemExpanded
Public Event ItemExpanded As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemExpanding Event

TreeListBoxItemExpanding Event
Occurs before an item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemExpansionEventArgs> ItemExpanding
Public Event ItemExpanding As EventHandler(Of TreeListBoxItemExpansionEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemExpansionEventArgs
Remarks
Set the event argument's Cancel property to true to prevent the expansion.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemMenuRequested Event

TreeListBoxItemMenuRequested Event
Occurs when an item requests a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemMenuEventArgs> ItemMenuRequested
Public Event ItemMenuRequested As EventHandler(Of TreeListBoxItemMenuEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemMenuEventArgs
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemSelecting Event

TreeListBoxItemSelecting Event
Occurs before an item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListBoxItemEventArgs> ItemSelecting
Public Event ItemSelecting As EventHandler(Of TreeListBoxItemEventArgs)

Value

Type: SystemEventHandler TreeListBoxItemEventArgs
Remarks
Set the event argument's Cancel property to true to prevent the selection.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.RootItemChanged Event

TreeListBoxRootItemChanged Event
Occurs when the RootItem property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler RootItemChanged
Public Event RootItemChanged As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectionChanged Event

TreeListBoxSelectionChanged Event
Occurs when the selection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event SelectionChangedEventHandler SelectionChanged
Public Event SelectionChanged As SelectionChangedEventHandler

Value

Type: Windows.UI.Xaml.ControlsSelectionChangedEventHandler
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox Fields

TreeListBox Fields

The TreeListBox type exposes the following members.

Fields
Name | Description
AutoExpandItemsOnFilterProperty | Identifies the AutoExpandItemsOnFilter dependency property. This field is read-only.
CanDragItemsProperty | Identifies the CanDragItems dependency property. This field is read-only.
DataFilterProperty | Identifies the DataFilter dependency property. This field is read-only.
IndentIncrementProperty | Identifies the IndentIncrement dependency property. This field is read-only.
IsDataVirtualizationEnabledProperty | Identifies the IsDataVirtualizationEnabled dependency property. This field is read-only.
IsFilterActiveProperty | Identifies the IsFilterActive dependency property. This field is read-only.
IsKeyboardFocusWithinProperty | Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.
IsRootItemVisibleProperty | Identifies the IsRootItemVisible dependency property. This field is read-only.
ItemAdapterProperty | Identifies the ItemAdapter dependency property. This field is read-only.
ItemDataFormat | Specifies the data format to use for item data.
MultiDragKindProperty | Identifies the MultiDragKind dependency property. This field is read-only.
MultiSelectionKindProperty | Identifies the MultiSelectionKind dependency property. This field is read-only.
PathSeparatorProperty | Identifies the PathSeparator dependency property. This field is read-only.
RootItemProperty | Identifies the RootItem dependency property. This field is read-only.
SelectedItemProperty | Identifies the SelectedItem dependency property. This field is read-only.
SelectionModeProperty | Identifies the SelectionMode dependency property. This field is read-only.
TopLevelIndentProperty | Identifies the TopLevelIndent dependency property. This field is read-only.
Top
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.AutoExpandItemsOnFilterProperty Field

TreeListBoxAutoExpandItemsOnFilterProperty Field
Identifies the AutoExpandItemsOnFilter dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoExpandItemsOnFilterProperty
Public Shared ReadOnly AutoExpandItemsOnFilterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoExpandItemsOnFilter dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.CanDragItemsProperty Field

TreeListBoxCanDragItemsProperty Field
Identifies the CanDragItems dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanDragItemsProperty
Public Shared ReadOnly CanDragItemsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanDragItems dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.DataFilterProperty Field

TreeListBoxDataFilterProperty Field
Identifies the DataFilter dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DataFilterProperty
Public Shared ReadOnly DataFilterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DataFilter dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IndentIncrementProperty Field

TreeListBoxIndentIncrementProperty Field
Identifies the IndentIncrement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentIncrementProperty
Public Shared ReadOnly IndentIncrementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentIncrement dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsDataVirtualizationEnabledProperty Field

TreeListBoxIsDataVirtualizationEnabledProperty Field
Identifies the IsDataVirtualizationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDataVirtualizationEnabledProperty
Public Shared ReadOnly IsDataVirtualizationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDataVirtualizationEnabled dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsFilterActiveProperty Field

TreeListBoxIsFilterActiveProperty Field
Identifies the IsFilterActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFilterActiveProperty
Public Shared ReadOnly IsFilterActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFilterActive dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsKeyboardFocusWithinProperty Field

TreeListBoxIsKeyboardFocusWithinProperty Field
Identifies the IsKeyboardFocusWithin dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsKeyboardFocusWithinProperty
Public Shared ReadOnly IsKeyboardFocusWithinProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsKeyboardFocusWithin dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.IsRootItemVisibleProperty Field

TreeListBoxIsRootItemVisibleProperty Field
Identifies the IsRootItemVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsRootItemVisibleProperty
Public Shared ReadOnly IsRootItemVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsRootItemVisible dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemAdapterProperty Field

TreeListBoxItemAdapterProperty Field
Identifies the ItemAdapter dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemAdapterProperty
Public Shared ReadOnly ItemAdapterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemAdapter dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.ItemDataFormat Field

TreeListBoxItemDataFormat Field
Specifies the data format to use for item data.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const string ItemDataFormat = "ActiproSoftware.TreeListBox.Items"
Public Const ItemDataFormat As String = "ActiproSoftware.TreeListBox.Items"

Field Value

Type: String
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.MultiDragKindProperty Field

TreeListBoxMultiDragKindProperty Field
Identifies the MultiDragKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MultiDragKindProperty
Public Shared ReadOnly MultiDragKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MultiDragKind dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.MultiSelectionKindProperty Field

TreeListBoxMultiSelectionKindProperty Field
Identifies the MultiSelectionKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MultiSelectionKindProperty
Public Shared ReadOnly MultiSelectionKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MultiSelectionKind dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.PathSeparatorProperty Field

TreeListBoxPathSeparatorProperty Field
Identifies the PathSeparator dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PathSeparatorProperty
Public Shared ReadOnly PathSeparatorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PathSeparator dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.RootItemProperty Field

TreeListBoxRootItemProperty Field
Identifies the RootItem dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RootItemProperty
Public Shared ReadOnly RootItemProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the RootItem dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectedItemProperty Field

TreeListBoxSelectedItemProperty Field
Identifies the SelectedItem dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectedItemProperty
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectedItem dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.SelectionModeProperty Field

TreeListBoxSelectionModeProperty Field
Identifies the SelectionMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionModeProperty
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionMode dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBox.TopLevelIndentProperty Field

TreeListBoxTopLevelIndentProperty Field
Identifies the TopLevelIndent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TopLevelIndentProperty
Public Shared ReadOnly TopLevelIndentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TopLevelIndent dependency property.
See Also

Reference

TreeListBox Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem Class

TreeListBoxItem Class
Represents an item for a TreeListBox control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItem
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListBoxItem : ContentControl
Public Class TreeListBoxItem
    Inherits ContentControl

The TreeListBoxItem type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItem | Initializes an instance of the TreeListBoxItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed.
Public property | IsExpanded | Gets or sets whether the node is expanded.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected.
Public property | IsSelected | Gets or sets whether the node is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped.
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides ControlOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides ControlOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides ControlOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides ControlOnDrop(DragEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Overrides ControlOnRightTapped(RightTappedRoutedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DefaultActionCommandProperty | Identifies the DefaultActionCommand dependency property. This field is read-only.
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
IsExpandableProperty | Identifies the IsExpandable dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsSelectableProperty | Identifies the IsSelectable dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
ToggleExpansionButtonStyleProperty | Identifies the ToggleExpansionButtonStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem Constructor

TreeListBoxItem Constructor
Initializes an instance of the TreeListBoxItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItem()
Public Sub New
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem Properties

TreeListBoxItem Properties

The TreeListBoxItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed.
Public property | IsExpanded | Gets or sets whether the node is expanded.
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected.
Public property | IsSelected | Gets or sets whether the node is selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.DefaultActionCommand Property

TreeListBoxItemDefaultActionCommand Property
Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand DefaultActionCommand { get; set; }
Public Property DefaultActionCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand to execute when this node is double-tapped or Enter is pressed while it's focused.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.DropIndicatorArea Property

TreeListBoxItemDropIndicatorArea Property
Gets a TreeItemDropArea that specifies the drop indicator to display.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeItemDropArea DropIndicatorArea { get; }
Public ReadOnly Property DropIndicatorArea As TreeItemDropArea
    Get

Property Value

Type: TreeItemDropArea
The TreeItemDropArea that specifies the drop indicator to display.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IndentAmount Property

TreeListBoxItemIndentAmount Property
Gets or sets the amount that this item's content is indented.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double IndentAmount { get; set; }
Public Property IndentAmount As Double
    Get
    Set

Property Value

Type: Double
The amount that this item's content is indented.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsExpandable Property

TreeListBoxItemIsExpandable Property
Gets or sets whether the node is capable of being expanded or collapsed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsExpandable { get; set; }
Public Property IsExpandable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is capable of being expanded or collapsed; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsExpanded Property

TreeListBoxItemIsExpanded Property
Gets or sets whether the node is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is expanded; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsSelectable Property

TreeListBoxItemIsSelectable Property
Gets or sets whether the node is capable of being selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelectable { get; set; }
Public Property IsSelectable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is capable of being selected; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsSelected Property

TreeListBoxItemIsSelected Property
Gets or sets whether the node is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the node is selected; otherwise, false.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.ToggleExpansionButtonStyle Property

TreeListBoxItemToggleExpansionButtonStyle Property
Gets or sets the Style to use for the toggle expansion button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ToggleExpansionButtonStyle { get; set; }
Public Property ToggleExpansionButtonStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the toggle expansion button.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem Methods

TreeListBoxItem Methods

The TreeListBoxItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped.
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Overrides ControlOnDragEnter(DragEventArgs).)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Overrides ControlOnDragLeave(DragEventArgs).)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Overrides ControlOnDragOver(DragEventArgs).)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Overrides ControlOnDrop(DragEventArgs).)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed.
Protected method | OnKeyDown | Occurs when a key is pressed. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Overrides ControlOnRightTapped(RightTappedRoutedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnApplyTemplate Method

TreeListBoxItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnDoubleTapped Method

TreeListBoxItemOnDoubleTapped Method
Overload List
 | Name | Description
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped.
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnDoubleTapped Method (InputPointerButtonEventArgs)

TreeListBoxItemOnDoubleTapped Method (InputPointerButtonEventArgs)
Occurs when the item is double-tapped.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDoubleTapped(
    InputPointerButtonEventArgs e
)
Protected Overridable Sub OnDoubleTapped (
    e As InputPointerButtonEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.InputInputPointerButtonEventArgs
The InputPointerButtonEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
OnDoubleTapped Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnDragEnter Method

TreeListBoxItemOnDragEnter Method
Occurs when an object is dragged inside of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDragEnter(
    DragEventArgs e
)
Protected Overrides Sub OnDragEnter (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnDragLeave Method

TreeListBoxItemOnDragLeave Method
Occurs when an object is dragged outside of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDragLeave(
    DragEventArgs e
)
Protected Overrides Sub OnDragLeave (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnDragOver Method

TreeListBoxItemOnDragOver Method
Occurs when an object is dragged over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDragOver(
    DragEventArgs e
)
Protected Overrides Sub OnDragOver (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnDrop Method

TreeListBoxItemOnDrop Method
Occurs when an object is dropped over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnDrop(
    DragEventArgs e
)
Protected Overrides Sub OnDrop (
    e As DragEventArgs
)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs containing data related to this event.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnGotFocus Method

TreeListBoxItemOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnIndentAmountChanged Method

TreeListBoxItemOnIndentAmountChanged Method
Occurs when the IndentAmount property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIndentAmountChanged()
Protected Overridable Sub OnIndentAmountChanged
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnKeyDown Method

TreeListBoxItemOnKeyDown Method
Occurs when a key is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyRoutedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnLostFocus Method

TreeListBoxItemOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.OnRightTapped Method

TreeListBoxItemOnRightTapped Method
Occurs when the pointer is right tapped over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnRightTapped(
    RightTappedRoutedEventArgs e
)
Protected Overrides Sub OnRightTapped (
    e As RightTappedRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputRightTappedRoutedEventArgs
The RightTappedRoutedEventArgs that contains the event data.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.ToString Method

TreeListBoxItemToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem Events

TreeListBoxItem Events

The TreeListBoxItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem Fields

TreeListBoxItem Fields

The TreeListBoxItem type exposes the following members.

Fields
Name | Description
DefaultActionCommandProperty | Identifies the DefaultActionCommand dependency property. This field is read-only.
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
IsExpandableProperty | Identifies the IsExpandable dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsSelectableProperty | Identifies the IsSelectable dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
ToggleExpansionButtonStyleProperty | Identifies the ToggleExpansionButtonStyle dependency property. This field is read-only.
Top
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.DefaultActionCommandProperty Field

TreeListBoxItemDefaultActionCommandProperty Field
Identifies the DefaultActionCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultActionCommandProperty
Public Shared ReadOnly DefaultActionCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultActionCommand dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.DropIndicatorAreaProperty Field

TreeListBoxItemDropIndicatorAreaProperty Field
Identifies the DropIndicatorArea dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropIndicatorAreaProperty
Public Shared ReadOnly DropIndicatorAreaProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropIndicatorArea dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IndentAmountProperty Field

TreeListBoxItemIndentAmountProperty Field
Identifies the IndentAmount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentAmountProperty
Public Shared ReadOnly IndentAmountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentAmount dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsExpandableProperty Field

TreeListBoxItemIsExpandableProperty Field
Identifies the IsExpandable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandableProperty
Public Shared ReadOnly IsExpandableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpandable dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsExpandedProperty Field

TreeListBoxItemIsExpandedProperty Field
Identifies the IsExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandedProperty
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpanded dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsSelectableProperty Field

TreeListBoxItemIsSelectableProperty Field
Identifies the IsSelectable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectableProperty
Public Shared ReadOnly IsSelectableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelectable dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.IsSelectedProperty Field

TreeListBoxItemIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItem.ToggleExpansionButtonStyleProperty Field

TreeListBoxItemToggleExpansionButtonStyleProperty Field
Identifies the ToggleExpansionButtonStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ToggleExpansionButtonStyleProperty
Public Shared ReadOnly ToggleExpansionButtonStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ToggleExpansionButtonStyle dependency property.
See Also

Reference

TreeListBoxItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter Class

TreeListBoxItemAdapter Class
An adapter that can provide an item's hierarchy and visual state data for usage in a TreeListBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemAdapter
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItemAdapter

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListBoxItemAdapter
Public Class TreeListBoxItemAdapter

The TreeListBoxItemAdapter type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemAdapter | Initializes a new instance of the TreeListBoxItemAdapter class
Top
Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items.
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items.
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried.
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability.
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable.
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable.
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable.
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited.
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states.
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded.
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded.
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states.
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously.
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states.
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected.
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities.
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected.
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states.
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item.
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item.
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability.
Top
Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items.
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled.
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets active filter conditions.
Protected method | Finalize | (Inherited from Object.)
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item.
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item.
Public method | GetExpandability | Returns the expandability of the specified item.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the indent amount of the specified item.
Public method | GetIsDraggable | Returns whether the specified item is draggable.
Public method | GetIsEditable | Returns whether the specified item is editable.
Public method | GetIsEditing | Returns whether the specified item is currently being edited.
Public method | GetIsExpanded | Returns whether the specified item is expanded.
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously.
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected.
Public method | GetIsSelected | Returns whether the specified item is selected.
Public method | GetPath | Returns the item's string path.
Public method | GetSearchText | Returns the item's text by which to match when searching.
Public method | GetType | (Inherited from Object.)
Public method | InitializeDataObject | Initializes a DataPackage based on the specified items.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnDragOverAsync | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.
Public method | OnDropAsync | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs.
Public method | SetIsEditing | Sets whether the specified item is currently being edited.
Public method | SetIsExpanded | Sets whether the specified item is expanded.
Public method | SetIsSelected | Sets whether the specified item is selected.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter Constructor

TreeListBoxItemAdapter Constructor
Initializes a new instance of the TreeListBoxItemAdapter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItemAdapter()
Public Sub New
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter Properties

TreeListBoxItemAdapter Properties

The TreeListBoxItemAdapter type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenBinding | Gets or sets a Binding that can be used to retrieve an IEnumerable of child items.
Public property | ChildrenPath | Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items.
Public property | ChildrenQueryModeDefault | Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried.
Public property | ExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability.
Public property | IsDraggableBinding | Gets or sets a Binding that determines whether an item is draggable.
Public property | IsEditableBinding | Gets or sets a Binding that determines whether an item is editable.
Public property | IsEditableDefault | Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable.
Public property | IsEditingBinding | Gets or sets a Binding that determines whether an item is currently being edited.
Public property | IsEditingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states.
Public property | IsExpandedBinding | Gets or sets a Binding that determines whether an item should be expanded.
Public property | IsExpandedDefault | Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded.
Public property | IsExpandedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states.
Public property | IsLoadingBinding | Gets or sets a Binding that determines whether an item is currently loading children asynchronously.
Public property | IsLoadingPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states.
Public property | IsSelectableBinding | Gets or sets a Binding that determines whether an item is capable of being selected.
Public property | IsSelectablePath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities.
Public property | IsSelectedBinding | Gets or sets a Binding that determines whether an item should be selected.
Public property | IsSelectedPath | Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states.
Public property | PathBinding | Gets or sets a Binding that can retrieve the path of an item.
Public property | SearchTextBinding | Gets or sets a Binding that can retrieve the search text of an item.
Public property | TopLevelExpandabilityDefault | Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability.
Top
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.ChildrenBinding Property

TreeListBoxItemAdapterChildrenBinding Property
Gets or sets a Binding that can be used to retrieve an IEnumerable of child items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding ChildrenBinding { get; set; }
Public Property ChildrenBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetChildren(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetChildren(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetChildren(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.ChildrenPath Property

TreeListBoxItemAdapterChildrenPath Property
Gets or sets the resolved item property name for which to monitor INotifyPropertyChanged events related to child items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ChildrenPath { get; set; }
Public Property ChildrenPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.ChildrenQueryModeDefault Property

TreeListBoxItemAdapterChildrenQueryModeDefault Property
Gets or sets a default GetChildrenQueryMode(TreeListBox, Object) return value for designating when children are queried.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeItemChildrenQueryMode ChildrenQueryModeDefault { get; set; }
Public Property ChildrenQueryModeDefault As TreeItemChildrenQueryMode
    Get
    Set

Property Value

Type: TreeItemChildrenQueryMode
A TreeItemChildrenQueryMode indicating the children query mode. The default value is OnDisplay.
Remarks
This value is returned by GetChildrenQueryMode(TreeListBox, Object).
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.ExpandabilityDefault Property

TreeListBoxItemAdapterExpandabilityDefault Property
Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating item expandability.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeItemExpandability ExpandabilityDefault { get; set; }
Public Property ExpandabilityDefault As TreeItemExpandability
    Get
    Set

Property Value

Type: TreeItemExpandability
A TreeItemExpandability indicating the expandability. The default value is Auto.
Remarks
This value is returned by GetExpandability(TreeListBox, Object, Int32).
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsDraggableBinding Property

TreeListBoxItemAdapterIsDraggableBinding Property
Gets or sets a Binding that determines whether an item is draggable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsDraggableBinding { get; set; }
Public Property IsDraggableBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsDraggable(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsDraggable(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsDraggable(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditableBinding Property

TreeListBoxItemAdapterIsEditableBinding Property
Gets or sets a Binding that determines whether an item is editable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsEditableBinding { get; set; }
Public Property IsEditableBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsEditable(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsEditable(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsEditable(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditableDefault Property

TreeListBoxItemAdapterIsEditableDefault Property
Gets or sets a default GetIsEditable(TreeListBox, Object) return value as to whether all items should be editable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEditableDefault { get; set; }
Public Property IsEditableDefault As Boolean
    Get
    Set

Property Value

Type: Boolean
true if all items should be editable; otherwise, false. The default value is false.
Remarks
This value is returned by GetIsEditable(TreeListBox, Object) if no IsEditableBinding is set. Set this property to true to allow all items to be editable. Note that an IsEditableBinding value will override it.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditingBinding Property

TreeListBoxItemAdapterIsEditingBinding Property
Gets or sets a Binding that determines whether an item is currently being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsEditingBinding { get; set; }
Public Property IsEditingBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsEditing(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsEditing(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsEditing(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsEditingPath Property

TreeListBoxItemAdapterIsEditingPath Property
Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to editing states.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string IsEditingPath { get; set; }
Public Property IsEditingPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsExpandedBinding Property

TreeListBoxItemAdapterIsExpandedBinding Property
Gets or sets a Binding that determines whether an item should be expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsExpandedBinding { get; set; }
Public Property IsExpandedBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsExpanded(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsExpanded(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsExpanded(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsExpandedDefault Property

TreeListBoxItemAdapterIsExpandedDefault Property
Gets or sets a default GetIsExpanded(TreeListBox, Object) return value as to whether all items should be initially expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsExpandedDefault { get; set; }
Public Property IsExpandedDefault As Boolean
    Get
    Set

Property Value

Type: Boolean
true if all items should be initially expanded; otherwise, false. The default value is false.
Remarks
This value is returned by GetIsExpanded(TreeListBox, Object) if no IsExpandedBinding is set. Set this property to true to always fully expand a tree. Note that an IsExpandedBinding value will override it.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsExpandedPath Property

TreeListBoxItemAdapterIsExpandedPath Property
Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to expansion states.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string IsExpandedPath { get; set; }
Public Property IsExpandedPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsLoadingBinding Property

TreeListBoxItemAdapterIsLoadingBinding Property
Gets or sets a Binding that determines whether an item is currently loading children asynchronously.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsLoadingBinding { get; set; }
Public Property IsLoadingBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsLoading(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsLoading(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsLoading(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsLoadingPath Property

TreeListBoxItemAdapterIsLoadingPath Property
Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to async children loading states.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string IsLoadingPath { get; set; }
Public Property IsLoadingPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectableBinding Property

TreeListBoxItemAdapterIsSelectableBinding Property
Gets or sets a Binding that determines whether an item is capable of being selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsSelectableBinding { get; set; }
Public Property IsSelectableBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsSelectable(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsSelectable(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsSelectable(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectablePath Property

TreeListBoxItemAdapterIsSelectablePath Property
Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection capabilities.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string IsSelectablePath { get; set; }
Public Property IsSelectablePath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectedBinding Property

TreeListBoxItemAdapterIsSelectedBinding Property
Gets or sets a Binding that determines whether an item should be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding IsSelectedBinding { get; set; }
Public Property IsSelectedBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetIsSelected(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetIsSelected(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetIsSelected(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.IsSelectedPath Property

TreeListBoxItemAdapterIsSelectedPath Property
Gets or sets the item property name for which to monitor INotifyPropertyChanged events related to selection states.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string IsSelectedPath { get; set; }
Public Property IsSelectedPath As String
    Get
    Set

Property Value

Type: String
The name of the property to monitor.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.PathBinding Property

TreeListBoxItemAdapterPathBinding Property
Gets or sets a Binding that can retrieve the path of an item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding PathBinding { get; set; }
Public Property PathBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetPath(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetPath(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetPath(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.SearchTextBinding Property

TreeListBoxItemAdapterSearchTextBinding Property
Gets or sets a Binding that can retrieve the search text of an item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Binding SearchTextBinding { get; set; }
Public Property SearchTextBinding As Binding
    Get
    Set

Property Value

Type: Binding
The Binding to use.
Remarks
When this property is set, it will be used within the default implementation of the GetSearchText(TreeListBox, Object) method. Please note that bindings take longer to execute than a code-based override of the GetSearchText(TreeListBox, Object) method. If you encounter any performance issues when using this binding, override the GetSearchText(TreeListBox, Object) method instead.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.TopLevelExpandabilityDefault Property

TreeListBoxItemAdapterTopLevelExpandabilityDefault Property
Gets or sets a default GetExpandability(TreeListBox, Object, Int32) return value for designating only top-level item expandability.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeItemExpandability TopLevelExpandabilityDefault { get; set; }
Public Property TopLevelExpandabilityDefault As TreeItemExpandability
    Get
    Set

Property Value

Type: TreeItemExpandability
A TreeItemExpandability indicating the expandability. The default value is Auto, meaning fall back to the ExpandabilityDefault value.
Remarks
This value is returned by GetExpandability(TreeListBox, Object, Int32).
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter Methods

TreeListBoxItemAdapter Methods

The TreeListBoxItemAdapter type exposes the following members.

Methods
 | Name | Description
Public method | CanHaveChildren | Returns whether the specified item is capable of having child items.
Public method | CreateVirtualPlaceholder | Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled.
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets active filter conditions.
Protected method | Finalize | (Inherited from Object.)
Public method | GetChildren | Returns an IEnumerable that will be used to provide child items for the specified parent item.
Public method | GetChildrenQueryMode | Returns the children query mode of the specified item.
Public method | GetExpandability | Returns the expandability of the specified item.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetIndentAmount | Returns the indent amount of the specified item.
Public method | GetIsDraggable | Returns whether the specified item is draggable.
Public method | GetIsEditable | Returns whether the specified item is editable.
Public method | GetIsEditing | Returns whether the specified item is currently being edited.
Public method | GetIsExpanded | Returns whether the specified item is expanded.
Public method | GetIsLoading | Returns whether the specified item is currently loading children asynchronously.
Public method | GetIsSelectable | Returns whether the specified item is capable of being selected.
Public method | GetIsSelected | Returns whether the specified item is selected.
Public method | GetPath | Returns the item's string path.
Public method | GetSearchText | Returns the item's text by which to match when searching.
Public method | GetType | (Inherited from Object.)
Public method | InitializeDataObject | Initializes a DataPackage based on the specified items.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | OnDragOverAsync | Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.
Public method | OnDropAsync | Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs.
Public method | SetIsEditing | Sets whether the specified item is currently being edited.
Public method | SetIsExpanded | Sets whether the specified item is expanded.
Public method | SetIsSelected | Sets whether the specified item is selected.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.CanHaveChildren Method

TreeListBoxItemAdapterCanHaveChildren Method
Returns whether the specified item is capable of having child items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanHaveChildren(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function CanHaveChildren (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is capable of having child items; otherwise, false.
Remarks
The default implementation of this method returns true. This method should only return false if an item is not capable of having child items and is always a 'leaf' node in the tree. It should not return false if the item can have child items, but doesn't at the current time.

Optimizations are in place to not call GetChildren(TreeListBox, Object) when this method returns true. This method should be overridden if OnExpansion is used and certain items are known to be 'leaf' nodes.

See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.CreateVirtualPlaceholder Method

TreeListBoxItemAdapterCreateVirtualPlaceholder Method
Creates a virtual placeholder for an item's child at the specified index, when data virtualization is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual ITreeItemVirtualPlaceholder CreateVirtualPlaceholder(
    TreeListBox ownerControl,
    Object parentItem,
    int index
)
Public Overridable Function CreateVirtualPlaceholder (
    ownerControl As TreeListBox,
    parentItem As Object,
    index As Integer
) As ITreeItemVirtualPlaceholder

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
parentItem
Type: SystemObject
The parent item.
index
Type: SystemInt32
The index of the child.

Return Value

Type: ITreeItemVirtualPlaceholder
The ITreeItemVirtualPlaceholder that was created.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.Filter Method

TreeListBoxItemAdapterFilter Method
Examines the specified item to see if meets active filter conditions.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataFilterResult Filter(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function Filter (
    ownerControl As TreeListBox,
    item As Object
) As DataFilterResult

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.
Remarks
The default implementation of this method uses the DataFilter value to filter the item. If no data filter is available, the method returns true.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetChildren Method

TreeListBoxItemAdapterGetChildren Method
Returns an IEnumerable that will be used to provide child items for the specified parent item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IEnumerable GetChildren(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetChildren (
    ownerControl As TreeListBox,
    item As Object
) As IEnumerable

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: IEnumerable
An IEnumerable that will be used to provide child items for the specified parent item.
Remarks
The ChildrenBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetChildrenQueryMode Method

TreeListBoxItemAdapterGetChildrenQueryMode Method
Returns the children query mode of the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TreeItemChildrenQueryMode GetChildrenQueryMode(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetChildrenQueryMode (
    ownerControl As TreeListBox,
    item As Object
) As TreeItemChildrenQueryMode

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: TreeItemChildrenQueryMode
A TreeItemChildrenQueryMode indicating the children query mode.
Remarks
The default implementation of this method returns the ChildrenQueryModeDefault property value. That property can be set in XAML, or this method may be overridden for more complex logic.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetExpandability Method

TreeListBoxItemAdapterGetExpandability Method
Returns the expandability of the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TreeItemExpandability GetExpandability(
    TreeListBox ownerControl,
    Object item,
    int depth
)
Public Overridable Function GetExpandability (
    ownerControl As TreeListBox,
    item As Object,
    depth As Integer
) As TreeItemExpandability

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.
depth
Type: SystemInt32
The item depth.

Return Value

Type: TreeItemExpandability
A TreeItemExpandability indicating the expandability.
Remarks
The default implementation of this method examines the TopLevelExpandabilityDefault property if the item is top-level. If that property return Auto, or if the item isn't top-level, the ExpandabilityDefault property value is returned. Both properties can be set in XAML, or this method may be overridden for more complex logic.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIndentAmount Method

TreeListBoxItemAdapterGetIndentAmount Method
Returns the indent amount of the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual double GetIndentAmount(
    TreeListBox ownerControl,
    Object item,
    int depth
)
Public Overridable Function GetIndentAmount (
    ownerControl As TreeListBox,
    item As Object,
    depth As Integer
) As Double

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.
depth
Type: SystemInt32
The item depth.

Return Value

Type: Double
The indent amount.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsDraggable Method

TreeListBoxItemAdapterGetIsDraggable Method
Returns whether the specified item is draggable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsDraggable(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsDraggable (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is draggable; otherwise, false.
Remarks
The IsDraggableBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsEditable Method

TreeListBoxItemAdapterGetIsEditable Method
Returns whether the specified item is editable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsEditable(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsEditable (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is editable; otherwise, false.
Remarks
The IsEditableBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value. The IsEditableDefault property can also be set (if IsEditableBinding is not used) to designate the default return value of this method, and that can be set in XAML.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsEditing Method

TreeListBoxItemAdapterGetIsEditing Method
Returns whether the specified item is currently being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsEditing(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsEditing (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is currently being edited; otherwise, false.
Remarks
The IsEditingBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsExpanded Method

TreeListBoxItemAdapterGetIsExpanded Method
Returns whether the specified item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsExpanded(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsExpanded (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is expanded; otherwise, false.
Remarks
The IsExpandedBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value. The IsExpandedDefault property can also be set (if IsExpandedBinding is not used) to designate the default return value of this method, and that can be set in XAML.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsLoading Method

TreeListBoxItemAdapterGetIsLoading Method
Returns whether the specified item is currently loading children asynchronously.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsLoading(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsLoading (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is currently loading children asynchronously; otherwise, false.
Remarks
The IsLoadingBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsSelectable Method

TreeListBoxItemAdapterGetIsSelectable Method
Returns whether the specified item is capable of being selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsSelectable(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsSelectable (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is capable of being selected; otherwise, false.
Remarks
The IsSelectableBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetIsSelected Method

TreeListBoxItemAdapterGetIsSelected Method
Returns whether the specified item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool GetIsSelected(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetIsSelected (
    ownerControl As TreeListBox,
    item As Object
) As Boolean

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: Boolean
true if the specified item is selected; otherwise, false.
Remarks
The IsSelectedBinding binding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetPath Method

TreeListBoxItemAdapterGetPath Method
Returns the item's string path.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string GetPath(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetPath (
    ownerControl As TreeListBox,
    item As Object
) As String

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: String
The item's string path.
Remarks
The PathBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.GetSearchText Method

TreeListBoxItemAdapterGetSearchText Method
Returns the item's text by which to match when searching.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string GetSearchText(
    TreeListBox ownerControl,
    Object item
)
Public Overridable Function GetSearchText (
    ownerControl As TreeListBox,
    item As Object
) As String

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to examine.

Return Value

Type: String
The item's string search text.
Remarks
The SearchTextBinding property can be set for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to retrieve the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.InitializeDataObject Method

TreeListBoxItemAdapterInitializeDataObject Method
Initializes a DataPackage based on the specified items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void InitializeDataObject(
    TreeListBox sourceControl,
    DataPackage dataObject,
    IEnumerable<Object> items
)
Public Overridable Sub InitializeDataObject (
    sourceControl As TreeListBox,
    dataObject As DataPackage,
    items As IEnumerable(Of Object)
)

Parameters

sourceControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The source control that contains the items.
dataObject
Type: Windows.ApplicationModel.DataTransferDataPackage
The DataPackage to initialize.
items
Type: System.Collections.GenericIEnumerable Object
The items to examine.
Remarks
The default implementation of this method does nothing. Override this method to initialize the DataPackage with text and/or other data formats (such as ItemDataFormat for supporting drag/drop), and to set an appropriate DataPackage.RequestedOperation.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDragOverAsync Method

TreeListBoxItemAdapterOnDragOverAsync Method
Notifies that a drag event occurred over a target item, requests that appropriate updates are made to the supplied DragEventArgs, and requests that the allowed drop area is returned for visual target feedback.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Task<TreeItemDropArea> OnDragOverAsync(
    DragEventArgs e,
    TreeListBox targetControl,
    Object targetItem,
    TreeItemDropArea dropArea
)
Public Overridable Function OnDragOverAsync (
    e As DragEventArgs,
    targetControl As TreeListBox,
    targetItem As Object,
    dropArea As TreeItemDropArea
) As Task(Of TreeItemDropArea)

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs whose effects should be updated.
targetControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The target control, over which the event occurred.
targetItem
Type: SystemObject
The target item, which could be if dragging below the last tree item.
dropArea
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeItemDropArea
A TreeItemDropArea indicating the drop area over the target item.

Return Value

Type: Task TreeItemDropArea
A TreeItemDropArea indicating the allowed drop area, which will be used for visual feedback to the end user. Return TreeItemDropArea.None for no visual feedback.
Remarks
The default implementation of this method sets the e.AcceptedOperation to DataPackageOperation.None and returns that no drop area is allowed. Override this method if you wish to support dropping and add logic to properly handle the dragged data.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.OnDropAsync Method

TreeListBoxItemAdapterOnDropAsync Method
Notifies that a drop event occurred over a target item and requests that appropriate updates are made to the supplied DragEventArgs.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Task OnDropAsync(
    DragEventArgs e,
    TreeListBox targetControl,
    Object targetItem,
    TreeItemDropArea dropArea
)
Public Overridable Function OnDropAsync (
    e As DragEventArgs,
    targetControl As TreeListBox,
    targetItem As Object,
    dropArea As TreeItemDropArea
) As Task

Parameters

e
Type: Windows.UI.XamlDragEventArgs
The DragEventArgs whose effects should be updated.
targetControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The target control, over which the event occurred.
targetItem
Type: SystemObject
The target item, which could be if dragging below the last tree item.
dropArea
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeItemDropArea
A TreeItemDropArea indicating the drop area over the target item.

Return Value

Type: Task

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.TreeListBoxItemAdapter.OnDropAsync(Windows.UI.Xaml.DragEventArgs,ActiproSoftware.UI.Xaml.Controls.Grids.TreeListBox,System.Object,ActiproSoftware.UI.Xaml.Controls.Grids.TreeItemDropArea)"]

Remarks
The default implementation of this method sets the e.AcceptedOperation to DataPackageOperation.None and takes no further action. Override this method if you wish to support dropping and add logic to properly handle the dragged data.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.SetIsEditing Method

TreeListBoxItemAdapterSetIsEditing Method
Sets whether the specified item is currently being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void SetIsEditing(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overridable Sub SetIsEditing (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
Remarks
The IsEditingBinding binding property can be set to a two-way binding for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to set the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.SetIsExpanded Method

TreeListBoxItemAdapterSetIsExpanded Method
Sets whether the specified item is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void SetIsExpanded(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overridable Sub SetIsExpanded (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
Remarks
The IsExpandedBinding binding property can be set to a two-way binding for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to set the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemAdapter.SetIsSelected Method

TreeListBoxItemAdapterSetIsSelected Method
Sets whether the specified item is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void SetIsSelected(
    TreeListBox ownerControl,
    Object item,
    bool value
)
Public Overridable Sub SetIsSelected (
    ownerControl As TreeListBox,
    item As Object,
    value As Boolean
)

Parameters

ownerControl
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
The owner control.
item
Type: SystemObject
The item to update.
value
Type: SystemBoolean
The new value.
Remarks
The IsSelectedBinding binding property can be set to a two-way binding for a pure XAML-based implementation of this method. Please note that bindings aren't as performant as code, so for large trees or if you see performance issues, it is recommended to override this method instead with custom logic to set the appropriate value.
See Also

Reference

TreeListBoxItemAdapter Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemEventArgs Class

TreeListBoxItemEventArgs Class
Provides event arguments for TreeListBox item-related events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemExpansionEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemMenuEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListBoxItemEventArgs : CancelableEventArgs
Public Class TreeListBoxItemEventArgs
    Inherits CancelableEventArgs

The TreeListBoxItemEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemEventArgs | Initializes a new instance of the TreeListBoxItemEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item.
Public property | Item | Gets the TreeListBox data item.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemEventArgs Constructor

TreeListBoxItemEventArgs Constructor
Initializes a new instance of the TreeListBoxItemEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItemEventArgs(
    Object item,
    TreeListBoxItem container
)
Public Sub New (
    item As Object,
    container As TreeListBoxItem
)

Parameters

item
Type: SystemObject
The TreeListBox data item.
container
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItem
The TreeListBoxItem container that wraps the Item.
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemEventArgs Properties

TreeListBoxItemEventArgs Properties

The TreeListBoxItemEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item.
Public property | Item | Gets the TreeListBox data item.
Top
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemEventArgs.Container Property

TreeListBoxItemEventArgsContainer Property
Gets the TreeListBoxItem container that wraps the Item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItem Container { get; }
Public ReadOnly Property Container As TreeListBoxItem
    Get

Property Value

Type: TreeListBoxItem
The TreeListBoxItem container that wraps the Item.
Remarks
This property may return when the Item is not currently visible. In that case a container might not yet have been generated for the item, or a prior container may have been recycled, both due to UI virtualization.
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemEventArgs.Item Property

TreeListBoxItemEventArgsItem Property
Gets the TreeListBox data item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Item { get; }
Public ReadOnly Property Item As Object
    Get

Property Value

Type: Object
The TreeListBox data item.
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemEventArgs Methods

TreeListBoxItemEventArgs Methods

The TreeListBoxItemEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeListBoxItemEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Class

TreeListBoxItemExpansionEventArgs Class
Provides event arguments for TreeListBox item expand and collapse-related events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemExpansionEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListBoxItemExpansionEventArgs : TreeListBoxItemEventArgs
Public Class TreeListBoxItemExpansionEventArgs
    Inherits TreeListBoxItemEventArgs

The TreeListBoxItemExpansionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemExpansionEventArgs | Initializes a new instance of the TreeListBoxItemExpansionEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Kind | Gets a TreeExpansionKind that specifies the kind of expansion.
Public property | SourceItem | Gets the TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Constructor

TreeListBoxItemExpansionEventArgs Constructor
Initializes a new instance of the TreeListBoxItemExpansionEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItemExpansionEventArgs(
    Object item,
    TreeListBoxItem container,
    TreeExpansionKind kind,
    Object sourceItem
)
Public Sub New (
    item As Object,
    container As TreeListBoxItem,
    kind As TreeExpansionKind,
    sourceItem As Object
)

Parameters

item
Type: SystemObject
The TreeListBox data item.
container
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItem
The TreeListBoxItem container that wraps the Item.
kind
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeExpansionKind
A TreeExpansionKind that specifies the kind of expansion.
sourceItem
Type: SystemObject
The TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Properties

TreeListBoxItemExpansionEventArgs Properties

The TreeListBoxItemExpansionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Kind | Gets a TreeExpansionKind that specifies the kind of expansion.
Public property | SourceItem | Gets the TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
Top
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs.Kind Property

TreeListBoxItemExpansionEventArgsKind Property
Gets a TreeExpansionKind that specifies the kind of expansion.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeExpansionKind Kind { get; }
Public ReadOnly Property Kind As TreeExpansionKind
    Get

Property Value

Type: TreeExpansionKind
A TreeExpansionKind that specifies the kind of expansion.
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs.SourceItem Property

TreeListBoxItemExpansionEventArgsSourceItem Property
Gets the TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object SourceItem { get; }
Public ReadOnly Property SourceItem As Object
    Get

Property Value

Type: Object
The TreeListBox data item that triggered the expand/collapse, if not expanding/collapsing all items in the control.
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemExpansionEventArgs Methods

TreeListBoxItemExpansionEventArgs Methods

The TreeListBoxItemExpansionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeListBoxItemExpansionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Class

TreeListBoxItemMenuEventArgs Class
Provides event arguments for TreeListBox item menu events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItemMenuEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListBoxItemMenuEventArgs : TreeListBoxItemEventArgs
Public Class TreeListBoxItemMenuEventArgs
    Inherits TreeListBoxItemEventArgs

The TreeListBoxItemMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListBoxItemMenuEventArgs | Initializes a new instance of the TreeListBoxItemMenuEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Public property | PointerLocation | Gets or sets the location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Constructor

TreeListBoxItemMenuEventArgs Constructor
Initializes a new instance of the TreeListBoxItemMenuEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListBoxItemMenuEventArgs(
    Object item,
    TreeListBoxItem container,
    Nullable<Point> pointerLocation
)
Public Sub New (
    item As Object,
    container As TreeListBoxItem,
    pointerLocation As Nullable(Of Point)
)

Parameters

item
Type: SystemObject
The TreeListBox data item.
container
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItem
The TreeListBoxItem container that wraps the Item.
pointerLocation
Type: SystemNullable Point
The location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Properties

TreeListBoxItemMenuEventArgs Properties

The TreeListBoxItemMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Container | Gets the TreeListBoxItem container that wraps the Item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Item | Gets the TreeListBox data item. (Inherited from TreeListBoxItemEventArgs.)
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Public property | PointerLocation | Gets or sets the location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
Top
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs.Menu Property

TreeListBoxItemMenuEventArgsMenu Property
Gets or sets the MenuFlyout that is about to be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MenuFlyout Menu { get; set; }
Public Property Menu As MenuFlyout
    Get
    Set

Property Value

Type: MenuFlyout
The MenuFlyout that is about to be displayed.
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs.PointerLocation Property

TreeListBoxItemMenuEventArgsPointerLocation Property
Gets or sets the location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Point> PointerLocation { get; set; }
Public Property PointerLocation As Nullable(Of Point)
    Get
    Set

Property Value

Type: Nullable Point
The location of the pointer relative to the Container if the menu was opened by a pointer (e.g. mouse right-click).
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListBoxItemMenuEventArgs Methods

TreeListBoxItemMenuEventArgs Methods

The TreeListBoxItemMenuEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeListBoxItemMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView Class

TreeListView Class
Represents an advanced multi-column tree view control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsItemsControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBox
ActiproSoftware.UI.Xaml.Controls.GridsTreeListView
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGrid

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListView : TreeListBox
Public Class TreeListView
    Inherits TreeListBox

The TreeListView type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListView | Initializes an instance of the TreeListView class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible.
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user.
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user.
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Columns | Gets the collection of columns in the control.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility.
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from TreeListBox.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListBoxArrangeOverride(Size).)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Inherited from TreeListBox.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
 | GetColumnHeaderVisibility | Gets the value of the ColumnHeaderVisibility attached property for the specified object.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListBoxGetContainerForItemOverride.)
 | GetFrozenColumnsWidth | Gets the value of the FrozenColumnsWidth attached property for the specified object.
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListBoxIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListBoxOnApplyTemplate.)
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user.
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBox.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Overrides TreeListBoxOnScrollViewerScrollChanged(ScrollViewerViewChangedEventArgs).)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from TreeListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
 | SetColumnHeaderVisibility | Sets the value of the ColumnHeaderVisibility attached property to the specified object.
 | SetFrozenColumnsWidth | Sets the value of the FrozenColumnsWidth attached property to the specified object.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Public event | ColumnReordered | Occurs after a column is reordered by the end user.
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | RootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreColumnHeadersVisibleProperty | Identifies the AreColumnHeadersVisible dependency property. This field is read-only.
CanColumnsReorderProperty | Identifies the CanColumnsReorder dependency property. This field is read-only.
CanColumnsResizeProperty | Identifies the CanColumnsResize dependency property. This field is read-only.
CanColumnsToggleVisibilityProperty | Identifies the CanColumnsToggleVisibility dependency property. This field is read-only.
ColumnHeaderVisibilityProperty | Identifies the ColumnHeaderVisibility dependency property. This field is read-only.
ExpansionColumnIndexProperty | Identifies the ExpansionColumnIndex dependency property. This field is read-only.
FrozenColumnCountProperty | Identifies the FrozenColumnCount dependency property. This field is read-only.
FrozenColumnsWidthProperty | Identifies the FrozenColumnsWidth dependency property. This field is read-only.
IsDefaultColumnHeaderContextMenuEnabledProperty | Identifies the IsDefaultColumnHeaderContextMenuEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView Constructor

TreeListView Constructor
Initializes an instance of the TreeListView class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListView()
Public Sub New
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView Properties

TreeListView Properties

The TreeListView type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreColumnHeadersVisible | Gets or sets whether column headers are visible.
Public property | AutoExpandItemsOnFilter | Gets or sets whether to auto-expand to items that are included by a filter when IsFilterActive is true. (Inherited from TreeListBox.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanColumnsReorder | Gets or sets whether columns can be reordered by the end user.
Public property | CanColumnsResize | Gets or sets whether columns can be resized by the end user.
Public property | CanColumnsToggleVisibility | Gets or sets whether columns can have their visibility toggled by the end user.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanDragItems | Gets or sets whether to allow dragging of selected items. (Inherited from TreeListBox.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Columns | Gets the collection of columns in the control.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataFilter | Gets or sets the IDataFilter to use when IsFilterActive is true. (Inherited from TreeListBox.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets the name or path of the property that is displayed for each data item. (Inherited from ItemsControl.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | ExpansionColumnIndex | Gets or sets the index of the columns that contains the indentation and expander button.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FrozenColumnCount | Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility.
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a reference to a custom GroupStyleSelector logic class. The GroupStyleSelector returns different GroupStyle values to use for content based on the characteristics of that content. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentIncrement | Gets or sets the incremental amount by which to indent an item for each depth level. (Inherited from TreeListBox.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDataVirtualizationEnabled | Gets or sets whether data virtualization is enabled. (Inherited from TreeListBox.)
Public property | IsDefaultColumnHeaderContextMenuEnabled | Gets or sets whether the default column header context menu is enabled.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFilterActive | Gets or sets whether a filter is currently active. (Inherited from TreeListBox.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets whether keyboard focus is within the control. (Inherited from TreeListBox.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsRootItemVisible | Gets or sets whether the RootItem is visible, or whether its children are the top-level node items. (Inherited from TreeListBox.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemAdapter | Gets or sets the TreeListBoxItemAdapter that adapts items with the UI by providing child items, expansion states, etc. (Inherited from TreeListBox.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator associated with this ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the style that is used when rendering the item containers. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets a reference to a custom StyleSelector logic class. The StyleSelector returns different Style values to use for the item container based on characteristics of the object being displayed. (Inherited from ItemsControl.)
Public property | ItemContainerTransitions | Gets or sets the collection of Transition style elements that apply to the item containers of an ItemsControl. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the control. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsPanelRoot | Gets the Panel specified by ItemsPanel. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets an object source used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets a reference to a custom DataTemplateSelector logic class. The DataTemplateSelector referenced by this property returns a template to apply to items. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MultiDragKind | Gets or sets a TreeMultiDragKind that indicates the dragging support when multiple items are involved. (Inherited from TreeListBox.)
Public property | MultiSelectionKind | Gets or sets a TreeMultiSelectionKind that indicates the selection support when multiple items are involved. (Inherited from TreeListBox.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree item full path uses. (Inherited from TreeListBox.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | RootItem | Gets or sets the root item to display in the control. (Inherited from TreeListBox.)
Public property | SelectedItem | Gets or sets the primary selected item. (Inherited from TreeListBox.)
Public property | SelectedItems | Gets the collection of selected items. (Inherited from TreeListBox.)
Public property | SelectionMode | Gets or sets a SelectionMode that indicates the selection behavior. (Inherited from TreeListBox.)
Public property | SizeAllColumnsToFitCommand | Gets the ICommand that sizes all non-star width columns to fit.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | TopLevelIndent | Gets or sets the amount by which to indent a top-level item. (Inherited from TreeListBox.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.AreColumnHeadersVisible Property

TreeListViewAreColumnHeadersVisible Property
Gets or sets whether column headers are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreColumnHeadersVisible { get; set; }
Public Property AreColumnHeadersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if column headers are visible; otherwise, false. The default value is true.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.CanColumnsReorder Property

TreeListViewCanColumnsReorder Property
Gets or sets whether columns can be reordered by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanColumnsReorder { get; set; }
Public Property CanColumnsReorder As Boolean
    Get
    Set

Property Value

Type: Boolean
true if columns can be reordered by the end user; otherwise, false. The default value is false.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.CanColumnsResize Property

TreeListViewCanColumnsResize Property
Gets or sets whether columns can be resized by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanColumnsResize { get; set; }
Public Property CanColumnsResize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if columns can be resized by the end user; otherwise, false. The default value is true.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.CanColumnsToggleVisibility Property

TreeListViewCanColumnsToggleVisibility Property
Gets or sets whether columns can have their visibility toggled by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanColumnsToggleVisibility { get; set; }
Public Property CanColumnsToggleVisibility As Boolean
    Get
    Set

Property Value

Type: Boolean
true if columns can have their visibility toggled by the end user; otherwise, false. The default value is false.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.Columns Property

TreeListViewColumns Property
Gets the collection of columns in the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<TreeListViewColumn> Columns { get; }
Public ReadOnly Property Columns As ObservableCollection(Of TreeListViewColumn)
    Get

Property Value

Type: ObservableCollection TreeListViewColumn
The collection of columns in the control.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ExpansionColumnIndex Property

TreeListViewExpansionColumnIndex Property
Gets or sets the index of the columns that contains the indentation and expander button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int ExpansionColumnIndex { get; set; }
Public Property ExpansionColumnIndex As Integer
    Get
    Set

Property Value

Type: Int32
The index of the columns that contains the indentation and expander button. The default value is 0.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.FrozenColumnCount Property

TreeListViewFrozenColumnCount Property
Gets or sets the number of non-scrolling columns, that are always displayed left-most and cannot be scrolled out of visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int FrozenColumnCount { get; set; }
Public Property FrozenColumnCount As Integer
    Get
    Set

Property Value

Type: Int32
The number of non-scrolling columns. The default value is 0.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.IsDefaultColumnHeaderContextMenuEnabled Property

TreeListViewIsDefaultColumnHeaderContextMenuEnabled Property
Gets or sets whether the default column header context menu is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDefaultColumnHeaderContextMenuEnabled { get; set; }
Public Property IsDefaultColumnHeaderContextMenuEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the default column header context menu is enabled; otherwise, false. The default value is true.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.SizeAllColumnsToFitCommand Property

TreeListViewSizeAllColumnsToFitCommand Property
Gets the ICommand that sizes all non-star width columns to fit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SizeAllColumnsToFitCommand { get; }
Public ReadOnly Property SizeAllColumnsToFitCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that sizes all non-star width columns to fit.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView Methods

TreeListView Methods

The TreeListView type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListBoxArrangeOverride(Size).)
Public method | BringItemIntoView | Brings the specified node's container into view. (Inherited from TreeListBox.)
Public method | BringItemIntoViewByFullPath | Brings the container for the item with the specified full path into view. (Inherited from TreeListBox.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Protected method | ClearContainerForItemOverride | Removes the effects of a PrepareContainerForItemOverride(DependencyObject, Object) call. (Inherited from TreeListBox.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | ContainerFromIndex | Returns the container for the item at the specified index within the ItemCollection. (Inherited from ItemsControl.)
Public method | ContainerFromItem | Returns the container corresponding to the specified item. (Inherited from ItemsControl.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | FocusItem | Focuses the container for the specified node, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | FocusItemByFullPath | Focuses the container for the node with the specified full path, scrolling it into view as needed. (Inherited from TreeListBox.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
 | GetColumnHeaderVisibility | Gets the value of the ColumnHeaderVisibility attached property for the specified object.
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides TreeListBoxGetContainerForItemOverride.)
 | GetFrozenColumnsWidth | Gets the value of the FrozenColumnsWidth attached property for the specified object.
Public method | GetFullPath | Returns the full path of the specified item. (Inherited from TreeListBox.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemByFullPath | Returns the item with the specified full path. (Inherited from TreeListBox.)
Public method | GetItemNavigator | Returns the ITreeItemNavigator for the specified item, if the item is a visible item. (Inherited from TreeListBox.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | GroupHeaderContainerFromItemContainer | (Inherited from ItemsControl.)
Public method | IndexFromContainer | Returns the index to the item that has the specified, generated container. (Inherited from ItemsControl.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateChildren | Invalidates the children of the specified item, allowing the children to be requeried. (Inherited from TreeListBox.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own item container. (Overrides TreeListBoxIsItemItsOwnContainerOverride(Object).)
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides TreeListBoxOnApplyTemplate.)
Protected method | OnColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Protected method | OnColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Protected method | OnColumnReordered | Occurs after a column is reordered by the end user.
Protected method | OnColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBox.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBox.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBox.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBox.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBox.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the value of the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Protected method | OnItemContainerStyleChanged | Invoked when the value of the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the value of the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Protected method | OnItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Protected method | OnItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Protected method | OnItemsChanged | Invoked when the value of the Items property changes. (Inherited from ItemsControl.)
Protected method | OnItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Protected method | OnItemTemplateChanged | Invoked when the value of the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the value of the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBox.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnRootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Protected method | OnScrollViewerScrollChanged | Occurs when the scroll viewer's scroll is changed. (Overrides TreeListBoxOnScrollViewerScrollChanged(ScrollViewerViewChangedEventArgs).)
Protected method | OnSelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from TreeListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SelectItemByFullPath | Sets the SelectedItem to the node with the specified full path. (Inherited from TreeListBox.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
 | SetColumnHeaderVisibility | Sets the value of the ColumnHeaderVisibility attached property to the specified object.
 | SetFrozenColumnsWidth | Sets the value of the FrozenColumnsWidth attached property to the specified object.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | SizeAllColumnsToFit | Sizes all non-star width columns to fit.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ArrangeOverride Method

TreeListViewArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListBoxArrangeOverride(Size).)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ArrangeOverride Method (Size)

TreeListViewArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListView Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.GetColumnHeaderVisibility Method

TreeListViewGetColumnHeaderVisibility Method
Gets the value of the ColumnHeaderVisibility attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static Visibility GetColumnHeaderVisibility(
    ScrollViewer obj
)
Public Shared Function GetColumnHeaderVisibility (
    obj As ScrollViewer
) As Visibility

Parameters

obj
Type: Windows.UI.Xaml.ControlsScrollViewer
The object from which the property value is read.

Return Value

Type: Visibility
The object's value.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.GetContainerForItemOverride Method

TreeListViewGetContainerForItemOverride Method
Creates or identifies the element used to display the specified item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DependencyObject GetContainerForItemOverride()
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

Type: DependencyObject
The element that is used to display the given item.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.GetFrozenColumnsWidth Method

TreeListViewGetFrozenColumnsWidth Method
Gets the value of the FrozenColumnsWidth attached property for the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static double GetFrozenColumnsWidth(
    ScrollViewer obj
)
Public Shared Function GetFrozenColumnsWidth (
    obj As ScrollViewer
) As Double

Parameters

obj
Type: Windows.UI.Xaml.ControlsScrollViewer
The object from which the property value is read.

Return Value

Type: Double
The object's value.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.IsItemItsOwnContainerOverride Method

TreeListViewIsItemItsOwnContainerOverride Method
Determines if the specified item is (or is eligible to be) its own item container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Protected Overrides Function IsItemItsOwnContainerOverride (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
Specified item.

Return Value

Type: Boolean
true if the item is its own item container; otherwise, false.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.MeasureOverride Method

TreeListViewMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.MeasureOverride Method (Size)

TreeListViewMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

TreeListView Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.OnApplyTemplate Method

TreeListViewOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.OnColumnHeaderMenuRequested Method

TreeListViewOnColumnHeaderMenuRequested Method
Occurs when a column header requests a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnColumnHeaderMenuRequested(
    TreeListViewColumnMenuEventArgs e
)
Protected Overridable Sub OnColumnHeaderMenuRequested (
    e As TreeListViewColumnMenuEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnMenuEventArgs
The TreeListViewColumnMenuEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.OnColumnIsVisibleChanged Method

TreeListViewOnColumnIsVisibleChanged Method
Occurs when a column's visibility has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnColumnIsVisibleChanged(
    TreeListViewColumnEventArgs e
)
Protected Overridable Sub OnColumnIsVisibleChanged (
    e As TreeListViewColumnEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnEventArgs
The TreeListViewColumnEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.OnColumnReordered Method

TreeListViewOnColumnReordered Method
Occurs after a column is reordered by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnColumnReordered(
    TreeListViewColumnEventArgs e
)
Protected Overridable Sub OnColumnReordered (
    e As TreeListViewColumnEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnEventArgs
The TreeListViewColumnEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.OnColumnsResized Method

TreeListViewOnColumnsResized Method
Occurs after the ActualWidth of one or more columns changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnColumnsResized(
    RoutedEventArgs e
)
Protected Overridable Sub OnColumnsResized (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
Remarks
This method has no default implementation. Because an intermediate class in the inheritance might implement this method, we recommend that you call the base implementation in your implementation.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.OnScrollViewerScrollChanged Method

TreeListViewOnScrollViewerScrollChanged Method
Occurs when the scroll viewer's scroll is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnScrollViewerScrollChanged(
    ScrollViewerViewChangedEventArgs e
)
Protected Overrides Sub OnScrollViewerScrollChanged (
    e As ScrollViewerViewChangedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.ControlsScrollViewerViewChangedEventArgs
The ScrollViewerViewChangedEventArgs that contains data related to the event.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.SetColumnHeaderVisibility Method

TreeListViewSetColumnHeaderVisibility Method
Sets the value of the ColumnHeaderVisibility attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetColumnHeaderVisibility(
    ScrollViewer obj,
    Visibility value
)
Public Shared Sub SetColumnHeaderVisibility (
    obj As ScrollViewer,
    value As Visibility
)

Parameters

obj
Type: Windows.UI.Xaml.ControlsScrollViewer
The object to which the attached property is written.
value
Type: Windows.UI.XamlVisibility
The value to set.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.SetFrozenColumnsWidth Method

TreeListViewSetFrozenColumnsWidth Method
Sets the value of the FrozenColumnsWidth attached property to the specified object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetFrozenColumnsWidth(
    ScrollViewer obj,
    double value
)
Public Shared Sub SetFrozenColumnsWidth (
    obj As ScrollViewer,
    value As Double
)

Parameters

obj
Type: Windows.UI.Xaml.ControlsScrollViewer
The object to which the attached property is written.
value
Type: SystemDouble
The value to set.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.SizeAllColumnsToFit Method

TreeListViewSizeAllColumnsToFit Method
Sizes all non-star width columns to fit.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SizeAllColumnsToFit()
Public Sub SizeAllColumnsToFit
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView Events

TreeListView Events

The TreeListView type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ColumnHeaderMenuRequested | Occurs when a column header requests a context menu.
Public event | ColumnIsVisibleChanged | Occurs when a column's visibility has changed.
Public event | ColumnReordered | Occurs after a column is reordered by the end user.
Public event | ColumnsResized | Occurs after the ActualWidth of one or more columns changes.
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | ItemCollapsed | Occurs after an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemCollapsing | Occurs before an item is collapsed. (Inherited from TreeListBox.)
Public event | ItemDefaultActionExecuting | Occurs before the default action is executed for an item. (Inherited from TreeListBox.)
Public event | ItemExpanded | Occurs after an item is expanded. (Inherited from TreeListBox.)
Public event | ItemExpanding | Occurs before an item is expanded. (Inherited from TreeListBox.)
Public event | ItemMenuRequested | Occurs when an item requests a context menu. (Inherited from TreeListBox.)
Public event | ItemSelecting | Occurs before an item is selected. (Inherited from TreeListBox.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | RootItemChanged | Occurs when the RootItem property is changed. (Inherited from TreeListBox.)
Public event | SelectionChanged | Occurs when the selection is changed. (Inherited from TreeListBox.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ColumnHeaderMenuRequested Event

TreeListViewColumnHeaderMenuRequested Event
Occurs when a column header requests a context menu.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnMenuEventArgs> ColumnHeaderMenuRequested
Public Event ColumnHeaderMenuRequested As EventHandler(Of TreeListViewColumnMenuEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnMenuEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ColumnIsVisibleChanged Event

TreeListViewColumnIsVisibleChanged Event
Occurs when a column's visibility has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnEventArgs> ColumnIsVisibleChanged
Public Event ColumnIsVisibleChanged As EventHandler(Of TreeListViewColumnEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ColumnReordered Event

TreeListViewColumnReordered Event
Occurs after a column is reordered by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TreeListViewColumnEventArgs> ColumnReordered
Public Event ColumnReordered As EventHandler(Of TreeListViewColumnEventArgs)

Value

Type: SystemEventHandler TreeListViewColumnEventArgs
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ColumnsResized Event

TreeListViewColumnsResized Event
Occurs after the ActualWidth of one or more columns changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event RoutedEventHandler ColumnsResized
Public Event ColumnsResized As RoutedEventHandler

Value

Type: Windows.UI.XamlRoutedEventHandler
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView Fields

TreeListView Fields

The TreeListView type exposes the following members.

Fields
Name | Description
AreColumnHeadersVisibleProperty | Identifies the AreColumnHeadersVisible dependency property. This field is read-only.
CanColumnsReorderProperty | Identifies the CanColumnsReorder dependency property. This field is read-only.
CanColumnsResizeProperty | Identifies the CanColumnsResize dependency property. This field is read-only.
CanColumnsToggleVisibilityProperty | Identifies the CanColumnsToggleVisibility dependency property. This field is read-only.
ColumnHeaderVisibilityProperty | Identifies the ColumnHeaderVisibility dependency property. This field is read-only.
ExpansionColumnIndexProperty | Identifies the ExpansionColumnIndex dependency property. This field is read-only.
FrozenColumnCountProperty | Identifies the FrozenColumnCount dependency property. This field is read-only.
FrozenColumnsWidthProperty | Identifies the FrozenColumnsWidth dependency property. This field is read-only.
IsDefaultColumnHeaderContextMenuEnabledProperty | Identifies the IsDefaultColumnHeaderContextMenuEnabled dependency property. This field is read-only.
Top
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.AreColumnHeadersVisibleProperty Field

TreeListViewAreColumnHeadersVisibleProperty Field
Identifies the AreColumnHeadersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreColumnHeadersVisibleProperty
Public Shared ReadOnly AreColumnHeadersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreColumnHeadersVisible dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.CanColumnsReorderProperty Field

TreeListViewCanColumnsReorderProperty Field
Identifies the CanColumnsReorder dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanColumnsReorderProperty
Public Shared ReadOnly CanColumnsReorderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanColumnsReorder dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.CanColumnsResizeProperty Field

TreeListViewCanColumnsResizeProperty Field
Identifies the CanColumnsResize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanColumnsResizeProperty
Public Shared ReadOnly CanColumnsResizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanColumnsResize dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.CanColumnsToggleVisibilityProperty Field

TreeListViewCanColumnsToggleVisibilityProperty Field
Identifies the CanColumnsToggleVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanColumnsToggleVisibilityProperty
Public Shared ReadOnly CanColumnsToggleVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanColumnsToggleVisibility dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ColumnHeaderVisibilityProperty Field

TreeListViewColumnHeaderVisibilityProperty Field
Identifies the ColumnHeaderVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColumnHeaderVisibilityProperty
Public Shared ReadOnly ColumnHeaderVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColumnHeaderVisibility dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.ExpansionColumnIndexProperty Field

TreeListViewExpansionColumnIndexProperty Field
Identifies the ExpansionColumnIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ExpansionColumnIndexProperty
Public Shared ReadOnly ExpansionColumnIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ExpansionColumnIndex dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.FrozenColumnCountProperty Field

TreeListViewFrozenColumnCountProperty Field
Identifies the FrozenColumnCount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FrozenColumnCountProperty
Public Shared ReadOnly FrozenColumnCountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FrozenColumnCount dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.FrozenColumnsWidthProperty Field

TreeListViewFrozenColumnsWidthProperty Field
Identifies the FrozenColumnsWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FrozenColumnsWidthProperty
Public Shared ReadOnly FrozenColumnsWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FrozenColumnsWidth dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListView.IsDefaultColumnHeaderContextMenuEnabledProperty Field

TreeListViewIsDefaultColumnHeaderContextMenuEnabledProperty Field
Identifies the IsDefaultColumnHeaderContextMenuEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDefaultColumnHeaderContextMenuEnabledProperty
Public Shared ReadOnly IsDefaultColumnHeaderContextMenuEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDefaultColumnHeaderContextMenuEnabled dependency property.
See Also

Reference

TreeListView Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn Class

TreeListViewColumn Class
Represents a column definition for a TreeListView control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewColumn : DependencyObject,
    INotifyPropertyChanged
Public Class TreeListViewColumn
    Inherits DependencyObject
    Implements INotifyPropertyChanged

The TreeListViewColumn type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumn | Initializes an instance of the TreeListViewColumn class.
Top
Properties
 | Name | Description
Public property | ActualWidth | Gets the actual width of the column.
Public property | AutoWidthMode | Gets or sets the TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.
Public property | CanReorder | Gets or sets whether the column can be reordered by the end user.
Public property | CanResize | Gets or sets whether the column can be resized by the end user.
Public property | CanToggleVisibility | Gets or sets whether the column can have its visibility toggled by the end user.
Public property | CellBorderThickness | Gets or sets the Thickness of the border around cells in this column.
Public property | CellContainerStyle | Gets or sets the Style that defines the visual representation of the column's cells.
Public property | CellHorizontalAlignment | Gets or sets the HorizontalAlignment of the cell content in this column.
Public property | CellPadding | Gets or sets the Thickness of the padding in cells in this column.
Public property | CellTemplate | Gets or sets the DataTemplate that defines the visual representation of the column's cells.
Public property | CellTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column's cells.
Public property | ClipX | Gets the clip x-location.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberBinding | Gets or sets the data item to bind to for this column.
Public property | Header | Gets or sets the column header content.
Public property | HeaderCellBorderThickness | Gets or sets the Thickness of the border around the header cell in this column.
Public property | HeaderCellPadding | Gets or sets the Thickness of the padding in the header cell in this column.
Public property | HeaderContainerStyle | Gets or sets the Style to use for the column header container.
Public property | HeaderHorizontalAlignment | Gets or sets the HorizontalAlignment of the column header content.
Public property | HeaderTemplate | Gets or sets the DataTemplate that defines the visual representation of the column header.
Public property | HeaderTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column header.
Public property | Index | Gets the index of the column within its owner control.
Public property | IsFrozen | Gets whether the column is frozen.
Public property | IsResizeGripperEnabled | Gets whether the column's resize gripper is enabled.
Public property | IsVisible | Gets or sets whether the column is visible.
Public property | MaxWidth | Gets or sets the maximum column width.
Public property | MinWidth | Gets or sets the minimum column width.
Public property | SizeToFitCommand | Gets the ICommand that adjusts the width of the column to fit all of its contents.
Public property | Title | Gets or sets the string title of the column, used in context menus and other secondary UI, but not visible within the column itself.
Public property | ToggleVisibilityCommand | Gets the ICommand that can be used to toggle the column's visibility.
Public property | Width | Gets or sets the column width.
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | SizeToFit | Adjusts the width of the column to fit all of its contents.
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
Fields
Name | Description
AutoWidthModeProperty | Identifies the AutoWidthMode dependency property. This field is read-only.
CanReorderProperty | Identifies the CanReorder dependency property. This field is read-only.
CanResizeProperty | Identifies the CanResize dependency property. This field is read-only.
CanToggleVisibilityProperty | Identifies the CanToggleVisibility dependency property. This field is read-only.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. This field is read-only.
CellContainerStyleProperty | Identifies the CellContainerStyle dependency property. This field is read-only.
CellHorizontalAlignmentProperty | Identifies the CellHorizontalAlignment dependency property. This field is read-only.
CellPaddingProperty | Identifies the CellPadding dependency property. This field is read-only.
CellTemplateProperty | Identifies the CellTemplate dependency property. This field is read-only.
CellTemplateSelectorProperty | Identifies the CellTemplateSelector dependency property. This field is read-only.
HeaderCellBorderThicknessProperty | Identifies the HeaderCellBorderThickness dependency property. This field is read-only.
HeaderCellPaddingProperty | Identifies the HeaderCellPadding dependency property. This field is read-only.
HeaderContainerStyleProperty | Identifies the HeaderContainerStyle dependency property. This field is read-only.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property. This field is read-only.
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property. This field is read-only.
IndexProperty | Identifies the Index dependency property. This field is read-only.
IsFrozenProperty | Identifies the IsFrozen dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
IsVisibleProperty | Identifies the IsVisible dependency property. This field is read-only.
MaxWidthProperty | Identifies the MaxWidth dependency property. This field is read-only.
MinWidthProperty | Identifies the MinWidth dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
WidthProperty | Identifies the Width dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn Constructor

TreeListViewColumn Constructor
Initializes an instance of the TreeListViewColumn class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumn()
Public Sub New
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn Properties

TreeListViewColumn Properties

The TreeListViewColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | Gets the actual width of the column.
Public property | AutoWidthMode | Gets or sets the TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.
Public property | CanReorder | Gets or sets whether the column can be reordered by the end user.
Public property | CanResize | Gets or sets whether the column can be resized by the end user.
Public property | CanToggleVisibility | Gets or sets whether the column can have its visibility toggled by the end user.
Public property | CellBorderThickness | Gets or sets the Thickness of the border around cells in this column.
Public property | CellContainerStyle | Gets or sets the Style that defines the visual representation of the column's cells.
Public property | CellHorizontalAlignment | Gets or sets the HorizontalAlignment of the cell content in this column.
Public property | CellPadding | Gets or sets the Thickness of the padding in cells in this column.
Public property | CellTemplate | Gets or sets the DataTemplate that defines the visual representation of the column's cells.
Public property | CellTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column's cells.
Public property | ClipX | Gets the clip x-location.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayMemberBinding | Gets or sets the data item to bind to for this column.
Public property | Header | Gets or sets the column header content.
Public property | HeaderCellBorderThickness | Gets or sets the Thickness of the border around the header cell in this column.
Public property | HeaderCellPadding | Gets or sets the Thickness of the padding in the header cell in this column.
Public property | HeaderContainerStyle | Gets or sets the Style to use for the column header container.
Public property | HeaderHorizontalAlignment | Gets or sets the HorizontalAlignment of the column header content.
Public property | HeaderTemplate | Gets or sets the DataTemplate that defines the visual representation of the column header.
Public property | HeaderTemplateSelector | Gets or sets the DataTemplateSelector that selects which template to use for the column header.
Public property | Index | Gets the index of the column within its owner control.
Public property | IsFrozen | Gets whether the column is frozen.
Public property | IsResizeGripperEnabled | Gets whether the column's resize gripper is enabled.
Public property | IsVisible | Gets or sets whether the column is visible.
Public property | MaxWidth | Gets or sets the maximum column width.
Public property | MinWidth | Gets or sets the minimum column width.
Public property | SizeToFitCommand | Gets the ICommand that adjusts the width of the column to fit all of its contents.
Public property | Title | Gets or sets the string title of the column, used in context menus and other secondary UI, but not visible within the column itself.
Public property | ToggleVisibilityCommand | Gets the ICommand that can be used to toggle the column's visibility.
Public property | Width | Gets or sets the column width.
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.ActualWidth Property

TreeListViewColumnActualWidth Property
Gets the actual width of the column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ActualWidth { get; }
Public ReadOnly Property ActualWidth As Double
    Get

Property Value

Type: Double
The actual width of the column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.AutoWidthMode Property

TreeListViewColumnAutoWidthMode Property
Gets or sets the TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumnAutoWidthMode AutoWidthMode { get; set; }
Public Property AutoWidthMode As TreeListViewColumnAutoWidthMode
    Get
    Set

Property Value

Type: TreeListViewColumnAutoWidthMode
The TreeListViewColumnAutoWidthMode that specifies which column cells are used to calculate auto-width when Width is Auto.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CanReorder Property

TreeListViewColumnCanReorder Property
Gets or sets whether the column can be reordered by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanReorder { get; set; }
Public Property CanReorder As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the column can be reordered by the end user.
Remarks
If set to , the resolved value will use the global CanColumnsReorder setting.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CanResize Property

TreeListViewColumnCanResize Property
Gets or sets whether the column can be resized by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanResize { get; set; }
Public Property CanResize As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the column can be resized by the end user.
Remarks
If set to , the resolved value will use the global CanColumnsResize setting.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CanToggleVisibility Property

TreeListViewColumnCanToggleVisibility Property
Gets or sets whether the column can have its visibility toggled by the end user.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<bool> CanToggleVisibility { get; set; }
Public Property CanToggleVisibility As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable Boolean
A nullable Boolean that indicates whether the column can have its visibility toggled by the end user.
Remarks
If set to , the resolved value will use the global CanColumnsToggleVisibility setting.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellBorderThickness Property

TreeListViewColumnCellBorderThickness Property
Gets or sets the Thickness of the border around cells in this column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness CellBorderThickness { get; set; }
Public Property CellBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the border around cells in this column. The default value is 0.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellContainerStyle Property

TreeListViewColumnCellContainerStyle Property
Gets or sets the Style that defines the visual representation of the column's cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style CellContainerStyle { get; set; }
Public Property CellContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style that defines the visual representation of the column's cells.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellHorizontalAlignment Property

TreeListViewColumnCellHorizontalAlignment Property
Gets or sets the HorizontalAlignment of the cell content in this column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HorizontalAlignment CellHorizontalAlignment { get; set; }
Public Property CellHorizontalAlignment As HorizontalAlignment
    Get
    Set

Property Value

Type: HorizontalAlignment
The HorizontalAlignment of the cell content in this column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellPadding Property

TreeListViewColumnCellPadding Property
Gets or sets the Thickness of the padding in cells in this column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness CellPadding { get; set; }
Public Property CellPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the padding in cells in this column. The default value is 7, 2.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellTemplate Property

TreeListViewColumnCellTemplate Property
Gets or sets the DataTemplate that defines the visual representation of the column's cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate CellTemplate { get; set; }
Public Property CellTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate that defines the visual representation of the column's cells.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellTemplateSelector Property

TreeListViewColumnCellTemplateSelector Property
Gets or sets the DataTemplateSelector that selects which template to use for the column's cells.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector CellTemplateSelector { get; set; }
Public Property CellTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector that selects which template to use for the column's cells.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.ClipX Property

TreeListViewColumnClipX Property
Gets the clip x-location.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ClipX { get; }
Public ReadOnly Property ClipX As Double
    Get

Property Value

Type: Double
The clip x-location.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.DisplayMemberBinding Property

TreeListViewColumnDisplayMemberBinding Property
Gets or sets the data item to bind to for this column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BindingBase DisplayMemberBinding { get; set; }
Public Property DisplayMemberBinding As BindingBase
    Get
    Set

Property Value

Type: BindingBase
The data item to bind to for this column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.Header Property

TreeListViewColumnHeader Property
Gets or sets the column header content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Header { get; set; }
Public Property Header As Object
    Get
    Set

Property Value

Type: Object
The column header content.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderCellBorderThickness Property

TreeListViewColumnHeaderCellBorderThickness Property
Gets or sets the Thickness of the border around the header cell in this column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness HeaderCellBorderThickness { get; set; }
Public Property HeaderCellBorderThickness As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the border around the header cell in this column. The default value is 0, 0, 1, 1.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderCellPadding Property

TreeListViewColumnHeaderCellPadding Property
Gets or sets the Thickness of the padding in the header cell in this column.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness HeaderCellPadding { get; set; }
Public Property HeaderCellPadding As Thickness
    Get
    Set

Property Value

Type: Thickness
The Thickness of the padding in the header cell in this column. The default value is 7, 2.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderContainerStyle Property

TreeListViewColumnHeaderContainerStyle Property
Gets or sets the Style to use for the column header container.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style HeaderContainerStyle { get; set; }
Public Property HeaderContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for the column header container.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderHorizontalAlignment Property

TreeListViewColumnHeaderHorizontalAlignment Property
Gets or sets the HorizontalAlignment of the column header content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public HorizontalAlignment HeaderHorizontalAlignment { get; set; }
Public Property HeaderHorizontalAlignment As HorizontalAlignment
    Get
    Set

Property Value

Type: HorizontalAlignment
The HorizontalAlignment of the column header content.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplate Property

TreeListViewColumnHeaderTemplate Property
Gets or sets the DataTemplate that defines the visual representation of the column header.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate HeaderTemplate { get; set; }
Public Property HeaderTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate that defines the visual representation of the column header.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplateSelector Property

TreeListViewColumnHeaderTemplateSelector Property
Gets or sets the DataTemplateSelector that selects which template to use for the column header.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector HeaderTemplateSelector { get; set; }
Public Property HeaderTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector that selects which template to use for the column header.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.Index Property

TreeListViewColumnIndex Property
Gets the index of the column within its owner control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the column within its owner control.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IsFrozen Property

TreeListViewColumnIsFrozen Property
Gets whether the column is frozen.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsFrozen { get; }
Public ReadOnly Property IsFrozen As Boolean
    Get

Property Value

Type: Boolean
true if the column is frozen; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IsResizeGripperEnabled Property

TreeListViewColumnIsResizeGripperEnabled Property
Gets whether the column's resize gripper is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsResizeGripperEnabled { get; }
Public ReadOnly Property IsResizeGripperEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the column's resize gripper is enabled; otherwise, false. The default value is true.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IsVisible Property

TreeListViewColumnIsVisible Property
Gets or sets whether the column is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the column is visible; otherwise, false. The default value is true.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.MaxWidth Property

TreeListViewColumnMaxWidth Property
Gets or sets the maximum column width.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MaxWidth { get; set; }
Public Property MaxWidth As Double
    Get
    Set

Property Value

Type: Double
The maximum column width. The default value is NaN, meaning no maximum.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.MinWidth Property

TreeListViewColumnMinWidth Property
Gets or sets the minimum column width.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinWidth { get; set; }
Public Property MinWidth As Double
    Get
    Set

Property Value

Type: Double
The minimum column width. The default value is 30.0.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.SizeToFitCommand Property

TreeListViewColumnSizeToFitCommand Property
Gets the ICommand that adjusts the width of the column to fit all of its contents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand SizeToFitCommand { get; }
Public ReadOnly Property SizeToFitCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that adjusts the width of the column to fit all of its contents.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.Title Property

TreeListViewColumnTitle Property
Gets or sets the string title of the column, used in context menus and other secondary UI, but not visible within the column itself.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
The title of the column.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.ToggleVisibilityCommand Property

TreeListViewColumnToggleVisibilityCommand Property
Gets the ICommand that can be used to toggle the column's visibility.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ToggleVisibilityCommand { get; }
Public ReadOnly Property ToggleVisibilityCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to toggle the column's visibility.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.Width Property

TreeListViewColumnWidth Property
Gets or sets the column width.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GridLength Width { get; set; }
Public Property Width As GridLength
    Get
    Set

Property Value

Type: GridLength
The column width. The default value is Auto.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn Methods

TreeListViewColumn Methods

The TreeListViewColumn type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | SizeToFit | Adjusts the width of the column to fit all of its contents.
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.SizeToFit Method

TreeListViewColumnSizeToFit Method
Adjusts the width of the column to fit all of its contents.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void SizeToFit()
Public Sub SizeToFit
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn Events

TreeListViewColumn Events

The TreeListViewColumn type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.PropertyChanged Event

TreeListViewColumnPropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn Fields

TreeListViewColumn Fields

The TreeListViewColumn type exposes the following members.

Fields
Name | Description
AutoWidthModeProperty | Identifies the AutoWidthMode dependency property. This field is read-only.
CanReorderProperty | Identifies the CanReorder dependency property. This field is read-only.
CanResizeProperty | Identifies the CanResize dependency property. This field is read-only.
CanToggleVisibilityProperty | Identifies the CanToggleVisibility dependency property. This field is read-only.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. This field is read-only.
CellContainerStyleProperty | Identifies the CellContainerStyle dependency property. This field is read-only.
CellHorizontalAlignmentProperty | Identifies the CellHorizontalAlignment dependency property. This field is read-only.
CellPaddingProperty | Identifies the CellPadding dependency property. This field is read-only.
CellTemplateProperty | Identifies the CellTemplate dependency property. This field is read-only.
CellTemplateSelectorProperty | Identifies the CellTemplateSelector dependency property. This field is read-only.
HeaderCellBorderThicknessProperty | Identifies the HeaderCellBorderThickness dependency property. This field is read-only.
HeaderCellPaddingProperty | Identifies the HeaderCellPadding dependency property. This field is read-only.
HeaderContainerStyleProperty | Identifies the HeaderContainerStyle dependency property. This field is read-only.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property. This field is read-only.
HeaderProperty | Identifies the Header dependency property. This field is read-only.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. This field is read-only.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector dependency property. This field is read-only.
IndexProperty | Identifies the Index dependency property. This field is read-only.
IsFrozenProperty | Identifies the IsFrozen dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
IsVisibleProperty | Identifies the IsVisible dependency property. This field is read-only.
MaxWidthProperty | Identifies the MaxWidth dependency property. This field is read-only.
MinWidthProperty | Identifies the MinWidth dependency property. This field is read-only.
TitleProperty | Identifies the Title dependency property. This field is read-only.
WidthProperty | Identifies the Width dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.AutoWidthModeProperty Field

TreeListViewColumnAutoWidthModeProperty Field
Identifies the AutoWidthMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AutoWidthModeProperty
Public Shared ReadOnly AutoWidthModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AutoWidthMode dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CanReorderProperty Field

TreeListViewColumnCanReorderProperty Field
Identifies the CanReorder dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanReorderProperty
Public Shared ReadOnly CanReorderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanReorder dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CanResizeProperty Field

TreeListViewColumnCanResizeProperty Field
Identifies the CanResize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanResizeProperty
Public Shared ReadOnly CanResizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanResize dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CanToggleVisibilityProperty Field

TreeListViewColumnCanToggleVisibilityProperty Field
Identifies the CanToggleVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanToggleVisibilityProperty
Public Shared ReadOnly CanToggleVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanToggleVisibility dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellBorderThicknessProperty Field

TreeListViewColumnCellBorderThicknessProperty Field
Identifies the CellBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellBorderThicknessProperty
Public Shared ReadOnly CellBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellBorderThickness dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellContainerStyleProperty Field

TreeListViewColumnCellContainerStyleProperty Field
Identifies the CellContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellContainerStyleProperty
Public Shared ReadOnly CellContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellContainerStyle dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellHorizontalAlignmentProperty Field

TreeListViewColumnCellHorizontalAlignmentProperty Field
Identifies the CellHorizontalAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellHorizontalAlignmentProperty
Public Shared ReadOnly CellHorizontalAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellHorizontalAlignment dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellPaddingProperty Field

TreeListViewColumnCellPaddingProperty Field
Identifies the CellPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellPaddingProperty
Public Shared ReadOnly CellPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellPadding dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellTemplateProperty Field

TreeListViewColumnCellTemplateProperty Field
Identifies the CellTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellTemplateProperty
Public Shared ReadOnly CellTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellTemplate dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.CellTemplateSelectorProperty Field

TreeListViewColumnCellTemplateSelectorProperty Field
Identifies the CellTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CellTemplateSelectorProperty
Public Shared ReadOnly CellTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CellTemplateSelector dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderCellBorderThicknessProperty Field

TreeListViewColumnHeaderCellBorderThicknessProperty Field
Identifies the HeaderCellBorderThickness dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderCellBorderThicknessProperty
Public Shared ReadOnly HeaderCellBorderThicknessProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderCellBorderThickness dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderCellPaddingProperty Field

TreeListViewColumnHeaderCellPaddingProperty Field
Identifies the HeaderCellPadding dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderCellPaddingProperty
Public Shared ReadOnly HeaderCellPaddingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderCellPadding dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderContainerStyleProperty Field

TreeListViewColumnHeaderContainerStyleProperty Field
Identifies the HeaderContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderContainerStyleProperty
Public Shared ReadOnly HeaderContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderContainerStyle dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderHorizontalAlignmentProperty Field

TreeListViewColumnHeaderHorizontalAlignmentProperty Field
Identifies the HeaderHorizontalAlignment dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderHorizontalAlignmentProperty
Public Shared ReadOnly HeaderHorizontalAlignmentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderHorizontalAlignment dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderProperty Field

TreeListViewColumnHeaderProperty Field
Identifies the Header dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderProperty
Public Shared ReadOnly HeaderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Header dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplateProperty Field

TreeListViewColumnHeaderTemplateProperty Field
Identifies the HeaderTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateProperty
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplate dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.HeaderTemplateSelectorProperty Field

TreeListViewColumnHeaderTemplateSelectorProperty Field
Identifies the HeaderTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HeaderTemplateSelectorProperty
Public Shared ReadOnly HeaderTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HeaderTemplateSelector dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IndexProperty Field

TreeListViewColumnIndexProperty Field
Identifies the Index dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndexProperty
Public Shared ReadOnly IndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Index dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IsFrozenProperty Field

TreeListViewColumnIsFrozenProperty Field
Identifies the IsFrozen dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsFrozenProperty
Public Shared ReadOnly IsFrozenProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsFrozen dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IsResizeGripperEnabledProperty Field

TreeListViewColumnIsResizeGripperEnabledProperty Field
Identifies the IsResizeGripperEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizeGripperEnabledProperty
Public Shared ReadOnly IsResizeGripperEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizeGripperEnabled dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.IsVisibleProperty Field

TreeListViewColumnIsVisibleProperty Field
Identifies the IsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsVisibleProperty
Public Shared ReadOnly IsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsVisible dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.MaxWidthProperty Field

TreeListViewColumnMaxWidthProperty Field
Identifies the MaxWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxWidthProperty
Public Shared ReadOnly MaxWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxWidth dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.MinWidthProperty Field

TreeListViewColumnMinWidthProperty Field
Identifies the MinWidth dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinWidthProperty
Public Shared ReadOnly MinWidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinWidth dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.TitleProperty Field

TreeListViewColumnTitleProperty Field
Identifies the Title dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TitleProperty
Public Shared ReadOnly TitleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Title dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumn.WidthProperty Field

TreeListViewColumnWidthProperty Field
Identifies the Width dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WidthProperty
Public Shared ReadOnly WidthProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Width dependency property.
See Also

Reference

TreeListViewColumn Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode Class

TreeListViewColumnAutoWidthMode Class
Specifies which column cells are used to calculate auto-width.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnAutoWidthMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeListViewColumnAutoWidthMode : Enum
Public NotInheritable Class TreeListViewColumnAutoWidthMode
    Inherits Enum

The TreeListViewColumnAutoWidthMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Both | Both the header and item cells in this column are used to calculate the width.
 | HeaderOnly | Only the header cells in this column are used to calculate the width.
 | ItemsOnly | Only the item cells in this column are used to calculate the width.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode Methods

TreeListViewColumnAutoWidthMode Methods

The TreeListViewColumnAutoWidthMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeListViewColumnAutoWidthMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode Fields

TreeListViewColumnAutoWidthMode Fields

The TreeListViewColumnAutoWidthMode type exposes the following members.

Fields
 | Name | Description
 | Both | Both the header and item cells in this column are used to calculate the width.
 | HeaderOnly | Only the header cells in this column are used to calculate the width.
 | ItemsOnly | Only the item cells in this column are used to calculate the width.
Public field | value__ |
Top
See Also

Reference

TreeListViewColumnAutoWidthMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode.Both Field

TreeListViewColumnAutoWidthModeBoth Field
Both the header and item cells in this column are used to calculate the width.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeListViewColumnAutoWidthMode Both = 0
Public Const Both As TreeListViewColumnAutoWidthMode = 0

Field Value

Type: TreeListViewColumnAutoWidthMode
See Also

Reference

TreeListViewColumnAutoWidthMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode.HeaderOnly Field

TreeListViewColumnAutoWidthModeHeaderOnly Field
Only the header cells in this column are used to calculate the width.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeListViewColumnAutoWidthMode HeaderOnly = 1
Public Const HeaderOnly As TreeListViewColumnAutoWidthMode = 1

Field Value

Type: TreeListViewColumnAutoWidthMode
See Also

Reference

TreeListViewColumnAutoWidthMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode.ItemsOnly Field

TreeListViewColumnAutoWidthModeItemsOnly Field
Only the item cells in this column are used to calculate the width.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeListViewColumnAutoWidthMode ItemsOnly = 2
Public Const ItemsOnly As TreeListViewColumnAutoWidthMode = 2

Field Value

Type: TreeListViewColumnAutoWidthMode
See Also

Reference

TreeListViewColumnAutoWidthMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnAutoWidthMode.value__ Field

TreeListViewColumnAutoWidthModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeListViewColumnAutoWidthMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeListViewColumnAutoWidthMode Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnEventArgs Class

TreeListViewColumnEventArgs Class
Provides event arguments for TreeListViewColumn events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnMenuEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewColumnEventArgs : CancelableEventArgs
Public Class TreeListViewColumnEventArgs
    Inherits CancelableEventArgs

The TreeListViewColumnEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnEventArgs | Initializes a new instance of the TreeListViewColumnEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Column | Gets the target TreeListViewColumn.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnEventArgs Constructor

TreeListViewColumnEventArgs Constructor
Initializes a new instance of the TreeListViewColumnEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumnEventArgs(
    TreeListViewColumn column
)
Public Sub New (
    column As TreeListViewColumn
)

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The target TreeListViewColumn.
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnEventArgs Properties

TreeListViewColumnEventArgs Properties

The TreeListViewColumnEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Column | Gets the target TreeListViewColumn.
Top
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnEventArgs.Column Property

TreeListViewColumnEventArgsColumn Property
Gets the target TreeListViewColumn.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumn Column { get; }
Public ReadOnly Property Column As TreeListViewColumn
    Get

Property Value

Type: TreeListViewColumn
The target TreeListViewColumn.
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnEventArgs Methods

TreeListViewColumnEventArgs Methods

The TreeListViewColumnEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeListViewColumnEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader Class

TreeListViewColumnHeader Class
Represents an item for a TreeListBox control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnHeader

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewColumnHeader : ContentControl
Public Class TreeListViewColumnHeader
    Inherits ContentControl

The TreeListViewColumnHeader type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnHeader | Initializes an instance of the TreeListViewColumnHeader class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDragging | Gets whether the control is being dragged.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPressed | Gets whether the control is pressed.
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Role | Gets or sets a TreeListViewColumnHeaderRole that indicates the role of the column header.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Occurs when a pointer button is released over the control. (Overrides ControlOnPointerReleased(PointerRoutedEventArgs).)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
RoleProperty | Identifies the Role dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader Constructor

TreeListViewColumnHeader Constructor
Initializes an instance of the TreeListViewColumnHeader class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumnHeader()
Public Sub New
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader Properties

TreeListViewColumnHeader Properties

The TreeListViewColumnHeader type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDragging | Gets whether the control is being dragged.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPressed | Gets whether the control is pressed.
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Role | Gets or sets a TreeListViewColumnHeaderRole that indicates the role of the column header.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.DropIndicatorArea Property

TreeListViewColumnHeaderDropIndicatorArea Property
Gets a TreeItemDropArea that specifies the drop indicator to display.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeItemDropArea DropIndicatorArea { get; }
Public ReadOnly Property DropIndicatorArea As TreeItemDropArea
    Get

Property Value

Type: TreeItemDropArea
The TreeItemDropArea that specifies the drop indicator to display.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.IsDragging Property

TreeListViewColumnHeaderIsDragging Property
Gets whether the control is being dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get

Property Value

Type: Boolean
true if the control is being dragged; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.IsPressed Property

TreeListViewColumnHeaderIsPressed Property
Gets whether the control is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPressed { get; }
Public ReadOnly Property IsPressed As Boolean
    Get

Property Value

Type: Boolean
true if the control is pressed; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.IsResizeGripperEnabled Property

TreeListViewColumnHeaderIsResizeGripperEnabled Property
Gets whether the resizing header gripper is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsResizeGripperEnabled { get; }
Public ReadOnly Property IsResizeGripperEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the resizing header gripper is enabled; otherwise, false. The default value is false.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.Role Property

TreeListViewColumnHeaderRole Property
Gets or sets a TreeListViewColumnHeaderRole that indicates the role of the column header.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumnHeaderRole Role { get; set; }
Public Property Role As TreeListViewColumnHeaderRole
    Get
    Set

Property Value

Type: TreeListViewColumnHeaderRole
A TreeListViewColumnHeaderRole that indicates the role of the column header. The default value is Normal.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader Methods

TreeListViewColumnHeader Methods

The TreeListViewColumnHeader type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Occurs when a pointer button is released over the control. (Overrides ControlOnPointerReleased(PointerRoutedEventArgs).)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.OnApplyTemplate Method

TreeListViewColumnHeaderOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.OnGotFocus Method

TreeListViewColumnHeaderOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.OnLostFocus Method

TreeListViewColumnHeaderOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.OnPointerReleased Method

TreeListViewColumnHeaderOnPointerReleased Method
Occurs when a pointer button is released over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerReleased(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerReleased (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.ToString Method

TreeListViewColumnHeaderToString Method
Returns a String that represents the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader Events

TreeListViewColumnHeader Events

The TreeListViewColumnHeader type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader Fields

TreeListViewColumnHeader Fields

The TreeListViewColumnHeader type exposes the following members.

Fields
Name | Description
DropIndicatorAreaProperty | Identifies the DropIndicatorArea dependency property. This field is read-only.
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
IsPressedProperty | Identifies the IsPressed dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
RoleProperty | Identifies the Role dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.DropIndicatorAreaProperty Field

TreeListViewColumnHeaderDropIndicatorAreaProperty Field
Identifies the DropIndicatorArea dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DropIndicatorAreaProperty
Public Shared ReadOnly DropIndicatorAreaProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DropIndicatorArea dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.IsDraggingProperty Field

TreeListViewColumnHeaderIsDraggingProperty Field
Identifies the IsDragging dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingProperty
Public Shared ReadOnly IsDraggingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDragging dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.IsPressedProperty Field

TreeListViewColumnHeaderIsPressedProperty Field
Identifies the IsPressed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsPressedProperty
Public Shared ReadOnly IsPressedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsPressed dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.IsResizeGripperEnabledProperty Field

TreeListViewColumnHeaderIsResizeGripperEnabledProperty Field
Identifies the IsResizeGripperEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizeGripperEnabledProperty
Public Shared ReadOnly IsResizeGripperEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizeGripperEnabled dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeader.RoleProperty Field

TreeListViewColumnHeaderRoleProperty Field
Identifies the Role dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty RoleProperty
Public Shared ReadOnly RoleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Role dependency property.
See Also

Reference

TreeListViewColumnHeader Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeaderRole Class

TreeListViewColumnHeaderRole Class
Specifies the role for a TreeListViewColumnHeader within a TreeListView.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnHeaderRole

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeListViewColumnHeaderRole : Enum
Public NotInheritable Class TreeListViewColumnHeaderRole
    Inherits Enum

The TreeListViewColumnHeaderRole type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Normal | A normal column header.
 | Padding | The column header provides padding between the last column and the right end of the control.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeaderRole Methods

TreeListViewColumnHeaderRole Methods

The TreeListViewColumnHeaderRole type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeListViewColumnHeaderRole Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeaderRole Fields

TreeListViewColumnHeaderRole Fields

The TreeListViewColumnHeaderRole type exposes the following members.

Fields
 | Name | Description
 | Normal | A normal column header.
 | Padding | The column header provides padding between the last column and the right end of the control.
Public field | value__ |
Top
See Also

Reference

TreeListViewColumnHeaderRole Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeaderRole.Normal Field

TreeListViewColumnHeaderRoleNormal Field
A normal column header.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeListViewColumnHeaderRole Normal = 0
Public Const Normal As TreeListViewColumnHeaderRole = 0

Field Value

Type: TreeListViewColumnHeaderRole
See Also

Reference

TreeListViewColumnHeaderRole Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeaderRole.Padding Field

TreeListViewColumnHeaderRolePadding Field
The column header provides padding between the last column and the right end of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeListViewColumnHeaderRole Padding = 1
Public Const Padding As TreeListViewColumnHeaderRole = 1

Field Value

Type: TreeListViewColumnHeaderRole
See Also

Reference

TreeListViewColumnHeaderRole Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnHeaderRole.value__ Field

TreeListViewColumnHeaderRolevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeListViewColumnHeaderRole.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeListViewColumnHeaderRole Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Class

TreeListViewColumnMenuEventArgs Class
Provides event arguments for TreeListViewColumn menu events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnEventArgs
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumnMenuEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewColumnMenuEventArgs : TreeListViewColumnEventArgs
Public Class TreeListViewColumnMenuEventArgs
    Inherits TreeListViewColumnEventArgs

The TreeListViewColumnMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnMenuEventArgs | Initializes a new instance of the TreeListViewColumnMenuEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Column | Gets the target TreeListViewColumn. (Inherited from TreeListViewColumnEventArgs.)
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Constructor

TreeListViewColumnMenuEventArgs Constructor
Initializes a new instance of the TreeListViewColumnMenuEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumnMenuEventArgs(
    TreeListViewColumn column
)
Public Sub New (
    column As TreeListViewColumn
)

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The target TreeListViewColumn.
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Properties

TreeListViewColumnMenuEventArgs Properties

The TreeListViewColumnMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Column | Gets the target TreeListViewColumn. (Inherited from TreeListViewColumnEventArgs.)
Public property | Menu | Gets or sets the MenuFlyout that is about to be displayed.
Top
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs.Menu Property

TreeListViewColumnMenuEventArgsMenu Property
Gets or sets the MenuFlyout that is about to be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MenuFlyout Menu { get; set; }
Public Property Menu As MenuFlyout
    Get
    Set

Property Value

Type: MenuFlyout
The MenuFlyout that is about to be displayed.
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewColumnMenuEventArgs Methods

TreeListViewColumnMenuEventArgs Methods

The TreeListViewColumnMenuEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeListViewColumnMenuEventArgs Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItem Class

TreeListViewItem Class
Represents an item for a TreeListView control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListBoxItem
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewItem
ActiproSoftware.UI.Xaml.Controls.GridsPropertyGridItem

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewItem : TreeListBoxItem
Public Class TreeListViewItem
    Inherits TreeListBoxItem

The TreeListViewItem type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItem | Initializes an instance of the TreeListViewItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from TreeListBoxItem.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped. (Inherited from TreeListBoxItem.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Overrides TreeListBoxItemOnIndentAmountChanged.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from TreeListBoxItem.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItem Constructor

TreeListViewItem Constructor
Initializes an instance of the TreeListViewItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewItem()
Public Sub New
See Also

Reference

TreeListViewItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItem Properties

TreeListViewItem Properties

The TreeListViewItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultActionCommand | Gets or sets the ICommand to execute when this node is double-tapped or Enter is pressed while it's focused. (Inherited from TreeListBoxItem.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DropIndicatorArea | Gets a TreeItemDropArea that specifies the drop indicator to display. (Inherited from TreeListBoxItem.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this item's content is indented. (Inherited from TreeListBoxItem.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsExpandable | Gets or sets whether the node is capable of being expanded or collapsed. (Inherited from TreeListBoxItem.)
Public property | IsExpanded | Gets or sets whether the node is expanded. (Inherited from TreeListBoxItem.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectable | Gets or sets whether the node is capable of being selected. (Inherited from TreeListBoxItem.)
Public property | IsSelected | Gets or sets whether the node is selected. (Inherited from TreeListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ToggleExpansionButtonStyle | Gets or sets the Style to use for the toggle expansion button. (Inherited from TreeListBoxItem.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListViewItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItem Methods

TreeListViewItem Methods

The TreeListViewItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from TreeListBoxItem.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped(DoubleTappedRoutedEventArgs) | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDoubleTapped(InputPointerButtonEventArgs) | Occurs when the item is double-tapped. (Inherited from TreeListBoxItem.)
Protected method | OnDragEnter | Occurs when an object is dragged inside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragLeave | Occurs when an object is dragged outside of the control. (Inherited from TreeListBoxItem.)
Protected method | OnDragOver | Occurs when an object is dragged over the control. (Inherited from TreeListBoxItem.)
Protected method | OnDrop | Occurs when an object is dropped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Inherited from TreeListBoxItem.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIndentAmountChanged | Occurs when the IndentAmount property is changed. (Overrides TreeListBoxItemOnIndentAmountChanged.)
Protected method | OnKeyDown | Occurs when a key is pressed. (Inherited from TreeListBoxItem.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Inherited from TreeListBoxItem.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Inherited from TreeListBoxItem.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from TreeListBoxItem.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItem.OnIndentAmountChanged Method

TreeListViewItemOnIndentAmountChanged Method
Occurs when the IndentAmount property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnIndentAmountChanged()
Protected Overrides Sub OnIndentAmountChanged
See Also

Reference

TreeListViewItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItem Events

TreeListViewItem Events

The TreeListViewItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewItem Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Class

TreeListViewItemCell Class
Represents an item for a TreeListView control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewItemCell

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewItemCell : ContentControl
Public Class TreeListViewItemCell
    Inherits ContentControl

The TreeListViewItemCell type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItemCell | Initializes an instance of the TreeListViewItemCell class.
Public method | TreeListViewItemCell(TreeListViewColumn) | Initializes an instance of the TreeListViewItemCell class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Column | Gets the TreeListViewColumn in which the cell resides.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this cell's content is indented.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ColumnProperty | Identifies the Column dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Constructor

TreeListViewItemCell Constructor
Overload List
 | Name | Description
Public method | TreeListViewItemCell | Initializes an instance of the TreeListViewItemCell class.
Public method | TreeListViewItemCell(TreeListViewColumn) | Initializes an instance of the TreeListViewItemCell class.
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Constructor

TreeListViewItemCell Constructor
Initializes an instance of the TreeListViewItemCell class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewItemCell()
Public Sub New
See Also

Reference

TreeListViewItemCell Class
TreeListViewItemCell Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Constructor (TreeListViewColumn)

TreeListViewItemCell Constructor (TreeListViewColumn)
Initializes an instance of the TreeListViewItemCell class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewItemCell(
    TreeListViewColumn column
)
Public Sub New (
    column As TreeListViewColumn
)

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The TreeListViewColumn in which the cell resides.
See Also

Reference

TreeListViewItemCell Class
TreeListViewItemCell Overload
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Properties

TreeListViewItemCell Properties

The TreeListViewItemCell type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Column | Gets the TreeListViewColumn in which the cell resides.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IndentAmount | Gets or sets the amount that this cell's content is indented.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsResizeGripperEnabled | Gets whether the resizing header gripper is enabled.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.Column Property

TreeListViewItemCellColumn Property
Gets the TreeListViewColumn in which the cell resides.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumn Column { get; }
Public ReadOnly Property Column As TreeListViewColumn
    Get

Property Value

Type: TreeListViewColumn
The TreeListViewColumn in which the cell resides.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.IndentAmount Property

TreeListViewItemCellIndentAmount Property
Gets or sets the amount that this cell's content is indented.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double IndentAmount { get; set; }
Public Property IndentAmount As Double
    Get
    Set

Property Value

Type: Double
The amount that this cell's content is indented.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.IsResizeGripperEnabled Property

TreeListViewItemCellIsResizeGripperEnabled Property
Gets whether the resizing header gripper is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsResizeGripperEnabled { get; }
Public ReadOnly Property IsResizeGripperEnabled As Boolean
    Get

Property Value

Type: Boolean
true if the resizing header gripper is enabled; otherwise, false. The default value is false.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Methods

TreeListViewItemCell Methods

The TreeListViewItemCell type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.OnApplyTemplate Method

TreeListViewItemCellOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Events

TreeListViewItemCell Events

The TreeListViewItemCell type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell Fields

TreeListViewItemCell Fields

The TreeListViewItemCell type exposes the following members.

Fields
Name | Description
ColumnProperty | Identifies the Column dependency property. This field is read-only.
IndentAmountProperty | Identifies the IndentAmount dependency property. This field is read-only.
IsResizeGripperEnabledProperty | Identifies the IsResizeGripperEnabled dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.ColumnProperty Field

TreeListViewItemCellColumnProperty Field
Identifies the Column dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColumnProperty
Public Shared ReadOnly ColumnProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Column dependency property.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.IndentAmountProperty Field

TreeListViewItemCellIndentAmountProperty Field
Identifies the IndentAmount dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndentAmountProperty
Public Shared ReadOnly IndentAmountProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndentAmount dependency property.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeListViewItemCell.IsResizeGripperEnabledProperty Field

TreeListViewItemCellIsResizeGripperEnabledProperty Field
Identifies the IsResizeGripperEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizeGripperEnabledProperty
Public Shared ReadOnly IsResizeGripperEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizeGripperEnabled dependency property.
See Also

Reference

TreeListViewItemCell Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind Class

TreeMultiDragKind Class
Specifies the item multi-drag mode for a tree control.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeMultiDragKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeMultiDragKind : Enum
Public NotInheritable Class TreeMultiDragKind
    Inherits Enum

The TreeMultiDragKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Any | Any node can be dragged.
 | None | Drags are not allowed when multiple items are selected. Only single item selection drags are permitted.
 | SameDepth | Any node at the same depth can be dragged.
 | SameType | Any node that is the same type can be dragged.
 | Siblings | Any node that shares the same parent can be dragged.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind Methods

TreeMultiDragKind Methods

The TreeMultiDragKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind Fields

TreeMultiDragKind Fields

The TreeMultiDragKind type exposes the following members.

Fields
 | Name | Description
 | Any | Any node can be dragged.
 | None | Drags are not allowed when multiple items are selected. Only single item selection drags are permitted.
 | SameDepth | Any node at the same depth can be dragged.
 | SameType | Any node that is the same type can be dragged.
 | Siblings | Any node that shares the same parent can be dragged.
Public field | value__ |
Top
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind.Any Field

TreeMultiDragKindAny Field
Any node can be dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiDragKind Any = 1
Public Const Any As TreeMultiDragKind = 1

Field Value

Type: TreeMultiDragKind
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind.None Field

TreeMultiDragKindNone Field
Drags are not allowed when multiple items are selected. Only single item selection drags are permitted.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiDragKind None = 0
Public Const None As TreeMultiDragKind = 0

Field Value

Type: TreeMultiDragKind
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind.SameDepth Field

TreeMultiDragKindSameDepth Field
Any node at the same depth can be dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiDragKind SameDepth = 3
Public Const SameDepth As TreeMultiDragKind = 3

Field Value

Type: TreeMultiDragKind
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind.SameType Field

TreeMultiDragKindSameType Field
Any node that is the same type can be dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiDragKind SameType = 2
Public Const SameType As TreeMultiDragKind = 2

Field Value

Type: TreeMultiDragKind
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind.Siblings Field

TreeMultiDragKindSiblings Field
Any node that shares the same parent can be dragged.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiDragKind Siblings = 4
Public Const Siblings As TreeMultiDragKind = 4

Field Value

Type: TreeMultiDragKind
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiDragKind.value__ Field

TreeMultiDragKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeMultiDragKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeMultiDragKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind Class

TreeMultiSelectionKind Class
Specifies the item multi-select mode for a tree control.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.GridsTreeMultiSelectionKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TreeMultiSelectionKind : Enum
Public NotInheritable Class TreeMultiSelectionKind
    Inherits Enum

The TreeMultiSelectionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Any | Any node can be selected.
 | SameDepth | Any node at the same depth can be selected.
 | SameType | Any node that is the same type can be selected.
 | Siblings | Any node that shares the same parent can be selected.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind Methods

TreeMultiSelectionKind Methods

The TreeMultiSelectionKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind Fields

TreeMultiSelectionKind Fields

The TreeMultiSelectionKind type exposes the following members.

Fields
 | Name | Description
 | Any | Any node can be selected.
 | SameDepth | Any node at the same depth can be selected.
 | SameType | Any node that is the same type can be selected.
 | Siblings | Any node that shares the same parent can be selected.
Public field | value__ |
Top
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind.Any Field

TreeMultiSelectionKindAny Field
Any node can be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiSelectionKind Any = 0
Public Const Any As TreeMultiSelectionKind = 0

Field Value

Type: TreeMultiSelectionKind
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind.SameDepth Field

TreeMultiSelectionKindSameDepth Field
Any node at the same depth can be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiSelectionKind SameDepth = 2
Public Const SameDepth As TreeMultiSelectionKind = 2

Field Value

Type: TreeMultiSelectionKind
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind.SameType Field

TreeMultiSelectionKindSameType Field
Any node that is the same type can be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiSelectionKind SameType = 1
Public Const SameType As TreeMultiSelectionKind = 1

Field Value

Type: TreeMultiSelectionKind
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind.Siblings Field

TreeMultiSelectionKindSiblings Field
Any node that shares the same parent can be selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TreeMultiSelectionKind Siblings = 3
Public Const Siblings As TreeMultiSelectionKind = 3

Field Value

Type: TreeMultiSelectionKind
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


TreeMultiSelectionKind.value__ Field

TreeMultiSelectionKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.TreeMultiSelectionKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TreeMultiSelectionKind Class
ActiproSoftware.UI.Xaml.Controls.Grids Namespace


ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace
Contains the primitive classes used for Grids product controls.
Classes
 | Class | Description
Public class | PropertyGridItemContentPanel | Provides a panel for arranging content that spans the width of a PropertyGridItem.
Public class | PropertyGridItemRowPanel | A panel that arranges the cells within a PropertyGridItem.
Public class | PropertyGridSummaryContentControl | Represents a ContentControl that displays summary content for a PropertyGrid and contains a gripper, allowing it to be resized.
Public class | PropertyGridSummaryResizeGripper | Represents a resize gripper for a PropertyGridSummaryContentControl.
Public class | PropertyValueConverter | Represents the converter that converts a property model value from an object to a target Type.
Public class | TreeItemExpansionToggleButton | Represents a ToggleButton for toggling the expansion state of a tree item.
Public class | TreeListViewColumnResizeGripper | Represents a resize gripper for a TreeListViewColumn.
Public class | TreeListViewHeaderRowPanel | A panel that arranges a TreeListView header.
Public class | TreeListViewItemRowPanel | A panel that arranges the cells within a TreeListViewItem.
Public class | TreeListViewRowPanelBase | Provides a base panel for arranging a TreeListView header and cells within a TreeListViewItem.
Public class | TreeNodeItemCollection | Stores a collection of tree node items.


PropertyGridItemContentPanel Class

PropertyGridItemContentPanel Class
Provides a panel for arranging content that spans the width of a PropertyGridItem.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesPropertyGridItemContentPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemContentPanel : Panel
Public Class PropertyGridItemContentPanel
    Inherits Panel

The PropertyGridItemContentPanel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemContentPanel | Initializes a new instance of the PropertyGridItemContentPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Constructor

PropertyGridItemContentPanel Constructor
Initializes a new instance of the PropertyGridItemContentPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemContentPanel()
Public Sub New
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Properties

PropertyGridItemContentPanel Properties

The PropertyGridItemContentPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Methods

PropertyGridItemContentPanel Methods

The PropertyGridItemContentPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel.ArrangeOverride Method

PropertyGridItemContentPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel.ArrangeOverride Method (Size)

PropertyGridItemContentPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

PropertyGridItemContentPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel.MeasureOverride Method

PropertyGridItemContentPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel.MeasureOverride Method (Size)

PropertyGridItemContentPanelMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

PropertyGridItemContentPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemContentPanel Events

PropertyGridItemContentPanel Events

The PropertyGridItemContentPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridItemContentPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Class

PropertyGridItemRowPanel Class
A panel that arranges the cells within a PropertyGridItem.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewItemRowPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesPropertyGridItemRowPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridItemRowPanel : TreeListViewItemRowPanel
Public Class PropertyGridItemRowPanel
    Inherits TreeListViewItemRowPanel

The PropertyGridItemRowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridItemRowPanel | Initializes a new instance of the PropertyGridItemRowPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets the Brush to use for foregrounds. (Inherited from TreeListViewItemRowPanel.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListViewItemRowPanelArrangeOverride(Size).)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Inherited from TreeListViewItemRowPanel.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides TreeListViewItemRowPanelMeasureOverride(Size).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Inherited from TreeListViewItemRowPanel.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewItemRowPanel.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Inherited from TreeListViewItemRowPanel.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Constructor

PropertyGridItemRowPanel Constructor
Initializes a new instance of the PropertyGridItemRowPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridItemRowPanel()
Public Sub New
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Properties

PropertyGridItemRowPanel Properties

The PropertyGridItemRowPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets the Brush to use for foregrounds. (Inherited from TreeListViewItemRowPanel.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Methods

PropertyGridItemRowPanel Methods

The PropertyGridItemRowPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListViewItemRowPanelArrangeOverride(Size).)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Inherited from TreeListViewItemRowPanel.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides TreeListViewItemRowPanelMeasureOverride(Size).)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Inherited from TreeListViewItemRowPanel.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewItemRowPanel.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Inherited from TreeListViewItemRowPanel.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel.ArrangeOverride Method

PropertyGridItemRowPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Overrides TreeListViewItemRowPanelArrangeOverride(Size).)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel.ArrangeOverride Method (Size)

PropertyGridItemRowPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
Protected Overrides Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

PropertyGridItemRowPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel.MeasureOverride Method

PropertyGridItemRowPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Overrides TreeListViewItemRowPanelMeasureOverride(Size).)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel.MeasureOverride Method (Size)

PropertyGridItemRowPanelMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Size MeasureOverride(
    Size availableSize
)
Protected Overrides Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

PropertyGridItemRowPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridItemRowPanel Events

PropertyGridItemRowPanel Events

The PropertyGridItemRowPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Class

PropertyGridSummaryContentControl Class
Represents a ContentControl that displays summary content for a PropertyGrid and contains a gripper, allowing it to be resized.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesPropertyGridSummaryContentControl

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridSummaryContentControl : ContentControl
Public Class PropertyGridSummaryContentControl
    Inherits ContentControl

The PropertyGridSummaryContentControl type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridSummaryContentControl | Initializes an instance of the PropertyGridSummaryContentControl class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAutoSize | Gets or sets whether the gripper auto-sizes to its content when it is double-tapped.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsResizable | Gets or sets whether the gripper is visible and the control can be resized.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | AutoSize | Auto-sizes the content control to the desired size of its content.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CanAutoSizeProperty | Identifies the CanAutoSize dependency property. This field is read-only.
IsResizableProperty | Identifies the IsResizable dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Constructor

PropertyGridSummaryContentControl Constructor
Initializes an instance of the PropertyGridSummaryContentControl class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridSummaryContentControl()
Public Sub New
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Properties

PropertyGridSummaryContentControl Properties

The PropertyGridSummaryContentControl type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanAutoSize | Gets or sets whether the gripper auto-sizes to its content when it is double-tapped.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsResizable | Gets or sets whether the gripper is visible and the control can be resized.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.CanAutoSize Property

PropertyGridSummaryContentControlCanAutoSize Property
Gets or sets whether the gripper auto-sizes to its content when it is double-tapped.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAutoSize { get; set; }
Public Property CanAutoSize As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the gripper auto-sizes to its content when it is double-tapped; otherwise, false. The default value is true.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.IsResizable Property

PropertyGridSummaryContentControlIsResizable Property
Gets or sets whether the gripper is visible and the control can be resized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsResizable { get; set; }
Public Property IsResizable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the gripper is visible and the control can be resized; otherwise, false. The default value is true.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Methods

PropertyGridSummaryContentControl Methods

The PropertyGridSummaryContentControl type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | AutoSize | Auto-sizes the content control to the desired size of its content.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.AutoSize Method

PropertyGridSummaryContentControlAutoSize Method
Auto-sizes the content control to the desired size of its content.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AutoSize()
Public Sub AutoSize
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.OnApplyTemplate Method

PropertyGridSummaryContentControlOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Events

PropertyGridSummaryContentControl Events

The PropertyGridSummaryContentControl type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl Fields

PropertyGridSummaryContentControl Fields

The PropertyGridSummaryContentControl type exposes the following members.

Fields
Name | Description
CanAutoSizeProperty | Identifies the CanAutoSize dependency property. This field is read-only.
IsResizableProperty | Identifies the IsResizable dependency property. This field is read-only.
Top
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.CanAutoSizeProperty Field

PropertyGridSummaryContentControlCanAutoSizeProperty Field
Identifies the CanAutoSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanAutoSizeProperty
Public Shared ReadOnly CanAutoSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanAutoSize dependency property.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryContentControl.IsResizableProperty Field

PropertyGridSummaryContentControlIsResizableProperty Field
Identifies the IsResizable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsResizableProperty
Public Shared ReadOnly IsResizableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsResizable dependency property.
See Also

Reference

PropertyGridSummaryContentControl Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryResizeGripper Class

PropertyGridSummaryResizeGripper Class
Represents a resize gripper for a PropertyGridSummaryContentControl.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesPropertyGridSummaryResizeGripper

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridSummaryResizeGripper : Control
Public Class PropertyGridSummaryResizeGripper
    Inherits Control

The PropertyGridSummaryResizeGripper type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridSummaryResizeGripper | Initializes an instance of the PropertyGridSummaryResizeGripper class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryResizeGripper Constructor

PropertyGridSummaryResizeGripper Constructor
Initializes an instance of the PropertyGridSummaryResizeGripper class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridSummaryResizeGripper()
Public Sub New
See Also

Reference

PropertyGridSummaryResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryResizeGripper Properties

PropertyGridSummaryResizeGripper Properties

The PropertyGridSummaryResizeGripper type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

PropertyGridSummaryResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryResizeGripper Methods

PropertyGridSummaryResizeGripper Methods

The PropertyGridSummaryResizeGripper type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

PropertyGridSummaryResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyGridSummaryResizeGripper Events

PropertyGridSummaryResizeGripper Events

The PropertyGridSummaryResizeGripper type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyGridSummaryResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyValueConverter Class

PropertyValueConverter Class
Represents the converter that converts a property model value from an object to a target Type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesPropertyValueConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyValueConverter : IValueConverter
Public Class PropertyValueConverter
    Implements IValueConverter

The PropertyValueConverter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyValueConverter | Initializes a new instance of the PropertyValueConverter class
Top
Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyValueConverter Constructor

PropertyValueConverter Constructor
Initializes a new instance of the PropertyValueConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyValueConverter()
Public Sub New
See Also

Reference

PropertyValueConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyValueConverter Methods

PropertyValueConverter Methods

The PropertyValueConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyValueConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyValueConverter.Convert Method

PropertyValueConverterConvert Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function Convert (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

PropertyValueConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


PropertyValueConverter.ConvertBack Method

PropertyValueConverterConvertBack Method
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    string language
)
Public Function ConvertBack (
    value As Object,
    targetType As Type,
    parameter As Object,
    language As String
) As Object

Parameters

value
Type: SystemObject
The value produced by the binding source.
targetType
Type: SystemType
The type of the binding target property.
parameter
Type: SystemObject
The converter parameter to use.
language
Type: SystemString
The language of the conversion.

Return Value

Type: Object
A converted value.
See Also

Reference

PropertyValueConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Class

TreeItemExpansionToggleButton Class
Represents a ToggleButton for toggling the expansion state of a tree item.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
Windows.UI.Xaml.Controls.PrimitivesButtonBase
Windows.UI.Xaml.Controls.PrimitivesToggleButton
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeItemExpansionToggleButton

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeItemExpansionToggleButton : ToggleButton
Public Class TreeItemExpansionToggleButton
    Inherits ToggleButton

The TreeItemExpansionToggleButton type exposes the following members.

Constructors
 | Name | Description
Public method | TreeItemExpansionToggleButton | Initializes an instance of the TreeItemExpansionToggleButton class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClickMode | Gets or sets a value that indicates when the Click event occurs, in terms of device behavior. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPointerOver | Gets a value that indicates whether a device pointer is located over this button control. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently in a pressed state. (Inherited from ButtonBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsThreeState | Gets or sets a value that indicates whether the control supports three states. (Inherited from ToggleButton.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnToggle | Called when the ToggleButton receives toggle stimulus. (Inherited from ToggleButton.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Checked | Fires when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a button control is clicked. (Inherited from ButtonBase.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Indeterminate | Fires when the state of a ToggleButton is switched to the indeterminate state. (Inherited from ToggleButton.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Constructor

TreeItemExpansionToggleButton Constructor
Initializes an instance of the TreeItemExpansionToggleButton class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeItemExpansionToggleButton()
Public Sub New
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Properties

TreeItemExpansionToggleButton Properties

The TreeItemExpansionToggleButton type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | ClickMode | Gets or sets a value that indicates when the Click event occurs, in terms of device behavior. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsPointerOver | Gets a value that indicates whether a device pointer is located over this button control. (Inherited from ButtonBase.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently in a pressed state. (Inherited from ButtonBase.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsThreeState | Gets or sets a value that indicates whether the control supports three states. (Inherited from ToggleButton.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Methods

TreeItemExpansionToggleButton Methods

The TreeItemExpansionToggleButton type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnToggle | Called when the ToggleButton receives toggle stimulus. (Inherited from ToggleButton.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeItemExpansionToggleButton Events

TreeItemExpansionToggleButton Events

The TreeItemExpansionToggleButton type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | Checked | Fires when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a button control is clicked. (Inherited from ButtonBase.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Indeterminate | Fires when the state of a ToggleButton is switched to the indeterminate state. (Inherited from ToggleButton.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeItemExpansionToggleButton Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Class

TreeListViewColumnResizeGripper Class
Represents a resize gripper for a TreeListViewColumn.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewColumnResizeGripper

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewColumnResizeGripper : Control
Public Class TreeListViewColumnResizeGripper
    Inherits Control

The TreeListViewColumnResizeGripper type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewColumnResizeGripper | Initializes an instance of the TreeListViewColumnResizeGripper class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Constructor

TreeListViewColumnResizeGripper Constructor
Initializes an instance of the TreeListViewColumnResizeGripper class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewColumnResizeGripper()
Public Sub New
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Properties

TreeListViewColumnResizeGripper Properties

The TreeListViewColumnResizeGripper type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Methods

TreeListViewColumnResizeGripper Methods

The TreeListViewColumnResizeGripper type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewColumnResizeGripper Events

TreeListViewColumnResizeGripper Events

The TreeListViewColumnResizeGripper type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewColumnResizeGripper Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Class

TreeListViewHeaderRowPanel Class
A panel that arranges a TreeListView header.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewHeaderRowPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewHeaderRowPanel : TreeListViewRowPanelBase
Public Class TreeListViewHeaderRowPanel
    Inherits TreeListViewRowPanelBase

The TreeListViewHeaderRowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewHeaderRowPanel | Initializes a new instance of the TreeListViewHeaderRowPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewRowPanelBase.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Constructor

TreeListViewHeaderRowPanel Constructor
Initializes a new instance of the TreeListViewHeaderRowPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewHeaderRowPanel()
Public Sub New
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Properties

TreeListViewHeaderRowPanel Properties

The TreeListViewHeaderRowPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Methods

TreeListViewHeaderRowPanel Methods

The TreeListViewHeaderRowPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Inherited from TreeListViewRowPanelBase.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.ArrangeOverride Method

TreeListViewHeaderRowPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.ArrangeOverride Method (Size)

TreeListViewHeaderRowPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListViewHeaderRowPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.CreateCellElement Method

TreeListViewHeaderRowPanelCreateCellElement Method
Creates a Control that should be used within a cell.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Control CreateCellElement(
    TreeListViewColumn column
)
Protected Overrides Function CreateCellElement (
    column As TreeListViewColumn
) As Control

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The

Return Value

Type: Control
A Control that should be used within a cell.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.MeasureOverride Method

TreeListViewHeaderRowPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.MeasureOverride Method (Size)

TreeListViewHeaderRowPanelMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

TreeListViewHeaderRowPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.OnColumnPropertyChanged Method

TreeListViewHeaderRowPanelOnColumnPropertyChanged Method
Occurs when a property on a column has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnColumnPropertyChanged(
    TreeListViewColumn column,
    string propertyName
)
Protected Overrides Sub OnColumnPropertyChanged (
    column As TreeListViewColumn,
    propertyName As String
)

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The column.
propertyName
Type: SystemString
The property name.
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel.UpdateAllCellElementZIndexes Method

TreeListViewHeaderRowPanelUpdateAllCellElementZIndexes Method
Updates all cell element z-indices.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateAllCellElementZIndexes()
Protected Overrides Sub UpdateAllCellElementZIndexes
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewHeaderRowPanel Events

TreeListViewHeaderRowPanel Events

The TreeListViewHeaderRowPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewHeaderRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Class

TreeListViewItemRowPanel Class
A panel that arranges the cells within a TreeListViewItem.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewItemRowPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesPropertyGridItemRowPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeListViewItemRowPanel : TreeListViewRowPanelBase
Public Class TreeListViewItemRowPanel
    Inherits TreeListViewRowPanelBase

The TreeListViewItemRowPanel type exposes the following members.

Constructors
 | Name | Description
Public method | TreeListViewItemRowPanel | Initializes a new instance of the TreeListViewItemRowPanel class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets the Brush to use for foregrounds.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementContent.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Constructor

TreeListViewItemRowPanel Constructor
Initializes a new instance of the TreeListViewItemRowPanel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeListViewItemRowPanel()
Public Sub New
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Properties

TreeListViewItemRowPanel Properties

The TreeListViewItemRowPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets the Brush to use for foregrounds.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout. (Inherited from TreeListViewRowPanelBase.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.Foreground Property

TreeListViewItemRowPanelForeground Property
Gets or sets the Brush to use for foregrounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush Foreground { get; set; }
Public Property Foreground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for foregrounds.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Methods

TreeListViewItemRowPanel Methods

The TreeListViewItemRowPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell. (Overrides TreeListViewRowPanelBaseCreateCellElement(TreeListViewColumn).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed. (Overrides TreeListViewRowPanelBaseOnColumnPropertyChanged(TreeListViewColumn, String).)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementContent.)
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices. (Overrides TreeListViewRowPanelBaseUpdateAllCellElementZIndexes.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.ArrangeOverride Method

TreeListViewItemRowPanelArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.ArrangeOverride Method (Size)

TreeListViewItemRowPanelArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

TreeListViewItemRowPanel Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.CreateCellElement Method

TreeListViewItemRowPanelCreateCellElement Method
Creates a Control that should be used within a cell.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Control CreateCellElement(
    TreeListViewColumn column
)
Protected Overrides Function CreateCellElement (
    column As TreeListViewColumn
) As Control

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The

Return Value

Type: Control
A Control that should be used within a cell.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.MeasureOverride Method

TreeListViewItemRowPanelMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.MeasureOverride Method (Size)

TreeListViewItemRowPanelMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

TreeListViewItemRowPanel Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.OnColumnPropertyChanged Method

TreeListViewItemRowPanelOnColumnPropertyChanged Method
Occurs when a property on a column has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnColumnPropertyChanged(
    TreeListViewColumn column,
    string propertyName
)
Protected Overrides Sub OnColumnPropertyChanged (
    column As TreeListViewColumn,
    propertyName As String
)

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The column.
propertyName
Type: SystemString
The property name.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.UpdateAllCellElementContent Method

TreeListViewItemRowPanelUpdateAllCellElementContent Method
Updates all cell element content, which occurs when the data context changes but the data type is the same.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateAllCellElementContent()
Protected Overrides Sub UpdateAllCellElementContent
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.UpdateAllCellElementZIndexes Method

TreeListViewItemRowPanelUpdateAllCellElementZIndexes Method
Updates all cell element z-indices.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void UpdateAllCellElementZIndexes()
Protected Overrides Sub UpdateAllCellElementZIndexes
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Events

TreeListViewItemRowPanel Events

The TreeListViewItemRowPanel type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel Fields

TreeListViewItemRowPanel Fields

The TreeListViewItemRowPanel type exposes the following members.

Fields
Name | Description
ForegroundProperty | Identifies the Foreground dependency property. This field is read-only.
Top
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewItemRowPanel.ForegroundProperty Field

TreeListViewItemRowPanelForegroundProperty Field
Identifies the Foreground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ForegroundProperty
Public Shared ReadOnly ForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Foreground dependency property.
See Also

Reference

TreeListViewItemRowPanel Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Class

TreeListViewRowPanelBase Class
Provides a base panel for arranging a TreeListView header and cells within a TreeListViewItem.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewRowPanelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewHeaderRowPanel
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeListViewItemRowPanel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class TreeListViewRowPanelBase : Panel,
    IOrientedElement
Public MustInherit Class TreeListViewRowPanelBase
    Inherits Panel
    Implements IOrientedElement

The TreeListViewRowPanelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TreeListViewRowPanelBase | Initializes an instance of the TreeListViewRowPanelBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed.
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same.
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Constructor

TreeListViewRowPanelBase Constructor
Initializes an instance of the TreeListViewRowPanelBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected TreeListViewRowPanelBase()
Protected Sub New
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Properties

TreeListViewRowPanelBase Properties

The TreeListViewRowPanelBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the child element layout.
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.Orientation Property

TreeListViewRowPanelBaseOrientation Property
Gets the Orientation of the child element layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; }
Public ReadOnly Property Orientation As Orientation
    Get

Property Value

Type: Orientation
The Orientation of the child element layout.

Implements

IOrientedElementOrientation
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Methods

TreeListViewRowPanelBase Methods

The TreeListViewRowPanelBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateCellElement | Creates a Control that should be used within a cell.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnColumnPropertyChanged | Occurs when a property on a column has changed.
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Protected method | UpdateAllCellElementContent | Updates all cell element content, which occurs when the data context changes but the data type is the same.
Protected method | UpdateAllCellElementZIndexes | Updates all cell element z-indices.
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | CreateSize | Creates a Size comprised of the specified extent and ascent. (Defined by OrientedElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetLocationAscent(Point) | Overloaded. Returns the location ascent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationAscent(Rect) | Overloaded. Returns the location ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Point) | Overloaded. Returns the location extent of the specified Point, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetLocationExtent(Rect) | Overloaded. Returns the location extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Rect) | Overloaded. Returns the size ascent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeAscent(Size) | Overloaded. Returns the size ascent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Rect) | Overloaded. Returns the size extent of the specified Rect, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | GetSizeExtent(Size) | Overloaded. Returns the size extent of the specified Size, based on the orientation of the element. (Defined by OrientedElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.CreateCellElement Method

TreeListViewRowPanelBaseCreateCellElement Method
Creates a Control that should be used within a cell.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Control CreateCellElement(
    TreeListViewColumn column
)
Protected MustOverride Function CreateCellElement (
    column As TreeListViewColumn
) As Control

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The

Return Value

Type: Control
A Control that should be used within a cell.
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.OnColumnPropertyChanged Method

TreeListViewRowPanelBaseOnColumnPropertyChanged Method
Occurs when a property on a column has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void OnColumnPropertyChanged(
    TreeListViewColumn column,
    string propertyName
)
Protected MustOverride Sub OnColumnPropertyChanged (
    column As TreeListViewColumn,
    propertyName As String
)

Parameters

column
Type: ActiproSoftware.UI.Xaml.Controls.GridsTreeListViewColumn
The column.
propertyName
Type: SystemString
The property name.
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.UpdateAllCellElementContent Method

TreeListViewRowPanelBaseUpdateAllCellElementContent Method
Updates all cell element content, which occurs when the data context changes but the data type is the same.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateAllCellElementContent()
Protected Overridable Sub UpdateAllCellElementContent
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase.UpdateAllCellElementZIndexes Method

TreeListViewRowPanelBaseUpdateAllCellElementZIndexes Method
Updates all cell element z-indices.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdateAllCellElementZIndexes()
Protected Overridable Sub UpdateAllCellElementZIndexes
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeListViewRowPanelBase Events

TreeListViewRowPanelBase Events

The TreeListViewRowPanelBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

TreeListViewRowPanelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Class

TreeNodeItemCollection Class
Stores a collection of tree node items.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Grids.PrimitivesTreeNodeItemCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TreeNodeItemCollection : IList<Object>,
    ICollection<Object>, IEnumerable<Object>, IEnumerable,
    ISelectedTreeItemCollection, IObservableVector<Object>, ICollectionView
Public Class TreeNodeItemCollection
    Implements IList(Of Object), ICollection(Of Object),
    IEnumerable(Of Object), IEnumerable, ISelectedTreeItemCollection, IObservableVector(Of Object),
    ICollectionView

The TreeNodeItemCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TreeNodeItemCollection | Initializes a new instance of the TreeNodeItemCollection class
Top
Properties
 | Name | Description
Public property | CollectionGroups | Gets any collection groups that are associated with the view.
Public property | Count | Gets the count of items in the collection.
Public property | CurrentItem | Gets the current item in the view.
Public property | CurrentPosition | Gets the ordinal position of the CurrentItem within the view.
Public property | HasMoreItems | Gets a sentinel value that supports incremental loading implementations.
Public property | IsCurrentAfterLast | Gets whether the CurrentItem of the view is beyond the end of the collection.
Public property | IsCurrentBeforeFirst | Gets whether the CurrentItem of the view is beyond the beginning of the collection.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Gets the item at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Public method | Insert | Inserts an item into the collection at the specified index.
Public method | LoadMoreItemsAsync | Initializes incremental loading from the view.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveCurrentTo | Sets the specified item to be the CurrentItem in the view.
Public method | MoveCurrentToFirst | Sets the first item in the view as the CurrentItem.
Public method | MoveCurrentToLast | Sets the last item in the view as the CurrentItem.
Public method | MoveCurrentToNext | Sets the item after the CurrentItem in the view as the CurrentItem.
Public method | MoveCurrentToPosition | Sets the item at the specified index to be the CurrentItem in the view.
Public method | MoveCurrentToPrevious | Sets the item before the CurrentItem in the view as the CurrentItem.
Public method | Remove | Removes the specified item from the collection.
Public method | RemoveAt | Removes the item at the specified index of the collection.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CurrentChanged | Occurs after the CurrentItem has changed.
Public event | CurrentChanging | Occurs after the CurrentItem has changed.
Public event | VectorChanged | Occurs when the collection is changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Constructor

TreeNodeItemCollection Constructor
Initializes a new instance of the TreeNodeItemCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TreeNodeItemCollection()
Public Sub New
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Properties

TreeNodeItemCollection Properties

The TreeNodeItemCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionGroups | Gets any collection groups that are associated with the view.
Public property | Count | Gets the count of items in the collection.
Public property | CurrentItem | Gets the current item in the view.
Public property | CurrentPosition | Gets the ordinal position of the CurrentItem within the view.
Public property | HasMoreItems | Gets a sentinel value that supports incremental loading implementations.
Public property | IsCurrentAfterLast | Gets whether the CurrentItem of the view is beyond the end of the collection.
Public property | IsCurrentBeforeFirst | Gets whether the CurrentItem of the view is beyond the beginning of the collection.
Public property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public property | Item | Gets the item at the specified index.
Top
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CollectionGroups Property

TreeNodeItemCollectionCollectionGroups Property
Gets any collection groups that are associated with the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IObservableVector<Object> CollectionGroups { get; }
Public ReadOnly Property CollectionGroups As IObservableVector(Of Object)
    Get

Property Value

Type: IObservableVector Object
Any collection groups that are associated with the view.

Implements

ICollectionViewCollectionGroups
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Count Property

TreeNodeItemCollectionCount Property
Gets the count of items in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The count of items in the collection.

Implements

ICollectionTCount
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentItem Property

TreeNodeItemCollectionCurrentItem Property
Gets the current item in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object CurrentItem { get; }
Public ReadOnly Property CurrentItem As Object
    Get

Property Value

Type: Object
The current item in the view.

Implements

ICollectionViewCurrentItem
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentPosition Property

TreeNodeItemCollectionCurrentPosition Property
Gets the ordinal position of the CurrentItem within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CurrentPosition { get; }
Public ReadOnly Property CurrentPosition As Integer
    Get

Property Value

Type: Int32
The ordinal position of the CurrentItem within the view.

Implements

ICollectionViewCurrentPosition
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.HasMoreItems Property

TreeNodeItemCollectionHasMoreItems Property
Gets a sentinel value that supports incremental loading implementations.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool HasMoreItems { get; }
Public ReadOnly Property HasMoreItems As Boolean
    Get

Property Value

Type: Boolean
A sentinel value that supports incremental loading implementations.

Implements

ICollectionViewHasMoreItems
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsCurrentAfterLast Property

TreeNodeItemCollectionIsCurrentAfterLast Property
Gets whether the CurrentItem of the view is beyond the end of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCurrentAfterLast { get; }
Public ReadOnly Property IsCurrentAfterLast As Boolean
    Get

Property Value

Type: Boolean
true if the CurrentItem of the view is beyond the end of the collection; otherwise, false.

Implements

ICollectionViewIsCurrentAfterLast
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsCurrentBeforeFirst Property

TreeNodeItemCollectionIsCurrentBeforeFirst Property
Gets whether the CurrentItem of the view is beyond the beginning of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCurrentBeforeFirst { get; }
Public ReadOnly Property IsCurrentBeforeFirst As Boolean
    Get

Property Value

Type: Boolean
true if the CurrentItem of the view is beyond the beginning of the collection; otherwise, false.

Implements

ICollectionViewIsCurrentBeforeFirst
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IsReadOnly Property

TreeNodeItemCollectionIsReadOnly Property
Gets a value indicating whether the collection is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the collection is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Item Property

TreeNodeItemCollectionItem Property
Gets the item at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object this[
    int index
] { get; set; }
Public Property Item (
    index As Integer
) As Object
    Get
    Set

Parameters

index
Type: SystemInt32
The index of the item to return.

Property Value

Type: Object
The item at the specified index.

Implements

IListTItemInt32
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Methods

TreeNodeItemCollection Methods

The TreeNodeItemCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the collection.
Public method | Clear | Removes all items from the collection.
Public method | Contains | Determines whether the collection contains a specific value.
Public method | CopyTo | Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Retrieves an IEnumerator object for the entire collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Public method | Insert | Inserts an item into the collection at the specified index.
Public method | LoadMoreItemsAsync | Initializes incremental loading from the view.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | MoveCurrentTo | Sets the specified item to be the CurrentItem in the view.
Public method | MoveCurrentToFirst | Sets the first item in the view as the CurrentItem.
Public method | MoveCurrentToLast | Sets the last item in the view as the CurrentItem.
Public method | MoveCurrentToNext | Sets the item after the CurrentItem in the view as the CurrentItem.
Public method | MoveCurrentToPosition | Sets the item at the specified index to be the CurrentItem in the view.
Public method | MoveCurrentToPrevious | Sets the item before the CurrentItem in the view as the CurrentItem.
Public method | Remove | Removes the specified item from the collection.
Public method | RemoveAt | Removes the item at the specified index of the collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Add Method

TreeNodeItemCollectionAdd Method
Adds an item to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Add(
    Object item
)
Public Sub Add (
    item As Object
)

Parameters

item
Type: SystemObject
The object to add to the collection.

Implements

ICollectionTAdd(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Clear Method

TreeNodeItemCollectionClear Method
Removes all items from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Contains Method

TreeNodeItemCollectionContains Method
Determines whether the collection contains a specific value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Contains(
    Object item
)
Public Function Contains (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The object to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CopyTo Method

TreeNodeItemCollectionCopyTo Method
Copies the entire collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void CopyTo(
    Object[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As Object(),
    arrayIndex As Integer
)

Parameters

array
Type: SystemObject
The one-dimensional Array that is the destination of the elements copied from the collection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.GetEnumerator Method

TreeNodeItemCollectionGetEnumerator Method
Retrieves an IEnumerator object for the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<Object> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Object)

Return Value

Type: IEnumerator Object
An IEnumerator object for the entire collection

Implements

IEnumerableTGetEnumerator
Remarks
Enumerators are intended to be used only to read data in the collection. Enumerators cannot be used to modify the underlying collection.

The enumerator does not have exclusive access to the collection.

When an enumerator is instantiated, it takes a snapshot of the current state of the collection. If changes are made to the collection, such as adding, modifying or deleting elements, the snapshot gets out of sync and the enumerator throws an InvalidOperationException. Two enumerators instantiated from the same collection at the same time can have different snapshots of the collection.

See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.IndexOf Method

TreeNodeItemCollectionIndexOf Method
Determines the index of a specific item in the list.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    Object item
)
Public Function IndexOf (
    item As Object
) As Integer

Parameters

item
Type: SystemObject
The object to locate in the list.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Insert Method

TreeNodeItemCollectionInsert Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Insert(
    int index,
    Object item
)
Public Sub Insert (
    index As Integer,
    item As Object
)

Parameters

index
Type: SystemInt32
The zero-based index at which the item should be inserted.
item
Type: SystemObject
The item to insert.

Implements

IListTInsert(Int32, T)
Remarks
If index is equal to Count, value is added to the end of the collection.
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.LoadMoreItemsAsync Method

TreeNodeItemCollectionLoadMoreItemsAsync Method
Initializes incremental loading from the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAsyncOperation<LoadMoreItemsResult> LoadMoreItemsAsync(
    uint count
)
Public Function LoadMoreItemsAsync (
    count As UInteger
) As IAsyncOperation(Of LoadMoreItemsResult)

Parameters

count
Type: SystemUInt32
The number of items to load.

Return Value

Type: IAsyncOperation LoadMoreItemsResult
The wrapped results of the load operation.

Implements

ICollectionViewLoadMoreItemsAsync(UInt32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentTo Method

TreeNodeItemCollectionMoveCurrentTo Method
Sets the specified item to be the CurrentItem in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveCurrentTo(
    Object item
)
Public Function MoveCurrentTo (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The item to set.

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentTo(Object)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToFirst Method

TreeNodeItemCollectionMoveCurrentToFirst Method
Sets the first item in the view as the CurrentItem.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveCurrentToFirst()
Public Function MoveCurrentToFirst As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToFirst
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToLast Method

TreeNodeItemCollectionMoveCurrentToLast Method
Sets the last item in the view as the CurrentItem.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveCurrentToLast()
Public Function MoveCurrentToLast As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToLast
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToNext Method

TreeNodeItemCollectionMoveCurrentToNext Method
Sets the item after the CurrentItem in the view as the CurrentItem.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveCurrentToNext()
Public Function MoveCurrentToNext As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToNext
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToPosition Method

TreeNodeItemCollectionMoveCurrentToPosition Method
Sets the item at the specified index to be the CurrentItem in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveCurrentToPosition(
    int position
)
Public Function MoveCurrentToPosition (
    position As Integer
) As Boolean

Parameters

position
Type: SystemInt32
The index to set the CurrentItem to.

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToPosition(Int32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.MoveCurrentToPrevious Method

TreeNodeItemCollectionMoveCurrentToPrevious Method
Sets the item before the CurrentItem in the view as the CurrentItem.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool MoveCurrentToPrevious()
Public Function MoveCurrentToPrevious As Boolean

Return Value

Type: Boolean
true if the resulting CurrentItem is within the view; otherwise, false.

Implements

ICollectionViewMoveCurrentToPrevious
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.Remove Method

TreeNodeItemCollectionRemove Method
Removes the specified item from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Remove(
    Object item
)
Public Function Remove (
    item As Object
) As Boolean

Parameters

item
Type: SystemObject
The item to remove.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.Grids.Primitives.TreeNodeItemCollection.Remove(System.Object)"]

Implements

ICollectionTRemove(T)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.RemoveAt Method

TreeNodeItemCollectionRemoveAt Method
Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection Events

TreeNodeItemCollection Events

The TreeNodeItemCollection type exposes the following members.

Events
 | Name | Description
Public event | CurrentChanged | Occurs after the CurrentItem has changed.
Public event | CurrentChanging | Occurs after the CurrentItem has changed.
Public event | VectorChanged | Occurs when the collection is changed.
Top
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentChanged Event

TreeNodeItemCollectionCurrentChanged Event
Occurs after the CurrentItem has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<Object> CurrentChanged
Public Event CurrentChanged As EventHandler(Of Object)

Value

Type: SystemEventHandler Object
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.CurrentChanging Event

TreeNodeItemCollectionCurrentChanging Event
Occurs after the CurrentItem has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event CurrentChangingEventHandler CurrentChanging
Public Event CurrentChanging As CurrentChangingEventHandler

Value

Type: Windows.UI.Xaml.DataCurrentChangingEventHandler
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


TreeNodeItemCollection.VectorChanged Event

TreeNodeItemCollectionVectorChanged Event
Occurs when the collection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.Primitives
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event VectorChangedEventHandler<Object> VectorChanged
Public Event VectorChanged As VectorChangedEventHandler(Of Object)

Value

Type: Windows.Foundation.CollectionsVectorChangedEventHandler Object
See Also

Reference

TreeNodeItemCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace
Contains the classes used for PropertyGrid model data.
Classes
 | Class | Description
Public class | CachedPropertyModelBase | Provides an abstract base class for a property grid property IDataModel that caches the values returned as an optimization.
Public class | CategoryEditorModel | Represents a property grid category editor IDataModel.
Public class | CategoryModel | Represents a property grid category IDataModel.
Public class | CollectionPropertyDescriptorPropertyModel | Represents a property grid collection property IDataModel that is based on PropertyDescriptor data.
Public class | CollectionPropertyDisplayMode | Specifies the display mode of collection properties in the property grid.
Public class | DataFactoryBase | Provides an abstract base class for an IDataFactory implementation.
Public class | DataModelBase | Provides an abstract base class for a property grid IDataModel.
Public class | DataModelCollection | Represents a collection of IDataModel objects.
Public class | DataModelSortComparer | Provides a comparer implementation for sorting IDataModel objects in order of sort importance, sort order, numeric display name index (if applicable), and finally display name.
Public class | DataModelSortImportance | Specifies the sort importance of data models.
Public class | ExpandableCollectionConverter | Represents a type converter that is capable of expanding various collection types.
Protected class | ExpandableCollectionConverterCollectionItemPropertyDescriptor | Represents a PropertyDescriptor for an item in a read-only collection.
Protected class | ExpandableCollectionConverterDictionaryItemPropertyDescriptor | Represents a PropertyDescriptor for an item in a dictionary.
Protected class | ExpandableCollectionConverterListItemPropertyDescriptor | Represents a PropertyDescriptor for an item in a list.
Public class | MergedPropertyModel | Represents a property grid property IDataModel that merges a property from multiple data objects.
Public class | PropertyDescriptorPropertyModel | Represents a property grid property IDataModel that is based on PropertyDescriptor data.
Public class | PropertyExpandability | Specifies the expandability of properties in the property grid.
Public class | PropertyModel | Represents a property grid property IDataModel that can be easily explicitly-defined and optionally bound to in XAML.
Public class | PropertyModelBase | Provides an abstract base class for a property grid IDataModel that can provide the foundation for an IPropertyModel implementation.
Public class | PropertyModelBooleanFilter | Represents a IDataFilter implementation for IPropertyModel boolean properties.
Public class | PropertyModelBooleanFilterSource | Specifies the source IPropertyModel boolean properties that can be used by a PropertyModelBooleanFilter.
Public class | PropertyModelCollection | Represents a collection of IPropertyModel objects.
Public class | PropertyModelStringFilter | Represents a IDataFilter implementation for IPropertyModel string properties.
Public class | PropertyModelStringFilterSource | Specifies the source IPropertyModel string properties that can be used by a PropertyModelStringFilter.
Public class | PropertyRefreshReason | Specifies the reason a property is being refreshed.
Public class | TypeReflectionFactory | Implements an IDataFactory that uses reflection to return data models.
Interfaces
 | Interface | Description
Public interface | ICategoryEditorModel | Provides the requirements for a property grid category editor IDataModel, that can consume and display one or more properties.
Public interface | ICategoryModel | Provides the requirements for a property grid category IDataModel.
Public interface | ICollectionItemPropertyDescriptor | Identifies an object as a property descriptor for an item in a collection.
Public interface | ICollectionTypeConverter | Identifies an object as a type converter for a collection used to control how and when items should be added.
Public interface | IDataFactory | Provides the requirements for class that can return the data models for requested object values.
Public interface | IDataFactoryRequest | Provides the core requirements of a request made to an IDataFactory.
Public interface | IDataModel | Provides the requirements for a data model class that can represent a property or category in a property grid.
Public interface | IPropertyModel | Provides the requirements for a property grid property IDataModel.
Public interface | IRootModel | Provides the requirements for a data model class that is the root model in the hierarchy.


CachedPropertyModelBase Class

CachedPropertyModelBase Class
Provides an abstract base class for a property grid property IDataModel that caches the values returned as an optimization.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataMergedPropertyModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyDescriptorPropertyModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class CachedPropertyModelBase : PropertyModelBase,
    IPropertyModel, IDataModel, IDisposable
Public MustInherit Class CachedPropertyModelBase
    Inherits PropertyModelBase
    Implements IPropertyModel, IDataModel, IDisposable

The CachedPropertyModelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CachedPropertyModelBase | Initializes a new instance of the CachedPropertyModelBase class
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Overrides PropertyModelBaseCanAddChildResolved.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Overrides PropertyModelBaseCanRemoveResolved.)
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Overrides PropertyModelBaseCanResetValueResolved.)
Public property | Category | Gets a category for the property.
Protected property | CategoryCore | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property.
Protected property | ConverterCore | Gets the TypeConverter to use for the property.
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Overrides PropertyModelBaseConverterResolved.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides PropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Overrides PropertyModelBaseIsImmutableResolved.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified.
Protected property | IsModifiedCore | Gets whether the data model has been modified.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only.
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Overrides PropertyModelBaseIsValueReadOnlyResolved.)
Public property | Name | Gets the name of the data model.
Protected property | NameCore | Gets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Overrides PropertyModelBaseShouldNotifyParentOnValueChangeResolved.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesCore | Gets the standard list of values for the Value property.
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Overrides PropertyModelBaseStandardValuesResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property.
Protected property | TargetCore | Gets the target object that owns the property.
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Overrides PropertyModelBaseTargetResolved.)
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation.
Protected property | ValueCore | Gets or sets the property value.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Overrides PropertyModelBaseValueResolved.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Protected property | ValueTypeCore | Gets the Type of the Value property.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Overrides PropertyModelBaseValueTypeResolved.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides PropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Constructor

CachedPropertyModelBase Constructor
Initializes a new instance of the CachedPropertyModelBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected CachedPropertyModelBase()
Protected Sub New
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Properties

CachedPropertyModelBase Properties

The CachedPropertyModelBase type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Overrides PropertyModelBaseCanAddChildResolved.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent.
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Overrides PropertyModelBaseCanRemoveResolved.)
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Overrides PropertyModelBaseCanResetValueResolved.)
Public property | Category | Gets a category for the property.
Protected property | CategoryCore | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property.
Protected property | ConverterCore | Gets the TypeConverter to use for the property.
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Overrides PropertyModelBaseConverterResolved.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides PropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Overrides PropertyModelBaseIsImmutableResolved.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified.
Protected property | IsModifiedCore | Gets whether the data model has been modified.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only.
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Overrides PropertyModelBaseIsValueReadOnlyResolved.)
Public property | Name | Gets the name of the data model.
Protected property | NameCore | Gets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Overrides PropertyModelBaseShouldNotifyParentOnValueChangeResolved.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings.
Protected property | StandardValuesCore | Gets the standard list of values for the Value property.
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Overrides PropertyModelBaseStandardValuesResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property.
Protected property | TargetCore | Gets the target object that owns the property.
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Overrides PropertyModelBaseTargetResolved.)
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation.
Protected property | ValueCore | Gets or sets the property value.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Overrides PropertyModelBaseValueResolved.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Protected property | ValueTypeCore | Gets the Type of the Value property.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Overrides PropertyModelBaseValueTypeResolved.)
Top
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanAddChild Property

CachedPropertyModelBaseCanAddChild Property
Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanAddChild { get; }
Public Overridable ReadOnly Property CanAddChild As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanAddChild
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanAddChildCore Property

CachedPropertyModelBaseCanAddChildCore Property
Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool CanAddChildCore { get; }
Protected Overridable ReadOnly Property CanAddChildCore As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanAddChildResolved Property

CachedPropertyModelBaseCanAddChildResolved Property
Gets the resolved value for whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool CanAddChildResolved { get; }
Protected Overrides NotOverridable ReadOnly Property CanAddChildResolved As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanRemove Property

CachedPropertyModelBaseCanRemove Property
Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanRemove
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanRemoveCore Property

CachedPropertyModelBaseCanRemoveCore Property
Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool CanRemoveCore { get; }
Protected Overridable ReadOnly Property CanRemoveCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanRemoveResolved Property

CachedPropertyModelBaseCanRemoveResolved Property
Gets the resolved value for whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool CanRemoveResolved { get; }
Protected Overrides NotOverridable ReadOnly Property CanRemoveResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanResetValue Property

CachedPropertyModelBaseCanResetValue Property
Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanResetValue { get; }
Public Overridable ReadOnly Property CanResetValue As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.

Implements

IPropertyModelCanResetValue
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanResetValueCore Property

CachedPropertyModelBaseCanResetValueCore Property
Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool CanResetValueCore { get; }
Protected MustOverride ReadOnly Property CanResetValueCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CanResetValueResolved Property

CachedPropertyModelBaseCanResetValueResolved Property
Gets the resolved value for whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool CanResetValueResolved { get; }
Protected Overrides NotOverridable ReadOnly Property CanResetValueResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Category Property

CachedPropertyModelBaseCategory Property
Gets a category for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Category { get; }
Public Overridable ReadOnly Property Category As String
    Get

Property Value

Type: String
A category for the property.

Implements

IPropertyModelCategory
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.CategoryCore Property

CachedPropertyModelBaseCategoryCore Property
Gets a category for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string CategoryCore { get; }
Protected Overridable ReadOnly Property CategoryCore As String
    Get

Property Value

Type: String
A category for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Converter Property

CachedPropertyModelBaseConverter Property
Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual TypeConverter Converter { get; }
Public Overridable ReadOnly Property Converter As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.

Implements

IPropertyModelConverter
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ConverterCore Property

CachedPropertyModelBaseConverterCore Property
Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TypeConverter ConverterCore { get; }
Protected Overridable ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ConverterResolved Property

CachedPropertyModelBaseConverterResolved Property
Gets the resolved TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed TypeConverter ConverterResolved { get; }
Protected Overrides NotOverridable ReadOnly Property ConverterResolved As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Description Property

CachedPropertyModelBaseDescription Property
Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DescriptionCore Property

CachedPropertyModelBaseDescriptionCore Property
Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string DescriptionCore { get; }
Protected Overridable ReadOnly Property DescriptionCore As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DescriptionResolved Property

CachedPropertyModelBaseDescriptionResolved Property
Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string DescriptionResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DisplayName Property

CachedPropertyModelBaseDisplayName Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string DisplayName { get; }
Public Overridable ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DisplayNameCore Property

CachedPropertyModelBaseDisplayNameCore Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string DisplayNameCore { get; }
Protected Overridable ReadOnly Property DisplayNameCore As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.DisplayNameResolved Property

CachedPropertyModelBaseDisplayNameResolved Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string DisplayNameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.HasStandardValues Property

CachedPropertyModelBaseHasStandardValues Property
Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool HasStandardValues { get; }
Public Overrides ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.

Implements

IPropertyModelHasStandardValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.HasStandardValuesCore Property

CachedPropertyModelBaseHasStandardValuesCore Property
Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool HasStandardValuesCore { get; }
Protected Overridable ReadOnly Property HasStandardValuesCore As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsImmutable Property

CachedPropertyModelBaseIsImmutable Property
Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsImmutable { get; }
Public Overridable ReadOnly Property IsImmutable As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.

Implements

IPropertyModelIsImmutable
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsImmutableCore Property

CachedPropertyModelBaseIsImmutableCore Property
Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsImmutableCore { get; }
Protected Overridable ReadOnly Property IsImmutableCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsImmutableResolved Property

CachedPropertyModelBaseIsImmutableResolved Property
Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool IsImmutableResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsImmutableResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsLimitedToStandardValues Property

CachedPropertyModelBaseIsLimitedToStandardValues Property
Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsLimitedToStandardValues { get; }
Public Overridable ReadOnly Property IsLimitedToStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.

Implements

IPropertyModelIsLimitedToStandardValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsLimitedToStandardValuesCore Property

CachedPropertyModelBaseIsLimitedToStandardValuesCore Property
Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsLimitedToStandardValuesCore { get; }
Protected Overridable ReadOnly Property IsLimitedToStandardValuesCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsMergeable Property

CachedPropertyModelBaseIsMergeable Property
Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsMergeable { get; }
Public Overridable ReadOnly Property IsMergeable As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.

Implements

IPropertyModelIsMergeable
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsMergeableCore Property

CachedPropertyModelBaseIsMergeableCore Property
Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsMergeableCore { get; }
Protected MustOverride ReadOnly Property IsMergeableCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsModified Property

CachedPropertyModelBaseIsModified Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsModified { get; }
Public Overridable ReadOnly Property IsModified As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.

Implements

IDataModelIsModified
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsModifiedCore Property

CachedPropertyModelBaseIsModifiedCore Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsModifiedCore { get; }
Protected MustOverride ReadOnly Property IsModifiedCore As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsModifiedResolved Property

CachedPropertyModelBaseIsModifiedResolved Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool IsModifiedResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsValueReadOnly Property

CachedPropertyModelBaseIsValueReadOnly Property
Gets or sets whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsValueReadOnly { get; set; }
Public Overridable Property IsValueReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.

Implements

IPropertyModelIsValueReadOnly
Remarks
This property can be set to true to force a normally-editable property to be read-only. Some implementations of this property will always return true when the underlying property value is unable to be set.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsValueReadOnlyCore Property

CachedPropertyModelBaseIsValueReadOnlyCore Property
Gets whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsValueReadOnlyCore { get; }
Protected MustOverride ReadOnly Property IsValueReadOnlyCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.IsValueReadOnlyResolved Property

CachedPropertyModelBaseIsValueReadOnlyResolved Property
Gets the resolved value for whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool IsValueReadOnlyResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsValueReadOnlyResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Name Property

CachedPropertyModelBaseName Property
Gets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameCore Property

CachedPropertyModelBaseNameCore Property
Gets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract string NameCore { get; }
Protected MustOverride ReadOnly Property NameCore As String
    Get

Property Value

Type: String
The name of the data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameResolved Property

CachedPropertyModelBaseNameResolved Property
Gets the resolved name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string NameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplate Property

CachedPropertyModelBaseNameTemplate Property
Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplate NameTemplate { get; }
Public Overridable ReadOnly Property NameTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplate
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateCore Property

CachedPropertyModelBaseNameTemplateCore Property
Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DataTemplate NameTemplateCore { get; }
Protected Overridable ReadOnly Property NameTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateKey Property

CachedPropertyModelBaseNameTemplateKey Property
Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object NameTemplateKey { get; }
Public Overridable ReadOnly Property NameTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplateKey
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateKeyCore Property

CachedPropertyModelBaseNameTemplateKeyCore Property
Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Object NameTemplateKeyCore { get; }
Protected Overridable ReadOnly Property NameTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateSelector Property

CachedPropertyModelBaseNameTemplateSelector Property
Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector NameTemplateSelector { get; }
Public Overridable ReadOnly Property NameTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.

Implements

IPropertyModelNameTemplateSelector
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.NameTemplateSelectorCore Property

CachedPropertyModelBaseNameTemplateSelectorCore Property
Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DataTemplateSelector NameTemplateSelectorCore { get; }
Protected Overridable ReadOnly Property NameTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ShouldNotifyParentOnValueChange Property

CachedPropertyModelBaseShouldNotifyParentOnValueChange Property
Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldNotifyParentOnValueChange { get; }
Public Overridable ReadOnly Property ShouldNotifyParentOnValueChange As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.

Implements

IPropertyModelShouldNotifyParentOnValueChange
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ShouldNotifyParentOnValueChangeCore Property

CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore Property
Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool ShouldNotifyParentOnValueChangeCore { get; }
Protected Overridable ReadOnly Property ShouldNotifyParentOnValueChangeCore As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ShouldNotifyParentOnValueChangeResolved Property

CachedPropertyModelBaseShouldNotifyParentOnValueChangeResolved Property
Gets the resolved value for whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool ShouldNotifyParentOnValueChangeResolved { get; }
Protected Overrides NotOverridable ReadOnly Property ShouldNotifyParentOnValueChangeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortImportance Property

CachedPropertyModelBaseSortImportance Property
Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataModelSortImportance SortImportance { get; }
Public Overridable ReadOnly Property SortImportance As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.

Implements

IDataModelSortImportance
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortImportanceCore Property

CachedPropertyModelBaseSortImportanceCore Property
Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DataModelSortImportance SortImportanceCore { get; }
Protected Overridable ReadOnly Property SortImportanceCore As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortImportanceResolved Property

CachedPropertyModelBaseSortImportanceResolved Property
Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed DataModelSortImportance SortImportanceResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortOrder Property

CachedPropertyModelBaseSortOrder Property
Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int SortOrder { get; }
Public Overridable ReadOnly Property SortOrder As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortOrderCore Property

CachedPropertyModelBaseSortOrderCore Property
Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual int SortOrderCore { get; }
Protected Overridable ReadOnly Property SortOrderCore As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.SortOrderResolved Property

CachedPropertyModelBaseSortOrderResolved Property
Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed int SortOrderResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValues Property

CachedPropertyModelBaseStandardValues Property
Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IEnumerable StandardValues { get; }
Public Overridable ReadOnly Property StandardValues As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.

Implements

IPropertyModelStandardValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesAsStrings Property

CachedPropertyModelBaseStandardValuesAsStrings Property
Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IEnumerable<string> StandardValuesAsStrings { get; }
Public Overridable ReadOnly Property StandardValuesAsStrings As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.

Implements

IPropertyModelStandardValuesAsStrings
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesAsStringsCore Property

CachedPropertyModelBaseStandardValuesAsStringsCore Property
Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IEnumerable<string> StandardValuesAsStringsCore { get; }
Protected Overridable ReadOnly Property StandardValuesAsStringsCore As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesCore Property

CachedPropertyModelBaseStandardValuesCore Property
Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IEnumerable StandardValuesCore { get; }
Protected Overridable ReadOnly Property StandardValuesCore As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.StandardValuesResolved Property

CachedPropertyModelBaseStandardValuesResolved Property
Gets the resolved standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed IEnumerable StandardValuesResolved { get; }
Protected Overrides NotOverridable ReadOnly Property StandardValuesResolved As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Target Property

CachedPropertyModelBaseTarget Property
Gets the target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object Target { get; }
Public Overridable ReadOnly Property Target As Object
    Get

Property Value

Type: Object
The target object that owns the property.

Implements

IPropertyModelTarget
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.TargetCore Property

CachedPropertyModelBaseTargetCore Property
Gets the target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Object TargetCore { get; }
Protected MustOverride ReadOnly Property TargetCore As Object
    Get

Property Value

Type: Object
The target object that owns the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.TargetResolved Property

CachedPropertyModelBaseTargetResolved Property
Gets the resolved target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed Object TargetResolved { get; }
Protected Overrides NotOverridable ReadOnly Property TargetResolved As Object
    Get

Property Value

Type: Object
The target object that owns the property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.TargetType Property

CachedPropertyModelBaseTargetType Property
Gets the Type of the Target property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Type TargetType { get; }
Public Overridable ReadOnly Property TargetType As Type
    Get

Property Value

Type: Type
The Type of the Target property.

Implements

IPropertyModelTargetType
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Value Property

CachedPropertyModelBaseValue Property
Gets or sets the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object Value { get; set; }
Public Overridable Property Value As Object
    Get
    Set

Property Value

Type: Object
The property value.

Implements

IPropertyModelValue
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueAsString Property

CachedPropertyModelBaseValueAsString Property
Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual string ValueAsString { get; set; }
Public Overridable Property ValueAsString As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.

Implements

IPropertyModelValueAsString
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueAsStringCore Property

CachedPropertyModelBaseValueAsStringCore Property
Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string ValueAsStringCore { get; set; }
Protected Overridable Property ValueAsStringCore As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueCore Property

CachedPropertyModelBaseValueCore Property
Gets or sets the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Object ValueCore { get; set; }
Protected MustOverride Property ValueCore As Object
    Get
    Set

Property Value

Type: Object
The property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueResolved Property

CachedPropertyModelBaseValueResolved Property
Gets or sets the resolved property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed Object ValueResolved { get; set; }
Protected Overrides NotOverridable Property ValueResolved As Object
    Get
    Set

Property Value

Type: Object
The property value.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.Values Property

CachedPropertyModelBaseValues Property
Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IList<Object> Values { get; }
Public Overridable ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.

Implements

IPropertyModelValues
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValuesCore Property

CachedPropertyModelBaseValuesCore Property
Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IList<Object> ValuesCore { get; }
Protected Overridable ReadOnly Property ValuesCore As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplate Property

CachedPropertyModelBaseValueTemplate Property
Gets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplate ValueTemplate { get; }
Public Overridable ReadOnly Property ValueTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplate
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateCore Property

CachedPropertyModelBaseValueTemplateCore Property
Gets the DataTemplate to use for use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DataTemplate ValueTemplateCore { get; }
Protected Overridable ReadOnly Property ValueTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKey Property

CachedPropertyModelBaseValueTemplateKey Property
Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object ValueTemplateKey { get; }
Public Overridable ReadOnly Property ValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateKey
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKeyCore Property

CachedPropertyModelBaseValueTemplateKeyCore Property
Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Object ValueTemplateKeyCore { get; }
Protected Overridable ReadOnly Property ValueTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKind Property

CachedPropertyModelBaseValueTemplateKind Property
Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DefaultValueTemplateKind ValueTemplateKind { get; }
Public Overridable ReadOnly Property ValueTemplateKind As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Implements

IPropertyModelValueTemplateKind
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateKindCore Property

CachedPropertyModelBaseValueTemplateKindCore Property
Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DefaultValueTemplateKind ValueTemplateKindCore { get; }
Protected Overridable ReadOnly Property ValueTemplateKindCore As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateSelector Property

CachedPropertyModelBaseValueTemplateSelector Property
Gets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector ValueTemplateSelector { get; }
Public Overridable ReadOnly Property ValueTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateSelector
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTemplateSelectorCore Property

CachedPropertyModelBaseValueTemplateSelectorCore Property
Gets the DataTemplateSelector to use for use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual DataTemplateSelector ValueTemplateSelectorCore { get; }
Protected Overridable ReadOnly Property ValueTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueType Property

CachedPropertyModelBaseValueType Property
Gets the Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Type ValueType { get; }
Public Overridable ReadOnly Property ValueType As Type
    Get

Property Value

Type: Type
The Type of the Value property.

Implements

IPropertyModelValueType
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, and finally any value templates in matching property editors.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTypeCore Property

CachedPropertyModelBaseValueTypeCore Property
Gets the Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Type ValueTypeCore { get; }
Protected MustOverride ReadOnly Property ValueTypeCore As Type
    Get

Property Value

Type: Type
The Type of the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.ValueTypeResolved Property

CachedPropertyModelBaseValueTypeResolved Property
Gets the resolved Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed Type ValueTypeResolved { get; }
Protected Overrides NotOverridable ReadOnly Property ValueTypeResolved As Type
    Get

Property Value

Type: Type
The Type of the Value property.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Methods

CachedPropertyModelBase Methods

The CachedPropertyModelBase type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides PropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase.OnPropertyChanged Method

CachedPropertyModelBaseOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CachedPropertyModelBase Events

CachedPropertyModelBase Events

The CachedPropertyModelBase type exposes the following members.

Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CachedPropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Class

CategoryEditorModel Class
Represents a property grid category editor IDataModel.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCategoryEditorModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CategoryEditorModel : DataModelBase,
    ICategoryEditorModel, IDataModel, IDisposable
Public Class CategoryEditorModel
    Inherits DataModelBase
    Implements ICategoryEditorModel, IDataModel, IDisposable

The CategoryEditorModel type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorModel | Initializes an instance of the CategoryEditorModel class.
Public method | CategoryEditorModel(CategoryEditor) | Initializes an instance of the CategoryEditorModel class.
Top
Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CategoryEditor | Gets the CategoryEditor that was used to create this data model.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Constructor

CategoryEditorModel Constructor
Overload List
 | Name | Description
Public method | CategoryEditorModel | Initializes an instance of the CategoryEditorModel class.
Public method | CategoryEditorModel(CategoryEditor) | Initializes an instance of the CategoryEditorModel class.
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Constructor

CategoryEditorModel Constructor
Initializes an instance of the CategoryEditorModel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorModel()
Public Sub New
See Also

Reference

CategoryEditorModel Class
CategoryEditorModel Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Constructor (CategoryEditor)

CategoryEditorModel Constructor (CategoryEditor)
Initializes an instance of the CategoryEditorModel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorModel(
    CategoryEditor categoryEditor
)
Public Sub New (
    categoryEditor As CategoryEditor
)

Parameters

categoryEditor
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditor
The CategoryEditor that was used to create this data model.
See Also

Reference

CategoryEditorModel Class
CategoryEditorModel Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Properties

CategoryEditorModel Properties

The CategoryEditorModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CategoryEditor | Gets the CategoryEditor that was used to create this data model.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.CategoryEditor Property

CategoryEditorModelCategoryEditor Property
Gets the CategoryEditor that was used to create this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditor CategoryEditor { get; }
Public ReadOnly Property CategoryEditor As CategoryEditor
    Get

Property Value

Type: CategoryEditor
The CategoryEditor that was used to create this data model.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.Description Property

CategoryEditorModelDescription Property
Gets or sets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.DescriptionResolved Property

CategoryEditorModelDescriptionResolved Property
Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string DescriptionResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.DisplayName Property

CategoryEditorModelDisplayName Property
Gets or sets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.DisplayNameResolved Property

CategoryEditorModelDisplayNameResolved Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string DisplayNameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.EditorTemplate Property

CategoryEditorModelEditorTemplate Property
Gets the DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate EditorTemplate { get; set; }
Public Property EditorTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the properties consumed by this editor.

Implements

ICategoryEditorModelEditorTemplate
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.EditorTemplateKey Property

CategoryEditorModelEditorTemplateKey Property
Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object EditorTemplateKey { get; set; }
Public Property EditorTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Implements

ICategoryEditorModelEditorTemplateKey
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.IsModifiedResolved Property

CategoryEditorModelIsModifiedResolved Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsModifiedResolved { get; }
Protected Overrides ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.Name Property

CategoryEditorModelName Property
Gets or sets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.NameResolved Property

CategoryEditorModelNameResolved Property
Gets the resolved name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string NameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.SortImportanceResolved Property

CategoryEditorModelSortImportanceResolved Property
Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataModelSortImportance SortImportanceResolved { get; }
Protected Overrides ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.SortOrder Property

CategoryEditorModelSortOrder Property
Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SortOrder { get; set; }
Public Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel.SortOrderResolved Property

CategoryEditorModelSortOrderResolved Property
Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed int SortOrderResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Methods

CategoryEditorModel Methods

The CategoryEditorModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryEditorModel Events

CategoryEditorModel Events

The CategoryEditorModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditorModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel Class

CategoryModel Class
Represents a property grid category IDataModel.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCategoryModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CategoryModel : DataModelBase,
    ICategoryModel, IDataModel, IDisposable
Public Class CategoryModel
    Inherits DataModelBase
    Implements ICategoryModel, IDataModel, IDisposable

The CategoryModel type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryModel | Initializes an instance of the CategoryModel class.
Top
Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel Constructor

CategoryModel Constructor
Initializes an instance of the CategoryModel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryModel(
    string name
)
Public Sub New (
    name As String
)

Parameters

name
Type: SystemString
The category name.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel Properties

CategoryModel Properties

The CategoryModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Overrides DataModelBaseDescriptionResolved.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Overrides DataModelBaseDisplayNameResolved.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Overrides DataModelBaseIsModifiedResolved.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | Name | Gets or sets the name of the data model.
Protected property | NameResolved | Gets the resolved name of the data model. (Overrides DataModelBaseNameResolved.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Overrides DataModelBaseSortImportanceResolved.)
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides DataModelBaseSortOrderResolved.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.Description Property

CategoryModelDescription Property
Gets or sets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.DescriptionResolved Property

CategoryModelDescriptionResolved Property
Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string DescriptionResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.DisplayName Property

CategoryModelDisplayName Property
Gets or sets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.DisplayNameResolved Property

CategoryModelDisplayNameResolved Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string DisplayNameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.IsModifiedResolved Property

CategoryModelIsModifiedResolved Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed bool IsModifiedResolved { get; }
Protected Overrides NotOverridable ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.Name Property

CategoryModelName Property
Gets or sets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.NameResolved Property

CategoryModelNameResolved Property
Gets the resolved name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed string NameResolved { get; }
Protected Overrides NotOverridable ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.SortImportanceResolved Property

CategoryModelSortImportanceResolved Property
Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataModelSortImportance SortImportanceResolved { get; }
Protected Overrides ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.SortOrder Property

CategoryModelSortOrder Property
Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SortOrder { get; set; }
Public Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel.SortOrderResolved Property

CategoryModelSortOrderResolved Property
Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override sealed int SortOrderResolved { get; }
Protected Overrides NotOverridable ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel Methods

CategoryModel Methods

The CategoryModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CategoryModel Events

CategoryModel Events

The CategoryModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Class

CollectionPropertyDescriptorPropertyModel Class
Represents a property grid collection property IDataModel that is based on PropertyDescriptor data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyDescriptorPropertyModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCollectionPropertyDescriptorPropertyModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CollectionPropertyDescriptorPropertyModel : PropertyDescriptorPropertyModel
Public Class CollectionPropertyDescriptorPropertyModel
    Inherits PropertyDescriptorPropertyModel

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionPropertyDescriptorPropertyModel | Initializes an instance of the CollectionPropertyDescriptorPropertyModel class.
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | AttachedCollectionValue | Gets or sets the collection object that is attached for change notification, if any.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Overrides CachedPropertyModelBaseCanAddChildCore.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Inherited from PropertyDescriptorPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides PropertyDescriptorPropertyModelConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Inherited from PropertyDescriptorPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Inherited from PropertyDescriptorPropertyModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Inherited from PropertyDescriptorPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Overrides PropertyModelBaseAddChild.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Protected method | CreateExpandableCollectionConverter | Creates a new expandable collection TypeConverter.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides PropertyDescriptorPropertyModelDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides CachedPropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Constructor

CollectionPropertyDescriptorPropertyModel Constructor
Initializes an instance of the CollectionPropertyDescriptorPropertyModel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollectionPropertyDescriptorPropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor,
    bool isCollectionReadOnly,
    bool areItemsReadOnly
)
Public Sub New (
    target As Object,
    propertyDescriptor As PropertyDescriptor,
    isCollectionReadOnly As Boolean,
    areItemsReadOnly As Boolean
)

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: PropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
isCollectionReadOnly
Type: SystemBoolean
Whether items can be added to or removed from the collection.
areItemsReadOnly
Type: SystemBoolean
Whether the values of the items in the collection are read-only and cannot be changed.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Properties

CollectionPropertyDescriptorPropertyModel Properties

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | AttachedCollectionValue | Gets or sets the collection object that is attached for change notification, if any.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Overrides CachedPropertyModelBaseCanAddChildCore.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Inherited from PropertyDescriptorPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides PropertyDescriptorPropertyModelConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Inherited from PropertyDescriptorPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Inherited from PropertyDescriptorPropertyModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Inherited from PropertyDescriptorPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Inherited from PropertyDescriptorPropertyModel.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.AreItemsReadOnly Property

CollectionPropertyDescriptorPropertyModelAreItemsReadOnly Property
Gets whether the values of the items in the collection are read-only and cannot be changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreItemsReadOnly { get; }
Public ReadOnly Property AreItemsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the values of the items in the collection are read-only and cannot be changed; otherwise, false.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.AttachedCollectionValue Property

CollectionPropertyDescriptorPropertyModelAttachedCollectionValue Property
Gets or sets the collection object that is attached for change notification, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object AttachedCollectionValue { get; set; }
Public Property AttachedCollectionValue As Object
    Get
    Set

Property Value

Type: Object
The collection object that is attached for change notification, if any.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.CanAddChildCore Property

CollectionPropertyDescriptorPropertyModelCanAddChildCore Property
Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool CanAddChildCore { get; }
Protected Overrides ReadOnly Property CanAddChildCore As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.ConverterCore Property

CollectionPropertyDescriptorPropertyModelConverterCore Property
Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override TypeConverter ConverterCore { get; }
Protected Overrides ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.IsCollectionReadOnly Property

CollectionPropertyDescriptorPropertyModelIsCollectionReadOnly Property
Gets whether items can be added to or removed from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCollectionReadOnly { get; }
Public ReadOnly Property IsCollectionReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if items can be added to or removed from the collection; otherwise, false.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Methods

CollectionPropertyDescriptorPropertyModel Methods

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Overrides PropertyModelBaseAddChild.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Protected method | CreateExpandableCollectionConverter | Creates a new expandable collection TypeConverter.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides PropertyDescriptorPropertyModelDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides CachedPropertyModelBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from PropertyDescriptorPropertyModel.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.AddChild Method

CollectionPropertyDescriptorPropertyModelAddChild Method
Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void AddChild()
Public Overrides Sub AddChild
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.CreateExpandableCollectionConverter Method

CollectionPropertyDescriptorPropertyModelCreateExpandableCollectionConverter Method
Creates a new expandable collection TypeConverter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual TypeConverter CreateExpandableCollectionConverter()
Protected Overridable Function CreateExpandableCollectionConverter As TypeConverter

Return Value

Type: TypeConverter
The TypeConverter that was created.
Remarks
The default implementation of this method creates an ExpandableCollectionConverter instance.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.Dispose Method

CollectionPropertyDescriptorPropertyModelDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides PropertyDescriptorPropertyModelDispose(Boolean).)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.Dispose Method (Boolean)

CollectionPropertyDescriptorPropertyModelDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel.OnPropertyChanged Method

CollectionPropertyDescriptorPropertyModelOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDescriptorPropertyModel Events

CollectionPropertyDescriptorPropertyModel Events

The CollectionPropertyDescriptorPropertyModel type exposes the following members.

Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CollectionPropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode Class

CollectionPropertyDisplayMode Class
Specifies the display mode of collection properties in the property grid.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCollectionPropertyDisplayMode

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CollectionPropertyDisplayMode : Enum
Public NotInheritable Class CollectionPropertyDisplayMode
    Inherits Enum

The CollectionPropertyDisplayMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Indicates that collections will only be expandable if the associated type converter supports it.
 | EditableInline | Indicates that collections will be forced to be expandable if a custom type converter has not been specified. In addition, inline editing buttons will be used when possible.
 | Expandable | Indicates that collections will be forced to be expandable if a custom type converter has not been specified.
Public field | value__ |
Top
Remarks
The Expandable and EditableInline values will only override default type converters. If a custom type converter is used, the collection may not be expandable.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode Methods

CollectionPropertyDisplayMode Methods

The CollectionPropertyDisplayMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CollectionPropertyDisplayMode Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode Fields

CollectionPropertyDisplayMode Fields

The CollectionPropertyDisplayMode type exposes the following members.

Fields
 | Name | Description
 | Default | Indicates that collections will only be expandable if the associated type converter supports it.
 | EditableInline | Indicates that collections will be forced to be expandable if a custom type converter has not been specified. In addition, inline editing buttons will be used when possible.
 | Expandable | Indicates that collections will be forced to be expandable if a custom type converter has not been specified.
Public field | value__ |
Top
See Also

Reference

CollectionPropertyDisplayMode Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode.Default Field

CollectionPropertyDisplayModeDefault Field
Indicates that collections will only be expandable if the associated type converter supports it.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CollectionPropertyDisplayMode Default = 0
Public Const Default As CollectionPropertyDisplayMode = 0

Field Value

Type: CollectionPropertyDisplayMode
See Also

Reference

CollectionPropertyDisplayMode Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode.EditableInline Field

CollectionPropertyDisplayModeEditableInline Field
Indicates that collections will be forced to be expandable if a custom type converter has not been specified. In addition, inline editing buttons will be used when possible.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CollectionPropertyDisplayMode EditableInline = 2
Public Const EditableInline As CollectionPropertyDisplayMode = 2

Field Value

Type: CollectionPropertyDisplayMode
See Also

Reference

CollectionPropertyDisplayMode Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode.Expandable Field

CollectionPropertyDisplayModeExpandable Field
Indicates that collections will be forced to be expandable if a custom type converter has not been specified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CollectionPropertyDisplayMode Expandable = 1
Public Const Expandable As CollectionPropertyDisplayMode = 1

Field Value

Type: CollectionPropertyDisplayMode
See Also

Reference

CollectionPropertyDisplayMode Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionPropertyDisplayMode.value__ Field

CollectionPropertyDisplayModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData.CollectionPropertyDisplayMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CollectionPropertyDisplayMode Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase Class

DataFactoryBase Class
Provides an abstract base class for an IDataFactory implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataFactoryBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataTypeReflectionFactory

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DataFactoryBase : IDataFactory
Public MustInherit Class DataFactoryBase
    Implements IDataFactory

The DataFactoryBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataFactoryBase | Initializes a new instance of the DataFactoryBase class
Top
Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection.
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor.
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase Constructor

DataFactoryBase Constructor
Initializes a new instance of the DataFactoryBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DataFactoryBase()
Protected Sub New
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase Methods

DataFactoryBase Methods

The DataFactoryBase type exposes the following members.

Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection.
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor.
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.CategorizeDataModels Method

DataFactoryBaseCategorizeDataModels Method
Returns a categorized variation of the specified data models collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IList<IDataModel> CategorizeDataModels(
    IList<IDataModel> models,
    IDataFactoryRequest request
)
Protected Overridable Function CategorizeDataModels (
    models As IList(Of IDataModel),
    request As IDataFactoryRequest
) As IList(Of IDataModel)

Parameters

models
Type: System.Collections.GenericIList IDataModel
The collection of data models to sort.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IDataModel
A categorized variation of the specified data models collection.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.CreateCategoryEditorModel Method

DataFactoryBaseCreateCategoryEditorModel Method
Creates an ICategoryEditorModel for the specified CategoryEditor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual ICategoryEditorModel CreateCategoryEditorModel(
    CategoryEditor categoryEditor,
    IDataFactoryRequest request
)
Protected Overridable Function CreateCategoryEditorModel (
    categoryEditor As CategoryEditor,
    request As IDataFactoryRequest
) As ICategoryEditorModel

Parameters

categoryEditor
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditor
The CategoryEditor that was used to create the data model.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: ICategoryEditorModel
The ICategoryEditorModel that was created.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.CreateCategoryModel Method

DataFactoryBaseCreateCategoryModel Method
Creates an ICategoryModel for the specified category name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual ICategoryModel CreateCategoryModel(
    string name,
    IDataFactoryRequest request
)
Protected Overridable Function CreateCategoryModel (
    name As String,
    request As IDataFactoryRequest
) As ICategoryModel

Parameters

name
Type: SystemString
The category name.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: ICategoryModel
The ICategoryModel that was created.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.CreateMergedPropertyModel Method

DataFactoryBaseCreateMergedPropertyModel Method
Creates an IPropertyModel that merges a common property from multiple data objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IPropertyModel CreateMergedPropertyModel(
    IList<IPropertyModel> propertyModels,
    IDataFactoryRequest request
)
Protected Overridable Function CreateMergedPropertyModel (
    propertyModels As IList(Of IPropertyModel),
    request As IDataFactoryRequest
) As IPropertyModel

Parameters

propertyModels
Type: System.Collections.GenericIList IPropertyModel
The collection of IPropertyModel objects to merge.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IPropertyModel
The IPropertyModel that was created.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.GetDataModels Method

DataFactoryBaseGetDataModels Method
Returns the IDataModel collection for the requested object values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IList<IDataModel> GetDataModels(
    IDataFactoryRequest request
)
Public Overridable Function GetDataModels (
    request As IDataFactoryRequest
) As IList(Of IDataModel)

Parameters

request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IDataModel
A collection of IDataModel objects, if any were returned.

Implements

IDataFactoryGetDataModels(IDataFactoryRequest)
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.GetPropertyModels Method

DataFactoryBaseGetPropertyModels Method
Returns the IPropertyModel collection for the specified data object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IList<IPropertyModel> GetPropertyModels(
    Object dataObject,
    IDataFactoryRequest request
)
Protected MustOverride Function GetPropertyModels (
    dataObject As Object,
    request As IDataFactoryRequest
) As IList(Of IPropertyModel)

Parameters

dataObject
Type: SystemObject
The single object to examine.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IPropertyModel
A collection of IPropertyModel objects, if the specified data object has any properties.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataFactoryBase.SortDataModels Method

DataFactoryBaseSortDataModels Method
Returns a sorted variation of the specified data models collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IList<IDataModel> SortDataModels(
    IList<IDataModel> models,
    IDataFactoryRequest request,
    DataModelSortComparer sortComparer
)
Protected Overridable Function SortDataModels (
    models As IList(Of IDataModel),
    request As IDataFactoryRequest,
    sortComparer As DataModelSortComparer
) As IList(Of IDataModel)

Parameters

models
Type: System.Collections.GenericIList IDataModel
The collection of data models to sort.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.
sortComparer
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelSortComparer
The DataModelSortComparer to use. Otherwise, fall back to the request's sort comparer.

Return Value

Type: IList IDataModel
A sorted variation of the specified data models collection.
See Also

Reference

DataFactoryBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase Class

DataModelBase Class
Provides an abstract base class for a property grid IDataModel.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCategoryEditorModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCategoryModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBase

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DataModelBase : ObservableObjectBase,
    IDataModel, IDisposable
Public MustInherit Class DataModelBase
    Inherits ObservableObjectBase
    Implements IDataModel, IDisposable

The DataModelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataModelBase | Initializes a new instance of the DataModelBase class
Top
Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Protected property | IsModifiedResolved | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Protected property | NameResolved | Gets the resolved name of the data model.
Public property | Parent | Gets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase Constructor

DataModelBase Constructor
Initializes a new instance of the DataModelBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DataModelBase()
Protected Sub New
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase Properties

DataModelBase Properties

The DataModelBase type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip.
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Protected property | IsModifiedResolved | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Protected property | NameResolved | Gets the resolved name of the data model.
Public property | Parent | Gets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.CanAutoDispose Property

DataModelBaseCanAutoDispose Property
Gets whether the data model should be automatically disposed when it is removed from a parent data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanAutoDispose { get; }
Public Overridable ReadOnly Property CanAutoDispose As Boolean
    Get

Property Value

Type: Boolean
true if the data model should be automatically disposed when it is removed from a parent data model; otherwise, false.

Implements

IDataModelCanAutoDispose
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Children Property

DataModelBaseChildren Property
Gets the collection of child data models.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelCollection Children { get; }
Public ReadOnly Property Children As DataModelCollection
    Get

Property Value

Type: DataModelCollection
The collection of child data models.

Implements

IDataModelChildren
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.DescriptionResolved Property

DataModelBaseDescriptionResolved Property
Gets the resolved description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract string DescriptionResolved { get; }
Protected MustOverride ReadOnly Property DescriptionResolved As String
    Get

Property Value

Type: String
The resolved description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.DisplayNameResolved Property

DataModelBaseDisplayNameResolved Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract string DisplayNameResolved { get; }
Protected MustOverride ReadOnly Property DisplayNameResolved As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.IsExpanded Property

DataModelBaseIsExpanded Property
Gets or sets whether the data model is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is expanded; otherwise, false.

Implements

IDataModelIsExpanded
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.IsModifiedResolved Property

DataModelBaseIsModifiedResolved Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsModifiedResolved { get; }
Protected MustOverride ReadOnly Property IsModifiedResolved As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.IsRoot Property

DataModelBaseIsRoot Property
Gets whether the data model is the root.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsRoot { get; }
Public Overridable ReadOnly Property IsRoot As Boolean
    Get

Property Value

Type: Boolean
true if the data model is the root; otherwise, false.

Implements

IDataModelIsRoot
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.IsSelected Property

DataModelBaseIsSelected Property
Gets or sets whether the data model is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is selected; otherwise, false.

Implements

IDataModelIsSelected
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.NameResolved Property

DataModelBaseNameResolved Property
Gets the resolved name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract string NameResolved { get; }
Protected MustOverride ReadOnly Property NameResolved As String
    Get

Property Value

Type: String
The resolved name of the data model.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Parent Property

DataModelBaseParent Property
Gets the parent data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataModel Parent { get; }
Public ReadOnly Property Parent As IDataModel
    Get

Property Value

Type: IDataModel
The parent data model.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.SortComparer Property

DataModelBaseSortComparer Property
Gets or sets the DataModelSortComparer to use for sorting this data model's children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelSortComparer SortComparer { get; set; }
Public Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting this data model's children.

Implements

IDataModelSortComparer
Remarks
If this property doesn't return anything, the default SortComparer will be used.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.SortImportanceResolved Property

DataModelBaseSortImportanceResolved Property
Gets a resolved DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract DataModelSortImportance SortImportanceResolved { get; }
Protected MustOverride ReadOnly Property SortImportanceResolved As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.SortOrderResolved Property

DataModelBaseSortOrderResolved Property
Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract int SortOrderResolved { get; }
Protected MustOverride ReadOnly Property SortOrderResolved As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Tag Property

DataModelBaseTag Property
Gets or sets custom data for the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the data model.

Implements

IDataModelTag
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase Methods

DataModelBase Methods

The DataModelBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Dispose Method

DataModelBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Dispose Method

DataModelBaseDispose Method
Releases all resources used by the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

DataModelBase Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Dispose Method (Boolean)

DataModelBaseDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

DataModelBase Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.Finalize Method

DataModelBaseFinalize Method
Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.RefreshChildren Method

DataModelBaseRefreshChildren Method
Refreshes the contents of the Children property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void RefreshChildren()
Protected Overridable Sub RefreshChildren
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase.ToString Method

DataModelBaseToString Method
Returns a String representation of this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String representation of this instance.
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelBase Events

DataModelBase Events

The DataModelBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

DataModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection Class

DataModelCollection Class
Represents a collection of IDataModel objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataModel
System.Collections.ObjectModelObservableCollection IDataModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DataModelCollection : ObservableCollection<IDataModel>
Public Class DataModelCollection
    Inherits ObservableCollection(Of IDataModel)

The DataModelCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataModelCollection | Initializes a new instance of the DataModelCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection IDataModel .)
Public property | ItemInt32 | (Inherited from Collection IDataModel .)
Public property | ItemString | Gets the IDataModel in this collection that matches the specified name.
Protected property | Items | (Inherited from Collection IDataModel .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection IDataModel .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection IDataModel .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection IDataModel .)
Public method | Clear | (Inherited from Collection IDataModel .)
Protected method | ClearItems | (Inherited from ObservableCollection IDataModel .)
Public method | Contains | (Inherited from Collection IDataModel .)
Public method | CopyTo | (Inherited from Collection IDataModel .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection IDataModel .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection IDataModel .)
Public method | Insert | (Inherited from Collection IDataModel .)
Protected method | InsertItem | (Inherited from ObservableCollection IDataModel .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection IDataModel .)
Protected method | MoveItem | (Inherited from ObservableCollection IDataModel .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection IDataModel .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection IDataModel .)
Public method | Remove | (Inherited from Collection IDataModel .)
Public method | RemoveAt | (Inherited from Collection IDataModel .)
Protected method | RemoveItem | (Inherited from ObservableCollection IDataModel .)
Protected method | SetItem | (Inherited from ObservableCollection IDataModel .)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection IDataModel .)
Protected event | PropertyChanged | (Inherited from ObservableCollection IDataModel .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection Constructor

DataModelCollection Constructor
Initializes a new instance of the DataModelCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelCollection()
Public Sub New
See Also

Reference

DataModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection Properties

DataModelCollection Properties

The DataModelCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection IDataModel .)
Public property | ItemInt32 | (Inherited from Collection IDataModel .)
Public property | ItemString | Gets the IDataModel in this collection that matches the specified name.
Protected property | Items | (Inherited from Collection IDataModel .)
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection.Item Property

DataModelCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from Collection IDataModel .)
Public property | ItemString | Gets the IDataModel in this collection that matches the specified name.
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection.Item Property (String)

DataModelCollectionItem Property (String)
Gets the IDataModel in this collection that matches the specified name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataModel this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As IDataModel
    Get

Parameters

name
Type: SystemString

Property Value

Type: IDataModel
The IDataModel in this collection that matches the specified name.
See Also

Reference

DataModelCollection Class
Item Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection Methods

DataModelCollection Methods

The DataModelCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection IDataModel .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection IDataModel .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection IDataModel .)
Public method | Clear | (Inherited from Collection IDataModel .)
Protected method | ClearItems | (Inherited from ObservableCollection IDataModel .)
Public method | Contains | (Inherited from Collection IDataModel .)
Public method | CopyTo | (Inherited from Collection IDataModel .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection IDataModel .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection IDataModel .)
Public method | Insert | (Inherited from Collection IDataModel .)
Protected method | InsertItem | (Inherited from ObservableCollection IDataModel .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection IDataModel .)
Protected method | MoveItem | (Inherited from ObservableCollection IDataModel .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection IDataModel .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection IDataModel .)
Public method | Remove | (Inherited from Collection IDataModel .)
Public method | RemoveAt | (Inherited from Collection IDataModel .)
Protected method | RemoveItem | (Inherited from ObservableCollection IDataModel .)
Protected method | SetItem | (Inherited from ObservableCollection IDataModel .)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelCollection Events

DataModelCollection Events

The DataModelCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection IDataModel .)
Protected event | PropertyChanged | (Inherited from ObservableCollection IDataModel .)
Top
See Also

Reference

DataModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer Class

DataModelSortComparer Class
Provides a comparer implementation for sorting IDataModel objects in order of sort importance, sort order, numeric display name index (if applicable), and finally display name.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelSortComparer

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DataModelSortComparer : IComparer<IDataModel>
Public Class DataModelSortComparer
    Implements IComparer(Of IDataModel)

The DataModelSortComparer type exposes the following members.

Constructors
 | Name | Description
Public method | DataModelSortComparer | Initializes a new instance of the DataModelSortComparer class
Top
Properties
 | Name | Description
Public property | CanCompareDisplayName | Gets or sets whether display name can be compared.
Public property | CanCompareIndex | Gets or sets whether a numeric index value (e.g. [0]) in the display name can be compared.
Public property | CanCompareSortImportance | Gets or sets whether sort importance can be compared.
Public property | CanCompareSortOrder | Gets or sets whether sort order can be compared.
Top
Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareDisplayName | Compares two DisplayName values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareIndex | Compares two DisplayName values to see if they contain numeric indices (e.g. [0]) and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortImportance | Compares two SortImportance values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortOrder | Compares two SortOrder values and returns a value indicating whether one is less than, equal to or greater than the other.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer Constructor

DataModelSortComparer Constructor
Initializes a new instance of the DataModelSortComparer class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelSortComparer()
Public Sub New
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer Properties

DataModelSortComparer Properties

The DataModelSortComparer type exposes the following members.

Properties
 | Name | Description
Public property | CanCompareDisplayName | Gets or sets whether display name can be compared.
Public property | CanCompareIndex | Gets or sets whether a numeric index value (e.g. [0]) in the display name can be compared.
Public property | CanCompareSortImportance | Gets or sets whether sort importance can be compared.
Public property | CanCompareSortOrder | Gets or sets whether sort order can be compared.
Top
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareDisplayName Property

DataModelSortComparerCanCompareDisplayName Property
Gets or sets whether display name can be compared.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompareDisplayName { get; set; }
Public Property CanCompareDisplayName As Boolean
    Get
    Set

Property Value

Type: Boolean
true if display name can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareIndex Property

DataModelSortComparerCanCompareIndex Property
Gets or sets whether a numeric index value (e.g. [0]) in the display name can be compared.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompareIndex { get; set; }
Public Property CanCompareIndex As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a numeric index value (e.g. [0]) in the display name can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareSortImportance Property

DataModelSortComparerCanCompareSortImportance Property
Gets or sets whether sort importance can be compared.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompareSortImportance { get; set; }
Public Property CanCompareSortImportance As Boolean
    Get
    Set

Property Value

Type: Boolean
true if sort importance can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CanCompareSortOrder Property

DataModelSortComparerCanCompareSortOrder Property
Gets or sets whether sort order can be compared.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCompareSortOrder { get; set; }
Public Property CanCompareSortOrder As Boolean
    Get
    Set

Property Value

Type: Boolean
true if sort order can be compared; otherwise, false. The default value is true.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer Methods

DataModelSortComparer Methods

The DataModelSortComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two objects and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareDisplayName | Compares two DisplayName values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareIndex | Compares two DisplayName values to see if they contain numeric indices (e.g. [0]) and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortImportance | Compares two SortImportance values and returns a value indicating whether one is less than, equal to or greater than the other.
Protected method | CompareSortOrder | Compares two SortOrder values and returns a value indicating whether one is less than, equal to or greater than the other.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.Compare Method

DataModelSortComparerCompare Method
Compares two objects and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual int Compare(
    IDataModel left,
    IDataModel right
)
Public Overridable Function Compare (
    left As IDataModel,
    right As IDataModel
) As Integer

Parameters

left
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataModel
First object to compare.
right
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataModel
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.

Implements

IComparerTCompare(T, T)
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareDisplayName Method

DataModelSortComparerCompareDisplayName Method
Compares two DisplayName values and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual int CompareDisplayName(
    string left,
    string right
)
Protected Overridable Function CompareDisplayName (
    left As String,
    right As String
) As Integer

Parameters

left
Type: SystemString
First object to compare.
right
Type: SystemString
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareIndex Method

DataModelSortComparerCompareIndex Method
Compares two DisplayName values to see if they contain numeric indices (e.g. [0]) and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual int CompareIndex(
    string left,
    string right
)
Protected Overridable Function CompareIndex (
    left As String,
    right As String
) As Integer

Parameters

left
Type: SystemString
First object to compare.
right
Type: SystemString
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareSortImportance Method

DataModelSortComparerCompareSortImportance Method
Compares two SortImportance values and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual int CompareSortImportance(
    DataModelSortImportance left,
    DataModelSortImportance right
)
Protected Overridable Function CompareSortImportance (
    left As DataModelSortImportance,
    right As DataModelSortImportance
) As Integer

Parameters

left
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelSortImportance
First object to compare.
right
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelSortImportance
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortComparer.CompareSortOrder Method

DataModelSortComparerCompareSortOrder Method
Compares two SortOrder values and returns a value indicating whether one is less than, equal to or greater than the other.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual int CompareSortOrder(
    int left,
    int right
)
Protected Overridable Function CompareSortOrder (
    left As Integer,
    right As Integer
) As Integer

Parameters

left
Type: SystemInt32
First object to compare.
right
Type: SystemInt32
Second object to compare.

Return Value

Type: Int32
A value indicating whether one is less than, equal to or greater than the other.
See Also

Reference

DataModelSortComparer Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance Class

DataModelSortImportance Class
Specifies the sort importance of data models.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelSortImportance

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DataModelSortImportance : Enum
Public NotInheritable Class DataModelSortImportance
    Inherits Enum

The DataModelSortImportance type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AfterCategory | Indicates the data model should be sorted after categories.
 | AfterCategoryEditor | Indicates the data model should be sorted after category editors.
 | AfterProperty | Indicates the data model should be sorted after properties.
 | BeforeCategory | Indicates the data model should be sorted before categories.
 | BeforeCategoryEditor | Indicates the data model should be sorted before category editors.
 | BeforeProperty | Indicates the data model should be sorted before properties.
 | Category | Indicates the data model should be sorted as a category.
 | CategoryEditor | Indicates the data model should be sorted as a category editor.
 | Property | Indicates the data model should be sorted as a property.
Public field | value__ |
Top
Remarks
The standard sort order is: categories, category editors, and finally properties. The values of this enumeration allow data models to be placed in or around any of these three groups.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance Methods

DataModelSortImportance Methods

The DataModelSortImportance type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance Fields

DataModelSortImportance Fields

The DataModelSortImportance type exposes the following members.

Fields
 | Name | Description
 | AfterCategory | Indicates the data model should be sorted after categories.
 | AfterCategoryEditor | Indicates the data model should be sorted after category editors.
 | AfterProperty | Indicates the data model should be sorted after properties.
 | BeforeCategory | Indicates the data model should be sorted before categories.
 | BeforeCategoryEditor | Indicates the data model should be sorted before category editors.
 | BeforeProperty | Indicates the data model should be sorted before properties.
 | Category | Indicates the data model should be sorted as a category.
 | CategoryEditor | Indicates the data model should be sorted as a category editor.
 | Property | Indicates the data model should be sorted as a property.
Public field | value__ |
Top
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.AfterCategory Field

DataModelSortImportanceAfterCategory Field
Indicates the data model should be sorted after categories.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance AfterCategory = 2
Public Const AfterCategory As DataModelSortImportance = 2

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.AfterCategoryEditor Field

DataModelSortImportanceAfterCategoryEditor Field
Indicates the data model should be sorted after category editors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance AfterCategoryEditor = 5
Public Const AfterCategoryEditor As DataModelSortImportance = 5

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.AfterProperty Field

DataModelSortImportanceAfterProperty Field
Indicates the data model should be sorted after properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance AfterProperty = 8
Public Const AfterProperty As DataModelSortImportance = 8

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.BeforeCategory Field

DataModelSortImportanceBeforeCategory Field
Indicates the data model should be sorted before categories.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance BeforeCategory = 0
Public Const BeforeCategory As DataModelSortImportance = 0

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.BeforeCategoryEditor Field

DataModelSortImportanceBeforeCategoryEditor Field
Indicates the data model should be sorted before category editors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance BeforeCategoryEditor = 3
Public Const BeforeCategoryEditor As DataModelSortImportance = 3

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.BeforeProperty Field

DataModelSortImportanceBeforeProperty Field
Indicates the data model should be sorted before properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance BeforeProperty = 6
Public Const BeforeProperty As DataModelSortImportance = 6

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.Category Field

DataModelSortImportanceCategory Field
Indicates the data model should be sorted as a category.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance Category = 1
Public Const Category As DataModelSortImportance = 1

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.CategoryEditor Field

DataModelSortImportanceCategoryEditor Field
Indicates the data model should be sorted as a category editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance CategoryEditor = 4
Public Const CategoryEditor As DataModelSortImportance = 4

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.Property Field

DataModelSortImportanceProperty Field
Indicates the data model should be sorted as a property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DataModelSortImportance Property = 7
Public Const Property As DataModelSortImportance = 7

Field Value

Type: DataModelSortImportance
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DataModelSortImportance.value__ Field

DataModelSortImportancevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData.DataModelSortImportance.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DataModelSortImportance Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Class

ExpandableCollectionConverter Class
Represents a type converter that is capable of expanding various collection types.
Inheritance Hierarchy
SystemObject
TypeConverter
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataExpandableCollectionConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExpandableCollectionConverter : TypeConverter,
    ICollectionTypeConverter
Public Class ExpandableCollectionConverter
    Inherits TypeConverter
    Implements ICollectionTypeConverter

The ExpandableCollectionConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverter | Initializes a new instance of the ExpandableCollectionConverter class.
Public method | ExpandableCollectionConverter(Boolean, Boolean) | Initializes a new instance of the ExpandableCollectionConverter class.
Top
Properties
 | Name | Description
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | MultipleItemsFormat | Gets or sets the format for text to return when there are multiple items.
Public property | NoItemsText | Gets or sets the text to return when there are no items.
Public property | OneItemText | Gets or sets the text to return when there is one item.
Top
Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertTo | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Protected method | CreateCollectionItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the collection item.
Protected method | CreateDictionaryItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the dictionary item.
Public method | CreateItem | Creates a new item that can be added into to the collection.
Protected method | CreateListItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the list item.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetCollectionProperties | Gets a collection of properties for the specified collection using the specified context and attributes.
Protected method | GetDictionaryProperties | Gets a collection of properties for the specified dictionary using the specified context and attributes.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetListProperties | Gets a collection of properties for the specified list using the specified context and attributes.
Public method | GetProperties | Gets a collection of properties for the value using the specified context and attributes. (Overrides TypeConverter.GetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Gets a value indicating whether this object supports properties. (Overrides TypeConverter.GetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Constructor

ExpandableCollectionConverter Constructor
Overload List
 | Name | Description
Public method | ExpandableCollectionConverter | Initializes a new instance of the ExpandableCollectionConverter class.
Public method | ExpandableCollectionConverter(Boolean, Boolean) | Initializes a new instance of the ExpandableCollectionConverter class.
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Constructor

ExpandableCollectionConverter Constructor
Initializes a new instance of the ExpandableCollectionConverter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExpandableCollectionConverter()
Public Sub New
See Also

Reference

ExpandableCollectionConverter Class
ExpandableCollectionConverter Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Constructor (Boolean, Boolean)

ExpandableCollectionConverter Constructor (Boolean, Boolean)
Initializes a new instance of the ExpandableCollectionConverter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExpandableCollectionConverter(
    bool isCollectionReadOnly,
    bool areItemsReadOnly
)
Public Sub New (
    isCollectionReadOnly As Boolean,
    areItemsReadOnly As Boolean
)

Parameters

isCollectionReadOnly
Type: SystemBoolean
Whether items can be added to or removed from the collection.
areItemsReadOnly
Type: SystemBoolean
Whether the values of the items in the collection are read-only and cannot be changed.
See Also

Reference

ExpandableCollectionConverter Class
ExpandableCollectionConverter Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Properties

ExpandableCollectionConverter Properties

The ExpandableCollectionConverter type exposes the following members.

Properties
 | Name | Description
Public property | AreItemsReadOnly | Gets whether the values of the items in the collection are read-only and cannot be changed.
Public property | IsCollectionReadOnly | Gets whether items can be added to or removed from the collection.
Public property | MultipleItemsFormat | Gets or sets the format for text to return when there are multiple items.
Public property | NoItemsText | Gets or sets the text to return when there are no items.
Public property | OneItemText | Gets or sets the text to return when there is one item.
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.AreItemsReadOnly Property

ExpandableCollectionConverterAreItemsReadOnly Property
Gets whether the values of the items in the collection are read-only and cannot be changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreItemsReadOnly { get; }
Public ReadOnly Property AreItemsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the values of the items in the collection are read-only and cannot be changed; otherwise, false.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.IsCollectionReadOnly Property

ExpandableCollectionConverterIsCollectionReadOnly Property
Gets whether items can be added to or removed from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCollectionReadOnly { get; }
Public ReadOnly Property IsCollectionReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if items can be added to or removed from the collection; otherwise, false.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.MultipleItemsFormat Property

ExpandableCollectionConverterMultipleItemsFormat Property
Gets or sets the format for text to return when there are multiple items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string MultipleItemsFormat { get; set; }
Public Property MultipleItemsFormat As String
    Get
    Set

Property Value

Type: String
The format for text to return when there are multiple items. The default value is "{0} items".
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.NoItemsText Property

ExpandableCollectionConverterNoItemsText Property
Gets or sets the text to return when there are no items.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string NoItemsText { get; set; }
Public Property NoItemsText As String
    Get
    Set

Property Value

Type: String
The text to return when there are no items. The default value is "No items".
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.OneItemText Property

ExpandableCollectionConverterOneItemText Property
Gets or sets the text to return when there is one item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string OneItemText { get; set; }
Public Property OneItemText As String
    Get
    Set

Property Value

Type: String
The text to return when there is one item. The default value is "1 item".
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter Methods

ExpandableCollectionConverter Methods

The ExpandableCollectionConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertTo | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Protected method | CreateCollectionItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the collection item.
Protected method | CreateDictionaryItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the dictionary item.
Public method | CreateItem | Creates a new item that can be added into to the collection.
Protected method | CreateListItemPropertyDescriptor | Creates an instance of PropertyDescriptor for the list item.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Protected method | GetCollectionProperties | Gets a collection of properties for the specified collection using the specified context and attributes.
Protected method | GetDictionaryProperties | Gets a collection of properties for the specified dictionary using the specified context and attributes.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetListProperties | Gets a collection of properties for the specified list using the specified context and attributes.
Public method | GetProperties | Gets a collection of properties for the value using the specified context and attributes. (Overrides TypeConverter.GetProperties(ITypeDescriptorContext, Object, Attribute).)
Public method | GetPropertiesSupported | Gets a value indicating whether this object supports properties. (Overrides TypeConverter.GetPropertiesSupported(ITypeDescriptorContext).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.AddItem Method

ExpandableCollectionConverterAddItem Method
Adds the specified item into to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool AddItem(
    IPropertyModel propertyModel,
    Object item
)
Public Overridable Function AddItem (
    propertyModel As IPropertyModel,
    item As Object
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.
item
Type: SystemObject
The item that should be added.

Return Value

Type: Boolean
true if the item was added to the collection; otherwise, false.

Implements

ICollectionTypeConverterAddItem(IPropertyModel, Object)
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CanAddItem Method

ExpandableCollectionConverterCanAddItem Method
Gets a value indicating whether a new item can be added to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanAddItem(
    IPropertyModel propertyModel
)
Public Overridable Function CanAddItem (
    propertyModel As IPropertyModel
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Boolean
true if a new item can be added to the collection; otherwise, false.

Implements

ICollectionTypeConverterCanAddItem(IPropertyModel)
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CanConvertTo Method

ExpandableCollectionConverterCanConvertTo Method
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ConvertTo Method

ExpandableCollectionConverterConvertTo Method
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo object. If is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateCollectionItemPropertyDescriptor Method

ExpandableCollectionConverterCreateCollectionItemPropertyDescriptor Method
Creates an instance of PropertyDescriptor for the collection item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor CreateCollectionItemPropertyDescriptor(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    ICollection collection,
    int index,
    Object item,
    Type itemType
)
Protected Overridable Function CreateCollectionItemPropertyDescriptor (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    collection As ICollection,
    index As Integer,
    item As Object,
    itemType As Type
) As PropertyDescriptor

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
collection
Type: System.CollectionsICollection
The collection that contains the item.
index
Type: SystemInt32
The index of the item in the collection.
item
Type: SystemObject
The item in the collection.
itemType
Type: SystemType
Type of the item.

Return Value

Type: PropertyDescriptor
An instance of PropertyDescriptor for the collection item.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateDictionaryItemPropertyDescriptor Method

ExpandableCollectionConverterCreateDictionaryItemPropertyDescriptor Method
Creates an instance of PropertyDescriptor for the dictionary item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor CreateDictionaryItemPropertyDescriptor(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IDictionary dictionary,
    Object key,
    Type itemType
)
Protected Overridable Function CreateDictionaryItemPropertyDescriptor (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    dictionary As IDictionary,
    key As Object,
    itemType As Type
) As PropertyDescriptor

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
dictionary
Type: System.CollectionsIDictionary
The dictionary that contains the item.
key
Type: SystemObject
The key of the item in the dictionary.
itemType
Type: SystemType
Type of the item.

Return Value

Type: PropertyDescriptor
An instance of PropertyDescriptor for the dictionary item.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateItem Method

ExpandableCollectionConverterCreateItem Method
Creates a new item that can be added into to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object CreateItem(
    IPropertyModel propertyModel
)
Public Overridable Function CreateItem (
    propertyModel As IPropertyModel
) As Object

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Object
The item that was created.

Implements

ICollectionTypeConverterCreateItem(IPropertyModel)
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CreateListItemPropertyDescriptor Method

ExpandableCollectionConverterCreateListItemPropertyDescriptor Method
Creates an instance of PropertyDescriptor for the list item.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor CreateListItemPropertyDescriptor(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IList list,
    int index,
    Type itemType
)
Protected Overridable Function CreateListItemPropertyDescriptor (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    list As IList,
    index As Integer,
    itemType As Type
) As PropertyDescriptor

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
list
Type: System.CollectionsIList
The list that contains the item.
index
Type: SystemInt32
The index of the item in the list.
itemType
Type: SystemType
Type of the item.

Return Value

Type: PropertyDescriptor
An instance of PropertyDescriptor for the list item.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetCollectionProperties Method

ExpandableCollectionConverterGetCollectionProperties Method
Gets a collection of properties for the specified collection using the specified context and attributes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor[] GetCollectionProperties(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    ICollection collection
)
Protected Overridable Function GetCollectionProperties (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    collection As ICollection
) As PropertyDescriptor()

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
collection
Type: System.CollectionsICollection
The collection whose properties should be returned.

Return Value

Type: PropertyDescriptor
A PropertyDescriptor array with the properties associated with the specified collection, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetDictionaryProperties Method

ExpandableCollectionConverterGetDictionaryProperties Method
Gets a collection of properties for the specified dictionary using the specified context and attributes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor[] GetDictionaryProperties(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IDictionary dictionary
)
Protected Overridable Function GetDictionaryProperties (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    dictionary As IDictionary
) As PropertyDescriptor()

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
dictionary
Type: System.CollectionsIDictionary
The dictionary whose properties should be returned.

Return Value

Type: PropertyDescriptor
A PropertyDescriptor array with the properties associated with the specified dictionary, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetListProperties Method

ExpandableCollectionConverterGetListProperties Method
Gets a collection of properties for the specified list using the specified context and attributes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual PropertyDescriptor[] GetListProperties(
    ITypeDescriptorContext context,
    Attribute[] attributes,
    IList list
)
Protected Overridable Function GetListProperties (
    context As ITypeDescriptorContext,
    attributes As Attribute(),
    list As IList
) As PropertyDescriptor()

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.
list
Type: System.CollectionsIList
The list whose properties should be returned.

Return Value

Type: PropertyDescriptor
A PropertyDescriptor array with the properties associated with the specified list, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetProperties Method

ExpandableCollectionConverterGetProperties Method
Gets a collection of properties for the value using the specified context and attributes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties (
    context As ITypeDescriptorContext,
    value As Object,
    attributes As Attribute()
) As PropertyDescriptorCollection

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
value
Type: SystemObject
An Object that specifies the type to get the properties for.
attributes
Type: SystemAttribute
An array of type Attribute that will be used as a filter.

Return Value

Type: PropertyDescriptorCollection
A PropertyDescriptorCollection with the properties that are exposed for this data type, or if there are no properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.GetPropertiesSupported Method

ExpandableCollectionConverterGetPropertiesSupported Method
Gets a value indicating whether this object supports properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported (
    context As ITypeDescriptorContext
) As Boolean

Parameters

context
Type: ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.

Return Value

Type: Boolean
true if properties are supported; otherwise, false.
Remarks
The default method implementation always returns true since child items should be accessible as nested properties.
See Also

Reference

ExpandableCollectionConverter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor Class

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
Represents a PropertyDescriptor for an item in a read-only collection.
Inheritance Hierarchy
SystemObject
PropertyDescriptor
SimplePropertyDescriptor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataExpandableCollectionConverterCollectionItemPropertyDescriptor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected class CollectionItemPropertyDescriptor : SimplePropertyDescriptor
Protected Class CollectionItemPropertyDescriptor
    Inherits SimplePropertyDescriptor

The ExpandableCollectionConverterCollectionItemPropertyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverterCollectionItemPropertyDescriptor | Initializes a new instance of the ExpandableCollectionConverterCollectionItemPropertyDescriptor class.
Top
Properties
 | Name | Description
Public property | IsReadOnly | Gets a value indicating whether this property is read-only. (Overrides SimplePropertyDescriptor.IsReadOnly.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor.GetValue(Object).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor.SetValue(Object, Object).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor Constructor

ExpandableCollectionConverterCollectionItemPropertyDescriptor Constructor
Initializes a new instance of the ExpandableCollectionConverterCollectionItemPropertyDescriptor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollectionItemPropertyDescriptor(
    ICollection collection,
    int index,
    Object item,
    Type itemType,
    Attribute[] attributes
)
Public Sub New (
    collection As ICollection,
    index As Integer,
    item As Object,
    itemType As Type,
    attributes As Attribute()
)

Parameters

collection
Type: System.CollectionsICollection
The collection associated with the item.
index
Type: SystemInt32
The index of the item in the collection.
item
Type: SystemObject
The item in the collection.
itemType
Type: SystemType
Type of the item.
attributes
Type: SystemAttribute
An Attribute[] with attributes to associated with the property.
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionItemPropertyDescriptor Properties

CollectionItemPropertyDescriptor Properties

The ExpandableCollectionConverterCollectionItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | IsReadOnly | Gets a value indicating whether this property is read-only. (Overrides SimplePropertyDescriptor.IsReadOnly.)
Top
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor.IsReadOnly Property

ExpandableCollectionConverterCollectionItemPropertyDescriptorIsReadOnly Property
Gets a value indicating whether this property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
true if the property is read-only; false if the property is read/write.
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


CollectionItemPropertyDescriptor Methods

CollectionItemPropertyDescriptor Methods

The ExpandableCollectionConverterCollectionItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor.GetValue(Object).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor.SetValue(Object, Object).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor.GetValue Method

ExpandableCollectionConverterCollectionItemPropertyDescriptorGetValue Method
When overridden in a derived class, gets the current value of the property on a component.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object

Parameters

component
Type: SystemObject
The component with the property for which to retrieve the value.

Return Value

Type: Object
The value of a property for a given component.
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.CollectionItemPropertyDescriptor.SetValue Method

ExpandableCollectionConverterCollectionItemPropertyDescriptorSetValue Method
When overridden in a derived class, sets the value of the component to a different value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)

Parameters

component
Type: SystemObject
The component with the property value that is to be set.
value
Type: SystemObject
The new value.
See Also

Reference

ExpandableCollectionConverterCollectionItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor Class

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
Represents a PropertyDescriptor for an item in a dictionary.
Inheritance Hierarchy
SystemObject
PropertyDescriptor
SimplePropertyDescriptor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataExpandableCollectionConverterDictionaryItemPropertyDescriptor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected class DictionaryItemPropertyDescriptor : SimplePropertyDescriptor,
    ICollectionItemPropertyDescriptor
Protected Class DictionaryItemPropertyDescriptor
    Inherits SimplePropertyDescriptor
    Implements ICollectionItemPropertyDescriptor

The ExpandableCollectionConverterDictionaryItemPropertyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverterDictionaryItemPropertyDescriptor | Initializes a new instance of the ExpandableCollectionConverterDictionaryItemPropertyDescriptor class.
Top
Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Public property | Dictionary | Gets the dictionary associated with this property descriptor.
Public property | IsReadOnly | Gets a value indicating whether this property is read-only. (Overrides SimplePropertyDescriptor.IsReadOnly.)
Public property | Key | Gets the key of the dictionary item associated with this property descriptor.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor.GetValue(Object).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | Removes this item from the associated collection.
Public method | SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor.SetValue(Object, Object).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor Constructor

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Constructor
Initializes a new instance of the ExpandableCollectionConverterDictionaryItemPropertyDescriptor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DictionaryItemPropertyDescriptor(
    IDictionary dictionary,
    Object key,
    Type itemType,
    Attribute[] attributes,
    bool isCollectionReadOnly,
    bool isReadOnly
)
Public Sub New (
    dictionary As IDictionary,
    key As Object,
    itemType As Type,
    attributes As Attribute(),
    isCollectionReadOnly As Boolean,
    isReadOnly As Boolean
)

Parameters

dictionary
Type: System.CollectionsIDictionary
The dictionary associated with the item.
key
Type: SystemObject
The key of the item in the dictionary.
itemType
Type: SystemType
Type of the item.
attributes
Type: SystemAttribute
An Attribute[] with attributes to associated with the property.
isCollectionReadOnly
Type: SystemBoolean
Whether the dictionary is forced to be read-only, and this item cannot be removed from it.
isReadOnly
Type: SystemBoolean
if set to true then this property will be read-only.
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DictionaryItemPropertyDescriptor Properties

DictionaryItemPropertyDescriptor Properties

The ExpandableCollectionConverterDictionaryItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Public property | Dictionary | Gets the dictionary associated with this property descriptor.
Public property | IsReadOnly | Gets a value indicating whether this property is read-only. (Overrides SimplePropertyDescriptor.IsReadOnly.)
Public property | Key | Gets the key of the dictionary item associated with this property descriptor.
Top
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.CanRemove Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorCanRemove Property
Gets a value indicating whether the collection item can be removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the collection item can be removed; otherwise, false.

Implements

ICollectionItemPropertyDescriptorCanRemove
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Dictionary Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorDictionary Property
Gets the dictionary associated with this property descriptor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDictionary Dictionary { get; }
Public ReadOnly Property Dictionary As IDictionary
    Get

Property Value

Type: IDictionary
The dictionary associated with this property descriptor.
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.IsReadOnly Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorIsReadOnly Property
Gets a value indicating whether this property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
true if the property is read-only; false if the property is read/write.
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Key Property

ExpandableCollectionConverterDictionaryItemPropertyDescriptorKey Property
Gets the key of the dictionary item associated with this property descriptor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Key { get; }
Public ReadOnly Property Key As Object
    Get

Property Value

Type: Object
The key of the dictionary item associated with this property descriptor.
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


DictionaryItemPropertyDescriptor Methods

DictionaryItemPropertyDescriptor Methods

The ExpandableCollectionConverterDictionaryItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor.GetValue(Object).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | Removes this item from the associated collection.
Public method | SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor.SetValue(Object, Object).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.GetValue Method

ExpandableCollectionConverterDictionaryItemPropertyDescriptorGetValue Method
When overridden in a derived class, gets the current value of the property on a component.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object

Parameters

component
Type: SystemObject
The component with the property for which to retrieve the value.

Return Value

Type: Object
The value of a property for a given component.
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.Remove Method

ExpandableCollectionConverterDictionaryItemPropertyDescriptorRemove Method
Removes this item from the associated collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Remove()
Public Overridable Function Remove As Boolean

Return Value

Type: Boolean
true if the item was removed; otherwise, false.

Implements

ICollectionItemPropertyDescriptorRemove
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.DictionaryItemPropertyDescriptor.SetValue Method

ExpandableCollectionConverterDictionaryItemPropertyDescriptorSetValue Method
When overridden in a derived class, sets the value of the component to a different value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)

Parameters

component
Type: SystemObject
The component with the property value that is to be set.
value
Type: SystemObject
The new value.
See Also

Reference

ExpandableCollectionConverterDictionaryItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor Class

ExpandableCollectionConverterListItemPropertyDescriptor Class
Represents a PropertyDescriptor for an item in a list.
Inheritance Hierarchy
SystemObject
PropertyDescriptor
SimplePropertyDescriptor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataExpandableCollectionConverterListItemPropertyDescriptor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected class ListItemPropertyDescriptor : SimplePropertyDescriptor,
    ICollectionItemPropertyDescriptor
Protected Class ListItemPropertyDescriptor
    Inherits SimplePropertyDescriptor
    Implements ICollectionItemPropertyDescriptor

The ExpandableCollectionConverterListItemPropertyDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpandableCollectionConverterListItemPropertyDescriptor | Initializes a new instance of the ExpandableCollectionConverterListItemPropertyDescriptor class.
Top
Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Public property | Index | Gets the index of the list item associated with this property descriptor.
Public property | IsReadOnly | Gets a value indicating whether this property is read-only. (Overrides SimplePropertyDescriptor.IsReadOnly.)
Public property | List | Gets the list associated with this property descriptor.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor.GetValue(Object).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | Removes this item from the associated collection.
Public method | SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor.SetValue(Object, Object).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor Constructor

ExpandableCollectionConverterListItemPropertyDescriptor Constructor
Initializes a new instance of the ExpandableCollectionConverterListItemPropertyDescriptor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ListItemPropertyDescriptor(
    IList list,
    int index,
    Type itemType,
    Attribute[] attributes,
    bool isCollectionReadOnly,
    bool isReadOnly
)
Public Sub New (
    list As IList,
    index As Integer,
    itemType As Type,
    attributes As Attribute(),
    isCollectionReadOnly As Boolean,
    isReadOnly As Boolean
)

Parameters

list
Type: System.CollectionsIList
The list associated with the item.
index
Type: SystemInt32
The index of the item in the list.
itemType
Type: SystemType
Type of the item.
attributes
Type: SystemAttribute
An Attribute[] with attributes to associated with the property.
isCollectionReadOnly
Type: SystemBoolean
Whether the list is forced to be read-only, and this item cannot be removed from it.
isReadOnly
Type: SystemBoolean
if set to true then this property will be read-only.
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ListItemPropertyDescriptor Properties

ListItemPropertyDescriptor Properties

The ExpandableCollectionConverterListItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Public property | Index | Gets the index of the list item associated with this property descriptor.
Public property | IsReadOnly | Gets a value indicating whether this property is read-only. (Overrides SimplePropertyDescriptor.IsReadOnly.)
Public property | List | Gets the list associated with this property descriptor.
Top
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.CanRemove Property

ExpandableCollectionConverterListItemPropertyDescriptorCanRemove Property
Gets a value indicating whether the collection item can be removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the collection item can be removed; otherwise, false.

Implements

ICollectionItemPropertyDescriptorCanRemove
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.Index Property

ExpandableCollectionConverterListItemPropertyDescriptorIndex Property
Gets the index of the list item associated with this property descriptor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the list item associated with this property descriptor.
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.IsReadOnly Property

ExpandableCollectionConverterListItemPropertyDescriptorIsReadOnly Property
Gets a value indicating whether this property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
true if the property is read-only; false if the property is read/write.
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.List Property

ExpandableCollectionConverterListItemPropertyDescriptorList Property
Gets the list associated with this property descriptor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IList List { get; }
Public ReadOnly Property List As IList
    Get

Property Value

Type: IList
The list associated with this property descriptor.
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ListItemPropertyDescriptor Methods

ListItemPropertyDescriptor Methods

The ExpandableCollectionConverterListItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | When overridden in a derived class, gets the current value of the property on a component. (Overrides PropertyDescriptor.GetValue(Object).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Remove | Removes this item from the associated collection.
Public method | SetValue | When overridden in a derived class, sets the value of the component to a different value. (Overrides PropertyDescriptor.SetValue(Object, Object).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.GetValue Method

ExpandableCollectionConverterListItemPropertyDescriptorGetValue Method
When overridden in a derived class, gets the current value of the property on a component.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object

Parameters

component
Type: SystemObject
The component with the property for which to retrieve the value.

Return Value

Type: Object
The value of a property for a given component.
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.Remove Method

ExpandableCollectionConverterListItemPropertyDescriptorRemove Method
Removes this item from the associated collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool Remove()
Public Overridable Function Remove As Boolean

Return Value

Type: Boolean
true if the item was removed; otherwise, false.

Implements

ICollectionItemPropertyDescriptorRemove
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ExpandableCollectionConverter.ListItemPropertyDescriptor.SetValue Method

ExpandableCollectionConverterListItemPropertyDescriptorSetValue Method
When overridden in a derived class, sets the value of the component to a different value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)

Parameters

component
Type: SystemObject
The component with the property value that is to be set.
value
Type: SystemObject
The new value.
See Also

Reference

ExpandableCollectionConverterListItemPropertyDescriptor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryEditorModel Interface

ICategoryEditorModel Interface
Provides the requirements for a property grid category editor IDataModel, that can consume and display one or more properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICategoryEditorModel : IDataModel,
    IDisposable
Public Interface ICategoryEditorModel
    Inherits IDataModel, IDisposable

The ICategoryEditorModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryEditorModel Properties

ICategoryEditorModel Properties

The ICategoryEditorModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | EditorTemplate | Gets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryEditorModel.EditorTemplate Property

ICategoryEditorModelEditorTemplate Property
Gets the DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataTemplate EditorTemplate { get; }
ReadOnly Property EditorTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryEditorModel.EditorTemplateKey Property

ICategoryEditorModelEditorTemplateKey Property
Gets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object EditorTemplateKey { get; }
ReadOnly Property EditorTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryEditorModel Methods

ICategoryEditorModel Methods

The ICategoryEditorModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

ICategoryEditorModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryModel Interface

ICategoryModel Interface
Provides the requirements for a property grid category IDataModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICategoryModel : IDataModel,
    IDisposable
Public Interface ICategoryModel
    Inherits IDataModel, IDisposable

The ICategoryModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryModel Properties

ICategoryModel Properties

The ICategoryModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Top
See Also

Reference

ICategoryModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICategoryModel Methods

ICategoryModel Methods

The ICategoryModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

ICategoryModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor Interface

ICollectionItemPropertyDescriptor Interface
Identifies an object as a property descriptor for an item in a collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICollectionItemPropertyDescriptor
Public Interface ICollectionItemPropertyDescriptor

The ICollectionItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Top
Methods
 | Name | Description
Public method | Remove | Removes this item from the associated collection.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor Properties

ICollectionItemPropertyDescriptor Properties

The ICollectionItemPropertyDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | CanRemove | Gets a value indicating whether the collection item can be removed.
Top
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor.CanRemove Property

ICollectionItemPropertyDescriptorCanRemove Property
Gets a value indicating whether the collection item can be removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanRemove { get; }
ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the collection item can be removed; otherwise, false.
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor Methods

ICollectionItemPropertyDescriptor Methods

The ICollectionItemPropertyDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Remove | Removes this item from the associated collection.
Top
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionItemPropertyDescriptor.Remove Method

ICollectionItemPropertyDescriptorRemove Method
Removes this item from the associated collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Remove()
Function Remove As Boolean

Return Value

Type: Boolean
true if the item was removed; otherwise, false.
See Also

Reference

ICollectionItemPropertyDescriptor Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter Interface

ICollectionTypeConverter Interface
Identifies an object as a type converter for a collection used to control how and when items should be added.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICollectionTypeConverter
Public Interface ICollectionTypeConverter

The ICollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CreateItem | Creates a new item that can be added into to the collection.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter Methods

ICollectionTypeConverter Methods

The ICollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Adds the specified item into to the collection.
Public method | CanAddItem | Gets a value indicating whether a new item can be added to the collection.
Public method | CreateItem | Creates a new item that can be added into to the collection.
Top
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter.AddItem Method

ICollectionTypeConverterAddItem Method
Adds the specified item into to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AddItem(
    IPropertyModel propertyModel,
    Object item
)
Function AddItem (
    propertyModel As IPropertyModel,
    item As Object
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.
item
Type: SystemObject
The item that should be added.

Return Value

Type: Boolean
true if the item was added to the collection; otherwise, false.
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter.CanAddItem Method

ICollectionTypeConverterCanAddItem Method
Gets a value indicating whether a new item can be added to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanAddItem(
    IPropertyModel propertyModel
)
Function CanAddItem (
    propertyModel As IPropertyModel
) As Boolean

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Boolean
true if a new item can be added to the collection; otherwise, false.
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ICollectionTypeConverter.CreateItem Method

ICollectionTypeConverterCreateItem Method
Creates a new item that can be added into to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object CreateItem(
    IPropertyModel propertyModel
)
Function CreateItem (
    propertyModel As IPropertyModel
) As Object

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel associated with the collection.

Return Value

Type: Object
The item that was created.
See Also

Reference

ICollectionTypeConverter Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactory Interface

IDataFactory Interface
Provides the requirements for class that can return the data models for requested object values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDataFactory
Public Interface IDataFactory

The IDataFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactory Methods

IDataFactory Methods

The IDataFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetDataModels | Returns the IDataModel collection for the requested object values.
Top
See Also

Reference

IDataFactory Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactory.GetDataModels Method

IDataFactoryGetDataModels Method
Returns the IDataModel collection for the requested object values.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<IDataModel> GetDataModels(
    IDataFactoryRequest request
)
Function GetDataModels (
    request As IDataFactoryRequest
) As IList(Of IDataModel)

Parameters

request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IDataModel
A collection of IDataModel objects, if any were returned.
See Also

Reference

IDataFactory Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest Interface

IDataFactoryRequest Interface
Provides the core requirements of a request made to an IDataFactory.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDataFactoryRequest
Public Interface IDataFactoryRequest

The IDataFactoryRequest type exposes the following members.

Properties
 | Name | Description
Public property | AreCategoriesAutoExpanded | Gets whether categories are auto-expanded when they are added into the property grid.
Public property | AreInheritedPropertiesBrowsable | Gets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Public property | BrowsableAttributes | Gets or sets an array of Attribute objects that are used to determine which properties are browsable.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | DataObjects | Gets the objects for which data models are being requested.
Public property | IsCategorized | Gets whether properties are categorized.
Public property | IsHostReadOnly | Gets whether the host UI control (e.g. a property grid) is read-only.
Public property | MiscCategoryName | Gets the name used for the miscellaneous category.
Public property | Parent | Gets the IDataModel, if any, that is making the request.
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyExpandability | Gets a PropertyExpandability that indicates the expandability of properties.
Public property | SortComparer | Gets the DataModelSortComparer to use for sorting data models.
Public property | Source | Gets the object or control that originally made the request.
Public property | Tag | Gets or sets custom data for the request.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest Properties

IDataFactoryRequest Properties

The IDataFactoryRequest type exposes the following members.

Properties
 | Name | Description
Public property | AreCategoriesAutoExpanded | Gets whether categories are auto-expanded when they are added into the property grid.
Public property | AreInheritedPropertiesBrowsable | Gets whether inherited properties are browsable and are displayed in the property grid.
Public property | AreNestedCategoriesSupported | Gets whether nested categories are supported, using a special syntax in the category name.
Public property | ArePropertiesAutoExpanded | Gets whether expandable properties are auto-expanded when they are added into the property grid.
Public property | AreReadOnlyPropertiesBrowsable | Gets or sets whether read-only properties are browsable and are displayed in the property grid.
Public property | BrowsableAttributes | Gets or sets an array of Attribute objects that are used to determine which properties are browsable.
Public property | CategoryEditors | Gets the category editors that can consume and display one or more properties.
Public property | CollectionPropertyDisplayMode | Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.
Public property | DataObjects | Gets the objects for which data models are being requested.
Public property | IsCategorized | Gets whether properties are categorized.
Public property | IsHostReadOnly | Gets whether the host UI control (e.g. a property grid) is read-only.
Public property | MiscCategoryName | Gets the name used for the miscellaneous category.
Public property | Parent | Gets the IDataModel, if any, that is making the request.
Public property | Properties | Gets the explicitly-defined properties that should be displayed.
Public property | PropertyExpandability | Gets a PropertyExpandability that indicates the expandability of properties.
Public property | SortComparer | Gets the DataModelSortComparer to use for sorting data models.
Public property | Source | Gets the object or control that originally made the request.
Public property | Tag | Gets or sets custom data for the request.
Top
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreCategoriesAutoExpanded Property

IDataFactoryRequestAreCategoriesAutoExpanded Property
Gets whether categories are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreCategoriesAutoExpanded { get; }
ReadOnly Property AreCategoriesAutoExpanded As Boolean
    Get

Property Value

Type: Boolean
true if categories are auto-expanded when they are added into the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreInheritedPropertiesBrowsable Property

IDataFactoryRequestAreInheritedPropertiesBrowsable Property
Gets whether inherited properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreInheritedPropertiesBrowsable { get; }
ReadOnly Property AreInheritedPropertiesBrowsable As Boolean
    Get

Property Value

Type: Boolean
true if inherited properties are browsable and are displayed in the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreNestedCategoriesSupported Property

IDataFactoryRequestAreNestedCategoriesSupported Property
Gets whether nested categories are supported, using a special syntax in the category name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreNestedCategoriesSupported { get; }
ReadOnly Property AreNestedCategoriesSupported As Boolean
    Get

Property Value

Type: Boolean
true if nested categories are supported; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.ArePropertiesAutoExpanded Property

IDataFactoryRequestArePropertiesAutoExpanded Property
Gets whether expandable properties are auto-expanded when they are added into the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ArePropertiesAutoExpanded { get; }
ReadOnly Property ArePropertiesAutoExpanded As Boolean
    Get

Property Value

Type: Boolean
true if expandable properties are auto-expanded when they are added into the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.AreReadOnlyPropertiesBrowsable Property

IDataFactoryRequestAreReadOnlyPropertiesBrowsable Property
Gets or sets whether read-only properties are browsable and are displayed in the property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreReadOnlyPropertiesBrowsable { get; }
ReadOnly Property AreReadOnlyPropertiesBrowsable As Boolean
    Get

Property Value

Type: Boolean
true if read-only properties are browsable and are displayed in the property grid; otherwise false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.BrowsableAttributes Property

IDataFactoryRequestBrowsableAttributes Property
Gets or sets an array of Attribute objects that are used to determine which properties are browsable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<Attribute> BrowsableAttributes { get; }
ReadOnly Property BrowsableAttributes As IEnumerable(Of Attribute)
    Get

Property Value

Type: IEnumerable Attribute
The array of Attribute objects that are used to determine which properties are browsable. The default value is a list with a single entry of BrowsableAttribute.Yes.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.CategoryEditors Property

IDataFactoryRequestCategoryEditors Property
Gets the category editors that can consume and display one or more properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<CategoryEditor> CategoryEditors { get; }
ReadOnly Property CategoryEditors As IEnumerable(Of CategoryEditor)
    Get

Property Value

Type: IEnumerable CategoryEditor
The category editors that can consume and display one or more properties.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.CollectionPropertyDisplayMode Property

IDataFactoryRequestCollectionPropertyDisplayMode Property
Gets or sets a CollectionPropertyDisplayMode that indicates the display mode of collection properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CollectionPropertyDisplayMode CollectionPropertyDisplayMode { get; }
ReadOnly Property CollectionPropertyDisplayMode As CollectionPropertyDisplayMode
    Get

Property Value

Type: CollectionPropertyDisplayMode
A CollectionPropertyDisplayMode that indicates the display mode of collection properties. The default value is CollectionPropertyDisplayMode.Default.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.DataObjects Property

IDataFactoryRequestDataObjects Property
Gets the objects for which data models are being requested.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<Object> DataObjects { get; }
ReadOnly Property DataObjects As IList(Of Object)
    Get

Property Value

Type: IList Object
The objects for which data models are being requested.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.IsCategorized Property

IDataFactoryRequestIsCategorized Property
Gets whether properties are categorized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsCategorized { get; }
ReadOnly Property IsCategorized As Boolean
    Get

Property Value

Type: Boolean
true if properties are categorized; otherwise, false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.IsHostReadOnly Property

IDataFactoryRequestIsHostReadOnly Property
Gets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsHostReadOnly { get; }
ReadOnly Property IsHostReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.MiscCategoryName Property

IDataFactoryRequestMiscCategoryName Property
Gets the name used for the miscellaneous category.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string MiscCategoryName { get; }
ReadOnly Property MiscCategoryName As String
    Get

Property Value

Type: String
The name used for the miscellaneous category.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Parent Property

IDataFactoryRequestParent Property
Gets the IDataModel, if any, that is making the request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDataModel Parent { get; }
ReadOnly Property Parent As IDataModel
    Get

Property Value

Type: IDataModel
The IDataModel, if any, that is making the request.
Remarks
This property will not return a value if the request is for the root data models.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Properties Property

IDataFactoryRequestProperties Property
Gets the explicitly-defined properties that should be displayed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<IPropertyModel> Properties { get; }
ReadOnly Property Properties As IEnumerable(Of IPropertyModel)
    Get

Property Value

Type: IEnumerable IPropertyModel
the explicitly-defined properties that should be displayed
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.PropertyExpandability Property

IDataFactoryRequestPropertyExpandability Property
Gets a PropertyExpandability that indicates the expandability of properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PropertyExpandability PropertyExpandability { get; }
ReadOnly Property PropertyExpandability As PropertyExpandability
    Get

Property Value

Type: PropertyExpandability
A PropertyExpandability that indicates the expandability of properties.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.SortComparer Property

IDataFactoryRequestSortComparer Property
Gets the DataModelSortComparer to use for sorting data models.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataModelSortComparer SortComparer { get; }
ReadOnly Property SortComparer As DataModelSortComparer
    Get

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting data models.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Source Property

IDataFactoryRequestSource Property
Gets the object or control that originally made the request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Source { get; }
ReadOnly Property Source As Object
    Get

Property Value

Type: Object
The object or control that originally made the request.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataFactoryRequest.Tag Property

IDataFactoryRequestTag Property
Gets or sets custom data for the request.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the request.
See Also

Reference

IDataFactoryRequest Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel Interface

IDataModel Interface
Provides the requirements for a data model class that can represent a property or category in a property grid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDataModel : IDisposable
Public Interface IDataModel
    Inherits IDisposable

The IDataModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsInitialized | Gets or sets whether the data model has been initialized.
Public property | IsModified | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | Name | Gets the name of the data model.
Public property | Parent | Gets or sets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel Properties

IDataModel Properties

The IDataModel type exposes the following members.

Properties
 | Name | Description
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | Children | Gets the collection of child data models.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsInitialized | Gets or sets whether the data model has been initialized.
Public property | IsModified | Gets whether the data model has been modified.
Public property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | Name | Gets the name of the data model.
Public property | Parent | Gets or sets the parent data model.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | Tag | Gets or sets custom data for the data model.
Top
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.CanAutoDispose Property

IDataModelCanAutoDispose Property
Gets whether the data model should be automatically disposed when it is removed from a parent data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanAutoDispose { get; }
ReadOnly Property CanAutoDispose As Boolean
    Get

Property Value

Type: Boolean
true if the data model should be automatically disposed when it is removed from a parent data model; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.Children Property

IDataModelChildren Property
Gets the collection of child data models.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataModelCollection Children { get; }
ReadOnly Property Children As DataModelCollection
    Get

Property Value

Type: DataModelCollection
The collection of child data models.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.Description Property

IDataModelDescription Property
Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.DisplayName Property

IDataModelDisplayName Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DisplayName { get; }
ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.IsExpanded Property

IDataModelIsExpanded Property
Gets or sets whether the data model is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsExpanded { get; set; }
Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is expanded; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.IsInitialized Property

IDataModelIsInitialized Property
Gets or sets whether the data model has been initialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsInitialized { get; set; }
Property IsInitialized As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model has been initialized; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.IsModified Property

IDataModelIsModified Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsModified { get; }
ReadOnly Property IsModified As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.IsRoot Property

IDataModelIsRoot Property
Gets whether the data model is the root.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsRoot { get; }
ReadOnly Property IsRoot As Boolean
    Get

Property Value

Type: Boolean
true if the data model is the root; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.IsSelected Property

IDataModelIsSelected Property
Gets or sets whether the data model is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsSelected { get; set; }
Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is selected; otherwise, false.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.Name Property

IDataModelName Property
Gets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
The name of the data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.Parent Property

IDataModelParent Property
Gets or sets the parent data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IDataModel Parent { get; set; }
Property Parent As IDataModel
    Get
    Set

Property Value

Type: IDataModel
The parent data model.
Remarks
Do not set this property directly, as it will be set when a data model is added as a child of another data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.SortComparer Property

IDataModelSortComparer Property
Gets or sets the DataModelSortComparer to use for sorting this data model's children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataModelSortComparer SortComparer { get; set; }
Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting this data model's children.
Remarks
If this property doesn't return anything, the default SortComparer will be used.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.SortImportance Property

IDataModelSortImportance Property
Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataModelSortImportance SortImportance { get; }
ReadOnly Property SortImportance As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.SortOrder Property

IDataModelSortOrder Property
Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int SortOrder { get; }
ReadOnly Property SortOrder As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel.Tag Property

IDataModelTag Property
Gets or sets custom data for the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the data model.
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IDataModel Methods

IDataModel Methods

The IDataModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

IDataModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel Interface

IPropertyModel Interface
Provides the requirements for a property grid property IDataModel.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPropertyModel : IDataModel,
    IDisposable
Public Interface IPropertyModel
    Inherits IDataModel, IDisposable

The IPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Public property | Category | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | (Inherited from IDisposable.)
Public method | Refresh | Refreshes the property based on the specified reason.
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel Properties

IPropertyModel Properties

The IPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets whether the property can be reset to its default value.
Public property | Category | Gets a category for the property.
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property.
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | StandardValues | Gets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets the Type of the Value property.
Top
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.AddChildCommand Property

IPropertyModelAddChildCommand Property
Gets the ICommand used to add a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICommand AddChildCommand { get; }
ReadOnly Property AddChildCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to add a new child into to an associated collection/parent.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.CanAddChild Property

IPropertyModelCanAddChild Property
Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanAddChild { get; }
ReadOnly Property CanAddChild As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.CanRemove Property

IPropertyModelCanRemove Property
Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanRemove { get; }
ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.CanResetValue Property

IPropertyModelCanResetValue Property
Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanResetValue { get; }
ReadOnly Property CanResetValue As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Category Property

IPropertyModelCategory Property
Gets a category for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Category { get; }
ReadOnly Property Category As String
    Get

Property Value

Type: String
A category for the property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Converter Property

IPropertyModelConverter Property
Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TypeConverter Converter { get; }
ReadOnly Property Converter As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.HasStandardValues Property

IPropertyModelHasStandardValues Property
Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasStandardValues { get; }
ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.IsHostReadOnly Property

IPropertyModelIsHostReadOnly Property
Gets or sets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsHostReadOnly { get; set; }
Property IsHostReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.IsImmutable Property

IPropertyModelIsImmutable Property
Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsImmutable { get; }
ReadOnly Property IsImmutable As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.IsLimitedToStandardValues Property

IPropertyModelIsLimitedToStandardValues Property
Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLimitedToStandardValues { get; }
ReadOnly Property IsLimitedToStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.IsMergeable Property

IPropertyModelIsMergeable Property
Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsMergeable { get; }
ReadOnly Property IsMergeable As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.IsReadOnly Property

IPropertyModelIsReadOnly Property
Gets whether UI for editing the property value is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the UI for editing the property value is read-only; otherwise, false.
Remarks
This property is a resolved value of IsHostReadOnly and IsValueReadOnly.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.IsValueReadOnly Property

IPropertyModelIsValueReadOnly Property
Gets or sets whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsValueReadOnly { get; set; }
Property IsValueReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property can be set to true to force a normally-editable property to be read-only. Some implementations of this property will always return true when the underlying property value is unable to be set.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.NamePropertyEditor Property

IPropertyModelNamePropertyEditor Property
Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PropertyEditor NamePropertyEditor { get; set; }
Property NamePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.NameTemplate Property

IPropertyModelNameTemplate Property
Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataTemplate NameTemplate { get; }
ReadOnly Property NameTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.NameTemplateKey Property

IPropertyModelNameTemplateKey Property
Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object NameTemplateKey { get; }
ReadOnly Property NameTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.NameTemplateSelector Property

IPropertyModelNameTemplateSelector Property
Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataTemplateSelector NameTemplateSelector { get; }
ReadOnly Property NameTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.RemoveCommand Property

IPropertyModelRemoveCommand Property
Gets the ICommand used to remove the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICommand RemoveCommand { get; }
ReadOnly Property RemoveCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to remove the property from an associated collection/parent.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ResetValueCommand Property

IPropertyModelResetValueCommand Property
Gets the ICommand used to reset the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICommand ResetValueCommand { get; }
ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to reset the property value to its default value.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ShouldNotifyParentOnValueChange Property

IPropertyModelShouldNotifyParentOnValueChange Property
Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ShouldNotifyParentOnValueChange { get; }
ReadOnly Property ShouldNotifyParentOnValueChange As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.StandardValues Property

IPropertyModelStandardValues Property
Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable StandardValues { get; }
ReadOnly Property StandardValues As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.StandardValuesAsStrings Property

IPropertyModelStandardValuesAsStrings Property
Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<string> StandardValuesAsStrings { get; }
ReadOnly Property StandardValuesAsStrings As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Target Property

IPropertyModelTarget Property
Gets the target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Target { get; }
ReadOnly Property Target As Object
    Get

Property Value

Type: Object
The target object that owns the property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.TargetType Property

IPropertyModelTargetType Property
Gets the Type of the Target property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Type TargetType { get; }
ReadOnly Property TargetType As Type
    Get

Property Value

Type: Type
The Type of the Target property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Value Property

IPropertyModelValue Property
Gets or sets the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set

Property Value

Type: Object
The property value.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueAsString Property

IPropertyModelValueAsString Property
Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ValueAsString { get; set; }
Property ValueAsString As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValuePropertyEditor Property

IPropertyModelValuePropertyEditor Property
Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PropertyEditor ValuePropertyEditor { get; set; }
Property ValuePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Values Property

IPropertyModelValues Property
Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<Object> Values { get; }
ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplate Property

IPropertyModelValueTemplate Property
Gets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataTemplate ValueTemplate { get; }
ReadOnly Property ValueTemplate As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplateKey Property

IPropertyModelValueTemplateKey Property
Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object ValueTemplateKey { get; }
ReadOnly Property ValueTemplateKey As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplateKind Property

IPropertyModelValueTemplateKind Property
Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DefaultValueTemplateKind ValueTemplateKind { get; }
ReadOnly Property ValueTemplateKind As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueTemplateSelector Property

IPropertyModelValueTemplateSelector Property
Gets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataTemplateSelector ValueTemplateSelector { get; }
ReadOnly Property ValueTemplateSelector As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ValueType Property

IPropertyModelValueType Property
Gets the Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Type ValueType { get; }
ReadOnly Property ValueType As Type
    Get

Property Value

Type: Type
The Type of the Value property.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel Methods

IPropertyModel Methods

The IPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | (Inherited from IDisposable.)
Public method | Refresh | Refreshes the property based on the specified reason.
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Top
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.AddChild Method

IPropertyModelAddChild Method
Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void AddChild()
Sub AddChild
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.CycleToNextStandardValue Method

IPropertyModelCycleToNextStandardValue Method
Cycles the property value to the next standard value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CycleToNextStandardValue()
Function CycleToNextStandardValue As Boolean

Return Value

Type: Boolean
true if a standard value was set; otherwise, false.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Refresh Method

IPropertyModelRefresh Method
Refreshes the property based on the specified reason.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Refresh(
    PropertyRefreshReason reason
)
Sub Refresh (
    reason As PropertyRefreshReason
)

Parameters

reason
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyRefreshReason
The reason the property needs to be refreshed.
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.Remove Method

IPropertyModelRemove Method
Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Remove()
Sub Remove
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IPropertyModel.ResetValue Method

IPropertyModelResetValue Method
Resets the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ResetValue()
Sub ResetValue
See Also

Reference

IPropertyModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IRootModel Interface

IRootModel Interface
Provides the requirements for a data model class that is the root model in the hierarchy.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IRootModel : IPropertyModel,
    IDataModel, IDisposable
Public Interface IRootModel
    Inherits IPropertyModel, IDataModel, IDisposable

The IRootModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from IPropertyModel.)
Public property | Category | Gets a category for the property. (Inherited from IPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from IPropertyModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from IPropertyModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from IPropertyModel.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from IPropertyModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from IPropertyModel.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from IPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from IPropertyModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from IPropertyModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from IPropertyModel.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from IPropertyModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Source | Gets the object or control that owns the data model hierarchy.
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from IPropertyModel.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from IPropertyModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property. (Inherited from IPropertyModel.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from IPropertyModel.)
Public property | Value | Gets or sets the property value. (Inherited from IPropertyModel.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from IPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from IPropertyModel.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from IPropertyModel.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from IPropertyModel.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from IPropertyModel.)
Public method | Dispose | (Inherited from IDisposable.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from IPropertyModel.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from IPropertyModel.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IRootModel Properties

IRootModel Properties

The IRootModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from IDataModel.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from IPropertyModel.)
Public property | Category | Gets a category for the property. (Inherited from IPropertyModel.)
Public property | Children | Gets the collection of child data models. (Inherited from IDataModel.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from IPropertyModel.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from IDataModel.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from IDataModel.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from IPropertyModel.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from IDataModel.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from IPropertyModel.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from IPropertyModel.)
Public property | IsInitialized | Gets or sets whether the data model has been initialized. (Inherited from IDataModel.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from IPropertyModel.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from IPropertyModel.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from IDataModel.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from IPropertyModel.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from IDataModel.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from IDataModel.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from IPropertyModel.)
Public property | Name | Gets the name of the data model. (Inherited from IDataModel.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from IPropertyModel.)
Public property | Parent | Gets or sets the parent data model. (Inherited from IDataModel.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from IPropertyModel.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from IPropertyModel.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from IDataModel.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from IDataModel.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from IDataModel.)
Public property | Source | Gets the object or control that owns the data model hierarchy.
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from IPropertyModel.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from IPropertyModel.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from IDataModel.)
Public property | Target | Gets the target object that owns the property. (Inherited from IPropertyModel.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from IPropertyModel.)
Public property | Value | Gets or sets the property value. (Inherited from IPropertyModel.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from IPropertyModel.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from IPropertyModel.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from IPropertyModel.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from IPropertyModel.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from IPropertyModel.)
Top
See Also

Reference

IRootModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IRootModel.Source Property

IRootModelSource Property
Gets the object or control that owns the data model hierarchy.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Source { get; }
ReadOnly Property Source As Object
    Get

Property Value

Type: Object
The object or control that owns the data model hierarchy.
See Also

Reference

IRootModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


IRootModel Methods

IRootModel Methods

The IRootModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from IPropertyModel.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from IPropertyModel.)
Public method | Dispose | (Inherited from IDisposable.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from IPropertyModel.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from IPropertyModel.)
Public method | ResetValue | Resets the property value to its default value. (Inherited from IPropertyModel.)
Top
See Also

Reference

IRootModel Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel Class

MergedPropertyModel Class
Represents a property grid property IDataModel that merges a property from multiple data objects.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataMergedPropertyModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MergedPropertyModel : CachedPropertyModelBase
Public Class MergedPropertyModel
    Inherits CachedPropertyModelBase

The MergedPropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | MergedPropertyModel | Initializes an instance of the MergedPropertyModel class.
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides CachedPropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Overrides CachedPropertyModelBaseIsLimitedToStandardValuesCore.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateCore.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateKeyCore.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateSelectorCore.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Overrides CachedPropertyModelBaseSortImportanceCore.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Overrides CachedPropertyModelBaseStandardValuesAsStrings.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Overrides CachedPropertyModelBaseStandardValuesCore.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Overrides CachedPropertyModelBaseTargetType.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Overrides CachedPropertyModelBaseValuesCore.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateCore.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKeyCore.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKindCore.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateSelectorCore.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Overrides PropertyModelBaseGetErrorMessages(String).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel Constructor

MergedPropertyModel Constructor
Initializes an instance of the MergedPropertyModel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MergedPropertyModel(
    IList<IPropertyModel> propertyModels
)
Public Sub New (
    propertyModels As IList(Of IPropertyModel)
)

Parameters

propertyModels
Type: System.Collections.GenericIList IPropertyModel
The collection of IPropertyModel objects to merge.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel Properties

MergedPropertyModel Properties

The MergedPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Overrides CachedPropertyModelBaseHasStandardValues.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Overrides CachedPropertyModelBaseIsLimitedToStandardValuesCore.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateCore.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateKeyCore.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Overrides CachedPropertyModelBaseNameTemplateSelectorCore.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Overrides CachedPropertyModelBaseSortImportanceCore.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Overrides CachedPropertyModelBaseStandardValuesAsStrings.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Overrides CachedPropertyModelBaseStandardValuesCore.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Overrides CachedPropertyModelBaseTargetType.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Overrides CachedPropertyModelBaseValuesCore.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateCore.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKeyCore.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateKindCore.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Overrides CachedPropertyModelBaseValueTemplateSelectorCore.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.CanResetValueCore Property

MergedPropertyModelCanResetValueCore Property
Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool CanResetValueCore { get; }
Protected Overrides ReadOnly Property CanResetValueCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.CategoryCore Property

MergedPropertyModelCategoryCore Property
Gets a category for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string CategoryCore { get; }
Protected Overrides ReadOnly Property CategoryCore As String
    Get

Property Value

Type: String
A category for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ConverterCore Property

MergedPropertyModelConverterCore Property
Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override TypeConverter ConverterCore { get; }
Protected Overrides ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.DescriptionCore Property

MergedPropertyModelDescriptionCore Property
Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string DescriptionCore { get; }
Protected Overrides ReadOnly Property DescriptionCore As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.DisplayNameCore Property

MergedPropertyModelDisplayNameCore Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string DisplayNameCore { get; }
Protected Overrides ReadOnly Property DisplayNameCore As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.HasStandardValues Property

MergedPropertyModelHasStandardValues Property
Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool HasStandardValues { get; }
Public Overrides ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.

Implements

IPropertyModelHasStandardValues
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsImmutableCore Property

MergedPropertyModelIsImmutableCore Property
Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsImmutableCore { get; }
Protected Overrides ReadOnly Property IsImmutableCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsLimitedToStandardValuesCore Property

MergedPropertyModelIsLimitedToStandardValuesCore Property
Gets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsLimitedToStandardValuesCore { get; }
Protected Overrides ReadOnly Property IsLimitedToStandardValuesCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsMergeableCore Property

MergedPropertyModelIsMergeableCore Property
Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsMergeableCore { get; }
Protected Overrides ReadOnly Property IsMergeableCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsModifiedCore Property

MergedPropertyModelIsModifiedCore Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsModifiedCore { get; }
Protected Overrides ReadOnly Property IsModifiedCore As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.IsValueReadOnlyCore Property

MergedPropertyModelIsValueReadOnlyCore Property
Gets whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValueReadOnlyCore { get; }
Protected Overrides ReadOnly Property IsValueReadOnlyCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameCore Property

MergedPropertyModelNameCore Property
Gets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string NameCore { get; }
Protected Overrides ReadOnly Property NameCore As String
    Get

Property Value

Type: String
The name of the data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameTemplateCore Property

MergedPropertyModelNameTemplateCore Property
Gets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate NameTemplateCore { get; }
Protected Overrides ReadOnly Property NameTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameTemplateKeyCore Property

MergedPropertyModelNameTemplateKeyCore Property
Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object NameTemplateKeyCore { get; }
Protected Overrides ReadOnly Property NameTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.NameTemplateSelectorCore Property

MergedPropertyModelNameTemplateSelectorCore Property
Gets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplateSelector NameTemplateSelectorCore { get; }
Protected Overrides ReadOnly Property NameTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ShouldNotifyParentOnValueChangeCore Property

MergedPropertyModelShouldNotifyParentOnValueChangeCore Property
Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool ShouldNotifyParentOnValueChangeCore { get; }
Protected Overrides ReadOnly Property ShouldNotifyParentOnValueChangeCore As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.SortImportanceCore Property

MergedPropertyModelSortImportanceCore Property
Gets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataModelSortImportance SortImportanceCore { get; }
Protected Overrides ReadOnly Property SortImportanceCore As DataModelSortImportance
    Get

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.SortOrderCore Property

MergedPropertyModelSortOrderCore Property
Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override int SortOrderCore { get; }
Protected Overrides ReadOnly Property SortOrderCore As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.StandardValuesAsStrings Property

MergedPropertyModelStandardValuesAsStrings Property
Gets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override IEnumerable<string> StandardValuesAsStrings { get; }
Public Overrides ReadOnly Property StandardValuesAsStrings As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.

Implements

IPropertyModelStandardValuesAsStrings
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.StandardValuesCore Property

MergedPropertyModelStandardValuesCore Property
Gets the standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable StandardValuesCore { get; }
Protected Overrides ReadOnly Property StandardValuesCore As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.TargetCore Property

MergedPropertyModelTargetCore Property
Gets the target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object TargetCore { get; }
Protected Overrides ReadOnly Property TargetCore As Object
    Get

Property Value

Type: Object
The target object that owns the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.TargetType Property

MergedPropertyModelTargetType Property
Gets the Type of the Target property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Type TargetType { get; }
Public Overrides ReadOnly Property TargetType As Type
    Get

Property Value

Type: Type
The Type of the Target property.

Implements

IPropertyModelTargetType
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueCore Property

MergedPropertyModelValueCore Property
Gets or sets the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object ValueCore { get; set; }
Protected Overrides Property ValueCore As Object
    Get
    Set

Property Value

Type: Object
The property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValuesCore Property

MergedPropertyModelValuesCore Property
Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<Object> ValuesCore { get; }
Protected Overrides ReadOnly Property ValuesCore As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateCore Property

MergedPropertyModelValueTemplateCore Property
Gets the DataTemplate to use for use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplate ValueTemplateCore { get; }
Protected Overrides ReadOnly Property ValueTemplateCore As DataTemplate
    Get

Property Value

Type: DataTemplate
The DataTemplate to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateKeyCore Property

MergedPropertyModelValueTemplateKeyCore Property
Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object ValueTemplateKeyCore { get; }
Protected Overrides ReadOnly Property ValueTemplateKeyCore As Object
    Get

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateKindCore Property

MergedPropertyModelValueTemplateKindCore Property
Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DefaultValueTemplateKind ValueTemplateKindCore { get; }
Protected Overrides ReadOnly Property ValueTemplateKindCore As DefaultValueTemplateKind
    Get

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTemplateSelectorCore Property

MergedPropertyModelValueTemplateSelectorCore Property
Gets the DataTemplateSelector to use for use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override DataTemplateSelector ValueTemplateSelectorCore { get; }
Protected Overrides ReadOnly Property ValueTemplateSelectorCore As DataTemplateSelector
    Get

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for use for editing the property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ValueTypeCore Property

MergedPropertyModelValueTypeCore Property
Gets the Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Type ValueTypeCore { get; }
Protected Overrides ReadOnly Property ValueTypeCore As Type
    Get

Property Value

Type: Type
The Type of the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel Methods

MergedPropertyModel Methods

The MergedPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Overrides PropertyModelBaseGetErrorMessages(String).)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.Dispose Method

MergedPropertyModelDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.Dispose Method (Boolean)

MergedPropertyModelDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

MergedPropertyModel Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.GetErrorMessages Method

MergedPropertyModelGetErrorMessages Method
Returns the error messages for the target object or one of its properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IEnumerable GetErrorMessages(
    string columnName
)
Protected Overrides Function GetErrorMessages (
    columnName As String
) As IEnumerable

Parameters

columnName
Type: SystemString
The name of the property to examine, or if the target object itself should be examined.

Return Value

Type: IEnumerable
The error messages that are applicable, if any.
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel.ResetValue Method

MergedPropertyModelResetValue Method
Resets the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void ResetValue()
Public Overrides Sub ResetValue
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


MergedPropertyModel Events

MergedPropertyModel Events

The MergedPropertyModel type exposes the following members.

Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MergedPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Class

PropertyDescriptorPropertyModel Class
Represents a property grid property IDataModel that is based on PropertyDescriptor data.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCachedPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyDescriptorPropertyModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCollectionPropertyDescriptorPropertyModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyDescriptorPropertyModel : CachedPropertyModelBase,
    IServiceProvider
Public Class PropertyDescriptorPropertyModel
    Inherits CachedPropertyModelBase
    Implements IServiceProvider

The PropertyDescriptorPropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDescriptorPropertyModel | Initializes an instance of the PropertyDescriptorPropertyModel class.
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Overrides CachedPropertyModelBaseCanRemoveCore.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Overrides PropertyModelBaseRemove.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Constructor

PropertyDescriptorPropertyModel Constructor
Initializes an instance of the PropertyDescriptorPropertyModel class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyDescriptorPropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor
)
Public Sub New (
    target As Object,
    propertyDescriptor As PropertyDescriptor
)

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: PropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Properties

PropertyDescriptorPropertyModel Properties

The PropertyDescriptorPropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildCore | Gets whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Protected property | CanRemoveCore | Gets whether the property can be removed from an associated collection/parent. (Overrides CachedPropertyModelBaseCanRemoveCore.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent. (Inherited from CachedPropertyModelBase.)
Public property | CanResetValue | Gets whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Protected property | CanResetValueCore | Gets whether the property can be reset to its default value. (Overrides CachedPropertyModelBaseCanResetValueCore.)
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value. (Inherited from CachedPropertyModelBase.)
Public property | Category | Gets a category for the property. (Inherited from CachedPropertyModelBase.)
Protected property | CategoryCore | Gets a category for the property. (Overrides CachedPropertyModelBaseCategoryCore.)
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Public property | Converter | Gets the TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Protected property | ConverterCore | Gets the TypeConverter to use for the property. (Overrides CachedPropertyModelBaseConverterCore.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property. (Inherited from CachedPropertyModelBase.)
Public property | Description | Gets the description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Protected property | DescriptionCore | Gets the description of the data model, often displayed in a summary area or a tooltip. (Overrides CachedPropertyModelBaseDescriptionCore.)
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from CachedPropertyModelBase.)
Public property | DisplayName | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Protected property | DisplayNameCore | Gets the name to use when displaying the data model, often the same as Name. (Overrides CachedPropertyModelBaseDisplayNameCore.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from CachedPropertyModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Protected property | HasStandardValuesCore | Gets whether the property supports StandardValues. (Inherited from CachedPropertyModelBase.)
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only. (Inherited from PropertyModelBase.)
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Protected property | IsImmutableCore | Gets whether the Value's child properties, if any, are capable of being edited. (Overrides CachedPropertyModelBaseIsImmutableCore.)
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited. (Inherited from CachedPropertyModelBase.)
Public property | IsLimitedToStandardValues | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Protected property | IsLimitedToStandardValuesCore | Gets whether the Value property can only be set to one of the values defined by the StandardValues property. (Inherited from CachedPropertyModelBase.)
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects. (Inherited from CachedPropertyModelBase.)
Protected property | IsMergeableCore | Gets whether the property can be merged when presenting multiple objects. (Overrides CachedPropertyModelBaseIsMergeableCore.)
Public property | IsModified | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Protected property | IsModifiedCore | Gets whether the data model has been modified. (Overrides CachedPropertyModelBaseIsModifiedCore.)
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from CachedPropertyModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only. (Inherited from PropertyModelBase.)
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Protected property | IsValueReadOnlyCore | Gets whether the Value property is read-only. (Overrides CachedPropertyModelBaseIsValueReadOnlyCore.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only. (Inherited from CachedPropertyModelBase.)
Public property | Name | Gets the name of the data model. (Inherited from CachedPropertyModelBase.)
Protected property | NameCore | Gets the name of the data model. (Overrides CachedPropertyModelBaseNameCore.)
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name. (Inherited from PropertyModelBase.)
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplate | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateCore | Gets the DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateKeyCore | Gets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | NameTemplateSelector | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Protected property | NameTemplateSelectorCore | Gets the DataTemplateSelector to use for showing the property display name. (Inherited from CachedPropertyModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent. (Inherited from PropertyModelBase.)
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value. (Inherited from PropertyModelBase.)
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Protected property | ShouldNotifyParentOnValueChangeCore | Gets whether the property should notify its parent property when the Value changes. (Overrides CachedPropertyModelBaseShouldNotifyParentOnValueChangeCore.)
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes. (Inherited from CachedPropertyModelBase.)
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Public property | SortImportance | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceCore | Gets a DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from CachedPropertyModelBase.)
Public property | SortOrder | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Protected property | SortOrderCore | Gets a numeric sort order for sorting the data model within other data models of the same sort importance. (Overrides CachedPropertyModelBaseSortOrderCore.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from CachedPropertyModelBase.)
Public property | StandardValues | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | StandardValuesAsStrings | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesAsStringsCore | Gets the standard list of values for the ValueAsString property as a list of strings. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesCore | Gets the standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property. (Inherited from CachedPropertyModelBase.)
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Public property | Target | Gets the target object that owns the property. (Inherited from CachedPropertyModelBase.)
Protected property | TargetCore | Gets the target object that owns the property. (Overrides CachedPropertyModelBaseTargetCore.)
Protected property | TargetResolved | Gets the resolved target object that owns the property. (Inherited from CachedPropertyModelBase.)
Public property | TargetType | Gets the Type of the Target property. (Inherited from CachedPropertyModelBase.)
Public property | Value | Gets or sets the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueAsString | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueAsStringCore | Gets or sets the property value in a string representation. (Inherited from CachedPropertyModelBase.)
Protected property | ValueCore | Gets or sets the property value. (Overrides CachedPropertyModelBaseValueCore.)
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value. (Inherited from PropertyModelBase.)
Protected property | ValueResolved | Gets or sets the resolved property value. (Inherited from CachedPropertyModelBase.)
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Protected property | ValuesCore | Gets the property values, of which there will only be more than one if this is a merged property. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplate | Gets the DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateCore | Gets the DataTemplate to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKeyCore | Gets the resource key that references a DataTemplate to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateKind | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateKindCore | Gets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueTemplateSelector | Gets the DataTemplateSelector to use for editing the property value. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTemplateSelectorCore | Gets the DataTemplateSelector to use for use for editing the property value. (Inherited from CachedPropertyModelBase.)
Public property | ValueType | Gets the Type of the Value property. (Inherited from CachedPropertyModelBase.)
Protected property | ValueTypeCore | Gets the Type of the Value property. (Overrides CachedPropertyModelBaseValueTypeCore.)
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property. (Inherited from CachedPropertyModelBase.)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.CanRemoveCore Property

PropertyDescriptorPropertyModelCanRemoveCore Property
Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool CanRemoveCore { get; }
Protected Overrides ReadOnly Property CanRemoveCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.CanResetValueCore Property

PropertyDescriptorPropertyModelCanResetValueCore Property
Gets whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool CanResetValueCore { get; }
Protected Overrides ReadOnly Property CanResetValueCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.CategoryCore Property

PropertyDescriptorPropertyModelCategoryCore Property
Gets a category for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string CategoryCore { get; }
Protected Overrides ReadOnly Property CategoryCore As String
    Get

Property Value

Type: String
A category for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ConverterCore Property

PropertyDescriptorPropertyModelConverterCore Property
Gets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override TypeConverter ConverterCore { get; }
Protected Overrides ReadOnly Property ConverterCore As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.DescriptionCore Property

PropertyDescriptorPropertyModelDescriptionCore Property
Gets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string DescriptionCore { get; }
Protected Overrides ReadOnly Property DescriptionCore As String
    Get

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.DisplayNameCore Property

PropertyDescriptorPropertyModelDisplayNameCore Property
Gets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string DisplayNameCore { get; }
Protected Overrides ReadOnly Property DisplayNameCore As String
    Get

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsImmutableCore Property

PropertyDescriptorPropertyModelIsImmutableCore Property
Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsImmutableCore { get; }
Protected Overrides ReadOnly Property IsImmutableCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsMergeableCore Property

PropertyDescriptorPropertyModelIsMergeableCore Property
Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsMergeableCore { get; }
Protected Overrides ReadOnly Property IsMergeableCore As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsModifiedCore Property

PropertyDescriptorPropertyModelIsModifiedCore Property
Gets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsModifiedCore { get; }
Protected Overrides ReadOnly Property IsModifiedCore As Boolean
    Get

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.IsValueReadOnlyCore Property

PropertyDescriptorPropertyModelIsValueReadOnlyCore Property
Gets whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool IsValueReadOnlyCore { get; }
Protected Overrides ReadOnly Property IsValueReadOnlyCore As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.NameCore Property

PropertyDescriptorPropertyModelNameCore Property
Gets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string NameCore { get; }
Protected Overrides ReadOnly Property NameCore As String
    Get

Property Value

Type: String
The name of the data model.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ShouldNotifyParentOnValueChangeCore Property

PropertyDescriptorPropertyModelShouldNotifyParentOnValueChangeCore Property
Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool ShouldNotifyParentOnValueChangeCore { get; }
Protected Overrides ReadOnly Property ShouldNotifyParentOnValueChangeCore As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.SortOrderCore Property

PropertyDescriptorPropertyModelSortOrderCore Property
Gets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override int SortOrderCore { get; }
Protected Overrides ReadOnly Property SortOrderCore As Integer
    Get

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.TargetCore Property

PropertyDescriptorPropertyModelTargetCore Property
Gets the target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object TargetCore { get; }
Protected Overrides ReadOnly Property TargetCore As Object
    Get

Property Value

Type: Object
The target object that owns the property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ValueCore Property

PropertyDescriptorPropertyModelValueCore Property
Gets or sets the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Object ValueCore { get; set; }
Protected Overrides Property ValueCore As Object
    Get
    Set

Property Value

Type: Object
The property value.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ValueTypeCore Property

PropertyDescriptorPropertyModelValueTypeCore Property
Gets the Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Type ValueTypeCore { get; }
Protected Overrides ReadOnly Property ValueTypeCore As Type
    Get

Property Value

Type: Type
The Type of the Value property.
Remarks
This property does the actual work of retrieving the value for the cached version of this property.
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Methods

PropertyDescriptorPropertyModel Methods

The PropertyDescriptorPropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent. (Inherited from PropertyModelBase.)
Protected method | ConvertFromString | Converts the specified value from a string. (Inherited from PropertyModelBase.)
Protected method | ConvertToString | Converts the specified value to a string. (Inherited from PropertyModelBase.)
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value. (Inherited from PropertyModelBase.)
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties. (Inherited from PropertyModelBase.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from CachedPropertyModelBase.)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid. (Inherited from PropertyModelBase.)
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid. (Inherited from PropertyModelBase.)
Public method | Refresh | Refreshes the property based on the specified reason. (Inherited from PropertyModelBase.)
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent. (Overrides PropertyModelBaseRemove.)
Public method | ResetValue | Resets the property value to its default value. (Overrides PropertyModelBaseResetValue.)
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.Dispose Method

PropertyDescriptorPropertyModelDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Overrides DataModelBaseDispose(Boolean).)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.Dispose Method (Boolean)

PropertyDescriptorPropertyModelDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

PropertyDescriptorPropertyModel Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.Remove Method

PropertyDescriptorPropertyModelRemove Method
Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Remove()
Public Overrides Sub Remove
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel.ResetValue Method

PropertyDescriptorPropertyModelResetValue Method
Resets the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void ResetValue()
Public Overrides Sub ResetValue
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyDescriptorPropertyModel Events

PropertyDescriptorPropertyModel Events

The PropertyDescriptorPropertyModel type exposes the following members.

Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity. (Inherited from PropertyModelBase.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyDescriptorPropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability Class

PropertyExpandability Class
Specifies the expandability of properties in the property grid.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyExpandability

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PropertyExpandability : Enum
Public NotInheritable Class PropertyExpandability
    Inherits Enum

The PropertyExpandability type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Indicates that properties will be expandable if the associated type converter allows sub-properties to be retrieved.
 | ForceAlways | Indicates that properties will be forced to be expandable even if a custom type converter has been specified. If a custom type converter has been specified, then it will only be overridden if it does not allow the property to be expandable.
 | ForceSimple | Indicates that properties will be forced to be expandable if a custom type converter has not been specified.
 | None | Indicates that properties will never be expandable.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability Methods

PropertyExpandability Methods

The PropertyExpandability type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability Fields

PropertyExpandability Fields

The PropertyExpandability type exposes the following members.

Fields
 | Name | Description
 | Default | Indicates that properties will be expandable if the associated type converter allows sub-properties to be retrieved.
 | ForceAlways | Indicates that properties will be forced to be expandable even if a custom type converter has been specified. If a custom type converter has been specified, then it will only be overridden if it does not allow the property to be expandable.
 | ForceSimple | Indicates that properties will be forced to be expandable if a custom type converter has not been specified.
 | None | Indicates that properties will never be expandable.
Public field | value__ |
Top
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability.Default Field

PropertyExpandabilityDefault Field
Indicates that properties will be expandable if the associated type converter allows sub-properties to be retrieved.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyExpandability Default = 0
Public Const Default As PropertyExpandability = 0

Field Value

Type: PropertyExpandability
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability.ForceAlways Field

PropertyExpandabilityForceAlways Field
Indicates that properties will be forced to be expandable even if a custom type converter has been specified. If a custom type converter has been specified, then it will only be overridden if it does not allow the property to be expandable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyExpandability ForceAlways = 3
Public Const ForceAlways As PropertyExpandability = 3

Field Value

Type: PropertyExpandability
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability.ForceSimple Field

PropertyExpandabilityForceSimple Field
Indicates that properties will be forced to be expandable if a custom type converter has not been specified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyExpandability ForceSimple = 2
Public Const ForceSimple As PropertyExpandability = 2

Field Value

Type: PropertyExpandability
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability.None Field

PropertyExpandabilityNone Field
Indicates that properties will never be expandable.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyExpandability None = 1
Public Const None As PropertyExpandability = 1

Field Value

Type: PropertyExpandability
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyExpandability.value__ Field

PropertyExpandabilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData.PropertyExpandability.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PropertyExpandability Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel Class

PropertyModel Class
Represents a property grid property IDataModel that can be easily explicitly-defined and optionally bound to in XAML.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModel

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyModel : DependencyObject,
    INotifyPropertyChanged, IPropertyModel, IDataModel, IDisposable, INotifyDataErrorInfo
Public Class PropertyModel
    Inherits DependencyObject
    Implements INotifyPropertyChanged, IPropertyModel, IDataModel, IDisposable,
    INotifyDataErrorInfo

The PropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModel | Initializes a new instance of the PropertyModel class
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets or sets whether the property can be reset to its default value.
Public property | Category | Gets or sets a category for the property.
Public property | Children | Gets the collection of child data models.
Public property | Converter | Gets or sets the TypeConverter to use for the property.
Public property | DefaultValue | Gets or sets the default value to use for a reset operation.
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsLimitedToStandardValues | Gets or sets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets or sets whether the data model has been modified.
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Protected property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets or sets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model.
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets or sets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | StandardValues | Gets or sets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets or sets the standard list of values for the ValueAsString property as a list of strings.
Public property | Tag | Gets or sets custom data for the data model.
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets or sets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets or sets the Type of the Value property.
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity.
Public event | PropertyChanged | Occurs when a property has been changed.
Top
Fields
Name | Description
CanResetValueProperty | Identifies the CanResetValue dependency property. This field is read-only.
CategoryProperty | Identifies the Category dependency property. This field is read-only.
ConverterProperty | Identifies the Converter dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
DisplayNameProperty | Identifies the DisplayName dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsHostReadOnlyProperty | Identifies the IsHostReadOnly dependency property. This field is read-only.
IsImmutableProperty | Identifies the IsImmutable dependency property. This field is read-only.
IsLimitedToStandardValuesProperty | Identifies the IsLimitedToStandardValues dependency property. This field is read-only.
IsModifiedProperty | Identifies the IsModified dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
IsValueReadOnlyProperty | Identifies the IsValueReadOnly dependency property. This field is read-only.
NameProperty | Identifies the Name dependency property. This field is read-only.
NamePropertyEditorProperty | Identifies the NamePropertyEditor dependency property. This field is read-only.
NameTemplateKeyProperty | Identifies the NameTemplateKey dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SortImportanceProperty | Identifies the SortImportance dependency property. This field is read-only.
SortOrderProperty | Identifies the SortOrder dependency property. This field is read-only.
StandardValuesAsStringsProperty | Identifies the StandardValuesAsStrings dependency property. This field is read-only.
StandardValuesProperty | Identifies the StandardValues dependency property. This field is read-only.
TagProperty | Identifies the Tag dependency property. This field is read-only.
TargetTypeProperty | Identifies the TargetType dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
ValuePropertyEditorProperty | Identifies the ValuePropertyEditor dependency property. This field is read-only.
ValueTemplateKeyProperty | Identifies the ValueTemplateKey dependency property. This field is read-only.
ValueTemplateKindProperty | Identifies the ValueTemplateKind dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
ValueTypeProperty | Identifies the ValueType dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel Constructor

PropertyModel Constructor
Initializes a new instance of the PropertyModel class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModel()
Public Sub New
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel Properties

PropertyModel Properties

The PropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Public property | CanAddChild | Gets whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model.
Public property | CanRemove | Gets whether the property can be removed from an associated collection/parent.
Public property | CanResetValue | Gets or sets whether the property can be reset to its default value.
Public property | Category | Gets or sets a category for the property.
Public property | Children | Gets the collection of child data models.
Public property | Converter | Gets or sets the TypeConverter to use for the property.
Public property | DefaultValue | Gets or sets the default value to use for a reset operation.
Public property | Description | Gets or sets the description of the data model, often displayed in a summary area or a tooltip.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | DisplayName | Gets or sets the name to use when displaying the data model, often the same as Name.
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded.
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Public property | IsImmutable | Gets whether the Value's child properties, if any, are capable of being edited.
Public property | IsLimitedToStandardValues | Gets or sets whether the Value property can only be set to one of the values defined by the StandardValues property.
Public property | IsMergeable | Gets whether the property can be merged when presenting multiple objects.
Public property | IsModified | Gets or sets whether the data model has been modified.
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Protected property | IsRoot | Gets whether the data model is the root.
Public property | IsSelected | Gets or sets whether the data model is selected.
Public property | IsValueReadOnly | Gets or sets whether the Value property is read-only.
Public property | Name | Gets or sets the name of the data model.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | Parent | Gets the parent data model.
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Public property | ShouldNotifyParentOnValueChange | Gets whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children.
Public property | SortImportance | Gets or sets a DataModelSortImportance that indicates the sort importance of this data model.
Public property | SortOrder | Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.
Public property | StandardValues | Gets or sets the standard list of values for the Value property.
Public property | StandardValuesAsStrings | Gets or sets the standard list of values for the ValueAsString property as a list of strings.
Public property | Tag | Gets or sets custom data for the data model.
Public property | Target | Gets the target object that owns the property.
Public property | TargetType | Gets or sets the Type of the Target property.
Public property | Value | Gets or sets the property value.
Public property | ValueAsString | Gets or sets the property value in a string representation.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Public property | Values | Gets the property values, of which there will only be more than one if this is a merged property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Public property | ValueType | Gets or sets the Type of the Value property.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.AddChildCommand Property

PropertyModelAddChildCommand Property
Gets the ICommand used to add a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand AddChildCommand { get; }
Public ReadOnly Property AddChildCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to add a new child into to an associated collection/parent.

Implements

IPropertyModelAddChildCommand
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CanAddChild Property

PropertyModelCanAddChild Property
Gets whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanAddChild { get; }
Public Overridable ReadOnly Property CanAddChild As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanAddChild
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CanAutoDispose Property

PropertyModelCanAutoDispose Property
Gets whether the data model should be automatically disposed when it is removed from a parent data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanAutoDispose { get; }
Public ReadOnly Property CanAutoDispose As Boolean
    Get

Property Value

Type: Boolean
true if the data model should be automatically disposed when it is removed from a parent data model; otherwise, false.

Implements

IDataModelCanAutoDispose
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CanRemove Property

PropertyModelCanRemove Property
Gets whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CanRemove { get; }
Public Overridable ReadOnly Property CanRemove As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.

Implements

IPropertyModelCanRemove
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CanResetValue Property

PropertyModelCanResetValue Property
Gets or sets whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanResetValue { get; set; }
Public Property CanResetValue As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false. The default value is false.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Category Property

PropertyModelCategory Property
Gets or sets a category for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String
A category for the property.

Implements

IPropertyModelCategory
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Children Property

PropertyModelChildren Property
Gets the collection of child data models.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelCollection Children { get; }
Public ReadOnly Property Children As DataModelCollection
    Get

Property Value

Type: DataModelCollection
The collection of child data models.

Implements

IDataModelChildren
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Converter Property

PropertyModelConverter Property
Gets or sets the TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypeConverter Converter { get; set; }
Public Property Converter As TypeConverter
    Get
    Set

Property Value

Type: TypeConverter
The TypeConverter to use for the property.

Implements

IPropertyModelConverter
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.DefaultValue Property

PropertyModelDefaultValue Property
Gets or sets the default value to use for a reset operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object DefaultValue { get; set; }
Public Property DefaultValue As Object
    Get
    Set

Property Value

Type: Object
The default value to use for a reset operation.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Description Property

PropertyModelDescription Property
Gets or sets the description of the data model, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the data model, often displayed in a summary area or a tooltip.

Implements

IDataModelDescription
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.DisplayName Property

PropertyModelDisplayName Property
Gets or sets the name to use when displaying the data model, often the same as Name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the data model, often the same as Name.

Implements

IDataModelDisplayName
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.HasStandardValues Property

PropertyModelHasStandardValues Property
Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool HasStandardValues { get; }
Public Overridable ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.

Implements

IPropertyModelHasStandardValues
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsExpanded Property

PropertyModelIsExpanded Property
Gets or sets whether the data model is expanded.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsExpanded { get; set; }
Public Property IsExpanded As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is expanded; otherwise, false.

Implements

IDataModelIsExpanded
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsHostReadOnly Property

PropertyModelIsHostReadOnly Property
Gets or sets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHostReadOnly { get; set; }
Public Property IsHostReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.

Implements

IPropertyModelIsHostReadOnly
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsImmutable Property

PropertyModelIsImmutable Property
Gets whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsImmutable { get; set; }
Public Property IsImmutable As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.

Implements

IPropertyModelIsImmutable
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsLimitedToStandardValues Property

PropertyModelIsLimitedToStandardValues Property
Gets or sets whether the Value property can only be set to one of the values defined by the StandardValues property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLimitedToStandardValues { get; set; }
Public Property IsLimitedToStandardValues As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property can only be set to one of the values defined by the StandardValues property; otherwise, false.

Implements

IPropertyModelIsLimitedToStandardValues
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsMergeable Property

PropertyModelIsMergeable Property
Gets whether the property can be merged when presenting multiple objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool IsMergeable { get; }
Public Overridable ReadOnly Property IsMergeable As Boolean
    Get

Property Value

Type: Boolean
true if the property can be merged when presenting multiple objects; otherwise, false.

Implements

IPropertyModelIsMergeable
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsModified Property

PropertyModelIsModified Property
Gets or sets whether the data model has been modified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsModified { get; set; }
Public Property IsModified As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model has been modified; otherwise, false.

Implements

IDataModelIsModified
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsReadOnly Property

PropertyModelIsReadOnly Property
Gets whether UI for editing the property value is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the UI for editing the property value is read-only; otherwise, false.

Implements

IPropertyModelIsReadOnly
Remarks
This property is a resolved value of IsHostReadOnly and IsValueReadOnly, and also considers whether a parent property is immutable.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsRoot Property

PropertyModelIsRoot Property
Gets whether the data model is the root.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool IsRoot { get; }
Protected Overridable ReadOnly Property IsRoot As Boolean
    Get

Property Value

Type: Boolean
true if the data model is the root; otherwise, false.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsSelected Property

PropertyModelIsSelected Property
Gets or sets whether the data model is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data model is selected; otherwise, false.

Implements

IDataModelIsSelected
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsValueReadOnly Property

PropertyModelIsValueReadOnly Property
Gets or sets whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsValueReadOnly { get; set; }
Public Property IsValueReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.

Implements

IPropertyModelIsValueReadOnly
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Name Property

PropertyModelName Property
Gets or sets the name of the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The name of the data model.

Implements

IDataModelName
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NamePropertyEditor Property

PropertyModelNamePropertyEditor Property
Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor NamePropertyEditor { get; set; }
Public Property NamePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Implements

IPropertyModelNamePropertyEditor
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplate Property

PropertyModelNameTemplate Property
Gets or sets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate NameTemplate { get; set; }
Public Property NameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplate
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateKey Property

PropertyModelNameTemplateKey Property
Gets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object NameTemplateKey { get; set; }
Public Property NameTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.

Implements

IPropertyModelNameTemplateKey
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateSelector Property

PropertyModelNameTemplateSelector Property
Gets or sets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector NameTemplateSelector { get; set; }
Public Property NameTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.

Implements

IPropertyModelNameTemplateSelector
Remarks
The priority order of value template specification is NameTemplate, NameTemplateSelector, NameTemplateKey, and finally any name templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Parent Property

PropertyModelParent Property
Gets the parent data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataModel Parent { get; }
Public ReadOnly Property Parent As IDataModel
    Get

Property Value

Type: IDataModel
The parent data model.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RemoveCommand Property

PropertyModelRemoveCommand Property
Gets the ICommand used to remove the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RemoveCommand { get; }
Public ReadOnly Property RemoveCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to remove the property from an associated collection/parent.

Implements

IPropertyModelRemoveCommand
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ResetValueCommand Property

PropertyModelResetValueCommand Property
Gets the ICommand used to reset the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ResetValueCommand { get; }
Public ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to reset the property value to its default value.

Implements

IPropertyModelResetValueCommand
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ShouldNotifyParentOnValueChange Property

PropertyModelShouldNotifyParentOnValueChange Property
Gets whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool ShouldNotifyParentOnValueChange { get; }
Public Overridable ReadOnly Property ShouldNotifyParentOnValueChange As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.

Implements

IPropertyModelShouldNotifyParentOnValueChange
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.SortComparer Property

PropertyModelSortComparer Property
Gets or sets the DataModelSortComparer to use for sorting this data model's children.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataModelSortComparer SortComparer { get; set; }
Public Property SortComparer As DataModelSortComparer
    Get
    Set

Property Value

Type: DataModelSortComparer
The DataModelSortComparer to use for sorting this data model's children.

Implements

IDataModelSortComparer
Remarks
If this property doesn't return anything, the default SortComparer will be used.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.SortImportance Property

PropertyModelSortImportance Property
Gets or sets a DataModelSortImportance that indicates the sort importance of this data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataModelSortImportance SortImportance { get; set; }
Public Overridable Property SortImportance As DataModelSortImportance
    Get
    Set

Property Value

Type: DataModelSortImportance
A DataModelSortImportance that indicates the sort importance of this data model.

Implements

IDataModelSortImportance
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.SortOrder Property

PropertyModelSortOrder Property
Gets or sets a numeric sort order for sorting the data model within other data models of the same sort importance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int SortOrder { get; set; }
Public Property SortOrder As Integer
    Get
    Set

Property Value

Type: Int32
A numeric sort order for sorting the data model within other data models of the same sort importance.

Implements

IDataModelSortOrder
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValues Property

PropertyModelStandardValues Property
Gets or sets the standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable StandardValues { get; set; }
Public Property StandardValues As IEnumerable
    Get
    Set

Property Value

Type: IEnumerable
The standard list of values for the Value property.

Implements

IPropertyModelStandardValues
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesAsStrings Property

PropertyModelStandardValuesAsStrings Property
Gets or sets the standard list of values for the ValueAsString property as a list of strings.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<string> StandardValuesAsStrings { get; set; }
Public Property StandardValuesAsStrings As IEnumerable(Of String)
    Get
    Set

Property Value

Type: IEnumerable String
The standard list of values for the ValueAsString property as a list of strings.

Implements

IPropertyModelStandardValuesAsStrings
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Tag Property

PropertyModelTag Property
Gets or sets custom data for the data model.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set

Property Value

Type: Object
The custom data for the data model.

Implements

IDataModelTag
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Target Property

PropertyModelTarget Property
Gets the target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object Target { get; }
Public Overridable ReadOnly Property Target As Object
    Get

Property Value

Type: Object
The target object that owns the property.

Implements

IPropertyModelTarget
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.TargetType Property

PropertyModelTargetType Property
Gets or sets the Type of the Target property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type TargetType { get; set; }
Public Property TargetType As Type
    Get
    Set

Property Value

Type: Type
The Type of the Target property.

Implements

IPropertyModelTargetType
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Value Property

PropertyModelValue Property
Gets or sets the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
The property value.

Implements

IPropertyModelValue
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueAsString Property

PropertyModelValueAsString Property
Gets or sets the property value in a string representation.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string ValueAsString { get; set; }
Public Property ValueAsString As String
    Get
    Set

Property Value

Type: String
The property value in a string representation.

Implements

IPropertyModelValueAsString
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValuePropertyEditor Property

PropertyModelValuePropertyEditor Property
Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor ValuePropertyEditor { get; set; }
Public Property ValuePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Implements

IPropertyModelValuePropertyEditor
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Values Property

PropertyModelValues Property
Gets the property values, of which there will only be more than one if this is a merged property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual IList<Object> Values { get; }
Public Overridable ReadOnly Property Values As IList(Of Object)
    Get

Property Value

Type: IList Object
The property values, of which there will only be more than one if this is a merged property.

Implements

IPropertyModelValues
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplate Property

PropertyModelValueTemplate Property
Gets or sets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ValueTemplate { get; set; }
Public Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplate
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKey Property

PropertyModelValueTemplateKey Property
Gets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ValueTemplateKey { get; set; }
Public Property ValueTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateKey
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKind Property

PropertyModelValueTemplateKind Property
Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DefaultValueTemplateKind ValueTemplateKind { get; set; }
Public Property ValueTemplateKind As DefaultValueTemplateKind
    Get
    Set

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Implements

IPropertyModelValueTemplateKind
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateSelector Property

PropertyModelValueTemplateSelector Property
Gets or sets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplateSelector ValueTemplateSelector { get; set; }
Public Property ValueTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplate to use for editing the property value.

Implements

IPropertyModelValueTemplateSelector
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, ValueTemplateKind, and finally any value templates in matching property editors.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueType Property

PropertyModelValueType Property
Gets or sets the Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type ValueType { get; set; }
Public Property ValueType As Type
    Get
    Set

Property Value

Type: Type
The Type of the Value property.

Implements

IPropertyModelValueType
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel Methods

PropertyModel Methods

The PropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | Returns a String representation of this instance. (Overrides ObjectToString.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.AddChild Method

PropertyModelAddChild Method
Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddChild()
Public Overridable Sub AddChild

Implements

IPropertyModelAddChild
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ConvertFromString Method

PropertyModelConvertFromString Method
Converts the specified value from a string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Object ConvertFromString(
    string stringValue
)
Protected Overridable Function ConvertFromString (
    stringValue As String
) As Object

Parameters

stringValue
Type: SystemString
The string value to convert.

Return Value

Type: Object
An object from the string representation, or .
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ConvertToString Method

PropertyModelConvertToString Method
Converts the specified value to a string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string ConvertToString(
    Object value
)
Protected Overridable Function ConvertToString (
    value As Object
) As String

Parameters

value
Type: SystemObject
The value to convert.

Return Value

Type: String
A string representation of the specified value, or .
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CycleToNextStandardValue Method

PropertyModelCycleToNextStandardValue Method
Cycles the property value to the next standard value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CycleToNextStandardValue()
Public Overridable Function CycleToNextStandardValue As Boolean

Return Value

Type: Boolean
true if a standard value was set; otherwise, false.

Implements

IPropertyModelCycleToNextStandardValue
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Dispose Method

PropertyModelDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Dispose Method

PropertyModelDispose Method
Releases all resources used by the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PropertyModel Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Dispose Method (Boolean)

PropertyModelDispose Method (Boolean)
Releases the unmanaged resources used by the object and optionally releases the managed resources.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Remarks
This method is called by the public Dispose method and the Finalize method. Dispose invokes this method with the disposing parameter set to true. Finalize invokes this method with disposing set to false.
See Also

Reference

PropertyModel Class
Dispose Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.GetErrorMessages Method

PropertyModelGetErrorMessages Method
Returns the error messages for the target object or one of its properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IEnumerable GetErrorMessages(
    string columnName
)
Protected Overridable Function GetErrorMessages (
    columnName As String
) As IEnumerable

Parameters

columnName
Type: SystemString
The name of the property to examine, or if the target object itself should be examined.

Return Value

Type: IEnumerable
The error messages that are applicable, if any.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NotifyPropertyChanged Method

PropertyModelNotifyPropertyChanged Method
Notifies that a property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.OnPropertyChanged Method

PropertyModelOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyAddedEvent Method

PropertyModelRaiseChildPropertyAddedEvent Method
Raises a collection item property added event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyAddingEvent Method

PropertyModelRaiseChildPropertyAddingEvent Method
Raises a collection item property adding event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyRemovedEvent Method

PropertyModelRaiseChildPropertyRemovedEvent Method
Raises a collection item property removed event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RaiseChildPropertyRemovingEvent Method

PropertyModelRaiseChildPropertyRemovingEvent Method
Raises a collection item property removing event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RaisePropertyValueChangedEvent Method

PropertyModelRaisePropertyValueChangedEvent Method
Raises a property value changed event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangedEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangedEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RaisePropertyValueChangingEvent Method

PropertyModelRaisePropertyValueChangingEvent Method
Raises a property value changing event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangingEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangingEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Refresh Method

PropertyModelRefresh Method
Refreshes the property based on the specified reason.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    PropertyRefreshReason reason
)
Public Overridable Sub Refresh (
    reason As PropertyRefreshReason
)

Parameters

reason
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyRefreshReason
The reason the property needs to be refreshed.

Implements

IPropertyModelRefresh(PropertyRefreshReason)
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.RefreshChildren Method

PropertyModelRefreshChildren Method
Refreshes the contents of the Children property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void RefreshChildren()
Protected Overridable Sub RefreshChildren
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.Remove Method

PropertyModelRemove Method
Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Remove()
Public Overridable Sub Remove

Implements

IPropertyModelRemove
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ResetValue Method

PropertyModelResetValue Method
Resets the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void ResetValue()
Public Overridable Sub ResetValue

Implements

IPropertyModelResetValue
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ToString Method

PropertyModelToString Method
Returns a String representation of this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String representation of this instance.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel Events

PropertyModel Events

The PropertyModel type exposes the following members.

Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity.
Public event | PropertyChanged | Occurs when a property has been changed.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ErrorsChanged Event

PropertyModelErrorsChanged Event
Occurs when the validation errors have changed for a property or for the entire entity.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DataErrorsChangedEventArgs> ErrorsChanged
Public Event ErrorsChanged As EventHandler(Of DataErrorsChangedEventArgs)

Value

Type: SystemEventHandler DataErrorsChangedEventArgs

Implements

INotifyDataErrorInfoErrorsChanged
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.PropertyChanged Event

PropertyModelPropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel Fields

PropertyModel Fields

The PropertyModel type exposes the following members.

Fields
Name | Description
CanResetValueProperty | Identifies the CanResetValue dependency property. This field is read-only.
CategoryProperty | Identifies the Category dependency property. This field is read-only.
ConverterProperty | Identifies the Converter dependency property. This field is read-only.
DefaultValueProperty | Identifies the DefaultValue dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
DisplayNameProperty | Identifies the DisplayName dependency property. This field is read-only.
IsExpandedProperty | Identifies the IsExpanded dependency property. This field is read-only.
IsHostReadOnlyProperty | Identifies the IsHostReadOnly dependency property. This field is read-only.
IsImmutableProperty | Identifies the IsImmutable dependency property. This field is read-only.
IsLimitedToStandardValuesProperty | Identifies the IsLimitedToStandardValues dependency property. This field is read-only.
IsModifiedProperty | Identifies the IsModified dependency property. This field is read-only.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. This field is read-only.
IsSelectedProperty | Identifies the IsSelected dependency property. This field is read-only.
IsValueReadOnlyProperty | Identifies the IsValueReadOnly dependency property. This field is read-only.
NameProperty | Identifies the Name dependency property. This field is read-only.
NamePropertyEditorProperty | Identifies the NamePropertyEditor dependency property. This field is read-only.
NameTemplateKeyProperty | Identifies the NameTemplateKey dependency property. This field is read-only.
NameTemplateProperty | Identifies the NameTemplate dependency property. This field is read-only.
NameTemplateSelectorProperty | Identifies the NameTemplateSelector dependency property. This field is read-only.
SortComparerProperty | Identifies the SortComparer dependency property. This field is read-only.
SortImportanceProperty | Identifies the SortImportance dependency property. This field is read-only.
SortOrderProperty | Identifies the SortOrder dependency property. This field is read-only.
StandardValuesAsStringsProperty | Identifies the StandardValuesAsStrings dependency property. This field is read-only.
StandardValuesProperty | Identifies the StandardValues dependency property. This field is read-only.
TagProperty | Identifies the Tag dependency property. This field is read-only.
TargetTypeProperty | Identifies the TargetType dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
ValuePropertyEditorProperty | Identifies the ValuePropertyEditor dependency property. This field is read-only.
ValueTemplateKeyProperty | Identifies the ValueTemplateKey dependency property. This field is read-only.
ValueTemplateKindProperty | Identifies the ValueTemplateKind dependency property. This field is read-only.
ValueTemplateProperty | Identifies the ValueTemplate dependency property. This field is read-only.
ValueTemplateSelectorProperty | Identifies the ValueTemplateSelector dependency property. This field is read-only.
ValueTypeProperty | Identifies the ValueType dependency property. This field is read-only.
Top
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CanResetValueProperty Field

PropertyModelCanResetValueProperty Field
Identifies the CanResetValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanResetValueProperty
Public Shared ReadOnly CanResetValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanResetValue dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.CategoryProperty Field

PropertyModelCategoryProperty Field
Identifies the Category dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CategoryProperty
Public Shared ReadOnly CategoryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Category dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ConverterProperty Field

PropertyModelConverterProperty Field
Identifies the Converter dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ConverterProperty
Public Shared ReadOnly ConverterProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Converter dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.DefaultValueProperty Field

PropertyModelDefaultValueProperty Field
Identifies the DefaultValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DefaultValueProperty
Public Shared ReadOnly DefaultValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DefaultValue dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.DescriptionProperty Field

PropertyModelDescriptionProperty Field
Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.DisplayNameProperty Field

PropertyModelDisplayNameProperty Field
Identifies the DisplayName dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DisplayNameProperty
Public Shared ReadOnly DisplayNameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DisplayName dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsExpandedProperty Field

PropertyModelIsExpandedProperty Field
Identifies the IsExpanded dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsExpandedProperty
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsExpanded dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsHostReadOnlyProperty Field

PropertyModelIsHostReadOnlyProperty Field
Identifies the IsHostReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHostReadOnlyProperty
Public Shared ReadOnly IsHostReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHostReadOnly dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsImmutableProperty Field

PropertyModelIsImmutableProperty Field
Identifies the IsImmutable dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsImmutableProperty
Public Shared ReadOnly IsImmutableProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsImmutable dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsLimitedToStandardValuesProperty Field

PropertyModelIsLimitedToStandardValuesProperty Field
Identifies the IsLimitedToStandardValues dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLimitedToStandardValuesProperty
Public Shared ReadOnly IsLimitedToStandardValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLimitedToStandardValues dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsModifiedProperty Field

PropertyModelIsModifiedProperty Field
Identifies the IsModified dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsModifiedProperty
Public Shared ReadOnly IsModifiedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsModified dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsReadOnlyProperty Field

PropertyModelIsReadOnlyProperty Field
Identifies the IsReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsReadOnlyProperty
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsReadOnly dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsSelectedProperty Field

PropertyModelIsSelectedProperty Field
Identifies the IsSelected dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectedProperty
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelected dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.IsValueReadOnlyProperty Field

PropertyModelIsValueReadOnlyProperty Field
Identifies the IsValueReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsValueReadOnlyProperty
Public Shared ReadOnly IsValueReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsValueReadOnly dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameProperty Field

PropertyModelNameProperty Field
Identifies the Name dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameProperty
Public Shared ReadOnly NameProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Name dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NamePropertyEditorProperty Field

PropertyModelNamePropertyEditorProperty Field
Identifies the NamePropertyEditor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NamePropertyEditorProperty
Public Shared ReadOnly NamePropertyEditorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NamePropertyEditor dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateKeyProperty Field

PropertyModelNameTemplateKeyProperty Field
Identifies the NameTemplateKey dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateKeyProperty
Public Shared ReadOnly NameTemplateKeyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplateKey dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateProperty Field

PropertyModelNameTemplateProperty Field
Identifies the NameTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateProperty
Public Shared ReadOnly NameTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplate dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.NameTemplateSelectorProperty Field

PropertyModelNameTemplateSelectorProperty Field
Identifies the NameTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NameTemplateSelectorProperty
Public Shared ReadOnly NameTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NameTemplateSelector dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.SortComparerProperty Field

PropertyModelSortComparerProperty Field
Identifies the SortComparer dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortComparerProperty
Public Shared ReadOnly SortComparerProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortComparer dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.SortImportanceProperty Field

PropertyModelSortImportanceProperty Field
Identifies the SortImportance dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortImportanceProperty
Public Shared ReadOnly SortImportanceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortImportance dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.SortOrderProperty Field

PropertyModelSortOrderProperty Field
Identifies the SortOrder dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SortOrderProperty
Public Shared ReadOnly SortOrderProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SortOrder dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesAsStringsProperty Field

PropertyModelStandardValuesAsStringsProperty Field
Identifies the StandardValuesAsStrings dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardValuesAsStringsProperty
Public Shared ReadOnly StandardValuesAsStringsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardValuesAsStrings dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.StandardValuesProperty Field

PropertyModelStandardValuesProperty Field
Identifies the StandardValues dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StandardValuesProperty
Public Shared ReadOnly StandardValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StandardValues dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.TagProperty Field

PropertyModelTagProperty Field
Identifies the Tag dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TagProperty
Public Shared ReadOnly TagProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Tag dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.TargetTypeProperty Field

PropertyModelTargetTypeProperty Field
Identifies the TargetType dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TargetTypeProperty
Public Shared ReadOnly TargetTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the TargetType dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueProperty Field

PropertyModelValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValuePropertyEditorProperty Field

PropertyModelValuePropertyEditorProperty Field
Identifies the ValuePropertyEditor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValuePropertyEditorProperty
Public Shared ReadOnly ValuePropertyEditorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValuePropertyEditor dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKeyProperty Field

PropertyModelValueTemplateKeyProperty Field
Identifies the ValueTemplateKey dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateKeyProperty
Public Shared ReadOnly ValueTemplateKeyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateKey dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateKindProperty Field

PropertyModelValueTemplateKindProperty Field
Identifies the ValueTemplateKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateKindProperty
Public Shared ReadOnly ValueTemplateKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateKind dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateProperty Field

PropertyModelValueTemplateProperty Field
Identifies the ValueTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateProperty
Public Shared ReadOnly ValueTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplate dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTemplateSelectorProperty Field

PropertyModelValueTemplateSelectorProperty Field
Identifies the ValueTemplateSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTemplateSelectorProperty
Public Shared ReadOnly ValueTemplateSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueTemplateSelector dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModel.ValueTypeProperty Field

PropertyModelValueTypeProperty Field
Identifies the ValueType dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueTypeProperty
Public Shared ReadOnly ValueTypeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ValueType dependency property.
See Also

Reference

PropertyModel Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase Class

PropertyModelBase Class
Provides an abstract base class for a property grid IDataModel that can provide the foundation for an IPropertyModel implementation.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataCachedPropertyModelBase

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class PropertyModelBase : DataModelBase,
    INotifyDataErrorInfo
Public MustInherit Class PropertyModelBase
    Inherits DataModelBase
    Implements INotifyDataErrorInfo

The PropertyModelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PropertyModelBase | Initializes a new instance of the PropertyModelBase class
Top
Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from DataModelBase.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from DataModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from DataModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from DataModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from DataModelBase.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from DataModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Protected property | TargetResolved | Gets the resolved target object that owns the property.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Protected property | ValueResolved | Gets or sets the resolved property value.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property.
Top
Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides ObservableObjectBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity.
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase Constructor

PropertyModelBase Constructor
Initializes a new instance of the PropertyModelBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected PropertyModelBase()
Protected Sub New
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase Properties

PropertyModelBase Properties

The PropertyModelBase type exposes the following members.

Properties
 | Name | Description
Public property | AddChildCommand | Gets the ICommand used to add a new child into to an associated collection/parent.
Protected property | CanAddChildResolved | Gets the resolved value for whether a new child can be added to an associated collection/parent.
Public property | CanAutoDispose | Gets whether the data model should be automatically disposed when it is removed from a parent data model. (Inherited from DataModelBase.)
Protected property | CanRemoveResolved | Gets the resolved value for whether the property can be removed from an associated collection/parent.
Protected property | CanResetValueResolved | Gets the resolved value for whether the property can be reset to its default value.
Public property | Children | Gets the collection of child data models. (Inherited from DataModelBase.)
Protected property | ConverterResolved | Gets the resolved TypeConverter to use for the property.
Protected property | DescriptionResolved | Gets the resolved description of the data model, often displayed in a summary area or a tooltip. (Inherited from DataModelBase.)
Protected property | DisplayNameResolved | Gets the name to use when displaying the data model, often the same as Name. (Inherited from DataModelBase.)
Public property | HasStandardValues | Gets whether the property supports StandardValues.
Public property | IsExpanded | Gets or sets whether the data model is expanded. (Inherited from DataModelBase.)
Public property | IsHostReadOnly | Gets or sets whether the host UI control (e.g. a property grid) is read-only.
Protected property | IsImmutableResolved | Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.
Protected property | IsModifiedResolved | Gets whether the data model has been modified. (Inherited from DataModelBase.)
Public property | IsReadOnly | Gets whether UI for editing the property value is read-only.
Public property | IsRoot | Gets whether the data model is the root. (Inherited from DataModelBase.)
Public property | IsSelected | Gets or sets whether the data model is selected. (Inherited from DataModelBase.)
Protected property | IsValueReadOnlyResolved | Gets the resolved value for whether the Value property is read-only.
Public property | NamePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
Protected property | NameResolved | Gets the resolved name of the data model. (Inherited from DataModelBase.)
Public property | Parent | Gets the parent data model. (Inherited from DataModelBase.)
Public property | RemoveCommand | Gets the ICommand used to remove the property from an associated collection/parent.
Public property | ResetValueCommand | Gets the ICommand used to reset the property value to its default value.
Protected property | ShouldNotifyParentOnValueChangeResolved | Gets the resolved value for whether the property should notify its parent property when the Value changes.
Public property | SortComparer | Gets or sets the DataModelSortComparer to use for sorting this data model's children. (Inherited from DataModelBase.)
Protected property | SortImportanceResolved | Gets a resolved DataModelSortImportance that indicates the sort importance of this data model. (Inherited from DataModelBase.)
Protected property | SortOrderResolved | Gets a resolved numeric sort order for sorting the data model within other data models of the same sort importance. (Inherited from DataModelBase.)
Protected property | StandardValuesResolved | Gets the resolved standard list of values for the Value property.
Public property | Tag | Gets or sets custom data for the data model. (Inherited from DataModelBase.)
Protected property | TargetResolved | Gets the resolved target object that owns the property.
Public property | ValuePropertyEditor | Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
Protected property | ValueResolved | Gets or sets the resolved property value.
Protected property | ValueTypeResolved | Gets the resolved Type of the Value property.
Top
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.AddChildCommand Property

PropertyModelBaseAddChildCommand Property
Gets the ICommand used to add a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand AddChildCommand { get; }
Public ReadOnly Property AddChildCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to add a new child into to an associated collection/parent.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.CanAddChildResolved Property

PropertyModelBaseCanAddChildResolved Property
Gets the resolved value for whether a new child can be added to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool CanAddChildResolved { get; }
Protected MustOverride ReadOnly Property CanAddChildResolved As Boolean
    Get

Property Value

Type: Boolean
true if a new child can be added to an associated collection/parent; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.CanRemoveResolved Property

PropertyModelBaseCanRemoveResolved Property
Gets the resolved value for whether the property can be removed from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool CanRemoveResolved { get; }
Protected MustOverride ReadOnly Property CanRemoveResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be removed from an associated collection/parent; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.CanResetValueResolved Property

PropertyModelBaseCanResetValueResolved Property
Gets the resolved value for whether the property can be reset to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool CanResetValueResolved { get; }
Protected MustOverride ReadOnly Property CanResetValueResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property can be reset to its default value; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ConverterResolved Property

PropertyModelBaseConverterResolved Property
Gets the resolved TypeConverter to use for the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract TypeConverter ConverterResolved { get; }
Protected MustOverride ReadOnly Property ConverterResolved As TypeConverter
    Get

Property Value

Type: TypeConverter
The TypeConverter to use for the property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.HasStandardValues Property

PropertyModelBaseHasStandardValues Property
Gets whether the property supports StandardValues.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool HasStandardValues { get; }
Public Overridable ReadOnly Property HasStandardValues As Boolean
    Get

Property Value

Type: Boolean
true if the property supports StandardValues; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsHostReadOnly Property

PropertyModelBaseIsHostReadOnly Property
Gets or sets whether the host UI control (e.g. a property grid) is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHostReadOnly { get; set; }
Public Property IsHostReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the host UI control (e.g. a property grid) is read-only; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsImmutableResolved Property

PropertyModelBaseIsImmutableResolved Property
Gets the resolved value for whether the Value's child properties, if any, are capable of being edited.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsImmutableResolved { get; }
Protected MustOverride ReadOnly Property IsImmutableResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value's child properties, if any, are capable of being edited; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsReadOnly Property

PropertyModelBaseIsReadOnly Property
Gets whether UI for editing the property value is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the UI for editing the property value is read-only; otherwise, false.
Remarks
This property is a resolved value of IsHostReadOnly and IsValueReadOnly, and also considers whether a parent property is immutable.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.IsValueReadOnlyResolved Property

PropertyModelBaseIsValueReadOnlyResolved Property
Gets the resolved value for whether the Value property is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool IsValueReadOnlyResolved { get; }
Protected MustOverride ReadOnly Property IsValueReadOnlyResolved As Boolean
    Get

Property Value

Type: Boolean
true if the Value property is read-only; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.NamePropertyEditor Property

PropertyModelBaseNamePropertyEditor Property
Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor NamePropertyEditor { get; set; }
Public Property NamePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for showing the property display name.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RemoveCommand Property

PropertyModelBaseRemoveCommand Property
Gets the ICommand used to remove the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand RemoveCommand { get; }
Public ReadOnly Property RemoveCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to remove the property from an associated collection/parent.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ResetValueCommand Property

PropertyModelBaseResetValueCommand Property
Gets the ICommand used to reset the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ResetValueCommand { get; }
Public ReadOnly Property ResetValueCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand used to reset the property value to its default value.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ShouldNotifyParentOnValueChangeResolved Property

PropertyModelBaseShouldNotifyParentOnValueChangeResolved Property
Gets the resolved value for whether the property should notify its parent property when the Value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract bool ShouldNotifyParentOnValueChangeResolved { get; }
Protected MustOverride ReadOnly Property ShouldNotifyParentOnValueChangeResolved As Boolean
    Get

Property Value

Type: Boolean
true if the property should notify its parent property when the Value changes; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.StandardValuesResolved Property

PropertyModelBaseStandardValuesResolved Property
Gets the resolved standard list of values for the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract IEnumerable StandardValuesResolved { get; }
Protected MustOverride ReadOnly Property StandardValuesResolved As IEnumerable
    Get

Property Value

Type: IEnumerable
The standard list of values for the Value property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.TargetResolved Property

PropertyModelBaseTargetResolved Property
Gets the resolved target object that owns the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Object TargetResolved { get; }
Protected MustOverride ReadOnly Property TargetResolved As Object
    Get

Property Value

Type: Object
The target object that owns the property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ValuePropertyEditor Property

PropertyModelBaseValuePropertyEditor Property
Gets or sets the PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor ValuePropertyEditor { get; set; }
Public Property ValuePropertyEditor As PropertyEditor
    Get
    Set

Property Value

Type: PropertyEditor
The PropertyEditor, if any, that was used to select the DataTemplate for editing the property value.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ValueResolved Property

PropertyModelBaseValueResolved Property
Gets or sets the resolved property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Object ValueResolved { get; set; }
Protected MustOverride Property ValueResolved As Object
    Get
    Set

Property Value

Type: Object
The property value.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ValueTypeResolved Property

PropertyModelBaseValueTypeResolved Property
Gets the resolved Type of the Value property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract Type ValueTypeResolved { get; }
Protected MustOverride ReadOnly Property ValueTypeResolved As Type
    Get

Property Value

Type: Type
The Type of the Value property.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase Methods

PropertyModelBase Methods

The PropertyModelBase type exposes the following members.

Methods
 | Name | Description
Public method | AddChild | Adds a new child into to an associated collection/parent.
Protected method | ConvertFromString | Converts the specified value from a string.
Protected method | ConvertToString | Converts the specified value to a string.
Public method | CycleToNextStandardValue | Cycles the property value to the next standard value.
Public method | Dispose | Releases all resources used by the object. (Inherited from DataModelBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the object and optionally releases the managed resources. (Inherited from DataModelBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | Allows an object to attempt to free resources and perform other cleanup operations before the object is reclaimed by garbage collection. (Inherited from DataModelBase.)
Protected method | GetErrorMessages | Returns the error messages for the target object or one of its properties.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Overrides ObservableObjectBaseOnPropertyChanged(PropertyChangedEventArgs).)
Protected method | RaiseChildPropertyAddedEvent | Raises a collection item property added event on the PropertyGrid.
Protected method | RaiseChildPropertyAddingEvent | Raises a collection item property adding event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovedEvent | Raises a collection item property removed event on the PropertyGrid.
Protected method | RaiseChildPropertyRemovingEvent | Raises a collection item property removing event on the PropertyGrid.
Protected method | RaisePropertyValueChangedEvent | Raises a property value changed event on the PropertyGrid.
Protected method | RaisePropertyValueChangingEvent | Raises a property value changing event on the PropertyGrid.
Public method | Refresh | Refreshes the property based on the specified reason.
Protected method | RefreshChildren | Refreshes the contents of the Children property. (Inherited from DataModelBase.)
Public method | Remove | Removes the property from an associated collection/parent.
Public method | ResetValue | Resets the property value to its default value.
Public method | ToString | Returns a String representation of this instance. (Inherited from DataModelBase.)
Top
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.AddChild Method

PropertyModelBaseAddChild Method
Adds a new child into to an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void AddChild()
Public Overridable Sub AddChild
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ConvertFromString Method

PropertyModelBaseConvertFromString Method
Converts the specified value from a string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Object ConvertFromString(
    string stringValue
)
Protected Overridable Function ConvertFromString (
    stringValue As String
) As Object

Parameters

stringValue
Type: SystemString
The string value to convert.

Return Value

Type: Object
An object from the string representation, or .
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ConvertToString Method

PropertyModelBaseConvertToString Method
Converts the specified value to a string.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual string ConvertToString(
    Object value
)
Protected Overridable Function ConvertToString (
    value As Object
) As String

Parameters

value
Type: SystemObject
The value to convert.

Return Value

Type: String
A string representation of the specified value, or .
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.CycleToNextStandardValue Method

PropertyModelBaseCycleToNextStandardValue Method
Cycles the property value to the next standard value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual bool CycleToNextStandardValue()
Public Overridable Function CycleToNextStandardValue As Boolean

Return Value

Type: Boolean
true if a standard value was set; otherwise, false.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.GetErrorMessages Method

PropertyModelBaseGetErrorMessages Method
Returns the error messages for the target object or one of its properties.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IEnumerable GetErrorMessages(
    string columnName
)
Protected Overridable Function GetErrorMessages (
    columnName As String
) As IEnumerable

Parameters

columnName
Type: SystemString
The name of the property to examine, or if the target object itself should be examined.

Return Value

Type: IEnumerable
The error messages that are applicable, if any.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.OnPropertyChanged Method

PropertyModelBaseOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overrides Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyAddedEvent Method

PropertyModelBaseRaiseChildPropertyAddedEvent Method
Raises a collection item property added event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyAddingEvent Method

PropertyModelBaseRaiseChildPropertyAddingEvent Method
Raises a collection item property adding event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyAddingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyAddingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyRemovedEvent Method

PropertyModelBaseRaiseChildPropertyRemovedEvent Method
Raises a collection item property removed event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovedEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovedEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaiseChildPropertyRemovingEvent Method

PropertyModelBaseRaiseChildPropertyRemovingEvent Method
Raises a collection item property removing event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaiseChildPropertyRemovingEvent(
    PropertyModelChildChangeEventArgs e
)
Protected Sub RaiseChildPropertyRemovingEvent (
    e As PropertyModelChildChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelChildChangeEventArgs
The PropertyModelChildChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaisePropertyValueChangedEvent Method

PropertyModelBaseRaisePropertyValueChangedEvent Method
Raises a property value changed event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangedEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangedEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.RaisePropertyValueChangingEvent Method

PropertyModelBaseRaisePropertyValueChangingEvent Method
Raises a property value changing event on the PropertyGrid.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void RaisePropertyValueChangingEvent(
    PropertyModelValueChangeEventArgs e
)
Protected Sub RaisePropertyValueChangingEvent (
    e As PropertyModelValueChangeEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.GridsPropertyModelValueChangeEventArgs
The PropertyModelValueChangeEventArgs that contains the event data.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.Refresh Method

PropertyModelBaseRefresh Method
Refreshes the property based on the specified reason.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh(
    PropertyRefreshReason reason
)
Public Overridable Sub Refresh (
    reason As PropertyRefreshReason
)

Parameters

reason
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyRefreshReason
The reason the property needs to be refreshed.
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.Remove Method

PropertyModelBaseRemove Method
Removes the property from an associated collection/parent.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Remove()
Public Overridable Sub Remove
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ResetValue Method

PropertyModelBaseResetValue Method
Resets the property value to its default value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void ResetValue()
Public Overridable Sub ResetValue
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase Events

PropertyModelBase Events

The PropertyModelBase type exposes the following members.

Events
 | Name | Description
Public event | ErrorsChanged | Occurs when the validation errors have changed for a property or for the entire entity.
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBase.ErrorsChanged Event

PropertyModelBaseErrorsChanged Event
Occurs when the validation errors have changed for a property or for the entire entity.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<DataErrorsChangedEventArgs> ErrorsChanged
Public Event ErrorsChanged As EventHandler(Of DataErrorsChangedEventArgs)

Value

Type: SystemEventHandler DataErrorsChangedEventArgs

Implements

INotifyDataErrorInfoErrorsChanged
See Also

Reference

PropertyModelBase Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Class

PropertyModelBooleanFilter Class
Represents a IDataFilter implementation for IPropertyModel boolean properties.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Data.FilteringDataFilterBase
ActiproSoftware.UI.Xaml.Data.FilteringBooleanFilterBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBooleanFilter

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyModelBooleanFilter : BooleanFilterBase
Public Class PropertyModelBooleanFilter
    Inherits BooleanFilterBase

The PropertyModelBooleanFilter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelBooleanFilter | Initializes a new instance of the PropertyModelBooleanFilter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the boolean operation performed by this filter. (Inherited from BooleanFilterBase.)
Public property | Source | Gets or sets the IPropertyModel boolean property to examine with this filter.
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from BooleanFilterBase.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object).)
Protected method | FilterByBoolean | Examines the specified boolean to see if meets filter conditions. (Inherited from BooleanFilterBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Constructor

PropertyModelBooleanFilter Constructor
Initializes a new instance of the PropertyModelBooleanFilter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelBooleanFilter()
Public Sub New
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Properties

PropertyModelBooleanFilter Properties

The PropertyModelBooleanFilter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the boolean operation performed by this filter. (Inherited from BooleanFilterBase.)
Public property | Source | Gets or sets the IPropertyModel boolean property to examine with this filter.
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from BooleanFilterBase.)
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter.Source Property

PropertyModelBooleanFilterSource Property
Gets or sets the IPropertyModel boolean property to examine with this filter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelBooleanFilterSource Source { get; set; }
Public Property Source As PropertyModelBooleanFilterSource
    Get
    Set

Property Value

Type: PropertyModelBooleanFilterSource
The IPropertyModel boolean property to examine with this filter. The default value is PropertyModelBooleanFilterSource.IsReadOnly.
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Methods

PropertyModelBooleanFilter Methods

The PropertyModelBooleanFilter type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object).)
Protected method | FilterByBoolean | Examines the specified boolean to see if meets filter conditions. (Inherited from BooleanFilterBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter.Filter Method

PropertyModelBooleanFilterFilter Method
Examines the specified item to see if meets filter conditions.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override DataFilterResult Filter(
    Object item
)
Public Overrides Function Filter (
    item As Object
) As DataFilterResult

Parameters

item
Type: SystemObject
The item to examine.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.

Implements

IDataFilterFilter(Object)
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Events

PropertyModelBooleanFilter Events

The PropertyModelBooleanFilter type exposes the following members.

Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter Fields

PropertyModelBooleanFilter Fields

The PropertyModelBooleanFilter type exposes the following members.

Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilter.SourceProperty Field

PropertyModelBooleanFilterSourceProperty Field
Identifies the Source dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SourceProperty
Public Shared ReadOnly SourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Source dependency property.
See Also

Reference

PropertyModelBooleanFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource Class

PropertyModelBooleanFilterSource Class
Specifies the source IPropertyModel boolean properties that can be used by a PropertyModelBooleanFilter.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelBooleanFilterSource

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PropertyModelBooleanFilterSource : Enum
Public NotInheritable Class PropertyModelBooleanFilterSource
    Inherits Enum

The PropertyModelBooleanFilterSource type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CanResetValue | The CanResetValue property should be used as the source.
 | HasStandardValues | The HasStandardValues property should be used as the source.
 | IsLimitedToStandardValues | The IsLimitedToStandardValues property should be used as the source.
 | IsMergeable | The IsMergeable property should be used as the source.
 | IsModified | The IsModified property should be used as the source.
 | IsReadOnly | The IsReadOnly property should be used as the source.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource Methods

PropertyModelBooleanFilterSource Methods

The PropertyModelBooleanFilterSource type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource Fields

PropertyModelBooleanFilterSource Fields

The PropertyModelBooleanFilterSource type exposes the following members.

Fields
 | Name | Description
 | CanResetValue | The CanResetValue property should be used as the source.
 | HasStandardValues | The HasStandardValues property should be used as the source.
 | IsLimitedToStandardValues | The IsLimitedToStandardValues property should be used as the source.
 | IsMergeable | The IsMergeable property should be used as the source.
 | IsModified | The IsModified property should be used as the source.
 | IsReadOnly | The IsReadOnly property should be used as the source.
Public field | value__ |
Top
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.CanResetValue Field

PropertyModelBooleanFilterSourceCanResetValue Field
The CanResetValue property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelBooleanFilterSource CanResetValue = 0
Public Const CanResetValue As PropertyModelBooleanFilterSource = 0

Field Value

Type: PropertyModelBooleanFilterSource
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.HasStandardValues Field

PropertyModelBooleanFilterSourceHasStandardValues Field
The HasStandardValues property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelBooleanFilterSource HasStandardValues = 1
Public Const HasStandardValues As PropertyModelBooleanFilterSource = 1

Field Value

Type: PropertyModelBooleanFilterSource
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.IsLimitedToStandardValues Field

PropertyModelBooleanFilterSourceIsLimitedToStandardValues Field
The IsLimitedToStandardValues property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelBooleanFilterSource IsLimitedToStandardValues = 2
Public Const IsLimitedToStandardValues As PropertyModelBooleanFilterSource = 2

Field Value

Type: PropertyModelBooleanFilterSource
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.IsMergeable Field

PropertyModelBooleanFilterSourceIsMergeable Field
The IsMergeable property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelBooleanFilterSource IsMergeable = 3
Public Const IsMergeable As PropertyModelBooleanFilterSource = 3

Field Value

Type: PropertyModelBooleanFilterSource
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.IsModified Field

PropertyModelBooleanFilterSourceIsModified Field
The IsModified property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelBooleanFilterSource IsModified = 4
Public Const IsModified As PropertyModelBooleanFilterSource = 4

Field Value

Type: PropertyModelBooleanFilterSource
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.IsReadOnly Field

PropertyModelBooleanFilterSourceIsReadOnly Field
The IsReadOnly property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelBooleanFilterSource IsReadOnly = 5
Public Const IsReadOnly As PropertyModelBooleanFilterSource = 5

Field Value

Type: PropertyModelBooleanFilterSource
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelBooleanFilterSource.value__ Field

PropertyModelBooleanFilterSourcevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData.PropertyModelBooleanFilterSource.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PropertyModelBooleanFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection Class

PropertyModelCollection Class
Represents a collection of IPropertyModel objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IPropertyModel
System.Collections.ObjectModelObservableCollection IPropertyModel
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyModelCollection : ObservableCollection<IPropertyModel>
Public Class PropertyModelCollection
    Inherits ObservableCollection(Of IPropertyModel)

The PropertyModelCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelCollection | Initializes a new instance of the PropertyModelCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection IPropertyModel .)
Public property | ItemInt32 | (Inherited from Collection IPropertyModel .)
Public property | ItemString | Gets the IPropertyModel in this collection that matches the specified name.
Protected property | Items | (Inherited from Collection IPropertyModel .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection IPropertyModel .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection IPropertyModel .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection IPropertyModel .)
Public method | Clear | (Inherited from Collection IPropertyModel .)
Protected method | ClearItems | (Inherited from ObservableCollection IPropertyModel .)
Public method | Contains | (Inherited from Collection IPropertyModel .)
Public method | CopyTo | (Inherited from Collection IPropertyModel .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection IPropertyModel .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection IPropertyModel .)
Public method | Insert | (Inherited from Collection IPropertyModel .)
Protected method | InsertItem | (Inherited from ObservableCollection IPropertyModel .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection IPropertyModel .)
Protected method | MoveItem | (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection IPropertyModel .)
Public method | Remove | (Inherited from Collection IPropertyModel .)
Public method | RemoveAt | (Inherited from Collection IPropertyModel .)
Protected method | RemoveItem | (Inherited from ObservableCollection IPropertyModel .)
Protected method | SetItem | (Inherited from ObservableCollection IPropertyModel .)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection IPropertyModel .)
Protected event | PropertyChanged | (Inherited from ObservableCollection IPropertyModel .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection Constructor

PropertyModelCollection Constructor
Initializes a new instance of the PropertyModelCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelCollection()
Public Sub New
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection Properties

PropertyModelCollection Properties

The PropertyModelCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection IPropertyModel .)
Public property | ItemInt32 | (Inherited from Collection IPropertyModel .)
Public property | ItemString | Gets the IPropertyModel in this collection that matches the specified name.
Protected property | Items | (Inherited from Collection IPropertyModel .)
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection.Item Property

PropertyModelCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | (Inherited from Collection IPropertyModel .)
Public property | ItemString | Gets the IPropertyModel in this collection that matches the specified name.
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection.Item Property (String)

PropertyModelCollectionItem Property (String)
Gets the IPropertyModel in this collection that matches the specified name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPropertyModel this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As IPropertyModel
    Get

Parameters

name
Type: SystemString

Property Value

Type: IPropertyModel
The IPropertyModel in this collection that matches the specified name.
See Also

Reference

PropertyModelCollection Class
Item Overload
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection Methods

PropertyModelCollection Methods

The PropertyModelCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection IPropertyModel .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection IPropertyModel .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection IPropertyModel .)
Public method | Clear | (Inherited from Collection IPropertyModel .)
Protected method | ClearItems | (Inherited from ObservableCollection IPropertyModel .)
Public method | Contains | (Inherited from Collection IPropertyModel .)
Public method | CopyTo | (Inherited from Collection IPropertyModel .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection IPropertyModel .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection IPropertyModel .)
Public method | Insert | (Inherited from Collection IPropertyModel .)
Protected method | InsertItem | (Inherited from ObservableCollection IPropertyModel .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection IPropertyModel .)
Protected method | MoveItem | (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection IPropertyModel .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection IPropertyModel .)
Public method | Remove | (Inherited from Collection IPropertyModel .)
Public method | RemoveAt | (Inherited from Collection IPropertyModel .)
Protected method | RemoveItem | (Inherited from ObservableCollection IPropertyModel .)
Protected method | SetItem | (Inherited from ObservableCollection IPropertyModel .)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelCollection Events

PropertyModelCollection Events

The PropertyModelCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection IPropertyModel .)
Protected event | PropertyChanged | (Inherited from ObservableCollection IPropertyModel .)
Top
See Also

Reference

PropertyModelCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Class

PropertyModelStringFilter Class
Represents a IDataFilter implementation for IPropertyModel string properties.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Data.FilteringDataFilterBase
ActiproSoftware.UI.Xaml.Data.FilteringStringFilterBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelStringFilter

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyModelStringFilter : StringFilterBase
Public Class PropertyModelStringFilter
    Inherits StringFilterBase

The PropertyModelStringFilter type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModelStringFilter | Initializes a new instance of the PropertyModelStringFilter class
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the string operation performed by this filter. (Inherited from StringFilterBase.)
Public property | RegexOptions | Gets or sets the options used for regex matches performed by this filter. (Inherited from StringFilterBase.)
Public property | Source | Gets or sets the IPropertyModel string property to examine with this filter.
Public property | StringComparison | Gets or sets the string comparison performed by this filter. (Inherited from StringFilterBase.)
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from StringFilterBase.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object).)
Protected method | FilterByString | Examines the specified string to see if meets filter conditions. (Inherited from StringFilterBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Constructor

PropertyModelStringFilter Constructor
Initializes a new instance of the PropertyModelStringFilter class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelStringFilter()
Public Sub New
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Properties

PropertyModelStringFilter Properties

The PropertyModelStringFilter type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Protected property | FallbackFilterResult | Gets the fallback filter result for scenarios where the filter is not applied. (Inherited from DataFilterBase.)
Public property | IsEnabled | Gets or sets whether the filter is enabled. (Inherited from DataFilterBase.)
Public property | Operation | Gets or sets the string operation performed by this filter. (Inherited from StringFilterBase.)
Public property | RegexOptions | Gets or sets the options used for regex matches performed by this filter. (Inherited from StringFilterBase.)
Public property | Source | Gets or sets the IPropertyModel string property to examine with this filter.
Public property | StringComparison | Gets or sets the string comparison performed by this filter. (Inherited from StringFilterBase.)
Public property | Value | Gets or sets the operand value used by this filter. (Inherited from StringFilterBase.)
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter.Source Property

PropertyModelStringFilterSource Property
Gets or sets the IPropertyModel string property to examine with this filter.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyModelStringFilterSource Source { get; set; }
Public Property Source As PropertyModelStringFilterSource
    Get
    Set

Property Value

Type: PropertyModelStringFilterSource
The IPropertyModel string property to examine with this filter. The default value is PropertyModelStringFilterSource.DisplayName.
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Methods

PropertyModelStringFilter Methods

The PropertyModelStringFilter type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Public method | Filter | Examines the specified item to see if meets filter conditions. (Overrides DataFilterBaseFilter(Object).)
Protected method | FilterByString | Examines the specified string to see if meets filter conditions. (Inherited from StringFilterBase.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | RaiseFilterChangedEvent | Raises the FilterChanged event if the filter is enabled. (Inherited from DataFilterBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter.Filter Method

PropertyModelStringFilterFilter Method
Examines the specified item to see if meets filter conditions.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override DataFilterResult Filter(
    Object item
)
Public Overrides Function Filter (
    item As Object
) As DataFilterResult

Parameters

item
Type: SystemObject
The item to examine.

Return Value

Type: DataFilterResult
A DataFilterResult that indicates the filter result.

Implements

IDataFilterFilter(Object)
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Events

PropertyModelStringFilter Events

The PropertyModelStringFilter type exposes the following members.

Events
 | Name | Description
Public event | FilterChanged | Occurs when the filter has changed and should be reapplied. (Inherited from DataFilterBase.)
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter Fields

PropertyModelStringFilter Fields

The PropertyModelStringFilter type exposes the following members.

Fields
Name | Description
SourceProperty | Identifies the Source dependency property. This field is read-only.
Top
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilter.SourceProperty Field

PropertyModelStringFilterSourceProperty Field
Identifies the Source dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SourceProperty
Public Shared ReadOnly SourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Source dependency property.
See Also

Reference

PropertyModelStringFilter Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource Class

PropertyModelStringFilterSource Class
Specifies the source IPropertyModel string properties that can be used by a PropertyModelStringFilter.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyModelStringFilterSource

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PropertyModelStringFilterSource : Enum
Public NotInheritable Class PropertyModelStringFilterSource
    Inherits Enum

The PropertyModelStringFilterSource type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Category | The Category property should be used as the source.
 | Description | The Description property should be used as the source.
 | DisplayName | The DisplayName property should be used as the source.
 | Name | The Name property should be used as the source.
Public field | value__ |
 | ValueType | The ValueType property should be used as the source.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource Methods

PropertyModelStringFilterSource Methods

The PropertyModelStringFilterSource type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource Fields

PropertyModelStringFilterSource Fields

The PropertyModelStringFilterSource type exposes the following members.

Fields
 | Name | Description
 | Category | The Category property should be used as the source.
 | Description | The Description property should be used as the source.
 | DisplayName | The DisplayName property should be used as the source.
 | Name | The Name property should be used as the source.
Public field | value__ |
 | ValueType | The ValueType property should be used as the source.
Top
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource.Category Field

PropertyModelStringFilterSourceCategory Field
The Category property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelStringFilterSource Category = 0
Public Const Category As PropertyModelStringFilterSource = 0

Field Value

Type: PropertyModelStringFilterSource
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource.Description Field

PropertyModelStringFilterSourceDescription Field
The Description property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelStringFilterSource Description = 1
Public Const Description As PropertyModelStringFilterSource = 1

Field Value

Type: PropertyModelStringFilterSource
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource.DisplayName Field

PropertyModelStringFilterSourceDisplayName Field
The DisplayName property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelStringFilterSource DisplayName = 2
Public Const DisplayName As PropertyModelStringFilterSource = 2

Field Value

Type: PropertyModelStringFilterSource
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource.Name Field

PropertyModelStringFilterSourceName Field
The Name property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelStringFilterSource Name = 3
Public Const Name As PropertyModelStringFilterSource = 3

Field Value

Type: PropertyModelStringFilterSource
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource.value__ Field

PropertyModelStringFilterSourcevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData.PropertyModelStringFilterSource.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyModelStringFilterSource.ValueType Field

PropertyModelStringFilterSourceValueType Field
The ValueType property should be used as the source.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyModelStringFilterSource ValueType = 4
Public Const ValueType As PropertyModelStringFilterSource = 4

Field Value

Type: PropertyModelStringFilterSource
See Also

Reference

PropertyModelStringFilterSource Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason Class

PropertyRefreshReason Class
Specifies the reason a property is being refreshed.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataPropertyRefreshReason

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PropertyRefreshReason : Enum
Public NotInheritable Class PropertyRefreshReason
    Inherits Enum

The PropertyRefreshReason type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | ChildPropertyValueChanged | Indicates that a child property's value has changed.
 | CollectionItemAdded | Indicates that an item was added to the property's collection value.
 | CollectionItemRemoved | Indicates that an item was removed from the property's collection value.
 | StandardValuesChanged | Indicates that the standard values have changed.
Public field | value__ |
 | ValueChanged | Indicates that the property's value has changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason Methods

PropertyRefreshReason Methods

The PropertyRefreshReason type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason Fields

PropertyRefreshReason Fields

The PropertyRefreshReason type exposes the following members.

Fields
 | Name | Description
 | ChildPropertyValueChanged | Indicates that a child property's value has changed.
 | CollectionItemAdded | Indicates that an item was added to the property's collection value.
 | CollectionItemRemoved | Indicates that an item was removed from the property's collection value.
 | StandardValuesChanged | Indicates that the standard values have changed.
Public field | value__ |
 | ValueChanged | Indicates that the property's value has changed.
Top
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason.ChildPropertyValueChanged Field

PropertyRefreshReasonChildPropertyValueChanged Field
Indicates that a child property's value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyRefreshReason ChildPropertyValueChanged = 1
Public Const ChildPropertyValueChanged As PropertyRefreshReason = 1

Field Value

Type: PropertyRefreshReason
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason.CollectionItemAdded Field

PropertyRefreshReasonCollectionItemAdded Field
Indicates that an item was added to the property's collection value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyRefreshReason CollectionItemAdded = 2
Public Const CollectionItemAdded As PropertyRefreshReason = 2

Field Value

Type: PropertyRefreshReason
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason.CollectionItemRemoved Field

PropertyRefreshReasonCollectionItemRemoved Field
Indicates that an item was removed from the property's collection value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyRefreshReason CollectionItemRemoved = 3
Public Const CollectionItemRemoved As PropertyRefreshReason = 3

Field Value

Type: PropertyRefreshReason
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason.StandardValuesChanged Field

PropertyRefreshReasonStandardValuesChanged Field
Indicates that the standard values have changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyRefreshReason StandardValuesChanged = 4
Public Const StandardValuesChanged As PropertyRefreshReason = 4

Field Value

Type: PropertyRefreshReason
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason.value__ Field

PropertyRefreshReasonvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData.PropertyRefreshReason.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


PropertyRefreshReason.ValueChanged Field

PropertyRefreshReasonValueChanged Field
Indicates that the property's value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PropertyRefreshReason ValueChanged = 0
Public Const ValueChanged As PropertyRefreshReason = 0

Field Value

Type: PropertyRefreshReason
See Also

Reference

PropertyRefreshReason Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


TypeReflectionFactory Class

TypeReflectionFactory Class
Implements an IDataFactory that uses reflection to return data models.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataDataFactoryBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataTypeReflectionFactory

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TypeReflectionFactory : DataFactoryBase
Public Class TypeReflectionFactory
    Inherits DataFactoryBase

The TypeReflectionFactory type exposes the following members.

Constructors
 | Name | Description
Public method | TypeReflectionFactory | Initializes a new instance of the TypeReflectionFactory class
Top
Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name. (Inherited from DataFactoryBase.)
Protected method | CreateCollectionPropertyModel | Creates an IPropertyModel for the specified collection data object.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects. (Inherited from DataFactoryBase.)
Protected method | CreatePropertyModel | Creates an IPropertyModel for the specified mutable data object.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDataModels | Returns the IDataModel collection for the requested object values. (Inherited from DataFactoryBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object. (Overrides DataFactoryBaseGetPropertyModels(Object, IDataFactoryRequest).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection. (Inherited from DataFactoryBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


TypeReflectionFactory Constructor

TypeReflectionFactory Constructor
Initializes a new instance of the TypeReflectionFactory class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TypeReflectionFactory()
Public Sub New
See Also

Reference

TypeReflectionFactory Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


TypeReflectionFactory Methods

TypeReflectionFactory Methods

The TypeReflectionFactory type exposes the following members.

Methods
 | Name | Description
Protected method | CategorizeDataModels | Returns a categorized variation of the specified data models collection. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryEditorModel | Creates an ICategoryEditorModel for the specified CategoryEditor. (Inherited from DataFactoryBase.)
Protected method | CreateCategoryModel | Creates an ICategoryModel for the specified category name. (Inherited from DataFactoryBase.)
Protected method | CreateCollectionPropertyModel | Creates an IPropertyModel for the specified collection data object.
Protected method | CreateMergedPropertyModel | Creates an IPropertyModel that merges a common property from multiple data objects. (Inherited from DataFactoryBase.)
Protected method | CreatePropertyModel | Creates an IPropertyModel for the specified mutable data object.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetDataModels | Returns the IDataModel collection for the requested object values. (Inherited from DataFactoryBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetPropertyModels | Returns the IPropertyModel collection for the specified data object. (Overrides DataFactoryBaseGetPropertyModels(Object, IDataFactoryRequest).)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | SortDataModels | Returns a sorted variation of the specified data models collection. (Inherited from DataFactoryBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TypeReflectionFactory Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


TypeReflectionFactory.CreateCollectionPropertyModel Method

TypeReflectionFactoryCreateCollectionPropertyModel Method
Creates an IPropertyModel for the specified collection data object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IPropertyModel CreateCollectionPropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor,
    IDataFactoryRequest request
)
Protected Overridable Function CreateCollectionPropertyModel (
    target As Object,
    propertyDescriptor As PropertyDescriptor,
    request As IDataFactoryRequest
) As IPropertyModel

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: PropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IPropertyModel
The IPropertyModel that was created.
See Also

Reference

TypeReflectionFactory Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


TypeReflectionFactory.CreatePropertyModel Method

TypeReflectionFactoryCreatePropertyModel Method
Creates an IPropertyModel for the specified mutable data object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual IPropertyModel CreatePropertyModel(
    Object target,
    PropertyDescriptor propertyDescriptor,
    IDataFactoryRequest request
)
Protected Overridable Function CreatePropertyModel (
    target As Object,
    propertyDescriptor As PropertyDescriptor,
    request As IDataFactoryRequest
) As IPropertyModel

Parameters

target
Type: SystemObject
The target object that owns the property.
propertyDescriptor
Type: PropertyDescriptor
The PropertyDescriptor for the property be accessed on the target.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IPropertyModel
The IPropertyModel that was created.
See Also

Reference

TypeReflectionFactory Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


TypeReflectionFactory.GetPropertyModels Method

TypeReflectionFactoryGetPropertyModels Method
Returns the IPropertyModel collection for the specified data object.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<IPropertyModel> GetPropertyModels(
    Object dataObject,
    IDataFactoryRequest request
)
Protected Overrides Function GetPropertyModels (
    dataObject As Object,
    request As IDataFactoryRequest
) As IList(Of IPropertyModel)

Parameters

dataObject
Type: SystemObject
The single object to examine.
request
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIDataFactoryRequest
An IDataFactoryRequest that contains data about the request.

Return Value

Type: IList IPropertyModel
A collection of IPropertyModel objects, if the specified data object has any properties.
See Also

Reference

TypeReflectionFactory Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyData Namespace


ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace
Contains the classes used for PropertyGrid property editors.
Classes
 | Class | Description
Public class | BooleanPropertyEditor | Represents a PropertyEditor for editing a Boolean value with a two-state CheckBox.
Public class | BrushPropertyEditor | Represents a PropertyEditor for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Public class | CategoryEditor | Provides information for an editor that can consume and display one or more properties in a property grid.
Public class | CategoryEditorCollection | Represents a collection of CategoryEditor objects.
Public class | CategoryEditorProperty | Provides information about a property to be consumed by a CategoryEditor.
Public class | CategoryEditorPropertyCollection | Represents a collection of CategoryEditorProperty objects.
Public class | ColorPropertyEditor | Represents a PropertyEditor for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Public class | DefaultValueTemplateKind | Specifies the kind of default PropertyGrid value cell template.
Public class | ExtendedStringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Public class | FontFamilyPropertyEditor | Represents a PropertyEditor for editing a FontFamily value with a ComboBox that contains system font families.
Public class | FontStretchPropertyEditor | Represents a PropertyEditor for editing a FontStretch value with a ComboBox that contains font stretch options.
Public class | FontStylePropertyEditor | Represents a PropertyEditor for editing a FontStyle value with a ComboBox that contains font style options.
Public class | FontWeightPropertyEditor | Represents a PropertyEditor for editing a FontWeight value with a ComboBox that contains font weight options.
Public class | LimitedObjectPropertyEditor | Represents a PropertyEditor for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Public class | LimitedStringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Public class | NullableBooleanPropertyEditor | Represents a PropertyEditor for editing a nullable Boolean with a three-state CheckBox.
Public class | PropertyEditor | Provides information used for displaying and manipulating a property value in a property grid.
Public class | PropertyEditorCollection | Represents a collection of PropertyEditor objects.
Public class | PropertyGridPropertyEditorsModifier | Represents a class that can optionally clear or append to the DefaultPropertyEditors collection from XAML, such as in Application.Resources.
Public class | StringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox.
Public class | SuggestedStringPropertyEditor | Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Interfaces
 | Interface | Description
Public interface | IPropertyEditorsProvider | Provides the base requirements for an object that has a collection of property editors.


BooleanPropertyEditor Class

BooleanPropertyEditor Class
Represents a PropertyEditor for editing a Boolean value with a two-state CheckBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsBooleanPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BooleanPropertyEditor : PropertyEditor
Public Class BooleanPropertyEditor
    Inherits PropertyEditor

The BooleanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanPropertyEditor | Initializes an instance of the BooleanPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Constructor

BooleanPropertyEditor Constructor
Initializes an instance of the BooleanPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BooleanPropertyEditor()
Public Sub New
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Properties

BooleanPropertyEditor Properties

The BooleanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Methods

BooleanPropertyEditor Methods

The BooleanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BooleanPropertyEditor Events

BooleanPropertyEditor Events

The BooleanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Class

BrushPropertyEditor Class
Represents a PropertyEditor for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsBrushPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class BrushPropertyEditor : PropertyEditor
Public Class BrushPropertyEditor
    Inherits PropertyEditor

The BrushPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BrushPropertyEditor | Initializes an instance of the BrushPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Constructor

BrushPropertyEditor Constructor
Initializes an instance of the BrushPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public BrushPropertyEditor()
Public Sub New
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Properties

BrushPropertyEditor Properties

The BrushPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Methods

BrushPropertyEditor Methods

The BrushPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


BrushPropertyEditor Events

BrushPropertyEditor Events

The BrushPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

BrushPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor Class

CategoryEditor Class
Provides information for an editor that can consume and display one or more properties in a property grid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CategoryEditor : ObservableObjectBase
Public Class CategoryEditor
    Inherits ObservableObjectBase

The CategoryEditor type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditor | Initializes a new instance of the CategoryEditor class
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the category associated with this editor.
Public property | Description | Gets or sets the description of the category editor, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets or sets the name to use when displaying the category editor.
Public property | EditorTemplate | Gets or sets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | Properties | Gets the properties that are consumed by this category editor.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor Constructor

CategoryEditor Constructor
Initializes a new instance of the CategoryEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditor()
Public Sub New
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor Properties

CategoryEditor Properties

The CategoryEditor type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the category associated with this editor.
Public property | Description | Gets or sets the description of the category editor, often displayed in a summary area or a tooltip.
Public property | DisplayName | Gets or sets the name to use when displaying the category editor.
Public property | EditorTemplate | Gets or sets the DataTemplate to use for editing the properties consumed by this editor.
Public property | EditorTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Public property | Properties | Gets the properties that are consumed by this category editor.
Top
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor.Category Property

CategoryEditorCategory Property
Gets or sets the category associated with this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String
The category associated with this editor.
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor.Description Property

CategoryEditorDescription Property
Gets or sets the description of the category editor, often displayed in a summary area or a tooltip.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description of the category editor, often displayed in a summary area or a tooltip.
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor.DisplayName Property

CategoryEditorDisplayName Property
Gets or sets the name to use when displaying the category editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
The name to use when displaying the category editor.
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor.EditorTemplate Property

CategoryEditorEditorTemplate Property
Gets or sets the DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate EditorTemplate { get; set; }
Public Property EditorTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor.EditorTemplateKey Property

CategoryEditorEditorTemplateKey Property
Gets or sets the resource key that references a DataTemplate to use for editing the properties consumed by this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object EditorTemplateKey { get; set; }
Public Property EditorTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the properties consumed by this editor.
Remarks
The priority order of editor template specification is EditorTemplate and then EditorTemplateKey.
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor.Properties Property

CategoryEditorProperties Property
Gets the properties that are consumed by this category editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorPropertyCollection Properties { get; }
Public ReadOnly Property Properties As CategoryEditorPropertyCollection
    Get

Property Value

Type: CategoryEditorPropertyCollection
The properties that are consumed by this category editor.
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor Methods

CategoryEditor Methods

The CategoryEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditor Events

CategoryEditor Events

The CategoryEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Class

CategoryEditorCollection Class
Represents a collection of CategoryEditor objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CategoryEditor
System.Collections.ObjectModelObservableCollection CategoryEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditorCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CategoryEditorCollection : ObservableCollection<CategoryEditor>
Public Class CategoryEditorCollection
    Inherits ObservableCollection(Of CategoryEditor)

The CategoryEditorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorCollection | Initializes a new instance of the CategoryEditorCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection CategoryEditor .)
Public property | Item | (Inherited from Collection CategoryEditor .)
Protected property | Items | (Inherited from Collection CategoryEditor .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection CategoryEditor .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection CategoryEditor .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection CategoryEditor .)
Public method | Clear | (Inherited from Collection CategoryEditor .)
Protected method | ClearItems | (Inherited from ObservableCollection CategoryEditor .)
Public method | Contains | (Inherited from Collection CategoryEditor .)
Public method | CopyTo | (Inherited from Collection CategoryEditor .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection CategoryEditor .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection CategoryEditor .)
Public method | Insert | (Inherited from Collection CategoryEditor .)
Protected method | InsertItem | (Inherited from ObservableCollection CategoryEditor .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection CategoryEditor .)
Protected method | MoveItem | (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection CategoryEditor .)
Public method | Remove | (Inherited from Collection CategoryEditor .)
Public method | RemoveAt | (Inherited from Collection CategoryEditor .)
Protected method | RemoveItem | (Inherited from ObservableCollection CategoryEditor .)
Protected method | SetItem | (Inherited from ObservableCollection CategoryEditor .)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection CategoryEditor .)
Protected event | PropertyChanged | (Inherited from ObservableCollection CategoryEditor .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Constructor

CategoryEditorCollection Constructor
Initializes a new instance of the CategoryEditorCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorCollection()
Public Sub New
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Properties

CategoryEditorCollection Properties

The CategoryEditorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection CategoryEditor .)
Public property | Item | (Inherited from Collection CategoryEditor .)
Protected property | Items | (Inherited from Collection CategoryEditor .)
Top
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Methods

CategoryEditorCollection Methods

The CategoryEditorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection CategoryEditor .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection CategoryEditor .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection CategoryEditor .)
Public method | Clear | (Inherited from Collection CategoryEditor .)
Protected method | ClearItems | (Inherited from ObservableCollection CategoryEditor .)
Public method | Contains | (Inherited from Collection CategoryEditor .)
Public method | CopyTo | (Inherited from Collection CategoryEditor .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection CategoryEditor .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection CategoryEditor .)
Public method | Insert | (Inherited from Collection CategoryEditor .)
Protected method | InsertItem | (Inherited from ObservableCollection CategoryEditor .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection CategoryEditor .)
Protected method | MoveItem | (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection CategoryEditor .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection CategoryEditor .)
Public method | Remove | (Inherited from Collection CategoryEditor .)
Public method | RemoveAt | (Inherited from Collection CategoryEditor .)
Protected method | RemoveItem | (Inherited from ObservableCollection CategoryEditor .)
Protected method | SetItem | (Inherited from ObservableCollection CategoryEditor .)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorCollection Events

CategoryEditorCollection Events

The CategoryEditorCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection CategoryEditor .)
Protected event | PropertyChanged | (Inherited from ObservableCollection CategoryEditor .)
Top
See Also

Reference

CategoryEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Class

CategoryEditorProperty Class
Provides information about a property to be consumed by a CategoryEditor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditorProperty

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CategoryEditorProperty : ObservableObjectBase
Public Class CategoryEditorProperty
    Inherits ObservableObjectBase

The CategoryEditorProperty type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorProperty | Initializes a new instance of the CategoryEditorProperty class
Top
Properties
 | Name | Description
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Constructor

CategoryEditorProperty Constructor
Initializes a new instance of the CategoryEditorProperty class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorProperty()
Public Sub New
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Properties

CategoryEditorProperty Properties

The CategoryEditorProperty type exposes the following members.

Properties
 | Name | Description
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Top
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty.ObjectType Property

CategoryEditorPropertyObjectType Property
Gets or sets the type of the data object that contains the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type ObjectType { get; set; }
Public Property ObjectType As Type
    Get
    Set

Property Value

Type: Type
The type of the data object that contains the property.
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty.PropertyName Property

CategoryEditorPropertyPropertyName Property
Gets or sets the name of the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string PropertyName { get; set; }
Public Property PropertyName As String
    Get
    Set

Property Value

Type: String
The name of the property.
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty.PropertyType Property

CategoryEditorPropertyPropertyType Property
Gets or sets the type of the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type PropertyType { get; set; }
Public Property PropertyType As Type
    Get
    Set

Property Value

Type: Type
The type of the property.
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Methods

CategoryEditorProperty Methods

The CategoryEditorProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorProperty Events

CategoryEditorProperty Events

The CategoryEditorProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

CategoryEditorProperty Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Class

CategoryEditorPropertyCollection Class
Represents a collection of CategoryEditorProperty objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection CategoryEditorProperty
System.Collections.ObjectModelObservableCollection CategoryEditorProperty
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsCategoryEditorPropertyCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CategoryEditorPropertyCollection : ObservableCollection<CategoryEditorProperty>
Public Class CategoryEditorPropertyCollection
    Inherits ObservableCollection(Of CategoryEditorProperty)

The CategoryEditorPropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryEditorPropertyCollection | Initializes a new instance of the CategoryEditorPropertyCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection CategoryEditorProperty .)
Public property | Item | (Inherited from Collection CategoryEditorProperty .)
Protected property | Items | (Inherited from Collection CategoryEditorProperty .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection CategoryEditorProperty .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Clear | (Inherited from Collection CategoryEditorProperty .)
Protected method | ClearItems | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Contains | (Inherited from Collection CategoryEditorProperty .)
Public method | CopyTo | (Inherited from Collection CategoryEditorProperty .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection CategoryEditorProperty .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection CategoryEditorProperty .)
Public method | Insert | (Inherited from Collection CategoryEditorProperty .)
Protected method | InsertItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | MoveItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Remove | (Inherited from Collection CategoryEditorProperty .)
Public method | RemoveAt | (Inherited from Collection CategoryEditorProperty .)
Protected method | RemoveItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | SetItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected event | PropertyChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Constructor

CategoryEditorPropertyCollection Constructor
Initializes a new instance of the CategoryEditorPropertyCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CategoryEditorPropertyCollection()
Public Sub New
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Properties

CategoryEditorPropertyCollection Properties

The CategoryEditorPropertyCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection CategoryEditorProperty .)
Public property | Item | (Inherited from Collection CategoryEditorProperty .)
Protected property | Items | (Inherited from Collection CategoryEditorProperty .)
Top
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Methods

CategoryEditorPropertyCollection Methods

The CategoryEditorPropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection CategoryEditorProperty .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Clear | (Inherited from Collection CategoryEditorProperty .)
Protected method | ClearItems | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Contains | (Inherited from Collection CategoryEditorProperty .)
Public method | CopyTo | (Inherited from Collection CategoryEditorProperty .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection CategoryEditorProperty .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection CategoryEditorProperty .)
Public method | Insert | (Inherited from Collection CategoryEditorProperty .)
Protected method | InsertItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | MoveItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | Remove | (Inherited from Collection CategoryEditorProperty .)
Public method | RemoveAt | (Inherited from Collection CategoryEditorProperty .)
Protected method | RemoveItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected method | SetItem | (Inherited from ObservableCollection CategoryEditorProperty .)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


CategoryEditorPropertyCollection Events

CategoryEditorPropertyCollection Events

The CategoryEditorPropertyCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Protected event | PropertyChanged | (Inherited from ObservableCollection CategoryEditorProperty .)
Top
See Also

Reference

CategoryEditorPropertyCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Class

ColorPropertyEditor Class
Represents a PropertyEditor for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsColorPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ColorPropertyEditor : PropertyEditor
Public Class ColorPropertyEditor
    Inherits PropertyEditor

The ColorPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ColorPropertyEditor | Initializes an instance of the ColorPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Constructor

ColorPropertyEditor Constructor
Initializes an instance of the ColorPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ColorPropertyEditor()
Public Sub New
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Properties

ColorPropertyEditor Properties

The ColorPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Methods

ColorPropertyEditor Methods

The ColorPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ColorPropertyEditor Events

ColorPropertyEditor Events

The ColorPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ColorPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind Class

DefaultValueTemplateKind Class
Specifies the kind of default PropertyGrid value cell template.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsDefaultValueTemplateKind

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class DefaultValueTemplateKind : Enum
Public NotInheritable Class DefaultValueTemplateKind
    Inherits Enum

The DefaultValueTemplateKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Boolean | A template for editing a Boolean value with a two-state CheckBox.
 | Brush | A template for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
 | Color | A template for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
 | ExtendedString | A template for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
 | FontFamily | A template for editing a FontFamily value with a ComboBox that contains system font families.
 | FontStretch | A template for editing a FontStretch value with a ComboBox that contains font stretch options.
 | FontStyle | A template for editing a FontStyle value with a ComboBox that contains font style options.
 | FontWeight | A template for editing a FontWeight value with a ComboBox that contains font weight options.
 | LimitedObject | A template for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
 | LimitedString | A template for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
 | None | No template is specified.
 | NullableBoolean | A template for editing a nullable Boolean with a three-state CheckBox.
 | String | A template for editing a String value (or Object value via ValueAsString) with a TextBox.
 | SuggestedString | A template for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind Methods

DefaultValueTemplateKind Methods

The DefaultValueTemplateKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind Fields

DefaultValueTemplateKind Fields

The DefaultValueTemplateKind type exposes the following members.

Fields
 | Name | Description
 | Boolean | A template for editing a Boolean value with a two-state CheckBox.
 | Brush | A template for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.
 | Color | A template for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.
 | ExtendedString | A template for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
 | FontFamily | A template for editing a FontFamily value with a ComboBox that contains system font families.
 | FontStretch | A template for editing a FontStretch value with a ComboBox that contains font stretch options.
 | FontStyle | A template for editing a FontStyle value with a ComboBox that contains font style options.
 | FontWeight | A template for editing a FontWeight value with a ComboBox that contains font weight options.
 | LimitedObject | A template for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
 | LimitedString | A template for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
 | None | No template is specified.
 | NullableBoolean | A template for editing a nullable Boolean with a three-state CheckBox.
 | String | A template for editing a String value (or Object value via ValueAsString) with a TextBox.
 | SuggestedString | A template for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Public field | value__ |
Top
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.Boolean Field

DefaultValueTemplateKindBoolean Field
A template for editing a Boolean value with a two-state CheckBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind Boolean = 1
Public Const Boolean As DefaultValueTemplateKind = 1

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.Brush Field

DefaultValueTemplateKindBrush Field
A template for editing a Brush value with a swatch that renders the value, and a TextBox for editing the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind Brush = 2
Public Const Brush As DefaultValueTemplateKind = 2

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.Color Field

DefaultValueTemplateKindColor Field
A template for editing a Color value with a swatch that renders the value, and a TextBox for editing the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind Color = 3
Public Const Color As DefaultValueTemplateKind = 3

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.ExtendedString Field

DefaultValueTemplateKindExtendedString Field
A template for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind ExtendedString = 4
Public Const ExtendedString As DefaultValueTemplateKind = 4

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.FontFamily Field

DefaultValueTemplateKindFontFamily Field
A template for editing a FontFamily value with a ComboBox that contains system font families.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind FontFamily = 5
Public Const FontFamily As DefaultValueTemplateKind = 5

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.FontStretch Field

DefaultValueTemplateKindFontStretch Field
A template for editing a FontStretch value with a ComboBox that contains font stretch options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind FontStretch = 6
Public Const FontStretch As DefaultValueTemplateKind = 6

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.FontStyle Field

DefaultValueTemplateKindFontStyle Field
A template for editing a FontStyle value with a ComboBox that contains font style options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind FontStyle = 7
Public Const FontStyle As DefaultValueTemplateKind = 7

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.FontWeight Field

DefaultValueTemplateKindFontWeight Field
A template for editing a FontWeight value with a ComboBox that contains font weight options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind FontWeight = 8
Public Const FontWeight As DefaultValueTemplateKind = 8

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.LimitedObject Field

DefaultValueTemplateKindLimitedObject Field
A template for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind LimitedObject = 9
Public Const LimitedObject As DefaultValueTemplateKind = 9

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.LimitedString Field

DefaultValueTemplateKindLimitedString Field
A template for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind LimitedString = 10
Public Const LimitedString As DefaultValueTemplateKind = 10

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.None Field

DefaultValueTemplateKindNone Field
No template is specified.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind None = 0
Public Const None As DefaultValueTemplateKind = 0

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.NullableBoolean Field

DefaultValueTemplateKindNullableBoolean Field
A template for editing a nullable Boolean with a three-state CheckBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind NullableBoolean = 11
Public Const NullableBoolean As DefaultValueTemplateKind = 11

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.String Field

DefaultValueTemplateKindString Field
A template for editing a String value (or Object value via ValueAsString) with a TextBox.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind String = 12
Public Const String As DefaultValueTemplateKind = 12

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.SuggestedString Field

DefaultValueTemplateKindSuggestedString Field
A template for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const DefaultValueTemplateKind SuggestedString = 13
Public Const SuggestedString As DefaultValueTemplateKind = 13

Field Value

Type: DefaultValueTemplateKind
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


DefaultValueTemplateKind.value__ Field

DefaultValueTemplateKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors.DefaultValueTemplateKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

DefaultValueTemplateKind Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Class

ExtendedStringPropertyEditor Class
Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox and ... (ellipses) button.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsExtendedStringPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class ExtendedStringPropertyEditor : PropertyEditor
Public Class ExtendedStringPropertyEditor
    Inherits PropertyEditor

The ExtendedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedStringPropertyEditor | Initializes an instance of the ExtendedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | ButtonCommand | Gets or sets the ICommand to use on the button in the template.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Constructor

ExtendedStringPropertyEditor Constructor
Initializes an instance of the ExtendedStringPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ExtendedStringPropertyEditor()
Public Sub New
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Properties

ExtendedStringPropertyEditor Properties

The ExtendedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | ButtonCommand | Gets or sets the ICommand to use on the button in the template.
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor.ButtonCommand Property

ExtendedStringPropertyEditorButtonCommand Property
Gets or sets the ICommand to use on the button in the template.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand ButtonCommand { get; set; }
Public Property ButtonCommand As ICommand
    Get
    Set

Property Value

Type: ICommand
The ICommand to use on the button in the template.
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Methods

ExtendedStringPropertyEditor Methods

The ExtendedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ExtendedStringPropertyEditor Events

ExtendedStringPropertyEditor Events

The ExtendedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ExtendedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Class

FontFamilyPropertyEditor Class
Represents a PropertyEditor for editing a FontFamily value with a ComboBox that contains system font families.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontFamilyPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FontFamilyPropertyEditor : PropertyEditor
Public Class FontFamilyPropertyEditor
    Inherits PropertyEditor

The FontFamilyPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontFamilyPropertyEditor | Initializes an instance of the FontFamilyPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Constructor

FontFamilyPropertyEditor Constructor
Initializes an instance of the FontFamilyPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontFamilyPropertyEditor()
Public Sub New
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Properties

FontFamilyPropertyEditor Properties

The FontFamilyPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Methods

FontFamilyPropertyEditor Methods

The FontFamilyPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontFamilyPropertyEditor Events

FontFamilyPropertyEditor Events

The FontFamilyPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontFamilyPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Class

FontStretchPropertyEditor Class
Represents a PropertyEditor for editing a FontStretch value with a ComboBox that contains font stretch options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontStretchPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FontStretchPropertyEditor : PropertyEditor
Public Class FontStretchPropertyEditor
    Inherits PropertyEditor

The FontStretchPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontStretchPropertyEditor | Initializes an instance of the FontStretchPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Constructor

FontStretchPropertyEditor Constructor
Initializes an instance of the FontStretchPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontStretchPropertyEditor()
Public Sub New
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Properties

FontStretchPropertyEditor Properties

The FontStretchPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Methods

FontStretchPropertyEditor Methods

The FontStretchPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStretchPropertyEditor Events

FontStretchPropertyEditor Events

The FontStretchPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontStretchPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Class

FontStylePropertyEditor Class
Represents a PropertyEditor for editing a FontStyle value with a ComboBox that contains font style options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontStylePropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FontStylePropertyEditor : PropertyEditor
Public Class FontStylePropertyEditor
    Inherits PropertyEditor

The FontStylePropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontStylePropertyEditor | Initializes an instance of the FontStylePropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Constructor

FontStylePropertyEditor Constructor
Initializes an instance of the FontStylePropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontStylePropertyEditor()
Public Sub New
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Properties

FontStylePropertyEditor Properties

The FontStylePropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Methods

FontStylePropertyEditor Methods

The FontStylePropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontStylePropertyEditor Events

FontStylePropertyEditor Events

The FontStylePropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontStylePropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Class

FontWeightPropertyEditor Class
Represents a PropertyEditor for editing a FontWeight value with a ComboBox that contains font weight options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontWeightPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class FontWeightPropertyEditor : PropertyEditor
Public Class FontWeightPropertyEditor
    Inherits PropertyEditor

The FontWeightPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FontWeightPropertyEditor | Initializes an instance of the FontWeightPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Constructor

FontWeightPropertyEditor Constructor
Initializes an instance of the FontWeightPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontWeightPropertyEditor()
Public Sub New
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Properties

FontWeightPropertyEditor Properties

The FontWeightPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Methods

FontWeightPropertyEditor Methods

The FontWeightPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


FontWeightPropertyEditor Events

FontWeightPropertyEditor Events

The FontWeightPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

FontWeightPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


IPropertyEditorsProvider Interface

IPropertyEditorsProvider Interface
Provides the base requirements for an object that has a collection of property editors.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPropertyEditorsProvider
Public Interface IPropertyEditorsProvider

The IPropertyEditorsProvider type exposes the following members.

Properties
 | Name | Description
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


IPropertyEditorsProvider Properties

IPropertyEditorsProvider Properties

The IPropertyEditorsProvider type exposes the following members.

Properties
 | Name | Description
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
See Also

Reference

IPropertyEditorsProvider Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


IPropertyEditorsProvider.PropertyEditors Property

IPropertyEditorsProviderPropertyEditors Property
Gets the property editors to append to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PropertyEditorCollection PropertyEditors { get; }
ReadOnly Property PropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The property editors to append to the collection.
See Also

Reference

IPropertyEditorsProvider Interface
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Class

LimitedObjectPropertyEditor Class
Represents a PropertyEditor for editing an Object value with a non-editable ComboBox (drop-down only) that contains suggested options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsLimitedObjectPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LimitedObjectPropertyEditor : PropertyEditor
Public Class LimitedObjectPropertyEditor
    Inherits PropertyEditor

The LimitedObjectPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | LimitedObjectPropertyEditor | Initializes an instance of the LimitedObjectPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Constructor

LimitedObjectPropertyEditor Constructor
Initializes an instance of the LimitedObjectPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LimitedObjectPropertyEditor()
Public Sub New
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Properties

LimitedObjectPropertyEditor Properties

The LimitedObjectPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Methods

LimitedObjectPropertyEditor Methods

The LimitedObjectPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedObjectPropertyEditor Events

LimitedObjectPropertyEditor Events

The LimitedObjectPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LimitedObjectPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Class

LimitedStringPropertyEditor Class
Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a non-editable ComboBox (drop-down only) that contains suggested options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsLimitedStringPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class LimitedStringPropertyEditor : PropertyEditor
Public Class LimitedStringPropertyEditor
    Inherits PropertyEditor

The LimitedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | LimitedStringPropertyEditor | Initializes an instance of the LimitedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Constructor

LimitedStringPropertyEditor Constructor
Initializes an instance of the LimitedStringPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public LimitedStringPropertyEditor()
Public Sub New
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Properties

LimitedStringPropertyEditor Properties

The LimitedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Methods

LimitedStringPropertyEditor Methods

The LimitedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


LimitedStringPropertyEditor Events

LimitedStringPropertyEditor Events

The LimitedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

LimitedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Class

NullableBooleanPropertyEditor Class
Represents a PropertyEditor for editing a nullable Boolean with a three-state CheckBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsNullableBooleanPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class NullableBooleanPropertyEditor : PropertyEditor
Public Class NullableBooleanPropertyEditor
    Inherits PropertyEditor

The NullableBooleanPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NullableBooleanPropertyEditor | Initializes an instance of the NullableBooleanPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Constructor

NullableBooleanPropertyEditor Constructor
Initializes an instance of the NullableBooleanPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public NullableBooleanPropertyEditor()
Public Sub New
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Properties

NullableBooleanPropertyEditor Properties

The NullableBooleanPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Methods

NullableBooleanPropertyEditor Methods

The NullableBooleanPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


NullableBooleanPropertyEditor Events

NullableBooleanPropertyEditor Events

The NullableBooleanPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

NullableBooleanPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor Class

PropertyEditor Class
Provides information used for displaying and manipulating a property value in a property grid.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
More...

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyEditor : ObservableObjectBase
Public Class PropertyEditor
    Inherits ObservableObjectBase

The PropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditor | Initializes a new instance of the PropertyEditor class
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Editors.Interop.Grids.PropertyEditors.PrimitivesPropertyEditorBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsBooleanPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsBrushPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsColorPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsExtendedStringPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontFamilyPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontStretchPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontStylePropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsFontWeightPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsLimitedObjectPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsLimitedStringPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsNullableBooleanPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsStringPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsSuggestedStringPropertyEditor


PropertyEditor Constructor

PropertyEditor Constructor
Initializes a new instance of the PropertyEditor class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor()
Public Sub New
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor Properties

PropertyEditor Properties

The PropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name.
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name.
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name.
Public property | ObjectType | Gets or sets the type of the data object that contains the property.
Public property | PropertyName | Gets or sets the name of the property.
Public property | PropertyType | Gets or sets the type of the property.
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value.
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value.
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value.
Top
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.NameTemplate Property

PropertyEditorNameTemplate Property
Gets or sets the DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplate NameTemplate { get; set; }
Public Overridable Property NameTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for showing the property display name.
Remarks
The priority order of name template specification is NameTemplate, NameTemplateSelector, and finally NameTemplateKey.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.NameTemplateKey Property

PropertyEditorNameTemplateKey Property
Gets or sets the resource key that references a DataTemplate to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object NameTemplateKey { get; set; }
Public Overridable Property NameTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for showing the property display name.
Remarks
The priority order of name template specification is NameTemplate, NameTemplateSelector, and finally NameTemplateKey.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.NameTemplateSelector Property

PropertyEditorNameTemplateSelector Property
Gets or sets the DataTemplateSelector to use for showing the property display name.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector NameTemplateSelector { get; set; }
Public Overridable Property NameTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for showing the property display name.
Remarks
The priority order of name template specification is NameTemplate, NameTemplateSelector, and finally NameTemplateKey.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ObjectType Property

PropertyEditorObjectType Property
Gets or sets the type of the data object that contains the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type ObjectType { get; set; }
Public Property ObjectType As Type
    Get
    Set

Property Value

Type: Type
The type of the data object that contains the property.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.PropertyName Property

PropertyEditorPropertyName Property
Gets or sets the name of the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string PropertyName { get; set; }
Public Property PropertyName As String
    Get
    Set

Property Value

Type: String
The name of the property.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.PropertyType Property

PropertyEditorPropertyType Property
Gets or sets the type of the property.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type PropertyType { get; set; }
Public Property PropertyType As Type
    Get
    Set

Property Value

Type: Type
The type of the property.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplate Property

PropertyEditorValueTemplate Property
Gets or sets the DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplate ValueTemplate { get; set; }
Public Overridable Property ValueTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplateKey Property

PropertyEditorValueTemplateKey Property
Gets or sets the resource key that references a DataTemplate to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Object ValueTemplateKey { get; set; }
Public Overridable Property ValueTemplateKey As Object
    Get
    Set

Property Value

Type: Object
The resource key that references a DataTemplate to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplateKind Property

PropertyEditorValueTemplateKind Property
Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DefaultValueTemplateKind ValueTemplateKind { get; set; }
Public Overridable Property ValueTemplateKind As DefaultValueTemplateKind
    Get
    Set

Property Value

Type: DefaultValueTemplateKind
The DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.ValueTemplateSelector Property

PropertyEditorValueTemplateSelector Property
Gets or sets the DataTemplateSelector to use for editing the property value.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual DataTemplateSelector ValueTemplateSelector { get; set; }
Public Overridable Property ValueTemplateSelector As DataTemplateSelector
    Get
    Set

Property Value

Type: DataTemplateSelector
The DataTemplateSelector to use for editing the property value.
Remarks
The priority order of value template specification is ValueTemplate, ValueTemplateSelector, ValueTemplateKey, and finally ValueTemplateKind.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor Methods

PropertyEditor Methods

The PropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor.GetIsReadOnly Method

PropertyEditorGetIsReadOnly Method
Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Nullable<bool> GetIsReadOnly(
    IPropertyModel propertyModel
)
Protected Overridable Function GetIsReadOnly (
    propertyModel As IPropertyModel
) As Nullable(Of Boolean)

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: Nullable Boolean
true if the property model should be read-only. false if the property model should not be read-only. to allow default logic for determining read-only state to execute.
Remarks
Do not call IsReadOnly from within this method, since the getter for that property calls into this method as part of its default logic.
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditor Events

PropertyEditor Events

The PropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

PropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Class

PropertyEditorCollection Class
Represents a collection of PropertyEditor objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection PropertyEditor
System.Collections.ObjectModelObservableCollection PropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditorCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyEditorCollection : ObservableCollection<PropertyEditor>
Public Class PropertyEditorCollection
    Inherits ObservableCollection(Of PropertyEditor)

The PropertyEditorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditorCollection | Initializes a new instance of the PropertyEditorCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection PropertyEditor .)
Public property | Item | (Inherited from Collection PropertyEditor .)
Protected property | Items | (Inherited from Collection PropertyEditor .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection PropertyEditor .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection PropertyEditor .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection PropertyEditor .)
Public method | Clear | (Inherited from Collection PropertyEditor .)
Protected method | ClearItems | (Inherited from ObservableCollection PropertyEditor .)
Public method | Contains | (Inherited from Collection PropertyEditor .)
Public method | CopyTo | (Inherited from Collection PropertyEditor .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection PropertyEditor .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNameEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's name cell template.
Public method | GetType | (Inherited from Object.)
Public method | GetValueEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's value cell template.
Public method | IndexOf | (Inherited from Collection PropertyEditor .)
Public method | Insert | (Inherited from Collection PropertyEditor .)
Protected method | InsertItem | (Inherited from ObservableCollection PropertyEditor .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection PropertyEditor .)
Protected method | MoveItem | (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection PropertyEditor .)
Public method | Remove | (Inherited from Collection PropertyEditor .)
Public method | RemoveAt | (Inherited from Collection PropertyEditor .)
Protected method | RemoveItem | (Inherited from ObservableCollection PropertyEditor .)
Protected method | SetItem | (Inherited from ObservableCollection PropertyEditor .)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection PropertyEditor .)
Protected event | PropertyChanged | (Inherited from ObservableCollection PropertyEditor .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Constructor

PropertyEditorCollection Constructor
Initializes a new instance of the PropertyEditorCollection class

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditorCollection()
Public Sub New
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Properties

PropertyEditorCollection Properties

The PropertyEditorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection PropertyEditor .)
Public property | Item | (Inherited from Collection PropertyEditor .)
Protected property | Items | (Inherited from Collection PropertyEditor .)
Top
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Methods

PropertyEditorCollection Methods

The PropertyEditorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection PropertyEditor .)
Protected method | BlockReentrancy | (Inherited from ObservableCollection PropertyEditor .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection PropertyEditor .)
Public method | Clear | (Inherited from Collection PropertyEditor .)
Protected method | ClearItems | (Inherited from ObservableCollection PropertyEditor .)
Public method | Contains | (Inherited from Collection PropertyEditor .)
Public method | CopyTo | (Inherited from Collection PropertyEditor .)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection PropertyEditor .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetNameEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's name cell template.
Public method | GetType | (Inherited from Object.)
Public method | GetValueEditor | Returns the best PropertyEditor match for selecting a IPropertyModel's value cell template.
Public method | IndexOf | (Inherited from Collection PropertyEditor .)
Public method | Insert | (Inherited from Collection PropertyEditor .)
Protected method | InsertItem | (Inherited from ObservableCollection PropertyEditor .)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection PropertyEditor .)
Protected method | MoveItem | (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnCollectionChanged | (Inherited from ObservableCollection PropertyEditor .)
Protected method | OnPropertyChanged | (Inherited from ObservableCollection PropertyEditor .)
Public method | Remove | (Inherited from Collection PropertyEditor .)
Public method | RemoveAt | (Inherited from Collection PropertyEditor .)
Protected method | RemoveItem | (Inherited from ObservableCollection PropertyEditor .)
Protected method | SetItem | (Inherited from ObservableCollection PropertyEditor .)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection.GetNameEditor Method

PropertyEditorCollectionGetNameEditor Method
Returns the best PropertyEditor match for selecting a IPropertyModel's name cell template.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor GetNameEditor(
    IPropertyModel propertyModel
)
Public Function GetNameEditor (
    propertyModel As IPropertyModel
) As PropertyEditor

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: PropertyEditor
The best PropertyEditor match for selecting a IPropertyModel's name cell template.
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection.GetValueEditor Method

PropertyEditorCollectionGetValueEditor Method
Returns the best PropertyEditor match for selecting a IPropertyModel's value cell template.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditor GetValueEditor(
    IPropertyModel propertyModel
)
Public Function GetValueEditor (
    propertyModel As IPropertyModel
) As PropertyEditor

Parameters

propertyModel
Type: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyDataIPropertyModel
The IPropertyModel to examine.

Return Value

Type: PropertyEditor
The best PropertyEditor match for selecting a IPropertyModel's value cell template.
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyEditorCollection Events

PropertyEditorCollection Events

The PropertyEditorCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection PropertyEditor .)
Protected event | PropertyChanged | (Inherited from ObservableCollection PropertyEditor .)
Top
See Also

Reference

PropertyEditorCollection Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Class

PropertyGridPropertyEditorsModifier Class
Represents a class that can optionally clear or append to the DefaultPropertyEditors collection from XAML, such as in Application.Resources.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyGridPropertyEditorsModifier

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PropertyGridPropertyEditorsModifier : DependencyObject,
    IPropertyEditorsProvider
Public Class PropertyGridPropertyEditorsModifier
    Inherits DependencyObject
    Implements IPropertyEditorsProvider

The PropertyGridPropertyEditorsModifier type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridPropertyEditorsModifier | Initializes an instance of the PropertyGridPropertyEditorsModifier class.
Top
Properties
 | Name | Description
Public property | Clear | Gets or sets whether to clear the collection before appending anything.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
Fields
Name | Description
ClearProperty | Identifies the Clear dependency property. This field is read-only.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Constructor

PropertyGridPropertyEditorsModifier Constructor
Initializes an instance of the PropertyGridPropertyEditorsModifier class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyGridPropertyEditorsModifier()
Public Sub New
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Properties

PropertyGridPropertyEditorsModifier Properties

The PropertyGridPropertyEditorsModifier type exposes the following members.

Properties
 | Name | Description
Public property | Clear | Gets or sets whether to clear the collection before appending anything.
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | PropertyEditors | Gets the property editors to append to the collection.
Top
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier.Clear Property

PropertyGridPropertyEditorsModifierClear Property
Gets or sets whether to clear the collection before appending anything.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Clear { get; set; }
Public Property Clear As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the collection should be cleared before appending anything; otherwise, false.
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier.PropertyEditors Property

PropertyGridPropertyEditorsModifierPropertyEditors Property
Gets the property editors to append to the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PropertyEditorCollection PropertyEditors { get; }
Public ReadOnly Property PropertyEditors As PropertyEditorCollection
    Get

Property Value

Type: PropertyEditorCollection
The property editors to append to the collection.

Implements

IPropertyEditorsProviderPropertyEditors
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Methods

PropertyGridPropertyEditorsModifier Methods

The PropertyGridPropertyEditorsModifier type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier Fields

PropertyGridPropertyEditorsModifier Fields

The PropertyGridPropertyEditorsModifier type exposes the following members.

Fields
Name | Description
ClearProperty | Identifies the Clear dependency property. This field is read-only.
Top
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


PropertyGridPropertyEditorsModifier.ClearProperty Field

PropertyGridPropertyEditorsModifierClearProperty Field
Identifies the Clear dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ClearProperty
Public Shared ReadOnly ClearProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Clear dependency property.
See Also

Reference

PropertyGridPropertyEditorsModifier Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Class

StringPropertyEditor Class
Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with a TextBox.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsStringPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class StringPropertyEditor : PropertyEditor
Public Class StringPropertyEditor
    Inherits PropertyEditor

The StringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | StringPropertyEditor | Initializes an instance of the StringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Constructor

StringPropertyEditor Constructor
Initializes an instance of the StringPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public StringPropertyEditor()
Public Sub New
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Properties

StringPropertyEditor Properties

The StringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Methods

StringPropertyEditor Methods

The StringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


StringPropertyEditor Events

StringPropertyEditor Events

The StringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

StringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Class

SuggestedStringPropertyEditor Class
Represents a PropertyEditor for editing a String value (or Object value via ValueAsString) with an editable ComboBox that contains suggested options.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsPropertyEditor
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditorsSuggestedStringPropertyEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SuggestedStringPropertyEditor : PropertyEditor
Public Class SuggestedStringPropertyEditor
    Inherits PropertyEditor

The SuggestedStringPropertyEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SuggestedStringPropertyEditor | Initializes an instance of the SuggestedStringPropertyEditor class.
Top
Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Constructor

SuggestedStringPropertyEditor Constructor
Initializes an instance of the SuggestedStringPropertyEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors
Assembly: AS.Grids.Universal (in AS.Grids.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SuggestedStringPropertyEditor()
Public Sub New
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Properties

SuggestedStringPropertyEditor Properties

The SuggestedStringPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | NameTemplate | Gets or sets the DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateKey | Gets or sets the resource key that references a DataTemplate to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | Gets or sets the DataTemplateSelector to use for showing the property display name. (Inherited from PropertyEditor.)
Public property | ObjectType | Gets or sets the type of the data object that contains the property. (Inherited from PropertyEditor.)
Public property | PropertyName | Gets or sets the name of the property. (Inherited from PropertyEditor.)
Public property | PropertyType | Gets or sets the type of the property. (Inherited from PropertyEditor.)
Public property | ValueTemplate | Gets or sets the DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKey | Gets or sets the resource key that references a DataTemplate to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateKind | Gets or sets the DefaultValueTemplateKind that specifies a default value cell template to use for editing the property value. (Inherited from PropertyEditor.)
Public property | ValueTemplateSelector | Gets or sets the DataTemplateSelector to use for editing the property value. (Inherited from PropertyEditor.)
Top
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Methods

SuggestedStringPropertyEditor Methods

The SuggestedStringPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetIsReadOnly | Returns whether the specified IPropertyModel should be optionally forced read-only or not, directly affecting the IsReadOnly result. (Inherited from PropertyEditor.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


SuggestedStringPropertyEditor Events

SuggestedStringPropertyEditor Events

The SuggestedStringPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

SuggestedStringPropertyEditor Class
ActiproSoftware.UI.Xaml.Controls.Grids.PropertyEditors Namespace


ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace
Contains classes that support implementing micro chart controls.
Classes
 | Class | Description
Public class | MicroAggregationKind | Specifies the various kinds of built-in aggregation functions.
Public class | MicroAreaSeries | Represents an area series for use in a MicroXYChart.
Public class | MicroAreaSeriesStyleKinds | Specifies the various alternate styles that can be used when rendering an area.
Public class | MicroBarSeries | Represents a bar series for use in a MicroXYChart.
Public class | MicroBarSeriesStyleKinds | Specifies the various alternate styles that can be used when rendering a bar.
Public class | MicroBoxPlot | Represents a box plot control.
Public class | MicroBulletGraph | Represents a bullet graph control that has a primary featured measure and optionally compares that measure to another measure to enrich its meaning, while also displaying this information in the context of qualitative ranges of performance (poor, satisfactory, good, etc.).
Public class | MicroCandlestickChart | Represents a candlestick chart control.
Public class | MicroChartMarker | Represents a control capable of rendering predefined shapes.
Public class | MicroChartMarkerShapeKind | Specifies the various predefined shapes supported by MicroChartMarker.
Public class | MicroChartMarkerStyleKinds | Specifies the various alternate styles that can be used when rendering a MicroChartMarker.
Public class | MicroChartMarkerVisibility | Specifies the visibility of the various kinds of MicroChartMarker.
Public class | MicroHeatMapPresenter | Represents a HeatMap element.
Public class | MicroLineSeries | Represents a line series for use in a MicroXYChart.
Public class | MicroLineSeriesStyleKinds | Specifies the various alternate styles that can be used when rendering a line.
Public class | MicroLineSeriesVisibility | Specifies the visibility of the various kinds of a line.
Public class | MicroQualitativeRange | Represents a qualitative range element for use within a MicroBulletGraph.
Public class | MicroQualitativeRangeCollection | Represents a collection of MicroQualitativeRange objects.
Public class | MicroScatterSeries | Represents a scatter series for use in a MicroXYChart.
Public class | MicroSegmentChart | Represents a segment chart control.
Public class | MicroSegmentChartItem | Represents a segment chart item.
Public class | MicroSeriesStyleSelector | Provides a way to apply series styles based on custom logic.
Public class | MicroTrendIndicator | Represents a trend indicator.
Public class | MicroWinLossSeries | Represents a win/loss series for use in a MicroXYChart.
Public class | MicroXYChart | Represents a micro chart control that uses an X/Y coordinate system.
Public class | MicroXYDataPoint | Represents a data point presented by a a MicroXYSeriesBase series.
Public class | MicroXYDataPointCollectionView | Represents a collection view that generates MicroXYDataPoint from a specified source collection.
Public class | MicroXYRange | Represents a range for use in a MicroXYChart.
Public class | MicroXYRangeCollection | Represents a collection of MicroXYRange objects.
Public class | MicroXYSeriesCollection | Represents a collection of MicroXYSeriesBase objects.
Public class | MicroXYSeriesLineKind | Specifies the line kinds supported by a MicroLineSeries and MicroAreaSeries series.
Public class | MicroXYSeriesStackKind | Specifies the stacking methods supported by a MicroXYSeriesBase series.


MicroAggregationKind Class

MicroAggregationKind Class
Specifies the various kinds of built-in aggregation functions.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroAggregationKind

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroAggregationKind : Enum
Public NotInheritable Class MicroAggregationKind
    Inherits Enum

The MicroAggregationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Average | Indicates that the values will be averaged together.
 | First | Indicates that the first value will be used.
 | Last | Indicates that the last value will be used.
 | Maximum | Indicates that the maximum value will be used.
 | Minimum | Indicates that the minimum value will be used.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind Methods

MicroAggregationKind Methods

The MicroAggregationKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind Fields

MicroAggregationKind Fields

The MicroAggregationKind type exposes the following members.

Fields
 | Name | Description
 | Average | Indicates that the values will be averaged together.
 | First | Indicates that the first value will be used.
 | Last | Indicates that the last value will be used.
 | Maximum | Indicates that the maximum value will be used.
 | Minimum | Indicates that the minimum value will be used.
Public field | value__ |
Top
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind.Average Field

MicroAggregationKindAverage Field
Indicates that the values will be averaged together.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAggregationKind Average = 0
Public Const Average As MicroAggregationKind = 0

Field Value

Type: MicroAggregationKind
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind.First Field

MicroAggregationKindFirst Field
Indicates that the first value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAggregationKind First = 3
Public Const First As MicroAggregationKind = 3

Field Value

Type: MicroAggregationKind
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind.Last Field

MicroAggregationKindLast Field
Indicates that the last value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAggregationKind Last = 4
Public Const Last As MicroAggregationKind = 4

Field Value

Type: MicroAggregationKind
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind.Maximum Field

MicroAggregationKindMaximum Field
Indicates that the maximum value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAggregationKind Maximum = 1
Public Const Maximum As MicroAggregationKind = 1

Field Value

Type: MicroAggregationKind
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind.Minimum Field

MicroAggregationKindMinimum Field
Indicates that the minimum value will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAggregationKind Minimum = 2
Public Const Minimum As MicroAggregationKind = 2

Field Value

Type: MicroAggregationKind
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAggregationKind.value__ Field

MicroAggregationKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroAggregationKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroAggregationKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries Class

MicroAreaSeries Class
Represents an area series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroAreaSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroAreaSeries : MicroLineSeriesBase
Public Class MicroAreaSeries
    Inherits MicroLineSeriesBase

The MicroAreaSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroAreaSeries | Initializes a new instance of the MicroAreaSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreaNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyleKinds | Gets or sets a MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreaNegativeStyleProperty | Identifies the AreaNegativeStyle dependency property. This field is read-only.
AreaStyleKindsProperty | Identifies the AreaStyleKinds dependency property. This field is read-only.
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries Constructor

MicroAreaSeries Constructor
Initializes a new instance of the MicroAreaSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroAreaSeries()
Public Sub New
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries Properties

MicroAreaSeries Properties

The MicroAreaSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreaNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | AreaStyleKinds | Gets or sets a MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineVisibility | Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.AreaNegativeStyle Property

MicroAreaSeriesAreaNegativeStyle Property
Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style AreaNegativeStyle { get; set; }
Public Property AreaNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyle Property

MicroAreaSeriesAreaStyle Property
Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style AreaStyle { get; set; }
Public Property AreaStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyleKinds Property

MicroAreaSeriesAreaStyleKinds Property
Gets or sets a MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroAreaSeriesStyleKinds AreaStyleKinds { get; set; }
Public Property AreaStyleKinds As MicroAreaSeriesStyleKinds
    Get
    Set

Property Value

Type: MicroAreaSeriesStyleKinds
A MicroAreaSeriesStyleKinds which indicates what style kinds are used for areas along the series. The default value is MicroAreaSeriesStyleKinds.None.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.LineVisibility Property

MicroAreaSeriesLineVisibility Property
Gets or sets a value indicating which lines are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroLineSeriesVisibility LineVisibility { get; set; }
Public Property LineVisibility As MicroLineSeriesVisibility
    Get
    Set

Property Value

Type: MicroLineSeriesVisibility
A MicroLineSeriesVisibility indicating which lines are rendered along the series. The default value is MicroLineSeriesVisibility.None.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries Methods

MicroAreaSeries Methods

The MicroAreaSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.PlotSeries Method

MicroAreaSeriesPlotSeries Method
Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries Events

MicroAreaSeries Events

The MicroAreaSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries Fields

MicroAreaSeries Fields

The MicroAreaSeries type exposes the following members.

Fields
Name | Description
AreaNegativeStyleProperty | Identifies the AreaNegativeStyle dependency property. This field is read-only.
AreaStyleKindsProperty | Identifies the AreaStyleKinds dependency property. This field is read-only.
AreaStyleProperty | Identifies the AreaStyle dependency property. This field is read-only.
LineVisibilityProperty | Identifies the LineVisibility dependency property. This field is read-only.
Top
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.AreaNegativeStyleProperty Field

MicroAreaSeriesAreaNegativeStyleProperty Field
Identifies the AreaNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaNegativeStyleProperty
Public Shared ReadOnly AreaNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaNegativeStyle dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyleKindsProperty Field

MicroAreaSeriesAreaStyleKindsProperty Field
Identifies the AreaStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaStyleKindsProperty
Public Shared ReadOnly AreaStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaStyleKinds dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.AreaStyleProperty Field

MicroAreaSeriesAreaStyleProperty Field
Identifies the AreaStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreaStyleProperty
Public Shared ReadOnly AreaStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreaStyle dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeries.LineVisibilityProperty Field

MicroAreaSeriesLineVisibilityProperty Field
Identifies the LineVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineVisibilityProperty
Public Shared ReadOnly LineVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineVisibility dependency property.
See Also

Reference

MicroAreaSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds Class

MicroAreaSeriesStyleKinds Class
Specifies the various alternate styles that can be used when rendering an area.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroAreaSeriesStyleKinds

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MicroAreaSeriesStyleKinds : Enum
<FlagsAttribute>
Public NotInheritable Class MicroAreaSeriesStyleKinds
    Inherits Enum

The MicroAreaSeriesStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds Methods

MicroAreaSeriesStyleKinds Methods

The MicroAreaSeriesStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroAreaSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds Fields

MicroAreaSeriesStyleKinds Fields

The MicroAreaSeriesStyleKinds type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

MicroAreaSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds.All Field

MicroAreaSeriesStyleKindsAll Field
Indicates that all styles can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAreaSeriesStyleKinds All = 8388609
Public Const All As MicroAreaSeriesStyleKinds = 8388609

Field Value

Type: MicroAreaSeriesStyleKinds
See Also

Reference

MicroAreaSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds.Negative Field

MicroAreaSeriesStyleKindsNegative Field
Indicates that a negative style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAreaSeriesStyleKinds Negative = 1
Public Const Negative As MicroAreaSeriesStyleKinds = 1

Field Value

Type: MicroAreaSeriesStyleKinds
See Also

Reference

MicroAreaSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds.None Field

MicroAreaSeriesStyleKindsNone Field
Indicates that no alternate styles will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroAreaSeriesStyleKinds None = 0
Public Const None As MicroAreaSeriesStyleKinds = 0

Field Value

Type: MicroAreaSeriesStyleKinds
See Also

Reference

MicroAreaSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroAreaSeriesStyleKinds.value__ Field

MicroAreaSeriesStyleKindsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroAreaSeriesStyleKinds.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroAreaSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeries Class

MicroBarSeries Class
Represents a bar series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroBarSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroBarSeries : MicroBarSeriesBase
Public Class MicroBarSeries
    Inherits MicroBarSeriesBase

The MicroBarSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroBarSeries | Initializes a new instance of the MicroBarSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeries Constructor

MicroBarSeries Constructor
Initializes a new instance of the MicroBarSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroBarSeries()
Public Sub New
See Also

Reference

MicroBarSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeries Properties

MicroBarSeries Properties

The MicroBarSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroBarSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeries Methods

MicroBarSeries Methods

The MicroBarSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroBarSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeries Events

MicroBarSeries Events

The MicroBarSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroBarSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds Class

MicroBarSeriesStyleKinds Class
Specifies the various alternate styles that can be used when rendering a bar.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroBarSeriesStyleKinds

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MicroBarSeriesStyleKinds : Enum
<FlagsAttribute>
Public NotInheritable Class MicroBarSeriesStyleKinds
    Inherits Enum

The MicroBarSeriesStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | High | Indicates that a high style can be used.
 | Low | Indicates that a low style can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds Methods

MicroBarSeriesStyleKinds Methods

The MicroBarSeriesStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds Fields

MicroBarSeriesStyleKinds Fields

The MicroBarSeriesStyleKinds type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | High | Indicates that a high style can be used.
 | Low | Indicates that a low style can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds.All Field

MicroBarSeriesStyleKindsAll Field
Indicates that all styles can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroBarSeriesStyleKinds All = 7
Public Const All As MicroBarSeriesStyleKinds = 7

Field Value

Type: MicroBarSeriesStyleKinds
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds.High Field

MicroBarSeriesStyleKindsHigh Field
Indicates that a high style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroBarSeriesStyleKinds High = 2
Public Const High As MicroBarSeriesStyleKinds = 2

Field Value

Type: MicroBarSeriesStyleKinds
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds.Low Field

MicroBarSeriesStyleKindsLow Field
Indicates that a low style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroBarSeriesStyleKinds Low = 4
Public Const Low As MicroBarSeriesStyleKinds = 4

Field Value

Type: MicroBarSeriesStyleKinds
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds.Negative Field

MicroBarSeriesStyleKindsNegative Field
Indicates that a negative style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroBarSeriesStyleKinds Negative = 1
Public Const Negative As MicroBarSeriesStyleKinds = 1

Field Value

Type: MicroBarSeriesStyleKinds
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds.None Field

MicroBarSeriesStyleKindsNone Field
Indicates that no alternate styles will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroBarSeriesStyleKinds None = 0
Public Const None As MicroBarSeriesStyleKinds = 0

Field Value

Type: MicroBarSeriesStyleKinds
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBarSeriesStyleKinds.value__ Field

MicroBarSeriesStyleKindsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroBarSeriesStyleKinds.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroBarSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot Class

MicroBoxPlot Class
Represents a box plot control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroBoxPlot

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroBoxPlot : Control
Public Class MicroBoxPlot
    Inherits Control

The MicroBoxPlot type exposes the following members.

Constructors
 | Name | Description
Public method | MicroBoxPlot | Initializes a new instance of the MicroBoxPlot class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreOutliersVisible | Gets or sets a boolean value indicating whether or not outliers should be rendered. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BoxStyle | Gets or sets the Style used to render the box. This is a dependency property.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IqrMultiplier | Gets or sets a value indicating the amount to multiply the IQR by to find the range of the whiskers. This is a dependency property.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMeanVisible | Gets or sets a boolean value indicating whether or not the mean value bar should be rendered. This is a dependency property.
Public property | IsMedianVisible | Gets or sets a boolean value indicating whether or not the median value bar should be rendered. This is a dependency property.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBoxPlot control will display in a tool tip. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MeanStyle | Gets or sets the style of the mean value bar. This is a dependency property.
Public property | MedianStyle | Gets or sets the style of the median value bar. This is a dependency property.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the MicroBoxPlot. This is a dependency property.
Public property | OutlierStyle | Gets or sets the style of the outlier marker. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Values | Gets or sets the list of data values to be represented by the chart. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | WhiskerAscent | Gets or sets a Unit indicating the ascent of the whisker endline. This is a dependency property.
Public property | WhiskerStyle | Gets or sets the style of the whisker line. This is a dependency property.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AreOutliersVisibleProperty | Identifies the AreOutliersVisible dependency property. This field is read-only.
BoxStyleProperty | Identifies the BoxStyle dependency property. This field is read-only.
IqrMultiplierProperty | Identifies the IqrMultiplier dependency property. This field is read-only.
IsMeanVisibleProperty | Identifies the IsMeanVisible dependency property. This field is read-only.
IsMedianVisibleProperty | Identifies the IsMedianVisible dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MeanStyleProperty | Identifies the MeanStyle dependency property. This field is read-only.
MedianStyleProperty | Identifies the MedianStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
OutlierStyleProperty | Identifies the OutlierStyle dependency property. This field is read-only.
ValuesProperty | Identifies the Values dependency property. This field is read-only.
WhiskerAscentProperty | Identifies the WhiskerAscent dependency property. This field is read-only.
WhiskerStyleProperty | Identifies the WhiskerStyle dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot Constructor

MicroBoxPlot Constructor
Initializes a new instance of the MicroBoxPlot class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroBoxPlot()
Public Sub New
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot Properties

MicroBoxPlot Properties

The MicroBoxPlot type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreOutliersVisible | Gets or sets a boolean value indicating whether or not outliers should be rendered. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | BoxStyle | Gets or sets the Style used to render the box. This is a dependency property.
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IqrMultiplier | Gets or sets a value indicating the amount to multiply the IQR by to find the range of the whiskers. This is a dependency property.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsMeanVisible | Gets or sets a boolean value indicating whether or not the mean value bar should be rendered. This is a dependency property.
Public property | IsMedianVisible | Gets or sets a boolean value indicating whether or not the median value bar should be rendered. This is a dependency property.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBoxPlot control will display in a tool tip. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MeanStyle | Gets or sets the style of the mean value bar. This is a dependency property.
Public property | MedianStyle | Gets or sets the style of the median value bar. This is a dependency property.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the MicroBoxPlot. This is a dependency property.
Public property | OutlierStyle | Gets or sets the style of the outlier marker. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Values | Gets or sets the list of data values to be represented by the chart. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | WhiskerAscent | Gets or sets a Unit indicating the ascent of the whisker endline. This is a dependency property.
Public property | WhiskerStyle | Gets or sets the style of the whisker line. This is a dependency property.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.AreOutliersVisible Property

MicroBoxPlotAreOutliersVisible Property
Gets or sets a boolean value indicating whether or not outliers should be rendered. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreOutliersVisible { get; set; }
Public Property AreOutliersVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if outlier values are visible; otherwise, false. The default value is false.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.BoxStyle Property

MicroBoxPlotBoxStyle Property
Gets or sets the Style used to render the box. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style BoxStyle { get; set; }
Public Property BoxStyle As Style
    Get
    Set

Property Value

Type: Style
The Style used to render the box. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.IqrMultiplier Property

MicroBoxPlotIqrMultiplier Property
Gets or sets a value indicating the amount to multiply the IQR by to find the range of the whiskers. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double IqrMultiplier { get; set; }
Public Property IqrMultiplier As Double
    Get
    Set

Property Value

Type: Double
A value indicating the amount to multiply the IQR by to find the range of the whiskers. The default value is 1.5.
Remarks
IQR stands for interquartile range, which is equal to the difference of the upper and lower quartiles.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.IsMeanVisible Property

MicroBoxPlotIsMeanVisible Property
Gets or sets a boolean value indicating whether or not the mean value bar should be rendered. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMeanVisible { get; set; }
Public Property IsMeanVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mean value is visible; otherwise, false. The default value is false.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.IsMedianVisible Property

MicroBoxPlotIsMedianVisible Property
Gets or sets a boolean value indicating whether or not the median value bar should be rendered. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMedianVisible { get; set; }
Public Property IsMedianVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the median value is visible; otherwise, false. The default value is true.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.LegendStringFormat Property

MicroBoxPlotLegendStringFormat Property
Gets or sets the format that the MicroBoxPlot control will display in a tool tip. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a tool tip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The minimum value.
  • {1} - The lower whisker value.
  • {2} - The first quartile value.
  • {3} - The median value.
  • {4} - The third quartile value.
  • {5} - The upper whisker value.
  • {6} - The maximum value.
  • {7} - The mean value.
  • {8} - The number of values.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.Maximum Property

MicroBoxPlotMaximum Property
Gets or sets the maximum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the chart. The default value is NaN.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.MeanStyle Property

MicroBoxPlotMeanStyle Property
Gets or sets the style of the mean value bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MeanStyle { get; set; }
Public Property MeanStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the mean value bar. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.MedianStyle Property

MicroBoxPlotMedianStyle Property
Gets or sets the style of the median value bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MedianStyle { get; set; }
Public Property MedianStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the median value bar. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.Minimum Property

MicroBoxPlotMinimum Property
Gets or sets the minimum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the chart. The default value is NaN.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.Orientation Property

MicroBoxPlotOrientation Property
Gets or sets the orientation of the MicroBoxPlot. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the MicroBoxPlot. The default value is Horizontal.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.OutlierStyle Property

MicroBoxPlotOutlierStyle Property
Gets or sets the style of the outlier marker. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style OutlierStyle { get; set; }
Public Property OutlierStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the outlier marker. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.Values Property

MicroBoxPlotValues Property
Gets or sets the list of data values to be represented by the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Values { get; set; }
Public Property Values As Object
    Get
    Set

Property Value

Type: Object
The the list of data values. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerAscent Property

MicroBoxPlotWhiskerAscent Property
Gets or sets a Unit indicating the ascent of the whisker endline. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit WhiskerAscent { get; set; }
Public Property WhiskerAscent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the ascent of the whisker endline. The default value is 50%.
Remarks
Ascent is height when in a horizontal graph, and width when in a vertical graph.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerStyle Property

MicroBoxPlotWhiskerStyle Property
Gets or sets the style of the whisker line. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style WhiskerStyle { get; set; }
Public Property WhiskerStyle As Style
    Get
    Set

Property Value

Type: Style
The style of the whisker line. The default value is .
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot Methods

MicroBoxPlot Methods

The MicroBoxPlot type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.OnApplyTemplate Method

MicroBoxPlotOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.OnCreateAutomationPeer Method

MicroBoxPlotOnCreateAutomationPeer Method
When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.OnSizeChanged Method

MicroBoxPlotOnSizeChanged Method
Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Windows.UI.XamlSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.Refresh Method

MicroBoxPlotRefresh Method
Updates the chart based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot Events

MicroBoxPlot Events

The MicroBoxPlot type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot Fields

MicroBoxPlot Fields

The MicroBoxPlot type exposes the following members.

Fields
Name | Description
AreOutliersVisibleProperty | Identifies the AreOutliersVisible dependency property. This field is read-only.
BoxStyleProperty | Identifies the BoxStyle dependency property. This field is read-only.
IqrMultiplierProperty | Identifies the IqrMultiplier dependency property. This field is read-only.
IsMeanVisibleProperty | Identifies the IsMeanVisible dependency property. This field is read-only.
IsMedianVisibleProperty | Identifies the IsMedianVisible dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MeanStyleProperty | Identifies the MeanStyle dependency property. This field is read-only.
MedianStyleProperty | Identifies the MedianStyle dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
OutlierStyleProperty | Identifies the OutlierStyle dependency property. This field is read-only.
ValuesProperty | Identifies the Values dependency property. This field is read-only.
WhiskerAscentProperty | Identifies the WhiskerAscent dependency property. This field is read-only.
WhiskerStyleProperty | Identifies the WhiskerStyle dependency property. This field is read-only.
Top
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.AreOutliersVisibleProperty Field

MicroBoxPlotAreOutliersVisibleProperty Field
Identifies the AreOutliersVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreOutliersVisibleProperty
Public Shared ReadOnly AreOutliersVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreOutliersVisible dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.BoxStyleProperty Field

MicroBoxPlotBoxStyleProperty Field
Identifies the BoxStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BoxStyleProperty
Public Shared ReadOnly BoxStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BoxStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.IqrMultiplierProperty Field

MicroBoxPlotIqrMultiplierProperty Field
Identifies the IqrMultiplier dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IqrMultiplierProperty
Public Shared ReadOnly IqrMultiplierProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IqrMultiplier dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.IsMeanVisibleProperty Field

MicroBoxPlotIsMeanVisibleProperty Field
Identifies the IsMeanVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMeanVisibleProperty
Public Shared ReadOnly IsMeanVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMeanVisible dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.IsMedianVisibleProperty Field

MicroBoxPlotIsMedianVisibleProperty Field
Identifies the IsMedianVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMedianVisibleProperty
Public Shared ReadOnly IsMedianVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMedianVisible dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.LegendStringFormatProperty Field

MicroBoxPlotLegendStringFormatProperty Field
Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.MaximumProperty Field

MicroBoxPlotMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.MeanStyleProperty Field

MicroBoxPlotMeanStyleProperty Field
Identifies the MeanStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MeanStyleProperty
Public Shared ReadOnly MeanStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MeanStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.MedianStyleProperty Field

MicroBoxPlotMedianStyleProperty Field
Identifies the MedianStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MedianStyleProperty
Public Shared ReadOnly MedianStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MedianStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.MinimumProperty Field

MicroBoxPlotMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.OrientationProperty Field

MicroBoxPlotOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.OutlierStyleProperty Field

MicroBoxPlotOutlierStyleProperty Field
Identifies the OutlierStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OutlierStyleProperty
Public Shared ReadOnly OutlierStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OutlierStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.ValuesProperty Field

MicroBoxPlotValuesProperty Field
Identifies the Values dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValuesProperty
Public Shared ReadOnly ValuesProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Values dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerAscentProperty Field

MicroBoxPlotWhiskerAscentProperty Field
Identifies the WhiskerAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WhiskerAscentProperty
Public Shared ReadOnly WhiskerAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WhiskerAscent dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBoxPlot.WhiskerStyleProperty Field

MicroBoxPlotWhiskerStyleProperty Field
Identifies the WhiskerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WhiskerStyleProperty
Public Shared ReadOnly WhiskerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WhiskerStyle dependency property.
See Also

Reference

MicroBoxPlot Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph Class

MicroBulletGraph Class
Represents a bullet graph control that has a primary featured measure and optionally compares that measure to another measure to enrich its meaning, while also displaying this information in the context of qualitative ranges of performance (poor, satisfactory, good, etc.).
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroBulletGraph

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroBulletGraph : Control
Public Class MicroBulletGraph
    Inherits Control

The MicroBulletGraph type exposes the following members.

Constructors
 | Name | Description
Public method | MicroBulletGraph | Initializes a new instance of the MicroBulletGraph class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ComparativeMeasureAscent | Gets or sets a Unit indicating the ascent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureBrush | Gets or sets the Brush used to render the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureExtent | Gets or sets a Unit indicating the extent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureValue | Gets or sets the value represented by the comparative measure bar. This is a dependency property.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FeaturedMeasureAscent | Gets or sets a Unit indicating the ascent of the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureBrush | Gets or sets the Brush used to render the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureValue | Gets or sets the value represented by the featured measure bar. This is a dependency property.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBulletGraph control will display in a tool tip. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value displayed by the control. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value displayed by the control. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the MicroBulletGraph. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | ProjectedMeasureBrush | Gets or sets the Brush used to render the projected measure bar. This is a dependency property.
Public property | ProjectedMeasureValue | Gets or sets the value represented by the projected measure bar. This is a dependency property.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QualitativeRanges | Gets the chart's collection of qualitative ranges.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ThemeBaseColor | Gets or sets the base Color to use when auto-generating brushes for rendering the graph. This is a dependency property.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ComparativeMeasureAscentProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureBrushProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureExtentProperty | Identifies the ComparativeMeasureExtent dependency property. This field is read-only.
ComparativeMeasureValueProperty | Identifies the ComparativeMeasureValue dependency property. This field is read-only.
FeaturedMeasureAscentProperty | Identifies the FeaturedMeasureAscent dependency property. This field is read-only.
FeaturedMeasureBrushProperty | Identifies the FeaturedMeasureBrush dependency property. This field is read-only.
FeaturedMeasureValueProperty | Identifies the FeaturedMeasureValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ProjectedMeasureBrushProperty | Identifies the ProjectedMeasureBrush dependency property. This field is read-only.
ProjectedMeasureValueProperty | Identifies the ProjectedMeasureValue dependency property. This field is read-only.
ThemeBaseColorProperty | Identifies the ThemeBaseColor dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph Constructor

MicroBulletGraph Constructor
Initializes a new instance of the MicroBulletGraph class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroBulletGraph()
Public Sub New
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph Properties

MicroBulletGraph Properties

The MicroBulletGraph type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ComparativeMeasureAscent | Gets or sets a Unit indicating the ascent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureBrush | Gets or sets the Brush used to render the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureExtent | Gets or sets a Unit indicating the extent of the comparative measure bar. This is a dependency property.
Public property | ComparativeMeasureValue | Gets or sets the value represented by the comparative measure bar. This is a dependency property.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FeaturedMeasureAscent | Gets or sets a Unit indicating the ascent of the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureBrush | Gets or sets the Brush used to render the featured measure bar. This is a dependency property.
Public property | FeaturedMeasureValue | Gets or sets the value represented by the featured measure bar. This is a dependency property.
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroBulletGraph control will display in a tool tip. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value displayed by the control. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value displayed by the control. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the MicroBulletGraph. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | ProjectedMeasureBrush | Gets or sets the Brush used to render the projected measure bar. This is a dependency property.
Public property | ProjectedMeasureValue | Gets or sets the value represented by the projected measure bar. This is a dependency property.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | QualitativeRanges | Gets the chart's collection of qualitative ranges.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | ThemeBaseColor | Gets or sets the base Color to use when auto-generating brushes for rendering the graph. This is a dependency property.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureAscent Property

MicroBulletGraphComparativeMeasureAscent Property
Gets or sets a Unit indicating the ascent of the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit ComparativeMeasureAscent { get; set; }
Public Property ComparativeMeasureAscent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the ascent of the comparative measure bar. The default value is 66.7%.
Remarks
Ascent is height when in a horizontal graph, and width when in a vertical graph.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureBrush Property

MicroBulletGraphComparativeMeasureBrush Property
Gets or sets the Brush used to render the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ComparativeMeasureBrush { get; set; }
Public Property ComparativeMeasureBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used to render the comparative measure bar. The default value is .
Remarks
When this value is , a brush will be auto-generated from the ThemeBaseColor.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureExtent Property

MicroBulletGraphComparativeMeasureExtent Property
Gets or sets a Unit indicating the extent of the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit ComparativeMeasureExtent { get; set; }
Public Property ComparativeMeasureExtent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the extent of the comparative measure bar. The default value is 2.
Remarks
Extent is width when in a horizontal graph, and height when in a vertical graph.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureValue Property

MicroBulletGraphComparativeMeasureValue Property
Gets or sets the value represented by the comparative measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ComparativeMeasureValue { get; set; }
Public Property ComparativeMeasureValue As Double
    Get
    Set

Property Value

Type: Double
The value represented by the comparative measure bar. The default value is NaN, meaning don't show a comparative measure.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureAscent Property

MicroBulletGraphFeaturedMeasureAscent Property
Gets or sets a Unit indicating the ascent of the featured measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit FeaturedMeasureAscent { get; set; }
Public Property FeaturedMeasureAscent As Unit
    Get
    Set

Property Value

Type: Unit
A Unit indicating the ascent of the featured measure bar. The default value is 33.3%.
Remarks
Ascent is height when in a horizontal graph, and width when in a vertical graph.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureBrush Property

MicroBulletGraphFeaturedMeasureBrush Property
Gets or sets the Brush used to render the featured measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush FeaturedMeasureBrush { get; set; }
Public Property FeaturedMeasureBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used to render the featured measure bar. The default value is .
Remarks
When this value is , a brush will be auto-generated from the ThemeBaseColor.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureValue Property

MicroBulletGraphFeaturedMeasureValue Property
Gets or sets the value represented by the featured measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double FeaturedMeasureValue { get; set; }
Public Property FeaturedMeasureValue As Double
    Get
    Set

Property Value

Type: Double
The value represented by the featured measure bar. The default value is 0.0.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.LegendStringFormat Property

MicroBulletGraphLegendStringFormat Property
Gets or sets the format that the MicroBulletGraph control will display in a tool tip. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a tool tip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The featured measure value.
  • {1} - The projected measure value.
  • {2} - The comparitive measure value.
  • {3} - The minimum value.
  • {4} - The maximum value.
  • {5} - The value of the first qualitative range.
  • {6} - The value of the second qualitative range.
  • {7} - The value of the third qualitative range.
  • {8} - The value of the fourth qualitative range.
  • {9} - The value of the fifth qualitative range.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.Maximum Property

MicroBulletGraphMaximum Property
Gets or sets the maximum value displayed by the control. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value displayed by the control. The default value is NaN, meaning auto-calculate.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.Minimum Property

MicroBulletGraphMinimum Property
Gets or sets the minimum value displayed by the control. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value displayed by the control. The default value is NaN, meaning auto-calculate.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.Orientation Property

MicroBulletGraphOrientation Property
Gets or sets the orientation of the MicroBulletGraph. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the MicroBulletGraph. The default value is Horizontal.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureBrush Property

MicroBulletGraphProjectedMeasureBrush Property
Gets or sets the Brush used to render the projected measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush ProjectedMeasureBrush { get; set; }
Public Property ProjectedMeasureBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush used to render the projected measure bar. The default value is .
Remarks
When this value is , a brush will be auto-generated from the ThemeBaseColor.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureValue Property

MicroBulletGraphProjectedMeasureValue Property
Gets or sets the value represented by the projected measure bar. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ProjectedMeasureValue { get; set; }
Public Property ProjectedMeasureValue As Double
    Get
    Set

Property Value

Type: Double
The value represented by the projected measure bar. The default value is NaN, meaning don't display a projected measure.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.QualitativeRanges Property

MicroBulletGraphQualitativeRanges Property
Gets the chart's collection of qualitative ranges.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroQualitativeRangeCollection QualitativeRanges { get; }
Public ReadOnly Property QualitativeRanges As MicroQualitativeRangeCollection
    Get

Property Value

Type: MicroQualitativeRangeCollection
The chart's collection of qualitative ranges. The default value is .
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ThemeBaseColor Property

MicroBulletGraphThemeBaseColor Property
Gets or sets the base Color to use when auto-generating brushes for rendering the graph. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Color ThemeBaseColor { get; set; }
Public Property ThemeBaseColor As Color
    Get
    Set

Property Value

Type: Color
The base Color to use when auto-generating brushes for rendering the graph. The default value is #000000.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph Methods

MicroBulletGraph Methods

The MicroBulletGraph type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.OnApplyTemplate Method

MicroBulletGraphOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.OnCreateAutomationPeer Method

MicroBulletGraphOnCreateAutomationPeer Method
When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.OnSizeChanged Method

MicroBulletGraphOnSizeChanged Method
Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Windows.UI.XamlSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.Refresh Method

MicroBulletGraphRefresh Method
Updates the chart based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph Events

MicroBulletGraph Events

The MicroBulletGraph type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph Fields

MicroBulletGraph Fields

The MicroBulletGraph type exposes the following members.

Fields
Name | Description
ComparativeMeasureAscentProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureBrushProperty | Identifies the ComparativeMeasureBrush dependency property. This field is read-only.
ComparativeMeasureExtentProperty | Identifies the ComparativeMeasureExtent dependency property. This field is read-only.
ComparativeMeasureValueProperty | Identifies the ComparativeMeasureValue dependency property. This field is read-only.
FeaturedMeasureAscentProperty | Identifies the FeaturedMeasureAscent dependency property. This field is read-only.
FeaturedMeasureBrushProperty | Identifies the FeaturedMeasureBrush dependency property. This field is read-only.
FeaturedMeasureValueProperty | Identifies the FeaturedMeasureValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
ProjectedMeasureBrushProperty | Identifies the ProjectedMeasureBrush dependency property. This field is read-only.
ProjectedMeasureValueProperty | Identifies the ProjectedMeasureValue dependency property. This field is read-only.
ThemeBaseColorProperty | Identifies the ThemeBaseColor dependency property. This field is read-only.
Top
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureAscentProperty Field

MicroBulletGraphComparativeMeasureAscentProperty Field
Identifies the ComparativeMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureAscentProperty
Public Shared ReadOnly ComparativeMeasureAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureBrushProperty Field

MicroBulletGraphComparativeMeasureBrushProperty Field
Identifies the ComparativeMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureBrushProperty
Public Shared ReadOnly ComparativeMeasureBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureExtentProperty Field

MicroBulletGraphComparativeMeasureExtentProperty Field
Identifies the ComparativeMeasureExtent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureExtentProperty
Public Shared ReadOnly ComparativeMeasureExtentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureExtent dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ComparativeMeasureValueProperty Field

MicroBulletGraphComparativeMeasureValueProperty Field
Identifies the ComparativeMeasureValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ComparativeMeasureValueProperty
Public Shared ReadOnly ComparativeMeasureValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ComparativeMeasureValue dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureAscentProperty Field

MicroBulletGraphFeaturedMeasureAscentProperty Field
Identifies the FeaturedMeasureAscent dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FeaturedMeasureAscentProperty
Public Shared ReadOnly FeaturedMeasureAscentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FeaturedMeasureAscent dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureBrushProperty Field

MicroBulletGraphFeaturedMeasureBrushProperty Field
Identifies the FeaturedMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FeaturedMeasureBrushProperty
Public Shared ReadOnly FeaturedMeasureBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FeaturedMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.FeaturedMeasureValueProperty Field

MicroBulletGraphFeaturedMeasureValueProperty Field
Identifies the FeaturedMeasureValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty FeaturedMeasureValueProperty
Public Shared ReadOnly FeaturedMeasureValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the FeaturedMeasureValue dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.LegendStringFormatProperty Field

MicroBulletGraphLegendStringFormatProperty Field
Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.MaximumProperty Field

MicroBulletGraphMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.MinimumProperty Field

MicroBulletGraphMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.OrientationProperty Field

MicroBulletGraphOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureBrushProperty Field

MicroBulletGraphProjectedMeasureBrushProperty Field
Identifies the ProjectedMeasureBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ProjectedMeasureBrushProperty
Public Shared ReadOnly ProjectedMeasureBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ProjectedMeasureBrush dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ProjectedMeasureValueProperty Field

MicroBulletGraphProjectedMeasureValueProperty Field
Identifies the ProjectedMeasureValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ProjectedMeasureValueProperty
Public Shared ReadOnly ProjectedMeasureValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ProjectedMeasureValue dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroBulletGraph.ThemeBaseColorProperty Field

MicroBulletGraphThemeBaseColorProperty Field
Identifies the ThemeBaseColor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ThemeBaseColorProperty
Public Shared ReadOnly ThemeBaseColorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ThemeBaseColor dependency property.
See Also

Reference

MicroBulletGraph Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart Class

MicroCandlestickChart Class
Represents a candlestick chart control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroCandlestickChart

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroCandlestickChart : Control
Public Class MicroCandlestickChart
    Inherits Control

The MicroCandlestickChart type exposes the following members.

Constructors
 | Name | Description
Public method | MicroCandlestickChart | Initializes a new instance of the MicroCandlestickChart class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseValue | Gets or sets the closing value of the chart. This is a dependency property.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GainStyle | Gets or sets the Style used if the closing value is greater than the opening value. This is a dependency property.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighValue | Gets or sets the highest value of the chart. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroCandlestickChart control will display in a tool tip. This is a dependency property.
Public property | LossStyle | Gets or sets the Style used if the closing value is less than the opening value. This is a dependency property.
Public property | LowValue | Gets or sets the lowest value of the chart. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenValue | Gets or sets the opening value of the chart. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroCandlestickChart. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CloseValueProperty | Identifies the CloseValue dependency property. This field is read-only.
GainStyleProperty | Identifies the GainStyle dependency property. This field is read-only.
HighValueProperty | Identifies the HighValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
LossStyleProperty | Identifies the LossStyle dependency property. This field is read-only.
LowValueProperty | Identifies the LowValue dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OpenValueProperty | Identifies the OpenValue dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart Constructor

MicroCandlestickChart Constructor
Initializes a new instance of the MicroCandlestickChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroCandlestickChart()
Public Sub New
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart Properties

MicroCandlestickChart Properties

The MicroCandlestickChart type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CloseValue | Gets or sets the closing value of the chart. This is a dependency property.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GainStyle | Gets or sets the Style used if the closing value is greater than the opening value. This is a dependency property.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighValue | Gets or sets the highest value of the chart. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroCandlestickChart control will display in a tool tip. This is a dependency property.
Public property | LossStyle | Gets or sets the Style used if the closing value is less than the opening value. This is a dependency property.
Public property | LowValue | Gets or sets the lowest value of the chart. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the chart. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the chart. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OpenValue | Gets or sets the opening value of the chart. This is a dependency property.
Public property | Orientation | Gets or sets the orientation of the MicroCandlestickChart. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.CloseValue Property

MicroCandlestickChartCloseValue Property
Gets or sets the closing value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double CloseValue { get; set; }
Public Property CloseValue As Double
    Get
    Set

Property Value

Type: Double
The closing value of the chart. The default value is 0.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.GainStyle Property

MicroCandlestickChartGainStyle Property
Gets or sets the Style used if the closing value is greater than the opening value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style GainStyle { get; set; }
Public Property GainStyle As Style
    Get
    Set

Property Value

Type: Style
The Style used to render the chart.
Remarks
If this style is left the LossStyle will be used with a transparent fill.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.HighValue Property

MicroCandlestickChartHighValue Property
Gets or sets the highest value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double HighValue { get; set; }
Public Property HighValue As Double
    Get
    Set

Property Value

Type: Double
The highest value of the chart. The default value is 1.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.LegendStringFormat Property

MicroCandlestickChartLegendStringFormat Property
Gets or sets the format that the MicroCandlestickChart control will display in a tool tip. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a tool tip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The low value.
  • {1} - The high value.
  • {2} - The open value.
  • {3} - The close value.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.LossStyle Property

MicroCandlestickChartLossStyle Property
Gets or sets the Style used if the closing value is less than the opening value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LossStyle { get; set; }
Public Property LossStyle As Style
    Get
    Set

Property Value

Type: Style
The Style used to render the chart.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.LowValue Property

MicroCandlestickChartLowValue Property
Gets or sets the lowest value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LowValue { get; set; }
Public Property LowValue As Double
    Get
    Set

Property Value

Type: Double
The lowest value of the chart. The default value is 0.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.Maximum Property

MicroCandlestickChartMaximum Property
Gets or sets the maximum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the chart. The default value is NaN.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.Minimum Property

MicroCandlestickChartMinimum Property
Gets or sets the minimum value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the chart. The default value is NaN.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.OpenValue Property

MicroCandlestickChartOpenValue Property
Gets or sets the opening value of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double OpenValue { get; set; }
Public Property OpenValue As Double
    Get
    Set

Property Value

Type: Double
The opening value of the chart. The default value is 0.0.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.Orientation Property

MicroCandlestickChartOrientation Property
Gets or sets the orientation of the MicroCandlestickChart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the MicroCandlestickChart. The default value is Horizontal.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart Methods

MicroCandlestickChart Methods

The MicroCandlestickChart type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.OnApplyTemplate Method

MicroCandlestickChartOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.OnCreateAutomationPeer Method

MicroCandlestickChartOnCreateAutomationPeer Method
When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.OnSizeChanged Method

MicroCandlestickChartOnSizeChanged Method
Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Windows.UI.XamlSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.Refresh Method

MicroCandlestickChartRefresh Method
Updates the chart based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart Events

MicroCandlestickChart Events

The MicroCandlestickChart type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart Fields

MicroCandlestickChart Fields

The MicroCandlestickChart type exposes the following members.

Fields
Name | Description
CloseValueProperty | Identifies the CloseValue dependency property. This field is read-only.
GainStyleProperty | Identifies the GainStyle dependency property. This field is read-only.
HighValueProperty | Identifies the HighValue dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
LossStyleProperty | Identifies the LossStyle dependency property. This field is read-only.
LowValueProperty | Identifies the LowValue dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OpenValueProperty | Identifies the OpenValue dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.CloseValueProperty Field

MicroCandlestickChartCloseValueProperty Field
Identifies the CloseValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CloseValueProperty
Public Shared ReadOnly CloseValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CloseValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.GainStyleProperty Field

MicroCandlestickChartGainStyleProperty Field
Identifies the GainStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GainStyleProperty
Public Shared ReadOnly GainStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GainStyle dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.HighValueProperty Field

MicroCandlestickChartHighValueProperty Field
Identifies the HighValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighValueProperty
Public Shared ReadOnly HighValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.LegendStringFormatProperty Field

MicroCandlestickChartLegendStringFormatProperty Field
Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.LossStyleProperty Field

MicroCandlestickChartLossStyleProperty Field
Identifies the LossStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LossStyleProperty
Public Shared ReadOnly LossStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LossStyle dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.LowValueProperty Field

MicroCandlestickChartLowValueProperty Field
Identifies the LowValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LowValueProperty
Public Shared ReadOnly LowValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LowValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.MaximumProperty Field

MicroCandlestickChartMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.MinimumProperty Field

MicroCandlestickChartMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.OpenValueProperty Field

MicroCandlestickChartOpenValueProperty Field
Identifies the OpenValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OpenValueProperty
Public Shared ReadOnly OpenValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OpenValue dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroCandlestickChart.OrientationProperty Field

MicroCandlestickChartOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroCandlestickChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker Class

MicroChartMarker Class
Represents a control capable of rendering predefined shapes.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroChartMarker

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroChartMarker : Control
Public Class MicroChartMarker
    Inherits Control

The MicroChartMarker type exposes the following members.

Constructors
 | Name | Description
Public method | MicroChartMarker | Initializes a new instance of the MicroChartMarker class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Protected property | Path | Gets the Path associated with the marker.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ShapeKind | Gets or sets a MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker Constructor

MicroChartMarker Constructor
Initializes a new instance of the MicroChartMarker class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroChartMarker()
Public Sub New
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker Properties

MicroChartMarker Properties

The MicroChartMarker type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Protected property | Path | Gets the Path associated with the marker.
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ShapeKind | Gets or sets a MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker.Path Property

MicroChartMarkerPath Property
Gets the Path associated with the marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected Path Path { get; }
Protected ReadOnly Property Path As Path
    Get

Property Value

Type: Path
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker.ShapeKind Property

MicroChartMarkerShapeKind Property
Gets or sets a MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroChartMarkerShapeKind ShapeKind { get; set; }
Public Property ShapeKind As MicroChartMarkerShapeKind
    Get
    Set

Property Value

Type: MicroChartMarkerShapeKind
A MicroChartMarkerShapeKind, which indicates what kind of shape should be rendered by the marker. The default value is MicroChartMarkerShapeKind.Ellipse.
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker Methods

MicroChartMarker Methods

The MicroChartMarker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdatePath | Updates the Geometry of the Path element.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker.OnApplyTemplate Method

MicroChartMarkerOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker.UpdatePath Method

MicroChartMarkerUpdatePath Method
Updates the Geometry of the Path element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void UpdatePath()
Protected Overridable Sub UpdatePath
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker Events

MicroChartMarker Events

The MicroChartMarker type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker Fields

MicroChartMarker Fields

The MicroChartMarker type exposes the following members.

Fields
Name | Description
ShapeKindProperty | Identifies the ShapeKind dependency property. This field is read-only.
Top
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarker.ShapeKindProperty Field

MicroChartMarkerShapeKindProperty Field
Identifies the ShapeKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ShapeKindProperty
Public Shared ReadOnly ShapeKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ShapeKind dependency property.
See Also

Reference

MicroChartMarker Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind Class

MicroChartMarkerShapeKind Class
Specifies the various predefined shapes supported by MicroChartMarker.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroChartMarkerShapeKind

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroChartMarkerShapeKind : Enum
Public NotInheritable Class MicroChartMarkerShapeKind
    Inherits Enum

The MicroChartMarkerShapeKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Diamond | Indicates a diamond shape will be rendered.
 | Ellipse | Indicates an ellipse shape will be rendered.
 | Hexagon | Indicates a hexagon shape will be rendered.
 | Octagon | Indicates an octagon shape will be rendered.
 | Pentagon | Indicates a pentagon shape will be rendered.
 | Rectangle | Indicates a rectangle shape will be rendered.
 | Star4Points | Indicates an 4-pointed star shape will be rendered.
 | Star5Points | Indicates an 5-pointed star shape will be rendered.
 | Star6Points | Indicates an 6-pointed star shape will be rendered.
 | Star8Points | Indicates an 8-pointed star shape will be rendered.
 | Triangle | Indicates a triangle shape will be rendered.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind Methods

MicroChartMarkerShapeKind Methods

The MicroChartMarkerShapeKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind Fields

MicroChartMarkerShapeKind Fields

The MicroChartMarkerShapeKind type exposes the following members.

Fields
 | Name | Description
 | Diamond | Indicates a diamond shape will be rendered.
 | Ellipse | Indicates an ellipse shape will be rendered.
 | Hexagon | Indicates a hexagon shape will be rendered.
 | Octagon | Indicates an octagon shape will be rendered.
 | Pentagon | Indicates a pentagon shape will be rendered.
 | Rectangle | Indicates a rectangle shape will be rendered.
 | Star4Points | Indicates an 4-pointed star shape will be rendered.
 | Star5Points | Indicates an 5-pointed star shape will be rendered.
 | Star6Points | Indicates an 6-pointed star shape will be rendered.
 | Star8Points | Indicates an 8-pointed star shape will be rendered.
 | Triangle | Indicates a triangle shape will be rendered.
Public field | value__ |
Top
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Diamond Field

MicroChartMarkerShapeKindDiamond Field
Indicates a diamond shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Diamond = 0
Public Const Diamond As MicroChartMarkerShapeKind = 0

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Ellipse Field

MicroChartMarkerShapeKindEllipse Field
Indicates an ellipse shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Ellipse = 1
Public Const Ellipse As MicroChartMarkerShapeKind = 1

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Hexagon Field

MicroChartMarkerShapeKindHexagon Field
Indicates a hexagon shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Hexagon = 2
Public Const Hexagon As MicroChartMarkerShapeKind = 2

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Octagon Field

MicroChartMarkerShapeKindOctagon Field
Indicates an octagon shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Octagon = 4
Public Const Octagon As MicroChartMarkerShapeKind = 4

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Pentagon Field

MicroChartMarkerShapeKindPentagon Field
Indicates a pentagon shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Pentagon = 3
Public Const Pentagon As MicroChartMarkerShapeKind = 3

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Rectangle Field

MicroChartMarkerShapeKindRectangle Field
Indicates a rectangle shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Rectangle = 5
Public Const Rectangle As MicroChartMarkerShapeKind = 5

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Star4Points Field

MicroChartMarkerShapeKindStar4Points Field
Indicates an 4-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Star4Points = 6
Public Const Star4Points As MicroChartMarkerShapeKind = 6

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Star5Points Field

MicroChartMarkerShapeKindStar5Points Field
Indicates an 5-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Star5Points = 7
Public Const Star5Points As MicroChartMarkerShapeKind = 7

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Star6Points Field

MicroChartMarkerShapeKindStar6Points Field
Indicates an 6-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Star6Points = 8
Public Const Star6Points As MicroChartMarkerShapeKind = 8

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Star8Points Field

MicroChartMarkerShapeKindStar8Points Field
Indicates an 8-pointed star shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Star8Points = 9
Public Const Star8Points As MicroChartMarkerShapeKind = 9

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.Triangle Field

MicroChartMarkerShapeKindTriangle Field
Indicates a triangle shape will be rendered.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerShapeKind Triangle = 10
Public Const Triangle As MicroChartMarkerShapeKind = 10

Field Value

Type: MicroChartMarkerShapeKind
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerShapeKind.value__ Field

MicroChartMarkerShapeKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroChartMarkerShapeKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroChartMarkerShapeKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds Class

MicroChartMarkerStyleKinds Class
Specifies the various alternate styles that can be used when rendering a MicroChartMarker.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroChartMarkerStyleKinds

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MicroChartMarkerStyleKinds : Enum
<FlagsAttribute>
Public NotInheritable Class MicroChartMarkerStyleKinds
    Inherits Enum

The MicroChartMarkerStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | First | Indicates that a first style can be used.
 | High | Indicates that a high style can be used.
 | Last | Indicates that a last style can be used.
 | Low | Indicates that a low style can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds Methods

MicroChartMarkerStyleKinds Methods

The MicroChartMarkerStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds Fields

MicroChartMarkerStyleKinds Fields

The MicroChartMarkerStyleKinds type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | First | Indicates that a first style can be used.
 | High | Indicates that a high style can be used.
 | Last | Indicates that a last style can be used.
 | Low | Indicates that a low style can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.All Field

MicroChartMarkerStyleKindsAll Field
Indicates that all styles can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds All = 31
Public Const All As MicroChartMarkerStyleKinds = 31

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.First Field

MicroChartMarkerStyleKindsFirst Field
Indicates that a first style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds First = 8
Public Const First As MicroChartMarkerStyleKinds = 8

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.High Field

MicroChartMarkerStyleKindsHigh Field
Indicates that a high style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds High = 2
Public Const High As MicroChartMarkerStyleKinds = 2

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.Last Field

MicroChartMarkerStyleKindsLast Field
Indicates that a last style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds Last = 16
Public Const Last As MicroChartMarkerStyleKinds = 16

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.Low Field

MicroChartMarkerStyleKindsLow Field
Indicates that a low style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds Low = 4
Public Const Low As MicroChartMarkerStyleKinds = 4

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.Negative Field

MicroChartMarkerStyleKindsNegative Field
Indicates that a negative style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds Negative = 1
Public Const Negative As MicroChartMarkerStyleKinds = 1

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.None Field

MicroChartMarkerStyleKindsNone Field
Indicates that no alternate styles will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerStyleKinds None = 0
Public Const None As MicroChartMarkerStyleKinds = 0

Field Value

Type: MicroChartMarkerStyleKinds
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerStyleKinds.value__ Field

MicroChartMarkerStyleKindsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroChartMarkerStyleKinds.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroChartMarkerStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility Class

MicroChartMarkerVisibility Class
Specifies the visibility of the various kinds of MicroChartMarker.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroChartMarkerVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MicroChartMarkerVisibility : Enum
<FlagsAttribute>
Public NotInheritable Class MicroChartMarkerVisibility
    Inherits Enum

The MicroChartMarkerVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | First | Indicates that the first marker will be visible.
 | High | Indicates that high markers will be visible.
 | Last | Indicates that the last marker will be visible.
 | Low | Indicates that low markers will be visible.
 | Negative | Indicates that negative markers will be visible.
 | None | Indicates that no markers will be visible.
 | Positive | Indicates that positive markers will be visible.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility Methods

MicroChartMarkerVisibility Methods

The MicroChartMarkerVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility Fields

MicroChartMarkerVisibility Fields

The MicroChartMarkerVisibility type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | First | Indicates that the first marker will be visible.
 | High | Indicates that high markers will be visible.
 | Last | Indicates that the last marker will be visible.
 | Low | Indicates that low markers will be visible.
 | Negative | Indicates that negative markers will be visible.
 | None | Indicates that no markers will be visible.
 | Positive | Indicates that positive markers will be visible.
Public field | value__ |
Top
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.All Field

MicroChartMarkerVisibilityAll Field
Indicates that all markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility All = 63
Public Const All As MicroChartMarkerVisibility = 63

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.First Field

MicroChartMarkerVisibilityFirst Field
Indicates that the first marker will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility First = 16
Public Const First As MicroChartMarkerVisibility = 16

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.High Field

MicroChartMarkerVisibilityHigh Field
Indicates that high markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility High = 4
Public Const High As MicroChartMarkerVisibility = 4

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.Last Field

MicroChartMarkerVisibilityLast Field
Indicates that the last marker will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility Last = 32
Public Const Last As MicroChartMarkerVisibility = 32

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.Low Field

MicroChartMarkerVisibilityLow Field
Indicates that low markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility Low = 8
Public Const Low As MicroChartMarkerVisibility = 8

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.Negative Field

MicroChartMarkerVisibilityNegative Field
Indicates that negative markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility Negative = 2
Public Const Negative As MicroChartMarkerVisibility = 2

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.None Field

MicroChartMarkerVisibilityNone Field
Indicates that no markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility None = 0
Public Const None As MicroChartMarkerVisibility = 0

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.Positive Field

MicroChartMarkerVisibilityPositive Field
Indicates that positive markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroChartMarkerVisibility Positive = 1
Public Const Positive As MicroChartMarkerVisibility = 1

Field Value

Type: MicroChartMarkerVisibility
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroChartMarkerVisibility.value__ Field

MicroChartMarkerVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroChartMarkerVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroChartMarkerVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter Class

MicroHeatMapPresenter Class
Represents a HeatMap element.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
Windows.UI.Xaml.ControlsContentControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroHeatMapPresenter

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroHeatMapPresenter : ContentControl
Public Class MicroHeatMapPresenter
    Inherits ContentControl

The MicroHeatMapPresenter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroHeatMapPresenter | Initializes a new instance of the MicroHeatMapPresenter class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ColorMaximum | Gets or sets the maximum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorMinimum | Gets or sets the minimum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorValue | Gets or sets a value represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GradientStops | Gets or sets a collection of GradientStops used to the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSizingEnabled | Gets or sets whether or not the control can change size MicroHeatMapPresenter. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroHeatMapPresenter control will display in a ToolTip. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets the style of the marker of the MicroHeatMapPresenter. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SizeMaximum | Gets or sets the maximum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeMinimum | Gets or sets the minimum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeValue | Gets or sets a value represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ColorMaximumProperty | Identifies the ColorMaximumProperty dependency property. This field is read-only.
ColorMinimumProperty | Identifies the ColorMinimumProperty dependency property. This field is read-only.
ColorValueProperty | Identifies the ColorValue dependency property. This field is read-only.
GradientStopsProperty | Identifies the GradientStops dependency property. This field is read-only.
IsSizingEnabledProperty | Identifies the IsSizingEnabled dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
SizeMaximumProperty | Identifies the SizeMaximum dependency property. This field is read-only.
SizeMinimumProperty | Identifies the SizeMinimum dependency property. This field is read-only.
SizeValueProperty | Identifies the SizeValue dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter Constructor

MicroHeatMapPresenter Constructor
Initializes a new instance of the MicroHeatMapPresenter class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroHeatMapPresenter()
Public Sub New
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter Properties

MicroHeatMapPresenter Properties

The MicroHeatMapPresenter type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | ColorMaximum | Gets or sets the maximum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorMinimum | Gets or sets the minimum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | ColorValue | Gets or sets a value represented by the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template that is used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateRoot | Gets the root element of the date template specified by the ContentTemplate property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a selection object that changes the DataTemplate to apply for content, based on processing information about the content item or its container at run time. (Inherited from ContentControl.)
Public property | ContentTransitions | Gets or sets the collection of Transition style elements that apply to the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GradientStops | Gets or sets a collection of GradientStops used to the color of the MicroHeatMapPresenter. This is a dependency property.
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSizingEnabled | Gets or sets whether or not the control can change size MicroHeatMapPresenter. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendStringFormat | Gets or sets the format that the MicroHeatMapPresenter control will display in a ToolTip. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerStyle | Gets or sets the style of the marker of the MicroHeatMapPresenter. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SizeMaximum | Gets or sets the maximum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeMinimum | Gets or sets the minimum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | SizeValue | Gets or sets a value represented by the size of the MicroHeatMapPresenter. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMaximum Property

MicroHeatMapPresenterColorMaximum Property
Gets or sets the maximum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ColorMaximum { get; set; }
Public Property ColorMaximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the data set represented by color. The default value is 1.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMinimum Property

MicroHeatMapPresenterColorMinimum Property
Gets or sets the minimum value of data represented by the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ColorMinimum { get; set; }
Public Property ColorMinimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the data set represented by color. The default value is 0.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorValue Property

MicroHeatMapPresenterColorValue Property
Gets or sets a value represented by the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ColorValue { get; set; }
Public Property ColorValue As Double
    Get
    Set

Property Value

Type: Double
This marker's value to be represented by color. The default value is 0.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.GradientStops Property

MicroHeatMapPresenterGradientStops Property
Gets or sets a collection of GradientStops used to the color of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public GradientStopCollection GradientStops { get; set; }
Public Property GradientStops As GradientStopCollection
    Get
    Set

Property Value

Type: GradientStopCollection
The collection of GradientStops to select the control's color from. The default value is .
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.IsSizingEnabled Property

MicroHeatMapPresenterIsSizingEnabled Property
Gets or sets whether or not the control can change size MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSizingEnabled { get; set; }
Public Property IsSizingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
A boolean determining if the control can change size. The default value is false.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.LegendStringFormat Property

MicroHeatMapPresenterLegendStringFormat Property
Gets or sets the format that the MicroHeatMapPresenter control will display in a ToolTip. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format that determines how to display a ToolTip. The default value is .
Remarks
The format string will be passed the following parameters:
  • {0} - The value represented by color.
  • {1} - The minimum color value.
  • {2} - The maximum color value.
  • {3} - The value represented by size.
  • {4} - The minimum size value.
  • {5} - The maximum size value.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.MarkerStyle Property

MicroHeatMapPresenterMarkerStyle Property
Gets or sets the style of the marker of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; set; }
Public Property MarkerStyle As Style
    Get
    Set

Property Value

Type: Style
This marker's style. The default value is .
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMaximum Property

MicroHeatMapPresenterSizeMaximum Property
Gets or sets the maximum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SizeMaximum { get; set; }
Public Property SizeMaximum As Double
    Get
    Set

Property Value

Type: Double
The maximum value of the data set represented by size. The default value is 1.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMinimum Property

MicroHeatMapPresenterSizeMinimum Property
Gets or sets the minimum value of data represented by the size of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SizeMinimum { get; set; }
Public Property SizeMinimum As Double
    Get
    Set

Property Value

Type: Double
The minimum value of the data set represented by size. The default value is 0.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeValue Property

MicroHeatMapPresenterSizeValue Property
Gets or sets a value represented by the size of the MicroHeatMapPresenter. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SizeValue { get; set; }
Public Property SizeValue As Double
    Get
    Set

Property Value

Type: Double
This marker's value to be represented by size. The default value is 1.0.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter Methods

MicroHeatMapPresenter Methods

The MicroHeatMapPresenter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnContentChanged | Invoked when the value of the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Invoked when the value of the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Invoked when the value of the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.OnApplyTemplate Method

MicroHeatMapPresenterOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.OnCreateAutomationPeer Method

MicroHeatMapPresenterOnCreateAutomationPeer Method
When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter Events

MicroHeatMapPresenter Events

The MicroHeatMapPresenter type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter Fields

MicroHeatMapPresenter Fields

The MicroHeatMapPresenter type exposes the following members.

Fields
Name | Description
ColorMaximumProperty | Identifies the ColorMaximumProperty dependency property. This field is read-only.
ColorMinimumProperty | Identifies the ColorMinimumProperty dependency property. This field is read-only.
ColorValueProperty | Identifies the ColorValue dependency property. This field is read-only.
GradientStopsProperty | Identifies the GradientStops dependency property. This field is read-only.
IsSizingEnabledProperty | Identifies the IsSizingEnabled dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
SizeMaximumProperty | Identifies the SizeMaximum dependency property. This field is read-only.
SizeMinimumProperty | Identifies the SizeMinimum dependency property. This field is read-only.
SizeValueProperty | Identifies the SizeValue dependency property. This field is read-only.
Top
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMaximumProperty Field

MicroHeatMapPresenterColorMaximumProperty Field
Identifies the ColorMaximumProperty dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorMaximumProperty
Public Shared ReadOnly ColorMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColorMaximumProperty dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorMinimumProperty Field

MicroHeatMapPresenterColorMinimumProperty Field
Identifies the ColorMinimumProperty dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorMinimumProperty
Public Shared ReadOnly ColorMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColorMinimumProperty dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.ColorValueProperty Field

MicroHeatMapPresenterColorValueProperty Field
Identifies the ColorValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ColorValueProperty
Public Shared ReadOnly ColorValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ColorValue dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.GradientStopsProperty Field

MicroHeatMapPresenterGradientStopsProperty Field
Identifies the GradientStops dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty GradientStopsProperty
Public Shared ReadOnly GradientStopsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the GradientStops dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.IsSizingEnabledProperty Field

MicroHeatMapPresenterIsSizingEnabledProperty Field
Identifies the IsSizingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSizingEnabledProperty
Public Shared ReadOnly IsSizingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSizingEnabled dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.LegendStringFormatProperty Field

MicroHeatMapPresenterLegendStringFormatProperty Field
Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.MarkerStyleProperty Field

MicroHeatMapPresenterMarkerStyleProperty Field
Identifies the MarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleProperty
Public Shared ReadOnly MarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyle dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMaximumProperty Field

MicroHeatMapPresenterSizeMaximumProperty Field
Identifies the SizeMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeMaximumProperty
Public Shared ReadOnly SizeMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeMaximum dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeMinimumProperty Field

MicroHeatMapPresenterSizeMinimumProperty Field
Identifies the SizeMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeMinimumProperty
Public Shared ReadOnly SizeMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeMinimum dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroHeatMapPresenter.SizeValueProperty Field

MicroHeatMapPresenterSizeValueProperty Field
Identifies the SizeValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SizeValueProperty
Public Shared ReadOnly SizeValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SizeValue dependency property.
See Also

Reference

MicroHeatMapPresenter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeries Class

MicroLineSeries Class
Represents a line series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroLineSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroLineSeries : MicroLineSeriesBase
Public Class MicroLineSeries
    Inherits MicroLineSeriesBase

The MicroLineSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroLineSeries | Initializes a new instance of the MicroLineSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeries Constructor

MicroLineSeries Constructor
Initializes a new instance of the MicroLineSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroLineSeries()
Public Sub New
See Also

Reference

MicroLineSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeries Properties

MicroLineSeries Properties

The MicroLineSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroLineSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroLineSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeries Methods

MicroLineSeries Methods

The MicroLineSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroLineSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroLineSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeries.PlotSeries Method

MicroLineSeriesPlotSeries Method
Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroLineSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeries Events

MicroLineSeries Events

The MicroLineSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroLineSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds Class

MicroLineSeriesStyleKinds Class
Specifies the various alternate styles that can be used when rendering a line.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroLineSeriesStyleKinds

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MicroLineSeriesStyleKinds : Enum
<FlagsAttribute>
Public NotInheritable Class MicroLineSeriesStyleKinds
    Inherits Enum

The MicroLineSeriesStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds Methods

MicroLineSeriesStyleKinds Methods

The MicroLineSeriesStyleKinds type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroLineSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds Fields

MicroLineSeriesStyleKinds Fields

The MicroLineSeriesStyleKinds type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all styles can be used.
 | Negative | Indicates that a negative style can be used.
 | None | Indicates that no alternate styles will be used.
Public field | value__ |
Top
See Also

Reference

MicroLineSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds.All Field

MicroLineSeriesStyleKindsAll Field
Indicates that all styles can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesStyleKinds All = 8388609
Public Const All As MicroLineSeriesStyleKinds = 8388609

Field Value

Type: MicroLineSeriesStyleKinds
See Also

Reference

MicroLineSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds.Negative Field

MicroLineSeriesStyleKindsNegative Field
Indicates that a negative style can be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesStyleKinds Negative = 1
Public Const Negative As MicroLineSeriesStyleKinds = 1

Field Value

Type: MicroLineSeriesStyleKinds
See Also

Reference

MicroLineSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds.None Field

MicroLineSeriesStyleKindsNone Field
Indicates that no alternate styles will be used.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesStyleKinds None = 0
Public Const None As MicroLineSeriesStyleKinds = 0

Field Value

Type: MicroLineSeriesStyleKinds
See Also

Reference

MicroLineSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesStyleKinds.value__ Field

MicroLineSeriesStyleKindsvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroLineSeriesStyleKinds.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroLineSeriesStyleKinds Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility Class

MicroLineSeriesVisibility Class
Specifies the visibility of the various kinds of a line.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroLineSeriesVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class MicroLineSeriesVisibility : Enum
<FlagsAttribute>
Public NotInheritable Class MicroLineSeriesVisibility
    Inherits Enum

The MicroLineSeriesVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | Negative | Indicates that negative lines will be visible.
 | None | Indicates that no lines will be visible.
 | Positive | Indicates that positive lines will be visible.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility Methods

MicroLineSeriesVisibility Methods

The MicroLineSeriesVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility Fields

MicroLineSeriesVisibility Fields

The MicroLineSeriesVisibility type exposes the following members.

Fields
 | Name | Description
 | All | Indicates that all markers will be visible.
 | Negative | Indicates that negative lines will be visible.
 | None | Indicates that no lines will be visible.
 | Positive | Indicates that positive lines will be visible.
Public field | value__ |
Top
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility.All Field

MicroLineSeriesVisibilityAll Field
Indicates that all markers will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesVisibility All = 3
Public Const All As MicroLineSeriesVisibility = 3

Field Value

Type: MicroLineSeriesVisibility
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility.Negative Field

MicroLineSeriesVisibilityNegative Field
Indicates that negative lines will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesVisibility Negative = 2
Public Const Negative As MicroLineSeriesVisibility = 2

Field Value

Type: MicroLineSeriesVisibility
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility.None Field

MicroLineSeriesVisibilityNone Field
Indicates that no lines will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesVisibility None = 0
Public Const None As MicroLineSeriesVisibility = 0

Field Value

Type: MicroLineSeriesVisibility
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility.Positive Field

MicroLineSeriesVisibilityPositive Field
Indicates that positive lines will be visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroLineSeriesVisibility Positive = 1
Public Const Positive As MicroLineSeriesVisibility = 1

Field Value

Type: MicroLineSeriesVisibility
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroLineSeriesVisibility.value__ Field

MicroLineSeriesVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroLineSeriesVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroLineSeriesVisibility Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange Class

MicroQualitativeRange Class
Represents a qualitative range element for use within a MicroBulletGraph.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroQualitativeRange

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroQualitativeRange : Control
Public Class MicroQualitativeRange
    Inherits Control

The MicroQualitativeRange type exposes the following members.

Constructors
 | Name | Description
Public method | MicroQualitativeRange | Initializes a new instance of the MicroQualitativeRange class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroBulletGraph that owns this range.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the MicroQualitativeRange. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the range based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange Constructor

MicroQualitativeRange Constructor
Initializes a new instance of the MicroQualitativeRange class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroQualitativeRange()
Public Sub New
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange Properties

MicroQualitativeRange Properties

The MicroQualitativeRange type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroBulletGraph that owns this range.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the value of the MicroQualitativeRange. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange.Chart Property

MicroQualitativeRangeChart Property
Gets the MicroBulletGraph that owns this range.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroBulletGraph Chart { get; }
Public ReadOnly Property Chart As MicroBulletGraph
    Get

Property Value

Type: MicroBulletGraph
The MicroBulletGraph that owns this range.
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange.Value Property

MicroQualitativeRangeValue Property
Gets or sets the value of the MicroQualitativeRange. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The value of the range. The default value is NaN.
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange Methods

MicroQualitativeRange Methods

The MicroQualitativeRange type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the range based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange.Refresh Method

MicroQualitativeRangeRefresh Method
Updates the range based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange Events

MicroQualitativeRange Events

The MicroQualitativeRange type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange Fields

MicroQualitativeRange Fields

The MicroQualitativeRange type exposes the following members.

Fields
Name | Description
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRange.ValueProperty Field

MicroQualitativeRangeValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

MicroQualitativeRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Class

MicroQualitativeRangeCollection Class
Represents a collection of MicroQualitativeRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection MicroQualitativeRange
System.Collections.ObjectModelObservableCollection MicroQualitativeRange
ActiproSoftware.UI.XamlDeferrableObservableCollection MicroQualitativeRange
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroQualitativeRangeCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroQualitativeRangeCollection : DeferrableObservableCollection<MicroQualitativeRange>
Public Class MicroQualitativeRangeCollection
    Inherits DeferrableObservableCollection(Of MicroQualitativeRange)

The MicroQualitativeRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MicroQualitativeRangeCollection | Initializes a new instance of the MicroQualitativeRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection MicroQualitativeRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection MicroQualitativeRange .)
Protected property | Items | (Inherited from Collection MicroQualitativeRange .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection MicroQualitativeRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection MicroQualitativeRange .)
Public method | Clear | (Inherited from Collection MicroQualitativeRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection MicroQualitativeRange .)
Public method | CopyTo | (Inherited from Collection MicroQualitativeRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection MicroQualitativeRange .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection MicroQualitativeRange .)
Public method | Insert | (Inherited from Collection MicroQualitativeRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | MoveItem | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection MicroQualitativeRange .)
Public method | RemoveAt | (Inherited from Collection MicroQualitativeRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected event | PropertyChanged | (Inherited from ObservableCollection MicroQualitativeRange .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Constructor

MicroQualitativeRangeCollection Constructor
Initializes a new instance of the MicroQualitativeRangeCollection class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroQualitativeRangeCollection(
    MicroBulletGraph chart
)
Public Sub New (
    chart As MicroBulletGraph
)

Parameters

chart
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroBulletGraph
The MicroBulletGraph that owns this collection and the associated ranges.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Properties

MicroQualitativeRangeCollection Properties

The MicroQualitativeRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection MicroQualitativeRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection MicroQualitativeRange .)
Protected property | Items | (Inherited from Collection MicroQualitativeRange .)
Top
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Methods

MicroQualitativeRangeCollection Methods

The MicroQualitativeRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection MicroQualitativeRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection MicroQualitativeRange .)
Public method | Clear | (Inherited from Collection MicroQualitativeRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection MicroQualitativeRange .)
Public method | CopyTo | (Inherited from Collection MicroQualitativeRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection MicroQualitativeRange .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection MicroQualitativeRange .)
Public method | Insert | (Inherited from Collection MicroQualitativeRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | MoveItem | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection MicroQualitativeRange .)
Public method | RemoveAt | (Inherited from Collection MicroQualitativeRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.ClearItems Method

MicroQualitativeRangeCollectionClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.InsertItem Method

MicroQualitativeRangeCollectionInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    MicroQualitativeRange item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As MicroQualitativeRange
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroQualitativeRange
The object to insert.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.RemoveItem Method

MicroQualitativeRangeCollectionRemoveItem Method
Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection.SetItem Method

MicroQualitativeRangeCollectionSetItem Method
Replaces the element at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    MicroQualitativeRange item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As MicroQualitativeRange
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroQualitativeRange
The new value for the element at the specified index.
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroQualitativeRangeCollection Events

MicroQualitativeRangeCollection Events

The MicroQualitativeRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection MicroQualitativeRange .)
Protected event | PropertyChanged | (Inherited from ObservableCollection MicroQualitativeRange .)
Top
See Also

Reference

MicroQualitativeRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries Class

MicroScatterSeries Class
Represents a scatter series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroScatterSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroScatterSeries : MicroXYSeriesBase
Public Class MicroScatterSeries
    Inherits MicroXYSeriesBase

The MicroScatterSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroScatterSeries | Initializes a new instance of the MicroScatterSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries Constructor

MicroScatterSeries Constructor
Initializes a new instance of the MicroScatterSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroScatterSeries()
Public Sub New
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries Properties

MicroScatterSeries Properties

The MicroScatterSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries Methods

MicroScatterSeries Methods

The MicroScatterSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries.GetMinimumMargin Method

MicroScatterSeriesGetMinimumMargin Method
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> GetMinimumMargin()
Protected Overrides Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries.PlotSeries Method

MicroScatterSeriesPlotSeries Method
Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroScatterSeries Events

MicroScatterSeries Events

The MicroScatterSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroScatterSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart Class

MicroSegmentChart Class
Represents a segment chart control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroSegmentChart

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroSegmentChart : Control
Public Class MicroSegmentChart
    Inherits Control

The MicroSegmentChart type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSegmentChart | Initializes a new instance of the MicroSegmentChart class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DecreaseCommand | Gets the ICommand that can be used to decrease the value.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncreaseCommand | Gets the ICommand that can be used to increase the value.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for item containers. This is a dependency property.
Public property | ItemsPanel | Gets or sets the ItemsPanelTemplate to use for positioning segments. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Total | Gets or sets the total number of segments in the chart. This is a dependency property.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the number of segments that should appear highlighted in the chart. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DecreaseCommandProperty | Identifies the DecreaseCommand dependency property. This field is read-only.
IncreaseCommandProperty | Identifies the IncreaseCommand dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemsPanelProperty | Identifies the ItemsPanel dependency property. This field is read-only.
TotalProperty | Identifies the Total dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart Constructor

MicroSegmentChart Constructor
Initializes a new instance of the MicroSegmentChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSegmentChart()
Public Sub New
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart Properties

MicroSegmentChart Properties

The MicroSegmentChart type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DecreaseCommand | Gets the ICommand that can be used to decrease the value.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IncreaseCommand | Gets the ICommand that can be used to increase the value.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemContainerStyle | Gets or sets the Style to use for item containers. This is a dependency property.
Public property | ItemsPanel | Gets or sets the ItemsPanelTemplate to use for positioning segments. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Total | Gets or sets the total number of segments in the chart. This is a dependency property.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the number of segments that should appear highlighted in the chart. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.DecreaseCommand Property

MicroSegmentChartDecreaseCommand Property
Gets the ICommand that can be used to decrease the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand DecreaseCommand { get; }
Public ReadOnly Property DecreaseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to decrease the value.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.IncreaseCommand Property

MicroSegmentChartIncreaseCommand Property
Gets the ICommand that can be used to increase the value.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICommand IncreaseCommand { get; }
Public ReadOnly Property IncreaseCommand As ICommand
    Get

Property Value

Type: ICommand
The ICommand that can be used to increase the value.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.ItemContainerStyle Property

MicroSegmentChartItemContainerStyle Property
Gets or sets the Style to use for item containers. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style ItemContainerStyle { get; set; }
Public Property ItemContainerStyle As Style
    Get
    Set

Property Value

Type: Style
The Style to use for item containers.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.ItemsPanel Property

MicroSegmentChartItemsPanel Property
Gets or sets the ItemsPanelTemplate to use for positioning segments. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ItemsPanelTemplate ItemsPanel { get; set; }
Public Property ItemsPanel As ItemsPanelTemplate
    Get
    Set

Property Value

Type: ItemsPanelTemplate
The ItemsPanelTemplate to use for positioning segments.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.Total Property

MicroSegmentChartTotal Property
Gets or sets the total number of segments in the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Total { get; set; }
Public Property Total As Integer
    Get
    Set

Property Value

Type: Int32
The total number of segments in the chart. The default value is 10.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.Value Property

MicroSegmentChartValue Property
Gets or sets the number of segments that should appear highlighted in the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set

Property Value

Type: Int32
The number of segments that should appear highlighted in the chart. The default value is 0.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart Methods

MicroSegmentChart Methods

The MicroSegmentChart type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.OnApplyTemplate Method

MicroSegmentChartOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart Events

MicroSegmentChart Events

The MicroSegmentChart type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart Fields

MicroSegmentChart Fields

The MicroSegmentChart type exposes the following members.

Fields
Name | Description
DecreaseCommandProperty | Identifies the DecreaseCommand dependency property. This field is read-only.
IncreaseCommandProperty | Identifies the IncreaseCommand dependency property. This field is read-only.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property. This field is read-only.
ItemsPanelProperty | Identifies the ItemsPanel dependency property. This field is read-only.
TotalProperty | Identifies the Total dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.DecreaseCommandProperty Field

MicroSegmentChartDecreaseCommandProperty Field
Identifies the DecreaseCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DecreaseCommandProperty
Public Shared ReadOnly DecreaseCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the DecreaseCommand dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.IncreaseCommandProperty Field

MicroSegmentChartIncreaseCommandProperty Field
Identifies the IncreaseCommand dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IncreaseCommandProperty
Public Shared ReadOnly IncreaseCommandProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IncreaseCommand dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.ItemContainerStyleProperty Field

MicroSegmentChartItemContainerStyleProperty Field
Identifies the ItemContainerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemContainerStyleProperty
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemContainerStyle dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.ItemsPanelProperty Field

MicroSegmentChartItemsPanelProperty Field
Identifies the ItemsPanel dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsPanelProperty
Public Shared ReadOnly ItemsPanelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsPanel dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.TotalProperty Field

MicroSegmentChartTotalProperty Field
Identifies the Total dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TotalProperty
Public Shared ReadOnly TotalProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Total dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChart.ValueProperty Field

MicroSegmentChartValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

MicroSegmentChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem Class

MicroSegmentChartItem Class
Represents a segment chart item.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroSegmentChartItem

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroSegmentChartItem : Control
Public Class MicroSegmentChartItem
    Inherits Control

The MicroSegmentChartItem type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSegmentChartItem | Initializes a new instance of the MicroSegmentChartItem class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightedBackground | Gets or sets the Brush to use when the item is highlighted. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets the whether the item is highlighted. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HighlightedBackgroundProperty | Identifies the HighlightedBackground dependency property. This field is read-only.
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem Constructor

MicroSegmentChartItem Constructor
Initializes a new instance of the MicroSegmentChartItem class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSegmentChartItem()
Public Sub New
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem Properties

MicroSegmentChartItem Properties

The MicroSegmentChartItem type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightedBackground | Gets or sets the Brush to use when the item is highlighted. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHighlighted | Gets or sets the whether the item is highlighted. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem.HighlightedBackground Property

MicroSegmentChartItemHighlightedBackground Property
Gets or sets the Brush to use when the item is highlighted. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush HighlightedBackground { get; set; }
Public Property HighlightedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when the item is highlighted.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem.IsHighlighted Property

MicroSegmentChartItemIsHighlighted Property
Gets or sets the whether the item is highlighted. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHighlighted { get; set; }
Public Property IsHighlighted As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the item is highlighted; otherwise, false. The default value is false.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem Methods

MicroSegmentChartItem Methods

The MicroSegmentChartItem type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem.OnApplyTemplate Method

MicroSegmentChartItemOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem Events

MicroSegmentChartItem Events

The MicroSegmentChartItem type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem Fields

MicroSegmentChartItem Fields

The MicroSegmentChartItem type exposes the following members.

Fields
Name | Description
HighlightedBackgroundProperty | Identifies the HighlightedBackground dependency property. This field is read-only.
IsHighlightedProperty | Identifies the IsHighlighted dependency property. This field is read-only.
Top
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem.HighlightedBackgroundProperty Field

MicroSegmentChartItemHighlightedBackgroundProperty Field
Identifies the HighlightedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightedBackgroundProperty
Public Shared ReadOnly HighlightedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightedBackground dependency property.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSegmentChartItem.IsHighlightedProperty Field

MicroSegmentChartItemIsHighlightedProperty Field
Identifies the IsHighlighted dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHighlightedProperty
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHighlighted dependency property.
See Also

Reference

MicroSegmentChartItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector Class

MicroSeriesStyleSelector Class
Provides a way to apply series styles based on custom logic.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroSeriesStyleSelector
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroSeriesPaletteStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroSeriesStyleSelector
Public Class MicroSeriesStyleSelector

The MicroSeriesStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesStyleSelector | Initializes a new instance of the MicroSeriesStyleSelector class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series.
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series.
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series.
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series.
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series.
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series.
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series.
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector Constructor

MicroSeriesStyleSelector Constructor
Initializes a new instance of the MicroSeriesStyleSelector class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelector()
Public Sub New
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector Methods

MicroSeriesStyleSelector Methods

The MicroSeriesStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series.
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series.
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series.
Public method | SelectAreaStyle | Returns the area Style to use for the specified series.
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series.
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series.
Public method | SelectLineStyle | Returns the line Style to use for the specified series.
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series.
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series.
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series.
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series.
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series.
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaHighStyle Method

MicroSeriesStyleSelectorSelectAreaHighStyle Method
Returns the high area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaLowStyle Method

MicroSeriesStyleSelectorSelectAreaLowStyle Method
Returns the low area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaNegativeStyle Method

MicroSeriesStyleSelectorSelectAreaNegativeStyle Method
Returns the negative area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectAreaStyle Method

MicroSeriesStyleSelectorSelectAreaStyle Method
Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectAreaStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectAreaStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectLegendMarkerStyle Method

MicroSeriesStyleSelectorSelectLegendMarkerStyle Method
Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectLegendMarkerStyle(
    MicroXYSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLegendMarkerStyle (
    series As MicroXYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectLineNegativeStyle Method

MicroSeriesStyleSelectorSelectLineNegativeStyle Method
Returns the negative line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectLineNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectLineStyle Method

MicroSeriesStyleSelectorSelectLineStyle Method
Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectLineStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectLineStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerFirstStyle Method

MicroSeriesStyleSelectorSelectMarkerFirstStyle Method
Returns the first marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerFirstStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerFirstStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerHighStyle Method

MicroSeriesStyleSelectorSelectMarkerHighStyle Method
Returns the high marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerLastStyle Method

MicroSeriesStyleSelectorSelectMarkerLastStyle Method
Returns the last marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerLastStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerLastStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerLowStyle Method

MicroSeriesStyleSelectorSelectMarkerLowStyle Method
Returns the low marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerNegativeStyle Method

MicroSeriesStyleSelectorSelectMarkerNegativeStyle Method
Returns the negative marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroSeriesStyleSelector.SelectMarkerStyle Method

MicroSeriesStyleSelectorSelectMarkerStyle Method
Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual Style SelectMarkerStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overridable Function SelectMarkerStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator Class

MicroTrendIndicator Class
Represents a trend indicator.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroTrendIndicator

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroTrendIndicator : Control
Public Class MicroTrendIndicator
    Inherits Control

The MicroTrendIndicator type exposes the following members.

Constructors
 | Name | Description
Public method | MicroTrendIndicator | Initializes a new instance of the MicroTrendIndicator class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HigherTemplate | Gets or sets the DataTemplate to use for a higher value. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LowerTemplate | Gets or sets the DataTemplate to use for a lower value. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NeutralTemplate | Gets or sets the DataTemplate to use for a neutral value. This is a dependency property.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OriginValue | Gets or sets the origin value. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the current value. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HigherTemplateProperty | Identifies the HigherTemplate dependency property. This field is read-only.
LowerTemplateProperty | Identifies the LowerTemplate dependency property. This field is read-only.
NeutralTemplateProperty | Identifies the NeutralTemplate dependency property. This field is read-only.
OriginValueProperty | Identifies the OriginValue dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator Constructor

MicroTrendIndicator Constructor
Initializes a new instance of the MicroTrendIndicator class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroTrendIndicator()
Public Sub New
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator Properties

MicroTrendIndicator Properties

The MicroTrendIndicator type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HigherTemplate | Gets or sets the DataTemplate to use for a higher value. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LowerTemplate | Gets or sets the DataTemplate to use for a lower value. This is a dependency property.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | NeutralTemplate | Gets or sets the DataTemplate to use for a neutral value. This is a dependency property.
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OriginValue | Gets or sets the origin value. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | Gets or sets the current value. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.HigherTemplate Property

MicroTrendIndicatorHigherTemplate Property
Gets or sets the DataTemplate to use for a higher value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate HigherTemplate { get; set; }
Public Property HigherTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for a higher value.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.LowerTemplate Property

MicroTrendIndicatorLowerTemplate Property
Gets or sets the DataTemplate to use for a lower value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate LowerTemplate { get; set; }
Public Property LowerTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for a lower value.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.NeutralTemplate Property

MicroTrendIndicatorNeutralTemplate Property
Gets or sets the DataTemplate to use for a neutral value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate NeutralTemplate { get; set; }
Public Property NeutralTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate to use for a neutral value.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.OriginValue Property

MicroTrendIndicatorOriginValue Property
Gets or sets the origin value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double OriginValue { get; set; }
Public Property OriginValue As Double
    Get
    Set

Property Value

Type: Double
The origin value. The default value is 0.0.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.Value Property

MicroTrendIndicatorValue Property
Gets or sets the current value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The current value. The default value is 0.0.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator Methods

MicroTrendIndicator Methods

The MicroTrendIndicator type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.OnApplyTemplate Method

MicroTrendIndicatorOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator Events

MicroTrendIndicator Events

The MicroTrendIndicator type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator Fields

MicroTrendIndicator Fields

The MicroTrendIndicator type exposes the following members.

Fields
Name | Description
HigherTemplateProperty | Identifies the HigherTemplate dependency property. This field is read-only.
LowerTemplateProperty | Identifies the LowerTemplate dependency property. This field is read-only.
NeutralTemplateProperty | Identifies the NeutralTemplate dependency property. This field is read-only.
OriginValueProperty | Identifies the OriginValue dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.HigherTemplateProperty Field

MicroTrendIndicatorHigherTemplateProperty Field
Identifies the HigherTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HigherTemplateProperty
Public Shared ReadOnly HigherTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HigherTemplate dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.LowerTemplateProperty Field

MicroTrendIndicatorLowerTemplateProperty Field
Identifies the LowerTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LowerTemplateProperty
Public Shared ReadOnly LowerTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LowerTemplate dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.NeutralTemplateProperty Field

MicroTrendIndicatorNeutralTemplateProperty Field
Identifies the NeutralTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty NeutralTemplateProperty
Public Shared ReadOnly NeutralTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the NeutralTemplate dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.OriginValueProperty Field

MicroTrendIndicatorOriginValueProperty Field
Identifies the OriginValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OriginValueProperty
Public Shared ReadOnly OriginValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OriginValue dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroTrendIndicator.ValueProperty Field

MicroTrendIndicatorValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

MicroTrendIndicator Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroWinLossSeries Class

MicroWinLossSeries Class
Represents a win/loss series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroWinLossSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroWinLossSeries : MicroBarSeriesBase
Public Class MicroWinLossSeries
    Inherits MicroBarSeriesBase

The MicroWinLossSeries type exposes the following members.

Constructors
 | Name | Description
Public method | MicroWinLossSeries | Initializes a new instance of the MicroWinLossSeries class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Overrides MicroXYSeriesBaseRequiresNormalizedValues.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroWinLossSeries Constructor

MicroWinLossSeries Constructor
Initializes a new instance of the MicroWinLossSeries class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroWinLossSeries()
Public Sub New
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroWinLossSeries Properties

MicroWinLossSeries Properties

The MicroWinLossSeries type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroBarSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property. (Inherited from MicroBarSeriesBase.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Overrides MicroXYSeriesBaseRequiresNormalizedValues.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroBarSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroWinLossSeries.RequiresNormalizedValues Property

MicroWinLossSeriesRequiresNormalizedValues Property
Gets a value indicating whether the values presented by this series must be normalized.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool RequiresNormalizedValues { get; }
Protected Overrides ReadOnly Property RequiresNormalizedValues As Boolean
    Get

Property Value

Type: Boolean
true if the values presented by this series must be normalized; otherwise, false.
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroWinLossSeries Methods

MicroWinLossSeries Methods

The MicroWinLossSeries type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Inherited from MicroBarSeriesBase.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroBarSeriesBase.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroWinLossSeries Events

MicroWinLossSeries Events

The MicroWinLossSeries type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroWinLossSeries Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart Class

MicroXYChart Class
Represents a micro chart control that uses an X/Y coordinate system.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroChartBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYChart

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroXYChart : MicroChartBase
Public Class MicroXYChart
    Inherits MicroChartBase

The MicroXYChart type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYChart | Initializes a new instance of the MicroXYChart class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | AxisBaselineValue | Gets or sets the baseline value for the oriented axis. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsHotTrackingEnabled | Gets or sets a value indicating whether hot tracking is enabled, which is displays a tooltip with the associated value nearest the mouse cursor. This is a dependency property.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property. (Inherited from MicroChartBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxisMaximum | Gets or sets the maximum value along the X-axis. This is a dependency property.
Public property | XAxisMinimum | Gets or sets the minimum value along the X-axis. This is a dependency property.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxisMaximum | Gets or sets the maximum value along the Y-axis. This is a dependency property.
Public property | YAxisMinimum | Gets or sets the minimum value along the Y-axis. This is a dependency property.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Overrides ControlOnPointerCaptureLost(PointerRoutedEventArgs).)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Overrides ControlOnPointerEntered(PointerRoutedEventArgs).)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Overrides ControlOnPointerMoved(PointerRoutedEventArgs).)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Overrides ControlOnPointerPressed(PointerRoutedEventArgs).)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state. (Overrides MicroChartBaseRefresh.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
AxisBaselineValueProperty | Identifies the AxisBaselineValue dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsHotTrackingEnabledProperty | Identifies the IsHotTrackingEnabled dependency property. This field is read-only.
XAxisMaximumProperty | Identifies the XAxisMaximum dependency property. This field is read-only.
XAxisMinimumProperty | Identifies the XAxisMinimum dependency property. This field is read-only.
YAxisMaximumProperty | Identifies the YAxisMaximum dependency property. This field is read-only.
YAxisMinimumProperty | Identifies the YAxisMinimum dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart Constructor

MicroXYChart Constructor
Initializes a new instance of the MicroXYChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYChart()
Public Sub New
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart Properties

MicroXYChart Properties

The MicroXYChart type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AxisBaselineStyle | Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.
Public property | AxisBaselineValue | Gets or sets the baseline value for the oriented axis. This is a dependency property.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAxisBaselineVisible | Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsHotTrackingEnabled | Gets or sets a value indicating whether hot tracking is enabled, which is displays a tooltip with the associated value nearest the mouse cursor. This is a dependency property.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | Ranges | Gets the collection of ranges displayed by this chart.
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Series | Gets the collection of series displayed by this chart.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property. (Inherited from MicroChartBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XAxisMaximum | Gets or sets the maximum value along the X-axis. This is a dependency property.
Public property | XAxisMinimum | Gets or sets the minimum value along the X-axis. This is a dependency property.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YAxisMaximum | Gets or sets the maximum value along the Y-axis. This is a dependency property.
Public property | YAxisMinimum | Gets or sets the minimum value along the Y-axis. This is a dependency property.
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineStyle Property

MicroXYChartAxisBaselineStyle Property
Gets or sets a Style, which is applied to the Shape element used to render the baseline along the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style AxisBaselineStyle { get; set; }
Public Property AxisBaselineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the baseline along the chart. The default value is .
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineValue Property

MicroXYChartAxisBaselineValue Property
Gets or sets the baseline value for the oriented axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object AxisBaselineValue { get; set; }
Public Property AxisBaselineValue As Object
    Get
    Set

Property Value

Type: Object
The baseline value for the oriented axis. The default value is , which indicates to automatically calculate the baseline value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.IsAxisBaselineVisible Property

MicroXYChartIsAxisBaselineVisible Property
Gets or sets a value indicating whether a line is rendered at the baseline value. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAxisBaselineVisible { get; set; }
Public Property IsAxisBaselineVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a line is rendered at the baseline value; otherwise, false. The default value is false.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.IsHotTrackingEnabled Property

MicroXYChartIsHotTrackingEnabled Property
Gets or sets a value indicating whether hot tracking is enabled, which is displays a tooltip with the associated value nearest the mouse cursor. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHotTrackingEnabled { get; set; }
Public Property IsHotTrackingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if hot tracking is enabled; otherwise, false. The default value is false.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.Ranges Property

MicroXYChartRanges Property
Gets the collection of ranges displayed by this chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYRangeCollection Ranges { get; }
Public ReadOnly Property Ranges As MicroXYRangeCollection
    Get

Property Value

Type: MicroXYRangeCollection
The collection of ranges displayed by this chart.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.Series Property

MicroXYChartSeries Property
Gets the collection of series displayed by this chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYSeriesCollection Series { get; }
Public ReadOnly Property Series As MicroXYSeriesCollection
    Get

Property Value

Type: MicroXYSeriesCollection
The collection of series displayed by this chart.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.XAxisMaximum Property

MicroXYChartXAxisMaximum Property
Gets or sets the maximum value along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object XAxisMaximum { get; set; }
Public Property XAxisMaximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value along the X-axis. The default value is , which indicates to automatically calculate the maximum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.XAxisMinimum Property

MicroXYChartXAxisMinimum Property
Gets or sets the minimum value along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object XAxisMinimum { get; set; }
Public Property XAxisMinimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value along the X-axis. The default value is , which indicates to automatically calculate the minimum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.YAxisMaximum Property

MicroXYChartYAxisMaximum Property
Gets or sets the maximum value along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object YAxisMaximum { get; set; }
Public Property YAxisMaximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value along the Y-axis. The default value is , which indicates to automatically calculate the maximum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.YAxisMinimum Property

MicroXYChartYAxisMinimum Property
Gets or sets the minimum value along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object YAxisMinimum { get; set; }
Public Property YAxisMinimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value along the Y-axis. The default value is , which indicates to automatically calculate the minimum value.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart Methods

MicroXYChart Methods

The MicroXYChart type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Overrides ControlOnPointerCaptureLost(PointerRoutedEventArgs).)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Overrides ControlOnPointerEntered(PointerRoutedEventArgs).)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Overrides ControlOnPointerMoved(PointerRoutedEventArgs).)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Overrides ControlOnPointerPressed(PointerRoutedEventArgs).)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnSizeChanged | Handles the SizeChanged event of the control.
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state. (Overrides MicroChartBaseRefresh.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnApplyTemplate Method

MicroXYChartOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnCreateAutomationPeer Method

MicroXYChartOnCreateAutomationPeer Method
When implemented in a derived class, returns class-specific AutomationPeer implementations for the Silverlight automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The class-specific AutomationPeer subclass to return.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnPointerCaptureLost Method

MicroXYChartOnPointerCaptureLost Method
Called before the PointerCaptureLost event occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerCaptureLost(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerCaptureLost (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnPointerEntered Method

MicroXYChartOnPointerEntered Method
Called before the PointerEntered event occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerEntered(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerEntered (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnPointerExited Method

MicroXYChartOnPointerExited Method
Called before the PointerExited event occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerExited(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerExited (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnPointerMoved Method

MicroXYChartOnPointerMoved Method
Called before the PointerMoved event occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerMoved(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerMoved (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnPointerPressed Method

MicroXYChartOnPointerPressed Method
Called before the PointerPressed event occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerPressed(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerPressed (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
Event data for the event.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.OnSizeChanged Method

MicroXYChartOnSizeChanged Method
Handles the SizeChanged event of the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
Protected Overridable Sub OnSizeChanged (
    sender As Object,
    e As SizeChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: Windows.UI.XamlSizeChangedEventArgs
The SizeChangedEventArgs instance containing the event data.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.Refresh Method

MicroXYChartRefresh Method
Updates the chart based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart Events

MicroXYChart Events

The MicroXYChart type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart Fields

MicroXYChart Fields

The MicroXYChart type exposes the following members.

Fields
Name | Description
AxisBaselineStyleProperty | Identifies the AxisBaselineStyle dependency property. This field is read-only.
AxisBaselineValueProperty | Identifies the AxisBaselineValue dependency property. This field is read-only.
IsAxisBaselineVisibleProperty | Identifies the IsAxisBaselineVisible dependency property. This field is read-only.
IsHotTrackingEnabledProperty | Identifies the IsHotTrackingEnabled dependency property. This field is read-only.
XAxisMaximumProperty | Identifies the XAxisMaximum dependency property. This field is read-only.
XAxisMinimumProperty | Identifies the XAxisMinimum dependency property. This field is read-only.
YAxisMaximumProperty | Identifies the YAxisMaximum dependency property. This field is read-only.
YAxisMinimumProperty | Identifies the YAxisMinimum dependency property. This field is read-only.
Top
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineStyleProperty Field

MicroXYChartAxisBaselineStyleProperty Field
Identifies the AxisBaselineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AxisBaselineStyleProperty
Public Shared ReadOnly AxisBaselineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AxisBaselineStyle dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.AxisBaselineValueProperty Field

MicroXYChartAxisBaselineValueProperty Field
Identifies the AxisBaselineValue dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AxisBaselineValueProperty
Public Shared ReadOnly AxisBaselineValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AxisBaselineValue dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.IsAxisBaselineVisibleProperty Field

MicroXYChartIsAxisBaselineVisibleProperty Field
Identifies the IsAxisBaselineVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAxisBaselineVisibleProperty
Public Shared ReadOnly IsAxisBaselineVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAxisBaselineVisible dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.IsHotTrackingEnabledProperty Field

MicroXYChartIsHotTrackingEnabledProperty Field
Identifies the IsHotTrackingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsHotTrackingEnabledProperty
Public Shared ReadOnly IsHotTrackingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsHotTrackingEnabled dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.XAxisMaximumProperty Field

MicroXYChartXAxisMaximumProperty Field
Identifies the XAxisMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XAxisMaximumProperty
Public Shared ReadOnly XAxisMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XAxisMaximum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.XAxisMinimumProperty Field

MicroXYChartXAxisMinimumProperty Field
Identifies the XAxisMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XAxisMinimumProperty
Public Shared ReadOnly XAxisMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XAxisMinimum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.YAxisMaximumProperty Field

MicroXYChartYAxisMaximumProperty Field
Identifies the YAxisMaximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YAxisMaximumProperty
Public Shared ReadOnly YAxisMaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YAxisMaximum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYChart.YAxisMinimumProperty Field

MicroXYChartYAxisMinimumProperty Field
Identifies the YAxisMinimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YAxisMinimumProperty
Public Shared ReadOnly YAxisMinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YAxisMinimum dependency property.
See Also

Reference

MicroXYChart Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint Class

MicroXYDataPoint Class
Represents a data point presented by a a MicroXYSeriesBase series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroDataPointBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYDataPoint

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroXYDataPoint : MicroDataPointBase
Public Class MicroXYDataPoint
    Inherits MicroDataPointBase

The MicroXYDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYDataPoint | Initializes a new instance of the MicroXYDataPoint class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from MicroDataPointBase.)
Public property | StackedDataPoint | Gets the MicroXYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint Constructor

MicroXYDataPoint Constructor
Initializes a new instance of the MicroXYDataPoint class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint()
Public Sub New
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint Properties

MicroXYDataPoint Properties

The MicroXYDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point. (Inherited from MicroDataPointBase.)
Public property | StackedDataPoint | Gets the MicroXYDataPoint that this data point is stacked on top of.
Public property | XValue | Gets the X-value of the data point.
Public property | XValueResolved | Gets the resolved X-value of the data point.
Public property | YValue | Gets the Y-value of the data point.
Public property | YValueResolved | Gets the resolved Y-value of the data point.
Top
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint.StackedDataPoint Property

MicroXYDataPointStackedDataPoint Property
Gets the MicroXYDataPoint that this data point is stacked on top of.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint StackedDataPoint { get; }
Public ReadOnly Property StackedDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint.XValue Property

MicroXYDataPointXValue Property
Gets the X-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object XValue { get; }
Public ReadOnly Property XValue As Object
    Get

Property Value

Type: Object
The X-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint.XValueResolved Property

MicroXYDataPointXValueResolved Property
Gets the resolved X-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object XValueResolved { get; }
Public ReadOnly Property XValueResolved As Object
    Get

Property Value

Type: Object
The resolved X-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint.YValue Property

MicroXYDataPointYValue Property
Gets the Y-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object YValue { get; }
Public ReadOnly Property YValue As Object
    Get

Property Value

Type: Object
The Y-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint.YValueResolved Property

MicroXYDataPointYValueResolved Property
Gets the resolved Y-value of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object YValueResolved { get; }
Public ReadOnly Property YValueResolved As Object
    Get

Property Value

Type: Object
The resolved Y-value of the data point.
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint Methods

MicroXYDataPoint Methods

The MicroXYDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPoint Events

MicroXYDataPoint Events

The MicroXYDataPoint type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MicroXYDataPoint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Class

MicroXYDataPointCollectionView Class
Represents a collection view that generates MicroXYDataPoint from a specified source collection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroDataPointCollectionViewBase MicroXYDataPoint
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYDataPointCollectionView

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroXYDataPointCollectionView : MicroDataPointCollectionViewBase<MicroXYDataPoint>
Public NotInheritable Class MicroXYDataPointCollectionView
    Inherits MicroDataPointCollectionViewBase(Of MicroXYDataPoint)

The MicroXYDataPointCollectionView type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYDataPointCollectionView | Initializes a new instance of the MicroXYDataPointCollectionView class.
Top
Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | Count | Gets the number of records in the view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | FirstDataPoint | Gets the first data point of the collection.
Public property | LastDataPoint | Gets the last data point of the collection.
Public property | MaxXDataPoint | Gets the maximum data point along the X-axis.
Public property | MaxXValue | Gets the maximum value along the X-axis.
Public property | MaxXValueResolved | Gets the maximum resolved value along the X-axis.
Public property | MaxYDataPoint | Gets the maximum data point along the Y-axis.
Public property | MaxYValue | Gets the maximum value along the Y-axis.
Public property | MaxYValueResolved | Gets the maximum resolved value along the Y-axis.
Public property | MinXDataPoint | Gets the minimum data point along the X-axis.
Public property | MinXValue | Gets the minimum value along the X-axis.
Public property | MinXValueResolved | Gets the minimum resolved value along the X-axis.
Public property | MinYDataPoint | Gets the minimum data point along the Y-axis.
Public property | MinYValue | Gets the minimum value along the Y-axis.
Public property | MinYValueResolved | Gets the minimum resolved value along the Y-axis.
Public property | XType | Gets the Type of data along the X-axis.
Public property | YType | Gets the Type of data along the X-axis.
Top
Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemFromXValue | Gets a MicroXYDataPoint associated with a specified X value, if that data is available.
Public method | GetItemFromYValue | Gets a MicroXYDataPoint associated with a specified Y value, if that data is available.
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index at which the specified item is located. (Inherited from MicroDataPointCollectionViewBaseT.)
Protected method | Initialize | Initializes this instance. (Overrides MicroDataPointCollectionViewBaseTInitialize.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Constructor

MicroXYDataPointCollectionView Constructor
Initializes a new instance of the MicroXYDataPointCollectionView class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPointCollectionView(
    MicroXYSeriesBase series,
    Object baselineValue,
    int optimalAggregationCount
)
Public Sub New (
    series As MicroXYSeriesBase,
    baselineValue As Object,
    optimalAggregationCount As Integer
)

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The series associated with the view.
baselineValue
Type: SystemObject
The baseline value.
optimalAggregationCount
Type: SystemInt32
The optimal number of data points used when aggregation is enabled.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Properties

MicroXYDataPointCollectionView Properties

The MicroXYDataPointCollectionView type exposes the following members.

Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | Count | Gets the number of records in the view. (Inherited from MicroDataPointCollectionViewBaseT.)
Public property | FirstDataPoint | Gets the first data point of the collection.
Public property | LastDataPoint | Gets the last data point of the collection.
Public property | MaxXDataPoint | Gets the maximum data point along the X-axis.
Public property | MaxXValue | Gets the maximum value along the X-axis.
Public property | MaxXValueResolved | Gets the maximum resolved value along the X-axis.
Public property | MaxYDataPoint | Gets the maximum data point along the Y-axis.
Public property | MaxYValue | Gets the maximum value along the Y-axis.
Public property | MaxYValueResolved | Gets the maximum resolved value along the Y-axis.
Public property | MinXDataPoint | Gets the minimum data point along the X-axis.
Public property | MinXValue | Gets the minimum value along the X-axis.
Public property | MinXValueResolved | Gets the minimum resolved value along the X-axis.
Public property | MinYDataPoint | Gets the minimum data point along the Y-axis.
Public property | MinYValue | Gets the minimum value along the Y-axis.
Public property | MinYValueResolved | Gets the minimum resolved value along the Y-axis.
Public property | XType | Gets the Type of data along the X-axis.
Public property | YType | Gets the Type of data along the X-axis.
Top
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.FirstDataPoint Property

MicroXYDataPointCollectionViewFirstDataPoint Property
Gets the first data point of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint FirstDataPoint { get; }
Public ReadOnly Property FirstDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.LastDataPoint Property

MicroXYDataPointCollectionViewLastDataPoint Property
Gets the last data point of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint LastDataPoint { get; }
Public ReadOnly Property LastDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxXDataPoint Property

MicroXYDataPointCollectionViewMaxXDataPoint Property
Gets the maximum data point along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MaxXDataPoint { get; }
Public ReadOnly Property MaxXDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxXValue Property

MicroXYDataPointCollectionViewMaxXValue Property
Gets the maximum value along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MaxXValue { get; }
Public ReadOnly Property MaxXValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxXValueResolved Property

MicroXYDataPointCollectionViewMaxXValueResolved Property
Gets the maximum resolved value along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MaxXValueResolved { get; }
Public ReadOnly Property MaxXValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxYDataPoint Property

MicroXYDataPointCollectionViewMaxYDataPoint Property
Gets the maximum data point along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MaxYDataPoint { get; }
Public ReadOnly Property MaxYDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxYValue Property

MicroXYDataPointCollectionViewMaxYValue Property
Gets the maximum value along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MaxYValue { get; }
Public ReadOnly Property MaxYValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MaxYValueResolved Property

MicroXYDataPointCollectionViewMaxYValueResolved Property
Gets the maximum resolved value along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MaxYValueResolved { get; }
Public ReadOnly Property MaxYValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinXDataPoint Property

MicroXYDataPointCollectionViewMinXDataPoint Property
Gets the minimum data point along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MinXDataPoint { get; }
Public ReadOnly Property MinXDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinXValue Property

MicroXYDataPointCollectionViewMinXValue Property
Gets the minimum value along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MinXValue { get; }
Public ReadOnly Property MinXValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinXValueResolved Property

MicroXYDataPointCollectionViewMinXValueResolved Property
Gets the minimum resolved value along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MinXValueResolved { get; }
Public ReadOnly Property MinXValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinYDataPoint Property

MicroXYDataPointCollectionViewMinYDataPoint Property
Gets the minimum data point along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint MinYDataPoint { get; }
Public ReadOnly Property MinYDataPoint As MicroXYDataPoint
    Get

Property Value

Type: MicroXYDataPoint
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinYValue Property

MicroXYDataPointCollectionViewMinYValue Property
Gets the minimum value along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MinYValue { get; }
Public ReadOnly Property MinYValue As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.MinYValueResolved Property

MicroXYDataPointCollectionViewMinYValueResolved Property
Gets the minimum resolved value along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object MinYValueResolved { get; }
Public ReadOnly Property MinYValueResolved As Object
    Get

Property Value

Type: Object
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.XType Property

MicroXYDataPointCollectionViewXType Property
Gets the Type of data along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type XType { get; }
Public ReadOnly Property XType As Type
    Get

Property Value

Type: Type
The Type of data along the X-axis.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.YType Property

MicroXYDataPointCollectionViewYType Property
Gets the Type of data along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Type YType { get; }
Public ReadOnly Property YType As Type
    Get

Property Value

Type: Type
The Type of data along the X-axis.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView Methods

MicroXYDataPointCollectionView Methods

The MicroXYDataPointCollectionView type exposes the following members.

Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from MicroDataPointCollectionViewBaseT.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetItemFromXValue | Gets a MicroXYDataPoint associated with a specified X value, if that data is available.
Public method | GetItemFromYValue | Gets a MicroXYDataPoint associated with a specified Y value, if that data is available.
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index at which the specified item is located. (Inherited from MicroDataPointCollectionViewBaseT.)
Protected method | Initialize | Initializes this instance. (Overrides MicroDataPointCollectionViewBaseTInitialize.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.GetItemFromXValue Method

MicroXYDataPointCollectionViewGetItemFromXValue Method
Gets a MicroXYDataPoint associated with a specified X value, if that data is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint GetItemFromXValue(
    Object value
)
Public Function GetItemFromXValue (
    value As Object
) As MicroXYDataPoint

Parameters

value
Type: SystemObject
The X value.

Return Value

Type: MicroXYDataPoint
A MicroXYDataPoint associated with a specified X value, if that data is available.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.GetItemFromYValue Method

MicroXYDataPointCollectionViewGetItemFromYValue Method
Gets a MicroXYDataPoint associated with a specified Y value, if that data is available.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPoint GetItemFromYValue(
    Object value
)
Public Function GetItemFromYValue (
    value As Object
) As MicroXYDataPoint

Parameters

value
Type: SystemObject
The Y value.

Return Value

Type: MicroXYDataPoint
A MicroXYDataPoint associated with a specified Y value, if that data is available.
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYDataPointCollectionView.Initialize Method

MicroXYDataPointCollectionViewInitialize Method
Initializes this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void Initialize()
Protected Overrides Sub Initialize
See Also

Reference

MicroXYDataPointCollectionView Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange Class

MicroXYRange Class
Represents a range for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYRange

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroXYRange : Control
Public Class MicroXYRange
    Inherits Control

The MicroXYRange type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYRange | Initializes a new instance of the MicroXYRange class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this range.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotRange | Plots the range to the associated chart using the specified plotter.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the range based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange Constructor

MicroXYRange Constructor
Initializes a new instance of the MicroXYRange class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYRange()
Public Sub New
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange Properties

MicroXYRange Properties

The MicroXYRange type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this range.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value of the range. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value of the range. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the range. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.Chart Property

MicroXYRangeChart Property
Gets the MicroXYChart that owns this range.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYChart Chart { get; }
Public ReadOnly Property Chart As MicroXYChart
    Get

Property Value

Type: MicroXYChart
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.Maximum Property

MicroXYRangeMaximum Property
Gets or sets the maximum value of the range. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Maximum { get; set; }
Public Property Maximum As Object
    Get
    Set

Property Value

Type: Object
The maximum value of the range. The default value is .
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.Minimum Property

MicroXYRangeMinimum Property
Gets or sets the minimum value of the range. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object Minimum { get; set; }
Public Property Minimum As Object
    Get
    Set

Property Value

Type: Object
The minimum value of the range. The default value is .
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.Orientation Property

MicroXYRangeOrientation Property
Gets or sets the orientation of the range. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the range. The default value is Orientation.Horizontal.
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange Methods

MicroXYRange Methods

The MicroXYRange type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotRange | Plots the range to the associated chart using the specified plotter.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the range based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.PlotRange Method

MicroXYRangePlotRange Method
Plots the range to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void PlotRange(
    MicroXYChartPlotter plotter
)
Protected Overridable Sub PlotRange (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.Refresh Method

MicroXYRangeRefresh Method
Updates the range based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange Events

MicroXYRange Events

The MicroXYRange type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange Fields

MicroXYRange Fields

The MicroXYRange type exposes the following members.

Fields
Name | Description
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.MaximumProperty Field

MicroXYRangeMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.MinimumProperty Field

MicroXYRangeMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRange.OrientationProperty Field

MicroXYRangeOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroXYRange Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection Class

MicroXYRangeCollection Class
Represents a collection of MicroXYRange objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection MicroXYRange
System.Collections.ObjectModelObservableCollection MicroXYRange
ActiproSoftware.UI.XamlDeferrableObservableCollection MicroXYRange
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYRangeCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroXYRangeCollection : DeferrableObservableCollection<MicroXYRange>
Public Class MicroXYRangeCollection
    Inherits DeferrableObservableCollection(Of MicroXYRange)

The MicroXYRangeCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYRangeCollection | Initializes a new instance of the MicroXYRangeCollection class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection MicroXYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection MicroXYRange .)
Protected property | Items | (Inherited from Collection MicroXYRange .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection MicroXYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection MicroXYRange .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection MicroXYRange .)
Public method | Clear | (Inherited from Collection MicroXYRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection MicroXYRange .)
Public method | CopyTo | (Inherited from Collection MicroXYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection MicroXYRange .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection MicroXYRange .)
Public method | Insert | (Inherited from Collection MicroXYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection MicroXYRange .)
Protected method | MoveItem | (Inherited from ObservableCollection MicroXYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection MicroXYRange .)
Public method | RemoveAt | (Inherited from Collection MicroXYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection MicroXYRange .)
Protected event | PropertyChanged | (Inherited from ObservableCollection MicroXYRange .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection Constructor

MicroXYRangeCollection Constructor
Initializes a new instance of the MicroXYRangeCollection class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYRangeCollection(
    MicroXYChart chart
)
Public Sub New (
    chart As MicroXYChart
)

Parameters

chart
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYChart
The MicroXYChart that owns this collection and the associated ranges.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection Properties

MicroXYRangeCollection Properties

The MicroXYRangeCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection MicroXYRange .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection MicroXYRange .)
Protected property | Items | (Inherited from Collection MicroXYRange .)
Top
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection Methods

MicroXYRangeCollection Methods

The MicroXYRangeCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection MicroXYRange .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection MicroXYRange .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection MicroXYRange .)
Public method | Clear | (Inherited from Collection MicroXYRange .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection MicroXYRange .)
Public method | CopyTo | (Inherited from Collection MicroXYRange .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection MicroXYRange .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection MicroXYRange .)
Public method | Insert | (Inherited from Collection MicroXYRange .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection MicroXYRange .)
Protected method | MoveItem | (Inherited from ObservableCollection MicroXYRange .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection MicroXYRange .)
Public method | RemoveAt | (Inherited from Collection MicroXYRange .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection.ClearItems Method

MicroXYRangeCollectionClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection.InsertItem Method

MicroXYRangeCollectionInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    MicroXYRange item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As MicroXYRange
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYRange
The object to insert.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection.RemoveItem Method

MicroXYRangeCollectionRemoveItem Method
Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection.SetItem Method

MicroXYRangeCollectionSetItem Method
Replaces the element at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    MicroXYRange item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As MicroXYRange
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYRange
The new value for the element at the specified index.
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYRangeCollection Events

MicroXYRangeCollection Events

The MicroXYRangeCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection MicroXYRange .)
Protected event | PropertyChanged | (Inherited from ObservableCollection MicroXYRange .)
Top
See Also

Reference

MicroXYRangeCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection Class

MicroXYSeriesCollection Class
Represents a collection of MicroXYSeriesBase objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection MicroXYSeriesBase
System.Collections.ObjectModelObservableCollection MicroXYSeriesBase
ActiproSoftware.UI.XamlDeferrableObservableCollection MicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYSeriesCollection

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroXYSeriesCollection : DeferrableObservableCollection<MicroXYSeriesBase>
Public Class MicroXYSeriesCollection
    Inherits DeferrableObservableCollection(Of MicroXYSeriesBase)

The MicroXYSeriesCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYSeriesCollection | Initializes a new instance of the MicroXYChart class.
Top
Properties
 | Name | Description
Public property | Count | (Inherited from Collection MicroXYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection MicroXYSeriesBase .)
Protected property | Items | (Inherited from Collection MicroXYSeriesBase .)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from Collection MicroXYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection MicroXYSeriesBase .)
Public method | Clear | (Inherited from Collection MicroXYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection MicroXYSeriesBase .)
Public method | CopyTo | (Inherited from Collection MicroXYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection MicroXYSeriesBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection MicroXYSeriesBase .)
Public method | Insert | (Inherited from Collection MicroXYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | MoveItem | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection MicroXYSeriesBase .)
Public method | RemoveAt | (Inherited from Collection MicroXYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection MicroXYSeriesBase .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection Constructor

MicroXYSeriesCollection Constructor
Initializes a new instance of the MicroXYChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYSeriesCollection(
    MicroXYChart chart
)
Public Sub New (
    chart As MicroXYChart
)

Parameters

chart
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYChart
The MicroXYChart that owns this collection and the associated series.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection Properties

MicroXYSeriesCollection Properties

The MicroXYSeriesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from Collection MicroXYSeriesBase .)
Public property | IsDirty | Gets whether there are any suspended property changes. (Inherited from DeferrableObservableCollectionT.)
Public property | IsPropertyChangeSuspended | Gets whether property change notifications are currently suspended. (Inherited from DeferrableObservableCollectionT.)
Public property | Item | (Inherited from Collection MicroXYSeriesBase .)
Protected property | Items | (Inherited from Collection MicroXYSeriesBase .)
Top
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection Methods

MicroXYSeriesCollection Methods

The MicroXYSeriesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from Collection MicroXYSeriesBase .)
Public method | AddRange | Adds multiple items to the collection. (Inherited from DeferrableObservableCollectionT.)
Public method | BeginUpdate | Flags that a bulk update is about to begin. (Inherited from DeferrableObservableCollectionT.)
Protected method | BlockReentrancy | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | CheckReentrancy | (Inherited from ObservableCollection MicroXYSeriesBase .)
Public method | Clear | (Inherited from Collection MicroXYSeriesBase .)
Protected method | ClearItems | Removes all items from the collection. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | (Inherited from Collection MicroXYSeriesBase .)
Public method | CopyTo | (Inherited from Collection MicroXYSeriesBase .)
Public method | EndUpdate | Flags that a bulk update has ended. (Inherited from DeferrableObservableCollectionT.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | (Inherited from Collection MicroXYSeriesBase .)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | (Inherited from Collection MicroXYSeriesBase .)
Public method | Insert | (Inherited from Collection MicroXYSeriesBase .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Overrides DeferrableObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Move | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | MoveItem | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from DeferrableObservableCollectionT.)
Public method | Remove | (Inherited from Collection MicroXYSeriesBase .)
Public method | RemoveAt | (Inherited from Collection MicroXYSeriesBase .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides DeferrableObservableCollectionTSetItem(Int32, T).)
Public method | ToArray | Returns a strongly-typed array containing the items in this collection. (Inherited from DeferrableObservableCollectionT.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection.ClearItems Method

MicroXYSeriesCollectionClearItems Method
Removes all items from the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection.InsertItem Method

MicroXYSeriesCollectionInsertItem Method
Inserts an item into the collection at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    MicroXYSeriesBase item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As MicroXYSeriesBase
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The object to insert.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection.RemoveItem Method

MicroXYSeriesCollectionRemoveItem Method
Removes the item at the specified index of the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection.SetItem Method

MicroXYSeriesCollectionSetItem Method
Replaces the element at the specified index.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    MicroXYSeriesBase item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As MicroXYSeriesBase
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to replace.
item
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The new value for the element at the specified index.
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesCollection Events

MicroXYSeriesCollection Events

The MicroXYSeriesCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | (Inherited from ObservableCollection MicroXYSeriesBase .)
Protected event | PropertyChanged | (Inherited from ObservableCollection MicroXYSeriesBase .)
Top
See Also

Reference

MicroXYSeriesCollection Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind Class

MicroXYSeriesLineKind Class
Specifies the line kinds supported by a MicroLineSeries and MicroAreaSeries series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYSeriesLineKind

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroXYSeriesLineKind : Enum
Public NotInheritable Class MicroXYSeriesLineKind
    Inherits Enum

The MicroXYSeriesLineKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Normal | Indicates a normal line will be used to connect the data points.
 | Spline | Indicates a spline will be used to connect the data points.
 | Step | Indicates stepped lines will be used to connect the data points.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind Methods

MicroXYSeriesLineKind Methods

The MicroXYSeriesLineKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroXYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind Fields

MicroXYSeriesLineKind Fields

The MicroXYSeriesLineKind type exposes the following members.

Fields
 | Name | Description
 | Normal | Indicates a normal line will be used to connect the data points.
 | Spline | Indicates a spline will be used to connect the data points.
 | Step | Indicates stepped lines will be used to connect the data points.
Public field | value__ |
Top
See Also

Reference

MicroXYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind.Normal Field

MicroXYSeriesLineKindNormal Field
Indicates a normal line will be used to connect the data points.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroXYSeriesLineKind Normal = 0
Public Const Normal As MicroXYSeriesLineKind = 0

Field Value

Type: MicroXYSeriesLineKind
See Also

Reference

MicroXYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind.Spline Field

MicroXYSeriesLineKindSpline Field
Indicates a spline will be used to connect the data points.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroXYSeriesLineKind Spline = 1
Public Const Spline As MicroXYSeriesLineKind = 1

Field Value

Type: MicroXYSeriesLineKind
See Also

Reference

MicroXYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind.Step Field

MicroXYSeriesLineKindStep Field
Indicates stepped lines will be used to connect the data points.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroXYSeriesLineKind Step = 2
Public Const Step As MicroXYSeriesLineKind = 2

Field Value

Type: MicroXYSeriesLineKind
See Also

Reference

MicroXYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesLineKind.value__ Field

MicroXYSeriesLineKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroXYSeriesLineKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroXYSeriesLineKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind Class

MicroXYSeriesStackKind Class
Specifies the stacking methods supported by a MicroXYSeriesBase series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYSeriesStackKind

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroXYSeriesStackKind : Enum
Public NotInheritable Class MicroXYSeriesStackKind
    Inherits Enum

The MicroXYSeriesStackKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | Indicates the series will not be stacked.
 | Normal | Indicates the series will be stacked by adding its values to the values of other stacked series.
 | Percentage | Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind Methods

MicroXYSeriesStackKind Methods

The MicroXYSeriesStackKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroXYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind Fields

MicroXYSeriesStackKind Fields

The MicroXYSeriesStackKind type exposes the following members.

Fields
 | Name | Description
 | None | Indicates the series will not be stacked.
 | Normal | Indicates the series will be stacked by adding its values to the values of other stacked series.
 | Percentage | Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.
Public field | value__ |
Top
See Also

Reference

MicroXYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind.None Field

MicroXYSeriesStackKindNone Field
Indicates the series will not be stacked.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroXYSeriesStackKind None = 0
Public Const None As MicroXYSeriesStackKind = 0

Field Value

Type: MicroXYSeriesStackKind
See Also

Reference

MicroXYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind.Normal Field

MicroXYSeriesStackKindNormal Field
Indicates the series will be stacked by adding its values to the values of other stacked series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroXYSeriesStackKind Normal = 1
Public Const Normal As MicroXYSeriesStackKind = 1

Field Value

Type: MicroXYSeriesStackKind
See Also

Reference

MicroXYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind.Percentage Field

MicroXYSeriesStackKindPercentage Field
Indicates the series will be stacked by calculating percentages of its values based on the total values of all stacked series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroXYSeriesStackKind Percentage = 2
Public Const Percentage As MicroXYSeriesStackKind = 2

Field Value

Type: MicroXYSeriesStackKind
See Also

Reference

MicroXYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


MicroXYSeriesStackKind.value__ Field

MicroXYSeriesStackKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.MicroXYSeriesStackKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroXYSeriesStackKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts Namespace


ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace
Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | AutomationPeerBaseT | The base implementation for Automation Peers.


AutomationPeerBase(T) Class

AutomationPeerBaseT Class
The base implementation for Automation Peers.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.PeersAutomationPeerBaseT

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AutomationPeerBase<T> : FrameworkElementAutomationPeer
where T : FrameworkElement

Public Class AutomationPeerBase(Of T As FrameworkElement)
    Inherits FrameworkElementAutomationPeer

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers.AutomationPeerBase`1"]

The AutomationPeerBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | AutomationPeerBaseT | Initializes a new instance of the AutomationPeerBase class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T) Constructor

AutomationPeerBaseT Constructor
Initializes a new instance of the AutomationPeerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AutomationPeerBase(
    T owner
)
Public Sub New (
    owner As T
)

Parameters

owner
Type: T
The owner.
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T) Properties

AutomationPeerBaseT Properties

The AutomationPeerBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T) Methods

AutomationPeerBaseT Methods

The AutomationPeerBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAutomationId or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemStatus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLocalizedControlType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetName or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T).GetChildrenCore Method

AutomationPeerBaseTGetChildrenCore Method
Returns the collection of child elements of the UIElement that is associated with this FrameworkElementAutomationPeer. This method is called by GetChildren.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override IList<AutomationPeer> GetChildrenCore()
Protected Overrides Function GetChildrenCore As IList(Of AutomationPeer)

Return Value

Type: IList AutomationPeer
A list of child AutomationPeer elements.
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace


AutomationPeerBase(T).GetClassNameCore Method

AutomationPeerBaseTGetClassNameCore Method
Gets a human readable name that, in addition to AutomationControlType, differentiates the control represented by this AutomationPeer.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override string GetClassNameCore()
Protected Overrides Function GetClassNameCore As String

Return Value

Type: String
The string that contains the name.
See Also

Reference

AutomationPeerBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Automation.Peers Namespace


ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
Contains types related to micro chart palettes.
Classes
 | Class | Description
Public class | MicroColorSelectionHint | Specifies a hint for how a MicroSeriesPaletteStyleSelector should select colors for a series.
Public class | MicroPalette | Provides a palette of colors for use in charts.
Public class | MicroPaletteKind | Specifies the built-in palette options for a MicroSeriesPaletteStyleSelector.
Public class | MicroSeriesBrushKind | Specifies the kind of brush to use for a series element.
Public class | MicroSeriesPaletteStyleSelector | Provides a way to apply series styles based on a palette of colors.


MicroColorSelectionHint Class

MicroColorSelectionHint Class
Specifies a hint for how a MicroSeriesPaletteStyleSelector should select colors for a series.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroColorSelectionHint

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroColorSelectionHint : Enum
Public NotInheritable Class MicroColorSelectionHint
    Inherits Enum

The MicroColorSelectionHint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
 | UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroColorSelectionHint Methods

MicroColorSelectionHint Methods

The MicroColorSelectionHint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroColorSelectionHint Fields

MicroColorSelectionHint Fields

The MicroColorSelectionHint type exposes the following members.

Fields
 | Name | Description
 | Sequential | Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.
 | UniformDistribution | Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.
Public field | value__ |
Top
See Also

Reference

MicroColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroColorSelectionHint.Sequential Field

MicroColorSelectionHintSequential Field
Pick palette colors sequentially. The first series gets the first palette color. The second series gets the second palette color, and so on.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroColorSelectionHint Sequential = 0
Public Const Sequential As MicroColorSelectionHint = 0

Field Value

Type: MicroColorSelectionHint
See Also

Reference

MicroColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroColorSelectionHint.UniformDistribution Field

MicroColorSelectionHintUniformDistribution Field
Pick palette colors based on a uniform distribution. If the palette consists of nine base colors and the chart being rendered has three series, the first series gets one of the first three colors in the palette. The second series gets one of the middle three colors in the palette. And the third series gets one of the last three colors in the palette. If there are more series being rendered than base colors in the palette, fallback is to Sequential mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroColorSelectionHint UniformDistribution = 1
Public Const UniformDistribution As MicroColorSelectionHint = 1

Field Value

Type: MicroColorSelectionHint
See Also

Reference

MicroColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroColorSelectionHint.value__ Field

MicroColorSelectionHintvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes.MicroColorSelectionHint.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroColorSelectionHint Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Class

MicroPalette Class
Provides a palette of colors for use in charts.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroPalette

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroPalette
Public Class MicroPalette

The MicroPalette type exposes the following members.

Constructors
 | Name | Description
Public method | MicroPalette | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(Color) | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(MicroPaletteKind) | Initializes a new instance of the MicroPalette class.
Top
Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a MicroColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a MicroPaletteKind that indicates the built-in palette to use.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor

MicroPalette Constructor
Overload List
 | Name | Description
Public method | MicroPalette | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(Color) | Initializes a new instance of the MicroPalette class.
Public method | MicroPalette(MicroPaletteKind) | Initializes a new instance of the MicroPalette class.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor

MicroPalette Constructor
Initializes a new instance of the MicroPalette class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroPalette()
Public Sub New
See Also

Reference

MicroPalette Class
MicroPalette Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor (Color[])

MicroPalette Constructor (Color)
Initializes a new instance of the MicroPalette class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroPalette(
    params Color[] paletteBaseColors
)
Public Sub New (
    ParamArray paletteBaseColors As Color()
)

Parameters

paletteBaseColors
Type: Windows.UIColor
The palette Color values.
See Also

Reference

MicroPalette Class
MicroPalette Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Constructor (MicroPaletteKind)

MicroPalette Constructor (MicroPaletteKind)
Initializes a new instance of the MicroPalette class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroPalette(
    MicroPaletteKind kind
)
Public Sub New (
    kind As MicroPaletteKind
)

Parameters

kind
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroPaletteKind
A MicroPaletteKind that indicates the built-in palette to use.
See Also

Reference

MicroPalette Class
MicroPalette Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Properties

MicroPalette Properties

The MicroPalette type exposes the following members.

Properties
 | Name | Description
Public property | BaseColors | Gets the collection of palette base Color objects used to generate the palette.
Public property | Colors | Gets the read-only collection of Color objects in this palette.
Public property | ColorSelectionHint | Gets or sets a MicroColorSelectionHint that provides a hint on how to perform color selection for this palette.
Public property | IsShadeGenerationEnabled | Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.
Public property | Kind | Gets or sets a MicroPaletteKind that indicates the built-in palette to use.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette.BaseColors Property

MicroPaletteBaseColors Property
Gets the collection of palette base Color objects used to generate the palette.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ObservableCollection<Color> BaseColors { get; }
Public ReadOnly Property BaseColors As ObservableCollection(Of Color)
    Get

Property Value

Type: ObservableCollection Color
The collection of palette base Color objects used to generate the palette.
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette.Colors Property

MicroPaletteColors Property
Gets the read-only collection of Color objects in this palette.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ReadOnlyObservableCollection<Color> Colors { get; }
Public ReadOnly Property Colors As ReadOnlyObservableCollection(Of Color)
    Get

Property Value

Type: ReadOnlyObservableCollection Color
The read-only collection of Color objects in this palette.
Remarks
This collection includes the BaseColors values, along with other shade variants if the IsShadeGenerationEnabled property is set to true.
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroPaletteIsShadeGenerationEnabled


MicroPalette.ColorSelectionHint Property

MicroPaletteColorSelectionHint Property
Gets or sets a MicroColorSelectionHint that provides a hint on how to perform color selection for this palette.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroColorSelectionHint ColorSelectionHint { get; set; }
Public Property ColorSelectionHint As MicroColorSelectionHint
    Get
    Set

Property Value

Type: MicroColorSelectionHint
A MicroColorSelectionHint that provides a hint on how to perform color selection for this palette. The default hint is UniformDistribution.
Remarks
See the documentation on the MicroColorSelectionHint for more information on usage.
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette.IsShadeGenerationEnabled Property

MicroPaletteIsShadeGenerationEnabled Property
Gets or sets whether dark and light shade variants of the BaseColors will be appended to the Colors collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsShadeGenerationEnabled { get; set; }
Public Property IsShadeGenerationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if shade generation is enabled; otherwise, false.
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette.Kind Property

MicroPaletteKind Property
Gets or sets a MicroPaletteKind that indicates the built-in palette to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroPaletteKind Kind { get; set; }
Public Property Kind As MicroPaletteKind
    Get
    Set

Property Value

Type: MicroPaletteKind
A MicroPaletteKind that indicates the built-in palette to use.
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Methods

MicroPalette Methods

The MicroPalette type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnChanged | Raises the Changed event.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette.OnChanged Method

MicroPaletteOnChanged Method
Raises the Changed event.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnChanged(
    EventArgs e
)
Protected Overridable Sub OnChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
An EventArgs that contains the event data.
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette Events

MicroPalette Events

The MicroPalette type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs after the palette has been changed.
Top
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPalette.Changed Event

MicroPaletteChanged Event
Occurs after the palette has been changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler Changed
Public Event Changed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

MicroPalette Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind Class

MicroPaletteKind Class
Specifies the built-in palette options for a MicroSeriesPaletteStyleSelector.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroPaletteKind

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroPaletteKind : Enum
Public NotInheritable Class MicroPaletteKind
    Inherits Enum

The MicroPaletteKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Autumn | Red to green colors.
 | Beach | Blue, yellow, and green colors.
 | Default | The default colors.
 | Earth | Yellow and brown colors.
 | Fishbowl | Blue, tan, and orange colors.
 | Forest | Green, blue, and brown colors.
 | IceCream | Muted blue, beige, and pink colors.
 | Melon | Muted pastel colors.
 | Mesa | Blue/green, tan, and red colors.
 | Plum | Purple colors.
 | Rainbow | Rainbow colors.
 | Retro | Purple, orange, and green colors.
 | Roman | Red, tan, and blue colors.
 | Rose | Rose reddish colors.
 | Sand | Muted blue and tan colors.
 | Sea | Blue and green colors.
 | Tulip | Red, green, yellow, and purple colors.
Public field | value__ |
 | Vibrant | Magenta, blue, and green colors.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind Methods

MicroPaletteKind Methods

The MicroPaletteKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind Fields

MicroPaletteKind Fields

The MicroPaletteKind type exposes the following members.

Fields
 | Name | Description
 | Autumn | Red to green colors.
 | Beach | Blue, yellow, and green colors.
 | Default | The default colors.
 | Earth | Yellow and brown colors.
 | Fishbowl | Blue, tan, and orange colors.
 | Forest | Green, blue, and brown colors.
 | IceCream | Muted blue, beige, and pink colors.
 | Melon | Muted pastel colors.
 | Mesa | Blue/green, tan, and red colors.
 | Plum | Purple colors.
 | Rainbow | Rainbow colors.
 | Retro | Purple, orange, and green colors.
 | Roman | Red, tan, and blue colors.
 | Rose | Rose reddish colors.
 | Sand | Muted blue and tan colors.
 | Sea | Blue and green colors.
 | Tulip | Red, green, yellow, and purple colors.
Public field | value__ |
 | Vibrant | Magenta, blue, and green colors.
Top
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Autumn Field

MicroPaletteKindAutumn Field
Red to green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Autumn = 1
Public Const Autumn As MicroPaletteKind = 1

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Beach Field

MicroPaletteKindBeach Field
Blue, yellow, and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Beach = 2
Public Const Beach As MicroPaletteKind = 2

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Default Field

MicroPaletteKindDefault Field
The default colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Default = 0
Public Const Default As MicroPaletteKind = 0

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Earth Field

MicroPaletteKindEarth Field
Yellow and brown colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Earth = 3
Public Const Earth As MicroPaletteKind = 3

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Fishbowl Field

MicroPaletteKindFishbowl Field
Blue, tan, and orange colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Fishbowl = 4
Public Const Fishbowl As MicroPaletteKind = 4

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Forest Field

MicroPaletteKindForest Field
Green, blue, and brown colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Forest = 5
Public Const Forest As MicroPaletteKind = 5

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.IceCream Field

MicroPaletteKindIceCream Field
Muted blue, beige, and pink colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind IceCream = 6
Public Const IceCream As MicroPaletteKind = 6

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Melon Field

MicroPaletteKindMelon Field
Muted pastel colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Melon = 7
Public Const Melon As MicroPaletteKind = 7

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Mesa Field

MicroPaletteKindMesa Field
Blue/green, tan, and red colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Mesa = 8
Public Const Mesa As MicroPaletteKind = 8

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Plum Field

MicroPaletteKindPlum Field
Purple colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Plum = 9
Public Const Plum As MicroPaletteKind = 9

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Rainbow Field

MicroPaletteKindRainbow Field
Rainbow colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Rainbow = 10
Public Const Rainbow As MicroPaletteKind = 10

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Retro Field

MicroPaletteKindRetro Field
Purple, orange, and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Retro = 11
Public Const Retro As MicroPaletteKind = 11

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Roman Field

MicroPaletteKindRoman Field
Red, tan, and blue colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Roman = 12
Public Const Roman As MicroPaletteKind = 12

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Rose Field

MicroPaletteKindRose Field
Rose reddish colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Rose = 13
Public Const Rose As MicroPaletteKind = 13

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Sand Field

MicroPaletteKindSand Field
Muted blue and tan colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Sand = 14
Public Const Sand As MicroPaletteKind = 14

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Sea Field

MicroPaletteKindSea Field
Blue and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Sea = 15
Public Const Sea As MicroPaletteKind = 15

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Tulip Field

MicroPaletteKindTulip Field
Red, green, yellow, and purple colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Tulip = 16
Public Const Tulip As MicroPaletteKind = 16

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.value__ Field

MicroPaletteKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes.MicroPaletteKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroPaletteKind.Vibrant Field

MicroPaletteKindVibrant Field
Magenta, blue, and green colors.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroPaletteKind Vibrant = 17
Public Const Vibrant As MicroPaletteKind = 17

Field Value

Type: MicroPaletteKind
See Also

Reference

MicroPaletteKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind Class

MicroSeriesBrushKind Class
Specifies the kind of brush to use for a series element.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroSeriesBrushKind

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroSeriesBrushKind : Enum
Public NotInheritable Class MicroSeriesBrushKind
    Inherits Enum

The MicroSeriesBrushKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Complement | Use a complement of the Default color.
 | ComplementDark | Use a complement of the Dark color.
 | ComplementDarkToLightGradient | Use a gradient, from the ComplementDark to ComplementLight color.
 | ComplementLight | Use a complement of the Light color.
 | ComplementLightToDarkGradient | Use a gradient, from the ComplementLight to ComplementDark color.
 | ComplementSemiTransparent | Use a semi-transparent version of the Complement color.
 | Dark | Use a slightly darker version of the palette color.
 | DarkToLightGradient | Use a gradient, from the Dark to Light color.
 | Default | Use the exact palette color.
 | Light | Use a slightly lighter version of the palette color.
 | LightToDarkGradient | Use a gradient, from the Light to Dark color.
 | SemiTransparent | Use a semi-transparent version of the palette color.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind Methods

MicroSeriesBrushKind Methods

The MicroSeriesBrushKind type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind Fields

MicroSeriesBrushKind Fields

The MicroSeriesBrushKind type exposes the following members.

Fields
 | Name | Description
 | Complement | Use a complement of the Default color.
 | ComplementDark | Use a complement of the Dark color.
 | ComplementDarkToLightGradient | Use a gradient, from the ComplementDark to ComplementLight color.
 | ComplementLight | Use a complement of the Light color.
 | ComplementLightToDarkGradient | Use a gradient, from the ComplementLight to ComplementDark color.
 | ComplementSemiTransparent | Use a semi-transparent version of the Complement color.
 | Dark | Use a slightly darker version of the palette color.
 | DarkToLightGradient | Use a gradient, from the Dark to Light color.
 | Default | Use the exact palette color.
 | Light | Use a slightly lighter version of the palette color.
 | LightToDarkGradient | Use a gradient, from the Light to Dark color.
 | SemiTransparent | Use a semi-transparent version of the palette color.
Public field | value__ |
Top
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.Complement Field

MicroSeriesBrushKindComplement Field
Use a complement of the Default color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind Complement = 6
Public Const Complement As MicroSeriesBrushKind = 6

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.ComplementDark Field

MicroSeriesBrushKindComplementDark Field
Use a complement of the Dark color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind ComplementDark = 8
Public Const ComplementDark As MicroSeriesBrushKind = 8

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.ComplementDarkToLightGradient Field

MicroSeriesBrushKindComplementDarkToLightGradient Field
Use a gradient, from the ComplementDark to ComplementLight color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind ComplementDarkToLightGradient = 10
Public Const ComplementDarkToLightGradient As MicroSeriesBrushKind = 10

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.ComplementLight Field

MicroSeriesBrushKindComplementLight Field
Use a complement of the Light color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind ComplementLight = 7
Public Const ComplementLight As MicroSeriesBrushKind = 7

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.ComplementLightToDarkGradient Field

MicroSeriesBrushKindComplementLightToDarkGradient Field
Use a gradient, from the ComplementLight to ComplementDark color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind ComplementLightToDarkGradient = 11
Public Const ComplementLightToDarkGradient As MicroSeriesBrushKind = 11

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.ComplementSemiTransparent Field

MicroSeriesBrushKindComplementSemiTransparent Field
Use a semi-transparent version of the Complement color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind ComplementSemiTransparent = 9
Public Const ComplementSemiTransparent As MicroSeriesBrushKind = 9

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.Dark Field

MicroSeriesBrushKindDark Field
Use a slightly darker version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind Dark = 2
Public Const Dark As MicroSeriesBrushKind = 2

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.DarkToLightGradient Field

MicroSeriesBrushKindDarkToLightGradient Field
Use a gradient, from the Dark to Light color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind DarkToLightGradient = 4
Public Const DarkToLightGradient As MicroSeriesBrushKind = 4

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.Default Field

MicroSeriesBrushKindDefault Field
Use the exact palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind Default = 0
Public Const Default As MicroSeriesBrushKind = 0

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.Light Field

MicroSeriesBrushKindLight Field
Use a slightly lighter version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind Light = 1
Public Const Light As MicroSeriesBrushKind = 1

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.LightToDarkGradient Field

MicroSeriesBrushKindLightToDarkGradient Field
Use a gradient, from the Light to Dark color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind LightToDarkGradient = 5
Public Const LightToDarkGradient As MicroSeriesBrushKind = 5

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.SemiTransparent Field

MicroSeriesBrushKindSemiTransparent Field
Use a semi-transparent version of the palette color.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MicroSeriesBrushKind SemiTransparent = 3
Public Const SemiTransparent As MicroSeriesBrushKind = 3

Field Value

Type: MicroSeriesBrushKind
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesBrushKind.value__ Field

MicroSeriesBrushKindvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes.MicroSeriesBrushKind.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MicroSeriesBrushKind Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Class

MicroSeriesPaletteStyleSelector Class
Provides a way to apply series styles based on a palette of colors.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroSeriesStyleSelector
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroSeriesPaletteStyleSelector

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroSeriesPaletteStyleSelector : MicroSeriesStyleSelector
Public Class MicroSeriesPaletteStyleSelector
    Inherits MicroSeriesStyleSelector

The MicroSeriesPaletteStyleSelector type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesPaletteStyleSelector | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Public method | MicroSeriesPaletteStyleSelector(MicroPalette) | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Top
Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaHighBrushCustom | Gets or sets the custom Brush to use for the high area.
Public property | AreaHighBrushKind | Gets or sets the kind of brush to use for the high area.
Public property | AreaHighTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaHighBrushKind setting.
Public property | AreaLowBrushCustom | Gets or sets the custom Brush to use for the low area.
Public property | AreaLowBrushKind | Gets or sets the kind of brush to use for the low area.
Public property | AreaLowTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaLowBrushKind setting.
Public property | AreaNegativeBrushCustom | Gets or sets the custom Brush to use for negative areas.
Public property | AreaNegativeBrushKind | Gets or sets the kind of brush to use for negative areas.
Public property | AreaNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaNegativeBrushKind setting.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineNegativeBrushCustom | Gets or sets the custom Brush to use for negative lines.
Public property | LineNegativeBrushKind | Gets or sets the kind of brush to use for negative lines.
Public property | LineNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the LineNegativeBrushKind setting.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerFirstBrushCustom | Gets or sets the custom Brush to use for the first marker.
Public property | MarkerFirstBrushKind | Gets or sets the kind of brush to use for the first marker.
Public property | MarkerFirstTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerFirstBrushKind setting.
Public property | MarkerHighBrushCustom | Gets or sets the custom Brush to use for the high marker.
Public property | MarkerHighBrushKind | Gets or sets the kind of brush to use for the high marker.
Public property | MarkerHighTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerHighBrushKind setting.
Public property | MarkerLastBrushCustom | Gets or sets the custom Brush to use for the last marker.
Public property | MarkerLastBrushKind | Gets or sets the kind of brush to use for the last marker.
Public property | MarkerLastTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLastBrushKind setting.
Public property | MarkerLowBrushCustom | Gets or sets the custom Brush to use for the low marker.
Public property | MarkerLowBrushKind | Gets or sets the kind of brush to use for the low marker.
Public property | MarkerLowTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLowBrushKind setting.
Public property | MarkerNegativeBrushCustom | Gets or sets the custom Brush to use for negative markers.
Public property | MarkerNegativeBrushKind | Gets or sets the kind of brush to use for negative markers.
Public property | MarkerNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerNegativeBrushKind setting.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the MicroPalette of colors to use.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaHighStyle(MicroSeriesBase, Style).)
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaLowStyle(MicroSeriesBase, Style).)
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaStyle(MicroSeriesBase, Style).)
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLegendMarkerStyle(MicroXYSeriesBase, Style).)
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectLineStyle | Returns the line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerFirstStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerHighStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLastStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLowStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerStyle(MicroSeriesBase, Style).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Constructor

MicroSeriesPaletteStyleSelector Constructor
Overload List
 | Name | Description
Public method | MicroSeriesPaletteStyleSelector | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Public method | MicroSeriesPaletteStyleSelector(MicroPalette) | Initializes a new instance of the MicroSeriesPaletteStyleSelector class.
Top
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Constructor

MicroSeriesPaletteStyleSelector Constructor
Initializes a new instance of the MicroSeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesPaletteStyleSelector()
Public Sub New
See Also

Reference

MicroSeriesPaletteStyleSelector Class
MicroSeriesPaletteStyleSelector Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Constructor (MicroPalette)

MicroSeriesPaletteStyleSelector Constructor (MicroPalette)
Initializes a new instance of the MicroSeriesPaletteStyleSelector class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesPaletteStyleSelector(
    MicroPalette palette
)
Public Sub New (
    palette As MicroPalette
)

Parameters

palette
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PalettesMicroPalette
The MicroPalette of colors to use.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
MicroSeriesPaletteStyleSelector Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Properties

MicroSeriesPaletteStyleSelector Properties

The MicroSeriesPaletteStyleSelector type exposes the following members.

Properties
 | Name | Description
Public property | AreaBrushCustom | Gets or sets the custom Brush to use for areas.
Public property | AreaBrushKind | Gets or sets the kind of brush to use for areas.
Public property | AreaHighBrushCustom | Gets or sets the custom Brush to use for the high area.
Public property | AreaHighBrushKind | Gets or sets the kind of brush to use for the high area.
Public property | AreaHighTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaHighBrushKind setting.
Public property | AreaLowBrushCustom | Gets or sets the custom Brush to use for the low area.
Public property | AreaLowBrushKind | Gets or sets the kind of brush to use for the low area.
Public property | AreaLowTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaLowBrushKind setting.
Public property | AreaNegativeBrushCustom | Gets or sets the custom Brush to use for negative areas.
Public property | AreaNegativeBrushKind | Gets or sets the kind of brush to use for negative areas.
Public property | AreaNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaNegativeBrushKind setting.
Public property | AreaTintColor | Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.
Public property | LineBrushCustom | Gets or sets the custom Brush to use for lines.
Public property | LineBrushKind | Gets or sets the kind of brush to use for lines.
Public property | LineNegativeBrushCustom | Gets or sets the custom Brush to use for negative lines.
Public property | LineNegativeBrushKind | Gets or sets the kind of brush to use for negative lines.
Public property | LineNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the LineNegativeBrushKind setting.
Public property | LineTintColor | Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.
Public property | MarkerBrushCustom | Gets or sets the custom Brush to use for markers.
Public property | MarkerBrushKind | Gets or sets the kind of brush to use for markers.
Public property | MarkerFirstBrushCustom | Gets or sets the custom Brush to use for the first marker.
Public property | MarkerFirstBrushKind | Gets or sets the kind of brush to use for the first marker.
Public property | MarkerFirstTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerFirstBrushKind setting.
Public property | MarkerHighBrushCustom | Gets or sets the custom Brush to use for the high marker.
Public property | MarkerHighBrushKind | Gets or sets the kind of brush to use for the high marker.
Public property | MarkerHighTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerHighBrushKind setting.
Public property | MarkerLastBrushCustom | Gets or sets the custom Brush to use for the last marker.
Public property | MarkerLastBrushKind | Gets or sets the kind of brush to use for the last marker.
Public property | MarkerLastTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLastBrushKind setting.
Public property | MarkerLowBrushCustom | Gets or sets the custom Brush to use for the low marker.
Public property | MarkerLowBrushKind | Gets or sets the kind of brush to use for the low marker.
Public property | MarkerLowTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerLowBrushKind setting.
Public property | MarkerNegativeBrushCustom | Gets or sets the custom Brush to use for negative markers.
Public property | MarkerNegativeBrushKind | Gets or sets the kind of brush to use for negative markers.
Public property | MarkerNegativeTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerNegativeBrushKind setting.
Public property | MarkerTintColor | Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.
Public property | Palette | Gets or sets the MicroPalette of colors to use.
Top
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.AreaBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaBrushCustom Property
Gets or sets the custom Brush to use for areas.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaBrushCustom { get; set; }
Public Property AreaBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for areas.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaBrushKind


MicroSeriesPaletteStyleSelector.AreaBrushKind Property

MicroSeriesPaletteStyleSelectorAreaBrushKind Property
Gets or sets the kind of brush to use for areas.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaBrushKind { get; set; }
Public Property AreaBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for areas.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaBrushCustom
MicroSeriesPaletteStyleSelectorAreaTintColor


MicroSeriesPaletteStyleSelector.AreaHighBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaHighBrushCustom Property
Gets or sets the custom Brush to use for the high area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaHighBrushCustom { get; set; }
Public Property AreaHighBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the high area.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaHighBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaHighBrushKind


MicroSeriesPaletteStyleSelector.AreaHighBrushKind Property

MicroSeriesPaletteStyleSelectorAreaHighBrushKind Property
Gets or sets the kind of brush to use for the high area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaHighBrushKind { get; set; }
Public Property AreaHighBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the high area.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaHighBrushCustom
MicroSeriesPaletteStyleSelectorAreaHighTintColor


MicroSeriesPaletteStyleSelector.AreaHighTintColor Property

MicroSeriesPaletteStyleSelectorAreaHighTintColor Property
Gets or sets the tint color to apply to the resulting brush from the AreaHighBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaHighTintColor { get; set; }
Public Property AreaHighTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaHighBrushKind


MicroSeriesPaletteStyleSelector.AreaLowBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaLowBrushCustom Property
Gets or sets the custom Brush to use for the low area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaLowBrushCustom { get; set; }
Public Property AreaLowBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the low area.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaLowBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaLowBrushKind


MicroSeriesPaletteStyleSelector.AreaLowBrushKind Property

MicroSeriesPaletteStyleSelectorAreaLowBrushKind Property
Gets or sets the kind of brush to use for the low area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaLowBrushKind { get; set; }
Public Property AreaLowBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the low area.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaLowBrushCustom
MicroSeriesPaletteStyleSelectorAreaLowTintColor


MicroSeriesPaletteStyleSelector.AreaLowTintColor Property

MicroSeriesPaletteStyleSelectorAreaLowTintColor Property
Gets or sets the tint color to apply to the resulting brush from the AreaLowBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaLowTintColor { get; set; }
Public Property AreaLowTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaLowBrushKind


MicroSeriesPaletteStyleSelector.AreaNegativeBrushCustom Property

MicroSeriesPaletteStyleSelectorAreaNegativeBrushCustom Property
Gets or sets the custom Brush to use for negative areas.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush AreaNegativeBrushCustom { get; set; }
Public Property AreaNegativeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for negative areas.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the AreaNegativeBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaNegativeBrushKind


MicroSeriesPaletteStyleSelector.AreaNegativeBrushKind Property

MicroSeriesPaletteStyleSelectorAreaNegativeBrushKind Property
Gets or sets the kind of brush to use for negative areas.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind AreaNegativeBrushKind { get; set; }
Public Property AreaNegativeBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for negative areas.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaNegativeBrushCustom
MicroSeriesPaletteStyleSelectorAreaNegativeTintColor


MicroSeriesPaletteStyleSelector.AreaNegativeTintColor Property

MicroSeriesPaletteStyleSelectorAreaNegativeTintColor Property
Gets or sets the tint color to apply to the resulting brush from the AreaNegativeBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaNegativeTintColor { get; set; }
Public Property AreaNegativeTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaNegativeBrushKind


MicroSeriesPaletteStyleSelector.AreaTintColor Property

MicroSeriesPaletteStyleSelectorAreaTintColor Property
Gets or sets the tint color to apply to the resulting brush from the AreaBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> AreaTintColor { get; set; }
Public Property AreaTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorAreaBrushKind


MicroSeriesPaletteStyleSelector.LineBrushCustom Property

MicroSeriesPaletteStyleSelectorLineBrushCustom Property
Gets or sets the custom Brush to use for lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineBrushCustom { get; set; }
Public Property LineBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for lines.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the LineBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineBrushKind


MicroSeriesPaletteStyleSelector.LineBrushKind Property

MicroSeriesPaletteStyleSelectorLineBrushKind Property
Gets or sets the kind of brush to use for lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind LineBrushKind { get; set; }
Public Property LineBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for lines.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineBrushCustom
MicroSeriesPaletteStyleSelectorLineTintColor


MicroSeriesPaletteStyleSelector.LineNegativeBrushCustom Property

MicroSeriesPaletteStyleSelectorLineNegativeBrushCustom Property
Gets or sets the custom Brush to use for negative lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineNegativeBrushCustom { get; set; }
Public Property LineNegativeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for negative lines.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the LineNegativeBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineNegativeBrushKind


MicroSeriesPaletteStyleSelector.LineNegativeBrushKind Property

MicroSeriesPaletteStyleSelectorLineNegativeBrushKind Property
Gets or sets the kind of brush to use for negative lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind LineNegativeBrushKind { get; set; }
Public Property LineNegativeBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for negative lines.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineNegativeBrushCustom
MicroSeriesPaletteStyleSelectorLineNegativeTintColor


MicroSeriesPaletteStyleSelector.LineNegativeTintColor Property

MicroSeriesPaletteStyleSelectorLineNegativeTintColor Property
Gets or sets the tint color to apply to the resulting brush from the LineNegativeBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> LineNegativeTintColor { get; set; }
Public Property LineNegativeTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineNegativeBrushKind


MicroSeriesPaletteStyleSelector.LineTintColor Property

MicroSeriesPaletteStyleSelectorLineTintColor Property
Gets or sets the tint color to apply to the resulting brush from the LineBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> LineTintColor { get; set; }
Public Property LineTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorLineBrushKind


MicroSeriesPaletteStyleSelector.MarkerBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerBrushCustom Property
Gets or sets the custom Brush to use for markers.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerBrushCustom { get; set; }
Public Property MarkerBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for markers.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerBrushKind


MicroSeriesPaletteStyleSelector.MarkerBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerBrushKind Property
Gets or sets the kind of brush to use for markers.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerBrushKind { get; set; }
Public Property MarkerBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for markers.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerBrushCustom
MicroSeriesPaletteStyleSelectorMarkerTintColor


MicroSeriesPaletteStyleSelector.MarkerFirstBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerFirstBrushCustom Property
Gets or sets the custom Brush to use for the first marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerFirstBrushCustom { get; set; }
Public Property MarkerFirstBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the first marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerFirstBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerFirstBrushKind


MicroSeriesPaletteStyleSelector.MarkerFirstBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerFirstBrushKind Property
Gets or sets the kind of brush to use for the first marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerFirstBrushKind { get; set; }
Public Property MarkerFirstBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the first marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerFirstBrushCustom
MicroSeriesPaletteStyleSelectorMarkerFirstTintColor


MicroSeriesPaletteStyleSelector.MarkerFirstTintColor Property

MicroSeriesPaletteStyleSelectorMarkerFirstTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerFirstBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerFirstTintColor { get; set; }
Public Property MarkerFirstTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerFirstBrushKind


MicroSeriesPaletteStyleSelector.MarkerHighBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerHighBrushCustom Property
Gets or sets the custom Brush to use for the high marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerHighBrushCustom { get; set; }
Public Property MarkerHighBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the high marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerHighBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerHighBrushKind


MicroSeriesPaletteStyleSelector.MarkerHighBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerHighBrushKind Property
Gets or sets the kind of brush to use for the high marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerHighBrushKind { get; set; }
Public Property MarkerHighBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the high marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerHighBrushCustom
MicroSeriesPaletteStyleSelectorMarkerHighTintColor


MicroSeriesPaletteStyleSelector.MarkerHighTintColor Property

MicroSeriesPaletteStyleSelectorMarkerHighTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerHighBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerHighTintColor { get; set; }
Public Property MarkerHighTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerHighBrushKind


MicroSeriesPaletteStyleSelector.MarkerLastBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerLastBrushCustom Property
Gets or sets the custom Brush to use for the last marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerLastBrushCustom { get; set; }
Public Property MarkerLastBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the last marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerLastBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLastBrushKind


MicroSeriesPaletteStyleSelector.MarkerLastBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerLastBrushKind Property
Gets or sets the kind of brush to use for the last marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerLastBrushKind { get; set; }
Public Property MarkerLastBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the last marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLastBrushCustom
MicroSeriesPaletteStyleSelectorMarkerLastTintColor


MicroSeriesPaletteStyleSelector.MarkerLastTintColor Property

MicroSeriesPaletteStyleSelectorMarkerLastTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerLastBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerLastTintColor { get; set; }
Public Property MarkerLastTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLastBrushKind


MicroSeriesPaletteStyleSelector.MarkerLowBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerLowBrushCustom Property
Gets or sets the custom Brush to use for the low marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerLowBrushCustom { get; set; }
Public Property MarkerLowBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for the low marker.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerLowBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLowBrushKind


MicroSeriesPaletteStyleSelector.MarkerLowBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerLowBrushKind Property
Gets or sets the kind of brush to use for the low marker.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerLowBrushKind { get; set; }
Public Property MarkerLowBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for the low marker.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLowBrushCustom
MicroSeriesPaletteStyleSelectorMarkerLowTintColor


MicroSeriesPaletteStyleSelector.MarkerLowTintColor Property

MicroSeriesPaletteStyleSelectorMarkerLowTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerLowBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerLowTintColor { get; set; }
Public Property MarkerLowTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerLowBrushKind


MicroSeriesPaletteStyleSelector.MarkerNegativeBrushCustom Property

MicroSeriesPaletteStyleSelectorMarkerNegativeBrushCustom Property
Gets or sets the custom Brush to use for negative markers.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush MarkerNegativeBrushCustom { get; set; }
Public Property MarkerNegativeBrushCustom As Brush
    Get
    Set

Property Value

Type: Brush
The custom Brush to use for negative markers.
Remarks
When specified, this brush will directly be used instead of the resulting brush from the MarkerNegativeBrushKind setting.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerNegativeBrushKind


MicroSeriesPaletteStyleSelector.MarkerNegativeBrushKind Property

MicroSeriesPaletteStyleSelectorMarkerNegativeBrushKind Property
Gets or sets the kind of brush to use for negative markers.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesBrushKind MarkerNegativeBrushKind { get; set; }
Public Property MarkerNegativeBrushKind As MicroSeriesBrushKind
    Get
    Set

Property Value

Type: MicroSeriesBrushKind
A MicroSeriesBrushKind indicating the kind of brush to use for negative markers.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerNegativeBrushCustom
MicroSeriesPaletteStyleSelectorAreaHighTintColor


MicroSeriesPaletteStyleSelector.MarkerNegativeTintColor Property

MicroSeriesPaletteStyleSelectorMarkerNegativeTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerNegativeBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerNegativeTintColor { get; set; }
Public Property MarkerNegativeTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerNegativeBrushKind


MicroSeriesPaletteStyleSelector.MarkerTintColor Property

MicroSeriesPaletteStyleSelectorMarkerTintColor Property
Gets or sets the tint color to apply to the resulting brush from the MarkerBrushKind setting.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Nullable<Color> MarkerTintColor { get; set; }
Public Property MarkerTintColor As Nullable(Of Color)
    Get
    Set

Property Value

Type: Nullable Color
The tint color, if tinting should be applied.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace
MicroSeriesPaletteStyleSelectorMarkerBrushKind


MicroSeriesPaletteStyleSelector.Palette Property

MicroSeriesPaletteStyleSelectorPalette Property
Gets or sets the MicroPalette of colors to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroPalette Palette { get; set; }
Public Property Palette As MicroPalette
    Get
    Set

Property Value

Type: MicroPalette
The MicroPalette of colors to use.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector Methods

MicroSeriesPaletteStyleSelector Methods

The MicroSeriesPaletteStyleSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SelectAreaHighStyle | Returns the high area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaHighStyle(MicroSeriesBase, Style).)
Public method | SelectAreaLowStyle | Returns the low area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaLowStyle(MicroSeriesBase, Style).)
Public method | SelectAreaNegativeStyle | Returns the negative area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectAreaStyle | Returns the area Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectAreaStyle(MicroSeriesBase, Style).)
Public method | SelectLegendMarkerStyle | Returns the legend marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLegendMarkerStyle(MicroXYSeriesBase, Style).)
Public method | SelectLineNegativeStyle | Returns the negative line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectLineStyle | Returns the line Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectLineStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerFirstStyle | Returns the first marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerFirstStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerHighStyle | Returns the high marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerHighStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLastStyle | Returns the last marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLastStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerLowStyle | Returns the low marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerLowStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerNegativeStyle | Returns the negative marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerNegativeStyle(MicroSeriesBase, Style).)
Public method | SelectMarkerStyle | Returns the marker Style to use for the specified series. (Overrides MicroSeriesStyleSelectorSelectMarkerStyle(MicroSeriesBase, Style).)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaHighStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaHighStyle Method
Returns the high area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectAreaHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaLowStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaLowStyle Method
Returns the low area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectAreaLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaNegativeStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaNegativeStyle Method
Returns the negative area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectAreaNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectAreaStyle Method

MicroSeriesPaletteStyleSelectorSelectAreaStyle Method
Returns the area Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectAreaStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectAreaStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectLegendMarkerStyle Method

MicroSeriesPaletteStyleSelectorSelectLegendMarkerStyle Method
Returns the legend marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectLegendMarkerStyle(
    MicroXYSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectLegendMarkerStyle (
    series As MicroXYSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectLineNegativeStyle Method

MicroSeriesPaletteStyleSelectorSelectLineNegativeStyle Method
Returns the negative line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectLineNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectLineNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectLineStyle Method

MicroSeriesPaletteStyleSelectorSelectLineStyle Method
Returns the line Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectLineStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectLineStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerFirstStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerFirstStyle Method
Returns the first marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectMarkerFirstStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerFirstStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerHighStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerHighStyle Method
Returns the high marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectMarkerHighStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerHighStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerLastStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerLastStyle Method
Returns the last marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectMarkerLastStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerLastStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerLowStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerLowStyle Method
Returns the low marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectMarkerLowStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerLowStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerNegativeStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerNegativeStyle Method
Returns the negative marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectMarkerNegativeStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerNegativeStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


MicroSeriesPaletteStyleSelector.SelectMarkerStyle Method

MicroSeriesPaletteStyleSelectorSelectMarkerStyle Method
Returns the marker Style to use for the specified series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override Style SelectMarkerStyle(
    MicroSeriesBase series,
    Style defaultStyle
)
Public Overrides Function SelectMarkerStyle (
    series As MicroSeriesBase,
    defaultStyle As Style
) As Style

Parameters

series
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
The series to examine.
defaultStyle
Type: Windows.UI.XamlStyle
The default Style to use.

Return Value

Type: Style
The Style to use for the specified series.
See Also

Reference

MicroSeriesPaletteStyleSelector Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Palettes Namespace


ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace
Contains the primitive classes used for micro charts.
Classes
 | Class | Description
Public class | InvalidPropertyPathException | InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Public class | MicroBarSeriesBase | Represents a base class for bar series used in a MicroXYChart.
Public class | MicroChartBase | Provides the base class for a micro chart control.
Public class | MicroChartCanvas | Represents a panel were child elements are positioned using explicit/relative coordinates.
Public class | MicroDataPointBase | Represents a base class for a data point presented by a chart series.
Public class | MicroDataPointCollectionViewBaseT | Represents a base class for collection views into a source collection.
Public class | MicroLegendItem | Represents an item used in a chart legend.
Public class | MicroLineSeriesBase | Represents a base class for line and area series for use in a MicroXYChart.
Public class | MicroSeriesBase | Provides the base class for a micro series.
Public class | MicroSeriesItemsSourceConverter | Represents a type converter for the ItemsSource type.
Public class | MicroXYChartPlotter | Represents a class that is capable of plotting various shapes on to a MicroXYChart.
Public class | MicroXYSeriesBase | Provides the base class for a micro series that uses an X/Y axis.
Interfaces
 | Interface | Description
Public interface | IMicroXYAxis | Provides the base requirements for a axis used by a MicroXYChart.


IMicroXYAxis Interface

IMicroXYAxis Interface
Provides the base requirements for a axis used by a MicroXYChart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IMicroXYAxis
Public Interface IMicroXYAxis

The IMicroXYAxis type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline value for the axis.
Public property | Maximum | Gets the maximum value of the axis.
Public property | Minimum | Gets the minimum value of the axis.
Public property | SlotCount | Gets the number of slots for data points of the axis when using slotted layout.
Top
Methods
 | Name | Description
Public method | GetPercentagePosition | Gets a plot coordinate for the specified value using it's overall percentage for the given key.
Public method | GetPosition | Gets a plot coordinate for the specified value.
Public method | GetValue | Gets a value for the specified plot coordinate.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis Properties

IMicroXYAxis Properties

The IMicroXYAxis type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the baseline value for the axis.
Public property | Maximum | Gets the maximum value of the axis.
Public property | Minimum | Gets the minimum value of the axis.
Public property | SlotCount | Gets the number of slots for data points of the axis when using slotted layout.
Top
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.Baseline Property

IMicroXYAxisBaseline Property
Gets the baseline value for the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Baseline { get; }
ReadOnly Property Baseline As Object
    Get

Property Value

Type: Object
The baseline value for the axis.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.Maximum Property

IMicroXYAxisMaximum Property
Gets the maximum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Maximum { get; }
ReadOnly Property Maximum As Object
    Get

Property Value

Type: Object
The maximum value of the axis.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.Minimum Property

IMicroXYAxisMinimum Property
Gets the minimum value of the axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Minimum { get; }
ReadOnly Property Minimum As Object
    Get

Property Value

Type: Object
The minimum value of the axis.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.SlotCount Property

IMicroXYAxisSlotCount Property
Gets the number of slots for data points of the axis when using slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int SlotCount { get; }
ReadOnly Property SlotCount As Integer
    Get

Property Value

Type: Int32
The number of slots for data points of the axis when using slotted layout.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis Methods

IMicroXYAxis Methods

The IMicroXYAxis type exposes the following members.

Methods
 | Name | Description
Public method | GetPercentagePosition | Gets a plot coordinate for the specified value using it's overall percentage for the given key.
Public method | GetPosition | Gets a plot coordinate for the specified value.
Public method | GetValue | Gets a value for the specified plot coordinate.
Top
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.GetPercentagePosition Method

IMicroXYAxisGetPercentagePosition Method
Gets a plot coordinate for the specified value using it's overall percentage for the given key.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double GetPercentagePosition(
    Object key,
    Object value
)
Function GetPercentagePosition (
    key As Object,
    value As Object
) As Double

Parameters

key
Type: SystemObject
The key associated with the specified value.
value
Type: SystemObject
The value whose position should be returned.

Return Value

Type: Double
A plot coordinate for the specified value using it's overall percentage for the given key.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.GetPosition Method

IMicroXYAxisGetPosition Method
Gets a plot coordinate for the specified value.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double GetPosition(
    Object value
)
Function GetPosition (
    value As Object
) As Double

Parameters

value
Type: SystemObject
The value whose position should be returned.

Return Value

Type: Double
A plot coordinate for the specified value.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


IMicroXYAxis.GetValue Method

IMicroXYAxisGetValue Method
Gets a value for the specified plot coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object GetValue(
    double position
)
Function GetValue (
    position As Double
) As Object

Parameters

position
Type: SystemDouble
A plot coordinate whose value should be returned.

Return Value

Type: Object
A value for the specified plot coordinate.
See Also

Reference

IMicroXYAxis Interface
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Class

InvalidPropertyPathException Class
InvalidPropertyPathException is an exception for use when a PropertyPath is invalid.
Inheritance Hierarchy
SystemObject
SystemException
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesInvalidPropertyPathException

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class InvalidPropertyPathException : Exception
Public Class InvalidPropertyPathException
    Inherits Exception

The InvalidPropertyPathException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor

InvalidPropertyPathException Constructor
Overload List
 | Name | Description
Public method | InvalidPropertyPathException | Initializes a new instance of the InvalidPropertyPathException class.
Public method | InvalidPropertyPathException(String) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message.
Public method | InvalidPropertyPathException(String, Exception) | Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor

InvalidPropertyPathException Constructor
Initializes a new instance of the InvalidPropertyPathException class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException()
Public Sub New
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor (String)

InvalidPropertyPathException Constructor (String)
Initializes a new instance of the InvalidPropertyPathException class with a specified error message.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Constructor (String, Exception)

InvalidPropertyPathException Constructor (String, Exception)
Initializes a new instance of the InvalidPropertyPathException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public InvalidPropertyPathException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
See Also

Reference

InvalidPropertyPathException Class
InvalidPropertyPathException Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Properties

InvalidPropertyPathException Properties

The InvalidPropertyPathException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


InvalidPropertyPathException Methods

InvalidPropertyPathException Methods

The InvalidPropertyPathException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

InvalidPropertyPathException Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Class

MicroBarSeriesBase Class
Represents a base class for bar series used in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroBarSeries
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroWinLossSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroBarSeriesBase : MicroXYSeriesBase
Public MustInherit Class MicroBarSeriesBase
    Inherits MicroXYSeriesBase

The MicroBarSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroBarSeriesBase | Initializes a new instance of the MicroBarSeriesBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property.
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property.
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Overrides MicroSeriesBaseLogicalOrientation.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides MicroXYSeriesBaseRequiresSlottedLayout.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BarHighStyleProperty | Identifies the BarHighStyle dependency property. This field is read-only.
BarLowStyleProperty | Identifies the BarLowStyle dependency property. This field is read-only.
BarNegativeStyleProperty | Identifies the BarNegativeStyle dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
BarStyleKindsProperty | Identifies the BarStyleKinds dependency property. This field is read-only.
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Constructor

MicroBarSeriesBase Constructor
Initializes a new instance of the MicroBarSeriesBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroBarSeriesBase()
Protected Sub New
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Properties

MicroBarSeriesBase Properties

The MicroBarSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BarHighStyle | Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property.
Public property | BarLowStyle | Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property.
Public property | BarNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarSpacing | Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.
Public property | BarStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | BarStyleKinds | Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property.
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Overrides MicroSeriesBaseLogicalOrientation.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of the series. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Overrides MicroXYSeriesBaseRequiresSlottedLayout.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarHighStyle Property

MicroBarSeriesBaseBarHighStyle Property
Gets or sets a Style, which is applied to the Shape element used to render the high bar along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style BarHighStyle { get; set; }
Public Property BarHighStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the high bar along the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarLowStyle Property

MicroBarSeriesBaseBarLowStyle Property
Gets or sets a Style, which is applied to the Shape element used to render the low bar along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style BarLowStyle { get; set; }
Public Property BarLowStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape element used to render the low bar along the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarNegativeStyle Property

MicroBarSeriesBaseBarNegativeStyle Property
Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style BarNegativeStyle { get; set; }
Public Property BarNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarSpacing Property

MicroBarSeriesBaseBarSpacing Property
Gets or sets the amount of spacing applied to either side of the individual bar shapes. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Unit BarSpacing { get; set; }
Public Property BarSpacing As Unit
    Get
    Set

Property Value

Type: Unit
The amount of spacing applied to either side of the individual bar shapes. The default value is 1px.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyle Property

MicroBarSeriesBaseBarStyle Property
Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style BarStyle { get; set; }
Public Property BarStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyleKinds Property

MicroBarSeriesBaseBarStyleKinds Property
Gets or sets a MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroBarSeriesStyleKinds BarStyleKinds { get; set; }
Public Property BarStyleKinds As MicroBarSeriesStyleKinds
    Get
    Set

Property Value

Type: MicroBarSeriesStyleKinds
A MicroBarSeriesStyleKinds which indicates what style kinds are used for bars along the series. The default value is MicroBarSeriesStyleKinds.None.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.LogicalOrientation Property

MicroBarSeriesBaseLogicalOrientation Property
Gets the logical orientation of the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Orientation LogicalOrientation { get; }
Protected Overrides ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.MarkerVisibility Property

MicroBarSeriesBaseMarkerVisibility Property
Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As MicroChartMarkerVisibility
    Get
    Set

Property Value

Type: MicroChartMarkerVisibility
A MicroChartMarkerVisibility indicating which markers are rendered along the series. The default value is MicroChartMarkerVisibility.None.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.Orientation Property

MicroBarSeriesBaseOrientation Property
Gets or sets the orientation of the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Orientation Orientation { get; set; }
Public Property Orientation As Orientation
    Get
    Set

Property Value

Type: Orientation
The orientation of the series. The default value is Orientation.Horizontal.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.RequiresSlottedLayout Property

MicroBarSeriesBaseRequiresSlottedLayout Property
Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override bool RequiresSlottedLayout { get; }
Protected Overrides ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Methods

MicroBarSeriesBase Methods

The MicroBarSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Overrides MicroXYSeriesBasePlotSeries(MicroXYChartPlotter).)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.GetMinimumMargin Method

MicroBarSeriesBaseGetMinimumMargin Method
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> GetMinimumMargin()
Protected Overrides Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.PlotSeries Method

MicroBarSeriesBasePlotSeries Method
Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overrides Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Events

MicroBarSeriesBase Events

The MicroBarSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase Fields

MicroBarSeriesBase Fields

The MicroBarSeriesBase type exposes the following members.

Fields
Name | Description
BarHighStyleProperty | Identifies the BarHighStyle dependency property. This field is read-only.
BarLowStyleProperty | Identifies the BarLowStyle dependency property. This field is read-only.
BarNegativeStyleProperty | Identifies the BarNegativeStyle dependency property. This field is read-only.
BarSpacingProperty | Identifies the BarSpacing dependency property. This field is read-only.
BarStyleKindsProperty | Identifies the BarStyleKinds dependency property. This field is read-only.
BarStyleProperty | Identifies the BarStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
OrientationProperty | Identifies the Orientation dependency property. This field is read-only.
Top
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarHighStyleProperty Field

MicroBarSeriesBaseBarHighStyleProperty Field
Identifies the BarHighStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarHighStyleProperty
Public Shared ReadOnly BarHighStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarHighStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarLowStyleProperty Field

MicroBarSeriesBaseBarLowStyleProperty Field
Identifies the BarLowStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarLowStyleProperty
Public Shared ReadOnly BarLowStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarLowStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarNegativeStyleProperty Field

MicroBarSeriesBaseBarNegativeStyleProperty Field
Identifies the BarNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarNegativeStyleProperty
Public Shared ReadOnly BarNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarNegativeStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarSpacingProperty Field

MicroBarSeriesBaseBarSpacingProperty Field
Identifies the BarSpacing dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarSpacingProperty
Public Shared ReadOnly BarSpacingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarSpacing dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyleKindsProperty Field

MicroBarSeriesBaseBarStyleKindsProperty Field
Identifies the BarStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarStyleKindsProperty
Public Shared ReadOnly BarStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarStyleKinds dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.BarStyleProperty Field

MicroBarSeriesBaseBarStyleProperty Field
Identifies the BarStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty BarStyleProperty
Public Shared ReadOnly BarStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the BarStyle dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.MarkerVisibilityProperty Field

MicroBarSeriesBaseMarkerVisibilityProperty Field
Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroBarSeriesBase.OrientationProperty Field

MicroBarSeriesBaseOrientationProperty Field
Identifies the Orientation dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OrientationProperty
Public Shared ReadOnly OrientationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Orientation dependency property.
See Also

Reference

MicroBarSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase Class

MicroChartBase Class
Provides the base class for a micro chart control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroChartBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYChart

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroChartBase : Control
Public MustInherit Class MicroChartBase
    Inherits Control

The MicroChartBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroChartBase | Initializes a new instance of the MicroChartBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase Constructor

MicroChartBase Constructor
Initializes a new instance of the MicroChartBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroChartBase()
Protected Sub New
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase Properties

MicroChartBase Properties

The MicroChartBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase.SeriesStyleSelector Property

MicroChartBaseSeriesStyleSelector Property
Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelector SeriesStyleSelector { get; set; }
Public Property SeriesStyleSelector As MicroSeriesStyleSelector
    Get
    Set

Property Value

Type: MicroSeriesStyleSelector
A MicroSeriesStyleSelector object that contains logic that chooses the style to use for each element in the associated series. The default value is .
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase Methods

MicroChartBase Methods

The MicroChartBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the chart based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase.Refresh Method

MicroChartBaseRefresh Method
Updates the chart based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase Events

MicroChartBase Events

The MicroChartBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase Fields

MicroChartBase Fields

The MicroChartBase type exposes the following members.

Fields
Name | Description
SeriesStyleSelectorProperty | Identifies the SeriesStyleSelector dependency property. This field is read-only.
Top
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartBase.SeriesStyleSelectorProperty Field

MicroChartBaseSeriesStyleSelectorProperty Field
Identifies the SeriesStyleSelector dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SeriesStyleSelectorProperty
Public Shared ReadOnly SeriesStyleSelectorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SeriesStyleSelector dependency property.
See Also

Reference

MicroChartBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Class

MicroChartCanvas Class
Represents a panel were child elements are positioned using explicit/relative coordinates.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsPanel
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroChartCanvas

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroChartCanvas : Panel
Public Class MicroChartCanvas
    Inherits Panel

The MicroChartCanvas type exposes the following members.

Constructors
 | Name | Description
Public method | MicroChartCanvas | Initializes a new instance of the MicroChartCanvas class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
 | GetZIndex | Gets the value of the ZIndexProperty attached property for the specified element.
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
 | SetZIndex | Sets the value of the ZIndexProperty attached property to the specified element.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
ZIndexProperty | Identifies the ZIndex dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Constructor

MicroChartCanvas Constructor
Initializes a new instance of the MicroChartCanvas class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroChartCanvas()
Public Sub New
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Properties

MicroChartCanvas Properties

The MicroChartCanvas type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the panel. (Inherited from Panel.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | Children | Gets the collection of child elements of the panel. (Inherited from Panel.)
Public property | ChildrenTransitions | Gets or sets the collection of Transition style elements that apply to child content of a Panel subclass. (Inherited from Panel.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets a value that indicates whether this Panel is a container for UI items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Methods

MicroChartCanvas Methods

The MicroChartCanvas type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
 | GetX | Gets the value of the XProperty attached property for a specified element.
 | GetY | Gets the value of the YProperty attached property for a specified element.
 | GetZIndex | Gets the value of the ZIndexProperty attached property for the specified element.
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
 | SetX | Sets the value of the XProperty attached property to a specified element.
 | SetY | Sets the value of the YProperty attached property to a specified element.
 | SetZIndex | Sets the value of the ZIndexProperty attached property to the specified element.
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.ArrangeOverride Method

MicroChartCanvasArrangeOverride Method
Overload List
 | Name | Description
Protected method | ArrangeOverride(Size) | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride(Size) | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.ArrangeOverride Method (Size)

MicroChartCanvasArrangeOverride Method (Size)
When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size ArrangeOverride(
    Size finalSize
)
Protected Overridable Function ArrangeOverride (
    finalSize As Size
) As Size

Parameters

finalSize
Type: Windows.FoundationSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

Type: Size
The actual size used.
See Also

Reference

MicroChartCanvas Class
ArrangeOverride Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.GetX Method

MicroChartCanvasGetX Method
Gets the value of the XProperty attached property for a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static double GetX(
    UIElement element
)
Public Shared Function GetX (
    element As UIElement
) As Double

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is retrieved.

Return Value

Type: Double
The X-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.GetY Method

MicroChartCanvasGetY Method
Gets the value of the YProperty attached property for a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static double GetY(
    UIElement element
)
Public Shared Function GetY (
    element As UIElement
) As Double

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is retrieved.

Return Value

Type: Double
The Y-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.GetZIndex Method

MicroChartCanvasGetZIndex Method
Gets the value of the ZIndexProperty attached property for the specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static int GetZIndex(
    UIElement element
)
Public Shared Function GetZIndex (
    element As UIElement
) As Integer

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is retrieved.

Return Value

Type: Int32
The element's value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.MeasureOverride Method

MicroChartCanvasMeasureOverride Method
Overload List
 | Name | Description
Protected method | MeasureOverride(Size) | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MeasureOverride(Size) | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.MeasureOverride Method (Size)

MicroChartCanvasMeasureOverride Method (Size)
When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Size MeasureOverride(
    Size availableSize
)
Protected Overridable Function MeasureOverride (
    availableSize As Size
) As Size

Parameters

availableSize
Type: Windows.FoundationSize
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

Type: Size
The size that this element determines it needs during layout, based on its calculations of child element sizes.
See Also

Reference

MicroChartCanvas Class
MeasureOverride Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.SetX Method

MicroChartCanvasSetX Method
Sets the value of the XProperty attached property to a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetX(
    UIElement element,
    double value
)
Public Shared Sub SetX (
    element As UIElement,
    value As Double
)

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is written.
value
Type: SystemDouble
The X-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.SetY Method

MicroChartCanvasSetY Method
Sets the value of the YProperty attached property to a specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetY(
    UIElement element,
    double value
)
Public Shared Sub SetY (
    element As UIElement,
    value As Double
)

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is written.
value
Type: SystemDouble
The Y-coordinate value.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.SetZIndex Method

MicroChartCanvasSetZIndex Method
Sets the value of the ZIndexProperty attached property to the specified element.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static void SetZIndex(
    UIElement element,
    int value
)
Public Shared Sub SetZIndex (
    element As UIElement,
    value As Integer
)

Parameters

element
Type: Windows.UI.XamlUIElement
The element to which the attached property is written.
value
Type: SystemInt32
The value to set.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Events

MicroChartCanvas Events

The MicroChartCanvas type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas Fields

MicroChartCanvas Fields

The MicroChartCanvas type exposes the following members.

Fields
Name | Description
XProperty | Identifies the X dependency property. This field is read-only.
YProperty | Identifies the Y dependency property. This field is read-only.
ZIndexProperty | Identifies the ZIndex dependency property. This field is read-only.
Top
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.XProperty Field

MicroChartCanvasXProperty Field
Identifies the X dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XProperty
Public Shared ReadOnly XProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the X dependency property.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.YProperty Field

MicroChartCanvasYProperty Field
Identifies the Y dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YProperty
Public Shared ReadOnly YProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Y dependency property.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroChartCanvas.ZIndexProperty Field

MicroChartCanvasZIndexProperty Field
Identifies the ZIndex dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZIndexProperty
Public Shared ReadOnly ZIndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZIndex dependency property.
See Also

Reference

MicroChartCanvas Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Class

MicroDataPointBase Class
Represents a base class for a data point presented by a chart series.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.XamlObservableObjectBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroDataPointBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYDataPoint

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroDataPointBase : ObservableObjectBase
Public MustInherit Class MicroDataPointBase
    Inherits ObservableObjectBase

The MicroDataPointBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroDataPointBase | Initializes a new instance of the MicroDataPointBase class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Constructor

MicroDataPointBase Constructor
Initializes a new instance of the MicroDataPointBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroDataPointBase()
Protected Sub New
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Properties

MicroDataPointBase Properties

The MicroDataPointBase type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index of the data point.
Top
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase.Index Property

MicroDataPointBaseIndex Property
Gets or sets the index of the data point.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of the data point; The default value is 0.
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Methods

MicroDataPointBase Methods

The MicroDataPointBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from ObservableObjectBase.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ObservableObjectBase.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointBase Events

MicroDataPointBase Events

The MicroDataPointBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from ObservableObjectBase.)
Top
See Also

Reference

MicroDataPointBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Class

MicroDataPointCollectionViewBaseT Class
Represents a base class for collection views into a source collection.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroDataPointCollectionViewBaseT
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYDataPointCollectionView

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroDataPointCollectionViewBase<T> : IEnumerable<T>,
    IEnumerable

Public MustInherit Class MicroDataPointCollectionViewBase(Of T)
    Implements IEnumerable(Of T), IEnumerable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives.MicroDataPointCollectionViewBase`1"]

The MicroDataPointCollectionViewBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroDataPointCollectionViewBaseT | Initializes a new instance of the MicroDataPointCollectionViewBaseT class
Top
Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view.
Public property | Count | Gets the number of records in the view.
Top
Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index at which the specified item is located.
Protected method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Constructor

MicroDataPointCollectionViewBaseT Constructor
Initializes a new instance of the MicroDataPointCollectionViewBaseT class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroDataPointCollectionViewBase()
Protected Sub New
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Properties

MicroDataPointCollectionViewBaseT Properties

The MicroDataPointCollectionViewBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | Collection | Gets or sets the IEnumerableT presented by this view.
Public property | Count | Gets the number of records in the view.
Top
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).Collection Property

MicroDataPointCollectionViewBaseTCollection Property
Gets or sets the IEnumerableT presented by this view.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IEnumerable<T> Collection { get; set; }
Protected Property Collection As IEnumerable(Of T)
    Get
    Set

Property Value

Type: IEnumerable T
The IEnumerableT presented by this view.
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).Count Property

MicroDataPointCollectionViewBaseTCount Property
Gets the number of records in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Count { get; protected set; }
Public Property Count As Integer
    Get
    Protected Set

Property Value

Type: Int32
The number of records in the view, or –1 if the number of records is unknown.
Remarks
If a filter is set, this property value only includes items that pass the filter. If the underlying collection is of type IEnumerable, this is an O(N) operation. This value is cached until the collection changes.
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T) Methods

MicroDataPointCollectionViewBaseT Methods

The MicroDataPointCollectionViewBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | EnsureInitialized | Ensures that this instance is currently initialized.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | IndexOf | Returns the index at which the specified item is located.
Protected method | Initialize | Initializes this instance.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).EnsureInitialized Method

MicroDataPointCollectionViewBaseTEnsureInitialized Method
Ensures that this instance is currently initialized.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void EnsureInitialized()
Protected Sub EnsureInitialized
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).GetEnumerator Method

MicroDataPointCollectionViewBaseTGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).IndexOf Method

MicroDataPointCollectionViewBaseTIndexOf Method
Returns the index at which the specified item is located.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The item to locate.

Return Value

Type: Int32
The index at which the specified item is located, or –1 if the item is unknown.
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroDataPointCollectionViewBase(T).Initialize Method

MicroDataPointCollectionViewBaseTInitialize Method
Initializes this instance.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void Initialize()
Protected Overridable Sub Initialize
See Also

Reference

MicroDataPointCollectionViewBaseT Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Class

MicroLegendItem Class
Represents an item used in a chart legend.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroLegendItem

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroLegendItem
Public Class MicroLegendItem

The MicroLegendItem type exposes the following members.

Constructors
 | Name | Description
Public method | MicroLegendItem | Initializes a new instance of the MicroLegendItem class
Top
Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the MicroChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Constructor

MicroLegendItem Constructor
Initializes a new instance of the MicroLegendItem class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroLegendItem()
Public Sub New
See Also

Reference

MicroLegendItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Properties

MicroLegendItem Properties

The MicroLegendItem type exposes the following members.

Properties
 | Name | Description
Public property | MarkerStyle | Gets the Style applied to the MicroChartMarker used to present the legend item.
Public property | Text | Gets a description of the legend item.
Top
See Also

Reference

MicroLegendItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLegendItem.MarkerStyle Property

MicroLegendItemMarkerStyle Property
Gets the Style applied to the MicroChartMarker used to present the legend item.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; }
Public ReadOnly Property MarkerStyle As Style
    Get

Property Value

Type: Style
See Also

Reference

MicroLegendItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLegendItem.Text Property

MicroLegendItemText Property
Gets a description of the legend item.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
See Also

Reference

MicroLegendItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLegendItem Methods

MicroLegendItem Methods

The MicroLegendItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroLegendItem Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Class

MicroLineSeriesBase Class
Represents a base class for line and area series for use in a MicroXYChart.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroLineSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroAreaSeries
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroLineSeries

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroLineSeriesBase : MicroXYSeriesBase
Public MustInherit Class MicroLineSeriesBase
    Inherits MicroXYSeriesBase

The MicroLineSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroLineSeriesBase | Initializes a new instance of the MicroLineSeriesBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineNegativeStyleProperty | Identifies the LineNegativeStyle dependency property. This field is read-only.
LineStyleKindsProperty | Identifies the LineStyleKinds dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Constructor

MicroLineSeriesBase Constructor
Initializes a new instance of the MicroLineSeriesBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroLineSeriesBase()
Protected Sub New
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Properties

MicroLineSeriesBase Properties

The MicroLineSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series. (Inherited from MicroXYSeriesBase.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series. (Inherited from MicroXYSeriesBase.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | LineKind | Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.
Public property | LineNegativeStyle | Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyle | Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.
Public property | LineStyleKinds | Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | MarkerVisibility | Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized. (Inherited from MicroXYSeriesBase.)
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout. (Inherited from MicroXYSeriesBase.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property. (Inherited from MicroXYSeriesBase.)
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineKind Property

MicroLineSeriesBaseLineKind Property
Gets or sets a MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYSeriesLineKind LineKind { get; set; }
Public Property LineKind As MicroXYSeriesLineKind
    Get
    Set

Property Value

Type: MicroXYSeriesLineKind
A MicroXYSeriesLineKind, which indicates what kind of line should be rendered by the series. The default value is MicroXYSeriesLineKind.Normal.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineNegativeStyle Property

MicroLineSeriesBaseLineNegativeStyle Property
Gets or sets a negative Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LineNegativeStyle { get; set; }
Public Property LineNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyle Property

MicroLineSeriesBaseLineStyle Property
Gets or sets a Style, which is applied to the Shape used to render the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LineStyle { get; set; }
Public Property LineStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the Shape used to render the series. The default value is .
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyleKinds Property

MicroLineSeriesBaseLineStyleKinds Property
Gets or sets a MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroLineSeriesStyleKinds LineStyleKinds { get; set; }
Public Property LineStyleKinds As MicroLineSeriesStyleKinds
    Get
    Set

Property Value

Type: MicroLineSeriesStyleKinds
A MicroLineSeriesStyleKinds which indicates what style kinds are used for lines along the series. The default value is MicroLineSeriesStyleKinds.None.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.MarkerVisibility Property

MicroLineSeriesBaseMarkerVisibility Property
Gets or sets a value indicating which markers are rendered along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroChartMarkerVisibility MarkerVisibility { get; set; }
Public Property MarkerVisibility As MicroChartMarkerVisibility
    Get
    Set

Property Value

Type: MicroChartMarkerVisibility
A MicroChartMarkerVisibility indicating which markers are rendered along the series. The default value is MicroChartMarkerVisibility.None.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Methods

MicroLineSeriesBase Methods

The MicroLineSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series. (Overrides MicroXYSeriesBaseGetMinimumMargin.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline (Inherited from MicroXYSeriesBase.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter. (Inherited from MicroXYSeriesBase.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Inherited from MicroXYSeriesBase.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.GetMinimumMargin Method

MicroLineSeriesBaseGetMinimumMargin Method
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override Nullable<Thickness> GetMinimumMargin()
Protected Overrides Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Events

MicroLineSeriesBase Events

The MicroLineSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase Fields

MicroLineSeriesBase Fields

The MicroLineSeriesBase type exposes the following members.

Fields
Name | Description
LineKindProperty | Identifies the LineKind dependency property. This field is read-only.
LineNegativeStyleProperty | Identifies the LineNegativeStyle dependency property. This field is read-only.
LineStyleKindsProperty | Identifies the LineStyleKinds dependency property. This field is read-only.
LineStyleProperty | Identifies the LineStyle dependency property. This field is read-only.
MarkerVisibilityProperty | Identifies the MarkerVisibility dependency property. This field is read-only.
Top
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineKindProperty Field

MicroLineSeriesBaseLineKindProperty Field
Identifies the LineKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineKindProperty
Public Shared ReadOnly LineKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineKind dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineNegativeStyleProperty Field

MicroLineSeriesBaseLineNegativeStyleProperty Field
Identifies the LineNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineNegativeStyleProperty
Public Shared ReadOnly LineNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineNegativeStyle dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyleKindsProperty Field

MicroLineSeriesBaseLineStyleKindsProperty Field
Identifies the LineStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineStyleKindsProperty
Public Shared ReadOnly LineStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineStyleKinds dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.LineStyleProperty Field

MicroLineSeriesBaseLineStyleProperty Field
Identifies the LineStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineStyleProperty
Public Shared ReadOnly LineStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineStyle dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroLineSeriesBase.MarkerVisibilityProperty Field

MicroLineSeriesBaseMarkerVisibilityProperty Field
Identifies the MarkerVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerVisibilityProperty
Public Shared ReadOnly MarkerVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerVisibility dependency property.
See Also

Reference

MicroLineSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Class

MicroSeriesBase Class
Provides the base class for a micro series.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroSeriesBase : Control,
    INotifyPropertyChanged
Public MustInherit Class MicroSeriesBase
    Inherits Control
    Implements INotifyPropertyChanged

The MicroSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroSeriesBase | Initializes a new instance of the MicroSeriesBase class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Protected property | LogicalOrientation | Gets the logical orientation of the series.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Constructor

MicroSeriesBase Constructor
Initializes a new instance of the MicroSeriesBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroSeriesBase()
Protected Sub New
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Properties

MicroSeriesBase Properties

The MicroSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Protected property | LogicalOrientation | Gets the logical orientation of the series.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.Index Property

MicroSeriesBaseIndex Property
Gets the index of this series in the associated chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
The index of this series in the associated chart. The default value is -1.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.ItemsSource Property

MicroSeriesBaseItemsSource Property
Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Object ItemsSource { get; set; }
Public Property ItemsSource As Object
    Get
    Set

Property Value

Type: Object
A collection used to generate the data points of the MicroSeriesBase. The default value is .
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.LogicalOrientation Property

MicroSeriesBaseLogicalOrientation Property
Gets the logical orientation of the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Orientation LogicalOrientation { get; }
Protected Overridable ReadOnly Property LogicalOrientation As Orientation
    Get

Property Value

Type: Orientation
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Methods

MicroSeriesBase Methods

The MicroSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NotifyPropertyChanged | Notifies that a property has changed.
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed.
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection.
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state.
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.NotifyPropertyChanged Method

MicroSeriesBaseNotifyPropertyChanged Method
Notifies that a property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected void NotifyPropertyChanged(
    string propertyName
)
Protected Sub NotifyPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
The name of the property that was changed.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.OnItemsSourceChanged Method

MicroSeriesBaseOnItemsSourceChanged Method
Occurs when the ItemsSource value is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Protected Overridable Sub OnItemsSourceChanged (
    oldValue As IEnumerable,
    newValue As IEnumerable
)

Parameters

oldValue
Type: System.CollectionsIEnumerable
Old value of the ItemsSource property.
newValue
Type: System.CollectionsIEnumerable
New value of the ItemsSource property.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.OnItemsSourceCollectionChanged Method

MicroSeriesBaseOnItemsSourceCollectionChanged Method
Handles the CollectionChanged event of the ItemsSource collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnItemsSourceCollectionChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnItemsSourceCollectionChanged (
    sender As Object,
    e As NotifyCollectionChangedEventArgs
)

Parameters

sender
Type: SystemObject
The source of the event.
e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
The NotifyCollectionChangedEventArgs instance containing the event data.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.OnPropertyChanged Method

MicroSeriesBaseOnPropertyChanged Method
Raises the PropertyChanged event.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
The PropertyChangedEventArgs that contains the event data.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.Refresh Method

MicroSeriesBaseRefresh Method
Updates the series based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract void Refresh()
Public MustOverride Sub Refresh
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Events

MicroSeriesBase Events

The MicroSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed.
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.PropertyChanged Event

MicroSeriesBasePropertyChanged Event
Occurs when a property has been changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase Fields

MicroSeriesBase Fields

The MicroSeriesBase type exposes the following members.

Fields
Name | Description
IndexProperty | Identifies the read-only Index dependency property. This field is read-only.
ItemsSourceProperty | Identifies the ItemsSource dependency property. This field is read-only.
Top
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.IndexProperty Field

MicroSeriesBaseIndexProperty Field
Identifies the read-only Index dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndexProperty
Public Shared ReadOnly IndexProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Index dependency property.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesBase.ItemsSourceProperty Field

MicroSeriesBaseItemsSourceProperty Field
Identifies the ItemsSource dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ItemsSourceProperty
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ItemsSource dependency property.
See Also

Reference

MicroSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter Class

MicroSeriesItemsSourceConverter Class
Represents a type converter for the ItemsSource type.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesItemsSourceConverter

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MicroSeriesItemsSourceConverter
Public NotInheritable Class MicroSeriesItemsSourceConverter

The MicroSeriesItemsSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroSeriesItemsSourceConverter | Initializes a new instance of the MicroSeriesItemsSourceConverter class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter Constructor

MicroSeriesItemsSourceConverter Constructor
Initializes a new instance of the MicroSeriesItemsSourceConverter class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesItemsSourceConverter()
Public Sub New
See Also

Reference

MicroSeriesItemsSourceConverter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroSeriesItemsSourceConverter Methods

MicroSeriesItemsSourceConverter Methods

The MicroSeriesItemsSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MicroSeriesItemsSourceConverter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Class

MicroXYChartPlotter Class
Represents a class that is capable of plotting various shapes on to a MicroXYChart.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class MicroXYChartPlotter
Public Class MicroXYChartPlotter

The MicroXYChartPlotter type exposes the following members.

Constructors
 | Name | Description
Public method | MicroXYChartPlotter | Initializes a new instance of the MicroXYChart class.
Top
Properties
 | Name | Description
Public property | Height | Gets the height of the plot area.
Public property | IsAxisBaselineVisible | Gets a value indicating whether a line is rendered at the baseline value.
Public property | IsHotTracking | Gets a value indicating whether this instance is hot tracking.
Public property | Margin | Gets or sets the margin around the plot area.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series.
Public property | Width | Gets the width of the plot area.
Top
Methods
 | Name | Description
Public method | AddBaseline | Adds a baseline to the associated chart.
Public method | AddHorizontalBaseline | Adds a horizontal baseline to the associated chart.
Public method | AddMarker(Point, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddMarker(Double, Double, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddPolygon | Adds a Polygon to the associated chart using with the given points.
Public method | AddPolyline | Adds a Polyline to the associated chart using with the given points.
Public method | AddShape | Adds the shape to the associated chart.
Public method | AddVerticalBaseline | Adds a vertical baseline to the associated chart.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetXAxis | Gets an IMicroXYAxis associated with the specified type for use along the X-axis.
Public method | GetYAxis | Gets an IMicroXYAxis associated with the specified type for use along the Y-axis.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Plot | Plots the series and ranges on the associated chart.
Public method | StartHotTracking | Starts the hot tracking.
Public method | StopHotTracking | Stops the hot tracking.
Public method | ToString | (Inherited from Object.)
Public method | UpdateHotTracking | Updates the hot tracking.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Constructor

MicroXYChartPlotter Constructor
Initializes a new instance of the MicroXYChart class.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYChartPlotter(
    MicroXYChart chart
)
Public Sub New (
    chart As MicroXYChart
)

Parameters

chart
Type: ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroXYChart
The chart associated with the plotter.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Properties

MicroXYChartPlotter Properties

The MicroXYChartPlotter type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height of the plot area.
Public property | IsAxisBaselineVisible | Gets a value indicating whether a line is rendered at the baseline value.
Public property | IsHotTracking | Gets a value indicating whether this instance is hot tracking.
Public property | Margin | Gets or sets the margin around the plot area.
Public property | SeriesStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series.
Public property | Width | Gets the width of the plot area.
Top
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Height Property

MicroXYChartPlotterHeight Property
Gets the height of the plot area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get

Property Value

Type: Double
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.IsAxisBaselineVisible Property

MicroXYChartPlotterIsAxisBaselineVisible Property
Gets a value indicating whether a line is rendered at the baseline value.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAxisBaselineVisible { get; }
Public ReadOnly Property IsAxisBaselineVisible As Boolean
    Get

Property Value

Type: Boolean
true if a line is rendered at the baseline value; otherwise, false.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.IsHotTracking Property

MicroXYChartPlotterIsHotTracking Property
Gets a value indicating whether this instance is hot tracking.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsHotTracking { get; }
Public ReadOnly Property IsHotTracking As Boolean
    Get

Property Value

Type: Boolean
true if this instance is hot tracking; otherwise, false.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Margin Property

MicroXYChartPlotterMargin Property
Gets or sets the margin around the plot area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Thickness Margin { get; set; }
Public Property Margin As Thickness
    Get
    Set

Property Value

Type: Thickness
The margin around the plot area.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.SeriesStyleSelector Property

MicroXYChartPlotterSeriesStyleSelector Property
Gets or sets custom style-selection logic for a style that can be applied to each element in the associated series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroSeriesStyleSelector SeriesStyleSelector { get; }
Public ReadOnly Property SeriesStyleSelector As MicroSeriesStyleSelector
    Get

Property Value

Type: MicroSeriesStyleSelector
A MicroSeriesStyleSelector object that contains logic that chooses the style to use for each element in the associated series.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Width Property

MicroXYChartPlotterWidth Property
Gets the width of the plot area.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get

Property Value

Type: Double
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter Methods

MicroXYChartPlotter Methods

The MicroXYChartPlotter type exposes the following members.

Methods
 | Name | Description
Public method | AddBaseline | Adds a baseline to the associated chart.
Public method | AddHorizontalBaseline | Adds a horizontal baseline to the associated chart.
Public method | AddMarker(Point, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddMarker(Double, Double, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddPolygon | Adds a Polygon to the associated chart using with the given points.
Public method | AddPolyline | Adds a Polyline to the associated chart using with the given points.
Public method | AddShape | Adds the shape to the associated chart.
Public method | AddVerticalBaseline | Adds a vertical baseline to the associated chart.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | GetXAxis | Gets an IMicroXYAxis associated with the specified type for use along the X-axis.
Public method | GetYAxis | Gets an IMicroXYAxis associated with the specified type for use along the Y-axis.
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Plot | Plots the series and ranges on the associated chart.
Public method | StartHotTracking | Starts the hot tracking.
Public method | StopHotTracking | Stops the hot tracking.
Public method | ToString | (Inherited from Object.)
Public method | UpdateHotTracking | Updates the hot tracking.
Top
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddBaseline Method

MicroXYChartPlotterAddBaseline Method
Adds a baseline to the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddBaseline(
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub AddBaseline (
    x1 As Double,
    y1 As Double,
    x2 As Double,
    y2 As Double
)

Parameters

x1
Type: SystemDouble
The X-coordinate of the first point.
y1
Type: SystemDouble
The Y-coordinate of the first point.
x2
Type: SystemDouble
The X-coordinate of the second point.
y2
Type: SystemDouble
The Y-coordinate of the second point.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddHorizontalBaseline Method

MicroXYChartPlotterAddHorizontalBaseline Method
Adds a horizontal baseline to the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddHorizontalBaseline(
    double y
)
Public Sub AddHorizontalBaseline (
    y As Double
)

Parameters

y
Type: SystemDouble
The Y-coordinate of the baseline.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddMarker Method

MicroXYChartPlotterAddMarker Method
Overload List
 | Name | Description
Public method | AddMarker(Point, Style) | Adds a MicroChartMarker to the associated chart.
Public method | AddMarker(Double, Double, Style) | Adds a MicroChartMarker to the associated chart.
Top
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddMarker Method (Point, Style)

MicroXYChartPlotterAddMarker Method (Point, Style)
Adds a MicroChartMarker to the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddMarker(
    Point point,
    Style style
)
Public Sub AddMarker (
    point As Point,
    style As Style
)

Parameters

point
Type: Windows.FoundationPoint
The point at which the marker should be added.
style
Type: Windows.UI.XamlStyle
The style that should be applied to the marker.
See Also

Reference

MicroXYChartPlotter Class
AddMarker Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddMarker Method (Double, Double, Style)

MicroXYChartPlotterAddMarker Method (Double, Double, Style)
Adds a MicroChartMarker to the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddMarker(
    double x,
    double y,
    Style style
)
Public Sub AddMarker (
    x As Double,
    y As Double,
    style As Style
)

Parameters

x
Type: SystemDouble
The X coordinate at which the marker should be added.
y
Type: SystemDouble
The Y coordinate at which the marker should be added.
style
Type: Windows.UI.XamlStyle
The style that should be applied to the marker.
See Also

Reference

MicroXYChartPlotter Class
AddMarker Overload
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddPolygon Method

MicroXYChartPlotterAddPolygon Method
Adds a Polygon to the associated chart using with the given points.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddPolygon(
    PointCollection points,
    Style style,
    Geometry clip,
    Nullable<Rect> clipBounds
)
Public Sub AddPolygon (
    points As PointCollection,
    style As Style,
    clip As Geometry,
    clipBounds As Nullable(Of Rect)
)

Parameters

points
Type: Windows.UI.Xaml.MediaPointCollection
The points that make up the shape.
style
Type: Windows.UI.XamlStyle
The Style to be applied to the shape.
clip
Type: Windows.UI.Xaml.MediaGeometry
The clipping geometry to be used by the shape.
clipBounds
Type: SystemNullable Rect
The clipping bounds of the shape.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddPolyline Method

MicroXYChartPlotterAddPolyline Method
Adds a Polyline to the associated chart using with the given points.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddPolyline(
    PointCollection points,
    Style style,
    Geometry clip,
    Nullable<Rect> clipBounds
)
Public Sub AddPolyline (
    points As PointCollection,
    style As Style,
    clip As Geometry,
    clipBounds As Nullable(Of Rect)
)

Parameters

points
Type: Windows.UI.Xaml.MediaPointCollection
The points that make up the shape.
style
Type: Windows.UI.XamlStyle
The Style to be applied to the shape.
clip
Type: Windows.UI.Xaml.MediaGeometry
The clipping geometry to be used by the shape.
clipBounds
Type: SystemNullable Rect
The clipping bounds of the shape.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddShape Method

MicroXYChartPlotterAddShape Method
Adds the shape to the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddShape(
    Shape shape
)
Public Sub AddShape (
    shape As Shape
)

Parameters

shape
Type: Windows.UI.Xaml.ShapesShape
The shape to add.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.AddVerticalBaseline Method

MicroXYChartPlotterAddVerticalBaseline Method
Adds a vertical baseline to the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void AddVerticalBaseline(
    double x
)
Public Sub AddVerticalBaseline (
    x As Double
)

Parameters

x
Type: SystemDouble
The X-coordinate of the baseline.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.GetXAxis Method

MicroXYChartPlotterGetXAxis Method
Gets an IMicroXYAxis associated with the specified type for use along the X-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMicroXYAxis GetXAxis(
    Type type
)
Public Function GetXAxis (
    type As Type
) As IMicroXYAxis

Parameters

type
Type: SystemType
The type of axis.

Return Value

Type: IMicroXYAxis
An IMicroXYAxis associated with the specified type for use along the X-axis.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.GetYAxis Method

MicroXYChartPlotterGetYAxis Method
Gets an IMicroXYAxis associated with the specified type for use along the Y-axis.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMicroXYAxis GetYAxis(
    Type type
)
Public Function GetYAxis (
    type As Type
) As IMicroXYAxis

Parameters

type
Type: SystemType
The type of axis.

Return Value

Type: IMicroXYAxis
An IMicroXYAxis associated with the specified type for use along the Y-axis.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.Plot Method

MicroXYChartPlotterPlot Method
Plots the series and ranges on the associated chart.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Plot()
Public Sub Plot
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.StartHotTracking Method

MicroXYChartPlotterStartHotTracking Method
Starts the hot tracking.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void StartHotTracking(
    Point position
)
Public Sub StartHotTracking (
    position As Point
)

Parameters

position
Type: Windows.FoundationPoint
The position of the mouse cursor.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.StopHotTracking Method

MicroXYChartPlotterStopHotTracking Method
Stops the hot tracking.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void StopHotTracking()
Public Sub StopHotTracking
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYChartPlotter.UpdateHotTracking Method

MicroXYChartPlotterUpdateHotTracking Method
Updates the hot tracking.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void UpdateHotTracking(
    Point position
)
Public Sub UpdateHotTracking (
    position As Point
)

Parameters

position
Type: Windows.FoundationPoint
The position of the mouse cursor.
See Also

Reference

MicroXYChartPlotter Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Class

MicroXYSeriesBase Class
Provides the base class for a micro series that uses an X/Y axis.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroChartsMicroScatterSeries
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroBarSeriesBase
ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroLineSeriesBase

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class MicroXYSeriesBase : MicroSeriesBase
Public MustInherit Class MicroXYSeriesBase
    Inherits MicroSeriesBase

The MicroXYSeriesBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MicroXYSeriesBase | Initializes a new instance of the MicroXYSeriesBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property.
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property.
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property.
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property.
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property.
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized.
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter.
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Overrides MicroSeriesBaseRefresh.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendItemTemplateProperty | Identifies the LegendItemTemplate dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerFirstStyleProperty | Identifies the MarkerFirstStyle dependency property. This field is read-only.
MarkerHighStyleProperty | Identifies the MarkerHighStyle dependency property. This field is read-only.
MarkerLastStyleProperty | Identifies the MarkerLastStyle dependency property. This field is read-only.
MarkerLowStyleProperty | Identifies the MarkerLowStyle dependency property. This field is read-only.
MarkerNegativeStyleProperty | Identifies the MarkerNegativeStyle dependency property. This field is read-only.
MarkerStyleKindsProperty | Identifies the MarkerStyleKinds dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Constructor

MicroXYSeriesBase Constructor
Initializes a new instance of the MicroXYSeriesBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected MicroXYSeriesBase()
Protected Sub New
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Properties

MicroXYSeriesBase Properties

The MicroXYSeriesBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AggregationFactor | Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Chart | Gets the MicroXYChart that owns this series.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets the data points associated with this series.
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | Description | Gets or sets a description of the series. This is a dependency property.
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Index | Gets the index of this series in the associated chart. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAggregationEnabled | Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | ItemsSource | Gets or sets a collection used to generate the data points of the MicroSeriesBase. This is a dependency property. (Inherited from MicroSeriesBase.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LegendItemTemplate | Gets or sets the data template used when presenting a legend item for the series. This is a dependency property.
Public property | LegendMarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property.
Public property | LegendStringFormat | Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.
Protected property | LogicalOrientation | Gets the logical orientation of the series. (Inherited from MicroSeriesBase.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MarkerFirstStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property.
Public property | MarkerHighStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property.
Public property | MarkerLastStyle | Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property.
Public property | MarkerLowStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property.
Public property | MarkerNegativeStyle | Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyle | Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.
Public property | MarkerStyleKinds | Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrimaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Protected property | RequiresNormalizedValues | Gets a value indicating whether the values presented by this series must be normalized.
Public property | RequiresPointer | (Inherited from Control.)
Protected property | RequiresSlottedLayout | Gets a value indicating whether the series requires slotted layout.
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SecondaryAggregationKind | Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.
Public property | StackKind | Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XPath | Gets or sets the path to the item property represented along the X-axis. This is a dependency property.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | YPath | Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.AggregationFactor Property

MicroXYSeriesBaseAggregationFactor Property
Gets or sets a factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double AggregationFactor { get; set; }
Public Property AggregationFactor As Double
    Get
    Set

Property Value

Type: Double
A factor between 0 and 1 that indicates the number of data points generated based on the size of the chart. The default value is 0.2.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.Chart Property

MicroXYSeriesBaseChart Property
Gets the MicroXYChart that owns this series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYChart Chart { get; }
Public ReadOnly Property Chart As MicroXYChart
    Get

Property Value

Type: MicroXYChart
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.DataPoints Property

MicroXYSeriesBaseDataPoints Property
Gets the data points associated with this series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYDataPointCollectionView DataPoints { get; }
Public ReadOnly Property DataPoints As MicroXYDataPointCollectionView
    Get

Property Value

Type: MicroXYDataPointCollectionView
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.Description Property

MicroXYSeriesBaseDescription Property
Gets or sets a description of the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
A description of the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.IsAggregationEnabled Property

MicroXYSeriesBaseIsAggregationEnabled Property
Gets or sets a value indicating whether the data points will be an aggregation of the source data. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAggregationEnabled { get; set; }
Public Property IsAggregationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the data points will be an aggregation of the source data; otherwise, false. The default value is true.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendItemTemplate Property

MicroXYSeriesBaseLegendItemTemplate Property
Gets or sets the data template used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate LegendItemTemplate { get; set; }
Public Property LegendItemTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The data template used when presenting a legend item for the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendMarkerStyle Property

MicroXYSeriesBaseLegendMarkerStyle Property
Gets or sets a Style, which is applied to the MicroChartMarker element used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style LegendMarkerStyle { get; set; }
Public Property LegendMarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker used when presenting a legend item for the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendStringFormat Property

MicroXYSeriesBaseLegendStringFormat Property
Gets or sets the string format used when presenting a legend item for the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string LegendStringFormat { get; set; }
Public Property LegendStringFormat As String
    Get
    Set

Property Value

Type: String
The string format used when presenting legend item for the series. The default value is "{0}".
Remarks
The format string will be passed the following parameters:
  • {0} - The value of the primary axis. -
  • {1} - The value of the secondary axis. -
  • {2} - The X value. -
  • {3} - The Y value. -
  • {4} - Reserved. -
  • {5} - Description. -
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerFirstStyle Property

MicroXYSeriesBaseMarkerFirstStyle Property
Gets or sets a Style, which is applied to the MicroChartMarker element used to render the first marker along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerFirstStyle { get; set; }
Public Property MarkerFirstStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker element used to render the first marker along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerHighStyle Property

MicroXYSeriesBaseMarkerHighStyle Property
Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerHighStyle { get; set; }
Public Property MarkerHighStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker elements used to render the high markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLastStyle Property

MicroXYSeriesBaseMarkerLastStyle Property
Gets or sets a Style, which is applied to the MicroChartMarker element used to render the last marker along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerLastStyle { get; set; }
Public Property MarkerLastStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker element used to render the last marker along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLowStyle Property

MicroXYSeriesBaseMarkerLowStyle Property
Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the low markers along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerLowStyle { get; set; }
Public Property MarkerLowStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker used to render the low markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerNegativeStyle Property

MicroXYSeriesBaseMarkerNegativeStyle Property
Gets or sets a negative Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerNegativeStyle { get; set; }
Public Property MarkerNegativeStyle As Style
    Get
    Set

Property Value

Type: Style
A negative Style, which is applied to the MicroChartMarker used to render the markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyle Property

MicroXYSeriesBaseMarkerStyle Property
Gets or sets a Style, which is applied to the MicroChartMarker elements used to render the markers along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Style MarkerStyle { get; set; }
Public Property MarkerStyle As Style
    Get
    Set

Property Value

Type: Style
A Style, which is applied to the MicroChartMarker used to render the markers along the series. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyleKinds Property

MicroXYSeriesBaseMarkerStyleKinds Property
Gets or sets a MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroChartMarkerStyleKinds MarkerStyleKinds { get; set; }
Public Property MarkerStyleKinds As MicroChartMarkerStyleKinds
    Get
    Set

Property Value

Type: MicroChartMarkerStyleKinds
A MicroChartMarkerStyleKinds which indicates what style kinds are used for markers along the series. The default value is MicroChartMarkerStyleKinds.None.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PrimaryAggregationKind Property

MicroXYSeriesBasePrimaryAggregationKind Property
Gets or sets a value indicating which kind of aggregation to perform along the primary axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroAggregationKind PrimaryAggregationKind { get; set; }
Public Property PrimaryAggregationKind As MicroAggregationKind
    Get
    Set

Property Value

Type: MicroAggregationKind
A MicroAggregationKind indicating which kind of aggregation to perform along the primary axis. The default value is MicroAggregationKind.Average.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.RequiresNormalizedValues Property

MicroXYSeriesBaseRequiresNormalizedValues Property
Gets a value indicating whether the values presented by this series must be normalized.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool RequiresNormalizedValues { get; }
Protected Overridable ReadOnly Property RequiresNormalizedValues As Boolean
    Get

Property Value

Type: Boolean
true if the values presented by this series must be normalized; otherwise, false.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.RequiresSlottedLayout Property

MicroXYSeriesBaseRequiresSlottedLayout Property
Gets a value indicating whether the series requires slotted layout.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual bool RequiresSlottedLayout { get; }
Protected Overridable ReadOnly Property RequiresSlottedLayout As Boolean
    Get

Property Value

Type: Boolean
true if the series requires slotted layout; otherwise, false.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.SecondaryAggregationKind Property

MicroXYSeriesBaseSecondaryAggregationKind Property
Gets or sets a value indicating which kind of aggregation to perform along the secondary axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroAggregationKind SecondaryAggregationKind { get; set; }
Public Property SecondaryAggregationKind As MicroAggregationKind
    Get
    Set

Property Value

Type: MicroAggregationKind
A MicroAggregationKind indicating which kind of aggregation to perform along the secondary axis. The default value is MicroAggregationKind.First.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.StackKind Property

MicroXYSeriesBaseStackKind Property
Gets or sets a value indicating the kind of stacking applied to the series. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public MicroXYSeriesStackKind StackKind { get; set; }
Public Property StackKind As MicroXYSeriesStackKind
    Get
    Set

Property Value

Type: MicroXYSeriesStackKind
The kind of stacking applied to the series. The default value is MicroXYSeriesStackKind.None.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.XPath Property

MicroXYSeriesBaseXPath Property
Gets or sets the path to the item property represented along the X-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string XPath { get; set; }
Public Property XPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the X-axis. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.YPath Property

MicroXYSeriesBaseYPath Property
Gets or sets the path to the item property represented along the Y-axis. This is a dependency property.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string YPath { get; set; }
Public Property YPath As String
    Get
    Set

Property Value

Type: String
The path to the item property represented along the Y-axis. The default value is .
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Methods

MicroXYSeriesBase Methods

The MicroXYSeriesBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetMinimumMargin | Gets the minimum margin around the plotted area required by the series.
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | NormalizeValue | Normalizes the value using the specified baseline
Protected method | NotifyPropertyChanged | Notifies that a property has changed. (Inherited from MicroSeriesBase.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnItemsSourceChanged | Occurs when the ItemsSource value is changed. (Inherited from MicroSeriesBase.)
Protected method | OnItemsSourceCollectionChanged | Handles the CollectionChanged event of the ItemsSource collection. (Inherited from MicroSeriesBase.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from MicroSeriesBase.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | PlotSeries | Plots the series to the associated chart using the specified plotter.
Protected method | PrepareSeries | Prepares the series to be plotted to the associated chart using the specified plotter.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | Refresh | Updates the series based on the current state. (Overrides MicroSeriesBaseRefresh.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.GetMinimumMargin Method

MicroXYSeriesBaseGetMinimumMargin Method
Gets the minimum margin around the plotted area required by the series.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Nullable<Thickness> GetMinimumMargin()
Protected Overridable Function GetMinimumMargin As Nullable(Of Thickness)

Return Value

Type: Nullable Thickness
The minimum margin around the plotted area required by the series.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.NormalizeValue Method

MicroXYSeriesBaseNormalizeValue Method
Normalizes the value using the specified baseline

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual Object NormalizeValue(
    Object value,
    Object baselineValue
)
Protected Overridable Function NormalizeValue (
    value As Object,
    baselineValue As Object
) As Object

Parameters

value
Type: SystemObject
The value to normalize.
baselineValue
Type: SystemObject
The baseline value.

Return Value

Type: Object
A normalized value.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PlotSeries Method

MicroXYSeriesBasePlotSeries Method
Plots the series to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void PlotSeries(
    MicroXYChartPlotter plotter
)
Protected Overridable Sub PlotSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter used to render shapes on the chart.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PrepareSeries Method

MicroXYSeriesBasePrepareSeries Method
Prepares the series to be plotted to the associated chart using the specified plotter.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void PrepareSeries(
    MicroXYChartPlotter plotter
)
Protected Overridable Sub PrepareSeries (
    plotter As MicroXYChartPlotter
)

Parameters

plotter
Type: ActiproSoftware.UI.Xaml.Controls.MicroCharts.PrimitivesMicroXYChartPlotter
The plotter.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.Refresh Method

MicroXYSeriesBaseRefresh Method
Updates the series based on the current state.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Events

MicroXYSeriesBase Events

The MicroXYSeriesBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | PropertyChanged | Occurs when a property has been changed. (Inherited from MicroSeriesBase.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase Fields

MicroXYSeriesBase Fields

The MicroXYSeriesBase type exposes the following members.

Fields
Name | Description
AggregationFactorProperty | Identifies the AggregationFactor dependency property. This field is read-only.
DescriptionProperty | Identifies the Description dependency property. This field is read-only.
IsAggregationEnabledProperty | Identifies the IsAggregationEnabled dependency property. This field is read-only.
LegendItemTemplateProperty | Identifies the LegendItemTemplate dependency property. This field is read-only.
LegendMarkerStyleProperty | Identifies the LegendMarkerStyle dependency property. This field is read-only.
LegendStringFormatProperty | Identifies the LegendStringFormat dependency property. This field is read-only.
MarkerFirstStyleProperty | Identifies the MarkerFirstStyle dependency property. This field is read-only.
MarkerHighStyleProperty | Identifies the MarkerHighStyle dependency property. This field is read-only.
MarkerLastStyleProperty | Identifies the MarkerLastStyle dependency property. This field is read-only.
MarkerLowStyleProperty | Identifies the MarkerLowStyle dependency property. This field is read-only.
MarkerNegativeStyleProperty | Identifies the MarkerNegativeStyle dependency property. This field is read-only.
MarkerStyleKindsProperty | Identifies the MarkerStyleKinds dependency property. This field is read-only.
MarkerStyleProperty | Identifies the MarkerStyle dependency property. This field is read-only.
PrimaryAggregationKindProperty | Identifies the PrimaryAggregationKind dependency property. This field is read-only.
SecondaryAggregationKindProperty | Identifies the SecondaryAggregationKind dependency property. This field is read-only.
StackKindProperty | Identifies the StackKind dependency property. This field is read-only.
XPathProperty | Identifies the XPath dependency property. This field is read-only.
YPathProperty | Identifies the YPath dependency property. This field is read-only.
Top
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.AggregationFactorProperty Field

MicroXYSeriesBaseAggregationFactorProperty Field
Identifies the AggregationFactor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AggregationFactorProperty
Public Shared ReadOnly AggregationFactorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AggregationFactor dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.DescriptionProperty Field

MicroXYSeriesBaseDescriptionProperty Field
Identifies the Description dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DescriptionProperty
Public Shared ReadOnly DescriptionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Description dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.IsAggregationEnabledProperty Field

MicroXYSeriesBaseIsAggregationEnabledProperty Field
Identifies the IsAggregationEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAggregationEnabledProperty
Public Shared ReadOnly IsAggregationEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAggregationEnabled dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendItemTemplateProperty Field

MicroXYSeriesBaseLegendItemTemplateProperty Field
Identifies the LegendItemTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendItemTemplateProperty
Public Shared ReadOnly LegendItemTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendItemTemplate dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendMarkerStyleProperty Field

MicroXYSeriesBaseLegendMarkerStyleProperty Field
Identifies the LegendMarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendMarkerStyleProperty
Public Shared ReadOnly LegendMarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendMarkerStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.LegendStringFormatProperty Field

MicroXYSeriesBaseLegendStringFormatProperty Field
Identifies the LegendStringFormat dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LegendStringFormatProperty
Public Shared ReadOnly LegendStringFormatProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LegendStringFormat dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerFirstStyleProperty Field

MicroXYSeriesBaseMarkerFirstStyleProperty Field
Identifies the MarkerFirstStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerFirstStyleProperty
Public Shared ReadOnly MarkerFirstStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerFirstStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerHighStyleProperty Field

MicroXYSeriesBaseMarkerHighStyleProperty Field
Identifies the MarkerHighStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerHighStyleProperty
Public Shared ReadOnly MarkerHighStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerHighStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLastStyleProperty Field

MicroXYSeriesBaseMarkerLastStyleProperty Field
Identifies the MarkerLastStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerLastStyleProperty
Public Shared ReadOnly MarkerLastStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerLastStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerLowStyleProperty Field

MicroXYSeriesBaseMarkerLowStyleProperty Field
Identifies the MarkerLowStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerLowStyleProperty
Public Shared ReadOnly MarkerLowStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerLowStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerNegativeStyleProperty Field

MicroXYSeriesBaseMarkerNegativeStyleProperty Field
Identifies the MarkerNegativeStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerNegativeStyleProperty
Public Shared ReadOnly MarkerNegativeStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerNegativeStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyleKindsProperty Field

MicroXYSeriesBaseMarkerStyleKindsProperty Field
Identifies the MarkerStyleKinds dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleKindsProperty
Public Shared ReadOnly MarkerStyleKindsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyleKinds dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.MarkerStyleProperty Field

MicroXYSeriesBaseMarkerStyleProperty Field
Identifies the MarkerStyle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MarkerStyleProperty
Public Shared ReadOnly MarkerStyleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MarkerStyle dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.PrimaryAggregationKindProperty Field

MicroXYSeriesBasePrimaryAggregationKindProperty Field
Identifies the PrimaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrimaryAggregationKindProperty
Public Shared ReadOnly PrimaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrimaryAggregationKind dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.SecondaryAggregationKindProperty Field

MicroXYSeriesBaseSecondaryAggregationKindProperty Field
Identifies the SecondaryAggregationKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SecondaryAggregationKindProperty
Public Shared ReadOnly SecondaryAggregationKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SecondaryAggregationKind dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.StackKindProperty Field

MicroXYSeriesBaseStackKindProperty Field
Identifies the StackKind dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty StackKindProperty
Public Shared ReadOnly StackKindProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the StackKind dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.XPathProperty Field

MicroXYSeriesBaseXPathProperty Field
Identifies the XPath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty XPathProperty
Public Shared ReadOnly XPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the XPath dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


MicroXYSeriesBase.YPathProperty Field

MicroXYSeriesBaseYPathProperty Field
Identifies the YPath dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives
Assembly: AS.MicroCharts.Universal (in AS.MicroCharts.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty YPathProperty
Public Shared ReadOnly YPathProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the YPath dependency property.
See Also

Reference

MicroXYSeriesBase Class
ActiproSoftware.UI.Xaml.Controls.MicroCharts.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.Primitives Namespace

ActiproSoftware.UI.Xaml.Controls.Primitives Namespace
Contains some primitive classes used for the Shared Library controls.
Classes
 | Class | Description
Public class | CircularThumb | Represents a circular thumb used to change values in a various input control.
Public class | RangeBase | Represents a radial slider.


CircularThumb Class

CircularThumb Class
Represents a circular thumb used to change values in a various input control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.PrimitivesCircularThumb

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CircularThumb : Control
Public Class CircularThumb
    Inherits Control

The CircularThumb type exposes the following members.

Constructors
 | Name | Description
Public method | CircularThumb | Initializes an instance of the CircularThumb class.
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | ArrowAngle | Gets or sets the arrow angle.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDragging | Gets whether the thumb is being dragged by a pointer.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PressedBackground | Gets or sets the background Brush to render when the thumb is pressed.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ArrowAngleProperty | Identifies the ArrowAngle dependency property. This field is read-only.
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
PressedBackgroundProperty | Identifies the PressedBackground dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb Constructor

CircularThumb Constructor
Initializes an instance of the CircularThumb class.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CircularThumb()
Public Sub New
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb Properties

CircularThumb Properties

The CircularThumb type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | ArrowAngle | Gets or sets the arrow angle.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsDragging | Gets whether the thumb is being dragged by a pointer.
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PressedBackground | Gets or sets the background Brush to render when the thumb is pressed.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.ArrowAngle Property

CircularThumbArrowAngle Property
Gets or sets the arrow angle.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ArrowAngle { get; set; }
Public Property ArrowAngle As Double
    Get
    Set

Property Value

Type: Double
The arrow angle. The default value is 180.0.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.IsDragging Property

CircularThumbIsDragging Property
Gets whether the thumb is being dragged by a pointer.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get

Property Value

Type: Boolean
true if the thumb is being dragged by a pointer; otherwise, false.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.PressedBackground Property

CircularThumbPressedBackground Property
Gets or sets the background Brush to render when the thumb is pressed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush PressedBackground { get; set; }
Public Property PressedBackground As Brush
    Get
    Set

Property Value

Type: Brush
The background Brush to render when the thumb is pressed.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb Methods

CircularThumb Methods

The CircularThumb type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs when the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Occurs when the control loses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.OnApplyTemplate Method

CircularThumbOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.OnGotFocus Method

CircularThumbOnGotFocus Method
Occurs when the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.OnLostFocus Method

CircularThumbOnLostFocus Method
Occurs when the control loses focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
The RoutedEventArgs that contains the event data.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb Events

CircularThumb Events

The CircularThumb type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Top
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb Fields

CircularThumb Fields

The CircularThumb type exposes the following members.

Fields
Name | Description
ArrowAngleProperty | Identifies the ArrowAngle dependency property. This field is read-only.
IsDraggingProperty | Identifies the IsDragging dependency property. This field is read-only.
PressedBackgroundProperty | Identifies the PressedBackground dependency property. This field is read-only.
Top
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.ArrowAngleProperty Field

CircularThumbArrowAngleProperty Field
Identifies the ArrowAngle dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ArrowAngleProperty
Public Shared ReadOnly ArrowAngleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ArrowAngle dependency property.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.IsDraggingProperty Field

CircularThumbIsDraggingProperty Field
Identifies the IsDragging dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDraggingProperty
Public Shared ReadOnly IsDraggingProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDragging dependency property.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


CircularThumb.PressedBackgroundProperty Field

CircularThumbPressedBackgroundProperty Field
Identifies the PressedBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PressedBackgroundProperty
Public Shared ReadOnly PressedBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PressedBackground dependency property.
See Also

Reference

CircularThumb Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase Class

RangeBase Class
Represents a radial slider.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.PrimitivesRangeBase
ActiproSoftware.UI.Xaml.ControlsRadialSlider

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class RangeBase : Control
Public MustInherit Class RangeBase
    Inherits Control

The RangeBase type exposes the following members.

Constructors
 | Name | Description
Protected method | RangeBase | Initializes a new instance of the RangeBase class
Top
Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of the range control.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range control.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible Value of the range control.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets a value to be added to or subtracted from the Value of the range control.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | ets or sets the current setting of the range control, which may be coerced.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed.
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
Fields
Name | Description
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase Constructor

RangeBase Constructor
Initializes a new instance of the RangeBase class

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected RangeBase()
Protected Sub New
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase Properties

RangeBase Properties

The RangeBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanDrag | (Inherited from UIElement.)
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of the range control.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range control.
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the lowest possible Value of the range control.
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | SmallChange | Gets or sets a value to be added to or subtracted from the Value of the range control.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | Value | ets or sets the current setting of the range control, which may be coerced.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Top
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.LargeChange Property

RangeBaseLargeChange Property
Gets or sets a value to be added to or subtracted from the Value of the range control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LargeChange { get; set; }
Public Property LargeChange As Double
    Get
    Set

Property Value

Type: Double
The value to be added to or subtracted from the Value of the range control. The default value is 1.0.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.Maximum Property

RangeBaseMaximum Property
Gets or sets the highest possible Value of the range control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Maximum { get; set; }
Public Property Maximum As Double
    Get
    Set

Property Value

Type: Double
The highest possible Value of the range control. The default value is 1.0.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.Minimum Property

RangeBaseMinimum Property
Gets or sets the lowest possible Value of the range control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Minimum { get; set; }
Public Property Minimum As Double
    Get
    Set

Property Value

Type: Double
The lowest possible Value of the range control. The default value is 0.0.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.SmallChange Property

RangeBaseSmallChange Property
Gets or sets a value to be added to or subtracted from the Value of the range control.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double SmallChange { get; set; }
Public Property SmallChange As Double
    Get
    Set

Property Value

Type: Double
The value to be added to or subtracted from the Value of the range control. The default value is 1.0.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.Value Property

RangeBaseValue Property
ets or sets the current setting of the range control, which may be coerced.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set

Property Value

Type: Double
The current setting of the range control, which may be coerced. The default value is 0.0.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase Methods

RangeBase Methods

The RangeBase type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes (such as a rebuilding layout pass) call ApplyTemplate. In simplest terms, this means the method is called just before a UI element displays in your app. Override this method to influence the default post-template logic of a class. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | When implemented in a derived class, returns class-specific AutomationPeer implementations for the Microsoft UI Automation infrastructure. (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Called before the GotFocus event occurs. (Inherited from Control.)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnKeyDown | Called before the KeyDown event occurs. (Inherited from Control.)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnMaximumChanged | Occurs when the Maximum property has changed.
Protected method | OnMinimumChanged | Occurs when the Minimum property has changed.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Called before the PointerEntered event occurs. (Inherited from Control.)
Protected method | OnPointerExited | Called before the PointerExited event occurs. (Inherited from Control.)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Called before the RightTapped event occurs. (Inherited from Control.)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnValueChanged | Occurs when the Value property has changed.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.OnMaximumChanged Method

RangeBaseOnMaximumChanged Method
Occurs when the Maximum property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnMaximumChanged(
    double oldMaximum,
    double newMaximum
)
Protected Overridable Sub OnMaximumChanged (
    oldMaximum As Double,
    newMaximum As Double
)

Parameters

oldMaximum
Type: SystemDouble
The old value.
newMaximum
Type: SystemDouble
The new value.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.OnMinimumChanged Method

RangeBaseOnMinimumChanged Method
Occurs when the Minimum property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnMinimumChanged(
    double oldMinimum,
    double newMinimum
)
Protected Overridable Sub OnMinimumChanged (
    oldMinimum As Double,
    newMinimum As Double
)

Parameters

oldMinimum
Type: SystemDouble
The old value.
newMinimum
Type: SystemDouble
The new value.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.OnValueChanged Method

RangeBaseOnValueChanged Method
Occurs when the Value property has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnValueChanged(
    double oldValue,
    double newValue
)
Protected Overridable Sub OnValueChanged (
    oldValue As Double,
    newValue As Double
)

Parameters

oldValue
Type: SystemDouble
The old value.
newValue
Type: SystemDouble
The new value.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase Events

RangeBase Events

The RangeBase type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs after the Value property value changes.
Top
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.ValueChanged Event

RangeBaseValueChanged Event
Occurs after the Value property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler ValueChanged
Public Event ValueChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase Fields

RangeBase Fields

The RangeBase type exposes the following members.

Fields
Name | Description
LargeChangeProperty | Identifies the LargeChange dependency property. This field is read-only.
MaximumProperty | Identifies the Maximum dependency property. This field is read-only.
MinimumProperty | Identifies the Minimum dependency property. This field is read-only.
SmallChangeProperty | Identifies the SmallChange dependency property. This field is read-only.
ValueProperty | Identifies the Value dependency property. This field is read-only.
Top
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.LargeChangeProperty Field

RangeBaseLargeChangeProperty Field
Identifies the LargeChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LargeChangeProperty
Public Shared ReadOnly LargeChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LargeChange dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.MaximumProperty Field

RangeBaseMaximumProperty Field
Identifies the Maximum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaximumProperty
Public Shared ReadOnly MaximumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Maximum dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.MinimumProperty Field

RangeBaseMinimumProperty Field
Identifies the Minimum dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinimumProperty
Public Shared ReadOnly MinimumProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Minimum dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.SmallChangeProperty Field

RangeBaseSmallChangeProperty Field
Identifies the SmallChange dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SmallChangeProperty
Public Shared ReadOnly SmallChangeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SmallChange dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


RangeBase.ValueProperty Field

RangeBaseValueProperty Field
Identifies the Value dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.Primitives
Assembly: AS.Shared.Universal (in AS.Shared.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ValueProperty
Public Shared ReadOnly ValueProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Value dependency property.
See Also

Reference

RangeBase Class
ActiproSoftware.UI.Xaml.Controls.Primitives Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
Contains types related to the SyntaxEditor product.
Classes
 | Class | Description
Public class | CaretStyle | Specifies the drawing style of a ICaret.
Public class | CutCopyDragAction | Specifies the source of a CutCopyDrag event.
Public class | CutCopyDragEventArgs | Event arguments for the CutCopyDrag event.
Public class | DisplayItemClassificationTypeProvider | Represents a provider of IClassificationType objects for the UI display items within a SyntaxEditor.
Public class | EditorCommands | Contains the commands used for the SyntaxEditor control.
Public class | EditorDocumentChangedEventArgs | Event arguments for an IEditorDocument change event.
Public class | EditorDocumentLanguageChangedEventArgs | Event arguments for an ISyntaxLanguage change event.
Public class | EditorSearchScope | Specifies the scope in which a find/replace operation should occur.
Public class | EditorSnapshotChangedEventArgs | Event arguments for the SyntaxEditor.DocumentTextChanged event.
Public class | EditorSnapshotChangingEventArgs | Event arguments for the SyntaxEditor.DocumentTextChanging event.
Public class | EditorViewChangedEventArgs | Event arguments for an IEditorView change event.
Public class | EditorViewPlacement | Specifies an individual IEditorView location within a split SyntaxEditor.
Public class | EditorViewSearchEventArgs | Event arguments for a search operation within an IEditorView.
Public class | EditorViewSelectionEventArgs | Event arguments for a selection change within an IEditorView.
Public class | HitTestResultType | Specifies a high-level categorization about what an IHitTestResult represents.
Public class | IndentMode | Specifies the type of indentation to perform when the key is pressed.
Public class | LocationToPositionAlgorithm | Specifies a type of location to TextPosition algorithm.
Public class | MacroRecordingState | Specifies the state of macro recording.
Public class | PasteDragDropAction | Specifies the source of a PasteDragDrop event.
Public class | PasteDragDropEventArgs | Event arguments for the PasteDragDrop event.
Public class | SelectionModes | Specifies the types of selection.
Public class | SyntaxEditor | Represents a syntax-highlighting code editor control.
Public class | TextBounds | Describes the width, height, location, and flow direction of a range of text.
Public class | TextCompositionEventArgs | Event arguments for a text composition.
Public class | TextViewEventArgs | Event arguments for a ITextView.
Public class | TextViewLineChange | Specifies the change made to the text represented by an ITextViewLine on the last layout pass.
Public class | TextViewLineVisibility | Specifies the vertical visibility of an ITextViewLine.
Public class | TextViewTextAreaLayoutEventArgs | Event arguments for a ITextView.TextAreaLayout event.
Public class | WordWrapMode | Specifies the mode of word wrapping to perform.
Interfaces
 | Interface | Description
Public interface | ICaret | Provides the base requirements for a blinking caret within a view.
Public interface | ICollapsedRegionManager | Provides the base requirements for a manager that can return information about collapsed regions.
Public interface | IDataStore | Defines the base requirements for an object that can be used to wrap access of data for clipboard operations.
Public interface | IEditAction | Defines the base requirements for an edit action that can be performed in an IEditorView.
Public interface | IEditorDocumentTextChangeEventSink | Provides the base requirements for an object that can be notified of IEditorDocument text change events.
Public interface | IEditorSearchOptions | Provides the base requirements for find/replace options within a view.
Public interface | IEditorView | Provides the base requirements for a text view that is presented in a SyntaxEditor.
Public interface | IEditorViewIntelliPrompt | Provides the base requirements for an object that can request IntelliPrompt within an IEditorView.
Public interface | IEditorViewKeyInputEventSink | Provides the base requirements for an object that can be notified of IEditorView keyboard input events.
Public interface | IEditorViewLine | Provides the base requirements for a display line within an IEditorView.
Public interface | IEditorViewLineCollection | Provides the base requirements for a read-only collection of IEditorViewLine objects.
Public interface | IEditorViewMouseInputEventSink | Provides the base requirements for an object that can be notified of IEditorView mouse input events.
Public interface | IEditorViewScroller | Provides the base requirements for an object that can scroll an IEditorView.
Public interface | IEditorViewSearcher | Provides the base requirements for an object that can perform find/replace and other search-related operations on an IEditorView.
Public interface | IEditorViewSelection | Provides the base requirements for an object that tracks the selection of an IEditorView.
Public interface | IEditorViewSelectionChangeEventSink | Provides the base requirements for an object that can be notified of IEditorView selection change events.
Public interface | IEditorViewSelectionState | Provides the base requirements for an object that can persist the selection state for an IEditorView and restore it later under a new snapshot.
Public interface | IEditorViewTextChangeActions | Provides the base requirements for an object that performs text change actions in an IEditorView.
Public interface | IEditorViewTextChangeOptions | Provides the base requirements for options that are applied to an ITextChange, and are created from an IEditorView.
Public interface | IEditorViewTextInputEventSink | Provides the base requirements for an object that can be notified of IEditorView text input events.
Public interface | IHitTestResult | Provides the base requirements for the hit test results of a call to the SyntaxEditor.HitTest(Point) method.
Public interface | IIndentProvider | Provides the base requirements of an object that indicates how text should be indented when the end user presses Enter.
Public interface | IMacroRecording | Provides the base requirements for all macro recording functionality in a SyntaxEditor.
Public interface | IPrinterView | Provides the base requirements for a text view that is presented on a printed page.
Public interface | IPrinterViewLine | Provides the base requirements for a display line within an IPrinterView.
Public interface | IPrinterViewLineCollection | Provides the base requirements for a read-only collection of IPrinterViewLine objects.
Public interface | IPrintSettings | Provides the base requirements for an object that supports printing the contents of a SyntaxEditor.
Public interface | ITextPositionFinder | Provides the base requirements for a helper class that finds TextPosition objects based on the current state of an IEditorView.
Public interface | ITextView | Provides the base requirements for a text view.
Public interface | ITextViewLifecycleEventSink | Provides the base requirements for an object that can be notified of when a ITextView becomes associated and disassociated with a language, via events such as view open/close, document change, or language change.
Public interface | ITextViewLine | Provides the base requirements for a display line within an ITextView.
Public interface | ITextViewLineCollection | Provides the base requirements for a read-only collection of ITextViewLine objects.
Public interface | ITextViewLineFormattingOptions | Provides the base requirements for an object that provides line formatting options to an ITextView.


CaretStyle Class

CaretStyle Class
Specifies the drawing style of a ICaret.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorCaretStyle

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CaretStyle : Enum
Public NotInheritable Class CaretStyle
    Inherits Enum

The CaretStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Block | Draw a block over the character.
 | HorizontalUnderline | Draw a horizontal underline.
Public field | value__ |
 | VerticalLine | Draw a vertical line.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CaretStyle Methods

CaretStyle Methods

The CaretStyle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CaretStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CaretStyle Fields

CaretStyle Fields

The CaretStyle type exposes the following members.

Fields
 | Name | Description
 | Block | Draw a block over the character.
 | HorizontalUnderline | Draw a horizontal underline.
Public field | value__ |
 | VerticalLine | Draw a vertical line.
Top
See Also

Reference

CaretStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CaretStyle.Block Field

CaretStyleBlock Field
Draw a block over the character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CaretStyle Block = 2
Public Const Block As CaretStyle = 2

Field Value

Type: CaretStyle
See Also

Reference

CaretStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CaretStyle.HorizontalUnderline Field

CaretStyleHorizontalUnderline Field
Draw a horizontal underline.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CaretStyle HorizontalUnderline = 1
Public Const HorizontalUnderline As CaretStyle = 1

Field Value

Type: CaretStyle
See Also

Reference

CaretStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CaretStyle.value__ Field

CaretStylevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.CaretStyle.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CaretStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CaretStyle.VerticalLine Field

CaretStyleVerticalLine Field
Draw a vertical line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CaretStyle VerticalLine = 0
Public Const VerticalLine As CaretStyle = 0

Field Value

Type: CaretStyle
See Also

Reference

CaretStyle Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction Class

CutCopyDragAction Class
Specifies the source of a CutCopyDrag event.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorCutCopyDragAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class CutCopyDragAction : Enum
Public NotInheritable Class CutCopyDragAction
    Inherits Enum

The CutCopyDragAction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Copy | The action is a copy text operation.
 | Cut | The action is a cut text operation.
 | Drag | The action is a drag operation.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction Methods

CutCopyDragAction Methods

The CutCopyDragAction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

CutCopyDragAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction Fields

CutCopyDragAction Fields

The CutCopyDragAction type exposes the following members.

Fields
 | Name | Description
 | Copy | The action is a copy text operation.
 | Cut | The action is a cut text operation.
 | Drag | The action is a drag operation.
Public field | value__ |
Top
See Also

Reference

CutCopyDragAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction.Copy Field

CutCopyDragActionCopy Field
The action is a copy text operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CutCopyDragAction Copy = 0
Public Const Copy As CutCopyDragAction = 0

Field Value

Type: CutCopyDragAction
See Also

Reference

CutCopyDragAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction.Cut Field

CutCopyDragActionCut Field
The action is a cut text operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CutCopyDragAction Cut = 1
Public Const Cut As CutCopyDragAction = 1

Field Value

Type: CutCopyDragAction
See Also

Reference

CutCopyDragAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction.Drag Field

CutCopyDragActionDrag Field
The action is a drag operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const CutCopyDragAction Drag = 2
Public Const Drag As CutCopyDragAction = 2

Field Value

Type: CutCopyDragAction
See Also

Reference

CutCopyDragAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragAction.value__ Field

CutCopyDragActionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.CutCopyDragAction.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

CutCopyDragAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragEventArgs Class

CutCopyDragEventArgs Class
Event arguments for the CutCopyDrag event.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorCutCopyDragEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CutCopyDragEventArgs
Public Class CutCopyDragEventArgs

The CutCopyDragEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CutCopyDragEventArgs | Initializes a new instance of the CutCopyDragEventArgs class.
Top
Properties
 | Name | Description
Public property | Action | Gets the CutCopyDragAction describing the action that is the source of the event.
Public property | DataStore | Gets the IDataStore that contains the data to be dragged or set to the clipboard.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragEventArgs Constructor

CutCopyDragEventArgs Constructor
Initializes a new instance of the CutCopyDragEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CutCopyDragEventArgs(
    CutCopyDragAction action,
    IDataStore dataStore
)
Public Sub New (
    action As CutCopyDragAction,
    dataStore As IDataStore
)

Parameters

action
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorCutCopyDragAction
The CutCopyDragAction describing the action that is the source of the event.
dataStore
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIDataStore
The IDataStore that contains the data to be dragged or set to the clipboard.
See Also

Reference

CutCopyDragEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragEventArgs Properties

CutCopyDragEventArgs Properties

The CutCopyDragEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets the CutCopyDragAction describing the action that is the source of the event.
Public property | DataStore | Gets the IDataStore that contains the data to be dragged or set to the clipboard.
Top
See Also

Reference

CutCopyDragEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragEventArgs.Action Property

CutCopyDragEventArgsAction Property
Gets the CutCopyDragAction describing the action that is the source of the event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CutCopyDragAction Action { get; }
Public ReadOnly Property Action As CutCopyDragAction
    Get

Property Value

Type: CutCopyDragAction
The CutCopyDragAction describing the action that is the source of the event.
See Also

Reference

CutCopyDragEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragEventArgs.DataStore Property

CutCopyDragEventArgsDataStore Property
Gets the IDataStore that contains the data to be dragged or set to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataStore DataStore { get; }
Public ReadOnly Property DataStore As IDataStore
    Get

Property Value

Type: IDataStore
The IDataStore that contains the data to be dragged or set to the clipboard.
See Also

Reference

CutCopyDragEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


CutCopyDragEventArgs Methods

CutCopyDragEventArgs Methods

The CutCopyDragEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CutCopyDragEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider Class

DisplayItemClassificationTypeProvider Class
Represents a provider of IClassificationType objects for the UI display items within a SyntaxEditor.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorDisplayItemClassificationTypeProvider

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class DisplayItemClassificationTypeProvider
Public Class DisplayItemClassificationTypeProvider

The DisplayItemClassificationTypeProvider type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayItemClassificationTypeProvider | Initializes a new instance of the DisplayItemClassificationTypeProvider class.
Public method | DisplayItemClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the DisplayItemClassificationTypeProvider class.
Top
Properties
 | Name | Description
Public property | BreakpointDisabled | Gets the IClassificationType to use for a disabled breakpoint.
Public property | BreakpointEnabled | Gets the IClassificationType to use for an enabled breakpoint.
Public property | CodeSnippetDependentField | Gets the IClassificationType to use for a code snippet dependent field.
Public property | CodeSnippetField | Gets the IClassificationType to use for a code snippet field.
Public property | CollapsedText | Gets the IClassificationType to use for collapsed text.
Public property | CollapsibleRegion | Gets the IClassificationType to use for collapsible regions.
Public property | CurrentLine | Gets the IClassificationType to use for a current line highlight.
Public property | CurrentStatement | Gets the IClassificationType to use for a current statement.
Public property | DelimiterMatching | Gets the IClassificationType to use for a delimiter match highlight.
Public property | FindMatchHighlight | Gets the IClassificationType to use for a find match highlight.
Public property | IndentationGuides | Gets the IClassificationType to use for indentation guides.
Public property | IndicatorMargin | Gets the IClassificationType to use for the indicator margin.
Public property | LineNumbers | Gets the IClassificationType to use for line numbers.
Public property | OutliningMarginSquare | Gets the IClassificationType to use for outlining margin squares.
Public property | OutliningMarginVerticalRule | Gets the IClassificationType to use for outlining margin vertical rules.
Public property | PlainText | Gets the IClassificationType to use for plain text.
Public property | RevertedChangesMark | Gets the IClassificationType to use for reverted changes marks.
Public property | SavedChangesMark | Gets the IClassificationType to use for saved changes marks.
Public property | UnsavedChangesMark | Gets the IClassificationType to use for unsaved changes marks.
Public property | VisibleWhitespace | Gets the IClassificationType to use for visible whitespace.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider Constructor

DisplayItemClassificationTypeProvider Constructor
Overload List
 | Name | Description
Public method | DisplayItemClassificationTypeProvider | Initializes a new instance of the DisplayItemClassificationTypeProvider class.
Public method | DisplayItemClassificationTypeProvider(IHighlightingStyleRegistry) | Initializes a new instance of the DisplayItemClassificationTypeProvider class.
Top
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider Constructor

DisplayItemClassificationTypeProvider Constructor
Initializes a new instance of the DisplayItemClassificationTypeProvider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DisplayItemClassificationTypeProvider()
Public Sub New
See Also

Reference

DisplayItemClassificationTypeProvider Class
DisplayItemClassificationTypeProvider Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider Constructor (IHighlightingStyleRegistry)

DisplayItemClassificationTypeProvider Constructor (IHighlightingStyleRegistry)
Initializes a new instance of the DisplayItemClassificationTypeProvider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DisplayItemClassificationTypeProvider(
    IHighlightingStyleRegistry registry
)
Public Sub New (
    registry As IHighlightingStyleRegistry
)

Parameters

registry
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HighlightingIHighlightingStyleRegistry
The IHighlightingStyleRegistry to use when registering classification types and highlighting styles.
See Also

Reference

DisplayItemClassificationTypeProvider Class
DisplayItemClassificationTypeProvider Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider Properties

DisplayItemClassificationTypeProvider Properties

The DisplayItemClassificationTypeProvider type exposes the following members.

Properties
 | Name | Description
Public property | BreakpointDisabled | Gets the IClassificationType to use for a disabled breakpoint.
Public property | BreakpointEnabled | Gets the IClassificationType to use for an enabled breakpoint.
Public property | CodeSnippetDependentField | Gets the IClassificationType to use for a code snippet dependent field.
Public property | CodeSnippetField | Gets the IClassificationType to use for a code snippet field.
Public property | CollapsedText | Gets the IClassificationType to use for collapsed text.
Public property | CollapsibleRegion | Gets the IClassificationType to use for collapsible regions.
Public property | CurrentLine | Gets the IClassificationType to use for a current line highlight.
Public property | CurrentStatement | Gets the IClassificationType to use for a current statement.
Public property | DelimiterMatching | Gets the IClassificationType to use for a delimiter match highlight.
Public property | FindMatchHighlight | Gets the IClassificationType to use for a find match highlight.
Public property | IndentationGuides | Gets the IClassificationType to use for indentation guides.
Public property | IndicatorMargin | Gets the IClassificationType to use for the indicator margin.
Public property | LineNumbers | Gets the IClassificationType to use for line numbers.
Public property | OutliningMarginSquare | Gets the IClassificationType to use for outlining margin squares.
Public property | OutliningMarginVerticalRule | Gets the IClassificationType to use for outlining margin vertical rules.
Public property | PlainText | Gets the IClassificationType to use for plain text.
Public property | RevertedChangesMark | Gets the IClassificationType to use for reverted changes marks.
Public property | SavedChangesMark | Gets the IClassificationType to use for saved changes marks.
Public property | UnsavedChangesMark | Gets the IClassificationType to use for unsaved changes marks.
Public property | VisibleWhitespace | Gets the IClassificationType to use for visible whitespace.
Top
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.BreakpointDisabled Property

DisplayItemClassificationTypeProviderBreakpointDisabled Property
Gets the IClassificationType to use for a disabled breakpoint.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType BreakpointDisabled { get; }
Public ReadOnly Property BreakpointDisabled As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for a disabled breakpoint.
Remarks
Only the border is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.BreakpointEnabled Property

DisplayItemClassificationTypeProviderBreakpointEnabled Property
Gets the IClassificationType to use for an enabled breakpoint.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType BreakpointEnabled { get; }
Public ReadOnly Property BreakpointEnabled As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for an enabled breakpoint.
Remarks
Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.CodeSnippetDependentField Property

DisplayItemClassificationTypeProviderCodeSnippetDependentField Property
Gets the IClassificationType to use for a code snippet dependent field.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CodeSnippetDependentField { get; }
Public ReadOnly Property CodeSnippetDependentField As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for a code snippet dependent field.
Remarks
Only the border is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.CodeSnippetField Property

DisplayItemClassificationTypeProviderCodeSnippetField Property
Gets the IClassificationType to use for a code snippet field.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CodeSnippetField { get; }
Public ReadOnly Property CodeSnippetField As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for a code snippet field.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.CollapsedText Property

DisplayItemClassificationTypeProviderCollapsedText Property
Gets the IClassificationType to use for collapsed text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CollapsedText { get; }
Public ReadOnly Property CollapsedText As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for collapsed text.
Remarks
Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.CollapsibleRegion Property

DisplayItemClassificationTypeProviderCollapsibleRegion Property
Gets the IClassificationType to use for collapsible regions.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CollapsibleRegion { get; }
Public ReadOnly Property CollapsibleRegion As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for collapsible regions.
Remarks
Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.CurrentLine Property

DisplayItemClassificationTypeProviderCurrentLine Property
Gets the IClassificationType to use for a current line highlight.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CurrentLine { get; }
Public ReadOnly Property CurrentLine As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for current line highlight.
Remarks
Only the background and border are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.CurrentStatement Property

DisplayItemClassificationTypeProviderCurrentStatement Property
Gets the IClassificationType to use for a current statement.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType CurrentStatement { get; }
Public ReadOnly Property CurrentStatement As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for a current statement.
Remarks
Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.DelimiterMatching Property

DisplayItemClassificationTypeProviderDelimiterMatching Property
Gets the IClassificationType to use for a delimiter match highlight.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType DelimiterMatching { get; }
Public ReadOnly Property DelimiterMatching As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for delimiter match highlight.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.FindMatchHighlight Property

DisplayItemClassificationTypeProviderFindMatchHighlight Property
Gets the IClassificationType to use for a find match highlight.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType FindMatchHighlight { get; }
Public ReadOnly Property FindMatchHighlight As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for find match highlight.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.IndentationGuides Property

DisplayItemClassificationTypeProviderIndentationGuides Property
Gets the IClassificationType to use for indentation guides.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType IndentationGuides { get; }
Public ReadOnly Property IndentationGuides As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for indentation guides.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.IndicatorMargin Property

DisplayItemClassificationTypeProviderIndicatorMargin Property
Gets the IClassificationType to use for the indicator margin.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType IndicatorMargin { get; }
Public ReadOnly Property IndicatorMargin As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for the indicator margin.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.LineNumbers Property

DisplayItemClassificationTypeProviderLineNumbers Property
Gets the IClassificationType to use for line numbers.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType LineNumbers { get; }
Public ReadOnly Property LineNumbers As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for line numbers.
Remarks
Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.OutliningMarginSquare Property

DisplayItemClassificationTypeProviderOutliningMarginSquare Property
Gets the IClassificationType to use for outlining margin squares.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType OutliningMarginSquare { get; }
Public ReadOnly Property OutliningMarginSquare As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for outlining margin squares.
Remarks
Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.OutliningMarginVerticalRule Property

DisplayItemClassificationTypeProviderOutliningMarginVerticalRule Property
Gets the IClassificationType to use for outlining margin vertical rules.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType OutliningMarginVerticalRule { get; }
Public ReadOnly Property OutliningMarginVerticalRule As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for outlining margin vertical rules.
Remarks
Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.PlainText Property

DisplayItemClassificationTypeProviderPlainText Property
Gets the IClassificationType to use for plain text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType PlainText { get; }
Public ReadOnly Property PlainText As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for plain text.
Remarks
Only the foreground and background are editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.RevertedChangesMark Property

DisplayItemClassificationTypeProviderRevertedChangesMark Property
Gets the IClassificationType to use for reverted changes marks.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType RevertedChangesMark { get; }
Public ReadOnly Property RevertedChangesMark As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for reverted changes marks.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.SavedChangesMark Property

DisplayItemClassificationTypeProviderSavedChangesMark Property
Gets the IClassificationType to use for saved changes marks.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType SavedChangesMark { get; }
Public ReadOnly Property SavedChangesMark As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for saved changes marks.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.UnsavedChangesMark Property

DisplayItemClassificationTypeProviderUnsavedChangesMark Property
Gets the IClassificationType to use for unsaved changes marks.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType UnsavedChangesMark { get; }
Public ReadOnly Property UnsavedChangesMark As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for unsaved changes marks.
Remarks
Only the background is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.VisibleWhitespace Property

DisplayItemClassificationTypeProviderVisibleWhitespace Property
Gets the IClassificationType to use for visible whitespace.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IClassificationType VisibleWhitespace { get; }
Public ReadOnly Property VisibleWhitespace As IClassificationType
    Get

Property Value

Type: IClassificationType
The IClassificationType to use for visible whitespace.
Remarks
Only the foreground is editable in the default IHighlightingStyle that is registered for this classification type.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider Methods

DisplayItemClassificationTypeProvider Methods

The DisplayItemClassificationTypeProvider type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | RegisterAll | Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


DisplayItemClassificationTypeProvider.RegisterAll Method

DisplayItemClassificationTypeProviderRegisterAll Method
Registers all classification types and highlighting styles with the IHighlightingStyleRegistry used by this class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<IClassificationType> RegisterAll()
Public Function RegisterAll As IEnumerable(Of IClassificationType)

Return Value

Type: IEnumerable IClassificationType
The collection of IClassificationType objects that were registered.
See Also

Reference

DisplayItemClassificationTypeProvider Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands Class

EditorCommands Class
Contains the commands used for the SyntaxEditor control.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorCommands

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class EditorCommands
Public NotInheritable Class EditorCommands

The EditorCommands type exposes the following members.

Properties
Name | Description
Backspace | Gets the EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the previous character.
BackspaceToPreviousWord | Gets the EditActionCommand that backspaces and deletes text to the beginning of the previous word.
CancelMacroRecording | Gets the EditActionCommand that cancels recording a macro.
Capitalize | Gets the EditActionCommand that capitalizes the first letter of each word.
CodeBlockSelectionContract | Gets the EditActionCommand that contracts the code block selection level.
CodeBlockSelectionExpand | Gets the EditActionCommand that expands the code block selection level.
CollapseSelection | Gets the EditActionCommand that collapses the selection to the caret.
CollapseToDefinitions | Gets the EditActionCommand that collapses all outlining nodes that have an IsImplementation value of true.
CommentLines | Gets the EditActionCommand that comments the currently selected lines.
ConvertSpacesToTabs | Gets the EditActionCommand that converts all spaces in the selection to an equivalent number of tabs.
ConvertTabsToSpaces | Gets the EditActionCommand that converts all tabs in the selection to an equivalent number of spaces.
CopyAndAppendToClipboard | Gets the EditActionCommand that copies and appends the currently selected text to the clipboard.
CopyToClipboard | Gets the EditActionCommand that copies the currently selected text to the clipboard.
CutAndAppendToClipboard | Gets the EditActionCommand that cuts and appends the currently selected text to the clipboard.
CutLineToClipboard | Gets the EditActionCommand that cuts the current view line's text to the clipboard.
CutToClipboard | Gets the EditActionCommand that cuts the currently selected text to the clipboard.
Delete | Gets the EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the next character.
DeleteBlankLines | Gets the EditActionCommand that deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
DeleteHorizontalWhitespace | Gets the EditActionCommand that deletes the horizontal whitespace within the current selection.
DeleteLine | Gets the EditActionCommand that deletes the currently active view line.
DeleteToLineEnd | Gets the EditActionCommand that deletes the currently selected text through to the end of the current view line.
DeleteToLineStart | Gets the EditActionCommand that deletes the currently selected text through to the start of the current view line.
DeleteToNextWord | Gets the EditActionCommand that deletes text to the beginning of the next word.
DuplicateLine | Gets the EditActionCommand that duplicates the current view line.
FormatDocument | Gets the EditActionCommand that formats the document.
FormatSelection | Gets the EditActionCommand that formats the currently selected lines.
HideSelection | Gets the EditActionCommand that collapses the current selection.
IncrementalSearch | Gets the EditActionCommand that performs a forward incremental search.
Indent | Gets the EditActionCommand that indents the currently selected lines.
InsertLineBreak | Gets the EditActionCommand that inserts a line break at the current position.
InsertTabStopOrIndent | Gets the EditActionCommand that inserts whitespace to bring the caret to the next tab stop if there is no selection, or alternatively indents the currently selected lines.
MakeLowercase | Gets the EditActionCommand that changes the character casing of the selected text to lowercase.
MakeUppercase | Gets the EditActionCommand that changes the character casing of the selected text to uppercase.
MoveDown | Gets the EditActionCommand that is used to move the caret down a line.
MoveLeft | Gets the EditActionCommand that is used to move the caret left a character.
MovePageDown | Gets the EditActionCommand that is used to move the caret down a page.
MovePageUp | Gets the EditActionCommand that is used to move the caret up a page.
MoveRight | Gets the EditActionCommand that is used to move the caret right a character.
MoveSelectedLinesDown | Gets the EditActionCommand that moves the selected lines down.
MoveSelectedLinesUp | Gets the EditActionCommand that moves the selected lines up.
MoveToDocumentEnd | Gets the EditActionCommand that is used to move the caret to the document end.
MoveToDocumentStart | Gets the EditActionCommand that is used to move the caret to the document start.
MoveToLineEnd | Gets the EditActionCommand that is used to move the caret to the line end.
MoveToLineStart | Gets the EditActionCommand that is used to move the caret to the line start.
MoveToLineStartAfterIndentation | Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the current view line.
MoveToMatchingBracket | Gets the EditActionCommand that is used to move the caret to the matching bracket, if any.
MoveToNextLineStartAfterIndentation | Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the next view line.
MoveToNextWord | Gets the EditActionCommand that is used to move the caret to the next word.
MoveToPreviousLineStartAfterIndentation | Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the previous view line.
MoveToPreviousWord | Gets the EditActionCommand that is used to move the caret to the previous word.
MoveToVisibleBottom | Gets the EditActionCommand that is used to move the caret to the bottom of the view.
MoveToVisibleTop | Gets the EditActionCommand that is used to move the caret to the top of the view.
MoveUp | Gets the EditActionCommand that is used to move the caret up a line.
OpenLineAbove | Gets the EditActionCommand that inserts a new line above the current view line.
OpenLineBelow | Gets the EditActionCommand that inserts a new line below the current view line.
Outdent | Gets the EditActionCommand that outdents the currently selected lines.
PasteFromClipboard | Gets the EditActionCommand that pastes text from the clipboard into the editor view.
PauseResumeMacroRecording | Gets the EditActionCommand that pauses or resumes recording a macro, depending on the current state of macro recording.
Redo | Gets the EditActionCommand that performs a redo operation.
RemoveTabStopOrOutdent | Gets the EditActionCommand that removes whitespace to bring the caret to the previous tab stop if there is no selection, or alternatively outdents the currently selected lines.
RequestIntelliPromptAutoComplete | Gets the EditActionCommand that performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset
RequestIntelliPromptCompletionSession | Gets the EditActionCommand that displays a completion list if the language supports an IntelliPrompt completion session at the current offset
RequestIntelliPromptInsertSnippetSession | Gets the EditActionCommand that allows for IntelliPrompt 'surrounds with' code snippet selection at the current offset.
RequestIntelliPromptParameterInfoSession | Gets the EditActionCommand that displays IntelliPrompt parameter info based on the current context.
RequestIntelliPromptQuickInfoSession | Gets the EditActionCommand that displays IntelliPrompt quick info based on the current context.
RequestIntelliPromptSurroundWithSession | Gets the EditActionCommand that allows for IntelliPrompt 'expansion' code snippet selection at the current offset.
ReverseIncrementalSearch | Gets the EditActionCommand that performs a reverse incremental search.
RunMacro | Gets the EditActionCommand that runs the macro that was last recorded.
ScrollDown | Gets the EditActionCommand that is used to scroll down a line.
ScrollLeft | Gets the EditActionCommand that is used to scroll left a column.
ScrollLineToVisibleBottom | Gets the EditActionCommand that is used to scroll the current view line to the bottom of the view.
ScrollLineToVisibleMiddle | Gets the EditActionCommand that is used to scroll the current view line to the middle of the view.
ScrollLineToVisibleTop | Gets the EditActionCommand that is used to scroll the current view line to the top of the view.
ScrollPageDown | Gets the EditActionCommand that is used to scroll down a page.
ScrollPageUp | Gets the EditActionCommand that is used to scroll up a page.
ScrollRight | Gets the EditActionCommand that is used to scroll right a column.
ScrollToDocumentEnd | Gets the EditActionCommand that is used to scroll the caret to the document end.
ScrollToDocumentStart | Gets the EditActionCommand that is used to scroll the caret to the document start.
ScrollUp | Gets the EditActionCommand that is used to scroll up a line.
SelectAll | Gets the EditActionCommand that is used to select all the text.
SelectBlockDown | Gets the EditActionCommand that is used to extend the block selection down a line.
SelectBlockLeft | Gets the EditActionCommand that is used to extend the block selection left a character.
SelectBlockRight | Gets the EditActionCommand that is used to extend the block selection right a character.
SelectBlockToNextWord | Gets the EditActionCommand that is used to extend the block selection to the next word.
SelectBlockToPreviousWord | Gets the EditActionCommand that is used to extend the block selection to the previous word.
SelectBlockUp | Gets the EditActionCommand that is used to extend the block selection up a line.
SelectDown | Gets the EditActionCommand that is used to extend the selection down a line.
SelectLeft | Gets the EditActionCommand that is used to extend the selection left a character.
SelectPageDown | Gets the EditActionCommand that is used to extend the selection down a page.
SelectPageUp | Gets the EditActionCommand that is used to extend the selection up a page.
SelectRight | Gets the EditActionCommand that is used to extend the selection right a character.
SelectToDocumentEnd | Gets the EditActionCommand that is used to extend the selection to the document end.
SelectToDocumentStart | Gets the EditActionCommand that is used to extend the selection to the document start.
SelectToLineEnd | Gets the EditActionCommand that is used to extend the selection to the line end.
SelectToLineStart | Gets the EditActionCommand that is used to extend the selection to the line start.
SelectToLineStartAfterIndentation | Gets the EditActionCommand that is used to extend the selection to the first non-whitespace character on the current view line.
SelectToMatchingBracket | Gets the EditActionCommand that is used to extend the selection to the matching bracket, if any.
SelectToNextWord | Gets the EditActionCommand that is used to extend the selection to the next word.
SelectToPreviousWord | Gets the EditActionCommand that is used to extend the selection to the previous word.
SelectToVisibleBottom | Gets the EditActionCommand that is used to extend the selection to the bottom of the view.
SelectToVisibleTop | Gets the EditActionCommand that is used to extend the selection to the top of the view.
SelectUp | Gets the EditActionCommand that is used to extend the selection up a line.
SelectWord | Gets the EditActionCommand that is used to select the current word.
StartAutomaticOutlining | Gets the EditActionCommand that is used to start automatic outlining.
StopHidingCurrent | Gets the EditActionCommand that is used to stop hiding the outlining node that currently contains the caret, if any.
StopOutlining | Gets the EditActionCommand that is used to stop outlining.
TabifySelectedLines | Gets the EditActionCommand that converts spaces at the beginning of the active view lines to tabs.
ToggleAllOutliningExpansion | Gets the EditActionCommand that toggles the collapsed state of all outlining nodes.
ToggleCharacterCasing | Gets the EditActionCommand that toggles the character casing of the selected text.
ToggleMacroRecording | Gets the EditActionCommand that starts or stops recording a macro, depending on the current state of macro recording.
ToggleOutliningExpansion | Gets the EditActionCommand that toggles the collapsed state of the outlining node that contains the caret, if any.
ToggleOverwriteMode | Gets the EditActionCommand that toggles overwrite mode.
TransposeCharacters | Gets the EditActionCommand that transposes the characters before and after the caret.
TransposeLines | Gets the EditActionCommand that transposes the current view line with the next view line.
TransposeWords | Gets the EditActionCommand that transposes the words before and after the caret.
TrimAllTrailingWhitespace | Gets the EditActionCommand that trims the trailing whitespace off all the lines in the document.
TrimTrailingWhitespace | Gets the EditActionCommand that trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
UncommentLines | Gets the EditActionCommand that uncomments the currently selected lines.
Undo | Gets the EditActionCommand that performs an undo operation.
UntabifySelectedLines | Gets the EditActionCommand that converts tabs at the beginning of the active view lines to spaces.
Top
Methods
Name | Description
GetAll | Returns a collection of all the known commands.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands Properties

EditorCommands Properties

The EditorCommands type exposes the following members.

Properties
Name | Description
Backspace | Gets the EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the previous character.
BackspaceToPreviousWord | Gets the EditActionCommand that backspaces and deletes text to the beginning of the previous word.
CancelMacroRecording | Gets the EditActionCommand that cancels recording a macro.
Capitalize | Gets the EditActionCommand that capitalizes the first letter of each word.
CodeBlockSelectionContract | Gets the EditActionCommand that contracts the code block selection level.
CodeBlockSelectionExpand | Gets the EditActionCommand that expands the code block selection level.
CollapseSelection | Gets the EditActionCommand that collapses the selection to the caret.
CollapseToDefinitions | Gets the EditActionCommand that collapses all outlining nodes that have an IsImplementation value of true.
CommentLines | Gets the EditActionCommand that comments the currently selected lines.
ConvertSpacesToTabs | Gets the EditActionCommand that converts all spaces in the selection to an equivalent number of tabs.
ConvertTabsToSpaces | Gets the EditActionCommand that converts all tabs in the selection to an equivalent number of spaces.
CopyAndAppendToClipboard | Gets the EditActionCommand that copies and appends the currently selected text to the clipboard.
CopyToClipboard | Gets the EditActionCommand that copies the currently selected text to the clipboard.
CutAndAppendToClipboard | Gets the EditActionCommand that cuts and appends the currently selected text to the clipboard.
CutLineToClipboard | Gets the EditActionCommand that cuts the current view line's text to the clipboard.
CutToClipboard | Gets the EditActionCommand that cuts the currently selected text to the clipboard.
Delete | Gets the EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the next character.
DeleteBlankLines | Gets the EditActionCommand that deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
DeleteHorizontalWhitespace | Gets the EditActionCommand that deletes the horizontal whitespace within the current selection.
DeleteLine | Gets the EditActionCommand that deletes the currently active view line.
DeleteToLineEnd | Gets the EditActionCommand that deletes the currently selected text through to the end of the current view line.
DeleteToLineStart | Gets the EditActionCommand that deletes the currently selected text through to the start of the current view line.
DeleteToNextWord | Gets the EditActionCommand that deletes text to the beginning of the next word.
DuplicateLine | Gets the EditActionCommand that duplicates the current view line.
FormatDocument | Gets the EditActionCommand that formats the document.
FormatSelection | Gets the EditActionCommand that formats the currently selected lines.
HideSelection | Gets the EditActionCommand that collapses the current selection.
IncrementalSearch | Gets the EditActionCommand that performs a forward incremental search.
Indent | Gets the EditActionCommand that indents the currently selected lines.
InsertLineBreak | Gets the EditActionCommand that inserts a line break at the current position.
InsertTabStopOrIndent | Gets the EditActionCommand that inserts whitespace to bring the caret to the next tab stop if there is no selection, or alternatively indents the currently selected lines.
MakeLowercase | Gets the EditActionCommand that changes the character casing of the selected text to lowercase.
MakeUppercase | Gets the EditActionCommand that changes the character casing of the selected text to uppercase.
MoveDown | Gets the EditActionCommand that is used to move the caret down a line.
MoveLeft | Gets the EditActionCommand that is used to move the caret left a character.
MovePageDown | Gets the EditActionCommand that is used to move the caret down a page.
MovePageUp | Gets the EditActionCommand that is used to move the caret up a page.
MoveRight | Gets the EditActionCommand that is used to move the caret right a character.
MoveSelectedLinesDown | Gets the EditActionCommand that moves the selected lines down.
MoveSelectedLinesUp | Gets the EditActionCommand that moves the selected lines up.
MoveToDocumentEnd | Gets the EditActionCommand that is used to move the caret to the document end.
MoveToDocumentStart | Gets the EditActionCommand that is used to move the caret to the document start.
MoveToLineEnd | Gets the EditActionCommand that is used to move the caret to the line end.
MoveToLineStart | Gets the EditActionCommand that is used to move the caret to the line start.
MoveToLineStartAfterIndentation | Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the current view line.
MoveToMatchingBracket | Gets the EditActionCommand that is used to move the caret to the matching bracket, if any.
MoveToNextLineStartAfterIndentation | Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the next view line.
MoveToNextWord | Gets the EditActionCommand that is used to move the caret to the next word.
MoveToPreviousLineStartAfterIndentation | Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the previous view line.
MoveToPreviousWord | Gets the EditActionCommand that is used to move the caret to the previous word.
MoveToVisibleBottom | Gets the EditActionCommand that is used to move the caret to the bottom of the view.
MoveToVisibleTop | Gets the EditActionCommand that is used to move the caret to the top of the view.
MoveUp | Gets the EditActionCommand that is used to move the caret up a line.
OpenLineAbove | Gets the EditActionCommand that inserts a new line above the current view line.
OpenLineBelow | Gets the EditActionCommand that inserts a new line below the current view line.
Outdent | Gets the EditActionCommand that outdents the currently selected lines.
PasteFromClipboard | Gets the EditActionCommand that pastes text from the clipboard into the editor view.
PauseResumeMacroRecording | Gets the EditActionCommand that pauses or resumes recording a macro, depending on the current state of macro recording.
Redo | Gets the EditActionCommand that performs a redo operation.
RemoveTabStopOrOutdent | Gets the EditActionCommand that removes whitespace to bring the caret to the previous tab stop if there is no selection, or alternatively outdents the currently selected lines.
RequestIntelliPromptAutoComplete | Gets the EditActionCommand that performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset
RequestIntelliPromptCompletionSession | Gets the EditActionCommand that displays a completion list if the language supports an IntelliPrompt completion session at the current offset
RequestIntelliPromptInsertSnippetSession | Gets the EditActionCommand that allows for IntelliPrompt 'surrounds with' code snippet selection at the current offset.
RequestIntelliPromptParameterInfoSession | Gets the EditActionCommand that displays IntelliPrompt parameter info based on the current context.
RequestIntelliPromptQuickInfoSession | Gets the EditActionCommand that displays IntelliPrompt quick info based on the current context.
RequestIntelliPromptSurroundWithSession | Gets the EditActionCommand that allows for IntelliPrompt 'expansion' code snippet selection at the current offset.
ReverseIncrementalSearch | Gets the EditActionCommand that performs a reverse incremental search.
RunMacro | Gets the EditActionCommand that runs the macro that was last recorded.
ScrollDown | Gets the EditActionCommand that is used to scroll down a line.
ScrollLeft | Gets the EditActionCommand that is used to scroll left a column.
ScrollLineToVisibleBottom | Gets the EditActionCommand that is used to scroll the current view line to the bottom of the view.
ScrollLineToVisibleMiddle | Gets the EditActionCommand that is used to scroll the current view line to the middle of the view.
ScrollLineToVisibleTop | Gets the EditActionCommand that is used to scroll the current view line to the top of the view.
ScrollPageDown | Gets the EditActionCommand that is used to scroll down a page.
ScrollPageUp | Gets the EditActionCommand that is used to scroll up a page.
ScrollRight | Gets the EditActionCommand that is used to scroll right a column.
ScrollToDocumentEnd | Gets the EditActionCommand that is used to scroll the caret to the document end.
ScrollToDocumentStart | Gets the EditActionCommand that is used to scroll the caret to the document start.
ScrollUp | Gets the EditActionCommand that is used to scroll up a line.
SelectAll | Gets the EditActionCommand that is used to select all the text.
SelectBlockDown | Gets the EditActionCommand that is used to extend the block selection down a line.
SelectBlockLeft | Gets the EditActionCommand that is used to extend the block selection left a character.
SelectBlockRight | Gets the EditActionCommand that is used to extend the block selection right a character.
SelectBlockToNextWord | Gets the EditActionCommand that is used to extend the block selection to the next word.
SelectBlockToPreviousWord | Gets the EditActionCommand that is used to extend the block selection to the previous word.
SelectBlockUp | Gets the EditActionCommand that is used to extend the block selection up a line.
SelectDown | Gets the EditActionCommand that is used to extend the selection down a line.
SelectLeft | Gets the EditActionCommand that is used to extend the selection left a character.
SelectPageDown | Gets the EditActionCommand that is used to extend the selection down a page.
SelectPageUp | Gets the EditActionCommand that is used to extend the selection up a page.
SelectRight | Gets the EditActionCommand that is used to extend the selection right a character.
SelectToDocumentEnd | Gets the EditActionCommand that is used to extend the selection to the document end.
SelectToDocumentStart | Gets the EditActionCommand that is used to extend the selection to the document start.
SelectToLineEnd | Gets the EditActionCommand that is used to extend the selection to the line end.
SelectToLineStart | Gets the EditActionCommand that is used to extend the selection to the line start.
SelectToLineStartAfterIndentation | Gets the EditActionCommand that is used to extend the selection to the first non-whitespace character on the current view line.
SelectToMatchingBracket | Gets the EditActionCommand that is used to extend the selection to the matching bracket, if any.
SelectToNextWord | Gets the EditActionCommand that is used to extend the selection to the next word.
SelectToPreviousWord | Gets the EditActionCommand that is used to extend the selection to the previous word.
SelectToVisibleBottom | Gets the EditActionCommand that is used to extend the selection to the bottom of the view.
SelectToVisibleTop | Gets the EditActionCommand that is used to extend the selection to the top of the view.
SelectUp | Gets the EditActionCommand that is used to extend the selection up a line.
SelectWord | Gets the EditActionCommand that is used to select the current word.
StartAutomaticOutlining | Gets the EditActionCommand that is used to start automatic outlining.
StopHidingCurrent | Gets the EditActionCommand that is used to stop hiding the outlining node that currently contains the caret, if any.
StopOutlining | Gets the EditActionCommand that is used to stop outlining.
TabifySelectedLines | Gets the EditActionCommand that converts spaces at the beginning of the active view lines to tabs.
ToggleAllOutliningExpansion | Gets the EditActionCommand that toggles the collapsed state of all outlining nodes.
ToggleCharacterCasing | Gets the EditActionCommand that toggles the character casing of the selected text.
ToggleMacroRecording | Gets the EditActionCommand that starts or stops recording a macro, depending on the current state of macro recording.
ToggleOutliningExpansion | Gets the EditActionCommand that toggles the collapsed state of the outlining node that contains the caret, if any.
ToggleOverwriteMode | Gets the EditActionCommand that toggles overwrite mode.
TransposeCharacters | Gets the EditActionCommand that transposes the characters before and after the caret.
TransposeLines | Gets the EditActionCommand that transposes the current view line with the next view line.
TransposeWords | Gets the EditActionCommand that transposes the words before and after the caret.
TrimAllTrailingWhitespace | Gets the EditActionCommand that trims the trailing whitespace off all the lines in the document.
TrimTrailingWhitespace | Gets the EditActionCommand that trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
UncommentLines | Gets the EditActionCommand that uncomments the currently selected lines.
Undo | Gets the EditActionCommand that performs an undo operation.
UntabifySelectedLines | Gets the EditActionCommand that converts tabs at the beginning of the active view lines to spaces.
Top
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Backspace Property

EditorCommandsBackspace Property
Gets the EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the previous character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Backspace { get; }
Public Shared ReadOnly Property Backspace As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the previous character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.BackspaceToPreviousWord Property

EditorCommandsBackspaceToPreviousWord Property
Gets the EditActionCommand that backspaces and deletes text to the beginning of the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand BackspaceToPreviousWord { get; }
Public Shared ReadOnly Property BackspaceToPreviousWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that backspaces and deletes text to the beginning of the previous word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CancelMacroRecording Property

EditorCommandsCancelMacroRecording Property
Gets the EditActionCommand that cancels recording a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CancelMacroRecording { get; }
Public Shared ReadOnly Property CancelMacroRecording As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that cancels recording a macro.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Capitalize Property

EditorCommandsCapitalize Property
Gets the EditActionCommand that capitalizes the first letter of each word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Capitalize { get; }
Public Shared ReadOnly Property Capitalize As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that capitalizes the first letter of each word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CodeBlockSelectionContract Property

EditorCommandsCodeBlockSelectionContract Property
Gets the EditActionCommand that contracts the code block selection level.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CodeBlockSelectionContract { get; }
Public Shared ReadOnly Property CodeBlockSelectionContract As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that contracts the code block selection level.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CodeBlockSelectionExpand Property

EditorCommandsCodeBlockSelectionExpand Property
Gets the EditActionCommand that expands the code block selection level.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CodeBlockSelectionExpand { get; }
Public Shared ReadOnly Property CodeBlockSelectionExpand As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that expands the code block selection level.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CollapseSelection Property

EditorCommandsCollapseSelection Property
Gets the EditActionCommand that collapses the selection to the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CollapseSelection { get; }
Public Shared ReadOnly Property CollapseSelection As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that collapses the selection to the caret.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CollapseToDefinitions Property

EditorCommandsCollapseToDefinitions Property
Gets the EditActionCommand that collapses all outlining nodes that have an IsImplementation value of true.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CollapseToDefinitions { get; }
Public Shared ReadOnly Property CollapseToDefinitions As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that collapses all outlining nodes that have an IsImplementation value of true.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CommentLines Property

EditorCommandsCommentLines Property
Gets the EditActionCommand that comments the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CommentLines { get; }
Public Shared ReadOnly Property CommentLines As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that comments the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ConvertSpacesToTabs Property

EditorCommandsConvertSpacesToTabs Property
Gets the EditActionCommand that converts all spaces in the selection to an equivalent number of tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ConvertSpacesToTabs { get; }
Public Shared ReadOnly Property ConvertSpacesToTabs As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that converts all spaces in the selection to an equivalent number of tabs.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ConvertTabsToSpaces Property

EditorCommandsConvertTabsToSpaces Property
Gets the EditActionCommand that converts all tabs in the selection to an equivalent number of spaces.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ConvertTabsToSpaces { get; }
Public Shared ReadOnly Property ConvertTabsToSpaces As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that converts all tabs in the selection to an equivalent number of spaces.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CopyAndAppendToClipboard Property

EditorCommandsCopyAndAppendToClipboard Property
Gets the EditActionCommand that copies and appends the currently selected text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CopyAndAppendToClipboard { get; }
Public Shared ReadOnly Property CopyAndAppendToClipboard As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that copies and appends the currently selected text to the clipboard.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CopyToClipboard Property

EditorCommandsCopyToClipboard Property
Gets the EditActionCommand that copies the currently selected text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CopyToClipboard { get; }
Public Shared ReadOnly Property CopyToClipboard As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that copies the currently selected text to the clipboard.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CutAndAppendToClipboard Property

EditorCommandsCutAndAppendToClipboard Property
Gets the EditActionCommand that cuts and appends the currently selected text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CutAndAppendToClipboard { get; }
Public Shared ReadOnly Property CutAndAppendToClipboard As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that cuts and appends the currently selected text to the clipboard.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CutLineToClipboard Property

EditorCommandsCutLineToClipboard Property
Gets the EditActionCommand that cuts the current view line's text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CutLineToClipboard { get; }
Public Shared ReadOnly Property CutLineToClipboard As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that cuts the current view line's text to the clipboard.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.CutToClipboard Property

EditorCommandsCutToClipboard Property
Gets the EditActionCommand that cuts the currently selected text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand CutToClipboard { get; }
Public Shared ReadOnly Property CutToClipboard As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that cuts the currently selected text to the clipboard.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Delete Property

EditorCommandsDelete Property
Gets the EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the next character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Delete { get; }
Public Shared ReadOnly Property Delete As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the currently selected text if text is selected; otherwise, deletes the next character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DeleteBlankLines Property

EditorCommandsDeleteBlankLines Property
Gets the EditActionCommand that deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DeleteBlankLines { get; }
Public Shared ReadOnly Property DeleteBlankLines As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DeleteHorizontalWhitespace Property

EditorCommandsDeleteHorizontalWhitespace Property
Gets the EditActionCommand that deletes the horizontal whitespace within the current selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DeleteHorizontalWhitespace { get; }
Public Shared ReadOnly Property DeleteHorizontalWhitespace As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the horizontal whitespace within the current selection.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DeleteLine Property

EditorCommandsDeleteLine Property
Gets the EditActionCommand that deletes the currently active view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DeleteLine { get; }
Public Shared ReadOnly Property DeleteLine As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the currently active view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DeleteToLineEnd Property

EditorCommandsDeleteToLineEnd Property
Gets the EditActionCommand that deletes the currently selected text through to the end of the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DeleteToLineEnd { get; }
Public Shared ReadOnly Property DeleteToLineEnd As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the currently selected text through to the end of the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DeleteToLineStart Property

EditorCommandsDeleteToLineStart Property
Gets the EditActionCommand that deletes the currently selected text through to the start of the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DeleteToLineStart { get; }
Public Shared ReadOnly Property DeleteToLineStart As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes the currently selected text through to the start of the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DeleteToNextWord Property

EditorCommandsDeleteToNextWord Property
Gets the EditActionCommand that deletes text to the beginning of the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DeleteToNextWord { get; }
Public Shared ReadOnly Property DeleteToNextWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that deletes text to the beginning of the next word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.DuplicateLine Property

EditorCommandsDuplicateLine Property
Gets the EditActionCommand that duplicates the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand DuplicateLine { get; }
Public Shared ReadOnly Property DuplicateLine As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that duplicates the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.FormatDocument Property

EditorCommandsFormatDocument Property
Gets the EditActionCommand that formats the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand FormatDocument { get; }
Public Shared ReadOnly Property FormatDocument As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that formats the document.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.FormatSelection Property

EditorCommandsFormatSelection Property
Gets the EditActionCommand that formats the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand FormatSelection { get; }
Public Shared ReadOnly Property FormatSelection As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that formats the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.HideSelection Property

EditorCommandsHideSelection Property
Gets the EditActionCommand that collapses the current selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand HideSelection { get; }
Public Shared ReadOnly Property HideSelection As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that collapses the current selection.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.IncrementalSearch Property

EditorCommandsIncrementalSearch Property
Gets the EditActionCommand that performs a forward incremental search.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand IncrementalSearch { get; }
Public Shared ReadOnly Property IncrementalSearch As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that performs a forward incremental search.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Indent Property

EditorCommandsIndent Property
Gets the EditActionCommand that indents the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Indent { get; }
Public Shared ReadOnly Property Indent As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that indents the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.InsertLineBreak Property

EditorCommandsInsertLineBreak Property
Gets the EditActionCommand that inserts a line break at the current position.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand InsertLineBreak { get; }
Public Shared ReadOnly Property InsertLineBreak As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that inserts a line break at the current position.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.InsertTabStopOrIndent Property

EditorCommandsInsertTabStopOrIndent Property
Gets the EditActionCommand that inserts whitespace to bring the caret to the next tab stop if there is no selection, or alternatively indents the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand InsertTabStopOrIndent { get; }
Public Shared ReadOnly Property InsertTabStopOrIndent As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that inserts whitespace to bring the caret to the next tab stop if there is no selection, or alternatively indents the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MakeLowercase Property

EditorCommandsMakeLowercase Property
Gets the EditActionCommand that changes the character casing of the selected text to lowercase.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MakeLowercase { get; }
Public Shared ReadOnly Property MakeLowercase As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that changes the character casing of the selected text to lowercase.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MakeUppercase Property

EditorCommandsMakeUppercase Property
Gets the EditActionCommand that changes the character casing of the selected text to uppercase.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MakeUppercase { get; }
Public Shared ReadOnly Property MakeUppercase As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that changes the character casing of the selected text to uppercase.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveDown Property

EditorCommandsMoveDown Property
Gets the EditActionCommand that is used to move the caret down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveDown { get; }
Public Shared ReadOnly Property MoveDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret down a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveLeft Property

EditorCommandsMoveLeft Property
Gets the EditActionCommand that is used to move the caret left a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveLeft { get; }
Public Shared ReadOnly Property MoveLeft As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret left a character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MovePageDown Property

EditorCommandsMovePageDown Property
Gets the EditActionCommand that is used to move the caret down a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MovePageDown { get; }
Public Shared ReadOnly Property MovePageDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret down a page.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MovePageUp Property

EditorCommandsMovePageUp Property
Gets the EditActionCommand that is used to move the caret up a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MovePageUp { get; }
Public Shared ReadOnly Property MovePageUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret up a page.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveRight Property

EditorCommandsMoveRight Property
Gets the EditActionCommand that is used to move the caret right a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveRight { get; }
Public Shared ReadOnly Property MoveRight As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret right a character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveSelectedLinesDown Property

EditorCommandsMoveSelectedLinesDown Property
Gets the EditActionCommand that moves the selected lines down.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveSelectedLinesDown { get; }
Public Shared ReadOnly Property MoveSelectedLinesDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that moves the selected lines down.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveSelectedLinesUp Property

EditorCommandsMoveSelectedLinesUp Property
Gets the EditActionCommand that moves the selected lines up.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveSelectedLinesUp { get; }
Public Shared ReadOnly Property MoveSelectedLinesUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that moves the selected lines up.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToDocumentEnd Property

EditorCommandsMoveToDocumentEnd Property
Gets the EditActionCommand that is used to move the caret to the document end.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToDocumentEnd { get; }
Public Shared ReadOnly Property MoveToDocumentEnd As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the document end.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToDocumentStart Property

EditorCommandsMoveToDocumentStart Property
Gets the EditActionCommand that is used to move the caret to the document start.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToDocumentStart { get; }
Public Shared ReadOnly Property MoveToDocumentStart As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the document start.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToLineEnd Property

EditorCommandsMoveToLineEnd Property
Gets the EditActionCommand that is used to move the caret to the line end.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToLineEnd { get; }
Public Shared ReadOnly Property MoveToLineEnd As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the line end.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToLineStart Property

EditorCommandsMoveToLineStart Property
Gets the EditActionCommand that is used to move the caret to the line start.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToLineStart { get; }
Public Shared ReadOnly Property MoveToLineStart As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the line start.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToLineStartAfterIndentation Property

EditorCommandsMoveToLineStartAfterIndentation Property
Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToLineStartAfterIndentation { get; }
Public Shared ReadOnly Property MoveToLineStartAfterIndentation As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the first non-whitespace character on the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToMatchingBracket Property

EditorCommandsMoveToMatchingBracket Property
Gets the EditActionCommand that is used to move the caret to the matching bracket, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToMatchingBracket { get; }
Public Shared ReadOnly Property MoveToMatchingBracket As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the matching bracket, if any.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToNextLineStartAfterIndentation Property

EditorCommandsMoveToNextLineStartAfterIndentation Property
Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the next view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToNextLineStartAfterIndentation { get; }
Public Shared ReadOnly Property MoveToNextLineStartAfterIndentation As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the first non-whitespace character on the next view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToNextWord Property

EditorCommandsMoveToNextWord Property
Gets the EditActionCommand that is used to move the caret to the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToNextWord { get; }
Public Shared ReadOnly Property MoveToNextWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the next word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToPreviousLineStartAfterIndentation Property

EditorCommandsMoveToPreviousLineStartAfterIndentation Property
Gets the EditActionCommand that is used to move the caret to the first non-whitespace character on the previous view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToPreviousLineStartAfterIndentation { get; }
Public Shared ReadOnly Property MoveToPreviousLineStartAfterIndentation As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the first non-whitespace character on the previous view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToPreviousWord Property

EditorCommandsMoveToPreviousWord Property
Gets the EditActionCommand that is used to move the caret to the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToPreviousWord { get; }
Public Shared ReadOnly Property MoveToPreviousWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the previous word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToVisibleBottom Property

EditorCommandsMoveToVisibleBottom Property
Gets the EditActionCommand that is used to move the caret to the bottom of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToVisibleBottom { get; }
Public Shared ReadOnly Property MoveToVisibleBottom As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the bottom of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveToVisibleTop Property

EditorCommandsMoveToVisibleTop Property
Gets the EditActionCommand that is used to move the caret to the top of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveToVisibleTop { get; }
Public Shared ReadOnly Property MoveToVisibleTop As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret to the top of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.MoveUp Property

EditorCommandsMoveUp Property
Gets the EditActionCommand that is used to move the caret up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand MoveUp { get; }
Public Shared ReadOnly Property MoveUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to move the caret up a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.OpenLineAbove Property

EditorCommandsOpenLineAbove Property
Gets the EditActionCommand that inserts a new line above the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand OpenLineAbove { get; }
Public Shared ReadOnly Property OpenLineAbove As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that inserts a new line above the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.OpenLineBelow Property

EditorCommandsOpenLineBelow Property
Gets the EditActionCommand that inserts a new line below the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand OpenLineBelow { get; }
Public Shared ReadOnly Property OpenLineBelow As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that inserts a new line below the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Outdent Property

EditorCommandsOutdent Property
Gets the EditActionCommand that outdents the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Outdent { get; }
Public Shared ReadOnly Property Outdent As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that outdents the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.PasteFromClipboard Property

EditorCommandsPasteFromClipboard Property
Gets the EditActionCommand that pastes text from the clipboard into the editor view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand PasteFromClipboard { get; }
Public Shared ReadOnly Property PasteFromClipboard As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that pastes text from the clipboard into the editor view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.PauseResumeMacroRecording Property

EditorCommandsPauseResumeMacroRecording Property
Gets the EditActionCommand that pauses or resumes recording a macro, depending on the current state of macro recording.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand PauseResumeMacroRecording { get; }
Public Shared ReadOnly Property PauseResumeMacroRecording As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that pauses or resumes recording a macro, depending on the current state of macro recording.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Redo Property

EditorCommandsRedo Property
Gets the EditActionCommand that performs a redo operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Redo { get; }
Public Shared ReadOnly Property Redo As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that performs a redo operation.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RemoveTabStopOrOutdent Property

EditorCommandsRemoveTabStopOrOutdent Property
Gets the EditActionCommand that removes whitespace to bring the caret to the previous tab stop if there is no selection, or alternatively outdents the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RemoveTabStopOrOutdent { get; }
Public Shared ReadOnly Property RemoveTabStopOrOutdent As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that removes whitespace to bring the caret to the previous tab stop if there is no selection, or alternatively outdents the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RequestIntelliPromptAutoComplete Property

EditorCommandsRequestIntelliPromptAutoComplete Property
Gets the EditActionCommand that performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RequestIntelliPromptAutoComplete { get; }
Public Shared ReadOnly Property RequestIntelliPromptAutoComplete As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RequestIntelliPromptCompletionSession Property

EditorCommandsRequestIntelliPromptCompletionSession Property
Gets the EditActionCommand that displays a completion list if the language supports an IntelliPrompt completion session at the current offset

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RequestIntelliPromptCompletionSession { get; }
Public Shared ReadOnly Property RequestIntelliPromptCompletionSession As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RequestIntelliPromptInsertSnippetSession Property

EditorCommandsRequestIntelliPromptInsertSnippetSession Property
Gets the EditActionCommand that allows for IntelliPrompt 'surrounds with' code snippet selection at the current offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RequestIntelliPromptInsertSnippetSession { get; }
Public Shared ReadOnly Property RequestIntelliPromptInsertSnippetSession As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that allows for IntelliPrompt 'surrounds with' code snippet selection at the current offset.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RequestIntelliPromptParameterInfoSession Property

EditorCommandsRequestIntelliPromptParameterInfoSession Property
Gets the EditActionCommand that displays IntelliPrompt parameter info based on the current context.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RequestIntelliPromptParameterInfoSession { get; }
Public Shared ReadOnly Property RequestIntelliPromptParameterInfoSession As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that displays IntelliPrompt parameter info based on the current context.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RequestIntelliPromptQuickInfoSession Property

EditorCommandsRequestIntelliPromptQuickInfoSession Property
Gets the EditActionCommand that displays IntelliPrompt quick info based on the current context.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RequestIntelliPromptQuickInfoSession { get; }
Public Shared ReadOnly Property RequestIntelliPromptQuickInfoSession As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that displays IntelliPrompt quick info based on the current context.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RequestIntelliPromptSurroundWithSession Property

EditorCommandsRequestIntelliPromptSurroundWithSession Property
Gets the EditActionCommand that allows for IntelliPrompt 'expansion' code snippet selection at the current offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RequestIntelliPromptSurroundWithSession { get; }
Public Shared ReadOnly Property RequestIntelliPromptSurroundWithSession As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that allows for IntelliPrompt 'expansion' code snippet selection at the current offset.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ReverseIncrementalSearch Property

EditorCommandsReverseIncrementalSearch Property
Gets the EditActionCommand that performs a reverse incremental search.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ReverseIncrementalSearch { get; }
Public Shared ReadOnly Property ReverseIncrementalSearch As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that performs a reverse incremental search.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.RunMacro Property

EditorCommandsRunMacro Property
Gets the EditActionCommand that runs the macro that was last recorded.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand RunMacro { get; }
Public Shared ReadOnly Property RunMacro As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that runs the macro that was last recorded.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollDown Property

EditorCommandsScrollDown Property
Gets the EditActionCommand that is used to scroll down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollDown { get; }
Public Shared ReadOnly Property ScrollDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll down a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollLeft Property

EditorCommandsScrollLeft Property
Gets the EditActionCommand that is used to scroll left a column.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollLeft { get; }
Public Shared ReadOnly Property ScrollLeft As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll left a column.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollLineToVisibleBottom Property

EditorCommandsScrollLineToVisibleBottom Property
Gets the EditActionCommand that is used to scroll the current view line to the bottom of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollLineToVisibleBottom { get; }
Public Shared ReadOnly Property ScrollLineToVisibleBottom As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll the current view line to the bottom of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollLineToVisibleMiddle Property

EditorCommandsScrollLineToVisibleMiddle Property
Gets the EditActionCommand that is used to scroll the current view line to the middle of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollLineToVisibleMiddle { get; }
Public Shared ReadOnly Property ScrollLineToVisibleMiddle As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll the current view line to the middle of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollLineToVisibleTop Property

EditorCommandsScrollLineToVisibleTop Property
Gets the EditActionCommand that is used to scroll the current view line to the top of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollLineToVisibleTop { get; }
Public Shared ReadOnly Property ScrollLineToVisibleTop As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll the current view line to the top of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollPageDown Property

EditorCommandsScrollPageDown Property
Gets the EditActionCommand that is used to scroll down a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollPageDown { get; }
Public Shared ReadOnly Property ScrollPageDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll down a page.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollPageUp Property

EditorCommandsScrollPageUp Property
Gets the EditActionCommand that is used to scroll up a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollPageUp { get; }
Public Shared ReadOnly Property ScrollPageUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll up a page.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollRight Property

EditorCommandsScrollRight Property
Gets the EditActionCommand that is used to scroll right a column.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollRight { get; }
Public Shared ReadOnly Property ScrollRight As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll right a column.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollToDocumentEnd Property

EditorCommandsScrollToDocumentEnd Property
Gets the EditActionCommand that is used to scroll the caret to the document end.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollToDocumentEnd { get; }
Public Shared ReadOnly Property ScrollToDocumentEnd As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll the caret to the document end.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollToDocumentStart Property

EditorCommandsScrollToDocumentStart Property
Gets the EditActionCommand that is used to scroll the caret to the document start.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollToDocumentStart { get; }
Public Shared ReadOnly Property ScrollToDocumentStart As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll the caret to the document start.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ScrollUp Property

EditorCommandsScrollUp Property
Gets the EditActionCommand that is used to scroll up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ScrollUp { get; }
Public Shared ReadOnly Property ScrollUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to scroll up a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectAll Property

EditorCommandsSelectAll Property
Gets the EditActionCommand that is used to select all the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectAll { get; }
Public Shared ReadOnly Property SelectAll As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to select all the text.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectBlockDown Property

EditorCommandsSelectBlockDown Property
Gets the EditActionCommand that is used to extend the block selection down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectBlockDown { get; }
Public Shared ReadOnly Property SelectBlockDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the block selection down a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectBlockLeft Property

EditorCommandsSelectBlockLeft Property
Gets the EditActionCommand that is used to extend the block selection left a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectBlockLeft { get; }
Public Shared ReadOnly Property SelectBlockLeft As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the block selection left a character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectBlockRight Property

EditorCommandsSelectBlockRight Property
Gets the EditActionCommand that is used to extend the block selection right a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectBlockRight { get; }
Public Shared ReadOnly Property SelectBlockRight As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the block selection right a character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectBlockToNextWord Property

EditorCommandsSelectBlockToNextWord Property
Gets the EditActionCommand that is used to extend the block selection to the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectBlockToNextWord { get; }
Public Shared ReadOnly Property SelectBlockToNextWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the block selection to the next word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectBlockToPreviousWord Property

EditorCommandsSelectBlockToPreviousWord Property
Gets the EditActionCommand that is used to extend the block selection to the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectBlockToPreviousWord { get; }
Public Shared ReadOnly Property SelectBlockToPreviousWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the block selection to the previous word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectBlockUp Property

EditorCommandsSelectBlockUp Property
Gets the EditActionCommand that is used to extend the block selection up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectBlockUp { get; }
Public Shared ReadOnly Property SelectBlockUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the block selection up a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectDown Property

EditorCommandsSelectDown Property
Gets the EditActionCommand that is used to extend the selection down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectDown { get; }
Public Shared ReadOnly Property SelectDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection down a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectLeft Property

EditorCommandsSelectLeft Property
Gets the EditActionCommand that is used to extend the selection left a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectLeft { get; }
Public Shared ReadOnly Property SelectLeft As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection left a character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectPageDown Property

EditorCommandsSelectPageDown Property
Gets the EditActionCommand that is used to extend the selection down a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectPageDown { get; }
Public Shared ReadOnly Property SelectPageDown As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection down a page.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectPageUp Property

EditorCommandsSelectPageUp Property
Gets the EditActionCommand that is used to extend the selection up a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectPageUp { get; }
Public Shared ReadOnly Property SelectPageUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection up a page.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectRight Property

EditorCommandsSelectRight Property
Gets the EditActionCommand that is used to extend the selection right a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectRight { get; }
Public Shared ReadOnly Property SelectRight As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection right a character.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToDocumentEnd Property

EditorCommandsSelectToDocumentEnd Property
Gets the EditActionCommand that is used to extend the selection to the document end.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToDocumentEnd { get; }
Public Shared ReadOnly Property SelectToDocumentEnd As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the document end.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToDocumentStart Property

EditorCommandsSelectToDocumentStart Property
Gets the EditActionCommand that is used to extend the selection to the document start.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToDocumentStart { get; }
Public Shared ReadOnly Property SelectToDocumentStart As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the document start.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToLineEnd Property

EditorCommandsSelectToLineEnd Property
Gets the EditActionCommand that is used to extend the selection to the line end.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToLineEnd { get; }
Public Shared ReadOnly Property SelectToLineEnd As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the line end.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToLineStart Property

EditorCommandsSelectToLineStart Property
Gets the EditActionCommand that is used to extend the selection to the line start.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToLineStart { get; }
Public Shared ReadOnly Property SelectToLineStart As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the line start.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToLineStartAfterIndentation Property

EditorCommandsSelectToLineStartAfterIndentation Property
Gets the EditActionCommand that is used to extend the selection to the first non-whitespace character on the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToLineStartAfterIndentation { get; }
Public Shared ReadOnly Property SelectToLineStartAfterIndentation As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the first non-whitespace character on the current view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToMatchingBracket Property

EditorCommandsSelectToMatchingBracket Property
Gets the EditActionCommand that is used to extend the selection to the matching bracket, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToMatchingBracket { get; }
Public Shared ReadOnly Property SelectToMatchingBracket As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the matching bracket, if any.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToNextWord Property

EditorCommandsSelectToNextWord Property
Gets the EditActionCommand that is used to extend the selection to the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToNextWord { get; }
Public Shared ReadOnly Property SelectToNextWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the next word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToPreviousWord Property

EditorCommandsSelectToPreviousWord Property
Gets the EditActionCommand that is used to extend the selection to the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToPreviousWord { get; }
Public Shared ReadOnly Property SelectToPreviousWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the previous word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToVisibleBottom Property

EditorCommandsSelectToVisibleBottom Property
Gets the EditActionCommand that is used to extend the selection to the bottom of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToVisibleBottom { get; }
Public Shared ReadOnly Property SelectToVisibleBottom As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the bottom of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectToVisibleTop Property

EditorCommandsSelectToVisibleTop Property
Gets the EditActionCommand that is used to extend the selection to the top of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectToVisibleTop { get; }
Public Shared ReadOnly Property SelectToVisibleTop As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection to the top of the view.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectUp Property

EditorCommandsSelectUp Property
Gets the EditActionCommand that is used to extend the selection up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectUp { get; }
Public Shared ReadOnly Property SelectUp As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to extend the selection up a line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.SelectWord Property

EditorCommandsSelectWord Property
Gets the EditActionCommand that is used to select the current word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand SelectWord { get; }
Public Shared ReadOnly Property SelectWord As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to select the current word.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.StartAutomaticOutlining Property

EditorCommandsStartAutomaticOutlining Property
Gets the EditActionCommand that is used to start automatic outlining.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand StartAutomaticOutlining { get; }
Public Shared ReadOnly Property StartAutomaticOutlining As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to start automatic outlining.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.StopHidingCurrent Property

EditorCommandsStopHidingCurrent Property
Gets the EditActionCommand that is used to stop hiding the outlining node that currently contains the caret, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand StopHidingCurrent { get; }
Public Shared ReadOnly Property StopHidingCurrent As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to stop hiding the outlining node that currently contains the caret, if any.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.StopOutlining Property

EditorCommandsStopOutlining Property
Gets the EditActionCommand that is used to stop outlining.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand StopOutlining { get; }
Public Shared ReadOnly Property StopOutlining As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that is used to stop outlining.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.TabifySelectedLines Property

EditorCommandsTabifySelectedLines Property
Gets the EditActionCommand that converts spaces at the beginning of the active view lines to tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand TabifySelectedLines { get; }
Public Shared ReadOnly Property TabifySelectedLines As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that converts spaces at the beginning of the active view lines to tabs.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ToggleAllOutliningExpansion Property

EditorCommandsToggleAllOutliningExpansion Property
Gets the EditActionCommand that toggles the collapsed state of all outlining nodes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ToggleAllOutliningExpansion { get; }
Public Shared ReadOnly Property ToggleAllOutliningExpansion As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that toggles the collapsed state of all outlining nodes.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ToggleCharacterCasing Property

EditorCommandsToggleCharacterCasing Property
Gets the EditActionCommand that toggles the character casing of the selected text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ToggleCharacterCasing { get; }
Public Shared ReadOnly Property ToggleCharacterCasing As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that toggles the character casing of the selected text.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ToggleMacroRecording Property

EditorCommandsToggleMacroRecording Property
Gets the EditActionCommand that starts or stops recording a macro, depending on the current state of macro recording.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ToggleMacroRecording { get; }
Public Shared ReadOnly Property ToggleMacroRecording As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that starts or stops recording a macro, depending on the current state of macro recording.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ToggleOutliningExpansion Property

EditorCommandsToggleOutliningExpansion Property
Gets the EditActionCommand that toggles the collapsed state of the outlining node that contains the caret, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ToggleOutliningExpansion { get; }
Public Shared ReadOnly Property ToggleOutliningExpansion As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that toggles the collapsed state of the outlining node that contains the caret, if any.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.ToggleOverwriteMode Property

EditorCommandsToggleOverwriteMode Property
Gets the EditActionCommand that toggles overwrite mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand ToggleOverwriteMode { get; }
Public Shared ReadOnly Property ToggleOverwriteMode As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that toggles overwrite mode.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.TransposeCharacters Property

EditorCommandsTransposeCharacters Property
Gets the EditActionCommand that transposes the characters before and after the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand TransposeCharacters { get; }
Public Shared ReadOnly Property TransposeCharacters As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that transposes the characters before and after the caret.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.TransposeLines Property

EditorCommandsTransposeLines Property
Gets the EditActionCommand that transposes the current view line with the next view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand TransposeLines { get; }
Public Shared ReadOnly Property TransposeLines As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that transposes the current view line with the next view line.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.TransposeWords Property

EditorCommandsTransposeWords Property
Gets the EditActionCommand that transposes the words before and after the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand TransposeWords { get; }
Public Shared ReadOnly Property TransposeWords As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that transposes the words before and after the caret.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.TrimAllTrailingWhitespace Property

EditorCommandsTrimAllTrailingWhitespace Property
Gets the EditActionCommand that trims the trailing whitespace off all the lines in the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand TrimAllTrailingWhitespace { get; }
Public Shared ReadOnly Property TrimAllTrailingWhitespace As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that trims the trailing whitespace off all the lines in the document.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.TrimTrailingWhitespace Property

EditorCommandsTrimTrailingWhitespace Property
Gets the EditActionCommand that trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand TrimTrailingWhitespace { get; }
Public Shared ReadOnly Property TrimTrailingWhitespace As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.UncommentLines Property

EditorCommandsUncommentLines Property
Gets the EditActionCommand that uncomments the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand UncommentLines { get; }
Public Shared ReadOnly Property UncommentLines As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that uncomments the currently selected lines.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.Undo Property

EditorCommandsUndo Property
Gets the EditActionCommand that performs an undo operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand Undo { get; }
Public Shared ReadOnly Property Undo As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that performs an undo operation.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.UntabifySelectedLines Property

EditorCommandsUntabifySelectedLines Property
Gets the EditActionCommand that converts tabs at the beginning of the active view lines to spaces.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static EditActionCommand UntabifySelectedLines { get; }
Public Shared ReadOnly Property UntabifySelectedLines As EditActionCommand
    Get

Property Value

Type: EditActionCommand
The EditActionCommand that converts tabs at the beginning of the active view lines to spaces.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands Methods

EditorCommands Methods

The EditorCommands type exposes the following members.

Methods
Name | Description
GetAll | Returns a collection of all the known commands.
Top
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorCommands.GetAll Method

EditorCommandsGetAll Method
Returns a collection of all the known commands.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static IEnumerable<EditActionCommand> GetAll()
Public Shared Function GetAll As IEnumerable(Of EditActionCommand)

Return Value

Type: IEnumerable EditActionCommand
A collection of all the known commands.
See Also

Reference

EditorCommands Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentChangedEventArgs Class

EditorDocumentChangedEventArgs Class
Event arguments for an IEditorDocument change event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlPropertyChangedEventArgs IEditorDocument
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorDocumentChangedEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorDocumentChangedEventArgs : PropertyChangedEventArgs<IEditorDocument>
Public Class EditorDocumentChangedEventArgs
    Inherits PropertyChangedEventArgs(Of IEditorDocument)

The EditorDocumentChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorDocumentChangedEventArgs | Initializes a new instance of the EditorDocumentChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentChangedEventArgs Constructor

EditorDocumentChangedEventArgs Constructor
Initializes a new instance of the EditorDocumentChangedEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorDocumentChangedEventArgs(
    IEditorDocument oldValue,
    IEditorDocument newValue
)
Public Sub New (
    oldValue As IEditorDocument,
    newValue As IEditorDocument
)

Parameters

oldValue
Type: ActiproSoftware.TextIEditorDocument
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.TextIEditorDocument
The new value of the property being tracked as reported by an event.
See Also

Reference

EditorDocumentChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentChangedEventArgs Properties

EditorDocumentChangedEventArgs Properties

The EditorDocumentChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

EditorDocumentChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentChangedEventArgs Methods

EditorDocumentChangedEventArgs Methods

The EditorDocumentChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorDocumentChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentLanguageChangedEventArgs Class

EditorDocumentLanguageChangedEventArgs Class
Event arguments for an ISyntaxLanguage change event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlPropertyChangedEventArgs ISyntaxLanguage
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorDocumentLanguageChangedEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorDocumentLanguageChangedEventArgs : PropertyChangedEventArgs<ISyntaxLanguage>
Public Class EditorDocumentLanguageChangedEventArgs
    Inherits PropertyChangedEventArgs(Of ISyntaxLanguage)

The EditorDocumentLanguageChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorDocumentLanguageChangedEventArgs | Initializes a new instance of the EditorDocumentLanguageChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentLanguageChangedEventArgs Constructor

EditorDocumentLanguageChangedEventArgs Constructor
Initializes a new instance of the EditorDocumentLanguageChangedEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorDocumentLanguageChangedEventArgs(
    ISyntaxLanguage oldValue,
    ISyntaxLanguage newValue
)
Public Sub New (
    oldValue As ISyntaxLanguage,
    newValue As ISyntaxLanguage
)

Parameters

oldValue
Type: ActiproSoftware.TextISyntaxLanguage
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.TextISyntaxLanguage
The new value of the property being tracked as reported by an event.
See Also

Reference

EditorDocumentLanguageChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentLanguageChangedEventArgs Properties

EditorDocumentLanguageChangedEventArgs Properties

The EditorDocumentLanguageChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

EditorDocumentLanguageChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorDocumentLanguageChangedEventArgs Methods

EditorDocumentLanguageChangedEventArgs Methods

The EditorDocumentLanguageChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorDocumentLanguageChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSearchScope Class

EditorSearchScope Class
Specifies the scope in which a find/replace operation should occur.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSearchScope

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EditorSearchScope : Enum
Public NotInheritable Class EditorSearchScope
    Inherits Enum

The EditorSearchScope type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Document | Search the entire document.
 | Selection | Search the selection. When no selection is available, search the document.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSearchScope Methods

EditorSearchScope Methods

The EditorSearchScope type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

EditorSearchScope Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSearchScope Fields

EditorSearchScope Fields

The EditorSearchScope type exposes the following members.

Fields
 | Name | Description
 | Document | Search the entire document.
 | Selection | Search the selection. When no selection is available, search the document.
Public field | value__ |
Top
See Also

Reference

EditorSearchScope Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSearchScope.Document Field

EditorSearchScopeDocument Field
Search the entire document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorSearchScope Document = 0
Public Const Document As EditorSearchScope = 0

Field Value

Type: EditorSearchScope
See Also

Reference

EditorSearchScope Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSearchScope.Selection Field

EditorSearchScopeSelection Field
Search the selection. When no selection is available, search the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorSearchScope Selection = 1
Public Const Selection As EditorSearchScope = 1

Field Value

Type: EditorSearchScope
See Also

Reference

EditorSearchScope Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSearchScope.value__ Field

EditorSearchScopevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditorSearchScope.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

EditorSearchScope Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs Class

EditorSnapshotChangedEventArgs Class
Event arguments for the SyntaxEditor.DocumentTextChanged event.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorSnapshotChangedEventArgs
Public Class EditorSnapshotChangedEventArgs

The EditorSnapshotChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorSnapshotChangedEventArgs | Initializes a new instance of the EditorSnapshotChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | ChangedSnapshotRange | Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
Public property | Handled | Gets or sets whether the event has been handled.
Public property | IsTypedWordStart | Gets whether the text change is a Typing type that starts a word.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Public property | TypedText | Gets the text that was typed, if the text change is a Typing type with a single insert operation, and didn't originate from an undo/redo..
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetIsTypedWordStart | Returns whether the specified text change is typing that starts a word.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs Constructor

EditorSnapshotChangedEventArgs Constructor
Initializes a new instance of the EditorSnapshotChangedEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorSnapshotChangedEventArgs(
    ITextSnapshot oldSnapshot,
    ITextSnapshot newSnapshot,
    ITextChange textChange
)
Public Sub New (
    oldSnapshot As ITextSnapshot,
    newSnapshot As ITextSnapshot,
    textChange As ITextChange
)

Parameters

oldSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
newSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that is made.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs Properties

EditorSnapshotChangedEventArgs Properties

The EditorSnapshotChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangedSnapshotRange | Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
Public property | Handled | Gets or sets whether the event has been handled.
Public property | IsTypedWordStart | Gets whether the text change is a Typing type that starts a word.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Public property | TypedText | Gets the text that was typed, if the text change is a Typing type with a single insert operation, and didn't originate from an undo/redo..
Top
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.ChangedSnapshotRange Property

EditorSnapshotChangedEventArgsChangedSnapshotRange Property
Gets a TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextSnapshotRange ChangedSnapshotRange { get; }
Public ReadOnly Property ChangedSnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
A TextSnapshotRange that contains the unioned changed range relative to the NewSnapshot.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.Handled Property

EditorSnapshotChangedEventArgsHandled Property
Gets or sets whether the event has been handled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.IsTypedWordStart Property

EditorSnapshotChangedEventArgsIsTypedWordStart Property
Gets whether the text change is a Typing type that starts a word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTypedWordStart { get; }
Public ReadOnly Property IsTypedWordStart As Boolean
    Get

Property Value

Type: Boolean
true if the text change is a Typing type that starts a word; otherwise, false.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.NewSnapshot Property

EditorSnapshotChangedEventArgsNewSnapshot Property
Gets the ITextSnapshot that is in effect after the text change is applied.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot NewSnapshot { get; }
Public ReadOnly Property NewSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
Remarks
This property value may be before the text change actually occurs.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.OldSnapshot Property

EditorSnapshotChangedEventArgsOldSnapshot Property
Gets the ITextSnapshot that is in effect before the text change is applied.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot OldSnapshot { get; }
Public ReadOnly Property OldSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.TextChange Property

EditorSnapshotChangedEventArgsTextChange Property
Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextChange TextChange { get; }
Public ReadOnly Property TextChange As ITextChange
    Get

Property Value

Type: ITextChange
The ITextChange that is made to the document.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.TypedText Property

EditorSnapshotChangedEventArgsTypedText Property
Gets the text that was typed, if the text change is a Typing type with a single insert operation, and didn't originate from an undo/redo..

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TypedText { get; }
Public ReadOnly Property TypedText As String
    Get

Property Value

Type: String
The text that was typed if the above criteria is met; otherwise, .
Remarks
This a helper property that is very useful for searching for things such as when a "." is typed so you know when to activate an IntelliPrompt completion list.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs Methods

EditorSnapshotChangedEventArgs Methods

The EditorSnapshotChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
 | GetIsTypedWordStart | Returns whether the specified text change is typing that starts a word.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangedEventArgs.GetIsTypedWordStart Method

EditorSnapshotChangedEventArgsGetIsTypedWordStart Method
Returns whether the specified text change is typing that starts a word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool GetIsTypedWordStart(
    ITextSnapshot snapshot,
    ITextChange textChange,
    CharClass wordStartChars
)
Public Shared Function GetIsTypedWordStart (
    snapshot As ITextSnapshot,
    textChange As ITextChange,
    wordStartChars As CharClass
) As Boolean

Parameters

snapshot
Type: ActiproSoftware.TextITextSnapshot
The new ITextSnapshot after the change.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that caused the new snapshot.
wordStartChars
Type: ActiproSoftware.Text.RegularExpressionsCharClass
The characters that can start a word.

Return Value

Type: Boolean
true if the specified text change is typing that starts a word; otherwise, false.
See Also

Reference

EditorSnapshotChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs Class

EditorSnapshotChangingEventArgs Class
Event arguments for the SyntaxEditor.DocumentTextChanging event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlCancelableEventArgs
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorSnapshotChangingEventArgs : CancelableEventArgs
Public Class EditorSnapshotChangingEventArgs
    Inherits CancelableEventArgs

The EditorSnapshotChangingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorSnapshotChangingEventArgs | Initializes a new instance of the EditorSnapshotChangingEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Handled | Gets or sets whether the event has been handled.
Public property | IsTypedWordStart | Gets whether the text change is a Typing type that starts a word.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Public property | TypedText | Gets the text that was typed, if the text change is a Typing type with a single insert operation, and didn't originate from an undo/redo.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs Constructor

EditorSnapshotChangingEventArgs Constructor
Initializes a new instance of the EditorSnapshotChangingEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorSnapshotChangingEventArgs(
    ITextSnapshot oldSnapshot,
    ITextSnapshot newSnapshot,
    ITextChange textChange
)
Public Sub New (
    oldSnapshot As ITextSnapshot,
    newSnapshot As ITextSnapshot,
    textChange As ITextChange
)

Parameters

oldSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
newSnapshot
Type: ActiproSoftware.TextITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
textChange
Type: ActiproSoftware.TextITextChange
The ITextChange that is made.
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs Properties

EditorSnapshotChangingEventArgs Properties

The EditorSnapshotChangingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelableEventArgs.)
Public property | Handled | Gets or sets whether the event has been handled.
Public property | IsTypedWordStart | Gets whether the text change is a Typing type that starts a word.
Public property | NewSnapshot | Gets the ITextSnapshot that is in effect after the text change is applied.
Public property | OldSnapshot | Gets the ITextSnapshot that is in effect before the text change is applied.
Public property | TextChange | Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.
Public property | TypedText | Gets the text that was typed, if the text change is a Typing type with a single insert operation, and didn't originate from an undo/redo.
Top
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs.Handled Property

EditorSnapshotChangingEventArgsHandled Property
Gets or sets whether the event has been handled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs.IsTypedWordStart Property

EditorSnapshotChangingEventArgsIsTypedWordStart Property
Gets whether the text change is a Typing type that starts a word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTypedWordStart { get; }
Public ReadOnly Property IsTypedWordStart As Boolean
    Get

Property Value

Type: Boolean
true if the text change is a Typing type that starts a word; otherwise, false.
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs.NewSnapshot Property

EditorSnapshotChangingEventArgsNewSnapshot Property
Gets the ITextSnapshot that is in effect after the text change is applied.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot NewSnapshot { get; }
Public ReadOnly Property NewSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect after the text change is applied.
Remarks
This property value may be before the text change actually occurs.
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs.OldSnapshot Property

EditorSnapshotChangingEventArgsOldSnapshot Property
Gets the ITextSnapshot that is in effect before the text change is applied.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextSnapshot OldSnapshot { get; }
Public ReadOnly Property OldSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that is in effect before the text change is applied.
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs.TextChange Property

EditorSnapshotChangingEventArgsTextChange Property
Gets the ITextChange that is made to the document, causing a transition from OldSnapshot to NewSnapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextChange TextChange { get; }
Public ReadOnly Property TextChange As ITextChange
    Get

Property Value

Type: ITextChange
The ITextChange that is made to the document.
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs.TypedText Property

EditorSnapshotChangingEventArgsTypedText Property
Gets the text that was typed, if the text change is a Typing type with a single insert operation, and didn't originate from an undo/redo.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string TypedText { get; }
Public ReadOnly Property TypedText As String
    Get

Property Value

Type: String
The text that was typed if the above criteria is met; otherwise, .
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorSnapshotChangingEventArgs Methods

EditorSnapshotChangingEventArgs Methods

The EditorSnapshotChangingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorSnapshotChangingEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewChangedEventArgs Class

EditorViewChangedEventArgs Class
Event arguments for an IEditorView change event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.XamlPropertyChangedEventArgs IEditorView
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewChangedEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorViewChangedEventArgs : PropertyChangedEventArgs<IEditorView>
Public Class EditorViewChangedEventArgs
    Inherits PropertyChangedEventArgs(Of IEditorView)

The EditorViewChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorViewChangedEventArgs | Initializes a new instance of the EditorViewChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewChangedEventArgs Constructor

EditorViewChangedEventArgs Constructor
Initializes a new instance of the EditorViewChangedEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorViewChangedEventArgs(
    IEditorView oldValue,
    IEditorView newValue
)
Public Sub New (
    oldValue As IEditorView,
    newValue As IEditorView
)

Parameters

oldValue
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The previous value of the property being tracked as reported by an event.
newValue
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The new value of the property being tracked as reported by an event.
See Also

Reference

EditorViewChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewChangedEventArgs Properties

EditorViewChangedEventArgs Properties

The EditorViewChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Public property | OldValue | Gets the previous value of the property being tracked as reported by an event. (Inherited from PropertyChangedEventArgsT.)
Top
See Also

Reference

EditorViewChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewChangedEventArgs Methods

EditorViewChangedEventArgs Methods

The EditorViewChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorViewChangedEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement Class

EditorViewPlacement Class
Specifies an individual IEditorView location within a split SyntaxEditor.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewPlacement

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class EditorViewPlacement : Enum
Public NotInheritable Class EditorViewPlacement
    Inherits Enum

The EditorViewPlacement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Default | Used when there is only one view in the control to indicate the default split.
 | Left | Used in dual vertical splits to indicate the left view.
 | Lower | Used in dual horizontal splits to indicate the lower view.
 | LowerLeft | Used in four-way splits to indicate the lower left view.
 | LowerRight | Used in four-way splits to indicate the lower right view.
 | Right | Used in dual vertical splits to indicate the right view.
 | Upper | Used in dual horizontal splits to indicate the upper view.
 | UpperLeft | Used in four-way splits to indicate the upper left view.
 | UpperRight | Used in four-way splits to indicate the upper right view.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement Methods

EditorViewPlacement Methods

The EditorViewPlacement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement Fields

EditorViewPlacement Fields

The EditorViewPlacement type exposes the following members.

Fields
 | Name | Description
 | Default | Used when there is only one view in the control to indicate the default split.
 | Left | Used in dual vertical splits to indicate the left view.
 | Lower | Used in dual horizontal splits to indicate the lower view.
 | LowerLeft | Used in four-way splits to indicate the lower left view.
 | LowerRight | Used in four-way splits to indicate the lower right view.
 | Right | Used in dual vertical splits to indicate the right view.
 | Upper | Used in dual horizontal splits to indicate the upper view.
 | UpperLeft | Used in four-way splits to indicate the upper left view.
 | UpperRight | Used in four-way splits to indicate the upper right view.
Public field | value__ |
Top
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.Default Field

EditorViewPlacementDefault Field
Used when there is only one view in the control to indicate the default split.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement Default = 1
Public Const Default As EditorViewPlacement = 1

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.Left Field

EditorViewPlacementLeft Field
Used in dual vertical splits to indicate the left view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement Left = 3
Public Const Left As EditorViewPlacement = 3

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.Lower Field

EditorViewPlacementLower Field
Used in dual horizontal splits to indicate the lower view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement Lower = 1
Public Const Lower As EditorViewPlacement = 1

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.LowerLeft Field

EditorViewPlacementLowerLeft Field
Used in four-way splits to indicate the lower left view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement LowerLeft = 3
Public Const LowerLeft As EditorViewPlacement = 3

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.LowerRight Field

EditorViewPlacementLowerRight Field
Used in four-way splits to indicate the lower right view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement LowerRight = 1
Public Const LowerRight As EditorViewPlacement = 1

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.Right Field

EditorViewPlacementRight Field
Used in dual vertical splits to indicate the right view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement Right = 1
Public Const Right As EditorViewPlacement = 1

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.Upper Field

EditorViewPlacementUpper Field
Used in dual horizontal splits to indicate the upper view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement Upper = 2
Public Const Upper As EditorViewPlacement = 2

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.UpperLeft Field

EditorViewPlacementUpperLeft Field
Used in four-way splits to indicate the upper left view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement UpperLeft = 4
Public Const UpperLeft As EditorViewPlacement = 4

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.UpperRight Field

EditorViewPlacementUpperRight Field
Used in four-way splits to indicate the upper right view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const EditorViewPlacement UpperRight = 2
Public Const UpperRight As EditorViewPlacement = 2

Field Value

Type: EditorViewPlacement
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewPlacement.value__ Field

EditorViewPlacementvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.EditorViewPlacement.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

EditorViewPlacement Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSearchEventArgs Class

EditorViewSearchEventArgs Class
Event arguments for a search operation within an IEditorView.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSearchEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorViewSearchEventArgs
Public Class EditorViewSearchEventArgs

The EditorViewSearchEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorViewSearchEventArgs | Initializes a new instance of the EditorViewSearchEventArgs class.
Top
Properties
 | Name | Description
Public property | ResultSet | Gets the ISearchResultSet that contains the result of the search operation.
Public property | View | Gets the IEditorView whose selection is affected by this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSearchEventArgs Constructor

EditorViewSearchEventArgs Constructor
Initializes a new instance of the EditorViewSearchEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorViewSearchEventArgs(
    IEditorView view,
    ISearchResultSet resultSet
)
Public Sub New (
    view As IEditorView,
    resultSet As ISearchResultSet
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView whose selection is affected by this event.
resultSet
Type: ActiproSoftware.Text.SearchingISearchResultSet
The ISearchResultSet that contains the result of the search operation.
See Also

Reference

EditorViewSearchEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSearchEventArgs Properties

EditorViewSearchEventArgs Properties

The EditorViewSearchEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ResultSet | Gets the ISearchResultSet that contains the result of the search operation.
Public property | View | Gets the IEditorView whose selection is affected by this event.
Top
See Also

Reference

EditorViewSearchEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSearchEventArgs.ResultSet Property

EditorViewSearchEventArgsResultSet Property
Gets the ISearchResultSet that contains the result of the search operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ISearchResultSet ResultSet { get; }
Public ReadOnly Property ResultSet As ISearchResultSet
    Get

Property Value

Type: ISearchResultSet
The ISearchResultSet that contains the result of the search operation.
See Also

Reference

EditorViewSearchEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSearchEventArgs.View Property

EditorViewSearchEventArgsView Property
Gets the IEditorView whose selection is affected by this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditorView View { get; }
Public ReadOnly Property View As IEditorView
    Get

Property Value

Type: IEditorView
The IEditorView whose selection is affected by this event.
See Also

Reference

EditorViewSearchEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSearchEventArgs Methods

EditorViewSearchEventArgs Methods

The EditorViewSearchEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorViewSearchEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs Class

EditorViewSelectionEventArgs Class
Event arguments for a selection change within an IEditorView.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class EditorViewSelectionEventArgs
Public Class EditorViewSelectionEventArgs

The EditorViewSelectionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | EditorViewSelectionEventArgs | Initializes a new instance of the EditorViewSelectionEventArgs class.
Top
Properties
 | Name | Description
Public property | CaretCharacterColumn | Gets the character column of the caret within the View.
Public property | CaretDisplayCharacterColumn | Gets the character column of the caret within the View. and adds one to the value for display purposes.
Public property | CaretDisplayPosition | Obsolete. Gets the TextPosition of the caret within the View, and adds one to the line and character values for display purposes.
Public property | CaretPosition | Gets the TextPosition of the caret within the View.
Public property | Handled | Gets or sets whether the event has been handled.
Public property | LastCaretPosition | Gets the TextPosition of the caret within the View the last time the event was raised.
Public property | View | Gets the IEditorView whose selection is affected by this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs Constructor

EditorViewSelectionEventArgs Constructor
Initializes a new instance of the EditorViewSelectionEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public EditorViewSelectionEventArgs(
    IEditorView view,
    TextPosition lastCaretPosition
)
Public Sub New (
    view As IEditorView,
    lastCaretPosition As TextPosition
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView whose selection is affected by this event.
lastCaretPosition
Type: ActiproSoftware.TextTextPosition
The optional last known TextPosition of the caret.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs Properties

EditorViewSelectionEventArgs Properties

The EditorViewSelectionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CaretCharacterColumn | Gets the character column of the caret within the View.
Public property | CaretDisplayCharacterColumn | Gets the character column of the caret within the View. and adds one to the value for display purposes.
Public property | CaretDisplayPosition | Obsolete. Gets the TextPosition of the caret within the View, and adds one to the line and character values for display purposes.
Public property | CaretPosition | Gets the TextPosition of the caret within the View.
Public property | Handled | Gets or sets whether the event has been handled.
Public property | LastCaretPosition | Gets the TextPosition of the caret within the View the last time the event was raised.
Public property | View | Gets the IEditorView whose selection is affected by this event.
Top
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.CaretCharacterColumn Property

EditorViewSelectionEventArgsCaretCharacterColumn Property
Gets the character column of the caret within the View.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CaretCharacterColumn { get; }
Public ReadOnly Property CaretCharacterColumn As Integer
    Get

Property Value

Type: Int32
The character column of the caret within the View.
Remarks
This property is the same as calling the GetCharacterColumn(Int32) method using the value of the EndPosition property.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.CaretDisplayCharacterColumn Property

EditorViewSelectionEventArgsCaretDisplayCharacterColumn Property
Gets the character column of the caret within the View. and adds one to the value for display purposes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int CaretDisplayCharacterColumn { get; }
Public ReadOnly Property CaretDisplayCharacterColumn As Integer
    Get

Property Value

Type: Int32
The character column of the caret within the View, offset by one.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.CaretDisplayPosition Property

EditorViewSelectionEventArgsCaretDisplayPosition Property

Note: This API is now obsolete.

Gets the TextPosition of the caret within the View, and adds one to the line and character values for display purposes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use the CaretPosition property instead, as TextPosition structures now have DisplayLine and DisplayCharacter properties that are one-based.  This CaretDisplayPosition property will be removed in a future version.")]
public TextPosition CaretDisplayPosition { get; }
<ObsoleteAttribute("Use the CaretPosition property instead, as TextPosition structures now have DisplayLine and DisplayCharacter properties that are one-based.  This CaretDisplayPosition property will be removed in a future version.")>
Public ReadOnly Property CaretDisplayPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the caret within the View, offset by one.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.CaretPosition Property

EditorViewSelectionEventArgsCaretPosition Property
Gets the TextPosition of the caret within the View.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition CaretPosition { get; }
Public ReadOnly Property CaretPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the caret within the View.
Remarks
This property is the same as the EndPosition property.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.Handled Property

EditorViewSelectionEventArgsHandled Property
Gets or sets whether the event has been handled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.LastCaretPosition Property

EditorViewSelectionEventArgsLastCaretPosition Property
Gets the TextPosition of the caret within the View the last time the event was raised.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextPosition LastCaretPosition { get; }
Public ReadOnly Property LastCaretPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the caret within the View the last time the event was raised.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs.View Property

EditorViewSelectionEventArgsView Property
Gets the IEditorView whose selection is affected by this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditorView View { get; }
Public ReadOnly Property View As IEditorView
    Get

Property Value

Type: IEditorView
The IEditorView whose selection is affected by this event.
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


EditorViewSelectionEventArgs Methods

EditorViewSelectionEventArgs Methods

The EditorViewSelectionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

EditorViewSelectionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType Class

HitTestResultType Class
Specifies a high-level categorization about what an IHitTestResult represents.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorHitTestResultType

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class HitTestResultType : Enum
Public NotInheritable Class HitTestResultType
    Inherits Enum

The HitTestResultType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Other | The location is over some unidentified result.
Public field | value__ |
 | ViewMargin | The location is over an editor view margin.
 | ViewScrollBar | The location is over a scrollbar within an editor view.
 | ViewScrollBarBlock | The location is over the block that is in the corner where the horizontal and vertical scrollbars meet.
 | ViewScrollBarTray | The location is over an editor view scrollbar tray area that generally contains other controls like buttons.
 | ViewTextArea | The location is not over any editor view lines, but it is in the text area.
 | ViewTextAreaOverCharacter | The location is directly over a character within an editor view.
 | ViewTextAreaOverIntraTextSpacer | The location is directly over an intra-text spacer within an editor view.
 | ViewTextAreaOverLine | The location is not over a character within an editor view, but it is in the whitespace past the end of a view line.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType Methods

HitTestResultType Methods

The HitTestResultType type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType Fields

HitTestResultType Fields

The HitTestResultType type exposes the following members.

Fields
 | Name | Description
 | Other | The location is over some unidentified result.
Public field | value__ |
 | ViewMargin | The location is over an editor view margin.
 | ViewScrollBar | The location is over a scrollbar within an editor view.
 | ViewScrollBarBlock | The location is over the block that is in the corner where the horizontal and vertical scrollbars meet.
 | ViewScrollBarTray | The location is over an editor view scrollbar tray area that generally contains other controls like buttons.
 | ViewTextArea | The location is not over any editor view lines, but it is in the text area.
 | ViewTextAreaOverCharacter | The location is directly over a character within an editor view.
 | ViewTextAreaOverIntraTextSpacer | The location is directly over an intra-text spacer within an editor view.
 | ViewTextAreaOverLine | The location is not over a character within an editor view, but it is in the whitespace past the end of a view line.
Top
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.Other Field

HitTestResultTypeOther Field
The location is over some unidentified result.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType Other = 0
Public Const Other As HitTestResultType = 0

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.value__ Field

HitTestResultTypevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.HitTestResultType.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewMargin Field

HitTestResultTypeViewMargin Field
The location is over an editor view margin.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewMargin = 5
Public Const ViewMargin As HitTestResultType = 5

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewScrollBar Field

HitTestResultTypeViewScrollBar Field
The location is over a scrollbar within an editor view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewScrollBar = 6
Public Const ViewScrollBar As HitTestResultType = 6

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewScrollBarBlock Field

HitTestResultTypeViewScrollBarBlock Field
The location is over the block that is in the corner where the horizontal and vertical scrollbars meet.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewScrollBarBlock = 7
Public Const ViewScrollBarBlock As HitTestResultType = 7

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewScrollBarTray Field

HitTestResultTypeViewScrollBarTray Field
The location is over an editor view scrollbar tray area that generally contains other controls like buttons.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewScrollBarTray = 8
Public Const ViewScrollBarTray As HitTestResultType = 8

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewTextArea Field

HitTestResultTypeViewTextArea Field
The location is not over any editor view lines, but it is in the text area.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewTextArea = 4
Public Const ViewTextArea As HitTestResultType = 4

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewTextAreaOverCharacter Field

HitTestResultTypeViewTextAreaOverCharacter Field
The location is directly over a character within an editor view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewTextAreaOverCharacter = 1
Public Const ViewTextAreaOverCharacter As HitTestResultType = 1

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewTextAreaOverIntraTextSpacer Field

HitTestResultTypeViewTextAreaOverIntraTextSpacer Field
The location is directly over an intra-text spacer within an editor view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewTextAreaOverIntraTextSpacer = 2
Public Const ViewTextAreaOverIntraTextSpacer As HitTestResultType = 2

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


HitTestResultType.ViewTextAreaOverLine Field

HitTestResultTypeViewTextAreaOverLine Field
The location is not over a character within an editor view, but it is in the whitespace past the end of a view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const HitTestResultType ViewTextAreaOverLine = 3
Public Const ViewTextAreaOverLine As HitTestResultType = 3

Field Value

Type: HitTestResultType
See Also

Reference

HitTestResultType Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret Interface

ICaret Interface
Provides the base requirements for a blinking caret within a view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICaret
Public Interface ICaret

The ICaret type exposes the following members.

Properties
 | Name | Description
Public property | BlinkInterval | Gets or sets the interval at which the caret blinks.
Public property | CharacterColumn | Gets the character column of the caret within the active view.
Public property | DisplayCharacterColumn | Gets the character column of the caret within the the active view. and adds one to the value for display purposes within a status bar.
Public property | DisplayPosition | Obsolete. Gets the TextPosition of the caret within the active view, and adds one to the line and character values for display purposes within a status bar.
Public property | InsertStyle | Gets or sets the style of the caret when in insert mode.
Public property | InsertWidth | Gets or sets the width of the caret when in insert mode, if a non-block caret style is used.
Public property | IsVisible | Gets whether the caret is visible.
Public property | Offset | Gets or sets the offset of the caret within the active view.
Public property | OverwriteStyle | Gets or sets the style of the caret when in overwrite mode.
Public property | OverwriteWidth | Gets or sets the width of the caret when in overwrite mode, if a non-block caret style is used.
Public property | Position | Gets or sets the TextPosition of the caret within the active view.
Top
Methods
 | Name | Description
Public method | ResumeBlinking | Resumes the blinking of the caret.
Public method | SuspendBlinking | Suspends the blinking of the caret.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret Properties

ICaret Properties

The ICaret type exposes the following members.

Properties
 | Name | Description
Public property | BlinkInterval | Gets or sets the interval at which the caret blinks.
Public property | CharacterColumn | Gets the character column of the caret within the active view.
Public property | DisplayCharacterColumn | Gets the character column of the caret within the the active view. and adds one to the value for display purposes within a status bar.
Public property | DisplayPosition | Obsolete. Gets the TextPosition of the caret within the active view, and adds one to the line and character values for display purposes within a status bar.
Public property | InsertStyle | Gets or sets the style of the caret when in insert mode.
Public property | InsertWidth | Gets or sets the width of the caret when in insert mode, if a non-block caret style is used.
Public property | IsVisible | Gets whether the caret is visible.
Public property | Offset | Gets or sets the offset of the caret within the active view.
Public property | OverwriteStyle | Gets or sets the style of the caret when in overwrite mode.
Public property | OverwriteWidth | Gets or sets the width of the caret when in overwrite mode, if a non-block caret style is used.
Public property | Position | Gets or sets the TextPosition of the caret within the active view.
Top
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.BlinkInterval Property

ICaretBlinkInterval Property
Gets or sets the interval at which the caret blinks.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int BlinkInterval { get; set; }
Property BlinkInterval As Integer
    Get
    Set

Property Value

Type: Int32
The interval at which the caret blinks, in milliseconds. The default value is 500ms.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.CharacterColumn Property

ICaretCharacterColumn Property
Gets the character column of the caret within the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int CharacterColumn { get; }
ReadOnly Property CharacterColumn As Integer
    Get

Property Value

Type: Int32
The character column of the caret within the active view.
Remarks
This property is the same as calling the GetCharacterColumn(Int32) method using the value of the EndPosition property.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.DisplayCharacterColumn Property

ICaretDisplayCharacterColumn Property
Gets the character column of the caret within the the active view. and adds one to the value for display purposes within a status bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DisplayCharacterColumn { get; }
ReadOnly Property DisplayCharacterColumn As Integer
    Get

Property Value

Type: Int32
The character column of the caret within the active view, offset by one.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.DisplayPosition Property

ICaretDisplayPosition Property

Note: This API is now obsolete.

Gets the TextPosition of the caret within the active view, and adds one to the line and character values for display purposes within a status bar.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use the Position property instead, as TextPosition structures now have DisplayLine and DisplayCharacter properties that are one-based.  This DisplayPosition property will be removed in a future version.")]
TextPosition DisplayPosition { get; }
<ObsoleteAttribute("Use the Position property instead, as TextPosition structures now have DisplayLine and DisplayCharacter properties that are one-based.  This DisplayPosition property will be removed in a future version.")>
ReadOnly Property DisplayPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition of the caret within the active view, offset by one.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.InsertStyle Property

ICaretInsertStyle Property
Gets or sets the style of the caret when in insert mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CaretStyle InsertStyle { get; set; }
Property InsertStyle As CaretStyle
    Get
    Set

Property Value

Type: CaretStyle
A CaretStyle indicating the style of the caret when in insert mode. The default value is CaretStyle.VerticalLine.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.InsertWidth Property

ICaretInsertWidth Property
Gets or sets the width of the caret when in insert mode, if a non-block caret style is used.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int InsertWidth { get; set; }
Property InsertWidth As Integer
    Get
    Set

Property Value

Type: Int32
The width of the caret when in insert mode. The width must be within 1 and 8. The default value is 2.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.IsVisible Property

ICaretIsVisible Property
Gets whether the caret is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVisible { get; }
ReadOnly Property IsVisible As Boolean
    Get

Property Value

Type: Boolean
true if the caret is visible; otherwise, false.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.Offset Property

ICaretOffset Property
Gets or sets the offset of the caret within the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Offset { get; set; }
Property Offset As Integer
    Get
    Set

Property Value

Type: Int32
The offset of the caret within the active view.
Remarks
This property is the same as the EndOffset property.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.OverwriteStyle Property

ICaretOverwriteStyle Property
Gets or sets the style of the caret when in overwrite mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
CaretStyle OverwriteStyle { get; set; }
Property OverwriteStyle As CaretStyle
    Get
    Set

Property Value

Type: CaretStyle
A CaretStyle indicating the style of the caret when in overwrite mode. The default value is CaretStyle.Block.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.OverwriteWidth Property

ICaretOverwriteWidth Property
Gets or sets the width of the caret when in overwrite mode, if a non-block caret style is used.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int OverwriteWidth { get; set; }
Property OverwriteWidth As Integer
    Get
    Set

Property Value

Type: Int32
The width of the caret when in overwrite mode. The width must be within 1 and 8. The default value is 2.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.Position Property

ICaretPosition Property
Gets or sets the TextPosition of the caret within the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition Position { get; set; }
Property Position As TextPosition
    Get
    Set

Property Value

Type: TextPosition
The TextPosition of the caret within the active view.
Remarks
This property is the same as the EndPosition property.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret Methods

ICaret Methods

The ICaret type exposes the following members.

Methods
 | Name | Description
Public method | ResumeBlinking | Resumes the blinking of the caret.
Public method | SuspendBlinking | Suspends the blinking of the caret.
Top
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.ResumeBlinking Method

ICaretResumeBlinking Method
Resumes the blinking of the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ResumeBlinking()
Sub ResumeBlinking
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICaret.SuspendBlinking Method

ICaretSuspendBlinking Method
Suspends the blinking of the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SuspendBlinking(
    bool show
)
Sub SuspendBlinking (
    show As Boolean
)

Parameters

show
Type: SystemBoolean
Whether to display the caret.
See Also

Reference

ICaret Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICollapsedRegionManager Interface

ICollapsedRegionManager Interface
Provides the base requirements for a manager that can return information about collapsed regions.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ICollapsedRegionManager
Public Interface ICollapsedRegionManager

The ICollapsedRegionManager type exposes the following members.

Methods
 | Name | Description
Public method | GetCollapsedRange | Returns a TextSnapshotRange indicating the collapsed region that contains the specified snapshot offset, if any.
Public method | GetCollapsedRanges | Returns a collection of TextSnapshotRange objects that indicate the collapsed regions that intersect the specified snapshot range.
Top
Events
 | Name | Description
Public event | RegionsChanged | Occurs when one or more collapsed regions have changed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICollapsedRegionManager Methods

ICollapsedRegionManager Methods

The ICollapsedRegionManager type exposes the following members.

Methods
 | Name | Description
Public method | GetCollapsedRange | Returns a TextSnapshotRange indicating the collapsed region that contains the specified snapshot offset, if any.
Public method | GetCollapsedRanges | Returns a collection of TextSnapshotRange objects that indicate the collapsed regions that intersect the specified snapshot range.
Top
See Also

Reference

ICollapsedRegionManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICollapsedRegionManager.GetCollapsedRange Method

ICollapsedRegionManagerGetCollapsedRange Method
Returns a TextSnapshotRange indicating the collapsed region that contains the specified snapshot offset, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange GetCollapsedRange(
    TextSnapshotOffset snapshotOffset
)
Function GetCollapsedRange (
    snapshotOffset As TextSnapshotOffset
) As TextSnapshotRange

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset to examine.

Return Value

Type: TextSnapshotRange
A TextSnapshotRange indicating the collapsed region that contains the specified snapshot offset, if any. If no collapsed range contains the offset, TextSnapshotRange.Deleted is returned.
See Also

Reference

ICollapsedRegionManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICollapsedRegionManager.GetCollapsedRanges Method

ICollapsedRegionManagerGetCollapsedRanges Method
Returns a collection of TextSnapshotRange objects that indicate the collapsed regions that intersect the specified snapshot range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
NormalizedTextSnapshotRangeCollection GetCollapsedRanges(
    TextSnapshotRange snapshotRange
)
Function GetCollapsedRanges (
    snapshotRange As TextSnapshotRange
) As NormalizedTextSnapshotRangeCollection

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange in which to look for collapsed regions.

Return Value

Type: NormalizedTextSnapshotRangeCollection
A NormalizedTextSnapshotRangeCollection that contains the intersecting ranges.
See Also

Reference

ICollapsedRegionManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICollapsedRegionManager Events

ICollapsedRegionManager Events

The ICollapsedRegionManager type exposes the following members.

Events
 | Name | Description
Public event | RegionsChanged | Occurs when one or more collapsed regions have changed.
Top
See Also

Reference

ICollapsedRegionManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ICollapsedRegionManager.RegionsChanged Event

ICollapsedRegionManagerRegionsChanged Event
Occurs when one or more collapsed regions have changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<TextSnapshotRangeEventArgs> RegionsChanged
Event RegionsChanged As EventHandler(Of TextSnapshotRangeEventArgs)

Value

Type: SystemEventHandler TextSnapshotRangeEventArgs
See Also

Reference

ICollapsedRegionManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IDataStore Interface

IDataStore Interface
Defines the base requirements for an object that can be used to wrap access of data for clipboard operations.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IDataStore
Public Interface IDataStore

The IDataStore type exposes the following members.

Methods
 | Name | Description
Public method | GetDataAsync | Gets data of the specified format type from the data store.
Public method | GetDataPresent | Returns whether there is data available in the specified format.
Public method | SetData | Sets data into the data store.
Public method | ToDataPackage | Returns an DataPackage, if available, containing the data within this data store.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IDataStore Methods

IDataStore Methods

The IDataStore type exposes the following members.

Methods
 | Name | Description
Public method | GetDataAsync | Gets data of the specified format type from the data store.
Public method | GetDataPresent | Returns whether there is data available in the specified format.
Public method | SetData | Sets data into the data store.
Public method | ToDataPackage | Returns an DataPackage, if available, containing the data within this data store.
Top
See Also

Reference

IDataStore Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IDataStore.GetDataAsync Method

IDataStoreGetDataAsync Method
Gets data of the specified format type from the data store.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Task<Object> GetDataAsync(
    string format
)
Function GetDataAsync (
    format As String
) As Task(Of Object)

Parameters

format
Type: SystemString
The desired data format.

Return Value

Type: Task Object
The data of the specified format, if available.
See Also

Reference

IDataStore Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IDataStore.GetDataPresent Method

IDataStoreGetDataPresent Method
Returns whether there is data available in the specified format.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool GetDataPresent(
    string format
)
Function GetDataPresent (
    format As String
) As Boolean

Parameters

format
Type: SystemString
The desired data format.

Return Value

Type: Boolean
true if there is data available in the specified format; otherwise, false.
See Also

Reference

IDataStore Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IDataStore.SetData Method

IDataStoreSetData Method
Sets data into the data store.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SetData(
    string format,
    Object data,
    bool autoConvert
)
Sub SetData (
    format As String,
    data As Object,
    autoConvert As Boolean
)

Parameters

format
Type: SystemString
The data format.
data
Type: SystemObject
The data to store.
autoConvert
Type: SystemBoolean
Whether to allow auto-conversion to other formats.
See Also

Reference

IDataStore Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IDataStore.ToDataPackage Method

IDataStoreToDataPackage Method
Returns an DataPackage, if available, containing the data within this data store.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
DataPackage ToDataPackage()
Function ToDataPackage As DataPackage

Return Value

Type: DataPackage
The DataPackage containing data, if available.
See Also

Reference

IDataStore Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction Interface

IEditAction Interface
Defines the base requirements for an edit action that can be performed in an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditAction : IKeyedObject
Public Interface IEditAction
    Inherits IKeyedObject

The IEditAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView.
Public method | Execute | Executes the edit action in the specified IEditorView.
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML.
Public method | WriteToXml | Serializes the data for the IEditAction to XML.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction Properties

IEditAction Properties

The IEditAction type exposes the following members.

Properties
 | Name | Description
Public property | CanRecordInMacro | Gets whether the action can be recorded in a macro.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Top
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction.CanRecordInMacro Property

IEditActionCanRecordInMacro Property
Gets whether the action can be recorded in a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanRecordInMacro { get; }
ReadOnly Property CanRecordInMacro As Boolean
    Get

Property Value

Type: Boolean
true if the action can be recorded in a macro; otherwise, false.
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction Methods

IEditAction Methods

The IEditAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Returns whether the edit action can execute in the specified IEditorView.
Public method | Execute | Executes the edit action in the specified IEditorView.
Public method | ReadFromXml | Deserializes the data for the IEditAction from XML.
Public method | WriteToXml | Serializes the data for the IEditAction to XML.
Top
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction.CanExecute Method

IEditActionCanExecute Method
Returns whether the edit action can execute in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanExecute(
    IEditorView view
)
Function CanExecute (
    view As IEditorView
) As Boolean

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView to examine.

Return Value

Type: Boolean
true if the edit action can execute in the specified IEditorView; otherwise, false.
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction.Execute Method

IEditActionExecute Method
Executes the edit action in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Execute(
    IEditorView view
)
Sub Execute (
    view As IEditorView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView in which to execute the edit action.
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction.ReadFromXml Method

IEditActionReadFromXml Method
Deserializes the data for the IEditAction from XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ReadFromXml(
    XmlReader reader
)
Sub ReadFromXml (
    reader As XmlReader
)

Parameters

reader
Type: System.XmlXmlReader
The XmlReader to use.
Remarks
This method is used for macro serialization.
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditAction.WriteToXml Method

IEditActionWriteToXml Method
Serializes the data for the IEditAction to XML.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void WriteToXml(
    XmlWriter writer
)
Sub WriteToXml (
    writer As XmlWriter
)

Parameters

writer
Type: System.XmlXmlWriter
The XmlWriter to use.
Remarks
This method is used for macro serialization.
See Also

Reference

IEditAction Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorDocumentTextChangeEventSink Interface

IEditorDocumentTextChangeEventSink Interface
Provides the base requirements for an object that can be notified of IEditorDocument text change events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorDocumentTextChangeEventSink
Public Interface IEditorDocumentTextChangeEventSink

The IEditorDocumentTextChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDocumentTextChanged | Notifies after a text change occurs to an IEditorDocument.
Public method | NotifyDocumentTextChanging | Notifies before a text change occurs to an IEditorDocument.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorDocumentTextChangeEventSink Methods

IEditorDocumentTextChangeEventSink Methods

The IEditorDocumentTextChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyDocumentTextChanged | Notifies after a text change occurs to an IEditorDocument.
Public method | NotifyDocumentTextChanging | Notifies before a text change occurs to an IEditorDocument.
Top
See Also

Reference

IEditorDocumentTextChangeEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanged Method

IEditorDocumentTextChangeEventSinkNotifyDocumentTextChanged Method
Notifies after a text change occurs to an IEditorDocument.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDocumentTextChanged(
    SyntaxEditor editor,
    EditorSnapshotChangedEventArgs e
)
Sub NotifyDocumentTextChanged (
    editor As SyntaxEditor,
    e As EditorSnapshotChangedEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument is changed.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangedEventArgs
The EditorSnapshotChangedEventArgs that contains the event data.
See Also

Reference

IEditorDocumentTextChangeEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorDocumentTextChangeEventSink.NotifyDocumentTextChanging Method

IEditorDocumentTextChangeEventSinkNotifyDocumentTextChanging Method
Notifies before a text change occurs to an IEditorDocument.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyDocumentTextChanging(
    SyntaxEditor editor,
    EditorSnapshotChangingEventArgs e
)
Sub NotifyDocumentTextChanging (
    editor As SyntaxEditor,
    e As EditorSnapshotChangingEventArgs
)

Parameters

editor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor whose IEditorDocument that is changing.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorSnapshotChangingEventArgs
The EditorSnapshotChangingEventArgs that contains the event data.
See Also

Reference

IEditorDocumentTextChangeEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorSearchOptions Interface

IEditorSearchOptions Interface
Provides the base requirements for find/replace options within a view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorSearchOptions : ISearchOptions
Public Interface IEditorSearchOptions
    Inherits ISearchOptions

The IEditorSearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find. (Inherited from ISearchOptions.)
Public property | MatchCase | Gets or sets whether searches should be case sensitive. (Inherited from ISearchOptions.)
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words. (Inherited from ISearchOptions.)
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found. (Inherited from ISearchOptions.)
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.). (Inherited from ISearchOptions.)
Public property | ReplaceText | Gets or sets the text with which to replace (replace operations only). (Inherited from ISearchOptions.)
Public property | Scope | Gets or sets an EditorSearchScope that indicates the scope in which to search.
Public property | SearchUp | Gets or sets whether to search backwards. (Inherited from ISearchOptions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationEditorSearchOptions


IEditorSearchOptions Properties

IEditorSearchOptions Properties

The IEditorSearchOptions type exposes the following members.

Properties
 | Name | Description
Public property | FindText | Gets or sets the text to find. (Inherited from ISearchOptions.)
Public property | MatchCase | Gets or sets whether searches should be case sensitive. (Inherited from ISearchOptions.)
Public property | MatchWholeWord | Gets or sets whether searches should only match whole words. (Inherited from ISearchOptions.)
Public property | MaximumResultCount | Gets or sets the maximum number of results that can be found. (Inherited from ISearchOptions.)
Public property | PatternProvider | Gets or sets the search pattern provider (normal, regular expression, wildcard, etc.). (Inherited from ISearchOptions.)
Public property | ReplaceText | Gets or sets the text with which to replace (replace operations only). (Inherited from ISearchOptions.)
Public property | Scope | Gets or sets an EditorSearchScope that indicates the scope in which to search.
Public property | SearchUp | Gets or sets whether to search backwards. (Inherited from ISearchOptions.)
Top
See Also

Reference

IEditorSearchOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorSearchOptions.Scope Property

IEditorSearchOptionsScope Property
Gets or sets an EditorSearchScope that indicates the scope in which to search.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
EditorSearchScope Scope { get; set; }
Property Scope As EditorSearchScope
    Get
    Set

Property Value

Type: EditorSearchScope
An EditorSearchScope that indicates the scope in which to search.
See Also

Reference

IEditorSearchOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView Interface

IEditorView Interface
Provides the base requirements for a text view that is presented in a SyntaxEditor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorView : ITextView
Public Interface IEditorView
    Inherits ITextView

The IEditorView type exposes the following members.

Properties
 | Name | Description
Public property | AreSelectionEventsSuspended | Gets whether the selection events are currently suspended.
Public property | CollapsedRegionManager | Gets an ICollapsedRegionManager that provides information about collapsed regions in the document. (Inherited from ITextView.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that currently is used to populate the view. (Inherited from ITextView.)
Public property | CurrentSnapshotLine | Gets the current ITextSnapshotLine that the caret appears on within the view.
Public property | CurrentViewLine | Gets the current IEditorViewLine that the caret appears on within the view.
Public property | FirstVisiblePosition | Gets or sets the TextPosition indicating the position of the first character on the top view line in the view.
Public property | FirstVisibleX | Gets or sets the first visible x-coordinate in the view.
Public property | HasFocus | Gets whether the view currently has keyboard focus.
Public property | HighlightedResultSearchOptions | Gets or sets the ISearchOptions to use for searching when highlighting search results.
Public property | HighlightingStyleRegistry | Gets the IHighlightingStyleRegistry used by this view. (Inherited from ITextView.)
Public property | IntelliPrompt | Gets the IEditorViewIntelliPrompt to use for requesting IntelliPrompt within the view.
Public property | IsActive | Gets whether the view is the currently-active view in the editor.
Public property | IsIncrementalSearchActive | Gets or sets whether incremental searching is active.
Public property | Margins | Gets the collection of margins that are currently in the view.
Public property | Placement | Gets a EditorViewPlacement indicating the location of the view.
Public property | PositionFinder | Gets the ITextPositionFinder that can be used to find TextPosition objects relative to another specified TextPosition.
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ITextView.)
Public property | Scroller | Gets the IEditorViewScroller to use for scrolling the view.
Public property | ScrollToCaretOnSelectionChange | Gets or sets whether to scroll to the caret on a selection change.
Public property | Searcher | Gets the IEditorViewSearcher that is used to perform find/replace and other search-related operations on the view.
Public property | SelectedText | Gets or sets the text that is currently selected in the view.
Public property | Selection | Gets an IEditorViewSelection that manages the selection within the view.
Public property | SyntaxEditor | Gets the SyntaxEditor that contains the view. (Inherited from ITextView.)
Public property | TextAreaViewportBounds | Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates. (Inherited from ITextView.)
Public property | TextChangeActions | Gets the IEditorViewTextChangeActions that is used to perform text change actions in the view.
Public property | ViewLineFormattingOptions | Gets an ITextViewLineFormattingOptions that provides view line formatting options. (Inherited from ITextView.)
Public property | VisibleViewLines | Gets the collection of IEditorViewLine objects that are currently visible within the view.
Public property | VisualElement | Gets the FrameworkElement that represents the view. (Inherited from ITextView.)
Top
Methods
 | Name | Description
Public method | Activate | Activates this view.
Public method | CopyAndAppendToClipboard | Copies the currently selected text and appends it to the existing text on the clipboard.
Public method | CopyToClipboard | Copies the currently selected text to the clipboard.
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view. (Inherited from ITextView.)
Public method | CutAndAppendToClipboard | Cuts the currently selected text and appends it to the existing text on the clipboard.
Public method | CutLineToClipboard | Cuts the currently active view line to the clipboard.
Public method | CutToClipboard | Cuts the currently selected text to the clipboard.
Public method | DeleteSelectedText(ITextChangeType) | Performs a delete text change by deleting the view's selected text.
Public method | DeleteSelectedText(ITextChangeType, IEditorViewTextChangeOptions) | Performs a delete text change by deleting the view's selected text.
Public method | ExecuteEditAction | Executes the specified IEditAction within the view.
Public method | ExportSelectedText | Exports the selected text to another text format, such as HTML or RTF.
Public method | FindCurrentWordEnd | Returns the document offset of the word end character that occurs at or after the caret.
Public method | FindCurrentWordStart | Returns the document offset of the word start character that occurs at or before the caret.
Public method | FindNextWordStart | Returns the document offset of the word start character that occurs after the caret.
Public method | FindPreviousWordStart | Returns the document offset of the word start character that occurs before the caret.
Public method | Focus | Ensures the view has focus.
Public method | GetAdornmentLayer | Returns an IAdornmentLayer for the view with the specified definition. (Inherited from ITextView.)
Public method | GetCharacterBounds(Int32) | Returns the TextBounds for the specified offset, relative to the text area's coordinates.
Public method | GetCharacterBounds(TextPosition) | Returns the TextBounds for the specified TextPosition, relative to the text area's coordinates.
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified offset.
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified TextPosition.
Public method | GetCharacterIndexRanges | Returns an array of character index Range objects for characters contained on each view line in the specified TextPositionRange.
Public method | GetCurrentWordText | Gets the text of the current word.
Public method | GetCurrentWordTextRange | Gets the TextRange for the current word.
Public method | GetReader | Returns an ITextSnapshotReader, initialized at the caret offset, that can be used to navigate through the text and token contents of the current snapshot.
Public method | GetTextStatisticsForSelectedText | Returns the ITextStatistics for the selected text in the view, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.
Public method | GetViewLine(Int32) | Returns an IEditorViewLine that contains the specified offset.
Public method | GetViewLine(TextPosition) | Returns an IEditorViewLine that contains the specified TextPosition.
Public method | GetViewLine(Double, LocationToPositionAlgorithm) | Gets the IEditorViewLine that contains the specified y-coordinate.
Public method | GetViewLine(IEditorViewLine, Int32) | Returns the IEditorViewLine that is relative to the specified IEditorViewLine.
Public method | GetViewLine(IEditorViewLine, Int32, Boolean) | Returns the IEditorViewLine that is relative to the specified IEditorViewLine.
Public method | GetVirtualCharacterFillString | Gets a string specifying the indentation (tabs and/or spaces) needed to fill a view line up to the specified TextPosition.
Public method | InsertSurroundingText(String, String) | Inserts text into the document that surrounds the currently selected text in the view, using a TextChangeTypes.Typing change type.
Public method | InsertSurroundingText(ITextChangeType, String, String) | Inserts text into the document that surrounds the currently selected text in the view.
Public method | InsertSurroundingText(ITextChangeType, String, String, Boolean) | Inserts text into the document that surrounds the currently selected text in the view.
Public method | IsVirtualCharacter | Returns whether the specified TextPosition is a virtual character (beyond line or document end).
Public method | IsVirtualLine(Int32) | Returns whether the specified TextPosition line index is a virtual line (beyond document end).
Public method | IsVirtualLine(TextPosition) | Returns whether the specified TextPosition is a virtual line (beyond document end).
Public method | LocationToPosition | Returns the TextPosition for the specified location.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the view lines. (Inherited from ITextView.)
Public method | PasteFromClipboard | Pastes text from the clipboard into the selection.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the view lines. (Inherited from ITextView.)
Public method | ReplaceSelectedText(ITextChangeType, String) | Performs a replace text change by overwriting the view's selected text.
Public method | ReplaceSelectedText(ITextChangeType, String, IEditorViewTextChangeOptions) | Performs a replace text change by overwriting the view's selected text.
Public method | ResumeSelectionEvents | Allows the selection to raise events.
Public method | StartMouseSelection | Starts a mouse selection operation during a pointer button down event.
Public method | SuspendSelectionEvents | Prevents the selection from raising events.
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the view is closed. (Inherited from ITextView.)
Public event | HasFocusChanged | Occurs when the HasFocus property value is changed.
Public event | HighlightedResultSearchOptionsChanged | Occurs when the HighlightedResultSearchOptions property value is changed.
Public event | MarginsDestroyed | Occurs when the view's margins need to be destroyed. (Inherited from ITextView.)
Public event | SelectionChanged | Occurs after the selection is changed.
Public event | TextAreaLayout | Occurs when the layout of the lines in the text area has been updated. (Inherited from ITextView.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView Properties

IEditorView Properties

The IEditorView type exposes the following members.

Properties
 | Name | Description
Public property | AreSelectionEventsSuspended | Gets whether the selection events are currently suspended.
Public property | CollapsedRegionManager | Gets an ICollapsedRegionManager that provides information about collapsed regions in the document. (Inherited from ITextView.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that currently is used to populate the view. (Inherited from ITextView.)
Public property | CurrentSnapshotLine | Gets the current ITextSnapshotLine that the caret appears on within the view.
Public property | CurrentViewLine | Gets the current IEditorViewLine that the caret appears on within the view.
Public property | FirstVisiblePosition | Gets or sets the TextPosition indicating the position of the first character on the top view line in the view.
Public property | FirstVisibleX | Gets or sets the first visible x-coordinate in the view.
Public property | HasFocus | Gets whether the view currently has keyboard focus.
Public property | HighlightedResultSearchOptions | Gets or sets the ISearchOptions to use for searching when highlighting search results.
Public property | HighlightingStyleRegistry | Gets the IHighlightingStyleRegistry used by this view. (Inherited from ITextView.)
Public property | IntelliPrompt | Gets the IEditorViewIntelliPrompt to use for requesting IntelliPrompt within the view.
Public property | IsActive | Gets whether the view is the currently-active view in the editor.
Public property | IsIncrementalSearchActive | Gets or sets whether incremental searching is active.
Public property | Margins | Gets the collection of margins that are currently in the view.
Public property | Placement | Gets a EditorViewPlacement indicating the location of the view.
Public property | PositionFinder | Gets the ITextPositionFinder that can be used to find TextPosition objects relative to another specified TextPosition.
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ITextView.)
Public property | Scroller | Gets the IEditorViewScroller to use for scrolling the view.
Public property | ScrollToCaretOnSelectionChange | Gets or sets whether to scroll to the caret on a selection change.
Public property | Searcher | Gets the IEditorViewSearcher that is used to perform find/replace and other search-related operations on the view.
Public property | SelectedText | Gets or sets the text that is currently selected in the view.
Public property | Selection | Gets an IEditorViewSelection that manages the selection within the view.
Public property | SyntaxEditor | Gets the SyntaxEditor that contains the view. (Inherited from ITextView.)
Public property | TextAreaViewportBounds | Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates. (Inherited from ITextView.)
Public property | TextChangeActions | Gets the IEditorViewTextChangeActions that is used to perform text change actions in the view.
Public property | ViewLineFormattingOptions | Gets an ITextViewLineFormattingOptions that provides view line formatting options. (Inherited from ITextView.)
Public property | VisibleViewLines | Gets the collection of IEditorViewLine objects that are currently visible within the view.
Public property | VisualElement | Gets the FrameworkElement that represents the view. (Inherited from ITextView.)
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.AreSelectionEventsSuspended Property

IEditorViewAreSelectionEventsSuspended Property
Gets whether the selection events are currently suspended.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool AreSelectionEventsSuspended { get; }
ReadOnly Property AreSelectionEventsSuspended As Boolean
    Get

Property Value

Type: Boolean
true if selection events are currently suspended; otherwise, false.
Remarks
If this flag is set, no selection change events are raised.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CurrentSnapshotLine Property

IEditorViewCurrentSnapshotLine Property
Gets the current ITextSnapshotLine that the caret appears on within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotLine CurrentSnapshotLine { get; }
ReadOnly Property CurrentSnapshotLine As ITextSnapshotLine
    Get

Property Value

Type: ITextSnapshotLine
The current ITextSnapshotLine that the caret appears on within the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CurrentViewLine Property

IEditorViewCurrentViewLine Property
Gets the current IEditorViewLine that the caret appears on within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine CurrentViewLine { get; }
ReadOnly Property CurrentViewLine As IEditorViewLine
    Get

Property Value

Type: IEditorViewLine
The current IEditorViewLine that the caret appears on within the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.FirstVisiblePosition Property

IEditorViewFirstVisiblePosition Property
Gets or sets the TextPosition indicating the position of the first character on the top view line in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition FirstVisiblePosition { get; set; }
Property FirstVisiblePosition As TextPosition
    Get
    Set

Property Value

Type: TextPosition
The TextPosition indicating the position of the first character on the top view line in the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.FirstVisibleX Property

IEditorViewFirstVisibleX Property
Gets or sets the first visible x-coordinate in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FirstVisibleX { get; set; }
Property FirstVisibleX As Integer
    Get
    Set

Property Value

Type: Int32
The index of the first visible x-coordinate in the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.HasFocus Property

IEditorViewHasFocus Property
Gets whether the view currently has keyboard focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasFocus { get; }
ReadOnly Property HasFocus As Boolean
    Get

Property Value

Type: Boolean
true if the view currently has keyboard focus; otherwise, false.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.HighlightedResultSearchOptions Property

IEditorViewHighlightedResultSearchOptions Property
Gets or sets the ISearchOptions to use for searching when highlighting search results.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchOptions HighlightedResultSearchOptions { get; set; }
Property HighlightedResultSearchOptions As ISearchOptions
    Get
    Set

Property Value

Type: ISearchOptions
The ISearchOptions to use for searching when highlighting search results.
Remarks
Highlighted results are displayed when using incremental search and the IsIncrementalSearchResultHighlightingEnabled property is set to true. This property can also be manually set when using a search pane as the user types, so that results will be immediately displayed. Set the property to to stop highlighting.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IntelliPrompt Property

IEditorViewIntelliPrompt Property
Gets the IEditorViewIntelliPrompt to use for requesting IntelliPrompt within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewIntelliPrompt IntelliPrompt { get; }
ReadOnly Property IntelliPrompt As IEditorViewIntelliPrompt
    Get

Property Value

Type: IEditorViewIntelliPrompt
The IEditorViewIntelliPrompt to use for requesting IntelliPrompt within the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IsActive Property

IEditorViewIsActive Property
Gets whether the view is the currently-active view in the editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsActive { get; }
ReadOnly Property IsActive As Boolean
    Get

Property Value

Type: Boolean
true if the view is the currently-active view in the editor; otherwise, false.
Remarks
The currently-active view in the editor is the view that contains focus when focus is moved within the editor. There is always a single view in an editor marked as active. Use the HasFocus property to determine if the view currently has keyboard focus.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IsIncrementalSearchActive Property

IEditorViewIsIncrementalSearchActive Property
Gets or sets whether incremental searching is active.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsIncrementalSearchActive { get; set; }
Property IsIncrementalSearchActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if incremental searching is active; otherwise, false.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Margins Property

IEditorViewMargins Property
Gets the collection of margins that are currently in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewMarginCollection Margins { get; }
ReadOnly Property Margins As IEditorViewMarginCollection
    Get

Property Value

Type: IEditorViewMarginCollection
The collection of margins that are currently in the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Placement Property

IEditorViewPlacement Property
Gets a EditorViewPlacement indicating the location of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
EditorViewPlacement Placement { get; }
ReadOnly Property Placement As EditorViewPlacement
    Get

Property Value

Type: EditorViewPlacement
A EditorViewPlacement indicating the location of the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.PositionFinder Property

IEditorViewPositionFinder Property
Gets the ITextPositionFinder that can be used to find TextPosition objects relative to another specified TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextPositionFinder PositionFinder { get; }
ReadOnly Property PositionFinder As ITextPositionFinder
    Get

Property Value

Type: ITextPositionFinder
The ITextPositionFinder instance.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Scroller Property

IEditorViewScroller Property
Gets the IEditorViewScroller to use for scrolling the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewScroller Scroller { get; }
ReadOnly Property Scroller As IEditorViewScroller
    Get

Property Value

Type: IEditorViewScroller
The IEditorViewScroller to use for scrolling the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ScrollToCaretOnSelectionChange Property

IEditorViewScrollToCaretOnSelectionChange Property
Gets or sets whether to scroll to the caret on a selection change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ScrollToCaretOnSelectionChange { get; set; }
Property ScrollToCaretOnSelectionChange As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the view should scroll to the caret on a selection change; otherwise, false.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Searcher Property

IEditorViewSearcher Property
Gets the IEditorViewSearcher that is used to perform find/replace and other search-related operations on the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewSearcher Searcher { get; }
ReadOnly Property Searcher As IEditorViewSearcher
    Get

Property Value

Type: IEditorViewSearcher
The IEditorViewSearcher that is used to perform find/replace and other search-related operations on the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.SelectedText Property

IEditorViewSelectedText Property
Gets or sets the text that is currently selected in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string SelectedText { get; set; }
Property SelectedText As String
    Get
    Set

Property Value

Type: String
The text that is currently selected in the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Selection Property

IEditorViewSelection Property
Gets an IEditorViewSelection that manages the selection within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewSelection Selection { get; }
ReadOnly Property Selection As IEditorViewSelection
    Get

Property Value

Type: IEditorViewSelection
An IEditorViewSelection that manages the selection within the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.TextChangeActions Property

IEditorViewTextChangeActions Property
Gets the IEditorViewTextChangeActions that is used to perform text change actions in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewTextChangeActions TextChangeActions { get; }
ReadOnly Property TextChangeActions As IEditorViewTextChangeActions
    Get

Property Value

Type: IEditorViewTextChangeActions
The IEditorViewTextChangeActions that is used to perform text change actions in the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.VisibleViewLines Property

IEditorViewVisibleViewLines Property
Gets the collection of IEditorViewLine objects that are currently visible within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLineCollection VisibleViewLines { get; }
ReadOnly Property VisibleViewLines As IEditorViewLineCollection
    Get

Property Value

Type: IEditorViewLineCollection
The collection of IEditorViewLine objects that are currently visible within the view.
Remarks
The IEditorViewLine items in this collection are sorted in their display order, top to bottom.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView Methods

IEditorView Methods

The IEditorView type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates this view.
Public method | CopyAndAppendToClipboard | Copies the currently selected text and appends it to the existing text on the clipboard.
Public method | CopyToClipboard | Copies the currently selected text to the clipboard.
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view. (Inherited from ITextView.)
Public method | CutAndAppendToClipboard | Cuts the currently selected text and appends it to the existing text on the clipboard.
Public method | CutLineToClipboard | Cuts the currently active view line to the clipboard.
Public method | CutToClipboard | Cuts the currently selected text to the clipboard.
Public method | DeleteSelectedText(ITextChangeType) | Performs a delete text change by deleting the view's selected text.
Public method | DeleteSelectedText(ITextChangeType, IEditorViewTextChangeOptions) | Performs a delete text change by deleting the view's selected text.
Public method | ExecuteEditAction | Executes the specified IEditAction within the view.
Public method | ExportSelectedText | Exports the selected text to another text format, such as HTML or RTF.
Public method | FindCurrentWordEnd | Returns the document offset of the word end character that occurs at or after the caret.
Public method | FindCurrentWordStart | Returns the document offset of the word start character that occurs at or before the caret.
Public method | FindNextWordStart | Returns the document offset of the word start character that occurs after the caret.
Public method | FindPreviousWordStart | Returns the document offset of the word start character that occurs before the caret.
Public method | Focus | Ensures the view has focus.
Public method | GetAdornmentLayer | Returns an IAdornmentLayer for the view with the specified definition. (Inherited from ITextView.)
Public method | GetCharacterBounds(Int32) | Returns the TextBounds for the specified offset, relative to the text area's coordinates.
Public method | GetCharacterBounds(TextPosition) | Returns the TextBounds for the specified TextPosition, relative to the text area's coordinates.
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified offset.
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified TextPosition.
Public method | GetCharacterIndexRanges | Returns an array of character index Range objects for characters contained on each view line in the specified TextPositionRange.
Public method | GetCurrentWordText | Gets the text of the current word.
Public method | GetCurrentWordTextRange | Gets the TextRange for the current word.
Public method | GetReader | Returns an ITextSnapshotReader, initialized at the caret offset, that can be used to navigate through the text and token contents of the current snapshot.
Public method | GetTextStatisticsForSelectedText | Returns the ITextStatistics for the selected text in the view, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.
Public method | GetViewLine(Int32) | Returns an IEditorViewLine that contains the specified offset.
Public method | GetViewLine(TextPosition) | Returns an IEditorViewLine that contains the specified TextPosition.
Public method | GetViewLine(Double, LocationToPositionAlgorithm) | Gets the IEditorViewLine that contains the specified y-coordinate.
Public method | GetViewLine(IEditorViewLine, Int32) | Returns the IEditorViewLine that is relative to the specified IEditorViewLine.
Public method | GetViewLine(IEditorViewLine, Int32, Boolean) | Returns the IEditorViewLine that is relative to the specified IEditorViewLine.
Public method | GetVirtualCharacterFillString | Gets a string specifying the indentation (tabs and/or spaces) needed to fill a view line up to the specified TextPosition.
Public method | InsertSurroundingText(String, String) | Inserts text into the document that surrounds the currently selected text in the view, using a TextChangeTypes.Typing change type.
Public method | InsertSurroundingText(ITextChangeType, String, String) | Inserts text into the document that surrounds the currently selected text in the view.
Public method | InsertSurroundingText(ITextChangeType, String, String, Boolean) | Inserts text into the document that surrounds the currently selected text in the view.
Public method | IsVirtualCharacter | Returns whether the specified TextPosition is a virtual character (beyond line or document end).
Public method | IsVirtualLine(Int32) | Returns whether the specified TextPosition line index is a virtual line (beyond document end).
Public method | IsVirtualLine(TextPosition) | Returns whether the specified TextPosition is a virtual line (beyond document end).
Public method | LocationToPosition | Returns the TextPosition for the specified location.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the view lines. (Inherited from ITextView.)
Public method | PasteFromClipboard | Pastes text from the clipboard into the selection.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the view lines. (Inherited from ITextView.)
Public method | ReplaceSelectedText(ITextChangeType, String) | Performs a replace text change by overwriting the view's selected text.
Public method | ReplaceSelectedText(ITextChangeType, String, IEditorViewTextChangeOptions) | Performs a replace text change by overwriting the view's selected text.
Public method | ResumeSelectionEvents | Allows the selection to raise events.
Public method | StartMouseSelection | Starts a mouse selection operation during a pointer button down event.
Public method | SuspendSelectionEvents | Prevents the selection from raising events.
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Activate Method

IEditorViewActivate Method
Activates this view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Activate()
Sub Activate
Remarks
The currently-active view in the editor is the view that contains focus when focus is moved within the editor. There is always a single view in an editor marked as active.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CopyAndAppendToClipboard Method

IEditorViewCopyAndAppendToClipboard Method
Copies the currently selected text and appends it to the existing text on the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CopyAndAppendToClipboard()
Sub CopyAndAppendToClipboard
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CopyToClipboard Method

IEditorViewCopyToClipboard Method
Copies the currently selected text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CopyToClipboard()
Sub CopyToClipboard
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CutAndAppendToClipboard Method

IEditorViewCutAndAppendToClipboard Method
Cuts the currently selected text and appends it to the existing text on the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CutAndAppendToClipboard()
Sub CutAndAppendToClipboard
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CutLineToClipboard Method

IEditorViewCutLineToClipboard Method
Cuts the currently active view line to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CutLineToClipboard()
Sub CutLineToClipboard
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.CutToClipboard Method

IEditorViewCutToClipboard Method
Cuts the currently selected text to the clipboard.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CutToClipboard()
Sub CutToClipboard
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.DeleteSelectedText Method

IEditorViewDeleteSelectedText Method
Overload List
 | Name | Description
Public method | DeleteSelectedText(ITextChangeType) | Performs a delete text change by deleting the view's selected text.
Public method | DeleteSelectedText(ITextChangeType, IEditorViewTextChangeOptions) | Performs a delete text change by deleting the view's selected text.
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.DeleteSelectedText Method (ITextChangeType)

IEditorViewDeleteSelectedText Method (ITextChangeType)
Performs a delete text change by deleting the view's selected text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool DeleteSelectedText(
    ITextChangeType type
)
Function DeleteSelectedText (
    type As ITextChangeType
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
DeleteSelectedText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.DeleteSelectedText Method (ITextChangeType, IEditorViewTextChangeOptions)

IEditorViewDeleteSelectedText Method (ITextChangeType, IEditorViewTextChangeOptions)
Performs a delete text change by deleting the view's selected text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool DeleteSelectedText(
    ITextChangeType type,
    IEditorViewTextChangeOptions options
)
Function DeleteSelectedText (
    type As ITextChangeType,
    options As IEditorViewTextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewTextChangeOptions
The IEditorViewTextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
DeleteSelectedText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ExecuteEditAction Method

IEditorViewExecuteEditAction Method
Executes the specified IEditAction within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ExecuteEditAction(
    IEditAction action
)
Function ExecuteEditAction (
    action As IEditAction
) As Boolean

Parameters

action
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditAction
The IEditAction to execute.

Return Value

Type: Boolean
true if the action was able to execute; otherwise, false.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ExportSelectedText Method

IEditorViewExportSelectedText Method
Exports the selected text to another text format, such as HTML or RTF.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string ExportSelectedText(
    ITextExporter exporter
)
Function ExportSelectedText (
    exporter As ITextExporter
) As String

Parameters

exporter
Type: ActiproSoftware.Text.ExportersITextExporter
The ITextExporter to use for the export operation.

Return Value

Type: String
The exported text.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.FindCurrentWordEnd Method

IEditorViewFindCurrentWordEnd Method
Returns the document offset of the word end character that occurs at or after the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindCurrentWordEnd()
Function FindCurrentWordEnd As Integer

Return Value

Type: Int32
The document offset of the word end character that occurs at or after the caret.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.FindCurrentWordStart Method

IEditorViewFindCurrentWordStart Method
Returns the document offset of the word start character that occurs at or before the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindCurrentWordStart()
Function FindCurrentWordStart As Integer

Return Value

Type: Int32
The document offset of the word start character that occurs at or before the caret.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.FindNextWordStart Method

IEditorViewFindNextWordStart Method
Returns the document offset of the word start character that occurs after the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindNextWordStart()
Function FindNextWordStart As Integer

Return Value

Type: Int32
The document offset of the word start character that occurs after the caret.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.FindPreviousWordStart Method

IEditorViewFindPreviousWordStart Method
Returns the document offset of the word start character that occurs before the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FindPreviousWordStart()
Function FindPreviousWordStart As Integer

Return Value

Type: Int32
The document offset of the word start character that occurs before the caret.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.Focus Method

IEditorViewFocus Method
Ensures the view has focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Focus()
Function Focus As Boolean

Return Value

Type: Boolean
true if focus was successfully set; otherwise, false.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterBounds Method

IEditorViewGetCharacterBounds Method
Overload List
 | Name | Description
Public method | GetCharacterBounds(Int32) | Returns the TextBounds for the specified offset, relative to the text area's coordinates.
Public method | GetCharacterBounds(TextPosition) | Returns the TextBounds for the specified TextPosition, relative to the text area's coordinates.
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterBounds Method (Int32)

IEditorViewGetCharacterBounds Method (Int32)
Returns the TextBounds for the specified offset, relative to the text area's coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextBounds GetCharacterBounds(
    int offset
)
Function GetCharacterBounds (
    offset As Integer
) As TextBounds

Parameters

offset
Type: SystemInt32
The offset whose bounds need to be retrieved.

Return Value

Type: TextBounds
A TextBounds containing the visible character bounds for the specified offset.
See Also

Reference

IEditorView Interface
GetCharacterBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterBounds Method (TextPosition)

IEditorViewGetCharacterBounds Method (TextPosition)
Returns the TextBounds for the specified TextPosition, relative to the text area's coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextBounds GetCharacterBounds(
    TextPosition position
)
Function GetCharacterBounds (
    position As TextPosition
) As TextBounds

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition whose bounds need to be retrieved.

Return Value

Type: TextBounds
A TextBounds containing the visible character bounds for the specified TextPosition.
See Also

Reference

IEditorView Interface
GetCharacterBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterColumn Method

IEditorViewGetCharacterColumn Method
Overload List
 | Name | Description
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified offset.
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified TextPosition.
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterColumn Method (Int32)

IEditorViewGetCharacterColumn Method (Int32)
Returns the column index within the view for the specified offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetCharacterColumn(
    int offset
)
Function GetCharacterColumn (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset whose column index is being requested.

Return Value

Type: Int32
The column index within the view for the specified offset.
See Also

Reference

IEditorView Interface
GetCharacterColumn Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterColumn Method (TextPosition)

IEditorViewGetCharacterColumn Method (TextPosition)
Returns the column index within the view for the specified TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetCharacterColumn(
    TextPosition position
)
Function GetCharacterColumn (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition whose column index is being requested.

Return Value

Type: Int32
The column index within the view for the specified TextPosition.
See Also

Reference

IEditorView Interface
GetCharacterColumn Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCharacterIndexRanges Method

IEditorViewGetCharacterIndexRanges Method
Returns an array of character index Range objects for characters contained on each view line in the specified TextPositionRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Range[] GetCharacterIndexRanges(
    TextPositionRange positionRange,
    bool allowWholeLines,
    int minimumLines
)
Function GetCharacterIndexRanges (
    positionRange As TextPositionRange,
    allowWholeLines As Boolean,
    minimumLines As Integer
) As Range()

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange to examine.
allowWholeLines
Type: SystemBoolean
Whether to allow whole line ranges if the x-coordinate range is empty, used for block selections. For continuous stream selections, pass false.
minimumLines
Type: SystemInt32
The minimum number of lines to return, used for block selections. For continuous stream selections, pass 1.

Return Value

Type: Range
An array of character index Range objects for characters contained on each view line in the specified TextPositionRange.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCurrentWordText Method

IEditorViewGetCurrentWordText Method
Gets the text of the current word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetCurrentWordText()
Function GetCurrentWordText As String

Return Value

Type: String
The text of the current word.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetCurrentWordTextRange Method

IEditorViewGetCurrentWordTextRange Method
Gets the TextRange for the current word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange GetCurrentWordTextRange()
Function GetCurrentWordTextRange As TextRange

Return Value

Type: TextRange
A TextRange containing the offset range for the current word.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetReader Method

IEditorViewGetReader Method
Returns an ITextSnapshotReader, initialized at the caret offset, that can be used to navigate through the text and token contents of the current snapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotReader GetReader()
Function GetReader As ITextSnapshotReader

Return Value

Type: ITextSnapshotReader
An ITextBufferReader, initialized at the caret offset, that can be used to navigate through the text and token contents of the current snapshot.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetTextStatisticsForSelectedText Method

IEditorViewGetTextStatisticsForSelectedText Method
Returns the ITextStatistics for the selected text in the view, which provides numerous statistics about the text such as word, sentence, character counts as well as readability scores.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextStatistics GetTextStatisticsForSelectedText()
Function GetTextStatisticsForSelectedText As ITextStatistics

Return Value

Type: ITextStatistics
The ITextStatistics for the selected text in the view.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetViewLine Method

IEditorViewGetViewLine Method
Overload List
 | Name | Description
Public method | GetViewLine(Int32) | Returns an IEditorViewLine that contains the specified offset.
Public method | GetViewLine(TextPosition) | Returns an IEditorViewLine that contains the specified TextPosition.
Public method | GetViewLine(Double, LocationToPositionAlgorithm) | Gets the IEditorViewLine that contains the specified y-coordinate.
Public method | GetViewLine(IEditorViewLine, Int32) | Returns the IEditorViewLine that is relative to the specified IEditorViewLine.
Public method | GetViewLine(IEditorViewLine, Int32, Boolean) | Returns the IEditorViewLine that is relative to the specified IEditorViewLine.
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetViewLine Method (Int32)

IEditorViewGetViewLine Method (Int32)
Returns an IEditorViewLine that contains the specified offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine GetViewLine(
    int offset
)
Function GetViewLine (
    offset As Integer
) As IEditorViewLine

Parameters

offset
Type: SystemInt32
The offset for which to retrieve an IEditorViewLine.

Return Value

Type: IEditorViewLine
An IEditorViewLine that contains the specified offset.
See Also

Reference

IEditorView Interface
GetViewLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetViewLine Method (TextPosition)

IEditorViewGetViewLine Method (TextPosition)
Returns an IEditorViewLine that contains the specified TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine GetViewLine(
    TextPosition position
)
Function GetViewLine (
    position As TextPosition
) As IEditorViewLine

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition for which to retrieve an IEditorViewLine.

Return Value

Type: IEditorViewLine
An IEditorViewLine that contains the specified TextPosition.
See Also

Reference

IEditorView Interface
GetViewLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetViewLine Method (Double, LocationToPositionAlgorithm)

IEditorViewGetViewLine Method (Double, LocationToPositionAlgorithm)
Gets the IEditorViewLine that contains the specified y-coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine GetViewLine(
    double verticalLocation,
    LocationToPositionAlgorithm algorithm
)
Function GetViewLine (
    verticalLocation As Double,
    algorithm As LocationToPositionAlgorithm
) As IEditorViewLine

Parameters

verticalLocation
Type: SystemDouble
The y-coordinate to examine, in text area-relative coordinates.
algorithm
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm
The LocationToPositionAlgorithm to use for calculation.

Return Value

Type: IEditorViewLine
The IEditorViewLine that contains the specified y-coordinate.
See Also

Reference

IEditorView Interface
GetViewLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetViewLine Method (IEditorViewLine, Int32)

IEditorViewGetViewLine Method (IEditorViewLine, Int32)
Returns the IEditorViewLine that is relative to the specified IEditorViewLine.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine GetViewLine(
    IEditorViewLine viewLine,
    int lineDelta
)
Function GetViewLine (
    viewLine As IEditorViewLine,
    lineDelta As Integer
) As IEditorViewLine

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The source IEditorViewLine.
lineDelta
Type: SystemInt32
The number of lines to traverse (can be negative).

Return Value

Type: IEditorViewLine
The IEditorViewLine that is relative to the specified IEditorViewLine.
See Also

Reference

IEditorView Interface
GetViewLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetViewLine Method (IEditorViewLine, Int32, Boolean)

IEditorViewGetViewLine Method (IEditorViewLine, Int32, Boolean)
Returns the IEditorViewLine that is relative to the specified IEditorViewLine.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine GetViewLine(
    IEditorViewLine viewLine,
    int lineDelta,
    bool forceVirtualSpace
)
Function GetViewLine (
    viewLine As IEditorViewLine,
    lineDelta As Integer,
    forceVirtualSpace As Boolean
) As IEditorViewLine

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine
The source IEditorViewLine.
lineDelta
Type: SystemInt32
The number of lines to traverse (can be negative).
forceVirtualSpace
Type: SystemBoolean
Whether to force virtual line space to be used as needed (for block selections).

Return Value

Type: IEditorViewLine
The IEditorViewLine that is relative to the specified IEditorViewLine.
See Also

Reference

IEditorView Interface
GetViewLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.GetVirtualCharacterFillString Method

IEditorViewGetVirtualCharacterFillString Method
Gets a string specifying the indentation (tabs and/or spaces) needed to fill a view line up to the specified TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string GetVirtualCharacterFillString(
    TextPosition position,
    bool returnCharacterFill
)
Function GetVirtualCharacterFillString (
    position As TextPosition,
    returnCharacterFill As Boolean
) As String

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to be examined.
returnCharacterFill
Type: SystemBoolean
Whether to return a character fill in addition to line fill.

Return Value

Type: String
A string specifying the indentation (tabs and/or spaces) needed to fill a view line up to the specified TextPosition.
Remarks
This method will return String.Empty if the character is not a virtual character.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.InsertSurroundingText Method

IEditorViewInsertSurroundingText Method
Overload List
 | Name | Description
Public method | InsertSurroundingText(String, String) | Inserts text into the document that surrounds the currently selected text in the view, using a TextChangeTypes.Typing change type.
Public method | InsertSurroundingText(ITextChangeType, String, String) | Inserts text into the document that surrounds the currently selected text in the view.
Public method | InsertSurroundingText(ITextChangeType, String, String, Boolean) | Inserts text into the document that surrounds the currently selected text in the view.
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.InsertSurroundingText Method (String, String)

IEditorViewInsertSurroundingText Method (String, String)
Inserts text into the document that surrounds the currently selected text in the view, using a TextChangeTypes.Typing change type.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool InsertSurroundingText(
    string preText,
    string postText
)
Function InsertSurroundingText (
    preText As String,
    postText As String
) As Boolean

Parameters

preText
Type: SystemString
The text to insert before the current selection.
postText
Type: SystemString
The text to insert after the current selection.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
InsertSurroundingText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.InsertSurroundingText Method (ITextChangeType, String, String)

IEditorViewInsertSurroundingText Method (ITextChangeType, String, String)
Inserts text into the document that surrounds the currently selected text in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool InsertSurroundingText(
    ITextChangeType type,
    string preText,
    string postText
)
Function InsertSurroundingText (
    type As ITextChangeType,
    preText As String,
    postText As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
preText
Type: SystemString
The text to insert before the current selection.
postText
Type: SystemString
The text to insert after the current selection.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
InsertSurroundingText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.InsertSurroundingText Method (ITextChangeType, String, String, Boolean)

IEditorViewInsertSurroundingText Method (ITextChangeType, String, String, Boolean)
Inserts text into the document that surrounds the currently selected text in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool InsertSurroundingText(
    ITextChangeType type,
    string preText,
    string postText,
    bool reselect
)
Function InsertSurroundingText (
    type As ITextChangeType,
    preText As String,
    postText As String,
    reselect As Boolean
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
preText
Type: SystemString
The text to insert before the current selection.
postText
Type: SystemString
The text to insert after the current selection.
reselect
Type: SystemBoolean
Whether to reselect the inner text.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
InsertSurroundingText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IsVirtualCharacter Method

IEditorViewIsVirtualCharacter Method
Returns whether the specified TextPosition is a virtual character (beyond line or document end).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVirtualCharacter(
    TextPosition position,
    bool lineTerminatorsAreVirtual
)
Function IsVirtualCharacter (
    position As TextPosition,
    lineTerminatorsAreVirtual As Boolean
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.
lineTerminatorsAreVirtual
Type: SystemBoolean
Indicates whether to treat line terminators as virtual characters.

Return Value

Type: Boolean
true if the specified TextPosition is a virtual character (beyond line or document end); otherwise, false.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IsVirtualLine Method

IEditorViewIsVirtualLine Method
Overload List
 | Name | Description
Public method | IsVirtualLine(Int32) | Returns whether the specified TextPosition line index is a virtual line (beyond document end).
Public method | IsVirtualLine(TextPosition) | Returns whether the specified TextPosition is a virtual line (beyond document end).
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IsVirtualLine Method (Int32)

IEditorViewIsVirtualLine Method (Int32)
Returns whether the specified TextPosition line index is a virtual line (beyond document end).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVirtualLine(
    int positionLineIndex
)
Function IsVirtualLine (
    positionLineIndex As Integer
) As Boolean

Parameters

positionLineIndex
Type: SystemInt32
The TextPosition line index to examine.

Return Value

Type: Boolean
true if the specified TextPosition line index is a virtual line (beyond document end); otherwise, false.
See Also

Reference

IEditorView Interface
IsVirtualLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.IsVirtualLine Method (TextPosition)

IEditorViewIsVirtualLine Method (TextPosition)
Returns whether the specified TextPosition is a virtual line (beyond document end).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVirtualLine(
    TextPosition position
)
Function IsVirtualLine (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to examine.

Return Value

Type: Boolean
true if the specified TextPosition is a virtual line (beyond document end); otherwise, false.
See Also

Reference

IEditorView Interface
IsVirtualLine Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.LocationToPosition Method

IEditorViewLocationToPosition Method
Returns the TextPosition for the specified location.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition LocationToPosition(
    Point location,
    LocationToPositionAlgorithm algorithm
)
Function LocationToPosition (
    location As Point,
    algorithm As LocationToPositionAlgorithm
) As TextPosition

Parameters

location
Type: Windows.FoundationPoint
A Point specifying a location in text area-relative coordinates.
algorithm
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm
The LocationToPositionAlgorithm to use for calculation.

Return Value

Type: TextPosition
The TextPosition for the specified location.
Remarks
If using an absolute algorithm and no valid TextPosition is located, TextPosition.Empty will be returned.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.PasteFromClipboard Method

IEditorViewPasteFromClipboard Method
Pastes text from the clipboard into the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void PasteFromClipboard()
Sub PasteFromClipboard
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ReplaceSelectedText Method

IEditorViewReplaceSelectedText Method
Overload List
 | Name | Description
Public method | ReplaceSelectedText(ITextChangeType, String) | Performs a replace text change by overwriting the view's selected text.
Public method | ReplaceSelectedText(ITextChangeType, String, IEditorViewTextChangeOptions) | Performs a replace text change by overwriting the view's selected text.
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ReplaceSelectedText Method (ITextChangeType, String)

IEditorViewReplaceSelectedText Method (ITextChangeType, String)
Performs a replace text change by overwriting the view's selected text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReplaceSelectedText(
    ITextChangeType type,
    string text
)
Function ReplaceSelectedText (
    type As ITextChangeType,
    text As String
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
ReplaceSelectedText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ReplaceSelectedText Method (ITextChangeType, String, IEditorViewTextChangeOptions)

IEditorViewReplaceSelectedText Method (ITextChangeType, String, IEditorViewTextChangeOptions)
Performs a replace text change by overwriting the view's selected text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool ReplaceSelectedText(
    ITextChangeType type,
    string text,
    IEditorViewTextChangeOptions options
)
Function ReplaceSelectedText (
    type As ITextChangeType,
    text As String,
    options As IEditorViewTextChangeOptions
) As Boolean

Parameters

type
Type: ActiproSoftware.TextITextChangeType
An ITextChangeType specifying the type of change.
text
Type: SystemString
The text to insert.
options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewTextChangeOptions
The IEditorViewTextChangeOptions for the change.

Return Value

Type: Boolean
true if a text change was allowed to occur; otherwise, false.
See Also

Reference

IEditorView Interface
ReplaceSelectedText Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.ResumeSelectionEvents Method

IEditorViewResumeSelectionEvents Method
Allows the selection to raise events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ResumeSelectionEvents(
    bool forceEvent
)
Sub ResumeSelectionEvents (
    forceEvent As Boolean
)

Parameters

forceEvent
Type: SystemBoolean
Whether to force the event to raise, even if there was no selection change.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
IEditorViewAreSelectionEventsSuspended
IEditorViewSuspendSelectionEvents


IEditorView.StartMouseSelection Method

IEditorViewStartMouseSelection Method
Starts a mouse selection operation during a pointer button down event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void StartMouseSelection(
    PointerRoutedEventArgs e
)
Sub StartMouseSelection (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
A PointerRoutedEventArgs that contains the event data.
Remarks
The left or right mouse button must be pressed when this method is called. When the left button mouse selection starts, the mouse will be captured and further selection processing will be handled automatically.
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.SuspendSelectionEvents Method

IEditorViewSuspendSelectionEvents Method
Prevents the selection from raising events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SuspendSelectionEvents()
Sub SuspendSelectionEvents
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
IEditorViewAreSelectionEventsSuspended
IEditorViewResumeSelectionEvents(Boolean)


IEditorView Events

IEditorView Events

The IEditorView type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the view is closed. (Inherited from ITextView.)
Public event | HasFocusChanged | Occurs when the HasFocus property value is changed.
Public event | HighlightedResultSearchOptionsChanged | Occurs when the HighlightedResultSearchOptions property value is changed.
Public event | MarginsDestroyed | Occurs when the view's margins need to be destroyed. (Inherited from ITextView.)
Public event | SelectionChanged | Occurs after the selection is changed.
Public event | TextAreaLayout | Occurs when the layout of the lines in the text area has been updated. (Inherited from ITextView.)
Top
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.HasFocusChanged Event

IEditorViewHasFocusChanged Event
Occurs when the HasFocus property value is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler HasFocusChanged
Event HasFocusChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.HighlightedResultSearchOptionsChanged Event

IEditorViewHighlightedResultSearchOptionsChanged Event
Occurs when the HighlightedResultSearchOptions property value is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler HighlightedResultSearchOptionsChanged
Event HighlightedResultSearchOptionsChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorView.SelectionChanged Event

IEditorViewSelectionChanged Event
Occurs after the selection is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<EditorViewSelectionEventArgs> SelectionChanged
Event SelectionChanged As EventHandler(Of EditorViewSelectionEventArgs)

Value

Type: SystemEventHandler EditorViewSelectionEventArgs
See Also

Reference

IEditorView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt Interface

IEditorViewIntelliPrompt Interface
Provides the base requirements for an object that can request IntelliPrompt within an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewIntelliPrompt
Public Interface IEditorViewIntelliPrompt

The IEditorViewIntelliPrompt type exposes the following members.

Methods
 | Name | Description
Public method | RequestAutoComplete | Performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
Public method | RequestCompletionSession | Displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
Public method | RequestInsertSnippetSession | Displays IntelliPrompt 'expansion' code snippet selection at the current offset.
Public method | RequestParameterInfoSession | Displays IntelliPrompt parameter info based on the current context.
Public method | RequestQuickInfoSession | Displays IntelliPrompt quick info based on the current context.
Public method | RequestSurroundWithSession | Displays IntelliPrompt 'surrounds with' code snippet selection at the current offset.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt Methods

IEditorViewIntelliPrompt Methods

The IEditorViewIntelliPrompt type exposes the following members.

Methods
 | Name | Description
Public method | RequestAutoComplete | Performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.
Public method | RequestCompletionSession | Displays a completion list if the language supports an IntelliPrompt completion session at the current offset.
Public method | RequestInsertSnippetSession | Displays IntelliPrompt 'expansion' code snippet selection at the current offset.
Public method | RequestParameterInfoSession | Displays IntelliPrompt parameter info based on the current context.
Public method | RequestQuickInfoSession | Displays IntelliPrompt quick info based on the current context.
Public method | RequestSurroundWithSession | Displays IntelliPrompt 'surrounds with' code snippet selection at the current offset.
Top
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt.RequestAutoComplete Method

IEditorViewIntelliPromptRequestAutoComplete Method
Performs an auto-complete if the language supports an IntelliPrompt completion session at the current offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RequestAutoComplete()
Sub RequestAutoComplete
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt.RequestCompletionSession Method

IEditorViewIntelliPromptRequestCompletionSession Method
Displays a completion list if the language supports an IntelliPrompt completion session at the current offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RequestCompletionSession()
Sub RequestCompletionSession
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt.RequestInsertSnippetSession Method

IEditorViewIntelliPromptRequestInsertSnippetSession Method
Displays IntelliPrompt 'expansion' code snippet selection at the current offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RequestInsertSnippetSession()
Sub RequestInsertSnippetSession
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt.RequestParameterInfoSession Method

IEditorViewIntelliPromptRequestParameterInfoSession Method
Displays IntelliPrompt parameter info based on the current context.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RequestParameterInfoSession()
Sub RequestParameterInfoSession
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt.RequestQuickInfoSession Method

IEditorViewIntelliPromptRequestQuickInfoSession Method
Displays IntelliPrompt quick info based on the current context.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RequestQuickInfoSession()
Sub RequestQuickInfoSession
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewIntelliPrompt.RequestSurroundWithSession Method

IEditorViewIntelliPromptRequestSurroundWithSession Method
Displays IntelliPrompt 'surrounds with' code snippet selection at the current offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void RequestSurroundWithSession()
Sub RequestSurroundWithSession
See Also

Reference

IEditorViewIntelliPrompt Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewKeyInputEventSink Interface

IEditorViewKeyInputEventSink Interface
Provides the base requirements for an object that can be notified of IEditorView keyboard input events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewKeyInputEventSink
Public Interface IEditorViewKeyInputEventSink

The IEditorViewKeyInputEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyKeyDown | Notifies when a key is pressed down while focus is in the specified IEditorView.
Public method | NotifyKeyUp | Notifies when a key is released while focus is in the specified IEditorView.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewKeyInputEventSink Methods

IEditorViewKeyInputEventSink Methods

The IEditorViewKeyInputEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyKeyDown | Notifies when a key is pressed down while focus is in the specified IEditorView.
Public method | NotifyKeyUp | Notifies when a key is released while focus is in the specified IEditorView.
Top
See Also

Reference

IEditorViewKeyInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewKeyInputEventSink.NotifyKeyDown Method

IEditorViewKeyInputEventSinkNotifyKeyDown Method
Notifies when a key is pressed down while focus is in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyKeyDown(
    IEditorView view,
    KeyRoutedEventArgs e
)
Sub NotifyKeyDown (
    view As IEditorView,
    e As KeyRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

IEditorViewKeyInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewKeyInputEventSink.NotifyKeyUp Method

IEditorViewKeyInputEventSinkNotifyKeyUp Method
Notifies when a key is released while focus is in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyKeyUp(
    IEditorView view,
    KeyRoutedEventArgs e
)
Sub NotifyKeyUp (
    view As IEditorView,
    e As KeyRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
The KeyEventArgs that contains the event data.
See Also

Reference

IEditorViewKeyInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine Interface

IEditorViewLine Interface
Provides the base requirements for a display line within an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewLine : ITextViewLine,
    ITextRangeProvider
Public Interface IEditorViewLine
    Inherits ITextViewLine, ITextRangeProvider

The IEditorViewLine type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the distance from the top of the line to the baseline of the text. (Inherited from ITextViewLine.)
Public property | Bounds | Gets the bounds of the line within the view. (Inherited from ITextViewLine.)
Public property | Change | Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass. (Inherited from ITextViewLine.)
Public property | CharacterCount | Gets the number of characters that are displayed on the line, accounting for any hidden text. (Inherited from ITextViewLine.)
Public property | DisplayLineNumber | Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view. (Inherited from ITextViewLine.)
Public property | EndOffset | Gets the offset at which the line ends. (Inherited from ITextViewLine.)
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | EndPosition | Gets the TextPosition at which the line ends. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceCharacterIndex | Gets the index of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceOffset | Gets the offset of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | HasHardLineBreak | Gets whether the the line has a hard line break. (Inherited from ITextViewLine.)
Public property | IndentAmount | Gets the number of columns that the first non-whitespace character is indented on the line. (Inherited from ITextViewLine.)
Public property | IsFirstLine | Gets whether the line contains the first offset of the document. (Inherited from ITextViewLine.)
Public property | IsLastLine | Gets whether the line contains the last offset of the document. (Inherited from ITextViewLine.)
Public property | IsPureWhitespace | Gets whether the line consists purely of whitespace characters. (Inherited from ITextViewLine.)
Public property | IsVirtualLine | Gets whether the line is a virtual line, past the end of the document.
Public property | NextLine | Gets the IEditorViewLine that is after this line.
Public property | PositionRange | Gets the TextPositionRange that contains the line. (Inherited from ITextViewLine.)
Public property | PreviousLine | Gets the IEditorViewLine that is before this line.
Public property | SavePointChangeType | Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point. (Inherited from ITextViewLine.)
Public property | Size | Gets the Size of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRange | Gets the TextSnapshotRange that indicates the snapshot range of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRangeIncludingLineTerminator | Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | StartOffset | Gets the offset at which the line starts. (Inherited from ITextViewLine.)
Public property | StartPosition | Gets the TextPosition at which the line starts. (Inherited from ITextViewLine.)
Public property | TabStopLevel | Gets or sets the tabstop level for the line.
Public property | Text | Gets or sets the text of the line, excluding the line terminator. (Inherited from ITextViewLine.)
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | TranslationY | Gets the amount by which the line was translated if the Change was Translated. (Inherited from ITextViewLine.)
Public property | View | Gets the IEditorView that this line is on.
Public property | Visibility | Gets a TextViewLineVisibility that indicates the visibility state of the line. (Inherited from ITextViewLine.)
Public property | WordWrapIndex | Gets the vertical index of the line as displayed for the related ITextSnapshotLine. (Inherited from ITextViewLine.)
Top
Methods
 | Name | Description
Public method | CharacterIndexToOffset | Returns the offset for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | CharacterIndexToPosition | Returns the TextPosition for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTagsTTag | Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text. (Inherited from ITextViewLine.)
Public method | IsVirtualCharacter | Returns whether the character at the specified index is a virtual character.
Public method | LocationToCharacterIndex | Returns the character index that contains the specified x-coordinate.
Public method | LocationToOffset | Returns the offset that contains the specified x-coordinate.
Public method | LocationToPosition(Double, LocationToPositionAlgorithm) | Returns the TextPosition that contains the specified x-coordinate.
Public method | LocationToPosition(Double, LocationToPositionAlgorithm, Boolean) | Returns the TextPosition that contains the specified x-coordinate.
Public method | OffsetToCharacterIndex | Returns the character index that represents the specified offset within the line. (Inherited from ITextViewLine.)
Public method | PositionToCharacterIndex | Returns the character index that represents the specified TextPosition within the line. (Inherited from ITextViewLine.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine Properties

IEditorViewLine Properties

The IEditorViewLine type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the distance from the top of the line to the baseline of the text. (Inherited from ITextViewLine.)
Public property | Bounds | Gets the bounds of the line within the view. (Inherited from ITextViewLine.)
Public property | Change | Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass. (Inherited from ITextViewLine.)
Public property | CharacterCount | Gets the number of characters that are displayed on the line, accounting for any hidden text. (Inherited from ITextViewLine.)
Public property | DisplayLineNumber | Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view. (Inherited from ITextViewLine.)
Public property | EndOffset | Gets the offset at which the line ends. (Inherited from ITextViewLine.)
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | EndPosition | Gets the TextPosition at which the line ends. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceCharacterIndex | Gets the index of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceOffset | Gets the offset of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | HasHardLineBreak | Gets whether the the line has a hard line break. (Inherited from ITextViewLine.)
Public property | IndentAmount | Gets the number of columns that the first non-whitespace character is indented on the line. (Inherited from ITextViewLine.)
Public property | IsFirstLine | Gets whether the line contains the first offset of the document. (Inherited from ITextViewLine.)
Public property | IsLastLine | Gets whether the line contains the last offset of the document. (Inherited from ITextViewLine.)
Public property | IsPureWhitespace | Gets whether the line consists purely of whitespace characters. (Inherited from ITextViewLine.)
Public property | IsVirtualLine | Gets whether the line is a virtual line, past the end of the document.
Public property | NextLine | Gets the IEditorViewLine that is after this line.
Public property | PositionRange | Gets the TextPositionRange that contains the line. (Inherited from ITextViewLine.)
Public property | PreviousLine | Gets the IEditorViewLine that is before this line.
Public property | SavePointChangeType | Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point. (Inherited from ITextViewLine.)
Public property | Size | Gets the Size of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRange | Gets the TextSnapshotRange that indicates the snapshot range of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRangeIncludingLineTerminator | Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | StartOffset | Gets the offset at which the line starts. (Inherited from ITextViewLine.)
Public property | StartPosition | Gets the TextPosition at which the line starts. (Inherited from ITextViewLine.)
Public property | TabStopLevel | Gets or sets the tabstop level for the line.
Public property | Text | Gets or sets the text of the line, excluding the line terminator. (Inherited from ITextViewLine.)
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | TranslationY | Gets the amount by which the line was translated if the Change was Translated. (Inherited from ITextViewLine.)
Public property | View | Gets the IEditorView that this line is on.
Public property | Visibility | Gets a TextViewLineVisibility that indicates the visibility state of the line. (Inherited from ITextViewLine.)
Public property | WordWrapIndex | Gets the vertical index of the line as displayed for the related ITextSnapshotLine. (Inherited from ITextViewLine.)
Top
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.IsVirtualLine Property

IEditorViewLineIsVirtualLine Property
Gets whether the line is a virtual line, past the end of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVirtualLine { get; }
ReadOnly Property IsVirtualLine As Boolean
    Get

Property Value

Type: Boolean
true if the line is a virtual line, past the end of the document; otherwise, false.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.NextLine Property

IEditorViewLineNextLine Property
Gets the IEditorViewLine that is after this line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine NextLine { get; }
ReadOnly Property NextLine As IEditorViewLine
    Get

Property Value

Type: IEditorViewLine
The IEditorViewLine that is after this line.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.PreviousLine Property

IEditorViewLinePreviousLine Property
Gets the IEditorViewLine that is before this line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine PreviousLine { get; }
ReadOnly Property PreviousLine As IEditorViewLine
    Get

Property Value

Type: IEditorViewLine
The IEditorViewLine that is before this line.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.TabStopLevel Property

IEditorViewLineTabStopLevel Property
Gets or sets the tabstop level for the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int TabStopLevel { get; set; }
Property TabStopLevel As Integer
    Get
    Set

Property Value

Type: Int32
The tabstop level for the line.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.View Property

IEditorViewLineView Property
Gets the IEditorView that this line is on.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorView View { get; }
ReadOnly Property View As IEditorView
    Get

Property Value

Type: IEditorView
The IEditorView that this line is on.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine Methods

IEditorViewLine Methods

The IEditorViewLine type exposes the following members.

Methods
 | Name | Description
Public method | CharacterIndexToOffset | Returns the offset for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | CharacterIndexToPosition | Returns the TextPosition for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTagsTTag | Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text. (Inherited from ITextViewLine.)
Public method | IsVirtualCharacter | Returns whether the character at the specified index is a virtual character.
Public method | LocationToCharacterIndex | Returns the character index that contains the specified x-coordinate.
Public method | LocationToOffset | Returns the offset that contains the specified x-coordinate.
Public method | LocationToPosition(Double, LocationToPositionAlgorithm) | Returns the TextPosition that contains the specified x-coordinate.
Public method | LocationToPosition(Double, LocationToPositionAlgorithm, Boolean) | Returns the TextPosition that contains the specified x-coordinate.
Public method | OffsetToCharacterIndex | Returns the character index that represents the specified offset within the line. (Inherited from ITextViewLine.)
Public method | PositionToCharacterIndex | Returns the character index that represents the specified TextPosition within the line. (Inherited from ITextViewLine.)
Top
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.IsVirtualCharacter Method

IEditorViewLineIsVirtualCharacter Method
Returns whether the character at the specified index is a virtual character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsVirtualCharacter(
    int characterIndex,
    bool lineTerminatorsAreVirtual
)
Function IsVirtualCharacter (
    characterIndex As Integer,
    lineTerminatorsAreVirtual As Boolean
) As Boolean

Parameters

characterIndex
Type: SystemInt32
The index of the character to examine.
lineTerminatorsAreVirtual
Type: SystemBoolean
Indicates whether to treat line terminators as virtual characters.

Return Value

Type: Boolean
true if the character at the specified index is a virtual character; otherwise, false.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.LocationToCharacterIndex Method

IEditorViewLineLocationToCharacterIndex Method
Returns the character index that contains the specified x-coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LocationToCharacterIndex(
    double horizontalLocation,
    LocationToPositionAlgorithm algorithm
)
Function LocationToCharacterIndex (
    horizontalLocation As Double,
    algorithm As LocationToPositionAlgorithm
) As Integer

Parameters

horizontalLocation
Type: SystemDouble
The x-coordinate for which to search.
algorithm
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm
The LocationToPositionAlgorithm to use for calculation.

Return Value

Type: Int32
The character index that contains the specified x-coordinate.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.LocationToOffset Method

IEditorViewLineLocationToOffset Method
Returns the offset that contains the specified x-coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LocationToOffset(
    double horizontalLocation,
    LocationToPositionAlgorithm algorithm
)
Function LocationToOffset (
    horizontalLocation As Double,
    algorithm As LocationToPositionAlgorithm
) As Integer

Parameters

horizontalLocation
Type: SystemDouble
The x-coordinate for which to search.
algorithm
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm
The LocationToPositionAlgorithm to use for calculation.

Return Value

Type: Int32
The offset that contains the specified x-coordinate.
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.LocationToPosition Method

IEditorViewLineLocationToPosition Method
Overload List
 | Name | Description
Public method | LocationToPosition(Double, LocationToPositionAlgorithm) | Returns the TextPosition that contains the specified x-coordinate.
Public method | LocationToPosition(Double, LocationToPositionAlgorithm, Boolean) | Returns the TextPosition that contains the specified x-coordinate.
Top
See Also

Reference

IEditorViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.LocationToPosition Method (Double, LocationToPositionAlgorithm)

IEditorViewLineLocationToPosition Method (Double, LocationToPositionAlgorithm)
Returns the TextPosition that contains the specified x-coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition LocationToPosition(
    double horizontalLocation,
    LocationToPositionAlgorithm algorithm
)
Function LocationToPosition (
    horizontalLocation As Double,
    algorithm As LocationToPositionAlgorithm
) As TextPosition

Parameters

horizontalLocation
Type: SystemDouble
The x-coordinate for which to search.
algorithm
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm
The LocationToPositionAlgorithm to use for calculation.

Return Value

Type: TextPosition
The TextPosition that contains the specified x-coordinate.
See Also

Reference

IEditorViewLine Interface
LocationToPosition Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLine.LocationToPosition Method (Double, LocationToPositionAlgorithm, Boolean)

IEditorViewLineLocationToPosition Method (Double, LocationToPositionAlgorithm, Boolean)
Returns the TextPosition that contains the specified x-coordinate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition LocationToPosition(
    double horizontalLocation,
    LocationToPositionAlgorithm algorithm,
    bool forceVirtualSpace
)
Function LocationToPosition (
    horizontalLocation As Double,
    algorithm As LocationToPositionAlgorithm,
    forceVirtualSpace As Boolean
) As TextPosition

Parameters

horizontalLocation
Type: SystemDouble
The x-coordinate for which to search.
algorithm
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm
The LocationToPositionAlgorithm to use for calculation.
forceVirtualSpace
Type: SystemBoolean
Whether to force virtual space to be used (for block selections).

Return Value

Type: TextPosition
The TextPosition that contains the specified x-coordinate.
See Also

Reference

IEditorViewLine Interface
LocationToPosition Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLineCollection Interface

IEditorViewLineCollection Interface
Provides the base requirements for a read-only collection of IEditorViewLine objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewLineCollection : IList<IEditorViewLine>,
    ICollection<IEditorViewLine>, IEnumerable<IEditorViewLine>, IEnumerable
Public Interface IEditorViewLineCollection
    Inherits IList(Of IEditorViewLine), ICollection(Of IEditorViewLine),
    IEnumerable(Of IEditorViewLine), IEnumerable

The IEditorViewLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IEditorViewLine .)
Public property | FullyVisibleCount | Gets the number of lines that are fully visible.
Public property | IsReadOnly | (Inherited from ICollection IEditorViewLine .)
Public property | Item | (Inherited from IList IEditorViewLine .)
Public property | SnapshotRange | Gets the TextSnapshotRange that contains the text range rendered with the view lines.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IEditorViewLine .)
Public method | Clear | (Inherited from ICollection IEditorViewLine .)
Public method | Contains | (Inherited from ICollection IEditorViewLine .)
Public method | CopyTo | (Inherited from ICollection IEditorViewLine .)
Public method | GetEnumerator | (Inherited from IEnumerable IEditorViewLine .)
Public method | GetMaximumWidth | Returns the maximum width of the lines in this collection.
Public method | IndexOf | (Inherited from IList IEditorViewLine .)
Public method | Insert | (Inherited from IList IEditorViewLine .)
Public method | Remove | (Inherited from ICollection IEditorViewLine .)
Public method | RemoveAt | (Inherited from IList IEditorViewLine .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorViewLine


IEditorViewLineCollection Properties

IEditorViewLineCollection Properties

The IEditorViewLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IEditorViewLine .)
Public property | FullyVisibleCount | Gets the number of lines that are fully visible.
Public property | IsReadOnly | (Inherited from ICollection IEditorViewLine .)
Public property | Item | (Inherited from IList IEditorViewLine .)
Public property | SnapshotRange | Gets the TextSnapshotRange that contains the text range rendered with the view lines.
Top
See Also

Reference

IEditorViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLineCollection.FullyVisibleCount Property

IEditorViewLineCollectionFullyVisibleCount Property
Gets the number of lines that are fully visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FullyVisibleCount { get; }
ReadOnly Property FullyVisibleCount As Integer
    Get

Property Value

Type: Int32
The number of lines that are fully visible.
See Also

Reference

IEditorViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLineCollection.SnapshotRange Property

IEditorViewLineCollectionSnapshotRange Property
Gets the TextSnapshotRange that contains the text range rendered with the view lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that contains the text range rendered with the view lines.
See Also

Reference

IEditorViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLineCollection Methods

IEditorViewLineCollection Methods

The IEditorViewLineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IEditorViewLine .)
Public method | Clear | (Inherited from ICollection IEditorViewLine .)
Public method | Contains | (Inherited from ICollection IEditorViewLine .)
Public method | CopyTo | (Inherited from ICollection IEditorViewLine .)
Public method | GetEnumerator | (Inherited from IEnumerable IEditorViewLine .)
Public method | GetMaximumWidth | Returns the maximum width of the lines in this collection.
Public method | IndexOf | (Inherited from IList IEditorViewLine .)
Public method | Insert | (Inherited from IList IEditorViewLine .)
Public method | Remove | (Inherited from ICollection IEditorViewLine .)
Public method | RemoveAt | (Inherited from IList IEditorViewLine .)
Top
See Also

Reference

IEditorViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewLineCollection.GetMaximumWidth Method

IEditorViewLineCollectionGetMaximumWidth Method
Returns the maximum width of the lines in this collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double GetMaximumWidth()
Function GetMaximumWidth As Double

Return Value

Type: Double
The maximum width of the lines in this collection.
See Also

Reference

IEditorViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink Interface

IEditorViewMouseInputEventSink Interface
Provides the base requirements for an object that can be notified of IEditorView mouse input events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewMouseInputEventSink
Public Interface IEditorViewMouseInputEventSink

The IEditorViewMouseInputEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyMouseDown | Occurs when a mouse button is pressed over the specified IEditorView.
Public method | NotifyMouseEnter | Occurs when the mouse enters the specified IEditorView.
Public method | NotifyMouseHover | Occurs when the mouse hovers over the specified IEditorView.
Public method | NotifyMouseLeave | Occurs when the mouse leaves the specified IEditorView.
Public method | NotifyMouseMove | Occurs when the mouse moves within the specified IEditorView.
Public method | NotifyMouseUp | Occurs when a mouse button is released over the specified IEditorView.
Public method | NotifyMouseWheel | Occurs when the mouse wheel is turned over the specified IEditorView.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink Methods

IEditorViewMouseInputEventSink Methods

The IEditorViewMouseInputEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyMouseDown | Occurs when a mouse button is pressed over the specified IEditorView.
Public method | NotifyMouseEnter | Occurs when the mouse enters the specified IEditorView.
Public method | NotifyMouseHover | Occurs when the mouse hovers over the specified IEditorView.
Public method | NotifyMouseLeave | Occurs when the mouse leaves the specified IEditorView.
Public method | NotifyMouseMove | Occurs when the mouse moves within the specified IEditorView.
Public method | NotifyMouseUp | Occurs when a mouse button is released over the specified IEditorView.
Public method | NotifyMouseWheel | Occurs when the mouse wheel is turned over the specified IEditorView.
Top
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseDown Method

IEditorViewMouseInputEventSinkNotifyMouseDown Method
Occurs when a mouse button is pressed over the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseDown(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseDown (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseEnter Method

IEditorViewMouseInputEventSinkNotifyMouseEnter Method
Occurs when the mouse enters the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseEnter(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseEnter (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseHover Method

IEditorViewMouseInputEventSinkNotifyMouseHover Method
Occurs when the mouse hovers over the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseHover(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseHover (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseLeave Method

IEditorViewMouseInputEventSinkNotifyMouseLeave Method
Occurs when the mouse leaves the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseLeave(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseLeave (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseMove Method

IEditorViewMouseInputEventSinkNotifyMouseMove Method
Occurs when the mouse moves within the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseMove(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseMove (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseUp Method

IEditorViewMouseInputEventSinkNotifyMouseUp Method
Occurs when a mouse button is released over the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseUp(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseUp (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewMouseInputEventSink.NotifyMouseWheel Method

IEditorViewMouseInputEventSinkNotifyMouseWheel Method
Occurs when the mouse wheel is turned over the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyMouseWheel(
    IEditorView view,
    PointerRoutedEventArgs e
)
Sub NotifyMouseWheel (
    view As IEditorView,
    e As PointerRoutedEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
The PointerRoutedEventArgs that contains the event data.
See Also

Reference

IEditorViewMouseInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller Interface

IEditorViewScroller Interface
Provides the base requirements for an object that can scroll an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewScroller
Public Interface IEditorViewScroller

The IEditorViewScroller type exposes the following members.

Methods
 | Name | Description
Public method | ScrollDown | Scrolls down a line.
Public method | ScrollIntoView | Ensures that the specified TextPosition is visible by scrolling it into view if necessary.
Public method | ScrollLeft | Scrolls left a column.
Public method | ScrollLineToVisibleBottom | Scrolls the current view line to the bottom of the view.
Public method | ScrollLineToVisibleMiddle | Scrolls the current view line to the middle of the view.
Public method | ScrollLineToVisibleTop | Scrolls the current view line to the top of the view.
Public method | ScrollPageDown | Scrolls down a page.
Public method | ScrollPageUp | Scrolls up a page.
Public method | ScrollRight | Scrolls right a column.
Public method | ScrollToCaret | Scrolls the view to the caret position.
Public method | ScrollToDocumentEnd | Scrolls to the end of the document.
Public method | ScrollToDocumentStart | Scrolls to the start of the document.
Public method | ScrollUp | Scrolls up a line.
Public method | ScrollVerticallyByLine | Scrolls the view vertically by the specified number of lines.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller Methods

IEditorViewScroller Methods

The IEditorViewScroller type exposes the following members.

Methods
 | Name | Description
Public method | ScrollDown | Scrolls down a line.
Public method | ScrollIntoView | Ensures that the specified TextPosition is visible by scrolling it into view if necessary.
Public method | ScrollLeft | Scrolls left a column.
Public method | ScrollLineToVisibleBottom | Scrolls the current view line to the bottom of the view.
Public method | ScrollLineToVisibleMiddle | Scrolls the current view line to the middle of the view.
Public method | ScrollLineToVisibleTop | Scrolls the current view line to the top of the view.
Public method | ScrollPageDown | Scrolls down a page.
Public method | ScrollPageUp | Scrolls up a page.
Public method | ScrollRight | Scrolls right a column.
Public method | ScrollToCaret | Scrolls the view to the caret position.
Public method | ScrollToDocumentEnd | Scrolls to the end of the document.
Public method | ScrollToDocumentStart | Scrolls to the start of the document.
Public method | ScrollUp | Scrolls up a line.
Public method | ScrollVerticallyByLine | Scrolls the view vertically by the specified number of lines.
Top
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollDown Method

IEditorViewScrollerScrollDown Method
Scrolls down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollDown()
Sub ScrollDown
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollIntoView Method

IEditorViewScrollerScrollIntoView Method
Ensures that the specified TextPosition is visible by scrolling it into view if necessary.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollIntoView(
    TextPosition position,
    bool scrollToVerticalMiddle
)
Sub ScrollIntoView (
    position As TextPosition,
    scrollToVerticalMiddle As Boolean
)

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to ensure is visible.
scrollToVerticalMiddle
Type: SystemBoolean
Whether to scroll to the vertical middle, if scrolling is necessary.
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollLeft Method

IEditorViewScrollerScrollLeft Method
Scrolls left a column.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollLeft()
Sub ScrollLeft
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollLineToVisibleBottom Method

IEditorViewScrollerScrollLineToVisibleBottom Method
Scrolls the current view line to the bottom of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollLineToVisibleBottom()
Sub ScrollLineToVisibleBottom
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollLineToVisibleMiddle Method

IEditorViewScrollerScrollLineToVisibleMiddle Method
Scrolls the current view line to the middle of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollLineToVisibleMiddle()
Sub ScrollLineToVisibleMiddle
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollLineToVisibleTop Method

IEditorViewScrollerScrollLineToVisibleTop Method
Scrolls the current view line to the top of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollLineToVisibleTop()
Sub ScrollLineToVisibleTop
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollPageDown Method

IEditorViewScrollerScrollPageDown Method
Scrolls down a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollPageDown()
Sub ScrollPageDown
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollPageUp Method

IEditorViewScrollerScrollPageUp Method
Scrolls up a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollPageUp()
Sub ScrollPageUp
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollRight Method

IEditorViewScrollerScrollRight Method
Scrolls right a column.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollRight()
Sub ScrollRight
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollToCaret Method

IEditorViewScrollerScrollToCaret Method
Scrolls the view to the caret position.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollToCaret()
Sub ScrollToCaret
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollToDocumentEnd Method

IEditorViewScrollerScrollToDocumentEnd Method
Scrolls to the end of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollToDocumentEnd()
Sub ScrollToDocumentEnd
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollToDocumentStart Method

IEditorViewScrollerScrollToDocumentStart Method
Scrolls to the start of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollToDocumentStart()
Sub ScrollToDocumentStart
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollUp Method

IEditorViewScrollerScrollUp Method
Scrolls up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollUp()
Sub ScrollUp
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewScroller.ScrollVerticallyByLine Method

IEditorViewScrollerScrollVerticallyByLine Method
Scrolls the view vertically by the specified number of lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ScrollVerticallyByLine(
    int lineDelta
)
Sub ScrollVerticallyByLine (
    lineDelta As Integer
)

Parameters

lineDelta
Type: SystemInt32
The number of view lines (can be negative) by which to scroll.
See Also

Reference

IEditorViewScroller Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher Interface

IEditorViewSearcher Interface
Provides the base requirements for an object that can perform find/replace and other search-related operations on an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewSearcher
Public Interface IEditorViewSearcher

The IEditorViewSearcher type exposes the following members.

Methods
 | Name | Description
Public method | FindAll | Performs a find all operation.
Public method | FindCurrentOrNext | Performs a find next operation that can possibly match at the current caret offset.
Public method | FindNext | Performs a find next operation.
Public method | FindNextIncremental | Performs an incremental search find next operation.
Public method | ReplaceAll | Performs a replace all operation.
Public method | ReplaceNext | Performs a replace next operation.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher Methods

IEditorViewSearcher Methods

The IEditorViewSearcher type exposes the following members.

Methods
 | Name | Description
Public method | FindAll | Performs a find all operation.
Public method | FindCurrentOrNext | Performs a find next operation that can possibly match at the current caret offset.
Public method | FindNext | Performs a find next operation.
Public method | FindNextIncremental | Performs an incremental search find next operation.
Public method | ReplaceAll | Performs a replace all operation.
Public method | ReplaceNext | Performs a replace next operation.
Top
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher.FindAll Method

IEditorViewSearcherFindAll Method
Performs a find all operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindAll(
    IEditorSearchOptions options
)
Function FindAll (
    options As IEditorSearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorSearchOptions
The IEditorSearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher.FindCurrentOrNext Method

IEditorViewSearcherFindCurrentOrNext Method
Performs a find next operation that can possibly match at the current caret offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindCurrentOrNext(
    IEditorSearchOptions options
)
Function FindCurrentOrNext (
    options As IEditorSearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorSearchOptions
The IEditorSearchOptions to use.

Return Value

Type: ISearchResultSet
An ISearchResultSet that specifies the result of the operation.
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher.FindNext Method

IEditorViewSearcherFindNext Method
Performs a find next operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindNext(
    IEditorSearchOptions options
)
Function FindNext (
    options As IEditorSearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorSearchOptions
The IEditorSearchOptions to use.

Return Value

Type: ISearchResultSet
A ISearchResultSet that specifies the result of the operation.
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher.FindNextIncremental Method

IEditorViewSearcherFindNextIncremental Method
Performs an incremental search find next operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet FindNextIncremental(
    bool searchUp
)
Function FindNextIncremental (
    searchUp As Boolean
) As ISearchResultSet

Parameters

searchUp
Type: SystemBoolean
Whether to search upwards.

Return Value

Type: ISearchResultSet
A ISearchResultSet that specifies the result of the operation.
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher.ReplaceAll Method

IEditorViewSearcherReplaceAll Method
Performs a replace all operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceAll(
    IEditorSearchOptions options
)
Function ReplaceAll (
    options As IEditorSearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorSearchOptions
The IEditorSearchOptions to use.

Return Value

Type: ISearchResultSet
A ISearchResultSet that specifies the result of the operation.
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSearcher.ReplaceNext Method

IEditorViewSearcherReplaceNext Method
Performs a replace next operation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ISearchResultSet ReplaceNext(
    IEditorSearchOptions options
)
Function ReplaceNext (
    options As IEditorSearchOptions
) As ISearchResultSet

Parameters

options
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorSearchOptions
The IEditorSearchOptions to use.

Return Value

Type: ISearchResultSet
A ISearchResultSet that specifies the result of the operation.
See Also

Reference

IEditorViewSearcher Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection Interface

IEditorViewSelection Interface
Provides the base requirements for an object that tracks the selection of an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewSelection
Public Interface IEditorViewSelection

The IEditorViewSelection type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets or sets the end offset of the selection.
Public property | EndPosition | Gets or sets the TextPosition that represents the end of the selection range.
Public property | EndSnapshotOffset | Gets the TextSnapshotOffset that specifies the end offset of the selection.
Public property | FirstOffset | Gets the first offset in the selection.
Public property | FirstPosition | Gets the first TextPosition in the selection.
Public property | IsNormalized | Gets whether the selection is normalized (StartPosition occurs at or before the EndPosition).
Public property | IsReadOnly | Get whether any character in the selection is flagged as read-only.
Public property | IsZeroLength | Gets whether the selection has a zero length.
Public property | LastOffset | Gets the last offset in the selection.
Public property | LastPosition | Gets the last TextPosition in the selection.
Public property | Length | Gets the absolute offset length of the selection.
Public property | Mode | Gets a SelectionModes that indicates the selection mode currently in use.
Public property | PositionRange | Gets or sets the TextPositionRange that describes the start and end TextPosition of the selection.
Public property | PreferredHorizontalLocation | Gets the preferred horizontal location.
Public property | SnapshotRange | Gets the TextSnapshotRange that specifies the offset range of the selection.
Public property | StartOffset | Gets or sets the start offset of the selection.
Public property | StartPosition | Gets or sets the TextPosition that represents the start of the selection range.
Public property | StartSnapshotOffset | Gets the TextSnapshotOffset that specifies the start offset of the selection.
Public property | TextRange | Gets or sets the TextRange that specifies the offset range of the selection.
Top
Methods
 | Name | Description
Public method | CaptureState | Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.
Public method | CaptureState(TextRangeTrackingModes) | Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.
Public method | CodeBlockContract | Contracts the selection to encompass a range previously expanded by a call to CodeBlockExpand.
Public method | CodeBlockExpand | Expands the selection to encompass a larger range based on surrounding code blocks.
Public method | Collapse | Collapses the selection.
Public method | CollapseLeft | Collapses the selection to the left.
Public method | CollapseRight | Collapse the selection to the right.
Public method | Contains(Int32) | Returns whether the selection contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the selection contains the specified TextPosition.
Public method | GetCharacterIndexRanges | Returns an array of character index Range objects for characters contained on each view line in the selection.
Public method | GetTextRanges | Returns an array of TextRange objects that specify the ranges of text that is selected.
Public method | GetTextRanges(Int32) | Returns an array of TextRange objects that specify the ranges of text that is selected.
Public method | MoveDown | Moves the caret down a line.
Public method | MoveLeft | Moves the caret left a character.
Public method | MovePageDown | Moves the caret down a page.
Public method | MovePageUp | Moves the caret up a page.
Public method | MoveRight | Moves the caret right a character.
Public method | MoveToDocumentEnd | Moves the caret to the end of the document.
Public method | MoveToDocumentStart | Moves the caret to the start of the document.
Public method | MoveToLineEnd | Moves the caret to the end of the current line.
Public method | MoveToLineStart | Moves the caret to the start of the current line.
Public method | MoveToLineStartAfterIndentation | Moves the caret to the first non-whitespace character on the current view line.
Public method | MoveToMatchingBracket | Moves the caret to the matching bracket.
Public method | MoveToNextLineStartAfterIndentation | Moves the caret to the first non-whitespace character on the next view line.
Public method | MoveToNextWord | Moves the caret to the next word.
Public method | MoveToPreviousLineStartAfterIndentation | Moves the caret to the first non-whitespace character on the previous view line.
Public method | MoveToPreviousWord | Moves the caret to the previous word.
Public method | MoveToVisibleBottom | Moves the caret to the bottom of the view.
Public method | MoveToVisibleTop | Moves the caret to the top of the view.
Public method | MoveUp | Moves the caret up a line.
Public method | SelectAll | Selects all of the text.
Public method | SelectBlockDown | Block selects down a line.
Public method | SelectBlockLeft | Block selects left a character.
Public method | SelectBlockRight | Block selects right a character.
Public method | SelectBlockToNextWord | Block selects to the next word.
Public method | SelectBlockToPreviousWord | Block selects to the previous word.
Public method | SelectBlockUp | Block selects up a line.
Public method | SelectDown | Selects down a line.
Public method | SelectLeft | Selects left a character.
Public method | SelectPageDown | Selects down a page.
Public method | SelectPageUp | Selects up a page.
Public method | SelectRange(TextPositionRange) | Selects a range of text using a TextPositionRange.
Public method | SelectRange(TextRange) | Selects a range of text using a TextRange.
Public method | SelectRange(Int32, Int32) | Selects a range of text using an offset and length.
Public method | SelectRange(TextPosition, TextPosition) | Selects a range of text using a pair of TextPosition objects.
Public method | SelectRange(TextPositionRange, SelectionModes) | Selects a range of text using a TextPositionRange.
Public method | SelectRange(TextRange, SelectionModes) | Selects a range of text using a TextRange.
Public method | SelectRange(Int32, Int32, SelectionModes) | Selects a range of text using an offset and length.
Public method | SelectRange(TextPosition, TextPosition, SelectionModes) | Selects a range of text using a pair of TextPosition objects.
Public method | SelectRange(TextPositionRange, SelectionModes, Boolean) | Selects a range of text using a TextPositionRange, and optionally updates the PreferredHorizontalLocation.
Public method | SelectRight | Selects right a character.
Public method | SelectToDocumentEnd | Selects to the end of the document.
Public method | SelectToDocumentStart | Selects to the start of the document.
Public method | SelectToLineEnd | Selects to the end of the current line.
Public method | SelectToLineStart | Selects to the start of the current line.
Public method | SelectToLineStartAfterIndentation | Selects to the first non-whitespace character on the current view line.
Public method | SelectToMatchingBracket | Selects to the matching bracket.
Public method | SelectToNextWord | Selects to the next word.
Public method | SelectToPreviousWord | Selects to the previous word.
Public method | SelectToVisibleBottom | Selects to the bottom of the view.
Public method | SelectToVisibleTop | Selects to the top of the view.
Public method | SelectUp | Selects up a line.
Public method | SelectWord | Selects the current word.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection Properties

IEditorViewSelection Properties

The IEditorViewSelection type exposes the following members.

Properties
 | Name | Description
Public property | EndOffset | Gets or sets the end offset of the selection.
Public property | EndPosition | Gets or sets the TextPosition that represents the end of the selection range.
Public property | EndSnapshotOffset | Gets the TextSnapshotOffset that specifies the end offset of the selection.
Public property | FirstOffset | Gets the first offset in the selection.
Public property | FirstPosition | Gets the first TextPosition in the selection.
Public property | IsNormalized | Gets whether the selection is normalized (StartPosition occurs at or before the EndPosition).
Public property | IsReadOnly | Get whether any character in the selection is flagged as read-only.
Public property | IsZeroLength | Gets whether the selection has a zero length.
Public property | LastOffset | Gets the last offset in the selection.
Public property | LastPosition | Gets the last TextPosition in the selection.
Public property | Length | Gets the absolute offset length of the selection.
Public property | Mode | Gets a SelectionModes that indicates the selection mode currently in use.
Public property | PositionRange | Gets or sets the TextPositionRange that describes the start and end TextPosition of the selection.
Public property | PreferredHorizontalLocation | Gets the preferred horizontal location.
Public property | SnapshotRange | Gets the TextSnapshotRange that specifies the offset range of the selection.
Public property | StartOffset | Gets or sets the start offset of the selection.
Public property | StartPosition | Gets or sets the TextPosition that represents the start of the selection range.
Public property | StartSnapshotOffset | Gets the TextSnapshotOffset that specifies the start offset of the selection.
Public property | TextRange | Gets or sets the TextRange that specifies the offset range of the selection.
Top
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.EndOffset Property

IEditorViewSelectionEndOffset Property
Gets or sets the end offset of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffset { get; set; }
Property EndOffset As Integer
    Get
    Set

Property Value

Type: Int32
The end offset of the selection.
Remarks
The end offset may occur before the start offset if the selection is not normalized. The IsNormalized property indicates if the selection is normalized. To get the normalized first offset in the selection, use the FirstOffset property. To get the normalized last offset in the selection, use the LastOffset property.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.EndPosition Property

IEditorViewSelectionEndPosition Property
Gets or sets the TextPosition that represents the end of the selection range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition EndPosition { get; set; }
Property EndPosition As TextPosition
    Get
    Set

Property Value

Type: TextPosition
The TextPosition that represents the end of the selection range.
Remarks
This property's value comes from the end TextPosition of the PositionRange property. The EndPosition may occur before the StartPosition if the selection is not normalized. The IsNormalized property indicates if the selection is normalized. To get the normalized first TextPosition in the selection, use the FirstPosition property. To get the normalized last TextPosition in the selection, use the LastPosition property.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.EndSnapshotOffset Property

IEditorViewSelectionEndSnapshotOffset Property
Gets the TextSnapshotOffset that specifies the end offset of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotOffset EndSnapshotOffset { get; }
ReadOnly Property EndSnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset that specifies the end offset of the selection.
Remarks
The start offset may occur after the end offset if the selection is not normalized. The IsNormalized property indicates if the selection is normalized.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.FirstOffset Property

IEditorViewSelectionFirstOffset Property
Gets the first offset in the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FirstOffset { get; }
ReadOnly Property FirstOffset As Integer
    Get

Property Value

Type: Int32
The first offset in the selection.
Remarks
This property returns either the StartOffset or EndOffset property, whichever comes first.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.FirstPosition Property

IEditorViewSelectionFirstPosition Property
Gets the first TextPosition in the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition FirstPosition { get; }
ReadOnly Property FirstPosition As TextPosition
    Get

Property Value

Type: TextPosition
The first TextPosition in the selection.
Remarks
This property returns either the StartPosition or EndPosition property, whichever comes first.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.IsNormalized Property

IEditorViewSelectionIsNormalized Property
Gets whether the selection is normalized (StartPosition occurs at or before the EndPosition).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsNormalized { get; }
ReadOnly Property IsNormalized As Boolean
    Get

Property Value

Type: Boolean
true if the selection is normalized; otherwise, false.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.IsReadOnly Property

IEditorViewSelectionIsReadOnly Property
Get whether any character in the selection is flagged as read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Return Value

Type: Boolean
true if any character in the selection is flagged as read-only; otherwise, false.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.IsZeroLength Property

IEditorViewSelectionIsZeroLength Property
Gets whether the selection has a zero length.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsZeroLength { get; }
ReadOnly Property IsZeroLength As Boolean
    Get

Property Value

Type: Boolean
true if the selection has a zero length; otherwise, false.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.LastOffset Property

IEditorViewSelectionLastOffset Property
Gets the last offset in the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int LastOffset { get; }
ReadOnly Property LastOffset As Integer
    Get

Property Value

Type: Int32
The last offset in the selection.
Remarks
This property returns either the StartOffset or EndOffset property, whichever comes last.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.LastPosition Property

IEditorViewSelectionLastPosition Property
Gets the last TextPosition in the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition LastPosition { get; }
ReadOnly Property LastPosition As TextPosition
    Get

Property Value

Type: TextPosition
The last TextPosition in the selection.
Remarks
This property returns either the StartPosition or EndPosition property, whichever comes last.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.Length Property

IEditorViewSelectionLength Property
Gets the absolute offset length of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32
The absolute offset length of the selection.
Remarks
This value is always positive.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.Mode Property

IEditorViewSelectionMode Property
Gets a SelectionModes that indicates the selection mode currently in use.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SelectionModes Mode { get; }
ReadOnly Property Mode As SelectionModes
    Get

Property Value

Type: SelectionModes
A SelectionModes that indicates the selection mode currently in use.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.PositionRange Property

IEditorViewSelectionPositionRange Property
Gets or sets the TextPositionRange that describes the start and end TextPosition of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; set; }
Property PositionRange As TextPositionRange
    Get
    Set

Property Value

Type: TextPositionRange
The TextPositionRange that describes the start and end TextPosition of the selection.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.PreferredHorizontalLocation Property

IEditorViewSelectionPreferredHorizontalLocation Property
Gets the preferred horizontal location.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double PreferredHorizontalLocation { get; }
ReadOnly Property PreferredHorizontalLocation As Double
    Get

Property Value

Type: Double
The preferred horizontal location.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SnapshotRange Property

IEditorViewSelectionSnapshotRange Property
Gets the TextSnapshotRange that specifies the offset range of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that specifies the offset range of the selection.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.StartOffset Property

IEditorViewSelectionStartOffset Property
Gets or sets the start offset of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; set; }
Property StartOffset As Integer
    Get
    Set

Property Value

Type: Int32
The start offset of the selection.
Remarks
The start offset may occur after the end offset if the selection is not normalized. The IsNormalized property indicates if the selection is normalized. To get the normalized first offset in the selection, use the FirstOffset property. To get the normalized last offset in the selection, use the LastOffset property.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.StartPosition Property

IEditorViewSelectionStartPosition Property
Gets or sets the TextPosition that represents the start of the selection range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition StartPosition { get; set; }
Property StartPosition As TextPosition
    Get
    Set

Property Value

Type: TextPosition
The TextPosition that represents the start of the selection range.
Remarks
This property's value comes from the start TextPosition of the PositionRange property. The StartPosition may occur after the EndPosition if the selection is not normalized. The IsNormalized property indicates if the selection is normalized. To get the normalized first TextPosition in the selection, use the FirstPosition property. To get the normalized last TextPosition in the selection, use the LastPosition property.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.StartSnapshotOffset Property

IEditorViewSelectionStartSnapshotOffset Property
Gets the TextSnapshotOffset that specifies the start offset of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotOffset StartSnapshotOffset { get; }
ReadOnly Property StartSnapshotOffset As TextSnapshotOffset
    Get

Property Value

Type: TextSnapshotOffset
The TextSnapshotOffset that specifies the start offset of the selection.
Remarks
The start offset may occur after the end offset if the selection is not normalized. The IsNormalized property indicates if the selection is normalized.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.TextRange Property

IEditorViewSelectionTextRange Property
Gets or sets the TextRange that specifies the offset range of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRange { get; set; }
Property TextRange As TextRange
    Get
    Set

Property Value

Type: TextRange
The TextRange that specifies the offset range of the selection.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection Methods

IEditorViewSelection Methods

The IEditorViewSelection type exposes the following members.

Methods
 | Name | Description
Public method | CaptureState | Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.
Public method | CaptureState(TextRangeTrackingModes) | Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.
Public method | CodeBlockContract | Contracts the selection to encompass a range previously expanded by a call to CodeBlockExpand.
Public method | CodeBlockExpand | Expands the selection to encompass a larger range based on surrounding code blocks.
Public method | Collapse | Collapses the selection.
Public method | CollapseLeft | Collapses the selection to the left.
Public method | CollapseRight | Collapse the selection to the right.
Public method | Contains(Int32) | Returns whether the selection contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the selection contains the specified TextPosition.
Public method | GetCharacterIndexRanges | Returns an array of character index Range objects for characters contained on each view line in the selection.
Public method | GetTextRanges | Returns an array of TextRange objects that specify the ranges of text that is selected.
Public method | GetTextRanges(Int32) | Returns an array of TextRange objects that specify the ranges of text that is selected.
Public method | MoveDown | Moves the caret down a line.
Public method | MoveLeft | Moves the caret left a character.
Public method | MovePageDown | Moves the caret down a page.
Public method | MovePageUp | Moves the caret up a page.
Public method | MoveRight | Moves the caret right a character.
Public method | MoveToDocumentEnd | Moves the caret to the end of the document.
Public method | MoveToDocumentStart | Moves the caret to the start of the document.
Public method | MoveToLineEnd | Moves the caret to the end of the current line.
Public method | MoveToLineStart | Moves the caret to the start of the current line.
Public method | MoveToLineStartAfterIndentation | Moves the caret to the first non-whitespace character on the current view line.
Public method | MoveToMatchingBracket | Moves the caret to the matching bracket.
Public method | MoveToNextLineStartAfterIndentation | Moves the caret to the first non-whitespace character on the next view line.
Public method | MoveToNextWord | Moves the caret to the next word.
Public method | MoveToPreviousLineStartAfterIndentation | Moves the caret to the first non-whitespace character on the previous view line.
Public method | MoveToPreviousWord | Moves the caret to the previous word.
Public method | MoveToVisibleBottom | Moves the caret to the bottom of the view.
Public method | MoveToVisibleTop | Moves the caret to the top of the view.
Public method | MoveUp | Moves the caret up a line.
Public method | SelectAll | Selects all of the text.
Public method | SelectBlockDown | Block selects down a line.
Public method | SelectBlockLeft | Block selects left a character.
Public method | SelectBlockRight | Block selects right a character.
Public method | SelectBlockToNextWord | Block selects to the next word.
Public method | SelectBlockToPreviousWord | Block selects to the previous word.
Public method | SelectBlockUp | Block selects up a line.
Public method | SelectDown | Selects down a line.
Public method | SelectLeft | Selects left a character.
Public method | SelectPageDown | Selects down a page.
Public method | SelectPageUp | Selects up a page.
Public method | SelectRange(TextPositionRange) | Selects a range of text using a TextPositionRange.
Public method | SelectRange(TextRange) | Selects a range of text using a TextRange.
Public method | SelectRange(Int32, Int32) | Selects a range of text using an offset and length.
Public method | SelectRange(TextPosition, TextPosition) | Selects a range of text using a pair of TextPosition objects.
Public method | SelectRange(TextPositionRange, SelectionModes) | Selects a range of text using a TextPositionRange.
Public method | SelectRange(TextRange, SelectionModes) | Selects a range of text using a TextRange.
Public method | SelectRange(Int32, Int32, SelectionModes) | Selects a range of text using an offset and length.
Public method | SelectRange(TextPosition, TextPosition, SelectionModes) | Selects a range of text using a pair of TextPosition objects.
Public method | SelectRange(TextPositionRange, SelectionModes, Boolean) | Selects a range of text using a TextPositionRange, and optionally updates the PreferredHorizontalLocation.
Public method | SelectRight | Selects right a character.
Public method | SelectToDocumentEnd | Selects to the end of the document.
Public method | SelectToDocumentStart | Selects to the start of the document.
Public method | SelectToLineEnd | Selects to the end of the current line.
Public method | SelectToLineStart | Selects to the start of the current line.
Public method | SelectToLineStartAfterIndentation | Selects to the first non-whitespace character on the current view line.
Public method | SelectToMatchingBracket | Selects to the matching bracket.
Public method | SelectToNextWord | Selects to the next word.
Public method | SelectToPreviousWord | Selects to the previous word.
Public method | SelectToVisibleBottom | Selects to the bottom of the view.
Public method | SelectToVisibleTop | Selects to the top of the view.
Public method | SelectUp | Selects up a line.
Public method | SelectWord | Selects the current word.
Top
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CaptureState Method

IEditorViewSelectionCaptureState Method
Overload List
 | Name | Description
Public method | CaptureState | Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.
Public method | CaptureState(TextRangeTrackingModes) | Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.
Top
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CaptureState Method

IEditorViewSelectionCaptureState Method
Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewSelectionState CaptureState()
Function CaptureState As IEditorViewSelectionState

Return Value

Type: IEditorViewSelectionState
An IEditorViewSelectionState that represents the current selection state.
Remarks
When capturing the selection state, the future restoration should be performed immediately after any programmatic text changes that are made following the capture.
See Also

Reference

IEditorViewSelection Interface
CaptureState Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CaptureState Method (TextRangeTrackingModes)

IEditorViewSelectionCaptureState Method (TextRangeTrackingModes)
Captures the current IEditorViewSelectionState and allows it to be restored later for a different snapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewSelectionState CaptureState(
    TextRangeTrackingModes trackingModes
)
Function CaptureState (
    trackingModes As TextRangeTrackingModes
) As IEditorViewSelectionState

Parameters

trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
The TextRangeTrackingModes to use for translating between snapshots.

Return Value

Type: IEditorViewSelectionState
An IEditorViewSelectionState that represents the current selection state.
Remarks
When capturing the selection state, the future restoration should be performed immediately after any programmatic text changes that are made following the capture.
See Also

Reference

IEditorViewSelection Interface
CaptureState Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CodeBlockContract Method

IEditorViewSelectionCodeBlockContract Method
Contracts the selection to encompass a range previously expanded by a call to CodeBlockExpand.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CodeBlockContract()
Function CodeBlockContract As Boolean

Return Value

Type: Boolean
true of selection was contracted; otherwise, false.
Remarks
This method iterates backward through the selection history produced by calls to CodeBlockExpand. The code block selection history resets after any other selection or text changes.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CodeBlockExpand Method

IEditorViewSelectionCodeBlockExpand Method
Expands the selection to encompass a larger range based on surrounding code blocks.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CodeBlockExpand()
Function CodeBlockExpand As Boolean

Return Value

Type: Boolean
true of selection was expanded; otherwise, false.
Remarks
Syntax languages can implement an ICodeBlockFinder service to support this feature.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.Collapse Method

IEditorViewSelectionCollapse Method
Collapses the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Collapse()
Sub Collapse
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CollapseLeft Method

IEditorViewSelectionCollapseLeft Method
Collapses the selection to the left.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CollapseLeft()
Sub CollapseLeft
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.CollapseRight Method

IEditorViewSelectionCollapseRight Method
Collapse the selection to the right.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CollapseRight()
Sub CollapseRight
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.Contains Method

IEditorViewSelectionContains Method
Overload List
 | Name | Description
Public method | Contains(Int32) | Returns whether the selection contains the specified offset.
Public method | Contains(TextPosition) | Returns whether the selection contains the specified TextPosition.
Top
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.Contains Method (Int32)

IEditorViewSelectionContains Method (Int32)
Returns whether the selection contains the specified offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    int offset
)
Function Contains (
    offset As Integer
) As Boolean

Parameters

offset
Type: SystemInt32
The offset to check.

Return Value

Type: Boolean
true if the selection contains the specified offset; otherwise false.
See Also

Reference

IEditorViewSelection Interface
Contains Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.Contains Method (TextPosition)

IEditorViewSelectionContains Method (TextPosition)
Returns whether the selection contains the specified TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    TextPosition position
)
Function Contains (
    position As TextPosition
) As Boolean

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition to check.

Return Value

Type: Boolean
true if the selection contains the specified TextPosition; otherwise false.
See Also

Reference

IEditorViewSelection Interface
Contains Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.GetCharacterIndexRanges Method

IEditorViewSelectionGetCharacterIndexRanges Method
Returns an array of character index Range objects for characters contained on each view line in the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Range[] GetCharacterIndexRanges(
    bool allowWholeLines,
    int minimumLines
)
Function GetCharacterIndexRanges (
    allowWholeLines As Boolean,
    minimumLines As Integer
) As Range()

Parameters

allowWholeLines
Type: SystemBoolean
Whether to allow whole line ranges if the x-coordinate range is empty, optionally for block selections. For continuous stream selections, pass false.
minimumLines
Type: SystemInt32
The minimum number of lines to return, used for block selections. For continuous stream selections, pass 1.

Return Value

Type: Range
An array of character index Range objects for characters contained on each view line in the selection.
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.GetTextRanges Method

IEditorViewSelectionGetTextRanges Method
Overload List
 | Name | Description
Public method | GetTextRanges | Returns an array of TextRange objects that specify the ranges of text that is selected.
Public method | GetTextRanges(Int32) | Returns an array of TextRange objects that specify the ranges of text that is selected.
Top
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.GetTextRanges Method

IEditorViewSelectionGetTextRanges Method
Returns an array of TextRange objects that specify the ranges of text that is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange[] GetTextRanges()
Function GetTextRanges As TextRange()

Return Value

Type: TextRange
An array of TextRange objects that specify the ranges of text that is selected.
Remarks
Normally a single TextRange is returned. However in the case of block selections, more than one TextRange can be returned.
See Also

Reference

IEditorViewSelection Interface
GetTextRanges Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.GetTextRanges Method (Int32)

IEditorViewSelectionGetTextRanges Method (Int32)
Returns an array of TextRange objects that specify the ranges of text that is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange[] GetTextRanges(
    int minimumLines
)
Function GetTextRanges (
    minimumLines As Integer
) As TextRange()

Parameters

minimumLines
Type: SystemInt32
The minimum number of lines to return when the selection is a block selection.

Return Value

Type: TextRange
An array of TextRange objects that specify the ranges of text that is selected.
Remarks
Normally a single TextRange is returned. However in the case of block selections, more than one TextRange can be returned.
See Also

Reference

IEditorViewSelection Interface
GetTextRanges Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveDown Method

IEditorViewSelectionMoveDown Method
Moves the caret down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveDown()
Sub MoveDown
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveLeft Method

IEditorViewSelectionMoveLeft Method
Moves the caret left a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveLeft()
Sub MoveLeft
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MovePageDown Method

IEditorViewSelectionMovePageDown Method
Moves the caret down a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MovePageDown()
Sub MovePageDown
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MovePageUp Method

IEditorViewSelectionMovePageUp Method
Moves the caret up a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MovePageUp()
Sub MovePageUp
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveRight Method

IEditorViewSelectionMoveRight Method
Moves the caret right a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveRight()
Sub MoveRight
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToDocumentEnd Method

IEditorViewSelectionMoveToDocumentEnd Method
Moves the caret to the end of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToDocumentEnd()
Sub MoveToDocumentEnd
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToDocumentStart Method

IEditorViewSelectionMoveToDocumentStart Method
Moves the caret to the start of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToDocumentStart()
Sub MoveToDocumentStart
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToLineEnd Method

IEditorViewSelectionMoveToLineEnd Method
Moves the caret to the end of the current line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToLineEnd()
Sub MoveToLineEnd
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToLineStart Method

IEditorViewSelectionMoveToLineStart Method
Moves the caret to the start of the current line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToLineStart()
Sub MoveToLineStart
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToLineStartAfterIndentation Method

IEditorViewSelectionMoveToLineStartAfterIndentation Method
Moves the caret to the first non-whitespace character on the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToLineStartAfterIndentation()
Sub MoveToLineStartAfterIndentation
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToMatchingBracket Method

IEditorViewSelectionMoveToMatchingBracket Method
Moves the caret to the matching bracket.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToMatchingBracket()
Sub MoveToMatchingBracket
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToNextLineStartAfterIndentation Method

IEditorViewSelectionMoveToNextLineStartAfterIndentation Method
Moves the caret to the first non-whitespace character on the next view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToNextLineStartAfterIndentation()
Sub MoveToNextLineStartAfterIndentation
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToNextWord Method

IEditorViewSelectionMoveToNextWord Method
Moves the caret to the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToNextWord()
Sub MoveToNextWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToPreviousLineStartAfterIndentation Method

IEditorViewSelectionMoveToPreviousLineStartAfterIndentation Method
Moves the caret to the first non-whitespace character on the previous view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToPreviousLineStartAfterIndentation()
Sub MoveToPreviousLineStartAfterIndentation
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToPreviousWord Method

IEditorViewSelectionMoveToPreviousWord Method
Moves the caret to the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToPreviousWord()
Sub MoveToPreviousWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToVisibleBottom Method

IEditorViewSelectionMoveToVisibleBottom Method
Moves the caret to the bottom of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToVisibleBottom()
Sub MoveToVisibleBottom
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveToVisibleTop Method

IEditorViewSelectionMoveToVisibleTop Method
Moves the caret to the top of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveToVisibleTop()
Sub MoveToVisibleTop
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.MoveUp Method

IEditorViewSelectionMoveUp Method
Moves the caret up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveUp()
Sub MoveUp
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectAll Method

IEditorViewSelectionSelectAll Method
Selects all of the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectAll()
Sub SelectAll
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectBlockDown Method

IEditorViewSelectionSelectBlockDown Method
Block selects down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectBlockDown()
Sub SelectBlockDown
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectBlockLeft Method

IEditorViewSelectionSelectBlockLeft Method
Block selects left a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectBlockLeft()
Sub SelectBlockLeft
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectBlockRight Method

IEditorViewSelectionSelectBlockRight Method
Block selects right a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectBlockRight()
Sub SelectBlockRight
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectBlockToNextWord Method

IEditorViewSelectionSelectBlockToNextWord Method
Block selects to the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectBlockToNextWord()
Sub SelectBlockToNextWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectBlockToPreviousWord Method

IEditorViewSelectionSelectBlockToPreviousWord Method
Block selects to the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectBlockToPreviousWord()
Sub SelectBlockToPreviousWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectBlockUp Method

IEditorViewSelectionSelectBlockUp Method
Block selects up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectBlockUp()
Sub SelectBlockUp
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectDown Method

IEditorViewSelectionSelectDown Method
Selects down a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectDown()
Sub SelectDown
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectLeft Method

IEditorViewSelectionSelectLeft Method
Selects left a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectLeft()
Sub SelectLeft
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectPageDown Method

IEditorViewSelectionSelectPageDown Method
Selects down a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectPageDown()
Sub SelectPageDown
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectPageUp Method

IEditorViewSelectionSelectPageUp Method
Selects up a page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectPageUp()
Sub SelectPageUp
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method

IEditorViewSelectionSelectRange Method
Overload List
 | Name | Description
Public method | SelectRange(TextPositionRange) | Selects a range of text using a TextPositionRange.
Public method | SelectRange(TextRange) | Selects a range of text using a TextRange.
Public method | SelectRange(Int32, Int32) | Selects a range of text using an offset and length.
Public method | SelectRange(TextPosition, TextPosition) | Selects a range of text using a pair of TextPosition objects.
Public method | SelectRange(TextPositionRange, SelectionModes) | Selects a range of text using a TextPositionRange.
Public method | SelectRange(TextRange, SelectionModes) | Selects a range of text using a TextRange.
Public method | SelectRange(Int32, Int32, SelectionModes) | Selects a range of text using an offset and length.
Public method | SelectRange(TextPosition, TextPosition, SelectionModes) | Selects a range of text using a pair of TextPosition objects.
Public method | SelectRange(TextPositionRange, SelectionModes, Boolean) | Selects a range of text using a TextPositionRange, and optionally updates the PreferredHorizontalLocation.
Top
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextPositionRange)

IEditorViewSelectionSelectRange Method (TextPositionRange)
Selects a range of text using a TextPositionRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextPositionRange positionRange
)
Sub SelectRange (
    positionRange As TextPositionRange
)

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange containing the range of characters to select.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextRange)

IEditorViewSelectionSelectRange Method (TextRange)
Selects a range of text using a TextRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextRange textRange
)
Sub SelectRange (
    textRange As TextRange
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange containing the range of characters to select.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (Int32, Int32)

IEditorViewSelectionSelectRange Method (Int32, Int32)
Selects a range of text using an offset and length.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    int offset,
    int length
)
Sub SelectRange (
    offset As Integer,
    length As Integer
)

Parameters

offset
Type: SystemInt32
The offset at which to start the selection.
length
Type: SystemInt32
The number of characters to select.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextPosition, TextPosition)

IEditorViewSelectionSelectRange Method (TextPosition, TextPosition)
Selects a range of text using a pair of TextPosition objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextPosition startPosition,
    TextPosition endPosition
)
Sub SelectRange (
    startPosition As TextPosition,
    endPosition As TextPosition
)

Parameters

startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition at which to start the selection.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition at which to end the selection.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextPositionRange, SelectionModes)

IEditorViewSelectionSelectRange Method (TextPositionRange, SelectionModes)
Selects a range of text using a TextPositionRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextPositionRange positionRange,
    SelectionModes mode
)
Sub SelectRange (
    positionRange As TextPositionRange,
    mode As SelectionModes
)

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange containing the range of characters to select.
mode
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes
The SelectionModes to use. This value must be either SelectionModes.ContinuousStream or SelectionModes.Block.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextRange, SelectionModes)

IEditorViewSelectionSelectRange Method (TextRange, SelectionModes)
Selects a range of text using a TextRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextRange textRange,
    SelectionModes mode
)
Sub SelectRange (
    textRange As TextRange,
    mode As SelectionModes
)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange containing the range of characters to select.
mode
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes
The SelectionModes to use. This value must be either SelectionModes.ContinuousStream or SelectionModes.Block.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (Int32, Int32, SelectionModes)

IEditorViewSelectionSelectRange Method (Int32, Int32, SelectionModes)
Selects a range of text using an offset and length.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    int offset,
    int length,
    SelectionModes mode
)
Sub SelectRange (
    offset As Integer,
    length As Integer,
    mode As SelectionModes
)

Parameters

offset
Type: SystemInt32
The offset at which to start the selection.
length
Type: SystemInt32
The number of characters to select.
mode
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes
The SelectionModes to use. This value must be either SelectionModes.ContinuousStream or SelectionModes.Block.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextPosition, TextPosition, SelectionModes)

IEditorViewSelectionSelectRange Method (TextPosition, TextPosition, SelectionModes)
Selects a range of text using a pair of TextPosition objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextPosition startPosition,
    TextPosition endPosition,
    SelectionModes mode
)
Sub SelectRange (
    startPosition As TextPosition,
    endPosition As TextPosition,
    mode As SelectionModes
)

Parameters

startPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition at which to start the selection.
endPosition
Type: ActiproSoftware.TextTextPosition
The TextPosition at which to end the selection.
mode
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes
The SelectionModes to use. This value must be either SelectionModes.ContinuousStream or SelectionModes.Block.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRange Method (TextPositionRange, SelectionModes, Boolean)

IEditorViewSelectionSelectRange Method (TextPositionRange, SelectionModes, Boolean)
Selects a range of text using a TextPositionRange, and optionally updates the PreferredHorizontalLocation.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRange(
    TextPositionRange positionRange,
    SelectionModes mode,
    bool updatePreferredHorizontalLocation
)
Sub SelectRange (
    positionRange As TextPositionRange,
    mode As SelectionModes,
    updatePreferredHorizontalLocation As Boolean
)

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange containing the range of characters to select.
mode
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes
The SelectionModes to use. This value must be either SelectionModes.ContinuousStream or SelectionModes.Block.
updatePreferredHorizontalLocation
Type: SystemBoolean
Whether to update the PreferredHorizontalLocation.
See Also

Reference

IEditorViewSelection Interface
SelectRange Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectRight Method

IEditorViewSelectionSelectRight Method
Selects right a character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectRight()
Sub SelectRight
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToDocumentEnd Method

IEditorViewSelectionSelectToDocumentEnd Method
Selects to the end of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToDocumentEnd()
Sub SelectToDocumentEnd
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToDocumentStart Method

IEditorViewSelectionSelectToDocumentStart Method
Selects to the start of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToDocumentStart()
Sub SelectToDocumentStart
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToLineEnd Method

IEditorViewSelectionSelectToLineEnd Method
Selects to the end of the current line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToLineEnd()
Sub SelectToLineEnd
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToLineStart Method

IEditorViewSelectionSelectToLineStart Method
Selects to the start of the current line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToLineStart()
Sub SelectToLineStart
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToLineStartAfterIndentation Method

IEditorViewSelectionSelectToLineStartAfterIndentation Method
Selects to the first non-whitespace character on the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToLineStartAfterIndentation()
Sub SelectToLineStartAfterIndentation
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToMatchingBracket Method

IEditorViewSelectionSelectToMatchingBracket Method
Selects to the matching bracket.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToMatchingBracket()
Sub SelectToMatchingBracket
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToNextWord Method

IEditorViewSelectionSelectToNextWord Method
Selects to the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToNextWord()
Sub SelectToNextWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToPreviousWord Method

IEditorViewSelectionSelectToPreviousWord Method
Selects to the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToPreviousWord()
Sub SelectToPreviousWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToVisibleBottom Method

IEditorViewSelectionSelectToVisibleBottom Method
Selects to the bottom of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToVisibleBottom()
Sub SelectToVisibleBottom
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectToVisibleTop Method

IEditorViewSelectionSelectToVisibleTop Method
Selects to the top of the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectToVisibleTop()
Sub SelectToVisibleTop
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectUp Method

IEditorViewSelectionSelectUp Method
Selects up a line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectUp()
Sub SelectUp
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelection.SelectWord Method

IEditorViewSelectionSelectWord Method
Selects the current word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void SelectWord()
Sub SelectWord
See Also

Reference

IEditorViewSelection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionChangeEventSink Interface

IEditorViewSelectionChangeEventSink Interface
Provides the base requirements for an object that can be notified of IEditorView selection change events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewSelectionChangeEventSink
Public Interface IEditorViewSelectionChangeEventSink

The IEditorViewSelectionChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifySelectionChanged | Notifies when the selection is changed in the specified IEditorView.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionChangeEventSink Methods

IEditorViewSelectionChangeEventSink Methods

The IEditorViewSelectionChangeEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifySelectionChanged | Notifies when the selection is changed in the specified IEditorView.
Top
See Also

Reference

IEditorViewSelectionChangeEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionChangeEventSink.NotifySelectionChanged Method

IEditorViewSelectionChangeEventSinkNotifySelectionChanged Method
Notifies when the selection is changed in the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifySelectionChanged(
    IEditorView view,
    EditorViewSelectionEventArgs e
)
Sub NotifySelectionChanged (
    view As IEditorView,
    e As EditorViewSelectionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs
The EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

IEditorViewSelectionChangeEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionState Interface

IEditorViewSelectionState Interface
Provides the base requirements for an object that can persist the selection state for an IEditorView and restore it later under a new snapshot.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewSelectionState
Public Interface IEditorViewSelectionState
Methods
 | Name | Description
Public method | Restore | Restores the selection.
Public method | Restore(Boolean) | Restores the selection.
Top
Remarks
Instances can be created via calls to CaptureState.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionState Methods

IEditorViewSelectionState Methods
Methods
 | Name | Description
Public method | Restore | Restores the selection.
Public method | Restore(Boolean) | Restores the selection.
Top
See Also

Reference

IEditorViewSelectionState Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionState.Restore Method

IEditorViewSelectionStateRestore Method
Overload List
 | Name | Description
Public method | Restore | Restores the selection.
Public method | Restore(Boolean) | Restores the selection.
Top
See Also

Reference

IEditorViewSelectionState Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionState.Restore Method

IEditorViewSelectionStateRestore Method
Restores the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Restore()
Sub Restore
See Also

Reference

IEditorViewSelectionState Interface
Restore Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewSelectionState.Restore Method (Boolean)

IEditorViewSelectionStateRestore Method (Boolean)
Restores the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Restore(
    bool collapseColumns
)
Sub Restore (
    collapseColumns As Boolean
)

Parameters

collapseColumns
Type: SystemBoolean
Whether to collapse the selection's columns.
See Also

Reference

IEditorViewSelectionState Interface
Restore Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions Interface

IEditorViewTextChangeActions Interface
Provides the base requirements for an object that performs text change actions in an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewTextChangeActions
Public Interface IEditorViewTextChangeActions

The IEditorViewTextChangeActions type exposes the following members.

Methods
 | Name | Description
Public method | Backspace | Deletes the currently selected text if text is selected; otherwise, deletes the previous character.
Public method | BackspaceToPreviousWord | Backspaces and deletes text to the beginning of the previous word.
Public method | ChangeCharacterCasing | Changes the character casing of the selected text in the view.
Public method | CommentLines | Comments the currently selected lines, using the ILineCommenter specified by the current ISyntaxLanguage.
Public method | ConvertSpacesToTabs | Converts all spaces in the selection to an equivalent number of tabs.
Public method | ConvertTabsToSpaces | Converts all tabs in the selection to an equivalent number of spaces.
Public method | Delete | Deletes the currently selected text if text is selected; otherwise, deletes the next character.
Public method | DeleteBlankLines | Deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
Public method | DeleteHorizontalWhitespace | Deletes the horizontal whitespace within the current selection.
Public method | DeleteLine | Deletes the currently active view line.
Public method | DeleteToLineEnd | Deletes the currently selected text through to the end of the current view line.
Public method | DeleteToLineStart | Deletes the currently selected text through to the start of the current view line.
Public method | DeleteToNextWord | Deletes text to the beginning of the next word.
Public method | DuplicateLine | Duplicates the current view line.
Public method | Indent | Indents the currently selected lines.
Public method | InsertLineBreak | Inserts a line break at the current position.
Public method | MoveSelectedLinesDown | Moves the selected lines down.
Public method | MoveSelectedLinesUp | Moves the selected lines up.
Public method | OpenLineAbove | Inserts a new line above the current view line.
Public method | OpenLineBelow | Inserts a new line below the current view line.
Public method | Outdent | Outdents the currently selected lines.
Public method | TabifySelectedLines | Converts spaces at the beginning of the active view lines to tabs.
Public method | ToggleCharacterCasing | Toggles, or inverts, the character casing of the selected text.
Public method | TransposeCharacters | Transposes the characters before and after the caret.
Public method | TransposeLines | Transposes the current view line with the next view line.
Public method | TransposeWords | Transposes the current word with the next word.
Public method | TrimAllTrailingWhitespace | Trims the trailing whitespace off all the lines in the document.
Public method | TrimTrailingWhitespace | Trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
Public method | UncommentLines | Uncomments the currently selected lines, using the line comment delimiter specified by the current ISyntaxLanguage.
Public method | UntabifySelectedLines | Converts tabs at the beginning of the active view lines to spaces.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions Methods

IEditorViewTextChangeActions Methods

The IEditorViewTextChangeActions type exposes the following members.

Methods
 | Name | Description
Public method | Backspace | Deletes the currently selected text if text is selected; otherwise, deletes the previous character.
Public method | BackspaceToPreviousWord | Backspaces and deletes text to the beginning of the previous word.
Public method | ChangeCharacterCasing | Changes the character casing of the selected text in the view.
Public method | CommentLines | Comments the currently selected lines, using the ILineCommenter specified by the current ISyntaxLanguage.
Public method | ConvertSpacesToTabs | Converts all spaces in the selection to an equivalent number of tabs.
Public method | ConvertTabsToSpaces | Converts all tabs in the selection to an equivalent number of spaces.
Public method | Delete | Deletes the currently selected text if text is selected; otherwise, deletes the next character.
Public method | DeleteBlankLines | Deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.
Public method | DeleteHorizontalWhitespace | Deletes the horizontal whitespace within the current selection.
Public method | DeleteLine | Deletes the currently active view line.
Public method | DeleteToLineEnd | Deletes the currently selected text through to the end of the current view line.
Public method | DeleteToLineStart | Deletes the currently selected text through to the start of the current view line.
Public method | DeleteToNextWord | Deletes text to the beginning of the next word.
Public method | DuplicateLine | Duplicates the current view line.
Public method | Indent | Indents the currently selected lines.
Public method | InsertLineBreak | Inserts a line break at the current position.
Public method | MoveSelectedLinesDown | Moves the selected lines down.
Public method | MoveSelectedLinesUp | Moves the selected lines up.
Public method | OpenLineAbove | Inserts a new line above the current view line.
Public method | OpenLineBelow | Inserts a new line below the current view line.
Public method | Outdent | Outdents the currently selected lines.
Public method | TabifySelectedLines | Converts spaces at the beginning of the active view lines to tabs.
Public method | ToggleCharacterCasing | Toggles, or inverts, the character casing of the selected text.
Public method | TransposeCharacters | Transposes the characters before and after the caret.
Public method | TransposeLines | Transposes the current view line with the next view line.
Public method | TransposeWords | Transposes the current word with the next word.
Public method | TrimAllTrailingWhitespace | Trims the trailing whitespace off all the lines in the document.
Public method | TrimTrailingWhitespace | Trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.
Public method | UncommentLines | Uncomments the currently selected lines, using the line comment delimiter specified by the current ISyntaxLanguage.
Public method | UntabifySelectedLines | Converts tabs at the beginning of the active view lines to spaces.
Top
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.Backspace Method

IEditorViewTextChangeActionsBackspace Method
Deletes the currently selected text if text is selected; otherwise, deletes the previous character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Backspace()
Sub Backspace
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.BackspaceToPreviousWord Method

IEditorViewTextChangeActionsBackspaceToPreviousWord Method
Backspaces and deletes text to the beginning of the previous word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void BackspaceToPreviousWord()
Sub BackspaceToPreviousWord
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.ChangeCharacterCasing Method

IEditorViewTextChangeActionsChangeCharacterCasing Method
Changes the character casing of the selected text in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ChangeCharacterCasing(
    CharacterCasing casing
)
Sub ChangeCharacterCasing (
    casing As CharacterCasing
)

Parameters

casing
Type: ActiproSoftware.TextCharacterCasing
A CharacterCasing indicating the character case to change to.
Remarks
If no text is currently selected in the view, only the character after the ICaret is changed. A casing value of CharacterCasing.Normal will capitalize the first letter of each word.
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.CommentLines Method

IEditorViewTextChangeActionsCommentLines Method
Comments the currently selected lines, using the ILineCommenter specified by the current ISyntaxLanguage.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void CommentLines()
Sub CommentLines
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.ConvertSpacesToTabs Method

IEditorViewTextChangeActionsConvertSpacesToTabs Method
Converts all spaces in the selection to an equivalent number of tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ConvertSpacesToTabs()
Sub ConvertSpacesToTabs
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.ConvertTabsToSpaces Method

IEditorViewTextChangeActionsConvertTabsToSpaces Method
Converts all tabs in the selection to an equivalent number of spaces.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ConvertTabsToSpaces()
Sub ConvertTabsToSpaces
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.Delete Method

IEditorViewTextChangeActionsDelete Method
Deletes the currently selected text if text is selected; otherwise, deletes the next character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Delete()
Sub Delete
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DeleteBlankLines Method

IEditorViewTextChangeActionsDeleteBlankLines Method
Deletes the blank lines in the selected text, or the current view line if no text is selected and it is blank.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteBlankLines()
Sub DeleteBlankLines
Remarks
If there is no selection and the current line is not blank, any blank view lines immediately before the current view line will be deleted.
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DeleteHorizontalWhitespace Method

IEditorViewTextChangeActionsDeleteHorizontalWhitespace Method
Deletes the horizontal whitespace within the current selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteHorizontalWhitespace()
Sub DeleteHorizontalWhitespace
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DeleteLine Method

IEditorViewTextChangeActionsDeleteLine Method
Deletes the currently active view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteLine()
Sub DeleteLine
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DeleteToLineEnd Method

IEditorViewTextChangeActionsDeleteToLineEnd Method
Deletes the currently selected text through to the end of the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteToLineEnd()
Sub DeleteToLineEnd
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DeleteToLineStart Method

IEditorViewTextChangeActionsDeleteToLineStart Method
Deletes the currently selected text through to the start of the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteToLineStart()
Sub DeleteToLineStart
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DeleteToNextWord Method

IEditorViewTextChangeActionsDeleteToNextWord Method
Deletes text to the beginning of the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DeleteToNextWord()
Sub DeleteToNextWord
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.DuplicateLine Method

IEditorViewTextChangeActionsDuplicateLine Method
Duplicates the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void DuplicateLine()
Sub DuplicateLine
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.Indent Method

IEditorViewTextChangeActionsIndent Method
Indents the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Indent()
Sub Indent
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.InsertLineBreak Method

IEditorViewTextChangeActionsInsertLineBreak Method
Inserts a line break at the current position.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void InsertLineBreak()
Sub InsertLineBreak
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.MoveSelectedLinesDown Method

IEditorViewTextChangeActionsMoveSelectedLinesDown Method
Moves the selected lines down.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveSelectedLinesDown()
Sub MoveSelectedLinesDown
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.MoveSelectedLinesUp Method

IEditorViewTextChangeActionsMoveSelectedLinesUp Method
Moves the selected lines up.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void MoveSelectedLinesUp()
Sub MoveSelectedLinesUp
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.OpenLineAbove Method

IEditorViewTextChangeActionsOpenLineAbove Method
Inserts a new line above the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void OpenLineAbove()
Sub OpenLineAbove
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.OpenLineBelow Method

IEditorViewTextChangeActionsOpenLineBelow Method
Inserts a new line below the current view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void OpenLineBelow()
Sub OpenLineBelow
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.Outdent Method

IEditorViewTextChangeActionsOutdent Method
Outdents the currently selected lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Outdent()
Sub Outdent
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.TabifySelectedLines Method

IEditorViewTextChangeActionsTabifySelectedLines Method
Converts spaces at the beginning of the active view lines to tabs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void TabifySelectedLines()
Sub TabifySelectedLines
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.ToggleCharacterCasing Method

IEditorViewTextChangeActionsToggleCharacterCasing Method
Toggles, or inverts, the character casing of the selected text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void ToggleCharacterCasing()
Sub ToggleCharacterCasing
Remarks
If no text is currently selected, only the character after the caret is changed.
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.TransposeCharacters Method

IEditorViewTextChangeActionsTransposeCharacters Method
Transposes the characters before and after the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void TransposeCharacters()
Sub TransposeCharacters
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.TransposeLines Method

IEditorViewTextChangeActionsTransposeLines Method
Transposes the current view line with the next view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void TransposeLines()
Sub TransposeLines
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.TransposeWords Method

IEditorViewTextChangeActionsTransposeWords Method
Transposes the current word with the next word.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void TransposeWords()
Sub TransposeWords
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.TrimAllTrailingWhitespace Method

IEditorViewTextChangeActionsTrimAllTrailingWhitespace Method
Trims the trailing whitespace off all the lines in the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void TrimAllTrailingWhitespace()
Sub TrimAllTrailingWhitespace
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.TrimTrailingWhitespace Method

IEditorViewTextChangeActionsTrimTrailingWhitespace Method
Trims the trailing whitespace off all the lines in the selected text, or the current document line if no text is selected.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void TrimTrailingWhitespace()
Sub TrimTrailingWhitespace
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.UncommentLines Method

IEditorViewTextChangeActionsUncommentLines Method
Uncomments the currently selected lines, using the line comment delimiter specified by the current ISyntaxLanguage.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void UncommentLines()
Sub UncommentLines
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeActions.UntabifySelectedLines Method

IEditorViewTextChangeActionsUntabifySelectedLines Method
Converts tabs at the beginning of the active view lines to spaces.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void UntabifySelectedLines()
Sub UntabifySelectedLines
See Also

Reference

IEditorViewTextChangeActions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions Interface

IEditorViewTextChangeOptions Interface
Provides the base requirements for options that are applied to an ITextChange, and are created from an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewTextChangeOptions : ITextChangeOptions
Public Interface IEditorViewTextChangeOptions
    Inherits ITextChangeOptions

The IEditorViewTextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | BlockEditRangeAdjustFunc | Gets or sets a function that can adjust a block selection line's character Range prior to modification.
Public property | CanApplyToBlockEdit | Gets or sets whether the text change can apply to each line in a block edit when applicable.
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available. (Inherited from ITextChangeOptions.)
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only. (Inherited from ITextChangeOptions.)
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on. (Inherited from ITextChangeOptions.)
Public property | IsBlock | Gets or sets whether the text change is a block change.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations. (Inherited from ITextChangeOptions.)
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view. (Inherited from ITextChangeOptions.)
Public property | SelectInsertedText | Gets or sets whether to select the text that is inserted into the document.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified. (Inherited from ITextChangeOptions.)
Public property | VirtualCharacterFill | Gets or sets whether when at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions Properties

IEditorViewTextChangeOptions Properties

The IEditorViewTextChangeOptions type exposes the following members.

Properties
 | Name | Description
Public property | BlockEditRangeAdjustFunc | Gets or sets a function that can adjust a block selection line's character Range prior to modification.
Public property | CanApplyToBlockEdit | Gets or sets whether the text change can apply to each line in a block edit when applicable.
Public property | CanMergeIntoPreviousChange | Gets or sets whether this text change can merge into the previous text change in the undo stack, assuming one is available. (Inherited from ITextChangeOptions.)
Public property | CheckReadOnly | Gets or sets whether to prevent the text change from occurring if the text range to modify is flagged as read-only. (Inherited from ITextChangeOptions.)
Public property | CustomData | Gets or sets custom data that can be persisted with the text change and restored when undo operations occur later on. (Inherited from ITextChangeOptions.)
Public property | IsBlock | Gets or sets whether the text change is a block change.
Public property | OffsetDelta | Gets or sets how an ITextChange's ITextChangeOperation offsets are modified based on previously-added operations. (Inherited from ITextChangeOptions.)
Public property | RetainSelection | Gets or sets whether to prevent the caret from moving to the end of the text change in the active view. (Inherited from ITextChangeOptions.)
Public property | SelectInsertedText | Gets or sets whether to select the text that is inserted into the document.
Public property | Source | Gets or sets the optional source of the text change, which is most often an editor view if specified. (Inherited from ITextChangeOptions.)
Public property | VirtualCharacterFill | Gets or sets whether when at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.
Top
See Also

Reference

IEditorViewTextChangeOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions.BlockEditRangeAdjustFunc Property

IEditorViewTextChangeOptionsBlockEditRangeAdjustFunc Property
Gets or sets a function that can adjust a block selection line's character Range prior to modification.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Func<IEditorViewLine, Range, Range> BlockEditRangeAdjustFunc { get; set; }
Property BlockEditRangeAdjustFunc As Func(Of IEditorViewLine, Range, Range)
    Get
    Set

Property Value

Type: Func IEditorViewLine, Range, Range
A function that can adjust a block selection line's character Range prior to modification.
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText. This property is generally used to handle zero-width character Range scenarios during block edits.
See Also

Reference

IEditorViewTextChangeOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions.CanApplyToBlockEdit Property

IEditorViewTextChangeOptionsCanApplyToBlockEdit Property
Gets or sets whether the text change can apply to each line in a block edit when applicable.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool CanApplyToBlockEdit { get; set; }
Property CanApplyToBlockEdit As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text change can apply to each line in a block edit when applicable; otherwise, false.
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText.
See Also

Reference

IEditorViewTextChangeOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions.IsBlock Property

IEditorViewTextChangeOptionsIsBlock Property
Gets or sets whether the text change is a block change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsBlock { get; set; }
Property IsBlock As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the text change is a block change; otherwise, false.
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText.
See Also

Reference

IEditorViewTextChangeOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions.SelectInsertedText Property

IEditorViewTextChangeOptionsSelectInsertedText Property
Gets or sets whether to select the text that is inserted into the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool SelectInsertedText { get; set; }
Property SelectInsertedText As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the inserted text should be selected; otherwise, false.
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText.
See Also

Reference

IEditorViewTextChangeOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextChangeOptions.VirtualCharacterFill Property

IEditorViewTextChangeOptionsVirtualCharacterFill Property
Gets or sets whether when at a virtual character position, the text change will insert whitespace into the document to fill up to the insertion point's TextPosition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool VirtualCharacterFill { get; set; }
Property VirtualCharacterFill As Boolean
    Get
    Set

Property Value

Type: Boolean
true if whitespace will be inserted; otherwise, false.
Remarks
This option is only used in editor view change methods such as ReplaceSelectedText. It is generally used by text changes such as line feed insertion or open line actions.
See Also

Reference

IEditorViewTextChangeOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextInputEventSink Interface

IEditorViewTextInputEventSink Interface
Provides the base requirements for an object that can be notified of IEditorView text input events.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IEditorViewTextInputEventSink
Public Interface IEditorViewTextInputEventSink

The IEditorViewTextInputEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyTextInput | Notifies before text is input to the specified IEditorView.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextInputEventSink Methods

IEditorViewTextInputEventSink Methods

The IEditorViewTextInputEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyTextInput | Notifies before text is input to the specified IEditorView.
Top
See Also

Reference

IEditorViewTextInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IEditorViewTextInputEventSink.NotifyTextInput Method

IEditorViewTextInputEventSinkNotifyTextInput Method
Notifies before text is input to the specified IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyTextInput(
    IEditorView view,
    TextCompositionEventArgs e
)
Sub NotifyTextInput (
    view As IEditorView,
    e As TextCompositionEventArgs
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIEditorView
The IEditorView that received the event.
e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextCompositionEventArgs
The TextCompositionEventArgs that contains the event data.
See Also

Reference

IEditorViewTextInputEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult Interface

IHitTestResult Interface
Provides the base requirements for the hit test results of a call to the SyntaxEditor.HitTest(Point) method.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IHitTestResult
Public Interface IHitTestResult

The IHitTestResult type exposes the following members.

Properties
 | Name | Description
Public property | IntraTextSpacerTag | Gets the intra-text spacer tag range that is directly under the Location, if any.
Public property | Location | Gets the Point for which the hit test result was created, relative to the SyntaxEditor.
Public property | Offset | Gets the zero-based offset within the Snapshot that is directly under the Location, or closest to it.
Public property | Position | Gets the zero-based TextPosition within the Snapshot that is directly under the Location, or closest to it.
Public property | Snapshot | Gets the ITextSnapshot that was current within the View when the hit test was performed.
Public property | SyntaxEditor | Gets the SyntaxEditor that was hit tested.
Public property | TextAreaLocation | Gets the Location value but in Point relative to the View's text area.
Public property | Type | Gets a HitTestResultType that provides a general categorization about what the hit test result represents.
Public property | View | Gets the IEditorView, if any, that the Location is over.
Public property | ViewLine | Gets the IEditorViewLine that contains the Position.
Public property | ViewMargin | Gets the IEditorViewMargin, if any, that the Location is over.
Public property | VisualElement | Gets the FrameworkElement, if any, that is related to the hit test result.
Top
Methods
 | Name | Description
Public method | GetReader | Returns an ITextSnapshotReader that is initialized to the Offset and allows for reading of nearby text and tokens.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult Properties

IHitTestResult Properties

The IHitTestResult type exposes the following members.

Properties
 | Name | Description
Public property | IntraTextSpacerTag | Gets the intra-text spacer tag range that is directly under the Location, if any.
Public property | Location | Gets the Point for which the hit test result was created, relative to the SyntaxEditor.
Public property | Offset | Gets the zero-based offset within the Snapshot that is directly under the Location, or closest to it.
Public property | Position | Gets the zero-based TextPosition within the Snapshot that is directly under the Location, or closest to it.
Public property | Snapshot | Gets the ITextSnapshot that was current within the View when the hit test was performed.
Public property | SyntaxEditor | Gets the SyntaxEditor that was hit tested.
Public property | TextAreaLocation | Gets the Location value but in Point relative to the View's text area.
Public property | Type | Gets a HitTestResultType that provides a general categorization about what the hit test result represents.
Public property | View | Gets the IEditorView, if any, that the Location is over.
Public property | ViewLine | Gets the IEditorViewLine that contains the Position.
Public property | ViewMargin | Gets the IEditorViewMargin, if any, that the Location is over.
Public property | VisualElement | Gets the FrameworkElement, if any, that is related to the hit test result.
Top
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.IntraTextSpacerTag Property

IHitTestResultIntraTextSpacerTag Property
Gets the intra-text spacer tag range that is directly under the Location, if any.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagSnapshotRange<IIntraTextSpacerTag> IntraTextSpacerTag { get; }
ReadOnly Property IntraTextSpacerTag As TagSnapshotRange(Of IIntraTextSpacerTag)
    Get

Property Value

Type: TagSnapshotRange IIntraTextSpacerTag
The intra-text spacer tag range that is directly under the Location, if any.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.Location Property

IHitTestResultLocation Property
Gets the Point for which the hit test result was created, relative to the SyntaxEditor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Point Location { get; }
ReadOnly Property Location As Point
    Get

Property Value

Type: Point
The Point for which the hit test result was created, relative to the SyntaxEditor.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.Offset Property

IHitTestResultOffset Property
Gets the zero-based offset within the Snapshot that is directly under the Location, or closest to it.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Offset { get; }
ReadOnly Property Offset As Integer
    Get

Property Value

Type: Int32
The zero-based offset within the Snapshot that is directly under the Location, or closest to it.
Remarks
If the Location is directly over a character, the Type property returns HitTestResultType.ViewTextAreaOverCharacter and this property indicates the offset of the character. Otherwise, the offset of the nearest character is used. For instance, locations over the line number margin will return the offset of the first character in the view line that the mouse is over.

The value will be -1 if the Location is not over an editor view.

See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.Position Property

IHitTestResultPosition Property
Gets the zero-based TextPosition within the Snapshot that is directly under the Location, or closest to it.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition Position { get; }
ReadOnly Property Position As TextPosition
    Get

Property Value

Type: TextPosition
The zero-based TextPosition within the Snapshot that is directly under the Location, or closest to it.
Remarks
If the Location is directly over a character, the Type property returns HitTestResultType.ViewTextAreaOverCharacter and this property indicates the TextPosition of the character. Otherwise, the position of the nearest character is used. For instance, locations over the line number margin will return the position of the first character in the view line that the mouse is over.

The value will be TextPosition.Empty if the Location is not over an editor view.

See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.Snapshot Property

IHitTestResultSnapshot Property
Gets the ITextSnapshot that was current within the View when the hit test was performed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot Snapshot { get; }
ReadOnly Property Snapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that was current within the View when the hit test was performed.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.SyntaxEditor Property

IHitTestResultSyntaxEditor Property
Gets the SyntaxEditor that was hit tested.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SyntaxEditor SyntaxEditor { get; }
ReadOnly Property SyntaxEditor As SyntaxEditor
    Get

Property Value

Type: SyntaxEditor
The SyntaxEditor that was hit tested.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.TextAreaLocation Property

IHitTestResultTextAreaLocation Property
Gets the Location value but in Point relative to the View's text area.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Point TextAreaLocation { get; }
ReadOnly Property TextAreaLocation As Point
    Get

Property Value

Type: Point
The Location value but in Point relative to the View's text area.
Remarks
This location is useful for calls to methods like IEditorView.LocationToPosition(Point, LocationToPositionAlgorithm).
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.Type Property

IHitTestResultType Property
Gets a HitTestResultType that provides a general categorization about what the hit test result represents.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
HitTestResultType Type { get; }
ReadOnly Property Type As HitTestResultType
    Get

Property Value

Type: HitTestResultType
A HitTestResultType that provides a general categorization about what the hit test result represents.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.View Property

IHitTestResultView Property
Gets the IEditorView, if any, that the Location is over.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorView View { get; }
ReadOnly Property View As IEditorView
    Get

Property Value

Type: IEditorView
The IEditorView, if any, that the Location is over.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.ViewLine Property

IHitTestResultViewLine Property
Gets the IEditorViewLine that contains the Position.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewLine ViewLine { get; }
ReadOnly Property ViewLine As IEditorViewLine
    Get

Property Value

Type: IEditorViewLine
The IEditorViewLine that contains the Position.
Remarks
See the remarks on the Position property for details on how it is populated.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.ViewMargin Property

IHitTestResultViewMargin Property
Gets the IEditorViewMargin, if any, that the Location is over.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEditorViewMargin ViewMargin { get; }
ReadOnly Property ViewMargin As IEditorViewMargin
    Get

Property Value

Type: IEditorViewMargin
The IEditorViewMargin, if any, that the Location is over.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.VisualElement Property

IHitTestResultVisualElement Property
Gets the FrameworkElement, if any, that is related to the hit test result.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
FrameworkElement VisualElement { get; }
ReadOnly Property VisualElement As FrameworkElement
    Get

Property Value

Type: FrameworkElement
The FrameworkElement, if any, that is related to the hit test result.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult Methods

IHitTestResult Methods

The IHitTestResult type exposes the following members.

Methods
 | Name | Description
Public method | GetReader | Returns an ITextSnapshotReader that is initialized to the Offset and allows for reading of nearby text and tokens.
Top
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IHitTestResult.GetReader Method

IHitTestResultGetReader Method
Returns an ITextSnapshotReader that is initialized to the Offset and allows for reading of nearby text and tokens.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshotReader GetReader()
Function GetReader As ITextSnapshotReader

Return Value

Type: ITextSnapshotReader
An ITextSnapshotReader that is initialized to the Offset.
See Also

Reference

IHitTestResult Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IIndentProvider Interface

IIndentProvider Interface
Provides the base requirements of an object that indicates how text should be indented when the end user presses Enter.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IIndentProvider
Public Interface IIndentProvider

The IIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Top
Remarks
This interface type can be registered with an ISyntaxLanguage using the RegisterService(Object, Object) method. Once an object that implements this interface is registered with the language for this interface type, its features can be used by the language.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IIndentProvider Properties

IIndentProvider Properties

The IIndentProvider type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Gets the IndentMode that specifies the mode by which to indent text.
Top
See Also

Reference

IIndentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IIndentProvider.Mode Property

IIndentProviderMode Property
Gets the IndentMode that specifies the mode by which to indent text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IndentMode Mode { get; }
ReadOnly Property Mode As IndentMode
    Get

Property Value

Type: IndentMode
The IndentMode that specifies the mode by which to indent text.
See Also

Reference

IIndentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IIndentProvider Methods

IIndentProvider Methods

The IIndentProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetIndentAmount | Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.
Top
See Also

Reference

IIndentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IIndentProvider.GetIndentAmount Method

IIndentProviderGetIndentAmount Method
Returns the ideal amount of indent, always in columns, for the line containing the snapshot offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetIndentAmount(
    TextSnapshotOffset snapshotOffset,
    int defaultAmount
)
Function GetIndentAmount (
    snapshotOffset As TextSnapshotOffset,
    defaultAmount As Integer
) As Integer

Parameters

snapshotOffset
Type: ActiproSoftware.TextTextSnapshotOffset
The TextSnapshotOffset whose line should be examined.
defaultAmount
Type: SystemInt32
The default indent amount, which is the amount used in Block mode.

Return Value

Type: Int32
The ideal amount of indent, always in columns, for the line containing the snapshot offset.
Remarks
This method is called when the IndentMode is Smart. The containing ITextDocument is accessible via the snapshot range's ITextSnapshot.
See Also

Reference

IIndentProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording Interface

IMacroRecording Interface
Provides the base requirements for all macro recording functionality in a SyntaxEditor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IMacroRecording
Public Interface IMacroRecording

The IMacroRecording type exposes the following members.

Properties
 | Name | Description
Public property | CurrentMacroAction | Gets the MacroAction that is currently being recorded.
Public property | LastMacroAction | Gets the last MacroAction that was recorded.
Public property | State | Gets the current state of macro recording.
Top
Methods
 | Name | Description
Public method | Cancel | Cancels recording a macro.
Public method | Pause | Pauses recording a macro.
Public method | Record | Starts recording a new macro.
Public method | Resume | Resumes recording a macro from a paused state.
Public method | Stop | Stops recording a macro.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording Properties

IMacroRecording Properties

The IMacroRecording type exposes the following members.

Properties
 | Name | Description
Public property | CurrentMacroAction | Gets the MacroAction that is currently being recorded.
Public property | LastMacroAction | Gets the last MacroAction that was recorded.
Public property | State | Gets the current state of macro recording.
Top
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.CurrentMacroAction Property

IMacroRecordingCurrentMacroAction Property
Gets the MacroAction that is currently being recorded.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MacroAction CurrentMacroAction { get; }
ReadOnly Property CurrentMacroAction As MacroAction
    Get

Property Value

Type: MacroAction
The MacroAction that is currently being recorded.
Remarks
This method returns if no macro recording is currently taking place.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.LastMacroAction Property

IMacroRecordingLastMacroAction Property
Gets the last MacroAction that was recorded.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MacroAction LastMacroAction { get; }
ReadOnly Property LastMacroAction As MacroAction
    Get

Property Value

Type: MacroAction
The last MacroAction that was recorded.
Remarks
After macro recording is stopped, this property contains what was recorded.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.State Property

IMacroRecordingState Property
Gets the current state of macro recording.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MacroRecordingState State { get; }
ReadOnly Property State As MacroRecordingState
    Get

Property Value

Type: MacroRecordingState
A MacroRecordingState that specifies the state.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording Methods

IMacroRecording Methods

The IMacroRecording type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels recording a macro.
Public method | Pause | Pauses recording a macro.
Public method | Record | Starts recording a new macro.
Public method | Resume | Resumes recording a macro from a paused state.
Public method | Stop | Stops recording a macro.
Top
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.Cancel Method

IMacroRecordingCancel Method
Cancels recording a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Cancel()
Sub Cancel
Remarks
When macro recording is cancelled, the old value of the LastMacroAction property is not overwritten.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.Pause Method

IMacroRecordingPause Method
Pauses recording a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Pause()
Sub Pause
Remarks
Use the Resume method to resume recording.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.Record Method

IMacroRecordingRecord Method
Starts recording a new macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Record()
Sub Record
Remarks
Use the Stop method to end recording and save the macro that was recorded.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.Resume Method

IMacroRecordingResume Method
Resumes recording a macro from a paused state.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Resume()
Sub Resume
Remarks
This method should be called after a Pause to resume recording.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IMacroRecording.Stop Method

IMacroRecordingStop Method
Stops recording a macro.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
MacroAction Stop()
Function Stop As MacroAction

Return Value

Type: MacroAction
The MacroAction that was recorded.
Remarks
The MacroAction that is recorded is stored in the LastMacroAction property. If no actions were recorded during this recording session, the old value of the LastMacroAction property will not be overwritten.
See Also

Reference

IMacroRecording Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode Class

IndentMode Class
Specifies the type of indentation to perform when the key is pressed.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIndentMode

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class IndentMode : Enum
Public NotInheritable Class IndentMode
    Inherits Enum

The IndentMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Block | When selected and the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.
 | None | When selected, no automatic indenting occurs when the end user presses Enter to move to a new line of text, and the cursor is placed at the first column of the next line.
 | Smart | When selected and the end user presses Enter, the new line of text is automatically indented based on what the current language's IIndentProvider service determines the context to be.
Public field | value__ |
Top
Remarks
If the syntax language does not have a IIndentProvider service registered, the default indent mode is to Block indent.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode Methods

IndentMode Methods

The IndentMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

IndentMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode Fields

IndentMode Fields

The IndentMode type exposes the following members.

Fields
 | Name | Description
 | Block | When selected and the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.
 | None | When selected, no automatic indenting occurs when the end user presses Enter to move to a new line of text, and the cursor is placed at the first column of the next line.
 | Smart | When selected and the end user presses Enter, the new line of text is automatically indented based on what the current language's IIndentProvider service determines the context to be.
Public field | value__ |
Top
See Also

Reference

IndentMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode.Block Field

IndentModeBlock Field
When selected and the end user presses Enter, the new line of text is automatically indented to the same indentation as the line preceding it.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IndentMode Block = 1
Public Const Block As IndentMode = 1

Field Value

Type: IndentMode
See Also

Reference

IndentMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode.None Field

IndentModeNone Field
When selected, no automatic indenting occurs when the end user presses Enter to move to a new line of text, and the cursor is placed at the first column of the next line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IndentMode None = 0
Public Const None As IndentMode = 0

Field Value

Type: IndentMode
See Also

Reference

IndentMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode.Smart Field

IndentModeSmart Field
When selected and the end user presses Enter, the new line of text is automatically indented based on what the current language's IIndentProvider service determines the context to be.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const IndentMode Smart = 2
Public Const Smart As IndentMode = 2

Field Value

Type: IndentMode
See Also

Reference

IndentMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IndentMode.value__ Field

IndentModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IndentMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

IndentMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView Interface

IPrinterView Interface
Provides the base requirements for a text view that is presented on a printed page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPrinterView : ITextView
Public Interface IPrinterView
    Inherits ITextView

The IPrinterView type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedRegionManager | Gets an ICollapsedRegionManager that provides information about collapsed regions in the document. (Inherited from ITextView.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that currently is used to populate the view. (Inherited from ITextView.)
Public property | HighlightingStyleRegistry | Gets the IHighlightingStyleRegistry used by this view. (Inherited from ITextView.)
Public property | Margins | Gets the collection of margins that are currently in the view.
Public property | PageCount | Gets the total number of printed pages.
Public property | PageNumber | Gets the page number that the view represents.
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ITextView.)
Public property | SyntaxEditor | Gets the SyntaxEditor that contains the view. (Inherited from ITextView.)
Public property | TextAreaViewportBounds | Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates. (Inherited from ITextView.)
Public property | ViewLineFormattingOptions | Gets an ITextViewLineFormattingOptions that provides view line formatting options. (Inherited from ITextView.)
Public property | VisibleViewLines | Gets the collection of IPrinterViewLine objects that are currently visible within the view.
Public property | VisualElement | Gets the FrameworkElement that represents the view. (Inherited from ITextView.)
Top
Methods
 | Name | Description
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view. (Inherited from ITextView.)
Public method | GetAdornmentLayer | Returns an IAdornmentLayer for the view with the specified definition. (Inherited from ITextView.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the view lines. (Inherited from ITextView.)
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the view lines. (Inherited from ITextView.)
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the view is closed. (Inherited from ITextView.)
Public event | MarginsDestroyed | Occurs when the view's margins need to be destroyed. (Inherited from ITextView.)
Public event | TextAreaLayout | Occurs when the layout of the lines in the text area has been updated. (Inherited from ITextView.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView Properties

IPrinterView Properties

The IPrinterView type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedRegionManager | Gets an ICollapsedRegionManager that provides information about collapsed regions in the document. (Inherited from ITextView.)
Public property | CurrentSnapshot | Gets the ITextSnapshot that currently is used to populate the view. (Inherited from ITextView.)
Public property | HighlightingStyleRegistry | Gets the IHighlightingStyleRegistry used by this view. (Inherited from ITextView.)
Public property | Margins | Gets the collection of margins that are currently in the view.
Public property | PageCount | Gets the total number of printed pages.
Public property | PageNumber | Gets the page number that the view represents.
Public property | Properties | Gets the dictionary containing custom properties for this object. (Inherited from ITextView.)
Public property | SyntaxEditor | Gets the SyntaxEditor that contains the view. (Inherited from ITextView.)
Public property | TextAreaViewportBounds | Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates. (Inherited from ITextView.)
Public property | ViewLineFormattingOptions | Gets an ITextViewLineFormattingOptions that provides view line formatting options. (Inherited from ITextView.)
Public property | VisibleViewLines | Gets the collection of IPrinterViewLine objects that are currently visible within the view.
Public property | VisualElement | Gets the FrameworkElement that represents the view. (Inherited from ITextView.)
Top
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView.Margins Property

IPrinterViewMargins Property
Gets the collection of margins that are currently in the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPrinterViewMarginCollection Margins { get; }
ReadOnly Property Margins As IPrinterViewMarginCollection
    Get

Property Value

Type: IPrinterViewMarginCollection
The collection of margins that are currently in the view.
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView.PageCount Property

IPrinterViewPageCount Property
Gets the total number of printed pages.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PageCount { get; }
ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32
The total number of printed pages.
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView.PageNumber Property

IPrinterViewPageNumber Property
Gets the page number that the view represents.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PageNumber { get; }
ReadOnly Property PageNumber As Integer
    Get

Property Value

Type: Int32
The page number that the view represents.
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView.VisibleViewLines Property

IPrinterViewVisibleViewLines Property
Gets the collection of IPrinterViewLine objects that are currently visible within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPrinterViewLineCollection VisibleViewLines { get; }
ReadOnly Property VisibleViewLines As IPrinterViewLineCollection
    Get

Property Value

Type: IPrinterViewLineCollection
The collection of IPrinterViewLine objects that are currently visible within the view.
Remarks
The IPrinterViewLine items in this collection are sorted in their display order, top to bottom.
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView Methods

IPrinterView Methods

The IPrinterView type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view. (Inherited from ITextView.)
Public method | GetAdornmentLayer | Returns an IAdornmentLayer for the view with the specified definition. (Inherited from ITextView.)
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the view lines. (Inherited from ITextView.)
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the view lines. (Inherited from ITextView.)
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates. (Inherited from ITextView.)
Top
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterView Events

IPrinterView Events

The IPrinterView type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the view is closed. (Inherited from ITextView.)
Public event | MarginsDestroyed | Occurs when the view's margins need to be destroyed. (Inherited from ITextView.)
Public event | TextAreaLayout | Occurs when the layout of the lines in the text area has been updated. (Inherited from ITextView.)
Top
See Also

Reference

IPrinterView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLine Interface

IPrinterViewLine Interface
Provides the base requirements for a display line within an IPrinterView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPrinterViewLine : ITextViewLine,
    ITextRangeProvider
Public Interface IPrinterViewLine
    Inherits ITextViewLine, ITextRangeProvider

The IPrinterViewLine type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the distance from the top of the line to the baseline of the text. (Inherited from ITextViewLine.)
Public property | Bounds | Gets the bounds of the line within the view. (Inherited from ITextViewLine.)
Public property | Change | Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass. (Inherited from ITextViewLine.)
Public property | CharacterCount | Gets the number of characters that are displayed on the line, accounting for any hidden text. (Inherited from ITextViewLine.)
Public property | DisplayLineNumber | Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view. (Inherited from ITextViewLine.)
Public property | EndOffset | Gets the offset at which the line ends. (Inherited from ITextViewLine.)
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | EndPosition | Gets the TextPosition at which the line ends. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceCharacterIndex | Gets the index of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceOffset | Gets the offset of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | HasHardLineBreak | Gets whether the the line has a hard line break. (Inherited from ITextViewLine.)
Public property | IndentAmount | Gets the number of columns that the first non-whitespace character is indented on the line. (Inherited from ITextViewLine.)
Public property | IsFirstLine | Gets whether the line contains the first offset of the document. (Inherited from ITextViewLine.)
Public property | IsLastLine | Gets whether the line contains the last offset of the document. (Inherited from ITextViewLine.)
Public property | IsPureWhitespace | Gets whether the line consists purely of whitespace characters. (Inherited from ITextViewLine.)
Public property | PositionRange | Gets the TextPositionRange that contains the line. (Inherited from ITextViewLine.)
Public property | SavePointChangeType | Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point. (Inherited from ITextViewLine.)
Public property | Size | Gets the Size of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRange | Gets the TextSnapshotRange that indicates the snapshot range of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRangeIncludingLineTerminator | Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | StartOffset | Gets the offset at which the line starts. (Inherited from ITextViewLine.)
Public property | StartPosition | Gets the TextPosition at which the line starts. (Inherited from ITextViewLine.)
Public property | Text | Gets or sets the text of the line, excluding the line terminator. (Inherited from ITextViewLine.)
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | TranslationY | Gets the amount by which the line was translated if the Change was Translated. (Inherited from ITextViewLine.)
Public property | View | Gets the IPrinterView that this line is on.
Public property | Visibility | Gets a TextViewLineVisibility that indicates the visibility state of the line. (Inherited from ITextViewLine.)
Public property | WordWrapIndex | Gets the vertical index of the line as displayed for the related ITextSnapshotLine. (Inherited from ITextViewLine.)
Top
Methods
 | Name | Description
Public method | CharacterIndexToOffset | Returns the offset for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | CharacterIndexToPosition | Returns the TextPosition for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTagsTTag | Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text. (Inherited from ITextViewLine.)
Public method | OffsetToCharacterIndex | Returns the character index that represents the specified offset within the line. (Inherited from ITextViewLine.)
Public method | PositionToCharacterIndex | Returns the character index that represents the specified TextPosition within the line. (Inherited from ITextViewLine.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLine Properties

IPrinterViewLine Properties

The IPrinterViewLine type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the distance from the top of the line to the baseline of the text. (Inherited from ITextViewLine.)
Public property | Bounds | Gets the bounds of the line within the view. (Inherited from ITextViewLine.)
Public property | Change | Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass. (Inherited from ITextViewLine.)
Public property | CharacterCount | Gets the number of characters that are displayed on the line, accounting for any hidden text. (Inherited from ITextViewLine.)
Public property | DisplayLineNumber | Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view. (Inherited from ITextViewLine.)
Public property | EndOffset | Gets the offset at which the line ends. (Inherited from ITextViewLine.)
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | EndPosition | Gets the TextPosition at which the line ends. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceCharacterIndex | Gets the index of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | FirstNonWhitespaceOffset | Gets the offset of the first non-whitespace character in the line. (Inherited from ITextViewLine.)
Public property | HasHardLineBreak | Gets whether the the line has a hard line break. (Inherited from ITextViewLine.)
Public property | IndentAmount | Gets the number of columns that the first non-whitespace character is indented on the line. (Inherited from ITextViewLine.)
Public property | IsFirstLine | Gets whether the line contains the first offset of the document. (Inherited from ITextViewLine.)
Public property | IsLastLine | Gets whether the line contains the last offset of the document. (Inherited from ITextViewLine.)
Public property | IsPureWhitespace | Gets whether the line consists purely of whitespace characters. (Inherited from ITextViewLine.)
Public property | PositionRange | Gets the TextPositionRange that contains the line. (Inherited from ITextViewLine.)
Public property | SavePointChangeType | Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point. (Inherited from ITextViewLine.)
Public property | Size | Gets the Size of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRange | Gets the TextSnapshotRange that indicates the snapshot range of the line. (Inherited from ITextViewLine.)
Public property | SnapshotRangeIncludingLineTerminator | Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | StartOffset | Gets the offset at which the line starts. (Inherited from ITextViewLine.)
Public property | StartPosition | Gets the TextPosition at which the line starts. (Inherited from ITextViewLine.)
Public property | Text | Gets or sets the text of the line, excluding the line terminator. (Inherited from ITextViewLine.)
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line. (Inherited from ITextViewLine.)
Public property | TranslationY | Gets the amount by which the line was translated if the Change was Translated. (Inherited from ITextViewLine.)
Public property | View | Gets the IPrinterView that this line is on.
Public property | Visibility | Gets a TextViewLineVisibility that indicates the visibility state of the line. (Inherited from ITextViewLine.)
Public property | WordWrapIndex | Gets the vertical index of the line as displayed for the related ITextSnapshotLine. (Inherited from ITextViewLine.)
Top
See Also

Reference

IPrinterViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLine.View Property

IPrinterViewLineView Property
Gets the IPrinterView that this line is on.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPrinterView View { get; }
ReadOnly Property View As IPrinterView
    Get

Property Value

Type: IPrinterView
The IPrinterView that this line is on.
See Also

Reference

IPrinterViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLine Methods

IPrinterViewLine Methods

The IPrinterViewLine type exposes the following members.

Methods
 | Name | Description
Public method | CharacterIndexToOffset | Returns the offset for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | CharacterIndexToPosition | Returns the TextPosition for the specified character index within the line. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer. (Inherited from ITextViewLine.)
Public method | GetIntraTextSpacerTagsTTag | Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text. (Inherited from ITextViewLine.)
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text. (Inherited from ITextViewLine.)
Public method | OffsetToCharacterIndex | Returns the character index that represents the specified offset within the line. (Inherited from ITextViewLine.)
Public method | PositionToCharacterIndex | Returns the character index that represents the specified TextPosition within the line. (Inherited from ITextViewLine.)
Top
See Also

Reference

IPrinterViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLineCollection Interface

IPrinterViewLineCollection Interface
Provides the base requirements for a read-only collection of IPrinterViewLine objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPrinterViewLineCollection : IList<IPrinterViewLine>,
    ICollection<IPrinterViewLine>, IEnumerable<IPrinterViewLine>, IEnumerable
Public Interface IPrinterViewLineCollection
    Inherits IList(Of IPrinterViewLine), ICollection(Of IPrinterViewLine),
    IEnumerable(Of IPrinterViewLine), IEnumerable

The IPrinterViewLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IPrinterViewLine .)
Public property | IsReadOnly | (Inherited from ICollection IPrinterViewLine .)
Public property | Item | (Inherited from IList IPrinterViewLine .)
Public property | SnapshotRange | Gets the TextSnapshotRange that contains the text range rendered with the view lines.
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IPrinterViewLine .)
Public method | Clear | (Inherited from ICollection IPrinterViewLine .)
Public method | Contains | (Inherited from ICollection IPrinterViewLine .)
Public method | CopyTo | (Inherited from ICollection IPrinterViewLine .)
Public method | GetEnumerator | (Inherited from IEnumerable IPrinterViewLine .)
Public method | IndexOf | (Inherited from IList IPrinterViewLine .)
Public method | Insert | (Inherited from IList IPrinterViewLine .)
Public method | Remove | (Inherited from ICollection IPrinterViewLine .)
Public method | RemoveAt | (Inherited from IList IPrinterViewLine .)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIPrinterViewLine


IPrinterViewLineCollection Properties

IPrinterViewLineCollection Properties

The IPrinterViewLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ICollection IPrinterViewLine .)
Public property | IsReadOnly | (Inherited from ICollection IPrinterViewLine .)
Public property | Item | (Inherited from IList IPrinterViewLine .)
Public property | SnapshotRange | Gets the TextSnapshotRange that contains the text range rendered with the view lines.
Top
See Also

Reference

IPrinterViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLineCollection.SnapshotRange Property

IPrinterViewLineCollectionSnapshotRange Property
Gets the TextSnapshotRange that contains the text range rendered with the view lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that contains the text range rendered with the view lines.
See Also

Reference

IPrinterViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrinterViewLineCollection Methods

IPrinterViewLineCollection Methods

The IPrinterViewLineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ICollection IPrinterViewLine .)
Public method | Clear | (Inherited from ICollection IPrinterViewLine .)
Public method | Contains | (Inherited from ICollection IPrinterViewLine .)
Public method | CopyTo | (Inherited from ICollection IPrinterViewLine .)
Public method | GetEnumerator | (Inherited from IEnumerable IPrinterViewLine .)
Public method | IndexOf | (Inherited from IList IPrinterViewLine .)
Public method | Insert | (Inherited from IList IPrinterViewLine .)
Public method | Remove | (Inherited from ICollection IPrinterViewLine .)
Public method | RemoveAt | (Inherited from IList IPrinterViewLine .)
Top
See Also

Reference

IPrinterViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings Interface

IPrintSettings Interface
Provides the base requirements for an object that supports printing the contents of a SyntaxEditor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IPrintSettings
Public Interface IPrintSettings

The IPrintSettings type exposes the following members.

Properties
 | Name | Description
Public property | DocumentTitle | Gets or sets the document title that should appear at the top of every page.
Public property | HighlightingStyleRegistry | Gets or sets the IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.
Public property | IsDocumentTitleMarginVisible | Gets or sets whether the document title margin is visible.
Public property | IsLineNumberMarginVisible | Gets or sets whether the line number margin is visible.
Public property | IsPageNumberMarginVisible | Gets or sets whether the page number margin is visible.
Public property | IsSyntaxHighlightingEnabled | Gets or sets whether syntax highlighting is enabled.
Public property | IsWhitespaceVisible | Gets or sets whether whitespace (spaces and tabs) is visible.
Public property | IsWordWrapGlyphMarginVisible | Gets or sets whether the word wrap glyph margin is visible.
Public property | ViewMarginFactories | Gets the collection that contains the IPrinterViewMarginFactory objects used to generate the margins for an IPrinterView.
Top
Methods
 | Name | Description
Public method | CreatePrintDocument | Creates a PrintDocument that is prepared to create a representation of the editor contents, allowing for printing.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ImplementationPrintSettings


IPrintSettings Properties

IPrintSettings Properties

The IPrintSettings type exposes the following members.

Properties
 | Name | Description
Public property | DocumentTitle | Gets or sets the document title that should appear at the top of every page.
Public property | HighlightingStyleRegistry | Gets or sets the IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.
Public property | IsDocumentTitleMarginVisible | Gets or sets whether the document title margin is visible.
Public property | IsLineNumberMarginVisible | Gets or sets whether the line number margin is visible.
Public property | IsPageNumberMarginVisible | Gets or sets whether the page number margin is visible.
Public property | IsSyntaxHighlightingEnabled | Gets or sets whether syntax highlighting is enabled.
Public property | IsWhitespaceVisible | Gets or sets whether whitespace (spaces and tabs) is visible.
Public property | IsWordWrapGlyphMarginVisible | Gets or sets whether the word wrap glyph margin is visible.
Public property | ViewMarginFactories | Gets the collection that contains the IPrinterViewMarginFactory objects used to generate the margins for an IPrinterView.
Top
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.DocumentTitle Property

IPrintSettingsDocumentTitle Property
Gets or sets the document title that should appear at the top of every page.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string DocumentTitle { get; set; }
Property DocumentTitle As String
    Get
    Set

Property Value

Type: String
The document title that should appear at the top of every page.
Remarks
This is often set to the filename of the document.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.HighlightingStyleRegistry Property

IPrintSettingsHighlightingStyleRegistry Property
Gets or sets the IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry to use for printouts, if different than the active registry in the editor.
Remarks
If this property is , the active registry in the editor will be used. This property should generally be set when the editor is using a dark theme, since printouts require a light theme.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.IsDocumentTitleMarginVisible Property

IPrintSettingsIsDocumentTitleMarginVisible Property
Gets or sets whether the document title margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsDocumentTitleMarginVisible { get; set; }
Property IsDocumentTitleMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the document title margin is visible; otherwise, false. The default value is true.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.IsLineNumberMarginVisible Property

IPrintSettingsIsLineNumberMarginVisible Property
Gets or sets whether the line number margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLineNumberMarginVisible { get; set; }
Property IsLineNumberMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the line number margin is visible; otherwise, false. The default value is false.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.IsPageNumberMarginVisible Property

IPrintSettingsIsPageNumberMarginVisible Property
Gets or sets whether the page number margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPageNumberMarginVisible { get; set; }
Property IsPageNumberMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the page number margin is visible; otherwise, false. The default value is true.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.IsSyntaxHighlightingEnabled Property

IPrintSettingsIsSyntaxHighlightingEnabled Property
Gets or sets whether syntax highlighting is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsSyntaxHighlightingEnabled { get; set; }
Property IsSyntaxHighlightingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if syntax highlighting is enabled; otherwise, false. The default value is true.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.IsWhitespaceVisible Property

IPrintSettingsIsWhitespaceVisible Property
Gets or sets whether whitespace (spaces and tabs) is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWhitespaceVisible { get; set; }
Property IsWhitespaceVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if whitespace (spaces and tabs) is visible; otherwise, false. The default value is false.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.IsWordWrapGlyphMarginVisible Property

IPrintSettingsIsWordWrapGlyphMarginVisible Property
Gets or sets whether the word wrap glyph margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWordWrapGlyphMarginVisible { get; set; }
Property IsWordWrapGlyphMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the word wrap glyph margin is visible; otherwise, false. The default value is true.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.ViewMarginFactories Property

IPrintSettingsViewMarginFactories Property
Gets the collection that contains the IPrinterViewMarginFactory objects used to generate the margins for an IPrinterView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IPrinterViewMarginFactoryCollection ViewMarginFactories { get; }
ReadOnly Property ViewMarginFactories As IPrinterViewMarginFactoryCollection
    Get

Property Value

Type: IPrinterViewMarginFactoryCollection
A IPrinterViewMarginFactoryCollection that contains the factories. The default collection contains a DefaultPrinterViewMarginFactory.
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings Methods

IPrintSettings Methods

The IPrintSettings type exposes the following members.

Methods
 | Name | Description
Public method | CreatePrintDocument | Creates a PrintDocument that is prepared to create a representation of the editor contents, allowing for printing.
Top
See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


IPrintSettings.CreatePrintDocument Method

IPrintSettingsCreatePrintDocument Method
Creates a PrintDocument that is prepared to create a representation of the editor contents, allowing for printing.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PrintDocument CreatePrintDocument(
    SyntaxEditor syntaxEditor
)
Function CreatePrintDocument (
    syntaxEditor As SyntaxEditor
) As PrintDocument

Parameters

syntaxEditor
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor
The SyntaxEditor for which to create a PrintDocument.

Field Value

Type: PrintDocument
The PrintDocument that was created.

Return Value

Type: PrintDocument

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.IPrintSettings.CreatePrintDocument(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.SyntaxEditor)"]

See Also

Reference

IPrintSettings Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextPositionFinder Interface

ITextPositionFinder Interface
Provides the base requirements for a helper class that finds TextPosition objects based on the current state of an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextPositionFinder
Public Interface ITextPositionFinder

The ITextPositionFinder type exposes the following members.

Methods
 | Name | Description
Public method | GetPositionForCharacterDelta | Returns the TextPosition that is relative to the specified TextPosition by a number of visible characters.
Public method | GetPositionForLineDelta | Returns the TextPosition that is relative to the specified TextPosition by a number of visible view lines.
Public method | GetPositionForLineEnd | Returns the TextPosition for the end of the view line upon which the specified TextPosition falls.
Public method | GetPositionForLineStart | Returns the TextPosition for the start of the view line upon which the specified TextPosition falls.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextPositionFinder Methods

ITextPositionFinder Methods

The ITextPositionFinder type exposes the following members.

Methods
 | Name | Description
Public method | GetPositionForCharacterDelta | Returns the TextPosition that is relative to the specified TextPosition by a number of visible characters.
Public method | GetPositionForLineDelta | Returns the TextPosition that is relative to the specified TextPosition by a number of visible view lines.
Public method | GetPositionForLineEnd | Returns the TextPosition for the end of the view line upon which the specified TextPosition falls.
Public method | GetPositionForLineStart | Returns the TextPosition for the start of the view line upon which the specified TextPosition falls.
Top
See Also

Reference

ITextPositionFinder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextPositionFinder.GetPositionForCharacterDelta Method

ITextPositionFinderGetPositionForCharacterDelta Method
Returns the TextPosition that is relative to the specified TextPosition by a number of visible characters.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition GetPositionForCharacterDelta(
    TextPosition position,
    int characterDelta,
    bool wrapAtLineTerminators,
    bool forceVirtualSpace
)
Function GetPositionForCharacterDelta (
    position As TextPosition,
    characterDelta As Integer,
    wrapAtLineTerminators As Boolean,
    forceVirtualSpace As Boolean
) As TextPosition

Parameters

position
Type: ActiproSoftware.TextTextPosition
The start TextPosition from which to search.
characterDelta
Type: SystemInt32
The number of visible characters (can be negative) relative to the start TextPosition that should be traversed to find the result.
wrapAtLineTerminators
Type: SystemBoolean
Whether to wrap to the next/previous view line when a line terminator is encountered.
forceVirtualSpace
Type: SystemBoolean
Whether to force virtual space to be used (for block selections).

Return Value

Type: TextPosition
The TextPosition that would found based on the criteria.
See Also

Reference

ITextPositionFinder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextPositionFinder.GetPositionForLineDelta Method

ITextPositionFinderGetPositionForLineDelta Method
Returns the TextPosition that is relative to the specified TextPosition by a number of visible view lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition GetPositionForLineDelta(
    TextPosition position,
    int lineDelta,
    bool useCaretPreferredHorizontalLocation,
    bool forceVirtualSpace
)
Function GetPositionForLineDelta (
    position As TextPosition,
    lineDelta As Integer,
    useCaretPreferredHorizontalLocation As Boolean,
    forceVirtualSpace As Boolean
) As TextPosition

Parameters

position
Type: ActiproSoftware.TextTextPosition
The start TextPosition from which to search.
lineDelta
Type: SystemInt32
The number of visible view lines (can be negative) relative to the start TextPosition that should be traversed to find the result.
useCaretPreferredHorizontalLocation
Type: SystemBoolean
Whether to use the caret's preferred horizontal location.
forceVirtualSpace
Type: SystemBoolean
Whether to force virtual space to be used (for block selections).

Return Value

Type: TextPosition
The TextPosition that would found based on the criteria.
See Also

Reference

ITextPositionFinder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextPositionFinder.GetPositionForLineEnd Method

ITextPositionFinderGetPositionForLineEnd Method
Returns the TextPosition for the end of the view line upon which the specified TextPosition falls.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition GetPositionForLineEnd(
    TextPosition position
)
Function GetPositionForLineEnd (
    position As TextPosition
) As TextPosition

Parameters

position
Type: ActiproSoftware.TextTextPosition
The start TextPosition from which to search.

Return Value

Type: TextPosition
The TextPosition that would found based on the criteria.
See Also

Reference

ITextPositionFinder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextPositionFinder.GetPositionForLineStart Method

ITextPositionFinderGetPositionForLineStart Method
Returns the TextPosition for the start of the view line upon which the specified TextPosition falls.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition GetPositionForLineStart(
    TextPosition position
)
Function GetPositionForLineStart (
    position As TextPosition
) As TextPosition

Parameters

position
Type: ActiproSoftware.TextTextPosition
The start TextPosition from which to search.

Return Value

Type: TextPosition
The TextPosition that would found based on the criteria.
See Also

Reference

ITextPositionFinder Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView Interface

ITextView Interface
Provides the base requirements for a text view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextView
Public Interface ITextView

The ITextView type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedRegionManager | Gets an ICollapsedRegionManager that provides information about collapsed regions in the document.
Public property | CurrentSnapshot | Gets the ITextSnapshot that currently is used to populate the view.
Public property | HighlightingStyleRegistry | Gets the IHighlightingStyleRegistry used by this view.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | SyntaxEditor | Gets the SyntaxEditor that contains the view.
Public property | TextAreaViewportBounds | Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates.
Public property | ViewLineFormattingOptions | Gets an ITextViewLineFormattingOptions that provides view line formatting options.
Public property | VisibleViewLines | Gets the collection of ITextViewLine objects that are currently visible within the view.
Public property | VisualElement | Gets the FrameworkElement that represents the view.
Top
Methods
 | Name | Description
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view.
Public method | GetAdornmentLayer | Returns an IAdornmentLayer for the view with the specified definition.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the view lines.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the view lines.
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates.
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates.
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates.
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates.
Top
Events
 | Name | Description
Public event | Closed | Occurs when the view is closed.
Public event | MarginsDestroyed | Occurs when the view's margins need to be destroyed.
Public event | TextAreaLayout | Occurs when the layout of the lines in the text area has been updated.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView Properties

ITextView Properties

The ITextView type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedRegionManager | Gets an ICollapsedRegionManager that provides information about collapsed regions in the document.
Public property | CurrentSnapshot | Gets the ITextSnapshot that currently is used to populate the view.
Public property | HighlightingStyleRegistry | Gets the IHighlightingStyleRegistry used by this view.
Public property | Properties | Gets the dictionary containing custom properties for this object.
Public property | SyntaxEditor | Gets the SyntaxEditor that contains the view.
Public property | TextAreaViewportBounds | Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates.
Public property | ViewLineFormattingOptions | Gets an ITextViewLineFormattingOptions that provides view line formatting options.
Public property | VisibleViewLines | Gets the collection of ITextViewLine objects that are currently visible within the view.
Public property | VisualElement | Gets the FrameworkElement that represents the view.
Top
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.CollapsedRegionManager Property

ITextViewCollapsedRegionManager Property
Gets an ICollapsedRegionManager that provides information about collapsed regions in the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ICollapsedRegionManager CollapsedRegionManager { get; }
ReadOnly Property CollapsedRegionManager As ICollapsedRegionManager
    Get

Property Value

Type: ICollapsedRegionManager
An ICollapsedRegionManager that provides information about collapsed regions in the document.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.CurrentSnapshot Property

ITextViewCurrentSnapshot Property
Gets the ITextSnapshot that currently is used to populate the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextSnapshot CurrentSnapshot { get; }
ReadOnly Property CurrentSnapshot As ITextSnapshot
    Get

Property Value

Type: ITextSnapshot
The ITextSnapshot that currently is used to populate the view.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.HighlightingStyleRegistry Property

ITextViewHighlightingStyleRegistry Property
Gets the IHighlightingStyleRegistry used by this view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IHighlightingStyleRegistry HighlightingStyleRegistry { get; }
ReadOnly Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get

Property Value

Type: IHighlightingStyleRegistry
The IHighlightingStyleRegistry used by this view.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.Properties Property

ITextViewProperties Property
Gets the dictionary containing custom properties for this object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
PropertyDictionary Properties { get; }
ReadOnly Property Properties As PropertyDictionary
    Get

Property Value

Type: PropertyDictionary
The dictionary containing custom properties for this object.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.SyntaxEditor Property

ITextViewSyntaxEditor Property
Gets the SyntaxEditor that contains the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SyntaxEditor SyntaxEditor { get; }
ReadOnly Property SyntaxEditor As SyntaxEditor
    Get

Property Value

Type: SyntaxEditor
The SyntaxEditor that contains the view.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TextAreaViewportBounds Property

ITextViewTextAreaViewportBounds Property
Gets a Rect indicating the bounds of visible portion of the text area, relative to view coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Rect TextAreaViewportBounds { get; }
ReadOnly Property TextAreaViewportBounds As Rect
    Get

Property Value

Type: Rect
A Rect indicating the bounds of visible portion of the text area, relative to view coordinates.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.ViewLineFormattingOptions Property

ITextViewViewLineFormattingOptions Property
Gets an ITextViewLineFormattingOptions that provides view line formatting options.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextViewLineFormattingOptions ViewLineFormattingOptions { get; }
ReadOnly Property ViewLineFormattingOptions As ITextViewLineFormattingOptions
    Get

Property Value

Type: ITextViewLineFormattingOptions
An ITextViewLineFormattingOptions that provides view line formatting options.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.VisibleViewLines Property

ITextViewVisibleViewLines Property
Gets the collection of ITextViewLine objects that are currently visible within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextViewLineCollection VisibleViewLines { get; }
ReadOnly Property VisibleViewLines As ITextViewLineCollection
    Get

Property Value

Type: ITextViewLineCollection
The collection of ITextViewLine objects that are currently visible within the view.
Remarks
The ITextViewLine items in this array are sorted in their display order, top to bottom.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.VisualElement Property

ITextViewVisualElement Property
Gets the FrameworkElement that represents the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
FrameworkElement VisualElement { get; }
ReadOnly Property VisualElement As FrameworkElement
    Get

Property Value

Type: FrameworkElement
The FrameworkElement that represents the view.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView Methods

ITextView Methods

The ITextView type exposes the following members.

Methods
 | Name | Description
Public method | CreateTagAggregatorT | Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view.
Public method | GetAdornmentLayer | Returns an IAdornmentLayer for the view with the specified definition.
Public method | OffsetToPosition | Returns the TextPosition that represents the specified offset within the view lines.
Public method | PositionToOffset | Returns the offset for the specified TextPosition within the view lines.
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates.
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates.
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates.
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates.
Top
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.CreateTagAggregator(T) Method

ITextViewCreateTagAggregatorT Method
Creates a new ITagAggregatorT that collects the tag results from all ITaggerT instances associated with this view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITagAggregator<T> CreateTagAggregator<T>()
where T : ITag

Function CreateTagAggregator(Of T As ITag) As ITagAggregator(Of T)

Type Parameters

T
The type of ITag associated with this aggregator.

Return Value

Type: ITagAggregator T
The ITagAggregatorT that was created.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.GetAdornmentLayer Method

ITextViewGetAdornmentLayer Method
Returns an IAdornmentLayer for the view with the specified definition.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornmentLayer GetAdornmentLayer(
    AdornmentLayerDefinition layerDefinition
)
Function GetAdornmentLayer (
    layerDefinition As AdornmentLayerDefinition
) As IAdornmentLayer

Parameters

layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The layer definition.

Return Value

Type: IAdornmentLayer
An IAdornmentLayer for the view with the specified string-based key.
Remarks
If no IAdornmentLayer already exists with the specified name, one is created.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.OffsetToPosition Method

ITextViewOffsetToPosition Method
Returns the TextPosition that represents the specified offset within the view lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition OffsetToPosition(
    int offset
)
Function OffsetToPosition (
    offset As Integer
) As TextPosition

Parameters

offset
Type: SystemInt32
The offset of a character within the document.

Return Value

Type: TextPosition
The TextPosition that represents the specified offset within the view lines.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.PositionToOffset Method

ITextViewPositionToOffset Method
Returns the offset for the specified TextPosition within the view lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PositionToOffset(
    TextPosition position
)
Function PositionToOffset (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition of a character within the view lines.

Return Value

Type: Int32
The offset for the specified TextPosition within the view lines.
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TransformFromTextArea Method

ITextViewTransformFromTextArea Method
Overload List
 | Name | Description
Public method | TransformFromTextArea(Point) | Transforms the specified Point in text area-relative coordinates to view-relative coordinates.
Public method | TransformFromTextArea(Rect) | Transforms the specified Rect in text area-relative coordinates to view-relative coordinates.
Top
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TransformFromTextArea Method (Point)

ITextViewTransformFromTextArea Method (Point)
Transforms the specified Point in text area-relative coordinates to view-relative coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Point TransformFromTextArea(
    Point location
)
Function TransformFromTextArea (
    location As Point
) As Point

Parameters

location
Type: Windows.FoundationPoint
The Point to transform.

Return Value

Type: Point
The transformed Point.
See Also

Reference

ITextView Interface
TransformFromTextArea Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TransformFromTextArea Method (Rect)

ITextViewTransformFromTextArea Method (Rect)
Transforms the specified Rect in text area-relative coordinates to view-relative coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Rect TransformFromTextArea(
    Rect bounds
)
Function TransformFromTextArea (
    bounds As Rect
) As Rect

Parameters

bounds
Type: Windows.FoundationRect
The Rect to transform.

Return Value

Type: Rect
The transformed Rect.
See Also

Reference

ITextView Interface
TransformFromTextArea Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TransformToTextArea Method

ITextViewTransformToTextArea Method
Overload List
 | Name | Description
Public method | TransformToTextArea(Point) | Transforms the specified Point in view-relative coordinates to text area-relative coordinates.
Public method | TransformToTextArea(Rect) | Transforms the specified Rect in view-relative coordinates to text area-relative coordinates.
Top
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TransformToTextArea Method (Point)

ITextViewTransformToTextArea Method (Point)
Transforms the specified Point in view-relative coordinates to text area-relative coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Point TransformToTextArea(
    Point location
)
Function TransformToTextArea (
    location As Point
) As Point

Parameters

location
Type: Windows.FoundationPoint
The Point to transform.

Return Value

Type: Point
The transformed Point.
See Also

Reference

ITextView Interface
TransformToTextArea Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TransformToTextArea Method (Rect)

ITextViewTransformToTextArea Method (Rect)
Transforms the specified Rect in view-relative coordinates to text area-relative coordinates.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Rect TransformToTextArea(
    Rect bounds
)
Function TransformToTextArea (
    bounds As Rect
) As Rect

Parameters

bounds
Type: Windows.FoundationRect
The Rect to transform.

Return Value

Type: Rect
The transformed Rect.
See Also

Reference

ITextView Interface
TransformToTextArea Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView Events

ITextView Events

The ITextView type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the view is closed.
Public event | MarginsDestroyed | Occurs when the view's margins need to be destroyed.
Public event | TextAreaLayout | Occurs when the layout of the lines in the text area has been updated.
Top
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.Closed Event

ITextViewClosed Event
Occurs when the view is closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler Closed
Event Closed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.MarginsDestroyed Event

ITextViewMarginsDestroyed Event
Occurs when the view's margins need to be destroyed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler MarginsDestroyed
Event MarginsDestroyed As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextView.TextAreaLayout Event

ITextViewTextAreaLayout Event
Occurs when the layout of the lines in the text area has been updated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
event EventHandler<TextViewTextAreaLayoutEventArgs> TextAreaLayout
Event TextAreaLayout As EventHandler(Of TextViewTextAreaLayoutEventArgs)

Value

Type: SystemEventHandler TextViewTextAreaLayoutEventArgs
See Also

Reference

ITextView Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLifecycleEventSink Interface

ITextViewLifecycleEventSink Interface
Provides the base requirements for an object that can be notified of when a ITextView becomes associated and disassociated with a language, via events such as view open/close, document change, or language change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextViewLifecycleEventSink
Public Interface ITextViewLifecycleEventSink

The ITextViewLifecycleEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyViewAttached | Occurs when the specified ITextView is attached to a language.
Public method | NotifyViewDetached | Occurs when the specified ITextView is detached from a language.
Top
Remarks
Objects implementing this event sink interface can be registered as a service with an ISyntaxLanguage using the RegisterService(Object, Object) method. Any object implementing this interface will be notified automatically when related events occur.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLifecycleEventSink Methods

ITextViewLifecycleEventSink Methods

The ITextViewLifecycleEventSink type exposes the following members.

Methods
 | Name | Description
Public method | NotifyViewAttached | Occurs when the specified ITextView is attached to a language.
Public method | NotifyViewDetached | Occurs when the specified ITextView is detached from a language.
Top
See Also

Reference

ITextViewLifecycleEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLifecycleEventSink.NotifyViewAttached Method

ITextViewLifecycleEventSinkNotifyViewAttached Method
Occurs when the specified ITextView is attached to a language.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyViewAttached(
    ITextView view
)
Sub NotifyViewAttached (
    view As ITextView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that is attached.
See Also

Reference

ITextViewLifecycleEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLifecycleEventSink.NotifyViewDetached Method

ITextViewLifecycleEventSinkNotifyViewDetached Method
Occurs when the specified ITextView is detached from a language.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void NotifyViewDetached(
    ITextView view
)
Sub NotifyViewDetached (
    view As ITextView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that is detached.
See Also

Reference

ITextViewLifecycleEventSink Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine Interface

ITextViewLine Interface
Provides the base requirements for a display line within an ITextView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextViewLine : ITextRangeProvider
Public Interface ITextViewLine
    Inherits ITextRangeProvider

The ITextViewLine type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the distance from the top of the line to the baseline of the text.
Public property | Bounds | Gets the bounds of the line within the view.
Public property | Change | Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass.
Public property | CharacterCount | Gets the number of characters that are displayed on the line, accounting for any hidden text.
Public property | DisplayLineNumber | Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view.
Public property | EndOffset | Gets the offset at which the line ends.
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.
Public property | EndPosition | Gets the TextPosition at which the line ends.
Public property | FirstNonWhitespaceCharacterIndex | Gets the index of the first non-whitespace character in the line.
Public property | FirstNonWhitespaceOffset | Gets the offset of the first non-whitespace character in the line.
Public property | HasHardLineBreak | Gets whether the the line has a hard line break.
Public property | IndentAmount | Gets the number of columns that the first non-whitespace character is indented on the line.
Public property | IsFirstLine | Gets whether the line contains the first offset of the document.
Public property | IsLastLine | Gets whether the line contains the last offset of the document.
Public property | IsPureWhitespace | Gets whether the line consists purely of whitespace characters.
Public property | PositionRange | Gets the TextPositionRange that contains the line.
Public property | SavePointChangeType | Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point.
Public property | Size | Gets the Size of the line.
Public property | SnapshotRange | Gets the TextSnapshotRange that indicates the snapshot range of the line.
Public property | SnapshotRangeIncludingLineTerminator | Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line.
Public property | StartOffset | Gets the offset at which the line starts.
Public property | StartPosition | Gets the TextPosition at which the line starts.
Public property | Text | Gets or sets the text of the line, excluding the line terminator.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
Public property | TranslationY | Gets the amount by which the line was translated if the Change was Translated.
Public property | Visibility | Gets a TextViewLineVisibility that indicates the visibility state of the line.
Public property | WordWrapIndex | Gets the vertical index of the line as displayed for the related ITextSnapshotLine.
Top
Methods
 | Name | Description
Public method | CharacterIndexToOffset | Returns the offset for the specified character index within the line.
Public method | CharacterIndexToPosition | Returns the TextPosition for the specified character index within the line.
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character.
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character.
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character.
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character.
Public method | GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer.
Public method | GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer.
Public method | GetIntraTextSpacerTagsTTag | Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag.
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text.
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text.
Public method | OffsetToCharacterIndex | Returns the character index that represents the specified offset within the line.
Public method | PositionToCharacterIndex | Returns the character index that represents the specified TextPosition within the line.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine Properties

ITextViewLine Properties

The ITextViewLine type exposes the following members.

Properties
 | Name | Description
Public property | Baseline | Gets the distance from the top of the line to the baseline of the text.
Public property | Bounds | Gets the bounds of the line within the view.
Public property | Change | Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass.
Public property | CharacterCount | Gets the number of characters that are displayed on the line, accounting for any hidden text.
Public property | DisplayLineNumber | Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view.
Public property | EndOffset | Gets the offset at which the line ends.
Public property | EndOffsetIncludingLineTerminator | Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.
Public property | EndPosition | Gets the TextPosition at which the line ends.
Public property | FirstNonWhitespaceCharacterIndex | Gets the index of the first non-whitespace character in the line.
Public property | FirstNonWhitespaceOffset | Gets the offset of the first non-whitespace character in the line.
Public property | HasHardLineBreak | Gets whether the the line has a hard line break.
Public property | IndentAmount | Gets the number of columns that the first non-whitespace character is indented on the line.
Public property | IsFirstLine | Gets whether the line contains the first offset of the document.
Public property | IsLastLine | Gets whether the line contains the last offset of the document.
Public property | IsPureWhitespace | Gets whether the line consists purely of whitespace characters.
Public property | PositionRange | Gets the TextPositionRange that contains the line.
Public property | SavePointChangeType | Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point.
Public property | Size | Gets the Size of the line.
Public property | SnapshotRange | Gets the TextSnapshotRange that indicates the snapshot range of the line.
Public property | SnapshotRangeIncludingLineTerminator | Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line.
Public property | StartOffset | Gets the offset at which the line starts.
Public property | StartPosition | Gets the TextPosition at which the line starts.
Public property | Text | Gets or sets the text of the line, excluding the line terminator.
Public property | TextRange | Gets or sets a TextRange that specifies the text range of the object. (Inherited from ITextRangeProvider.)
Public property | TextRangeIncludingLineTerminator | Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
Public property | TranslationY | Gets the amount by which the line was translated if the Change was Translated.
Public property | Visibility | Gets a TextViewLineVisibility that indicates the visibility state of the line.
Public property | WordWrapIndex | Gets the vertical index of the line as displayed for the related ITextSnapshotLine.
Top
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.Baseline Property

ITextViewLineBaseline Property
Gets the distance from the top of the line to the baseline of the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double Baseline { get; }
ReadOnly Property Baseline As Double
    Get

Property Value

Type: Double
The distance from the top of the line to the baseline of the text.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.Bounds Property

ITextViewLineBounds Property
Gets the bounds of the line within the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Rect Bounds { get; }
ReadOnly Property Bounds As Rect
    Get

Property Value

Type: Rect
The bounds of the line within the view.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.Change Property

ITextViewLineChange Property
Gets a TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextViewLineChange Change { get; }
ReadOnly Property Change As TextViewLineChange
    Get

Property Value

Type: TextViewLineChange
A TextViewLineChange that indicates the change made to the text represented by the line on the last layout pass.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.CharacterCount Property

ITextViewLineCharacterCount Property
Gets the number of characters that are displayed on the line, accounting for any hidden text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int CharacterCount { get; }
ReadOnly Property CharacterCount As Integer
    Get

Property Value

Type: Int32
The number of characters that are displayed on the line, accounting for any hidden text.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.DisplayLineNumber Property

ITextViewLineDisplayLineNumber Property
Gets the index of the line that contains the first visible character, adding one to the value for display purposes within a view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int DisplayLineNumber { get; }
ReadOnly Property DisplayLineNumber As Integer
    Get

Property Value

Type: Int32
The index of the line that contains the first visible character, adding one to the value for display purposes within a view.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.EndOffset Property

ITextViewLineEndOffset Property
Gets the offset at which the line ends.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffset { get; }
ReadOnly Property EndOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the line ends.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.EndOffsetIncludingLineTerminator Property

ITextViewLineEndOffsetIncludingLineTerminator Property
Gets the offset at which the line ends, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int EndOffsetIncludingLineTerminator { get; }
ReadOnly Property EndOffsetIncludingLineTerminator As Integer
    Get

Property Value

Type: Int32
The offset at which the line ends, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.EndPosition Property

ITextViewLineEndPosition Property
Gets the TextPosition at which the line ends.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition EndPosition { get; }
ReadOnly Property EndPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the line ends.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.FirstNonWhitespaceCharacterIndex Property

ITextViewLineFirstNonWhitespaceCharacterIndex Property
Gets the index of the first non-whitespace character in the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FirstNonWhitespaceCharacterIndex { get; }
ReadOnly Property FirstNonWhitespaceCharacterIndex As Integer
    Get

Property Value

Type: Int32
The index of the first non-whitespace character in the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.FirstNonWhitespaceOffset Property

ITextViewLineFirstNonWhitespaceOffset Property
Gets the offset of the first non-whitespace character in the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int FirstNonWhitespaceOffset { get; }
ReadOnly Property FirstNonWhitespaceOffset As Integer
    Get

Property Value

Type: Int32
The offset of the first non-whitespace character in the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.HasHardLineBreak Property

ITextViewLineHasHardLineBreak Property
Gets whether the the line has a hard line break.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool HasHardLineBreak { get; }
ReadOnly Property HasHardLineBreak As Boolean
    Get

Property Value

Type: Boolean
true if the the line has a hard line break; otherwise, false.
Remarks
This property will return false when there is a word-wrapped line following the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.IndentAmount Property

ITextViewLineIndentAmount Property
Gets the number of columns that the first non-whitespace character is indented on the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndentAmount { get; }
ReadOnly Property IndentAmount As Integer
    Get

Property Value

Type: Int32
The number of columns that the first non-whitespace character is indented on the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.IsFirstLine Property

ITextViewLineIsFirstLine Property
Gets whether the line contains the first offset of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsFirstLine { get; }
ReadOnly Property IsFirstLine As Boolean
    Get

Property Value

Type: Boolean
true if the line contains the first offset of the document; otherwise, false.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.IsLastLine Property

ITextViewLineIsLastLine Property
Gets whether the line contains the last offset of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsLastLine { get; }
ReadOnly Property IsLastLine As Boolean
    Get

Property Value

Type: Boolean
true if the line contains the last offset of the document; otherwise, false.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.IsPureWhitespace Property

ITextViewLineIsPureWhitespace Property
Gets whether the line consists purely of whitespace characters.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsPureWhitespace { get; }
ReadOnly Property IsPureWhitespace As Boolean
    Get

Property Value

Type: Boolean
true if the line consists purely of whitespace characters; otherwise, false.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.PositionRange Property

ITextViewLinePositionRange Property
Gets the TextPositionRange that contains the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPositionRange PositionRange { get; }
ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange
The TextPositionRange that contains the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.SavePointChangeType Property

ITextViewLineSavePointChangeType Property
Gets a SavePointChangeType that indicates the type of change that has been made on the line relative to the save point.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
SavePointChangeType SavePointChangeType { get; }
ReadOnly Property SavePointChangeType As SavePointChangeType
    Get

Property Value

Type: SavePointChangeType
A SavePointChangeType that indicates the type of change that has been made on the line relative to the save point.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.Size Property

ITextViewLineSize Property
Gets the Size of the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Size Size { get; }
ReadOnly Property Size As Size
    Get

Property Value

Type: Size
The Size of the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.SnapshotRange Property

ITextViewLineSnapshotRange Property
Gets the TextSnapshotRange that indicates the snapshot range of the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that indicates the snapshot range of the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.SnapshotRangeIncludingLineTerminator Property

ITextViewLineSnapshotRangeIncludingLineTerminator Property
Gets the TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRangeIncludingLineTerminator { get; }
ReadOnly Property SnapshotRangeIncludingLineTerminator As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that indicates the snapshot range of the line, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.StartOffset Property

ITextViewLineStartOffset Property
Gets the offset at which the line starts.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int StartOffset { get; }
ReadOnly Property StartOffset As Integer
    Get

Property Value

Type: Int32
The offset at which the line starts.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.StartPosition Property

ITextViewLineStartPosition Property
Gets the TextPosition at which the line starts.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition StartPosition { get; }
ReadOnly Property StartPosition As TextPosition
    Get

Property Value

Type: TextPosition
The TextPosition at which the line starts.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.Text Property

ITextViewLineText Property
Gets or sets the text of the line, excluding the line terminator.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
string Text { get; set; }
Property Text As String
    Get
    Set

Property Value

Type: String
The text of the line, excluding the line terminator.
Remarks
If more than one document line are encompassed on the view line, a single newline character will represent the line terminator.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.TextRangeIncludingLineTerminator Property

ITextViewLineTextRangeIncludingLineTerminator Property
Gets the TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextRange TextRangeIncludingLineTerminator { get; }
ReadOnly Property TextRangeIncludingLineTerminator As TextRange
    Get

Property Value

Type: TextRange
The TextRange that indicates the text range of the line, including the line terminator if there is a hard line break on the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.TranslationY Property

ITextViewLineTranslationY Property
Gets the amount by which the line was translated if the Change was Translated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double TranslationY { get; }
ReadOnly Property TranslationY As Double
    Get

Property Value

Type: Double
The amount by which the line was translated if the Change was Translated.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.Visibility Property

ITextViewLineVisibility Property
Gets a TextViewLineVisibility that indicates the visibility state of the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextViewLineVisibility Visibility { get; }
ReadOnly Property Visibility As TextViewLineVisibility
    Get

Property Value

Type: TextViewLineVisibility
A TextViewLineVisibility that indicates the visibility state of the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.WordWrapIndex Property

ITextViewLineWordWrapIndex Property
Gets the vertical index of the line as displayed for the related ITextSnapshotLine.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int WordWrapIndex { get; }
ReadOnly Property WordWrapIndex As Integer
    Get

Property Value

Type: Int32
The vertical index of the line as displayed for the related ITextSnapshotLine.
Remarks
0 is returned if no word wrapping has occurred for the related ITextSnapshotLine at all. 0 is returned if there is word wrapping for the related ITextSnapshotLine, but this is the first view line within that group. 1 is returned for the second view line within that group, and so on.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine Methods

ITextViewLine Methods

The ITextViewLine type exposes the following members.

Methods
 | Name | Description
Public method | CharacterIndexToOffset | Returns the offset for the specified character index within the line.
Public method | CharacterIndexToPosition | Returns the TextPosition for the specified character index within the line.
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character.
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character.
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character.
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character.
Public method | GetIntraTextSpacerBounds | Returns a TextBounds representing the bounds of the specified intra-text spacer.
Public method | GetIntraTextSpacerTag | Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer.
Public method | GetIntraTextSpacerTagsTTag | Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag.
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text.
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text.
Public method | OffsetToCharacterIndex | Returns the character index that represents the specified offset within the line.
Public method | PositionToCharacterIndex | Returns the character index that represents the specified TextPosition within the line.
Top
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.CharacterIndexToOffset Method

ITextViewLineCharacterIndexToOffset Method
Returns the offset for the specified character index within the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int CharacterIndexToOffset(
    int characterIndex
)
Function CharacterIndexToOffset (
    characterIndex As Integer
) As Integer

Parameters

characterIndex
Type: SystemInt32
The index of a character within the line.

Return Value

Type: Int32
The offset for the specified character index within the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.CharacterIndexToPosition Method

ITextViewLineCharacterIndexToPosition Method
Returns the TextPosition for the specified character index within the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextPosition CharacterIndexToPosition(
    int characterIndex
)
Function CharacterIndexToPosition (
    characterIndex As Integer
) As TextPosition

Parameters

characterIndex
Type: SystemInt32
The index of a character within the line.

Return Value

Type: TextPosition
The TextPosition for the specified character index within the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetCharacterBounds Method

ITextViewLineGetCharacterBounds Method
Overload List
 | Name | Description
Public method | GetCharacterBounds(Int32) | Returns a TextBounds representing the bounds of the specified character.
Public method | GetCharacterBounds(TextPosition) | Returns a TextBounds representing the bounds of the specified character.
Top
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetCharacterBounds Method (Int32)

ITextViewLineGetCharacterBounds Method (Int32)
Returns a TextBounds representing the bounds of the specified character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextBounds GetCharacterBounds(
    int offset
)
Function GetCharacterBounds (
    offset As Integer
) As TextBounds

Parameters

offset
Type: SystemInt32
The offset of the character for which to retrieve bounds.

Return Value

Type: TextBounds
A TextBounds representing the bounds of the specified character.
See Also

Reference

ITextViewLine Interface
GetCharacterBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetCharacterBounds Method (TextPosition)

ITextViewLineGetCharacterBounds Method (TextPosition)
Returns a TextBounds representing the bounds of the specified character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextBounds GetCharacterBounds(
    TextPosition position
)
Function GetCharacterBounds (
    position As TextPosition
) As TextBounds

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition of the character for which to retrieve bounds.

Return Value

Type: TextBounds
A TextBounds representing the bounds of the specified character.
See Also

Reference

ITextViewLine Interface
GetCharacterBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetCharacterColumn Method

ITextViewLineGetCharacterColumn Method
Overload List
 | Name | Description
Public method | GetCharacterColumn(Int32) | Returns the column index within the view for the specified character.
Public method | GetCharacterColumn(TextPosition) | Returns the column index within the view for the specified character.
Top
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetCharacterColumn Method (Int32)

ITextViewLineGetCharacterColumn Method (Int32)
Returns the column index within the view for the specified character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetCharacterColumn(
    int offset
)
Function GetCharacterColumn (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset of the character whose column index is being requested.

Return Value

Type: Int32
The column index within the view for the specified character.
See Also

Reference

ITextViewLine Interface
GetCharacterColumn Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetCharacterColumn Method (TextPosition)

ITextViewLineGetCharacterColumn Method (TextPosition)
Returns the column index within the view for the specified character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int GetCharacterColumn(
    TextPosition position
)
Function GetCharacterColumn (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition of the character whose column index is being requested.

Return Value

Type: Int32
The column index within the view for the specified character.
See Also

Reference

ITextViewLine Interface
GetCharacterColumn Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetIntraTextSpacerBounds Method

ITextViewLineGetIntraTextSpacerBounds Method
Returns a TextBounds representing the bounds of the specified intra-text spacer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextBounds GetIntraTextSpacerBounds(
    Object tagKey
)
Function GetIntraTextSpacerBounds (
    tagKey As Object
) As TextBounds

Parameters

tagKey
Type: SystemObject
The object used to uniquely identify the intra-text spacer.

Return Value

Type: TextBounds
A TextBounds representing the bounds of the specified intra-text spacer.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetIntraTextSpacerTag Method

ITextViewLineGetIntraTextSpacerTag Method
Returns the intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TagSnapshotRange<IIntraTextSpacerTag> GetIntraTextSpacerTag(
    int characterIndex
)
Function GetIntraTextSpacerTag (
    characterIndex As Integer
) As TagSnapshotRange(Of IIntraTextSpacerTag)

Parameters

characterIndex
Type: SystemInt32
The index of the character to examine.

Return Value

Type: TagSnapshotRange IIntraTextSpacerTag
The intra-text spacer tag range on the line at the specified character, if the character represents an intra-text spacer.
Remarks
Spacer characters are embedded in between other real text characters. While spacer characters do take up a character index, they do not have a corresponding real character in a document.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetIntraTextSpacerTags(TTag) Method

ITextViewLineGetIntraTextSpacerTagsTTag Method
Returns a collection of intra-text spacer tag ranges on the line that are of the type TTag.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IEnumerable<TagSnapshotRange<TTag>> GetIntraTextSpacerTags<TTag>()
where TTag : IIntraTextSpacerTag

Function GetIntraTextSpacerTags(Of TTag As IIntraTextSpacerTag) As IEnumerable(Of TagSnapshotRange(Of TTag))

Type Parameters

TTag
The type of tag to look for.

Return Value

Type: IEnumerable TagSnapshotRange TTag
A collection of intra-text spacer tag ranges on the line that are of the type TTag.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetTextBounds Method

ITextViewLineGetTextBounds Method
Overload List
 | Name | Description
Public method | GetTextBounds(TextPositionRange) | Returns the list of bounds for the specified TextPositionRange of text.
Public method | GetTextBounds(TextRange) | Returns the list of bounds for the specified TextRange of text.
Top
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetTextBounds Method (TextPositionRange)

ITextViewLineGetTextBounds Method (TextPositionRange)
Returns the list of bounds for the specified TextPositionRange of text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<TextBounds> GetTextBounds(
    TextPositionRange positionRange
)
Function GetTextBounds (
    positionRange As TextPositionRange
) As IList(Of TextBounds)

Parameters

positionRange
Type: ActiproSoftware.TextTextPositionRange
The TextPositionRange of the text for which to retrieve bounds.

Return Value

Type: IList TextBounds
The list of bounds for the specified TextPositionRange text.
Remarks
This method typically only returns more than one TextBounds if there is bi-directional text in the text range.
See Also

Reference

ITextViewLine Interface
GetTextBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.GetTextBounds Method (TextRange)

ITextViewLineGetTextBounds Method (TextRange)
Returns the list of bounds for the specified TextRange of text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IList<TextBounds> GetTextBounds(
    TextRange textRange
)
Function GetTextBounds (
    textRange As TextRange
) As IList(Of TextBounds)

Parameters

textRange
Type: ActiproSoftware.TextTextRange
The TextRange of the text for which to retrieve bounds.

Return Value

Type: IList TextBounds
The list of bounds for the specified TextRange text.
Remarks
This method typically only returns more than one TextBounds if there is bi-directional text in the text range.
See Also

Reference

ITextViewLine Interface
GetTextBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.OffsetToCharacterIndex Method

ITextViewLineOffsetToCharacterIndex Method
Returns the character index that represents the specified offset within the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int OffsetToCharacterIndex(
    int offset
)
Function OffsetToCharacterIndex (
    offset As Integer
) As Integer

Parameters

offset
Type: SystemInt32
The offset of a character within the document.

Return Value

Type: Int32
The character index that represents the specified offset within the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLine.PositionToCharacterIndex Method

ITextViewLinePositionToCharacterIndex Method
Returns the character index that represents the specified TextPosition within the line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int PositionToCharacterIndex(
    TextPosition position
)
Function PositionToCharacterIndex (
    position As TextPosition
) As Integer

Parameters

position
Type: ActiproSoftware.TextTextPosition
The TextPosition of a character within the document.

Return Value

Type: Int32
The character index that represents the specified TextPosition within the line.
See Also

Reference

ITextViewLine Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection Interface

ITextViewLineCollection Interface
Provides the base requirements for a read-only collection of ITextViewLine objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextViewLineCollection : IEnumerable<ITextViewLine>,
    IEnumerable
Public Interface ITextViewLineCollection
    Inherits IEnumerable(Of ITextViewLine), IEnumerable

The ITextViewLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the ITextViewLine at the specified index. [C#] In C#, this property is the indexer for the ITextViewLineCollection class.
Public property | SnapshotRange | Gets the TextSnapshotRange that contains the text range rendered with the view lines.
Top
Methods
 | Name | Description
Public method | Contains | Determines whether the specified ITextViewLine is in the collection.
Public method | GetEnumerator | (Inherited from IEnumerable ITextViewLine .)
Public method | IndexOf | Searches for the specified ITextViewLine and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextViewLine


ITextViewLineCollection Properties

ITextViewLineCollection Properties

The ITextViewLineCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the ITextViewLine at the specified index. [C#] In C#, this property is the indexer for the ITextViewLineCollection class.
Public property | SnapshotRange | Gets the TextSnapshotRange that contains the text range rendered with the view lines.
Top
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection.Count Property

ITextViewLineCollectionCount Property
Gets the number of elements contained in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the collection.
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection.Item Property

ITextViewLineCollectionItem Property
Gets the ITextViewLine at the specified index.

[C#] In C#, this property is the indexer for the ITextViewLineCollection class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextViewLine this[
    int index
] { get; }
ReadOnly Property Item (
    index As Integer
) As ITextViewLine
    Get

Parameters

index
Type: SystemInt32
The index of the ITextViewLine to return.

Property Value

Type: ITextViewLine
The ITextViewLine at the specified index.
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection.SnapshotRange Property

ITextViewLineCollectionSnapshotRange Property
Gets the TextSnapshotRange that contains the text range rendered with the view lines.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
TextSnapshotRange SnapshotRange { get; }
ReadOnly Property SnapshotRange As TextSnapshotRange
    Get

Property Value

Type: TextSnapshotRange
The TextSnapshotRange that contains the text range rendered with the view lines.
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection Methods

ITextViewLineCollection Methods

The ITextViewLineCollection type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether the specified ITextViewLine is in the collection.
Public method | GetEnumerator | (Inherited from IEnumerable ITextViewLine .)
Public method | IndexOf | Searches for the specified ITextViewLine and returns the zero-based index of the first occurrence within the entire collection.
Top
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection.Contains Method

ITextViewLineCollectionContains Method
Determines whether the specified ITextViewLine is in the collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool Contains(
    ITextViewLine viewLine
)
Function Contains (
    viewLine As ITextViewLine
) As Boolean

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextViewLine
The ITextViewLine to locate in the collection.

Return Value

Type: Boolean
true if the specified ITextViewLine is found in the collection; otherwise, false.
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineCollection.IndexOf Method

ITextViewLineCollectionIndexOf Method
Searches for the specified ITextViewLine and returns the zero-based index of the first occurrence within the entire collection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
int IndexOf(
    ITextViewLine viewLine
)
Function IndexOf (
    viewLine As ITextViewLine
) As Integer

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextViewLine
The ITextViewLine to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of the specified ITextViewLine within the entire collection, if found; otherwise, -1.
See Also

Reference

ITextViewLineCollection Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineFormattingOptions Interface

ITextViewLineFormattingOptions Interface
Provides the base requirements for an object that provides line formatting options to an ITextView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface ITextViewLineFormattingOptions
Public Interface ITextViewLineFormattingOptions

The ITextViewLineFormattingOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsWhitespaceVisible | Gets whether whitespace (spaces and tabs) is visible.
Public property | WordWrapMode | Gets a WordWrapMode value indicating the type of word wrapping that is performed.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineFormattingOptions Properties

ITextViewLineFormattingOptions Properties

The ITextViewLineFormattingOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsWhitespaceVisible | Gets whether whitespace (spaces and tabs) is visible.
Public property | WordWrapMode | Gets a WordWrapMode value indicating the type of word wrapping that is performed.
Top
See Also

Reference

ITextViewLineFormattingOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineFormattingOptions.IsWhitespaceVisible Property

ITextViewLineFormattingOptionsIsWhitespaceVisible Property
Gets whether whitespace (spaces and tabs) is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsWhitespaceVisible { get; }
ReadOnly Property IsWhitespaceVisible As Boolean
    Get

Property Value

Type: Boolean
true if whitespace (spaces and tabs) is visible; otherwise, false.
See Also

Reference

ITextViewLineFormattingOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ITextViewLineFormattingOptions.WordWrapMode Property

ITextViewLineFormattingOptionsWordWrapMode Property
Gets a WordWrapMode value indicating the type of word wrapping that is performed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
WordWrapMode WordWrapMode { get; }
ReadOnly Property WordWrapMode As WordWrapMode
    Get

Property Value

Type: WordWrapMode
A WordWrapMode value indicating the type of word wrapping that is performed.
See Also

Reference

ITextViewLineFormattingOptions Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm Class

LocationToPositionAlgorithm Class
Specifies a type of location to TextPosition algorithm.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorLocationToPositionAlgorithm

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class LocationToPositionAlgorithm : Enum
Public NotInheritable Class LocationToPositionAlgorithm
    Inherits Enum

The LocationToPositionAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Absolute | If the location is over a character, the character's position is returned. Otherwise, -1 is returned.
 | BestFit | If the location is over the left half of a character, the character's position is returned. If the location is over the right half of a character, the next character's position is returned. If the location is past the last character in a line and virtual space past the end of lines is disabled, the position of the last character in the line is returned. If the location is past the end of a document and virtual space past the end of the document is disabled, the position of the last character in the document is returned.
 | Block | If the location is over a character, the character's offset is returned. If the location is past the last character in a line and virtual space past the end of lines is disabled, the position of the last character in the line is returned. If the location is past the end of a document and virtual space past the end of the document is disabled, the position of the last character in the document is returned.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm Methods

LocationToPositionAlgorithm Methods

The LocationToPositionAlgorithm type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

LocationToPositionAlgorithm Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm Fields

LocationToPositionAlgorithm Fields

The LocationToPositionAlgorithm type exposes the following members.

Fields
 | Name | Description
 | Absolute | If the location is over a character, the character's position is returned. Otherwise, -1 is returned.
 | BestFit | If the location is over the left half of a character, the character's position is returned. If the location is over the right half of a character, the next character's position is returned. If the location is past the last character in a line and virtual space past the end of lines is disabled, the position of the last character in the line is returned. If the location is past the end of a document and virtual space past the end of the document is disabled, the position of the last character in the document is returned.
 | Block | If the location is over a character, the character's offset is returned. If the location is past the last character in a line and virtual space past the end of lines is disabled, the position of the last character in the line is returned. If the location is past the end of a document and virtual space past the end of the document is disabled, the position of the last character in the document is returned.
Public field | value__ |
Top
See Also

Reference

LocationToPositionAlgorithm Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm.Absolute Field

LocationToPositionAlgorithmAbsolute Field
If the location is over a character, the character's position is returned. Otherwise, -1 is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LocationToPositionAlgorithm Absolute = 2
Public Const Absolute As LocationToPositionAlgorithm = 2

Field Value

Type: LocationToPositionAlgorithm
See Also

Reference

LocationToPositionAlgorithm Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm.BestFit Field

LocationToPositionAlgorithmBestFit Field
If the location is over the left half of a character, the character's position is returned. If the location is over the right half of a character, the next character's position is returned. If the location is past the last character in a line and virtual space past the end of lines is disabled, the position of the last character in the line is returned. If the location is past the end of a document and virtual space past the end of the document is disabled, the position of the last character in the document is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LocationToPositionAlgorithm BestFit = 0
Public Const BestFit As LocationToPositionAlgorithm = 0

Field Value

Type: LocationToPositionAlgorithm
See Also

Reference

LocationToPositionAlgorithm Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm.Block Field

LocationToPositionAlgorithmBlock Field
If the location is over a character, the character's offset is returned. If the location is past the last character in a line and virtual space past the end of lines is disabled, the position of the last character in the line is returned. If the location is past the end of a document and virtual space past the end of the document is disabled, the position of the last character in the document is returned.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const LocationToPositionAlgorithm Block = 1
Public Const Block As LocationToPositionAlgorithm = 1

Field Value

Type: LocationToPositionAlgorithm
See Also

Reference

LocationToPositionAlgorithm Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


LocationToPositionAlgorithm.value__ Field

LocationToPositionAlgorithmvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.LocationToPositionAlgorithm.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

LocationToPositionAlgorithm Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState Class

MacroRecordingState Class
Specifies the state of macro recording.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorMacroRecordingState

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class MacroRecordingState : Enum
Public NotInheritable Class MacroRecordingState
    Inherits Enum

The MacroRecordingState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Paused | Macro recording is in progress, however is currently paused.
 | Recording | Macro recording is in progress.
 | Stopped | No recording is taking place.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState Methods

MacroRecordingState Methods

The MacroRecordingState type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

MacroRecordingState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState Fields

MacroRecordingState Fields

The MacroRecordingState type exposes the following members.

Fields
 | Name | Description
 | Paused | Macro recording is in progress, however is currently paused.
 | Recording | Macro recording is in progress.
 | Stopped | No recording is taking place.
Public field | value__ |
Top
See Also

Reference

MacroRecordingState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState.Paused Field

MacroRecordingStatePaused Field
Macro recording is in progress, however is currently paused.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MacroRecordingState Paused = 2
Public Const Paused As MacroRecordingState = 2

Field Value

Type: MacroRecordingState
See Also

Reference

MacroRecordingState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState.Recording Field

MacroRecordingStateRecording Field
Macro recording is in progress.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MacroRecordingState Recording = 1
Public Const Recording As MacroRecordingState = 1

Field Value

Type: MacroRecordingState
See Also

Reference

MacroRecordingState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState.Stopped Field

MacroRecordingStateStopped Field
No recording is taking place.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const MacroRecordingState Stopped = 0
Public Const Stopped As MacroRecordingState = 0

Field Value

Type: MacroRecordingState
See Also

Reference

MacroRecordingState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


MacroRecordingState.value__ Field

MacroRecordingStatevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.MacroRecordingState.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

MacroRecordingState Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction Class

PasteDragDropAction Class
Specifies the source of a PasteDragDrop event.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorPasteDragDropAction

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class PasteDragDropAction : Enum
Public NotInheritable Class PasteDragDropAction
    Inherits Enum

The PasteDragDropAction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | CanPaste | The action is a check to see whether a paste operation can occur.
 | Paste | The action is a paste operation, immediately before the paste occurs.
 | PasteComplete | The action is a paste operation, immediately after the paste occurs.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction Methods

PasteDragDropAction Methods

The PasteDragDropAction type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

PasteDragDropAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction Fields

PasteDragDropAction Fields

The PasteDragDropAction type exposes the following members.

Fields
 | Name | Description
 | CanPaste | The action is a check to see whether a paste operation can occur.
 | Paste | The action is a paste operation, immediately before the paste occurs.
 | PasteComplete | The action is a paste operation, immediately after the paste occurs.
Public field | value__ |
Top
See Also

Reference

PasteDragDropAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction.CanPaste Field

PasteDragDropActionCanPaste Field
The action is a check to see whether a paste operation can occur.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PasteDragDropAction CanPaste = 0
Public Const CanPaste As PasteDragDropAction = 0

Field Value

Type: PasteDragDropAction
See Also

Reference

PasteDragDropAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction.Paste Field

PasteDragDropActionPaste Field
The action is a paste operation, immediately before the paste occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PasteDragDropAction Paste = 1
Public Const Paste As PasteDragDropAction = 1

Field Value

Type: PasteDragDropAction
See Also

Reference

PasteDragDropAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction.PasteComplete Field

PasteDragDropActionPasteComplete Field
The action is a paste operation, immediately after the paste occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const PasteDragDropAction PasteComplete = 2
Public Const PasteComplete As PasteDragDropAction = 2

Field Value

Type: PasteDragDropAction
See Also

Reference

PasteDragDropAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropAction.value__ Field

PasteDragDropActionvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PasteDragDropAction.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

PasteDragDropAction Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs Class

PasteDragDropEventArgs Class
Event arguments for the PasteDragDrop event.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorPasteDragDropEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class PasteDragDropEventArgs
Public Class PasteDragDropEventArgs

The PasteDragDropEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PasteDragDropEventArgs | Initializes a new instance of the PasteDragDropEventArgs class.
Top
Properties
 | Name | Description
Public property | Action | Gets the PasteDragDropAction describing the action that is the source of the event.
Public property | DataStore | Gets the IDataStore that contains the data.
Public property | Text | Gets or sets the text associated with the DataStore or drag/drop.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs Constructor

PasteDragDropEventArgs Constructor
Initializes a new instance of the PasteDragDropEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PasteDragDropEventArgs(
    PasteDragDropAction action,
    IDataStore dataStore,
    string text
)
Public Sub New (
    action As PasteDragDropAction,
    dataStore As IDataStore,
    text As String
)

Parameters

action
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorPasteDragDropAction
The PasteDragDropAction describing the action that is the source of the event.
dataStore
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorIDataStore
The IDataStore that contains the data set to the clipboard.
text
Type: SystemString
The text associated with the IDataStore.
See Also

Reference

PasteDragDropEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs Properties

PasteDragDropEventArgs Properties

The PasteDragDropEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Action | Gets the PasteDragDropAction describing the action that is the source of the event.
Public property | DataStore | Gets the IDataStore that contains the data.
Public property | Text | Gets or sets the text associated with the DataStore or drag/drop.
Top
See Also

Reference

PasteDragDropEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs.Action Property

PasteDragDropEventArgsAction Property
Gets the PasteDragDropAction describing the action that is the source of the event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public PasteDragDropAction Action { get; }
Public ReadOnly Property Action As PasteDragDropAction
    Get

Property Value

Type: PasteDragDropAction
The PasteDragDropAction describing the action that is the source of the event.
See Also

Reference

PasteDragDropEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs.DataStore Property

PasteDragDropEventArgsDataStore Property
Gets the IDataStore that contains the data.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IDataStore DataStore { get; }
Public ReadOnly Property DataStore As IDataStore
    Get

Property Value

Type: IDataStore
The IDataStore that contains the data.
See Also

Reference

PasteDragDropEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs.Text Property

PasteDragDropEventArgsText Property
Gets or sets the text associated with the DataStore or drag/drop.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The text associated with the DataStore or drag/drop.
Remarks
Set this value to to indicate that no text is associated with the DataStore or drag/drop.
See Also

Reference

PasteDragDropEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


PasteDragDropEventArgs Methods

PasteDragDropEventArgs Methods

The PasteDragDropEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PasteDragDropEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes Class

SelectionModes Class
Specifies the types of selection.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
[FlagsAttribute]
public sealed class SelectionModes : Enum
<FlagsAttribute>
Public NotInheritable Class SelectionModes
    Inherits Enum

The SelectionModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | Block | Only a rectangular portion of text is selected instead of the whole line. The selection includes all of the characters captured within the rectangle defined by the first (anchor) character and the last character in the selection.
 | ContinuousStream | Selection proceeds in a continuous, linear stream from the start of the selection to the end, as in a standard edit control. Entire lines are selected when you move to the next or previous line. This is the default selection mode.
 | None | No selection is permitted. This value should only be used setting the allowed selection modes and not for setting a specific selection mode on the IEditorViewSelection object.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes Methods

SelectionModes Methods

The SelectionModes type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

SelectionModes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes Fields

SelectionModes Fields

The SelectionModes type exposes the following members.

Fields
 | Name | Description
 | Block | Only a rectangular portion of text is selected instead of the whole line. The selection includes all of the characters captured within the rectangle defined by the first (anchor) character and the last character in the selection.
 | ContinuousStream | Selection proceeds in a continuous, linear stream from the start of the selection to the end, as in a standard edit control. Entire lines are selected when you move to the next or previous line. This is the default selection mode.
 | None | No selection is permitted. This value should only be used setting the allowed selection modes and not for setting a specific selection mode on the IEditorViewSelection object.
Public field | value__ |
Top
See Also

Reference

SelectionModes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes.Block Field

SelectionModesBlock Field
Only a rectangular portion of text is selected instead of the whole line. The selection includes all of the characters captured within the rectangle defined by the first (anchor) character and the last character in the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SelectionModes Block = 2
Public Const Block As SelectionModes = 2

Field Value

Type: SelectionModes
See Also

Reference

SelectionModes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes.ContinuousStream Field

SelectionModesContinuousStream Field
Selection proceeds in a continuous, linear stream from the start of the selection to the end, as in a standard edit control. Entire lines are selected when you move to the next or previous line. This is the default selection mode.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SelectionModes ContinuousStream = 1
Public Const ContinuousStream As SelectionModes = 1

Field Value

Type: SelectionModes
See Also

Reference

SelectionModes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes.None Field

SelectionModesNone Field
No selection is permitted. This value should only be used setting the allowed selection modes and not for setting a specific selection mode on the IEditorViewSelection object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const SelectionModes None = 0
Public Const None As SelectionModes = 0

Field Value

Type: SelectionModes
See Also

Reference

SelectionModes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SelectionModes.value__ Field

SelectionModesvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.SelectionModes.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

SelectionModes Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor Class

SyntaxEditor Class
Represents a syntax-highlighting code editor control.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.XamlUIElement
Windows.UI.XamlFrameworkElement
Windows.UI.Xaml.ControlsControl
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSyntaxEditor

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class SyntaxEditor : Control
Public Class SyntaxEditor
    Inherits Control

The SyntaxEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SyntaxEditor | Initializes an instance of the SyntaxEditor class.
Top
Properties
 | Name | Description
Public property | AcceptsTab | Gets or sets the Tab key is accepted, allowing for the insertion of tab stops and/or indenting blocks of text.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveView | Gets the currently-active IEditorView in the editor.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreIndentationGuidesVisible | Gets or sets whether indentation guides are visible.
Public property | AreLineModificationMarksVisible | Gets or sets whether line modification marks are visible.
Public property | AreSelectionGrippersEnabled | Gets or sets whether selection grippers (when touching a view) are enabled.
Public property | AreWordWrapGlyphsVisible | Gets or sets whether word wrap glyphs are visible when word wrap is enabled.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanBackspaceOverSpacesToTabStop | Gets or sets whether a Backspace key pressed before the first non-whitespace character of a line will backspace to the previous tab stop.
Public property | CanCutCopyBlankLineWhenNoSelection | Gets or sets whether cut/copy operations on a blank line with no selection overwrites the clipboard with the blank line.
Public property | CanCutCopyDragWithHtml | Gets or sets whether the cutting and copying of text to the clipboard or dragging text also copies the text in HTML format, which retains syntax highlighting.
Public property | CanCutCopyDragWithRtf | Gets or sets whether the cutting and copying of text to the clipboard or dragging text also copies the text in RTF format, which retains syntax highlighting.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanIncrementalSearchTrimUnmatchedFindText | Gets or sets whether incremental search can ignore typed characters appended to the find text when no match was found for the previous find text.
Public property | CanMoveCaretOnMouseRightClick | Gets or sets whether to move the caret when a view is right-clicked by the mouse (outside of the current selection).
Public property | CanMoveCaretToNextLineAtLineEnd | Gets or sets whether to move the caret to the next view line when pressing the right-arrow key at the end of a view line.
Public property | CanMoveCaretToPreviousLineAtLineStart | Gets or sets whether to move the caret to the previous view line when pressing the left-arrow key at the start of a view line.
Public property | CanScrollPastDocumentEnd | Gets or sets whether it is possible to scroll past the end of the document.
Public property | Caret | Gets the ICaret that manages the blinking caret within the editor.
Public property | CaretBrush | Gets or sets the Brush to use for rendering the caret.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | CharacterWidth | Gets the width of an average character.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Document | Gets or sets the IEditorDocument being edited by the control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightingStyleRegistry | Gets or sets the default IHighlightingStyleRegistry to use.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | Gets or sets the ScrollBarVisibility that specifies the visibility of the horizontal ScrollBar.
Public property | IndicatorMarginBackground | Gets or sets the Brush to use when rendering the indicator margin background.
Public property | IntelliPrompt | Gets the IIntelliPromptManager that manages IntelliPrompt user interface functionality for this editor.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoCorrectEnabled | Gets or sets whether auto-correct, such as case correction, is enabled.
Public property | IsCollapsibleRegionHighlightingEnabled | Gets or sets whether collapsible regions highlight when the mouse is over the outlining margin.
Public property | IsCurrentLineHighlightingEnabled | Gets or sets whether current line highlighting is enabled for the active view.
Public property | IsDefaultContextMenuEnabled | Gets or sets whether the default context menu is enabled.
Public property | IsDelimiterAutoCompleteEnabled | Gets or sets whether delimiter auto-correct is enabled for the active view.
Public property | IsDelimiterHighlightingEnabled | Gets or sets whether delimiter highlighting is enabled for the active view.
Public property | IsDocumentReadOnly | Gets whether the attached document is read-only.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsIncrementalSearchResultHighlightingEnabled | Gets or sets whether incremental search result highlighting is enabled for the active view.
Public property | IsIndicatorMarginVisible | Gets or sets whether the indicator margin is visible.
Public property | IsLineNumberMarginVisible | Gets or sets whether the line number margin is visible.
Public property | IsMouseWheelZoomEnabled | Gets or sets whether holding Ctrl while scrolling the mouse wheel allows view zooming.
Public property | IsMultiLine | Gets or sets whether the editor allows multiple lines of text.
Public property | IsOutliningMarginVisible | Gets or sets whether the outlining margin is visible.
Public property | IsOverwriteModeActive | Gets or sets whether the editor is in overwrite mode, where typing overwrites the character at the caret's offset.
Public property | IsPointerOver | Gets whether the pointer is over the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectionMarginVisible | Gets or sets whether the selection margin is visible.
Public property | IsSoftKeyboardEnabled | Gets or sets whether the soft keyboard is enabled when a view gets focus.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextDataBindingEnabled | Gets or sets whether data binding on the Text property is currently enabled.
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsViewLineMeasureEnabled | Gets or sets whether the editor view lines are measured, allowing the editor to resize as text contents change.
Public property | IsWhitespaceVisible | Gets or sets whether whitespace (spaces and tabs) is visible.
Public property | IsWordWrapEnabled | Gets whether word wrap mode is currently enabled.
Public property | IsWordWrapGlyphMarginVisible | Gets whether the word wrap glyph margin is visible.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LineNumberMarginBackground | Gets or sets the Brush to use when rendering the line number margin background.
Public property | LineNumberMarginFontFamily | Gets or sets the FontFamily to use when rendering line number margin text.
Public property | LineNumberMarginFontSize | Gets or sets the font size to use when rendering line number margin text.
Public property | LineNumberMarginForeground | Gets or sets the Brush to use when rendering line number margin text.
Public property | MacroRecording | Gets the IMacroRecording that manages macro recording and playback functionality.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxZoomLevel | Gets or sets a percentage value indicating the maximum zoom level of editor view content.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinZoomLevel | Gets or sets a percentage value indicating the minimum zoom level of editor view content.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OutliningMarginBackground | Gets or sets the Brush to use when rendering the outlining margin background.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrintSettings | Gets or sets the IPrintSettings that provides access to all printing functionality.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ScrollBarTrayBottomTemplate | Gets or sets the DataTemplate containing controls that are displayed under the vertical ScrollBar in an IEditorView.
Public property | ScrollBarTrayLeftTemplate | Gets or sets the DataTemplate containing controls that are displayed left of the horizontal ScrollBar in an IEditorView.
Public property | ScrollBarTrayRightTemplate | Gets or sets the DataTemplate containing controls that are displayed right of the horizontal ScrollBar in an IEditorView.
Public property | ScrollBarTrayTopTemplate | Gets or sets the DataTemplate containing controls that are displayed above the vertical ScrollBar in an IEditorView.
Public property | ScrollToCaretOnSelectAll | Gets or sets whether to scroll to the caret when selecting all text in a view.
Public property | SelectionBackgroundActive | Gets or sets the Brush to use for rendering the active selection background.
Public property | SelectionBackgroundInactive | Gets or sets the Brush to use for rendering the inactive selection background.
Public property | SelectionCollapsesOnCopy | Gets or sets whether the selection collapses when a copy operation occurs.
Public property | SelectionCollapsesToAnchor | Gets or sets whether the selection collapses to the anchor of the selection.
Public property | SelectionMarginBackground | Gets or sets the Brush to use when rendering the selection margin background.
Public property | SelectionModesAllowed | Gets or sets a SelectionModes value indicating the selection modes that are allowed within the editor.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the complete document text within the editor. This property is created specifically for data binding, and be sure to see the remarks for important configuration and performance information.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalScrollBarVisibility | Gets or sets the ScrollBarVisibility that specifies the visibility of the vertical ScrollBar.
Public property | ViewMarginFactories | Gets the collection that contains the IEditorViewMarginFactory objects used to generate the margins for an IEditorView.
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | VisibleWhitespaceForeground | Gets or sets the Brush to use when rendering visible whitespace.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WordWrapGlyphMarginBackground | Gets or sets the Brush to use when rendering the word wrap glyph margin background.
Public property | WordWrapGlyphMarginForeground | Gets or sets the Brush to use when rendering the word wrap glyph margin foreground.
Public property | WordWrapMode | Gets or sets a WordWrapMode value indicating the type of word wrapping that is performed.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomAnimationDuration | Gets or sets the Duration to animate the scale from one zoom level to the next.
Public property | ZoomLevel | Gets or sets a percentage value indicating the zoom level of editor view content.
Public property | ZoomLevelAnimated | Gets or sets a percentage value indicating the current animated zoom level of editor view content.
Public property | ZoomLevelIncrement | Gets or sets the percentage increment by which the zoom level changes via the mouse wheel.
Top
Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateDefaultContextMenu | Creates the default MenuFlyout.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTest | Performs a hit test of the specified Point within the editor and returns detailed results in an IHitTestResult.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | InvalidateViews | Invalidates the views and redraws them.
Public method | IsSelectionModeAllowed | Gets whether the specified SelectionModes value is allowed.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnCutCopyDrag | Invoked when an unhandled CutCopyDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDocumentChanged | Invoked when an unhandled DocumentChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs after the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsOverwriteModeActiveChanged | Invoked when an unhandled IsOverwriteModeActiveChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnMacroRecordingStateChanged | Invoked when an unhandled MacroRecordingStateChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPasteDragDrop | Invoked when an unhandled PasteDragDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Invoked when an unhandled pointer enter attached event is raised on this element. Implement this method to add class handling for this event. (Overrides ControlOnPointerEntered(PointerRoutedEventArgs).)
Protected method | OnPointerExited | Invoked when an unhandled pointer leave attached event is raised on this element. Implement this method to add class handling for this event. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Overrides ControlOnRightTapped(RightTappedRoutedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnUserInterfaceUpdate | Invoked when an unhandled UserInterfaceUpdate attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewClosed | Invoked when an unhandled ViewClosed attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewIsIncrementalSearchActiveChanged | Invoked when an unhandled ViewIsIncrementalSearchActiveChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewOpened | Invoked when an unhandled ViewOpened attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewSearch | Invoked when an unhandled ViewSearch attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewSelectionChanged | Invoked when an unhandled ViewSelectionChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ResetViews | Resets the splits and creates an initial view.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | CutCopyDrag | Occurs before text is cut or copied to the clipboard, and also before a drag occurs.
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DocumentChanged | Occurs when the Document property is changed.
Public event | DocumentIsModifiedChanged | Occurs after the current document's IsModified property value has changed.
Public event | DocumentIsReadOnlyChanged | Occurs after the current document's IsReadOnly property value has changed.
Public event | DocumentLanguageChanged | Occurs when the Document's Language property is changed.
Public event | DocumentParseDataChanged | Occurs after the current document's ParseData property value has changed.
Public event | DocumentTextChanged | Occurs after a text change occurs to the Document.
Public event | DocumentTextChanging | Occurs before a text change occurs to the Document.
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | IsOverwriteModeActiveChanged | Occurs when the IsOverwriteModeActive property value changes.
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | MacroRecordingStateChanged | Occurs when the macro recording state changes.
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PasteDragDrop | Occurs when a paste or drag/drop operation occurs over the control, allowing for customization of the text to be inserted.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | UserInterfaceUpdate | Occurs after a brief delay following any document text, parse data, or view selection update, allowing consumers to update the user interface during an idle period.
Public event | ViewClosed | Occurs when an ITextView is closed.
Public event | ViewIsIncrementalSearchActiveChanged | Occurs when the incremental search mode of an ITextView is activated or deactivated.
Public event | ViewOpened | Occurs when an ITextView is opened.
Public event | ViewSearch | Occurs when a IEditorView search operation is performed.
Public event | ViewSelectionChanged | Occurs when a IEditorView selection has changed.
Top
Fields
Name | Description
AcceptsTabProperty | Identifies the AcceptsTab dependency property. This field is read-only.
AreIndentationGuidesVisibleProperty | Identifies the AreIndentationGuidesVisible dependency property. This field is read-only.
AreLineModificationMarksVisibleProperty | Identifies the AreLineModificationMarksVisible dependency property. This field is read-only.
AreSelectionGrippersEnabledProperty | Identifies the AreSelectionGrippersEnabled dependency property. This field is read-only.
AreWordWrapGlyphsVisibleProperty | Identifies the AreWordWrapGlyphsVisible dependency property. This field is read-only.
CanBackspaceOverSpacesToTabStopProperty | Identifies the CanBackspaceOverSpacesToTabStop dependency property. This field is read-only.
CanCutCopyBlankLineWhenNoSelectionProperty | Identifies the CanCutCopyBlankLineWhenNoSelection dependency property. This field is read-only.
CanCutCopyDragWithHtmlProperty | Identifies the CanCutCopyDragWithHtml dependency property. This field is read-only.
CanCutCopyDragWithRtfProperty | Identifies the CanCutCopyDragWithRtf dependency property. This field is read-only.
CanIncrementalSearchTrimUnmatchedFindTextProperty | Identifies the CanIncrementalSearchTrimUnmatchedFindText dependency property. This field is read-only.
CanMoveCaretOnMouseRightClickProperty | Identifies the CanMoveCaretOnMouseRightClick dependency property. This field is read-only.
CanMoveCaretToNextLineAtLineEndProperty | Identifies the CanMoveCaretToNextLineAtLineEnd dependency property. This field is read-only.
CanMoveCaretToPreviousLineAtLineStartProperty | Identifies the CanMoveCaretToPreviousLineAtLineStart dependency property. This field is read-only.
CanScrollPastDocumentEndProperty | Identifies the CanScrollPastDocumentEnd dependency property. This field is read-only.
CaretBrushProperty | Identifies the CaretBrush dependency property. This field is read-only.
DocumentProperty | Identifies the Document dependency property. This field is read-only.
HighlightingStyleRegistryProperty | Identifies the HighlightingStyleRegistry dependency property. This field is read-only.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility dependency property. This field is read-only.
IndicatorMarginBackgroundProperty | Identifies the IndicatorMarginBackground dependency property. This field is read-only.
IsAutoCorrectEnabledProperty | Identifies the IsAutoCorrectEnabled dependency property. This field is read-only.
IsCollapsibleRegionHighlightingEnabledProperty | Identifies the IsCollapsibleRegionHighlightingEnabled dependency property. This field is read-only.
IsCurrentLineHighlightingEnabledProperty | Identifies the IsCurrentLineHighlightingEnabled dependency property. This field is read-only.
IsDefaultContextMenuEnabledProperty | Identifies the IsDefaultContextMenuEnabled dependency property. This field is read-only.
IsDelimiterAutoCompleteEnabledProperty | Identifies the IsDelimiterAutoCompleteEnabled dependency property. This field is read-only.
IsDelimiterHighlightingEnabledProperty | Identifies the IsDelimiterHighlightingEnabled dependency property. This field is read-only.
IsDocumentReadOnlyProperty | Identifies the IsDocumentReadOnly dependency property. This field is read-only.
IsIncrementalSearchResultHighlightingEnabledProperty | Identifies the IsIncrementalSearchResultHighlightingEnabled dependency property. This field is read-only.
IsIndicatorMarginVisibleProperty | Identifies the IsIndicatorMarginVisible dependency property. This field is read-only.
IsLineNumberMarginVisibleProperty | Identifies the IsLineNumberMarginVisible dependency property. This field is read-only.
IsMouseWheelZoomEnabledProperty | Identifies the IsMouseWheelZoomEnabled dependency property. This field is read-only.
IsMultiLineProperty | Identifies the IsMultiLine dependency property. This field is read-only.
IsOutliningMarginVisibleProperty | Identifies the IsOutliningMarginVisible dependency property. This field is read-only.
IsOverwriteModeActiveProperty | Identifies the IsOverwriteModeActive dependency property. This field is read-only.
IsSelectionMarginVisibleProperty | Identifies the IsSelectionMarginVisible dependency property. This field is read-only.
IsSoftKeyboardEnabledProperty | Identifies the IsSoftKeyboardEnabled dependency property. This field is read-only.
IsTextDataBindingEnabledProperty | Identifies the IsTextDataBindingEnabled dependency property. This field is read-only.
IsViewLineMeasureEnabledProperty | Identifies the IsViewLineMeasureEnabled dependency property. This field is read-only.
IsWhitespaceVisibleProperty | Identifies the IsWhitespaceVisible dependency property. This field is read-only.
IsWordWrapEnabledProperty | Identifies the IsWordWrapEnabled dependency property. This field is read-only.
IsWordWrapGlyphMarginVisibleProperty | Identifies the IsWordWrapGlyphMarginVisible dependency property. This field is read-only.
LineNumberMarginBackgroundProperty | Identifies the LineNumberMarginBackground dependency property. This field is read-only.
LineNumberMarginFontFamilyProperty | Identifies the LineNumberMarginFontFamily dependency property. This field is read-only.
LineNumberMarginFontSizeProperty | Identifies the LineNumberMarginFontSize dependency property. This field is read-only.
LineNumberMarginForegroundProperty | Identifies the LineNumberMarginForeground dependency property. This field is read-only.
MaxZoomLevelProperty | Identifies the MaxZoomLevel dependency property. This field is read-only.
MinZoomLevelProperty | Identifies the MinZoomLevel dependency property. This field is read-only.
OutliningMarginBackgroundProperty | Identifies the OutliningMarginBackground dependency property. This field is read-only.
PrintSettingsProperty | Identifies the PrintSettings dependency property. This field is read-only.
ScrollBarTrayBottomTemplateProperty | Identifies the ScrollBarTrayBottomTemplate dependency property. This field is read-only.
ScrollBarTrayLeftTemplateProperty | Identifies the ScrollBarTrayLeftTemplate dependency property. This field is read-only.
ScrollBarTrayRightTemplateProperty | Identifies the ScrollBarTrayRightTemplate dependency property. This field is read-only.
ScrollBarTrayTopTemplateProperty | Identifies the ScrollBarTrayTopTemplate dependency property. This field is read-only.
ScrollToCaretOnSelectAllProperty | Identifies the ScrollToCaretOnSelectAll dependency property. This field is read-only.
SelectionBackgroundActiveProperty | Identifies the SelectionBackgroundActive dependency property. This field is read-only.
SelectionBackgroundInactiveProperty | Identifies the SelectionBackgroundInactive dependency property. This field is read-only.
SelectionCollapsesOnCopyProperty | Identifies the SelectionCollapsesOnCopy dependency property. This field is read-only.
SelectionCollapsesToAnchorProperty | Identifies the SelectionCollapsesToAnchor dependency property. This field is read-only.
SelectionMarginBackgroundProperty | Identifies the SelectionMarginBackground dependency property. This field is read-only.
SelectionModesAllowedProperty | Identifies the SelectionModesAllowed dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility dependency property. This field is read-only.
VisibleWhitespaceForegroundProperty | Identifies the VisibleWhitespaceForeground dependency property. This field is read-only.
WordWrapGlyphMarginBackgroundProperty | Identifies the WordWrapGlyphMarginBackground dependency property. This field is read-only.
WordWrapGlyphMarginForegroundProperty | Identifies the WordWrapGlyphMarginForeground dependency property. This field is read-only.
WordWrapModeProperty | Identifies the WordWrapMode dependency property. This field is read-only.
ZoomAnimationDurationProperty | Identifies the ZoomAnimationDuration dependency property. This field is read-only.
ZoomLevelAnimatedProperty | Identifies the ZoomLevelAnimated dependency property. This field is read-only.
ZoomLevelIncrementProperty | Identifies the ZoomLevelIncrement dependency property. This field is read-only.
ZoomLevelProperty | Identifies the ZoomLevel dependency property. This field is read-only.
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor Constructor

SyntaxEditor Constructor
Initializes an instance of the SyntaxEditor class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SyntaxEditor()
Public Sub New
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor Properties

SyntaxEditor Properties

The SyntaxEditor type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsTab | Gets or sets the Tab key is accepted, allowing for the insertion of tab stops and/or indenting blocks of text.
Public property | AccessKey | (Inherited from UIElement.)
Public property | AccessKeyScopeOwner | (Inherited from UIElement.)
Public property | ActiveView | Gets the currently-active IEditorView in the editor.
Public property | ActualHeight | Gets the rendered height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value that determines whether this UIElement can be a drop target for purposes of drag-and-drop operations. (Inherited from UIElement.)
Public property | AllowFocusOnInteraction | (Inherited from FrameworkElement.)
Public property | AllowFocusWhenDisabled | (Inherited from FrameworkElement.)
Public property | AreIndentationGuidesVisible | Gets or sets whether indentation guides are visible.
Public property | AreLineModificationMarksVisible | Gets or sets whether line modification marks are visible.
Public property | AreSelectionGrippersEnabled | Gets or sets whether selection grippers (when touching a view) are enabled.
Public property | AreWordWrapGlyphsVisible | Gets or sets whether word wrap glyphs are visible when word wrap is enabled.
Public property | Background | Gets or sets a brush that provides the background of the control. (Inherited from Control.)
Public property | BaseUri | Gets a Uniform Resource Identifier (URI) that represents the base Uniform Resource Identifier (URI) for an XAML-constructed object at XAML load time. This property is useful for Uniform Resource Identifier (URI) resolution at run time. (Inherited from FrameworkElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a value that indicates that rendered content should be cached as a composited bitmap when possible. (Inherited from UIElement.)
Public property | CanBackspaceOverSpacesToTabStop | Gets or sets whether a Backspace key pressed before the first non-whitespace character of a line will backspace to the previous tab stop.
Public property | CanCutCopyBlankLineWhenNoSelection | Gets or sets whether cut/copy operations on a blank line with no selection overwrites the clipboard with the blank line.
Public property | CanCutCopyDragWithHtml | Gets or sets whether the cutting and copying of text to the clipboard or dragging text also copies the text in HTML format, which retains syntax highlighting.
Public property | CanCutCopyDragWithRtf | Gets or sets whether the cutting and copying of text to the clipboard or dragging text also copies the text in RTF format, which retains syntax highlighting.
Public property | CanDrag | (Inherited from UIElement.)
Public property | CanIncrementalSearchTrimUnmatchedFindText | Gets or sets whether incremental search can ignore typed characters appended to the find text when no match was found for the previous find text.
Public property | CanMoveCaretOnMouseRightClick | Gets or sets whether to move the caret when a view is right-clicked by the mouse (outside of the current selection).
Public property | CanMoveCaretToNextLineAtLineEnd | Gets or sets whether to move the caret to the next view line when pressing the right-arrow key at the end of a view line.
Public property | CanMoveCaretToPreviousLineAtLineStart | Gets or sets whether to move the caret to the previous view line when pressing the left-arrow key at the start of a view line.
Public property | CanScrollPastDocumentEnd | Gets or sets whether it is possible to scroll past the end of the document.
Public property | Caret | Gets the ICaret that manages the blinking caret within the editor.
Public property | CaretBrush | Gets or sets the Brush to use for rendering the caret.
Public property | CharacterSpacing | Gets or sets the uniform spacing between characters, in units of 1/1000 of an em. (Inherited from Control.)
Public property | CharacterWidth | Gets the width of an average character.
Public property | Clip | Gets or sets the RectangleGeometry used to define the outline of the contents of a UIElement. (Inherited from UIElement.)
Public property | CompositeMode | Gets or sets a property that declares alternate composition and blending modes for the element in its parent layout and window. This is relevant for elements that are involved in a mixed XAML / Microsoft DirectX UI. (Inherited from UIElement.)
Public property | ContextFlyout | (Inherited from UIElement.)
Public property | DataContext | Gets or sets the data context for a FrameworkElement when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key that references the default style for the control. (Inherited from Control.)
Public property | DesiredSize | Gets the size that this UIElement computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | Document | Gets or sets the IEditorDocument being edited by the control.
Public property | ElementSoundMode | (Inherited from Control.)
Public property | ExitDisplayModeOnAccessKeyInvoked | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction in which text and other UI elements flow within any parent element that controls their layout. This property can be set to either LeftToRight or RightToLeft. Setting FlowDirection to RightToLeft on any element sets the alignment to the right, the reading order to right-to-left and the layout of the control to flow from right to left. (Inherited from FrameworkElement.)
Public property | FocusState | Gets a value that specifies whether this control has focus, and the mode by which focus was obtained. (Inherited from Control.)
Public property | FocusVisualMargin | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualPrimaryThickness | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryBrush | (Inherited from FrameworkElement.)
Public property | FocusVisualSecondaryThickness | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font used to display text in the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the size of the text in this control. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the style in which the text is rendered. (Inherited from Control.)
Public property | FontWeight | Gets or sets the thickness of the specified font. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | HighlightingStyleRegistry | Gets or sets the default IHighlightingStyleRegistry to use.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics that are applied to a FrameworkElement when it is composed in a layout parent, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | Gets or sets the ScrollBarVisibility that specifies the visibility of the horizontal ScrollBar.
Public property | IndicatorMarginBackground | Gets or sets the Brush to use when rendering the indicator margin background.
Public property | IntelliPrompt | Gets the IIntelliPromptManager that manages IntelliPrompt user interface functionality for this editor.
Public property | IsAccessKeyScope | (Inherited from UIElement.)
Public property | IsAutoCorrectEnabled | Gets or sets whether auto-correct, such as case correction, is enabled.
Public property | IsCollapsibleRegionHighlightingEnabled | Gets or sets whether collapsible regions highlight when the mouse is over the outlining margin.
Public property | IsCurrentLineHighlightingEnabled | Gets or sets whether current line highlighting is enabled for the active view.
Public property | IsDefaultContextMenuEnabled | Gets or sets whether the default context menu is enabled.
Public property | IsDelimiterAutoCompleteEnabled | Gets or sets whether delimiter auto-correct is enabled for the active view.
Public property | IsDelimiterHighlightingEnabled | Gets or sets whether delimiter highlighting is enabled for the active view.
Public property | IsDocumentReadOnly | Gets whether the attached document is read-only.
Public property | IsDoubleTapEnabled | Gets or sets a value that determines whether the DoubleTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether the user can interact with the control. (Inherited from Control.)
Public property | IsFocusEngaged | (Inherited from Control.)
Public property | IsFocusEngagementEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets whether the contained area of this UIElement can return true values for hit testing. (Inherited from UIElement.)
Public property | IsHoldingEnabled | Gets or sets a value that determines whether the Holding event can originate from that element. (Inherited from UIElement.)
Public property | IsIncrementalSearchResultHighlightingEnabled | Gets or sets whether incremental search result highlighting is enabled for the active view.
Public property | IsIndicatorMarginVisible | Gets or sets whether the indicator margin is visible.
Public property | IsLineNumberMarginVisible | Gets or sets whether the line number margin is visible.
Public property | IsMouseWheelZoomEnabled | Gets or sets whether holding Ctrl while scrolling the mouse wheel allows view zooming.
Public property | IsMultiLine | Gets or sets whether the editor allows multiple lines of text.
Public property | IsOutliningMarginVisible | Gets or sets whether the outlining margin is visible.
Public property | IsOverwriteModeActive | Gets or sets whether the editor is in overwrite mode, where typing overwrites the character at the caret's offset.
Public property | IsPointerOver | Gets whether the pointer is over the control.
Public property | IsRightTapEnabled | Gets or sets a value that determines whether the RightTapped event can originate from that element. (Inherited from UIElement.)
Public property | IsSelectionMarginVisible | Gets or sets whether the selection margin is visible.
Public property | IsSoftKeyboardEnabled | Gets or sets whether the soft keyboard is enabled when a view gets focus.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTapEnabled | Gets or sets a value that determines whether the Tapped event can originate from that element. (Inherited from UIElement.)
Public property | IsTextDataBindingEnabled | Gets or sets whether data binding on the Text property is currently enabled.
Public property | IsTextScaleFactorEnabled | (Inherited from Control.)
Public property | IsViewLineMeasureEnabled | Gets or sets whether the editor view lines are measured, allowing the editor to resize as text contents change.
Public property | IsWhitespaceVisible | Gets or sets whether whitespace (spaces and tabs) is visible.
Public property | IsWordWrapEnabled | Gets whether word wrap mode is currently enabled.
Public property | IsWordWrapGlyphMarginVisible | Gets whether the word wrap glyph margin is visible.
Public property | Language | Gets or sets localization/globalization language information that applies to a FrameworkElement, and also to all child elements of the current FrameworkElement in the object representation and in UI. (Inherited from FrameworkElement.)
Public property | LineNumberMarginBackground | Gets or sets the Brush to use when rendering the line number margin background.
Public property | LineNumberMarginFontFamily | Gets or sets the FontFamily to use when rendering line number margin text.
Public property | LineNumberMarginFontSize | Gets or sets the font size to use when rendering line number margin text.
Public property | LineNumberMarginForeground | Gets or sets the Brush to use when rendering line number margin text.
Public property | MacroRecording | Gets the IMacroRecording that manages macro recording and playback functionality.
Public property | ManipulationMode | Gets or sets the ManipulationModes value used for UIElement behavior and interaction with gestures. (Inherited from UIElement.)
Public property | Margin | Gets or sets the outer margin of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MaxZoomLevel | Gets or sets a percentage value indicating the maximum zoom level of editor view content.
Public property | MinHeight | Gets or sets the minimum height constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | MinZoomLevel | Gets or sets a percentage value indicating the minimum zoom level of editor view content.
Public property | Name | Gets or sets the identifying name of the object. When a XAML processor creates the object tree from XAML markup, run-time code can refer to the XAML-declared object by this name. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the degree of the object's opacity. (Inherited from UIElement.)
Public property | OutliningMarginBackground | Gets or sets the Brush to use when rendering the outlining margin background.
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the parent object of this FrameworkElement in the object tree. (Inherited from FrameworkElement.)
Public property | PointerCaptures | Gets the set of all captured pointers, represented as Pointer values. (Inherited from UIElement.)
Public property | PrintSettings | Gets or sets the IPrintSettings that provides access to all printing functionality.
Public property | Projection | Gets or sets the perspective projection (3-D effect) to apply when rendering this element. (Inherited from UIElement.)
Public property | RenderSize | Gets the final render size of a UIElement. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of a UIElement. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the origin point of any possible render transform declared by RenderTransform, relative to the bounds of the UIElement. (Inherited from UIElement.)
Public property | RequestedTheme | Gets or sets the UI theme that is used by the UIElement (and its child elements) for resource determination. The UI theme you specify with RequestedTheme can override the app-level RequestedTheme. (Inherited from FrameworkElement.)
Public property | RequiresPointer | (Inherited from Control.)
Public property | Resources | Gets the locally defined resource dictionary. In XAML, you can establish resource items as child object elements of a frameworkElement.Resources property element, through XAML implicit collection syntax. (Inherited from FrameworkElement.)
Public property | ScrollBarTrayBottomTemplate | Gets or sets the DataTemplate containing controls that are displayed under the vertical ScrollBar in an IEditorView.
Public property | ScrollBarTrayLeftTemplate | Gets or sets the DataTemplate containing controls that are displayed left of the horizontal ScrollBar in an IEditorView.
Public property | ScrollBarTrayRightTemplate | Gets or sets the DataTemplate containing controls that are displayed right of the horizontal ScrollBar in an IEditorView.
Public property | ScrollBarTrayTopTemplate | Gets or sets the DataTemplate containing controls that are displayed above the vertical ScrollBar in an IEditorView.
Public property | ScrollToCaretOnSelectAll | Gets or sets whether to scroll to the caret when selecting all text in a view.
Public property | SelectionBackgroundActive | Gets or sets the Brush to use for rendering the active selection background.
Public property | SelectionBackgroundInactive | Gets or sets the Brush to use for rendering the inactive selection background.
Public property | SelectionCollapsesOnCopy | Gets or sets whether the selection collapses when a copy operation occurs.
Public property | SelectionCollapsesToAnchor | Gets or sets whether the selection collapses to the anchor of the selection.
Public property | SelectionMarginBackground | Gets or sets the Brush to use when rendering the selection margin background.
Public property | SelectionModesAllowed | Gets or sets a SelectionModes value indicating the selection modes that are allowed within the editor.
Public property | Style | Gets or sets an instance Style that is applied for this object during layout and rendering. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by pressing the Tab key. (Inherited from Control.)
Public property | TabNavigation | Gets or sets a value that modifies how tabbing and TabIndex work for this control. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this object. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. The control template defines the visual appearance of a control in UI, and is defined in XAML markup. (Inherited from Control.)
Public property | Text | Gets or sets the complete document text within the editor. This property is created specifically for data binding, and be sure to see the remarks for important configuration and performance information.
Public property | Transform3D | (Inherited from UIElement.)
Public property | Transitions | Gets or sets the collection of Transition style elements that apply to a UIElement. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers for animations that are defined for a FrameworkElement. Not commonly used. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets or sets a value that determines whether rendering for the object and its visual subtree should use rounding behavior that aligns rendering to whole pixels. (Inherited from UIElement.)
Public property | UseSystemFocusVisuals | (Inherited from Control.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics that are applied to a FrameworkElement when it is composed in a parent object such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalScrollBarVisibility | Gets or sets the ScrollBarVisibility that specifies the visibility of the vertical ScrollBar.
Public property | ViewMarginFactories | Gets the collection that contains the IEditorViewMarginFactory objects used to generate the margins for an IEditorView.
Public property | Visibility | Gets or sets the visibility of a UIElement. A UIElement that is not visible is not rendered and does not communicate its desired size to layout. (Inherited from UIElement.)
Public property | VisibleWhitespaceForeground | Gets or sets the Brush to use when rendering visible whitespace.
Public property | Width | Gets or sets the width of a FrameworkElement. (Inherited from FrameworkElement.)
Public property | WordWrapGlyphMarginBackground | Gets or sets the Brush to use when rendering the word wrap glyph margin background.
Public property | WordWrapGlyphMarginForeground | Gets or sets the Brush to use when rendering the word wrap glyph margin foreground.
Public property | WordWrapMode | Gets or sets a WordWrapMode value indicating the type of word wrapping that is performed.
Public property | XYFocusDown | (Inherited from Control.)
Public property | XYFocusLeft | (Inherited from Control.)
Public property | XYFocusRight | (Inherited from Control.)
Public property | XYFocusUp | (Inherited from Control.)
Public property | ZoomAnimationDuration | Gets or sets the Duration to animate the scale from one zoom level to the next.
Public property | ZoomLevel | Gets or sets a percentage value indicating the zoom level of editor view content.
Public property | ZoomLevelAnimated | Gets or sets a percentage value indicating the current animated zoom level of editor view content.
Public property | ZoomLevelIncrement | Gets or sets the percentage increment by which the zoom level changes via the mouse wheel.
Top
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AcceptsTab Property

SyntaxEditorAcceptsTab Property
Gets or sets the Tab key is accepted, allowing for the insertion of tab stops and/or indenting blocks of text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AcceptsTab { get; set; }
Public Property AcceptsTab As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the tab key is accepted; otherwise, false. The default value is true.
Remarks
When this property is false, the Tab and Shift+Tab key shortcuts will move focus instead.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ActiveView Property

SyntaxEditorActiveView Property
Gets the currently-active IEditorView in the editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditorView ActiveView { get; }
Public ReadOnly Property ActiveView As IEditorView
    Get

Property Value

Type: IEditorView
The currently-active IEditorView in the editor.
Remarks
The currently-active view in the editor is the view that contains focus when focus is moved within the editor. There is always a single view in an editor marked as active.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreIndentationGuidesVisible Property

SyntaxEditorAreIndentationGuidesVisible Property
Gets or sets whether indentation guides are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreIndentationGuidesVisible { get; set; }
Public Property AreIndentationGuidesVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if indentation guides are visible; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreLineModificationMarksVisible Property

SyntaxEditorAreLineModificationMarksVisible Property
Gets or sets whether line modification marks are visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreLineModificationMarksVisible { get; set; }
Public Property AreLineModificationMarksVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if line modification marks are visible; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreSelectionGrippersEnabled Property

SyntaxEditorAreSelectionGrippersEnabled Property
Gets or sets whether selection grippers (when touching a view) are enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreSelectionGrippersEnabled { get; set; }
Public Property AreSelectionGrippersEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if selection grippers (when touching a view) are enabled; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreWordWrapGlyphsVisible Property

SyntaxEditorAreWordWrapGlyphsVisible Property
Gets or sets whether word wrap glyphs are visible when word wrap is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool AreWordWrapGlyphsVisible { get; set; }
Public Property AreWordWrapGlyphsVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if word wrap glyphs are visible when word wrap is enabled; otherwise, false. The default value is false.
Remarks
Set the WordWrapMode property to control to designate the current word wrap mode.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanBackspaceOverSpacesToTabStop Property

SyntaxEditorCanBackspaceOverSpacesToTabStop Property
Gets or sets whether a Backspace key pressed before the first non-whitespace character of a line will backspace to the previous tab stop.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanBackspaceOverSpacesToTabStop { get; set; }
Public Property CanBackspaceOverSpacesToTabStop As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a Backspace key pressed before the first non-whitespace character of a line will backspace to the previous tab stop; otherwise, false. The default value is true.
Remarks
This property is only used when AutoConvertTabsToSpaces is true. When this property is false, only one space character maximum will be consumed when backspacing before the first non-whitespace character of a line.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
ITextDocumentAutoConvertTabsToSpaces


SyntaxEditor.CanCutCopyBlankLineWhenNoSelection Property

SyntaxEditorCanCutCopyBlankLineWhenNoSelection Property
Gets or sets whether cut/copy operations on a blank line with no selection overwrites the clipboard with the blank line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCutCopyBlankLineWhenNoSelection { get; set; }
Public Property CanCutCopyBlankLineWhenNoSelection As Boolean
    Get
    Set

Property Value

Type: Boolean
true if cut/copy operations on a blank line with no selection overwrites the clipboard with the blank line; otherwise, false. The default value is true.
Remarks
When there is no selection in the editor and a cut or copy operation occurs, the text of the current line will be sent to the clipboard. If the text is subsequently pasted back into the editor while there is no selection, a new link will be created to insert the clipboard data and the caret will not move. Even if this property is false, cutting of blank lines will occur but the clipboard will not be changed.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanCutCopyDragWithHtml Property

SyntaxEditorCanCutCopyDragWithHtml Property
Gets or sets whether the cutting and copying of text to the clipboard or dragging text also copies the text in HTML format, which retains syntax highlighting.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCutCopyDragWithHtml { get; set; }
Public Property CanCutCopyDragWithHtml As Boolean
    Get
    Set

Property Value

Type: Boolean
true if HTML format is included; otherwise, false. The default value is false.
Remarks
Activating this feature will cause a slight delay when cutting, copying, or dragging text since the building of HTML formatted text can take time. However most likely this delay will be negligible.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanCutCopyDragWithRtf Property

SyntaxEditorCanCutCopyDragWithRtf Property
Gets or sets whether the cutting and copying of text to the clipboard or dragging text also copies the text in RTF format, which retains syntax highlighting.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanCutCopyDragWithRtf { get; set; }
Public Property CanCutCopyDragWithRtf As Boolean
    Get
    Set

Property Value

Type: Boolean
true if RTF format is included; otherwise, false. The default value is true.
Remarks
Activating this feature will cause a slight delay when cutting, copying, or dragging text since the building of RTF formatted text can take time. However most likely this delay will be negligible.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanIncrementalSearchTrimUnmatchedFindText Property

SyntaxEditorCanIncrementalSearchTrimUnmatchedFindText Property
Gets or sets whether incremental search can ignore typed characters appended to the find text when no match was found for the previous find text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanIncrementalSearchTrimUnmatchedFindText { get; set; }
Public Property CanIncrementalSearchTrimUnmatchedFindText As Boolean
    Get
    Set

Property Value

Type: Boolean
true if incremental search can ignore typed characters appended to the find text when no match was found for the previous find text; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanMoveCaretOnMouseRightClick Property

SyntaxEditorCanMoveCaretOnMouseRightClick Property
Gets or sets whether to move the caret when a view is right-clicked by the mouse (outside of the current selection).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveCaretOnMouseRightClick { get; set; }
Public Property CanMoveCaretOnMouseRightClick As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret should move when a view is right-clicked by the mouse; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanMoveCaretToNextLineAtLineEnd Property

SyntaxEditorCanMoveCaretToNextLineAtLineEnd Property
Gets or sets whether to move the caret to the next view line when pressing the right-arrow key at the end of a view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveCaretToNextLineAtLineEnd { get; set; }
Public Property CanMoveCaretToNextLineAtLineEnd As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret should move to the next view line when pressing the right-arrow key at the end of a view line; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanMoveCaretToPreviousLineAtLineStart Property

SyntaxEditorCanMoveCaretToPreviousLineAtLineStart Property
Gets or sets whether to move the caret to the previous view line when pressing the left-arrow key at the start of a view line.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanMoveCaretToPreviousLineAtLineStart { get; set; }
Public Property CanMoveCaretToPreviousLineAtLineStart As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the caret should move to the previous view line when pressing the left-arrow key at the start of a view line; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanScrollPastDocumentEnd Property

SyntaxEditorCanScrollPastDocumentEnd Property
Gets or sets whether it is possible to scroll past the end of the document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool CanScrollPastDocumentEnd { get; set; }
Public Property CanScrollPastDocumentEnd As Boolean
    Get
    Set

Property Value

Type: Boolean
true if it is possible to scroll past the end of the document; otherwise, false. The default value is false.
Remarks
When this property is set to true, the vertical scrollbar allows scrolling of the last line of the document up to the first view line in the view.

This property has no effect when word wrap mode is active.

See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.Caret Property

SyntaxEditorCaret Property
Gets the ICaret that manages the blinking caret within the editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ICaret Caret { get; }
Public ReadOnly Property Caret As ICaret
    Get

Property Value

Type: ICaret
The ICaret that manages the blinking caret within the editor.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CaretBrush Property

SyntaxEditorCaretBrush Property
Gets or sets the Brush to use for rendering the caret.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush CaretBrush { get; set; }
Public Property CaretBrush As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering the caret.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CharacterWidth Property

SyntaxEditorCharacterWidth Property
Gets the width of an average character.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double CharacterWidth { get; }
Public ReadOnly Property CharacterWidth As Double
    Get

Property Value

Type: Double
The width of an average character.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.Document Property

SyntaxEditorDocument Property
Gets or sets the IEditorDocument being edited by the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditorDocument Document { get; set; }
Public Property Document As IEditorDocument
    Get
    Set

Property Value

Type: IEditorDocument
The IEditorDocument being edited by the control.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.HighlightingStyleRegistry Property

SyntaxEditorHighlightingStyleRegistry Property
Gets or sets the default IHighlightingStyleRegistry to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHighlightingStyleRegistry HighlightingStyleRegistry { get; set; }
Public Property HighlightingStyleRegistry As IHighlightingStyleRegistry
    Get
    Set

Property Value

Type: IHighlightingStyleRegistry
The default IHighlightingStyleRegistry to use.
Remarks
If this property is , the AmbientHighlightingStyleRegistry will be used.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.HorizontalScrollBarVisibility Property

SyntaxEditorHorizontalScrollBarVisibility Property
Gets or sets the ScrollBarVisibility that specifies the visibility of the horizontal ScrollBar.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility
    Get
    Set

Property Value

Type: ScrollBarVisibility
The ScrollBarVisibility that specifies the visibility of the horizontal ScrollBar. The default value is Visible.
Remarks
Visible and Auto always show the ScrollBar. Hidden and Disabled always hide the ScrollBar.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IndicatorMarginBackground Property

SyntaxEditorIndicatorMarginBackground Property
Gets or sets the Brush to use when rendering the indicator margin background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush IndicatorMarginBackground { get; set; }
Public Property IndicatorMarginBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering the indicator margin background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IntelliPrompt Property

SyntaxEditorIntelliPrompt Property
Gets the IIntelliPromptManager that manages IntelliPrompt user interface functionality for this editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IIntelliPromptManager IntelliPrompt { get; }
Public ReadOnly Property IntelliPrompt As IIntelliPromptManager
    Get

Property Value

Type: IIntelliPromptManager
The IIntelliPromptManager that manages IntelliPrompt user interface functionality for this editor.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsAutoCorrectEnabled Property

SyntaxEditorIsAutoCorrectEnabled Property
Gets or sets whether auto-correct, such as case correction, is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsAutoCorrectEnabled { get; set; }
Public Property IsAutoCorrectEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if auto-correct, such as case correction, is enabled; otherwise, false. The default value is true.
Remarks
Note that the auto correct feature requires that the current language have an IAutoCorrector service registered, along with other possible requirements.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsCollapsibleRegionHighlightingEnabled Property

SyntaxEditorIsCollapsibleRegionHighlightingEnabled Property
Gets or sets whether collapsible regions highlight when the mouse is over the outlining margin.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCollapsibleRegionHighlightingEnabled { get; set; }
Public Property IsCollapsibleRegionHighlightingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if collapsible regions highlight when the mouse is over the outlining margin; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsCurrentLineHighlightingEnabled Property

SyntaxEditorIsCurrentLineHighlightingEnabled Property
Gets or sets whether current line highlighting is enabled for the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsCurrentLineHighlightingEnabled { get; set; }
Public Property IsCurrentLineHighlightingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if current line highlighting is enabled for the active view; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDefaultContextMenuEnabled Property

SyntaxEditorIsDefaultContextMenuEnabled Property
Gets or sets whether the default context menu is enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDefaultContextMenuEnabled { get; set; }
Public Property IsDefaultContextMenuEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the default context menu is enabled; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDelimiterAutoCompleteEnabled Property

SyntaxEditorIsDelimiterAutoCompleteEnabled Property
Gets or sets whether delimiter auto-correct is enabled for the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDelimiterAutoCompleteEnabled { get; set; }
Public Property IsDelimiterAutoCompleteEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if delimiter auto-correct is enabled for the active view; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDelimiterHighlightingEnabled Property

SyntaxEditorIsDelimiterHighlightingEnabled Property
Gets or sets whether delimiter highlighting is enabled for the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDelimiterHighlightingEnabled { get; set; }
Public Property IsDelimiterHighlightingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if delimiter highlighting is enabled for the active view; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDocumentReadOnly Property

SyntaxEditorIsDocumentReadOnly Property
Gets whether the attached document is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsDocumentReadOnly { get; }
Public ReadOnly Property IsDocumentReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if attached document is read-only; otherwise, false. The default value is false.
Remarks
Use the ITextDocument.IsReadOnly property to alter this value.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsIncrementalSearchResultHighlightingEnabled Property

SyntaxEditorIsIncrementalSearchResultHighlightingEnabled Property
Gets or sets whether incremental search result highlighting is enabled for the active view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsIncrementalSearchResultHighlightingEnabled { get; set; }
Public Property IsIncrementalSearchResultHighlightingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if incremental search result highlighting is enabled for the active view; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsIndicatorMarginVisible Property

SyntaxEditorIsIndicatorMarginVisible Property
Gets or sets whether the indicator margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsIndicatorMarginVisible { get; set; }
Public Property IsIndicatorMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the indicator margin is visible; otherwise, false. The default value is false.
Remarks
This property is only effective if the default indicator margin is created by the ViewMarginFactories currently in use.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsLineNumberMarginVisible Property

SyntaxEditorIsLineNumberMarginVisible Property
Gets or sets whether the line number margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLineNumberMarginVisible { get; set; }
Public Property IsLineNumberMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the line number margin is visible; otherwise, false. The default value is false.
Remarks
This property is only effective if the default line number margin is created by the ViewMarginFactories currently in use.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsMouseWheelZoomEnabled Property

SyntaxEditorIsMouseWheelZoomEnabled Property
Gets or sets whether holding Ctrl while scrolling the mouse wheel allows view zooming.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMouseWheelZoomEnabled { get; set; }
Public Property IsMouseWheelZoomEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the mouse wheel zooming is enabled; otherwise, false. The default value is true.
Remarks
Mouse wheel zooming occurs at 0.25 (25%) increments so plan your MinZoomLevel and MaxZoomLevel settings in increments of 0.25 for best results.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsMultiLine Property

SyntaxEditorIsMultiLine Property
Gets or sets whether the editor allows multiple lines of text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsMultiLine { get; set; }
Public Property IsMultiLine As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the editor allows multiple lines of text; otherwise, false. The default value is true.
Remarks
When this property is false, only a single line of text is permitted in the document and the editor renders like a native WPF single-line textbox.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsOutliningMarginVisible Property

SyntaxEditorIsOutliningMarginVisible Property
Gets or sets whether the outlining margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOutliningMarginVisible { get; set; }
Public Property IsOutliningMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the outlining margin is visible; otherwise, false. The default value is true.
Remarks
This property is only effective if the default outlining margin is created by the ViewMarginFactories currently in use.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsOverwriteModeActive Property

SyntaxEditorIsOverwriteModeActive Property
Gets or sets whether the editor is in overwrite mode, where typing overwrites the character at the caret's offset.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsOverwriteModeActive { get; set; }
Public Property IsOverwriteModeActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the editor is in overwrite mode; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsPointerOver Property

SyntaxEditorIsPointerOver Property
Gets whether the pointer is over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsPointerOver { get; set; }
Public Property IsPointerOver As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the pointer is over the control; otherwise, false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsSelectionMarginVisible Property

SyntaxEditorIsSelectionMarginVisible Property
Gets or sets whether the selection margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelectionMarginVisible { get; set; }
Public Property IsSelectionMarginVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the selection margin is visible; otherwise, false. The default value is true.
Remarks
This property is only effective if the default selection margin is created by the ViewMarginFactories currently in use.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsSoftKeyboardEnabled Property

SyntaxEditorIsSoftKeyboardEnabled Property
Gets or sets whether the soft keyboard is enabled when a view gets focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSoftKeyboardEnabled { get; set; }
Public Property IsSoftKeyboardEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the the soft keyboard is enabled when a view gets focus; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsTextDataBindingEnabled Property

SyntaxEditorIsTextDataBindingEnabled Property
Gets or sets whether data binding on the Text property is currently enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsTextDataBindingEnabled { get; set; }
Public Property IsTextDataBindingEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if data binding on the Text property is currently enabled; otherwise, false. The default value is false.
Remarks

Data binding is off by default on the Text property for two reasons. First, supporting the Text dependency property means that two full copies of the document text are stored in memory instead of one, which can increase memory a lot for large documents. Second, the full text must be set to the dependency property after each text change, meaning performance could suffer depending on the size of the document.

It is recommended to only set IsTextDataBindingEnabled to true when data binding is required, and note that the IsTextDataBindingEnabled property must be set before creating a binding on the Text property.

See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsViewLineMeasureEnabled Property

SyntaxEditorIsViewLineMeasureEnabled Property
Gets or sets whether the editor view lines are measured, allowing the editor to resize as text contents change.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsViewLineMeasureEnabled { get; set; }
Public Property IsViewLineMeasureEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the editor view lines can be measured; otherwise, false. The default value is false.
Remarks
This property affects performance and should only be set to true in specific scenarios where it is desired for the editor to resize based on contents, such as when used within a StackPanel.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsWhitespaceVisible Property

SyntaxEditorIsWhitespaceVisible Property
Gets or sets whether whitespace (spaces and tabs) is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWhitespaceVisible { get; set; }
Public Property IsWhitespaceVisible As Boolean
    Get
    Set

Property Value

Type: Boolean
true if whitespace (spaces and tabs) is visible; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsWordWrapEnabled Property

SyntaxEditorIsWordWrapEnabled Property
Gets whether word wrap mode is currently enabled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWordWrapEnabled { get; }
Public ReadOnly Property IsWordWrapEnabled As Boolean
    Get

Property Value

Type: Boolean
true if word wrap mode is currently enabled; otherwise, false. The default value is false.
Remarks
Set the WordWrapMode property to control to designate the current word wrap mode.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsWordWrapGlyphMarginVisible Property

SyntaxEditorIsWordWrapGlyphMarginVisible Property
Gets whether the word wrap glyph margin is visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsWordWrapGlyphMarginVisible { get; }
Public ReadOnly Property IsWordWrapGlyphMarginVisible As Boolean
    Get

Property Value

Type: Boolean
true if the word wrap glyph margin is visible; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginBackground Property

SyntaxEditorLineNumberMarginBackground Property
Gets or sets the Brush to use when rendering the line number margin background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineNumberMarginBackground { get; set; }
Public Property LineNumberMarginBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering the line number margin background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginFontFamily Property

SyntaxEditorLineNumberMarginFontFamily Property
Gets or sets the FontFamily to use when rendering line number margin text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FontFamily LineNumberMarginFontFamily { get; set; }
Public Property LineNumberMarginFontFamily As FontFamily
    Get
    Set

Property Value

Type: FontFamily
The FontFamily to use when rendering line number margin text. The default value is Consolas, using Courier New if Consolas is not available.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginFontSize Property

SyntaxEditorLineNumberMarginFontSize Property
Gets or sets the font size to use when rendering line number margin text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double LineNumberMarginFontSize { get; set; }
Public Property LineNumberMarginFontSize As Double
    Get
    Set

Property Value

Type: Double
The font size to use when rendering line number margin text. The default value is 12.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginForeground Property

SyntaxEditorLineNumberMarginForeground Property
Gets or sets the Brush to use when rendering line number margin text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush LineNumberMarginForeground { get; set; }
Public Property LineNumberMarginForeground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering line number margin text.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.MacroRecording Property

SyntaxEditorMacroRecording Property
Gets the IMacroRecording that manages macro recording and playback functionality.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IMacroRecording MacroRecording { get; }
Public ReadOnly Property MacroRecording As IMacroRecording
    Get

Property Value

Type: IMacroRecording
The IMacroRecording that manages macro recording and playback functionality.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.MaxZoomLevel Property

SyntaxEditorMaxZoomLevel Property
Gets or sets a percentage value indicating the maximum zoom level of editor view content.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MaxZoomLevel { get; set; }
Public Property MaxZoomLevel As Double
    Get
    Set

Property Value

Type: Double
A percentage value indicating the maximum zoom level of editor view content. The default value is 3.0, meaning 300%.
Remarks
Set the IsMouseWheelZoomEnabled property to true to allow end user zooming when Ctrl is held and the mouse wheel is turned.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
SyntaxEditorIsMouseWheelZoomEnabled
SyntaxEditorMinZoomLevel
SyntaxEditorZoomLevel


SyntaxEditor.MinZoomLevel Property

SyntaxEditorMinZoomLevel Property
Gets or sets a percentage value indicating the minimum zoom level of editor view content.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double MinZoomLevel { get; set; }
Public Property MinZoomLevel As Double
    Get
    Set

Property Value

Type: Double
A percentage value indicating the minimum zoom level of editor view content. The default value is 0.5, meaning 50%.
Remarks
Set the IsMouseWheelZoomEnabled property to true to allow end user zooming when Ctrl is held and the mouse wheel is turned.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
SyntaxEditorIsMouseWheelZoomEnabled
SyntaxEditorMaxZoomLevel
SyntaxEditorZoomLevel


SyntaxEditor.OutliningMarginBackground Property

SyntaxEditorOutliningMarginBackground Property
Gets or sets the Brush to use when rendering the outlining margin background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush OutliningMarginBackground { get; set; }
Public Property OutliningMarginBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering the outlining margin background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.PrintSettings Property

SyntaxEditorPrintSettings Property
Gets or sets the IPrintSettings that provides access to all printing functionality.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IPrintSettings PrintSettings { get; set; }
Public Property PrintSettings As IPrintSettings
    Get
    Set

Property Value

Type: IPrintSettings
The IPrintSettings that provides access to all printing functionality.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayBottomTemplate Property

SyntaxEditorScrollBarTrayBottomTemplate Property
Gets or sets the DataTemplate containing controls that are displayed under the vertical ScrollBar in an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollBarTrayBottomTemplate { get; set; }
Public Property ScrollBarTrayBottomTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing controls that are displayed under the vertical ScrollBar in an IEditorView.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayLeftTemplate Property

SyntaxEditorScrollBarTrayLeftTemplate Property
Gets or sets the DataTemplate containing controls that are displayed left of the horizontal ScrollBar in an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollBarTrayLeftTemplate { get; set; }
Public Property ScrollBarTrayLeftTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing controls that are displayed left of the horizontal ScrollBar in an IEditorView.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayRightTemplate Property

SyntaxEditorScrollBarTrayRightTemplate Property
Gets or sets the DataTemplate containing controls that are displayed right of the horizontal ScrollBar in an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollBarTrayRightTemplate { get; set; }
Public Property ScrollBarTrayRightTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing controls that are displayed right of the horizontal ScrollBar in an IEditorView.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayTopTemplate Property

SyntaxEditorScrollBarTrayTopTemplate Property
Gets or sets the DataTemplate containing controls that are displayed above the vertical ScrollBar in an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public DataTemplate ScrollBarTrayTopTemplate { get; set; }
Public Property ScrollBarTrayTopTemplate As DataTemplate
    Get
    Set

Property Value

Type: DataTemplate
The DataTemplate containing controls that are displayed above the vertical ScrollBar in an IEditorView.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollToCaretOnSelectAll Property

SyntaxEditorScrollToCaretOnSelectAll Property
Gets or sets whether to scroll to the caret when selecting all text in a view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool ScrollToCaretOnSelectAll { get; set; }
Public Property ScrollToCaretOnSelectAll As Boolean
    Get
    Set

Property Value

Type: Boolean
true if a view should scroll to the caret when selecting all its text; otherwise, false. The default value is true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionBackgroundActive Property

SyntaxEditorSelectionBackgroundActive Property
Gets or sets the Brush to use for rendering the active selection background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SelectionBackgroundActive { get; set; }
Public Property SelectionBackgroundActive As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering the active selection background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionBackgroundInactive Property

SyntaxEditorSelectionBackgroundInactive Property
Gets or sets the Brush to use for rendering the inactive selection background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SelectionBackgroundInactive { get; set; }
Public Property SelectionBackgroundInactive As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use for rendering the inactive selection background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionCollapsesOnCopy Property

SyntaxEditorSelectionCollapsesOnCopy Property
Gets or sets whether the selection collapses when a copy operation occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SelectionCollapsesOnCopy { get; set; }
Public Property SelectionCollapsesOnCopy As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the selection collapses when a copy operation occurs; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionCollapsesToAnchor Property

SyntaxEditorSelectionCollapsesToAnchor Property
Gets or sets whether the selection collapses to the anchor of the selection.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool SelectionCollapsesToAnchor { get; set; }
Public Property SelectionCollapsesToAnchor As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the selection collapses to the anchor of the selection; otherwise, false. The default value is false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionMarginBackground Property

SyntaxEditorSelectionMarginBackground Property
Gets or sets the Brush to use when rendering the selection margin background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush SelectionMarginBackground { get; set; }
Public Property SelectionMarginBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering the selection margin background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionModesAllowed Property

SyntaxEditorSelectionModesAllowed Property
Gets or sets a SelectionModes value indicating the selection modes that are allowed within the editor.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public SelectionModes SelectionModesAllowed { get; set; }
Public Property SelectionModesAllowed As SelectionModes
    Get
    Set

Property Value

Type: SelectionModes
A SelectionModes value indicating the selection modes that are allowed within the editor. The default value is Block and ContinuousStream.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.Text Property

SyntaxEditorText Property
Gets or sets the complete document text within the editor. This property is created specifically for data binding, and be sure to see the remarks for important configuration and performance information.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set

Property Value

Type: String
The complete document text within the editor.
Remarks

Every time the getter of this property is called, the text of the document is reconstructed. Every call to the setter, sets the complete document text. Therefore many calls to this property can be a performance bottleneck.

Data binding is off by default on the Text property for two reasons. First, supporting the Text dependency property means that two full copies of the document text are stored in memory instead of one, which can increase memory a lot for large documents. Second, the full text must be set to the dependency property after each text change, meaning performance could suffer depending on the size of the document.

Data binding can be enabled by setting the IsTextDataBindingEnabled property to true. It is recommended to only set IsTextDataBindingEnabled to true when data binding is required, and note that the IsTextDataBindingEnabled property must be set before creating a binding on the Text property.

When IsTextDataBindingEnabled is false, the TextProperty dependency property is not used and text is get/set directly from the document.

To properly get text substrings from the document, get the current ITextSnapshot from ITextDocument.CurrentSnapshot and use the GetSubstring(Int32, Int32) method. Likewise, to determine document length, use the ITextSnapshot.Length property.

Programmatic document updates should be performed using methods on ITextDocument.

See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.VerticalScrollBarVisibility Property

SyntaxEditorVerticalScrollBarVisibility Property
Gets or sets the ScrollBarVisibility that specifies the visibility of the vertical ScrollBar.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
    Get
    Set

Property Value

Type: ScrollBarVisibility
The ScrollBarVisibility that specifies the visibility of the vertical ScrollBar. The default value is Visible.
Remarks
Visible and Auto always show the ScrollBar. Hidden and Disabled always hide the ScrollBar.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ViewMarginFactories Property

SyntaxEditorViewMarginFactories Property
Gets the collection that contains the IEditorViewMarginFactory objects used to generate the margins for an IEditorView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEditorViewMarginFactoryCollection ViewMarginFactories { get; }
Public ReadOnly Property ViewMarginFactories As IEditorViewMarginFactoryCollection
    Get

Property Value

Type: IEditorViewMarginFactoryCollection
A IEditorViewMarginFactoryCollection that contains the factories. The default collection contains a DefaultEditorViewMarginFactory.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.VisibleWhitespaceForeground Property

SyntaxEditorVisibleWhitespaceForeground Property
Gets or sets the Brush to use when rendering visible whitespace.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush VisibleWhitespaceForeground { get; set; }
Public Property VisibleWhitespaceForeground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering visible whitespace.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.WordWrapGlyphMarginBackground Property

SyntaxEditorWordWrapGlyphMarginBackground Property
Gets or sets the Brush to use when rendering the word wrap glyph margin background.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush WordWrapGlyphMarginBackground { get; set; }
Public Property WordWrapGlyphMarginBackground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering the word wrap glyph margin background.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.WordWrapGlyphMarginForeground Property

SyntaxEditorWordWrapGlyphMarginForeground Property
Gets or sets the Brush to use when rendering the word wrap glyph margin foreground.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Brush WordWrapGlyphMarginForeground { get; set; }
Public Property WordWrapGlyphMarginForeground As Brush
    Get
    Set

Property Value

Type: Brush
The Brush to use when rendering the word wrap glyph margin foreground.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.WordWrapMode Property

SyntaxEditorWordWrapMode Property
Gets or sets a WordWrapMode value indicating the type of word wrapping that is performed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public WordWrapMode WordWrapMode { get; set; }
Public Property WordWrapMode As WordWrapMode
    Get
    Set

Property Value

Type: WordWrapMode
A WordWrapMode value indicating the type of word wrapping that is performed. The default value is WordWrapMode.None.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ZoomAnimationDuration Property

SyntaxEditorZoomAnimationDuration Property
Gets or sets the Duration to animate the scale from one zoom level to the next.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Duration ZoomAnimationDuration { get; set; }
Public Property ZoomAnimationDuration As Duration
    Get
    Set

Property Value

Type: Duration
The Duration to animate the scale from one zoom level to the next. The default value is 300ms.
Remarks
Set to 0ms or Duration.Automatic to disable zoom animation.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
SyntaxEditorZoomLevel


SyntaxEditor.ZoomLevel Property

SyntaxEditorZoomLevel Property
Gets or sets a percentage value indicating the zoom level of editor view content.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ZoomLevel { get; set; }
Public Property ZoomLevel As Double
    Get
    Set

Property Value

Type: Double
A percentage value indicating the zoom level of editor view content. The default value is 1.0, meaning 100%.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
SyntaxEditorIsMouseWheelZoomEnabled
SyntaxEditorMinZoomLevel
SyntaxEditorMaxZoomLevel
SyntaxEditorZoomAnimationDuration


SyntaxEditor.ZoomLevelAnimated Property

SyntaxEditorZoomLevelAnimated Property
Gets or sets a percentage value indicating the current animated zoom level of editor view content.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ZoomLevelAnimated { get; set; }
Public Property ZoomLevelAnimated As Double
    Get
    Set

Property Value

Type: Double
A percentage value indicating the current animated zoom level of editor view content.
Remarks
Never set this property directly. Use the ZoomLevel property instead.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ZoomLevelIncrement Property

SyntaxEditorZoomLevelIncrement Property
Gets or sets the percentage increment by which the zoom level changes via the mouse wheel.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double ZoomLevelIncrement { get; set; }
Public Property ZoomLevelIncrement As Double
    Get
    Set

Property Value

Type: Double
The percentage increment by which the zoom level changes via the mouse wheel. The default value is 0.25, meaning 25% increments.
Remarks
This value is only used when IsMouseWheelZoomEnabled is set to true.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace
SyntaxEditorIsMouseWheelZoomEnabled
SyntaxEditorZoomLevel


SyntaxEditor Methods

SyntaxEditor Methods

The SyntaxEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked even if the event is handled elsewhere. (Inherited from UIElement.)
Public method | ApplyTemplate | Loads the relevant control template so that its parts can be referenced. (Inherited from Control.)
Public method | Arrange | Positions child objects and determines a size for a UIElement. Parent objects that implement custom layout for their child elements should call this method from their layout override implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Provides the behavior for the Arrange pass of layout. Classes can override this method to define their own Arrange pass behavior. (Inherited from FrameworkElement.)
Public method | CancelDirectManipulations | Cancels ongoing direct manipulation processing (system-defined panning/zooming) on any ScrollViewer parent that contains the current UIElement. (Inherited from UIElement.)
Public method | CapturePointer | Sets pointer capture to a UIElement. Once captured, only the element that has capture will fire pointer-related events. (Inherited from UIElement.)
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Protected method | CreateDefaultContextMenu | Creates the default MenuFlyout.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | FindName | Retrieves an object that has the specified identifier name. (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | Enables a UIElement subclass to expose child elements that assist with resolving touch targeting. (Inherited from UIElement.)
Public method | Focus | Attempts to set the focus on the control. (Inherited from Control.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetTemplateChild | Retrieves the named element in the instantiated ControlTemplate visual tree. (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Protected method | GoToElementStateCore | When implemented in a derived class, enables per-state construction of a visual tree for a control template in code, rather than by loading XAML for all states at control startup. (Inherited from FrameworkElement.)
Public method | HitTest | Performs a hit test of the specified Point within the editor and returns detailed results in an IHitTestResult.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for a UIElement. After the invalidation, the UIElement will have its layout updated, which will occur asynchronously. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for a UIElement. (Inherited from UIElement.)
Public method | InvalidateViews | Invalidates the views and redraws them.
Public method | IsSelectionModeAllowed | Gets whether the specified SelectionModes value is allowed.
Public method | Measure | Updates the DesiredSize of a UIElement. Typically, objects that implement custom layout for their layout children call this method from their own MeasureOverride implementations to form a recursive layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Provides the behavior for the Measure pass of the layout cycle. Classes can override this method to define their own Measure pass behavior. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the automation infrastructure. (Overrides UIElementOnCreateAutomationPeer.)
Protected method | OnCutCopyDrag | Invoked when an unhandled CutCopyDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnDisconnectVisualChildren | Override this method to implement how layout and logic should behave when items are removed from a class-specific content or children property. (Inherited from UIElement.)
Protected method | OnDocumentChanged | Invoked when an unhandled DocumentChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnDoubleTapped | Called before the DoubleTapped event occurs. (Inherited from Control.)
Protected method | OnDragEnter | Called before the DragEnter event occurs. (Inherited from Control.)
Protected method | OnDragLeave | Called before the DragLeave event occurs. (Inherited from Control.)
Protected method | OnDragOver | Called before the DragOver event occurs. (Inherited from Control.)
Protected method | OnDrop | Called before the Drop event occurs. (Inherited from Control.)
Protected method | OnGotFocus | Occurs after the control gains focus. (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnHolding | Called before the Holding event occurs. (Inherited from Control.)
Protected method | OnIsOverwriteModeActiveChanged | Invoked when an unhandled IsOverwriteModeActiveChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Overrides ControlOnKeyDown(KeyRoutedEventArgs).)
Protected method | OnKeyUp | Called before the KeyUp event occurs. (Inherited from Control.)
Protected method | OnLostFocus | Called before the LostFocus event occurs. (Inherited from Control.)
Protected method | OnMacroRecordingStateChanged | Invoked when an unhandled MacroRecordingStateChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnManipulationCompleted | Called before the ManipulationCompleted event occurs. (Inherited from Control.)
Protected method | OnManipulationDelta | Called before the ManipulationDelta event occurs. (Inherited from Control.)
Protected method | OnManipulationInertiaStarting | Called before the ManipulationInertiaStarting event occurs. (Inherited from Control.)
Protected method | OnManipulationStarted | Called before the ManipulationStarted event occurs. (Inherited from Control.)
Protected method | OnManipulationStarting | Called before the ManipulationStarting event occurs. (Inherited from Control.)
Protected method | OnPasteDragDrop | Invoked when an unhandled PasteDragDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnPointerCanceled | Called before the PointerCanceled event occurs. (Inherited from Control.)
Protected method | OnPointerCaptureLost | Called before the PointerCaptureLost event occurs. (Inherited from Control.)
Protected method | OnPointerEntered | Invoked when an unhandled pointer enter attached event is raised on this element. Implement this method to add class handling for this event. (Overrides ControlOnPointerEntered(PointerRoutedEventArgs).)
Protected method | OnPointerExited | Invoked when an unhandled pointer leave attached event is raised on this element. Implement this method to add class handling for this event. (Overrides ControlOnPointerExited(PointerRoutedEventArgs).)
Protected method | OnPointerMoved | Called before the PointerMoved event occurs. (Inherited from Control.)
Protected method | OnPointerPressed | Called before the PointerPressed event occurs. (Inherited from Control.)
Protected method | OnPointerReleased | Called before the PointerReleased event occurs. (Inherited from Control.)
Protected method | OnPointerWheelChanged | Called before the PointerWheelChanged event occurs. (Inherited from Control.)
Protected method | OnRightTapped | Occurs when the pointer is right tapped over the control. (Overrides ControlOnRightTapped(RightTappedRoutedEventArgs).)
Protected method | OnTapped | Called before the Tapped event occurs. (Inherited from Control.)
Protected method | OnUserInterfaceUpdate | Invoked when an unhandled UserInterfaceUpdate attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewClosed | Invoked when an unhandled ViewClosed attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewIsIncrementalSearchActiveChanged | Invoked when an unhandled ViewIsIncrementalSearchActiveChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewOpened | Invoked when an unhandled ViewOpened attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewSearch | Invoked when an unhandled ViewSearch attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Protected method | OnViewSelectionChanged | Invoked when an unhandled ViewSelectionChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | Releases pointer captures for capture of one specific pointer by this UIElement. (Inherited from UIElement.)
Public method | ReleasePointerCaptures | Releases all pointer captures held by this element. (Inherited from UIElement.)
Public method | RemoveFocusEngagement | (Inherited from Control.)
Public method | RemoveHandler | Removes the specified routed event handler from this UIElement. Typically the handler in question was added by AddHandler. (Inherited from UIElement.)
Public method | ResetViews | Resets the splits and creates an initial view.
Public method | SetBinding | Attaches a binding to a FrameworkElement, using the provided binding object. (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | StartDragAsync | (Inherited from UIElement.)
Public method | ToString | (Inherited from Object.)
Public method | TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object. (Inherited from UIElement.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | UpdateLayout | Ensures that all positions of child objects of a UIElement are properly updated for layout. (Inherited from UIElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AnimateDoubleProperty | Animates a Double-based property to a value. (Defined by FrameworkElementExtensions.)
Public Extension Method | BindToProperty | Binds a dependency property to a property on the specified source. (Defined by FrameworkElementExtensions.)
Public Extension Method | BringIntoView | Brings the element into view. (Defined by FrameworkElementExtensions.)
Public Extension Method | FindResource | Locates a resource with the specified resource key and throws an exception if one is not found. (Defined by UIElementExtensions.)
Public Extension Method | Focus | Focuses the control. (Defined by FrameworkElementExtensions.)
Public Extension Method | GetCurrentSize | Returns the element's current size. (Defined by FrameworkElementExtensions.)
Public Extension Method | TryFindResource | Tries to locate a resource with the specified resource key. (Defined by UIElementExtensions.)
Top
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CreateDefaultContextMenu Method

SyntaxEditorCreateDefaultContextMenu Method
Creates the default MenuFlyout.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual MenuFlyout CreateDefaultContextMenu()
Protected Overridable Function CreateDefaultContextMenu As MenuFlyout

Return Value

Type: MenuFlyout
The default MenuFlyout to use.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.HitTest Method

SyntaxEditorHitTest Method
Performs a hit test of the specified Point within the editor and returns detailed results in an IHitTestResult.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IHitTestResult HitTest(
    Point point
)
Public Function HitTest (
    point As Point
) As IHitTestResult

Parameters

point
Type: Windows.FoundationPoint
The Point to hit test, relative to editor's coordinates.

Return Value

Type: IHitTestResult
An IHitTestResult that contains the hit test results.
Remarks
Use Mouse.GetPosition(editor) to get a mouse Point relative to the editor.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.InvalidateViews Method

SyntaxEditorInvalidateViews Method
Invalidates the views and redraws them.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void InvalidateViews()
Public Sub InvalidateViews
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsSelectionModeAllowed Method

SyntaxEditorIsSelectionModeAllowed Method
Gets whether the specified SelectionModes value is allowed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsSelectionModeAllowed(
    SelectionModes mode
)
Public Function IsSelectionModeAllowed (
    mode As SelectionModes
) As Boolean

Parameters

mode
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorSelectionModes
A SelectionModes indicating the value to check.

Return Value

Type: Boolean
true if the specified SelectionModes value is allowed; otherwise, false.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnApplyTemplate Method

SyntaxEditorOnApplyTemplate Method
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnApplyTemplate()
Protected Overrides Sub OnApplyTemplate
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnCreateAutomationPeer Method

SyntaxEditorOnCreateAutomationPeer Method
Returns class-specific AutomationPeer implementations for the automation infrastructure.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override AutomationPeer OnCreateAutomationPeer()
Protected Overrides Function OnCreateAutomationPeer As AutomationPeer

Return Value

Type: AutomationPeer
The type-specific AutomationPeer implementation.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnCutCopyDrag Method

SyntaxEditorOnCutCopyDrag Method
Invoked when an unhandled CutCopyDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnCutCopyDrag(
    CutCopyDragEventArgs e
)
Protected Overridable Sub OnCutCopyDrag (
    e As CutCopyDragEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorCutCopyDragEventArgs
A CutCopyDragEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnDocumentChanged Method

SyntaxEditorOnDocumentChanged Method
Invoked when an unhandled DocumentChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnDocumentChanged(
    EditorDocumentChangedEventArgs e
)
Protected Overridable Sub OnDocumentChanged (
    e As EditorDocumentChangedEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorDocumentChangedEventArgs
An EditorDocumentChangedEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnGotFocus Method

SyntaxEditorOnGotFocus Method
Occurs after the control gains focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnGotFocus (
    e As RoutedEventArgs
)

Parameters

e
Type: Windows.UI.XamlRoutedEventArgs
A RoutedEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnIsOverwriteModeActiveChanged Method

SyntaxEditorOnIsOverwriteModeActiveChanged Method
Invoked when an unhandled IsOverwriteModeActiveChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIsOverwriteModeActiveChanged(
    PropertyChangedEventArgs<bool> e
)
Protected Overridable Sub OnIsOverwriteModeActiveChanged (
    e As PropertyChangedEventArgs(Of Boolean)
)

Parameters

e
Type: ActiproSoftware.UI.XamlPropertyChangedEventArgs Boolean
A PropertyChangedEventArgs<bool> that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnKeyDown Method

SyntaxEditorOnKeyDown Method
Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyRoutedEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputKeyRoutedEventArgs
A KeyRoutedEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnMacroRecordingStateChanged Method

SyntaxEditorOnMacroRecordingStateChanged Method
Invoked when an unhandled MacroRecordingStateChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnMacroRecordingStateChanged(
    EventArgs e
)
Protected Overridable Sub OnMacroRecordingStateChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnPasteDragDrop Method

SyntaxEditorOnPasteDragDrop Method
Invoked when an unhandled PasteDragDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnPasteDragDrop(
    PasteDragDropEventArgs e
)
Protected Overridable Sub OnPasteDragDrop (
    e As PasteDragDropEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorPasteDragDropEventArgs
A PasteDragDropEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnPointerEntered Method

SyntaxEditorOnPointerEntered Method
Invoked when an unhandled pointer enter attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerEntered(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerEntered (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
A PointerRoutedEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnPointerExited Method

SyntaxEditorOnPointerExited Method
Invoked when an unhandled pointer leave attached event is raised on this element. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnPointerExited(
    PointerRoutedEventArgs e
)
Protected Overrides Sub OnPointerExited (
    e As PointerRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputPointerRoutedEventArgs
A PointerRoutedEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnRightTapped Method

SyntaxEditorOnRightTapped Method
Occurs when the pointer is right tapped over the control.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnRightTapped(
    RightTappedRoutedEventArgs e
)
Protected Overrides Sub OnRightTapped (
    e As RightTappedRoutedEventArgs
)

Parameters

e
Type: Windows.UI.Xaml.InputRightTappedRoutedEventArgs
The RightTappedRoutedEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnUserInterfaceUpdate Method

SyntaxEditorOnUserInterfaceUpdate Method
Invoked when an unhandled UserInterfaceUpdate attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnUserInterfaceUpdate(
    EventArgs e
)
Protected Overridable Sub OnUserInterfaceUpdate (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
The EventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnViewClosed Method

SyntaxEditorOnViewClosed Method
Invoked when an unhandled ViewClosed attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewClosed(
    TextViewEventArgs e
)
Protected Overridable Sub OnViewClosed (
    e As TextViewEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewEventArgs
A TextViewEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnViewIsIncrementalSearchActiveChanged Method

SyntaxEditorOnViewIsIncrementalSearchActiveChanged Method
Invoked when an unhandled ViewIsIncrementalSearchActiveChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewIsIncrementalSearchActiveChanged(
    TextViewEventArgs e
)
Protected Overridable Sub OnViewIsIncrementalSearchActiveChanged (
    e As TextViewEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewEventArgs
A TextViewEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnViewOpened Method

SyntaxEditorOnViewOpened Method
Invoked when an unhandled ViewOpened attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewOpened(
    TextViewEventArgs e
)
Protected Overridable Sub OnViewOpened (
    e As TextViewEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewEventArgs
A TextViewEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnViewSearch Method

SyntaxEditorOnViewSearch Method
Invoked when an unhandled ViewSearch attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewSearch(
    EditorViewSearchEventArgs e
)
Protected Overridable Sub OnViewSearch (
    e As EditorViewSearchEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSearchEventArgs
A EditorViewSearchEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OnViewSelectionChanged Method

SyntaxEditorOnViewSelectionChanged Method
Invoked when an unhandled ViewSelectionChanged attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnViewSelectionChanged(
    EditorViewSelectionEventArgs e
)
Protected Overridable Sub OnViewSelectionChanged (
    e As EditorViewSelectionEventArgs
)

Parameters

e
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorEditorViewSelectionEventArgs
A EditorViewSelectionEventArgs that contains the event data.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ResetViews Method

SyntaxEditorResetViews Method
Resets the splits and creates an initial view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void ResetViews()
Public Sub ResetViews
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor Events

SyntaxEditor Events

The SyntaxEditor type exposes the following members.

Events
 | Name | Description
Public event | AccessKeyDisplayDismissed | (Inherited from UIElement.)
Public event | AccessKeyDisplayRequested | (Inherited from UIElement.)
Public event | AccessKeyInvoked | (Inherited from UIElement.)
Public event | ContextCanceled | (Inherited from UIElement.)
Public event | ContextRequested | (Inherited from UIElement.)
Public event | CutCopyDrag | Occurs before text is cut or copied to the clipboard, and also before a drag occurs.
Public event | DataContextChanged | Occurs when the value of the FrameworkElement.DataContext property changes. (Inherited from FrameworkElement.)
Public event | DocumentChanged | Occurs when the Document property is changed.
Public event | DocumentIsModifiedChanged | Occurs after the current document's IsModified property value has changed.
Public event | DocumentIsReadOnlyChanged | Occurs after the current document's IsReadOnly property value has changed.
Public event | DocumentLanguageChanged | Occurs when the Document's Language property is changed.
Public event | DocumentParseDataChanged | Occurs after the current document's ParseData property value has changed.
Public event | DocumentTextChanged | Occurs after a text change occurs to the Document.
Public event | DocumentTextChanging | Occurs before a text change occurs to the Document.
Public event | DoubleTapped | Occurs when an otherwise unhandled DoubleTap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarting | (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropCompleted | (Inherited from UIElement.)
Public event | FocusDisengaged | (Inherited from Control.)
Public event | FocusEngaged | (Inherited from Control.)
Public event | GotFocus | Occurs when a UIElement receives focus. (Inherited from UIElement.)
Public event | Holding | Occurs when an otherwise unhandled Hold interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | IsEnabledChanged | Occurs when the IsEnabled property changes. (Inherited from Control.)
Public event | IsOverwriteModeActiveChanged | Occurs when the IsOverwriteModeActive property value changes.
Public event | KeyDown | Occurs when a keyboard key is pressed while the UIElement has focus. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a keyboard key is released while the UIElement has focus. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the visual tree changes. (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when a FrameworkElement has been constructed and added to the object tree, and is ready for interaction. (Inherited from FrameworkElement.)
Public event | Loading | (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when a UIElement loses focus. (Inherited from UIElement.)
Public event | MacroRecordingStateChanged | Occurs when the macro recording state changes.
Public event | ManipulationCompleted | Occurs when a manipulation on the UIElement is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | PasteDragDrop | Occurs when a paste or drag/drop operation occurs over the control, allowing for customization of the text to be inserted.
Public event | PointerCanceled | Occurs when a pointer that made contact abnormally loses contact. (Inherited from UIElement.)
Public event | PointerCaptureLost | Occurs when pointer capture previously held by this element moves to another element or elsewhere. (Inherited from UIElement.)
Public event | PointerEntered | Occurs when a pointer enters the hit test area of this element. (Inherited from UIElement.)
Public event | PointerExited | Occurs when a pointer leaves the hit test area of this element. (Inherited from UIElement.)
Public event | PointerMoved | Occurs when a pointer moves while the pointer remains within the hit test area of this element. (Inherited from UIElement.)
Public event | PointerPressed | Occurs when the pointer device initiates a Press action within this element. (Inherited from UIElement.)
Public event | PointerReleased | Occurs when the pointer device that previously initiated a Press action is released, while within this element. (Inherited from UIElement.)
Public event | PointerWheelChanged | Occurs when the delta value of a pointer wheel changes. (Inherited from UIElement.)
Public event | RightTapped | Occurs when a right-tap input stimulus happens while the pointer is over the element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth property changes value on a FrameworkElement. (Inherited from FrameworkElement.)
Public event | Tapped | Occurs when an otherwise unhandled Tap interaction occurs over the hit test area of this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when this object is no longer connected to the main object tree. (Inherited from FrameworkElement.)
Public event | UserInterfaceUpdate | Occurs after a brief delay following any document text, parse data, or view selection update, allowing consumers to update the user interface during an idle period.
Public event | ViewClosed | Occurs when an ITextView is closed.
Public event | ViewIsIncrementalSearchActiveChanged | Occurs when the incremental search mode of an ITextView is activated or deactivated.
Public event | ViewOpened | Occurs when an ITextView is opened.
Public event | ViewSearch | Occurs when a IEditorView search operation is performed.
Public event | ViewSelectionChanged | Occurs when a IEditorView selection has changed.
Top
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CutCopyDrag Event

SyntaxEditorCutCopyDrag Event
Occurs before text is cut or copied to the clipboard, and also before a drag occurs.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<CutCopyDragEventArgs> CutCopyDrag
Public Event CutCopyDrag As EventHandler(Of CutCopyDragEventArgs)

Value

Type: SystemEventHandler CutCopyDragEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentChanged Event

SyntaxEditorDocumentChanged Event
Occurs when the Document property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<EditorDocumentChangedEventArgs> DocumentChanged
Public Event DocumentChanged As EventHandler(Of EditorDocumentChangedEventArgs)

Value

Type: SystemEventHandler EditorDocumentChangedEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentIsModifiedChanged Event

SyntaxEditorDocumentIsModifiedChanged Event
Occurs after the current document's IsModified property value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler DocumentIsModifiedChanged
Public Event DocumentIsModifiedChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentIsReadOnlyChanged Event

SyntaxEditorDocumentIsReadOnlyChanged Event
Occurs after the current document's IsReadOnly property value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler DocumentIsReadOnlyChanged
Public Event DocumentIsReadOnlyChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentLanguageChanged Event

SyntaxEditorDocumentLanguageChanged Event
Occurs when the Document's Language property is changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<EditorDocumentLanguageChangedEventArgs> DocumentLanguageChanged
Public Event DocumentLanguageChanged As EventHandler(Of EditorDocumentLanguageChangedEventArgs)

Value

Type: SystemEventHandler EditorDocumentLanguageChangedEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentParseDataChanged Event

SyntaxEditorDocumentParseDataChanged Event
Occurs after the current document's ParseData property value has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler DocumentParseDataChanged
Public Event DocumentParseDataChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentTextChanged Event

SyntaxEditorDocumentTextChanged Event
Occurs after a text change occurs to the Document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<EditorSnapshotChangedEventArgs> DocumentTextChanged
Public Event DocumentTextChanged As EventHandler(Of EditorSnapshotChangedEventArgs)

Value

Type: SystemEventHandler EditorSnapshotChangedEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentTextChanging Event

SyntaxEditorDocumentTextChanging Event
Occurs before a text change occurs to the Document.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<EditorSnapshotChangingEventArgs> DocumentTextChanging
Public Event DocumentTextChanging As EventHandler(Of EditorSnapshotChangingEventArgs)

Value

Type: SystemEventHandler EditorSnapshotChangingEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsOverwriteModeActiveChanged Event

SyntaxEditorIsOverwriteModeActiveChanged Event
Occurs when the IsOverwriteModeActive property value changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PropertyChangedEventArgs<bool>> IsOverwriteModeActiveChanged
Public Event IsOverwriteModeActiveChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

Value

Type: SystemEventHandler PropertyChangedEventArgs Boolean
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.MacroRecordingStateChanged Event

SyntaxEditorMacroRecordingStateChanged Event
Occurs when the macro recording state changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler MacroRecordingStateChanged
Public Event MacroRecordingStateChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.PasteDragDrop Event

SyntaxEditorPasteDragDrop Event
Occurs when a paste or drag/drop operation occurs over the control, allowing for customization of the text to be inserted.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<PasteDragDropEventArgs> PasteDragDrop
Public Event PasteDragDrop As EventHandler(Of PasteDragDropEventArgs)

Value

Type: SystemEventHandler PasteDragDropEventArgs
Remarks
This event allows for any sort of IDataStore (such as a file) to be handled when pasted or drag/dropped on the editor and representative text inserted.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.UserInterfaceUpdate Event

SyntaxEditorUserInterfaceUpdate Event
Occurs after a brief delay following any document text, parse data, or view selection update, allowing consumers to update the user interface during an idle period.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler UserInterfaceUpdate
Public Event UserInterfaceUpdate As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ViewClosed Event

SyntaxEditorViewClosed Event
Occurs when an ITextView is closed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TextViewEventArgs> ViewClosed
Public Event ViewClosed As EventHandler(Of TextViewEventArgs)

Value

Type: SystemEventHandler TextViewEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ViewIsIncrementalSearchActiveChanged Event

SyntaxEditorViewIsIncrementalSearchActiveChanged Event
Occurs when the incremental search mode of an ITextView is activated or deactivated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TextViewEventArgs> ViewIsIncrementalSearchActiveChanged
Public Event ViewIsIncrementalSearchActiveChanged As EventHandler(Of TextViewEventArgs)

Value

Type: SystemEventHandler TextViewEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ViewOpened Event

SyntaxEditorViewOpened Event
Occurs when an ITextView is opened.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<TextViewEventArgs> ViewOpened
Public Event ViewOpened As EventHandler(Of TextViewEventArgs)

Value

Type: SystemEventHandler TextViewEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ViewSearch Event

SyntaxEditorViewSearch Event
Occurs when a IEditorView search operation is performed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<EditorViewSearchEventArgs> ViewSearch
Public Event ViewSearch As EventHandler(Of EditorViewSearchEventArgs)

Value

Type: SystemEventHandler EditorViewSearchEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ViewSelectionChanged Event

SyntaxEditorViewSelectionChanged Event
Occurs when a IEditorView selection has changed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public event EventHandler<EditorViewSelectionEventArgs> ViewSelectionChanged
Public Event ViewSelectionChanged As EventHandler(Of EditorViewSelectionEventArgs)

Value

Type: SystemEventHandler EditorViewSelectionEventArgs
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor Fields

SyntaxEditor Fields

The SyntaxEditor type exposes the following members.

Fields
Name | Description
AcceptsTabProperty | Identifies the AcceptsTab dependency property. This field is read-only.
AreIndentationGuidesVisibleProperty | Identifies the AreIndentationGuidesVisible dependency property. This field is read-only.
AreLineModificationMarksVisibleProperty | Identifies the AreLineModificationMarksVisible dependency property. This field is read-only.
AreSelectionGrippersEnabledProperty | Identifies the AreSelectionGrippersEnabled dependency property. This field is read-only.
AreWordWrapGlyphsVisibleProperty | Identifies the AreWordWrapGlyphsVisible dependency property. This field is read-only.
CanBackspaceOverSpacesToTabStopProperty | Identifies the CanBackspaceOverSpacesToTabStop dependency property. This field is read-only.
CanCutCopyBlankLineWhenNoSelectionProperty | Identifies the CanCutCopyBlankLineWhenNoSelection dependency property. This field is read-only.
CanCutCopyDragWithHtmlProperty | Identifies the CanCutCopyDragWithHtml dependency property. This field is read-only.
CanCutCopyDragWithRtfProperty | Identifies the CanCutCopyDragWithRtf dependency property. This field is read-only.
CanIncrementalSearchTrimUnmatchedFindTextProperty | Identifies the CanIncrementalSearchTrimUnmatchedFindText dependency property. This field is read-only.
CanMoveCaretOnMouseRightClickProperty | Identifies the CanMoveCaretOnMouseRightClick dependency property. This field is read-only.
CanMoveCaretToNextLineAtLineEndProperty | Identifies the CanMoveCaretToNextLineAtLineEnd dependency property. This field is read-only.
CanMoveCaretToPreviousLineAtLineStartProperty | Identifies the CanMoveCaretToPreviousLineAtLineStart dependency property. This field is read-only.
CanScrollPastDocumentEndProperty | Identifies the CanScrollPastDocumentEnd dependency property. This field is read-only.
CaretBrushProperty | Identifies the CaretBrush dependency property. This field is read-only.
DocumentProperty | Identifies the Document dependency property. This field is read-only.
HighlightingStyleRegistryProperty | Identifies the HighlightingStyleRegistry dependency property. This field is read-only.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility dependency property. This field is read-only.
IndicatorMarginBackgroundProperty | Identifies the IndicatorMarginBackground dependency property. This field is read-only.
IsAutoCorrectEnabledProperty | Identifies the IsAutoCorrectEnabled dependency property. This field is read-only.
IsCollapsibleRegionHighlightingEnabledProperty | Identifies the IsCollapsibleRegionHighlightingEnabled dependency property. This field is read-only.
IsCurrentLineHighlightingEnabledProperty | Identifies the IsCurrentLineHighlightingEnabled dependency property. This field is read-only.
IsDefaultContextMenuEnabledProperty | Identifies the IsDefaultContextMenuEnabled dependency property. This field is read-only.
IsDelimiterAutoCompleteEnabledProperty | Identifies the IsDelimiterAutoCompleteEnabled dependency property. This field is read-only.
IsDelimiterHighlightingEnabledProperty | Identifies the IsDelimiterHighlightingEnabled dependency property. This field is read-only.
IsDocumentReadOnlyProperty | Identifies the IsDocumentReadOnly dependency property. This field is read-only.
IsIncrementalSearchResultHighlightingEnabledProperty | Identifies the IsIncrementalSearchResultHighlightingEnabled dependency property. This field is read-only.
IsIndicatorMarginVisibleProperty | Identifies the IsIndicatorMarginVisible dependency property. This field is read-only.
IsLineNumberMarginVisibleProperty | Identifies the IsLineNumberMarginVisible dependency property. This field is read-only.
IsMouseWheelZoomEnabledProperty | Identifies the IsMouseWheelZoomEnabled dependency property. This field is read-only.
IsMultiLineProperty | Identifies the IsMultiLine dependency property. This field is read-only.
IsOutliningMarginVisibleProperty | Identifies the IsOutliningMarginVisible dependency property. This field is read-only.
IsOverwriteModeActiveProperty | Identifies the IsOverwriteModeActive dependency property. This field is read-only.
IsSelectionMarginVisibleProperty | Identifies the IsSelectionMarginVisible dependency property. This field is read-only.
IsSoftKeyboardEnabledProperty | Identifies the IsSoftKeyboardEnabled dependency property. This field is read-only.
IsTextDataBindingEnabledProperty | Identifies the IsTextDataBindingEnabled dependency property. This field is read-only.
IsViewLineMeasureEnabledProperty | Identifies the IsViewLineMeasureEnabled dependency property. This field is read-only.
IsWhitespaceVisibleProperty | Identifies the IsWhitespaceVisible dependency property. This field is read-only.
IsWordWrapEnabledProperty | Identifies the IsWordWrapEnabled dependency property. This field is read-only.
IsWordWrapGlyphMarginVisibleProperty | Identifies the IsWordWrapGlyphMarginVisible dependency property. This field is read-only.
LineNumberMarginBackgroundProperty | Identifies the LineNumberMarginBackground dependency property. This field is read-only.
LineNumberMarginFontFamilyProperty | Identifies the LineNumberMarginFontFamily dependency property. This field is read-only.
LineNumberMarginFontSizeProperty | Identifies the LineNumberMarginFontSize dependency property. This field is read-only.
LineNumberMarginForegroundProperty | Identifies the LineNumberMarginForeground dependency property. This field is read-only.
MaxZoomLevelProperty | Identifies the MaxZoomLevel dependency property. This field is read-only.
MinZoomLevelProperty | Identifies the MinZoomLevel dependency property. This field is read-only.
OutliningMarginBackgroundProperty | Identifies the OutliningMarginBackground dependency property. This field is read-only.
PrintSettingsProperty | Identifies the PrintSettings dependency property. This field is read-only.
ScrollBarTrayBottomTemplateProperty | Identifies the ScrollBarTrayBottomTemplate dependency property. This field is read-only.
ScrollBarTrayLeftTemplateProperty | Identifies the ScrollBarTrayLeftTemplate dependency property. This field is read-only.
ScrollBarTrayRightTemplateProperty | Identifies the ScrollBarTrayRightTemplate dependency property. This field is read-only.
ScrollBarTrayTopTemplateProperty | Identifies the ScrollBarTrayTopTemplate dependency property. This field is read-only.
ScrollToCaretOnSelectAllProperty | Identifies the ScrollToCaretOnSelectAll dependency property. This field is read-only.
SelectionBackgroundActiveProperty | Identifies the SelectionBackgroundActive dependency property. This field is read-only.
SelectionBackgroundInactiveProperty | Identifies the SelectionBackgroundInactive dependency property. This field is read-only.
SelectionCollapsesOnCopyProperty | Identifies the SelectionCollapsesOnCopy dependency property. This field is read-only.
SelectionCollapsesToAnchorProperty | Identifies the SelectionCollapsesToAnchor dependency property. This field is read-only.
SelectionMarginBackgroundProperty | Identifies the SelectionMarginBackground dependency property. This field is read-only.
SelectionModesAllowedProperty | Identifies the SelectionModesAllowed dependency property. This field is read-only.
TextProperty | Identifies the Text dependency property. This field is read-only.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility dependency property. This field is read-only.
VisibleWhitespaceForegroundProperty | Identifies the VisibleWhitespaceForeground dependency property. This field is read-only.
WordWrapGlyphMarginBackgroundProperty | Identifies the WordWrapGlyphMarginBackground dependency property. This field is read-only.
WordWrapGlyphMarginForegroundProperty | Identifies the WordWrapGlyphMarginForeground dependency property. This field is read-only.
WordWrapModeProperty | Identifies the WordWrapMode dependency property. This field is read-only.
ZoomAnimationDurationProperty | Identifies the ZoomAnimationDuration dependency property. This field is read-only.
ZoomLevelAnimatedProperty | Identifies the ZoomLevelAnimated dependency property. This field is read-only.
ZoomLevelIncrementProperty | Identifies the ZoomLevelIncrement dependency property. This field is read-only.
ZoomLevelProperty | Identifies the ZoomLevel dependency property. This field is read-only.
Top
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AcceptsTabProperty Field

SyntaxEditorAcceptsTabProperty Field
Identifies the AcceptsTab dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AcceptsTabProperty
Public Shared ReadOnly AcceptsTabProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AcceptsTab dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreIndentationGuidesVisibleProperty Field

SyntaxEditorAreIndentationGuidesVisibleProperty Field
Identifies the AreIndentationGuidesVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreIndentationGuidesVisibleProperty
Public Shared ReadOnly AreIndentationGuidesVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreIndentationGuidesVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreLineModificationMarksVisibleProperty Field

SyntaxEditorAreLineModificationMarksVisibleProperty Field
Identifies the AreLineModificationMarksVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreLineModificationMarksVisibleProperty
Public Shared ReadOnly AreLineModificationMarksVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreLineModificationMarksVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreSelectionGrippersEnabledProperty Field

SyntaxEditorAreSelectionGrippersEnabledProperty Field
Identifies the AreSelectionGrippersEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreSelectionGrippersEnabledProperty
Public Shared ReadOnly AreSelectionGrippersEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreSelectionGrippersEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.AreWordWrapGlyphsVisibleProperty Field

SyntaxEditorAreWordWrapGlyphsVisibleProperty Field
Identifies the AreWordWrapGlyphsVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty AreWordWrapGlyphsVisibleProperty
Public Shared ReadOnly AreWordWrapGlyphsVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the AreWordWrapGlyphsVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanBackspaceOverSpacesToTabStopProperty Field

SyntaxEditorCanBackspaceOverSpacesToTabStopProperty Field
Identifies the CanBackspaceOverSpacesToTabStop dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanBackspaceOverSpacesToTabStopProperty
Public Shared ReadOnly CanBackspaceOverSpacesToTabStopProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanBackspaceOverSpacesToTabStop dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanCutCopyBlankLineWhenNoSelectionProperty Field

SyntaxEditorCanCutCopyBlankLineWhenNoSelectionProperty Field
Identifies the CanCutCopyBlankLineWhenNoSelection dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCutCopyBlankLineWhenNoSelectionProperty
Public Shared ReadOnly CanCutCopyBlankLineWhenNoSelectionProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanCutCopyBlankLineWhenNoSelection dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanCutCopyDragWithHtmlProperty Field

SyntaxEditorCanCutCopyDragWithHtmlProperty Field
Identifies the CanCutCopyDragWithHtml dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCutCopyDragWithHtmlProperty
Public Shared ReadOnly CanCutCopyDragWithHtmlProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanCutCopyDragWithHtml dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanCutCopyDragWithRtfProperty Field

SyntaxEditorCanCutCopyDragWithRtfProperty Field
Identifies the CanCutCopyDragWithRtf dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanCutCopyDragWithRtfProperty
Public Shared ReadOnly CanCutCopyDragWithRtfProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanCutCopyDragWithRtf dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanIncrementalSearchTrimUnmatchedFindTextProperty Field

SyntaxEditorCanIncrementalSearchTrimUnmatchedFindTextProperty Field
Identifies the CanIncrementalSearchTrimUnmatchedFindText dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanIncrementalSearchTrimUnmatchedFindTextProperty
Public Shared ReadOnly CanIncrementalSearchTrimUnmatchedFindTextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanIncrementalSearchTrimUnmatchedFindText dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanMoveCaretOnMouseRightClickProperty Field

SyntaxEditorCanMoveCaretOnMouseRightClickProperty Field
Identifies the CanMoveCaretOnMouseRightClick dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanMoveCaretOnMouseRightClickProperty
Public Shared ReadOnly CanMoveCaretOnMouseRightClickProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanMoveCaretOnMouseRightClick dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanMoveCaretToNextLineAtLineEndProperty Field

SyntaxEditorCanMoveCaretToNextLineAtLineEndProperty Field
Identifies the CanMoveCaretToNextLineAtLineEnd dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanMoveCaretToNextLineAtLineEndProperty
Public Shared ReadOnly CanMoveCaretToNextLineAtLineEndProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanMoveCaretToNextLineAtLineEnd dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanMoveCaretToPreviousLineAtLineStartProperty Field

SyntaxEditorCanMoveCaretToPreviousLineAtLineStartProperty Field
Identifies the CanMoveCaretToPreviousLineAtLineStart dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanMoveCaretToPreviousLineAtLineStartProperty
Public Shared ReadOnly CanMoveCaretToPreviousLineAtLineStartProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanMoveCaretToPreviousLineAtLineStart dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CanScrollPastDocumentEndProperty Field

SyntaxEditorCanScrollPastDocumentEndProperty Field
Identifies the CanScrollPastDocumentEnd dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CanScrollPastDocumentEndProperty
Public Shared ReadOnly CanScrollPastDocumentEndProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CanScrollPastDocumentEnd dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.CaretBrushProperty Field

SyntaxEditorCaretBrushProperty Field
Identifies the CaretBrush dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty CaretBrushProperty
Public Shared ReadOnly CaretBrushProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the CaretBrush dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.DocumentProperty Field

SyntaxEditorDocumentProperty Field
Identifies the Document dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty DocumentProperty
Public Shared ReadOnly DocumentProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Document dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.HighlightingStyleRegistryProperty Field

SyntaxEditorHighlightingStyleRegistryProperty Field
Identifies the HighlightingStyleRegistry dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HighlightingStyleRegistryProperty
Public Shared ReadOnly HighlightingStyleRegistryProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HighlightingStyleRegistry dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.HorizontalScrollBarVisibilityProperty Field

SyntaxEditorHorizontalScrollBarVisibilityProperty Field
Identifies the HorizontalScrollBarVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty HorizontalScrollBarVisibilityProperty
Public Shared ReadOnly HorizontalScrollBarVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the HorizontalScrollBarVisibility dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IndicatorMarginBackgroundProperty Field

SyntaxEditorIndicatorMarginBackgroundProperty Field
Identifies the IndicatorMarginBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IndicatorMarginBackgroundProperty
Public Shared ReadOnly IndicatorMarginBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IndicatorMarginBackground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsAutoCorrectEnabledProperty Field

SyntaxEditorIsAutoCorrectEnabledProperty Field
Identifies the IsAutoCorrectEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsAutoCorrectEnabledProperty
Public Shared ReadOnly IsAutoCorrectEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsAutoCorrectEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsCollapsibleRegionHighlightingEnabledProperty Field

SyntaxEditorIsCollapsibleRegionHighlightingEnabledProperty Field
Identifies the IsCollapsibleRegionHighlightingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCollapsibleRegionHighlightingEnabledProperty
Public Shared ReadOnly IsCollapsibleRegionHighlightingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCollapsibleRegionHighlightingEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsCurrentLineHighlightingEnabledProperty Field

SyntaxEditorIsCurrentLineHighlightingEnabledProperty Field
Identifies the IsCurrentLineHighlightingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsCurrentLineHighlightingEnabledProperty
Public Shared ReadOnly IsCurrentLineHighlightingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsCurrentLineHighlightingEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDefaultContextMenuEnabledProperty Field

SyntaxEditorIsDefaultContextMenuEnabledProperty Field
Identifies the IsDefaultContextMenuEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDefaultContextMenuEnabledProperty
Public Shared ReadOnly IsDefaultContextMenuEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDefaultContextMenuEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDelimiterAutoCompleteEnabledProperty Field

SyntaxEditorIsDelimiterAutoCompleteEnabledProperty Field
Identifies the IsDelimiterAutoCompleteEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDelimiterAutoCompleteEnabledProperty
Public Shared ReadOnly IsDelimiterAutoCompleteEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDelimiterAutoCompleteEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDelimiterHighlightingEnabledProperty Field

SyntaxEditorIsDelimiterHighlightingEnabledProperty Field
Identifies the IsDelimiterHighlightingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDelimiterHighlightingEnabledProperty
Public Shared ReadOnly IsDelimiterHighlightingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDelimiterHighlightingEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsDocumentReadOnlyProperty Field

SyntaxEditorIsDocumentReadOnlyProperty Field
Identifies the IsDocumentReadOnly dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsDocumentReadOnlyProperty
Public Shared ReadOnly IsDocumentReadOnlyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsDocumentReadOnly dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsIncrementalSearchResultHighlightingEnabledProperty Field

SyntaxEditorIsIncrementalSearchResultHighlightingEnabledProperty Field
Identifies the IsIncrementalSearchResultHighlightingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsIncrementalSearchResultHighlightingEnabledProperty
Public Shared ReadOnly IsIncrementalSearchResultHighlightingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsIncrementalSearchResultHighlightingEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsIndicatorMarginVisibleProperty Field

SyntaxEditorIsIndicatorMarginVisibleProperty Field
Identifies the IsIndicatorMarginVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsIndicatorMarginVisibleProperty
Public Shared ReadOnly IsIndicatorMarginVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsIndicatorMarginVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsLineNumberMarginVisibleProperty Field

SyntaxEditorIsLineNumberMarginVisibleProperty Field
Identifies the IsLineNumberMarginVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsLineNumberMarginVisibleProperty
Public Shared ReadOnly IsLineNumberMarginVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsLineNumberMarginVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsMouseWheelZoomEnabledProperty Field

SyntaxEditorIsMouseWheelZoomEnabledProperty Field
Identifies the IsMouseWheelZoomEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMouseWheelZoomEnabledProperty
Public Shared ReadOnly IsMouseWheelZoomEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMouseWheelZoomEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsMultiLineProperty Field

SyntaxEditorIsMultiLineProperty Field
Identifies the IsMultiLine dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsMultiLineProperty
Public Shared ReadOnly IsMultiLineProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsMultiLine dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsOutliningMarginVisibleProperty Field

SyntaxEditorIsOutliningMarginVisibleProperty Field
Identifies the IsOutliningMarginVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOutliningMarginVisibleProperty
Public Shared ReadOnly IsOutliningMarginVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOutliningMarginVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsOverwriteModeActiveProperty Field

SyntaxEditorIsOverwriteModeActiveProperty Field
Identifies the IsOverwriteModeActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsOverwriteModeActiveProperty
Public Shared ReadOnly IsOverwriteModeActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsOverwriteModeActive dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsSelectionMarginVisibleProperty Field

SyntaxEditorIsSelectionMarginVisibleProperty Field
Identifies the IsSelectionMarginVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSelectionMarginVisibleProperty
Public Shared ReadOnly IsSelectionMarginVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSelectionMarginVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsSoftKeyboardEnabledProperty Field

SyntaxEditorIsSoftKeyboardEnabledProperty Field
Identifies the IsSoftKeyboardEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsSoftKeyboardEnabledProperty
Public Shared ReadOnly IsSoftKeyboardEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsSoftKeyboardEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsTextDataBindingEnabledProperty Field

SyntaxEditorIsTextDataBindingEnabledProperty Field
Identifies the IsTextDataBindingEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsTextDataBindingEnabledProperty
Public Shared ReadOnly IsTextDataBindingEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsTextDataBindingEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsViewLineMeasureEnabledProperty Field

SyntaxEditorIsViewLineMeasureEnabledProperty Field
Identifies the IsViewLineMeasureEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsViewLineMeasureEnabledProperty
Public Shared ReadOnly IsViewLineMeasureEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsViewLineMeasureEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsWhitespaceVisibleProperty Field

SyntaxEditorIsWhitespaceVisibleProperty Field
Identifies the IsWhitespaceVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWhitespaceVisibleProperty
Public Shared ReadOnly IsWhitespaceVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWhitespaceVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsWordWrapEnabledProperty Field

SyntaxEditorIsWordWrapEnabledProperty Field
Identifies the IsWordWrapEnabled dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWordWrapEnabledProperty
Public Shared ReadOnly IsWordWrapEnabledProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWordWrapEnabled dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.IsWordWrapGlyphMarginVisibleProperty Field

SyntaxEditorIsWordWrapGlyphMarginVisibleProperty Field
Identifies the IsWordWrapGlyphMarginVisible dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty IsWordWrapGlyphMarginVisibleProperty
Public Shared ReadOnly IsWordWrapGlyphMarginVisibleProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the IsWordWrapGlyphMarginVisible dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginBackgroundProperty Field

SyntaxEditorLineNumberMarginBackgroundProperty Field
Identifies the LineNumberMarginBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineNumberMarginBackgroundProperty
Public Shared ReadOnly LineNumberMarginBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineNumberMarginBackground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginFontFamilyProperty Field

SyntaxEditorLineNumberMarginFontFamilyProperty Field
Identifies the LineNumberMarginFontFamily dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineNumberMarginFontFamilyProperty
Public Shared ReadOnly LineNumberMarginFontFamilyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineNumberMarginFontFamily dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginFontSizeProperty Field

SyntaxEditorLineNumberMarginFontSizeProperty Field
Identifies the LineNumberMarginFontSize dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineNumberMarginFontSizeProperty
Public Shared ReadOnly LineNumberMarginFontSizeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineNumberMarginFontSize dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.LineNumberMarginForegroundProperty Field

SyntaxEditorLineNumberMarginForegroundProperty Field
Identifies the LineNumberMarginForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty LineNumberMarginForegroundProperty
Public Shared ReadOnly LineNumberMarginForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the LineNumberMarginForeground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.MaxZoomLevelProperty Field

SyntaxEditorMaxZoomLevelProperty Field
Identifies the MaxZoomLevel dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MaxZoomLevelProperty
Public Shared ReadOnly MaxZoomLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MaxZoomLevel dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.MinZoomLevelProperty Field

SyntaxEditorMinZoomLevelProperty Field
Identifies the MinZoomLevel dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty MinZoomLevelProperty
Public Shared ReadOnly MinZoomLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the MinZoomLevel dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.OutliningMarginBackgroundProperty Field

SyntaxEditorOutliningMarginBackgroundProperty Field
Identifies the OutliningMarginBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty OutliningMarginBackgroundProperty
Public Shared ReadOnly OutliningMarginBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the OutliningMarginBackground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.PrintSettingsProperty Field

SyntaxEditorPrintSettingsProperty Field
Identifies the PrintSettings dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty PrintSettingsProperty
Public Shared ReadOnly PrintSettingsProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the PrintSettings dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayBottomTemplateProperty Field

SyntaxEditorScrollBarTrayBottomTemplateProperty Field
Identifies the ScrollBarTrayBottomTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollBarTrayBottomTemplateProperty
Public Shared ReadOnly ScrollBarTrayBottomTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollBarTrayBottomTemplate dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayLeftTemplateProperty Field

SyntaxEditorScrollBarTrayLeftTemplateProperty Field
Identifies the ScrollBarTrayLeftTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollBarTrayLeftTemplateProperty
Public Shared ReadOnly ScrollBarTrayLeftTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollBarTrayLeftTemplate dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayRightTemplateProperty Field

SyntaxEditorScrollBarTrayRightTemplateProperty Field
Identifies the ScrollBarTrayRightTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollBarTrayRightTemplateProperty
Public Shared ReadOnly ScrollBarTrayRightTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollBarTrayRightTemplate dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollBarTrayTopTemplateProperty Field

SyntaxEditorScrollBarTrayTopTemplateProperty Field
Identifies the ScrollBarTrayTopTemplate dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollBarTrayTopTemplateProperty
Public Shared ReadOnly ScrollBarTrayTopTemplateProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollBarTrayTopTemplate dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ScrollToCaretOnSelectAllProperty Field

SyntaxEditorScrollToCaretOnSelectAllProperty Field
Identifies the ScrollToCaretOnSelectAll dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ScrollToCaretOnSelectAllProperty
Public Shared ReadOnly ScrollToCaretOnSelectAllProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ScrollToCaretOnSelectAll dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionBackgroundActiveProperty Field

SyntaxEditorSelectionBackgroundActiveProperty Field
Identifies the SelectionBackgroundActive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionBackgroundActiveProperty
Public Shared ReadOnly SelectionBackgroundActiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionBackgroundActive dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionBackgroundInactiveProperty Field

SyntaxEditorSelectionBackgroundInactiveProperty Field
Identifies the SelectionBackgroundInactive dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionBackgroundInactiveProperty
Public Shared ReadOnly SelectionBackgroundInactiveProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionBackgroundInactive dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionCollapsesOnCopyProperty Field

SyntaxEditorSelectionCollapsesOnCopyProperty Field
Identifies the SelectionCollapsesOnCopy dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionCollapsesOnCopyProperty
Public Shared ReadOnly SelectionCollapsesOnCopyProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionCollapsesOnCopy dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionCollapsesToAnchorProperty Field

SyntaxEditorSelectionCollapsesToAnchorProperty Field
Identifies the SelectionCollapsesToAnchor dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionCollapsesToAnchorProperty
Public Shared ReadOnly SelectionCollapsesToAnchorProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionCollapsesToAnchor dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionMarginBackgroundProperty Field

SyntaxEditorSelectionMarginBackgroundProperty Field
Identifies the SelectionMarginBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionMarginBackgroundProperty
Public Shared ReadOnly SelectionMarginBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionMarginBackground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.SelectionModesAllowedProperty Field

SyntaxEditorSelectionModesAllowedProperty Field
Identifies the SelectionModesAllowed dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty SelectionModesAllowedProperty
Public Shared ReadOnly SelectionModesAllowedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the SelectionModesAllowed dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.TextProperty Field

SyntaxEditorTextProperty Field
Identifies the Text dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty TextProperty
Public Shared ReadOnly TextProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the Text dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.VerticalScrollBarVisibilityProperty Field

SyntaxEditorVerticalScrollBarVisibilityProperty Field
Identifies the VerticalScrollBarVisibility dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty VerticalScrollBarVisibilityProperty
Public Shared ReadOnly VerticalScrollBarVisibilityProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the VerticalScrollBarVisibility dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.VisibleWhitespaceForegroundProperty Field

SyntaxEditorVisibleWhitespaceForegroundProperty Field
Identifies the VisibleWhitespaceForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty VisibleWhitespaceForegroundProperty
Public Shared ReadOnly VisibleWhitespaceForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the VisibleWhitespaceForeground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.WordWrapGlyphMarginBackgroundProperty Field

SyntaxEditorWordWrapGlyphMarginBackgroundProperty Field
Identifies the WordWrapGlyphMarginBackground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WordWrapGlyphMarginBackgroundProperty
Public Shared ReadOnly WordWrapGlyphMarginBackgroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WordWrapGlyphMarginBackground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.WordWrapGlyphMarginForegroundProperty Field

SyntaxEditorWordWrapGlyphMarginForegroundProperty Field
Identifies the WordWrapGlyphMarginForeground dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WordWrapGlyphMarginForegroundProperty
Public Shared ReadOnly WordWrapGlyphMarginForegroundProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WordWrapGlyphMarginForeground dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.WordWrapModeProperty Field

SyntaxEditorWordWrapModeProperty Field
Identifies the WordWrapMode dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty WordWrapModeProperty
Public Shared ReadOnly WordWrapModeProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the WordWrapMode dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ZoomAnimationDurationProperty Field

SyntaxEditorZoomAnimationDurationProperty Field
Identifies the ZoomAnimationDuration dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomAnimationDurationProperty
Public Shared ReadOnly ZoomAnimationDurationProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomAnimationDuration dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ZoomLevelAnimatedProperty Field

SyntaxEditorZoomLevelAnimatedProperty Field
Identifies the ZoomLevelAnimated dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomLevelAnimatedProperty
Public Shared ReadOnly ZoomLevelAnimatedProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomLevelAnimated dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ZoomLevelIncrementProperty Field

SyntaxEditorZoomLevelIncrementProperty Field
Identifies the ZoomLevelIncrement dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomLevelIncrementProperty
Public Shared ReadOnly ZoomLevelIncrementProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomLevelIncrement dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


SyntaxEditor.ZoomLevelProperty Field

SyntaxEditorZoomLevelProperty Field
Identifies the ZoomLevel dependency property. This field is read-only.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static readonly DependencyProperty ZoomLevelProperty
Public Shared ReadOnly ZoomLevelProperty As DependencyProperty

Field Value

Type: DependencyProperty
The identifier for the ZoomLevel dependency property.
See Also

Reference

SyntaxEditor Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Class

TextBounds Class
Describes the width, height, location, and flow direction of a range of text.
Inheritance Hierarchy
SystemObject
SystemValueType
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextBounds : ValueType
Public NotInheritable Class TextBounds
    Inherits ValueType

The TextBounds type exposes the following members.

Constructors
 | Name | Description
Public method | TextBounds(Rect, FlowDirection) | Initializes a new instance of the TextBounds structure.
Public method | TextBounds(Double, Double, Double, Double, FlowDirection) | Initializes a new instance of the TextBounds structure.
Top
Properties
 | Name | Description
Public property | Bottom | Gets the y-axis value of the bottom of the bounds (Y + Height).
 | Empty | Gets the empty bounds, a special value that represents a bounds with no position or area.
Public property | FlowDirection | Gets the FlowDirection of the text.
Public property | Height | Gets the height of the bounds.
Public property | IsEmpty | Gets a value that indicates whether this bounds is the Empty bounds.
Public property | IsLeftToRight | Gets whether the text is left-to-right.
Public property | IsRightToLeft | Gets whether the text is right-to-left.
Public property | IsYValid | Gets a value that indicates whether the Y property is a valid value.
Public property | Left | Gets the x-axis position of the left side of the bounds. Getting this property is equivalent to getting the bounds's X property.
Public property | Rect | Gets a Rect that specifies the bounds.
Public property | Right | Gets the x-axis value of the right side of the bounds (X + Width).
Public property | Top | Gets the y-axis position of the top of the bounds. Getting this property is equivalent to getting the bounds's Y property.
Public property | Width | Gets the width of the bounds.
Public property | X | Gets the x-axis position of the left side of the bounds.
Public property | Y | Gets the y-axis position of the top of the bounds.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Constructor

TextBounds Constructor
Overload List
 | Name | Description
Public method | TextBounds(Rect, FlowDirection) | Initializes a new instance of the TextBounds structure.
Public method | TextBounds(Double, Double, Double, Double, FlowDirection) | Initializes a new instance of the TextBounds structure.
Top
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Constructor (Rect, FlowDirection)

TextBounds Constructor (Rect, FlowDirection)
Initializes a new instance of the TextBounds structure.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextBounds(
    Rect bounds,
    FlowDirection flowDirection
)
Public Sub New (
    bounds As Rect,
    flowDirection As FlowDirection
)

Parameters

bounds
Type: Windows.FoundationRect
A Rect that specifies the bounds.
flowDirection
Type: Windows.UI.XamlFlowDirection
A FlowDirection that specifies the flow direction of the text.
See Also

Reference

TextBounds Class
TextBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Constructor (Double, Double, Double, Double, FlowDirection)

TextBounds Constructor (Double, Double, Double, Double, FlowDirection)
Initializes a new instance of the TextBounds structure.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextBounds(
    double x,
    double y,
    double width,
    double height,
    FlowDirection flowDirection
)
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double,
    flowDirection As FlowDirection
)

Parameters

x
Type: SystemDouble
Gets the x-axis position of the left side of the bounds.
y
Type: SystemDouble
Gets the y-axis position of the top of the bounds.
width
Type: SystemDouble
Gets the width of the bounds.
height
Type: SystemDouble
Gets the height of the bounds.
flowDirection
Type: Windows.UI.XamlFlowDirection
A FlowDirection that specifies the flow direction of the text.
See Also

Reference

TextBounds Class
TextBounds Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Properties

TextBounds Properties

The TextBounds type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | Gets the y-axis value of the bottom of the bounds (Y + Height).
 | Empty | Gets the empty bounds, a special value that represents a bounds with no position or area.
Public property | FlowDirection | Gets the FlowDirection of the text.
Public property | Height | Gets the height of the bounds.
Public property | IsEmpty | Gets a value that indicates whether this bounds is the Empty bounds.
Public property | IsLeftToRight | Gets whether the text is left-to-right.
Public property | IsRightToLeft | Gets whether the text is right-to-left.
Public property | IsYValid | Gets a value that indicates whether the Y property is a valid value.
Public property | Left | Gets the x-axis position of the left side of the bounds. Getting this property is equivalent to getting the bounds's X property.
Public property | Rect | Gets a Rect that specifies the bounds.
Public property | Right | Gets the x-axis value of the right side of the bounds (X + Width).
Public property | Top | Gets the y-axis position of the top of the bounds. Getting this property is equivalent to getting the bounds's Y property.
Public property | Width | Gets the width of the bounds.
Public property | X | Gets the x-axis position of the left side of the bounds.
Public property | Y | Gets the y-axis position of the top of the bounds.
Top
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Bottom Property

TextBoundsBottom Property
Gets the y-axis value of the bottom of the bounds (Y + Height).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Bottom { get; }
Public ReadOnly Property Bottom As Double
    Get

Property Value

Type: Double
The y-axis value of the bottom of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Empty Property

TextBoundsEmpty Property
Gets the empty bounds, a special value that represents a bounds with no position or area.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static TextBounds Empty { get; }
Public Shared ReadOnly Property Empty As TextBounds
    Get

Property Value

Type: TextBounds
The empty rectangle, which has X and Y values of PositiveInfinity, and has Width and Height values of NegativeInfinity.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.FlowDirection Property

TextBoundsFlowDirection Property
Gets the FlowDirection of the text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public FlowDirection FlowDirection { get; }
Public ReadOnly Property FlowDirection As FlowDirection
    Get

Property Value

Type: FlowDirection
The FlowDirection of the text.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Height Property

TextBoundsHeight Property
Gets the height of the bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get

Property Value

Type: Double
The height of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.IsEmpty Property

TextBoundsIsEmpty Property
Gets a value that indicates whether this bounds is the Empty bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
true if this rectangle is the Empty rectangle; otherwise, false.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.IsLeftToRight Property

TextBoundsIsLeftToRight Property
Gets whether the text is left-to-right.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsLeftToRight { get; }
Public ReadOnly Property IsLeftToRight As Boolean
    Get

Property Value

Type: Boolean
true if the text is left-to-right; otherwise, false.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.IsRightToLeft Property

TextBoundsIsRightToLeft Property
Gets whether the text is right-to-left.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsRightToLeft { get; }
Public ReadOnly Property IsRightToLeft As Boolean
    Get

Property Value

Type: Boolean
true if the text is right-to-left; otherwise, false.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.IsYValid Property

TextBoundsIsYValid Property
Gets a value that indicates whether the Y property is a valid value.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsYValid { get; }
Public ReadOnly Property IsYValid As Boolean
    Get

Property Value

Type: Boolean
true if the Y property is a valid value; otherwise, false.
Remarks
The Y value may be invalid when getting bounds for a text line that is not currently visible.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Left Property

TextBoundsLeft Property
Gets the x-axis position of the left side of the bounds. Getting this property is equivalent to getting the bounds's X property.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Left { get; }
Public ReadOnly Property Left As Double
    Get

Property Value

Type: Double
The x-axis position of the left side of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Rect Property

TextBoundsRect Property
Gets a Rect that specifies the bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public Rect Rect { get; }
Public ReadOnly Property Rect As Rect
    Get

Property Value

Type: Rect
A Rect that specifies the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Right Property

TextBoundsRight Property
Gets the x-axis value of the right side of the bounds (X + Width).

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Right { get; }
Public ReadOnly Property Right As Double
    Get

Property Value

Type: Double
The x-axis value of the right side of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Top Property

TextBoundsTop Property
Gets the y-axis position of the top of the bounds. Getting this property is equivalent to getting the bounds's Y property.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Top { get; }
Public ReadOnly Property Top As Double
    Get

Property Value

Type: Double
The y-axis position of the top of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Width Property

TextBoundsWidth Property
Gets the width of the bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get

Property Value

Type: Double
The width of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.X Property

TextBoundsX Property
Gets the x-axis position of the left side of the bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double X { get; }
Public ReadOnly Property X As Double
    Get

Property Value

Type: Double
The x-axis position of the left side of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Y Property

TextBoundsY Property
Gets the y-axis position of the top of the bounds.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public double Y { get; }
Public ReadOnly Property Y As Double
    Get

Property Value

Type: Double
The y-axis position of the top of the bounds.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Methods

TextBounds Methods

The TextBounds type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ValueTypeEquals(Object).)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | Converts the object to a String. (Overrides ValueTypeToString.)
Top
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Equals Method

TextBoundsEquals Method
Determines whether the specified Object is equal to the current Object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare to the current Object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.GetHashCode Method

TextBoundsGetHashCode Method
Returns a hash code for this object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
An integer value that specifies a hash value for this object.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.ToString Method

TextBoundsToString Method
Converts the object to a String.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string whose value represents this object.
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds Operators

TextBounds Operators

The TextBounds type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Equality Operator

TextBoundsEquality Operator

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Equality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator ==(
    TextBounds left,
    TextBounds right
)
Public Shared Operator = (
    left As TextBounds,
    right As TextBounds
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

[Missing <param name="left"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Equality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

right
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

[Missing <param name="right"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Equality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Equality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextBounds.Inequality Operator

TextBoundsInequality Operator

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Inequality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static bool operator !=(
    TextBounds left,
    TextBounds right
)
Public Shared Operator <> (
    left As TextBounds,
    right As TextBounds
) As Boolean

Parameters

left
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

[Missing <param name="left"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Inequality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

right
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

[Missing <param name="right"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Inequality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds.op_Inequality(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds,ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

See Also

Reference

TextBounds Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextCompositionEventArgs Class

TextCompositionEventArgs Class
Event arguments for a text composition.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextCompositionEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextCompositionEventArgs
Public Class TextCompositionEventArgs

The TextCompositionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextCompositionEventArgs | Initializes a new instance of the TextCompositionEventArgs class.
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets whether the event has been handled.
Public property | Text | Gets the input text.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextCompositionEventArgs Constructor

TextCompositionEventArgs Constructor
Initializes a new instance of the TextCompositionEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextCompositionEventArgs(
    string text
)
Public Sub New (
    text As String
)

Parameters

text
Type: SystemString
The input text.
See Also

Reference

TextCompositionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextCompositionEventArgs Properties

TextCompositionEventArgs Properties

The TextCompositionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets whether the event has been handled.
Public property | Text | Gets the input text.
Top
See Also

Reference

TextCompositionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextCompositionEventArgs.Handled Property

TextCompositionEventArgsHandled Property
Gets or sets whether the event has been handled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

TextCompositionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextCompositionEventArgs.Text Property

TextCompositionEventArgsText Property
Gets the input text.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get

Property Value

Type: String
The input text.
See Also

Reference

TextCompositionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextCompositionEventArgs Methods

TextCompositionEventArgs Methods

The TextCompositionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextCompositionEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewEventArgs Class

TextViewEventArgs Class
Event arguments for a ITextView.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextViewEventArgs
Public Class TextViewEventArgs

The TextViewEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextViewEventArgs | Initializes a new instance of the TextViewEventArgs class.
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets whether the event has been handled.
Public property | View | Gets the ITextView that is affected by this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewEventArgs Constructor

TextViewEventArgs Constructor
Initializes a new instance of the TextViewEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextViewEventArgs(
    ITextView view
)
Public Sub New (
    view As ITextView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that is affected by this event.
See Also

Reference

TextViewEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewEventArgs Properties

TextViewEventArgs Properties

The TextViewEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets whether the event has been handled.
Public property | View | Gets the ITextView that is affected by this event.
Top
See Also

Reference

TextViewEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewEventArgs.Handled Property

TextViewEventArgsHandled Property
Gets or sets whether the event has been handled.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the event has been handled; otherwise, false.
See Also

Reference

TextViewEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewEventArgs.View Property

TextViewEventArgsView Property
Gets the ITextView that is affected by this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextView View { get; }
Public ReadOnly Property View As ITextView
    Get

Property Value

Type: ITextView
The ITextView that is affected by this event.
See Also

Reference

TextViewEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewEventArgs Methods

TextViewEventArgs Methods

The TextViewEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextViewEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange Class

TextViewLineChange Class
Specifies the change made to the text represented by an ITextViewLine on the last layout pass.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewLineChange

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextViewLineChange : Enum
Public NotInheritable Class TextViewLineChange
    Inherits Enum

The TextViewLineChange type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | AddedOrUpdated | The line was added or updated.
 | None | No change was made.
 | Removed | The line was removed.
 | Translated | The line was moved up or down within the view's text area.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange Methods

TextViewLineChange Methods

The TextViewLineChange type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange Fields

TextViewLineChange Fields

The TextViewLineChange type exposes the following members.

Fields
 | Name | Description
 | AddedOrUpdated | The line was added or updated.
 | None | No change was made.
 | Removed | The line was removed.
 | Translated | The line was moved up or down within the view's text area.
Public field | value__ |
Top
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange.AddedOrUpdated Field

TextViewLineChangeAddedOrUpdated Field
The line was added or updated.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineChange AddedOrUpdated = 1
Public Const AddedOrUpdated As TextViewLineChange = 1

Field Value

Type: TextViewLineChange
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange.None Field

TextViewLineChangeNone Field
No change was made.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineChange None = 0
Public Const None As TextViewLineChange = 0

Field Value

Type: TextViewLineChange
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange.Removed Field

TextViewLineChangeRemoved Field
The line was removed.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineChange Removed = 3
Public Const Removed As TextViewLineChange = 3

Field Value

Type: TextViewLineChange
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange.Translated Field

TextViewLineChangeTranslated Field
The line was moved up or down within the view's text area.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineChange Translated = 2
Public Const Translated As TextViewLineChange = 2

Field Value

Type: TextViewLineChange
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineChange.value__ Field

TextViewLineChangevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextViewLineChange.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TextViewLineChange Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility Class

TextViewLineVisibility Class
Specifies the vertical visibility of an ITextViewLine.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewLineVisibility

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class TextViewLineVisibility : Enum
Public NotInheritable Class TextViewLineVisibility
    Inherits Enum

The TextViewLineVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | FullyVisible | The line is fully visible vertically.
 | Hidden | The line is not visible.
 | PartiallyVisible | The line is partially visible vertically. This is usually only set on the last visible line in a view.
Public field | value__ |
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility Methods

TextViewLineVisibility Methods

The TextViewLineVisibility type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

TextViewLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility Fields

TextViewLineVisibility Fields

The TextViewLineVisibility type exposes the following members.

Fields
 | Name | Description
 | FullyVisible | The line is fully visible vertically.
 | Hidden | The line is not visible.
 | PartiallyVisible | The line is partially visible vertically. This is usually only set on the last visible line in a view.
Public field | value__ |
Top
See Also

Reference

TextViewLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility.FullyVisible Field

TextViewLineVisibilityFullyVisible Field
The line is fully visible vertically.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineVisibility FullyVisible = 1
Public Const FullyVisible As TextViewLineVisibility = 1

Field Value

Type: TextViewLineVisibility
See Also

Reference

TextViewLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility.Hidden Field

TextViewLineVisibilityHidden Field
The line is not visible.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineVisibility Hidden = 0
Public Const Hidden As TextViewLineVisibility = 0

Field Value

Type: TextViewLineVisibility
See Also

Reference

TextViewLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility.PartiallyVisible Field

TextViewLineVisibilityPartiallyVisible Field
The line is partially visible vertically. This is usually only set on the last visible line in a view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const TextViewLineVisibility PartiallyVisible = 2
Public Const PartiallyVisible As TextViewLineVisibility = 2

Field Value

Type: TextViewLineVisibility
See Also

Reference

TextViewLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewLineVisibility.value__ Field

TextViewLineVisibilityvalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextViewLineVisibility.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

TextViewLineVisibility Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs Class

TextViewTextAreaLayoutEventArgs Class
Event arguments for a ITextView.TextAreaLayout event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextViewTextAreaLayoutEventArgs

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class TextViewTextAreaLayoutEventArgs : EventArgs
Public Class TextViewTextAreaLayoutEventArgs
    Inherits EventArgs

The TextViewTextAreaLayoutEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TextViewTextAreaLayoutEventArgs | Initializes a new instance of the TextViewTextAreaLayoutEventArgs class.
Top
Properties
 | Name | Description
Public property | AddedOrUpdatedViewLines | Gets the collection of view lines that were added or updated by this layout cycle.
Public property | RemovedViewLines | Gets the collection of view lines that were removed by this layout cycle.
Public property | TranslatedViewLines | Gets the collection of view lines that were translated by this layout cycle.
Public property | View | Gets the ITextView that is affected by this event.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs Constructor

TextViewTextAreaLayoutEventArgs Constructor
Initializes a new instance of the TextViewTextAreaLayoutEventArgs class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TextViewTextAreaLayoutEventArgs(
    ITextView view
)
Public Sub New (
    view As ITextView
)

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that is affected by this event.
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs Properties

TextViewTextAreaLayoutEventArgs Properties

The TextViewTextAreaLayoutEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AddedOrUpdatedViewLines | Gets the collection of view lines that were added or updated by this layout cycle.
Public property | RemovedViewLines | Gets the collection of view lines that were removed by this layout cycle.
Public property | TranslatedViewLines | Gets the collection of view lines that were translated by this layout cycle.
Public property | View | Gets the ITextView that is affected by this event.
Top
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs.AddedOrUpdatedViewLines Property

TextViewTextAreaLayoutEventArgsAddedOrUpdatedViewLines Property
Gets the collection of view lines that were added or updated by this layout cycle.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<ITextViewLine> AddedOrUpdatedViewLines { get; }
Public ReadOnly Property AddedOrUpdatedViewLines As IEnumerable(Of ITextViewLine)
    Get

Property Value

Type: IEnumerable ITextViewLine
The collection of view lines that were added or updated by this layout cycle.
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs.RemovedViewLines Property

TextViewTextAreaLayoutEventArgsRemovedViewLines Property
Gets the collection of view lines that were removed by this layout cycle.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<ITextViewLine> RemovedViewLines { get; }
Public ReadOnly Property RemovedViewLines As IEnumerable(Of ITextViewLine)
    Get

Property Value

Type: IEnumerable ITextViewLine
The collection of view lines that were removed by this layout cycle.
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs.TranslatedViewLines Property

TextViewTextAreaLayoutEventArgsTranslatedViewLines Property
Gets the collection of view lines that were translated by this layout cycle.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<ITextViewLine> TranslatedViewLines { get; }
Public ReadOnly Property TranslatedViewLines As IEnumerable(Of ITextViewLine)
    Get

Property Value

Type: IEnumerable ITextViewLine
The collection of view lines that were translated by this layout cycle.
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs.View Property

TextViewTextAreaLayoutEventArgsView Property
Gets the ITextView that is affected by this event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public ITextView View { get; }
Public ReadOnly Property View As ITextView
    Get

Property Value

Type: ITextView
The ITextView that is affected by this event.
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


TextViewTextAreaLayoutEventArgs Methods

TextViewTextAreaLayoutEventArgs Methods

The TextViewTextAreaLayoutEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TextViewTextAreaLayoutEventArgs Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


WordWrapMode Class

WordWrapMode Class
Specifies the mode of word wrapping to perform.
Inheritance Hierarchy
SystemObject
SystemValueType
SystemEnum
ActiproSoftware.UI.Xaml.Controls.SyntaxEditorWordWrapMode

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class WordWrapMode : Enum
Public NotInheritable Class WordWrapMode
    Inherits Enum

The WordWrapMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
Fields
 | Name | Description
 | None | Do not perform any word wrapping.
Public field | value__ |
 | Word | Perform word-boundary-based word wrap.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


WordWrapMode Methods

WordWrapMode Methods

The WordWrapMode type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | (Inherited from Enum.)
Public method | Equals | (Inherited from Enum.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Enum.)
Public method | GetType | (Inherited from Object.)
Public method | HasFlag | (Inherited from Enum.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Enum.)
Public method | ToString(String) | (Inherited from Enum.)
Top
See Also

Reference

WordWrapMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


WordWrapMode Fields

WordWrapMode Fields

The WordWrapMode type exposes the following members.

Fields
 | Name | Description
 | None | Do not perform any word wrapping.
Public field | value__ |
 | Word | Perform word-boundary-based word wrap.
Top
See Also

Reference

WordWrapMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


WordWrapMode.None Field

WordWrapModeNone Field
Do not perform any word wrapping.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WordWrapMode None = 0
Public Const None As WordWrapMode = 0

Field Value

Type: WordWrapMode
See Also

Reference

WordWrapMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


WordWrapMode.value__ Field

WordWrapModevalue__ Field

[Missing <summary> documentation for "F:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.WordWrapMode.value__"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public int value__
Public value__ As Integer

Field Value

Type: Int32
See Also

Reference

WordWrapMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


WordWrapMode.Word Field

WordWrapModeWord Field
Perform word-boundary-based word wrap.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public const WordWrapMode Word = 1
Public Const Word As WordWrapMode = 1

Field Value

Type: WordWrapMode
See Also

Reference

WordWrapMode Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace
Contains types related to adornments.
Classes
 | Class | Description
Public class | AdornmentLayerDefinition | Provides a definition that is used when creating a new IAdornmentLayer.
Public class | AdornmentLayerDefinitions | Provides access to the built-in AdornmentLayerDefinition instances.
Interfaces
 | Interface | Description
Public interface | IAdornment | Provides the base requirements for an adornment that is within an IAdornmentLayer.
Public interface | IAdornmentLayer | Provides the base requirements for an adornment layer within an ITextView that contains IAdornment objects.
Public interface | IAdornmentManager | Provides the base requirements for an ITextView adornment manager, that adds and removes adornments to a particular IAdornmentLayer as appropriate.
Public interface | IAdornmentManagerProvider | Provides the base requirements for a object that can create IAdornmentManager objects for an ITextView.


AdornmentLayerDefinition Class

AdornmentLayerDefinition Class
Provides a definition that is used when creating a new IAdornmentLayer.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public sealed class AdornmentLayerDefinition : IOrderable,
    IKeyedObject
Public NotInheritable Class AdornmentLayerDefinition
    Implements IOrderable, IKeyedObject

The AdornmentLayerDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | AdornmentLayerDefinition(String) | Initializes a new instance of the AdornmentLayerDefinition class.
Public method | AdornmentLayerDefinition(String, Ordering) | Initializes a new instance of the AdornmentLayerDefinition class.
Public method | AdornmentLayerDefinition(String, IEnumerableOrdering) | Initializes a new instance of the AdornmentLayerDefinition class.
Top
Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the layer.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition Constructor

AdornmentLayerDefinition Constructor
Overload List
 | Name | Description
Public method | AdornmentLayerDefinition(String) | Initializes a new instance of the AdornmentLayerDefinition class.
Public method | AdornmentLayerDefinition(String, Ordering) | Initializes a new instance of the AdornmentLayerDefinition class.
Public method | AdornmentLayerDefinition(String, IEnumerableOrdering) | Initializes a new instance of the AdornmentLayerDefinition class.
Top
See Also

Reference

AdornmentLayerDefinition Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition Constructor (String)

AdornmentLayerDefinition Constructor (String)
Initializes a new instance of the AdornmentLayerDefinition class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdornmentLayerDefinition(
    string key
)
Public Sub New (
    key As String
)

Parameters

key
Type: SystemString
The string-based key that identifies the layer.
See Also

Reference

AdornmentLayerDefinition Class
AdornmentLayerDefinition Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition Constructor (String, Ordering[])

AdornmentLayerDefinition Constructor (String, Ordering)
Initializes a new instance of the AdornmentLayerDefinition class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdornmentLayerDefinition(
    string key,
    params Ordering[] orderings
)
Public Sub New (
    key As String,
    ParamArray orderings As Ordering()
)

Parameters

key
Type: SystemString
The string-based key that identifies the layer.
orderings
Type: ActiproSoftware.Text.UtilityOrdering
The array of Ordering objects, used to determine how this object is positioned relative to other objects.
See Also

Reference

AdornmentLayerDefinition Class
AdornmentLayerDefinition Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition Constructor (String, IEnumerable(Ordering))

AdornmentLayerDefinition Constructor (String, IEnumerableOrdering)
Initializes a new instance of the AdornmentLayerDefinition class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdornmentLayerDefinition(
    string key,
    IEnumerable<Ordering> orderings
)
Public Sub New (
    key As String,
    orderings As IEnumerable(Of Ordering)
)

Parameters

key
Type: SystemString
The string-based key that identifies the layer.
orderings
Type: System.Collections.GenericIEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.
See Also

Reference

AdornmentLayerDefinition Class
AdornmentLayerDefinition Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition Properties

AdornmentLayerDefinition Properties

The AdornmentLayerDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the string-based key that identifies the layer.
Public property | Orderings | Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.
Top
See Also

Reference

AdornmentLayerDefinition Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition.Key Property

AdornmentLayerDefinitionKey Property
Gets the string-based key that identifies the layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get

Property Value

Type: String
The string-based key that identifies the layer.

Implements

IKeyedObjectKey
See Also

Reference

AdornmentLayerDefinition Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition.Orderings Property

AdornmentLayerDefinitionOrderings Property
Gets the collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IEnumerable<Ordering> Orderings { get; }
Public ReadOnly Property Orderings As IEnumerable(Of Ordering)
    Get

Property Value

Type: IEnumerable Ordering
The collection of Ordering objects, used to determine how this object is positioned relative to other objects.

Implements

IOrderableOrderings
See Also

Reference

AdornmentLayerDefinition Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinition Methods

AdornmentLayerDefinition Methods

The AdornmentLayerDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdornmentLayerDefinition Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions Class

AdornmentLayerDefinitions Class
Provides access to the built-in AdornmentLayerDefinition instances.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinitions

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static class AdornmentLayerDefinitions
Public NotInheritable Class AdornmentLayerDefinitions

The AdornmentLayerDefinitions type exposes the following members.

Properties
Name | Description
Caret | Gets the AdornmentLayerDefinition for the caret layer.
CollapsedRegion | Gets the AdornmentLayerDefinition for the collapsed region layer.
Guides | Gets the AdornmentLayerDefinition for the guides layer.
Highlight | Gets the AdornmentLayerDefinition for the highlight layer.
Selection | Gets the AdornmentLayerDefinition for the selection layer.
Squiggle | Gets the AdornmentLayerDefinition for the squiggle lines layer.
TextBackground | Gets the AdornmentLayerDefinition for the text background layer.
TextForeground | Gets the AdornmentLayerDefinition for the text foreground layer.
Top
Remarks
Order from top to bottom: Caret, TextForeground, Squiggle, CollapsedRegion, Selection, Highlight, Guides, TextBackground.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions Properties

AdornmentLayerDefinitions Properties

The AdornmentLayerDefinitions type exposes the following members.

Properties
Name | Description
Caret | Gets the AdornmentLayerDefinition for the caret layer.
CollapsedRegion | Gets the AdornmentLayerDefinition for the collapsed region layer.
Guides | Gets the AdornmentLayerDefinition for the guides layer.
Highlight | Gets the AdornmentLayerDefinition for the highlight layer.
Selection | Gets the AdornmentLayerDefinition for the selection layer.
Squiggle | Gets the AdornmentLayerDefinition for the squiggle lines layer.
TextBackground | Gets the AdornmentLayerDefinition for the text background layer.
TextForeground | Gets the AdornmentLayerDefinition for the text foreground layer.
Top
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.Caret Property

AdornmentLayerDefinitionsCaret Property
Gets the AdornmentLayerDefinition for the caret layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition Caret { get; }
Public Shared ReadOnly Property Caret As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the caret layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.CollapsedRegion Property

AdornmentLayerDefinitionsCollapsedRegion Property
Gets the AdornmentLayerDefinition for the collapsed region layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition CollapsedRegion { get; }
Public Shared ReadOnly Property CollapsedRegion As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the collapsed region layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.Guides Property

AdornmentLayerDefinitionsGuides Property
Gets the AdornmentLayerDefinition for the guides layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition Guides { get; }
Public Shared ReadOnly Property Guides As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the guides layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.Highlight Property

AdornmentLayerDefinitionsHighlight Property
Gets the AdornmentLayerDefinition for the highlight layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition Highlight { get; }
Public Shared ReadOnly Property Highlight As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the highlight layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.Selection Property

AdornmentLayerDefinitionsSelection Property
Gets the AdornmentLayerDefinition for the selection layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition Selection { get; }
Public Shared ReadOnly Property Selection As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the selection layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.Squiggle Property

AdornmentLayerDefinitionsSquiggle Property
Gets the AdornmentLayerDefinition for the squiggle lines layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition Squiggle { get; }
Public Shared ReadOnly Property Squiggle As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the squiggle lines layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.TextBackground Property

AdornmentLayerDefinitionsTextBackground Property
Gets the AdornmentLayerDefinition for the text background layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition TextBackground { get; }
Public Shared ReadOnly Property TextBackground As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the text background layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


AdornmentLayerDefinitions.TextForeground Property

AdornmentLayerDefinitionsTextForeground Property
Gets the AdornmentLayerDefinition for the text foreground layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public static AdornmentLayerDefinition TextForeground { get; }
Public Shared ReadOnly Property TextForeground As AdornmentLayerDefinition
    Get

Property Value

Type: AdornmentLayerDefinition
The AdornmentLayerDefinition for the text foreground layer.
See Also

Reference

AdornmentLayerDefinitions Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment Interface

IAdornment Interface
Provides the base requirements for an adornment that is within an IAdornmentLayer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAdornment
Public Interface IAdornment

The IAdornment type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets a Point indicating the current location of the adornment.
Public property | RemovedCallback | Gets the callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.
Public property | SnapshotRange | Gets the nullable TextSnapshotRange that optionally indicates the range of the adornment.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | TrackingModes | Gets a nullable TextRangeTrackingModes indicating the tracking modes to use.
Public property | VisualElement | Gets the UIElement that is used to visually render the adornment.
Top
Methods
 | Name | Description
Public method | Translate | Translates the adornment by the specified x- and y-coordinate values.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment Properties

IAdornment Properties

The IAdornment type exposes the following members.

Properties
 | Name | Description
Public property | Location | Gets or sets a Point indicating the current location of the adornment.
Public property | RemovedCallback | Gets the callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.
Public property | SnapshotRange | Gets the nullable TextSnapshotRange that optionally indicates the range of the adornment.
Public property | Tag | Gets or sets the object that contains user-defined data about the object.
Public property | TrackingModes | Gets a nullable TextRangeTrackingModes indicating the tracking modes to use.
Public property | VisualElement | Gets the UIElement that is used to visually render the adornment.
Top
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.Location Property

IAdornmentLocation Property
Gets or sets a Point indicating the current location of the adornment.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Point Location { get; set; }
Property Location As Point
    Get
    Set

Property Value

Type: Point
A Point indicating the current location of the adornment.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.RemovedCallback Property

IAdornmentRemovedCallback Property
Gets the callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Action<IAdornment> RemovedCallback { get; }
ReadOnly Property RemovedCallback As Action(Of IAdornment)
    Get

Property Value

Type: Action IAdornment
The callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.SnapshotRange Property

IAdornmentSnapshotRange Property
Gets the nullable TextSnapshotRange that optionally indicates the range of the adornment.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextSnapshotRange> SnapshotRange { get; }
ReadOnly Property SnapshotRange As Nullable(Of TextSnapshotRange)
    Get

Property Value

Type: Nullable TextSnapshotRange
The nullable TextSnapshotRange that optionally indicates the range of the adornment.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.Tag Property

IAdornmentTag Property
Gets or sets the object that contains user-defined data about the object.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Object Tag { get; }
ReadOnly Property Tag As Object
    Get

Property Value

Type: Object
An Object that contains user-defined data about the object. The default is .
Remarks
Any type derived from the Object class can be assigned to this property.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.TrackingModes Property

IAdornmentTrackingModes Property
Gets a nullable TextRangeTrackingModes indicating the tracking modes to use.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
Nullable<TextRangeTrackingModes> TrackingModes { get; }
ReadOnly Property TrackingModes As Nullable(Of TextRangeTrackingModes)
    Get

Property Value

Type: Nullable TextRangeTrackingModes
A nullable TextRangeTrackingModes indicating the tracking modes to use.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.VisualElement Property

IAdornmentVisualElement Property
Gets the UIElement that is used to visually render the adornment.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
UIElement VisualElement { get; }
ReadOnly Property VisualElement As UIElement
    Get

Property Value

Type: UIElement
The UIElement that is used to visually render the adornment.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment Methods

IAdornment Methods

The IAdornment type exposes the following members.

Methods
 | Name | Description
Public method | Translate | Translates the adornment by the specified x- and y-coordinate values.
Top
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornment.Translate Method

IAdornmentTranslate Method
Translates the adornment by the specified x- and y-coordinate values.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Translate(
    double deltaX,
    double deltaY
)
Sub Translate (
    deltaX As Double,
    deltaY As Double
)

Parameters

deltaX
Type: SystemDouble
The x-amount by which to move the adornment.
deltaY
Type: SystemDouble
The y-amount by which to move the adornment.
See Also

Reference

IAdornment Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer Interface

IAdornmentLayer Interface
Provides the base requirements for an adornment layer within an ITextView that contains IAdornment objects.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAdornmentLayer : IKeyedObject
Public Interface IAdornmentLayer
    Inherits IKeyedObject

The IAdornmentLayer type exposes the following members.

Properties
 | Name | Description
Public property | Adornments | Gets a read-only collection of the IAdornment objects in the layer.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Opacity | Gets or sets the opacity applies to the layer and all its contained visual elements.
Public property | View | Gets the ITextView to which this layer is attached.
Top
Methods
 | Name | Description
Public method | AddAdornment(UIElement, Point, Object, ActionIAdornment) | Adds a new adornment to the layer that is not tracked with a particular text range.
Public method | AddAdornment(UIElement, Point, Object, TextSnapshotRange, TextRangeTrackingModes, ActionIAdornment) | Adds a new adornment to the layer that is tracked with a particular text range
Public method | FindAdornment | Returns the IAdornment that contains the specified UIElement.
Public method | FindAdornments(Object) | Returns an array of IAdornment objects that contain the specified tag.
Public method | FindAdornments(PredicateIAdornment) | Returns an array of IAdornment objects that pass the specified match predicate.
Public method | FindAdornments(TextSnapshotRange) | Returns an array of IAdornment objects that intersect the specified TextSnapshotRange.
Public method | RemoveAdornment | Removes the specified adornment from the layer.
Public method | RemoveAdornments | Removes the specified adorments from the layer.
Public method | RemoveAllAdornments | Removes all adornments in the layer.
Top
Remarks
Use the AddAdornment method to create a new IAdornment within the layer.
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer Properties

IAdornmentLayer Properties

The IAdornmentLayer type exposes the following members.

Properties
 | Name | Description
Public property | Adornments | Gets a read-only collection of the IAdornment objects in the layer.
Public property | Key | Gets the string-based key that identifies the object. (Inherited from IKeyedObject.)
Public property | Opacity | Gets or sets the opacity applies to the layer and all its contained visual elements.
Public property | View | Gets the ITextView to which this layer is attached.
Top
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.Adornments Property

IAdornmentLayerAdornments Property
Gets a read-only collection of the IAdornment objects in the layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ReadOnlyCollection<IAdornment> Adornments { get; }
ReadOnly Property Adornments As ReadOnlyCollection(Of IAdornment)
    Get

Property Value

Type: ReadOnlyCollection IAdornment
A read-only collection of the IAdornment objects in the layer.
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.Opacity Property

IAdornmentLayerOpacity Property
Gets or sets the opacity applies to the layer and all its contained visual elements.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
double Opacity { get; set; }
Property Opacity As Double
    Get
    Set

Property Value

Type: Double
The opacity applies to the layer and all its contained visual elements.
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.View Property

IAdornmentLayerView Property
Gets the ITextView to which this layer is attached.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextView View { get; }
ReadOnly Property View As ITextView
    Get

Property Value

Type: ITextView
The ITextView to which this layer is attached.
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer Methods

IAdornmentLayer Methods

The IAdornmentLayer type exposes the following members.

Methods
 | Name | Description
Public method | AddAdornment(UIElement, Point, Object, ActionIAdornment) | Adds a new adornment to the layer that is not tracked with a particular text range.
Public method | AddAdornment(UIElement, Point, Object, TextSnapshotRange, TextRangeTrackingModes, ActionIAdornment) | Adds a new adornment to the layer that is tracked with a particular text range
Public method | FindAdornment | Returns the IAdornment that contains the specified UIElement.
Public method | FindAdornments(Object) | Returns an array of IAdornment objects that contain the specified tag.
Public method | FindAdornments(PredicateIAdornment) | Returns an array of IAdornment objects that pass the specified match predicate.
Public method | FindAdornments(TextSnapshotRange) | Returns an array of IAdornment objects that intersect the specified TextSnapshotRange.
Public method | RemoveAdornment | Removes the specified adornment from the layer.
Public method | RemoveAdornments | Removes the specified adorments from the layer.
Public method | RemoveAllAdornments | Removes all adornments in the layer.
Top
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.AddAdornment Method

IAdornmentLayerAddAdornment Method
Overload List
 | Name | Description
Public method | AddAdornment(UIElement, Point, Object, ActionIAdornment) | Adds a new adornment to the layer that is not tracked with a particular text range.
Public method | AddAdornment(UIElement, Point, Object, TextSnapshotRange, TextRangeTrackingModes, ActionIAdornment) | Adds a new adornment to the layer that is tracked with a particular text range
Top
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.AddAdornment Method (UIElement, Point, Object, Action(IAdornment))

IAdornmentLayerAddAdornment Method (UIElement, Point, Object, ActionIAdornment)
Adds a new adornment to the layer that is not tracked with a particular text range.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornment AddAdornment(
    UIElement visualElement,
    Point location,
    Object tag,
    Action<IAdornment> removedCallback
)
Function AddAdornment (
    visualElement As UIElement,
    location As Point,
    tag As Object,
    removedCallback As Action(Of IAdornment)
) As IAdornment

Parameters

visualElement
Type: Windows.UI.XamlUIElement
The UIElement that is used to visually render the adornment.
location
Type: Windows.FoundationPoint
The initial location of the adornment.
tag
Type: SystemObject
An Object that contains user-defined data about the adornment.
removedCallback
Type: SystemAction IAdornment
The callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.

Return Value

Type: IAdornment
The IAdornment that was created.
See Also

Reference

IAdornmentLayer Interface
AddAdornment Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.AddAdornment Method (UIElement, Point, Object, TextSnapshotRange, TextRangeTrackingModes, Action(IAdornment))

IAdornmentLayerAddAdornment Method (UIElement, Point, Object, TextSnapshotRange, TextRangeTrackingModes, ActionIAdornment)
Adds a new adornment to the layer that is tracked with a particular text range

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornment AddAdornment(
    UIElement visualElement,
    Point location,
    Object tag,
    TextSnapshotRange snapshotRange,
    TextRangeTrackingModes trackingModes,
    Action<IAdornment> removedCallback
)
Function AddAdornment (
    visualElement As UIElement,
    location As Point,
    tag As Object,
    snapshotRange As TextSnapshotRange,
    trackingModes As TextRangeTrackingModes,
    removedCallback As Action(Of IAdornment)
) As IAdornment

Parameters

visualElement
Type: Windows.UI.XamlUIElement
The UIElement that is used to visually render the adornment.
location
Type: Windows.FoundationPoint
The initial location of the adornment.
tag
Type: SystemObject
An Object that contains user-defined data about the adornment.
snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange that indicates the range of the adornment.
trackingModes
Type: ActiproSoftware.TextTextRangeTrackingModes
A TextRangeTrackingModes indicating the tracking modes to use.
removedCallback
Type: SystemAction IAdornment
The callback method that is invoked when the adornment is removed from its parent IAdornmentLayer.

Return Value

Type: IAdornment
The IAdornment that was created.
See Also

Reference

IAdornmentLayer Interface
AddAdornment Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.FindAdornment Method

IAdornmentLayerFindAdornment Method
Returns the IAdornment that contains the specified UIElement.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornment FindAdornment(
    UIElement visualElement
)
Function FindAdornment (
    visualElement As UIElement
) As IAdornment

Parameters

visualElement
Type: Windows.UI.XamlUIElement
The UIElement for which to search.

Return Value

Type: IAdornment
The IAdornment that contains the specified UIElement.
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.FindAdornments Method

IAdornmentLayerFindAdornments Method
Overload List
 | Name | Description
Public method | FindAdornments(Object) | Returns an array of IAdornment objects that contain the specified tag.
Public method | FindAdornments(PredicateIAdornment) | Returns an array of IAdornment objects that pass the specified match predicate.
Public method | FindAdornments(TextSnapshotRange) | Returns an array of IAdornment objects that intersect the specified TextSnapshotRange.
Top
See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.FindAdornments Method (Object)

IAdornmentLayerFindAdornments Method (Object)
Returns an array of IAdornment objects that contain the specified tag.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornment[] FindAdornments(
    Object tag
)
Function FindAdornments (
    tag As Object
) As IAdornment()

Parameters

tag
Type: SystemObject
The tag object for which to search.

Return Value

Type: IAdornment
An array of IAdornment objects that contain the specified tag.
See Also

Reference

IAdornmentLayer Interface
FindAdornments Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.FindAdornments Method (Predicate(IAdornment))

IAdornmentLayerFindAdornments Method (PredicateIAdornment)
Returns an array of IAdornment objects that pass the specified match predicate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornment[] FindAdornments(
    Predicate<IAdornment> match
)
Function FindAdornments (
    match As Predicate(Of IAdornment)
) As IAdornment()

Parameters

match
Type: SystemPredicate IAdornment
The predicate to use for determining adornments that meet custom criteria.

Return Value

Type: IAdornment
An array of IAdornment objects that pass the specified match predicate.
See Also

Reference

IAdornmentLayer Interface
FindAdornments Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.FindAdornments Method (TextSnapshotRange)

IAdornmentLayerFindAdornments Method (TextSnapshotRange)
Returns an array of IAdornment objects that intersect the specified TextSnapshotRange.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornment[] FindAdornments(
    TextSnapshotRange snapshotRange
)
Function FindAdornments (
    snapshotRange As TextSnapshotRange
) As IAdornment()

Parameters

snapshotRange
Type: ActiproSoftware.TextTextSnapshotRange
The TextSnapshotRange to examine.

Return Value

Type: IAdornment
An array of IAdornment objects that intersect the specified TextSnapshotRange.
See Also

Reference

IAdornmentLayer Interface
FindAdornments Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.RemoveAdornment Method

IAdornmentLayerRemoveAdornment Method
Removes the specified adornment from the layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RemoveAdornment(
    IAdornment adornmentToRemove
)
Function RemoveAdornment (
    adornmentToRemove As IAdornment
) As Boolean

Parameters

adornmentToRemove
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsIAdornment
The adornment to remove.

Field Value

Type: Boolean
true if the adornment were removed; otherwise, false.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.IAdornmentLayer.RemoveAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.IAdornment)"]

See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.RemoveAdornments Method

IAdornmentLayerRemoveAdornments Method
Removes the specified adorments from the layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RemoveAdornments(
    IEnumerable<IAdornment> adornmentsToRemove
)
Function RemoveAdornments (
    adornmentsToRemove As IEnumerable(Of IAdornment)
) As Boolean

Parameters

adornmentsToRemove
Type: System.Collections.GenericIEnumerable IAdornment
The collection of adornments to remove.

Field Value

Type: Boolean
true if any adornments were removed; otherwise, false.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.IAdornmentLayer.RemoveAdornments(System.Collections.Generic.IEnumerable{ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.IAdornment})"]

See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentLayer.RemoveAllAdornments Method

IAdornmentLayerRemoveAllAdornments Method
Removes all adornments in the layer.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool RemoveAllAdornments()
Function RemoveAllAdornments As Boolean

Field Value

Type: Boolean
true if any adornments were removed; otherwise, false.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.IAdornmentLayer.RemoveAllAdornments"]

See Also

Reference

IAdornmentLayer Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager Interface

IAdornmentManager Interface
Provides the base requirements for an ITextView adornment manager, that adds and removes adornments to a particular IAdornmentLayer as appropriate.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAdornmentManager
Public Interface IAdornmentManager

The IAdornmentManager type exposes the following members.

Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager.
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event.
Public property | View | Gets the view to which this manager is attached.
Top
Methods
 | Name | Description
Public method | Close | Closes the manager and detaches it from the view.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager Properties

IAdornmentManager Properties

The IAdornmentManager type exposes the following members.

Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager.
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event.
Public property | View | Gets the view to which this manager is attached.
Top
See Also

Reference

IAdornmentManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager.AdornmentLayer Property

IAdornmentManagerAdornmentLayer Property
Gets the IAdornmentLayer being managed by this manager.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornmentLayer AdornmentLayer { get; }
ReadOnly Property AdornmentLayer As IAdornmentLayer
    Get

Property Value

Type: IAdornmentLayer
The IAdornmentLayer being managed by this manager.
See Also

Reference

IAdornmentManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager.IsActive Property

IAdornmentManagerIsActive Property
Gets or sets whether the manager's adornments are currently active, generally based on some option or event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
bool IsActive { get; set; }
Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the manager's adornments are currently active; otherwise, false.
See Also

Reference

IAdornmentManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager.View Property

IAdornmentManagerView Property
Gets the view to which this manager is attached.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
ITextView View { get; }
ReadOnly Property View As ITextView
    Get

Property Value

Type: ITextView
The view to which this manager is attached.
See Also

Reference

IAdornmentManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager Methods

IAdornmentManager Methods

The IAdornmentManager type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the manager and detaches it from the view.
Top
See Also

Reference

IAdornmentManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManager.Close Method

IAdornmentManagerClose Method
Closes the manager and detaches it from the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
void Close()
Sub Close
See Also

Reference

IAdornmentManager Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManagerProvider Interface

IAdornmentManagerProvider Interface
Provides the base requirements for a object that can create IAdornmentManager objects for an ITextView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public interface IAdornmentManagerProvider
Public Interface IAdornmentManagerProvider

The IAdornmentManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetAdornmentManager | Returns a IAdornmentManager for the specified ITextView.
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManagerProvider Methods

IAdornmentManagerProvider Methods

The IAdornmentManagerProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetAdornmentManager | Returns a IAdornmentManager for the specified ITextView.
Top
See Also

Reference

IAdornmentManagerProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


IAdornmentManagerProvider.GetAdornmentManager Method

IAdornmentManagerProviderGetAdornmentManager Method
Returns a IAdornmentManager for the specified ITextView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
IAdornmentManager GetAdornmentManager(
    ITextView view
)
Function GetAdornmentManager (
    view As ITextView
) As IAdornmentManager

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that requires an IAdornmentManager.

Return Value

Type: IAdornmentManager
A IAdornmentManager for the specified ITextView.
See Also

Reference

IAdornmentManagerProvider Interface
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace
Contains implementation types related to adornments.
Classes
 | Class | Description
Public class | AdornmentManagerBaseTView | Provides an abstract base class for an adornment manager.
Public class | AdornmentManagerProviderTManager | Provides an IAdornmentManagerProvider capable of creating IAdornmentManager objects which have a constructor that accepts a single ITextView instance parameter.
Public class | DecorationAdornmentManagerBaseTView, TTag | Provides a helpful base class for implementing an adornment manager that displays text decorations.
Public class | IntraTextAdornmentManagerBaseTView, TTag | Provides a helpful base class for implementing an adornment manager that displays adornments in intra-text spacers.


AdornmentManagerBase(TView) Class

AdornmentManagerBaseTView Class
Provides an abstract base class for an adornment manager.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationAdornmentManagerBaseTView
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationDecorationAdornmentManagerBaseTView, TTag
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationIntraTextAdornmentManagerBaseTView, TTag

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class AdornmentManagerBase<TView> : IAdornmentManager
where TView : ITextView

Public MustInherit Class AdornmentManagerBase(Of TView As ITextView)
    Implements IAdornmentManager

Type Parameters

TView
The type of ITextView to support. Use ITextView to support all text view types.

The AdornmentManagerBaseTView type exposes the following members.

Constructors
 | Name | Description
Protected method | AdornmentManagerBaseTView(TView, AdornmentLayerDefinition) | Initializes a new instance of the AdornmentManagerBase class.
Protected method | AdornmentManagerBaseTView(TView, AdornmentLayerDefinition, Boolean) | Initializes a new instance of the AdornmentManagerBase class.
Top
Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager.
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event.
Public property | View | Gets the view to which this manager is attached.
Top
Methods
 | Name | Description
Public method | Close | Closes the manager and detaches it from the view.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view.
Protected method | OnIsActiveChanged | Occurs when the IsActive property changes.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView) Constructor

AdornmentManagerBaseTView Constructor
Overload List
 | Name | Description
Protected method | AdornmentManagerBaseTView(TView, AdornmentLayerDefinition) | Initializes a new instance of the AdornmentManagerBase class.
Protected method | AdornmentManagerBaseTView(TView, AdornmentLayerDefinition, Boolean) | Initializes a new instance of the AdornmentManagerBase class.
Top
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView) Constructor (TView, AdornmentLayerDefinition)

AdornmentManagerBaseTView Constructor (TView, AdornmentLayerDefinition)
Initializes a new instance of the AdornmentManagerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AdornmentManagerBase(
    TView view,
    AdornmentLayerDefinition layerDefinition
)
Protected Sub New (
    view As TView,
    layerDefinition As AdornmentLayerDefinition
)

Parameters

view
Type: TView
The view to which this manager is attached.
layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The AdornmentLayerDefinition indicating which adornment layer to use.
See Also

Reference

AdornmentManagerBaseTView Class
AdornmentManagerBaseTView Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView) Constructor (TView, AdornmentLayerDefinition, Boolean)

AdornmentManagerBaseTView Constructor (TView, AdornmentLayerDefinition, Boolean)
Initializes a new instance of the AdornmentManagerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected AdornmentManagerBase(
    TView view,
    AdornmentLayerDefinition layerDefinition,
    bool isForLanguage
)
Protected Sub New (
    view As TView,
    layerDefinition As AdornmentLayerDefinition,
    isForLanguage As Boolean
)

Parameters

view
Type: TView
The view to which this manager is attached.
layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The AdornmentLayerDefinition indicating which adornment layer to use.
isForLanguage
Type: SystemBoolean
Indicates whether this adornment manager is for a language. If true, the adornment manager is closed when the language or document within a SyntaxEditor changes.
See Also

Reference

AdornmentManagerBaseTView Class
AdornmentManagerBaseTView Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView) Properties

AdornmentManagerBaseTView Properties

The AdornmentManagerBaseTView generic type exposes the following members.

Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager.
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event.
Public property | View | Gets the view to which this manager is attached.
Top
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView).AdornmentLayer Property

AdornmentManagerBaseTViewAdornmentLayer Property
Gets the IAdornmentLayer being managed by this manager.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAdornmentLayer AdornmentLayer { get; }
Public ReadOnly Property AdornmentLayer As IAdornmentLayer
    Get

Property Value

Type: IAdornmentLayer
The IAdornmentLayer being managed by this manager.

Implements

IAdornmentManagerAdornmentLayer
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView).IsActive Property

AdornmentManagerBaseTViewIsActive Property
Gets or sets whether the manager's adornments are currently active, generally based on some option or event.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public bool IsActive { get; set; }
Public Property IsActive As Boolean
    Get
    Set

Property Value

Type: Boolean
true if the manager's adornments are currently active; otherwise, false.

Implements

IAdornmentManagerIsActive
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView).View Property

AdornmentManagerBaseTViewView Property
Gets the view to which this manager is attached.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public TView View { get; }
Public ReadOnly Property View As TView
    Get

Property Value

Type: TView
The view to which this manager is attached.
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView) Methods

AdornmentManagerBaseTView Methods

The AdornmentManagerBaseTView generic type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the manager and detaches it from the view.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view.
Protected method | OnIsActiveChanged | Occurs when the IsActive property changes.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView).Close Method

AdornmentManagerBaseTViewClose Method
Closes the manager and detaches it from the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

IAdornmentManagerClose
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView).OnClosed Method

AdornmentManagerBaseTViewOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnClosed()
Protected Overridable Sub OnClosed
Remarks
The default implementation of this method does nothing. Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerBase(TView).OnIsActiveChanged Method

AdornmentManagerBaseTViewOnIsActiveChanged Method
Occurs when the IsActive property changes.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected virtual void OnIsActiveChanged()
Protected Overridable Sub OnIsActiveChanged
Remarks
The default implementation of this method does nothing. Overrides should attach to or detach from other events that are needed while active.
See Also

Reference

AdornmentManagerBaseTView Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerProvider(TManager) Class

AdornmentManagerProviderTManager Class
Provides an IAdornmentManagerProvider capable of creating IAdornmentManager objects which have a constructor that accepts a single ITextView instance parameter.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationAdornmentManagerProviderTManager

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class AdornmentManagerProvider<TManager> : IAdornmentManagerProvider
where TManager : IAdornmentManager

Public Class AdornmentManagerProvider(Of TManager As IAdornmentManager)
    Implements IAdornmentManagerProvider

Type Parameters

TManager
The Type of IAdornmentManager that this factory creates. The tagger type must have a constructor that accepts a single ITextView instance parameter.

The AdornmentManagerProviderTManager type exposes the following members.

Constructors
 | Name | Description
Public method | AdornmentManagerProviderTManager | Initializes a new instance of the AdornmentManagerProvider class.
Public method | AdornmentManagerProviderTManager(Object) | Initializes a new instance of the AdornmentManagerProvider class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAdornmentManager | Returns a IAdornmentManager for the specified ITextView.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerProvider(TManager) Constructor

AdornmentManagerProviderTManager Constructor
Overload List
 | Name | Description
Public method | AdornmentManagerProviderTManager | Initializes a new instance of the AdornmentManagerProvider class.
Public method | AdornmentManagerProviderTManager(Object) | Initializes a new instance of the AdornmentManagerProvider class.
Top
See Also

Reference

AdornmentManagerProviderTManager Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerProvider(TManager) Constructor

AdornmentManagerProviderTManager Constructor
Initializes a new instance of the AdornmentManagerProvider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdornmentManagerProvider()
Public Sub New
See Also

Reference

AdornmentManagerProviderTManager Class
AdornmentManagerProviderTManager Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerProvider(TManager) Constructor (Object)

AdornmentManagerProviderTManager Constructor (Object)
Initializes a new instance of the AdornmentManagerProvider class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public AdornmentManagerProvider(
    Object singletonKey
)
Public Sub New (
    singletonKey As Object
)

Parameters

singletonKey
Type: SystemObject
When a non-null value is passed, the tagger will be stored as a singleton under the specified key in the views's properties.
See Also

Reference

AdornmentManagerProviderTManager Class
AdornmentManagerProviderTManager Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerProvider(TManager) Methods

AdornmentManagerProviderTManager Methods

The AdornmentManagerProviderTManager generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAdornmentManager | Returns a IAdornmentManager for the specified ITextView.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdornmentManagerProviderTManager Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


AdornmentManagerProvider(TManager).GetAdornmentManager Method

AdornmentManagerProviderTManagerGetAdornmentManager Method
Returns a IAdornmentManager for the specified ITextView.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public IAdornmentManager GetAdornmentManager(
    ITextView view
)
Public Function GetAdornmentManager (
    view As ITextView
) As IAdornmentManager

Parameters

view
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextView
The ITextView that requires an IAdornmentManager.

Return Value

Type: IAdornmentManager
A IAdornmentManager for the specified ITextView.

Implements

IAdornmentManagerProviderGetAdornmentManager(ITextView)
See Also

Reference

AdornmentManagerProviderTManager Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag) Class

DecorationAdornmentManagerBaseTView, TTag Class
Provides a helpful base class for implementing an adornment manager that displays text decorations.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationAdornmentManagerBase TView
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationDecorationAdornmentManagerBaseTView, TTag

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class DecorationAdornmentManagerBase<TView, TTag> : AdornmentManagerBase<TView>
where TView : ITextView
where TTag : ITag

Public MustInherit Class DecorationAdornmentManagerBase(Of TView As ITextView, TTag As ITag)
    Inherits AdornmentManagerBase(Of TView)

Type Parameters

TView
The type of ITextView to support. Use ITextView to support all text view types.
TTag
The type of ITag to aggregate.

The DecorationAdornmentManagerBaseTView, TTag type exposes the following members.

Constructors
 | Name | Description
Protected method | DecorationAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition) | Initializes a new instance of the DecorationAdornmentManagerBase class.
Protected method | DecorationAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition, Boolean) | Initializes a new instance of the DecorationAdornmentManagerBase class.
Top
Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager. (Inherited from AdornmentManagerBaseTView.)
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event. (Inherited from AdornmentManagerBaseTView.)
Public property | View | Gets the view to which this manager is attached. (Inherited from AdornmentManagerBaseTView.)
Top
Methods
 | Name | Description
Protected method | AddAdornment |
Public method | Close | Closes the manager and detaches it from the view. (Inherited from AdornmentManagerBaseTView.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides AdornmentManagerBaseTViewOnClosed.)
Protected method | OnIsActiveChanged | Occurs when the IsActive property changes. (Inherited from AdornmentManagerBaseTView.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag) Constructor

DecorationAdornmentManagerBaseTView, TTag Constructor
Overload List
 | Name | Description
Protected method | DecorationAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition) | Initializes a new instance of the DecorationAdornmentManagerBase class.
Protected method | DecorationAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition, Boolean) | Initializes a new instance of the DecorationAdornmentManagerBase class.
Top
See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag) Constructor (TView, AdornmentLayerDefinition)

DecorationAdornmentManagerBaseTView, TTag Constructor (TView, AdornmentLayerDefinition)
Initializes a new instance of the DecorationAdornmentManagerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DecorationAdornmentManagerBase(
    TView view,
    AdornmentLayerDefinition layerDefinition
)
Protected Sub New (
    view As TView,
    layerDefinition As AdornmentLayerDefinition
)

Parameters

view
Type: TView
The view to which this manager is attached.
layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The AdornmentLayerDefinition indicating which adornment layer to use.
See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
DecorationAdornmentManagerBaseTView, TTag Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag) Constructor (TView, AdornmentLayerDefinition, Boolean)

DecorationAdornmentManagerBaseTView, TTag Constructor (TView, AdornmentLayerDefinition, Boolean)
Initializes a new instance of the DecorationAdornmentManagerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected DecorationAdornmentManagerBase(
    TView view,
    AdornmentLayerDefinition layerDefinition,
    bool isForLanguage
)
Protected Sub New (
    view As TView,
    layerDefinition As AdornmentLayerDefinition,
    isForLanguage As Boolean
)

Parameters

view
Type: TView
The view to which this manager is attached.
layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The AdornmentLayerDefinition indicating which adornment layer to use.
isForLanguage
Type: SystemBoolean
Indicates whether this adornment manager is for a language. If true, the adornment manager is closed when the language or document within a SyntaxEditor changes.
See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
DecorationAdornmentManagerBaseTView, TTag Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag) Properties

DecorationAdornmentManagerBaseTView, TTag Properties

The DecorationAdornmentManagerBaseTView, TTag generic type exposes the following members.

Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager. (Inherited from AdornmentManagerBaseTView.)
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event. (Inherited from AdornmentManagerBaseTView.)
Public property | View | Gets the view to which this manager is attached. (Inherited from AdornmentManagerBaseTView.)
Top
See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag) Methods

DecorationAdornmentManagerBaseTView, TTag Methods

The DecorationAdornmentManagerBaseTView, TTag generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddAdornment |
Public method | Close | Closes the manager and detaches it from the view. (Inherited from AdornmentManagerBaseTView.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides AdornmentManagerBaseTViewOnClosed.)
Protected method | OnIsActiveChanged | Occurs when the IsActive property changes. (Inherited from AdornmentManagerBaseTView.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag).AddAdornment Method

DecorationAdornmentManagerBaseTView, TTagAddAdornment Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.DecorationAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void AddAdornment(
    ITextViewLine viewLine,
    TagSnapshotRange<TTag> tagRange,
    TextBounds bounds
)
Protected MustOverride Sub AddAdornment (
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of TTag),
    bounds As TextBounds
)

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextViewLine

[Missing <param name="viewLine"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.DecorationAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange TTag

[Missing <param name="tagRange"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.DecorationAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

bounds
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

[Missing <param name="bounds"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.DecorationAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


DecorationAdornmentManagerBase(TView, TTag).OnClosed Method

DecorationAdornmentManagerBaseTView, TTagOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
Remarks
Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

DecorationAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag) Class

IntraTextAdornmentManagerBaseTView, TTag Class
Provides a helpful base class for implementing an adornment manager that displays adornments in intra-text spacers.
Inheritance Hierarchy
SystemObject
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationAdornmentManagerBase TView
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.ImplementationIntraTextAdornmentManagerBaseTView, TTag

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public abstract class IntraTextAdornmentManagerBase<TView, TTag> : AdornmentManagerBase<TView>
where TView : ITextView
where TTag : IIntraTextSpacerTag

Public MustInherit Class IntraTextAdornmentManagerBase(Of TView As ITextView, TTag As IIntraTextSpacerTag)
    Inherits AdornmentManagerBase(Of TView)

Type Parameters

TView
The type of ITextView to support. Use ITextView to support all text view types.
TTag
The type of IIntraTextSpacerTag to aggregate.

The IntraTextAdornmentManagerBaseTView, TTag type exposes the following members.

Constructors
 | Name | Description
Protected method | IntraTextAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition) | Initializes a new instance of the IntraTextAdornmentManagerBase class.
Protected method | IntraTextAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition, Boolean) | Initializes a new instance of the IntraTextAdornmentManagerBase class.
Top
Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager. (Inherited from AdornmentManagerBaseTView.)
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event. (Inherited from AdornmentManagerBaseTView.)
Public property | View | Gets the view to which this manager is attached. (Inherited from AdornmentManagerBaseTView.)
Top
Methods
 | Name | Description
Protected method | AddAdornment |
Public method | Close | Closes the manager and detaches it from the view. (Inherited from AdornmentManagerBaseTView.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides AdornmentManagerBaseTViewOnClosed.)
Protected method | OnIsActiveChanged | Occurs when the IsActive property changes. (Inherited from AdornmentManagerBaseTView.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag) Constructor

IntraTextAdornmentManagerBaseTView, TTag Constructor
Overload List
 | Name | Description
Protected method | IntraTextAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition) | Initializes a new instance of the IntraTextAdornmentManagerBase class.
Protected method | IntraTextAdornmentManagerBaseTView, TTag(TView, AdornmentLayerDefinition, Boolean) | Initializes a new instance of the IntraTextAdornmentManagerBase class.
Top
See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag) Constructor (TView, AdornmentLayerDefinition)

IntraTextAdornmentManagerBaseTView, TTag Constructor (TView, AdornmentLayerDefinition)
Initializes a new instance of the IntraTextAdornmentManagerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IntraTextAdornmentManagerBase(
    TView view,
    AdornmentLayerDefinition layerDefinition
)
Protected Sub New (
    view As TView,
    layerDefinition As AdornmentLayerDefinition
)

Parameters

view
Type: TView
The view to which this manager is attached.
layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The AdornmentLayerDefinition indicating which adornment layer to use.
See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
IntraTextAdornmentManagerBaseTView, TTag Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag) Constructor (TView, AdornmentLayerDefinition, Boolean)

IntraTextAdornmentManagerBaseTView, TTag Constructor (TView, AdornmentLayerDefinition, Boolean)
Initializes a new instance of the IntraTextAdornmentManagerBase class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected IntraTextAdornmentManagerBase(
    TView view,
    AdornmentLayerDefinition layerDefinition,
    bool isForLanguage
)
Protected Sub New (
    view As TView,
    layerDefinition As AdornmentLayerDefinition,
    isForLanguage As Boolean
)

Parameters

view
Type: TView
The view to which this manager is attached.
layerDefinition
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.AdornmentsAdornmentLayerDefinition
The AdornmentLayerDefinition indicating which adornment layer to use.
isForLanguage
Type: SystemBoolean
Indicates whether this adornment manager is for a language. If true, the adornment manager is closed when the language or document within a SyntaxEditor changes.
See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
IntraTextAdornmentManagerBaseTView, TTag Overload
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag) Properties

IntraTextAdornmentManagerBaseTView, TTag Properties

The IntraTextAdornmentManagerBaseTView, TTag generic type exposes the following members.

Properties
 | Name | Description
Public property | AdornmentLayer | Gets the IAdornmentLayer being managed by this manager. (Inherited from AdornmentManagerBaseTView.)
Public property | IsActive | Gets or sets whether the manager's adornments are currently active, generally based on some option or event. (Inherited from AdornmentManagerBaseTView.)
Public property | View | Gets the view to which this manager is attached. (Inherited from AdornmentManagerBaseTView.)
Top
See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag) Methods

IntraTextAdornmentManagerBaseTView, TTag Methods

The IntraTextAdornmentManagerBaseTView, TTag generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddAdornment |
Public method | Close | Closes the manager and detaches it from the view. (Inherited from AdornmentManagerBaseTView.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnClosed | Occurs when the manager is closed and detached from the view. (Overrides AdornmentManagerBaseTViewOnClosed.)
Protected method | OnIsActiveChanged | Occurs when the IsActive property changes. (Inherited from AdornmentManagerBaseTView.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag).AddAdornment Method

IntraTextAdornmentManagerBaseTView, TTagAddAdornment Method

[Missing <summary> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.IntraTextAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected abstract void AddAdornment(
    ITextViewLine viewLine,
    TagSnapshotRange<TTag> tagRange,
    TextBounds bounds
)
Protected MustOverride Sub AddAdornment (
    viewLine As ITextViewLine,
    tagRange As TagSnapshotRange(Of TTag),
    bounds As TextBounds
)

Parameters

viewLine
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorITextViewLine

[Missing <param name="viewLine"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.IntraTextAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

tagRange
Type: ActiproSoftware.Text.TaggingTagSnapshotRange TTag

[Missing <param name="tagRange"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.IntraTextAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

bounds
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditorTextBounds

[Missing <param name="bounds"/> documentation for "M:ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation.IntraTextAdornmentManagerBase`2.AddAdornment(ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.ITextViewLine,ActiproSoftware.Text.Tagging.TagSnapshotRange{`1},ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.TextBounds)"]

See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


IntraTextAdornmentManagerBase(TView, TTag).OnClosed Method

IntraTextAdornmentManagerBaseTView, TTagOnClosed Method
Occurs when the manager is closed and detached from the view.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
protected override void OnClosed()
Protected Overrides Sub OnClosed
Remarks
Overrides should release any event handlers set up in the manager's constructor.
See Also

Reference

IntraTextAdornmentManagerBaseTView, TTag Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Adornments.Implementation Namespace


ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace
Contains automation peer classes that support UI automation for the product.
Classes
 | Class | Description
Public class | CollapsedRegionAdornmentAutomationPeer | Exposes CollapsedRegionAdornment types to UI Automation.
Public class | EditorIndicatorMarginAutomationPeer | Exposes EditorIndicatorMargin types to UI Automation.
Public class | EditorLineNumberMarginAutomationPeer | Exposes EditorLineNumberMargin types to UI Automation.
Public class | EditorOutliningMarginAutomationPeer | Exposes EditorOutliningMargin types to UI Automation.
Public class | EditorSelectionMarginAutomationPeer | Exposes EditorSelectionMargin types to UI Automation.
Public class | EditorViewAutomationPeer | Exposes EditorView types to UI Automation.
Public class | EditorWordWrapGlyphMarginAutomationPeer | Exposes EditorWordWrapGlyphMargin types to UI Automation.
Public class | IntelliPromptCompletionListAutomationPeer | Exposes IntelliPromptCompletionList types to UI Automation.
Public class | IntelliPromptParameterInfoAutomationPeer | Exposes IntelliPromptParameterInfo types to UI Automation.
Public class | IntelliPromptQuickInfoAutomationPeer | Exposes IntelliPromptQuickInfo types to UI Automation.
Public class | SyntaxEditorAutomationPeer | Exposes SyntaxEditor types to UI Automation.


CollapsedRegionAdornmentAutomationPeer Class

CollapsedRegionAdornmentAutomationPeer Class
Exposes CollapsedRegionAdornment types to UI Automation.
Inheritance Hierarchy
SystemObject
Windows.UI.XamlDependencyObject
Windows.UI.Xaml.Automation.PeersAutomationPeer
Windows.UI.Xaml.Automation.PeersFrameworkElementAutomationPeer
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.PeersCollapsedRegionAdornmentAutomationPeer

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public class CollapsedRegionAdornmentAutomationPeer : FrameworkElementAutomationPeer
Public Class CollapsedRegionAdornmentAutomationPeer
    Inherits FrameworkElementAutomationPeer

The CollapsedRegionAdornmentAutomationPeer type exposes the following members.

Constructors
 | Name | Description
Public method | CollapsedRegionAdornmentAutomationPeer | Initializes a new instance of the CollapsedRegionAdornmentAutomationPeer class.
Top
Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
Methods
 | Name | Description
Public method | ClearValue | Clears the local value of a dependency property. (Inherited from DependencyObject.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetAcceleratorKey | Gets the accelerator key combinations for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAcceleratorKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAcceleratorKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAccessKey | Gets the access key for the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAccessKeyCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetAccessKey or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetAnimationBaseValue | Returns any base value established for a dependency property, which would apply in cases where an animation is not active. (Inherited from DependencyObject.)
Public method | GetAnnotations | (Inherited from AutomationPeer.)
Protected method | GetAnnotationsCore | (Inherited from AutomationPeer.)
Public method | GetAutomationControlType | Gets the control type for the element that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationControlTypeCore | Gets the control type for the element that is associated with the UI Automation peer. (Overrides AutomationPeerGetAutomationControlTypeCore.)
Public method | GetAutomationId | Gets the AutomationId of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetAutomationIdCore | Gets the ID of the object that is associated with the automation peer. (Overrides AutomationPeerGetAutomationIdCore.)
Public method | GetBoundingRectangle | Gets the Rect object that represents the screen coordinates of the element that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetBoundingRectangleCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetBoundingRectangle or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetChildren | Gets the collection of child elements that are represented in the UI Automation tree as immediate child elements of the automation peer. (Inherited from AutomationPeer.)
Protected method | GetChildrenCore | Returns the child UI Automation peers. (Overrides AutomationPeerGetChildrenCore.)
Public method | GetClassName | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Inherited from AutomationPeer.)
Protected method | GetClassNameCore | Gets a name that is used with AutomationControlType, to differentiate the control that is represented by this AutomationPeer. (Overrides AutomationPeerGetClassNameCore.)
Public method | GetClickablePoint | Gets a point on the element that is associated with the automation peer that responds to a mouse click. (Inherited from AutomationPeer.)
Protected method | GetClickablePointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetClickablePoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetControlledPeers | Provides the peer's behavior when a Microsoft UI Automation client calls GetControlledPeers or an equivalent Microsoft UI Automation client API such as getting a property value as identified by UIA_ControllerForPropertyId. (Inherited from AutomationPeer.)
Protected method | GetControlledPeersCore | Gets a list of the controlled peers for the current automation peer. (Inherited from AutomationPeer.)
Protected method | GetDescribedByCore | (Inherited from AutomationPeer.)
Public method | GetElementFromPoint | (Inherited from AutomationPeer.)
Protected method | GetElementFromPointCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsFromCore | (Inherited from AutomationPeer.)
Protected method | GetFlowsToCore | (Inherited from AutomationPeer.)
Public method | GetFocusedElement | (Inherited from AutomationPeer.)
Protected method | GetFocusedElementCore | (Inherited from AutomationPeer.)
Public method | GetFullDescription | (Inherited from AutomationPeer.)
Protected method | GetFullDescriptionCore | (Inherited from AutomationPeer.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetHelpText | Gets text that describes the functionality of the control that is associated with the automation peer. (Inherited from AutomationPeer.)
Protected method | GetHelpTextCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetHelpText or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetItemStatus | Gets text that conveys the visual status of the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetItemStatusCore | Gets text that conveys the visual status of the object that is associated with this automation peer. (Overrides AutomationPeerGetItemStatusCore.)
Public method | GetItemType | Gets a string that describes what kind of item an element represents. (Inherited from AutomationPeer.)
Protected method | GetItemTypeCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetItemType or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLabeledBy | Gets the AutomationPeer for the UIElement that is targeted to the element. (Inherited from AutomationPeer.)
Protected method | GetLabeledByCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLabeledBy or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetLevel | (Inherited from AutomationPeer.)
Protected method | GetLevelCore | (Inherited from AutomationPeer.)
Public method | GetLiveSetting | Gets the live setting notification behavior information for the object that is associated with the UI Automation peer. (Inherited from AutomationPeer.)
Protected method | GetLiveSettingCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetLiveSetting or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetLocalizedControlType | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | GetLocalizedControlTypeCore | Gets a localized string that represents the AutomationControlType value for the control that is associated with this automation peer. (Overrides AutomationPeerGetLocalizedControlTypeCore.)
Public method | GetLocalizedLandmarkType | (Inherited from AutomationPeer.)
Protected method | GetLocalizedLandmarkTypeCore | (Inherited from AutomationPeer.)
Public method | GetName | Gets text that describes the element that is associated with this automation peer. The Microsoft UI Automation Name value is the primary identifier used by most assistive technology when they represent your app's UI by interacting with the Microsoft UI Automation framework. (Inherited from AutomationPeer.)
Protected method | GetNameCore | Gets the value that the automation peer reports as the UI Automation name for the associated control. (Overrides AutomationPeerGetNameCore.)
Public method | GetOrientation | Gets a value that indicates the explicit control orientation, if any. (Inherited from AutomationPeer.)
Protected method | GetOrientationCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetOrientation or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetParent | Gets the AutomationPeer that is the parent of this AutomationPeer. (Inherited from AutomationPeer.)
Public method | GetPattern | Gets the control pattern that is associated with the specified PatternInterface. (Inherited from AutomationPeer.)
Protected method | GetPatternCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPattern or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPeerFromPoint | Gets an AutomationPeer from the specified point. (Inherited from AutomationPeer.)
Protected method | GetPeerFromPointCore | Provides the peer's behavior when a Microsoft UI Automation client calls GetPeerFromPoint or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | GetPositionInSet | (Inherited from AutomationPeer.)
Protected method | GetPositionInSetCore | (Inherited from AutomationPeer.)
Public method | GetSizeOfSet | (Inherited from AutomationPeer.)
Protected method | GetSizeOfSetCore | (Inherited from AutomationPeer.)
Public method | GetType | (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property from a DependencyObject. (Inherited from DependencyObject.)
Public method | HasKeyboardFocus | Gets a value that indicates whether the element that is associated with this automation peer currently has keyboard focus. (Inherited from AutomationPeer.)
Protected method | HasKeyboardFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls HasKeyboardFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | InvalidatePeer | Triggers recalculation of the main properties of the AutomationPeer and raises the PropertyChanged notification to the automation client if the properties have changed. (Inherited from AutomationPeer.)
Public method | IsContentElement | Gets a value that indicates whether the element that is associated with this automation peer contains data that is presented to the user. (Inherited from AutomationPeer.)
Protected method | IsContentElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsContentElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsControlElement | Gets a value that indicates whether the element is understood by the user as interactive or as contributing to the logical structure of the control in the GUI. (Inherited from AutomationPeer.)
Protected method | IsControlElementCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsControlElement or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsDataValidForForm | (Inherited from AutomationPeer.)
Protected method | IsDataValidForFormCore | (Inherited from AutomationPeer.)
Public method | IsEnabled | Gets a value that indicates whether the element associated with this automation peer supports interaction. (Inherited from AutomationPeer.)
Protected method | IsEnabledCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsEnabled or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsKeyboardFocusable | Gets a value that indicates whether the element can accept keyboard focus. (Inherited from AutomationPeer.)
Protected method | IsKeyboardFocusableCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsKeyboardFocusable or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsOffscreen | Gets a value that indicates whether an element is off the screen. (Inherited from AutomationPeer.)
Protected method | IsOffscreenCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsOffscreen or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPassword | Gets a value that indicates whether the element contains sensitive content. (Inherited from AutomationPeer.)
Protected method | IsPasswordCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsPassword or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | IsPeripheral | (Inherited from AutomationPeer.)
Protected method | IsPeripheralCore | (Inherited from AutomationPeer.)
Public method | IsRequiredForForm | Gets a value that indicates whether the element that is associated with this peer must be completed on a form. (Inherited from AutomationPeer.)
Protected method | IsRequiredForFormCore | Provides the peer's behavior when a Microsoft UI Automation client calls IsRequiredForForm or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Navigate | (Inherited from AutomationPeer.)
Protected method | NavigateCore | (Inherited from AutomationPeer.)
Protected method | PeerFromProvider | Gets an AutomationPeer for the specified IRawElementProviderSimple proxy. (Inherited from AutomationPeer.)
Protected method | ProviderFromPeer | Gets the IRawElementProviderSimple proxy for the specified AutomationPeer. (Inherited from AutomationPeer.)
Public method | RaiseAutomationEvent | Raises an automation event. (Inherited from AutomationPeer.)
Public method | RaisePropertyChangedEvent | Raises an event to notify the automation client of a changed property value. (Inherited from AutomationPeer.)
Public method | RaiseStructureChangedEvent | (Inherited from AutomationPeer.)
Public method | RaiseTextEditTextChangedEvent | (Inherited from AutomationPeer.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if a local value is set. (Inherited from DependencyObject.)
Public method | RegisterPropertyChangedCallback | (Inherited from DependencyObject.)
Public method | SetFocus | Sets the keyboard focus on the element that is associated with this automation peer. (Inherited from AutomationPeer.)
Protected method | SetFocusCore | Provides the peer's behavior when a Microsoft UI Automation client calls SetFocus or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | SetParent | (Inherited from AutomationPeer.)
Public method | SetValue | Sets the local value of a dependency property on a DependencyObject. (Inherited from DependencyObject.)
Public method | ShowContextMenu | Shows the available context menu for the owner element. (Inherited from AutomationPeer.)
Protected method | ShowContextMenuCore | Provides the peer's behavior when a Microsoft UI Automation client calls ShowContextMenu or an equivalent Microsoft UI Automation client API. (Inherited from AutomationPeer.)
Public method | ToString | (Inherited from Object.)
Public method | UnregisterPropertyChangedCallback | (Inherited from DependencyObject.)
Top
See Also

Reference

ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer Constructor

CollapsedRegionAdornmentAutomationPeer Constructor
Initializes a new instance of the CollapsedRegionAdornmentAutomationPeer class.

Namespace: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers
Assembly: AS.SyntaxEditor.Universal (in AS.SyntaxEditor.Universal.dll) Version: 17.1.310.0
Syntax
C#
VB
Copy
public CollapsedRegionAdornmentAutomationPeer(
    CollapsedRegionAdornment owner
)
Public Sub New (
    owner As CollapsedRegionAdornment
)

Parameters

owner
Type: ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.PrimitivesCollapsedRegionAdornment
The owner element.
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace


CollapsedRegionAdornmentAutomationPeer Properties

CollapsedRegionAdornmentAutomationPeer Properties

The CollapsedRegionAdornmentAutomationPeer type exposes the following members.

Properties
 | Name | Description
Public property | Dispatcher | Gets the CoreDispatcher that this object is associated with. (Inherited from DependencyObject.)
Public property | EventsSource | Gets or sets an AutomationPeer that is reported to the automation client as the source for all the events that come from this AutomationPeer. See Remarks. (Inherited from AutomationPeer.)
Public property | Owner | Gets the UIElement owner that is associated with this FrameworkElementAutomationPeer. (Inherited from FrameworkElementAutomationPeer.)
Top
See Also

Reference

CollapsedRegionAdornmentAutomationPeer Class
ActiproSoftware.UI.Xaml.Controls.SyntaxEditor.Automation.Peers Namespace